"Азбука РС" Дм.Белоусова, вступление

...Ничему нельзя научить,
... всему можно только научиться... 		Моей любимой дочке Татьяне
- предназначается
Персональный компьютер
или
"Азбука PC" для начинающих
Автор рад приветствовать Вас на своих страницах, посвященных азам информационно-коммуникационных технологий - науки, связанной с применением компьютера. Представляю свою небольшую книгу, адресованную:
  • Школьникам средней школы (для уроков информатики и ИКТ);
  • Студентам ВУЗов (помощь к самостоятельной подготовке);
  • Людям любого возраста (делающим первые шаги в освоении ПК);
  • Преподавателям информатики (здесь все и сразу и совсем нет "воды", только суть);
  • Всем пользователям ПК (для создания целостной картины);
Напоминаю, что с 01.09.2002г., согласно распоряжению МинОбразования РФ, в программу средней школы (со второго класса) обязательно включается урок информационно-коммуникационных технологий (ИКТ, минимум 1 урок в неделю). Основные и главные отличия этой книги от множества публикаций (книг, статей, обозрений, etc.):
  1. даны ВСЕ компьютерные азы полностью (это первая подобная публикация в России);
  2. все очень-очень кратко;
  3. выстроена стройная система "who is who";
В основном эта информация адресована совсем начинающим пользователям, но и люди, вроде бы "умеющие щелкать мышкой", найдут для себя немало интересного, ибо работать на ПК и знать его - увы, две абсолютно разные вещи.
Практика показывает, что сведений в объеме этой книги достаточно для того, чтобы пользователь усвоил АЗЫ компьютера ПРАВИЛЬНО. Вся информация не только визуально подана в виде наглядных и простых схем, но и детально прописана и соответственно не должна представлять сложности в восприятии. Тем не менее я все же получаю письма читателей, в которых Вы жалуетесь на обилие названий-терминов ("...тяжело..."). Но помилуйте, рассказать как можно проще - это одно, но рассказать без названий? И вообще, а "...кто сказал, что Вам будет легко?.."
С причинами, из-за которых у автора возникла необходимость в написании этих страниц и с кратким обзором Ваших писем, можно ознакомиться здесь.
Конечно, в специальной технической литературе (книгах, журналах, справочниках и т.п.) конкретные "узкие" темы будут описаны более подробно. Я же стремился заложить правильный базис (основу, фундамент) или говоря русским языком - азбуку: что, из чего и куда. Освоите азбуку - вот тогда и читайте умные книжки. Технически учебник создан в электронном виде для показа через проектор или монитор (в HTML-коде, специально без всяких дизайнерских изысков & аплетов). Гиперссылки позволили:
1. легко сделать перекрестные ссылки;
2. уменьшить объем и увеличить наглядность;
3. избавить файлы от word-овых вирусов;
Внизу каждой страницы Вы найдете небольшое оглавление, позволяющее как последовательно идти по главам, так и читать выборочно. И давайте сразу оговоримся - в этом учебнике Вы
· не найдете по-шаговых описаний "как работать" в какой-либо программе;
· не найдете сравнительных тестов на производительность;
· не найдете советов по настройке системы;
· не найдете схем и инструкций по модернизации & разгону;
и т.д. и т.п. И уж конечно здесь нет рекламы (упаси боже). Это именно азбука - бесплатная таблица умножения для совсем начинающих.
На каждой странице обязательно будет немного компьютерного слэнга, выделенного кавычками (например память - "мозги", материнская плата - "мама"). Для начинающих пользователей эти названия звучат дико, иногда даже пошло. Но они активно используются компьютерщиками в обыденной речи и не упоминать о них было бы неправильно. Для облегчения чтения перед началом каждой главы и кое-где прямо в текст вставлены юмористические фразы и анекдоты о компьютерах. Они выделены цветом, вот так: "... Hе надо очеловечивать компьютеры, они этого страсть как не любят!...". Обращаю внимание, что все эти фразы рассчитаны на людей, имеющих чувство юмора (остальным же рекомендуется эти анекдоты не читать).
Обращаю Ваше внимание на то, что в Internet-e на странице-описании (в окошечке) указана дата модификации учебника - Вы всегда можете скачать более полную новую версию. Поскольку сразу нельзя "объять необъятное", некоторые главы еще не закончены и часть гиперссылок внутри пока еще не работает. Т.е. если Вы щелкнете по такой, пока не работающей, ссылке браузером MS IE, то выскочит пустая страница. Другие (нормальные) браузеры просто покажут, что файла нет. К некоторым, уже написанным главам, планирую вернуться впоследствии повторно - осветить более подробно сложную тему. Ко многим, в том числе уже написанным главам, планирую постоянно возвращаться впоследствии - осветить более подробно сложную тему, заменить картинку и т.п.
Не пытайтесь "проглотить АЗБУКУ". Так Вы только создадите путаницу в голове. Отнеситесь к Азбуке серьезно и не спешите, если хотите получить настоящие знания. Более "продвинутые" друзья-подруги уже принесли Вам эти файлы и щелкнули мышкой на первом...
Вот собственно и все вступление... Прошу:

"Азбука РС"
базовый учебник по информатике
рекомендован здравым смыслом

Данная публикация является некоммерческой. Хотя автор никогда не претендовал на огромную популярность данной книги, он приветствует распространение "Азбуки РС" в печатном и электронном виде при соблюдении четырех условий:

  1. "Азбука РС" распространяется целиком и бесплатно.
  2. "Азбука РС" не подвергается модификации без согласия автора.
  3. "Азбука РС" нельзя использовать в платных и бесплатных учебных курсах, в издании в виде книг, брошюр и статей, размещать материал на коммерческих компакт-дисках и платных сайтах.
  4. "Азбука РС" распространяется с указанием следующих сведений об авторе: имя (Дмитрий Белоусов), e-mail (dmitry@belousov.spb.su), город (Санкт-Петербург)
Нарушение данных условий является нарушением закона РФ об авторском праве и карается согласно статье Административного кодекса РФ. Любое отступление от указанных выше условий должно быть предварительно обсуждено с автором.

Успехов Вам и Вашим близким!

© Dmitry Belousov
http://www.orakul.spb.ru
ноябрь 2001г.-ноябрь 2003г.

[ вступление | оглавление | начало | глоссарий ]


"Азбука РС" Дм.Белоусова, начало

Персональный
компьютер

•

Монитор

Персональный компьютер = ПК
= PC = "писюк"

•

Системный блок

•

Периферия

•

Операционная система

•

Программы

"...Каждый может работать на компьютере. А может этого и не делать - результат не изменится ..."

· Хронология изобретений или история создания:
  • 1907 год: русский ученый Борис Розинг (г.Санкт-Петербург) патентует электронно-лучевую трубку;
  • 1918 год: инженеры Абрахам и Блох разрабатывают калькулятор, оперирующий с двоичными числами;
  • 1936 год: английский математик Алан Тьюринг закончил работу "О вычислительных числах", с описанием механического устройства "универсальная машина";
  • 1937 год: в Bell Telephone Labaratories инженер Джордж Стибитц построил первую вычислительную машину на основе двоичной системы счисления;
  • 1938 год: немецкий инженер Конрад Цузе разработал механическую цифровую программируемую машину Z1. Модель была пробной и в практической работе не использовалась;
  • 1959 год: "Digital Equipment Corporation" создала пра-образ мини-компьютера
  • 1961 год: корпорация "Fairchild" создала первую коммерческую интегральную схему;
  • 1964 год: инженер Пьер-Карл Перотто (1931-2002), работавший конструктором в фирме "Оливетти", сконструировал "Программу-101" - опытный образец первого настольного компьютера. Вскоре компания "Hewlett Packard" за миллион долларов выкупила патенты некоторых важнейших узлов. Перотто считается изобретателем ПК;
  • 1965 год: "DEC" создал первый мини-компьютер (имеющий габариты холодильника) и цену ~$20.000;
  • 1970 год: Дуглас Энгельбарт (Douglas Engelbart) в "Augmentation Research Center" придумал первый многооконный интерфейс пользователя;
  • 1972 год: "MITS" (Micro Instrumentation and Telemetry Systems) предложил первый цифровой микро-компьютер, доступный для персонального использования;
  • 1973 год: лаборатория фирмы "Xerox" (в Пало-Альто) впервые выпустила компьютер, укомплектованный монитором;
  • 1974 год: Джонатан Титус (Jonathan Titus) предложил на продажу комплект для сборки ПК, а в мартовском журнале "QST" вышла первая реклама ПК в прессе;
  • 1975 год: начались продажи серийно произведенного ПК Аltair 8800" (разработчики Эдвард Робертс (Edward Roberts), Вильям Ятес (William Yates) и Джим Байби (Jim Вуbее));
  • 1976 год: появился первый продаваемый (чрезвычайно успешно!) ПК - "Apple" (будущий "Macintosh", разработчики Стив Джобс (Steve Jobs) и Стив Возняк (Steve Wozniak));
  • 12 августа 1981 года (спустя пять лет) компания "IBM" представила свой IBM Personal Сomputer. Первоначально IBM PC (модель 5150) имел процессор Intel 8088, 16 Кбайт стандартной оперативной памяти на материнской плате (расширяемой до 64 Кбайт) и до 540 Кбайт возможного общего количества памяти (a не 640 Кбайт из-за аппаратной ошибки); имел одноцветный TTL-монитор (модель 5151); монохромный графический адаптер с параллельным портом для принтера; поспедовательный порт; два пятидюймовых дисковода для гибких дискет на 360 Кбайт; OS PC-DOS v1.1. Вскоре другие изготовители быстро наладили производство жестких дисков;
  • ... ... ...
  • апрель 2002 года: по данным аналитической компании Gartner Dataquest (США), 27 лет спустя после начала поставок первого массового персонального компьютера Altair, в мире продан 1.000.000.0000 (миллиардный) персональный компьютер;

· Сегментация: к концу XX века на рынке настольных компьютеров сложились и сейчас имеются четыре уровня РС:

  • Сервера и мощные рабочие станции (Personal Workstations). Предназначены для выполнения задач, требующих большого объема вычислений либо интенсивного обмена информацией с внешними устройствами.
  • Персональные компьютеры (Personal System). Предназначены для индивидуальной (рутинной) работы-игр дома или в офисе.
  • Сетевые компьютеры (Network Computers) и NetPC. Предназначены для коллективной работы в системах, ориентированных на сервер, а также для индивидуальной работы в сети.
  • Терминалы (Network Appliances). В 20 веке имели строго фиксированный набор функций, теперь превратились в интеллектуальные "сетевые устройства".

         "... Вот представь: у тебя есть 1000 рублей... Или, для круглого счета, пусть 1024 ..."

8 бит (bit) = 1 байт (b, byte)
1024 байт = 1 килобайт (Kb)
1024 килобайта = 1 мегабайт (Mb)
1024 мегабайта = 1 гигабайт (Гб)
1024 гигабайта = 1 терабайт (Tb)
1024 терабайта = 1 петабайт (Пб)
1024 петабайта = 1 экзабайт (Эб)
1024 экзабайта = 1 зеттабайт (Зб)
1024 зеттабайта = 1 йоттабайт (Йб) 		1073741824 килобайт = терабайт
134217728 килобайт = терабит
1048576 килобайт = гигабайт
131072 килобайт = гигабит
8388608 бит = мегабайт
8 мегабит = мегабайт
131072 байт = мегабит
128 килобайт = мегабит
8192 бит = килобайт
8 килобит = килобайт
1024 бит = килобит

© Dmitry Belousov
http://www.orakul.spb.ru
ноябрь 2001г.-июнь 2002г.

[ оглавление | начало | следующая глава | глоссарий ]


"Азбука РС" Дм.Белоусова, мониторы

Мониторы

•

Электронно-лучевые
• с теневой маской
• с щелевой маской
• с апертурной решеткой
монитор = дисплей = экран = "очко" = "фонарь"

•

Жидкокристаллические ( LCD display )

•

Газо-плазменные ( plasma display )

•

Сенсорные экраны ( sensor display )
Конфиденциальный монитор

•

Перспективные display (FED-, LEP-, LED-, ЭЛ-,
VF-, чернила, нанотрубки, плоскопанельные, DLP-)
Монитор для слепых

•

Вращающиеся проекторы

Монитор - устройство визуального отображения информации (в виде текста, таблиц, рисунков, чертежей и др.). Каждый монитор имеет свой определенный срок службы, который в среднем составляет пять лет. От выбора монитора напрямую зависит, как он будет влиять на Ваше зрение. Существует несколько стандартов безопасности монитора:

[ TCO 92 ] [ TCO 95 ] [ TCO 99 ] [ TUV ] [ CE ] [ MPR-II ] [ DPMS ] [ Nutek ] [ FCC-B ] [ VDE-B ] [ CISPR22B ] [ VCCI ] [ UL ] [ CSA ] [ ISO9241 ] [ SCAN ] [ EPA EnergyStar ]
У одной фирмы-производителя мониторов может быть несколько зарегистрированных торговых марок. Марки:
[ ADI ] [ Acana ] [ Acer ] [ Apple ] [ Barco ] [ BenQ ] [ Belinea ] [ BLISS ] [ CTX ] [ Compaq ] [ Daewoo ] [ Daytek ] [ Eizo Nanao ] [ ELSA ] [ Foled ] [ Funai ] [ Greenwood ] [ HP ] [ Hitachi ] [ Hyundai ] [ Iiyama ] [ LaCie ] [ LG ] [ MAG Innovision ] [ MAXDATA ] [ Mitsubishi ] [ NEC ] [ Nokia ] [ 0ptiQuest ] [ Packard Bell ] [ Panasonic ] [ Philips ] [ Radius ] [ Samsung ] [ Scott ] [ Sony ] [ TVM ] [ Targa ] [ Techmedia ] [ Toshiba ] [ ViewSonic ]
* - торговая марка Acer принадлежит компании "Benq" (бывш. "Acer Communications")
Монитор в среднем занимает треть стоимости ПК и не подлежит апгрейду. Обычный срок гарантии - 3 года. Для теста лучше всего воспользоваться программой "Nokia Monitor Test". Параметы:

· Размер монитора определяется диагональю экрана. В ЭЛТ действительный размер изображения меньше на 1 дюйм. При выборе большого монитора у Вас, прежде всего, значительно увеличивается рабочая площадь на экране. Но диагональ экрана нужно рассматривать вместе с разрешением и разверткой (другими параметрами).

ЭЛТ: | [ 14" ] [ 15" ] [ 17" ] [ 19" ] [ 21" ] [ 22"* ]
LCD: | [ 10,1" ] [ 12,1" ] [ 14" ] [ 14,1" ] [ 15" ] [ 15,1" ] [ 15,4" ] [ 15,7" ] [ 16" ] [ 17" ] [ 17,1" ] [ 17,4" ] [ 17,5" ] [ 18" ] [ 18,1" ] [ 19" ] [ 19,6" ] [ 20" ] [ 20,1" ] [ 21,3" ] [ 22,2" ] [ 23" ] [ 23,1" ] [ 24" ] [ 30" ] [ 42" ] [ 46" ] [ 52" ]
Plasma: | [ 40" ] [ 42" ] [ 44" ] [ 46" ] [ 48" ] [ 50" ]
1 дюйм (inch, 1") = 2,54 см. Сочетание распространенных размеров:
в дюймах: | 14" | 15" | 17" | 19" | 21" | 22"
в см: | ~35,6 см | 38,1 см | ~43,2 см | ~48,3 см | ~53,3 см | ~55,9 см
в дюймах: | 40" | 42" | 44" | 46" | 48" | 50"
в см: | ~101,6 см | ~106,7 см | ~111,8 см | ~116,8 см | ~121,9 см | 127 см
Для комфортной работы с графикой нужно иметь диагональ не меньше, чем 19", а лучше 21". Для ЖК-мониторов указывается диагональ матрицы, которая и является реально видимой.
* - компанией Mistubishi была разработала новая трубка 22", которая предназначена только для модели LaCie electron22blue III и не имеет аналогов. Samsung готовит ЖК-панели размером 1800х2000 мм.

· Разрешение (resolution, разрешающая способность монитора) - это разрешающая способность монитора и частота его кадровой развертки. Разрешение - это количество точек по горизонтали и по вертикали на экране монитора. Например, разрешение 800х600 означает, что изображение на экране состоит из 800 точек горизонтали и 600 точек по вертикали. Увеличение разрешения данного монитора непременно ведет к снижению частоты его кадровой развертки. В рекламе ЭЛТ-мониторов всегда указано максимально возможное разрешение - напр. указано 1280x1024@60. Но при таком разрешении просто нельзя работать из-за низкой частоты кадровой развертки - реально это будет 800x600@85. Самыми популярными разрешениями в 2001 году являлись 800x600 (49.33%) и 1024x768 (41.23%), в 2002 году - те же 800x600 (29.0%) и 1024x768 (53.8%). Применяемые разрешения (из inet-статистики):

[ 3840х2400 ] [ 2560х2048** ] [ 2048х1536* ] [ 1800x1440 ] [ 1600x1280 ] [ 1600x1200 ] [ 1400x1050 ] [ 1280x1024 ] [ 1280x960 ] [ 1280x720 ] [ 1152x864 ] [ 1024x768 ] [ 1024x721 ] [ 960x720 ] [ 800x600 ] [ 800x553 ] [ 720x480 ] [ 640x480 ] [ 640x350 ] [ 320x200 ]
Рабочим разрешением для ЖК-монитора является его максимальное. Меньшие ЖК-разрешения могут поддерживаться двумя путями: изображение меньшего разрешения либо «растягивается» на весь экран (соответственно, повышается его зернистость), либо отображается в своем разрешении, тогда по краям экрана остаются незанятые черные полосы. Т.е. работать с ЖК-монитором нужно в его "родном" разрешении.
В ЭЛТ-мониторах применяется хитрость - через-строчная развертка (Interlased)- для достижения более высокого разрешения. Регенерация экрана идет сначала по нечетным строкам, потом - четным; всю поверхность экрана луч проходит за два цикла кадровой развертки, называемых полукадрами. Это приводит к мерцанию. Пример: один и тот же монитор имеет 1280x1024 при Interlased и 1024x768 при NI (Non-Interlased). Конечно, в рекламе всегда идет максимальное, т.е. Interlaced.
История: в первой системе цветного телевещания (NTSC) принята частота кадров 30 Гц (частота полей - 60 Гц), а количество строк - 525, из которых видимых - 480. При полосе канала яркости 4,5 МГц в строке может быть различимо до 640 пикселов. Вот и появилось 640x480.
* - компанией Mistubishi была разработала новая трубка c максимальным разрешением 2048х1536 точек при частоте 80 Гц, которая предназначена только для модели LaCie electron22blue III и не имеет аналогов.
** - экспериментальное;

· Частота кадровой развертки - это количество раз, которое сменится изображение на экране ЭЛТ-монитора за 1 сек. Она измеряется в герцах (Гц, Hz). Этот параметр непосредственно влияет на зрение, т.к. при слишком малой частоте кадровой развертки (меньше 75 Гц) человек визуально ощущает мерцание экрана. Рекомендую частоту не менее 85 Гц.
В ЖК-мониторах управление идет отдельно каждым пикселем, ЭЛТ-проблема с частотой обновления экрана снимается. Важно время отклика пикселя матрицы - время, требуемое пикселю, чтобы поменять цвет. Измеряется в милисекундах (25-40).

· Шаг точки (зерно, пиксель, Pixel Pitch). Измеряется в сотых долях мм. Для ЭЛТ шаг - это расстояние между смежными RGB-группами точек фосфора ("триадами"). Чем меньше зерно, тем больше точек приходится на единицу площади, тем выше разрешение. В рекламе производители указывают горизонтальный шаг точки, который всегда меньше диагонального. Для с теневой маски и решетки шаг измеряется по разному, сравнивать не корректно.
Устаревшие: | [ 0,50 ] [ 0,43 ] [ 0,39 ] [ 0,35 ] [ 0,34 ] [ 0,32 ] [ 0,31 ] [ 0,30 ] [ 0,29 ]
Выпускаемые: | [ 0,28 ] [ 0,27 ] [ 0,26 ] [ 0,25 ] [ 0,24 ] [ 0,22 ] [ 0,19 ] [ 0,18 ]
Существует шаг матрицы зерен экрана (Dot Pitch, зернистость экрана). В первом приближении он совпадает с размером зерна, но это разные параметры. Измеряется в миллиметрах.

· Ширина полосы видеосигнала (полоса пропускания видео-тракта, Video Bandwidth), колеблется в диапазоне 65-220МГц. Она отражает способность монитора включать/выключать каждый пиксель.Чем выше разрешение или частота регенерации, тем выше должна быть ширина полосы частот. Т.е. монитор с разрешением 1024х768 и частотой 85Гц должен иметь шину более 67 МГц: 1024 x 768 x 85 = 66.846.720

· Покрытие экрана (антибликовое покрытие, NB) для ЭЛТ-монитора необходимо для уменьшения блеска стеклянной поверхности экрана и устранения на нем бликов. Пять основных методов обработки поверхности:
· Полировка. Повышенная резкость, но сильно отражает свет.
· Травление. Шершавый экран (воздействие кислоты) позволяет рассеивать внешний свет, но уменьшает резкость. Устарело.
· Кварцевое покрытие. Экран покрывается тонким слоем кремния. Дешевая технология.
· Анти-отражающее покрытие (AR Coating). На поверхность наложены два тонких слоя кремния с различными коэффициентами преломления. Хорошее соотношение цена/качество.
· Анти-отражающая панель (AR-панель). Трехслойный фильтр в виде специальной стеклянной панели на поверхности. Выглядит как темная мелкая сеточка, ее нельзя снять. Это не защитный фильтр! Лучшая, но дорогая технология.
NB - небликующий. На старых моделях ЭЛТ-мониторов днем против света (т.е. монитор напротив окна) работать просто невозможно.

· Сведение лучей (динамическая фокусировка). Регулируется магнитными кольцами системы коррекции сведения. Идеал - все три луча ЭЛТ-монитора ложатся в одну точку на маске. Если сведение невыровнено, луч будет проходить через другое отверстие - цветная "окантовка". Идеального сведения не бывает вследствие трудностей с отклонением лучей на малые углы. Особенно заметно по краям экрана. Обычные значения: 0.3 мм - центр / 0.4 мм - углы. Последние разработки - 0.2 мм. Сведение меняется с течением времени.
В мониторах с цифровой коррекцией экран поделен на блоки (5х5, 8х8) и сведение корректируется для каждого блока. В хороших ЭЛТ-мониторах - есть функция сведения.

· Геометрия изображения для ЭЛТ-монитора. Существует 6 видов искажений: бочкообразные искажения, подушкообразные искажения, параллелограмные искажения, трапециидальные искажения, вертикальная нелинейность, горизонтальная нелинейность.

Хорошая геометрия обязательна для САПР-а, настольных типографий, дизайна, etc. В мониторе с цифровым управлением можно вручную устранить искажения.

· Муар для ЭЛТ-монитора - побочный эффект при улучшении фокусировки. Если луч точно попадает в отверстие теневой маски - данная область экрана более яркая. Хорошо заметен, когда качество фона стоит серый цвет. Устраняется технологией увеличения толшины луча. Желательно, чтобы на мониторе была анти-муарная настройка.

· Low Radiation (LR, Low Radiation Station). ЭЛТ-монитор излучает электромагнитное поле в диапазоне 15-85КГц и 50-90ГЦ. Поэтому иногда применяются специальные электромагниты, замыкающие электромагнитные поля внутри монитора (специальное поглощающее покрытие). Но реально фраза "Low Radiation" ни к чему производителя монитора не обязывает ("пустозвон").

· Плоскоэкранный (Flat Screen, Natural Flat, DynaFlat, Pure Flat) ЭЛТ-монитор. Сначала термин не означал, что кинескоп имеет идеально ровную поверхность. С конца 80-х годов так называли дисплеи, радиус кривизны которых был примерно вдвое меньше, чем у стандартных. Напр. кинескоп Sony Trinitron начала 90-х годов был плоским только по вертикали. Первые Flat Screen - Diamondtron Mitsubishi (1996 год) и LG Pure Flat (1999 год), экран которых был плоским как снаружи, так и изнутри. Но пользователь видел изображение вогнутым (т.к. края под углом и разница величин преломления создает впечатление разной глубины). Для избежания этого сейчас делают внутреннюю поверхность слегка вогнутой.

· Подставка корпуса, дизайн и управление монитора. Монитор может вращаться вокруг вертикальной оси и поворачиваться вокруг горизонтальной (Portrait- и Landspace-направления). Вентиляция должна быть только на вертикальных плоскостях. Проработка дизайна позволяет уменьшить "глубину" ЭЛТ-монитора. В управлении должно быть память режимов (т.е. запоминание настроек) и наличие фиксатора в среднем положении; в некоторых экранных меню (OSD, On-Screen Display) есть экран подсказок.

Желательно также, чтобы монитор:

  • был полноэкранный (Full Screen), т.е. не имел рамки по границам кинескопа;
  • низкоэнергетичный (Le, Low energy);
  • мог подключать два системных блока;
  • имел настройку линейности;
  • имел автосканирование;
  • имел динамическое формирование луча;
  • имел размагничивание;
  • имел программу калибровки;
  • имел оптимизацию яркости выводимой картинки;
  • регулировал контраст в зависимости от типа выводимого изображения;
  • ..... и т.д.;
Вообще, чем больше возможностей настройки, тем лучше.

         "... Мы тут у Вас монитор приобрели, а он ничего не печатает! ..."
CRT-мониторы - это мониторы, главной частью которых является электронно-лучевая трубка, в которой происходит непрерывная бомбардировка электронами люминесцентного экрана (люминофора, Luminofor) из, как правило, трех электронных пушек разных цветов - зеленого, синего и красного. Бомбардировка происходит через специальную теневую маску, изготавливается из специального железоникелевого сплава (инвара). Различают три вида теневых масок: теневая маска (shadow mask), щелевая маска (slot mask, по сути дела, тоже является теневой) и апертурная решетка (Aperture Grill). Теневая маска представляет собой очень тонкую и прозрачную металлическую сетку с множеством отверстий, которые и служат для прохождения электронов. Решетка представляет собой очень тонкий лист фольги с вертикально нанесенными прозрачными штрихами, которые направляют поток электронов в нужном направлении. Щелевая маска - это смешанная технология. Апертурная решетка проводит больше света, чем теневая маска, поэтому цвета на экране получаются более сочными и насыщенными. У мониторов с решеткой меньше вероятность появления муара (различных пятен и помутнений). Но горизонтальные полосы решетки (damper wire, их две) хорошо видны при работе, хуже сведение лучей, мониторы менее устойчивы к механическим воздействиям (дрожь). С апертурной решеткой производятся трубки Sony Trinitron и Mitsubishi Diamondtron; с теневой маской - Hitachi, Panasonic, Samsung, Daewoo, LG, Nokia, Viewsonic; с щелевой маской - фирмы NEC.
ЭЛТ-монитор имеет срок службы, который в среднем составляет пять лет эксплуатации. После на экране монитора могут потускнеть цвета или появиться различные пятна, искажения изображения и другие дефекты, которые могут привести как к некомфортной работе, так и к порче зрения. Я настоятельно рекомендую не покупать подержанные мониторы. При выборе дайте ЭЛТ-монитору поработать (минут 20), так как дефекты у монитора проявляются не сразу, а только после того, как он нагреется.
Несмотря на резкое падение цен на жидкокристаллические мониторы, для амбициозных пользователей (профессионалов графики, геймеров, видеоманов) альтернативы электронно-лучевой трубке пока нет. Но и стоит CRT-профи-монитор очень дорого.

         "... с возрастом растут две вещи - живот и диагональ монитора..."

Дисплеи на жидкокристаллических панелях LSD (Liquid Crystal Display, LCD-, LCD Monitors, жидкокристаллические, ЖК-, TFT-). Жидкие кристаллы старше ЭЛТ почти на 10 лет, первое описание этих веществ было сделано еще в 1888г. австрийским ученым Ф.Ренитцером, но только в 1930-м исследователи из британской корпорации "Marconi" получили патент на их промышленное применение. Прорыв совершили Фергесон (Fergason) и Вильямс (Williams) из корпорации RCA (Radio Corporation of America), создав на базе жидких кристаллов термодатчик. В конце 1966г. корпорация "RCA" продемонстрировала прототип LCD-монитора – цифровые часы. В октябре 1975 г. по технологии TN LCD были изготовлены первые компактные цифровые часы. Во второй половине 70-х начался переход от восьмисегментных жидкокристаллических индикаторов к производству матриц с адресацией каждой точки. Так, в 1976 г. Sharp выпустила черно-белый телевизор с диагональю экрана 5,5 дюйма, выполненного на базе LCD-матрицы разрешением 160х120 пикселов. Но промышленно впервые ЖК-мониторы стали применяться только в ноутбуках.
Принцип получения изображения основан на том, что жидкие кристаллы способны менять свою ориентацию в пространстве под действием света и тем самым изменять свойства данного светового луча. Тонкий слой вещества из жидких кристаллов пропускает свет или препятствует его прохождению, множество мельчайших ячеек, выполненных из этого вещества, позволяют управлять каждой точкой изображения. LCD монитор имеет несколько слоев, где ключевую роль играют две панели, сделанные из свободного от натрия и очень чистого стеклянного материала, называемого субстрат или подложка, которые собственно и содержат тонкий слой жидких кристаллов между собой [см. рис. 2.1]. На панелях имеются бороздки, которые направляют кристаллы, сообщая им специальную ориентацию. Бороздки расположены таким образом, что они параллельны на каждой панели, но перпендикулярны между двумя панелями. Соприкасаясь с бороздками, молекулы в жидких кристаллах ориентируются одинаково во всех ячейках. Подача электрического сигнала на индивидуальные электроды происходит через тонкопленочные транзисторы - TFT (Thin Film Transistors). Технология называется TN TFT или TN+Film TFT (Twisted Nematic + Film). Термин Film обозначает дополнительное наружное пленочное покрытие, позволяющее увеличить угол обзора со стандартных 90 градусов (по 45 с каждой стороны) до приблизительно 140 градусов. В первых TFT-дисплеях, появившихся в 1972г., использовался селенид кадмия, обладающий высокой подвижностью электронов и поддерживающий высокую плотность тока, но со временем был осуществлен переход на аморфный кремний (a-Si), а в матрицах с высоким разрешением используется поликристаллический кремний (p-Si). в случае отказа транзистора на экране образуется посторонняя "мертвая" яркая точка ("битый пиксель").

Частично LCD-недостатки исправляют новые разработки. Есть технология Super-TFT или IPS (In-Plane Switching), разработанная компанией Hitachi. IPS позволила расширить угол обзора до примерно 170 градусов за счет более точного механизма управления ориентацией жидких кристаллов. И есть технология MVA (Multi-Domain Vertical Alignment), разработанная компанией Fujitsu. Это конструкция, в которой все цветовые элементы панели разбиты на ячейки или зоны, образуемые выступами на внутренней поверхности фильтров. Т.о. дана возможность жидким кристаллам двигаться независимо от своих соседей в противоположном направлении и расширяется угол обзора.
Различают типы LCD-дисплеев:
· LCD-мониторы с пассивной матрицей (Passive Matrix). В пассивной матрице на жидкие кристаллы воздействуют поля самих координатных проводников. Устаревшие, ограничен угол обзора пользователя.
· LCD-мониторы c активной матрицей (Active Matrix). В активной матрице каждая ячейка управляется транзистором, которым, в свою очередь, управляют через координатные шины. В активной матрице используются отдельные усилительные элементы для каждой ячейки экрана, компенсирующие влияние емкости ячеек и позволяющие значительно уменьшить время изменения их прозрачности. Active Matrix расширяет угол обзора до 170 градусов.
Панели требуют подсветки - либо задней (Back Light), либо боковой (Side Light).

Параметры LCD мониторов, на которые следует смотреть:

· Яркость (Brightness) ЖК-дисплея определяется яркостью заднего освещения и пропускной способностью панели. Чем выше яркость, тем насыщеннее будет изображение. Измеряется в кд/кв.м (от 170 до 250 cd/m2). Монитор с очень высокой яркостью вполне способен слепить глаза!

· Контрастность показывает соотношение уровней яркости между самым ярким белым и самым темным черным цветами, которые отображает монитор. Чем выше уровень контрастности, тем богаче отображаемая цветовая палитра монитора. От 250:1 до 500:1. Контрастность может измеряться стандартом (напр. по ISO 13406-2) и по собственной методике фирмы. У старых ЖК-дисплеев контрастность менее 300:1.
STN - это сокращение, означающее "Super Twisted Nematic". Технология STN позволяет увеличить торсионный угол (угол кручения) ориентации кристаллов внутри LCD дисплея с 90° до 270°, что обеспечивает лучшую контрастность изображения при увеличении размеров монитора. Часто STN ячейки используются в паре. Такая конструкция называется DSTN (Double Super Twisted Nematic).

· Угол обзора (Viewing Angle). Максимальный угол обзора определяется как угол, при обзоре с которого контрастность изображения уменьшается в 10 раз. Различают углы по цвету и углы по контрасту. Максимум по контрасту = 170°, по цвету = 125°. Обычные цифры рекламы - 160° horizontal и 160° vertical.

· Время рекции пикселя (Response Time, время отклика пикселя матрицы). Самый важный параметр - время, требуемое пикселю для смены цвета. Или время, за которое транзистор успевает изменить пространственную ориентацию молекул жидких кристаллов. Чем он меньше, тем быстрее перестраиваются частицы. Измеряется в милисекундах (25-40 ms).
Производители мониторов по-разному трактуют время отклика. Этот параметр состоит из двух величин – времени на включение пикселя (come-up time), времени на выключение (come-down time). Нужно - суммарное время отклика, но производитель может указать в паспорте среднее время или даже минимальное.
Время отклика напрямую связано с частотой обновления изображения на экране. Справедлива формула:
максимальное число FPS = 1 с / время отклика
Пример: время отклика 25 мс - получается, что частота обновления изображения на данном мониторе ограничена 40 кадрами в секунду (1 / 0.025 = 40).

· Интерфейс передачи видео-сигнала. Обычное подключение монитора - через стандартный VGA-разъем. Но есть DVI - цифровой интерфейс передачи видеосигнала. На видеокартах оснащенных таким интерфейсом обычно два вида коннекторов: DVI-I (совмещающий цифровой и аналоговый сигналы) и DVI-D (только цифровой). "Правильные" LCD-мониторы имеют оба типа коннекторов (и VGA и DVI), на остальных моделях - один старый старый VGA.

Очень большим плюсом LCD-мониторов является их изящный вид и компактное исполнение. У жидкокристаллических мониторов отсутствует мелькание изображения, к тому же ЖК-монитор можно расположить на любом расстоянии от глаз (LCD-монитор никакого воздействия на зрение не оказывает). ЖК-монитор абсолютно плоский и следовательно, отсутствуют искажения. В силу особенностей технологии "зерно" на ЖК-дисплее выглядит гораздо четче. Экран 18-дюймового LCD-монитора соответствует видимой области 21-дюймового ЭЛТ-устройства. Максимальные размеры LCD-экранов, которые выпускаются промышленно, не превышают 40", более идут плазменные дисплеи.
Уже существуют перспективные разработки LCD-мониторов, выполненных по технологии диодов MIM (металл-изолятор-металл), по технологии многослойных ЖК-панелей Super TFT, по технологии Ferroelectric LCD (FLCD, кирально-смектические жидкие кристаллы), по низкотемпературной технологии LTPS.
Кстати, встроенные динамики LCD-монитора уступают даже самым дешевым настольным, а шарнир (для установки экрана в вертикальное положение), хоть и весьма полезен при редактировании документов и web-серфинге, но только для мониторов с очень большим разрешением.

· 3D на ЖК-дисплее. Осенью 2002г. Sharp представила свою версии технологии, обеспечивающей отображение трехмерных картинок на двухмерном экране. Обычно для создания стереоэффекта требуется генерация двух изображений с некоторым сдвигом, одного для восприятия правым и для восприятия левым глазом. Изюминка технологии Sharp заключается в отсутствии каких-либо дополнительных приспособлений (например стерео-очков), требующихся для восприятия трехмерного изображения. Метод создания параллакса - см.рис. Экран Sharp может работать и как обычный, двухмерный дисплей. При этом ход лучей от источника подсветки изменяется, и формирование параллаксного барьера отключается.

· Склеенный ЖК-дисплей. В 2001 году фирма Rainbow Displays представила на InfoComm’2002 первый 37,5-дюймовый ЖК-монитор, получивший название Rainbow Spectrum Model 3750. Его экран склеен из трех отдельных панелей (Philips ЖК-матрицы). Rainbow удалось разработать технологию бесшовной склейки, благодаря которой экран выглядит как единое целое. Можно ожидать, что склеенные ЖК-дисплеи имеют шанс занять нишу между цельными ЖК-мониторами с размерами экрана от 15" до 28" и 42"-50" плазменными панелями.

· Еще интересный факт - "двойня":

По прогнозу DisplaySearch, рынок ЖК-мониторов будет расти примерно по 49% в год и объем его к 2006 году достигнет 113 млн.единиц, а доля ЖК-мониторов по отношению к общему числу мониторов для настольных ПК составит 82%. Уже в 2002 году соотношение продаж мониторов изменяется в пользу ЖК-дисплеев и их доля превысит долю продаж мониторов с ЭЛТ.

         "... подскажите, у меня не получается отправить факс, нажимая кнопку "send" и прикладывая лист к экрану монтора ..."
Плазменные дисплеи (Plasma Display Panel, PDP). Эффект плазмы был открыт в лабораториях Иллинойсского университета в 1966 году. Это свечение газов под воздействием электрического тока (пример - неоновые вывески и лампы дневного света). Разработки дисплеев начались в 1968 году. Первые образцы были монохромными и основывались на принципе газового разряда постоянного тока. Далее был осуществлен переход на технологию разряда переменного тока. Формирование изображения в плазменном дисплее происходит в пространстве шириной примерно 0,1 мм между двумя стеклянными пластинами, заполненном смесью газов (ксенона, неона). На переднюю, прозрачную пластину нанесены тончайшие прозрачные проводники (электроды), а на заднюю – ответные проводники. Задняя стенка имеет микроскопические ячейки, заполненные люминофорами трех основных цветов – красного, синего и зеленого, по три ячейки на каждый пиксель. При разряде смесь газов излучает ультрафиолетовый свет, который воздействует на люминофор, заставляя его светиться в видимом спектре. Плазменные панели очень "прожорливы" (потребляемой мощностью), но не создают магнитных полей (что служит гарантией их безвредности для здоровья), не страдают от вибрации (как ЭЛТ-мониторы), имеют небольшое время отклика (время между посылкой сигнала на изменение яркости пикселя и фактическим изменением), у них отсутствуют напряжение выше 200 вольт (экран практически ничего не излучает), имеют абсолютно плоский экран.

 | угол обзора | яркость "картинки" | контрастность | долговечность
ЭЛТ и/или телевизор | max 120 градусов | max 200 кд/м2 | около 150:1 | 7-10 тысяч часов
плазменные панели | min 160 градусов | min 300 кд/м2 | min 400:1 | 30 тысяч часов
Везде min - т.е. есть "запас прочности" по всем показателям. Фон излучения панели меньше, чем у ЭЛТ-телевизора почти в 20 раз. Плазменные панели "тоньше" 15 сантиметров (и есть тенденция к уменьшению), повышенная яркость и сочность цветов.
Производством плазменных дисплеев занимаются Hitachi (работает в этой области с 1970 года), Fujitsu (является лидером, первые коммерческие модели появились в 1989 году, серия Plasmavision), Sharp, NEC, Toshiba, JVC, Mitsubishi, Sony и Pioneer. У Fujitsu берут готовые панели также Philips, Grundig, Hitachi и Sony. Каждый производитель плазменных панелей добавляет к классической технологии некоторые собственные ноу-хау, улучшающие цветопередачу, контрастность и управляемость. Fujitsu разработала специальную технологию Alternate Lighting of Surfaces (ALiS). Это позволило повысить яркость PDP-экранов до 500 нит, контраст - до 400:1, а угол обзора - до 160 градусов. NEC объединила (1998г.) свою плазменную технологию с электроникой Thomson-а и предлагает технологию капсулированного цветового фильтра (CCF, отсекающего ненужные цвета) и методику повышения контрастности за счет отделения пикселей друг от друга черными полосами. Популярен конструктив Plasma Engine Layout, позволяющий уместить в корпусе дисплея полный ПК. Pioneer использует технологию Encased Cell Structure (увеличение площади люминофорного пятна), новую формулу голубого люминофора (более яркое свечение), технологию суперчеткого отображения, технологию повышения контрастности и удаления "двойного контура", технологию "PureCinema". Sony-Sharp-Philips совместно работают над PALC – жидкокристаллической технологией с плазменной адресацией (позволяет адресовать каждый пиксель дисплея по отдельности, появились в 1998 году). Samsung разработала монитор повышенной управляемости (панель разделена на 44 участка). У Sony существует технология точного вывода изображения Four-Line Vertical Interpolation. Mitsubishi первыми в мире выпустили устройства, размещаемые на стене (телевизоры DiamondPanel).
Первые коммерческие панели (дисплеи Fujitsu) имели три цвета и представляли собой бегущую текстовую строку (появились в 1984 году). Полноцветные панели (1989 год) имели диагональ 20 дюймов и применялись для отображения быстро обновляемой информации (напр. на биржах). На 2001 год стандартный размер диагонали плазменного монитора для применения в бытовой технике 40-42 дюйма; для работы с компьютерной графикой выпускаются профессиональные мониторы с диагональю 25 дюймов.
P.S. Вот так выглядит 42":

Самое популярное применение плазменной панели – в качестве широкоформатного телевизора для домашнего кинотеатра, в сфере информационных технологий и презентаций. Некоторые устанавливают панели даже в кухнях и ванных. Например Билл Гейтс приобрел 50 больших панелей, чтобы транслировать на них у себя дома картины известных живописцев.

         "... В приступе злости все почему-то молотят по невинному монитору, вместо системного блока..."
Сенсорные мониторы (sensor display, ). Цена сенсорного монитора складывается из цены монитора, цены сенсорного экрана и цены контроллера. Мониторы имеют улучшенные прочностные характеристики и надежность, нечувствительны к воздействию "бытовых агрессивных сред" (кофе, соков, кока-колы, etc.). Работать на сенсорном мониторе просто - нужно прикоснуться к выбранной точке на экране.

Использование сенсорных мониторов позволяет организовать тестирование в общественных местах (например, на выставке). Сенсорные мониторы имеют очень ограниченную сферу применения: справочные системы, киоски, терминалы и пока мало распространены во всем мире.

         "... Первый закон Чизхолма: Все, что может испортиться - портится..."
FED-мониторы (Field Emisson Display, дисплеи с электростатической (автоэлектронной) эмиссией, ThinCRT - "тонкая ЭЛТ"). В отличие от LCD-экранов, которые работают с отраженным светом, FED-панели сами генерируют свет, что роднит их с ЭЛТ и плазменными дисплеями. В отличие от ЭЛТ (у которой всего три электронных пушки, которые испускают три электронных луча, последовательно сканирующих экран, покрытый люминофорным слоем), в FED-устройствах изображение для каждого пиксела формируется излучением электронов с нескольких тысяч субмикрометровых остроконечных элементов поверхности (т.е. для каждого пиксела предназначен свой электрод и он управляется напрямую, как в LCD). Толщина панели не превышает нескольких миллиметров.
Над FED-устройствами работают PixTech, Motorola, Raytheon, Candescent Technologies. FED мониторы обеспечивают крайне высокую яркость изображения (600-800 кд/м2), угол обзора 160° во всех направлениях, а также имеют очень короткое время отклика, легки, тонки, потребляют мало электроэнергии, могут работать в широком температурном диапазоне. Главные проблемы FED-дисплеев - поддержание вакуума в экранах, разгон электронов в высоковольтном поле, невысокий срок работы. Корпорация PixTech уже выпускает цветные 8,5-дюймовые FED-панели. В 2001г. в мире было произведено около миллиона 14,1-дюймовых FED-дисплеев
В Красноярском государственном техническом университете тоже разработана технология производства FED-дисплеев.

· LEP-мониторы (LEP, Light Emission Plastics, Light-Emitting Polymer, светоизлучающая полимерная пленка). Начало LEP-технологии было положено в 1989 году, когда профессор Ричард Френд из лаборатории Кембриджского университета открыл светоизлучающие полимеры. Для изучения LEP и создания новых дисплеев была образована компания CDT (Cambridge Display Technologies, Великобритания). В 1992 году началась разработка первого монитора, сделанного на основе LEP-технологии. Устройство монитора достаточно простое - слои полимера наносят прямо на TFT-матрицу и на прозрачную подложку. Полимерный экран нуждается в герметизации, чтобы избежать его расслоения под действием водяных паров. Можно получить практически любое разрешение и придать отдельному пикселю, а также экрану в целом произвольную форму. Угол обзора новых устройств достигает 180° за счет того, что пластик излучает сам и не требует подсветки. LEP-мониторы работают при напряжении питания всего около 5В и имеют очень малый вес. Узкий диапазон цветов, в котором излучали пластики, удалось расширить и в настоящее время он простирается от синего до ближнего инфракрасного. Низкий срок службы LEP-мониторов (из-за обесвечивания пластика под действием УФ-лучей) продлили до 5 лет за счет использования многослойной структуры и других ухищрений. Сегодня срок службы LEP-мониторов составляе более 7000 часов (~36 месяцев), ведутся работы до доведения 20000 часов. В конце февраля 2000г. "CDT" объявила о завершении строительства предприятия по производству LEP-материалов.
CDT сотрудничает с японской корпорацией Seiko-Epson, что уже привело в к созданию первого в мире пластикового монитора (официально об этом было объявлено 16 февраля 1998 года). Дисплей был монохромным (черно-желтым), имел разрешение 800х236 точек и площадь ~50 мм2 при толщине в 2 мм. Каждым пикселем этого дисплея управлял отдельный тонкопленочный транзистор (как в LCD), а светоизлучающий полимер наносился на коммутирующую матрицу в жидком виде по технологии, аналогичной струйной Epson-печати. К 2002г. "CDT" уже разработала полноцветный полимерный дисплей.
Летом 2000г. "CDT" объявила о завершении разработки дисплея, который можно будет распечатать на струйном принтере! На гибкое покрытие напыляют светоизлучающие полимеры, после чего к подложке достаточно подвести токопроводящие подложки, чтобы получить цветное изображение. Стоимость такого монитора составляет 60% от цены сопоставимого по размерам ЖК-монитора. В настоящее время с CDT сотрудничают такие компании, как Seiko Epson, Intel, HP.

· LED-мониторы (Light Emmited Diode, светоизлучающий диод, светодиодная матрица). Имеют два типа:
а) LED-display имеют очень высокую потребляемую мощность по сравнению с другими типами индикаторов и их в плоских панелях не применяют. Бывают одно-, двух- многоцветные светодиодные матрицы. Пока LED-display применяется для производства электронных табло (напр. для стадионов и спортзалов), видеоэкранов, мобильные видео-установки, электронных часов, дисплеев сотовых телефонов, etc.
б) Полимерные дисплеи (PolyLED, Polymer Light Emitting Diodes). Имеют прекрасную яркость, низкое энергопотребление (3-5 вольт), угол обзора 180 градусов, компактность. Производятся Philips Electronics в сотрудничестве с UNIX (США) и Covion Opto Semiconductors (Германия).

·Электролюминесцентные мониторы (Electroluminescent displays) похожи на ЖК, но имеют специальные доработки, обеспечивающие светоизлучение при туннельных переходах. Эффект излучения видимого света некоторыми материалами (типа сульфида цинка) при прохождении тока известен еще с 1937г., но практическое применение этот эффект получил, когда появились тонкопленочные EL-материалы.
ЭЛ-мониторы имеют высокие частоты развертки, хорошую надежность и яркость. Они работают в широком спектре температур (от -40 до +85°C), Время отклика меньше 1 мс. Угол обзора >160°. Однако для ЭЛ-мониторов необходимо высокое напряжение (>80 Вт), цвета у них не такие чистые, как у ЖК-моделей, и изображение на ярком свете тускнеет. Ведущий производитель этих устройств компания Planar Systems пока поставляет EL-панели преимущественно для различного медицинского оборудования.

· Вакуумные флуоресцентные мониторы (Vacuum fluorescent displays) Эта технология использует высокоэффективное фосфорное покрытие, нанесенное непосредственно на каждый прозрачный анод в области экрана. Однако эти модели имеют относительно низкое разрешение, т.к. размер матрицы ограничивается шириной точек фосфора. Вакуумные мониторы используют в низкоинформационных приложениях.

· Электронная бумага. Компания E Ink (Кембридж, штат Масачусетс) и Bell Labs, исследовательское подразделение Lucent Techologies, получили вещество ("электронные чернила"), похожее на краску и способное изменять цвет под воздействием электрического поля. Электронные чернила - цветная жидкость, состоящая из миллионов крошечных сфер, называемых микрокапсулами. Каждая микрокапсула имеет прозрачную оболочку, наполнитель синего цвета и микроскопические частицы белого пигмента. Микрокапсулы этого вещества впечатываются в поверхности ткани, бумаги, пластика или даже металла, выполняющих роль своеобразного дисплея. Краситель изменяет оттенок в зависимости от характеристик электрического поля. «Чернила» являются бистабильными, то есть полученный элементом заряд сохраняется без подпитки, а значит, обеспечивается немалая экономия электроэнергии. Электронная бумага имеет преимущества перед ЖК-дисплеями вследствие своей гибкости и долговечности. Электронную бумагу можно сворачивать (но не складывать), ее нельзя разбить, уронив. Вариант технологии электронных чернил E Ink, основанный на обычной кремниевой микроэлектронике, используется в уже выпускаемых компанией электронных табло Immedia.

·Мониторы на углеродных нанотрубках. Компания NEC нашла метод получения углеродных нанотрубочных гетерогенных структур и в австралийском центре CSIRO Molecular Science на основе углеродных нанотрубок разрабатываются ультратонкие дисплейные панели, более экономичные и обладающие лучшим разрешением, нежели жидкокристаллические.

· Плоскопанельные мониторы IBM. Исследователи из IBM разработали новую плоскопанельную технологию с разрешением в четыре раза выше, чем у традиционных настольных LCD-дисплеев. Вместо обычных материалов (молибден и вольфрам) для изготовления монитора использовались алюминий и медь, обладающие лучшими проводящими свойствами. В результате появился Roentgen, 16,3-дюймовый дисплей с разрешением 2560х2048. Пока они применяются только в медицине.

· DLP-мониторы (Digital Light Processing). Дисплеи, созданные на основе технологии DLP (разработала компания Texas Instruments) широко используются в военном деле: экраны для шлемов, кабин самолетов, командных центров и т.п. В основе DLP-технологии лежит DMD-ячейка (Digital Micromirror Device). По сути, это структура состоящая из ячейки статической памяти и микроскопического алюминиевого зеркальца, которое может поворачиваться в две стороны на угол 10 градусов. В зависимости от своего положения зеркало отражает или не отражает свет от внешнего источника, результат проецируется на большой экран.

· Кривые мониторы. С конца 90-х годов ведутся работы по искривлению "плоских экранов". Идея состоит в том, чтобы экран как бы "обернуть" вокруг головы человека. На сегодня созданный в лаборатории образец имеет экран в 30 см высоты и 112 - ширины, изгибающийся дугой в 90 градусов. В формировании изображения участвуют цифровые проекторы и телескопические зеркала, призванные устранить линейные искажения при проецировании на вогнутую поверхность. "Кривой" экран в пять раз ярче аналогов. Стоимость опытного экземпляра $25.000.

· Визуализационная система Perspecta или хрустальный шар вместо монитора. 40-тысячедолларовую видеосистему создала компания Actuality Systems. Пока позиционируется как инструмент для медицины и трехмерного моделирования молекул, а в будущем (после снижения цены и запуска в массовое производство) - для игр.
Визуализационная платформа Perspecta работает на принципе перевода трехмерных декартовых координат в сферические. Полученные сферические координаты используются для подсветки вокселей на проекционном экране, вращающемся со скоростью 600 оборотов в минуту (то есть получается 10 оборотов в секунду). Форматированием данных в системе занимается центральный процессор Pentium 4, а работает платформа под управлением OS. Механизм проекции шара создан на основе Digital Light Projector, микроэлектронной (MEMS) системы TI. Для пересчета декартовых координат в сферические в системе добавлен специальный цифровой сигнальный процессор производительностью 1500 Mips (млн.инструкций в секунду).
Пользователь может обойти шар с любой стороны и увидеть картинку со всеми тенями, текстурами и полутонами, которые может обеспечить современный графический движок. На 2002г. Perspecta - лидер среди подобных, обладая способностью отображать 100 млн. вокселей в секунду на шаре диаметром 10 дюймов (25,4 см).

P.S. такое ощущение, что ожил палантир Ортханка из знаменитого фэнтэзийного романа "Властелин Колец" Дж.Р.Толкиена, правда?

· Монитор для слепых. Чтобы помочь слепым людям, в Национальном институте стандартов и технологий (NIST, США) разработано устройство, представляющее собой своеобразный монитор, поверхность которого передана множеством игл. Информация на мониторе появляется в виде выступающих иголочек и становится читаемой - текст или картинка приобретает рельефный вид. Приблизительная стоимость нового монитора - $2.000.

· Конфиденциальный монитор. Японская компания Lizuka Denki Kogyo разработала ЖК-дисплей для финансистов, на который можно выводить закрытую для посторонних информацию. Данные с такого экрана можно прочитать, только надев специальные очки. Эффект достигнут за счет удаления с монитора поляризующего фильтра. Для всех остальных экран будет выглядеть как святящийся белый прямоугольник. Стартовая цена модели 15" - $1600-2500 (осень 2002г.). Впрочем данную защиту можно обойти, правильно подобрав поляризующие очки.

Вместо итога: если Вы собираетесь приобрести качественный монитор и при этом дешевую видеокарту, то ничего хорошего из этого не выйдет: не стоит ставить на "Феррари" двигатель от "Запорожца". При выборе каждый конкретный экземпляр монитора очень индивидуален - не покупайте монитор, не посмотрев его в действии. Прогноз: по прошествии некоторого времени LEP-дисплеи составят достойную конкуренцию по качеству и цене как ЖК, так и ЭЛТ-мониторам.

© Dmitry Belousov
http://www.orakul.spb.ru
ноябрь 2001г.-апрель 2003г.


"Азбука РС" Дм.Белоусова, начало

Системный блок

•

Оперативная память (RAM)

•

Материнская плата (m/b)

•

Compact Disc x/x

•

Процессор (CPU)

•

Floppy (FDD)

•

Винчестер (HDD)

•

Звук (Sound)

•

Корпус (Case)

•

Внутренняя периферия
Сетевая карта (сеть)

•

Видео (video)

Возможности компьютера (например показатели производительности) зависят не только от центрального процессора (любимая ошибка "лоха"), но и от остальных комплектующих, в первую очередь от объема оперативной памяти и chipset-а. Все "железные" компоненты можно разделить на две группы:
  • медленно стареющие (и морально и физически);
  • быстро стареющие (или морально или физически);
  • OEM-упаковка (в п/э пакете);
  • Retail-упаковка (в коробке);
Существует универсальный принцип покупателя ПК: медленно стареющие компоненты надо покупать как можно лучше, на пределе возможного, так как следующий upgrade будет не скоро. В компьютере медленно стареющими компонентами являются монитор и корпус.
Коробочный комплект обязательно включает в себя:
  • компонент (собственно "железо");
  • руководство пользователя (брошюра);
  • CD или дискета с драйверами;
  • картонная (фабричная) коробка;
  • кабель(и)
Коробка обычно выполнена в стиле боксов от системных плат (с откидывающейся вверх крышкой). В brand-e "железо" не просто лежит, а закреплено в специальных картонных держателях внутри коробки.
Но не стоит забывать главного – универсальных решений "для всех" не существует. А поэтому: "Каждый выбирает для себя...". А насчет гонки за самым новым и модным - купите себе более мощный компьютер, чтобы быстрее перезагружаться!

© Dmitry Belousov
azbuka.htm
ноябрь 2001г.-июнь 2002г.

[ оглавление | начало | предыдущая глава | СБ | следующая глава | глоссарий ]


"Азбука РС" Дм.Белоусова, периферия

Периферия

•

Устройства ввода-вывода

•

Связь с сотовым телефоном
Аксессуары к ПК

•

Колонки & наушники

•

Игровые устройства

•

Цифровая техника

•

CompactFlash

•

Накопители

•

Планшеты

•

Принтеры

•

Сканеры

•

Модемы

•

Сеть и ее аппаратура
Проекторы

•

UPS-ы

Теpмин периферия (от греческого periphъreia - окружность) - устройства, связывающие компьютер с внешним миром. Список периферийных устройств, делающих компьютер "вещью для нас", практически неограничен. Сюда же часто ошибочно относят мониторы. Периферийные устройства также называют внешними. Второе определение периферии - это устройства, с помощью которых информация может или вводится в компьютер, или же может выводится из него. Условно периферийные устройства можно разделить на:

  • Основные, без которых работа компьютера практически невозможна;
  • Прочие, которые подключаются при необходимости;
К основным устройствам относятся устройства управления курсором и отчасти модемы (для терминалов и бездисковых станций). Практически к ПК можно подключить любые устройста, которые могут вырабатывать электрические сигналы и/или ими управляться. Периферийные устройства подключаются к компьютеру через внешние интерфейсы или с помощью специализированных адаптеров или контроллеров. Средством стыковки какого-либо устройства и какой-либо шины компьютера является адаптер и контроллер. Понятия "Адаптер" и "Контроллер" не являются синонимами! Контроллер служит тем же целям сопряжения, но он имеет самостоятельные действия (после получения команд от обслуживающей его программы). Сложный контроллер может иметь в своем составе и собственный процессор.
Взаимодействие программ с периферийными устройствами (точнее с программы с адаптерами) происходит через инструкции обращения к портам ввода/вывода, используя прерывания, прямой доступ к памяти и непосредственное управление шиной. Инициатором обмена может выступать как программа, так и периферийное устройство. Программа ожидает какого-либо события в устройстве (например, установки бита готовности), периодически читая его регистр состояния. Такой способ называется обменом по опросу готовности. Прерывания (иили аппаратные прерывания) обеспечивают обмен данными только с участием процессора и т.о. подобное сильно загружает процессор. Различают четыре источника прерываний: внутренние прерывания процессора и сопроцессора, немаскируемые внешние прерывания, маскируемые внешние прерывания, программно-вызываемые прерывания. Прямой доступ к памяти или DMA (Direct Memory Access) - метод обмена данными периферийного устройства с памятью почти без участия процессора. В этом режиме процессор инициализирует контроллер прямого доступа к памяти - задает начальный адрес, счетчик и режим обмена, после чего освобождается. Сам обмен производит контроллер. Еще возможно комплексное решение - опрос готовности устройств (polling) по периодическим прерываниям, например, от системного таймера. Устройство, для которого обнаружена готовность - обслуживается, не готовое - пропускается до следующего прерывания.

         "... все чудесатее и чудесатее ..."

· Многофункциональные устройства или All-in-One. Устройство класса "все-в-одном", сочетающее в себе высокоскоростной принтер, планшетный сканер, копир и факс. В данном устройстве аккумулировано большинство необходимых функций, которые могут понадобиться (как дома, так и в офисе). При этом в функции копира входит увеличение исходного изображения до размеров листа A4, печать нескольких изображений на листе, увеличение изображения до 400% от исходного и печать полученного изображения фрагментами размера A4 для получения большого "изображения". Наличие же разъемов flash-карт дает возможность печатать изображения с данных носителей, полученных с помощью цифрового аппарата без участия ПК.

Широко распространено мнение, что устройства класса "все в одном" уступают аналогичным по функциональности наборам периферии, включающим принтер, сканер и факсимильный аппарат. Действительно, общая надежность любого комплекса меньше, чем у отдельных его составных частей. Однако длительный опыт эксплуатации показал, что на самом деле наиболее критичным их узлом является только принтер.

         "... пришел, увидел, побледнел ..."

· Связь с сотовым телефоном или встроенные средства для синхронизации с ПК. Пока связь используется для передачи данных "записной книжки", но уже есть проекты использования телефона вместо модема. Объем памяти в сотовых аппаратах такой, что можно сохранить до 500 имен с телефонами (причем зачастую на одно имя можно записать несколько телефонов) и текстовую информацию в виде небольших заметок. Возможные варианты, используемые для синхронизации:

  1. Порты
    • Инфракрасный порт. В ПК бывает внешний или внутренний;
    • Параллельный порт в ПК;
    • Порт USB в ПК;
  2. Пакетная передача данных GPRS (в телефоне);
  3. Система высокоскоростного мобильного доступа HSCSD (в телефоне);
  4. Bluetooth-устройство;
  5. Технология EDGE;
Напр. IrDA-IrDA, GPRS-USB, Bluetooth-Bluetooth и т.д. Еще имеется возможность синхронизации данных при помощи специального программного обеспечения, которое зачастую входит в комплект поставки телефона.

ИК-порт (IrDA, ИК-адаптер, IR-) служит для беспроводной передачи информацию на любое устройство (КПК, телефон, компьютер), поддерживающее формат vCard. Стандарты - IrDA 1.3 и USB 1.1. Скорость приема/передачи данных: 9,6 Kbps, в теории- 4000 Kbps. Дистанция соединения 0-2,0м (реально должен лежать в пределах видимости до 1 м). Подключается к IrDA-порту или к USB-порту на материнской плате РС. Рекомендую наличие светодиодного индикатора. Мировыми лидерами в производстве адаптеров IrDA являются фирмы "Vishay Telefunken", "SigmaTel", "Agilent Technologies", "Philips". В отличии от ноутбука, обычный ПК не комплектуется ИК-портом. Вариант решения проблемы - установка в ПК дополнительного ИК-порта, например, смонтированного в корпус или внешнего.

Технология GPRS (General Packet Radio Service) - услуга пакетной передачи данных по радиоканалу. При GPRS расчеты производяться пропорционально объему переданной информации, а не времени, проведенному online. "Пакеты" данных передаваются одновременно по многим каналам в паузах между передачей речи. Голосовой трафик имеет безусловный приоритет перед данными. Поэтому в GPRS существует несколько классов QoS (Quality of Service - качества сервиса). Скорость передачи данных определяется количеством каналов, с которыми одновременно может работать GPRS-телефон. Один канал обеспечивает скоростью до 13.4 кбит/с. Максимальная (в теории)- 171.2 кбит/с. В комплект поставки GPRS-телефонa входит коммуникационный кабель (при наличии ИК-порта, можно подключить и с помощью него), компакт-диск с программой GPRS Wizard и руководство по настройке. GPRS-терминалы подразделяются на три класса:

  1. устройства класса А способны одновременно работать как с передачей голоса, так и с передачей данных одновременно;
  2. устройства класса В могут осуществлять либо передачу голоса, либо передачу данных, но не одновременно;
  3. устройства класса С поддерживают только передачу данных и не могут быть использованы для голосовой связи. Это разного рода компьютерные платы для обеспечения беспроводного доступа к данным.
Технология HSCSD (high speed circuit switched data) - это беспроводной доступ в Интернет, осуществляемый с помощью адаптера размером с кредитную карту. Она позволяет выделять одному сеансу связи до четырех временных слотов, в результате чего обычная скорость передачи данных в подобных сетях (9,6 Кбит/с) может быть увеличена в четыре раза, т.е. стать даже выше, чем при использовании большинства современных проводных телефонных модемов. В отличие от GPRS, обеспечивающему постоянный доступ в Интернет, для HSCSD пользователю необходимо находиться в режиме "dial-up", что более удобно для передачи видеоинформации. Внедрение этой технологии требует только модернизации ПО. Скорость приема/передачи данных: 28,8 - 43,2 Kбит/с. Поддерживается компаниями Nokia и Ericsson. Конкурирует с технологией GPRS.

Технология Bluetooth- - технология беспроводной передачи данных по радио для связи разнородных устройств. Название Bluetooth было дано в честь датского короля X-го века Гаральда Блатана, прославивщегося своей способностью находить общий язык с князьями-вассалами. Инициатором проекта Bluetooth была шведская компания Ericsson, затем присоединились Motorola и Nokia. Этот стандарт позволяет соединять друг с другом при минимальном пользовательском участии практически любые устройства, в т.ч. мобильные телефоны, ноутбуки, принтеры, цифровые фотоаппараты и даже холодильники (!), микроволновые печи (!), кондиционеры. Соединить можно все, что имеет встроенный микрочип Bluetooth. Технология стандартизирована, следовательно, проблемы несовместимости нет. Технология также предлагает беспроводный доступ LAN, PSTN, сеть мобильных телефонов и Internet для домашних приборов (!!!).
Одно Bluetooth-устройство может одновременно общаться с 7 устройствами Bluetooth, остальные будут в режиме ожидания. Используются сверх-высокие радиочастоты 2.4 ГГц. – диапазон, свободный от лицензирования. Bluetooth-чипсет обеспечивает скорость передачи данных до 721 Кбит/с (!) в радиусе до 10–20 метров. Зависит от типа чипсета и его мощности. Разработывается радиус до 100 метров (!!!). В отличие от IrDA, который требует, чтобы устройства были нацелены на друг друга, Bluetooth использует радиоволны, которые свободно проходят через стены и неметаллические барьеры. Уже существует понятие Bluetooth-сети. На сегодня это самая перспективная технология.

Технология EDGE (Enhanced Data Rates for GSM Evolution) - в вольном переводе "передача данных на повышенной скорости"), позволяющая осуществлять перекачку информации на скоростях до 384 кбит/с в восьми GSM-каналах (48кбит/с на канал). Для внедрения EDGE "поверх GPRS" операторам необходимо будет заменить аппаратуру базовых станций BTS, а пользователям - приобрести новые EDGE-телефоные. Применимо для сетей третьего поколения UMTS (Universal Mobile Telephone System) - т.е. это планы на будущее.

         "... пятница, оно, конечно, святое, но нельзя же вот так, прямо с утра, приступать-то ..."

· Презентационное оборудование или передача ПК-данных на экран. Уже сейчас стоимость недорогой проекционной системы равняется стоимости двух недешевых компьютеров. Всего существует четыре типа проекторов

  1. Диапроекторы - проекторы для слайдов. К ПК не подключаются.
  2. Эпископы — проекторы для отображения на экран непрозрачных объектов: страниц книг, журналов, фотографий и даже предметов. К ПК не подключаются.
  3. Оверхед-проекторы (оverhead`ы) проецируют изображение со специальных прозрачных пленок. На прозрачную пленку изображение можно нанести тремя способами: фломастером от руки, при помощи принтера и при помощи ксерокса. В каждом из вариантов используется свой тип пленки. Некоторые модели оверхед-проекторов могут проецировать компьютерные данные при посредстве вспомогательного устройства (ЖК-панели).
  4. Мультимедиапроекторы - проекторы для проецирования компьютерного и видео-изображения на большой экран. Гибрид оverhead-а и жк-панели, плюс навароты.Обычное расстояние до экрана: 1,5м (мин) - 10м (макс).
По весу и объему оверхед-аппараты делятся на портативные, полупортативные и стационарные модели. По общему принципу проекции модели подразделяются на оверхед-проекторы проходящего и отраженного света. Иногда жидко-кристаллические (LCD) проекционные панели оverhead-ов ошибочно выделяют в группу, называя ее ЖК-проекторы. Современные мультимедиапроекторы берут сигнал и с видеомагнитофона или телевизора, и с компьютера. Изображение получается очень качественным: яркие и четкое. Мощность проекторов позволяет не затемнять помещение - работать в присутствии внешнего освещения. Контрастность: 600:1. Реальное разрешение - около 1024x768. С ПК соединяется кабелем. Хороший проектор без хорошего экрана бессилен. Мультимедиапроекторы делятся на три группы, отличающиеся друг от друга технологией и способом передачи изображения на экран. Существует TFT ЖК-технология (1), полисиликоновая ЖК-технология (2) и DMD/DLP-технология (3).
В силу высокой стоимости мультимедиапроекторы пока распространены мало. Кроме проекторов в презентационное оборудование входят копировальные, маркерные, календарные, информационные и демонстрационные доски, флип-чарты, лазерные указки, настольные видеокамеры; аудио-системы, дистанционные мыши и т.д. Использование проекционной техники резко повышает эффективность учебного процесса.

         "... Коврик для мыши совершил недопустимую операцию и будет свернут ..."

· Компьютерные аксессуары. Теpмин - от французского accessoire - придаточное к главному, второстепенный предмет. Предназначены для комфортной работы & транспортировки (за ПК, за письменным столом, в дороге, etc.).

  • Боксы (коробки) для CD & дискет:
    • Бокс для CD;
    • Бокс для в/кассет;
    • Бокс для дискет 3.5" (2,5,10,25,50 шт.);
    • Чехлы для дискет;
    • Чехлы для CD;
  • Сумочки
    • Сумка для notebook-а;
    • Сумочка на дискеты;
    • Сумочка на CD-диски;
    • Сумка для CD-проигрывателя;
    • Сумочка для мобильного телефона;
  • Чехлы для монитора;
  • Чистящие средства:
    • Чистящий диск для CD-ROM;
    • Комплект для чистки экранов;
    • Средства ухода за оргтехникой;
    • Чистящая дискета для 3,5" дисковода;
    • Чистящая дискета для 5,25" дисковода;
    • Комплект для чистки любых поверхностей;
    • Чистящие салфетки (cалфетки для протирки);
    • Сжатый воздух для чистки клавиатуры (балончик);
  • Компьютерная мебель;
  • Сумки для ноутбуков;
  • Уничтожители бумаг;
  • Сетевые фильтры;
  • Защитный экран;
  • Подставки:
    • подставка под клавиатуру;
    • подставка под монитор;
    • подставка под корпус;
  • Коврики для мыши:
    • матерчатый материал;
    • материал neopren;
    • материал nylon;
    • материал PEVA;
    • материал blister;
    • материал EVA;
    • материал PP;
    • кожезаменитель;
  • Расходники:
    • Аксессуары для принтеров
    • Картриджи для принтеров
    • Бумага, пленка
    • Дискеты;
    • СD-R(W);
  • Держатели:
    • держатель клавиатуры;
    • держатель мыши;
    • держатель для бумаг (Copy Holder)
      • Paper Clip (держатель бумаги на монитор)
      • с креплением клипса ("прищепка");
      • с креплением на липучке";
      • планшет с линейкой (в т.ч. на откидной подставке);
      • планшет портативный;
  • Прочие аксессуары;

Вместо эпилога... Выбирая периферию - не забывайте про современный дизайн и эргономику!

© Dmitry Belousov
http://www.orakul.spb.ru
ноябрь 2001г.-июнь 2002г.

[ оглавление | начало | предыдущая глава | периферия | следующая глава | глоссарий ]


"Азбука РС" Дм.Белоусова, операционки

Операционные
системы

•

OS компании Мicrosoft

· пакет исправлений
· Boot Manager

•

OS для Mac-ов
· OS и пользователи
· файловая система

•

Unix-ные OS
·
OS для КПК

•

Прочие OS

Операционная система (OS) контролирует и координирует действия аппаратного обеспечения ПК, а также осуществляет взаимодействие аппаратного обеспечения с программным. К главным функциям OS относятся:
  • осуществление диалога с пользователем;
  • ввод-вывод и управление данными;
  • планирование и организация процесса обработки программ;
  • распределение ресурсов (оперативной памяти и кэша, процессора, внешних устройств);
  • запуск программ на выполнение;
  • всевозможные вспомогательные операции обслуживания;
  • передача информации между различными внутренними устройствами;
  • программная поддержка работы периферийных устройств;
Каждая операционная система имеет свой командный язык. Для управления внешними устройствами компьютера используются специальные системные программы — драйверы. Драйверы стандартных устройств образуют в совокупности базовую систему ввода-вывода (Bios), которая заносится в память ПК.

 Все, что хорошо начинается, кончается плохо. Все, что плохо начинается, кончается еще хуже
(Закон Паддера)

Единой классификации операционных систем не существует, но в зависимости от разных факторов-критериев все OS можно разделить на классы. Рассмотрим самые важные:
· Client / Server
· бесплатные / платные
· версия оригинальная / локализованная
· интерфейс Text Mode / Graphic Mode
· архитектура 16-bit / 32-bit / 64-bit
· объем большой / маленький
· версия сетевая / псевдо-сетевая & локальная
· память процесса с защитой / без защиты
· загрузка программы экономная / не экономная
· однозадачные / многозадачные
· однопользовательские / многопользовательские
· стабильная / нестабильная
· virus friendly / no virus friendly
и т.д. и т.п.

· Client / Server. Универсального разделения OS на клиентскую и серверную части не существует. Как правило, компания либо выпускает серию OS, позиционируя каждую отдельно (напр. серия Windows 2000), либо создает единый (глобальный) дистрибутив для личного выбора пользователя во время установки (напр. Linux). Конечно второй вариант удобнее. Формально Client ставится домой и/или на рабочие места, а Server служит для размещения многочисленных серверов (сервер приложений, web-сервер, почтовый сервер, сервер базы данных, etc.). Обычно Client не поддерживает более одного процессора, а Server имеет огромный набор встроенных утилит (в т.ч. администрирования и нескольких мониторов сразу), шифрование и разделение доступа. Поддержка "железа" (драйвера) должна быть одинаковой.

· бесплатные / платные. Большая часть OS распространяются за деньги (о пиратах помолчим). Пример - Windows. Т.е. уплатив некую сумму, Вы получаете
* CD-Rom с дистрибутивом;
* книгу-брошюру ("Руководство пользователя");
* сетрификат подлинности (Certificate of Authenticity) с номером (Product ID:);
* инсталляционные дискеты (иногда);
Но есть и бесплатно распространяемые OS - напр. Linux. Вы можете бесплатно получить Linux у того, кто им уже обладает, скачать его из Internet-a, купить CD-Rom у дистрибьютора (деньги берутся за "болванку" CD-Rom-а и/или тех.поддержку).
При сравнении платных OS следует помнить, что суммарная цена состоит не только из разовой оплаты (стоимости лицензии). В минимальный расчет стоимости OS входит:
1. стоимость лицензии(ий) на OS;
2. стоимости аппаратного обеспечения (нового или upgrade старого);
3. стоимость технической поддержки;
4. стоимость услуг upgrade/обслуживания;
5. прибыль, потерянная за каждый час не работы OS;
6. оплаты персонала за восстановление данных, потерянных из-за дефектов OS;
7. зарплата системных администраторов;
Какая же из платных OS в результате окажется дешевле? Считайте...

· Оригинальная / Локализованная. Это язык OS (английский, русский, etc.). Грамотные пользователи всегда ставят оригинальную (английскую) версию. Причин много, в т.ч.: неизбежные для локализованных продуктов задержки выхода новых версий, новые ошибки от локализации, просто отсутствие русской версии, неудобный способ переключения клавиатуры (между русской и латинской раскладкой), плохой перевод, etc...

· Интерфейс. Бывают OS с командным интерпретатором (текстовый интерфейс, Text Mode) или OS с графическим интерфейсом (Graphic Mode, оконный менеджер).
а) Если операционная система с Text Mode, то после входа пользователя в систему для него запускается один из командных интерпретаторов. Обычно в системе поддерживается несколько командных интерпретаторов с похожими, но различающимися своими возможностями командными языками. Часто их называют консолями. Общее название для любых консолей-интерпретаторов - shell (оболочка), поскольку любой интерпретатор представляет внешнее окружение ядра системы.
б) Графический интерфейс - это окошки, картинки, поддержка мыши и т.п. Его также называют Presentation Manager (PM). В любой современной OS обычно есть несколько Graphic Mode. Например, в Linux их больше десятка, а в любой версии Windows - оконный менеджер один (как обычно, Windows - мерзкое исключение).

Виртуальная мультиконсоль. Дает возможность на одном дисплее организовать работу нескольких консолей (т.е. одновременное выполнение многих программ). Пример из UNIX:
На первой консоли запускается связь с корпоративной базой данных. Комбинацией клавиш Alt-F2 следует переход на вторую консоль. Трансляция продолжается, но при этом первая консоль на экране монитора заменяется новой картинкой второй консоли. В которой запускается обработка текста (напр. редактор, переводчик, словарь, etc.). Комбинацией Alt-F3 следует переход на третью консоль, в которой запускается отладчик программ. На четвертой консоли - играете в DOOM. Ну и т.д. Обычно в системе 8 консолей, но можно установить до 64-х. В любой момент времени можно переключиться на любую консоль. На отдельной консоли может работать как текстовая, так и графическая программа. На одной из свободных консолей можно запустить оконную графическую систему X Window System. Открываете окно и напр. выход в Internet (звонилка, браузер, etc.). Можно ICQ через сеть. А в других окнах - база данных, почта, редактор, трансляция и т.д. Таким образом, одновременно работает много консолей, а на одной из консолей еще и много окон X Window System.

· Архитектура. Бывают 16-разрядные OS (16-bit), 32-разрядная OS (32 бита, 32-bit), 64-разрядная OS (64-bit). Зависит от того, сколько одновременно OS может обрабатывать единиц информации. Самая распространенная - 32-разрядная операционная система.
Кстати, практически все производители, выпустив новую 32-разрядную OS, полностью переписывали 16-разрядный код (честно на 32-bit). Но вот один 6 лет выпускал 16-bit-ные OS под рекламой 32-bit. Исключение обычное - Microsoft (кусков 16-разрядного кода нет только в Windows XP).

· Псевдо-сетевые OS. Проблема не в чисто локальных OS - они безнадежно устарели и их уже нет, а в OS, имитирующих сеть. Операционные системы, подобные Windows, изначально строились в расчете на управление внутренними процессами. Операции, относящиеся к сетевому взаимодействию, надстраиваются в них поверх структуры OS и соответствующие прерывания имеют низкий приоритет. Т.е. управление прерываниями реального времени (напр. нажатие на кнопку мыши или воспроизведение видеоклипа), осуществляется по приоритетной схеме, а сетевые службы (напр. модем или сетевой интерфейс) рассматриваются как дополнительная функция, которую OS должна поддерживать параллельно. Получается, что в таких OS нет способа гарантировать сетевой программе все необходимое время процессора для обработки реальных событий. А от сетевых устройств удаленный ПК ждет только строго определенного "поведения". Если сетевая программа сделает чуть не так, связь будет нарушена или разорвана. Не говоря уж о том, что структура OS становится дико громоздкой, а иерархия уровней еще более усложняется.
Частично проблема решается на аппаратном уровне (напр. Intel - новые инструкции для процессора). Большие объемы памяти и сверхбыстрые процессоры способны замаскировать проблему, но не решить. Поэтому нужно или покупать новые процессоры или ставить нормальную OS (напр. один из Unix).

· Защита памяти процесса. Есть OS (большинство), в которых сбой одной (какой-нибудь) программы не вызывает "зависание" всей системы (напр. Unix), а есть OS, у которых от сбоя программы "виснет" вся система (напр. Windows).

· Загрузка программы. Для работы программы можно считать с диска только те части программы, которые действительно используются для выполнения, а можно все подряд. Соответственно есть - экономная загрузка (напр. Linux), а есть не-экономная (напр. Windows).

· однозадачные / многозадачные (или многопользовательский режим и его поддержка). Однозадачные OS могут работать только с одной (в данный момент времени) программой, т.е. выполняют функцию предоставления пользователю виртуальной машины. Пример - MS-DOS. Многозадачность - это способность OS одновременно выполнять много программ (любых!) на одном ПК. Среди множества существующих вариантов реализации многозадачности можно выделить две группы алгоритмов: вытесняющая / невытесняющая многозадачность. Основные различия между этими вариантами многозадачности определяются:
1 определение: способом распределения процессорного времени между несколькими одновременно существующими в системе процессами (или нитями).
2 определение: степенью централизации механизма планирования работы. При невытесняющей многозадачности активный процесс выполняется до тех пор, пока он сам не отдаст управление OS для того, чтобы та выбрала из очереди другой готовый к выполнению процесс. При вытесняющей многозадачности решение о переключении процессора с одного процесса на другой принимается самой OS, вне зависимости от готовности первого процесса.
После объявления Windows многозадачной, у других OS появился термин "истинная многозадачность". К невытесняющая многозадачности относятся NetWare, Windows 95/98; а к вытесняющей многозадачности - Windows NT4-2000, OS/2, все UNIX.
Нельзя многозадачность путать с режимом переключением задач, который допускает запуск нескольких программ, но не позволяет работать этим программам на одном компьютере одновременно.

· однопользовательские / многопользовательские. Здесь OS делят по числу одновременно работающих пользователей. Многопользовательский режим OS - много пользователей одновременно работают на одном и том же ПК. Главным отличием многопользовательских систем от однопользовательских является наличие средств защиты информации каждого пользователя от несанкционированного доступа других пользователей. Чтобы начать работать, человек должен "войти" в систему, введя свое учетное имя (account name) и пароль (password). Человек, зарегистрированный в учетных файлах системы (имеющий учетное имя), называется зарегистрированным пользователем системы. Регистрацию новых пользователей выполняет администратор системы. Пользователь не может изменить свое учетное имя, но может установить и/или изменить свой пароль. Пароли хранятся в отдельном файле в закодированном виде. Есть OS:
· однопользовательские однозадачные (например MS-DOS), которые поддерживают одну клавиатуру и могут работать только с одной (в данный момент) задачей;
· однопользовательские многозадачные (например OS/2), которые обеспечивают одному пользователю параллельную обработку нескольких задач;
· многопользовательские многозадачные (например UNIX), позволяющие на одном компьютере запускать несколько задач нескольким пользователям;
Внимание: не всякая многозадачная система является многопользовательской, и не всякая однопользовательская OS является однозадачной.

· стабильная / нестабильная. Любой пользователь Windows сталкивался с фразой на экране "Программа выполнила недопустимую операцию и будет закрыта. Если эта ошибка будет повторяться, обратитесь к разработчику.". Вы наверное, уже привыкли "зависать" в день по два-три раза и переустанавливать свои "винды" каждые полгода? Вот поэтому Windows и называется крайне нестабильной OS. Вам не обидно читать после перезагрузки "повисших виндов" фразу на экране "Из-за того, что работа Windows не была завершена должным образом, у Вас могут быть ошибки."? Т.е. сначала Windows сама "виснет", а потом еще и портит.
Кстати, так мучаетесь только Вы. Альтернативный пример: автор за 3 года в Linux не "повис" ни разу.

· virus friendly / no virus friendly. Есть OS (большинство), в которых не только активация, но и само существование вируса затруднено (напр. UNIX), а есть отдельные OS, "дружественные по отношению к вирусам" (напр. Windows, которая вообще стала своего рода базовой системой для техно-крыс. И такое положению MS устранивает, судя по тому, что реальных мер не предпринимается).

99,9% пользователей на самом деле не используют операционную систему. Повторяю - не используют!. Т.к. работают с приложениями. Именно прикладные программы и используют операционную систему. И любая OS (даже самая привлекательная) хороша лишь в той мере, в какой хороши программы, работающие под ее управлением. Если Вам необходимо использовать (или Вы к нему привыкли) программу, которая доступна только для одной OS, Вам нельзя заменять операционную систему. Но есть вероятность, что эта (или похожая) программа существует для другой OS.

         Никогда не испpавляйте найденные ошибки, ибо это повлечет за собой появление неизвестного числа не найденных (совет начинающему)

· Service Pack (SP, пакет исправлений, "заплатки"). Большая часть широко распространенных OS глюкава, но это еще полбеды, ибо они содеpжат ошибки. Hастоящие сбоpники имеют своей целью испpавление того, чего не в состоянии сделать производители OS сразу. Все пакеты SP инкpементальны, т.е. каждый последующий содеpжит все пpедыдущие. Достаточно ставить испpавления из последнего SP.
Стандартная реклама-описание с ремарками-переводом: SP представляет собой набор дополнений и обновлений для системы и не содержит новых модулей (т.е. только исправление существующих ошибок). Обновления, вошедшие в состав SP, обеспечивают улучшение совместимости приложений и аппаратного обеспечения (т.е. что-то не работало вообще), более высокую защищенность данных (т.е. хакеры уже успели взломать) и дальнейшее повышение надежности операционной системы (т.е. были официальные претензии). Ну и т.д.
К сожалению, каждый SP не только устраняет найденные старые ошибки (не все, правда), но и создает при этом новые... Поэтому не ставьте их без крайней необходимости!
Производители с большим количеством ошибок даже создают отдельные сайты в Internet-e по обновлениям. Хороший пример - Microsoft Download Center.
SP также называется Fixpack, FIX ("пофиксить" систему).

· Несколько OS на ПК одновременно. При наличии на одном ПК нескольких операционок ставят менеджер загрузки (Boot Manager). Система управления загрузкой Boot Manager устанавливается в отдельный раздел диска (как правило) и получает управление после инициализации компьютера. Boot Manager выводит на экран меню, при помощи которого пользователь может выбрать необходимую OS. Пример возможных схем расположения Boot-раздела (для использования OS/2 Boot Manager или системы LInux LOader Boot)- на рисунке:

Т.е. раздел Boot Manager можно разместить не только в середине, но и в конце первого диска. Обычно возможность выбора нескольких операционных систем получается, если пользователь установил новую OS, но при этом сохранил и старую. Реально есть всего три популярных (и бесплатных) Boot Manager-а и полтора десятка прочих. Главная проблема в том, что большинство этих программ создается только для загрузки разных версий Windows и не могут работать с другими OS. Другие проблемы - ограничение количества OS, убогий интерфейс, скромные возможности. Небольшой список (лучшие выделены синим цветом):
[ Boot Easy (FreeBSD) ] [ BootIt Next Generation ] [ BootStar Boot Manager ] [ Lilo (LInux LOader) ] [ MasterBooter ] [ MATTsoft Boot Manager ] [ MSTBOOT Boot Manager ] [ My Boot Manager ] [ NZBoot ] [ OS/2 Boot Manager ] [ OS-BS (FreeBSD) ] [ OSLoader 2000 ] [ Paragon Ext2FS Anywhere ] [ Partition Boot Manager ] [ Sleepy ] [ Smart Boot Manager ] [ SyMon (R3 References) ] [ Windows Boot Manager (NT-2000) ] [ XBOOT ]
* - Boot Easy, OS/2 Boot, Lilo, NZBoot, SyMon и Sleepy бесплатны.
Следует отметить тот факт, что встроенный в W2K Windows Boot Manager при каждом своем запуске уничтожает загрузочные данные других OS, блокируя т.о. их запуск. Дело дошло до того, что в популярной утилите dfsee (анализ строения диска, разделов и файловых систем) появилось встроенное средство борьбы с отродьем фирмы Microsoft.
Рекомендация по лучшим: ставьте SyMon (при выборе между Windows) или универсальный OS/2 Boot Manager.

VMWare: кроме менеджера загрузки есть еще возможность создать виртуальный ПК. 15 марта 2001г. компанией VMWare выпущен одноименный продукт. Эта программа представляет собой диспетчер виртуальных машин, работающий под управлением хост-системы (напр. под Linux). VMWare может создавать до 254 (!!!) виртуальных машин под своим управлением (конечно, если "железо" хост-система позволяет) и при этом каждая виртуальная машина получает в свое распоряжение свой биос, свою память, свою сетевую карточку и считает, что она работает в системе совсем одна. Т.е. не надо перезагружаться в нее, а достаточно запустить VMWare, указать ему параметры виртуальной машины, указать откуда загружать OS и получить в свое распоряжение полностью работоспособную систему, но работающую в окне хост-системы. Пример: одновременно Win2000, WinME, Win98 в окнах под Linux-ом...

· Кроме работы программ под Windows, есть различные проекты работы Windows-программ под другими OS. Отметим два популярных:

  1. проект Odin под OS/2.
  2. Wine (API WineX). Канадская компания Transgaming Technologies в феврале 2002г. выпустила пресс-релиз о успешной разработке нового API WineX, который позволяет работать с Windows-приложениями под OS Unix, в т.ч. играть в DirectX 8-игры на Linux-платформе. Первой игрой, которая про-тестировалась под Linux - API WineX, стала Max Payne. На момент написания главы в базе первого сайта содержится более 2700 Windows-приложений, которые протестированы и работают. Можно протестировать нужное приложение на «запускаемость» или воспользоваться поиском на одном из двух сайтов: Wine Development HQ (http://www.winehq.com/Apps), CodeWeavers Wine Application Database (http://appdb.codeweavers.com/).
    Ложка дегтя для "простых" пользователей: скачать бесплатно можно только исходники WineX, а за уже откомпилированную версию API и соответствующие добавления, улучшения и модули поддержки новых игр придется заплатить (правда месячная подписка обойдется всего в $5). Или учитесь компилировать сами...

· Немного статистики по используемым сейчас OS (от мая 2002г, статистика Netstat-а и Hotlog-а):

OS, как серверы (для Internet-a) OS, для дома (в России)
  • Linux - 37.9%
  • FreeBSD - 37.09%
  • Windows (любой) - 15.27%
  • Solaris - 6.17%
  • BSDi - 1.22%
  • AIX - 0.82%
  • SCO - 0.66%
  • OpenBSD - 0.54%
  • Irix - 0.15%
  • Other - 0.12%
  • OS/2 - 0.06%
  • Windows 98 - 60.35%
  • Windows 2000 - 21.29%
  • Windows NT4 - 7.47%
  • Windows XP - 6.18%
  • Windows 95 - 3.74%
  • Other - 0.49%
  • Windows ME - 0.22%
  • Linux - 0.18%
  • FreeBSD - 0.04%
  • Macintosh - 0.04%
Во-первых, наглядно видно различие в OS у профессиналов и обычных пользователей (слева Unix - 84,55%, справа Windows - 99,25%) и про-Мicrosoft-ское "прогибание" России... (во-вторых). Впрочем, это уже к психиатру, ибо "...компьютер без Windows как морожение без кетчупа...".

         ... Не дари девчонке роз - подари ей лучше ОС...

· OS и типы пользователей или почему Windows - "...объективно плохая система..." (Линус Торвальдс, основатель Linux). Существует классификация, по которой абсолютно всех обычных компьютерных пользователей (usr-ов, "лаймеров", "чайников" и т.п.) разделяют всего на три категории:

  1. Пользователи, которые хотели бы разобраться в операционной системе до упора. Причем - вне зависимости от образования, опыта предыдущей работы, характера основной деятельности, etc. Категория немногочисленна и в итоге (рано или поздно) эти люди приходят в мир Linux/Unix и открытого кода. Сначала эти пользователи способны доставить немало хлопот, но потом они превращаются в коллег и товарищей.
  2. Пользователи, которые об устройстве компьютера, его операционной системе и прочих материях знать ничего не желают, им достаточно было бы того, что ПК был кем-то запущен и как-то работает. Я не говорю, что это плохо, т.к. бывает, что амбиции и знания таких пользователей лежат совсем в других сферах деятельности. Как клиенты такие пользователи очень приятны - они делают только то, что им сказано и не занимаются никакой отсебятиной. К этой категории относится подавляющее большинство пользователей на Западе и единицы в России. Идеальная OS для них - Macintosh. Но Mac-ов у нас мало, они дороги, программы для них не очень доступны.
  3. В России пользователи второй группы волей неволей превращается в пользователя третьей. Ибо для работы в Windows мало щелкать мышкой по иконкам и менюшкам. Приходится узнавать не только о том, что такое файл и расширение файла, но и о драйверах устройств, прерываниях, "заплатках" и многом другом. Однако разобраться в этом досконально а) нет желания б) нет возможности.
Поясню еще... Пользователь Linux/FreeBSD/Unix просто вынужден идти до конца в освоении системы. Пользователь Mac-ов может обойтись без знаний о системе вообще - ему довольно будет чисто практических навыков работы со своими программами. Пользователя Windows просто против его воли толкают к компьютерной полуграмотности. Да - пользователи Windows героически преодолевают тяготы и лишения, пытаясь разобраться в этой мерзкой системе для идиотов. В итоге, нахватавшись умных слов и научившись менять разрешение экрана и обои рабочего стола, "чайник" проникается манией собственного величия. Оставаясь при этом полным "лохом". Т.е. Windows вреден, "...потому что создает иллюзию понимания там, где о настоящем понимании не может быть и речи...".

Знай свое железо... Перед установкой любой OS желательно знать конфигурацию аппаратных средств компьютера. В процессе установки Вам может потребоваться такая информация, как тип видеоадаптера, тип звукового и сетевого адаптера, адреса портов ввода/вывода, номера прерываний и каналов прямого доступа, диапазоны адресов памяти, используемых периферийными устройствами для выполнения операций ввода/вывода и т.п.

Вместо эпилога: позволю себе наглость поделиться личным видением компьютерного будущего. Mac OS XX - Unix, обручённая с Java и OpenGL, является мечтой любого сисадмина и хакера и занимает половину рынка OS (причём поставляется она только на Mac-ах, хотя отдельные радикалы уже давно портировали Darwin на i386 и работают с ней только в режиме командной строки). На другой половине царит Linux, не менее успешно впитавшая самые перспективные открытые стандарты (те же Java, OpenGL, BlueTooth и Unicode...). Причем царит Linux на разношёрстном (в отличие от Macintosh-а), но зато оставляющем большой простор для экспериментов железе. Хакерская богема, стремящаяся обособиться от мэйнстрима, ищет прибежища на новой свободной BeOS. Что Вы говорите - Windows... извините, а что это такое?

© Dmitry Belousov
http://www.orakul.spb.ru
ноябрь 2001г.-май 2003г.

[ оглавление | предыдущая глава | OS | следующая глава | глоссарий ]


"Азбука РС" Дм.Белоусова, программы-приложения

Программы (software)

•

Золотой фонд soft-a

•

License на программу
Получение soft-a

•

Офисные пакеты
Пиратство soft-a

•

Новая версия для "лоха"
О горе-писателях...

•

Вирусы

Теpмин "Пpогpамма"(также software, ПО) подpазумевает под собой оpигинальную пpогpамму, все ее составляющие части, а также копии. Пpогpамма содеpжит исполняемый код, документацию, аудио-визуальную часть (гpафика, текст, записи или звук, видео-анимация) а также матеpиалы по лицензиям и использованию. Кроме вышеперечисленной, существует старая (простейшая) классификация пpогpамм:

  • Прикладные программы, обеспечивающие выполнение необходимых пользователю функций (работ);
    Пример: "MS Word", текстовый редактор.
  • Системные программы, выполняющие различные вспомогательные функции;
    Пример: "TouchStone Checkit", справочная информация о компьютере.
  • Инструментальные программные системы, облегчающие процесс создания новых программ;
    Пример: "Borland Delphi", среда программирования.
Программы для ПК стоят денег и обычно стоимость установленного ПО превышает стоимость собственно "железа". Таким образом, речь идет о сумме, сравнимой со стоимостью всего парка имеющихся компьютеров и по самым скромным оценкам составляет миллиарды долларов. Часть этих денег уже уплачена за легально купленное ПО. Большая же часть ПО в России используется нелегально, в нарушение международных законов. По новому закону "...использование несертифицированных информационных систем ... карается ... штрафом на граждан в размере от 5 до 10 МРОТ с конфискацией... на должностных лиц - от 10 до 20 МРОТ... на юридических лиц - от 100 до 200 МРОТ с конфискацией..." (статья 3.12 Административного кодекса РФ, введен с 01.07.2002г.).
К сожалению, худшие программы обычно лучше рекламируются и как следствие - более распространены. Существует всего несколько способов получения ПО:
  • Full Package Product (FPP) или коробочная заводская упаковка. Коробки могут приобретать как частные лица, так и фирмы. Коробка содержит лицензионное соглашение, сертификат подлинности, регистрационную карточку, дистрибутив с программным продуктом (обычно на CD-Rom-е) и как правило, документацию в печатном виде. Коробки продаются в розничной сети (в магазине, в фирме).
  • Original Equipment Manufacturer (OEM) или pre-intall. Это ПО для продажи вместе с новым компьютером в виде предустановленной версии. OEM-версия продукта, как правило, включает: лицензионное соглашение конечного пользователи (EULA), сертификат подлинности, дистрибутив с продуктом, документацию, регистрационную карту. Часто, при покупке новых ПК с предустановленной OS, пользователь не получает носитель с продуктом: продукт уже полностью установлен на жестком диске ПК. Внешний вид OEM-а - CD-Rom (в п/э, в бумажном конверте). Различают:
    1. OS pre-install (операционная система, установленная на продаваемый компьютер). На Западе вообще нельзя купить ПК без установленной OS, в России пока еще можно;
    2. Soft pre-install (пpогpаммы, установленные на продаваемый ПК). При этом различают:
      • Выбранные. По выбору пользователя ему инсталлируется на новый ПК необходимые программы;
      • Навязанные. Например при инсталляции Windows всем без исключения пользователям насильно "впаривается" куча никому не нужных, корявых и убогих, Windows-программ от Microsoft-a;
    3. Драйвера от производителя железа (к m/b, video, принтеру, etc.). Подробнее;
    4. Бонус-пpогpаммы от производителя железа (для настройки, графики, сканера, etc.). Обычно на одном CD с драйверами;
    Если же продукт получен отдельно от "железа", использование такого ПО запрещено.
  • Пpогpаммы в Internet-е. Различаются в зависимости от типа лицензии. В сети можно найти любой нужный Вам софт, нужно только уметь искать. Программы можно закачать с:
    • web- и ftp-сайтов авторов (и фирмы, и частные лица);
    • файловых архивов (ftp-архивы, http-архивы). Самый знаменитый - "Tucows";
  • Рекламный CD. Иногда организации (напр. компьютерные журналы) периодически выпускают сборники ПО на CD-Rom-е, включая туда софт (freeware, shareware, demo), близкий к тематике выпуска.
  • Пиpатские копии. Это CD-Rom-ы (ранее - дискеты) на рынках, лотках, в киосках, etc. Является воровством и карается штрафом и конфискацией. Отмечу, что по постановлению Правительства РФ N421 от июля 2003 года запрещаются продажи с лотков пиратских аудио- и видео-CD, а к концу 2003 года это коснется и пиратских CD с компьютерными программами;
  • Копирование (на работе, у друзей, etc.). Является воровством и карается штрафом и конфискацией;
Необходимо отметить, что для ПО, поставляемого на CD, существует своя классификация:
  • jewel-упаковка = CD + регистрационная карточка;
  • box-упаковка = коробка + описание + CD + регистрационная карточка;
  • DVD-упаковка = пластиковый кейс + описание + CD + регистрационная карточка;
Jewel-упаковка называется также экономичной и имеет множество разновидностей (Jewel Case, Jewel CD, mini-slim jewel box, etc.)
В свете штрафов я рекомендую случае приобретения коробочных и OEM-версий продуктов сохранять все документы и компоненты приобретенного ПО, включая товарный чек.

         "... Просьба ногами не пинать, по газонам не ходить и провайдеру не стучать..."

· Лицензия (License) или условия использования программ. От латинского Licentia - разрешение, право. ПО защищено от несанкционированного использования законами об авторских правах. Законы предусматривают сохранение за автором ПО нескольких исключительных прав, одно из которых — право на производство копий ПО. Приобретение программного продукта — это приобретение лицензии (права) на его использование. Лицензия на ПО предоставляет официальное право на использование конкретной программы. Для каждой используемой программы необходима лицензия. Условия лицензии фиксируются в лицензионном соглашении конечного пользователя (EULA — End User License Agreement). Т.о. лицензия - официальный документ (разрешение), выдаваемое одним лицом другому, в которой излагаются обязанности сторон по использованию данного программного обеспечения. Стандартные лицензии, как правило, запрещают передавать ПО во временное пользование, прокат, сдавать в аренду. Всего имеется более 30 разных типов лицензии, вот пять самых распространенных в России:

  • Freeware - полнофункциональное ПО, распространяется бесплатно с согласия авторов. По смыслу к этой лицензии близко и GNU;
  • ShareWare - условно-бесплатное ПО, где авторы ограничивают его функции либо временем бесплатной работы (напр. 30 дней от даты первого включения), либо блокировкой части функций. Полнофункциональным становится после оплаты;
  • Beta Software - полнофункциональное бесплатное ПО (прототип), обеспечивающее тестирование новой версии продукта; имеет ошибки и как правило ограниченное время работы. Без права дарения и модернизации, часто без права копирования;
  • Demo version - специальная бесплатная версия ПО, демонстрирующая работу программы или ее прототипа. Все главные функции программы заблокированы или убраны. Может свободно копироваться и дариться;
  • Commercial License - платное (коммерческое) полнофункциональное ПО, без права копирования, дарения и модернизации. Действительно для количества ПК, указанных в лиценции;
Поясняя, что такое ShareWare, приведем текст: "...В мире приступили к выпуску shareware-кофеварок. Такой кофеваркой можно пользоваться совершенно бесплатно ровно 30 дней, после чего в случайные порции кофе добавляется пурген как напоминание о том, что пора бы и заплатить..."
Упомяну еще Microsoft Open License - это соглашение о приобретении лицензий от Microsoft-а. Предназначено для гос.структур (органов законодательной, исполнительной и судебной власти). Действует в пределах только 1 юр.лица. За счет невключения дисков и документации цена понижена до 50-70% коробочной.

· Бесплатная лицензия. В середине 80-х легендарный программист Ричард Столмен основал GPL или проект GNU (Gnu Not Unix). Его целью было создание совершенно открытой OS с доступными исходными кодами, а также всех необходимых для нормальной работы приложений. И не только полностью открытых, но и с гарантией, что эти программы будут открытыми и доступными на все времена. Столмен вместе с первыми версиями своих программ разработал особое лицензионное соглашение, GNU GPL (General Public Licence). Это соглашение гарантирует, что автор программы разрешает как угодно использовать свою программу, дополнять, изменять ее, но требует всегда публиковать исходный код программы и сделанных изменений. Таким образом, фирмы, создающие коммерческие закрытые программы, или не могут использовать программы из проекта GNU, или обязаны предоставить исходный код своих доработок. Упрощенно оно может быть вкратце изложено следующим образом:
- Пользуйтесь бесплатно, даже для извлечения выгоды.
- Не говорите, что это написано Вами.
- Не судитесь с нами, если что-то не работает.
- Делайте с ней всё, что Вам заблагорассудится.
- Любой, у кого есть усовершенствования и/или исправления, может предоставить свой код и он будет добавлен в исходные тексты системы.

Ecть cвободное ПО, а есть бесплатное ПО. Не путайте! Еще в 1983 году, при получении самой престижной в мире программирования премии им.Тьюринга, Кен Томпсон (Ken Thompson, создатель OS Unix) сказал пророческие слова: "...Нельзя доверять программам, написанным не Вами самими... Никакой объем тестирования не защитит Вас от использования ненадежного кода. По мере того, как уровень языка, на котором написана программа снижается, находить эти ошибки становится все труднее... "Хорошо продуманную" ошибку в микрокоде найти почти невозможно...".
Существуют четыре разновидности свободы пользователей программы:

  • Свобода запускать программу в любых целях (свобода N1);
  • Свобода изучения работы программы и адаптация ее к вашим нуждам (свобода N2). Доступ к исходным текстам является необходимым условием;
  • Свобода распространять копии, так что вы можете помочь вашему товарищу (свобода N3);
  • Свобода улучшать программу и публиковать ваши улучшения, так что все общество выиграет от этого (свобода N4). Доступ к исходным текстам является необходимым условием;
Но с Вас могут взять деньги за копирование программы на CD, за поддержку, за FAQ-ки. При дальнейшем распространении программы Вы не вправе вводить ограничения на свободу других.
Конечно бесплатная лицензия вызывает лютую злобу корпораций, получающих на этом миллиарды. В первую очередь - ненависть Microsoft. В лицензионном соглашении к бета-версии MS Mobile Internet Toolkit они объявили такое ПО "вирусным" (?!). А Стив Балмер - вице-президент MS (в интервью "Chicago Sun-Times", 06.2001г.) даже заявил, что бесплатный "Linux - это раковая опухоль, которая распространяется на всю интеллектуальную собственность, с которой соприкасается". Нет уж, скорее "...вирус, который устанавливает на компьютер, называется Windows.....".

Для россиян интересно ПО с бесплатной лицензией, которое разрешает неограниченное бесплатное использование и копирование. OS, ядро OS, интерфейсы OS, текстовые и графические редакторы, СУБД, сеть, игры и масса другого ПО объемом в тысячи мегабайт - все бесплатно и все на законной основе. Выигрыш в цене только на программах может составить от тысяч до десятков тысяч долларов. Для многих пользователей в России GPL-подобная лицензия - это единственная возможность легально снабдить себя полноценным набором ПО.
В настоящее время имеется несколько типов "халявных" категорий программного обеспечения, например:

[ Freeware (Свободное) ] [ General Public License (GPL) ] [ Lesser/Library GPL (LGPL) ] [ The Artistic License (PERL) ] [ Sun Community Source License (SCSL) ] [ Sun Industry Standards License (SISL) ] [ Berkeley software license (BSD) ] [ Mozilla Public License (MozPL) ] [ Netscape Public License (NPL) ] [ Open source (с открытыми исходными текстами) ] [ Public domain software (общественной собственности) ] [ Copylefted software (подчиняющееся "авторскому леву") ] [ Non-copylefted free software (Свободное, не подчиняющееся "авторскому леву") ] [ Semi-free software (Полусвободное) ] [ Proprietary software (Собственническое) ]
Отличаются они друг от друга в основном в двух компонентах: обязательном опубликовании изменениий кода и возможности продажи продуктов, созданных с использованием этого исходного кода.

         "... Верх упорства: набирать неверный пароль, пока компьютер не согласится..."

· О пиратских копиях западного ПО. Проблема пиратства существует везде и основная причина кроется не только в отсутствии денег у россиян для покупки западного ПО легально. Деньги накопить можно, но зачем?
По большому счету разница между "чистой" и ворованной программой состоит в возможности получения зарегистрированными пользователями поддержки со стороны фирм-производителей (неуплату налогов не рассматриваем). Т.е. в цену легального продукта закладываются и расходы на техническую поддержку, которую мы по сути не получаем. Если службы технической поддержки (СТП) реально нет, то и покупать фирменное западное ПО нет смысла (как это не прискорбно)- все равно с вопросами придется обращаться к друзьям. Что конечно же не оправдывает пиратства. Кстати, установка программ на большее количество ПК, чем это предусмотрено условиями лицензии - тоже пиратство.
По результатам исследования "International Planning and Research" для Ассоциации Business Software Alliance, уровень пиратства в сфере ПО делового назначения в конце 20 века в среднем по всему миру достигал 37%. В абсолютных показателях это означает ущерба 12 миллиардов долларов США в год. Уровень пиратства в России - 88%, пятое место (Вьетнам - 97%, Китай - 94%, Индонезия - 89%, Украина - 89%).
Пиратское ПО несет прямую угрозу для тех, кто его приобретает - в нем может недоставать тех или иных ключевых компонентов и документации; оно может содержать дефекты или быть непригодно к использованию из-за брака в процессе "взлома". Пираты часто выдают beta-версию за release, что в итоге ведет к многочисленным "зависаниям". Т.е. на обложке CD-Rom-а нет никаких прямых или косвенных свидетельств того, что предлагаемая версия не является финальной.

         "...Самый страшный вирус - это продвинутый Юзверь..."

· Компьютерные вирусы получили распространение в 70-х годах. В 1970г. появилась самомножающаяся программа Creeper (для сети APRAnet, автор Bob Thomas). В 1974г. была написана Rabbit (для IBM), в 1975 - самокопирующая игра Animal (для Univac 1108). К 1980 году относится появление первой научной публикации - "Самовоспроизводящиеся программы" Й.Крауса. В 1981-82 появился первый бутовый вирус (для Apple II). К 1985 году относится первое упоминание идеи счетчика в бут-секторе и появился список "Грязная дюжина"("The Dirty Dosen", опасные загружаемые программы, автор TomNelf). Зимой 1984 года Andy Hopkins написал Chk4Bomb и BombSqad, а в начале 1985 года Gee Wong - резидентную DProtect. Это были первые программы защиты (ныне антивирусы). В 1987 году были зарегистрированы первые три случая массового заражения ПК вирусами. Первые вирусы в СССР зарегистрированы в 1988 году ("чивир", "венский", "падающие буквы"). С осени 1989 начал распространяться антивирус Aidstest - полифаг Д.Н.Лозинского. Противостояние началось....
Еще пророческие слова 1983 года от Ken Thompson: "...Надвигается взрывоопасная ситуация... действия этих ребят скоро будут наказываться годами тюрьмы... Проникновение в компьютерные системы должно накладывать на человека такое же клеймо, как проникновение в чужую квартиру...".
Согласно статистике (с viruslist.com), основная масса вирусов - это VBS-вирусы, Интернет-черви (типа LoveLetter) и макро-вирусы (размножающиеся в документах MS Office). Приводимые данные свидетельствует о том, что:

  1. пользователи неграмотны и неосторожны, т.к. запуск vbs-скриптов и действие Интернет-червя инициирует сам пользователь! Как и включить/отключить защиту от макровирусов;
  2. компании Microsoft абсолютно наплевать на вирусную безопасность пользователя. Например, в любом описании вируса обратите внимание на из года в год повторяющиеся слова - "вирус рассылает свои копии через адресную книгу MS Outlook (Express)"... Ну а то что MS Word - практически единственный источник макро-вирусов, уже все даже привыкли...;
  3. Интернет и пиратские CD - самый массовые источники вирусов
При этом полное отключение опасных функций (автоматической рассылки, авто-чтения скриптов из приходящих писем, запуска макросов с потенциально опасным содержимым) не является чем-то невозможным. Встает вопрос - неужели, зная все это, MS не может внести в программы небольшие изменения? А если она этого не делает, то может Microsoft-у выгодно массовое распространение вирусов? В сентябре 2002г. Брайан Валентайн, старший вице-президент компании Microsoft, наконец-то официально подтвердил общеизвестный факт - программы корпорации Microsoft являются абсолютно не защищенными от вирусов и внешнего взлома - "...продукты компании просто не созданы для безопасности...".
В новой версии MS Windows (Win XP) появилась (ранее отсутствовавшаяся) изумительная возможность для хакеров - инструмент для формирования IP-пакетов (аналогичный Unix sockets). Если ранее серьезную атаку можно было предпринять только из под Unix (Linux), требующих профессионализма, то теперь этот опасный инструмент попал в руки к любому психу. Ждите "хакерного 9 вала" и "благодарите" Microsoft.

         "... Hажми Reset, забудь пpоблемы ..."

· Офисные (интегрированные) пакеты. ПО представляет собой набор нескольких программных продуктов, объединенных в единый инструмент. Как правило, пакеты содержат некоторое ядро, обеспечивающее возможность тесного взаимодействия между составляющими. Часто все программы пакета выглядят единообразно, что облегчает как их освоение, так и использование. За последние 10-12 лет пакеты превратились из набора разрозненных средств в мощный интегрированный набор приложений. Чтобы объективно оценить все эти пакеты, нужно повесить рядом с монитором табличку с ценами. Существующие Office:

[ Ability Office ] [ Applix Java Office ] [ AnywareOffice ] [ Corel WordPerfect Office ] [ Do Office ] [ Gnome Office ] [ KOffice ] [ LotusSmartSuite ] [ Microsoft Office ] [ OpenOffice ] [ StarOffice ] [ Русский офис ]
Обычно интегрированный пакет включает в себя текстовый редактор, электронную таблицу, программу презентационной графики, органайзер, СУБД, электронную почту, браузер. Разные пакеты имеют не только близкий интерфейс, но даже их меню почти повторяется. Основные отличия пакетов - в стоимости (1), функциях и удобстве составляющих программ (2), совместимости форматов (3), многоплатформенности (4). Ну а в мелочах - в папке авто-сохранения файлов (в Windows -"My Documents"). Для user-ов (по недомыслию любящих все держать в "Мои документы") напомню, что при повреждении FAT-овой системы в первую очередь "летят" каталоги с русскими длинными именами, что ведет к полной потере содержимого каталога.

· Пакеты KOffice (KWord, KSpread, KPresenter, Kivio, Kontour, Krita, Kugar, KChart от "KDE Team"), Gnome Office и Do Office (HancomWord, HancomSheet, HancomPresenter, HancomPainter) от корейской Hancom Linux Inc.- только для мира Linux (Unix). При этом KOffice еще называют KDE Office, а Do Office прекрасно совместим с Microsoft Office 95/97/2000. GNOME Office - это мета-проект для среды GNOME Desktop c cоставом пакета из приложений:

  • текстовый процессор AbiWord;
  • электронные таблицы Gnumeric;
  • Web-браузер Galeon;
  • две программы работы с векторной графикой Sodipodi, Sketch;
  • программа просмотра изображений Eye Of GNOME;
  • программа работы с растровой графикой GIMP;
  • двe почты Balsa, Evolution;
  • программа работы с чертежами Guppi;
  • программа работы с диаграммами Dia
  • два ПО управления проектами MrProject, Toutdoux;
  • ПО управления финансами Gnucash;
  • ПО для создания презентаций Achtung;
  • программа работы с БД GNOME-DB;
  • ПО коммуникаций Gfax;
По своей функциональности KDE Office и GNOME Office сегодня - лучшие интегрированные пакеты в мире. И кстати - полностью бесплатные.

· Пакет Corel WordPerfect Office имеет две редакции: Standard Edition , Professional Edition и стоит $399. Состоит из WordPerfect, QuattroR Pro, Corel Presentations, CorelCENTRAL, Paradox, TrellixR 2, Dragon NaturallySpeaking, Pocket Oxford Dictionary, Net2Phone, Corel PHOTO-PAINT, Corel Print Office, Visual Basic, HTMLCorelWeb.Designer, CorelWeb.Move, CorelWeb.Gallery. При этом в офис также входит ПО распознавания речи (Dragon NaturallySpeaking), небольшая издательская система (Corel Print Office) и словарь определений (Pocket Oxford Dictionary)! Текстовый процессор WordPerfect до сих пор - лучший редакток больших документов (в отличии от MS Word), а также для документов, перемещаемых между Mac-UNIX-Microsoft-платформами. Пакет работает под HP-Unix, IBM AIX, SCO, Sun Solaris, Sun SunOS, Digital Unix, Macintosh, Microsoft DOS, Microsoft Windows, Linux. Документы, созданные WordPerfect на одной платформе, могут быть прочитаны, отредактированы и распечатаны на других платформах. Есть "домашний пакет" - WordPerfect Family Pack 3 ($100), включающий WordPerfect (редактор), Quattro Pro (таблицы), Corel Print House (графика), Corel Photo House (рисование и обработка изображений), Cybersitter (фильтр ограничения Internet-доступа детей!), интерактивный атлас мира Комптона (!), Mavis Beacon Teaches Typing (обучающая программа печати на клавиатуре!), McAfee VirusScan (антивирусный пакет). Но коммерческий CorelOffice в России почти не распространен, даже у пиратов его практически не бывает.

· О пакете "Русский офис" (Лексикон, Диско-Командир, Декарт, Сократ) или реализованная глупость за $40... Основа офиса - знаменитый редактор Lexicon. Его DOS-версия в начале 90-х - действительно лучшая (создатель - Евгений Веселов). Потом пришел Word и "лекса" умер. А феврале 1997г. компания "Арсеналъ" представила реинкарнацию -"национальный" Лексикон'97 под Windows. Но в программах "национальность" имеет смысл только для некоторых программ (бухгалтерских, кадровых, правовых) и то - только из-за идиотизма российских законов. В "Русском офисе" нет ни одной чисто национальной функции. Потенциал заложен большой, реализован кое-как и... никому не нужен. Т.к. либо офисный пакет используют во всем мире, либо нигде.

· "StarOffice". У пакета есть несколько разных версий. Полностью (100%) бесплатна только версия 2001 года (v.5.2), что сделано для увеличения продаж других версий.

Soft \ Office | MS Office | OpenOffice | StarOffice 5.2. | Lotus Office
Деньги? | ~$400 | Бесплатно | Бесплатно | $399
Русский интерфейс | Да | Да | Да | Нет
Операционная система | Windows | Windows, Linux | Windows, Linux, Solaris, OS/2 | Windows, OS/2
Межплатформенная совместимость | Нет | Да | Да | на Java
Не-изменяемые форматы файлов | Нет | Да | Да | Да
"Чужие" форматы файлов | Нет | Да | Да | Да
Служба управления | Нет | OpenDesktop | StarDesktop | SmartCenter
Доступ к исходному коду | Закрыт | Свободный | Свободный | Закрыт
Наименования программ (справка)
Текстовый редактор | "MS Word" | "Open Writer" | "Star Writer" | "Lotus WordPro"
Электронная таблица | "MS Excel" | "Open Calc" | "Star Calc" | "Lotus 1-2-3"
Cоздание презентаций | "MS PowerPoint" | "Open Impress" | "Star Impress" | "Freelance Graphics", "Corel Presentation"*
Векторная графика | --- | "Open Draw" | "Star Draw" | "Lotus ScreenCam"
База данных | "MS Access"* | "MySQL"* с ODBC-драйверами | "Star Base" | "Lotus Approach"
Планирование мероприятий | "MS Schedule+" | "Mozilla" | "Star Schedule" | "Lotus Organizer"
Электронная почта | "MS Outlook" - "MS Exchange" | "Mozilla Mail" | "Star Mail" | "Lotus Notes"
Cлужбa новостей |  | "Mozilla News" | "Star Discussion"
Браузер | "MS Internet Explorer" | "Mozilla" | из OS | + InternetDrawers, + InternetTextSearch, + PublishtotheInternet
HTML-редактор | "MS Publisher"*, "MS FrontPage"* | "Mozilla Composer", + HTML-конвектор OpenOffice | --- | "Lotus FastSite", + LiveLinks, + Web SmartMasters
файлы *.pdf (Adobe Acrobat) | --- | "Mozilla" | --- | ---
прочее ПО | "Task Panes", "Smart Tags" | "Open Math", "GNU Privacy Guard" | --- | "TeamReview", "VersionManager", "LotusComponents"

* - в обычную конфигурацию пакета не входит. Или в расширенной (профессиональной) или дополнительно. StarOffice и OpenOffice обладают межплатформенной совместимостью (работают на любой платформе). Самый молодой - OpenOffice.org (версия 1.0 выпущена 01 мая 2002г.). Часто применяют одинаковый интерфейс приложений, не зависящий от того, какого типа документ редактируется. Командой меню программу можно превратить и в Web-редактор, и в Web-броузер, и в электронную таблицу, и в графический редактор, и в систему электронных презентаций, и в текстовый процессор. Это давно у всех (кроме Microsoft конечно).

· Пакет Microsoft Office - самый слабый и самый глючный, но тем не менее - самый распространенный в России ( "...мыши плакали и кололись, но продолжали жрать кактус..." ). В каждой новой версии компания Microsoft под бурные рукоплескания придурков выдает то, что в других Office уже имелось 3-5 лет назад. Не говоря уж о MS-поддержке вирусов и беспрерывной смене форматов. Есть следующие версии:

[ MS Works ] [ MS Office 95 ] [ MS Office 97 ] [ MS Office 2000 ] [ MS Office XP ] [ MS MacOffice 98 ] [ MS MacOffice 2001 ]
Пара слов о мерзавчике... MS Office XP. "ХРюшкин" пакет в максимальном варианте установки занимает на диске 400Мб, а для поддержки форматов прошлых версий требуются дополнения на еще почти 14Мб. Русская Office XP представлена Microsoft-ом 19 сентября 2001 года. Формат файла новой версии СУБД Access опять изменился. Не надейтесь - XP не стала надежней. Как и раньше, приложения "виснут" с завидной регулярностью. Но теперь заранее всплывают предупреждения о нехватке системных ресурсов :) А функция Save Autorecover info (автосохраняет документ) обеспечивает "лохам" иллюзию безопасности. Включенные Smart Tags (автопроверка, смарт-теги) в большом документе = мертвое зависание OfficeXP. Вообще сбойность диаграмм увеличилась просто резко. Средство встроенного перевода не видит установленных русских словарей. Мастер сохранения настроек - практически бесполезен. Как обычно, идет раздувание размера всего. Размер DOC-файлов в OfficeXP увеличился почти в два раза! "Распух" даже Word`овский Normal.dot, что блокирует простейшую проверку на вирусы. Вот уж воистину "...MS Office совместим только с одним форматом: "format C: ..." .
Внимание! Office XP предлогает отправить отчет об ошибке. А в отчет будет включены и все данные о пользователе (т.е. о Вас и Вашем пиратском CD-Rom-е!). Этакий донос в духе 1937-го... Есть мнение, что MS выгодно массовое распространение вирусов, чтобы объяснять потерю информации в результате столь частых глюков в продуктах MS Office.
Согласно высказываниям официальных лиц MS, Office XP планируется как последнее приложение, распространяемое (т.е. продаваемое) в виде дистрибутива, после инсталляции которого пользователь получает право пользоваться им в течение неограниченного срока. Все следующие приложения будут распространяться по подписке, то есть пользователь будет приобретать право использования программы только в течение определенного срока, по окончании которого функции блокируются (полностью или частично). Подписка будет стоить меньше, чем дистрибутив с неограниченным сроком использования. MS уже проводит подобный эксперимент в Австралии. И для MS корпорации это будет означать практически гарантированный спрос на ее продукты, т.е. халявы - не будет.
Пользователи, желающие установить MS Office под другими OS, могут воспользоваться пакетом CrossOver Office от компании CodeWeavers). Это программное решения для запуска Windows-приложений в средах Linux/UNIX, дающее возможность работы файлов проприетарных форматов, разработанных Microsoft (в том числе Word, Excel, PowerPoint, Outlook и Internet Explorer и т.д.). Стоимость - $54,95 за одну лицензию частного лица и/или $1195 за серверную. Напр. так поступил Джонсонский космический центр NASA. При этом инсталлировать MS-Office можно прямо с сервера в локальной сети.

         Если что-то само плывет к вам в руки, присмотритесь - возможно, оно просто не тонет

· Поставил новую версию? Ну ты и "лох"! Как известно - Россия славится дураками. А в компьютерном мире дураки очень любят новые версии. Вне зависимости от социального статуса и толщины кошелька, толпы "лохов" при выходе у soft-производителя очередной версии немедленно ее инсталлируют. И еще хвастаются своим идиотизмом друг перед другом. С радостным похрюкиванием ставят даже beta-версии и рабочие build-ы! Вопрос к "чайникам", еще способным думать - а зачем Вам новая версия вообще? Зачем это нужно производителю - понятно - денег снять. А пользователям-то зачем? При этом проблему пиратства вместо необходимости оплаты новой версии личными кровными - не затрагиваем. Смотрим только функции, баги, быстроту работы и т.п. Автор знает только одну вещь, которую следует обновлять как можно чаще - антивирусную базу. Задумайтесь (те, кто еще может думать) над тремя простыми вопросами:
- Чем конкретно Вас не устраивает старая версия?
- Вам что, так не хватало в старой версии каких-то функций, что нужна новая?
- На сколько процентов Вы использовали старую версию?
На больших пресс-конференциях, посвященных выходу "в свет" новой версии, изредка все же звучит вопрос здравого смысла - "...ну а что нового-то появилось?...". И всегда докладчик начинает мяться, краснеть-бледнеть... в итоге выдавая какую-то мелочь (кроме потока словоблудия). Для примера рассмотрим всем известный Microsoft Word - последних есть аж 5 windows-версий редактора, в которых уже 3 раза (вот идиотизм-то!!!) менялся формат.

[ MS Word 6 ] [ MS Word 95 ] [ MS Word 97 ] [ MS Word 2000 ] [ MS Word XP ]
В 2002 году около 32% офисов использовали в своей работе Word 97. Крайне интересны аналитические данные по проценту использования его функций. Обычный user использует мощности редактора на 2-3%. Всего! Продвинутый user - до 5%. А остальные 95% - увы, либо люди не умеют, а чаще просто не нужны. Для наглядности - возьмем крайности: Word_6 (из старой Windows 3.11) и Word_ХР. Объем - резко вырос, появилась поддержка inet-функций, качество - резко упало, скорость работы - упала, удобство настроек - упало, с русским пошли проблемы, etc. Но все, что делает обычный пользователь на Word_ХР, легко делается и на Word_6. Все делается на самой старой версии! Итак, господа "чайники" - зачем козлу баян? Вот зачем?!!!
Вместо заключения: конечно изредко бывает, что новая версия действительно необходима. Скажем, в архиваторе произошла смена алгоритма сжатия. Например WinRar 2.x-3.x. Или в Вашем графическом редакторе появилась поддержка любимого расширения файла. Или просто - крайне необходимая функция. Но это бывает так редко! А ведь большинство "лохов" ставит версию просто так - только потому что она новая... Таким "лохам" могу только посоветовать посильнее побиться своей тупой головой об стенку - вдруг мозги появятся? Ну вдруг...

         Чем больше пpогpамма необходима, тем больше в ней ошибок (закон пpопоpциональности)

· Золотой фонд... В мире имеются сотни тысяч разнообразных программ. Какие же software действительно нужны рядовому пользователю под Windows? У каждого опытного компьютерщика есть личный набор soft-a, который всегда нужен. Далее обычно меняются только версии. Этим списком я и делюсь. Условия использования программ помечены: бесплатные - Free, с ограничениями - Share, коммерческие - License. Описание целей программ - в соответствующих разделах Азбуки. Итак - необходимые и незаменимые:

  • Архиваторы: WinZip (Share), WinRar (Share), Arj (DOS, Free).
  • Антивирусы: или "Norton Antivirus"(License) или "AVP Касперского"(License). На одну OS вместе их не ставить! "Dr.Web" не советую. И не забывайте, что любому антивирусу нужно почаще обновлять базы.
  • Программы чистки Win-регистра: "RegCleaner"(Free), "RegRun"(Free).
  • Системные винчестера: "Partition Magic"(License), "Norton Ghost"(License).
  • Менеджер загрузки OS: "OS/2 Boot"(Free).
  • Файловые менеджеры: "Nortom Commander"(Share, v.4), "Far"(Share).
  • Просмотрщики графики: "ACDSee"(License), "IrfanView"(Free). На любителя - "FineView"(Free), "Image Guider"(Free), "PicaView"(License).
  • Конвекторы графики: "Graphic Workshop"(GWS, License). Или встроенные конвекторы просмотрщиков.
  • Редактор графики: "Corel Xara"(Share). Для "профи" - "Adobe Photoshop"(License), "CorelDRAW"(License). На профи-любителя - "Adobe Illustrator", "Macromedia Flash".
  • Сканирование и обработка: "iPhotoPlus"(Free), "FineReader"(License).
  • Программы ftp-закачки файлов: "ReGet"(License), "GetRight"(License). На любителя - "Go!Zilla", "FlashGet".
  • Проигрыватель музыкальных файлов: "WinAmp" c VQF-Plugin-ом (Free). Кстати он же и редактор Mp3 ID Tag-ов.
  • Конвектор музыкальных файлов: "CDex"(Free). Wav-Mp3, Mp3-Wav, изменение битрайта.
  • Звонилки: "MDialer"(Free), "EType Dialer"(Free).
  • Браузеры: "Mozilla"(Free), "Opera"(Share). На любителя - "Netscape Communicator"(Free), "Netcaptor"(Free). "MS Internet Explorer"(Free) расчитан на "лохов" и крайне неудобен (фрэйм, избранное, доносы и т.д.).
  • HTML-редактор: "CuteHTML"(Share). Мазохистам с "MS Front Page" - к психиатру.
  • Inet-общение: "ICQ 200*"(Free), "Миранда"(Share). Правда, "аськой" более не пользуюсь сам и Вам не советую - очень плохо с защитой.
  • Почта: "TheBat!"(Share), "UUPC"(DOS, Free). Кстати: MS Outlook - это ужасное нагромождение маразма и глюков, с кучой дыр в защите.
  • Перекодировщики русского: "Shtirlitz"(Free), "Wincode"(Free), "Цифирица"(Free), "CodePage Translator"(Free).
  • Домашняя бухгалтерия: "Orakl-Деньги"(License).
  • Редакторы документов: "Adobe Acrobat"(License), "MS Word"(License), "CryptEdit"(Share), "TextViewer"(Free), "R-Win"(Free). MS Word только старый (!) v.6 (с установленным конвектором на 97/2000), а CryptEdit - v.5 и выше.
  • Переводчики и словари: "Stylus"(License), "Сократ"(License), "Lingvo"(License), "ОРФО"(License).
  • CD и DVD: "Nero Burning ROM"(License), "Roxio Easy CD Creator"(License), "DVD Genie"(Free), "CDR Identifier"(Free), "DVD Region-Free"(License).
Все эти программы - мощные и удобные, но без излишних наворотов и препятствий. За исключением, пожалуй платности (у некоторых). Но уплаченные деньги эти прекрасные software быстро оправдают.

Вместо эпилога - совет: полюбите старый "Nortom Commander"(v.4). Только v.4 - DOS-овскую. От более поздних своих версий этот Nortom резко различается объемом. Старенький v.4 = всего 340Кб, а напр. Wind-овый NС v.5 = 3,7Мб. Несмотря на древность v.4 и отсутствия многих удобств (напр. нет поддержки длинных имен файлов и русских букв), только он поможет с вирусами и удалением Windows-"закрытых" файлов. Во-первых, открывая вирусный файл в NС v.4, Вы не вызовете активации "гадости". Ведь windows-вирус не может "жить" в DOS-е, а практически все новые вирусы - под Windows. Напр. автор таким образом открывает сомнительные e-mail-ы (предварительно экспортировав их в DOS-файл, не открывая). Во-вторых, NС v.4 "тупой" и ему безразлично, что windows запрещает удалять какой-то файл - NС все равно файл убивает.
Любые Windows-заменители (напр. "Far") для этих целей использовать нельзя! Хотя внешне они очень похожи, но это принципиально разные программы.

© Dmitry Belousov
http://www.orakul.spb.ru
ноябрь 2001г.-декабрь 2002г.


"Азбука РС" Дм.Белоусова, сеть и ее аппаратура

Компьютерная сеть

•

Ethernet
Internet
WWW

•

Cетевые карты
Терминология
Модель OSI

•

Сервера
UPS-ы
Шины

История развития компьютерных сетей насчитывает уже несколько десятилетий. Но широкое распространение компьютерные сети получили в 80-х годах 20-го века - с появления персональных компьютеров. Сеть - это совокупность компьютеров (хостов, hosts), которые могут связаться друг с другом, часто полагаясь на услуги ряда выделенных компьютеров, передающих данные между участниками. Хостом может являться не обязательно полноценный компьютер, им вполне может быть X-терминал или интеллектуальный принтер. Сети бывают локальные (типа Ethernet) и глобальные (типа Internet). Связь невозможна без языка или кода. В сетях языки называются протоколами (protocols). Но это не письменные протоколы, а точнее высоко формализованный код поведения. Т.е. протоколы, используемые в компьютерных сетях, это только очень строгие правила для обмена сообщениями между компьютерами.
Уже сейчас есть сферы человеческой деятельности, которые принципиально не могут существовать без сетей (например работа банков, крупных библиотек, etc.). Сети также используются при управлении крупными автоматизированными производствами, газопроводами, электростанциями и т.п. Для передачи данных компьютеры используют самые разнообразные физические каналы, которые обычно называются средой передачи.
Рано или поздно, но каждый пользователь ПК сталкивается с необходимостью подключить ПК к сети (временно или постоянно). Это может быть объединение нескольких домашних ПК или подключение компьютера к сети дома или офиса.

По типам и физическому устройству все сети подразделяют на:
  • локальные
  • региональные
  • глобальные
  • кабельные
  • беспроводные
  • электрические
  • одноранговые сети
  • с выделенным сервером
где к кабельным сетям относится связь через телефонный кабель, коаксиал, витую пару, экранированную витую пару, оптоволокно; а к беспроводным сетям - через радиочастотные системы, технологию Bluetooth, инфракрасные каналы (ИК) и оптические системы.
Каждая сеть имеет топологию - т.е. физическую или электрическую конфигурацию кабельной системы и соединений сети. Термин "топология сети" характеризует физическое расположение компьютеров, кабелей и других компонентов ЛВС (другими словами - скелет сети).

         "... Не так страшна Ethernet, как ее спецификации...

· Локальная сеть (локальная вычислительная сеть, локальная компьютерная сеть, структурированная кабельная сеть, СКС, ЛС, ЛВС, "сетка", "локалка", Ethernet, Local Area Networks, LAN). Простое определение - это совокупность серверов и рабочих станций. Полное определение - это распределенная система, построенная на базе локальной сети связи и предназначенная для обеспечения физической связности всех компонентов системы, расположенных на расстоянии, не превышающем максимальное для данной технологии. Выбор топологии сети зависит от Ваших условий, задач и возможностей. Или же определяется стандартом используемой сети. Допускается соединить часть компьютеров в сеть с одной топологией, другую часть - в сеть с другой топологией. Например далее можно затем соединить эти сети между собой по третьей топологии. Правильнее считать Ethernet не сетью, а типом спецификаций на кабельную структуру и передачу сигналов. Изначально разработанный корпорацией Xerox в конце 1970. В 1980 году Digital Equipment Corp. (DEC), Intel и Xerox (происхождение термина DIX основано на первых буквах этих компаний) начали совместное продвижение сети передачи данных по коаксиальному кабелю. И опубликовали "Blue Book Standart" для Ethernet версии 1. Этот стандарт был позднее дополнен и в 1985 году вышел Ethernet-2. Затем был проект 802 IEEE ("Institute of Electrical and Electronic Engineers"), который использовал версию 2 Ethernet. Стандарт 802.3 IEEE в основном взаимозаменяем с стандартом Ethernet-2 DIX (главное отличие в заголовке сетевого пакета).
Существует всего пять основных типов топологии:

  • Топология "Общая Шина" (Bus, линейная). Все компьютеры подключаются к одному кабелю. На его концах должны быть расположены терминаторы. В качестве кабеля используется витая пара или коаксиальный кабель (редко). Нарушение общего кабеля или любого из двух терминаторов приводит к выходу из строя участка сети между этими терминаторами (сегмент сети). Отключение любого из подключенных устройств на работу сети никакого влияния не оказывает. Увеличение количества соединений увеличивает вероятность выхода сети из строя. С другой стороны, сеть линейной топологии гораздо легче прокладывать и для маленьких сегментов требуется меньше проводки. Например, по такой топологии строятся 10 Мегабитные сети 10Base-2 и 10Base-5. А в 100Мбитных сетях такая топология не применяется. Это LAN-топология.
  • Топология "Звезда" (Star, звездообразная). Каждый компьютер (или периферия) подключен отдельным проводом к отдельному порту устройства, называемого концентратором (Hub). Если между устройством и концентратором происходит разрыв соединения, то вся остальная сеть продолжает работать. При выходе из строя концентратора сеть перестанет работать. Например, по такой топологии строятся 100 и 1000 Мбитные сети. Это LAN-топология.
  • Топология "Кольцо" (Ring, кольцевая) - способ соединения компьютеров в сеть, когда данные в сети передаются последовательно от одной станции к другой. Как правило, данные передаются только в одну сторону, поэтому, чтобы передать сообщение рядом стоящему, но находящемуся против движения данных компьютеру, нужно пройти все компьютеры в сети. Преимущество - простота управления, недостаток - возможность отказа всей сети при сбое в канале между двумя узлами. Это LAN-топология.
  • Топология "Древовидная" (Tree, древовидная) - каждая группа компьютеров подключаются к одному хабу, хабы могут каскадно соединяться друг с другом, oбразуя древовидную топологию с единственным хабом в вершине. Древовидную топологию также иногда называют структурой иерархической звезды. Максимальное количество пользователей - 1024 шт. Это LAN-топология.
  • Топология "Mesh" (ячеистая, сеть без инфраструктуры) - схема соединения компьютеров в сеть, при которой физические линии связи установлены со всеми рядом стоящими компьютерами. Достоинства данной топологии в ее устойчивости к отказам и перегрузкам, т.к. имеется несколько способов обойти отдельные узлы. Можно сказать, что все элементы сети соединены напрямую друг с другом. Это Internet-топология. Частным проявлением данной конфигурации является полносвязная ("Full Mesh") топология.

· Принцип работы ЛВС... Локальная вычислительная сеть состоит из множества фрагментов, размазанных между рабочими станциями и серверами. Информация между элементами отправляется порциями ("пакетами"). Слушают сеть - все ПК в сети, но ПК опознавшая в начале пакета свой МАС-адрес, переносит его в буфер сетевой карты. После получения нескольких пакетов шлется назад подтверждение об их приеме и информация переносится в зарезервированные для этой карты адреса оперативной памяти компьютера. При отсутствии подтверждений - через тайм-ауты идут повторные посылки, а при их не подтверждении - пользователь видит на экране - "Сеть недоступна". Передающий ПК одновременно прослушивает сеть. Если при передаче обнаруживает активность в сети (передача другой станции, образуется "коллизия", collision) - по признаку двухкратного напряжения в кабеле в результате наложения на передаваемый сигнал другого внешнего сигнала, либо присутствия сигнала в приемном тракте. При этом передача прерывается и возобновляется через случайно взятый тайм аут (backoff аlgorithm).

· Международный Институт Стандартизации ISO (International Standart Organization) предложил модель OSI (model of open system interconnections), состоящую из семи уровней архитектуры компьютерных сетей (или уровни стека сетевых протоколов):

7 | прикладной (App) | Окно для доступа прикладных процессов к сетевым возможностям, напрямую поддерживает приложения пользователя (программное обеспечение для передачи файлов, доступ к базам данных, электронная почта), управляет общим доступом к сети, потоком данных и обработкой ошибок
6 | уровень представления (Pr) | Управляет форматами данных, транслируя их (узел отправителя) в общепонятную форму, а потом (узел получателя) обратно в специфическую для приложения (шифровка, расшифровка файлов, сжатие, распаковка данных, преобразование форматов данных)
5 | сеансовый (S) | Позволяет приложениям на 2-х узлах установить соединение, управляет всем диалогом между двумя процессами, следит за доставкой сообщений, кроме этого обеспечивает безопасность (проверка пароля)
4 | транспортный (Tr) | Обеспечивает эффективную доставку всех пакетов от источника до места назначения (через все узлы)
3 | сетевой (Net) | Адресация данных и трансляция логических адресов в физические, оперирует пакетами данных
2 | канальный (Dl) | Структурирует данные и обеспечивает их доставку от узла к узлу (формирует поддающиеся управлению логические порции данных -frame; frame содержит сами данные, источник информации и место назначения передачи)
1 | физический (F) | Отвечает за передачу двоичных данных по сетевому кабелю.

На кабельные соединения Ethernet существуют большое количество ограничений, которые зависят от используемой среды передачи (т.е. от типа кабеля). В первую очередь это ограничения по длине сегмента:

  • 10Base2 - ограничено до 185 метров (607 футов) на один кабельный сегмент без повторителей. 10Base2 известен как тонкий Ethernet;
  • 10Base5 - ограничено до 500 метров (1640 футов) на сегмент без повторителей;
  • 10BaseF - зависит от технологии передачи сигналов и типа используемых кабелей (среды передачи), но может достигать 2 километров;
  • 10BaseT - в общем, принимается максимальное расстояние 100-150 метров, но в действительности, все зависит от затухания сигнала в децибелах (11,5 db максимальное затухание от источника до приемника);
  • 10broad36 - ограничено до 3600 метров (2,25 мили);
10Base2, 10BaseT и т.д.- это IEEE-шные имена для различных физических типов Ethernet. "10" обозначает скорость передачи сигнала 10MHz, "Base" - означает "Baseband", "Broad" - "Broadband", T - обозначает "twisted pair" - витая пара и 10BaseF , где F обозначает "fiber" - волокно. Кроме длины, между любыми двумя станциями в сети имеются ограничения по количеству повторителей и кабельных сегментов.

· Телефонная проводка... В качестве среды передачи данных может использоваться телефонная проводка в квартире или офисе. Но это все будет работать, только если все розетки соединены параллельно, а не через мини-АТС. Используется стандарт Home PNA (Phoneline Network Alliance). Скорости достигают 10Mbit.

· USB-сети... В качестве среды передачи данных используется USB-шина. Возможно объединение до 16 ПК в сеть со скоростью до 12Mbit/s. Поддерживаются все возможности USB - питание через шину, Plug&Play. Для объединения с проводной сетью достаточно одного, уже подключенного к ней ПК с портом USB.
USB-сети - это интересный вариант организации домашней сети, но на взгляд автора, у Bluetooth-сетей больше перспективы.

· Беспроводные сети... Технология, не требующая прокладки проводов и предоставляющая уникальные возможности по подключению мобильных пользователей. Сегодня она обеспечивает работу на скорости до 11Mbit/s на расстояниях порядка 100м в помещении и 300 за его пределами. В первую очередь это технологии Bluetooth и GPRS.
В 2003 году принят стандарт беспроводной связи IEEE 802.16a, описывающий спецификации устройств, использующих частотный диапазон от 2 до 11 ГГц. Но не решен вопрос с тем, считать ли 802.11 и 802.16 дополняющими друг друга стандартами, или же стандартами, конкурирующими в определенных частотных диапазонах. На взгляд автора 802.16a предназначен для построения MAN (Metropolitan Area Networks, транспортные сети), а 802.11a – для локальных беспроводных WLAN (Wireless Local Area Networks). Стандарт описывает три физических уровня: первый работает на одной несущей частоте и предназначен для специальных сетей, второй, основной, использует 256 несущих и мультиплексирование по ортогональным несущим (OFDM) и третий, OFDMa с 2048 несущими, предназначен для выборочных трансляционных приложений и согласования связанный транспортных сетей.
До появления стандарта IEEE 802.11b большинство беспроводных устройств работали на скоростях до 2Mbit/s и были несовместимы между собой. Они продаются до сих пор, будьте внимательны!
Существует возможность подключения ПК к беспроводной Wi-Fi сети. Например, модуль WL-140 (от компании ASUS) оборудован Plug-n-Play интерфейсом USB 1.1 и может быть расположен в любом удобном месте (в т.ч. на стене или на потолке). Модуль совместим со спецификациями стандарта IEEE802.11b, поддерживает 40- и 128-битное шифрование по протоколу WEP, способен поддерживать обмен данными со скоростью 11 Мбит/с с автоматическим переключением в режим 5,5, 2 или 1 Мбит/с. Габариты модуля всего 126,9 x 75,8 x 37,96 мм, вес - 75 граммов.

· Электрические сети... Сегодня уже удалось добиться скорости передачи даных порядка 4 Мб/сек (компания "Consolidated Edison") при ориентировочной стоимости доступа в $30/месяц. Но инфраструктура обычных электрических сетей сама по себе непригодна для передачи данных (даже на Западе). На электрических подстанциях (раз) и на стороне клиентов (два) необходимо устанавливать дополнительное оборудование (коммуникационные устройства), выделяющее информацию из силового сигнала. Если такого оборудования не будет, данные будут потеряны при преобразовании напряжений на трансформаторе.
Плюсы подобных сетей очевидны - для подключения к Internet-у достаточно наличия в доме свободной розетки. Но в бывш.СССР это малореально (см. главу "Электричество в России" раздела UPS-ы).

· Internet как LAN... Компания Kontron Embedded Modules первой представила модуль WEBasDISK форм-фактора 3,5", позволяющий работать с сетевыми соединениями как с обычными HDD - через интерфейс жестких дисков. Т.е. пользователь обращается к ресурсам Internet-а как к своему локальному диску. Из характеристик модуля отмечу: 10/100Base-T Ethernet-контроллер для связи с сервером, реализацию на плате FlashDisk объемом до 32Мб, поддержку удаленного конфигурирования и возможность работы модуля в качестве primary/slave-диска (!).

         "... Объявление в газете: "Вывожу из Интернета"...

Сеть Internet (гиперсеть, "паутина", сеть сетей) - всемирная компьютерная сеть, совокупность технических средств, программного обеспечения, стандартов и договоренностей, позволяющих поддерживать связь между различными компьютерными сетями в мире. Понятие Интернет обычно связывают с двумя важнейшими особенностями этой гиперсети: пакетным способом передачи информации и использованием протокола TCP/IP. Очень упрощенно можно представить Internet как "рыболовную сеть", накинутую на земной шар, где каждый узел - отдельный хост-компьютер.

· История Internet... В начале 60-х годов 20 века Министерство обороны США поставило задачу - разработать надежную компьютерную сеть на идее децентрализации. Т.е. в такой системе частичный оказ в работе сети не приводил к полной потере ее работоспособности. Будущая сеть предназначалась только для военных и должна была служить стратегическим интересам США. В 1969 году Американское Агентство перспективных исследований (ARPA) связало главные научные центры Министерством обороны США в так называемую ARPANet (Advanced Research Projects Agency Network), где Net - сеть по английски. Основная особенность ARPANet – гибкая маршрутизация (идет "холодная война") и пакетный способ передачи данных (прообраз протокола TCP/IP). К новой сети проявили большой интерес крупные Университеты США. Сеть ARPANet - прародитель современной сети Internet. В 1983 году ученые Калифорнийского университета в Беркли для стандартизации обмена данными между Unix-серверами и клиентами разработали протокол передачи данных - родился протокол TCP/IP. А после того, как право подключения к сети ARPANet получили коммерческие предприятия и частные лица, ARPANet превратилась в Internet. В 1993 году студенты факультета NCSA (National Center for Supercomputing Applications) из университета в Иллинойсе создали первый Web-броузер Mosaic, который позволил отображать на мониторах компьютеров HTML-документы. В этом же году число подключенных серверов перевалило за первый миллион и сеть Internet приобрела очертания, близкие к сегодняшним.

Дата | Событие
1962 | Paul Baran, RAND: "Распределенные коммуникационные сети"
1967 | ACM Симпозиум по принципам управления - Проект пакетно-переключаемых сетей
1968 | Презентация сети для ARPA
1969 | ARPANET принята для тестирования. Первый RFC (Request for Comment). Программное обеспечение узла Steve Crocker
1970 | В ARPANET стали применять Network Control Protocol (NCP)
1971 | 15 узлов ( 23 машины)
1972 | Международная конференция с демонстрацией ARPANet с 40 машинами
1973 | Первая международная линия. Подключены Англия и Норвегия
1974 | Спецификация протокола TCP
1976 | Протокол UUCP (Unix-Unix CoPy)
1979 | Рождение USENET
1980 | Разделение военной и гражданской сетей, TCP/IP становится основным протоколом
1981 | BITNET, the "Because Its Time NETwork"; CSNET (Computer Science NETwork)
1982 | Оформление протоколов ARPA в семейство TCP/IP. Рождение Eunet (European UNIX Network)
1983 | Разработан Name server, установлен шлюз в CSNET, рождение EARN. Считается годом рождения сети Интернет.
1984 | Разработан Domain Name Server, рождение JUNET (Japan Unix Network)
1986 | Создана NSFNET, разработан протокол NNTP (Network News Transfer Protocol)
1987 | Тысячный RFC
1988 | "Червь" поразил Internet, нарушена работа ~ 6000 компьютеров
1989 | Подключение первой коммерческой сети - MCI Mail. В марте Тим Бернерс-Ли (Tim Berners-Lee из CERN) предложил концепцию (проект "Гипертекст для ЦЕРН") новой распределенной инфо-системы, которую назвал World Wide Web.
1990 | Разработаны Archie (Peter Deutsch) и Hytelnet (Peter Scott). Старт проекта World Wide Web.
1991 | Предложена WAIS (Brewster Kahle) и реализован Gopher (Paul Linder и Mark P.McCahill)
1992 | World-Wide-Web (Tim Berners-Lee)
1993 | Mosaic from NCSA вдохнула новую жизнь в WWW
1994 | Появление новых "червей" в Internet
1995 | Начало триумфа World Wide Web

Internet не является отдельной сетью! Это сообщество сетей ("сеть сетей") и если вы подключены к сети, являющейся частью, то Вы имеете доступ к ресурсам любого из них. Имеется больше десятка сервисов Internet-а, из которых "чайникам" известны только WWW, IRC, e-mail, а грамотным пользователям - еще и News, Gopher, WAIS, Telnet, Ftp, Archie и т.д. Подробно о сервисах - см. в главе Internet-soft.
Число российских пользователей Internet-а к началу 2003 года составила 5,1 миллиона человек (данные проекта Web-Vector компании Комкон). 3,6 миллиона из них живут в крупных и средних городах. 78% пользователей регулярно посещают веб-сайты, 72% пользуются электронной почтой, 21% общается по ICQ.

· GOVNET... Администрация США в 2003 году объявила, что обычная сеть Internet не достаточно для нее защищена и предложила создать новую сеть специально для передачи правительственной информации. Идея принадлежит Ричарду Кларку (Richard Clarke, советник президента по безопасности киберпространства). Новая сеть уже получила название GOVNET (название "режет" ухо). Предполагается, что эта сеть будет передавать обычные данные, речь и возможно видео по протоколу IP.

· World Wide Web или самый популярный Internet-сервис... Первое сообщение об WWW было послано в телеконференции : alt.hypertext, com.sys.next, comp.text.sgml и comp.mail.multi- media в августе 1991 года. Сообщество Internet получило еще одну программу, работающую в режиме командной строки. Прошло еще целых полтора года до того момента, когда Марк Андресен (Mark Andressen) из Национального Центра Суперкомпьютерных Приложений (NCSA) разработал программу Mosaic - первый web-броузер. Mosaic разрабатывалась как программа с возможностями доступа к ресурсам Internet посредством различных протоколов, в число которых входили FTP, telnet, NNTP, SMTP. А в марте 1994 года Андресен покинул NCSA и организовал коммерческую корпорацию Netscape. В марте 1993 года трафик World Wide Web составлял 0,1% от общего трафика сети NSF, сентябре 1993 года он уже составил 1,0% от общего трафика сети NSF, в октябре 1993 года количество зарегистрированных WWW-серверов равнялось 500, в июле 1995 года - более 6 миллионов и т.д.
Упрощенно говоря, web-броузеры (которые безусловно являются WWW-клиентами)- это просто графический интерфейс в Internet-е. Фактически же web-броузер - это интерпретатор HTML, который в зависимости от команд (разметки) выполняет различные функции. В круг этих функций входит не только размещение текста на экране, но и обмен информацией с сервером по мере анализа полученного HTML-текста. База данных HTML-документов - это часть файловой системы, которая содержит текстовые файлы в формате HTML и связанные с ними графику и другие ресурсы. Из прикладного программного обеспечения, работающего с web-сервером, можно выделить программы-шлюзы. Шлюзы - это программы, обеспечивающие взаимодействие сервера с серверами других протоколов, например ftp. Tim Berners-Lee в 1989 году заложил три краеугольных камня системы WWW из четырех существующих ныне, разработав:
1. язык гипертекстовой разметки документов HTML (HyperText Markup Language);
2. универсальный способ адресации ресурсов в сети URL (Universal Resource Locator);
3. протокол обмена гипертекстовой информацией HTTP (HyperText Transfer Protocol);
Позже команда NCSA добавила к этим трем компонентам четвертый:
4. универсальный интерфейс шлюзов CGI (Common Gateway Interface);
В качестве базы для разработки языка гипертекстовой разметки был выбран SGML (Standard Generalised Markup Language). Важным компонентом языка стало описание встроенных и ассоциированных гипертекстовых ссылок, встроенной графики и обеспечение возможности поиска по ключевым словам. Любой документ HTML представляет из себя набор вложенных элементов. Элементы представляют из себя "контейнеры" (парные тэги), в которых размещаются: текст, графика, гипертекстовые ссылки, инструкции управления отображением. Сам документ является также элементом, который может иметь две формы: обычного документа, форму фрейма. С момента разработки первой версии языка (HTML 1.0) постоянно увеличивается число элементов разметки, оформление документов все больше приближается к оформлению качественных печатных изданий, развиваются средства описания не текстовых информационных ресурсов.

· URL-ы Internet-а... Вторым краеугольным камнем WWW стала универсальная форма адресации информационных ресурсов. Universal Resource Identification (URI) представляет собой довольно стройную систему, учитывающую опыт адресации и идентификации. Но реально из всего, что описано в URI, для организации данных в WWW требуется только Universal Resource Locator (URL, "юрл").
Ключом к получению информации в Internet являются адреса ресурсов: либо почтовые адреса (mail addresses), либо адреса хост-компьютеров (host names). Все хост-компьютеры имеют IP-адрес (напр. 195.87.150.66) и составное имя в доменной форме (напр. www.infocentre.spb.ru). Для соответствия между адресом и именем существует специальная система запросов, позволяющая получать эту информацию из сети - DNS (Domain Name System) и ARP (Address Resolution Protocol). Один хост может иметь несколько имен и адресов. По существу, доменный адрес - лишь удобный способ идентификации компьютера.
Сочетание трех крайних букв справа определяет имя домена верхнего (первого) уровня, а кроме этого каждая страна имеет свой двухбуквенный код. Еще недавно существовало очень строгое соответствие, но в последние годы оно нарушено и напр. домен *.com может купить любая фирма бывш.СССР.

*.com - коммерческие организации Запада;
*.edu - университеты и пр. образовательные учреждения;
*.mil - военные ведомства;
*.gov - правительственные учреждения;
*.net - сетевые организации;
*.org - прочие организации; 		*.fr - Франция;
*.de - Германия;
*.ru - Россия;
*.ca - Канада;
*.uk - Великобритания;
*.au - Австралия;
Ранее был еще домен 1 уровня *.arpa (вышел из употребления).
IP-адрес состоит из четырех чисел (каждое из которых лежит в пределах 1-254), разделенных точками. Адрес содержит 32 бита и состоит из 2 частей: адреса сети и адреса хоста. При обращении ARP делает общий запрос "чей это IP-адрес?". Отвечает один. И так по всей цепочке уровней доменов. Порядок работы серверов имен корневой зоны (знают хост-компьютеры серверов имен доменов 1 уровня, их всего 9 одинаковых) – выдача указателей на домены следующего уровня. Локальные серверы имен (знают имена доменов своего уровня) кэшируют список найденных имен и повторяют свои запросы, пока не получат ответ.

         "... Мир становится все web'анутее и web'анутее...

Cетевые карты... Основным компонентом, отличающим обычный ПК от сетевого, является сетевая карта. Как и большинство плат расширения, сетевые карты выпускаются во многих вариантах - для шин PCI, ISA, PCCard/PCMCIA и даже USB. Сегодня для настольного ПК наиболее выгодно использовать карты на шину PCI, поскольку только она может обеспечить необходимую скорость и является самой распространенной в настоящий момент. Для старых ПК можно использовать карты на шину ISA, но в этом случае высоких скоростей передачи вы не получите. Ноутбуки обычно используют сетевые контроллеры на шинах PCMCIA и USB.
Используемый интерфейс также приводит к некоторым отличиям в конфигурировании карт. Если для PCI вариантов все легко проходит по технологии Plug&Play, то для ISA карт есть несколько вариантов конфигурирования: перемычками (jumper), программой конфигурирования (jumperless) и конечно по технологии Plug&Play. Устройства USB работают исключительно со своими драйверами. Для PCMCIA карт есть два варианта работы - для старых ноутбуков обычно карта устанавливается как NE2000 совместимая, при этом требуется только запустить ее конфигуратор в файле autoexec.bat, или, для современных PnP систем, она работает как полноценное PCMCIA устройство с возможностью горячей замены.
Кроме скорости и типа интерфейса у сетевых карт есть несколько других, менее важных параметров:

  • поддержка Boot ROM (загрузка ПК без жесткого диска по сети);
  • поддержка Wake On Lan (включение ПК по сети);
  • поддержка режима Full Duplex (одновременная прием и передача информации, требует поддержки этого режима от всего остального оборудования сегмента сети);
  • количество индикаторов на задней панели;
При выборе сетевой карты обязательно учитывайте поддержку ее драйверами Вашей операционной системы. Продукция известных производителей чаще всего имеет большой список: как минимум вся линейка OS компании Microsoft (от MS-DOS до Windows XP), Novell NetWare, несколько OS семейства Unix.

Производители сетевых карт (что получше - выделено синим, а тайваньские - бордовым):

[ 3Com ] [ Acorp ] [ Allied Telesyn ] [ CNet ] [ Compex ] [ D-Link ] [ Intel ] [ Genius ] [ LG ] [ Linksys ] [ SMC ] [ Surecom ]
Лидерами являются компании Intel и 3Com, правда разница в цене с аналогичным продуктом другой фирмы может достигать четырех раз. Рекомендую не покупать карты неизвестного производителя. Время, потраченное на установку и настройку таких карт стоит дороже выгоды в цене.

         "... Интернет - Лучше для мужчины нет...

До сих пор самая популярная IT-профессия — "компьютерщик", в то время как настоящий сетевой администратор должен начинать деятельность после окончания соответствующего факультета вуза, прохождения сертификационных курсов и последующей стажировки. Поэтому привожу некоторые термины для "молодых специалистов":

· Структурированная кабельная система - сформированная из нескольких типовых уровней: магистральных, этажных, комнатных и индивидуальных;

· Сегмент - часть сетевого кабеля, ограниченная мостами, маршрутизаторами, повторителями или терминаторами (terminators);

· Сеть Baseband - эта такая сеть, которая предоставляет единственный канал для коммуникаций в пределах сетевой среды (например кабеля), таким образом, одновременно может передавать только одно устройство;

· Broadband сеть - многоканальная/многополосная сеть, противоположная Baseband-сети. При широкополосности, физический кабель условно делится на несколько различных каналов, каждый со своей собственной несущей частотой;

· MAC-адрес - уникальный шестнадцатиричный серийный номер, назначаемый каждому сетевому устройству Ethernet, для идентификации его в сети. Для сетевых устройств этот адрес (permanently) устанавливается во время изготовления, хотя обычно, он может быть изменен при помощи соответствующей утилиты;

· Коаксиальный кабель ("коаксиал") - это металлический электрический кабель, используемый для радиочастотной передачи и определенной передачи данных. Кабель состоит из одного цельного или витого центрального проводника, который окружен слоем диэлектрика. Проводящий слой алюминиевой фольги, металлической оплетки или их комбинации окружает диэлектрик и служит одновременно как экран против наводок. Общий изолирующий слой образует внешнюю оболочку кабеля;

· Кабель витая пара (TP - Twisted Pair). Бывает неэкранированый (unshielded, название - UTP) и экранированый (Shielded, название - STP). UTP - подразделяется на уровни, в зависимости от возможности передавать данные (например Level3, Level4, Level5). 10BaseT Ethernet требует наличия кабеля, как минимум Level3. Во многих местах сейчас устанавливают провод только Level5. STP обычно используется для сетей Token-Ring, где его соотносят с кабелем IBM-тип;

· Пакетный драйвер - - это способ, позволяющий множеству протоколов получать доступ к сетевому интерфейсу одновременно;

· Концентраторы (hub, "хаб", репитер) - это место соединения проводов для сетей с любой логической топологией (чаще - с топологией "звезда"). Бывают активные и пассивные. Активный хаб - устройство сети, регенерирующее и передающее сигналы. Пассивный хаб - пропускает через себя сигнал, не усиливая и не восстанавливая его. Хаб - это общепринятый синоним концентратора. Hub часто называют свичом 1-го уровня. На рис.- 4-портовый USB 2.0 хаб от Transcend:

Производители концентраторов и коммутаторов:

[ 3Com ] [ Acorp ] [ Allied Telesyn ] [ Avaya ] [ Cabletron ] [ Cisco ] [ CNet ] [ Compex ] [ Corega ] [ D-Link ] [ Defender ] [ Edimax ] [ Eline ] [ Gembird ] [ Genius ] [ Hewlett-Packard ] [ Kramer ] [ Lantech ] [ LG ] [ Nortel Networks ] [ SMC ] [ SureCom ]

· Повторитель (repeat, repeaters) - устройство сети, которое повторяет входящий на него сигнал (усиливает и заново формирует форму аналогово сигнала на расстояние другого сегмента). Повторитель действует на чисто электрическом уровне для соединения двух сегментов. Repeat ничего не знает об адресах или forwarding, поэтому не может использоваться для уменьшения трафика (как это делает мост). Repeat не есть Hub!...

· Коммутатор - управляемое программным обеспечением центральное устройство, куда сходятся все кабели сети, сокращение сетевого трафика. Главное отличие коммутатора от концентратора - у коммутатора всегда есть консольный вход. Коммутатор часто называют свичом 2-го уровня;

· Маршрутизатор (router, routers) - стандартное устройство сети, работающее на сетевом уровне ЭМВОС и позволяющее переадресовывать и маршрутизировать пакеты из одной сети в другую, а также фильтровать широковещательные сообщения. По сути Router - это обычный ПК, но с двумя сетевыми картами. Routerом часто называют свичом 3-го уровня. "Умный" маршрутизатор может работать как выделенный файл-сервер. На рис.- маршрутизатор Secure Storage Router Pro от U.S.Robotics:

Производители маршрутизаторов :

[ Allied Telesyn ] [ Avaya ] [ Cisco ] [ Compex ] [ D-Link ] [ Enterasys Networks ] [ HUAWEI ] [ Intel ] [ LG ] [ SMC ] [ Zyxel ]

· Мост (bridge, "интеллектуальный повторитель") - устройство сети, которое соединит два отдельных сегмента, обычно ограниченных физической длиной сегмента и будет передавать трафик между ними. Мост также усиливают и конвертируют сигналы для кабеля другого типа. Это позволяет расширить максимальный размер сети, одновременно не нарушая ограничений на макимальную длину кабеля, количество подключеных устройств или количество повторителей (репитеров) на сетевой сегмент. Выделяют "обучаемый мост (learning bridge)" и "удаленный мост" (remote bridge). Bridge часто называют свичом 2-го уровня;

· Шлюз (gateway) - транслятор, конвертирующий данные из одной формы в другую ("переводчик");

· Мультиплексор - устройство центрального офиса, которое поддерживает несколько сотен цифровых абонентских линий (DSL). Мультиплексор посылает и получает абонентские данные по существующим телефонным линиям, концетрируя весь трафик в одном высокоростном канале для передачи в Internet или в сеть компании;

· Коммуникационный протокол - совокупность правил, регламентирующих формат и процедуры обмена информацией между двумя или несколькими независимыми устройствами, компьютерами, программами или процессами;

· Терминатор (terminators, заглушка, зажимное соед.) - резистор, который производит затухание сигнала на концах сегмента. Норма = 50 Ом (с погрешностью не превышаюшей 1%). Такой терминатор есть прецензионное сопротивление. Проверяйте тестером! Автору однажды попалось аж на 85 Ом. При необходимости терминатор делается вручную: обычное сопротивление номиналом 47 Ом, припаевается на Т-конектор вместо терминатора, один контакт на центральную жилу, а второй на экран соответственно. На сопротивление надеть кембрик (хлоровениловую трубку) для изоляции.

         "... если связь обрывается - у провайдера провода кривые?...

· Сетевое (телекоммуникационное) оборудование подразделяется на:

  1. Кабельную систему - это кабеля, коннекторы, розетки, короба, шкафы, и прочие "атрибуты проводов". Зависит от категории качества элементов, технологичности монтажа системы и соответственно желаемой скорости передачи данных по сети.
  2. Сетевое оборудование - это концентраторы, коммуникаторы, маршрутизаторы, межсетевые экраны, мультиплексоры. Оборудование бывает активное и пассивное. Обеспечивает увязку всех проводов в единое целое. В последних сериях типичный дизайн корпуса позволяет составлять несколько сетевых устройств в одну стойку. При этом самые ответственные участки сети подключаются к высокопроизводительным устройствам. Проще говоря - это как железные дороги с различной пропускной способностью линий.
  3. Сервера - см. главу о серверах;
Необходимо отметить, что сетевое оборудование работает вместе с сетевой операционной системой, которая предоставляет пользователям права, разграничения доступа и т.п.

· Межсетевой экран (МЭ, МСЭ, firewall, брандмауэр) - это сетевое устройство, реализующее контроль за информацией (как поступающей в ЛС, так и выходящей) и обеспечивающая защиту ЛС посредством фильтрации информации. Бывает локальное (однокомпонентное) или функционально-распределенным (комплекс).
Абсолютное большинство межсетевых экранов построено на классических моделях разграничения доступа, разработанных в конце 20-го столетия в военных ведомствах. Согласно этим моделям субъекту (пользователю, программе, процессу или сетевому пакету) разрешается или запрещается доступ к какому-либо объекту (например, файлу или узлу сети) при предъявлении некоторого уникального, присущего только этому субъекту, элемента. В 80% случаев этим элементом является пароль. В других случаях таким уникальным элементом является таблетка Touch Memory, Smart или Proximity Card, биометрические характеристики пользователя и т.д. Для сетевого пакета таким элементом являются адреса или флаги, находящиеся в заголовке пакета, а также некоторые другие параметры.
Просмотр трафика на границе между внешней и внутренней сетями не гарантирует полной защиты. Межсетевой экран фильтрует трафик и принимает решения о пропуске или блокировании сетевых пакетов, опираясь на информацию об используемом протоколе. Например, если в МСЭ разрешен 25 и 80 порты, то тем самым разрешается пропуск во внутреннюю сеть почтового (SMTP) и Web (HTTP) трафика.

Можно сказать, что МЭ - это программный и/или аппаратный барьер между двумя сетями, позволяющий устанавливать только авторизованные межсетевые соединения. МЭ защищает соединяемую с Интернет корпоративную сеть от проникновения извне и исключает возможность доступа к конфиденциальной информации. Подразделяют пять типов межсетевых экранов:
  1. Фильтрирующие МЭ - это самые простые экраны, относящиеся к классам 4 и 5. Таким экраном может служить любой маршрутизатор.
  2. МЭ, построенные на основе сервисов посредников - экраны, которые анализируют внутри протоколов. Относятся к классам 3,2 и 1.
  3. Прозразные МЭ - экраны, которые пользователь вообще не видит.
  4. Комплексные МЭ представляют из себя смесь первых трех вариантов.
  5. Stealth - это самые мощные экраны, которые вообще не имеют IP-адреса.
Любой межсетевой экран состоит из операционной системы, пакетного фильтра, шлюзов приложений, средств идентификации и аутентификации, средств регистрации и учета, модуля удаленного управления и конфигурации, средств контроля целостности. И лично автор советует использовать МЭ как внешний шлюз. Самыми распространенными видами сетевых атак, отражаемых МЭ являются: сканирование сетевых портов, атаки на отказ в обслуживании, изучение топологии внутренней сети, использование слабостей протоколов прикладного уровня, распространение вирусов и спама.
Межсетевой экран - не панацея! Это просто "ограждение" вокруг Вашей сети. И еще он настраивается людьми (которым свойственно ошибаться). Статистика ассоциации ICSA показывает, что до 70% всех работающих межсетевых экранов уязвимы из-за неправильной конфигурации и настройки! Часта ситуация, когда кроме своих ошибок специалистам по защите информации приходится изменять настройки межсетевого экрана, выполняя идиотские распоряжение начальства (типа "...дай мне доступ к..."). Роль черного входа также может выполнять "неизвестный" модем. К тому же стоит отметить, что "дырки" в операционной системе позволят злоумышленнику пройти через любой экран.

· VPN (Virtual Private Network) - это безопасный канал связи (т.н. туннель) через существующую сеть, которая имеет IP-инфраструктуру. Перед посылкой данных через этот туннель, устройства VPN, создающие его, кодируют данные. Т.о. технология VPN позволяет использовать недоверенную сетевую инфраструктуру, обеспечив при этом защиту передаваемых данных в соответствии с политикой безопасности конкретной организации.
Сами устройства VPN - это как аппаратные средства (например, шлюзы или маршрутизаторы), так и программное обеспечением, так и firewall (включая компоненты VPN). Существующая IP-сеть, через которую прокладывается этот VPN-туннель, может быть частной корпоративной сетью, но обычно это сеть Internet. В зависимости от решения, VPN может также соединять удаленных пользователей в корпоративную сеть.

При этом VPN-туннели не нужны, если есть высокоуровневое шифрование. Но даже в случае создания VPN-соединений между сетью, защищаемой при помощи МСЭ с функциями VPN, и доверенной сетью, злоумышленник сможет реализовывать свои атаки.

Личное мнение... если у Вас простое соединение 2-3 компьютеров, попробуйте сделать сеть самостоятельно, выбрав карты от Intel-а или 3Com-а. Если же у Вас сложная сеть или компьютеров много - обратитесь к профессионалам. Поверьте - оно того стоит...

© Dmitry Belousov
http://www.orakul.spb.ru
ноябрь 2001г.-июль 2003г.


"Азбука РС" Дм.Белоусова, видео

Video

•

Видеоадаптер
• видеопамять
• контроллер
• пpеобpазователь
• video ROM
электронная плата обработки видео-данных, "видюха"

•

Графические ускорители

•

Фрейм-грабберы

•

Типы
FPS

•

ТV-тюнеры

•

Библиотеки стандартов
Video-драйвера

Затраты на видео-систему составляют от 30% до 50% стоимости всего компьютера. Изображение будет одинаково ужасным с хорошим монитором при отвратительной видеокарте и/или с отличной видеокартой при безобразном мониторе. Часто переплачивают за функции, которые Вам не нужны, и наоборот – пожадничав, получиют видеосистему, откровенно не справляющуюся со своими прямыми обязанностями. Количество цветов:
· 16 цветов.
· 256 цветов. 8 битов на пиксел
· 32768 цветов: High Color, 15 бит
· 65536 цветов: High Color, 16 бит
· 16,7 миллиона цветов: True Color ("истинный цвет"), 24 бит.
15 и 24 бита распределяются между базисными цветами R:G:B поровну (5:5:5 и 8:8:8), 16 бит - с учетом особенностей цветовосприятия неравномерно (5:6:5 или 6:6:4).
P.S. Вид современной видеокарты:

· Видеоадаптер - посылает в дисплей сигналы управления яркостью лучей и сигналы развертки изображения. За эти годы использовались следующие типы адаптеров:
  • MDA (Monochrome Display Adapter) - монохромный адаптер, применяемый в первых PC. Режим - только текстовой, ... монохромный, 4 цвета реализуются атрибутами знакоместа: обычный, подсвеченный, подчеркнутый, инверсный.
  • MGA (Monochrome Graphics Adapter) - монохромный графический адаптер, графическое расширение MDA, обеспечивается режим 720x350 с двумя битами на пиксел. Иногда называют Hercules Graphics Adapter (HGC, Hercules Graphic Controller).
  • CGA (Color Graphics Adapter), цветной графический адаптер. Первая графическая система PC. Режимы - текстовой и графический, разрешение низкое, особенно по вертикали.
  • EGA (Enhanced Graphics Adapter), улучшенный (расширенный) графический адаптер. Режимы - текстовой и графический, кроме собственных видео-режимов поддерживает режимы MDA и CGA.
  • PGA (Professional Graphic Adapter), профессиональный графический адаптер с процессором трехмерной графики. Появился в 1984 году и не прижился из-за высокой цены.
  • MCGA (Multi Color Graphics Array), блок видеосистемы на системной плате PS/2. Поддерживаются режимы CGA и другие.
  • VGA (Video Graphics Array), видеографическая матрица. Появился как блок видеосистемы на системной плате PS/2, затем стал самостоятельным стандартным адаптером. Режимы: текстовой и графический. Поддерживает режимы MDA, CGA, EGA и дополнительные... Обеспечивает 256 цветов на экране из палитры 262144 цветов или 64 градации серого. Адаптеры различных производителей могут различаться на аппаратном уровне, совместимость обеспечивается на уровне BIOS-а.
  • IBM 8514/A display adapter - адаптер для шины MCA PS/2. Превосходит VGA по разрешению, имеет аппаратную поддержку многих функций. Все преимущества реализуются только с монитором IBM 8514.
  • XGA, XGA-2 (eXtended Graphics Array), высокопроизводительные 32-битные адаптеры. Хорошо сочетаются с монитором IBM 8514.
  • SVGA (Super Video Graphics Array), видеографическая матрица высокого класса, превосходят VGA по разрешению (от 800*600 и выше) и/или количеству цветов (True Color 16-32 млн цветов). Является стандартом среди видео-карт с 1992 года. В режимах VGA эти адаптеры стандартизированы, на более высоком разрешении взаимной совместимости на уровне регистров нет.
Основными составляющими видеокарты являются:
1. Видеопамять. В ней хранится изображение. Ее объем определяет максимально возможное разрешение. Разрешение характеризуется тремя составляющими: по горизонтали, по вертикали и количеством возможных цветов точки. Объем, Мбайт: 0,5-1-2-4-8 (устар.), 16-32 (2000-2001гг.), 64-128 (2002 год), 256 (планы). Пример формулы расчета min-a количества видео-памяти:
( 1024 x 768 x 16 ) / 8.388.608 = 1,5 Мб
Т.е. объем видео-памяти, необходимый для работы на выбранном разрешении = умножению количества точек по вертикали и горизонтали друг на друга, а произведение умножить на глубину цвета в битах; затем биты перевести в мегабайты.
2. Контроллер видеоизображения. Выхватывает изображение из памяти, обрабатывает запросы центрального процессора, формирует видеосигналы.
3. Цифpоаналоговый пpеобpазователь. Преобразует поток данных, поступающих от контроллера, в цветовые уровни, подаваемые на монитор.
4. Video R0M (ПЗУ). Служит для хранения видео-BIOS-а, экранных шрифтов и прочей, необходимой для первоначального запуска адаптера, информации.
Hа многих новых каpтах устанавливаются электpически пеpепpогpаммиpуемые ПЗУ (EEPROM, Flash ROM), допускающие пеpезапись этой информации самим пользователем под упpавлением специальной пpогpаммы. В системах автоматизированного проектирования, издательских системах используются специальные типы видео-адаптеров. Все видеокарты выпускаются для одной из трех слотов (шин):
· IDE (устарев.)
· PCI (Peripheral Component Interconnect)
· AGP (Accelerated Graphic Port)
В последние годы абсолютное большинство выпускаемого - для шины AGP. Стандарт на AGP был разработан фирмой Intel чтобы, не меняя сложившийся стандарт на шину PCI, ускорить ввод/вывод данных в видеокарту и увеличить производительность ПК при обработке трехмерных изображений. Шина PCI имеет тактовую частоту 33 MHz и 32 разряда данных, поэтому может пропустить до 132 мегабайт в секунду. (33.000.000х4байта). AGP имеет частоту шины 66/100 MHz и 32 разряда данных. В стандартном режиме она может пропустить до 266 Mb/c (66.000.000 х 4 байта). Возможность передавать данные, используя как передний, так и задний фронт синхро-сигнала, получила название AGP 2x. Новые видеокарты поддерживают режимы AGP 4x, AGP 8x. Но AGP-видеокарты больше загружают центральный процессор во время работы и потому более требовательны к его частоте. Далеко не все графические платы AGP обладают равноценными функциональными возможностями, ибо спецификация AGP не требует обязательной поддержки всех ее функций. Кстати, решение обычных офисных задач вполне могут обеспечить PCI-карты.
Видеокарты производит огромное количество производителей. Торговые марки популярных в РФ выделены синим цветом:
[ 3Dlabs ] [ 3dfx ] [ Abit ] [ A0pen ] [ Asus ] [ ATi ] [ Alliance ] [ Apollo ] [ Appian Graphics ] [ Apple ] [ Axle ] [ Butterfly ] [ Canopus ] [ Chaintech ] [ Cirrus Logice ] [ Compaq ] [ Creative Labs ] [ DFI ] [ Daytona ] [ Diamond ] [ Digital PowerStorm ] [ Eagle ] [ Eline ] [ Elitegroup ] [ Elsa ] [ EVI ] [ ExpertColor ] [ GA ] [ Gainward ] [ GeForce ] [ Gigabyte ] [ Guillemot ] [ Hercules ] [ Innovision ] [ Intel ] [ Jaton ] [ Jetway ] [ Kyro ] [ Leadtek ] [ Lucky Star ] [ Manli ] [ Matrox ] [ Maxtor ] [ Mercury ] [ Microstar ] [ Miracle Business ] [ Number Nine ] [ nVidia ] [ Palit ] [ Pine ] [ Pixel View ] [ PowerColor ] [ Radeon (ATI)] [ Realtek ] [ Riva ] [ S3 ] [ Siluro (Abit)] [ SiS ] [ Sparkle ] [ STM ] [ Suma ] [ SumaPlatinum ] [ Super Grace ] [ Tekram ] [ Trident ] [ Tornado (Innovision)] [ Twin ] [ Vanta ] [ Video Logic ] [ VideoExcel ] [ Volkano ] [ WinFast (Leadtek)] [ Wonder (Jetway)]
Примечание: GA - GIGABYTE, STM - STMicroelectronics, STB куплено 3dfx, SG - SuperGrace, IXMICRO - бывшая Integrated Micro Solutions.
И это множество производителей видеокарт применяют совсем небольшое количество чипсетов. Известные производители графических чипсетов:
  • линейка от nVidia: NV1, Riva128/Riva128ZX, RivaTNT, RivaTNT2, RivaTNT2 Ultra, Riva TNT2 M64, Riva TNT2 Vanta, GeForce256, GeForce2GTS, GeForce2, GeForce2MX, GeForce3, GeForce4, Quadro 2 mxr, Quadro 2 pro, Quadro DCC, Quadro4 900XGL, Quadro4 750XGL, GeForce4 Ti 4400, GeForce4 Ti 4600. Чип имеет 32-битные цвет (основной козырь) и 24-битный Z-buffer. Стратегия выпуска новых чипов - новый чип каждый полгода. Сейчас nVidia - лидер рынка, но в ее планах увеличивать производительность чипа, не внося существенных изменений...
  • линейка от 3Dfx Iteractive: Voodoo Graphics, Voodoo Rush, Voodoo2, Voodoo Banshee, Voodoo3 2000, Voodoo3 3000, Voodoo3 3500, Voodoo3 500 Velocity, Voodoo3 4000, Voodoo4 4500, Voodoo5 5000, Voodoo5 5500, Voodoo5 6000. У 3Dfx самый высокий филлрейт, самый быстрый алгоритм просчета дельты, но почти все не работают в 32-битном цвете. Стратегия выпуска новых чипов - в течение года выпускается два продукта - один для долгосрочной перспективы и один дешевый, для текущих продаж. На сегодня чипы устарели, плюс банкротство 3dfx... Хотя 3dfx купила 3D-графическую компанию Gigapixelа и все ее разработки будущего по тайловой архитектуре. Хорошее наследство.
  • линейка от S3: Virge, ET4000, ET6000, ET6100, Savage 4, Savage 4GT, Savage 4 Pro. На сегодня компания сосредоточилась на видео для ноутбуков и видео, интегрированных в чипсет материнских плат.
  • линейка от ATI: 3D Rage Pro, 3D Changer, Xpert&Play, Trident 9750, Rage 128, FireGL2, FireGL 8800, Radeon 8500/8500LE. На сегодня канадцы - единственный конкурент nVidia.
  • линейка от Matrox: Matrox G200, Matrox G400, Matrox G450, Matrox G500, Matrox G550. Matrox пока нацелен на видеокарты для САПР и издательских систем.
  • прочие: Intel740, Savige 3D, Verite1000, Verite2100, Verite2200, Permedia, Permedia 2, 3DLabs Wildcat II 5000.
Из истории: в чипе NV1 компания nVidia использовала технологию кривых поверхностей третьего порядка (!), но проиграла направление развития Microsoft-у (библиотека Direct3D), внедрявшему технологию треугольников. Как всегда - Microsoft загубила хорошее...
Основная болезнь рынка нынешних видеокарт - узкая полоса пропускания шины данных. Пример: чип GeForce2GTS работает на 38% от реальной мощности при полной загрузке чипа, а остальные 62% "срезаются" узкой полосой пропускания шины памяти).
Любой современный видео-чип позволяет изготовителю видеокарты сильно варьировать ее характеристики - как путем установки различных компонентов, так и путем программирования самого чипа. Итог - скорость и качество работы видео-карты будет зависеть от мощности графического чипа, качества сборки и наличия нормальных драйверов от производителя видеоадаптера.

· Микросхемы видео-памяти: видеокарта комплектуется модулями памяти, работающими на своих штатных частотах. В разных партиях даже одного производителя (но разных поставщиков) идет разная комплектация! Например вместо памяти 3.6 ns идет 4 ns, т.е. с пониженными частотами. В данном примере карта будет работать не на 275 МГц, а на 250 МГц. А китайские производители не приводят честно данные о лежащей в коробке карте с более низкими частотами.

· Упаковка и подделка: российский рынок завален дешевыми и некачественными видеокартами в упаковке от разных китайских фирм. Море подделок под видом продукции известной компании. Перемаркировать или наклеить липовые лейбы на видеокарту - сейчас это легко. Могут и "впарить" карту, украденную из партии брака, направляющейся обратно на завод. ОЕМ-поставки ("в пакетике")- это рай для мошенничества и обмана. Рекомендую брать продукцию в Retail-упаковках и смотреть штрих-код. А я, если завтра увижу видеокарту в упаковке от какого-нибудь мясокомбината - уже не удивлюсь :)

         "... Если какая-нибудь неприятность может случиться, она случается" (закон Мерфи)

· Графические ускорители (акселераторы и сопроцессоры) - специализированные графические сопроцессоры, увеличивающие эффективность видеосистемы. Их применение освобождает центральный процессор от большого объёма операций с видео-данными, так как акселераторы самостоятельно вычисляют, какие пиксели отображать на экране и каковы их цвета. Различают:
· графический сопроцессор - специализированный процессор, который подключается к шине компьютера и имеет доступ к его оперативной памяти. В процессе своей работы сопроцессор пользуется оперативной памятью, конкурируя с центральным процессором по доступу и к памяти и к шине.
· графический акселератор ("движок") работает автономно и при решении своей задачи практически не выходит на системную шину.

  • 2D-ускоритель. Чтобы не было задержек в выводе графики на экран, в видеокарту встроили спец микросхему - акселератор 2-мерной графики, который отчасти используя CPU (но аппаратно почти самостоятельно) на основании координат и параметров элементарных геометрических фигур (отрезков, дуг и т.п.) рисовал на экране полное изображение этих фигур из которых и формировался рисунок. И изображение строилось уже не из отдельных точек, а из простых геометрических примитивов, что ускоряло (на порядок) вывод изображения на экран. Позднее видеоакселераторы совместили с видеочипом (микросхемой) видеокарты и дополнили реализуемыми аппаратно функциями: масштабирование (пересчет размеров) по определенной оси координат, рисование окна и т.п.
  • 3D-ускоритель. На основании параметров элементарных 3-мерных фигур и точки наблюдателя рисовалась их проекция на экране (математически - создавалась 3-мерная модель изображения и рассчитывалась ее проекция на плоский экран). Для помещения фигуры в любую точку экрана использовали искусственное "смещение системы координат". Объекты перекрываемые по дальности (рассчитывалось их удаление до наблюдателя), заслонялись приближенными. В зависимости от расположения источника света просчитывалась освещенность фрагментов поверхности объекта. Объекты представляют в упрощенной геометрической форме, а ее усложнение задается накладываемой на рисунок поверхностью - текстурой. В результате - не поточечное описание всей поверхности, а всего-лишь одна команда головной программы по инициализации ее модуля описания вызываемой текстуры с задаваемыми параметрами ее наложения. Все текстуры, z-буфер и буфера следующего кадра хранятся в видео-памяти. Соответственно видеопамяти для 3D-изображений требуется в 4 раза больше, чем для 2D изображения.
  • адаптер с аппаратной геометрией (будущее)
На рынке практически не осталось ускорителей, предназначенных для работы с 2D, а только 2D/3D. Но реально 3D-ускоритель является необходимым лишь для тех, кто собирается уделять много времени современным играм и работе с 3D-графикой.

· FPS (frames per second, тест на 3D-игру) - один из основных показателей скорости игры, означает количество выводимых кадров в секунду. FPS является обобщенной характеристикой многих технических параметров видеокарты, таких как частота ядра контроллера, технология изготовления чипсета, разрядность шины и пр. Есть тенденция его абсолютизировать, т.е. попытки представить его главным и единственным скоростным показателем. Но:
a) нельзя применять FPS без приведения конкретных обстоятельств его получения. Ести вещи, от программ не зависящие - например, частота смены кадров монитора.
b) fps - это интегральный показатель, точнее - это усредненное за определенный период времени значение.
Нельзя мерять (посредством FPS) именно скорость видео-аккселератора. Скорость же данной игры на данном видео-аккселераторе на данной PC с данным ПО - можно и нужно измерять при помощи FPS. Новое поколение ускорителей берет на себя огромное количество функций (обработкой текстур, теней, многослойных изображений, etc.). Важнейшей характеристикой 3D является аппаратная поддержка ставших стандартами библиотек трехмерного моделирования (API). Сегодня таких стандартов три +:

  • Glide – библиотека от 3Dfx. В свое время эта библиотека завоевала популярность благодаря широкому распространению первых 3D-ускорителей 3Dfx Voodoo. Для быстрого Glide было создано множество игр. Однако компания 3Dfx только сейчас сделала библиотеку свободно доступной для других производителей видеокарт, а потому пока Glide поддерживают лишь карты от самого 3Dfx. Эта библиотека позволяет создавать игры с весьма средним качеством графики, но непревзойденной скоростью. На сегодняшний день Glide – вымирающий стандарт.
  • Direct3D – библиотека от Microsoft-a. DirectX - это интефейс низкого уровня, он предоставляет программисту прямой доступ к памяти адаптера, где тот создает изображение, хранит графические образы, звуки и т. д. Получила широкое распространение благодаря агрессивной политике. Функциональная часть названа Direct3D. Состоит из:
    • DirectSound - микширование звука и 3D звук .
    • DirectInput - для поддержки клавиатуры, мыши, джойстика и так далее
    • DirectPlay - для обеспечения поддержки играть через сеть
    • DirectAnimation - для создания анимационных эффектов в WEB-стриницах
    • DirectShow - для применения мультимедиа в WEB
    • DirectMusic - новый раздел. Служит для применения музыки в играх
    На сегодняшний день поддерживается почти всеми видеокартами. Проверка работы отдельных опций DirectX (в частности -3D) -утиллитой Windows\System\dxdiag.exe.
  • 0penGL – была создана специально для программ трехмерного моделирования, а также для мощных графических станций. В результате быстрого развития видеоиндустрии в последние годы, эта библиотека постепенно стала одним из ведущих стандартов для 3D-игр на платформе PC. Единственный минус – отсутствие ее полных вариантов для некоторых ускорителей (например, для абсолютного большинства видеоадаптеров от 3Dfx). Однако сами производители видеокарт постоянно борются с этим, выпуская все новые и новые драйвера для своих детищ, и порой делают это весьма успешно. OpenGL является самым перспективным стандартом.
  • Универсальный драйвер позволяет программисту не нужно думать над стыковкой программы (напр. игрушки) с той или иной платой. Однако при этом реализуются только общие (стандартные) функции графики. Поэтому существует целый ряд библиотек от различных разработчиков видеокарт. Это 3DR (Intel), Rave (Apple), Heidi (Autodesk), RenderGL (Intergraph), Criterion Renderware, Argonaut BRender Все они пока не получили широкого распространения ввиду узкого применения.
Королем программирования 3D-акселераторов считается John Carmack (Джон Кармак) из idSoftware.

· Фрейм-грабберы (Frame Gragger, Video capture) - средство захвата видеокадра. По команде движущееся изображение (от видеомагнитофона, камеры, лазерного проигрывателя и т.п.) может быть мгновенно зафиксированно в оверлейном буфере (в память), после чего захваченный кадр может быть записан на диск в виде файла (в каком-либо графическом формате). С этим файлом могут выполняться любые операции нелинейного монтажа (монтажа с произвольным доступом к кадрам). Возможности такого монтажа определяются программным обеспечением и, по сути, безграничны.

· TV-тюнеры - это видео-платы, превращающие компьютер в телевизор. TV-тюнер позволяет выбрать любую нужную телевизионную программу и отображать ее на экране в масштабируемом окне. Видеоизображение выводится в окно, занимающее весь экран или его часть. Поскольку вывод видео перекрывает часть графического изображения, такой способ вывода называют видеооверлеем (Video Overlay), а платы, обеспечивающие данный режим, называют видеооверлейными (overlay board). В оверлейной плате для видеоизображения имеется специальный "слой" видеопамяти. В этом слое содержится оцифрованное растровое изображение каждого кадра видеосигнала. Движущееся изображение, видимое на экране, существует лишь в оверлейном буфере, но никак не попадает в видеопамять графического адаптера и не передается ни по каким внутренним цифровым шинам компьютера. В видеопамяти графического адаптера "расчищается" окно, через которое "выглядывает" видеоизображение из оверлейного буфера. Некоторый цвет (комбинация бит RGB) принимается за прозрачный. Оверлейная плата обычно имеет несколько входов для источников аналогового сигнала и программно-управляемые средства выбора одного из них. Такое устройство обычно имеет в своем составе и фрейм-грабер.
О стандартах видео-изображения - в домашнем ПК-кинотеатре.

© Dmitry Belousov
http://www.orakul.spb.ru
ноябрь 2001г.-июнь 2002г.


"Азбука РС" Дм.Белоусова, CD-Disk

Compact Disc

•

технология CD

Систематизация дисководов
(вид & интерфейс):

•

CD/DVD библиотеки
проекты

•

технология DVD
· Внутренние / Внешние
· IDЕ / SCSI / IEEE / USB
· LPT / PCMCIA

•

single disc (mini-диск)
прошивка

•

технология FMD

Первым Disc-ом была видеопластинка Laservision, которую фирма Philips представила в 1971 году на Берлинской Радио-выставке. Пластинки были двух размеров - 20 см и 30 см. Disc-дисководы имеют USB-, SCSI-, USB-, FireWire-, Parallel-port и IDE-интерфейсы и подключаются непосредственно к магистралям [USB, SCSI - с заданием номера устройства, IDE(АТА) с заданием Master/Slave]. Дисководы IDE работают в стандарте ATAPI (ATA Packet Interface). Для считывания информации применяются два принципа:
· CAV (Constant Angular Velocity) - постоянная угловая скорость.
· CLV (Constant Linear Velocity) - постоянная линейная скорость.
Различают одно- и много-сеансовые (Single & multiple sessions) записи Disc-а.

· Прошивка (микропрограмма) – это софт, который управляет работой декодера и всем прочим, от декодирования секторов CD-ROM, до записи таблицы содержания. Прошивка может храниться как в неизменяемом виде, например, в чипе ПЗУ, или в переписываемом, как в "флэш"-ПЗУ. В первом случае обновление производится путем физической замены чипа. Устройства же с флэш-прошивкой могут обновляться путем скачивания новой прошивки из Internet-а. При обновлении обычно исправляются баги и добавляются дополнительные возможности. Многие прошивки являются необновляемыми. Помните известную мудрость: не ремонтируйте то, что не сломалось!

· Поддержка технологии защиты буфера (BurnProof, JustLink, SuperLink, SafeBurn, etc.) - т.е. защита от ошибок опустошения буфера. При записи диска декодер получает данные из буфера непрерывно и стоит буферу опустошиться - остановится запись => записываемая "болванка" будет непригодна (полностью или частично) к дальнейшему использованию. Опустошение буфера происходит по многим причинам: нехватка ресурсов, снижении скорости источника (при записи с CD-ROM-а), сработавший скринсейвер и т.п. Приводы, оборудованные защитой от опустошения буфера, действуют так: при опустошении буфера лазер выключается, а микроконтроллер запоминает точное местоположение последнего записанного сектора. После наполнения буфера лазер включится, спозиционирует и продолжит запись с того места, где она оборвалась. Буфер имеет объем от 2 до 8Мб.
От отключения электричества во время записи защиты буфера не спасает!

· Каналы под-кода. Существует восемь каналов подкода (P,Q,R,S,T,U,V,W). Данные размещены единообразно на всем CD и каждый канал может вмещать около 4 Мб. Канал подкода P может управляться рекордерами JVC/Pinnacle. Канал подкода Q содержит полезную информацию пользователя и состоит из трех типов данных подкода Q: информация о положении (размещении), каталожный номер носителя и код ISRC (International Standard Recording Code – Международный стандартный код записи). В ISRC указывается страна происхождения, владелец, год выпуска и серийный номер треков и он может быть различным для каждого трека. Каналы подкода R-W используются для текста и графики в некоторых приложениях.

· Мини-диски (Mini-Disc), или MD - это небольшие (64мм) диски, размещающие около 140Мб данных или 160Мб аудио. Спец.технология сжатия позволяет сжимать аудио с коэффициентом 5:1, что дает возможность записать 74 минуты без слышимого ухудшения качества. Как и CD-рекордеры, существуют MD-рекордеры, подключаемые к компьютеру, а также MD-рекордеры, подключаемые к стерео-системе. Существуют штампованные MD, аналогичные CD по конструкции, и перезаписываемые MD, использующие магнито-оптическую технологию записи. MD-аудио-рекордеры обычно удобнее в эксплуатации, чем автономные рекордеры аудио-CD, поскольку проигрывающий механизм дает возможность более гибкого размещения аудио-данных. Вряд ли технология MD заменит CD-R или DAT, поскольку сжатие идет с большими потерями. На сегодня MD продвигается как замена аналоговых аудио-кассет.

· Приводы (главные производители):
[ Goldstar ] [ Kodak ] [ LG ] [ Matshita ] [ Mitsumi ] [ HP ] [ Pioneer ] [ Philips ] [ Plextor ] [ Samsung ] [ Sanyo ] [ Sony ] [ Teac ] [ Toshiba ] [ JVC ] [ Ricoh ] [ Yamaha ] [ Wearnes ]
Подавляющее большинство приводов - внутренние, то есть вставляются внутрь корпуса в 5,25" отсек. Во внешнем исполнении обычно попадаются либо архаичные LPT-шные, либо новые USB-шные рекордеры. Многие из рекордеров - просто OEM-версии устройств других компаний. Но одинаковые "внешне", эти аппараты - разные, т.к. имеют разную прошивку. Любой пишущий дисковод характеризуется тремя основными функциями (т.н. "скоростная формула") - X/Y/Z, где X - скорость записи обычных записываемых (CD-R) дисков, Y - скорость записи перезаписываемых (CD-RW) дисков, а Z - cкорость чтения дисков. Критичны: количество форматов записи (поддерживаемых приводом, в т.ч. DAO (Disk At Once), TAO (Track At Once), Multi-Session и Packet Writing), поддержка приводом режима форсированной записи (Overburn) или запись информации на диск, превышающей документированный объем (OverSizing, OverBurning), поддержка записи в режиме RAW-mode (способность устройства работать с программами копирования защищенных дисков). Для CD-RW еще желателен отдельный блок управления скоростью чтения. Использование SCSI -интерфейса резко облегчает работу процессору, но есть неспособность IDE-винчестера поставить для SCSI CD-RW очередную порцию данных и параллельно осуществлять дополнительную ресурсоемкую задачу. Поэтому SCSI - к SCSI.
Не существует идеальных рекордеров, просто некоторые лучше. Лидером по функциям является Plextor (ценой, увы тоже).

· CD-RW+DVD-ROM (комбо-дрaйв). Устройство использует общий механизм загрузки, шпиндельный узел и устройство радиального перемещения оптико-механической системы (pickup). Позволяет как записывать CD, так и смотреть фильмы на DVD.

         "... - Моя подставка для кофе сломалась!!!
- Какая подставка?!?!?!?!?!
- Ну на ней еще 50х написано ..."

CD (Compact Disk Read Only Memory, компакт-диск, "блин"). Максимальная емкость CD-ROM составляет 680 Мбайт и 180 Мбайт для дисков диаметром 12 и 8 см соответственно. Толщина диска CD-ROM составляет 1,2 мм. Типовой CD состоит из платы электроники, шпиндельного двигателя, системы оптической считывающей головки и механизма загрузки диска. Скорость передачи данных (при стандартной скорости вращения диска) составляет 150 Кб/сек. Для малых n-скоростных CD скорость возрастает пропорционально (8х=1200Кб/сек). При более 10х ограничивают верхний предел скорости на внутренних дорожках. Очень быстрые приводы (например, 72х) в действительности не раскручиваются до таких скоростей, вместо этого используется несколько лазеров для считывания нескольких областей диска одновременно.

Важная цифра в каждом из CD-форматов - число байтов данных пользователя на сектор - это количество данных, которые Вы можете фактически записывать в каждом секторе - 2048 байтов (2 килобайта). Математический расчет для 74-минутного recordable диска:
74 min x (60 sec) x (75 sectors) x (2 kbytes) = 660,000 kilobytes = 650 megabytes
Наиболее вероятно пропускная способность диска вычисляется согласно числу байтов, которые были бы сохранены на диске, если это записано в CD-DA (звуковом) формате:
74 min x (60 sec) x (75 sectors) x (2352 bytes) = 783,216,000 bytes = 764,859 kilobytes = 747 megabytes
Но реально из-за сеанса и накладных расходов файловой системы фактически получится приблизительно на 20Mb меньше данных на диске. Реальный битрейт значительно выше из-за EFM, CIRC, L2 ECC, etc. Битрейт канала составляет 4.3218 МГц. Развиваемые форматы СD:
  • CD-DA (CD-Digital Audio) ..... цифровой звуковой, как правило, музыкальный компакт-диск со временем звучания до 74 мин. Существует три различных режима записи AudioCD-дисков: 1) Disc At Once (DAO, сразу диск); 2) Track At Once (TAO, сразу дорожку); 3) Session At Once (SAO, сразу сессию).
  • SACD (Super Audio Compact Disc) ..... новые диски, могут иметь два слоя, один из которых будет в аудиоформате Красной книги, другой – в похожем на DVD формате, обеспечивающем высокое качество. SACD – альтернатива DVD-audio, созданная фирмой Sony. В сущности они не являются форматом CD. Такие диски могут иметь соответствующий Красной книге слой, считываемый обычными CD проигрывателями, но для реализации их преимуществ необходим специальный проигрыватель.
  • CD-ROM Mode (CD-ROM Mode-1, CD-ROM Mode-2) ..... - это стандартные секторы Желтой книги.
  • CD-ROM XA (расширенная архитектура)..... CD-ROM Extended Architecture Mode-2, CD-ROM Extended Architecture Form 1/2. Расширенный формат компакт-диска с данными, позволяющий объединять звук и изображение для их одновременного (синхронного) воспроизведения. eXtended Architecture - мост между Желтой книгой и CD-i. FORM-1 - 2048 байт данных, с коррекцией ошибок, для данных. FORM-2 - 2324 байт данных, без коррекции ошибок, для аудио/видео.
  • CD-R (CD-Recordable, записываемый СD)..... - компакт-диск с однократной записью (матрицу CD-R называют "болванкой"). Записываемые CD являются носителями WORM (Write Once, Read Multiple – однократной записи, многократного чтения), которые работают так же, как и обычные CD. Можно воспроизводить эти диски на обычном проигрывателе CD, но нельзя записать его повторно. Цифры после названия модели (например "4x2/512K") обозначают скорость считывания и записи аппарата и размер буфера записи. "4x2" означает двухскоростной рекордер, способный читать на четвертой скорости. Дисководы CD-Rewritable способны записывать как диски CD-R, так и CD-RW. Существует два класса аудио CD-R, бытовые и профессиональные.
  • CD-RW (CD-E, стираемые CD) ..... перезаписываемые компакт-диски. Можно стирать диски и повторно использовать их, но диски CD-RW не читаются на многих старых приводах CD-ROM и проигрывателях аудио CD. Цифры обозначаются как и в CD-R, но будет присутствовать третье значение (например "6x4x2/1MB" - это привод, читающий на 6х, пишущий на CD-R на 4x, и пишущий на CD-RW на 2x). ComboDrive.
  • CD-I (CD-Interactive, CD-i/FMW, также известен как Зеленая книга) ..... интерактивный компакт-диск, предназначенный для хранения до 90 минут видеоизображения со звуком.
  • CD-WO ..... однократно записываемые (также известен как Оранжевая книга). Физический формат для записываемых CD.
  • CD-Extra (CD-Plus, также известен как Голубая книга) есть двухсессионный формат диска, разработанный фирмами Philips and Sony. Первая сессия содержит аудио-трэки, а вторая cессия - один дата-трэк. Т.е. диск записан в формате CD-Extra, если он содержит одновременно аудио-сессию и сессию с данными. Аудио-сессия всегда идет первой, таким образом обычные аудио-плееры могут беспроблемно её воспроизводить. CD-ROM читает вторую сессию, которая содержит произвольные данные, обычно дополнительную информацию об исполнителе (фотографии, тексты песен, видео).
  • Video CD (Compact Disc Digital Video, также известен как Белая книга).
  • SVCD (Super Video Compact Disc). Диски используют один из стандартных форматов CD-ROM.
  • Photo CD ..... фото компакт-диск от фирмы Eastman Kodak. Single & multiple sessions. Представлена в сентябре 1990г., продемонстрирована в полном виде - в конце 1992г. Используется для хранения цифровых фотографий. На диске может храниться от 100 до 800 фотоизображений с разрешением от 2048х3072 до 256х384 точек соответственно, а также звуковая информация. Для воспроизведения Photo-CD нужен привод, поддерживающий формат CD-ROM/XA. Фирма Kodak ввела лицензирование услуг Photo CD.
  • CD-Text ..... это "продвинутая" возможность для AudioCD (Красная Книга). CD-Text содержит на диске дополнительную текстовую ифнормацию, например, Заглавие диска, исполнителя и название композиции для каждого трека и т.д. Большое количество CD-ROM и бытовых аудио-плееров не читают CD-text информацию, не все пишущие CD приводы могут писать CD-Text, но практически всё программы записи CD имеют функции для работы с CD-Text.
  • DTS CD (Compact Disc Dolby Theater Surround) ..... - CD те же, что и обычные, но используют кодировку DTS вместо PCM.
  • HDCD (High Definition Compatible Digital) ..... - диски записаны в формате Красной книги, но некоторые биты аудио содержат дополнительную закодированную информацию. Они звучат на обычном CD проигрывателе, но лучше на проигрывателе HDCD.
  • прочие: Audio Karaoke CD, CD+G (CD с графикой), CD-ROM Mixed Mode, CD-R/RW, CD-IFMV, CD-Bridge, DVCD, CD-MO (магнитно-оптические), CD-RFS (дифференциальная файловая система пакетной записи Sony), CD-UDF (промышленная дифференциальная файловая система пакетной записи).
Диски, на которых сессия с данными размещена в начале (как в некоторых компьютерных играх со звуковыми дорожками в формате AudioCD), не являются CD-Extra!

· поверхность CD-ROM-a: в соответствии со стандартами (ISO 9660 c последующими дополнениями) поверхность разделена на три области:

  1. Входная директория (Lead In) - это область в форме ближайшего к центру диска кольца шириной 4 мм, которая читается первой. Здесь находятся: оглавление (TOC - Table of Contents), адреса всех записей, число заголовков, суммарное время (объем) записи, имя диска (Disc Label) и т.д.
  2. Область данных в форме кольца шириной 33 мм, в которой записана основная информация диска в виде файловой системы;
  3. Выходная директория (Lead Out) c меткой конца диска.

         "... Жизнь - игра, в которой нет setup'а ..."

CD-болванки (CD-R, болванки, матрицы). В отличии заводских дисков, штампуемых на алюминиевую основу с золотого мастер-диска, однократно записываемые диски покрыты специальным отражающим слоем (золото или серебро) и слоем красителя. Лазер прожигает "дырки" в слое красителя и именно этими "дырками" и выпуклостями (lands & pits) кодируется информация на CD. Мощность лазера большая, чем в обычных CD-дисководах. Различают виды красителей:

  • цианиновый (Cyanine) - первый краситель для CD-R. Цианин придает диску синюю окраску (в комбинации с золотым отражающим слоем она становится зеленоватой).
  • фталоцианиновый (Phtalocyanine) - современная разработка. Фталоцианин практически бесцветен (легкий зеленоватый оттенок), вместе с серебряным отражающим слоем дает зеленовато-желтую окраску диску, а с золотым отражающим слоем - золотистую окраску.
  • MetalAzo (специальный). Разработка Mitsubishi Chemicals, имеет ярко выраженный темно-синий цвет; диски продаются они под маркой Verbatim DataLife Plus и Verbatim Color.
  • UltraGreen (специальный), используется активный слой dye. Разработка компании CIBA. В России используется для производства CD-R Mirex по технологии Plasmon.
Все красители достаточно надежны и легко считываются на любых дисководах. Долговечность красителя не имеет значения, т.к. болванка поломается, потеряется или поцарапается задолго до начала проблем с красящим слоем (50-70 лет). Кстати, обычные Verbatim Datalife производятся CMC Magnetics на фталоцианиновой основе.
Болванки бывают двух видов:
  • одноразовой записи (CD-R) - можно записывать, но нельзя стирать. Нельзя "физически", но если в следующей сессии убрать ссылки на некоторые файлы, то они станут не видны (хотя и будут занимать место на диске);
  • многоразовой записи (CD-RW) - можно записывать и стирать до 1000 раз (реально - меньше из-за царапин). Диски CD-RW имеют вместо слоя красителя - Phase-change слой, укрытый сверху и снизу двумя слоями диэлектрика (из-за них слоев все CD-RW имеют металлическо-коричневый цвет оборотной стороны). Вещество в регистрирующем слое (сплав индий-сурьма-теллур-серебро) под действием лазера меняет свое состояние и становится либо амфорным (не пропускает свет, "pit"), либо кристаллическим (пропускает свет, "land"). Лучшие - Hi-Speed.
У CD-RW есть недостаток - низкая отражающая способность, в разы меньшая, чем у обычных CD-R дисков или "штамповки". За счет этого RW-шки не читаются на большинстве старых CD-ROM-ов и на многих бытовых приводах (музыкальные центры и т.п.). Но перезаписываемые CD-RW-шки удобны для постоянной архивации данных - можно все стереть и перезаписать другой информацией.

· Производители "болванок": brand-фирмы скупают у реальных фирм-производителей готовые матрицы, упаковывают их, маркируют и продают как свои. Т.е. Philips, BASF, Sony, Samsung, Verbatim и т.д. - не настоящие. Кстати Mirex - это Уральский электронный завод. Но некоторые (TDK, Kodak) продают свои матрицы под своей же торговой маркой. "Реальный" производитель ищется по данным в ATIP. В коробках TDK обычно встречаются диски TDK, Taiyo Yuden и Ritek (на шпинделе, т.н. Bulk упаковка), в коробках Kodak - только Kodak. Memorex продает болванки от CMC Magnetics, диски Verbatim Color и Verbatim Datalife PLUS - это Mitsubishi Chemicals, просто Verbatim Datalife - CMC Magnetics, Crystal. Samsung - в исполнении Ritek, диски от Prodisc - в коробках Shuttle, Dysan и FlexData. Philips обычно продает Ritek-овские болванки, а Mirex - MultimediaMasters'n'Machinery и Plasmon. SONY обычно продает болванки в исполнении Taiyo Yuden.
ATIP (Actual Time In Pregroove) - эта специальная область (дорожка) на диске, которая служит для калибровки лазера при записи. На ней закодирована информация о реальном производителе, регистрирующем слое красителя, реальном объеме диска и допустимых скоростях записи. ATIP считывается с диска специальными утилитами (напр. СDRId). Производители, чьи "болванки" продаются в России:

[ TDK ] [ Kodak ] [ CMC Magnetics ] [ Taiyo Yuden* ] [ Plasmon ] [ Mitsubishi Chemicals* ] [ Prodisc ] [ Ritek ] [ Crystal ] [ MultiMedia Masters & Machinery ]

* где "Taiyo Yuden" это "TY", а "MultiMedia Masters & Machinery" - "4M".
Для начала "записей" советую взять 2-3 качественных (TDK Ultra, Verbatim DataLife Plus для важных дисков) и bulk (шпиндель на 25 шт.) с новыми матрицами Mirex. "Болванки" CD-R(W) выпускаются в пяти видах:

  • CD-коробка - стандартный бокс, обтянутый п/э;
  • "slim-CD"-коробка - тонкий бокс, обтянутый п/э;
  • в бумажных конвертах - для комплекта с журналами, справочниками, книгами, etc. Бывают также в п/э конвертах;
  • bulk-упаковка - "колбаса" CD-R носителей (25 шт., 50 шт., 100 шт.). Т.е. это CD без коробок, на шпинделях;
  • подарочная упаковка - индивидуальный бокс (напр. W-23G, S-57G);
В РФ под видом Mirex продаются множество китайских noname-подделок. Два нюанса: с 01.12.2002 года завод прекратил выпуск CD-R объемом 650 Мб/74 мин, а с 01.01.2002г. весь Mirex, выходящий в bulk-упаковках, будет сверху дополняться вот такими дисками:

· "Сохранность" дисков: СD-R(W) диски нельзя купать в воде (кислоте, спирте, ацетоне и т.п.); писать на них чем-либо, кроме специального мягкого фломастера на водяной основе (Water-based ink); долго держать под солнечными лучами и царапать. Особенно чреваты повреждения лицевой стороны (там, где обычно бывает полиграфия) и концентрические (круговые) царапины. Легкие радиальные (от центра к внешней стороне) менее опасны и система коррекции ошибок сможет восстановить данные, то концентрическая (как и глубокая радиальная) дает практически 100% гарантию нечитаемости этих данных, а может и всего диска. Будьте осторожны!

         "... Вижy DVD, пpиклеенный к коpпyсy скочем... - Зачем? - Чтобы сам не открывался ..."

DVD (Цифровой Универсальный Диск) - это семейство оптических дисков, одинакового с CD размера, но большей емкости хранения (4,7-50 Гбайт), достигнутой за счет увеличения плотности записи. Все разновидности дисков имеют габариты обычного CD диска (диаметр 12 см, толщина 1,2 мм). Название DVD первоначально означало Digital Video Disc. Позднее (из-за расширении функций DVD) аббревиатура стала читаться иначе - Digital Versatile Disk. Начало разработки формата DVD - сентябрь 1995г. В мае 1997г. 10 компаний (Hitachi, JVC, Matsushita, Mitsubishi, Philips, Pioneer, Sony, Thomson, Time Warner, Toshiba) создали DVD-консорциум (ныне — DVD Forum, насчитывающая более 200 членов). Принцип работы DVD: луч лазера вызывает кристаллографические изменения в активном слое оптического диска (а именно, в результате облучения вещество меняет свое состояние с кристаллического на аморфное и наоборот). По конструкции различают четыре типа DVD дисков:

  • DVD-5 (Single-sided, single-layer disc) - это первая версия DVD-диска: односторонний диск с однослойной записью и max емкостью 4,7 Гб. DVD состоит из 0,6 мм пленки, покрытой аллюминием и наклеенной на чистую подложку. Технология напыления та же, что для обычного CD. Алюминиевая пленка имеет толщину 55 нанометров, как и для аудио-CD и CD-ROM;
  • DVD-9 (Single-sided, double-layer disc) - это двух-уровневый односторонний диск с max емкостью 8,5 Гбайт. Создается полупрозрачный слой, который отражает 18-30% лазерного излучения. Это позволяет считывать информацию с верхнего слоя. И в то же время полупрозрачный слой будет пропускать достаточно излучения, чтобы сигнал от нижнего уровня с высокой отражательно способностью тоже читался. Информационные уровни разделяет высоко-однородный клей (толщина клеевой прослойки составляет 40-70 микрон), используемый для соединения двух половин диска. Это расстояние необходимо, чтобы различить сигнал, отраженный от 1-го и 2-го уровней. Оптимальный материал полупрозрачного слоя - золото, но используются кремниевый и серебряный сплавы. Считывание данных с внутреннего или внешнего слоя производится с помощью перефокусировки оптической системы;
  • DVD-10 (Double-sided, single-layer disc) - однослойный двухсторонний диск с одним информационным слоем и max емкостью 9,4 Гб (по сути это двойной DVD-5 без чистой подложки). Два диска, покрытых металлическими пленками, соединены вместе. Для считывания информации с 2-х сторон диска используется один лазер;
  • DVD-18 (Double-sided, double-layer disc) - двухсторонний диск с двумя информационными слоями и max емкостью 17 Гб. Структура DVD-18 та же самая, как и у DVD-9.
В настоящее время серийно выпускаются только видеодиски DVD-5 и DVD-10. Значение 1х для DVD-накопителей эквивалентно скорости 8х CD-накопителя. CD и DVD - слишком разные форматы, поэтому нельзя записать DVD на вашем CD рекордере. Однако, можно конвертировать содержимое диска DVD в формат более низкого качества.
Существующие и развиваемые стандарты (форматы) DVD:
  • DVD-ROM ..... Только для чтения. Digital Versatile Disc Read Only Memory, предназначены для компьютерной техники. Информация заносится на диск единственный раз - при его производстве. Большинство накопителей непригодны для чтения многосеансовых дисков. Устройства DVD-ROM бывают 3-х поколений: первое - использовали режим CLV и считывали с диска со скоростью 1.38 Мб/с (1х DVD), второе - читают DVD со скоростью - 2.8 Мб/с (2х DVD), третье - используют режим контроля вращения (CAV) с максимальной скоростью чтения 5.5 - 8.3 Мб/с (4х-6х DVD).
  • DVD-Video ..... Только для чтения, предназначен для хранения и воспроизведения видео (до 2-х часов в формате сжатия MPEG-2, многоканальное звуковое сопровождение [на 8 языках], выбор экранного формата, титры на 32 языках, экранное меню, до 9 угловых направлений просмотра).
  • DVD-Audio ..... Только для чтения. Есть две версии: просто DVD-Audio - только для звукового содержания и DVD-AudioV - для звука с дополнительной информацией. Поддерживает широкий диапазон качества звука (квантование 16, 20, 24 бит при частоте от 44,1 до 192 кГц).
  • DVD-AR ..... Для многократной перезаписи звука, DVD Audio Recording. Позволит записывать, редактировать и воспроизводить высококачественную запись звука с использованием линейной и сжатой импульсно-кодовых модуляций, а также запись большого объема звука с использованием одного из шести кодеков, сжимающих звук с потерей данных. Помимо звука, DVD-AR дает возможность записывать изображения и текст
  • DVD-RAM ..... Для многократной перезаписи, Digital Versatile Disc Random Access Memory, одобрен DVD-форумом в июле 1997г. Возможность перезаписи до 100.000 раз. Два типа односторонних DVD-RAM - в картридже и без картриджа. Картриджи могут быть двух видов - открываемые и цельные. Первое поколение дисков DVD-RAM вмещало 2.6 ГБ на сторону, второго - 4,7Гб на стороне (9,4Гб для двусторонней). DVD-RAM-приводы читают диски DVD-ROM и могут быть прочитаны только приводами DVD-ROM третьего поколения (выпуск от середины 1999г.).
  • DVD+RW ..... Для многократной перезаписи, Digital Versatile Disc ReWritable. Не поддержан DVD-форумом, только разработчики (Hewlett-Packard, Mitsubishi Chemical, Philips, Ricoh, Sony, Yamaha). Для записи как потокового видео или звука, так и компьютерных данных. Диски могут быть перезаписаны около 1000 раз. DVD+RW полностью совместимы с оборудованием, работающим в форматах DVD-Video и могут быть воспроизведены как на выпущенной ранее бытовой аппаратуре DVD, так и прочитаться обычными DVD-Video плеерами. На базе DVD+RW создан формат записи потокового видео - DVD+RW Video Format.
  • DVD-RW (DVD-R/W, DVD-ER) ..... Для многократной перезаписи, Digital Versatile Disc ReRecordable. Вмещают 4,7 ГБ на одну сторону, выпускаются в односторонней и двусторонней модификациях. Могут быть перезаписаны до 1000 раз и прочитаны на приводах DVD-ROM первого поколения.
  • DVD-R(G) ..... Для одноразовой записи, Digital Versatile Disc Recordable. DVD-R for General отличается от DVD-R(A) другой длиной волны лазера при записи информации. Диски этого формата защищены от возможности побитового копирования на них информации с других дисков. Формат поддерживается в устройствах массового хранения (например, в DVD-библиотеках).
  • DVD-R(A) ..... Для одноразовой записи, Digital Versatile Disc Recordable. DVD-R for Authoring используется в профессиональных приложениях. В частности, поддержка специального формата (Cutting Master Format) позволяет применять эти диски для записи исходной реплики информации (пре-мастеринг).
  • DVD-VR ..... Для видеозаписи. Основана на DVD-RAM. Формат позволяет записать в реальном времени до 2 часов высококачественного видео в формате MPEG-2 на односторонний диск. Старое название - формат MMVF (MultiMedia Video File) компании NEC.
  • HD-DVD (1) ..... Для многократной перезаписи, High-Definition DVD. Поддерживается Toshiba и NEC, формат представлен в августе 2002г. Разработан для новых оптических дисков, емкостью дисков - от 15 до 17Гб. См. "голубой лазер".
  • HD-DVD (2) ..... Для многократной перезаписи, High-Definition DVD. Поддерживается девятью фирмами (Hitachi, LG Electronics, Matsushita, Pioneer, Philips, Samsung, Sharp, Sony, Thomson), формат представлен в сентябре 2002г. Разработан для новых оптических дисков, емкостью дисков - от 15 до 17Гб. См. "голубой лазер".
  • HD-DVD (3) ..... Для многократной перезаписи, High-Definition DVD. Разрабатан тайваньским консорциумом Advanced Optical Storage Research Consortium при поддержке тайваньского правительства. Формат представлен в октябре 2002г., емкость дисков - от 15 до 17 Гб. Принят только на тайваньском и китайском рынках. См. "голубой лазер".
Разработчики не смогли достичь единого формата записываемых дисков. Поэтому диски, записанные в одном из форматов, как правило, не читаются на приводах других записываемых форматов - т.е. отсутствие поддержки одним устройством нескольких записывающих форматов. DVD-устройства могут не понимать тот формат дисков DVD, который был предложен уже после их выпуска. Бытовая электроника ориентирована на два формата: DVD-Audio, DVD-Video.
Существующие над-стандарты (форматы) DVD:
  • DVD-Multi ..... Объединены спецификации DVD-Video, DVD-ROM, DVD-Audio, DVD-R, DVD-RW, DVD-RAM, DVD-Video Recording, DVD Audio Recording. Спецификация разработанна компаниями Toshiba, Panasonic и Hitachi и в 2002г. поддержана членами DVD Forum-а. Предусматривает отказ от некоторых предыдущих наработок в пользу создания более совершенной технологии перезаписываемых DVD дисков. Полноразмерные диски DVD Multi имеют объемы 4.7 и 9.4Гб, а 8 сантиметровые, для использования в портативной технике - 1.4 и 2.8 Гб. DVD-Multi может применяться как в бытовой электронике, так и в ПК. Доля DVD Multi - 90% выпускаемых в мире приводов DVD.
  • DVD-Dual ..... Развитие спецификации DVD+RW. Поддерживается Sony и Philips, не одобрен DVD Forum-ом. Полная совместимость со всеми, когда-либо выпускавшимися DVD-плеерами и компьютерными приводами. Лидеры рынка бытовой электроники (т.е. все DVD-плееров воспринимают формат DVD+RW).
· Файловая система "UDF". В 2000 году принята единая файловая система технологии DVD - MicroUDF. Файловая система MicroUDF - это, адаптированная для применения в DVD, версия файловой системы UDF (Universal Disk Format), которая, в свою очередь, основана на международном стандарте ISO-13346. Эта файловая система постепенно идет на смену устаревшей ISO9660, созданной в свое время для использования в компакт-дисках. На переходный период (пока не выйдут из обращения компьютерные устройства и диски, работающие в формате ISO9660) будет использоваться файловая система UDF Bridge, которая является некоторой комбинацией MicroUDF и ISO9660. Для записи Audio/Video DVD дисков может использоваться только MicroUDF.

· Регион DVD. Для защиты от пиратов стандартом DVD-Video предусмотрено введение специального регионального кодирования как самих DVD-дисков, так и проигрывателей для них. Имеется аналоговое (Analogue Protection System фирмы Macrovision) и цифровое (Content Scrambling System) кодирование. Весь мир условно поделен на 6 зон, каждой из которых присвоен соответствующий код. Для каждой из этих зон выпускаются предназначенные для нее версии DVD-дисков и соответствующие им DVD-пригрыватели. Только при совпадении кодов проигрыватель может воспроизводить установленный в него диск. Номер зоны указывается на каждом DVD-диске и на каждом DVD-проигрывателе (на задней панели). Вид маркировки - стилизованного изображения земного шара, внутри которого помещен номер регионального кода. Коды зон:

  • США, Канада - 1;
  • Европы и Япония - 2;
  • Юго-Восточная Азия - 3;
  • Австралия, Центральная и Южная Америка - 4;
  • Африка и СНГ (в т.ч. Россия)- 5;
  • Китай - 6;
Для проигрывания на привода дисков любой зоны, меняют код у программного декодера, отвечающего за воспроизведение DVD-изображения. Для этого есть множество утилит (самая знаменитые - официальная DVD Genie и хакерская DeCSS Йона Йохансена), позволяющих настраивать скрытые параметры программных DVD-декодеров.
Сегодня выпускаются приводы типа RPC2, позволяющие изменять код региона не более пяти раз, после чего эта процедура блокируется. Приводы, выпускавшиеся ранее, не имели региональной защиты и назывались RPC1. Т.е. нужно также поменять firmware (программное обеспечение, которое зашивается в привод при изготовлении и управляет его работой) на аналогичное, но с отключенной процедурой проверки кода. В Internet-e регулярно появляются прошивки, удаляющие защиту с приводов RPC2 и превращающие их в RPC1. Запись неподходящего Firmware или ошибка в процессе прошивки необратимо выведет из строя Ваш DVD-привод!
Существуют мультизонные варианты и DVD-дисков и DVD-проигрывателей. Вместо номера региона на маркировке - надпись «ALL». Диски, имеющие такую маркировку, могут быть воспроизведены на проигрывателе любой зоны, а мультизонные проигрыватели могут воспроизвести любой диск (стоят дороже).

· Перспективы DVD. "Запаса прочности" у действующей DVD-технологии "красного лазера" уже практически нет - объем до 17 Гбайт является предельным. Но:
1. уже разработано (для стандарта DVD-RAM) следующее поколение оптических дисков. В них запись/чтение будет производиться фиолетовым лазером (технология коротковолнового "голубого лазера") с длиной волны 405 нм, что позволит на одной стороне диска размещать до 27 Гбайт, а в двухслойном варианте – 50 Гбайт. В таких дисках, которые называются Blu-Ray Disc, расстояние между треками (tracking pitch) уменьшено до 0,32 мкм, а минимальный размер пита составляет 0,138 мкм. При этом новые диски позволяют размещать до 13 часов видео стандартного разрешения. Параметры Blu-Ray-диска и "обычного":

Параметры | Blu-Ray Disc | DVD-RW
Диаметр диска, мм | 120 | 120
Толщина диска, мм | 1,2 | 1,2
Емкость одного слоя, Гбайт | 23,3 / 25 / 27 | 4,7
Длина волны лазера, нм | 405 | 650
Числовая апертура лазера | 0,85 | 0,6
Скорость передачи, Мбит/с | До 36 | До 10
Способ записи | Изменение фазового состояния | Изменение фазового состояния
Количество перезаписей, не менее | 10.000 | 1.000
Ширина трека, мкм | 0,32 | 0,5
Минимальная длина пита, мкм | 0,160 / 0,149 / 0,138 | 0,4

2. компания Calimetrics Inc предложила технологию ML (multilevel), позволяющую в три раза повысить емкость стандартного DVD/CD. При этом нет необходимости совершать какие-либо доработки в механизме и оптике существующих приводов. Для внедрения достаточно воспользоваться спец.набором микросхем.

         "... Пpогpаммист увидел HЛО:
- У кого-то диск полетел ..."

Компанией "Constellation 3D" был изобретен новый формат: FMD (Fluorescent Multilayer Disk), флуоресцентный многослойный диск, "трехмерный диск". Компания существует с 1995г., имеет офисы в Нью-Йорке, Флориде и Калифорнии, а также лаборатории в Израиле и России; обладатель более 60 патентов. Президент - физик Евгений Левич, эмигрировавший из России в 1975 году.
Первым поколением дисковых продуктов компании Constellation 3D стало семейство 120 мм многослойных FM-дисков с вместимостью до 140 Гбайт и со скоростью чтения до 1 Гбита в секунду. Пример объема: диск способен вместить до 20 часов сжатых фильмов в формате HDTV.
FMD-диск прозрачный и данная технология не нуждается в присутствии отражающего слоя. Технологическое производство FM дисков имеет две разновидности. В первой используется метод горячего тиснения (выдавливания), во второй метод использует процесс фотополимеризации, при котором многослойный диск получается складыванием слоев одним за другим (формирующиеся из "тонких отпечатков"). FMD-приводы будут понимать форматы как CD, так и DVD-дисков.
C3D ведут разработку системы вопроизведения для цифровых кинотеатров а также для HDTV (телевидение высокой четкости) пока с использованием красных лазеров. При использовании синего лазера (480 нм, более дорогого) возможно увеличение плотности записи до десятков Тбайт на один FM диск. В ноябре 2000 в Нью-Йорке в цифровом кинотеатре состоялась премьера фильма "Bounce" на FMD-диске. Оптические диски это один из возможных носителей для полностью цифрового кинопроката, но шифрованная доставка по широкополосным сетям (возможно со спутника) на данный момент имеет больше шансов.

         "... Опыт pастет пpямо пpопоpционально выведенномy из стpоя обоpyдованию ..."

· Сотовый CD-привод. В июне 2002г. голландская компания Philips Electronics продемонстрировала прототип CD-устройства, имеющего размеры 5,6-3,4-0,75 см и CD-диск с диаметром в 3 см. Их создание стало возможным благодаря использованию лазера синего диапазона, имеющего меньшую длину волны, чем у красного в существующих CD. Емкость трехсантиметрового диска в полтора раза больше обычного CD, то есть превышает гигабайт. Привод планируется использовать в сотовых телефонах, palm-ах, ноутбуках и других мобильных устройствах. Недостатками мини-CD: большие размеры самого привода по сравнению с flash-карточками, большее энергопотребление из-за необходимости вращать шпиндель и большая цена.

· Технология UDO. Plasmon объявил о разработке новой технологии UDO (Ultra Density Optical) сверхвместительных 5.25-дюймовых устройств нового поколения. Новая разработка использует 405нм сине-фиолетовый лазер и технологию смещения фазы. UDO прежде всего рассчитана на профессионалов и позволяет добиться высокой производительности, более эффективной и малостоящей, чем DVD. Носители будут располагаться в 5.25-дюймовых картриджах, используемых сегодня, для обеспечения совместимости с носителями текущего поколения, как однократнозаписываемых, так и перезаписываемых носителей.

· Отдельные рекордеры. Автор не рассматривал отдельные рекордеры типа "CD Blaster" или "CD Dupe-It", которые представляют из себя коробки с процессором, CD-R и жестким диском, способные копировать CD без привязки к компьютеру. Большинство из этих low-end наборов представляет собой "железо" и софт, собранные в один аппарат, так что их отдельное упоминание не имеет особого смысла.

· Роботизированная CD/DVD библиотека. "...Роботизированную дисковую библиотеку надо покупать, если речь идет о хранении 500 гигабайтов или терабайта, т.е. тогда, когда CD-R просто не подходит...". Традиционно CD/DVD библиотеки соединялись с ПК посредством интерфейса SCSI. Сейчас чаасто включают их в сеть как самостоятельное устройство - NAS (Network Attached Storage). Для этого используется соединение 10/100 BaseT Ethernet. Дисковые библиотеки производят Cygnet, Plasmon, Quikstor, ЭЛАР НСМ, Pioneer, Kubota, Asaca и JVC. В 2001г. рынок пр-ва CD/DVD библиотек покинул Kodak. Обычное время инсталляции CD/DVD библиотеки - за 15 минут.
Роботизированные DVD-RAM библиотеки Plasmon вмещают 120, 240 и 480 дисков, что составляет объем 312 ГБ, 624 ГБ и 1,2 ТБ соответственно при использовании дисков DVD-RAM 4,7 ГБ. В конструкции библиотеки используются кассеты на 10 дисков для бесконтактной работы с носителями. Plasmon объявила о начале работы с двусторонними дисками. Теперь библиотеки вмещают 750 ГБ, 1,9 ТБ и 4,7 ТБ.
Примеры: Элар НСМ 0,6 - 5,8ТБ, Asaca 2,4 - 109ТБ, JVC 0,5 - 5,1ТБ, Plasmon 0,7 - 4,7ТБ.

Вместо эпилога - сводная таблица некоторых параметров трех технологий. От FMD взят один из проектов - 50 Гбайтный диск (12-слоев):

Параметр | CD | DVD | FMD
Диаметр диска, мм | 120 | 120 | 130
Вместимость, Гбайт | 0,64 | 17,4 | 50,8
Число слоев | 1 | 2 (на каждой стороне) | 12
Расстояние между слоями, мкм | --- | 40 | 25±5
Общая толщина информационных слоев | 0,11 мкм | 2 мкм | 275 мкм
Формат | CD | DVD | Модифици- рованный DVD
Расстояние между треками, мкм | 1,6 | 0,74 | 0,8
Длина волны, нм | 780 | 635-650 | 532

Итоги: CD-RW постепенно заменяют флоппик, новые DVD-рекордеры все еще дороги, к тому идет война форматов. А если после прочтения этого текста Вы "еще понимаете автора", примите мои поздравления - Ваш IQ явно выше среднего :)

© Dmitry Belousov
http://www.orakul.spb.ru
ноябрь 2001г.-январь 2003г.


"Азбука РС" Дм.Белоусова, оперативная память

Оперативная память

•

SIMM & SIPP
30-штырьковые
• Single In-line Memory Modules
• Single In-line Pinned Packages
модули памяти, шины памяти, оперативка, "мозги"

•

DIMM
• 168-штырьковые DIMM
• 200-штырьковые DIMM

•

DDR SDRAM (DDR I, DDR II, DDR III)
SLDRAM & RLDRAM

•

Direct Rambus (RDRAM, RIMM)
Молекулярная память

•

Голографическая память

· История... Во время появления первых действующих компьютеров сложилось деление памяти на внутреннюю и внешнюю. Под внутренней подразумевалась память, расположенная внутри процессорного "шкафа" (или примыкающая к нему). Сюда входила и электронная и магнитная память (на магнитных сердечниках). Для внутренней памяти характерен одномерный (линейный) адрес, который представляет собой одно двоичное число. Доступ к памяти осуществляется по адресу, заданному программой и для процессора она является непосредственно доступной. Сегодня внутреняя (и оперативная, и постоянная) электронная (полупроводниковая) память является хранилищем программного кода, который непосредственно может быть исполнен процессором и устанавливается на системной плате или на платах расширения.
Т.н. "внешняя память" раньше представляла собой отдельные устройства с подвижными носителями - накопители на магнитных дисках (в т.ч. на барабанах) и ленте. Процессор или программа могли получить доступ к содержимому файлов только опосредованно через отображение в какой-нибудь области оперативной памяти. Т.е. доступ осуществляется к некоторому блоку (имееющего многомерный адрес), внутри которого каждая ячейка имеет свой адрес. Исполнить программный код или обратиться к данным непосредственно на диске процессор не мог (и не может сейчас). В настоящее время "внешняя память" - память, реализованная в виде устройств с различными принципами хранения информации и обычно с подвижными носителями. Т.е. она используется для хранения файлов и ее современное название - накопители данных. Это миниатюрные накопители и винчестеры, стриммеры, Zip-ы и Jazz-ы, USB-диски и устройства хранения, магнитооптика и пр.

Обычно под компьютерной памятью понимают только "внутреннюю память" компьютера, которая в свою очередь классифицируется на:

  • ОЗУ, оперативное запоминающее устройство с оперативной памятью (RAM, Random Access Memory) - памятью с произвольным доступом (английский термин), определяет допустимый объём и скорость одновременно выполняемых процедур. Произвольность доступа подразумевает возможность операций записи или чтения с любой ячейкой ОЗУ в произвольном порядке. До последних лет из микросхем памяти использовали два основных типа: статическую (SRAM - Static RAM) и динамическую (DRAM - Dynamic RAM).
  • ПЗУ (постоянное запоминающее устройство, ROM, Read Only Memory, память только для чтения) - постоянная память, информацию из которой можно только считывать. Это одна или несколько микросхем, расположенных на системной плате и содержащих набор подпрограмм. На такую память, например, помещена Bios.
  • Cashe-память (Кэш-память, Cashe Memory) - сверхоперативная память (СОЗУ), является буфером между ОЗУ и процессором (несколькими процессорами) и другими абонентами системной шины. Кэш-память не является самостоятельным хранилищем; информация в ней неадресуема клиентами подсистемы памяти, присутствие кэша для них "прозрачно". Кэш хранит копии блоков данных тех областей ОЗУ, к которым происходили последние обращения, и весьма вероятное последующее обращение к тем же данным будет обслужено кэш-памятью существенно быстрее, чем оперативной памятью.
  • Flash-память (флэш-память). Предназначенного для хранения информации и/или переноса между мобильными устройствами и ПК. Для исполнения программы на ПК в моменты программирования и стирания флэш-памяти требуется ОЗУ. Подобно ОЗУ, флэш-память модифицируется электрически внутрисистемно, но подобно ПЗУ, flash-память энергонезависима и хранит данные даже после отключения питания. В отличие от ОЗУ, flash-память нельзя переписывать побайтно. Она читается и записывается байт за байтом и ее нужно полностью стереть перед тем, как записывать новые данные. Наибольшее распространение получили карты памяти и тип Boot Block. Flash-память типа Boot Block служит для хранения обновляемых программ и данных в сотовых телефонах (SIM-карта), модемах, BIOS-ах, системы управления автомобильными двигателями и т.п.
Любые модули вставляются в слоты на материнской плате:

При выключении компьютера вся информация, которая находилась в оперативной памяти компьютера, безвозвратно теряется. В любом ПК есть cashe. Принцип его действия основан на том, что не работа (простой) более быстрого устройства сильно влияет на общую производительность (во-первых) и что с скорее всего запрашиваются данные, сохраненные недавно (во-вторых). Поэтому между устройствами помещают буфер быстрой памяти (небольшой по сравнению со всеми хранимыми данными), что позволяет снизить потери быстрого устройства как на записи, так и на чтении. Кэш в современных компьютерах строится по двух-уровневой схеме:

  • L1 Cashe (Level 1 Cashe, Первичный кэш) - кэш 1 уровня, внутренний (Internal, Integrated) кэш процессоров класса 486 и старше.
  • L2 Cashe (Level 2 Cashe, Вторичный кэш) - кэш 2 уровня. Работает на частоте шины. Для кэша 2-го уровня всегда используется SRAM. Характерные емкости - от 256kB до 1MB на процессор. Объем и быстродействие L2 Cashe оказывают огромное влияние на быстродействие ПК в целом. Но иногда установка в ПК систему дополнительной памяти может и заметно замедлить ее работу, если контроллер не поддерживает кэширование этой памяти. Обычно это внешний (External) кэш, установленный на системной плате. Для Pentium Pro и Pentium II вторичный кэш расположен в одном корпусе с самим процессором.

RAM - важнейшая часть ПК, т.к. почти половину времени процессор простаивает в ожидании ответа от оперативной памяти. Все модули памяти, представленные на любом рынке (и в России), грубо делятся на три большие группы:

  • Модули brand-name. Это модули памяти, произведенные известнейшими мировыми производителями, напр. такими как Kingston.
  • Модули памяти среднего класса. Это изделия ряда фирм, продукция которых доминирует на рынке в средней ценовой категории. Напр. фирмы NCP, Mtec, IBM.
  • Дешевые модули памяти. Это товар непонятного происхождения, маркированные порой странным образом, с непонятными идентификаторами производителя. Положительным моментом их наличия на рынке является цена.
Известные торговые марки фирм-производителей памяти (получше - выделено синим):
[ Alliance ] [ Altera Corporation ] [ Centon ] [ Century Microelectronics ] [ Cisco ] [ Compaq ] [ Corsair ] [ Crucial ] [ Fujitsu Ltd. ] [ Hitachi ] [ Hyundai ] [ HP ] [ Hyrix ] [ IBM Corporation ] [ Kingston Technology ] [ Kingmax Retail ] [ Micron ] [ Mitsubishi ] [ Motorola ] [ M.tec ] [ Nanay ] [ NCP ] [ NEC ] [ OKIc ] [ PNY ] [ Panasonic ] [ Samsung ] [ SEC ] [ SG ] [ Siemens ] [ Simple Technology ] [ Smart Modular Technologies ] [ Southland Micro Systems ] [ Sun ] [ Texas Instruments ] [ Toshiba ] [ Trancend JetRam ] [ Unigen ] [ Vanguard ] [ Viking ] [ Visiontek ] [ Vitelic ]
* - Century Microelectronics - подразделение компании Daewoo. Kingston ValueRAM всегда продается в retail-упаковке, при этом цена модулей выше безымянных примерно процентов на 30, а гарантия обычно составляет 36 месяцев. Модули Transcend JetRam отличаются от noname примерно на 10%, гарантия предоставляется пожизненная. Micron производит отличные чипы, но отнюдь не модули памяти. Есть множество производителей модулей памяти, которые сами чипов не производят. Они просто приобретают чипы и прочие компоненты для производства модулей памяти либо у производителей, либо у посредников. Напр. в прайс-листах под маркой Micron модули памяти на чипах Micron производства компании "Формоза".
Любые микросхемы памяти имеют пять основных параметров:
  1. Тип памяти. Обозначает статическая (SRAM - Static RAM) она или динамическая (DRAM - Dynamic RAM).
    В статической памяти элементы (ячейки) построены на различных вариантах схем (триггеров) с двумя устойчивыми состояниями. После записи бита в ячейку она может пребывать в этом состоянии столь угодно долго - необходимо только наличие питания. Ячейки статической памяти имеют малое время срабатывания (единицы-десятки наносекунд), однако микросхемы на их основе имеют низкую удельную плотность данных (порядка единиц Мбит на корпус) и высокое энергопотребление. Поэтому статическая память используется в основном в качестве буферной (кэш-память).
    В динамической памяти ячейки построены на основе областей (занимающих гораздо меньшую площадь, нежели триггеры) с накоплением зарядов и практически не потребляющих энергии при хранении. При записи бита в такую ячейку в ней формируется электрический заряд, который сохраняется в течение нескольких миллисекунд; для постоянного сохранения заряда ячейки необходимо регенерировать - перезаписывать содержимое для восстановления зарядов. Ячейки динамической памяти имеют большее время срабатывания (десятки-сотни наносекунд), но большую удельную плотность (порядка десятков Мбит на корпус) и меньшее энергопотребление. Динамическая память используется в качестве основной.
    Еще различают под-типы: DRAM (Dynamically RAM), SDRAM (Synchronous DRAM), EDO RAM (Extended Data Output RAM), FPM DRAM (Fast Page Mode DRAM), SRAM (Statically RAM), CDRAM (Cached DRAM), NVRAM (Non Volatile RAM), FeRAM (Ferroelectric RAM), DRDRAM (Direct RAMBus DRAM), DDR SDRAM (Double Data Rate SDRAM), ESDRAM (Enhanced SDRAM), MRAM (Magnetic RAM), etc.
  2. Объем памяти. Показывает общую емкость микросхемы. Измеряется в Мб. Для "обычных" пользователей предлагаются 1Mb, 4Mb, 8Mb, 16Mb, 32Mb, 64Mb, 128Mb, 256Mb, 512Mb; для "продвинутых" - 1Гб модули. Максимум одного модуля постоянно растет и сейчас составляет 4Гб. В 2002г. минимальный объем оперативной памяти в ПК - 64Mb, в 2003 - 128Мб. Идеальный метод определения емкости при отсутствии маркировки - определить номинал всех чипов данного модуля и "сложить". Минимальные условия работы современных операционок - при объеме оперативной памяти 32Mb.
  3. Структура памяти. Обозначает количество ячеек памяти и разрядность каждой ячейки. Разрядность памяти - это количество байт (или бит), с которыми операция чтения или записи может быть выполнена одновременно. Разрядность основной памяти обычно согласуется с разрядностью внешней шины процессора. Напр. 1 байт - для 8088; 2 байта - для 8086-80286, 386SX; 4 байта - для 386DX, 486; 8 байт - для Pentium и т.д. Каждый чип содержит ячейки, в которых может хранится от 1 до 16 бит данных. Например, 32Mb-чип может быть сконфигурирован как 32Mbx1, 16Mbx2, 8Mbx4 или 2Mbx16, но его общая емкость только 32Mb. А 28/32-выводные DIP-микросхемы SRAM имеют восьмиразрядную структуру (8k*8, 16k*8, 32k*8, 64k*8, 128k*8), и кэш для 486 объемом 256 кб будет состоять из восьми микросхем 32k*8 или четырех микросхем 64k*8. Т.о., первое число маркировки указывает на общее количество ячеек в чипе, а второе - на число бит в ячейке. 30-контактные SIMM имеют 8-разрядную структуру и ставятся с процессорами 286, 386SX и 486SLC по два, а с 386DX, 486DLC и обычными 486 - по четыре. 72-контактные SIMM имеют 32-разрядную структуру и могут ставиться с 486 по одному, а с Pentium и Pentium Pro - по два. 168-контактные DIMM имеют 64-разрядную структуры и ставятся в Pentium и Pentium Pro по одному. Установка модулей памяти или микросхем кэша в количестве больше минимального позволяет некоторым платам ускорить работу с ними, используя принцип расслоения (Interleave-чередование).
  4. Время доступа (время такта для синхронных устройств). Характеризует скорость работы микросхемы и обычно указывается в наносекундах (нс) через тире в конце наименования. На более медленных динамических микросхемах могут указываться только первые цифры (-7 вместо -70, -15 вместо -150), на более быстрых статических "-15" или "-20" обозначают реальное время доступа к ячейке. Часто указывается не реальное, а минимальное из всех возможных времен доступа. Например в EDO DRAM ставят маркировку 45 нс (или 50 нс), хотя такой цикл достижим только в блочном режиме, а в одиночном режиме микросхема по-прежнему работает за 70 нс (или 60 нс). Аналогично - в маркировке PB SRAM: 6 нс вместо 12 нс, и 7 - вместо 15 нс. Микросхемы SDRAM обычно маркируются временем доступа в блочном режиме (10 или 12 нс). Напр. модули SDRAM имеют время доступа: 12ns максимально до 83Mhz, 10ns максимально до 100Mhz, 8ns максимально до 125Mhz, 7ns максимально до 143Mhz.
  5. Корпуса и форм-факторы микросхем памяти. Бывают колодки:
    • Устаревшие форм-факторы:
      • DIP (Dual In line Package) и SIP (Single In line Package) - маленький черный корпус из пластмассы с двумя рядами контактов, расположенными вдоль длинных сторон чипа и загнутых "вниз". Это первые ПК-микросхемы, применявшиеся в блоках основной памяти XT и ранних AT, а сейчас - в блоках кэш-памяти.
      • SIPP (Single In line Pinned Package) - корпус с одним рядом выводов, устанавливаемая вертикально. Т.е. контакты не "наклеены" на плату, а имеют форму иголок (pin-ы) и торчат в виде гребенки, вставляемые в плату наподобие микросхем DIP/SIP. Модули SIPP имели определенные вырезы, которые не позволяли вставить их в разъемы неправильным образом. Применялся в ранних AT. Очень прост в установке.
      • CELP (Card Egde Low Profile) - невысокая карта с ножевым разъемом на краю) - модуль внешней кэш-памяти, собранный на микросхемах SRAM (асинхронный) или PB SRAM (синхронный). По внешнему виду похож на 72-контактный SIMM, имеет емкость 256 или 512 кб. Другое название - COAST (Cache On A STick - "кэш на палочке").
      • PQFP (Plastic Quad Flat Package) - плоский прямоугольный пластмассовый корпус с выводами по четырем сторонам). Выводы pin-ов сделаны по каждой из сторон в плоскости корпуса, при монтаже они изгибаются. В этих корпусах выпускалось большинство процессоров 386, но были и напр. PB SRAM в 100-выводных корпусах PQFP.
    • Форм-факторы последних лет. кроме прочего, отличаются напряжением (напр. 5V-SIMM, 3V-DIMM) и количеством контактов:
      • 30- и 72pin SIMM - наиболее распространенный в течении 90-х годов форм-фактор для модулей памяти. Подробнее...
      • 144pin SODIMM SDRAM - SO DIMM (Small Outline DIMM) - разновидность DIMM малого размера (small outline), предназначенных для портативных компьютеров. Наиболее часто встречаются 72- и 144-контактные модули (32 и 64 бит). Имеют ключ "со смещением", ответственный за напряжение, т.е ключи (и соответствующие выступы) смещены вдоль, что сделало невозможным установку "неправильного" модуля;
      • 72pin SODIMM FPM - Fast page (FPM) - "быстрый страничный" (режим). Позволяет наряду с обычным циклом (RAS, затем CAS), использовать сокращенный. FPM сегодня наиболее медленная из применяемых организаций памяти;
      • 168pin DIMM SDRAM - одна из современных разновидностей форм-фактора модулей памяти. Подробнее...
      • DDR SDRAM - второе поколение SDRAM с вдвое большей пропускной способностью. Подробнее...
      • Rambus RIMM Module - форм-фактор модуля памяти, разработанного компанией Rambus для Direct RDRAM. Подробнее....
      • Specific Memory Module - специфический модуль памяти, предназначенный для использования в конкретной системе (или классе систем) конкретного производителя. Термин не отрицает возможности того, что указанная система может расширяться и стандартными модулями.
      • Printer Memory - 100pin DIMM - специальная память, предназначенная для принтеров. Имеет вырез (ключ) "со смещением", ответственным за контроль рабочего напряжения (3,3 вольт).
Распространенные PB SRAM в 100-выводных корпусах PQFP имеют 32-разрядную структуру 32k*32 или 64k*32 и используются по две или по четыре в платах для Pentuim. Кроме основных параметров, важно "refresh rate (частота регенерации)" - число рядов, обновляемых за один цикл и "материал контакта" - золоченые или луженые. Чаще всего используются refresh rates равный 2K и 4K. Чипы, имеющие частоту регенерации 2К, могут обновлять большее количество ячеек за один раз, чем 4К и завершать процесс регенерации быстрее. И хотя вид материала - безразличен (у каждого есть свои недостатки - gold lead имеет свойство облезать, а tin lead - ржаветь), но материал контактов и разъемов, в которые устанавливаются модули памяти, должен совпадать. Проблема не в гальванической коррозии (разные материалы контактов), а в обычном требовании фирм-производителей.

Каждый чип по выходу с производства проверяется в соответствии со спецификацией. Однако, чип может иметь меньшую или большую скорость доступа, чем написано на нем. Например, 50ns-чип может работать и как 49ns или даже как 45ns-чип. Если же заводские тесты показали, что фактическая скорость доступа чипа 51ns или 59ns, то он будет промаркирован как 60ns-чип. На каждую микросхему фирмы-производители наносят маркировку, включающую название производителя, конфигурацию чипа, скорость доступа и дату производства. Эта маркировка нанесена не на поверхность, а на пластмассовом корпусе чипа.
Чипы, показавшие устойчивую работу на всех тестах, относятся к классу А (независимо от быстродействия), чипы с небольшими дефектами будут отнесены к классу С, а чипы имеющие значительные дефекты должны быть уничтожены (увы, не всегда). Для чипов разного класса используется различная маркировка. Например, Micron использует маркировку MT для чипов класса А, а чипы других классов маркируются как USA или Laser. Другие производители используют название страны для маркировки чипов низших классов. Т.о., можно встретить чипы с надписями типа "japan", "france", "korea", и т.п. Согласно Micron-у, есть четыре ценовых чип-категории. Чипы верхней ценовой категории протестированы тщательно и гарантируется отсутствие ошибок в 99,9% случаев. Чипы четвертой (с наименьшей ценой) категории на скорость и надежность не тестировались, т.е. покупатель приобретает чипы "как есть" и ему может не повезти. К сожалению, в России чипы всех 4-х категорий продаются скопом (все вместе).

· Организация JEDEC (Joint Electron Device Engineering Council, Объединенный инженерный совет по электронным устройствам) проводит работу по разработке стандартов памяти для ПК, в т.ч. им приходится сочетать модули памяти, чипсеты и системные интерфейсы. Стандарт системной памяти имеет жизненный цикл в 2–3 года, стандарт графической памяти – порядка 9-ти месяцев.

         "... Reset - не кнопка, а горькая необходимость ..."

SIMM (Single In line Memory Module, DRAM) - память с асинхронным доступом. Модуль вставляется в зажимающий разъем системной плате; применяется во всех m/b, а также во многих адаптерах, принтерах и прочих устройствах. SIMM имеет контакты с двух сторон модуля, но все они соединены между собой, образуя как бы один ряд контактов. Single говорит о том, что контакты с двух сторон модуля на самом деле являются одним и тем же контактом (для увеличения контактной поверхности). Модули памяти SIMM вытеснили с рынка SIPP (Single In-line Pin Package). SIPP по внешнему виду похож на SIMM, у которого контакты не "наклеены" на плату, а имеют форму иголок (наименование pin в первоначальном значении этого слова) и торчат в виде расчески.

SIMM начал широко применяться на PC c 386-м процессором. А рассвет SIMM-ов пришелся на PC c 486-м и первыми Pentium-процессорами. Модуль памяти представляет собой прямоугольную плату с контактной полосой вдоль одной из сторон. Соединение с системной платой идет через позолоченные полоски (pin-ы, пины), а не через штырьки.
Для фиксации память вставляется в пластмассовую колодку m/b под углом 70 градусов, потом поворот и зажимается с помощью защелок. При этом SIMM-модуль встает перпендекулярно к плате.

Модули динамической памяти, помимо памяти для данных, могут иметь дополнительную память для хранения битов четности (Parity) для байтов данных - такие SIMM называют 9- и 36-разрядными модулями (по одному биту четности на байт данных). Биты четности служат для контроля правильности считывания данных из модуля, позволяя обнаружить часть ошибок (но не все). Существует две разновидности модулей SIMM (в зависимости от числа выводов модуля):

  1. 30-контактные модули имеют ширину 9 бит (8 бит и бит контроля четности). Реально использует порядка 25 контактов, остальные сделаны "про запас", в сумме получается всего 100 контактов.
  2. 72-контактные модули имеют ширину 32 бита (без контроля четности) или 36 бит (с контролем четности). Многие SIMM 72-пин также имеют рудиментные или вообще отсутствующие контакты 35-36 и 37-38. Кстати, в этом форм-факторе (72-пинового SIMM) выпускалось минимум восемь разных стандартов модулей (х32, х36, х18, х33, х39, х40, PS/2 x36, x36 с 5 линиями CAS), но распространены только х32 & х36.
Так как шины ПК с 386- и 486-процессорами 32-битные, необходимо использовать либо аж четыре 30-контактных модуля SIMM, либо один 72-контактный модуль. ПК на базе процессоров Pentium, Pentium Pro и Pentium II имеют 64-битную шину, поэтому в материнские платы для Pentium'ов надо вставлять 72-х контактные модули SIMM по двое. Иначе компьютер либо не будет работать, либо просто не "заметит" стоящего в гордом одиночестве 32-х "битника".
Существовует т.н. SIMM-конвертер - плата расширения, имеющаю контактную решетку под 72-пиновый разъем и слоты для установки 4-х 30-пиновых SIMM. Правда, смысла в нем нет.
На каждом SIMM-е имеется обозначения - типа 2х36-70. Где "70" - это время доступа, в наносекундах. "х36" - это организацию модуля памяти, т.е. количество линий ввода-вывода.
  1. х8, х9 ... 30-пиновый SIMM без четности и с четностью соответственно;
  2. x2, x3 ... некорректное, но иногда встречающееся обозначение тех же 30-пиновых SIMM, но в исполнении с малым количеством (2 и 3) чипов;
  3. х32, х36 ... 72-пиновый SIMM без и с четностью (х32 также может быть 72-пин SO DIMM);
Произведение ("2х36") дает емкость модуля, в мегабитах. Для получения мегабайт нужно поделить результат на 8. Т.о., 2х36-70 есть SIMM 8MB 72-пин с четностью 70 нс, 4x32-60 - SIMM 16MB 72-пин без четности 60 нс, 16x32-60 - SIMM 64MB 72-пин без четности 60 нс.

72-контактные (SIMM EDO RAM) имеют только 72 пина и могут работать на частоте до 50 МГц. Этими модулями памяти оснащались компьютеры с процессорами Intel 80486DX2/DX4, Intel Pentium, Pentium Pro и Pentium MMX, а также AMD 80586 и K5. Эти модули устанавливались на платах с чипсетом Intel 440TX, 440EX, 440LX, 450NX; VIA Apollo MVP 3/4, Pro/Pro+; ALI Alladin 4/4+/V/PRO II, ALI Alladin TNT2. С появлением в 1996 году процессора Intel Pentium II и чипсета Intel 440BX частота локальной шины возросла до 100 МГц, что заставило производителей памяти перейти на другие технологии, прежде всего DIMM SDRAM.

· PD... Начиная с 72-pin SIMM, вся память имеет четыре специальных линии PD (Presence Detect - обнаружение наличия, "электрическая" маркировка модуля памяти), на которых при помощи перемычек может быть установлено до 16 комбинаций сигналов. Линии PD используются некоторыми "Brand name"-платами для определения наличия модулей в разъемах и их параметров. Большинство обычных (т.е. не brend) m/b не используют линий PD, что формально не соответствует стандарту JEDEC. Впоследствии PD трансформировалось в SPD.

· FPM DRAM (Fast Page Mode DRAM - динамическая память с быстрым страничным асинхронным доступом) активно используется в последние несколько лет. Память со страничным доступом отличается от обычной динамической памяти тем, что после выбора строки матрицы и удержании RAS допускает многократную установку адреса столбца, стробируемого CAS, а также быструю регенерацию по схеме "CAS прежде RAS". Первое позволяет ускорить блочные передачи, когда весь блок данных или его часть находятся внутри одной строки матрицы, называемой в этой системе страницей, а второе - снизить накладные расходы на регенерацию памяти.

· EDO (Extended Data Out - расширенное время удержания данных на выходе) фактически представляют собой обычные микросхемы FPM, на выходе которых установлены регистры-защелки данных. При страничном обмене такие микросхемы работают в режиме простого конвейера: удерживают на выходах данных содержимое последней выбранной ячейки, в то время как на их входы уже подается адрес следующей выбираемой ячейки. Это позволяет примерно на 15% по сравнению с FPM ускорить процесс считывания последовательных массивов данных. При случайной адресации такая память ничем не отличается от обычной. Микросхемы EDO часто (но не всегда) имеют в обозначении "некруглые" числа: например, 53C400 - обычная DRAM, 53C408 - EDO DRAM.

· BEDO (Burst EDO - EDO с блочным доступом) - память на основе EDO, работающая не одиночными, а пакетными циклами чтения/записи. Современные процессоры, благодаря внутреннему и внешнему кэшированию команд и данных, обмениваются с основной памятью преимущественно блоками слов максимальной ширины. В случае памяти BEDO отпадает необходимость постоянной подачи последовательных адресов на входы микросхем с соблюдением необходимых временных задержек - достаточно стробировать переход к очередному слову отдельным сигналом. О поддержке этого стандарта производители чипсетов заявляли уже давно, однако BEDO RAM так и не появилась на рынке, и наверное уже не появится, проиграв SDRAM как более быстрой.

· PB SRAM (Pipelined Burst SRAM - статическая память с блочным конвейерным доступом) - разновидность синхронных SRAM с внутренней конвейеризацией, за счет которой примерно вдвое повышается скорость обмена блоками данных.

· FeRAM (Ferroelectric RAM) - ферроэлектрическая память. Сочетает простоту и надежность в эксплуатации DRAM, энергонезависимость MRAM и время хранения флэш-памяти. Производители разделились на два конкурирующих между собой лагеря. Первая часть, Infineon Technologies AG и Toshibа, разрабатывает технологию памяти, основанную на производственном процессе 1T/1C (1 транзистор / 1 конденсатор) для рынка мобильных устройств, персональных компьютеров и PDA. Производство основано на классе материалов PZT (Provskite lead zirconate titanate). Фирмы Matsushita, NEC, Siemens, Motorola, Hynix и Micron занимаются разработкой продуктов со встроенной FeRAM для рынка процессоров, смарт-карт и микроконтроллеров. Они ведут разработки на основе технологического процесса 2T/2C. Введение дополнительных транзистора и конденсатора в ячейку памяти дает большую стабильность работы, но и увеличивает цену. Toshiba и Infineon Technologies в 2002 году выпустили 32-мегабитную микросхему памяти FeRAM.

· Pseudo SRAM - память для мобильных телефонов. Модули разработаны по 0,18-мкм технологии и являются первыми за всю историю промышленности чипами, "стопроцентно взаимозаменяющими стандартные модули SRAM для мобильных устройств". Первые модули 16 и 32 Мбит были выпущены в 48-ball FBGA корпусе размером 7х8 мм корейской компанией Hynix Semiconductor в ноябре 2001 года.

· FCRAM (fast cycle random access memory) - память произвольного доступа с быстрым циклом. Опять память для мобильных телефонов от компании Fujitsu. Начало производства первых 32-битных модулей емкостью 32 Мбит и 64 Мбит - октябрь 2002 года.

         "... Abort, Retry, Ignore = Нафиг, Нефиг, Пофиг ..."

DIMM (SDRAM, Synchronic DRAM, Dual In line Memory Module, - "синхронная DRAM" - динамическое ОЗУ с синхронным интерфейсом. SDRAM - синхронная память "первого поколения", имеют пропускную способность порядка 100 Mb/s и представляет собой модуль памяти с двумя рядами контактов. Внешне похожи на SIMM-ы. Синхронизация отличает SDRAM от работающих по асинхронному интерфейсу (FPM/EDO/BEDO DRAM). Помимо синхронного метода доступа, SDRAM использует внутреннее разделение массива памяти на два независимых банка (т.е имеют раздельные контакты - обычно 2x84), что позволяет увеличивать разрядность - т.е. в итоге совмещать выборку из одного банка с установкой адреса в другом банке. SDRAM также поддерживает блочный обмен. Применяется как в IBM-совместимых PC (в основном - платах под Pentium III), так и в компьютерах Apple. Возможна и установка SDRAM для процессора Intel Pentium 4 (существует чипсет i845 с поддержкой данного типа памяти). В отличии от SIMM DIMM вдавливается в разъем и "накрывается" рычажками, с помощью которых и вытаскивается.

Присутствие слова dial означает независимость контактов с двух сторон. Все разновидности обычных DIMM-ов имеют одинаковое (168) число контактов (168-ми, рассчитанные на ширину шины 64 бит) и форм-фактор, и различаются только "ключами" (вырезки по бокам).

DIMM-ы

•

Dimm PC66

•

Dimm PC100

•

Dimm PC133

•

HSDRAM 150

•

72pin SODIMM

•

144pin SODIMM

•

GF1000

Устанавливать модули DIMM совместно с модулями типа SIMM (т.е. вместе на m/b) не рекомендуется в связи с тем, что модули DIMM питаются от 3.3 вольт, а SIMM - от 5. При этом большинство материнских плат имеют общее питание для слотов SIMM и DIMM. В связи с этим, при установке модулей в оба типа разъемов, на DIMM будет подаваться повышенное напряжение 5 вольт (может привести к выходу из строя чипов).
Цифры - это и спецификация (напр. стандарт PC 100), и частота работы модуля (напр. 100 МГц). Во многих старых материнских платах можно использовать также частоты 75 MHz и 83 MHz, но - на страх и риск пользователя. Оверклокеры использовали также значения 103, 112, 124 MHz. Применение повышенной частоты шины и нормальная работа m/b-периферии, как правило, никем не гарантировалось.
Первую полную спецификацию на DIMM-модули (это были PC-100) выпустила Intel при подготовке чипсета i440BX (с тактовой частотой системной шины 100 MHz) в 1998 году. Спецификация до сих пор является самой полной из всех существующих на сегодняшний день спецификаций модулей памяти. Вместе с дополнением, детально описывающим программирование EEPROM для модулей SDRAM, она занимает больше 70 страниц! Начальная спецификация PC133 была также выпущена Intel-ом в конце 1999 года и реально отличается от PC100 только параметрами быстродействия. Но еще в ноябре 1996г. Intel официально встал на сторону Direct Rambus, заявив, что следующим после PC100 SDRAM стандартом станет RDRAM. PC133 SDRAM поддерживала компания Via и c учетом колоссальных проблем Rambus-а на тот момент (с процентом выхода годных чипов) - победила.
Шины памяти в 66МГц и 100 МГц - устарели. Все модули PC133 содержат чипы со временем доступа от 7.5 нс и меньше, что гарантирует беспроблемную работу на 133 Мгц. 133-МГц чипы совместимы со всеми PC100-продуктами. Незначительные различия между PC100 и PC133 стали причинами для обмана потребителей путем нестандартной маркировки. Зачем приобретать новый модуль PC133, если б/у PC100 со временем доступа 7 нс тоже сможет работать на 133Мгц? Модули со временем доступа 7 нс и менее вполне работоспособны на 150Мгц. Здесь критерием выбора становится качество изготовления всего модуля DIMM и имя фирмы-производителя. Т.е грубо так: Brand-овская PC133 практически всегда держит 150 МГц.
Кроме частоты, модули DIMM подразделяются по напряжению питания и алгоритму работы. Стандартными является небуферизированные модули с напряжением питания 3,3 вольта. Небуферизованный DIMM может содержать память типа SDRAM, BEDO, EDO и FPM, иметь ширину 64 или 72 бита данных для контроля четности, а также 72 и 80 бит для ECC. Эти модули отличаются от остальных положениями ключей (пропилов) в контактной линейке. Т.е. если посмотреть на модуль с лицевой стороны (где чипы), то левый ключ (пропил) должен быть в крайнем правом положении, а средний - в среднем положении. Левый ключ определяет, является ли модуль буферизированым, а средний - определяет напряжение питания. Буферизованные DIMM, как правило, несовместимы с не буферизованными.

В соответствии со спецификацией JEDEC, в модулях DIMM необходима реализация технология PD. Делается при помощи перезаписываемого ПЗУ с последовательным доступом (Serial EEPROM) и носит название Serial Presence Detect (SPD). ПЗУ представляет собой 8-выводную микросхему, размещенную в углу DIMM-a, а его содержимое описывает конфигурацию и параметры модуля. Т.е. визуально SPD - это небольшой "лишний" чип на модуле. Системные платы с некоторыми chiset`ами (напр. 440LX/BX) могут использовать SPD для настройки системы управления памятью. Некоторые системные платы могут обходиться без SPD, определяя конфигурацию модулей обычным путем - это стимулирует выпуск рядом производителей DIMM без ПЗУ, не удовлетворяющих спецификации JEDEC.
Известность SPD получил после того, как ряд материнских плат (например, Intel AL440LX) отказались работать с "ширпотребными" DIMM-ами. По сути дела это означало инспирированную Intel попытку возродить использование PRD (теперь в виде SPD). 440LX проверял не только собственно SPD, но и "информацию от производителя", по поводу которой был разработан специальный закрытый стандарт, так что даже DIMM с корректным SPD могли быть им отвергнуты. Впрочем, попытка не имела особого успеха, так как функция контроля SPD задействована далеко не во всех современных материнских платах.

· HSDRAM, Enhanced High Speed SDRAM - усовершенствованная высокоскоростная SDRAM (DIMM-ы) на частоте шины 150 МГц и выше (в зависимости от типа чипсета). Т.е. HSDRAM - более высококачественные чипы, чем нормальные SDRAM. И раньше были единственные "PC150" DIMM - модули Kingmax. В сентябре 2000г. компании Enhanced Memory Systems (подразделение Ramtron International)и Mushkin объявили о выпуске новых SDRAM DIMM модулей - с частотой 150 и установкой 2-3-2 (CAS, CAS-to-RAS, RAS, clock access time - 4.5 нс). Установкой или таймингом называют время отклика памяти на различные запросы. HSDRAM-модули смогут работать с этими же таймингами на частотах вплоть до 166 МГц. HSDRAM не имеет буфера и обеспечивает малое время задержки, чем достигается высокая производительность. Теоретически, пропускная способность памяти, работающей на частоте 150MHz, равна 150MHz*8 байт (т.к. ширина шины 64 бита) = 1200MB/s (1.2GB/s). Ну что же, по сравнению с 1.066GB/s у PC133 очень неплохо. Но, младший DDR PC1600 со своими 1.6GB/s все же быстрее.
Выигрыш HSDRAM по сравнению с hi-end системами на базе PC-100 и Direct Rambus DRAM составил от 28% до 49% (по разным показателям).

· Small Outline DIMM, SO DIMM - разновидность DIMM малого размера, предназначенных в первую очередь для портативных компьютеров (notebook, ноутбуках) и иногда для принтеров. Наиболее часто встречаются 72- и 144-контактные модули (32 и 64 бит соответственно).

Полное наименование - 144pin SODIMM SDRAM и 72pin SODIMM SDRAM. 144-контактные SO DIMM имеют ключ "со смещением", ответственный за напряжение, т.е ключи (и соответствующие выступы) смещены вдоль, что сделало невозможным установку "неправильного" модуля памяти, хотя и заметно осложнило производство.

· GF1000 DIMM . Компания Samsung разрабатывает новую технологиею DRAM для графических процессоров. Кодовое название памяти - GF1000, пропускная способность памяти - 2-4 Гбит/с, напряжение питания - 1,8 В. В продаже память появится в 2004 году.

Обычные виды SDRAM и DRAM называют также асинхронными - потому, что установка адреса, подача управляющих сигналов и чтение/запись данных могут выполняться в произвольные моменты времени - необходимо только соблюдение временнЫх соотношений между этими сигналами. В эти временные соотношения включены так называемые охранные интервалы, необходимые для стабилизации сигналов, которые не позволяют достичь теоретически возможного быстродействия памяти. Существуют также синхронные виды памяти, получающие внешний синхросигнал, к импульсам которого жестко привязаны моменты подачи адресов и обмена данными; помимо экономии времени на охранных интервалах, они позволяют более полно использовать внутреннюю конвейеризацию и блочный доступ.

         "... Закладывая что-нибудь в память компьютера - помни куда ты это положил ..."

Double Data Rate-Synchronous DRAM, DDR - синхронная DRAM с двойной скоростью передачи данных. К сожалению, DDR-ы часто тоже называют аббревиатурой DIMM, что вызывает огромную путаницу. Т.к. тип памяти - SDRAM, еще одно название - SDRAM-II (т.е. SDRAM второго поколения). Третье название - DDR первого поколения.

DDR-ы

•

DDR I

•

DDR II

•

GDDR-III

•

DDR III
  • PC-1600
  • PC-2100
  • PC-2400
  • PC-2700
  • PC-3000
  • PC-3200
  • PC2-3200
  • PC2-4300
  • PC2-5400
  • PC2-6400
По принципам работы DDR-SDRAM похожа на SDRAM. Она может принимать и передавать данные два раза за такт – на обоих фронтах тактовых импульсов (по восходящему и нисходящему фронту стробирующего сигнала), что удваивает скорость предачи данных. У DDR-SDRAM меньше потребляемая мощность (удобно для карманных компьютеров). В DDR RAM используется протокол DLL (Delay Locked Loop), позволяющий сдвинуть во времени интервал действительного значения выходных данных. Таким образом сокращаются простои системной шины при считывании данных на нее из нескольких модулей памяти.
Расшифровка названий DDR I:
PC-1600 (DDR 200) = 100MHzx2 = 1.6 Гб/с пропускная способность
PC-2100 (DDR 266) = 133MHzx2 = 2.1 Гб/с пропускная способность
PC-2400 (DDR 300) = 150MHzx2 = 2.4 Гб/с пропускная способность
PC-2700 (DDR 333) = 166MHzx2 = 2.7 Гб/с пропускная способность
PC-3000 (DDR 366) = 183MHzx2 = 3.0 Гб/с пропускная способность
PC-3200 (DDR 400) = 200MHzx2 = 3,2 Гб/с пропускная способность
PC-3500 (DDR 434) - модули HyperX DDR-памяти от Kingston
DDR SDRAM имеет только одну "прорезь" посередине, в то время как типичный 168-контактный JEDEC DIMM имеет три "прорези". Это должно послужить "зашитой от дурака", который попытается вставить DDR SDRAM в слот для обычной SDRAM.

Модули SDRAM PC66/PC100/PC133/PC150 не могут работать с DDR-материнскими платами, т.к. DDR использует новый 184-pin-овый формат модуля и физически несовместим с 168-pin-овым форматом модулей DIMM.
В рамках стандарта DDR-I выпущены спецификации PC1600, PC2100, PC2100А, PC2400, PC2700, PC3200 и экстремальные PC3000. Память PC1600 имеет латентность 2-2-2, модули PC2100 - 2.5-3-3, модули PC2100А - 2-2-2, модули PC2400 - 2-3-3. Первый чипсет от Intel с поддержкой двухканальной 333 МГц DDR-I - Granite Bay, а 400 МГц DDR-I - Springdale.
Пример по DDR PC2100: работает на частоте 133МГц DDR и предлагает пиковую пропускную способность 2100 MB/s (133 МГц x 2 x 64 bit). Латентность CAS рана 5, и так как DDR может использовать и повышающий и понижающий фронты, получаем цифру 2.5 цикла. Латентность RAS to CAS и precharge требуют трех циклов, подобно большинству PC133 SDRAM.
У канадской компании Corsair есть серия памяти XMS (Xtreme Memory Speed, память экстремальной скорости). Это т.н. супер-быстрая память. Выпускается в варианте от 512Мб на модуль, т.к. по их тестам 512Мб одним модулем оказывается быстрее, чем два по 256Мб. В т.ч. компания выпускает PC-3000 (CMX512-3000C2) со временем 2-3-3 1Т.
В апреле 2002 года компания Samsung первой выпустила 128 Мб-чипы DDR 400 SDRAM для применения в видеокартах. Они работают на частоте 800МГц (400 Мгц DDR) при напряжении 2,8 вольт.
Следует отметить, что многие ПК при установке модулей PC-2700 (и выше) в системные платы сразу не запускаются, даже при заниженных таймингах. Необходима новейшая прошивки BIOS-а. Во-вторых, очень важна проблема охлаждения модулей, работающих на такой частоте. в случае с памятью DDR400 используется новый, специальный тип корпусов для чипов, который решает проблему тепловыделения. А напр. компания OCZ на свой PC-3000 прикрепила с обеих сторон модуля по радиатору.
На начало 2002г. века память DDR-I (в просторечии - DDR) исчерпала технологические возможности наращивания тактовой частоты в экономически оправданных пределах, поэтому появился стандарт DDR-II.

· DDR II... Впервые спецификация DDR-II, второго поколения памяти DDR SDRAM, была представлена в марте 2002 года во время конференции JEDEX в Калифорнии. DDR-II очень похож на DDR, но работает на 200 МГц тактовой частоте. DDR-II обратно совместим с DDR, т.е. Вы сможете использовать DDR-I память в DDR-II платах. Первые образцы появились в конце 2002 года от компания Samsung Electronics в 60-контактном BGA-корпусе. Конструктивные отличия от DDR-I - три. Во-первых, количество контактов увеличилось с 184 до 240, т.е., почти на треть. Во-вторых, микросхемы памяти выполнены в конструктиве FBGA, а в старых модулях DDR-I использовались TSOP и TBGA. Сразу отмечу, что микросхемы в упаковке FBGA работают более стабильно за счет возможности калибровки сигнальных импульсов и лучшей целостности сигнала. В-третьих, рабочее напряжение модулей уменьшено с 2,5 В (и 2,6 В для DDR 400) до 1,8 В для DDR-II. Т.о. потребляемая мощность снижена на 28%.
В рамках стандарта DDR-II выпущены-готовятся спецификации DDR II 400, DDR II 533, DDR II 667, DDR II 800 и DDR II 1000. При этом DDR II 400 сертифицировано JEDEC только исходя из интересов корейской Samsung и американской Micron-а. Все другие компании не собираются выходить на рынок с 400-МГц DDR-памятью.
Расшифровка названий DDR II:
PC2-3200 (DDR II 400) = 100MHzx4 = 3,2 Гб/с пропускная способность
PC2-4300 (DDR II 533) = 133MHzx4 = 4,3 Гб/с пропускная способность
PC2-5400 (DDR II 667) = 166MHzx4 = 3,2-5,4 Гб/с пропускная способность
PC2-6400 (DDR II 800) = 200MHzx4 = 3,2-6,4 Гб/с пропускная способность
Первой в мае 2002 года чип DDR-II представила компания Samsung, второй - в июле 2002г. компания Elpida Memory, третьим вендором стал Micron в феврале 2003г. Все модули - 512Мб.

· GDDR-III (GDDR3)... В первом полугодии 2003 года появились чипы памяти GDDR-III, разработанные для высокопроизводительных графических плат от компаний Micron Technology и ATI Technologies. В разработке и коммерциализации GDDR-III принимают участие NVIDIA, корейская Hynix Semiconductor, Infineon Technologies. Причина - DDR-II очень медленная для серьезных графических приложений. GDDR-III может работать также в коммуникационных устройствах и бытовой электронике.
Первоначально чипы GDDR-III будут иметь емкость 256 Мбит, тактовую частоту 500 МГц и линейную пропускную способность 1 Гбит/с на вывод. Затем тактовые частоты вырастут до 750 МГц, линейная пропускная способность – до 1,5 Гбит/с на вывод. При формировании I/O шины GDDR-III будет использоваться технология с открытым стоком (в отличие от двухтактной I/O шину у памяти для ПК) и применяться внутрикристалльная терминация (on-die termination, ODT). Несмотря на то, что спецификации GDDR-III основаны на стандарте DDR-II, это совсем другие чипы в корпусах CSP (chip-scale packaging), в 144-контактной BGA конфигурации, в отличие от 84-контактных чипов DDR-II в корпусе CSP.
Открытый стандарт памяти GDDR-III спецификаций третьего поколения DDR DRAM для графики (от ATI Technologies) существует за рамками стандартов, одобренных JEDEC Solid State Technology Association.

· DDR III... В JEDEC начата работа над спецификациями стандарта DDR-III для ПК. Пять производителей DRAM - Elpida, Hynix, Infineon, Micron и Samsung, разделили между собой основные части будущего стандарта и теперь каждая из них ведет разработку черновых спецификаций своей части.
Стандарт DDR-III в рамках JEDEC также нацелен на достижение линейной пропускной способности от 1 Гбит/с и выше.

DDR-эпилог... Реальный прирост производительности ПК при переходе с DIMM на DDR I (если тестировать только пропускную способность памяти) далеко не соответствует двукратному. Даже при пересылке огромных объемов данных производительность выросла лишь на 8%, а прирост производительности офисных приложений - еще меньше, а работа игр вообще ускоряется лишь на несколько процентов. Но по прогнозу Hyundai Electronics Industries в 2001 году DDR SDRAM составит 15% всего объема производимой DRAM, в 2002 году эта цифра поднимется до 40%, а к 2004 году достигнет 85% отметки.

         "... Не хотите по плохому, по хорошему будет хуже ..."

SLDRAM (Synchronous Link DRAM, SyncLink DRAM) — открытый стандарт архитектуры динамической памяти, разработанный консорциумом SLDRAM и принятый IEEE. Интерфейс SyncLink (шина SLDRAM или SLBus — SyncLink Bus) является продолжением и усовершенствованием шинной структуры RamLink, применяющейся при создании памяти RLDRAM (RamLink DRAM). SLDRAM использует узкую (16 бит для базового интерфейса и 18 бит для ECC-интерфейса) шину с пакетной адресацией, эффективно увеличивающей пропускную способность. Простая структура шины позволяет увеличить частоту шины, до 800MHz. Фокус этой технологии не в самой памяти, которая в-принципе не меняется по сравнению со стандартной DRAM, а в интерфейсе (протоколе), делающем возможным многие одновременные доступы (если только они все имеют физически разное расположение в памяти). Общая политика SLDRAM — это как можно меньшее использование внутренних блоков в микросхеме памяти и как можно большая интеграция самого базового контроллера.
Сама SLBus — разработка компании MicroGate Corporation, хотя и принадлежит к числу открытых стандартов.
На низкую стоимость SLDRAM влияет использование обычного корпуса, методов упаковки микросхемы и технологии изготовления монтажной печатной платы PCB (Printed Circuit Board) для модуля памяти. Микросхемы SLDRAM пакуются в стандартный 80pin корпус TSOP (Thin Small Outline Package) c 0.5mm расстоянием между соседними выводами, или в 64pin упаковку VSMP (Vertically Surface Mounted Package) для вертикального монтажа c шахматным расположением выводов, с 0.8mm расстоянием между соседними выводами (по диагонали).
История... Еще в начале 90-х годов разработчики архитектур динамической памяти разбились на два лагеря: одни пошли по пути увеличения частоты и уменьшения ширины шины (RDRAM, RLDRAM и SLDRAM), другие — наоборот (SDRAM, ESDRAM, HSDRAM, VCSDRAM, DDR SDRAM). Уже давно стало ясно, что вторые испытывают технологические затруднения, т.к. архитектура группы-2 очень близко подошла к своему пределу — стала сильно сдерживать растущее влияние паразитных факторов, причем эффективность и загрузка протокола даже в настоящее время не могут подняться выше 70%. Кардинально противоположно ситуация складывается с первой группой (в которой Rambus (RDRAM) уже стал массовым продуктом).
Работа над SLDRAM началась в начале 1995 года. За семь лет разработок SLDRAM не является массовым коммерческим продуктом и до сих пор находится в стадии доработки и отладки. На сегодняшний день нет полностью рабочих систем SLDRAM, а все идеи SLDRAM почти целиком "импортированы" в архитектуру DDR-II.

· RLDRAM (Reduced Latency DRAM) - динамическая память со сниженным временем задержек. Еще ее называют высокоскоростным вариантом DDR SDRAM. В феврале 2002г. компания Infineon Technologies представила первый образец 256 Мбитного чипа в двух вариантах: с организацией 8M x 32 и 16M x 16. Работая с тактовыми частотами до 300 МГц и используя интерфейс DDR, RLDRAM обеспечивает постоянную пропускную способность в 2,4 Гб/с. позволило Время произвольной построчной выборки снижено до 25 нс (при 50 нс и более у стандартной DRAM). Чипы RLDRAM от Infineon выпускаются в T-FBGA (thin- fine pitch ball grid array) упаковке, с тактовыми частотами 300 МГц, 250 МГц и 200 МГц. Главные производители - Micron Technology, Infineon Technologies, Fujitsu и Toshiba.
В первую очередь чипы RLDRAM предназначены для скоростного сетевого оборудования (высокоскоростных маршутизаторов, коммутаторов и т.п.). Напр. Cisco приняла решение отказаться от планов использования Rambus и переключиться на FCRAM/RLDRAM.

SLDRAM Incorporated — это целый консорциум, а стандарт является полностью открытым и сертифицирован на уровне IEEE (Institute of Electrical and Electronics Engineers, концепция интерфейса). RamLink стандартизирована как IEEE Std 1594.4-1995, а SyncLink — как IEEE 1596.7-199x) и JEDEC. В группу вошли компании: Fujitsu Microelectronics, Hitachi Semiconductor, Hyundai Electronics, IBM Global Procurement, IBM Microelectronics Division, LG Semiconductors, Matsushita Electric, Micron Technology, Mitsubishi Electric, MOSAID Technologies, Mosel Vitelic, Motorola Corporate Communications, NEC Electronics, Siemens Components, Texas Instruments, Toshiba Electronic Components, Vanguard International Semiconductor и пр. Открытость стандарта позволяет производителям изготавливать различные продукты каждые для своей ниши рынка. Т.о. консорциум SLDRAM состоит из фактически всех производителей памяти и большинства производителей полупроводников - за исключением Intel-а, который является партнером Rambus Inc. для разрaботки другой технологии, именуемой RDRAM - Direct RDRAM.

         "... программисты не заливают в машину 95-й бензин... Боятся, что повиснет ..."

DRDRAM (Direct Rambus, RDRAM, Rimm) — спецификация высокоскоростной памяти, созданная и запатентованная фирмой Rambus Inc. При этом Rambus Dram - не дизайн чипов, а технология (т.е. интерфейс).
Самая распространная сегодня Rambus-память работает на тактовой частоте 400 МГц, но позволяет данным обращаться два раза за один такт, поэтому эффективная частота памяти составляет 800 МГц. Ширина шины данных составляет 16 бит, или 2 байт. Пиковая пропускная способность - до 3,2 Гбайт/с (по 1,6 Гбайт на канал). Модули RIMM имеют размеры, сходные с SDRAM DIMMs, но другие пропилы. Модули Rimm поддерживают SPD, которые используются на DIMM'ах. Direct Rambus, в отличие от SDRAM DIMM, может содержать любое целое число чипов RDRAM. Один канал Direct Rambus может поддерживать максимум 32 чипа DRDRAM. Чтобы расширить память сверх 32-х устройств, могут использоваться два чипа повторителя. С одним повторителем канал может поддерживать 64 устройства с 6-ю RIMM модулями, а с двумя — 128 устройств на 12 модулях. На материнской плате может использоваться до трех RIMM-модулей. Существуют специальные модули только с каналом, называемые continuity modules. Они не содержат чипов памяти и предназначены для заполнения свободных посадочных мест.

· История... Технология Direct Rambus представляет собой третий этап развития памяти RDRAM. Впервые память RDRAM появилась в 1995г., работала на частоте 150 МГц и обеспечивала пропускную способность 600 Мбайт/с. Это был Rimm PC600 RDRAM 266 МГц. Она использовалась в станциях SGI Indigo2 IMPACTtm, в приставках Nintendo64, а также в качестве видеопамяти. Следующее поколение RDRAM появилось в 1997г. под названием Concurrent RDRAM. Новые модули были полностью совместимы с первыми. Далее было 2-х летнее ожидание единственного чипсета (от Intel-а - i820) для материнских плат с поддержкой Direct Rambus. В 1999г. из-за дефицита чипов выпускался S-RIMM - модуль RIMM с преобразователем питания на 3.3 В, позволяющем разместить на модуле PC100 SDRAM чипы. В августе 1999г. Dell продемонстрировал результаты тестов Direct Rambus vs PC100 SDRAM, наглядно показав - на существующих программах-приложениях, разницы в производительности между этими типами памяти практически нет (2-3%). В сентябре 1999г. Intel в очередной раз отменил выход i820 и производители m/b потеряли около миллиона плат на beta-i820. А Via официально объявляет чипсет Apollo Pro133. В итоге в 1999-2000гг. память RDRAM не поддержал ни один (!) производитель чипсетов.

На сегодняшний день не так много чипсетов (i820, i850/i850E, SiS 658) поддерживает Direct Rambus. Пока существует девять спецификаций RDRAM:

•

Rimm PC600 RDRAM

•

Rimm PC700 RDRAM

•

Rimm PC800 RDRAM

•

Rimm PC1066 RDRAM

•

Rimm PC1200 RDRAM

•

Rimm PC4200 RDRAM

•

Rimm PC4800 RDRAM

•

Rimm PC8500 RDRAM

•

Rimm PC9600 RDRAM

где Rimm PC700 RDRAM - промежуточная спецификация от апреля 1998г. Rimm PC800 RDRAM имеет 400 МГц шину, а Rimm PC1066 RDRAM - 533 МГц. Лучшая память от Rambus-а - Rimm PC1200 RDRAM - память, имеющая максимальную скорость передачи данный по шине в 4.8 Гб/с (представлена в январе 2002г.)
Любая подсистема памяти Direct Rambus состоит из пяти компонент:

  1. Direct Rambus Controller — это главная шина подсистемы памяти. Он помещается на чипе логики, как и PC-чипсет, микропроцессор, графический контроллер. Физически можно поместить до четырех Direct Rambus—контроллеров на одном чипе логики. Контроллер — это интерфейс между чипом логики и памятью Rambus, и в его обязанности входит генерация запросов, управление потоком данных, и ряд других функций.
  2. Direct Rambus Channel создает электрические соединения между Rambus Controller и чипами Direct RIMM. Работа канала основана на 30-ти сигналах, составляющих высокоскоростную шину. Эта шина работает на частоте 400 МГц и, за счет передачи данных на обеих границах тактового сигнала, позволяет передавать данные на 800 МГц. Два канала данных (шириной в байт каждый) позволяет получать пиковую пропускную способность в 1,6 Гбайт/с. Канал соответствует форм-фактору SDRAM.
  3. Direct Rambus Connector. 168-контактный разъем представляет собой низкоиндуктивный интерфейс между каналом на модуле RIMM и каналом на материнской плате.
  4. Direct Rambus Rimm(tm). Собственно модуль памяти, который включает в себя один или более чипов и организует непрерывность канала. По существу, RIMM образует непрерывный канал на пути от одного разъема к другому. Поэтому оставлять свободные разъемы нельзя.
  5. Direct Rambus DRAMs (чипы DRDRAM, запоминающие данные). Устройства Direct Rambus могут только отвечать на запросы контроллера, который делает их шину подчиненной или отвечающей.
Пока память DRDRAM является наиболее производительной, но и самой дорогой. Хотя благодаря 0.13 мкм техпроцессу, себестоимость Direct Rambus Rimm сильно снизилась. Но ее преимущество перед DDR SDRAM не столь существенно. К моменту выхода моделей Pentium 4 (с FSB533, где реально могла бы пригодиться пропускная способность Rambus-а), Intel уже начал выпуск чипсетов с поддержкой PC2700 DDR, что практически сравнимо с пропускной способностью двухканального Rimm PC800 DRAM. C появлением все новых чипсетов, поддерживающих DDR-I SDRAM, привлекательность Rambus падает. Т.е. сначала Rambus из-за Intel-а проиграл PC133 SDRAM, потом над Rambus-ом взяла вверх DDR-I, а далее противостояние опять: Rambus против DDR-II.
На мой взгляд эта память нужна очень немногим - пользователям, которым нужна производительность любой ценой (точнее - по любой цене). Использование Direct Rambus обычным пользователям - не рекомендую.

         "... Обещанного не всякий дождется ..."

Голографическая память или технология оптической записи. В мире существуют две научно-исследовательские программы. Одна - программа PRISM (Photorefractive Information Storage Material), вторая - HDSS (Holographic Data Storage System). Целью PRISM является поиск подходящих сред для хранения голограмм, а HDSS ориентирована на разработку аппаратных средств, необходимых для практической реализации голографических запоминающих систем. Обе ведут ряд фундаментальных исследований, а ее участниками являются те же компании.
Высокая плотность записи достигается за счет того, что голографический образ (голограмма) кодируется в один большой блок данных, который записывается всего за одно обращение. При чтении этот блок целиком извлекается из памяти. За основной материал разработок принят светочувствительном материал - ниобат лития, LiNbO3. Материалом для носителя в коммерческих устройствах является новый класс фотополимерных материалов. Для чтения или записи голографических блоков используются лазеры. Тысячи т.н. цифровых страниц, каждая из которых содержит до миллиона бит, можно поместить в устройство размером с кусочек сахара. Уже достигнута плотность порядка 10GB/sm3, ожидается - плотность данных в 1TБ на кубический сантиметр (TB/sm3). Можно сравнить с используемым сегодня магнитным способом - нескольких MB/sm2.
Сначала в устройстве голографической памяти происходит разделение луча сине-зеленого аргонового лазера на две составляющие - опорный и предметный лучи (последний является носителем самих данных). Для голографической памяти не годятся светодиоды на базе полупроводниковых лазеров, а применяются новые твердотельные лазеры. Предметный луч подвергается расфокусировке, чтобы он мог полностью освещать пространственный световой модулятор (SLM - Spatial Light Modulator). SLM - это жидкокристаллическую (LCD) панель, на которой страница данных отображается в виде матрицы, состоящей из светлых и темных пикселей (двоичные данные). Оба луча направляются внутрь светочувствительного кристалла, где и происходит их взаимодействие. В результате этого взаимодействия образуется интерференционная картина, которая и является основой голограммы и запоминается в виде набора вариаций показателя преломления или коэффициента отражения внутри этого кристалла. При чтении данных кристалл освещается опорным лучом, который, взаимодействуя с хранимой в кристалле интерференционной картиной, воспроизводит записанную страницу в виде образа "шахматной доски" из светлых и темных пикселей (голограмма преобразует опорную волну в копию предметной). Затем этот образ направляется в матричный детектор, основой для которого служит прибор с зарядовой связью (CCD - Charge-Coupled Device или ПЗС), захватывающее всю страницу данных. При чтении данных опорный луч должен падать на кристалл под тем же самым углом, при котором производилась запись этих данных, и допускается изменение этого угла не более чем на градус. Это позволяет получить высокую плотность данных: изменяя угол опорного луча или его частоту, можно записать дополнительные страницы данных в том же самом кристалле.
Динамическая область среды определяется количеством страниц, которые она может реально вмещать, поэтому участники PRISM и занимаются исследованием ограничений на светочувствительность материалов.

         "... Ничто не дается нам так дешево, как хочется ..."

Молекулярная память. Группа исследователей центра "W.M. Keck Center for Molecular Electronic" под руководством профессора Роберта Р.Бирга (Robert R. Birge) уже получила прототип системы памяти, использующей для запоминания цифровые биты молекулы. Это молекулы протеина, который называется бактериородопсин (bacteriorhodopsin). Данные, записанные на бактериородопсинном запоминающем устройстве, должны сохраняться около пять лет.
Был построен прототип системы памяти, в котором бактериородопсин запоминает данные в трехмерной матрице. Такая матрица представляет собой кювету (прозрачный сосуд), заполненную полиакридным гелем, в который помещен протеин. Кювета имеет продолговатую форму размером 1x1x2 дюйма. Протеин, который находится в bR-состоянии, фиксируется в пространстве при полимеризации геля. Кювету окружают батарея лазеров и детекторная матрица, построенная на базе прибора, использующего принцип зарядовой инжекции (CID - Charge Injection Device), которые служат для записи и чтения данных. При записи данных сначала используется желтый "страничный" лазер - для перевода молекул в Q-состояние. Пространственный световой модулятор (SLM, представляет собой LCD-матрицу, создающую маску на пути луча), вызывает возникновение активной (возбужденной) плоскости в материале внутри кюветы. Перед возвратом протеина в состояние покоя (в нем он может находиться довольно длительное время, сохраняя информацию) зажигается красный, записывающий лазер. Для стирания данных достаточно короткого импульса синего лазера, чтобы вернуть молекулы из Q-состояния в исходное bR-состояние.
Суммарное время для выполнения операции чтения или записи составляет около 10ms. Как и голографическая память, молекулярная осуществляет параллельный доступ в цикле чтения-записи, что позволяет рассчитывать на скорость до 10MBps. Если объединить по восемь запоминающих битовых ячеек в байт с параллельным доступом, то можно достигнуть скорости 80MBps. Некоторые версии устройств SLM выполняют страничную адресацию, которая в недорогих конструкциях используется при направлении луча на нужную страницу с помощью поворотной системы гальванических зеркал. Такой SLM обеспечивает доступ за 1ms, но и стоит в четыре раза дороже. Ограничения на емкость связаны с проблемами линзовой системы и качеством протеина, но на сегодня модуль молекулярной памяти может вместить 1 ТВ данных.
Данные сохраняются постоянно - даже если выключить питание системы памяти, это не приведет к потере информации. Кубики с данными, имеющие маленькие размеры, но содержащие гигабайты информации, можно помещать в архив для хранения копий (как магнитные ленты). Так как кубики не содержат движущихся частей, это удобнее и надежнее, чем винчестеры или любые накопители.

Вместо эпилога - сводная таблица некоторых параметров трех технологий.

DRAM Type | Name | Base Memory Speed | DDR/ QDR | Bus Width (bits) | Bits per Byte | Single Channel Theoretical Bandwidth | Dual Channel Theoretical Bandwidth | Quad Channel Theoretical Bandwidth
SDRAM | PC66 | 66MHz | -- | 64 | 8 | 533MB/s | 1066MB/s | 2133MB/s
 | PC100 | 100MHz | -- | 64 | 8 | 800MB/s | 1600MB/s | 3200MB/s
 | PC133 | 133MHz | -- | 64 | 8 | 1066MB/s | 2133MB/s | 4266MB/s
 | PC150 | 150MHz | -- | 64 | 8 | 1200MB/s | 2400MB/s | 4800MB/s
DDR SDRAM | PC1600 (DDR200) | 100MHz | x2 | 64 | 8 | 1600MB/s | 3200MB/s | 6400MB/s
 | PC2100 (DDR266) | 133MHz | x2 | 64 | 8 | 2133MB/s | 4266MB/s | 8533MB/s
 | PC2400 | 150MHz | x2 | 64 | 8 | 2400MB/s | 4800MB/s | 9600MB/s
 | PC2700 (DDR333) | 166MHz | x2 | 64 | 8 | 2666MB/s | 5333MB/s | 10666MB/s
 | PC3200 (DDR400) | 200MHz | x2 | 64 | 8 | 3200MB/s | 6400MB/s | 12800MB/s
QDR SDRAM | PC1600 (QDR400) | 100MHz | x4 | 64 | 8 | 3200MB/s | 6400MB/s | --
 | PC2100 (QDR533) | 133MHz | x4 | 64 | 8 | 4266MB/s | 8533MB/s | --
 | PC2700 (QDR666) | 166MHz | x4 | 64 | 8 | 5333MB/s | 10666MB/s | --
DDR-II SDRAM | PC3200 (DDRII-400) | 200MHz | x2 | 64 | 8 | 3200MB/s | 6400MB/s | 12800MB/s
 | PC4300 (DDRII-533) | 266MHz | x2 | 64 | 8 | 4266MB/s | 8533MB/s | 16466MB/s
 | PC5400 (DDRII-667) | 333MHz | x2 | 64 | 8 | 5333MB/s | 10666MB/s | 21333MB/s
 | PC6400 (DDRII-800) | 400MHz | x2 | 64 | 8 | 6400MB/s | 12800MB/s | 25600MB/s
Rambus | PC600 | 266MHz | x2 | 16 | 8 | 1066MB/s | 2133MB/s | --
 | PC600 | 300MHz | x2 | 16 | 8 | 1200MB/s | 2400MB/s | --
 | PC700 | 300MHz | x2 | 16 | 8 | 1200MB/s | 2400MB/s | --
 | PC700 | 356MHz | x2 | 16 | 8 | 1424MB/s | 2848MB/s | --
 | PC800 | 400MHz | x2 | 16 | 8 | 1600MB/s | 3200MB/s | --
Rambus Hastings | PC1066 | 533MHz | x2 | 16 | 8 | --- | 4266MB/s | --
 | PC1200 | 600MHz | x2 | 16 | 8 | --- | 4800MB/s | ---
32-bit-ные модули Rambus | PC4200 | 533MHz | x2 | 16 | 8 | --- | 4266MB/s | ---
 | PC4800 | 600MHz | x2 | 16 | 8 | --- | 4800MB/s | ---
64-bit-ные модули Rambus | PC8500 | 533MHz | x2 | 16 | 8 | --- | --- | 8533MB/s
 | PC9600 | 600MHz | x2 | 16 | 8 | --- | --- | 9600MB/s

Вместо итогов обращаю Ваше внимание на ряд важных факторов:
  • развитие оперативной памяти - бесконечный и быстрый процесс. Чтобы Вы не купили - оно уже морально устарело;
  • если какая-то память предлагается по более дешевой цене, то вероятно, что и качество у нее более низкое. Копьютеры с установленной в них дешевой памятью могут часто "зависать", например при высокой температуре воздуха или большой влажности;
  • при выборе материнской платы всегда смотрите тип поддерживаемой ее чипсетом оперативной памяти. Многие чипсеты по своей спецификации поддерживают как память SDRAM, так и память DDR SDRAM, и все зависит от того, какой именно тип памяти реализован. Встречаются даже платы с наличием двойных слотов (одновременно и для SDRAM и для DDR SDRAM-памяти), хотя использован может быть только один тип памяти;
  • не покупайте память "Made in China";
  • верхний объем памяти зависит еще и от операционной системы. Например Windows 95, 98, 98SE и Me не предназначены для работы с памятью объемом более 512 Мб;
Личное мнение... если Вы покупаете новый системный блок - покупайте DDR и частоту побольше. А если Вы модернизируетесь на P_IV (напр. с P_III) - оставьте свои Dimm-ы и ищите плату с чипсетом i845.

© Dmitry Belousov
http://www.orakul.spb.ru
ноябрь 2001г.-март 2003г.


"Азбука РС" Дм.Белоусова, m/b

Материнская плата (m/b)

•

Bios

•

Шины

Систематизация
m/b по Chipset-у:
Систематизация
m/b по форм-фактору:
Систематизация
m/b по типу памяти:
Систематизация
m/b по разъему ЦП:
  • от Intel-а;
  • от VIA-а;
  • от SiS-а;
  • прочие;
  • ATX;
  • AT;
  • NLX, ITX;
  • WTX;
  • SIMM-ы (SRAM);
  • DIMM-ы (SDRAM);
  • QDR-ы (SDRAM);
  • DDR (DDR-II) DRAM;
  • RIMM-ы (Rambus DRAM);
  • Socket-ы;
  • Slot-ы;

Системной (System Board) или материнской платой (Mother Board, m/b, MB, "мама") называют основную печатную плату ПК, на которой устанавливается другие системные компоненты. Она представляет собой плоский лист фольгированного стеклотекстолита (в последние годы - пластика), на котором размещены основные компоненты. Компоненты подразделяются на:
  • Внутренние. Соединение этих элементов выполняется предварительным травлением медной фольги нанесенной на подложку стеклотекстолита. В технологическом цикле несколько листов соединяются в многослойную структуру, покрытую защищенным лаком.
  • Внешние. В системную плату устанавливается процессор и память, а также платы таких устройств, как внутренний модем, сетевая плата, видео-плата и т.п.
У некоторых компьютеров на одной системной плате могут быть все элементы, необходимые для его работы. Это контроллеры дисковых накопителей, видеоадаптер, контроллеры портов и др. Называются All-In-One или "все на борту". Но чаще всего к стандарту добавляют только два компонента - звук и видео. У большинства же плат - только основные узлы. Отсутствующие элементы располагают на отдельных платах, которые вставляются в специальные разъемы расширения на системной плате. Разъемы расширения этих плат связаны друг с другом на m/b рядом параллельных проводников, по которым осуществляется передача данных, адресов и управляющих сигналов. Разъемы бывают разборные и неразборные.
На платах All-In-One иногда все же имеется только один разъем расширения для так называемой riser-карты. На ней размещаются несколько разъемов расширения и вставляемые в них платы располагаются параллельно материнской.
От качества m/b зависит надёжность и скорость взаимодействия между различными узлами компьютера. Основные признаки платы: фирменное название, под какой процессор, какие шины и сколько у нее разъемов, сколько и каких разъемов под память, что написано на микросхемах и т.п.
Cистемные платы выпускает большое количество фирм-производителей. Самые известные торговые марки:
[ Abit* ] [ Acorp ] [ Albatron ] [ AOpen* ] [ Asus* ] [ BioStar* ] [ Chaintech* ] [ DFI* ] [ ECS / Elpina / PCChips* ] [ Epox* ] [ FIC ] [ Gigabyte* ] [ Gainward ] [ Intel ] [ Iwill ] [ Jetway ] [ Leadtek ] [ Lucky Star ] [ MSI* ] [ NMC ] [ Octek ] [ PCPartner ] [ Soltek ] [ Soyo* ] [ Suma ] [ SuperMicro ] [ Shuttle* ] [ Tekram* ] [ Tyan ] [ VIA / VPSD ] [ USI* ] [ Zida ]
* - тайваньские производители (отмечу ASUS и MSI). Совет - не читайте тесты по платам. Использование одинаковых чипсетов в разных платах приводит к примерно одинаковым результатам по большинству тестов. Но у каждого имеются свои особенности. Например на плате фирмы ACORP с обратной стороны находится пластиковая подложка, предохраняющая ее от ненужных контактов (фирменная традиция). Платы компании Intel выполнены в соответствии с принципом "Шаг вправо, шаг влево - расcтрел", т.е. возможностей для вмешательства пользователя практически нет. И в момент загрузки, после информации о Bios, Intel-платы выводят серийный номер m/b. У Iwill-плат в поставке есть дополнительный термодатчик, который можно прикрепить к любому устройству, имеющему отверстие под крепежный винт, например, к жесткому диску. Платы с логикой от VIA позволяют воспользоваться поддержкой режима работы жесткого диска в Ultra DMA 66, повысив т.о. производительность.
Вид двух системных плат (слева - с Socket-ом, справа - со Slot-ом):

Системная плата содержит множество внутренних компонентов, определяющих архитектуру компьютера. Это:

  • Разъём под центральный процессор (1-2 шт., Socket-Slot);
  • Cashe (кэш, L1-L2, напр. объёмом 256 Кбайт) и разъём под него;
  • Контроллер винчестера (как минимум требуется поддержка и "UltraDMA" и 7200 об\мин) и разъёмы шлейфов к жёстким дискам;
  • Слоты (разъёмы) под оперативную память (два, три, четыре);
  • Контроллер (коннектор) клавиатуры и мыши;
  • Микросхема, обслуживающая floppy-дисковод, последовательные порты и параллельный порт;
  • Перезаписываемая Bios (старое название Flash-память);
  • Системные преобразователи напряжения;
  • Слот (разъёмы) AGP-шины (для видео-карты, карты Internet и др.);
  • Гнёзда расширения (слоты, Slot);
  • Контроллеры внешних устройств;
  • Разъёмы прочих шин (интерфейсные схемы);
  • CNR-слот (либо для сетевой карты, либо для модема);
  • AMR-слот (либо для звуковой карты [Audio Riser], либо для модема [Modem Riser]);
  • Прочие компоненты;
В рамках одного семейства производители выпускают большое число плат-близнецов, отличающихся только наличием или отсутствием дополнительных компонентов (SCSI-адаптер, звуковая или сетевая карта и т.п.). И производительность, и другие характеристики таких "близняшек" одинаковы.
Слот (Slot) представляет собой щелевой разъем, в который устанавливается либо процессор (напр. сокет-Socket) или какая-либо печатная плата (это слот расширения). Другое определение слота расширения (Expansion Slot) - разъем системной шины в совокупности с прорезью в задней стенке компьютера. Обычно это ISA Slot, PCI Slot, AGP Slot. Т.е. это посадочное место для установки карты расширения. Платой расширения, или картой расширения (Expansion Card), называют печатную плату с краевым разъемом, устанавливаемую в слот расширения. Карты расширения, привносящие в PC какой-либо дополнительный интерфейс, называются интерфейсными картами (Interface Card). Поскольку интерфейсная плата представляет собой "приспособление" для подключения какого-либо устройства, к ней применимо и название адаптер (Adapter). Например дисплейный адаптер (Display adapter) служит для подключения дисплея-монитора. Адаптер и интерфейсная карта практически синонимы, и например, NIC (Network Interface Card) часто переводится как адаптер ЛВС (локальной вычислительной сети). Каждая m/b, формально декларируя работа на одной частоте:
[ 33 МГц ] [ 66 МГц ] [ 100 МГц ] [ 133 МГц ] [ 200 МГц ] [ 266 МГц ] [ 333 МГц ] [ 533МГц ]
имеет несколько частот работы: частота шина между мостами чипсета (напр. 266 MBps), частота FSB (напр. 400 MHz), частота памяти (напр. 100/133/200/266). При этом выбор системной частоты подразумевает как выбор PCI-частоты /напрямую 66/33 или через делитель частоты 66(1/2)/
[ 66/33 ] [ 68/34 ] [ 75/37 ] [ 83/41 ] [ 100/33 ] [ 103/34 ] [ 105/35 ] [ 110/36 ] [ 112/37 ] [ 115/38 ] [ 117/29 ] [ 117/30 ] [ 117/39 ] [ 120/40 ] [ 124/31 ] [ 124/41 ] [ 129/32 ] [ 133/33 ] [ 133/44 ] [ 138/34 ] [ 140/35 ] [ 143/36 ] [ 148/37 ] [ 150/37 ] [ 153/38 ]
так и выбор-соотношение отношение частоты шины AGP к системной частоте:
[ 1/1 ] [ 2/3 ]
Важно, что при частоте шине PCI, значительно отличающейся от стандартного значения 33МГц, возможна нестабильная работа устройств, установленных в ее слотах, а также некоторых жестких дисков.

· Джампер (Jumper) представляет собой маленькую съемную перемычку, устанавливаемую на торчащие из m/b контакты. Джамперы используются для конфигурирования различных компонентов, для которых не требуется оперативного управления (как выключатели или переключатели). Установку на m/b требуемую частоту процессора делается jumper-ом. Напр. процессор PIII 1000Мz - это частота шины 133Мz (1-й jumper) и коэффициент умножения 7,5 (2-й jumper). Коэффициент умножения имеет значения от 2,0 до 10,0, обычный диапазон меньше - напр. 2,0-8,0 с шагом 0,5.

Разгон процессора до недавних пор делался именно jumper-ами. Например, чтобы заставить PIII 666Мz работать как PIII 750Мz, достаточно было переключить или jumper коэффициента с 5 на 5,5, или jumper частоты с 133 до 150. Правда выигрыш будет только в том случае, если устройства (минимум m/b и процессор) могут работать на итоговой новой повышенной частоте. Работать стабильно! Однако в последние годы фирмы-производители стали блокировать jumper частоты шины и ограничивать кол-во вариантов jumper-а коэффициентов. Т.о. возможности разгона резко сократились. Счастливое исключение - платы ABIT, где вместе с "Руководством" по самой плате дается еще и Oveclocking Gid.
Есть тенденция постепенного перехода к безджамперным технологиям. В этом случае появляется возможность производить установки для процессора непосредственно из Bios-а.

· DIP-переключатели (DIP Switches) представляют собой малогабаритные выключатели в m/b, применяемые для тех же целей, что и джамперы. Их преимущество - в более легком переключении. Недостатком является большее (по сравнению с джамперами), занимаемое на плате место и более высокая цена. Кроме того, они обычно являются только выключателями, что делает их применение менее гибким, чем применение джамперов.

· Системные преобразователи регулируют уровень напряжения. Напр. можно установить либо стандартное напряжение 3,5В (для DRAM, AGP и чипсета) или повысить его до 3,65В. Также можно выбрать напряжение на ядре процессора (напр. из значений 2,00, 2,05, 2,10, 2,20, 2,30, 2,40В). Также регулируются частоты на AGP - три положения: автоопределение "по умолчанию", выбор делителя от тактовой (1/1, 2/3).

Данные конфигурирования для 486-плат под Intel-процессоры:

486 CPU Speed Settings

Bus Speeds (MHz) | Jumpers
1.0x | 16 | 20 | 25 | 33 | 40 | 50 | 60 | BF
2.0x | 32 | 40 | 50 | 66 | 80 | 100 | 120 | on
2.5x 40 50 63 83 100 125 150 --
3.0x | 48 | 60 | 75 | 100 | 120 | 150 | 180 | off
4.0x | 64 | 80 | 100 | 133 | 160 | 200 | 240 | on

Данные конфигурирования для плат с гнездом Socket 7 под Intel-процессоры:
Socket 7

586 CPU, Bus Speeds (MHz)

Jumpers
1.0x | 40 | 50 | 55 | 60 | 62 | 66 | 68 | 75 | 83 | 90 | 95 | 100 | 105 | 110 | 112 | 115 | 120 | 124 | 133 | BF0 | BF1 | BF2
1.5x | 60 | 75 | 83 | 90 | 94 | 100 | 103 | 113 | 125 | 135 | 143 | 150 | 158 | 165 | 168 | 173 | 180 | 186 | 200 | off | off | off
1.75x | 70 | 88 | 96 | 105 | 109 | 116 | 120 | 131 | 146 | 158 | 166 | 175 | 184 | 193 | 196 | 201 | 210 | 217 | 233 | on | on | off
2.0x | 80 | 100 | 110 | 120 | 125 | 133 | 137 | 150 | 166 | 180 | 190 | 200 | 210 | 220 | 224 | 230 | 240 | 248 | 266 | on | off | off
2.33x | 93 | 117 | 128 | 140 | 146 | 156 | 159 | 175 | 194 | 210 | 222 | 233 | 245 | 256 | 261 | 268 | 280 | 289 | 311 | off | on | on
2.5x | 100 | 125 | 138 | 150 | 156 | 166 | 171 | 188 | 208 | 225 | 238 | 250 | 263 | 275 | 280 | 288 | 300 | 310 | 333 | on | on | off
2.66x | 107 | 133 | 147 | 160 | 166 | 178 | 182 | 200 | 222 | 240 | 253 | 266 | 280 | 293 | 299 | 307 | 320 | 331 | 356 | off | off | on
3.0x | 120 | 150 | 165 | 180 | 188 | 200 | 205 | 225 | 250 | 270 | 285 | 300 | 315 | 330 | 336 | 345 | 360 | 372 | 400 | off | on | off
3.33x | 133 | 166 | 183 | 200 | 208 | 222 | 228 | 250 | 278 | 300 | 317 | 333 | 350 | 366 | 373 | 383 | 400 | 413 | 444 | on | off | off
3.5x | 140 | 175 | 193 | 210 | 219 | 233 | 239 | 263 | 290 | 315 | 333 | 350 | 368 | 385 | 392 | 403 | 420 | 434 | 466 | off | off | off
4.0x | 160 | 200 | 220 | 240 | 250 | 266 | 273 | 300 | 333 | 360 | 380 | 400 | 420 | 440 | 448 | 460 | 480 | 496 | 533 | on | off | on
4.5x | 180 | 225 | 248 | 270 | 281 | 300 | 308 | 338 | 375 | 405 | 428 | 450 | 473 | 495 | 504 | 518 | 540 | 558 | 600 | on | on | on
5.0x | 200 | 250 | 275 | 300 | 313 | 333 | 342 | 375 | 417 | 450 | 475 | 500 | 525 | 550 | 560 | 575 | 600 | 620 | 666 | off | on | on
5.5x | 220 | 275 | 303 | 330 | 344 | 366 | 376 | 413 | 458 | 495 | 523 | 550 | 578 | 605 | 616 | 633 | 660 | 682 | 733 | off | off | on
6.0x | 240 | 300 | 330 | 360 | 375 | 400 | 410 | 450 | 500 | 540 | 570 | 600 | 630 | 660 | 672 | 690 | 720 | 744 | 800 | on | off | off

Данные конфигурирования Socket 8 / Slot 1 / Slot 2 / Socket 370 для 686-плат под Intel-процессоры:

686 CPU, Bus Speeds (MHz)

Jumpers
50 | 60 | 66 | 68 | 75 | 83 | 90 | 100 | 102 | 112 | 124 | 133 | 150 | 200 | BF0 | BF1 | BF2 | BF3
1.5x | 75 | 90 | 100 | 103 | 113 | 125 | 135 | 150 | 154 | 168 | 186 | 200 | 225 | 300 | off | on | off | off
2.0x | 100 | 120 | 133 | 137 | 150 | 166 | 180 | 200 | 205 | 224 | 248 | 266 | 300 | 400 | off | off | off | off
2.0x | 100 | 120 | 133 | 137 | 150 | 166 | 180 | 200 | 205 | 224 | 248 | 266 | 300 | 400 | on | on | on | on
2.5x | 125 | 150 | 166 | 171 | 188 | 208 | 225 | 250 | 256 | 280 | 310 | 333 | 375 | 500 | off | on | on | on
3.0x | 150 | 180 | 200 | 206 | 225 | 250 | 270 | 300 | 308 | 336 | 372 | 400 | 450 | 600 | on | off | on | on
3.5x | 175 | 210 | 233 | 240 | 263 | 292 | 315 | 350 | 359 | 392 | 434 | 466 | 525 | 700 | off | off | on | on
4.0x | 200 | 240 | 266 | 274 | 300 | 333 | 360 | 400 | 410 | 448 | 496 | 533 | 600 | 800 | on | on | off | on
4.5x | 225 | 270 | 300 | 308 | 338 | 375 | 405 | 450 | 461 | 504 | 558 | 600 | 675 | 900 | off | on | off | on
5.0x | 250 | 300 | 333 | 343 | 375 | 417 | 450 | 500 | 513 | 560 | 620 | 666 | 750 | 1000 | on | off | off | on
5.5x | 275 | 330 | 366 | 377 | 413 | 458 | 495 | 550 | 564 | 616 | 682 | 733 | 825 | 1100 | off | off | off | on
6.0x | 300 | 360 | 400 | 411 | 450 | 500 | 540 | 600 | 615 | 672 | 744 | 800 | 900 | 1200 | on | on | on | off
6.5x | 325 | 390 | 433 | 445 | 488 | 542 | 585 | 650 | 666 | 728 | 806 | 866 | 975 | 1300 | off | on | on | off
7.0x | 350 | 420 | 466 | 480 | 525 | 583 | 630 | 700 | 718 | 784 | 868 | 933 | 1050 | 1400 | on | off | on | off
7.5x | 375 | 450 | 500 | 514 | 563 | 625 | 675 | 750 | 769 | 840 | 930 | 1000 | 1125 | 1500 | off | off | on | off
8.0x | 400 | 480 | 533 | 548 | 600 | 666 | 720 | 800 | 820 | 896 | 992 | 1066 | 1200 | 1600 | on | on | off | off
8.5x | 425 | 510 | 566 | 584 | 638 | 708 | 765 | 850 | 867 | 952 | 1054 | 1133 | 1275 | 1700 | н/д | н/д | н/д | н/д
9.0x | 450 | 540 | 600 | 618 | 675 | 750 | 810 | 900 | 918 | 1008 | 1116 | 1200 | 1350 | 1800 | н/д | н/д | н/д | н/д
9.5x | 475 | 570 | 633 | 652 | 713 | 792 | 855 | 950 | 969 | 1064 | 1178 | 1266 | 1425 | 1900 | н/д | н/д | н/д | н/д
10.0x | 500 | 600 | 667 | 687 | 750 | 833 | 900 | 1000 | 1020 | 1120 | 1240 | 1333 | 1500 | 2000 | н/д | н/д | н/д | н/д
10.5x | 525 | 630 | 700 | 721 | 798 | 875 | 945 | 1100 | 1071 | 1176 | 1302 | 1400 | 1575 | 2100 | н/д | н/д | н/д | н/д
11.0x | 550 | 660 | 733 | 755 | 825 | 917 | 990 | 1200 | 1122 | 1232 | 1364 | 1466 | 1650 | 2200 | н/д | н/д | н/д | н/д

В современных компонентах стремятся сокращать количество переключателей или джамперов, стараясь переложить все конфигурационные функции на программно-управляемые электронные компоненты. Платы-карты, в которых удается изжить jumper-ы полностью (но которые требуют конфигурирования), называются Jamperless Cards - карты, свободные от джамперов. Компоненты, которые после установки конфигурируются автоматически, относятся к классу PnP - Plug and Play - вставляй и играй (точнее "включи и молись, чтобы заработало").

· Form factor платы. Так обозначается физическая конструкция и типо-размер системных плат и корпусов. Вам могут встретиться платы типо-размеров ATX, Baby AT, NLX. Еще бывают Form factor-ы ITX и WTX.

· Тип оперативной памяти. Плата и процессор поддерживают один (очень редко - два) типа оперативной памяти. Это SIMM-ы, DIMM-ы, DDR DRAM, RIMM-ы. В последние годы при выборе материнской платы уже не стоит вопрос - "Какой чипсет?", а только - "Какая память?". При этом выбор типа памяти не менее важен, чем выбор процессора. При смене типа производители (пытаясь угодить покупателям), порой доходили до того, что на одной материнской плате можно было увидеть одновременно гнезда под и SIMM-модули и DIMM-модули.
В зависимости от типа памяти количество слотов для ее установки может быть различным. Так, если речь идет о SDRAM PC133-памяти, то обычно на плате будет три слота. Для памяти DDR SDRAM может быть два или три слота, а для двухканальной DRDRAM-памяти разводится 4 слота (по два слота на канал). Слоты для установки различных типов памяти не совместимы друг с другом, поэтому ошибиться невозможно. Количество слотов уже не является столь критичным, как ранее, т.к. объем модулей памяти постоянно растет. Часто и двух слотов вполне достаточно, чтобы установить максимальный объем памяти, поддерживаемый современными чипсетами.

         ...Если я конечно везде правильно путаю...

Вид разъема для ЦП или гнездо, в которое устанавливается центральный процессор. Бывает всего два типа гнезда (с множеством модификаций у каждого):
· Socket - плоский разъем для установки микросхемы с выводами, перпендикулярными корпусу. См. вид;
· Slot - щелевой разъем для установки платы с контактами по краю. См. вид;

В прежние годы пользователи PC стройными рядами переходили с Socket 3 на Socket 4, Socket 7. Каждый знал, что какой бы фирмы процессор он не купил, он точно будет работать на материнской плате. Все - эта "лафа" заканчилась. Ныне постоянно появляются новые, чуть-чуть другие разъемы и т.о. фирмы-производители заставляют нас покупать новые платы. Самые распространенные разъемы:
  • Socket 1 (PGA-169) - под процессоры 486SX/DX/DX2 (5В);
  • Socket 2 (PGA-238) - под процессоры 486SX/DX/DX2/DX4 (5В);
  • Socket 3 (PGA-237) - под процессоры 486SX/DX/DX2/DX4 (5В/3,3В);
  • Socket 4 (PGA-273) - под процессоры Pentium 60/66 (5В);
  • Socket 5 (SPGA-320) - под процессоры Pentium 75-133 (3,3В);
  • Socket 6 (PGA-235) - под процессоры 486DX4 (3,3В);
  • Socket 7 (SPGA-321) - под процессоры Pentium 60-333 (2,2-3,3В);
  • Socket 8 (PGA/SPGA-387) - под процессоры Pentium Pro (P6);
  • Socket 370 (PPGA-370) - под процессоры Celeron PPGA;
  • Socket 423 - под процессоры Intel Pentium 4;
  • Socket 462 (Socket A) - под процессоры AMD Thunderbird/Duron до 1.5 ГГц;
  • Socket 478 - под процессоры Intel Pentium 4 для настольных ПК;
  • Socket 479 (Willamette-479) - под процессоры Intel для мобильных Pentium 4;
  • Socket 603 - под процессоры Intel Intel Xeon (Prestonia);
  • Socket 754 - под процессоры AMD ClawHammer (линейка Athlon XP 64);
  • Socket 924 - под процессор AMD 1 ГГц Dual-Duron (плата Solo);
  • Socket 940 - под процессоры AMD SledgeHammer;
  • Slot 1 (SEC-242) - под процессоры Pentium II/Celeron;
  • Slot 2 (SEC-330) - под процессоры Pentium II Xeon;
  • Slot A - под процессоры AMD Athlon (К7-К75) 500-1000 МГц;
  • Slot A - под процессоры AMD Thunderbird (К7-К75) 650-1000 МГц;
Отмечу знаменитый Socket 924 от AMD - это двукратное увеличение мощности системы путем простого арифметического сложения двух процессоров AMD Duron 1000. На основе Intel-а есть двухпроцессорные платы (Socket 603) у ASUS-а, у ABIT-а.
Для каждого типа разъема, помимо физического расположения и количества контактов, имеется своя схема соответствия контактов электрическим сигналам. Поэтому, несмотря на то, что процессоры 486 физически могут быть установлены в любой из новых разъемов, а процессоры Pentium - в любой из разъемов Socket 5/7, правильная (безопасная и полноценная) работа процессора в "чужом" разъеме возможна лишь в случае совместимости существующей разводки сигналов с типом установленного процессора. Это касается выводов коэффициента умножения, управления внутренним кэшем, автоматического определения напряжения питания и т.п. функций, имеющих различное расположение и назначение в процессорах разных типов и серий.

                               CORE voltage | I/O voltage
                               plane (Vcc2) | plane (Vcc3)
                                            |
     1   3   5   7   9   11  13  15  17  19 |21  23  25  27  29  31  33  35  37
       2   4   6   8   10  12  14  16  18  20  22  24  26  28  30  32  34  36
   |----------------------------------------|----------------------------------|
AN | o   o   o   o   o   o   o   o   o   o  |o   o   o   o   o   o   o   o   o | AN
AM |   o   o   o   o   o   o   o   o   o   o|  o   o   o   o   o   o   o   o   | AM
AL | o   o   o   o   o   o   o   o   o   o__|o   o   o   o   o   o   o   o   o | AL
AK |   o   o   o   o   o   o   o   o   o|  o   o   o   o   o   o   o   o   o   | AK
AJ | o   o   o   o   o   o   o   o   o  |o   o   o   o   o   o   o   o   o   o | AJ
AH |   o   o       ---------------------|-----------------------   x   o   o   | AH
AG | o   o   o   /                      |                        \   o   o   o | AG
AF |   o   o    /                       |                         \    o   o   | AF
AE | o   o   o |                        |                          | o   o   o | AE
AD |   o   o   |                        |                          |   o   o   | AD
AC | o   o   o |                        |                          | o   o   o | AC
AB |   o   o   |                        |                          |   o   o   | AB
AA | o   o   o |                        |                          | o   o   o | AA
Z  |   o   o   |                        |                          |   o   o   | Z
Y  | o   o   o |                        |                          | o   o   o | Y
X  |   o   o   |                        |                          |   o   o   | X
W  | o   o   o |                        |                          | o   o   o | W
V  |   o   o   |                    BOTTOM VIEW                    |   o   o   | V
U  | o   o   o |                    (pin side)                     | o   o   o | U
T  |   o   o   |                        |                          |   o   o   | T
S  | o   o   o |                        |                          | o   o   o | S
R  |   o   o   |                        |                          |   o   o   | R
Q  | o   o   o |                        |                          | o   o   o | Q
P  |   o   o   |                        |                          |   o   o   | P
N  | o   o   o |                        |                          | o   o   o | N
M  |   o   o   |                        |                          |   o   o   | M
L  | o   o   o |                        |                          | o   o   o | L
K  |   o   o   |                        |                          |   o   o   | K
J  | o   o   o |                        |                          | o   o   o | J
H  |   o   o    \                       |                         /    o   o   | H
G  | o   o   o   \                      |                        /   o   o   o | G
F  |   o   o   o   ---------------------|-----------------------       o   o   | F
E  | o   o   o   o   o   o   o   o   o  |o   o   o   o   o   o   o   o   o   o | E
D  |   o   o   o   o   o   o   o   o   o|  o   o   o   o   o   o   o   o   o   | D
C  | o   o   o   o   o   o   o   o   o  |o   o   o   o   o   o   o   o   o   o | C
B  |   o   o   o   o   o   o   o   o   o|  o   o   o   o   o   o   o   o   o   | B
A   \    o   o   o   o   o   o   o   o  |o   o   o   o   o   o   o   o   o   o | A
     \----------------------------------|--------------------------------------|
     1   3   5   7   9   11  13  15  17 |19  21  23  25  27  29  31  33  35  37
       2   4   6   8   10  12  14  16  18  20  22  24  26  28  30  32  34  36
                                        |
                           CORE voltage | I/O voltage
                           plane (Vcc2) | plane (Vcc3)

· Socket-переходники используют для установки нового процессора в старое гнездо m/b. Первым появился адаптер S370 -> Slot 1 вследствии политики Intel-а по разделению двух веток процессоров: Pentium II для Slot I для серьезных задач и Celeron под Socket 370 "для дома". Это переходники от фирмы ASUSTeK (S370), от фирмы MSI (MS-6905), PL-iP3/T. Затем появились Socket 423 -> Socket 478, Socket A -> Slot A.
На процессор, установленный в переходник, можно прикрепить более мощный радиатор. Некоторые продвинутые модели имеют настройку CPU voltage (выбирая напряжение из значений 1,80 - 2,10 В (с шагом 0,05В) и в диапазоне 2,20 - 2,60 В (с шагом 0,10 В) или оставив его в стандартном режиме), блокировка B21 и т.п. параметров. Но не все переходники поддерживают высокие частоты FSB (даже 133 MГц). Учтите, что дешевые переходники (как и материнские платы) не имеют функции контроля температуры (точнее, не способны передать материнской плате показания встроенного в процессор термодатчика) - главного параметра при overclocking. Эта проблема решается использованием внешнего датчика, но точность при этом снижается.
Подобный upgrade для грамотного компьютерщика крайне выгоден (напр. цена "Переходника Socket 370 на Slot1" - всего $5-7), но требует знаний. Напр. для слотовой m/b нужен переходник socket/slot с пошаговой регулировкой вольтажа (скажем от ASUS).
При покупке нового ПК лучше берите материнскую плату с новым разъемом.
Face of table... AMD неоднократно заявляла о невозможности создания переходников Socket A -> Slot A ... но вот "невозможный" адаптер вышел. Чудо-разработчик - немецкая компания NMC. Название - NMC Slotket A. Согласно заявлениям разработчиков, Slotket A будет работать в любых системных платах с разъемом Slot A.

         ... Hardware detection: Found RAM 262144 kb - ok, Found CPU Pentium IV 1800 Mhz - ok, Found 2 processors kernel - ok, Found New User Lamer - failed, Crashing System, oi mama!!! ...

· Чипсет (ChipSets, МСЛ, микросхема системной логики). ПК состоит из устройств, которые подключены к материнской плате и занимаются приемом, обработкой и передачей какой-либо информации. Логической организацией этой работы (с помощью интегрированных в его состав контроллеров) и занимаются чипсеты, т.е. именно чипсет обеспечивает работу основных подсистем компьютера (центральный процессор, видеоадаптер, оперативная память).
Ранее материнские платы несли на себе до ста микросхем. Первая большая микросхема была выпущена в 1986 году фирмой "Chips & Technologies" и называлась 82С206. Она выполняла функции: 1. контроллера шин, 2. генератора тактовой частоты 3. системного таймера 4. контроллера прерываний 5. контроллера прямого доступа к памяти 6. CMOS-а. Вместе с еще 4-мя микросхемами в качестве буферов и контроллеров получился первый чипсет, названный CS8220. Следующий набор 82C836 Single Chip (SCAT) уже состоял из одной микросхемы. Внешне микросхемы Chipset'а выглядят, как самые большие чипы (после процессора), с количеством выводов от нескольких десятков до сотен. Сегодня на плате размещают 1–2 микросхемы.
Вид Chipset'а от Intel-а:

Современные ChipSet-ы содержат в себе периферийный контроллер (содержащий два контроллера прерываний IRQ0–7 и IRQ8–15), два контроллера DMA (каналы 0–3 и 4–7), контроллер для Enhanced IDE устройств, часы реального времени с CMOS-памятью (около 100 байт), прямой доступ к памяти, таймер, систему управления памятью и шиной; поддерживают спецификацию шины PCI, синхронную и асинхронную кэш-память, EDO и FPM DRAM, AGP. Обычно в одну из микросхем набора входят также и клавиатурный контроллер (может присутствовать и в виде отдельных чипов). В последние годы в состав МСЛ стали включать и контроллеры внешних устройств.
Чипсет состоит из двух микросхем, называемых северным и южным мостами. Эти мосты выполняют функции связи различных шин и интерфейсов. Северный мост всегда закрыт радиатором (иногда с вентилятором) и располагается рядом с процессором (северный мост гораздо "быстрее" южного и больше нагревается). Северный мост отвечает за взаимодействие с оперативной памятью (шина памяти), взаимодействие с центральным процессором (системная шина), взаимодействие с графической подсистемой (шина AGP) и взаимодействие с южным мостом. Т.е. северный мост контролирует потоки из четырех шин. Южный мост соединен с достаточно медленными компонентами, а также с медленными периферийными устройствами (жесткий диск, интерфейс USB и т.д.). Управляя работой высокоскоростных шин, чипсет использует развитые механизмы арбитража, буферизации, очередей и т.о. оптимизирует основные информационные потоки в системе компьютера.
Название набора обычно происходит от маркировки основной микросхемы (напр. SiS471, i440BX). При этом используется только код микросхемы внутри серии: например, полное наименование SiS471 - SiS85C471. Последние разработки используют и собственые имена.
Раньше наборы системной логики (они же ChipSets) выпускали компании "Acer", "Chips & Technologies", "OPTi", "Erso", "Headland Technology", "PC Chips", "Suntac", "Symphony", "UMC", "VLSI". Но в 1989 году "Compaq" разработала шину EISA, а предоставить контролер к ней отказалась. И в Intel-е за короткое время сами разработали контроллер. В 1994 году, выпустив процессор i486, фирме Intel пришлось ждать, когда производители чипсетов подготовят подходящий набор системной логики (МСЛ). Чтобы больше не терять время, при выпуске процессора Pentium (в 1995 году), Intel сразу же разработала и выпустила собственный набор. Так на рынок ChipSets-ов вышел монстр Intel и ... почти все другие фирмы-разработчики скоро закрылись. Даже прародитель чипсетов ("Chip&T") был выжит с этого рынка, а затем и вовсе куплен Intel’ом. С тех пор у Intel’а: вышел новый процессор – вышел к нему чипсет.
Хотя формально и появились новые фирмы-производители чипсетов (всего 12 компаний), но в основном МСЛ выпускают три "монстра" (выделены синим цветом):
[ ALi (Acer) ] [ AMD ] [ ATI ] [ IBM ] [ Intel ] [ Micron ] [ NVidia ] [ OPTi ] [ ServerWorks ] [ SiS ] [ VIA Technologies ] [ VLSI ]
Именно ChipSets определяет функции, реализуемые на плате - тип оперативной памяти, поддержку частот, процессорного слота, типов шин и т.п.
Для "пытливых" привожу огромный перечень по фирмам-производителям, по возможности сохраняя хронологию выхода "в свет":

ALi Chipsets Typical
CPUs 		DRAM
Types 		Mem
Rows 		DRAM
Density 		Max
Mem 		ECC/
Parity 		AGP Bus
Speeds 		PCI Clock
Dividers 		Max L2/
Tag bits
ALi Aladdin III P54C FPM
EDO
SDRAM 		? ?Mbit 256MB ? N/A 50
60
66 		1/2 512KB/?-bit
?MB WT
?MB WB
ALi Aladdin IV
[M1531]
[M1533] 		P54C
P55C
Lin Burst 		FPM
EDO
SDRAM 		8 16Mbit
64Mbit 		1GB Both N/A 50
60
66
75
83 		1/2
2/5 		1MB/11-bit
512MB WB
ALi Aladdin IV+
[M1531]
[M1543] 		P54C
P55C
Lin Burst 		FPM
EDO
SDRAM 		8 16Mbit
64Mbit 		1GB Both N/A 50
60
66
75
83 		1/2
2/5 		1MB/11-bit
512MB WB
ALi Aladdin V
[M1541]
[M1543] 		P54C
P55C
Lin Burst 		FPM
EDO
SDRAM 		8 16Mbit
64Mbit 		1GB Both 1x
2x 		50
60
66
75
83
100 		1/2
2/5
1/3 		1MB/8-bit
ALi Aladdin V+
[M1541]
[M1543] 		P54C
P55C
Lin Burst 		FPM
EDO
SDRAM 		8 16Mbit
64Mbit
128Mbit
256Mbit 		4GB Both 1x
2x 		50
60
66
75
83
95
100 		1/2
2/5
1/3 		1MB/8-bit
ALi Aladdin V+ (rev. F)
[M1542]
[M1543] 		P54C
P55C
Lin Burst 		FPM
EDO
SDRAM 		8 16Mbit
64Mbit
128Mbit
256Mbit 		4GB Both 1x
2x 		50
60
66
75
83
95
100 		1/2
2/5
1/3 		1MB/12-bit
ALi Aladdin 7
[M1561]
[M1535D]
ArtX 128-bit SMA 		P54C
P55C
Lin Burst 		SDRAM PC100 8 ?Mbit 1GB ? N/A 66
100 		1/2
1/3
PCI 2.2 		?MB/?-bit
?MB WB
ALi Aladdin Pro
[ ? ]
[ ? ] 		P-II FPM
EDO
SDRAM 		? 16Mbit
64Mbit 		? Both 1x
2x 		60
66 		1/2 N/A
ALi Aladdin Pro II
[M1621]
[M1543] 		P-II Dual FPM
EDO
SDRAM 		8 16Mbit
64Mbit 		2GB F
2GB E
1GB S 		Both 1x
2x 		60
66
100 		1/2
1/3 		N/A
ALi Aladdin TNT2
[M1631]
[M1535D]
TNT2 AGP
UMA 		P-III
Celeron 		EDO
SDRAM PC133
VC SDRAM 		6 16Mbit
64Mbit
128Mbit
256Mbit 		1.5GB ECC 1x
2x 		66
100 		1/2
1/3
PCI 2.2 		N/A
ALi Aladdin Pro 4
[M1641B]
[M1535D] 		P-III
Celeron 		EDO
SDRAM PC133
VC SDRAM 		8 16Mbit
64Mbit
128Mbit
256Mbit 		1.5GB ECC 1x
2x
4x 		66
100 		1/2
1/3
PCI 2.2 		N/A
ALi ?
[M1642]
[M1535D]
? AGP 		P-III
Celeron 		SDRAM PC133
DDR SDRAM
VC SDRAM 		8 16Mbit
64Mbit
128Mbit
256Mbit 		?GB ECC 1x
2x
4x 		100
133 		1/3
1/4
PCI 2.2 		N/A
ALi Aladdin Pro 5
[M1651]
[M1535D+] 		P-III
Celeron 		SDRAM PC133
VC SDRAM
DDR PC2100
Asynch Mem 		6 16Mbit
64Mbit
128Mbit
256Mbit
512Mbit 		3GB ECC 1x
2x
4x 		100
133 		1/3
1/4
Asynch
PCI 2.2 		N/A
ALi Aladdin Pro 5T
[M1651T]
[M1535D+] 		P-III
P-III(T)
Celeron 		SDRAM PC133
VC SDRAM
DDR PC2100
Asynch Mem 		6 16Mbit
64Mbit
128Mbit
256Mbit
512Mbit 		3GB ECC 1x
2x
4x 		100
133 		1/3
1/4
Asynch
PCI 2.2 		N/A
ALi Aladdin P4
[M1671]
[M1535D+] 		P-4 SDRAM PC133
DDR PC2700
Asynch Mem 		6 64Mbit
128Mbit
256Mbit
512Mbit 		3GB No 1x
2x
4x 		100 (x4) 1/3
Asynch
PCI 2.2 		N/A
ALi Aladdin P4A
[M1671A]
[M1535D+] 		P-4 SDRAM PC133
DDR PC2700
Asynch Mem 		6 64Mbit
128Mbit
256Mbit
512Mbit 		3GB No 1x
2x
4x 		100 (x4)
133 (x4) 		1/3
1/4
Asynch
PCI 2.2 		N/A
ALi ?
[M1672]
[M1563]
? AGP 		P-4 SDRAM PC133
DDR PC2700 		? ?Mbit ?GB ? 1x
2x
4x
8x 		100 (x4) 1/3
PCI 2.2 		N/A
ALi ?
[M1681]
[M1563] 		P-4 SDRAM PC133
DDR PC2700 		? ?Mbit ?GB ? 1x
2x
4x
8x 		100 (x4)
133 (x4) 		1/3
1/4
PCI 2.2 		N/A
ALi ?
[M1741]
[ ? ] 		P-4 ? ? ?Mbit ?GB ? ? 100 (x4) 1/3
PCI 2.2 		N/A
ALi MAGiK 1
[M1647]
[M1535D+] 		K7
Duron 		SDRAM PC133
DDR PC2100
Asynch Mem 		6 16Mbit
64Mbit
128Mbit
256Mbit
512Mbit 		3GB ? 1x
2x
4x 		100 (x2)
133 (x2) 		1/3
1/4
Asynch
PCI 2.2 		N/A
ALi MAGiK 2
[M1648]
[ ? ]
? AGP 		K7
Duron 		SDRAM PC133
DDR PC2100 		? ?Mbit ?GB ? 1x
2x
4x 		100 (x2)
133 (x2) 		1/3
1/4
Asynch
PCI 2.2 		N/A
ALi Aladdin K7 III
[M1657]
[ ? ] 		K7
Duron 		SDRAM PC133
DDR PC2100 		? ?Mbit ?GB ? 1x
2x
4x 		100 (x2)
133 (x2) 		1/3
1/4
Asynch
PCI 2.2 		N/A
ALi ?
[M1667]
[M1563] 		K7
Duron 		SDRAM PC133
DDR PC2700 		? ?Mbit ?GB ? 1x
2x
4x
8x 		100 (x2)
133 (x2) 		? N/A
ALi ?
[M1687]
[M1563] 		Hammer Integrated into CPU -- -- -- -- 1x
2x
4x
8x 		200 (x2) ? N/A
ALi ?
[M1688]
[M1563]
? AGP 		Hammer Integrated into CPU -- -- -- -- 1x
2x
4x
8x 		200 (x2) ? N/A
AMD Chipsets Typical
CPUs 		DRAM
Types 		Mem
Rows 		DRAM
Density 		Max
Mem 		ECC/
Parity 		AGP Bus
Speeds 		PCI Clock
Dividers 		Max L2/
Tag bits
AMD 640
[640]
[645] 		P54C
P55C
Lin Burst 		FPM
EDO
SDRAM 		6 16Mbit
64Mbit 		768MB Both N/A 50
60
66 		1/2 2MB/10-bit
AMD 640AGP
[ ? ]
[VT82C586B] 		P54C
P55C
Lin Burst 		FPM
EDO
SDRAM 		6 16Mbit
64Mbit 		768MB Both 1x
2x 		66
100 		1/2
1/3 		?MB/?-bit
?MB WT
?MB WB
AMD 750
[751] (Irongate)
[756] (Viper) 		K7
Duron 		SDRAM PC100 8 16Mbit
64Mbit
128Mbit 		768MB ECC 1x
2x 		100 (x2) 1/3
PCI 2.2 		N/A
AMD 760
[761] (Irongate-4)
[766] 		K7
Duron 		DDR PC2100
Reg DDR 		8 64Mbit
128Mbit
256Mbit
512Mbit 		2GB
4GB Reg 		ECC 1x
2x
4x 		100 (x2)
133 (x2) 		1/3
1/4
PCI 2.2 		N/A
AMD 760MP
[762] (Irongate-4)
[766] 		Athlon MP Dual Reg DDR PC2100 8 64Mbit
128Mbit
256Mbit
512Mbit 		4GB ECC 1x
2x
4x 		100 (x2)
133 (x2) 		Pseudosynch
PCI 2.2 		N/A
AMD 760MPX
[762] (Irongate-4)
[768] 		Athlon MP Dual Reg DDR PC2100 8 64Mbit
128Mbit
256Mbit
512Mbit 		4GB ECC 1x
2x
4x 		100 (x2)
133 (x2) 		Pseudosynch
PCI-66/64
PCI 2.2 		N/A
AMD 770
[ ? ]
[ ? ] 		Athlon MP Dual DDR PC? 8 ?Mbit ?GB Yes 1x
2x
4x 		100 (x2)
133 (x2) 		Pseudosynch N/A
AMD 8000
(Golem)
[8111] (I/O)
[8131] (PCI)
[8151] (AGP) 		Hammer Integrated into CPU -- -- -- -- 1x
2x
4x
8x 		200 (x2) PCI-X
PCI 2.2 		N/A
AMD ???
(Lokar)
[ ? ]
[ ? ]
? AGP 		Hammer Integrated into CPU -- -- -- -- 1x
2x
4x
8x 		200 (x2) PCI 2.2 N/A
ATI Chipsets Typical
CPUs 		DRAM
Types 		Mem
Rows 		DRAM
Density 		Max
Mem 		ECC/
Parity 		AGP Bus
Speeds 		PCI Clock
Dividers 		Max L2/
Tag bits
ATI S1-370 TL
[S1-370 TL]
[M1535D]
ArtX 128-bit UMA 		P-III
Celeron 		SDRAM PC133 ? ?Mbit ?GB ? N/A 66
100
133 		1/2
1/3
1/4
PCI 2.2 		N/A
ATI ???
[ ? ]
[ ? ]
Radeon 7000 AGP 		P-III
Celeron 		DDR PC2100 ? ?Mbit ?GB ? 1x
2x
4x
8x 		66
100
133 		1/2
1/3
1/4
PCI 2.2 		N/A
ATI IGP 330
[IGP 330]
[IXP 200]
Radeon 7000 AGP 		P-4 DDR PC2100 ? ?Mbit ?GB ? ? 100 (x4) ? N/A
ATI IGP 340
[IGP 340]
[IXP 200]
Radeon 7000 AGP 		P-4 DDR PC2100 ? ?Mbit ?GB ? ? 100 (x4)
133 (x4) 		? N/A
ATI ???
[IGP ?]
[IXP ?]
Radeon 8500 AGP 		P-4 DDR PC2700 ? ?Mbit ?GB ? ? 100 (x4)
133 (x4) 		? N/A
ATI IGP 320
[IGP 320]
[IXP 200]
Radeon 7000 AGP 		K7
Duron 		SDRAM PC133
DDR PC2100 		? ?Mbit ?GB ? 1x
2x
4x
1.5v 		100 (x2)
133 (x2) 		? N/A
ATI ???
[IGP ?]
[IXP ?]
Radeon 8500 AGP 		K7
Duron 		SDRAM PC133
DDR PC2700 		? ?Mbit ?GB ? 1x
2x
4x
1.5v 		100 (x2)
133 (x2) 		? N/A
IBM Chipsets Typical
CPUs 		DRAM
Types 		Mem
Rows 		DRAM
Density 		Max
Mem 		ECC/
Parity 		AGP Bus
Speeds 		PCI Clock
Dividers 		Max L2/
Tag bits
IBM Summit
[ ? ]
[ ? ] 		P4 Xeon Quad DDR PC? ? ?Mbit ?GB Chipkill ? 100 (x4) 1/3
PCI-X 		N/A
IBM Summit
[ ? ]
[ ? ] 		P7 16-way DDR PC? ? ?Mbit ?GB Chipkill ? 100 (x4) 1/3
PCI-X 		N/A
Intel Chipsets Typical
CPUs 		DRAM
Types 		Mem
Rows 		DRAM
Density 		Max
Mem 		ECC/
Parity 		AGP Bus
Speeds 		PCI Clock
Dividers 		Max L2/
Tag bits
Intel 430LX {ISA}
(Mercury)
[82434LX] (PCMC)
[82433LX] (LBX)
[82378ZB] (SIO) 		P5 FPM 6 16Mbit 192MB Parity N/A 60
66 		1/2
PCI 2.0 		512KB/9-bit
256MB WT
128MB WB
Intel 430LX {EISA}
(Mercury)
[82434LX] (PCMC)
[82433LX] (LBX)
[82374EB/SB] (ESC)
[82375EB/SB] (PCEB) 		P5 FPM 6 16Mbit 192MB Parity N/A 60
66 		1/2
PCI 2.0 		512KB/9-bit
256MB WT
128MB WB
Intel 430NX {ISA}
(Neptune)
[82434NX] (PCMC)
[82433NX] (LBX)
[82378ZB] (SIO) 		P54C Uni FPM 8 ?Mbit 512MB Parity N/A 50
60
66 		1/2
PCI 2.0 		512KB/11-bit
512MB WB
Intel 430NX {ISA}
(Neptune)
[82434NX] (PCMC)
[82433NX] (LBX)
[82379AB] (SIO.A) 		P54C Dual FPM 8 ?Mbit 512MB Parity N/A 50
60
66 		1/2
PCI 2.0 		512KB/11-bit
512MB WB
Intel 430NX {EISA}
(Neptune)
[82434NX] (PCMC)
[82433NX] (LBX)
[82374EB/SB] (ESC)
[82375EB/SB] (PCEB) 		P54C Dual FPM 8 ?Mbit 512MB Parity N/A 50
60
66 		1/2
PCI 2.0 		512KB/11-bit
512MB WB
Intel 430FX
(Triton I)
[82437FX] (TSC)
[82438FX] (TDP)
[82371FB] (PIIX) 		P54C FPM
EDO 		? 16Mbit 128MB No N/A 60
66 		1/2
PCI 2.0 		512KB/8-bit
64MB WB
Intel 430HX
(Triton II)
[82439HX] (TXC)
[82371SB] (PIIX3) 		P54C Dual
P55C Dual 		FPM
EDO 		8 16Mbit
64Mbit 		512MB Both N/A 60
66 		1/2 512KB/11-bit
512MB WB
Intel 430VX
(Triton II/III)
[82437VX] (TVX)
[82438VX] (TDX)
[82371SB] (PIIX3)
UMA 		P54C
P55C 		FPM
EDO
SDRAM 		5 16Mbit 128MB No N/A 50
60
66 		1/2 512KB/8-bit
64MB WB
Intel 430TX
[82439TX] (MTXC)
[82371AB] (PIIX4) 		P54C
P55C 		FPM
EDO
SDRAM 		6 16Mbit
64Mbit 		256MB No N/A 50
60
66 		1/2 512KB/8-bit
64MB WB
Intel 450GX
(Orion)
[82454GX] (PB)
[82453GX] (DC)
[82452GX] (DP)
[82451GX] (MIC)
UMA 		P6 Quad FPM
2-way Interleave
4-way Interleave 		8 16Mbit
64Mbit 		4GB Both N/A 60
66 		1/2 N/A
Intel 450KX
(Mars)
[82454KX] (PB)
[82453KX] (DC)
[82452KX] (DP)
[82451KX] (MIC)
UMA 		P6 Dual FPM
2-way Interleave 		8 16Mbit
64Mbit 		1GB Both N/A 60
66 		1/2 N/A
Intel 440FX
(Natoma)
[82441FX] (PMC)
[82442FX] (DBX)
[82371SB] (PIIX3) 		P6 Dual
P6T Dual
P-II Dual 		FPM
EDO
BEDO 		8 16Mbit
64Mbit 		1GB Both N/A 50
60
66 		1/2 N/A
Intel 440LX
[82443LX] (PAC)
[82371AB] (PIIX4) 		P-II Dual
Celeron 		EDO
SDRAM 		8 16Mbit
64Mbit 		1GB E
512MB S 		Both 1x
2x 		66 1/2 N/A
Intel 440BX
[82443BX] (PAC)
[82371EB] (PIIX4E) 		P-II Dual
P-III Dual
Celeron 		EDO
SDRAM
Reg SDRAM
ESDRAM 		6 E
8 S
8 Reg
8 ESD 		16Mbit
64Mbit
128Mbit 		1GB Both 1x
2x 		66
100 		1/2
1/3
1/4 		N/A
Intel 440EX
[82443EX] (PAC)
[82371AB/EB] (PIIX4/4E) 		P-II
Celeron 		EDO
SDRAM 		4 16Mbit
64Mbit 		256MB No 1x
2x 		66 1/2 N/A
Intel 440ZX
[82443ZX] (PAC)
[82371EB] (PIIX4E) 		P-II
Celeron 		EDO
SDRAM 		4 16Mbit
64Mbit 		256MB No 1x
2x 		66
100 		1/2
1/3 		N/A
Intel 440ZX66
[82443ZX] (PAC)
[82371EB] (PIIX4E) 		Celeron EDO
SDRAM 		4 16Mbit
64Mbit 		256MB No 1x
2x 		66 1/2 N/A
Intel 810L
(Whitney)
[82810] (GMCH)
[82801AB] (ICH0)
[82802] (FWH)
i752 AGP (Portola) 		Celeron SDRAM PC100
Asynch Mem 		4 16Mbit
64Mbit
128Mbit 		512MB No 1x
2x 		66
100 		1/2
1/3
PCI 2.2 		N/A
Intel 810
(Whitney)
[82810] (GMCH)
[82801AA] (ICH)
[82802] (FWH)
i752 AGP (Portola) 		Celeron SDRAM PC100
Asynch Mem 		4 16Mbit
64Mbit
128Mbit 		512MB No 1x
2x 		66
100 		1/2
1/3
PCI 2.2 		N/A
Intel 810-DC100
(Whitney)
[82810-DC100] (GMCH)
[82801AA] (ICH)
[82802] (FWH)
i752 AGP (Portola) 		Celeron SDRAM PC100
Asynch Mem 		4 16Mbit
64Mbit
128Mbit 		512MB No 1x
2x 		66
100 		1/2
1/3
PCI 2.2 		N/A
Intel 810e-DC133
(Whitney)
[82810E-DC133] (GMCH)
[82801AA] (ICH)
[82802] (FWH)
i752 AGP (Portola) 		P-III
P-III(T)
Celeron 		SDRAM PC100
Asynch Mem 		4 16Mbit
64Mbit
128Mbit 		512MB No 1x
2x 		66
100
133 		1/2
1/3
1/4
PCI 2.2 		N/A
Intel 820
(Camino)
[82820] (MCH)
[82801AA] (ICH)
[82802] (FWH)
[82805AA] (MTH) 		P-III Dual
Celeron 		SDRAM PC100
Reg SDRAM
RDR PC800
Asynch SDRAM 		-- 64Mbit
128Mbit
256Mbit 		512MB S
1GB Reg
1GB RDR 		ECC 1x
2x
4x 		100
133 		1/3
1/4
PCI 2.2 		N/A
Intel 815
(Solano)
[82815] (GMCH)
[82801AA] (ICH)
[82802] (FWH)
i754 AGP (Coloma) 		P-III
P-III(T)
Celeron 		SDRAM PC133 6 64Mbit
128Mbit
256Mbit 		512MB No 1x
2x
4x 		66
100
133 		1/2
1/3
1/4
PCI 2.2 		N/A
Intel 815e
(Solano-2)
[82815] (GMCH)
[82801BA] (ICH2)
[82802] (FWH)
i754 AGP (Coloma) 		P-III
P-III(T)
Celeron 		SDRAM PC133 6 64Mbit
128Mbit
256Mbit 		512MB No 1x
2x
4x 		66
100
133 		1/2
1/3
1/4
PCI 2.2 		N/A
Intel 820e
(Camino-2)
[82820] (MCH)
[82801BA] (ICH2)
[82802] (FWH) 		P-III Dual
Celeron 		RDR PC800 -- 64Mbit
128Mbit
256Mbit 		1GB Yes 1x
2x
4x 		100
133 		1/3
1/4
PCI 2.2 		N/A
Intel 815p
(Solano-3)
[82815P] (MCH)
[82801AA] (ICH)
[82802] (FWH) 		P-III
P-III(T)
Celeron 		SDRAM PC133 6 64Mbit
128Mbit
256Mbit 		512MB No 1x
2x
4x 		66
100
133 		1/2
1/3
1/4
PCI 2.2 		N/A
Intel 815ep
(Solano-3)
[82815P] (MCH)
[82801BA] (ICH2)
[82802] (FWH) 		P-III
P-III(T)
Celeron 		SDRAM PC133 6 64Mbit
128Mbit
256Mbit 		512MB No 1x
2x
4x 		66
100
133 		1/2
1/3
1/4
PCI 2.2 		N/A
Intel 810e2-DC133
(Whitney)
[82810E-DC133] (GMCH)
[82801AA] (ICH2)
[82802] (FWH)
i752 AGP (Portola) 		P-III
P-III(T)
Celeron
         SDRAM PC100
Asynch Mem 		4 16Mbit
64Mbit
128Mbit 		512MB No 1x
2x 		66
100
133 		1/2
1/3
1/4
PCI 2.2 		N/A
Intel 815g
(Solano-3)
[82815G] (GMCH)
[82801AA] (ICH)
[82802] (FWH)
i754 AGP (Coloma) 		P-III
P-III(T)
Celeron 		SDRAM PC133 6 64Mbit
128Mbit
256Mbit 		512MB No 1x
2x
4x 		66
100
133 		1/2
1/3
1/4
PCI 2.2 		N/A
Intel 815eg
(Solano-3)
[82815G] (GMCH)
[82801BA] (ICH2)
[82802] (FWH)
i754 AGP (Coloma) 		P-III
P-III(T)
Celeron 		SDRAM PC133 6 64Mbit
128Mbit
256Mbit 		512MB No 1x
2x
4x 		66
100
133 		1/2
1/3
1/4
PCI 2.2 		N/A
Intel 830P
(Almador)
[82830P] (MCH)
[82801CA] (ICH3) 		P-III
P-III(T)
Celeron 		SDRAM PC133
         ? 64Mbit
128Mbit
256Mbit
512Mbit 		1GB No 1x
2x
4x 		133 1/4
PCI 2.2 		N/A
Intel 830G
(Almador)
[82830G] (GMCH)
[82801CA] (ICH3)
? AGP 		P-III
P-III(T)
Celeron 		SDRAM PC133
         ? 64Mbit
128Mbit
256Mbit
512Mbit 		1GB No 1x
2x
4x 		133 1/4
PCI 2.2 		N/A
Intel 440GX
[82443GX] (PAC)
[82371EB] (PIIX4E) 		P-II Dual
P-III Dual
P2/3 Xeon Dual 		SDRAM
Reg SDRAM 		8 16Mbit
64Mbit
128Mbit
256Mbit 		2GB Both 1x
2x 		100 1/3 N/A
Intel 450NX
[82454NX] (PXB)
[82453NX] (MUX)
[82452NX] (RCG)
[82451NX] (MIOC)
[82371EB] (PIIX4E) 		P2/3 Xeon Quad FPM
EDO
2-way Interleave
4-way Interleave 		8 16Mbit
64Mbit 		8GB Both N/A 90
100 		1/3 N/A
Intel 840
(Carmel)
[82840] (MCH)
[82801AA] (ICH)
[82802] (FWH)
[82803AA] (MRH-R)
[82804AA] (MRH-S)
[82806AA] (P64H) 		P-III Dual
P3 Xeon Quad 		SDRAM PC100
Reg SDRAM
RDR DC PC800
Asynch SDRAM 		-- 64Mbit
128Mbit
256Mbit 		4GB S
8GB Reg
4GB RDR 		ECC 1x
2x
4x 		100
133 		1/3
1/4 		N/A
Intel Profusion
[ ? ]
[ ? ] 		P3 Xeon Oct SDRAM PC100
2-way Interleave 		? ?Mbit 32GB ECC N/A 100 1/3
PCI-66/64 		N/A
Intel 850
(Tehama)
[82850] (MCH)
[82801BA] (ICH2)
[82802] (FWH) 		P-4 RDR DC PC800 -- 128Mbit
256Mbit 		2GB ECC 1x
2x
4x
1.5v 		100 (x4) 1/3
1/4
PCI 2.2 		N/A
Intel 845
(Brookdale)
[82845] (MCH)
[82801BA] (ICH2)
[82802AB] (FWH) 		P-4 SDRAM PC133 6 64Mbit
128Mbit
256Mbit
512Mbit 		3GB ECC 1x
2x
4x
1.5v 		100 (x4) 1/3
PCI 2.2 		N/A
Intel 855
(Tulloch)
[82855] (MCH)
[82801CA] (ICH3) 		P-4 RDR 4i 32 PC1066 -- 64Mbit
128Mbit
256Mbit 		2GB Yes 1x
2x
4x
8x 		100 (x4)
133 (x4) 		1/3
1/4
PCI 2.2 		N/A
Intel 845B
(Brookdale DDR)
[82845] (MCH)
[82801BA] (ICH2)
[82802AC] (FWH) 		P-4 DDR PC2100 4 64Mbit
128Mbit
256Mbit
512Mbit 		2GB ECC 1x
2x
4x
1.5v 		100 (x4) 1/3
PCI 2.2 		N/A
Intel 850E
(Tehama-E)
[82850E] (MCH)
[82801BA] (ICH2)
[82802] (FWH) 		P-4 RDR DC PC1066 -- 128Mbit
256Mbit 		2GB ECC 1x
2x
4x
1.5v 		100 (x4)
133 (x4) 		1/3
1/4
PCI 2.2 		N/A
Intel 845E
(Brookdale DDR)
[82845E] (MCH)
[82801DB] (ICH4) 		P-4 DDR PC2100 4 64Mbit
128Mbit
256Mbit
512Mbit 		2GB ECC 1x
2x
4x
1.5v 		100 (x4)
133 (x4) 		1/3
1/4
PCI 2.2 		N/A
Intel 845G
(Brookdale-G)
[82845G] (GMCH)
[82801DB] (ICH4)
Intel Extreme AGP 		P-4 SDRAM PC133
DDR PC2100 		4 64Mbit
128Mbit
256Mbit
512Mbit 		2GB no 1x
2x
4x
1.5v 		100 (x4)
133 (x4) 		1/3
1/4
PCI 2.2 		N/A
Intel 845GL
(Brookdale-GL)
[82845GL] (GMCH)
[82801DB] (ICH4)
Intel Extreme AGP 		P-4 SDRAM PC133
DDR PC2100 		4 64Mbit
128Mbit
256Mbit
512Mbit 		2GB no 1x
2x
4x 		100 (x4)
133 (x4) 		1/3
1/4
PCI 2.2 		N/A
Intel 845GE
(Brookdale-G)
[82845GE] (GMCH)
[82801DB] (ICH4)
Intel Extreme AGP 		P-4 DDR PC2700 4 64Mbit
128Mbit
256Mbit
512Mbit 		2GB no 1x
2x
4x
1.5v 		100 (x4)
133 (x4) 		1/3
1/4
PCI 2.2 		N/A
Intel 845GV
(Brookdale-GV)
[82845GE] (GMCH)
[82801DB] (ICH4)
Intel Extreme AGP 		P-4 DDR PC2100 4 64Mbit
128Mbit
256Mbit
512Mbit 		2GB no 1x
2x
4x 		100 (x4)
133 (x4) 		1/3
1/4
PCI 2.2 		N/A
Intel 845PE
(Brookdale DDR)
[82845PE] (MCH)
[82801DB] (ICH4) 		P-4 DDR PC2700 4 64Mbit
128Mbit
256Mbit
512Mbit 		2GB ECC 1x
2x
4x
1.5v 		100 (x4)
133 (x4) 		1/3
1/4
PCI 2.2 		N/A
Intel E7205
(Granite Bay)
[ ? ] (MCH)
[82801DB] (ICH4) 		P-4 DDR DC PC2700 ? ?Mbit ?GB ? 1x
2x
4x
8x 		133 (x4) ? N/A
Intel ?
(Springdale)
[ ? ] (MCH)
[ ? ] (ICH5) 		P-4 DDR-II+ PC4300 ? ?Mbit ?GB ? 1x
2x
4x
8x 		133 (x4) ? N/A
Intel ?
(Springdale-G)
[ ? ] (MCH)
[ ? ] (ICH5)
? AGP 		P-4 DDR-II+ PC4300 ? ?Mbit ?GB ? 1x
2x
4x
8x 		133 (x4) ? N/A
Intel 860
(Colusa)
[82860] (MCH)
[82801BA] (ICH2)
[82802] (FWH)
[82803AA] (MRH-R)
[82806AA] (P64H) 		P4 Xeon Dual RDR DC PC800 -- 256Mbit 4GB ECC 1x
2x
4x
1.5v 		100 (x4) 1/3
PCI 2.2 		N/A
Intel E7500
(Plumas)
[E7500] (MCH)
[82870P2] (P64H2)
[82801CA] (ICH3-S) 		P4 Xeon Dual DDR DC PC1600
Reg DDR 		? 64Mbit
128Mbit
256Mbit
512Mbit 		16GB ECC
Chipkill 		N/A 100 (x4) 1/3
PCI-X
PCI 2.2 		N/A
Intel 870
[ ? ]
[ ? ] 		P4 Xeon Quad DDR DC PC1600
2-way Interleave 		? 512Mbit
1Gbit 		?GB Parity
MCA 		1x
2x
4x 		100 (x4) 1/3
PCI-X 		N/A
Intel 860E
(Colusa-E)
[ ? ] (MCH)
[82801BA] (ICH2)
[82802] (FWH)
[82803AA] (MRH-R)
[82806AA] (P64H) 		P4 Xeon Dual RDR DC PC? -- 256Mbit 4GB ECC 1x
2x
4x
1.5v 		100 (x4)
133 (x4) 		1/3
1/4
PCI 2.2 		N/A
Intel E7501
(Plumas 533)
[E7501] (MCH)
[ ? ]
[82801CA] (ICH3-S) 		P4 Xeon Dual DDR DC PC2100
Reg DDR 		? 64Mbit
128Mbit
256Mbit
512Mbit 		16GB ECC
Chipkill 		N/A 100 (x4)
133 (x4) 		1/3
1/4
PCI-X
PCI 2.2 		N/A
Intel ?
(Plumas LE)
[ ? ] (MCH)
[ ? ]
[82801CA] (ICH3-S) 		P4 Xeon Dual DDR PC2100 ? ?Mbit ?GB ECC
Chipkill 		? 100 (x4)
133 (x4) 		1/3
1/4
? 		N/A
Intel E7507
(Placer)
[E7507] (MCH)
[ ? ] (ICH4) 		P-4 Xeon Dual DDR DC PC2700 ? ?Mbit ?GB ? 1x
2x
4x
8x 		100 (x4)
133 (x4) 		? N/A
Intel 460GX
[82461GX] (SAC)
[82462GX] (SDC)
[82463GX] (MAC)
[82464GX] (MDC)
[82465GX] (GXB)
[82466GX] (WXB)
[82467GX] (PXB)
[82468GX] (IFB)
[82802AC] (FWH)
[82094AA] (PID) 		P7 Quad SDRAM PC100
4-way Interleave 		? 16Mbit
64Mbit
128Mbit
256Mbit 		64GB ECC
Parity
MCA 		1x
2x
4x 		133 (x2) 1/4
PCI-66/64
PCI 2.2 		N/A
Intel E8870
[ ? ] (SNC)
[ ? ] (MRH-D)
[ ? ] (SIOH)
[ ? ] (ICH)
[ ? ] (P64H2)
[ ? ] (VXB)
[ ? ] (FWH) 		P7 Quad DDR QC PC1600
4-way Interleave 		? 512Mbit
1Gbit 		128GB ECC
Parity
MCA 		1x
2x
4x 		100 (x4) 1/3
PCI-X 		N/A
Micron Chipsets Typical
CPUs 		DRAM
Types 		Mem
Rows 		DRAM
Density 		Max
Mem 		ECC/
Parity 		AGP Bus
Speeds 		PCI Clock
Dividers 		Max L2/
Tag bits
Micron Samurai
[ ? ]
[VT82C586B] 		PII Dual FPM
EDO
SDRAM 		8 16Mbit
64Mbit 		1GB Yes N/A 66 PCI-66/64 N/A
Micron Samurai DDR
(Copperhead)
[ ? ]
[ ? ] (Coppertail) 		PIII Dual
PIII(T) Dual
P-III-S Dual 		DDR PC?
Reg DDR 		? 512Mbit 4GB D
8GB Reg 		Yes 1x
2x
4x 		100
133 		PCI-X
PCI 2.2 		N/A
Micron Samurai K7
[ ? ]
[ ? ] 		K7 Dual DDR SDRAM ? ?Mbit ?GB Yes 1x
2x
4x 		100 (x2) PCI-66/64 N/A
Micron Mamba
[4400e]
[ ? ] 		K7 DDR SDRAM ? ?Mbit ?GB Yes 1x
2x
4x 		133 (x2) PCI-X 8MB L3/?-bit
Micron Shogun
[ ? ]
[ ? ]
Rendition AGP 		K7 DDR SDRAM ? ?Mbit ?GB Yes 1x
2x
4x 		133 (x2) PCI-X 8MB L3/?-bit
Micron Scimitar
[ ? ]
[ ? ]
Rendition AGP 		K7 DDR SDRAM ? ?Mbit ?GB Yes 1x
2x
4x 		133 (x2) ? 8MB L3/?-bit
NVidia Chipsets Typical
CPUs 		DRAM
Types 		Mem
Rows 		DRAM
Density 		Max
Mem 		ECC/
Parity 		AGP Bus
Speeds 		PCI Clock
Dividers 		Max L2/
Tag bits
NVidia nForce220
(Crush11)
[IGP-64]
[MCP]
GeForce2 MX 		K7
Duron 		SDRAM PC133
DDR PC2100
Asynch Mem 		6 64Mbit
128Mbit
256Mbit
512Mbit 		1.5GB No 1x
2x
4x 		100 (x2)
133 (x2) 		Asynch N/A
NVidia nForce220D
(Crush11)
[IGP-64]
[MCP-D]
GeForce2 MX 		K7
Duron 		SDRAM PC133
DDR PC2100
Asynch Mem 		6 64Mbit
128Mbit
256Mbit
512Mbit 		1.5GB No 1x
2x
4x 		100 (x2)
133 (x2) 		Asynch N/A
NVidia nForce420
(Crush12)
[IGP-128]
[MCP]
GeForce2 MX 		K7
Duron 		SDRAM DC PC133
DDR DC PC2100
Asynch Mem 		6 64Mbit
128Mbit
256Mbit
512Mbit 		1.5GB No 1x
2x
4x 		100 (x2)
133 (x2) 		Asynch N/A
NVidia nForce420D
(Crush12)
[IGP-128]
[MCP-D]
GeForce2 MX 		K7
Duron 		SDRAM DC PC133
DDR DC PC2100
Asynch Mem 		6 64Mbit
128Mbit
256Mbit
512Mbit 		1.5GB No 1x
2x
4x 		100 (x2)
133 (x2) 		Asynch N/A
NVidia nForce415D
(Crush12)
[IGP-128]
[MCP-D] 		K7
Duron 		SDRAM DC PC133
DDR DC PC2100
Asynch Mem 		6 64Mbit
128Mbit
256Mbit
512Mbit 		1.5GB No 1x
2x
4x 		100 (x2)
133 (x2) 		Asynch N/A
NVidia nForce620D
(Crush?)
[IGP-128/333]
[MCP-D]
GeForce2 MX 		K7
Duron 		SDRAM DC PC133
DDR DC PC2700
Asynch Mem 		6 64Mbit
128Mbit
256Mbit
512Mbit 		1.5GB No 1x
2x
4x 		100 (x2)
133 (x2) 		Asynch N/A
NVidia nForce615D
(Crush?)
[IGP-128/333]
[MCP-D] 		K7
Duron 		SDRAM DC PC133
DDR DC PC2700
Asynch Mem 		6 64Mbit
128Mbit
256Mbit
512Mbit 		1.5GB No 1x
2x
4x 		100 (x2)
133 (x2) 		Asynch N/A
NVidia nForce2 SPP
(Crush18)
[ ? ]
[MCP-T] 		K7
Duron 		DDR PC3200 6 ?Mbit 3GB ? 1x
2x
4x
8x 		100 (x2)
133 (x2) 		Asynch N/A
NVidia nForce2 IGP
(Crush18)
[ ? ]
[MCP-T]
GeForce4 MX 		K7
Duron 		DDR DC PC3200 6 ?Mbit 3GB ? 1x
2x
4x
8x 		100 (x2)
133 (x2) 		Asynch N/A
NVidia CK8
(?)
[ ? ]
[ ? ]
GeForce4 MX 		Hammer Integrated into CPU -- -- -- -- 1x
2x
4x 		200 (x2) ? N/A
OPTi Chipsets Typical
CPUs 		DRAM
Types 		Mem
Rows 		DRAM
Density 		Max
Mem 		ECC/
Parity 		AGP Bus
Speeds 		PCI Clock
Dividers 		Max L2/
Tag bits
OPTi Python
[82C546]
[82C547]
[82C606]
[82C822] 		P5
P54C 		FPM 4 16Mbit 128MB ? N/A 50
60
66 		1/1
1/2
2/3
VLB/PCI 		512KB/?-bit
?MB WT
?MB WB
OPTi Cobra
[82C596]
[82C597]
[82C606]
[82C822] 		P5
P54C 		FPM 4 16Mbit 128MB ? N/A 50
60
66 		33MHz
VLB/PCI 		512KB/?-bit
?MB WT
?MB WB
OPTi Viper
[82C556]
[82C557]
[82C558] 		P54C
P55C
Lin Burst 		FPM
EDO
SDRAM 		6 16Mbit
64Mbit 		512MB Parity N/A 50
60
66 		1/2 512KB/8-bit
128MB WT
128MB WB
OPTi Viper-N
[82C556]
[82C557]
[82C558N] 		P54C
P55C
Lin Burst 		FPM
EDO 		6 16Mbit
64Mbit 		512MB Parity N/A 50
60
66 		1/2 512KB/8-bit
128MB WT
128MB WB
OPTi Viper-N+
[82C556M]
[82C557M]
[82C558E] 		P54C
P55C
Lin Burst 		FPM
EDO 		6 16Mbit
64Mbit 		512MB Parity N/A 50
60
66 		1/2 512KB/8-bit
128MB WT
128MB WB
OPTi ViperMax
[82C566]
[82C567]
[82C568]
UMA 		P54C
P55C
Lin Burst 		FPM
EDO
BEDO
SDRAM 		6 F
6 E
4 B
4 S 		16Mbit
64Mbit 		512MB Parity N/A 50
60
66 		1/2
Asynch 		512KB/8-bit
128MB WT
128MB WB
OPTi Viper Xpress
[82C576]
[82C577]
[82C578] 		P54C
P55C
Lin Burst 		FPM
EDO
SDRAM 		6 16Mbit
64Mbit 		512MB Parity N/A 40
50
60
66 		1/2 512KB/?-bit
?MB WT
?MB WB
OPTi Vendetta
[82C750] 		P54C
Lin Burst 		FPM
EDO
SDRAM 		8 16Mbit
64Mbit 		512MB Both N/A 50
60
66 		1/2 512KB/?-bit
?MB WT
?MB WB
OPTi Discovery
[82C650]
[82C651] 		P6
P6T 		? ? ?Mbit ?MB ? N/A ? ? N/A
ServerWorks Chipsets Typical
CPUs 		DRAM
Types 		Mem
Rows 		DRAM
Density 		Max
Mem 		ECC/
Parity 		AGP Bus
Speeds 		PCI Clock
Dividers 		Max L2/
Tag bits
SW Serverset III LE
[NB6635] (CNB30LE)
[NB6566] (CIOB20) 		P-III Dual
P-III-S Dual
P3 Xeon Dual 		SDRAM PC133
Reg SDRAM 		? ?Mbit 4GB ECC N/A 100
133 		1/3
1/4
PCI-66/64 		N/A
SW Serverset III HE
[NB6536] (CNB20HE)
[NB6566] (CIOB20)
[NB6555IO] (OSB4)
[NB6535] (MADP) 		P-III Dual
P-III-S Dual
P3 Xeon Quad 		SDRAM QC PC133
4-way Interleave 		? ?Mbit 16GB ECC N/A 100
133 		1/3
1/4
PCI-66/64 		N/A
SW Serverset III WS
[NB6536] (CNB20HE)
[NB6566] (CIOB20)
[NB6555] (AOB2)
[NB6525] (MADP) 		P-III Dual
P-III-S Dual
P3 Xeon Dual 		SDRAM DC PC133
2-way Interleave 		? ?Mbit 8GB ECC 4x 100
133 		1/3
1/4
PCI-66/64 		N/A
SW Serverset III HESL
[NB-HESL]
[CIOB2]
[CSB5] 		P-III Dual
P-III-S Dual
P3 Xeon Dual 		SDRAM DC PC133
2-way Interleave 		? ?Mbit 12GB ECC
Chipkill 		N/A 100
133 		1/3
1/4
PCI-66/64 		N/A
SW Serverset IV
[ ? ]
[ ? ] 		P4 Xeon Dual DDR SDRAM ? ?Mbit ?GB Yes ? 100 (x4) ? N/A
SW Grand Champion LE
[CMIC LE]
[CIOB-X2]
[CSB5] 		P4 Xeon Dual DDR DC PC1600
2-way Interleave 		? ?Mbit 16GB ECC
Chipkill 		N/A 100 (x4) PCI-X
PCI 2.2 		N/A
SW Grand Champion WS
[CMIC WS]
[CIOB-X]
[CSB5]
[CIOB-G] 		P4 Xeon Dual DDR DC PC1600
2-way Interleave 		? ?Mbit 16GB ECC
Chipkill 		1x
2x
4x 		100 (x4) PCI-X
PCI 2.2 		N/A
SW Grand Champion HE
[CMIC HE]
[CIOB-X]
[CSB5] 		P4 Xeon Quad DDR QC PC1600
4-way Interleave 		? ?Mbit 64GB ECC
Chipkill 		N/A 100 (x4) PCI-X
PCI 2.2 		N/A
SW Grand Champion SL
[CMIC SL]
[CIOB-X2]
[CSB6] 		P4 Xeon Dual DDR PC1600 ? ?Mbit 8GB ECC
Chipkill 		N/A 100 (x4) PCI-X
PCI 2.2 		N/A
SiS Chipsets Typical
CPUs 		DRAM
Types 		Mem
Rows 		DRAM
Density 		Max
Mem 		ECC/
Parity 		AGP Bus
Speeds> 		PCI Clock
Dividers 		Max L2/
Tag bits
SiS 501/02/03
[501]
[502]
[503] 		P54C FPM
EDO 		4 16Mbit 128MB No N/A 50
60
66 		1/2
2/3
14MHz 		512MB/8-bit
128MB WT
64MB WB
SiS 5511/12/13
[5511]
[5512]
[5513] 		P54C Dual FPM
EDO
2-way Interleave
Single SIMM 		4 16Mbit 512MB Parity N/A 50
60
66 		1/2
Asynch 		1MB/8-bit
256MB WT
128MB WB
SiS 5596
(Genesis)
[5596]
[5513]
UMA 		P54C FPM
EDO 		4 16Mbit 512MB No N/A 50
60
66 		1/2
Asynch 		1MB/8-bit
256MB WT
128MB WB
SiS 5571
(Trinity)
[5571] 		P54C
P55C
Lin Burst 		FPM
EDO
SDRAM
Single SIMM 		6 F
6 E
4 S 		16MBit 384MB F
384MB E
256MB S 		No N/A 50
60
66
75 		1/2
Asynch 		512KB/8-bit
128MB WT
128MB WB
SiS 5597/98
(Jedi)
[5597]
UMA 		P54C
P55C
Lin Burst 		FPM
EDO
SDRAM
Single SIMM 		6 16Mbit
64Mbit 		384MB No N/A 50
55
60
66
75 		1/2
Asynch 		512KB/8-bit
128MB WB
SiS 5581/82
[5581/82] 		P54C
P55C
Lin Burst 		FPM
EDO
SDRAM
Single SIMM 		6 16Mbit
64Mbit 		384MB No N/A 50
55
60
66
75 		1/2
Asynch 		512KB/8-bit
128MB WB
SiS 5591/92
(David)
[5591/92]
[5595] 		P54C
P55C
Lin Burst 		FPM
EDO
SDRAM 		6 16Mbit
64Mbit 		768MB No 1x
2x 		50
60
66
75
83
100 		1/2
Asynch 		1MB/8-bit
256MB WB
SiS 530
(Sinbad)
[530]
[5595]
SiS6326 AGP
UMA 		P54C
P55C
Lin Burst 		SDRAM
Mem=3/4 Bus
Mem=4/5 Bus
Mem=5/4 Bus 		6 16Mbit
64Mbit 		1.5GB No 1x
2x 		66
75
83
95
100 		Asynch
PCI 2.2 		2MB/8-bit
256MB WB
SiS 540
[540]
[950]
[301]
SiS300 AGP 		P54C
P55C 		SDRAM PC133
VC SDRAM 		6 16Mbit
64Mbit 		1.5GB ECC 1x
2x
4x 		66
83
90
95
100 		Asynch
PCI 2.2 		2MB/?-bit
?MB WB
SiS 5600
[5600]
[5595] 		P-II Dual FPM
EDO
SDRAM 		6 16Mbit
64Mbit 		1.5GB ECC 1x
2x 		60
66
100 		1/2
1/3 		N/A
SiS 600
[600]
[5595] 		P-II Dual FPM
EDO
SDRAM 		6 16Mbit
64Mbit 		1.5GB ECC 1x
2x 		60
66
100 		1/2
1/3 		N/A
SiS 620
[620]
[5595]
SiS6326 AGP
UMA 		P-II SDRAM
Mem=3/4 Bus
Mem=4/5 Bus
Mem=5/4 Bus
Mem=3/2 Bus 		6 16Mbit
64Mbit
128Mbit
256Mbit 		1.5GB No 1x
2x 		60
66
75
83
100 		Asynch
PCI 2.2 		N/A
SiS 621
[621]
[5595]
SiS6326 AGP 		P-II SDRAM ? ?Mbit ?GB ? 1x
2x
4x 		66
100 		Asynch
PCI 2.2 		N/A
SiS 630
[630]
SiS301 AGP
UMA 		P-III
Celeron 		SDRAM PC133
VC SDRAM
Asynch Mem 		6 16Mbit
64Mbit
128Mbit
256Mbit
512Mbit 		3GB No 1x
2x
4x 		66
100
133 		Asynch
PCI 2.2 		N/A
SiS 630S
[630S]
SiS301 AGP 		P-III
Celeron 		SDRAM PC133
VC SDRAM
Asynch Mem 		6 16Mbit
64Mbit
128Mbit
256Mbit
512Mbit 		3GB No 1x
2x
4x 		66
100
133 		Asynch
PCI 2.2 		N/A
SiS 630E
[630E]
SiS301 AGP 		P-III
Celeron 		SDRAM PC133
Asynch Mem 		6 16Mbit
64Mbit
128Mbit
256Mbit
512Mbit 		3GB No 1x
2x
4x 		66
100
133 		Asynch
PCI 2.2 		N/A
SiS 633
[633] 		P-III SDRAM PC133
Asynch Mem 		6 16Mbit
64Mbit
128Mbit
256Mbit 		1.5GB No 1x
2x
4x 		66
100
133 		PCI 2.2 N/A
SiS 635
[635] 		P-III SDRAM PC133
DDR PC2100
Asynch Mem 		6 16Mbit
64Mbit
128Mbit
256Mbit 		1.5GB No 1x
2x
4x 		66
100
133 		PCI 2.2 N/A
SiS 635T
[635T] 		P-III
P-III(T) 		SDRAM PC133
DDR PC2100
Asynch Mem 		6 16Mbit
64Mbit
128Mbit
256Mbit 		1.5GB No 1x
2x
4x 		66
100
133 		PCI 2.2 N/A
SiS 630ST
[630ST]
SiS301 AGP 		P-III
P-III(T)
Celeron 		SDRAM PC133
VC SDRAM
Asynch Mem 		6 16Mbit
64Mbit
128Mbit
256Mbit
512Mbit 		3GB No 1x
2x
4x 		66
100
133 		Asynch
PCI 2.2 		N/A
SiS 633T
[633T] 		P-III
P-III(T) 		SDRAM PC133
Asynch Mem 		6 16Mbit
64Mbit
128Mbit
256Mbit 		1.5GB No 1x
2x
4x 		66
100
133 		PCI 2.2 N/A
SiS 640T
[640T]
[961]
SiS 315 AGP 		P-III
P-III(T) 		SDRAM PC133
DDR SDRAM 		? ?Mbit 1.5GB ? 1x
2x
4x 		66
100
133 		PCI 2.2 N/A
SiS 645
[645]
[961] 		P-4 SDRAM PC133
DDR PC2700
Mem=4/3 Bus
Mem=5/3 Bus 		6 16Mbit
64Mbit
128Mbit
256Mbit
512Mbit 		3GB No 1x
2x
4x 		100 (x4) 1/3
PCI 2.2 		N/A
SiS 650
[650]
[961]
SiS 315 AGP 		P-4 SDRAM PC133
DDR PC2700
Mem=4/3 Bus
Mem=5/3 Bus 		6 16Mbit
64Mbit
128Mbit
256Mbit
512Mbit 		3GB No 1x
2x
4x 		100 (x4) 1/3
PCI 2.2 		N/A
SiS 645DX
[645DX]
[961B] 		P-4 SDRAM PC133
DDR PC2700
Mem=4/3 Bus
Mem=5/3 Bus 		6 16Mbit
64Mbit
128Mbit
256Mbit
512Mbit 		3GB No 1x
2x
4x 		100 (x4)
133 (x4) 		1/3
1/4
PCI 2.2 		N/A
SiS 650GX
[650GX]
[961]
SiS 315 AGP 		P-4 SDRAM PC133
DDR PC2700
Mem=4/3 Bus
Mem=5/3 Bus 		6 16Mbit
64Mbit
128Mbit
256Mbit
512Mbit 		3GB No 1x
2x
4x 		100 (x4) 1/3
PCI 2.2 		N/A
SiS 651
[651]
[962]
? AGP 		P-4 SDRAM PC133
DDR PC2700
Mem=4/3 Bus
Mem=5/3 Bus 		6 16Mbit
64Mbit
128Mbit
256Mbit
512Mbit 		3GB No 1x
2x
4x 		100 (x4)
133 (x4) 		1/3
1/4
PCI 2.2 		N/A
SiS 648
[648]
[963] 		P-4 SDRAM PC133
DDR PC2700 		6 16Mbit
64Mbit
128Mbit
256Mbit
512Mbit 		3GB No 1x
2x
4x
8x 		100 (x4)
133 (x4) 		1/3
1/4
PCI 2.2 		N/A
SiS R658
[R658]
[963] 		P-4 RDR 32 DC PC1066 -- ?Mbit 4GB ECC 1x
2x
4x
8x 		100 (x4)
133 (x4) 		1/3
1/4 		N/A
SiS 648DX
[648DX]
[963] 		P-4 SDRAM PC133
DDR PC3200 		6 16Mbit
64Mbit
128Mbit
256Mbit
512Mbit 		3GB No 1x
2x
4x
8x 		100 (x4)
133 (x4) 		1/3
1/4
PCI 2.2 		N/A
SiS 648FX
[648FX]
[963] 		P-4 SDRAM PC133
DDR PC3200 		6 16Mbit
64Mbit
128Mbit
256Mbit
512Mbit 		3GB No 1x
2x
4x
8x 		100 (x4)
133 (x4)
166 (x4) 		1/3
1/4
1/5
PCI 2.2 		N/A
SiS 655
[655]
[962] 		P-4 SDRAM PC133
DDR DC PC2700
Mem=4/3 Bus
Mem=5/3 Bus 		6 16Mbit
64Mbit
128Mbit
256Mbit
512Mbit 		3GB No 1x
2x
4x
8x 		100 (x4)
133 (x4) 		1/3
1/4
PCI 2.2 		N/A
SiS 660
[660]
[963]
? AGP 		P-4 DDR DC PC2700 6 16Mbit
64Mbit
128Mbit
256Mbit
512Mbit 		3GB No 1x
2x
4x
8x 		100 (x4)
133 (x4) 		1/3
1/4 		N/A
SiS 649
[649]
[964] 		P-4 DDR-II ? ? ?Mbit ?GB ? 1x
2x
4x
8x 		100 (x4)
133 (x4) 		PCI ? N/A
SiS 730S
[730S]
SiS301 AGP 		K7
Duron 		SDRAM PC133
Asynch Mem 		6 16Mbit
64Mbit
128Mbit
256Mbit 		1.5GB No 1x
2x
4x 		100 (x2) PCI 2.2 N/A
SiS 733
[733] 		K7
Duron 		SDRAM PC133 6 16Mbit
64Mbit
128Mbit
256Mbit 		1.5GB No 1x
2x
4x 		100 (x2)
133 (x2) 		PCI 2.2 N/A
SiS 735
[735] 		K7
Duron 		SDRAM PC133
DDR PC2100
Mem=4/3 Bus 		6 16Mbit
64Mbit
128Mbit
256Mbit 		1.5GB No 1x
2x
4x 		100 (x2)
133 (x2) 		PCI 2.2 N/A
SiS 745
[745] 		K7
Duron 		SDRAM PC133
DDR PC2700
Mem=4/3 Bus 		6 16Mbit
64Mbit
128Mbit
256Mbit
512Mbit 		3GB No 1x
2x
4x 		100 (x2)
133 (x2) 		? N/A
SiS 746
[746]
[963] 		K7
Duron 		SDRAM PC133
DDR PC2700 		6 16Mbit
64Mbit
128Mbit
256Mbit 		?GB No 1x
2x
4x
8x 		100 (x2)
133 (x2) 		1/3
1/4
PCI 2.2 		N/A
SiS 746DX
[746DX]
[963] 		K7
Duron 		SDRAM PC133
DDR PC3200 		6 16Mbit
64Mbit
128Mbit
256Mbit 		?GB No 1x
2x
4x
8x 		100 (x2)
133 (x2) 		1/3
1/4
PCI 2.2 		N/A
SiS 746FX
[746FX]
[963] 		K7
Duron 		SDRAM PC133
DDR PC3200 		6 16Mbit
64Mbit
128Mbit
256Mbit 		?GB No 1x
2x
4x
8x 		100 (x2)
133 (x2)
166 (x2) 		1/3
1/4
1/5
PCI 2.2 		N/A
SiS 740
[740]
[961]
SiS 315 AGP 		K7
Duron 		SDRAM PC133
DDR PC2100 		6 16Mbit
64Mbit
128Mbit
256Mbit 		1.5GB No 1x
2x
4x 		100 (x2)
133 (x2) 		1/3
1/4
PCI 2.2 		N/A
SiS 750
[750]
[961]
SiS 330 AGP 		K7
Duron 		SDRAM PC133
DDR PC? 		? ?Mbit 1.5GB ? 1x
2x
4x 		100 (x2)
133 (x2) 		1/3
1/4
PCI 2.2 		N/A
SiS 755
[755]
[963] 		Hammer Integrated into CPU -- -- -- -- 1x
2x
4x
8x 		200 (x2) PCI 2.2 N/A
SiS 760
[760]
[963]
? AGP 		Hammer Integrated into CPU -- -- -- -- 1x
2x
4x
8x 		200 (x2) PCI 2.2 N/A
VIA Chipsets Typical
CPUs 		DRAM
Types 		Mem
Rows 		DRAM
Density 		Max
Mem 		ECC/
Parity 		AGP Bus
Speeds 		PCI Clock
Dividers 		Max L2/
Tag bits
VIA VP
[VT82C585VP]
[VT82C586]
[VT82C587VP]
UMA 		P54C
Lin Burst 		FPM
EDO
BEDO
SDRAM 		6 16Mbit 512MB No N/A 50
60
66 		1/2 2MB/10-bit
~2GB WT
~2GB WB
VIA VP2
[VT82C595]
[VT82C586A] 		P54C
P55C
Lin Burst 		FPM
EDO
SDRAM 		6 16Mbit
64Mbit 		512MB ECC N/A 50
60
66 		1/2 2MB/10-bit
~2GB WT
~2GB WB
VIA VP2/97
[VT82C595]
[VT82C586B] 		P54C
P55C
Lin Burst 		FPM
EDO
SDRAM 		6 16Mbit
64Mbit 		512MB ECC N/A 50
60
66 		1/2 2MB/10-bit
~2GB WT
~2GB WB
VIA VPX
[VT82C585]
[VT82C586A] 		P54C
P55C
Lin Burst 		FPM
EDO
SDRAM 		6 16Mbit
64Mbit 		512MB No N/A 66
75 		1/2
Asynch 		2MB/10-bit
~2GB WT
~2GB WB
VIA VPX/97
[VT82C585]
[VT82C586B] 		P54C
P55C
Lin Burst 		FPM
EDO
SDRAM 		6 16Mbit
64Mbit 		512MB No N/A 66
75 		1/2
Asynch 		2MB/10-bit
~2GB WT
~2GB WB
VIA VP3
[VT82C597/597AT]
[VT82C586B] 		P54C
P55C
Lin Burst 		FPM
EDO
SDRAM
DDR SDRAM 		6 16Mbit
64Mbit 		1GB Both 1x
2x 		50
60
66 		1/2 2MB/10-bit
~2GB WT
~2GB WB
VIA MVP3
[VT82C598/598AT]
[VT82C586B] 		P54C
P55C
Lin Burst 		FPM
EDO
SDRAM
Mem=AGP 		6 16Mbit
64Mbit 		1GB Both 1x
2x 		66
75
83
100 		1/2
2/5
1/3 		2MB/8-bit
510MB WT
254MB WB
VIA MVP4
[VT8501]
[VT82C686A]
Trident Blade3D AGP 		P54C
P55C
Lin Burst 		FPM
EDO
SDRAM
VC SDRAM
Mem=AGP 		6 16Mbit
64Mbit 		768MB Both 1x
2x 		66
75
83
100		1/2
2/5
1/3 		2MB/8-bit
510MB WT
254MB WB
VIA Apollo
[VT82C685]
[VT82C586]
[VT82C687] 		P6 Dual
P6T Dual 		FPM
EDO 		8 16Mbit
64Mbit 		1GB ? N/A 66 1/2 N/A
VIA Apollo Pro
[VT82C691]
[VT82C586B] 		P6
P6T
P-II 		FPM
EDO
SDRAM
DDR SDRAM
ESDRAM
VC SDRAM
Mem=AGP 		8 16Mbit
64Mbit 		1GB Both 1x
2x 		66
100 		1/2
2/5
1/3 		N/A
VIA Apollo Pro+
[VT82C693]
[VT82C596A] 		P6
P6T
P-II 		FPM
EDO
SDRAM
VC SDRAM
Mem=AGP 		8 16Mbit
64Mbit
128Mbit 		1GB Both 1x
2x 		66
100 		1/2
2/5
1/3 		N/A
VIA Apollo Pro133
[VT82C693A]
[VT82C596B] 		P-III
Celeron 		FPM
EDO
SDRAM PC133
VC SDRAM
Mem=AGP
Mem=2/3 Bus
Mem=3/4 Bus
Mem=4/3 Bus
Mem=3/2 Bus 		6 16Mbit
64Mbit
128Mbit
256Mbit 		1.5GB Both 1x
2x 		66
100
133 		1/2
2/5
1/3
1/4
PCI 2.2 		N/A
VIA Apollo Pro133A
[VT82C694X]
[VT82C596B] 		P-III Dual
Celeron 		FPM
EDO
SDRAM PC133
Reg SDRAM
ESDRAM
VC SDRAM
Mem=AGP
Mem=2/3 Bus
Mem=3/4 Bus
Mem=4/3 Bus
Mem=3/2 Bus 		8 16Mbit
64Mbit
128Mbit
256Mbit 		2GB
4GB Reg 		Both 1x
2x
4x 		66
100
133 		1/2
2/5
1/3
1/4
PCI 2.2 		N/A
VIA PLE133 (PM601)
[VT8601]
[VT8231]
Trident Blade3D AGP 		P-III
Celeron 		FPM
EDO
SDRAM PC133
VC SDRAM
Mem=2/3 Bus
Mem=3/4 Bus
Mem=4/3 Bus
Mem=3/2 Bus 		6 16Mbit
64Mbit
128Mbit
256Mbit 		1.5GB No 1x
2x 		66
100
133 		1/2
1/3
1/4
PCI 2.2 		N/A
VIA PL-133
[VT8604]
[VT8231]
Savage4 AGP 		P-III
Celeron 		FPM
EDO
SDRAM PC133
ESDRAM
VC SDRAM
Mem=AGP
Mem=2/3 Bus
Mem=3/4 Bus
Mem=4/3 Bus
Mem=3/2 Bus 		6 16Mbit
64Mbit
128Mbit
256Mbit 		1.5GB Both 1x
2x
4x 		66
100
133 		1/2
1/3
1/4
PCI 2.2 		N/A
VIA PM-133
(VS1-P6)
[VT8605]
[VT8231]
Savage4 AGP 		P-III
Celeron 		FPM
EDO
SDRAM PC133
ESDRAM
VC SDRAM
Mem=AGP
Mem=2/3 Bus
Mem=3/4 Bus
Mem=4/3 Bus
Mem=3/2 Bus 		6 16Mbit
64Mbit
128Mbit
256Mbit 		1.5GB Both 1x
2x
4x 		66
100
133 		1/2
1/3
1/4
PCI 2.2 		N/A
VIA Apollo Pro266
[VT8633]
[VT8233] 		P-III
Celeron 		SDRAM PC133
Reg SDRAM
VC SDRAM
DDR PC2100 		8 128Mbit
256Mbit
512Mbit 		2GB ECC 1x
2x
4x 		66
100
133 		1/2
1/3
1/4
PCI 2.2 		N/A
VIA PLE133T
[VT8602]
[VT8231]
Trident Blade3D AGP 		P-III
P-III(T)
Celeron 		FPM
EDO
SDRAM PC133
VC SDRAM
Mem=2/3 Bus
Mem=3/4 Bus
Mem=4/3 Bus
Mem=3/2 Bus 		6 16Mbit
64Mbit
128Mbit
256Mbit 		1.5GB No 1x
2x 		66
100
133 		1/2
1/3
1/4
PCI 2.2 		N/A
VIA PL-133T
[VT8604T]
[VT8231]
Savage4 AGP 		P-III
P-III(T)
Celeron 		FPM
EDO
SDRAM PC133
ESDRAM
VC SDRAM
Mem=AGP
Mem=2/3 Bus
Mem=3/4 Bus
Mem=4/3 Bus
Mem=3/2 Bus 		6 16Mbit
64Mbit
128Mbit
256Mbit 		1.5GB Both 1x
2x
4x 		66
100
133 		1/2
1/3
1/4
PCI 2.2 		N/A
VIA Apollo Pro133T
[VT82C694T]
[VT82C596B] 		P-III
P-III(T)
Celeron 		FPM
EDO
SDRAM PC133
Reg SDRAM
ESDRAM
VC SDRAM
Mem=AGP
Mem=2/3 Bus
Mem=3/4 Bus
Mem=4/3 Bus
Mem=3/2 Bus 		8 16Mbit
64Mbit
128Mbit
256Mbit 		2GB
4GB Reg 		Both 1x
2x
4x 		66
100
133 		1/2
2/5
1/3
1/4
PCI 2.2 		N/A
VIA Apollo Pro266T
[VT8653]
[VT8233]
[VT8101] (VPX) 		P-III
P-III(T)
Celeron 		SDRAM PC133
Reg SDRAM
VC SDRAM
DDR PC2100
Reg DDR 		8 128Mbit
256Mbit
512Mbit 		4GB ECC 1x
2x
4x 		66
100
133 		1/2
1/3
1/4
PCI 2.2 		N/A
VIA PM-266T
(VS10-P6)
[VT8608]
[ ? ]
Savage4 AGP 		P-III
P-III(T)
Celeron 		SDRAM PC133
DDR PC2100 		? ?Mbit ?GB ? 1x
2x
4x 		100
133 		1/3
1/4
PCI 2.2 		N/A
VIA Apollo Pro333T
[ ? ]
[ ? ] 		P-III
P-III(T)
Celeron 		SDRAM PC133
Reg SDRAM
DDR PC2700
Reg DDR 		? ?Mbit ?GB ECC 1x
2x
4x
8x 		66
100
133 		1/2
1/3
1/4
PCI 2.2 		N/A
VIA P4X-266
[VT8753]
[VT8233]
[VT8101] (VPX) 		P-4 SDRAM PC133
Reg SDRAM
DDR PC2100
Reg DDR
Mem=4/3 Bus 		? ?Mbit 4GB ECC 1x
2x
4x 		100 (x4) 1/3
1/4
PCI 2.2 		N/A
VIA P4M-266
[VT8751]
[VT8233]
Savage8 AGP 		P-4 SDRAM PC133
Reg SDRAM
DDR PC2100
Reg DDR
Mem=4/3 Bus 		? ?Mbit 4GB ECC 1x
2x
4x 		100 (x4) 1/3
1/4
PCI 2.2 		N/A
VIA P4X-266A
[VT8753]
[VT8233]
[VT8101] (VPX) 		P-4 SDRAM PC133
Reg SDRAM
DDR PC2100
Reg DDR
Mem=4/3 Bus 		? ?Mbit 4GB ECC 1x
2x
4x 		100 (x4)
133 (x4) 		1/3
1/4
PCI 2.2 		N/A
VIA P4X-333
[VT8754]
[VT8235] 		P-4 SDRAM PC133
Reg SDRAM
DDR PC2700
Reg DDR
Mem=4/3 Bus
Mem=5/3 Bus 		? ?Mbit 32GB ECC 1x
2x
4x
8x 		100 (x4)
133 (x4) 		PCI ? N/A
VIA P4X-266E
[VT8753A]
[VT8233A]
[VT8101] (VPX) 		P-4 SDRAM PC133
Reg SDRAM
DDR PC2100
Reg DDR
Mem=4/3 Bus 		? ?Mbit 4GB ECC 1x
2x
4x 		100 (x4)
133 (x4) 		1/3
1/4
PCI 2.2 		N/A
VIA P4X-400
[VT?]
[VT8235]
[VT8101] (VPX) 		P-4 DDR PC3200
Mem=3/2 Bus
Mem=4/3 Bus
Mem=5/3 Bus 		? ?Mbit ?GB ? 1x
2x
4x
8x 		100 (x4)
133 (x4) 		1/3
1/4
PCI 2.2 		N/A
VIA P4M-266A
[ ? ]
[VT8233]
Savage8 AGP 		P-4 SDRAM PC133
Reg SDRAM
DDR PC2100
Reg DDR
Mem=4/3 Bus 		? ?Mbit 4GB ECC 1x
2x
4x 		100 (x4)
133 (x4) 		1/3
1/4
PCI 2.2 		N/A
VIA P4M-333
[ ? ]
[VT8235]
[ ? ] (VPX-II)
Zoetrope AGP 		P-4 SDRAM PC133
Reg SDRAM
DDR PC2700
Reg DDR
Mem=4/3 Bus
Mem=5/3 Bus 		? ?Mbit ?GB ECC 1x
2x
4x
8x 		100 (x4)
133 (x4) 		PCI ? N/A
VIA P4X-600
[ ? ]
[VT8235]
[ ? ] (VPX-II) 		P-4 SDRAM PC133
Reg SDRAM
DDR DC PC2700
Reg DDR
Mem=4/3 Bus
Mem=5/3 Bus 		? ?Mbit ?GB ECC 1x
2x
4x
8x 		100 (x4)
133 (x4) 		PCI ? N/A
VIA P4X-800
[ ? ]
[VT8235]
[ ? ] (VPX-II) 		P-4 Dual DDR II+ ? ?Mbit ?GB ECC 1x
2x
4x
8x 		100 (x4)
133 (x4) 		PCI ? N/A
VIA KX-133
[VT8371]
[VT82C686A] 		K7 EDO
SDRAM PC133
ESDRAM
VC SDRAM
Mem=4/3 Bus 		6 16Mbit
64Mbit
128Mbit
256Mbit 		2GB Both 1x
2x
4x 		100 (x2) 1/3
Pseudosynch
PCI 2.2 		N/A
VIA KT-133
[VT8363]
[VT82C686A] 		K7
Duron 		SDRAM PC133
ESDRAM
VC SDRAM
Mem=4/3 Bus 		6 16Mbit
64Mbit
128Mbit
256Mbit 		1.5GB No 1x
2x
4x 		100 (x2) 1/3
Pseudosynch
PCI 2.2 		N/A
VIA KM-133
(VS2-K7)
[VT8365]
[VT8231]
Savage4 AGP 		K7
Duron 		FPM
EDO
SDRAM PC133
VC SDRAM 		6 16Mbit
64Mbit
128Mbit
256Mbit 		1.5GB No 1x
2x
4x 		100 (x2) 1/3
Pseudosynch
PCI 2.2 		N/A
VIA KT-133E
[VT8363E]
[VT82C686B] 		K7
Duron 		SDRAM PC133
ESDRAM
VC SDRAM
Mem=4/3 Bus 		6 16Mbit
64Mbit
128Mbit
256Mbit 		1.5GB No 1x
2x
4x 		100 (x2) 1/3
Pseudosynch
PCI 2.2 		N/A
VIA KT-133A
[VT8363A]
[VT82C686A] 		K7
Duron 		SDRAM PC133
ESDRAM
VC SDRAM
Mem=4/3 Bus 		6 16Mbit
64Mbit
128Mbit
256Mbit 		1.5GB No 1x
2x
4x 		100 (x2)
133 (x2) 		1/3
1/4
Pseudosynch
PCI 2.2 		N/A
VIA KT-266
[VT8366]
[VT8233] 		K7
Duron 		SDRAM PC133
Reg SDRAM
VC SDRAM
DDR PC2100
Reg DDR
Mem=3/4 Bus
Mem=4/3 Bus
Mem=AGP 		6 S
8 Reg 		64Mbit
128Mbit
256Mbit
512Mbit 		3GB S
4GB Reg 		Both 1x
2x
4x 		100 (x2)
133 (x2) 		1/3
1/4
Pseudosynch
PCI 2.2 		N/A
VIA KLE133
[VT8361]
[VT82C686B]
Trident Blade 3D 		K7
Duron 		SDRAM PC133
VC SDRAM 		? ?Mbit 2GB ? 1x
2x
4x 		100 (x2)
133 (x2) 		1/3
1/4
Pseudosynch
PCI 2.2 		N/A
VIA KL-133
[VT8364]
[VT82C686B]
Savage4 AGP 		K7
Duron 		SDRAM PC133
VC SDRAM 		? 16Mbit
64Mbit
128Mbit
256Mbit 		1GB ? 1x
2x
4x 		100 (x2) 1/3
Pseudosynch
PCI 2.2 		N/A
VIA KL-133A
[VT8364A]
[VT82C686B]
Savage4 AGP 		K7
Duron 		SDRAM PC133
VC SDRAM 		? 16Mbit
64Mbit
128Mbit
256Mbit 		1GB ? 1x
2x
4x 		100 (x2)
133 (x2) 		1/3
1/4
Pseudosynch
PCI 2.2 		N/A
VIA KM-133A
(VS2-K7)
[VT8365A]
[VT8231]
Savage4 AGP 		K7
Duron 		FPM
EDO
SDRAM PC133
VC SDRAM 		6 16Mbit
64Mbit
128Mbit
256Mbit 		1.5GB No 1x
2x
4x 		100 (x2)
133 (x2) 		1/3
1/4
Pseudosynch
PCI 2.2 		N/A
VIA KT-266A
[VT8366A]
[VT8233] 		K7
Duron 		SDRAM PC133
Reg SDRAM
DDR PC2100
Reg DDR
Mem=3/4 Bus
Mem=4/3 Bus
Mem=AGP 		6 S
8 Reg 		64Mbit
128Mbit
256Mbit
512Mbit 		3GB S
4GB Reg 		Both 1x
2x
4x 		100 (x2)
133 (x2) 		1/3
1/4
1/5
Pseudosynch
PCI 2.2 		N/A
VIA KT-266DP
[ ? ]
[VT8233A] 		Athlon MP Dual SDRAM PC133
Reg SDRAM
DDR PC2100
Reg DDR 		6 S
8 Reg 		64Mbit
128Mbit
256Mbit
512Mbit 		3GB S
4GB Reg 		ECC 1x
2x
4x 		100 (x2)
133 (x2) 		1/3
1/4
Pseudosynch
PCI 2.2 		N/A
VIA KM-266
(VS12-K7)
[VT8375]
[VT8233A]
Savage8 AGP 		K7
Duron 		SDRAM PC133
Reg SDRAM
VC SDRAM
DDR PC2100
Reg DDR 		6 S
8 Reg 		64Mbit
128Mbit
256Mbit
512Mbit 		3GB S
4GB Reg 		ECC 1x
2x
4x 		100 (x2)
133 (x2) 		1/3
1/4
Pseudosynch
PCI 2.2 		N/A
VIA KT-333
[VT8367]
[VT8233A] 		K7
Duron 		SDRAM PC133
Reg SDRAM
VC SDRAM
DDR PC2700
Reg DDR 		6 S
8 Reg 		64Mbit
128Mbit
256Mbit
512Mbit 		3GB S
4GB Reg 		ECC 1x
2x
4x 		100 (x2)
133 (x2) 		1/3
1/4
1/5
Pseudosynch
PCI 2.2 		N/A
VIA KT-333A
[VT8367]
[VT8235] 		K7
Duron 		SDRAM PC133
Reg SDRAM
DDR PC2700
Reg DDR 		? 64Mbit
128Mbit
256Mbit
512Mbit 		4GB ECC 1x
2x
4x
8x 		100 (x2)
133 (x2) 		1/3
1/4
1/5
Pseudosynch
PCI 2.2 		N/A
VIA KT-400
[VT8368]
[VT8235] 		K7
Duron 		SDRAM PC133
Reg SDRAM
DDR PC3200
Reg DDR 		? 64Mbit
128Mbit
256Mbit
512Mbit 		4GB ECC 1x
2x
4x
8x 		100 (x2)
133 (x2) 		1/3
1/4
1/5
Pseudosynch
PCI 2.2 		N/A
VIA KM-333
[ ? ]
[VT8235]
Zoetrope AGP 		K7
Duron 		SDRAM PC133
Reg SDRAM
DDR PC2700
Reg DDR 		? ?Mbit ?GB ECC 1x
2x
4x
8x 		100 (x2)
133 (x2) 		1/3
1/4
Pseudosynch
PCI 2.2 		N/A
VIA K8HTB
[ ? ]
[VT8235] 		Hammer Integrated into CPU -- -- -- -- 1x
2x
4x
8x 		200 (x2) PCI-66/64 N/A
VIA K8M-333
[ ? ]
[ ? ]
Zoetrope AGP 		Hammer Integrated into CPU -- -- -- -- 1x
2x
4x
8x 		200 (x2) PCI-66/64 N/A
VLSI Chipsets Typical
CPUs 		DRAM
Types 		Mem
Rows 		DRAM
Density 		Max
Mem 		ECC/
Parity 		AGP Bus
Speeds 		PCI Clock
Dividers 		Max L2/
Tag bits
VLSI Lynx
[82C541]
[82C543] 		P54C FPM
EDO
SDRAM 		? ?Mbit 256MB ? N/A 50
60
66 		1/2
Asynch 		512KB/?-bit
?MB WT
?MB WB

...Истина может быть любой, только вот здравый смысл подсказывает другое...

Вместо эпилога... Процесс выбора материнской платы можно условно разделить на несколько этапов:
1. Выбор производителя.
2. Выбор поддерживаемого процессора.
3. Выбор чипсета и типа поддерживаемой оперативной памяти.
4. Выбор необходимых дополнительных функций материнской платы.
Конечно, такая последовательность достаточно условна и на практике эти этапы прорабатываются порой одновременно.
Этап-1... производитель - brand или no-name? На российском рынке представлено такое изобилие плат от разных производителей, что перечислить их все не под силу даже профессионалу. При этом платы от разных производителей с почти одинаковыми возможностями стоят по-разному. За последние годы многие компании стали уделять качеству своей продукции пристальное внимание и в плане надежности и качества своих продуктов сравнялись с ASUSTeK-ом и Intel-ом. Это относится напр. к Leadtek, Gainward, SUMA. Но все же не стоит размениваться на покупку дешевых плат от малоизвестных производителей: велика вероятность, что такая плата будет "глючить", а найти причину нестабильной работы крайне сложно. Советую все же выбирать плату от наиболее известного производителя. Если это не подделка, то качество товара гарантированно. Можно доверять компаниям ASUS, Abit, AOpen, DFI, Gigabyte, Intel и MSI. У каждой из этих компаний разнообразная линейка материнских плат с разными чипсетами и функциональными возможностями, поэтому Вы всегда сможете найти нужное. Удобно и техническая поддержка на web-сайте производителя.
Нюанс: только в России сильно завышены цены на Asus-товары. Марка раскручена и торговцы ставят "заоблачные" цены. Это касается не только системных плат, но видеокарт.
Этап-2... Каждая материнская плата рассчитана на установку конкретной "линейки" процессоров, имеющих один корпус (следовательно устанавливаемых в один и тот же разъем), но отличающихся друг от друга только тактовой частотой. Советую выбирать плату, в которой у Вас "есть запас" на замену процессора с более высокой частотой. Второй совет - разъем для его установки процессора должен быть "молодым", т.е. чтобы на этот разъем были планы по выпуску новых процессоров.
Этап-3... Каждая материнская плата поддерживает определенный тип памяти. Или совпадает с имеющимся у Вас типом, или придется покупать новую оперативную память. Т.е. выбор чипсета с поддержкой нужной памяти.
Этап-4... дополнительные функции. Определите:
а) нужное количество PCI-слотов для установки дочерних карт. В такие слоты могут устанавливаться внутренние модемы, звуковые карты, сетевые карты, RAID-контроллеры, SCSI-контроллеры, TV-тюнеры и другие специфические устройства и контроллеры.
b) тип AGP-слота для установки видеокарты (может быть 2х, 4х, 8х).
c) необходимость AMR- или CNR-слотов. Cетевая карта, модем или звуковая карта должны быть совместимыми с данными слотами. Не советую.
d) поддержку интерфейса или ATA 66, или ATA 100, или ATA 133. Т.е. это о пиковая пропускная способность шины, соединяющей жесткий диск с другими компонентами.
e) необходимость интегрированного на IDE RAID-контроллера, т.к. покупать отдельный RAID-контроллер нерентабельно. Как правило, такие интегрированные контроллеры являются двухканальными и позволяют создавать RAID-массивы уровня 0 или 1. Следует иметь в виду, что интерфейс IDE позволяет подключать только два устройства на канал, а всего таких каналов на материнских платах — два, то есть можно подключить только четыре IDE-устройства, чего может оказаться недостаточно.
f) необходимость интегрированной звуковой карты.
g) необходимость интегрированного сетевого адаптера Ethernet 10/100Base-T. Имеет смысл только при планах использовании компьютера в составе локальной сети.
h) число и стандарт USB-портов. Все современные платы имеют хотя бы два разъема для подключения количество устройств, подключаемых по USB-интерфейсу. Количество устройств с каждым годом увеличивается - это модемы, мыши, клавиатуры, сканеры, принтеры, цифровые фотоаппараты и т.д. USB-стандартов существуют два: USB 1.1 и USB 2.0, различающиеся в первую очередь скоростью передачи.
i) возможности разгона. Производители по-разному относятся к этой возможности. К примеру, Intel-платы вообще не позволяют осуществлять какой-либо разгон, а ASUS, AOpen, Abit, Gigabyte, MSI иногда даже помогают таким действия. Некоторые модели материнских плат даже снабжаются специальными утилитами, позволяющими программно изменять тактовые частоты и напряжение ядра.

P.S. M/b со Slot-ами из полностью прозрачного пластика:

© Dmitry Belousov
http://www.orakul.spb.ru
ноябрь 2001г.-июнь 2002г.


"Азбука РС" Дм.Белоусова, корпуса

Корпус (case)
Классификация
по форм-фактору: 		Классификация
по внешнему виду:

•

Блок питания
БП Pentium 4

•

ATX
Mini-, Micro, Flex

•

Desktop

•

Вентилятор
Дизайн

•

AT
Full, Baby, 3/4, 2/3

•

Tower

•

Важные мелочи

•

NLX
LPX и micro-

•

Server
WTX

•

•

ITX
в т.ч. mini-

Корпус (корпус системного блока) — это конструктив (коробка), в которой собран ПК. Корпус определяет внешний вид компьютера и является одним из наиболее долговечных компонентов компьютера, который переживает не одну модернизацию, в частности, смену "матерей". В России новый корпус стоит "в среднем" от $20 до $90, хотя есть экземпляры и за $500-700. Корпус (case, Housing) состоит из несущего шасси (chassis), внешних стенок или единого чехла и блока питания (power supply unit, PSU).
От конструкции шасси зависит, будет ли материнская плата перекашиваться и испытывать изгибающиее ее нагрузки, будут ли платы расширения смещаться в слотах материнской платы и выскакивать из них, будет ли удобным доступ к элементам материнской платы, будет ли достаточной циркуляция воздуха для охлаждения элементов и т.п. Схема и вид Tower-корпуса:

Раньше выбор составляющих ПК можно было начинать с корпуса. Теперь это изменилось - процессоры Intel Pentium 4 и AMD Athlon диктуют выбор шасси, блока питания, системной платы и др. Чем лучше Вы представляете назначение своего ПК и прогнозируете его развитие, тем удачнее Вы сможете сделать выбор корпуса.

         "... написано "нажмите любую клавишу"... я нажимаю, и начинается перезагрузка... А какую кнопку Вы нажимаете? - Написано "любую", вот я и жму большую круглую на корпусе..."
Корпус обычно имеет форму параллелепипеда, у которого есть ярко выраженная малая сторона и две больших. Габариты корпуса пишутся так: Ширина х Высота х Глубина. Если корпус в рабочем положении стоит "на ребре", то он относится к классу Tower (башня, "тауэр"); если же лежит "плашмя", на большой грани, то он относится к классу DeskTop (настольный, "десктоп"). Tower занимает немного места, на ее верху обычно размещают внешний модем, легче организовать охлаждение, а самим корпусом загородить дисплей от бокового света. Однозначного ответа, что лучше - Desktop или Tower просто нет, т.к. есть отлично спроектированные Desktop и ужасно спроектированные Tower. Но "ужасно" спроектировать Desktop-корпус проще, то есть в случае этого формата изначальные требования к грамотности проектировщика выше. Впрочем, это компенсируется тем, что сейчас производители малобюджетных корпусов практически отказались от этого формата, а бренды как правило корпуса проектируют хорошо.

Есть и гибридные корпуса, т.е. те, которые можно смонтировать как DeskTop или как Tower. В дорогих корпусах можно повернуть привод CD-дисков, есть две лицевые панели и отдельная панель для дна с ножками. Однако, как и все гибридное, это выливается в повышенную стоимость и необходимость иметь дополнительные части. Некоторые известные производители корпусов:
[ APRA ] [ Asus ] [ Bernic ] [ Bopla ] [ Codegen ] [ Denco ] [ Eclipse ] [ Enigma ] [ Enlight ] [ Eurocase ] [ Feel ] [ Fibox ] [ Gainta ] [ Inwin ] [ Ivory ] [ KME ] [ Linkworld ] [ Modecom ] [ Pelo Alto ] [ Promedia ] [ SWEC ] [ Teko ]
Корпус имеет некоторое число больших (5.25") и малых (3.5") внешних отсеков (bay, "бэй"), выходящих на лицевую сторону. Незаполненные отсеки закрыты заглушками. В отсеки вставляются те устройства, к которым требуется доступ в процессе работы (например, привод CD-дисков - в 5.25", floppy-привод, LS-120, Iomega Zip, магнитооптика - в 3.5".

· Виды DeskTop-ов. DeskTop-ы появились первыми и преобладали (во времена небольших мониторов). Удобно использовались как дисплей-подставка. Сейчас DeskTop-ы используются, в основном, в качестве офисных компьютеров, а размещают на нем принтер. DeskTop можно поставить и на бок, превратив его в Tower, но это неудобно (затрудняется открывание корпуса, многие приводы плохо работают со съемными дисками в вертикальном положении и т.п.).

Подклассом десктопов являются тонкие корпуса slim ("слим"), применяемые для офисных компьютеров.

· Виды Tower-ов. Корпусы-башни наиболее распространены. Имеется классификация башeн по числу больших внешних отсеков (отсеков 5,25"). Число малых внешних отсеков во внимание не принимается, так как их число равно 1-2 для всех типов. Но данная классификация не стандартизована и каждый производитель волен называть как угодно.

Тип башни | Число отсеков 5.25"
Полная, big, full | 5 и более
Средняя, midi, middle | 3-4 шт.
Мини, mini | 2 шт.
Микро, micro | 1 шт.

Полные башни используются в основном как серверы, так как в них помещается большое число дисководов и удобно организуется охлаждение. Полные башни обычно имеют дверцу, закрывающую отсеки и кнопки. Программисты также любят этот тип корпуса за вместительность и держат башню под столом. Midi- и mini-башни наиболее широко используются для домашних компьютеров и для корпоративных рабочих станций. Недорогие микро-башни в основном используются в офисах.

· Дизайн корпуса можно подобрать по своему вкусу - строгие формы "свело-серого евростандарта" или дизайнерские изыски. Цвета, "подушкообразные" формы, прозразные крышки и т.п. Главное, чтобы это сочеталось с разумной внутренней компоновкой.

· Корпуса Server. Данная группа корпусов включает в себя огромное количество различных решений, в массе своей — очень специфических. Серверные корпуса могут быть рассчитаны на монтаж их в стойки, имеют большое количество вентиляторов и мест для их установки, некоторые снабжаются системами термоконтроля и возможностью установки нескольких блок питания. Есть и другой класс серверных корпусов: крупные Tower, рассчитанные на обычную установку (не в стойки), имеющие большое количество отсеков для установки устройств, несколько блоков питания. Корпуса обоих категорий обычно имеют возможности "горячей" замены компонентов.
Корпуса, рассчитанные на монтаж в стойки, имеют стандартизированные габариты. Их толщина может варьироваться от 1 Units (U) до трех (1U — 3U), допустимы и «нецелые» значения (2.5U, к примеру). Наиболее тонкие 1U обычно рассчитаны на установку специальных, имеющих повышенную компактность, комплектующих. Среди них низкопрофильные радиаторы, материнские платы, имеющие наклонные гнёзда для памяти и рассчитанные на установку плат расширения параллельно поверхности платы.

"... Чтобы купить у Вас новый корпус, мне нужно приходить со своим монитором?..."

· Форм-фактор корпуса - это отношение сторон, например, 3:2 для прямоугольника. В техническом значении - это прежде всего задание геометрии устройства. В полном значении - это геометрия плюс параметры электропитания (напряжение, распределение по контактам и т.д.), плюс дополнительные параметры. Именно в таком значении применяется термин форм-фактор для корпусов и системных плат. Параметр напрямую связан с совместимостью корпуса с системными платами. Существуют спецификации на корпуса и системные платы (так как эти устройства должны быть совместимы между собой), где определяются форм-факторы этих устройств. Главное отличие - различное электропитание, несовместимое между собой.

Форм-фактор АT

•

Full AT

•

Baby AT (BAT)

•

3/4 BAT

•

2/3 BAT
АХ - морально устаревший форм-фактор. Спецификация выпущена IBM, устарела. Используется для старых, б/у или недорогих компьютеров. Имеет 4 семейства размеров. Наиболее часто употребляемый размер - BAT, иногда этот форм-фактор так и называют. Название "глубина" говорит о преимущественном использовании в десктопах. Особенности семейства:
• Full AT - использовалась исключительно в серверах, т.к. достигала 12" в ширину.
• Baby AT - нормальный размер.
• Глубина 3/4 и 2/3 от глубины BAT при той же ширине.
На платы AT подается только 5В, а 3.3В получается преобразователем напряжения на самой плате; от блока питания идут два разъема на плату (надо черными проводами к середине!). На AT-е все коннекторы собраны в одном месте, в результате чего либо кабели от коммуникационных портов тянутся через всю материнскую плату к задней части корпуса, либо от портов IDE и FDD – к передней; гнезда для модулей памяти чуть ли не под блоком питания. Неудачно решен вопрос с охлаждением – воздух не поступает напрямую к процессору.

Форм-фактор АTX

•

АTX

•

Mini-ATX

•

MicroATX

•

FlexATX
Спецификация выпущена Intel в середине 90-х годов. ATX раскрывается как AT Extension, что означает развитие AT. Периодически выходят новые версии спецификации АТX, напр. версия 2.03 от 1998 года. Особенности семейства:
• ATX - большой размер (305x244 мм), позволяющий разместить целых 7 слотов карт расширения (PCI, AGP, AMR, CNR, ACR, ISA). Плата совместима с корпусами десктоп и башнями. Является аналогом Baby AT.
• Mini-ATX - имеет меньшие размеры (284x208 мм) и позволяет разместить 6 слотов карт. Совместима с теми же корпусами, что и ATX.
• MicroATX - уменьшенная АТX (244x244 мм): большая сторона прямоугольника уменьшилась до квадрата. Позволяет разместить 4 слота. Основное применение - офисные компьютеры.
• FlexATX - еще уменьшенный вариант MicroATX (229x191 мм). Одно из его применений - Интернет-приставки. MicroATX и FlexATX иногда называют SFX.
На платы AT подается готовое напряжение 3.3В; от блока питания идет один разъем на плату; компоновка платы, уменьшающая длину интерфейсных кабелей; выключение компьютера из OS. Цвет проводов стандарта ATX следующий:

Цепь | Цвет провода | Пояснение
+5V | Красный | Основное напряжение
+12V | Желтый | Питание двигателей устройств и интерфейсных цепей
-5V | Белый | Не используется. Присутствует для соблюдения стандарта ISA Bus
-12V | Синий | Питание интерфейсных цепей
+3,3V | Оранжевый | Питание процессора
+3,3V Sence | Коричневый | Сигнал обратной связи стабилизатора +3,3V
+5VSB | Малиновый | Дежурный маломощный источник +5V
PS-ON | Зеленый | Сигнал включения источников питания
PW-OK | Серый | Сигнал питание в норме
GND | Черный | Общий, относительно питающих напряжений

Форм-фактор LPX, NLX

•

LPX

•

miniLPX

•

NLX

•

microNLX
Спецификация LPX предназначалась для использования в корпусах Slimline или Low-profile. Была введена стойка. Т.е. карты расширения вставляются не в материнскую плату, а в подключаемую к плате вертикальную стойку, параллельно материнской плате. Это позволило заметно уменьшить высоту корпуса, максимальное количество подключаемых карт - 2-3 штуки. Еще одно нововведение, родившиеся в LPX - это интегрированный на материнскую плату видеочип. Размер корпуса для LPX оставляет 9х13", для Mini-LPX - 8 x 10". После появления NLX, LPX начал вытесняться.
Сверхкомпактный стандарт вновь родился в ноябре 1997г., когда Intel представила спецификацию NLX. Сегодня NLX - открытая спецификация системных плат low profile (v.1.2), т.е. разработкой форм-фактора занимались совместно многие поставщики ПК. В NLX слоты расширения расположены на отдельной карте, что позволяет легко вытаскивать системную плату - все платы расширения остаются в этой отдельной карте. Кроме того, форм-фактор был разработан как решения для построения дешевых NetPC-систем. Спецификация также требует специальный корпус, так как дизайн NLX позволяет платам расширения и системной плате располагаться на специальных рельсах, для удобного изъятия их из корпуса. Форм-фактор корпуса иногда называется NLX-slim. На системной плате устанавливается специальная карта для плат расширения (riser card). Предназначенна для использования в системах различных типов.

Фото сзади | Riser card | Фото сбоку

Размеры семейства: NLX (большой размер) - 400x400x100 мм, microNLX (маленький размер) - 210x254 мм. Основные отличия NLX:
- поддерживает существующие и будущие процессоры;
- поддерживает графические возможности с помощью графического порта AGP;
- поддерживает технологию "высоких" блоков памяти;
- обеспечивает гибкость разработки и интеграции системы (напр. дает возможность заменены платы даже без отвинчивания винтов).

Форм-фактор ITX

•

ITX

•

Mini-ITX
Новая спецификация. Стандарт Mini-ITX был разработан в компании VIA Technologies и представлен ею в ноябре 2001 года (т.н. инициатива Total Connectivity, в т.ч. разработка "систем-в-материнской-плате"). Cистемы в корпусе Mini-ITX не требуют вентиляции. Компактность Mini-ITX позволяет изготавливать бесшумные полнофункциональные системы, занимающие очень мало места. Размеры семейства:
• ITX - большой размер (215x191 мм).
• Mini-ITX - маленький размер (170x170 мм).

Форм-фактор WTX

Мощные рабочие станции и серверы спецификации AT и ATX тоже не устраивают. Там на передний план выходят обеспечение нормального охлаждения, размещение больших объемов памяти, удобная поддержка многопроцессорных конфигураций, большая мощность блока питания, размещение большего количество портов контроллеров накопителей данных и портов ввода/вывода, т.е. стоимость играет не самую главную роль. Так в 1998 году родилась спецификация WTX, ориентированная на поддержку двухпроцессорных материнских плат любых конфигураций, поддержку сегодняшних и завтрашних технологий видеокарт и памяти.
В этой спецификации разработчики попытались отойти от привычной модели, когда материнская плата крепится к корпусу посредством расположенных в определенных местах крепежных отверстий. Здесь она крепится к BAP (Board Adapter Plate), причем способ крепления оставлен на совести производителя платы, а стандартный BAP крепится к корпусу.
WTX описывает архитектуру Flex Slot. На подобных картах могут размещаться любые PCI, SCSI или IEEE 1394 контроллеры, звук, сетевой интерфейс, параллельные и последовательные порты, USB, средства для контроля за состоянием системы.
Первые серийные образцы WTX появились осенью 1999 года.

         "... У меня блок питания ревет!
- А может, это звуки на заставке?..."
Блок питания входит в комплект корпуса, отдельно продаются редко (в РФ). Ненадежный БП не только сам выйдет из строя, но и "унесет за собой в могилу" почти все элементы ПК. В поставку корпуса одного типа могут входить различные блоки, в частности, отличающиеся мощностью. Существует несколько стандартных значений мощности: 200Вт, 230Вт, 235Вт, 250Вт, 280Вт, 300Вт, 350Вт, 400Вт, 2х300Вт, 2x337Вт, 700Вт. Это полезная мощность, т.е. выдаваемая в нагрузку. Верхние значения - это блоки питания с резервной мощностью (удвоенной, утроенной).
• для офисных ПК почти всегда достаточно мощности 200Вт.
• для домашнего мультимедийного ПК можно порекомендовать 230-250Вт.
• для рабочих станций (с "тяжелыми" приложениями) достаточно 300 Вт.
Лидером среди производителей БП является Seasonic.
С самых первых моделей ПК применяется двухтактная схема преобразователя с бестрансформаторным входом. Импульсный преобразователь является регулирующим элементом стабилизатора напряжения: управляя шириной импульса, можно изменять величину энергии, поступающей через трансформатор в выпрямитель, и следовательно, регулировать (стабилизировать) его выходное напряжение. Преобразователь может стабилизировать лишь одно напряжение, обычно выбирают основное питающее напряжение. От блока питания требуется стабильно выдавать нужные номиналы и служить долго и безотказно. Хорошие блоки также исправляют (в большей или меньшей степени) отклонения во входном питании, серверные допускают возможностью "горячей замены". Срок работы блока питания составляет 4-7 лет, а продлить его можно тем, что реже выключать и включать компьютер, причем интервал между последовательным выключением и включением должен составлять не менее 10 секунд. При выходе блока питания из строя его проще заменить, чем ремонтировать. Стоимость хорошего блока составляет $35-40, поэтому хороший корпус в принципе не может стоить менее $40.
Сводная таблица размеров блоков питания:

Форм-фактор | Размеры, мм | Фото
ATX | 140х150х86 |
MicroATX, FlexATX) | 125x100x50
ITX и Mini-ITX | 174х73х55

Блок питания имеет стандартный конструктив и набор жгутов с разъемами питания системной платы и периферийных устройств. Если комплектующих много, набора не хватает. Но "с рук" можно купить "тройничок" (дополнительный жгут проводов с одной "мамой" и двумя "папами") и т.о. расширить стандартный комплект.

· Сертификат. Минимальные требования к блоку питания - наличие хотя бы одного сертификата авторитетных тестовых лабораторий из числа: UL, CSA, TUV, CB, CE, VDE, FCC, FTZ, DEMKO, NEMKO, FIMKO & SEMKO/ Сертификат есть в спецификации к блоку, соответствующие наклейки располагаются на видном месте блока. Обычно это TUV.

· Выключатель или розетка? На блоке питания (помимо сетевого разъема-вилки) находится или розетка для питания дисплея или выключатель (ATX-питание). У ATX-питания напряжение все время подается на системную плату. Если нужно провести работы внутри корпуса и нужно обесточить компьютер, выключатель позволяет сделать это быстро и удобно. Предпочтение следует отдавать выключателю. При подключении через корпус экономится розетка, но нужен переходник, так что выигрыш сомнительный. Даже в случае AT-питания использование розетки нежелательно, так как кнопка питания ПК одновременно включает и его и дисплей, что ведет к обгоранию выключателя, ибо ЭЛТ-дисплей потребляет большой ток.

· Блок питания к Pentium 4, не соответствующий стандарту ATX 2.03 (так называемый «Pentium 4 Ready»), не имеет соответствующих коннекторов для подключения к P4-плате. Законодателем мод (Intel) предписывается иметь три разъема питания на плате для Pentium 4:

  • "стандартный" ATX;
  • "квадратный" 4-Pin ATX12V;
  • 5-pin "половина AT-разъема" (AUXPWR);
Таким образом, если конструкцией платы не предусмотрена работа в случае если все необходимые коннекторы не подключены к разъемам питания, она просто откажется работать. Однако даже если жесткой блокировки запуска нет, угроза нестабильной работы все же остается. Некоторые платы вместо ATX12V и AUXPWR имеют использовавшийся для стандартного HDD/CDROM разъём питания, что снимает часть проблем со стабильностью питания. Большинство фирменных БП на 250-300W. Блок питания, дающий "честные" 250-300W потянет почти любую материнскую плат без проблем и с очень большой степенью вероятности будет работать с платой для Pentium 4, даже если он для этого не предназначен. 200-230W БП — может быть будет, а может быть и нет. Если же мощность БП меньше 200W, то само по себе наличие в системе Pentium 4 уже не важно — с таким блоком будет работать только тщательно просчитанная конфигурация, гарантированно не потребляющая больше чем данный БП может «отдать». Кстати, что бренды (к примеру, Hewlett Packard), выпускают компьютеры на базе Pentium 4 с БП мощностью менее 200W, но о модернизации такого ПК Вам лучше даже и не думать...
Т.о., перед началом экспериментов имеет смысл выяснить, имеет ли вообще смысл их начинать: быть может, Ваша плата для Pentium 4 не будет работать с старым БП в любом случае.

         "... Смажьте, наконец, этот долбаный вентилятор, а то жена ворчит!..."

Вентилятор (culer). Ряд комплектующих ПК являются "горячими" (процессор, чипсет, графическая карта, высокооборотные жесткие диски и др.). Поэтому есть проблема охлаждения этих деталей. Решается она созданием охлаждающих воздушных потоков в корпусе, а также системой температурного контроля. Вентилятор блока питается от цепи +12 В и обеспечивает охлаждение всего системного блока. В современных качественных блоках питания устанавливают так называемый Fan Processor, регулирующий скорость вращения вентилятора в зависимости от температуры. Это позволяет увеличить ресурс вентилятора и снижает шум при нормальной температуре окружающего воздуха. Некоторые производители вентиляторов:

[ Comair Rotron ] [ Indek Corporation ] [ Matsushita Electric ] [ Nidec ] [ NMB Technologies ] [ Sunon ] [ Y. S. Tech ]
В тепло уходит от 40% до 80% от номинальной мощности блока питания, в зависимости от комплектации компьютера. Т.е. для блока мощностью 200Вт по минимуму получается уже 80Вт! Штатного вентилятора в блоке питания для отвода даже такой минимальной мощности недостаточно. Поэтому для эффективного теплоотвода корпуса оборудуют дополнительными вентиляторами (от 1 до 4 вентиляторов). Эти вентиляторы могут быть уже установлены (редко) или же поставка самим.

В хороших корпусах должны присутствовать от двух до четырех отсеков для установки дополнительных вентиляторов. Не бывает хороших дешевых вентиляторов! Либо плохие, либо дорогие :(

         "... Любое устройство, требующее наладки и регулировки обычно не поддается ни тому, ни другому..."
При прочих равных условиях (размер, положение БП, количество отсеков и пр.) есть несколько параметров, определяющих удобство и ценовые характеристики корпусов:

  • Щель для дискеты;
  • Качество корпуса;
  • Низкое излучение наружу;
  • Легкая замена жестких дисков;
  • Крепление тяжелого кулера;
  • Наличие дополнительных возможностей;
  • Кнопки управления;

· Щель для дискеты. На некоторых корпусах вместо одного из 3,5" отсеков имеется щель для дискеты. Под неё внутри ставиться floppy-дисковод. Это выглядит привлекательно, щель более эстетична и совместима со всеми дисководами. Но щель требует, чтобы floppy-привод имел мощную пружину, далеко выталкивающую дискету. Иначе ее придется буквально выщипывать из корпуса. Заталкивается она тоже не просто. А на некоторых китайских корпусах эти отсеки имеют такие перекосы, что дискету просто невозможно вставить или вынуть. К тому же, при монтаже дисковода в такой корпус следует следить за очень точным совмещением щели дисковода со щелью корпуса, иначе у Вас будут проблемы с вставкой/извлечением дискет. Этот параметр скорее отрицательный.

· Качество корпуса или точнее качество материала, из которого изготовлен корпус: толщина стенок, качество самого металла и т.п. Основным параметром качества корпуса является толщина металла его шасси (несущей рамы), а также стенок (кожуха). Если шасси сделано из толстого металла, то практически отсутствует шум и вибрация. Кроме того, такой корпус прочен, что также важно. Если шасси добротное, то такими же являются и стенки (кожух). Наоборот, у дешевых корпусов стенки легко прогибаются (как жесть). Выбирайте корпус с толщиной металла шасси не меньше 0,8 мм, лучше 1 мм и более. Сюда же входит и качество обработки краёв металлических конструкций: они должны быть с надёжно обработанными гладкими краями (напр. завальцованными), чтобы было меньше шансов порезаться об них. Существуют даже покрашенные шасси.
В последние годы производители меняют материал – большая часть корпусов практически целиком сделана из пластика.

· Низкое излучение наружу. Хороший корпус должен быть экранирован, т.е. не выпускать наружу радиочастотные помехи, которые мешают внешним устройствам и бытовой электронике. Излучение обнаруживается, например, если подойти с радиоприемником к компьютеру при снятом кожухе - звук сразу покроется треском и шипением. Критерием является наличие в спецификации соответствие жесткому стандарту FCC Class B (американскому) на величину излучения от офисных и домашних компьютеров. В России термин Class B в документации "забывают". Лучшие корпуса изнутри покрыты пермаллоем - материалом, не пропускающим низкочастотные электромагнитные излучения. Но корпуса с таким покрытием и стоят примерно в 2 раза дороже обычных. Экранирование выполняется за счет плотного прилегания стенок к шасси посредством специальных лапок.

· Легкая замена жестких дисков. Т.е. заменять (вынимать & вставлять) эти приводы не снимая пластину с системной платой, а только сняв стенки (или даже одну стенку). Все дело в доступе к винтам крепления приводов с правой стороны. Эти винты закрываются пластиной, несущей системную плату. Существуют корпуса, где имеется:

  • Сдвигающийся вбок короб приводов. Он выдвигается на салазках влево и снимается. Заметим только, что, если такой короб охватывает и привод, вставленный в малый отсек (типа флопповода), то придется также снимать и лицевую панель корпуса.
  • Сдвигающийся вперед короб приводов. Не имеет ограничений предыдущего решения. Лицевая панель корпуса делается легкосъемной.
  • Отверстия напротив винтов. На пластине, несущей системную плату, делаются отверстия напротив винтов, так что магнитной отверткой можно исхитриться поработать с винтами.
  • Сдвигающаяся рама. Пластина, на которую крепится системная плата, смонтирована на раме, выдвигающейся назад на салазках. Тогда достаточно отодвинуть раму (отодвинув защелку) на 10-15 см и получить доступ к правым винтам. Кабели приводов при таком малом сдвиге снимать не надо. Обычно не надо снимать и тонкие проводки светодиодов, так как у большинства ATX плат они находятся в нижнем ближнем углу платы
Не могу не рассказать... Все неудобство существующих в РФ корпусов автор осознал, увидев решение проблемы у PowerMac (один из iMac'ом). Правую стенку можно открыть как дверь секретера (то есть ось поворота составляет нижнее правое ребро). А вместе со стенкой поворачивается и системная плата, открывая все для доступа

· Крепление тяжелого кулера. Последние ("горячие") процессоры снабжаются большими радиаторами. Если радиатор высокий (как, например, некоторые модели "Intel-a"), то при вертикальном расположении системной платы (как во всех башнях) радиатор создает большой рычаг. "Intel" предлагает крепить радиатор в конечном счете к пластине, несущей системную плату, через отверстия в этой плате. Поэтому пластина имеет дополнительные 4 отверстия, к которым крепятся специальные полые ножки-втулки с внутренней резьбой. Ножки входят в комплект корпуса. К этим ножкам уже крепится сама системная плата и удерживающий механизм (входит в комплект платы) посредством длинных винтов (входят в комплект шасси и/или платы).

· Наличие дополнительных возможностей. Это и инфракрасный порт, дополнительные установленные вентиляторы (напр. вытяжной вентилятор 80 мм), всевозможные рукава для отвода горячего воздуха, сдвижные подплатники (InWin), скобки и крючки для фиксации кабелей на стенках корпуса (входят в состав комплекта, фиксация кабелей возле стенок освобождает путь воздушным потокам), наличие системы термоконтроля блока питания (частота вращения вентилятора регулируется в зависимости от температуры блока питания; наличие термоконтроля благоприятным образом сказывается на снижении шума), наличие механизма защиты петель (при открывании дверцы более, чем на 120°, дверца с петлями автоматически вынимается из корпуса во избежание поломки петель), дверца, закрывающая отсеки с устройствами (с замком и ключом)
и многое-многое другое.

· Кнопки управления. На лицевой стороне корпуса находятся как минимум 2 кнопки: включения (POWER) и перезагрузки (RESET, сброс). К их дизайну предъявляются жесткие требования. Очень плохо, если все они одинаковые (например, круглые), одного диаметра и цвета и расположены близко друг от друга. Для кнопка включения-выключения питания форм-фактора AT лучшим является тумблер. Для форм-фактора ATX это в принципе невозможно. Кнопка перезагрузки должна быть мелкой и утопленной, чтобы затруднить непреднамеренное нажатие на нее. Лучший вариант, когда она настолько маленькая, что нажимается только тонким предметом типа шариковой ручки.
На некоторых ATX корпусах есть кнопка Sleep. Позволяет мгновенно послать компьютер в состояние сна (энергосберегающий режим).

Вместо эпилога - если Вы покупаете noname-корпус, закручивайте его на все болты, одевайте боковые стенки и легонько стучите по ним. Услышите характерный дребезг — не верьте заверениям, что "вставите плату — все будет ОК". Лучше вряд ли будет. Тоже самое относится и к неустойчивости при нажатии на корпус сверху / вправо / влево, — корпус должен и без внутренностей представлять собой устойчивую несущую конструкцию, а не скрепляться, например, за счет CD-ROM.

© Dmitry Belousov
http://www.orakul.spb.ru
ноябрь 2001г.-июнь 2002г.


"Азбука РС" Дм.Белоусова, HDD

Винчестер (HDD)

•

Bios

•

Шины

•

файловая
система

Систематизация
HDD по форм-фактору:
Систематизация
HDD по интерфейсу:
Систематизация
HDD по скорости:
Систематизация
HDD по виду:
  • 1,8";
  • 2,5";
  • 3,5";
  • 5,25";
  • прочие
    (1.63", 3.25");
  • IDЕ (E-IDE);
  • SCSI (SCSI-2);
  • IEEE;
  • USB;
  • 3600 об/м (устар.);
  • 4500 об/м (устар.);
  • 5400 об/м;
  • 7200 об/мин;
  • 10000 об/мин;
  • 15000 об/мин;
  • Внутренние;
  • Внешние;
  • Контактные;
  • Бесконтакные;

Винчестер (Hard Disk Drive, HDD, накопитель на жестких магнитных дисках, НЖМД, жесткий диск, "винт", "хард") - это устройство, предназначенное для долговременного хранения операционных систем, программ и данных. По способу записи и чтения информации винчестеры относятся к магнитным накопителям. Все файлы, размещенные на HDD, будут сохраняться без каких-либо потерь независимо от того, включен ПК или нет. Любые файлы могут быть скопированы, а программы проинсталлированы на HDD. Винчестер - самая важная вещь для Вас и вашей информации.
Постоянно растет объем винчестеров, новые диски каждый год сменяют старые. По данным Dataquest, в 2001 году были заменены 130 миллионов HDD, в 2002 - уже 150 миллионов.

История: в начале 70-х годов фирмой IBM был разработан первый накопитель на жестких магнитных дисках (14-дюймовый). Диск позволял записать 30 дорожек по 30 секторов в каждой из них (30/30) и мог хранить до 16 Кбайт информации. Вначале ему присвоили название 30/30. Но по аналогии с американскими автоматическими винтовками "Winchester", имеющими калибр 30/30, дисковые устройства с несъемными дисками (жесткие диски) стали называться винчестерами. В 1973 году фирма IBM создала первый HDD с несколькими дисками емкостью 140Мб, который продавался по цене $8600.
Развитие HDD-технологий можно разбить на пять этапов:

  • Первый (до 1979 года) - использование "классических" индуктивных головок записи/воспроизведения;
  • Второй этап (1979-1991гг.) - применение тонкопленочных головок;
  • Третий (1991-1995гг.) - применение магниторезисторных (MR, Magneto-Resistive) головок;
  • Четвертый (1995-2000гг.) - применение супермагниторезистивных головок (GMR, Giant Magneto-Resistive): уменьшение магнитного зазора в записывающей головке и повышение чувствительности головки чтения за счет использования материалов с аномально высоким коэфициэнтом магниточувствительности;
  • Пятый (с 2000 года) - появление моделей с новым типом магнитного покрытия — с антиферромагнитной связью (AFC) при сохранении параметров магнитных головок;

Относительно корпуса ПК различают внутренние и внешние винчестеры. Внутренние HDD - дешевле, но их максимальное количество ограничивается числом свободных отсеков корпуса, мощностью и количеством соответствующих разъемов блока питания. Установка и замена внутренних HDD требует выключения ПК. Внутренние HDD с возможностью "горячей" замены (Hot Swap) представляют собой те же винчестеры, но установленные в специальные кассеты с разъемами. Кассеты вставляются в специальные отсеки со стороны лицевой панели корпуса, конструкция позволяет вынимать и вставлять накопители при включенном питании. Для стандартных корпусов существуют недорогие приспособления (Mobile Rack), обеспечивающие оперативную съемность стандартных винчестеров.
Внешние HDD имеют собственные корпуса и блоки питания, их максимальное количество определяется возможностями интерфейса. Обслуживание внешних накопителей может производиться и при работающем ПК (критично для серверов), хотя и может требовать прекращения доступа к части дисков.
Для больших объемов хранимых данных применяются блоки внешних HDD - дисковые массивы и стойки - сложные устройства с собственными интеллектуальными контроллерами, обеспечивающими (кроме обычных режимов работы), диагностику и тестирование своих накопителей.
Самые сложные и надежные устройства хранения состоят из множества HDD и называются RAID-массивами.

Жесткий диск имеет восемь основных параметров:

  • Протокол передачи данных. Есть винчестеры со следующими интерфейсами: IDЕ / SCSI / FC-AL / IEEE / USB. Пеpвые винчестеpы в PC XT имели интеpфейс ST412/ST506; так как он оpиентиpован на метод записи MFM, его часто называют MFM-интеpфейсом.
  • Среднее время доступа (Average Seek Time) - процесс позиционирования головки записи/чтения на нужное место HDD. Бывает время при чтении и время при записи. Состоит из:
    • времени перемещения головки с текущего трека на трек с нужным сектором (Track-to-Track Seek Time);
    • времени ожидания, пока диск повернется так, что нужный сектор окажется под головкой записи/чтения;
    Время измеряется в милисекундах (мс) и сегодня составляет 3,6-11,5 мс.
  • Скорость вращения (Spindle Speed) шпинделя - это скорость, с которой вращаются диски. Измеряется в оборотах в минуту (rpm). Она влияет:
    • на скорость чтения с поверхности диска. Чем быстрее диск крутится, тем больше информации считывается за единицу времени;
    • на время доступа к нужной информации. Информация в HDD записывается по кольцевым дорожкам, а каждая дорожка разбита на сектора. Время поиска информации определяется временем выбора нужной дорожки (не зависит от скорости вращения диска) и временем, необходимым для того, чтобы диск провернулся так, чтобы под головкой оказался нужный сектор. Чем скорость вращения выше, тем меньше это время. Скорость вращения 3600 - 15000 об/мин;
  • Объём. Измеряется в гигабайтах (Gb). Hа самих HDD раньше писали емкость в миллионах байт и указывалась нефоpматиpованная емкость (pеальная - на 10-15% меньше). Бывает, что Bios'ы выдают емкость не в Gb, а Mb или даже в млн.байт. Сегодня в продаже - HDD емкостью 10-80Gb, максимальный объем дисков постоянно растет и пока равен 320Gb (MaXLine от Maxtor). Для обычного пользователя вполне хватает 10-20Gb гигабайт и заполнить остальной объем реально нечем. Исключение - музыка и видео-файлы. Но для mp3 рекомендую все же CD-RW, а для video - RAID-массивы.
  • Плотность записи. Измеряется в гигабайтах на пластину. Внутри HDD находится один или несколько дисков. Она влияет:
    • на скорость: чем больше плотность записи, тем больше информации помещается на одну дорожку, и, соответственно, больше скорость считывания этой информации при одинаковой скорости вращения диска
    • на охлаждение: меньшее число пластин уменьшает тепловыделение (диск меньше греется);
    До 5Gb на пластину - старые винчестеры; HDD в продаже - с плотностью записи 10Gb/пл.(устар.), 15Gb/пл., 20Gb/пл., 30Gb/пл.; максимальная плотность пока равна 125Gb/пл. (винчестеры от Seagate Technology).
  • Объем кэша (мультисегментного - Multisegmented Cache, Сache memory). Учитывается, что следующей командой винчестеру потребуется считать данные из секторов, следующих за текущим. Поэтому идет чтение данных из оставшихся секторов на треке, которые записываются во внутреннюю память дисковода ("кэш"). Измеряется в килобайтах (мегабайтах). Ранее Cache составлял 128-1.024 Кбайт, сегодня 2-8 Мбайт. Некоторые производители (напр. Quantum), используют часть кэша под свое программное обеспечение. У других (напр. Western Digital) для хранения firmware используются специально отведенные сектора на диске, невидимые для любых операционных систем. По включению питания эта программа загружается в обычную память.
  • Потоковая скорость передачи данных (Sustained Transfer Rate). При размере считываемой информации во много раз превышающих размер выделенного для него кэша идет непрерывное Cache-считывание секторов. Измеряется в мегабайтах в секунду и сегодня составляет до 80Мбайт/с.
  • MTBF (Mean Time Between Failures, среднее время наработки на отказ). Это надежность винчестера и измеряется в часах работы. MTBF - величина усредненная (по партии), но MBFT=900т.час лучше MBFT=300т.час. Современные HDD имеют от 500,000 до 1,000,000 часов. Т.е. это 20-40 лет (при 8-часовой работе). Лидер пока SCSI-винчестер Cheetah с 1,200,000 часов.
Кроме основных параметров, важны "Перегрузка от удара в рабочем/нерабочем состоянии (Operating/Nonoperating Shock), G" (параметр, характеризующий устойчивость винчестера к механическим воздействиям), "Рабочая температура (Operating temperature),°C" (параметр, по которому можно судить о "жаростойкости" винчестера), Потребляемая мощность (Power Management), Вт (параметр, о том, насколько винчестер будет нагреваться), срок гарантии (от 6 месяцев до 5 лет) и фирма-производитель:

Главные производители:
[ Fujitsu ] [ Hitachi Inc. ] [ IBM ] [ Iomega* ] [ LaCie ] [ Matsushita* ] [ Maxtor Corporation ] [ QArchos* ] [ Quantum Corporation* ] [ Samsung ] [ Seagate Technology, Inc. ] [ SimpleTech ] [ Storage Technology Corporation ] [ Toshiba* ] [ Western Digital Corporation ]
* - компанией Maxtor куплен винчестерный бизнес у Quantum и Matsushita; Toshiba специализируется на винчестерах для цифровых плееров и 1,8-дюймовых; Iomega разрабатывает только внешние винчестеры; QArchos - карманные винчестеры; SimpleTech - флэш-винчестеры.
** - многие фирмы-разработчики винчестеров имеют несколько заводов-изготовителей по выпуску винчестеров разных марок.

· Разделение винчестера. Винчестер "физический" делится на один или несколько "логических" (т.е. содержит logical область). Вы можете создать любую конфигурацию разделов. Разделы могут быть четырех типов:

  1. Master Boot Record (главная загрузочная запись, MBR). Здесь (в первом блоке HDD) хранится информация о разбиении диска и там можно разместить Boot Manager;
  2. Primary (основной). Это раздел, в котором всегда устанавливается операционная система. Многие "простые" OS (напр. DOS, Windows) инсталлируются только в primary;
  3. Extended (расширенный). Это раздел для программ пользователя, к которому OS имеет доступ. Extended может использоваться целиком (как единый логический диск) или же разбит на несколько логических дисков (см. рис);
  4. Other (иной) раздел. Это Extended-раздел, выделяемое для установки другой OS, отличной от установленной в primary;
При разделении HDD всегда получается только один primary-раздел и один или несколько extended-разделов. Размер любого HDD-раздела имеет верхний предел. Максимальное число логических дисков для файловых систем FATxx составляет 26 штук. Пример разделения HDD на три раздела:

Миллионы "чайников" потеряли свои данные, делая резервное копирование с "диска C:\" на соседний диск "D:\", ибо часто это один винчестер! Раньше разделение винчестера делали обязательно из-за ограничений фатовой системы и кластеризации, теперь - для удобства (раз), нескольких операционок (два) и той же кластеризации (три). Выделяемый объем зависит от вида операционной системы и количества программ, которые Вы используете.

· Режимы pаботы IDE-винчестеров. Из-за более низкой стоимости IDE-дисков (по сравнению с SCSI-дисками и учитывая неразвитость USB-дисков) фактически они и преобладают. Hа одном IDE-кабеле могут pаботать до двух IDE-устpойств: Master (MA) - основной (пеpвый) и Slave (SL) - дополнительный (втоpой). Т.е. max - 4 IDE-HDD. Установка Master/Slave производится HDD-Jumper-ами. Если устpойство на кабеле одно, его устанавливают в pежим Master, однако у некотоpых HDD есть отдельный pежим Single. Напрямую не допускается pабота устpойства в pежиме Slave пpи отсутствии Master-устpойства, но некоторые новые модели HDD могут так pаботать в этом pежиме при условии соответствующего Bios-а или дpайвеpа. Это необходимо, т.к. многие дpайвеpы, обнаpужив отсутствие Master-устpойства, пpекpащают дальнейшую работу с данным контpоллеpом. Существует pежим, в котоpом HDD само устанавливается в pежим Master/Slave в зависимости от типа pазъема на интеpфейсном кабеле - Cable Select (CS, CSel, выбоp по pазъему кабеля). Два примера установки жестких дисков:

primary |  | secondary
master | slave | master | slave
HDD | --- | CD | ---

primary |  | secondary
master | slave | master | slave
HDD 1 | HDD 2 | CD-RW/DVD | CD

Есть вариант и увеличения максимального количества подключенных устройств IDE-устройств (стандарт - не более 4-х штук). Для "обмана" нужен свободный PCI-слот m/b. По внешнему виду это карта с двумя (или четырьмя) IDE-контроллерами, установленная в PCI-разъем материнской платы. Для активации контроллера необходимо настройка Bios-a карты.

         "... Если жесткий диск не подает признаков жизни, значит, на Вашем компьютере уже установлена Windows ...

Анатомия винчестера... HDD состоит из геpмоблока и платы электpоники. В геpмоблоке pазмещены ("запечатаны") все механические части и пpедусилитель, на плате - почти вся упpавляющая электpоника. В дальней от pазъемов части геpмоблока установлен шпиндель с одним или несколькими дисками. Магнитные диски представляет собой пластины из алюминия, керамики или стекла, на которые нанесен тонкий слой высококачественного ферромагнетика - на основе окиси хpома (ранее - окиси железа и бариевых ферритов). Количество дисков - одного до трех (как правило), но в некоторых моделях достигает 10. Под дисками находится двигатель, создающий вращающееся магнитное поле. Ближе к pазъемам, с левой или пpавой стоpоны от шпинделя, находится повоpотный позиционеp (head positioner) - с одной стоpоны - несущие магнитных головок, а с дpугой - коpоткий и более массивный хвостовик с обмоткой электpомагнитного пpивода. Встречаются поворотные и линейные позиционеры.
Внутри геpмоблока - обычный воздух (а не вакуум), очищенный при изготовлении с помощью специальных фильтров. Пpи вpащении дисков создается сильный поток воздуха, котоpый циpкулиpует по пеpиметpу геpмоблока и постоянно очищается фильтpом, установленным на одной из его стоpон. Данные с поверхности диска считываются непосредственно магнитной головкой. При записи головка создает магнитное поле, намагничивая тем самым участок диска - при считывании же, наоборот, поле диска возбуждает сигнал в головке. Современные приводы содержат несколько магнитных головок - как правило, по одной на каждую сторону каждого диска.
Т.к. магнитные головки винчестера работают с очень большей скоростью, необходим очень тесный контакт между ними и поверхностью носителя. При вращении дисков внутри корпуса возникает воздушный поток, который и приподнимает головки над поверхностью - головки "посадили" на воздушную подушку. Но эта конструкция требует парковки головок - перемещения их за пределы рабочей области диска (landing zone) во время выключения компьютера. Т.е. когда винчестер выключается, диски останавливаются, исчезает магнитный поток и головки "падают" на поверхность. Поэтому головки нужно отвести в нерабочую область. Управляет всем этим позиционер.

Плата электpоники - съемная, подключается к геpмоблоку чеpез один-два pазъема pазличной констpукции. Hа плате pасположены основной пpоцессоp винчестеpа, ПЗУ с пpогpаммой, pабочее ОЗУ, котоpое обычно используется и в качестве дискового буфеpа, цифpовой сигнальный пpоцессоp (DSP) для подготовки записываемых и обpаботки считанных сигналов и интеpфейсная логика. Hа одних винчестеpах пpогpамма пpоцессоpа полностью хpанится в ПЗУ, на дpугих опpеделенная ее часть записана в служебной области диска. Hа диске также записаны паpаметpы HDD (производитель, модель, сеpийный номеp и т.п.). Hекотоpые винчестеpы хpанят эту инфоpмацию в электpически pепpогpаммиpуемом ПЗУ (EEPROM). Многие винчестеpы имеют на плате электpоники специальный технологический интеpфейс с pазъемом, чеpез котоpый пpи помощи стендового обоpудования можно выполнять pазличные сеpвисные опеpации с накопителем - тестиpование, фоpматиpование, пеpеназначение дефектных участков и т.п.
Всю информацию, хранящуюся на диске, условно делят на служебную и пользовательскую. Первая обеспечивает нормальную работу и изначально присутствует в любом HDD - ее записывает завод-изготовитель.
Каждый HDD разделен на зоны (notches), в каждую из которых входит обычно от 20 до 30 цилиндров с одинаковым количеством секторов. Секторов может умещаться от 17 до 150 (как правило) на одной дорожке. Их нумерация начинается с 1, тогда как нумерация головок и цилиндров начинается с 0. Количество секторов на дорожке не равное. Чем дальше дорожка от центра, тем больше число секторов на диске.
Т.к. технология производства винчестеров пока не позволяет избавиться от битых секторов на 100%, в каждом винчестере существует таблица перераспределения запорченных секторов (участок дорожки). При каждом включении HDD считывает таблицу и просто "не замечает" битых частей. Но в процессе эксплуатации появляются новые bad-секторы - те, которые не помечены в заводской таблице. Обращаясь к такому сектору, магнитная головка многократно повторяет попытку чтения или записи, при этом возможно разрушение "здоровой" поверхности диска. Это влечет за собой дальнейшее "размножение" запорченных секторов. Таким образом винт постепенно приходит в негодность. Во многих винчестерах есть функция autoremap. Она предназначена для замены сбойных секторов на нормальные из резервной области на аппаратном уровне. Однако она не всегда срабатывает. Но можно прогнать дисковую утилиту (напр. HDDSpeed в режиме теста записи) - после этого bad-блоки пропадают (срабатывает autoremap).
Все диски на заводе проходят первичную разметку (низкоуровневую, Low Level Formatting) на специальном высокоточном технологическом стенде. При разметке на диски записываются служебные метки (сервометки), а также формируются дорожки и секторы. Записываются их префиксы и суффиксы. Высокоуровневое форматирование делает пользователь при помощи утилиты FORMAT. В каждый раздел диска записывается VBS (volume boot sector - загрузочный сектор тома), FAT, корневой каталог (root directory), проверяется диск на наличие ошибок.
Есть система звукоподавления (Sound Barrier Technology), которая обеспечивает низкий уровень шума во время работы диска (напр. разработанная Seagate SBT-технология).
В винчестерах последнего поколения используются технологии PRML (Partial Response, Maximum Likelihood - максимальное правдоподобие при неполном отклике) и S.M.A.R.T. (Self Monitoring Analysis and Report Technology - технология самостоятельного следящего анализа и отчетности). Для пользователя существует много дисковых утилит. Пример - DFT (Drive Fitness Test) и IBM Feature Tool. Обе - freeware. Первая из них диагностирует жесткий диск, позволяет просматривать параметры S.M.A.R.T. а также осуществлять low-level format, вторая - управлять работой кэша, изменять акустические характеристики и режим UDMA.

· Геометрия диска или Normal, LBA, Large. Бывший классический способ адресации секторов - CHS - по номеру цилиндра, головки и сектора (Cylinder/Head/Sector). Разработчики первого ПК подложили всем "мину", строго определив количество разрядов, с помощью которых адресовались данные. Под номер цилиндра было отведено 16 разрядов, под номер головки - 4 и сектора - 8, что давало максимальную емкость винчестера в 128 Гб. Но Bios с самого начала ограничивал количество секторов до 63, а цилиндров - до 1024, этому же примеру следовал и DOS, что в итоге дало максимум - 528Мб. Когда же появились жесткие диски емкостью более 528Мб, ПК перестали "видеть" диск полностью. Производители Bios срочно выпустили поддержку режима LBA (Logical Block Addressing). Они использовали сквозную нумерация секторов и адрес CHS преобразуется в одно линейное 28-битовое число абсолютного номеpа сектоpа (для DOS по-пpежнему остается огpаничение в 8,4Гб), используемое для нумерации секторов (LBA-адрес) и пpеобpазуемого винчестеpом. Для pаботы в pежиме LBA необходима поддеpжка винчестеpа, Bios-а, дpайвеpа OS. Схема адресации с использованием LBA была впервые применена фирмой Western Digital в конце 1993 года.
Режим Large (Large Block Adressing) предназначен для винчестеров емкостью до 1Гб, не поддерживающих режима LBA. В Large количество логических головок увеличивается до 32, а количество логических цилиндров уменьшается вдвое. При этом обращения к логическим головкам 0..F транслируются в четные физические цилиндры, а обращения к головкам 10..1F - в нечетные. Винчестер, размеченный в режиме LBA, несовместим с режимом Large, и наоборот. Режим Normal заставлял Bios работать подобно старым версиям без трансляции.
Но сегодня это все в прошлом (с нынешними Гб-ными HDD). Те параметры диска, которые Вы видите в разделе SETUP Standart CMOS Setup, как правило, ничего общего не имеют с реальными параметрами диска. HDD ныне работают напрямую (через драйвера).

         "...пользователь может быть уверен только в одном свойстве их винчестеров - в том, что рано или поздно они полетят..."(Eric Newhouse)

· Кластер - минимальный размер места на HDD, выделяемый файловой системой для хранения одного файла. Проще: кластер - ячейка размещения данных. Все доступное пространство винчестера разделено на разделы - от одного до множества. Разделы делятся на кластеры, причем каждый кластер может или быть незанятым (доступным для использования файлом) или дефектным (непригодным для использования). На одном жестком диске может быть много разделов (диск С, диск D, диск E, диск F, диск G, диск H, диск I, диск J, диск K, etc.). За основание системы исчисления размеров кластеров принят 512-байтный сектор диска. Кластер должен иметь размер, равный основанию (512 байт), умноженному на 2 в степени n. Размер кластера определяется автоматически, в зависимости от объема созданного раздела и/или фатовой системы. Исключение - только системный раздел: если он меньше 2048Мб, размер кластера всегда 512 байт. 16-разрядная FAT может поддерживать только 65.526 кластеров.
Влияние размера кластера на потери - эффективность использования дискового пространства - можно оценить по формуле:

Eff = [ Size / (Size + Overhang) ] x 100%

где:
- Eff - эффективность использования дискового пространства, выраженная в процентах от 0 до 100;
- Size - суммарный размер всех файлов в накопителе;
- Overhang - суммарная остаточная избыточность кластеров.
Сумма величин Size и Overhang дает общий объем кластеров, занятых всеми файлами в накопителе. Чем выше отношение, тем более эффективно используется дисковое пространство. Обычное Eff составляет от 51% до 98%. Например, для раздела FAT-a в 1Гб с 10.000 файлов потери составят 160 Мб!

Размер раздела HDD | Размер в FAT16 | Средние потери | Размер в NTFS
менее 127 Mб | 2 Kб | 1,00-1,75 Kб | 512 байт
127 Mб - 255 Mб | 4 Kб | 2,00-3,75 Kб | 512 байт
256 Mб - 511 Mб | 8 Kб | 4,00-7,75 Kб | 512 байт
512 Mб - 1023 Mб | 16 Kб | 8,00-15,75 Kб | 1Kб
1024 Mб - 2047 Mб | 32 Kб | 16,00-31,75 Kб | 2K
2048 Mб - 4095 Mб | 64 Kб | 16,00-31,75 Kб | 4K
4096 Mб - 8191Mб |  |  | 8K
8192 Mб - 16383 Mб |  |  | 16K
16384 Mб - 32767Mб |  |  | 32K
от 32768 Mб |  |  | 64K

Грубо можно считать, что каждый файл занимает свой последний кластеp пpимеpно наполовину - пpи этом Ваши потеpи (места на HDD) будут pавны количеству файлов, умноженному на половину pазмеpа кластеpа. Способы боpьбы с потеpями пpостpанства:
- хpанение больших набоpов pедко используемых файлов в виде аpхивов;
- pазбиение винчестеpа на логические диски.
Есть универсальный метод для любых Windows (кроме встроенных утилит). Создаете (или берете готовый) очень маленький файлик размером 1-500 байт. Правая кнопка мыши - Properties. Смотрите на два пункта: Size и Size on disk. Size - размер файлик реально имеет. Size on disk будет (например) 4096 байт, что соответствует настоящему размеру кластера, т.е. 4Kб. Т.е. при кластере 32Kb файл с информацией в 1 байт займет на диске 32Kb.
Размер кластера может выбрать и пользователь (вручную при форматировании). Делается это так: "format d: /A:size", где size это размер кластера в байтах. Но существуют правила, которых следует придерживаться: размер кластера должен быть кратен размеру физического сектора, то есть 512 байтам в подавляющем большинстве случаев (во-первых); есть ограничения по количеству кластеров на разделе (во-вторых).

         "... Каждой твари по hardware! ...

RAID-массивы (Redundant Array of Inexpensive Disks, избыточный набоp недорогих дисков). Raid - способ оpганизации больших хpанилищ инфоpмации, увеличения скоpости обмена и надежности хpанения данных. RAID-система пpедставляет собой гpуппу из нескольких обычных (недоpогих) винчестеpов, pаботающих под упpавлением пpостого контpоллеpа и видимую извне, как одно устpойство суммарной емкости и высокой скоpости или надежности. Технология RAID базируется на трех основных методах:

  1. Поочередное размещение данных по дискам с определенной циклической очередностью. Поочередное размещение предполагает запись первого сегмента данных на первый диск, второго — на второй и т. д. В этом случае производительность массива повышается, поскольку компьютер начинает записывать очередной сегмент данных (на следующий диск) до того, как закончил запись предыдущего сегмента. Дальнейшее повышение производительности дисковых систем обеспечивается за счет подключения разных групп дисков к отдельным контроллерам;
  2. Зеркальное отражение дисков. Резервное копирование данных (ежедневно или несколько раз в неделю) не обеспечивает быстрое восстановление информации и оперативную защиту новых данных, созданных после последнего сеанса копирования. Эти задачи решаются с помощью зеркального отражения дисков, при котором все, что записывается на первый диск, дублируется на второй. В случае поломки первого диска (или записи данных в испорченный сектор его дискового пространства), они будут считаны с второго ("зеркального") диска;
  3. Вычисление контрольных сумм. Контроль четности работает так: все информационные биты в байте складываются по модулю 2 и если число единиц в нем четное - контрольный бит устанавливается в ноль, а если нечетное — в единицу. При считывании данных информационные разряды снова суммируются и полученный результат сравнивается со значением контрольного бита. Если они совпадают - данные верны, а если нет - значения одного или нескольких разрядов ошибочны;
Компании (Adaptec, CMD и другие) выпускают специальные контроллеры, предназначенные для организации массивов RAID.
Такой массив можно реализовать и на основе обычного контроллера SCSI или Fibre Channel - с помощью программы, распределяющей сегменты данных по дискам. Такое программное решение дешевле, чем основанное на специальном контроллере, но оно (как правило) поддерживает только RAID-уровни 0 и 1.

· История... Место рождения RAID-технологии - Калифорнийский университет, г.Беркли, USA. В 1987г. его специалисты (Петтерсон, Гибсон и Катц) опубликовали статью с описанием принципов объединения многочисленных дисковых накопителей. Первоначально было определено шесть уровней (levels) RAID 0—5, но по мере развития технологии появились дополнительные уровни (еще пять).

· Raid 0: распределение данных (data striping). Информация разбивается на куски (фиксированные объемы данных, обычно именуемые блоками) и эти куски записываются на диски и считываются с них в параллель. Два дисковых блока по 512 байт образуют сегмент.

Контроллер массива
Диск 1 | Диск 2 | Диск 3 | Диск 4 | Диск 5
Сегмент 1 | Сегмент 2 | Сегмент 3 | Сегмент 4 | Сегмент 5
Сегмент 6 | Сегмент 7 | Сегмент 8 | Сегмент 9 | Сегмент 10

Raid 0 не является отказоустойчивой, но этот RAID-уровень используется гораздо чаще других уровней RAID. Преимущества Raid 0 (с точки зрения производительности):

  • повышается пропускная способность последовательного ввода/вывода за счет одновременной загрузки нескольких интерфейсов;
  • снижается латентность случайного доступа - несколько запросов к различным небольшим сегментам информации могут выполнятся одновременно;
· Raid 1: Зеркальные диски (disk mirroring). Копия каждого блока информации хранится отдельно. Обычно каждый (используемый) диск имеет "двойника", который хранит точную копию этого диска. Если происходит сбой одного из основных дисков, он замещается своим "двойником". Производительность улучшают, настраивая систему так, чтобы для чтения информации использовался тот "двойник", головка которого расположена ближе к требуемому блоку.

Диск 1 | Диск 2 | Диск 3 | Диск 4 | Диск 5
Сегмент 1 | Сегмент 1 | Сегмент 2 | Сегмент 2 | ---
Сегмент 3 | Сегмент 3 | Сегмент 4 | Сегмент 4 | ---
данные X | копия диска 1 | данные Y | копия диска 3 | свободный

Один из наиболее дорогостоящих уровней, т.к. все диски дублируются и при каждой записи информация записывается еще и на проверочный диск. Часто для нормальной работы RAID 1-го уровня требуются HDD одинаковой емкости, выпущенные одним и тем же производителем. К недостаткам Raid 1 относится самый высокая избыточность, а при программной реализации - проблемы с "горячей" заменой вышедшего из строя HDD.

· Raid 2: матрица с поразрядным расслоением. В этой технологии предусмотрена защита данных с помощью корректирующей ошибки кода Хэминга. Записываемые данные распределяются по нескольким дискам, а затем контрольные суммы ECC (Error-Correction Code) записываются на отдельный диск или на несколько отдельных дисков. Коммерческие реализации RAID 2-го уровня практически отсутствуют.

· Raid 3: аппаратное обнаружение ошибок и четность. Данные распределяются по информационным дискам и для каждой “полосы” данных (совокупности сегментов данных, расположенных в одних и тех же секторах на разных физических дисках) определяется контрольная сумма (или код четности), которая записывается на отдельный диск.

Диск 1 | Диск 2 | Диск 3 | Диск 4 | Диск 5
Байт 1 | Байт 2 | Байт 3 | Байт 4 | Байт четности
Байт 5 | Байт 6 | Байт 7 | Байт 8 | Байт четности
данные | данные | данные | данные | информация четности

RAID 3-го уровня довольно сложен и реализовывается только аппаратным способом. Как минимум нужны три диска.

· Raid 4: внутригрупповой параллелизм. В отличии от Raid 3 происходит поочередное распределение не коротких сегментов данных, а информационных блоков значительного размера. Это дает возможность выполнять несколько разных запросов на чтение одновременно. Т.к. вся контрольная информация сосредоточена на одном (последнем) диске, данный массив не может осуществлять несколько операций записи одновременно. Как минимум нужны три диска. Raid 4 встречаются крайне редко.

· Raid 5: четность вращения для распараллеливания записей. На дисках системы RAID уровня 5 поочередно размещаются большие блоки данных, но в отличие от Raid 4 контрольная информация распределяется по всем дискам массива. Для первой “полосы” сегментов данных код четности может быть записан на последнем диске массива, для второй — на предпоследнем и т. д. Это позволяет выполнять несколько операций записи одновременно.

Диск 1 | Диск 2 | Диск 3 | Диск 4 | Диск 5
Сегмент четности | Сегмент 1 | Сегмент 2 | Сегмент 3 | Сегмент 4
Сегмент 5 | Сегмент четности | Сегмент 6 | Сегмент 7 | Сегмент 8
Сегмент 9 | Сегмент 10 | Сегмент четности | Сегмент 11 | Сегмент 12

Один из наиболее часто применяемых на практике и самый сложный из первых шести уровней. Как минимум нужны три диска.

· Raid 6: Двумерная четность. это расширенный вариант RAID-уровня 5, в котором предусмотрен двойной контроль четности хранимой информации для обеспечения большей надежности. Только для хранения контрольной информации требуется два HDD. RAID 6-го уровня разработан для критически важных приложений и имеет очень низкую производительность записи в связи с необходимостью расчета дополнительных контрольных сумм.

· Raid 7. Уникальная технология компании Storage Computer Corporation. Предполагает асинхронность работы своих компонентов (включая канал связи с хост-машиной) и независимость управления ими. В массивах используется встроенная операционная система реального времени для кэширования данных и расчета контрольной информации. Причем эта самая информация передается по специальной Х-шине. Данные распределяются по обычным дискам, а контрольная информация хранится на отдельном диске. С целью повышения производительности операции чтения и записи централизованно кэшируются. Очень высокая производительность и надежность хранения данных, однако высока и цена системы, оборудованной таким массивом. RAID 7 является торговой маркой.

· Raid 10/1+0. Массивы этого уровня представляют собой сочетание принципов, применяемых в массивах нулевого и первого уровня. То есть, "стриппинг" в сочетании с зеркалированием. Т.е. сначала создаются два массива RAID 0 и затем зеркалируются, что требует, как минимум, четыре диска в минимальной конфигурации - очень дорого. Цена такого массива начинает быстро расти, когда начинается расширение.

· Raid 50. Массив, сочетающий в себе принципы массивов нулевого и пятого уровня. Т.е. если например контроллер получает команду записать на HDD 256Кб данных, то эти данные по принципам RAID 0 разбиваются на два куска по 128Кб и затем каждый из них по принципам уже массивов пятого уровня разбивается на кусочки по 32Кб и записываются физически одновременно на все диски массива. Цель применения - повышение скорости работы дисковой подсистемы при сохранении высочайшей надежности хранения данных.

· Raid 53. Правильнее назвать RAID-уровнем 03, так как в нем комбинируются архитектуры RAID уровней 0 и 3. Для реализации такого дискового массива нужно не менее пяти HDD. В этой конфигурации система RAID уровня 53 поочередно записывает небольшие сегменты данных на первые два HDD, а информацию о четности — на третий HDD. Последние два диска (четвертый и пятый) содержат те же самые данные, поочередно записанные большими блоками без контроля четности, как это делается в системе RAID уровня 0.

         "..."Ты слишком много знал", - сказал Windows Hard-у..."

· Если винчестер умер... Никакой HDD не вечен и Вы должны быть готовы к его смерти. Делать резервные копии на CD-R, стриммер, магнитооптику и т.п. Итак, это случилось. Самые частые причины смерти:

  • повреждения механики (напр. диска);
  • выход из строя электроники (напр. контролера);
  • вирусная атака (напр. Win95.CIH);
  • программный сбой операционной системы Windows (особенно ХР);
  • "рукоблудство" пользователя;
Если HDD еще гарантийный - меняете на новый (с доплатой), если гарантия закончилась - отдайте старьевщикам или выбросьте. Если архивов данных не делали, а информация очень важна - попытайтесь восстановить. Количество информации (файлов) на HDD огромно, а их физическое уничтожение довольно длительно. Т.е. информация почти всегда еще жива, но не доступна. И восстанавливать надо не саму информацию, а только доступ к ней. Обращаю внимание, что как правило восстановление не лечит HDD, а позволяет скопировать имеющиеся данные на другой носитель.
Не оставляйте чужим свою информацию! В 2002 году студенты Массачусетского института провели эксперимент - купили несколько сотен "битых" HDD. Только 60% HDD были отформатированы, а на 17,7% даже вообще не удалялась информация. 81,6% винчестеров находились в рабочем состоянии. Т.к. штатная команда Windows-форматирования format не производит перезаписи блоков (не пользуйтесь этим барахлом), а "чайники" по глупости держат информацию в папке "Мои документы" (два) - все данные легко восстановимы. В частности были извлечены корпоративная финансовая информация, номера кредиток, персональные медицинские данные и т.п.
Для восстановления потребуются: загрузочная дискета (защищённая от записи), утилиты FDisk и Format (из комплекта установленной OS), утилиты DiskEdit и UnErase (из Norton Utilities), программа NC. И все легче, когда диск определяется Bios-ом и физически исправен.
Если Вы не уверены в своих знаниях и/или не исключаете возможной ошибки в своих действиях, не предпринимайте сами никаких действий. Даже незначительная неточность в Ваших действиях может значительно осложнить или даже сделать невозможным дальнейшее восстановление информации. Обратитесь за помощью к спецам.

Несколько определений, поясняющих принцип хранения информации на диске c FATxx:

  • PT состоит из четырёх элементов описывающих разделы диска. DOS и Windows используют только первые два элемента. Описание раздела диска содержит информацию о первых и последних головках, дорожках, секторах раздела, общем количестве секторов в разделе, типе файловой системы и признак того, что раздел является загрузочным.
  • MBR находится в том же секторе что и PT. Данные в MBR представляют собой код процессора, необходимый для дальнейшей загрузки операционной системы. В последних двух байтах MBR находится сигнатура 55AAh указывающая на то, что данные в MBR необходимо использовать для загрузки. Если эта сигнатура отсутствует, данные MBR не будут использованы. PT и MBR расположены на самом первом секторе HDD.
  • BR содержит массу данных и служит для описания параметров файловой системы. В отличие от диска, минимальным адресуемым блоком данных для операционной системы служит кластер, состоящий из одного или нескольких секторов. Нужны данные: размер кластера, размер и количество копий FAT.
  • FAT состоит из 12, 16 или 32 битных элементов, количество которых равно количеству кластеров на диске. Нужны эти элементы для связи кластеров в цепочки соответствующие файлам.
  • ROOT - это корневой каталог диска. Содержит записи описывающие файлы (дескрипторы файлов) в корневом каталоге. Запись описывает имя, тип, дату создания, размер, атрибуты файла, а также содержит указатель на первый кластер файла. Каталоги представляют собой файлы, идентичные по структуре корневому каталогу. Каталог, кроме записей описывающих файлы, содержит 2 записи, первая из которых содержит указатель на первый кластер самого каталога, вторая - на первый кластер родительского каталога.

         "...Диски свежие, не очищенные..."

Обозначения любого винчестеpа легко pасшифpовать - они обычно буквенно-цифpовые и стpоятся по схожим пpинципам: вначале - обозначение пpоизводителя и модели, затем объем в миллионах байтов, и в конце - суффиксы, уточняющие исполнение, конкpетные хаpактеpистики и т.п. Hапpимеp, суффикс "A" указывает на интеpфейс ATA (IDE), а "S" - на SCSI. Суффикс "V" у многих моделей обозначает удешевленную (Value) модель, за исключением винчестеpов Micropolis, у котоpых суффикс "AV" обозначает Audio/Video - оpиентацию на pавномеpный обмен данными пpи чтении/записи. Примеры:

******* Western Digital *******
WD A C 2 635 - 0 0 F
1  2 3 4  5    6 7 8

1 - Western Digital
2 - интеpфейс: A - IDE, S - SCSI, C - PCMCIA-IDE
3 - модель: C - Caviar, P - Piranha, L - Lite, U - Ultralite
4 - количество физических дисков
5 - емкость в миллионах байт
6 - светодиодный индикатоp: 0 - нет, 1 - кpасный, 2 - зеленый
7 - пеpедняя панель: 0 - нет, 1 - чеpная, 2 - сеpая
8 - объем буфеpа: S - 8 кб, M - 32 кб, F - 64 кб, H - 128 кб.

Для восстановленных винчестеpов после даты изготовления указывается место
восстановления: E - Евpопа, S - Сингапуp.

******* Maxtor *******
Mxt 7 850 AV
1   2  3  4

1 - Maxtor
2 - сеpия (7xxx)
3 - емкость в миллионах байт
4 - суффиксы: A - ATA (IDE), S - SCSI, V - Value

******* Seagate *******
ST 5 1080 A PR -0
1  2   3  4  5  6
1 - Seagate Technology
2 - коpпус:
  1 - 3.5" высотой 41 мм
  2 - 5.25" высотой 41 мм
  3 - 3.5" высотой 25 мм или 5.7" глубиной 146 мм
  4 - 5.25" высотой 82 мм
  5 - 3.5" высотой 25 мм или 5" глубиной 127 мм
  6 - 9"
  7 - 1.8"
  8 - 8"
  9 - 2.5" высотой 19 мм или 12.5 мм

Вместо итогов обращаю Ваше внимание на ряд важных факторов:
  • на чрезвычайную чувствительность жестких дисков к различного рода встряскам, толчкам и ударам;
  • что винчестеры одной марки, но из разных стран резко отличаются по цене и качеству;
  • что не стоит покупать винчестеров "Made in China";
  • что если гарантия всего 6 месяцев, то эти винчестеры где-то долго лежали;
Личное мнение... жесткие диски, применяемые в обычных ПК, развиваются только в направлении повышения емкости одновременно со снижением стоимости. Скорость и надежность, к сожалению, отходят на второй план. В мире есть хорошие HDD, но предлагаемым на российском рынке "обывательским" винчестерам до них страшно далеко…

© Dmitry Belousov
http://www.orakul.spb.ru
ноябрь 2001г.-январь 2003г.


"Азбука РС" Дм.Белоусова, Floppy-дисководы

Мобильный дисковод

•

Floppy-дисковод
• 8 дюймов
• 5,25 дюйма
• 3,5 дюйма

•

Дисковод для ноутбуков
Магнитооптика

•

Iomega Zip
• V=100Mb
• V=250Mb
• V=750Mb

•

Разработки Fujifilm
32Мб от Panasonic-а

•

SuperDisk LS-120

•

Новые fdd-разработки
Накопители

•

Накопитель ORB

Накопители на гибких магнитных дисках (НГМД) называют дисководами для флоппи-дисков или используют аббревиатуру FDD (Floppy Disk Drive) от английского, что означает "дисковод для флоппи-дисков". Размеры Floppy-дисков удобны, цена невысока и они достаточно надежны в эксплуатации. При известной осторожности в обращении дискеты очень редко портятся. В мире насчитывается миллиарды (!) floppy-дискет. Мобильный дисковод нужен (в основном) для четырех функций:

  • для загрузки (запуска) ПК со специально подготовленной дискеты ("системной") в случае сбоя (при невозможности загрузки с жесткого диска);
  • для загрузки и инсталляции на ПК программного обеспечения;
  • для обмена данными с другими ПК (переноса информации на другой компьютер);
  • для резервного копирования ценной информации (создания на дискетах Ваших архивов данных - устарело), мало ли что случится с компьютером;
Некоторые известные торговые марки стандартного внутреннего Floppy-дисковода:
[ Samsung ] [ SONY ] [ NEC ] [ Mitsumi ] [ Panasonic ] [ Teac ] [ ALPS ]
Емкость 3,5-дюймовых дисководов (1,44 Мб) не такая уж маленькая. Ее вполне достаточно, чтобы перенести 500 страниц обычного текста или хорошую картинку. Вид двух 3,5" floppy-дисководов для большого (5.25") и малого (3.5") отсека корпуса:

Принципиально существует всего три типа накопителей на гибких магнитных дисках (8"-5,25"-3,5"). Накопители диаметром 8" (203 мм) и 5,25" (133 мм) давно устарели и более не применяются. Но диаметр 3,5 дюйма (89 мм) пока "живет", хотя корпорация Intel неоднократно принимала попытки "убить floppy-дисководы". В таблице представлена таблица соответствия некоторых типов дискет и дисководов.

Дискеты & дисководы | 5,25", DD | 5,25", HD | 3,5", DD | 3,5", HD | 3,5", HD2
5,25", DD | 360Kb | 360Kb | - | - | -
5,25", HD | 360Kb | 1,2Мb | - | - | -
3,5", DD | - | - | 720Кb | 720Кb | 720Кb
3,5", HD | - | - | 720К | 1,44Мb | 1,44Мb
3,5", HD2 | - | - | 720Кb | 1,44Мb | 2,88Мb

Сегодняшний стандартный дисковод является невообразимым анахронизмом. Нынешний стандарт на дисководы был выработан больше десятелетия назад и с тех пор нисколько не изменился. Изменились все остальные комплектующие, а дисковод как был, так и остался. Но раз нет нового стандарта - он будет "жить" и успешно продаваться. Дискета представляет собой круглый кусок гибкого пластика, покрытый магнитным окислом. Популярное название "гибкие" или "флоппи" - диски появилось из-за того, что этот кусок пластика - гибкий. Круглый диск с магнитным покрытием помещен в квадратный предохранительный конверт. Внутренняя поверхность этого конверта покрыта слоем белого фетро-подобного материала, помогающим в защите дискеты. Он служит как для смягчения ударов, так и для улавливания пыли. Квадратный предохранительный конверт (имеющий ныне любой цвет, ранее - только черный), имеет четыре отверстия, каждое из которых имеет свое назначение:

  1. Отверстие в центре предназначено для захвата дискеты приводом дисковода. Через это отверстие механизм дисковода захватывает гибкий диск, чтобы привести его во вращение;
  2. Второе отверстие в предохранительном конверте - продолговатая прорезь, через которую осуществляется доступ к дискете головок чтения/записи. Через эту прорезь осуществляется процесс чтения и записи информации;
  3. Третье отверстие представляет собой небольшую дырочку. Это отверстие в конверте позволяет следить за небольшим индексным отверстием в самой дискете. Индексное отверстие используется для указания начала и конца дорожки на дискете. Индексное отверстие служит для определения точки отсчета при чтении или записи информации;
  4. Четвертое отверстие - квадратная прорезь на краю предохранительного конверта - служит в качестве признака защиты записи. Если эта прорезь открыта, то запись на эту дискету может выполняться дисководом, если же она закрыта, то дискета защищена от записи.
Закрытая прорезь говорит только о том, что правильно работающий дисковод не будет пытаться выполнять запись на такую дискету. Неисправный дисковод может делать все что угодно, независимо от наличия или отсутствия признака защиты. Не держите дискеты рядом с источниками магнитного поля (раз). Не держите их на солнце или на батарее отопления (два). Не гните корпус дискеты, а для переноса в сумке используйте специальные коробки - box-ы (три).
О юстировке. Если дисковод разъюстирован, то Вы не сможете прочитать чьи-либо дискеты, а все остальные не смогут читать записи сделанные на Вашем дисководе. Юстировка - процесс сложный (требуется осциллограф). Легче купить новый дисковод.

         "... Изобретатель - друг Человека ..."

· 8" и 5,25" - история. Первое регулярное использование 8-дюймовой гибкой дискеты состоялось в 1971 году. Разработчик - группа инженеров IBM под руководством Алана Шугарта (Alan Shugart). Стандартов, определяющих размеры floppy-дисков, было разработано было множество, но победу одержали 8 дюймовые дискеты. Они и были приняты за стандарт. Сами диски изготавливались из тонкого пластика, покрывались оксидом железа, а затем упаковывались в пластиковые или твердобумажные пакеты - корпуса. Вся конструкция была довольно "жидкой" (отсюда и название floppy - гибкий). На ПК тогда устанавливали два дисковода 8": А и В. Жесткие диски в первых ПК вообще отсутствовали (их еще не создали!). С дисковода А грузилась операционная система (DOS), а с дисководом В велась вся остальная работа.
По типу 8 дюймовые дискеты делились на односторонние и двухсторонние. Были еще и такие двухсторонние дискеты, которые позволяли работать на дисководах, предназначенных для односторонних дискет. Объем дискет был от 400 Kb до 1,6Mb, в зависимости от типа. Для сравнения: 8 дюймовая дискета по объему хранения данных заменяла порядка 12.000 перфокарт или около 300 метров перфоленты. При этом допускалась еще и перезапись. Это была революция.

В 1976 году на смену 8-дюймовым floppy-дискам пришли 5,25 дюймовые. Преимущества новой технологии были очевидны. Корпус стал более жестким, внутри он был оклеен специальным материалом, который предохранял диск от чрезмерного износа. Первые 5,25 floppy-диски были односторонними и вмещали до 160Kb. Потом появились 180Kb, 360Kb, 720Kb и 1,2Mb-ные дискеты.

         "... Рожденный ползать, уйди со взлетной полосы! ..."

· Дисковод 3,5". В 1981 году, появились 3,5 дюймовые дискеты. Их корпус стал еще более жестким. В отличие от 5,25 дюймовых дискет, в 3,5 дюймовых диск защищен специальной подпружиненной шторкой. Сегодняшний стандарт настолько стар, что и писать о нём как о действующем как-то стыдно. Так как "микро-флоппи" заключены в твердую упаковку, строго говоря они не являются гибкими дисками. Но название прижилось. Сейчас все дисководы используют две головки чтения/записи и находятся они с двух сторон диска. Метод записи на диск называется туннельной подчисткой. Во время записи головки следят за тем, чтобы данные писались только в пределах заданной дорожки. Для этого применяется выравнивание дорожек, что предотвращает возможность "съезда" в сторону. Сначала пишется дорожка определенной ширины, а затем края этих дорожек подтираются. Это предотвращает влияние на соседние дорожки. Ширина дорожки 3,5 дюймовой дискеты объемом 1,44 Mb равна 0,115 мм. 3,5"-диски записывают 80 цилиндров и 160 дорожек, соответственно. Каждая дорожка имеет 18 секторов. Скорость передачи данных равна 500.000 бит/сек. Скорость вращения диска - 300 об/мин. Плотность дорожек равна 135 TPI (Track Per Inch - количество дорожек на дюйм), а линейная плотность равна 17.434 BPI (Bits Per Inch - битов на дюйм).
Существует несколько типов 3,5 дюймовых floppy - дисков: SS (Single Sided - односторонние), DS (Double Sided - двухсторонние), DD (Double Density - двойной плотности), HD (High Density - высокой плотности), EHD (Extra High Density - сверх высокой плотности). В данный момент применяются в основном только дискеты типа HD. Дискеты 3,5" поддерживают форматы 640Кб, 720Кб, 1,2Мб, 1,44Мб, но многие OS оставляют выбор только 720Кб и 1,44Мб.

В 1983 году были разработаны еще и 4 дюймовые floppy-диски. Но они большого распространения они не получили. Brand-производители 3,5" дискет:
[ Basf ] [ Maxell ] [ TDK ] [ Sony ] [ Verbatim ]

· Накопители Bernoulli. Это тоже уже история. Диски типа Bernoulli считаются самыми прочными и надежными из всех сменных носителей. По сути, они представляют собой гибкие диски, уложенные в жесткий футляр. Принцип работы дисков Bernoulli прост. Диск в накопителе вращается, опираясь на воздушную подушку, причем, зазор между диском и головками составляет доли миллиметра. Создаваемый вращающимся диском воздушный поток отклоняется определенным образом с помощью, так называемой, пластины Бернулли. Она неподвижна и располагается таким образом, что диск подталкивается воздушным потоком вплотную к головке, но не касается ее. Диск вращается очень быстро.
Фирма Iomega не случайно одной из первых представила накопитель со сменным магнитным носителем формата 3,5" - долгие годы она занималась разработкой и продажей накопителей типа Bernoulli с дисками емкостью 35, 65, 105 и 150МБайт.

         "... Истина может быть любой, только вот здравый смысл подсказывает другое ..."

· Iomega Zip. Компания Iomega создала абсолютно новое устройство, напоминающее по своему строению винчестер со сменными носителями. "Zip" по-английски значит: "мгновенно перемещать". Время доступа равно 29 мс, скорость передачи данных составляет 7 МБайт/с (при использовании интерфейса SCSI). При этом частота вращения диска составляет 2945 об/мин. В отличие от HDD, головки Zip не находятся все время в рабочей камере, они вводятся во время работы в картридж и выводятся после окончания работы с Zip Iomega. В дисках Zip используются тонкие магнитные покрытия с высокой коэрцитивной силой. Zip-дисковод очень чувствителен как к количеству включений-выключений, а внутренние накопители лучше защищены от внешних воздействий.
Технология Zip за почти 10 лет, что прошли с выхода в свет первого накопителя, стала достаточно отработанной и устойчивой, хотя ZIP-диски и не смогли вытеснить стандартные дисководы с рынка. Zip - без 5 минут стандарт: внутренние дисководы ZIP давно уже устанавливаются в новые ПК вместе со стандартным дисководом 1,44Мб. Вид двух внешних Zip-ов (современного и старого):

Защита Zip-диска от записи - с помощью ПО. Основные достоинства: простота установки и эксплуатации, очень хорошее программное обеспечение, приличное быстродействие. Основные недостатки: несовместимость со старым флопиком, температурная нестабильность дискет, "щелчки смерти". ZIP (бывает внутренний и внешний) выпускается с четырьмя интерфейсами:
  • параллельного порта (LPT, Parallel), скорость передачи данных ограничена скоростью параллельного порта;
  • порт USB;
  • через SCSI-карту (требуется). Iomega предлагает недорогой SCSI адаптер Zip Zoom SCSI Accelerator. Но работает практически с любым стандартным ASPI-совместимым SCSI адаптером;
  • на IDE-шине;
Поддерживается OS DOS, Windows, OS/2, Novell, Mac. Специальный соединитель позволяет одновременно подключить-использовать и привод Zip и принтер. Для глупой Windows проверяйте, не слишком ли старый у Вас драйвер. Начиная с версии 5.62 они работают в 4 раза быстрее. Если при копировании большого файла светодиод доступа к Zip мигает, а не горит постоянно, то смело набирайте (www.iomega.com) и качайте свежий драйвер. Пока наилучшее применение накопителей Zip – это перенос информации.

· "Щелчки смерти" (Click Of Death, Click Death, COD) или бывшие проблемы. Технология Iomega сумела излечиться от множества болезней, в т.ч. от самой страшной - "щелчков смерти". COD - когда устройство начинает испускать ряд слышимых и легко различимых щелчков. Это происходит при вставке диска или при попытке читать/писать данные на уже вставленном диске. Минуты (часы или дни) проходят после того, как щелканье было услышано впервые, как вдруг устройство (и обычно один или несколько дисков) - внезапно умирает без предупреждения. Было много суеверия и мифологии. Но все просто. Устройства Iomega Zip and Jazz начинают щелкать из-за неправильной записи на сменный носитель. Звук щелчка есть ничто иное, как звук щелканья головок, когда головки входят в картридж диска, а затем возвращаются. Звук щелчка сам по себе - НЕ проблема. Щелчок - только слышимый признак того, что устройство имеет проблемы с доступом к данным этого диска (Zip-а, Jazz-а). "Щелчки Смерти" не заразны! Но напр. если диск, который щелкал в одном устройстве, вставить в другое устройство и там щелчки тоже будут, это не означает, что это второе устройство теперь инфицировано Click Death. Но повреждение, которое было нанесено диску в первом устройстве, сделало диск неудобочитаемым любым другим устройством, которое также "щелкает", поскольку пробует получить доступ к данным поврежденного диска. Это - ошибка первого устройства, которое сделало повреждение, но теперь любое устройство будет щелкать при попытке доступа к данным этого диска.
Диагностика... Инженер Стив Гибсон в 1998 году создан программу "Trouble In Paradise"(tip.exe, 66 Кб), которая является высокоэффективным средством предсказания и предотвращения потерь для Zip100. Производитель (Iomega) выпустила уведомление о желательности периодических визуальных проверок дисков на наличие видимых повреждений (порывы, неровные края, задиры, отсутствующие места).
Что делать... Я советую уже при первом щелчке выбрасывать этот диск (Zip100). И лучше пользоваться новым 250Мб-дисководом.

· PocketZip (iOmega Clik!). Емкость сравнительно небольшая, 40 Мб. Средняя скорость передачи данных до 600K/sec, скорость вращения 2941 RPM, реднее время доступа менее 25 ms, защита от записи - с помощью ПО. Формально позиционируется Iomega как устройство для использования с цифровыми фотокамерами, но его также можно применять для переноски файлов ПК-ПК. Но накопитель и дискеты очень небольшого размера. Полный комплект оборудования (называется Drive Plus) стоит около $300. Интерфейс у PocketZip-а:
- параллельный порт (LPT, Parallel);
- USB-порт;
- PC CArd (для Notebook-а);
Для соединения PocketZip PC CARD (т.е. при интерфейсе PCMCIA) с обычным ПК используется специальная док-станция, подключаемая к USB-порту настольного компьютера. Иногда она поставляется в комплекте с PocketZip. Футляр для переноски дисковода и одного диска - очень стильная вещица из алюминиевого сплава, внутри у нее сделанные из резины посадочные места.
Подключение и отключение полностью Plug&Play - установка дисковода сводится к установке комплекта драйверов IomegaWare. Но фактически, USB док-станция не активна до тех пор, пока со своей частью ATAPI к ней не присоединится дисковод. Кстати, не найдя диска в дисководе, дурная OS Windows начинает постоянно опрашивать дисковод о том, есть ли в нем диск и жутко тормозит.

На основе технологии Clik! ведется разработка MP3-плееров, которые должны одновременно выполнять роль дисководов для дискет Clik! для подключения к ПК. Пока PocketZip занимает небольшую нишу на рынке цифровых камер.

         "...Удача сваливается на голову тому, кто умеет ждать..."

· SuperDisk LS-120 Технология SuperDisk-a разработана группой производителей (Compaq, Imation, Matsushita, O.R. Technology) исключительно с целью замены обычных дисководов гибких дисков 1.44МВ. Дисковод LS-120 опоздал с выходом на рынок, но его совместимость с флопиком дает положительный результат - он покупается.
Технология LS-120 Laser Servo основана на уникальной комбинации оптической и магнитной технологии записи данных. На поверхности дискеты LS-120 нанесены высокоточные оптические дорожки, которые не несут никакой полезной информации, и используются лазерной следящей системой дисковода для высокоточного позиционирования магнитной головки на нужную дорожку. Отсюда и название Laser Servo (LS, Оптическая Система Слежения). Оптические треки с высокой точностью наносятся на дискету на заводе, и не могут быть случайно стерты или перезаписаны пользователем. Если в привод вставлена дискета LS-120, то лазерная система слежения обнаруживает наличие оптических дорожек на поверхности диска, и очень точно позиционирует головку дисковода на нужный трек. Подобная система слежения с высокоточным позиционированием позволяет намного увеличить плотность дорожек на диске. На поверхности дискеты LS-120 умещается 2490 дорожек на дюйм (у обычных дискет 1.44Mb HD - всего 135 дорожек на дюйм). Треки с данными записываются обычным магнитным способом.

SuperDisk LS-120 является единственной технологией для внешних носителей высокой емкости, позволяющей читать и записывать как дискеты LS-120, так и обычные дискеты 3.5" высокой и двойной плотности. Это обеспечивается применением специальной двухзазорной магнитной головки. Скорость вращения диска увеличена в несколько раз, что позволяет работать с дискетами на большей скорости, чем в обычном дисководе. Естественно, на обычную дискету нельзя записать больше 1.44Mb. На дискеты LS-120 c лазерной разметкой умещается 120Mb данных. Для магнитной записи высокой плотности поверхность этих дискет покрывается по специальной двухслойной технологии высококоэрцетивным металлическим составом. Магнитный слой наносится на тонкую 0.0025 дюймовую полиэтиленовую подложку. Дискеты LS-120 выглядят так же, как обычные и имеют окошко защиты от записи. Современные материнские платы поддерживают загрузку с LS-120. Варианты накопителей LS-120:

  • ATAPI IDE - внутренний накопитель. Устанавливается на место обычного 3-х дюймового дисковода, подсоединяется как master- или slave-устройство на IDE-канал;
  • PCMCIA - внешний накопитель с автономным питанием и интерфейсом PCMCIA Type II;
  • Parallel port - внешний накопитель с автономным питанием, подключается к PC через параллельный порт;
LS-120 превосходит 120Мбайтным объемом старые 100-Мбайтные Zip-диски, но проигрывает новым 250-Мбайтным. Самое главное - использует стандартные дискеты. Но LS-120 имеет и ряд недостатков: среднее время доступа втрое больше, а максимальная скорость передачи данных в 2,5 раза меньше, чем в SCSI-моделях Zip. Стоимость дискет почти одинакова. В настоящее время Compaq и Dell встраивают дисководы LS-120 в некоторые модели своих ПК. O.R.Technology поставляет LS-120-совместимое устройство FD-3120A в качестве отдельного продукта. Panasonic, Toshiba и Twinhead поставляют LS-120 для Notebook-ов. Mitsubishi и Hitachi-Maxell имеют производство и дисководов и дисков LS-120. В России LS-120 пока мало популярен.
Некоторые технические характеристики | LS-120 | FDD 1.44
Форматируемая емкость | 120 Mb | 1,44 Mb
Максимальная скорость передачи данных | 565 Kb/sec | 63 Kb/sec
Среднее время поиска | 65 msec | 84 msec
Переход "дорожка-дорожка" | 6 msec | н/д
Скорость вращения диска | 720 rpm | 300 rpm
Количество дорожек | 1736 | 80

         "... пришел, увидел, побледнел ..."

· ORB от Castlewood или накопитель на съемных дисках. Основан на применении магнито-резистивной головки - magnetoresistive (MR) head technology. Это накопитель на сменных дисках со скоростью вращения диска - 5400 оборотов в минуту. Применение этой технологии позволять концентрировать больше данных на ед. площади, а от этого диски стали компактней и объемнее. Сама головка разделена на две части - считывающая узкая и записывающая широкая, что вкупе с особо точным механизмом перемещения головки существенно понижает время доступа и повышает быстродействие.

Емкость 2.2GB для трехдюймового диска, приемлемая цена как на устройство (около $200), так и на диски к нему ($30). Варианты интерфейсов накопителей ORB:
  • внешний накопитель (External Parallel Port) с автономным питанием, подключается к PC через параллельный порт (Parallel port);
  • внутренний накопитель ATAPI IDE (Internal EIDE). Устанавливается на место обычного 3-х дюймового дисковода, подсоединяется как master- или slave-устройство на IDE-канал;
  • внешний накопитель с интерфейсом USB;
  • через SCSI-карту (External SCSI, Internal SCSI);
  • через FireWire-порт (IEEE 1394 FireWire);
Для IDE-модели никаких драйверов не требуется. Скорость передачи данных - до 12.2 Мб/с (2 Мб/с -LPT). Поддерживается OS DOS, Windows, OS/2, Mac. Время ожидания при загрузке и извлечении диска - около 10 сек. Стоит он почти в 2 раза дешевле вышеупомянутого JAZ-а при лучших технических характеристиках. Полный набор драйверов и всяких полезных "тулзов" тоже прилагается, а также в комплекте идет 2,2GB (!) дискетка. При использовании файловой системы FAT16 емкость ограничена 2.16Гб. Фактически при такой цене он становится убийцей и JAZ- и Zip-накопителей. Правда есть тревожащие слухи о существовании у ORB проблемы порчи магнитного слоя головкой (cходная с HiFD), но они пока официально не подтверждены.

         "... Один мегабайт плохо, да и 32 - не лучше ..."

Аргументы "за" новые разработки: LS-120 все так и не стал стандартом, а Zip не совместим с "флопиком". Так никто пока не смог делать дешевый и совместимый с floppy-дисками дисковод. Нам все еще нужна старая floppy-поддержка. По непонятному стечению обстоятельств аутсайдерами являются совместимые с флоппиком устройства, а лидерами - не совместимые. Уже появились "потерпевшие", но, не смотря на это, сотни тысяч ПК продолжают комплектоваться драйвом 3,5" 1,44Мб. Возможность записать на простую дискету побольше привлекает доступностью и дешевизной носителей информации, однако повсеместное распространение CD-RW (во-первых) и бурное развитие миниатюрных накопителей (во-вторых) резко сужает перспективы внедрения подобного.

· HiFD-дискета от Sony уже была в продаже, но очень скоро все накопители были отозваны. В связи с технологической недоработкой (перекос головки) получалось, что головка сдирает магнитный слой и через некоторое время HiFD-дискета становится непригодной.

· UHC31130 130Mb от Mitsumi (аналог Zip + флопик) так и не поступил в продажу. Mitsumi, ведущий изготовитель стандартных floppy-дисководов, разработал дисковод нового поколения. Новый дисковод имел в 90 раз большую емкость, чем стандартный floppy-диск и совместим с существующим старым форматом 1.44M /0.72Mb. Mitsumi объединило свою собственную технологию NCCI с технологией движка, которая разработана ANTEK - Корпорацией Периферийных Устройств из Калифорнии. Реально емкость носителя данных после форматирования все же 128Мб, а 150Мб - неформатная емкость. Скорость - 2.45 Мб/с, время доступа 20 msec. Теперь это только история.

· UHD 144Mb от Caleb Technology не поступил в продажу, хотя есть опытные образцы. Caleb UHD144 совместим со стандартным floppy-диском и для легкой интеграции имеет IDE/ATAPI интерфейс с поддержкой Bios и устанавливается аналогично LS-120. Скорость вращения шпинделя возрасла всего лишь с 600 до 1000RPM, а вот плотность записи со 135 до 2705 TPI. Выбор размера 144MB - сильный маркетинговый ход для легкой узнаваемости.

· Накопитель Pro-FD 123Мб от Samsung (совместимый с флопиком). Носителю не требуется специальная дорожка для позиционирования головки и он своей высокой возможности (емкости и скорости) будет достигать благодаря своему механизму записи. Ожидается, что дискета 123Мб будет продаваться за менее чем $10. Pro-FD обещает двоекратное ускорение чтения/записи floppy-дисков, а с новыми 123 MB floppy-дисками, он обеспечит скорость до 5 MB/s. Samsung пытается сделать такой, чтоб стоимость его приблизилась к отметке $50 за дисковод и $2 за дискеты. Пока остается в проекте.

· 3Гб дискеты от Fujifilm. В ноябре 2001г. компания Fujifilm сообщила о новой разработке - технологии Nano3 (Nano Cubic), позволяющей получить тонкопленочный (толщиной в несколько микрон) дисперсный слой из магнитных микрочастиц. Nano3 позволит выпускать стандартные дискеты 3,5" с емкостью 3Гб (!). Конечно же, 3Гб дискеты - пример. Fujifilm планирует использовать Nano3 во всевозможных носителях, которые могут понадобиться рынку. Был бы спрос.
Nano3 (Nano Cubic) является развитием запатентованной Fujifilm в 1992 году технологии сверхтонкого металлического покрытия ATOMM (advanced super thin layer and high output metal media), которая сейчас применяется в дисках Zip100 и Zip250, а также в ленточных картриджах DLTtype (40 Гб). Усовершенствования, примененные в Nano3, коснулись не только уменьшения толщины покрытия по сравнению с ATOMM; для создания надежного покрытия Fujifilm будет применять смесь из двух магнитных материалов: сплава ферромагнетика с игольчатой структурой частиц диаметром порядка 10 нм - 30 нм и "дискообразных" частиц феррита бария. Помимо этого, не обошлось и без разработки специального связывающего частицы высокомолекулярного материала (клея), позволяющего "уложить" 10 нм -30 нм частицы в однородную массу.

· 32Мб дискеты от Panasonic. Не дождавшись различных сменщиков 1.44Мбайт дисковода, в октябре 2000г. компания Andy Matsushita-Kotobuki Electronics Industries (американское отделение Panasonic) объявила свой вариант - технологию FD32MB. Она позволяет записывать на самую обычную дискету 3.5" 32 Мбайт данных - за счет использования специального дисковода, использующего для чтения специальные магнитные головки для чтения. Технически принцип работы заключается в разбиении области дискеты при форматировании не на 80, а на 777 дорожек. Данная технология уже сейчас используется в устройствах SuperDisk. Суть в самом простом увеличении плотности записи: количество секторов увеличивается с 36 до 53 на дорожку, емкость дорожки - с 9,2 до 27 Кбайт.
Это отдельное устройство и upgrade существующих дисководов невозможен. Он рассчитан также на чтение дисков SuperDisk объемом 120 и 240Мб. Цена устройства - 200 долларов. Файлы на таких дискетах будут пока доступны "только для чтения" и для новой записи перезаписи будет требоваться форматирование.

Вместо эпилога... Еще одна из причин по которым плохо приживаются в компьютерах новые сменные накопители это то, что все они имеют интерфейс IDE и SCSI, а не устаревающий интерфейс FDD и в связи с этим есть некоторые нюансы при работе со старыми программами, которые используют прямой доступ к флоппи-контроллеру (адреса и прерывание 6). Витающая в воздухе идея о третьем канале IDE (соответственно третьем разъеме - Disks IDE) кроме двух стандартных (Primary IDE, Secondary IDE) продолжает витать в воздухе. Задача проста - добавить третий контроллер с адресами и прерыванием используемым флоппи-контроллером. Достаточно в Bios добавить две строки устройств и вкл/выкл контроллеров FDD и IDE AB. Но ни один разработчик на это никак не отреагировал.
Война за возможность стать наследником старого флоппи-дисковода продолжается.

© Dmitry Belousov
http://www.orakul.spb.ru
ноябрь 2001г.-июнь 2002г.


"Азбука РС" Дм.Белоусова, UPS-ы

UPS-ы (ИБП)

•

UPS On-line (тип standby)

•

Интерактивные UPS

•

Программы для ИБП
Сетевые фильтры

•

UPS Off-line

Данная классификация принята большинством ведущих UPS-производителей и UPS-дистрибьюторов. Но имеется и альтернативное деление, продвигаемое некоторыми производителями:
· сетевые ИБП для серверов и рабочих групп;
· ИБП для рабочих станций;
· ИБП для домашних ПК;
Но в альтернативной разбивке границы этих категорий весьма размыты и зачастую устройства относят к той или иной группе, основываясь только на их мощности.

 "... Бесполезно придумывать защиту от дурака - ведь дураки так гениальны ..."

· UPS-ы (Uninterruptible Power Supple, источники бесперебойного питания, ИБП, источники непрерывного электропитания, ю-пи-эс) - это устройства, предназначенные для временного поддержания работы электроприборов (компьютеров и пр.) при сбоях электропитания. В отличие от основных периферийных устройств, UPS-ы подключаются к компьютеру в зависимости от конкретных нужд пользователя.
Скачки напряжения представляют серьезную угрозу для Вашей электроники, компьютеров и периферии. Они возникают и из-за помех (работы бытовых электроприборов, разрядов молний, кратковременных скачков, etc.), но чаще всего - по вине компаний, поставляющих электричество в жилые помещения. Еще есть электромагнитные помехи (EMI) и радиопомехи (RFI) от бытовых приборов, электроники, механизированного оборудования и радиопередатчиков, которые сильно мешают работе компьютеров и разрушают целостность файлов. Т.е. проблемы с питанием компьютера хотя и внешне могут быть незаметны для Вас, но способны нанести серьезный урон - как оборудованию, так и информации. По данным компании APC, около 80% сбоев (!) на ПК инициированы проблемами питания.

В состав UPS-а входят следующие элементы: входной фильтр, аккумуляторная батарея (АБ) с зарядным устройством (ЗУ), инвертор, схема управления работой. В некоторых моделях также имеются: преобразователь постоянного тока (конвектор) и трансформаторные развязки выхода от входа. Любой UPS характеризуется четырьмя основными параметрами:
  • требуемая мощность определяется как сумма мощностей всех устройств, питающихся от UPS-а. Выражается в вольт-амперах (VA, ВА). Обычно мощность отдельного устройства указывается на задней панели каждого устройства в ваттах (W) или вольт-амперах. Если мощность указана в W, то для старых BAT-корпусов цифру нужно умножить на к-т 1,4 - для перевода в VA. Для импульсных блоков питания (т.е. ATХ-корпусов) коэффициент мощности близок к единице. Точнее - 0,7 плюс корректор (PFC - Power Factor Corrector).
    По опыту - для питания обычного ПК с 15" монитором достаточно UPS-ы мощностью 400 ВА.
  • время автономной работы (Back-up Time, время работы в резервном режиме) зависит от емкости используемых батарей и коэффициента полезного действия инвертора. Время автономной работы указывается в минутах или часах и минимально при максимальной мощности нагрузки, а растет с ее уменьшением. Емкость батареи кроме времени поддержания нагрузки, определяет жизненный ресурс батареи, т.к. от емкости зависит количество полных разрядно-зарядных циклов. Сам UPS тоже потребляет энергию и имеет потери, поэтому даже без нагрузки время работы в резеврном режиме - конечно. Принято указывать время при нагрузке 100% и 50% отноминальной.
  • форма выходного напряжения или качество электроэнергии. Идеальной является четко синусоидальная форма напряжения, которая имеет значение 220В, максимальную амплитуду 311В и частоту ровно 50Гц;
  • время переключения (Transfer Time), измеряется в миллисекундах. Может существенно превышать (!) среднее значение, которое указывают производители. Этот параметр важен только для коммутирующих UPS-ов, т.е. там, где при нормальной работе нагрузка подключена непосредственно к электросети и лишь при сбоях в сети или при прекращении подачи электроэнергии UPS переключается на питание от батарей;
В последние годы наблюдается массовый поток ИБП из малоизвестных фирм Тайваня и Кореи, изготавливающих недорогие UPS-ы. Но мировой лидер на рынке ИБП - APC (особенно маломощных UPS-ов). Главные производители (что получше - выделено синим цветом):

[ APC* ] [ Best Power ] [ Centralion ] [ Chloride ] [ Deltec ] [ Eline Power ] [ Emerson ] [ Exide ] [ Fiskars ] [ Galatrek ] [ IMV ] [ Inelt ] [ Invensys Powerware ] [ Ippon ] [ MGE ] [ Liebert ] [ NeuHaus group ] [ N-Power ] [ PowerCom Co., Ltd ] [ PowerMan ] [ Powerware ] [ Pulsar ] [ Riello ] [ Socomec Sicon ] [ Tripp Lite ] [ Liebert ] [ ИНЭЛТ ]

* APC - это компания "American Power Conversion".
Подключение UPS-а к компьютеру может быть как только "силовым" (через розетки , вне зависимости от OS), так и "силовым" плюс связь с компьютером (кабель через последовательный или USB-порт). Розетки UPS-а могут различаться: с питанием от батарей и защитой от скачков напряжения или только с защитой от скачков напряжения. Связь с компьютером через кабель нужна для работы бесплатного программного обеспечения, поставляемого вместе с ИБП. Она обеспечивает упорядоченное отключение системы в случае длительного сбоя электропитания. Программа автоматически сохраняет открытые файлы, закрывает запущенные приложения и корректно завершает работу операционной системы, тем самым защищая от повреждений жесткий диск и Ваши данные. Несмотря на однотипность конструкции и несущественно отличающиеся характеристики ИБП одного класса, модели от разных производителей обладают особенностями, о которых можно узнать только с помощью специальных тестов. Это формы кривых напряжения и тока при разных режимах работы, характере переходных процессов при переключениях режимов, а также время автономной работы от батарей под нагрузкой. Данные о популярности UPS-ов в Европе:

"... А для Виндов, что сорвались и падают, есть только миг, ослепительный миг ..."

· UPS On-line (тип standby, резервные). Работают по принципу подавления электрических помех и включения встроенного аккумулятора как резервного питания. Т.е. в нормальном режиме нагрузка подключена непосредственно к электросети, а при сбоях в сети (или при выходе напряжения сети за заранее определенные параметры) или при полном пропадании входного напряжения переключается на питание от батарей. Обычный путь энергии пролегает через подавитель импульсов и радиочастотный фильтр.
Недостатки:

  • разрыв кривой выходного напряжения при переходе с линии на инвертор и обратно. Т.е. во время переключения возникает разрыв напряжения на 1-5 мс. Для системных блоков компьютеров (имеющих свой блок питания) в большинстве случаев это не критично, но очень критично для питания ЖК-мониторов, подключаемых к электросети напрямую.
  • низкие характеристики встроенного фильтра. Т.е. если место (дом, работа) расположены близко от электросварочных и т.п. агрегатов, холодильных установок и даже просто мощных кондиционеров, UPS не справится с входными помехами и просто передаст их дальше.
  • напряжение может в пределах допустимого коридора гулять как угодно.
  • форма выходного напряжения при питании от батареи или несинусоидальность. Т.е. вместо ровной синусоиды форма представляет собой напр. трапецию.
К достоинствам данного типа относятся минимальный вес и габариты, простота схемы, высокий КПД, относительно низкая цена. Реально при переходе на резервное питание такой UPS годен только для аврального завершения всех программ и парковки компьютера. Лучшее применение - периферия (напр. оргтехника). Но сегодня это самые простые и "дешевые" UPS-ы, и к сожалению - самые популярные.

"... Для перехода к следующей ошибке нажмите кнопку ДАЛЕЕ ..."

· Интерактивные UPS (линейно-интерактивные, line-interactive) - это разнообразные гибриды UPS-standby и UPS-Off-line. Их объединяет только то, что являясь по схеме UPS-standby, они выдают на выходе более-мене стабилизированное напряжение при питании от сети. Достигается это встроенным стабилизатором напряжения (AVR). Стабилизатор позволяет держать более стабильным выходное напряжение питания и внедрена улучшенная схема при переходе на питание от батареи. У данных UPS наилучшее соотношение цена-производительность. Линейно-интерактивные UPS-ы по схемотехническим признакам делятся на три группы, различающиеся формой выходного напряжения:

Интерактивные UPS

•

Со ступенчатой формой

•

С синусоидальной формой

•

С феррорезонансной стабилизацией

Интерактивные UPS-ы со ступенчато-апроксимированной формой выходного напряжения отличаются от UPS-ов типа standby лишь двумя плюсами:
a) имеют стабилизированное выходное напряжение;
b) заряжают свою батарею от обратной стороны инвертора, что позволяет избавиться от громоздкого зарядного устройства;
Сам инвертор постоянно подсоединен к выходу, обеспечивая дополнительные стабилизационные характеристики. Интерактивные UPS-ы с синусоидальной формой выходного напряжения в свою очередь отличаются от первой группы двумя основными качествами:
c) синусоидальная форма выходного напряжения в любом режиме работы;
d) развитый интерфейс;
По сути эти две группы обладают наилучшим соотношением цена-качество. Именно интерактивные UPS-ы пока являются лучшей первой покупкой.

Отдельной группой стоят интерактивные UPS-ы с с феррорезонансной стабилизацией выходного напряжения, прекрасно работающие с линейными блоками питания нагрузки. Схема такого UPS-а отличается от UPS-ов типа standby лишь тем, что на выходе стоит феррорезонансный трансформатор и инвертор подключается к одной из двух его первичных обмоток. Ранее считалось, что энергии, запасенной в феррорезонансном трансформаторе достаточно, чтобы обеспечить без-обрывную синусоиду выходного напряжения при пропадании напряжения на входе и переключении устройства на батарею. Это верно только изредка, напр. при выдергивании вилки UPS-а из розетки. Чаще всего, учитывая высокое внутреннее сопротивление ферротрансформатора, энергия мгновенно закончится. При этом время переключения на батарею в несколько раз выше, чем у UPS-ов типа standby (порядка 20-30 мс). Это переключение к тому сопровождается дополнительным разрядом батареи на насыщение сердечника трансформатора и броском напряжения в начальный момент времени. В довершении минусов следует отметить, что ферротрансформатор является нелинейным элементом и как следствие вносит свои нелинейные искажения в нагрузку. Достоинствами феррорезонансных UPS-ов являются их отличные изолирующие и стабилизирующие характеристики (превосходящие другие интерактивные UPS-ы). Такой UPS может отлично заменить дорогостоящие фильтро-симметрирующие устройства, служа согласующим устройством между нелинейной нагрузкой и первичной сетью (напр. мотор-генераторами). Для компьютерной техники эти UPS-ы уже неинтересны.

"... Жизнь - игра. Сюжет конечно хреновый, но зато какая графика! ..."

· UPS Off-line генерируют собственное, стабильное по амплитуде и частоте синусоидальное напряжение. Напряжение от сети выпрямляется и питает выходной инвертор, а часть энергии расходуется на заряд батарей. При пропадании входного напряжения выходной инвертор запитывается от батарей с нулевым временем переключения. На выходе и входе цепи часто имеются трансформаторные развязки. Таким образом, параметры выходного напряжения формируются только самой схемой ИБП и никак не зависят от параметров входного напряжения. Говоря по другому, устройства изолируют потребление от внешней сети, используя высокочастотную технологию регенерации. Схема построена по принципу двойного преобразования энергии, напр. переменный ток в постоянный и обратно. "На выходе" таких UPS-ов получается идеальная синусоида. Источники с двойным преобразованием позволяют полностью исключить амплитудные и частотные искажения при работе в слабых и нестабильных сетях. Плюс они защищают внешнюю корпоративную сеть от помех, создаваемых нагрузкой, а саму нагрузку защищают от несанкционированного доступа со стороны внешней сети.
К недостаткам относят меньший, чем у других схем, КПД из-за двойного преобразования энергии, более высокую сложность, а следовательно - цену. Стоимость данного класса в 2-3 раза превышает цену UPS-standby-аналогов. ИБП этого типа используют только там, где предъявляются высокие требования к качеству электропитания (серверы сети, медицинское оборудование, схемы управления важными тех.процессами), а также в случае слабых и нестабильных электросетей, например при питании от дизель-генератора. Увы - для России это лучшие UPS-ы.

"... Три пальца... Да не в рот! Нажать на клаве! ..."

· Программное обеспечение ИБП предназначено для конфигурирования, оперативного мониторинга состояния системы питания, корректного выхода из приложений, с которыми работал пользователь, и автоматического завершения работы OS в случае длительного отсутствия напряжения. Кроме того, большинство программ, предназначенных для совместной работы с ИБП, ведут протокол событий, связанных с работой ИБП: включение/выключение, переход на питание от батареи и обратно, результаты тестирования и т.д. Многие программы позволяют вывести на экран монитора график входного и выходного напряжения за любой период, что облегчает анализ качества электроснабжения. Часто встречается такая функция, как возможность задания расписания автоматического включения и выключения ИБП или проведения авто-тестирования.
Главное, чтобы помимо параметров сети можно было всегда проконтролировать ресурс батареи (т.е. оставшееся время автономной работы при пропадании в сети напряжения), степень заряда при зарядке батареи, потенциальную энергоемкость для контроля степени устаревания батареи и процент подключенной нагрузки от максимально допустимой. Кроме того, программа должна успевать корректно закрывать приложения и саму операционную систему.
Производители создают программу, работающую под одним типом операционных систем. Как правило, это Mac OS (9,X), OS Windows (9x/ME/2000/XP), OS Linux. Раньше еще был OS Novell и OS/2.

· Bypass - режим обхода основной схемы, включающийся автоматически при существенной перегрузке или в случае неисправности самого ИБП, что предохраняет нагрузку не только от неполадок в сети, но и от выхода из строя основных узлов ИБП.

· Батарея - наиболее капризный и часто выходящий из строя элемент ИБП. Жизненный цикл свинцово-кислотных батарей, используемых в большинстве ИБП, составляет 3—6 лет. На разницу оказывает влияние температура внутри батареи и напряжение подзаряда. Например незначительное отклонение напряжение подзаряда от оптимального приводит к ускоренной коррозии решеток и расходу электролита. Почти все современные ИБП с двойным преобразованием оснащаются микропроцессорами, обеспечивающими температурно-компенсированный заряд батарей, их авто-тестирование, контроль циклов заряд/разряд, регулирование напряжения окончания заряда, расчет времени автономной работы. В ряде UPS-ов предусмотрена функция предупреждения о приближающейся "смерти" батарей. Существуют также никель-кадмиевые батареи (в 3—5 раз дороже свинцово-кислотных), литиево-ионные (преимущественно в ноутбуках), железоникелевые, свинцово-цинковые. Из новых технологий: воздушно-цинковые и протон-полимерные электрохимические батареи.

· "Холодный" старт - функция, реализованная почти во всех современных ИБП. Достаточно нажать кнопку включения — и Ваша домашняя электростанция в течение нескольких минут (в зависимости от мощности батарей и нагрузки) обеспечит электроэнергией компьютер или факс.

· Сетевые фильтры - устройства подавления электропомех, наложенных на основную кривую питающего напряжения. Амплитуда таких помех - до 10В. Сетевые фильтры также подавляют импульсы высоких энергий. Сетевой фильтр нельзя назвать UPS-ом! От простейшего UPS-а типа standby фильтр отличается отсутсвием резервного источника энергии (батареи) и стабилизатора напряжения. На мой взгляд, сетевые фильтры хорошее дополнение к UPS-ам, которые удобно использовать как развлетвители ("тройники"). Например, к одной из розеток фильтра подключается UPS (для системного блока и монитора), к другой - принтер, к третьей - сканер и т.п.

· Инвертор - устройство для инвертирования тока или напряжения. Различают инверторы зависимые (ведомые электрической сетью) и автономные. В зависимых инверторах между источниками постоянного и переменного тока включены управляемый вентиль, сопротивление и катушка индуктивности. Машина переменного тока работает как генератор, а постоянного тока - как двигатель. В режиме инвертирования (позднее зажигание вентиля) машина переменного тока работает как двигатель, а постоянного тока - как генератор. Для перехода от выпрямления к инвертированию необходимо еще изменить либо полярность напряжения со стороны постоянного тока, либо направление тока вентиля.

· Электричество в России - крайне скверное (мягко говоря). Чаще всего даже стандартное сетевое напряжение - или пониженное (напр. 205В-210В) или повышенное (напр. 230В-235В). Поэтому необходимо или использовать интерактивные UPS (со встроенным стабилизатором), или UPS Off-line (c двойным преобразованием). Но в любом случае Вам необходим UPS, который может работать в широком диапазоне входного напряжения, не переходя при этом на батареи. Поймите, UPS Вам нужен не только тогда, когда напряжение полностью исчезает, а главным образом - для повседневного получения "чистого" от помех электропитания.

В заключение - кто так и не понял, чем отличаются категории UPS-ов - вот схема работы каждого типа:

Вместо итогов обращаю Ваше внимание на ряд важных факторов:

  • внимательно смотрите на название торговой марки. Например есть PowerCom, есть Powerware и есть PowerMan. И только один из них хороший;
  • приобретайте ИБП, мощность которого всегда больше суммарной мощности Вашей нагрузки. Хотя бы на 30%;
  • малоизвестные азиатские ИБП стоят меньше нормальных почти в два с лишним раза, но и толку от них никакого. О их качестве вообще молчу. Место их - в помойке;
  • продавцы для Вас назовут лучшим абсолютно любой ИБП, напр. даже обычный фильтр. Не слушайте их бред, читайте характеристики UPS-ов и сравнивайте;
  • отнеситесь к установке UPS-а для ПК как к вопросу установки сигнализации на автомобиль. Это затраты обязательные!
Личное мнение... Пользователь, столкнувшийся с потерей данных в результате внезапного, пусть и очень кратковременного, пропадания напряжения в сети, уже сам сделал вывод в пользу приобретения UPS-a. Ну а в сегодняшней России (с главным "рыжим" энергетиком) иметь компьютер без UPS-а - это просто самоубийство.

© Dmitry Belousov
http://www.orakul.spb.ru
ноябрь 2001г.-май 2003г.


"Азбука РС" Дм.Белоусова, OS от MS

Хиросима - 1945
Чернобыль - 1986
MS Windows - 1995 		"Азбука РС"

Операционные системы от Мicrosoft-а

•

МS DOS
• Norton
• Windows X

•

МS Windows NT2

•

МS Windows Longhorn

•

МS Windows 95

•

МS Windows NT3

•

МS Windows Blackcomb

•

МS Windows 98

•

МS Windows NT4

•

МS Windows ME

•

МS Windows 2000
"мастдай"

•

МS Windows XP

•

МS Windows Yukon

Т.о. наглядно видны три "линейки" операционных систем от МS. Как бы одинаково не выглядели они внешне, это принципиально разные системы!

         Все люди Земли делятся на две категории: первые не знают, кто такой Билл Гейтс, а вторые его очень не любят.
Немного из истории ... или кто же в действительности создавал идеи, прославившие Мicrosoft:
Графический интерфейс
Apple Мacintosh
МS Windows 3.11
МS Windows 95
Oперационная система
IBM OS/2 Windows NT 1
МS Windows NT 2

... Символично, что праздник мелких пакостей и легких ужасов в США назывется "Хелло Win" ...

Немного о "старом добром" MS DOS-e (не путать с другими DOS-ами - напр. есть РС DOS): эта операционная система не имеет графического интерфейса, мышь там не работает; "грубо" выглядит вот так:

С:\
Некоторые DOS-команды:
dir - просмотр содержимого каталога
cd - смена текущего каталога
md - создание каталога
rd - удаление каталога
copy - копирование файла
ren - переименование
del - удаление файла
help - получение справки

Пример копирования файла через DOS-команду:
copy doc1.txt doc2.txt

№ | Работа с дисками | Назначение
1 | FОRМАТ дисковод: FORMAT дисковод: /S | форматирование диска подготовка системной дискеты
2 | TREE дисковод: | вывод дерева каталога на экран
3 | DATE день-месяц-год (05-11-01) | установка или вывод даты
4 | TIME часы: минуты: секунды | установка или вывод времени
5 | CLS | очистка экрана
6 | DISKCOMP диск1: диск2: | сравнение дискет (по дорожкам)
7 | DISKCOPY диск1: диск2: | копирование дискет
8 | VER | версия используемой DOS
9 | MEM | информация о распределении памяти
 | Работа с файлами |
10 | COPY CON имя файла | создание текстовых файлов
11 | DEL дисковод:путь\имя файла | удаление файлов
12 | REN дисковод:путь\имя файла имя файла | переименование файла
13 | COPY имя файла | копирование файлов

         ... Можно ли программу, написанную под Windows, называть подоконником?...

Немного о Windows-надстройках над старым DOS-ом... Это программы-приложения устанавливаются "сверху" на OS MS DOS, обеспечивая удобство работы. Они не являются операционными системами! Получили известность:
· Windows 1.0... Release вышел 20 ноября 1985 года, хотя анансирована была еще весной 1983 года. Интерфейс Win 1.0* естественно напоминал старый Apple'овский и был очень похож на сегодняшний PDA. Впервые использована мышь, появилась "Панель Управления". Windows 1.x основывается на МS-DOS 2.0. Но реально система так и не вышла за стены Microsoft.

· Windows 2.0/286... Release вышел 02 апреля 1987 года, ориентирована на машины PC/AT с процессором i80286. Введена улучшенная обработка скорости данного процессора Intel (использовала защищенный режим процессора) и возможность перекрытия одним окном любую часть других окон, введена поддержка графического стандарта VGA и "горячих клавиш" для окон. Интерфейс - как и Windows 1.0*, в основном черно-белые окна. Под версию 2.0 был даже Excel и PageMaker. Уже v.2 была требовательна к памяти, 612Кб порой было мало. В 1998 году вышла Windows 2.0 с поддержкой 386 enhanced mode, впоследствии названная Windows 2.0/386. Единственное отличие Windows 2.0/286 от Windows 2.0/386 - последняя позволяла запускать многочисленные приложения МS DOS одновременно в расширенной памяти, которая не ограничена пределом базовой памяти в 640Kб. Обе - довольно неустойчивые и в общем неудачные коммерческие версии. Не отличались стабильностью.

· Windows 3.0... Release вышел 22 мая 1990 года, ориентирована на машины PC/AT с процессором Intel 386. Платформа предлагала 32-битовое исполнение с поддержкой графики, улучшенную установку иконок, появились Program manager и File manager. К Windows 3.0 выпущена SDK (software development kit, программная разработка комплектов), которая позволила независимым разработчикам начать создание программ-приложений. Коммерческая версия - крайне неудачная, но послужила основой для Windows 3.1.

· Windows 3.1... Release вышел 06 апреля 1992 года. Предназначалась для i80386, но работала и на машинах с i80286. В систему встроена поддержка звуковых и видео- файлов, впервые реализованы TrueType шрифты и Screen savers. Первая удачная и широко распространенная версия компании Microsoft - продажи Windows 3.x достигли 10 миллионов штук. Под эту версию Windows тысячи независимых производителей программ начали создавать свои коммерческие программы. Но в Windows 3.1 не было встроенной поддержки сети. В этом же 1992 году вышла Windows 3.2, являющаяся переводом Windows 3.1 для китайского языка.

· Windows 3.11 for Workgroups... Release вышел 27 октября 1992 года и отличался от Windows 3.1 только встроенной поддержки сети. Т.е. интерфейс остался как и Windows 3.1, но добавили прямое создание рабочих групп, доменную поддержку организации сети, поддержку для сетей Novell NetWare, remote access service (RAS), централизацию безопасности и т.п. Первые заявления о 32-битовой файловой системе, что было чистым враньем. 15 февраля 1994 года вышел отдельный upgrade системы с обычной Windows 3.1 до Windows 3.11 for Workgroups. Практически все пользователи Windows 3.1 перешли на нее. Windows для Workgroups был использован как в сетях локальной области (LANs), так и на отдельных ПК (Windows 3.11 Workstations), в т.ч. на laptop-ах. Когда говорят о Windows 3.11 - имеют ввиду Windows 3.11 for Workgroups.
Внимание! Любой человек, утверждающий, что Windows 3.11 является операционной системой, является полным дилетантом.

Интересно, что Windows для Workgroups 3.xx не поддерживал сеть Internet! Вообще! Для работы в Internet было необходимо использовать независимое программное обеспечение, которое часто противоречило встроенным сетевым характеристикам.

· Другие DOS-надстройки... Кроме Windows v.1.0-3.1, в качестве надстроек над операционной системой MS DOS применялись DOS-файловые менеджеры. Самый распространенный - Norton Commander от "Symantec Corporation". Т.е. после загрузки OS MS DOS сразу же загружался NC и внешне это выглядело одним процессом. Впоследствии некоторые из этих программ получили популярность и при работе под OS Windows старших версий.
Не следует путать нынешние Windows-версии файловых менеджеров от их DOS-предшественников. При всей одинаковости интерфейса это принципиально разные программы.

         "... Остап знал 512 относительно честных способов повесить Windows NT..."

Windows NT 3.x... Release Windows NT 3.1 вышел в августе 1993 года и реально представлял собой дальнейшее внесение новых функций в "чужую" OS/2 NT 1.0, созданную компанией IBM еще в 80-х годах. Windows NT 3.1 был создан для бизнеса и стыковался с MS Windows 3.1, которую в то время многие использовали как дома, так и на работе. Из новых функций необходимо отметить файловую систему NTFS и поддержку multiple processor архитектуры.

06 сентября 1994 года появились Release Windows NT 3.5x: Windows 3.5x Workstation (с ограничением количества одновременно работающих сетевых задач) и Windows 3.5x Server (для серверов). Интерфейсы двух версий Windows NT 3.5x были такие же, как у Windows 3.1. Впервые Windows стал поддерживать графический стандарт OpenGL. Из улучшений важно появление возможности давать файлам 255-символьные имена. В июне 1995 года MS выпустил Windows NT 3.51, в которой добавил Client Access Licenses (CALs) for the Microsoft BackOffice и утилиты сетевой установки.

 ...Компьютер без Windows 95 - как рыба без зонтика...

Windows 95 (ака "маздай")... Release вышел 24 апреля 1995 года и являлся преемником 3.xx Workgroups. Система включала встроенный 32-битный стек TCP/IP для встроенной поддержки Internet, dial-up networking, новые Plug and Play и справочная система. Появилось меню правой кнопки мыши, а с OSR 2.0 - поддержка файловой системы FAT32. 95-е с полным правом называются операционными системами "для тупой американской домохозяйки". Реально по большей части имеют не 32-bit-ную архитектуру, a всего 16-bit. Всего их четыре штуки:
• MS Windows 95
• MS Windows 95 OSR 2.0 (OEM Service Версия 2.95b)
• MS Windows 95 OSR 2.1
• MS Windows 95 OSR 2.5
Причем "MS Windows 95 OSR 2.5" отличается от последующей "MS Windows 98" только двумя вещами (браузером IE и фатовой системой).

Негативных моментов хватит на огромный том. Взять хотя бы пресловутую не-стабильность "девяностопятых", падучие программы, увлекающие за собой всю систему вместе с содержимым жёсткого диска, невообразимую мешанину файлов в помойке с гордым названием /WINDOWS/SYSTEM, потребность в костылях (типа всевозможных диск-докторов, крэш-гардов и ан-инсталлеров) для поддержания системы в стоячем положении, а также всепобеждающее "...тебе незачем об этом знать, поскольку за тебя уже подумали...". О безопасности речь тоже не шла. Впрочем, "тупой" американской домохозяйке (а OS была рассчитана только на нее!), было комфортно.

 - Служба поддержки? У меня Windows виснет...
- Нашли чем удивить...

· Немного о эмуляции DOS-а под Windows: для работы в OS Windows 9x имеется DOS как бы внутри. Но это именно эмуляция (псевдо-DOS) и ее характеристики частично не совпадают с настоящим. Отсюда и проблемы при работе старых DOS-игрушек. Ну а начиная с "Windows ME" псевдо-DOS вообще уничтожен.

· "Горячие" клавиши или как работать в Windows без мыши. На вопрос: "кому это надо?" отвечу вопросом "Ваша мышь не работает или просто сгорела, а как будете работать?"
Контекстно-зависимая справка | F1 | Закрыть активное окно | ALT+F4
Открывает меню выделенного объекта | SHIFT+F10 | Вызов меню "Пуск" | CTRL+ESC
Открывает соответствующее меню | ALT + [подчеркнутая буква меню] | Активирует строку меню | F10
Переключение между окнами вперед | ALT+TAB | Вырезать в буфер обмена | SHIFT+DEL
Переключение между окнами назад | ALT+SHIFT+TAB | Скопировать в буфер обмена | CTRL+INS
Отмена последнего действия | CTRL+Z | Вставить из буфера обмена | SHIFT+INS
Свернуть все окнa | WIN+M | Развернуть все окнa | WIN+SHIFT+M
Создание ярлыка | CTRL+SHIFT во время буксировки | Удаление без помещения в мусорную корзину | SHIFT+DEL
Перейти в папку верхнего уровня | Back Space | Выделить все | CTRL+A
Открыть документ | CTRL+O | Сохранить документ | CTRL+S
Найти файл или папку | F3 | Делает текущим выделенным кнопку "Пуск" | CTRL + ESC, ESC

         "... 95, 98, 2000 - это количество багов. В процентах ..."

Windows NT 4.x... Release Windows NT 4.0 вышел 24 августа 1996 года и представлял собой модернизацию 3.5x Windows NT. Система имела интерфейс Windows 95, встроенный Web-сервер, полный комплект инструментальных средств для разработки и управления Intranets, ... Подобно Windows NT 3.5x, операционка имела две версии:
• MS Windows NT 4.0 Workstation
• MS Windows NT 4.0 Server

стоит парень в ванной, коврик для мышки стирает. Подходит второй и спрашивает: - Ты чего это делаешь? - Коврик от мышки стираю. - А зачем? - Да хотел себе Windows 2000 поставить, только начал, а мышь вырвало...

Немного о W2k и маркетинге: г-н Б.Гейтс - сильный маркетолог, что отражается в частности и в поддержке продаж. Например OS "Windows NT5" получила название "Windows 2000", что внешне выглядело логичным продолжением W95-W95*-W98. Вот так простофилям пудрят мозги...
Всего есть четыре вида поставок W2k:
• MS Windows 2000 Professional
• MS Windows 2000 Server
• MS Windows 2000 Advanced Server
• MS Windows 2000 DataCenter
Отличаются они друг от друга, во-первых, количеством служб и програм входящих в поставку, во-вторых, степенью поддержки аппаратного обеспечения. Например, W2k Pro не держит больше 2 процессоров, W2k Server держит уже 4 процессора, W2k AdvServer - 8 процессоров, а W2k DataCenter - 64. Кроме этого, они сильно различаются по цене. В W2000 дебютировала Динамическая поддержка Диска (убирает старое деление диска и логические отметки в Master Boot Record) в пользу базы данных управления диска, хранящейся в конце диска. Логическая разметка дисков и устройств все еще используется, но фактический размер и местоположение логических дисков (c: d: и т.д.) становятся динамическими.

Ищу поклонников Microsoft. Найду - убью...

Немного о Windows XP (eXPerience - опыт, ХРюшка), бывшая Windows Whistler. Создана на ядре Win NT - как и Win2000. Официально вышла 25 октября 2001 года. Есть "авторизация" установки OS ("Windows Product Activation")- т.е. после установки необходимо ее активировать - ввести специальный код через сообщение номера (личного) Windows в тех.службу Microsoft (по Internet-у, по телефону). Если же этого не сделать, то через 30 дней OS работать откажется. Если идет любой upgrade - новая авторизация. Количество авторизаций только 3 шт! Далее за upgrade платите снова (!!!). Впрочем, в феврале 2003 года у хакеров уже появился первый генератор ХР-ключей.
XP работает с zip-архивами как с обычными папками, чуть лучше стала корявая Plug & Play (Плач анд Пей или включи и молись). В XP нельзя войти, не введя пароль. Чисто 16-битные программы работать не будут, как и программы, использующие прямое обращение к жесткому диску и другим аппаратным средствам. ХР проявляет просто ослиное упрямство в отношении автоматической проверки upgrade, регистрации в системе Passport, использования Windows Messenger и т.п. функций. Может со временем Вы привыкните к этому, но скорее всего - не доживете до этого радостного момента в здравом уме.
Всего есть 3+1+2 вида поставок XP:

  • MS Windows ХР Home Edition. Нацелена на замену линейки Windows_9x-Windows_Ме. Не поддерживает: более одного процессора, динамическую поддержку диска, систему шифрования файлов. Нет многоязычного интерфейса (!), нет удаленного доступа к компьютеру (!!).
  • MS Windows ХР Professional Edition. Нацелена на замену линейки Windows_NT-Windows_2000.
  • MS Windows ХР 64-bit Editor. Нацелена на замену Windows NT Server и Windows 2000 Server.
  • MS Windows Net Server (планы);
  • MS Windows ХР Media Center Edition. Версия XP для гибридных ПК/ТВ-устройств, вышла 03 сентября 2002 года. С помощью XP Media Center Edition через ПК можно управлять телевизором, видеомагнитофоном, приставкой для приема кабельного телевидения, etc.
  • MS Windows XP Tablet PC Edition предназначена для нового поколения ноутбуков. Oтличается поддержкой дигитайзера с пером для письма непосредственно на экране.
Три самых писка...:
1. если во время инсталляции ХР не найдет нужный драйвер к "железу", она просто повиснет;
2. в первый ХР-год форумы Internet-а были забиты множеством обвинений (от бывших российских пользователей XP) о безвозвратном уничтожении их винчестеров этой мерзкой OS через несколько месяцев работы. Специального умысла MS здесь конечно нет, но виновата действительно ХРюшка. Из-за существенно более высоких требований к "железу", а также из-за многочисленных "оптимизаций" винчестер под новыми (такими "тяжелыми"!) окнами реально работает в запредельном режиме. И быстро умирает. Единственное спасение - резкое увеличение оперативной пямяти;
3. при любом программном сбое Windows XP будет автоматически отсылать на сервер корпорации отчет о возникшей проблеме. Будут пересылаться все данные, находящиеся в данный момент в оперативной памяти компьютера. Это официальное заявление должностных лиц Microsoft-а! Напоминаю, что в момент сбоя в ОЗУ компьютера находятся файлы, с которыми работает в данный момент пользователь! Т.е. Ваши документы!!!
Единственный плюс ХР - после 5 лет обещаний реализована поддержка всех Windows-фатовых систем. Со своей стороны могу порекомендовать если уж и инсталлить ХР, то только на официальное 100% "белое" brand-"железо", но лучше - не ставить ее никогда!

В Windows, как в самолете - и тошнит и выйти некуда...

Внешние графические интерфейсы Windows... Graphic Mode у MS почему-то только один, но существуют программы-оболочки для Windows, способные изменить внешний вид так, как Вы сами этого захотите. Конечно, нужны небольшие знания по программированию. Основная функция этих программ - запуск всех Windows-приложений в обход стандартного "Рабочего стола" Windows. Например: Bonjour-Талисман. Подробнее...

Подождите, Windows готовится к зависанию компьютера...
Заключение... Важные нюансы (4+1):
Во-первых, OS от Мicrosoft-а получили огромное распространение в России только благодаря пиратским CD. Между прочим, на Западе без установленной OS купить ПК нельзя. Если не нужна - купи и сноси. В России платить сотни долларов могут (хотят) очень немногие. Запрет на продажи с лотков пиратских аудио- и видео-CD уже есть с июля 2003 года, к концу 2003 года это коснется и пиратских CD с программами. А большие штрафы идут уже давно. Пример: 14.08.2002г. вынесено судебное решение о взыскании в пользу Microsoft 500.000 рублей с московской фирмы "Армир" за распространение нелицензионных MS-программ. Итог - в связи с интеграцией России в мир и жесткими требованиями Запада эта халява будет понемногу прикрываться.
Во-вторых, каждый, кто сменил хотя 3-4 разных OS от Мicrosoft-а, мог воотчию убедиться, что ошибок (багов) становится все больше, система все нестабильнее. Нововведения вообще обычным пользователям не нужны. Одно дублирование всех файлов пользователя под предлогом возможности восстановления чего стоит (стучим-с?). Только у Мicrosoft-а возможен такой дебилизм, как "...программа совершила недопустимую операцию и будет закрыта...", только эту OS надо бы переставлять каждые полгода (официальная рекомендация!), только в этой системе выключение начинается с кнопки "Start"("Пуск"), etc.
Во-третьих, о сложности OS. Разобраться в Windows до самого конца практически невозможно. Хотя бы из-за ее закрытого кода. Пользователь Windows не пасует, но в итоге... любой разумный человек обнаруживает, что затраченные им усилия и потраченное время таковы, что стоят освоения трех Linux'ов!!! Особенно если речь идет о линейке Windows NT/2000/XP.
Во-четвертых, не надо путать OS Windows и Windows-программы. Ваши любимые проги могут прекрасно работать под другой, намного более лучшей OS. Пример работы.

Извращенцам, нежно любящим OS Windows, можно посоветовать провериться в псих.диспансере. Чем более пользователь ПК-грамотен, тем чаще он ругает Windows. Т.е. нормальный человек может ее только ненавидеть.
Самое главное: любая OS имеет срок поддержки от производителя. Это очень важно, т.к. без поддержки MS у Вас не заработает никакое новое "железо"! И это не Unix (где можно самостоятельно написать драйвер), а MS, имеющий закрытый код! У большинства в России стоит Windows 98/98SE (даже у экспериментаторов с Win ME/2000/XP), хотя бы параллельно. А вот официальные даты прекращения поддержки Windows компанией Мicrosoft:

Операционная система | Прекрашение off-line поддержки | Полное прекрашение поддержки
OS Windows 95 | 31 декабря 2001 года | 31 декабря 2002 года
OS Windows NT 3.5x | 31 декабря 2001 года | 31 декабря 2002 года
OS Windows 98 | 30 июня 2003 года | 30 июня 2004 года
OS Windows NT 4 | 30 июня 2003 года | 30 июня 2004 года
OS Windows ME | 31 декабря 2004 года | 31 декабря 2005 года
OS Windows 2000 (NT5) | 31 декабря 2004 года | 31 декабря 2005 года
OS Windows XP | 31 декабря 2007 года | 31 декабря 2008 года

Вопрос к Вам: что Вы будете делать, когда Мicrosoft полностью закроет поддержку 98-х? Уже вот-вот...

Вместо эпилога... Святая правда, что существует Windows, легкая в освоении и что существует (может быть) Windows устойчивая и надежная. Да вот только еще никто не доказал, что надежная Windows есть вообще и главное что это - одна и та же Windows. Один из "маленьких грязных секретов" Windows - в сложности перехода с нее на другие платформы. Пока еще есть достаточно времени, советую выбрать, какая OS у Вас будет стоять в будущем. Ставить ее "в параллель" и учится с ней работать. Одновременно инсталлировать "под свои винды" Unix-софт из выбранной OS (у производителя обычно есть бесплатные Windows-версии) и учиться работать с этими Unix-программами. Время Мicrosoft-а завершается. Спасибо тебе, Мicrosoft, за наше детсадовское обучение и ... прощай. Впрочем, люди с задержками умственного развития могут и далее оставаться на виндах - что с убогих-то требовать... Обычные люди уже "выросли". А MS? Мавр сделал свое дело, мавру давно пора на покой...

Новости :)) от Microsoft: "... новая операционная система имеет удобный дружественный интерфейс и множество функций, облегчающих жизнь пользователю. Сразу после запуска она форматирует диск, уничтожает содержимое Bios и выводит из строя процессор, после чего на экране появляется надпись "Теперь питание компьютера можно отключить"..."

© Dmitry Belousov
http://www.orakul.spb.ru
ноябрь 2001г.-январь 2003г.


"Азбука РС" Дм.Белоусова, Macintosh

"Азбука РС"
Macintosh и его OS

"...некоторые люди безумны настолько, что уверены в своих способностях изменить мир. Мы верим, что энтузиасты могут сделать это. И эти энтузиасты - МЫ..."
( Steve Jobs )

компания "Apple Computer Inc."

История Apple и Macintosh-ей сильно связана с невероятно противоречивой личностью Джобса. Стив Джобс - это и обаяние, и деспотизм, и маркетинговый гений, и грандиозные неудачи, жестокие заблуждения и создание настолько героических и продуктивных творческих команд, что просто дух захватывает от гордости за человечество вообще...
01 апреля 1976 года Стив Джобс и Стив Возняк создали компанию "Apple Computer". Владелец самого первого в истории компьютерного магазина под названием Byte Shop (Поль Террел, г.Маунтин Вью, Калифорния) купил первые 50 Apple I по $500/шт. 03 января 1977 года фирма Apple Computer была официально зарегистрирована. Успех пришел с моделью Apple II. Это был первый в истории человечества персональный компьютер в пластиковом корпусе, с цветной графикой. Стоил этот компьютер $1298. В начале 1978 года вышел первый дисковод для дискет Apple Disk II. К концу 70-х компания вошла на рынок образования... она быстро росла и превращалась в монстра.

· ПК для "Mac-ов". История "железа" началась с серии Macintosh 128K (январь 1984г.), Macintosh 512K (сентябрь 1984г.), Macintosh Plus 1Mb (январь 1986г.), Macintosh SE 1/20 (март 1987г.), Macintosh Classic (октябрь 1990г.)... Именно эта продукция компании произвела в мире настоящую революцию, изменив расстановку сил и заложив фундамент для потрясающего будущего.
Последняя линейка - PowerBook G4 и ее лидер Titanium PowerBook G4. Вот несколько характеристик Titanium-а образца 2001 года:
- корпус из титана толщиной 1 дюйм, весом 2,45 кг*;
- TFT-экран диагональю 15,2 дюйма, разрешение 1152х768;
- PowerPC G4 процессор 256K кэш 2-го уровня;
- системная шина 133 МГц;
- SDRAM, расширяемая до 1Гб;
- DVD-ROM/CD-RW дисковод с упрощенной загрузкой;
- предустановленная карта AirPort, встроенные антенны;
- ATI Mobility Radeon 16Mб DDR видеопамяти, AGP 4X;
- 20Гб или 30Гб Ultra ATA/66 жесткие диски;
- 10/100/1000 Base-TX Gigabit Ethernet;
- до 5 часов работы от литий-ионной батареи;
- порты USB, FireWire, VGA, IrDA и S-Video;
Power Mac G4 предлагается вместе с 15" или 17" монитором Apple Studio Display или с уникальным 22" широкоформатным монитором Apple Cinema Display.

 "... Драйверы, прерывания, BIOS… всего этого нет в MacOS..."

· Операционная система "MacOS" (классическая версия).
Производитель - корпорация "Apple Computer Inc."
Последняя официальная версия - 9.1 (2001 год). Более ранние версии - 9.0, 8.0 Allegro, 8.0 Rhapsody Release, 7.7 Tempo, 7.6 Harmony, 7.53, etc. Mac OS с самого начала создавалась с ориентацией на обычного непрофессионала. Удобство и простота работы были одними из главных целей. За почти 20-летнюю историю нашлось немало желающих «позаимствовать» большинство элементов классического интерфейса.

· Операционная система "MacOS" (новая серия).
Производитель - фирма "Apple", команда Стива Джобса. Версия - Mac OS X v.10.1 (2001 год).
MacOS X - в основе Unix, точнее - система OpenStep (Unix NeXTstep). Разработчик - фирма Next, которую долгие годы возглавлял нынешний глава Apple Стив Джобс. Ядро системы называется Darwin и основано на Mach 3.0 (из Университета Carnegie-Mellon, автор ядра - Avadis Tevanian) и FreeBSD 3.2 (на основе BSD 4.4-Lite). MacOS X поддерживает файловые системы стандарта POSIX и доступ к файлам NFS, стандартные службы (telnet и FTP), протоколы IPv6, PPP и IPsec. Защищенная память, управление памятью. Технологии Quartz, 3-х мерной графика (OpenGL) и QuickTime, встроенная поддержку PDF и т.д.
В MacOS X три программных среды: Классическая, Carbon и Cocoa. Классическая позволит запускать все существующие программы для Macintosh “как есть”. Старые программы будут работать, но не будут использовать преимущества MacOS X (такие как многопоточность и компоненты интерфейса Aqua). В среде Carbon напротив - приложения оптимизированы для работы в MacOS X. Они будут использовать современный API Carbon и все преимущества ядра системы Darvin. Прогрессивная объектно-ориентированную среда Cocoa - на будущее, oнa сможет привлечь разработчиков новой системой разработок приложений для построения приложений следующего поколения.

· Операционная система "BeOS" (с поддержкой как платформы Intel, так и PowerPC). Создатель - Компания "Be Inc."( 1996-2001гг.)
Эта мультимедийная OS была создана для ныне несуществующего компьютера под названием BeBox, в 1996г. ее вознамерилась купить компания "Apple" и она чуть не стала следующим поколением "MacOS".
В августе 2001г "Be Inc." была куплена в собственность компанией "Palm Inc." за $11.000.000. "BeOS" умерла. О воссоздании новой "BeOS"- см. "OBOS" проекта "Scarabeos2001".

· О кризисе "Mac".
В середине 90-х "Apple Computer Inc." терпела убытки. Но вернулся Steve Jobs, закрыты клоны, вышла MacOS X... И вот 16 января 2002 года "Apple" сообщила о результатах первого финансового квартала 2002 года (закончился 29 декабря 2001). В этом квартале компания впервые получила чистую прибыль в $38 миллионов, или $.11 на одну акцию и выпустила 746 тысяч компьютеров Macintosh. Вместо эпилога - кризиса "Apple" больше нет, гонка Windows/Linux/MacOS продолжается.

© Dmitry Belousov
http://www.orakul.spb.ru
ноябрь 2001г.-июнь 2002г.


"Азбука РС" Дм.Белоусова, UNIX-ные OS

"...Если вы хотите иметь хоpошую систему в будущем, Вы должны найти способ медленно и плавно двинуться в миp Unix..." "Азбука РС"

Unix-ные OS

•

Solaris (Unix)

•

HP-UX (Unix)

•

BSD/OS (Unix)

•

OpenBSD (Unix)

•

Digital Unix

•

SunOS (Unix)

•

FreeBSD (Unix)

•

IRIX (Unix)

•

Linux (Unix)

•

Pyramid (Unix)

•

SCO (Unix)

•

BSDI (Unix)

•

NetBSD (Unix)

•

AIX (Unix)

"... Вопрос о том, как поменять "обои" в Windows вызывает желание перерезать горло вопрошающему ..."

OS Unix же разрабатывалась прежде всего как система для профессионалов. Вообще это целое семейство, в которое входит несколько десятков разных операционных систем. На этой странице приведены только самые популярные UNIX-клоны. Изначально Unix-система должна была обеспечить высокую надежность, устойчивость, гибкость для критически важных участков применения ПК, например в энергетике, в управлении производством, в аэрокосмической отрасли и т.п. областях. Но! Легкость и простота работы для обычного user-a (не-профессионального пользователя) вплоть до самого конца 90-х не являлись критически важными факторами для Unix'а. Поскольку он был разработан для программистов, основным его интерфейсом очень долгое время оставалась командная строка.
Сегодня Unix - это зрелая, технически самая мощная, группа операционных систем с проверенной рекордной производительностью, надежностью и безопасностью в серверной среде. За более чем 30-летний (!) период непрерывной разработки (часто выполняемой добровольцами, верящим в то дело, которым занимаются), была создана группа OS и чрезвычайно мощные, сделанные под определенные нужды, многопроцессорные серверные системы, имеющие производительность, равной которой еще нет в аппаратуре Wintel (Windows-Intel), которые не только отвечают запросам сегодняшних вычислительных потребностей, но и во многих случаях превышают их.
Почему MS Windows (напр. NT4.0, 2000, ХР) до сих пор продолжают существовать на предприятиях - это тема будущей дисертации для врача псих.больницы или какого-нибудь института маркетинга, но не статьи моего учебника об информационных технологиях. Технически, Windows (любой версии) не идет ни в какое сравнение с любой Unix (как бы не подтасовывались факты и сколько бы газетных статей с заказным оплаченным враньем не выпускалось). Хотите авто-аллегорию? Мерзкого вида, вечно ломающийся Запорожец - это Windows, а надежный и сияющий красавец Mercedes (а некоторые модели еще и бесплатны!) - это Unix. Вот и выбирайте...

 "... У большинства людей, нуждающихся в компьютерной помощи, причина ошибок в работе программы - чисто генетическая..."
· Рождение OS... Unix началась в недрах Bell Telephone Laboratories (теперь AT&T Bell Laboratories). Исходным толчком к появлению Unix явилась работа Кена Томпсона по созданию компьютерной игры "Space Travel". Он сделал это в 1969 году на компьютере Honeywell 635, который до этого использовался для разработки проекта MAC. Название придумал Брайан Керниган. Он предложил назвать эту двухпользовательскую систему UNICS (Uniplexed Information and Computing System). Первыми реальными пользователями Unix стали сотрудники патентного отдела Bell Labs. В ноябре 1971 года был опубликован первый выпуск документации ("Первая редакция"). В соответствии с "Первой редакцией" назвали и соответствующую версию системы. "Второй редакция" появилась в 1972 году, система была переписана на языке Би ("B"). В июле 1974 года Кен Томпсон и Деннис Ритчи опубликовали в журнале Communications of the ACM историческую статью "UNIX Timesharing Operating System", которая положила начало новому этапу в истории системы. Unix заинтересовались в университетах. Появившуюся к этому времени "Пятую редакцию" Unix одними из первых получили Калифорнийский университет г.Беркли (США) и университет Нового Южного Уэльса г.Сидней (Австралия).
В 1976 году Кен Томпсон провел свой академический отпуск в университете г.Беркли и установил там Unix v.6 на компьютере PDP-11/70. Дипломником этого университета был Билл Джой (основатель BSD - Berkeley Software Distribution, а впоследствии основатель и вице-президент компании Sun Microsystems). Билл Джой собрал вместе большой объем ПО, включавший полный набор текстов Unix v.6, компилятор языка Паскаль, свой собственный редактор ex (потом его стали называть vi) и другие программы. Все это было названо Berkeley Software Distribution (BSD Unix 1.0).
В 1978 году в Bell Labs специально для поддержки Unix была организована "Группа поддержки Unix" (Unix Support Group - USG).
Мир Unix достаточно тесно переплетен между собой, вот пример из истории:

"... Да превратятся Чайники в Кофейников! ..."
· Компоненты: любая Unix-система имеет 4 основных компонента:

  • ядро операционной системы: контролирует доступ к компьютеру, управляет памятью компьютера, обслуживает файловую систему и распределяет ресурсы компьютера среди пользователей, т.е. координирует внутренние функции компьютера. Ядро работает невидимо для Вас;
  • shell - это программа, которая позволяет Вам связываться с операционной системой, т.е. осуществляет связь между Вами и ядром. Shell считывает команды, которые вы вводите, и интерпретирует их как запросы на выполнение других программ. Интерактивная;
  • commands - это набор инструкций для компьютера. Программы, которые могут быть выполнены компьютером без предварительной трансляции, называются исполняемыми программами или командами. Пакеты программ называются инструментальными средствами;
  • file system (файловая система) - это набор всех файлов, возможных для Вашего ПК. Она обеспечивает логический метод организации, восстановления и управления информацией. Файловая система имеет иерархическую структуру.
· Графический интерфейс пользователя - или CDE (Common Desktop Environment), он же GUI-десктоп, он же оконный менеджер. Именно CDE рисует обрамление окошек, выводит заголовки и меню, отлавливает клики мыши и передаёт их программам - т.е., делает всю черновую работу, связанную с окнами. Выбрать CDE по душе можно лишь лично его попробовав. , но, прежде чем приступать к экспериментам, давайте рассмотрим две группы, на которые подразделяются оконные менеджеры. Он есть, просто он просто идет отдельной программой и имеется не один встроенный, а много вариантов - для Вашего личного выбора CDE. CDE поставляется с большинством OS Unix.
Пример знаменитых GUI-систем, поставляемых с OS Linux: KDE, OpenLook, FVWM 1.24, FVWM 2.x, FVWM-95, TWM, TED, etc.

· Действительно многопользовательская... - начинать сеанс работы с любой версией Unix нужно с сообщения о том, кто Вы. В этом заключается одно из отличий UNIX от DOS, Windows (любой) и Macintosh (до v.9.x вкл.)- операционных систем, в которых понятие "многопользовательский" просто отсутствует. UNIX должна знать, кто Вы, чтобы выделять Вас и Ваши программы среди десятков, сотен и даже тысяч других пользователей. Это не зависит от того, работаете Вы локально (за своим отдельным ПК) или по сети (связываетесь с большим узлом общего пользования).

· "Корневой каталог" и ... - в операционной системе UNIX иерархическая (или "древовидная") файловая система, также как в MS-DOS & Windows и Macintosh. Это означает, что каждый файл находится в каталоге, а каталоги могут включать другие каталоги. Но! В OS UNIX никогда не обращаются к самому диску, а всегда - к под-каталогам корневого каталога. Перед именем стоит косая черта (/). Косая черта в начале имени обозначает "корневой каталог", который является, по сути, точкой, в которой "склеены" между собой все диски системы. Т.о. нет букв (A,C,D,E,...), нет печально знаменитого windows-идиотизма с настройкой "священного" ярлыка на путь к файлу. Нет и быть не может. Каждому пользователю назначается "домашний каталог", в котором он должен хранить свои файлы, даже если он - является единственным пользователем системы. Пример: /home/dima - это домашний каталог пользователя Dima.

         "...Решение всех жизненных проблем находится в Internet-e. Надо только уметь искать..."
· OS FreeBSD (Unix) - это мощная операционная система семейства BSD UNIX для компьютеров архитектур, совместимых с Intel ia32, DEC Alpha и PC-98. Корни ее идут из операционной системы "4.4BSD-Lite" с некоторыми усовершенствованиями, взятыми из "4.4BSD-Lite2" Калифорнийского Университета (Беркли). Также она косвенно базируется на 386BSD (BSD Net/2, перенесённой на платформу i386 Вильямом Джолитцем (William Jolitz)). Часть исходного кода системы, подпадает под действие GNU General Public License (GPL) и GNU Library General Public License (LGPL). FreeBSD распространяется бесплатно и поставляется со всеми исходными текстами. Она разрабатывается и поддерживается командой разработчиков (Core Team), с руководством из 9 человек. В команде существует группа из более чем 200 коммиттеров (committers), которые могут делать изменения прямо в дереве исходных текстов FreeBSD. Дата релиза обычно объявляется заранее, так что те, кто работает над системой, знают, когда их проекты должны быть закончены и протестированы. Увеличивается поддержка других платформ, сейчас в разных стадиях разработки находятся работы по портированию в FreeBSD/Alpha, FreeBSD/IA-64, FreeBSD/PPC, FreeBSD/Sparc64, FreeBSD/x86-64.
Последние версии: FreeBSD 4.5 Release Notes, январь 2002г. (for platforms i386), ветка 4-STABLE. Все основные релизы FreeBSD доступны по FTP (ftp://ftp.FreeBSD.org/pub/FreeBSD/).
После того, как была выпущена FreeBSD 2.0.5, авторы решили разделить разработку FreeBSD на две части. Одна ветка, названная FreeBSD-STABLE, предназначена для внесения только хорошо оттестированных исправлений и маленьких последовательных усовершенствований (для пользователей, которым неожиданные изменения или экспериментальные возможности нежелательны). Другой ветвью является FreeBSD-CURRENT, версия OS, находящаяся в стадии разработки до момента выпуска RELEASE. Т.о., она представляет реальный интерес только для разработчиков системы и её фанатов. Вот как это выглядит на схеме:

                 2.0
                  |
                  |
                  |  [2.1-STABLE]
   *ВЕТВЬ*      2.0.5 -> 2.1 -> 2.1.5 -> 2.1.6 -> 2.1.7.1  [конец 2.1-STABLE]
                  |                            (Мар 1997)
                  |
                  |
                  |  [2.2-STABLE]
   *ВЕТВЬ*      2.2.1 -> 2.2.2-RELEASE -> 2.2.5 -> 2.2.6 -> 2.2.7 -> 2.2.8 [конец]
                  |        (Мар 1997)   (Окт 97) (Апр 98)  (Июл 98) (Дек 98)
                  |
                  |
               3.0-SNAPs  (начало в I квартале 1997)
                  |
                  |
               3.0-RELEASE (Окт 1998)
                  |
                  |  [3.0-STABLE]           (Сен 1999)    (Июнь 2000)
   *ВЕТВЬ*     3.1-RELEASE (Фев 1999) -> 3.2 -> 3.3 -> 3.4 -> 3.5 -> 3.5.1
                  |                  (Май 1999)    (Дек 1999)     (Июль 2000)
                  |
                  |  [4.0-STABLE]
   *ВЕТВЬ*       4.0  (Март 2000) -> 4.1 -> 4.1.1 -> 4.2 -> 4.3 -> 4.4 -> 4.5 ->...
                  |                (Июль 2000) (Сентябрь 2000) (Ноябрь 2000)
                  |                 -- будущие релизы 4.x ...
                 \|/
                  +
          [продолжение 5.0-CURRENT]

Ветвь 2.2-STABLE была завершена выходом релиза 2.2.8. Ветвь 3-STABLE была завершена выходом релиза 3.5.1. Единственными изменениями в этих ветвях могут быть только исправления ошибок, касающихся безопасности. Активно разрабатываемой веткой -STABLE является 4-*-STABLE. Ветка 5-CURRENT продвигается к выходу 5.0-RELEASE.
Прикладные программы для "FreeBSD" могут быть свободно скачены из Коллекции Портов (http://www.freebsd.org/ports/). Для пользователей издаются "Бюллетень FreeBSD" (распространяется бесплатно, от компании Walnut Creek CDROM) и журнал "BSD magazine"(от компании ASCII).

         "... Пингвин? Пингвин! Да здравствует Пингвин!!! ..."

· OS Linux (Unix) - это современная POSIX-совместимая и Unix-подобная многопользовательская сетевая операционная 32-х разрядная (64-х разрядная на платформе DEC AXP) система с сетевой оконной графической системой X Window System для персональных компьютеров и рабочих станций. OS Linux поддерживает стандарты открытых систем и протоколы сети Internet; работает с сетями на базе Novell и MS Windows. Все компоненты системы, включая исходные тексты, распространяются с лицензией на свободное копирование и установку для неограниченного числа пользователей. OS Linux широко распространена на платформах Intel PC (386/486/P_I/P_Pro/P_II/P_III/P_IV) и завоевывает позиции на ряде других платформ (DEC AXP, Power Macintosh и др.).
Основная часть системы, включая GUI и диспетчер окон, может прекрасно работать всего на 8Мб памяти. Даже с массой утилит сама Linux "съест" всего 10-20Mb на винчестере. Большое количество документации (Linux Howto, Linux FAQ, Kernel Howto, Linux Documentation Project, etc.) можно получить через Web.
История: 05 октября 1991 года Линус Торвалдс (Linus Torvalds) из университета г.Хельсинки объявил о первой "официальной" версии Linux (v.0.02). Отладка OS (v.0.03, v.0.10, ..., v.0.95, ..., v.0.99, ..., v.0.99pl14) была закончена в марте 1994 года (v.1.0). Сейчас L.Torvalds продолжает разработку только ядра Linux в компании "Transmeta Corp." (г.Санта-Клара, Калифорния, США), а над OS работает не поддающееся подсчету гигантская команда из многих сотен тысяч пользователей сети Internet, сотрудников унивеpситетов, фондов, исследовательских центpов, etc.
Существует огромное количество дистрибутивов OS Linux, при этом версия фирмы-поставщика не имеет никакого отношения к версиям компонентов. Даже номер версии ядра ничего не значит для версии Linux в "целом". Но в любой момент времени есть две "последние" версии ядра - стабильная (номер версии всегда четный, напр. 2.4.) и разрабатываемая (номер всегда нечетный, напр. 2.5.). У каждой из версий ядра есть "уровень патчей"(третий уровень, напр. 2.4.2). Не забывайте, что даже CD с дистрибутивом, купленный в любом пиратском ларьке, является официальным и законным!
На начало 2002г. есть следующие виды дистрибутивов:
- Debian (tonio). Hаиболее полно укомплектованный, с педантично продуманным эффективным дизайном, debian удовлетворит нужды любого. Между стабильными релизами проходят значительные промежутки времени и его установка иногда сложна, особенно для новичков. Пример: Linux Debian 2.2r5
- Red Hat (tonio). Поддерживается командой профессионалов, быстро и хорошо эволюционирует. Устанавливаемые программы как правило готовы к использованию, что делает его идеальным выбором для новичков. Доступен для разных платформ. Пример: Linux Red Hat 7.1 Cyrillic Edition + Star Office 5.2, Linux RedHat 7.2, Red Hat Linux v.8.0
- Mandrake (PJ). Французский дистрибутив наиболее законченный и хорошо локализованный. Программное обеспечение оптимизированно для Pentium и дисков UDMA. Версия GPL состоит из одного CD. Коммерческая версия на пяти CD содержит 2500 пакетов. Пример: Linux Mandrake 8.1, Mandrake Linux v.8.2, Linux Mandrake Russian Edition Spring 2001, Mandrake Linux v.9.0.
- S.u.S.E (vdefert, stef). Дистрибутив, включающий большое количество заранее сконфигурированных приложений. Очень хорошая онлайновая помощь во время инсталляции. Превосходня утилита YaST. Ввиду активного сотрудничества команды разработчиков с членами проекта XFree86, поставляются новейшие версии X-серверов. Пример: Linux S.u.S.E 7.3
- Slackware (vdefert, tonio). Рекомендется тем, кто желает познать сладость высокого мастерства в Unix, кому хочется продемонстрировать собственные возможности. Зарезервирован для завсегдатаев, которые не хотят менять своих привычек. Создатель дистрибутива - Patrick Volkerding. Пример: Linux Slackware 8.0
- Stampede. Дистрибутив, с лучшей производительностью для процессоров Intel. По режиму своего функционирования похож на Slackware. Локализация исключительно американская. Компания VA-Research предоставила сервера. Пример: Stampede Linux 0.90.
- Caldera. Дистрибутив, с почти автоматической инсталляцией, KDE включен. Предлагается 4 варианта инсталляции: мини, стандартная без X, стандартная с X и макси. Входит полный набор приложений, который может потребоваться обычному пользователю. Пример: Caldera OpenLinux 3.1.1.
- DIY (Do It Yourself). Предназначенный для профи дистрибутив. Минимальный набор (типа Slackware, с сериями a (минимум), d (и gcc)) и необходимостью компиляции остальных частей из исходных текстов.
- Minilinux (hc). Сильно урезанный дистрибутив. Идеально подходит чтобы попробовать Linux, посмотреть на что он похож. На нем нельзя делать серьезных вещей. Пример: ALT Linux Junior 1.1, Babilonia 12r2.
- прочие (в т.ч. групп пользователей). Это Jurix, SLS, MCC, HJ, Craftworks, Linux Pro, Trans-Ameritech Linuxware, Turbo Linux. Эти дистрибутивы поддерживаются командоами увлеченных людей и бывают просто незаменимы для нестандартной архитектуры или конфигурации.

О производительности... - "...Linux на i486 превзошел Windows NT4.0 на P600, а еще одна машина с Linux работает без сбоев с той поры, когда Windows NT 4.0 еще не было..."(John Kirch, сетевой консультант).
В первом полугодии 2002г. начался взлет популярности Linux и в высших эшелонах власти. Франция, Финляндия, Германия, Бразилия, Мексика, Перу, ЮАР, Китай, Индия, Тайвань, Филиппины, Австралия имеют Linux в гос.структурах официально. Например в Китае свободная Linux официально объявлена одним из государственных ИТ-стандартов и применяется на 20.000 китайских станций по обработке газа, на почте, в министерстве иностранной торговли, на центральном ТВ-канале и т.д. Ну а Россия - в ..... (как обычно).

         Генеральный спонсор апокалипсиса - компания Microsoft
Для OS Linux и OS FreeBSD (при желании и знаниях можно и другие Unix), существует возможность работы всех Windows-программ через Wine. Это бесплатный проект, позволяющий без какого-либо использования кода Windows выполнять Windows-приложения. Подробнее о Wine... Необходимо отметить еще пакет CrossOver Office (компания CodeWeavers), позволящий пользователям компьютеров с Linux устанавливать и работать с любым офисным ПО Microsoft Office.

От автора (вместо OS-эпилога): установка и последующая работа с Linux могут стать захватывающим, увлекательным и приносящим плоды занятием. Cчитаю, что Linux возвращает работе с ПК утраченное очарование.

© Dmitry Belousov
http://www.orakul.spb.ru
ноябрь 2001г.-декабрь 2002г.


"Азбука РС" Дм.Белоусова, другие OS

Товарищ, верь - пройдет пора Виндов и ламерского софта
И на руинах Майкрософта напишут наши имена...
(из народного эпоса) 		"Азбука РС"

Прочие OS

•

IBM OS/2 & eCom

•

BeOS for x86

•

Novell NetWare

•

Новые проекты OS

Все эти группы OS объединяет относительно малое (по сравнению с МS, Mac, Unix) количество пользователей. Это не значит, что они плохие. Чаще всего это очень сильные OS, но у каждой что-то не хватило для победы. Может быть, не хватило пока и их время еще впереди?

         "... Это же IBM! Достаточно и половины OS!...
· OS/2 компании "IBM" ("полуось", "пополама", "полумуха", "осина") - великолепная OS начала 90-х. Именно великолепная. Некоторых функций из дедушки OS/2 Warp (напр. создания тени) до сих пор нет даже в новенькой MS Windows ХР! Ее главные достоинства - существенно меньшая (в сравнении с Windows) прожорливость и нормальная многозадачность (3-4 десятка запущенных пользовательских приложений - обычное явление в OS/2). От Linux отличается простотой в освоении и отличной поддержкой программ для DOS и Win16. Всего было выпущено 12 систем:

  1. OS/2 1.0 ( 08 декабря 1986 года)
  2. OS/2 1.1 ( октябрь 1988 года). Также выпущена OS/2 Extended Edition, имеющая средства поддержки сетей.
  3. OS/2 1.2 ( осень 1989 года )
  4. OS/2 1.3 ( 1991 год )
  5. OS/2 2.0 ( весна 1992 года). Система стала полностью 32-битной.
  6. OS/2 2.1 ( май 1993 года ). Также вышла OS/2 2.1 for Windows, которая устанавливается поверх уже существующей на компьютере Windows 3.1.
  7. OS/2 Warp 3.0 ( октябрь 1994 года ). Также выпущена OS/2 Warp Connect 3.0, в которой добавлены службы для работы в локальных сетях и Интернете.
  8. OS/2 Warp 4.0 "Merlin" ( 26 октября 1996 года ). В этой OS в т.ч. появилось голосовое управление и набор текста с голоса. Слэнг -"мерин".
  9. OS/2 Warp Server for e-business ( осень 1998 года, v.4.5, "Aurora", client-а нет ). Слэнг -"аврора".
  10. Convenience Package к "Aurora"( апрель 2000 года ).
OS/2 создавалась "голубым гигантом"("IBM") для собственных нужд и ее никогда не предполагалось продвигать на рынок SOHO и в сверх-малый бизнес, осуществить поддержку которого "IBM" просто не способна. OS/2 использовалась IBM в качестве основы для своих программных решений, таких как комментаторские системы олимпийских игр, программное обеспечение для банков, банкоматов (в т.ч. и в России), etc. Компания IBM никогда не прикладывала усилий для популяризации OS/2. Несмотря на это, OS/2 в середине 90-х держала до 18% рынка операционных систем. Но то, что люди полюбили OS/2 - это собственные проблемы этих людей.
Есть ли вероятность возрождения OS/2? Дело в том, что для корпораций она и не умирала! До сих пор IBM ежегодно получает миллионные $-прибыли от написания заказных программ к OS/2. Время прекращения поддержки OS/2 Warp все время сдвигается и пока анонсировано в 2006 году. Но будут поступать заказы, будет и продолжение поддержки. А вот для рынка SOHO операционка в том виде, в каком она сейчас существует - умерла. Но есть "наследники", пока их два:
· eComStation (eCS). Это платный OS/2-"клиент" от компании "Serenity System". 19 мая 2001 года появилась v.1.00 ($99). Две веpсии: eComStation Entry (начального уpовня) и eComStation Professional (пpофессиональная). В числе прочих в состав eCS вошли: журналирующая файловая система JFS, поддержка симметричных многопроцессорных систем (до 64 процессоров), программы из бонус-пака OS/2 Warp 4 (в том числе программа голосового управления и диктовки VoiceType), два офисных пакета (Lotus SmartSuite и StarOffice).
eComStation совместима с всеми существующими пpиложениями для OS/2, DOS, Windows 3.1 полностью! Более того, с использованием сопpоцессоpной платы можно запускать все Win32-пpиложения и даже Linux-пpиложения. По наваротам eCS сравним с WinME. Будущее eCS (на мой взгляд) зависит от проекта Odin. Тем более для пиратской России.
· проект osFree (февраль 2002 года, клон OS/2, открытый исходный код). Реально это OS/2, скомпилированная из давно гуляющих по свету исходников Warp4 (юридически - ворованных). Если сообщество сумеет переписать код под открытой лицензией (как начали в BeOS), то "все впереди".... Существует русская и английская версии системы.

Проект Odin позволяет запускать программное обеспечение Win32 (от MS Windows 95/98/NT4/ME/2000/XP) под OS/2-eCS. Т.о. самая большая проблема OS/2 (нехватка хороших программ), может быть решена за счет Windows. Odin равивается очень быстро. Пока запускаются под OS/2 отдельные программы (WinAMP, Soliter, WinMine, WinCechkers, WinChess, WordPad, Paint, Calender, Calc, Lexicon'97, ACD Browser, etc.).

         "... Сервер, не суетись под клиентом!...

· Novell (Novell NetWare) - серверная платформа, основанная на открытых стандартах и предназначенная быть ядром гетерогенной информационной системы масштаба предприятия.
Сетевые операционные системы NetWare: Netware 6, NetWare Deployment, NetWare 5.1, NetWare 5, NetWare Migration Wizard 6.0, NetWare 4.2, NetWare 4.11, NetWare 3.x, Novell Small Business Suite 6, Novell Small Business Suite 5.1, Novell Small Business Suite 5, NetWare for Small Business 4.2, Novell Error Codes.
В России массовое вторжение Novell NetWare началось с версии 2.15, работавшей даже на компьютерах с процессором 80286. Тогда в России везде использовался DOS (о ОS Unix VINES мало кто знал, Microsoft Lan Manager был слаб) и ОS Novell NetWare с огромным успехом заняла сетевую нишу. Эта OS прекрасно подходила для организации сети на базе файл-сервера для решения задач совместного использования принтеров и дисковой памяти. Она относится к классу сетевых OS с централизованным управлением. NetWare позволяла совмещать в одном компьютере функции файл-сервера и рабочей станции. К тому времени, когда Microsoft утащила у IBM серверную линейку OS/2 (ныне Windows NT), NetWare уже пережила множество "переизданий" и захватила значительную часть рынка. Версия 3.12 является "топ моделью" своего поколения, в которой исправлены ошибки предыдущих версий и "наведены мосты" к сетям нового поколения - 4.x. Версии NetWare 4.0, 4.01 и 4.02 были переходными и "сырыми". Версия 3.12 появилась позже 4.0.
Сегодня NetWare представляет собой многозадачную многосерверную сетевую операционную систему. Годами проверенная надежность, перенесенная на многопроцессорную и кластерную платформу, остается основой популярности NetWare. Регулярно выходят новые версии и Support Pack-и. Но... очень медленно, но неуклонно уменьшается доля рынка NetWare... Интересный факт: 17.11.2001г. Novell объявил о сокращении штата на 19%!
Есть ли вероятность возвращения роста популярности NetWare? У самой ОS - вряд ли. Но у Novell-а уже очень много других програмных решений: средства интеграции, управления рабочими станциями и серверами, администрирования, средствам обеспечения безопасности информации, etc. Для платформы NetWare уже создано множество различных продуктов, как то:

  • Novell Client
    Примеры soft-a: NT/2000 v4.7-4.8, 95/98 v3.2-3.3, NT-v4.6, 95/98-v3.1, DOS/Win-v2.71.
  • Защита
    Примеры soft-a: BorderManager Enterprise, Edition 3.6, BorderManager Enterprise, Edition 3.5, BorderManager Enterprise, Edition 3, NMAS 2.0, NMAS 1.0, Novell FireWALL for NT, Novell SecureLogin, Novell Single Sign-on 2.1, Novell Single Sign-on 2.0, Novell Single Sign-on 1.0, Novell Certificate Server v2.03, Novell Certificate Server v2.0, NDS Authentication Services for UNIX/Windows Servers and OS/390.
  • Сервисы обмена и управления знаниями
    Примеры: GroupWise 6, GroupWise 5.5, GroupWise 5.2, GroupWise 5.1, GroupWise 4.1, GroupWise Wireless 1.1, GroupWise Plug-in for Outlook, GroupWise 5.5 Enhancement, Pack, GroupWise Archive Migration, Utilities, GroupWise Client Standalone, Version, Novell Net Publisher 2.0, Novell Net Publisher.
  • Сервис подключения хостов
    Примеры soft-a: NIAS 4.1, NetWare for SAA.
  • Сервис Каталога
    Примеры soft-a: NDS eDirectory 8.5, NDS Account Management 2.1, NDS DirXML 1.0, Novell DirXML Drivers, NDS 8, NDS for NT 2.01 (QuickStart PDF 31K), NDS for Solaris 2.0, NDS Corporate Edition, NDS eDirectory, ConsoleOne 1.3, ConsoleOne 1.2c, ConsoleOne 1.2b, Novell Error Codes.
  • Интернет-сервисы
    Примеры soft-a: Novell Portal Services 1.1, Novell Portal Services 1.0, Novell iChain 2.0, Novell iChain 1.5, Novell OnDemand Services 1.5, Novell Internet Caching System 1.3, Novell Internet Caching System 1.2, Novell Internet Caching System 1.0, eGuide, IBM WebSphere, Novell Internet Messaging, System.
  • Дополнительные сетевые сервисы
    Примеры: Novell JVM for NetWare, NRS 1.2, NetWare NFS 3.0, NFS Services for NetWare 5, Backup and Restore Services for NW5, Netscape Enterprise Server for NetWare, Netscape Admin Server for NetWare, NetWare Enterprise Print Services, Novell Licensing Services.
  • Отказоустойчивость
    Примеры soft-a: NetWare Cluster Services.
  • Storage Services
    Пример: iFolder.
  • Сетевое управление
    Примеры: ZENworks for Servers 2, ZENworks for Desktops 3, ZENworks, Servers/Desktops/Networks, ZENworks Servers/Desktops, ZENworks for Servers, ZENworks for Networks, ZENworks Starter Pack (Oct'99), ZENworks 2, ZENworks 1.1, ManageWise 2.7, ManageWise 2.6, ManageWise 2.5, ZENworks 2/ManageWise 2.6, BranchManager for NT.
Т.е. стратегическое будущее NetWare - создание программного обеспечения служб Сети.

         "... Если Windows - это трехсоткилограммовая горилла, а Linux - пингвин, то BeOS компании Be, пожалуй хамелеон...

· BeOS for x86 (BeOS for платформы Intel) - просто прекрасная OS и рядом с ней Windows "отдыхает"(сравните Запорожец с 600-м Мерседесом). Инсталляция BeOS фантастически проста и занимает максимум десять минут. Загрузка всей BeOS 5.0 занимала меньше времени, чем запуск браузера Internet Explorer в Windows, а образ системы занимал на диске сущие копейки по сравнению с Windows или MacOS. Первая версия BeOS появилась в 1997г., причем для процессоров PowerPC. В 1998г. появилась версия для Intel. К моменту появления v.5.0 уже существовала совершенно бесплатная BeOS Personal Edition, хотя успешно продавалась и BeOS Pro Edition (стоила она $70 у авторов и не дороже $100 в магазинах). В системе поддерживались практически все основные файловые системы (FAT, FAT32, NTFS, NTFS 5, ext2), а также файловая система дисков DVD. Собственная файловая система BFS (Be File System) была 64-х разрядной, причем кроме привязки расширений имен файлов к приложениям можно было пользоваться независимыми дескрипторами MIME. Элегантный пользовательский интерфейс BeOS наследовал лучшие черты Windows и напоминал MacOS, электронная почта и адресная книга интегрированы с файловой системой (т.е.Вы работаете с почтой и контактами так же, как и с обычными файлами). Т.о. BeOS была идеальной платформой для создания мультимедийных продуктов, не в последнюю очередь благодаря своей оптимизированной параллельной архитектуре.
Но.. за малым исключением BeOS работала лишь с такими устройствами, для которых написали драйверы разработчики компании Be. Существующие программы под BeOS представляли собой утилиты и узкоспециальные инструменты. Есть немного действительно серьезных программ, главным образом мультимедийных и графических. Полноценного офисного пакета не было. Встроенный Web-браузер работает хорошо, но JavaScript поддерживает только в "порядке эксперимента", а Java не поддерживалось вообще. Несмотря на то, что "Be Inc." выпускала систему "версия за версией", все еще оставалось безграничное множество вещей, на техническую поддержку которых не хватало денег-ресурсов.

Последняя официальная версия "Be Inc."- R5.0 (2000 год). Более ранние версии - v.4.5 (21.06.1999г.), v.4.0, v.3.2, v.3.1. Но еще есть R5.1 Dano, выпущенная энтузиастами без прямого участия компанией "Be Inc.". На западе ее обычно называют как BeOS 6.
В августе 2001г "Be Inc." была куплена в собственность компанией "Palm Inc." за одиннадцать миллионов долларов. В первую очередь "Palm Inc." интересует BeIA - основа операционной системы (Be Internet Appliance), чья модульная структура позволяет с легкостью адаптировать ее к широкому спектру различных устройств для бытового и бизнес-применения.
Есть ли вероятность возрождения BeOS? В том коде, в каком она была - нет. "Palm Inc." не будет продолжать поддержку BeOS, она "умерла". Но! На момент продажи "Be Inc."(осень 2001г.) примерно 80% акций (!!!) принадлежало поклонникам BeOS со всего света. И ее преданные поклонники не смирились...
Группа BeOS-активистов и держателей акций "Be Inc." основали лоббистскую группу по сохранению и развитию операционной системы. Из сомнений упомяну, что часть кода не принадлежит собственно "Be Inc.". По "наколенному BeOS-коду" сейчас развиваются направления, различающихся как основой для ядра, так и амбициями:
• BlueOS и OpenBeOS (декабрь 2001г., открытый исходный код). Это проекты воссоздания BeOS под GPL-License. Первый - на Xfree и ядре 2.4.12 ( http://blueos.free.fr/ ), второй - на основе NewOS с переписыванием Individual servers and APIs ( http://open-beos.sourceforge.net/news.php ). И как мне кажется, перспективы этого направления "open source" весьма радужны.
• "коммерческие", напр. "Phoenix" - проект Рудольфа Хельмара и Донована Шульте. Это создание коммерческой структуры с привлечением венчурного и народного капитала. Есть проект Робина Бэнди и т.п. проекты, явно малоосуществимые.

         "... Всякое pешение плодит новые пpоблемы ..."

· Новые OS-разработки .... Каждый год рождается множество операционных систем, которые затем тихо умирают. В мире OS царствует триумвират Windows-Unix (Linix)-Mac. На российском же рынке OS для персональных компьютеров доминирует Windows. Как тут не вспомнить фразу Фоменко "... Мыши плакали и кололись, но продолжали жрать кактус ...". Потеснить мелко-мягкого пытались уже не раз, но преуспеть в этом пока не удалось никому. Главный недостаток, мешающий любой новоявленной операционной системе - это отсутствие в ней нужных пользователям приложений и слабая поддержка разнообразного "железа". Конкурировать с Windows, программы и драйверы для которой пишутся тысячами программистов свыше десятка лет, почти невозможно. И тем не менее, вот несколько очень интересных OS с хорошей (и не очень) перспективой:

  • операционная система MenuetOS
    Представлена - сентябрь 2001г., автор - Вилле Турьянмаа (Финляндия).
    Всего два главных отличия от всех других ОС, но каких! Во-первых, она, при всех своих возможностях, написана с использованием только 32-битного ассемблера. Во-вторых, вся система, включая около десятка прилагающихся несложных приложений, умещается на одной дискете 3,5".
    Menuet представляет собой 32-битную многозадачную операционную систему реального времени, работающие на компьютерах архитектуры x86 и имеющую встроенный графический интерфейс пользователя. Поддерживаются разрешения до 1280x1024 при 16,7 миллионах цветов. Разработка Menuet началась меньше года назад, и многих необходимых возможностей (например, поддержки TCP/IP) в ней пока отсутствуют. Создатель системы опубликовал её исходники на условиях лицензии GNU GPL.

    Личное мнение: бесплатность, открытый код (т.е. помощь добровольцев со всего мира), малый размер. Когда-то и Linix начинал так же, в той же Финляндии кстати. Лет через 5 посмотрим...
  • операционная система PetrOS
    Представлена - сентябрь 2001г., автор - компания Trumpet Software (Австралия)
    До появления Windows 95-98 австралийская компания Trumpet Software пользовалась большой популярностью. Сетевые возможности Windows были довольно ограниченны, и желающим попасть в Internet было не обойтись без выпускаемой этой компанией программы Trumpet Winsock.
    Операционная система PetrOS - совместимая с Windows, но требующая для работы 486-ой процессор, 2 мегабайта RAM и 2 мегабайта на диске. PetrOS полностью совместима с Windows, и под ней будут работать любые предназначенные для Windows программы. Существующая сейчас версия PetrOS загружается в компьютер за 5 секунд. Размер ядра составляет 190 килобайт (всего!), что сразу приводит к существенному увеличению производительности: большая часть ядра может оставаться постоянно загруженной в кэш процессора. Завлено полное отсутствие многочисленных Microsoft-недостатков, свойственных всем Windows (требовательности к ресурсам, крайней ненадёжности, чрезмерных размеров и т.п.). Стоимость PetrOS - $50.
    Личное мнение: Т.к. это unix-подобная система, PetrOS будет обладать развитыми средствами удалённого управления, и пользоваться ей можно будет с удалённого терминала. А работа всех Windows-приложений - это очень сильный ход. Но лично я увидел некий заменитель DOS, который даже команду DIR называет по-своему, кое-как умеет читать диск FAT32. "За деньги", да при отсутствии маркетинга. Увы, не верю...
  • операционная система Lindows
    Представлена - октябрь 2001г., автор - компания Lindows.com во главе с Майклом Робертсоном (Michael Robertson). Lindows: Linux + Windows.
    Новая система базируется на результатах многолетней работы над open-source проектом Wine – попытке "мимикрировать" команды, использующиеся программами Windows. Еще одним достоинством новой OS является возможность запуска программ Microsoft без необходимости платить за Windows (!). Кроме того Lindows улучшает патентованное ПО, например, за счет более удобных шрифтов или большей легкости установки. Первая версия Lindows 1.0 появилась в начале 2002 (стоит $99), 26 ноября 2002 года вышла уже v.3.0 (комплект из двух дисков и документации стоит 129$, а загрузка дистрибутива с сайта компании обойдется в $119). Владелец лицензии получает годичный бесплатный доступ к онлайновой библиотеке программ, в которую входят и коммерческие Linux-продукты.

    Личное мнение: второй раз за всю свою историю Microsoft поднял всю свою армию "продажных" юристов и бросил миллионы долларов, чтобы "задушить дитя в колыбели". А ведь это пока еще скорее клон Linix с возможностью запуска программ для Windows. Будущее этой OS решится в судебных схватках с MS. Если юристы Lindows в ближайшие годы смогут отбиться от мелко-мягкого монстра, а одновременно программисты "еще улучшат" систему... win-программы уже работают. Ох, как интересно может быть!
  • операционная система "OBOS" ("BeOS open source")
    Представлена - февраль 2002г., авторы - проект "Scarabeos2001". Группа Scarabeos2001/openBeOS-openBeIA-Committee переводит знаменитую операционную систему BeOS (BeOS/BeIA) под "GPL-ориентированную" лицензию, по сути создавая новую OS. Два примера из жизни OBOS Group:
    • ReOS - инсталлятор OBOS. ReOS предназначен для плавного апгрейда Вашей BeOS на OBOS. При появлении очередного опенсоурсного модуля, им можно будет заменить закрытый код от покойной "Be inc." Инсталлер вызывает перловый скрипт, который в свою очередь вызывает wget, выкачивающий нужный софт и ставящий его. Для установки ReOS требуются: сам файл инсталлятора ReOS, Perl, Wget, CVS, SSH. Механизм работы ReOS довольно прост: есть набор файликов, в которых описываются программы и методы их установки/удаления. По необходиммости файлики по ssh заливаются в локальный cvs, это необходимо для того, чтобы качать свежие, актуальные пакаджи.
    • Патч для BeOS R5. 15.02.2002г. произошло эпохальное событие в жизни новой BeOS - OpenBeOS Group выпустила первый патч к v.5.0.
  • операционная система BedOS
    Представлена - лето 2001г., автор - Бедрин Сергей Викторович, г.Москва. Имеет несколько версий:
    • BedOS72214-1: OS очень анекдотичная. BedOS построена на системных компонентах 4 разных Windows. Она ставится из Windows (!!!). Впрочем это было и в QNX, но QNX ведь настоящая OS, просто такая инсталляция удобнее для пользователей. Из-под Windows же BedOS и запускается! "...Кликнув на иконку, попадешь в операционку...". Но в работе не используется даже папки от Windows. Вроде и OS, вроде и не OS.
    • БедОС2 "ТАНЯ": последняя версия. Бесплатный, свободно-распространяемый клон Windows98. В отличие от BedOS72214-1 устанавливается как из под Windows, так и из под DOS-a на новый компьютер. Для компаний юридически продается не OS, а носитель CD ($12), предназначенный для тестирования, неограниченного по времени. Версия из Интернета (доступна с июня 2002г.) предназначена только для дома (опять же - юридически для тестирования).

    Личное мнение: хотя количество почитателей БедОС2 "ТАНЯ" и сейчас растет (файл bedos2.exe перегружен), пик популярности этой OS придется на время окончания поддержки Windows 98. А этот "судный день" - уже скоро. А авторские же права MS очень изяшно "кинуты" тестированием...
  • операционная система SkyOS
    Представлена - 2001г., автор - Роберт Шелени. Это уже клон Linux (дожили).
    32-разрядная многозадачная OS с графической оболочкой и поддержкой самого разнообразного железа. Осенью 2001г. объявлено о поддержке всех Linux-приложений, в перспективе - поддержка программ Windows.
    Личное мнение: ничего хорошего я в ней не нашел...

Успехов Вам, энтузиасты!

© Dmitry Belousov
http://www.orakul.spb.ru
ноябрь 2001г.-июнь 2002г.


"Азбука РС" Дм.Белоусова, причины написания

...На бескрайних русь-просторах, в кучах грязи, нечистот
прозябает некультурный обленившийся народ...
(из западных СМИ) 		"Азбука РС"

Причины написания Азбуки...

· О авторе... Ф.И.О. - Белоусов Дмитрий Витальевич, профессиональный программист, "компьютерщик" с более чем десятилетним стажем. Лет - немного старше возраста Христа... В настоящий момент директор software-компании (выпускаем программы серии "Оракул"), в 90-е годы - топ-менеджер нескольких петербурских компьютерных фирм. Не учитель школы, не преподаватель ВУЗа (и никогда ими не был). Лектор & докладчик & преподаватель, еще приглашают фирмы на ПК-консультации и проекты. За последние годы работал в более чем 20 операционных системах, в том числе всех 8-ти Windows и в 11 альтернативных (Linux, FreeBSD, Novell, BeOS, MacOS 9х, MacOS X, последние версии OS/2, eComStation, BedOS). Программ смотрел - многие тысячи (сбился со счета очень давно). Т.е. мне есть что и с чем сравнивать. Чтобы не придирались - говорю сразу - я работаю либо на лицензионном, либо на бесплатном софте. Только.

· О Ваших письмах... Каждый месяц мне приходит до полутора сотен писем по "Азбуке РС". Позволю их немного классифицировать.
1-я группа - благодарности (более сотни в месяц). Вот всего несколько цитат: "...довелось заполучить ваш труд... Восхищению нет предела! Знания, профессиональная компетентность, умение лаконично и систематизированно преподнести материал - это качества, наверное, от Бога ...., ...Очень понравилась программа Азбука PC... , ...все хорошо, книга просто супер..., пишу по поводу "Азбука РС", спасибо за труд, она мне очень помогает, уверен она помогает не только мне!!..., ... я посмотрел Вашу работу, мне она очень понравилась. Я нашел там для себя много интересного (учитель информатики- стаж работы 8 лет) ...".
2-я группа с вопросами (5-10 писем в месяц). Чаще всего они касаются остальных (отсутствующих) файлов. "...многие темы пусты. Пожалуйста просветите: это недописанные статьи или у меня какие-то глюки... будут ли новые материалы...".
3-я группа - от пустоголовых придурков (2 письма за первый год), пытающихся меня учить - КАК мне писать компьютерный учебник. "...Такое совершенно недопустимо в учебнике!!! ... Какая дикость!!! Чему и кого Вы этим учебником сможете учить???... помещать такой сырой, недоработанный материал... беретесь за такой труд, поняития о котором Вы даже не имеете!!!... Вот если послушаете меня......".
Так вот. Я бесконечно благодарен своим читателям, посчитавшим необходимым сказать простое человеческое спасибо за мой бесплатный учебник, который очень тяжело пишется (уж поверьте). И моя искренняя признательность людям, обнаружившим и приславшим мне сообщения о допущенных грамматических опечатках. По задаваемым вопросам считаю, что во вступлении (первая страница) я уже на них ответил. Хотя если есть пара свободных минут, я все равно стараюсь людям написать ответ. Ну а те два придурка - ну что с "митрофанушки" возьмешь? Время только жалко...

· Читать или пропустить... Это очень грустная глава, но самое главное - она больше о нашей сегодняшей жизни, чем о компьютерах. Поэтому "нарцисам" (самовлюбленным) наверное можно ее и пропустить. Вы готовы прочитать неприятные (а кой-кому и страшные) фразы? Если нет, не читайте дальше, а просто жмите на

Начало Азбуки РС

.... .... ....
.... .... ....
.... .... ....
.... .... ....

Вы решились? Но помните - я Вас предупреждал. Итак, если отвлечься от обязательных уроков информатики, то строки этой книги написаны для:
  1. той немногочисленной части молодежи, кто способен думать (анализировать, понимать и т.п.) "своим умом", а не телевизором. Тем, кто мысли в слова может складывать сам, а не тупо повторять рекламные слоганы;
  2. людям среднего возраста, в силу поиска работы вынужденных изучать ПК;
  3. людям старшего возраста, решившимся научиться работать на ПК;
Короче для тех, кто способен в сегодняшней России жить нормально, невзирая на "любимое" государство. Книга не предназначается все увеличивающемуся "тупого быдла" любого возраста (пардон - "поколению пепси", "поколению next", etc.), так дебилов и придурков учить бесполезно. Для слепо-любящих матерей-отцов, имеющих баранов-наследников любого пола и наивно думающих за очень большие деньги все же научить своих ослов-ослиц, повторяю еще раз: Вашу бестолочь учить бесмысленно.

· Зачем это надо знать... Причин много, приведу только несколько. Первая главная причина - потому, что при приеме на работу Вас никто не будет спрашивать про любимую марку пива, а вот о знании ПК не только спросят, но и проверят обязательно. Вторая главная - при отъезде за рубеж компьютер надо знать "на отлично", ибо дуракам рабочие визы не даются. Еще это надо знать, чтобы Вы понимали, что за ПК у Вас есть (это раз), чтобы Вас не обманывали при покупке & upgrade (это два), чтобы Вы сами себе не создавали проблем (это три), чтобы Вы не слушали идиотских советов со стороны (это четыре), чтобы Вы осознали, что большая часть предлагаемых программ и комплектующих - полное "г.." (это пять), чтобы наконец дошло, что Microsoft - только для тупых (это шесть) и т.д. Занятно, что огульная критика типа "...это кроме учащихся никому не интересно...", "...это все и так знают...", "...в каждой "вшивой" газетке это есть..." и т.п., исчезла после звонков руководителей школ и гимназий ("...Вы не могли бы обучить моих учителей информатики?..."), не говоря уж о просьбах знакомых и друзей в возрасте "старше 30" (с просьбой обучить наследника(у), проконсультировать, помочь с upgrade, ответить на вопросы, etc.). Ибо работать на ПК и знать его - увы, две разные вещи. Помните классика: "...мы все учились понемногу, чему-нибудь и как-нибудь...". А знать причины своей болезни и пытаться их исправить - уже половина успеха.

· Последняя капля... По работе мне каждый год приходится беседовать с претендентами на вакантные места. Как правило, это молодые люди, недавно закончившие школу или студенты. Картина "маслом": я грустно наблюдаю за тем бредом, что несут претенденты. Уровень компьютерной грамотности не просто низкий - он нулевой! Речь даже не идет о том, что можно кого-то найти без последующего обучения в фирме. И отсеивая одного-двух способных их многих тысяч, "вбивая" им потом знания, я мечтал о Азбуке, которую просто можно дать почитать. В 2001 году ко мне обратилась элитная гимназия с просьбой обучить их учителей информатики нормально (не по пособиям МинОбразования "времен Куликовской битвы") и написать текст с картинками (для проектора). Пока я колебался (писать или не писать), я как-то неожиданно оказался перед необходимостью рассказывать всю эту азбуку своей повзрослевшей дочери-школьнице самому. Т.е. ко мне сами пришли те самые уроки маразма (извините - информатики) в 7-11 классе. И это стало последней каплей.

· Что творится в ПК-образовании .... Творится УЖАС. Конечно, может где-то и есть отдельные счастливые исключения, но в 99,99% это полное незнание предмета преподавания. Некомпетентность, умноженная на зазубривание переизданных учебников "времен первобытного человека и царя гороха". Поймите меня правильно - я не обвиняю учителей школ & гимназий - у большинства нет ни зарплаты, ни компьютеров, ни знаний. Даже официоз констатирует, что "...обучить в области компьютерных технологий нужно почти два миллиона работников системы образования..." (И.Смольникова, президент российской ассоциации учителей информатики, 2002г.). Я не обвиняю и преподавателей институтов & университетов - какие были у них крохи знаний с советских времен, так все и осталось. А ведь все так ушло вперед. Кстати, во многих новых ВУЗах эти крохи еще и умножены (или скорее поделены?) на холуйство перед ректором. Поймите - я просто констатирую факт - молодые люди вступают в жизнь и ищут работу, не имея ни малейшего правильного понятия ни о компьютерах, ни о программах, ни о информатике в целом. То же самое для людей среднего возраста, вынужденно пытающихся пройти те или иные компьютерные курсы (для смены работы). А вывод при собеседовании будет один - такому претенденту НЕ место в компании.
Кстати о "потемкинских деревнях". По продажному, многократно завравшемуся, TV любят показывать подаренный какой-нибудь школе очередным депутатом (перед выборами) компьютерный класс или ПК-аудиторию ВУЗа. На осень 2002г. в г.Санкт-Петербурге на свыше 750 школ и гимназий приходилось всего 902 компьютерных класса. Это 1 ПК на 80-100 учеников, а например в Европе соотношение 1 ПК на 10-15 учеников. При этом около 10% наших классов укомплектованы устаревшими советскими машинами 80-х годов, даже не IBM-совместимыми. А на одну "одаренную" школу (с многими ПК-классами) приходятся сотни обычных.
Но ужас даже в тех 19% школ, где есть современные ПК. Во-первых, мало поставить, надо еще и пользоваться. Во-вторых, чтобы обучать, надо знать (самому учителю). Ну хоть чуть больше ученика. А знаний-то нет вне зависимости от собираемой с родителей суммы оплаты! Мои наивные надежды, что уж в недавно созданных (платных) университетах все преподается как надо, в одночасье рухнули при посещении лекции в одном из супер-разрекламированном, страшно дорогущем питерском ВУЗе. Когда солидный дядя-лектор в обычной "потоковой" аудитории (а не в многократно показанном по TV ПК-классе) пытается нарисовать мелом на доске клавиатуру (и не может правильно!)- это уже верх маразма.
Давно прошло то время, когда образование в России было лучшим в мире. Ныне уровень образования - чуть выше папуасов. Очень симптоматична выделенная России DVD-зона: Африка и СНГ. Утритесь, дамы-господа, о Вас вытерли ноги. Но все же главная беда российского образования в другом - в неправильно закладываемом базисе-основе. И первая фраза, которую говорят в любых нормальных фирмах новичкам - "...забудьте тот бред, чему Вас учили раньше...". Мы переучиваем, а это всегда сложнее.

· О газетах, журналах, TV и магазинах... или о горе-писателях и горе-советчиках. Чем больше применяется ПК в нашей жизни (чем больше "парк ПК" в России), тем больше появляется бездарных (но крайне нахальных) дилетантов, считающих, что они знают все и пытающихся описывать-рассказывать-советовать. Подавляющее большинство пишется личностями, не имеющими ни малейшего представления о теме. Статьи-обзоры-дискуссии... в газетах-журналах, в Internet-e, по TV и т.п. Некоторые даже с картинками и терминами. Даже в обычных газетах уже появляются специализированные компьютерные статейки, где нагло и самоуверенно врут. Выдумывают эту ахинею ради гонорара! Есть всего один совет - не читайте всю эту галиматью. Никогда!!! Помните Булгакова? ("...Не читайте советских газет по утрам..."). Конечно, есть специализированные газеты и журналы. Кстати, их немного - с десяток по всей РФ. Но они - для профессионалов, а не для новичка. Как отличить хороший обзор от "липы"? В липовом псевдо-обзоре будет:

  • детальное описание одной (обычно самой разрекламированной, чаще всего от большой корпорации) программы обзора и только вскольз будут упомянуты остальные;
  • очень малое кол-во программ в обзоре (обычно 2-5 шт.);
  • нет "сухих" фактов, а есть много "воды" и бурных эмоций горе-автора;
  • навязываемый итог: всего одна класная программа, все остальные - все хуже;
Т.е. горе-писатель просто расписал стоящую у него программу, выдавая ее за лучшую. Хорошей информации очень-очень мало!
В последние годы "как грибы" развелись ПК-магазины, где продавец вроде бы отвечает на вопрос и можно спросить.. Нельзя! В большинстве случаев он просто "впаривает" товар. Автор регулярно (раз в месяц, получая "моральное" удовлетворение) заходит в очередной магазин г.С-Петербурга и после самоуверенного (но тупого и дебильного) ответа "размазывает по столу" продавца. Ибо торговцы просто "натасканы на общие вопросы", но реально они ничего не знают...
Но хуже всего - "лапша на уши" от соседа (однокласника, однокурсника и т.п.). Увы, каждый "митрофанушка" считает себя великим "знатоком". А с чего Вы взяли, что сосед знает? Хоть что-то? Из-за того, что его родители купили ПК на год раньше Вас? Глупо... Тому бреду идиота, что передается при личной беседе, позавидует любая психбольница! Или думайте сами - своей головой, или платите деньги профессионалам и вообще не лезьте туда, где Вы разбираетесь "...как свинья в апельсинах...".

· О книгах и курсах... В попытке как-то снять с себя надвигающююся роль школьного учителя, я вспомнил о учебниках, в частности о знаменитых Фигурнове В.Э., Богумирском Б.С. и т.п. Каюсь, никогда раньше их не читал и ... так долго не смеялся. Впрочем, невзирая на море грубейших ошибок, для начинающих они может и неплохие, но увы... это не то. Или скажем точнее - это не азы. Направленность учебников такая же, как и у многочисленных курсов компьютерной грамотности: в лучшем случае научат набирать текст в MS Word-e, складывать в MS Excel-e, если очень повезет - открывать MS Internet Explorer и отправлять E-mail из MS Outlook и т.п. Т.е. идет подготовка к использованию компьютера в качестве печатной машинки с оглядкой на "паутину" и все это - на "падучих" ворованных программах от мелкософта.

· О "паутине"... Последней надеждой найти "азы школьнику" был Internet. При этом как "постоянный житель рунета" и программист со стажем, я достаточно четко (в отличие от несчастного школьника) знал, что же искать, как и где. Увы... Есть "океан" ссылок на продаваемые книги, несколько устаревших статей (учебников) общего плана (напр. "60 уроков компьютерной грамоты" И.А.Кузнецова 1999г. или "Основы вычислительной и компьютерной техники" Е.Филиппова), десятка два обзоров общего плана (напр. "Самые начала…" Ю.А.Денисова). Иногда проскальзывают написанные обычным языком небольшие обзоры на сайте какой-либо компании (тематические). И ... все! Искал даже в студенческих рефератах. Вздор, бред, ахинея и липа. Оговорюсь сразу - во-первых, искал только freeware (т.е. бесплатное); а во-вторых, немногочисленные профессиональные сайты (с действительно хорошими текстами) не подходили ввиду сложности текстов для самых начинающих.

· Печальный итог - никто и нигде почему-то не дает азы полностью, все какие-то куски. Нет стройной системы "who is who". Это тем более странно, что ведь азы-то очень мало меняются, в отличии от конкретики далее. Впрочем дилетанты написать подобное не способны, а программистам действительно "влом" писать такую элементарщину. Море времени надо потратить... Но в итоге при наборе кандидатов в компанию мы сталкиваемся с всеобщей и вопиющей компьютерной безграмотностью, очень часто еще и помноженной на бездарность и "растопыренные пальцы идиотов с клинским в руке и орбитом в зубах". Раньше люди могли заняться самообразованием, но теперь... Не смешите мои тапочки... В России с каждым годом все больше не людей, а быдла. Тупого, хамоватого и бескультурного быдла, озабоченного только животными инстинктами. Наш знаменитый философ и писатель А.А.Зиновьев 12.03.2002 сказал "...в России оскотинивание произошло еще большее. И такого вырождения ... ни в одной стране не наблюдалось...". Может для власти это и выгодно (не будет очередных революций), но крайне плохо для владения ПК. Менталитет другой. Компьютерщик должен думать и не просто думать, а нестандартно думать.

· О нестандартном мышлении или степень Вашей сопротивляемости... Вы считаете, что думаете сами? Ой ли? Перефразируя Ф.М.Достоевского ("Преступление и наказание") - "человек думающий или тварь дрожащая?". И здесь нет оттенков. Не может человек одновременно и нестандартно думать, сидя за ПК и тупо повторять вранье телевизора. К сожалению, иметь нестандартное мышление не означает быть богатым в жизни (многие хорошие программисты живут бедно).
В последние годы каждый баран называет себя программистом. Но назваться не значит быть. И мышление новоявленных программистов - увы... не то. Сразу вспоминается огромное предложение на рынке "web-дизайнеров", взявшиеся после нескольких дурацких школьных уроков. Что ж, Россия издавна славится дураками.

· О воинствующих рабах Билла... Я достаточно критически отношусь к компании Microsoft и к ее операционным системам. Небольшая автомобильная аналогия: для меня лично работа в Windows сродни езде на старом Запорожце. И с каким облегчением я возвращаюсь обратно за руль нового Mercedes-а (BMW, Nissan-а и т.п.). Большинство пользователей России "...слаще морковки ничего не едали...", т.е. кроме двух-трех Windows, ничего и не видели. Но среди них обязательно есть мрачные личности, крайне воинствующе относящиеся к моей критике своей нежно любимой Windows. Причем аргументированной критике Windows! Поймите - это авторский материал. Я - автор, вот так считаю. Вообще в мире даже есть такое понятие - "стокгольмский синдром". Это когда заложники террористов настолько с ними сроднились, что защищали их даже после своего освобождения. Нечто подобное наблюдается и с Microsoft-ом. Один такой воинствующий раб Билла Гейтса ("...Он вызывет во мне поклонение... Он пример!...") даже засыпал меня письмами, обливая потоками оскорблений. Всем подобным личностям могу ответить однозначно - к психиатру!

· Откуда все это взялось... Из головы. Картинки сканировались из журналов, что-то найдено в Internet-е. Если какие-то нюансы подзабывались - смотрел профессиональные сайты, данные тестирования, FAQ, мнения людей в конференциях. Старался написать попроще, но боюсь, что совсем уж "разжевать" не получилось. Впрочем полностью от терминов не уйти, да это и не нужно.
Вот так и родилась Азбука РС. Конечно, нельзя объять необъятное и многие мелочи наверняка все же упущены. Даже за первый год написания мне приходилось многократно возвращаться к уже написанным главам и корректировать их. Но тем не менее - пока в России это первый и единственный бесплатный учебник азов ПК, в котором есть все!

Вот собственно и все причины. У кого под руками - открывайте вино-пиво.. и "поехали"...

© Dmitry Belousov
http://www.orakul.spb.ru
ноябрь 2001г.-январь 2003г.

[ оглавление | причины написания | начало | глоссарий ]


"Азбука РС" Дм.Белоусова, оглавление

...Я бы изменил мир!
Но Бог не дает мне исходники...

Содержание

В отличии от оглавления каждой страницы, здесь Вы найдете полное содержание "Азбуки", наглядно показывающее структуру книги (html-учебника). Гиперссылки помогут Вам тут же открыть не только нужную главу, но и конкретный абзац.

  • Вступление. Что это за книга? Для кого это? Авторские права.
  • Содержание. Настоящий файл.
  • Причины написания Азбуки ПК или почему автор был вынужден написать эту книгу. Немного о Ваших письмах.
  • Начало. Из чего состоит компьютер, история создания, соотношение размеров.
  • Монитор. Что такое монитор? Описание и характеристики электронно-лучевых, жидкокристаллических, газо-плазменных, сенсорных, вращающихся мониторов, FED-display, LEP-display, LED-display, ЭЛ-display, VF-display, чернильных display, нанотрубок, плоскопанельных, DLP-display.
  • Системный блок. Составляющие части, виды упаковки, моральное старение.
    • Видео (video). Все о видео-системе, цветам и типам видео-адаптера, составляющими видеокарты, графических ускорителях, библиотеках стандартов, FPS, фрейм-грабберах, TV-тюнерах.
    • Compact Disc xx. Описаны технологии CD, DVD, FMD; CD-болванки и их реальные производители. Стандарты CD-DVD. Информация по системе "UDF", региональной защите DVD, single disc, CD/DVD библиотекам, новым проектам.
    • Оперативная память (RAM). Классификация памяти, кэш, пять основных параметров памяти (тип, объем, структура, время доступа, корпуса и форм-факторы микросхем), oрганизация JEDEC, SIMM-ы и их обозначения, маркировка Presence Detect, FPM DRAM, EDO, BEDO, PB SRAM, DIMM-ы и их спецификации, Serial Presence Detect, HSDRAM-ы и SO DIMM-ы, GF1000, DDR-ы и их расшифровка, DDR-II, GDDR-III, SLDRAM, RLDRAM, консорциум SLDRAM Incorporated, технология Direct Rambus и ее компоненты, голографическая память, молекулярная память.
    • Процессор (CPU).
    • Материнская плата (m/b). Классификация плат, определения, внутренние m/b-компоненты, системные частоты, джамперы и DIP-переключатели, таблицы соотношений напряжения, m/b по форм-фактору и оперативной памяти, виды процессорного разъема, Socket-переходники, Chipset-ы, выбор материнской платы.
    • Корпус (case). Классификация по внешнему виду и по форм-фактору. В т.ч. о ATX, AT, NLX, ITX, WTX. Описаны блоки питания, вентилятор и дизайн, параметры выбора.
    • Винчестер (HDD). Описание и история жестких дисков, основные параметры, разделение винчестера, режимы pаботы IDE-винчестеров, анатомия винчестера, геометрия диска, кластер и кластеризация винчестера, 11 уровней RAID-массивов, о HDD-смерти, pасшифpовка HDD-обозначения.
    • Floppy (FDD). Определение, история старых форматов, дисковод 3,5", Iomega Zip, Iomega Click Death, Iomega PocketZip, SuperDisk LS-120, ORB от Castlewood, новые fdd-разработки.
    • Звук (sound).
  • Периферия. Определения, составляющие части, многофункциональные устройства, средства синхронизации с ПК (IrDA, GPRS, HSCSD, Bluetooth, EDGE), презентационное оборудование, компьютерные аксессуары.
    • Устройства ввода-вывода.
    • Колонки & наушники.
    • Цифровая техника.
    • Накопители.
    • Принтеры.
    • Модемы.
    • UPS-ы. Классификация UPS-ов, четыре основных параметра, UPS On-line (тип standby), интерактивные UPS (линейно-интерактивные), UPS Off-line, программное обеспечение ИБП, Bypass, батарея, "холодный" старт, сетевые фильтры, инвертор, электричество в России, схема работы.
    • Игровые устройства.
    • CompactFlash.
    • Планшеты.
    • Сканеры.
  • Операционная система. Определение и главные функции, разделение OS, Service Pack, менеджер загрузки (Boot Manager), виртуальный ПК (VMWare), Windows-эмуляторы, статистика по OS, OS и типы пользователей.
    • OS компании Мicrosoft. Настоящие авторы идей. Три "линейки", в т.ч.: DOS, МS Windows 95 (4 шт.), о эмуляции DOS-а, "горячие" клавиши, Windows 98, Windows ME, Windows NT 2.0, Windows NT 3.0, Windows NT 4.0, МS Windows 2000, МS Windows ХР, нюансы будущего.
    • OS для Mac-ов. Macintosh и "Apple Computer Inc.", Стив Джобс, MacOS X - в основе Unix.
    • Unix-ные OS. Группа операционных систем Unix, рождение, 4 основных компонента, бесплатные OS FreeBSD и OS Linux.
    • Прочие OS. IBM OS/2 & eComStation, Novell NetWare, BeOS for x86, новые OS-разработки (MenuetOS, PetrOS, Lindows, OBOS, BedOS, SkyOS)
  • Программы (software). Определение, способы получения, лицензия (License) и ее типы, бесплатное ПО, проблема пиратства, компьютерные вирусы, офисные пакеты (интегрированные), новые версии, золотой фонд программ.
    • Бизнес, техника, наука.
    • Графика и мультимедиа.
    • Делопроизводство, образование.
    • Системные, служебные.
    • Программирование.
    • Утилиты & драйвера.
    • Internet-soft.
    • Игры & Дом.
  • Прочие компоненты. Отдельные компоненты, не вошедшие в главные разделы.
    • Домашний ПК-кинотеатр.
    • Шины ПК.
    • Bios ПК.
    • Файловая система.
    • Сервера.
    • Сеть и ее аппаратура. Классификация сетей, локальная вычислительная сеть, пять типов топологии, телефонная проводка, USB-сети, беспроводные сети, электрические сети, история Internet-а, GOVNET, o World Wide Web-е, o Universal Resource Locator, сетевые карты, сетевые термины, сетевое оборудование, межсетевые экраны.
    • Другие компьютеры.
  • Небольшие советы.
  • Глоссарий. Краткий справочник сокращений и наименований.
Вот собственно и все главы Азбуки...

© Dmitry Belousov
ноябрь 2001г.-июнь 2003г.

[ оглавление | вступление | начало | глоссарий ]


"Азбука РС", учебник Дм.Белоусова

...Ничему нельзя научить,
... всему можно только научиться...
Персональный компьютер
или
"Азбука PC" для начинающих
Автор рад приветствовать Вас на своих страницах, посвященных азам информационно-коммуникационных технологий - науки, связанной с применением компьютера. Представляю свою небольшую книгу, адресованную:
  • Школьникам средней школы (для уроков информатики и ИКТ);
  • Студентам ВУЗов (помощь к самостоятельной подготовке);
  • Людям любого возраста (делающим первые шаги в освоении ПК);
  • Преподавателям информатики (здесь все и сразу и совсем нет "воды", только суть);
  • Всем пользователям ПК (для создания целостной картины);
Напоминаю, что еще с 01.09.2002г., согласно распоряжению МинОбразования РФ, в программу средней школы (со второго класса) обязательно включается урок информационно-коммуникационных технологий (ИКТ, минимум 1 урок в неделю). Основные и главные отличия этой книги от множества публикаций (книг, статей, обозрений, etc.):
  1. даны ВСЕ компьютерные азы полностью (это первая подобная публикация в России);
  2. все очень-очень кратко;
  3. выстроена стройная система "who is who";
В основном эта информация адресована совсем начинающим пользователям, но и люди, вроде бы "умеющие щелкать мышкой", найдут для себя немало интересного, ибо работать на ПК и знать его - увы, две абсолютно разные вещи.
Практика показывает, что сведений в объеме этой книги достаточно для того, чтобы пользователь усвоил АЗЫ компьютера ПРАВИЛЬНО. Вся информация не только визуально подана в виде наглядных и простых схем, но и детально прописана и соответственно не должна представлять сложности в восприятии.
Конечно, в специальной технической литературе (книгах, журналах, справочниках и т.п.) конкретные "узкие" темы будут описаны более подробно. Я же стремился заложить правильный базис (основу, фундамент) или говоря русским языком - азбуку: что, из чего и куда. Освоите азбуку - вот тогда и читайте умные книжки. Технически учебник создан в электронном виде для показа через проектор или монитор (в HTML-коде, специально без всяких дизайнерских изысков & аплетов). Гиперссылки позволили:
1. легко сделать перекрестные ссылки;
2. уменьшить объем и увеличить наглядность;
3. избавить файлы от word-овых вирусов;
Внизу каждой страницы Вы найдете небольшое оглавление, позволяющее как последовательно идти по главам, так и читать выборочно. И давайте сразу оговоримся - в этом учебнике Вы
- не найдете по-шаговых описаний "как работать" в какой-либо программе;
- не найдете сравнительных тестов на производительность;
- не найдете советов по настройке системы;
- не найдете схем-инструкций по модернизации & разгону;
и т.д. и т.п. И уж конечно здесь нет рекламы (упаси боже). Это именно азбука, бесплатная таблица умножения для совсем начинающих.
На каждой странице обязательно будет немного компьютерного слэнга, выделенного ковычками (например память - "мозги", материнская плата - "мама"). Для начинающих пользователей эти названия звучат дико, иногда даже пошло. Но они активно используются компьютерщиками в обыденной речи и не упоминать о них было бы неправильно. Для облегчения чтения перед началом каждой главы и кое-где прямо в текст вставлены юмористические фразы и анекдоты о компьютерах. Они выделены цветом, вот так: "... Hе надо очеловечивать компьютеры, они этого страсть как не любят!...". Обращаю внимание, что все эти фразы рассчитаны на людей, имеющих чувство юмора (остальным рекомендуется эти анекдоты не читать).
Не пытайтесь "проглотить" АЗБУКУ. Так Вы только создадите путаницу в голове. Отнеситесь к Азбуке серьезно и не спешите, если хотите получить настоящие знания.
Вот собственно и все вступление. Книга лежит в Internet-е большими (периодически обновляемыми) zip-архивами, впервые она стала доступна народу аж 31.10.2002г. Обращаю Ваше внимание на то, что:
  1. в окошечке (под ссылкой) указана дата модификации учебника - Вы всегда можете скачать более новую полную версию. Для проверки, что выходило, привожу сведения о трех последних обновлениях и планах, действующий архив выделен серым:

    Дата обновления | 01.02.2003г | 07.04.2003г | 10.12.2003г | Планы
    Кол-во файлов | 104 | 116 | 163 | весна 2005г.
    Объем zip-a | 2.035 Кб | 2.318 Кб | 3.398 Кб
    Поскольку сразу нельзя "объять необъятное", некоторые главы еще не закончены и часть гиперссылок внутри пока еще не работает. Т.е. если Вы щелкнете по такой, пока не работающей ссылке, браузером MS IE, то выскочит пустая страница. Другие (нормальные) браузеры просто покажут, что файла нет. Чтобы сразу ответить на вопрос, какие главы есть в книге (а каких нет), прямо здесь в Internet-e есть файл оглавления книги. Вы можете открыть его прямо сейчас и посмотреть. Но к некоторым, уже написанным главам, планирую вернуться впоследствии повторно - осветить более подробно сложную тему.
  2. для тех "чайников со свистком", которые книгу с даже позавчерашней датой считают устаревшей, пишу специально: эта Азбука ПК не нуждается в частых обновлениях. Ибо ПК-основы не меняются! Поэтому нечто подобное до сих пор ни у кого и не вышло в печати (без регулярных изменений печатный тираж или невыгоден, или должен стоить заоблачно дорого).
  3. указан размер каждого zip-a. Использовался "старый" WinZip 8.0. Напоминаю, что "доблестный гнилой" браузер MS Internet Explorer имеет много глюков и как следствие, недо-каченный Вами zip не распакуется. Поэтому лучше скачивать не через меню правой кнопки мыши ("Save As..) и не простым щелчком мыши (с MS Internet Explorer - упаси боже!), а только через программы ftp-докачки (напр. очень популярны GetRight или Reget). В этом случае даже при длительном прерывании связи процесс скачивания продолжится с места разрыва.

Данная публикация является не-коммерческой. Хотя автор никогда не претендовал на огромную популярность данной книги, он приветствует распространение "Азбуки РС" в печатном и электронном виде при соблюдении четырех условий:

  1. "Азбука РС" распространяется целиком и бесплатно.
  2. "Азбука РС" не подвергается модификации без согласия автора.
  3. "Азбука РС" нельзя использовать в платных и бесплатных учебных курсах, в издании в виде книг, брошюр и статей, размещать материал на коммерческих компакт-дисках и web-сайтах.
  4. "Азбука РС" распространяется с указанием следующих сведений об авторе: имя ( Дмитрий Белоусов ), e-mail ( dmitry@belousov.spb.su ), город ( г.Санкт-Петербург )
Любое отступление от указанных выше условий должно быть предварительно обсуждено с автором. Нарушение данных условий является нарушением закона РФ об авторском праве и карается согласно статье Административного кодекса РФ.

Успехов Вам и Вашим близким!

© Dmitry Belousov
ноябрь 2001г.-январь 2005г.


"Азбука РС" Дм.Белоусова, словарь

Словарь сокращений

Автор "Азбуки" попытался собрать вместе наиболее часто употребляемые компьютерные сокращения и термины. Дается расшифровка и комментарии. Основу словаря составили небольшие личные справочники автора, дополненные "по мелочи" как терминами из существующих словарей, свободно доступных в Internet-е ("Словарь аббревиатур" Ю.П.Цуканова 1995 года, "Словарь Пржиялковского", "Словарь книги Э.Ратч", STING-glossary и т.п.), так и словариками из компьютерной периодики ("Англо-русский словарь терминов по вычислительной технике" журнала "PC Magazin/RE", журналов "Hard&Soft" и "Мир ПК", еженедельника "PC Week" и пр.). Словарь ориентирован в основном на "простого компьютерного пользователя" (user-a).
В тексте имеется 27 глав, содержащих ~2500 терминов.

© Dmitry Belousov
www.infocentre.spb.ru
ноябрь 2001г.-июнь 2002г.
г.Cанкт-Петербург

рус 0 A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

[ оглавление | начало | советы | глоссарий | обновить ]

Русские сокращения

 АПД    аппаратура передачи данных
 АТС    автоматическая телефонная станция
 ГИП    графический интерфейс пользователя
 ДЗУП   динамическое ЗУ с произвольной выборкой
 ЗУПД   запоминающее устройство с прямым доступом
 ИИ     искусственный интеллект
 ИС     интегральная схема
 КМОП   комплементарная структура металл-оксид-полупроводник
 ЛС     локальная сеть
 МК     многотерминальные комплексы
 МОП    структура металл-оксид-полупроводник
 НГМД   накопитель на гибких магнитных дисках
 НМЛ    накопители на магнитной ленте
 ОЗУ    оперативное запоминающее устройство
 ОС     операционная система
 ПЗУ    постоянное запоминающее устройство
 ПИН    персональный идентификационный номер
 ПК     персональный компьютер
 ПО     программное обеспечение
 СДРД   сотовая пакетная передача данных
 СИ     системная интеграция
 СКЗИ   система криптографической защиты информации
 СППР   cистема поддержки принятия решений: система, обеспечивающая на базе имеющихся данных
        получение средним управляющим звеном информации, необходимой для тактического
        планирования и деятельности. Опирается в значительной степени на анализ данных в БД
        (по современным представлениям - в складе данных) визуальными средствами (графики) и
        средней сложности статистическими или иными математическими методами. См.DSS
 СУБД - система управления базой данных
 ТЦМС - территориальные центры междугородней связи
 ЭВМ  - электронная вычислительная машина
 ЭЛТ  - электронно-лучевая
 ЭСЛ  - эмиттерно-связанная логика
0
 3DA     Three Dimentional Architecture, трёхмерная архитектура
 3DMF    3D Metafile, формат файлов трёхмерной графики кросс-платформенного
         пакета QuickDraw
 3GL     Third Generation Language,
         язык ( программирования ) третьего поколения
 4GL     Fourth Generation Language,
         язык ( программирования ) четвертого поколения
 5GL     Fifth Generation Language,
         язык ( программирования ) пятого поколения
A
 AAC     Alternative access carrier, альтернативный поставщик службы доступа
         (частная компания-поставщик сетевых услуг)
 AACS    Asynchronous address communication system, асинхронно-адресная сис-
         тема связи
 AAD     Active addressing display, дисплей с активной адресацией
 AAI     Application-to-Application Interface,
         интерфейс связи между приложениями
 AAL     ATM Adaptation Layel, адаптационный уровень ATM ( преобразует битовые
         потоки данных конечного пользователя в ячейки данных АТМ )
 AAP     Accounting Analysis Pack for Excel, программы-расширения к МS Excel
 AAR     automatic alternative routing,
         автоматическая альтернативная маршрутизация (с автоматическим обходом
         неисправных узлов)
 AAS     Advanced Automation System,
         система автоматизации с дополнительными возможностями
 ABC     1. Activity Based Costing, оплата на базе фактического использования
           (сетевых услуг, лицензионных программ и т.п.);
         2. Application Building Classes, классы построения приложений
 ABDL    automatic binary data link,
         линия автоматической передачи двоичных данных
 ABI     Application Binary Interface, двоичный интерфейс приложений
         (спецификация взаимодействия прикладных программ с ОС Unix SVR.4)
 ABIOS   Advanced Basic Input/Output System, усовершенствованная BIOS
         ( с поддержкой защищенного режима в среде OS/2)
 ABR     available bit rate, доступная скорость передачи двоичных данных
 ABVS    Advanced Broadcasting Video Services,
         усовершенствованная служба видеовещания
 AC      1. access control, управление доступом;
         2. alternating current, переменный ток
 ACA     Application Control Architecture,
         архитектура управления приложениями
 ACB     audio conference bridge, микшер для речевой конференц-связи
 ACCESS  1. automatic computer-controlled electronic scanning system,
         автоматическая электронная система сканирования с управлением от ЭВМ
         2. Microsoft Access for Windows3.*, 16-разрядная СУБД
         3. Microsoft Access for Windows95, 32-разрядная СУБД
 ACD     Automatic call distribution ( distributor )
         автоматическое распределение вызовов ( в системах телефонной связи)
 ACE     1. Access control encryption, шифрование управления доступом;
         2. Access control equipment, аппаратура управления доступом;
         3. Advanced Computing Environment, перспективная вычислительная
           среда (группа фирм-производителей, разрабатывающих среду для ПК и
           рабочих станций,в которую входят Digital Equipment, Compaq, Micro-
           soft и др.компании)
 ACF     Advanced communications function, развитая функция связи
 ACI     Adjacent channel interference, помеха от соседнего канала
 ACIA    Asynchronous communications interface adapter,
         адаптер асинхронной связи
 ACID    Automatic classification and interpretation of data
         автоматическая классификация и интерпретация данных
 ACL     1. Access Control List, список контроля доступа;
         2. authorization control list,
         2а) контрольный список для санкционирования доступа,
         2б) контрольный список для проверки числа пользователей в сети
 ACM     Association for Computing Machinery,
         Ассоциация по вычислительной технике (США)
 ACMS    1. Application Control and Management System,
           система контроля и администрирования приложений (в среде VAX;
           обеспечивает высокую надежность обработки транзакций);
         2. Automated Connection Manager Server, сервер автоматизированного
           управления соединениями ACPA Association of Computer Programmers
           and Analysts,Ассоциация программистов и системных аналитиков (США)
 ACS     1. Asynchronous Communications Server, сервер асинхронной связи;
         2. automated cartridge system, автоматизированная картриджная система
         3. Automated Commercial System,
            автоматизированная коммерческая система
 ACSE    Association Control Service Element, элемент службы управления ассо-
         цияцией ( протокол прикладного уровня )
 ACT     Association of Color Thermoprinting,
         Ассоциация по цветной термопечати
 ACU     automatic calling unit, автоматическое вызывное устройство
 ADA     automatic data acquisition, автоматический сбор данных
 ADB     Apple Desktop Bus, шина настольных систем фирмы Apple Computer
         (позволяет подключать несколько устройств к одному разъему)
 ADC     analog-to-digital converter, аналого-цифровой преобразователь
 ADE     Application Development Environment, среда разработки приложений
 ADF     Automatic Document Feeder, автоматический загрузчик оригиналов
         (в копировальном устройстве)
 ADHS    analog data handling system, система обработки аналоговых данных
 ADI     Autodesk Device Interface, интерфейс с периферийными устройствами
         фирмы Autodesk (для системы AutoCAD)
 ADIS    automatic data interchange system, система автоматического обмена
         данными
 ADL     1. animation description language, язык описания анимации;
         2. automated data library, автоматизированная библиотека данных
 ADMD    Administration Management Domain, домен административного управления
         (каждая отдельная сеть, входящая в Internet)
 ADP     automatic data processing, автоматическая обработка данных
 ADPCM   Adaptive Differential Pulse Code Modulation, адаптивная дифференци-
         альная импульсно-кодовая модуляция (стандарт сжатия аудиоинформации)
 ADPE    automatic data processing equipment, оборудование для автоматической
         обработки данных
 ADPS    automatic data processing system, система автоматической обработки
         данных
 ADS     Administration Server, административный сервер
 ADSL    Asymmetrical Digital Subscriber Line, асимметричная цифровая або-
         нентская линия ( для кабельных модемов )
 ADW     Application Development Workbench,
         инструментальная система разработки приложений
 ADX     automatic data exchange, автоматический обмен данными
 AEA     American Electronics Association, Американская ассоциация электроники
 AEB     Analog expansion bus, аналоговое электрическое соединение между раз-
         личными платами компьютерной телефонии, установленными в одном шасси
 AEC     1. Authorized Education Center, авторизованный учебный центр
         2. automatic error correction, автоматическое исправление ошибок
 AEP     Application Environment Profiles, профили прикладной среды
         (дополнения к стандарту POSIX, ориентированные на специализированные
         приложения реального времени)
 AES     1. Application Environment Specifications, спецификации среды прик-
          ладных программ (утверждены OSF);
         2. auto emulation switching, автоматическое переключение эмуляции
          (режим автоматического распознавания принтером управляющего
          языка входного текста)
 AFI     Authority and Format Identifier, идентификатор полномочий и формата
 AFIPS   American Federation of Information Processing Societies,
         Американская федерация обществ по обработке информации
 AFM     Applications from Models, приложения на базе моделей
 AFN     Access Feeder Node, узел, обеспечивающий доступ ( в сети )
 AFP     1. Advanced Function Printer, принтер с расширенными функциональными
          возможностями (программа поддержки печати на удаленном принтере);
         2. AppleTalk File Protocol, протокол передачи файлов в сетях
           AppleTalk
 AFR     automatic format recognition, автоматическое распознавание формата
 AGA     Advanced Graphics Adapter, усовершенствованный графический адаптер
 AHT     aggregate hardware test, объединенный тест аппаратных средств
         (для определения производительности ПК)
 AI      Artificial Intelligence, искусственный интеллект
 AIA     Apple Integration Architecture, архитектура интеграции фирмы Apple
 AIE     American Information Exchange, американский информационный обмен
         (система, разработанная фирмой Autodesk и обеспечивающая доступ к
         информации через сеть с оплатой только использованных данных)
 AIFF    Audio Interchange File Format,
         файловый формат для обмена аудиоданными
 AIIM    Association for Information and Image Management, Ассоциация по
         системам управления обработкой информации и изображений (США)
 AIM     associative indexed (access) method, ассоциативный индексный метод
         (доступа)
 AIN     Advanced Intelligent Network, развитая интеллектуальная сеть
 ALE     address lifetime expectation, ожидаемое время актуальности адреса
 ALM     1. Application Loadable Module,
           приложение в виде загружаемого модуля NetWare;
         2. AppWare Loadable Module, загружаемый модуль среды AppWare
 ALU     arithmetical and logical unit, арифметико-логическое устройство
 ALW     Advanced Laboratory Workstation, лабораторная рабочая станция с
         расширенными возможностями
 AMA     absolute mail address, абсолютный почтовый адрес (определяющий
         местоположение адресата электронной почты независимо от маршрута)
 AMAS    automatic message accounting system, автоматическая система учета
         сообщений
 AMCA    Apple Media Control Architecture, архитектура управления носителями
         информации фирмы Apple (стандарт для среды Macintosh)
 AMDS    Automatic Message Distribution System, автоматическая система распре-
         деления сообщений (прикрепления сообщений к определенным заданиям)
 AMIS    Audio Messaging Interchange Specification, спецификация на обмен
         речевыми сообщениями
 AMLCD   active matrix liquid-crystal display, жидкокристаллический дисплей
         на активной матрице
 AMP     asymmetrical multiprocessing,
         асимметричная мультипроцессорная обработка
 AMPS    Advanced Mobile Phone System, усовершенствованная система мобильной
         радиотелефонной связи (стандарт сотовой связи в США)
 AMR     automatic message recording, автоматическая запись (регистрация)
         сообщений
 AMS     Administration and Management Services, службы (сетевого)
         администрирования и управления
 AMTFT   active-matrix thin-film transistor,
         дисплей на активной матрице тонкопленочных транзисторов
 ANDF    Architecture Neutral Distribution Format,
         независимый от архитектуры формат электронного распространения прог-
         раммного обеспечения (разработанная фирмой USL технология компиляции
         программ, позволяющая создавать единую версию готового программного
         продукта одновременно для нескольких платформ)
 ANI     automatic number identification,
         автоматическое определение номера (телефона)
 ANO     automated network operations, автоматизированная эксплуатация сети
 ANR     Automatic Network Routing, автоматическая сетевая маршрутизация
         (составная часть HPR)
 ANS     American National Standard, американский национальный стандарт
 ANSI    American National Standards Institute, Американский национальный
         институт стандартов ( основан в 1918 году )
 AOC     automated operations control,
         автоматизированное управление эксплуатацией
 AOCE    Apple Open Collaboration Environment, открытая среда взаимодействия
         фирмы Apple (набор интерфейсов прикладного программирования)
 APA     all points addressable, полноадресуемый (дисплей с адресацией
         пикселов)
 APCUG   Association of PC Users Groups, Ассоциация групп пользователей ПК
 APD     average packet delay, средняя задержка пакетов
 API     Application Programming Interface, интерфейс прикладного программи-
         рования (набор функций, доступных  прикладным программам и обеспечи-
         вающих построение пользовательского интерфейса, обмен информацией,
         внутрисистемный сервис и т.д.)
 APIC    Advanced Programmable Interrupt Controller, усовершенствованный
         программируемый контроллер прерываний ( стандарт фирмы Intel на
         контроллер прерываний для мультипроцессорных систем)
 APM     Advanced Power Management, усовершенствованное управление питанием
         (спецификация для ПК-блокнотов,предложенная фирмами Intel и Microsoft
         и позволяющая продлить время работы батарей; предполагает наличие
         некоторого интерфейса прикладных программ с BIOS)
 APP     Application Portability Profile, прикладной переносимый профиль
         ( спецификация, разработанная NIST для OSE, на базе которой фирмы
         могут развивать свои прикладные профили)
 APPC    Advanced Program-to-Program Communications, развитая связь между
         программами (интерфейс,разработанный фирмой IBM и входящий в сетевую
         архитектуру SNA для использования в локальных сетях)
 APPI    Advanced Peer-to-Peer Internetworking, развитая архитектура связи
         одноуровневых сетей (схема маршрутизации для сетей SNA, предложенная
         фирмой Cisco Systems)
 APPI/COM   Application/Communication,"приложения/связь" (интерфейс,
         независимый от особенностей аппаратной платформы)
 APPN    Advanced Peer-to-Peer Networking, развитая архитектура ( улучшенный
         протокол ) одноуровневых ( одноранговых ) сетей ( схема маршрутизации
         фирмы IBM для сетей System Network Architecture )
 APPN-NN    Advanced Peer-to-Peer Networking - Network Node,
         развитая архитектура одноуровневых сетей - сетевой узел ( технология
         фирмы IBM, позволяющая, в отличие от SNA, рабочим станциям иницииро-
         вать связь без обращения к хост-машинам )
 APRP    Adaptive Pattern Recognition Process, активное распознование образов
 APS     1. Asynchronous Protocol Specification,
           спецификация асинхронного протокола (стандарт);
         2. Automated Patent System,
           автоматизированная патентная система APSE Ada Programming Support
           Environment, среда поддержки программирования на языке Ада
 APT     1. Advanced Parallel Technology, развитая параллельная технология
           (обеспечивает переадресацию трафика приложений в среде Windows в
           параллельный порт вместо последовательного в целях увеличения ско-
           рости передачи данных; предложена фирмой Microcom);
         2. all-picture transfer, передача полного изображения;
         3. application programming tools,
           инструментальные средства прикладного программирования
 AR      Automatic restoration, автоматическое восстановление (данных)
 ARA     Apple Remote Access,
         метод дистанционного доступа фирмы Apple ( протокол )
 ARAP    AppleTalk Remote Access Protocol, протокол удаленного доступа в
         сетях AppleTalk
 ARCnet  Attached Resourse Computing network, вычислительная сеть с присое-
         диненными ресурсами (стандарт локальной сети, разработанный фирмой
         Datapoint и используемый в учрежденческих системах)
 ARDIS   Advanced Radio Data Information Services, усовершенствованная инфор-
         мационная служба радиопередачи данных (одна из беспроводных сетей в
         США)
 ARL     Access Rights List, список пользователей, имеющих право доступа
 ARLL    advanced run-length-limited, усовершенствованный (код) с ограничением
         длины ( используется в контроллерах жестких дисков )
 ARM     Advanced Recovery Mode, усовершенствованный режим восстановления
         информации (на жестком диске)
 ARM     asynchronous response mode, режим асинхронного ответа
 AROM    Alterable Read-Only Memory, перепрограммируемое ПЗУ
 ARP     Address Resolution Protocol, протокол определения ( дешифрования) ад-
         ресов (протокол низкого уровня из набора TCP/IP; используется для оп-
         ределения физического адрес узла по известному логическому IP-адресу,
         преобразует IP-адрес в специфический аппаратный адрес )
 ARPA    Advanced Research Projects Agency, Управление перспективных иссле-
         дований и разработок ( Министества обороны США; некоторое время назы-
         валось DARPA)
 ARPANET    Advanced Research Projects Agency Network, сеть ARPA ( имевшая
         преимущественно экспериментальный характер и использовавшаяся для
         разработки многих сетевых протоколов, включая TCP/IP)
 ART     1. Adaptive Recognition Technology,
           технология адаптивного распознавания (образов);
         2. Automatic Recognition Technology,
           технология автоматического распознавания (интерфейса принтера)
 ARTA    Apple Real-Time Architecture,
         архитектура реального времени фирмы Apple
 AS      Architectural Simulator, архитектурный имитатор
 ASA     1. American Software Association,
           Американская ассоциация программного обеспечения;
         2. American Standards Association,
           Американская ассоциация по стандартизации
 ASCII   American Standard Code for Information Interchange,
         Американский стандартный код для обмена информацией
 ASD     automated software distribution,
         автоматизированное распространение программного обеспечения
 ASE     Accredited System Engineer, уполномоченный инженер-системотехник
 ASF     automatic sheet feed, автоматическая подача бумаги (в принтере)
 ASI     asynchronous serial interface,
         асинхронный последовательный интерфейс
 ASIC    applications specific integrated circuitry ( circuits ),
         специализированные интегральные схемы
 ASIS    American Society for Information Science,
         Американское общество по информатике
 ASN     Abstract Syntax Notation, правила задания структур данных, переда-
         ваемых по сети OSI ( система обозначений для описания абстрактного
         синтаксиса )
 ASPI    Advanced SCSI Programming Interface, развитой интерфейс программиро-
         вания SCSI ( разработан фирмой Adaptec для программирования SCSI-
         -устройств в среде MS DOS)
 ASR     automatic speech recognition, автоматическое распознавание речи
 ATC     authorized training center, авторизованный учебный центр
 ATCP    AppleTalk Control Protocol, управляющий протокол среды AppleTalk
         (протокол высокого уровня, используемый в глобальных сетях поверх
         протокола PPP)
 ATDM    asynchronous time division multiplexing, асинхронное мультиплексиро-
         вание с разделением времени (временное уплотнение)
 ATM     1. Asynchronous Transfer Mode, асинхронный режим передачи ( стандарт
         МККТТ, определяющий трансляцию ячеек; предусматривает выделение про-
         пускной способности по требованию; ориентирован на коммутацию, а не
         на общую среду )
         2. Automatic Teller Machine,
         2а) торговый автомат   2б) банковский автомат, банкомат
 ATP     ATM Interface Processor, интерфейсный процессор ATM
 ATRN    Active Token Ring Network, активная сеть типа Token Ring
         ( с доступом по системе маркерного кольца)
 ATS     Automatic Transfer System, система автоматического перевода средств
 ATX     ATX, стандарт на конструктивное исполнение корпусов, блоков питания
         и системных плат ПК
 AUI     1. Access Unit Interface, интерфейс устройств доступа;
         2. attachment unit interface, интерфейс устройств подключения
           (интерфейс между приемопередатчиком и сетевым блоком сопряжения)
 AURP    AppleTalk Update-based Routing Protocol, протокол маршрутизации с
         обновлением среды AppleTalk ( предназначен для маршрутизации данных
         через граничные шлюзы глобальных сетей )
 AVI     Audio Video Interlaced, чередование аудио и видео ( технология фирмы
         Microsoft в области систем мультимедиа )
 AVNP    Autonomous Virtual Network Protocol, протокол автономной виртуальной
         сети
 AVR     automatic voice recognition, автоматическое распознавание речи ( голоса )
B
 BACP    Bandwidth Allocation Control Protocol, протокол управления распреде-
         лением пропускной способности
 BAM     basic access method, базисный метод доступа
 BASIC   beginner's all-purpose symbolic instruction code, универсальная сис-
         тема символического кодирования для начинающих ( язык программирова-
         ния Бейсик)
 BBS     1. Building-block system, модульная система;
         2. Bulletin Board Service ( System ),
          а) (компьютерная) служба (система) публикации объявлений
          б) электронная доска объявлений
 BC      broadband channel, широкополосный канал
 BCC     block check character,
         символ контроля блока ( содержащий контрольную сумму )
 BCD     Binary-coded decimal, двоично-десятичный код
 BCN     1. Broadband communication network, широкополосная сеть связи;
         2. Business communication network, коммерческая сеть связи
          ( для передачи финансовой и деловой информации )
 BCR     Business Card Reader, устройство чтения визитных карточек
 BCS     basic catalog structure, базовая структура каталога
 BDAM    basic direct access method, базисный прямой метод доступа
 BDC     backup domain controller, резервный контроллер домена ( принимает на
         себя управляющие функции при отказе PDC )
 BDE     Borland Database Engine, машина баз данных фирмы Borland ( библиотека
         модулей DLL, механизм общения различных баз данных, один из главных
         компонентов BOCA )
 BDF     Business Design Facility, средство разработки бизнес-модели
 BDOS    Basic disk operating system, базовая дисковая операционная система
 BEP     Back-end processor,
         а) постпроцессор    б) процессор файлов   в) процессор базы данных
         г) процессор ( программный ), функционирующий на сервере BER Bit
         Error Rate, коэффициент битовой ошибки ( вероятность появления
         ошибочного бита при считывании информации с носителя )
 BFS     Boot File System, загрузочная файловая система ( поддерживающая
         загрузку независимо от используемой файловой системы операционной
         среды )
 BFT     Binary file transfer, передача двоичных файлов ( стандарт )
 BGI     Borland Graphics Interface, графический интерфейс фирмы Borland
 BIC     Bus interface controller, контроллер магистрального интерфейса
         ( используется в высокопроизводительных магистральных интерфейсах
         типа Multibus II )
 BICI    Broadband intercarrier interface, интерфейс широкополосной связи
         частных региональных сетей
 BICMOS  Bipolar complementary metal-oxide-semiconductor, биполярная КМОП-
         технология (комбинированная технология ИС на биполярных и комплемен-
         тарных МОП-транзисторах)
 BIDM    Basic Interoperability Data Model, базовая модель данных для обеспе-
         чения взаимодействия библиотек ( стандарт, подмножество UDM )
 BIOS    Basic Input/Output System, базовая система ввода/вывода
 BISDN   Broadband ISDN, широкополосная сеть ISDN ( и соответствующая иерархи-
         ческая четырехуровневая модель протоколов)
 BIST    Built-in self test, встроенный тест для самопроверки
 BIT     Broadband Infrastructure Technology, технология широкополосной
         инфраструктуры ( программа ARPA по созданию базовых сетей с использо-
         ванием технологий ATM и SONET )
 BITNET  Because It's Time Network, "сеть, время которой пришло",
         сеть BITNET ( сеть связи между университетами в США и Европе )
 BIU     Buffer interface unit, блок сопряжения с буфером
 BLOB    Binary Large Object Block, большой блок двоично-кодированных данных
         объекта (см. BLOb)
 BLOb    Binary Large Objects, большие двоичные объекты (обобщенный тип объек-
         тов, предложенный фирмой Borland и позволяющий хранить графики, фо-
         тографии, аудио- или видеозаписи )
 BLR     Binary Language Representation, язык двоичного представления ( инфор-
         мации; используется для обращения к базам данных на внутреннем уровне
         СУБД; элемент BOCA)
 BMS     1. Broadcast Message Server, сервер вещательной рассылки сообщений;
         2. Business Management System, коммерческая управляющая система
          ( система выписывания счетов за сетевые услуги )
 BMWG    Benchmarking Methodology Working Group,
         Рабочая группа по методологии эталонных испытаний (в составе IETF)
 BNA     Broadband Network Architecture, архитектура широкополосных сетей
         ( предложена фирмой IBM )
 BNC     Baby N-connector, соединитель типа "бэби N" (для проводов)
 BNS     Broadband Network Services, широкополосная сетевая служба
         ( архитектура фирмы IBM )
 BNU     Basic Networking Utilities, базовые сетевые утилиты
 BOCA    Borland Object Component Architecture, архитектура объектных компо-
         нентов фирмы Borland ( главными компонентами являются Borland Desktop
         - среда объектов, общих для разных прикладных программ, и машина баз
         данных BDE )
 BOOTP   Bootstrap Protocol, протокол начальной загрузки (в составе TCP/IP)
 BOP     Bit-oriented protocol, протокол побитовой передачи данных
 BOS     Basic operating system, базовая операционная система
 BPI     Bits per inch, (число) битов на дюйм ( единица измерения плотности
         записи на магнитной ленте )
 BPR     Business Process Reengineering,
         реорганизация (реинжениринг) системы ведения бизнеса
 BPS     Bits per second, (число) битов в секунду (единица измерения скорости
         передачи по каналам связи)
 BR      1. Boundary Routing, граничная маршрутизация (технология, предло-
          женная фирмой 3Com)
         2. Тэг языка HTML
 BRI     Basic Rate Interface, интерфейс передачи данных (по телефонной линии)
         с номинальной скоростью ( стандарт, описывающий способы подключения
         терминалов и телефонов абонентов к коммутаторам сети ISDN)
 BRIM    Bridge Router Interface Module ( напр.BRIM-E100 $995 ),
         интерфейсный модуль моста-маршрутизатора
 BSA     Business Software Association (Alliance),
         Aссоциация (Союз) производителей программ для бизнеса
 BSAM    Basic sequential access method,
         базисный последовательный метод доступа
 BSC     1. Binary Synchronous Communications, телекоммуникационный протокол,
          использующий стандартный набор символов управления передачей и пос-
          ледовательностей управляющих символов; двоичная синхронная связь
          ( передача данных )
         2. binary synchronous control, двоичное синхронное управление
          ( протокол двоичной синхронной передачи данных, разработанный фирмой
          IBM для дистанционного ввода/вывода заданий с терминалов в системах
          IBM 360/370 )
 BSCA    Binary synchronous communication adapter,
         адаптер двоичной синхронной передачи ( данных )
 BTAC    Branch target address cache, кэш-память адресов ветвлений
 BTAM    Basic telecommunication access method,
         базисный телекоммуникационный метод доступа
 BTB     Branch target buffer, буфер адресов ветвлений
 BTU     Basic transmission unit, основной блок передачи (данных)
 BUS     Broadcast and Unknown Server, сервер широковещательной рассылки и
         идентификации неопознанных ресурсов ( в технологии эмуляции локальных
         сетей в режиме ATM )
 BW      Black and white ( B&W ), черно-белый
 BWOD    BandWidth On Demand,
         режим выбора пропускной способности по требованию
C
 CABE    Computer-Aided Business Engineering,
         автоматизированное проектирование бизнеса
 CAD     Computer-Aided Design,
         1) автоматизированное проектирование,
         2) система автоматизированного проектирования ( САПР )
 CADD    computer-aided design and drafting,
         1) автоматизированное проектирование и оформление чертежей,
         2) система автоматизированного проектирования и оформления чертежей
 CADE    Computer-aided design and evaluation,
         автоматизированное проектирование и оценка
 CADIS   computer-aided design interactive system,
         интерактивная система автоматизированного проектирования
 CADL    communication and data line, линия связи и передачи данных
 CADS    computer-aided design system,
         система автоматизированного проектирования (САПР)
 CAE     1. Common Application Environment, общая прикладная среда (предназна-
          чена для обеспечения переносимости приложений, разработана консор-
          циумом X/Open);
         2. computer-aided engineering,
          а) автоматизированная подготовка производства,
          б) автоматизированная разработка,
          в) автоматизированное конструирование,
          г) автоматизированное моделирование
 CAI      computer-aided instruction, машинное обучение
 CAM     1. computer-aided management, автоматизированное управление;
         2. Computer-Aided Manufacturing,
          а) автоматизированное производство,
          б) система автоматизированного производства (САП);
         3. Controlled Attachment Module,
          управляемый модуль подключения к среде
 CAMAC   Computer Automated Measurement and Control, автоматизированное с
         помощью ЭВМ измерение и управление (набор стандартов, широко исполь-
         зуемый в системах автоматизации научно-технических экспериментов и
         измерительно-вычислительных комплексах, КАМАК )
 CAMP    Corporate Association for Microcomputer Professionals,
         Корпоративная ассоциация профессионалов по микрокомпьютерам
 CAN     customer access network, сеть с абонентским доступом
 CAP     1. Communication Access Point, пункт доступа к среде передачи
          ( ассемблер/обратный ассемблер пакетов фирмы Motorola );
         2. Communications Access Processor,процессор доступа к среде передачи;
         3. competitive access providers, компании, предоставляющие развитые
          средства доступа к среде передачи;
         4. computer-aided publishing, компьютерная издательская деятель-
          ность ( автоматизированная подготовка полиграфической продукции)
 CAPM    Computer-aided production management,
         автоматизированное управление производством
 CAQ     computer-aided quality,
         1) автоматизированный контроль качества,
         2) система автоматизированного контроля качества
 CAS     Communication Application Specification, спецификация приложений
         связи ( стандарт,разработанный фирмами Intel и Digital Communications
         Associates для программного обеспечения факс-модемов )
 CASD    computer-aided system design,
         автоматизированное проектирование систем
 CASE    Computer-Aided Software/System Engineering,
         технология, связанная с проектированием, разработкой и сопровожде-
         нием программного обеспечения
 CAT     1. Computer-Aided Technologies, компьютерные технологии;
         2. computer-aided translation, автоматизированный перевод;
         3. computer-aided typesetting, компьютерный набор (текста);
         4. customer-activated terminal, терминал для потребителей,
           банкомат, терминал самообслуживания
 CATV    1. (также CTV ) cable television, кабельное телевидение;
         2. Community Antenna TV, кабельное телевидение с общей антенной
           ( используется в широковещательных локальных сетях )
 CAU     Controlled Access Unit, управляемое устройство доступа
 CAV     Constant Angular Velocity,
         1) постоянная угловая скорость,
         2) соответствующий способ записи изображений ( на лазерном диске
          при постоянной скорости его вращения ),
         3) соответствующий формат лазерного диска ( поддерживающий пошаговый
          захват)
 CBCS    computer-based conference system,
         компьютерная система для проведения конференций
 CBEMA   Computer and Business Equipment Manufacturers Association,
         Ассоциация производителей компьютеров и конторского оборудования
 CBF     computer-based fax, компьютерная факс-машина
 CBIOS   customized BIOS,
         настраиваемая BIOS ( ориентированная на пользователя )
 CBL     computer-based learning, обучение с использованием компьютера
 CBMS    computer-based message system,
         автоматизированная система обработки сообщений (электронная почта)
 CBR     1. Case-Based Reasoning, рассуждения по прецедентам ( в системах
          искусственного интеллекта);
         2. constant bit rate, постоянная скорость передачи двоичных данных;
         3. content-based retrieval, поиск по содержимому;
         4. continuous bit rate, постоянная скорость передачи двоичных данных
          ( сервис передачи неуплотненных данных в сетях ATM)
 CC      color code; цветовой код
 CCB     cyclic check byte, байт циклического контроля ( сопровождающий
         запись блока данных на магнитном носителе)
 CCC     Copyright Clearance Center, Центр по проверке авторских прав (США)
 CCD     charge coupled device, прибор с зарядовой связью
         ( технология, применяемая в датчиках сканеров )
 CCE     Collaborative Computing Environment, среда совместных вычислений
         ( модульная архитектура фирмы Novell для работы с приложениями
         других поставщиков )
 CCF     Common Communication Format, единый коммуникационный формат
 CCIA    Computer and Communucations Industry Association,
         Ассоциация производителей компьютеров и средств связи (США)
 CCIRN   Coordinating Committee for Intercontinental Research Networks,
         Координационный комитет по межконтинентальным исследовательским
         сетям (содействует исследованиям по глобальным сетевым вопросам;
         объединяет сети различных стран)
 CCITT   Consultative Committee on International Telephony & Telegraphy,
         Международный консультативный комитет по телеграфии и телефонии
         - МККТТ, устанавливает коммуникационные стандарты  ( современное
         название - ITU-TSS )
 CCL     Communication Control Language, язык управления передачей (данных)
 CCP     1. Certified Computing Professional,
          сертифицированный специалист по вычислительной технике;
         2. communication control program,
          программа управления передачей (данных)
 CCS     1. Common Command Set, унифицированный список команд
          ( в стандарте SCSI );
         2. Common Communication Support, унифицированная поддержка связи
          ( стандарт  IBM для сетевого телекоммуникационного оборудования )
 CCU     1. Common Control Unit, общее устройство управления;
         2. communication control unit, блок управления передачей (данных)
 CD      Compact Disk, компакт-диск
 CDC     common data channel, общий канал передачи данных
 DA      compact disk-digital audio, цифровой аудио компакт-диск
         ( лазерный аудиодиск )
 CDDI    Copper Distributed Data Interface,распределенный интерфейс передачи
         данных по кабельным линиям ( вариант FDDI для кабельных линий)
 CDE     1. Common Desktop Environment,
          общая вычислительная среда для настольных систем;
         2. Cooperative Development Environment, среда коллективной
          разработки программ (стандартная спецификация Unix)
 CDF     Сomma delimited format, формат с разделителями-запятыми
 CDFS    CD-ROM File System, файловая система на компакт-дисках
 CDI     ( CD-I ) compact disk interactive, интерактивный компакт-диск ( стан-
         дарт, позволяющий записывать звук, графику и движущиеся изображения
         на один и тот же диск; разработан фирмой Philips совместно с Sony и
         Matsushita )
 CDMA    Code Division Multiple Access,
         множественный доступ с кодовым разделением ( каналов )
 CDP     communication data processor, процессор передачи данных ( выполня-
         ющий функции управления каналами передачи данных, предварительной
         обработки сообщений, преобразования кодов, защиты от ошибок в кана-
         лах связи)
 CDPD    Cellular Digital Packet Data, пакеты цифровых данных сотовой сети
         ( стандарт на пересылку пакетов по не используемым в данное время
         линиям речевой связи в сотовой сети )
 CDPS    communication data processing system,
         система передачи и обработки данных
 CDROM   Compact Disk Read-Only Memory, ПЗУ на компакт-дисках
 CD/XA   CD-ROM/Extended Architecture, ПЗУ на компакт-дисках/расширенная
         архитектура (расширенная спецификация стандарта компакт-дисков)
 CEC     Communications Engine Controller, контроллер коммуникационного про-
         цессора ( процессор, являющийся сервером маршрутизации через магист-
         раль по протоколу IMS в многопроцессорной архитектуре фирмы 3Com)
 CEDD    Committee for the Exchange of Digital Data, Комитет по обмену цифро-
         вой информацией ( США )
 CEM     contract electronic manufacturers, изготовители электронной аппара-
         туры (смонтированных печатных плат ) на заказ
 CEO     Chief Executive Officer, главный администратор,
         генеральный директор, распорядитель (компании)
 CERT    Computer Emergency Response Team, группа реагирования на нарушения
         компьютерной защиты (в сети Internet)
 CFO     Chief Financial Officer, вице-президент (компании) по финансам,
         финансовый директор
 CFOOT   Corporate Facilitators of Object-Oriented Technology, корпоративные
         средства внедрения объектно-ориентированной технологии
 CGA     Color Graphics Adaptor, адаптер цветной графики
         ( а также соответствующие цветной монитор и стандарт )
 CGI     1. Computer Graphics Interface, интерфейс компьютерной графики
         2а. Common Gateway Interface
         2б. Common Graphics Interface, стандартный интерфейс для межсетевых
         шлюзов и информационных серверов
 CGM     computer graphics metafile, метафайл компьютерной графики
         ( стандартный формат хранения и передачи изображений )
 CHAP    Challenge-Handshake Authentication Protocol,
         протокол аутентификации по квитированию вызова
 CHDL    Computer Hardware Description Language,
         язык описания аппаратной части ЭВМ
 CHI     computer human interface, интерфейс "человек-машина"
 CI      Component Interface, интерфейс компонентов (интерфейс в составе DMI
         между программой служебного уровня и управляемым устройством)
 CIC     1. carrier (circuit) identification code,
          код идентификации канала;
         2. commercial Internet carriers,
          поставщики платных услуг в сети Internet
 CICS    Customer Information Control System, информационно-управляющая сис-
         тема обслуживания потребителей ( предложена фирмой IBM )
 CID     Configuration, Installation and Distribution, Конфигурация, инстал-
         ляция и распространение (архитектура фирмы IBM для распространения
         программных пакетов по сети )
 CIDR    Classless Inter-Domain Routing,
         бесклассовая междоменная маршрутизация
 CIEA    Commercial Internet Exchange Association,
         Ассоциация обмена коммерческой информацией в сети Internet
 CIF     1. Common Intermediate Format, единый промежуточный формат
          ( стандарт на разрешающую способность при цифровом кодировании/
          /декодировании видеосигналов);
         2. Customer Information File, файл информации о заказчике
 CIM     1. CompuServe Information Manager,
          администратор потоков информации в сети CompuServe;
         2. computer-integrated manufacturing,
          автоматизированное производство;
         3. Corporate Information Management,
          корпоративное информационное управление
 CIO     Chief Information Officer,
         руководитель информационной службы (компании)
 CIOP    communication input/output processor,
         процессор ввода/вывода сообщений
 CIR     committed information rate,
         согласованная скорость передачи информации
 CIS     Customer Interaction Software,
         трёхуровневый пакет поддержки покупателя ( для Web-страниц )
 CISC    Complex (Complete) Instruction Set Computer,
         процессор с полным ( сложным ) набором команд
 CIT     computer-integrated telephony, компьютерная телефония
 CIX     Commercial Internet Exchange,
         1) межсетевой обмен коммерческой информацией,
         2) одноименная некоммерческая торговая ассоциация
 CLI     Call Level Interface, интерфейс на уровне вызовов (коммуникационный
         интерфейс для обеспечения связи между различными базами данных;
         стандарт, предложенный консорциумом SQL Access Group)
 CLM     communication line multiplexing, мультиплексирование линий связи
 CLNP    Connectionless Layer Network Protocol, протокол сетевого уровня в
         модели OSI, не требующий установления канала ( соединения ) перед
         передачей данных ( бесканальный сетевой протокол )
 CLNS    Connectionless Network Service,
         сетевое обслуживание без установления соединения
 CLOS    Common Lisp Object System, общая объектная система языка ЛИСП
         ( стандарт для ряда диалектов этого языка)
 CLP     Cell Loss Priority, приоритет потери элемента данных ( управляющий
         бит, используемый при передачи данных через коммутаторы ATM-сетей )
 CLT     communication line terminal, терминал линии связи, связной терминал
 CLUT    Color Look Up Table, таблица цветов
 CLV     Constant Linear Velocity, 1) постоянная линейная скорость,
         2) соответствующий способ записи изображений ( на лазерном диске,
         при котором скорость вращения диска меняется в процессе записи, а
         постоянной остается скорость лазерного считывающего устройства),
         3) соответствующий формат лазерного диска
 CM      1. command mode, командный режим ( один из двух базовых режимов ра-
          боты модема, см. тж. DM);
         2. Configuration Management, управление конфигурацией
          ( сетевых устройств );
         3. control module, управляющий модуль
 CMA     Communications Managers Association,
         Ассоциация менеджеров в области связи (США)
 CMC     1. Common Mail Call, стандартный вызов электронной почты
         ( интерфейс, разработанный ассоциацией XAPIA );
         2. common messaging call, общий вызов с использованием сообщения;
         3. Computer Mediated Communication,
         связь с использованием компьютеров
 CMIP    Common Management Information Protocol,
         общий протокол передачи управляющей информациии
 CMIS    Common Management Information Service,
         общая служба передачи управляющей информации
 CMISE   Common Management Information Service Element,
         элемент общей информационной службы  управления. Термин из области
         беспроводной связи. Функции описываются протоколом CMIP.
 CMOS    complementary metal-oxide-semiconductor,
         комплементарная структура металл-оксид-полупроводник, КМОП-структура
 CMS     1. Call Management System,
          система управления (телефонными) вызовами;
         2. Color Management System, система управления цветом;
         3. connection management system, система управления соединениями
 CMVC    configuration management and version control,
         управление конфигурацией и контроль версий
 CMW     compartmented mode workstation, рабочая станция, функционирующая в
         сети изолированно от других
 CMY     Cyаn-Magenta-Yellow,
         бирюзовый-пурпурный-желтый ( система цветопередачи )
 CMYK    Cyan-Magenta-Yellow-blacK,
         бирюзовый-пурпурный-желтый-черный ( система цветопередачи )
 CNA     Certified NetWare Administrator,
         сертифицированный администратор среды NetWare
 CNC     computer numerical control, числовое (программное) управление, ЧПУ
 CNE     Certified NetWare Engineer, сертифицированный инженер по NetWare
 CNI     1. Certified NetWare Instructor,
          сертифицированный инструктор по NetWare;
         2. common network interface, общий сетевой интерфейс
 CNIDR   Clearinghouse for Networked Information Discovery and Retrieval,
         Центр координации средств поиска и получения информации по сети
         ( поддерживает разработку инструментальных средств поиска данных в
         сети Internet)
 CNLP    Connectionless Network Layer Protocol, протокол сетевого уровня, не
         ориентированный на установление соединения ( протокол типа "маршру-
         тизатор-маршрутизатор" )
 CNM     Customer Network Management, управление абонентской сетью
 CNX     Certified Network Expert, сертифицированный специалист по сетям
 COBOL   Common Business-Oriented Language, универсальный язык программиро-
         вания, ориентированный на коммерческие задачи, КОБОЛ
 COCOM   Coordinating Committee of East-West Trade Policy,
         Комитет по координации торговли между Западом и Востоком, КОКОМ
 CODE    Client/Server Open Development Environment,
         открытая среда разработки программ типа клиент/сервер
 CODEC   1. coder/decoder, кодер/декодер;
         2. compression/decompression (algorithms),
          алгоритмы сжатия/разворачивания (данных)
 CO IPX  Connection-Oriented IPX, (транспортный) протокол IPX, ориентирован-
         ный на установление соединений
 COL     Computer-oriented language,
         машинно-ориентированный язык ( программирования )
 COM     1. Common Object Model, модель с общими объектами ( спецификация
          фирм Microsoft и Digital Equipment, обеспечивающая совместимость
          технологий объектной компоновки OLE и CORBA);
         2. Component Object Model, объектная модель ( программных ) компо-
          нентов ( лежащая в основе OLE )
 CONS    1. Connection-Oriented Network Service
         2. Connection Mode Network Service
         Служба коммутации каналов, обеспечивающая установление соединения
         в начале сеанса связи и поддержание его до окончания сеанса ( сете-
         вая служба режима соединения )
 COP     character-oriented protocol, протокол посимвольной передачи данных
 COR     connection-oriented routing,
         маршрутизация, ориентированная на установление соединений
 CORBA   Common Object Request Broker Architecture, единая архитектура прог-
         раммы-брокера объектных запросов ( стандарт в составе OMA для мани-
         пулирования объектами в сетевой среде, или объектной компоновки)
 COS     class of service, класс обслуживания
 COSE    Common Open Software Environment, общая среда открытого программного
         обеспечения ( стандарт, разработанный фирмами HP, Sun,I BM, SCO и
         USL для среды Unix )
 COSS    Common Object Services Specification, спецификация на общие
         средства объектного сервиса (в архитектуре OMA)
 COTS    commercial off-the-shelf, коммерческие ( программные продукты )
 CPA     Call progress analysis, мониторинг телефонной линии ( автоматическое
         распознавание результатов телефонного вызова: достигнуто соединение,
         получен  ответ абонента, линия занята, сигналы на линии отсутствуют,
         окончание разговора )
 CPE     1. Cross-Platform Environment, кросс-платформенная среда;
         2. Customer Premises Equipment,
          оборудование, устанавливаемое в помещении пользователя
 CPI     1. ( cpi ) characters per inch, ( число ) знаков на дюйм;
         2. Common Programming Interface, единый интерфейс программирования
          ( стандарт IBM для протоколов установления связи и сеансов информа-
           ционного обмена, элемент архитектуры SAA);
         3. computer-to-PBX interface, интерфейс между ЭВМ и PBX
 CPIC    ( CPI-C ) Common Programming Interface for Communications,
         единый интерфейс программирования (данными)
 CPM     critical path method, метод критического пути
 CPS     ( cps ) characters per second, ( число ) знаков в секунду
 CPT     1. critical path technique, метод критического пути;
         2. customer provided terminal, терминал пользователя
 CPU     central processing unit, центральный процессор, ЦП
 CR      carriage return, возврат каретки
 CRA     Computing Research Association,
         Ассоциация по исследованиям в области вычислительной техники (США)
 CRC     Cyclic Redundancy Check, циклический избыточный код коррекции ( ме-
         тод контроля ошибок, используемый для проверки правильности переда-
         чи цифровых данных )
 CROM    control read-only memory,
         управляющая постоянная память, управляющее ПЗУ
 CRS     customer response system, система обратной связи с потребителем
 CRT     cathode-ray tube,
         1) электронно-лучевая трубка, ЭЛТ  2) дисплей на ЭЛТ
 CRU     customer replaceable unit, блок, заменяемый пользователем
 CS      carrier sense, контроль носителя (функция, постоянно выполняемая
         станцией и обеспечивающая распознавание ею процесса передачи со сто-
         роны другой станции)
 CSA     Client/Server Architecture, архитектура клиент/сервер
 CSCW    Computer Supported Cooperative Work,
         коллективная работа с использованием компьютеров
 CSDN    circuit-switched data network,
         сеть передачи данных с коммутацией каналов
 CSLIP   compressed SLIP, (сетевой протокол) SLIP с уплотнением данных
 CSM     central service module, центральный обслуживающий модуль
         ( используемый в параллельной системной магистрали и обслуживающий
         запросы всех ее агентов )
 CA      Carrier-Sense Multiple Access/Collision Avoidance, метод множествен-
         ного доступа с контролем носителя и избежанием конфликтов ( стандар-
         тный протокол )
 CSMA/CD Carrier Sense Multiple Access with Collision Detection,
         многократный доступ с контролем носителя и обнаружением конфликтов
         ( протокол доступа к сети, используемый в ЛВС Ethernet; если уст-
         ройству нужно получить доступ к сети, оно проверяет, свободна ли
         сеть; стандартный метод и протокол асинхронного доступа в сети с
         шинной топологией )
 CSMIM   Communications Server Media Interface Module,
         модуль интерфейса среды связного сервера
 CSO     Computing Services Office, компьютерный сервисный комплекс
         ( система, обеспечивающая возможность поиска пользователями глобаль-
         ных сетей учащихся и преподавателей данного учебного заведения по
         компьютерному справочнику )
 CSP     1. Certified Support Partner, сертифицированный партнер по техничес-
          кой поддержке;
         2. Certified Systems Professional,
          сертифицированный специалист по системам
 CSRS    Continuous Speech Recognition System;
         система распознавания слитной речи
 CST     code segment table, таблица сегментов кода
 CSTA    Computer Supported Telecommunications Application, Применение теле-
         коммуникационных технологий с использованием вычислительной техники
         ( стандарт ECMA )
 CSU     1. channel service unit, устройство обслуживания канала;
         2. communication(s) service unit, связное устройство
 CTB     Communications ToolBox, инструментальные средства передачи
         ( файлов; в составе FTP )
 CTCA    Сhannel-to-channel adapter, адаптер "канал-канал"
 CTI     1. Computational Testbed for Industry, промышленный вычислительный
          испытательный стенд;
         2. Computer/Telephone Integration,
          а) управление телефонным коммутатором при помощи подключённого к не-
          му компьютера - рабочей станции или файлового сервера ( компьютерно-
          телефонная интеграция),
          б) Союз пользователей телефонного оборудования на базе компьютеров
 CTM     communication terminal module, оконечный модуль связи
 CTO     Chief Technical Officer, главный технический директор (компании)
 CTV     см. CATV
 CU      1. control unit, устройство (блок) управления;
         2. cryptographic unit, криптографический блок ( блок засекречивания
          данных в сети с повышенной степенью защиты информации )
 CUA     Common User Access, единый пользовательский доступ ( стандарт IBM
         для интерфейса пользовательских программ, элемент SAA )
 CUI     character user interface, символьный интерфейс пользователя
 CVA     Computer Virus Association,
         Ассоциация по борьбе с компьютерными вирусами
 CVF     Compressed Volume File, файл сжатого тома
 CVI     Compressed Video Interoperability,
         взаимодействие при работе с уплотненными видеоданными (протокол)
 CVS     computer vision system, система машинного зрения ( обеспечивающая
         ввод и обработку изображений)
 CVTS    Compressed Video Trasmission Service,
         служба передачи уплотненной видеоинформации
 CWIS    Campus Wide Information System, университетская информационная сис-
         тема (предоставляет доступ к местным новостям, справочникам, ката-
         логам, библиотекам и базам данных)
 CX      central exchange, центральная АТС
D
 D       Data aquisition and distribution, сбор и распределение данных
 DA      1. Disk Array, дисковая матрица;
         2. Domain Address, адрес домена
          ( формат адреса электронной почты в сети Internet )
 DAB     Data aquisition board, плата сбора данных
         ( для ПК, обычно многофункциональная )
 DAC     1. Digital-to-analog converter, цифроаналоговый преобразователь, ЦАП
         2. Dual Attachment Concentrator, концентратор с двойным подключени-
          ем ( система защиты, не требующая авторизации источника )
 DAE     Distributed Application Environment,среда распределенных приложений
 DAL     Data Access Language, язык доступа к данным
 DAM     1. Data Access Manager, программа управления доступом к данным;
         2. data access method, метод доступа к данным ( совокупность сог-
          лашений и средств, с помощью которых реализуется заданный вид дос-
          тупа к физическим записям наборов данных)
 DAMA    Demand-assignment multiple access,
         множественный доступ с предоставлением канала по требованию
 DANS    Distributed Administration of Network Software, распределенное уп-
         равление сетевым программным обеспечением ( технология фирмы Sun )
 DAP     1. Data Access Protocol, протокол доступа к данным;
         2. Database Access Point, место доступа к базе данных (в сети);
         3. Directory Access Protocol, протокол доступа к каталогам
 DARPA   Defence Advanced Research Projects Agency, Управление перспективных
         исследований и разработок Министерства обороны (США) ( современное
         название ARPA)
 DAS     1. data acquisition system, система сбора данных;
         2. Database Application Simulation, имитация приложения базы данных
          ( один из тестов проверки производительности компьютеров );
         3. dual attachment station, станция с двойным подключением (к сети)
 DASD    Direct-access storage device,
         запоминающее устройство с прямым доступом, ЗУПД
 DAT     1. data access tools, инструментальные средства доступа к данным;
         2. Digital Audio Tape, цифровая магнитная аудиолента
 DAV     Data Above Voice, "данные над голосом" ( система передачи цифровых
         данных на частотах, выше выделенных для речевых сигналов; см. также:
         DIV, DUV)
 DB      Database, база данных, БД
 DBA     Database administrator, администратор базы данных (должностное лицо,
         осуществляющее контроль за надлежащим использованием базы данных )
 DBCL    Database control language, язык управления базами данных
 DBMS    Database Management System, система управления базами данных, СУБД
 DBR     Dial-up bridge/router, мост/маршрутизатор, устанавливаемый в комму-
         тируемых линиях
 DC      1. data channel, канал (передачи) данных;
         2. direct current, постоянный ток
 DCB     1. Disk Coprocessor Board, плата сопроцессора диска ( интеллек-
          туальная плата, связывающая главный микропроцессор с контроллером
          диска);
         2. Domain Control Database, управляющая база данных домена ( ката-
          лог, содержащий информацию о всех совместно используемых ресурсах
          домена )
 DCC     1. Data communication channel, канал передачи данных;
         2. Digital cellular communications, цифровая сотовая радиосвязь;
         3. Digital Compact Cassette, цифровая компакт-кассета
 DCE     1. Data Circuit Terminating Equipment, оконечное оборудование канала
          передачи данных { а) аппаратура, обеспечивающая кодирование и преоб-
          разование сигналов между DTE и линией связи,  например модем
          б) устройство, которое устанавливает, поддерживает и завершает сеанс
          взаимодействия систем в сети; может также осуществлять преобразова-
          ние сигнала перед передачей }
         2. Data Communications Equipment, аппаратура передачи данных, АПД;
         3. Distributed Computing Environment, среда распределенных вычисле-
          ний ( создана для сопряжения различных платформ, поддерживающих
          Unix и другие ОС; разработана OSF )
 DCI     1. Data communication interface, интерфейс канала передачи данных;
         2. Display Control Interface, интерфейс управления дисплеем
 DCN     Distributed computer network, распределенная вычислительная сеть
 DCS     1. distributed control system, распределенная система управления;
         2. data communication unit, устройство передачи данных
 DCU     Data control unit, устройство ( блок ) управления данными
 DD      1. Double density, двойная плотность ( записи данных )
         2. Data Direct, система доступа к данным, часть системы сбора финан-
          совой информации FDRS
 DDAS    Digital data acquisition system, система сбора цифровой информации
 DDB     Distributed database, распределенная база данных
 DDBMS   Distributed database management system,
         система управления распределенными базами данных
 DDCMP   Digital Data Communication Message Protocol, протокол цифровой пере-
         дачи сообщений ( байт-ориентированный протокол, разработанный фирмой
         Digital Equipment )
 DDCS    Distributed Data Communications Server,
         сервер связи с распределенными данными
 DDD     Direct distance dialing, автоматический вызов удаленного абонента
 DDDLU   Dynamic Definition of Dependent Logical Units,
         динамическое определение зависимых логических блоков
 DDE     1. direct data entry, прямой ввод данных;
         2. Dynamic Data Exchange, динамический обмен данными ( набор прото-
          колов для взаимодействия приложений в среде Windows)
 DDI     Device driver interface, интерфейс драйверов внешних устройств
 DDL     Data Definition Language, язык описания данных
 DDM     Distributed Data Management, распределенное управление данными
 DDMA    Disk direct memory access, прямой доступ к дисковой памяти
 DDN     Digital data network, цифровая сеть передачи данных
 DDP     Distributed data processing, распределенная обработка данных
 DDR     Dynamic Device Reconfiguration,динамическая реконфигурация устройств
 DDS     Digital Data Service, служба передачи цифровых данных
 DEA     Data Encryption Algorithm, алгоритм шифрования данных ( разработан
         ANSI )
 DEB     Desktop Expansion Base, настольное устройство расширения  ( для
         портативных ПК фирмы Compaq )
 DEMARC  Distributed Enterprise Management Architecture, архитектура распре-
         деленного управления сетью масштаба предприятия ( предложена фирмой
         Banyan )
 DEMS    Digital electronic message service,
         электронная служба передачи цифровых сообщений
 DEN     Document Enabled Networking, сетевая среда, поддерживающая работу с
         документами ( единая модель распространения документов в ОС NetWare
         независимо от их формы )
 DES     Data ( Digital ) Encryption Standard, стандарт шифрования данных
         ( стандарт NIST-шифрования, при котором данные шифрируются в нефраг-
         ментируемый код для передачи по общедоступным линиям )
 DFC     S data flow control, управление потоком данных
 DFS     Dual fail-safe system, система с двойным резервированием
 DFT     1. diagnostic function test, диагностический функциональный тест;
         2. Disk Failure ( Fault ) Tolerance, средства поддержки отказоустой-
          чивости диска
 DFWMAC  Distributed foundation wireless MAC, распределенное базовое управле-
         ние доступом к носителю в беспроводных сетях ( протокол для беспро-
         водных сетей, предложенный компаниями NCR, Symbol Technologies и
         Xircom )
 DGIS    Direct Graphics Interface Standard,
         стандарт непосредственного графического интерфейса
 DHCP    Dynamic Host Configuration Protocol, протокол динамического конфигу-
         рирования хоста ( метод управления информацией о клиентах в сети ПК
         с пульта хост-ЭВМ )
 DID     Direct Inward Dialing, прямой набор внутренних (добавочных) номеров
         ( в учрежденческой АТС )
 DIF     Data interchange format, формат обмена данными
 DIL     Dual-in-line, двухрядное ( расположение выводов микросхемы )
 DIP     1. distributed information processing, распределенная обработка
          информации;
         2. document and image processing,обработка документов и изображений
         3. dual-in-line package, двухрядный корпус (микросхема с двухрядным
          расположением выводов ), корпус ДИП
 DIS     1. Data Interpretation System, система интерпретации данных;
         2. Dealer Information System, система информационного обеспечения
          дилеров
 DISA    1. Data Interchange Standards Association, Ассоциация по стандартам
          обмена данными (США)
         2. direct inward system access, прямой внутрисистемный доступ
 DIV     Data In Voice, "данные в голосе" ( система передачи цифровых данных
         на частотах, выделенных для речевых сигналов; см.также DAV, DUV)
 DL      1. data link, канал передачи данных;
         2. distribution lists, списки рассылки;
         3. dynamic load, динамическая загрузка
 DLC     Data link control, управление каналом передачи данных
 DLCI    1. Data Link Control Identifier
         2. Data Link Connection Identifier
         управляющий идентификатор канала передачи данных ( номер виртуально-
         го канала  при  передаче с ретрансляцией кадров { frame relay }, со-
         ответствующий определённому адресату; входит в состав заголовка кадра
         и обычно имеет длину 10 бит )
 DLCP    Data Link Control Protocol,
         протокол управления каналом передачи данных
 DLL     Dynamic Link Library, динамически компонуемая библиотека ( набор
         процедур, представленных в форме, готовой для выполнения, и загружа-
         емых с диска в память при их вызове; используется в среде Windows)
 DLM     Data Line Multiplexer, мультиплексор линий передачи данных ( через
         систему спутниковой связи )
 DLMS    Digital Link Management System,
         система управления цифровыми линиями передачи данных
 DLP     Display-list processing, обработка дисплейных файлов
 DLSw    Data Link Switching, коммутация каналов передачи данных
         ( спецификация IBM )
 DLT     Digital linear tape, магнитная лента с цифровой линейной записью
 DLU     Dependent logical unit, зависимый логический блок
 DLUR    Dependent Logical Unit Requestor,
         генератор запросов зависимого логического блока
 DM      1. Data mode, режим передачи данных ( один из двух базовых режимов
          работы модема, см. тж. CM);
         2. Disk Mirroring, отображение дисков ( хранящихся данных )
 DMA     Direct memory access, пряиой доступ к памяти ( без участия процес-
         сора )
 DMAC    DMA channel (controller), канал (контроллер) DMA
 DMD     Digital micromirror display,
         цифровой микрозеркальный ( проекционный ) дисплей
 DME     Distributed Management Environment, среда распределенного управления
         ( интегрированный набор технологий и стандартов для вычислительных
         сетей и систем управления масштаба предприятия )
 DMI     Desktop Management Interface, интерфейс управления настольными сис-
         темами ( разработан DMTF )
 DML     Data Manipulation Language, язык манипулирования данными
 DMM     1. Distributed Management Module, модуль распределенного управления
         2. dynamic memory control, динамическое управление памятью
 DMR     Distributed Message Router, программа распределенной маршрутизации
         сообщений
 DMS     1. Data Management System, система управления данными;
         2. Document Management Service (System),
          служба ( система ) управления документированием
 DMTF    Desktop Management Task Force, Рабочая группа по управлению настоль-
         ными системами ( консорциум производителей ПО, разрабатывающий отк-
         рытый стандартный метод доступа к информации в ПК, в который входят
         DEC, HP, IBM, Intel, Microsoft, Novell, SunConnect и SynOptics
         Communications )
 DNA     1. DEC Network Architecture, сетевая архитектура фирмы Digital
          Equipment (набор стандартных протоколов, интерфейсов и связных
          функций, обеспечивающий взаимодействие в сети различных операцион-
          ных систем, связных устройств и типов компьютеров, был положен в
          основу всех продуктов для сетей протокола DECnet);
         2. digital network architecture, архитектура цифровой сети
 DNIS    Dialed Number Identification Service,
         служба определения набираемого номера
 DNS     1. Distributed Name Service, распределенная служба именования;
         2. Domain Naming System ( Service ), система именования доменов
         ( онлайновая система управления распределённой базой данных, приме-
         няется для установления соответствия между смысловыми ( буквенными )
         именами машин и их IP-адресами; схема электронной почты, использу-
         емая в сетях Internet )
 DOAPI   DOS Open API, открытый интерфейс прикладного программирования в сре-
         де DOS
 DOD     Digital optic disk, цифровой оптический диск
 DOE     1. Distributed Object Environment, распределенная объектная среда
          ( разработана фирмой SunSoft )
         2. distributed objects everywhere, "распределенные объекты повсюду"
          ( архитектура фирмы SunSoft )
 DOMF    Distributed Object Management Facility,
         средства распределенного управления объектами
 DOMS    Distributed Object Management System,
         система управления распределенными объектами
 DOR     Digital optical recording, цифровая оптическая запись
 DOS     Disk Operating System, дисковая операционная система
 DP      Data processing, обработка данных
 DPA     Data processing automation, автоматизация обработки данных
 DPC     Data Processing Center,
         центр обработки данных, вычислительный центр, ВЦ
 DPI     ( dpi ) dot per inch, ( число ) точек на дюйм
 DPM     1. data processing manager, программа управления обработкой данных
         2. dual processor mode, двухпроцессорная обработка
 DPMI    DOS Protected Mode Interface, интерфейс защищенного режима в среде
         DOS
 DPMS    1. Display Power Management Signaling, сигнализация управления пита-
         нием дисплея ( энергосберегающая технология VESA, при которой дисплей
         отключается, если с ним долго не работают )
         2. DOS Protected Mode Services, сервис защищенного режима DOS
 DPN     Data Packet Network, сеть передачи пакетов данных
 DPP     Distributed parallel processing,
         распределенная параллельная обработка ( данных )
 DPS     1. Distributed Processing System,
          распределенная система обработки (данных)
         2. Document Processing System, система обработки документов
 DQM     Dynamic Queue Manager, программа динамического управления очередями
 DQS     Distributed Queueing Service,
         распределенная система обслуживания очередей
 DRAM    Dynamic Random Access Memory, динамическая оперативная память, дина-
         мическое ЗУ с произвольной выборкой ( ДЗУПВ ), тип видеопамяти
 DRAW    Direct read after write, считывание непосредственно после записи
 DRDA    Distributed Relational Database Architecture, распределенная архитек-
         тура реляционных баз данных ( стандарт фирмы IBM )
 DS      1. Double-sided, двусторонняя (дискета)
         2. Dual-scan, с двойным сканированием ( метод улучшения изображения
          на жидкокристаллическом дисплее)
         3. Dynamic switching, динамическая коммутация
 DSA     1. Digital Signature Algorithm, алгоритм цифровой подписи;
         2. Directory System Agent, системный агент каталога;
         3. Dynamic Scalable Architecture,
          динамическая расширяемая архитектура
 DSDD    Double-sided double-density,
         двусторонний с двойной плотностью записи ( гибкий магнитный диск )
 DSDL    Data Storage Description Language,
         язык описания хранения данных ( физической структуры базы данных )
 DSDM    Dynamic System Development Method,
         1) метод разраотки динамических систем 2) Международный консорциум
 DSE     Data switching exchange, устройство коммутации данных
 DSG     Distributed systems gateway, шлюз распределенных систем ( для сое-
         динения сетей с различными архитектурами или протоколами )
 DSL     Digital Subscriber Line, линия
 DSN     Digital switching network, цифровая коммутационная сеть
 DSOM    Distributed System Object Model,
         модель распределенных системных объектов
 DSP     1. Digital Signal Processing, цифровая обработка сигналов
         2. Digital Signal Processor, специализированный процессор, осуществ-
          ляющий быстрые операции с цифровыми сигналами
 DSPF    Dynamic Shortest Path First, "первым выбирается динамически кратчай-
         ший путь" ( алгоритм дистанционной организации мостовой передачи дан-
         ных)
 DSPS    Digital Signal Processing System, система цифровой обработки сигналов
 DSR     Document search and retrieval, поиск и извлечение документов
 DSS     1. decision support system, система поддержки принятия решений
         2. Digital Signature Standard,
          стандарт на цифровые подписи ( разработан NIST )
 DSSD    Double-sided single-density,
         двусторонний с одинарной плотностью записи ( гибкий магнитный диск )
 DSU     Data Service Unit, устройство обработки данных
 DSVT    Digital subscriber voice terminal,
         цифровой абонентский речевой терминал
 DTAS    Data transmission and switching, передача и коммутация данных
 DTC     1. data transfer channel, канал передачи данных
         2. desktop computer, настольный компьютер
 DTCS    Data Transmission and Control System,
         система передачи и управления данными
 DTD     Document Type Definition, определение типа документа
 DTE     Data Terminal Equipment, оборудование терминала данных ( коммуни-
         кационное устройство, являющееся источником или приёмником сетевых
         сигналов )
 DTI     Digital trunk interface, интерфейс цифрового магистрального канала
 DTL     Data transmission line, линия передачи данных
 DTMF    Dual Tone Multifrequency dialing, синоним тонового набора ( способ
         набора номера,при которомкаждой цифре на наборной клавиатуре соответ-
         ствует пара звуковых сигналов высокой и низкой частоты.
 DTN     Data transmission network, сеть передачи данных
 DTP     1. Desktop publishing, а) настольная издательская деятельность,
          б) настольная издательская система ( на базе ЭВМ )
         2. distributed transaction processing,
          распределенная обработка транзакций
 DTVS    Desktop video studio, настольная видеостудия
 DUA     Directory User Agent, пользовательский агент каталога
 DUV     Data Under Voice, "данные под голосом" ( система передачи цифровых
         данных на частотах, ниже выделенных для речевых сигналов; см. также
         DAV, DIV)
 DV      Digital video, цифровое видео
 DVA     1. distance vector algorithm, дистанционный векторный алгоритм
          ( в протоколах обмена между маршрутизаторами )
         2. distant vector approach, дистанционный векторный метод ( алгоритм
           сетевого обмена )
 DVE     Digital Video Editor, средства редактирования цифровых видеоданных
 DVI     Digital Video Interactive, интерактивное цифровое видео ( стандарт
         записи сжатой смешанной информации на оптический диск, предложенный
         фирмой Intel )
 DVMRP   Distance Vector Multicast Routing Protocol, протокол дистанционной
         векторной групповой ( многоадресной ) маршрутизации
 DVR     Digital video recording, цифровая видеозапись
 DVX     Digital Voice Exchange, цифровая передача речи ( система коммутации
         речевых сообщений в цифровой форме )
 DWP     Daisy wheel printer, принтер с печатающей головкой типа "ромашка"
 DX      Directory Exchange, обмен каталогами
 DXF     Drawing Exchange Format, формат обмена рисунками ( стандарт, разра-
         ботанный фирмой Autodesk и позволяющий пользователям среды AutoCAD
         импортировать рисунки, созданные в других графических редакторах, и
         наоборот )
 DXI     Data Exchange Interface, интерфейс обмена данными
 DXS     Directory Exchange Server, сервер обмена каталогами
E
 EAD     Enhanced Access Diversity, улучшенный многовариантный доступ ( метод
         маршрутизации )
 EAROM   Electrically alterable read-only memory,
         электрически перепрограммируемое ПЗУ
 EASE    Embedded Advanced Sampling Environment, встроенная среда опроса с до-
         полнительными возможностями ( система сбора и анализа статистики по
         сетевому трафику  с предоставлением этой информации администратору )
 EBB     Electronic bulletin board, электронная доска объявлений
 EBCDIC  extended binary-coded decimal interchange code,
         расширенный двоично-десятичный код обмена информацией
 EBR     Enterprise Backup and Restore, (система) резервного копирования и
         восстановления информации для сети масштаба предприятия
 EC2     Enhanced Cellular Control, усовершенствованное управление сотовой
         сетью ( протокол, предложенный фирмой Motorola )
 ECAT    Electronic Card Assembly and Test, монтаж и тестирование плат
 ECB     Event control block, блок управления событием ( структура данных, ис-
         пользуемая при приеме-передаче пакетов в протоколах IPX и SPX фирмы
         Novell )
 ECC     Error-Correcting Code, код с исправлением ошибок
 ECD     Edit/Compile/Debug, редактирование/компиляция/отладка
 ECL     Emitter-coupled logic, эмиттерно-связанная логика, ЭСЛ
 ECM     Error Correcting Mode, режим исправления ошибок
 ECMA    European Computer Manufacturers Association,
         Европейская ассоциация производителей вычислительной техники
 ECNE    Enterprise Certified NetWare Engineer, сертифицированный инженер по
         эксплуатации ОС NetWare в сети масштаба предприятия
 ECP     Extended Capabilities Port, порт с расширенными возможностями ( па-
         раллельный порт, разработанный фирмами Microsoft и Hewlett-Packard;
         предназначен для двунаправленной связи с внешними устройствами и
         обеспечивает прямой доступ к памяти, DMA)
 ECS     External cache socket, гнездо для подключения внешней кэш-памяти
 ECSA    Exchange Carriers Standards Association,
         Ассоциация по стандартизации средств ( телефонной ) связи
 EDA     1. Electronic Design Automation, автоматизация проектирования;
         2. electronic digital analyzer, электронный цифровой анализатор;
         3. Enterprise Data Access,
          доступ к данным в сети масштаба предприятия
 EDAC    Error detection and correction, обнаружение и исправление ошибок
 EDB     External database, внешняя база данных
 EDCC    Error detection and correction code, код с обнаружением и исправлением
         ошибок
 EDD     Electronic Document Delivery, электронная доставка документов
 EDGAR   Electronic Data Gathering, Analysis and Retrieval,
         система электронного сбора, анализа и извлечения данных
 EDI     Electronic Data Interchange, электронный ( безбумажный ) обмен доку-
         ментами и данными ( стандартная технология передачи документов между
         компьютерами )
 EDL     Event definition language, язык описания событий
 EDMS    1. Electronic Document Management System,
          система управления электронными документами;
         2. Extended Data Management System,
          расширенная система управления данными
 EDP     1. electronic data processing, электронная обработка данных;
         2. electronic data processor,
          процессор для электронной обработки данных
 EDPS    Electronic data processing system,
         электронная система обработки данных
 EDR     Enhanced Data Replication, усовершенствованная технология тиражиро-
         вания данных (в распределенной среде)
 EDRO    Enhanced Diversity Routing Option, улучшенный метод многовариантной
         маршрутизации
 EDS     1. electronic data switching, электронная коммутация данных;
         2. electronic data system, электронная информационная система
 EE      1. Electrical Engineering, электротехника;
         2. Extended Edition, расширенная редакция
          ( версия программного продукта );
         3. External environment,
          внешняя среда, окружение, условия эксплуатации
 EEI     External Environment Interface, интерфейс внешней среды ( обеспечи-
         вает взаимодействие прикладной платформы с пользователем, внешними
         хранилищами данных и другими прикладными платформами )
 EEPROM  Electrically erasable programmable read-only memory, электрически-
         стираемая программируемая постоянная память, электронно-перепрограм-
         мируемое ПЗУ
 EGA     Enhanced Graphics Adaptor, графический адаптер с повышенной разрешаю-
         щей способностью (а также соответствующие цветной монитор и стандарт)
 EIN     Electronic ID number, электронный идентифицирующий номер
 EIS     Executive information system, информационная система для руководящих
         сотрудников
 EISA    Extended Industry Standard Architecture,
         расширенная системная шина ISA
 ELF     Executable and linkable format,
         формат исполняемого и компонуемого модуля
 ELS     Entry level system, система начального уровня
         ( минимальная версия системы )
 ELSI    Extra large-scale integration, 1) ультравысокая степень интеграции,
         2) ультрабольшая ИС, УБИС
 EMA     1. Electronic Mail Association,
          Ассоциация разработчиков систем электронной почты;
         2. Electronic Manufacturers Association,
          Ассоциация производителей электронного оборудования;
         3. Electronic Messaging Association,
          Ассоциация электронной по передаче сообщений;
         4. Enterprise Management Architecture,
          архитектура управления сетью масштаба предприятия
 EMC     Electromagnetic compatibility, электромагнитная совместимость
 EMMI    Enhanced Multimedia Interface,
         усовершенствованный интерфейс мультимедиа (разработанный фирмой AT&T)
 EMS     1. electronic mail service, служба электронной почты;
         2. Electronic Messaging Server,
          сервер электронных сообщений ( электронной почты );
         3. Enterprise Management System,
          система управления сетью масштаба предприятия;
         4. Enterprise Messaging Server,
          сервер сообщений в сети масштаба предприятия;
         5. expanded memory specification, спецификация дополнительной памяти
          ( стандарт, обеспечивающий использование в PC-совместимых ПК опера-
           тивной памяти свыше 640 Кбайт);
         6. Expanded Memory System, дополнительная память
 EMX     Enterprise Mail Exchange, автоматический обмен сообщениями в сети
         масштаба предприятия ( с автоматической коммутацией )
 EN      1. end node, конечный узел ( в сети )
         2. European Norm, Европейская норма ( европейский стандарт )
 ENAC    European Networking and Applications Center,
         Европейский центр сетевой обработки и прикладных программ
 ENMS    Enterprise network management system,
         система управления сетью масштаба предприятия
 EOA     End of address, конец адреса
 EOB     End of block, конец блока
 EOF     End of file, конец файла
 EOL     End of line, конец строки
 EOM     1. end of message, конец сообщения;
         2. event-oriented modelling,
          моделирование, ориентированное на события
 EOR     End of record, конец записи
 EP      Electronic publishing, электронная издательская деятельность
 EPDM    Enterprise performance data manager, система управления производи-
         тельностью обработки данных в сети масштаба предприятия
 EPL     1. effective privilege level, эффективный уровень привилегий;
         2. Evaluated Products List, список оцененных продуктов ( результаты
          тестирования компьютерных систем в NCSC с точки зрения их пригоднос-
          ти к обработке критической информации )
 EPP     Enhanced Parallel Port, усовершенствованный параллельный порт (разра-
         ботан корпорациями Intel, Xerox, Zenith и др.; предназначен для дву-
         направленного обмена данными с внешними устройствами )
 EPROM   Erasable programmable read-only memory,
         стираемое программируемое ПЗУ, СППЗУ
 EPS     Encapsulated PostScript, инкапсулированный PostScript ( графический
         файловый формат, позволяющий хранить любой графический материал )
 EPU     Electrical power unit, блок электропитания
 ERD     Element relations diagram, схема взаимосвязи элементов
 EROM    Erasable Read-Only Memory, стираемое ПЗУ
 ERP     Enterprise Resource Planning,
         планирование ресурсов в масштабах предприятия
 ES      1. enterprise system, ( сетевая ) система масштаба предприятия;
         2. expansion slot, разъем расширения;
         3. expert system, экспертная система
 ESCP    Epson Stsndard Code for Printers,
         стандартный код для принтеров фирмы Epson
 ESCON   Enterprise System Connection,связь систем в сети масштаба предприятия
 ESD     Electronic Software Distribution,
         электронное распространение программного обеспечения
 ESDI    Enhanced small-device (disk) interface, расширенный интерфейс малых
         ( дисковых ) накопительных устройств
 ESDL    Electronic software distribution and licensing,
         электронное распространение и лицензирование программного обеспечения
 ESF     Extended superframe, расширенный суперфрейм
 ESL     Electronic software licensing,
         электронное лицензирование программного обеспечения
 ESM     1. Enterprise Storage Manager,
          программа управления внешней памятью в сети масштаба предприятия;
         2. Ethernet Switching Module, коммутационный модуль сети Ethernet
 ESN     Electronic serial number, электронный порядковый номер (устройства)
 ESP     Expert System Protocol, протокол экспертных систем
 ESS     Electronic switching system, электронная система коммутации
 ETANN   Electrically Trainable Analogous Neural Network,
         электрически обучаемая аналоговая нейронная сеть
 ETC     Enhanced Throughput Cellular, усовершенствованная сотовая связь (про-
         токол фирмы AT&T, обеспечивающий исправление ошибок в сотовых сетях)
 ETOM    Electron Trapped Optical Memory,
         оптическая память на захваченных электронах
 ETSI    European Telecommunications Standards Institute,
         Европейский институт по стандартам в области телекоммуникаций
 ExCA    Exchangeable Card Architecture, расширяемая архитектура плат
         ( спецификация фирмы Intel )
F
 FAM     File Access Manager, программа управления доступом к файлам
 FAQ     Frequently Asked Questions, ответы на часто встречающиеся вопросы
         ( документ с основной информацией из отдельной конференции USENET или
         списка рассылки )
 FARNET  Federation of Advanced Research Networks, Федерация передовых иссле-
         довательских сетей ( некоммерческое объединение, занимающееся внедре-
         нием сетей в науку и образование )
 FAST    Federation Against Software Theft, Федерация по борьбе с незаконным
         использованием программного обеспечения ( США )
 FASTAR  Fast Automatic Restoration,
         ускоренное автоматическое восстановление ( системы )
 FAT     File Allocation Table, таблица размещения файлов
 FAU     Fax Access Unit, блок доступа к факсимильному аппарату
 FCA     Fibre Channel Association,
         Ассоциация разработчиков волоконно-оптических каналов (США)
 FCC     Federal Communications Comission, Федеральная комиссия связи (США)
 FCP     1. Fiber Channel Profile, профиль волоконно-оптического канала
         ( специальный сетевой профиль);
         2. for cooperative processing, "для совместной обработки данных"
 FCS     1. Facsimile communication system, система факсимильной связи;
         2. Fast Circuit Switching, быстрая коммутация каналов;
         3. Fiber Channel Standard, стандарт на волоконно-оптические каналы;
         4. Flight Control System, система управления полетом (тип джойстика)
         5. Frame Check Sequence, контрольная последовательность кадра ( в би-
          тово-ориентированных протоколах - 16-разрядное поле, содержащее ин-
          формацию для контроля ошибок при передаче данных, дописываемое обыч-
          но в конец кадра )
 FCSI    Fibre Channel System Initiative, инициатива по системам волоконно-
         оптической связи ( совместная программа Sun Microsystems, IBM и
         Hewlett-Packard )
 FCT     function call tree, дерево функциональных вызовов
 FDB     file description block, блок описания файла
 FDD     Floppy Disk Drive, накопитель на гибких магнитных дисках, НГМД
 FDDI    Fiber Distributed Data Interface, распределенный интерфейс передачи
         данных по волоконно-оптическим каналам (определяемая стандартом сеть,
         разработанная ANSI и модифицированная IEEE/ISO, с передачей маркера,
         позволяющая передавать данные со скоростью 100Мбит/с на расстояния до
         двух км ). Совместим со спецификацией IEEE802.
 FDDL    frequency-division data link,
         канал передачи данных с частотным разделением
 FDHD    floppy drive high density, НГМД высокой плотности
 FDM     frequency-division multiplexing, частотное уплотнение (разделение)
 FDMA    frequency-division multiple access, множественный доступ с частотным
         разделением
 FDRS    Financial Data Retrieval System, система сбора финансовой информации
         ( состоит  из  трёх  компонентов: системы просмотра отчётов, системы
         стандартных запросов, системы доступа к данным )
 FDSE    Full Duplex Switched Ethernet, дуплексная коммутируемая сеть Ethernet
 FEA     Fast Ethernet Alliance, Союз Fast Ethernet
         ( группа по поддержке технологии высокоскоростных сетей Ethernet )
 FED     1. Ferroelectric display, сегнетоэлектрический дисплей;
         2. Field Emission Display, дисплей с автоэлектронной эмиссией (техно-
         логия фирмы Pixel International для плоских дисплеев портативных ПК )
 FEFO    First-ended, first-out, "первым готов - первым обслужен"
         ( дисциплина обслуживания по мере готовности )
 FEM     Facsimile electronic mail, факсимильная электронная почта
 FEP     Front-end processor, 1) интерфейсный процессор,
         2) процессор на станции-клиенте
 FFP     Fan Folded Paper, перфорированная фальцованная бумага (для принтера)
 FFST    First Failure Support Technology,технология поддержки первого отказа
         ( средство быстрого получения информации о сбоях, введенное фирмой
         IBM в OS/2 )
 FGA     Future Graphics Adapter, адаптер графики начала 2000-го года
 FICS    Facsimile Intelligent Communication System, интеллектуальная система
         факсимильной связи ( с использованием микропроцессоров в терминалах)
 FIFO    First-in, first-out, "первым пришел - первым обслужен"
         ( дисциплина обслуживания на основе последовательной очереди )
 FITS    Functional Interpolating Transformation System,
         система трансформации изображений методом функциональной интерполяции
 FLAG    Fiberoptic Link Around the Globe, волоконно-оптическая связь по всему
         земному шару ( проект подводной системы волоконно-оптической связи от
         Японии до Великобритании, которая должна вступить в эксплуатацию к
         концу 1996 г.)
 FLCD    Ferroelectric liquid crystal display,
         сегнетоэлектрический дисплей на жидких кристаллах
 FLOPS   Floating Point Operations Per Second, количество операций с плавающей
         запятой в секунду, флопс ( единица измерения быстродействия ЭВМ )
 FMP     Function Management Protocol, протокол управления функциями (сети)
 FMV     Full-motion video, полномасштабное видео ( передача изображений в
         реальном масштабе времени со стандартным разрешением и частотой
         кадров )
 FO      Fiber optics, волоконная оптика
 FOC     1. fiber optic cable, волоконно-оптический кабель;
         2. fiber optic communications, волоконно-оптическая связь
 FOCS    Fiber optic communication system, волоконно-оптическая система связи
 FOD     Fax on demand, факс по запросу
 FOIRL   Fiber Optic Inter-Repeater Link, волоконно-оптическая связь между
         ретрансляторами ( протокол передачи данных по световодам в сетях
         Ethernet )
 FOL     Fiber optic link, волоконно-оптическая линия связи, ВОЛС
 FOLAN   Fiber optic LAN, локальная сеть с волоконно-оптическими линиями связи
 FOTAG   Fiber Optic Technical Advisory Group,
         Техническая консультативная группа по волоконно-оптической связи
 FOTS    Fiber Optic Transmission System,
         волоконно-оптическая система передачи ( данных )
 FPD     Flat panel display, индикаторная панель, плоский индикатор
 FPFR    Fast-packet frame-relay,
         скоростная пакетная передача с ретрансляцией фреймов ( протокол )
 FPLA    Field programming logic array,
         программируемая пользователем логическая матрица
 FPMH    Failures per million hours, число отказов за миллион часов
 FPROM   1. factory-programmable read-only memory,
          ПЗУ, программируемое изготовителем;
         2. field-programmable read-only memory,
          ПЗУ, программируемое пользователем
 FPS     Fast Packet Switching, быстрая коммутация пакетов (в сетях ATM)
 FPU     Floating Point Unit, арифметическое устройство с плавающей запятой
 FQL     Function Query Language, функциональный язык запросов
 FR      1. Failure rate, интенсивность (частота) отказов
         2. Frame Relay, ретрансляция кадров
 FRAD    Frame Relay Assembler/Disassembler,
         ассемблер/дисассемблер ретрансляции фреймов
 FRC     Functional redundancy checking,
         функциональный избыточный контроль (в двухпроцессорных системах)
 FRX     Frame Relay Exchange, обмен с ретрансляцией фреймов
 FS      File Server, файл-сервер ( компьютер в составе ЛС, на котором хра-
         нятся общие файлы абонентов сети )
 FSD     Flat screen display, дисплей с плоским экраном
 FSF     Free Software Foundation, Фонд бесплатного программного обеспечения
         ( занимается разработкой бесплатных программ, призванных заменить
         коммерческое программное обеспечение )
 FSIOP   File server I/O processor, процессор ввода/вывода
 FSP     File service process, процесс обслуживания файлов
 FTAM    File Transfer, Access and Management, передача, доступ и управление
         файлами ( стандартный протокол прикладного уровня OSI, определяющий
         порядок и администрирование работы с файлами в сетях с различными ап-
         паратными платформами )
 FTMD    Flat-tension mask display, дисплей с плоской маской
 FTP     File Transfer Protocol, протокол пересылки файлов ( набор команд для
         входа в сеть, вывода списка файлов и каталогов, копирования файлов.
         Позволяет преобразовывать кодировку данных из ASCII в код EBCDIC и
         обратно; входит в набор протоколов TCP/IP сети Internet )
 FTPS    Financial Transaction Processing System,
         система обработки финансовых транзакций (операций)
 FTS     Functional test suite, набор функциональных тестов
 FTSA    Fault-Tolerant Server Architecture,
         отказоустойчивая серверная архитектура
 FTU     First-time user, новый пользователь
         ( еще не зарегистрированный в системе )
 FY      Fiscal year, финансовый год
 FYI     For Your Information, "Для вашего сведения" ( название серии доку-
         ментов в сети Штеуктун, в которых содержатся базовые материалы для
         начинающих )
G
 GAPPN   Gigabit Advanced Peer-to-Peer Networking,
         архитектура гигабитных одноуровневых сетей (разработана фирмой IBM)
 GB      Gigabyte, гигабайт - Гбайт: 230 или несколько более 109 байтов
         ( единица измерения ёмкости памяти или объёма передаваемой, хранимой,
         обрабатываемой информации)
 Gbps    Gigabit per second, гигабит в секунду - Гбит/с: 230 или несколько бо-
         лее 109 битов в секунду, единица измерения пропускной способности
         линии/канала связи, сети или устройства передачи данных )
 GCA     Graphic Communication Association,
         Ассоциация по передаче графической информации (США)
 GCR     Grey component replacement, замещение серых тонов
 GDI     1. General Data Interface, общий интерфейс доступа к данным;
         2. Graphic Device Interface, интерфейс графического устройства
          ( набор процедур и соответствующих данных в среде Windows, обеспечи-
          вающий вывод изображений на различные графические устройства; графи-
          ческий стандарт )
 GDMO    Guidelines for the Definition of Managed Objects,
         принципы описания управляемых объектов (стандарт ISO)
 GDSS    Group decision support system, система поддержки принятия решений
         для рабочих групп
 GEM     Graphics Environment Manager, программа-менеджер графической среды
         ( графический пользовательский интерфейс для среды DOS )
 GFLOPS  GigaFLOPS, миллиард FLOPS, гигафлопс, Гфлопс
 GFS     1. generic flow control,
         контроль обобщенного потока ( с целью выявления перегрузок в сети )
         2. grandfather/father/son, "дед/отец/сын" ( порядок дублирования дан-
         ных на магнитных лентах раз в месяц, раз в неделю и ежедневно )
 GGP     Gateway-to-gateway protocol, протокол межсетевого сопряжения
 GIF     Graphics Interchange (Image) Format, формат обмена графическими дан-
         ными ( разработанный фирмой CompuServe и создающий сжатые файлы
         растровых изображений )
 GIOC    Generalized input/output controller,
         универсальный контроллер ввода/вывода
 GIS     Geographic Information System,
         географическая информационная система, ГИС
 GIWG    Geographic Information Working Group,
         Рабочая группа по географическим информационным системам
 GKS     Graphic Kernel System, базовая графическая система ( международный
         стандарт интерфейса прикладных программ с системами графического вво-
         да/вывода )
 GLOP    Graphical Library Object Parser,
         синтаксический анализатор графических библиотечных объектов
 GM      General manager, главный управляющий, директор-распорядитель фирмы
 GMF     Graphics Monitor Facility, графическая программа мониторинга
 GMHS    Global Message Handling Service (System),
         глобальная служба (система) обработки сообщений (фирмы Novell)
 GOOP    Graphical Object-Oriented Programming,
         графическое объектно-ориентированное программирование
 GOSIP   Government Open Systems Interconnection Profile,
         правительственный профиль взаимодействия открытых систем (США)
 GP      1. game port, игровой порт ( разъем, предназначенный для подключения
          джойстиков и пультов ручного управления играми )
         2. general purpose, универсальный, общего назначения
 GPD     Gas plasma display, газоплазменный дисплей
 GPF     General protection fault, общее нарушение защиты
 GPIB    General-purpose interface bus, универсальная интерфейсная шина
 GPS     Global Positioning System, система глобального позиционирования
 GPSG    General phrase structure grammar,
         обобщенная грамматика лексических структур
 GPSS    General-purpose simulation system,
         универсальная система моделирования, язык моделирования GPSS
 GRASP   Graphic Animation System for Professionals,
         профессиональная графическая анимационная система
 GS      1. grey scale, шкала серого цвета;
         2. ground station, наземная станция
 GSAM    Generalized sequential access method,
         обобщенный последовательный метод доступа
 GSL     Generalized simulation language,
         обобщенный язык ( имитационного ) моделирования
 GSM     Global System for Mobile communications, глобальная ( общеевропейс-
         кая ) сотовая система цифровой радиосвязи (стандарт)
 GSSAPI  Generic security services API,
         общий интерфейс прикладного программирования служб защиты данных
 GTM     Graphic Text Mode, графический текстовый режим
         (формирование текстовых символов графическими средствами)
 GTN     Global Transportation Network, глобальная транспортная сеть
 GTS     Global Telecommunications System,глобальная система телекоммуникаций
 GUI     Graphical User Interface, графический пользовательский интерфейс
 GVPN    Global Virtual Private Network, глобальная виртуальная частная сеть
H
 HADA    High Availability Disk Array, дисковая матрица с высоким коэффициен-
         том готовности ( разработана фирмой Data General, позволяет сочетать
         в одном устройстве различные уровни RAID )
 HAL     Hardware Abstraction Layer, абстрактный аппаратный слой ( предложен
         фирмой Corollary для архитектуры C-bus II с целью поддержки ОС
         Windows NT )
 HAM     Host Attachment Module, модуль подключения к хост-машине
 HCI     Human-computer interface, интерфейс "человек-машина"
 HCP     Host Communications Processor, главный коммуникационный процессор
 HCS     Hierarchical Storage Controller,
         контроллер иерархической ( внешней ) памяти
 HCSS    High Capacity Storage System, накопитель большой емкости
 HD      High density, высокая плотность ( записи данных )
 HDAM    Hierarchical direct access method,
         иерархический прямой метод доступа
 HDD     Hard Disk Drive, накопитель на жсстких магнитных дисках, НМД
 HDDR    High-density digital recording, цифровая запись с высокой плотностью
 HDL     Hardware Description Language, язык описания аппаратных средств
 HDLC    High-Level Data Link Control,
         высокоуровневое управление каналом передачи данных (стандарт ISO)
 HDMS    High-Density Modem System, система модуляции/демодуляции с высоким
         коэффициентом сжатия (данных)
 HDN     High-bandwidth Data Network, высокоскоростная сеть передачи данных
 HDPS    High-definition projection system,
         проекционная система высокой четкости
 HDR     High Dynamic Range, расширенный динамический диапазон
 HDTV    High Definition Television, телевидение высокой четкости, ТВЧ
 HFT     High Function Terminal, многофункциональный терминал
 HGC     Hercules Graphics Card, графический адаптер фирмы Hercules
 HHC     Hand-held computer, "карманный" компьютер
 HHD     Half-height drive, накопитель "половинной" высоты ( около 4 см, что
         примерно вдвое меньше стандартной высоты первых НГМД для ПК )
 HI-FI   (Hi-Fi, hi-fi) high fidelity,
         1) высокая точность передачи или воспроизведения,
         2) аппаратура класса HI-FI
 HIMIB   Hardware Integrated Management Information Base,
         интегрированная административная база данных об аппаратных средствах
 HIOM    High-speed input/output module, высокоскоростной модуль ввода/вывода
 HIPPI   см. HPPI
 HLI     High-level interface, интерфейс высокого уровня
 HLL     High-level language, язык высокого уровня
 HLLAPI  High Level Language Application Programming Interface,
         интерфейс прикладного программирования на языках высокого уровня
 HLP     High-level protocol, протокол высокого уровня
         (определяющий взаимодействие на уровне запросов, сообщений, файлов)
 HLS     Hue-level-saturation, цвет-яркость-насыщенность (метод цветопередачи)
 HMA     high memory area, верхняя область памяти
 HMI     Hub Management Interface, интерфейс управления концентратором
 HOST    Hybride Open Systems Technology, гибридная технология открытых систем
 HPC     High-performance computing, вычисления с высокой производительностью
 HPCC    High-performance computing and communications,
         высокопроизводительные вычисления и связь
 HPCCI   High Performance Computing and Communication Initiative,
         инициатива в области высокопроизводительных вычислений и средств свя-
         зи (выдвинута правительством США)
 HPCN    High Performance Processing, Communications, Networking,
         высокопроизводительные вычислительная техника, средства связи и сети
 HPDS    High Performance Disk Subsystem,
         высокопроизводительная дисковая подсистема
 HPFS    High Performance File System, высокопроизводительная файловая система
         ( предложена фирмой IBM для OS/2, использует кэш-память )
 HPGL    Hewlett-Packard Graphics Language, язык описания графики фирмы Hew-
         lett-Packard ( в графопостроителях и принтерах )
 HPPI    (HIPPI) High Performance Parallel Interface,
         высокоскоростной параллельный интерфейс
 HPR     High Performance Routing, высокопроизводительная маршрутизация
         ( стандарт фирмы IBM, вошедший в спецификацию APPN; протокол, извест-
         ный также под названием APPN+ )
 HPSN    High Performance Scalable Networking,
         высокопроизводительные расширяемые сети (архитектура фирмы 3Com)
 HPSS    High Performance Storage System,
         высокопроизводительная система хранения данных
 HRC     High Resolution Control, управление высоким разрешением
 HSB     Hue-saturation-brightness,
         цвет-насыщенность-яркость ( метод цветопередачи )
 HSD     High Speed Draft, режим скоростной печати (в матричных принтерах)
 HSDL    High-speed data link, высокоскоростной канал передачи данных
 HSI     Hue-saturation-intensity, цвет-насыщенность-интенсивность
         ( метод цветопередачи, другое название - HSB )
 HSM     Hierarchical storage management,
         управление иерархическими запоминающими устройствами
 HSP     High-speed printer, высокоскоростной принтер
 HSRP    Hot Standby Router Protocol,
         протокол связи с маршрутизатором горячего резерва (в сети Internet)
 HSSB    High Speed Serial Bus, высокоскоростная последовательная шина
         ( спецификации IEEE )
 HSSI    High Speed Serial Interface,
         высокоскоростной последовательный интерфейс
 HSV     Hue-saturation-value,
         цвет-насыщенность-значение ( метод цветопередачи )
 HTML    Hyper-Text Markup Language, гипертекстовый язык описания документов
         ( формат файлов, используемый в сети Internet )
 HTTP    HyperText Transfer Protocol, протокол передачи гипертекста
         ( основа гипертекстовой системы WWW )
 HW      hardware, оборудование, аппаратура, аппаратные средства
I
 IAB     Internet Architecture (ранее - Activities) Board, Совет по архитекту-
         ре Internet ( координирует разработки и развитие протоколов TCP/IP)
 IAN     Integrated Access Node, узел объединенного доступа
 IBCN    Integrated Broadband Communication Network,
         интегральная широкополосная коммуникационная сеть
 IBN     1. Integrated Branch Node, объединенный коммутационный узел
          ( концентратор/маршрутизатор )
         2. integrated business network, интегральная сеть деловой связи
 IC      Integrated circuit, интегральная схема, ИС
 ICA     1. Intelligent Console Architecture,
          архитектура интеллектуальной консоли
         2. International Communications Association,
          Международная ассоциация связи
 ICAD    Interactive computer-aided design,
         интерактивное (диалоговое) автоматизированное проектирование
 ICASE   Integrated Computer-Aided Software Engineering,
         интегрированная автоматизированная разработка программ
 ICCP    Institute for Certification of Computer Professionals, Институт
         сертификации профессионалов в области вычислительной техники
 ICDA    Integrated Cashed Disk Array,
         дисковая матрица со встроенной кэш-памятью
 ICE     Internet Commerce Enabled,
         технология проведения коммерческих операций через Internet
 ICFA    International Computer Facsimile Association,
         Международная ассоциация компьютерной факсимильной связи
 ICI     Inter-Carrier Interface,
         интерфейс связи между линиями различных телефонных компаний
 ICM     Image Compression Manager, программа управления сжатием изображений
 ICMP    Internet Control Message Protocol, протокол управления сообщениями
         в сети Internet (составная часть TCP/IP)
 ICP     intelligent call processing, интеллектуальная обработка вызовов
 ICP/SPP  Interprocess Communications Protocol/Sequenced Packet Protocol,
         протокол связи между процессами/протокол упорядоченной передачи паке-
         тов ( обеспечивает маршрутизацию в сетевой операционной системе VINES
         фирмы Banyan )
 ICSA    International Computer Safety Association,
         Международная ассоциация надежности вычислительных систем
 ICST    Institute of Computer Science and Technology,
         Институт вычислительной техники (США)
 ICTS    Inter-City Telecommunications System, система междугородной связи
 IDAPI   Integrated Database Application Programming Interface,
         единый интерфейс прикладного программирования баз данных ( предложен
         фирмой Borland и поддержан компаниями IBM, Novell, WordPerfect, Com-
         puter Associates, Oracle, Gupta, XDB Systems; обеспечивает в сетях
         клиент/сервер доступ к многопользовательским СУБД независимо от ап-
         паратных платформ, операционных систем и сетевых сред )
 IDDE    Integrated Development and Debugging Environment,
         интегрированная среда разработки и отладки ( программ )
 IDE     1. Integrated Developer's Environment,
          интегрированная среда разработки ( предложена фирмой Borland )
         2. Integrated Drive ( Disk ) Electronics,
          интерфейс устройств со встроенными контроллерами ( стандарт )
         3. Intelligent Drive Equipment, интеллектуальное оборудование диско-
          вого накопителя ( популярный интерфейс, поддерживающий до двух
          жестких дисков )
 IDEF    Integration Definition Method, метод описания интеграции ( стандарт-
         ный, получивший широкое распространение структурированный метод моде-
         лирования, анализа и проектирования деятельности организации, разра-
         ботанный в Управлении ВВС США, один из предшественников BPR )
 IDI     Initial Domain Identifier, идентификатор исходного домена
 IDL     Interface Definition Language, язык описания интерфейса
 IDM     impact dot matrix,
         ударная точечная матрица (печатающая головка матричного принтера)
 IEEE    Institute of Electrical and Electronics Engineers,
         Институт инженеров по электротехнике и радиоэлектронике, ИИЭР
 IEF     Information Engineering Facility,
         инструментальные средства разработки программ
 IEN     Integrated Enterprise Network,
         интегрированная сеть масштаба предприятия
 IESG    Internet Engineering Systems Group,
         Группа системных инженеров сети Internet (в составе IETF)
 IETF    Internet Engineering Task Force, Рабочая группа инженеров Internet
         ( подразделение в составе IAB, разрабатывающее стандарты для этой се-
         ти )
 IFAC    International Federation of Automatic Control,
         Международная федерация по автоматическому управлению
 IFE     intelligent front-end, интеллектуальная станция-клиент
 IFIP    International Federation for Information Processing,
         Международная федерация по обработке информации
 IFL     intelligent form language, язык интеллектуальных форм ( допускающий
         указание адресатов и маршрутов пересылки форм по электронной почте;
         разработан фирмой Delrina)
 IFT     Interbank File Transfer, межбанковский обмен файлами
 IGES    1. Initial Graphics Exchange Standard,
          первичный стандарт обмена графикой (формат графических файлов)
         2. International Graphical Exchange Standard,
          международный стандарт по обмену графической информацией
 IGRP    Interior Gateway Routing Protocol,
         протокол внутренней маршрутизации между шлюзами
 IH      Information Highway, информационная магистраль
 IIA     Information Industry Association,
         Ассоциация информационной индустрии (США)
 IIOP    intelligence input/output processor,
         интеллектуальный процессор ввода/вывода
 IIS     Internet Information Server, информационный сервер Internet
 IITF    Information Infrastructure Task Force,
         Рабочая группа по информационной инфраструктуре
 ILE     Integrated Language Environment,
         интегрированная языковая среда ( разработки программ )
 ILMI    Interim Local Management Interface, промежуточный интерфейс локально-
         го управления ( определяет правила пользования средствами SNMP и со-
         ответствующей административной базой данных для связи конечной стан-
         ции с коммутатором )
 IM      Intelligent Messaging, интелектуальная передача сообщений
 IMA     1. Interactive Multimedia Association,
          Ассоциация по интерактивным средствам мультимедиа
         2. International MIDI Association, Международная ассоциация MIDI
 IMAC    ISDN Media Access Control,
         уровень управления доступом к среде передачи данных в сетях ISDN
 IMAP    Interactive Mail Access Protocol,
         протокол интерактивного доступа к электронной почте
 IMP     1. Interface Message Processor, интерфейсный процессор сообщений
          ( мини-ЭВМ, из которых состоит базовая подсеть сети ARPANET )
         2. Internal Message Protocol,
          протокол внутренних ( служебных ) сообщений
 IMPI    Internal Microprogramming Interface,
         внутренний микропрограммный интерфейс
 IMR     Integrated Multiport Repeater,интегральный многопортовый ретранслятор
 IMS     1. information management system,
          а) информационно-управляющая система, б) система управления информа-
          цией ( иерархическая система управления базами данных, разработанная
          фирмой IBM)
         2. Integration of Management Systems,
          объединение административных систем
         3. Intelligent Messaging Service, интеллектуальная служба передачи
          сообщений ( совместная разработка фирм Microsoft и Banyan, предназ-
          наченная для интеграции средств электронной почты)
         4. Interprocessor Messaging System, система обмена сообщениями между
          процессорами ( протокол фирмы 3Com )
 IMSP    Independent Manufacturer Support Program, программа поддержки незави-
         симых производителей ( выдвинута фирмой Novell )
 IN      Intelligent Network, интеллектуальная сеть
 INM     Internet Network Management, администрирование в сети Internet
 InterNIC     Internet Network Information Center,
         Центр сетевой информации Internet ( содержит большое количество мате-
         риалов по этой сети, доступных всем пользователям; управление Центром
         осуществляют компании Network Solutions, AT&T и General Atomics )
 IO      (I/O) input/output, ввод/вывод
 IONL    Internal Organization of the Network Layer, внутренняя организация
         сетевого уровня ( определяет архитектуру с тремя подуровнями, описы-
         вает типы протоколов и стратегии использования для организации взаи-
         модействия в соответствии с моделью OSI реальных сетей )
 IOP     I/O processor, процессор ввода/вывода
 IOS     1. integrated office system, интегрированная офисная система;
         2. Internetworking Operating System, межсетевая операционная система
          ( стандарт фирмы Cisco Systems )
 IP      1. Image processing, обработка изображений
         2. Internet Protocol, межсетевой протокол ( используется для маршру-
          тизации данных на пути от источника к адресату; первоначально разра-
          ботанный для сети Internet )
 IPC     1. instructions per cycle, число команд, выполняемых за цикл
         2. Interprocessor Communication, межпроцессорная связь
 IPCP    IP Control Protocol, управляющий протокол в семействе IP
 IPDN    International Public Data Network,
         международная общедоступная сеть передачи данных
 IPDS    Intelligent Printer Data System,
         интеллектуальная система (подготовки) данных для печати (элемент SAA)
 IPI     Intelligent Peripheral Interface,
         интеллектуальный интерфейс периферийных устройств
 IPM     intelligent power management, интеллектуальное управление питанием
         ( средства минимизации потребления питания в портативных ПК )
 IPNG    Internetwork Protocol of Next Generation, протокол межсетевого обмена
         следующего поколения ( стандартный протокол обмена данными в сети
         Internet, принятый IETF )
 IPR     1. intellectual property rights,
          права на интеллектуальную собственность
         2. Interactive Photorealistic Rendering,интерактивная натуралистичес-
          кая визуализация ( с получением изображений,не уступающих по качест-
          ву фотографии )
 IPS     1. image processing system, система обработки изображений;
         2. information processing system, система обработки информации
         3. Internet Protocol Suite, набор протоколов Internet ( первоначально
          был разработан для сети APRANET, позднее адаптирован для использова-
          ния в качестве главных протоколов локальных сетей )
 IPX     Internetwork Packet Exchange, межсетевой обмен пакетами ( простейший
         стандартный протокол сети NetWare, выполняющий функции транспортного
         и сетевого уровня без управления потоком данных и обнаружения ошибок;
         разработан фирмой Novell )
 IPXCP   IPX Control Protocol, управляющий протокол в составе IPX
 IRC     Information Resource Commission, Комиссия по информационным ресурсам
 IRDA    Infrared Data Association,
         Ассоциация по инфракрасной технологии ( лучей ) для передачи данных
 IRM     1. Information Resources Management,
          управление информационными ресурсами
         2. information resources manager, менеджер по информационным ресурсам
 IRQ     interruption request, запрос на прерывание
 IRS     information retrieval system, информационно-поисковая система
 IRTO    International Radio and Television Organization,
         Международная организация радиовещания и телевидения
 IS      1. information science, информатика;
         2. information system, информационная система
 ISA     Industry Standard Architecture,
         промышленная стандартная архитектура ( IBM PC ), тип системной шины
 ISAM    Indexed Sequential Access Method,
         индексно-последовательный метод доступа
 ISDN    Integrated Services Digital Network,
         цифровая сеть с интегрированными ( комплексными ) услугами
 ISF     installed file system, установленная файловая система
 IS      Intermediate System to Intermediate System, "Промежуточная система -
         промежуточная система" (протокол обмена между маршрутизаторами )
 ISO     International Standardization Organization,
         Международная организация по стандартизации, МОС
 ISODE   ISO Development Environment,
         среда разработки программ, предложенная ISO
 ISP     1. international standardized profile,
          профиль, соответствующий международному стандарту
         2. Internet Service Provider, поставщик сервиса в сети Internet
          (через узел с прямым доступом к Internet по протоколу IP )
 ISR     information storage and retrieval, хранение и поиск информации
 ISRC    International Standard Recording Code,
         международный стандартный код записи
 ISSA    Information Systems Security Association,
         Ассоциация защиты информационных систем (США)
 ISV     1. Independent Software Vendor,
          независимая фирма-разработчик программного обеспечения
         2. Information System Vendor, поставщик информационных систем
         3. Intelligent Software Vendor,
          фирма-производитель интеллектуальных программных средств
 IT      information technology, информационная технология
 ITA     Interactive Television Association,
         Ассоциация интерактивного телевидения (США)
 ITAA    Information Technology Association of America,
         Американская ассоциация по информационным технологиям
 ITSEC   Information Technology Security,
         безопасность информационных технологий
 ITU     International Telecommunications Union,
         Международный союз электросвязи, МСЭ
 IVR     interactive voice response,
         интерактивный речевой ответ ( система ) на телефонные звонки
 IXC     interexchange carrier,
         канал обмена информацией между телефонными сетями (междугородная
         телефонная связь)
J
 JAD     joint application development, совместная разработка приложений
 Java    язык программирования компании Sun
 JCL     Job Control Language, язык управления заданиями
 JDBC    Java Database Connectivity, связь между БД на языке Java
 JDK     Java Development Kit, инструментарий языка Java
 JEIDA   Japan Electronic Industry Development Association,
         Японская ассоциация развития электронной промышленности
 JES     job entry system, система ввода заданий
 JIEO    Joint Interoperability Engineering Organization,
         Объединенная организация по методам сетевого взаимодействия
 JPEG    Joint Photographic Experts Group,
         а) Объединенная экспертная группа по фотографии,
         б) алгоритм сжатия неподвижного изображения, разработанный группой
         в) стандарт JPEG и соответствующий формат файлов
K
 KB      1. keyboard port, порт клавиатуры
          ( разъем для подключения клавиатуры к компьютеру )
         2. Kilobyte, килобайт (Кбайт: 1024 байта, единица измерения емкости
          памяти или объема передаваемой, хранимой, обрабатываемой информации)
         3. knowledge base, база знаний
 KBMS    Knowledge Base Management System, система управления базой знаний
 Kbps    Kilobit per second, килобит в секунду ( Кбит/с: 210 или 1024 бита в
         секунду, единица измерения пропускной способности линии/канала связи,
         сети или устройства передачи данных )
 KBS     Knowledge Base System, система баз знаний, СБЗ
 KEE     Knowledge Engineering Environment,
         среда представления и использования знаний
L
 LAA     LAN Administration Architecture,
         архитектура администрирования локальных сетей
 LAN     Local Area Network, локальная (вычислительная) сеть, ЛС (ЛВС)
 LAND    Local Area Network Directory, каталог локальной сети
 LANRES  LAN Resource Extension and Services, программные средства расширения
         и обслуживания ресурсов локальной сети
 LAP     Link Access Protocol,
         протокол доступа к каналу связи ( протокол в составе HDLC )
 LAP-B   Link Access Protocol - Balanced,
         сбалансированный протокол доступа к линии связи
 LAPM    Link Access Protocol for Modems,
         протокол доступа к каналу связи для модемов
 LAT     Local Area Transport, передача в локальной сети
         ( протокол фирмы DEC для работы терминалов в локальной сети )
 LATA    local access and transport area, область локального доступа и переда-
         чи ( географическая зона, обслуживаемая одной компанией RBOC )
 LAU     LAN Access Unit, блок (устройство) доступа к локальной сети
 LBA     logical block addressing, логическая адресация блоков
 LC      logical channel, логический канал
 LCD     1. liquid-crystal display, жидкокристаллический индикатор (дисплей);
         2. lowest common denominator, наименьшее общее кратное ( метод пост-
          роения мультиплатформенных объектно-ориентированных приложений,осно-
          ванный на поддержке только общих функций для различных платформ )
 LCFS    Least Completed First Served,
         "наименее завершенный обслуживается первым" (дисциплина обслуживания)
 LCSS    Line Conditioners, Surge Supressors,
         средства защиты оборудования от бросков электропитания
 LCT     Link Certification Test, тест на сертификацию канала связи
 LDDI    Local Distributed Data Interface,
         локальный распределенный интерфейс передачи данных (в сетях)
 LDN     local distributed network, локальная распределенная сеть
 LE      limited edition, сокращенная редакция (версия программного продукта)
 LEC     1. LAN Emulation Client, клиент эмуляции локальной сети
         2. local exchange carrier, а) местная телефонная сеть,
          б) фирма-владелец местной телефонной сети
 LEC/ID  LAN Emulation Client Identifier,
         идентификатор клиента эмуляции локальной сети
 LECS    LAN Emulation Configuration Service,
         служба конфигурации эмуляции локальной сети
 LED     Light-Emitting Diode, светодиод
 LEL     Link, Embed and Launch-to-Edit,компоновка и запуск на редактирование
         ( технология, позволяющая автоматически загружать другое приложение
         при обращении к документу )
 LENNI   LAN Emulation Network to Network Interface,
         межсетевой интерфейс эмуляции локальных сетей
 LER     Link Error Rate, коэффициент встречаемости ошибок в каналах связи
 LES     LAN Emulation Server, сервер эмуляции локальных сетей
 LF      line feed, перевод строки
 LFU     least frequently used, наименее часто используемый
 LIC     Licensed Internal Code, лицензионный внутренний код
 LIF     Logical Interchange Format,
         формат логического обмена ( в операционной системе HP-UX )
 LIFO    last-in, first-out, "последним пришел - первым обслужен"
         ( метод обработки в порядке, обратном порядку поступления )
 LISP    List Processing, ЛИСП ( язык программирования для обработки нечисло-
         вых данных - списков )
 LLC     Logical Link Control, управление логическим каналом (протокол)
 LLCS    Logical Link Control Sublayer, подуровень управления логическим зве-
         ном ( часть уровня звена данных в модели OSI, независимая от передаю-
         щей среды и использующая сервис подуровня управления доступом к сре-
         де, MACS, для предоставления услуг сетевому уровню )
 LMI     local management interface, интерфейс локального управления (в сети)
 LMP     LAN Management Protocol, протокол управления локальной сетью
         ( типа Token Ring )
 LNM     LAN Network Manager, программа управления локальной сетью
 LON     LAN Outer Network, сеть,внешняя по отношению к данной локальной сети
 LP      light pen, световое перо
 LPA     LAN Performance Analyzer,
         анализатор пропускной способности локальной сети
 LPB     Linpack benchmark, эталонный тест Linpack ( пакет тестов для оценки
         быстродействия при вычислениях с плавающей запятой )
 LPF     League for Programming Freedom,
         Лига борьбы за свободу программирования
 LPI     (lpi) lines per inch, (число) линий на дюйм
 LPM     (lpm) lines per minute, (число) строк в минуту
 LPP     Licensed Program Product, лицензионный программный продукт
 LPS     (lps) lines per second, (число) строк в секунду
 LPT     line printer, а) построчный принтер,
         б) обозначение параллельного порта ПК для подключения принтера
 LQ      letter quality, режим высококачественной печати
 LRU     Last (Least) Recently Used, "наиболее давно использовавшийся" ( алго-
         ритм замещения блоков информации в иерархических системах запоминаю-
         щих устройств )
 LS      1. Library Server, библиотечный сервер;
         2. Licensing System, система лицензирования
 LSAE    Low-Speed Asynchronous Encryptor,
         низкоскоростной шифрователь асинхронного типа
 LSAPI   1. License Server Application Programming Interface,
         интерфейс прикладного программирования для сервера контроля лицензий
         ( программное средство в составе ОС и приложений, позволяющее контро-
         лировать фактическое использование лицензионных программ в сети )
         2. License Service Application Programming Interface,
         интерфейс прикладного программирования службы лицензирования
 LSI     large-scale integration, а) интеграция высокого уровня,
         б) большая интегральная схема, БИС
 LSL     Link Support Level, уровень поддержки канала передачи данных ( служит
         прослойкой между драйверами локальной сети и коммуникационными прото-
         колами IPX, AFP, TCP/IP )
 LTE     Line termination equipment,
         оконечная аппаратура линии ( передачи данных )
 LU      Logical unit, логический блок
 LUE     Look up engine, механизм поиска (в рамках технологии коммутации SFPS)
 LUG     Local User Group, локальная группа пользователей
 LVM     Logical Volume Manager, программа управления логическими томами
M
 MAC     Media Access Control,
         управление доступом к среде передачи (стандарт сетей Ethernet)
 MACH    Multilayer Actuator Head, головка с многоуровневым исполнительным ме-
         ханизмом ( пьезотехнология фирмы Epson для струйных принтеров )
 MACP    Medium Access Control Protocol, протокол управления доступом к среде
 MACS    Medium Access Control Sublayer, подуровень управления доступом к сре-
         де (часть уровня звена данных в модели OSI, применяющая метод доступа
         к передающей среде и использующая сервис физического уровня для пре-
         доставления услуг подуровню управления логическим звеном, LLCS)
 MAIS    Maintenance Information System,
         информационная система технического обслуживания
 MAN     1. medium area network, региональная (зональная) сеть;
         2. metropolitan area network, общегородская сеть
 MAP     Manufacturing Automation Protocol,
         протокол автоматизации производства
 MAPI    Messaging Application Programming Interface, интерфейс программирова-
         ния приложений электронной почты ( предложен фирмой Microsoft )
 MAS     Multimedia Access System, система доступа к данных мультимедиа
 MAU     1. medium attachment unit,
          ( пассивный ) блок доступа к среде ( передачи данных )
         2. multistation (multi) access unit,
          устройство множественного доступа
 MB      Megabyte, мегабайт (Мбайт) - 220 или несколько более 106 байтов, еди-
         ница измерения емкости памяти или объема передаваемой, хранимой, об-
         рабатываемой информации)
 MBONE   Multicast Backbone, базовая сеть многоадресного вещания ( для тести-
         рования средств передачи аудио- и видеоинформации по Internet )
 Mbps    Megabit per second, мегабит в секунду (Мбит/с) - 220 или несколько
         более 106 битов в секунду, единица измерения пропускной способности
         линии/канала связи, сети или устройства передачи данных )
 MCA     Micro Channel Architecture, микроканальнаая архитектура ( стандартная
         системная шина, разработанная фирмой IBM )
 MCAM    Multiple Communications Adapter Module,
         модуль адаптера многоканальной связи
 MCGA    multicolor graphics adapter, многоцветный графический адаптер
 MCI     Medium Control Interface, интерфейс управления средой передачи данных
 MCU     1. multipoint conferencing unit,
          система видеоконференц-связи между несколькими пунктами;
         2. Multipoint Control Unit, устройство управления многопунктовой
          связью ( для проведения видеоконференций )
 MDA     mono display adapter, монохромный дисплейный адаптер
 MDC     multi-device controller, контроллер нескольких периферийных устройств
 MDI     1. Medium Dependent Interface,
          интерфейс, зависящий от среды (передачи данных);
         2. Multiple Document Interface, многодокументный интерфейс ( средства
          общения пользователя с множеством наборов данных, представленных в
          различных форматах; стандарт, принятый в среде Windows)
 MDP     Message Driven Processor, процессор, управляемый сообщениями
 MDR     medium data rate, средняя скорость передачи данных
 MEE     Multimedia Enabled Ethernet, Ethernet с возможностями мультимедиа
         ( технология, предложенная фирмой 3Com и обеспечивающая работу ло-
         кальных сетей Ethernet с приложениями мультимедиа )
 MFC     Microsoft Foundation Classes,
         базовые классы ( объектов ) фирмы Microsoft
 MFDU    Minifloppy disk unit, мини-накопитель на гибких магнитных дисках
 MFLOPS  MegaFLOPS, миллион FLOPS, мегафлопс, Мфлопс
 MFM     Multifunctional module, многофункциональный модуль
 MFSS    Military and Federal Specifications and Standards,
         военные и федеральные спецификации и стандарты (США)
 MGA     Multimedia Graphics Architecture,
         графическая архитектура мультимедиа
 MGE     Modular GIS Environment, модульная среда географических информацион-
         ных систем ( формат географических данных )
 MH      Modular hub, модульный концентратор
 MHS     1. Message Handling Service, служба обработки сообщений ( протокол
          фирмы Novell для связи с системами электронной почты );
         2. Message Handling System, система обработки сообщений
 MI      Management interface, интерфейс управления ( интерфейс в составе DMI
         между программой служебного уровня и административными приложениями )
 MIB     Management Information Base, административная база данных ( содержит
         информацию обо всех управляемых устройствах; используется в SNMP)
 MIC     Management Integration Consortium,
         Консорциум по интеграции средств (сетевого) управления
 MICE    Management Information, Control and Exchange,
         управляющая информация, контроль и обмен
 MICR    Magnetic Ink Character Recognition, чтение знаков, отпечатанных маг-
         нитной краской; распознавание символов, нанесенных магнитными черни-
         лами
 MICS    Manufacturing information and control system,
         информационная система управления производством
 MIDI    Musical Instrument Device Interface,
         интерфейс электромузыкальных инструментов
 MIF     Management Information File, файл административной информации
 MII     Medium Independent Interface,
         интерфейс, независимый от среды ( передачи данных )
 MIMD    Multiple-Instruction, Multiple-Data, множество потоков команд и мно-
         жество потоков данных ( архитектура параллельных систем )
 MIME    Multi-purpose Internet Mail Extensions, многоцелевые расширения
         электронной почты в Internet ( протокол передачи графики и другой
         нетекстовой информации по электронной почте )
 MIO     Modular input/output, модульный ввод/вывод
 MIPS    Million Instructions Per Second, миллион операций в секунду, мипс
         ( единица измерения быстродействия ЭВМ )
 MIS     1. Management Information System, административно-информационная сис-
          тема ( автоматизированная информационная система для руководителей
          и администраторов высшего и среднего звена, обеспечивающая оператив-
          ный доступ к текущей информации );
         2. manager of information system,
          менеджер ( администратор ) информационной системы
 MIT     Massachusetts Institute of Technology,
         Массачусетский технологический институт (США)
 MIS     Мanagement information system
 MLAN    Multichannel LAN, многоканальная локальная сеть
 MLB     Multilayer board, многослойная печатная плата
 MLFA    Machine-Learned Fragment Analysis, анализ через машинное обучение на
         фрагментах (методика распознавания символов)
 MLID    Multiple Link Interface Driver, многоканальный интерфейсный драйвер
 MLS     Multilevel Security, многоуровневая защита данных
 MMA     Microcomputer Managers Association, Ассоциация менеджеров микро-ЭВМ
 MMAC    Multimedia Access Control, управление доступом к различным средам
         передачи данных
 MMCF    MultiMedia Communications Forum,
         Форум по средствам связи с использованием мультимедиа
 MMI     Man-machine interface, интерфейс "человек-машина"
 MMPM    MultiMedia Presentation Manager, программа управления презентацией с
         использованием мультимедиа
 MMS     Manufacturing Messaging Specification, спецификация производственной
         службы сообщений (стандарт для передачи сообщений внутри предприятия)
 MMU     Memory management unit,
         1) блок (устройство) управления памятью 2) диспетчер памяти
 ММХ     MultiMedia eXtension, технология мультимедийных расширений ( впер-
         вые реализована в 200-МГц версии процессора Р55С в 1996 году )
 MNI     Mobile network integration, объединение сетей подвижной связи
 MNP     Microcom Network(ing) Protocol, сетевой протокол Microcom ( набор
         протоколов модемной связи, обеспечивающих исправление ошибок и сжатие
         данных; разработан фирмой Microcom и признан стандартом в области
         модемов )
 MO      Magneto-optical, магнитооптический
 MOB     Movable object block, перемещаемый фрагмент объекта, спрайт
 MOD     Magneto-optical disk, магнитооптический диск
 MOLAR   Multidimensional OLAP,  многомерная OLAP, включающая как базы данных,
         так и клиентские инструменты,которые используют и хранят данные в ви-
         де многомерных моделей, а не в реляционных таблицах
 MOM     1. manager of managers, "администратор администраторов"( принцип рас-
          пределенного управления сетями с передачей функциональной обработки
          локальным серверам, но с сохранением централизованного контроля за
          работой всей сети);
         2. message-oriented middleware, ПО промежуточного уровня, ориентиро-
          ванное на сообщения
 MOSPF   Multicast Open Shortest Path First, предпочтительное предоставление
         кратчайшего пути при групповой ( многоадресной ) рассылке ( сетевой
         протокол )
 MOTIS   Message-Oriented Text Interchange System, система обмена текстовыми
         файлами на основе механизма сообщений
 MP      Multiprocessing, мультипроцессорная обработка
 MPB     Multiprocessor Parallel Bus, мультипроцессорная параллельная шина
         ( магистраль с 32-разрядными мультиплексированными шинами адреса и
         данных, реализованная в компьютерах серии HP 9000 фирмы Hewlett-
         -Packard )
 MPC     1. Multimedia Personal Computer, ПК со средствами мультимедиа ( стан-
          дарт, предложенный фирмой Microsoft и определяющий минимальные ха-
          рактеристики аппаратных средств мультимедиа и их интерфейсы);
         2. multi-purpose communications, многоцелевая система связи
 MPEG    Motion Picture Experts Group, 1) экспертная группа по кинематографии
         2) одноименный алгоритм сжатия подвижного изображения, разработанный
          этой группой, а также соответствующий формат файлов ( стандарт был
          предложен фирмами Intel и Xing Technology )
 MPP     1. Massively Parallel Processing,
          обработка данных с массовым параллелизмом;
         2. massively parallel processor, процессор с массовым параллелизмом
 MPS     MultiProcessor Specification, спецификация мультипроцессорных систем
         ( разработана фирмой Intel )
 MPTN    Multiprotocol Transport Network,
         многопротокольная сеть передачи данных
 MQ      Messaging and Queuing, передача сообщений с организацией очередей
         ( технологии передачи данных с промежуточным хранением, разработанная
         фирмой IBM )
 MQI     Message Queue Interface, интерфейс очередей сообщений
 MRCI    Microsoft Realtime Compression Interface,
         интерфейс сжатия данных в реальном времени фирмы Microsoft
 MS      1. Message Server, сервер сообщений;
         2. mirrored server, задублированный сервер
 MSH     Multi Services Hub,
         многоцелевой концентратор ( обслуживающий сети различных типов )
 MSL     Mirrored Server Link, задублированная связь серверов
 MSS     Mass storage system, массовое запоминающее устройство
 MTA     Message Transfer (Transport) Agent, агент передачи сообщений ( прог-
         рамма, обеспечивающая доставку электронной почты в местный почтовый
         ящик и задающая маршрут почтовых сообщений в глобальной сети )
 MTBDL   Mean Time Between Data Losses, среднее время между потеряpми данных
 MTBE    Mean time between errors, средняя наработка на ошибку, среднее время
         безошибочной работы
 MTBF    Mean Time Between Failures, среднее время между отказами, средняя на-
         работка на отказ, среднее время безотказной работы
 MTBSF   Mean time between system failures,
         среднее время между системными отказами, наработка на системный отказ
 MTC     MIDI Time Code, временной код MIDI
 MTF     Microsoft Tape Format, формат магнитной ленты фирмы Microsoft
 MTNT    Multiple Technology Network Testbed,
         многофункциональный стенд для испытаний сетевых технологий
 MTOP    Million theoretical operations per second,
         миллион теоретических операций в секунду
 MTTD    Mean time to detect, среднее время обнаружения (ошибки)
 MTTF    Mean time to failure,
         средняя наработка на отказ, среднее время безотказной работы
 MTTFF   Mean time to first failure, средняя наработка до первого отказа
 MTTR    1. mean time to recovery, среднее время восстановления;
         2. mean time to repair, а) средняя наработка до ремонта,
          б) среднее время ремонта
 MUI     Media User Interface, интерфейс пользователя для доступа к среде
         ( передачи данных )
 MUSE    Mail Users' Support Environment,
         среда поддержки пользователей электронной почты
 MVP     Multimedia Video Processor, мультимедиа-видеопроцессор ( микропро-
         цессор цифровой обработки сигналов фирмы Texas Instruments )
 MVS     1. multiple virtual storage, многосегментная виртуальная память;
         2. MultiVideo System, система мультивидео
 MVT     Multiprogramming with variable tasks,
         мультипрограммирование с переменным числом заданий
 MX      Mail exchange, обмен по почте
N
 NACSE   National Association of Communication Systems Engineers,
         Национальная ассоциация инженеров по системам связи (США)
 NAEC    Novell Authorized Education Center,
         авторизованный учебный центр компании Novell
 NAF     Network access facility, средства доступа к сети
 NAM     1. network access method, метод доступа к сети;
         2. numerical assignment module,
          модуль задания номера ( телефона в сотовой сети )
 NAP     1. network access point, точка входа в сеть
         2. Network Applications Platform, платформа сетевых приложений
          ( разработана фирмой Unisys )
 NAPI    Network Application Program Interface,
         сетевой интерфейс прикладного программирования
 NAR     Novell Authorized Reseller, авторизованный реселлер фирмы Novell
 NAS     1. Network Administration System, система сетевого администрирования;
         2. Network Application Support,  поддержка сетевых приложений ( архи-
          тектура корпорации Digital Equipment для сетей, содержащих различные
          платформы )
 NASI    NetWare Asynchronous Service (System) Interface,
         асинхронный служебный (системный) интерфейс ОС NetWare
 NBS     National Bureau of Standards, Национальное бюро стандартов (США)
 NC      Numerical control, числовое (программное) управление, ЧПУ
 NCC     Network control center, центр управления сетью
 NCD     Network Call Distributor, механизм распространения вызовов в сети
 NCE     Network Control and Exchange,
         управление и обмен данными в сети (протокол фирмы Digital Equipment)
 NCGA    National Computer Graphics Association,
         Национальная ассоциация компьютерной графики (США)
 NCIA    Native Client Interface Architecture, естественная архитектура интер-
         фейса станции-клиента ( предложенный фирмой Cisco Systems метод реа-
         лизации технологии коммутации DLSw путем инкапсуляции трафика SNA в
         данные TCP/IP непосредственно на станции-клиенте )
 NCL     Network Control Language, язык управления сетью
 NCP     1. NetWare Core Protocol, протокол ядра ОС NetWare;
         2. network control point, сетевая административная консоль;
         3. Network Control Program, программа управления сетью;
         4. Network Control Protocol, протокол управления сетью
 NCS     1. Network Computing ( Computer ) System, система сетевых вычислений
          ( стандарт, разработанный фирмой Hewlett-Packard для протокола сете-
           вого уровня )
         2. network control system, система управления сетью
 NCSA    1. National Center for Supercomputing Application, Национальный
          центр по применению супер-ЭВМ (организован NSF при Университете шт.
          Иллинойс, США)
         2. National Computer Security Association,
          Национальная ассоциация компьютерной безопасности (США)
 NCSC    National Computer Security Center,
         Национальный центр компьютерной безопасности (США)
 NDBS    Network database system,
         сетевая система управления базой данных, сетевая СУБД
 NDIS    Netwоrk Driver Interface Specification,
         спецификация интерфейсов сетевых драйверов (стандарт фирмы Microsoft)
 NDM     Network Data Mover, программа управления передачей данных в сети
 NDMS    NetWare Distributed Management Services,
         службы распределенного администрирования в ОС NetWare
 NDS     NetWare Directory Services, (глобальная) служба каталогов ОС NetWare
         (единый сетевой каталог, набор функций, предоставляющий пользователям
         "сквозной" доступ к распределенным сетевым ресурсам; имеет древовид-
         ную структуру, основан на стандарте X.500; позволяет объединить все
         сетевые ресурсы в единую систему независимо от их физического разме-
         щения )
 NEP     Network entry point, точка входа в сеть
 NEST    NetWare (Novell) Embedded Systems Technology, технология встроенных
         систем NetWare (Novell) ( технология широкого доступа к данным по те-
         лефону в сети NetWare )
 NETBEUI NETBIOS Extended User Interface, расширенный пользовательский интер-
         фейс среды NETBIOS ( транспортный протокол широковещательной переда-
         чи )
 NETBIOS (NetBIOS) Network Basic Input/Output System, сетевая базовая система
         ввода/вывода ( разработана фирмой IBM, предназначена для обеспечения
         взаимодействия между ПК в сети, записана в системном ПЗУ )
 NETSP   Network Security Program, программа защиты данных в сети
 NEU     Network Encryption Unit, сетевой шифровальный блок
 NEXT    Near-end cross talk,
         перекрестные наводки на ближнем конце ( линии связи )
 NFS     1. Network File Service, сетевой файловый сервис (протокол);
         2. Network File System, сетевая файловая система ( стандартный прото-
          кол фирмы Sun Microsystems с разделенными файлами, входящий в состав
          ONC; не зависит от платформы, обеспечивает совместное использование
          файлов посредством "виртуальных  дисков" и поддерживается TCP/IP )
 NIC     1. Network Information Center, сетевой информационный центр;
         2. Network Interface Card,
          сетевая интерфейсная карта ( плата ), сетевой адаптер
 NICA    Novell Integrated Computing Architecture,
         интегрированная вычислительная архитектура фирмы Novell
 NICE    Natural Interface for Computing Environments,
         естественный интерфейс вычислительных сред
 NID     Network interface device, устройство сопряжения с сетью
 NIF     Node Information Frame, фрейм информации об узле
 NII     National Information Infrastructure,
         национальная информационная инфраструктура (США)
 NIIT    National Information Infrastructure Testbed,
         1) Испытательный стенд национальной информационной инфраструктуры,
         2) одноименная рабочая группа представителей промышленных, академи-
          ческих и правительственных кругов
 MH      (Ni-MH) см. NMH
 NIP     Nonimpact printer, принтер безударного действия
 NIR     Normalized information rate,
         стандартизованная скорость передачи информации
 NIS     Network Information Service, сетевая информационная служба ( исполь-
         зуемый NFS глобальный каталог ресурсов сети, включающей разнотипные
         платформы )
 NISA    New Information Services Architecture, новая архитектура информацион-
         ных услуг ( однородная вычислительная среда клиент/сервер сети Compu-
         Serve )
 NISO    National Information Standard Organization,
         Национальная организация по информационным стандартам (США)
 NIST    National Institute of Standards and Technologies,
         Национальный институт по стандартам и технологиям (США)
 NITC    National Information Technology Center,
         Национальный центр информационных технологий (США)
 NL      Natural Language, естественный язык
 NLM     NetWare Loadable Module, загружаемый модуль ОС NetWare ( приложения,
         выполняемые на сервере локальной сети под управлением сетевой опера-
         ционной системы NetWare фирмы Novell)
 NLQ     Near Letter Quality, режим высококачественной печати
         ( на уровне пишущей машинки )
 NLS     1. National Language Support, поддержка национальных языков;
         2. Network License Server, сетевой сервер (контроля) лицензий
 NLSP    NetWare Link Services Protocol,
         протокол обслуживания связей (маршрутизации) в ОС NetWare
 NMA     Network management application, приложение сетевого администрирования
 NMC     Null Modem Cable, "нуль-модемный" кабель ( специальный кабель для
         соединения двух ПК через последовательные порты)
 NMH     Nickel-metal hydride, никель-металл-гидридная ( батарея питания )
 NMI     Non-maskable interrupt, немаскируемое прерывание
 NMMA    National Microcomputer Managers Association,
         Национальная ассоциация администраторов микрокомпьютерных систем США
 NMO     Network management option, средства сетевого управления
 NMS     1. NetWare Management System,
          система сетевого администрирования ОС NetWare;
         2. Network Management Station, станция управления сетью
 NMT     Nordic Mobile Telephone, северный мобильный телефон ( первый в мире
         стандарт сотовых сетей, введенный в 1981 г. в скандинавских странах;
         предшественник AMPS )
 NMVT    Network Management Vector Transport, векторная ( направленная ) пере-
         дача данных управления сетью ( формат, тип сообщения SNA для пере-
         сылки управляющей информации )
 NN      Network node, узел сети
 NNCP    Network node control point, пункт управления узлами сети
 NNI     1. network-node interface, интерфейс "узел-сеть";
         2. network-to-network interface, межсетевой интерфейс ( спецификация,
         предложенная консорциумом ATM Forum и описывающая различные типы про-
         токолов связи между коммутаторами разных производителей в сетях ATM)
 NNM     Network Node Manager, программа управления узлами сети
 NNRP    Network News Reading Protocol, протокол для чтения сетевых новостей
         ( используется в службе новостей Usenet сети Internet для обмена те-
         матическими информационными сообщениями между локальными серверами
         новостей )
 NNS     NetWare Naming Service, служба именования в ОС NetWare ( средство,
         копирующее информацию  из перечня на все задействованные серверы )
 NNTP    Network News Transport (Transfer) Protocol, протокол передачи новос-
         тей по сети ( стандарт обмена сообщениями конференций Usenet по сети
         Internet )
 NOP     1. network operational protocol, рабочий протокол обслуживания сети;
         2. no operation, а) в нерабочем состоянии, б) пустая операция
 NOS     Network operating system, сетевая операционная система
 NPA     Network Printer Alliance,
         Объединение производителей сетевых принтеров
 NPDU    Network (Layer) Protocol Data Unit,
         блок протокольных данных сетевого уровня
 NPS     Network printing service, сетевая служба печати
 NREN    National Research and Education Network,
         Национальная научно-исследовательская и образовательная сеть (США)
 NRS     Network Resource Server, сервер сетевых ресурсов
 NRZI    Non return to zero inverted, (запись) без возврата к нулю с инверти-
         рованием ( способ кодирования двоичных сигналов )
 NS      Name Services, служба именования
 NSAP    1. NetWare Service Advertizing Protocol,
         протокол рекламного сервиса в среде Netware;
         2. Network Service Access Point, точка доступа к сетевому сервису
 NSC     1. Network Security Center,
          Центр по защите сетей ( от несанкционированного доступа );
         2. network switching center, коммутационный центр сети
 NSDU    Network Service Data Unit, блок служебных данных в сети
 NSE     Network Services Engine, механизм сетевого обслуживания
 NSF     National Science Foundation, Национальный научный фонд (США)
 NSP     Network Services Protocol, протокол сетевого обслуживания
 NSS     1. Network Security Server, сетевой сервер защиты данных;
         2. Network Security System, система защиты данных в сети
 NSSN    National Standards Systems Network, Национальная сеть систем стандар-
         тизации ( сеть, связывающая все организации по разработке стандартов
         NIST и ANSI, США )
 NSTL    National Software Testing Laboratory,
         Национальная лаборатория тестирования программного обеспечения (США)
 NTFS    New Technology File System, файловая система новой теxнологии ( спо-
         собная к самовосстановлению после отказов диска )
 NTIS    National Technical Information Service,
         Национальная служба технической информации (США)
 NTP     Network Time Protocol, сетевой протокол службы времени
         ( для получения  точного времени с атомных часов в сети Internet )
 NTSC    National Television System Committee,
         а) Национальный комитет по телевизионным системам США
         б) НТСЦ ( одноименная система цветного телевидения, стандартный фор-
          мат, принятый в США и Японии, а также используемый в системах муль-
          тимедиа )
 NUG     National User Group, национальная группа пользователей
 NVT     Network virtual terminal, сетевой виртуальный терминал
 NWN     Nationwide Wireless Network, общенациональная беспроводная сеть
O
 OA      Office automation, автоматизация офиса
 OAM     1. Operations, Administration and Maintenance,
          а) администрирование и обслуживание в процессе эксплуатации;
          б) одноименный формат административных данных
         2. operation and maintenance,эксплуатация и техническое обслуживание
 OBEX    Object Exchange, обмен объектами (технология фирмы Borland)
 OC      1. Office communications, учрежденческая связь;
         2. Optical carrier, оптоволоконная линия связи
 OCE     Open Collaboration Environment, среда открытого сотрудничества ( рас-
         ширение системного программного обеспечения, разработанное фирмой
         Apple )
 OCF     Object Component Framework, структура объектных компонентов ( библио-
         тека классов фирмы Borland )
 OCR     1. optical character reader, оптическое считывающее устройство;
         2. Optical Character Recognition, оптическое распознавание символов
 OCS     Office communication system, учрежденческая система связи
 OD      (O/D) on demand, по требованию, по запросу
 ODA     1. Office Document Architecture,
          архитектура учрежденческих документов (стандарт);
         2. Open Document Architecture,
          открытая архитектура обработки документов (см. тж. ODMA)
 ODAPI   Open Database Application Programming Interface, открытый интерфейс
         прикладного программирования баз данных
 ODB     Object database, объектная база данных
 ODBC    (ODC) Open Database Connectivity, открытые средства связи с базами
         данных ( стандартный протокол фирмы Microsoft )
 ODCS    Open Distributed Computing Structure,
         открытая структура распределенных вычислений
 ODI     Open Data-link Interface, открытый интерфейс передачи данных ( стан-
         дарт, позволяющий различным транспортным протоколам совместно исполь-
         зовать каналы передачи данных независимо от среды )
 ODIF    Office Document Interchange Format,
         формат взаимного обмена учрежденческими документами
 ODL     1. object definition language, язык описания объектов;
         2. optical data link, оптический канал передачи данных
 ODM     1. Object Data Manager, программа-менеджер объектных данных;
         2. original design manufacturer,
          производитель систем собственной разработки
 ODMA    Open Document Management Architecture, открытая архитектура управле-
         ния документами ( стандартный интерфейс прикладного программирования
         для связи клиентов с DMS )
 ODMG    Object Database Management Group,
         Группа по управлению объектными базами данных (консорциум)
 ODTP    Open Distributed Transaction Processing,
         открытая распределенная обработка транзакций
 OECR    Overall Evaluation Class Rating, рейтинг общей оценки класса ( рей-
         тинг безопасности компьютерной системы по критериям NCSC )
 OEM     Original Equipment Manufacturer, фирма-изготовитель комплектного
         ( комплексного ) оборудования ( поставщик систем )
 OFC     1. optical fiber cable, волоконно-оптический кабель;
         2. optical fiber communication, волоконно-оптическая связь
 OFS     1. object file system, объектная файловая система;
         2. Office Server, офисный сервер
 OFTL    Optical fiber transmission line,
         волоконно-оптическая линия связи, ВОЛС
 OFTS    Optical fiber transmission system,
         система передачи (данных) по волоконно-оптическим каналам
 OID     Object identifier, идентификатор объекта
 OIRT    см. IRTO
 OIS     Ooffice information system, учрежденческая информационная система
 OLAP    On-Line Analytical Processing,
         а) оперативная аналитическая обработка,
         б) одноименный консорциум ( по применению многомерных баз данных для
          аналитической обработки в реальном времени )
 OLB     Object location broker, программа-брокер местоположения объектов
 OLCP    On-Line Complex Processing, оперативная комплексная обработка (техно-
         логия обработки объектов, предложенная фирмой Borland )
 OLE     Object Linking and Embedding, объектная компоновка
 OLEO    Open Linking and Embedding of Objects, открытая компоновка объектов
         ( технология фирмы WordPerfect, поддерживающая методы объектной ком-
         поновки OLE и предназначенная для связи между приложениями )
 OLI     Optical Line Interface, интерфейс оптических линий связи
 OLTP    On-line transaction processing, оперативная обработка транзакций
 OMA     Object Management Architecture, архитектура объектного управления
 OME     Open Messaging Environment, открытая среда передачи сообщений
 OMF     1. object management facility,
          средства управления объектами ( поддерживают стандарты NCS и ONS )
         2. Object Module Format, формат объектного модуля
 OMG     1. Object Management Group, a) Группа по управлению объектами
          ( консорциум ), б) одноименный стандарт;
         2. Object Manipulation Group, Группа ( по разработке стандартов )
          манипулирования объектами
 OMI     1. Open Messaging Interface, открытый интерфейс передачи сообщений
          ( стандартная технология, предложенная фирмой Lotus и обеспечивающая
          работу электронной почты с различными операционными системами )
         2. Open Microprocessor System Initiative, Инициатива по открытым мик-
          ропроцессорным системам ( организация европейских производителей
          микропроцессоров )
 OMW     Object Management Workbench,
         инструментальные средства объектного управления
 ONA     Open Network Architecture, открытая сетевая архитектура
 ONC     Open Network Computing, открытая сетевая вычислительная среда ( тех-
         нология, предложенная фирмой Sun Microsystems; набор сетевых протоко-
         лов и услуг, позволяющий организовать распределенные вычисления в
         разнородной сети, включающей различные платформы )
 ONTC    Optical Networks Technology Consortium,
         Консорциум по технологиям оптических сетей
 OOA     Object-oriented analysis, объектно-ориентированный анализ
 OOD     Object-oriented design, объектно-ориентированное проектирование
 OODB    Object-oriented database, объектно-ориентированная база данных
 OOM     Object-oriented modelling, объектно-ориентированное моделирование
 OOP     Object-Oriented Programming,объектно-ориентированное программирование
 OOPS    Object-oriented programming system, объектно-ориентированная система
         программирования
 OOT     Object-oriented technology, объектно-ориентированная технология
 OR      Object Repository, хранилище объектов (данных об объектах)
 ORB     Object Request Broker, программа-брокер объектных запросов (программ-
         ное обеспечение взаимодействия объектов в объектно-ориентированной
         сети )
 OS      1. Object Server, объектный сервер;
         2. operating system, операционная система, ОС
 OSA     1. office system automation, автоматизация делопроизводства
         2. Open Scripting Architecture, открытая архитектура сценариев ( на-
          бор интерфейсов API, совместимых с сетевой средой и позволяющих об-
          щаться с программными компонентами на разных языках описания сцена-
          риев)
         3. Open Systems Adapter, адаптер открытых систем;
         4. Open Systems Architecture, архитектура открытых систем
 OSE     Open System Environment, среда открытых систем ( развитие идей OSI
         для расширения возможностей переносимости и взаимодействия приложений)
 OSF     Open Software Foundation,
         Фонд открытого программного обеспечения (консорциум)
 OSI     Open Systems Interconnection, взаимодействие открытых систем ( стан-
         дарт сетевого и межсетевого взаимодействия, разработанный ISO; семи-
         уровневая модель сетевых протоколов )
 OSI\RM  Open Systems Interconnection/Reference Model, эталонная модель OSI
 OSI\TP  Open Systems Interconnection/Transaction Processing,
         обработка транзакций в среде OSI (стандарт)
 OSME    Open Systems Message Exchange, обмен сообщениями в открытых системах
 OSPF    Open Shortest Path First, "первым выбирается кратчайший путь" (прото-
         кол маршрутизации в составе TCP/IP, предложенный фирмой Proteon)
 OSS     Operational Support System, система оперативной поддержки
 OT      Object technology, объектная технология
 OTF     Open Tape Format, открытый формат лент (стандарт)
 OURS    Open User Recommended Solutions, "Технические решения, рекомендуемые
         пользователям открытых систем" ( группа, занимающаяся вопросами сов-
         местимости и управления в распределенных средах, включающих продукты
         разных поставщиков )
 OWL     Object Windows Library, объектная библиотека для среды Windows ( биб-
         лиотека классов фирмы Borland )
P
 PABX    Private automatic branch exchange,
         учрежденческая АТС с исходящей и входящей связью (с городом)
 PACE    1. Priority Access Control Enabled, управление с возможностью приори-
          тетного доступа ( технология коммутации портов в сетях Ethernet,
          предложенная корпорацией 3Com и обеспечивающая передачу в реальном
          времени высокоприоритетных данных мультимедиа)
         2. program analysis control and evaluation,
          управление анализом программ и их оценка
 PACT    Pay Actual Computer Time,
         оплата за фактически использованное время ЭВМ
 PAD     1. Packet Assembler/Disassembler, устройство сборки/разборки пакетов
          ( применяется в сети X.25 для обслуживания асинхронных терминалов)
         2. packet assembly and disassembly,
          формирование и декомпозиция пакетов
 PAL     Phase Alternation(ing) Line, ПАЛ ( система цветного телевидения, раз-
         работанная в Германии; европейский стандарт, принятый во всем мире,
         кроме Франции и бывшего СССР )
 PAM     1. personal application manager, администратор приложений для ПК;
         2. Port-Assignment Module, модуль назначения портов
 PAMA    Preassigned multiple access,
         множественный доступ с жестким закреплением каналов
 PAP     1. Password Authentication Protocol,
          протокол аутентификации по паролю;
         2. printer access protocol, протокол доступа к принтеру ( обеспечи-
          вает передачу данных в сети между рабочими станциями и принтерами
          общего пользования )
 PAR     Positive acknowledgement and retransmission,
         подтверждение приема с повторной передачей
 PARIS   Packetized Automatic Routing Integrated System, интегрированная сис-
         тема автоматизированной маршрутизации пакетов ( разработана фирмой
         IBM )
 PARISS  Project, Accounting, and Resource Information Support System, система
         поддержки планирования, бухгалтерского учета и информации о ресурсах
 PAX     private automatic exchange, учрежденческая АТС без исходящей и входя-
         щей связи ( с городом )
 PBX     Private branch exchange, учрежденческая телефонная станция с исходя-
         щей и входящей связью ( с городом )
 PC      Personal Computer, персональный компьютер, ПК
 PCB     Printed circuit board, печатная плата
 PCI     Peripheral Component Interface ( Interconnect ), интерфейс периферий-
         ных устройств ( стандарт локальной шины, предложенный фирмой Intel;
         позволяет подключать быстродействующие периферийные устройства непос-
         редственно к процессору в обход шины ввода/вывода )
 PCL     Printer Control Language, язык управления принтерами ( предложен фир-
         мой Hewlett-Packard для управления лазерными принтерами )
 PCM     plug-compatible manufacturer,
         производитель плат, совместимых по разъему
 PCMCIA  Personal Computer Memory Card International Association,
         a) Международная ассоциация производителей плат памяти для персональ-
          ных компьютеров
         б) одноименный стандарт на средства расширения портативных ПК
 PCMIM   Personal Computer Media Interface Module,
         сетевой интерфейсный модуль ПК
 PCN     1. personal communications network, сеть личной связи;
         2. personal computer network, сеть персональных компьютеров
 PCS     1. personal communications services, обслуживание личной связи;
         2. personal communication system, персональная система связи;
         3. Personal Conferencing Specification, спецификация видеоконференц-
          связи между ПК ( с передачей голоса, видео и цифровых данных; пред-
          ложена фирмой Intel )
 PCSA    Personal Computing System Architecture,
         архитектура персональных вычислительных систем
 PCTE    Portable Common Tools Environment,
         переносимая универсальная инструментальная среда
 PCWG    Personal Conferencing Work Group, Рабочая группа по видеоконференц-
         связи между ПК ( включающая компании Compaq  Computer, Lotus Develop-
         ment и Novell и поддерживаемая AT&T и Intel )
 PDA     Personal  Digital  Assistant, персональный цифровой ассистент, элект-
         ронный секретарь ( тип портативного компьютера )
 PDB     protocol data block, протокольный блок данных
 PDC     primary domain controller, первичный контроллер домена ( сервер, об-
         служивающий определенный участок сети )
 PDF     Portable Document Format, формат переносимого документа ( формат фай-
         лов электронных документов, разработанный фирмой Adobe и применяемый
         в настольных издательских системах )
 PDL     1. Page Description Language, язык описания страниц;
         2. Printer Description Language, язык описания принтеров
 PDN     public data network, сеть передачи данных общего пользования
 PDO     Portable Distributed Object, переносимый распределенный объект
 PDP     plasma display panel,
         газоразрядная индикаторная панель, плазменный дисплей
 PDQ     Parallel Data Query, параллельный запрос данных
 PDS     program development system, система разработки программ
 PDT     portable data terminal, переносной терминал для обмена данными
 PDU     protocol data unit, протокольный блок данных ( содержит управляющую
         информацию протокола )
 PEM     Privacy Enhanced Mail, почта повышенной секретности ( стандартные
         протоколы для поддержки аутентификации, конфиденциальности и защиты
         от злонамеренного искажения информации при выполнении электронных
         коммерческих транзакций )
 PEP     Packet Encoding Protocol, протокол пакетного кодирования ( предложен
         фирмой Telebit )
 PERM    Pre-Embossed Rigid Magnetic, предварительно размеченный магнитный но-
         ситель ( технология сравнительно дешевых и емких НМД, где методом
         травления нанесены все служебные дорожки; предложена фирмами Seagate
         Technology и Sony )
 PG      presentation graphics, презентационная графика
 PGA     1. pin grid array, корпус ИС с матрицей штырьковых выводов;
         2. professional graphic adapter, профессиональный графический адап-
           тер ( семейства IBM PS/2 )
 PGP     Pretty Good Privacy, "надежная конфиденциальность" ( алгоритм шифро-
         вания с общедоступным и личным ключами )
 PIC     Picture Image Compression, сжатие неподвижных изображений ( формат
         графических файлов )
 PIF     program information file, файл информации о программе
 PIM     Personal Information Manager, персональный информационный менеджер
         ( программа организации распорядка дня )
 PIN     personal identification number, личный идентификационный номер
 PIR     protocol independent routing, маршрутизация, независимая от протоко-
         ла ( алгоритм маршрутизации, предложенный фирмой CrossComm )
 PIS     personal information system, персональная информационная система
 PJL     Printer Job Language, язык заданий вывода на печать ( предложен фир-
         мой Hewlett-Packard )
 PKCS    Public Key Cryptography Standard, криптографический стандарт с общим
         ключом ( предшественник стандарта PEM )
 PL      programming language, язык программирования
 PL\1    Programming Language/1, ПЛ/1 ( язык программирования, разработанный
         фирмой IBM для ЭВМ серии IBM/360 и сочетающий черты языков КОБОЛ,
         ФОРТРАН и АЛГОЛ )
 PLA     programmable logic array, программируемая логическая матрица
 PLB     Picture Level Benchmark, эталонный тест уровня изображения ( разра-
          ботка NCGA )
 PLC     1. Polycenter Licensing System, распределенная система лицензирования
         ( технология контроля за соблюдением лицензионных соглашений об ис-
          пользовании прикладных программ в сети);
         2. programmable logic controller, программируемый контроллер
 PLM     Programming Language for Microprocessors, язык программирования для
         микропроцессоров ( разработан фирмой Intel на базе языка PL/1 )
 PLP     presentation level protocol, протокол уровня представления данных ( в
         модели OSI)
 PLV     Production Level Video, a) видео промышленного уровня ( характеристи-
         ка качества видеоизображения)
         б) одноименный алгоритм сжатия изображений
 PMA     Physical Medium Attachment,
         подсоединение к физической среде ( передачи данных )
 PMD     Physical Medium Dependent,
         зависимый от физического носителя ( сетевой уровень )
 PMF     Parameter Management Frame, фрейм управления параметрами
 PMP     Parallel MultiProcessing, параллельная мультипроцессорная обработка
 PMT     photomultiplier tube, фотоэлектронный умножитель ( устройство, приме-
         няемое в датчиках сканеров )
 PMU     power management unit, блок управления электропитанием
 PNNI    (P-NNI) Private Network-to-Network Interface, интерфейс связи между
         частными сетями ( спецификация, предложенная консорциумом ATM Forum
         и описывающая взаимодействие коммутаторов в частных сетях ATM )
 PNP     Plug-and-Play, "подсоединяй и работай" ( стандарт автоматической
         настройки конфигурации )
 POL     problem-oriented language,
         проблемно-ориентированный язык ( программирования )
 POP     1. point of presence, а) месторасположение, б) местное отделение;
         2. Post Office Protocol, почтовый протокол ( для связи конечного
          пользователя с сервером доступа к сети Internet )
 POS     1. point-of-sale, а) кассовый автомат, б) торговый терминал;
         2. point-of-service, пункт обслуживания
 POSI    Portable Operating System Interface,
         переносимый интерфейс для операционных систем
 POSIX   Portable Operating Systems Interface, интерфейс переносимых операци-
         онных систем ( государственный стандарт США для обеспечения переноси-
         мости прикладных программ на разные платформы в среде Unix )
 POST    1. Procedure Of Self-Testing, процедура начального самотестирования;
         2. power-on self-test; самотестирование после включения питания
 POWER   Performance Optimization With Enhanced RISC, оптимизация производите-
         льности путем усовершенствования RISC-технологии ( архитектура вычис-
         лительных RISC-систем корпорации IBM )
 PPDS    Personal printer data stream,
         поток данных, направляемых на персональный принтер
 PPGA    Plastic Pin Grid Array,
         корпус для процессоров ( пластмассовый с матрицей выводов )
 PPL     Process-to-process linking, связь между процессами
 PPP     Point-to-Point Protocol, протокол двухточечной связи
 PPS     Pictures per second, (число) кадров в секунду
 PPSN    Public packet switching network,
         сеть общего пользования с коммутацией пакетов
 PQET    Print Quality Enhancement Technology,
         технология повышения качества печати
 PQO     Parallel Query Option,
         средство параллельной обработки запросов ( на языке SQL )
 PQS     Parallel Query Server, сервер параллельной обработки запросов
 PR      Pattern recognition, распознавание образов
 PRD     Primary Receive Device, первичное приемное устройство
 PREP    PowerPC Reference Platform, эталонная платформа PowerPC ( документ,
         разработанный IBM и Apple и определяющий совместимость с PowerPC)
 PRI     Primary rate interface,
         интерфейс передачи с базовой скоростью ( в линиях ISDN )
 PRMD    Private Management Domain, частный домен управляющей системы
         ( локальная административная единица в сети)
 PROM    Programmable read-only memory,
         программируемое постоянное запоминающее устройство, ППЗУ
 PS      1. packet switch, узел коммутации пакетов (в сети)
         2. power supply, источник питания
 PSB     Parallel system bus, параллельная системная шина
         ( разработана фирмой Intel, стандарт IEEE )
 PSC     packet switching center, центр коммутации пакетов
 PSDN    1. packet switched data network, сеть с коммутацией пакетов данных
         2. public switched data network,
          коммутационная сеть передачи данных общего пользования
 PSE     Packet switching exchange, пункт коммутации пакетов
 PSF     Permanent swap file, постоянно подкачиваемый файл
 PSN     1. packet switching network, сеть с коммутацией пакетов
         2. packet switch node, узел коммутации пакетов
 PSNL    Packet switching network line, канал сети с коммутацией пакетов
 PSP     Personal Software Products,
         программное обеспечение для персональных компьютеров
 PSS     1. Physical Signaling Sublayer,
          физический подуровень передачи сигналов;
         2. Product Support Services,
          служба сопровождения (программных) продуктов
 PSTN    public switched telephone network,
         коммутируемая телефонная сеть общего пользования
 PSU     1. packet switching unit, коммутатор пакетов;
         2. power supply unit, блок питания
 PTC     packet transmission channel, канал передачи пакетов
 PTF     Program Temporary Fixes, временные исправления в программе
 PTM     packet transfer mode, режим пакетной передачи
 PTS     Parallel Transaction Server, сервер параллельной обработки транзакций
 PTT     post, telegraph, telephone,
         предприятие почтовой, телеграфной и телефонной связи
 PU      physical unit, физический блок
 PVC     1. permanent virtual circuit (channel), постоянный виртуальный канал
         2. permanent virtual connection, постоянное виртуальное соединение
 PWC     power connector, разъем питания
 PWI     Public Windows Interface, интерфейс Windows общего пользования
Q
 QAM     Queued access method, метод доступа с организацией очереди
 QAS     question answer(ing) system, вопросно-ответная система ( интеллекту-
         альная база данных с доступом на естественном языке )
 QBE     Query by Example, запрос по образцу
 QBF     Query by Form, запрос через форму
 QBM     Query by Model, запрос по модели
 QC      quality control, контроль качества
 QCIF    Quarter CIF, квартетный формат CIF
 QFA     Quick File Access, ускоренный доступ к файлу
 QFP     quad flat package, плоский корпус (интегральной схемы) с четырехсто-
         ронним расположением выводов
 QIC     quarter-inch cartridge, а) 1/4-дюймовый картридж б) одноименный коми-
         тет по стандартизации 1/4-дюймовых стриммеров и магнитных лент
 QICDS   Quarter-Inch Cartridge Drive Standard,
         стандарт на 1/4-дюймовые стриммеры и магнитные ленты
 QISAM   queued indexed sequential access method,
         индексно-последовательный метод доступа с очередями
 QOS     quality of service, качество обслуживания
 QRAAM   Quality, Reliability Assurance and Maintainability,
         гарантия качества, надежности и ремонтопригодности
 QSAM    queued sequential access method,
         последовательный метод доступа с очередями
 QTAM    queued telecomminications access method,
         телекоммуникационный метод доступа с очередями
R
 RACF    Resource Access Control Facility, средства управления доступом к ре-
         сурсам ( система защиты данных в хост-машинах фирмы IBM )
 RAD     Rapid Application Development,
         быстрая разработка приложений (технология)
 RADIUS  Remote Authentication Dial In User Service, служба удаленной аутенти-
         фикации пользователей по телефонным линиям ( стандарт на защиту дан-
         ных при дистанционном доступе; предложен фирмой Livingston
         Enterprises )
 RAI     Remote Application Interface,
         интерфейс дистанционной работы с приложениями (фирмы Sun)
 RAID    Redundant Array of Inexpensive Drives (Disks), матрица недорогих дис-
         ковых накопителей с избыточностью ( тип дисковой памяти с резервиро-
         ванием и дублированием данных )
 RAM     Random-Access Memory,
         память с произвольной выборкой, ЗУПВ, оперативная память
 RAMPS   Remote Access MultiPort Server,
         многопортовый сервер дистанционного доступа
 RAN     Regional area network, региональная ( зональная ) сеть ( объединяющая
         несколько локальных сетей )
 RARE    Reseaux Associes pour la Recherche Europeenne, Европейская ассоциация
         сетевых организаций ( выполняет функции, аналогичные IETF )
 RARP    Reverse Address Resolution Protocol,
         протокол определения обратного адреса
 RAS     1. Reliability, Availability and Serviceability,
          надежность, работоспособность и удобство эксплуатации (аппаратуры)
         2. Remote Access Server, сервер дистанционного доступа
         3. Remote Access Service, служба дистанционного доступа ( разработана
           фирмой Microsoft )
 RBCS    Remote Bar Coding System,
         дистанционно-управляемая система штрихового кода
 RBHC    Regional Bell holding company, региональная холдинговая компания Bell
 RBOC    Regional Bell operating company, региональная телефонная компания Bell
         ( каждая из семи частей Bell Telephone System, принадлежавшей AT&T и
         разделенной по решению суда на независимые телефонные компании, иног-
         да называемые "Baby Bell")
 RC      Remote control, дистанционное управление
 RCL     Radio Communications Link, линия радиосвязи
 RCS     1. remote control software, программа дистанционного управления;
         2. Revision Control System,
          система контроля за новыми редакциями ( документов )
 RDA     Remote Database Access,
         дистанционный доступ к базам данных (спецификация фирмы IBM)
 RDB     Relational database, реляционная база данных
 RDBMS   Relational database management system,
         система управления реляционными базами данных
 RDD     Replaceable Database Driver, сменный драйвер базы данных
 RDM     Relational Document Manager,
         реляционная программа управления документами
 RDS     Radio Data Standard, (международный) стандарт радиоданных
 RER     Residual error ratio, коэффициент необнаруженных ошибок
 RET     1. Reality Emulation Technology,
          технология эмуляции действительности;
         2. Resolution Enhancing Technology, технология повышения разрешения
          ( предложена фирмой Hewlett-Packard11 )
 REX     Remote Execution Service, служба удаленного исполнения ( элемент ONC,
         обеспечивающий доступ к вычислительным средствам, отсутствующим на
         ЭВМ клиента )
 RFC     Request for comments, запрос на комментарии и предложения (документ,
         в котором публикуются первоначальные варианты спецификаций при разра-
         ботке сандартов )
 RFI     Request for information, запрос информации
 RGB     Red-Green-Blue, красный-зеленый-синий (система цветопередачи)
 RIF     Routing Information Field, поле информации о маршруте
 RIFF    Resource Interchange File Format, формат файла взаимодействия ресур-
         сов ( содержит семейство форматов аудиофайлов ( WAVE, RDIB, RMID ),
         файлов изображений ( DIB, WMF, PAL ), мультимедиа (MMM) и текстовых
         файлов (RTF); имеет специальный заголовок, определяющий формат данных
         и идентифицирующий тип файла)
 RIO     Rasterized image output, вывод изображения в виде растра
 RIP     1. Raster Image Processor,
          процессор для обработки растровых изображений
         2. Routing Information Protocol,
          протокол обмена информацией о маршрутизации
 RIPE    Reseaux IP Europeenne, Организация европейских поставщиков услуг в
         сети Internet ( в составе RARE )
 RISC    Reduced Instruction Set Computer, ЭВМ с сокращенным набором команд
 RIT     Rate of information transfer, скорость передачи информации
 RJE     Remote Job Entry, дистанционный ввод заданий
 RLE     Run-length encoding, групповое кодирование ( алгоритм сжатия последо-
         вательности одинаковых символов, используемый, в частности, в растро-
         вой графике )
 RLL     Run-length-limited,( кодирование ) с ограничением расстояния ( между
         переходами намагниченности; метод записи на магнитный диск )
 RLN     Remote LAN Node, удаленный узел локальной сети
 RMON    Remote Monitoring, а) дистанционное управление ( дистанционный сбор
         административной информации, помещаемой в MIB ) б) одноименный стан-
         дарт для среды дистанционного контроля сети (часть SNMP)
 RMP     Remote maintenance processor, процессор дистанционного обслуживания
 RMS     Record Management Services, служба управления записями
 RNC     1. Remote NetWare Control, дистанционное управление в среде NetWare;
         2. remote network controller, дистанционный сетевой контроллер
 RNG     Random number generator, генератор случайных чисел
 ROM     Read-only memory, постоянное запоминающее устройство, ПЗУ
 RPC     Remote Procedure Call, дистанционный вызов процедур ( сетевого адми-
         нистрирования в ONC и DCE )
 RPG     Report program generator,
         генератор отчетов ( по результатам анализа данных )
 RPL     Remote Program Load, дистанционная загрузка программ
 RPM     Rotations per minute, (число) оборотов в минуту
 RQBE    Relational query by example, реляционный запрос по образцу
 RQS     Recoverable Queuing Service,
         обслуживание очередей (транзакций) с восстановлением при отказах
 RSA     Rivest-Shamir-Adleman,
         алгоритм цифровой подписи (сигнатуры) Ривеста-Шамира-Адлемана
 RSN     Release sequence number, порядковый номер версии
 RTAM    Remote terminal access method, дистанционный терминальный метод дос-
         тупа ( с использованием удаленных терминалов )
 RTC     Remote terminal concentrator, концентратор удаленных терминалов
 RTCA    Real Time Computing Association,
         Ассоциация по вычислениям в реальном времени (США)
 RTF     Rich Text Format, усовершенствованный текстовый формат ( формат обме-
         на текстовыми документами, разработанный фирмой Microsoft )
 RTMP    Routing Table Maintenance Protocol,
         протокол поддержания таблицы маршрутизации
 RTOM    Real-Time Object Manager,
         система управления объектами в реальном времени
 RTOS    Real-Time Operating System, операционная система реального времени
 RTP     1. Rapid Transport Protocol,
          протокол ускоренной передачи данных ( составная часть HPR )
         2. Real-Time Protocol, протокол реального времени
 RTR     Real-Time Restoration, восстановление в реальном времени
 RTR\CTS Request To Send/Clear To Send,
         запрос/подтверждение готовности (режим при модемной передаче)
 RTV     Realtime Video, видео в реальном времени ( стандарт воспроизведения
         видеофрагментов на ПК и соответствующая характеристика качества ви-
         деоизображения )
 RV      Remote Viewing, дистанционная визуализация
 RV&M    Remote Viewing and Manipulation,
         дистанционные выбор кадра и манипулирование им
 R/W     Read/write, чтение/запись
S
 SAA     Systems Application Architecture, архитектура системных приложений
         ( предложена фирмой IBM для соединения различных платформ в сети;
         представляет собой набор программных интерфейсов, условных обозначе-
         ний, соглашений и протоколов, обеспечивающий разработку согласованных
         приложений в различных вычислительных средах; охватывает CPI, CUA,
         CCS и CA, является дальнейшим развитием SNA )
 SAF     Service access facility, средства доступа к сервису ( общий язык дос-
         тупа в операционной системе Unix SVR4.2 )
 SAFE    Secure Access Facility for Enterprise,
         средства доступа к защищенным данным в сети масштаба предприятия
 SAG     SQL Access Group,
         Группа по средствам доступа с использованием языка SQL
 SAL     SQL Application Language, язык описания приложений SQL
 SAM     1. Secure Access Management, управление защищенным доступом;
         2. sequential access method, последовательный метод доступа;
         3. System Administrator Means,
          инструментальные средства системного администратора
 SAP     Service Advertising Protocol, протокол рекламного (сетевого) сервиса
 SAR     Segmentation and reassembly,
         декомпозиция и повторное объединение (ячеек данных в сетях ATM)
 SAS     Single attachment station,
         станция с единственным подключением (к сети)
 SBA     1. Software Business Association, Ассоциация разработчиков программ;
         2. standards-based architecture,
          архитектура, основанная на стандартах
 SBC     Single-board computer, одноплатный компьютер
 SCA     System Communication Architecture, архитектура системной связи
 SCC     Switching control center, центр управления коммутацией
 SCCS    Source Code Control System, система контроля за исходным кодом
 SCI     Single channel interface, одноканальный интерфейс
 SCM     Software configuration management,
         управление конфигурацией программного обеспечения
 SCP     Signal control point, пункт контроля сигналов
 SCPC    Single channel per carrier, один канал на несущую
 SCS     Structured cabling system, структурированная кабельная система
 SCSA    Signal Computing System Architecture,
         архитектура вычислительных систем по обработке сигналов
 SCSI    Small Computer System Interface,
         интерфейс малых вычислительных систем (стандарт)
 SD      Single density, одинарная плотность (записи данных)
 SDAM    Scheduling delay access mechanism,
         механизм доступа с планированием задержки
 SDB     Shareable database, база данных коллективного пользования
 SDBMS   Specialized database management system,
         система управления специализированной базой данных
 SDC     Synchronous Data Compression,
         сжатие синхронных потоков данных (технология фирмы Motorola)
 SDDI    Schielded Distributed Data Interface,
         распределенный интерфейс передачи данных по экранированной витой паре
 SDE     Software development environment, среда разработки программ
 SDF     1. space delimited format, формат с разделителями-пробелами;
         2. Structured Directory Format, структурированный формат каталога
          ( в операционной системе HP-UX )
 SDIF    Sony Digital Interface Format, формат цифрового интерфейса фирмы Sony
 SDK     1. Software Development ( Developer ) Kit, набор инструментальных
          средств ( пакет ) разработки программ ( первоначально - название
          продукта фирмы Microsoft для разработки ПО в среде Windows);
         2. System Development Kit,
          набор инструментальных средств разработки систем
 SDLC    Synchronous Data Link Control, синхронное управление передачей данных
         ( стандартный сетевой протокол управления последовательной передачей
         данных, разработанный фирмой IBM )
 SDM     SNA Datastream Management,
         управление информационными потоками в среде SNA
 SDMA    Space-division multiple access,
         множественный доступ с пространственным разделением каналов
 SDN     Software Defined Network,
         программно определяемая сеть ( технология виртуальных сетей )
 SDP     Software Development Package, пакет для разработки программ
 SDS     1. Screen Designing System,
          система проектирования экранного интерфейса;
         2. Spatial Data System, система обработки географических данных
 SDTS    Spatial Data Transfer Standard,
         стандарт на передачу географических данных
 SDU     Service data unit, сервисный блок данных
 SE      Standard edition, стандартная редакция (версия программного продукта)
 SE-DED  Single error correction-double error detection,
         (код) с исправлением одиночных и обнаружением двойных ошибок
 SECAM   Sequential Color and Memory,
         СЕКАМ (система цветного телевидения, принятая во Франции, стандарт)
 SEE     Software Engineering Environment, среда разработки программ
 SEI     Software Engineering Institute,
         Институт по разработке программного обеспечения (США)
 SEIH    Stackable Ethernet intelligent hub,
         наращиваемый интеллектуальный концентратор сети Ethernet
 SERC    Safety Critical Systems Initiative,
         инициатива по надежным критическим (информационным) системам (США)
 SES     Smart Energy System, интеллектуальная система энергосбережения
 SF      Superframe, суперфрейм
 SFPS    Secure Fast Packet Switching, защищенная скоростная коммутация паке-
         тов ( технология фирмы Cabletron Systems, основанная на использовании
         интеллектуальных коммутаторов )
 SFS     Shared File Server, файл-сервер коллективного доступа
 SFT     1. Server Fault Tolerance, отказоустойчивость сервера;
         2. System Fault Tolerance, отказоустойчивость системы
 SGML    Standard Generalized (General) Markup Language,
         стандартный обобщенный язык описания документов
 SH      Stackable hub, наращиваемый концентратор
 SHA     Secure Hash Algorithm, защищенный алгоритм хэширования
 SHRC    Super High Resolution Card, плата сверхвысокой разрешающей способнос-
         ти ( видеоадаптер для систем автоматического проектирования и нас-
         тольных издательских систем )
 SIDF    System Independent Data Format, формат данных,независимый от системы
         ( стандартный способ представления информации файловых систем различ-
         ных ОС и платформ, используемый в сетевых программах резервного копи-
         рования на запоминающие устройства с последовательным доступом )
 SIF     Status Information Frame, фрейм информации о статусе
 SIG     Special Interest Group, специальная группа (конечных пользователей)
         по какой-либо проблеме ( в составе Ассоциации по вычислительной тех-
         нике США )
 SIM     Society for Information Management,
         Общество информационного управления
 SIMD    Single-Instruction, Multiple-Data, один поток команд и множество
         потоков данных ( архитектура параллельных систем )
 SIMM    Single-in-line Memory Module, модуль с однорядным расположением мик-
         росхем памяти
 SINC    Single-image network computing,
         единое представление сетевых вычислений
 SIP     Single in-line package,
         плоский корпус с однорядным расположением выводов
 SIPP    Simple Internet Protocol Plus, расширенный простой протокол IP
 SIR     1. serial infra-red, инфракрасное последовательное соединение;
         2. signal-to-interference ratio, отношение сигнал/шум
 SIU     Subscriber interface unit, абонентское устройство сопряжения
 SKU     Stock-keeping unit, карман для пачки бумаги (в принтере)
 SLAP    Serial Line Access Protocol,
         протокол доступа к последовательному каналу
 SLC     System life cycle, жизненный цикл системы
 SLED    Single Large Expensive Disk,
         дорогостоящий одиночный диск большой емкости
 SLIP    Serial Line Interface (Internet) Protocol,
         протокол последовательной межсетевой связи
 SLS     System-level software, системное программное обеспечение
 SLT     Subscriber line terminal, терминал абонентской линии
 SM      Smart Card, интеллектуальная карточка (содержащая микропроцессор)
 SMA     Systems Monitor Architecture, архитектура системного мониторинга
 SMB     Server Message Block,
         блок сообщений сервера (сетевой протокол фирмы Microsoft)
 SMC     1. small multiuser computer, малая многопользовательская ЭВМ;
         2. Standard Multiuser Computer, стандартная многопользовательская ЭВМ
 SMDL    Standard music description language,
         стандартный язык описания музыки
 SMDS    Switched Multimegabit Data Service, служба коммутируемой мультимега-
         битной передачи данных (набор спецификаций фирмы Bell Communications)
 SME     Storage Management Engine, механизм управления запоминающими устрой-
         ствами (составная часть стандарта SMS)
 SMF     Standard Messaging Format, стандартный формат (передачи) сообщений
 SMI     Structure of Management Information, структура управляющей информации
 SMIT    System Management Interface Tool,
         инструментальное средство интерфейса системного управления
 SMM     System management mode, режим системного управления
 SMP     1. Simple Management Protocol, упрощенный протокол управления;
         2. symmetrical multiple processor, симметричный мультипроцессор;
         3. Symmetrical Multiprocessing,
          симметричная мультипроцессорная обработка
 SMR     Specialized mobile radio,
         специальная радиосвязь с подвижными объектами
 SMS     1. Storage Management Services, служба управления запоминающими уст-
           ройствами ( стандартный набор API фирмы Novell для облегчения ре-
           зервного копирования);
         2. Storage Management System, система управления запоминающими уст-
           ройствами ( спецификация фирмы Novell );
         3. Systems Management Server, сервер системного управления ( техноло-
           гия управления настольным программным и апппаратным обеспечением в
           сетях клиент/сервер, разработанная фирмой Microsoft )
 SMT     Station Management, управление станциями
         ( протокол, входящий в спецификацию FDDI )
 SMTI    Systems Management Tools Initiative, инициатива по средствам систем-
         ного управления ( программа фирмы Oracle по сотрудничеству с основны-
         ми фирмами-поставщиками сетевого программного обеспечения, предназна-
         ченного для связи между различными СУБД и приложениями сетевого адми-
         нистрирования)
 SMTP    Simple Mail Transfer Protocol,
         упрощенный протокол электронной почты ( стандарт )
 SNA     System Network Architecture, системная сетевая архитектура
         ( предложена фирмой IBM; предшественница SAA )
 SNADS   Systems Network Architecture Distributed Services,
         распределенное обслуживание в среде SNA
 SNAP    1. Standard Network Access Protocol,
          стандартный протокол доступа к сети;
         2. Subnetwork Access Protocol,
          протокол доступа к подсетям ( в сети Internet )
 SNI     Subscriber-to-net interface, интерфейс абонент/сеть
 SNMP    Simple Network Management Protocol,
         упрощенный протокол управления сетью
 SOHO    Small office/home office, малый бизнес - домашний офис
 SOL     Spatial Object Library, библиотека географических объектов
 SOM     System Object Model, модель системных объектов ( механизм фирмы IBM,
         позволяющий устанавливать динамические связи между программными ком-
         понентами на одном или разных компьютерах и перемещать эти объекты в
         пределах документов и приложений )
 SONET   (SONet) Synchronous Optical Network, сеть синхронной оптической связи
         ( набор международных стандартов передачи сигналов по волоконно-опти-
         ческим сетям, предложенный фирмой AT&T )
 SONOC   Synchronous Optical Network Optical Carrier, сеть синхронной передачи
         с волоконно-оптическим носителем ( сеть фирмы AT&T )
 SOS     Secure operating system, операционная система с защитой информации
 SPA     Software Publishers Association,
         Ассоциация издателей программных продуктов
 SPANS   Simple Protocol for ATM-Network Signaling, упрощенный протокол пере-
         дачи сигналов в сетях ATM ( предложен фирмой Fore Systems для связи
         между коммутаторами различных производителей, некоторые его элементы
         включены в стандарт PNNI )
 SPARC   Scalable Processor Architecture, наращиваемая архитектура процессоров
         ( с изменяемой вычислительной мощностью; разработана фирмой Sun Mic-
         rosystems )
 SPC     Standard peripheral controller,
         контроллер стандартных периферийных устройств
 SPEC    System Performance Evaluation Cooperative, Группа по оценке системной
         производительности ( занимающаяся стандартизацией соответствующих
         тестов )
 SPGA    Staggered Pin Grid Array, плоский корпус с матрицей штырьковых выво-
         дов, расположенных в шахматном порядке
 SPI     1. Service Provider Interface, интерфейс поставщиков услуг;
         2. System Programming Interface,
           интерфейс системного программирования
 SPP     1. Scalable Parallel Processor, наращиваемый параллельный процессор;
         2. sequenced packet protocol, протокол последовательной передачи па-
           кетов ( предложен фирмой Xerox )
 SPX     Sequenced Packet Exchange, последовательный обмен пакетами ( усовер-
         шенствованный фирмой Novell протокол SPP; используется в NetWare )
 SQA     Software quality assurance,
         обеспечение качества программного обеспечения
 SQL     Structured Query Language, язык структурированных запросов
 SRAM    Static random access memory,
         статическое ЗУ с произвольной выборкой, СЗУПВ
 SRB     Source route bridging, мостовая передача с маршрутизацией от источни-
         ка ( протокол, предложенный фирмой IBM )
 SRF     Status Report Frame, кадр сообщения о состоянии
 SRM     System resources manager, администратор системных ресурсов
 SRP     Source routing protocol, протокол маршрутизации от источника
 SRS     Speech recognition system, система распознавания речи
 SS      Static switching, статическая коммутация
 SSAP    Source Service Access Point, точка доступа к обслуживанию источника
 SSB     Serial system bus, последовательная системная шина
 STARS   Software Technology for Adaptable Reliable Systems,методика разработ-
         ки программ для адаптируемых надежных систем ( программа ARPA )
 STC     Standard transmission code, стандартный код для передачи данных
 STDMA   Space-time division multiple access,
         множественный доступ с пространственно-временным разделением каналов
 STN     Switched telephone network, коммутируемая телефонная сеть
 STP     1. Shielded Twisted Pair, экранированная витая пара;
         2. Signal Transfer Point, пункт передачи сигнала (в сети)
 STR     Synchronous transmitter-receiver, синхронный приемопередатчик
 SUDS    Software Update and Distribution System (Service); система (служба)
         обновления и распространения программного обеспечения
 SUS     Speech-understanding system, система распознавания речи
 SVC     1. switched virtual circuit (channel);
          коммутируемый виртуальный канал;
         2. switched virtual connection, коммутируемое виртуальное соединение
 SVGA    SuperVGA, суперVGA ( супервидеографическая матрица; стандарт видеог-
         рафики, поддерживающий также режим VGA )
 SVHS    Super Video Home System, супер-VHS ( развитие стандарта VHS )
 SVID    System V Interface Definition, определение интерфейса System V (базо-
         вой версии Unix )
 SW      software, программное обеспечение, программные средства
 SWIFT   Society for Worldwide Interbank Financial Telecommunications,
         а) Международная межбанковская организация по валютным и финансовым
          расчетам по телексу;
         б) Международная межбанковская электронная система платежей, СВИФТ
 SWS     Structured wiring system, структурированная система ( жгутовой ) ка-
         бельной разводки
T
 TAB     Tape automated bonding, автоматизированное присоединение кристаллов
         к балочным выводам на ленточном носителе (тип корпуса ИС )
 TAC     1. Technical Advisory Council, Технический консультативный совет;
         2. technical assistance center, центр технической помощи
 TACS    Total Access Communication System, система связи с всеобщим доступом
         ( европейский вариант стандарта AMPS )
 TAPI    Telephony Application Programming Interface, интерфейс программиро-
         вания приложений телефонной связи ( стандарт, предложенный фирмами
         Microsoft и Intel; составная часть стандарта WOSA )
 TAS     Telephone Access Server, сервер телефонного доступа
 TAXI    Transparent Asynchronous Transmitter/Receiver Interface, "прозрачный"
         асинхронный интерфейс приема/передачи ( используется в сетях ATM )
 TB      Terabyte, терабайт - 240 или несколько более 1012 байтов, единица из-
         мерения емкости памяти или объема передаваемой, хранимой, обрабатыва-
         емой информации )
 Tbps    Terabit per second, терабит в секунду (Тбит/с) - 240 или несколько
         более 1012 битов в секунду, единица измерения пропускной способности
         линии/канала связи, сети или устройства передачи данных )
 TBT     Technology-based training, обучение с применением технических средств
 TCAM    Telecommunication access method, телекоммуникационный метод доступа
 TCP     1. Tape Carrier Package, корпус (ИС) на ленточном носителе;
         2. Transmission Control Protocol,
          протокол управления передачей ( данных )
 TCP/IP  Transmission Control Protocol/Internet Protocol, протокол управления
         передачей/межсетевой протокол ( стандарт, используемый в качестве
         протокола сетевого и транспортного уровня в Internet )
 TCSEC   Trusted Computer System Evaluation Criteria, критерии оценки пригод-
         ности компьютерных систем ( стандарт Министерства обороны США на ха-
         рактеристики системы для обработки важнейшей информации; используется
         NCSC для включения включения в список EPL )
 TDDL    Time-division data link, канал передачи данных с разделением времени
 TDM     Time-division multiplexing, мультиплексирование с разделением времени
         ( временным уплотнением каналов )
 TDMA    Time Division Multiple Access, множественный доступ с разделением
         времени ( временным уплотнением каналов )
 TDS     Time-division switching, коммутация с разделением времени ( временным
         уплотнением каналов )
 TERN    Telecommunications Education Research Network, научно-образовательная
         телекоммуникационная сеть ( связывающая между собой университеты США)
 TES     Terminal Emulation Service, служба эмуляции терминалов
 TFLOPS  TeraFLOPS, триллион FLOPS, терафлопс, Тфлопс ( единица измерения
         быстродействия ЭВМ )
 TFPC    Trouble-free personal computing, безотказные вычисления на персональ-
         ных компьютерах
 TFT     Thin-film transistor, тонкопленочный транзистор
 TFT     LCD thin-film transistor liquid-crystal display,
         жидкокристаллический дисплей на тонкопленочных транзисторах
 TFTP    Trivial File Transfer Protocol, простейший протокол передачи файлов
         (см. тж. FTP)
 TIAT    Transport Independent AppleTalk, транспортно-независимый ( протокол
         среды ) AppleTalk
 TIFF    Tagged Image File Format, формат файлов изображений, снабженных мет-
         ками, теговый формат графических файлов ( формат растровой графики,
         разработанный фирмой Microsoft и обеспечивающий связь между различны-
         ми аппаратными платформами; используется, в частности, в сканирующих
         устройствах; промышленный стандарт хранения изображения в виде упако-
         ванных полей )
 TIGA    Texas Instruments Graphics Architecture,
         графическая архитектура фирмы Texas Instruments
 TIGER   Topologically Integrated Geographic Encoding and Referencing,
         топологически интегрированное географическое кодирование и стандарти-
         зация ( стандарт представления географических данных )
 TIGERS  Topologically Integrated Geographic Encoding and Referencing System,
         топологически интегрированная географическая справочная система с
         шифрованием изображений
 TIMS    Transmission impairment measurement set,
         набор средств измерения искажений при передаче
 TISC    Tool Interface Standards Committee,
         Комитет по стандартам на интерфейсы инструментальных средств
 TIU     Transceiver/interface unit, блок приемо-передачи/интерфейса
         ( конечного пользователя )
 TLI     Transport Layer Interface, интерфейс транспортного уровня ( обеспечи-
         вает в среде Unix System V совместимость NFS с различными транспорт-
         ными протоколами )
 TLU     Table look-up, табличный поиск
 TMDE    Test, measurement and diagnostic equipment, контрольно-измерительная
         и диагностическая аппаратура
 TME     Tivoli Management Environment, среда администрирования фирмы Tivoli
         ( объектно-ориентированная система администрирования, предназначенная
         для управления сетевыми устройствами, базами данных и приложениями )
 TMN     Telecommunications Management Network, сеть управления телекоммуни-
         кациями ( платформа фирмы IBM, использующая CMIP )
 TMS     1. Telephony Messaging Services,
          служба передачи сообщений по телефонным линиям;
         2. Traffic Management System, система управления трафиком
 TNI     Trusted Network Interpretation, интерпретация надежной сети
 TNN     Transport Network Node, транспортный узел сети, асинхронный коммута-
         тор ( разработанный фирмой IBM )
 TNT     Telecommunications Network Telnet, телекоммуникационная сеть Telnet
         ( протокол семейства TCP/IP; один из трех основных протоколов сети
         Internet, обеспечивающий дистанционный доступ к хост-системам )
 TOP     Technical and Office Protocols, технические и служебные протоколы
         ( применяемые внутри телефонной станции )
 TP      1. transaction processing, обработка транзакций;
         2. transport protocol, транспортный протокол;
         3. twisted pair, витая пара
 TP-FDDI Twisted Pair-FDDI, (экранированная) витая пара-FDDI ( стандарт, поз-
         воляющий использовать интерфейс FDDI для передачи данных по кабельным
         линиям )
 TP-PMD  Twisted Pair-Physical Medium Dependent, витая пара, зависящая от фи-
         зической среды ( стандарт, позволяющий использовать интерфейс FDDI
         для передачи данных по кабельным линиям )
 TPC     Transaction Processing Council, а) Совет по обработке транзакций;
         б) одноименный набор стандартов для тестирования СУБД
 TPI     Tracks per inch, (число) дорожек на дюйм
 TPL     Technical patch library, библиотека технических "заплат" ( исправлен-
         ных частей исполняемого кода )
 TPS     Transactions per second, (число) транзакций в секунду
 TRN     Token Ring Network, ( локальная ) сеть с маркерным кольцом ( разрабо-
         тана и внедрена фирмой IBM )
 TRT     Token Rotation Time, время оборота маркера ( затрачиваемое в сети TRN
         на однократное прохождение маркера по логическому кольцу с учетом за-
         держки доступа к среде передачи )
 TSA     Technical Support Alliance,
         Объединение по техническому сопровождению
 TSAPI   Telephony services application programing interface, интерфейс прог-
         раммирования сервисных приложений телефонной связи ( предложен фирмой
         Novell )
 TSPI    Telephone Service Provider Interface, интерфейс поставщика телефонных
         услуг ( спецификация доступа приложений к любым типам коммутаторов
         телефонной связи )
 TSR     1. Terminate-and-stay-resident,
          "после выполнения остаться в памяти" ( тип резидентной программы);
         2. Time-Sharing Regime, режим разделения времени
 TSS     Telecommunication Standartization Sector,
         Сектор стандартизации телекоммуникаций ( бывш. CCITT )
 TTL     Transistor-transistor logic, транзисторно-транзисторная логика, ТТЛ
 TTRT    Target Token Rotation Time,
         контрольное время обращения маркера ( в сетях TRN )
 TTS     Text-to-speech, (преобразование) "текст-в-речь"
U
 UA      User agent, пользовательский агент ( программа, связывающая MTA с
         конечным пользователем электронной почты )
 UAE     1. unidentified application error,
          неидентифицированная ошибка в приложении;
         2. unrecoverable application error, неустранимая ошибка в приложении
 UART    Universal Asynchronous Receiver/Transmitter,
         универсальный асинхронный приемопередатчик
 UCA     Universal Communications Architecture,
         универсальная архитектура связи
 UCM     Universal Cable Module, универсальный кабельный модуль ( кабель со
         встроенными активными электронными элементами, предназначенный для
         двунаправленной связи между параллельными портами двух ПК; особенно
         полезен для типов портов EPP и ECP )
 UCR     Under Color Removal,
         удаление цвета низлежащего слоя ( удаление паразитных цветов )
 UCS     1. United Card Service,
          объединенная система обслуживания кредитных карточек;
         2. User Coordinate System, система координат пользователя
 UDC     User-defined command, команда, определяемая пользователем
 UDF     User-defined function, функция, определяемая пользователем
 UDM     Uniform Data Model, стандартная модель данных ( стандарт взаимодей-
         ствия библиотек многократно используемых программ )
 UDP     User Datagram Protocol, протокол передачи пользовательских дейтаграмм
 UDP/IP  User datagram protocol/Internet protocol,
         протокол пользовательских дейтаграмм/протокол Internet
 UDS     Universal Directory Services,
         универсальная служба каталогов ( разработана фирмой Novell )
 UFI     User-friendly interface, интерфейс, дружественный к пользователю
 UFO     User Familiar Objects, объекты,
         знакомые пользователю ( элемент архитектуры BOCA )
 ULANA   Unified LAN Architecture, унифицированная архитектура локальных сетей
 ULP     Upper Layer Protocol, протокол верхнего уровня
 UM      User module, пользовательский модуль
 UMA     1. Universal Measurement Architecture,
          универсальная архитектура для измерений;
         2. upper memory area, область верхней памяти
 UMB     Upper Memory Block, блок верхней памяти
 UME     UNI Management Entities, контролируемые UNI-объекты
 UMIG    Universal Messaging Interoperability Group,
         Группа по универсальному взаимодействию систем передачи сообщений
 UNC     Universal Naming Convention, соглашение об универсальных именах
 UNI     User(-to-)Network Interface, сетевой интерфейс пользователя ( специ-
         фикация, предложенная консорциумом ATM Forum и описывающая различные
         типы протоколов связи между коммутаторами разных производителей в се-
         тях ATM )
 UNMA    Unified Network Management Architecture,
         единая архитектура управления сетями ( компании AT&T )
 UPS     1. uninterruptible power supply,
          источник бесперебойного электропитания;
         2. Uninterruptible Power System,
          система бесперебойного электропитания
 URL     Uniform Resourse Locator,
         унифицированный указатель ресурсов ( в системе WWW )
 URPC    Universal Remote Procedure Call,
         универсальный дистанционный вызов процедур
 USART   Universal synchronous/asynchronous receiver/transmitter,
         универсальный синхронно-асинхронный приемопередатчик
 USBS    United States Bureau of Standards, Бюро стандартов США
 USS     United States Standard, стандарт США
 UTG     UnixWare Technology Group, Группа по технологии UnixWare (консорциум)
 UTP     Unshielded Twisted Pair, неэкранированная витая пара
 UUCP    1. Unix to Unix Copy Program, программа копирования Unix-Unix ( шлюз
          и утилита для доступа к сети Internet из почтовых пакетов локальных
          сетей);
         2. UNIX to UNIX CoPy, копирование UNIX-UNIX ( применяется в хост-ма-
          шинах под управлением операционной системы Unix для передачи файлов
          и дистанционного выполнения команд )
 UVEPROM Ultraviolet-erasable programmable read-only memory,
         программируемое ПЗУ с ультрафиолетовым стиранием информации
V
 VAC     Value-added carrier, а) высококачественная арендуемая линия связи;
         б) компания-владелец сети, предоставляющей дополнительные услуги
 VAD     1. value-added and data,
          сеть связи с дополнительными услугами по передаче данных;
         2. value-added distributor,
          дистрибутор, вносящий добавленную стоимость;
         3. Visual Application Designer,
          инструментарий визуальной разработки приложений
 VAFC    VESA Advanced Feature Connector, усовершенствованный разъем VESA
 VAN     Value-added network, сеть с дополнительными услугами
 VAR     Value-Added Reseller,
         торговый посредник (реселлер), вносящий добавленную стоимость
 VAT     Video Audio Teleconference, видео-аудио-телеконференция
 VATP    Vector Adaptive Transform Processing, адаптивное векторное преобразо-
         вание ( алгоритм уплотнения/разуплотнения, позволяющий передавать
         речь, видео и цифровые данные по единственной телефонной линии )
 VB      Visual Basic,
         "визуальный" Бейсик BASIC язык программирования фирмы Microsoft
 VBA     Visual Basic for Applications, Visual Basic для приложений (редакция
         языка Visual Basic фирмы Microsoft )
 VBR     Variable bit rate, переменная скорость передачи двоичных данных
 VC      1. virtual circuit, виртуальный канал;
         2. virtual connection, виртуальное соединение
 VCC     Virtual channel connection, соединение виртуальных каналов
 VCI     Virtual circuit identifier, идентификатор виртуального канала
 VCO     Virtual central office, виртуальный центральный офис
 VCPI    Virtual Control Program Interface, программный интерфейс виртуального
         управления ( разработан фирмами Quarterdeck и Phar Lap; предшествен-
         ник DPMI )
 VCS     Version check system, система контроля версий
 VDE     Video Data Elements, элементы видеоизображения
 VDI     1. Video Device Interface, интерфейс видеоустройств;
         2. virtual device interface, интерфейс виртуального устройства
          ( стандарт для асимметричных систем мультимедиа )
 VDM     Virtual DOS Machine, виртуальная машина DOS
 VDMA    Virtual direct memory access, виртуальный прямой доступ к памяти
         ( прямой доступ к памяти по виртуальному адресу в интерфейсе S-bus )
 VDS     Virus detection system, система обнаружения вирусов
 VDT     Visual display terminal, видеотерминал
 VESA    Video Electronics Standards (Suppliers) Association,
         а) Ассоциация по стандартам в области видеоэлектроники ( Ассоциация
          производителей средств видеоэлектроники);
         б) одноименный тип локальной шины ( в ПК с процессором фирмы Intel )
 VFAT    Virtual File Allocation Table,
         таблица размещения файлов виртуальной файловой системы
 VFS     Virtual file system, виртуальная файловая система
 VFW     Video For Windows, см. AVI
 VGA     Video Graphics Array, видеографическая матрица ( стандарт, разра-
         ботанный фирмой IBM для IBM PS/2, а также соответствующие адаптер и
         монитор )
 VHS     Video Home System, а) бытовое видео ( стандарт качества видеоизобра-
         жения для домашних видеомагнитофонов); б) бытовой видеомагнитофон
 VIM     Vendоr Independent Messaging, передача сообщений независимо от фирм-
         поставщиков ( интерфейс электронной почты фирмы Lotus )
 VIP     Video image processor,
         процессор видеоизображений ( специализированная микросхема )
 VIPS    Voice information processing server,
         сервер обработки речевой информации
 VIVID   Video, Voice, Image and Data,
         видео, речь, изображение и цифровые данные ( мультимедиа )
 VLAN    Virtual Local Area Network, виртуальная локальная сеть
 VLB     VESA Local Bus, локальная шина VESA
 VLIW    Very Long Instruction Word, "очень длинное командное слово", широкая
         команда (архитектура ЭВМ с системой команд сверхбольшой разрядности)
 VLM     Virtual Loadable Module, виртуальный загрузочный модуль
 VLSI    Very large-scale integration, а) интеграция сверхвысокого уровня;
         б) сверхбольшая интегральная схема, СБИС
 VM      Virtual machine, виртуальная машина
 VMC     Video Memory Controller, контроллер видеопамяти
 VME-bus Versabus Module Europe-bus, модульная интерфейсная система на евро-
         конструктивах ( стандарт, разработанный фирмой Motorola )
 VMM     1. Virtual Machine Manager, менеджер виртуальной машины;
         2. Virtual Memory Management, система управления виртуальной памятью
 VMS     1. VESA Media Channel, канал мультимедиа на шине VESA ( технология,
          предложенная фирмой VideoLogic; поддерживает такие методы сжатия,
          как MPEG);
         2. virtual memory system, система виртуальной памяти
 VMTP    Versatile Message Transaction Protocol,
         универсальный протокол обработки сообщений
 VNS     Virtual Notebook System, система виртуальных записных книжек ( систе-
         ма хранения и обработки документов в сети )
 VPDN    Virtual private data network,
         частная виртуальная сеть передачи данных
 VPI     Virtual path identifier, идентификатор виртуального пути
 VCI     см. VPI, VCI
 VPN     Virtual private network, виртуальная частная сеть
 VPT     Virtual Printer Technology, технология виртуальных принтеров
 VRAM    Video Random-Access Memory, видеоОЗУ, видеопамять
 VRS     Voice recognition system, система распознавания речи
 VSAM    Virtual storage access method,
         виртуальный метод доступа (к запоминающему устройству)
 VSU     Video Service Unit, блок обслуживания видеоустройства
 VT      Virtual terminal, виртуальный терминал
 VTAM    Virtual telecommunications access method,
         виртуальный телекоммуникационный метод доступа
 VTP     Virtual Terminal Protocol, протокол виртуального терминала
 VTS     Video Terminal Screen, экран видеотерминала
W
 WABI    Windows Application Binary Interface, двоичный интерфейс приложений
         среды Windows ( разработан фирмой Sun Microsystems и предназначен для
         обеспечения работы Windows-программ в среде Unix; составная часть
         COSE )
 WAC     Wide Area Connector, объединяющий блок для глобальной связи
 WAIS    Wide-Area Information Server, глобальный информационный сервер ( сис-
         тема, позволяющая вести поиск в базах данных по ключевым словам и
         уточнять запросы с помощью обратной связи )
 WAN     Wide-Area Network, глобальная территориальная сеть (охватывает район,
         штат, страну и т.п.)
 WAND    Wide-Area Network Distribution,
         распространение программ по глобальной сети
 WARC    World Administrative Radio Conference, Международная комиссия по рас-
         пределению радиочастот ( в мировом масштабе )
 WATS    1. wide-area telecommunications service,
          глобальная служба телекоммуникаций;
         2. wide-area telephone service, служба междугородной телефонной связи
 WCS     Weapons Control System, система управления оружием (тип джойстика)
 WFS     Workflow software, программное обеспечение автоматизации деловых про-
         цедур ( документооборота )
 WIN     1. Wireless Inbuilding Network, беспроводная сеть внутри здания ( ар-
          хитектура локальной сети фирмы Motorola );
         2. Wireless Information Network, беспроводная информационная сеть;
         3. Workstation Interface Node,
          узел взаимодействия с рабочими станциями
 WINS    1. Windows Integrated Name Server (Services);
          интегрированный(ая) сервер (служба) именования среды Windows;
         2. Windows Internet Naming System,
          система межсетевых адресов в среде Windows
 WISE    WordPerfect Information System Environment, среда информационных сис-
         тем фирмы WordPerfect ( в настоящее время - подразделение фирмы No-
         vell )
 WMF     Windows Metafile, метафайл среды Windows ( формат хранения графичес-
         кой информации в среде Windows )
 WN      Wireless network, беспроводная сеть, радиосеть
 WNIC    Wide-Area Network Interface Coprocessor,
         сопроцессор взаимодействия с глобальной сетью
 WORM    Write-Once/Read-Many, с однократной записью и многократным считывани-
         ем ( тип лазерного диска )
 WOS     Wireless office system, учрежденческая система радиосвязи
 WOSA    Windows Open Services Architecture,
         открытая архитектура служебных функций для среды Windows (стандарт)
 WP      1. word processing, обработка текстов;
         2. word processor, текстовый процессор ( программа редактирования
          текстов )
 WS      workstation, рабочая станция
 WWW     World-Wide Web, всемирная "паутина" ( сервисная глобальная гипертек-
         стовая система в сети Internet )
 WYDIWYS What You Do Is What You See, "что сделаешь, то и увидишь" ( принцип
         построения дружественного экранного интерфейса )
 WYSIWYG What You See Is What You Get, "что видишь, то и получишь" ( режим
         полного соответствия между изображением на экране и распечаткой )
X
 XAPIA   X.400 Application Program Interface Alliance, Ассоциация разработчи-
         ков интерфейсов прикладного программирования для сетей X.400
 XCOFF   Extended Common Object File Format,
         расширенный общий формат объектных файлов
 XDP     External Data Presentation, внешнее представление данных
 XDR     External Data Representation,
         внешнее представление данных (машинно-независимый стандарт в ONC)
 XDS     X/Open Directory Service, (глобальная) служба каталогов/именования,
         разработанная компанией X/Open
 XE      extended edition, расширенная редакция (версия программного продукта)
 XGA     Extended Graphics Adapter, адаптер расширенной графики
 XMM     extended memory manager, программа управления расширенной памятью
 XMS     1. extended memory specification, спецификация расширенной памяти;
         2. extended memory system, расширенная память
 XNA     Extended Network Architecture,
         расширенная архитектура сети ( предложена фирмой IBM )
 XNS     1. Xerox Network Services, сетевая служба Xerox ( многоуровневая сис-
          тема протоколов, разработанная фирмой Xerox и принятая Novell и дру-
          гими компаниями);
         2. Xerox Network Standard, сетевой стандарт фирмы Xerox
 XOR     exclusive OR, исключающее ИЛИ
Y
 Y/N     yes/no, да/нет
Z
 ZIF     Zero insertion force, с нулевым усилием сочленения (соединитель)
 ZIP     1. zigzag-in-line package, плоский корпус со штырьковыми выводами,
         расположенными зигзагообразно
         2. zip iomega, устройство резервного копирования 100Мб/250Мб

[ оглавление | начало | глоссарий ]