Основы работы в табличном процессоре Microsoft Excel 97

Содержание:

Запуск Excel 3
Выход из Excel 7.0_ 3
Экран Excel 3
Основное меню_ 3
Контекстное меню_ 3
Панели инструментов_ 3
Панель формул (строка формул) 4
Основные термины и обозначения в MS Excel. 4
Управление файлами_ 5
Управление рабочими листами_ 6
Добавление рабочих листов_ 6
Перемещение рабочих листов_ 6
Переименование рабочих листов_ 6
Коррекция высоты строк и ширины столбцов_ 6
Построение таблиц_ 6
Выделение ячеек_ 7
Отмена операций_ 7
Копирование данных 7
Удаление данных 7
Форматирование данных 7
Ссылки на ячейку или на группу ячеек_ 9
Относительные и абсолютные ссылки_ 9
Табличные вычисления_ 10
Редактирование формул_ 10
Мастер функций_ 10
Редактирование функций_ 11
Вычисление суммы_ 11
Массивы формул_ 11
Проверка вводимых в ячейку данных 12
Выбор вводимых данных из списка 12
Ограничение количества вводимых в ячейку символов_ 12
Определение правильности вводимых данных с помощью формулы_ 13
Поиск некорректных данных на листе 13
Группирование элементов таблицы_ 13
Разделение окон_ 13
Создание нового окна 14
Фиксация подокон_ 14
Присвоение имени ячейке, диапазону или формуле 14
Создание примечаний_ 14
Работа с базами данных 15
Сортировка данных 15
Формы данных 15
Установление диапазона критериев_ 16
Автофильтр 16
Расширенный фильтр 17
Текстовый режим индикации функций_ 18
Сообщения об ошибках 18
Построение и оформление диаграмм_ 18
Перемещение объектов диаграммы_ 19
Изменение данных посредством изменения графика. 19
Копирование данных из другого приложения Microsoft в Excel 20
Открытие документа, созданного в другом приложении_ 21
Печать документа 21
Предварительный просмотр 21
Установка параметров страницы_ 21

Основы работы в табличном процессоре Microsoft excel

При работе с большими объемами данных важную роль играет их наглядность. Поэтому часто данные представляют в виде таблиц. Данные в таблицах можно не только хранить, но и обрабатывать. Табличные вычисления можно производить с любыми данными, но особенно удобно это делать с числовыми данными. Благодаря наглядности намного упрощается проведение любых расчетов, использующих данные, хранящиеся в таблицах. Одно из самых популярных средств управления электронными таблицами – программа Microsoft Excel.

Запуск Excel

Запуск Excel можно осуществить используя меню:

Пуск – Программы – Microsoft Excel.

Удобнее запускать Excel , щелкнув по пиктограмме файла, с которым недавно работали:

Пуск → Документы → щелчок мышкой по пиктограмме файла, созданного пакетом Microsoft Excel.

Пункт Документы вызывает меню, в котором накапливается имена документов, открывавшихся и редактировавшихся пользователем при работе с Windows 98 (до 15 последних файлов).

Выход из Excel 7.0

Выход из Excel используя основное меню осуществляется так:

Файл → Выход

Иначе процесс выхода из Excel можно выполнить:

1. Щелкнуть на кнопке закрытия в верхнем правом углу окна Excel (или нажать комбинацию клавиш Alt+ F4).

2. Щелкнуть на кнопке Нет, чтобы повторно не сохранять файл. При этом вернемся на рабочий стол или в окно другого запущенного приложения.

3. Щелкнуть на кнопке Пуск и выбрать пункт Завершение работы.

4. Если необходимо завершить работу, то щелкнуть на кнопке Да и затем при появлении соответствующего сообщения выключить компьютер.

Экран Excel

Экран Excel содержит следующие основные компоненты:

- строка заголовка с кнопками управления окном программы и окном документа;

- строка основного меню;

- две панели инструментов Стандартная и Форматирования;

- строка формул и поле имени;

- рабочая область;

- полоса прокрутки;

- полоса перебора страниц рабочей книги;

- строка состояния.

Все программы, работающие под управлением системы Windows, имеют строку заголовка. В ней указывается имя программы, и здесь же находятся некоторые кнопки управления, которые можно использовать для изменения внешнего вида окна.

Кнопки управления окном программы и окном документа:

- свернуть в пиктограмму, кнопка минимизации;

- развернуть во весь экран, кнопка максимизации;

- вернуть окно в предыдущее состояние, кнопка восстановления;

- закрыть окно, кнопка закрытия;

- кнопка системного меню. Щелчок на этой кнопке откроет системное меню, позволяющее манипулировать окном Excel.

Основное меню

Каждый из пунктов меню объединяет набор команд, имеющих общую функциональную направленность. Щелчок на любом пункте меню разворачивает список команд выбранного пункта. Работа с меню – один из возможных способов задавать команды Excel.

Контекстное меню

В дополнение к основному меню, постоянно находящемуся на экране, Excel предлагает вторичную систему контекстного меню. Контекстные меню предоставляют возможность быстрого доступа к часто используемым для данного объекта в рассматриваемой ситуации командам.

При выполнении щелчка правой кнопкой мыши на пиктограмме, ячейке, выделенной группе ячеек или на встроенном объекте, возле указателя мыши открывается меню с основными функциями, применяемыми в данной ситуации – в контексте.

Команды, входящие в контекстное меню, всегда относятся к активному объекту.

Контекстное меню можно вызвать также с помощью комбинации клавиш Shift+F10.

Панели инструментов

Панели содержат наиболее часто используемые команды меню. После установки программы на экране присутствуют две панели инструментов: Стандартная и Форматирования. Excel включает много других панелей инструментов, которые можно вынести в рабочее окно программы.

В панели инструментов можно добавить новые пиктограммы, как входящие в программу, так и созданные самим пользователем.

При движении вдоль пиктограмм этих панелей указателем мыши, под каждой из них появляется имя инструмента в окне (орудие намеков).

1. Настройка панелей инструментов (пиктографических меню) предоставляет следующие возможности:

2. отображение на экране пиктографических меню;

3. добавление отдельных пиктограмм;

4. создание пользовательского пиктографического меню;

5. создание собственных пиктограмм пользователя и привязка к ним определенных действий.

Все операции по форматированию пиктографических меню выполняются в окне:

Вид → Панели инструментов

На экране будут отображены те пиктографические меню, около названия которых в окне списка панелей инструментов стоит галочка.

Панели инструментов объединяют функционально близкие пиктограммы: Стандартная – стандартные возможности системы (создание, загрузка, сохранение, печать рабочих папок и др.);

Форматирование – оформление ячеек таблицы;

Запрос и сводная – средства работы с базами данных таблицы;

Диаграмма – инструменты построения диаграмм;

Рисование – элементы схем и иллюстраций;

Мастер подсказок – подсказка, помогающая оптимизировать рабочие шаги пользователя;

Элементы управления – создание стандартных управляющих элементов (меню, кнопок, полос прокрутки …);

Запись макроса – закончить запись последовательности команд, которые автоматически преобразуют Excel в макрокоманду;

Зависимости – анализ связи между ячейками;

Коллективная работа – совместная работа с документами;

Visual Basic – инструменты создания и отладки пользовательских программ на встроенном языке Excel - Visual Basic;

Microsoft – вызов приложений Microsoft для работы в рамках механизма OLE.

Панель формул (строка формул)

Панель формул используется для ввода и редактирования значений или формул в ячейках или диаграммах, а также для отображения адреса текущей ячейки.

Поле имени указывает имя или адрес активной ячейки в текущей рабочей книге. Щелчок на стрелке раскроет список, в котором перечислены все поименованные ячейки и диапазоны активной рабочей книги.

Основные термины и обозначения в MS Excel.

Каждый документ представляет собой набор таблиц – рабочую книгу, которая состоит из одного или многих рабочих листов. Листы одной рабочей книги обычно связаны между собой тематически. В случае необходимости рабочая книга может содержать десятки и даже сотни рабочих листов. Каждый рабочий лист имеет название. Это как бы отдельная электронная таблица. Файлы Excel имеют расширение .xls. Каждая рабочая книга имеет собственное имя и хранится в отдельном файле на диске. По умолчанию новым рабочим книгам Excel дает имена Книга1, Книга2 и т. д. В Excel допускается работать с несколькими рабочими книгами одновременно, при этом каждая открывается в собственном окне. Активной, или текущей, может быть только одна из них.

Листы рабочей книги могут содержать прямоугольные таблицы данных («электронные таблицы»), одну или несколько диаграмм, а также внедренные или связанные объекты других приложений и так называемые «пользовательские элементы» интерфейса. Каждый лист имеет имя, которое выводится на ярлычке данного листа внизу слева. По умолчанию имена листов Лист1, Лист2 и т. д. Для переименования текущего листа можно выполнить команду Формат, Лист, Переименовать (или сделать двойной щелчок на ярлычке листа) и ввести новое непустое имя. Для перехода на нужный лист можно выполнить одно из следующих действий:

1) Щелкнуть ярлычок с именем данного листа (если он есть среди тех ярлычков, которые видны на экране).

2) Нажимать кнопки прокрутки ярлычков (левую или правую) до тех пор, пока не появиться имя искомого рабочего листа (и затем выполнить действия предыдущего пункта).

3) Нажимать клавиши <Ctrl>+<PgUp> или <Ctrl>+<PgDn> до тех пор, пока не появится имя нужного рабочего листа.

4) Щелкнуть правой кнопкой мыши в области кнопок прокрутки ярлычков, затем выбратьв контекстном меню имя требуемого листа.

Отдельный лист с диаграммой называется лист диаграмм, все прочие листы, т. е. листы с прямоугольными таблицами (на которых, в частности, могут быть расположены и диаграммы) – называются рабочими листами.

По умолчанию новая рабочая книга в Excel 2000 состоит из трех рабочих листов. Для изменения количества рабочих листов по умолчанию нужно выполнить команду Сервис, Параметры, Общие и изменить значение счетчика Листов в новой книге.

Расположенная на рабочем листе таблица состоит из прямоугольных ячеек. Каждая ячейка имеет адрес (используется также термин ссылка), обычно состоящий из латинской буквы, обозначающей столбец, в котором находится данная ячейка, и числа, задающего строку, которой ячейка принадлежит. Если нужно указать, что адрес не должен меняться при его возможном копировании, переносе и т. п., то он записывается с использованием знака «$» - например $A$1 или $B$5 – и называется абсолютным адресом или абсолютной ссылкой. Если не должен меняться только столбец или строка, то адрес записывается как $B5 или, соответственно, как B$5. Адрес без знака «$» называется относительным адресом или относительной ссылкой. Трудно сказать, как правильно называть адрес, который содержит только один зак «$», поскольку он является наполовину абсолютным, наполовину относительным. Иногда такой адрес называют смешанным.

Если надо задать адрес ячейки, которая находится на другом рабочем листе или в другой рабочей книге, перед адресом ячейки указывается название этого рабочего листа, а при необходимости и название рабочей книги, например, Лист1!В5 или [Пример1.xls]Лист1!$A$2. Обратите внимание, что после названия рабочего листа ставится восклицательный знак, а имя рабочей книги заключается в квадратные скобки.

Минимальное количество столбцов на рабочем листе – 256 (28), строк – 65536 (216).

Управление файлами

Рассмотрим процедуры обращения с рабочими документами. С помощью программы Excel можно создавать самые различные документы. Рабочие листы можно использовать для составления таблиц, вычисления статистических оценок, управления базой данных и составления диаграмм. Для каждого из этих приложений программа Excel может создать отдельный документ, который сохраняется на диске в виде файла.

Общий вид окна электронной таблицы MS Excel

Файл может содержать несколько взаимосвязанных рабочих листов, образующих единый трехмерный документ (блокнот, рабочую папку). С помощью трехмерных документов пользователь получает прямой доступ одновременно к нескольким таблицам и диаграммам что повышает эффективность их обработки.

Создание нового документа

Для создания нового документа из меню Файл нужно выбрать команду Создать. Excel сразу присваивает новым документам имя Книга с добавлением текущего порядкового номера.

Загрузка рабочего документа

Чтобы загрузить с диска расположенный там файл с рабочим документом, нужно вызвать команду Открыть из меню Файл.

Можно также щелкнуть мышью по соответствующей пиктограмме, которая находится на основной панели. В любом случае откроется диалоговое окно загрузки файла. В этом окне в поле нужно выбрать диск и директорию, где расположен искомый файл. Если щелкнуть по имени этого файла, оно появится в поле Имя файла. После этого нужно закрыть диалоговое окно, щелкнув мышью по кнопке Открыть или дважды щелкнув по имени искомого файла.

Сохранение документа

При первом сохранении документа необходимо вызвать из меню Файл команду Сохранить как. После этого откроется диалоговое окно, в котором нужно указать имя сохраняемого файла, а также диск и директорию, в которой его надо расположить. Программа «по умолчанию» предлагает стандартное имя (Книга[порядковый номер]), которое пользователь может заменить любым другим. После того как будут сделаны все установки, нужно закрыть диалоговое окно щелчком по кнопке Сохранить.

Защита данных

Для введения пароля необходимо вызвать команду Сохранить как из меню Файл. Затем нажмите кнопку Параметры. Введите пароль в поле Пароль для открытия файла:. При этом на экране вместо букв появляются звездочки.

При вводе пароля следует различать строчные и прописные буквы. Вводите пароль в точности так, как он должен будет вводиться пользователями, учитывая регистр букв.

Продублируйте пароль в поле Введите пароль еще раз: и нажмите кнопку OK.

Нажмите кнопку Сохранить.

При появлении диалогового окна нажмите кнопку Да, чтобы заменить существующую книгу текущей.

Если щелкнуть по кнопке Рекомендовать доступ только для чтения, то файл впоследствии можно будет только просматривать, но нельзя записать его на диск под тем же именем.

Структура документов

Рабочие документы могут содержать до 255 таблиц, диаграмм или VBA-программ в одном файле, а принцип работы с ними напоминает обычную работу с деловыми блокнотами в любом офисе. В каждом рабочем блокноте можно поместить всю деловую информацию, относящуюся к одной теме, и хранить ее в одном файле, что позволяет значительно повысить наглядность рабочих документов.

Управление рабочими листами

Отдельные рабочие листы одного документа расположены друг под другом. С помощью именного указателя, расположенного в нижней части экрана, можно переходить с одного листа на другой. На именном указателе находятся корешки рабочих листов, расположенные в порядке возрастания номеров: Лист1, Лист2 и т.д.

Щелчок мышью, например, по второму корешку вызывает появление рабочего листа Лист2. Корешок активного рабочего листа выделяется на именном указателе белым цветом. Сначала на указателе видны корешки первых трех рабочих листов. Слева от именного указателя расположены пиктограммы стрелок, с помощью которых можно изменять содержимое указателя, чтобы получить доступ к следующим листам документа.

Щелчок по пиктограмме с правой стрелкой сдвигает на единицу вправо диапазон (окно) видимости корешков рабочих листов. Щелчок по пиктограмме с левой стрелкой сдвигает этот диапазон на единицу влево. Стрелки с вертикальными штрихами позволяют перейти соответственно к первому и к последнему листам документа.

Добавление рабочих листов

Команды добавления расположены в меню Вставка. Пользователь может добавить в документ элементы следующих типов:

· рабочие листы для создания таблиц;

· диаграммы (в качестве элемента таблицы или на отдельном листе);

· рабочий лист для записи макрокоманды в виде программного модуля (с использованием макросов MS Excel 4.0 или международного языка макросов);

· рабочий лист для создания диалогового окна.

Новый лист всегда вставляется перед активным рабочим листом. Если лист предназначен для создания таблицы, то независимо от занимаемой позиции он будет иметь название Лист4 с последующим увеличением номера при добавлении новых таблиц.

Перемещение рабочих листов

Установите указатель мыши на корешке рабочего листа, который нужно переместить, и щелчком правой кнопки мыши откройте контекстное меню. С помощью команды Переместить/скопировать откройте диалоговое окно с тем же названием и укажите в нем новую позицию переставляемого листа. Закройте окно Переместить/скопировать щелчком по кнопке OK, и рабочий лист займет новую позицию. Если включить опциональную кнопку Создавать копию, то данный рабочий лист останется на прежней позиции, а новую позицию займет его копия. Название копии листа будет образовано путем добавления порядкового номера к имени копируемого листа, например, Лист1(2).

Можно переставить сразу несколько листов. Для этого промаркируйте эти листы, щелкнув по их именам в именном указателе при нажатой клавише Shift. Затем выполните команду Переместить/скопировать, которая в этом случае будет применяться сразу ко всем маркированным рабочим листам.

Переместить рабочий лист (листы) можно также перетаскиванием их мышью в нужное место.

Переименование рабочих листов

Установите указатель мыши на корешке рабочего листа, который нужно переименовать, и щелкните правой кнопкой мыши. Откроется контекстное меню, в котором с помощью команды Переименовать можно перейти непосредственно на имя рабочего листа и изменить его. Туда можно попасть, используя двойной щелчок левой кнопки мыши по названию рабочего листа. В этом поле укажите новое имя листа, которое должно содержать не более 31 символа, включая пробелы. После ввода имени нажмите клавишу мыши, установив ее указатель в любом другом месте, и на именном указателе появится новое имя рабочего листа. При задании имен рабочих листов не должны использоваться следующие символы: квадратные скобки "[ ]"; двоеточие ":"; косая черта "/"; обратная косая черта "\".

Коррекция высоты строк и ширины столбцов

Прежде всего, корректируемая строка или столбец таблицы должны быть выделены. Для этого необходимо щелкнуть левой кнопкой мыши по номеру (координате) строки или столбца. В меню Формат находятся подменю Строка и Столбец. При выборе одного из этих подменю открывается меню следующего уровня. В подменю Столбец вызовите команду Ширина, тогда откроется диалоговое окно, в котором пользователь может указать ширину столбца. Для стандартного шрифта в качестве единицы измерения можно использовать один символ. Например, если в столбце нужно записать стандартным шрифтом 10 символов, то в поле ввода Ширина столбца следует указать число 10. Команда Автоподбор ширины из меню Столбец автоматически корректирует ширину столбца в соответствии с его содержимым.

Коррекцию можно выполнить и с помощью манипулятора мыши. Для этого указатель мыши нужно установить на границу между номерами строк или названиями столбцов. При этом указатель мыши приобретает вид двунаправленной стрелки o n. Если нажать левую кнопку мыши и, не отпуская ее, немного сдвинуть указатель мыши, то можно увидеть штриховую линию, которая показывает смещение границы строки. Переместите эту линию в нужную позицию и отпустите кнопку мыши, тогда в таблице появится новая граница строки. Если дважды щелкнуть мышью по номеру строки (адресу столбца), то высота (ширина) этой строки (столбца) будет автоматически скорректирована по ее содержимому.

Построение таблиц

Все данные таблицы записываются в так называемые ячейки, которые находятся на пересечении строк и столбцов таблицы. «По умолчанию» содержимое ячейки представляется программой Excel в стандартном формате, который устанавливается при запуске программы. Например, для чисел и текстов задается определенный вид и размер шрифта.

В программе Excel имеются контекстные меню, которые вызываются правой кнопкой мыши, когда промаркирована некоторая область таблицы. Эти меню содержат много команд обработки и форматирования таблиц. Команды форматирования можно также вызвать на панели форматирования (вторая строка пиктографического меню), щелкнув мышью по соответствующей пиктограмме.

Выделение ячеек

Отдельные ячейки таблицы выделяются (маркируются) автоматически с помощью указателя ячеек. Чтобы перевести указатель в заданную ячейку, нужно щелкнуть по ней левой кнопкой мыши или использовать клавиши управления курсором. Для выделения нескольких ячеек нужно щелкнуть в начале выделяемой области (левый верхний угол) и, удерживая кнопку мыши нажатой, перемещать манипулятор в конец области (правый нижний угол). Чтобы отменить маркировку области, можно просто щелкнуть по невыделенной ячейке. Для выделения нескольких ячеек с помощью клавиатуры необходимо установить указатель ячеек в начальную ячейку области, а затем, удерживая клавишу Shift нажатой, распространить выделение на всю область с помощью клавиш управления курсором.

Одна строка или столбец таблицы выделяются щелчком по номеру (адресу), который расположен в заголовке строки или столбца. Для выделения нескольких строк или столбцов нужно щелкнуть по номеру первой строки (столбца), а затем, удерживая кнопку мыши нажатой, переместить манипулятор в нужную позицию.

Выделить несколько несмежных ячеек или диапазонов можно мышкой с нажатой клавишей Ctrl. При нажатой клавише Shift можно выделить диапазон ячеек от первой до последней ячейки диапазона указанных мышкой.

Отмена операций

Действие, которое выполнено последним, можно отменить командой Отменить действие из меню Правка или комбинацией клавиш Ctrl+Z. Операцию отмены можно также выполнить, щелкнув мышью по соответствующей пиктограмме на панели управления.

Команда отмены после выполнения превращается в команду подтверждения изменения Вернуть действие Выполнив эту команду, можно снова ввести в таблицу измененные данные и т.д. Это можно сделать также с помощью клавиатурной комбинации Ctrl+Z или щелчка по соответствующей пиктограмме.

Предыдущее действие можно повторить - для этого служит команда Повторить действие из меню Правка. Для повторения последнего действия можно также нажать клавишу F4 или щелкнуть по соответствующей пиктограмме на панели управления.

Копирование данных

Прежде всего, нужно выделить группу ячеек, содержимое которых должно быть скопировано, а затем вызвать команду Копировать из меню Правка. После этого выделенная область будет заключена в рамку. Теперь следует установить указатель мыши в позицию, куда должны быть скопированы данные, и нажать клавишу ввода Enter. Содержимое выделенной области появится в новом месте. Если область, в которую нужно поместить копию, тоже выделена, то размеры обеих групп должны быть одинаковыми, в противном случае будет выдано сообщение об ошибке.

В контекстном меню правой кнопки мыши также есть команда копирования. Для копирования можно также использовать комбинацию клавиш Ctrl+Insert или соответствующую пиктограмму на панели инструментов.

Если нужно удалить содержимое группы ячеек и поместить его на новое место в таблице, то следует использовать команду Вырезать из меню Правка.

Удаление данных

Прежде всего, нужно выделить группу ячеек, содержимое которых должно быть удалено. Затем можно воспользоваться одним из способов удаления данных. Для этого в меню Правка есть подменю Очистить, которое содержит следующие четыре команды:

Все - удаляет содержимое и отменяет формат ячейки;

Форматы - отменяет только формат ячейки;

Содержимое - удаляет только содержимое ячейки;

Примечания - удаляет только комментарии к ячейке.

Команда удаления Очистить содержимое есть также в контекстном. С помощью этой команды можно удалить только содержимое ячеек. Тот же результат достигается просто нажатием клавиши Del. Если пользователь случайно удалил нужную информацию, то командой Отменить очистку меню Правка – пользователь отменит команду удаления.

Форматирование данных

Прежде всего, нужно выделить ячейки, в которых надо изменить формат данных. После этого можно либо открыть правой кнопкой мыши контекстное меню и вызвать в нем команду Формат ячеек, либо вызвать команду Формат Ячейки из меню Формат. В любом случае на экране появится диалоговое окно Формат ячеек. Используя его можно установить форматы представления данных в ячейках: числовые форматы, выравнивание, границы и вид ячеек, а также определить степень защиты данных.

Формат ячеек: вкладка Число

Формат ячеек: вкладка Выравнивание

Ссылки на ячейку или на группу ячеек

В Microsoft Excel каждая ячейка имеет свой адрес (координаты). Ссылка на ячейку или группу ячеек – способ указания адреса (координат) конкретной ячейки или нескольких ячеек. С помощью ссылок можно использовать в формуле данные, находящиеся в различных местах листа, а также использовать значение одной и той же ячейки в нескольких формулах. Кроме того, можно ссылаться на ячейки, находящиеся на других листах книги или в другой книге, или на данные другого приложения. Ссылки на ячейки других книг называются внешними ссылками. Ссылки на данные других приложений называются удаленными ссылками.

«По умолчанию» в Microsoft Excel используются ссылки типа «A1», в которых столбцы обозначаются буквами от A до IV (256 столбцов максимально), а строки числами — от 1 до 65536. Альтернативный способ, когда названия столбцов указываются арабскими цифрами и в адресе сначала указывается номер строки, а потом столбца – тип «R1C1» (изменить тип ссылок можно в меню Сервис, Параметры, Общие, Стиль ссылок R1C1). Чтобы указать ссылку на ячейку, введите адрес (координаты) ячейки, то есть букву заголовка столбца, а затем номер строки. Например, D50 является ссылкой на ячейку, расположенную в пересечении столбца D с 50-й строкой. Чтобы сослаться на диапазон ячеек, введите ссылку на верхний левый угол диапазона, поставьте двоеточие (:), а затем — ссылку на правый нижний угол диапазона.

Ссылки можно делать не только на ячейки текущего листа, но и на ячейки других листов и файлов (книг). При этом в ссылке должно быть название листа, на ячейки которого делается ссылка, отделенное от адреса ячеек восклицательным знаком, например, Лист1!A10. А при ссылке на другую книгу добавляется название книги в квадратных скобках [Книга2]Лист5!$A$5.

В следующей таблице представлены варианты возможных ссылок.

Чтобы сослаться на | Введите
Ячейку столбца A и 10-й строки | A10
Диапазон ячеек столбца A с 10-й строки по 20-ю | A10:A20
Диапазон ячеек в 15-й строке со столбца B по столбец E | B15:E15
Все ячейки в 5-й строке | 5:5
Все ячейки между 5-й и 10-й строками включительно | 5:10
Все ячейки в столбце H | H:H
Все ячейки между столбцами H и J включительно | H:J

Относительные и абсолютные ссылки

При перемещении формулы ссылки, расположенные внутри формулы, не изменяются. При копировании формулы абсолютные ссылки не изменяются, а относительные ссылки изменяются.

При создании формулы ссылки обычно изменяются относительно расположения ячейки, содержащей формулу. В следующем примере ячейка С5 содержит формулу =A5*В5. Ссылка на ячейку А5 (как и В5) называется относительной (т.е. адрес относительно названия столбца и номера строки).

 | A | B | С
5 | 100 | 2 | =А5*В5
6 | 200 | 5 |
7 |  |  |

При копировании формулы, содержащей относительные ссылки в другие ячейки ссылки, будут меняться относительно адреса новой ячейки. В следующем примере формула из ячейки С5 копируется в ячейку С6. В ячейке С6 будет содержаться формула =A6*В6, которая при копировании на 1 строку ниже изменила номер строки на 1. А при копировании формулы из ячейки С5 в ячейку D6, будет содержаться формула =B6*C6, в которой изменился адрес ячеек относительно перемещения на 1 строку ниже и 1 столбец вправо.

 | A | B | С | D
5 | 100 | 2 | =А5*В5 |
6 | 200 | 5 | =A6*В6 | =B6*C6
7 |  |  |  |

Если необходимо, чтобы ссылки не изменялись при копировании формулы в другую ячейку, воспользуйтесь абсолютными ссылками. Например, если необходимо умножить все значения столбца А на содержимое ячейки B5 (=A5*В5, =A6*В5, =A7*В5 и т.д.), то чтобы не вводит формулу в каждую ячейку, а копировать ее, необходима абсолютная ссылка. Для создания абсолютной ссылки на ячейку В5, поставьте знак доллара ($) перед той частью адреса, которая не должна изменяться (В$5). Чтобы создать абсолютную ссылку на ячейку В5, поместите знак доллара так:

=A5*$В$5

При копировании такой формулы, как по строкам, так и по столбцам, ссылка на ячейку не будет меняться В5. И, например, после копирования ее в ячейку D45 будет формула =В45*$В$5.

Можно фиксировать и диапазоны ячеек: $В$2:$В$20.

Для удобства, при создании абсолютной ссылки в режиме ввода и редактирования формул можно использовать клавишу F4. Поставив курсор у адреса ячейки, и нажав 1 раз F4 , будет зафиксирована вся ячейка ($C$1 – абсолютная ссылка), 2 раза – только номер строки (C$1 – абсолютная ссылка по строке), 3 раза – только название столбца ($C1 – абсолютная ссылка по столбцу) и 4 раза – снимается фиксация (C1 – относительная ссылка).

Табличные вычисления

Возможность использования формул и функций является одним из важнейших свойств программы обработки электронных таблиц. Это, в частности, позволяет проводить статистический анализ числовых значений в таблице.

Текст формулы, которая вводится в ячейку таблицы, должен начинаться со знака равенства (=), чтобы программа Excel могла отличить формулу от текста. Знак равенства вводится с клавиатуры или нажатием на кнопку = - Редактирование формулы в строке формул. После знака равенства в ячейку записывается математическое выражение, содержащее аргументы, арифметические операции и функции.

В качества аргументов в формуле обычно используются числа и адреса ячеек. Для обозначения арифметических операций могут использоваться следующие символы: + (сложение); - (вычитание); Ч (умножение); / (деление); ^ (возведение в степень).

Предположим, что в ячейке А1 таблицы находится число 100, а в ячейке В1 - число 20. Чтобы разделить первое число на второе и результат поместить в ячейку С1, в ячейку С1 следует ввести формулу =А1/В1 и нажать на клавиатуре Enter или в строке формул кнопку P . Адреса ячеек А1 и В1 вводятся латинским буквами.

Ввод адресов ячеек можно существенно упростить, используя манипулятор мыши. После ввода знака = следует просто щелкнуть мышью по первой ячейке, затем нажать / и щелкнуть по второй ячейке, затем нажать Enter.

Формула может содержать ссылки на ячейки, которые расположены на другом рабочем листе или даже в таблице другого файла. Однажды введенная формула может быть в любое время модифицирована. Встроенный Менеджер формул помогает пользователю найти ошибку или неправильную ссылку в большой таблице.

Кроме этого, программа Excel позволяет работать со сложными формулами, содержащими несколько арифметических действий и функций.

Редактирование формул

Чтобы начать редактировать содержимое ячейки, нужно сначала выделить эту ячейку. Далее включить режим редактирования, нажав клавишу F2 или выполнив двойной щелчок мышью. Для редактирования формул можно нажать кнопку = в строке формул. В режиме редактирования активизируется строка формул, в которой виден текст формулы, а не результат ее вычисления.

Чтобы изменить формулу нужно щелкнуть мышью в той позиции строки, где необходимо внести изменения. Изменения вносятся также, как производится ввод формул.

Где был выполнен щелчок, появится мерцающий текстовый курсор. С этой позиции можно вводить новые символы с клавиатуры. Щелчок по кнопке Р (Esc)слева от формулы отменяет все произведенные изменения, так что содержимое ячейки остается без изменения. Щелчок по кнопке ь (Enter) слева от формулы подтверждает изменение, и в ячейке появляется новое значение.

Мастер функций

Поскольку многие сложные и несложные вычисления встречаются очень часто, то программа Excel предлагает более 200 заранее запрограммированных функций. Функциями в Microsoft Excel называют вычислительную операция по определенному алгоритму и формуле.

Для быстрого поиска необходимой функции они разделены по категориям: 10 недавно использовавшихся, Полный алфавитный перечень, Финансовые, Дата и время, Математические, Статистические, Ссылки и массивы, Работа с базой данных, Текстовые, Логические и Проверка свойств. Встроенный Мастер функций помогает правильно применять функции. Он позволяет построить и вычислить большинство функций.

Функции в Microsoft Excel представляют собой формулы, которые имеют один или несколько аргументов. В качестве аргументов указываются числовые значения или адреса ячеек.

Например:

=СУММ(А5:А9) – сумма ячеек А5, А6, А7, А8, А9;

=СРЗНАЧ(G4:G6) – среднее значение ячеек G4, G5, G6.

Функции могут быть вложенными одна в другой, например:

=ОКРУГЛ(СРЗНАЧ(H4:H8);2).

Функция расчета среднего значения является вложенной в функцию округления. При расчете сначала выполняется вложенная функция. Можно сделать в формуле не более 7 вложенностей.

Строка формул и диалоговое окно функции Просмотр

Для введения функции в ячейку необходимо выделить ту ячейку, в которой должен появиться результат вычислений. Затем щелчком по соответствующей кнопке [image] - Мастер функций откройте диалоговое окно.

В левом поле этого окна перечислены категории функций, а в правом – в алфавитном порядке функции, соответствующие выбранной категории. Для того чтобы увидеть все функции, следует щелкнуть мышью по опции Все в поле категорий.

После щелчка мышью по названию искомой функции, ее название появится в отдельной строке вместе с кратким описанием этой функции. Здесь же указываются параметры (аргументы) функции и их количество.

После нажатия кнопки ОК появится диалоговое окно выбранной функции (например, функция Просмотр,

Необходимо в полях обязательных и необязательных параметров этого окна ввести аргументы функции (числовые значения или ссылки на ячейки). Чтобы указать аргументы, можно щелкнуть кнопку [image], находящуюся справа от поля, и выделить мышью ячейки, содержащие аргументы функции; для выхода из этого режима следует щелкнуть кнопку Х, которая находится справа от поля или клавишу Esc. Для завершения ввода формулы нажмите ОК.

Названия Обязательных параметров выделены жирным шрифтом, эти поля обязательно подлежат заполнению. Если не введены обязательные параметры при нажатии кнопки ОК будет выдано сообщение об ошибке. Необязательные параметры заполняются по необходимости.

Чтобы в качестве аргумента вложить функцию, нужно поставить курсор в поле параметра и выбрать из Списка функций в строке формул необходимую. Желательно сначала ввести все аргументы первой функции, а затем переходить к вводу вложенной функции.

После этого в указанной ячейке таблицы появится результат вычислений, но ячейка останется выделенной и в наборной строке можно увидеть текст функции вместе с соответствующими параметрами.

Редактирование функций

Щелкните мышью по ячейке, где находится функция. Затем щелчком по пиктограмме Мастер функций откройте соответствующее диалоговое окно.

В этом окне дается название функции, приводится ее краткое описание, перечисляются ее аргументы. Для того чтобы изменить содержимое поля, где находятся аргументы, следует либо непосредственно внести новые адреса, либо выделить соответствующую группу ячеек. После окончания редактирования следует щелкнуть по кнопке ОК.

После щелчка по ячейке, где находится функция, в строке формул появится текст функции, содержащей значения аргументов. Поэтому редактирование можно выполнить непосредственно в строке формул, не обращаясь к Мастеру функций. Для этого нужно щелкнуть мышью в той позиции наборной строки, где необходимо исправить формулу.

Где был выполнен щелчок, появится мерцающий текстовый курсор. С этой позиции можно вводить новые символы с клавиатуры. Щелчок по кнопке Отмена Р слева от формулы отменяет все произведенные изменения, так что содержимое ячейки остается без изменения. Щелчок по кнопке ь (Enter) слева от формулы подтверждает изменение, и в ячейке появляется новое значение.

Вычисление суммы

Выделите ячейку, где должна располагаться сумма, и щелкните мышью по соответствующей пиктограмме сложения.

В наборной строке появится знак равенства и слово SUM, за которым в скобках обычно следует адрес некоторой области, которую программа предлагает после анализа близлежащих ячеек в качестве области суммирования. Если Excel "угадала" правильно, нажмите Enter .

В противном случае выделите группу ячеек, которые нужно сложить. Можно выделить несколько несмежных групп ячеек, используя клавишу Ctrl. Эту клавишу нужно удерживать в нажатом состоянии до тех пор, пока все группы не будут выделены.

Адреса групп можно ввести с клавиатуры. В этом случае нужно помнить, что адреса начальной и конечной ячеек группы разделяются двоеточием, а адреса различных групп - точкой с запятой (или запятой, в зависимости от установки опций Язык и стандарты в среде Windows). Кроме этого в формулу можно ввести и числовые слагаемые. После этого щелкните по пиктограмме автосуммирования, чтобы вычислить сумму.

Массивы формул

Формула массива выполняет несколько вычислений и возвращает либо несколько значений, либо одно значение. Формулы массива обычно обрабатывают один и несколько наборов аргументов, которые называются аргументами массива. При этом все аргументы массива должны быть прямоугольными и иметь одинаковое количество строк и столбцов. Чтобы вернуть несколько значений, формулу необходимо ввести в несколько ячеек.

Массивы формул удобно использовать для введения однотипных формул и обработки данных в виде таблиц. Например, для вычисления модуля от чисел, размещенных в ячейках A1, B1, C1, D1, E1, вместо ввода формул в каждую ячейку можно ввести одну формулу–массив для всех ячеек. Microsoft Excel добавляет вокруг массива формул фигурные скобки { }, по которым его можно отличить.

Для создания массива формул необходимо:

- выделить ячейки, в которых должен находиться массив формул;

- ввести формулу обычным способом, указав в качестве аргументов группу ячеек-аргументов;

- в последнем окне вместо кнопки ОК нажать комбинацию клавиш Ctrl+Shift+Enter.

- Для редактирования массива формул необходимо:

- выделить ячейки, в которых находится массив;

- щелкнуть мышью внутри строки редактирования и отредактировать формулу;

- нажать комбинацию клавиш Ctrl+Shift+Enter.

Массив формул

Другой пример формулы массива для одной ячейки: ={СУММ(ЕСЛИ(А1:Е1=-12; А2:Е2;0))},

Эта формула просматривает все ячейки массива А1:Е1 и если они равны –12 суммирует соответствующие ячейки строки 2.

Проверка вводимых в ячейку данных

Чтобы исключить ввод ошибочных данных, необходимо указать формат и диапазон данных, которые являются допустимыми для отдельных ячеек или диапазона ячеек. Для этого в меню Данные есть команда Проверка, в параметрах которой можно устанавливать ниже перечисленные виды ограничений ввода данных. При вводе данных, не удовлетворяющих условиям проверки, будет выводиться сообщение об ошибке. Ошибочные данные невозможно ввести.

Ограничение диапазона вводимых данных

Выделите ячейки, на которые нужно наложить ограничения.

Выберите команду Проверка в меню Данные, а затем откройте вкладку Параметры.

Выберите тип данных в списке Тип данных.

Чтобы установить только числа, выберите Целое число или Действительное (с дробной частью).

Чтобы установить только даты или время, выберите Дата или Время.

Выберите нужный оператор в списке Даты и затем введите верхнюю и нижнюю границы допустимого диапазона данных или только одну из них, в зависимости от требований. Границами могут служить числовые значения, а также ссылки на ячейки или формулы.

Флажок Игнорировать пустые ячейки позволяет оставить ячейку, на которую наложены ограничения, пустой, а также установить границы, содержащие ссылку на изначально пустую ячейку или использующие формулу, в которую входит такая ячейка.

Чтобы задействовать ограничения, которые были наложены на пустые ячейки так, как если бы эти ячейки содержали нули, снимите флажок Игнорировать пустые ячейки.

Чтобы выводить подсказку, а также давать пояснения по поводу некорректных данных или предотвращать их ввод, укажите типы сообщений на вкладках Сообщение для ввода и Сообщение об ошибке.

Примечания

Определение типа корректных данных не приводит к форматированию ячейки. Чтобы отформатировать числа, даты или время, содержащиеся в ячейке, выберите в меню Формат_ Ячейки… и затем — вкладку Число. В списке Числовые форматы выберите нужный формат, а также требуемые параметры.

Выбор вводимых данных из списка

Введите список корректных данных в строку или в столбец. Не включайте в список пустые ячейки.

Выделите ячейки, на которые нужно наложить ограничения.

Выберите команду Проверка в меню Данные, а затем откройте вкладку Параметры.

Выберите Список в окне Тип данных.

Введите ссылку на список корректных данных в поле Источник.

Чтобы воспользоваться при вводе данных списком для выбора имеющих ограничения ячеек, установите флажок Список допустимых значений.

Чтобы предотвратить ввод данных если ячейки, на которые наложены ограничения, пусты или отсутствует список корректных данных, снимите флажок Игнорировать пустые ячейки.

Чтобы выводить подсказку, а также давать пояснения по поводу некорректных данных или предотвращать их ввод, укажите типы сообщений на вкладках Сообщение для ввода и Сообщение об ошибке.

Советы:

Если список корректных данных короток, его можно вводить непосредственно в поле Источник, используя разделитель элементов списка – точка с запятой (;). Так, допустимо набрать Низкий; Средний; Высокий в поле Источник. Если список большой можно ввести эти данные в ячейки на листе и поле Источник сделать ссылку на эти ячейки.

Ограничение количества вводимых в ячейку символов

Выделите ячейки, на которые нужно наложить ограничения.

Выберите команду Проверка в меню Данные, а затем откройте вкладку Параметры.

Выберите команду Длина текста в окне Тип данных.

Выберите нужный оператор в окне Значение. Для этого оператора следует указать границы диапазона. Границами диапазона могут служить числовые значения, ссылки на ячейки и формулы.

Флажок Игнорировать пустые ячейки позволяет оставить ячейку, на которую наложены ограничения, пустой, а также установить границы, содержащие ссылку на изначально пустую ячейку или использующие формулу, в которую входит такая ячейка.

Чтобы задействовать ограничения, которые были наложены на пустые ячейки так, как если бы эти ячейки содержали нули, снимите флажок Игнорировать пустые ячейки.

Чтобы выводить подсказку, а также давать пояснения по поводу некорректных данных или предотвращать их ввод, укажите типы сообщений на вкладках Сообщение для ввода и Сообщение об ошибке.

Определение правильности вводимых данных с помощью формулы

Выделите ячейки, на которые нужно наложить ограничения.

Выберите команду Проверка в меню Данные, а затем откройте вкладку Параметры.

Выберите тип Другой в окне Тип данных.

В поле Формула введите формулу для расчета логического значения (ИСТИНА или ЛОЖЬ). Данные, вводимые в ячейку, считаются некорректными, если результатом вычислений является значение ЛОЖЬ. Перед формулой необходимо поставить знак равенства (=).

Например, на листе производится расчет прибыли путем вычитания суммы вводимых издержек из расчетной суммы дохода. Может возникнуть необходимость поддерживать прибыль на уровне, превышающем определенный процент издержек. В этом случае для ячеек D6:D13, служащих для ввода издержек, следует определить допустимые данные с помощью формулы следующего вида: =Прибыль > СУММ(D6:D13) * 15%, где «Прибыль» — это имя ячейки.

Поиск некорректных данных на листе

Во время проверки листа Microsoft Excel находит все ячейки, которые содержат значения, противоречащие ограничениям, заданным с помощью команды Проверка в меню Данные. Сюда входят значения, непосредственно введенные в ячейку, значения, полученные в результате вычислений по формулам, копирования или автозаполнения, а также значения, которые были помещены в ячейки макросами.

Убедитесь, что отображается панель инструментов Зависимости. Для этого выберите Зависимости в меню Сервис, а затем проверьте, что установлен флажок для отображения панели Зависимости.

На панели инструментов Зависимости нажмите кнопку Обвести неверные данные.

Совет: Чтобы узнать, какие сообщения и ограничения на данные имеет ячейка, выберите ячейку, а затем — команду Проверка в меню Данные.

Группирование элементов таблицы

Microsoft Excel позволяет группировать элементы в сводной таблице для того, чтобы создать один элемент. Например, для того, чтобы сгруппировать месяцы в кварталы для построения диаграммы или для печати.

Для группирования элементов таблицы необходимо:

выделить строки или столбцы, которые будут подчинены итоговой строке или столбцу (это будут строки или столбцы, которые необходимо сгруппировать);

в меню Данные выбрать пункт Группа и структура;

выбрать пункт Группировать.

Так можно создать все необходимые уровни структуры. Например, таблица содержит 3 уровня детализации. Третий уровень скрывает строки 2-4 и 6-8, второй – скрывает строки 2-9. Таким образом, первый уровень детализации содержит только строки 1 и 10. Для перехода между уровнями используются кнопки с соответствующими цифрами в верхнем левом углу таблицы.

Группы и структура

Чтобы снять группирование, следует выделить необходимые элементы, выбрать пункт Группа и структура [image] меню Данные, затем пункт Разгруппировать.

Разделение окон

Иногда необходимо одновременно просматривать различные части большой таблицы. Для этого следует разделить окно таблицы на подокна одним из следующих способов:

- установить указатель мыши на горизонтальную или вертикальную вешку разбиения (он примет вид двунаправленной стрелки) и перетянуть в нужное место. Размеры подокон можно изменять, перетягивая вешку разбиения;

- выделить столбец или строку, по которой следует разделить окно. Для разделения окна на 4 части необходимо выделить ячейку, по которой нужно выполнить разделение. Затем в меню Окно выбрать команду Разделить. Окно разделится горизонтально по строке над выделенной ячейкой и вертикально по столбцу слева от нее.

Чтобы отменить разделение окон, следует в меню Окно выбрать команду Снять разделение или дважды щелкнуть на вешке разбиения.

Создание нового окна

С помощью команды Новое меню Окно можно создать дополнительное окно для активной рабочей книги, чтобы просматривать различные части рабочей книги одновременно. В этом случае в заголовке окна после имени рабочей книги через двоеточие указывается номер нового окна. Например, второе окно рабочей книги Отчет будет названо Отчет:2.

Упорядочить окна рабочей книги можно следующим способом. В меню Окно выбрать команду Расположить. В диалоговом окне Расположение окон выбрать подходящий вариант.

Для возврата к однооконному изображению необходимо развернуть активное окно на весь экран, щелкнув на кнопке восстановления окна.

Фиксация подокон

Иногда необходимо зафиксировать одну часть таблицы. Например, зафиксировать заголовок таблицы, чтобы он всегда присутствовал на экране. Для фиксации только вертикальных или только горизонтальных заголовков следует:

- чтобы зафиксировать горизонтальные заголовки, выделить строку ниже заголовков;

- чтобы зафиксировать вертикальные заголовки, выделить столбец справа от заголовков;

- в меню Окно выбрать команду Закрепить области.

Для фиксации и вертикальных, и горизонтальных заголовков необходимо:

- выделить ячейку, по которой следует зафиксировать заголовки (все строки выше выделенной ячейки и все столбцы слева от выделенной ячейки будут зафиксированы);

- в меню Окно

выбрать команду Закрепить области.

Если разделить окно до фиксации подокон, они зафиксируются по их текущему месту, а не по активной ячейке.

Отменяется фиксация окон и подокон командой Снять закрепление областей меню Окно.

Присвоение имени ячейке, диапазону или формуле

При обращении к ячейке, диапазону или формуле вместо адреса ячеек можно использовать присвоенные им имена. Чтобы присвоить имя формуле необходимо:

- в меню Вставка выбрать пункт Имя, а затем пункт Присвоить;

- в поле Имя ввести имя для формулы;

- в поле Формула ввести формулу (она должна начинаться со знака "=";

- щелкнуть кнопку Добавить, после чего имя формулы появится в списке;

- для удаления имени из списка следует выделить его и щелкнуть кнопку Удалить;

- после ввода всех имен щелкнуть ОК.

Чтобы вставить формулу с собственным именем, необходимо:

- в меню Вставка выбрать пункт Имя, а затем пункт Вставить;

- в списке Имя выбрать имя формулы и щелкнуть ОК.

Для присвоения имени ячейке или диапазону, следует:

- выделить ячейку, диапазон ячеек или несколько диапазонов, которым следует присвоить имя;

- щелкнуть мышью в поле имени в левой части строки формул;

- набрать имя для ячейки или диапазона;

- нажать клавишу Enter.

Если щелкнуть на кнопке со стрелкой рядом с полем имени, то появится список собственных имен ячеек. При выборе имени из этого списка будет выделена соответствующая ячейка или диапазон ячеек.

Если ячейке или диапазону ячеек присвоено имя, его можно использовать на любом другом листе этой же книги. Можно также создавать имена, определенные только для текущего уровня рабочего листа. Например, чтобы использовать одинаковое имя на нескольких различных листах одной книги, необходимо:

- в меню Вставка выбрать пункт Имя, а затем – Присвоить;

- в поле Имя набрать сначала имя рабочего листа, за ним восклицательный знак, а затем имя ячейки или диапазона ячеек, например, Лист5!Баланс;

- в поле Формула ввести формулу или ссылку (она должна начинаться со знака равенства) и щелкнуть кнопку ОК.

Можно использовать одно и тоже имя для определения имени на уровне листа и на уровне всей книги. Тогда имя на уровне рабочего листа будет перекрывать общее имя на том листе, где оно определено.

Создание примечаний

Microsoft Excel позволяет добавлять текстовые примечания к ячейкам. Это особенно полезно в одном из следующих случаев:

- рабочий лист используется совместно несколькими пользователями;

- рабочий лист большой и сложный;

- рабочий лист содержит формулы, в которых потом будет тяжело разобраться.

После добавления примечания к ячейке в ее верхнем правом углу появляется указатель примечания (красный треугольник). Для добавления текстового примечания необходимо:

- выделить ячейку, к которой следует добавить примечание;

- вызывать команду Примечание из меню Вставка;

- в поле, которое появилось, ввести примечание (размер поля можно изменить, перетягивая маркеры размера);

- щелкнуть мышью за пределами поля.

Примечание присоединится к ячейке и будет появляться при наведении на него указателя мыши. Для изменения текста примечания следует выделить соответствующую ячейку и в меню Вставка выбрать пункт Изменить примечание. Также для этого удобно использовать контекстное меню.

Чтобы увидеть одновременно все примечания и работать с ними, можно перейти в режим Примечания через соответствующий пункт в меню Вид. При этом появляется панель Рецензирование, содержащая кнопки для работы с примечаниями.

Работа с базами данных

С помощью Microsoft Excel можно создавать и обрабатывать базы данных. База данных в Microsoft Excel – таблица, состоящая из однотипных записей (строк). Столбцы таблицы являются полями записи в базе данных. Под имена полей выделяется первая строка базы данных. Например, если базой данных считать телефонный справочник, то полями записи будут фамилии, номера телефонов и адреса абонентов.

База данных

Для работы с базой данных необходимо сначала создать соответствующую таблицу. Если выделить ячейку в таблице и выбрать одну из команд обработки баз данных в меню Данные, Microsoft Excel автоматически определяет и обрабатывает всю таблицу. Данные, расположенные в столбцах и строках рабочего листа, обрабатываются как набор полей, которые образуют записи.

Сортировка данных

Подпись: Рис. 40. Сортировка Сортировка позволяет переупорядочить строки в таблице по любому полю. Например, чтобы отсортировать данные по цене изделия. Для сортировки данных следует выделить одну ячейку таблицы и вызвать команду Сортировка меню Данные.

В поле списка Сортировать по выбирается поле, по которому будут отсортированы данные, и тип сортировки:

по возрастанию – цифры сортируются по возрастанию, текст – в алфавитном порядке, логические выражения – ЛОЖЬ предшествует ИСТИНА.

по убыванию – сортировка в обратном порядке.

В поле списка Затем по указывается поле, по которому будут отсортированы данные, имеющие одинаковые значения в первом ключевом поле. Во втором поле Затем по указывается поле, по которому будут отсортированы данные, имеющие одинаковые значения в первых двух ключевых полях.

Для сортировки данных также используются кнопки [image] . Перед их использованием следует выделить столбец, по которому необходимо сортировать записи.

При сортировке по одному столбцу, строки с одинаковыми значениями в этом столбце сохраняют прежнее упорядочение. Строки с пустыми ячейками в столбце, по которому ведется сортировка, располагаются в конце сортируемого списка. Microsoft Excel позволяет также сортировать не всю таблицу, а только выделенные строки или столбцы.

Формы данных

При выполнении характерных для баз данных операций, таких как поиск, сортировка, подведение итогов, Microsoft Excel автоматически рассматривает таблицу как базу данных.

При просмотре, изменении, добавлении и удалении записи в базе данных, а также при поиске записей по определенному критерию удобно использовать формы данных. При обращении к команде Форма меню Данные Microsoft Excel считывает данные и создает диалоговое окно формы данных. В форме данных на экран выводится одна запись. При вводе или изменении данных в полях этого окна изменяется содержимое соответствующих ячеек базы данных.

Для использования форм данных таблица должна иметь имена столбцов. Имена столбцов становятся именами полей в форме данных. Поле соответствует каждому столбцу таблицы. Форма данных автоматически раскрывается так, чтобы вывести на экран сразу все поля в данной таблице, до 32 полей за один раз. С помощью полосы прокрутки можно прокручивать записи базы данных. Позиция выведенной записи указывается в верхнем правом углу. Передвигаться по полям формы можно с помощью мыши и клавиш Tab (вниз), Shift+Tab (вверх). В правой части окна расположены следующие кнопки.

Добавить – очищает поля для ввода новой записи базы данных. Если снова щелкнуть кнопку Добавить, то введенные данные будут добавлены, как новая запись, в конец базы данных.

Удалить – удаляет выведенную запись, другие записи базы данных сдвигаются. Удаленные записи не могут быть восстановлены.

Вернуть – восстанавливает отредактированные поля в выведенной записи, удаляя сделанные изменения. Чтобы восстановить запись, необходимо сделать это перед нажатием клавиши Enter или перед переходом к другой записи.

Назад – выводит предыдущую запись в списке. Если был определен критерий с помощью кнопки Критерии, то кнопка Назад выведет предыдущую запись из тех, которые удовлетворяют заданному критерию.

Далее – выводит следующую запись базы данных.

Критерии – очищает поля перед вводом критериев сравнения с операторами сравнения для поиска необходимого подмножества записей.

Правка – служит для выхода из режима ввода критериев. Доступна только после нажатия кнопки Критерии.

Очистить – удаляет существующий критерий из окна диалога. Доступна только после нажатия кнопки Критерии.

Закрыть – закрывает форму данных.

Для добавления записи к базе данных необходимо:

- выделить ячейку в таблице, к которой следует добавить запись;

- в меню Данные выбрать команду Форма;

- щелкнуть кнопку Добавить;

- заполнить поля новой записи;

- для перемещения к следующему полю нажать клавишу Тab;

- после ввода данных нажать клавишу Enter для добавления записи;

- после добавления всех необходимых записей, щелкнуть кнопку Закрыть.

Новые записи будут добавлены в конец базы данных.

Установление диапазона критериев

Критерии бывают двух типов.

Критерии вычисления – это критерии, которые являются результатом вычисления формулы. Например, диапазон критериев =F7>СРЗНАЧ($F$7:$F$21) выводит на экран строки, имеющие в столбце F значения большие, чем среднее значение величин в ячейках F7:F21. Формула должна возвращать логическое значение ЛОЖЬ или ИСТИНА. При фильтрации будут доступны только те строки, значения которых будут придавать формуле значения ИСТИНА.

Критерии сравнения – это набор условий для поиска, используемый для извлечения данных при запросах по примеру. Критерий сравнения может быть последовательностью символов (константой) или выражением (например, Цена > 700).

Для поиска с помощью формы данных записей, отвечающих критерию, необходимо:

- выделить ячейку в таблице;

- в меню Данные выбрать команду Форма;

- щелкнуть кнопку Критерии;

- в полях редактирования ввести критерии для поиска данных;

- для вывода на экран первой записи, отвечающей критерию, щелкнуть кнопку Далее;

- для вывода на экран предыдущей записи, отвечающей критерию, щелкнуть кнопку Назад;

- для поиска записей в списке по другим критериям щелкнуть кнопку Критерии и ввести новые критерии;

- по окончанию щелкнуть кнопку Закрыть.

Чтобы снова получить доступ ко всем записям таблицы, необходимо щелкнуть кнопку Критерии, а затем – кнопку Правка.

Команда Фильтр меню Данные позволяет отыскивать и использовать нужное подмножество данных в списке. В отфильтрованном списке выводятся на экран только те строки, которые содержат определенное значение или отвечают определенным критериям, при этом другие строки скрываются. Для фильтрации данных используются команды Автофильтр и Расширенный фильтр пункта Фильтр меню Данные.

Автофильтр

Команда Автофильтр устанавливает кнопки скрытых списков (кнопки со стрелками) непосредственно в строку с именами столбцов. С их помощью можно выбирать записи базы данных, которые следует вывести на экран. После выделения элемента в открывшемся списке, строки, не содержащие данный элемент, будут скрыты. Например, если в скрытом списке поля Цена выбрать 160 р., то будут выведены только записи, у которых в поле Цена содержится значение 160 р.

Пример установки автофильтра

Если в поле списка выбрать пункт Условие … , то появится окно Пользовательский автофильтр. В верхнем правом списке следует выбрать один из операторов (равно, больше, меньше и др.), в поле справа – выбрать одно из значений. В нижнем правом списке можно выбрать другой оператор, и в поле по левую сторону – значение. Когда включен переключатель И, то будут выводиться только записи, удовлетворяющие оба условия. При включенном переключателе ИЛИ будут выводиться записи, удовлетворяющие одному из условий.

Для вывода нескольких записей с самым большим или самым малым значением по любому полю следует в скрытом списке поля выбрать пункт Первые 10. В диалоговом окне Наложение условия по списку в первом поле со счетчиком необходимо выбрать количество записей, а в поле справа выбрать – наибольших или наименьших.

Чтобы вывести все данные таблицы, необходимо вызвать команду Отобразить все или отменить команду Автофильтр меню Данные, подменю Фильтр.

Расширенный фильтр

Команда Расширенный фильтр позволяет фильтровать данные с использованием диапазона критериев для вывода только записей, удовлетворяющих определенным критериям. При повторной фильтрации будут просматриваться все строки, и скрытые, и открытые. Значение переключателей и полей окна Расширенный фильтр следующие:

Диалоговое окно Расширенный фильтр

фильтровать список на месте – переключатель, скрывающий строки, которые не удовлетворяют указанному критерию;

скопировать результат в другое место – копирует отфильтрованные данные на другой рабочий лист или на другое место на этом же рабочем листе;

Исходный диапазон – поле, определяющее диапазон, который содержит список, подлежащий фильтрации;

Диапазон условий – поле, определяющее диапазон ячеек на рабочем листе, который содержит необходимые условия;

Поместить результат в диапазон – поле, определяющее диапазон ячеек, в который копируются строки, удовлетворяющие определенным условиям; это поле активно только в том случае, если выбран переключатель скопировать результат в другое место;

Только уникальные записи – переключатель, который выводит только строки, удовлетворяющие критерию и не содержащие неповторяющихся элементов. Если диапазон критериев не определен, то в этом случае все строки списка, содержащие дубликаты, будут скрыты.

Для установления сложных критериев необходимо:

- вставить несколько строк в верхней части рабочего листа;

- в одном из вставленных пустых строк ввести имена столбцов, по которым следует отфильтровать таблицу;

- при использовании критериев сравнения, имена критериев должны быть идентичны именам столбцов, которые проверяются;

- в строках, расположенных под строкой с именами проверяемых столбцов, ввести критерии, которым должны соответствовать ячейки проверяемых столбцов;

- выбрать в меню Данные пункт Фильтр, затем – Расширенный фильтр, и в диалоговом окне ввести условия фильтрации.

Пример расширенной фильтрации

Для объединения критериев с помощью условного оператора И следует указать критерии в одной и той же строке, а для объединения критериев с помощью условного оператора ИЛИ следует ввести критерии в разных строках. Например, диапазон критериев выводит на экран все записи, имеющие в столбце Цена значения больше 150 и меньше 1000.

После использования команд Автофильтр или Расширенный фильтр, таблица переходит в режим фильтрации. В этом режиме многие команд Microsoft Excel влияют только на видимые ячейки. После применения фильтра для вывода только нужных строк, можно скопировать полученное подмножество данных в другое место для дальнейшего анализа.

Чтобы снова вывести все записи следует в меню Данные выбрать пункт Фильтр, затем пункт Отобразить все.

Текстовый режим индикации функций

В обычном режиме программа Excel вводит в таблицу результаты вычислений по формулам. Можно изменить этот режим и вывести текстовый режим индикации (отображения) формул, нажав комбинацию клавиш Ctrl+~ или Сервис_ Параметры на вкладке включить Формулы.

После этого на экране становятся видны не результаты вычислений, а тексты самих формул и функций. В этом режиме увеличивается ширина столбцов, чтобы можно было увидеть всю формулу и попытаться найти ошибку.

Сообщения об ошибках

Если формула в ячейке не может быть правильно вычислена, Microsoft Excel выводит в ячейку сообщение об ошибке. Если формула содержит ссылку на ячейку, которая содержит значения ошибки, то вместо этой формулы также будет выводиться сообщение об ошибке. Значение сообщений об ошибках следующее:

#### – ширина ячейки не позволяет отобразить число в заданном формате;

#ИМЯ? – Microsoft Excel не смог распознать имя, использованное в формуле;

#ДЕЛ/0! – в формуле делается попытка деления на нуль;

#ЧИСЛО! – нарушены правила задания операторов, принятые в математике;

#Н/Д – такое сообщение может появиться, если в качестве аргумента задана ссылка на пустую ячейку;

#ПУСТО! – неверно указано пересечение двух областей, которые не имеют общих ячеек;

#ССЫЛКА! – в формуле задана ссылка на несуществующую ячейку;

#ЗНАЧ! – использован недопустимый тип аргумента.

Построение и оформление диаграмм

Диаграмма – это представление данных таблицы в графическом виде, которое используется для анализа и сравнения данных. На диаграмме числовые данные ячеек изображаются в виде точек, линий, полос, столбиков, секторов и в другой форме. Группы элементов данных, отражающих содержимое ячеек одной строки или столбца на рабочем листе, составляют ряд данных.

Для создания диаграммы необходимо:

- на рабочем листе выделить данные, по которым следует построить диаграмму, включая ячейки, содержащие имена категорий или рядов, которые будут использоваться в диаграмме;

- выбрать команду Диаграмма меню Вставка или щелкнуть кнопку [image];

- в диалоговых окнах Мастера диаграмм следует выбрать тип, формат и другие параметры диаграммы;

- для перехода к следующему шагу используется кнопка Далее>>;

- для построения диаграммы на любом шаге можно щелкнуть кнопку Готово, тогда Мастер диаграмм самостоятельно закончит построение диаграммы;

- в последнем (4-м) окне, после выбора места размещения диаграммы, щелкнуть кнопку Готово.

Диаграмму можно перетянуть мышью в любое место. Для изменения размера диаграммы необходимо щелкнуть на ней мышью и перетянуть маркеры размера. Для изменения типа и параметров построенной диаграммы следует щелкнуть на диаграмме правой клавишей мыши и в контекстном меню выбрать подходящую команду. Для удаления диаграммы следует щелкнуть на ней мышью, чтобы появились маркеры размера, и нажать клавишу Delete.

Перемещение объектов диаграммы

Перемещение объектов диаграммы выполняется в режиме редактирования диаграммы. Перейдите в него. Для перемещения объекта диаграммы выполните следующие действия:

1. Нажмите мышью на объекте, который вы хотите переместить. При этом вокруг объекта появляется окаймление из черных квадратиков.

2. Подведите курсор к границе объекта и нажмите кнопку мыши. Появится прерывистая рамка.

3. Переместите объект в нужное место (перемещение осуществляется курсором мыши), удерживая нажатой кнопку мыши, после чего отпустите кнопку мыши. Объект переместился.

Для изменения размеров поля, на котором находится какой-либо из объектов диаграммы, выполняются следующие действия:

1. Нажмите мышью на объекте, размеры которого вы хотите изменить При этом вокруг объекта появляется окаймление из черных квадратиков.

2. Переместите указатель мыши в черный квадратик на той стороне объекта, которую вы собираетесь
изменять, или в угол объекта. При этом белая стрелка переходит в двунаправленную черную стрелку.

3. Нажмите кнопку мыши и удерживайте ее нажатой. Появится прерывистая рамка.

4. Переместите границу объекта (перемещение осуществляется курсором мыши), удерживая нажатой кнопку мыши, в нужное место и отпустите кнопку мыши. Размеры объекта изменились. Если размеры объекта вас опять не устраивают, повторите операцию.

Размеры и положение диаграммы изменяются аналогично. Операция форматирования для любых объектов выполняется по следующей схеме:

1. Нажмите правую кнопку мыши на объекте, который нужно форматировать, Появляется список команд, который зависит от выбранного объекта.

2. Выберите команду для форматирования:

-форматировать название диаграммы;

-форматировать легенду;

-форматировать ось;

-форматировать область построения.

После выбора любой из этих команд появляется окно диалога для форматирования объекта, в котором, используя стандартную технику MS Excel, вы можете выбирать шрифты, размеры, стили, форматы, заполнения и цвета.

Для изменения заполнения области построения диаграммы нажмите на ней правую кнопку мыши и в появившемся списке выберите опцию «Формат» области построения. В открывшемся окне диалога выберите подходящее заполнение.

При работе с графикой MS Excel вы можете заменить один ряд данных другим в построенной диаграмме и, изменяя данные на диаграмме, соответственно корректировать исходные данные в таблице. В окне диалога "Форматирование ряда данных" вы можете не только изменять значения данных, но и корректировать метки оси ОХ. Для этого нужно выбрать вкладку "Значение X" и внести соответствующие изменения. Во вкладке "Вид" можно изменить стиль, цвет и толщину линий, которыми изображаются на графике ряды данных. Вы можете ввести величину погрешности значений во вкладке "Y-погрешность". Кроме того, вы можете также отформатировать метки данных в соответствующей вкладке.

Изменение данных посредством изменения графика.

В MS Excel вы можете подобрать внешний вид диаграммы и соответствующим образом откорректированную таблицу исходных данных.

Данные в таблице и линии графика связаны между собой. Если вы изменяете данные в таблице, то соответственно изменяются и линии графики. Это совершенно естественно. Но, оказывается, можно поступать и наоборот: вы изменяете линии на графике и соответственно изменяются данные в таблице. Можно увеличивать и уменьшать значения данных ряда без всяких ограничений. MS Excel автоматически растягивает ось OY так, чтобы новое значение ряда не выходило за пределы графика.

Для восстановления информации в режиме редактирования воспользуйтесь Ctrl+Z, но это возможно только тогда, когда вы не успели выполнить еще какие-либо действия. Для удаления диаграммы выполните следующие операции:

1. Выберите диаграмму для удаления

2. Нажмите правую кнопку мыши. Появится меню со списком команд,

3. Выберите из списка команду «Очистить", в результате диаграмма будет удалена с рабочего листа. Для изменения типа диаграммы после ее построения выполните следующие действия:

1. Перейдите в режим редактирования диаграммы. Для этого дважды нажмите на ней кнопку мыши.

2. Нажмите правую кнопку мыши, когда ее указатель находится на диаграмме. Появится меню со списком команд,

3. Выберите команду «Тип диаграммы». Появится окно с образцами доступных типов диаграмм. 4. Выберите тип диаграммы. Для этого нажмите кнопку мыши на соответствующем образце, а затем либо нажмите клавишу Enter, либо дважды нажмите кнопку мыши.

Еще один способ изменения типа осуществляется командой «Автоформат», Эта команда находится в списке, который появляется после нажатия правой кнопки мыши на активной диаграмме. Команда «Автоформат» меняет не только тип диаграммы, но и устанавливает параметры диаграммы, принятые по умолчанию. При нажатии левой кнопки мыши на строке с командой «Автоформат» появляется окно диалога со списком всех типов форматов. Перемещая курсор по списку типов, выбираем нужный вид диаграммы. Дважды нажав кнопку на нужном образце диаграммы, получаем соответствующую диаграмму, в которой все параметры установлены по умолчанию. В частности, изменяются стиль, цвет, толщина линий, расположение заголовка, размеры рабочего поля диаграммы.

В MS Excel можно строить объемные и плоские диаграммы. Всего насчитывается 102 вида различных диаграмм и графиков. Существуют следующие типы плоских диаграмм: линейчатая, гистограмма, с областями, график, круговая, кольцевая, лепестковая, ху-точечная и смешанная. Объемные диаграммы можно строить следующих типов: линейчатая, гистограмма, с областями, график, круговая и поверхность. У каждого типа диаграммы, как у плоской, так и у объемной, существуют подтипы.

Требуемый тип выбирается на шагах 2 и 3 процесса построения. В режиме редактирования диаграмм нужный тип можно выбрать при помощи команды «Автоформат».

Линейчатые диаграммы и гистограммы похожи по внешнему виду и способам представления данных, отличаясь друг от друга в основном ориентацией: в линейчатых диаграммах ось ОХ, или ось меток, располагается вертикально, ось OY - горизонтально; в гистограммах расположение осей обратное. Поэтому из этих двух типов диаграмм более подробно рассмотрим только линейчатые.

Два важных подтипа линейчатой диаграммы заслуживают особого внимания. На левом варианте диаграммы четыре горизонтальных линейки соответствуют четырем столбцам исходных данных. Строкам исходных данных соответствуют цвета закраски отрезков линеек. Диаграмма данного типа строится так, что все линейки имеют одинаковую длину, поэтому диаграмма в целом показывает процентное распределение суммы столбца по строкам. На правом варианте диаграммы линейки также соответствуют столбцам, но все данные изображены в одном масштабе и поэтому длина линеек показывает сумму данных столбца. Линейчатая диаграмма имеет 10 подтипов, из которых вы практически всегда можете выбрать наиболее подходящий вид для графического отображения ваших данных.

Характерной особенностью диаграмм с областями является то, что области, ограниченные значениями в рядах данных, заполняются штриховкой. Величины следующего ряда данных не изменяются по величине, но откладываются от значений предыдущего ряда.

Для определения, какой ряд данных оказывает самое сильное влияние на суммарный итог, нужно поставить поочередно на нижнее место все ряды данных. Для этой цели в окне диалога "Форматирование диаграмм с областями" перейдите на вкладку "Порядок рядов" и выберите кнопку Поместить вниз. Кольцевые диаграммы отличаются от круговых только тем, чем отличается кольцо от круга - наличием в середине пустого пространства. Выбор нужного типа определяется соображениями целесообразности, наглядности и т.д. С точки зрения техники построения отличия отсутствуют. При помощи круговой диаграммы вы можете показать только один ряд данных. Каждому элементу ряда данных соответствует сектор круга. Подтипы круговых диаграмм. На круговых диаграммах вы можете изменять величину отдельного сектора, также как изменяли ранее размеры столбца на гистограмме и расположение линии на графике. Трехмерная графика. В MS Excel трехмерная графика представлена шестью типами трехмерных диаграмм: гистограмма, линейчатый, с областями, графика, круговая и поверхность. Для получения трехмерной диаграммы нужно на втором шаге построения диаграммы выбрать пространственный образец. После пятого шага мы получили трехмерную диаграмму.

К трехмерной диаграмме можно перейти и в режиме редактирования диаграммы. Для этого нужно установить флажок "Объемная" в тех режимах, где изменяется тип диаграммы.

Изменение вида стандартной диаграммы. При нажатии правой кнопки мыши в режиме редактирования диаграммы, в списке команд к существовавшим ранее добавляется еще одна - Объемный вид. При выполнении команды "Объемный вид" появляется окно диалога "Форматирование объемного вида", в котором все пространственные перемещения имеют количественное выражение: поворот, возвышение и перспектива. Эти операции вы можете также выполнить с помощью соответствующих кнопок. Изменить пространственную ориентацию диаграммы можно и не прибегая к команде "Объемный вид".

При нажатии левой кнопки мыши на конце любой координатной оси появляются черные квадратики в вершинах параллелепипеда, содержащего диаграмму. Стоит вам поместить указатель мыши в один из этих квадратиков и нажать кнопку мыши, как диаграмма исчезнет, а останется только параллелепипед, в котором она была расположена. Удерживая кнопку мыши нажатой, вы можете изменять расположение параллелепипеда, вытягивая, сжимая и перемещая его ребра. Отпустив кнопку мыши, вы получаете новое пространственное расположение диаграммы.

В MS Excel можно строить комбинированные типы диаграмм, состоящие из различных типов графиков. Кроме того, вы можете построить диаграмму для одного ряда данных или для типовой группы рядов вдоль другой, вспомогательной оси значений.

Можно комбинировать различные типы только плоских диаграмм. При использовании объемных диаграмм комбинирование невозможно.

Пользовательские форматы диаграмм. Мастер диаграмм форматирует элементы диаграммы всегда стандартным образом для каждого типа и подтипа диаграмм. И хотя в MS Excel встроено 102 подтипа диаграмм, иногда возникает потребность иметь свой, пользовательский формат диаграмм.

По умолчанию при построении диаграммы используется тип "Гистограмма». Термин по умолчанию означают следующее.

После того как на первом шаге построения диаграммы вы указали таблицу данных, нажимаете кнопку «Готово". В этом случае на экране появляется диаграмма по умолчанию, После того как вы определитесь ,какие диаграммы вам нужно строить, имеет смысл изменить установки диаграммы по умолчанию. Существуют два варианта изменения установки по умолчанию: установить текущий вариант гистограммы или заранее записанный пользовательский формат.

Копирование данных из другого приложения Microsoft в Excel

1. Перейдите к документу, содержащему данные для копирования.

2. Выделите ту информацию, которую нужно скопировать в Microsoft Excel.

3. Выберите команду Копировать из меню Правка.

4. Процесс копирования в других приложениях может быть другим. Для получения подробной информации об этой процедуре следует смотреть документацию к приложению.

5. Перейдите к документу Microsoft Excel, предназначенному для вставки скопированных данных.

6. Выделите верхнюю левую ячейку той области, в которую необходимо вставить данные.

7. Из меню Правка или меню быстрого доступа выберите команду Специальная вставка.

8. Выберите формат, в котором должны быть вставлены данные.

Например, текст из Microsoft Word можно вставить в трех различных форматах: как объект Microsoft Word, как изображение и как текст.

9. Нажмите кнопку OK.

Открытие документа, созданного в другом приложении

1. Выберите кнопку Открыть или команду Открыть в меню Файл.

2. Укажите имя файла.

В окне Имя Файла перечисляются файлы того типа, который указан в раскрывающемся списке Тип Файлов. Если нужного типа в списке нет, то выберите параметр Все Файлы или же просто введите полное имя документа в поле Имя Файла.

3. Нажмите кнопку OK.

Если открывается текстовый файл, то Мастер Текста спросит, как разместить текст по столбцам

Печать документа

Предварительный просмотр

При предварительном просмотре на экран выводится изображение документа в том виде, в каком оно получается при печати. Для предварительного просмотра необходимо войти в меню и выбрать Файл -> Предварительный просмотр. Войти в режим предварительного просмотра можно лишь в том случае, если в рабочий лист введен хотя бы один символ. При работе в режиме предварительного просмотра можно выполнять следующие действия:

• просмотр следующей страницы ( предыдущей страницы);

• вывод укрупненного изображения на экран;

• печать;

• настройка параметров страницы;

• показ полей на листе бумаги, ручная корректировка полей;

• возврат в рабочую книгу;

• справка.

Установка параметров страницы

Для установки параметров страницы надо войти в меню и выбрать Файл ® Параметры страницы или Файл ® Предварительный просмотр ® Страница. При этом на экране параметров появится четыре вкладки: Страница, Поля, Колонтитулы и Лист.

Вкладка Страница ориентирует страницу по вертикали, по горизонтали, производит масштабирование, увеличение/уменьшение распечатки в % по отношению к оригиналу.

Вкладка Поле позволяет сделать отступы от края листа до текста, расстояние от края бумаги, расстояние от края листа до колонтитулов, центрирование, горизонтальное/вертикальное расположение. Поля отступа можно быстро изменить в режиме предварительного просмотра: Файл® Предварительный просмотр ® Поля.

Изменить поля отступа можно передвинуть мышью соответствующую ограничительную линию.

Колонтитулы - информация, выводимая над/под текстом каждой печатаемой странице. Чтобы напечатать свои колонтитулы необходимо выбрать Создать верхний колонтитул/ Создать нижний колонтитул. Колонтитулы состоят из трех секций: левой, правой и центральной. Например, верхний колонтитул может содержать название работы - в центре, номер страницы - в правой части, текущую дату - в левой части.

Вкладка Лист дает возможность печатать только выделенную область данных, печатать на каждом листе выделенные строки в виде заголовка, выводить на печать линии сетки, вывести на печать текст примечаний к ячейкам.

Чтобы вывести документ на печать используется командное меню:

Файл ® Печать Появится окно печати, в котором необходимо выбрать принтер для печати, установить признак печати в файл или на принтер, указать количество копий, указать ориентацию страницы. Если необходимо вывести на печать не весь документ, а только выбранные страницы, то надо указать диапазон страниц для печати.