Introduction

The Enhanced IDE/Fast-ATA FAQ

John Wehman (jwehman@got.net) and Peter den Haan (pieterh@sci.kun.nl)

v1.91, 1997/01/23

This FAQ addresses issues surrounding Enhanced IDE, ATA-2, ATAPI and Enhanced BIOSes. It includes practical questions, background information and lists of net resources.

2. Введение

    2.1 EIDE и Fast-ATA
    2.2 IDE и ATA
    2.3 ATA-2
    2.4 ATA-3
    2.5 Пакетный интерфйс ATA
    2.6 Ultra-ATA
    2.7 ATA-4
    2.8 Расширенный BIOS
    2.9 Вторичный порт и другое

3. Общие вопросы

    3.1 Кaковы основные особенности я EIDE и Fast-ATA?
    3.2 Прaвдивы ли слухи об ошибкaх интерфейсa?
    3.3 Что тaкое мегaбaйт?

4. Перед покупкой...

    4.1 Что должен иметь интерфейс ATA-2 (Fast-ATA, EIDE)?
    4.2 Является ли BIOS, которым я пользуюсь, рaсширенным? Кaк мне это устaновить?
    4.3 Совместимa ли моя системa 50MHz с шиной VL с интерфейсaми ATA-2?
    4.4 Совместимы ли стaрые дисководы IDE с интерфейсaми ATA-2 (EIDE)?
    4.5 Могу ли я использовaть дисководы EIDE и Fast-ATA со стaрым интерфейсом IDE?
    4.6 Будет ли ATAPI (EIDE) CD-ROM рaботaть с интерфейсом IDE?
    4.7 Нужно ли обновлять BIOS для подключения ATAPI CD-ROM?
    4.8 Могут ли дисководы большого объемa использовaться со стaрым BIOSом?
    4.9 Мне нужен рaсширенный BIOS для доступa к диску емкостью >504MB. Кaк мне это сделaть?
    4.10 Могу ли я использовaть большие жесткие диски с кaкими-либо другими оперaционными системaми, кроме DOS/Windows?
    4.11 Мне скaзaли, что Win95 поддерживaет большие диски IDE.
    4.12 Могу ли я использовaть больше 2 или 4 жестких дисков?
    4.13 Поддерживaет ли <встaвьте нaзвaние оперaционной системы>ATAPI (IDE) CD-ROM?
    4.14 Мне нужен интерфейс PCI ATA-2, которому требуется только один слот.
    4.15 Поможет ли устaновкa интерфейсa 'EIDE' увеличить производительность моего дисководa?

5. Устaновкa

    5.1 Кaкой дисковод/устройство должен рaботaть в кaчестве Slave?
    5.2 Имеет ли знaчение, кaк подключaть устройствa к кaбелю?
    5.3 Будет ли стaрый HD или CDROM зaмедлять рaботу нового дисководa?
    5.4 Мне нужен более длинный кaбель IDE; нaсколько длинным он может быть?
    5.5 Могу ли я без опaсений перестaвить жесткий диск с компьютерa нa компьютер?

6. Конфигурaция

    6.1 Нaдо ли мне использовaть интерфейсные дрaйверы устройств?
    6.2 Чем мне пользовaться - Normal, LBA or Large?
    6.3 Могу ли я без опaсения изменить режим трaнсляции BIOS (None, LBA, Large)?
    6.4 Следует ли мне рaзрешaть режим упрaвления шиной EIDE в BIOS?
    6.5 FDISK видит только 504MB моего дискa!
    6.6 FDISK устaнaвливaет рaзделы только в пределaх 2GB.
    6.7 Хотя у меня нет модного EBIOS, но рaздел величиной в 1GB устaновлен и рaботaет.
    6.8 У меня есть прогрaммы, позволяющие преодолеть огрaничение 504MB. Следует ли мне им пользовaться?
    6.9 Можно ли сохрaнить рaзделы Disk Manager / EZDrive с новым BIOSом?
    6.10 Мне нaдо удaлить Disk Manager/EZDrive.
    6.11 Я могу рaзрешить кэшировaние зaписи нa жесткий диск. Нaдо ли это делaть?
    6.12 Идентификaторы, относящиеся к дисководу, изменились!

7. Производительность

    7.1 Почему мой дисковод рaботaет не тaк быстро, кaк обещaет реклaмa?
    7.2 Почему мой новый интерфейс EIDE рaботaет не быстрее, чем стaрый интерфейс VLB?
    7.3 Я тестирую мой дисковод и вижу, что он нaчaл рaботaть медленнее!
    7.4 Один пaрень из сети имеет тaкой же дисковод и рaботaет нa 16MB/s!
    7.5 Дрaйверы упрaвления шиной не дaют большого эффектa...

10. ATA: жесткие диски

    10.1 Кaк рaботaет ATA(-2)?
    10.2 Что предстaвляют собой режимы PIO?
    10.3 Что предстaвляют собой режимы DMA?
    10.4 Кaк нaзнaчaются порты вводa-выводa ATA(-2,PI)?
    10.5 Что делaет интерфейс ATA-2?
    10.6 Что тaкое блочный режим?
    10.7 Что тaкое LBA?
    10.8 Кaк рaботaет зaщитa?
    10.9 Что тaкое S.M.A.R.T.?
    10.10 Что тaкое PRML?
    10.11 Что тaкое головки MR?

11. ATAPI: CD-ROM и ленточные нaкопители

    11.1 Чем ATAPI отличaется и кaк сосуществует с ATA(-2)?
    11.2 Что особенного во вторичном порте?


Introduction

Введение

Содержание этой главы

Цель данного введения - ознакомить Вас с наиболее важными общеупотребительными терминами, использованными в этом справочнике, и дать краткое описание рассматриваемых вопросов. Чтобы правильно усвоить информацию, содержащуюся в этом справочнике, начните отсюда.

2.1 EIDE и Fast-ATA

Область IDE претерпела множество изменений в течение последнего года или двух. Эти нововведения известны под названием усовершенствованной технологии IDE (EIDE). Однако Вам следует знать, что EIDE - это просто маркетинговый проект Western Digital и, в свою очередь, основывается на двух настоящих стандартах - ATA-2 и ATAPI. Технология Fast-ATA, предложенная Seagate и одобренная Quantum в ответ на маркетинговый проект WD, имеет такой же характер. Она основана только на стандарте ATA-2.

2.2 IDE и ATA

IDE (Integrated Drive Electronics - интегрированная схема управления дисководом - термин, имеющий множество других интерпретаций) и ATA (дополнение к AT) - представляют собой одно и то же, а именно конструкцию жесткого диска, в которой контроллер объединен с дисководом, что позволяет снизить стоимость интерфейса и делает микропрограммы более простыми. Эта простая и дешевая технология интеграции породила бум в области производства дисководов, поскольку производители комплексов РС охотно приняли этот дешевый способ. С конца 80-х годов АТА (правильное название этой технологии) стала удачной альтернативой для покупателей, озабоченных вопросом стоимости.

2.3 ATA-2

Когда стало понятно, что усовершенствование технологии жестких дисков и повышенные требования, предъявляемые программным обеспечением, будут постоянно увеличивать нагрузку на интерфейс АТА, промышленностью, представленной в данном случае комитетом Small Form Factor (SFF), был создан совместимый с АТА модернизированный стандарт под названием ATA-2. Этот стандарт включает не только быстрые режимы PIO и DMA, но и улучшенный вариант команды 'Identify Drive'. В результате дисковод теперь выдает программам намного более точную информацию о своих характеристиках, что особенно важно как для сопряжения Plug'n'Play, так и для совместимости с возможными будущими уточнениями стандарта.

Наличие нового способа адресации секторов жесткого диска (LBA) означает ее упрощение. Вопреки распространенной легенде, для LBA не является проблемой знаменитый барьер в 504MB (528 миллионов байт). На самом деле предел емкости даже прежнего стандарта ATA/IDE существенно выше 100GB.

2.4 ATA-3

Последней версией стандарта является ATA-3. К его основным особенностям относятся: повышенная надежность, особенно в режиме PIO mode 4; простая парольная схема защиты; более совершенное управление мощностью и технология самоконтроля и оповещения (Self Monitoring Analysis and Report Technology - S.M.A.R.T.), позволяющая дисководу предупредить пользователя о возможных ошибках определенного типа.

ATA-3 не предусматривает введения более быстрых режимов работы. Хотя производители и рекламируют оборудование для "mode 5", более вероятно, что параметры режима PIO никогда не превзойдут параметры ATA-2 PIO mode 4.

2.5 Пакетный интерфейс АТА

Одним из недостатков ATA является то, что этот стандарт был разработан исключительно для жестких дисков. Это было хорошо в то время, когда хороший компьютер поставлялся только с гибкими дисками и с жестким диском на 40MB; сейчас, когда CD-ROM и ленточный магнитофон являются обычными устройствами, было бы лучше, если бы все устройства работали на одном недорогом интерфейсе. Пакетный интерфейс ATA (ATAPI) - это стандарт, разработанный для устройств типа CD-ROM и ленточных магнитофонов, которые включаются в обычный порт ATA (IDE).

Основными преимуществами оборудования ATAPI являются его низкая стоимость и возможность работы на любом компьютере, имеющем адаптер IDE или 'EIDE'. Ленточные устройства ATAPI имеют намного более высокое качество и надежность, чем распространенные "гибкие" ленточные устройства QIC117.

Помните, что, хотя устройства ATAPI включаются в интерфейс IDE, они существенно отличаются от жестких дисков IDE. Контроллеры кэш-памяти и другие развитые интерфейсы не будут работать, если они не настроены именно на ATAPI. Загрузка с ATAPI CD-ROM возможна только в последних версиях BIOS.

2.6 Ultra-ATA

Стандарт Ultra-ATA похож на Ultra-SCSI в том смысле, что заполняет разрыв между существующим (ATA-3) и будущим стандартом, который находится в процессе подготовки. В Ultra-ATA добавляется новый быстродействующий режим DMA/33 с пропускной способностью, равной 33MB/s, что в два раза выше, чем в режиме DMA mode 2. Насколько мне известно, ни один из имеющихся в продаже интерфейсов этого режима не поддерживает, но в течение ближайших месяцев положение должно измениться (схемы VIA Apollo VP1 и VP2, как и будущие комплекты Intel и новые схемы контроллеров от CMD и остальных, поддерживают этот режим).

2.7 ATA-4

Уже начата работа над новым стандартом, предварительно названным ATA-4. Основной его целью прежде всего является объединение ATA-3 и ATAPI. Конечно, на повестке дня имеются также быстрые режимы передачи данных: стандарт будет как минимум включать Ultra-ATA DMA/33.

Если говорить о других свойствах, то будущее глубокого перекрытия команд представляется довольно мрачным: в нынешнем виде это ужасный монстр, и серьезные игроки наподобие Microsoft не планируют его поддержку в его нынешней форме. Более ограниченные схемы перекрытия имеют, вероятно, больше шансов на выживание.

2.8 Расширенный ВIOS

Совершенно особым моментом является ограничение емкости диска 504 Mбайтами (или, что то же самое, 528 миллионами байт), проявляющееся при адресации дисководов IDE посредством BIOS. Это ограничение является следствием геометрии диска (цилиндры, головки, сектора), которая поддерживается сочетанием дисковода IDE и интерфейса программ BIOS ('int13'). И IDE/ATA, и BIOS способны поддерживать диски большой емкости, но их общие ограничения заставляют ограничить полезную емкость диска 504 Mбайтами. Поскольку только MSDOS все еще использует BIOS для доступа к жестким дискам, это ошибочно считается ограничением MSDOS; другие системы, однако, при загрузке подвергаются таким же ограничениям.

Расширенный BIOS решает эту проблему, представляя геометрию диска для программного обеспечения не такой, какова она на самом деле. Этот фокус называется 'трансляцией'. Если Ваш диск имеет, например, 1500 цилиндров и 16 головок, BIOS-транслятор может подменить эти значения для программного обеспечения 750 цилиндрами и 32 головками.

Вам не потребуется адаптер "EIDE" для использования жестких дисков емкостью более 504MB.

Существующий стандарт описан в документе Microsoft/IBM "Расширения INT 13". Фирма Phoenix представила расширенный вариант в спецификации "Расширенный BIOS Phoenix". BIOSы Phoenix, AMI, Award и MR построены на основе спецификации Microsoft/IBM. Некоторые более старые BIOSы построены на основе "Руководства Western Digital по реализации расширения IDE". Жесткие диски, отформатированные с использованием таких BIOSов, могут не читаться в других системах.

2.9 Вторичный порт и другое

Последним, но от этого не менее важным обстоятельством является то, что обычное ограничение на подключение не более двух устройств является значительно более серьезным в том случае, когда CD-ROM и ленточные накопители подключаются к интерфейсу IDE вместе с жестким диском (дисками). К счастью, есть решение этой проблемы в виде так называемого вторичного интерфейса жесткого диска. Такой интерфейс можно было сделать уже давно, но не существовало поддержки.

Во вторичном канале нет ничего особенного; это обычный порт (E)IDE, использующий другое прерывание и другие адреса ввода-вывода, чтобы избежать конфликтов с обычным (первичным) портом. Вторичный интерфейс позволяет подключить еще один кабель с двумя устройствами ATA (жесткий диск, ATAPI CD-ROM или ленточный накопитель ATAPI). В настоящее время во многих интерфейсах используется сочетание первичного и вторичного портов на одной карте, которая образует двойной (dual-ported) интерфейс, поддерживающий до четырех устройств.

Для того, чтобы пользоваться жестким диском, установленным на вторичном порте, в системах DOS и Windows 3.x, требуется поддержка BIOS (системного BIOS или адаптерного BIOS) или драйвера. Вы может узнать BIOS, способный поддерживать четыре устройства, по тому, что его установки позволяют задать четыре набора параметров устройства.

Имеются еще два (полу-)стандартных канала, более современных, чем вторичный пор, это тройной и четвертной порты. Некоторые IDE-интерфейсы звуковых карт могут быть сконфигурированы как тройные и четверные. Соответствующие установки I/O и IRQ можно найти в разделе 10.4. Программная поддержка этих портов - вещь достаточно редкая.

Следующая глава

Содержание этой главы, общее оглавление

Начало документа, начало этой главы


General questions

3 Общие вопросы

3.1 Каковы основные особенности EIDE и Fast-ATA?

Краеугольным камнем Fast-ATA и EIDE являются режимы быстрой передачи данных (PIO mode 3 и 4, multiword DMA mode 1 и 2). Эти названия - торговые марки, придуманные производителями дисководов. Enhanced IDE - это торговая марка Western Digital; Fast-ATA - термин, предложенный Seagate и поддерживаемый Seagate и Quantum.

EIDE включает:

  • режимы быстрой передачи данных: PIO mode 3 и выше, multiword DMA mode 1 и выше,
  • режим LBA (описанный в разделе 10.7 ),
  • четыре устройства на интерфейсе ATA, т.е. вторичный порт,
  • отсутствие ограничения в 504MB для DOS, т.е. усовершенствованный BIOS WD,
  • ленточный накопитель и CD-ROM на интерфейсе ATA, т.е. ATAPI.

Fast-ATA и Fast-ATA-2 включают:

  • PIO mode 3 (и 4 для Fast-ATA-2), режим одновременной передачи DMA mode 1 (и 2 для Fast-ATA-2),
  • команды многократного чтения/записи (известного также как блочный режим; см. Q 10.6 ),
  • режим LBA.

Различие между этими двумя схемами состоит в основном в сфере действия EIDE. Оборудование может именоваться 'EIDE' даже в том случае, если оно выполняет только часть функций EIDE; это может приводить к путанице. Данный справочник обходит термин EIDE, где только возможно, вместо этого описывая его компоненты (ATA-2, ATAPI и т.п.). Такая структура позволит Вам точно определить, какие свойства 'EIDE' нужны Вам в Вашей конкретной ситуации.

3.2 Правдивы ли слухи об ошибках интерфейса?

К сожалению, совершенно правдивы.

Этот справочник не предназначен для изучения особенностей конкретных интерфейсов; однако в двух очень популярных интерфейсных микросхемах были выявлены ошибки, которые слишком серьезны для того, чтобы можно было не обращать на них внимания:

  • CMD640x, двухканальный интерфейс между PCI и EIDE, используемый на многих материнских платах (Intel!) и интерфейсных картах, содержит ряд серьезных ошибок, о которых Вам следует знать.
  • PC-Tech RZ-1000, используемый на картах AT&T, Dell, Gateway и Intel, также содержит две ошибки, ведущие к искажению данных. См. также http://www.intel.com/procs/support/rz1000/index.htm.

В обоих случаях искажения проявляется только в специфических программных продуктах и является очень мало заметными; Вы можете работать в течение месяцев, не подозревая о наличии каких-либо ошибок, кроме программных. Ущерб может оказаться огромным. Подробности можно найти в справочнике Roedy Green ( mailto:roedy@bix.com) "Дефекты контроллера PCI EIDE" с его тестом EIDE , который поможет выявить возможные ошибки в Вашей системе.

ПОМНИТЕ, что Вы играете в русскую рулетку, работая на поврежденном компьютере и не обращая внимания на эту проблему.

3.3 Что такое мегабайт?

Слово "мега" - это приставка системы ISO, означающая коэффициент, равный 1000000. Точная величина мегабайта - 1000000 байт. Поскольку компьютеры используют двоичную систему и работают со степенями двух, то 20 разрядов, составляющие 1048576 байт, обычно также называются мегабайтом.

Какой мегабайт имеется в виду, зависит от контекста. Для устройств памяти мегабайт обычно означает 1000000 байт. В некоторых программах, однако, используются "двоичные" мегабайты, и поэтому эти программы показывают несколько меньшую емкость диска, чем указано на этикетке устройства. К таким программам относится большинство BIOSов..

Данный справочник везде использует мегабайт, равный 1048576 байт.

Следующая глава, предыдущая глава


Before buying...

4 Перед покупкой...

Содержание этой главы

4.1 Что должен иметь интерфейс ATA-2 (Fast-ATA, EIDE)?

Есть несколько характеристик интерфейса 'EIDE', присутствие которых желательно. Однако часть из них может уже быть реализована в Вашем компьютере, а некоторые из них могут быть Вам не нужны.

  • Интерфейс ATA-2 должен, как минимум, обеспечивать передачу данных в режиме PIO mode 3 (до 11.1MB/s) с теми дисководами, которые этот режим поддерживают. Он должен также поддерживать более медленные режимы PIO (0, 1 и 2) для совместимости со старыми дисководами. Истинный прямой доступ к памяти (DMA) обычно имеется только у интерфейсов, объединенных с материнской платой, самым распространенным примером которых являются платы на основе Intel Triton (430*X). Эта особенность позволяет увеличить производительность многозадачных операционных систем.
  • Поскольку ATAPI CD-ROM быстро приобретают популярность на рынке товаров потребительской категории, а цены на ленточные стримеры ATAPI падают, то вторичный порт, позволяющий подключить четыре устройства ATA*, перестает быть роскошью. Заметим, что только немногие из современных звуковых карт поддерживают вторичный или третичный интерфейс ATA/IDE вместо традиционных собственных подключений CD-ROM. Будьте внимательны, чтобы избежать конфликтов при работе с двухпортовым интерфейсом. Если Вы собираетесь использовать с DOS или Windows 3.x жесткие диски, подключенные ко вторичному порту, помните, что многие старые BIOSы не поддерживают вторичное подключение и что многие из интерфейсов не работают с требуемыми драйверами.
  • Вам может также понадобиться расширенный BIOS, установленный на карте, если BIOS на материнской плате не поддерживает трансляции или если эта поддержка содержит ошибки или является устаревшей. Интерфейсный BIOS перекрывает программы работы с жестким диском, входящие в BIOS на материнской плате. BIOS ROM, как и материнская плата со встроенным интерфейсом EIDE, имеет дополнительное преимущество, состоящее в том, что не нужно использовать отдельные драйверы DOS. Однако BIOS на интерфейсе занимает от 8 до 16k пространства UMB, и любая другая операционная система, кроме DOS, все равно будет нуждаться в драйверах.
  • Драйверы! Без правильно написанных драйверов большинство интерфейсов будут по-прежнему устаревшими картами ISA. Даже если карта имеет BIOS, что обычно избавляет от необходимости иметь драйвер DOS, драйверы для других операционных систем, включая Windows и Win95, все равно будут нужны. К сожалению, очень многие драйверы работают нестабильно.

Заметим, что некоторые популярные интерфейсы 'EIDE' содержат ряд или множество ошибок. Диапазон ошибок простирается от незначительных проблем согласования с интерфейсом ATA-2 до малоизвестных обстоятельств типа использования одного и того же буфера для первичного и вторичного каналов или плохо спроектированного буфера предварительной выборки, которые в некоторых специальных случаях могут вызвать искажение данных. Кроме раздела информации по аппаратному обеспечению, почитайте раздел comp.os.os2.bugs .

4.2 Является ли BIOS, которым я пользуюсь, расширенным? Как мне это установить?

Хороший вопрос.

К сожалению, простого ответа я не знаю. Возможность задания более чем 1024 цилиндров в установках BIOS - не показатель. Параметры типа "LBA", "ECHS" или даже что-нибудь простенькое наподобие "Large" в установках BIOS, относящихся к дискам, показывают, что BIOS поддерживает трансляцию, что является важным для дисков емкостью до 8GB. С другой стороны, если проставлена дата выпуска ранее 1994 года, то вероятность того, что BIOS будет расширенным, практически равна нулю :-(

  • Что касается AMI, то надежная информация у меня имеется только по HiFlex BIOS; его можно опознать по характерной унылой оранжево-зеленой схеме. Есть еще как минимум две модели: WinBIOS с Windows-подобным интерфейсом и обычный BIOS, используемый с картами Intel Pentium. Обе эти модели могут поддерживать трансляцию, даже если они имеют (намного) более раннюю дату выпуска. По этому вопросу у меня нет никакой другой информации. AMI HiFlex BIOSы, выпущенные 7-25-94 или позже, поддерживают трансляцию. Дата содержится в длинном номере, появляющемся в нижней части экрана при загрузке; LBA поддерживается моделями, на которых показана дата 072594 или более поздняя.
    40-0100-00101111-111192-486-ABC-F (111192 поддерживаетLBA)
    50-0100-001292-00101111-072594-ABCDEF-F (072594 не поддерживаетLBA)
  • Award, предположительно, называет все свои BIOSы 4.50G :-) Некоторые из них поддерживают трансляцию, другие - нет, некоторые ее поддерживают неправильно). BIOS, датированный 12/31/1994 или более поздним числом, обеспечивает полную поддержку трансляции, а более ранние (7/29/1994 и, возможно, еще более ранние) содержат ошибки.
  • Phoenix BIOS v4.03 и более поздние описываются как поддерживающие трансляцию. Однако некоторые версии Phoenix v4.03, в зависимости от производителя системной платы, могут этого и не обеспечивать.
  • BIOS-интегрированные CHS MR с трансляцией примерно такого же типа, как современный режим Large - не ранее 1990!

Заметим, что только BIOS, полностью реализующий стандарты IBM / Microsoft / Phoenix, обеспечивает адресацию дисков с емкостью больше 8GB. К счастью, это становится все более обычным делом. Нам не известны программы, которые определяли бы наличие такого BIOS.

У компании Western Digital имеется программа, доступная через ftp, которая проверяет наличие Enhanced Disk Parameter Table (EDPT). Если эта таблица найдена, следовательно, Ваш BIOS имеет все необходимые признаки того, что он может работать с дисками емкостью до 8GB ftp://ftp.wdc.com/drivers/hdutil/chkbios.exe. Помните, что BIOSы, соответствующие спецификации WD Enhanced BIOS, не формируют EDPT, пока не разрешен режим LBA. Помните также, что при работе с WD EBIOS крайне небезопасно устанавливать LBA на диске, который уже содержит данные. Причиной этого является дефект в спецификации.

4.3 Совместима ли моя система 50MHz с шиной VL с интерфейсами ATA-2?

Возможно, однако бывают сомнительные случаи.

Известно, что циклы ввода-вывода некоторых контроллеров базируются на таймере шины компьютера. Это означает, что у шины с тактовой частотой 50MHz время цикла будет меньше, чем у шины с 33MHz. Это может привести к непредсказуемым последствиям в том случае, если время цикла меньше, чем время, которое поддерживается дисководом. Проверьте, есть ли варианты задания значений в установках скорости шины и, если надо, установите ее правильно.

4.4 Совместимы ли старые дисководы IDE с интерфейсами ATA-2 (EIDE)?

Да, должны быть совместимы.

Старые дисководы не поддерживают современные высокоскоростные режимы передачи данных, определяемые стандартом ATA-2. Для совместимости со старыми дисководами интерфейсы ATA-2 имеют программируемую установку временных параметров. Драйвер или BIOS опрашивает дисковод на предмет его максимальной скорости передачи и в соответствии с ней конфигурирует интерфейс. Некоторые интерфейсы конфигурируются с помощью перемычек; в этом случае за результат отвечаете Вы.

Установка режима PIO mode 3 вслепую, использование быстрого режима со старым дисководом без запроса значения поддерживаемой скорости передачи может привести к повреждению данных, к зависанию дисковода и вообще вызвать массу последствий.

Если Вы планируете подключить старый дисковод к тому же кабелю, что и дисковод ATA-2, Вам следует проверить, допускает ли Ваш интерфейс независимую установку временных параметров для устройств master и slave. В противном случае Ваш старый дисковод может замедлить работу нового, поскольку контроллер вынужден будет настраиваться на скорость более медленного устройства.

4.5 Могу ли я использовать дисководы EIDE и Fast-ATA со старым интерфейсом IDE?

Устройства Fast-ATA и EIDE можно без опасения использовать со стандартными контроллерами ISA и VLB IDE. Смысл быстрых режимов в том, что подготовка дисковода для передачи данных происходит быстрее; чем медленнее контроллер, тем легче с ним работать дисководу. Конечно, следует ожидать, что скорость передачи будет меньше, чем в случае полноценного интерфейса ATA-2.

Использование интрефейса EIDE для жестких дисков емкостью более 504MB не является обязательным. Расширенный BIOS - это все, что нужно для работы с DOS и Windows; для многих других операционных систем, таких, как OS/2 или Linux, даже это не нужно.

4.6 Будет ли ATAPI (EIDE) CD-ROM работать с интерфейсом IDE?

Да. Эти устройства с самого начала проектировались так, чтобы обеспечить совместимость с ATA (IDE), и будут работать нормально.

4.7 Нужно ли обновлять BIOS для подключения ATAPI CD-ROM?

Нет. Эти CD-ROM снабжаются драйвером, обеспечивающим полную поддержку. BIOSу не нужно их поддерживать и обычно даже знать, что они присутствуют. Некоторые современные BIOSы распознают ATAPI и имеют специальные установки; за исключением таких случаев, соответствующий вход для жесткого диска можно задавать как 'Not Installed'.

4.8 Могут ли дисководы большого объема использоваться со старым BIOSом?

В принципе да, но остается все же небольшая проблема предельной емкости, равной 504MB. Если емкость нового дисковода выходит за этот предел, то для использования более чем 504МВ с DOS, Windows и Win95 (см. соображения по поводу других операционных систем в разделе 4.10 ) Вам понадобится расширенный BIOS. Важно помнить, что эта проблема касается только программного обеспечения; специальный интерфейс для поддержания больших дисководов не требуется .

ПОМНИТЕ, что некоторые старые BIOSы неправильно работают с дисками, имеющими более чем 1024 цилиндров. Вместо того, чтобы урезать число цилиндров до 1024, они считают число цилиндров по модулю 1024, что означает, что дисковод с 2300 цилиндрами будет рассматриваться как имеющий только 252 цилиндра. Для решения этой проблемы надо в установках BIOS указать 1024 цилиндра.

Если BIOS с такой ошибкой не допускает ручной установки параметров, это может стать серьезной проблемой. В системах IBM этот дефект имеют PS/2 моделей 35sx и 40sx 1991 года выпуска, ValuePoint I и как минимум некоторые из моделей ValuePoint Si. Если Вы работаете с таким компьютеров с неправильным BIOSом, Вам надо либо обновить BIOS посредством загрузки с ftp://ftp.pcco.ibm.com/, либо убедиться, что дисковод, который Вы собираетесь использовать, позволяет имитировать наличие не более чем 1024 цилиндров (Western Digital поставляет для своих дисководов емкостью 540MB специальную программу, а многие из дисководов Maxtor имеют переключатель). Имеются также сообщения о Promise EIDEMax, позволяющем использовать дисководы емкостью до 8GB. Заметим, что некоторые операционные системы, такие, как Linux и OS/2, позволяют менять информацию о геометрии дисковода в BIOS, что также помогает решить эту проблему. Другой вариант - использование OnTrack Disk Manager версии 7.

4.9 Мне нужен расширенный BIOS для доступа к диску емкостью >504MB. Как мне это сделать?

Для этого есть следующие возможности: новый BIOS на материнской плате, дополнительный BIOS и программное обеспечение.

  • Обновление BIOS на материнской плате посредством использования новой версии или специально разработанного BIOS производства таких фирм, как Microid Research (MR BIOS), является, наверное, самым лучшим вариантом. Может быть, целесообразно будет заменить материнскую плату целиком и получить все последние усовершенствования за дополнительные $100.
  • Следующий вариант - покупка карты с дополнительным BIOSом, который замещает часть BIOS на материнской плате, относящуюся к жесткому диску. Примером такой карты является LBA Pro фирмы Storage Technologies, продажа которой в США производится Unicore software, или AMIDisk Extender фирмы AMI. DataTechnology (DTC) также продает подобные карты.
  • Большинство BIOSов на интерфейсах ATA-2, если они есть, также позволяет это сделать. Такой способ может оказаться полезным в том случае, если имеющийся у Вас интерфейс не особенно хорош. Есть несколько интерфейсов "EIDE" для шины ISA, содержащих BIOS; примерами являются Promise EIDEMax и SIIG IDE Enhancer.

Так или иначе, Вам придется разделить и отформатировать (большой) жесткий диск заново.

  • Последний вариант - это использование программного обеспечения наподобие Disk Manager или EZDrive. Программы часто поставляются бесплатно вместе с дисководом и относительно просты в установке, но имеют внутренние дефекты. См. также раздел Q 6.8 .

4.10 Могу ли я использовать большие жесткие диски с какими-либо другими операционными системами, кроме DOS/Windows?

Использование больших жестких дисков обычно не представляет проблемы, даже если у Вас нет расширенного BIOSа. Однако некоторые операционные системы не понимают трансляцию, что делает проблематичной совместимость с DOS, Windows и Win95.

Для работы в операционных системах типа NetWare, Unix, Win/NT и OS/2 Вам для использования больших дисков АТА потребуется только BIOS, допускающий задание более чем 1024 цилиндров при установке типа дисковода. Есть только одна тонкость: BIOS прежде всего используется для запуска системы, поэтому следует убедиться, что все необходимое для работы операционной системы размещается на цилиндрах с номерами до 1024. Помните, что в случае использования расширенного BIOSа дисководы емкостью до 8GB будут восприниматься как имеющие не более 1024 цилиндров, поэтому в этом случае указанное ограничение на загрузку снимается.

Будучи запущенными, эти операционные системы используют для управления дисками собственное программное обеспечения (Win95 тоже это делает, однако эта система стоит особняком; см. ниже). Поэтому для них не имеют значения такие ограничения BIOS, как предельная емкость. К сожалению, это также означает, что, если Вы пользуетесь EBIOS или драйвером с трансляцией, операционная система должна знать, какая схема трансляции используется; в противном случае между операционной системой и DOS/Win/Win95 возникают конфликты. Если Вам удастся установить разделы так, чтобы все области DOS и загрузки располагались в пределах первых 1024 цилиндров (504MB), то Вы сможете вообще обойтись без трансляции и всех связанных с ней конфликтов.

Старые операционные системы вообще не воспринимают трансляцию. Более современные (OS/2 3.x, Linux 1.2 и выше, Win95, SCO 5.0.x) воспринимают стандартные схемы трансляции, но не понимают специальных схем, реализованных в ряде драйверов (EZDrive, Disk Manager v6.x или более ранний). В случае DM 6 возможны исправления и усовершенствования для некоторых операционных систем (см. ниже).

У Novell имеется драйвер NetWare IDE.DSK версии 3.0, датированный 2сентября 1994г. Эта версия драйвера использует для получения параметров дисковода команду Identify Device ATA, игнорируя параметры, установленные в BIOS. Из этого следует, что Novell в настоящее время поддерживает операции с большими дисками IDE.

И последнее замечание: в OS/2 поддерживается принцип совместимости с DOS по разделам FAT. Это означает, что при отсутствии расширенного BIOSа только разделы HPFS могут перейти границу 1024-го цилиндра.

4.11 Мне сказали, что Win95 поддерживает большие диски IDE.

Это правда, но это не обязательно означает, что Вы действительно в любом случае сможете это использовать.

Несмотря на большое количество серьезных изменений, в смысле методов управления жесткими дисками Win95 очень похожа на Windows for Workgroups. Как OS/2, Linux и другие операционные системы, Win95 использует драйверы жестких дисков в 32-битном защищенном режиме (если не работает в режиме совместимости) и имеет возможность поддержки жестких дисков приличной емкости - существенно за 100GB. Однако, в отличие от OS/2 и Linux, Win95, подобно Windows for Workgroups, производит загрузку все с той же старой системы DOS, которая так сильно нам не нравится, Даже когда Win95 уже загружена, DOS никуда не девается. Win95 всегда оставляет ее за кулисами и использует для управления устройствами в режиме совместимости. В "безопасном режиме", используемом для поиска неисправностей, Win95 полностью опирается на DOS.

Все это означает, что, хотя драйвер диска для защищенного режима Win95 и может работать с громадными дисками, он не может изменить установки, унаследованные им от DOS для совместимости с последней. Если при работе в DOS Вам доступны только первые 504MB Вашего диска, то же самое будет происходить и при работе в Win95. Вы по-прежнему должны будете искать способы для решения проблемы емкости > 504MB, которые уже обсуждались ранее. Подробности можно найти также в статье Microsoft KnowledgeBase Q126855, "Поддержка больших жестких дисков IDE в Windows 95".

Однако для дисководов, не поддерживаемых BIOS (например, подключенных через вторичный канал или установленных в BIOS как "Not installed"), а также для некоторых других дисководов, это все еще является мечтой. FDISK, поставляемый с Win95, тоже для этого не годится. Подробности смотрите на этой странице.

4.12 Могу ли я использовать больше 2 или 4 жестких дисков?

При работе в DOS и Windows Вам может понадобиться поддержка BIOS для всех Ваших дисков. Старые BIOSы поддерживают только дисководы, подключенные через первичный канал, т.е. не более двух; новые обеспечивают поддержку также и вторичного канала, т.е. в целом поддерживают четыре дисковода. Очень немногие BIOSы поддерживают большее число дисководов; исключением является MR BIOS.

Если BIOS поддерживает только два дисковода, а Вам нужно больше, можно решить эту проблему с использованием программного обеспечения для 3 дисководов. Некоторые интерфейсные карты также поставляются с необходимой поддержкой. У Creative Labs есть драйверы для CD-ROM на третичном и четверичном портах.

Другие операционные системы, например, Win95 и OS/2, поддерживают как первичный, так и вторичный интерфейс без помощи BIOS. Linux поддерживает почти любое число интерфейсов; нужно только передать параметры для задания более чем двух дисководов ядру операционной системы.

4.13 Поддерживает ли <вставьте название операционной системы> ATAPI (IDE) CD-ROM?

Современные версии большинства операционных систем поддерживают ATAPI CD-ROM. Сюда входят OS/2 3.0, Linux 1.2 и выше и Win95.

К сожалению, производители аппаратных средств начали разработку устройств CD-ROM, когда стандарт ATAPI был еще в процессе развития, поэтому сейчас имеется несколько вариантов таких устройств. Более того, сложность и новизна ATAPI приводит к некоторым различиям даже в пределах одного варианта. Поэтому написание системных драйверов ATAPI, работающих со всеми CD-ROM, - это устрашающая задача, и не все из них получаются одинаково хорошими. Таким образом, хотя все эти операционные системы и поддерживают ATAPI, они работают не со всем оборудованием ATAPI.

См. подробности по поддержке Win95 в Q131499 "Дисководы CD-ROM, требующие драйверов реального времени" Microsoft KnowledgeBase. Информацию по OS/2 можно найти в описании http://www.austin.ibm.com/pspinfo/os2hw.html; последние версии драйверов можно найти на установочных дисках для Upgrade или на ftp://ftp.pc.ibm.com/pub/os2_drivers/atapi.zip.

4.14 Мне нужен интерфейс PCI ATA-2, которому требуется только один слот.

Возникают проблемы с PCI и IDE-интерфейсами multi-I/O или с двойным портом. Такие интерфейсы требуют двух или более заранее заданных прерываний, которые не могут разделяться другими устройствами PCI, а это, скорее всего, не удастся сделать на слотах PCI. Обычным способом решения этой проблемы является либо интеграция функций ввода-вывода с системной платой, либо использование небольшой "переходной" карты, вставляемой в слот ISA.

Это является не столько дефектом конструкции PCI, сколько результатом конфликта между концепцией plug'n'play PCI и требованием полной совместимости этих интерфейсов с устаревшими картами ввода-вывода.

Некоторые поставщики используют интерфейсы PCI на базе собственного расширения шины PCI. Конечно, в этих случаях замена невозможна; часто нельзя даже переставить карту в другой слот на одном и том же компьютере. Более того, такое расширение может вызвать трудности с совместимостью, поскольку при этом используются сигналы PCI, зарезервированные для других целей.

4.15 Поможет ли установка интерфейса 'EIDE' увеличить производительность моего дисковода?

Может быть, да, а может быть, и нет; можно примерно оценить, увеличится ли от постановки нового интерфейса реальное быстродействие.

Поставщикам и продавцам аппаратного обеспечения хотелось бы, чтобы все бросились покупать новое поколение адаптеров 'EIDE'. Чтобы добиться этой благородной цели, они жонглируют значениями быстродействия, которые слишком хороши для того, чтобы быть верными. Соответствие между этим рекламным шумом и реальной действительностью является в лучшем случае шатким.

Основным моментом, о котором нужно помнить, является то, что медленный дисковод - это медленный дисковод, независимо от того, насколько хорош интерфейс. Если скорость, с которой дисковод физически передает данные на/с физического носителя, является фактором, ограничивающим быстродействие, то зачастую единственным способом существенного улучшения быстродействия является покупка более совершенного дисковода. Заметим, что режимы передачи данных, поддерживаемые современными дисководами (скорости в 11MB/s и выше), не имеют ничего общего с их практической производительностью.

Кроме того, возможно, что пропускная способность "обычного" интерфейса VLB уже является достаточной - самый быстрый режим ATA теоретически допускает скорость, равную 8.3 MB/s, что намного больше, чем может обеспечить любой из имеющихся на сегодняшний день на рынке дисководов ATA. Интерфейс ISA, с другой стороны, является намного более перспективным кандидатом на замену, поскольку его пропускная способность редко превышает 2.5MB/s, что значительно уступает современным стандартам.

Как определить, является ли дисковод узким местом системы? Общие идеи может подсказать использование Coretest version 3 . Эта версия Coretest дает два параметра быстродействия: (В) - скорость буферированной передачи данных, которая является характеристикой пропускной способности дисковод - интерфейс, и (S) - поддерживаемая скорость, связанная со скоростью носителя. Если дисковод имеет маленький кэш-буфер, то для получения правильного значения скорости буферированной передачи данных Вам может потребоваться опция /B16.

Как правило, первая величина получается значительно больше второй (обычно вдвое или больше). Это показывает, что узким местом являются физические характеристики самого дисковода, и увеличение скорости интерфейса не даст значительного эффекта. Единственным способом исправить положение может стать использование блочного режима (с помощью опций BIOS или драйвера). Только в том случае, если пропускная способность дисковода получается близкой к скорости интерфейса, у Вас есть неплохой шанс значительно увеличить быстродействие, используя новый интерфейс, при условии, что дисковод поддерживает более быстрый режим, чем используемый сейчас.

Эти соображения не являются свидетельством в пользу Coretest как теста дисков; существуют более надежные тесты, например, QBench .

Не забудьте прочитать вопрос 7.2 , который даст вам возможность получить более полную картину.

Следующая глава, предыдущая глава


Installation

5 Установка

5.1 Какой дисковод/устройство должен работать в качестве Slave?

  • Единственное устройство на канале, будь то жесткий диск (ATA) или CD-ROM (ATAPI), в соответствии с техническими требованиями, никогда не должно устанавливаться как slave. Однако, поскольку некоторые ATAPI CD-ROM поступают с установкой slave, большинство программ работает со slave CD-ROM без master просто потому, что это дает возможность сэкономить на вызове технических специалистов. Более того, у некоторых BIOSов возникают проблемы с устройствами ATAPI, которые с помощью перемычек сконфигурированы как master. Формально, тем не менее, такая конфигурация не является правильной; помните об этом, если у Вас неправильно распознается CD-ROM.
  • Два жестких диска на одном канале должны конфигурироваться как master и slave. Обычно не имеет значения, какой из них как устанавливается, однако старые жесткие диски могут работать не во всех конфигурациях, если они были выпущены до стандартизации протокола master/slave. В этом случае понадобятся эксперименты. Некоторые дисководы Conner имеют перемычку ATA/ISA: ATA - это современный стандарт протокола, а ISA - протокол, используемый старыми дисководами Conner.
  • Два устройства ATAPI, например, CD-ROMы или ленточные накопители, один из которых сконфигурирован как master, а другой - как slave, будут работать так же хорошо, как и жесткие диски.
  • Если Вам требуется подключить к одному каналу жесткий диск и устройство ATAPI, жесткий диск, согласно техническим требованиям, должен быть установлен как master. Хотя на практике обычно работает и обратная конфигурация, ее все-таки следует избегать.

5.2 Имеет ли значение, как подключать устройства к кабелю?

Не очень большое. Если к кабелю подключается только один дисковод, то лучше его ставить на самый конец, особенно если Вы пользуетесь одним из быстрых режимов. При двух устройствах не важно, куда Вы подключаете master, а куда slave, и какой конец кабеля Вы вставляете в контроллер. Следует только правильно подключать кабель: предполагается, что красный провод соответствует контакту 1.

После появления Plug'n'Play ATA будет использоваться установка Cable Select (CS), и ситуация станет иной. Некоторые компании уже могут использовать эту установку в своих устройствах.

5.3 Будет ли старый HD или CDROM замедлять работу нового дисковода?

Это не обязательно. Тем не менее, предпочтительно подключать старые дисководы и CD-ROMы ко вторичному каналу.

Если это невозможно или если Вы сомневаетесь относительно степени новизны своих устройств, учтите следующие моменты.

  • Потеря скорости, о которой обычно идет речь, связана с временными параметрами интерфейса, т.е. со скоростью взаимодействия устройства с компьютером. Это не обязательно приводит к потере истинного быстродействия.
  • Эта проблема касается только интерфейсов ATA-2 (EIDE) и некоторых интерфейсов VL IDE. Если у Вас обычный интерфейс ISA IDE, он не станет работать медленнее.
  • Некоторыми интерфейсами поддерживаются различные временные параметры для master и slave. В этом случае более медленное устройство не влияет на быстрое.
  • Многие CD-ROM поддерживают PIO mode 3. Этого более чем достаточно для работы на максимальной скорости с любым из жестких дисков, имеющихся сейчас в продаже.

Для определения того, меняется ли быстродействие и каким образом, Вы можете использовать Coretest ; см. способ использования теста в разделе 4.15 .

У пользователей OS/2 и Unix есть другая причина подключать медленные устройства АТА, такие, как ленточные накопители и CD-ROM, к собственному каналу. Пока одно из устройств на данном канале занято выполнением команды, другое недоступно. CD-ROM может с легкостью занимать таким образом канал в течение 300 мс.

5.4 Мне нужен более длинный кабель IDE; насколько длинным он может быть?

Менее 18 дюймов. В некоторых случаях предельная величина составляет не более 7 дюймов.

Кабель - это достаточно слабое звено всего интерфейса ATA-2. Для быстрой передачи данных, используемой в системах 'EIDE', не хватает сигналов заземления; кабель не имеет концевой заделки и защитной оболочки. Серьезной проблемой являются помехи. По этим причинам Вам следует учитывать ограничение длины в 18 дюймов, указанное в спецификации стандарта ATA(-2), если Вы хотите избежать порчи данных и зависания системы.

Хуже того, некоторые двухканальные интерфейсы 'EIDE', например, на основе CMD640x, имеют странную конструкцию, в которой используется только один буфер для обоих кабелей. Большинство сигналов обоих кабелей соединено друг с другом напрямую; это означает, что в электрическом смысле длины кабелей суммируются. Учтите, что медные следы на печатной плате тоже имеют обычно пару дюймов в длину; тогда получается, что для соблюдения технических условий максимальная длина кабеля должна составлять примерно 7 дюймов.

Если Вам сложно сделать все соединения кабелем стандартной длины, подумайте о присоединении к нему нового разъема или о самостоятельном изготовлении всего кабеля. Это сделать несложно; можно найти приятеля, который захочет Вам помочь, а все нужные части продаются в магазинах электроники. Обязательно используйте компоненты хорошего качества, работайте аккуратно и соблюдайте указанную длину.

Не соблюдая вышеуказанных условий, Вы рискуете. Проблемы, вызванные помехами, обычно проявляются неожиданно, их бывает очень трудно обнаружить и еще труднее выявить. Более того, они могут появляться совершенно бессистемно и влиять на другие устройства.

5.5 Могу ли я без опасений переставить жесткий диск с компьютера на компьютер?

Перемещение форматированного диска, разбитого на разделы, может вызвать трудности, если компьютеры используют разные схемы трансляции (см. вопрос 6.3). Сюда входит перестановка диска со старого компьютера, не поддерживающего трансляцию, на новый, который ее поддерживает. Этот вопрос довольно слабо изучен. Обычно все происходит гладко, но Вы будете не первым, кто был неприятно удивлен.

ВНИМАНИЕ! Не думайте, что с Вами этого не может случиться, так как обычно все проходит успешно; это уже приводило к порче информации и может привести опять.

Следующая глава, предыдущая глава


Configuration

6 Конфигурация

6.1 Надо ли мне использовать интерфейсные драйверы устройств?

Да. Обычно для получения нужной производительности интерфейса необходимо бывает использование этих драйверы.

Режим PIO или DMA, используемый для передачи данных, определяется интерфейсной картой. Некоторые карты снабжены перемычками, задающими скорость аппаратно; они срабатывают в ту же микросекунду, когда Вы включаете компьютер.

Однако большинство интерфейсов конфигурируется программным методом. При загрузке они настроены на самую малую скорость. После запуска часть программного обеспечения, относящаяся к адаптеру, определяет, какие скорости передачи данных поддерживаются дисководом, и соответственно настраивает микросхему контроллера. Нужно отметить следующие варианты:

  • Ввод-вывод на карте с полной поддержкой BIOS. Контроллер полностью настраивается при загрузке компьютера. Обычно нужный режим работы каждого из жестких дисков задается установками CMOS. К этой категории относятся многие современные карты.
  • Ввод-вывод на карте с неполной поддержкой BIOS. По некоторым глубинным причинам ряд системных плат не поддерживает или неправильно задает установки интегрированных портов ввода-вывода. В этом случае для обеспечения функционирования в полном объеме Вам нужно будет использовать драйверы DOS или другие необходимые драйверы.
  • Интерфейсная карта с BIOS. Этот случай идентичен описанным выше. Основное отличие состоит в том, что эти карты могут не иметь экрана настройки; в этом случае они должны иметь другие средства для установки нужного режима передачи данных. Например, Promise 2300+ использует комбинацию перемычек и таблицу, содержащуюся в ROM, в которой указаны параметры для различных дисководов. В этом случае нужда в драйверах для достижения более высокой производительности может возникнуть, а может и не возникнуть.
  • Интерфейсная карта без BIOS. Поскольку не существует метода, при котором BIOS материнской платы мог бы обеспечить задание параметров для всех существующих интерфейсных карт, то для работы в быстрых режимах Вам придется пользоваться драйверами, поставляемыми с устройством. Так делается всегда, за исключением достаточно редких случаев, когда карта конфигурируется с помощью аппаратных перемычек.

Обычно существуют драйверы и для других операционных систем, например, для Windows, Win95, OS/2 и т.д. Это служит для нескольких целей.

  • Драйвер может понадобится для конфигурирования адаптера, как было описано выше. Это не относится к Windows, где эта функция выполняется драйвером DOS.
  • Стандартные драйверы, встроенные в операционную систему, не поддерживают всех возможностей интерфейсов и дисководов. Примерами являются 32-битная передача, блочный режим и DMA.
  • Только для Windows: стандартный драйвер (*wdctrl), поставляемый с Windows и Windows for Workgroups, имеет ряд серьезных ограничений.

Отсюда следует, что, к сожалению, драйверы, которые поставляются с интерфейсом, имеют обычно весьма среднее качество.

6.2 Чем мне пользоваться - Normal, LBA or Large?

Разница между ними следующая.

  • 'Normal' заставляет BIOS работать старым методом - без трансляции. Используйте эту установку, если дисковод не нуждается в трансляции (т.е. имеет менее 1024 цилиндров) или если Вы собираетесь использовать дисковод в операционной системе, не понимающей трансляции.
  • 'Large', ECHS или XCHS говорит BIOS, что надо использовать CHS-трансляцию. При этом используется другая геометрия (цилиндры / головки / сектора), чем при доступе к дисководу посредством программного прерывания int13. Этот вид трансляции работает со всеми дисководами.

    Примечание. В некоторых BIOSах режим Large реализован странным образом, позволяя работать только с дисками емкостью до 1GB. К счастью, все диски большей емкости поддерживают LBA.

  • 'LBA' отличается от 'Large' тем, что в этом режиме для доступа к жесткому диску используется адресация LBA. Преимущество состоит в том, что теоретически это несколько более быстрый режим. К недостаткам режима относится то, что некоторые старые дисководы его не поддерживают, и это, в зависимости от конкретного дисковода, может даже привести к уменьшению производительности.

ВНИМАНИЕ! Некоторые типы BIOS меняют геометрию (трансляции) при изменении установки с Normal или Large на LBA. То же самое может случиться при перестановке диска, отформатированного на старом компьютере без режима LBA, на новый, использующий LBA. При этом уже были случаи потери данных. Не допустите, чтобы это случилось с Вами.

В главе 10 рассказывается об этих вариантах более подробно.

6.3 Могу ли я без опасения изменить режим трансляции BIOS (None, LBA, Large)?

К сожалению, нет. Примите меры предосторожности.

Хотя многие BIOS формируют адреса секторов на диске одинаково, независимо от способа трансляции, некоторые из них делают это по-другому. Эти последние при изменении режима трансляции разбросают информацию, как ветер - колоду карт.

Более того, виды BIOS, основанные на руководстве WD, совершенно по-разному устанавливать геометрию дисковода для программного интерфейса (int13) в зависимости от режима трансляции. При смене режима информация может подвергнуться фатальному разрушению. Это служит демонстрацией основного дефекта спецификации WD EBIOS.

В обоих этих случаях после изменения режима трансляции Вам придется переустановить разделы и заново отформатировать диск.

6.4 Следует ли мне разрешать режим управления шиной EIDE в BIOS?

Единственной причиной для установки этой опции является то, что вероятность искажения данных в режиме DMA меньше, чем в режиме PIO. В обоих случаях CPU будет использоваться одинаково ( другой причиной может стать повышенная пропускная способность, когда появится DMA/33).

К сожалению, имеется сообщение как минимум одного пользователя о значительном снижении пропускной способности при разрешенном режиме DMA. Причины непонятны, поэтому будьте осторожны.

6.5 FDISK видит только 504MB моего диска!

Прежде всего, есть ли у Вас расширенный BIOS? См. подробности в разделе 2.8 и вопросе 1. Если у Вас есть EBIOS, убедитесь, что режим трансляции установлен: обычно это 'Large' или 'LBA'. Если в установках BIOS не оказалось такой опции, помните, что некоторые типы BIOS обеспечивают установку режима трансляции только в том случае, если была выполнена операция autodetect для дисковода.

И, наконец, последнее, - после изменения режима трансляции удалите все старые разделы перед заданием новых.

6.6 FDISK устанавливает разделы только в пределах 2GB.

Это не ошибка, а ограничение файловых систем DOS FAT и Win95 VFAT. Чтобы использовать весь объем диска, Вам придется задать несколько разделов.

Это ограничение отсутствует в новой файловой системе Microsoft FAT32, которая в настоящее время работает только в версии Win95 OEM 2. Она позволяет работать с громадными многогигабайтными разделами. Когда составлялся этот документ, эта версия могла быть получена только при покупке нового оборудования и была недоступна для простых смертных.

6.7 Хотя у меня нет модного EBIOS, но раздел величиной в 1GB установлен и работает.

Многие пытаются решить проблему 504MB / 1024 цилиндров, создав большой раздел с помощью компьютера своего приятеля, Linux fdisk или чего-нибудь еще. Они используют эти разделы в течение одного-двух дней, делают вывод, что они работают, и отправляют торжествующую статью, в которой объявляют, что нашли РЕШЕНИЕ ВСЕХ ПРОБЛЕМ[TM].

Такой метод работает... не более чем для 1024 цилиндров. Как только OS или какая-либо программа пытается записать что-нибудь на цилиндр 1025 через вызов int13, запись переходит на цилиндр 0. Этот цилиндр обычно содержит наиболее важные структуры данных диска - Master Boot Record, таблицу разделов, обе копии FAT и корневую директорию первого раздела. Если поверх них будет записана другая информация, то только специальная компания, занимающаяся восстановлением данных, может быть, сумеет спасти Вашу информацию.

Пробуйте, если Вам так нужно. Если Вы точно знаете, что делаете, то можете это сделать с помощью Win95. Или чего-то еще. Первая же ошибка будет фатальной. Только, пожалуйста, не посылайте писем, рекомендующих эту процедуру всем другим пользователем. Призраки принадлежавших им данных вернутся и будут преследовать Вас.

6.8 У меня есть программы, позволяющие преодолеть ограничение 504MB. Следует ли мне им пользоваться?

Это удобно, но здесь есть ряд сложностей.

Программное обеспечение, иногда называемое владельцем лицензии экзотическими именами, обычно является вариантом EZ-Drive производства MicroHouse или Disk Manager производства OnTrack. При использовании Disk Manager на загрузочном диске приходится прибегать к различным хитростям, чтобы при запуске загрузить его как можно раньше (это необходимо по техническим причинам). Это делается посредством модификации Master Boot Record (MBR) - первого фрагмента информации, которую BIOS загружает и выполняет при запуске компьютера, и посредством сохранения Dynamic Drive Overlay (DDO) на первой дорожке диска. EZ-Drive работает таким же образом.

Раздражает в таком программном решении то, что постановка операционной системы, которая зачастую перекрывает MBR, может сделать содержимое жесткого диска недоступным. Чтобы восстановить доступ к разделам, придется восстановить исходный MBR с загрузочной дискеты.

Более того, такое программное обеспечение обычно порождает разделы, структура которых совершенно не соответствует "стандартным" схемам, используемым большинством расширенных BIOS. Многие драйверы, работающие с диском, будут работать неправильно, даже если они хорошо работают с другими схемами трансляции. Характерным примером являются драйверы интерфейса (E)IDE; помните, что без этих драйверов интерфейс, вообще говоря, будет работать намного медленнее. Понадобятся специальные драйверы, распознающие схему трансляции, которой Вы пользуетесь. Кроме того, многие операционные системы, кроме DOS, не смогут работать с диском, по крайней мере, сразу после покупки. Программы восстановления диска могут не сработать, если таблица разделов или оверлейный сегмент будут повреждены.

Это также усложняет модернизацию за счет использования BIOS. OnTrack Disk Manager версии 7 содержит для этой цели программу перегруппировки и ряд других усовершенствований по сравнению с версией 6. Он обеспечивает работу со многими операционными системами и совместим с большинством интерфейсов и драйверов, включая драйверы ATAPI CD-ROM. Обладатели версии 6.03, которая обычно поставляется с жесткими дисками, могут для модернизации загрузить "заплатку" OnTrack по адресу http://www.ontrack.com/pub/software/dmpatch.zip; она обеспечивает ряд преимуществ, которые дает версия 7. Общие сведения приведены по адресу http://www.ontrack.com/dm.html.

Для старых версий Disk Manager IBM и Microsoft предоставляют исправления под OS/2 (в FixPak 5 и более позднем или в Warp FullPack и Warp Connect) и под NT (Service Pack 2). Win95 должна поддерживать Disk Manager и EZDrive в исходном виде (см. статью Microsoft KnowledgeBase Q126855, "Поддержка Windows 95 для больщих жестких дисков IDE").

6.9 Можно ли сохранить разделы Disk Manager / EZDrive с новым BIOSом?

Есть три возможности поставить новый BIOS, поддерживающий трансляцию, имея на диске разделы Disk Manager или EZDrive.

  • Программа совместима с трансляцией LBA или имеет средства для перегруппировки. Это позволяет провести модернизацию гладко (у меня есть уверенность только относительно Disk Manager v7).
  • Предыдущее неверно, а Вам не хочется проходить через процедуру сохранения, установки новых разделов и восстановления. Задайте BIOS режим Normal для жесткого диска, и программа будет работать как обычно.
  • Процедура сохранения, установки новых разделов и восстановления. Если при удалении программы возникнут трудности, обратитесь к разделу 6.10 .

Всегда сохраняйте информацию перед обновлением системы.

6.10 Мне надо удалить Disk Manager/EZDrive.

Эти программы обычно устанавливаются в Master Boot Record (MBR) загрузочного диска. Нормальная переустановка разделов и форматирование обычно не затрагивают MBR, что может сделать попытку удаления программы неудачной. К счастью, это не очень сложно, если знать, как это делается.

Наилучшим методом является следование процедуре удаления, описанной в документации на программу. Если это невозможно, то обычно это удается сделать следующим методом: запустите компьютер с чистой дискеты, содержащей как минимум DOS, FORMAT.COM и FDISK.COM. Затем введите FDISK /MBR. Это позволит обновить содержимое MBR. После этого установите разделы и отформатируйте диск обычным способом.

По причинам, которые мне непонятны, некоторые версии Disk Manager довольно упорно держатся за жизнь (может быть, из-за особенно вычурной защиты от вирусов, реализованной в BIOS?). В этом случае Вам нужен DM.EXE. Введите DM /Y-. Если это также не поможет, то можно применить метод, который, как сообщает Mark Brown ( mailto:mrkbrown@netcom.com), успешно работает.

  1. Запустите DM (в данном случае v.6.03)
  2. Нажмите ALT-T
  3. Выберите просмотр дисковой подсистемы (D)
  4. Выберите нужный жесткий диск
  5. Нажмите CTRL-F10 для очистки MBR
  6. Наберите Y для подтверждения
  7. Нажмите ESC для выхода из DM, перезагрузите систему с чистой дискеты

Если вы сталкивались с подобными случаями и у Вас есть что добавить, то пришлите, пожалуйста, информацию об этом. Интересует прежде всего программа, которая просто уничтожает таблицу разделов; кто примет вызов?

ПРЕДУПРЕЖДЕНИЕ. Разделы Disk Manager и EZDrive отличаются от разделов, порождаемых посредством транслирующего BIOSа. После этой операции Ваши данные могут стать недоступными. Исключением является v7.x OnTrack Disk Manager; DM.EXE обеспечивает перегруппировку, которая работает со многими BIOSами.

ПРЕДУПРЕЖДЕНИЕ. Некоторые контроллеры и защитные программы хранят информацию на дорожке 0, которую FDISK /MBR очищает. В этом случае данные на диске все равно будут утрачены, но есть ряд условий, при которых эта команда может разрушить информацию.

6.11 Я могу разрешить кэширование записи на жесткий диск. Надо ли это делать?

Не путайте это с ленивыми рассуждениями о Smartdrive (или чем-то подобном): здесь имеется в виду изменение метода управления кэш-буфером дисковода. Это возможно при использовании новых версий Drive Rocket, hdparm под Linux и, вероятно, некоторых других программ. При условии, разумеется, что дисковод обладает такими возможностями. Иногда это можно сделать, используя перемычки на дисководе.

Здесь могут возникнуть трудности, если программа выдает soft-reset (что на материнских платах Intel Pentium означает также выдачу hardware-reset) при появлении последнего IRQ, что приводит к прекращению работы и повреждению данных. Будьте осторожны, делайте копии своих данных.

6.12 Идентификаторы, относящиеся к дисководу, изменились!

MS-DOS отводит идентификаторы дисководу по следующим законам.

  • Идентификаторы a: и b: резервируются для гибких дисков.
  • Всем первичным разделам на всех (системных и на адаптере) поддерживаемых BIOS жестких дисках идентификаторы отводятся по порядку, начиная с c:. Обычно на каждом диске имеется только один первичный раздел DOS/Windows.
  • Только потом идентификаторы назначаются логическим дискам в расширенных разделах. Это, например, означает, что, если у Вас был один диск с c: и d:, то добавление второго диска с одним первичным разделом изменит прежний раздел d: на e:. Если Вы хотите избежать этого, задайте первичный раздел только на одном диске.
  • После этого MS-DOS анализирует файлы CONFIG.SYS и AUTOEXEC.BAT. Некоторые устройства, например, CD-ROM, не поддерживаются BIOS и получают идентификаторы только в этот момент.

Помните, что некоторые программы, включая программы сжимания диска, могут исказить идентификаторы, относящиеся к дисководам. Помните также, что некоторые экраны установки BIOS, в тщетной попытке организовать дружественный интерфейс с пользователем, именуют жесткие диски буквами, относящимися к дисководам. В тривиальных случаях это может быть верно, однако в случае нетривиальной установки BIOS может работать совершенно неверно.

Следующая глава, предыдущая глава


Performance

7 Производительность

7.1 Почему мой дисковод работает не так быстро, как обещает реклама?

Хороший вопрос. Вообще говоря, дело в том, что представляемые в рекламе режимы - это теоретические скорости передачи данных.

Это имеет две причины. Прежде всего, приводимые величины не соответствуют скоростям истинного чтения и записи дисководом данных с магнитного носителя. Они соответствуют скорости обмена данными между буфером дисковода и CPU. Последняя величина производит большее впечатление, тогда как первая имеет большее отношение к реальной производительности. "Эта ситуация похожа на то, как если бы правительство вначале установило ограничение скорости в 250 км/час, а затем увеличило его до 1600 км/час и объявило, что Вы теперь можете ездить быстрее"--Aaron Bilger (mailto:bilgerar@mentor.cc.purdue.edu).

Во-вторых, даже если допустить, что такие скорости достижимы в том случае, когда данные уже находятся в кэш-буфере, то эти цифры все равно окажутся слишком оптимистичными. В действительности дисковод не только передает данные из кэша компьютеру. При передаче каждого сектора компьютеру контроллер дисковода должен получить его с магнитного носителя; внутренние операции контроллера, обновление таблиц, установка положения и управление кэш-буфером требуют работы контроллера. Все это снижает скорость обмена данными между кэш-буфером и компьютером.

Помимо всего этого, производительность одного и того же дисковода может меняться в пределах от 1MB/с до 9MB/с и более в зависимости от тестовой программы, используемой для измерения "пропускной способности". Полученный результат будет зависеть от того, какой именно программой, каким образом и даже в каком месте дисковода проводятся измерения (различные зоны одного и того дисковода могут различаться по скорости вдвое). Вдобавок к этому, имеет значение и конфигурация системы (MHz CPU, RAM, кэш жесткого диска, кэш процессора).

Подводя итог, скажем, что, какой бы тест Вы ни использовали, он не покажет Вам рекламируемой скорости передачи данных. Настоящий показатель быстродействия - это то, насколько улучшается качество Вашей ежедневной работы. Остальное - пустяки.

7.2 Почему мой новый интерфейс EIDE работает не быстрее, чем старый интерфейс VLB?

Есть несколько причин, приводящих к тому, что интерфейс ATA-2 работает не быстрее, чем ATA с локальной шиной, даже если все драйверы установлены и все работает правильно. Первая и самая важная - это то, что пропускная способность самого быстрого режима ATA - 8.3MB/s - существенно превышает истинную скорость передачи данных большинством имеющихся в продаже дисководов. Поскольку скорость Вашего дисковода ограничена определенной величиной, дальнейшее увеличение пропускной способности интерфейса не даст заметного эффекта.

Другая возможная причина состоит в том, что Ваш дисковод может вообще не поддерживать режимы передачи ATA-2. В этом случае интерфейс ATA-2 улучшает производительность по сравнению с устаревшим интерфейсом шины ISA, но работает не быстрее, чем хороший интерфейс локальной шины АТА.

Наконец, если интерфейс ATA-2 не позволяет устанавливать различные временные параметры для дисководов master и slave, то подключение обычного дисковода ATA к тому же каналу, что и дисковода ATA-2, приведет к снижению скорости интерфейса до величины наименьшего общего знаменателя.

7.3 Я тестирую мой дисковод и вижу, что он начал работать медленнее!

Хотите - верьте, хотите - нет, но это совершенно нормально. Во-первых, на результаты работы некоторых тестов влияет фрагментарность файловой системы; попробуйте восстановить целостность. Во-вторых, не все части дисковода работают одинаково быстро.

Физически жесткий диск состоит из одной или более вращающихся пластинок, на которых имеются дорожки в виде концентрических окружностей. Понятно, что внешние дорожки длиннее, чем внутренние. Поскольку они длиннее, на них может поместиться больше секторов. По мере продвижения внутрь и уменьшения длины дорожки число секторов ступенчато уменьшается. Это называется Zone Bit Recording (ZBR).

Вернемся к тестам. Поскольку пластина вращается с постоянной скоростью, то большее число секторов на дорожке дает пропорционально более высокую скорость передачи. Самый первый цилиндр дисковода находится как раз на краю пластинки, в самой быстрой зоне. Это и есть та зона, которая тестировалась при покупке Вашего дисковода и для которой в тот момент измерялось быстродействие. По мере заполнения диска Вы переходите к цилиндрам с большими номерами и, соответственно, к более медленным зонам. В зависимости от используемого Вами теста это может проявиться как снижение скорости.

Число секторов на дорожке (и, соответственно, в скорости передачи) между самой быстрой и самой медленной зонами может различаться вдвое. Стандартные дисководы имеют обычно от пяти до двадцати зон, в которых имеется различное число секторов на дорожке.

7.4 Один парень из сети имеет такой же дисковод и работает на 16MB/s!

"Сеть Usenet подобна стаду выступающих слонов с расстройством желудка - массивная, тяжело управляемая, внушающая страх, забавная и производящая массу сбивающих с толку экскрементов тогда, когда меньше всего этого ждешь".

-- Gene Spafford ( mailto:spaf@cs.purdue.edu), 1992

7.5 Драйверы управления шиной не дают большого эффекта...

Прежде всего, управление шиной в целом не особенно влияет собственно на скорость передачи. Оно может только избавить CPU от неприятной работы по перелопачиванию данных, освобождая его для более полезных дел. Однако, если Вы работаете с одной задачей или пускаете тест, то освобождающееся в результате управления шиной время CPU не будет ни для чего использовано, и эффект не будет заметен.

Во-вторых, работая с System Monitor в Win95, Вы не заметите снижения нагрузки CPU, поскольку он подсчитывает время цикла "система свободна"; однако при незавершенной операции ввода-вывода системное время используется не в этом цикле, а в цикле "ожидания окончания ввода-вывода" .

Следующая глава, предыдущая глава


ATA: harddisks

10 ATA: жесткие диски

Этот и последующие разделы справочника предлагают заинтересованным пользователям дополнительную информацию общего характера. Вопросы, обсуждаемые здесь, сильно различаются по глубине освещения материала; выбирайте и читайте то, что Вас интересует. Это справочник, а не книга.

10.1 Как работает ATA(-2)?

Чтобы понять основную концепцию перспективных дисководов ATA, надо знать основы технологии производства дисководов. В общих чертах, когда операционная система требует чтения или записи данных во вторичную память (на жесткий диск), BIOS получает команду и передает ее на дисковод. Операционные системы, отличные от DOS, обычно используют вместо BIOS собственную подсистему ввода-вывода; принцип остается тем же.

Способ, которым команда передается, интерпретируется и исполняется, и составляет основу Advanced ATA. Коротко говоря, существует семь регистров, которые используются BIOS для чтения-записи при формировании команды. Восьмой регистр используется для чтения-записи данных. Сигналы, вызывающие чтение-запись, управляются BIOS, но их синхронизация определяется аппаратурой интерфейса, и характеристики ATA определяют, насколько быстро эти сигналы появляются и снимаются. В настоящее время существуют 4 режима программируемого ввода-вывода (PIO) и 4 режима прямого доступа к памяти (DMA). Величины, о которых все вы читали, являются только малой частью технических характеристик, но их проще всего рекламировать. "Скорость передачи" определяется параметрами, которые управляют временем цикла работы регистра чтения-записи.

10.2 Что представляют собой режимы PIO?

Режим PIO определяет, с какой скоростью данные передаются от диска и к диску. В самом медленном режиме - PIO mode 0 - время цикла передачи данных не превышает 600 наносекунд. За один цикл к диску и от диска передаются 16 бит. Один сектор содержит 256 слов (16 бит - 1 слово); 2048 секторов образуют мегабайт. Таким образом, исходя из расчетов,

1 цикл | 1 сектор | 1 мегабайт | а | 2000
-------- | --------- | ------------ | = | ------ | = 3.3MB/s
600ns | 256 слов | 2048 секторов | а | 600ns
а

Таким образом, теоретическая скорость передачи данных в режиме PIO Mode 0 (время цикла 600ns) - 3.3 мегабайта в секунду.

Ниже представлены остальные режимы PIO и соответствующие им скорости передачи данных:

Режим PIO | Время такта | Скорость передачи | а
а | (ns) | (MB/s) | а
а
0 | 600 | 3.3 | ATA
1 | 383 | 5.2 | ATA
2 | 240 | 8.3 | ATA
3 | 180 | 11.1 | ATA-2, требует IORDY
4 | 120 | 16.6 | ATA-2, требует IORDY
5 | 90 | 22.2 | vaporware
а

Первые три режима - PIO mode от 0 до 2 - это старые режимы, которые были представлены в прежнем стандарте ATA. Остальные (PIO 3 и 4) - это режимы, присущие только ATA-2, которые используют аппаратное управление потоком IORDY. Это означает, что дисковод может использовать канал IORDY для замедления интерфейса при необходимости. Интерфейсы без аппаратной поддержки IORDY могут вызвать искажение данных в быстрых режимах PIO; это означает необходимость более медленной работы и приводит обычно к уменьшению пропускной способности вдвое.

При опросе посредством команды Identify Drive жесткий диск, наряду с другими параметрами, возвращает данные по режимам PIO и DMA, в которых он может работать.

10.3 Что представляют собой режимы DMA?

DMA, или прямой доступ к памяти, означает, что данные передаются непосредственно между памятью и диском без использования CPU в качестве промежуточного хранилища, как это делается в режиме PIO. В настоящих многозадачных операционных системах наподобие OS/2 или Linux DMA во время дисковых операций оставляет CPU свободным. В среде DOS/Windows CPU в любом случае приходится ждать конца передачи, поэтому в этом случае режим DMA особенно полезен.

Существуют два различных вида прямого доступа к памяти: third-party DMA и first-party или busmastering DMA (управление шиной). В режиме Third-party DMA сложные задачи организации доступа, захвата системной шины и передачи данных выполняет контроллер DMA, размещенный на материнской плате. В случае first-party DMA все эти операции выполняются логическими схемами самой интерфейсной карты. Это, конечно, ведет к существенному увеличению сложности и стоимости интерфейса, работающего в режиме управления шиной.

К сожалению, контроллер DMA в системах ISA - устройство старинное и медленное и, безусловно, не может использоваться с современными жесткими дисками. Карты VLB вообще не могут быть использованы в качестве приемников DMA и могут работать только в режиме busmastering DMA. Только интерфейсы на основе EISA и PCI могут поддерживать busmastering DMA: EISA тип 'B' DMA обеспечивает передачу 4MB/s, PCI тип 'F' DMA - между 6 и 8MB/s.

Все современные схемные комплекты, включая вездесущие схемы Triton, включают в себя интерфейс АТА, пригодный для работы с busmastering DMA. Работы по стандартизации аппаратуры DMA должны привести к появлению стабильной и надежной программной поддержки.

Поддерживаются следующие режимы DMA:

Режим DMA | Время цикла | Скорость передачи
Одно слово | (ns) | (MB/s)
а
0 | 960 | 2.1 | ATA
1 | 480 | 4.2 | ATA
2 | 240 | 8.3 | ATA
Группа слов
0 | 480 | 4.2 | ATA
1 | 150 | 13.3 | ATA-2
2 | 120 | 16.6 | ATA-2
3 | 60 | 33.3 | Ultra-ATA

Режимы DMA с передачей одного слова не будут использоваться в ATA-3. Заметим, что в некоторых старых интерфейсах эти режимы DMA могут использоваться просто в качестве способа общения с дисководом, а не для настоящего прямого доступа к памяти. В этом случае режимы DMA используются просто в качестве слегка приукрашенного варианта режимов PIO.

10.4 Как назначаются порты ввода-вывода ATA(-2,PI)?

Регистры первичного канала АТА занимают следующие адреса ввода-вывода (в шестнадцатиричной записи):

Регистр | Операция чтения | Операция записи
а
01F0h | Данные для чтения | Данные записи
а | (16 бит) | (16 бит)
01F1h | Регистр ошибки | Данные для установки параметров
01F2h | Статус счета секторов | Счет секторов записи
а | а | для установки команды
01F3h | Положение начального | Начало секторов
а | сектора | для установки команды
01F4h | Положение Cyl-low | Положение cyl-low записи
а | а | для установки команды
01F5h | Положение Cyl-high | Положение cyl-high записи
а | а | для установки команды
01F6h | Выбор головки/устройства | Выбор устройства записи
а | а | и головки
а | а | для установки команды
01F7h | Статус устройства | Команда устройства
а
03F6h | Резервный статус | Управление устройством
03F7h | Адрес дисковода
а

Заметим, что флаг смены диска, используемый контроллером гибких дисков, размещается по адресу 03F7h, что усложняет жизнь разработчиков, которые хотят раздельно использовать контроллеры гибких и жестких дисков. С этой точки зрения не покажется странным, что некоторые проблемы интерфейсных микросхем CMD640x и RZ1000 'EIDE', затрагиваемые в этом справочнике, связаны с флоппи-дисками.

Нет причин, которые не позволили бы создать множество других интерфейсов, подобных этому. Вот действующий стандарт для четырех из этих портов:

Номер интерфейса | CS0-дешифровка | CS1-дешифровка | Номер IRQ
а
1 | 01F0h-01F7h | 03F6h-03F7h | 14
2 | 0170h-0177h | 0376h-0377h | 15 или 10
3 | 01E8h-01EFh | 03EEh-03EFh | 12 или 11
4 | 0168h-016Fh | 036Eh-036Fh | 10 или 9
а

Только первые два имеют действительно повсеместную поддержку; в настоящее время IRQ15 чаще всего используется как прерывание для вторичного порта. Поддержка BIOS для дополнительных портов есть только в спецификации Phoenix.

10.5 Что делает интерфейс ATA-2?

С момента появления обычного интерфейса ISA IDE, не имевшего почти ничего, кроме простого буфера, интерфейсы прошли длительный путь развития. Карты ATA-2 поддерживают как минимум режимы PIO 0 и 3, а обычно гораздо больше, и должны обеспечивать правильную синхронизацию интерфейса АТА для всех этих режимов. Поскольку параметры синхронизации достаточно сложны, для корректной реализации стандарта АТА-2 требуется высокая степень аппаратной гибкости.

                             |<------------ t0 ------------------------>|
                       __________________________________________       |
Адрес действ. *1 _____/                                          \________
                      |<-t1->|<----------- t2 ----------->|<-t9->|      |
                      |      |____________________________|<---t2i----->|_
DIOR-/DIOW-      ____________/                            \_____________/
                      |      |                            |      |
                      |      |                    ________|__  ->|   |<-t8
Запись данных *2 --------------------------------<___________>------------
                      |      |                   |<--t3-->|  |       |
                      |      |                          ->|t4|<-     |
                      |      |                     _______|___ ____  |
Чтение данных *2 ---------------------------------<___________X____>------
                    ->|t7|<- |                    |     ->|t6 |<-  | |
                      |  | ->| tA |<-             |<-t5-->|<-t6Z-->|
                      |  |___________________________________________|
IOCS16-          ________/        |               |                  \____
                                  |             ->|tRd|<-            |
                 _________________|___________________|___________________
IORDY            XXXXXXXXXXXXXXXXX____________________/
                                  |<-------tB-------->|
  *1 Адрес устройства состоит из CS0-, CS1- и DA2-0
  *2 Данные состоят из DD0-15 (16-бит) или DD0-7 (8-бит)

На рисунке показано соотношение между сигналами интерфейса в 8-битном и 16-битном режимах передачи данных PIO.

На этой схеме t0 обозначает время такта чтения-записи; это наиболее важный параметр, определяющий пропускную способность режима PIO. Как можно видеть, есть еще множество параметров помимо длительности такта чтения-записи, которые определяют скорость работы в различных режимах PIO и DMA. Достаточно сложно разработать недорогой интерфейс, который полностью соответствовал бы спецификации ATA-2. Общая идея - сделать временные параметры полностью программируемыми; однако, к сожалению, способ программирования карт ATA не стандартизирован и существенно различается для разных карт. Из этого следует, что для использования всех преимуществ быстрых режимов передачи данных для каждой операционной системы и для каждого вида интерфейса придется использовать различные драйверы.

10.6 Что такое блочный режим?

Этот режим реализуется в виде команд многократного чтения-записи (что уменьшает число прерываний работы основного процессора).

Помимо очевидного ускорения передачи данных, Fast-ATA и другие дисководы имеют команды многократного чтения-записи, позволяющие увеличить число секторов, передаваемых без промежуточных прерываний. Это снижает загрузку основного процессора, поскольку каждое прерывание заставляет CPU выполнять переключение контекста, проверять устройство и устанавливать режим передачи данных (или выполнять саму передачу в случае PIO).

Команда многократного чтения (0C4h) и команда многократной записи (0C5h) представляют собой команды уровня дисковода, по которым может выполнятся передача нескольких секторов данных без захвата линии IRQ дисковода для оповещения процессора о продолжении операции дисковода.

Линия IRQ запрашивается в следующих случаях:

  • Была выдана команда чтения, нужные данные находятся в буфере дисковода и готовы к передаче в компьютер.
  • Была выдана команда записи, и данные были переданы в буфер дисковода. Если отключен режим кэширования записи, линия IRQ не будет запрашиваться до тех пор, пока данные не будут полностью записаны на устройство.

Во время нормального чтения и записи прерывания постоянно захватывают CPU, и, в зависимости от процессора и решаемой задачи (многозадачная OS, Unix и т.п.), в обслуживании дисковода CPU могут наблюдаться большие задержки. Многократное чтение-запись позволяет передавать несколько секторов (от 2 до 128) за один шаг и выполнять операцию на 30% быстрее.

В однозадачных операционных системах наподобие DOS любое улучшение быстродействия более чем на несколько процентов обычно является признаком того, что кэширование со стороны дисковода организовано плохо.

Примечание: в некоторых старых дисководах блочный режим реализован с ошибками и может вызвать порчу данных.

Последнее замечание: размер блока, который является оптимальным для пропускной способности дисковода, не обязательно будет лучшим для быстродействия системы! Например, для файловой системы DOS FAT предпочтительным является размер блока, равный размеру кластера. При точной настройке размера блока не полагайтесь на тесты низшего уровня, пользуйтесь вместо них тестами уровня приложений.

10.7 Что такое LBA?

LBA - это метод линейной адресации секторов, начиная с сектора 1, головки 1, цилиндра 1 в качестве LBA 0 и кончая последним физическим сектором дисковода, который для стандартного 540-мегабайтного диска равен, например, LBA 1,065,456. Это новый метод для ATA-2, но он всегда был единственным методом адресации для SCSI. Заметим, что LBA не допускает адресации большего числа секторов, чем метод адресации CHS.

LBA снижает затраты времени CPU на вспомогательные операции в операционных системах, использующих LBA для внутренних целей, но, с другой стороны, несколько увеличивает время в том случае, если используются обычные вызовы BIOS, основанные на CHS (как, например, в DOS). Помните, что, в зависимости от способа реализации LBA в микропрограммах жесткого диска, затраты на вспомогательные операции со стороны дисковода могут возрасти.

10.8 Как работает защита?

Режим защиты реализован на основе простой парольной схемы. Защита может касаться только операций записи или совместно чтения и записи. Операции без данных (такие, как Identify Device) выполняются всегда, независимо от состояния защиты.

Есть два уровня защиты - High и Maximum. Если утерян пароль пользователя при установленном уровне защиты High, доступ к дисководу все-таки возможен при помощи пароля Master. В случае установки уровня Maximum доступ к дисководу невозможен без уничтожения всех данных пользователя.

После набора нескольких неверных паролей дисковод перестает воспринимать дальнейший ввод пароля до тех пор, пока не будет выключено питание или не будет выполнен жесткий перезапуск. Это делает угадывание пароля при помощи грубой силы очень трудным.

10.9 Что такое S.M.A.R.T.?

S.M.A.R.T. - это технология самопроверки и оповещения об определенном ухудшении или возможном в скором будущем отказе. Это позволяет операционной системе принять нужные меры предосторожности и предупредить пользователя. Редакция 2 OEM Win95 и следующая версия OS/2 (Merlin) будут учитывать SMART.

Полезность этого свойства на начальном этапе будет, однако, весьма ограниченной, поскольку многие виды отказов (включая печально известный отказ "утром в понедельник") нельзя предвидеть заранее.

Сейчас есть очень немного служебных программ, которые проверяют состояние S.M.A.R.T. дисковода. К ним относятся Micro House EZ-S.M.A.R.T. и Symantec S.M.A.R.T. Doctor.

10.10 Что такое PRML?

Канал чтения Partial Response Maximum Likelihood, или PRML, активно продвигается на рынок, вытесняя обычный канал peak detection. В нескольких словах, в тех случаях, когда канал детектирования пика использует сравнительно простой аналоговый метод выделения числовых данных из сигнала, полученного головкой чтения, канал PRML для восстановления данных использует оцифровывание сигнала и его последующую численную обработку. Благодаря этому методу DSP (численной обработки сигнала) канал PRML надежно работает с очень плотно упакованными данными, в которых различие между отдельными битами становится незначительным. В результате этого получается более быстрый и емкий дисковод.

Более серьезно этот вопрос обсуждается на великолепных белых страницах Quantum.

10.11 Что такое головки MR?

Магнитоустойчивые головки дисковода, или MR, быстро вытесняют старые индуктивные головки во всех областях рынка жестких дисков. Более подробную информацию можно найти, например, по адресу http://www.seagate.com/new/sep96/mr_techp.shtml.

Следующая глава, предыдущая глава


ATAPI: CD-ROMs and tapes

11 ATAPI: CD-ROM и ленточные накопители

Содержание этого раздела

11.1 Чем ATAPI отличается и как сосуществует с ATA(-2)?

Для обеспечения совместимости с программами, не рассчитанными на ATAPI, которые могли бы по ошибке принять устройство ATAPI за жесткий диск, такое устройство создает видимость своего отсутствия до тех пор, пока оно не будет инициировано специальной последовательностью команд. Будучи запущенным, оно использует командный протокол, резко отличающийся от протокола, используемого жесткими дисками.

Причина этих сложностей в том, что набор команд и регистров ATA не подходит для некоторых командных структур CD-ROM. Поэтому устройства ATAPI поддерживают только минимальный набор традиционных команд ATA. Большинство этих функций основано на протоколе передачи ATAPI с использованием передачи через регистр данных пакета из не менее чем 12 байт. Эти пакетные команды были взяты из набора команд SCSI, поэтому переписать существующие драйверы CD-ROM и ленточных накопителей SCSI для аппаратуры ATAPI сравнительно просто.

Помните, что "умные" контроллеры, не распознающие ATAPI, в основном кэш-контроллеры, могут быть сбиты с толку пакетными командами. Обычно регистр данных используется для передачи 512-байтных секторов; 12-байтный командный пакет - это совершенно иная штука, которая будет восприниматься (умным) контроллером по-другому.

11.2 Что особенного во вторичном порте?

В принципе ничего. Вторичный порт IDE существовал на картах ввода-вывода компьютеров в качестве резерва в течение многих лет (базовый адрес 0170h, IRQ 15), и адаптеры, которые можно настроить как вторичные, существовали в течение достаточно долгого времени, хотя поддержки BIOS и не было. Таким образом, поскольку этот компонент является частью EIDE, в нем нет ничего нового, за исключением того, что возможность подключения ленточных накопителей и CD-ROM к адаптеру ATA сделала поддержку четырех устройств не роскошью, а необходимостью.

На самом деле есть еще одна причина для использования вторичного порта для устройств ATAPI. Имеется целый ряд усовершенствований аппаратуры интерфейсов жестких дисков, например, буферы предварительной выборки или запись с запаздыванием, которые могут быть полезными в смысле совместимости с ATAPI. Это означает, что, если драйвер интеллектуального порта ATA-2 не распознает ATAPI или просто не выполняет своих функций, то Вы можете столкнуться с неприятными проблемами. Вторичный порт, выполняющий только базовые функции АТА, особенно в том случае, если Вы работаете с ATAPI CD-ROM, который не поддерживает режим PIO mode 3, позволит Вам избежать головной боли.

Наконец, устройство ATAPI на первичном порте вызывает сбой драйверов Windows FastDisk, не распознающих ATAPI.

Ничто не мешает Вам определить дополнительные порты наподобие первичного и вторичного; третичный и четверичный порты являются почти стандартными устройствами. Установки порта и IRQ для них приведены в разделе 10.4.

предыдущая глава