Электронный учебник "Архитектура ввода-вывода"

Устройства ввода-вывода

[Теория][ Обзор][Практика]

Устройства ввода-вывода служат для преобразования информации из внутреннего представления в компьютере (биты и байты) в форму доступную окружающим, и обратно. Под окружающими понимают как людей, так и другие машины. Устройства ввода-вывода связывают компьютер с внешним миром, без них он был бы "Вещью в себе". Список устройств, делающий компьютер "вещью для нас" практически неограничен. Сюда входят устройства ввода - мышь, клавиатура, сканер, джостик, трекбол, устройства оцифровки звука и видеоизображений. Устройства вывода - алфавитно-цифровые и графические мониторы, принтеры, плоттеры, акустические устройства и прочие устройства в великом множестве их разновидностей. Всё это а также многое другое рассмотрено в данном учебнике.
Весь матриал разделён на три основные части: 1. Теория; 2. Обзор; 3. Практика. После изучения которых Вы с полной уверенностью можете сказать: "Теперь я это знаю!!".

Также я хочу выразить благодарность людям, которые непосредственно участвовали в разработке учебника.


Эта страничка целиком и полностью посвящена людям, которые помогли создать, то где Вы сейчас находитесь. И так преступим!

Моей МАМЕ
За то, что она "оттаскивала" меня от компьютера, и предлагала съесть что-нибудь.
Серебрянской Людмиле Викторовне
За идейное вдохновление проекта.
Абубекарову Рустаму
За предоставление такой нужной вещи, как сканер, а также за краткий курс "Сканирование для особо одарённых" :-).
Брунько Александру
За создание дизайна.
Овчинникову Антону
За предоставление песен, без которых в голову бы ничего не пришло.
Разработчикам проигрывателя winAMP
Просто за то, что они создали эту программу.


Тест № 1.

1. Для долговременного хранения информации служит:
ПЗУ
ОП
процессор
ВП

2. Вы работаете на компьютере с 4-байтовым машинным словом. Адреса машинных слов меняются с шагом
16
2
8
4
1

3. Какое устройство компьютера может оказать вредное воздействие на человека?
гибкий диск;
монитор;
системный блок;
клавиатура.

4. В высказывание «… памяти означает, что любая информация заносится в память и извлекается из нее по…» вместо многоточия вставить правильные выражения:
дискретность, адресуемость;
адресуемость, байтам;
дискретность, битам;
адресуемость, значениям;
адресуемость, адресам.

5. Перечислить все виды памяти компьютера в порядке возрастания их объема:
регистры процессора, ОП, ВП;
ВП, ОП, регистры процессора;
ВП, регистры процессора, ОП;
ОП, ВП, регистры процессора.

6. В целях сохранения информации гибкие магнитные диски необходимо оберегать от...
перепадов давления;
света;
холода;
магнитных полей.

7. В каком устройстве производится обработка информации?
дисплей;
клавиатура;
внешняя память;
процессор.

8. Для чего предназначен сканер?
сканер – устройство, которое позволяет вывести изображение на экран;
сканер – устройство, которое служит для ввода в компьютер изображение, уже имеющегося на бумаге;
сканер – устройство, предназначенное для распечатки изображения на бумаге.

9. Чем мышь отличается от клавиатуры?
с клавиатуры можно вводить текстовую информацию и графическую, а мышь служит для ввода текстовой информации;
с клавиатуры удобно вводить в компьютер текст, а мышью хорошо рисовать;
клавиатура позволяет перемещаться по экрану быстрее, чем при работе с мышью.

10. Для чего предназначен модем?
для печати изображений, имеющих в компьютере;
для связи компьютеров через телефонную сеть;
для ввода графической информации в компьютер.

11. Для работы мыши необходимо специальное программное обеспечение, называемое:
текстовым процессором;
драйвером;
операционной системой.

12. Чем отличается параллельный порт от последовательного?
параллельный служит для подключения мыши, а последовательный для всех остальных ус-в;
в последовательном порту информационные биты передаются последовательно один за другим, а в параллельном – несколько битов данных передаются одновременно;
параллельный позволяет подключать одновременно несколько периферийных устройств, а последовательный – одно устройство.

13. В чем измеряется скорость модемов?
в битах;
в байтах;
в битах в секунду;
в Кбайтах.

14. Что нужно сделать прежде, чем выключить компьютер?
вынуть электровилку из розетки;
выключить стабилизатор;
закончить работающие программы.

15. Назовите недостатки внешних модемов.
их неудобно регулировать;
не имеют корпуса;
более высокая цена, нужен кабель и последовательный порт.

16. К какому виду ПО относится ОС?
к системному ПО;
к уникальному ПО;
к системам программирование;
к прикладному ПО

17. Чем характеризуется множество реализуемых в ЭВМ операций обработки, хранения и обмена информации?
производительностью ЭВМ;
быстродействием ЭВМ;
операционными ресурсами.

18. Что такое системное программное обеспечение?
СПО – это совокупность программ, управляющих процессом обработки информации в компьютере;
СПО – это комплекс программ, предназначенных для решения задач определенного класса;
СПО – это программы – переводчики с cимволического языка на машинный.

19. Что такое система программирование?
Системы программирование – это комплекс программ, предназначенных для решения задач определенного класса;
Системы программирование – это совокупность программ, управляющих процессом обработки информации в компьютере;
Системы программирование – это комплекс программ, предназначен для написания программ и перевода их в машинный язык.

20. Какие функции выполняет арифметико-логическое устройство (АЛУ)?
обеспечивает связь ЭВМ с внешней средой;
управляет работой всех устройств, входящих в ЭВМ;
выполняет арифметические и логические операции.

21. Для чего нужны прикладные программы?
для управления процессом обработки информации находящейся в ОП;
для решения задач пользователя;
для перевода программ в машинные кода.

22. Емкость памяти измеряется:
в см3;
количеством хранимых в ней символов;
в битах, байтах, Кбайтах и т.д.

23. Для чего предназначено устройство управления?
УУ производит вычисления;
УУ производит диалог с пользователем;
УУ реализует программное управление, т.е. выбирает команды из памяти и выполняет их.

24. Быстродействие ЭВМ характеризует:
время, за которое решается одна задача;
число операций, выполняемых в секунду;
время выполнения одной операции.

25. Из каких частей состоит процессор ЭВМ?
из устройств ввода/вывода;
из ОЗУ, ПЗУ, ВЗУ, УУ;
из АЛУ, УУ.

26. Из каких основных частей состоит персональный компьютер?
системный блок, мышь, монитор;
системный блок, принтер, клави
монитор, системный блок, принтер;
монитор, системный блок, клавиатура.

27. Какие компоненты размещаются в системном блоке?
блок питания, дискеты, дисковод, платы;
материнская плата, дисководы, НЖМД, блок питания, модем;
накопители ГМД, НЖМД, блок питания, материнская плата.

28. Для чего нужен микропроцессор?
он служит калькулятором;
он используется для ввода информации в компьютер;
он управляет работой всех устройств и производит вычислительные операции в соответствии с программами.

29. Основным компонентом системного блока является:
блок питания;
НГМД;
НЖМД;
Материнская плата.

30. Чем отличаются RAM и ROM?
RAM – в нее можно только записывать информацию, ROM - можно и записывать в нее информацию, и считывать информацию оттуда;
RAM и ROM предназначены для записи и считывания информации и ничем не отличаются;
RAM - память с произвольным доступом, ROM - память только для чтения, содержимое памяти ROM в отличии от RAM неизменно.

31. Для чего предназначен математический сопроцессор?
он позволяет ускорить выполнение математических операций за счет того, что выполняет вычисления, а микропроцессор в это время занимается чем-то другим;
он управляет работой компьютера, пока микропроцессор производит вычисления;
ими заменяют микропроцессоры в старых компьютерах.

32. Что такое BioS?
это программа, записанная на дискету, управляющая работой компьютера;
это обычная программа, записанная на жесткий магнитный диск;
это программа начальной загрузки, записанная в ПЗУ.

33. Что такое монитор?
это электронная плата;
это устройство ввода информации;
это устройство отображения информации

34. Что такое НГМД?
НГМД состоит из дисковода и дискет и служит для записи информации на дискеты и считывания информации с дискет в память компьютера;
НГМД состоит из дисковода и платы контроллера и предназначен для записи информации на дискеты и считывания информации с дискет в память компьютера;
НГМД – это плата, позволяющая записать информацию на дискеты или считать информацию с дискет в память компьютера.

35. Что такое видеоадаптер?
это устройство ввода информации;
это электронная схема, управляющая монитором;
это устройство отображения информации на основе электронной – лучевой трубки.

36. Чем отличаются НЖМД от НГМД?
НЖМД работает с жестким магнитным диском, обладает большим быстродействием, вмещает больше информации и хранит ее дольше и надежнее;
НЖМД работает немного медленнее и вмещает меньше информации, чем НГМД;
НЖМД имеет больше размер за счет использования жесткого магнитного диска.

37. Для чего предназначены принтера?
для ввода графической информации;
для вывода текстовой информации;
для вывода результатов работы на печать.

38. Чем отличается текстовый и графический режимы работы мониторов?
в текстовом режиме могут работать только монохромные мониторы, а в графическом - только цветные;
в текстовом режиме выводится только текстовая информация, а в графическом – и текст и графика (т.е. рисунки, схемы, диаграммы и т.д.);
в текстовом режиме выводится только текстовая информация, а в графическом – графическая (т.е. рисунки, схемы, диаграммы и т.д.).

39. Что такое картридж?
это лента для матричного принтера;
это кассета c краской для принтера;
это распечатанное на бумаге или на другом носители изображение.

40. Память какого вида используется для записи и чтения информации?
ОЗУ;
ПЗУ;
Гибкие диски;
Жёсткие диски.

41. Что общего у всех современных ЭВМ?
все современные ЭВМ решают одинаковые задачи;
все они имеют одинаковое быстродействие;
все они построены по принципу программного управления.

42. Модем обеспечивает:
модуляцию (преобразование двоичной информации в аналоговую);
демодуляцию (преобразование аналоговой информации в двоичную);
усиление сигнала;
модуляцию и демодуляцию.

43. Буфер принтера – это
устройство для подключения принтера к компьютеру;
часть внешней памяти, куда поступает печатаемый текст;
часть оперативной памяти, куда поступает печатаемый текст;
программа, связывающая принтер с процессором;
программа, связывающая принтер с оперативной памятью.

44. Принцип открытой архитектуры означает, что:
компьютер сделан единым неразъемным устройством;
возможна легкая замена устаревших частей компьютера;
новая деталь компьютера будет совместима со всем тем оборудованием, которое использовалось ранее.

45. Какое устройство обладает наименьшей скоростью обмена информацией?
жесткий диск;
микросхемы оперативной памяти;
дисковод для гибких дисков;
CD – ROM – дисковод.

46. Перечислить виды памяти компьютера в порядке возрастания их объема:
НГМД, СD-диски, НЖМД;
СD-диски, НГМД, НЖМД;
НГМД, НЖМД, СD-диски.

47. Объем не ограничен – это характеристика
ОЗУ;
ВЗУ;
ПЗУ.

48. Если бы вы хотели сохранить информацию как можно дольше вы бы сохранили ее на
ЖМД;
ГМД;
СD-диск;
OП.

49. Какой принтер обладает наилучшим качеством печати?
матричный;
струйный;
лазерный.

50. Контроллер – это
устройство для связи ОП и процессора;
плата для управления внешним устройством;
устройство вывода.

51. Тактовая частота – это характеристика...
ОП;
материнской платы;
процессора.

52. Энергозависимая - это характеристика
ОЗУ;
ПЗУ;
ВЗУ.

53. На ГМД 2 стороны, 80 дорожек, 18 секторов. Каков объем этого диска?
360 Кб;
1,2 Мб;
720 Кб;
1,44 Мб.

54. Идея совместного хранения программ и данных в общей памяти компьютера принадлежит
Джон фон Нейману;
Чарльзу Бэббиджу;
Говарду Эйкену.

55. Для обмена информацией между двумя ПК используют
ЖМД;
ГМД;
CD-диски.

56. Форматирование производится для...
удаления всей информации с диска;
подготовки нового диска к работе;
увеличения объема информации.

57. Какое устройство относится к устройствам хранения информации на магнитной ленте:
плоттер;
трекбол;
стример.

58. Сколько дискет 3,5 дюйма (макс V) потребуется для хранения 7300000 байт
7;
5;
6;
50.

59. Разрядность - это характеристика?
процессора;
ОП;
системной шины.

60. В высказывании «Программа, хранящаяся во внешней памяти, после вызова на выполнение попадает в ... и обрабатывается ...» вместо многоточия вставить правильные выражения:
Устройство ввода, процессором;
Процессор, регистрами процессора;
Постоянное запоминающее устройство, процессором;
Оперативную память, процессором.

61. Компьютер может читать и записывать информацию в
ROM;
RAM;
Кэш-память.

62. К параллельному порту можно подключить:
Сканер;
Принтер;
Мышь;
Модем.

63. Какие действия нельзя производить с компьютером, если он включен?
вставлять/вынимать дискету;
отключать/подключать внешние устройства;
перезагрузку ПК нажимая кнопку RESET;
перезагружать ALT+CTRL+DEL.

64. Шина управления -
передает адреса ячеек памяти или номера портов ввода/вывода;
состоит из 8, 16, 32 сигнальных линий, каждая из которых передает одну двоичную цифру;
передает сигналы, определяющие характер обмена информацией ввода/вывода и сигналы синхронизирующие взаимодействие устройств участвующих в обмене.

Ваша оценка:


Тест № 2.

1. Информация о том, в каком месте на диске хранится ОС, расположена в
регистрах ОЗУ;
ПЗУ;
АЛУ;
регистрах процессора.

2. Разрядность компьютера -
число регистров в компьютере;
число регистров в триггере;
число триггеров в компьютере;
число триггеров в регистре.

3. УУ является частью
ОЗУ;
ПЗУ;
процессора;
АЛУ;
оперативной памяти.

4. Логические операции над данными производит
УУ;
ПЗУ;
оперативная память;
АЛУ.

5. Периферийные устройства подключаются к материнской плате через
регистры;
слоты;
контроллеры;
внешние устройства.

6. С 4 Мбайтами может работать процессор
8086;
80286;
80386.

7. Тактовую частоту 100МГц имеет процессор
80386SX;
80386DX;
486SX;
486DX;
Pentium.

8. К основным периферийным устройствам относятся
устройства управления курсором, клавиатура, монитор, дисковод;
монитор, клавиатура, дисковод;
дисковод, принтер, монитор.

9. 256 цветов в графическом режиме имеет монитор
CGA;
EGA;
VGA;
SVGA.

10. Размер сектора диска состовляет
128 байт;
256 байт;
512 байт;
1024 байт.

11. 3-дюймовую дискеты марки DS/DD можно отформатировать максимум
360Кбайт;
720Кбайт;
1,2Мбайт;
1,44Мбайт.

12. 3-дюймовую дискеты марки DS/HD можно отформатировать максимум
360Кбайт;
720Кбайт;
1,2Мбайт;
1,44Мбайт.

13. Картридж с красящей лентой используется в
струйном принтере;
стримере;
сканере;
матричном принтере.

14. Наихудшее качество печати у
струйного принтера;
матричного принтера;
графопостроителя.

15. Для резервного копирования данных на винтчестере предназначен.
сканер;
модем;
трекбол;
плоттер;
стример.

16. Сколько данных (максимум) можно записать на обычный компакт диск
420Мбайт;
620Мбайт;
640Мбайт;
1024Мбайт.

Ваша оценка:


Тест № 3.

1. Для чего предназначен сканер?
сканер - устройство позволяющее вывести изображение на экран;
сканер - устройство, которое служит для ввода в компьютер изображения, уже имеющегося на бумаге;
сканер - устройство, предназначенное для распечатки изображения на бумаге.

2. Чем сканер отличается от фотокопировального аппарата?
ничем;
размером и ценой;
тем, что вместо копирования преобразует изображение в понятную компьютерную форму и записывает его на диск.

3. Назовите преимущества планшетных сканеров
высокое качество сканирования;
низкая стоимость, небольшиу габаритные размеры;
очень высокая скорость сканирования.

4. Назови преемущество барабанных сканеров
минимальные габариты;
самая низкая цена;
наилучшее качество сканирования.

5. Какую глубину точки имеют штрихорые сканеры
1 бит;
8 бит;
12 и более бит.

6. Что такое автокалибровка
подготовка компьютера к работе со сканером;
автоматическое сканирование;
автоматическая настройка сканера с целью уменьшения потерь качества.

7. Назовите достоинства беспроводных мышей
провод не путается под рукой;
позволяет работать на удалённом расстоянии;
низкая цена.

Ваша оценка:


Тест № 4.

1. Что такое 3DNow!
трёхмерный звук;
дополнительный набор мультимедийных команд в процессорах фирмы AMD;
возможность видеокарты реализовывать специальные эффекты.

2. Что такое MNP5
протокол сжатия данных при передачи их при помощи модема;
стандарт уровня излучения монитора;
обозначение микросхемы запоминающего устройства.

3. Что такое MPRII
тип процессора;
стандарт качества звука;
щведский стандарт, определяющий максимальный уровень электрических и магнитных полей.

4. Что такое CD-RW
марка машинного масла;
устройство на оптических дисках с возможностью многократной записи;
обозначение модели CD-ROM.

5. Что такое Р-рейтинг
персональный рейтинг шахматиста;
индекс процессора фирм AMD и Cyrix, значение которого равно тактовой частоте Pentiuma;
сравнительная характеристика скорость передачи информации.

6. Для чего нужен DSP-процессор
специальный сигнальный процессор, установленный на звуковых картах высокого класса для создания сложных эффектов;
новый тип центрального процессора, включающий средства обработки мультимедиа;
процессор для кухонного комбайна.

7. Что такое LCD-монитор
один из известных наркотиков;
монитор с малым линейным искажением;
монитор с экраном на основе жидкокристаллической матрицы.

8. Что такое AGP
тип графического принтера;
современный самый быстрый тип графического интерфейса;
сигнальный мультимедийный процессор.

9. Что такое IDE
интерфейс для подключения устройств накопления информации;
тип слота расширения на материнской плате;
сокращённое название шахмотной федерации.

10. Что такое ATX
форм-фактор, определяющий размеры и типы разъёмов корпусов и системных плат;
тип интерфейса для подключения CD-ROM;
слот расширения для видеокарты.

11. Что такое PC100
марка современного компьютера;
обозначение процессора Pentium с частотой 100 МГц;
спецификация, в которой регламентированы требования к современным модулям памяти.

Ваша оценка:


Часть III - Практика.


Торговая марка SVEN (выдаваемая ушлыми продавцами за шведскую) хорошо известна в России и Украине. Корпорация SVEN основана в 1991 году и имеет офисы на Тайване, в Китае, России и на Украине. Продукция под этой торговой маркой производится главным образом в Китайской Народной Республике. Кто именно является разработчиком и где находится штаб квартира — не разглашается. Особо полюбились народу недорогие активные акустические системы SVEN, сделанные весьма качественно и с претензией на продвинутое звучание. Впрочем, SVEN выпускает и относительно дорогую акустику класса HiFi. Сейчас настал черед недешевых клавиатур, представленных серией: Internet 650, Multimedia 800, Ergonomic 2500, Office 7000, Office 8000 и т. п.

Elegance 5000 действительно очень компактная клавиатура: около 370 мм в ширину, 203 мм в глубину и под 32 мм в высоту (со сложенными подставками) — что заметно экономит место на рабочем столе. При этом все клавиши обычного размера, но скомпонованы они плотненько, одна к одной, как на ноутбуке. Высота самих клавиш и цвет (темно-серый) — типично ноутбучные. Даже нанесение кириллицы краской темно красного цвета — и то, видимо, позаимствовано с ноутбуков Toshiba. Кстати, при недостаточном или неудачном освещении темно красные буквы-надписи на темно сером фоне клавиш видны плохо. Складывается впечатление, что где-то скопились нереализованными клавиши для ноутбуков, вот их и решили присобачить к авангардной клавиатуре для десктопа Впрочем, в отличие от некоторых бюджетных ноутбуков, имеющих подозрительно хлипкую механику клавиш, Elegance 5000 вышла основательной и добротной. Ничего не прогибается, не трясется, не хрустит и не щелкает.

Изюминка Elegance 5000 не только в том, что она компактна, — вдобавок это еще и мультимедийная модель, плюс четырнадцать аккуратных круглых кнопок в ряд над стандартными функциональными клавишами. Самая крупная отвечает за включение и выключение АТХ-компьютера. Мультимедийные кнопки выполняют типичные операции: уменьшение и увеличение громкости звука (общей, в микшере Windows), пуск/пауза воспроизведения звука (посредством специального программного плейера, о чем ниже), ну и, конечно, стоп, трек вперед и трек назад. Интернет/офисные кнопки выполняют быстрый вызов браузера, почтовой программы, поиска файлов, избранного, калькулятора, а также переход на предыдущий и последующий просмотренные сайты. Все четырнадцать дополнительных кнопок работают только в Windows (98/Me/ 2000/XP), отклик на их нажатие практически мгновенен, по крайней мере на 2000-м Селероне с 256 мегабайтами памяти.

Корпус клавиатуры сделан из пинципиально иной пластмассы, нежели клавиши. Серебристая краска напылена (правда, приличным по толщине слоем) на бело-серую пластмассу. Округлая блестящая выпуклость в верхнем правом углу клавиатуры, до близкого знакомства принимаемая мною за манипулятор, оказалась банальным зеркальцем, причем откровенно бутафорским. Секретарши, администраторши и бизнес-леди смотреться в него не захотят, так как отражение искажается до уродливо обезьяннего. Остальные юзеры тоже будут разочарованы: кривизна выпуклости слишком мала, чтобы оптически контролировать приближение нежеланных гостей (например, начальника) с тыла, не поворачивая головы.

Ход основных клавиш небольшой, с фиксируемым нажатием. Кто привык к ноутбучной клавиатуре, тому понравится. Заявленная бесшумность скорее рекламный трюк. Да, клавиши не клацают, как механические десятилетней давности. Но нажатие до упора, необходимое при беглом вводе текста, вызывает хорошо слышимый звук (например, через телефон), хотя и не раздражающий. Судя по качеству клавиш, вряд ли они начнут залипать даже спустя несколько лет интенсивной эксплуатации. Чтобы спровоцировать поломку, производитель предлагает нажать хотя бы на одну клавишу не менее 10 млн. раз.

SVEN предпочла разработать свой аудиоплейер, а не подобрать ключи к тому же WinAmp. И тем самым повязала пользователя по рукам и ногам. Конечно, плейер от SVEN без проблем крутит/понимает МР3-файлы, обычные аудио- и DivX-видеодиски. Зато со всеми остальными форматами мультимедиа (в частности, OGG, WMA, АС-3, ААС, VOB) ситуация удручающая; добавлю, что плейер не понимает 24-битные WAV-файлы. И, честно говоря, верится с трудом, что фирма готовит новые версии этого приложения.

Помимо аудиоплейера предусмотрен ряд стандартных примочек, в частности, переопределение горячих клавиш. Из сервисного программного обеспечения от SVEN следует отметить Mail Checker, который через указанные промежутки времени проверяет электронную почту и высвечивает количество писем, пришедших на ваш почтовый сервер.

На десерт. Предусмотрен выбор стороннего DVD-плейера из пяти обозначенных (WinDVD, PowerDVD, CreativeDVD, ATI DVD и Real Magic DVD). Действительно, софт видит установленные в системе плейеры, только вот всплыла одна странность. При инсталлированных драйверах управление с клавира выбранным DVD-плейером не пашет напрочь. Зато если драйверы клавиатуры снести (или не ставить вообще), то Elegance 5000 непостижимым образом находит PowerDVD и обеспечивает успешное им управление (включая громкость звука), причем с быстрой реакцией. Спрашивается, если есть PowerDVD, зачем вообще специальный софт Elegance 5000 ставить? Тем более что офисные и Интернет-кнопки и без него работают.

SVEN в очередной раз порадовала качеством изготовления и дизайном, но огорчила мелкими недоделками и озадачила отдельными техническими решениями. Клавиатура Elegance 5000 идеально смотрится рядом с серебристым жидкокристаллическим монитором, в паре с модным алюминиевым корпусом или серебристой мышью. Элегантно-респектабельная вещица, что и говорить. Рекомендуется привыкшим к вывертам распальцовки ноутбучных клавиатур и всем ценителям прекрасных форм.

Преимущества | Недостатки
• Замечательный дизайн • Короткий (ноутбучный) ход клавиш • Компактность • Комфортно длинный кабель (2 м) • Малый вес | • Вместо никчемного зеркальца напрашивается манипулятор типа трекбола • Требуется длительное привыкание, чтобы быстро находить клавиши End , Home , Del • Управление воспроизведением ограниченного числа форматов в фирменном аудиоплейере • Клавиатура не видит WinAmp и другие популярные аудиоплейеры • Странное взаимодействие с популярными сторонними DVD-плейерами


Едва ли кто не знает, но на всякий случая напомню: эргономичные клавиатуры отличаются от обыкновенных поделенным надвое полем клавиш. Половинки располагаются под углом друг к другу на небольшом расстоянии, а сама клавиатура нередко имеет «горб» в центре. Смысл такой конструкции двойной. Во-первых, позволить человеку во время печати принять более естественную позу (хотя бы слегка развести в стороны кисти рук и держать руки свободно). Если еще принять во внимание продуманную подставку под запястья, обязательно прилагающуюся в комплекте с «человеколюбивыми» моделями, можно надеяться, что на эрго-клаве заработать какой-нибудь туннельный синдром будет гораздо труднее, нежели за обычной. Особо продвинутые модели позволяют даже менять угол наклона алфавитных модулей.
Второе предназначение эрго-клавиатур — освоение десятипальцевого слепого метода печати. Если кто пробовал учиться по методике «ФЫВА + ОЛДЖ = месяц убитого времени», разработанной Владимиром Шахиджаняном, — знает, что у «слепого машиниста» правая и левая рука печатают каждая на своем поле клавиш, и поля эти не пересекаются. Соответственно в этом и есть главный смысл разделения эрго-клавиатуры на две половинки, чтобы пальцы и не «думали» лезть на чужое поле. В некоторый моделях можно менять угол между двумя половинками или вообще разделять клаву на две, никак не соединенные части!
Но формой клавиатуры дело не заканчивается: все дизайнерские изыски могут быть начисто перечеркнуты ватно- невнятно нажимающимися клавишами, поэтому эрго-клава непременно должна быть собрана на совесть из самых отборных компонентов. По конструкции клавиатуры принято делить на три класса. В мембранных моделях (они же — «резиновые»), коих абсолютное большинство, контакты наносятся на внутреннюю поверхность гибкой мембраны. От нажатия клавиши мембрана прогибается, и контакты соприкасаются, а при отпускании — самостоятельно распрямляется. Саму клавишу дополнительно подпружинивает резиновая пластинка. Кроме дешевизны, у такой технологии (но только в случае достойного воплощения!) есть и другие преимущества: например, низкий шум механизма при скоростном наборе текста и хорошая влагостойкость. Пролив на клавиатуру некую не слишком агрессивную жидкость, можно надеяться, что после просушки или даже «стирки» (тот же сладкий кофе, скорее всего, придется вымывать) она опять заработает, ведь контакты находятся внутри герметичных мембранных подушечек.
Но для господ эстетов, желающих получить почти вечную клавиатуру с неизменно четко нажимающимися клавишами, есть конструкции и получше. Например, полумеханические. В них контакты размыкаются пружинками, способными сохранять упругость гораздо дольше мембран. В чисто же механических моделях не только размыкание контактов, но и весь ход клавиши сопровождается сжатием пружины или комбинации пружины и резинового амортизатора. Благодаря такой схеме цикл «нажал — отпустил» становится исключительно четким и приятным. Правда, купать в воде такие суперклавы в общем случае чревато, хотя существуют и водостойкие механические модели. Главные же недостатки «механики» — высокая цена и крайне скудный выбор моделей. Вообще, страсти по комфортной печати нужны лишь тем, кому приходится регулярно и по много часов набирать тексты. Что ж тогда получается — для всех остальных вдумчивый выбор клавиатуры лишен смысла? Не совсем. «Клаво- производители» рассчитывают привлечь к своей продукции внимание и таких индивидов — например, «мультимедийными» кнопками. На первый взгляд, эти кнопки — явное излишество, зачем заводить дополнительные, когда и традиционные-то клавиши задействуются далеко не все? Тот же ряд функциональных клавиш повсеместно работал лишь во времена DOS и Norton Commander, а ныне все больше пылится. Но, согласитесь, одно дело, когда приходится запоминать, что вызов почтовой программы закреплен, скажем, за F5, и совсем другое — нажимать прямо на «конвертик», заметный и характерный рисунок на отдельной кнопке. Причем расположение, набор кнопок и характер их нажатия у разных моделей сильно разнятся, и не в последнюю очередь именно эти нюансы определят, захотите ли вы вообще пользоваться дополнительными кнопками у новоприобретенной клавиатуры.
Cherry
Немецкая компания Cherry первой в мире выпустила «гнутую» модель. То была полностью механическая (!) Cherry Ergo с регулируемым (!!) углом фиксации «половинок», позолоченными контактами (!!!), и она долго не уступала места на высшей ступеньке пьедестала. Увы, этот шедевр так и остался «памятником», возможно, из-за недостаточного спроса. И сейчас эргономических клавиатур классического типа в линейке Cherry нет. Хотя столь же дорогих (от $100) моделей предостаточно, только теперь эта цена набирается за счет оригинальной раскраски, беспроводного интерфейса и считывателей смарт-карт (карточки служат ключом, без которого нельзя войти в ОС). Плохо представляю себе логику людей, польстившихся на эти опции. А «секретки», на мой взгляд, и вовсе вредны, ибо создают ложное впечатление защищенности, на практике же совершенно бесплатная софтверная защита (зашифрованный в PGP диск вкупе с запароленным входом в Windows 2000 или XP) как минимум не менее надежна. Конечно, остается удобство (не надо вводить пароль), крутой имидж и т.п.

Но, на мой взгляд, в нынешней линейке Cherry преимущественный интерес представляют относительно недорогие классические модели. Например, полумеханическая G81-3000 LUNRB-0 с минимальным набором мультимедийных клавиш, и еще более строгая (без «мультимедии») механическая G80-3000 HPMRB, допускающая 100 000 миллионов (это ж сколько печатать надо?!) нажатий на каждую клавишу. Если есть желание получить «самую мультимедийную» клавиатуру от Cherry, стоит присмотреться к беспроводной CyBo@rd, только не рекомендую брать ее в комплекте с мышью, дороговато, а сама мышка — не шедевр.
Тем не менее, Cherry в нашем обзоре появилась не только из уважения к известному брэнду. Если вас интересуют полумеханические или полная «механика», придется обращаться исключительно к продукции этой фирмы. Все остальные выпускают сплошь «резинки» (но еще раз подчеркну — для дома механические клавиатуры, по моему мнению, шумноваты).
Microsoft
Хронологически следующей после Cherry Ergo эргономической клавиатурой была Microsoft Natural Keyboard, именно с нее мода на «гнутый» дизайн пошла в народ. И по сей день «натуральная» клавиатура от MS, добавившая к своему названию словечки «Multimedia» и «Pro», остается одной из самых удобных. На мой взгляд, у нее всего один недостаток — маленькая клавиша Enter. Относительно высокая цена никого не удивляет, Microsoft — суть имя, известное даже тем, кто компьютер видел лишь по телевизору.

Logitech
Logitech — тоже видный манипуляторный брэнд и в представлении не нуждается. Но в его обширной линейке человеколюбивых клавиатур раз-два и обчелся, причем обычно они предлагаются в беспроводном варианте вместе с мышью. Сие блюдо называется Logitech Cordless Desktop Keyboard и дешевле сотни у.е. пока нигде не встречается. Кроме высокой цены, снова претензия к маленькому Enter’у и мультимедийным клавишам — в природе существует более логичная их раскладка, да и сами кнопки неплохо бы сделать побольше. Хотя по совокупности ощущений этот комплект отменно хорош в работе.

BTC
BTC (Behavior Tech Computer) имеет богатейший ассортимент клавиатур, но и среди них обнаружилось лишь несколько искомых. У выдержанной в минималистском стиле BTC 8110W будто бы пропущен один вертикальный ряд клавиш в центре. Хороший выбор для тех, кто пока не уверен — нужна ли ему настоящая «гнутая» модель. Вот только раскладка основных клавиш слишком уж оригинальна. Функциональные выстроены в два ряда, есть дополнительная комбинация стрелок рядом с левым Shift, а клавиши перелистывания и Ins/Del задвинуты «под потолок». В чем-то такая раскладка и удобна (а то, что она компактнее обычной, отрицать трудно), но необходимость привыкать к ней может сильно испортить впечатление. Например, дополнительные стрелки, по-моему, не столько помогают управлять компьютером, сколько мешают печатать. Попасть по ним вместо того же «шифта» проще простого. Для мультимедийных клавиш в этой модели места не нашлось, зато об усыплении/включении компьютера позаботились.
BTC 8120 в отношении раскладки аналогична предыдущей, но в остальном… Клавиатура, единственная из всех ныне продаваемых, действительно состоит из двух независимых половинок, легко подстраивающихся под обе руки. Удобна ли она? Пожалуй, да. Удобнее всех прочих эргономических? Не уверен, поскольку хитрая раскладка и отсутствие мультимедийных клавиш компенсируют со знаком «минус» удобства от свободы передвижения. Кстати, левая половинка пробела и не пробел вовсе, а Eraze Eaze (именно так, с парой грамматических ошибок, как сейчас модно) — двойник Backspace.
BTC 8190 затесалась в эту компанию благодаря самой развитой среди BTC-клавиатур мультимедийности. У нее все свободное от основных клавиш пространство просто-таки усеяно вспомогательными кнопками и кнопочками. И вдобавок ко всему есть колесико для перемещения курсора (Scroll-pad). Мышь, правда, заменить оно не способно в принципе.


Часть II - Обзор.

Тест струйного принтера Epson Stylus Photo 900
SVEN Elegance 5000 - компактная мультимедийная клавиатура.
Cordless Presenter уникальная мышь-докладчик от Logitech
Microsoft Optical Mouse Blue новейшая оптическая мышь из Редмонда
Комплект Cordless Desktop Optical — свобода, выкупленная у Logitech
Крутому ноутбуку — крутую мышь
Новое семейство мышей от Logitech MX300, MX500 и MX700
Эргономичные клавиатуры
LCD vs CRT — противостояние технологий
Обзор LCD-монитора Sony SDM-N80
Обзор жидкокристаллического монитора Sony SDM-X52


В бытность свою работником (точнее сказать — я обзывался гордым словом «менеджер») компьютерного салона, бюджет такой периферии, как мышь, клавиатура и коврик считался чем-то, совершенно не стоящим внимания. Люди приходили, покупали компьютеры, прикидывали стоимость будущего электронного друга, и на вопрос «А как же, ведь еще нужна мышь и клавиатура?!» менеджер лениво махал рукой в сторону витрины с запылившимися Genius-ами и Microsoft-ами, произнося ничего не значащим тоном — «А-а, это ерунда… Максимум, баксов 15.» И был, как ни странно, прав.
Критерий первый. Удобство.
 Обычные «хвостатые» друзья неудобны уже в первую очередь наличием оного. В первую голову это, конечно, относится, к мышам. «Хвост», он же провод, необходимо грамотно протянуть от системного блока, при этом его длины должно хватать, и при движении мышью он не должен ни за что цепляться (а на собственном опыте могу Вам с уверенностью сказать — иногда это имеет место). К тому же, провод постоянно пачкается от трения о поверхность рабочего стола, вследствие чего имеет постоянно неопрятный вид. Для клавиатуры все вышесказанное практически неактуально, так как она твердо покоится на уготованном ей месте, длины провода почти всегда хватает (на крайний случай — можно приобрести удлинитель), но пачкается при этом почему-то клавиатурный провод не меньше.
Если говорить об обычных, роликовых «грызунах» (это у тех, которых внутри стальной шарик, покрытый резиной) и два-три пластмассовых ролика, то у них есть еще одна большая проблема. Для нормальной работы им необходим коврик, желательно с пластиковым покрытием. Коврик необходимо регулярно мыть от грязи, которую собирает на нем резиновое покрытие шарика, а также необходимо аккуратно очищать от грязи сам шарик и ролики (примерно раз в 3-4 недели).
Плюсы у «хвостатых друзей, конечно, есть». В первую очередь, такие устройства наиболее распространены, и неприхотливы в эксплуатации. Срок жизни дешевых девайсов такого племени — от месяца до полугода, устройства т.н. «среднего класса» (Genius, A4Tech) живут от полугода до полутора лет, «именитые» грызуны от Logitech иногда существуют и до 3-х лет.
Оптические проводные мыши имеют только недостатки, связанные с наличием самого провода. В остальном они намного удобнее своих «хвостатых сородичей».
Вряд ли имеет смысл описывать саму технологию работы оптической мыши — она всем известна, а вот отсутствие необходимости регулярной чистки, большая долговечность, возможность работы практически на любой поверхности, исключая, пожалуй, лишь зеркальные и стеклянные — плюсы несомненные. Если к этому прибавить в 1.5 — 2 раза точность позиционирования (от 400 до 800 dpi), и отсутствие коврика как класс — становится понятно, насколько роликовые мыши проигрывают в удобстве работы своим оптическим собратьям.
Что касается беспроводных оптических устройств — вопрос несколько спорный. С одной стороны, помимо всех плюсов, присущих оптическим мышам, исчезает привязка к системному блоку, однако в радиусе видимости пользователя появляется некая коробочка, выполняющая функцию приема радиосигнала (поскольку от инфракрасных технологий производители практически отказались, в силу необходимости размещать приемник сигнала в зоне видимости самого устройства — мыши или клавиатуры). Считать это недостатком или не считать — дело за пользователем, однако это есть объективная необходимость и с ней приходится мириться. К тому же, к беспроводным устройствам периодически приходится приобретать батарейки, но это, скорее, уже относится к вопросу цены.
Критерий второй. Цена.
 Что говорить, для российского пользователя критерий немаловажный, и вопрос здесь, пожалуй, лишь в том, окупит ли цена устройства все те удобства, которые оно призвано предоставить покупателю. Иными словами, устраивает ли пользователя то самое сочетание «цена / качество», по достижении оптимального значения которого уже не жалко отдавать свои кровные, ибо, как известно, покупка без улыбки — деньги на ветер.
Итак, обычные проводные девайсы низшего класса стоят в пределах 3(!) — 5$. Надо ли комментировать, что ровно такую же сумму Вам придется выкладывать каждые полгода, а комфорт работы с таким устройством — удовольствие ниже среднего. Гораздо разумнее, на наш взгляд, приобрести девайс от Genius, а лучше — Logitech ценою примерно от 7 до 15$ (за 13-15$ — это уже USB, что само по себе приятнее), и клавиатуру от BTC (10-20$). Такое приобретение позволит Вам забыть о замене манипуляторов примерно на год или немногим больше, при условии должного содержания и ухода.
Оптические проводные мыши сами по себе уже несколько дороже. Правда при этом радует тот факт, что оптических мышей «noname» на рынке не бывает. Как правило, это очень или достаточно хорошо зарекомендовавшие себя вендоры, начиная от A4Tech и Genius, и заканчивая Dexxa, Microsoft и Logitech. Стоимость таких устройств колеблется в пределах 20-30$.
Что касаемо «бесхвостых» устройств (имеются в виду преимущественно мыши), то здесь уже стоимость устройств сопоставима с некоторыми компонентами системного блока, а посему решение будет приниматься на более серьезном уровне. Судите сами: оптические беспроводные мыши лежат в ценовом диапазоне от 40 до 60$. Плюс примерно каждые полгода Вам придется раскошелиться на комплект качественных алкалиновых батареек. Примерно в эти деньги нынче обходится цена удобства и качества в сочетании со свободой в пределах Вашего рабочего стола.
Критерий третий. Дизайн.
Безусловно, не самый определяющий критерий выбора. Но, тем не менее, если Ваше рабочее место оборудовано по последнему слову техники, корпус не выглядит, как унылая башня цвета ivory, в тонах LCD монитора и компьютерного стола преобладают серый / голубой металлик или черный, теперь Вы всегда сможете подобрать клавиатуру и мышь, подходящую по стилю и цвету. Достаточно посмотреть ассортимент и внешний вид изделий на сайтах, приведенных ниже, чтобы убедится в этом. Дальнейшее принятие решения и походы по магазинам — за Вами.
На днях, благодаря компании «Альянс», к нам в редакцию попал один из последних хитов от многоуважаемой конторы Logitech, состоящий из беспроводной мультимедийной клавиатуры и беспроводной же оптической мыши, под длинным названием Cordless Desktop Optical. «Ну вот, опять будут писать про дорогой Logitech!» — недовольно надуют губы некоторые читатели. Да, пишем, писали, и писать, по возможности будем, ибо писать про вещи которыми в буквальном смысле приятно, удобно и, не побоюсь этого слова, престижно пользоваться — это в некотором смысле удовольствие. А знаете ли Вы, как жалко потом с ними расставаться, когда уже немного попользовался — а к хорошему, как известно, привыкают очень быстро — понял и прочувствовал все прелести хорошей вещи, и вдруг приходится возвращаться обратно к привычному и обыденному, но уже совсем не такому удобному.
Итак, начнем с клавиатуры. Внешний вид описать словами достаточно трудно, поэтому лучше ориентироваться на фото. Округлая нестандартная форма, со съемной подставкой для запястий оставляет приятное впечатление. Цвет корпуса черный, хотя нет, точнее — слегка полупрозрачный графитовый. А вот цвет самих клавиш действительно черный, и русские и английские символы нанесены светлой, почти белой краской, при этом английские символы слегка меньше размером, чем русские. Несмотря на одинаковый цвет, дифференцирование происходит без труда.
Очень приятное впечатление остается от нажатия клавиш. Атака мягкая, и могу сказать, что, по собственным ощущениям, привыкание происходит практически моментально. Верхняя часть клавиатуры увеличена, и функционально поделена на три части. Слева и справа сделаны прозрачные врезки, на которых расположены специальные программируемые кнопки, нажатием которых пользователь может быстро запустить необходимое приложение, зайти на нужный сайт или запрограммировать целое меню с различными функциями. Каждая кнопка имеет свое название, хотя оно вполне может не совпадать с той функцией, которую возложит на нее пользователь. Перечислим их по порядку слева направо: sleep (не программируется, назначение — погружать системный блок в «спячку»), Finance, My Sites, Community, Favorites, iTouch, E-mail, Shopping, Search, My Home.
Средняя часть клавиатуры наиболее проста, и призвана осуществлять управление установленным в системе плеером. Кнопкой Media вызывается собственно плеер, причем если их в системе установлено несколько, то сначала появится меню, содержащее их список. Мышью или клавиатурой можно выбрать необходимый. Слева направо расположены кнопки Rewind, Forward, Play/Pause и Stop — их размер весьма велик, так что промахнуться затруднительно. Некое подобие Jog-dial-а в середине призвано регулировать громкость, ну а что означает кнопка mute справа понятно всем.
На сегодняшний момент Cordless Desktop Optical можно приобрести в московской рознице по цене около 85$. Является ли эта цена завышенной? Для тех, кто предпочтет экономии качество, комфорт и удобство — несомненно, нет. Думаю, что сообразительных пользователей, желающих один раз вложить деньги в действительно классный продукт, вместо того, чтобы периодически менять один ширпотреб на другой, и у нас в стране найдется немало.


ЖК или CRT? Этот вопрос задает себе каждый человек, собравшийся приобрести себе новый монитор. И действительно, жидкокристаллические дисплеи завоевывают все большую и большую популярность. Так, например, в 1997 году было выпущено всего 370 тысяч ЖК-мониторов. А в 2000 году — уже 5,5 миллионов экземпляров. Если же верить прогнозам, то в следующем году будет произведено и продано более 20 миллионов дисплеев. Впечатляет? Еще как. Вот только количество проданных ЭЛТ-мониторов тоже растет, так что в процентном соотношении числа не так значительны. В 1998 году ЖК-дисплеи смогли захватить всего около 1% мирового рынка мониторов. А в 2000 году их число увеличилось до 3,9%. В денежном же эквиваленте структура рынка выглядит немного по-другому. Цифра 3,9 превращается в 11,4. Именно такова была доля ЖК-мониторов в общемировом рынке мониторов в денежном эквиваленте в 2000 году. Кстати, интересно отметить, что среди всех проданных жидкокристаллических дисплеев 25% пошло в различные фирмы, 23% в банки и другие финансовые институты, еще 23% ушло в розничную торговлю и лишь 8% попало в наши с вами квартиры. Причина этого, думаю, всем ясна — цена ЖК-мониторов недоступна подавляющему большинству домашних пользователей.
Но не так давно все изменилось. Цены на жидкокристаллические мониторы начали резко падать. Соответственно, объемы продаж стали быстро расти. И это на фоне очень большой конкуренции на рынке ЭЛТ-мониторов, принуждающей компании вести ценовые войны, которые, конечно, идут на пользу конечному пользователю, но лишают производителей большей части прибылей. Эти события повлекли за собой смещение приоритетов фирм, занимающихся выпуском мониторов в сторону ЖК-дисплеев. И это не замедлило сказаться. Вспомните, сколько новых ЭЛТ-мониторов появилось за последний месяц? А ЖК-дисплеев? Разница чувствительна. Правда, и ЭЛТ-мониторы не собираются сдаваться без боя. Появляются новые модели и технологии, снижаются цены. В результате ЖК-дисплеи еще долго не смогут завоевать лидирующие позиции.
Уменьшение прибылей от производства ЭЛТ-мониторов автоматически снижает и количество инвестиций, выделяемых на исследование новых технологий в этой области. Думаю, всем ясны последствия этого. Теперь немногие компании решаются затрачивать средства на серьезные разработки. Конечно, новые модели появляются, но ничего принципиального в них нет. На таком грустном фоне особенно порадовало недавнее появление новой трубки DiamondTron TrueFlat High Brigntness, разработанной компанией Mitsubishi. В чем же особенность этой технологии?
High Brigntness переводится с английского как «высокая яркость». И действительно, новая трубка отличается от других повышенной яркостью изображения. Это нужно не только для профессиональных дизайнеров, но и для домашних пользователей. Дело в том, что при просмотре фильмов, многие люди сидят достаточно далеко от монитора, и поэтому изображение кажется темным и размытым. А значит, приходится увеличивать яркость. Исходя из своего личного опыта, могу сказать, что изображение на мониторе с технологией High Brigntness очень похоже на картинку с экрана любого другого монитора, у которого яркость включена процентов на 90. За исключением одной детали. Дело в том, что при таком увеличении яркости появляется эффект «выцветания» точек. Интенсивность пучка электронов настолько велика, что возбуждается люминофорное покрытие точек, находящихся в непосредственной близости к адресуемому пикселю. Результат — размытое изображение. На этом фоне мониторы с High Brightness смотрятся, в общем-то, действительно неплохо. К сожалению, подробности новой технологии не разглашаются. Известно только, что новая трубка «знает», что она показывает и подстраивается под изображение. Если верить разработчикам, при отображении текста яркость не превышает 125 — 150 кд/кв.м, а в случае вывода видео этот параметр достигает максимального значения — 300 кд/кв.м. Новая трубка очень приглянулась всем другим производителям мониторов. Первыми появились модели от самой Mitsubishi и IIYAMA.
Вообще, сейчас большинство компаний предпочитают использовать чужие разработки, нежели заниматься своими. Лучшие умы теперь разрабатывают ЖК-мониторы. Даже известный лидер, Sony, и та не смогла придумать ничего лучше технологии FD Trinitron, появившейся в 1998 году. Естественно, есть новые модели, например, G500. В них используются различные системы вроде Digital Multiscan (специальный процессор Sony, обеспечивает автоматическую самонастройку мониторов Sony на любой входной графический режим), Dynamic Quadrupole Lens (компенсирует увеличение размера пятна на экране монитора), ASC (позволяет отцентрировать и пропорционально растянуть изображение до краев экрана «в одно касание»), BCF (обратная связь по току луча) и т.д. Все эти разработки появились в течение последних двух лет. Они не вносят принципиальных изменений в устройство монитора, но довольно приятны для конечного пользователя.
Другие компании также не отличаются большой активностью в области ЭЛТ-мониторов. Как я уже говорил, новые ЖК-модели появляются в несколько раз чаще, чем привычные нам дисплеи. А это значит, что дни ЭЛТ-мониторов сочтены. О сроках я предпочитаю не говорить, тем более не хочу заниматься прогнозами российского рынка. Уж слишком много неизвестных получается в нашем уравнении. Хочу только отметить, что ЭЛТ-мониторы может спасти только чудо. Точнее, открытие чего-либо революционного, чего-либо, что заставить людей снова обратить свой взор на привычные «телевизоры». Правда, после уменьшения инвестиций на исследования, вероятность такого чуда, фактически, не отличается от нуля.


Новую мышь-манипулятор назвали Cordless Presenter, и «беспроводной докладчик», наверное, мог бы все рассказать о себе сам. Если бы дали. На минувшей выставке «CeBIT 2002», например, это был один из ключевых экспонатов Logitech, и говорили за него в основном стендисты.
Дизайн у этого манипулятора безупречен: хорошо чувствуется, что мышь предназначена для работы не только на столе, но и в пространстве. В руке она лежит, простите за сравнение, как новейшие электробритвы Philips. Были и другие сравнения, особенно забавно давать Cordless Presenter в руки девушкам. Что говорили по этому поводу наши сотрудницы, пересказывать не буду — свалю на американок, которых не постеснялся процитировать сайт Hardwarecentral.com: «These things get more phallic every day».
Привычных мышиных кнопок, как ни странно, всего две. Они на удивление небольшие, но под ними скрываются традиционно качественные микропереключатели. Вместо традиционного колеса прокрутки, лучше которого уже вряд ли можно что-то придумать, инженеры выбрали довольно спорную в смысле удобства двухпозиционную кнопку. Впрочем, так кажется только на первый взгляд. Давайте наконец уточним, в чем идея Cordless Presenter. На рабочем столе — это мышь, но ее главное назначение — работать не с настольным монитором, а с презентационным оборудованием, в руке докладчика. Попробуйте продержать полчаса на весу обычную беспроводную мышь, повращать при этом колесо прокрутки — и вы поймете, зачем «Презентеру» такая форма и такие кнопки.
Кроме того, становится очевидно, что скрывается за голубовато-прозрачным дизайном и словом «cordless» — это технология Bluetooth. В паре с мышью поставляется маленький USB-приемник, такого же, как она сама, цвета, из темно-синей полупрозрачной пластмассы, питающийся от порта. Почему Bluetooth? Я вижу несколько объяснений. Во-первых, такие адаптеры стандартизованы в операционных системах, и мышь легко определится на любом компьютере. Во-вторых, обычные беспроводные технологии на прямой видимости, пожалуй, уступают Bluetooth в дальности и пропускной способности. Что касается экономичности Bluetooth, эта технология, пожалуй, прожорливее широко распространенной 27-мегагерцовой технологии, но, с другой стороны, изначально разрабатывалась для миниатюрных портативных устройств и обеспечивает 60–100 часов непрерывной работы. Остается добавить, что мышь питается от двух элементов AA и использует оптический датчик перемещения. Обычный датчик, спешу вас успокоить, — в воздухе не работает. Да, собственно, в воздухе он и не нужен: презентация в PowerPoint уже запущена, для перелистывания слайдов достаточно нажимать кнопки. На столе датчик — опять же от Agilent Technologies — безупречен, и благодаря беспроводному каналу 700 Кбит/с в диапазоне 2,4 ГГц напрочь лишен комплекса неполноценности, которым страдают обычные радиочастотные мыши (кстати, даже самой Logitech), работающие в радиусе двух-пяти пяти метров на частоте максимум до гигагерца (у очень редких моделей).
Что еще может понадобиться для проведения презентации? Правильно, лазерная указка! Она спрятана в остреньком носике «Презентера» и управляется специальной кнопкой на брюшке, точно под указательный палец. Там же, к слову, расположен переключатель режимов работы: выключено, просто настольная мышь и мышь с указкой — все возможные варианты для экономии жизни батарей. Оставленный без дела Presenter, к сожалению, глубоко не заснет и выжрет свежие батареи за несколько суток.
USB-адаптер и мышь имеют по крохотной кнопке, чтобы устанавливать связь между собой (что-то вроде системы «свой–чужой»), и хотя о числе возможных каналов передачи и одновременном сосуществовании нескольких манипуляторов из документации подробнее узнать не удалось, стандарт Bluetooth, напомню, не предусматривает на этот счет никаких ограничений.
В Москве новинку от Logitech пока не купить, даже в «Алионе». Ориентировочная цена на Западе, по разным данным, от ста до двухсот долларов. Недешево, потому и не везут. Остается добавить, что в эти деньги входит пятилетняя гарантия и приятный неопреновый чехольчик для переноски.
Архивы свидетельствуют, что первая Bluetooth-мышь была продемонстрирована тоже на «CeBIT» еще в 2000 году. Но тогда «голубые зубы» только резались, всерьез объявления подобных продуктов, наверное, можно воспринимать только сейчас. Так, например, Microsoft пошла дальше и уже представила прототип комплекта из клавиатуры и мыши. На минувшей выставке «Computex» свой прототип представила Genius, но в целом тайваньская индустрия, ориентированная на недорогие рациональные решения, оценивает перспективы Bluetooth-мышей очень осторожно.


Эта миниатюрная мышь, можно даже сказать мышонок, выглядит необычно. Дизайнеры постарались на славу: MouseMan Traveler, без сомнения, станет изящным дополнением к любому навороченному и супермодному ноутбуку (прилагающиеся к некоторым ноутбукам мыши не идут с ней ни в какое сравнение). Спинка сделана из шлифованной дюрали, а брюшко и бока — из бархатной на ощупь пластмассы. Ярко выраженных кнопок нет: цельную, жестко заделанную со стороны... мордочки (в общем, со стороны, противоположной хвосту) спинку колесо прокрутки как бы делит на две упругие пластины, которые и играют роль клавиш.
Ростом» MouseMan Traveler хотя и мышонок, зато по сути — настоящий мэн. Как упоминалось в предыдущем обзоре, в этой модели используются мини-переключатели от японской компании Omron, а также оптическая пара (светодиодный излучатель и камера) от Agilent, обеспечивающая разрешение 800 dpi — вдвое выше, чем у многих оптических мышей. Благодаря столь высокой точности позиционирования драйвер может настроить скорость движения курсора так, что для его перемещения с одного края экрана в другой достаточно передвинуть мышь на 1–3 сантиметра.
Легкость и миниатюрность MouseMan Traveler полезны не только путешественникам. По мнению многих авторитетных игроманов, подобные манипуляторы как нельзя лучше подходят для спиномозговых состязаний, где гораздо важнее быстро двигать пальцами, а не кистью. Старшим братьям Traveler уступает, пожалуй, только в удобстве колеса- кнопки — оно мелковато и прокручивается, если можно так выразиться, с невкусным тактильным ощущением, будто туда песочка насыпали...
Как и любое изделие от Logitech, мышка-путешественница укомплектована фирменными драйверами MouseWare. К манипулятору прилагается удобный дерматиновый чехол для переноски, переходник USB-PS/2 и удлинитель, позволяющий комфортно работать и на настольном компьютере. Нам на пробу MouseMan Traveler любезно предоставила дистрибьюторская компания «Альянс». В розницу мышь стоит около 45 долларов, с пятилетней гарантией.


MX300
Начнем с самой скромной (если такое слово применимо к устройству ценой 40 долларов, что сравнимо с превосходной моделью MouseManDualOptical) мышки из линейки MX. Встречайте: Logitech MX300 — отличная мышка для тех, кто не гонится за наворотами и не хочет тратить лишние деньги. И чем же она мне так нравится? Вроде бы, все те же две кнопки, одно колесо для прокрутки. На первый взгляд, самая обычная мышь. Но буквально каждая деталь, каждая мелочь продумана и проработана настолько тщательно, что девайс кажется чуть ли не идеальным. Стоит с ней хоть пару дней поработать — и расставаться уже не хочется.
Мышь безумно удобна. Вообще, эргономика всегда была сильной стороной Logitech. Стоит упомянуть, что мышь не совcем в традициях Logitech абсолютно симметрична. А значит, и левшам, и правшам работать будет одинаково комфортно. Корпус устройства, если чуть-чуть пофантазировать, кажется похожим на каплю.
Чуть ниже и уже спереди, чуть выше и шире сзади. Выполнен он из пластика цвета «синий металлик». Сверху наклейка — выпуклая эмблема «Logitech». При работе она оказывается в аккурат между пальцами, и поэтому не мешает. Серые кнопки симметричны и относительно малы по размерам. Хотя, впрочем, и сам манипулятор весьма невелик. Между кнопками находится стандартное колесо прокрутки темно-серого цвета.
Рядом можно обнаружить кнопку быстрого перехода между окнами. Нажимаете на нее — и на экране появляется список всех открытых в данный момент окошек. Щелкаете по интересующей вас строке — и попадаете в соответствующее окно.
Бока корпуса полупрозрачные. Настолько, что «начинки» практически не разглядеть, а красный свет лазера при перемещении мышки разливается по коврику. Особенно эффектно это смотрится в темноте — любители ночного веб-серфинга оценят. Кстати, по поводу ковриков. Как и в случае с другими моделями серии MX, идеальный вариант — коврик с тканевой поверхностью. Пластик почему-то устраивает капризного грызуна далеко не всегда.
Кнопки нажимаются именно так, как и должны, издавая несильный глухой щелчок. Колесо поворачивается вообще беззвучно и очень мягко. То есть сопротивление минимальное, но тем не менее достаточное для его четкой фиксации.
MX300 отлично подходит как для работы, так и для игр. На протяжении долгих сражений в «Quake III» и «Counter-Strike» каких бы то ни было проскальзываний и прочих глюков замечено не было. Так что MX300 можно смело назвать мышкой для геймера. Стоит отдельно отметить, что это устройство в качестве «рабочей лошадки» выбрала самая известная в России команда киберспортсменов — Asus|c58 (www.cyberfight.ru). А это уже, согласитесь, своеобразный знак качества: те, кто зарабатывают игрой деньги, могут доверять лишь самому надежному оборудованию.
О надежности мышки скажу только одно: Logitech дают пятилетнюю гарантию на все свои устройства.
MX700
Отдельно останавливаться на MX500 нет смысла — по сути это та же MX700. Вся разница состоит в том, что MX500 подключается к ПК при помощи кабеля, а MX700 — беспроводная.
У беспроводных мышек всегда были два недостатка. Во-первых, приходилось достаточно часто менять батарейки, которые они потребляли с неимоверной быстротой. Во-вторых, частота передачи сигнала с мышки на базу оставляла желать лучшего, и движение курсора по экрану чуть запаздывало по сравнению с движением мыши по коврику.
В MX700 эти недостатки устранены. Во-первых, мышь работает от аккумуляторов, срок службы которых куда выше, чем у батареек. Базовое устройство помимо того, что является приемником радиосигнала, представляет собой подзаряжающее устройство. Достаточно ставить в него мышь перед тем, как отойти от компьютера, и проблем с севшими аккумуляторами не будет. Единственная проблема — базу надо включать в электросеть. А лишняя свободная розетка есть не всегда.
С мышки на базу данные передаются с частотой 125 Гц, равной частоте USB-порта. Таким образом между беспроводной MX700 и MX500, подключенной кабелем в порт USB не чувствуется абсолютно никакой разницы. Разве что «хвост» не мешается на столе.
Оптический сенсор находится не как обычно — в центре устройства, а ближе к большому пальцу пользователя. Цвет привычный, красный. Даже при том, что сенсор всего один, точность движений мышки не уступает точности Logitech Dual Optical — а ведь там их два. При резких рывках мышь не проскальзывает, курсор движется практически идеально. Обладая разрешением 800 точек на дюйм, сенсор считывает с поверхности 4,3 мегапискеля информации в секунду. А это значит, что MX700 можно передвигать по коврику со скоростью до 1 метра в секунду и ускорением до 10 g.
Не обходится, правда, и без недостатков. Мышь очень неуверенно ведет себя на блестящих ковриках. Автор проверял ее в сочетании и с обычным пластиковым ковром, и с недешевым Nova (матовый, слегка ребристый пластик, покрытый блестками). Одинаково плохо — курсор иногда застаивается на месте, а иногда неожиданно резко дергается. И это при том, что Logitech iFeel Mouseman Optical и Dual Optical на пластике, и на блестках чувствуют себя уверенно. MX700 оказался куда более привередливым и нормально работать смог только на обычном, тканевом коврике, приобретенном на рынке за 30 рублей.


Нет, безусловно, не мышками славится Microsoft. Любим и ненавидим эту фирму мы за кое-что другое. Однако обходить «грызунов» стороной нельзя — среди них встречаются и довольно любопытные экземпляры. Причем в последнее время встречаются все чаще и чаще. На смену недорогим девайсам, валявшимся на каждом прилавке лет пять назад, в один прекрасный момент пришли действительно навороченные устройства.
Все — начиная с технических характеристик и заканчивая дизайном — говорит о том, что это продукция не какой-нибудь noname, а великой и ужасной MS.
Помнится, предыдущей мышкой от Microsoft, получившей широкую известность, была Microsoft IntelliMouse Explorer 3.0. Конкурент у нее был один — Logitech MouseMan Dual Optical. Стоили они приблизительно одинаково; «на ощупь» тоже были похожи – особых различий пользователь не чувствовал.
Не так давно, осенью, Logitech выпустила серию мышек MX. Три модели: MX300, MX500 и MX700 «били» сразу по трем ценовым нишам на рынке, стоя соответственно 30$, 60$ и 80$. Самая «простенькая» — MX300 — обычная двухкнопочная мышь. MX700 — эдакий беспроводной оптический монстр, работающий от аккумуляторов (два обычных, пальчиковых аккумулятора — подзаряжаются при установке мыши в приемник ее же радиосигнала) и увешанный дополнительными кнопками.
Собственно, уже тогда стало ясно, что Microsoft нанесет ответный удар. Пусть Logitech MouseMan Dual Optical и Microsoft Intellimouse Explorer 3.0 не так уж и сильно проигрывают новым моделям, но очевидно: их времена прошли. И вот, пожалуйста. Microsoft выпускает новую мышку в двух вариантах — в обычном и беспроводном. Называется новинка Microsoft Optical Mouse Blue (в случае с беспроводным вариантом между «Optical» и «Mouse» вклинивается слово «Cordless»).
Попробуем разобраться, сможет ли эта модель составить какую-либо конкуренцию Logitech MX.
Первое, самое очевидное, преимущество Logitech: серия MX (обзор этих мышей мы опубликуем на днях) включает три модели, а MS Blue — одна. Ожидается, что в России оно появится в розинце по цене около 50 долларов — и если у пользователя нет желания/возможности истратить столько на мышку, он либо купит Logitech MX300, либо вообще купит что-нибудь другое.
Кстати, насчет цен. По слухам, Microsoft вообще не собираются поставлять в Россию MS Blue — невыгодно им продавать мышки за двадцать минимальных окладов в нашей стране (хотя рекомендованная цена Microsoft не так уж и пугает — около 35 долларов). Так что те, кому удастся договориться о поставках с зарубежными отделениями компании, вполне могут на этом подзаработать. Если, конечно, покупатель найдется — риск здесь все же достаточно велик.
Однако слухи — это всего лишь слухи. Смущает небольшой значок Росстандарта, расположенный на нижней части устройства. Наверное, если он есть, значит, это кому-то нужно.
Ну да ладно, вернемся непосредственно к устройству. В коробке, кроме самой мышки, находился компакт-диск с драйверами и утилитой Microsoft IntelliPoint 4.1, руководство пользователя — небольшая брошюрка, а также переходник USB-to-PS/2.
Вообще, стоит заметить, что мышь прекрасно себя чувствует и без софта — достаточно просто воткнуть штекер в USB-порт, и Windows автоматически определяет наличие устройства. Естественно, никакой перезагрузки для того, чтобы начать работу, не надо (я говорю о Windows XP или 2000, под другими версиями вряд ли все будет так же просто).
Устройство удобно лежит в руке. Причем как в правой, так и в левой (это, между прочим, намек в адрес Logitech, которая делает мышки исключительно для правшей). Сверху две кнопки и колесико скроллинга — никаких излишеств. Зато все предельно удобно – кнопки нажимаются лишь тогда, когда пользователь этого хочет — никаких случайных нажатий. Колесико вращается куда более свободно, чем обычно, и вместе с этим четко фиксируется в каждом положении.
Разговор об эргономике завершим своеобразными «результатами тестов». Верстальщики «Компьютерры» (по совместительству заядлые квакеры) сочли мышь достаточно удобной. Вместе с тем никаких разительных отличий от привычной Logitech MouseMan Dual Optical они не заметили. Разве что колесо скроллинга показалось куда более приятным в плане тактильных ощущений.
Сказать что-то о технических характеристиках устройства сложно. Microsoft, в отличие от Logitech, не выставляют напоказ цифры, вроде 800 dpi, 4,7 мегапикселей в секунду и тому подобного. Это, кстати, подталкивает к определенным выводам — видимо, сенсор MS Blue все же уступает тому самому «MX engine» от Logitech.
Теперь что касается субъективного восприятия. Мышь великолепно работала на противном черном гладком столе в редакции (мерило, на котором неустойчиво работают все среднестатистические оптические мыши, кроме MouseMan Dual Optical). На ребристом пластиковом коврике тоже никаких проблем не наблюдалось. Единственным, что представило для MS Blue непреодолимое препятствие, оказалась абсолютно белая глянцевая обложка мануала к материнской плате Gigabyte GA-8IDX3 (завалялся под рукой у автора). На белой блестящей поверхности сенсор Microsoft и сдался. Зато на прозрачном куске плексигласа толщиной около 5 мм (под ним — обычный деревянный стол) испытания прошли успешно. Как и на поверхности экрана ЖК-монитора Philips Brilliance 150 P2.
В играх, вроде Quake 3 и Counter-Strike — мышь также показала себя весьма достойно. Пожалуй, не хуже и не лучше Logitech MX. Никаких проскальзываний и прочих багов.
В итоге мы имеем отличную мышь, в принципе, не уступающую как минимум Logitech MX300 (MX500 и MX700 — просто устройства другого класса, там и несколько дополнительных кнопок, и в случае с MX700 работа от аккумуляторов). Стоит, правда, она в полтора раза дороже, чем та же MX300, и на десяток долларов дороже проверенного MouseMan Dual Optical. Другой вопрос, что это все же Microsoft. Это, если хотите, как автомобиль Rolls-Royce: половина стоимости — это стоимость названия. В общем и целом, MS Blue — это скорее «предмет роскоши». Рядовой пользователь вряд ли выберет именно этот девайс, зато те, для кого компьютер — своеобразный фетиш, остановят свой выбор именно на этой мышке. Ну, и в качестве подарка MS Blue — отличный вариант для какого-нибудь сертифицированного пользователя продуктов Microsoft.


Уж кем может похвастаться земля японская, так это дизайнерами компании Sony. Анонсированный компанией еще в конце весны 15-дюймовый жидкокристаллический монитор SDM-X52 красив, скромен и элегантен. Причем эти качества присутствуют в нем в таком количестве, что все остальное, в общем-то, кажется не слишком важным. Ни спецификации, ни используемая матрица, ни прочие мелкие детали, о которых даже как-то неудобно вспоминать.
Кстати, с матрицей SDM-X52 произошла довольно интересная история. С легкой руки журналистов, первыми написавших о выходе SDM-X52 и его старшего 18-дюймового собрата SDM-X82, рядом с названиями этих моделей появилось уточнение «матрицы на базе аморфного кремния». Подобное уточнение может ввести в заблуждение несведущего читателя: создается впечатление, что технология аморфного кремния представляет собой нечто ультрасовременное и суперкачественное. На самом же деле жидкокристаллические панели на базе аморфного кремния сегодня чуть ли не самый распространенный и дешевый вид экранов и информационная ценность подобного уточнения приблизительно эквивалентна фразе «сделано из теста» при продаже пирожков. А с другой стороны и не придерешься – действительно, ведь аморфный кремний. Действительно, из теста.
Вообще, Sony очень неохотно делится информацией о том, какие именно матрицы используются в ее ЖК-мониторах. Эту модель мы разбирать не стали, но известно, например, что в Sony SDM-S51 используется панель от LG-Philips. Вполне возможно, что и здесь применена недорогая модель панели от того же производителя. Впрочем, никаких серьезных претензий к матрице нет.
Внешний вид
Как уже было сказано выше — никаких претензий. Существует две модификации SDM-X52: стандартная (серая) и черная (SDM-X52B). Обе красивы, невелики (391х358х198 с подставкой) и легки (4,8 кг). Обе спроектированы с учетом настенного крепления — все кабели заботливо убираются под съемную крышку на задней панели. Правда, кронштейн нужно приобретать отдельно.
Панель управления расположена справа от экрана и удобна и проста одновременно. Сверху вниз:
• кнопка включения-выключения монитора;
• кнопка вызова меню;
• кнопки навигации по меню (они же – регулятор уровня громкости встроенных динамиков);
• кнопка выбора видеовхода (у модели SDM-X52 их два: аналоговый RGB (HD-15) и цифровой RGB (DVI-D); у старших моделей SDM-Xхх – по три, добавляется второй аналоговый вход). Таким образом, к монитору можно подключить два компьютера одновременно – один к цифровому входу, другой к аналоговому
• и кнопка включения-выключения экономичного режима.
Переход в экономичный режим означает снижение уровня энергопотребления примерно на 5 Вт и, естественно, снижение уровня задней подсветки. Снижение, надо сказать, заметное – так что вряд ли кто-то будет использовать экономичный режим по доброй воле. Один из минусов экономичного режима – неработающие динамики. Звук не выдается ни на них, ни на наушники.
Одноваттные динамики расположены в нижней части передней панели. Звук для такого класса акустических систем вполне приличный, но не более того – слушать через них музыку сможет, наверное, только радиолюбитель со стажем.
Наличие двух аудиовходов позволяет помимо компьютера подключить к монитору и другой аудиоисточник. Задумка сама по себе очень неплохая, но в данном случае не слишком применимая в силу а) низкого класса встроенных динамиков и б) неудобства переключения между аудиовходами. В инструкции сказано, что при выставленном в меню значении «Автоформат» переключаться между входом 1 и входом 2 можно с помощью кнопки Input, однако это не так: даже при выставленной опции эта кнопка исправно позволяет выбирать нужный видеосигнал. Чтобы поменять приоритетный аудиовход, необходимо залезать довольно глубоко в меню.
Максимальный угол наклона монитора – 80 градусов. Подставка сконструирована таким образом, что монитор невозможно поднять на необходимую высоту для смены горизонтальной ориентации на вертикальную, и когда он находится в самом нижнем положении, угол наклона составляет всего 50 градусов. Вокруг вертикальной оси вращение также не предусмотрено, однако практической необходимости я в этом не вижу – с тем же успехом его можно повернуть вместе с подставкой.
Установка
Никаких драйверов для установки монитора не требуется - SDM-X52 распознается как стандартный монитор и прекрасно при этом работает. Единственное ПО, которое находится на идущем в комплекте к монитору диске – небольшая вспомогательная программка WinUtility.exe, которая используется для установки максимальной резкости изображения.
Собственно, настройка монитора этим не ограничивается и здесь, надо сказать, SDM-X52 на высоте. С помощью меню мы можем отрегулировать уровень подсветки, контраста, яркости, установить необходимую цветовую температуру и выбрать наиболее близкую гамму из трех предложенных производителем вариантов. Последние две функции, честно говоря, кажутся излишними – все равно ни один нормальный дизайнер не будет работать на ЖК-мониторе такого класса, а простому пользователю все эти настройки не слишком-то и нужны.
При использовании неродного разрешения (для SDM-X52 это 1024х768) есть возможность применить функцию сглаживания. Впрочем, подозреваю, что число желающих работать в режиме 800х600 даже с учетом функции сглаживания будет не очень велико – качество картинки оставляет желать лучшего, хотя видно, что процессор SDM-X52 «старается».
В стандартном разрешении все выглядит отлично. Единственная претензия – слишком большой период «затухания» точек. Указанное сплошь и рядом время отклика – 20 мс – неверно интерпретированный показатель. На самом деле, это время затухания, тогда как на полный цикл (подъем:спад) у X52 уйдет уже 30 мс. Конечно, для подавляющего большинства приложений этого хватит за глаза. SDM-X52 вполне подойдет для просмотра DVD при условии вывода звука на более достойные акустические системы (хотя рекомендовать его как идеальный выбор для подобного применения я не стал бы) и даже, возможно, для многих компьютерных игр. Тем не менее, найдется достаточно игрушек, которым этого окажется мало.
Резюме
Вполне достойный младший брат топовых моделей от Sony. Качественная картинка, приемлемое время отклика для ЖК-монитора, элегантный внешний вид и магический четырехбуквенный логотип. Множество не слишком нужных, но приятных мелочей в настройке плюс очень скромные размеры и вес. Подойдет он, скорее, для офиса чем для дома – прилагаемая мультимедийность весьма условна и может удовлетворить лишь совсем неприхотливого пользователя.
Единственный заметный минус — стоит монитор чуть дороже сопоставимых с ним моделей от других производителей. Впрочем, это известная беда Sony — пользователи, не склонные переплачивать за имя, продукцию этой компании не покупают.


Дизайн монитора SDM-N80 таков, что любые печатные слова будут выглядеть рекламными. Он восхищает. Максимальная толщина панели, у крепления — 35 миллиметров, минимальная по краям — 25 мм. Цвет — фиолетово- синий плюс нейтральный металлик. Задняя панель и основание подставки — из металла. Конструкция получается нелегкая (6,5 кг), но поразительно устойчивая и жесткая. Можно даже не включать — достаточно поставить на стол и просто любоваться.
Или, скажем, включить только питание монитора. Не торопитесь начинать рабочий день, поразмышляйте, зачем элементы управления вынесены на верхнюю кромку экрана. В первую очередь, пожалуй, это объясняется тем, что при низкой посадке экрана (он может быть попросту вжат в поверхность стола) вы не заметите модно подсвечиваемые оранжевым светом функциональные значки и надписи у сенсорных кнопок, выполненные в духе приборных панелей Audi. Причем загораются они не просто разом, а в соответствии с навигацией по меню и отдельным настройкам. Откровенно говоря, я впервые вижу интерфейс, где выборочная подсветка — по сути подсказка — у кнопок логически связана с экранным меню.
Очевидно, что 18,1-дюймовый N80 навеян успехом 15-дюймовых slim-моделей N50 и N50PS. Вся коммутационная и конвертирующая электроника аналогично упрятана в медиа-блок, освобождающий птицу-панель от путов громоздких соединений — далее протягивается оригинальный, очень эстетичный и комфортно длинный кабель с удобными защелками на коннекторах. Медиа-блок, как видно на фото, рассчитан на одновременное подключение и электронную коммутацию через меню видеосигнала двух компьютеров, причем один вход аналоговый (HD15), а второй — интегрированный DVI-I. Кроме того, коммутируются аудиосигналы и входящие шины USB (разветвитель на два порта установлен в основании-подставке). Переключатель аналог/цифра предусмотрен для использования входящего в комплект поставки шнура HD15—DVI-I, а также, по-видимому, будет полезен для видеокарт, не способных разделять вывод через собственный DVI-I-коннектор в драйвере. К монитору прилагаются всевозможные кабели (питание, аудио, USB), адаптер для подключения к компьютерам Macintosh, но, к моему великому удивлению, цифрового кабеля нет. И это в мониторе VIP-класса, который покупают исходя явно не из экономических соображений и не обращая внимания на плюс-минус двадцать долларов! Напомню, что видеокарты не комплектуются видеошнурами принципиально. Остается надеяться, что с началом широких поставок монитора Sony исправит это недоразумение.
Организация меню и перечень настроек комфортны, но все же выдают в SDM-N80 «менеджера высшего звена», не опускающегося до таких мелочей, как выбор гаммы и регулировка уровня черного (впрочем, присутствует очень полезная, независимая от яркости и контрастности регулировка яркости подсветки), которыми владеют «трудяги» CPD- M51 и M81. Этот красавец мыслит системно: при любой смене видеорежима тотчас включается автоподстройка, уверенно приводящая изображение в норму почти всегда. В этом «почти» виноват не монитор — дешевые или интегрированные в материнские платы видеокарты подчас выдают очень зашумленный сигнал. Монитор виноват в другом — автоподстройку нельзя запустить принудительно (кнопкой ли, через меню ли — как это принято в отрасли). Объясню в двух словах, почему это актуально: по моему опыту испытаний ЖК-мониторов, автоподстройке не все равно, на каком изображении она пытается «поймать» (оцифровать) частоту синхронизациии и фазу — на голом рабочем столе Windows может дать неудовлетворительный результат, но наверняка справится с задачей в многооконном режиме или, тем более, на через пиксельной сетке, предшествующей завершению работы Windows. Кстати, последний режим рекомендую для точной настройки всем, у кого к ЖК-мониторам не прилагаются специальные настроечные утилиты (к Sony N80 это не относится).
Будем надеяться, что видеокарта у вас хорошая. Тогда вы сможете насладиться несколькими режимами сглаживания и масштабирования (при разрешении отличном от физического). Хвалить такой дорогой монитор за идеальную картинку в малых разрешениях или текстовых режимах DOS, наверное, неуместно, но это факт, и промолчать не могу. Кроме того, N80, не будучи первым монитором, поддерживающим разрешение выше физического, первый на моей памяти дает в таком режиме изображение удовлетворительного качества. Что касается объективных тестов — старый добрый Display Mate в жидких кристаллах SDM-N80 отдыхает. В буквальном смысле. Придраться не к чему. Передача цвета и градаций серого безукоризненна. Огромные запасы яркости и контрастности.
О датчики освещения и присутствия пользователя, которыми оборудован SDM-N50, сломано немало копий. Вердикт этому смелому эксперименту Sony был такой — лучше отключить. Тем не менее в модели N80 компания не отказалась от этой симпатичной идеи (замечательной еще и тем, что прибор по сути приобретает второй режим энергосбережения, менее глубокий, чем инициируемый засыпающей системой). Более того, она взяла реванш! Авторегулировка яркости подсветки стала чрезвычайно плавной и осторожной (N50 попросту моргал от каждого движения пользователя). Датчик присутствия имеет несколько режимов чувствительности и практически не допускает ложных срабатываний. Зато какой у N50 звук! N80 здесь, увы, похвастать нечем: встроенные в панель среднего качества динамики, без всякой регулировки тембра.
По «белым» каналам N80 поступит в продажу в ближайший месяц (это первый оригинальный русскоязычный обзор монитора). Ориентировочная розничная цена — 1900–2000 долларов. Для сравнения, Sony M81 сейчас в столице можно приобрести за 1400 долларов.


В пресс-релизе, посвященном выходу нового принтера, гордо указано, что «в принтере используется цветной картридж Intellidge повышенной емкости, ресурс которого увеличен на 50% по сравнению с картриджем, использовавшимся в предыдущих моделях». Как вы понимаете, подобное заявление не стоит ровным счетом ничего хотя бы потому, что «предыдущие модели» не указаны. А если бы у меня дома «предыдущей моделью» был какой-нибудь широкоформатный монстр с полулитровыми бутылями чернил? Поэтому вооружимся артикулами картриджей и попробуем разобраться, в чем, собственно, изменения.

Черный картридж — T007 (C13T007401) — ничем не отличается от используемых в моделях EPSON Stylus Photo 790, 870, 890, 895, 900, 915, 1270 и 1290. Но в цветном принтере черный картридж играет роль второстепенную, и его вклад в себестоимость печати весьма низок — если вы, конечно, не печатаете тексты днями напролет. Забегая вперед, скажу, что при тестировании ресурса картриджей к тому моменту, когда цветной полностью закончился, черный, согласно показаниям EPSON Status Monitor, был израсходован всего на треть. Учитывая, что оригинальные картриджи EPSON T007 можно приобрести в Москве на десять долларов дешевле рекомендуемой EPSON цены — за 13 долларов вместо 23-х — и реально высокий ресурс картриджа (по заявлению производителя — 540 текстовых страниц), за черные чернила можно действительно не волноваться.

Но нас всех гораздо больше интересуют чернила цветные, так ведь? И вот тут мы замечаем действительно интересное изменение. Вместо использовавшегося в принтерах EPSON Stylus Photo 790 … 915 картриджа T008 в этой модели стоит чернильница T009 (C13T009401), ранее замеченная лишь в широкоформатных (A3+) моделях Stylus Photo 1270 и 1290. Естественно, ресурс картриджа, разработанного специально для широкоформатных принтеров, просто обязан быть выше — профессионалы не согласятся менять его через каждые десять страниц. Однако, как мне кажется, использование этой чернильницы вовсе не связано с повышенной заботой о потребителе — дело в том, что Stylus Photo 1270 уже снят с производства, и 1290, очевидно, скоро ждет та же судьба — сворачивать же производство картриджей с учетом того, что старые модели должны поддерживаться еще как минимум несколько лет, нерентабельно… Ну да пользователь от этого только выигрывает.

Официально этого картриджа должно хватить на 330 страниц формата A4 с 25-процентным заполнением цветом. Но официальные данные мало кому интересны — мы же печатаем не тестовые паттерны, а вполне реальные фотографии. Так вот, до полной «кончины» картриджа мне удалось распечатать:
• 5 болванок CD-R;
• 13 тест-страниц А4 без полей с 75-процентным заполнением цветом;
• 18 фотографий среднего формата 10х15;
• 16 фотографий формата A4 без полей;
• одну картонку A5 J.

Таким образом, в переводе получаем примерно 40 листов A4 без полей или 160 фотографий. Негусто? Негусто. Но следует учесть, что принтер был совсем новым, и картриджи устанавливались впервые, а при этом достаточно большое количество чернил расходуется на первоначальную промывку головок и заполнение печатающей системы — предупреждение об этом есть даже в руководстве. Поэтому реальный ресурс цветного картриджа должен быть примерно в полтора раза выше. В принципе, это хорошо согласуется с данными, полученными мной при длительном использовании Stylus Photo 1290 — одного цветного картриджа хватало в среднем на 60-70 фотографий формата A4 (я специально пишу «фотографий», поскольку при подобной печати средняя заливка цветом колеблется от 50 до 75% площади листа).

>А для такого количества страниц цена картриджа в 16,5 долларов уже не кажется высокой. Если посчитать удельную стоимость черных и цветных чернил для печати одной фотографии 10х15 см, получим приблизительно 8 центов (2,5 рубля) на отпечаток. Естественно, сюда нужно добавить стоимость бумаги, и поэтому мы с вами перейдем к изучению того, как принтер ведет себя с разнообразными типами носителей.

Тестирование принтера проводилось с использованием комплекта образцов "родных" бумаг от EPSON, двух типов бумаги Lomond — матовой и глянцевой (мои долгие исследования бумаг для струйной печати позволили сделать вывод, что именно этот сорт оптимально подходит по соотношению цена/качество для «повседневной» печати на принтерах EPSON) и обычной офисной бумаги от Lomond же.

Отмечу сразу: на глянцевых бумагах максимального качества можно добиться только на родной бумаге. Цвета получаемых на ней отпечатков буквально "вибрируют", а фотография просто "выпрыгивает" из листа. На Lomond’e же, несмотря на абсолютное внешнее сходство фактуры, цветовой охват меньше, и фотографии получаются более обыденными, "бытовыми" - как из среднестатистического минилаба. В общем, для обычной, качественной, но не супервыдающейся повседневной печати Lomond вполне подойдет, если же вам нужно создать действительно Произведение Искусства — разоритесь на пачечку EPSON Premium Gloss Photo Paper или пачечку/рулончик EPSON Premium Semigloss Photo Paper.

О последней нужно сказать особо: эта бумага фактурой тиснения имитирует так называемую "матовую" фотобумагу минилабов ("так называемую" потому, что реально "матовые" минилабовские фотографии матовыми не являются — старые фотолюбители, привыкшие печатать еще вручную, меня поймут). Соответственно, фотографии на ней смотрятся очень и очень пристойно, а уж отличить их от «настоящих» не сможет даже самый искушенный зритель. Из стандартного восьмиметрового рулона можно получить (с учетом отходов) около 50 фотографий 10х15, при этом себестоимость бумаги составит примерно 27 центов на отпечаток. С учетом стоимости чернил получаем около 11 рублей за фотографию. Как-то дороговато...

И вот тут имеет смысл обратить самое пристальное внимание на матовые бумаги — но не "псевдоматовые", как Semigloss, а матовые по настоящему: EPSON Archival Matte Paper, EPSON Matte Paper Heavyweight, матовый Lomond и иже с ними. При печати на матовых бумагах максимально возможное разрешение составляет "всего" 1440х720 dpi против 5760х720 на глянцевых, но визуально, как ни странно, отпечаток выглядит более детализированным — за счет отсутствия фактуры и глянца нюансы изображения не размываются. Вдобавок сразу появляется масса иных плюсов: во-первых, печать идет куда быстрее за счет меньшего разрешения. Во-вторых, матовая бумага дешевле. В третьих, диапазон оптических плотностей на матовой бумаге опять же выше (по крайней мере, «на глазок»). В четвертых, при печати на матовой бумаге различия между «родными» и «неродными» носителями практически незаметны, что вновь возвращает нас к пункту номер раз.

И, наконец, абсолютно субъективное наблюдение: все мои знакомые, которым я показывал одинаковые отпечатки на матовой, глянцевой и полуглянцевой бумаге, практически всегда выделяли именно матовые — или полуглянцевые. Глянец приглянулся лишь одному человеку, да и то с сугубо прагматическими целями: ему нужно было оформить витрину цветочного магазина, да так, чтобы «шибало издалека».

Ну и, наконец, нужно выяснить, насколько шустр в работе «новичок» - ведь мало кому понравится ожидать собственных фотографий по полдня… Я до сих пор с трепетом вспоминаю ста-арую модель EPSON PRO XL, в далеком 1997 году тратившую по нескольку часов (!) на лист формата A3. У нового принтера с этим все более-менее в порядке, хотя при установке максимального качества печати (при этом принтер перестает использовать применяющийся по умолчанию алгоритм двунаправленной печати, при которой каждый ход печатающей головки как в одну, так и в другую сторону — рабочий) подождать все равно приходится. Результаты тестирования скорости приведены далее в таблице, отдельно же хочется обратить внимание на практически не отличающееся время печати в черно-белом (печать проводится только черным картриджем) и цветном режимах, что говорит о хорошей сбалансированности печатающего механизма.

Режим печати | Время, мин:сек
Печать A4 с полями черными чернилами, простая бумага, «экономичное» качество | 00:17
Печать A4 с полями цветными чернилами, простая бумага, «экономичное» качество | 00:18
Печать A4 без полей черными чернилами, матовая бумага, нормальное качество | 00:58
Печать A4 без полей черными чернилами, матовая бумага, высокое качество | 02:11
Печать A4 без полей цветными чернилами, матовая бумага, нормальное качество | 01:10
Печать A4 без полей цветными чернилами, матовая бумага, высокое качество | 02:23
Печать A4 без полей цветными чернилами, матовая бумага, "фото"-качество | 04:22
A4 без полей цветными чернилами, матовая бумага, "суперфото"-качество, однонаправленная печать | 16:48
Печать фотографии 10х15, бумага Epson Premium Gloss, "фото"-качество | 01:49
Печать фотографии 10х15, бумага Epson Premium Gloss, "суперфото"-качество | 02:50
Печать фотографии 10х15, бумага Epson Premium Gloss, "суперфото RPM"-качество | 05:54
Печать фотографии 10х15, бумага Epson Premium Gloss, "суперфото"-качество, однонаправленная печать | 05:02
Печать фотографии 10х15, бумага Epson Premium Gloss, "суперфото RPM"-качество, однонаправленная печать | 09:46

Ну а насколько все же выгодно использовать этот принтер для печати фотографий? Я свел воедино в таблице наиболее употребимые варианты печати. Как видите, на «мелких» форматах обычная фотопечать пока еще дешевле, чем принтерная, хотя различия уже несущественны, на форматах же от А5 и выше принтер оказывается даже выгоднее минилаба.

Приблизительная себестоимость отпечатка на принтере EPSON Stylus Photo 900, рубли
Формат/тип бумаги | Lomond, матовая | EPSON, матовая (средняя цена) | Lomond, глянцевая | EPSON, глянцевая (средняя цена)
10х15 | 4,5 | 8,5 | 7 | 11
A5 | 8,5 | 9 | 10 | —
A4 | 17 | 18 | 20 | —

А для всегда существующих любителей точных цифр не премину привести некоторые технические подробности принтера:

Способ печати | Струйный, пьезоэлектрический
Направление печати | Двунаправленная, с логическим поиском
Конфигурация сопел | 48 сопел (черный); 48 сопел x 5 (CLcMLmY)
Разрешение | Макс. 5760 х 720 dpi (Resolution Performance Management), оптимизированное (Макс. 5760 dpi — Photo Paper; Premium Glossy Photo Paper; ColorLife Photo Paper; Photo Quality Glossy FilmМакс. 1440 dpi — Matte Paper Heavyweight; Photo Quality InkJet Paper; обычная бумага)
Минимальный размер капли | 4 пиколитра; Технология печати каплями переменного размера (Variable Sized Droplet Technology)

И наконец, приведу данные тестовой печати круговой миры для проверки максимальной линиатуры на разных сортах бумаги (тестирование для каждого сорта бумаги проводилось при установках, обеспечивающих максимально возможное качество печати для данного носителя):

Тип бумаги | Максимальная линиатура, черные чернила | Максимальная линиатура, цветные чернила
Обычная бумага | ~140 lpi | ~130 lpi
Матовая бумага | ~170 lpi | ~180 lpi
Lomond Gloss | ~140 lpi | ~130 lpi
Epson Premium Gloss | ~150 lpi | ~140 lpi

На этом мы завершим вторую часть статьи, посвященную принтеру EPSON Stylus Photo 900. В третьей же части мы поговорим об особенностях печати на толстых носителях и компакт-дисках и познакомимся с программным обеспечением принтеров EPSON. Эти материалы специально выносятся в отдельную статью, поскольку относятся не только к Stylus Photo 900, но и к целому ряду других моделей принтеров EPSON.


§ 1. - Параметры монитора.

Мониторы подразделяются на монохромные (Monochrome или Mono) и цветные (Colour или Color).
Монохромные мониторы могут быть как черно-белыми, так и черно-зелеными или черно-желтыми. Люминофор с желтым и зеленым свечением применялся в первых мониторах, предназначенных для адаптеров MDA и HGC. Эти мониторы обеспечивали передачу лишь трех уровней градации яркости и имели довольно длительное послесвечение. Черно-белые мониторы применялись (очень редко) для адаптеров EGA и до сих пор используются с адаптерами классов VGA и SVGA. Эти мониторы сочетают высокую разрешающую способность (у них отсутствуют трехцветные зерна люминофора) с низкой ценой. Высокая четкость изображения при режимах высокого разрешения позволяет длительно работать с текстом без какого бы то ни было утомления глаз (автор этих строк долгое время был приверженцем данного типа мониторов). Эти мониторы достаточно компактны и потребляют немного энергии (около 30 Вт). К сожалению, эта линия мониторов практически перестала развиваться - трудно найти монитор, поддерживающий режим 1024 х 768 и выше, а цифровое управление в таких мониторах, похоже, и не применяется. Многие современные приложения ориентированы на цветное изображение, и работа с ними на монохромном мониторе становится некомфортной.
Цветные мониторы получили наибольшее распространение. Первые цветные мониторы, имеющие цифровой интерфейс, использовались с адаптерами CGA и EGA. Мониторы CGA работали на частотах, близких к телевизионным, и некоторые умельцы подключали вместо них цветные телевизоры. Однако по качеству изображения телевизор обычно уступает монитору. Мониторы EGA имели возможность переключения частот развертки и обеспечивали довольно высокое качество изображения. В настоящее время распространены мониторы классов VGA и SVGA, имеющие аналоговый интерфейс. Мониторы VGA, допускающие работу в режиме 640 х 480, вытеснены мониторами класса SVGA, которые должны поддерживать по крайней мере режим 800 х 600. Именно об этих мониторах в основном и пойдет речь.
Главным параметром монитора является размер диагонали экрана (Screen Size), который принято измерять в дюймах. По умолчанию считается, что ширина экрана больше его высоты и соотношение этих размеров составляет 4:3. Такую ориентацию можно назвать "пейзажной" (Landscape), хотя это определение обычно опускают. Заметим, что стандартные графические режимы с высоким разрешением (640 х 480, 800 х 600 и далее) имеют то же соотношение числа точек в строке и числа строк. Этим достигается неискаженное изображение фигур: квадрат на экране будет иметь стороны с одинаковым числом пикселов. Существуют и мониторы с "портретной" (Portrait) ориентацией, у которых высота больше ширины. Это вовсе не повернутые на бок обычные мониторы, поскольку строки развертки у них остаются горизонтальными. Данный тип монитора предназначался для издательских систем и позволял более полно использовать площадь экрана при выводе книжных страниц. В настоящее время "портретные" мониторы встречаются редко, а в издательской деятельности чаще используют "просто" большие мониторы (19", 21" и больше). Размеры экранов приведены в таблице. Заметим, что указанный размер диагонали не является размером изображения, выводимого с гарантированным, уровнем качества. По краям экрана (особенно по углам) возможны геометрические искажения, нарушение фокусировки и сведения лучей. По этим причинам изображение (видимая часть растра) выводится на меньшую площадь. Так, например, для экрана 15" размер видимой (высококачественной) части изображения, может составлять, например, 13,7". Если изготовителю монитора удается добиться почти полного использования поверхности, он не забудет упомянуть в рекламе эту особенность. Иногда случается и так, что производитель, добившийся лучшего использования углов, укажет завышенный размер диагонали экрана, определяющий продажную цену монитора.

Диагональ, дюйм | Размер изображения, мм |  | Разрешение
 | по горизонтали | по вертикали | максимальное | рекомендуемое
14 | 254-264 | 190-200 | 1024 x 768 | 640 x 480
15 | 274-284 | 205-215 | 1280 x 1024 | 800 x 600
17 | 315-325 | 237-245 | 1600 x 1200 | 1024 x 768
19 | 355-365 | 267-275 | 1600 x 1200 | 1280 x 1024
21 | 396-406 | 298-306 | 1600 x 1200 | 1280 x 1024
24 | 436-447 | 328-336 | 1900 x 1200 | 1600 x 1200

Для цветных мониторов важным параметром является размер зерна экрана. Существуют мониторы с зернистостью 0,42, 0,39, 0,31, 0,28, 0,26 мм и тоньше.
По зернистости и размеру экрана. Можно определить "честную" разрешающую способность экрана, поскольку зерно является мельчайшей единицей изображения. Количество зерен в строке равно ширине рабочей области, деленной на шаг зерна. Однако (может, для сокрытия реальной картины?) размер экрана задают по диагонали, а не как ширину и высоту, причем указывается внешний размер, а не размер рабочей области, и в дюймах, а не в миллиметрах. Кроме того, для мониторов с теневой маской зернистость определяет шаг триад по диагонали, а для щелевой маски или апертурной решетки - горизонтальный шаг. Так что пользователю, которого утомят длинные пересчеты, остается поверить, что для режима 800 х 600 зернистость 0,28 мм экрана 14" (с теневой маской) является приемлемой. А вот для режима 1024 х 768 при такой же зернистости только-только хватает экрана размером 15". Конечно, никто не запретит использовать и режимы с большим разрешением на небольших или крупнозернистых мониторах (установив приемлемую для них частоту синхронизации), но качество отображения мелких элементов будет оставлять желать лучшего. В результате работа (не игра) на таком мониторе будет сильно утомлять и даже вести к ухудшению зрения.
Допустимая частота развертки определяется в основном параметрами отклоняющей системы и мощностью генератора строчной развертки. В соответствии с нормами ТCO99 минимальная частота регенерации (вертикальной развертки) должна составлять 85 Гц в любом режиме, а рекомендуемая - 100 Гц. Для обеспечения прогрессивной (нечередующейся) развертки в режимах с высоким разрешением (большим числом строк) требуется очень высокая частота строчной развертки. Так, для режима 1024 х 768 при частоте регенерации 85 Гц строчная частота должна быть порядка 70 кГц, а для 1600 х 1200 при частоте регенерации 100 Гц - 126 кГц.
На реальную разрешающую способность существенно влияет полоса пропускания видеотракта (Video Bandwidth). Ее связь с выбранным видеорежимом (количество точек и строк) и параметрами развертки (частота и режим) была показана выше. При недостаточно широкой полосе пропускания мелкие детали - точки или вертикальные линии толщиной в один пиксел - могут становиться нечеткими и даже незаметными. В технических данных на монитор обычно указывают предельное разрешение и максимальные частоты разверток. Однако это вовсе не означает, что максимальное разрешение можно использовать на максимальной частоте, да еще и при нечередующейся развертке. Оценить предел возможностей позволяет полоса пропускания. Заботливый производитель, конечно, избавит пользователя от решения таких головоломных задач и приведет таблицы оптимальных настроек для всех режимов (если ему нечего стесняться). Грубо требуемую полосу пропускания (BW, Гц) можно оценить через число точек в строке (Н), число строк (V) и частоту вертикальной развертки (F, Гц): BW = k*H*V*F (Гц)
Поправочный коэффициент k = (1,3...1,4) учитывает "простои" вывода точек на обратном ходе по строке и кадру. Для черезстрочной развертки в формулу подставляется половина частоты развертки. Так, например, для прогрессивной развертки (N1) с частотой кадров 75 Гц для режима 800 х 600 требуется полоса 45 МГц, для 1024 х 768 - 75 МГц, а для 1280 х 1024 - 125 МГц. Чем больше размер экрана, тем больше должна быть полоса пропускания, поскольку чем больше экран, тем большего от него требуют разрешения. Так, по самым жестким меркам высококачественный монитор 14" должен иметь полосу 65 МГц, 15" - 100 МГц, а 17" - более 135 МГц.
На некоторые мониторы с полосой пропускания более 125 МГц устанавливают BNC-разъемы для подачи видеосигналов (дополнительно с DB-15 или вместо них) или же интерфейсный кабель делают неотсоединяемым. На больших мониторах применяют и интерфейс DVI, снимающий проблемы качества разъемов.

[Следующий §]


§ 2. - Эргономические характеристики.

Теперь остановимся на некоторых эргономических вопросах. Оператору, работающему с монитором длительное время, небезразлично, каким воздействиям он подвергается. В первую очередь, конечно, интересует качество изображения. Естественно, изображение должно быть четким и достаточно контрастным, а цвета - чистыми. Несфокусированность и плохое качество сведения лучей приводят к напряжению глаз и, следовательно, к повышенной утомляемости со всеми вытекающими последствиями.
Важно обеспечить и правильную ориентацию экрана относительно источников освещения. Если монитор стоит напротив окна, то на экране возникают блики. Установка монитора экраном от окна, особенно с солнечной стороны, тоже не очень хороша: яркий свет, бьющий в глаза смотрящему на монитор оператору также утомляет глаза. Традиционно поверхность экрана является слегка выпуклой - это вызвано стремлением приблизить к прямому угол падения электронного луча ближе к краям экрана. Однако при выпуклом экране довольно трудно избавиться от бликов, вызванных внешними источниками света. Ряд новых моделей кинескопов имеет плоский экран Flat Screen. Такой экран обеспечивает меньшие геометрические искажения восприятия изображения и облегчает избавление от бликов. Уменьшить блики позволяет и специальное антибликовое покрытие экрана (Antiglare coating), а также применение стеклянных поляризационных фильтров. Хороший фильтр позволяет также улучшить контрастность изображения, правда, и с некоторой потерей яркости, которое можно компенсировать настройкой монитора.
Кроме видимого света - изображения на экране, монитор является источником высокого статического электрического потенциала, а также электромагнитного излучения в широком спектре частот. Для снижения статического потенциала применяют антистатическое покрытие, снимающее электростатический заряд с экрана, - это отмечается аббревиатурой AS (Anti Static) в перечислении достоинств монитора. Потенциал снижают также многие экранные фильтры - у них даже имеется провод с зажимом "крокодил" на конце, который нужно присоединить, например, к неокрашенной металлической части заземленного корпуса компьютера. Высокий потенциал определить просто - поднести палец к экрану, и если с расстояния в несколько миллиметров произойдет разряд (щелчок со слабым покалыванием или щекотанием), значит, потенциал велик. Если разряд возникает с расстояния сантиметра и больше, защитный антистатический фильтр просто необходим.
Что касается радиации, то многие ошибочно считают, что ее воздействию в наибольшей степени подвергается оператор. На самом деле большая часть излучения исходит из задней стенки (с тыльной части трубки) и достается не оператору, а его соседу при неудачной расстановке техники. Уровень радиации мониторов стремятся уменьшать, и аббревиатура LR (Low Radiation) указывает на заботу производителя о здоровье пользователя, но без конкретных цифр. Строгие нормы по допустимому уровню электромагнитных излучений в различных частях спектра заданы шведским стандартом MPR II, который фактически стал международным. Этот стандарт был принят в 1990 году и определяет как магнитные, так и электрические составляющие излучения. В 1992 году был принят более жесткий стандарт, называемый ТCO 92, описывающий еще и энергосберегающие функции монитора. Далее появился стандарт ТCО 95, относящийся уже не только к мониторам, но и ко всему компьютеру в целом. Более жесткие требования по всем параметрам монитора (и компьютера) предъявляет стандарт ТС099, в котором содержатся требования по эргономике (режимы разрешений и частоты регенерации), электромагнитным излучениям, экологии (выделение вредных веществ, а также способ утилизации).


§ 3. - Плоские дисплеи.

Дисплеи на электронно-лучевых трубках применительно к портативным компьютерам имеют два принципиальных неустранимых недостатка - большие габариты (объем) и потребляемую мощность. Надо заметить, что в первом портативном компьютере IBM PC Portable был применен все-таки дисплей на ЭЛТ, но если переносить этот компьютер было нетрудно (всего-то килограммов 10-15), то об автономном питании речи и не шло. В наколенных (LapTop) и блокнотных (NoteBook) ПК применяют плоские дисплейные панели (Flat Panel Display), основанные на различных физических принципах. В последнее время плоские дисплеи стали применять и для настольных компьютеров - их цена и качество стали уже вполне приемлемыми для замены громоздких и тяжелых ЭЛТ-мониторов. Плоские дисплеи выполняются в виде матрицы ячеек с какими-либо электрооптическими эффектами. Матрицы сканируются аналогично телевизионному растру, так что каждая ячейка управляется импульсно. Для повышения контрастности часто применяют двойное сканирование: экран разбивается на две части, в которых сканирование происходит одновременно. Таким образом повышается частота обращения к каждой ячейке.
Дисплеи на жидкокристаллических (ЖК) панелях LCD (Liquid Crystall Display - ЖК-дисплей) основаны, на изменении оптической поляризации отраженного или проходящего света под действием электрического поля. Слой жидкокристаллического вещества расположен между двумя стеклами с поляризационными решетками. Жидкокристаллическое вещество способно менять направление поляризации проходящего света в зависимости от состояния молекул. При отсутствии электрического поля направление поляризации меняется на 90°, а в дисплеях, изготовленных по технологии STN (Super Twisted Nematic), поворот достигает 270°. Под действием электрического поля молекулы "распрямляются", и угол поворота уменьшается. Таким образом, в сочетании с поляризационными решетками стекол можно управлять прозрачностью элемента, изменяя величину электрического поля. В дисплеях DSTN (Double Super Twisted Nematic) ячейки сдваиваются, что позволяет повысить контрастность изображения. Дисплейная панель представляет собой матрицу ячеек, каждая из которых находится на пересечении вертикальных и горизонтальных координатных проводников. В пассивной матрице (Passive Matrix) дисплеев на жидкие кристаллы воздействуют поля самих координатных проводников. Ячейкам пассивной матрицы свойственна большая инерционность - порядка 300^-400 мс (время на "перестройку" структуры молекул жидкокристаллического вещества), из-за чего на такие дисплеи плохо выводится динамическое изображение. Специально для таких дисплеев применяется особый режим отображения указателя мыши - за ним тянется шлейф, без которого быстро перемещаемый указатель визуально теряется. В активной матрице (Active Matrix) каждая ячейка управляется транзистором, которым, в свою очередь, управляют через координатные шины. В любом случае панели требуют подсветки - либо задней (Back Light), либо боковой (Side Light) от дополнительного (чаще люминесцентного) источника освещения. Иногда используют внешнее освещение, при .этом за панелью располагается зеркальная поверхность. Активные матрицы обеспечивают более высокую контрастность изображения. Цветные дисплеи имеют более сложные ячейки, состоящие из трех элементов для управления каждым из базисных цветов.
Современные плоские TFT LCD-дисплеи представляют собой "бутерброд" из двух стекол, между которыми расположены слои жидкокристаллического вещества и матрица тонкопленочных транзисторов (TFT - Thin Film Transistor). На переднем и заднем стеклах нанесены поляризационные решетки с взаимно перпендикулярным направлением поляризации. Жидкокристаллическая прослойка при отсутствии электрического поля поворачивает угол поляризации проходящего света на 90°, благодаря чему "бутерброд" становится прозрачным для проходящих лучей. Под действием электрического поля от напряжения, подаваемого транзистором каждой ячейки матрицы, угол поворота поляризации может быть уменьшен до нуля. Чем больше приложенное напряжение, тем меньше угол поворота и тем менее прозрачной будет ячейка. Инерционность ячеек активной матрицы порядка 20-30 мс меньше, чем пассивной, но все равно ощутима. Тем не менее на таких дисплеях хорошо смотрится "живое" видео и динамические игры. В цветных дисплеях каждый пиксел состоит из трех ячеек, каждая из которых снабжена своим светофильтром (красным, зеленым и синим). Управляя тремя транзисторами пиксела, можно изменять его цвет и яркость, что, собственно, и требуется от дисплея. Разрешающая способность по цвету у LCD-мониторов пока ниже - только 6 бит на каждый цветовой канал, так что 24-битный режим True Color они могут только эмулировать. Размер пиксела плоского дисплея близок к зерну ЭЛТ-мониторов: у дисплея 15" с разрешением 1024 х 768 - около 0,3 мм, а у дисплея 18" с разрешением 1280 х 1024 - около 0,28 мм. Размер изображения у LCD-дисплеев 15" больше, чем у ЭЛТ-мониторов 15" (но несколько меньше, чем у 17"). Матричная организация экрана не позволяет изменять разрешение экрана с той же легкостью, как у ЭЛТ-монитора: увеличить его просто невозможно, а уменьшить без потерь качества можно только одновременно с уменьшением размера изображения. Естественное (native) разрешение определяется форматом матрицы. При использовании графического режима с меньшим разрешением возможна два варианта: центровка (уменьшенное изображение располагается в середине экрана) или масштабирование. Масштабирование на весь экран выполняется встроенными средствами монитора, выполняющими интерполяцию цвета для каждого пиксела экрана.
Матричная организация располагает к применению цифрового интерфейса связи с графическим адаптером. Выпускаемые плоские дисплеи имеют и обычный аналоговый интерфейс, совместимый с любым (S)VGA-адаптером, однако лучше использовать цифровой интерфейс. Ряд графических адаптеров, в том числе и интегрированных в системные платы, имеют и специализированный интерфейс TFT-дисплеев. Заметим, что из-за инерционности ячеек не требуется слишком высокой частоты развертки - даже при 60 Гц мерцания экрана нет.
Преимущества TFT LCD-дисплеев, высокая яркость изображения, отсутствие геометрических искажений, четкая фокусировка, отсутствие мерцания экрана (из-за инерционности ячеек), малое потребление (25-40 Вт) и тепловыделение, малый вес и, конечно же, малое занимаемое место. Кроме того, они практически нечувствительны к внешним электромагнитным полям, от которых плавает, дергается и искажается изображение ЭЛТ-мониторов. Ряд моделей позволяет поворачивать экран на 90° (и, соответственно, менять местами координаты), так что он принимает "портретную" ориентацию. Вместе с тем TFT-дисплеи имеют ряд недостатков, обусловленных их природой: низкая контрастность изображения, зависимость качества изображения от угла наблюдения (меньший угол нормального восприятия цветного изображения), инерционность ячеек, невозможность смены разрешения (кроме как малопривлекательной интерполяцией), возможность отказа ячеек (на дисплее допускается неработоспособность нескольких транзисторов) и, конечно же, пока высокая цена. Фотореалистичность изображений, характерная для современных ЭЛТ-дисплеев, для LCD-дисплеев пока что недостижима.
Газоплазменные панели (Gas Plasma) основаны на свечении газа под действием электрического поля. Эти панели PDF (Plasma Display Panel), часто желто-черные, потребляют больше энергии, чем LCD, что препятствует их применению в системах с автономным питанием.
Электролюминесцентные панели EL (Electro-Luminescent) пока не получили широкого распространения из-за технологических трудностей создания долговечных элементов.
Светодиодные матрицы LED (Light Emmited Diode - светоизлучающий диод), казалось бы, могли стать решением всех проблем плоских дисплеев. Однако светодиоды имеют настолько высокую потребляемую мощность по сравнению с другими типами индикаторов, что их в плоских панелях не применяют.
Дисплеи на светящихся полимерных полупроводниках LEP (Light Emission Plastic) основаны на свечении этого материала в электрическом поле. Для работы этого дисплея требуется низкое напряжение - всего 3 В. Эти пока что только монохромные (черно-желтые) дисплеи еще не нашли широкого применения из-за малого срока службы.
Недавно появилась технология FED (Field Emission Display), основанная на свечении люминофора при бомбардировке их потоком электронов (тот же эффект используется и в ЭЛТ). Однако в отличие от ЭЛТ, имеющей три пушки (для каждого цвета), FED-панели имеют матрицу микроскопических триад пушек, расположенную между двумя плоскими пластинами. Каждый пиксел обслуживает, группа из нескольких сотен микропушек, управляемых общим транзистором (как и в активной LCD-матрице). Вместо отклоняющих систем и генераторов развертки применяется коммутация транзисторов матрицы. Поскольку длина "ствола" пушки существенно сократилась, снизился и уровень необходимого для работы высокого напряжения.


§ 4. - Интерфейсы дисплеев.

В традиционной технике цветного телевизионного вещания (PAL, SECAM или NTSC) видеосигнал непосредственно несет информацию о мгновенном значении яркости, а цветовая информация передается в модулированном виде на дополнительных частотах. Таким образом обеспечивается совместимость черно-белого приемника, игнорирующего цветовую информацию, с цветным передающим каналом. Однако для вывода графической информации с высоким разрешением ни одна из традиционных вещательных систем не подходит, поскольку они имеют существенно ограниченную полосу пропускания цветовых каналов (те минимальные 35 МГц, о которых мы говорили выше, недостижимы).
Для графики низкого разрешения, при которой частоты синхронизации были близки к стандартным телевизионным, использовался интерфейс Composite Video. По коаксиальному кабелю (75 Ом) передавался полный стандартный видеосигнал с размахом около 1,5 В. В видеотехнике этот сигнал называют низкочастотным, имея в виду, что по нему подается прямой, а не модулированный сигнал. Соответствующий ему вход имеется не у каждого телевизора. При наличии дополнительного радиочастотного модулятора RFM (Radio Frequency Modulator) можно было подключаться к антенному входу стандартного телевизионного приемника, но при этом еще более снижалось реальное разрешение графики. Для композитного интерфейса используют коаксиальные разъемы RCA ("колокольчик"), широко применяемые в видео- и аудиотехнике.
Для мониторов при высоком разрешении можно использовать только прямую подачу сигнала на входы видеоусилителей базовых цветов - RGB-вход (Red Green Blue - красный, зеленый и синий). Интерфейс между видеоадаптером и монитором может быть как дискретным (с сигналами ТТЛ), так и аналоговым. В ходе эволюции дискретный интерфейс монохромных и первых цветных мониторов CGA и EGA сменился популярным ныне аналоговым интерфейсом VGA, обеспечивающим передачу большого количества цветов. Однако далее качество передачи аналогового сигнала перестало удовлетворять растущие потребности (с повышением частот развертки и разрешения), и появился новый цифровой интерфейс DVI. Для плоских дисплеев с их матричной организацией и относительно большой инерционностью ячеек целесообразно использовать специализированный цифровой интерфейс (Flat Panel Monitor Interface, но не DVI), который имеется на некоторых современных графических адаптерах (например, в графическом контроллере чипсета 1810). В современных адаптерах снова появилась возможность подключения стандартного телевизора через специальный конвертор сигнала. Для телевизионного интерфейса возможно обеспечение синхронизации от внешней телевизионной системы (конвертора), что важно для совмещения компьютерного видеосигнала с внешним "телевизионным окружением".

Дискретный интерфейс RGB TTL

Первые мониторы для PC имели дискретный интерфейс с уровнями ТТЛ - RGB TTL Для монохромного монитора использовали лишь два сигнала - видео (включить/выключить луч) и повышенной яркости. Таким образом, монитор мог отобразить три градации яркости: хотя 22 = 4, "темный пиксел" и "темный с повышенной яркостью" неразличимы. В цветных мониторах класса CD (Color Display) имелось по одному сигналу для включения каждого луча и общий сигнал повышенной яркости. Таким образом, можно было задать 16 цветов. Следующий класс - улучшенный цветной дисплей ECD (Enhanced Color Display) имел дискретный интерфейс с двумя сигналами на каждый базовый цвет. Сигналы позволяли задавать одну из четырех градаций интенсивности; общее количество кодируемых цветов достигло 26 = 64. Сигналы RED, GREEN, BLUE и Red, Green, Blue обозначают соответственно старшие и младшие биты базисных цветов.
Строчная и кадровая синхронизация монитора осуществляется сигналами H.Sync и V.Sync. Монохромные адаптеры MDA и HGC, работающие с высоким разрешением (720 х 350 пикселов), используют высокую частоту развертки. Адаптер CGA работает с низкими частотами (параметры синхронизации близки к телевизионным). Адаптеры и мониторы EGA могут работать с любыми из этих частот. Чтобы облегчить переключение режимов генератора развертки монитора, используют сигнал V.Sync: полярность импульсов определяет диапазон частот развертки текущего видеорежима. Для всех разновидностей интерфейса RGB TTL используется разъем DB-9S.

Контакт | Монитор
 | MDA/HGC | CGA | EGA color/mono
1 | GND | GND | GND
2 | GND | GND | Red
3 | - | Red | Red
4 | - | Green | Green
5 | - | Blue | Blue
6 | Intensiv | Intensiv | Green/Intensiv
7 | Video | Reserved | Blue/Video
8 | +H.Sync | +H.Sync | +H.Sync
9 | -V.Sync | -V.Sync | -V.Sync

Аналоговый интерфейс RGB

Из-за ограниченных возможностей цветопередачи дискретного интерфейса пришлось перейти на аналоговый интерфейс, педенеся цифро-аналоговые преобразователи сигналов базовых цветов из монитора на графический адаптер. Такой интерфейс с 8-разрядными ЦАП для каждого цвета а настоящее время позволяет выводить 16,7 миллиона цветов '(True Color). Этот интерфейс называется RGBAnalog, в нем базовые цвета передаются аналоговыми сигналами с отдельными обратными линиями по витым парам. Черному цвету соответствует нулевой потенциал на линиях всех цветов, полной яркости каждого цвета соответствует уровень +0,7 В. Сигналы управления, состояния и синхронизации передаются сигналами ТТЛ. Впервые аналоговый интерфейс был применен на адаптере PGA фирмы IBM, где для него использовался 9-контактный разъем DB-9S. В дальнейшем, начиная с адаптеров VGA, стали применять малогабаритный 15-контактный разъем с таким же внешним размером. По назначению сигналов эти интерфейсы в основном совпадают, и существуют даже переходные кабели с 15- на 9-контактные разъемы. В адаптере PGA используется совмещенная синхронизация (Composite Sync) сигналом (H+V)Sync, этот режим поддерживают и многие современные мониторы.

Контакт | Видеоадаптер MCGA/VGA/SVGA/XGA | Монитор
 |  | Mono | Color
1 | Red | - | Red
2 | Green | Video | Green
3 | Blue | - | Blue
4 | Id2 | - | -
5 | GND/DDCReturn | SelfTest/DDC Return | SelfTest/DDCReturn
6 | Red Return | Key | Red Return
7 | Green Return | Video Return | Green Return
8 | Blue Return | - | Blue Return
9 | нет контакта | - | -
10 | GND | GND | GND
11 | Id0 | - | GND
12 | Id1/SDA | -/SDA | GND/SDA
13 | h.Sync/(H+V)Sync | h.Sync/(H+V)Sync | h.Sync/(H+V)Sync
14 | V.Sync | V.Sync | V.Sync
15 | SCL | SCL | SCL

Несмотря на наличие ключа - D-образного кожуха, 15-контактные разъемы ухитряются вставлять в перевернутом положении, при этом один из контактов среднего ряда подгибается, а потом и ломается (штырьки этих разъемов тоньше и слабее, чем у 9-контактных). Естественно, монитор, подключенный таким образом, работать не будет. Так что в случае отсутствия изображения первым делом имеет смысл проверять присоединение интерфейсного разъема.
В компьютерах Macintosh монитор, совместимый по параметрам с VGA, имеет разъем DB-15P (такой же, как и у Game-порта PC).
Кроме передачи изображения по интерфейсу передают информацию, необходимую для автоматизации согласования параметров и режимов монитора и компьютера. "Интересы" компьютера представляет дисплейный адаптер, к которому и подключается монитор. C его помощью обеспечивается идентификация монитора, необходимая для РnР, и управление энергопотреблением монитора.
Для простейшей идентификации в интерфейс ввели три логических сигнала IDO-ID2, по которым адаптер мог определить тип подключенного монитора IBM. Co стороны монитора эти линии либо подключались к шине GND, либо оставлялись неподключенными. Однако из этой системы идентификации использовали лишь сигнал ID1, по которому определяют подключение монохромного монитора. Монохромный монитор может быть опознан адаптером и иначе - по отсутствию нагрузки на линиях Red и Blue.
Параллельную идентификацию мониторов заменила последовательная по каналу цифрового интерфейса VESA DDC (Display Data Channel). Этот канал построен на интерфейсе I2C (DDC2B) или ACCESS.Bus (DDC2AB), которые используют всего два ТТЛ-сигнала SCL и SDA. Интерфейс DDC1 является однонаправленным - монитор посылает адаптеру блок своих параметров по линии SDA (контакт 12), которые синхронизируются сигналом V.Sync (контакт 14). На время приема блока параметров адаптер может повысить частоту V.Sync до 25 кГц (генератор кадровой развертки по такой высокой частоте синхронизироваться не будет). Интерфейс DDC2 является двунаправленным; для синхронизации используется выделенный сигнал SCL (контакт 15). Интерфейс DDC2AB отличается тем, что допускает подключение ПУ, не требующих высокой скорости обмена, к компьютеру по последовательной шине ACCESS.Bus. При этом внешний разъем шины выносится на монитор.
Блок параметров расширенной идентификации дисплея EDID (Extended Display Identification) имеет одинаковую структуру в любой реализации DDC.
Для управления энергопотреблением монитора в соответствии со стандартом VESA DPMS (Display Power Management Signaling) используются сигналы кадровой и строчной синхронизации V.Sync и H.Sync.

Режим | H.Sync | V.Sync
On | Активен | Активен
StandBy | Неактивен | Активен
Suspend | Активен | Неактивен
Off | Неактивен | Неактивен

Разъемы, применяемые в современных адаптерах и мониторах SVGA, не предназначены для передачи высокочастотных сигналов. Пределом для них является примерно 150 МГц, что для высокого разрешения и высокой частоты регенерации недостаточно. Поэтому на больших профессиональных мониторах с высокими разрешением и частотами синхронизации на соответствующих адаптерах имеются BNC-разъемы для соединения с помощью коаксиальных кабелей. Мониторы с коаксиальными входами могут быть подключены и к адаптерам с разъемом DB-15, для чего выпускаются специальные переходные кабели. У этих кабелей может быть 3-5 коаксиальных разъемов BNC (75-омных):

  • 3 разъема - сигналы базисных цветов, смешанная синхронизация (composite sync) передается в канале зеленого цвета;
  • 4 разъема - смешанная синхронизация передается по отдельному кабелю;
  • 5 разъемов - вертикальная и горизонтальная синхронизация передаются по раздельным кабелям.
С помощью коаксиальных кабелей возможно удаление монитора от компьютера на расстояние до 10-15 м при хорошем изображении.

Комбинированный интерфейс EVC

Для расширения частотного диапазона и, учитывая тенденцию к использованию последовательных шин USB и Fire Wire, для подключения ПУ к системному блоку компьютера VESA предложила новый тип разъема EVC (Enhanced Video Connector). Кроме обычного аналогового интерфейса RGB и канала DDC2 разъем EVC имеет контакты для видеовхода, входные и выходные стереоаудиосигналы, шины USB и FireWire, а также линии питания постоянного тока для зарядки аккумуляторов портативных ПК. Разъем имеет две секции: высокочастотную для присоединения четырех коаксиальных кабелей и низкочастотную на 30 контактов. Контакты высокочастотной секции, хотя и не являются коаксиальными, позволяют передавать сигналы с частотами до 2 ГГц. Контактом экранов является крестообразная перегородка. При использовании 75-омных коаксиальных кабелей на частоте 500 МГц гарантируется уровень отражений и перекрестных помех не выше 2 %. Контакты С1, С2 и С4 используются для передачи цветовых сигналов R, G и В соответственно, контакт СЗ служит для передачи синхросигнала пикселов. Разъем поделен на компактные зоны для каждой группы сигналов, правда, шины USB и 1394 используют общий контакт для экрана. Назначение контактов видеовхода (S-Video или композитный, PAL или NTSC) может программироваться по каналу DDC2.
Стандарт определяет три уровня реализации: базовый, мультимедийный и полный. Базовый включает только видеосигналы и DDC, в мультимедийном должны быть аудиосигналы. При использовании коннектора в полном объеме монитор превращается в коммутационный центр, который соединяется с компьютером одним кабелем, а все остальные ПУ (включая клавиатуру, мышь, принтер) подключаются к монитору. Разъем может использоваться для подключения портативного ПК к док-станции. EVC собирает сигналы от разных подсистем - графической, видео, аудио, последовательных шин и питания. Этот общий разъем, устанавливаемый на корпусе системного блока, может соединяться с разными платами внутренними кабелями через промежуточные разъемы.

Цифровой интерфейс DVI

Повсеместный переход на цифровые технологии дошел и до видеомониторов. Традиционный аналоговый канал передачи видеосигналов стал узким местом видеосистемы. По пути от ЦАП к входам видеоусилителей монитора сигнал проходит через пару разъемов и кабель. Несогласованность элементов, вызывающая отражения сигналов ("звон") и неравномерности частотных характеристик приводят к искажению формы сигналов цветов, что становится особо заметным на режимах с высоким разрешением и высокой частотой регенерации. Повысить качество изображения можно, перенеся микросхемы ЦАП в монитор, прямо на плату видеоусилителей, и подавая на них цифровые сигналы базисных цветов. Для реализации этой идеи группа DDWG (Digital Display Working Group - рабочая группа по цифровым дисплеям), в которую входит большое число ведущих фирм, разработала спецификацию цифрового видеоинтерфейса DVI (Digital Video Interface). Версия 1.0 была выпущена в апреле 1999 года, она доступна в Сети (http://www.ddwg.org).
Интерфейс DVI предназначен для подключения дисплеев любого типа (ЭЛТ и матричных) к компьютеру, причем возможны два варианта коннекторов и интерфейса: чисто цифровой и цифровой с традиционными аналоговыми сигналами. Во втором случае к разъему DVI через пассивный переходник может быть подключен монитор с обычным аналоговым VGA-интерфейсом. Полная схема интерфейса приведена на рисунке. Основной цифровой интерфейс имеет 6 каналов передачи данных (Data[0:5]) и канал синхронизации Clock. Каждый канал данных образован кодером, расположенным на видеокарте, линией связи и декодером, расположенным в дисплее. На вход кодера каждого канала поступают 8 бит кода яркости базисного цвета текущего пиксела. Кроме того, на вход кодера канала 0 поступают сигналы строчной и кадровой синхронизации, а на остальные каналы - дополнительные управляющие сигналы CtL:9], по паре на каждый канал. На приемной стороне сигналы декодируются и восстанавливаются в том же виде, в котором они поступали на входы кодеров. Физические линии реализованы экранированными витыми парами.
Минимальный вариант цифрового интерфейса содержит канал синхронизации и три канала данных (DataO-2). В таком варианте интерфейс почти ничем не отличается от аналогового - меняется только местоположение устройств ЦАП и применяется цифровой способ доставки данных. При этом гамма-коррекция возлагается на дисплей. Однако интерфейс предусматривает способ повышения пропускной способности за счет более эффективного использования времени. Дело в том, что традиционные ЭЛТ-мониторы имеют довольно значительное время обратного хода луча по строке и кадру, в течение которого пикселы на экран, естественно, не выводятся - в это время интерфейс простаивает. Для матричных дисплеев этих пауз не требуется, поэтому тот же объем информации о пикселах может передаваться за большее время - практически за весь период кадра. Следовательно, можно либо снижать тактовую частоту передачи пикселов (не меняя разрешения и частоты развертки), либо с той же (предельно достижимой) частотой передачи увеличить разрешение или(и) частоту развертки. Спецификация DVI предполагает, что возможность передачи данных в течение всего периода кадра может появиться и у цифровых дисплеев, построенных на обычных ЭЛТ, за счет внутренней буферизации. При наличии буферизации экрана в дисплее можно пойти и дальше - вместо непрерывной регенерации экрана, которой озабочены традиционные видеоадаптеры, передавать данные только при изменениях изображения, но это пока лишь возможные перспективы. Минимальный вариант DVI позволяет передавать сигналы при частоте пикселов до 165 МГц (по трем каналам данных). Если же требуется более высокая частота, то должны быть задействованы каналы 3-5 и информационная нагрузка должна распределяться поровну между парами каналов, что позволит передавать пикселы с частотой до 330 МГц. Предусматривается и иное использование дополнительных каналов: когда 8 бит на кодирование базисного цвета покажется недостаточным(!), каналы 3, 4 и 5 могут дополнить (как младшие биты) данные каналов О, 1 и 2 (старшие).
Кроме сигналов T.M.D.S. в интерфейс DVI входят сигналы интерфейса VESA DDC2, а также линия питания +5 В, по которой от видеокарты питаются цепи DDC, позволяя обмениваться конфигурационной информацией даже с выключенным монитором. Благодаря конфигурационной информации система определяет состояние монитора и должным образом конфигурирует имеющиеся каналы данных, согласуя возможности видеокарты и дисплея. Имеется также сигнал для слежения за подключением/отключением дисплея. Таким образом, дисплеи с DVI обеспечивают все необходимые функции для реализации принципов РnР.


§ 5. - Клавиатура.

Традиционная клавиатура PC представляет собой унифицированное устройство со стандартным разъемом и последовательным интерфейсом связи с системной платой. В качестве датчиков нажатия клавиш применяют механические контакты (открытые или герконовые), кнопки на основе токопроводящей резины, емкостные датчики и датчики на эффекте Холла. Типы клавишных датчиков влияют на надежность, долговечность и, конечно же, цену клавиатуры. Последние два типа являются самыми долговечными, поскольку в них исключены механические контактные системы. Независимо от типов применяемых датчиков нажатия клавиш, все они объединяются в матрицу. Клавиатура содержит внутренний контроллер, выполненный обычно на микросхеме из семейства MCS-48 фирмы Intel, осуществляющий сканирование матрицы клавиш, управление индикаторами, внутреннюю диагностику и связь с системной платой последовательным интерфейсом по линиям KB-Data и KB-Clock.
Среди обычных (стандартных) исполнений существуют три основных типа клавиатур.

  • Клавиатура XT - 83 клавиши, в оригинале без индикаторов. Впоследствии к ним добавили индикаторы состояния Num Lock и Caps Lock, управляемые внутренним контроллером по нажатию соответствующих клавиш. Однако состояние этих индикаторов могло быть не синхронизированным с флагами в ОЗУ, которыми пользуются драйверы.
  • Клавиатура AT - 84 клавиши, которая отличалась от XT появлением дополнительной клавиши SysReq загадочного назначения и программно-управляемых индикаторов Mum Lock, Caps Lock, Scroll Lock. Двунаправленный интерфейс с системной платой позволяет программе корректно управлять индикаторами, а также программировать некоторые параметры клавиатуры и производить диагностику.
  • Расширенная клавиатура (Enhanced) - 101/102 клавиши, применяемая в большинстве моделей AT и PS/2, ставшая современным стандартом. Некоторые расширенные клавиатуры (например, "Microsoft Natural") имеют 104 или 105 клавиш, имеются и 122-клавишные модели.
Клавиши расширенной клавиатуры разделены на несколько групп:
  • основная клавиатура;
  • функциональная клавиатура;
  • цифровая клавиатура (Numeric Keypad), при выключенном индикаторе Num Lock (или включенном индикаторе Num Lock и нажатии клавиши Shift) используемая для управления курсором и экраном;
  • выделенные клавиши управления курсором и экраном, дублирующие эти функции цифровой клавиатуры;
  • клавиши управления питанием;
  • клавиши (кнопки) быстрого доступа к приложениям.
Дополнительные клавиши управления питанием и другими системными функциями появились сравнительно недавно. Эти клавиши, как правило, бледно-лилового цвета и расположенные около клавиш управления курсором и экраном, досаждают пользователям, привыкшим к обычной расширенной клавиатуре и работающим с ней не глядя. Кнопки быстрого доступа - это тоже нововведение в "фирменные" клавиатуры, это действительно кнопки, и с клавишами их не перепутаешь. Эти кнопки предназначены для быстрого вызова некоторых приложений и работы с ними, например, Интернет-браузера и медиаплейера.
По электрическому интерфейсу клавиатуры XT и AT совпадают, за исключением того, что двунаправленный интерфейс позволяет клавиатуре AT принимать команды от системной платы. Однако по логическому интерфейсу они несовместимы (клавиатура AT иногда имеет переключатель режима XT/AT). Клавиатура PS/2 отличается от AT только исполнением разъема, при необходимости можно использовать переходник.
Внутренний контроллер клавиатуры способен определить факты нажатия и отпускания клавиш, при этом можно нажимать очередную клавишу, даже удерживая несколько ранее нажатых. При нажатии клавиши клавиатура передает идентифицирующий ее скан-код. При удержании клавиши в нажатом положении через некоторое время клавиатура начинает автоповтор передачи скан-кода нажатия этой клавиши. Задержка автоповтора (typematic delay) и скорость автоповтора (typematic rate) для клавиатур AT программируются. Расширенная клавиатура позволяет выбирать один из трех наборов скан-кодов.
Кроме традиционного стандартного исполнения существуют и другие варианты клавиатур. Малогабаритные клавиатуры портативных компьютеров интегрированы в общий корпус, но часто эти компьютеры имеют разъем для подключения обычной внешней клавиатуры, работать с которой все-таки удобнее. Некоторые производители оригинальных PC-совместимых компьютеров применяют собственные конструкции клавиатур, разъемов и даже интерфейса (например, Olivetty), что затрудняет их замену. При отсутствии поддержки производителем или поставщиком это может привести к тому, что в один момент компьютер может стать "чемоданом без ручки", поскольку механика клавиш подвержена износу. Кроме того, на клавиатуры иногда проливают чай (или хуже того -сладкий кофе), что выдерживают далеко не все конструкции. Существует множество вариантов клавиатур по используемым датчикам, по ощущениям от нажатия и по расположению клавиш. Имеются разные эргономические варианты: клавиатуры, "разламывающиеся" на две половины, имеющие подкладки для рук и т. п. При большом объеме клавиатурного ввода на эти нюансы есть смысл обратить внимание, поскольку неправильное положение рук оператора может приводить и к профессиональным заболеваниям. По ощущению от нажатия различают клавиатуры с "кликом" и без него. "Клик" - это щелчок, раздающийся при срабатывании нажатой клавиши. Щелчок может быть акустическим (это сильно раздражает соседей по помещению) и механическим, ощущаемым пальцами как преодоление некоторого предела упругости, после которого нажимаемая клавиша проваливается. В клавиатурах без клика срабатывание датчика почувствовать не удается и, если оператор не привык смотреть на экран, возможны пропуски символов или их ложные повторы. Конечно же, выбор клавиатуры -дело вкуса пользователя, но он определяется и финансовыми возможностями -цены клавиатур могут различаться на порядок.


§ 6. - MSMouse и PCMouse.

Serial Mouse - мышь с последовательным интерфейсом, подключаемая через 9- или 25-контактный разъем СОМ-порта. Эта мышь имеет встроенный микроконтроллер, который обрабатывает сигналы от координатных датчиков и кнопок. Каждое событие - перемещение мыши или нажатие-отпускание кнопки кодируется двоичной посылкой по интерфейсу RS-232C. Для передачи информации применяется асинхронная передача, а двуполярное питание, требуемое по протоколу RS-232, обеспечивается от управляющих линий интерфейса. Недостатком Serial Mouse является то, что она занимает СОМ-порт и требует монопольного использования его штатной линии прерывания (IRQ4 для СОМ1 и IRQ3 для COM2). Конечно, то, что для работы мыши порту СОМ1 требуется именно прерывание IRQ4, является недостатком не самой мыши, а ее программного драйвера, но для пользователя, не увлекающегося написанием "мышиных" драйверов, важен сам факт этого ограничения. Две основные разновидности - MS Mouse (Microsoft Mouse) и PC Mouse (Mouse Systems Mouse) - требуют разных драйверов, многие мыши имеют переключатель MS/PC. Эти два типа "мышей" при одинаковой скорости 1200 бит/с, одном стоп-бите и отсутствии контроля паритета используют различные форматы посылок.

  • MS Mouse: 7 бит данных, трехбайтный пакет (в "классическом" варианте), положительным значениям соответствует перемещение по координате X вправо, а по координате Y вниз. Для трехкнопочных мышей добавляется четвертый байт, передаваемый только при изменении состояния средней кнопки. Для ЗD-мыши четвертый байт имеет иное назначение.
  • PC Mouse: 8 бит данных, пятибайтный пакет, положительным значениям соответствует перемещение по координате X вправо, а по координате Y вверх.
Несовпадение форматов объясняет беспорядочные перемещения курсора на экране при несоответствии драйвера типу мыши.
Системная поддержка последовательной мыши осуществляется только на уровне ОС (сервисы вызываются через Int 33h), драйвер мыши - загружаемый или встроенный в ОС. BIOS мышь не поддерживает, даже если и пользуется ей для навигации в CMOS Setup. Еще раз подчеркнем, что для работы мыши обязательно требуется линия аппаратного прерывания - IRQ4 или IRQ3 для последовательных мышей на портах СОМ1 или COM2 соответственно.


§ 7. - Мышь PS/2.

PS/2-Mouse - мышь, появившаяся с компьютерами PS/2. Ее интерфейс и разъем 6-pin mini-DIN аналогичен клавиатурному и, как правило, реализуется тем же контроллером клавиатуры 8242. Адаптер и разъем PS/2-Mouse устанавливаются на многих современных системных платах. Контроллер мыши PS/2 может быть и на карте расширения (ISA), и занимать дополнительные адреса в пространстве ввода-вывода. С мышью PS/2 связь двусторонняя: процессор может посылать контроллеру 8242 специальные команды через порт 60h, но в отличие от интерфейса клавиатуры перед записью каждого байта (и команды, и ее параметра) в порт 64h должен записываться код D4h.
Системная поддержка последовательной мыши осуществляется только на уровне ОС (сервисы вызываются через Int 33h), драйвер мыши - загружаемый или встроенный в ОС. BIOS мышь не поддерживает, даже если и пользуется ей для навигации в CMOS Setup. Еще раз подчеркнем, что для работы мыши обязательно требуется линия аппаратного прерывания - IRQ4 или IRQ3 для последовательных мышей на портах СОМ1 или COM2 соответственно.
Мышь может работать в одном из двух режимов. В потоковом режиме (stream mode) мышь посылает данные по любому изменению состояния; в режиме опроса (remote mode) мышь передает данные только по запросу процессора. Есть еще диагностический режим (wrap mode), в котором мышь возвращает эхом данные, посылаемые ей контроллером. По приему пакета от мыши контроллер устанавливает флаг Mouse_OBF и вырабатывает прерывание IRQ12, если оно не запрещено командным байтом 8242.
Устройства-указатели с интерфейсом PS/2 (мышь PS/2) имеют поддержку BIOS обеспечивающую настройку параметров мыши (посылку вышеперечисленных команд). Собственно драйвер мыши (обработчик прерывания по вектору 74h от запроса IRQ12), обрабатывающий ее информационные посылки, входит лишь в состав ОС или загружается отдельно. Поддержка мыши вызывается через BIOS Int 15h, с кодом функции в регистре АХ. В регистре АН возвращается код возврата, при ошибке устанавливается CF=1. Коды возврата:

  • 00 - нормальное завершение;
  • 01 - недопустимая функция;
  • 02 - недопустимый параметр;
  • 03 - ошибка интерфейса;
  • 04 - требуется повторная передача;
  • 05 - драйвер не установлен.
Функции BIOS Int 15h (сервисы устройств-указателей):
  • АХ=С200 - разрешить (ВН=01) или запретить (ВН=00);
  • АХ=С201 - сброс на параметры умолчания и запрет (длина пакета не меняется), в ВН возвращается идентификатор устройства, в BL - значение, сообщаемое подключенным устройством после сброса (АА для мыши);
  • АХ=С202 - установка частоты передачи (ВН - код частоты);
  • АХ=С203 - установка разрешения (ВН - код разрешения);
  • АХ=С204 - чтение идентификатора (вернет его код в ВН);
  • АХ=С205 - инициализация интерфейса и установка длины пакета данных (ВН=1-8);
  • АХ=С206 - расширенная функция:
      • ВН=00 - чтение состояния: возвращает в BL байт состояния, в CL - код разрешения, в DL - код частоты передачи;
      ВН=01 - установка масштаба 1:1;
      ВН=02 - установка масштаба 2:1;
  • АХ=С207 - установка адреса драйвера мыши (в ES:BX);
  • АХ=С208 - посылка байта (из BL) в мышь (необязательная функция);
  • АХ=С209 - чтение байтов из мыши в BL, CL и DL (необязательная функция).


§ 8. - Мышь BusMOUSE.

Bus Mouse (шинная мышь) - один из первых вариантов мыши. Здесь мышь содержит только датчики и кнопки, а обработка их сигналов производится на специализированной плате адаптера (обычно ISA). Кабель 9-проводный, разъем специальный, хотя на первый взгляд и напоминающий разъем PS/2-Mouse. Главный недостаток такой системы заключается в том, что адаптер занимает слот системной шины, адреса ввода-вывода и линию запроса прерывания. Иногда встречаются мультипортовые карты (COM-, LPT- и GAME-порты), на которых установлен и адаптер Bus Mouse. Поскольку фирма Microsoft одна из первых выпустила такую мышь, снабдив ее своим логотипом, с понятием Bus Mouse иногда отождествляют и MS Mouse, хотя последние могут иметь любой из трех видов интерфейсов.


§ 9. - Буквопечатающие принтеры.

Электрифицированная пишущая машинка (ЭПМ, она же "пишмашка") для каждой буквы имеет рычаг со штампом литеры (рельефной буквой), ударяющий по бумаге через красящую ленту. Бумага заправляется в каретку, перемещающуюся влево-вправо и продвигающую бумагу вперед. После каждого удара каретка с бумагой перемещается на одну позицию влево. Рычаги приводятся в действие электромагнитами и электромотором. Электромагниты обеспечивают временное сцепление рычага выбранной буквы с приводным валом, чем и обеспечивается удар. Отдельный электромагнит переключает регистр (выбирает прописную или строчную букву), для чего смещается весь блок рычагов. Имеются и электромагниты для управления приводом возврата каретки и перевода строки. Аналогичная конструкция применялась в допотопных принтерах консолей больших машин и в ПК практически не применялась.
Принтер типа "ромашка" устроен иначе. Здесь литеры расположены по кругу на гибких рычагах, напоминая лепестки ромашки. Ромашка вращается над кареткой, и в позиции печати имеется молоточек, управляемый электромагнитом. Молоточек ударяет по лепестку, когда требуемая буква находится над позицией печати, и через красящую ленту символ отпечатывается на бумаге. В первых моделях перемещение каретки и бумаги выполнялось аналогично предыдущей конструкции. В других конструкциях подвижной каретки уже не было: протяжку бумаги осуществлял валик, а вдоль строки перемещалась сама головка с ромашкой. Таким образом, из конструкции ушла каретка, движущаяся влево-вправо, что было весьма неудобно в обращении. В одних конструкциях ромашка поворачивается шаговым двигателем в соответствии с требуемым символом, в других ромашка вращается постоянно, обеспечивая более высокую скорость печати (шаговый двигатель довольно долго поворачивал ромашку до нужного лепестка). Устройство управления обеспечивает синхронизацию молоточка с вращением ромашки в соответствии с символом, поступающим на печать; удар выполняется быстро, так что буква почти не смазывается. Как видно, эти принтеры (как и ЭПМ) являются последовательными, они печатают символ за символом. Принтеры "ромашка" менее шумные и более производительные, чем ЭПМ; такими принтерами комплектовали и первые ПК. Конструкция позволяла довольно легко менять ромашку, выбирая алфавит. Были даже двухцветные принтеры - у них двухцветная красящая лента может перемещаться вверх-вниз, подставляя нужный цвет.
Барабанный принтер по идее напоминает "ромашку" с непрерывным вращением, но в ином исполнении. Здесь имеется барабан, длина которого равна всей ширине бумаги, а на поверхность нанесены литеры для каждой печатаемой позиции (132 позиции для широкого принтера). В каждой позиции по всей длине окружности располагаются все символы доступного набора. Барабан постоянно вращается под бумагой, а над бумагой расположена красящая лента и линейка молоточков - каждый над своей позицией. Устройство управления довольно сложное - в нем имеется блок регистров, хранящий символы для каждой позиции печатаемой строки. Синхронизатор обеспечивает удар молоточка в момент, когда символ на барабане совпадет с требуемым для данной позиции. Таким образом, обеспечивается параллельная печать всей строки за один оборот барабана. Благодаря этому барабанные принтеры имеют очень высокую производительность печати, из-за чего их продолжают кое-где использовать и поныне (подключая принтеры от ЕС ЭВМ к ПК). Кроме того, у этих принтеров (громоздких, тяжелых и шумных) стоимость печати оказывается низкой - расходным материалом является сравнительно недорогая красящая лента (правда, широкая).


§ 10. - Матричные игольчатые принтеры.

Игольчатые принтеры (Dot Matrix Printer) имеют печатающую головку, на которой расположена матрица игольчатых молоточков, управляемых электромагнитами. Иголки ударяют по бумаге через красящую ленту, бумага лежит на валике, перемещаясь только продольно (перевод строк выполняется поворотом валика), но в обоих направлениях. Перемещение по строке выполняет сама печатающая головка - она довольно легкая, поэтому ее можно двигать быстро. Все управление механикой выполняет встроенный микроконтроллер принтера. В его ведении находятся шаговые двигатели подачи бумаги и перемещения головки по строке, а также приводы иголок, которых может быть от 8 до 24. На принтере имеются механические или оптоэлектронные датчики крайних положений каретки, а также датчик конца бумаги. Управляя этими механизмами и пользуясь датчиками, можно вывести любое изображение. Во время печати головка движется по строке слева направо, и ударами иголок отпечатываются требуемые точки. После того как строка отпечатана, передвигается бумага и выполняется печать следующей строки. Если бумагу не перемещать, то можно повторно пропечатывать отдельные элементы (символы), и они будут выглядеть ярче.
У "умных" принтеров печать может выполняться и на обратном ходе головки (это экономит время), хотя из-за люфтов механики возможно не очень точное совмещение точек, отпечатанных на прямом и обратном ходе.
Матричные принтеры могут работать как в графическом, так и в символьном режимах. Развертку символов в точечное изображение выполняет встроенный процессор (микроконтроллер) принтера, у которого есть ПЗУ с таблицами знакогенераторов. Обычно принтеры имеют несколько таблиц (для разных языков и шрифтов), переключаемых программно (по командам от компьютера), аппаратно (переключателями на принтере) или с помощью кнопок панели управления принтером.
Контроллер принтера по интерфейсу принимает от компьютера поток байтов, содержащий данные для печати и управляющие команды. Данные принимаются в буферное ОЗУ, откуда извлекаются и интерпретируются в соответствии с возможностями механики. Принтер обеспечивает обратную связь с компьютером: управляет потоком (останавливает по заполнению буфера) и сообщает свое состояние - готовность (On-Line), конец бумаги (Paper End), ошибка (Error). Это позволяет программе работать с принтером не вслепую и сообщать пользователю о необходимости вмешательства. Принтер способен печатать поступающие к нему данные, когда он включен, у него есть бумага и он находится в состоянии On-Line. В состоянии On-Line принтер готов к приему данных от компьютера (если у него есть место в буферной памяти). Заметим, что принтер печатает строку только после того, как "поймет", что у него в буферной памяти собрался окончательный образ для этой строки. В символьном режиме строка будет отпечатана в следующих случаях:

  • принято столько символов, сколько умещается в строке, и еще хотя бы один (принтеру полагается воспринимать код "забой", по которому он должен аннулировать предыдущий символ);
  • принят символ возврата каретки (CR), перевода строки (LF) или формата (FF);
  • оператор нажал кнопку перевода строки или формата (для их срабатывания принтер должен быть переведен в состояние Off-Line, печать строки может быть вызвана и переводом в это состояние).
Таким образом, матричный принтер является устройством построчного вывода. В графическом режиме идея печати та же - строка печатается целиком, когда для нее готовы данные (для всех используемых иголок). При переводе принтера в состояние Off-Line печать и прием данных приостанавливаются, но оставшиеся в буфере данные сохраняются. Буфер очищается по включению питания, аппаратному сбросу по сигналу интерфейса и по приему специальной команды.
По включению питания, аппаратному или программному сбросу контроллер выполняет самотестирование и приводит механику в исходное состояние. Для этого он перемещает головку до срабатывания датчика левого положения, чтобы откалибровать систему позиционирования. Некоторые принтеры после этого немного прогоняют головку вправо, чтобы она не мешала заправке бумаги.
Разрешающая способность матричного принтера определяется размером матрицы иголок, но и не только им. Точки можно пропечатывать, смещая головку (влево-вправо) и бумагу (вверх-вниз) даже на долю шага так, что точки сольются в почти гладкую линию. Правда, для этого требуется довольно точная механика. Разрешающая способность печати связана со скоростью: поскольку иголки все-таки инерционны, предельная частота их срабатывания ограничена. Поэтому для высокого разрешения скорость перемещения головки и бумаги невысока. Первые модели матричных принтеров были довольно грубыми, последующие позволяют достигать разрешения вплоть до 360dpi (точек на дюйм) по обоим координатам. Принтеры, как правило, могут работать в режимах с различным разрешением - от малого разрешения для быстрой печати черновиков (draft) до высокого разрешения (NLQ - Near Line Quality, качество, близкое к гладким буквам пишущих машинок).
Цветные матричные принтеры работают с многоцветной (обычно трехцветной) красящей лентой. Каждая строка печатается за несколько проходов головки, и на каждый проход устанавливается полоса ленты определенного цвета. Конечно, эта цветная печать происходит не быстро, да и качество цветопередачи невысокое.
Матричные принтеры весьма неприхотливы - могут печатать практически на любой бумаге - листовой, рулонной, фальцованной. Листовая бумага подается фрикционным механизмом - валиком, к которому она прижимается обрези-ненным роликом. Листы могут заправляться вручную, а в более дорогих моделях имеются специальные лотки для автоматической подачи бумаги из пачки. Для печати из рулона или стопки фальцованной бумаги с перфорацией по краям механизм подачи бумаги имеет траки - резиновые или пластмассовые "гусеницы" с зубчиками. Траки расположены на общей оси и обеспечивают подачу бумаги без перекосов, неизбежных (пусть и в небольшой степени) при фрикционной подаче. Узкие принтеры позволяют печатать на бумаге шириной до формата А4 (вертикально заправленный лист), широкие - до A3 (горизонтально заправленный лист). Принтеры имеют направляющие, регулируемые по ширине листа, а у моделей с траками направляющие двигаются вместе с траками. Существуют специальные приспособления для печати этикеток.
Параллельные матричные принтеры (например, Tally Mannusman) не имеют подвижной печатающей головки - у них иголки расположены вдоль всей печатаемой строки. За счет этого печать происходит очень быстро (с той же скоростью, что и у барабанных буквопечатающих принтеров). Горизонтальное разрешение у этих принтеров не обязательно определяется числом иголок: печатающий блок может немного перемещаться вдоль строки, и каждая строка может быть отпечатана за несколько ударов, при которых точки смещаются относительно друг друга на доли шага иголок. От этих принтеров в основном требуется высокая скорость печати символов, так что механизм повышения разрешения, безусловно снижающий скорость, может включаться лишь для фафическои печати и "экзотических" шрифтов. Эти принтеры, как правило, широкие и работают с рулонной и фальцованной бумагой с перфорацией по краям (фрикционная подача на большой длине всегда будет уводить бумагу в сторону). Принтеры очень дорогие, но при большом объеме текстовой печати весьма эффективные. Расходный материал - красящая лента.


§ 11. - Термопринтеры.

Термопринтеры по конструкции напоминают игольчатые, но вместо ударов иголок по красящей ленте их головки нагревают отдельные точки специальной термочувствительной бумаги. Эти принтеры отличаются практически бесшумной работой, правда, скорость печати невысока. Главный недостаток - требуется специальная бумага, изображение на которой получается не очень устойчивым (на солнечном свету и при нагревании бумага темнеет). В настоящее время термопринтеры практически не выпускаются и бумага для них может оказаться дефицитом.


§ 12. - Струйные принтеры.

Струйные принтеры также конструктивно аналогичны матричным игольчатым, но вместо удара по бумаге через красящую ленту они "стреляют" по бумаге капельками специальных чернил. Чернила выстреливаются из микроскопических сопел с использованием пьезоэлектрических механических микронасосов или пузырьковой технологии (bublejet). Пузырьки пара, выталкивающие чернила из сопла, образуются под воздействием микроскопического нагревательного элемента. Число сопел в головке измеряется десятками, благодаря их малому размеру удается достичь высокого разрешения (вплоть до 720 dpi). Цветные струйные принтеры имеют сопла для чернил базисных цветов и черных (набор цветов для модели CMYK - Cyan, Magenta, Yellow, Black). По конструкции чернильниц принтеры разделяются на два типа: с отдельными сменными чернильницами и с чернильницами, совмещенными с головкой. В совмещенном варианте предусматривается дозаправка чернильниц. Струйные принтеры работают тихо, скорость печати определяется режимом: черновая - быстро, качественная, особенно цветная печать, - довольно медленно. Высокое качество достижимо только на хорошей бумаге. На плохой бумаге чернила растекаются, правда, против этого применяют разные ухищрения (например, подогрев бумаги для ускорения высыхания). Струйные принтеры печатают только на листовой бумаге, большинство моделей работает с форматом А4, но есть и A3. Для них подходит бумага, предназначенная для ксероксов. Из-за довольно высокой цены картриджей с чернилами стоимость печати на струйном принтере, особенно цветной, оказывается довольно высокой, в то время как сами принтеры относительно недороги. Иногда у принтеров пересыхают чернила в соплах, и это, как правило, приводит к необходимости замены довольно дорогой головки. В отличие от игольчатых принтеров, которые готовы к работе почти сразу по включению питания, струйные принтеры довольно медлительны - по включению питания они выполняют серию манипуляций с головкой и чернильницами, подготавливаясь к работе. Чтобы сопла не высыхали, головка паркуется в специальном месте. Нештатное отключение питания во время работы не позволяет принтеру припарковать головку, и чернила могут засохнуть в соплах.
Число органов управления у струйных принтеров сведено к 1-2 кнопкам, одна из которых является выключателем питания. Одной кнопкой и переключают режим On-Line/Off-Line, и выводят недопечатанную страницу, и загружают новую страницу. Перевод строки, смена шрифтов и т. д. кнопками уже не выполняются - всеми этими функциями управляет компьютер. Это вполне закономерно, поскольку в струйном принтере место листа, в котором производится печать в данный момент, скрыто от глаз (поэтому ручной перевод строки не имеет смысла), а шрифтовые возможности настолько богаты (благодаря высокому разрешению), что кнопочное управление тут просто неуместно.


§ 13. - Лазерные принтеры.

В лазерных принтерах используется та же технология переноса изображения на бумагу, что и в копировальных аппаратах. Имеется барабан, покрытый фоточувствительным полупроводником. Поверхность барабана электризуется, после чего модулированный лазерный луч сканирует всю поверхность барабана, разряжая засвеченные участки. Сканирование осуществляется с помощью вращающегося зеркала, направляющего луч на поверхность барабана, и вращения самого барабана. К разряженным точкам поверхности притягивается тонер - очень мелкий красящий порошок, таким образом, на барабане формируется изображение полного листа. Далее синхронно с вращением барабана по барабану прокатывается наэлектризованный лист бумаги, и частички тонера переходят на него. Затем бумага с тонером прокатывается через горячие валки, и тонер припекается к бумаге, после чего лист выводится из принтера. Таким образом, лазерный принтер является постраничным печатающим устройством - он может печатать страницу только целиком, не имея возможности остановиться посреди строки (как последовательный принтер) или листа (как построчный принтер). Цветная печать осуществляется в несколько проходов - каждый раз со своим цветом тонера. Лазерные принтеры обеспечивают высокое качество печати и обладают самым высоким разрешением. Они работают с листовой бумагой высокого качества, пачка которой загружается в лоток, или с пленкой, используемой в полиграфии для вывода оригинал-макетов1. Специально для печати на пленку принтеры имеют возможность зеркальной печати изображения (именно так и печатают макеты книг). Принтеры чувствительны к механическим свойствам бумаги - плохую и мятую бумагу они заминают, и для извлечения остатков листа приходится открывать принтер (правда, это делается довольно просто). Скорость черно-белой печати достигает десятков листов в минуту, цветная печать выполняется медленнее.
Лазерные принтеры выпускаются в широком ассортименте - от маломощных персональных до мощных. Большие принтеры имеют несколько лотков для бумаги и возможность программного выбора лотка. Для каждой модели принтера имеется оптимальная нагрузка - количество отпечатанных листов за единицу времени, а также ресурс барабана. Превышение нагрузки ведет к ускоренному износу, и принтер может не успеть выработать свой официальный ресурс. Слишком малая нагрузка невыгодна - мощные принтеры стоят дорого, и удельная стоимость печати окажется слишком высокой.
Расходным материалом для лазерного принтера являются картриджи с тонером; иногда имеется возможность дозаправки картриджа порошком. Стоимость печати по расходным материалам у лазерного принтера невысока, но сами принтеры дороже всех других типов (правда, и качественнее).
Лазерные принтеры имеют мощные встроенные процессоры и большой объем буферной памяти, поскольку они должны хранить изображение целой страницы с высоким разрешением. Объемом буферной памяти определяется максимальное разрешение. Особенно много памяти требует цветная печать. Память лазерного принтера может быть расширена установкой дополнительных модулей динамической памяти, правда, ряд моделей довольно капризны по отношению к типам устанавливаемых модулей. Внутреннее ПО принтера, хранящееся в его ПЗУ, может быть расширено путем установки дополнительных модулей, как правило, флэш-памяти.
Органы управления "персональными" лазерными принтерами (как и струйными) минимизированы. Мощные принтеры, имеющие несколько лотков для подачи бумаги и обеспечивающие возможность различных настроек, часто имеют небольшой жидкокристаллический дисплей и кнопки, позволяющие управлять принтером с помощью меню.


§ 14. - Плоттеры.

Плоттеры, они же графопостроители, предназначены для вывода чертежей.
Плоттеры являются векторными устройствами (по крайней мере по входным данным). В плоттерах первых поколений пишущее средство перемещалось на бумаге по траектории, заданной отображаемой в данный момент фигурой. Плоттер способен рисовать графические примитивы: точка, отрезок прямой, дуга, эллипс (окружность как его разновидность), прямоугольник. Поток данных, получаемый плоттером, содержит команды рисования этих примитивов и параметры. Многие плоттеры "понимают" и команды написания текста: каждую букву они внутренне интерпретируют как набор отрезков и дуг; для этого они должны иметь соответствующие таблицы знакогенераторов. Плоттеры позволяют выводить изображения на листы разного формата - от А4 для настольных устройств до А1 и АО у крупных напольных устройств. Для принтеров такие большие размеры недоступны. По способу обеспечения движения пишущего средства относительного бумаги различают планшетные и рулонные плоттеры.
В планшетном плоттере лист бумаги укладывается на плоский стол и неподвижно закрепляется. На небольших устройствах лист по краям прижимается металлическими полосками к магнитному столу. На устройствах большого формата листы иногда присасываются воздухом через специальные отверстия в столе. Над столом в одном направлении перемещается каретка, вдоль которой перемещается пишущая головка. Вся эта конструкция, напоминающая мостовой кран, приводится в движения двумя шаговыми двигателями, обеспечивающими перемещение пишущей головки по всей поверхности листа. Точность позиционирования измеряется десятыми и даже сотыми долями миллиметра. Головка перьевого плоттера снабжена пишущим пером. На головке имеется соленоид, который прижимает перо к бумаге в нужных местах. У струйного плоттера используется головка такого же типа, как и у струйного принтера (черно-белая или цветная). Приводы позиционирования и пишущего узла управляются встроенным микроконтроллером в соответствии с принимаемым потоком команд. В рулонном плоттере имеется горизонтальный барабан, на который кладется лист бумаги и прижимается к барабану валиками. Края листа свободно свисают вниз (это напольные конструкции). Пишущая головка перемещается по направляющей только вдоль оси барабана. Вращение барабана (в обоих направлениях) и перемещение головки совместно обеспечивают взаимно перпендикулярные перемещения пишущего средства относительно бумаги. Рулонные плоттеры позволяют выводить чертежи крупного формата, не занимая при этом огромной площади (как планшетные). Здесь жестко ограничена лишь ширина рулона (А1 или АО). Есть устройства, у которых края листа не свисают, а наматываются на специальные барабаны - такие плоттеры могут выводить полотна длиной в несколько метров. Однако в рулонном плоттере при повторных прогонах довольно трудно обеспечивать точное позиционирования бумаги, которая катается по барабану вперед-назад во время вывода чертежа огромное количество раз. Из-за этого требуется очень высокоточная (а потому и дорогая) механика.
Современные струйные рулонные плоттеры сделаны несколько иначе. По сути дела они являются растровыми струйными принтерами, головка которых имеет ряд (и не один) сопел. При выводе бумага в них по барабану прокатывается всего один раз, в одном направлении, и за этот проход растровым способом выводится все изображение. Растеризация изображения производится во внутреннем ОЗУ огромного размера, но на данном этапе это оказывается уже проще, чем делать сложную механику.
Перьевой плоттер способен выбирать перья (по цвету чернил, типу и толщине) из имеющихся у него в распоряжении. Перья бывают разные - типа шариковой ручки (ball tip pen), фломастера (fiber tip pen) или керамического пера (keramic tip pen) - каждый тип имеет свою нишу применения. Для выбора пера используют разные механизмы. В револьверном механизме перья устанавливаются в ячейки барабана, размещенного у края рабочего стола плоттера. Отдельный привод поворачивает барабан на нужный угол, предоставляя для доступа требуемую ячейку. Головка подводится к барабану и определенным движением вынимает из него перо (предварительно поставив прежнее в свободную ячейку). У других плоттеров перья устанавливаются в ряд держателей, и головка для обмена подводится к одному из них.
Внешний интерфейс плоттера - параллельный или последовательный. В отличие от принтеров для плоттеров интерфейс не является узким местом - передача графических команд даже по последовательному интерфейсу происходит гораздо быстрее их механического исполнения. Параллельный интерфейс плоттера ничем не отличается от принтерного. С последовательным интерфейсом на некоторых старых плоттерах бывают сложности. Некоторые плоттеры с последовательным интерфейсом используют программное управление потоком, но посылают не стандартные символы XON/XOFF, а слова (ASCII-строки). Такой протокол обмена на уровне системы практически не поддерживается (эти плоттеры непосредственно "разговаривают" с прикладной программой). Это осложняет подключение плоттера к компьютерной сети (например, через принт-сервер).
У плоттеров имеется ряд специфических параметров:

  • формат бумаги (максимальный и минимальный размеры листа);
  • линейная скорость движения пера при рисовании и холостых перемещениях;
  • максимальное ускорение головки;
  • точность позиционирования;
  • повторяемость позиционирования (способность многократно попадать в заданную точку после длительных "путешествий");
  • количество цветов;
  • поддерживаемые языки графических команд.
Кроме рисующих плоттеров существуют и режущие плоттеры (cutter), в них вместо пишущей имеется режущая головка с механическим или лазерным резаком.


§ 15. - Игровые устройства - джостик, руль, педали.

Джойстик является одним из первых чисто развлекательных устройств IBM PC и его название (joystick) можно буквально перевести как "палочка для удовольствия". Джойстик позволяет вводить в компьютер информацию о двух координатах ручки управления и о состоянии двух кнопок. Вместо двухкоординатной ручки может быть сделан руль автомобиля с педалью газа или что-либо иное, были и простейшие игровые устройства (paddle) с парой ручек потенциометров и парой кнопок. Джойстик используют в играх, где за счет возможности пропорционального управления (сигнал вырабатывается пропорционально отклонению ручки) он гораздо привлекательнее, чем клавиатура. С самых первых моделей IBM PC был введен и фактически стандартизован интерфейс игрового адаптера - Game port, к которому можно подключить до двух джойстиков или иных устройств. Суммарно на порте доступно 4 координатных датчика (X1, Х2, Y1 и Y2) и 4 кнопки. Назначение координатных датчиков зависит от игры и конструкции манипулятора. Для авиасимуляторов X1 может соответствовать перемещению рукоятки вверх-вниз, Y1 - влево-вправо, Х2 - нажатие левой и правой педалей, Y2 - рукоятка сектора газа. Для автомобильных рулей X1 - руль, Y1 - газ, Х2 - тормоз (газ и тормоз могут быть совмещены в координате Y1). Кроме игровых целей порт может применяться и для подключения более "серьезных" датчиков.
Ввод дискретных сигналов от кнопок пояснений не требует. Упрощенная схема одного аналогового канала приведена на рисунке. Конденсатор заряжается через переменное сопротивление датчика и разряжается через ключ; компаратор сравнивает напряжение на конденсаторе с некоторым порогом. Выходы компараторов всех четырех каналов преобразования, как и дискретные входы, собираются в регистр порта, который может быть программно считан. Любая запись в порт приводит к открытию ключей и разряду конденсаторов, при этом биты 0-3 устанавливаются в 1. Эти биты сбросятся в 0, когда конденсаторы их каналов зарядятся до порога срабатывания компаратора; время заряда до срабатывания определяется текущим значением сопротивления каждого датчика. Замыканию кнопок соответствуют нули в битах 5-7.
Преобразование выполняется чисто программно и начинается по выводу любого байта в регистр адаптера. Далее программа циклически выполняет чтение регистра адаптера и измеряет время до возврата в нулевое состояние бит 0-3, соответствующих четырем аналоговым каналам. Если аналоговый вход закорочен на шину GND или цепь измеряемого сопротивления разорвана, соответствующий бит не обнулится. Поэтому в программе преобразования должен быть предусмотрен тайм-аут. Для измеряемых сопротивлений в диапазоне 0-100 кОм время определяется по формуле: Т (мкс) = 24,2 + 11 х R (кОм).
Точность и линейность преобразования невысока, выполняется оно не быстро (до 1,12 мс) и сильно загружает процессор. Однако в отличие от "настоящих" аналого-цифровых преобразователей этот достается даром - игровой адаптер входит в состав практически всех комбинированных плат последовательных и параллельных портов и звуковых карт.
Порт имеет разъем-розетку DB-15S. Кнопки подключаются к шине GND, переменные резисторы - к шине питания +5 В. Вместо переменных резисторов к порту можно подключать источники измеряемых токов. Аналоговые каналы можно использовать для дискретного ввода, если их входы подключить к кнопкам, замыкающим их на шину GND, и к резисторам, "подтягивающим" их к уровню + 5 В. Два джойстика (А и В) подключаются через Y-образный переходник-разветвитель. На звуковых картах вместе с джойстиками могут подключаться и внешние MIDI-устройства через разъем "Game" и специальный кабель-адаптер, обеспечивающий гальваническую развязку входного сигнала и ограничение выходного тока. Для интерфейса MIDI используются контакты 12 и 15, ранее предназначавшиеся для шин GND и +5V. Такое назначение делает безопасным подключение адаптера MIDI к "чистому" игровому порту и обычного джойстика к игровому порту с сигналами MIDI.
Системную поддержку джойстика обеспечивает BIOS Int 15h при AH=84h. При вызове в DX задается код подфункции:

  • DX=0 - опрос кнопок, возвращает в AL [7:4] состояние кнопок (соответствует битам порта 201h);
  • DX=1 - чтение координат X, Y джойстика А (в регистры АХ, ВХ) и В (в СХ, DX).
При ошибочном задании кода в DX устанавливается флаг CF=1. Стандартный джойстик поддерживается ОС Windows.
Из-за расточительного использования процессорного времени на преобразования (а их приходится выполнять регулярно, чтобы отслеживать динамику движения) традиционный джойстик и игровой адаптер из современных компьютеров изживают. Их место должны занять устройства с интерфейсом шины USB, в которых преобразования с точки зрения центрального процессора выполняются аппаратно. Такие джойстики называют цифровыми (в отличие от вышеописанного аналогового). Есть и цифровые джойстики с интерфейсом СОМ-порта.
Существуют и джойстики с механической обратной связью - в них на органы управления (рычаг, руль) воздействуют моторы привода, получающие управляющие сигналы от компьютера. Таким образом, например, может имитироваться сопротивление повороту руля автомобиля, удар по рулю при наезде на препятствие или, наоборот, ослабление сопротивления руля при заносе. Для подачи управляющих сигналов интерфейс игрового порта не приспособлен, поэтому для этих сигналов используется дополнительный интерфейсный кабель (от СОМ-порта). Джойстик с интерфейсом USB, естественно, по одному кабелю передает информацию в обе стороны. Цифровые джойстики требуют установки специальных драйверов.


§ 16. - Com-порт.

Последовательный интерфейс для передачи данных в одном направлении использует одну сигнальную линию, по которой информационные биты передаются друг за другом - последовательно. Английские названия интерфейса и порта - Serial Interface и Serial Port, иногда их неправильно переводят как "серийные". Последовательная передача позволяет сократить количество сигнальных линий и добиться улучшения связи на больших расстояниях.
Начиная с первых моделей, в PC имелся последовательный интерфейс - СОМ-порт (Communications Port - коммуникационный порт). Этот порт обеспечивает асинхронный обмен по стандарту RS-232C. Синхронный обмен в PC поддерживают лишь специальные адаптеры, например SDLC или V.35. СОМ-порты реализуются на микросхемах универсальных асинхронных приемопередатчиков (UART), совместимых с семейством i8250/16450/16550. Они занимают в пространстве ввода-вывода по 8 смежных 8-битных регистров и могут располагаться по стандартным базовым адресам 3F8h (COM1), 2F8h (COM2), 3E8h (COM3), 2E8h (COM4). Порты могут вырабатывать аппаратные прерывания IRQ4 (обычно используются для СОМ1 и COM3) и IRQ3 (для COM2 и COM4). С внешней стороны порты имеют линии последовательных данных передачи и приема, а также набор сигналов управления и состояния, соответствующий стандарту RS-232C. СОМ-порты имеют внешние разъемы-вилки (male - "папа") DB25P или DB9P, выведенные на заднюю панель компьютера. Характерной особенностью интерфейса является применение не ТТЛ-сигналов - все внешние сигналы порта двуполярные. Гальваническая развязка отсутствует - схемная земля подключаемого устройства соединяется со схемной землей компьютера. Скорость передачи данных может достигать 115 200 бит/с.
Компьютер может иметь до четырех последовательных портов СОМ 1-COM4 (для машин класса AT типично наличие двух портов) с поддержкой на уровне BIOS. Сервис BIOS Int 14h обеспечивает инициализацию порта, ввод и вывод символа (без прерываний) и опрос состояния. Через Int 14h скорость передачи программируется в диапазоне 110-9600 бит/с (меньше, чем реальные возможности порта). Для повышения производительности широко используется взаимодействие программ с портом на уровне регистров, для чего требуется совместимость аппаратных средств СОМ-порта с программной моделью 18250/16450/ 16550.
Название порта указывает на его основное назначение - подключение коммуникационного оборудования (например, модема) для связи с другими компьютерами, сетями и периферийными устройствами. К порту могут непосредственно подключаться и периферийные устройства с последовательным интерфейсом: принтеры, плоттеры, терминалы и др. СОМ-порт широко используется для подключения мыши, а также организации непосредственной связи двух компьютеров. К СОМ-порту подключают и электронные ключи.
Практически все современные системные платы (еще начиная с PCI-плат для процессоров 486) имеют встроенные адаптеры двух СОМ-портов. Один из портов может использоваться и для беспроводной инфракрасной связи с периферийными устройствами (IrDA). Существуют карты ISA с парой СОМ-портов, где они чаще всего соседствуют с LPT-портом, а также с контроллерами дисковых интерфейсов (FDC+IDE). "Классический" СОМ-порт позволял осуществлять обмен данными только программно- управляемым способом, при этом для пересылки каждого байта процессору приходится выполнять несколько инструкций. Современные порты имеют FIFO-буферы данных и позволяют выполнять обмен по каналу DMA, существенно разгружая центральный процессор, что особенно важно на больших скоростях обмена.
В спецификации РС'99 традиционные СОМ-порты не рекомендованы, но еще разрешены для использования. Если они есть, то должны быть совместимыми с UART 16550A и обеспечивать скорость до 115,2 Кбит/с. Устройства, которые традиционно используют СОМ-порт, рекомендуется переводить на последовательные шины USB и Fire Wire.


§ 17. - Инфракрасный интерфейс IrDA.

Применение излучателей и приемников инфракрасного (ИК) диапазона позволяет осуществлять беспроводную связь между парой устройств, удаленных на расстояние нескольких метров. Инфракрасная связь - IR (InfraRed) Connection - безопасна для здоровья, не создает помех в радиочастотном диапазоне и обеспечивает конфиденциальность передачи. ИК-лучи не проходят через стены, поэтому зона приема ограничивается небольшим, легко контролируемым пространством. Инфракрасная технология привлекательна для связи портативных компьютеров со стационарными компьютерами или док-станциями. Инфракрасный интерфейс имеют некоторые модели принтеров, им оснащают многие современные малогабаритные устройства: карманные компьютеры (PDA), мобильные телефоны, цифровые фотокамеры и т. п.
Различают инфракрасные системы низкой (до 115,2 Кбит/с), средней (1,152 Мбит/с) и высокой (4 Мбит/с) скорости. Низкоскоростные системы служат для обмена короткими сообщениями, высокоскоростные - для обмена файлами между компьютерами, подключения к компьютерной сети, вывода на принтер, проекционный аппарат и т. п. Ожидаются более высокие скорости обмена, которые позволят передавать "живое видео". В 1993 году создана ассоциация разработчиков систем инфракрасной передачи данных IrDA (Infrared Data Association), призванная обеспечить совместимость оборудования от различных производителей. В настоящее время действует стандарт IrDA 1.1, наряду с которым существуют и собственные системы фирм Hewlett Packard - HP-SIR (Hewlett Packard Slow Infra Red) и Sharp - ASK IR (Amplitude Shifted Keyed IR). Эти интерфейсы обеспечивают следующие скорости передачи:

  • IrDA SIR (Serial InfraRed), HP-SIR- 9,6-115,2 Кбит/с;
  • IrDA HDLC, известный и как IrDA MIR (Middle Infra Red) - 0,576 и 1,152 Мбит/с;
  • IrDA FIR (Fast Infra Red) - 4 Мбит/с;
  • ASK IR - 9,6-57,6 Кбит/с.
Излучателем для ИК-связи является светодиод, имеющий пик спектральной характеристики мощности 880 нм; светодиод дает конус эффективного излучения с углом около 30°. В качестве приемника используют PIN-диоды, эффективно принимающие ИК- лучи в конусе 15°. Спецификация IrDA определяет требования к мощности передатчика и чувствительности приемника, причем для приемника задается как минимальная, так и максимальная мощность ИК-лучей. Импульсы слишком малой мощности приемник не "увидит", а слишком большая мощность "ослепляет" приемник - принимаемые импульсы сольются в неразличимый сигнал. Кроме полезного сигнала на приемник воздействуют помехи: засветка солнечным освещением или лампами накаливания, дающая постоянную составляющую оптической мощности, и помехи от люминесцентных ламп, дающие переменную (но низкочастотную) составляющую. Эти помехи приходится фильтровать. Спецификация IrDA обеспечивает уровень битовых ошибок (BER - Bit Error Ratio) не более 10~9 при дальности до 1 м и дневном свете (освещенность - до 10 клюке). Поскольку передатчик почти неизбежно вызывает засветку своего же приемника, вводя его в насыщение, приходится прибегать к полудуплексной связи с определенными временными зазорами при смене направления обмена. Для передачи сигналов используют двоичную модуляцию (есть свет - нет света) и различные схемы кодирования.
Спецификация IrDA определяет многоуровневую систему протоколов, которую рассмотрим снизу вверх.
Ниже перечислены возможные варианты IrDA на физическом уровне.
  • IrDA SIR - для скоростей 2,4-115,2 Кбит/с используется стандартный асинхронный режим передачи (как в СОМ-портах): старт-бит (нулевой), 8 бит данных и стоп-бит (единичный). Нулевое значение бита кодируется импульсом длительностью 3/16 битового интервала (1,63 икс на скорости 115,2 Кбит/с), единичное - отсутствием импульсов (режим IrDA SIR-A). Таким образом, в паузе между посылками передатчик не светит, а каждая посылка начинается с импульса старт-бита. В спецификации 1.1 предусмотрен и иной режим - IrDA SIR-B, с фиксированной длительностью импульса 1,6,3 мкс для всех этих скоростей.
  • ASK IR - для скоростей 9,6-57,6 Кбит/с также используется асинхронный режим, но кодирование иное: нулевой бит кодируется посылкой импульсов с частотой 500 кГц, единичный - отсутствием импульсов.
  • IrDA HDLC - для скоростей 0,576 и 1,152 Мбит/с используется синхронный режим передачи и кодирование, аналогичное SIR, но с длительностью импульса 1/4 битового интервала. Формат кадра соответствует протоколу HDLC, начало и конец кадра отмечаются флагами 01111110, внутри кадра эта битовая последовательность исключается с помощью вставки битов (bit stuffing). Для контроля достоверности кадр содержит 16-битный CRC-код.
  • IrDA FIR (IrDA4PPM) - для скорости 4 Мбит/с также применяется синхронный режим, но кодирование несколько сложнее. Здесь каждая пара смежных битов кодируется позиционно-импульсным кодом: 00 - 1000, 01 - 0100, 10 - 0010, И - 0001 (в четверках символов единица означает посылку импульса в соответствующей четверти двухбитового интервала).
Такой способ кодирования позволяет вдвое снизить частоту включения светодиода по сравнению с предыдущим. Постоянство средней частоты принимаемых импульсов облегчает адаптацию к уровню внешней засветки. Для повышения достоверности применяется 32-битный CRC-код.
Над физическим уровнем расположен протокол доступа IrLAP (IrDA Infrared Link Access Protocol) - модификация протокола HDLC, отражающая нужды ИК-связи. Он инкапсулирует данные в кадры и предотвращает конфликты устройств: при наличии более двух устройств, "видящих" друг друга, одно из них назначается первичным, а остальные - вторичными. Связь всегда полудуплексная. IrLAP описывает процедуру установления, нумерации и закрытия соединений. Соединение устанавливается на скорости 9600 бит/с, после чего согласуется скорость обмена по максиму из доступных обоим (9,6, 19,2, 38,4, 57,6 или 115,2 Кбит/с) и устанавливаются логические каналы (каждый канал управляется одним ведущим устройством).
Над IrLAP располагается протокол управления соединением IrLMP (IrDA Infrared Link Management Protocol). С его помощью устройство сообщает остальным о своем присутствии в зоне охвата (конфигурация устройств IrDA может изменяться динамически: для ее изменения достаточно поднести новое устройство или отнести его подальше). Протокол IrLMP позволяет обнаруживать сервисы, предоставляемые устройством, проверять потоки данных и выступать в роли мультиплексора для конфигураций с множеством доступных устройств. Приложения с помощью IrLMP могут узнать, присутствует ли требуемое им устройство в зоне охвата. Однако гарантированной доставки данных этот протокол не обеспечивает.
Транспортный уровень обеспечивается протоколом Tiny TP (IrDA Transport Protocols) - здесь обслуживаются виртуальные каналы между устройствами, обрабатываются ошибки (потерянные пакеты, ошибки данных и т. п.), производится упаковка данных в пакеты и сборка исходных данных из пакетов (протокол напоминает TCP). На транспортном уровне может работать и протокол IrTP.
Протокол IrCOMM позволяет через ИК-связь эмулировать обычное проводное подключение:
  • 3-проводное по RS-232C (TXD, RXD и GND);
  • 9-проводное по RS-232C (весь набор сигналов СОМ-порта);
  • Centronics (эмуляция параллельного интерфейса).
Протокол IrLAN обеспечивает доступ к локальным сетям; он позволяет передавать кадры сетей Ethernet и Token Ring. Для ИК-подключения к локальной сети требуется устройство-провайдер с интерфейсом IrDA, подключенное обычным (проводным) способом к локальной сети, и соответствующая программная поддержка в клиентском устройстве (которое должно войти в сеть).
Протокол объектного обмена IrOBEX (Object Exchange Protocol) - простой протокол, определяющий команды PUT и GET для обмена "полезными" двоичными данными между устройствами. Этот протокол располагается над протоколом Tiny ТР. У протокола IrOBEX есть расширение для мобильных коммуникаций, определяющее передачу информации, относящуюся к сетям GSM (записная книжка, календарь, управление вызовом, цифровая передача голоса и т. п.), между телефоном и компьютерами разных размеров (от настольного до PDA).
Этими протоколами не исчерпывается весь список протоколов, имеющих отношение к ИК-связи. Заметим, что для дистанционного управления бытовой техникой (телевизоры, видеомагнитофоны и т. п.) используется то же 880-нм диапазон, но иные частоты и методы физического кодирования.
Приемопередатчик IrDA может быть подключен к компьютеру различными способами; по отношению к системному блоку он может быть как внутренним (размещаемым на лицевой панели), так и внешним, размещаемым в произвольном месте. Размещать приемопередатчик следует с учетом угла "зрения" (30° у передатчика и 15° у приемника) и расстояния до требуемого устройства (до 1 м).
Внутренние приемопередатчики на скоростях до 115,2 Кбит/с (IrDA SIR, HP-SIR, ASK IR) подключаются через обычные микросхемы UART, совместимые с 16450/16550 через сравнительно несложные схемы модуляторов-демодуляторов. В ряде современных системных плат на использование инфракрасной связи (до 115,2 Кбит/с) может конфигурироваться порт COM2. Для этого в дополнение к UART чипсет содержит схемы модулятора и демодулятора, обеспечивающие один или несколько протоколов инфракрасной связи. Чтобы порт COM2 использовать для инфракрасной связи, в CMOS Setup требуется выбрать соответствующий режим (запрет инфракрасной связи означает обычное использование COM2). Существуют внутренние адаптеры и в виде карт расширения (для шин ISA, PCI, PC Card), для системы они выглядят как дополнительные СОМ-порты.
На средних и высоких скоростях обмена применяются специализированные микросхемы контроллеров IrDА, ориентированные на интенсивный программный обмен (РЮ) или DMA, с возможностью прямого управления шиной. Здесь обычная микросхема UART непригодна, поскольку она не поддерживает синхронный режим и высокую скорость. Контроллер IrDA FIR выполняется в виде карты расширения либо интегрируется в системную плату; как правило, такой контроллер поддерживает и режимы SIR.
Приемопередатчик подключается к разъему IR-Connector системной платы, напрямую (если он устанавливается на лицевую панель компьютера) или через промежуточный разъем (mini-DIN), расположенный на скобе-заглушке на задней стенке корпуса. К сожалению, единой раскладки цепей на внутреннем коннекторе нет, и для большей гибкости приемопередатчик (или промежуточный разъем) снабжают кабелем с отдельными контактами разъема. Собрать их в должном порядке предоставляют пользователю. Некоторые приемопередатчики, поддерживающие режим FIR и SIR, имеют раздельные выходы приемников - IRRX (для SIR) и FIRRX (для FIR). Если контроллер поддерживает только один из режимов, один из контактов останется неподключенным.
Внешние ИК-адаптеры выпускают с интерфейсом RS-232C для подключения к СОМ-порту или же с шиной USB. Пропускной способности USB достаточно даже для FIR, СОМ-порт пригоден только для SIR. Внешний ИК-адаптер IrDA SIR для СОМ-порта не так прост, как казалось бы: для работы модулятора-демодулятора требуется сигнал синхронизации с частотой, 16-кратной частоте передачи данных (этот сигнал поступает на синхровход микросхемы UART СОМ-порта). Такого сигнала на выходе СОМ-порта нет и его приходится восстанавливать из асинхронного битового потока. Адаптер ASK IR в этом плане проще - передатчик должен передавать высокочастотные импульсы все время, пока на выходе TXD находится сигнал высокого уровня; приемник должен формировать огибающую принятых импульсов.
Для прикладного использования IrDA кроме физического подключения адаптера и трансивера требуется установка и настройка соответствующих драйверов.
В ОС Windows 9x/ME/2000 контроллер IrDA попадает в "Сетевое окружение". Сконфигурированное ПО позволяет устанавливать соединение с локальной сетью (для выхода в Интернет, использования сетевых ресурсов); передавать файлы между парой компьютеров; выводить данные на печать; синхронизировать данные PDA, мобильного телефона и настольного компьютера; выгружать отснятые изображения из фотокамеры в компьютер и выполнять ряд других полезных действий, не заботясь ни о каком кабельном хозяйстве.


§ 18. - Радиоинтерфейс Bluetooth.

Bluetooth (синий зуб) - это фактический стандарт на миниатюрные недорогие средства передачи информации на небольшие расстояния посредством радиосвязи между мобильными (и настольными) компьютерами, мобильными телефонами и любыми другими портативными устройствами. Разработкой спецификации занимается группа лидирующих фирм в областях телекоммуникаций, компьютеров и сетей - 3Com, Agere Systems, Ericsson, IBM, Intel, Microsoft, Motorola, Nokia, Toshiba. Эта группа, образовавшая Bluetooth Special Interest Group, и вывела данную технологию на рынок. Спецификация Bluetooth свободно доступна в Сети (www.bluetooth.com), правда, весьма объемиста (около 15 Мбайт PDF-файлов). Открытость спецификации должна способствовать ее быстрому распространению, что уже и наблюдается на практике. Здесь позволим себе сократить название технологии до "ВТ" (это не официальное сокращение). Само название берет начало от прозвища датского короля, объединившего Данию и Норвегию, - это намек на всеобщую объединяющую роль технологии.
Каждое устройство ВТ имеет радиопередатчик и приемник, работающие в диапазоне частот 2,4 ГГц. Этот диапазон в большинстве стран отведен для промышленной, научной и медицинской аппаратуры и не требует лицензирования, что обеспечивает повсеместную применимость устройств. Для ВТ используются радиоканалы с дискретной (двоичной) частотной модуляцией, несущая частота каналов F = 2402 + k (МГц), где k = 0,...,78. Для нескольких стран (например, Франции, где в этом диапазоне работают военные), возможен сокращенный вариант с F = 2454 + k (k = 0,...,22). Кодирование простое - логической единице соответствует положительная девиация частоты, нулю - отрицательная. Передатчики могут быть трех классов мощности, с максимальной мощностью 1, 2,5 и 100 МВт, причем должна быть возможность понижения мощности с целью экономии энергии.
Передача ведется с перескоком несущей частоты с одного радиоканала на другой, что помогает в борьбе с интерференцией и замираниями сигнала. Физический канал связи представляется определенной псевдослучайной последовательностью используемых радиоканалов (79 или 23 возможных частот). Группа устройств, разделяющих один канал (то есть "знающих" одну и ту же последовательность перескоков), образует так называемую пикосетъ (piconet), в которую может входить от 2 до 8 устройств. В каждой пикосети имеется одно ведущее устройство и до 7 активных ведомых. Кроме того, в зоне охвата ведущего устройства в его же пикосети могут находиться "припаркованные" ведомые устроиства: они тоже "знают" последовательность перескоков и синхронизируются (по перескокам) с мастером, но не могут обмениваться данными до тех пор, пока мастер не разрешит им активность. Каждое активное ведомое устройство пикосети имеет свой временный номер (1-7); когда ведомое устройство деактивируется (паркуется), оно отдает свой номер другим. При последующей активации оно уже может получить иной номер (потому-то он и временный). Пикосети могут перекрываться зонами охвата, образуя "разбросанную" сеть (scatternet). При этом в каждой пикосети мастер только один, но ведомые устройства могут входить в несколько пикосетеи посредством разделения времени (часть времени устройство работает в одной пикосети, часть - в другой). Более того, мастер одной пикосети может быть ведомым устройством другой пикосети. Эти пикосети никак не синхронизированы, каждая из них использует свой канал (последовательность перескоков).
Канал делится на тайм-слоты длительностью 625 мкс, слоты последовательно нумеруются с цикличностью 227. Каждый тайм-слот соответствует одной частоте несущей в последовательности перескоков (1600 перескоков в секунду). Последовательность частот определяется адресом устройства-мастера пикосети. Передачи ведутся пакетами, каждый пакет может занимать от 1 до 5 тайм-слотов. Если пакет длинный, то он весь передается на одной частоте несущей, но отсчет слотов по 625 мкс продолжается, и после длинного пакета следующая частота будет соответствовать очередному номеру слота (то есть несколько перескоков пропускаются). Мастер и ведомые устройства ведут передачу поочередно: в четных слотах передачу ведет мастер, а в нечетных - адресованное им ведомое устройство (если ему есть что "сказать").
Между мастером и ведомыми устройствами могут устанавливаться физические связи двух типов: синхронные и асинхронные.
Синхронные связи (они же изохронные) с установлением соединения, SCO link (Synchronous Connection Oriented), используются для передачи изохронного трафика (например, оцифрованного звука). Эти связи типа "точка-точка" предварительно устанавливаются мастером с выбранными ведомыми устройствами, и для каждой связи определяется период (в слотах), через который для нее резервируются слоты. Связи получаются симметричные двусторонние. Повторных передач пакетов в случае ошибок приема нет. Мастер может установить до трех связей SCO с одним или разными ведомыми устройствами. Ведомое устройство может иметь до трех связей с одним мастером или иметь по одной связи SCO с двумя различными мастерами. По сетевой классификации связи SCO относятся к коммутации цепей.
Асинхронные связи без установления соединения, ACL link (Asynchronous Connection-Less), реализуют коммутацию пакетов по схеме "точка-множество точек" между мастером и всеми ведомыми устройствами пикосети. Мастер может связываться с любым из ведомых устройств пикосети в слотах, не занятых под SCO, послав ему пакет и потребовав ответа. Ведомое устройство имеет право на передачу, только получив обращенный к нему запрос мастера (безошибочно декодировав свой адрес). Для большинства типов пакетов предусматривается повторная передача в случае обнаружения ошибки приема. Мастер может посыдать и безадресные широковещательные пакеты для всех ведомых устройств своей пикосети. С каждым из своих ведомых устройств мастер может установить лишь одну связь ACL.


§ 19. - Модемы и факс-модемы.

Для передачи данных на большие расстояния (в пределах всего мира) издавна используют телефонные сети общего пользования (ТФОП). Однако для непосредственной передачи цифровых данных обычные аналоговые телефонные сети непригодны - требуются модемы на сторонах обоих абонентов.
Модем (модулятор-демодулятор) служит для передачи информации на большие расстояния, недоступные локальным сетям, с использованием выделенных и коммутируемых телефонных линий. Модулятор поступающую от компьютера двоичную информацию преобразует в аналоговые сигналы с частотной и (или) фазовой модуляцией, спектр которых соответствует полосе пропускания обычных голосовых телефонных линий. Демодулятор из этого сигнала извлекает закодированную двоичную информацию и передает ее в принимающий компьютер.
Факс-модем (fax-modem) позволяет передавать и принимать факсимильные изображения, совместимые с обычными факс-машинами. Передача факсов также подразумевает передачу цифровых данных, хотя "цифра" не видна конечным пользователям: факс-машина сканирует изображение, оцифровывает его (1 бит на точку), сжимает данные и через модем передает в телефонную линию. На приемной стороне выполняются обратные преобразования. Факс-модем работает аналогично, только вместо сканирования его программная поддержка принимает графические или текстовые данные от других программ. Принятые факсы оформляются в виде файлов графических форматов, доступных приложениям для дальнейшей обработки или печати.
Современные модемы имеют ряд дополнительных возможностей, расширяющих сферу их применения. Голосовой модем (voice modem) способен преобразовывать звуковой сигнал в цифровой вид, в котором он передается по линии связи. На приемной стороне выполняются обратные преобразования. Аудиосигнал сжимается, например, по методу ADPCM (Adaptive Differential Pulse Code Modulation - адаптивная дифференциальная импульсно-кодовая модуляция, АДИКМ). С помощью голосового модема могут быть реализованы звуковая почта, автоответчик и другие речевые функции. Звуковое сообщение может передаваться по электронной почте или в диалоге реального времени и воспроизводиться голосовым модемом через внутренний динамик, дополнительный телефонный аппарат или через мультимедийные средства компьютера (звуковую карту). Средства обработки звуковых сигналов позволяют модему автоматически определять номер вызывающего абонента (АОН), распознавать сигналы тонального набора номера.
Модемы во время сеанса связи могут работать в симплексном, дуплексном или полудуплексном режиме. Для повышения эффективной скорости используются различные методы сжатия информации, реализуемые как самими модемами, так и коммуникационным ПО.


§ 20. - Технология xDSL и кабельные модемы.

Технологии xDSL основаны на превращении абонентской линии обычной телефонной сети из аналоговой в цифровую, что и отражено в их названии (Digital Subscriber Line - цифровая абонентская линия). Общая идея заключается в том, что на обоих концах абонентской линии - на АТС и у абонента - устанавливаются разделительные фильтры (splitter).
Низкочастотная (до 3,5 кГц) составляющая сигнала заводится на обычное телефонное оборудование (порт АТС и телефонный аппарат у абонента), а высокочастотная (выше 4 кГц) используется для передачи данных с помощью xDSL-модемов. Поскольку физическая линия (пара проводов) между абонентом и АТС позволяет пропускать сигнал в полосе даже до 1 МГц, достижимые скорости передачи гораздо выше, чем предел в 56 Кбит/с, установленный и достигнутый для обычных модемов. Высокочастотная часть полосы пропускания сигнала может разделяться между встречными потоками данных различными способами. При частотном разделении каналов (FDM) часть спектра отдается на передачу в одном направлении, часть - в другом. При эхоподавлении (echo-cancellation) вся полоса используется для передачи в обе стороны, а каждое устройство при приеме из общего сигнала вычитает сигнал собственного передатчика. Пропускная способность может быть как симметричной, так и асимметричной. В случае подключения пользователя к Интернету асимметрия выгодна, поскольку поток к абоненту (страницы текста, аудио-и видеопотоки) гораздо больше обратного потока (запросы URL).
Наибольшее распространение получила асимметричная технология ADSL (Asymmetric Digital Subscriber Line), где скорость к абоненту (downstream) достигает 6,1 Мбит/с, от абонента - 16-640 Кбит/с. Достижимая скорость связана с длиной абонентской линии и ее качеством (сечение проводов, материал изоляции, шаг скрутки, однородность и т. п.). Минимальная скорость обеспечивается на линиях длиной до 5,5 км при диаметре провода 0,5 мм (24 AWG) и до 4,6 км при 0,4 мм (26AWG). Скорость 6,1 Мбит/с достигается на линиях длиной до 3,7 км при диаметре провода 0,5 мм и до 2,7 км при 0,4 мм.
Технология UADSL (Universal ADSL), она же DSL Lite, - улучшенный вариант ADSL с меньшими скоростями (при длине линии до 3,5 км скорости 1,5 Мбит/с и 384 Кбит/с в разных направлениях; при длине линии до 5,5 км - 640 и 196 Кбит/с). Устройства просты в установке и относительно недороги.
RADSL (Rate Adaptive Digital Subscriber Line) - технология с адаптивным изменением скорости передачи в зависимости от качества линии.
HDSL (High Data-Rate Digital Subscriber Line) - высокоскоростная технология, обеспечивающая скорости 1,536 или 2,048 Мбит/с в обоих направлениях. Протяженность линии - до 3,7 км, требует четырехпроводной линии.
SDSL (Single-Line Digital Subscriber Line) - симметричная высокоскоростная (1,536 или 2,048 Мбит/с) технология, но на двухпроводной линии при длине до 3 км.
VDSL (Very High Data-Rate Digital Subscriber Line) - очень высокоскоростная (до 56 Мбит/с), симметричная технология. Расстояние до 1,5 км. Технология весьма дорогая, но рассчитана и на коллективное использование линий. После разделяющего фильтра на абонентской стороне может стоять одиночный модем (или концентратор), а может подключаться через специальную кабельную проводку (коаксиальный кабель или витая пара) и группа модемов, разделяя полосу пропускания предопределенным образом.
Для того чтобы использовать xDSL, провайдер (оператор связи) должен установить свое оборудование на территории АТС обслуживаемого абонента и соединить его с базовой сетью передачи данных каналом достаточной производительности. Конечно, возможны и частные случаи, когда с помощью xDSL объединяются локальные сети в зданиях, охваченных одной АТС. Установка модема xDSL на стороне абонента практически не отличается от установки обычного модема. Но технологии xDSL позволяют одновременно и независимо использовать одну и ту же телефонную линию и для передачи данных, и для телефонных переговоров, чего не позволяют обычные модемы для коммутируемых линий.
Кабельные модемы предназначены для работы через сети кабельного телевидения (CATV), для которых требуется широкополосный коаксиальный кабель с импедансом 75 Ом. Передача данных ведется параллельно с видеовещанием. Эти модемы используют кабельное хозяйство операторов услуг кабельного телевидения. Как и ADSL, кабельные модемы асимметричны: скорость к пользователю может достигать десятков мегабайт в секунду, от пользователя - значительно ниже. Кабельные модемы могут быть и симплексными - модем пользователя только принимает нисходящий (downstream) поток данных от модема оператора кабельного TV. При этом восходящий (upstream) поток данных от пользователя должен передаваться по иным каналам (например, ISDN или аналоговым модемам). Для упрощения структуры коммуникаций (но не оборудования) желательно оба потока передавать по одной и той же кабельной сети. Развитием идеи раздельной передачи потоков является передача нисходящего потока по спутниковым каналам, но пока что это слишком дорогая технология. Кабельные модемы в основном предназначены для предоставления пользователям доступа к Интернету с высокими скоростями получения информации.


§ 21. - Аудиосистема.

С самого рождения IBM PC имел голос - PC Speaker, превращающий компьютер в простейший синтезатор. Пройдя путь от программно-управляемого динамика до современных цифровых аудиокодеков, синтезаторов и сигнальных процессоров, современные PC стали полноправными участниками процесса создания, записи, редактирования и воспроизведения аудиоинформации высокого качества. Представление о наборе аудиосредств современного мультимедийного компьютера дает. Обязательными атрибутами мультимедийного компьютера являются привод CD-ROM или DVD и звуковая карта.
Типовая звуковая карта в своем составе имеет цифровой канал записи-воспроизведения, микшер, синтезатор и MIDI-порт.
Цифровой аудиоканал, он же аудиокодек, обеспечивает возможность моно- или стереофонической записи и воспроизведения аудиофайлов с уровнем качества от кассетного магнитофона до аудио-CD и даже выше. Запись (recording) производится оцифровкой (аналого-цифровым преобразованием) выборок мгновенного значения сигнала; современные карты позволяют принимать и цифровые аудио-данные. Оцифрованный звук может храниться в файлах, для которых обычно используется расширение .WAV (сокращенно от Wave - волна). Размер файла зависит от длительности записи, разрядности преобразования, частоты квантования и количества каналов (моно- или стереозапись). Эти "волновые файлы" могут редактироваться программными средствами, которые обычно позволяют вывести на экран подобие осциллограмм записанных сигналов. При воспроизведении (playback) поток цифровых данных выводится на внешний интерфейс, аналоговый (линейный выход или выход усилителей на колонки или наушники) или цифровой.
Микшер с программным управлением обеспечивает регулировку входных и выходных сигналов. Микшер позволяет смешивать входные сигналы от нескольких источников (микрофона, CD, внешнего входа и синтезатора). В стереокарте (а монокарты уже давно не используют) каждый источник должен иметь раздельные регуляторы уровня для каждого канала. Внешне (в графической оболочке программного интерфейса) это может выглядеть и как общий регулятор уровня и регулятор баланса. Для монофонических источников (например, микрофон) кроме регулятора уровня имеется регулятор панорамы, позволяющий балансировать уровни сигналов, посылаемых от данного источника в левый и правый стереоканалы. Физически это опять-таки могут быть просто два регулятора уровня для одного и того же сигнала. Дополнительно к микшеру карта обычно имеет регулировку тембра по низким и высоким частотам или даже эквалайзер - многополосный регулятор тембра.
Синтезатор обеспечивает имитацию звучания музыкальных инструментов и воспроизведение различных звуков. Из множества методов синтеза в звуковых картах в основном используют два - частотный и волновой.

  • FM Music Synthesizer - синтезатор с частотной модуляцией (Frequency Modulated), обеспечивающий невысокое качество синтеза.
  • WT Music Synthesizer - синтезаторы с табличным синтезом (Wave Table), хранящие в своей постоянной памяти образцы сигналов натуральных инструментов. Волновые синтезаторы обеспечивают высокое качество синтеза, но они заметно дороже.
Встроенный усилитель имеет мощность до 4 Вт на канал, хотя некоторые адаптеры обеспечивают мощность, достаточную только для наушников.
Колонки (speakers) для PC несколько отличаются от обычных бытовых акустических систем. Они, как правило, малогабаритные, поскольку предназначены для установки на столе, по бокам от монитора. Малые габариты, конечно же, отражаются на качестве и выходной мощности. Хорошие колонки имеют специальный магнитный экран или улучшенную конструкцию магнитной системы динамиков, чтобы предотвратить воздействие магнитного поля на монитор. Сильное магнитное поле нарушает линейность развертки и сведение лучей на экране монитора. Ряд моделей "мультимедийных" мониторов оборудован встроенными акустическими системами. Активные колонки (active speakers) имеют встроенный усилитель, требующий внешнего (или батарейного) питания. Они могут иметь регуляторы громкости и тембра. Пассивные колонки встроенного усилителя не имеют, их мощность невелика. Есть модели колонок, режим работы которых (активный или пассивный) выбирается переключателем. Полоса частот и мощность обычных малогабаритных колонок недостаточна для воспроизведения Hi-Fi. Более качественные системы имеют две колонки для средних и высоких частот и одну (большую) для низких. Для высококачественного воспроизведения лучше использовать внешний стереоусилитель с собственными акустическими системами или стереонаушники.
Наушники или усилитель можно подключать и к аудиовыходу CD-ROM, что позволит прослушивать аудио-CD (но не CD-ROM с файлами .МРЗ) независимо от наличия звуковой карты. Регулятор уровня этого 'выхода (диск потенциометра или кнопки) расположен на лицевой панели CD-ROM. Там же в ряде моделей приводов имеются кнопки воспроизведения и выбора трека, позволяющие управлять проигрыванием без привлечения каких-либо программных средств.
Недавно стали появляться звуковые устройства для шины USB - колонки и микрофоны. Они имеют цифровой интерфейс и к обычным звуковым картам непосредственно не подключаются. Доставка аудиоданных к ним и от них осуществляется программно через контроллер шины USB, имеющийся на современных системных платах. При наличии достаточно мощного процессора такие устройства позволяют обходиться и без звуковой карты, реализуя все перечисленные функции чисто программными средствами. Однако применение звуковой карты расширяет возможности аудиосистемы и снижает загрузку процессора.
Для подключения электромузыкальных инструментов звуковые карты имеют порт MIDI (Musical Instrument Device Interface). Устройством ввода могут служить специальные MIDI-клавиатиры (как на клавишных музыкальных инструментах). Устройством вывода может быть синтезатор звуковой карты или внешний синтезатор, подключаемый к порту MIDI. Компьютер в такой системе используется как мощное средство создания, редактирования и хранения музыкальных произведений. МIDI-интерфейс имеют многие профессиональные и полупрофессиональные клавишные синтезаторы.
Желание "обучить" PC звукозаписи возникло задолго до появления звуковых карт с АЦП/ЦАП и было реализовано даже через динамик АТ-286. Для преобразования аналогового сигнала в дискретную форму использовался принцип широтно-импульсной модуляции (ШИМ). Для оцифровки звука умельцы применяли несложную схему, состоящую из микрофонного усилителя-фильтра на операционном усилителе и компаратора. С выхода этой схемы двуполярный дискретный сигнал (1 бит) поступал на один из управляющих входов СОМ-порта. Программа записи замеряла интервалы времени между переключениями этого бита и записывала эти значения в файл. Воспроизводящая программа считывала данные из файла и с теми же интервалами переключала бит 1 порта динамика (06 lh). Динамик выступал в роли фильтра нижних частот этого дискретно-аналогового преобразователя. На машинах с большим динамиком (он лучше фильтровал) удавалось добиваться внятного воспроизведения речи, правда, процессор 286 был загружен этим полностью. Заметим, что метод ШИМ недавно снова "всплыл из небытия" в применении к новому способу сверхвысококачественной аудиозаписи SACD (Super-Audio CD), предложенному фирмами Sony и Philips на смену традиционным аудио-CD.
Звуковоспроизведение "подручными средствами" реализовывалось проще и качественнее - достаточно к выходному порту данных 2 РТ подключить матрицу резисторов R-2R, и получится простейший 8-битный ЦАП. Такая приставка называлась Covox. Если к порту подключить пару регистров- защелок, к каждому из которых подключить матрицу резисторов, то можно организовать и стереофонию. Такими простейшими устройствами можно было пользоваться для озвучивания некоторых игр или для улучшения качества звучания музыкальной программы Screem Tracker на РС/АТ-286. С появлением звуковых карт нужда в этих устройствах сошла на нет.


§ 22. - Сканер.

При вводе изображения в компьютер в первую очередь необходимо преобразовать его в последовательность электрических сигналов. Для этого используются так называемые фотоэлектронные элементы, которые проводят ток по-разному — в зависимости от яркости света, попадающего на их поверхность. В качестве примера можно привести известный всем фотодиод. Проводимость этого прибора пропорциональна его освещенности. Поэтому, пропуская через фотодиод электрический ток и измеряя напряжение на его выводах, можно определять значение попадающего на него светового потока.
Однако в качестве светочувствительных элементов для сканеров обычные фотодиоды не используются.
Вместо них применяются другие устройства, чаще всего — так называемые приборы с зарядовой связью (ПЗС). Они чувствительнее к незначительным перепадам яркости света и намного компактнее.
С помощью одиночного светочувствительного элемента можно измерить яркость только одной точки изображения, а чтобы считать всю поверхность, необходимо организовать целый массив фотодатчиков. Так, в цифровых видеокамерах используется двухмерная (прямоугольная) матрица ПЗС, на которую с помощью оптической системы объектива проецируется кадр. В сканерах эта проблема решена по-другому. Светочувствительные ячейки располагаются в ряд, а полученная таким образом линейчатая сканирующая головка движется относительно оригинала (или оригинал относительно нее — это зависит от конструкции сканера), считывая все изображение строчка за строчкой. Подобным образом работает обычный фотоаппарат, где пленка засвечивается через узкую щель между шторками, которая перемещается от одного края кадра к другому.
При вводе цветных изображений точность передачи оттенков в значительной степени зависит от освещения. Во избежание искажений цвета в каждом сканере предусмотрен встроенный источник света — высококачественная галогенная лампа. А «связующим звеном» между источником света, изображением на бумаге и матрицей ПЗС (размер которой намного меньше ширины листа) служит оптическая система, состоящая из линз и зеркал. С ее помощью 'поток света направляется на оригинал, а отраженные лучи фокусируются на светочувствительных элементах.
Кроме ПЗС, в сканерах могут использоваться фотодатчики других типов, в частности, так называемые фотоэлектронные умножители — ФЭУ (Photo Multiplier Tubes — РМТ). В этих приборах лучи, отраженные от оригинала, проходят между несколькими парами электродов, находящихся под высоким напряжением, за счет чего многократно усиливаются. Вследствие этого сканер с ФЭУ может различать детали даже на самых темных участках изображения.
И наконец, еще один тип светочувствительных приборов, применяемых в сканерах, — контактные оптические сенсоры (Contact Image Sensor — CIS). Сканирующая головка, построенная на этой технологии, представляет собой линейку миниатюрных фотодатчиков, которые располагаются в непосредственной близости от оригинала. Это позволяет обойтись без системы зеркал и линз, а следовательно, снизить цену сканера. Однако качество изображений, считанных с использованием этих устройств, пока довольно низкое.
В процессе считывания двухмерного изображения сканирующая головка движется относительно оригинала, а следовательно, неотъемлемой частью большинства сканеров является механизм, обеспечивающий их взаимное перемещение. Исходя из его наличия и конструкции различают следующие типы сканеров.


§ 23. - Ручные сканеры.

Эти устройства являются самыми простыми и дешевыми в своем классе. В их конструкции отсутствуют сложные прецизионные механизмы:

  • пользователь сам двигает сканер по поверхности оригинала.
  • практически все ручные сканеры — небольшого размера, и поэтому позволяют считывать изображения шириной до 10 см. С другой стороны, нет ограничений на высоту оригинала, а поставляемое вместе с устройством программное обеспечение позволяет вводить картинки, ширина которых больше, чем область захвата сканирующей головки. Для этого придется сделать несколько проходов, а затем «склеить» полученные таким образом части изображения в одно целое.
Ручные сканеры обладают серьезным недостатком. Пользователь не может двигать устройство строго равномерно и прямолинейно, что необходимо для качественного сканирования. Поэтому, чтобы получить приемлемый результат, нужны твердая рука и постоянные тренировки. Но даже в этом случае при вводе изображений с помощью ручного сканера неизбежно возникают искажения.
Раньше, когда настольные сканеры стоили тысячу и больше долларов, их «ручные собратья» были очень популярными. Однако в последнее время цены на настольные, модели упали, и вследствие этого спрос на ручные сканеры уменьшился. Сегодня их покупают, в основном, пользователи, сильно ограниченные в средствах. Однако у этих устройств есть одно преимущество: они компактны и могут с успехом применяться для ввода информации в портативные компьютеры. С ними можно работать в библиотеке, архиве или в любом другом месте.


§ 24. - Листовые сканеры.

По принципу действия эти устройства напоминают факс-аппарат. Считываемая страница с помощью специального механизма протягивается мимо головки. Протяжный сканер может оснащаться лотком для автоматической подачи листов, что существенно увеличивает скорость ввода многостраничных документов. Качество сканирования у этих устройств, как правило, невысокое, главным образом из-за того, что при протягивании листа бумаги очень трудно добиться его равномерного движения без перекосов.
Протяжные сканеры занимают немного места на рабочем столе и стоят довольно дешево. Кроме того, они очень часто комбинируются с другими периферийными устройствами. В качестве примера можно упомянуть дополнительный модуль для ввода изображений, которым оснащается принтер Hewlett-Packard LaserJet 1100A. Сконструирована даже клавиатура, в которую встроен малоформатный сканер. И наконец, протяжные сканеры очень часто входят в состав комбинированных периферийных устройств, выполняющих также функции принтера, копира, факс-аппарата и (в некоторых случаях) модема.
Серьезным недостатком протяжных сканеров является то, что с их помощью можно сканировать только отдельные листы. Чтобы ввести таким образом страницу из журнала, его придется расшить или разорвать. А вот считать изображение с негнущегося носителя (например, картона) протяжным сканером нельзя вообще.


§ 25. - Слайд - сканеры.

Для качественного считывания изображений со слайдов существуют специальные сканеры. Поскольку они работают с оригиналами небольшого размера, а полученные изображения в дальнейшем приходится многократно увеличивать, у этих устройств очень качественные оптика и электроника, а в роли светочувствительного элемента применяется двухмерная матрица ПЗС (как в цифровых видеокамерах). Эти устройства, как правило, намного дороже обычных планшетных или протяжных сканеров. Слайд-сканеры по внешнему виду обычно напоминают планшетные, но меньше по размерам. В некоторых моделях предусмотрен специальный выдвижной лоток со стеклянной подложкой, на которую помещают слайды.


§ 26. - Барабанные сканеры.

До появления и распространения настольных сканеров с приемлемым качеством эти устройства практически повсеместно использовались для ввода изображений при допечатной подготовке изданий. Барабанные сканеры и по сегодняшний день дороги и сложны в использовании, но они незаменимы там, где нужно сканировать графику для высококачественной цветной печати.
В качестве светочувствительного элемента в барабанных сканерах используется фотоэлектронный умножитель. Он располагается внутри полого стеклянного цилиндра, на поверхность которого накладывается оригинал. В ходе сканирования цилиндр вращается, вокруг своей оси, Сегодня барабанные сканеры обеспечивают самое высокое качество сканирования. Их преимущество заключается в том, что фотоэлектронные умножители очень чувствительны к незначительным изменениям яркости и, следовательно, позволяют различать большее количество оттенков, особенно в области очень темных и, наоборот, очень светлых тонов. Но хотя цены на эти устройства в последнее время значительно снизились, они все равно остаются дорогими по сравнению с планшетными и, тем более, протяжными сканерами. Однако на сегодняшний день характеристики лучших ПЗС не намного хуже, чем у ФЭУ, а следовательно, новые профессиональные планшетные сканеры обеспечивают практически такое же качество сканирования, как и барабанные.


§ 27. - Планшеные сканеры.

Устройства этого типа напоминают копировальные аппараты: считываемый документ располагается на поверхности стеклянной пластины, под которой перемещается сканирующая головка.
Такие сканеры являются универсальными, поскольку с их помощью можно вводить как отдельные листы, так и книги, журналы и даже изображения небольших трехмерных объектов. Они также могут комплектоваться дополнительным устройством для автоматической подачи бумаги, которое устанавливается вместо крышки. В этом случае вы сможете быстро сканировать большое количество страниц, правда, только отдельных.
Планшетные сканеры рассчитаны на ввод изображений с непрозрачных оригиналов. Для этого сканируемый документ подсвечивается снизу лампой, а сверху накрывается крышкой, дополнительно отражающей и рассеивающей свет. Однако считать таким образом изображения со слайдов, рентгеновских снимков и других прозрачных оригиналов не удастся, поскольку эти материалы нужно рассматривать, а значит, и сканировать в проходящем свете. Для работы с такими оригиналами планшетный сканер оснащают специальной приставкой, которая устанавливается вместо крышки и содержит дополнительный источник света.


§ 28. - Цветное сканирование.

Все светочувствительные приборы, применяемые в сканерах, измеряют только яркость попадающего на них света, но не его спектральные характеристики, по которым человеческий глаз различает цвета. Поэтому для ввода в компьютер цветных изображений пришлось дополнительно доработать конструкцию сканера.
Согласно законам физики любой оттенок может быть составлен из трех основных цветов — красного, синего и зеленого. Поэтому, если в заданной точке измерить яркость всех трех составляющих, можно однозначно определить и ее цвет.
В первых цветных планшетных сканерах использовался трехпроходный метод сканирования. В этом случае изображение считывалось трижды, причем при каждом проходе измерялись значения только одной из трех основных цветовых составляющих, для чего использовались либо сменные светофильтры на обычной лампе белого света, либо три цветные лампы (трехламповое сканирование).
Недостатком трехпроходного метода была низкая скорость работы — в три раза меньше по сравнению с черно-белым сканированием. Кроме того, необходимость наложения друг на друга трех отдельно полученных изображений приводила к ошибкам и искажениям. Альтернативой этому методу является однопроходное сканирование. В оптическую систему сканера добавили призму, разлагающую отраженный от сканируемой картинки белый свет на спектральные составляющие. В сканирующей головке предусмотрены три отдельные линейки ПЗС, расположенные таким образом, чтобы на каждую из них попадал световой пучок только одного из трех основных цветов — синего, красного или зеленого. Главным препятствием на пути к широкому распространению сканеров, работающих по такому принципу, была высокая стоимость ПЗС, но по мере снижения цен на эти чипы однопроходные сканеры практически повсеместно вытеснили трехпроходные.
В современных сканерах используются также усовершенствованные матрицы приборов с зарядовой связью, получившие название цветных ПЗС. Такая микросхема содержит три линейки светочувствительных элементов, каждый из которых оснащен встроенным светофильтром. При использовании цветных ПЗС отпадает необходимость в призме и сложной системе раздельного фокусирования световых пучков. В итоге сканирующая головка получается более компактной и дешевой.


§ 29. - Параметры сканеров.

Чтобы определить свойства той или иной модели сканера, в первую очередь рассматривают ее технические параметры. Производители сканеров при описании своих изделий зачастую приводят очень большое количество разных характеристик, но возможности устройства определяют, в основном, следующие параметры:

  • разрешающая способность.
  • глубина цвета.
  • размер области сканирования.
  • быстродействие и способ подключения.
Разрешающая способность, или разрешение — это количество точек, которые сканер может различить на отрезке единичной длины. Эту величину измеряют в точках на дюйм (dots per inch — dpi). Однако при оценке разрешающей способности сканера следует учитывать два следующих фактора.
Во-первых, разрешение сканера почти всегда определяют не одной, а двумя величинами — в горизонтальном (по ширине листа документа) и вертикальном (по высоте) направлениях. Разрешение по ширине определяется свойствами чипа ПЗС. а именно, количеством светочувствительных элементов в линейке. В вертикальном направление (по ходу движения головки) разрешающая способное зависит от шага ее перемещения и равна количеству позиций, которые может занимать сканирующая головка на отрезке длиной в 1 дюйм.
Соответственно, полное разрешение сканера обозначается двумя числами, например 600х600 dpi, причем эти значения не обязательно должны быть одинаковыми. До недавних пор в большинстве моделей шаг головки выбирался таким образом, чтобы разрешение по горизонтали и вертикали было одинаковым. Однако в последнее время многие разработчики используют в своих изделиях прецизионные механизмы, позволяющие увеличить количество возможных позиций сканирующей головки на единичном отрезке. В этих сканерах вертикальное разрешение больше, чем горизонтальное, например 300х600 dpi- Но если отсканировать картинку с такими параметрами, она, естественно, будет растянута по вертикали. Во избежание этого при сканировании либо отказываются от уменьшения шага головки (в таком случае устройства с разрешением 300х600 dpi работают в режиме 300х300 dpi), либо прибегают к специальной дополнительной обработке рисунка.
Описанные выше значения обеспечиваются реальными физическими характеристиками считывающей системы сканера. Поэтому их называют оптическим разрешением. Этот параметр для современных домашних планшетных сканеров в большинстве случаев равен 300х300 или 300х600 dpi. Для дальнейшего повышения разрешающей способности сканера можно продолжать совершенствовать оптику и механику устройства (что приводит к существенному повышению его цены) или же воспользоваться одним из методов программного увеличения разрешения.
Программные алгоритмы повышения разрешающей способности сканера работают по следующему принципу. Между точками, реально считанными оптической системой устройства, программа вставляет дополнительные, цвет которых рассчитывается на основе значений оттенков их ближайших «соседей». Полученное таким образом новое разрешение называют интерполированным. Оно может превышать оптическое во много раз. Например, сканер, работающий с максимальным оптическим разрешением 300х300 dpi, может передавать в графическую программу изображения с интерполированным разрешением 600х600 dpi и выше, однако при этом их качество существенно снижается — картинки становятся слегка размытыми.
Технология интерполяции недостающих точек нашла применение и при обработке картинок, отсканированных с неодинаковым разрешением по ширине и высоте. Допустим, сканер считывает картинку с разрешением 300 dpi по горизонтали и 600 dpi по вертикали. При ее обработке программа самостоятельно достраивает точки, которых недостает в рядах. Однако в этом случае таких «выдуманных» точек гораздо меньше, чем при обычной интерполяции. Поэтому качество полученной таким образом картинки хотя и ниже, чем при сканировании с высоким оптическим разрешением, но выше, чем после интерполяции точек в рядах и столбцах.

[Предыдущий §]


Часть I - Теория.

Глава I - "Дисплей" § 1. Параметры монитора;
§ 2. Эргономические характеристики;
§ 3. Плоские дисплеи;
§ 4. Интерфейсы дисплеев.
Глава II - "Клавиатура" | § 5. Клавиатура.
Глава III - "Манипуляторы" § 6. MSMouse и PCMouse;
§ 7. Мышь PS/2;
§ 8. Мышь BusMouse.
Глава IV - "Принтеры и плоттеры" § 9. Буквопечатающие;
§ 10. Матричные, игольчатые;
§ 11. Термопринтеры;
§ 12. Струйные;
§ 13. Лазерные;
§ 14. Плоттеры.
Глава V - "Игровые устройства" | § 15. Джостик, руль, педали.
Глава VI - "Комуникационные устройства" § 16. Com-порт;
§ 17. Инфракрасный порт IrDA;
§ 18. Радиоинтерфейс Bluetooth;
§ 19. Модемы и факс-модемы;
§ 20. Технология xDSL и кабельные модемы.
Глава VII - "Аудиосистема ПК" | § 21. Аудиосистема;
Глава VIII - "Сканер" § 22. Сканеры;
§ 23. Ручные сканеры;
§ 24. Листовые сканеры;
§ 25. Слайд - сканеры;
§ 26. Барабанные сканеры;
§ 27. Планшетные сканеры;
§ 28. Цветное сканирование;
§ 29. Параметры сканеров.