Варианты заданий

Практические задания

Задание 1. База данных «Абитуриент»

Постановка задачи. В данном варианте задания необходимо создать базу данных, в которой решались бы следующие задачи:

  • ввод, хранение и поиск информации об абитуриентах;
  • регистрация основных данных о вузах, предпочитаемых абитуриентами;
  • ведение учета оплаты абитуриентами подготовительных курсов;
  • отслеживание результатов поступления и посещения занятий после поступления.

Порядок выполнения задачи.

1. Создание базы данных. В меню Файл выберите команду Создать и из списка шаблонов на закладке Общие выберите шаблон «База данных». Сохраните создаваемую БД под именем Абитуриент.mdb.

2. С помощью конструктора создайте следующие таблицы.

Таблица: тАбитуриенты

Имя Тип Размер
КодАб Счетчик 4
Фамилия Текстовый 15
Имя Текстовый 15
Отчество Текстовый 1
Паспорт Текстовый 15
Индекс Длинное целое 4
Город Текстовый 15
Адрес Текстовый 20
Средний балл Одинарное с плавающей 4
Фото Поле объекта OLE -
Примечания Поле МЕМО -

Таблица: тАттестат

Имя Тип Размер
КодАб Длинное целое 4
Русский Длинное целое 4
Математика Длинное целое 4
Физика Длинное целое 4

Таблица: тВУЗы

Имя Тип Размер
КодВУЗа Счетчик 4
НазваниеВУЗа Текстовый 50
Индекс Длинное целое 4
Город Текстовый 20
Улица Текстовый 15
Телефон Текстовый 15
Рейтинг Длинное целое 4
Сочинение Одинарное с плавающей 4
Математика Длинное целое 4
Физика Длинное целое 4
ПроцПринятых Целое 2
Проверка Логический 1
Дата Дата/время 8

Таблица: тОплатаОбучения

Имя Тип Размер
КодОплаты Счетчик 4
КодАб Длинное целое 4
ДатаОплаты Дата/время 8
СуммаОплаты Денежный 8

Таблица: тСвязьАбВУЗ

Имя Тип Размер
КодАб Длинное целое 4
КодВУЗа Длинное целое 4
СтатусПоступления Логический 1
СтатусПосещения Логический 1

3. Создайте следующую схему данных:

4. Выполните подстановку поля КодАб из таблицы тАбитуриент в таблицы тСвязьАбВУЗ, тОплатаОбучения, тАттестат. Например, откройте таблицу тАттестат в режиме конструктора, выделите поле КодАб, перейдите на вкладку Подстановка и укажите свойства поля, показанные на рисунке:

Аналогично выполните подстановку поля КодВУЗа из таблицы тВУЗы в таблицу тСвязьАбВУЗы.

5. Заполните таблицы данными, введя в каждую из них не менее пяти строк. Например, первые две строки таблицы тАбитуриенты:

КодАб

Фамилия

Имя

Отчество

Паспорт

Индекс

Город

Адрес

Средний балл

Фото
Примечания

1

Иванов

Иван

И

V-АБ

308000

Белгород

4,60

2

Петров

Петр

П

VI-КА

309040

Ст.Оскол

4,30

…

…

…

…

…

…

…

…

…

…

…

6. Постройте запрос на выборку имен и фамилий тех абитуриентов, которые имеют средний балл от 4 до 5:

7. С помощью следующего запроса выведите фамилии тех абитуриентов, которые проживают или в Белгороде, или в Москве:

8. Постройте многотабличный запрос для вывода списка фамилий абитуриентов и названий тех вузов, в которые они собираются поступать:

9. С помощью следующего запроса выведите фамилии тех абитуриентов, которые пока не определились с выбором вуза (без предпочтений):

10. Примером создания вычисляемого поля в запросе может служить следующий запрос, в котором подсчитайте средний балл оценок аттестатов абитуриентов:

11. Постройте итоговый запрос для определения суммы оплаты каждым абитуриентом за подготовительные курсы в 2001 году:

12. С помощью мастера построения перекрестных запросов постройте перекрестный запрос, выводящий следующую таблицу:

Фамилия | Итого | Янв | Фев | Мар | Апр
Иванов | 300р. | 100р. | 200р. |  |
Петров | 300р. |  | 200р. | 100р. |
Сидоров | 300р. |  |  |  | 300р.

13. Создайте форму для ввода данных в таблицу тАбитуриенты:.

14. Создайте форму для ввода информации по вузам:

15. Создайте форму, состоящую из двух связанных форм, для ведения учета оплаты абитуриентами занятий на подготовительных курсах:

16. Создайте ленточную форму для изменения статуса абитуриентов:

17. Создайте форму для просмотра предпочтений абитуриентов:

18. Создайте отчеты, включающие списки абитуриентов и вузов.

19. Создайте итоговый отчет по оплате абитуриентами подготовительных курсов:

20. Создайте макрос для вывода информационного сообщения о назначении программы:

21. Создайте главную форму с набором командных кнопок и назначьте каждой кнопке макрос, выполняющий открытие нужной формы или отчета:.


Задание 2. База данных «Торговая организация»

Постановка задачи. Построить базу данных, содержащую информацию о товарах, имеющихся на складе, о клиентах, выполняющих заказы и покупки, о сотрудниках фирмы. Необходимо предусмотреть возможность выборки информации по различным критериям, создать формы для ввода информации и отчеты для подготовки печатных документов.

Порядок выполнения задачи.

1. Создание базы данных. В меню Файл выберите команду Создать и из списка шаблонов на закладке Общие выберите шаблон «База данных». Сохраните создаваемую БД под именем Торг_орг.mdb.

2. С помощью конструктора создайте следующие таблицы: тКлиенты, содержащую информацию о клиентах (поля: КодКлиента, Фамилия); тТовары, содержащую информацию по товарам (поля: КодТовара, Наименование, Цена, НаСкладе) и тЗаказы (поля: КодЗаказа, КодКлиента, КодТовара, Количество, ДатаПокупки).

3. Свяжите таблицы в следующую схему данных:

4. Выполните подстановку поля КодКлиента из таблицы тКлиенты в поле КодКлиента таблицы тЗаказы и поля КодТовара таблицы тТовары в поле КодТовара таблицы тЗаказы.

5. Заполните таблицы данными, введя в каждую из них не менее пяти строк. Примерное содержимое таблиц тКлиенты и тТовары:

КодКлиента | Фамилия | КодТовара | Наименование | Цена | НаСкладе
1 | Иванов | 1 | Компьютер | 10 000р. | 10
2 | Петров | 2 | Принтер | 5 000р. | 5
3 | Сидоров | 3 | Модем | 2 000р. | 3
… | … | … | … | … | …

Примерное содержимое таблицы тЗаказы:

КодЗаказа | КодКлиента | КодТовара | Количество | Дата покупки
1 | 1 | 1 | 2 | 20.01.01
2 | 2 | 1 | 3 | 02.03.01
3 | 2 | 2 | 1 | 02.06.02
… | … | … | … | …

6. Создайте запрос зЗаказы, который выводит список клиентов с названиями заказанных товаров и с датами покупки.

7. Создайте запрос зПокупки2000, выводящий список клиентов, сделавших покупки в 2000 году.

8. Создайте запрос зКлиентыБезЗаказов, выводящий список клиентов, не сделавших ни одного заказа.

9. Создайте запрос зСтоимость для просмотра общей стоимости каждого товара на складе (цена* на складе).

10. Создайте запрос зПокупки, результатом которого стала бы таблица тПокупки, содержащая информацию о фамилии клиента, наименовании, цене и количестве купленного им товара, а также дате приобретения и общей заплаченной сумме.

11. На основе запроса зПокупки создайте перекрестный запрос зСуммаПоГодам, который выводил бы информацию следующего вида:

Фамилия | Итоговое значение | 2001 | 2002
Иванов | 20 000р. | 20 000р. |
Петров | 35 000р. | 35 000р. |
Сидоров | 9 000р. |  | 9 000р.

12. Создайте запрос на удаление из таблицы тЗаказы записей, относящихся к 1999 году.

13. Изменить структуру тКлиенты, добавив новые поля: Организация, Адрес, Телефон, Факс, Заметки.

14. Создайте новую таблицу тСотрудники:

Код

ТабНомер

Фамилия

Имя

Отчество

Адрес

Должность

Фотография

1

1011

Иванов

Иван

Иванович

ул. Костюкова, 46

Методист

Точечный рис

2

1012

Петров

Петр

Петрович

ул. Костюкова, 46

Методист

Точечный рис

3

1013

Николаев

Николай

Николаевич

ул. Костюкова, 46

Методист

Точечный рис

15. Создайте запрос, который выводит фамилии клиентов и количество сделанных ими заказов.

16. Измените запрос зЗаказы, добавив поля "Цена", "Количество" и вычисляемое поле "Стоимость":

17. Создайте форму фСотрудники:

18. Создайте форму фТовары для ввода информации по товарам:.

19. Создайте форму с заголовком Заказы, в которой выводилась бы фамилия клиента, количество заказанных товаров и дата покупки.

20. Создайте диаграмму Цены на товары. По оси X расположить названия товаров, а по оси Y – цены.

21. Создайте ленточный отчет с заголовком Товары на складе об имеющихся на складе товарах, их цене, количестве и общей стоимости.

22. Создайте отчет в столбец отСотрудники.

23. Создайте итоговый отчет о покупках, сделанных клиентами, на основе запроса зЗаказы:

24. Создайте макросы для запуска форм и отчетов и закрепите их за кнопками главной кнопочной формы следующего вида:


Задание 3. База данных «Банк»

Постановка задачи. В базе данных «Банк» должна храниться информация о вкладах населения как в рублях, так и в валюте. Каждый вклад имеет свой срок хранения и начальный взнос по разным вкладам различен. Также банк может предоставлять различные кредиты – в рублях и в валюте.

Порядок выполнения задачи.

1. Создание базы данных. В меню Файл выберите команду Создать и из списка шаблонов на закладке Общие выберите шаблон «База данных». Сохраните создаваемую БД под именем Банк.mdb.

2. С помощью конструктора создайте следующие таблицы: тКлиенты, содержащую информацию о клиентах (поля: КодКлиента, Фамилия, Имя, Отчество, Паспорт, Гражданство, Индекс, Страна, Город, Адрес); тВклады, содержащую информацию о рублевых и валютных вкладах (поля: КодВклада, КодКлиента, НомерСчета, ТипСчета, ВидВклада, СуммаВклада, ДатаНачала, ДатаЗавершения) и тКредиты (поля: КодКредита, КодКлиента, ВидКредита, СуммаКредита, ТипВалюты, ДатаВыдачи, ДатаВозврата).

3. Свяжите таблицы в следующую схему данных:

4. Выполните подстановку поля КодКлиента из таблицы тКлиенты в поля КодКлиента таблиц тВклады и тКредиты.

5. Заполните таблицы данными, введя в каждую из них не менее пяти строк.

6. С помощью запроса на выборку выведите список иностранных клиентов банка.

7. Создайте запрос для выборки только тех клиентов, которые имеют вклады в валюте.

8. Преобразуйте предыдущий запрос так, чтобы выводился список тех клиентов, которые имеют рублевые вклады.

9. Выведите список тех клиентов, которые открыли вклады и взяли кредит в 2002 году.

10. Создайте запрос на создание таблицы тЗакрытыеВклады, в которую выведите список клиентов, закрывших свои счета к текущему периоду.

11. Удалите из таблицы тКлиенты тех клиентов, которые не имеют открытых вкладов и не взяли кредита.

12. Проведите деноминацию всех вкладов, уменьшив суммы в 10 раз.

13. Вычислите ежемесячную выплату процентов по кредитам.

14. Создайте форму в столбец для ввода персональной информации по клиентам.

15. Создайте ленточную форму для просмотра информации по вкладам и кредитам.

16. Создайте отчет для вывода персональной информации о клиентах.

17. Создайте итоговый отчет по всем вкладам и кредитам, используемым клиентами банка.

18. Создайте макросы для запуска форм и отчетов и закрепите их за кнопками главной кнопочной формы.


Задание 4. База данных «Страны Европы»

Постановка задачи. Создайте базу данных, содержащую сведения о странах Европы. В базу включить следующие пункты: страна, столица, население, площадь, сведения об экономике, основные экономические показатели. В базе данных должны храниться географические карты стран Европы. Также необходимо организовать хранение списка важнейших исторических событий XX века с указанием даты и страны, в которой это событие произошло.

Порядок выполнения задачи.

1. Создание базы данных. В меню Файл выберите команду Создать и из списка шаблонов на закладке Общие выберите шаблон «База данных». Сохраните создаваемую БД под именем СтраныЕвропы.mdb.

2. С помощью конструктора создайте следующие таблицы: тСтраны, содержащую информацию о странах Европы (поля: КодСтраны, Название, Столица, Население, Площадь, Карта); тСобытия, содержащую информацию об исторических событиях, произошедших в странах Европы (поля: КодСобытия, КодСтраны, Событие, Дата) и тЭкономика (поля: КодСтраны, ВНП, ДоходНаДушу, НазваниеВалюты).

3. Свяжите таблицы в схему данных таким образом, чтобы между таблицами тСтраны и тСобытия были отношения «один-ко-многим», а между тСтраны и тЭкономика отношения «один-ко-одному»:

4. Выполните подстановку поля КодСтраны из таблицы тСтраны в поля КодСтраны таблиц тСобытия и тЭкономика.

5. Заполните таблицы данными, введя в каждую из них не менее пяти записей.

6. С помощью запроса на выборку выведите список стран, чье население более 1 млн чел. Список отсортируйте по алфавиту.

7. С помощью запроса на выборку выведите список стран, площадь которых больше 300 тыс. км2. Список отсортируйте по алфавиту.

8. Выведите названия исторических событий, произошедших в Европе за последние 10 лет.

9. Выведите список тех государств, в наименовании валют которых присутствует слово «доллар» или «франк».

10. Создайте запрос на создание таблицы тСобытияВРоссии, в которую запишите список всех событий, произошедших в России за ХХ век.

11. Вычислите процент дохода на душу населения к валовому национальному продукту (ВНП).

12. Переведите ВНП из национальной валюты в доллары по текущему курсу.

13. Выведите список тех стран, для которых в таблице тСобытия не определено ни одного исторического события.

14. Создайте форму в столбец для ввода информации о странах Европы.

15. Создайте ленточную форму для заполнения информации об исторических событиях, произошедших в странах Европы.

16. Создайте отчет для вывода полной информации о странах.

17. Создайте отчет, который выводил бы название страны и список исторических событий, связанных со страной (группировка по полю Название таблицы тСтраны).

18. Создайте главную кнопочную форму.

19. Напишите макросы для запуска форм и отчетов и закрепите их за кнопками главной кнопочной формы.


Задание 5. База данных «Библиотека»

Постановка задачи. Создайте базу данных, позволяющую автоматизировать работу библиотеки. В базе необходимо хранить информацию о читателях библиотеки, датах выдачи и возврате читателями книг, список книг в фондах библиотеки, стоимость и количество экземпляров каждой книги .

Порядок выполнения задачи.

1. Создайте базу данных. В меню Файл выберите команду Создать и из списка шаблонов на закладке Общие выберите шаблон «База данных». Сохраните создаваемую БД под именем Библиотека.mdb.

2. С помощью конструктора создайте следующие таблицы: тЧитатели, содержащую информацию о читателях библиотеки(поля: КодЧитателя, ФИО, Паспорт, Город, Адрес, Телефон); тКниги, содержащую информацию о книгах (поля: КодКниги, Автор, Название, Жанр, Год издания, Издательство, Цена); тЭкземпляр, содержащую информацию о каждом экземпляре книги (поля: КодЭкземпляра, КодКниги, Местонахождение) и тВыдача (поля: КодЧитателя, КодЭкземпляра, Дата взятия, Дата возврата).

3. Свяжите таблицы в схему данных, представленную на рисунке:

4. Выполните подстановку поля КодЧитателя из таблицы тЧитатели в поле КодЧитателя таблицы тВыдача, а также подстановку КодКниги из таблицы тКниги в одноименное поле таблицы тЭкземпляр.

5. Заполните таблицы данными, введя в каждую из них не менее пяти записей.

6. С помощью запроса на выборку выведите список читателей, которые имеют «на руках» книги.

7. С помощью запроса на выборку выведите список читателей, которые имеют «на руках» более одной книги.

8. Выведите названия тех книг, которые имеются только в одном экземпляре.

9. Выведите названия тех книг, которые находятся в читальном зале.

10. Найдите минимальный и максимальный сроки пользования книгами читателями библиотеки.

11. Выведите список тех читателей, которые не взяли ни одной книги за последний год.

12. С помощью запроса на создание таблицы организуйте новую таблицу тСтарыеКниги, в которую запишите список тех книг, которые изданы более 30 лет назад.

13. Подсчитайте общую стоимость книг, хранящихся в библиотеке.

14. На основе таблицы тВыдача создайте перекрестный запрос. Значения заголовков столбцов и заголовков строк задайте по вашему усмотрению.

15. Создайте форму в столбец для ввода информации о читателях библиотеки.

16. Создайте форму в столбец для ввода информации о книгах.

17. Создайте ленточную форму для заполнения информации о выдаче и возврате книг.

18. Создайте отчет для вывода полной информации о читателях.

19. Создайте отчет, который выводил бы названия книг, сгруппированных по жанрам.

20. Создайте главную кнопочную форму.

21. Напишите макросы для запуска форм и отчетов и закрепите их за кнопками главной кнопочной формы.


Задание 6. База данных «Цементные заводы»

Постановка задачи. Разработать базу данных по технологическим замерам на цементных заводах для формирования данных о продуктах производства заводов, а также для расчетов дополнительных значений параметров продуктов. Требуется организовать хранение следующих категорий технологических замеров на цементных заводах: газовый анализ, параметры печи, химия сырья, учет информации по техническим характеристикам цементных заводов. Создать интерфейс, удобный для работы, включающий удобные и понятные формы, отчеты. Организовать работу с таблицами, поиск по ним, формирование и печать отчетов.

Порядок выполнения задачи.

1. Создайте базу данных. В меню Файл выберите команду Создать и из списка шаблонов на закладке Общие выберите шаблон «База данных». Сохраните создаваемую БД под именем Цементные_заводы.mdb.

2. С помощью конструктора создайте следующие таблицы: тЗаводы, содержащую информацию о цементных заводах (поля: КодЗавода, Название, Телефон, Тип Топлива); тПечь, содержащую информацию о печах обжига и выполненных замерах (поля: КодЗамера, КодЗавода, КолОборотов, ДлинаПечи, ДиаметрПечи, ДавлениеСтатическое, ДавлениеДинамическое, ДатаЗамера, ВремяЗамера); тГазовыйАнализ, содержащую информацию о замерах параметров газа (поля: КодЗамера, КодЗавода, СО2, СО, О2, ДатаЗамера, ВремяЗамера) и тХимияСырья (поля: КодСырья, КодЗавода, НазваниеСырья, ДатаАнализа, SiO2, Al2O3, Fe2O3).

3. Создайте схему данных, представленную на рисунке:

4. Выполните подстановку поля КодЗавода из таблицы тПечь в одноименные поля таблицы тПечь, тГазовыйАнализ и тХимияСырья.

5. Заполните таблицы данными, введя в каждую из них не менее пяти записей. Примерное содержимое таблицы тЗаводы (поле КодЗавода не приводится):

Примерное содержимое таблицы тХимияСырья:

6. С помощью запроса на выборку выведите список тех заводов, в которых газовый анализ и анализ химии сырья проводились в 2000 году.

7. Выведите список тех заводов, у которых одним из видов сырья является мел или известняк.

8. Выведите список тех заводов, которые в качестве топлива используют газ.

9. Выведите названия заводов и параметры печей при условии, если диаметр печи больше двух метров.

10. Выведите название заводов, дату и время газового замера, если суммарные показатели газа превосходят определенную величину (задается оператором).

11. Выведите координаты тех заводов, которые провели замеры параметров печи, газовый анализ и анализ химии сырья в один день.

12. Подсчитайте разницу между динамическим и статическим давлением в печи.

13. Выведите параметры тех печей, время замера которых было больше заданной оператором величины.

14. Создайте сводную таблицу тВсеПараметры, в которую запишите данные из всех четырех таблиц.

15. Создайте форму в столбец для ввода информации о заводах.

16. Создайте главную форму с информацией о заводах и подчиненную форму с информацией о печах.

17. Создайте ленточную форму для заполнения информации о газовом анализе.

18. Создайте отчет для вывода сводной информации по заводам и измеряемым параметрам.

19. Создайте ленточный отчет, который выводил бы названия заводов и параметры печей.

20. Создайте главную кнопочную форму.

21. Напишите макросы для запуска форм и отчетов и закрепите их за кнопками главной кнопочной формы.


Задание 7. База данных «Служба занятости»

Постановка задачи. Разработать систему, обеспечивающую ведение базы данных по безработным, вакансиям, выплатам, предприятиям. База данных должна содержать информацию о предприятиях, готовых предоставить рабочее место по специальности или имеющих вакансии, полную информацию о безработном, его предпочтения, а также дату постановки безработного на учет в службе занятости и пособие, которое будет ему выплачиваться. Создать интерфейс, удобный для работы, включающий удобные и понятные формы, отчеты. Организовать работу с таблицами, поиск по ним, формирование и печать отчетов.

Порядок выполнения задачи.

1. Создайте базу данных. В меню Файл выберите команду Создать и из списка шаблонов на закладке Общие выберите шаблон «База данных». Сохраните создаваемую БД под именем Служба_занятости.mdb.

2. С помощью конструктора создайте следующие таблицы: тПредприятия, содержащую информацию о предприятиях (поля: КодПредприятия, Наименование, Адрес, Телефон, Руководитель); тБезработные, содержащую информацию о безработных (поля: КодБезработного, ФИО, Адрес, Телефон, СемейноеПоложение, Образование, Стаж); тПособия, содержащую информацию о размерах пособия и дополнительных выплатах по льготам (поля: КодПособия, КодБезработного, РазмерВыплаты, ДопВыплаты, ДатаПостановки); предпочтения безработных хранятся в таблице тПредпочтения (поля: КодБезработного, КодПредприятия, КодСпециальности); справочная информация о вакансиях и специальностях хранится в таблицах тВакансии (поля: КодВакансии, КодСпециальности, КодПредприятия, Зарплата) и тСпециальности (поля: КодСпециальности, Наименование).

3. Свяжите таблицы в схему данных, показанную на рисунке. Проанализируйте данную схему и определите между какими таблицами установлены отношения «многие-ко-многим».

4. Выполните подстановку поля КодПредприятия из таблицы тПредприятия в одноименные поля таблиц тВакансии и тПредпочтения. Выполните подстановку поля КодБезработного из таблицы тБезработные в одноименные поля таблиц тПособие и тПредпочтения.

5. Заполните таблицы данными, введя в каждую из них не менее пяти записей.

6. С помощью запроса на выборку выведите список тех предприятий, которые имеют вакансии с зарплатой более 1 000 руб.

7. Выведите список тех предприятий, которые не имеют на текущий момент вакансий.

8. Выведите фамилии и телефоны тех безработных, которые имеют высшее образование.

9. Сделайте выборку тех безработных, чей стаж составляет более 5 лет.

10. Выведите данные по тем безработным, которые имеют максимальный размер пособия и были поставлены на учет в 2002 году.

11. Постройте запрос, формирующий полные данные о предпочтениях безработных, с указанием названия специальностей и предприятий.

12. Подсчитайте сумму всех выплачиваемых пособий и дополнительных выплат за один год.

13. Выведите фамилии тех руководителей предприятий, которые имеют более 3 вакансий.

14. Создайте перекрестную таблицу на основе данных о фамилиях безработных, датах постановки на учет и размерах пособий.

15. Создайте две формы в столбец для ввода информации о предприятиях и о безработных.

16. Создайте главную форму с информацией о безработных и подчиненную форму с информацией об их предпочтениях.

17. Создайте ленточную форму для заполнения информации о вакансиях.

18. Создайте отчет для вывода сводной информации по предприятиям и имеющимся у них вакансиям.

19. Создайте ленточный отчет, который выводил бы данные по безработным, выплачиваемым пособиям и предпочтениях.

20. Создайте главную кнопочную форму.

21. Напишите макросы для запуска форм и отчетов и закрепите их за кнопками главной кнопочной формы.


Задание 8. База данных «Железнодорожный вокзал»

Постановка задачи. Разработать систему, обеспечивающую ведение базы данных по поездам, расписанию движения поездов, пассажирах и билетах. База данных должна содержать информацию о времени прибытия и отправки поездов, тип поезда, пунктах отправления и прибытия. Для автоматизации процесса выдачи билета необходимо хранить Ф.И.О. и паспортные данные пассажира, а также размер льгот. Кроме того, в билете указывается номер вагона, номер места, место отправления и место прибытия и дата получения билета. Создать интерфейс, удобный для работы, включающий удобные и понятные формы, отчеты. Организовать работу с таблицами, поиск по ним, формирование и печать отчетов.

Порядок выполнения задачи.

1. Создайте базу данных. В меню Файл выберите команду Создать и из списка шаблонов на закладке Общие выберите шаблон «База данных». Сохраните создаваемую БД под именем ЖДВокзал.mdb.

2. С помощью конструктора создайте следующие таблицы: тПассажиры, содержащую информацию о пассажирах (поля: КодПассажира, ФИО, Паспорт, Льгота); тПоезда, содержащую информацию о поездах (поля: КодПоезда, Остановка, ВремяПриб, ВремяОтпр, ВремяСтоянки, Наценка); тБилеты, содержащую информацию о продаваемых билетах (поля: КодБилета, КодПассажира, КодПоезда, НомерВагона, НомерМеста, Откуда, Куда, Дата); расписание движения поездов хранится в таблице тРасписание (поля: КодРасписания, КодПоезда, ТипПоезда, ПунктОтпр, ПунктПриб, Период).

3. Свяжите таблицы в схему данных, показанную на рисунке

4. Выполните подстановку поля КодПоезда из таблицы тПоезда в одноименные поля таблиц тБилеты и тРасписание и подстановку поля КодПассажира из таблицы тПассажиры в одноименное поле таблицы тБилеты.

5. Заполните таблицы данными, введя в каждую из них не менее пяти записей.

6. С помощью запроса на выборку выведите список пассажиров, имеющих льготы.

7. С помощью запроса выведите список тех поездов, которые останавливаются в Белгороде.

8. С помощью запроса на выборку выведите список пассажиров, купивших билеты в первом квартале текущего года.

9. Выведите полную информацию о тех пассажирах, которые купили билеты на поезд, останавливающийся в Воронеже 7-го числа текущего месяца.

10. Выведите информацию о тех поездах, время следования в пути которых превышает одни сутки.

11. С помощью запроса выведите информацию о тех поездах, которые не включены в расписание движения.

12. Подсчитайте общую сумму льгот пассажиров, купивших билеты в текущем месяце.

13. С помощью запроса создайте сводную таблицу, в которую занесите прошлогодние данные о пассажирах, билетах и поездах.

14. На основе данных таблиц тПассажиры и тБилеты постройте перекрестный запрос.

15. Создайте две формы в столбец для ввода информации о пассажирах и поездах.

16. Создайте главную форму с информацией о поездах и подчиненную форму с информацией о расписании движения поездов.

17. Создайте ленточную форму для заполнения информации о продаваемых билетах.

18. Создайте отчеты для вывода сводной информации по пассажирам и поездам.

19. Создайте ленточный отчет, который выводил бы информацию о продаваемых билетах.

20. Создайте главную кнопочную форму.

21. Напишите макросы для запуска форм и отчетов и закрепите их за кнопками главной кнопочной формы.


Введение

Microsoft Access обладает всеми чертами классической системы управления базами данных (СУБД). Access – это не только мощная, гибкая и простая в использовании СУБД, но и система для разработки приложений баз данных. К числу наиболее мощных средств Access относятся средства разработки объектов – мастера, которые можно использовать для создания таблиц, запросов, различных типов форм и отчетов. В Microsoft Access включены мастера, помогающие производить анализ структуры данных, импортировать электронные таблицы и текстовые данные, повышать быстродействие приложения, создавать и настраивать одно из более, чем двадцати типов приложений с использованием встроенных шаблонов. Чтобы полностью автоматизировать работу приложения, можно использовать макросы для связывания данных с формами и отчетами. Большинство приложений можно создать, не написав ни единой строки программного кода. Однако при необходимости построения действительно сложного приложения можно использовать язык программирования – Visual Basic для приложений.

К областям применения Microsoft Access можно отнести следующие:

  • в малом бизнесе (бухгалтерский учет, ввод заказов, ведение информации о клиентах, ведение информации о деловых контактах);
  • в работе по контракту (разработка внутриотраслевых приложений, разработка межотраслевых приложений);
  • в крупных корпорациях (приложения для рабочих групп, системы обработки информации);
  • в качестве персональной СУБД (справочник по адресам, ведение инвестиционного портфеля, поваренная книга, каталоги книг, пластинок, видеофильмов и т. п.).

Рассмотрим основные определения, связанные с разработкой баз данных. Краткий словарь терминов приведен в приложении 1.

База данных (БД, data base, DB) – совокупность взаимосвязанных данных, используемых под управлением СУБД.

В самом общем смысле база данных – это набор записей и файлов, организованных специальным образом.

Система управления базой данных (СУБД, DBMS) – программная система, обеспечивающая определение физической и логической структуры базы данных, ввод информации и доступ к ней.

Возможности СУБД: система управления базами данных предоставляет возможность контролировать задание структуры и описание данных, работу с ними и организацию коллективного пользования информацией. СУБД также существенно увеличивает возможности и облегчает каталогизацию и ведение больших объемов хранящейся в многочисленных таблицах информации. СУБД включает в себя три основных типа функций: определение (задание структуры и описание) данных, обработки данных и управление данными.

Основные функции СУБД следующие:

Определение данных. Определяется, какая именно информация будет храниться в базе данных, задается структура данных и их тип (например, количество цифр или символов), а также указывается то, как данные будут связаны между собой. Задаются форматы и критерии проверки данных.

Обработка данных. Данные можно обрабатывать самыми различными способами. Можно выбирать любые поля, фильтровать и сортировать данные. Можно объединять данные с другой связанной информацией и вычислять итоговые значения.

Управление данными. Указываются правила доступа к данным, их корректировки и добавления новой информации. Можно также определить правила коллективного пользования данными.


6.1. Модели организации баз данных

1. Иерархический подход к организации баз данных. Иерархические базы данных имеют форму деревьев с дугами-связями и узлами-элементами данных. Иерархическая структура предполагала неравноправие между данными – одни жестко подчинены другим. Подобные структуры, безусловно, четко удовлетворяют требованиям многих, но далеко не всех реальных задач.

2. Сетевая модель данных. В сетевых БД наряду с вертикальными реализованы и горизонтальные связи. Однако унаследованы многие недостатки иерархической и главный из них, необходимость четко определять на физическом уровне связи данных и столь же четко следовать этой структуре связей при запросах к базе.

3. Реляционная модель. Реляционная модель появилась вследствие стремления сделать базу данных как можно более гибкой. Данная модель предоставила простой и эффективный механизм поддержания связей данных.

Во-первых, все данные в модели представляются в виде таблиц и только таблиц. Реляционная модель – единственная из всех обеспечивает единообразие представления данных. И сущности, и связи этих самых сущностей представляются в модели совершенно одинаково – таблицами. Правда, такой подход усложняет понимание смысла хранящейся в базе данных информации, и, как следствие, манипулирование этой информацией.

Избежать трудностей манипулирования позволяет второй элемент модели – реляционно-полный язык (отметим, что язык является неотъемлемой частью любой модели данных, без него модель не существует). Полнота языка в приложении к реляционной модели означает, что он должен выполнять любую операцию реляционной алгебры или реляционного исчисления (полнота последних доказана математически Э.Ф. Коддом). Более того, язык должен описывать любой запрос в виде операций с таблицами, а не с их строками. Одним из таких языков является SQL.

Третий элемент реляционной модели требует от реляционной модели поддержания некоторых ограничений целостности. Одно из таких ограничений утверждает, что каждая строка в таблице должна иметь некий уникальный идентификатор, называемый первичным ключом. Второе ограничение накладывается на целостность ссылок между таблицами. Оно утверждает, что атрибуты таблицы, ссылающиеся на первичные ключи других таблиц, должны иметь одно из значений этих первичных ключей.

4. Объектно-ориентированная модель. Новые области использования вычислительной техники, такие как научные исследования, автоматизированное проектирование и автоматизация учреждений, потребовали от баз данных способности хранить и обрабатывать новые объекты – текст, аудио- и видеоинформацию, а также документы. Основные трудности объектно-ориентированного моделирования данных проистекают из того, что такого развитого математического аппарата, на который могла бы опираться общая объектно-ориентированная модель данных, не существует. В большой степени поэтому до сих пор нет базовой объектно-ориентированной модели. С другой стороны, некоторые авторы утверждают, что общая объектно-ориентированная модель данных в классическом смысле и не может быть определена по причине непригодности классического понятия модели данных к парадигме объектной ориентированности. Несмотря на преимущества объектно-ориентированных систем – реализация сложных типов данных, связь с языками программирования и т.п. – на ближайшее время превосходство реляционных СУБД гарантировано.


6.2. Основные этапы разработки приложения

Основы методологии проектирования прикладных программ были заложены в 60-е годы XX века известными специалистами Дж. Мартином, Э. Йордоном и Д. Константайном. На заре применения вычислительной техники разработка программ, поиск и устранение ошибок были настолько дорогостоящими, что опытные программисты-практики часто советовали: прежде чем написать хоть одну строку программы, стоит потратить не менее 60% всего необходимого для разработки времени на проектирование.

Современные технологии разработки прикладных программ делают построение приложений фантастически дешевым и быстрым. Квалифицированный пользователь с помощью Microsoft Access сегодня может за один вечер создать на персональном компьютере то, что на ранних ЭВМ требовало месяцев работы (если это вообще было возможным). Кроме того, сейчас стало значительно легче находить ошибки, устранять их и видоизменять проект в процессе создания приложения. Современные технологии позволяют создавать очень сложные приложения. К тому же скорость вычислений по сравнению даже с предыдущим десятилетием возросла на несколько порядков. Однако несмотря на мощность средств, если вы не потратите значительных усилий на определение задач и принципов работы приложения, то впоследствии вам придется потерять значительно больше времени на всевозможные переделки. Если проект приложения недостаточно продуман, то добавление новых функций или устранение недостатков будет связано с большими временными и финансовыми затратами.

Рассмотрим основные этапы разработки приложения.

Этап 1. Уточнение задач

На первом этапе составляется список всех основных задач, которые в принципе должны решаться этим приложением, – включая и те, которые не нужны сегодня, но могут появиться в будущем. Под «основными» задачами понимаются функции, которые должны быть представлены в формах или отчетах приложения.

Этап 2. Последовательность выполнения задач

Для того, чтобы приложение работало логично и удобно, лучше всего объединить основные задачи в тематические группы и затем упорядочить задачи каждой группы так, чтобы они располагались в порядке их выполнения. Может получиться так, что некоторые задачи будут связаны с разными группами или, что выполнение некоторой задачи должно предшествовать выполнению другой, принадлежащей к иной группе.

Этап 3. Анализ данных

После формирования списка задач, наиболее важным этапом является составление подробного перечня всех данных, необходимых для решения каждой задачи. Некоторые данные понадобятся в качестве исходных и меняться не будут. Другие данные будут проверяться и изменяться в ходе выполнения задачи. Некоторые элементы данных могут быть удалены или добавлены. И наконец, некоторые данные будут получены с помощью вычислений: их вывод будет частью задачи, но в базу данных вноситься они не будут.

Этап 4. Определение структуры данных

После предварительного анализа всех необходимых элементов данных нужно упорядочить их по объектам и соотнести объекты с таблицами и запросами базы данных. Для реляционных баз данных типа Access используется процесс, называемый нормализацией, в результате которого вырабатывается наиболее эффективный и гибкий способ хранения данных.

Этап 5. Разработка макета приложения и пользовательского интерфейса

После задания структуры таблиц приложения, в Microsoft Access легко создать его макет с помощью форм и связать их между собой, используя несложные макросы или процедуры обработки событий. Предварительный рабочий макет легко продемонстрировать заказчику и получить его одобрение еще до детальной реализации задач приложения.

Этап 6. Создание приложения

В случае очень простых задач созданный макет является практически законченным приложением. Однако довольно часто приходится писать процедуры, позволяющие полностью автоматизировать решение всех намеченных в проекте задач. Поэтому, понадобится создать специальные связующие формы, которые обеспечивают переход от одной задачи к другой.

Этап 7. Тестирование и усовершенствование

После завершения работ по отдельным компонентам приложения необходимо проверить функционирование приложения в каждом из возможных режимов. Необходимо проверить работу макросов, использовав пошаговый режим отладки, при котором будет выполняться одна конкретная макрокоманда. При использовании Visual Basic для приложений в вашем распоряжении имеются разнообразные средства отладки, позволяющие проверить работу приложения, выявить и исправить ошибки.

По мере разработки автономных разделов приложения желательно передать их заказчику для проверки их функционирования и получения мнения о необходимости внесения тех или иных изменений. После того как заказчик ознакомится с работой приложения, у него практически всегда возникают дополнительные предложения по усовершенствованию, какой бы тщательной не была предварительная проработка проекта. Пользователи часто обнаруживают, что некоторые моменты, о которых в процессе постановки задач они говорили как об очень важных и необходимых, на самом деле не играют существенной роли при практическом использовании приложения. Выявление необходимых изменений на ранних стадиях разработки приложения позволяет существенно сократить время на последующие переделки.


6.3. Стратегия разработки приложения

При разработке приложений СУБД используются два подхода: проектирование сверху вниз, при котором разработка приложения начинается с определения основных функций и задач, и проектирование снизу вверх, при котором сначала проводится анализ данных и определение их структуры.

Сначала определяются задачи и выполняется их группировка (подход «сверху вниз»). Так как базы данных должны привязываться к решению определенных, связанных между собой групп задач или функций, то для каждой задачи определяется набор необходимых данных. Затем для связанных задач собираются все поля данных и начинается процесс формирования объектов (элементы подхода «снизу вверх»). Данные каждого объекта являются основой для включения в базу данных отдельной таблицы.

Данные и информация

Понимание различия между данными и информацией облегчит выявление сведений, которые необходимо хранить в базе данных. Это различие состоит в том, что данные – это статические значения, хранящиеся в таблицах базы данных, в то время как информация – это сведения, которые запрашиваются пользователем и представляются ему в наиболее удобном виде. Другими словами, данные хранятся, а информация запрашивается. Отличие данных от информации надо учитывать при разработке проекта приложения. Сначала вы определяете задачи (какую информацию можно будет запрашивать и получать), а затем выясняете, что нужно хранить в базе данных для выполнения этих задач (какие данные нужны для получения и представления требуемой информации). Когда вы ссылаетесь на элементы, хранимые в таблицах, запросах, макросах или процедурах, или работаете с ними, вы имеете дело с данными. Аналогично, когда вы работаете с наборами записей запросов, фильтрами, формами или отчетами, вы имеете дело с информацией.

Отбор необходимых данных

После определения задач нужно составить для каждой из них описание данных, необходимых для ее решения. Каждый элемент данных, по характеру его использования, может быть классифицирован одним из следующих признаков: входной, выходной, изменяемый, удаляемый и вычисляемый.

Элемент данных является входным, если для выполнения задачи его необходимо прочитать в базе данных (без изменения). Например, имя и адрес клиента являются входными данными для заполнения заказа.

Подобным образом данные являются выходными для задачи, если в этой задаче они вводятся или вычисляются на основе входных данных, а затем сохраняются. Например, адрес и телефон нового студента являются выходными для задачи ввода данных о студентах.

Данные в задаче изменяются, если они читаются в базе данных, а затем изменяются и записываются обратно. Например, задача обновления адреса студента получает старый адрес студента, изменяет его и сохраняет в базе данных новый.

Соответственно, задача удаляет данные, когда они убираются из базы данных.

И наконец, вычисляемыми данными являются новые значения, получаемые на основе входных данных, которые отображаются на экране или печатаются, но не сохраняются в базе данных.

Нормализация

Для устранения дублирующихся данных используется процесс, называемый нормализацией. Он позволяет организовать поля данных в группы таблиц. Лежащая в основе нормализации математическая теория довольно сложна, но для практического применения ее можно сформулировать в виде довольно простых правил.

Правило 1. Уникальность полей

Неэффективное использование памяти является основным недостатком ненормализованных таблиц, поэтому удаление избыточных полей из таблиц является одним из решений этой проблемы.

Правило 1: Каждое поле любой таблицы должно быть уникальным.

Этого можно достичь созданием отдельных таблиц для повторяющихся данных и установлением связей между новыми таблицами и исходной. Хотя дублируются данные в связующем поле в каждой из таблиц, общий объем хранимых данных значительно сокращается.

Правило 2. Первичные ключи

База данных хорошо спроектирована тогда, когда каждая запись в любой таблице является уникальной. Это означает, что значение некоторого поля (или нескольких полей) не повторяется ни в одной записи в таблице. Такой идентификатор называется первичным ключом (или просто ключом).

Правило 2: Каждая таблица должна иметь уникальный идентификатор, или первичный ключ, который может состоять из одного или нескольких полей.

Если вы создаете таблицу в базе данных, то Access всегда предлагает определить для нее первичный ключ. Вы можете также предоставить Access возможность создать искусственный первичный ключ. В таком случае Access добавляет к каждой записи поле, в которое записывается содержимое счетчика записей. При добавлении новой записи содержимое счетчика увеличивается на единицу.

Правило 3. Функциональная зависимость

Если вы определили для каждой таблицы первичный ключ, то можно проверить, включены ли в таблицы все сведения, относящиеся к соответствующим объектам. Кроме того, следует убедиться, что каждое поле функционально зависит от первичного ключа таблицы.

Правило 3: Для каждого значения первичного ключа значения в столбцах данных должны относиться к объекту таблицы и полностью его описывать.

Это правило используется двояко. Во-первых, в таблице не должно быть данных, не относящихся к объекту, определяемому первичным ключом. Во-вторых, данные в таблице должны полностью описывать объект.

Правило 4. Независимость полей

И наконец, последнее правило позволяет проверить, не возникнут ли у вас проблемы при изменении данных в таблицах.

Правило 4: Изменение значений любого поля (не входящего в первичный ключ) должно выполняться без воздействия на данные других полей.

Чужие ключи

Если при создании новой таблицы в существующую таблицу включается поле, связывающее старую и новую таблицы, то это «связующее» поле называется чужим ключом или внешним ключом.

В хорошо спроектированной базе данных использование чужих ключей обеспечивает эффективность работы приложения. В процессе проектирования нужно внимательно следить за созданием чужих ключей. Задаваемые при создании таблиц в Microsoft Access связи первичных ключей с чужими ключами используются для объединения данных из нескольких таблиц.


6.4. Архитектура Microsoft Access

Microsoft Access называет объектами все, что может иметь имя (в смысле Access). В базе данных Access основными объектами являются таблицы, запросы, формы, отчеты, макросы и модули. В других СУБД, как правило, термин база данных обычно относится только к файлам, в которых хранятся данные. В Microsoft Access база данных включает в себя все объекты, связанные с хранимыми данными, в том числе и те, которые определяются для автоматизации работы с ними. Ниже приведен список основных объектов базы данных Access.

1. Таблица. Объект, который определяется и используется для хранения данных. Каждая таблица включает информацию об объекте определенного типа, например о клиентах. Таблица содержит поля (столбцы), в которых хранятся различного рода данные, например фамилия или адрес клиента, и записи (которые называются также строками). В записи собрана вся информация о некотором объекте (человеке, образце продукции и т.п.). Для каждой таблицы можно определить первичный ключ (одно или несколько полей, содержащих уникальные для каждой записи значения) и один или несколько индексов, помогающих ускорить доступ к данным.

2. Запрос. Объект, который позволяет пользователю получить нужные данные из одной или нескольких таблиц. Для создания запроса можно использовать бланк QBE (запрос по образцу) или инструкции SQL (структурированный язык запросов). Можно создать запросы на выборку, обновление, удаление или добавление данных. С помощью запросов можно также создавать новые таблицы, используя данные из одной или нескольких существующих таблиц.

3. Форма. Объект, предназначенный в основном для ввода данных, отображения их на экране или управления работой приложения. Формы используются для того, чтобы реализовать требования пользователя к представлению данных из запросов или таблиц. Формы можно также распечатать. С помощью формы можно в ответ на некоторое событие, например изменение значения определенных данных, запустить макрос или процедуру VBA.

4. Отчет. Объект, предназначенный для создания документа, который впоследствии может быть распечатан или включен в документ другого приложения.

5. Макрос. Объект, представляющий собой структурированное описание одного или нескольких действий, которые должен выполнить Access в ответ на определенное событие. Например, можно определить макрос, который в ответ на выбор некоторого элемента в основной форме открывает другую форму. С помощью другого макроса можно осуществлять проверку значения некоторого поля при изменении его содержимого. В макрос можно включить дополнительные условия для выполнения или невыполнения тех или иных указанных в нем действий. Из одного макроса можно также запустить другой макрос или процедуру VBA.

6. Модуль. Объект, содержащий программы, написанные на языке Visual Basic для приложений. Модули могут быть независимыми объектами, содержащими функции, вызываемые из любого места приложения, но они могут быть и непосредственно «привязаны» к отдельным формам или отчетам для реакции на те или иные происходящие в них изменения.

Концептуальные взаимосвязи объектов Access показаны на рис. 6.1.

Рис. 6. 1. Взаимосвязи основных объектов в Microsoft Access

В таблицах хранятся данные, которые вы можете извлекать с помощью запросов. Используя формы, вы можете выводить данные на экран или изменять их. Заметим, что формы и отчеты получают данные как непосредственно из таблиц, так и через запросы. Для выполнения нужных вычислений и преобразования данных запросы могут использовать встроенные функции или функции, созданные с помощью Visual Basic для приложений. События, происходящие в формах или отчетах, могут запускать макросы или процедуры VBA.

Событие – любое изменение состояния объекта Microsoft Access. Например, событием является открытие формы, закрытие формы, ввод новой строки в форму, изменение содержимого текущей записи или элемента управления (объекта формы или отчета, который может содержать данные). Для обработки события вы можете создать макрос или процедуру Visual Basic для приложений.

С помощью макросов и модулей вы можете изменять ход выполнения приложения; открывать, фильтровать и изменять данные в формах и отчетах; выполнять запросы и создавать новые таблицы. Используя Visual Basic для приложений, вы можете создать, модифицировать и удалить любой объект Access, обрабатывать данные по строкам или по столбцам, а также каким-либо другим способом. Вы можете даже вызывать процедуры из библиотек динамической компоновки (DLL) Microsoft Windows, чтобы использовать в своем приложении не только встроенные в Access функции, но и возможности Windows.


6.5. Создание базы данных

В Microsoft Access поддерживаются два способа создания базы данных. Имеется возможность создать пустую базу данных, а затем добавить в нее таблицы, формы, отчеты и другие объекты. Такой способ является наиболее гибким, но требует отдельного определения каждого элемента базы данных. Имеется также возможность сразу создать с помощью мастера базу данных определенного типа со всеми необходимыми таблицами, формами и отчетами. Это простейший способ начального создания базы данных.

Для создания пустой базы данных выберите команду Файл–>Создать (кнопка [image] ), а затем в окне диалога Создание щелкните дважды по значку Новая база данных. После этого откроется окно диалога Файл новой базы данных. В раскрывающемся списке Папка выберите нужный диск и папку, например, диск С:, папка Мои документы. После этого в поле Имя файла введите имя новой базы данных. Access автоматически добавит к имени файла расширение .MDB . Теперь остается только нажать на кнопку Создать и на экране появится окно базы данных, представленное на рис. 6.2.

Рис. 6.2. Окно пустой базы данных

Создание новой пустой таблицы

В Microsoft Access существуют четыре способа создания пустой таблицы:

1. Мастер по созданию базы данных позволяет создать сразу все таблицы, формы и отчеты в базе данных. Этот мастер создает новую базу данных; его нельзя использовать для добавления новых таблиц, форм или отчетов в существующую базу данных.

2. Мастер по созданию таблицы позволяет выбрать поля, включаемые в таблицу, из широкого списка образцов полей разных типов, предназначенных для сохранения данных о деловых контактах, для ведения домашнего хозяйства или для регистрации медицинской информации.

3. Пользователь имеет возможность самостоятельно ввести данные в пустую таблицу в режиме таблицы. При сохранении новой таблицы Microsoft Access проанализирует данные и автоматически присвоит соответствующий тип данных и формат каждому полю.

4. В режиме конструктора можно непосредственно указать параметры всех элементов структуры таблицы.

Вне зависимости от способа создания таблицы режим конструктора позволяет в любой момент изменить структуру таблицы, например, добавить новые поля, указать значения по умолчанию или создать маски ввода.

Для примера определим таблицу тВУЗы для базы данных «Профконсультант средней школы». Перейдите на вкладку Таблицы и нажмите кнопку Создать. В окне диалога Новая таблица выберите Конструктор и нажмите кнопку Ok. Access выведет окно пустой таблицы в режиме конструктора. На рис. 3 показана таблица тВУЗы в режиме таблицы с уже определенными полями.

Рис. 6.3. Окно таблицы тВУЗы в режиме конструктора

В верхней части окна расположены столбцы, в которые вводятся имя, тип данных и краткое описание каждого поля. После выбора типа данных для поля в левой нижней части окна таблицы можно задать свойства поля. В правой нижней секции окна выводится краткая информация о полях или свойствах. При работе с полем определенного типа вкладка свойств Общие принимает соответствующий формат. Рассмотрим типы полей и их свойства.


Типы данных

Текстовый формат

Размер текстового поля может находиться в пределах от 1 до 255 символов.

Формат поля используется в формах и запросах. Существует набор специальных символов формата, которые жестко задают вид и размер вводимых строк.

Кодовые символы формата текстовых полей представлены ниже:

@ – должен быть текстовый символ или пробел; & – текстовый символ; < – преобразование символов в нижний регистр; > – преобразование символов в верхний регистр.

Формат поля может состоять из двух частей, разделенных знаком «точка с запятой». Первая часть является собственно форматом ввода, а вторая – определяет значение поля, если данные в него не были введены.

Маска ввода также представляет собой последовательность кодовых символов:

0 – должна быть цифра от 0 до 9; 9 - цифра или пробел; # – цифра, пробел, плюс или минус; L – должна быть буква (A...Z, А...Я); ? – буква; А – должна быть буква или цифра; а – может быть буква или цифра; & – должен быть любой символ или пробел; С – произвольный символ; : ; - / – разделители, которые сохраняют свой вид в строке данных; < – преобразование символов в нижний регистр; > – преобразование символов в верхний регистр; ! – маска должна заполняться справа налево; \ – ввод следующего за обратной косой чертой символа как символьной константы.

Кодовые символы 0, А, L, & предполагают обязательный ввод данных в поле. Поскольку некоторые виды данных (даты, время, телефонные номера) содержат стандартные разделители, то для упрощения ввода предусмотрено, что некоторые общепринятые символы-разделители воспринимаются в маске ввода «буквально», то есть записываются в поле наряду с введенными данными. Кроме того, для определения символьных констант, состоящих из нескольких символов, допускается использовать двойные кавычки. В отличие от символов формата, символы маски ввода являются общими для всех типов полей, в которых разрешено применение маски. Пароль – создание поля для ввода пароля, вводимые символы не отображаются.

Подпись – это второй (первый – Имя) идентификатор поля, который используется программой вместо имени поля при работе с данными в табличной форме для создания заголовка столбца. Видимо, подпись полезна тем, что она может быть более информативной и естественной, чем имя поля.

Свойство «значение по умолчанию» говорит само за себя. Если при вводе данных часто повторяется одно и то же значение (в данном случае текстовая строка), то целесообразно «попросить» программу автоматически подставлять заданное значение во все вновь создаваемые поля. Пользователь же в процессе работы решает, оставить поле как есть или изменить данные. Это может сэкономить время при вводе, но может быть и причиной дополнительных ошибок, если оператор забудет стереть ненужные значения поля. С этим свойством связана процедура Построитель выражений для облегчения формирования значения поля. Процедура вызывается нажатием кнопки [image], которая появляется после щелчка в строке «Значение по умолчанию».

Свойство «условие на значение» позволяет создать фильтр, который разрешит вводить в данное поле только то, что удовлетворяет определенному условию. Для задания такого критерия можно запустить Построитель выражений. Если же оператор БД нарушит условие ввода, то программа сообщит ему об этом, выведя на экран текст, определенный, как свойство «сообщение об ошибке».

При задании условия на значение используются следующие операторы сравнения:

< | Меньше
<= | Меньше или равно
> | Больше
>= | Больше или равно
= | Равно
<> | He равно
IN | Проверяет на равенство любому значению из списка; операндом является список, заключенный в круглые скобки
BETWEEN | Проверяет, что значение поля находится в заданном диапазоне; верхняя и нижняя границы диапазона разделяются логическим оператором AND
LIKE | Проверяет соответствие текстового или Мемо поля заданному шаблону символов

Примеры задания простых условий на значение для полей: Is Null Or >0 And <800– проверяет, является ли поле пустым (Is Null) или же введенное значение лежит в диапазоне от 0 до 800; >50 And <100или BETWEEN 50 And 100 – данные два условия идентичны и проверяют числовое значение на попадание в интервал от 50 до 100; In («Белгород», «Москва», «Los Angeles»)– с помощью оператора IN можно выполнить множественное сравнение; #15.01.94#– если в качестве операнда используется дата, то она должна быть заключена в символы числа (#); LIKE «*товар##*»– данное условие используется для нахождения строк, содержащих подстроку товар и две произвольные цифры.

Свойство «обязательное поле» является логическим. Оно может принимать одно из двух значений: Да или Нет, которые выбираются из списка, связанного со строкой данного свойства. Да означает, что в поле обязательно должны быть введены данные.

Свойство «пустые строки» тоже логическое и похоже на предыдущее. Оно определяет, разрешены или нет в данном поле пустые строки. Для Access существуют два разных понятия: «поле, в которое ничего не было введено» и «поле с пустой строкой, то есть содержащее пробелы». Реляционные базы данных обеспечивают возможность хранения в полях таблиц специального значения Null, называемого пустым значением, которое обозначает некоторое неизвестное значение. Пустое значение имеет особые свойства. Так, пустое значение не может быть равно никакому другому значению, в том числе другому пустому значению. Это означает, что нельзя объединить (связать) две таблицы по значению Null. Условие "А = В", где А или В содержит Null, всегда будет ложным. Наконец, пустые значения не учитываются в итоговых функциях, таких как Sum (Сумма) или Avg (Среднее значение). Вы можете лишь проверить наличие значения Null, сравнив значения поля со специальной константой NULL или используя встроенную функцию IsNull. С другой стороны, вы можете установить значение текстового или Мемо поля равным пустой строке (""), и это будет означать, что значение поля известно, но поле пустое. Вы можете соединять таблицы по пустым строкам. При сравнении пустые строки считаются равными друг другу. Чтобы разрешить пользователю ввод пустых строк в текстовые и Мемо поля, вам следует установить для свойства Пустые строки значение Да. Если вы этого не сделаете, Access преобразует введенные пользователем пустые строки, а также строки, состоящие из пробелов, в строки, содержащие значение Null. Если при этом свойство Обязательное поле для текстового поля установлено как Да, то Access сохраняет пустую строку в качестве значения, когда пользователь вводит "" или строку, состоящую только из пробелов.

Свойство «индексированное поле» может иметь одно из трех значений: или поле не индексировано, или индексировано, но допускаются повторяющиеся значения, или индексировано, и повторения значений поля запрещены.

Разумеется, при конструировании базы данных нет необходимости задавать все свойства полей. Но, чтобы полностью использовать потенциал Access, вы должны при работе с программой держать «в уме» возможность применения того или иного свойства.

Свойство «сжатие Юникод». В Microsoft Access 2000 для хранения информации полей типа «Текстовый», «Поле MEMO» и «Гиперссылка» используется кодировка Юникод (Unicode). В Юникод каждый символ представляется двумя байтами, а не одним, как в традиционных кодировках. В результате для хранения данных полей типа «Текстовый», «Поле MEMO» и «Гиперссылка» требуется больше места, чем в предыдущих версиях Access.

Этот эффект использования кодировки Юникод можно сгладить, установив свойство Сжатие Юникод (Unicode Compression) поля в значение Да. При создании полей типа «Текстовый», «Поле MEMO» и «Гиперссылка» это значение свойства устанавливается по умолчанию. Когда свойство Сжатие Юникод поля имеет значение Да, все символы, первый байт которых равен 0, будут сжиматься при сохранении и восстанавливаться при выборке. Если первый байт отдельного символа не равен нулю, этот символ не будет сжиматься.

Числовой формат

Числовые поля обладают, в основном, теми же свойствами, что и текстовые, за некоторыми отличиями. Тип числового поля может принимать значения из следующего списка:

Байт – целые числа в пределах от 0 до 255;
Целое – целые числа от –32768 до 32767;
Длинное целое – целые числа от -2147483648 до 2147483647;
С плавающей точкой (4 байт) – числа в пределах от –3.402823ЕЗ8 до 3.402823ЕЗ8;
С плавающей точкой (8 байт) – числа в пределах от –1.79769313486232ЕЗ08 до 1.79769313486232ЕЗ08;
Код репликации – глобально уникальный идентификатор (GUID) длиной 16 байт.

Формат числового поля может определяться следующими кодовыми символами:

. – точка используется в качестве десятичного разделителя;
, – запятая применяется как разделитель групп разрядов;
0 – вывод цифры или нуля, если разряд незначащий; # – вывод цифры;
$ – знак доллара; % – вывод числа в процентном формате;
Е или е – вывод числа в экспоненциальной форме.

При создании числового формата могут быть заданы четыре группы кодов:
первая – для вывода положительных чисел, вторая – для отрицательных значений, третья – для представления нулевого значения, четвертая – для пустых полей.

Группы разделяются знаком «точка с запятой». Основой для определения числового формата может служить следующая конструкция: # ##0,00

В этом формате указано не только расположение обязательных и факультативных разрядов, но и отмечено, что в числе должно проводиться разделение групп разрядов пробелами. Так, например, число 123456,789 в этом формате выглядело бы следующим образом: 123 456,78

В формате можно задавать и цвет выводимых символов. Допустим, надо представить значения температуры так, чтобы величины больше нуля были красного цвета, а меньше нуля – синего. В этом случае формат может быть таким:

#[Красный]; -#[Синий]; 0[Зеленый]; 'Нет данных"

Как можно использовать последнюю, четвертую группу формата? Во-первых, можно создать фразу-напоминание (Введи число!), которая покажет, что в некоторой ячейке отсутствуют данные, которые на самом деле должны там быть. Во-вторых, используя четвертую группу формата, можно из числового поля сделать «как бы текстовое», то есть позволить программе заполнять ячейку неким текстом при отсутствии числовых данных.

Формат «дата/время»

Для типа данных Дата/Время существует набор форматов поля, приведенный ниже вместе с примерами:

Полный формат (устанавливается по умолчанию) | 15.04.94 05:30:10 РМ
Длинный формат даты | Среда 15 Апрель 1994
Средний формат даты | 15-апр-94
Краткий формат даты | 15.04.94
Длинный формат времени | 17:30:10
Средний формат времени | 05:30 РМ
Краткий формат времени | 17:30

Денежный формат

По умолчанию денежный формат представляет собой числа, записанные с двумя знаками после запятой, с разделением групп разрядов и обозначением «р.» в конце. Пользователь может записать в строке Формат поля шаблон для своего формата. Допустим, необходимо вводить суммы в долларах. Тогда надо установить курсор на слово Денежный и заменить его шаблоном формата, например, таким: # ###$.

Этот формат предполагает, что сумма записана как целое число, с разделением групп из трех разрядов пробелами (чтобы легче было отличать единицы от тысяч, а тысячи от миллионов) и знаком доллара в конце числа, как принято в России, но не в США.

Формат «счетчик»

Поля типа «счетчик» выполняют определенную функцию – автоматическую идентификацию записей таблицы. Поэтому свойств, которые можно было бы изменить, у такого поля немного. Во-первых, счетчик – это всегда число. Во-вторых, наращивание его значения происходит автоматически. Access предлагает два варианта изменения счетчика: последовательный и случайный. Первый вариант удобен тем, что позволяет нумеровать записи. Второй вариант можно использовать, если надо создать систему кодирования записей в таблице, защищенную от неосторожных действий оператора. Если нумеровать записи последовательно (1, 2, 3, и т. д.), то опечатка при вводе может легко превратить один код в другой, и обнаружить такую ошибку будет трудно. Иначе обстоит дело, если коды выбираются случайным образом (например, 1193517479, 442230790, 1742918387, и т. д.). Поскольку случайные значения счетчика представляют собой многоразрядные числа, то вероятность того, что один код будет введен вместо другого, меньше, чем в первом случае. Кроме того, имея список всех кодов, легко проверить сколь угодно большую таблицу на наличие опечаток. Остается добавить, что использовать этот прием можно, если заменить в дальнейшем тип «счетчик» на другой, потому что изменять данные в поле счетчика оператор не может.

Логический формат

Ячейка в поле логического типа может содержать только одно из двух значений: Да или Нет. Access предлагает еще два варианта названий логического типа: Истина/Ложь и Включено/Выключено. Вне зависимости от того, какой формат поля вы изберете, в таблице логическое поле будет представлено в виде набора флажков. Когда вы щелкаете флажок мышью, это приводит к тому, что в квадрате появляется изображение галочки, что соответствует логическому значению Да ( [image]). Сброс флажка означает присвоение ячейке поля логического значения Нет. Использование логических полей может быть самым различным, например, в анкетах или для создания элементов управления.

Поле объекта OLE

Поле объекта OLE (Object Linking and Embedding) – последний выбираемый из списка тип поля. Он имеет всего два свойства: подпись и параметр «обязательное поле». Поля данного типа не хранят информацию как таковую, а содержат ссылки на объекты, которые могут быть включены в БД с использованием OLE-протокола обмена данными. Такими объектами могут быть, например, графические файлы. Даже самая лучшая СУБД не в состоянии обеспечить хранение всех существующих на сегодняшний день видов представления информации. Да это и не нужно. Достаточно осуществить связь с приложением, работающим с тем или иным типом файлов. Для этого и существует протокол OLE.

Для того чтобы внедрить в ячейку поля OLE-объект, надо установить на нее курсор и, нажав правую кнопку мыши, вызвать контекстное меню. В нем выберите команду Вставить объект. Программа раскроет окно диалога для выбора типа объекта. Объект в данном случае отождествляется с приложением, в котором он может быть создан или отредактирован. В том случае, когда в этом окне установлен переключатель Создать новый, открывается соответствующее приложение, работа с которым несколько отличается от обычной. Так, пользователь не имеет возможности открыть существующий файл для того, чтобы сделать его объектом. Например, если выбран документ Word и готовый документ уже имеется на диске, то его придется открыть в редакторе отдельно, скопировать в буфер обмена, а затем перейти в окно документа, связанного с Access, и вставить содержимое буфера. Если же объект создается, что называется, «с нуля», то работа в выбранном приложении происходит обычным образом. Команда выхода из приложения тоже видоизменяется. В данном случае уже нельзя, закрыв приложение, оказаться в Windows, а можно только вернуться в Access.

Второй вариант вставки объекта – выбор переключателя Создать из файла в окне Вставка объекта. В этом случае подразумевается, что файл уже существует, и нужно установить с ним связь. Access откроет окно открытия документа и после выбора нужного файла определит, какое приложение необходимо открыть для работы с ним. Необходимо иметь в виду, что одному типу файлов могут соответствовать несколько приложений. Например, файлы с расширением ВМР используются разными графическими редакторами. Выбранное Access приложение запускается, и в нем открывается выбранный пользователем файл. Внедрение объекта заканчивается после того, как вы закрываете программу.

Свойства на вкладке подстановка

Тип элемента управления задает тип элемента управления, используемого по умолчанию для отображения данного поля в формах, отчетах и объектах в режиме таблицы. Для большинства полей устанавливается тип Поле.

Тип источника строк. Если для свойства Тип элемента управления установлено значение Список или Поле со списком, это свойство позволяет задать тип источника данных для элемента управления: Таблица/запрос, Список значений или Список полей.

Источник строк. Если для свойства Тип источника строк установлено значение Таблица/запрос, указывается таблица или запрос, из которого поступают значения для списка. Если источником данных служит список значений, вводятся через точку с запятой значения для списка.

Присоединенный столбец. Значение указанного столбца списка используется в качестве значения элемента управления. Если источник данных содержит один столбец, то свойства Присоединенный столбец равно 1.

Число столбцов, выводящихся в списке или в раскрывающемся списке поля со списком.

Заглавия столбцов. При установке значения Да значения свойства Подпись, заданные в источнике данных, выводятся в качестве заголовков столбцов списка.

Ширина столбцов. Задаются значения для ширины столбцов, разделенные точкой с запятой. Если вы не хотите выводить некоторый столбец, укажите для него ширину, равную 0.

Число строк списка. Если элементом управления является поле со списком, это свойство определяет число строк, выводимых в списке.

Ширина списка. Определяет ширину раскрывающегося списка для поля со списком. Значением по умолчанию является Авто, при котором ширина раскрывающегося списка равна ширине самого элемента управления.

Ограничиться списком. При установке значения Да в поле можно ввести только значения, представленные в списке. Чтобы иметь возможность вводить произвольные значения, установите для данного свойства значение Нет. Замечание: Если вы не выводите значения присоединенного столбца в первом столбце списка, то поле со списком ведет себя так, будто для свойства Ограничиться списком установлено значение Да.

Гиперссылка

Текст или комбинация текста и чисел, используемая как адрес гиперссылки.

Адрес – это текст, задающий путь и имя файла для открываемого документа. Путь может представлять собой путь к файлу, записанному на жестком диске, являться адресом в формате UNC или адресом URL в Интернете.

Для вставки адреса в поле можно использовать команду Гиперссылка в меню Вставка.


Импорт данных. Импорт текстового файла

Одним из основных преимуществ Microsoft Access является возможность работы с самыми разнообразными данными других баз, электронных таблиц и текстовых файлов. Наряду с использованием собственной базы данных, можно импортировать или связывать данные, хранящиеся в других базах данных Access, в файлах dBASE, Paradox, FoxPro, Btrieve и в любых базах данных SQL, поддерживающих стандарт ODBC. Можно также экспортировать данные из таблиц Access в базы данных, электронные таблицы или текстовые файлы других приложений.

Если текстовый файл создан другой программой с использованием стандартных разделителей полей, его можно импортировать в Microsoft Access без изменений. Однако в большинстве случаев перед импортом файла необходимо отредактировать его содержимое или создать для Access описание этого файла. Access должен знать, как различать начало и конец значения поля в каждой входной текстовой строке.

Access признает в качестве стандартных разделителей полей следующие символы: символ табуляции, точку с запятой, запятую, пробел или другой символ. Если в качестве разделителя используется запятая, то она указывает на конец поля, и первый непустой символ после запятой воспринимается как первый символ следующего поля. Запятые не являются частью данных. Чтобы включить запятую в текстовую строку как элемент данных, вам придется заключить все текстовые в одинарные (апострофы) или двойные кавычки. Если какая-либо из текста строка содержит кавычки, вы должны заключить строки в апострофы и наоборот. В Access в качестве ограничителей текста допускает только апострофы или кавычки (но не те и другие одновременно).

Другим распространенным разделителем является символ табуляции.

Можно также импортировать текстовые файлы, поля в которых располагаются в фиксированных позициях внутри каждой записи, т.е. каждое поле во всех записях начинается точно в одном и том же месте. Чтобы подготовить такой файл к импорту, нужно удалить из него все заголовки или итоговые строки.

Пример текстового файла, в котором в качестве разделителя полей используется пробел:

Текстовое Целое Числовое Дата
Первая 1 1,001 01.01.99
Второстепенная 2 2,2 02.02.99
Третья 3 3,03 03.03.99

Пример текстового файла с фиксированной длиной записей (заголовки столбцов не указываются).

Первая 1 1,001 01.01.99
Второстепенная 2 2,2 02.02.99
Третья 3 3,03 03.03.99


Многотабличные базы данных. Отношения между таблицами

Реляционные базы данных состоят из нескольких таблиц, связь между которыми устанавливается с помощью совпадающих полей. Каждая запись в таблицах идентифицирует один объект. Отношение между объектами определяет отношение между таблицами. Существует 4 типа отношений:

  1. Отношение «один-к-одному» означает, что каждая запись в одной таблице соответствует только одной записи в другой таблице.
  2. Отношение «один-ко-многим» означает, что каждой записи в одной таблице соответствует одна или несколько записей в другой таблице.
  3. Отношение «многие-ко-одному» аналогично рассмотренному ранее типу. Тип отношения между объектами зависит от вашей точки зрения.
  4. Отношение «многие-ко-многим» возникает между двумя таблицами в тех случаях, когда:
  • одна запись из первой таблицы может быть связана более чем с одной записью из второй таблицы;
  • одна запись из второй таблицы может быть связана более чем с одной записью из первой таблицы.

В большинстве случаев любые две таблицы связаны отношением «один-ко-многим». Это означает, что любая запись в первой таблице может быть связана с несколькими записями во второй, однако любая запись второй таблицы связана только с одной записью в первой.

Иногда возникает потребность разбить одну таблицу на более мелкие – проблема может заключаться в том, что некоторые сведения из нее используются не слишком часто, или в том, что какие-то данные не предназначаются для всеобщего доступа. Например, часть информации о факультетах нужна только для рекламных целей и используется очень редко. С другой стороны, сведения о заработной плате должны быть доступны только определенным сотрудникам. В любом из этих случаев можно создать отдельную таблицу и связать ее с исходной таблицей отношением типа «один-к-одному». Это означает, что любая запись в первой таблице связана только с одной записью во второй.

Если же между таблицами необходимо организовать связь «многие-ко-многим», то в Access придется создать дополнительную таблицу пересечения, с помощью которой одна связь будет сведена к двум связям типа «один-ко-многим».


Создание связей между таблицами

Для того, чтобы рассмотреть создание связей между таблицами построим в базе данных «Профконсультант» еще две таблицы:

1. Таблица тАбитуриенты:

Имя Тип Размер
КодАб Счетчик 4
Фамилия Текстовый 15
Имя Текстовый 10
Отчество Текстовый 1
Паспорт Текстовый 15
Индекс Числовой 4
Город Текстовый 20
Адрес Текстовый 50
СреднийБалл Числовой 4
Фото Поле объекта OLE -
Примечания Поле МЕМО -

КодАб является ключевым полем.

2. Таблица пересечения тСвязьАбВУЗ:

Имя Тип Размер
КодАб Числовой (Длинное целое) 4
КодВУЗа Числовой (Длинное целое) 4
СтатусПоступления Логический 1
СтатусПосещения Логический 1

Первые два поля являются ключевыми, причем для таблицы тСвязьАбВУЗы они являются чужими ключами.

Чтобы определить связи, необходимо использовать команду Сервис->Схема данных (кнопка [image] ). Если связь определяется впервые в базе данных, то Access откроет пустое окно Схема данных, а затем выведет на экран окно диалога Добавление таблицы. В этом окне необходимо выделить нужные таблицы и нажать кнопку Добавить. В нашем случае в окно схемы данных надо добавить все три таблицы. Кнопка Закрыть закрывает окно диалога Добавление таблицы (данное окно можно вызвать по нажатию кнопки [image]). После этого окно Схемы данных должно выглядеть примерно так, как показано на рис. 6.4 (кроме линий соединения). Чтобы установить связь между таблицами тВУЗы и тСвязьАбВУЗ, надо выделить поле КодВУЗа в таблице тВУЗы (щелкнуть левой кнопкой «мыши»), перетащить и опустить его на поле КодВУЗа в таблице тСвязьАбВУЗ. Аналогично устанавливается связь между двумя другими таблицами.

Рис. 6.4. Окно Схема данных, показывающее связи между основными таблицами в базе данных «Профконсультант»

Когда вы отпустите кнопку мыши, Microsoft Access откроет окно диалога Связи, представленное на рис. 6.5.

Рис. 6.5. Окно диалога Связи

После установки флажка Обеспечение целостности данных, Access делает доступными еще два флажка: Каскадное обновление связанных полей и Каскадное удаление связанных записей. При установленном флажке Каскадное обновление связанных полей Microsoft Access обновляет все значения чужих ключей в дочерних таблицах (то есть в таблицах на стороне отношения «многие» при связи «один-ко-многим») при изменении значения первичного ключа в родительской таблице, которая находится на стороне отношения «один» при связи «один-ко-многим». Если же вы установите флажок Каскадное удаление связанных записей, Microsoft Access удалит дочерние строки (связанные строки в дочерних таблицах) при удалении родительской строки (связанная строка в родительской таблице). Например, если вы решили удалить некоторый вуз из базы данных, то в этом случае следует удалить соответствующие данные в связующей таблице. Access автоматически выполнит эту операцию, если установлен флажок Каскадное удаление связанных записей. Кроме того, коды вузов время от времени могут меняться. Установите флажок Каскадное обновление связанных полей, чтобы при изменении кода вуза Access автоматически обновлял записи в таблице тСвязьАбВУЗ.

Окно диалога Добавление таблицы дает возможность добавить как таблицы, так и запросы. Иногда требуется определить связи между таблицами и запросами или только между запросами. Вы можете также определить так называемые внешние объединения, нажав кнопку Объединение в окне диалога Связи. С помощью внешнего объединения вы сможете найти, например, те вузы, к которым студенты не проявили интереса.

После нажатия кнопки Создать Access создаст связь и нарисует линию между двумя таблицами, указывающую на наличие связи между ними. Заметьте, когда вы просите обеспечить целостность данных, Access изображает на конце линии у таблицы, находящейся на стороне отношения «один», цифру 1, а на другом конце у таблицы со стороны отношения «многие» – символ бесконечности (см. рис. 6.4). Чтобы удалить связь, щелкните по ее линии и нажмите клавишу Del. Если вы хотите отредактировать или изменить существующую связь, дважды щелкните по соответствующей линии, чтобы снова открыть окно диалога Связи.


6.6. Работа с данными при помощи запросов

В режиме таблицы доступны самые разные операции с данными – просмотр, сортировка, фильтрация, обновление и печать. Однако очень часто приходится проводить вычисления или просматривать данные из нескольких таблиц. Отобрать нужные данные можно с помощью запросов.

После выполнения запроса на выборку (который отбирает информацию из таблиц и других запросов базы данных, в то время как при выполнении запросов на изменение данные вставляются, обновляются или удаляются) Access создает набор записей, содержащий отобранные данные. В большинстве случаев с набором записей можно работать точно так же, как с таблицей: можно просматривать и выбирать информацию, печатать и даже обновлять данные. Однако в отличие от реальной таблицы, этот набор записей физически не существует в базе данных. Access создает набор записей из данных таблицы только во время выполнения запроса. Если вы измените данные в наборе записей, Access внесет соответствующие изменения в таблицы, на базе которой построен запрос.

Выбор данных из одной таблицы

Одним из преимуществ запросов является то, что они позволяют достаточно быстро отобрать необходимые данные из нескольких связанных таблиц. Но запросы полезны и при работе с одной таблицей. Все приемы, используемые при работе с единственной таблицей, годятся и для сложных многотабличных запросов, поэтому мы начнем с запросов на выборку данных одной таблицы.

На рис. 6.6 показан запрос в режиме конструктора. Окно конструктора запросов разделено на две части. В верхней находятся списки полей таблиц или запросов, на основе которых создается новый запрос. В нижней располагается бланк QBE (Query By Example – запрос по образцу), в котором выполняется вся работа по созданию запроса. Каждый столбец бланка представляет одно поле, используемое в запросе. Поле может просто принадлежать одной из таблиц, быть вычисляемым (иными словами, его значение рассчитывается на основе одного или нескольких полей таблицы), или итоговым, то есть использующим одну из встроенных функций Microsoft Access.

Рис. 6. 6. Запрос зХорошисты на основе таблицы тАбитуриенты в режиме
конструктора

Первая строка бланка запроса служит для выбора полей, которые должны присутствовать в наборе записей, используется для сортировки данных или для выбора информации из таблицы. Полям запроса можно присвоить имена, которые будут отображаться в заголовках столбцов при выводе набора записей запроса, а для генерации вычисляемых полей можно использовать выражения любой степени сложности.

Если была выполнена команда Вид->Имена таблиц, во второй строке бланка запроса Access выведет имя таблицы, из которой выбрано поле. В третьей строке бланка можно задать сортировку по возрастанию или по убыванию.

Флажки в строке бланка Вывод на экран отвечают за вывод полей в наборе записей. По умолчанию выводятся все поля, включенные в бланк запроса.

Для ввода условия отбора записей используется строка Условие отбора и строки или. На рис.6. 6 показан запрос на выборку фамилий тех студентов, которые имеют оценки от 4 до 5 баллов.


Включение полей в запрос

Первым шагом при создании запроса является выбор полей, включаемых в набор записей. Это можно сделать несколькими способами. Чтобы увидеть список доступных полей, надо перейти с помощью клавиши табуляции к нужному столбцу бланка запроса и нажать клавиши Alt+ "стрелка вниз" (для перевода курсора из верхней части окна в бланк запроса, нажмите клавишу F6). Чтобы включить поле в бланк запроса, надо переместить выделение к этому полю, пользуясь клавишами "стрелка вниз" или "стрелка вверх" и нажать клавишу Enter.

Можно просто перетащить поле с помощью мыши в нужный столбец бланка из списка полей верхней части окна. При перетаскивании поля указатель мыши превращается в маленький прямоугольник.

В самом начале списка полей, находящегося в верхней половине окна запроса (а также в раскрывающихся списках в первой строке бланка QBE), находится специальный символ «*», означающий «Все поля». Если необходимо включить в запрос все поля таблицы, не надо определять каждое по отдельности в бланке QBE. Достаточно перетащить «*» из списка полей в бланк QBE. Учтите, что вы можете повторно включить столбец поля таблицы в бланк запроса, чтобы определить условия отбора для них. В этом случае, чтобы поля дважды не выводились в наборе записей запроса снимите флажки Вывод на экран в столбцах бланка, содержащих повторяющиеся поля.

В общем случае поля, выводимые в наборе записей запроса, наследуют свойства, заданные для соответствующих полей таблицы. Можно задать другие свойства с помощью команды Вид->Свойства (кнопка [image] ).

Ввод условий отбора и выбор между AND и OR

Ввод условия отбора в запросе аналогичен заданию условия на значение для поля таблицы. Когда вы вводите условия отбора для нескольких полей, то все выражения в строке Условие отбора или в строке или должны принимать значение Истина для любой записи, включаемой в набор записей запроса. Это означает, что Асcess выполняет логическую операцию AND над условиями отбора, находящимися в одной строке. В таблице приведены значения выражения, состоящего из двух условий, связанных оператором AND. Очевидно, чтобы результат операции AND имел значение Истина, оба условия должны быть истинными; только в этом случае запись отбирается запросом.

Когда вы задаете для некоторого поля несколько условий отбора, соединенных логическим оператором OR, то для того, чтобы запись была отобрана истинным должно быть хотя бы одно из них. Есть два способа задать несколько связанных оператором OR условий для одного поля. Можно ввести все условия в одну ячейку строки Условие отбора, соединив их оператором OR. Другой вариант: ввод каждого условия в отдельную ячейку строки или. При использовании нескольких строк или для отбора записи достаточно выполнения всех условий в одной из строк или.

Результат применения к двум условиям логических операций AND и OR

AND | Истина | Ложь
Истина | Истина (Отбирается) | Ложь (Отвергается)
Ложь | Ложь (Отвергается) | Ложь (Отвергается)

OR | Истина | Ложь
Истина | Истина (Отбирается) | Истина (Отбирается)
Ложь | Истина (Отбирается) | Ложь (Отвергается)


Вычисляемые поля

С любыми полями таблицы можно выполнять вычисления и сделать вычисляемое выражение новым полем в наборе записей, при этом можно использовать любые из встроенных функций Access. Кроме того, поля запроса могут содержать данные, получаемые с помощью арифметических операций над полями таблицы. Например, ЦенаТовара*Количество.

Вычисляемое поле может содержать вызовы встроенных функций Access и следующие операторы:
+ – складывает два арифметических выражения.
- – вычитает из первого арифметического выражения второе.
* – перемножает два арифметических выражения.
/ – делит первое арифметическое выражение на второе.
\ – округляет два арифметических выражения до целых значений и делит первое на второе. Результат округляется до целого.
^ – возводит первое арифметическое выражение в степень, задаваемую вторым арифметическим выражением.
MOD – округляет оба арифметических выражения до целых значений, делит первое на второе и возвращает остаток.
& – создает текстовую строку как результат присоединения второй строки к концу первой. Если один из операндов является числом, то оно автоматически преобразуется в строку символов.

На рис. 6.7 показан пример вычисляемого поля для таблицы тАттестат. Вычисляемое поле Среднее выводит средний балл по трем предметам: Русский, Математика, Физика.

Рис. 6.7. Запрос на основе таблицы тАттестат с вычисляемым полем Среднее

Итоговые запросы

Для вычисления итоговых значений надо нажать кнопку Групповые операции( [image] ), чтобы в бланке QBE появилась строка Групповые операции. Access использует установку Группировка в строке Групповая операция для любого поля, занесенного в бланк запроса. Теперь записи по каждому полю группируются, но итог не подводится. Если выполнить запрос сейчас, вы получите набор записей, включающий по одной строке для каждого уникального значения поля запроса – но без итогов. Для получения итогов замените установку Группировка в строке Групповая операция на конкретные итоговые функции.

Access предоставляет девять функций, обеспечивающих выполнение групповых операций. Вы можете задать нужную вам функцию, введя ее имя с клавиатуры в строке Групповая операция бланка запроса или выбрав ее в раскрывающемся списке.

Итоговые функции Access:

Sum – вычисляет сумму всех значений заданного поля в каждой группе.
Avg – вычисляет среднее арифметическое всех значений данного поля в каждой группе.
Min – возвращает наименьшее значение, найденное в этом поле внутри каждой группы.
Max – возвращает наибольшее значение, найденное в этом поле внутри каждой группы.
Count – возвращает число записей, в которых значения данного поля отличны от Null.
StDev – стандартное отклонение всех значений данного поля в каждой группе.
Var –вычисляет дисперсию значений данного поля в каждой группе.
First – возвращает первое значение этого поля в группе.
Last – возвращает последнее значение этого поля в группе.

На рис. 6.8 показан пример запроса с применением групповой операции Sum. Данный запрос является многотабличным и позволяет определить сумму выплат, сделанных каждым абитуриентом.

Рис. 6.8. Запрос с применением групповой операции Sum


Перекрестные запросы

Access поддерживает особый тип итоговых запросов, называемый перекрестными запросами. Они позволяют увидеть вычисляемые значения в виде перекрестной таблицы, напоминающей электронную (рис. 6.9).

Для построения перекрестного запроса выделите имя нужной таблицы в окне базе данных и выберите Новый запрос в раскрывающемся списке кнопки Новый объект на панели инструментов. В окне диалога Новый запрос выберите Конструктор, а затем в окне конструктора выберите команду Запрос->Перекрестный. Access добавит в бланк запроса строку Перекрестная таблица. В этой строке для каждого поля перекрестного запроса может быть выбрана одна из четырех установок: Заголовки строк, Заголовки столбцов, Значение (выводимое в ячейках перекрестной таблицы) и Не отображается. Для перекрестного запроса надо определить по крайней мере одно поле в качестве заголовков строк, одно для заголовков столбцов и одно поле значений. Каждое поле, являющееся заголовком столбцов, должно иметь в строке Групповая операция установку Группировка. Для поля, использующегося в качестве заголовков строк, в строке Групповая операция должна быть установлена операция Группировка, выбрана одна из итоговых функций (Count, Min, и т. д.) или введено выражение, содержащее итоговую функцию. Для поля с установкой Значение выбирается одна из итоговых функций или вводится выражение, использующее итоговую функцию.

Как и в других типах итоговых запросов, для отбора данных, включаемых в набор записей, можно использовать дополнительные поля. Для них необходимо выбрать установку Условие в строке Групповая операция и Не отображается в строке Перекрестная таблица, а затем ввести условие отбора. Условие отбора можно также задать для любого поля, используемого в качестве заголовков столбцов, а данные можно сортировать по любым полям. (По умолчанию Access сортирует заголовки столбцов по возрастанию.)

Построить перекрестный запрос можно другим, более простым способом, с помощью мастера. Для этого в окне диалога Новый запрос надо выделить пункт Перекрестный запрос и нажать Ok. Затем мастер выведет на экран последовательно ряд окон, в которых запросит необходимые данные для построения перекрестного запроса. Пример результата выполнения перекрестного запроса показан на рис. 9,б.

а

б

Рис. 9. Перекрестный запрос в режиме конструктора (а),
результат выполнения перекрестного запроса (б)


Модификация данных с помощью запросов на изменение.

Модификация данных с помощью запросов на изменение. Проверка правильности отбора записей с помощью запроса на выборку

В режиме конструктора в меню Запрос присутствуют команды для четырех типов запросов на изменение: Создание таблицы, Обновление, Добавление, Удаление. Однако прежде чем приступить к созданию и выполнению запроса на изменение записей в базе данных, создайте запрос на выборку с условием отбора, позволяющим найти все подлежащие обновлению записи. После того, как Access выберет нужные записи, можно преобразовать запрос на выборку в запрос на обновление или в другой запрос на изменение.

Запрос на Создание таблицы используется для сохранения извлекаемых с помощью запроса на выборку данных в новой таблице.

Запрос на Обновление используется для замены в отобранных записях существующих данных.

С помощью запроса на Добавление можно скопировать выбранные записи и вставить их в другую таблицу. Кроме того, запрос на добавление можно использовать для перенесения данных из другого источника в свою базу данных (например, списка фамилий и адресов из списка рассылки фирмы), чтобы затем отредактировать полученные данные и вставить их в существующую таблицу. Запрос на добавление, подобно запросу на создание таблицы, позволяет собрать вычисленные итоговые данные и сохранить их в определенной таблице. Одно из преимуществ запроса на добавление состоит в том, что вы имеете возможность полностью определить поля и задать их свойства перед вставкой данных в конечную таблицу. Недостатком этого типа запросов является большая вероятность ошибок, поскольку добавляемые данные могут не соответствовать типам полей, определенным в конечной таблице, или нарушить уникальность первичного ключа.

Перед выполнением запроса на Удаление необходимо проверить его работу как запроса на выборку. Это необходимо для того, чтобы убедиться в том, что удаляются нужные записи.

Типовые ошибки и проблемы, возникающие при выполнении запросов на изменение

Во время выполнения запроса на изменение Access различает четыре категории ошибок:

1. Дубликаты первичного ключа. Эта категория ошибок возникает при попытке добавления или изменения некоторой записи в таблице, приводя к появлению дублирующего значения первичного ключа или уникального индекса. Access не будет обновлять или добавлять записи, создающие такие значения. Во избежание конфликта перед попыткой добавить такие записи следует изменить значения первичного ключа в исходной таблице.

2. Ошибки преобразования данных. Ошибки этой категории возникают в тех случаях, когда вы вставляете данные в существующую таблицу и при этом оказывается, что тип данных полей-получателей не совпадает с типом данных полей-источников (и данные полей-источников не могут быть преобразованы к типу данных полей-получателей). Например, ошибка возникает, если вы добавляете текстовые значения к полю, содержащему целочисленные данные, а текстовое поле содержит буквенные символы или слишком длинную строку цифровых символов. В запросе на обновление ошибка преобразования может возникнуть, если вы используете формулу, которая пытается произвести вычисления над полем, содержащим буквы.

3. Заблокированные записи. Ошибки этой категории возникают, когда при выполнении запроса на удаление или на обновление вы используете таблицу, к которой имеют доступ другие пользователи сети. Access не может произвести обновление записей, которые в это время обновляются другими пользователями. Вам следует подождать некоторое время и попытаться снова выполнить обновление или удаление в тот момент, когда данные записи больше никто не использует.

4. Нарушение условий на значение. Если вставляемые или обновляемые записи не удовлетворяют условию на значение для некоторого поля для таблицы, Access сообщает вам об ошибке и не производит вставки или обновления подобных записей.


6.7. Построение и применение форм

Формы являются основным средством организации интерфейса пользователя в приложениях Microsoft Access. Формы могут применяться для различных целей:

  • Вывод и редактирование данных. Это наиболее распространенный способ использования форм. Формы обеспечивают вывод на экран данных в необходимом представлении. С их помощью значительно упрощается внесение изменений, добавление и удаление данных из базы. В форме можно сделать доступными только для чтения все данные или некоторую их часть, автоматически выбирать информацию из других связанных таблиц и помещать ее в форму, вычислять выводимые в форме значения, скрывать или, наоборот, выводить некоторые данные в зависимости от значений других полей записи либо от выбранных пользователем параметров.
  • Управление ходом выполнения приложения. Чтобы автоматизировать вывод определенных данных или выполнение некоторой последовательности действий, создаются формы для работы с макросами или процедурами Visual Basic для приложений. Для запуска макросов или процедур VBA обычно используются элементы управления, называемые командными кнопками. С помощью макросов и процедур можно открывать другие формы, выполнять запросы или команды меню, фильтровать выводимые на экран данные, устанавливать значения в записях и формах, выводить меню на экран, печатать отчеты и выполнять ряд других действий. Можно так спроектировать форму, чтобы макросы или функции Visual Basic для приложений запускались в ответ на определенные события – например, открытие формы, активизацию определенного элемента управления или изменение данных в форме.
  • Ввод данных. Формы, предназначенные только для ввода в базу новых данных или значений, помогающих автоматизировать выполнение приложения.
  • Вывод сообщений. Формы могут предоставлять вспомогательную информацию о работе приложения или о выполняемых действиях. С помощью макрокоманды Сообщение или функции MsgBox Visual Basic для приложений можно вывести на экран информацию, предупреждение или сообщение об ошибках.
  • Печать информации. Несмотря на то, что для печати информации чаще всего используются отчеты, можно распечатать информацию, содержащуюся в форме. Поскольку для вывода формы на экран можно определить один набор параметров, а для печати – другой, форма может играть двойственную роль. Например, можно задать два заголовка и два примечания для формы – одну пару (заголовок и примечание) для ввода заказа, а другую – для печати счета по заказу.

Обзор форм

Рассмотрим основные виды форм, которые можно построить в Access.

Простые формы. В простой форме показывается только одна запись таблицы, причем все необходимые поля отображаются на одной странице.

Многостраничные формы. При необходимости вывести на экран записи, каждая из которых содержит большой объем информации, можно создать многостраничную форму.

Ленточные формы. Существует еще один тип форм, удобный для просмотра списка записей с небольшим числом полей данных. Это ленточная форма. В отличие от простой формы, которая показывает только одну запись, в ленточной форме отформатированные записи выводятся на экран одна за другой, как в таблице.

Подчиненные формы. Подчиненные формы используются для представления данных, находящихся на стороне «многие» отношения «один-ко-многим». Например, форма фАбитуриент показывает одного студента и несколько вузов, в которые студент поступает (рис. 6.10).

Рис. 6.10. Форма фАбитуриенты с подчиненной формой фВУЗы

Всплывающие формы. Иногда удобнее предоставлять информацию в окне, которое все время остается на переднем плане. По умолчанию в Microsoft Windows 95 активное окно выводится на переднем плане, а остальные окна перемещаются на задний. Единственным исключением являются окна справки. В частности, окно процедурной справки остается на переднем плане, позволяя вам следить за пошаговыми инструкциями в то время, когда фокус находится в вашем рабочем окне (то есть оно активно). Такой тип плавающих окон называется всплывающим окном.

Монопольные формы. При разработке приложения возникают ситуации, когда требуется получить какие-либо данные или передать важную информацию прежде, чем Microsoft Access сможет продолжить работу. В Access имеется специальный тип формы – монопольная форма (окно которой является монопольным), которая требует ответа как непременного условия дальнейшей работы приложения.


Конструктор форм

Чтобы начать создание формы, необходимо в окне базы данных выбрать таблицу или запрос, выполнить команду Вставка->Форма или выбрать Новая форма ( [image] ) в раскрывающемся списке кнопки Новый объект( [image] ) на панели инструментов. Access откроет окно диалога Новая форма. В поле со списком, расположенном в нижней части диалога, Access выводит имя таблицы или запроса, выбранного в окне базы данных. При необходимости можно выбрать другую таблицу или запрос, раскрыв список этого поля, содержащий перечень всех таблиц и запросов в текущей базе данных.

Выберите Конструктор в этом окне диалога и нажмите кнопку Ok. Access откроет окно формы в режиме конструктора и выведет на экран несколько инструментов конструктора форм (рис. 6.11). В нашем примере окно формы находится на заднем плане, панель элементов располагается третьей в панели инструментов, список полей – в верхней части окна, окно свойств формы – в правом нижнем углу. В новой форме будет присутствовать только область данных (с серой сеткой). Для добавления в форму областей заголовка и примечания используется команда Вид-> Заголовок/примечание формы, для добавления колонтитулов – Вид-> Колонтитулы. Увеличить или уменьшить размер любой области можно, если установить указатель мыши на краю этой области и перетащить его. Удаление сетки выполняется командой Вид-> Сетка.

Рис. 6. 11. Окно конструктора форм с его инструментами

Панель элементов

Панель элементов – это своеобразный «командный центр» создания формы. Её можно переместить, перетащив заголовок окна в нужное место на экране, или изменить её форму, перетащив края или углы панели. При желании можно переместить панель элементов в любую часть окна Access и закрепить ее как панель инструментов (см. рис. 6.11).

Чтобы в режиме конструктора форм вывести на экран панель элементов, нужно выбрать команду Вид->Панель элементов или нажать кнопку Панель элементов ( [image] ) на панели инструментов.

Панель элементов содержит кнопки для всех элементов управления, которые можно использовать при создании формы. Для того, чтобы поместить в форму конкретный элемент управления, нажмите соответствующую кнопку на панели элементов. После этого при перемещении указателя по форме он превращается в значок выбранного элемента управления. Поместите указатель там, где будет находиться левый верхний угол элемента управления, нажмите кнопку мыши и протащите указатель до места, где должен быть правый нижний угол элемента, а затем отпустите кнопку мыши. (Размер элемента управления можно изменить и после его размещения в форме, перетащив стороны или углы элемента в новое положение.)

Ниже перечислены кнопки панели элементов.

– кнопка Выбор объектов. По умолчанию эта кнопка нажата. Она используется для выделения, изменения размера, перемещения и редактирования элемента управления.

– кнопка Мастера элементов. Если кнопка нажата, то при создании группы, поля со списком, списка или командной кнопки активизируется мастер по созданию этих элементов управления. Он помогает правильно определить свойства элемента управления.

– кнопка Надпись используется для создания элемента управления Надпись, содержащего постоянный текст. По умолчанию большинство элементов управления формы имеют присоединенные к ним надписи. Данный элемент можно использовать также для создания в форме заголовков и инструкций, не связанных с другими элементами управления.

– кнопка Поле используется для создания элемента управления Поле для отображения текста, чисел, дат, времени. Можно связать элемент управления Поле с одним из полей базовой таблицы или запроса. В этом случае, при изменении значения элемента управления, обновляется значение соответствующего поля в базовой таблице или запросе. Этот элемент управления применяется также для вычисления значений некоторых выражений.

– кнопка Группа используется для создания группы элементов управления, содержащей несколько выключателей, переключателей или флажков. Каждому элементу управления, входящему в группу, присваивается отдельное числовое значение. Одновременно можно установить (выбрать) только один из включенных в группу элементов, и значение, назначенное ему, присваивается всей группе. Один из элементов группы может устанавливаться по умолчанию. Если связать группу с полем базового запроса или таблицы, то при выборе элемента группы будет устанавливаться новое значение поля.

Кнопки [image] Выключатель, [image] Переключатель и [image] Флажок используются для создания элементов управления, принимающих значение Вкл/Выкл, Истина/Ложь или Да/Нет. Состоянию Вкл, Истина или Да соответствует число –1, а Выкл, Ложь или Нет соответствует 0. При включении одного из этих элементов в группу элементов ему назначается уникальное числовое значение. При выборе одного из Выключателей, Переключателей или Флажков (т.е. переводе его во включенное состояние), любой ранее нажатый элемент группы будет переведен в выключенное состояние. К сожалению, в Access отличие между данными элементами управления заключается только в их изображении. Тогда как в некоторых системах программирования элементы типа Флажок реализуют логику «И», т.е. на нескольких таких переключателях пользователь может установить любую комбинацию соответствующих опций. В Access все данные элементы реализуют логику «ИЛИ», т.е. из нескольких опций пользователь может выбрать одну (ранее сделанный выбор автоматически сбрасывается).

– кнопка Поле со списком используется для создания элемента управления Поле со списком, который можно рассматривать как объединение двух элементов: поле и список. Для явного задания списка надо ввести список значений в строке свойства Источник записей. В качестве источника значений списка можно также использовать таблицу или запрос. Значение, выбранное в списке, отображается в поле. При выборе нового значения в списке изменяется значение элемента управления. Если поле со списком связано с полем базовой таблицы или запроса, можно изменить значение этого поля, выбрав в списке новое значение.

– кнопка Список используется для создания элемента управления Список, содержащего перечень возможных значений. Задание свойств аналогично предыдущему элементу управления.

– кнопка элемента Кнопка используется для создания элемента yправления Командная кнопка, с помощью которой можно запустить макрос или процедуру VBA.

– кнопка Набор вкладок используется для создания формы, состоящей из нескольких вкладок. На вкладку можно скопировать или добавить другие элементы управления. Для добавления, удаления или изменения порядка вкладок щелкните правой кнопкой мыши границу элемента «Набор вкладок» и выберите команду Добавить вкладку, Удалить вкладку или Последовательность вкладок.

– кнопка Рисунок позволяет поместить в форму статический рисунок. Его нельзя будет редактировать в форме. (Свойство формы Рисунок позволяет использовать некоторое изображение в качестве подложки (фона) формы.).

– кнопка Свободная рамка объекта используется для включения в форму объекта из другого поддерживающего OLE приложения. Объект становится частью формы, но не хранится в базе данных. Чтобы сделать форму более наглядной и выразительной, можно включить в нее рисунки, звуковые эффекты, диаграммы или слайды.

– кнопка Присоединенная рамка объекта используется для включения в форму объекта OLE, хранящегося в базовой таблице. Access может отобразить большинство рисунков и диаграмм непосредственно в форме. Для других объектов Access выводит в форме значок приложения, в котором был создан объект. Например, если объект является звуковым и создан в Sound Recorder, вы увидите в форме значок «динамика».

– кнопка Конец страницы позволяет вставлять разрыв страницы в многостраничной форме.

– кнопка Подчиненная форма/отчет используется для включения в текущую форму некоторой другой формы. С помощью подчиненной формы можно вывести данные таблицы или запроса, связанные с текущими данными основной формы.

– кнопка Линия используется для включения в форму прямых линий, помогающих сделать ее более выразительной.

– кнопка Прямоугольник используется для включения в форму прямоугольников и улучшения ее внешнего вида.

Любая, за исключением Выбора элементов, кнопка, выбранная на панели элементов, становится неактивной после размещения соответствующего элемента управления в форме. Если вы собираетесь создать несколько одинаковых элементов управления, например, серию флажков в группе, щелкните дважды по кнопке на панели элементов, чтобы зафиксировать ее в нажатом положении. После нажатия любой другой кнопки на панели элементов эта будет разблокирована.

Размещение в форме присоединенных элементов управления (элементы управления, связанные с полями таблицы или запроса) упрощается при использовании списка полей. Последний открывается с помощью кнопки Список полей ( [image] ) на панели инструментов или команды Вид->Список полей. Чтобы создать присоединенный элемент управления с помощью списка полей, выберите его тип, нажав соответствующую кнопку на панели инструментов. Затем перетащите поле из списка в нужное место формы. (При перетаскивании поля без предварительного выбора инструмента на панели элементов в форме создается по умолчанию элемент управления Поле). Если выбран элемент управления, не соответствующий типу данных связанного с ним поля базовой таблицы или запроса, Access создает элемент управления, используемый по умолчанию.

Сама форма, каждый ее раздел (заголовок, область данных, раздел примечаний) и элементы управления имеют свойства. Установить их значения можно с помощью окна свойств. Оно открывается с помощью кнопки Свойства ( [image] ) на панели инструментов или командой Вид->Свойства. Поскольку форма имеет более 70 свойств, а большинство элементов управления – более 30, то окно свойств содержит несколько вкладок. На вкладках представлены определенные категории свойств: свойства данных, макета, событий, другие свойства. На отдельной вкладке выводятся все объекты.


6.8. Основные сведения об отчетах

Отчеты представляют собой наилучшее средство для представления информации из базы данных в виде печатного документа. По сравнению с другими средствами вывода данных на печать отчеты обладают двумя принципиальными преимуществами:

  1. Предоставляют широкие возможности для группировки и вычисления промежуточных и общих итогов для больших наборов данных.
  2. Могут быть использованы для получения красиво оформленных счетов, заказов на покупку, почтовых наклеек, материалов для презентаций и других документов, которые могут понадобиться для успешного ведения бизнеса.

В отчете каждая группа данных и итоги по ней могут быть представлены отдельно. В отчетах имеются следующие возможности:

  • Для обеспечения иерархического представления данных можно определить до 10 условий группировки.
  • Для каждой из групп можно задать отдельные заголовки и примечания.
  • Можно производить сложные вычисления не только внутри некоторой группы или набора строк, но и по нескольким группам одновременно.
  • В дополнении к верхнему и нижнему колонтитулу можно задать заголовок и примечание для всего отчета в целом.

8.1. Создание отчета

В окне диалога Новый отчет можно выбрать один из шести вариантов.

Конструктор. Используется для создания отчета «с нуля» или для редактирования ранее созданного отчета.

Мастер отчетов. Запускает основного мастера по разработке отчетов, позволяющего выбрать поля для отчета, задать форматы, условия группировки и итоговые функции.

Автоотчет: в столбец. Этот мастер создает отчет, в котором каждая запись базового запроса или таблицы представлена в виде простого списка, содержащего названия и значение полей.

Автоотчет: ленточный. В отчете этого типа записи базового запроса или таблицы выводятся в одной строке. Если таблицы базового запроса связаны отношением «один-ко-многим», то мастер создает группу для данных, поступающих со стороны отношения «один», но не вычисляет никаких итоговых значений. При создании отчета используется последний стиль, который был выбран в мастере отчетов или применен с помощью автоформата в конструкторе отчетов.

Диаграмма. Этот мастер помогает построить диаграмму и создает в отчете свободную рамку объекта OLE с внедренной диаграммой Microsoft Graph.

Почтовая наклейка. Этот мастер позволяет выбрать поля с именами и адресами, отформатировать их и создать отчет для печати почтовых наклеек. Можно выбрать любой из нескольких наиболее распространенных типов наклеек.

8.2. Разработка отчета в режиме конструктора

Окно отчета в режиме Конструктора идентично окну формы в этом режиме, т.е. присутствует такая же Панель элементов, окно со списком полей и окно со списком свойств (см. рис. 10). Пустой макет отчета содержит разделы Верхний колонтитул, Нижний колонтитул, между которыми находится Область данных. Расположение данных на странице по вертикали определяется тем, как вы зададите верхний и нижний колонтитулы и соответствующие поля страницы. Как и при работе с формами, можно изменить размер любого раздела, перетащив его границу. Ширина всех разделов должна быть одной и той же, поэтому при изменении ширины одного из разделов Ассеss автоматически настраивает ширину всех остальных.

Верхний и нижний колонтитулы будут печататься соответственно вверху и внизу каждой страницы отчета. Добавить или удалить верхний и нижний колонтитулы можно с помощью команды Вид->Колонтитулы. Можно задать заголовок отчета, который будет печататься только в самом начале отчета, и примечание отчета, печатающееся в конце отчета. Чтобы добавить в отчет эти разделы, выберите Формат-> Заголовок/примечание отчета.


Сортировка и группировка информации

Отчеты в отличие от форм предоставляют возможность группировать выводимую в них информацию с помощью окна Сортировка и группировка. Чтобы открыть окно, приведенное на рис. 6.12, нажмите кнопку Сортировка и группировка ( [image] ) на панели инструментов. В окне Сортировка и группировка можно определить до 10 полей или выражений, которые будут использоваться в отчете для группировки данных. Первый элемент в списке определяет основную группу, а последующие – подгруппы внутри групп.

Рис. 6.12. Окно Сортировка и группировка

В простом отчете с информацией об оплате абитуриентами подготовительных курсов для вычисления общей суммы для каждого абитуриента нужно сгруппировать данные по полю Фамилия. Вообще, в столбце Поле/выражение можно ввести выражение, содержащее ссылку на любое поле базовой таблицы или запроса. По умолчанию Access сортирует значения по возрастанию. Можно изменить порядок сортировки, если выберите значение По убыванию в раскрывающемся списке, который появляется после щелчка в ячейке столбца Порядок сортировки.

В отчете должно быть зарезервировано место для заголовков каждой группы и примечания для вычисляемых полей. Чтобы добавить в отчет эти разделы, нужно установить для свойств Заголовок группы и Примечание группы значения Да в окне сортировки и группировки.

8.4. Задание условий группировки и сортировки

После установки свойства Заголовок группы или Примечание группы для любого поля или выражения в значение Да Access выводит символ группировки в области выделения этой строки. Кроме того, Access включает в отчет соответствующий раздел. Чтобы заголовок группы не оставался в конце страницы без детальных данных, нужно установить свойство Не разрывать в значение Первую область данных. Кроме того, Access может выводить все детальные данные для этого уровня группировки на одной странице (если это возможно), если установить для того же свойства значение Полную группу. В этом случае Access будет начинать новую страницу, если новая группа не помещается на текущей.

8.5. Задание диапазонов группировки

Для каждого поля или выражения, заданного в верхней части окна сортировка и группировки, можно установить свойства Группировка и Интервал. Обычно данные группируются по каждому значению поля или выражения. Но если значения поля (выражения) попадают в некоторый диапазон, можно объединить записи в одну группу. Вид и размер диапазона зависят от типа данных поля или выражения.

Для группировки по текстовому полю Access начинает новую Группу при изменении первого или нескольких начальных символов значения поля. Например, чтобы образовать по одной группе для каждой буквы алфавита, определите создание новой группы при изменении первой буквы значения поля – таким образом, вы получите группу записей, в которых значение поля начинается с буквы А, группу записей со значением поля, начинающегося с буквы Б, и т. д. Чтобы задать группировку по первым символам, установите свойство Группировка в значение По первым символам, а свойство Интервал делайте равным числу начальных символов, по которым вы хотите образовывать группы.

Для чисел можно установить свойство Группировка в значение Интервал. При такой установке свойство Интервал определяет диапазоны группировки. Access вычисляет диапазоны, начиная от 0. Если задать интервал, равный 10, то будут формироваться группы для значений от –20 до –11, от –10 до –1, от 0 до 9, от 0 до 19, от 20 до 29 и т. д.

Для полей даты/времени можно установить в качестве значения свойства Группировка такие единицы измерения, как Год, Квартал, Месяц, Неделя, День, Час и Минута. Для свойства Интервал укажите число единиц измерения, если вы хотите проводить группировку по определенному отрезку времени. Например, если вы хотите создавать группы с интервалом в два года, установите свойство Группировка в значение Год, а значение свойства Интервал сделайте равным 2.

Если вы создаете группы по полю, для которого свойство Группировка не равно По полному значению, Access сортирует только группирующие значения, а не индивидуальные значения внутри каждой группы. Чтобы Access отсортировал детальные данные внутри группы, дополнительно определите сортировку по этому полю. Например, если вы группируете данные по первым двум символам поля Фамилия и хотите отсортировать имена внутри каждой из полученных групп, то введите Фамилия в окне Сортировка и группировка со значением свойства Заголовок группы равным Да. Укажите для этого поля сортировку по возрастанию, свойство Группировка установите в значение По первым символам, а свойство Интервал – в значение 2. Введите Фамилия еще раз с установкой свойства Группировка равным По полному значению и задайте сортировку по возрастанию. Пример итогового отчета по оплате с группировкой по полю Фамилия показан на рис. 6.13.

Рис. 6.13. Отчет отАбитуриенты в режиме конструктора


6.9. Автоматизация работы приложения с помощью макросов

В Microsoft Access можно определить макрос, выполняющий практически те же действия, которые можно реализовать нажатием клавиш на клавиатуре или с помощью мыши. Основным преимуществом макросов в Access является то, что они могут выполняться в ответ на многие виды событий.

Событием может быть изменение данных, открытие и закрытие формы или отчета, а также передача фокуса от одного элемента управления, другому. В макрос можно включить несколько макрокоманд и задать проверку условий таким образом, что в зависимости от значений данных в формах или отчетах будут выполняться различные действия.

Microsoft Access предоставляет различные типы макрокоманд, позволяющих автоматизировать работу приложения. Рассмотрим основные действия, выполняемые с помощью макрокоманд:

  • Открытие любой таблицы, запроса, формы или отчета в любом доступном режиме выполняется макрокомандами: ОткрытьТаблицу, ОткрытьЗапрос, ОткрытьФорму, ОткрытьОтчет. С помощью макрокоманды Закрыть можно закрыть любую открытую таблицу, запрос, форму или отчет.
  • Для запуска других макросов используется макрокоманда ЗапускМакроса. Выполнение процедуры или функции VBA осуществляется макрокомандой ЗапускПрограммы. Чтобы прервать выполнение текущего макроса или всех макросов можно использовать ОстановитьМакрос или ОстановитьВсеМакросы.
  • Для определения специальной строки меню используется макрокоманда ДобавитьМеню. Можно сделать доступным или не доступным, снять галочку или пометить пункт специального меню, в том числе и контекстного с помощью макрокоманды ЗадатьКомандуМеню. Выполнить любую команду одного из стандартных команд меню Access позволяет макрокоманда КомандаМеню.
  • Для перемещения, изменения размеров, сворачивания или восстановления любого окна внутри рабочей области Access используются макрокоманды СдвигРазмер, Свернуть, Развернуть, Восстановить. Чтобы передавать любому элементу управления в окне используется КЭлементуУправления.
  • Для вывода на экран информационных сообщений и подачи звуковых сигналов для привлечения внимания к вашим сообщениям используются макрокоманды Сообщение и Сигнал.
  • Для переименования любого объекта базы данных, копирования выбранного объекта в текущую или другую базу данных Access, сохранения или удаления объектов из вашей базы данных используются макрокоманды Переименовать, КопироватьОбъект, Сохранить, УдалитьОбъект. Кроме того, макрокоманды ПреобразоватьБазуДанных, ПреобразоватьЭлектроннуюТаблицу, ПреобразоватьТекст позволяют импортировать, экспортировать или связывать таблицы из других баз данных, импортировать или экспортировать электронные таблицы и текстовые файлы.

Рассмотрим другие возможности макросов. Командные кнопки, которые открывают и размещают формы и устанавливают значения полей, помогут переключаться с одной задачи на другую. Вы можете создать очень сложные процедуры редактирования, проверяющие правильность вводимых в форму данных, включая проверку данных в других таблицах. Например, можно организовать проверку имени клиента, которое вводится в форму заказа, и открывать другую форму, чтобы пользователь вводил дополнительные сведения, если в базе не существует записи с информацией о клиенте.

Макросы особенно полезны для построения небольших персональных приложений или создания прототипов больших приложений. Для сложных приложений или приложений, предназначенных для работы в сети в режиме коллективного пользования, вам скорее всего придется использовать VBA. Но даже если вы считаете, что готовы сразу перейти к VBA, лучше сначала изучить макрокоманды. Вы увидите, что почти все из них придется использовать в VBA. Поэтому изучение макросов – прекрасное введение в программирование в Access в целом.


Создание простого макроса

В окне базы данных перейдите на вкладку Макросы и нажмите кнопку Создать, чтобы открыть окно нового макроса, подобное тому, что показано на рис. 6.14. Верхняя часть окна используется для определения нового макроса, а нижняя предназначена для ввода значений аргументов макрокоманд, включенных в макрос. В верхней части присутствуют по крайней мере два столбца с заголовками Макрокоманда и Примечание. Вы можете увидеть все четыре столбца, показанные на рис. 14, нажав кнопки Имена макросов ( [image] ) и Условия ( [image] ) на панели инструментов.

Рис. 6.14. Окно макроса мСообщение

В правой нижней части окна макроса выводится краткая справка. Содержание сообщения меняется в зависимости от положения курсора в верхней части окна макроса (помните: для получения контекстной справки всегда можно нажать клавишу F1).

В столбце Макрокоманда задается одна из более чем 49 макрокоманд, предоставляемых Access. Если вы щелкните в любой ячейке столбца Макрокоманда, то в правом конце ячейки появится кнопка со стрелкой вниз. Нажатие этой кнопки открывает список макрокоманд.

Чтобы познакомиться с работой окна макроса, выберите в списке макрокоманду Сообщение. Она используется для открытия монопольного окна диалога с сообщением. Это прекрасный способ для вывода в приложении разного рода предупреждающих или информационных сообщений без создания для этого специальной формы.

Столбец Примечание особенно полезен для документирования сложных макросов, содержащих большое число макрокоманд. В столбце Примечание можно вводить дополнительные комментарии, размещая их на пустых строках, не содержащих макрокоманд.

После выбора макрокоманды, такой как Сообщение, Access выведет в нижней части окна макроса ее аргументы.

Как и в случае работы с окнами таблицы и запроса в режиме конструктора, для перехода из верхней части окна макро в нижнюю и обратно вы можете воспользоваться клавишей F6.

Значение аргумента Сообщение представляет собой текст, который Access будет выводить в окне диалога. Аргумент Сигнал задает, будет ли звуковой сигнал сопровождать появление окна диалога. Аргумент Тип позволяет вставить в окно сообщения значок, например красный круг с белым перекрестием. В ячейку аргумента Заголовок вводится текст, который появится в заголовке окна диалога. Используйте в этом макросе установки, приведенные на рис. 6.14. (Полный текст сообщения: База данных «Профконсультант средней школы»).

Перед запуском макрос необходимо сохранить. Выберите команду Файл-> Сохранить (или Файл->Сохранить как/Экспорт). Access откроет окно диалога. Введите имя МакросСообщение и нажмите кнопку ОК, чтобы сохранить макрос.


Проверка работы макроса

Перед запуском макроса неплохо проверить его работу, выполнив макрокоманды в пошаговом режиме. Чтобы начать пошаговую проверку, перейдите в окно базы данных, на вкладке Макросы выделите имя макроса, который вы хотите протестировать, и нажмите кнопку Конструктор. После открытия окна макроса нажмите кнопку По шагам на панели инструментов либо выберите команду Запуск->По шагам.

Теперь после запуска макроса Access будет открывать окно диалога Пошаговое выполнение макроса перед выполнением каждого шага. В этом выводится имя макроса, название макрокоманды, условие ее выполнения и аргументы макрокоманды.

Если в макросе определено более одной макрокоманды, то после первого шага вы вновь вернетесь к окну диалога Пошаговое исполнение макроса, которое покажет следующую готовую к исполнению макрокоманду.

Если во время выполнения макроса в какой-нибудь макрокоманде встретится ошибка, то Access сначала выведет окно диалога, объясняющее ее. Затем появится окно диалога Ошибка макрокоманды с информацией о макрокоманде, вызвавшей ошибку. В этот момент можно нажать только кнопку Прервать и отредактировать макрос, чтобы устранить причину ошибки.

Создание сложного макроса

В Microsoft Access внутри одного макроса вы можете задать несколько макрокоманд и порядок их выполнения. Рассмотрим создание макроса с именем Autoexec. Microsoft Access будет запускать этот макрос при открытии базы данных, в которой он хранится. Чтобы избежать запуска макроса Autoexec, при открытии базы данных можно нажать клавишу shift. В этом макросе определены восемь макрокоманд, автоматически выполняемые Access при открытии этой базы данных. Первая макрокоманда ПесочныеЧасы выводит указатель в виде песочных часов, чтобы показать пользователю, что следующие шаги могут занять несколько секунд. Аргумент Включить вывод следующей макрокоманды ВыводНаЭкран установлен в значение Нет, так что во время выполнения макроса вы не увидите на экране лишних изображений. Третья макрокоманда ЗапускМакроса запускает другой макрос мСообщение. Следующая макрокоманда Открытьформу открывает форму фПрофконсультант. Как показано на рис. 6.15, работу этой макрокоманды определяют четыре аргумента: Имя формы задает открываемую форму, Режим устанавливает режим, в котором форма будет открыта. (Этот аргумент может принимать четыре значения: Форма, Конструктор, Просмотр и Таблица). По умолчанию для аргумента Режим данных устанавливается значение Изменение, разрешающее пользователю добавление, удаление и изменение записей во время работы с формой. (Этот аргумент может принимать следующие значения: Добавление, Изменение и Только чтение.) Для аргумента Режим окна по умолчанию устанавливается значение Обычное. В этом случае форма открывается в режиме, заданном ее свойствами.

Рис. 6.15. Макрос Autoexec, автоматически запускаемый при открытии базы данных

Затем макрокоманда Развернуть увеличивает активное окно до размеров рабочей области Access. Последняя макрокоманда (это снова ПесочныеЧасы) восстанавливает прежний вид указателя мыши, чтобы пользователь знал об окончании работы макроса. Итак, использование в макросе нескольких макрокоманд позволяет автоматизировать задачи, которые приходится выполнять регулярно.


Группы макросов

В большинстве форм, создаваемых для приложения требуется применение значительного числа макрокоманд. Одни используются для редактирования полей, другие открывают отчеты, третьи реагируют на нажатие командных кнопок. Можно создать макросы для каждой отдельной операции, но в этом случае в приложении накопятся сотни различных макросов. Существует более простой способ, при котором для каждой формы или отчета создается своя группа макросов. Возможен также и другой подход, при котором группы макросов создаются для каждого типа операций. Например, можно создать группу макросов, содержащую все макрокоманды ОткрытьФорму, используемые в базе данных. В группу можно включить несколько отдельных макросов. Каждому макросу в группе дается имя, которое заносится в столбец Имя макроса. Как вы уже видели на примере макроса Autoexec, с помощью макрокоманды ЗапускМакроса можно выполнить другой макрос. Точно так же Access выполнит конкретный макрос из группы, если в макрокоманде ЗапускМакроса указать имя группы макросов, точку и имя макроса. В начале группы макросов можно поместить несколько макрокоманд, которые будут выполняться при вызове группы без указания имени макроса. Имя, указанное при сохранении группы, появится в списке макросов в окне базы данных.

Задание условий выполнения макрокоманд

Иногда необходимо, чтобы макрокоманды в макросе выполнялись только при определенных условиях. Например, вы хотите обновлять запись лишь в том случае, если новые данные в элементах управления формы удовлетворяют условиям на значение или хотите выводить или скрывать определенные элементы управления в зависимости от значений других элементов управления.

Рассмотрим макрос мПросмотр, содержащий условия для проверки необходимости выполнения определенных макрокоманд (см. рис. 6.16). Этот макрос запускается с помощью командной кнопки Просмотр в форме фПечать. Эта форма позволяет пользователю просмотреть и распечатать определенный отчет, устанавливая соответствующий переключатель и нажимая кнопки Просмотр и Печать (см. рис. 6.17). Переключатели находятся внутри одного элемента управления, который называется группой. Каждый переключатель устанавливает определенное числовое значение (первый устанавливает 1, второй – 2, третий – 3, четвертый – 4) для этого элемента управления, которое проверяется в столбце Условие.

Рис. 6.16. Условия для макроса мПросмотр

Рис. 6.17. Форма фПечать

При включении условия в макрос Access выполняет макрокоманду в этой строке только в том случае, если условное выражение имеет значение Истина. Ввод многоточия (...) в столбце Условие в последующих строках позволяет распространить действие условия на ряд следующих макрокоманд. В этом случае Access вычисляет условное выражение только один раз и выполняет группу макрокоманд, если условие, заданное для первой макрокоманды в этой группе, является истинным.

В данном случае условия используются для проверки значения группы переключателей Группа0 в форме.

Использование групп макросов позволяет легко находить нужные макросы. Вы можете создавать группы макросов не только по задачам, но и по функциям. Предположим, что имеется форма с рядом командных кнопок, каждой из которых назначен макрос, выполняющий определенную задачу. Вы можете собрать эти макросы в одну группу и дать ей имя, указывающее на связь с формой. Так, если форма Клиенты содержит несколько командных кнопок, то можно создать группу макросов с именем МакросыФормыКлиенты. В эту группу следует включить макросы, назначенные командным кнопкам в этой форме.


6.11. Библиографический список

6.13. Библиографический список

1. Вейскас Д. Эффективная работа с Microsoft Access 7.0 для Windows 95: Пер. с англ. – СПб.:Питер, 1997. – 848 с.

2. Пакеты программ офисного назначения: Учеб. пособие / С.В. Назаров, Л.П. Смольников, В.А. Тафинцев и др.; Под ред. проф. С.В. Назарова. – М.: Финансы и статистика, 1997. – 320 с.

3. Гончаров А. Access 7.0 в примерах – СПб.:Питер, 1997. – 256 с.

4. Винтер П. Microsoft Access 97: справочник. – СПб.: Питер, 1998. – 416 с.

5. Келли Дж. Самоучитель Access 97. – СПб.: Питер, 1999. – 336 с.

6. Робинсон С. Microsoft Access 2000: Учебный курс. – СПб.: Питер, 2000.

7. Microsoft Access 2000: Справочник / Под ред. Ю. Колесникова. – СПб.: Питер, 1999. – 396 с.

8. Стоцкий Ю. Самоучитель Office 2000. – СПб: Изд-во «Питер», 1999. – 576 с.

9. Microsoft Office 2000. Официальный сайт фирмы Microsoft. URL: http://www.microsoft.com/rus/office2000/

10. Русская компьютерная библиотека. URL: http://www.rusdoc.ru

11. MS Access 97 со всех сторон. URL: http://nsa.chat.ru/

12. Московская группа пользователей MS Access URL: http://www.arimsoft.ru/msaccess/rindex.htm

13. MS Access - Books, Magazines and Resources URL: http://ourworld.compuserve.com/homepages/attac-cg/Acgbook.htm

14. Сервер информационных технологий URL: http://www.citforum.ru/


6.11. Глоссарий

6.12. Глоссарий

Атрибут (attribute) – минимальный элемент данных, определяющий некоторое свойство объекта данных, например адрес клиента или зарплата сотрудника. Атрибут обычно хранится в виде поля (столбца) таблицы.

Возрастание (ascending) – направление упорядочивания данных в базе от наименьшего к наибольшему значению в алфавитно-цифровом порядке в соответствии с кодами (ASCII, EBCDIC, Unicode и т.п.) символов, принятыми в системе.

Декларативный язык (declatative language) – язык программирования или манипулирования базой данных. Отличительной особенностью декларативных языков является то, что они описывают последовательность действий, а результат должен быть получен после выполнения программы.

Запрос (query) – предложение, описывающее критерий поиска информации в базе данных.

Импорт (import) – считывание файла, созданного в другой программе, для использования базой данных. Большинство СУБД способно считывать форматы ASCII, DBF, DB и т.п.

Индекс (index) – группа указателей, устанавливающих связь между значениями полей и их адресами. Большинство баз данных поддерживает множественное индексирование базы данных.

Клиент-сервер (client-server) – описывает частный случай распределенной базы данных, где под клиентом понимается фронтальная программа, обеспечивающая взаимодействие с пользователем, а под сервером – тыловая программа, обеспечивающая централизованную обработку данных.

Кортеж (tuple) – строка реляционной таблицы.

Модификация (update) – предложение, описывающее информацию в базе данных, подлежащую изменению.

Объединение – операция объединения информации из нескольких таблиц или запросов на основе совпадающих значений определенных атрибутов. Например, информация о клиентах может быть объединена с данными о заказах по коду клиента.

Отношение (relation) – множество, каждый элемент которого включает значения n атрибутов (1 атрибут – унарное, 2 атрибута – бинарное, n атрибутов – n-арное отношение).

Отчет (report) – документ, представляемый на бумаге или экране, который содержит некоторый набор информации из базы данных.

Реляционная алгебра (relational algebra) – средство процедурного описания запросов к реляционной базе данных. Основными операциями реляционной алгебры являются селекция, соединение и проекция.

Реляционное исчисление (relational calculus) – средство декларативного описания запросов к реляционной алгебре. Запросы описываются с помощью кортежных переменных, одноместных и двухместных предикатов и правильно построенных формул.

Связь – способ, которым информация в одной таблице связывается с данными в другой таблице. Отношения "один-к-одному", "один-ко-многим", "многие-ко-многим".

Селекция (selection) – одноместная операция реляционной алгебры, в результате которой формируется отношение, кортежи которого будут включать кортежи (или только некоторые атрибуты кортежей) исходного отношения, удовлетворяющие определенному логическому условию.

Соединение (join) – двухместная операция реляционной алгебры, в результате которой формируется отношение, кортежи которого включают пары кортежей исходных отношений, атрибуты которых удовлетворяют логическому условию.

Таблица (table) – см. Отношение.

Убывание (descending) – направление упорядочивания данных в базе от наибольшего к наименьшему значению в алфавитно-цифровом порядке в соответствии с кодами (ASCII, EBCDIC, Unicode и т.п.)·символов, принятыми в системе.

Экспорт (export) – запись информации на диск в виде файла, предназначенного для использования в какой-либо другой программе.

Язык QBE (query by example) – язык поиска в базе данных, когда критерий специфицируется в экранной форме, описывающей поля записи.

Язык SQL (structured query language) – язык манипулирования данными, предназначенный для выполнения реляционных запросов и имеющий минимальное количество операций.


MS Access

6.11. Контрольные вопросы

  1. Для чего необходимы базы данных?
  2. Какие основные типы баз данных?
  3. Какие основные этапы разработки приложения?
  4. Для чего используется процесс нормализации?
  5. Из каких компонентов состоит база данных?
  6. Сколько существует способов создания пустой таблицы? Каких?
  7. Что такое "чужой (внешний) ключ"?
  8. Какие основные возможности баз данных?
  9. Что такое запрос к базе?
  10. Какие существуют "отношения" между таблицами?
  11. Что такое вычисляемое поле? Какие операции в нем можно выполнять?
  12. Для чего применяется форма?
  13. Что такое запись?
  14. Что такое поле?
  15. Для чего предназначен Режим конструктора?
  16. Какие бывают фильтры?
  17. Для чего выполняется индексирование баз данных?
  18. Для чего нужен язык SQL?
  19. Какие функции обеспечивают выполнение групповых операций?
  20. Что такое перекрестный запрос?
  21. Какие существуют варианты создания отчетов?
  22. Какие основные в MS Access действия выполняются с помощью макрокоманд?
  23. Как создать простой макрос?


11.1. Алгоритмы и способы их описания

Понятие алгоритма

Для составления программы, предназначенной для решения на ЭВМ какой-либо задачи, требуется составление алгоритма ее решения.

Алгоритм — это точное предписание, которое определяет процесс, ведущий от исходных данных к требуемому конечному результату. Алгоритмами, например, являются правила сложения, умножения, решения алгебраических уравнений, умножения матриц и т.п. Слово алгоритм происходит от algoritmi, являющегося латинской транслитерацией арабского имени хорезмийского математика IX века аль-Хорезми. Благодаря латинскому переводу трактата аль-Хорезми европейцы в XII веке познакомились с позиционной системой счисления, и в средневековой Европе алгоритмом называлась десятичная позиционная система счисления и правила счета в ней.

Применительно к ЭВМ алгоритм определяет вычислительный процесс, начинающийся с обработки некоторой совокупности возможных исходных данных и направленный на получение определенных этими исходными данными результатов. Термин вычислительный процесс распространяется и на обработку других видов информации, например, символьной, графической или звуковой.

Если вычислительный процесс заканчивается получением результатов, то говорят, что соответствующий алгоритм применим к рассматриваемой совокупности исходных данных. В противном случае говорят, что алгоритм неприменим к совокупности исходных данных. Любой применимый алгоритм обладает следующими основными свойствами:

  • результативностью;
  • определенностью;
  • массовостью.

Результативность означает возможность получения результата после выполнения конечного количества операций.

Определенность состоит в совпадении получаемых результатов независимо от пользователя и применяемых технических средств.

Массовость заключается в возможности применения алгоритма к целому классу однотипных задач, различающихся конкретными значениями исходных данных.

Для задания алгоритма необходимо описать следующие его элементы:

  • набор объектов, составляющих совокупность возможных исходных данных, промежуточных и конечных результатов;
  • правило начала;
  • правило непосредственной переработки информации (описание последовательности действий);
  • правило окончания;
  • правило извлечения результатов.

Алгоритм всегда рассчитан на конкретного исполнителя. В нашем случае таким исполнителем является ЭВМ. Для обеспечения возможности реализации на ЭВМ алгоритм должен быть описан на языке, понятном компьютеру, то есть на языке программирования.

Таким образом, можно дать следующее определение программы.

Программа для ЭВМ представляет собой описание алгоритма и данных на некотором языке программирования, предназначенное для последующего автоматического выполнения.


Способы описания алгоритмов

К основным способам описания алгоритмов можно отнести следующие:

  • словесно-формульный;
  • структурный или блок-схемный;
  • с помощью граф-схем;
  • с помощью сетей Петри.

Перед составлением программ чаще всего используются словесно-формульный и блок-схемный способы. Иногда перед составлением программ на низкоуровневых языках программирования типа языка Ассемблера алгоритм программы записывают, пользуясь конструкциями некоторого высокоуровнего языка программирования. Удобно использовать программное описание алгоритмов функционирования сложных программных систем. Так, для описания принципов функционирования ОС использовался Алголоподобный высокоуровневый язык программирования.

При словесно-формульном способе алгоритм записывается в виде текста с формулами по пунктам, определяющим последовательность действий.

Пусть, например, необходимо найти значение следующего выражения:

у = 2а – (х+6).

Словесно-формульным способом алгоритм решения этой задачи может быть записан в следующем виде:

1. Ввести значения а и х.

2. Сложить х и 6.

3. Умножить a на 2.

4. Вычесть из 2а сумму (х+6).

5. Вывести у как результат вычисления выражения.

При блок-схемном описании алгоритм изображается геометрическими фигурами (блоками), связанными по управлению линиями (направлениями потока) со стрелками. В блоках записывается последовательность действий.

Данный способ по сравнению с другими способами записи алгоритма имеет ряд преимуществ. Он наиболее нагляден: каждая операция вычислительного процесса изображается отдельной геометрической фигурой. Кроме того, графическое изображение алгоритма наглядно показывает разветвления путей решения задачи в зависимости от различных условий, повторение отдельных этапов вычислительного процесса и Другие детали.

Оформление программ должно соответствовать определенным требованиям. В настоящее время действует единая система программной документации (ЕСПД), которая устанавливает правила разработки, оформления программ и программной документации. В ЕСПД определены и правила оформления блок-схем алгоритмов (ГОСТ 10.002-80 ЕСПД, ГОСТ 10.003-80 ЕСПД).

Операции обработки данных и носители информации изображаются на схеме соответствующими блоками. Большая часть блоков по построению условно вписана в прямоугольник со сторонами а и b. Минимальное значение а = 10 мм, увеличение а производится на число, кратное 5 мм. Размер b=1,5a. Для от дельных блоков допускается соотношение между а и b, равное 1:2. В пределах одной схемы рекомендуется изображать блоки одинаковых размеров. Все блоки нумеруются. Виды и назначение основных блоков приведены в табл. 1.

Таблица 1. Условные обозначения блоков схем алгоритмов

Наименование
Обозначение

Функции

Процесс

Выполнение операции или группы операций, в результате которых изменяется значение, форма представления или расположение данных.

Ввод-вывод

Преобразование данных в форму, пригодную для обработки (ввод) или отображения результатов обработки (вывод).

Решение

Выбор направления выполнения алгоритма в зависимости от некоторых переменных условий.

Предопределенный процесс

Использование ранее созданных и отдельно написанных программ (подпрограмм).

Документ

Вывод данных на бумажный носитель.

Магнитный диск

Ввод-вывод данных, носителем которых служит магнитный диск.

Пуск-останов

Начало, конец, прерывание процесса обработки данных.

Соединитель

Указание связи между прерванными линиями, соединяющими блоки.

Межстраничный соединитель

Указание связи между прерванными линиями, соединяющими блоки, расположенные на разных листах.

Комментарий

Связь между элементом схемы и пояснением.

Линии, соединяющие блоки и указывающие последовательность связей между ними, должны проводится параллельно линиям рамки. Стрелка в конце линии может не ставиться, если линия направлена слева направо или сверху вниз. В блок может входить несколько линий, то есть блок может являться преемником любого числа блоков. Из блока (кроме логического) может выходить только одна линия. Логический блок может иметь в качестве продолжения один из двух блоков, и из него выходят две линии. Если на схеме имеет место слияние линий, то место пересечения выделяется точкой. В случае, когда одна линия подходит к другой и слияние их явно выражено, точку можно не ставить.

Схему алгоритма следует выполнять как единое целое, однако в случае необходимости допускается обрывать линии, соединяющие блоки.

Если при обрыве линии продолжение схемы находится на этом же листе, то на одном и другом конце линии изображается специальный символ соединитель — окружность диаметром 0,5 а. Внутри парных окружностей указывается один и тот же идентификатор. В качестве идентификатора, как правило, используется порядковый номер блока, к которому направлена соединительная линия.

Если схема занимает более одного листа, то в случае разрыва линии вместо окружности используется межстраничный соединитель. Внутри каждого, соединителя указывается адрес — откуда и куда направлена соединительная линия. Адрес записывается в две строки: в первой указывается номер листа, во второй — порядковый номер блока.

Блок-схема должна содержать все разветвления, циклы и обращения к подпрограммам, содержащиеся в программе.


Структурные схемы алгоритмов

Одним из свойств алгоритма является дискретность — возможность расчленения процесса вычислений, предписанных алгоритмом, на отдельные этапы, возможность выделения участков программы с определенной структурой. Можно выделить и наглядно представить графически три простейшие структуры:

  • последовательность двух или более операций;
  • выбор направления;
  • повторение.

Любой вычислительный процесс может быть представлен как комбинация этих элементарных алгоритмических структур. Соответственно, вычислительные процессы, выполняемые на ЭВМ по заданной программе, можно разделить на три основных вида:

  • линейные;
  • ветвящиеся;
  • циклические.

Линейным принято называть вычислительный процесс, в котором операции выполняются последовательно, в порядке их записи. Каждая операция является самостоятельной, независимой от каких-либо условий. На схеме блоки, отображающие эти операции, располагаются в линейной последовательности.

Линейные вычислительные процессы имеют место, например, при вычислении арифметических выражений, когда имеются конкретные числовые данные и над ними выполняются соответствующие условию задачи действия. На рис. 11.1, а показан пример линейного алгоритма, определяющего процесс вычисления арифметического выражения

у=(b2-ас):(а+с).

а | б

Рис. 11.1. Примеры алгоритмов: а) линейный алгоритм; б) ветвящийся алгоритм

Вычислительный процесс называется ветвящимся, если для его реализации предусмотрено несколько направлений (ветвей). Каждое отдельное направление процесса обработки данных является отдельной ветвью вычислений. Ветвление в программе — это выбор одной из нескольких последовательностей команд при выполнении программы. Выбор направления зависит от заранее определенного признака, который может относиться к исходным данным, к промежуточным или конечным результатам. Признак характеризует свойство данных и имеет два или более значений.

Ветвящийся процесс, включающий в себя две ветви, называется простым, более двух ветвей — сложным. Сложный ветвящийся процесс можно представить с помощью простых ветвящихся процессов.

Направление ветвления выбирается логической проверкой, в результате которой возможны два ответа: «да» — условие выполнено и «нет» — условие не выполнено.

Следует иметь в виду, что, хотя на схеме алгоритма должны быть показаны все возможные направления вычислений в зависимости от выполнения определенного условия (или условий), при однократном прохождении программы процесс реализуется только по одной ветви, а остальные исключаются. Любая ветвь, по которой осуществляются вычисления, должна приводить к завершению вычислительного процесса.

На рис. 11.1,б показан пример алгоритма с разветвлением для вычисления следующего выражения:

Y = (а+b), если Х <0;

с/b, если Х>0.

Циклическими называются программы, содержащие циклы. Цикл — это многократно повторяемый участок программы.

В организации цикла можно выделить следующие этапы:

  • • подготовка (инициализация) цикла (И);
  • • выполнение вычислений цикла (тело цикла) (Т);
  • • модификация параметров (М);
  • • проверка условия окончания цикла (У).

Порядок выполнения этих этапов, например, Т и М, может изменяться. В зависимости от расположения проверки условия окончания цикла различают циклы с нижним и верхним окончаниями (рис. 11.2). Для цикла с нижним окончанием (рис. 11.2, а) тело цикла выполняется как минимум один раз, так как сначала производятся вычисления, а затем проверяется условие выхода из цикла. В случае цикла с верхним окончанием (рис. 11.2, б) тело цикла может не выполниться ни разу в случае, если сразу соблюдается условие выхода.

а | б

Рис. 11.2. Примеры циклических алгоритмов

Цикл называется детерминированным, если число повторений тела цикла заранее известно или определено. Цикл называется итерационным, если число повторений тела цикла заранее неизвестно, а зависит от значений параметров (некоторых переменных), участвующих в вычислениях.

На рис. 11.3 показан пример циклического алгоритма вычисления суммы десяти чисел.

Рис. 11.3. Алгоритм нахождения суммы 10-ти чисел


11.2. Этапы подготовки и решения задач на ЭВМ

На ЭВМ могут решаться задачи различного характера, например: научно-инженерные; разработки системного программного обеспечения; обучения; управления производственными процессами и т. д. В процессе подготовки и решения на ЭВМ научно -инженерных задач можно выделить следующие этапы:

  • постановка задачи;
  • математическое описание задачи;
  • выбор и обоснование метода решения;
  • алгоритмизация вычислительного процесса;
  • составление программы;
  • отладка программы;
  • решение задачи на ЭВМ и анализ результатов.

В задачах другого класса некоторые этапы могут отсутствовать, например, в задачах разработки системного программного обеспечения отсутствует математическое описание. Перечисленные этапы связаны друг с другом. Например, анализ результатов может показать необходимость внесения изменений в программу; алгоритм или даже в постановку задачи. Для уменьшения числа подобных изменений необходимо на каждом этапе по возможности учитывать требования, предъявляемые последующими этапами. В некоторых случаях связь между различными этапами, например, между постановкой задачи и выбором метода решения, между составлением алгоритма и программированием, может быть настолько тесной, что разделение их становится затруднительным.

Постановка задачи. На данном этапе формулируется цель решения задачи и подробно описывается ее содержание. Анализируются характер и сущность всех величин, используемых в задаче, и определяются условия, при которых она решается. Корректность постановки задачи является важным моментом, так как от нее в значительной степени зависят другие этапы.

Математическое описание задачи. Настоящий этап характеризуется математической формализацией задачи, при которой существующие соотношения между величинами, определяющими результат, выражаются посредством математических формул. Так формируется математическая модель явления с определенной точностью, допущениями и ограничениями. При этом в зависимости от специфики решаемой задачи могут быть использованы различные разделы математики и других дисциплин. |

Математическая модель должна удовлетворять по крайней мере двум требованиям: реалистичности и реализуемости. Под реалистичностью понимается правильное отражение моделью наиболее существенных черт исследуемого явления.

Реализуемость достигается разумной абстракцией, отвлечением от второстепенных деталей, чтобы свести задачу к проблеме с известным решением. Условием реализуемости является возможность практического выполнения необходимых вычислений за отведенное время при доступных затратах требуемых ресурсов.

Выбор и обоснование метода решения. Модель решения задачи с учетом ее особенностей должна быть доведена до решения при помощи конкретных методов решения. Само по себе математическое описание задачи в большинстве случаев трудно перевести на язык машины. Выбор и использование метода решения задачи позволяет привести решение задачи к конкретным машинным операциям. При обосновании выбора метода необходимо учитывать различные факторы и условия, в том числе точность вычислений, время решения задачи на ЭВМ, требуемый объем памяти и другие.

Одну и ту же задачу можно решить различными методами, при этом в рамках каждого метода можно составить различные алгоритмы.

Алгоритмизация вычислительного процесса. На данном этапе составляется алгоритм решения задачи согласно действиям, задаваемым выбранным методом решения. Процесс обработки данных разбивается на отдельные относительно самостоятельные блоки, и устанавливается последовательность выполнения блоков. Разрабатывается блок-схема алгоритма.

Составление программы. При составлении программы алгоритм решения задачи переводится на конкретный язык программирования. Для программирования обычно используются языки высокого уровня, поэтому составленная программа требует перевода ее на машинный язык ЭВМ. После такого перевода выполняется уже соответствующая машинная программа.

Отладка программы. Отладка заключается в поиске и устранении синтаксических и логических ошибок в программе.

В ходе синтаксического контроля программы транслятором выявляются конструкции и сочетания символов, недопустимые с точки зрения правил их построения или написания, принятых в данном языке. Сообщения об ошибках ЭВМ выдает программисту, при этом вид и форма выдачи подобных сообщений зависят от вида языка и версии используемого транслятора.

После устранения синтаксических ошибок проверяется логика работы программы в процессе ее выполнения с конкретными исходными данными. Для этого используются специальные методы, например, в программе выбираются контрольные точки, для которых вручную рассчитываются промежуточные результаты. Эти результаты сверяются со значениями, получаемыми ЭВМ в данных точках при выполнении отлаживаемой программы. Кроме того, для поиска ошибок могут быть использованы отладчики, выполняющие специальные действия на этапе отладки, например, удаление, замена или вставка отдельных операторов или целых фрагментов программы, вывод или изменение значений заданных переменных.

Решение задачи на ЭВМ и анализ результатов. После отладки программы ее можно использовать для решения прикладной задачи. При этом обычно выполняется многократное решение задачи на ЭВМ для различных наборов исходных данных. Получаемые результаты интерпретируются и анализируются специалистом или пользователем, поставившим задачу.

Разработанная программа длительного использования устанавливается на ЭВМ, как правило, в виде готовой к выполнению машинной программы. К программе прилагается документация, включая инструкцию для пользователя.

Чаще всего при установке программы на диск для ее последующего использования помимо файлов с исполняемым кодом устанавливаются различные вспомогательные программы (утилиты, справочники, настройщики и т. д.), а также необходимые для работы программ разного рода файлы с текстовой, графической, звуковой и другой информацией.


11.3. Компиляция и интерпретация программ

ЭВМ непосредственно выполняет программы на машинном языке программирования данной ЭВМ. При этом программа представляет собой набор отдельных команд компьютера. Эти команды являются достаточно «простыми», например, сложение, умножение, сравнение или пересылка отдельных данных. Каждая команда содержит в себе сведения о том, какая операция должна быть выполнена (код операции), с какими операндами (адреса данных или непосредственно сами данные) выполняются вычисления и куда (адрес) должен быть помещен результат.

Машинные языки были первыми языками программирования. Программирование на них затруднительно ввиду того, что, во-первых, эти языки различны для каждого типа ЭВМ, во-вторых, являются трудоемкими для большинства пользователей по причине необходимости знания особенностей конкретной ЭВМ и большого количества реализуемых ею операций (команд). Данные языки обычно используются для разработки системных программ, при этом чаще всего применяются специальные символические языки — Ассемблеры, близкие к соответствующим машинным языкам.

Человеку свойственно формулировать и решать задачи в выражениях более общего характера, чем команды ЭВМ. Поэтому с развитием программирования появились языки, ориентированные на более высокий уровень абстракции при описании решаемой на ЭВМ задачи. Эти языки получили название языков высокого уровня. Их теоретическую основу составляют алгоритмические языки, например, Паскаль, Си, Бейсик, Фортран, PL/1.

Для перевода программы, написанной на языке высокого уровня, в соответствующую машинную программу используются языковые процессоры. Различают два вида языковых процессоров: интерпретаторы и трансляторы.

Интерпретатор — это программа, которая получает исходную программу и по мере распознавания конструкций входного языка реализует действия, описываемые этими конструкциями.

Транслятор — это программа, которая принимает исходную программу и порождает на своем выходе программу, записываемую на объектном языке программирования (объектную программу). В частном случае объектным может служит машинный язык, и в этом случае полученную на выходе транслятора программу можно сразу же выполнить на ЭВМ. В общем случае объектный язык необязательно должен быть машинным или близким к нему (автокодом). В качестве объектного языка может служить и некоторый промежуточный язык.

Для промежуточного языка может быть использован другой транслятор или интерпретатор — с промежуточного языка на машинный. Транслятор, использующий в качестве входного язык, близкий к машинному (автокод или язык Ассемблера) традиционно называют Ассемблером.

Транслятор с языка высокого уровня называют компилятором.


11.4. Стили программирования

Одним из важнейших признаков классификации языков программирования является принадлежность их к одному из стилей, основными из которых являются следующие: процедурный, функциональный, логический и объектно-ориентированный.

Процедурное программирование

Процедурное (императивное) программирование является отражением архитектуры традиционных ЭВМ, которая была предложена фон Нейманом в 40-х годах. Теоретической моделью процедурного программирования служит алгоритмическая система под названием «машина Тьюринга».

Программа на процедурном языке программирования состоит из последовательности операторов (инструкций), задающих процедуру решения задачи. Основным является оператор присваивания, служащий для изменения содержимого областей памяти. Концепция памяти как хранилища значений, содержимое которого может обновляться операторами программы, является фундаментальной в императивном программировании.

Выполнение программы сводится к последовательному выполнению операторов с целью преобразования исходного состояния памяти, то есть значений исходных данных, в заключительное, то есть в результаты. Таким образом, с точки зрения программиста имеются программа и память, причем первая последовательно обновляет содержимое последней.

Процедурные языки характеризуются следующими особенностями:

  • необходимостью явного управления памятью, в частности, описанием переменных;
  • малой пригодностью для символьных вычислений;
  • отсутствием строгой математической основы;
  • высокой эффективностью реализации на традиционных ЭВМ.

Одним из важнейших классификационных признаков процедурного языка является его уровень. Уровень языка программирования определяется семантической (смысловой) емкостью его конструкций и степенью его ориентации на программиста. Язык программирования частично ликвидирует разрыв между методами решения различного рода задач человеком и вычислительной машиной. Чем более язык ориентирован на человека, тем выше его уровень. Дадим краткую характеристику реализованным на ПЭВМ языкам программирования в порядке возрастания их уровня.

Двоичный язык является непосредственно машинным языком. В настоящее время такие языки программистами практически не применяются.

Язык Ассемблера — это язык, предназначенный для представления в удобочитаемой символической форме программ, записанных на машинном языке. Он позволяет программисту пользоваться мнемоническими кодами операций, присваивать удобные имена ячейкам и областям памяти, а также задавать наиболее удобные схемы адресации.

Язык Макроассемблера является расширением языка Ассемблера путем включения в него макросредств. С их помощью в программе можно описывать последовательности инструкций с параметрами — макроопределения. После этого программист может использовать снабженные аргументами макрокоманды, которые в процессе ассемблирования программы автоматически замещаются макрорасширениями. Макрорасширение представляет собой макроопределение с подставленными вместо параметров аргументами.

Другими словами, язык Макроассемблера представляет средства определения и использования новых, более мощных команд как последовательности базовых инструкций, что несколько повышает его уровень.

Языки Ассемблера и Макроассемблера применяются системными программистами-профессионалами с целью использования всех возможностей оборудования ЭВМ и получения эффективной по времени выполнения и по требуемому объему памяти программы. На этих языках обычно разрабатываются относительно небольшие программы, входящие в состав системного программного обеспечения: драйверы, утилиты и другие.

Язык программирования С (Си) первоначально был разработан для реализации операционной системы UNIX в начале 70-х годов. В последующем приобрел высокую популярность среди системных и прикладных программистов. В настоящее время этот язык реализован на большинстве ЭВМ.

В С сочетаются достоинства современных высокоуровневых языков в части управляющих конструкций и структур данных с возможностями доступа к аппаратным средствам ЭВМ на уровне, который обычно ассоциируется с языком низкого уровня типа языка Ассемблера. Язык С имеет синтаксис, обеспечивающий краткость программы, а компиляторы способны генерировать эффективный объектный код.

Одна из наиболее существенных особенностей С состоит в нивелировании различий между выражениями и операторами, что приближает его к функциональным языкам. В частности, выражение может обладать побочным эффектом присваивания, а также может использоваться в качестве оператора. Нет также четкой границы между процедурами и функциями, более того, понятие процедуры не вводится вообще.

Синтаксис языка затрудняет программирование и восприятие составленных программ. Отсутствует и строгая типизация данных, что предоставляет дополнительные возможности программисту, но не способствует написанию надежных программ.

Ваsic(Бэйсик) (Beginners All-purpose Symbolic Instruction Code) — многоцелевой язык символических инструкций для начинающих) представляет собой простой язык программирования, разработанный в 1964 году для использования новичками. Он был разработан как простейший язык для непосредственного общения человека с вычислительной машиной. Поэтому первоначально работа велась в интерактивном режиме с использованием интерпретаторов. В настоящее время для этого языка имеются также и компиляторы.

Согласно концепциям, заложенным в Basic, этот язык в смысле строгости и стройности является антиподом языка Pascal. В частности, в нем широко распространены различные правила умолчания, что считается плохим тоном в большинстве языков программирования подобного типа.

Basic широко распространен на ЭВМ различных типов и очень популярен в среде программистов, особенно начинающих. Существует множество диалектов этого языка, мало совместимых между собой. Basic активно поглощает многие концепции и новинки из других языков. Поэтому он достаточно динамичен, и нельзя однозначно определить его уровень.

Pascal (Паскаль) является одним из наиболее популярных среди прикладных программистов процедурным языком программирования, особенно для ПЭВМ. Разработанный в 1970 году швейцарским специалистом в области вычислительной техники профессором Н. Виртом, язык назван в честь французского математика и по замыслу автора предназначался для обучения программированию. Однако язык получился настолько удачным, что стал одним из основных инструментов прикладных и системных программистов при решении задач вычислительного и информационно-логического характера. В 1979 году был подготовлен проект описания языка — Британский стандарт языка программирования Pascal BS6192, который стал также и международным стандартом ISO 7185.

В языке Pascal реализован ряд концепций, рассматриваемых как основа «дисциплинированного» программирования и заимствованных впоследствии разработчиками многих языков. Одним из существенных признаков языка Pascal является последовательная и достаточно полная реализация концепции структурного программирования. Причем это осуществляется не только путем упорядочивания связей между фрагментами программы по управлению, но и за счет структуризации данных. Кроме того, в языке реализована концепция определения новых типов данных на основе уже имеющихся. Этот язык, в отличие от языка С, является строго типизированным. Pascal характеризуется:

  • высоким уровнем;
  • широкими возможностями;
  • стройностью, простотой и краткостью;
  • строгостью, способствующей написанию эффективных и надежных программ;
  • высокой эффективностью реализации на ЭВМ.

Pascal реализован на ЭВМ различных типов, но наиболее распространен и развит для ПЭВМ. В настоящее время широко используются такие версии этого языка для ПЭВМ, как Borland Pascal и Turbo Pascal.


Функциональное программирование

Сущность функционального (аппликативного) программирования определена А. П. Ершовым как «... способ составления программ, в которых единственным действием является вызов функции, единственным способом расчленения программы на части является введение имени для функции, а единственным правилом композиции — оператор суперпозиции функции. Никаких ячеек памяти, ни операторов присваивания, ни циклов, ни, тем более, блок-схем, ни передачи управления».

Роль основной конструкции в функциональных языках играет выражение: К выражениям относятся скалярные константы, структурированные объекты, функции, тела функций и вызовы функций. Функция трактуется как однозначное отображение из X в X, где X — множество выражений.

Аппликативный язык программирования включает следующие элементы:

  • классы констант, которыми могут манипулировать функции;
  • набор базовых функций, которые программист может использовать без предварительного объявления и описания;
  • правила построения новых функций из базовых;
  • правила формирования выражений на основе вызовов функций.

Программа представляет собой совокупность описаний функций и выражения, которые необходимо вычислить. Данное выражение вычисляется посредством редукции, то есть серии упрощений, до тех пор, пока это возможно по следующим правилам: вызовы базовых функций заменяются соответствующими значениями; вызовы не базовых функций заменяются их телами, в которых параметры замещены аргументами.

Функциональное программирование не использует концепцию памяти как хранилища значений переменных. Операторы присваивания отсутствуют, вследствие чего переменные обозначают не области памяти, а объекты программы, что полностью соответствует понятию переменной в математике. В принципе, можно составлять программы и вообще без переменных. Кроме того, нет существенных различий между константами и функциями, то есть между программами и данными. В результате этого функция может быть значением вызова другой функции и может быть элементом структурированного объекта. Число аргументов при вызове функции не обязательно должно совпадать с числом параметров, указанных при ее описании. Перечисленные свойства характеризуют аппликативные языки как языки программирования очень высокого уровня.

Первым таким языком был LISP(Лисп) (LISt Processing — обработка списков), созданный в 1959 году. Цель его создания состояла в организации удобства обработки символьной информации. Существенная черта этого языка — унификация программных структур и структур данных: все выражения записываются в виде списков.


Логическое программирование

Новую область — логическое, или реляционное программирование, — открыло появление языка PROLOG (Пролог) (PROgramming in LOGic — программирование в терминах логики). Этот язык был создан французским ученым А. Кольмероэ в 1973 году. В настоящее время известны и другие языки, однако наиболее развитым и распространенным языком логического программирования является именно Пролог. Так, имеется свыше 15 различных его реализаций на ПЭВМ. Языки логического программирования, в особенности Пролог, широко используются в системах искусственного интеллекта, рассматриваемых в данном учебном пособии.

Центральным понятием в логическом программировании является отношение. Программа представляет собой совокупность определений отношений между объектами (в терминах условий или ограничений) и цели (запроса). Процесс выполнения программы трактуется как процесс общезначимости логической формулы, построен- ной из программы по правилам, установленным семантикой используемого языка. Результат вычисления является побочным продуктом этого процесса. В реляционном программировании нужно только специфицировать факты, на которых алгоритм основывается, а не определять последовательность шагов, которые требуется выполнить. Это свидетельствует о декларативности языка логического программирования. Она метко выражена в формуле Р. Ковальского: «алгоритм = логика + управление». Языки логического программирования характеризуются:

  • высоким уровнем;
  • строгой ориентацией на символьные вычисления;
  • возможностью инверсных вычислений, то есть переменные в процедурах не делятся на входные и выходные;
  • возможной логической неполнотой, поскольку зачастую невозможно выразить в программе определенные логические соотношения, а также невозможно получить из программы все выводы правильные.

Логические программы, в принципе, имеют небольшое быстродействие, так как вычисления осуществляются методом проб и ошибок, поиском с возвратами к предыдущим шагам.


Объектно-ориентированное программирование

Прототипом объектно-ориентированного программирования послужил ряд средств, входящих в состав языка SIMULA-67. Но в самостоятельный стиль оно оформилось с появлением языка SMALLTALK, разработанного А. Кеем в 1972 году и первоначально предназначенного для реализации функций машинной графики.

В основе объектно-ориентированного стиля программирования лежит понятие объекта, а суть его выражается формулой: «объект - данные + процедуры». Каждый объект интегрирует в себе некоторую структуру данных и доступные только ему процедуры обработки этих данных, называемые методами. Объединение данных и процедур в одном объекте называется инкапсуляцией и присуще объектно-ориентированному программированию.

Для описания объектов служат классы. Класс определяет свойства и методы объекта, принадлежащего этому классу. Соответственно, любой объект можно определить как экземпляр класса.

Программирование рассматриваемого стиля заключается в выборе имеющихся или создании новых объектов и организации взаимодействия между ними. При создании новых объектов свойства объектов могут добавляться или наследоваться от объектов-предков. В процессе работы с объектами допускается полиморфизм — возможность использования методов с одинаковыми именами для обработки данных разных типов.

К наиболее современным объектно-ориентированным языкам программирования относятся C++ и Java.

Язык C++ был разработан в начале 80-х годов Б. Страуструпом, сотрудником лаборатории Bell корпорации AT&T. Им была создана компактная компилирующая система, в которой за основу был взят язык С, дополненный элементами языков BCPL, Simula-67 и Algol-68. К июлю 1983 года появился язык С с классами, а чуть позднее — C++. К 1990 году была выпущена третья версия языка C++, принятая комитетом ANSI в качестве исходного материала для его стандартизации.

В 1990 году сотрудник корпорации Sun Д. Гослинг на основе расширения C++ разработал объектно-ориентированный язык Oak, основным достоинством которого было обеспечение сетевого взаимодействия различных по типу устройств. Новая интегрируемая в Internet версия языка, получила название Java. Первый броузер, который поддерживал язык Java, разработан программистом корпорации Sun П. Нафтоном и получил название HotJava. С января 1995 года Java получает распространение в Internet.

Согласно официальному определению авторов, Java является простым объектно-ориентированным и архитектурно-нейтральным языком интерпретирующего типа, обеспечивающим надежность, безопасность и переносимость, обладающим высокой производительностью в сочетании с многопоточностью и динамичностью.

Принципиальной разницей между Java и C++ является то, что первый из них является интерпретируемым, а второй – компилируемым. Синтаксис языков практически полностью совпадает.

С точки зрения возможностей собственно объектно-ориентированных средств язык Java обладает рядом преимуществ перед языком C++. Так, язык Java демонстрирует более гибкую и мощную систему инкапсуляции информации. Механизм наследования, реализованный в Java, обязывает к более строгому подходу к программированию, что улучшает надежность и понимаемость кода. Язык же C++ обладает сложной, неадекватной и трудной для понимания системой наследования. Возможности динамического связывания объектов одинаково хорошо представлены в обоих языках, однако, синтаксическая избыточность C++ заставляет и здесь отдать предпочтение языку Java.

В силу своей конструктивности идеи объектно-ориентированного программирования используются во многих универсальных процедурных языках. Так, например, в состав интегрированной системы программирования на языке PASCAL (корпорации Borland International) версии 5.5 входит специальная библиотека объектно-ориентированного программирования Turbo Vision.

В последнее время многие программы, в особенности объектно-ориентированные, реализуются как системы визуального программирования. Отличительной особенностью таких систем является мощная среда разработки программ из готовых «строительных блоков», позволяющая создать интерфейсную часть программного продукта в диалоговом режиме, практически без кодирования программных операций. К числу объектно-ориентированных систем визуального программирования относятся; Visual Basic, Delphi, C++Builder и Visual C++.


11.6. Глоссарий

Алгоритм – формализованная последовательность действий, необходимая для решения конкретной задачи.

Блок-схема – способ графического представления алгоритма.

Идентификатор – обозначение (имя) программной переменной, принятое для обращения к ней в программе, написанной на языке программирования высокого уровня.

Интерпретатор переводит каждую команду программы с одновременным её выполнением и, если обнаруживает ошибку, сообщает о ней и прекращает выполнение программы.

Компилятор переводит всю программу целиком и в конце работы выдаёт список ошибок, если они обнаружены.

Константы – данные, значение которых не меняется во время работы программы.

Переменная – объект в программе, значение которого изменяется самой программой.

Программа – упорядоченная последовательность команд, необходимых компьютеру для решения поставленной задачи.

Процедура – программа, описывающая алгоритм получения некоторого простейшего объекта, который может использоваться для создания сложных объектов.

Рекуррентное соотношение – это формула, в которой очередной член последовательности выражается через один или несколько предыдущих членов.

Фактический параметр – конкретное значение (например, число) формального параметра, которое указывается в команде вызова процедуры.

Формальный параметр – параметр, не имеющий конкретного указанного в теле процедуры значения.

Цикл – это многократное повторение одного или нескольких действий, которые называются телом цикла.


11.7. Библиографический список

1. Аверьянов Г.Я., Рошаль А. С. Элементы информатики: Учебное пособие.— М.:МИ-ФИ, 1995.-175 с.

2. Богумирскш Б. С. Руководство пользователя ПЭВМ: в 2-х частях,—Санкт-Петербург: Ассоциация OILCO, 1992. - 735 с.

3. ГОСТ 19.002-80 ЕСПД.

4. ГОСТ 19.003-80 ЕСПД.

5. Дворкин П. Л. Основы информатики и вычислительной техники: Учебное пособие .— Омск.: ОПИ, 1988. -119с.

6. Иванов Н. C++ или Java // Мир Internet, № 1,1997. - С. 42-49.

7. Информатика* Энциклопедический словарь для начинающих/Сост. Д. А. Поспелов — М.: Педагогика — Пресс, 1994. — 352 с.

8. Компьютерные технологии обработки информации: Учебное пособие /С. В. Назаров, В. И. Першинов, В. А. Тафинцев и др.; Под ред. С. В. Назарова. — М.: Финансы и статистика, 1995. — 248 с.

9. Основные понятия информатики и вычислительной техники: Методические материалы. — Новосибирск, 1990. — 123 с.

10. Основы компьютерной грамоты / А. Н.Жигарев, Н. В. Макарова, М. А. Путинце-ва; Под общ. ред. Н. В. Макаровой. — Л.: Машиностроение, 1987. — 255 с.

11. Программирование. Учебник под ред. Свердлика А. Н., МО СССР, 1992. — 608 с.

12. Ростовцев Ю. Г. Основы построения автоматизированных систем сбора и обработки информации: Учебник. — СПб.: ВИККА им. А. Ф. Можайского, 1992. — 717 с.

13. Трудов Ю. В. Основы построения ЭВМ. Часть 1. Теоретические основы, элементы и узлы ЭВМ: Учебное пособие. - Л.: ВИКИ им. А. Ф. Можайского, 1990. - 216 с.

14. Шафрин Ю. А. Основы компьютерных технологий. Уч. Пособие для 7-11 классов по курсу «Информатика и вычислительная техника». — М.: ABF, 1996. ~ 560 с.

15. Шоу А. Логическое проектирование операционных систем: Пер. с англ. — М.: Мир, 1981.-360 с.


11.5. Контрольные вопросы

  1. Что такое информация, сигнал, сообщение, данные? Дайте определение.
  2. Назовите основные формы представления информации.
  3. Что такое количество информации, в каких единицах оно измеряется?
  4. Дайте общую характеристику процессов сбора, обработки и передачи информации.
  5. Как соотносятся понятия «Информационная техника» и «информационная технология»?
  6. Что такое архитектура ЭВМ?
  7. Перечислите основные устройства ЭВМ и дайте им краткую характеристику.
  8. Назовите основные технико-эксплуатационные характеристики ЭВМ.
  9. Представьте десятичное число -113 двоичным восьмиразрядным прямым, обратным и дополнительным кодами.
  10. Числа -24.75(10) и 18.625{10) представьте последовательно в шестнадцатеричной и двоичной системах. Выполните сложение и вычитание этих чисел в обратном и дополнительном кодах. Переведите полученные результаты в десятичную систему счисления.
  11. Запишите свою фамилию, имя, отчество и год рождения в коде ДКОИ.
  12. Дайте классификацию видов ПО.
  13. Что такое алгоритм и какими свойствами он обладает?
  14. Укажите способы описания алгоритмов.
  15. Назовите этапы подготовки и решения задач на ЭВМ.
  16. Что такое компиляция и интерпретация программ?
  17. Охарактеризуйте основные стили программирования.


9.1. Основы архивации данных

Как хранение, так и передача информации обходятся участникам информационного процесса недешево. Зная стоимость носителя и его емкость (Мбайт, Гбайт), нетрудно подсчитать, во что обходится хранение единицы информации, а зная пропускную способность канала связи (Мбит/с) и стоимость его аренды, можно определить затраты на передачу единицы информации. Полученные результаты обычно составляют вполне значимые величины как для корпоративных пользователей, так и для индивидуальных. В связи с этим, регулярно возникает необходимость сжимать данные перед тем, как размещать их в архивах или передавать по каналам связи. Соответственно, существует и обратная необходимость восстановления данных из предварительно уплотненных архивов.

Теоретические основы сжатия данных

Характерной особенностью большинства «классических» типов данных, с которыми традиционно работают люди, является определенная избыточность. Степень избыточности зависит от типа данных. Например, у видеоданных степень избыточности обычно в несколько раз больше, чем у графических данных, а степень избыточности графических данных в несколько раз больше, чем текстовых. Кроме того, степень избыточности данных зависит от принятой системы кодирования. Так, например, можно сказать, что кодирование текстовой информации средствами русского языка (с использованием русской азбуки) дает в среднем избыточность на 20-30% больше, чем кодирование адекватной информации средствами английского языка.

Для человека избыточность информации нередко связана с представлением о ее качестве, поскольку избыточность, как правило, улучшает восприятие, особенно в неблагоприятных условиях (просмотр телепередач при наличии помех, восстановление поврежденного графического материала, чтение текстов в условиях недостаточной освещенности и т. п.).

При обработке информации избыточность также играет важную роль. Так, например, при преобразовании или селекции информации избыточность используют для повышения ее качества (репрезентативности, актуальности, адекватности и т. п.). Однако, когда речь заходит не об обработке, а о хранении готовых документов или их передаче, то избыточность можно уменьшить, что дает эффект сжатия данных.

Если методы сжатия информации применяют к готовым документам, то нередко термин сжатие данных подменяют термином архивация данных, а программные средства, выполняющие эти операции, называют архиваторами.


Объекты сжатия

В зависимости от того, в каком объекте размещены данные, подвергаемые сжатию, различают:

  • уплотнение (архивацию) файлов;
  • уплотнение (архивацию) папок;
  • уплотнение дисков.

Уплотнение файлов применяют для уменьшения их размеров при подготовке к передаче по каналам электронных сетей или к транспортировке на внешнем носителе малой емкости, например на гибком диске.

Уплотнение папок используют как средство архивации данных перед длительным хранением, в частности, при резервном копировании.

Уплотнение дисков служит целям повышения эффективности использования их рабочего пространства и, как правило, применяется к дискам, имеющим недостаточную емкость.


Обратимость сжатия

Несмотря на изобилие алгоритмов сжатия данных, теоретически есть только три способа уменьшения их избыточности. Это либо изменение содержания данных, либо изменение их структуры, либо и то и другое вместе.

Если при сжатии данных происходит изменение их содержания, метод сжатия необратим и при восстановлении данных из сжатого файла не происходит полного восстановления исходной последовательности. Такие методы называют также методами сжатия с регулируемой потерей информации. Они применимы только для тех типов данных, для которых формальная утрата, части содержания не приводит к значительному снижению потребительских свойств. В первую очередь, это относится к мультимедийным данным: видеорядам, музыкальным записям, звукозаписям и рисункам. Методы сжатия с потерей информации обычно обеспечивают гораздо более высокую степень сжатия, чем обратимые методы, но их нельзя применять к текстовым документам, базам данных и, тем более, к программному коду.

Характерными форматами сжатия с потерей информации являются:

  • .JPG для графических данных;
  • .MPG для видеоданных;
  • .МРЗ для звуковых данных.

Если при сжатии данных происходит только изменение их структуры, то метод сжатия обратим. Из результирующего кода можно восстановить исходный массив путем применения обратного метода. Обратимые методы применяют для сжатия любых типов данных.

Характерными форматами сжатия без потери информации являются:

  • .GIF, .TIP, .PCX и многие другие для графических данных;
  • .AVI для видеоданных;
  • .ZIP, .ARJ, .RAR, .LZH, .LH, .CAB и многие другие для любых типов данных.


Алгоритмы обратимых методов

При исследовании методов сжатия данных следует иметь в виду существование следующих доказанных теорем.

1. Для любой последовательности данных существует теоретический предел сжатия, который не может быть превышен без потери части информации.

2. Для любого алгоритма сжатия можно указать такую последовательность данных, для которой он обеспечит лучшую степень сжатия, чем другие методы.

3. Для любого алгоритма сжатия можно указать такую последовательность данных, для которой данный алгоритм вообще не позволит получить сжатия.

Таким образом, обсуждая различные методы сжатия, следует иметь в виду, что наивысшую эффективность они демонстрируют для данных разных типов и разных объемов.

Существует достаточно много обратимых методов сжатия данных, однако в их основе лежит сравнительно небольшое количество теоретических алгоритмов, представленных в следующей таблице:

Алгоритм | Выходная структура | Сфера применения | Примечание
RLE(Run Length Encoding) | Список (вектор данных) | Графические данные | Эффективность алгоритма не зависит от объема данных
KWE (Keyword Encoding) | Таблица данных (словарь) | Текстовые данные | Эффективность алгоритма не зависит от объема данных
Алгоритм Хафмана | Иерархическая структура (дерево кодировки) | Любые данные | Эффективность алгоритма не зависит от объема данных


Алгоритм RLE

В основу алгоритмов RLE положен принцип выявления повторяющихся последовательностей данных и замены их простой структурой, в которой указывается код данных и коэффициент повтора.

Например, для последовательности:
0; 0; 0; 127; 127; 0; 255; 255; 255; 255 (всего 10 байтов)
образуется следующий вектор, который при записи в строку имеет вид:
0; 3; 127; 2; 0; 1; 255; 4 (всего 8 байтов).

В данном примере коэффициент сжатия равен 8/10 (80 %).

Программные реализации алгоритмов RLE отличаются простотой, высокой скоростью работы, но в среднем обеспечивают недостаточное сжатие. Наилучшими объектами для данного алгоритма являются графические файлы, в которых большие одноцветные участки изображения кодируются длинными последовательностями одинаковых байтов. Этот метод также может давать заметный выигрыш на некоторых типах файлов баз данных, имеющих таблицы с фиксированной длиной полей. Для текстовых данных методы RLE, как правило, неэффективны.

Синтетические алгоритмы

Рассмотренные выше алгоритмы в «чистом виде» на практике не применяют из-за того, что эффективность каждого из них сильно зависит от начальных условий. В связи с этим, современные средства архивации данных используют более сложные алгоритмы, основанные на комбинации нескольких теоретических методов. Общим принципом в работе таких «синтетических» алгоритмов является предварительный просмотр и анализ исходных данных для индивидуальной настройки алгоритма на особенности обрабатываемого материала.


Программные средства сжатия данных

«Классическими» форматами сжатия данных, широко используемыми в повседневной работе с компьютером, являются форматы .ZIP и .ARJ. В последнее время к ним добавился популярный формат .RAR. Программные средства, предназначенные для создания и обслуживания архивов, выполненных в данных форматах, приведены в табл. 14.2.

Таблица 1. Средства архивации файлов

Операционная система | Формат сжатия | Средство архивации | Средство разархивирования
MS-DOS | .ZIP | PKZIP.EXE | PKUNZIP.EXE
 | .RAR | RAR.EXE | UNRAR.EXE
 | .ARJ | ARJ.EXE | ARJ.EXE
Windows 9x | .ZIP | WinZip | WinZip
 | .RAR | WinRAR | WinRAR
 | .ARJ | WinArj | WinArj

Несмотря на то что средства архивации, предназначенные для операционной системы MS-DOS, вполне могут работать под управлением Windows 9x (в окне Сеанс MS-DOS), пользоваться ими не рекомендуется. В первую очередь, это связано с тем, что при обработке файлов происходит утрата «длинных имен» файлов и подмена их именами MS-DOS по спецификации 8.3. Это может создать потребителю документа определенные неудобства, а в случаях, когда архивация производится с целью резервного копирования, утрата «длинных имен» вообще недопустима.


Базовые требования к диспетчерам архивов

Современные программные средства для создания и обслуживания архивов отличаются большим объемом функциональных возможностей, многие из которых выходят далеко за рамки простого сжатия данных и эффективно дополняют стандартные средства операционной системы. В этом смысле современные средства архивации данных называют диспетчерами архивов.

К базовым функциям, которые выполняют большинство современных диспетчеров архивов, относятся:

  • извлечение файлов из архивов;
  • создание новых архивов;
  • добавление файлов в имеющийся архив;
  • создание самораспаковывающихся архивов;
  • создание распределенных архивов на носителях малой емкости;
  • тестирование целостности структуры архивов;
  • полное или частичное восстановление поврежденных архивов;
  • защита архивов от просмотра и несанкционированной модификации.

Самораспаковывающиеся архивы. В тех случаях, когда архивация производится для передачи документа потребителю, следует предусмотреть наличие у него программного средства, необходимого для извлечения исходных данных из уплотненного архива. Если таких средств у потребителя нет или нет оснований предполагать их наличие, создают самораспаковывающиеся архивы. Самораспаковывающийся архив готовится на базе обычного архива путем присоединения к нему небольшого программного модуля. Сам архив получает расширение имени .ЕХЕ, характерное для исполнимых файлов. Потребитель сможет выполнить его запуск как программы, после чего распаковка архива произойдет на его компьютере автоматически.

Распределенные архивы. В тех случаях, когда предполагается передача большого архива на носителях малой емкости, например на гибких дисках, возможно распределение одного архива в виде малых фрагментов на нескольких носителях.

Некоторые диспетчеры (например WinZip) выполняют разбиение сразу на гибкие диски, а некоторые (например WinRAR и WinArj) позволяют выполнить предварительное разбиение архива на фрагменты заданного размера на жестком диске. Впоследствии их можно перенести на внешние носители путем копирования.

При создании распределенных архивов диспетчер WinZip обладает неприятной особенностью: каждый том несет файлы с одинаковыми именами. В результате этого нет возможности установить номера томов, хранящихся на каждом из гибких дисков, по названию файла. Поэтому каждый диск следует маркировать пометками на наклейке, а при создании распределенного архива следует аккуратно перекладывать дискеты из начальной стопки в конечную, чтобы не перепутать последовательность немаркированных томов.

В случае необходимости узнать номер тома можно не по названию файла, а по метке на диске, хотя эта операция не слишком удобна. Для этого следует открыть окно Мой компьютер, выбрать значок дисковода 3,5 (А:), щелкнуть на нем правой кнопкой мыши и выбрать в контекстном меню пункт Свойства. В диалоговом окне Свойства: Диск 3,5 (А:) на вкладке Общие можно узнать номер тома распределенного архива в поле Метка тома.

Диспетчеры архивов WinArj и WinRAR маркируют все файлы распределенного архива разными именами и потому не создают подобных проблем.

Гибкие диски являются крайне ненадежными носителями, поэтому архивы, сформированные на жестком диске, должны храниться до получения подтверждения от потребителя о том/что распределенный архив поступил к нему в неповрежденном виде и прошел распаковку. Правилом «хорошего тона» считается создание двух копий при передаче материалов на гибких дисках.

Защита архивов. В большинстве случаев защиту архивов выполняют с помощью пароля, который запрашивается при попытке просмотреть, распаковать или изменить архив. Теоретически, защита с помощью пароля считается неудовлетворительной и не рекомендуется для особо важной информации. В то же время необходимо отметить, что основные программные средства, используемые для восстановления утраченного пароля (или взлома закрытой информации, что, по сути, то же самое), используют методы прямого перебора. Работу этих средств можно существенно затруднить и замедлить, если расширить область перебора. Пароли на базе символов английского алфавита и цифр действительно снимаются очень быстро. Однако даже незначительное увеличение числа используемых символов за счет знаков препинания многократно увеличивает криптостойкость защиты, а использование также и символов русского алфавита может полностью опровергнуть попытки снять пароль путем перебора, сделав сроки работы неприемлемыми.


Дополнительные требования к диспетчерам архивов

К дополнительным функциям диспетчеров архивов относятся сервисные функции, делающие работу более удобной. Они часто реализуются внешним подключением дополнительных служебных программ и обеспечивают:

  • просмотр файлов различных форматов без извлечения их из архива;
  • поиск файлов и данных внутри архивов;
  • установку программ из архивов без предварительной распаковки;
  • проверку отсутствия компьютерных вирусов в архиве до его распаковки; « криптографическую защиту архивной информации;
  • декодирование сообщений электронной почты;
  • «прозрачное» уплотнение исполнимых файлов .ЕХЕ и .DLL;
  • создание самораспаковывающихся многотомных архивов;
  • выбор или настройку коэффициента сжатия информации.


9.2. Практические упражнения

Упражнение 1. Просмотр архивного файла в формате .ZIP

1. Запустите диспетчер архивов WinZip 7.0 командой Пуск -> Программы -> WinZip -> WinZip 7.0.

2. Вставьте гибкий диск, содержащий архивный файл в формате ZIP, в дисковод А:.

3. Дайте команду File -> Open Archive (Файл -> Открыть архив).

4. В диалоговом окне Open Archive (Открытие архива) воспользуйтесь раскрывающей кнопкой в списке Папка, найдите и откройте Диск 3,5 (А:), выделите значок файла в формате .ZIP и щелкните на командной кнопке Открыть. В окне программы WinZip 7.0 откроется список файлов, входящих в архив (рис. 9.1).

Рис. 9.1. Список файлов, входящих в ZIP-архив

5. Выделите значок файла, который желаете просмотреть, например Rekvizit.Txt. Дважды щелкните на этом значке, и файл откроется в окне ассоциированной программы. По умолчанию в операционной системе Windows 98/2000 с файлами типа .ТХТ ассоциирована программа Блокнот.

6. Если нужно просмотреть файл в другой программе, выделите его значок и воспользуйтесь командой Actions -> View (Действия -> Просмотр). По этой команде откроется диалоговое окно View (Просмотр), в котором можно самостоятельно указать, какую программу следует использовать в качестве средства просмотра для файлов данного типа.

7. Выделите для просмотра файл с иным расширением имени, например File_id.diz. Этот тип файлов не имеет ассоциированной программы просмотра. После предупреждающего сообщения он откроется в стандартном средстве просмотра Windows — в программе Быстрый просмотр.

Мы научились просматривать файлы, находящиеся внутри архива, без распаковки архива и, соответственно, без извлечения файлов. Это важно, поскольку далеко не все архивы, поступающие на компьютер, особенно из Интернета, стоит распаковывать. Предварительный просмотр позволяет убедиться в том, что архив содержит действительно необходимые данные, а также получить предварительную информацию о том, как лучше распорядиться его содержимым.


Упражнение 2. Извлечение файлов из ZIP-архива

1. Предварительно определите папку, в которую будут помещены файлы, извлекаемые из архива. Если никаких предпочтений нет, создайте временную папку, например папку
С:\Мои документы\Zip_Test.

2. Запустите диспетчер архивов WinZip 7.0 и откройте ZIP-архив, размещенный на гибком диске А:.

3. Выделите файлы, которые желаете извлечь. При групповом выделении пользуйтесь левой кнопкой мыши совместно с клавишами CTRL и SHIFT.

4. Дайте команду Actions -> Extract (Действия -> Извлечь) — откроется диалоговое окно Extract (Извлечение), представленное на рис. 9.2.

Рис. 9.2. Диалоговое окно Extract (Извлечение)

5. На левой панели диалогового окна установите необходимые переключатели.

6. На правой панели откройте папку-приемник, в которую произойдет извлечение выделенных файлов. Работа на правой панели аналогична работе с Проводником Windows.

7. Запустите процесс извлечения файлов щелчком на командной кнопке Extract (Извлечь).

8. По окончании процесса закройте диалоговое окно щелчком на кнопке Cancel (Отмена) или на закрывающей кнопке в правом верхнем углу окна и завершите работу с программой WinZip командой File -> Exit (Файл -> Выход).

9. С помощью Проводника (Пуск -> Программы -> Проводник) убедитесь в том, что файлы, извлеченные из архива, действительно поступили в заданную папку.

10. Удалите экспериментальную папку \Zip_Test.

Мы научились извлекать файлы из архива в заданную папку. При этом у нас есть следующие возможности выбора:

  • какие файлы извлекать, а какие — нет;

  • в какую папку производить запись.


Упражнение 3. Создание ZIP-архива

1. Создайте папку для экспериментов, например C:\Windows\Temp\Zip_Test.

2. Методом копирования наполните эту папку произвольными файлами, например, взяв их из стандартной папки C:\Windows\Media (файлы в этой папке имеют «длинные имена», а нам важно убедиться в том, что после архивации они остаются неповрежденными).

3. Запустите диспетчер архивов WinZip 7.0.

4. Дайте команду File -> New Archive (Файл > Создать Архив) — откроется диалоговое окно New Archive (Создание архива). В этом окне прежде всего выберите папку, в которой будет создан архив, например C:\Windows\Temp\Zip_Test.

5. Введите имя архива в поле Имя файла (например Media) и убедитесь, что в поле Files of type (Тип файла) установлен тип Zip files.

6. Обязательно установите флажок Add dialog (Открывать окно Включение в архив) и щелкните на кнопке ОК.

7. Если флажок Add dialog установлен, откроется диалоговое окно Add (Включение в архив), представленное на рис. 9.3.

Рис. 9.2. Диалоговое окно Add (Включение в архив)

8. В раскрывающемся списке Action (Действие) выберите пункт Add (and replace) files (Добавлять и заменять файлы).

9. В раскрывающемся списке Compression (Степень сжатия) выберите пункт Normal (Обычная).

10. В группе элементов управления Folders (Папки) установите флажок Include Subfolders (Включая вложенные папки). Несмотря на то что в нашем примере в папке \Media нет вложенных папок, надо взять за правило включать данный флажок всегда.

11. В группе элементов управления Attributes (Атрибуты) убедитесь в том, что установлен флажок Include system and hidden files (Включать системные и скрытые файлы).

12. Выделите файлы, включаемые в архив. При групповом выделении файлов пользуйтесь левой кнопкой мыши совместно с клавишами SHIFT и CTRL. Если нужно выделить все файлы, можно воспользоваться комбинацией клавиш CTRL+A.

13. Щелкните на командной кнопке Add (Добавить в архив) — начнется процесс создания архива.

14. С помощью Проводника откройте папку C:\Windows\Temp\Zip_test. Разыщите созданный файл Media.zip. Установите его размер по строке состояния или переключившись в режим Таблица.

15. Переключитесь в программу WinZip 7.0. Откройте в ней созданный архив и убедитесь в том, что «длинные имена» файлов сохранились.

16. Закройте программу WinZip.

Мы научились создавать архивы сжатых файлов. При этом мы имеем возможность выбрать, какие файлы включаются в архив и в какой папке создается результирующий файл.
Мы также можем выбрать степень сжатия, указать режим обновления файлов для тех случаев, когда в архиве уже имеются файлы, одноименные добавляемым, и задать режим упаковки папок с сохранением структуры вложенных папок.
Данные настройки выполняют в специальном диалоговом окне Add (Добавление в архив). Они особенно важны в тех случаях, когда диспетчер архивов используется с целью организации резервного копирования данных.


Упражнение 4. Защита ZIP-архива

1. Запустите программу WinZip 7.0.

2. Дайте команду File -> Open Archive (Файл -> Открыть архив). Откройте ранее созданный архив Media.zip.

3. Дайте команду Actions -> Add (Действия -> Добавить в архив) — откроется диалоговое окно Add (Добавление в архив).

4. В списке представленных файлов разыщите файл Media.zip, щелкните правой кнопкой мыши на его значке и в открывшемся контекстном меню выберите команду Удалить. Удаление ранее созданного архива необходимо для создания нового архива под тем же именем.

5. Выделите все файлы списка комбинацией клавиш CTRL+A.

6. Для защиты создаваемого архива паролем щелкните на кнопке Password (Пароль) - откроется одноименное диалоговое окно, представленное на рис. 9.4.

Рис. 9.4. Задание пароля для защиты архива

7. Обратите внимание на флажок Mask Password (He отображать пароль). Если он установлен, пароль при вводе не будет отображаться на экране, а его символы будут заменены подстановочным символом «*». Это мера защиты пароля от посторонних. Однако в данном случае пользователь не может быть уверен в том, что он набрал пароль правильно. Поэтому при установленном флажке Mask password система запрашивает повторный (контрольный) ввод пароля.

8. Введите пароль, например слово informatika.

9. Щелкните на кнопке ОК. Обратите внимание на то, что диалоговое окно Add
(Добавление в архив) изменило название — Add with password (Добавление в архив и защита паролем).

10. Щелкните на командной кнопке Add (Добавить в архив) — начнется процесс создания защищенного архива Media.zip.

11. Откройте созданный архив командой File -> Open (Файл -> Открыть).

12. Выделите любой файл, входящий в состав архива, и дайте команду Actions -> Extract (Действия > Извлечь).

13. В открывшемся диалоговом окне Extract (Извлечение) проверьте правильность установки необходимых элементов управления и выберите папку-приемник.

14. Щелкните на командной кнопке Extract (Извлечь). Процесс извлечения данных из архива не запустится, а вместо него откроется диалоговое окно для ввода пароля.

15. Убедитесь в том, что ввод неправильного пароля не позволяет извлечь файлы из архива.

16. Убедитесь в том, что правильный ввод пароля действительно запускает процесс.

17. Закройте программу WinZip 7.0.

Мы научились создавать защищенные архивы. Защита выполняется одновременно с созданием самого архива. Надежность защиты во многом определяется размером символьного набора, использованного при задании пароля.


Упражнение 5. Создание самораспаковывающегося ZIP-архива

1. Запустите программу WinZip 7.0.

2. Дайте команду File -> Open Archive (Файл -> Открыть архив). Откройте ранее созданный архив Media.zip.

3. Дайте команду Actions -> Make .Exe File (Действия -> Создать исполнимый файл) — откроется диалоговое окно WinZip Self-Extractor (Генератор самораспаковывающегося архива), представленное на рис. 9.5.

Рис. 9.5. Создание самораспаковывающегося архива

4. Самораспаковывающийся архив создается на базе ранее созданного обычного
архива. Убедитесь в том, что в поле Create Self-Extracting Zip files from (Создать
самораспаковывающийся архив из ...) правильно записан адрес исходного ZIP-
файла. Если это не так, воспользуйтесь кнопкой Browse (Обзор) для поиска нужного файла.

5. В группе Self Extractor Type (Тип самораспаковывающегося архива) включите переключатель, соответствующий операционной системе компьютера, для которого готовится архив.

6. В группе Spanning Support (Поддрежка распределенного архива) включите переключатель No spanning (Без распределения).

7. Щелкните на кнопке ОК.

8. Поскольку исходный архив имеет парольную защиту, то перед началом преобразования появится предупреждающее сообщение. Закройте его щелчком на кнопке ОК.

9. По окончании преобразования появится диалоговое окно с предупреждением о том, что самораспаковывающийся архив следует испытать. Подтвердите начало испытания щелчком на кнопке Да.

10. В очередном окне выберите папку, в которую произойдет проверочная распаковка архива. По умолчанию предлагается папка C:\Windows\Temp. Если она не устраивает, воспользуйтесь командной кнопкой Browse (Обзор), выберите нужную папку и щелкните на кнопке Unzip (Распаковать).

11. Поскольку архивный файл защищен, его распаковка не начнется, пока не будет введен правильный пароль.

Мы научились создавать самораспаковывающиеся архивы на базе предварительно подготовленных обычных архивов. Мы убедились в том, что если исходный архив был защищен паролем, то эта защита сохраняется и в самораспаковывающемся архиве.


Упражнение 6. Создание самораспаковывающегося распределенного архива

1. Запустите программу WinZip 7.0.

2. Дайте команду File -> Open Archive (Файл -> Открыть архив). Разыщите и откройте ранее созданный архив Media.zip.

3. Дайте команду Actions -> Make .Exe File (Действия -> Создать исполнимый файл) — откроется диалоговое окно WinZip Self-Extractor (Генератор самораспаковывающегося архива), представленное на рис. 9.5.

4. В группе элементов управления Spanning Support (Поддержка распределенного архива) включите переключатель Safe Spanning Method (Защищенный метод распределения) или Old Spanning Method (Обычный метод распределения).

Защищенный метод создает на первом гибком диске два файла: исполнимый файл, выполняющий автоматическую распаковку, и первый том распределенного архива. На последующих дисках создается продолжение распределенного архива. Такой подход повышает уровень безопасности, поскольку даже в том случае, когда исполнимый файл поврежден, например компьютерным вирусом, информация не пропадает и остается в архивном файле. После применения антивирусных средств для «лечения» зараженного исполнимого файла также не происходит нарушений в структуре архива, поскольку исполнимый файл автономен. Этот метод применяют для передачи архивных материалов на гибких дисках.

Обычный метод считается «устаревшим», поскольку он обеспечивался прошлыми версиями программы WinZip. Этот метод не создает отдельного исполнимого файла, и весь архив хранится в одном исполнимом файле, распределенном по нескольким носителям. Данный метод используют для самораспаковывающихся архивов, передаваемых по каналам компьютерных сетей.

5. Щелкните на командной кнопке ОК — откроется диалоговое окно WinZip Self-Extractor (Генератор самораспаковывающегося архива).

6. Установите флажок Erase any existing files on the new disk before continuing (Предварительно стереть все существующие файлы на гибких дисках).

7. Щелкните на кнопке ОК — начнется процесс создания первого тома распределенного архива. По окончании процесса по указанию от программы извлеките записанный гибкий диск и вставьте новый.

8. Создав последний том, программа предложит извлечь последний диск и вставить первый для внесения правок в заголовок архива.

Мы научились создавать самораспаковывающиеся распределенные архивы. Такой метод архивации нашел особенно широкое применение при распространении программных продуктов.


Упражнение 7. Наблюдение интеграционных свойств программы WinZip

В этом упражнении на примере диспетчера архивов WinZip 7.0 мы ознакомимся с тем, как выполняется интеграция служебных и прикладных программ с операционной системой Windows 98/2000.

Под интеграцией программного обеспечения понимают возможность совместной работы нескольких различных программ в рамках единой системы управления. Так, например, уже известным нам системным средством интеграции является концепция внедрения и связывания объектов и основанный на ней буфер обмена Windows. Здесь же мы познакомимся с другим приемом интеграции, в основе которого лежит изменение свойств программы Проводник и связанного с ней контекстного меню объектов.

С точки зрения интеграции в современном развитии диспетчеров архивов четко прослеживаются две тенденции: интеграция с операционной системой Windows 98/2000 и, наоборот, отказ от интеграции и автономное функционирование. Оба подхода имеют свои достоинства и недостатки. Глубокая интеграция с Проводником делает работу пользователя более удобной и интуитивно понятной. Отказ от интеграции позволяет расширить возможности настройки программы (в первую очередь за счет использования параметров командной строки запуска) и обеспечить гибкое взаимодействие с другими приложениями. Характерным представителем первого направления является рассмотренный нами диспетчер архивов WinZip. Характерным представителем второго направления является популярный в России диспетчер WinRAR.

В итоге получается следующее соотношение:

  • для эпизодических работ по архивации и извлечению файлов и папок удобнее использовать систему, хорошо интегрированную в Windows, например, WinZip 7.0;
  • для регулярных работ по созданию резервных копий папок и дисков удобнее использовать автономные средства, поскольку для них проще организуется взаимодействие с прочими программами (в частности, со средствами автоматизации). В этих случаях можно рекомендовать, например, WinRAR 2.0.

1. Запустите программу Проводник (Пуск > Программы > Проводник).

2. Создайте папку для экспериментов С:\Теmp (если эта папка уже существует, создайте в ней папку C:\Temp\Test.

3. Скопируйте в созданную папку несколько произвольных файлов, взяв их, например, из папки C:\Windows\Media.

4. Откройте созданную папку и выделите один из помещенных в нее файлов.

5. Щелкните правой кнопкой мыши на значке выделенного файла — откроется контекстное меню. Обратите внимание на то, что в нем имеются два пункта для создания архива (создание архива с произвольным именем и с именем, соответствующим текущему файлу). Появление этих пунктов связано с наличием в компьютерной системе диспетчера архивов и интеграции WinZip 7.0 с Проводником Windows.

6. Дайте команду Add to Zip (Добавить в архив) — произойдет автоматический запуск диспетчера архивов WinZip 7.0 и открытие диалогового окна Add (Добавление в архив).

7. В поле Add to archive (Добавить в архив) автоматически заносится адрес текущей папки. Сюда остается вписать только название файла создаваемого архива, например C:\Temp\Test\media. Если надо открыть другую папку, это можно сделать с помощью командной кнопки Open (Открыть). Если надо создать новую папку внутри текущей, воспользуйтесь кнопкой New (Создать). Проверив настройку прочих элементов управления, запустите процесс архивации щелчком на командной кнопке Add (Добавить).

8. Перейдите в окно программы Проводник и убедитесь в том, что в экспериментальной папке появился архивный файл Media.zip.

9. Щелкните на значке архивного файла правой кнопкой мыши и изучите новые команды контекстного меню, позволяющие выполнить операции с архивным файлом.

10. Дайте команду Create Self-Extractor (Создать самораспаковывающийся архив). В открывшемся диалоговом окне щелкните на командной кнопке Да и в последующих диалоговых окнах откажитесь от проверки созданного архива. Закройте открытые окна программы WinZip и в программе Проводник убедитесь в том, что в экспериментальной папке появился исполнимый файл (.ЕХЕ).

11. В программе Проводник выполните перетаскивание значка любого файла (или группы файлов) на значок созданного ZIP-архива. При отпускании кнопки мыши в конце перетаскивания происходит автоматическое добавление новых файлов в архив. Если содержимое правой панели Проводника открыто в режиме Таблица, после каждого перетаскивания можно наблюдать увеличение размера файла архива.

Мы наблюдали факт изменения свойств программы Проводник за счет того, что в компьютерной системе установлена программа WinZip. Это изменение свойств выразилось, во-первых, в изменении содержания контекстного меню, связанного с объектами Windows, и, во вторых, в том, что работает прием наполнения архива методом перетаскивания. Таким образом, мы можем говорить о том, что установка программы WinZip расширила функциональные возможности системной программы Проводник.


9.4. Глоссарий

Архиватор – специальная компьютерная программа, позволяющая архивировать файлы сжатием хранимой в них информации.

Разархивация (распаковка) – восстановление файла из архива.

Самораспаковывающийся архив – это исполняемый модуль, при запуске которого происходит восстановление файла из архива даже при отсутствии архиватора, которым файл был упакован.

Сжатие (архивация) – устранения избыточности информации. Например, за счёт упрощения кодов путём исключения из них постоянных битов. Служит для снижения экономических затрат по хранению данных и повышает общую надежность информационного процесса в целом.

Цель сжатия – размещение информации на носителях внешней памяти в более компактном виде, что требует меньших объёмов памяти.


9.3. Контрольные вопросы

  1. Что такое архиваторы?
  2. Какие бывают архиваторы?
  3. Для чего создаются архивы?
  4. За счет чего происходит сжатие информации?
  5. От чего зависит степень сжатия информации?
  6. С помощью чего создаются архивы?
  7. Какие Вы знаете программы-архиваторы?
  8. Какие базовые функции выполняют большинство современных диспетчеров архивов?
  9. Что такое самораспаковывающийся архив, как его создать?
  10. Что такое распределенный архив, как он создается?
  11. Что такое обратимость информации?
  12. Какие существуют форматы сжатия с потерей информации?


10.1. Понятие компьютерного преступления и защиты информации

Как известно, главным предназначение компьютера является обработка информации. Исходя из определения данного В.В. Крыловым: «компьютерная информация есть сведения, знания или набор команд (программ), предназначенных для использования в ЭВМ или управления ею, находящиеся в ЭВМ или машинных носителях, - идентифицируемый элемент информационной системы, имеющей собственника, установившего правила ее использования».

Под собственником информационных ресурсов, систем, технологий и средств их обеспечения понимается субъект, в полном объеме реализующий полномочия владения, пользования и распоряжения указанными объектами.

Владельцем информационных ресурсов, систем, технологий и средств их обеспечения является субъект, осуществляющий владение и пользование указанными объектами и реализующий полномочия распоряжения ими в пределах, установленных законом.

Пользователем (потребителем) информации признается субъект, обращающийся к ИС или посреднику за получением необходимой ему информации и пользующийся ею.

Действия других лиц, не являющихся собственником или владельцем информационных ресурсов, систем, технологий и средств их обеспечения, а равно не являющихся законными пользователями информации, признаются нарушением и, следовательно, влекут юридическую ответственность. В отдельных случаях действия таких лиц содержат признаки преступления. Предусмотренного ст.272 УК РФ (неправомерный доступ к компьютерной информации). Итак несмотря на ряд особенностей, информация наряду с традиционными материальными объектами может и должна рассматриваться законом как объект права собственности.

Охраняемая законом компьютерная информация – это информация ограниченного доступа, которая имеет не только специальный правовой статус, установленный соответствующими законами или законами субъектов РФ, но по своему характеру предназначена для ограниченного круга лиц (пользователей), имеющих право на ознакомление и работу с ней.

Под информацией с ограниченным доступом понимаются сведения, доступ к которым ограничен в соответствии с законом с целью защиты прав и законных интересов субъектов права на тайну.

Законодательство РФ устанавливает ряд обязательных признаков и условий защиты права на информацию с ограниченным доступом. Условием правовой защиты информации с ограниченным доступом, должна быть ее защита. При этом Федеральным законом «Об информации, информатизации и защите информации» указывается следующие цели защиты информации:

  • Предотвращение утечки, хищения, утраты, искажения, подделки;
  • Предотвращение несанкционированных действий по уничтожению, модификации, искажению, копированию, блокированию;
  • Реализация прав на государственную тайну и конфиденциальность.

Цель обеспечения безопасности информации заключается в защите прав собственности на нее, а задачи безопасности информации – защита ее от утечки, модификации и утраты.

Создание электронно-вычислительной техники, ее широкое внедрение в экономическую, социальную и управленческую деятельность привело к повышению значимости и ценности информации и информационных ресурсов. Однако позитивные явления всеобщей компьютеризации сопровождаются массой негативных явлений, связанных со злоупотреблениями возможностями вычислительной техники. Особую тревогу сегодня вызывает факт выявления и развития в России нового вида преступлений, связанных с использованием средств компьютерной техники и информационных технологий.

Виды компьютерных преступлений чрезвычайно многообразны. Это и несанкционированный доступ к информации, хранящейся в компьютере, и ввод в программное обеспечение "логических бомб", которые срабатывают при выполнении определенных условий и частично или полностью выводят из строя компьютерную систему, и разработка и распространение компьютерных вирусов, и хищение компьютерной информации. Компьютерное преступление может произойти также из-за небрежности в разработке, изготовлении и эксплуатации программно-вычислительных комплексов или из-за подделки компьютерной информации.

Часть указанных пробелов в общественных отношениях в области компьютерной информации была ликвидирована после введения в действие с 1 января 1997 года нового Уголовного Кодекса, принятого Государственной Думой 24 мая 1996 года.


10.2. Составы компьютерных преступлений

Составы компьютерных преступлений (т.е. перечень признаков, характеризующих общественно опасное деяние как конкретное преступление) приведены в 28 главе УК, которая называется "Преступления в сфере компьютерной информации" и содержит три статьи: "Неправомерный доступ к компьютерной информации" (ст. 272), "Создание, использование и распространение вредоносных программ для ЭВМ" (ст. 273) и "Нарушение правил эксплуатации ЭВМ, системы ЭВМ или их сети" (ст. 274).

Рассмотрим подробнее все три статьи УК РФ, ставя целью обрисовать основные признаки совершения компьютерных преступлений, т.е. предусмотренных уголовным законодательством виновных нарушений охраняемых законом прав и интересов в отношении информационных компьютерных систем. Сухое юридическое описание будет скрашено некоторыми немногочисленными примерами отечественных компьютерных преступлений прошлых лет, компенсирующие бедность правоприменительной практики на базе нового УК РФ и позволяющие осуществить мысленный эксперимент по его применению.


Неправомерный доступ к компьютерной информации (ст. 272 УК)

Статья 272 УК предусматривает ответственность за неправомерный доступ к компьютерной информации (информации на машинном носителе, в ЭВМ или сети ЭВМ), если это повлекло уничтожение, блокирование, модификацию либо копирование информации, нарушение работы вычислительных систем.

Данная статья защищает право владельца на неприкосновенность информации в системе. Владельцем информационной вычислительной системы может быть любое лицо, правомерно пользующееся услугами по обработке информации как собственник вычислительной системы (ЭВМ, сети ЭВМ) или как лицо, приобретшее право использования компьютера.

Преступное деяние, ответственность за которое предусмотрено ст. 272 должно состоять в неправомерном доступе к охраняемой законом компьютерной информации, который всегда носит характер совершения определенных действий и может выражаться в проникновении в компьютерную систему путем использования специальных технических или программных средств позволяющих преодолеть установленные системы защиты; незаконного применения действующих паролей или маскировка под видом законного пользователя для проникновения в компьютер, хищения носителей информации, при условии, что были приняты меры их охраны, если это деяние повлекло уничтожение или блокирование информации.

Неправомерным признается доступ к защищенной компьютерной информации лица, не обладающего правами на получение и работу с данной информацией, либо компьютерной системой.

Один из характерных примеров потенциального применения данной статьи - уголовное дело о хищении 125,5 тыс. долл. США и подготовке к хищению еще свыше 500 тыс. долл. во Внешэкономбанке СССР в 1991 г., рассмотренное московским судом. По материалам другого уголовного дела, в сентябре 1993 г. было совершено покушение на хищение денежных средств в особо крупных размерах из Главного расчетно-кассового центра Центрального банка России по г. Москве на сумму 68 млрд. руб.

Еще один пример. В 1990 г. компьютерная программа перечисления комсомольских взносов работников одного из отечественных предприятий была составлена так, что отчисления производились из зарплаты не только комсомольцев, но и всех работников в возрасте до 28 лет. Пострадавших оказалось 67 человек, теперь это возможно квалифицировать по части 1 ст. 272 УК.

Ярким примером возможности применения 272 ст. могут служить хорошо освещенные средствами массовой информации действия Л. и других граждан России, которые вступили в сговор с целью похищения денежных средств в крупных размерах, принадлежащих "City Bank of America", расположенного в Нью-Йорке (США). Образовав устойчивую преступную группу, они в период с конца июня по сентябрь 1994 г., используя Интернет и преодолев банковскую систему защиты от несанкционированного доступа, с помощью персонального компьютера, находящегося в Санкт-Петербурге, осуществляли денежные переводы на общую сумму свыше 10 млн. долл. США.

В марте 1995 г. Л. вылетел в Лондон, где был арестован. В приведенном примере необходимо подчеркнуть следующую немаловажную деталь: состоявшийся в августе 1995 г. лондонский суд отложил принятие решения по делу Л. на неопределенный срок, поскольку в ходе судебного разбирательства было доказано, что для получения доступа к счетам клиентов банка подсудимый использовал в качестве орудия совершения преступления компьютер, находящийся на территории России, а не на территории США, как того требует уголовное законодательство Великобритании. На основании вышеизложенного просьба американских и российских представителей о выдаче им Л. была судом отклонена.

Действия Л. и его сообщников можно квалифицировать по ч. 2 ст. 272 УК РФ, т.к. в результате предварительного сговора ими был осуществлен неправомерный доступ к секретной банковской информации с целью получения материальной выгоды. Место нахождения непосредственного объекта преступления - компьютерная система в США не повлияло бы на суть дела.

Статья 272 УК не регулирует ситуацию, когда неправомерный доступ осуществляется в результате неосторожных действий, что, в принципе, отсекает огромный пласт возможных посягательств и даже те действия, которые действительно совершались умышленно, т.к., при расследовании обстоятельств доступа будет крайне трудно доказать умысел компьютерного преступника (например, в сети Интернет, содержащей миллионы компьютеров, в связи со спецификой работы - переход по ссылке от одного компьютера к другому довольно легко попасть в защищаемую информационную зону даже не заметив этого).


Создание, использование и распространение вредоносных программ для ЭВМ (ст. 273 УК)

Статья предусматривает уголовную ответственность за создание программ для ЭВМ или их модификацию, заведомо приводящее к несанкционированному уничтожению, блокированию и модификации, либо копированию информации, нарушению работы информационных систем, а равно использование таких программ или машинных носителей с такими программами.

Статья защищает права владельца компьютерной системы на неприкосновенность находящейся в ней информации.

Под созданием вредоносных программам в смысле ст. 273 УК РФ понимаются программы специально разработанные для нарушения нормального функционирования компьютерных программ. Под нормальным функционированием понимается выполнение операций, для которых эти программы предназначены, определенные в документации на программу. Наиболее распространенными видами вредоносных программ являются широко известные компьютерные вирусы и логические бомбы.

Под использованием программы понимается выпуск в свет, воспроизведение, распространение и иные действия по их введению в оборот. Использование может осуществляться путем записи в память ЭВМ, на материальный носитель, распространения по сетям, либо путем иной передачи другим лицам.

Уголовная ответственность по этой статье возникает уже в результате создания программы, независимо от того использовалась эта программа или нет.

В 1983 г. на одном автомобильном заводе нашей страны был изобличен программист, который из мести к руководству предприятия умышленно внес изменения в программу ЭВМ, управлявшей подачей деталей на конвейер. В результате произошедшего сбоя заводу был причинен существенный материальный ущерб: не сошло с конвейера свыше сотни автомобилей. Программист был привлечен к уголовной ответственности. Подсудимый обвинялся по ст. 98 ч. 2 Уголовного кодекса РСФСР "Умышленное уничтожение или повреждение государственного или общественного имущества... причинившее крупный ущерб". При этом обвиняемый утверждал, что ничего натурально повреждено не было - нарушенным оказался лишь порядок работы, т. е. действия, не подпадающие ни под одну статью действующего в то время законодательства. С научной точки зрения интересен приговор суда: "три года лишения свободы условно; взыскание суммы, выплаченной рабочим за время вынужденного простоя главного конвейера; перевод на должность сборщика главного конвейера".

В настоящее время квалификация действий программиста должна была бы производиться по ч. 1 ст. 273. Он умышленно создал и использовал в заводском компьютере вредоносную программу, нарушившую технологический процесс.

Если в действиях же в действиях лица содержаться не только признаки преступления, предусмотренного ст. 273 УК, но и признаки другого преступления (убийства, уничтожения имущества), виновный будет нести ответственность по совокупности совершенных преступлений.


Нарушение правил эксплуатации ЭВМ, системы ЭВМ или их сети (ст. 274. УК)

Статья 274 УК устанавливает ответственность за нарушение правил эксплуатации ЭВМ, системы ЭВМ или их сети лицом, имеющим доступ к ним, повлекшее уничтожение, блокирование или модификацию охраняемой законом информации, если это деяние причинило существенный вред.

Статья защищает интерес владельца вычислительной системы относительно ее правильной эксплуатации.

Предусмотренные составы компьютерных преступлений не охватывают полностью всех видов совершения компьютерных посягательств. Хотя, возможно, в этом случае будут "оказывать помощь" статьи 146 УК РФ (нарушение авторских и смежных прав) и 147 УК РФ (нарушение изобретательских и патентных прав), дающие возможность уголовного преследования за незаконное использование программного обеспечения.

Хотя четкого определения компьютерного преступления не существует, их условно можно подразделить на две большие категории:

  • преступления, связанные с вмешательством в работу компьютеров
  • преступления, использующие компьютеры как необходимые технические средства.

Здесь мы не будем касаться «около компьютерных» преступлений, связанных с нарушением авторских прав программистов, незаконным бизнесом на вычислительной технике и т. п., а также физического уничтожения компьютеров взрывами, огнем или кирпичом.

Вывод: таким образом, компьютерное преступление, есть противоправные действия, направленные на достижение доступа к хранимой на компьютере информации, имеющей ограниченные права доступа. При этом компьютер может быть как объектом преступления, так и в качестве инструмента преступной деятельности. Целью защиты информации является гарантирование законных прав различных категорий пользователей на обеспечение возможности разграничения доступа к информации.


10.3. Объекты нападений компьютерных преступлений

В наш век автоматизации и всеобщей связи ни одна организация не застрахована от компьютерных преступлений. Кратко рассмотрим наиболее распространенные объекты компьютерных преступлений:

1. Компьютеры военных и разведывательных организаций (в шпионских целях).

Компьютеры играют все большую роль в обеспечении национальной безопасности. В них хранится разнообразная информация: от параметров орбит спутников до глобальных планов развертывания войск. Так же как обычные преступники поняли, что компьютеры – это то место, где есть деньги, шпионы осознали. Что из компьютеров можно извлекать разведывательную информацию. Шпионаж все более и более становится игрой компьютерного подслушивания, компьютерной криптографии, анализа сообщений. Плащ и кинжал стали виртуальными. Известен факт, когда расхождения в 75 центов в отчетных документах одной из калифорнийских организаций привели его к раскрытию западногерманского взломщика, который извлекал информацию из военных компьютеров более чем в 10 странах.

2. Компании и предприятия бизнеса (промышленный шпионаж).

В век глобальной экономической конкуренции. Конкуренция национальных экономик усиливает угрозу промышленного шпионажа. Даже дружественные нации становятся экономическими врагами.

3. Банки и предприятия бизнеса (профессиональные преступники).

В наши дни может показаться, что деньги являются не чем иным, как битами в компьютере, цифрами на экране и чернилах на редких выписках из банковского счета. Наши платежи осуществляются с помощью электронных средств. Соответственно банки всегда являлись и являются привлекательной целью для компьютерных преступников. Компьютерное преступление может быть значительно более выгодным, чем другие формы воровства или мошенничества и тем самым обладают большой привлекательностью для финансовых преступников.

4. Компьютеры любых организаций, особенно правительственных и коммунальных (террористы).

Зачем разрушать отдельный объект электроснабжения и вызвать местное отключение электролинии, если можно взломать всю систему электроснабжения и обесточить целый регион или страну?

5. Любая компания (мишень для бывших служащих, а университеты – для студентов).

Не только компьютерные преступники ищут информацию. Некоторые просто хотят нанести повреждения и разрушения. Одним из наиболее известных случаев преступления этой категории было дело Дональда Г. Берлисона, служащего Техасской страховой компании. Берлисон был аналитиком в области безопасности систем и проработал в этой компании более двух лет, после чего был уволен. После его увольнения отказал компьютер, в результате чего компания потеряла большую часть комиссионных записей, используемых при подготовке платежных ведомостей. Анализ программы, ответственной за возникновение этой проблемы, привел к терминалу Берликсона и его учетной записи. Следователям удалось доказать, что он поместил «логическую бомбу» в программу, когда еще был служащим компании.

6. Любая организация (с целью разрешения интеллектуальной головоломки, а иногда при выполнении заказов).

Компьютерные преступления часто совершаются с целью решения интеллектуальных головоломок без всяких корыстных мотивов. Преступники могут быть детьми, для которых компьютер – следующий шаг после видеоигр. В июне 1989г. 14-летний канзасский мальчик использовал свой скромный домашний компьютер для взлома программы ВВС США, чтобы определить координаты спутников. Тинэйджер, который, согласно сообщениям начал свою карьеру взломщика с восьми лет, специализировался на проникновении в миникомпьютеры HP3000 фирмы Hewlet-Packard, используемые бизнесменами и правительственными организациями.


10.4. Приемы компьютерных преступлений

Рассмотрим более подробно некоторые приемы, применяемые в компьютерных преступлениях.

Изъятие средств вычислительной техники

Изъятие средств вычислительной техники (СВТ) производится с целью получения системных блоков, отдельных винчестеров или других носителей информации, содержащих в памяти установочные данные о клиентах, вкладчиках, кредиторах банка и т.д. Такие действия проводятся путем хищения, разбоя, вымогательства и сами по себе содержат состав обычных «некомпьютерных» преступлений. Они квалифицируются по ст. 158, 161, 162,163 УК России.

Перехват информации

Перехват (негласное получение) информации также служит для «снятия» определенных сведений с помощью методов и аппаратуры аудио-, визуального и электромагнитного наблюдения. Объектами, как правило, являются каналы связи, телекоммуникационное оборудование, служебные помещения для проведения конфиденциальных переговоров, бумажные и магнитные носители (в том числе и технологические отходы). Это компетенция ст. 138,183 УК.

Несанкционированный доступ

Несанкционированный доступ (НСД) к средствам вычислительной техники. Это активные действия по созданию возможности распоряжаться информацией без согласия собственника. Они могут быть квалифицированы с использованием ст. 183, 272 УК. НСД обычно реализуется с использованием следующих основных приемов:

  • «за дураком» - физическое проникновение в производственные помещения. Злоумышленник ожидает у закрытого помещения, держа в руках предметы, связанные с работой на компьютерной технике (элементы маскировки), пока не появится кто-либо, имеющий легальный доступ к СВТ, затем остается только войти внутрь вместе с ним или попросить его помочь занести якобы необходимые для работы на компьютере Предметы. Другой вариант - электронное проникновение в СВТ - подключение дополнительного компьютерного терминала к каналам связи с использованием шлейфа «шнурка» в тот момент времени, когда законный пользователь кратковременно покидает свое рабочее место, оставляя свой терминал или персональный компьютер в активном режиме;
  • «за хвост» - злоумышленник подключается к линии связи законного пользователя и дожидается сигнала, обозначающего конец работы. перехватывает его на себя, а потом, когда законный пользователь заканчивает активный режим, осуществляет доступ к банковской системе. Подобными свойствами обладают телефонные аппараты с функцией удержания номера, вызываемого абонентом;
  • «компьютерный абордаж» - злоумышленник вручную или с использованием автоматической программы подбирает код (пароль) доступа к КС системе с использованием обычного телефонного аппарата:
  • «неспешный выбор» - преступник изучает и исследует систему защиты от НСД, ее слабые места, выявляет участки, имеющие ошибки или неудачную логику программного строения, разрывы программ (брешь, люк) и вводит дополнительные команды, разрешающие доступ;
  • «маскарад» - злоумышленник проникает в компьютерную систему, выдавая себя за законного пользователя с применением его кодов (паролей) и других идентифицирующих шифров;
  • «мистификация» - злоумышленник создает условия, когда законный пользователь осуществляет связь с нелегальным терминалом, будучи абсолютно уверенным в том, что он работаете нужным ему законным абонентом. Формируя правдоподобные ответы на запросы законного пользователя и поддерживая его заблуждения некоторое время, злоумышленник добывает коды (пароли) доступа или отклик на пароль;
  • «аварийный» - злоумышленник создает условия для возникновения сбоев или других отклонений в работе СВТ. При этом включается особая программа, позволяющая в аварийном режиме получать доступ к наиболее ценным данным. В этом режиме возможно «отключение» всех имеющихся в компьютерной системе средств защиты информации.


Разработка и распространение компьютерных вирусов.

Компьютерный вирус - это специально написанная, как правило, небольшая по размерам программа, которая может записывать (внедрять) свои копии (возможно, изменённые) в компьютерные программы, расположенные в исполнимых файлах, системных областях дисков, драйверах, документах и т.д., причём эти копии сохраняют возможность к «размножению». Процесс внедрения вирусом своей копии в другую программу (системную область диска и т.д.) называется ЗАРАЖЕНИЕМ, а программа или иной объект, содержащий вирус - ЗАРАЖЁННЫМ.

Часто с началом компьютерной эпидемии связывают имя уже упоминаемого Роберта Морисса студента Корнельского университета (США), в результате действий которого зараженными оказались важнейшие компьютерные сети восточного и западного побережий США. Эпидемия охватила более б тысяч компьютеров и 70 компьютерных систем. Пострадавшими оказались, в частности, компьютерные центры НАСА, Ливерморской лаборатории ядерных исследований, Гарвардского, Питсбургского, Мэрилендского, Висконсинского, Калифорнийского, Стэндфордского университетов. Пикантность ситуации в том, что отец Р. Морисса - высокопоставленный сотрудник отдела безопасности компьютеров Агентства национальной безопасности .

А изобретателем вируса является, однако, совсем другой человек. В августе 1984 года студент Калифорнийского университета Фред Коуэн, выступая на одной из конференций, рассказал про свои опыты с тем, что один его друг назвал «компьютерным вирусом». Когда началось практическое применение вирусов, неизвестно, ибо банки, страховые компании, предприятия, обнаружив, что их компьютеры заражены вирусом, не допускали, чтобы сведения об этом просочились наружу.

Существует несколько основных критериев, по которым можно классифицировать вирусы:

  • поддерживаемая ОС (операционная система),
  • среда обитания,
  • способ заражения,
  • особенности алгоритма работы
  • деструктивные возможности.

Что касается первого пункта, здесь все достаточно понятно без особых объяснений - речь идет о способности вируса воздействовать на объекты той или иной операционной системы.

Теперь о среде обитания вирусов. Здесь можно выделить четыре категории:

  • Файловые вирусы - чтобы размножиться, используют файловую систему, внедряясь в исполняемые файлы практически любой ОС: DOS, Windows, Unix/Linix, MacOS, OS/2 etc., независимо от ее версии. Иногда это могут быть даже исходные тексты программ, библиотечные или объектные модули.
  • Макровирусы иногда не выделяют в отдельный класс, причисляя их к предыдущему. На наш взгляд, подобная систематизация не совсем верна, поскольку их пишут на макроязыках, встроенных в некоторые системы обработки данных - чаще всего это текстовые редакторы или электронные таблицы.
  • Загрузочные вирусы - как несложно догадаться из названия, заражают загрузочный сектор гибкого диска или MBR (Master Boot Record) винчестера. Они подставляют свой код вместо программы, которая должна получать управление при старте системы; кроме того, зачастую переносят boot-сектор в другую область носителя.
  • Сетевые вирусы активно используют различные протоколы и возможности LAN (Local Area Network) или WAN (Wide Area Network). Границы данного термина весьма зыбки - далеко не каждую заразу, распространяющуюся по сети, принято относить к данной категории. Основная отличительная особенность сетевых вирусов состоит в их способности самостоятельно передавать свой код на удаленную рабочую станцию или сервер.

Существует также великое множество различных комбинаций перечисленных вирусов - например, файлово-загрузочные. Бороться с ними еще сложнее, а наносимый ущерб еще ощутимее; конечно, и алгоритм работы подобных вирусов гораздо изысканнее.

На очереди не менее важная характеристика - способ инфицирования системы. Он может быть резидентным и нерезидентным. В первом случае в ОЗУ (оперативном запоминающем устройстве) компьютера находится часть тела вируса, перехватывающая обращения ОС, например, к тем же файлам и заражающая их. Подобные вирусы активны в течение всего сеанса работы. Нерезидентные же, наоборот, действуют только в течение определенного промежутка времени, оставляя оперативную память "стерильно чистой". Для полноты картины надо сказать, что некоторые их них все же оставляют программы в оперативке, но последние не участвуют в распространении вируса.

В общем-то, мы уже вплотную подобрались к особенностям алгоритмов работы - согласитесь, ведь способ инфицирования системы тоже является частью алгоритма. Если есть желание вдаваться в подробности, то и здесь можно выделить огромное количество категорий. Остановимся на самых распространенных:

  • - Компаньоны никогда не изменяют существующих файлов, а создают файл-спутник с одинаковым именем и похожим расширением. Например, в DOS'е наряду с file.exe появляется file.com - естественно, зараженный. Достаточно в командной строке дать директиву запуска file (без расширения), и ОС выполнит file.com (приоритет расширения *.com выше, чем *.exe), после чего вирус ворвется в систему.
  • Сетевые черви действуют подобно компаньонам, только они распространяются по сети. Иногда они оставляют дополнительные файлы на дисках после себя, а иногда ограничиваются пространством ОЗУ. Как и предыдущие, содержимое дисков машины они не изменяют.
  • Паразиты, наоборот, при своем распространении ведут себя деструктивно по отношению к дискам и файлам.
  • Невидимки - куда более сложные вирусы. Их название неслучайно, они действительно могут полностью или частично скрывать себя в системе. Иногда невидимки временно лечат пораженные участки или подставляют вместо них "здоровые", перехватывая соответствующие обращения ОС.
  • Полиморфные - тоже весьма совершенные вирусы. Соответственно, их еще сложнее обнаружить - они не содержат сигнатур, т. е. ни одного постоянного участка кода. Такой прием очень популярен, в том или ином виде его можно встретить во многих существующих разновидностях вирусов. Иногда его еще называют самошифрованием.
  • Студенты, - как всегда, "в семье не без урода" :-). Нет, против студентов как таковых мы ничего не имеем против, то ли дело вирусы... Изделия подобного рода не отличаются особой сложностью или оригинальностью, они зачастую нерезиденты и нередко содержат ошибки. В одних случаях это спасает, в других приводит к еще более плачевным результатам.

Наконец, обратимся к деструктивным возможностям. Обычно различают 4 категории вирусов (хотя деление весьма условно) - в литературе их называют по-разному и не всегда точно. Поэтому мы предлагаем свою версию:

  • Переселенцы - влияние таких вирусов на систему можно свести только к распространению, а значит, лишь некоторому уменьшению количества свободных ресурсов.
  • Шутники - лучше всего их воспримут люди с развитым чувством юмора. Помимо некоторого естественного уменьшения общей производительности системы, они могут... спеть песенку или нарисовать на экране солнышко. Все зависит от фантазии самого программиста и от его уровня культуры, а то иногда вместо песенки нецензурная брань получается :-).
  • Диверсанты - приводят к серьезным сбоям в работе системы.
  • Разрушители - уничтожают программы, данные, затирают системные области и т. п.

Закончив классификацию вирусов по всем возможным параметрам, самое время сказать: существует и множество других вредных программ, так или иначе нацеленных на нанесение ущерба системе. Это логические бомбы или троянские кони, проявляющие себя в самый неподходящий момент, злые шутки с сообщениями о нанесении якобы ущерба компьютеру, хотя на самом деле ничего не происходит, есть даже конструкторы вирусов и полиморфик-генераторы. С их помощью в наш век высоких технологий даже ребенок без особых усилий может создать весьма грозное оружие - остается только уповать на здравый смысл.

Вывод: ни одна организация в современном обществе не может быть застрахована от угрозы компьютерного нападения, т.к. компьютерные системы обладают достаточно большим количеством уязвимых мест, делающим их весьма привлекательными для преступников, которые учатся извлекать выгоду из новейших достижений науки и техники.


10.5. Предупреждение компьютерных преступлений

На основе данных, полученных в ходе анализа отечественной и зарубежной специальной литературы и публикаций в периодической печати по вопросам теории и практики борьбы с компьютерной преступностью, можно выделить три основные группы мер предупреждения компьютерных преступлений:

1) правовые;

2) организационно-технические;

3) криминалистические.

Правовые меры

К правовым мерам следует отнести разработку норм, устанавливающих ответственность за компьютерные преступления, защиту авторских прав программистов, совершенствование уголовного и гражданского законодательства, а также судопроизводства. К правовым мерам относятся также вопросы общественного контроля за разработчиками компьютерных систем и принятие соответствующих международных. предупреждения компьютерных преступлений в первую очередь относятся нормы законодательства, устанавливающие уголовную ответственность за указанные выше противоправные деяния.

История развития законодательства зарубежных стран в этом направлении показывает, что впервые подобный шаг был предпринят законодательными собраниями американских штатов Флорида и Аризона уже в 1978 году. Принятый закон назывался “Computer crime act of 1978” и был первым в мире специальным законом, устанавливающим уголовную ответственность за компьютерные преступления. Затем практически во всех штатах США (в 45 штатах) были приняты аналогичные специальные законодательства.

Эти правовые акты стали фундаментом для дальнейшего развития законодательства в целях осуществления мер предупреждения компьютерных преступлений.

Отечественное законодательство также движется в этом направлении.

Только в последние годы появились работы по проблемам правовой борьбы с компьютерной преступностью, (в частности, это работы В.В. Крылова, Н.Г. Шурухнова, Ю. Батурина, М. Карелиной, В. Вехова) и совсем недавно отечественное законодательство встало на путь борьбы с компьютерной преступностью. И поэтому, представляется весьма важным расширить правовую и законодательную информированность специалистов и должностных лиц, заинтересованных в борьбе с компьютерными преступлениями.

До недавнего времени, а именно до 1 января 1997 года, даты вступления в действие нового Уголовного Кодекса Российской Федерации (УК РФ), в России отсутствовала возможность эффективно бороться с компьютерными преступлениями. Несмотря на явную общественную опасность, данные посягательства не были противозаконными, т.е. они не упоминались нашим уголовным законодательством. Хотя, еще до принятия нового УК в России была осознана необходимость правовой борьбы с компьютерной преступностью. Был принят ряд законов, которые внесли правовую определенность в явление компьютеризации нашего общества вообще и проблему компьютерной преступности в частности и вместе с другими правовыми актами сформировали пласт, именуемый "законодательством в сфере информатизации", охватывающий в настоящее время несколько сотен нормативно-правовых актов.

Непосредственно законодательство России в области информатизации начало формироваться с 1991 года и включало до 1997 года десять основных законов. Это закон "О средствах массовой информации" (27.12.91 г. N 2124-I), Патентный закон РФ (от 23.09.92 г. N 3517-I), закон "О правовой охране топологий интегральных микросхем" (от 23.09.92 г. N 3526-I), закон "О правовой охране программ для электронных вычислительных машин и баз данных" (от 23.09.92 г. N 3523-I), Основы законодательства об Архивном фонде РФ и архивах (от 7.07.93 г. N 5341-I), закон "Об авторском праве и смежных правах" (от 9.07.93 г. N 5351-I), закон "О государственной тайне" (от 21.07.93 г. N 5485-I), закон "Об обязательном экземпляре документов" (от 29.12.94 г. N 77-ФЗ), закон "О связи" (от 16.02.95 г. N 15-ФЗ), закон "Об информации, информатизации и защите информации" (от 20.02.95 г. N 24-ФЗ), закон "Об участии в международном информационном обмене" (от 5.06.1996 г. N 85-ФЗ).

В данных законах определяются основные термины и понятия в области компьютерной информации (например, такие как компьютерная информация, программа для ЭВМ, ЭВМ (компьютер), сеть ЭВМ, база данных), регулируются вопросы ее распространения, охраны авторских прав, имущественные и неимущественные отношения, возникающие в связи с созданием, правовой охраной и использованием программного обеспечения и новых информационных технологий. Также осуществлено законодательное раскрытие понятий информационной безопасности и международного информационного обмена.

Таким образом, в настоящее время на уровне действующего законодательства России можно было считать в достаточной степени урегулированными вопросы охраны исключительных прав и частично защиту информации (в рамках государственной тайны). Не получили достойного отражения в законодательстве права граждан на доступ к информации и защита информации, т.е. то, что напрямую связано с компьютерными преступлениями.

Решающим законодательным шагом можно считать принятие 24 мая 1996г. Государственной Думой РФ Уголовного Кодекса Российской Федерации и выделяющего информацию в качестве объекта уголовно-правовой охраны.

Между тем общеизвестно, что одними правовыми мерами не всегда удается достичь желаемого результата в деле предупреждения преступлений.

Тогда следующим этапом становится применение мер организационно-технического характера для защиты СКТ от противоправных посягательств на них.


Организационно-технические меры

По методам применения тех или иных организационно-технических мер предупреждения компьютерных преступлений специалистами отдельно выделяются три их основные группы:

1) организационные;

2) технические;

3) комплексные.

Организационные меры защиты СКТ включают в себя совокупность организационных мероприятий: по подбору, проверке и инструктажу персонала; разработке плана восстановления информационных объектов после входа их из строя; организации программно-технического обслуживания СКТ; возложению дисциплинарной ответственности на лиц по обеспечению безопасности конкретных СКТ; осуществлению режима секретности при функционировании компьютерных систем; обеспечению режима физической охраны объектов; материально-техническому обеспечению и т.д.

Организационные меры являются важным и одним из эффективных средств защиты информации, одновременно являясь фундаментом, на котором строится в дальнейшем вся система защиты.

Анализ материалов отечественных уголовных дел позволяет сделать вывод о том, что основными причинами и условиями, способствующими совершению компьютерных преступлений в большинстве случаев стали:

1) неконтролируемый доступ сотрудников к клавиатуре компьютера, используемого как автономно, так и в качестве рабочей станции автоматизированной сети для дистанционной передачи данных первичных бухгалтерских документов в процессе осуществления финансовых операций;

2) бесконтрольность за действиями обслуживающего персонала, что позволяет преступнику свободно использовать ЭВМ в качестве орудия совершения преступления;

3) низкий уровень программного обеспечения, которое не имеет контрольной защиты, обеспечивающей проверку соответствия и правильности вводимой информации;

4) несовершенство парольной системы защиты от несанкционированного доступа к рабочей станции и ее программному обеспечению, которая не обеспечивает достоверную идентификацию пользователя по индивидуальным биометрическим параметрам;

5) отсутствие должностного лица, отвечающего за режим секретности и конфиденциальности коммерческой информации;

6) отсутствие категорийности допуска сотрудников к документации строгой финансовой отчетности;

7) отсутствие договоров (контрактов) с сотрудниками на предмет неразглашения коммерческой и служебной тайны, персональных данных и иной конфиденциальной информации.

Для эффективной безопасности от компьютерных преступлений всего лишь необходимо:

  • просмотреть всю документацию в учреждении, организации;
  • ознакомиться с функциями и степенью ответственности каждого сотрудника;
  • определить возможные каналы утечки информации;
  • ликвидировать обнаруженные слабые звенья в защите.

Зарубежный опыт показывает, что наиболее эффективной мерой в этом направлении является введение в штатное расписание организации должности специалиста по компьютерной безопасности (администратора по защите информации) либо создание специальных служб как частных, так и централизованных, исходя из конкретной ситуации. Наличие такого отдела (службы) в организации снижает вероятность совершения компьютерных преступлений вдвое.

Кроме этого, в обязательном порядке должны быть реализованы следующие организационные мероприятия:

1) для всех лиц, имеющих право доступа к СКТ, должны быть определены категории допуска;

2) определена административная ответственность для лиц за сохранность и санкционированность доступа к имеющимся информационным ресурсам;

3) налажен периодический системный контроль за качеством защиты информации посредством проведения регламентных работ как самим лицом, ответственным за безопасность, так и с привлечением специалистов;

4) проведена классификация информации в соответствии с ее важностью;

5) организована физическая защита СКТ (физическая охрана).

Помимо организационно-управленческих мер, существенную общепрофилактическую роль в борьбе с компьютерными преступлениями могут играть также меры технического характера. Условно их можно подразделить на три основные группы в зависимости от характера и специфики охраняемого объекта, а именно: аппаратные, программные и комплексные.

Аппаратные методы предназначены для защиты аппаратных средств и средств связи компьютерной техники от нежелательных физических воздействий на них сторонних сил, а также для закрытия возможных нежелательных каналов утечки конфиденциальной информации и данных, образующихся за счет побочных электромагнитных излучений и наводок, виброакустических сигналов, и т.п.

Практическая реализация данных методов обычно осуществляется с помощью применения различных технических устройств специального назначения. К ним, в частности, относятся:

1) источники бесперебойного питания, предохраняющие от скачкообразных перепадов напряжения;

2) устройства экранирования аппаратуры, линий проводной связи и помещений, в которых находятся СКТ;

3) устройства комплексной защиты телефонии;

4) устройства, обеспечивающие только санкционированный физический доступ пользователя на охраняемые объекты СКТ (шифрозамки, устройства идентификации личности и т.п.);

5) устройства идентификации и фиксации терминалов и пользователей при попытках несанкционированного доступа к компьютерной сети;

6) средства охранно-пожарной сигнализации;

7) средства защиты портов компьютерной техники (наиболее эффективны для защиты компьютерных сетей от несанкционированного доступа) и т.д.

Программные методы защиты предназначаются для непосредственной защиты информации по трем направлениям: а) аппаратуры; б) программного обеспечения; в) данных и управляющих команд.

Для защиты информации при ее передаче обычно используют различные методы шифрования данных перед их вводом в канал связи или на физический носитель с последующей расшифровкой. Как показывает практика, методы шифрования позволяют достаточно надежно скрыть смысл сообщения.

Все программы защиты, осуществляющие управление доступом к машинной информации, функционируют по принципу ответа на вопросы: кто может выполнять, какие операции и над какими данными.

Доступ может быть определен как:

  • общий (безусловно предоставляемый каждому пользователю);
  • отказ (безусловный отказ, например разрешение на удаление порции информации);
  • зависимый от события (управляемый событием);
  • зависимый от содержания данных;
  • зависимый от состояния (динамического состояния компьютерной системы);
  • частотно-зависимый (например, доступ разрешен пользователю только один или определенное число раз);
  • по имени или другим признаком пользователя;
  • зависимый от полномочий;
  • по разрешению (например, по паролю);
  • по процедуре.

Также к эффективным мерам противодействия попыткам несанкционированного доступа относятся средства регистрации. Для этих целей наиболее перспективными являются новые операционные системы специального назначения, широко применяемые в зарубежных странах и получившие название мониторинга (автоматического наблюдения за возможной компьютерной угрозой).

Мониторинг осуществляется самой операционной системой (ОС), причем в ее обязанности входит контроль за процессами ввода-вывода, обработки и уничтожения машинной информации. ОС фиксирует время несанкционированного доступа и программных средств, к которым был осуществлен доступ. Кроме этого, она производит немедленное оповещение службы компьютерной безопасности о посягательстве на безопасность компьютерной системы с одновременной выдачей на печать необходимых данных (листинга).

В последнее время в США и ряде европейских стран для защиты компьютерных систем действуют также специальные подпрограммы, вызывающие самоуничтожение основной программы при попытке несанкционированного просмотра содержимого файла с секретной информацией по аналогии действия “логической бомбы”.

При рассмотрении вопросов, касающихся программной защиты информационных ресурсов особо надо подчеркнуть проблему защиты их от компьютерных вирусов.

Здесь необходимо активно использовать специальные программные антивирусные средства защиты (как зарубежного, так и отечественного производства). Антивирусные программы своевременно обнаруживают, распознают вирус в информационных ресурсах, а также “лечат” их. Подобно вирусам, их тоже можно поделить на несколько категорий:

  • Сканеры - наиболее популярные программы. Они проверяют файлы, секторы дисков и системную память на наличие как известных, так и неизвестных типов вирусов. Зачастую они используют эвристические алгоритмы, анализируя последовательности команд в проверяемых объектах и набирая определенную статистику, на основе которой "выносят приговор" - "болен", "не болен".
  • CRC-сканеры подсчитывают контрольные суммы для вышеозначенных объектов, при этом они менее популярны, чем обычные сканеры. И напрасно: некоторые из них содержат алгоритмы, направленные против вирусов-невидимок, благодаря чему их эффективность приближается к ста процентам!
  • Мониторы - это резидентные программы, "перехватывающие" с их точки зрения подозрительные действия и сообщающие о них пользователю. Они замечательны своей способностью выявлять вирусы на самых ранних стадиях проникновения в систему, не давая им ни малейшего шанса что-нибудь испортить.
  • Иммунизаторы делают систему невосприимчивой к тому или иному типу вирусов, т. е. их действие избирательно. Они бывают двух типов: одни сообщают о заражении, другие его блокируют.


Обзор наиболее распространенных антивирусных пакетов

Антивирус Dr. Web

РАЗРАБОТЧИК: Лаборатория Данилова и ДиалогНаука ( http://www.drweb.ru)
УСЛОВИЯ РАСПРОСТРАНЕНИЯ: коммерческий продукт (1000 руб. на год), есть демо-версия

ОСНОВНЫЕ ФУНКЦИИ: Dr. Web - старый и заслуженно популярный в России антивирус, уже несколько лет помогающий пользователям в борьбе с вирусами. Новые версии программы (DrWeb32) работают в нескольких операционных системах, защищая пользователей от более чем 17000 вирусов.

Набор функций вполне стандартный для антивируса - сканирование файлов (в том числе сжатых специальными программами и заархивированных), памяти, загрузочных секторов жестких дисков и дискет. Троянские программы, как правило, подлежат не излечению а удалению. К сожалению, почтовые форматы не проверяются, поэтому сразу после получения электронного письма нельзя узнать, нет ли во вложении вируса. Вложение придется сохранить на диск и проверять отдельно. Впрочем, поставляемый с программой резидентный монитор "Spider Guard" позволяет решить эту задачу "на лету".

Dr. Web - одна из первых программ, в которой был реализован эвристический анализ, который позволяет обнаруживать вирусы, не занесенные в антивирусную базу. Анализатор обнаруживает в программе вирусоподобные инструкции и помечает такую программу как подозрительную. Антивирусная база обновляется через Интернет одним нажатием кнопки. Бесплатная версия программы не проводит эвристического анализа и не лечит файлы.

НАСТРОЙКА ПРОГРАММЫ: полный спектр настроек классического антивируса. Области сканирования по умолчанию, типы файлов, которые надо сканировать, как реагировать на зараженные и подозрительные файлы, настройки протоколирования, и т.д. Настроек довольно много, но они достаточно просты, да и система помощи (вызываемая нажатием правой кнопки мыши) поможет разобраться в тонкостях той или иной опции.

ЭФФЕКТИВНОСТЬ ИСПОЛЬЗОВАНИЯ: программа очень эффективна против известных ей "троянцев" и вирусов. Награды Virus Bulletin 100% свидетельствуют о высоком качестве обнаружения вирусов, имеющих реальное распространение в мире. Что же до обнаружения троянцев, то программе известны далеко не все из них, но успешно решена проблема с наиболее распространенными экземплярами. Рекомендуется использовать в сочетании с хорошим брандмауэром для обеспечения максимальной защиты от троянцев.

ДОСТОИНСТВА: эффективно обнаруживает и лечит вирусы и "троянские кони", имеет русский интерфейс, удобна в настройке и использовании.

НЕДОСТАТКИ: скорость сканирования могла бы быть и повыше.

ОБЩАЯ ОЦЕНКА: эффективное средство в борьбе с вирусами и "троянцами", если используется наряду с другими программами, обеспечивающими другие способы защиты.

Norton AntiVirus 2000

РАЗРАБОТЧИК: Symantec Corp. (http://www.symantec.com/)
УСЛОВИЯ РАСПРОСТРАНЕНИЯ: $54, есть 30-дневная пробная версия

ОСНОВНЫЕ ФУНКЦИИ: Norton AntiVirus сделана на основе другого популярного продукта - персонального брандмауэра AtGuard (@guard) от WRQ Soft. В результате приложения к нему технологической мощи Symantec, получился интегрированный продукт, обладающий существенно расширенной функциональностью. Ядром системы по-прежнему является брандмауэр. Он весьма эффективно работает без настройки, практически не мешая в повседневном использовании сети, но блокируя попытки перезагрузить или "завесить" компьютер, получить доступ к файлам и принтерам, установить связь с троянскими программами на компьютере.

Norton AntiVirus - единственный брандмауэр из рассмотренных, который реализует возможности этого метода (которого) защиты на 100%. Осуществляется фильтрация всех видов пакетов, путешествующих по сети, в т.ч. служебных (ICMP), правила для работы брандмауэра могут учитывать, какое именно приложение работает с сетью, что за данные передаются и на какой компьютер, в какое время суток это происходит.

Для сохранения конфиденциальных данных, брандмауэр может блокировать отправку веб-серверам адреса электронной почты, типа браузера, возможна также блокировка cookies. Фильтр конфиденциальной информации предупреждает о попытке переслать в сеть в незашифрованном виде информацию, которую пользователь ввел и пометил, как конфиденциальную.

Активное содержимое веб-страниц (Java-апплеты, сценарии и т.д) также может блокироваться с помощью Norton AntiVirus - фильтр содержимого может вырезать небезопасные элементы из текста веб-страниц до того, как они попадут в браузер.

В качестве дополнительного сервиса, не связанного напрямую с вопросами безопасности, Norton AntiVirus предлагает очень удобный фильтр рекламных баннеров (эти надоедливые картинки попросту вырезаются из страницы, что ускоряет ее загрузку), а также систему родительского контроля. Запретив посещение определенных категорий сайтов и запуск отдельных видов интернет-приложений, можно быть достаточно спокойным по поводу содержимого сети, которое доступно детям.

Помимо возможностей брандмауэра, Norton AntiVirus предлагает пользователю защиту программы Norton Antivirus. Это популярное антивирусное приложение с регулярно обновляемыми антивирусными базами позволяет довольно надежно обнаруживать вирусы на самых ранних этапах их появления. Сканированию на вирусы подвергаются все закачиваемые из сети файлы, файлы, вложенные в электронную почту, активные элементы веб-страниц. Помимо этого, в Norton Antivirus есть антивирусный сканер и монитор, которые обеспечивают общесистемную защиту от вирусов без привязки к наличию доступа в сеть.

НАСТРОЙКА ПРОГРАММЫ: Norton AntiVirus поступает к пользователю в полностью готовом к употреблению виде. Сразу после установки происходит обновление антивирусных баз и сканирование всех дисков на наличие вирусов и троянских программ. Брандмауэр имеет очень продуманную трехуровневую систему настройки. Для самых неопытных пользователей настройка будет заключаться в установке двух переключателей - "Security" ("Безопасность") и "Privacy" ("Конфиденциальность") в положение "низкая", "средняя", "высокая", а также включении или выключении фильтра рекламы и родительского контроля. Помимо этого, нужно еще ввести конфиденциальную информацию, которая не должна пересылаться в незашифрованном виде. Более опытные пользователи могут нажать на кнопку "Custom level" ("собственный уровень") и определить настройки безопасности более подробно. Эксперты по безопасности могут вызвать дополнительный диалог настроек и определять правила работы брандмауэра вручную - с указанием портов, серверов и других технических подробностей.

Наиболее приятной особенностью брандмауэра является его самообучаемость. Наименее опытные пользователи могут предоставить программе учиться самой, более опытным доступен "Мастер правил", который будет появляться всякий раз, когда Norton AntiVirus сталкивается с попыткой установить непонятное соединение по сети. С помощью этого мастера можно на один раз или навсегда разрешить или запретить подобные соединения.

ЭФФЕКТИВНОСТЬ ИСПОЛЬЗОВАНИЯ: комплексный подход к защите компьютера, реализованный в Norton AntiVirus , позволяет спокойно работать в сети, не опасаясь попыток "завесить" или перезагрузить компьютер, получить доступ к файлам и принтерам через интернет или украсть конфиденциальную информацию. Брандмауэр работает таким образом, что для большинства попыток сканирования сети, которое делают хакеры, компьютер попросту невидим. Это - один из лучших методов защиты, поскольку он позволяет в принципе избежать нападения.

Брандмауэр и антивирус обеспечивают двухуровневую защиту от троянцев, вирусов и небезопасного активного содержимого веб-страниц. Грамотная настройка "по умолчанию" позволяет достаточно спокойно работать в сети через 5 минут после инсталляции программы и не углубляясь в тонкости работы интернет-протоколов. Фильтр активного содержимого снижает риск при просмотре соответствующих веб-страниц, хотя полная фильтрация активного содержимого обедняет современные высокотехнологичные веб-сайты.

Технология LiveUpdate позволяет обновлять через Интернет антивирусные базы, данные о сайтах, не рекомендованным детям, и т.д.

ДОСТОИНСТВА: комплексный подход к защите, нейтрализующий большинство факторов риска, связанных с Интернет. Очень удобная конфигурация, которая удовлетворит пользователя любого уровня. Грамотно и полноценно реализованы оба основных компонента системы - брандмауэр и антивирус.

НЕДОСТАТКИ: достаточно высокая цена, крайне неудобная система закачки программы из Интернет и большой размер дистрибутива (50 Мб).

ОБЩАЯ ОЦЕНКА: полноценная система безопасности, надежно защищающая от основных опасностей сети, подходящая для всех групп пользователей, вне зависимости от опыта и рода деятельности.

Антивирус Antiviral Toolkit Pro

РАЗРАБОТЧИК: Лаборатория Касперского (http://www.kasperskylab.ru/)
УСЛОВИЯ РАСПРОСТРАНЕНИЯ: коммерческий продукт ($50 на 2 года), есть демо-версия

ОСНОВНЫЕ ФУНКЦИИ: Antiviral Toolkit Pro - российский продукт, заслуживший популярность за рубежом и в России, благодаря широчайшим возможностям и высокой надежности. Имеются версии программы для большинства популярных операционных систем, антивирусная база насчитывает около 34000 вирусов.
Существует несколько вариантов поставки - AVP Lite, AVP Gold, AVP Platinum. В наиболее полной версии поставляется три продукта - сканер, резидентный монитор и центр управления. Сканер позволяет проверять файлы и память на наличие вирусов и "троянцев". При этом проверяются упакованные программы, архивы, почтовые базы данных (папки Outlook и т.д.) и осуществляется эвристический анализ для поиска новых вирусов, не занесенных в базу данных. Монитор "на лету" проверяет каждый открываемый файл на вирусы и предупреждает о вирусной опасности, одновременно блокируя доступ к зараженному файлу. Центр управления позволяет по расписанию проводить антивирусную проверку и обновлять базы данных через Интернет. В демонстрационной версии отсутствует возможность лечения зараженных объектов, проверка пакованных и архивных файлов, эвристический анализ.

НАСТРОЙКА ПРОГРАММЫ: все настройки, присущие антивирусам реализованы в полном объеме. Области сканирования по умолчанию, подлежащие сканированию типы файлов, реакция на обнаружение зараженного или подозрительного объекта, настройки протоколирования, и т.д. Полностью сформированные настройки можно сохранять и загружать в виде отдельных конфигураций антивируса. Все настройки снабжены подробной справкой. Интерфейс - на русском языке.

ЭФФЕКТИВНОСТЬ ИСПОЛЬЗОВАНИЯ: программа очень эффективна против известных ей "троянцев" и вирусов. Многочисленные награды Virus Bulletin 100% подтверждают репутацию качественного продукта. Рекомендуется использовать в сочетании с хорошим брандмауэром для обеспечения максимальной защиты от троянцев. Следует обратить внимание, что некоторые специфические программы для сканирования сетей (инструмент хакеров, но и системных администраторов) программа также идентифицирует как троянские.

ДОСТОИНСТВА: эффективно обнаруживает и лечит вирусы и "троянские кони", имеет русский интерфейс, удобна в настройке и использовании.

НЕДОСТАТКИ: слишком "подозрительна" к инструментальным средствам системного администратора.

ОБЩАЯ ОЦЕНКА: эффективное средство в борьбе с вирусами и "троянцами".


Комплексные организационно-технические меры

Однако, наряду с использованием антивирусных программ, для уменьшения опасности вирусных посягательств на СКТ необходимо предпринять комплексные организационно-технические меры.

1. Информировать всех сотрудников учреждения, организации, использующих СКТ, об опасности и возможном ущербе в случае совершения вирусного посягательства.

2. Запретить сотрудникам приносить на рабочее место программные средства (ПС) “со стороны” для работы с ними на СКТ учреждения, организации по месту работы сотрудника.

3. Запретить сотрудникам использовать, хранить на носителях и в памяти ЭВМ компьютерные игры.

4. Предостеречь сотрудников организации от использования ПС и носителей машинной информации, имеющих происхождение из учебных заведений различного уровня и профиля.

5. Все файлы, которые поступают из внешней компьютерной сети должны обязательно тестироваться.

6. Создать архив копий ПС, используемых в непосредственной работе организации.

7. Регулярно просматривать хранимые в компьютерной системе ПС, создавать новые их архивные копии; где это возможно, использовать защиту типа “только чтение” для предупреждения несанкционированных манипуляций с ценными данными.

8. Периодически проводить ревизионную проверку контрольных сумм файлов, путем их сличения с эталоном.

9. Использовать для нужд электронной почты отдельный стендовый компьютер или ввести специальный отчет.

10. Установить системы защиты информации на особо важных ЭВМ. Заактивировать на них специальные комплексные антивирусные ПС.

11. Постоянно контролировать исполнение установленных правил обеспечения безопасности СКТ и применять меры дисциплинарного воздействия к лицам, сознательно или неоднократно нарушавшим их и т.д.

Вывод: компьютерное преступление является преступлением с четко выраженными этапами развития и поэтому может быть предотвращено. Для профилактики компьютерных преступлений необходимо выполнять комплекс правовых, организационно-технических и комплексных мер по защите информации.


10.7. Глоссарий

Антивирусные программы – специальные программные средства защиты (как зарубежного, так и отечественного производства), которые своевременно обнаруживают, распознают вирус в информационных ресурсах, а также “лечат” их.

Загрузочный вирус – поражает не программные файлы, а определенные системные области магнитных носителей

Защита данных – комплекс мер, направленных на предотвращение утраты, воспроизведения и модификации данных.

Компьютерный вирус – специально написанная компьютерная программа, способная самопроизвольно присоединяться к другим программам, создавать свои копии, внедрять их в файлы с целью порчи файлов и каталогов, создания помех в работе.

Макровирус – разновидность вирусов, поражающая документы, имеющие средства для исполнения макрокоманд.

Хакер – (1) пользователь, пытающийся получить незаконный доступ к конфиденциальной или неоплаченной информации (обычно в компьютерной сети). (2) Пользователь, вносящий несанкционированные изменения в программное обеспечение, приводящее к нарушению авторских прав создателей программного продукта.


10.8. Библиографический список

1. Крылов В.В. Информационные компьютерные преступления.-М.:ИНФА М-НОРМА,1997.

2. Расследование неправомерного доступа к компьютерной информации/Под ред. Н.Г.Шурухнова. – М.:Щит-М, 1999

3. Мельников В.В. Защита информации в компьютерных системах. – М.: Финансы и статистика; Электроинформ, 1997.

4. Айков Д., Сейгер К., Фонсторх У. Компьютерные преступления. Руководство по борьбе с коипьютерными преступлениями: - М.: Мир,1999.

5. С. В. Вихорев, В. Г. ГерасименкоБорьба с преступлениями в банковских информационно - вычислительных системах. По материалам журнала «Системы безопасности связи и телекоммуникаций» №10-11 1997 г.

6. Материалы Международной конференции «Информатизация правоохранительных систем». Москва 1999.

7. Акапьев В.Л., Прокопенко А.Н. Информатика и математика в деятельности ОВД. Часть II. Белгород 1998.


10.6. Контрольные вопросы

  1. Какие существуют виды компьютерных преступлений?
  2. В каких документах перечислены составы компьютерных преступлений?
  3. Какие наиболее распространенные объекты компьютерных преступлений?
  4. Какие существуют приемы, применяемые в компьютерных преступлениях?
  5. Какими методами можно предупредить компьютерные преступления?
  6. Что такое компьютерный вирус?
  7. Какие симптомы в работе компьютера должны насторожить пользователя?
  8. Все ли вирусы опасны?
  9. Какие бывают виды вирусов?
  10. Какие существуют виды антивирусных программ, принципы их действия?
  11. Какие Вы знаете самые распространенные антивирусные программы, их достоинства и недостатки?
  12. Как уберечь компьютер от вирусов?


5.12. ПРИМЕРЫ ВЫПОЛНЕНИЯ ТИПОВЫХ ЗАДАЧ

Пример 1. Выравнивание содержимого ячейки

Сформировать общие заголовки столбцов для шапки следующей таблицы

Периоды |  |  |
2001 |  | 2002 |
1п/г | 2 л/г | 1п/г | 2п/г

Последовательность действий.

1. Создать новую рабочую книгу с помощью команды меню Файл -> Создать выбрать шаблон – Книга.

2. Сохранить рабочую книгу с помощью команды меню Файл -> Сохранить как, имя файла – Примеры.XLS.

3. Установить курсор в любую ячейку на листе Лист1.

4. Переименовать рабочий лист с помощью команды меню
Формат -> Лист -> Переименовать, имя листа – Пример 1.

5. Установить курсор в ячейку А1.

6. Выделить ячейки A1:D1.

7. Выполнить команду меню Формат -> Ячейки. На вкладке Выравнивание указать выравнивание по горизонтали – По центру выделения, отображение – Объединение ячеек. Нажать Ок.

8. Ввести слово Периоды.

9. Выделить ячейки А2:В2 и повторить п. 7. Ввести год 2001.

10. Выделить ячейки C2:D2 и повторить п 7. Ввести год 2002.

10. Заполнить остальные поля таблицы:

Периоды
2001 |  | 2002
1 п/г | 2п/г | 1 п/г | 2 п/г

11. Закрыть рабочую книгу с сохранением – команда Файл -> Закрыть.


Пример 2

Пример 2. Использование именованных блоков ячеек

Подготовить таблицы «Тарифные ставки» и «Картотека» для расчета сдельной зарплаты. Создать именованные блоки ячеек.

1. Открыть файл Примеры.XLS с помощью команды меню Файл -> Открыть.

2. Вставить новый лист (если требуется) с помощью команды меню Вставка -> Лист.

3. Переименовать новый лист с помощью команды меню Формат -> Лист -> Переименовать, указать – Тарифы.

4. На листе Тарифы, начиная с ячейки А1, создать следующую таблицу:

Разряд | Коэффициент | Ставка
1 | 1 | 3,67
2 | 1,35 | =$C$2*B3
3 | 1,57 | =$C$2*B4
4 | 1,85 | =$C$2*B5
5 | 2,12 | =$C$2*B6
6 | 2,57 | =$C$2*B7

5. Создать именованные блоки ячеек для столбцов Разряд, Коэффициент, Ставка. Для каждого столбца следует:

– выделить все ячейки столбца, включая заголовок столбца;

– выполнить команду меню Вставка -> Имя -> Создать -> По тексту в строке выше.

6. Вставить новый лист с помощью команды меню Вставка -> Лист.

7. Переименовать новый лист с помощью команды меню Формат -> Лист -> Переименовать, указать – Картотека.

8. Перед заполнением ячеек задать текстовый формат для ячеек столбца Табельный №. Для этого надо выделить столбец В и выполнить команду меню Формат -> Ячейки, на вкладке Число выбрать формат Текстовый.

На листе Картотека, начиная с ячейки А1, создать следующую таблицу:

ФИО | Табельный номер | Профессия | Разряд работающего | Тариф | Льготы
Иванов А. П. | 01234 | Кладовщик | 3 |  | 1
Колесов В. И. | 02345 | Грузчик | 3 |  | 1
Крылов А. Р. | 00127 | Грузчик | 4 |  | 2
Михайлов П. Р. | 12980 | Грузчик | 3 |  | 2
Смирнов И. А. | 13980 | Кладовщик | 4 |  | 3
Соколов Р. В. | 21097 | Уборщик | 2 |  | 1

9. Создать именованные блоки ячеек для столбцов ФИО, Табельный номер, Профессия, Разряд работающего, Тариф, Льготы – команда меню Вставка -> Создать -> По тексту в строке выше.

10. Проверить определение блоков всеми перечисленными ниже способами:

– выбрать блоки в списке имен ячеек (в окне слева от строки формул);

– выполнить команду меню Правка -> Перейти;

– нажать клавишу F5 .

11. Сохранить подготовленные таблицы (Файл -> Сохранить).

12. Закрыть книгу с помощью команды меню Файл -> Закрыть.


Пример 3

Пример 3. Контроль ввода данных

Задать условия проверки вводимых данных в ячейки столбца Разряд работающего таблицы Картотека. Вводимые значения разряда работающих должны соответствовать тарифным разрядам.

1. Открыть файл Примеры.XLS с помощью команды меню Файл -> Открыть.

2. Выбрать лист Картотека.

3. Выделить все ячейки столбца Разряд работающего – щелкнуть левой кнопкой мыши на заголовке столбца с именем D.

4. Выполнить команду меню Данные -> Проверка.

5. На вкладке Параметры установить: тип данных – Список, источник – Разряд (вызов списка именованных блоков – F3).

6. На вкладке Сообщение для ввода задать: Заголовок окна – Разряд работающего, Сообщение – Разряд выбирается из справочника Тарифы.

7. На вкладке Сообщение об ошибке задать: Вид – Останов, Сообщение – Неправильно указан разряд.

8. Нажать кнопку ОК.

9. Заполнить ячейки столбца Разряд работающего.

10. Закрыть файл с сохранением с помощью команды меню Файл -> Закрыть.


Пример 4

Пример 4. Транспонирование блока ячеек

Транспонирование выделенного блока ячеек выполняется путем создания копии в буфере обмена и вставки с помощью команд меню Правка-> Специальная вставка. Для вставки блока в транспонированном виде с поворотом указать Транспонировать. При этой операции все формулы в ячейках таблицы сохраняются.

Транспонировать матрицу размерностью 5 строк на 2 столбца или сокращенно – 5x2. Элементы матрицы находятся в ячейках А1:В5. Первый элемент транспонированной матрицы начинается в ячейке D3.

1. Открыть файл Примеры.ХLS с помощью команды меню Файл -> Открыть.

2. Вставить, если необходимо, новый лист с помощью команды меню Вставка -> Лист.

3. Переименовать новый лист с помощью команды меню Формат -> Лист -> Переименовать, имя листа – Пример 4.

4. Заполнить таблицу, начиная с ячейки А1:

1 | 2
3 | 4
5 | 6
7 | 8
9 | 10

5. Выделить блок ячеек А1:В5.

6. Создать буфер обмена с помощью команды меню Правка -> Копировать.

7. Установить курсор в месте вставки первого элемента транспонируемой матрицы – ячейка D3.

8. Выполнить команду меню Правка -> Специальная вставка, указать Транспонировать.

9. Закрыть файл с сохранением – команда меню Файл -> Закрыть.


Пример 5

Пример 5. Связь копии с источником

Microsoft Excel обеспечивает поддержку связи копии с источником, если при выполнении команды меню Правка -> Специальная вставка в диалоговом окне Специальная вставка была нажата кнопка Вставить связь.

Скопировать диапазон ячеек А1:А3 в область С1:С3 с поддержкой связи копии с источником.

1. Открыть файл Примеры.ХLS с помощью команды меню Файл -> Открыть.

2. Вставить, если необходимо, новый лист с помощью команды меню Вставка -> Лист.

3. Переименовать новый лист с помощью команды меню Формат -> Лист -> Переименовать, имя листа – Пример 5.

4. Заполнить таблицу, начиная с ячейки А1:

10

20

30

5. Выделить блок ячеек А1:A3.

6. Создать буфер обмена с помощью команды меню Правка -> Копировать.

7. Установить курсор в место вставки копии – ячейка С1.

8. Выполнить специальную вставку буфера обмена с помощью команды меню Правка -> Специальная вставка, нажать кнопку Вставить связь.

9. Закрыть файл с сохранением с помощью команды меню Файл -> Закрыть.


Пример 6

Пример 6. Автозаполнение элементов списка

Ячейки электронной таблицы содержат следующие значения: ячейки А1:С1 – Завод 1, Завод 3, Завод 4; ячейки А2:С2 – Цех1, Цех3, Цех5; ячейки АЗ:СЗ – Уч1, Уч2, Уч3.

Тиражировать образцы заполнения в ячейки D1:L3:

Завод 1 | Завод 3 | Завод 4 | Завод 1 | Завод 3 | Завод 4 | Завод 1 | Завод 3 | Завод 4 | …
Цех1 | Цех3 | Цех5 | Цех7 | Цех9 | Цех11 | Цех13 | Цех15 | Цех17 | …
Уч1 | Уч2 | Уч3 | Уч4 | Уч5 | Уч6 | Уч7 | Уч8 | Уч9 | …

1. Открыть файл Примеры.XLS с помощью команды меню Файл -> Открыть.

2. Вставить, если необходимо, новый лист с помощью команды меню Вставка ->Лист.

3. Переименовать новый лист с помощью команды меню Формат -> Лист -> Переименовать, имя листа – Пример 6.

4. Заполнить таблицу: ячейки А1:С3.

5. Выделить блок ячеек А1:СЗ.

6. Установить курсор на маркер заполнения и, при нажатой левой кнопке протянуть курсор вправо по столбцам.

7. Закрыть файл с сохранением с помощью команды меню Файл -> Закрыть.


Пример 7

Пример 7. Прогрессии

Можно автоматически заполнять большие блоки ячеек числами, значение которых подчиняется арифметической или геометрической прогрессии. Для значений типа дат можно создавать прогрессии с определенной периодичностью и шагом: по месяцам, годам, рабочим дням и т. п.

Создать календарь рабочих дней, график работы – через 2 дня, кроме субботы, воскресенья, начиная с 06.09.2001 по 01.11.2001.

1. Открыть файл Примеры.XLS с помощью команды меню Файл -> Открыть.

2. Вставить, если необходимо, новый лист с помощью команды меню Вставка ->Лист.

3. Переименовать новый лист с помощью команды меню Формат -> Лист -> Переименовать, имя листа – Пример 7.

4. Ввести в ячейку А1 дату 06.09.2001.

5. Выделить блок ячеек столбца А.

6. Выполнить команду меню Правка -> Заполнить -> Прогрессия, указать тип Даты, шаг – 3, единицы – Рабочий день, предельное значение – 01.11.2001.

7. Закрыть файл с сохранением с помощью команды меню Файл -> Закрыть.


Пример 8

Пример 8. Формулы.
Расчет налога на добавленную стоимость

Вычислить сумму налога на добавленную стоимость (НДС), «чистую» (без НДС) и общую сумму, если:

  • цена единицы товара, включая НДС, – 12 500 руб.;
  • количество проданного товара – 27 шт.;
  • ставка налога на добавленную стоимость – 20 %.

1. Открыть файл Примеры.XLS с помощью команды меню Файл -> Открыть.

2. Вставить, если необходимо, новый лист с помощью команды меню Вставка ->Лист.

3. Переименовать новый лист с помощью команды меню Формат -> Лист -> Переименовать, имя листа – Пример 8.

4. Заполнить таблицу – столбцы А и В, начиная с ячейки А1. В столбце А – названия параметров, в столбце В – значения параметров:

Цена | 12 500 р. | 12 500 р.
Количество | 27 | 27
Общая стоимость | =B1*B2 | 337 500 р.
Ставка НДС | 0,2 | 20%
Сумма НДС | =B3*20/120 | 56 250р.
Стоимость без НДС | =B3-B5 | 281 250 р.

Значения, показанные справа от таблицы, представляют собой конечный результат вычислений, отображаемый в ячейках таблицы.

5. Закрыть файл с сохранением с помощью команды меню Файл -> Закрыть.


Пример 9

Пример 9. Мастер функций

С применением Мастера функций вычислить предельные расходы на рекламу, принимаемые при налогообложении, учитывая следующие лимиты расходов на рекламу:

1) при объеме выручки в год от 1 до 2 000 000 руб. лимит расходов на рекламу составляет 2 % от объема выручки;

2) при объеме выручки в год от 2 000 001 до 50 000 000 руб. лимит расходов на рекламу составляет 40 000 руб. + 1 % с суммы выручки, превышающей 2 000 000 руб.;

3) при объеме выручки в год от 50 000 001 руб. лимит расходов на рекламу составляет 520 000 руб. + 0,5 % с суммы выручки, превышающей 50 000 000 руб.

Для включения в формулу встроенной функции используется Мастер функций, который вызывается одним из способов:

– с помощью команды меню Вставка -> Функция;
– при нажатии кнопки fx (Вставка функции) на панели инструментов Стандартная.

При нажатии клавиши = (равно) или аналогичной кнопки в строке формул слева от строки формул появляется список встроенных функций для выбора.

Задание выполняем в такой последовательности:

1. Открыть файл Примеры.XLS с помощью команды меню Файл -> Открыть.

2. Вставить, если необходимо, новый лист с помощью команды меню Вставка ->Лист.

3. Переименовать новый лист с помощью команды меню Формат -> Лист -> Переименовать, имя листа – Пример 9.

4. Заполнить таблицу, введя в ячейку А1 значение объема выручки, а в ячейку А2 формулу вида:

=ЕСЛИ (А1<2000000 ;А1*0,02; ЕСЛИ (А1 < 50000001; 40000 + (А1-
-2000000)*0,01;520000+(А1 - 50000000)*0.005))

Порядок создания формулы.

4.1. Установить курсор в ячейку А2.

4.2. Нажать клавишу = .

4.3. Нажать кнопку fх для вызова Мастера функций.

4.4. Выбрать категорию функций – Логические, указать функцию – ЕСЛИ.

4.5. На экран выводится диалоговое окно функции ЕСЛИ для ввода параметров.

4.6. Установить курсор в поле Логическое_выражение и нажать «красную» кнопку.

4.7. Щелкнуть левой кнопкой мыши на ячейке А1 и дописать выражение для условия: <2000000, полный вид условия: А1<2000000.

4.8. Нажать «красную» кнопку для возврата в диалоговое окно встроенной функции ЕСЛИ.

4.9. Установить курсор в поле Значение_если_истина и нажать «красную» кнопку.

4.10. Сформировать вычисляемое выражение вида: А1*0,02. Выражение формируется вручную, за исключением ссылки на ячейку А1.

4.11. Нажать «красную» кнопку для возврата в диалоговое окно встроенной функции ЕСЛИ.

4.12. Установить курсор в поле Значение_если_ложь.

4.13. Нажать стрелку поля со списком встроенных функций (слева от строки формул).

4.14. Выбрать функцию ЕСЛИ, которая становится вложенной для первой функции ЕСЛИ, появляется новое диалоговое окно для ввода параметров вложенной функции ЕСЛИ.

4.15. Установить курсор в поле Логические_выражение и нажать «красную», кнопку,

4.16. Сформировать условие проверки: А1<50000001.

4.17. Нажать «красную» кнопку для возврата в диалоговое окно встроенной функции ЕСЛИ.

4.18. Установить курсор в поле Значение_если_истина и нажать «красную» кнопку.

4.19. Сформировать вычисляемое выражение вида:
40000+(А1-2000000)*0,01.

4.20. Нажать «красную» кнопку для возврата в диалоговое окно встроенной функции ЕСЛИ.

4.21. Установить курсор в поле Значение_если_ложь и нажать «красную» кнопку.

4.22. Сформировать вычисляемое выражение вида:
520000+(А1-50000000)*0,005.

4.23. Нажать «красную» кнопку для возврата в диалоговое окно встроенной функции ЕСЛИ.

4.24. Нажать кнопку ОК для завершения ввода формулы.

5. Проверить работу формулы, введя различные значения в ячейку А1.

6. Закрыть файл с сохранением с помощью команды меню Файл -> Закрыть.


Пример 10

Пример 10. Копирование и перемещение формул

Ячейки с формулами можно копировать и перемещать в любое место текущего листа, книги или в другой рабочей книги. Результат операции зависит от вида ссылок, используемых в формуле: относительные ссылки автоматически изменяются, абсолютные ссылки – нет. Признаком абсолютной ссылки по одной или двум координатам является символ $. Для указания абсолютной ссылки следует в процессе ввода или редактирования формулы установить курсор на ссылку и нажать соответствующее число раз клавишу F4 , например:

  • =N3 – относительная ссылка на ячейку с адресом N3;
  • =$N$3 – абсолютная ссылка по двум координатам на ячейку с адресом N3;
  • =N$3 – абсолютная ссылка по номеру строки на ячейку с адресом N3;
  • =$N3 – абсолютная ссылка по номеру столбца на ячейку с адресом N3.

При копировании формул, использующих имена блоков, ссылки на блоки не изменяются, их можно считать абсолютными.

Вычислить стоимость товарных запасов и налог на добавленную стоимость.

1. Открыть файл Примеры.XLS с помощью команды меню Файл -> Открыть.

2. Вставить, если необходимо, новый лист с помощью команды меню Вставка ->Лист.

3. Переименовать новый лист с помощью команды меню Формат -> Лист -> Переименовать, имя листа – Пример 10.

4. Заполнить таблицу товаров, начиная с ячейки А1:

Курс у.е.(долл.) по курсу ЦБ на текущий день | ХХ,ХХ |
Наименование | Ед. изм. | Цена, руб. | Запас | Стоимость запаса, руб. | В том числе НДС, руб. | Стоимость в у.е.
Стол | Шт. | 2 500,00р. | 7 |  |  |
Стул | Шт. | 345,00р. | 12 |  |  |
Диван | Шт. | 7 250,00р. | 2 |  |  |

5. Ввести формулу стоимости запаса в ячейку ЕЗ: = C3*D3.

6. Скопировать формулу ячейки ЕЗ в ячейки Е4:Е5.

7. Ввести формулу суммы НДС в ячейку F3: = F3*20/120.

8. Скопировать формулу ячейки F3 в ячейки F4:F5.

9. Ввести формулу стоимости товарных запасов в условных единицах в ячейку G3: =E3/$B$1 (абсолютная ссылка на ячейку В1, в которой содержится значение курса условной единицы – доллара).

10. Скопировать формулу G3 в ячейки G4:G5.

11. Закрыть файл с сохранением с помощью команды меню Файл -> Закрыть.


Пример 11

Пример 11. Автосуммирование

В MS EXCEL предусмотрен быстрый способ суммирования данных. Для этого на панели инструментов Стандартная присутствует кнопка Автосумма.

1. Открыть файл Примеры.XLS с помощью команды меню Файл -> Открыть.

2. Вставить, если необходимо, новый лист с помощью команды меню Вставка ->Лист.

3. Переименовать новый лист с помощью команды меню Формат -> Лист -> Переименовать, имя листа – Пример 11.

4. Заполнить таблицу товаров, начиная с ячейки А2:

СТАТИСТИКА ПРОДАЖИ

Секция | Месяц 1 | Месяц 2 | Месяц 3 | Итого
Ткани | 104500 | 80000 | 92300 | =СУММ(B2:D2)
Ковры | 124000 | 243000 | 141700 | =СУММ(B3:D3)
Эл/товары | 264900 | 274200 | 261110 | =СУММ(B4:D4)
Сувениры | 17500 | 19140 | 26700 | =СУММ(B5:D5)
Косметика | 12000 | 19070 | 18900 | =СУММ(B6:D6)
Итого | =СУММ(B3:B7) | =СУММ(C3:C7) | =СУММ(D3:D7) | =СУММ(F3:F7)

5. Установить курсор в ячейку Е3 и нажать кнопку Автосумма (S) на панели инструментов. Программа вставит функцию =СУММ и адрес диапазона левее выделенной ячейки В3:D3.

6. Если выделенный фрагмент окажется неверным, выделить нужный вам диапазон или установить курсор в строку формул и изменить диапазон данных.

7. Нажать кнопку Ввод или клавишу Enter . Программа вычислит сумму значений в выделенных ячейках.

8. Скопировать формулу ячейки Е3 в ячейки Е4:Е7.

9. Установить курсор в ячейку В8 и нажать кнопку Автосумма (S) на панели инструментов. Программа вставит функцию =СУММ и адрес диапазона выше выделенной ячейки В3:В7.

10. Если выделенный фрагмент окажется неверным, выделить нужный вам диапазон или установить курсор в строку формул и изменить диапазон данных.

11. Нажать кнопку Ввод или клавишу Enter . Программа вычислит сумму значений в выделенных ячейках.

12. Скопировать формулу В8 в ячейки С8:F8.

13. Закрыть файл с сохранением с помощью команды меню Файл -> Закрыть.


Пример 12

Пример 12. Встроенные функции Microsoft Excel.
Категория «Ссылки и массивы»

Ссылка соответствует адресу ячейки или диапазону ячеек электронной таблицы. Ссылка на ячейки других рабочих книг или приложений носит название внешней или удаленной ссылки. В Microsoft Excel используются ссылки личного стиля, который выбирается с помощью команды меню Сервис -> Параметры, вкладка Общие:

– номер строки, номер столбца – R1C1;
– имя столбца, номер строки – А1.

Столбцы обозначаются буквами от А до IV (256 столбцов максимально) или цифрами 1-256, строки – числами от 1 до 65 536. Ссылка на диапазон ячеек задается как ссылка на верхний левый угол диапазона, далее ставится знак двоеточия (:), указывается ссылка на правый нижний угол диапазона.

Примеры использования некоторых функций из категории «Ссылки и массивы»:

1. Открыть файл Примеры.XLS с помощью команды меню Файл -> Открыть.

2. Вставить, если необходимо, новый лист с помощью команды меню Вставка ->Лист.

3. Выполнить переименование листа с помощью команды меню Формат -> Лист -> Переименовать, имя листа – Пример 12.

4. Заполнить значения ячеек в диапазоне С2:Е5.

 | А | В | С | D | Е | F | G
1 | “Пример 11!$E$4” | 125 |  |  |  | Асбест |
2 | 1000 | 450 | 125 | Асбест | 4500 | Глина |
3 | 4 | 5 | 200 | Глина | 500 | Мел |
4 | 3 | 125 | 270 | Мел | 1000 | Цемент |
5 | 3 | 3 | 450 | Цемент | 450 |  |
6 | 2 | Асбест |  |  |  |  |

5. Создать именованный блок для диапазона ячеек С2:Е5 с именем Блок с помощью команды меню Вставка -> Имя -> Присвоить.

6. Функция АДРЕС – адрес ячеек или диапазонов ячеек.

Адрес ссылки выдается в виде текста в двойных кавычках. Ссылка представляется в виде номера строки и столбца, на пересечении которых находится ячейка. Ссылка может быть относительной или абсолютной в определенном стиле (А1 или R1C1), включать имя листа рабочей книги.

Формула в ячейке А1 =АДРЕС(4;5;1;2;"Пример 11") дает ссылку на ячейку 'Пример 11'!$Е$4. В формуле использованы параметры (слева направо): 4 – номер строки, 5 – номер столбца, 1 – абсолютная ссылка, 1 – формат ссылки А1, Пример 11 – имя листа.

7. Функция ДВССЫЛ – значение из ссылки.

Ссылка задается в виде текстовой строки. Например, в ячейке А2 содержится формула вида =ДВССЫЛ (АДРЕС(4; 5; 1; 1); 1). Эта формула дает результат – значение из ячейки Е4 (если лист не указан, используется текущий).

8. Функция ЧСТРОК – определение числа строк в заданном диапазоне ячеек. Например, формула в ячейке A3 =ЧСТРОК(С2: Е5) дает значение 4.

9. Функция ЧИСЛСТОЛБ – определение числа столбцов в заданном диапазоне ячеек. Например, формула в ячейке А4 =ЧИСПСТОЛБ (С2: Е5) дает значение 3.

10. Функция СТОЛБЕЦ – определение начального номера столбца ссылки (диапазона ячеек или именованного блока ячеек). Например, формула в ячейке А5 =СТОЛБЕЦ(С2:Е5) дает значение 3.

11. Функция СТРОКА – определение начального номера строки ссылки (диапазона ячеек или именованного блока ячеек). Например, формула в ячейке А6 =СТРОКА(С2:Е5) дает значение 2.

15. Функция ПРОСМОТР – просмотр данных в блоках ячеек. Функция ПРОСМОТР обеспечивает различные режимы поиска: проверка наличия искомого значения в массиве (если значение существует, выводится само значение, в противном случае – сообщение об ошибке #Н/Д – нет данных); поиск искомого значения в векторе просмотра и вывод соответствующего ему значения из вектора результата. Перед выполнением функции ПРОСМОТР диапазон ячеек сортируется в порядке возрастания значений вектора просмотра.

Например, требуется по заданному значению кода материала – ячейка В1 определить соответствующее этому коду название материала. Коды материалов представлены в ячейках С2:С5, названия – в ячейках D2:D5. В ячейке В6 введена формула =ПРОСМОТР(В1;С2:С5;D2:D5), которая возвращает значение из вектора результата (наименование материала) для найденного в векторе просмотра (код материала) значения, в данном случае – Асбест.

19. Функция ТРАНСП – транспонирование диапазона ячеек. Для «разворота» на 90° блока ячеек используется функция ТРАНСП, которая вводится как массив формул. Например, требуется транспонировать исходный блок ячеек С2:Е5 в ячейки A10:D12. В ячейки A10:D12 вводится формула массива {=ТРАНСП(С2:Е5)}. Для этого надо выделить ячейки A10:D12, ввести формулу и нажать CTRL + SHIFT + ENTER .

20. Закрыть файл с сохранением с помощью команды меню Файл -> Закрыть.


Пример 13

Пример 13. Встроенные функции Microsoft Excel.
Категория «Текстовые функции»

Функции данной категории обеспечивают работу с текстом, находящимся в ячейках таблицы или вводимым в виде текстовых констант в формулы.

1. Открыть файл Примеры.XLS с помощью команды меню Файл -> Открыть.

2. Вставить, если необходимо, новый лист с помощью команды меню Вставка ->Лист.

3. Выполнить переименование листа с помощью команды меню Формат -> Лист -> Переименовать, имя листа – Пример 13.

4. Заполнить ячейки A1:D1, начиная с A1, значениями:

0,234567

0,234567

23/06/2002

20/07/02

5. В ячейки A2:D2, начиная с A2, ввести формулы для преобразования числа или даты в текст:

=ТЕКСТ(A1; "#,0#р.")

=ТЕКСТ(B1; "0,0#р.")

=ТЕКСТ(C1; "ГГГГ" "год" "ДД ММММ")

=ТЕКСТ(D1; "ММММ – ГГ")

6. В ячейку A3 ввести формулу преобразования текста в число: =ЗНАЧЕН("0,23р."). Формула дает результат 0,23. Это обратное преобразование функции ТЕКСТ.

7. В ячейку B3 ввести формулу сцепления текстовых строк:

=СЦЕПИТЬ("ПРИМЕР";" "; "СЦЕПЛЕНИЯ СТРОК ТЕКСТА";
" ";"ДЛЯ ВЫВОДА В ОДНОЙ ЯЧЕЙКЕ"). В результате в ячейке B3 выводится строка текста «ПРИМЕР СЦЕПЛЕНИЯ СТРОК ТЕКСТА ДЛЯ ВЫВОДА В ОДНОЙ ЯЧЕЙКЕ».

8. В ячейку СЗ ввести формулу для определения длины текста в ячейке B3: =ДЛСТР(B3).

9. В ячейку D3 ввести формулу для определения первого вхождения в строку текста в ячейке B3 сочетания букв «СТ» с учетом регистра, поиск вести с начала строки текста: =НАЙТИ("СТ";B3;1). При поиске без учета регистра используется функция ПОИСК.

10. Закрыть файл с сохранением с помощью команды меню Файл -> Закрыть.


Пример 14

Пример 14. Встроенные функции Microsoft Excel.
Категория «Дата и время»

Даты и время могут представляться в числовом или текстовом формате. Функции данной категории обеспечивают работу с датой и временем, находящимися в ячейках таблицы или вводимыми в виде констант в формулы.

1. Открыть файл Примеры.XLS с помощью команды меню Файл -> Открыть.

2. Вставить, если необходимо, новый лист с помощью команды меню Вставка ->Лист.

3. Выполнить переименование листа с помощью команды меню Формат -> Лист -> Переименовать, имя листа – Пример 14.

4. Ввести в столбец А, начиная с ячейки A1, формулы для вычисления:

– текущей даты: =СЕГОДНЯ();

– текущей даты и времени: =ТДАТА();

– даты в числовом формате, аргументы функции задаются по частям (год, месяц, день): =ДАТА (2002; 4; 12);

– перевод даты из текстового формата в числовой формат, аргумент задается как строка текста: =ДАТАЗНАЧ ("12.04.2002");

– определение номера года, месяца и дня для даты, заданной в числовом формате:
=ГОД(37430) дает год 2002,
=МЕСЯЦ(37430) дает месяц 6,
=ДЕНЬ(37430) дает число 23.

5. Закрыть файл с сохранением с помощью команды меню Файл -> Закрыть.


Пример 15

Пример 15. Встроенные функции Microsoft Excel.
Категория «Математические»

Это наиболее популярная категория встроенных функций, обеспечивающая разнообразные вычисления.

1. Открыть файл Примеры.XLS с помощью команды меню Файл -> Открыть.

2. Вставить, если необходимо, новый лист с помощью команды меню Вставка ->Лист.

3. Выполнить переименование листа с помощью команды меню Формат -> Лист -> Переименовать, имя листа – Пример 15.

4. Ввести в столбец А, начиная с ячейки A1, формулы:

– определение знака выражения: =ЗНАК(-1234) дает -1, так как число отрицательное;

– округление числа до ближайшего целого нечетного числа: =НЕЧЁТ(166,6667) дает 167;

– округление числа до ближайшего целого четного числа: =ЧЁТН(167,6667) дает 168;

– округление числа до ближайшего меньшего целого числа: =ЦЕЛОЕ(166,6667) дает 166;

– отбрасывание дробной части числа: =ОТБР( 166,6667;0) дает 166;

– округление числа до ближайшего целого или до ближайшего кратного указанному значению: =ОКРВВЕРХ(166,6667; 10) вычисляет 170;

– округление числа до ближайшего меньшего подмодулю целого числа: =ОКРВНИЗ(20/120*1000;10) вычисляет 160;

– округление числа до указанного количества десятичных разрядов: =ОКРУГЛ(166,6667;3) вычисляет 166,667;

– округление числа до ближайшего по модулю большего целого: =ОКРУГЛВВЕРХ(166,666667;3) вычисляет 166,667;

– округление числа до ближайшего меньшего по модулю целого: =ОКРУГЛВНИЗ(166,66667;3) вычисляет 166,666.

5. Закрыть файл с сохранением с помощью команды меню Файл -> Закрыть.


Пример 16

Пример 16. Создание списков

Список – это рабочий лист Microsoft Excel со столбцами и строками, с текстом и числами, сформированный по определенным правилам. Если правила соблюдены, то программа будет воспринимать список как двухмерную базу данных. Рассмотрим пример на создание списка:

1. Открыть файл Примеры.XLS с помощью команды меню Файл -> Открыть.

2. Вставить, если необходимо, новый лист с помощью команды меню Вставка ->Лист.

3. Выполнить переименование листа с помощью команды меню Формат -> Лист -> Переименовать, имя листа – Объем и сбыт.

4. Набрать список следующего содержания ( шапка таблицы набирается один раз):

Месяц | Год | Продукция | Продавец | Сбыт | Объем | Район
янв | 1995 | Молоко | Иванов | 2678 | 3400 | Южный
март | 1996 | Хлеб | Петров | 2190 | 2890 | Северный
янв | 1996 | Бакалея | Сидоров | 1900 | 2999 | Восточный
февр | 1995 | Мясо | Белов | 1888 | 3000 | Западный
апр | 1997 | Фрукты | Белов | 3034 | 4567 | Восточный
ноябрь | 1998 | Фрукты | Сидоров | 2400 | 3100 | Западный
март | 1999 | Мясо | Петров | 9087 | 10765 | Северный
февр | 1998 | Бакалея | Иванов | 1234 | 2900 | Северный
апр | 1997 | Хлеб | Иванов | 8765 | 9876 | Южный
ноябрь | 1996 | Молоко | Белов | 987 | 1200 | Восточный
март | 1997 | Мясо | Сидоров | 2367 | 3020 | Восточный
сент | 1996 | Хлеб | Петров | 1098 | 2095 | Южный
сент | 1995 | Фрукты | Петров | 3452 | 4910 | Северный
май | 1997 | Хлеб | Белов | 1987 | 2090 | Восточный

5. Выполнить заголовки столбцов (поля списка) другим шрифтом и начертанием. Это необходимо для дальнейшей работы со списком.

6. Закрыть файл с сохранением с помощью команды меню Файл -> Закрыть.


Пример 17

Пример 17. Использование формы для работы со списками

Список Microsoft Excel (база данных) может создаваться и редактироваться с помощью экранной формы, которая содержит имена и значения полей записи списка. Рассмотрим заполнение списка Картотека с помощью экранной формы. Разряд работающего определяет его тарифную ставку.

1. Открыть файл Примеры.XLS с помощью команды меню Файл -> Открыть.

2. Выбрать лист Тарифы (см. пример 2).

3. Снять защиту с ячейки Е2 (ставка 1-го разряда) с помощью команды меню Формат -> Ячейки, на вкладке Защита сбросить Защищаемая ячейка.

4. Заполнить и выделить блок ячеек Ставка.

5. Скрыть формулы в ячейках блока Ставка с помощью команды меню Формат -> Ячейки, на вкладке Защита установить Защищаемая ячейка и Скрыть формулы.

6. Защитить лист Тарифы от изменений с помощью команды меню Сервис -> Защита -> Защитить лист, указать защиту содержимого листа.

7. Выбрать лист Картотека (см. пример 2).

8. Установить курсор в ячейку первой строки столбца Тариф и ввести формулу тарифа в ячейку Е2: =ПРОСМОТР(D2;Разряд;Ставка).

9. Скопировать формулу ячейки Е2 в ячейки столбца Тариф (для заполнения строк списка).

10. Установить курсор в область списка и выполнить команду Данные -> Форма.

11. Ввести следующие новые записи в список с помощью кнопки Добавить:

ФИО | Табельный номер | Профессия | Разряд работающего | Тариф | Льготы
Котов А. А. | 01235 | Весовщик | 5 |  | 2
Павлов Ф. Ф. | 01236 | Весовщик | 4 |  | 2
Соловьев А. П. | 01237 | Упаковщик | 3 |  | 1
Крылов А. Н. | 01238 | Грузчик | 5 |  | 1
Ильин А. Е. | 01239 | Упаковщик | 5 |  | 1

12. Выполнить отбор записей по условию: профессия Грузчик, разряд работающего выше 3. Нажать кнопку Критерии и заполнить поля формы: поле Профессия – Грузчик; поле Разряд работающего – 3.

13. Нажать кнопку Далее и просмотреть записи, удовлетворяющие запросу.

14. Нажать кнопку Очистить.

15. Выполнить отбор записей по условию: разряд работающего до 4 и льготы больше 2. Нажать кнопку Критерии и заполнить поля формы: поле Разряд работающего – <4; поле Льготы – 2.

16. Нажать кнопку Далее и просмотреть записи, удовлетворяющие запросу.

17. Закрыть файл с сохранением с помощью команды меню Файл -> Закрыть.


Пример 18

Пример 18. Фильтрация списков. Автофильтр

Различают два способа фильтрации (отбора) записей списков в команде меню Данные -> Фильтр: Автофильтр и Расширенный фильтр.

После применения команды Автофильтр в строку таблицы с наименованиями полей будут помещены кнопки раскрывающихся списков (кнопки со стрелками). Каждый список содержит все значения, встречающиеся в этом поле.

1. Открыть файл Примеры.ХLS с помощью команды меню Файл -> Открыть.

2. Выбрать лист Объем и сбыт.

3. Установить курсор в любую ячейку списка, войти в меню Данные-> Фильтр: Автофильтр.

4. Щелкнуть левой клавишей мышки по появившейся стрелке в поле Год.

5. Из списка значений выбрать 1996.

6. Полученную таблицу скопировать на свободное место открытого листа.

7. 4. Щелкнуть левой клавишей мышки по появившейся стрелке в поле Сбыт.

8. Из списка значений выбрать Первые 10.

9. В открывшемся окне Наложения условий по списку установить первые 5 наибольших значений элементов списка.

10. Полученную таблицу скопировать на свободное место открытого листа.

11. Щелкнуть левой клавишей мышки по появившейся стрелке в поле Объем.

12. Из списка значений выбрать Условие.

13. В открывшемся окне выбрать условие больше или равно 3000.

14. Полученную таблицу скопировать на свободное место открытого листа.

15. Закрыть файл с сохранением с помощью команды меню Файл -> Закрыть.


Пример 19

Пример 19. Фильтрация списков. Расширенный фильтр

Расширенный фильтр предполагает формирование специального диапазона ячеек в произвольном месте. Этот диапазон является критерием для расширенного фильтра списка. Диапазон условий состоит из имен полей списка и строк условий.

Рассмотрим отбор сведений о сотрудниках, для которых число льгот по подоходному налогу находится в интервале от 2 до 3 и разряд не ниже 3, а также всех сотрудников по профессии Грузчик. Условия отбора поместить на новом листе. Результат фильтрации записей списка поместить на новом листе.

1. Открыть файл Примеры.ХLS с помощью команды меню Файл -> Открыть.

2. Выбрать лист Картотека.

3. Создать именованный блок БазаДанных для списка Картотека – команда меню Вставка -> Имя -> Присвоить. В блок входят заголовки столбцов и все заполненные записи списка Microsoft Excel.

4. Вставить новый лист с помощью команды меню Вставка -> Лист.

5. Выполнить переименование листа с помощью команды меню Формат -> Лист -> Переименовать, лист – Критерии.

6. Подготовить диапазон условий для расширенного фильтра на листе Критерии:

Льготы | Льготы | Профессия | Разряд работающего
>=2 | <=3 |  | >=3
 |  | Грузчик |

Имена полей списка в область критериев целесообразно перенести путем копирования, так как при фильтрации требуется полное совпадение имен полей в списке Microsoft Excel и диапазоне условий.

7. Вставить новый лист с помощью команды меню Вставка -> Лист.

8. Выполнить переименование листа с помощью команды меню Формат -> Лист -> Переименовать, лист – Результат.

9. Установить курсор в ячейку А1 листа Результат.

10. Выполнить команду меню Данные -> Фильтр -> Расширенный фильтр.

11. В диалоговом окне Расширенный фильтр указать:

– Скопировать результат в другое место;

– исходный диапазон – блок БазаДанных;

– диапазон условий – Критерии!$А$1:$D$3;

– поместить результат в диапазон – Результат!$А$1;

– нажать кнопку ОК.

12. Закрыть файл с сохранением с помощью команды меню Файл -> Закрыть.


Пример 20

Пример 20. Промежуточные итоги

Для формирования промежуточных итогов требуется предварительная сортировка списка по полям группировки записей, например, по полям Поле1, Поле2, Поле3. Команда меню Данные -> Итоги позволяет сформировать итоги определенного вида по указанным полям при каждом изменении поля группировки – Поле1 (или Поле2 или Поле3). По отдельному полю группировки за одно выполнение команды можно сформировать итоги по нескольким полям. В Microsoft Excel определены следующие встроенные операции и функции для агрегированных итогов:

Итоговая операция | Результат | Встроенная функция
Сумма | Сумма чисел | СУММ
Кол-во значений | Количество заполненных полей | СЧЁТЗ
Среднее | Среднее чисел | СРЗНАЧ
Максимум | Максимальное число | МАКС
Минимум | Минимальное число | МИН
Произведение | Произведение чисел | ПРОИЗВЕДЕНИЕ
Кол-во чисел | Количество заполненных полей, содержащих числа | СЧЁТ
Несмещенное отклонение | Несмещенная оценка стандартного отклонения генеральной совокупности по выборке данных | СТАНДОТКЛОН
Смещенное отклонение | Смещенная оценка стандартного отклонения генеральной совокупности по выборке данных | СТАНДОТКЛОНП
Несмещенная дисперсия | Несмещенная оценка дисперсии генеральной совокупности по выборке данных | ДИСП
Смещенная дисперсия | Смещенная оценка дисперсии генеральной совокупности по выборке данных | ДИСПР

Сформировать промежуточные итоги по полю Профессия. Вычислить средний тариф, средний разряд, количество сотрудников по профессиям.

1. Открыть файл Примеры.XLS с помощью команды меню Файл -> Открыть.

2. Выбрать лист Картотека.

3. Установить курсор в область списка на листе Картотека.

4. Отсортировать список по полю Профессия с помощью команды меню Данные -> Сортировка.

5. Установить курсор в область списка на листе Картотека.

6. Выполнить команду меню Данные -> Итоги:

– При каждом изменении – Профессия.

– Операция – Среднее.

– Добавить итоги по – Разряд работающего, Тариф.

– Установить Итоги под данными.

– Нажать на кнопку ОК.

7. Установить курсор в область списка на листе Картотека.

8. Выполнить команду меню Данные -> Итоги:

– При каждом изменении – Профессия.

– Операция – Кол-во значений.

– Добавить итоги по – Табельный номер.

– Установить Итоги под данными.

– Нажать на кнопку ОК.

9. Проанализировать получившуюся таблицу.

10. Закрыть файл с сохранением – команда меню Файл -> Закрыть.


Пример 21

Пример 21. Создание сводных таблиц

Построить сводную таблицу для расчета месячной зарплаты рабочих при повременной форме оплаты труда.

Установлена премия по разрядам работающих: 2-й разряд 25%, 3-й разряд 32%, 4-й разряд 50% к тарифу. Вычеты из всех видов начислений составляют 13,9%.

1. Открыть файл Примеры.XLS с помощью команды меню Файл -> Открыть.

2. Выбрать лист Картотека.

3. Установить курсор в список на листе Картотека.

4. Выполнить команду меню Данные -> Сводная таблица для вызова Мастера сводных таблиц и диаграмм.

5. На шаге 1 указать тип источника – Создать таблицу на основе данных, находящихся в списке или базе данных Microsoft Excel. Вид создаваемого отчета – Сводная диаграмма (со сводной таблицей).

6. На шаге 2 проверить диапазон ячеек для построения сводной таблицы списка Картотека.

7. На шаге 3 – нажать кнопку Макет, разместить поля в макете сводной таблицы: страница – Профессия, строка – Разряд работающего, столбец – ФИО, данные – Тариф.

8. Задать параметры сводной таблицы с помощью кнопки Параметры: Общая сумма по столбцам; Автоформат; Сохранять форматирование. Для пустых ячеек отображать – Пробел; Поместить таблицу – в Новый лист.

9. Нажать на кнопку Готово. Сводная таблица представлена на следующем рисунке:

10. Установить курсор в область сводной таблицы.

11. На панели инструментов Сводные таблицы нажать кнопку Сводная таблица, выбрать команду контекстного меню Формулы -> Вычисляемое поле. Создать новое вычисляемое поле: Имя поля – Зарплата, формула: =Тариф*168. Кнопка Добавить. Закрыть окно – кнопка ОК.

12. Установить курсор в область сводной таблицы.

13. Ha панели инструментов Сводные таблицы нажать кнопку Мастер сводных лиц. В окне мастера сводных таблиц на 3-м шаге нажать кнопку Макет: убрать из области Данные поле Сумма по полю Тариф. Нажать кнопку ОК. Нажать кнопку Готово.

14. Установить курсор в области сводной таблицы на поле Сумма по полю Зарплата.

15. На панели инструментов Сводная таблица нажать кнопку Параметры поля: изменить имя поля – Месячная зарплата. Выбрать формат поля – Денежный. Нажать кнопку ОК.

16. Установить курсор в области сводной таблицы на поле ФИО.

17. На панели инструментов Сводные таблицы нажать кнопку Сводная таблица.

18. Выполнить команду контекстного меню Формулы -> Вычисляемый объект:

– ввести имя поля – Премия;

– выбрать поле Разряд работающего, раскрыть список элементов (двойной щелчок левой кнопкой мыши на поле);

– в окно формулы ввести формулу: ='2'*0,25+'3'*0,32+'4'*0,5;

– нажать кнопку Добавить;

– ввести имя поля – Вычеты;

– выбрать поле Разряд работающего, раскрыть список элементов (двойной щелчок левой кнопкой мыши на поле);

– ввести формулу: = -0,13('2'*1,25+'3'*1.32+'4'*1,5);

– нажать кнопку Добавить;

– нажать кнопку ОК.

19. Для просмотра выражения вычисляемого поля и вычисляемых объектов панели инструментов Сводные таблицы нажать одноименную кнопку, выбрать команду контекстного меню Формулы -> Вывести формулы.

20. Установить курсор в сводную таблицу.

21. На панели инструментов Сводные таблицы нажать кнопку Мастер сводных таблиц. В окне третьего шага кнопка Макет изменить положение полей : строка – ФИО, столбец – Разряд работающего. Нажать кнопку ОК. Нажать кнопку Готово.

22. Закрыть рабочую книгу с сохранением с помощью команды меню Файл -> Закрыть.


Пример 22

Пример 22. Построение диаграмм

Построить диаграммы, отражающие основные средства и иные внеоборотные активы баланса на начало и конец года.

Название строки раздела баланса | На начало года | На конец года
НМА | 450 | 15 000
ОС | 80 000 | 120 000
Кап. вложения | 35 000 | 10 000
Финансовые вложения | 12 000 | 500
Итого по разделу 1 | 127 450 | 145 500

А. Диаграмма динамики баланса

По каждой строке раздела баланса выполняется сопоставление значений показателей на начало и конец года.

1. Открыть файл Примеры.XLS с помощью команды меню Файл -> Открыть.

2. Вставить, если необходимо, новый лист с помощью команды меню Вставка ->Лист.

3. Переименовать новый лист с помощью команды меню Формат -> Лист -> Переименовать, имя листа – Баланс.

4. Разместить исходные данные – табл. 1.

5. Выполнить команду меню Вставка -> Диаграмма, указать:

– тип диаграммы – Гистограмма, формат 4 (объемный вариант обычной гистограммы);

– диапазон – блок ячеек столбцов На начало года, На конец отчетного года, включая заголовки, без итогов;

– ряды в столбцах;

– подпись по оси X – блок ячеек, содержащих названия строк баланса;

– название диаграммы – Динамика баланса;

– подписи данных – значения;

– легенда – внизу;

– поместить диаграмму на отдельный лист – Динамика баланса.

6. Выполнить настройку форматов элементов диаграммы.

7. Закрыть файл с сохранением с помощью команды меню Файл -> Закрыть.

Б. Диаграмма структуры раздела баланса отдельно
на начало и конец года

Структура раздела показывает пропорции для строк баланса отдельно на начало и конец года.

1. Открыть файл Примеры.XLS с помощью команды меню Файл -> Открыть.

2. Выбрать лист Баланс.

3. Выполнить команду меню Вставка -> Диаграмма. Указать:

– тип диаграммы — Линейчатая, формат 3 (нормированная на 100%, отражает долю каждой категории в общей сумме);

– диапазон — блок ячеек столбцов На начало года, На конец отчетного года, включая заголовки, без итогов;

– ряды в строках;

– имя ряда 1 – НМА, имя ряда 2 – ОС, имя ряда 3 — Капвложения, имя ряда 4 – Финансовые вложения;

– название диаграммы — Структура раздела 1 баланса;

– подписи данных — значения;

– легенда — внизу;

– поместить диаграмму на отдельный лист — Динамика баланса.

4. Выполнить настройку форматов элементов диаграммы.

5. Закрыть файл с сохранением с помощью команды меню Файл -> Закрыть.

В. Диаграмма итогов раздела на начало и конец года

Диаграмма содержит итоги по строкам раздела на начало и конец года.

1. Открыть файл Примеры.XLS с помощью команды меню Файл -> Открыть.

2. Выбрать лист Баланс.

3. Выполнить команду меню Вставка -> Диаграмма. Указать:

– тип диаграммы – С областями с накоплением, формат 2 (отображает изменение общей суммы и каждой составляющей);

– диапазон – блок ячеек столбцов На начало года, На конец отчетного года, включая заголовки, без итогов;

– ряды в строках;

– имя ряда 1 – НМА, имя ряда 2 – ОС, имя ряда 3 – Капвложения, имя ряда 4 – Финансовые вложения;

– название диаграммы – Итоги раздела 1 баланса;

– подписи данных – значения;

– легенда – внизу;

– поместить диаграмму на отдельный лист – Итоги раздела баланса.

4. Выполнить настройку форматов элементов диаграммы.

5. Закрыть файл с сохранением с помощью команды меню Файл -> Закрыть.


5.13. ПРАКТИЧЕСКИЕ ЗАДАНИЯ

Задание 1. Отчёт о продаже товаров

Создать файл с именем Задания.XLS, имеющий следующую структуру: первый лист содержит исходную таблицу, второй лист – результаты необходимых расчетов по исходной таблице:

Варианты заданий:

ОТЧЕТ О ПРОДАЖЕ ТОВАРОВ

№ п/п | Наименование | Цена | Количество | Стоимость
1. | Удлинитель шнура питания 3 м | 54,00 | 23 |
2. | Розетка RJ 45 | 32,00 | 250 |
3. | Набор инструментов СТ-920 | 331,00 | 30 |
4. | Устройство зачистки кабеля RG-58 | 512,00 | 38 |
5. | Устройство обжима кабеля RG-58 | 788,00 | 60 |
6. | Кабель питания | 47,00 | 140 |
7. | Диск CD-R Dysan 700Mb | 20,00 | 230 |
8. | Диск CD-RW 650Mb | 20,00 | 140 |
9. | Мышь A4 Power mouse MUS-3 Maxxtro | 65,00 | 18 |
10. | Мышь A4 Fast mouse 2 кнопки PS/2 | 79,00 | 23 |
11. | Коврик для мыши матерчатый | 22,00 | 46 |
12. | Переходник для евровилки | 6,00 | 54 |
13. | Евророзетка | 12,00 | 119 |

1. Вычислить общую стоимость товаров с учетом того, что по позициям 3,4,5 и 9 списка сделана 5%-ная скидка.

2. Вычислить общую стоимость товаров с учетом того, что по последним четырем позициям произошло удорожание на 20%.

3. Вычислить общую стоимость товаров с учетом 10% скидки на тот товар, количество единиц которого больше 100.

4. Вычислить общую стоимость дорогостоящих товаров (цена товара больше 100 рублей).

5. Вычислить общую стоимость малоценных товаров (цена товара меньше 50 рублей).

6. Вычислить общую стоимость товаров с учетом того, что по позициям 4,5 сделана 5%-ная скидка, а по трем последним позициям произошло удорожание на 10%.

7. Вычислить общую стоимость товаров и количество малоценных (цена товара меньше 50 рублей).

8. Вычислить общую стоимость товаров и количество дорогостоящих (цена товара больше 100 рублей).

9. Вычислить общую стоимость товаров, учитывая 10%-ную скидку, если количество одноименных товаров больше 200.

10. Вычислить общую стоимость товаров, учитывая 5%-ную скидку, если количество одноименных товаров больше 100.


Задание 2

Задание 2. Фильтрация данных

Скопировать на третий лист файла Задания.XLS исходную таблицу с первого листа и выполнить один из следующих вариантов задания.

Варианты заданий:

1. Отфильтровать данные таким образом, чтобы оставались только те строки, которые содержат данные о малоценных товарах (стоимость меньше 50 руб.). Список отсортировать по алфавиту наименований товаров.

2. Отфильтровать данные таким образом, чтобы оставались только те строки, которые содержат данные о дорогостоящих товарах (стоимость товара больше 100 руб.). Список отсортировать по алфавиту наименований товаров.

3. Отфильтровать данные таким образом, чтобы оставались только те строки, которые содержат данные о тех товарах, количество которых не меньше 100 единиц. Список отсортировать по убыванию количества товаров.

4. Отфильтровать данные таким образом, чтобы оставались только те строки, которые содержат данные о тех товарах, количество которых не больше 50 единиц. Список отсортировать по возрастанию количества товаров.

5. Отфильтровать данные таким образом, чтобы оставались только те строки, которые содержат данные о тех товарах, количество которых не меньше 100 единиц и не больше 200. Список отсортировать по алфавиту наименований товаров.

6. Отфильтровать данные таким образом, чтобы оставались только те строки, которые содержат данные о тех товарах, цена которых колеблется между 30 и 80 руб. Список отсортировать по алфавиту наименований товаров.

7. Отфильтровать данные таким образом, чтобы оставались только те строки, которые содержат данные о тех товарах, стоимость которых превышает 2000 руб. Список отсортировать по алфавиту наименования товаров.

8. Отфильтровать данные таким образом, чтобы остались строки с пятью наиболее дорогими товарами.

9. Отфильтровать данные таким образом, чтобы остались строки с семью наиболее дешевыми товарами.

9. Отфильтровать данные таким образом, чтобы остались строки с семью наиболее дешевыми товарами.


Задание 3

Задание 3. Расчет заработной платы

Выполнить расчет заработной платы с учетом количества отработанных часов и стоимости одного часа работы.

Фамилия Имя Отчество | Стоимость одного часа (руб.) | Количество часов | Подох. налог (13%) | Итого удержано | К выдаче
Преподаватель 1 | 70,0 | 21 |  |  |
Преподаватель 2 | 45,0 | 32 |  |  |
Преподаватель 3 | 67,0 | 11 |  |  |
Преподаватель 4 | 43,0 | 43 |  |  |
Преподаватель 5 | 45,5 | 53 |  |  |
Преподаватель 6 | 50,0 | 31 |  |  |
Преподаватель 7 | 76,0 | 15 |  |  |
Преподаватель 8 | 78,0 | 28 |  |  |
Преподаватель 9 | 100,0 | 20 |  |  |
Преподаватель 10 | 99,0 | 15 |  |  |
Преподаватель 11 | 80,0 | 10 |  |  |
Всего: |  |  |  |  |


Задание 4

Задание 4. Семейный бюджет

Введите данные, соответствующие вашему семейному бюджету. Посчитайте Итоги по каждому пункту бюджета и по каждой неделе. Определите Экономию семейного бюджета. Выделите цифры перерасхода еженедельного бюджета с помощью Условного форматирования.

Бюджет одного месяца | --
Понедельный доход | --
Категория дохода | Неделя 1 | Неделя 2 | Неделя 3 | Неделя 4 | ИТОГО
Питание |  |  |  |  |
Кварт. Плата |  |  |  |  |
Одежда |  |  |  |  |
Газ/Электроэнергия/Вода |  |  |  |  |
Транспорт |  |  |  |  |
Телефон |  |  |  |  |
Междугородний телефон |  |  |  |  |
Дети |  |  |  |  |
Развлечения |  |  |  |  |
Прочие расходы |  |  |  |  |
ИТОГО |  |  |  |  |
ЭКОНОМИЯ |  |  |  |  |


Задание 5

Задание 5. Использование домашнего компьютера

Введите следующие данные, отражающие использование домашнего компьютера (исследования фирмы Microsoft).

Вид работы | %
Игры | 8,2
Обработка текстов | 24,5
Ведение финансов | 15,4
Работа, выполняемая дома | 26,5
Образование | 8,8
Домашний бизнес | 16,6

Задайте заголовок таблицы «Использование домашнего компьютера (исследования фирмы Microsoft)» и разместите в центре двух объединенных ячеек A1 и B1, так, чтобы текст разместился в две строки.

Постройте следующие диаграммы и расположите их на одном листе.


Задание 6

Задание 6. Перевозки москвичей городским транспортом

Введите следующие данные, отражающие использование москвичами городского транспорта.

 | 1917 | 1940 | 1970 | 1978 | 1990
Метрополитен | 0 | 14 | 35,5 | 39,5 | 50,4
Троллейбус | 0 | 8 | 17 | 16 | 15
Автобус | 0 | 8 | 33,5 | 34 | 25,6
Трамвай | 100 | 70 | 10,5 | 10,5 | 9

Задайте заголовок таблицы «Перевозки москвичей городским транспортом, в %» и разместите в центре объединенных ячеек A1:F1.

Постройте следующие диаграммы и расположите их на одном листе. При построении диаграмм обратите внимание на выбор диапазона ячеек и на расположение рядов данных (в одном случае в строках, а в другом в столбцах!)


Задание 7

Задание 7. Национальный состав населения Москвы на 1999 год

Введите следующие данные, отражающие национальный состав населения Москвы на 1999 год.

Национальный состав населения Москвы на 1999 год

Национальность | Общее количество, тыс. чел. | Из них считают родным русский язык, тыс. чел. | Из них считают родным русский язык, %
Украинцы | 253 | 154,33 | 61
Татары | 157 | 58,09 | 37
Белорусы | 73 | 48,18 | 66
Армяне | 44 | 25,08 | 57
Прочие | 300 | 126 | 42
Русские | 7963 | 7963 | 100

Постройте следующие диаграммы и расположите их на одном листе.


Задание 8

Задание 8. Анализ продажи мороженного

Введите данные, отражающие продажу мороженного в период с 05.06 по 15.06.

Анализ продажи мороженного

Дата | Температура воздуха | Продано |  |  | Цена за 1 шт. (руб.)
 |  | Загадка | Пломбир | Эскимо
05.06 | 20 | 320 | 405 | 320 | 6
06.06 | 18 | 302 | 360 | 300 | 6
07.06 | 19 | 310 | 375 | 310 | 6
08.06 | 21 | 322 | 405 | 335 | 6
09.06 | 24 | 357 | 460 | 360 | 6
10.06 | 26 | 360 | 475 | 380 | 6
11.06 | 26 | 400 | 480 | 410 | 6
12.06 | 29 | 600 | 750 | 680 | 6
13.06 | 26 | 320 | 500 | 490 | 6
14.06 | 23 | 380 | 435 | 420 | 6
15.06 | 24 | 350 | 450 | 450 | 6
Итого: |  |  |  |  |

2. Дополнить таблицу справа колонками «Выручка» по всем видам мороженного, посчитать по следующим формулам:

Выручка Загадка = Продано Загадка * Цена за 1 шт.

Выручка Пломбир = Продано Пломбир * Цена за 1 шт.

Выручка Эскимо = Продано Эскимо * Цена за 1 шт.

3. Добавить колонку «Общая выручка» и посчитать по формуле:

Выручка Загадка + Выручка Пломбир + Выручка Эскимо

4. Заполнить ячейки по строке "Итого" (где это имеет смысл) с помощью операции Автосуммирования.

5. Построить диаграмму, отражающую зависимость продажи мороженного от температуры воздуха.


Задание 9

Задание 9. Применение Автофильтра

Введите данные, отражающие рейтинг телевизионных программ

Канал | Программа | Жанр программы | Продолжительность (мин.) | Аудитория | Рейтинг
РТР | Вести | Новости | 30 | Общий | 6
НТВ | Сегодня | Новости | 30 | Общий | 9
ОРТ | Слабое звено | Ток-шоу | 50 | Общий | 7
РТР | Спокойной ночи, малыши | Другие | 15 | Для детей | 9
НТВ | Свобода слова | Ток-шоу | 60 | Для взрослых | 8
ОРТ | Время | Новости | 25 | Общий | 5
НТВ | Скорая помощь | Телесериал | 50 | Для взрослых | 7
ОРТ | Пока все дома | Другие | 45 | Общий | 10
РТР | Убойная сила | Телесериал | 55 | Для взрослых | 9
ОРТ | Секретные материалы | Телесериал | 70 | Для взрослых | 6
ОРТ | Умники и умницы | Другие | 50 | Для детей | 6
ОРТ | Ералаш | Тележурнал | 15 | Для детей | 9

Отсортировать по столбцу «Оценка» по убыванию и выполнить следующие задания по таблице, применяя Автофильтр:

1. Выбрать программы жанра Ток-шоу.

2. Выбрать программы Для взрослых.

3. Выбрать передачи продолжительностью более 30 минут.

4. Выбрать передачи канала НТВ.

5. Выбрать передачи с рейтингом больше или равным 8.

6. Выбрать первые пять программ с наибольшим рейтингом.

7. Выбрать передачи продолжительностью менее 40 минут, но более 15 минут.

8. Все отфильтрованные списки скопировать на отдельные листы книги, дав им соответствующие имена.

9. В основном списке определить средний рейтинг каждого канала и по результатам построить круговую (объемную) диаграмму с указанием наименования канала и среднего рейтинга.


Задание 10

Задание 10. Применение Расширенного фильтра

Введите данные, отражающие результаты сдачи экзаменов.

Номер группы | Номер зачетной книжки | Код предмета | Таб. номер преподавателя | Вид занятия | Дата | Оценка
133 | 1 | П1 | а1 | л | 12.06.02 | 3
133 | 1 | П2 | а2 | пр | 25.05.02 | 4
133 | 2 | П1 | а1 | л | 12.06.02 | 2
133 | 2 | П2 | а2 | пр | 20.05.02 | 4
133 | 3 | П1 | а1 | л | 12.06.02 | 3
133 | 3 | п2 | а3 | пр | 25.05.02 | 5
133 | 4 | п1 | а1 | л | 12.06.02 | 4
133 | 4 | п1 | а3 | пр | 25.05.02 | 4
134 | 11 | п1 | а2 | л | 07.06.02 | 3
134 | 11 | п2 | а1 | пр | 25.05.02 | 2
134 | 12 | п1 | а2 | л | 07.06.02 | 2
134 | 12 | п2 | а1 | пр | 20.05.02 | 3
134 | 13 | п1 | а2 | л | 07.06.02 | 4
134 | 13 | п2 | а3 | пр | 20.05.02 | 5
134 | 14 | п1 | а2 | л | 07.06.02 | 5
134 | 14 | п2 | а3 | пр | 20.05.02 | 5

1. Записать условие выбора записей о сдаче экзаменов студентами группы 133 по предмету п1 на оценки 4 или 5 несколькими способами на отдельных листах книги:

1-й способ. Множественный критерий сравнения — все условия находятся в одной строке, связка И. Номер группы, код предмета заданы как точные значения, оценка— оператор сравнения со значением константы.

Номер группы | Код предмета | Оценка
133 | П1 | >3

2-й способ. Множественный критерий сравнения — все условия (точи значения полей) находятся в одной строке, столбец Оценка используется дважды, связка И.

Номер группы | Код предмета | Оценка | Оценка
133 | П1 | 4 | 5

3-й способ. Множественный критерий сравнения — условия (точные значения полей) записаны в двух строках, связка ИЛИ.

Номер группы | Код предмета | Оценка
133 | п1 | 4
133 | п1 | 5

2. Выбрать записи о сдаче экзаменов студентами группы 133 с оценкой ниже общего среднего балла или записи с оценкой 5.

3. Сформируйте в области условий отбора вычисляемый критерий — для каждого преподавателя выбрать сведения о сдаче студентами экзамена на оценку выше средней, вид занятий — л; результат отбора поместите на новый рабочий лист.


Задание 11

Задание 11. Применение Расширенного фильтра. Подведение промежуточных итогов.

Введите данные о слушателях, принятых на обучение.

Пол | Дата рожд. | Кто направил | Сем. положение | Категория образ. | Стаж с
Жен | 12.11.70 | Белгородский ГЦЗН | Женат(замужем) | Высшее | 1.01.94
Жен | 8.04.67 | Яковлевский РЦЗН | Холост(не замужем) | Высшее | 1.01.84
Муж | 24.09.80 | Частное лицо | Холост(не замужем) | Среднее | 1.01.98
Жен | 16.04.72 | Белгородский РЦЗН | Холост(не замужем) | Высшее | 1.01.98
Жен | 20.01.75 | Белгородский ГЦЗН | Женат(замужем) | Высшее | 1.01.00
Муж | 17.08.70 | Шебекинский ГЦЗН | Женат(замужем) | Среднее | 1.01.87
Жен | 24.10.62 | Белгородский ГЦЗН | Женат(замужем) | Высшее | 1.01.84
Жен | 28.10.68 | Частное лицо | Женат(замужем) | Высшее | 1.01.94
Муж | 17.10.72 | Белгородский ГЦЗН | Женат(замужем) | Среднее | 1.01.98
Жен | 24.03.64 | Частное лицо | Холост(не замужем) | Нач.проф | 1.01.91
Муж | 16.12.78 | Борисовский РЦЗН | Женат(замужем) | Среднее | 1.01.00
Жен | 4.03.74 | Белгородский ГЦЗН | Женат(замужем) | Среднее | 1.01.93
Жен | 8.01.81 | Шебекинский ГЦЗН | Холост(не замужем) | Среднее | 1.01.00
Муж | 01.12.99 | Белгородский ГЦЗН | Женат(замужем) | Среднее | 1.01.99
Муж | 06.12.71 | Белгородский ГЦЗН | Холост(не замужем) | Нач.проф | 1.01.86
Жен | 3.07.60 | Белгородский ГЦЗН | Женат(замужем) | Ср-проф. | 1.01.77
Жен | 17.05.52 | Белгородский ГЦЗН | Холост(не замужем) | Ср-проф. | 1.01.71
Муж | 08.10.66 | Белгородский ГЦЗН | Женат(замужем) | Ср-спец | 1.01.87
Жен | 23.02.78 | Валуйский ГЦЗН | Женат(замужем) | Ср-проф. | 1.01.00
Жен | 24.09.69 | Белгородский РЦЗН | Холост(не замужем) | Ср-проф. | 1.01.89
Муж | 4.02.59 | Белгородский ГЦЗН | Холост(не замужем) | Среднее | 1.01.75
Жен | 29.04.72 | Яковлевский РЦЗН | Женат(замужем) | Ср-проф. | 1.01.91
Жен | 14.09.68 | Белгородский ГЦЗН | Холост(не замужем) | Ср-спец | 1.01.86
Муж | 2.07.65 | Ивнянский РЦЗН | Холост(не замужем) | Ср-проф. | 1.01.85

1. Выполнить сортировку по следующим полям: Пол, затем Кто направил, Образование.

2. Подвести промежуточные итоги по полям, указанным в п.1.

3. Записать результат на новый лист книги.

4. Выполнить сортировку по следующим полям: Пол, затем Семейное положение, Образование.

5. Подвести промежуточные итоги по полям, указанным в п.4.

6. Записать результат на новый лист книги.

7. В основной таблице отменить все Итоги.

8. Выполнить задания на Расширенный фильтр

а) Пол Дата рожд. Категория образ.
 Жен >01.01.70 Высшее

б) Кто направил Категория образ. Стаж с
Шебекинский Среднее <1.01.91
ГЦЗН
Высшее > 1.01.87

в) Пол Кто направил Сем. положение
 Муж Белгородский ГЦЗН Холост (не замужем)
Частное лицо

9. Результаты отбора записать на отдельные листы книги.


Задание 12

Задание 12. Сводные таблицы

Постройте сводные таблицы по данным из файла Примеры.xls, лист: Объем и сбыт. Каждая таблица должна находиться на отдельном листе. Сводные таблицы должны отражать следующие данные:

1. В Область страницы – Район, в Область строк – Продавец, в Область столбцов – Продукты, в Область данных – Сбыт и Объем. Добавить вычисляемое поле Разница (Объем – Сбыт). Проверить объем и сбыт по району Южный по продавцам Белов и Петров.

2. В Область страницы – Год, в Область строк – Район, в Область строк – Продавцы, в Область данных – Сбыт и Объем. Добавить вычисляемое поле Максимум по Сбыту. Проверить объем и сбыт по 1997 году по районам Восточный и Северный по продавцам Иванов и Сидоров.

3. В Область страницы – Продавец, в Область столбцов – Район, Год и Месяц, в Область строк – Продукты, в Область данных – Сбыт. Выключить общие итоги по столбцам и строкам сводной таблицы, перейдя в Мастер сводных таблиц – третий шаг – Параметры. Добавить вычисляемое поле Среднее по Сбыту. Проверить сбыт по продавцу Белову, по району Восточный, по продукции Мясо и Молоко.

4. На новом листе книги создать сводную таблицу с двумя полями в области страницы. Для поля области данных задать итоговую функцию и дополнительные вычисления по своему усмотрению. Отобразить все страницы одного из полей области страницы на отдельных листах с помощью пункта меню Сводные таблицы – Отобразить страницы панели инструментов и просмотреть полученные листы рабочей книги.

5. В полученных выше сводных таблицах поменять местами произвольно поля в Области страницы, Области столбцов и Области строк. Проанализировать полученные результаты.


5.1. Рабочая книга и листы

Общие сведения

Книга в Microsoft Excel представляет собой файл, используемый для обработки и хранения данных. Каждая книга может состоять из нескольких листов, поэтому в одном файле можно поместить разнообразные сведения и установить между ними необходимые связи. Она представляет собой электронный эквивалент папки-скоросшивателя. При запуске Microsoft Excel создается новая рабочая книга.

Листы служат для организации и анализа данных. Лист представляет собой сетку из строк и столбцов. Каждая ячейка образуется пересечением строки и столбца и имеет свой уникальный адрес или ссылку. Например, ячейка, находящаяся на пересечении столбца В и строки 5, имеет адрес В5. Эти адреса используются при записи формул или ссылках на ячейки. Наибольший размер листа -- 65536 строк и 256 столбцов.

Можно вводить и изменять данные одновременно на нескольких листах, а также выполнять вычисления на основе данных из нескольких листов. Имена листов отображаются на ярлычках в нижней части окна книги. Для перехода с одного листа на другой следует щелкнуть мышью на соответствующем ярлычке.

Примечание. Если ярлычки листов не отображаются в нижней части экрана, то необходимо выбрать команду Параметры в меню Сервис и на вкладке Вид установить флажок Ярлычки листов.


Работа с листами

Удобнее всего операции с листами выполнять с помощью команд контекстного меню (вызывается щелчком правой кнопки мыши на ярлычке листа).

Вставка листа. Выберите команду Добавить в контекстном меню. Лист будет вставлен слева от текущего листа.

Удаление листа. Выделите листы, которые нужно удалить, и выберите команду Удалить в контекстном меню.

Переименование листа. Выберите команду Переименовать в контекстном меню или дважды щелкните на ярлычке нужного листа, а затем введите новое имя поверх старого.

Перемещение и копирование листов. Листы можно перемещать и копировать из одной книги в другую, а также менять их порядок в пределах одной книги. Для этого:

1. Выделите листы, которые необходимо скопировать или переместить.

2. Выберите команду Переместить/скопировать в контекстном меню.

3. Выберите соответствующую книгу в поле Переместить выбранные листы в книгу. Чтобы переместить или скопировать выбранные листы в новую книгу, выберите пункт Новая книга.

4. В поле Перед листом выберите лист, перед которым нужно вставить перемещаемые или копируемые листы.

5. Чтобы только скопировать, а не переместить листы, установите флажок Создавать копию.

Совет. Перемещать выбранные листы в пределах текущей книги можно перетаскивая их с помощью мыши вдоль ряда ярлычков листов. Чтобы копировать листы, нажмите и удерживайте клавишу CTRL, переместите листы в нужное положение, затем отпустите кнопку мыши и только после этого — клавишу CTRL.

Скрытие листа. Чтобы сократить количество листов на экране, а также предотвратить нежелательные изменения, можно их скрыть. Например, можно скрыть листы, содержащие чувствительные к изменениям данные. Скрытые листы остаются открытыми, и другие документы могут использовать данные из них.

Для скрытия листа:

1. Выберите листы, которые нужно скрыть.

2. В меню Формат выберите пункт Лист, а затем команду Скрыть.

Для отображения скрытого листа:

1. В меню Формат выберите пункт Лист, а затем команду Показать.

2. Выберите имя скрытого листа, который нужно вывести на экран.

Одновременный просмотр нескольких книг

1. Откройте книги, которые нужно просмотреть.

2. В меню Окно выберите команду Расположить.

3. Выберите требуемый параметр.

Одновременный просмотр различных частей листа

Чтобы одновременно просматривать и прокручивать различные части листа, нужно разделить его по горизонтали и вертикали на отдельные области. Наведите указатель на вешку, расположенную в верхней части вертикальной полосы прокрутки или в правой части горизонтальной полосы прокрутки. Когда указатель примет вид двунаправленной стрелки [image], перетащите его вниз или влево.

Чтобы восстановить окно, которое было разделено на две области, дважды щелкните на полосе разделения областей или выберите команду Снять закрепление в меню Окно.

Чтобы заголовки строк и столбцов, а также другие данные, оставались видимыми во время прокрутки листа, нужно закрепить верхнюю и левую области. Данные в таких областях не прокручиваются и остаются видимыми при движении в других частях листа.

Закрепление областей:

  1. Чтобы закрепить верхнюю горизонтальную область, укажите строку, над которой требуется разбить лист. Чтобы закрепить левую вертикальную область, укажите столбец, слева от которого требуется разбить лист. Чтобы закрепить обе области, укажите ячейку, расположенную слева и выше того места, где требуется разбить лист.
  2. В меню Окно выберите команду Закрепить области.

Чтобы снять закрепление областей, выберите команду Снять закрепление областей в меню Окно.


5.2. Ввод данных

Выделение ячеек на листе

Чтобы выделить

Сделайте следующее

Диапазон ячеек

Выберите первую ячейку и, не отпуская кнопку мыши, переместите указатель мыши к последней ячейке диапазона

Все ячейки листа

Нажмите кнопку Выделить все

Несмежные ячейки или диапазоны ячеек

Выделите первую ячейку или первый диапазон ячеек, затем, удерживая нажатой клавишу CTRL, выделите остальные ячейки или диапазоны
Большой диапазон ячеек

Щелкните на первой ячейке, затем, удерживая нажатой клавишу SHIFT, укажите последнюю ячейку диапазона. Для перемещения к последней ячейке можно использовать полосы прокрутки

Всю строку

Щелкните на заголовке строки
Весь столбец Щелкните на заголовке столбца
Ячейки в соответствии с содержащимися в них данными

  1. Выделите диапазон, содержащий тип ячеек, которые нужно выделить

  2. В меню Правка выберите команду Перейти

  3. Нажмите кнопку Выделить

  4. Установите нужные параметры


Интерпретация данных

Числа. Вводимые в ячейку числа интерпретируются как константы. В Microsoft Excel число может состоять только из следующих символов:

0 1 2 3 4 5 6 7 8 9 + - ( ) , / $ % . E e

Стоящие перед числом знаки плюс (+) игнорируются, а запятая интерпретируется как разделитель десятичных разрядов. Все другие сочетания клавиш, состоящие из цифр и нецифровых символов, рассматриваются как текст. Символы, которые рассматриваются как числа, зависят от установленных параметров в компоненте Язык и стандарты панели управления Windows. Перед отрицательным числом необходимо вводить знак минус (-) или заключать его в круглые скобки ( ). Введенные числа выравниваются в ячейке по правому краю. Независимо от количества отображаемых разрядов числа хранятся с точностью до 15 разрядов.

Текст. В Microsoft Excel текстом является любая последовательность, состоящая из цифр, пробелов и нецифровых символов, например:10AA109, 127AXY, 12-976, 208 4675.

Введенный текст выравнивается в ячейке по левому краю.

Дата и время суток. В Microsoft Excel даты и время суток интерпретируются как числа. Поэтому их можно складывать, вычитать и производить с ними другие вычисления. В формулы они могут быть введены в виде текста, заключенного в двойные кавычки. Внешнее представление времени или даты на листе зависит от числового формата, назначенного ячейке. При вводе значений даты или времени происходит их автоматическое распознавание, и общий формат ячейки заменяется на встроенный формат даты или времени. По умолчанию значения даты и времени выравниваются в ячейке по правому краю. Если не происходит автоматического распознавания формата даты или времени, то введенные значения интерпретируются как текст, который выравнивается в ячейке по левому краю.

Параметры, установленные в компоненте Язык и стандарты панели управления Windows, определяют формат для текущей даты и времени и символы, использующиеся в качестве разделителей, например двоеточие (:) и точка (.) в стандарте России.

Чтобы ввести дату и время суток в одну и ту же ячейку, в качестве разделителя даты и времени используйте пробел.


Ввод текста и чисел

Для ввода данных:

1. Выберите ячейку, в которую необходимо ввести данные.

2. Наберите данные и нажмите клавишу ENTER или кнопку [image] слева от строки формул. Для отмены ввода данных перед нажатием клавиши ENTER, нажмите клавишу ESC или кнопку [image] .

Если введенный текст отображается не полностью, то необходимо увеличить ширину столбца или изменить формат ячейки.

Быстрое заполнение повторяющихся данных в столбце

Если несколько первых символов, вводимых в ячейку, совпадают с символами записи, ранее введенной в этом столбце, то недостающая часть набора будет произведена автоматически. В Microsoft Excel автоматический ввод производится только для тех записей, которые содержат текст или текст в сочетании с числами. Записи, полностью состоящие из чисел, дат или времени, необходимо вводить самостоятельно. Для подтверждения предлагаемого варианта нажмите клавишу ENTER. Для замены автоматически введенных символов продолжите ввод самостоятельно. Для удаления автоматически введенных символов нажмите клавишу BACKSPACE.

Вариант ввода также можно выбрать из списка записей, которые уже имеются в столбце. Чтобы просмотреть список, выделите ячейку с помощью правой кнопки мыши, а затем выберите команду Выбор из списка в контекстном меню.


Автозаполнение, основанное на смежных ячейках

Маркер заполнения – небольшой черный квадрат в правом нижнем углу выделенного диапазона. Попав на маркер заполнения, указатель принимает вид черного креста. Чтобы скопировать содержимое выделенного диапазона в соседние ячейки или заполнить их подобными данными (например, днями недели), нажмите левую кнопку мыши и перемещайте мышь в нужном направлении.

Примечание. Для включения и выключения режима правки с помощью перетаскивания и автозаполнения выберите команду Параметры в меню Сервис, а затем на вкладке Правка установите или снимите флажок Разрешить перетаскивание ячеек.

Если ячейка содержит число, дату или период времени, который может являться частью ряда, то при копировании происходит приращение ее значения. Например, если ячейка имеет значение "Январь", то существует возможность быстрого заполнения других ячеек строки или столбца значениями "Февраль", "Март" и так далее. Могут создаваться пользовательские списки автозаполнения для часто используемых значений, например названий торговых районов компании.

Совет. Для выбора типа ряда во время перетаскивания маркера заполнения удерживайте нажатой правую кнопку мыши. Затем освободите ее и выберите соответствующую команду в контекстном меню. Например, если начальное значение – дата «янв-96», то для ряда «фев-96», «мар-96», ... выберите команду Заполнить по месяцам. Для ряда «янв-96», «янв-97» ... выберите команду Заполнить по годам.

Заполнение рядов чисел, дат и других элементов

1. Выберите первую ячейку заполняемого диапазона и введите начальное значение. Чтобы задать приращение, отличное от 1, укажите вторую ячейку ряда и введите соответствующее ей значение. Величина приращения будет задана разностью значений, находящихся в этих ячейках.

2. Выделите ячейку или ячейки, содержащие начальные значения.

3. Перетащите маркер заполнения через заполняемые ячейки. Для заполнения в возрастающем порядке перетащите маркер вниз или вправо. Для заполнения в убывающем порядке перетащите маркер вверх или влево.


Создание пользовательского списка или порядка сортировки

Существует возможность создания пользовательского списка автозаполнения или порядка сортировки либо из существующих на листе элементов, либо с помощью непосредственного ввода списка.

Если ряд элементов, который необходимо представить в виде пользовательского списка автозаполнения, был набран заранее:

1. Выделите его на листе.

2. Выберите команду Параметры в меню Сервис, а затем на вкладке Списки нажмите кнопку Импорт.

Чтобы создать новый список:

1. Выберите Новый список в поле Списки.

2. Введите данные в поле Элементы списка, начиная с первого элемента. После ввода каждой записи нажимайте клавишу ENTER.

3. Нажмите кнопку Добавить после того, как список будет набран полностью.

Для изменения или удаления пользовательского списка автозаполнения или порядка сортировки сделайте необходимые изменения в поле Элементы списка и нажмите кнопку Добавить. Чтобы удалить список, нажмите кнопку Удалить.

Примечание. Стандартные списки, содержащие названия дней недели и месяцев, нельзя удалить или отредактировать.


Проверка вводимых в ячейку данных

Чтобы предотвратить появление на листе некорректных данных, следует указать, какие данные допустимо вводить в отдельные ячейки или в их диапазон. Ограничения можно накладывать на тип данных (целые числа, десятичные числа или текст), а также на количество вводимых символов. Проверка данных, полученных на основании вычислений в другой ячейке, осуществляется с помощью формулы. После ввода и выполнения расчетов на листе проводится поиск и исправление некорректных данных.

Для ограничения диапазона вводимых данных:

1. Выделите ячейки, на которые требуется наложить ограничения.

2. Выберите команду Проверка в меню Данные, затем вкладку Параметры.

3. Выберите тип данных в списке Тип данных.

4. Выберите нужный оператор в списке Значение и затем введите верхнюю и нижнюю границы допустимого диапазона данных или только одну из них, в зависимости от требований. Границами могут служить числовые значения, а также ссылки на ячейки или формулы. Флажок Игнорировать пустые ячейки позволяет оставить ячейку, на которую наложены ограничения, пустой.

5. Для вывода на экран подсказки при вводе неверных значений введите текст сообщений на вкладках Сообщение для ввода и Сообщение об ошибке.


5.3. Изменение данных на листе

Изменение содержимого ячейки

1. Выберите ячейку, содержимое которой необходимо изменить.

2. Щелкните в строке формул и измените содержимое ячейки. Если необходимо изменить функцию в формуле, можно воспользоваться панелью формул. Чтобы отобразить панель формул, нажмите кнопку Изменить формулу [image] . На панели отобразится первая функция формулы, а также все ее аргументы. Изменение первой функции или любой другой происходит путем выбора в строке формул необходимой части функции.

3. Для сохранения изменений нажмите клавишу ENTER. Для отмены изменений нажмите клавишу ESC.

Очистка ячейки

1. Выделите ячейки, строки или столбцы, которые следует очистить.

2. В меню Правка выберите команду Очистить, а затем один из пунктов - Все, Содержимое, Форматы или Примечания.

Примечание. При нажатии клавиш DELETE и BACKSPACE удаляется только содержимое. Значение очищенной ячейки равно 0.

Перемещение и копирование ячеек

При использовании перетаскивания, а также команд Вырезать [image] , Копировать [image] и Вставить [image] , Microsoft Excel полностью копирует ячейку, включая формулы и возвращаемые ими значения, примечания и форматы.

Вместо копирования содержимого ячеек целиком можно скопировать только часть содержимого ячейки, например возвращаемое формулой значение, без копирования самой формулы. Для этого вместо команды Вставить в меню Правка выберите команду Специальная вставка, укажите нужный параметр в группе Вставить, а затем нажмите кнопку OK.

Изменение ширины столбца

Установите указатель мыши на правую границу заголовка и перемещайте до тех пор, пока ширина столбца не достигнет необходимого размера.

Для подгонки ширины столбца в соответствии с содержимым его ячеек дважды щелкните на правой границе заголовка.

Вставка строк и столбцов

1. Для вставки одной строки выберите ячейку в строке, над которой следует вставить новую строку. Чтобы вставить несколько строк, выделите строки, над которыми следует вставить новые строки. Для вставки одного столбца выберите ячейку в столбце, слева от которого следует поместить новый столбец. Чтобы вставить несколько столбцов, выделите столбцы, слева от которых следует вставить новые столбцы.

2.В меню Вставка выберите соответственно команду Строка или Столбец.


5.4. Форматирование

Форматирование текста и размещение его внутри ячейки

  1. В меню Формат выберите команду Ячейки, затем перейдите к вкладке Выравнивание. Выберите соответствующие параметры выравнивания по горизонтали и вертикали, а также, если необходимо, ориентацию текста.
  2. Для размещения текста в нескольких ячейках установите флажок Объединение ячеек. Для размещения текста в несколько строк установите флажок Переносить по словам. Чтобы поместить текст, не изменяя ширины столбца, установите флажок Автоподбор ширины.

Примечание. Для объединения ячеек и центрирования их содержимого можно также нажать кнопку Объединить и поместить в центре [image] на панели инструментов.

Выделение данных, отвечающих определенным свойствам

Результаты вычисления или другие важные значения могут быть выделены при помощи условных форматов. Например, пусть ячейка содержит формулу, вычисляющую разницу между прогнозируемыми и реальными продажами. Если реальные продажи превышают прогнозируемые, Microsoft Excel может выделить ячейку зеленым цветом, а в обратном случае - красным. Для применения условных форматов:

1. Выделите ячейки, формат которых необходимо изменить.

2. В меню Формат выберите команду Условное форматирование.

3. Чтобы в качестве условия использовать значения выделенных ячеек, выберите параметр Значение, операцию сравнения, а затем в необходимое поле введите значение или формулу. Для оценки данных или условий, отличных от значений выделенных ячеек, в качестве критерия используйте формулу, которую введите в поле справа. Формула должна принимать логическое значение ИСТИНА или ЛОЖЬ.

4. Нажмите кнопку Формат и выберите параметры.

5. Для добавления условия нажмите кнопку А также>>. Указать можно до трех условий.

Выбранные форматы будут применены, только если значение ячейки отвечает поставленному условию или если формула принимает значение ИСТИНА.

Изменение способа отображения чисел, дат и времени

Для изменения формата чисел, дат и времени в меню Формат выберите команду Ячейки, перейдите к вкладке Число и выберите необходимый формат.

Для изменения основных форматов также можно воспользоваться кнопками на панели инструментов Форматирование, в том числе Формат с разделителями, Денежный формат, Процентный формат, Уменьшить разрядность, Увеличить разрядность.

Отображение и скрытие нулевых значений и других данных

По умолчанию нулевые значения представлены в виде нулей. Для скрытия нулей необходимо изменить соответствующий параметр. Ячейки можно отформатировать так, чтобы все значения ячеек были скрыты.

Для скрытия нулевых значений на всем листе в меню Сервис выберите команду Параметры, перейдите к вкладке Вид и снимите флажок Нулевые значения.

Для скрытия нулевых значений и других данных в выделенных ячейках:

1. В меню Формат выберите команду Ячейки и перейдите к вкладке Число.

2. В поле Числовые форматы выберите пункт (все форматы).

3. Для скрытия нулевых значений в поле Тип введите 0;-0;;@.

4. Для скрытия всех значений в поле Тип введите ;;; (три символа “точка с запятой”). Скрытые значения отображаются только в поле формул или в ячейке при ее редактировании. На печать эти значения не выводятся.

Использование рамок и фона в ячейках

Выделите ячейки, в которые необходимо добавить рамку.

Для использования рамки, выбранной в прошлый раз, нажмите кнопку Границы [image] на панели инструментов Форматирование. Для использования другого типа рамки нажмите стрелку рядом с кнопкой Границы и выберите желаемый тип рамки.

Чтобы использовать дополнительные типы рамок, в меню Формат выберите команду Ячейки и перейдите к вкладке Граница. Выберите желаемый тип линии, а затем укажите место применения выбранной рамки.

Для использования цвета фона, выбранного в прошлый раз, нажмите кнопку Цвет заливки [image] на панели инструментов Форматирование. Для использования другого цвета нажмите стрелку рядом с кнопкой, а затем выберите необходимый цвет.


5.5. Создание формул

Формула является основным средством для анализа данных. С помощью формул можно складывать, умножать и сравнивать данные, а также объединять значения. Формулы подчиняются определенному синтаксису, в который входит знак равенства (=), вычисляемые элементы (операнды) и операторы. Операндами могут быть: константы, ссылки или диапазоны ссылок, заголовки, имена или функции.

Применение операторов в формулах

Операторами обозначаются операции, которые следует выполнить над операндами формулы. В Microsoft Excel включено четыре вида операторов - арифметические, текстовые, а также операторы сравнения и адресные операторы.

Арифметические операторы используются для выполнения основных математических вычислений над числами. Результатом выполнения арифметической операции всегда является число. Обозначаются следующими символами:

+ сложение
– вычитание или унарный минус
* умножение
/ деление
% процент
^ возведение в степень

Операторы сравнения используются для обозначения операций сравнения двух чисел. Результатом выполнения операции сравнения является логическое значение ИСТИНА или ЛОЖЬ. Обозначаются следующими символами:

= равно
> больше
< меньше
>= больше или равно
<= меньше или равно
<> не равно

Текстовый оператор & используется для обозначения операции объединения последовательностей символов в единую последовательность. Например, результатом выполнения выражения "Северный" & " ветер" будет: "Северный ветер".

Адресные операторы объединяют диапазоны ячеек для осуществления вычислений. Обозначаются символами:

: | оператор диапазона, который ссылается на все ячейки между границами диапазона включительно
, | оператор объединения, который ссылается на объединение ячеек диапазонов
пробел | оператор пересечения, который ссылается на общие ячейки диапазонов.

Порядок выполнения действий в формулах

Если формула состоит из нескольких операторов, действия выполняются в следующем порядке:

: (двоеточие), (запятая) (пробел) | операторы ссылок
– | унарный минус (например, –1)
% | процент
^ | возведение в степень
* и / | умножение и деление
+ и – | сложение и вычитание
& | текстовый оператор
= < > <= >= <> | операторы сравнения

Чтобы изменить порядок обработки операторов, расставьте круглые скобки.


Ссылки на ячейку или на группу ячеек

В формулах могут быть ссылки на ячейки или на диапазоны ячеек текущего листа, листов той же книги или других книг, а также на имена или заголовки, представляющие ячейки или диапазоны ячеек.

Ссылкой однозначно определяется ячейка или группа ячеек листа, а также упрощается поиск значений или данных, используемых в формуле. С помощью ссылок можно использовать в формуле данные, находящиеся в различных местах листа, а также использовать значение одной и той же ячейки в нескольких формулах. Кроме того, можно ссылаться на ячейки, находящиеся на других листах книги или в другой книге. Ссылки на ячейки других книг называются внешними ссылками.

Примеры использования ссылок:

СРЗНАЧ(C2:C6) - вычисление среднего значения содержимого ячеек с C2 по C6;

СУММ(D4;Лист2!D6:E6) - вычисление суммы содержимого ячейки D4 и диапазона ячеек D6:E6 на листе Лист2;

СУММ(B1;[Книга1]Лист1!$D$4) - вычисление суммы содержимого ячейки B1 и ячейки D4 на листе Лист1 в книге Книга1.

В зависимости от поставленной задачи можно использовать либо относительные ссылки, которые ссылаются на ячейки относительно позиции формулы, либо абсолютные ссылки, которые ссылаются всегда на одну и ту же ячейку.

При создании формулы ссылки обычно изменяются относительно расположения ячейки, содержащей формулу.

В следующем примере ячейка B6 содержит формулу =A5; искомое значение находится на одну ячейку выше и левее ячейки B6. Такая ссылка называется относительной.

При копировании формулы, содержащей относительные ссылки, и вставке ее в другое место, ссылки будут указывать на другие ячейки.

В следующем примере формула из ячейки B6 копируется в ячейку B7. В ячейке B7 будет содержаться формула =A6, которая ссылается на одну ячейку выше и левее ячейки B7.

Если необходимо, чтобы ссылки не изменялись при копировании формулы в другую ячейку, воспользуйтесь абсолютными ссылками. Например, если имеется формула, умножающая содержимое ячейки A5 на ячейку C1, (=A5*C1), то при копировании формулы в другую ячейку изменятся обе ссылки. Для создания абсолютной ссылки на ячейку C1 поставьте знак доллара ($) перед той частью, которая не должна изменяться. Чтобы создать абсолютную ссылку на ячейку C1, поместите знак доллара перед номером строки и номером столбца $C$1 .


Ввод формулы

1. Выберите ячейку, в которую необходимо ввести формулу.

2. Введите = (знак равенства). Чтобы начать набор формулы с функции, нажмите кнопку Изменить формулу [image] или Вставка функции [image] . При этом автоматически вставляется знак равенства.

3. Введите формулу. Если в формуле используются ссылки, выделите необходимые ячейки при вводе. Если используется внешняя ссылка, выберите лист, содержащий связываемые ячейки, и выделите их.

4. Нажмите клавишу ENTER.


Использование функций

Функции задаются с помощью формул, которые выполняют вычисления по заданным величинам, называемым аргументами, и в указанном порядке, называемом синтаксисом. Список аргументов может состоять из чисел, текста, логических величин (ИСТИНА или ЛОЖЬ), массивов, значений ошибок (#Н/Д) или ссылок. Необходимо следить за соответствием типов аргументов. Кроме того, аргументы могут быть как константами, так и формулами. Эти формулы, в свою очередь, могут содержать другие функции.

Написание функции начинается с указания имени функции, затем вводится открывающая скобка, указываются аргументы, отделяющиеся запятыми, а затем — закрывающая скобка. Вставлять функцию в формулу рекомендуется с помощью панели формул. В панели формул отображается имя функции и ее аргументы, описание функции и аргументов, а также возвращаемое функцией и формулой значение.

Порядок вставки функции с помощью панели формул:

1. Нажмите кнопку Изменить формулу [image] в строке формул.

2. Нажмите кнопку со стрелкой, расположенную справа от поля Функции.

3. Выберите функцию, вставляемую в формулу. Если функция отсутствует в списке, выберите пункт Другие функции, после чего запустится мастер функций.

4. Введите аргументы. Для ввода в качестве аргументов значения ячейки удобно временно убрать с экрана диалоговое окно. Для этого нажмите кнопку [image] , расположенную справа от поля, где вводится аргумент, выделите необходимые ячейки листа и нажмите на эту же кнопку или на клавишу ENTER.

5. Нажмите кнопку OK.

Кроме того, панель формул можно использовать для изменения функции в формуле. Для этого выберите содержащую формулу ячейку и нажмите кнопку Изменить формулу. На панели отобразится первая функция формулы, а также все ее аргументы. Изменение первой функции или любой другой происходит путем выбора в строке формул необходимой части функции.

Функции могут использоваться как аргументы в других функциях. Если функция используется в качестве аргумента или является вложенной функцией, то она должна возвращать аргументу значение того же типа. Если функция возвращает значение другого типа, отобразится ошибка #ЗНАЧ!.

Например, следующая формула использует вложенную функцию СРЗНАЧ для сравнения ее значения со значением 50. Результат сравнения должен быть логической величиной (ИСТИНА или ЛОЖЬ), так как это требуемый тип для первого аргумента функции ЕСЛИ.

Чтобы использовать функцию в качестве аргумента, можно воспользоваться панелью формул. Например, нажимая стрелку списка в строке формул, можно вставить «функцию Б» в качестве аргумента «функции А» Для продолжения ввода аргументов в «функцию А» укажите ее имя в строке формул. В формулах можно использовать до семи уровней вложения функций.


Категории функций Microsoft Excel

В Microsoft Excel используется более 100 функций, объединенных по категориям:

  • Функции работы с базами данных можно использовать, если необходимо убедиться в том, что значения списка удовлетворяют условию. С их помощью, например, можно определить количество записей в таблице о продажах или извлечь те записи, в которых значение поля «Сумма» больше 1000, но меньше 2500.
  • Функции работы с датой и временем позволяют анализировать и работать со значениями даты и времени в формулах. Например, если требуется использовать в формуле текущую дату, воспользуйтесь функцией СЕГОДНЯ, возвращающей текущую дату по системным часам.
  • Инженерные функции служат для выполнения инженерного анализа. Это функции для работы с комплексными переменными, функции для преобразования чисел из одной системы счисления в другую (десятичную, шестнадцатиричную, восьмеричную, двоичную) и функции для преобразования величин из одной системы мер и весов в другую.
  • Финансовые функции осуществляют такие типичные финансовые расчеты, как вычисление суммы платежа по ссуде, объем периодической выплаты по вложению или ссуде, стоимость вложения или ссуды по завершении всех отложенных платежей и т.д.
  • Информационные функции предназначены для определения типа данных, хранимых в ячейке. Они проверяют выполнение какого-то условия и возвращают в зависимости от результата значение ИСТИНА или ЛОЖЬ. Так, если ячейка содержит четное значение, функция ЕЧЁТН возвращает значение ИСТИНА. Если в диапазоне функций имеется пустая ячейка, можно воспользоваться функцией СЧИТАТЬПУСТОТЫ.
  • Логические функции предназначены для проверки выполнения условия или для проверки нескольких условий. Так, функция ЕСЛИ позволяет определить, выполняется ли указанное условие, и возвращает одно значение, если условие истинно, и другое, — если оно ложно.
  • Функции ссылки и автоподстановки осуществляют поиск в списках или таблицах. Например, для поиска значения в таблице используйте функцию ВПР, а для поиска положения значения в списке — функцию ПОИСКПОЗ.
  • Арифметические и тригонометрические функции позволяют производить простые и сложные математические вычисления, например вычисление суммы диапазона ячеек, вычисление суммы ячеек диапазона, удовлетворяющих указанному условию, округление чисел и прочее.
  • Статистические функции позволяют выполнять статистический анализ диапазонов данных. Например, можно провести прямую по группе значений, вычислить угол наклона и точку пересечения с осью Y и прочее.
  • Функции обработки текста позволяют производить действия над строками текста, например изменить регистр или определить длину строки. Можно также объединить несколько строк в одну. Например, с помощью функций СЕГОДНЯ и ТЕКСТ можно создать сообщение, содержащее текущую дату и привести его к виду «дд-ммм-гг»:
    = «Балансовый отчет от» &ТЕКСТ(СЕГОДНЯ(), «дд-мм-гг»)

Если необходимо выполнить сложные вычисления, воспользуйтесь возможностью создания своих собственных нестандартных функций. Их создать с помощью языка VBA.


Ошибки в формулах

При появлении сообщения Ошибка в формуле:

  • Проверьте, одинаково ли количество открывающих и закрывающих скобок.
  • Проверьте правильность использования оператора диапазона при ссылке на группу ячеек.
  • Проверьте, все ли необходимые аргументы введены для функций.
  • Если первый символ в имени книги или листа не является буквой, необходимо заключить имя в одинарные кавычки.
  • Проверьте, в каждой ли внешней ссылке указано имя книги и полный путь к ней.
  • Не изменяйте формат чисел, введенных в формулы. Например, даже если в формулу необходимо ввести 1000 р., то введите число 1000.

Ошибка #####. Ошибка появляется, когда вводимое числовое значение или результат выполнения формулы не умещается в ячейке. В этом случае можно увеличить ширину столбца путем перемещения границы, расположенной между заголовками столбцов. Кроме того, можно изменить формат числа ячейки.

Ошибка #ДЕЛ/0!. Ошибка появляется, когда в формуле делается попытка деления на ноль. Например, в качестве делителя используется ссылка на ячейку, содержащую нулевое или пустое значение (если операнд является пустой ячейкой, то ее содержимое интерпретируется как ноль), или в формуле содержится явное деление на ноль.

Ошибка #Н/Д. Значение ошибки #Н/Д является сокращением термина “Неопределенные Данные”. Это значение помогает предотвратить использование ссылки на пустую ячейку. Введите в ячейки листа значение #Н/Д, если они должны содержать данные, но в настоящий момент эти данные отсутствуют. Формулы, ссылающиеся на эти ячейки, тоже будут возвращать значение #Н/Д вместо того, чтобы пытаться производить вычисления. Ошибка может возникнуть, если не заданы один или несколько аргументов стандартной или пользовательской функции, а также задан недопустимый аргумент.

Ошибка #ИМЯ?. Ошибка #ИМЯ? появляется, когда Excel не может распознать имя, используемое в формуле. Возможная причина:

  • Используемое имя было удалено или не было определено.
  • Имеется ошибка в написании имени.
  • Имеется ошибка в написании имени функции.
  • В формулу введен текст, не заключенный в двойные кавычки.
  • В ссылке на диапазон ячеек пропущен знак двоеточия (:).

Ошибка #ПУСТО!. Ошибка #ПУСТО! появляется, когда задано пересечение двух областей, которые в действительности не имеют общих ячеек.

Ошибка #ССЫЛКА!. Ошибка #ССЫЛКА! появляется, когда используется недопустимая ссылка на ячейку. Возможно, ячейки, на которые ссылаются формулы, были удалены или в эти ячейки было помещено содержимое других скопированных ячеек.

Ошибка #ЗНАЧ!. Ошибка #ЗНАЧ! появляется, когда используется недопустимый тип аргумента или операнда. Например, вместо числового или логического значения введен текст, и Microsoft Excel не может преобразовать его к нужному типу данных.


Использование имен

Рабочий лист может содержать заголовки, размещенные в начале столбца и слева от строки, с помощью которых описываются данные внутри листа. При ссылке на необходимые данные можно использовать эти заголовки в формуле, что делает ее более наглядной. Например, если таблица содержит количество проданной продукции в столбце «Продажа», а отдел, выполнивший торговую операцию, находится в строке «Отдел», то, создав формулу =Отдел Продажа, всегда можно определить количество проданной продукции заданным отделом. (Пробел между заголовками является оператором пересечения диапазонов, который предписывает формуле вернуть значения из ячейки, находящейся в пересечении строки «Отдел» и столбца «Продажа».)

Если данные не имеют заголовков или размещены на другом листе, можно создать имя, описывающее ячейку или диапазон ячеек. Использование имен может упростить понимание формулы. Например, формула =СУММ(Продано_в_первом_квартале) проще для понимания, чем формула =СУММ(Продажа!C20:C30). В этом примере имя Продано_в_первом_квартале представляет диапазон ячеек C20:C30 на листе «Продажа».

Имена можно использовать в любом листе книги. Например, если имя «Контракты» ссылается на группу ячеек A20:A30 в первом листе рабочей книги, то это имя можно применить в любом другом листе той же рабочей книги для ссылки на эту группу. По умолчанию имена являются абсолютными ссылками.

Для того чтобы присвоить имя ячейке или группе ячеек:

1. Выберите ячейку, группу ячеек или несмежный диапазон, которому необходимо присвоить имя.

2. Выберите поле имени, которое расположено слева в строке формул и введите имя ячеек.

Присвоить ячейкам имена можно при помощи существующих заголовков строк и столбцов. Для этого:

1. Выделите область, в которой следует присвоить имена строкам или столбцам. Выделенная область должна содержать строку или столбец заголовков.

2. Выберите команду Имя в меню Вставка, а затем — команду Создать.

3. Установите флажки В строке выше, В столбце слева, В строке ниже или В столбце справа в группе флажков По тексту, чтобы указать расположение заголовков, из которых следует создать имена.

Примечание. Созданное таким образом имя ссылается только на ячейки, содержащие значения, и не включает в себя существующие заголовки строк и столбцов.

Для того чтобы заменить ссылки именами в ячейке или формуле:

1. Выделите группу ячеек, содержащих формулы, в которых необходимо заменить ссылки именами. Чтобы заменить ссылки именами во всех формулах листа, выделите одну ячейку.

2. Выберите команду Имя в меню Вставка, а затем — команду Применить.

3. Выберите необходимые имена в списке Применить имена.


5.6. Проверка книг

Поиск зависимых и влияющих ячеек

При создании на листе формул можно получить подсказку о том, как связаны зависимые и влияющие ячейки.

Зависимые ячейки – это ячейки, содержащие формулы, ссылающиеся на другие ячейки. Например, если ячейка D10 содержит формулу =B5, ячейка D10 является зависимой от ячейки B5.

Влияющие ячейки – это ячейки, на которые ссылается формула из другой ячейки. Например, если ячейка D10 содержит формулу =B5, ячейка B5 является влияющей для ячейки D10.

Для поиска таких ячеек служат команды панели инструментов Зависимости.

Примечание. Перед тем как использовать панель инструментов Зависимости, установите флажки Отображать или Только очертания в группе Объекты на вкладке Вид диалогового окна Параметры (меню Сервис).

Для поиска зависимых и влияющих ячеек:

1. Выберите ячейку, для которой следует найти зависимые или влияющие ячейки.

2. Чтобы отобразить стрелку зависимостей к каждой зависимой ячейке, нажмите кнопку Зависимые ячейки [image] . Чтобы отобразить стрелку слежения от каждой влияющей ячейки, нажмите кнопку Влияющие ячейк и [image] .

3. Чтобы продолжить поиск следующего уровня зависимых или влияющих ячеек, снова нажмите соответствующую кнопку. Чтобы указать ячейку на другом конце стрелки, дважды щелкните стрелку мышью.

Примечание. Синие стрелки используются для поиска ячеек, формулы которых ссылаются на текущую ячейку. Красные стрелки указывают на циклические ссылки.

Поиск некорректных значений на листе

Во время проверки листа Microsoft Excel находит все ячейки, которые содержат значения, противоречащие ограничениям, заданным с помощью команды Проверка в меню Данные. Сюда входят значения, непосредственно введенные в ячейку, и значения, полученные в результате вычислений по формулам. Для поиска некорректных значений на панели инструментов Зависимости выберите Обвести неверные данные.

Совет. Чтобы узнать, какие сообщения и ограничения на данные имеет ячейка, выберите ячейку, а затем команду Проверка в меню Данные.


5.7. Работа с диаграммами

В Microsoft Excel имеется возможность графического представления данных в виде диаграмм. Диаграммы связаны с данными листа, на основе которых они были созданы, и изменяются каждый раз, когда изменяются данные на листе.

Диаграммы могут использовать данные несмежных ячеек. Диаграмма может также использовать данные сводной таблицы.

Примеры типов диаграмм

Гистограмма показывает изменение данных за определенный период времени и иллюстрирует соотношение отдельных значений данных. Категории располагаются по горизонтали, а значения - по вертикали. Таким образом, уделяется большее внимание изменениям во времени.

В трехмерной гистограмме сравнение данных производится по двум осям. Например, показанная на рисунке трехмерная диаграмма позволяет сравнить объемы продаж в Европе за каждый квартал с объемами продаж в двух других регионах.

Линейчатая диаграмма с накоплением показывает вклад отдельных элементов в общую сумму.

Линейчатая диаграмма отражает соотношение отдельных компонентов. Категории расположены по горизонтали, а значения -по вертикали. Таким образом, уделяется большее внимание сопоставлению значений и меньшее - изменениям во времени.

График отражает тенденции изменения данных за равные промежутки времени.

Круговая диаграмма показывает как абсолютную величину каждого элемента ряда данных, так и его вклад в общую сумму. На круговой диаграмме может быть представлен только один ряд данных. Такую диаграмму рекомендуется использовать, когда необходимо подчеркнуть какой-либо значительный элемент.

Точечная диаграмма отображает взаимосвязь между числовыми значениями в нескольких рядах и представляет две группы чисел в виде одного ряда точек в координатах xy. Эта диаграмма отображает нечетные интервалы данных и часто используется для представления данных научного характера. При подготовке данных следует расположить в одной строке или столбце все значения переменной x, а соответствующие значения y - в смежных строках или столбцах.

Диаграмма с областями подчеркивает величину изменения в течение определенного периода времени, показывая сумму введенных значений. Она также отображает вклад отдельных значений в общую сумму. В данном примере диаграмма с областями показывает увеличение продаж в Бразилии, а также иллюстрирует вклад каждой страны в общий объем продаж.

Как и круговая диаграмма, кольцевая диаграмма показывает вклад каждого элемента в общую сумму, но в отличие от круговой диаграммы она может содержать несколько рядов данных. Каждое кольцо в кольцевой диаграмме представляет отдельный ряд данных.

В лепестковой диаграмме каждая категория имеет собственную ось координат, исходящую из начала координат. Линиями соединяются все значения из определенной серии. Лепестковая диаграмма позволяет сравнить общие значения из нескольких наборов данных. На этой диаграмме ряд данных, охватывающий наибольшую часть площади (сорт A), представляет сорт с самым высоким содержанием витаминов.

Поверхностная диаграмма используется для поиска наилучшего сочетания двух наборов данных. Как на топографической карте, области с одним значением выделяются одинаковым узором и цветом

Биржевая диаграмма часто используется для демонстрации цен на акции. Этот тип диаграммы также может быть использован для научных данных, например, для определения изменения температуры. Для построения этой и других биржевых диаграмм необходимо правильно организовать данные.


Создание диаграммы

Выберите команду Диаграмма в меню Вставка или нажмите кнопку Мастер диаграмм [image] на панели инструментов Стандартная и следуйте инструкциям мастера:

Шаг 1. Выберите тип и вид диаграммы. Нажмите кнопку Далее.

Шаг 2. На вкладке Диапазон данных нажмите кнопку [image] , чтобы временно убрать с экрана диалоговое окно и выделите диапазон ячеек, содержащих данные, которые должны быть отражены на диаграмме. Если необходимо, чтобы в диаграмме были отражены и названия строк или столбцов, выделите также содержащие их ячейки.

На вкладке Ряды можно добавить или удалить любой из рядов данных. В поле Имя указывается ячейка листа, которую следует использовать как легенду или имя ряда. В поле Подписи оси X (категорий) указывается диапазон ячеек, которые нужно использовать как подписи делений оси категорий. Нажмите кнопку Далее.

Шаг 3. Укажите параметры элементов диаграммы. Нажмите кнопку Далее.

Шаг 4. Укажите, где следует поместить диаграмму - на отдельном новом листе или на имеющемся. Нажмите кнопку Готово.


Изменение диаграммы

Диаграмма может содержать следующие элементы:

  • Область диаграммы - вся диаграмма, вместе со всеми ее элементами.
  • Область построения - в двумерной диаграмме областью построения называется область, ограниченная осями и содержащая все ряды диаграммы. В трехмерной диаграмме это область, ограниченная осями и включающая ряды данных, названия категорий, подписи делений и названия осей.
  • Легенда - подпись, определяющая закраску или цвета точек данных или категорий диаграммы.
  • Название диаграммы - описательный текст, автоматически связанный с осью или расположенный по центру диаграммы.
  • Ряд данных - группа связанных точек данных диаграммы, отображающая значение строк или столбцов листа. Каждый ряд данных отображается по-своему. На диаграмме может быть отображен один или несколько рядов данных. На круговой диаграмме отображается только один ряд данных.
  • Подпись значения - подпись, предоставляющая дополнительные сведения о точке данных, отображающей какое-либо значение ячейки. Подписями данных могут быть снабжены как отдельные точки данных, так и весь ряд целиком. В зависимости от типа диаграммы подписи данных могут отображать значения, названия рядов и категорий, доли или их комбинации.
  • Маркер данных - столбик, закрашенная область, точка, сегмент или другой геометрический объект диаграммы, обозначающий точку данных или значение ячейки. Связанные точки на диаграмме образованы рядом данных.
  • Ось - линия, часто ограничивающая с одной стороны область построения и используемая как основа измерений для построения данных на диаграмме. В большинстве диаграмм точки данных отображаются по оси (y), которая обычно является вертикальной осью, а категории отображаются по оси (x), как правило, горизонтальной.
  • Деления и подписи делений - деления, или короткие вертикальные отрезки, пересекающиеся с осью, подобно делениям на линейке, позволяют отмерить одинаковые расстояния на линейке. Подписи делений обозначают меру длины, отложенную по оси, а также могут обозначать категории, значения или ряды значений диаграммы.
  • Линии сетки - линии, которые, будучи добавлены к диаграмме, облегчают просмотр и анализ данных. Линии сетки отображаются параллельно осям от делений диаграммы.
  • Таблица данных диаграммы - содержащая отображаемые на диаграмме данные таблица. Каждая строка таблицы данных содержит ряд данных. Таблица данных обычно связана с осью категорий и заменяет подписи оси категорий.
  • Линия тренда - графическое представление тренда или направления изменения данных в ряде данных. Линии тренда используются при прогнозировании, например при регрессионном анализе. Линии тренда могут быть построены на всех двумерных диаграммах без накопления (гистограмме, линейчатой диаграмме, графике, биржевой диаграмме, точечной диаграмме, а также пузырьковых диаграммах).
  • Планки погрешностей - графические линии, отображающие потенциальную ошибку (или степень недостоверности) каждой точки данных ряда данных. Планки погрешностей могут отображаться для всех плоских диаграмм (гистограммы, линейчатой диаграммы, точечной диаграммы и пузырьковых диаграмм). На точечных диаграммах могут также отображаться линии погрешности по оси X. Линии погрешности могут быть выделены и форматированы как группа.
  • Стенки и основание - плоскости, на фоне которых отображаются многие трехмерные диаграммы. Они придают трехмерным диаграммам впечатление объема и ограничивают область построения диаграммы. Обычно область построения ограничивают две стенки и одно основание.

Примечание. Имя элемента диаграммы будет выводиться в подсказке в случае, если установлен флажок Показывать имена (меню Сервис, команда Параметры, вкладка Диаграмма).

Для изменения или форматирования элементов диаграммы:

1. Выберите нужный элемент диаграммы. Ряды данных, подписи значений и легенды можно изменять поэлементно. Например, чтобы выбрать отдельный маркер данных в ряде данных, выберите нужный ряд данных, затем - нужный маркер данных.

2. В меню Формат или в контекстном меню выберите команду Формат соответствующего элемента.

3. Измените и установите соответствующие параметры.

Примечание. Текст элементов диаграммы, например подписи делений оси категорий, имена рядов данных, текст легенды и подписи данных, связан с ячейками рабочего листа, используемого для создания диаграммы. Чтобы сохранить связь этих элементов с ячейками листа, следует изменять текст на рабочем листе, а не на диаграмме.

Для изменения размеров и перемещения элементов можно использовать мышь.

Чтобы переместить элемент, выделите его и перетащите с помощью мыши в нужное положение.

Чтобы изменить размер элемента диаграммы, установите указатель на маркер изменения размера. Указатель примет форму двусторонней стрелки. Перетащите указатель для получения необходимого размера.

Чтобы отделить друг от друга все сектора в круговой диаграмме, выделите их и перетащите от центра диаграммы.


5.8. Управление списками

Список - это набор строк таблицы, содержащий связанные данные, например база данных счетов или набор адресов и телефонов клиентов. Список может использоваться как база данных, в которой строки выступают в качестве записей, а столбцы являются полями. Первая строка списка при этом содержит названия столбцов.

Рекомендации по созданию списка на листе книги

Чтобы облегчить обработку и анализ данных в списке необходимо ввести данные в список в соответствии с приведенными ниже рекомендациями.

Размер и расположение списка.

  • На листе не следует помещать более одного списка. Некоторые функции обработки списков, например, фильтры, не позволяют обрабатывать несколько списков одновременно.
  • Между списком и другими данными листа необходимо оставить, по меньшей мере, одну пустую строку и один пустой столбец.
  • В самом списке не должно быть пустых строк и столбцов. Это упрощает идентификацию и выделение списка.

Заголовки столбцов.

  • Заголовки столбцов должны находиться в первом столбце списка. Они используются Microsoft Excel при составлении отчетов, поиске и организации данных.
  • Шрифт, выравнивание, формат, шаблон, граница и формат прописных и строчных букв, присвоенные заголовкам столбцов списка, должны отличаться от формата, присвоенного строкам данных.
  • Для отделения заголовков от расположенных ниже данных следует использовать границы ячеек, а не пустые строки или прерывистые линии.

Содержание строк и столбцов:

  • Список должен быть организован так, чтобы во всех строках в одинаковых столбцах находились однотипные данные.
  • Перед данными в ячейке не следует вводить лишние пробелы, так как они влияют на сортировку.


Сортировка данных в списке

Строки в списке можно сортировать по значениям ячеек одного или нескольких столбцов. Строки, столбцы или отдельные ячейки в процессе сортировки переупорядочиваются в соответствии с заданным пользователем порядком сортировки. Списки можно сортировать в возрастающем (от 1 до 9, от А до Я) или убывающем (от 9 до 1, от Я до А) порядке.

Для сортировки строк данных в одном столбце:

1. Выберите любую ячейку в сортируемом столбце.

2. Нажмите кнопку По возрастанию [image] или По убыванию [image] на панели инструментов, в зависимости от направления сортировки.

Для сортировки строк по двум или более столбцам:

1. Выберите любую ячейку в сортируемом списке.

2. Выберите команду Сортировка в меню Данные.

3. Укажите столбцы сортировки в полях Сортировать по и Затем по.

4. Выберите другие параметры сортировки и нажмите кнопку OK.

Примечание. Если сортировка ведется по нескольким столбцам, то строки с одинаковыми значениями в столбце, указанном в поле Сортировать по, сортируются в порядке, определяемом столбцом, указанным в поле Затем по. Строки с одинаковыми значениями в первых двух столбцах сортируются по столбцу, указанному в поле В последнюю очередь.

Для сортировки месяцев, дней недели и списков, которые требуется отсортировать в порядке, отличном от алфавитного:

1. Укажите ячейку или диапазон ячеек в сортируемом списке.

2. Выберите команду Сортировка в меню Данные.

3. Нажмите кнопку Параметры.

4. В поле Порядок сортировки по первому ключу выберите требуемый порядок и нажмите кнопку OK.

5. Выберите другие необходимые параметры сортировки.

Примечание. Заданный на шаге 4 порядок сортировки применяется только для столбца, указанного в поле Сортировать п о. Чтобы использовать нестандартный порядок для сортировки нескольких столбцов, следует последовательно выполнить несколько отдельных сортировок для каждого из столбцов. Например, чтобы сортировать данные (сначала по А, а потом по В), сначала проведите сортировку по столбцу В, задав требуемый порядок сортировки в окне Параметры сортировк и. Затем проведите аналогичную сортировку списка по столбцу А.

Чтобы отсортировать список в порядке, отличном от алфавитного, например при сортировке организационных данных, используйте пользовательский порядок сортировки.

Разрешение вопросов, возникающих при сортировке

Если результаты сортировки оказались неожиданными, убедитесь в том, что:

  • Все ячейки в столбце, по которому ведется сортировка, содержат данные одного типа. Допускается ввод данных в виде чисел или текста, однако следует избегать ситуаций, когда в одной из ячеек содержится число, а в следующей ячейке столбца — текст. Если имеется необходимость сочетания чисел и текста в одном столбце, то отформатируйте числа как текст. Для этого выберите команду Ячейки в меню Формат, а затем установите текстовый числовой формат на вкладке Число. После изменения формата следует заново ввести значение в ячейке.
  • Перед данными отсутствуют заполняющие пробелы. Для выравнивания данных вместо заполняющих пробелов используйте кнопки выравнивания на панели инструментов Форматирование.
  • В диалоговом окне Языки и стандарты (панель управления Microsoft Windows) установлены правила сортировки, принятые в России. Порядок сортировки изменяется в зависимости от конкретной страны.
  • Заголовки столбцов введены только в одной строке. Если в списке необходимо использовать заголовки из нескольких строк, установите перенос слов в ячейке.


Фильтрация списка с использованием автофильтра

Порядок фильтрации списка:

1. Выберите любую ячейку в фильтруемом списке.

2. Выберите пункт Фильтр в меню Данные, а затем — команду Автофильтр.

3. Чтобы отфильтровать строки, содержащие определенное значение, нажмите кнопку со стрелкой в заголовке столбца, содержащего искомые данные.

4. Выберите значение в списке.

5. Повторите шаги 3 и 4, чтобы ввести дополнительные ограничения для значений в других столбцах.

Чтобы отфильтровать список по двум значениям в одном столбце или применить отличные от равенства операторы сравнения, нажмите кнопку со стрелкой, а затем выберите пункт Условие.

Чтобы отобразить строки, удовлетворяющие одному условию отбора, выберите необходимый оператор сравнения в первом поле под надписью Показать только те строки, значения которых и значение сравнения справа от него.

Чтобы отобразить строки, удовлетворяющие одновременно двум условиям отбора, введите оператор и значение сравнения в первой группе полей, нажмите кнопку И, а затем введите второй оператор и значение сравнения во второй группе полей.

Чтобы отобразить строки, удовлетворяющие одному из двух условий отбора, введите оператор и значение сравнения в первой группе полей, нажмите кнопку Или, а затем введите второй оператор и значение сравнения во второй группе полей.

Примечания.
1. Фильтр может быть использован только для одного списка на листе.
2. Если данные уже отфильтрованы по одному из столбцов, то при использовании фильтра для другого столбца будут предложены только те значения, которые видны в отфильтрованном списке.
3. С помощью автофильтра на столбец можно наложить до двух условий. Используйте расширенный фильтр, если требуется наложить три или более условий.

Чтобы удалить фильтр:

  • для одного столбца списка, нажмите на кнопку со стрелкой, а затем выберите из развернувшегося списка Все;
  • для всех столбцов списка, выберите пункт Фильтр в меню Данные, а затем — команду Показать все.

Чтобы удалить автофильтр из списка, выберите пункт Фильтр в меню Данные, а затем — команду Автофильтр.


Фильтрация списка с помощью расширенного фильтра

Чтобы отфильтровать список с помощью расширенного фильтра, столбцы списка должны иметь заголовки. На листе также должно быть не менее трех пустых строк выше списка. Эти строки будут использованы в качестве диапазона условий отбора. Порядок фильтрации списка:

1. Скопируйте из списка заголовки фильтруемых столбцов.

2. Вставьте скопированные заголовки столбцов в первой пустой строке диапазона условий отбора.

3. Введите в строки под заголовками условий требуемые критерии отбора. Убедитесь, что между значениями условий и списком находится как минимум одна пустая строка.

4. Укажите ячейку в списке.

5. Выберите пункт Фильтр в меню Данные, а затем — команду Расширенный фильтр.

6. Чтобы показать результат фильтрации, скрыв ненужные строки, установите переключатель Обработка в положение Фильтровать список на месте. Чтобы скопировать отфильтрованные строки в другую область листа, установите переключатель Обработка в положение Скопировать результаты в другое место, перейдите в поле Поместить результат в диапазон, а затем укажите верхнюю левую ячейку области вставки.

7. Введите в поле Диапазон критериев ссылку на диапазон условий отбора, включающий заголовки столбцов. Чтобы убрать диалоговое окно Расширенный фильтр на время выделения диапазона условий отбора, нажмите кнопку свертывания диалогового окна [image] .

Примеры условий отбора расширенного фильтра:

  • Чтобы задать для отдельного столбца три или более условий отбора, введите условия в ячейки, расположенные в смежных строках. Например, для следующего диапазона условий будут отобраны строки, содержащие «Белов», «Батурин» или «Сушкин» в столбце «Продавец».
  • Чтобы наложить условия отбора на несколько столбцов одновременно, введите условия в ячейки, расположенные в одной строке диапазона условий. Например, для следующего диапазона условий будут отобраны строки, содержащие «Продукты» в столбце «Товар», «Белов» - в столбце «Продавец» и имеющие сумму реализации - больше 1000.
  • Чтобы выбрать строки, удовлетворяющие одному из нескольких условий, наложенных на разные столбцы, введите условия в ячейки, расположенные в разных строках диапазона условий. Например, для следующего диапазона условий будут отобраны строки, содержащие либо «Продукты» в столбце «Товар», либо «Белов» - в столбце «Продавец», либо имеющие сумму реализации - больше 1000.
  • Чтобы наложить сложное условие отбора, введите его составные части в отдельные строки диапазона условий. Например, для следующего диапазона условий будут отобраны строки, содержащие «Белов» в столбце «Продавец» и имеющие сумму реализации больше 3000, или строки, содержащие «Батурин» в столбце «Продавец»и имеющие сумму реализации больше 1500.
  • В условии фильтрации можно использовать возвращаемое формулой значение. При задании формул в условиях не используйте в качестве заголовка условия заголовки столбцов, а оставьте его незаполненным. Формула должна ссылаться либо на заголовок столбца (например, «Продажи»), либо на соответствующее поле в первой записи. Например, для следующего диапазона условий будут отображены строки, в которых значение в столбце G превышает среднее значение в ячейках E5:E14. Заголовок условия не используется, и G5 ссылается на соответствующее поле (столбец G) первой записи (строка 5) списка.

Примечание. При использовании заголовка столбца в формуле условия вместо ссылки или имени диапазона в ячейке будет выведено значение ошибки #ИМЯ? или #ЗНАЧ!. Эту ошибку можно не исправлять, так как она не повлияет на результаты фильтрации.


5.9. Подведение итогов данных

Часто возникает необходимость сгруппировать данные и вычислить промежуточные и полные итоги.

Суммирование значений в списке

Microsoft Excel предоставляет несколько возможных способов суммирования и анализа значений в списке:

  • Для расчета общего итога по столбцу или по строке может быть использовано автоматическое суммирование, позволяющее быстро создать формулу суммирования значений столбца или строки.
  • Имеется возможность автоматического расчета промежуточных итогов по значениям списка. Например, для списка, содержащего суммы продаж для представителей отдела продаж по разным регионам, можно рассчитать промежуточные итоги для каждого региона или для каждого представителя отдела продаж.
  • Для расчета итогового значения по строкам списка в соответствии с заданным условием можно воспользоваться командой Автофильтр, чтобы вывести строки, удовлетворяющие этому условию, а затем рассчитать сумму только по этим строкам с помощью автоматического суммирования.


Подведение промежуточных итогов

В большом списке для автоматического структурирования данных листа могут быть использованы промежуточные итоги. Для подведения промежуточных итогов:

1. Отсортируйте список по столбцу, для которого необходимо подвести промежуточный итог. Например, чтобы просуммировать единицы продукции, проданные каждым лицом в списке продавцов, объемы продаж и количество проданного, отсортируйте список по столбцу продавцов.

2. Укажите ячейку в этом списке.

3. Выберите команду Итоги в меню Данные.

4. Выберите столбец, содержащий группы, по которым необходимо подвести итоги, из списка При каждом изменении в. Это должен быть тот столбец, по которому проводилась сортировка списка на шаге 1.

5. Выберите функцию, необходимую для подведения итогов, из списка Операция

6. Выберите столбцы, содержащие значения, по которым необходимо подвести итоги, в списке Добавить итоги по.

При выборе элементов, для которых создаются промежуточные итоги, лист представляется в виде структуры, что позволяет выбрать уровень детализации отображаемых данных. Можно скрывать или показывать столько деталей, сколько нужно.

Чтобы просмотреть:

  • детальные данные внутри группы, нажмите кнопку [image] ;
  • определенный уровень структуры, нажмите символ уровня [image] ;
  • все детальные данные в структуре, нажмите символ самого нижнего. Например, если существует три уровня, то нажмите кнопку [image] .

Чтобы скрыть:

  • детальные данные внутри группы, нажмите кнопку [image] ;
  • определенный уровень структуры, нажмите символ предыдущего уровня [image] ;
  • все детальные данные в структуре, нажмите символ первого уровня [image] .

Примечание. Если на листе отсутствуют символы структуры, то установите флажок Символы структуры вкладки Вид диалогового окна Параметры (меню Сервис).


Подведение «вложенных» или многоуровневых итогов

Имеется возможность «вложения» или вставки итогов для групп, находящихся внутри больших групп, что полезно при подведении итогов в группах значений. Для подведения вложенных итогов:

1. Отсортируйте список по двум или более столбцам, для которых необходимо подвести итог. Например, чтобы просуммировать проданные единицы продукции по регионам и по продавцам внутри каждого региона, в первую очередь, следует отсортировать список по столбцу регионов, а затем - по столбцу продавцов. При подведении промежуточных итогов значения итогов по продавцам вкладываются в итоги по регионам.

2. Вставьте автоматические итоги для первого столбца, содержащего группы суммируемых данных. Этот столбец при сортировке списка должен быть указан в поле Сортировать по. (В примере, приведенном на шаге 1, первым столбцом должен быть столбец регионов.)

3. После создания автоматических итогов в первом столбце повторите процедуру для следующего столбца.

4. Выделите ячейку в списке.

5. Выберите команду Итоги в меню Данные.

6. Выберите следующий столбец, по которому необходимо подвести итоги, из списка При каждом изменении в.

7. Снимите флажок Заменить текущие итоги, а затем нажмите кнопку OK.

8. Повторите шаги с 4 по 7 для каждого столбца, по которому необходимо подвести итоги.

9.4. Удаление промежуточных итогов

При удалении промежуточных итогов из списка удаляется структура и все разрывы страниц, которые были вставлены в список при подведении итогов. Исходные данные не будут изменены. Для удаления промежуточных итогов:

1. Выделите ячейку в списке, содержащую промежуточный итог.

2. Выберите команду Итоги в меню Данные и нажмите кнопку Убрать все.


5.10. Сводные таблицы

При работе со списком, содержащим полные данные, может возникнуть необходимость получить глобальную оценку, например проанализировать суммарные объемы продаж или получить ответ на вопрос, насколько успешно каждый товар продается определенными сотрудниками. Такую группировку данных можно осуществить с помощью динамических сводных таблиц.

Сводная таблица — это таблица, которая используется для быстрого подведения итогов или объединения больших объемов данных. Меняя местами строки и столбцы, можно создать новые итоги исходных данных. Отображая разные страницы, можно осуществить фильтрацию данных, а также отобразить детальные данные области.

Части сводной таблицы

Сводная таблица состоит из следующих частей:

  • Поле страницы — это поле исходного списка или таблицы, помещенное в область страничной ориентации сводной таблицы. При указании другого элемента поля страницы происходит пересчет сводной таблицы для отображения итогов, связанных с этим элементом.
  • Элементы поля страницы объединяют записи или значения поля или столбца исходного списка.
  • Поле данных — это поле исходного списка или таблицы, содержащее данные. В поле данных обычно подводятся итоги группы чисел (например, статистика или количество сбыта), хотя текущие данные могут быть и текстовыми. По умолчанию в сводной таблице подведение итогов текстовых данных производится с помощью итоговой функции Кол-во значений, а числовых данных — с помощью итоговой функции Сумма.
  • Поля строки — это поля исходного списка или таблицы, помещенные в область строчной ориентации сводной таблицы. Внутренние поля строки в точности соответствуют области данных. Внешние поля строки группируют внутренние.
  • Поле столбца — это поле исходного списка или таблицы, помещенное в область столбцов. Внутренние поля столбцов содержат элементы, соответствующие области данных. Внешние поля столбцов располагаются выше внутренних (в примере показано только одно поле столбца).
  • Элементы поля — это подкатегории поля сводной таблицы. Элементы поля представляют записи в поле или столбце исходных данных. Элементы поля появляются в виде заголовков строк или столбцов, а также в раскрывающемся списке для полей страниц.
  • Областью данных называется часть сводной таблицы, содержащая итоговые данные. В ячейках области данных отображаются итоги для элементов полей строки или столбца. Значения в каждой ячейке области данных соответствуют исходным данным.


Создание сводной таблицы

Рекомендации по организации исходных данных, находящихся в списке, для создания сводной таблицы:

  • В сводную таблицу включаются все данные списка. Фильтры списка, созданные командой Фильтр в меню Данные, при создании сводной таблицы игнорируются.
  • Чтобы создать сводную таблицу из данных, имеющих фильтры списка, воспользуйтесь командой Расширенный фильтр для перемещения диапазона данных в другое место листа. Эти данные можно использовать для создания сводной таблицы.
  • В сводной таблице автоматически создаются общие и промежуточные итоги. Если исходный список содержит общие и промежуточные итоги, их, возможно, потребуется удалить перед созданием сводной таблицы.
  • Исходный список должен иметь заголовки столбцов, так как содержимое ячеек первой строки списка будет использоваться в качестве имен полей.

Для создания сводной таблицы:

1. Выделите любую ячейку списка.

2. Выберите команду Сводная таблица в меню Данные.

3. Следуйте инструкциям мастера сводных таблиц.

Изменение структуры сводной таблицы

Представление сводной таблицы можно изменить непосредственно на листе, перетаскивая названия кнопок полей или элементов полей:

  • Чтобы переместить поле и все связанные с ним элементы, перетащите кнопку поля на новое место.
  • Чтобы поменять порядок расположения элементов в поле, выделите название элемента, а затем установите указатель на границу ячейки. Когда указатель примет вид стрелки, перетащите ячейку поля на новое место.
  • Чтобы создать новое поле страницы, перетащите кнопку поля в область поля страницы.
  • Чтобы удалить поле страницы, строки или столбца, перетащите кнопку поля за пределы сводной таблицы. Удаление поля приведет к скрытию в сводной таблице всех зависимых от него величин, но не повлияет на исходные данные.

Если необходимо использовать все предусмотренные средства структурирования сводной таблицы или если в текущую таблицу не были ранее включены все поля исходных данных, следует воспользоваться мастером сводных таблиц:

1. Выделите ячейку сводной таблицы.

2. Нажмите кнопку Мастер сводных таблиц [image] на панели инструментов Сводные таблицы.

3. В диалоговом окне Мастер сводных таблиц - шаг 3 из 4 перетащите кнопки полей в области с ориентацией по строкам, столбцам или по страницам.


Группировка данных в сводной таблице

В сводной таблице можно группировать даты, времена, числа и выделенные элементы. Например, можно объединить месяцы, чтобы подвести итоги за квартал.

Для группировки дат или времен в сводной таблице:

1. Выделите дату или время в поле, в котором следует сгруппировать элементы.

2. Нажмите кнопку Сгруппировать [image] на панели инструментов Сводные таблицы.

3. В поле Начиная с введите начальное значение, а в поле по - конечное значение, если это необходимо.

4. В списке с шагом выберите один или несколько временных интервалов для задания шага, с которым будут создаваться группы. Если в списке с шагом выделен единственный интервал Дни, введите шаг группировки в поле Количество дней.

Чтобы разгруппировать элементы, выделите группу, а затем нажмите кнопку Разгруппировать [image] на панели инструментов Сводные таблицы. При выполнении команды разгруппировки чисел, дат или времен разгруппировывается вся группа; разгруппировать отдельный элемент группы невозможно.

Обработка данных сводной таблицы

Итоговые значения текущих данных отображаются в области данных. Например, сводная таблица может содержать кнопку поля столбца, имеющую название «Месяц» и отображающую элементы поля в виде столбцов «Март», «Апрель» и «Май»; кнопку поля строки, имеющую название «Регион» и отображающую элементы поля в виде строк «Северный», «Южный», «Восточный» и «Западный»; а также поле данных, имеющее название «Общий доход» и отображающее итоговые данные. Значение, являющееся пересечением столбца «Май» и строки «Северный», будет итоговым доходом по элементам полей «Май» и «Северный».

Для подведения итогов значений области данных в сводной таблице используется итоговая функция. Для обработки числовых данных применяется итоговая функция Сумма, а для текстовых данных — итоговая функция Кол-во значений. Кроме того, для анализа данных можно воспользоваться и другими итоговыми функциями (например, Среднее, Максимум, Минимум или Несмещенное отклонение).

Для расчета значений относительно других элементов поля или ячеек области данных можно использовать дополнительные вычисления. Например, можно отобразить значения в процентах от итога строки сводной таблицы.

Чтобы воспользоваться формулой, использующей данные сводной таблицы или других листов, необходимо создать вычисляемое поле или вычисляемый элемент поля. Для создания вычисляемого поля в сводной таблице:

1. Выделите ячейку в сводной таблице.

2. Выберите команду Формулы (меню Сводная таблица в панели инструментов Сводные таблицы), а затем — команду Вычисляемое поле.

3. Введите имя вычисляемого поля в поле Имя.

4. Введите формулу в поле Формула. При создании формулы для вычисляемого поля и вычисляемого элемента можно применять операторы и выражения так же, как в формуле листа. В формуле можно использовать константы и ссылки на данные сводной таблицы, но нельзя использовать ссылки на ячейки или имена ячеек. Чтобы использовать в формуле данные поля, выберите поле в списке Поля, а затем нажмите кнопку Добавить поле.

5. Нажмите кнопку Добавить, а затем — кнопку OK.

6. Расположите вычисляемое поле в сводной таблице.

Для использования данных сводной таблицы в формуле, размещенной вне сводной таблицы, необходимо воспользоваться функцией ПОЛУЧИТЬ.ДАННЫЕ.СВОДНОЙ.ТАБЛИЦЫ.


5.11. Печать

Задание на листе области печати

Задание на листе области печати осуществляется в режиме разметки страницы (меню Вид). В этом режиме можно увидеть на листе расположение разрывов страниц, а также печатаемую и не печатаемую части листа. Печатаемые ячейки выделены белым цветом, и те части листа, которые не будут выведены на печать, изображаются серым цветом. Перемещая разрывы страниц, можно изменить расположение данных на странице.

Для задания на листе области печати выберите нужную область, щелкните правой кнопкой мыши одну из выделенных ячеек и в контекстном меню выберите Задать.

Для добавления ячеек в область печати выделите нужные ячейки, щелкните правой кнопкой мыши и в контекстном меню выберите Добавить к области печати.

Для исключения ячеек из области печати выделите нужные ячейки, щелкните правой кнопкой мыши и в контекстном меню выберите Исключить из области печати.


Изменение макета выводимого на печать листа Excel

Управление внешним видом или макетом выводимого на печать листа выполняется с помощью задания параметров в диалоговом окне Параметры страницы (меню Файл):

  • Вкладка Страница.

    - Группа Ориентация. Выберите Книжная или Альбомная.

    - Группа Масштаб. Для уменьшения или увеличения листа до размеров страницы в поле Установить введите коэффициент увеличения или уменьшения листа в процентах. Для печати листа на заданном числе страниц выберите Разместить не более чем на и введите число страниц, на которых должен уместиться распечатанный документ. При печати заданное число страниц не будет превышено. Если документ умещается на меньшем количестве страниц, он не будет увеличен, чтобы заполнить оставшиеся.

    - В поле Размер бумаги выберите необходимый размер бумаги.

    - В поле Номер первой страницы введите номер, который появится на первой странице листа. Значение Авто, введенное в это поле позволяет Microsoft Excel автоматически выполнить нумерацию страниц листа.

  • Вкладка Поля.

- Введите необходимые значения в поля Верхнее, Нижнее, Левое и Правое. Эти значения должны быть больше минимальных значений полей отступа, поддерживаемых принтером.

- Группа Центрировать на странице. Для горизонтального центрирования данных листа на странице между левым и правым полями в установите флажок Горизонтальное. Для вертикального центрирования данных листа на странице между верхним и нижним полями установите флажок Вертикальное.

  • Вкладка Колонтитул.

- Для задания встроенного верхнего или нижнего колонтитула в поле Верхний колонтитул или Нижний колонтитул выберите нужный верхний или нижний колонтитул

  • Вкладка Лист.

- Для печати подписей столбцов на каждой странице, в поле Сквозные строки введите строки, содержащие подписи столбцов. Для печати подписей строк на каждой странице, в поле Сквозные столбцы введите столбцы, содержащие подписи строк.

- Группа Печать. Для печати заголовков столбцов и строк установите флажок Заголовки строк и столбцов. Для печати сетки установите флажок Сетка. Чтобы распечатать примечания в конце листа, выберите флажок В конце листа в поле Примечания. Чтобы распечатать примечания в том виде, в каком они отображаются на листе Excel, выберите флажок Как на листе в поле Примечания.

Предварительный просмотр

Чтобы просмотреть каждую страницу документа в том виде, в каком она будет напечатана, выберите команду Предварительный просмотр. В режиме предварительного просмотра можно увидеть колонтитулы и заголовки печати, то есть текст, изображаемый на каждой печатаемой странице. Размер полей и ширину столбцов листа можно изменить, перетаскивая маркеры изменения размера.

Для изменения параметров страницы нажмите кнопку Страница.

Печать листа, выделенного диапазона или книги целиком

Для печати листа выберите пункт Печать в меню Файл. Если на листе задана область печати, будет распечатана только эта область. Если выделен диапазон ячеек и установлен флажок Выделенный диапазон, будут распечатаны ячейки из этого диапазона, а определенные на листе области печати будут игнорироваться. Выберите необходимый параметр в группе Вывести на печать.


5.15. Глоссарий

Абсолютная ссылка – ссылка на ячейку, не изменяющаяся при копировании формулы, например $A$1.

Адрес ячейки (ссылка) – состоит из номра строки и названия столбца, на пересечении которых находится ячейка.

Автофильтр – возможность наложить на столбец до двух условий отбора.

Активная ячейка – та, в которой находится курсор, и только в нее можно вводить данные.

Диаграмма – графическое представление данных.

Диапазон – прямоугольная область ячеек.

Книга – файл, объект обработки Microsoft Excel с произвольным именем и расширением xls. файл, используемый для обработки и хранения данных в Excel. В каждом файле размещается от 1 до 255 электронных таблиц, каждая из которых называется рабочим листом. Каждый лист состоит из 65 536 строк и 256 столбцов.

Маркер данных – столбик, закрашенная область, точка, сегмент или другой геометрический объект диаграммы, обозначающий точку данных или значение ячейки.

Легенда – подпись, определяющая закраску или цвета точек данных или категорий диаграммы.

Линии сетки – линии, которые, будучи добавлены к диаграмме, облегчают просмотр и анализ данных.

Линия тренда – графическое представление тренда или направления изменения данных в ряде данных.

Название диаграммы – описательный текст, автоматически связанный с осью или расположенный по центру диаграммы.

Область диаграммы – вся диаграмма, вместе со всеми ее элементами.

Область построения – в двумерной диаграмме областью построения называется область, ограниченная осями и содержащая все ряды диаграммы. В трехмерной диаграмме это область, ограниченная осями и включающая ряды данных, названия категорий, подписи делений и названия осей.

Ось – линия, часто ограничивающая с одной стороны область построения и используемая как основа измерений для построения данных на диаграмме.

Относительная ссылка – ссылка на ячейку, автоматически изменяющаяся при копировании формулы, например A1.

Подпись значения – подпись, предоставляющая дополнительные сведения о точке данных, отображающей какое-либо значение ячейки.

Расширенный фильтр – возможность отфильтровать данные по трем или большем количестве условий.

Ряд данных – группа связанных точек данных диаграммы, отображающая значение строк или столбцов листа.

Сводная таблица — это таблица, которая используется для быстрого подведения итогов или объединения больших объемов данных.

Смешанная ссылка – ссылка лишь частично абсолютная, например $A1.

Список – это набор строк таблицы, содержащий связанные данные, Список может использоваться как база данных, в которой строки выступают в качестве записей, а столбцы являются полями. Первая строка списка при этом содержит названия столбцов.

Стенки и основание – плоскости, на фоне которых отображаются многие трехмерные диаграммы.

Столбец – группа ячеек, расположенных в одном вертикальном ряду таблицы, нумеруется буквами латинского алфавита.

Строка – группа ячеек, расположенных на одном горизонтальном уровне, нумеруется целым числом,

Фильтрация – способ отображения строк списка, удовлетворяющих условию отбора.

Формула – комбинация адресов ячеек, чисел, знаков операций, стандартных функций. Формула всегда начинается знаком "=".

Электронная таблица – комплексное средство для хранения различных типов данных и их обработки.

Ячейка – клетка на пересечении строки и столбца таблицы Microsoft Excel.


5.16. Библиографический список

1. Microsoft Excel 97. Руководство пользователя.

2. Персен Р. Microsoft Excel 97 в подлиннике: В 2 т. - СПб: BHV-Санкт-Петербург, 1997.- 640 с.

3. Информационные технологии бухгалтерского учета / Под ред. О.П.Ильина. – СПб.:Питер, 2001. – 688 с.

4. Смышляев А.Г., Солопов Ю.И., Ушакова Н.Н. Информатика. Часть I. Методические указания. – Белгород: Изд-во БИИММАП, 2001. – 83 с.

5. Волков Ю.И. Microsoft Office 2000 Professional. Шесть книг в одной. – М.: Лаборатория базовых знаний, 2001. – 944 с.


5.14. Контрольные вопросы

  1. Как называется документ в Excel и из чего он состоит?
  2. Как добавить новый лист в книгу? Как переименовать лист?
  3. Что такое ячейка?
  4. Из чего состоит адрес ячейки?
  5. Что такое активная ячейка?
  6. Что такое абсолютная и относительная адресация?
  7. С какого символа начинают ввод формулы в ячейку?
  8. Что такое Мастер функций, как он работает?
  9. Как скопировать или переместить ячейку?
  10. Как отредактировать содержимое ячейки?
  11. Что такое автозаполнение и как оно выполняется?
  12. Как удалить (вставить) строку (столбец)?
  13. Что такое автосуммирование?
  14. Как выполнить сортировку по нескольким столбцам?
  15. Что такое Мастер диаграмм? Как вставить диаграмму в документ Excel?
  16. Как изменить параметры диаграммы?
  17. Какие Вы знаете виды диаграмм?
  18. Что такое фильтр? Какие виды фильтров Вы знаете?
  19. Какие правила выполнения Расширенного фильтра?
  20. Что такое сводная таблица?
  21. С помощью какого пункта меню формируется сводная таблица?
  22. Какие надо соблюдать правила при создании сводной таблицы?
  23. Каким образом можно изменять состав сводной таблицы?


Глоссарий электронного учебника по информатике

@ – служебный разделитель.

0,28 – имеется в виду размер зерна монитора 0,28 мм (см. dot). Типичен для мониторов среднего качества. Более качественные мониторы имеют размер зерна 0,24-0,26 мм.

100Вазе-Т – локальная сеть типа Ethernet на витой паре с пропускной способностью 100 Мбит/с.

101-key keyboard – 101-клавишная клавиатура.

10Base-5 – локальная сеть типа Ethernet (10 Мбит/с) на толстом кабеле. Часто это сокращение означает, что компьютер или иное устройство можно подсоединить к данной локальной сети.

24-pin – 24-точечный матричный принтер. Такие принтеры дороже, но обеспечивают более качественную печать по сравнению с 9-точечными матричными принтерами и выполняют ее быстрее.

6х86 – марка Intel-совместимых микропроцессоров, выпускаемых различными фирмами. По скорости эти микропроцессоры соперничают с Pentium.

9-pin – 9-точечный матричный принтер (наиболее дешевый тип матричных принтеров).

AТХ – новый тип материнской (системной) платы компьютера. Требует специального корпуса системного блока;

baby AT case – настольный (горизонтальный) тип корпуса системного блока компьютера уменьшенного размера по горизонтали.

BAT-файл (Batch-файл) – специальный текстовый файл, содержащий команду или группу команд MS-DOS (или вызовов программ), которые выполняются последовательно или в более сложном порядке.

BIOS – программы операционной системы, хранящиеся в постоянной памяти компьютера (ROM). В настоящее время чаще всего используются BIOS фирм AMI, AWARD, PHOENIX и т.д.

cache (кэш) – сверхбыстрый буфер для хранения данных, располагающийся «между» процессором и оперативной памятью. Наличие кэша может увеличить производительность компьютера на 10-15%. Размер кэша определяет его эффективность, типичный размер – от 32 до 256 Кбайт.

CD-Recorder – устройство для записи на диски CD-R.

CD-ROM – дисковод для воспроизведения информации, записанной на компакт-дисках.

CD-ROM – компакт-диск, иногда – дисковод для воспроизведения информации, записанной на компакт-дисках.

CGI (Common Gateway Interface) – это протокол для выполнения сценариев на серверах; в свою очередь серверы осуществляют конечную обработку, например связь с базой данных по запросу со страницы Web. Все коммерческие серверы Web поддерживают сценарии CGI.

Cps (character per second) – число символов в секунду (скорость печати у матричных и струйных принтеров, скорость передачи данных модемом и т.д.).

DIMM – тип микросхем памяти (dual in-line memory module). Наиболее быстродействующие микросхемы памяти типа SDRAM для компьютеров. Ввыполняются в формате DIMM со 168 контактами.

DNS (Domain Name System) – служба имен доменов, которая транслирует имена компьютеров в соответствующие адреса IP и обратно.

dot – точка. Применительно к дисплею обычно указывается ее размер.

dpi – число точек на дюйм (обычно – разрешающая способность принтера или иного устройства).

DRAM – динамическая память, наиболее часто применяемый тип устройства микросхем памяти.

EDO – (extended data output) – тип микросхем динамической памяти, обеспечивающий несколько более быстрый обмен с оперативной памятью, чем при использовании обычных микросхем (FPM DRAM).

EMB (расширенные блоки памяти) – блоки памяти, располагающиеся выше границы HMA.

EMS – дополнительная (expanded) оперативная память – вид оперативной памяти (свыше 640 кбайт) в компьютерах типа IBM PC. В отличие от расширенной памяти дополнительная память с помощью специальной аппаратуры и программного обеспечения отображается в диапазон адресов, лежащий ниже 1 Мбайт. Такой способ пригоден для компьютеров, использующих процессор Intel 8086, не обладающий возможностью адресации расширенной памяти.

FAT – таблица размещения файлов.

fax-modem (факс-модем) – устройство, сочетающее возможности телефакса и модема.

FD (Floppy Disk) – гибкий диск (дискета).

FDD (Floppy Disk Drive) – дисковод для гибких дисков (дискет). Обычно до или после этого сокращения указывается максимальная емкость дискет: 1,2 Мбайт или 360 Кбайт для дисководов для пятидюймовых дискет, 1,44 Мбайт или 720 Кбайт для дисководов для трехдюймовых дискет.

Flash – флэш-память, вид оперативной памяти, хранящий информацию даже при отключении электропитания. Дорог, а потому используется как ROM, но с возможностью модернизации (например, для хранения BIOS, микропрограмм модема или принтера и т.д.).

FTP – протокол передачи файлов, является средством доступа к файлам, хранящимся на удаленных компьютерных системах.

FTP-клиенты – программы для обмена файлами: CuteFTP, WS_FTP.

HDD (Hard Disk Drive) – жесткий диск (винчестер).

HMA-память (старшая область памяти) – это первые 64 кбайт расширенной памяти, начинающиеся с адреса FFFFh:0010h. Эта область может адресоваться процессором в реальном режиме и поэтому может быть использована обычными программами, предназначенными для работы в MS-DOS.

HTML-редакторы – программы для подготовки Web-документов: FrontPage 2000, DreamWeaver.

IDE – тип интерфейса устройств компьютера (жестких дисков и др.).

InkJet printer– струйный принтер, т.е. принтер, создающий изображение путем напыления на бумагу капель специальных чернил.

Intranet– технология ориентированая не на данные, а на информацию в ее окончательно готовом к потреблению виде. Технология появилась в результате перенесения идей сети Internet в среду корпоративных систем.

ISA – тип шины передачи данных внутри компьютера, используемый в большинстве персональных компьютеров для взаимодействия с низкоскоростными устройствами.

Java – язык программирования компании JavaSoft синтаксически подобен C++, но он предусматривает такие ограничения, как запрет на использование указателей.

laptop (лэптоп) – портативный компьютер «наколенного» формата. Обычно такой компьютер может переноситься, как небольшой чемоданчик. Типичный вес – от 4 до 10 кг.

laptop (лэптоп) – портативный компьютер «наколенного» формата. Обычно такой компьютер может переноситься, как небольшой чемоданчик. Типичная масса – от 4 до 10 кг.

laser printer – лазерный принтер, т.е. принтер, в котором формирование изображения выполняется с помощью лазера.

Login– регистрационное имя почтового ящика.

LPT – обозначение параллельного порта, Обычно имеете? в виду, что устройство подключается к параллельному порту.'''

matrix printer – матричный принтер – самый распространенный и дешевый тип принтеров. Он обеспечивает средние качество и скорость печати.

MHz (МГц) – мегагерц (обычно обозначает тактовую частоту микропроцессора компьютера).

Microsoft Equation 3.0– объект Word для ввода математических формул.

mini-tower – мини-башня, «башенный» (вертикальный) тип корпуса системного блока компьютера уменьшенной высоты.

modem (модем) – устройство для передачи данных между компьютерами через телефонную сеть. Обычно для модема указывается его максимальная скорость работы (в бодах, т.е. битах в секунду), а также поддерживаемые им стандарты передачи данных.

motherboard (материнская плата, системная плата) – главная плата компьютера, содержащая основной микропроцессор, сопроцессор (если он есть), память и т.д.

MPEG – тип сжатия видеоданных. Используется в видеодисках. MPEG-плейер – устройство или программа, позволяющая воспроизводить видеофильмы, записанные в формате MPEG. Чаще всего имеется в виду тип сжатия MPEG-1, обеспечивающий вывод изображения с разрешением 320х240 точек с частотой 30 кадров в секунду (качество, соответствующее бытовому видеомагнитофону VHS).

MPR-II – стандарт на излучение мониторов, обеспечивающий их безвредность для здоровья пользователей. Желательно приобретать только те мониторы, которые удовлетворяют стандарту MPR-II (а если они удовлетворяют стандартам ТСО-92 и/или ТСО-95 – еще лучше).

Norton Commander – неграфическая файловая оболочка.

notebook (ноутбук) – портативный компьютер «книжного» формата, обычный размер – 30х21х3-4 см, вес – 2-4 кг.

notebook (ноутбук) – портативный компьютер «книжного» формата, обычный размер – 30х21х3-4 см, масса – 2-4 кг.

OEM – изготовитель оборудования. Обычно имеется в виду комплектация чего-либо для производителей оборудования (без документации, красивой коробки и т.д.).

OLE (Object Linking and Embedding) – технология связывания и внедрения объектов; стандарт компании Microsoft для создания динамических, автоматически обновляемых связей между документами или внедрения объекта, созданного в одном из приложений, в документ, с которым работает другое приложение.

PC – персональный компьютер (personal computer).

Plug and Play – подключай и работай, тип устройств с облегченной (автоматической или полуавтоматической) настройкой прим подключении к компьютеру.

Plug-and-play – принцип динамического распределения ресурсов операционной системой.

POST – программа начального тестирования (Power-On Self Test) - это программа, прошитая в ПЗУ BIOS, которая выполняется при включении ПЭВМ.

ppm (pages per minute) – число страниц в минуту (скорость печати).

PS/2 – серия персональных компьютеров, выпускаемых фирмой IBM.

RAM (ОЗУ) – оперативная память (Random Access Memory). Размер оперативной памяти измеряется в мегабайтах (М, Мб, Mb) или килобайтах (К, Кб, Kb). Типичный размер – от 1 Мбайта до 64 Мбайт.

ROM (Read Only Memory, ПЗУ) – память в компьютере, доступная только для чтения, содержит программы тестирования компьютера, часть операционной системы (BIOS) и т.д.

scanner (сканер) – устройство для ввода изображений в компьютер.

SCSI – стандарт интерфейса устройств SCSI, обеспечивающий высокую скорость обмена данных. Используется в основном в компьютерах, в которых требуется обеспечить большую скорость обработки данных, серверах локальных сетей и т.д.

SDRAM (Synchronous DRAM) – синхронизируемая динамическая оперативная память, быстродействующий вариант оперативной памяти, применяется в основном в дорогих высокопроизводительных компьютерах.

serial port – последовательный порт (используется для подключения мыши, внешних модемов и т.д.).

SIMM – наиболее часто используемый тип микросхем памяти (single in-line memory module) с расположением контактов на одной стороне микросхемы. В основном используются 72-контактные SIMM.

streamer (стример) – устройство для записи данных на специальные кассеты с магнитной лентой, обычно используемое для создания резервных копий данных. Для стримеров часто указывается максимальный объем данных на кассете (60 Мбайт, 8 Гбайт и т.д.).

SVGA (SuperVGA) – адаптеры дисплеев, обеспечивающие как возможности адаптера VGA, так и работу в графическом режиме с разрешением 800х600 точек, а часто и в режимах с большим разрешением. Часто SVGA обозначаются также и мониторы (дисплеи), которые могут работать с адаптерами SVGA и обеспечивать разрешающую способность 800х600 точек или более.

Telnet – сервис, обеспечивающий удаленное подключение к компьютеру.

TFT – тип дисплеев на цветной активной матрице (обычно используются в портативных компьютерах). Обеспечивают яркие и насыщенные цвета, но весьма дороги.

trackball – манипулятор в виде шарика, используется для замены мыши, чаще всего в портативных компьютерах.

TrueType –формат масштабируемых шрифтов.

UMB-память (верхние блоки памяти) – блоки памяти на машинах, использующих процессор 8086. Эти блоки памяти располагаются между границей 640 кбайт и 1 Мбайт.

UPS – устройство бесперебойного электропитания.

URL – Uniform Resource Locator(универсальный указатель ресурса).

Usenet – это международная некоммерческая сетевая связь для обмена новостями, объединяющая тысячи узлов.

V34, V34bis – стандарты высокоскоростной (28800 и 33600 бит/с соответственно) передачи данных через модем по обычным (коммутируемым) телефонным линиям.

VESA – название ассоциации инженеров по видеоэлектронике.

Windows – графическая операционная система для компьютеров платформы IBM.

WordArt – объект Word для создания фигурного текста.

WWW – это система клиент/сервер, которая поддерживает эти гипертекстовые связи.

XMS – спецификация, содержащая описание программного интерфейса драйвера HIMEM.SYS и рекомендации по использованию области памяти HMA.

Абзац – последовательность строк, сгруппированных для смыслового выделения содержания.

Абсолютная ссылка – ссылка на ячейку, не изменяющаяся при копировании формулы, например $A$1.

Автофильтр – возможность наложить на столбец до двух условий отбора.

Адрес IP (Internet Protocol) – это 32-битный компьютерный адрес, с которым непосредственно работают компьютеры Internet.

Адрес ячейки (ссылка) – состоит из номра строки и названия столбца, на пересечении которых находится ячейка.

Активная ячейка – та, в которой находится курсор, и только в нее можно вводить данные.

Алгоритм – формализованная последовательность действий, необходимая для решения конкретной задачи.

Антивирусные программы – специальные программные средства защиты (как зарубежного, так и отечественного производства), которые своевременно обнаруживают, распознают вирус в информационных ресурсах, а также “лечат” их.

Архиватор –специальная компьютерная программа, позволяющая архивировать файлы сжатием хранимой в них информации.

Архитектура сети ЭВМ определяет принципы построения и функционирования аппаратного и программного обеспечения элементов сети.

Архитектура ЭВМ – совокупность общих принципов организации аппаратно-программных средств и их характеристик, определяющая функциональные возможности ЭВМ при решении соответствующих классов задач.

Атрибут (attribute) – минимальный элемент данных, определяющий некоторое свойство объекта данных, например адрес клиента или зарплата сотрудника. Атрибут обычно хранится в виде поля (столбца) таблицы.

Атрибуты файла – дополнительные параметры, определяющие свойства файла.

Базовое программное обеспечение – самый низкий уровень программного обеспечения, отвечающий за взаимодействие с базовыми аппаратными средствами.

Байт – восемь взаимосвязанных битов, наименьшая единица измерения информации.

Бит – наименьшая единица измерения объема информации.

Блок-схема – способ графического представления алгоритма.

Браузер – программное средство, предназначенное для просмотра электронных документов, выполненных в формате HTML.

Буквица – это увеличенная в размере первая буква первой строки текста, использующаяся как для оформления текста, так и для подчеркивания начала текста или раздела.

Буфер ввода-вывода - это область в памяти, которая выделяется для каждого файла.

Буфер обмена – область памяти для временного хранения объектов при выполнении операций копирования или перемещения.

Венгерская нотация - это соглашение о наименованиях переменных и функций.

Вертикальная полоса прокрутки – элемент окна Word, предназначенный для перемещения по документу вверх или вниз.

Ветвление - это конструкция, состоящая из развилки, двух операций и слияния. Одна из операций может отсутствовать.

Винчестер (HDD ) – несъемный жесткий магнитный диск (пакет дисков).

Вкладка – элемент управления диалогового окна или окна приложения, представляющий отдельную страницу. Содержит другие элементы управления.

Внешние команды MS-DOS – отдельные программы, которые для выполнения загружаются командным процессором MS-DOS в ОЗУ.

Внешняя память (ВЗУ) предназначена для размещения больших объемов информации и обмена ею с оперативной памятью.

Внутренние команды MS-DOS – команды, которые выполняются непосредственно командным процессором MS-DOS.

Внутренняя, или основная память — это запоминающее устройство, напрямую связанное с процессором и предназначенное для хранения выполняемых программ и данных, непосредственно участвующих в вычислениях.

Возрастание (ascending) – направление упорядочивания данных в базе от наименьшего к наибольшему значению в алфавитно-цифровом порядке в соответствии с кодами (ASCII, EBCDIC, Unicode и т.п.) символов, принятыми в системе.

Выражение в алгоритмическом языке состоит из элементарных конструкций и символов, оно задает правило вычисления некоторого значения.

Выражение-константа представляет собой выражение, которое может вычисляться компилятором без необходимости выполнения программы.

Вычислительная техника – совокупность устройств, предназначенных для автоматической или автоматизированной обработки данных.

Гбайт – 1024 Мбайт.

Гиперссылка – выделенный объект, связанный с другим файлом и реагирующий на щелчок мыши.

Гипертекст – текст, содержащий связи с другими текстами, графической, видео- или звуковой информацией.

Главное ( стартовое) меню – один из основных системных элементов управления Рабочего стола операционных систем Windows, предназначенный для быстрого доступа к приложениям и служебным функциям операционной системы. Вызывается щелчком на кнопке Пуск.

Глобальные переменные - это переменные, описанные вне процедуры и функции и располагающиеся в сегменте данных.

Глобальные сети – это распределённые сети всемирного масштаба. Самой известной и доступной глобальной сетью является Интернет (Internet).

Горизонтальная линейка – элемент окна Word, используемый для установки отступов и табуляции.

Горизонтальная полосы прокрутки – элемент окна Word, предназначенный для перемещения по документу влево или вправо.

Данные — это информация, представленная в формализованном виде и предназначенная для обработки ее техническими средствами, например, ЭВМ.

Двоичное кодирование – система представления данных последовательностью двух знаков: 1 и 0.

Деинсталляция программы – это обратный процесс, т.е. удаление программы.

Декларативный язык (declatative language) – язык программирования или манипулирования базой данных. Отличительной особенностью декларативных языков является то, что они описывают последовательность действий, а результат должен быть получен после выполнения программы.

Диаграмма – графическое представление данных.

Диалоговое окно – специальное окно, используемое для настройки параметров операционной системы или приложения. Отличается от окна приложения отсутствием строки меню. Содержит набор элементов управления, которые могут быть размещены на нескольких вкладках.

Диапазон – прямоугольная область ячеек.

Динамическая переменная создается во время выполнения программы и память для них выделяется в динамической области (heap).

Документ, т.е. объект обработки текстового процессора Word, – это файл с произвольным именем и расширением doc.

Домен – это совокупность компьютеров сервера и относящихся к нему PC.

Дорожка – концентрические окружности на магнитной поверхности диска, где располагается информация. Дорожки нумеруются с 0-й (дорожка с самым большим радиусом)

Загрузочный вирус – поражает не программные файлы, а определенные системные области магнитных носителей

Запись представляет собой совокупность ограниченного числа логически связанных компонент, принадлежащих к разным типам. Компоненты записи называются полями, каждое из которых определяется именем.

Запрос (query) – предложение, описывающее критерий поиска информации в базе данных.

Защита данных – комплекс мер, направленных на предотвращение утраты, воспроизведения и модификации данных.

Значки – графическое представление объектов.

Идентификатор – обозначение (имя) программной переменной, принятое для обращения к ней в программе, написанной на языке программирования высокого уровня.

Именами (идентификаторами) называют элементы языка - константы, метки, типы, переменные, процедуры, функции, модули, объекты. Имя - это последовательность букв и цифр, начинающаяся с буквы. В именах может использоваться символ '_' подчеркивание.

Импорт (import) – считывание файла, созданного в другой программе, для использования базой данных. Большинство СУБД способно считывать форматы ASCII, DBF, DB и т.п.

Имя пользователя – имя компьютера, введенное при настройке.

Индекс (index) – группа указателей, устанавливающих связь между значениями полей и их адресами. Большинство баз данных поддерживает множественное индексирование базы данных.

Инициализация переменных - это задание начальных значений переменным.

Инкапсуляция - это объединение данных и алгоритмов их обработки в одной структуре данных (объекте).

Инсталляция программы – это установка программы на персональный компьютер.

Интерпретатор переводит каждую команду программы с одновременным её выполнением и, если обнаруживает ошибку, сообщает о ней и прекращает выполнение программы.

Информатика – наука , систематизирующая приемы создания, хранения, воспроизведения, обработки и передачи данных средствами вычислительной техники, а также принципы функционирования этих средств и методы управления ими.

Информационная техника представляет собой материальную основу информационной технологии, с помощью которой осуществляется сбор, хранение, передача и обработка информации.

Информационная технология — это совокупность методов, производственных процессов и программно-технических средств, объединенных в технологическую цепочку, обеспечивающую сбор, обработку, хранение, распространение и отображение информации с целью снижения трудоемкости процессов использования информационного ресурса, а также повышения их надежности и оперативности.

Информационный процесс — это процесс, в результате которого осуществляется прием, передача (обмен), преобразование и использование информации.

Информация – сведения об окружающем мире, которые повышают уровень осведомленности человека.

Каталог (папка) – это определенное место на диске (в области данных диска), где содержится информация о файлах и подкаталогах, привязанных к данному каталогу.

Кбайт – 1024 байт.

Кибернетика – наука об управлении.

Кластер – это минимальная порция информации, которую MS-DOS считывает/записывает за одно обращение диску. Кластер “содержит” только последовательно расположенные сектора (цель - увеличить скорость обмена с диском). Размер Кластера = N×(Размер Сектора)= N×512 байт, где N = 2,4,8 и т.д.

Клиент – потребитель ресурса сети.

Клиент сети – это программное обеспечение, позволяющее использовать общие ресурсы сети (папки, принтеры и т.д.).

Клиент-сервер (client-server) – описывает частный случай распределенной базы данных, где под клиентом понимается фронтальная программа, обеспечивающая взаимодействие с пользователем, а под сервером – тыловая программа, обеспечивающая централизованную обработку данных.

Книга – файл, объект обработки Microsoft Excel с произвольным именем и расширением xls. файл, используемый для обработки и хранения данных в Excel. В каждом файле размещается от 1 до 255 электронных таблиц, каждая из которых называется рабочим листом. Каждый лист состоит из 65 536 строк и 256 столбцов.

Кодирование данных – выражение данных одного типа через данные другого типа.

Количеством информации называют числовую характеристику сигнала, отражающую ту степень неопределенности (неполноту знаний), которая исчезает после получения сообщения в виде данного сигнала. Эту меру неопределенности в теории информации называют энтропией.

Колонтитул – часть страницы, на которой размещен постоянный текст, несущий справочную информацию.

Компилятор переводит всю программу целиком и в конце работы выдаёт список ошибок, если они обнаружены.

Компонентные файлы состоят из машинных представлений значений переменных, они хранят данные в том же виде, что и память ЭВМ.

Компонентный или типизированный файл - это файл с объявленным типом его компонент.

Компьютер – это электронный прибор, предназначенный для автоматизации создания, хранения, обработки и транспортировки данных.

Компьютерный вирус – специально написанная компьютерная программа, способная самопроизвольно присоединяться к другим программам, создавать свои копии, внедрять их в файлы с целью порчи файлов и каталогов, создания помех в работе.

Коннекторы (соединители) необходимы для соединения сетевых адаптеров компьютеров с тонким кабелем, а также для соединения кабелей друг с другом.

Константы – данные, значение которых не меняется во время работы программы.

Контекстное меню – меню, содержащее команды, применимые к выбранному объекту. Вызывается щелчком правой кнопкой мыши на любом объекте Windows.

Корзина – специальный объект Windows, служащий для временного хранения удаляемых файлов.

Кортеж (tuple) – строка реляционной таблицы.

Курсор – мигающая вертикальная черта, указывающая место в документе, где появляется набираемый на клавиатуре текст.

Легенда – подпись, определяющая закраску или цвета точек данных или категорий диаграммы.

Линии передачи данных соединяют PC и серверы в районе размещения сети друг с другом.

Линии сетки – линии, которые, будучи добавлены к диаграмме, облегчают просмотр и анализ данных.

Линия тренда – графическое представление тренда или направления изменения данных в ряде данных.

Локальная вычислительная сеть (ЛВС)представляет собой коммуникационную систему, позволяющую совместно использовать ресурсы компьютеров, подключенных к сети, такие, как принтеры, плоттеры, диски, модемы, приводы CD-ROM и другие периферийные устройства.

Локальные переменные - это переменные, описанные в самой процедуре или функции и располагающиеся в сегменте стека.

Макровирус – разновидность вирусов, поражающая документы, имеющие средства для исполнения макрокоманд.

Маркер данных – столбик, закрашенная область, точка, сегмент или другой геометрический объект диаграммы, обозначающий точку данных или значение ячейки.

Массивы представляют собой ограниченную упорядоченную совокупность однотипных величин. Каждая отдельная величина называется компонентой массива.

Мастер – программный модуль для выполнения каких-либо операций.

Мбайт – 1024 Кбайт.

Менеджеры загрузки (download manager) – программы для перекачки файлов из Сети: Go!Zilla, ReGet, GetRight.

Методы - это инкапсулированные в объект процедуры и функции.

Многозадачность – свойство операционной системы, заключающееся в возможности одновременного выполнения нескольких программ.

Многоколоночная верстка – расположение текста в несколько колонок.

Множество - это ограниченная совокупность различных элементов.

Модем – устройство подключения ЛВС или отдельного компьютера к глобальной сети через телефонную связь, предназначенное для преобразования и передачи данных между удаленными клиентами.

Модификация (update) – предложение, описывающее информацию в базе данных, подлежащую изменению.

Модуль - это совокупность программных ресурсов, предназначенных для использования другими программами.

Мультимедиа – сочетание нескольких видов данных в одном документе (текстовые, графические, музыкальные и видеоданные) или совокупность устройств для воспроизведения этого комплекса данных.

Мэйнфрейм – централизованная схема управления вычислительным процессом на базе средней или большой ЭВМ.

Набор – это ввод текста с клавиатуры на экран.

Название диаграммы – описательный текст, автоматически связанный с осью или расположенный по центру диаграммы.

Область диаграммы – вся диаграмма, вместе со всеми ее элементами.

Область построения – в двумерной диаграмме областью построения называется область, ограниченная осями и содержащая все ряды диаграммы. В трехмерной диаграмме это область, ограниченная осями и включающая ряды данных, названия категорий, подписи делений и названия осей.

Обмен информацией — это процесс, в ходе которого источник информации ее передает, а получатель — принимает.

Обработка информации — это упорядоченный процесс ее преобразования в соответствии с алгоритмом решения задачи.

Объединение – операция объединения информации из нескольких таблиц или запросов на основе совпадающих значений определенных атрибутов. Например, информация о клиентах может быть объединена с данными о заказах по коду клиента.

Окно – это сложный графический объект, осуществляющий взаимодействие программы с пользователем и другими программами.

Оперативная память служит для приема, хранения и выдачи информации.

Оператор задает полное описание некоторого действия, которое необходимо выполнить. Для описания сложного действия может потребоваться группа операторов. В этом случае операторы объединяются в составной оператор или блок.

Операторы отношений сравнивают два значения, возвращая в результате булевское значение True или False.

Операционная система – набор программ и драйверов, обеспечивающих взаимодействие программ с аппаратным обеспечением компьютера и базовые возможности для ввода команд пользователем.

Ось – линия, часто ограничивающая с одной стороны область построения и используемая как основа измерений для построения данных на диаграмме.

Относительная ссылка – ссылка на ячейку, автоматически изменяющаяся при копировании формулы, например A1.

Отношение (relation) – множество, каждый элемент которого включает значения n атрибутов (1 атрибут – унарное, 2 атрибута – бинарное, n атрибутов – n-арное отношение).

Отчет (report) – документ, представляемый на бумаге или экране, который содержит некоторый набор информации из базы данных.

Пакет– это небольшие специфицированные элементы, на которые разбиваются сообщения для передачи по сети.

Панели инструментов – средство для быстрого выполнения команд и процедур.

Панель задач – один из основных элементов управления.

Пароль– секретная комбинация символов, служащая для подтверждения права доступа к определенному ресурсу, например, к удаленному компьютеру в сети или к папке на диске.

Переменная – объект в программе, значение которого изменяется самой программой.

Подпись значения – подпись, предоставляющая дополнительные сведения о точке данных, отображающей какое-либо значение ячейки.

Подпрограмма - это последовательность операторов, которые определены и записаны только в одном месте программы, однако их можно вызвать для выполнения из одной или нескольких точек программы. Каждая подпрограмма определяется уникальным именем.

Полиморфизм - это свойство, позволяющее называть разные алгоритмические действия одним именем.

Пользовательский интерфейс – методы и средства взаимодействия человека с аппаратными и программными средствами.

Последовательный доступ - это доступ в каждый момент времени лишь к одной компоненте данных из всей последовательности, записанной в файл.

Постоянная память обеспечивает хранение и выдачу информации. В отличие от содержимого оперативной памяти, содержимое постоянной заполняется при изготовлении ЭВМ и не может быть изменено в обычных условиях эксплуатации.

Почтовые программы (e-mail programmes) – специальные программы для принятия, отправки, сортировки и просмотра электронной почты: Eudora, The Bat!, MS Outlook, Pegasus.

Преобразование данных – перевод данных из одной формы в другую или из одной структуры в другую.

Прикладное программное обеспечение – комплекс программ, с помощью которых на данном рабочем месте выполняются конкретные задания.

Проводник – служебная программ, относящаяся к категории диспетчеров файлов.

Программа – упорядоченная последовательность команд, необходимых компьютеру для решения поставленной задачи.

Программа – упорядоченная последовательность команд.

Программа - это объединенная единым алгоритмом совокупность описаний и операторов на алгоритмическом языке.

Программы дозвона (dialer programmes) – программы для соединения с провайдером по одному или нескольким номерам телефонов: E-type Dialer, Advanced Dialer.

Программы общения (chat programmes) – программы, предоставляющие возможность вести переговоры в Сети как в текстовом режиме, так и в режиме аудио и видео обмена: MicroIRC, ICQ, IPhone, EasyTalk, NetMeeting.

Протокол– это набор конкретных правил обмена информацией между устройствами передачи данных.

Процедура – программа, описывающая алгоритм получения некоторого простейшего объекта, который может использоваться для создания сложных объектов.

Процедура и функция - это именованная последовательность описаний и операторов.

Процессор, или микропроцессор, – основное устройство ЭВМ, предназначен для выполнения вычислении по хранящейся в запоминающем устройстве программе и обеспечения общего управления ЭВМ.

Прямой доступ предполагает, что файл представляет собой линейную последовательность блоков.

Рабочая группа – совокупность пользователей, объединенных одной общей задачей (например, разработкой проекта) и имеющих общее имя.

Рабочие станции (PC) – это, как правило, персональные ЭВМ, которые являются рабочими местами пользователей сети.

Рабочий стол – графическая среда, на которой отображаются объекты и элементы управления Windows.

Разархивация (распаковка) – восстановление файла из архива.

Расширенная память (Extended Memory) – это память, используемая в компьютерах с процессорами 80286 и выше, располагающаяся в адресном пространстве выше одного мегабайта.

Расширенный фильтр – возможность отфильтровать данные по трем или большем количестве условий.

Регистры CPU – специальные внутренние устройства CPU, которые предназначены для хранения информации.

Редактирование – это ввод изменений, исправлений и дополнений в документ.

Резидентная программа – программа, которая после загрузки в ОЗУ и передаче ей управления инициализируется таким образом, что постоянно находится в ОЗУ и выполняется параллельно другим программам.

Рекуррентное соотношение – это формула, в которой очередной член последовательности выражается через один или несколько предыдущих членов.

Реляционная алгебра (relational algebra) – средство процедурного описания запросов к реляционной базе данных. Основными операциями реляционной алгебры являются селекция, соединение и проекция.

Реляционное исчисление (relational calculus) – средство декларативного описания запросов к реляционной алгебре. Запросы описываются с помощью кортежных переменных, одноместных и двухместных предикатов и правильно построенных формул.

Репитер предназначен для соединения сегментов сетей.

РСI – вид шины передачи данных, используемый для работы с высокоскоростными устройствами. Применяется практически во всех современных компьютерах.

Ряд данных – группа связанных точек данных диаграммы, отображающая значение строк или столбцов листа.

САМ (color active matrix) – цветная активная матрица – наиболее качественный тип цветного дисплея портативного компьютера. Обеспечивает яркие и насыщенные цвета, но дороже дисплея с пассивной матрицей двойного сканирования (СРМ, DS).

Самораспаковывающийся архив –это исполняемый модуль, при запуске которого происходит восстановление файла из архива даже при отсутствии архиватора, которым файл был упакован.

Самоустанавливающиеся устройства – устройства, удовлетворяющие принципу plug-and-play.

Сбор информации— это деятельность субъекта, в ходе которой он получает сведения об интересующем его объекте.

Сводная таблица — это таблица, которая используется для быстрого подведения итогов или объединения больших объемов данных.

Связь – способ, которым информация в одной таблице связывается с данными в другой таблице. Отношения "один-к-одному", "один-ко-многим", "многие-ко-многим".

Сектор – каждая дорожка, размещенная на диске, делится на секторы. Каждый сектор имеет размер = 512 байт (для MS-DOS)

Селекция (selection) – одноместная операция реляционной алгебры, в результате которой формируется отношение, кортежи которого будут включать кортежи (или только некоторые атрибуты кортежей) исходного отношения, удовлетворяющие определенному логическому условию.

Семантика - определение смысла и правила использования тех элементов языка, для которых были даны синтаксические определения.

Сервер – это мощный компьютер, выполняющий функции распределения сетевых ресурсов.

Сеть представляет собой совокупность компьютеров, объединенных средствами передачи данных.

Сжатие (архивация) – устранения избыточности информации. Например, за счёт упрощения кодов путём исключения из них постоянных битов. Служит для снижения экономических затрат по хранению данных и повышает общую надежность информационного процесса в целом.

Сигнал (от латинского signum — знак) представляет собой любой процесс, несущий информацию.

Символы языка - это основные неделимые знаки, в терминах которых пишутся все тексты на языке.

Синтаксис - правила построения элементов языка.

Системное программное обеспечение – программное обеспечение, отвечающее за взаимодействие прочих программ компьютерной системы с программами базового уровня, а также средства пользовательского интерфейса.

Системный интерфейс — это конструктивная часть ЭВМ, предназначенная для взаимодействия ее устройств и обмена информацией между ними.

Следование - это конструкция, представляющая собой последовательное выполнение двух или более операций.

Слово – 16 взаимосвязанных битов (2 взаимосвязанных байта).

Службадает возможность делать файлы, принтеры и прочие ресурсы доступными для других компьютеров, а также автоматизирует архивацию файлов на сервер сети.

Служебное программное обеспечение (утилиты) – обеспечивает автоматизацию проверки, наладки и настройки компьютерной системы.

Смешанная ссылка – ссылка лишь частично абсолютная, например $A1.

Соединение (join) – двухместная операция реляционной алгебры, в результате которой формируется отношение, кортежи которого включают пары кортежей исходных отношений, атрибуты которых удовлетворяют логическому условию.

Сообщение — это информация, представленная в определенной форме и предназначенная для передачи.

Списки рассылки – системы рассылки электронных писем между подписчиками.

Список – это набор строк таблицы, содержащий связанные данные, Список может использоваться как база данных, в которой строки выступают в качестве записей, а столбцы являются полями. Первая строка списка при этом содержит названия столбцов.

Статической переменной (статически размещенной) называется описанная явным образом в программе переменная, обращение к которой осуществляется по имени. Место в памяти для размещения статических переменных определяется при компиляции программы.

Стенки и основание – плоскости, на фоне которых отображаются многие трехмерные диаграммы.

Стилевое оформление – это назначение специальных стилей символам или абзацам.

Стиль – характерный вид, разновидность чего-либо, выражающаяся в каких-нибудь особенных признаках, свойствах художественного оформления.

Столбец – группа ячеек, расположенных в одном вертикальном ряду таблицы, нумеруется буквами латинского алфавита.

Строка – группа ячеек, расположенных на одном горизонтальном уровне, нумеруется целым числом,

Строки в языке Паскаль - это последовательность символов, записанная между апострофами.

Структурированная программа (или подпрограмма) - это программа, составленная из фиксированного множества базовых конструкций.

Таблица (table) – см. Отношение.

Тбайт – 1024 Гбайт.

Текст – последовательность слов, построенных по правилам языка.

Текстовый процессор – программа для ввода, редактирования и форматирования текстовых данных.

Текстовый редактор – программа для ввода и редактирования текстовых данных.

Терминаторы служат для подключения к открытым кабелям сети, а также для заземления (так называемые терминаторы с заземлением).

Технология — это совокупность знаний о способах и средствах проведения производственных процессов, при которых происходит качественное изменение обрабатываемых объектов.

Технология «клиент-сервер» – архитектура, в которой место терминала выполняет ПЭВМ (клиентская), а мэйнфрейма – один или несколько мощных компьютеров, специально выделенных для решения общих задач обработки информации (компьютеры-серверы).

Трансивер – это устройство подключения PC к толстому коаксиальному кабелю.

ТСО-92, ТСО-95 – стандарты на излучение мониторов, обеспечивающие их безвредность для здоровья пользователей. Стандарт ТСО-92 приблизительно аналогичен MPR-II, ТСО-95 – еще более жесток, стандарту ТСО-95 удовлетворяют далеко не все мониторы, удовлетворяющие MPR-II или ТСО-92.

Тэги (tags) – команды языка HTML.

Убывание (descending) – направление упорядочивания данных в базе от наибольшего к наименьшему значению в алфавитно-цифровом порядке в соответствии с кодами (ASCII, EBCDIC, Unicode и т.п.)·символов, принятыми в системе.

узкий принтер – принтер (как правило, матричный) с шириной печати 8". В такой принтер может быть заправлен узкой стороной лист бумаги формата А4.

Указатель мыши – активный элемент управления, графический объект, перемещение которого на экране синхронизировано с перемещением мыши.

Устройства ввода-вывода служат соответственно для ввода информации в ЭВМ и вывода из нее, а также для обеспечения общения пользователя с машиной.

Файл (по-английски file – папка, скоросшиватель) – это поименованная область памяти на каком-либо физическом носителе, предназначенная для хранения информации.

Файловая структура – иерархическая структура, в виде которой операционная система отображает файлы и папки диска.

Фактический параметр – конкретное значение (например, число) формального параметра, которое указывается в команде вызова процедуры.

Физические файлы - это файлы на внешних устройствах.

Фильтрация – способ отображения строк списка, удовлетворяющих условию отбора.

Флоппи-диск (дискета) – съемный гибкий магнитный диск.

Формальный параметр – параметр, не имеющий конкретного указанного в теле процедуры значения.

Форматирование – представление текстового документа или отдельных его объектов в заданной форме.

Форматирование абзаца – задание или изменение его параметров.

Форматирование шрифта – изменение параметров введенных символов.

Формула – комбинация адресов ячеек, чисел, знаков операций, стандартных функций. Формула всегда начинается знаком "=".

Хакер – (1) пользователь, пытающийся получить незаконный доступ к конфиденциальной или неоплаченной информации (обычно в компьютерной сети). (2) Пользователь, вносящий несанкционированные изменения в программное обеспечение, приводящее к нарушению авторских прав создателей программного продукта.

Хранение информации — это процесс поддержания исходной информации в виде, обеспечивающем выдачу данных по запросам конечных пользователей в установленные сроки.

Цель сжатия – размещение информации на носителях внешней памяти в более компактном виде, что требует меньших объёмов памяти.

Цикл - это конструкция, имеющая линии управления, ведущие к предыдущим операциям или развилкам.

Цикл – это многократное повторение одного или нескольких действий, которые называются телом цикла.

Цилиндр – объединение дорожек с одним и тем же номером, расположенных на разных поверхностях диска(для флоппи-диска под цилиндром подразумевается 2 дорожки)

Шаблон – это совокупность параметров документа, предназначенных для многократного использования.

широкий принтер – принтер (как правило, матричный) с шириной печати 15" и более. В такой принтер может быть заправлен лист бумаги формата A3. Используется для печати бухгалтерских документов, больших таблиц и т.д.

Экспорт (export)– запись информации на диск в виде файла, предназначенного для использования в какой-либо другой программе.

Электронная таблица – комплексное средство для хранения различных типов данных и их обработки.

Элементарные конструкции - это минимальные единицы языка, имеющие самостоятельный смысл. Они образуются из основных символов языка.

Язык QBE (query by example) – язык поиска в базе данных, когда критерий специфицируется в экранной форме, описывающей поля записи.

Язык SQL (structured query language) – язык манипулирования данными, предназначенный для выполнения реляционных запросов и имеющий минимальное количество операций.

Ярлык – указатель на объект.

Ячейка – клетка на пересечении строки и столбца таблицы Microsoft Excel.


2.1. Базовая аппаратная конфигурация

Персональный компьютер – универсальная техническая система. Его конфигурацию (состав оборудования) можно гибко изменять по мере необходимости. Тем не менее, существует понятие базовой конфигурации, которую считают типовой. В таком комплекте компьютер обычно поставляется. Понятие базовой конфигурации может меняться. В настоящее время в базовой конфигурации рассматривают четыре устройства (рис. 2.1):

  • системный блок;
  • монитор;
  • клавиатуру;
  • мышь.

Помимо компьютеров с базовой конфигурации всё большее распространение получают мультимедийные компьютеры, оснащенные устройством чтения компакт-дисков, колонками и микрофоном.


Системный блок

Системный блок представляет собой основной узел, внутри которого установлены наиболее важные компоненты. Устройства, находящиеся внутри системного блока, называют внутренними, а устройства, подключаемые к нему снаружи, называют внешними. Внешние дополнительные устройства, предназначенные для ввода, вывода и длительного хранения данных, также называют периферийными.

По внешнему виду системные блоки различаются формой корпуса. Корпуса персональных компьютеров выпускают в горизонтальном (desktop) и вертикальном (tower) исполнении. Корпуса, имеющие вертикальное исполнение, различают по габаритам: полноразмерный (big tower), среднеразмерный (midi tower) и малоразмерный (mini tower). Среди корпусов, имеющих горизонтальное исполнение, выделяют плоские и особо плоские (slim). Выбор того или иного типа корпуса определяется вкусом и потребностями модернизации компьютера. Наиболее оптимальным типом корпуса для большинства пользователей является корпус типа mini tower. Он имеет небольшие габариты, его удобно располагать как на рабочем столе, так и на тумбочке вблизи рабочего стола или на специальном держателе. Он имеет достаточно места для размещения от пяти до семи плат расширения.

Кроме формы, для корпуса важен параметр, называемый форм-фактором. От него зависят требования к размещаемым устройствам. В настоящее время в основном используются корпуса двух форм-факторов: AT и АТХ . Форм-фактор корпуса должен быть обязательно согласован с форм-фактором главной (системной) платы компьютера, так называемой материнской платы.

Корпуса персональных компьютеров поставляются вместе с блоком питания и, таким образом, мощность блока питания также является одним из параметров корпуса. Для массовых моделей достаточной является мощность блока питания 200-250 Вт.


Материнская плата

В предыдущем разделе мы выяснили, что первым элементом системного блока является корпус. Вторым и самым важным элементом является материнская плата.

Материнская плата (mother board) – основная плата персонального компьютера, представляющая из себя лист стеклотекстолита, покрытый медной фольгой. Путем травления фольги получают тонкие медные проводники соединяющие электронные компоненты. На материнской плате размещаются:

  • процессор – основная микросхема, выполняющая большинство математических и логических операций;
  • шины – наборы проводников, по которым происходит обмен сигналами между внутренними устройствами компьютера;
  • оперативная память (оперативное запоминающее устройство, ОЗУ) – набор микросхем, предназначенных для временного хранения данных, когда компьютер включен;
  • ПЗУ (постоянное запоминающее устройство) – микросхема, предназначенная для длительного хранения данных, в том числе и когда компьютер выключен;
  • микропроцессорный комплект (чипсет) – набор микросхем, управляющих работой внутренних устройств компьютера и определяющих основные функциональные возможности материнской платы;
  • разъемы для подключения дополнительных устройств (слоты).

Необходимо хотя бы кратко ознакомиться с этими устройствами, потому что даже при покупке компьютера без этих знаний не обойтись. Перед Вами откроется тайна странных надписей в рекламных объявлениях о продаже компьютеров. Начнем с размеров и марок самой материнской платы. Менялись микропроцессоры, рождались и умирали системные и локальные шины, а вид и размеры материнской платы практически не менялись с 1984 г. Например, размер оригинальной материнской платы IBM PC/AT под названием Baby-AT был равен 217 на 331 мм, а размеры современной материнской платы P3B-F равны 192 мм на 304 мм. (рис. 2.2).

а | б

Рис. 2.2. Материнские платы: а) Pentium III P3B-F фирмы ASUSTeK;
б) ASUSTeK P4G8X-Deluxe Socket478 фирмы ASUSTeK

У материнской платы Baby-AT есть один очень большой недостаток. При установке в слоты расширения печатных плат некоторые из них оказывались прямо над микропроцессором. А так как на микропроцессор чаще всего сверху устанавливают радиатор и вентилятор, установка длинных плат расширения была невозможна. В 1995 году была предложена новая схема размещения элементов на системной плате. Через некоторое время был разработан новый стандарт под названием ATX. Первое отличие материнской платы ATX от Baby AT – расположение слотов расширения. На плате Baby AT они располагаются вдоль длинной стороны платы, а на плате ATX разъемы слотов расширения параллельны короткой стороне, что позволяет в любой слот установить полноразмерную плату расширения. Серьезные изменения коснулись разъемов ввода/вывода. В дополнение к стандартным портам предусмотрены порты будущего: USB(Universal Serial Bus – универсальная последовательная шина) и инфракрасный порт (IrDA). Еще одно отличие – необходимость дополнительного напряжения 3,3 вольта (для платы Baby AT нужны были напряжения 5 и 12 вольт). В 1999 году на рынке большей частью были представлены материнские платы, допускающие работу с тактовой частотой микропроцессора до 500 Мгц. Некоторые из них имеют отличительный признак – наличие гнезда для подключения микропроцессора с нулевым усилием сопряжения – ZIF (Zero Insertion Force) типа Socket 7. В данное гнездо можно ставить как процессор Intel Pentium, так и процессоры Cyrix 6x86, AMD K5 и K6. Более современные платы имеют разъем Slot 1 или Slot 2 для подключения процессоров Pentium II и Pentium III.


Процессор

Процессор (микропроцессор, центральный процессор, CPU) – основная микросхема компьютера, в которой и производятся все вычисления. Он представляет из себя большую микросхему (например, размеры микропроцессора Pentium примерно 5*5*0,5 см), которую можно легко найти на материнской плате. На процессоре установлен большой медный ребристый радиатор, охлаждаемый вентилятором. Конструктивно процессор состоит из ячеек, в которых данные могут не только храниться, но и изменяться. Внутренние ячейки процессора называют регистрами. Важно также отметить, что данные, попавшие в некоторые регистры, рассматриваются не как данные, а как команды, управляющие обработкой данных в других регистрах. Среди регистров процессора есть и такие, которые в зависимости от своего содержания способны модифицировать исполнение команд. Таким образом, управляя засылкой данных в разные регистры процессора, можно управлять обработкой данных. На этом и основано исполнение программ.

С остальными устройствами компьютера, и в первую очередь с оперативной памятью, процессор связан несколькими группами проводников, называемых шинами. Основных шин три: шина данных, адресная тина и командная шина.

Адресная шина. У процессоров Intel Pentium (а именно они наиболее распространены в персональных компьютерах) адресная шина 32-разрядная, то есть состоит из 32 параллельных линий. В зависимости от того, есть напряжение на какой-то из линий или нет, говорят, что на этой линии выставлена единица или ноль. Комбинация из 32 нулей и единиц образует 32-разрядный адрес, указывающий на одну из ячеек оперативной памяти. К ней и подключается процессор для копирования данных из ячейки в один из своих регистров.

Шина данных. По этой шине происходит копирование данных из оперативной памяти в регистры процессора и обратно. В компьютерах, собранных на базе процессоров Intel Pentium, шина данных 64-разрядная, то есть состоит из 64 линий, по которым за один раз на обработку поступают сразу 8 байтов.

Шина команд. Для того чтобы процессор мог обрабатывать данные, ему нужны команды. Он должен знать, что следует сделать с теми байтами, которые хранятся в его регистрах. Эти команды поступают в процессор тоже из оперативной памяти, но не из тех областей, где хранятся массивы данных, а оттуда, где хранятся программы. Команды тоже представлены в виде байтов. Самые простые команды укладываются в один байт, однако есть и такие, для которых нужно два, три и более байтов. В большинстве современных процессоров шина команд 32-разрядная (например, в процессоре Intel Pentium), хотя существуют 64-разрядные процессоры и даже 128-разрядные.

Система команд процессора. В процессе работы процессор обслуживает данные, находящиеся в его регистрах, в поле оперативной памяти, а также данные, находящиеся во внешних портах процессора. Часть данных он интерпретирует непосредственно как данные, часть данных – как адресные данные, а часть – как команды. Совокупность всех возможных команд, которые может выполнить процессор над данными, образует так называемую систему команд процессора. Процессоры, относящиеся к одному семейству, имеют одинаковые или близкие системы команд. Процессоры, относящиеся к разным семействам, различаются по системе команд и невзаимозаменяемыми.

Совместимость процессоров. Если два процессора имеют одинаковую систему команд, то они полностью совместимы на программном уровне. Это означает, что программа, написанная для одного процессора, может исполняться и другим процессором. Процессоры, имеющие разные системы команд, как правило, несовместимы или ограниченно совместимы на программном уровне.

Группы процессоров, имеющих ограниченную совместимость, рассматривают как семейства процессоров. Так, например, все процессоры Intel Pentium относятся к так называемому семейству х86. Родоначальником этого семейства был 16-разрядный процессор Intel 8086, на базе которого собиралась первая модель компьютера IBM PC. Впоследствии выпускались процессоры Intel 80286, Intel 80386, Intel 80486, Intel Pentium 60,66,75,90,100,133; несколько моделей процессоров Intel Pentium MMX, модели Intel Pentium Pro, Intel Pentium II, Intel Celeron, Intel Xeon, Intel Pentium III (см. рис. 2.3,а), Intel Pentium IV и другие. Все эти модели, и не только они, а также многие модели процессоров компаний AMD (см. рис. 2.3,б) и Cyrix относятся к семейству х86 и обладают совместимостью по принципу «сверху вниз».

а) | б) | в)

Рис. 2.3. Микропроцессоры, разработанные фирмами Intel и AMD:
а) CPU Intel Pentium 4 2.8 ГГц; б) CPU Intel Pentium III 550 МГц ;
в) CPU AMD K6-3-450 МГц

Принцип совместимости «сверху вниз» – это пример неполной совместимости, когда каждый новый процессор «понимает» все команды своих предшественников, но не наоборот. Это естественно, поскольку двадцать лет назад разработчики процессоров не могли предусмотреть систему команд, нужную для современных программ. Благодаря такой совместимости на современном компьютере можно выполнять любые программы, созданные в последние десятилетия для любого из предшествующих компьютеров, принадлежащего той же аппаратной платформе.

Основные параметры процессоров. Основными параметрами процессоров являются: рабочее напряжение, разрядность, рабочая тактовая частота, коэффициент внутреннего умножения тактовой частоты и размер кэш-памяти.

Рабочее напряжение процессора обеспечивает материнская плата, поэтому разным маркам процессоров соответствуют разные материнские платы (их надо выбирать совместно). По мере развития процессорной техники происходит постепенное понижение рабочего напряжения. Ранние модели процессоров х86 имели рабочее напряжение 5 В. С переходом к процессорам Intel Pentium оно было понижено до 3,3 В, а в настоящее время оно составляет менее 3 В. Причем ядро процессора питается пониженным напряжением 2,2 В. Понижение рабочего напряжения позволяет уменьшить расстояния между структурными элементами в кристалле процессора до десятитысячных долей миллиметра, не опасаясь электрического пробоя. Пропорционально квадрату напряжения уменьшается и тепловыделение в процессоре, а это позволяет увеличивать его производительность без угрозы перегрева.

Разрядность процессора показывает, сколько бит данных он может принять и обработать в своих регистрах за один раз (за один такт). Первые процессоры х86 были 16-разрядными. Начиная с процессора 80386 они имеют 32-разрядную архитектуру. Современные процессоры семейства Intel Pentium остаются 32-разрядными, хотя и работают с 64-разрядной шиной данных (разрядность процессора определяется не разрядностью шины данных, а разрядностью командной шины).

В основе работы процессора лежит тот же тактовый принцип, что и в обычных часах. Исполнение каждой команды занимает определенное количество тактов. В настенных часах такты колебаний задает маятник; в ручных механических часах их задает пружинный маятник; в электронных часах для этого есть колебательный контур, задающий такты строго определенной частоты. В персональном компьютере тактовые импульсы задает одна из микросхем, входящая в микропроцессорный комплект (чипсет), расположенный на материнской плате. Чем выше частота тактов, поступающих на процессор, тем больше команд он может исполнить в единицу времени, тем выше его производительность. Первые процессоры х86 могли работать с частотой не выше 4,77 МГц, а сегодня рабочие частоты, некоторых процессоров уже превосходят 500 миллионов тактов в секунду (500 МГц).

Тактовые сигналы процессор получает от материнской платы, которая, в отличие от процессора, представляет собой не кристалл кремния, а большой набор проводников и микросхем. По чисто физическим причинам материнская плата не может работать со столь высокими частотами, как процессор. Сегодня ее предел составляет 100-133 МГц. Для получения более высоких частот в процессоре происходит внутреннее умножение частоты на коэффициент 3; 3,5; 4; 4,5; 5 и более.

Обмен данными внутри процессора происходит в несколько раз быстрее, чем обмен с другими устройствами, например с оперативной памятью. Для того чтобы уменьшить количество обращений к оперативной памяти, внутри процессора создают буферную область – так называемую кэш-память. Это как бы «сверхоперативная память». Когда процессору нужны данные, он сначала обращается в кэш-память, и только если там нужных данных нет, происходит его обращение в оперативную память. Принимая блок данных из оперативной памяти, процессор заносит его одновременно и в кэш-память. «Удачные» обращения в кэш-память называют попаданиями в кэш. Процент попаданий тем выше, чем больше размер кэш-памяти, поэтому высокопроизводительные процессоры комплектуют повышенным объемом кэш-памяти.

Нередко кэш-память распределяют по нескольким уровням. Кэш первого уровня выполняется в том же кристалле, что и сам процессор, и имеет объем порядка десятков Кбайт. Кэш второго уровня находится либо в кристалле процессора, либо в том же узле, что и процессор, хотя и исполняется на отдельном кристалле. Кэш-память первого и второго уровня работает на частоте, согласованной с частотой ядра процессора.

Кэш-память третьего уровня выполняют на быстродействующих микросхемах типа SRAM и размещают на материнской плате вблизи процессора. Ее объемы могут достигать нескольких Мбайт, но работает она на частоте материнской платы.


Шинные интерфейсы материнской платы

Связь между всеми собственными и подключаемыми устройствами материнской платы выполняют ее шины и логические устройства, размещенные в микросхемах микропроцессорного комплекта (чипсета). От архитектуры этих элементов во многом зависит производительность компьютера.

ISA. Историческим достижением компьютеров платформы IBM PC стало внедрение почти двадцать лет назад архитектуры, получившей статус промышленного стандарта ISA (Industry Standard Architecture). Она не только позволила связать все устройства системного блока между собой, но и обеспечила простое подключение новых устройств через стандартные разъемы (слоты). Пропускная способность шины, выполненной по такой архитектуре, составляет до 5,5 Мбайт/с, но, несмотря на низкую пропускную способность, эта шина продолжает использоваться в компьютерах для подключения сравнительно «медленных» внешних устройств, например звуковых карт и модемов.

EISA. Расширением стандарта ISA стал стандарт EISA (Extended ISA), отличающийся увеличенным разъемом и увеличенной производительностью (до 32 Мбайт/с). Как и ISA, в настоящее время данный стандарт считается устаревшим. После 2000 года выпуск материнских плат с разъемами ISA/EISA и устройств, подключаемых к ним, прекращается.

VLB. Название интерфейса переводится как локальная шина стандарта VESA ( VESA Local Bus). Понятие «локальной шины» впервые появилось в конце 80-х годов. Оно связано тем, что при внедрении процессоров третьего и четвертого поколений (Intel 80386 и Intel 80486) частоты основной шины (в качестве основной использовалась шина ISA/EISA) стало недостаточно для обмена между процессором и . оперативной памятью. Локальная шина, имеющая повышенную частоту, связала между собой процессор и память в обход основной шины. Впоследствии в эту шину «врезали» интерфейс для подключения видеоадаптера, который тоже требует повышенной пропускной способности, – так появился стандарт VLB, который позволил поднять тактовую частоту локальной шины до 50 МГц и обеспечил пиковую пропускную способность до 130 Мбайт/с.

Основным недостатком интерфейса VLB стало то, что предельная частота локальной шины и, соответственно, ее пропускная способность зависят от числа устройств, подключенных к шине. Так, например, при частоте 50 Мгц к шине может быть подключено только одно устройство (видеокарта). Для сравнения скажем, что при частоте 40 Мгц возможно подключение двух, а при частоте 33 МГц – трех устройств.

PCI. Интерфейс PCI (Peripheral Component Interconnect – стандарт подключения, внешних компонентов) был введен в персональных компьютерах, выполненных на базе процессоров Intel Pentium. По своей сути это тоже интерфейс локальной шины, связывающей процессор с оперативной памятью, в которую врезаны разъемы для р. подключения внешних устройств. Для связи с основной шиной компьютера (ISA/EISA) используются специальные интерфейсные преобразователи – мосты PCI (PCI Bridge). В современных компьютерах функции моста PCI выполняют микросхемы микропроцессорного комплекта (чипсета).

Данный интерфейс поддерживает частоту шины 33 МГц и обеспечивает пропускную способность 132 Мбайт/с. Последние версии интерфейса поддерживают частоту до 66 МГц и обеспечивают производительность 264 Мбайт/с для 32-разрядных данных и 528 Мбайт/с для 64-разрядных данных.

Важным нововведением, реализованным этим стандартом, стала поддержка так называемого режима plug-and-play, впоследствии оформившегося в промышленный стандарт на самоустанавливающиеся устройства. Его суть состоит в том, что после физического подключения внешнего устройства к разъему шины РС7 происходит обмен данными между устройством и материнской платой, в результате которого устройство автоматически получает номер используемого прерывания, адрес порта подключения и номер канала прямого доступа к памяти.

Конфликты между устройствами за обладание одними и теми же ресурсами (номерами прерываний, адресами портов и каналами прямого доступа к памяти) вызывают массу проблем у пользователей при установке устройств, подключаемых к шине ISA. С появлением интерфейса PCI и с оформлением стандарта plug-and-play появилась возможность выполнять установку новых устройств с помощью автоматических программных средств – эти функции во многом были возложены на операционную систему.

FSB. Шина PCI, появившаяся в компьютерах на базе процессоров Intel Pentium как локальная шина, предназначенная для связи процессора с оперативной памятью, недолго оставалась в этом качестве. Сегодня она используется только как шина для подключения внешних устройств, а для связи процессора и памяти, начиная с процессора Intel Pentium Pro используется специальная шина, получившая название Front Side Bus (FSB). Эта шина работает на очень высокой частоте 100-125 МГц. В настоящее время внедряются материнские платы с частотой шины FSB 133 МГц и ведутся разработки плат с частотой до 200 МГц. Частота шины FSB является одним из основных потребительских параметров – именно он и указывается в спецификации материнской платы. Пропускная способность шины FSB при частоте 100 МГц составляет порядка 800 Мбайт/с.

AGP. Видеоадаптер – устройство, требующее особенно высокой скорости передачи данных. Как при внедрении локальной шины VLB, так и при внедрении локальной шины PCI видеоадаптер всегда был первым устройством, «врезаемым» в новую шину. Сегодня параметры шины PCI уже не соответствуют требованиям видеоадаптеров, поэтому для них разработана отдельная шина, получившая название AGP (Advanced Graphic Port – усовершенствованный графический порт). Частота этой шины соответствует частоте шины PCI (33 МГц или 66 МГц), но она имеет много более высокую пропускную способность – до 1066 Мбайт/с (в режиме четырехкратного умножения).

PCMCIA (Personal Computer Memory Card International Association – стандарт международной ассоциации производителей плат памяти для персональных компьютеров). Этот стандарт определяет интерфейс подключения плоских карт памяти небольших размеров и используется в портативных персональных компьютерах.

USB (Universal Serial Bus – универсальная последовательная магистраль). Это одно из последних нововведений в архитектурах материнских плат. Этот стандарт определяет способ взаимодействия компьютера с периферийным оборудованием. Он позволяет подключать до 256 различных устройств, имеющих последовательный интерфейс. Устройства могут включаться цепочками (каждое следующее устройство подключается к предыдущему). Производительность шины USB относительно невелика и составляет до 1,5 Мбит/с, но для таких устройств, как клавиатура, мышь, модем, джойстик и т. п., этого достаточно. Удобство шины состоит в том, что она практически исключает конфликты между различным оборудованием, позволяет подключать и отключать устройства в «горячем режиме» (не выключая компьютер) и позволяет объединять несколько компьютеров в простейшую локальную сеть без применения специального оборудования и программного обеспечения.

Параметры микропроцессорного комплекта (чипсета) в наибольшей степени определяют свойства и функции материнской платы. В настоящее время большинство чипсетов материнских плат выпускаются на базе двух микросхем, получивших название «северный мост» и «южный мост».

«Северный мост» управляет взаимосвязью четырех устройств: процессора, оперативной памяти, порта AGP и шины PCI. Поэтому его также называют четырехпортовым контроллером.

«Южный мост» называют также функциональным контроллером. Он выполняет функции контроллера жестких и гибких дисков, функции моста ISA – PCI, контроллера клавиатуры, мыши, шины USB и т. п.


Оперативная память

Оперативная память (RAM – Random Access Memory) – это массив кристаллических ячеек, способных хранить данные. Существует много различных типов оперативной памяти, но с точки зрения физического принципа действия различают динамическую память (DRAM) и статическую память (SRAM).

Ячейки динамической памяти (DRAM) можно представить в виде микроконденсаторов, способных накапливать заряд на своих обкладках. Это наиболее распространенный и экономически доступный тип памяти. Недостатки этого типа связаны, во-первых, с тем, что как при заряде, так и при разряде конденсаторов неизбежны переходные процессы, то есть запись данных происходит сравнительно медленно. Второй важный недостаток связан с тем, что заряды ячеек имеют свойство рассеиваться в пространстве, причем весьма быстро. Если оперативную память постоянно не «подзаряжать», утрата данных происходит через несколько сотых долей секунды. Для борьбы с этим явлением в компьютере происходит постоянная регенерация (освежение, подзарядка) ячеек оперативной памяти. Регенерация осуществляется несколько десятков раз в секунду и вызывает непроизводительный расход ресурсов вычислительной системы.

Ячейки статической памяти (SRAM) можно представить как электронные микроэлементы – триггеры, состоящие из нескольких транзисторов. В триггере хранится не заряд, а состояние (включен/выключен), поэтому этот тип памяти обеспечивает . более высокое быстродействие, хотя технологически он сложнее и, соответственно, дороже.

Микросхемы динамической памяти используют в качестве основной оперативной памяти компьютера. Микросхемы статической памяти используют в качестве вспомогательной памяти (так называемой кэш-памяти), предназначенной для оптимизации работы процессора.

Каждая ячейка памяти имеет свой адрес, который выражается числом. В настоящее время в процессорах Intel Pentium и некоторых других принята 32-разрядная адресация, а это означает, что всего независимых адресов может быть 232. Таким образом, в современных компьютерах возможна непосредственная адресация к полю памяти размером 232 = 4 294 967 296 байт (4,3 Гбайт). Однако это отнюдь не означает, что именно столько оперативной памяти непременно должно быть в компьютере. Предельный размер поля оперативной памяти, установленной в компьютере, определяется микропроцессорным комплектом (чипсетом) материнской платы и обычно составляет несколько сот Мбайт.

Одна адресуемая ячейка содержит восемь двоичных ячеек, в которых можно сохранить 8 бит, то есть один байт данных. Таким образом, адрес любой ячейки памяти можно выразить четырьмя байтами.

Представление о том, сколько оперативной памяти должно быть в типовом компьютере, непрерывно меняется. В середине 80-х годов поле памяти размером 1 Мбайт казалось огромным, в начале 90-х годов достаточным считался объем 4 Мбайт, к середине 90-х годов он увеличился до 8 Мбайт, а затем и до 16 Мбайт. Сегодня типичным считается размер оперативной памяти 32-64 Мбайт, но очень скоро эта величина будет превышена в 2-4 раза даже для моделей массового потребления.

Оперативная память в компьютере размещается на стандартных панельках, называемых модулями. Модули оперативной памяти вставляют в соответствующие разъемы на материнской плате. Если к разъемам есть удобный доступ, то операцию можно выполнять своими руками. Если удобного доступа нет, может потребоваться неполная разборка узлов системного блока, и в таких случаях операцию поручают специалистам.

Конструктивно модули памяти имеют два исполнения – однорядные (SIMM-модули) и двухрядные (DIMM-модули) (см. рис. 2.4). На компьютерах с процессорами Pentium однорядные модули можно применять только парами (количество разъемов для их установки на материнской плате всегда четное), а DIMM-модули можно устанавливать по одному. Многие модели материнских плат имеют разъемы как того, так и другого типа, но комбинировать на одной плате модули разных типов нельзя.

а [image] б

Рис. 2.4. Модули памяти: а – SIMM; б – DIMM

Основными характеристиками модулей оперативной памяти являются объем памяти и время доступа. SIММ-модули поставляются объемами 4,8,16,32 Мбайт, а DIMM-модули – 16, 32, 64, 128 Мбайт и более. Время доступа показывает, сколько времени необходимо для обращения к ячейкам памяти – чем оно меньше, тем лучше. Время доступа измеряется в миллиардных долях секунды (наносекундах, нс). Типичное время доступа к оперативной памяти для SIММ-модулей – 50-70 нс. Для современных DIMM-модулей оно составляет 7-10 нс.


Микросхема ПЗУ и система BIOS

В момент включения компьютера в его оперативной памяти нет ничего – ни данных, ни программ, поскольку оперативная память не может ничего хранить без подзарядки ячеек более сотых долей секунды, но процессору нужны команды, в том числе и в первый момент после включения.

Поэтому сразу после включения на адресной шине процессора выставляется стартовый адрес. Это происходит аппаратно, без участия программ (всегда одинаково). Процессор обращается по выставленному адресу за своей первой командой и далее начинает работать по программам.

Этот исходный адрес не может указывать на оперативную память, в которой пока ничего нет. Он указывает на другой тип памяти – постоянное запоминающее устройство (ПЗУ). Микросхема ПЗУ способна длительное время хранить информацию, даже когда компьютер выключен. Программы, находящиеся в ПЗУ, называют «зашитыми» – их записывают туда на этапе изготовления микросхемы.

Комплект программ, находящихся в ПЗУ, образует базовую систему ввода-вывода (BIOS – Basic Input Output System). Основное назначение программ этого пакета состоит в том, чтобы проверить состав и работоспособность компьютерной системы и обеспечить взаимодействие с клавиатурой, монитором, жестким диском и дисководом гибких дисков. Программы, входящие в BIOS, позволяют нам наблюдать на экране диагностические сообщения, сопровождающие запуск компьютера, а также вмешиваться в ход запуска с помощью клавиатуры.


Энергонезависимая память CMOS

Выше мы отметили, что работа таких стандартных устройств, как клавиатура, может обслуживаться программами, входящими в BIOS, но такими средствами нельзя обеспечить работу со всеми возможными устройствами. Так, например, изготовители BIOS абсолютно ничего не знают о параметрах наших жестких и гибких дисков, им не известны ни состав, ни свойства произвольной вычислительной системы. Для того чтобы начать работу с другим оборудованием, программы, входящие в состав BIOS, должны знать, где можно найти нужные параметры. По очевидным причинам их нельзя хранить ни в оперативной памяти, ни в постоянном запоминающем устройстве.

Специально для этого на материнской плате есть микросхема «энергонезависимой памяти», по технологии изготовления называемая CMOS. От оперативной памяти она отличается тем, что ее содержимое не стирается во время выключения компьютера, а от ПЗУ она отличается тем, что данные в нее можно заносить и изменять самостоятельно, в соответствии с тем, какое оборудование входит в состав системы. Эта микросхема постоянно подпитывается от небольшой батарейки, расположенной на материнской плате. Заряда этой батарейки хватает на то, чтобы микросхема не теряла данные, даже если компьютер не будут включать несколько лет.

В микросхеме CMOS хранятся данные о гибких и жестких дисках, о процессоре, о некоторых других устройствах материнской платы. Тот факт, что компьютер четко отслеживает время и календарь (даже и в выключенном состоянии), тоже связан с тем, что показания системных часов постоянно хранятся (и изменяются) в CMOS.

Таким образом, программы, записанные в BIOS, считывают данные о составе оборудования компьютера из микросхемы CMOS, после чего они могут выполнить обращение к жесткому диску, а в случае необходимости и к гибкому, и передать управление тем программам, которые там записаны.


Жесткий диск

Жесткий диск – основное устройство для долговременного хранения больших объемов данных и программ (см. рис. 2.5). На самом деле это не один диск, а группа соосных дисков, имеющих магнитное покрытие и вращающихся с высокой скоростью. Таким образом, этот «диск» имеет не две поверхности, как должно быть у обычного плоского диска, а 2n поверхностей, где n – число отдельных дисков в группе.

Рис. 2.5. Жесткий диск MPD3043AT U_DMA фирмы FUJITSU
емкостью 4.3 Gb (IDE)

Над каждой поверхностью располагается головка, предназначенная для чтения-записи данных. При высоких скоростях вращения дисков (90 об/с) в зазоре между головкой и поверхностью образуется аэродинамическая подушка, и головка парит над магнитной поверхностью на высоте, составляющей несколько тысячных долей миллиметра. При изменении силы тока, протекающего через головку, происходит изменение напряженности динамического магнитного поля в зазоре, что вызывает изменения в стационарном магнитном поле ферромагнитных частиц, образующих покрытие диска. Так осуществляется запись данных на магнитный диск.

Операция считывания происходит в обратном порядке. Намагниченные частицы покрытия, проносящиеся на высокой скорости вблизи головки, наводят в ней ЭДС самоиндукции. Электромагнитные сигналы, возникающие при этом, усиливаются и передаются на обработку.

Управление работой жесткого диска выполняет специальное аппаратно-логическое устройство – контроллер жесткого диска. В прошлом оно представляло собой отдельную дочернюю плату, которую подключали к одному из свободных слотов материнской платы. В настоящее время функции контроллеров дисков выполняют микросхемы, входящие в микропроцессорный комплект (чипсет), хотя некоторые виды высокопроизводительных контроллеров жестких дисков по-прежнему поставляются на отдельной плате.

К основным параметрам жестких дисков относятся емкость и производительность. Емкость дисков зависит от технологии их изготовления. В настоящее время большинство производителей жестких дисков используют изобретенную компанией IBM технологию с использованием гигантского магниторезистивного эффекта (GMR – Giant Magnetic Resistance). Теоретический предел емкости одной пластины, исполненной по этой технологии, составляет порядка 20 Гбайт. В настоящее время достигнут технологический уровень 6,4 Гбайт на пластину, но развитие продолжается.

С другой стороны, производительность жестких дисков меньше зависит от технологии их изготовления. Сегодня все жесткие диски имеют очень высокий показатель скорости внутренней передачи данных (до 30-250 Мбайт/с), и потому их производительность в первую очередь зависит от характеристик интерфейса, с помощью которого они связаны с материнской платой. В зависимости от типа интерфейса разброс значений может быть очень большим: от нескольких Мбайт/с до 13-16 Мбайт/с для интерфейсов типа EIDE; до 80 Мбайт/с для интерфейсов типа SCSI-я от 50 Мбайт/с и более для наиболее современных интерфейсов типа IEEE 1394.

Кроме скорости передачи данных с производительностью диска напрямую связан параметр среднего времени доступа. Он определяет интервал времени, необходимый для поиска нужных данных, и зависит от скорости вращения диска. Для дисков, вращающихся с частотой 5400 об/мин, среднее время доступа составляет 9-10 мкс, для дисков с частотой 7200 об/мин – 7-8 мкс. Изделия более высокого уровня обеспечивают среднее время доступа к данным 5-6 мкс. Например, жесткий диск емкостью 18.2 Гб фирмы QUANTUM имеет скорость вращения дисков 7200 об/мин, время поиска – 8,5 мкс, скорость внутренней передачи данных – 235 Мбайт/с, размер буфера – 512 Кбайт.

Жесткий диск устанавливается в специальные монтажные отсеки внутри системного блока. Жесткий диск подключается прямо к материнской плате плоским 40 контактным кабелем. К одному кабелю можно подключить два жестких диска или один жесткий диск и один накопитель для чтения компакт-дисков (CD-ROM drive). Ранее для подключения жестких дисков применялись специальные платы расширения – мультикарты. На мультикартах располагались так же разъемы для подключения гибких дисков, разъемы (порты) COM1 и COM2 для подключения мыши, модема, сканера и LPT (от одного до трех) для подключения принтера. Сейчас все эти разъемы располагаются прямо на материнской плате.


Дисковод гибких дисков

Информация на жестком диске может храниться годами, однако иногда требуется ее перенос с одного компьютера на другой. Несмотря на свое название, жесткий диск является весьма хрупким прибором, чувствительным к перегрузкам, ударам и толчкам. Теоретически, переносить информацию с одного рабочего места на другое путем переноса жесткого диска возможно, и в некоторых случаях так и поступают, но все-таки этот прием считается нетехнологичным, поскольку требует особой аккуратности и определенной квалификации.

Для оперативного переноса небольших объемов информации используют так называемые гибкие магнитные диски (дискеты) (рис. 2.6), которые вставляют в специальный накопитель – дисковод (рис. 2.7). Приемное отверстие накопителя находится на лицевой панели системного блока. Правильное направление подачи гибкого диска отмечено стрелкой на его пластиковом кожухе.

Рис. 2.6. Дискета размером 3,5 дюйма емкостью 1,4 Мбайт | Рис. 2.7. Дисковод гибких дисков на 3,5 дюйма

Основными параметрами гибких дисков являются: технологический размер (измеряется в дюймах), плотность записи (измеряется в кратных единицах) и полная емкость.

Первый компьютер IBM PC (родоначальник платформы) был выпущен в 1981 году К нему можно было подключить внешний накопитель, использующий односторонние гибкие диски диаметром 5,25 дюйма. Емкость диска составляла 160 Кбайт. В следующем году появились аналогичные двусторонние диски емкостью 320 Кбайт. Начиная с 1984 года выпускались гибкие диски 5,25 дюйма высокой плотности (1,2 Мбайт). В наши дни диски размером 5,25 дюйма не используются, и соответствующие дисководы в базовой конфигурации персональных компьютеров после 1994 года не поставляются.

Гибкие диски размером 3,5 дюйма выпускают с 1980 года. Односторонний диск обычной плотности имел емкость 180 Кбайт, двусторонний – З60 Кбайт, а двусторонний двойной плотности – 720 Кбайт. Ныне стандартными считают диски размером 3,5 дюйма высокой плотности. Они имеют емкость 1440 Кбайт (1,4 Мбайт) и маркируются буквами HD (high density – высокая плотность).

С нижней стороны гибкий диск имеет центральную втулку, которая захватывается шпинделем дисковода и приводится во вращение. Магнитная поверхность прикрыта сдвигающейся шторкой для защиты от влаги, грязи и пыли. Если на гибком диске записаны ценные данные, его можно защитить от стирания и перезаписи, сдвинув защитную задвижку так, чтобы образовалось открытое отверстие. Для разрешения записи задвижку перемещают в обратную сторону и перекрывают отверстие. В некоторых случаях для безусловной защиты информации на диске задвижку выламывают физически, но и в этом случае разрешить запись на диск можно, если, например, заклеить образовавшееся отверстие тонкой полоской липкой ленты.

Гибкие диски считаются малонадежными носителями информации. Пыль, грязь, влага, температурные перепады и внешние электромагнитные поля очень часто становятся причиной частичной или полной утраты данных, хранившихся на гибком диске. Поэтому использовать гибкие диски в качестве основного средства хранения информации недопустимо. Их используют только для транспортировки информации или в качестве дополнительного (резервного) средства хранения.


Дисковод компакт-дисков CD-ROM

В период 1994-1995 годах в базовую конфигурацию персональных компьютеров перестали включать дисководы гибких дисков диаметром 5,25 дюйма, но вместо них стандартной стала считаться установка дисковода CD-ROM, имеющего такие же внешние размеры (рис. 2.8).

Рис. 2.8. Дисковод CD-ROM с производительностью 32x фирмы SAMSUNG

Аббревиатура CD-ROM (Compact Disc Read-Only Memory) переводится на русский язык как постоянное запоминающее устройство на основе компакт-диска. Принцип действия этого устройства состоит в считывании числовых данных с помощью лазерного луча, отражающегося от поверхности диска. Цифровая запись на компакт-диске отличается от записи на магнитных дисках очень высокой плотностью, и стандартный компакт-диск может хранить примерно 650 Мбайт данных.

Большие объемы данных характерны для мультимедийной информации (графика, музыка, видео), поэтому дисководы CD-ROM относят к аппаратным средствам мультимедиа. Программные продукты, распространяемые на лазерных дисках, называют мультимедийными изданиями. Сегодня мультимедийные издания завоевывают все более прочное место среди других традиционных видов изданий. Так, например, существуют книги, альбомы, энциклопедии и даже периодические издания (электронные журналы), выпускаемые на CD-ROM.

Основным недостатком стандартных дисководов CD-ROM является невозможность записи данных, но параллельно с ними существуют и устройства однократной записи CD-R (Compact Disk Recorder), и устройства многократной записи CD-RW.

Основным параметром дисководов CD-ROM является скорость чтения данных. Она измеряется в кратных долях. За единицу измерения принята скорость чтения в первых серийных образцах, составлявшая 150 Кбайт/с. Таким образом, дисковод с удвоенной скоростью чтения обеспечивает производительность 300 Кбайт/с, с учетверенной скоростью – 600 Кбайт/с и т. д. В настоящее время наибольшее распространение имеют устройства чтения CD-ROM с производительностью 32х-50х. Современные образцы устройств однократной записи имеют производительность 4х-8х, а устройств многократной записи – до 4х.


Видеокарта (видеоадаптер)

Совместно с монитором видеокарта (рис. 2.9) образует видеоподсистему персонального компьютера. Видеокарта не всегда была компонентом ПК. На заре развития персональной вычислительной техники в общей области оперативной памяти существовала небольшая выделенная экранная область памяти, в которую процессор заносил данные об изображении. Специальный контроллер экрана считывал данные об яркости отдельных точек экрана из ячеек памяти этой области и в соответствии с ними управлял разверткой горизонтального луча электронной пушки монитора.

Рис. 2.9. Видеокарта SpeedStar A50 фирмы Diamond

С переходом от черно-белых мониторов к цветным и с увеличением разрешения экрана (количества точек по вертикали и горизонтали) области видеопамяти стало недостаточно для хранения графических данных, а процессор перестал справляться с построением и обновлением изображения. Тогда и произошло выделение всех операций, связанных с управлением экраном, в отдельный блок, получивший название видеоадаптер. Физически видеоадаптер выполнен в виде отдельной дочерней платы, которая вставляется в один из слотов материнской платы и называется видеокартой. Видеоадаптер взял на себя функции видеоконтроллера, видеопроцессора и видеопамяти.

За время существования персональных компьютеров сменилось несколько стандартов видеоадаптеров: MDA (монохромный); CGA (4 цвета); EGA (16 цветов); VGA (256 цветов). В настоящее время применяются видеоадаптеры SVGA, обеспечивающие по выбору воспроизведение до 16,7 миллионов цветов с возможностью произвольного выбора разрешения экрана из стандартного ряда значений (640х480, 800х600,1024х768,1152х864; 1280х1024 точек и далее).

Разрешение экрана является одним из важнейших параметров видеоподсистемы. Чем оно выше, тем больше информации можно отобразить на экране, но тем меньше размер каждой отдельной точки и, тем самым, тем меньше видимый размер элементов изображения. Использование завышенного разрешения на мониторе малого размера приводит к тому, что элементы изображения становятся неразборчивыми и работа с документами и программами вызывает утомление органов зрения. Использование заниженного разрешения приводит к тому, что элементы изображения становятся крупными, но на экране их располагается очень мало. Если программа имеет сложную систему управления и большое число экранных элементов, они не полностью помещаются на экране. Это приводит к снижению производительности труда и неэффективной работе.

Таким образом, для каждого размера монитора существует свое оптимальное разрешение экрана, которое должен обеспечивать видеоадаптер. Так, например, для монитора 14" оптимальным является разрешение 640х480, для 15" – 800х600, а для 17" – 1024х768. Большинство современных прикладных и развлекательных программ рассчитаны на работу с разрешением экрана 800х600 и более. Именно поэтому сегодня наиболее популярный размер мониторов составляет 15 дюймов.

Цветовое разрешение (глубина цвета) определяет количество различных оттенков, которые может принимать отдельная точка экрана. Максимально возможное цветовое разрешение зависит от свойств видеоадаптера и, в первую очередь, от количества установленной на нем видеопамяти. Кроме того, оно зависит и от установленного разрешения экрана. При высоком разрешении экрана на каждую точку изображения приходится отводить меньше места в видеопамяти, так что информация о цветах вынужденно оказывается более ограниченной.

В зависимости от заданного экранного разрешения и глубины цвета необходимый объем видеопамяти можно определить по следующей формуле:

(т-п) – необходимый объем памяти видеоадаптера;

т – горизонтальное разрешение экрана (точек);

п – вертикальное разрешение экрана (точек);

b – разрядность кодирования цвета (бит).

Минимальное требование по глубине цвета на сегодняшний день – 256 цветов, хотя большинство программ требуют не менее 65 тыс. цветов (режим High Color). Наиболее комфортная работа достигается при глубине цвета 16,7 млн. цветов (режим True Color).

Работа в полноцветном режиме True Color с высоким экранным разрешением требует значительных размеров видеопамяти. Современные видеоадаптеры способны также выполнять функции обработки изображения, снижая нагрузку на центральный процессор ценой дополнительных затрат видеопамяти. Еще недавно типовыми считались видеоадаптеры с объемом памяти 2-4 Мбайт, но уже сегодня обычным считается объем 16 Мбайт.

Видеоускорение – одно из свойств видеоадаптера, которое заключается в том, что часть операций по построению изображений может происходить без выполнения математических вычислений в основном процессоре компьютера, а чисто аппаратным путем – преобразованием данных в микросхемах видеоускорителя. Видеоускорители могут входить в состав видеоадаптера (в таких случаях говорят о том, что видеокарта обладает функциями аппаратного ускорения), но могут поставляться в виде отдельной платы, устанавливаемой на материнской плате и подключаемой к видеоадаптеру.

Различают два типа видеоускорителей – ускорители плоской (2D) и трехмерной (3D) графики. Первые наиболее эффективны для работы с прикладными программами (обычно офисного применения) и оптимизированы для операционной системы Windows, а вторые ориентированы на работу мультимедийных развлекательных программ, в первую очередь компьютерных игр и профессиональных программ обработки трехмерной графики. Обычно в этих случаях используют разные математические принципы автоматизации графических операций, но существуют ускорители, обладающие функциями и двумерного, и трехмерного ускорения.


Звуковая карта

Звуковая карта явилась одним из наиболее поздних усовершенствований персонального компьютера. Она подключается к одному из слотов материнской платы в виде дочерней карты (см. рис. 2.10) и выполняет вычислительные операции, связанные с обработкой звука, речи, музыки. Звук воспроизводится через внешние звуковые колонки, подключаемые к выходу звуковой карты. Специальный разъем позволяет отправить звуковой сигнал на внешний усилитель. Имеется также разъем для подключения микрофона, что позволяет записывать речь или музыку и сохранять их на жестком диске для последующей обработки и использования.

Рис. 2.10. Звуковая карта YMF 724 фирмы Yamaha

Основным параметром звуковой карты является разрядность, определяющая количество битов, используемых при преобразовании сигналов из аналоговой в цифровую форму и наоборот. Чем выше разрядность, тем меньше погрешность, связанная с оцифровкой, тем выше качество звучания. Минимальным требованием сегодняшнего дня являются 16 разрядов, а наибольшее распространение имеют 32-разрядные и 64-разрядные устройства.

В области воспроизведения звука наиболее сложно обстоит дело со стандартизацией. Отсутствие единых централизованных стандартов привело к тому, что ряд фирм, занимающихся выпуском звукового оборудования, де-факто ввели в широкое использование свои внутрифирменные стандарты. Так, например, во многих случаях стандартными считают устройства, совместимые с устройством SoundBlaster, торговая марка на которое принадлежит компании Creative Labs.

В качестве внешних устройств, подключаемых к звуковой плате, используются колонки, наушники и микрофон. Колонки можно условно разделить на два вида: пассивные и активные. Пассивные подключаются так же как и наушники к выходу звуковой платы, не имеют встроенного усилителя, а следовательно звук можно регулировать только программно. Активные же колонки имеют встроенный усилитель и регуляторы уровня и тембра звука на передней панели (см. рис. 2.11).

Рис. 2. 11. Активные звуковые колонки SP-303 фирмы Genius мощностью 36Вт


Монитор

Монитор – устройство визуального представления данных (рис. 2.12, 2.13). Это не единственно возможное, но главное устройство вывода. Его основными потребительскими параметрами являются: размер и шаг маски экрана, максимальная частота регенерации изображения, класс защиты.

По способу формирования изображения мониторы делятся на жидкокристаллические (LCD) и построенные на основе электронно-лучевой трубки (CRT).

Рис. 2.12. CRT-монитор Samtron 17" фирмы Samsung | Рис. 2.13. Монитор LCD 15" Sony N50


Мониторы на электронно-лучевой трубке

Мониторы на электронно-лучевой трубке (CRT)

Изображение на экране монитора получается в результате облучения люминофорного покрытия остронаправленным пучком электронов, разогнанных в вакуумной колбе. Для получения цветного изображения люминофорное покрытие имеет точки или полоски трех типов, светящиеся красным, зеленым и синим цветом. Чтобы на экране все три луча сходились строго в одну точку и изображение было четким, перед люминофором ставят маску – панель с регулярно расположенными отверстиями или щелями. Часть мониторов оснащена маской из вертикальных проволочек, что усиливает яркость и насыщенность изображения. Чем меньше шаг между отверстиями или щелями (шаг маски), тем четче и точнее полученное изображение. Шаг маски измеряют в долях миллиметра. В настоящее время наиболее распространены мониторы с шагом маски 0,25-0,27 мм. Устаревшие мониторы могут иметь шаг до 0,43 мм, что негативно сказывается на органах зрения при работе с компьютером. Модели повышенной стоимости могут иметь значение менее 0,25 мм.

Рис. 2.12. CRT-монитор Samtron 17" фирмы Samsung

Одним из главных параметров монитора является частота кадровой развертки, называемой также частотой регенерации (обновления) изображения (частота смены изображения на экране). Она показывает, сколько раз в течение секунды монитор может полностью сменить изображение (поэтому ее также называют частотой кадров). Частоту регенерации изображения измеряют в герцах (Гц). Чем она выше, тем четче и устойчивее изображение, тем меньше утомление глаз, тем больше времени можно работать с компьютером непрерывно. Этот параметр зависит не только от монитора, но и от свойств и настроек видеоадаптера, хотя предельные возможности определяет все-таки монитор. При частоте регенерации порядка 60 Гц мелкое мерцание изображения заметно невооруженным глазом. Сегодня такое значение считается недопустимым. Минимальным считают значение 75 Гц, нормативным – 85 Гц и комфортным – 100 Гц и более. При работе с компьютером нужно помнить, что главная нагрузка приходится на зрение и если изображение будет дрожать на экране глаза будут сильно утомляться.

Размер монитора измеряется между противоположными углами трубки кинескопа по диагонали. Единица измерения – дюймы. Стандартные размеры: 14"; 15"; 17"; 19"; 20"; 21". В настоящее время наиболее универсальными являются мониторы размером 15 и 17 дюймов, а для операций с графикой желательны мониторы размером 19-21 дюйм.

Класс защиты монитора определяется стандартом, которому соответствует монитор с точки зрения требований техники безопасности. В настоящее время общепризнанными считаются следующие международные стандарты: MPR-II, ТСО-92, ТСО-95, ТСО-99 (приведены в хронологическом порядке). Стандарт MPR-II ограничил уровни электромагнитного излучения пределами, безопасными для человека. В стандарте ТСО-92 эти нормы были сохранены, а в стандартах TСО-95 и TСО-99 ужесточены. Эргономические и экологические нормы впервые появились в стандарте ТСО-95, а стандарт TСО-99 установил самые жесткие нормы по параметрам, определяющим качество изображения (яркость, контрастность, мерцание, антибликовые свойства покрытия).

Большинством параметров изображения, полученного на экране монитора, можно управлять программно. Программные средства, предназначенные для этой цели, обычно входят в системный комплект программного обеспечения.


Мониторы на жидких кристаллах

Мониторы на жидких кристаллах (LCD)

Мониторы на катодно-лучевой трубке (CRT) устареют в течение ближайших нескольких лет. Их место займут тонкие и плоские дисплеи на жидких кристаллах (см. рис. 2.13), до сих пор использовавшиеся в ноутбуках и компьютерах laptop.

Рис. 2.13. Монитор LCD 15" Sony N50

Основными достоинствами LCD-мониторов являются:

  • более живые и естественные цвета и образы;
  • отсутствие искривления экрана;
  • меньшее тепловое излучение;
  • потребление почти на 65% меньше энергии, чем CRT-мониторы;
  • отсутствие электромагнитного излучения (полностью безопасны для здоровья);
  • вес примерно в два раза меньше традиционных мониторов
  • занимаемая площадь на столе почти в два раза меньше, чем у CRT-мониторов. LCD-дисплеи настолько тонки, что их можно крепить к стене.

Сейчас используется два типа LCD-технологии для создания изображения на экране: активноматричная, также называемая технологией на тонкопленочных транзисторах (TFT), и пассивноматричная, или матрица с двойным сканированием (DSTN). Более популярными являются активноматричные дисплеи.

Единственный показатель по которому LCD-мониторы проигрывают CRT-мониторам – это цена. Жидкокристаллический дисплей 15" продается по цене около 400 - 500 долларов. Тогда как обычный 15" монитор стоит от 150 до 200 долларов. Однако цены падают. Постоянно увеличивающийся спрос должен постепенно снизить цены.


Клавиатура

Клавиатура – клавишное устройство управления персональным компьютером. Служит для ввода алфавитно-цифровых (знаковых) данных, а также команд управления. Комбинация монитора и клавиатуры обеспечивает простейший интерфейс пользователя. С помощью клавиатуры управляют компьютерной системой, а с помощью монитора получают от нее отклик.

Известно два типа клавиатур – клавиатура с механическими и мембранными переключателями. Переключатель первого типа это обычный механический датчик, традиционное устройство известное уже несколько десятилетий. Второй тип датчика устроен несколько сложнее. Переключатель данного типа представляет из себя набор мембран, при нажатии на клавишу верхняя мембрана прогибается и через специальное отверстие в изолирующей мембране замыкается на нижнюю мембрану. Как правило, предпочтение отдается клавиатуре с механическими датчиками. Они выдерживают многолетнюю эксплуатацию, надежны и поддаются ремонту в случае необходимости.

Принцип действия. Клавиатура относится к стандартным средствам персонального компьютера. Ее основные функции не нуждаются в поддержке специальными системными программами (драйверами). Необходимое программное обеспечение для начала работы с компьютером уже имеется в микросхеме ПЗУ в составе базовой системы ввода-вывода (BIOS), и потому компьютер реагирует на нажатия клавиш сразу после включения.

Физически клавиатура и процессор связаны только двумя проводами, контролер процессора сканирует переключатели клавиш и при нажатии на любую клавишу по этим двум проводам передается уникальный скан-код размером один байт. Когда скан-код попадает в процессор инициализируется аппаратное прерывание IRQ 9(Interrupt 9, Int9). Скан-код анализируется процессором и преобразуется в код символа. Далее полученный код символа помещается в небольшую область памяти, известную как буфер клавиатуры. Введенный символ хранится в буфере клавиатуры до тех пор, пока его не заберет оттуда та программа, для которой он и предназначался, например текстовый редактор или текстовый процессор. Если символы поступают в буфер чаще, чем забираются оттуда, наступает эффект переполнения буфера. В этом случае ввод новых символов на некоторое время прекращается. На практике в этот момент при нажатии на клавишу мы слышим предупреждающий звуковой сигнал и не наблюдаем ввода данных.

Из данного объяснения ясно, что каждой клавише присвоен уникальный цифровой код и существуют специальные таблицы кодировки клавиатуры. Например, кодовая таблица США имеет номер 437 (как правило, она записана в специальную микросхему – знакогенератор процессора), а кодовая страница России имеет номер 866. Для смены кодировки клавиатуры применяются специальные программы – клавиатурные драйверы. Современные клавиатуры способны не только передавать данные в процессор, но и воспринимать команды от него.

Состав клавиатуры. Стандартная клавиатура имеет более 100 клавиш, функционально распределенных по нескольким группам (см. рис. 2.14)

Группа алфавитно-цифровых клавши предназначена для ввода знаковой информации и команд, набираемых по буквам. Каждая клавиша может работать в нескольких режимах (регистрах) и, соответственно, может использоваться для ввода нескольких символов. Переключение между нижним регистром (для ввода строчных символов) и верхним регистром (для ввода прописных символов) выполняют удержанием клавиши SHIFT (нефиксированное переключение). При необходимости жестко переключить регистр используют клавишу CAPS LOCK (фиксированное переключение). Если клавиатура используется для ввода данных, абзац закрывают нажатием клавиши ENTER. При этом автоматически начинается ввод текста с новой строки. Если клавиатуру используют для ввода команд, клавишей ENTER завершают ввод команды и начинают ее исполнение.

Функциональные клавиши

Дополнительная панель

Алфавитно-цифровые клавиши

Клавиши управления курсором

Рис. 2.14. Группы клавиш стандартной клавиатуры

Для разных языков существуют различные схемы закрепления символов национальных алфавитов за конкретными алфавитно-цифровыми клавишами. Такие схемы называются раскладками клавиатуры. Переключения между различными раскладками выполняются программным образом – это одна из функций операционной системы. Соответственно, способ переключения зависит от того, в какой операционной системе работает компьютер. Например, в системе Windows 98 для этой цели могут использоваться следующие комбинации: левая клавиша ALT+SHIFT или CTRL+SHIFT. При работе с другой операционной системой способ переключения можно установить по справочной системе той программы, которая выполняет переключение.

Общепринятые раскладки клавиатуры имеют свои корни в раскладках клавиатур пишущих машинок. Для персональных компьютеров IBM PC типовыми считаются раскладки QWERTY (английская) и ЙЦУКЕНГ (русская). Раскладки принято именовать по символам, закрепленным за первыми клавишами верхней строки алфавитной группы.

Группа функциональных клавиш включает двенадцать клавиш (от F1 до F12), размещенных в верхней части клавиатуры. Функции, закрепленные за данными клавишами, зависят от свойств конкретной работающей в данный момент программы, а в некоторых случаях и от свойств операционной системы. Общепринятым для большинства программ является соглашение о том, что клавиша F1 вызывает справочную систему, в которой можно найти справку о действии прочих клавиш.

Служебные клавиши располагаются рядом с клавишами алфавитно-цифровой группы. В связи с тем, что ими приходится пользоваться особенно часто, они имеют увеличенный размер. К ним относятся рассмотренные выше клавиши SHIFT и ENTER, регистровые клавиши ALT и CTRL (их используют в комбинации с другими клавишами для формирования команд), клавиша TAB (для ввода позиций табуляции при наборе текста), клавиша ESC (от английского слова Escape) для отказа от исполнения последней введенной команды и клавиша BACKSPACE для удаления только что введенных знаков (она находится над клавишей ENTER и часто маркируется стрелкой, направленной влево).

Служебные клавиши PRINT SCREEN, SCROLL LOCK и PAUSE/BREAK размещаются справа от группы функциональных клавиш и выполняют специфические функции, зависящие от действующей операционной системы. Общепринятыми являются следующие действия:

PRINT SCREEN – печать текущего состояния экрана на принтере (для MS-DOS) или сохранение его в специальной области оперативной памяти, называемой буфером обмена (для Windows).

SCROLL LOCK – переключение режима работы в некоторых (как правило, устаревших) программах.

PAUSE/BREAK – приостановка/прерывание текущего процесса.

Две группы клавиш управления курсором расположены справа от алфавитно-цифровой панели.

Курсором называется экранный элемент, указывающий место ввода знаковой информации. Курсор используется при работе с программами, выполняющими ввод данных и команд с клавиатуры. Клавиши управления курсором позволяют управлять позицией ввода.

Четыре клавиши со стрелками выполняют смещение курсора в направлении, указанном стрелкой. Действие прочих клавиш описано ниже.

PAGE UP/PAGE DOWN – перевод курсора на одну страницу вверх или вниз. Понятие «страница» обычно относится к фрагменту документа, видимому на экране. В графических операционных системах (например Windows) этими клавишами выполняют «прокрутку» содержимого в текущем окне. Действие этих клавиш во многих программах может быть модифицировано с помощью служебных регистровых клавиш, в первую очередь SHIFT и CTRL Конкретный результат модификации зависит от конкретной программы и/или операционной системы.

Клавиши HOME и END переводят курсор в начало или конец текущей строки, соответственно. Их действие также модифицируется регистровыми клавишами.

Традиционное назначение клавиши INSERT состоит в переключении режима ввода данных (переключение между режимами вставки и замены). Если текстовый курсор находится внутри существующего текста, то в режиме вставки происходит ввод новых знаков без замены существующих символов (текст как бы раздвигается). В режиме замены новые знаки заменяют текст, имевшийся ранее в позиции ввода.

В современных программах действие клавиши INSERT может быть иным. Конкретную информацию следует получить в справочной системе программы. Возможно, что действие этой клавиши является настраиваемым, – это также зависит от свойств конкретной программы.

Клавиша DELETE предназначена для удаления знаков, находящихся справа от текущего положения курсора. При этом положение позиции ввода остается неизменным.

Группа клавиш дополнительной панели дублирует действие цифровых и некоторых знаковых клавиш основной панели. Во многих случаях для использования этой группы клавиш следует предварительно включать клавишу-переключатель NUM LOCK (о состоянии переключателей NUM LOCK, CAPS LOCK и SCROLL LOCK можно судить по светодиодным индикаторам, обычно расположенным в правом верхнем углу клавиатуры).

Появление дополнительной панели клавиатуры относится к началу 80-х годов. В то время клавиатуры были относительно дорогостоящими устройствами. Первоначальное назначение дополнительной панели состояло в снижении износа основной панели при проведении расчетно-кассовьк вычислений, а также при управлении компьютерными играми (при выключенном переключателе NUM LOCK клавиши дополнительной панели могут использоваться в качестве клавиш управления курсором).

Настройка клавиатуры. Клавиатуры персональных компьютеров обладают свойством повтора знаков, которое используется для автоматизации процесса ввода. Оно состоит в том, что при длительном удержании клавиши начинается автоматический ввод связанного с ней кода. При этом настраиваемыми параметрами являются:

  • интервал времени после нажатия, по истечении которого начнется автоматический повтор кода;
  • темп повтора (количество знаков в секунду).

Средства настройки клавиатуры относятся к системным и обычно входят в состав операционной системы. Кроме параметров режима повтора настройке подлежат также используемые раскладки и органы управления, используемые для переключения раскладок.

Со средствами настройки клавиатуры мы познакомимся при изучении функций операционной системы.

Специальные клавиатуры. Клавиатура является основным устройством ввода данных. Специальные клавиатуры предназначены для повышения эффективности процесса ввода данных. Это достигается путем изменения формы клавиатуры, раскладки ее клавиш или метода подключения к системному блоку.

Клавиатуры, имеющие специальную форму, рассчитанную с учетом требований эргономики, называют эргономичными клавиатурами. Их целесообразно применять на рабочих местах, предназначенных для ввода большого количества знаковой информации. Эргономичные клавиатуры не только повышают производительность наборщика и снижают общее утомление в течение рабочего дня, но и снижают вероятность и степень развития ряда заболеваний, например туннельного синдрома кистей рук и остеохондроза верхних отделов позвоночника.

Раскладка клавиш стандартных клавиатур далека от оптимальной. Она сохранилась со времен ранних образцов механических пишущих машин. В настоящее время существует техническая возможность изготовления клавиатур с оптимизированной раскладкой, и существуют образцы таких устройств (в частности, к ним относится клавиатура Дворака). Однако практическое внедрение клавиатур с нестандартной раскладкой находится под вопросом в связи с тем, что работе с ними надо учиться специально. На практике подобными клавиатурами оснащают только специализированные рабочие места.

По методу подключения к системному блоку различают проводные и беспроводные клавиатуры. Передача информации в беспроводных системах осуществляется инфракрасным лучом. Обычный радиус действия таких клавиатур составляет несколько метров. Источником сигнала является клавиатура.


Мышь

Мышь – устройство управления манипуляторного типа. Представляет собой плоскую коробочку с двумя-тремя кнопками (рис. 2.15). Перемещение мыши по плоской поверхности синхронизировано с перемещением графического объекта (указателя мыши) на экране монитора.

Рис. 2.15. Устройство управления манипуляторного типа Logitech Pilot Wheel Mouse

Принцип действия. В отличие от рассмотренной ранее клавиатуры, мышь не является стандартным органом управления, и персональный компьютер не имеет для нее выделенного порта. Для мыши нет и постоянного выделенного прерывания, а базовые средства ввода и вывода (BIOS) компьютера, размещенные в постоянном запоминающем устройстве (ПЗУ), не содержат программных средств для обработки прерываний мыши.

В связи с этим в первый момент после включения компьютера мышь не работает. Она нуждается в поддержке специальной системной программы – драйвера мыши. Драйвер устанавливается либо при первом подключении мыши, либо при установке операционной системы компьютера. Хотя мышь и не имеет выделенного порта на материнской плате, для работы с ней используют один из стандартных портов, средства для работы с которыми имеются в составе BIOS. Драйвер мыши предназначен для интерпретации сигналов, поступающих через порт. Кроме того, он обеспечивает механизм передачи информации о положении и состоянии мыши операционной системе и работающим программам.

Компьютером управляют перемещением мыши по плоскости и кратковременными нажатиями правой и левой кнопок (Эти нажатия называются щелчками.) В отличие от клавиатуры мышь не может напрямую использоваться для ввода знаковой информации – ее принцип управления является событийным. Перемещения мыши и щелчки ее кнопок являются событиями с точки зрения ее программы-драйвера. Анализируя эти события, драйвер устанавливает, когда произошло событие и в каком месте экрана в этот момент находился указатель. Эти данные передаются в прикладную программу, с которой работает пользователь в данный момент. По ним программа может определить команду, которую имел в виду пользователь, и приступить к ее исполнению.

Комбинация монитора и мыши обеспечивает наиболее современный тип интерфейса пользователя, который называется графическим. Пользователь наблюдает на экране графические объекты и элементы управления. С помощью мыши он изменяет свойства объектов и приводит в действие элементы управления компьютерной системой, а с помощью монитора получает от нее отклик в графическом виде.

Стандартная мышь имеет только две кнопки, хотя существуют нестандартные мыши с тремя кнопками или с двумя кнопками и одним вращающимся регулятором. В последнее время все большее распространение получают мыши с колесиком прокрутки, расположенным между двумя кнопками и позволяющим выполнять прокрутку в любых приложениях Windows (см. рис. 11). Функции нестандартных органов управления определяются тем программным обеспечением, которое поставляется вместе с устройством.

К числу регулируемых параметров мыши относятся: чувствительность (выражает величину перемещения указателя на экране при заданном линейном перемещении мыши), функции левой и правой кнопок, а также чувствительность к двойному нажатию (максимальный интервал времени, при котором два щелчка кнопкой мыши расцениваются как один двойной щелчок). Программные средства, предназначенные для этих регулировок, обычно входят в системный комплект программного обеспечения – мы рассмотрим их при изучении операционной системы.

Специальные манипуляторы. Кроме обычной мыши существуют и другие типы манипуляторов, например: трекболы, пенмаусы, инфракрасные мыши.

Трекбол в отличие от мыши устанавливается стационарно, и его шарик приводится в движение ладонью руки. Преимущество трекбола состоит в том, что он не нуждается в гладкой рабочей поверхности, поэтому трекболы нашли широкое применение в портативных персональных компьютерах.

Пенмаус представляет собой аналог шариковой авторучки, на конце которой вместо пишущего узла установлен узел, регистрирующий величину перемещения.

Инфракрасная мышь отличается от обычной наличием устройства беспроводной связи с системным блоком.

Для компьютерных игр и в некоторых специализированных имитаторах применяют также манипуляторы рычажно-нажимного типа (джойстики) и аналогичные им джой-пады, геймпады и штурвально-педальные устройства. Устройства этого типа подключаются к специальному порту, имеющемуся на звуковой карте, или к порту USB.


2.2. Периферийные устройства персонального компьютера

Периферийные устройства персонального компьютера подключаются к его интерфейсам и предназначены для выполнения вспомогательных операций. Благодаря им компьютерная система приобретает гибкость и универсальность.

По назначению периферийные устройства можно подразделить на:

  • устройства ввода данных;
  • устройства вывода данных;
  • устройства хранения данных;
  • устройства обмена данными.


Устройства ввода графических данных

Для ввода графической информации используют сканеры, графические планшеты (дигитайзеры) и цифровые фотокамеры. Интересно отметить, что с помощью сканеров можно вводить и знаковую информацию. В этом случае исходный материал вводится в графическом виде, после чего обрабатывается специальными программными средствами (программами распознавания образов),

Планшетные сканеры. Планшетные сканеры предназначены для ввода графической информации с прозрачного или непрозрачного листового материала (рис. 2.16). Принцип действия этих устройств состоит в том, что луч света, отраженный от поверхности материала (или прошедший сквозь прозрачный материал), фиксируется специальными элементами, называемыми приборами с зарядовой связью (ПЗС). Обычно элементы ПЗС конструктивно оформляют в виде линейки, располагаемой по ширине исходного материала. Перемещение линейки относительно листа бумаги выполняется механическим протягиванием линейки при неподвижной установке листа или протягиванием листа при неподвижной установке линейки.

Рис. 2.16. Планшетный сканер ScanJet 3200C с аппаратным разрешением 600х1200 dpi фирмы Hewlett Packard

Основными потребительскими параметрами планшетных сканеров являются:

  • разрешающая способность;
  • производительность;
  • динамический диапазон;
  • максимальный размер сканируемого материала.

Разрешающая способность планшетного сканера зависит от плотности размещения приборов ПЗС на линейке, а также от точности механического позиционирования линейки при сканировании. Типичный показатель для офисного применения: 600-1200 dpi (dpi – dots per inch – количество точек на дюйм). Для профессионального применения характерны показатели 1200-3000 dpi.

Производительность сканера определяется продолжительностью сканирования листа бумаги стандартного формата и зависит как от совершенства механической части устройства, так и от типа интерфейса, использованного для сопряжения с компьютером.

Динамический диапазон определяется логарифмом отношения яркости наиболее светлых участков изображения к яркости наиболее темных участков. Типовой показатель для сканеров офисного применения составляет 1,8-2,0, а для сканеров профессионального применения – от 2,5 (для непрозрачных материалов) до 3,5 (для прозрачных материалов).

Ручные сканеры. Принцип действия ручных сканеров в основном соответствует планшетным. Разница заключается в том, что протягивание линейки ПЗС в данном случае выполняется вручную. Равномерность и точность сканирования при этом обеспечиваются неудовлетворительно, и разрешающая способность ручного сканера составляет 150-300 dpi.

Барабанные сканеры. В сканерах этого типа исходный материал закрепляется на цилиндрической поверхности барабана, вращающегося с высокой скоростью. Устройства этого типа обеспечивают наивысшее разрешение (2400-5000 dpi) благодаря применению не ПЗС, а фотоэлектронных умножителей. Их используют для сканирования исходных изображений, имеющих высокое качество, но недостаточные линейные размеры (фотонегативов, слайдов и т. п.)

Сканеры форм. Предназначены для ввода данных со стандартных форм, заполненных механически или <от руки». Необходимость в этом возникает при проведении переписей населения, обработке результатов выборов и анализе анкетных данных.

От сканеров форм не требуется высокой точности сканирования, но быстродействие играет повышенную роль и является основным потребительским параметром.

Штрих-сканеры. Эта разновидность ручных сканеров предназначена для ввода данных, закодированных в виде штрих-кода. Такие устройства имеют применение в розничной торговой сети.

Графические планшеты (дигитайзеры). Эти устройства предназначены для ввода художественной графической информации. Существует несколько различных принципов действия графических планшетов, но в основе всех их лежит фиксация перемещения специального пера относительно планшета. Такие устройства удобны для художников и иллюстраторов, поскольку позволяют им создавать экранные изображения привычными приемами, наработанными для традиционных инструментов (карандаш, перо, кисть). К техническим характеристикам планшетам относятся: разрешающая способность (линий/мм), площадь рабочей области и количество уровней чувствительности к нажатию пера. На рис. 2.17 показан дигитайзер фирмы AIPTEK INK формата А6 с 512 уровнями чувствительности к нажатию пера.

Рис. 2.17. Дигитайзер HYPER Pen 5000 фирмы AIPTEK INK

Цифровые фото- и видеокамеры. Как и сканеры, эти устройства воспринимают графические данные с помощью приборов с зарядовой связью, объединенных в прямоугольную матрицу. Основным параметром цифровых фотоаппаратов является разрешающая способность, которая напрямую связана с количеством ячеек ПЗС в матрице. Наилучшие потребительские модели в настоящее время имеют до 1 млн. ячеек ПЗС и, соответственно, обеспечивают разрешение изображения до 800х1200 точек. У профессиональных моделей эти параметры выше. На рис. 2.18 показан недорогой фотоаппарат фирмы Mustek с оптическим разрешением 640х480 пикселей.

Рис. 2. 18. Цифровая фотокамера VDC-200 фирмы Mustek

Основные параметры видеокамер рассмотрим на примере камеры фирмы Mustek, представленной на рис. 19. Разрешение: 356х292 (HxV). Скорость передачи данных: 353х282, 16 бит цвета (сжатие), 20 кадров/с. Скорость передачи данных: 176x144, 16 бит цвета (сжатие), 30 кадров/с. Настройка фокусного расстояния: ручная. Экспозиция и баланс белого: автоматическая. Угол обзора ± 39°.

Основные параметры видеокамер рассмотрим на примере камеры фирмы Mustek, представленной на рис. 2.19. Разрешение: 356х292 (HxV). Скорость передачи данных: 353х282, 16 бит цвета (сжатие), 20 кадров/с. Скорость передачи данных: 176x144, 16 бит цвета (сжатие), 30 кадров/с. Настройка фокусного расстояния: ручная. Экспозиция и баланс белого: автоматическая. Угол обзора ± 39°.

Рис. 2.19. Цифровая видеокамера фирмы Mustek


Устройства хранения данных

Необходимость во внешних устройствах хранения данных возникает в двух случаях:

  • когда на вычислительной системе обрабатывается больше данных, чем можно разместить на базовом жестком диске;
  • когда данные имеют повышенную ценность и необходимо выполнять регулярное резервное копирование на внешнее устройство (копирование данных на жестком диске не является резервным и только создает иллюзию безопасности).

В настоящее время для внешнего хранения данных используют несколько типов устройств, использующих магнитные или магнитооптические носители.

Стримеры. Стримеры – это накопители на магнитной ленте. Их отличает сравнительно низкая цена. К недостаткам стримеров относят малую производительность (она связана прежде всего с тем, что магнитная лента – это устройство последовательного доступа) и недостаточную надежность (кроме электромагнитных наводок, ленты стримеров испытывают повышенные механические нагрузки и могут физически выходить из строя).

Емкость магнитных кассет (картриджей) для стримеров составляет до нескольких сот Мбайт. Дальнейшее повышение емкости за счет повышения плотности записи снижает надежность хранения, а повышение емкости за счет увеличения длины ленты сдерживается низким временем доступа к данным.

ZIP-накопители. ZIP-накопители выпускаются компанией Iomega, специализирующейся на создании внешних устройств для хранения данных. Устройство работает с дисковыми носителями, по размеру незначительно превышающими стандартные гибкие диски и имеющими емкость 100/250 Мбайт. ZIP-накопители выпускаются во внутреннем и внешнем исполнении. В первом случае их подключают к контроллеру жестких дисков материнской платы, а во втором – к стандартному параллельному порту, что негативно сказывается на скорости обмена данными.

Накопители HiFD. Основным недостатком ZIP-накопителей является отсутствие их совместимости со стандартными гибкими дисками 3,5 дюйма. Такой совместимостью обладают устройства HiFD компании Sony. Они позволяют использовать как специальные носители емкостью 200 Мбайт, так и обычные гибкие диски. В настоящее время распространение этих устройств сдерживается повышенной ценой.

Накопители JAZ. Этот тип накопителей, как и ZIP-накопители, выпускается компанией Iomega. По своим характеристикам JAZ-носитель приближается к жестким дискам, но в отличие от них является сменным. В зависимости от модели накопителя на одном диске можно разместить 1 или 2 Гбайт данных.

Магнитооптические устройства. Эти устройства получили широкое распространение в компьютерных системах высокого уровня благодаря своей универсальности. С их помощью решаются задачи резервного копирования, обмена данными и их накопления. Однако достаточно высокая стоимость приводов и носителей не позволяет отнести их к устройствам массового спроса.

В этом секторе параллельно развиваются 5,25- и 3,5-дюймовые накопители, носители для которых отличаются в основном форм-фактором и емкостью. Последнее поколение носителей формата 5,25" достигает емкости 5,2 Гбайт. Стандартная емкость для носителей 3,5" – 640 Мбайт.

В формате 3,5" недавно была разработана новая технология GIGAMO, обеспечивающая емкость носителей в 1,3 Гбайт, полностью совместимая сверху вниз с предыдущими стандартами. В перспективе ожидается появление накопителей и дисков форм-фактора 5,25", поддерживающих технологию NFR (Near Field Recording), которая обеспечит емкость дисков до 20 Гбайт, а позднее и до 40 Гбайт.


Устройства обмена данными

Модем. Устройство, предназначенное для обмена информацией между удаленными компьютерами по каналам связи, принято называть модемом (МОдулятор + ДЕМодулятор) (см. рис. 2.23). При этом под каналом связи понимают физические линии (проводные, оптоволоконные, кабельные, радиочастотные), способ их использования (коммутируемые и выделенные) и способ передачи данных (цифровые или аналоговые сигналы). В зависимости от типа канала связи устройства приема-передачи подразделяют на радиомодемы, кабельные модемы и прочие. Наиболее широкое применение нашли модемы, ориентированные на подключение к коммутируемым телефонным каналам связи.

Цифровые данные, поступающие в модем из компьютера, преобразуются в нем путем модуляции (по амплитуде, частоте, фазе) в соответствии с избранным стандартом (протоколом) и направляются в телефонную линию. Модем-приемник, понимающий данный протокол, осуществляет обратное преобразование (демодуляцию) и пересылает восстановленные цифровые данные в свой компьютер. Таким образом обеспечивается удаленная связь между компьютерами и обмен данными между ними.

К основным потребительским параметрам модемов относятся:

  • производительность (бит/с);
  • поддерживаемые протоколы связи и коррекции ошибок;
  • шинный интерфейс, если модем внутренний (ISA или РСI).

От производительности модема зависит объем данных, передаваемых в единицу времени. От поддерживаемых протоколов зависит эффективность взаимодействия данного модема с сопредельными модемами (вероятность того, что они вступят во взаимодействие друг с другом при оптимальных настройках). От шинного интерфейса в настоящее время пока зависит только простота установки и настройки модема (в дальнейшем при общем совершенствовании каналов связи шинный интерфейс начнет оказывать влияние и на производительность).

По способу подключения модемы делятся на два вида: внешние и внутренние. Внешний модем подключается к одному из COM-портов. Внутренний вставляется внутрь системного блока в виде платы расширения. На рис. 2.23 представлены внешний и внутренний факс/модемы Courier V.34 фирмы US Robotics.

Рис. 2.23. Внешний и внутренний факс/модемы Courier V.34 фирмы US Robotics


2.6. Библиографический список

1. Фигурнов В.Э. IBM PC для пользователя. Краткий курс. – М.:ИНФРА-М, 1999. – 480 с.

2. Информатика. Базовый курс / Симонович С.В. и др. – СПб.: Питер, 1999. – 640 с.

3. Гук М. Аппаратные средства PC:Энциклопедия. – СПб.: Питер, 1999. – 816 с.

4. Мир ПК. № 1-12, 1999.

5. iXBT. ЭНЦИКЛОПЕДИЯ КОМПЬЮТЕРНОГО ЖЕЛЕЗА.
URL: http://ixbt.stack.net

6. ЭНЦИКЛОПЕДИЯ Кирилла и Мефодия
URL: http://www.km.ru/pc/main.asp

7. INTEROPTORG. Расходники. Компьютеры. Техописания.
URL: http://www.interoptorg.ru


2.4. Глоссарий

2.5. Глоссарий

АТХ – новый тип материнской (системной) платы компьютера. Требует специального корпуса системного блока;

baby AT case – настольный (горизонтальный) тип корпуса системного блока компьютера уменьшенного размера по горизонтали.

BIOS – программы операционной системы, хранящиеся в постоянной памяти компьютера (ROM). В настоящее время чаще всего используются BIOS фирм AMI, AWARD, PHOENIX и т.д.

cache (кэш) – сверхбыстрый буфер для хранения данных, располагающийся «между» процессором и оперативной памятью. Наличие кэша может увеличить производительность компьютера на 10-15%. Размер кэша определяет его эффективность, типичный размер – от 32 до 256 Кбайт.

САМ (color active matrix) – цветная активная матрица – наиболее качественный тип цветного дисплея портативного компьютера. Обеспечивает яркие и насыщенные цвета, но дороже дисплея с пассивной матрицей двойного сканирования (СРМ, DS).

CD-Recorder – устройство для записи на диски CD-R.

CD-ROM – компакт-диск, иногда – дисковод для воспроизведения информации, записанной на компакт-дисках.

Cps (character per second) – число символов в секунду (скорость печати у матричных и струйных принтеров, скорость передачи данных модемом и т.д.).

DIMM – тип микросхем памяти (dual in-line memory module). Наиболее быстродействующие микросхемы памяти типа SDRAM для компьютеров. Ввыполняются в формате DIMM со 168 контактами.

dot – точка. Применительно к дисплею обычно указывается ее размер.

dpi – число точек на дюйм (обычно – разрешающая способность принтера или иного устройства).

DRAM – динамическая память, наиболее часто применяемый тип устройства микросхем памяти.

EDO – (extended data output) – тип микросхем динамической памяти, обеспечивающий несколько более быстрый обмен с оперативной памятью, чем при использовании обычных микросхем (FPM DRAM).

fax-modem (факс-модем) – устройство, сочетающее возможности телефакса и модема.

FD (Floppy Disk) – гибкий диск (дискета).

FDD (Floppy Disk Drive) – дисковод для гибких дисков (дискет). Обычно до или после этого сокращения указывается максимальная емкость дискет: 1,2 Мбайт или 360 Кбайт для дисководов для пятидюймовых дискет, 1,44 Мбайт или 720 Кбайт для дисководов для трехдюймовых дискет.

Flash – флэш-память, вид оперативной памяти, хранящий информацию даже при отключении электропитания. Дорог, а потому используется как ROM, но с возможностью модернизации (например, для хранения BIOS, микропрограмм модема или принтера и т.д.).

HDD (Hard Disk Drive) – жесткий диск (винчестер).

IDE – тип интерфейса устройств компьютера (жестких дисков и др.).

InkJet printer– струйный принтер, т.е. принтер, создающий изображение путем напыления на бумагу капель специальных чернил.

ISA – тип шины передачи данных внутри компьютера, используемый в большинстве персональных компьютеров для взаимодействия с низкоскоростными устройствами.

laptop (лэптоп) – портативный компьютер «наколенного» формата. Обычно такой компьютер может переноситься, как небольшой чемоданчик. Типичный вес – от 4 до 10 кг.

laser printer – лазерный принтер, т.е. принтер, в котором формирование изображения выполняется с помощью лазера.

LPT – обозначение параллельного порта, Обычно имеете? в виду, что устройство подключается к параллельному порту.'''

matrix printer – матричный принтер – самый распространенный и дешевый тип принтеров. Он обеспечивает средние качество и скорость печати.

MHz (МГц) – мегагерц (обычно обозначает тактовую частоту микропроцессора компьютера).

mini-tower – мини-башня, «башенный» (вертикальный) тип корпуса системного блока компьютера уменьшенной высоты.

modem (модем) – устройство для передачи данных между компьютерами через телефонную сеть. Обычно для модема указывается его максимальная скорость работы (в бодах, т.е. битах в секунду), а также поддерживаемые им стандарты передачи данных.

motherboard (материнская плата, системная плата) – главная плата компьютера, содержащая основной микропроцессор, сопроцессор (если он есть), память и т.д.

MPEG – тип сжатия видеоданных. Используется в видеодисках. MPEG-плейер – устройство или программа, позволяющая воспроизводить видеофильмы, записанные в формате MPEG. Чаще всего имеется в виду тип сжатия MPEG-1, обеспечивающий вывод изображения с разрешением 320х240 точек с частотой 30 кадров в секунду (качество, соответствующее бытовому видеомагнитофону VHS).

MPR-II – стандарт на излучение мониторов, обеспечивающий их безвредность для здоровья пользователей. Желательно приобретать только те мониторы, которые удовлетворяют стандарту MPR-II (а если они удовлетворяют стандартам ТСО-92 и/или ТСО-95 – еще лучше).

notebook (ноутбук) – портативный компьютер «книжного» формата, обычный размер – 30х21х3-4 см, вес – 2-4 кг.

OEM – изготовитель оборудования. Обычно имеется в виду комплектация чего-либо для производителей оборудования (без документации, красивой коробки и т.д.).

Plug and Play – подключай и работай, тип устройств с облегченной (автоматической или полуавтоматической) настройкой прим подключении к компьютеру.

PC – персональный компьютер (personal computer).

РСI – вид шины передачи данных, используемый для работы с высокоскоростными устройствами. Применяется практически во всех современных компьютерах.

ppm (pages per minute) – число страниц в минуту (скорость печати).

PS/2 – серия персональных компьютеров, выпускаемых фирмой IBM.

RAM (ОЗУ) – оперативная память (Random Access Memory). Размер оперативной памяти измеряется в мегабайтах (М, Мб, Mb) или килобайтах (К, Кб, Kb). Типичный размер – от 1 Мбайта до 64 Мбайт.

ROM (Read Only Memory, ПЗУ) – память в компьютере, доступная только для чтения, содержит программы тестирования компьютера, часть операционной системы (BIOS) и т.д.

scanner (сканер) – устройство для ввода изображений в компьютер.

SCSI – стандарт интерфейса устройств SCSI, обеспечивающий высокую скорость обмена данных. Используется в основном в компьютерах, в которых требуется обеспечить большую скорость обработки данных, серверах локальных сетей и т.д.

serial port – последовательный порт (используется для подключения мыши, внешних модемов и т.д.).

SIMM – наиболее часто используемый тип микросхем памяти (single in-line memory module) с расположением контактов на одной стороне микросхемы. В основном используются 72-контактные SIMM.

SDRAM (Synchronous DRAM) – синхронизируемая динамическая оперативная память, быстродействующий вариант оперативной памяти, применяется в основном в дорогих высокопроизводительных компьютерах.

streamer (стример) – устройство для записи данных на специальные кассеты с магнитной лентой, обычно используемое для создания резервных копий данных. Для стримеров часто указывается максимальный объем данных на кассете (60 Мбайт, 8 Гбайт и т.д.).

SVGA (SuperVGA) – адаптеры дисплеев, обеспечивающие как возможности адаптера VGA, так и работу в графическом режиме с разрешением 800х600 точек, а часто и в режимах с большим разрешением. Часто SVGA обозначаются также и мониторы (дисплеи), которые могут работать с адаптерами SVGA и обеспечивать разрешающую способность 800х600 точек или более.

ТСО-92, ТСО-95 – стандарты на излучение мониторов, обеспечивающие их безвредность для здоровья пользователей. Стандарт ТСО-92 приблизительно аналогичен MPR-II, ТСО-95 – еще более жесток, стандарту ТСО-95 удовлетворяют далеко не все мониторы, удовлетворяющие MPR-II или ТСО-92.

TFT – тип дисплеев на цветной активной матрице (обычно используются в портативных компьютерах). Обеспечивают яркие и насыщенные цвета, но весьма дороги.

trackball – манипулятор в виде шарика, используется для замены мыши, чаще всего в портативных компьютерах.

TrueType –формат масштабируемых шрифтов.

UPS – устройство бесперебойного электропитания.

VESA – название ассоциации инженеров по видеоэлектронике.

V34, V34bis – стандарты высокоскоростной (28800 и 33600 бит/с соответственно) передачи данных через модем по обычным (коммутируемым) телефонным линиям.

узкий принтер – принтер (как правило, матричный) с шириной печати 8". В такой принтер может быть заправлен узкой стороной лист бумаги формата А4.

широкий принтер – принтер (как правило, матричный) с шириной печати 15" и более. В такой принтер может быть заправлен лист бумаги формата A3. Используется для печати бухгалтерских документов, больших таблиц и т.д.

0,28 – имеется в виду размер зерна монитора 0,28 мм (см. dot). Типичен для мониторов среднего качества. Более качественные мониторы имеют размер зерна 0,24-0,26 мм.

10Base-5 – локальная сеть типа Ethernet (10 Мбит/с) на толстом кабеле. Часто это сокращение означает, что компьютер или иное устройство можно подсоединить к данной локальной сети.

100Вазе-Т – локальная сеть типа Ethernet на витой паре с пропускной способностью 100 Мбит/с.

101-key keyboard – 101-клавишная клавиатура.

24-pin – 24-точечный матричный принтер. Такие принтеры дороже, но обеспечивают более качественную печать по сравнению с 9-точечными матричными принтерами и выполняют ее быстрее.

6х86 – марка Intel-совместимых микропроцессоров, выпускаемых различными фирмами. По скорости эти микропроцессоры соперничают с Pentium.

9-pin – 9-точечный матричный принтер (наиболее дешевый тип матричных принтеров).


2.4. Контрольные вопросы

  1. Что такое базовая конфигурация компьютера?
  2. Что входит в состав системного блока?
  3. Что располагается на материнской плате?
  4. Какие функции выполняет процессор?
  5. Чем определяется быстродействие компьютера?
  6. Какие Вы знаете виды памяти7
  7. Что такое форматирование диска?
  8. Что такое контроллер?
  9. Какие Вы знаете виды мониторов?
  10. Какие основные характеристики монитора?
  11. Какие существуют разновидности принтеров?
  12. Какие бывают сканеры? Для чего они предназначены?
  13. Из каких групп клавиш состоит клавиатура?
  14. Какие вы знаете устройства для хранения данных?


1.1. Информация и формы ее представления

Понятие информации является основополагающим понятием информатики. Любая деятельность человека представляет собой процесс сбора и переработки информации, принятия на ее основе решении и их выполнения. С появлением современных средств вычислительной техники информация стала выступать в качестве одного из важнейших ресурсов научно-технического прогресса.

Информация содержится в человеческой речи, текстах книг, журналов и газет, сообщениях радио и телевидения, показаниях приборов и т. д. Человек воспринимает информацию с помощью органов чувств, хранит и перерабатывает ее с помощью мозга и центральной нервной системы. Передаваемая информация обычно касается каких-то предметов или нас самих и связана с событиями, происходящими в окружающем нас мире.

В рамках науки информация является первичным и неопределяемым понятием. Оно предполагает наличие материального носителя информации, источника информации, передатчика информации, приемника и канала связи между источником и приемником. Понятие информации используется во всех сферах: науке, технике, культуре, социологии и повседневной жизни. Конкретное толкование элементов, связанных с понятием информации, зависит от метода конкретной науки, цели исследования или просто от наших представлений.

Термин «информация» происходит от латинского informatio — разъяснение, изложение, осведомленность. Энциклопедический словарь (М.: Сов. энциклопедия, 1990) определяет информацию в исторической эволюции: первоначально — сведения, передаваемые людьми устным, письменным или другим способом (с помощью условных сигналов, технических средств и т. д.); с середины XX века — общенаучное понятие, включающее обмен сведениями между людьми, человеком и автоматом, обмен сигналами в животном и растительном мире (передача признаков от клетки к клетке, от организма к организму).

Более узкое определение дается в технике, где это понятие включает в себя все сведения, являющиеся объектом хранения, передачи и преобразования.

Наиболее общее определение имеет место в философии, где под информацией понимается отражение реального мира. Информацию как философскую категорию рассматривают как один из атрибутов материи, отражающий ее структуру.

В эволюционном ряду вещество -> энергия -> информация каждое последующее проявление материи отличается от предыдущего тем, что людям было труднее его распознать, выделить и использовать в чистом виде. Именно сложность выделения различных проявлений материи обусловила, наверное, указанную последовательность познания природы человечеством.

С понятием информации связаны такие понятия, как сигнал, сообщение и данные.

Сигнал (от латинского signum — знак) представляет собой любой процесс, несущий информацию.

Сообщение — это информация, представленная в определенной форме и предназначенная для передачи.

Данные — это информация, представленная в формализованном виде и предназначенная для обработки ее техническими средствами, например, ЭВМ.

Различают две формы представления информации — непрерывную и дискретную. Поскольку носителями информации являются сигналы, то в качестве последних могут использоваться физические процессы различной природы. Например, процесс протекания электрического тока в цепи, процесс механического перемещения тела, процесс распространения света и т. д. Информация представляется (отражается) значением одного или нескольких параметров физического процесса (сигнала), либо комбинацией нескольких параметров.

Сигнал называется непрерывным, если его параметр в заданных пределах может принимать любые промежуточные значения. Сигнал называется дискретным, если его параметр в заданных пределах может принимать отдельные фиксированные значения.

Следует различать непрерывность или дискретность сигнала по уровню и во времени.

На рис. 1.1 в виде графиков изображены: а) непрерывный по уровню и во времени сигнал Хнн; б) дискретный по уровню и непрерывный во времени сигнал Хдн; в) непрерывный по уровню и дискретный во времени сигнал Хнд; г) дискретный по уровню и во времени сигнал Хдд.

Рис. 1.1. Виды информационных процессов

Наконец, все многообразие окружающей нас информации можно сгруппировать по различным признакам, т. е. классифицировать по видам. Например, в зависимости от области возникновения информацию, отражающую процессы и явления неодушевленной природы, называют элементарной, процессы животного и растительного мира — биологической, человеческого общества — социальной.

По способу передачи и восприятия различают следующие виды информации: визуальную — передаваемую видимыми образами и символами, аудиальную — звуками, тактильную — ощущениями, органолептическую — запахами и вкусом, машинную — выдаваемую и воспринимаемую средствами вычислительной техники, и т. д.

Понятие количества информации

Количеством информации называют числовую характеристику сигнала, отражающую ту степень неопределенности (неполноту знаний), которая исчезает после получения сообщения в виде данного сигнала. Эту меру неопределенности в теории информации называют энтропией. Если в результате получения сообщения достигается полная ясность в каком-то вопросе, говорят, что была получена полная или исчерпывающая информация и необходимости в получении дополнительной информации нет. И, наоборот, если после получения сообщения неопределенность осталась прежней, значит, информации получено не было (нулевая информация).

Приведенные рассуждения показывают, что между понятиями информация, неопределенность и возможность выбора существует тесная связь. Так, любая неопределенность предполагает возможность выбора, а любая информация, уменьшая неопределенность, уменьшает и возможность выбора. При полной информации выбора нет. Частичная информация уменьшает число вариантов выбора, сокращая тем самым неопределенность.

Пример. Человек бросает монету и наблюдает, какой стороной она упадет. Обе стороны монеты равноправны, поэтому одинаково вероятно, что выпадет одна или другая сторона. Такой ситуации приписывается начальная неопределенность, характеризуемая двумя возможностями. После того, как монета упадет, достигается полная ясность и неопределенность исчезает (становится равной нулю).

Приведенный пример относится к группе событий, применительно к которым может быть поставлен вопрос типа «да-нет». Количество информации, которое можно получить при ответе на вопрос типа «да-нет», называется битом (англ. bit — сокращенное от binary digit — двоичная единица). Бит — минимальная единица количества информации, ибо получить информацию меньшую, чем 1 бит, невозможно. При получении информации в 1 бит неопределенность уменьшается в 2 раза. Таким образом, каждое бросание монеты дает нам информацию в 1 бит.

В качестве других моделей получения такого же количества информации могут выступать электрическая лампочка, двухпозиционный выключатель, магнитный сердечник, диод и т. п. Включенное состояние этих объектов обычно обозначают цифрой 1, а выключенное — цифрой 0.

Рассмотрим систему из двух электрических лампочек, которые независимо друг от друга могут быть включены или выключены. Для такой системы возможны следующие состояния:

Лампа А 0 0 1 1

Лампа В 0 1 0 1

Чтобы получить полную информацию о состоянии системы, необходимо задать два вопроса типа «да-нет» — по лампочке А и лампочке В соответственно. В этом случае количество информации, содержащейся в данной системе, определяется уже в 2 бита, а число возможных состояний системы — 4. Если взять три лампочки, то необходимо задать уже три вопроса и получить 3 бита информации. Количество состояний такой системы равно 8 и т. д.

Связь между количеством информации и числом состояний системы устанавливается формулой Хартли:

i=log2N,

где i — количество информации в битах; N —. число возможных состояний. Ту же формулу можно представить иначе:

N =2i.

Группа из 8 битов информации называется байтом. Если бит — минимальная единица информации, то байт ее основная единица. Существуют производные единицы информации: килобайт (кбайт, кб), мегабайт (Мбайт, Мб) и гигабайт (Гбайт, Гб).

1 кб =1024 байта - 210 (1024) байтов.

1 Мб = 1024 кбайта = 220(1024 x 1024) байтов.

1 Гб = 1024 Мбайта - 230 (1024х1024 х 1024)байтов.

Эти единицы чаще всего используют для указания объема памяти ЭВМ.


1.2. Информационные процессы и технологии

Информационные процессы (сбор, обработка и передача информации) всегда играли важную роль в науке, технике и жизни общества. В ходе эволюции человечества просматривается устойчивая тенденция к автоматизации этих процессов, хотя их внутреннее содержание по существу осталось неизменным.

Сбор информации — это деятельность субъекта, в ходе которой он получает сведения об интересующем его объекте. Сбор информации может производиться или человеком, или с помощью технических средств и систем — аппаратно. Например, пользователь может получить информацию о движении поездов или самолетов сам, изучив расписание, или же от другого человека непосредственно, либо через какие-то документы, составленные этим человеком, или с помощью технических средств (автоматической справки, телефона и т. д.). Задача сбора информации не может быть решена в отрыве от других задач, — в частности, задачи обмена информацией (передачи).

Обмен информацией — это процесс, в ходе которого источник информации ее передает, а получатель — принимает. Если в передаваемых сообщениях обнаружены ошибки, то организуется повторная передача этой информации. В результате обмена информацией между источником и получателем устанавливается своеобразный «информационный баланс», при котором в идеальном случае получатель будет располагать той же информацией, что и источник.

Обмен информации производится с помощью сигналов, являющихся ее материальным носителем. Источниками информации могут быть любые объекты реального мира, обладающие определенными свойствами и способностями. Если объект относится к неживой природе, то он вырабатывает сигналы, непосредственно отражающие его свойства. Если объектом-источником является человек, то вырабатываемые им сигналы могут не только непосредственно отражать его свойства, но и соответствовать тем знакам, которые человек вырабатывает с целью обмена информацией.

Принятую информацию получатель может использовать неоднократно. С этой целью он должен зафиксировать ее на материальном носителе (магнитном, фото, кино и др.). Процесс формирования исходного, несистематизированного массива информации называется накоплением информации. Среди записанных сигналов могут быть такие, которые отражают ценную или часто используемую информацию. Часть информации в данный момент времени особой ценности может не представлять, хотя, возможно, потребуется в дальнейшем.

Хранение информации — это процесс поддержания исходной информации в виде, обеспечивающем выдачу данных по запросам конечных пользователей в установленные сроки.

Обработка информации — это упорядоченный процесс ее преобразования в соответствии с алгоритмом решения задачи.

После решения задачи обработки информации результат должен быть выдан конечным пользователям в требуемом виде. Эта операция реализуется в ходе решения задачи выдачи информации. Выдача информации, как правило, производится с помощью внешних устройств ЭВМ в виде текстов, таблиц, графиков и пр.

Информационная техника представляет собой материальную основу информационной технологии, с помощью которой осуществляется сбор, хранение, передача и обработка информации. До середины XIX века, когда доминирующими были процессы сбора и накопления информации, основу информационной техники составляли перо, чернильница и бумага. Коммуникация (связь) осуществлялась путем направления пакетов (депеш). На смену «ручной» информационной технике в конце XIX века пришла «механическая» (пишущая машинка, телефон, телеграф и др.), что послужило базой для принципиальных изменений в технологии обработки информации. Понадобилось еще много лет, чтобы перейти от запоминания и передачи информации к ее переработке. Это стало возможно с появлением во второй половине нашего столетия такой информационной техники, как электронные вычислительные машины, положившие начало «компьютерной технологии».

Древние греки считали, что технология (techne — мастерство + togos — учение) — это мастерство (искусство) делать вещи. Более емкое определение это понятие приобрело в процессе индустриализации общества.

Технология — это совокупность знаний о способах и средствах проведения производственных процессов, при которых происходит качественное изменение обрабатываемых объектов.

Технологиям управляемых процессов свойственны упорядоченность и организованность, которые противопоставляются стихийным процессам. Исторически термин «технология» возник в сфере материального производства. Информационную технологию в данном контексте можно считать технологией использования программно-аппаратных средств вычислительной техники в данной предметной области.

Информационная технология — это совокупность методов, производственных процессов и программно-технических средств, объединенных в технологическую цепочку, обеспечивающую сбор, обработку, хранение, распространение и отображение информации с целью снижения трудоемкости процессов использования информационного ресурса, а также повышения их надежности и оперативности.

Информационные технологии характеризуются следующими основными свойствами:

  • предметом (объектом) обработки (процесса) являются данные;

  • целью процесса является получение информации;

  • средствами осуществления процесса являются программные, аппаратные и программно-аппаратные вычислительные комплексы;

  • процессы обработки данных разделяются на операции в соответствии с данной предметной областью;

  • выбор управляющих воздействий на процессы должен осуществляться лицами, принимающими решение;

  • критериями оптимизации процесса являются своевременность доставки информации пользователю, ее надежность, достоверность, полнота.

Из всех видов технологий информационная технология сферы управления предъявляет самые высокие требования к «человеческому фактору», оказывая принципиальное влияние на квалификацию работника, содержание его труда, физическую и умственную нагрузку, профессиональные перспективы и уровень социальных отношений.


1.3. ЭВМ как средство обработки информации

При рассмотрении ЭВМ как средства обработки информации важную роль играют понятие архитектуры ЭВМ, классификация ЭВМ, структура и принципы функционирования ЭВМ, а также основные характеристики вычислительной техник.

Понятие архитектуры ЭВМ

С середины 60-х годов существенно изменился подход к созданию вычислительных машин. Вместо независимой разработки аппаратуры и некоторых средств математического обеспечения стала проектироваться система, состоящая из совокупности аппаратных (hardware) и программных (software) средств. При этом на первый план выдвинулась концепция их взаимодействия. Так возникло принципиально новое понятие — архитектура ЭВМ.

Под архитектурой ЭВМ понимается совокупность общих принципов организации аппаратно-программных средств и их характеристик, определяющая функциональные возможности ЭВМ при решении соответствующих классов задач.

Архитектура ЭВМ охватывает широкий круг проблем, связанных с построением комплекса аппаратных и программных средств и учитывающих множество факторов. Среди этих факторов важнейшими являются: стоимость, сфера применения, функциональные возможности, удобство эксплуатации, а одним из главных компонентов архитектуры являются аппаратные средства. Основные компоненты архитектуры ЭВМ можно представить в виде схемы, показанной на рис. 1.2.

Рис. 1.2. Основные компоненты архитектуры ЭВМ

Архитектуру вычислительного средства следует отличать от его структуры. Структура вычислительного средства определяет его конкретный состав на некотором уровне детализации (устройства, блоки узлы и т. д.) и описывает связи внутри средства во всей их полноте. Архитектура же определяет правила взаимодействия составных частей вычислительного средства, описание которых выполняется в той мере, в какой это необходимо для формирования правил их взаимодействия. Она регламентирует не все связи, а наиболее важные, которые должны быть известны для более грамотного использования данного средства.

Так, пользователю ЭВМ безразлично, на каких элементах выполнены электронные схемы, схемно или программно реализуются команды и т. д. Важно другое: как те или иные структурные особенности ЭВМ связаны с возможностями, предоставляемыми пользователю, какие альтернативы реализованы при создании машины и по каким критериям принимались решения, как связаны между собой характеристики отдельных устройств, входящих в состав ЭВМ, и какое влияние они оказывают на общие характеристики машины. Иными словами, архитектура ЭВМ действительно отражает круг проблем, относящихся к общему проектированию и построению вычислительных машин и их программного обеспечения.

Классификация ЭВМ

Чтобы судить о возможностях ЭВМ, их принято разделять на группы по определенным признакам, т. е. классифицировать. Сравнительно недавно классифицировать ЭВМ по различным признакам не составляло большого труда. Важно было только определить признак классификации, например: по назначению, по габаритам, по производительности, по стоимости, по элементной базе и т. д.

С развитием технологии производства ЭВМ классифицировать их стало все более затруднительно, ибо стирались грани между такими важными характеристиками, как производительность, емкость внутренней и внешней памяти, габариты, вес, энергопотребление и др. Например, персональный компьютер, для размещения которого достаточно стола, имеет практически такие же возможности и технические характеристики, что и достаточно совершенная в недавнем прошлом ЭВМ Единой системы (ЕС), занимающая машинный зал в сотни квадратных метров. Поэтому разделение ЭВМ по названным признакам нельзя воспринимать как классификацию по техническим параметрам. Это, скорее, эвристический подход, где большой вес имеет предполагаемая сфера применения компьютеров.

С этой точки зрения классификацию вычислительных машин по таким показателям, как габариты и производительность, можно представить следующим образом:

  • сверхпроизводительные ЭВМ и системы (супер-ЭВМ);

  • большие ЭВМ (универсальные ЭВМ общего назначения);

  • средние ЭВМ;

  • малые или мини-ЭВМ;

  • микро-ЭВМ;

  • персональные компьютеры;

  • микропроцессоры.

Отметим, что понятия «большие», «средние» и «малые» для отечественных ЭВМ весьма условны и не соответствуют подобным категориям зарубежных ЭВМ.

Исторически первыми появились большие ЭВМ (универсальные ЭВМ общего назначения), элементная база которых прошла путь от электронных ламп до схем со сверхвысокой степенью интеграции. В процессе эволюционного развития больших ЭВМ можно выделить отдельные периоды, связываемые с пятью поколениями ЭВМ.

Поколение ЭВМ определяется элементной базой (лампы, полупроводники, микросхемы различной степени интеграции), архитектурой и вычислительными возможностями.

Основное назначение больших ЭВМ — выполнение работ, связанных с обработкой и хранением больших объемов информации, проведением сложных расчетов и исследований в ходе решения вычислительных и информационно-логических задач. Такими машинами, как правило, оснащаются вычислительные центры, используемые совместно несколькими организациями. Большие машины составляли основу парка вычислительной техники до середины 70-х годов и успешно эксплуатируются поныне. К ним относятся большинство моделей фирмы IBM (семейства 360,370,390) и их отечественные аналоги ЕС ЭВМ.

В настоящее время высказываются полярные мнения о перспективах развития больших машин. Согласно одному из них, возможности больших машин полностью перекрываются, с одной стороны, супер-ЭВМ, а с другой — мини-ЭВМ и, выработав свой ресурс, этот класс прекратит свое существование. Другая сторона убеждает в необходимости развития универсальных больших и супер-ЭВМ, которые обладают способностью работать одновременно с большим количеством пользователей, создавать гигантские базы данных и обеспечивать эффективную вычислительную работу. К этому следует добавить, что большие ЭВМ обеспечивают устойчивость вычислительного процесса, безопасность информации и низкую стоимость ее обработки.

Производительность больших ЭВМ порой оказывается недостаточной для ряда приложений, например, таких как прогнозирование метеообстановки, ядерная энергетика, оборона и т. д. Эти обстоятельства стимулировали создание сверхбольших или суперЭВМ. Такие машины обладают колоссальным быстродействием в миллиарды операций в секунду, основанном на выполнении параллельных вычислений и использовании многоуровневой иерархической структуры ЗУ(запоминающих устройств), требуют для своего размещения специальных помещений и крайне сложны в эксплуатации. Стоимость отдельной ЭВМ такого класса достигает десятков миллионов долларов. Представители этого класса ЭВМ — компьютеры фирм Cray Research, Control Data Corporation (CDC) и отечественные супер-ЭВМ семейства Эльбрус.

Средние ЭВМ представляют некоторый интерес в историческом плане. На определенном этапе развития ЭВМ, когда их номенклатура и, соответственно, возможности были ограниченными, появление средних машин было закономерным. Вычислительные машины этого класса обладают несколько меньшими возможностями, чем большие ЭВМ, но зато им присуща и более низкая стоимость. Они предназначены для использования всюду, где приходится постоянно обрабатывать достаточно большие объемы информации с приемлемыми временными затратами. В настоящее время трудно определить четкую грань между средними ЭВМ и большими с одной стороны и малыми — с другой. К средним могут быть отнесены некоторые модели ЕС ЭВМ, например: ЕС-1036, ЕС-1130, ЕС-1120. За рубежом средние ЭВМ выпускают фирмы IBM (International Business Machinary), DEC (Digital Equipment Corporation), Hewlett Packard, COMPAREX и др.

Малые ЭВМ составляют самый многочисленный и быстроразвивающийся класс ЭВМ. Их популярность объясняется малыми размерами, низкой стоимостью (по сравнению с большими и средними ЭВМ) и универсальными возможностями.

Класс мини-ЭВМ появился в 60-е годы (12-разрядная ЭВМ PD5-5 фирмы DEC). Их появление было обусловлено развитием элементной базы и избыточностью ресурсов больших и средних ЭВМ для ряда приложений. Для мини-ЭВМ характерно представление данных с узким диапазоном значений (машинное слово — 2 байта), использование принципа магистральности в архитектуре и более простое взаимодействие человека и ЭВМ. Такие машины широко применяются для управления сложными видами оборудования, создания систем автоматизированного проектирования и гибких производственных систем. К мини-ЭВМ относятся машины серии PDP (затем VAX) фирмы DEC и их отечественные аналоги — модели семейства малых ЭВМ (СМ ЭВМ).

При переходе от схем с малой и средней степенями интеграции к интегральным микросхемам с большой и сверхбольшой степенями интеграции оказалось возможным создание на одной БИС или СБИС функционально законченного устройства обработки информации, выполняющего функции процессора. Такое устройство принято называть микропроцессором. Изобретение микропроцессора привело к появлению еще одного класса ЭВМ — микро-ЭВМ. Определяющим признаком микро-ЭВМ является наличие одного или нескольких микропроцессоров. Создание микропроцессора не только изменило центральную часть ЭВМ, но и привело к необходимости разработки малогабаритных устройств ее периферийной части. Микро-ЭВМ, благодаря малым размерам, высокой производительности, повышенной надежности и небольшой стоимости нашли широкое распространение во всех сферах народного хозяйства и оборонного комплекса. С появлением микропроцессоров и микро-ЭВМ становится возможным создание так называемых интеллектуальных терминалов, выполняющих сложные процедуры предварительной обработки информации.

Успехи в развитии микропроцессоров и микро-ЭВМ привели к появлению персональных ЭВМ (ПЭВМ), предназначенных для индивидуального обслуживания пользователя и ориентированных на решение различных задач неспециалистами в области вычислительной техники. Все оборудование персональной ЭВМ размещается в пределах стола.

ПЭВМ, выпускаемые в сотнях тысяч и миллионах экземпляров, вносят коренные изменения в формы использования вычислительных средств, в значительной степени расширяют масштабы их применения. Они широко используются как для поддержки различных видов профессиональной деятельности (инженерной, административной, производственной, литературной, финансовой и др.), так и в быту, например для обучения и досуга.

Персональный компьютер позволяет эффективно выполнять научно-технические и финансово-экономические расчеты, организовывать базы данных, подготавливать и редактировать документы и любые другие тексты, вести делопроизводство, обрабатывать графическую информацию и т. д. Выполнение многих из указанных функций поддерживается многочисленными эффективными универсальными функциональными пакетами программ.

На основе ПЭВМ создаются автоматизированные рабочие места (АРМ) для представителей разных профессий (конструкторов, технологов, административного аппарата и др.).

Рынок персональных и микро-ЭВМ непрерывно расширяется за счет поставок ведущих мировых фирм: IBM, Compaq, Hewlett Packard, Apple (США), Siemens (Германия), ICL (Англия) и др.


Структура и принципы функционирования ЭВМ

Более чем за полвека развития вычислительных средств прогресс в аппаратной реализации ЭВМ и их технических характеристик превзошел все прогнозы, и пока не заметно снижение его темпов. Несмотря на то, что современные ЭВМ внешне не имеют ничего общего с первыми моделями, основополагающие идеи, заложенные в них и связанные с понятием алгоритма, разработанным Аланом Тьюрингом, а также архитектурной реализацией, предложенной Джоном фон Нейманом, пока не претерпели коренных изменений (за исключением систем параллельной обработки информации).

Любая ЭВМ неймановской архитектуры содержит следующие основные устройства:

  • арифметико-логическое устройство (АЛУ);

  • устройство управления (УУ)

  • запоминающее устройство (ЗУ);

  • устройства ввода-вывода (УВВ);

  • пульт управления (ПУ).

В современных ЭВМ АЛУ и УУ объединены в общее устройство, называемое центральным процессором. Обобщенная логическая структура ЭВМ представлена на рис. 1.3.

Рис. 1.3. Обобщённая логическая структура ЭВМ

Процессор, или микропроцессор, является основным устройством ЭВМ. Он предназначен для выполнения вычислении по хранящейся в запоминающем устройстве программе и обеспечения общего управления ЭВМ. Быстродействие ЭВМ в значительной мере определяется скоростью работы процессора. Для ее увеличения процессор использует собственную намять небольшого объема, именуемую местной или сверхоперативной, что в некоторых случаях исключает необходимость обращения к запоминающему устройству ЭВМ.

Вычислительный процесс должен быть предварительно представлен для ЭВМ в виде программы — последовательности инструкций (команд), записанных в порядке выполнения. В процессе выполнения программы ЭВМ выбирает очередную команду, расшифровывает ее, определяет, какие действия и над какими операндами следует выполнить. Эту функцию осуществляет УУ. Оно же помещает выбранные из ЗУ операнды в АЛУ, где они и обрабатываются. Само АЛУ работает под управлением УУ.

Обрабатываемые данные и выполняемая программа должны находиться в запоминающем устройстве — памяти ЭВМ, куда они вводятся через устройство ввода. Емкость памяти измеряется в величинах, кратных байту. Память представляет собой сложную структуру, построенную по иерархическому принципу, и включает в себя запоминающие устройства различных типов. Функционально она делится на две части: внутреннюю и внешнюю.

Внутренняя, или основная память — это запоминающее устройство, напрямую связанное с процессором и предназначенное для хранения выполняемых программ и данных, непосредственно участвующих в вычислениях. Обращение к внутренней памяти ЭВМ осуществляется с высоким быстродействием, но она имеет ограниченный объем, определяемый системой адресации машины.

Внутренняя память, в свою очередь, делится на оперативную (ОЗУ) и постоянную (ПЗУ) память. Оперативная память, по объему составляющая" большую часть внутренней памяти, служит для приема, хранения и выдачи информации. При выключении питания ЭВМ содержимое оперативной памяти в большинстве случаев теряется. Постоянная память обеспечивает хранение и выдачу информации. В отличие от содержимого оперативной памяти, содержимое постоянной заполняется при изготовлении ЭВМ и не может быть изменено в обычных условиях эксплуатации. В постоянной памяти хранятся часто используемые (универсальные) программы, и данные, к примеру, некоторые программы операционной системы, программы тестирования оборудования ЭВМ и др. При выключении питания содержимое постоянной памяти сохраняется.

Внешняя память (ВЗУ) предназначена для размещения больших объемов информации и обмена ею с оперативной памятью. Для построения внешней памяти используют энергонезависимые носители информации (диски и ленты), которые к тому же являются переносимыми. Емкость этой памяти практически не имеет ограничений, а для обращения к ней требуется больше времени, чем ко внутренней.

Внешние запоминающие устройства конструктивно отделены от центральных устройств ЭВМ (процессора и внутренней памяти), имеют собственное управление и выполняют запросы процессора без его непосредственного вмешательства. В качестве ВЗУ используют накопители на магнитных и оптических дисках, а также накопители на магнитных лентах.

ВЗУ по принципам функционирования разделяются на устройства прямого доступа (накопители на магнитных и оптических дисках) и устройства последовательного доступа (накопители на магнитных лентах). Устройства прямого доступа обладают большим быстродействием, поэтому они являются основными внешними запоминающими устройствами, постоянно используемыми в процессе функционирования ЭВМ. Устройства последовательного доступа используются в основном для резервирования информации.

Устройства ввода-вывода служат соответственно для ввода информации в ЭВМ и вывода из нее, а также для обеспечения общения пользователя с машиной. Процессы ввода-вывода протекают с использованием внутренней памяти ЭВМ. Иногда устройства ввода-вывода называют периферийными или внешними устройствами ЭВМ. К ним относятся, в частности, дисплеи (мониторы), клавиатура, манипуляторы типа «мышь», алфавитно-цифровые печатающие устройства (принтеры), графопостроители, сканеры и др. Для управления внешними устройствами (в том числе и ВЗУ) и согласования их с системным интерфейсом служат групповые устройства управления внешними устройствами, адаптеры или контроллеры.

Системный интерфейс — это конструктивная часть ЭВМ, предназначенная для взаимодействия ее устройств и обмена информацией между ними.

В больших, средних и супер-ЭВМ в качестве системного интерфейса используются сложные устройства, имеющие встроенные процессоры ввода-вывода, именуемые каналами. Такие устройства обеспечивают высокую скорость обмена данными между компонентами ЭВМ.

Отличительной особенностью малых ЭВМ является использование в качестве системного интерфейса системных шин. Различают ЭВМ с многошинной структурой и с общей шиной. В первых для обмена информацией между устройствами используются отдельные группы шин, во втором случае все устройства ЭВМ объединяются с помощью одной группы шин, в которую входят подмножества шин для передачи данных, адреса и управляющих сигналов. При такой организации системы шин обмен информацией между процессором, памятью и периферийными устройствами выполняется по единому правилу, что упрощает взаимодействие устройств машины.

Пульт управления служит для выполнения оператором ЭВМ или системным программистом системных операций в ходе управления вычислительным процессом. Кроме того, при техническом обслуживании ЭВМ за пультом управления работает инженерно-технический персонал. Пульт управления конструктивно часто выполняется вместе с центральным процессором.

Основные характеристики вычислительной техники

К основным характеристикам вычислительной техники относятся ее эксплуатационно-технические характеристики, такие, как быстродействие, емкость памяти, точность вычислений и др.

Быстродействие ЭВМ рассматривается в двух аспектах. С одной стороны, оно характеризуется количеством элементарных операций, выполняемых центральным процессором в секунду Под элементарной операцией понимается любая простейшая операция типа сложения, пересылки, сравнения и т. д. С другой стороны, быстродействие

ЭВМ существенно зависит от организации ее памяти. Время, затрачиваемое на поиск необходимой информации в памяти, заметно сказывается на быстродействии ЭВМ.

В зависимости от области применения выпускаются ЭВМ с быстродействием от нескольких сотен тысяч до миллиардов операций в секунду. Для решения сложных задач возможно объединение нескольких ЭВМ в единый вычислительный комплекс с требуемым суммарным быстродействием.

Наряду с быстродействием часто пользуются понятием производительность. Если первое обусловлено, главным образом, используемой в ЭВМ системой элементов, то второе связано с ее архитектурой и разновидностями решаемых задач. Даже для одно» ЭВМ такая характеристика, как быстродействие, не является величиной постоянной. В связи с этим различают:

  • пиковое быстродействие, определяемое тактовой частотой процессора без учета обращения к оперативной памяти;
  • номинальное быстродействие, определяемое с учетом времени обращения к оперативной памяти;
  • системное быстродействие, определяемое с учетом системных издержек на организацию вычислительной процесса;
  • эксплуатационное, определяемое с учетом характера решаемых задач (состав, операций или их «смеси»).

Емкость, или объем памяти определяется максимальным количеством информации которое можно разместить в памяти ЭВМ. Обычно емкость памяти измеряется в байтах. Как уже отмечалось, память ЭВМ подразделяется на внутреннюю и внешнюю. Внутренняя, или оперативная память, по своему объему у различных классов машин различна и определяется системой адресации ЭВМ. Емкость внешней памяти из-за блочной структуры и съемных конструкций накопителей практически неограниченна.

Точность вычислений зависит от количества разрядов, используемых для представления одного числа. Современные ЭВМ комплектуются 32- или 64-разрядными микропроцессорами, что вполне достаточно для обеспечения высокой точности расчетов самых разнообразных приложениях. Однако, если этого мало, можно использовать уд военную или утроенную разрядную сетку.

Система команд — это перечень команд, которые способен выполнить процессор ЭВМ. Система команд устанавливает, какие конкретно операции может выполнять процессор, сколько операндов требуется указать в команде, какой вид (формат) должна имеет команда для ее распознания. Количество основных разновидностей команд невелико, с их помощью ЭВМ способны выполнять операции сложения, вычитания, умножена деления, сравнения, записи в память, передачи числа из регистра в регистр, преобразования из одной системы счисления в другую и т. д. При необходимости выполняете модификация команд, учитывающая специфику вычислений. Обычно в ЭВМ используется от десятков до сотен команд (с учетом их модификации). На современном этап развития вычислительной техники используются два основных подхода при формировании системы команд процессора. С одной стороны, это традиционный подход, свзязанный с разработкой процессоров с полным набором команд, — архитектура CIS (Complete Instruction Set Computer — компьютер с полным набором команд). С друге стороны, это реализация в ЭВМ сокращенного набора простейших, но часто употреблю емых команд, что позволяет упростить аппаратные средства процессора и повысить ei быстродействие — архитектура RISC (Reduced Instruction Set Computer — компьютер сокращенным набором команд).

Стоимость ЭВМ зависит от множества факторов, в частности от быстродействия, емкости памяти, системы команд и т. д. Большое влияние на стоимость оказывает конкретная комплектация ЭВМ и, в первую очередь, внешние устройства, входящие в состав машины. Наконец, стоимость программного обеспечения ощутимо влияет на стоимость ЭВМ.

Надежность ЭВМ — это способность машины сохранять свои свойства при заданных условиях эксплуатации в течение определенного промежутка времени. Количественной оценкой надежности ЭВМ, содержащей элементы, отказ которых приводит к отказу всей машины, могут служить следующие показатели:

  • вероятность безотказной работы за определенное время при данных условиях эксплуатации;

  • наработка ЭВМ на отказ;

  • среднее время восстановления машины и др.

Для более сложных структур типа вычислительного комплекса или системы понятие «отказ» не имеет смысла. В таких системах отказы отдельных элементов приводят к некоторому снижению эффективности функционирования, а не к полной потере работоспособности в целом.

Важное значение имеют и другие характеристики вычислительной техники, например: универсальность, программная совместимость, вес, габариты, энергопотребление и др. Они принимаются во внимание при оценивании конкретных сфер применения ЭВМ.

Перспективы развития вычислительных средств

Появление новых поколений ЭВМ обусловлено расширением сферы их применения, требующей более производительной, дешевой и надежной вычислительной техники. В настоящее время стремление к реализации новых потребительских свойств ЭВМ стимулирует работы по созданию машин пятого и последующего поколений. Вычислительные средства пятого поколения, кроме более высокой производительности и надежности при более низкой стоимости, обеспечиваемых новейшими электронными технологиями, должны удовлетворять качественно новым функциональным требованиям:

  • работать с базами знаний в различных предметных областях и организовывать на их основе системы искусственного интеллекта;

  • обеспечивать простоту применения ЭВМ путем реализации эффективных систем ввода-вывода информации голосом, диалоговой обработки информации с использованием естественных языков, устройств распознавания речи и изображения;

  • упрощать процесс создания программных средств путем автоматизации синтеза программ.

В настоящее время ведутся интенсивные работы как по созданию ЭВМ пятого поколения традиционной (неймановской) архитектуры, так и по созданию и апробации перспективных архитектур и схемотехнических решений. На формальном и прикладном уровнях исследуются архитектуры на основе параллельных абстрактных вычислителей (матричные и клеточные процессоры, систолические структуры, однородные вычислительные структуры, нейронные сети и др.) Развитие вычислительной техники с высоким параллелизмом во многом определяется элементной базой, степенью развития параллельного программного обеспечения и методологией распараллеливания алгоритмов решаемых задач.

Проблема создания эффективных систем параллельного программирования, ориентированных на высокоуровневое распараллеливание алгоритмов вычислении и обработки данных, представляется достаточно сложной и предполагает дифференцированный подход с учетом сложности распараллеливания и необходимости синхронизации процессов во времени.

Наряду с развитием архитектурных и системотехнических решений ведутся работы по совершенствованию технологий производства интегральных схем и по созданию принципиально новых элементных баз, основанных на оптоэлектронных и оптических принципах.

В плане создания принципиально новых архитектур вычислительных средств большое внимание уделяется проектам нейрокомпьютеров, базирующихся на понятии нейронной сети (структуры на формальных нейронах), моделирующей основные свойства реальных нейронов. В случае применения био- или оптоэлементов могут быть созданы соответственно биологические или оптические нейрокомпьютеры. Многие исследователи считают, что в следующем веке нейрокомпьютеры в значительной степени вытеснят современные ЭВМ, используемые для решения трудно формализуемых задач. Последние достижения в микроэлектронике и разработка элементной базы на основе биотехнологий дают возможность прогнозировать создание биокомпьютеров.

Важным направлением развития вычислительных средств пятого и последующих поколений является интеллектуализация ЭВМ, связанная с наделением ее элементами интеллекта, интеллектуализацией интерфейса с пользователем и др. Работа в данном направлении, затрагивая, в первую очередь, программное обеспечение, потребует и создания ЭВМ определенной архитектуры, используемых в системах управления базами знаний, — компьютеров баз знаний, а так же других подклассов ЭВМ. При этом ЭВМ должна обладать способностью к обучению, производить ассоциативную обработку информации и вести интеллектуальный диалог при решении конкретных задач.

В заключение отметим, что ряд названных вопросов реализован в перспективных ЭВМ пятого поколения либо находится в стадии технической проработки, другие — в стадии теоретических исследований и поисков.


1.4. Программное обеспечение ЭВМ

1.4. Виды программного обеспечения ЭВМ

Назначением ЭВМ является выполнение программ. Программа содержит команды, определяющие порядок действий компьютера. Совокупность программ для компьютера образует программное обеспечение (ПО). По функциональному признаку различают следующие виды ПО:

  • системное;
  • прикладное.

Под системным (базовым) понимается программное обеспечение, включающее в себя операционные системы, сетевое ПО, сервисные программы, а также средства разработки программ (трансляторы, редакторы связей, отладчики и пр.).

Основные функции операционных систем (ОС) заключаются в управлении ресурсами (физическими и логическими) и процессами вычислительных систем. Физическими ресурсами являются: оперативная память, процессор, монитор, печатающее устройство, магнитные и оптические диски. К логическим ресурсам можно отнести программы, файлы, события и т. д. Под процессом понимается некоторая последовательность действий, предписанная соответствующей программой и используемыми ею данными.

В настоящее время существует большое количество ОС, разработанных для ЭВМ различных типов. На ЭВМ Единой Системы (ЕС ЭВМ), например, использовались такие операционные системы, как СВМ и ОС ЕС, на малых ЭВМ (СМ-4, СМ-1420 и др.) - ОС РВ и RSX-11. На персональных ЭВМ долгое время эксплуатировалась ОС-MS-DOS. В настоящее время получили распространение системы Windows 98/Me, Windows 2000, Linix.

Сетевое ПО предназначено для управления общими ресурсами в распределенных вычислительных системах: сетевыми накопителями на магнитных дисках, принтерами, сканерами, передаваемыми сообщениями и т. д. К сетевому ПО относят ОС, поддерживающие работу ЭВМ в сетевых конфигурациях (так называемые сетевые ОС), а также отдельные сетевые программы (пакеты), используемые совместно с обычными, не сетевыми ОС.

Например, большое распространение получили следующие сетевые ОС: NetWare 4.1 (фирма Novell), Windows NT Server 3.5 (фирма Microsoft) и LAN Server 4.0 Advanced (фирма IBM). Однако в последнее время лидирующие позиции начинает занимать ОС Windows 2000 Server фирмы Microsoft.

Для расширения возможностей операционных систем и предоставления набора дополнительных услуг используются сервисные программы. Их можно разделить на следующие группы:

  • интерфейсные системы;
  • оболочки операционных систем;
  • утилиты.

Интерфейсные системы являются естественным продолжением операционной системы и модифицируют как пользовательский, так и программный интерфейсы, а также реализуют дополнительные возможности по управлению ресурсами ЭВМ. В связи с тем, что развитая интерфейсная система может изменить весь пользовательский интерфейс, часто их также называют операционными системами. Это относится, например, к Windows 3.11 и Windows 3.11 for WorkGroups (для рабочих групп).

Оболочки операционных систем, в отличие от интерфейсных систем, модифицируют только пользовательский интерфейс, предоставляя пользователю качественно новый интерфейс по сравнению с реализуемым операционной системой. Такие системы существенно упрощают выполнение часто запрашиваемых функций, например, таких операций с файлами, как копирование, переименование и уничтожение, а также предлагают пользователю ряд дополнительных услуг. В целом, программы-оболочки заметно повышают уровень пользовательского интерфейса, наиболее полно удовлетворяя потребностям пользователя.

На ПЭВМ широко используются такие программы-оболочки, как Norton Commander, FAR Manager и Windows Commander.

Утилиты предоставляют пользователям средства обслуживания компьютера и его ПО. Они обеспечивают реализацию следующих действий:

  • обслуживание магнитных дисков;
  • обслуживание файлов и каталогов;
  • предоставление информации о ресурсах компьютера;
  • шифрование информации;
  • защита от компьютерных вирусов;
  • архивация файлов и др.

Существуют отдельные утилиты, используемые для решения одного из перечисленных действий, и многофункциональные комплекты утилит. В настоящее время для ПЭВМ среди многофункциональных утилит одним из наиболее совершенных является комплект утилит Norton Utilities. Существуют его версии для использования в среде DOS и Windows.

Средства разработки программ используются для разработки нового программного обеспечения как системного, так и прикладного.

Прикладным называется ПО, предназначенное для решения определенной целевой задачи из проблемной области. Часто такие программы называют приложениями.

Спектр проблемных областей в настоящее время весьма широк и включает в себя по крайней мере следующие: промышленное производство, инженерную практику, научные исследования, медицину, управление (менеджмент), делопроизводство, издательскую деятельность, образование и т. д.

Из всего разнообразия прикладного ПО выделяют группу наиболее распространенных программ (типовые пакеты и программы), которые можно использовать во многих областях человеческой деятельности.

К типовому прикладному ПО относят следующие программы:

  • текстовые процессоры;
  • табличные процессоры;
  • системы иллюстративной и деловой графики (графические процессоры);
  • системы управления базами данных;
  • экспертные системы;
  • программы математических расчетов, моделирования и анализа экспериментальных данных.

Предлагаемые на рынке ПО приложения, в общем случае, могут быть выполнены как отдельные программы либо как интегрированные системы. Интегрированными системами обычно являются экспертные системы, программы математических расчетов, моделирования и анализа экспериментальных данных, а также офисные системы. Примером мощной и широко распространенной интегрированной системы является офисная система Microsoft Office.

Поскольку разработка ПО любого назначения, как правило, является довольно сложным и трудоемким процессом, дальнейший материал настоящего раздела посвятим общим вопросам разработки программ и инструментальному ПО.


1.5. Операционная система MS-DOS

Операционная система MS-DOS – это однопользовательская, однозадачная, не сетевая 16-разрядная операционная система (ОС), ориентированная на использование на ПЭВМ с микропроцессором Intel 8088(80286).

Краткая история появления данной операционной системы такова. В октябре 1980 г. менеджеры фирмы IBM занялись поисками ОС для своего 16-разрядного персонального компьютера (ПК), находящегося в стадии разработки. В тот период на ПЭВМ наиболее широко применялась ОС CP/M (Control Program for MicroComputers) фирмы Digital Research. Не достигнув приемлемых соглашений с Digital Research, фирма IBM обратилась к фирме Microsoft (президент – Билл Гейтс). В тот момент у Microsoft не было соответствующей OС, но ей была известна небольшая фирма Seattle Computer Products, которая имела такую OС. За 50 000$ Билл Гейтс приобрел права на эту OС. В дальнейшем эта OС послужила основой для MS-DOS. В ноябре 1980 г. Microsoft и IBM подписали договор на разработку OС для IBM PC. В феврале 1981 г. появилась первая версия PC/MS-DOS, которая работала на IBM PC, в августе того же года – PC DOS 1.0 (эта версия была утверждена для применения на IBM PC).

Операционная система MS-DOS позволяет полностью использовать возможности процессоров Intel 8088 и Intel 80286, работающих в реальном режиме.

Основными характеристиками данной ОС являются:

– максимальный объем адресуемой физической памяти – 640 Кбайт;
– максимальный объем памяти, доступный из прикладных программ 640 Кбайт. Последние версии MS-DOS (начиная с 5.0) могут использовать адресное пространство между 640 Кбайт и 1 Мбайт для размещения своих составных частей и некоторых драйверов, освобождая тем самым память в адресном пространстве 0-640 Кбайт для использования прикладными программами;
– представление всех ресурсов персонального компьютера для одной, активной в настоящий момент, программы;
– развитая файловая система и процессор командного языка;
– слабая поддержка интерактивных средств взаимодействия с пользователем;
– занимаемый объем на диске, в зависимости от версии, от 1 Мбайта до
6 Мбайт. (минимум, при котором можно работать – 100 Кбайт).


Основные составные части MS-DOS

MS-DOS состоит из следующих компонент:

– блок начальной загрузки (размещается в 1-м секторе 0-дорожки 0-стороны системной дискеты);
– модуль расширения BIOS (IO.SYS для версии 5.0 и выше);
– модуль обработки прерываний (MSDOS.SYS для версии 5.0 и выше),
– командный процессор (COMMAND.COM);
– внешние команды (программы) MS-DOS;
– драйверы устройств;
– файл Config.SYS;
– файл Autoexec.bat.

Ядро MS-DOS включает блок начальной загрузки и файлы IO.SYS, MSDOS.SYS.

Блок начальной загрузки размещается в 1-м секторе 0-дорожки 0-стороны системной дискеты и/или в 1-м секторе HDD-диска, в разделе, отведенном под DOS. Выполняет следующие функции: просматривает корневой каталог системного диска и проверяет, являются ли первые два файла в каталоге – файлами IO.SYS и MSDOS.SYS. Если ДА – загружает их в ОЗУ и передает управление MS-DOS, если НЕТ – выдает сообщение на экране и ожидает нажатия какой-либо клавиши пользователем:

Non-System disk or disk error
Replace and press any key when ready

Не системный диск или ошибка диска
Замените и нажмите какую-либо клавишу, когда будет готово

Именно поэтому , при создании системной дискеты необходимо переносить на неё файлы IO.SYS и MSDOS.SYS с помощью специальной программы SYS.COM.

Модуль расширения BIOS IO.SYS

Это резидентный модуль (всегда находится в ОЗУ после загрузки, пока включен ПК). Взаимодействует с BIOS. Расширяет возможности BIOS или изменяет ее свойства (там, где необходимо) с помощью дополнительных драйверов.

Модуль обработки прерываний MSDOS.SYS

Это резидентный модуль. Обеспечивает интерфейс высокого уровня для прикладных программ, содержит программные средства для управления файлами, устройствами ввода-вывода, обработки исключительных ситуаций (ошибок) и др. Прикладная программа вызывает функции этого модуля через механизм программных прерываний, передавая (принимая) информацию к (от) MS-DOS через регистры CPU или (и) области памяти ОЗУ. MSDOS.SYS транслирует (переводит) запрос прикладной программы в один или несколько вызовов IO.SYS + BIOS.

Командный процессор COMMAND.COM

Отдельный модуль MS-DOS. Этот модуль может быть заменен на другой, более удобный. Предназначен для приема команд с клавиатуры или из *.bat - файлов и их выполнения; выполнения команд файла Autoexec.bat при загрузке MS-DOS; загрузки в ОЗУ и запуск на выполнение прикладных программ в среде MS-DOS.

Командный процессор состоит из 3-х частей :

– резидентной (размещается в ОЗУ сразу после MSDOS.SYS, включает процедуры обслуживания некоторых прерываний, процедуры обработки стандартных ошибок MS-DOS, процедуру загрузки транзитной части командного процессора);
– инициализирующей (в ОЗУ следует сразу за резидентной частью; во время загрузки OС ей передается управление; она выполняет файл Autoexec.bat и некоторые другие действия; эта часть командного процессора стирается из ОЗУ первой же загруженной программой);
– транзитной (загружается в старшие адреса ОЗУ; обрабатывает все внутренние команды, команды с клавиатуры и из *.bat-файлов; выдает системную подсказку MS-DOS; загружает в ОЗУ программы и передает им управление).

Внешние команды (программы)

Дополнительные программы, входящие в MS-DOS, выполняющие определенные функции.

Драйверы устройств

Специальные резидентные программы, которые управляют внешними устройствами. Драйверы загружаются в ОЗУ в том порядке, как они указаны в файле CONFIG.SYS.

Файл CONFIG.SYS

Специальный текстовый файл, где содержится информация о подгружаемых дополнительных драйверах и некоторая другая информация, касающаяся непосредственно MS-DOS и выполняемых в ее среде прикладных программ. MS-DOS выполняет этот файл автоматически, сразу после загрузки COMMAND.COM.

Файл AUTOEXEC.BAT

Специальный текстовый файл, в котором содержится дополнительная настроечная информация. MS-DOS выполняет этот файл автоматически, сразу после выполнения файла CONFIG.SYS.


Начальная загрузка MS-DOS

1. При включении ПК вначале выполняются программы BIOS.

2. После тестирования оборудования и выполнения других действий процедура POST (из модуля BIOS) осуществляет поиск и загрузку блока начальной загрузки по следующему алгоритму: вначале производится поиск на устройстве A:. Если блок не найден, то поиск выполняется на устройстве C:. Если снова поиск не завершился успешно, то вызывается встроенный в ПЗУ BASIC или производятся другие действия, записанные в ПЗУ.

3. Блок начальной загрузки производит поиск в корневом каталоге системной дискеты (диска) файлов IO.SYS и MSDOS.SYS (эти файлы должны быть первыми и именно в таком порядке).

4. Блок начальной загрузки производит загрузку файла IO.SYS и передает ему управление.

5. Файл IO.SYS выполняет следующие действия:

– загружает и настраивает MSDOS.SYS;
– определяет состояние подключенных устройств;
– инициализирует подключенные устройства;
– загружает необходимые драйверы устройств;
– передает управление файлу MSDOS.SYS.

6. Файл MSDOS.SYS выполняет следующие действия:

– инициализирует (настраивает) свои внутренние рабочие таблицы;
– загружает драйверы, указанные в файле CONFIG.SYS;
– загружает командный процессор (файл COMMAND.COM).

7. Командный процессор выполняет команды, указанные в файле Autoexec.bat.

8. Командный процессор выдает на экран монитора системную подсказку MS-DOS и ожидает ввода команд пользователя.


Файловая система MS-DOS

Файл (по-английски file – папка, скоросшиватель) – это поименованная область памяти на каком-либо физическом носителе, предназначенная для хранения информации.

Совокупность средств MS-DOS, обеспечивающих доступ к информации на внешних носителях, называется системой управления файлами, или файловой системой.

Одно из понятий файловой системы MS-DOS – логический диск. В некотором приближении можно считать, что с точки зрения MS-DOS каждый логический диск – это отдельный магнитный диск. Каждый логический диск имеет свое уникальное имя.

В качестве имени логического диска используются буквы английского алфавита от A до Z (включительно).

Таким образом, количество логических дисков, может быть не более 26.

Буквы A и B – отведены строго под имеющиеся в IBM PC дисководы.

Начиная с буквы C именуются логические диски (разделы) жесткого диска (рис. 1.3).

В случае, если данный IBM PC имеет только один FDD, буква B пропускается (см. рис. 1.4).

Как правило, только логические диски A и C могут быть системными.

Рис. 1.3. Разделение на логические диски в системе с двумя дисководами.

Рис. 1.4. Разделение на логические диски в системе с одним дисководом.


Файловая структура логического диска

Чтобы обратиться к информации на диске, находящейся в файле, надо знать физический адрес первого сектора (№ поверхности + № дорожки + № сектора), общее количество кластеров, занимаемое данным файлом, адрес следующего кластера, если размер файла больше, чем размер одного кластера и т.д. Все это очень туманно, трудно и не нужно.

MS-DOS избавляет пользователя от такой работы и ведет ее сама.

Для обеспечения доступа к файлам файловая система MS-DOS организует и поддерживает на логическом диске определенную файловую структуру (рис. 1.5).

Элементы файловой структуры:

– стартовый сектор(сектор начальной загрузки, Boot-сектор);
– таблица размещения файлов (FAT – File Allocation Table);
– корневой каталог(Root Directory);
– область данных (оставшееся свободным дисковое пространство).

Эти элементы создаются специальными программами в среде MS-DOS в процессе инициализации диска.

Стартовый сектор (сектор начальной загрузки, Boot-сектор)

Здесь записана информация, необходимая MS-DOS для работы с диском:

  – идентификатор ОС (если диск
системный);
– размер сектора диска;
– количество секторов в кластере;
– количество резервных секторов в
начале диска;
– количество копий FAT на диске (стандарт
– две);
– количество элементов в каталоге;
– количество секторов на диске;
– тип формата диска;
– количество секторов в FAT;
– количество секторов на дорожку;
– количество поверхностей;
– блок начальной загрузки ОС.

Рис. 1.5. Файловая структура на дискете емкостью 360 кбайт

За стартовым сектором располагается FAT.

FAT (таблица размещения файлов)

Область данных диска представлена в MS-DOS как последовательность пронумерованных кластеров.

FAT – это массив элементов, адресующих кластеры области данных диска. Каждому кластеру области данных соответствует один элемент FAT. Элементы FAT служат в качестве цепочки ссылок на кластеры файла в области данных.

FAT – крайне важный элемент файловой структуры. Нарушения в FAT могут привести к полной или частичной потери информации на всем логическом диске. Именно поэтому, на диске хранится две копии FAT. Существуют специальные программы, которые контролируют состояние FAT и исправляют нарушения.

Корневой Каталог. Это определенная область диска, создаваемая в процессе инициализации (форматировании) диска, где содержится информация о файлах и каталогах, хранящихся на диске. Корневой каталог всегда существует на отформатированном диске. На одном диске бывает только один корневой каталог. Размер корневого каталога для данного диска – величина фиксированная, поэтому максимальное количество "привязанных" к нему файлов и других (дочерних) каталогов (подкаталогов) – строго определенное.

Каталоги (подкаталоги). Каталог – это определенное место на диске (в области данных диска), где содержится информация о файлах и подкаталогах, привязанных к данному каталогу.

MS-DOS поддерживает иерархическую структуру каталогов (древообразную, см. рис. 1.6).

Рис. 1.6. Иерархическая структура каталогов

В отличие от корневого каталога, остальные каталоги (подкаталоги) создаются с помощью команд MS-DOS. Основная цель такой структуры каталогов – организация эффективного хранения большого количества файлов на диске.

Каждый каталог, кроме корневого, имеет "родителя", т.е. другой каталог, в котором зарегистрирован данный каталог. MS-DOS рассматривает каждый каталог, кроме корневого, как файл.

Файлы. Файл – это поименованная область памяти на каком-либо физическом носителе, предназначенная для хранения информации. Файл всегда зарегистрирован в каком-либо каталоге, в том числе, может быть "привязан" и к корневому каталогу (см. рис. 1.7).

Рис. 1.7. Иерархическая структура каталогов с файлами

Идентификация логических дисков, каталогов и файлов. Идентификация логических дисков, каталогов, файлов осуществляется на базе имен.

Файловая система MS-DOS не допускает, чтобы логические диски, каталоги, файлы были с одинаковыми ИДЕНТИФИКАТОРАМИ!

В качестве имени логического диска используется одна из букв латинского алфавита (A ... Z). Каждый файл или каталог, кроме корневого, имеет полное имя.

Полное имя файла состоит из следующих частей (рис. 1.8):

– имя логического диска (A … Z);
– символ-разделитель(двоеточие) ':';
– символ, идентифицирующий корневой каталог – '\' (слэш);
– перечень каталогов и подкаталогов (разделенных символом '\');
– собственно имя файла.

Рис. 1.8. Полное имя файла

Собственно имя файла состоит из имени, символа-разделителя '.' (точка) и расширения имени файла.

Маршрут доступа к файлу = "Имя логического диска" + "двоеточие" + "идентификация корневого каталога" + "весь перечень имен родительских каталогов".

Максимальное количество символов в полном имени файла равно 128.

Максимальное количество символов в имени файла равно 8.

Максимальное количество символов в расширении имени файла равно 3.

Расширение не обязательно, т.е. может и не присутствовать (в этом случае точка тоже отсутствует). Таким образом, размер собственно имени файла не превышает 13 символов (с учетом точки).

В полном имени файла разрешается использовать только следующие символы: A…Z, a … z, 0 … 9, $, &, #, `, ~, (, ), -, %, !, _, ^.

В полном имени файла запрещается использовать все остальные символы.

Примеры допустимых имен файлов:
format.COM read.me myfile.txt 28-03-96.doc 123.45

Примеры не допустимых имен файлов:
123456789.txt aa?.doc 35*.? i\t.f.doc *.txt my:file.txt

Использование расширений. Файлы, в зависимости от информации которая там хранится, могут иметь различное назначение: данные, программы, драйверы, настроечные файлы и т.д.

Расширения имени файла – не обязательный, но очень важный компонент. Он используется для разделения файлов по отдельным категориям (данные, программы, драйверы и т.д.).

В MS-DOS есть перечень предопределенных и наиболее часто встречающихся расширений файлов. В табл. 3 приведены некоторые из них.

Таблица 1

Расширение | Назначение файла
EXE, COM | Выполняемые файлы в MS-DOS – это программы, созданные с помощью специальных инструментальных систем программирования, базирующиеся на применении языков программирования
BAT | Файл последовательности команд MS-DOS (пакетный)
SYS | Системный файл или файл драйвера устройств
OVR OVL | Оверлейные файлы
BAK | Резервная (предыдущая) копия файла
TXT | Текстовый ASCII-файл
DOC | Файл-документ MS Word
PAS | Текст программы на языке программирования Pascal
C, CPP | Тексты программ на языках программирования С, С++
ASM | Текст программы на языке Ассемблер.
BMP | Файл изображения в формате Windows BitMaP
GIF | Файл точечного изображения (Graphic Interchange Format)
PCX | Файл изображения в формате Paintbrush
TIF | Файл изображения (Tagged Image File Format)
INI, CFG | Файлы настроек и конфигураций
TMP | Временный файл

Устройства MS-DOS. В MS-DOS имеется ряд имен файлов, которые зарезервированы для внутреннего использования. Каждое такое имя отражает какое-либо устройство. Запрещается использование этих имен не по назначению. В табл. 4 приведен перечень этих имен.

Таблица 2

Имя | Назначение
AUX | Асинхронный интерфейс (Auxiliary – вспомогательный выход)
CLOCK$ | Драйвер часов
CON | Консоль (клавиатура, дисплей)
COM1 | Первый порт последовательного ввода/вывода (от COMmunication)
COM2 | Второй порт последовательного ввода/вывода
COM3 | Третий порт последовательного ввода/вывода
COM4 | Четвертый порт последовательного ввода/вывода
LPT1 | Первый порт параллельного ввода/вывода (от Line PrinTer 1)
LPT2 | Второй порт параллельного ввода/вывода
LPT3 | Третий порт параллельного ввода/вывода
NUL | Отсутствующий выход ("нулевое устройство")
PRN | Принтер (от PRiNter – аналог LPT1)

С точки зрения пользователя эти устройства ничем не отличаются от обычных файлов (с ними можно производить все те же операции, что и с обычными файлами). Однако не рекомендуется использовать имена файлов, построенные на базе вышеприведенных зарезервированных имен, такие, как: NUL.BAT, COM2.COO, PRN. TXT и т.п. Использование их в качестве расширений имен файлов допустимо: TEXT.PRN, FILE1.CON, FILE.NUL и т.п.

Символы подстановки в именах файлов. Когда необходимо произвести какие-либо действия над файлами пользователь вызывает определенные внутренние или внешние команды MS-DOS и передает им в качестве параметров имена файлов. Очень часто приходится производить одни и те же действия над многими файлами. Например, необходимо скопировать все файлы какого-либо каталога в другой каталог. Если файлов больше 200, то ровно 200 раз необходимо произвести эту операцию для каждого файла в отдельности. Это, как минимум, неудобно и непроизводительно для пользователя. Для решения такого рода проблем существуют специальные средства, которые помогают производить однотипные операции над целой группой файлов одной командой.

Так называемые символы подстановки, называемые также масками (по-английски они называются wildcards), позволяют фильтровать файлы, выполняя функцию обозначения места в имени файла. Такими масками являются знак вопроса(?) и звездочка (*).

Эти символы можно использовать в любом месте собственно имени файла и расширения. Символ ? означает, что команда при фильтрации файлов признает любой символ в имени или расширении файла, в позиции которого находится символ ?.

Символ * означает, что команда при фильтрации файлов признает все символы, в имени или расширении файла, начиная с позиции, где находится символ *.

Символы ? и * действуют не зависимо друг от друга применительно к имени или расширению.

Примеры:

Выполнить операцию над следующими группами файлов:

*.* – все файлы, без исключения;

*.txt – файлы с любыми именами, но с расширением txt;

II*.* – файлы, имена которых начинаются с цепочки символов II и имеющие любое расширение;

YE??0198.* – файлы, имена которых начинаются с цепочки символов YE, два следующих символа могут быть любыми, следующие четыре символа должны быть 0198, расширение любое.

Атрибуты файлов. Каждый файл и каталог имеет атрибут, который указывает на то, что этот файл является именно файлом, или на то, что он является каталогом. Файлы, в зависимости от атрибута, могут быть скрытыми, архивными, системными, только для чтения.


1.7. Глоссарий

BAT-файл (Batch-файл) – специальный текстовый файл, содержащий команду или группу команд MS-DOS (или вызовов программ), которые выполняются последовательно или в более сложном порядке.

CD-ROM – дисковод для воспроизведения информации, записанной на компакт-дисках.

EMB (расширенные блоки памяти) – блоки памяти, располагающиеся выше границы HMA.

EMS – дополнительная (expanded) оперативная память – вид оперативной памяти (свыше 640 кбайт) в компьютерах типа IBM PC. В отличие от расширенной памяти дополнительная память с помощью специальной аппаратуры и программного обеспечения отображается в диапазон адресов, лежащий ниже 1 Мбайт. Такой способ пригоден для компьютеров, использующих процессор Intel 8086, не обладающий возможностью адресации расширенной памяти.

FAT – таблица размещения файлов.

HMA-память (старшая область памяти) – это первые 64 кбайт расширенной памяти, начинающиеся с адреса FFFFh:0010h. Эта область может адресоваться процессором в реальном режиме и поэтому может быть использована обычными программами, предназначенными для работы в MS-DOS.

laptop (лэптоп) – портативный компьютер «наколенного» формата. Обычно такой компьютер может переноситься, как небольшой чемоданчик. Типичная масса – от 4 до 10 кг.

Norton Commander – неграфическая файловая оболочка.

notebook (ноутбук) – портативный компьютер «книжного» формата, обычный размер – 30х21х3-4 см, масса – 2-4 кг.

Plug-and-play – принцип динамического распределения ресурсов операционной системой.

POST – программа начального тестирования (Power-On Self Test) - это программа, прошитая в ПЗУ BIOS, которая выполняется при включении ПЭВМ. Она выполняет следующие действия:

  • анализирует установку DIP-переключателей (PC/XT) или содержимое памяти CMOS (AT и PS/2) для определения конфигурации подключенного к ПЭВМ оборудования и устанавливает соответственно флаги оборудования в области данных BIOS;
  • выполняет тестирование ОЗУ, записывая и считывая определенные данные во все адреса памяти;
  • исполняет тесты основных компонент ПЭВМ (контроллеров ПДП, прерываний, клавиатуры, дисководов и т. д.);
  • выполняет сканирование ПЗУ для инициализации дополнительных адаптеров;
  • вызывает программу начальной загрузки операционной системы или Бейсик, прошитый в ПЗУ.

UMB-память (верхние блоки памяти) – блоки памяти на машинах, использующих процессор 8086. Эти блоки памяти располагаются между границей 640 кбайт и 1 Мбайт.

XMS – спецификация, содержащая описание программного интерфейса драйвера HIMEM.SYS и рекомендации по использованию области памяти HMA.

Атрибуты файла – дополнительные параметры, определяющие свойства файла.

Архитектура ЭВМ – совокупность общих принципов организации аппаратно-программных средств и их характеристик, определяющая функциональные возможности ЭВМ при решении соответствующих классов задач.

Базовое программное обеспечение – самый низкий уровень программного обеспечения, отвечающий за взаимодействие с базовыми аппаратными средствами.

Байт – восемь взаимосвязанных битов, наименьшая единица измерения информации.

Бит – наименьшая единица измерения объема информации.

Винчестер (HDD ) – несъемный жесткий магнитный диск (пакет дисков).

Внешняя память (ВЗУ) предназначена для размещения больших объемов информации и обмена ею с оперативной памятью.

Внешние команды MS-DOS – отдельные программы, которые для выполнения загружаются командным процессором MS-DOS в ОЗУ.

Внутренние команды MS-DOS – команды, которые выполняются непосредственно командным процессором MS-DOS.

Внутренняя, или основная память — это запоминающее устройство, напрямую связанное с процессором и предназначенное для хранения выполняемых программ и данных, непосредственно участвующих в вычислениях.

Вычислительная техника – совокупность устройств, предназначенных для автоматической или автоматизированной обработки данных.

Гбайт – 1024 Мбайт.

Данные — это информация, представленная в формализованном виде и предназначенная для обработки ее техническими средствами, например, ЭВМ.

Деинсталляция программы – это обратный процесс, т.е. удаление программы.

Двоичное кодирование – система представления данных последовательностью двух знаков: 1 и 0.

Дорожка – концентрические окружности на магнитной поверхности диска, где располагается информация. Дорожки нумеруются с 0-й (дорожка с самым большим радиусом)

Инсталляция программы – это установка программы на персональный компьютер.

Информатика – наука , систематизирующая приемы создания, хранения, воспроизведения, обработки и передачи данных средствами вычислительной техники, а также принципы функционирования этих средств и методы управления ими.

Информационная техника представляет собой материальную основу информационной технологии, с помощью которой осуществляется сбор, хранение, передача и обработка информации.

Информационная технология — это совокупность методов, производственных процессов и программно-технических средств, объединенных в технологическую цепочку, обеспечивающую сбор, обработку, хранение, распространение и отображение информации с целью снижения трудоемкости процессов использования информационного ресурса, а также повышения их надежности и оперативности.

Информационный процесс — это процесс, в результате которого осуществляется прием, передача (обмен), преобразование и использование информации.

Информация – сведения об окружающем мире, которые повышают уровень осведомленности человека.

Каталог (папка) – это определенное место на диске (в области данных диска), где содержится информация о файлах и подкаталогах, привязанных к данному каталогу.

Кбайт – 1024 байт.

Кибернетика – наука об управлении.

Кластер – это минимальная порция информации, которую MS-DOS считывает/записывает за одно обращение диску. Кластер “содержит” только последовательно расположенные сектора (цель - увеличить скорость обмена с диском). Размер Кластера = N×(Размер Сектора)= N×512 байт, где N = 2,4,8 и т.д.

Кодирование данных – выражение данных одного типа через данные другого типа.

Количеством информации называют числовую характеристику сигнала, отражающую ту степень неопределенности (неполноту знаний), которая исчезает после получения сообщения в виде данного сигнала. Эту меру неопределенности в теории информации называют энтропией.

Компьютер – это электронный прибор, предназначенный для автоматизации создания, хранения, обработки и транспортировки данных.

Мбайт – 1024 Кбайт.

Обмен информацией — это процесс, в ходе которого источник информации ее передает, а получатель — принимает.

Обработка информации — это упорядоченный процесс ее преобразования в соответствии с алгоритмом решения задачи.

Операционная система – набор программ и драйверов, обеспечивающих взаимодействие программ с аппаратным обеспечением компьютера и базовые возможности для ввода команд пользователем.

Оперативная память служит для приема, хранения и выдачи информации.

Пользовательский интерфейс – методы и средства взаимодействия человека с аппаратными и программными средствами.

Постоянная память обеспечивает хранение и выдачу информации. В отличие от содержимого оперативной памяти, содержимое постоянной заполняется при изготовлении ЭВМ и не может быть изменено в обычных условиях эксплуатации.

Преобразование данных – перевод данных из одной формы в другую или из одной структуры в другую.

Прикладное программное обеспечение – комплекс программ, с помощью которых на данном рабочем месте выполняются конкретные задания.

Программа – упорядоченная последовательность команд.

Процессор, или микропроцессор, – основное устройство ЭВМ, предназначен для выполнения вычислении по хранящейся в запоминающем устройстве программе и обеспечения общего управления ЭВМ.

Расширенная память (Extended Memory) – это память, используемая в компьютерах с процессорами 80286 и выше, располагающаяся в адресном пространстве выше одного мегабайта.

Регистры CPU – специальные внутренние устройства CPU, которые предназначены для хранения информации.

Резидентная программа – программа, которая после загрузки в ОЗУ и передаче ей управления инициализируется таким образом, что постоянно находится в ОЗУ и выполняется параллельно другим программам.

Самоустанавливающиеся устройства – устройства, удовлетворяющие принципу plug-and-play.

Сбор информации — это деятельность субъекта, в ходе которой он получает сведения об интересующем его объекте.

Сектор – каждая дорожка, размещенная на диске, делится на секторы. Каждый сектор имеет размер = 512 байт (для MS-DOS)

Сигнал (от латинского signum — знак) представляет собой любой процесс, несущий информацию.

Системное программное обеспечение – программное обеспечение, отвечающее за взаимодействие прочих программ компьютерной системы с программами базового уровня, а также средства пользовательского интерфейса.

Системный интерфейс — это конструктивная часть ЭВМ, предназначенная для взаимодействия ее устройств и обмена информацией между ними.

Слово – 16 взаимосвязанных битов (2 взаимосвязанных байта).

Служебное программное обеспечение (утилиты) – обеспечивает автоматизацию проверки, наладки и настройки компьютерной системы.

Сообщение — это информация, представленная в определенной форме и предназначенная для передачи.

Тбайт – 1024 Гбайт.

Технология — это совокупность знаний о способах и средствах проведения производственных процессов, при которых происходит качественное изменение обрабатываемых объектов.

Указатель мыши – активный элемент управления, графический объект, перемещение которого на экране синхронизировано с перемещением мыши.

Устройства ввода-вывода служат соответственно для ввода информации в ЭВМ и вывода из нее, а также для обеспечения общения пользователя с машиной.

Файл (по-английски file – папка, скоросшиватель) – это поименованная область памяти на каком-либо физическом носителе, предназначенная для хранения информации.

Флоппи-диск (дискета) – съемный гибкий магнитный диск.

Хранение информации — это процесс поддержания исходной информации в виде, обеспечивающем выдачу данных по запросам конечных пользователей в установленные сроки.

Цилиндр – объединение дорожек с одним и тем же номером, расположенных на разных поверхностях диска(для флоппи-диска под цилиндром подразумевается 2 дорожки)


1.8. Библиографический список

1. Франкен Г., Молявко С. MS-DOS 6.2 ... для пользователя – Киев: Издательская группа BHV, 1994. – 227 с.

2. Фигурнов В.Э. IBM PC для пользователя. Краткий курс. – М.:ИНФРА-М, 1999. – 480 с.

3. Информатика. Базовый курс / Симонович С.В. и др. – СПб.: Питер, 1999. – 640 с.

4. Брябрин В.М. Программное обеспечение персональных ЭВМ. – М. Наука, 1990. – 272 с.

5. Фролов А.В., Фролов Г.В. Аппаратное обеспечение IBM PC: В 2 ч. – М.: "ДИАЛОГ-МИФИ", 1992. – 208 с.

6. Пасько В., Колесников А. Самоучитель работы на персональном компьютере: – 2-е изд., доп. – Киев: Издательская группа BHV, 1999. – 656 c.

7. Орлов С.Б. Обзор команд и драйверов MS-DOS 6.2
URL: http://www.citforum.ru/operating_systems/msdos/index.shtml

8. Русская компьютерная библиотека
URL: http://rusdoc.df.ru


1.6. Контрольные вопросы

  1. Что такое информация?
  2. Что такое информатика?
  3. Что такое данные?
  4. Что такое информационные технологии?
  5. Какими основными свойствами характеризуются информационные технологии?
  6. Что такое архитектура ЭВМ?
  7. Какие основные устройства содержит любая ЭВМ неймановской архитектуры?
  8. Каковы основные эксплуатационно-технические характеристики вычислительной техники?
  9. По каким признакам отличают одно поколение компьютеров от другого?
  10. Как связаны эти признаки между собой?
  11. Какие существуют виды программного обеспечения?
  12. Как кодируется информация для обработки с помощью компьютера?
  13. В чем измеряется информация?
  14. Что такое кластер?
  15. Что такое корневой каталог?
  16. Что обозначает символы "*" , "?"в маске файла?
  17. Без каких программ работа компьютера невозможна?
  18. Что такое операционная система?
  19. Перечислите основные функции операционной системы?
  20. Что такое интерфейс? Какие виды интерфейса Вы знаете?
  21. Что такое файл? Как организовано хранение файлов на дисках?
  22. Что такое каталог?
  23. На что указывает расширение файла?
  24. По каким правилам формируется короткое имя файла и длинное имя файла?
  25. Что такое полное имя файла?
  26. Какие Вы знаете функции операционной системы по обслуживанию файловой структуры?
  27. В чем заключается операция установки приложения?
  28. Что такое инсталляция программы?


8.1. Интернет. Основные понятия

Объединение компьютеров, расположенных в непосредственной близости друг от друга (в одном или в нескольких соседних зданиях), с помощью специальных кабелей и программ управления принято называть локальной сетью. Если же в общую сеть объединяются компьютеры или локальные сети, удалённые друг от друга на значительные расстояния (в пределах одного или нескольких государств), такую структуру именуют распределённой или территориальной сетью.

Глобальные сети – это распределённые сети всемирного масштаба. Самой известной и доступной глобальной сетью является Интернет (Internet). Сеть Интернет не является устойчивой структурой, она постоянно изменяется самими пользователями Сети, число которых уже исчисляется миллионами.

Важнейшая особенность этой глобальной сети: отсутствие централизованного управления.

Следствием этого является абсолютная свобода информационного пространства. Это обстоятельство провоцирует бесконечные споры о цензуре в Сети. Хотя, несомненно, именно неограниченная свобода и привлекает массы пользователей Интернета.

Прообразом современной сети Интернет принято считать американскую военно-промышленную территориальную сеть ARPA. ARPA – Advanced Research Project Agency (Агентство по Передовым Исследовательским Проектам) – одно из подразделений Министерства Обороны США, в недрах которого 2 января 1969 г., после пятилетних дебатов, было принято решение о начале работы над проектом по созданию сети компьютеров оборонных организаций (ARPANet). Сеть должна сохранять работоспособность в условиях ядерной атаки. К 1972 г. сорок компьютерных центров могли обмениваться между собой электронной почтой, осуществлять сеансы работы с удаленными на несколько сотен и тысячи километров машинами и передавать файлы с данными.

Идеологическая основа проекта: отсутствие общего центра управления, полная самостоятельность каждого сегмента. Обмен информацией между узлами сети с гарантированной доставкой сообщений обеспечивался специальным набором протоколов TCP/IP. Сообщения для передачи разбиваются на небольшие специфицированные элементы, названные пакетами. Каждый пакет имеет информацию об адресе назначения, доставка сообщения обеспечивается тем, что каждый узел имеет возможность посылать (или переадресовывать) пакеты по сети к месту назначения. При этом узел сам выбирает наиболее быстрый путь для каждого пакета в соответствии с состоянием соседних участков сети. Таким образом, возможна ситуация, когда разные части файла (пакеты) добираются до адресата различными путями, при этом его окончательная сборка происходит на компьютере получателя (см. рис. 8.1).

Рис. 8.1. Схема, иллюстрирующая движение пакетов с данными в сети Интернет

Кроме того, был разработан ряд стандартных утилит для передачи файлов (FTP), для дистанционного запуска программ (Telnet) и для обмена электронной почтой (SMTP). В 1990 г. этот процесс был полностью завершен. Тогда же Federal Networking Council (Федеральный Совет по Информационным Сетям) отменил требование, заключавшееся в том что для подсоединения к Интернет была необходима рекомендация какого-либо государственного органа США. Это решение послужило началом эпохи коммерциализации Интернета, поскольку теперь любая организация могла получить доступ к Интернет без каких либо серьезных оговорок или обоснований. С 1992 г. Интернет удваивает свои ресурсы каждые полгода. Разумная оценка числа компьютеров, подключенных в сеть Интернет в 1995 г. – 6,5 млн, в марте 2001 г. – 379 млн [9]. Реальную статистику числа компьютеров в сети Интернет и числа серверов получить весьма трудно, так как эти данные меняются практически ежедневно. По прогнозам аналитиков, в 2003 г. пользователей Сети будет порядка 500-600 млн, а в 2005 году – более 800 млн человек.

Интернет можно рассматривать как совокупность миллионов узлов, связанных друг с другом всевозможными линиями связи (рис. 8.2). При этом, узлом может являться как отдельный компьютер, так и локальная сеть. Взаимодействие узлов не зависит от типов компьютеров, их архитектуры и операционных систем, а также физической реализации связи между ними. Обмен информацией между узлами Сети происходит с помощью специальных протоколов – своеобразных предписаний к взаимопониманию. При этом проблемы отдельного узла не могут глобально повлиять на Сеть. Во избежание путаницы при передаче информации ведётся контроль лишь за уникальностью имени узла (адреса).

Рис. 8.2. Интернет как совокупность узлов,
связанных друг с другом всевозможными линиями связи

Как правило, Интернет ещё рассматривают как некое информационное пространство, состоящее из большого количества взаимосвязанных сервисов (услуг, служб). Их приблизительно можно разделить на интерактивные (on-line), прямые и отложенного чтения (off-line). Наиболее простая аналогия – телефон, факс и почтовое отправление соответственно. Все эти сервисы имеют свои названия.


Программное обеспечение Интернет

Успешное использование сети Интернет в значительной степени зависит от правильного выбора программного обеспечения. К сожалению, не представляется возможным дать какие бы-то ни было универсальные рекомендации по этому поводу. Во-первых, потому что очень многое зависит от специфики Ваших интересов, конфигурации Вашего компьютера и избранной операционной системы. Во-вторых, Интернет постоянно развивается, меняются лидеры в программном обеспечении, возникают новые стандарты и новые методы их реализации.

На сегодняшний день программное обеспечение Интернета условно можно разбить на несколько больших групп:

1. Браузеры (browsers) – исследователи Всемирной Паутины (WWW). Это программы, позволяющие находить и просматривать гипертекстовые документы, опубликованные в Сети и на Вашем компьютере: Microsoft Internet Explorer, Netscape Navigator, Opera.

2. Почтовые программы (e-mail programmes) – специальные программы для принятия, отправки, сортировки и просмотра электронной почты: Eudora, The Bat!, MS Outlook, Pegasus.

3. FTP-клиенты – программы для обмена файлами: CuteFTP, WS_FTP.

4. Менеджеры загрузки (download manager) – программы для перекачки файлов из Сети: Go!Zilla, ReGet, GetRight.

5. Программы общения (chat programmes) – программы, предоставляющие возможность вести переговоры в Сети как в текстовом режиме, так и в режиме аудио и видео обмена: MicroIRC, ICQ, IPhone, EasyTalk, NetMeeting.

6. Программы дозвона (dialer programmes) – программы для соединения с провайдером по одному или нескольким номерам телефонов: E-type Dialer, Advanced Dialer.

7. HTML-редакторы – программы для подготовки Web-документов: FrontPage 2000, DreamWeaver.

8. Дополнительные программы – для доступа к аудио и видео информации (RealPlayer), для онлайнового перевода гипертекстов на русский язык (Web TranSite), для создания интерактивных описаний (HTML Help), для закачки сайтов и страниц (Teleport Pro).

Очевидно, что этим перечнем список программного обеспечения Интернета не ограничивается. Каждая из групп может быть значительно пополнена примерами.


8.2. Сервис World Wide Web (WWW) – всемирная паутина

8.2. Сервис World Wide Web (WWW) –
всемирная паутина

World Wide Web – интерактивный сервис Internet, в основу которого положено гипертекстовое представление информации в Сети. На серверах Web структуризация данных происходит не на уровне совокупностей данных (файлов), а внутри них. В самих документах имеются ссылки на другие документы, в которых может находиться пояснение или иллюстрация какой-то мысли или термина в исходном тексте. Такая схема представления данных и называется гипертекст; ему присуща не древовидная структура хранения данных (как в файловой системе), а сетевая. Отсюда и пошло название серверов Web (паутина).

Гипертекст позволяет просматривать информацию, выбирая при каждом доступе к ней новый маршрут (или гипертекстовую связь). Стандарт на правила построения таких документов известен как HTML (HyperText Markup Language). Каждый отдельный HTML-файл называется страницей.

WWW – это система клиент/сервер, которая поддерживает эти гипертекстовые связи.

Информация на WWW-сервере обычно представлена в виде отдельных страниц, содержащих не только текст, но и графические объекты, звук и видео. В связи с этим, для поддержки данного сервиса требуются быстрые линии связи и соответствующее оборудование (компьютеры, модемы, сетевое оборудование).

Клиентская часть для работы с такой информацией, проводник Internet (или browser), позволяет просматривать все эти типы данных, запускать внешние приложения. Существует множество реализаций проводников Internet от разных поставщиков, и от выбора программы просмотра зависит, насколько комфортно смогут чувствовать себя пользователи, работая в глобальной сети. В настоящее время наибольшее распространение получили браузеры фирм Microsoft и Netscape: Internet Explorer и Netscape Navigator соответственно. Схема работы проста: клиент запрашивает информацию, в ответ на запрос сервер посылает информацию клиенту. Для определения запроса в web-браузере необходимо ввести специальную строку URL – Uniform Resource Locator (универсальный указатель ресурса). Например, http://www.bsu.edu.ru

IP-адресация и система доменных имен

Для обеспечения уникальности имени каждого узла в сети Интернет применяется специальная система, именуемая IP-адресацией. Различают фиксированные (постоянные) и временные IP-адреса. Большинство пользователей, подключающихся к сети через обычные модемы для установления временного сеанса связи, не имеют фиксированного IP-адреса. Им присваивается лишь временный IP-адрес. Компьютеры в организациях, локальные сети которых подключены к Интернету 24 часа в сутки, как правило, имеют свои уникальные фиксированные IP-адреса.

Адрес IP (Internet Protocol) – это 32-битный компьютерный адрес, с которым непосредственно работают компьютеры Internet. IP-адрес записывается в виде четырех чисел, разделенных точками, например, 196.201.90.0. Каждое из четырех чисел не превышает значение 255. Трактоваться числовой адрес может по-разному. Обычно в нём отражаются класс сети, номер сети и номер компьютера.

Для того чтобы узнать IP-адрес вашего компьютера, можно запустить входящую в состав Windows 98 программу WINIPCFG.exe: меню Пуск->Выполнить->WINIPCFG. Для того, чтобы определить IP-адрес компьютера в Интернет, например Web-сервера фирмы Microsoft, запустите программу PING.exe, указав в качестве параметра адрес этого сервера: меню Пуск->Выполнить-> PING www.microsoft.com.

Цифровая нумерация является языком общения компьютеров, однако очень неудобна для запоминания. Поэтому существует другой тип адресации: система доменных имен. Слово «домен» (domain) можно перевести как «территория, сфера, область». Служба имен доменов – Domain Name System (DNS) – транслирует имена компьютеров в соответствующие адреса IP и обратно. Благодаря этому пользователю не нужно ничего знать о компьютерных IP-адресах.

В доменном адресе, как правило, отражаются: имя, определение рода деятельности владельца и код страны. Например, в адресе www.bsu.edu.ru, www указывает на принадлежность узла к Всемирной Информационной Паутине (World Wide Web), bsu – название организации (БелГУ) , а ru (Russia) указывает на место дислокации данной организации. Исторически сложились следующие сокращения для определения в доменном адресе рода деятельности организации:

  • com или co (коммерческие организации),
  • edu (учебные и научные организации),
  • gov (правительственные организации),
  • mil (военные организации),
  • net (сетевые организации разных сетей, в том числе, провайдеры),
  • org (другие организации).

Для указания страны используются двухбуквенные коды: ru (Россия), ua (Украина), uk (Великобритания), jp (Япония), de (Германия), fr (Франция) и т.д.

URL (Uniform Resource Locator)

Адрес ресурса записывается в нотации, которая называется URL (Uniform Resource Locator). Запись URL имеет следующий формат:

<схема доступа>://<имя_машины .имя_домена/полное_имя_файла>.

Примерами значений параметра <схема доступа> могут быть http, ftp, gopher. Вторая часть URL, то есть <имя_машины.имя_домена /полное_имя_файла>, определяет удаленный компьютер сети, на котором хранится данная информация и полное указание местоположения файла в файловой системе удаленного компьютера.

Название схемы доступа отделяется двумя косыми чертами (//) от Интернет-адреса компьютера, который, в свою очередь, отделен одной косой чертой (/) от полного (с указанием пути) имени файла.

Пример: страница издательства Санкт-петербургского государственного медицинского университета имеет URL http://www.spmu.runnet.ru/ publishing/.

Рассмотрим, как разделить этот адрес на составляющие: http: – эта последовательность символов означает, что для доступа к ресурсу используется протокол передачи гипертекста (HTTP протокол); www.spmu.runnet.ru – идентифицирует Интернет-адрес компьютера сети, на котором размещен данный ресурс; publishing – имя папки, в которой находятся файлы.

Как же программа просмотра WWW использует URL для нахождения страницы в Интернет? Когда программа-просмотрщик (броузер) получает от Вас адрес страницы, например, http://www.med.upenn.edu/ educate/, она выделяет имя домена из этого URL в соответствии с вышеописанной схемой. В нашем случае это med.upenn.edu. Это имя передается серверу DNS вашего провайдера.

Система серверов DNS может быть представлена как очень большая база данных. Сервер DNS получает доменное имя и возвращает в ответ соответствующий IP-адрес (в нашем случае – 165.123.128.12). Этот IP-адрес используется не только для идентификации компьютера сети, но и для маршрутизации передаваемого ему запроса. Начальная последовательность цифр адреса, 165, направляет запрос в Северную Америку. Дополнительные маршрутизаторы, связывающие различные сегменты Интернет в Северной Америке, в итоге направят запрос в г. Филадельфию, штат Пенсильвания, в Университет штата Пенсильвания. Как только запрос попадет на маршрутизатор домена с именем med.upenn.edu, он переправляется на компьютер с именем www, в соответствии с первой частью имени домена, и, в итоге, ссылается на соответствующий каталог /educate/ и файл index.html.

Компьютер, на котором находится этот файл, направит пакеты с его содержимым по IP адресу Вашего компьютера.

Замечание 1. Все имена ресурсов в Интернет – англоязычные.

Замечание 2. Как правило, системы, поддерживающие связь компьютеров в Интернет, нечувствительны к регистру букв (СТРОЧНЫЕ/прописные), однако при вводе URL рекомендуется набирать текст в точном соответствии с предлагаемым адресом страницы.

Замечание 3. Будьте внимательны! Не всегда URL может начинаться с привычных http:// и www.


8.3. Работа с Internet Explorer

Ввод URL в строке адреса

Ввод адреса нужной страницы в адресной строке браузера – один из наиболее частых приемов навигации по Web. При этом не обязательно вводить наименование протокола http:// перед каждым URL страницы Web, так как Internet Explorer сделает это самостоятельно.

С помощью ввода в строке адреса можно обратиться не только к узлам Web, но и к другим ресурсам Интернета. Если сам браузер не способен выполнить затребованную функцию, то будет вызвано приложение, поддерживающее нужный протокол. К примеру, если в строке адреса ввести news:relcom.newusers, то будет вызвана программа Outlook Express (или иной клиент новостей, установленный по умолчанию на вашем компьютере), и эта уже программа загрузит указанную группу новостей. Ниже в табл. 1 представлены виды ресурсов, которые можно ввести в адресной строке браузера.

Дополнительный совет: если вы посещаете чью-либо домашнюю страницу, расположенную на сервере под управлением UNIX, то адрес этой страницы может содержать знак тильды (~), – не забывайте правильно вводить этот знак с клавиатуры.

Таблица 1

Тип файла (ресурса) | Пример URL, на который показывает ссылка
Web-страница | http://www.mysite.ru/my-page.htm
Файл | file://C:/picture.bmp
Файл мультимедиа | http://www.mysite.ru/video.avi
Адрес электронной почты | mailto:user@company.ru
FTP-сервер | ftp://ftp.mysite.ru
Gopher-сервер | gopher://gopher.mysite.com
Статья UseNet | news:relcom.newusers
Сеанс Telnet | telnet://mysite.ru

Автозавершение адреса

В браузере Internet Explorer можно использовать функцию автозавершения URL для тех адресов, которые уже когда-то посещались. Для этого достаточно ввести несколько первых символов адреса, а браузер сам допишет остальное. Чтобы включить или отключить эту функциональную возможность в браузере Internet Explorer, следует установить или соответственно снять флажок Использовать встроенное автозаполнение для веб-адресов на закладке Дополнительно окна Свойства обозревателя. Чтобы вызвать это окно, выберите пункт Свойства обозревателя в меню Вид.

В браузере Internet Explorer можно использовать функцию автозавершения URL для тех адресов, которые уже когда-то посещались. Для этого достаточно ввести несколько первых символов адреса, а браузер сам допишет остальное. Чтобы включить или отключить эту функциональную возможность в браузере Internet Explorer, следует установить или соответственно снять флажок Использовать встроенное автозаполнение для веб-адресов на закладке Дополнительно окна Свойства обозревателя. Чтобы вызвать это окно, выберите пункт Свойства обозревателя в меню Вид.


Переключение кодировок русского языка

«Выберите кодировку...» – эта надпись очень часто встречается на отечественных серверах Web. Исторически получилось так, что локальные кодировки, принятые на компьютерах с разными операционными системами (Windows, UNIX, DOS, Mac), продолжают существовать и в виде сетевых кодировок. Поэтому, если загрузив какую либо страницу Web, вы видите набор совершенно непонятных символов кириллицы, то это значит, что кодировка на сервере не совпадает с кодировкой, установленной в браузере. В таком случае можно выбрать кодировку на сервере с помощью имеющегося там меню или сменить кодировку у браузера. Второй способ – более универсальный, так как ряд серверов не предоставляет возможности сменить кодировку.

Вообще говоря, за стандартную кодировку русских страниц в Интернете принята так называемая кодировка KOI8-R (которую поддерживают компьютеры под управлением UNIX). Именно она описана в RFC-1489, официальном документе комитета InterNIC (ftp://ds.internic.net/rfc/rfc1489.txt). Однако повсеместное внедрение Windows на ПК и серверов World Wide Web под управлением операционной системы Windows NT составляет «оппозицию» этому стандарту, реализуя «явочным порядком» поддержку кодировки 1251, принятой в различных версиях Windows. Кроме того, в российской части Интернета вы встретите и такие серверы, где документы представлены всего лишь в одной кодировке. Пример одного из узлов, где поддерживается только кодировка Windows 1251 – это узел российского представительства Microsoft (http://www.microsoft.com/rus).

Чтобы изменить кодировку русскоязычной страницы Web в браузере Internet Explorer, выберите пункт Вид кодировки в меню Вид. Откроется список возможных кодировок, в котором нужно выбрать нужную. Еще один способ – с помощью локального меню. Для этого, расположив указатель мыши на текстовой части страницы, щелкните правой клавишей мыши. Появится выпадающее меню, где будет пункт Вид кодировки, а далее уже следует выбрать нужную вам кодировку.


Использование гиперссылок

Гипертекстовые ссылки (для краткости – «ссылки») соединяют друг с другом страницы документов Web в сети Internet. Ссылки направляют или внутри одной страницы, или одного сервера, или на какой-либо другой сервер.

Любая ссылка состоит из двух частей. Первая из них – это то, что отображается на странице и называется она указатель. Другая, невидимая, скрыта в документе и называется адресной частью ссылки (URL).

Указатель ссылки может быть рисунком, трехмерным изображением или текстом другого цвета (обычно с подчеркнутым шрифтом). Чтобы узнать, является ли элемент страницы ссылкой, подведите к нему курсор мыши. Если курсор принимает вид ладони, элемент является ссылкой.

Адресная часть ссылки – это, как правило, адрес страницы Web, которую Internet Explorer должен загрузить. Кроме того, ссылки могут указывать еще на целый ряд файлов и ресурсов Web. Типы файлов и ресурсов, на которые могут указывать ссылки, приведены в табл. 1.

Использование ссылок в документах – это основной метод для переключения браузера между документами. Все присутствующие на странице ссылки помещены туда авторами этих документов и связаны непосредственно с контекстом документа. Для перехода по ссылке достаточно щелкнуть на ней мышью.

Функции кнопок Вперед и Назад

Кнопки Вперед и Назад – наиболее часто используемый инструмент браузера при навигации по Web.

Нажатие на эти кнопки последовательно возвращает к предыдущему или следующему просмотренному документу внутри списка уже просмотренных документов. Как только будет достигнут последний из просмотренных ранее документов, кнопка Назад станет недоступна, а если пролистать список вперед до первого просмотренного документа, – то станет недоступна кнопка Вперед.

Можно сразу перейти к нужному документу через несколько просмотренных документов.

Для этого щелкните по маленькой кнопке-стрелке справа от основной кнопки. Будет показан текущий список из последних просмотренных страниц (числом не более 9 в списке), и можно выбрать именно ту страницу, куда вы желаете перейти. Для быстрого перехода на страницы, посещенные еще раньше, в том числе в предыдущие сеансы работы с браузером, – используйте кнопку Журнал на панели браузера (см. ниже).

Прекращение загрузки ненужной страницы

Довольно часто случается, что после перехода по ссылке на какую-либо страницу, она грузится очень долго, и уже видно, что ее содержание вам не интересно. Для того, чтобы прервать загрузку такой страницы, нажмите кнопку Остановить на панели инструментов браузера или просто клавишу Esc на клавиатуре ПК. Затем можно нажать кнопку Назад, чтобы вернуться к предыдущей странице.

Использование кнопки Обновить

При навигации по Web может оказаться, что какая-либо страница загрузилась не полностью, причем особенно часто это бывает с картинками. Или вдруг скорость загрузки страницы неожиданно резко упала. Такое случается сплошь и рядом, поскольку загрузка каналов Интернета все время изменяется, периодически возникают сбои передачи и потеря части переданной информации. В таких случаях помогает кнопка перезагрузки страницы Обновить. При нажатии на эту кнопку текущая страница заново передается с сервера на ваш компьютер, и часто этого бывает достаточно для разрешения проблемы.

Кроме того, у кнопки обновления есть еще одна функция, связанная с использованием дисковой кэш-памяти. Дело в том, что переданные из Интернета страницы хранятся на жестком диске вашего компьютера в виде временных файлов. Когда вы нажимаете кнопки Вперед или Назад, то браузер может загрузить страницу с сервера или же восстановить из временного файла с диска. Как правило, по умолчанию браузер грузит страницу с жесткого диска (вы можете выбрать нужный режим с помощью параметров из окна Свойства Обозревателя, вызываемого из меню Вид).

Нажатие кнопки Обновить заставляет браузер загрузить страницу с сервера заново, что особенно важно для тех страниц, где информация часто меняется (например, с финансовой информацией по текущим торгам, новостями и т.п.).


Выбор начальной страницы

Любой браузер позволяет загрузить начальную страницу не только в начале каждого сеанса работы с браузером, но и в любой момент в течение работы. В Internet Explorer для этого достаточно нажать кнопку Домой на панели, и произойдет возврат к начальной странице. Таким образом можно будет возвращаться на начальную страницу. По умолчанию она расположена на сервере Microsoft.

Рис. 8.3. Свойства обозревателя

Для изменения адреса домашней страницы в Internet Explorer достаточно выбрать пункт Свойства обозревателя меню Вид. В диалоговом окне можно ввести адрес новой начальной страницы, и кроме того, браузер дает возможность назначить таковой ту страницу, которая загружена в окне в данный момент времени (см. рис. 16). В верхней части вкладки расположено окно Домашняя страница, куда можно или вручную ввести нужный адрес, или заполнить это окно автоматически – нажав на одну из кнопок, выбирающей адрес текущей, пустой или исходной страницы (исходная страница – страница «Добро пожаловать в Интернет», http://home.microsoft.com/intl/ru). Нажмите кнопку ОК, чтобы подтвердить сделанные изменения.

В качестве рекомендации можно посоветовать установить в качестве начальной страницы адрес организации или университета, где вы работаете или учитесь (например, у БелГУ это www.bsu.edu.ru). Другой полезный вариант – установить в качестве адреса начальной страницы адрес узла вашего провайдера. Тогда вы всегда будете в курсе новостей, которые затрагивают вашу работу, учебу или кошелек.

Можно также создать HTML-файл на жестком диске со ссылками на ваши любимые узлы Web, и назначить его в качестве начальной страницы. Такой локальный файл будет грузиться очень быстро, позволяя тем самым скорее приступить к работе с браузером и является хорошей альтернативой выбору пустой страницы (которая мгновенно грузится, но не содержит никакой информации).


Приемы навигации

Использование внутренних средств навигации узла

Как бы не были удобны универсальные кнопки Вперед и Назад, для перемещения между страницами конкретного узла зачастую эффективнее использовать внутренние средства навигации узла (если такие средства предусмотрены создателями данного узла). Обычно подобные средства навигации оформлены в виде графических ссылок с изображением кнопок со стрелками или надписями. Такая графическая панель управления обычно располагается сбоку или же в верхней или нижней части страницы. Графические кнопки управления позволяют вернуться на заглавную страницу узла, а также перейти к тем или иным его разделам. Достаточно часто там же есть изображения кнопок, которые дублируют кнопки Вперед и Назад на панели инструментов браузера.

Навигация по документам, содержащим фреймы

В Web часто встречаются страницы, разделенные на несколько независимых частей – кадров (или как их чаще называют, фреймов). Обычно в каждом из таких фреймов содержится информация, логически отделенная от информации на другом фрейме. В зависимости от того, как задуман художественный дизайн страницы, на фреймах могут присутствовать или отсутствовать полосы прокрутки изображения, а также возможность передвигать границу между фреймами (примерно так же, как вы передвигаете границу между панелями в Проводнике Windows).

Не всегда дизайн фреймов удачен, из-за чего многие пользователи Интернета недолюбливают страницы с фреймами. Кроме того, на страницах с фреймами кнопки Вперед и Назад на панели инструментов браузера работают несколько иначе – если содержание фреймов может изменяться (чаще всего боковые фреймы – статичны, и изменяется содержание только в основном фрейме), то кнопки действую на текущий фрейм до тех пор, пока вы не вернетесь к самой первому изображению фрейма. Таким образом, при навигации по узлу с фреймами приходится чаще обычного нажимать кнопки Назад и Вперед.

И последнее: хотя научиться работать с фреймами достаточно просто, ряд узлов предоставляет возможность ознакомиться с их содержанием без использования фреймов. Если вы предпочитаете страницы без фреймов, поищите, имеется ли на заглавной странице узла ссылка Non-frame version (Версия без фреймов).

Навигация в режиме полного окна

Если вы работаете с монитором, имеющим небольшой экран (14 или 15 дюймов), то при просмотре ряда узлов со сложным дизайнерским решением вам может помочь кнопка Во весь экран на панели инструментов Internet Explorer (или клавиша F11). В отличие от стандартной кнопки Windows-приложения Раскрыть, кнопка Во весь экран не только раскрывает окно браузера на максимальный размер окна, но одновременно закрывает все панели Internet Explorer, кроме панели инструментов. Таким образом, вы можете получить дополнительное пространство для просмотра, не занимаясь вручную операциями по закрытию панелей браузера. Чтобы вернуться из полноэкранного режима к обычному виду окна, используйте стандартную кнопку Свернуть в правом верхнем углу полноэкранного окна.

Навигация с помощью клавиатуры

Некоторые пользователи любят применять комбинации нажатия клавиш клавиатуры вместо того, чтобы щелкать указателем мыши по кнопкам и меню браузера. Для них в табл. 2 приведены основные комбинации клавиш.

Таблица 2

Действие по навигации | Комбинация клавиш клавиатуры
Назад | Alt + Левая стрелка или Backspace
Вперед | Alt + Правая стрелка
Переход между кадрами вперед | CTRL+Tab
Переход между кадрами назад | Shift+CTRL+Tab
Переход к следующей ссылке | Tab
Возврат к предыдущей ссылке | Shift + Tab
Переход по данной ссылке | Enter
Прокрутка страницы вниз (плавно) | Стрелка вниз
Прокрутка страницы вниз (кусками) | Page Down
Прокрутка страницы вверх (плавно) | Стрелка вверх
Прокрутка страницы вверх (кусками) | Page Up
Переход в конец документа | End
Переход в начало документа | Home
Обновить данную страницу | F5
Прекращение загрузки страницы | Esc
Открыть новое окно | CTRL+N
Сохранить текущую страницу | CTRL+S
Напечатать текущую страницу или кадр | CTRL+P

Навигация с помощью мыши MS IntelliMouse

Если на вашем компьютере установлена мышь Microsoft IntelliMouse, то в Internet Explorer ее можно использовать для выполнения следующих действий. Чтобы пролистывать Web-страницы, вращайте колесико вперед или назад. Чтобы непрерывно пролистывать текущие страницы Web, двигайте саму мышь, удерживая нажатой кнопку-колесико. Вместо того, чтобы нажимать кнопки Вперед и Назад, можно соответственно, выполнить «прокрутку» колесиком вперед, а чтобы вернуться к предыдущей странице, – «прокрутку» назад. Для этого необходимо, не отпуская клавишу SHIFT, вращать назад кнопку-колесико.

Панель Журнала браузера Internet Explorer

В браузере Internet Explorer существует очень полезная функция – панель Журнала. С ее помощью можно легко найти адрес любой ранее посещенной страницы Web и загрузить ее снова.

Чтобы панель Журнала появилась на экране (рис. 8.4), достаточно нажать кнопку Журнал на панели инструментов или выбрать пункт Панели обозревателя в меню Вид, откуда уже выбрать подпункт Журнал. Сразу после этого область просмотра браузера будет разделена на две части, где на левой стороне выводятся даты, включая сегодняшнюю. Чтобы познакомиться со списком адресов узлов, просмотренных в конкретный день, следует щелкнуть по нужной дате, и далее – по адресу конкретной страницы, которая будет загружена в браузер.

Рис. 8.4. Панель Журнала

По умолчанию, браузер ведет учет адресов страниц, просмотренных в течение последних 20-ти дней. Чтобы изменить этот период в сторону увеличения или уменьшения, выберите пункт Свойства обозревателя меню Вид. На закладке Общие можно изменить продолжительность периода ведения Журнала, а также стереть все текущие записи, для чего можно нажать кнопку Стереть. Затем достаточно нажать OK, чтобы сделанные вами изменения вступили в силу.


Поиск в Интернет

Поиск в Web – это во многом искусство, основанное на знании самой Сети, возможностях поисковых систем и в значительно меньшей степени – на возможностях конкретного браузера. Тем не менее, поскольку умение правильно применять существующие инструменты – основа любого искусства, рассмотрим те функции по поиску в Web, которые встроены прямо в интерфейс Internet Explorer.

Использование панели поиска в Internet Explorer

  • Rambler (русский Web-индекс и каталог);
  • Апорт! (русский Web-индекс);
  • Яndex (русский Web-индекс);
  • Alta Vista (международный Web-индекс);
  • Lycos (международная система поиска с индексом и каталогом);
  • Excite (международный Web-индекс).

Преимущество такой панели – вы можете отправить запрос на несколько серверов с одной страницы, значительно экономя время на том, что не надо загружать заглавные страницы этих поисковых серверов друг за другом. Подобные средства, обеспечивающие доступ сразу к нескольким поисковым системам (типа рассмотренной панели в Internet Explorer с доступом к нескольким серверам), называются мета-поисковыми средствами поиска.

К сожалению, подобные средства мета-поиска отнюдь не свободны от недостатков. Главный из них состоит в том, что мета-поиск на поддерживаемых серверах осуществляется по наиболее упрощенной методике (Simple Search). Это связано с тем, что каждая поисковая система имеет свой набор дополнительных опций по сужению области поиска, применению булевых операторов и т. д. Естественно, что в случае «простого поиска» (Simple Search) из «поля зрения» выпадают документы, которые могли бы быть найдены при более тщательном поиске «продвинутыми» средствами конкретного сервера.

В общем случае, чтобы улучшить результаты поиска при работе с мета-поисковыми сервисами, можно порекомендовать вначале выбрать один или несколько поисковых серверов, которые нашли наибольшее количество документов. Затем отдельно загрузить уже заглавные страницы этих серверов и в качестве следующего шага провести отдельный тщательный поиск с помощью уже только этих серверов. О том, как пользоваться средствами сложного поиска (advanced search) на каждом конкретном сервере, можно узнать, если обратиться к справке (обычно это оформлено в виде кнопки Help) по методике проведения сложного поиска на данном сервере.

Итак, чтобы вызвать поисковую страницу браузера Internet Explorer, проделайте следующее:

1. Вызовите панель поиска, щелкнув кнопку Поиск на панели инструментов.

2. Выберите сервер, с которым вам хотелось бы поработать.

3. Введите какое-нибудь интересующее вас слово в окне для ввода ключевых слов и нажмите на кнопку Поиск, которая изображена на этой WWW-странице рядом с окном ввода текста. В результате обработки запроса выбранный вами поисковый сервер возвратит список аннотаций найденных документов. Полученные ссылки на найденные документы можно прочесть на правой половине окна.

Как улучшить результаты поиска

Очень часто поисковый сервер возвращает более скромный, чем хотелось бы, список документов. Или наоборот, список полученных ссылок огромен, но они совершенно не относятся к искомой теме. Прежде чем переходить к другому поисковому серверу или впадать в уныние, попробуйте улучшить результаты поиска. Если вы работаете через интерфейс Internet Explorer, то выйдите из этого режима и загрузите заглавную страницу одного из поисковых серверов в окне просмотра. Затем постарайтесь внимательно изучить те страницы поискового сервера, где содержатся советы по организации поиска и различного рода подсказки. Хотя они (в случае международных узлов) приведены на английском языке, но написаны бывают очень простыми словами, и главное, содержат множество примеров, которые помогут вам правильно применить то или иное правило. К сожалению, практически на каждом сервере применена своя система правил (синтаксис команд), определяющая поиск фраз из нескольких слов, применение булевых операций и т. д. Поэтому конкретные правила, действующие на том или ином сервере, вам лучше изучить самостоятельно.

  • Сформулируйте ваш запрос по возможности точнее. Хотя ряд лидирующих поисковых машин позволяет вам задать вопрос на естественном языке, например «Tell me about the GreenPeace in 1998», этой возможностью следует пользоваться с осторожностью. Дело в том, что в таком случае поисковый сервер «отбрасывает» все незначащие по его мнению слова, кроме тех, которые можно интерпретировать как ключевые слова (в данном случае «GreenPeace» и «1998»). Однако существует вероятность, что при этом будет отброшено и то слово, которое важно для результатов поиска. Поэтому по возможности старайтесь пользоваться четкими и ясными ключевыми словами, наиболее полно характеризующими предмет вашего поиска.
  • Проверьте правильность написания ключевых слов. Если результаты поиска по какой-либо теме полностью отрицательны, проверьте орфографию введенных вами английских терминов (или терминов на другом языке, если вы ищите неанглоязычные страницы). Очень удобно, если на вашем компьютере установлен MS Word из комплекта Office 95 или 97 (или теперь Office 2000). В этом случае можно не рыться в словарях, а ввести вашу фразу в Word, который подчеркнет неправильно набранные слова. Если теперь щелкнуть правой клавишей мыши на подчеркнутом слове, то Word предложит вам его правильное написание.
  • Используйте синонимы. Во многих предметных областях можно улучшить результаты поиска, если задать поиск по синонимам. Это особенно касается областей знания, где в силу новизны предмета еще не полностью устоялась терминология (в том числе в области компьютерных технологий).
  • Используйте опцию «расширенного поиска» (Advanced Search). На многих серверах имеется режим «расширенного» или «сложного» поиска, где действуют специальные синтаксические правила для применения булевых операций над ключевыми словами, предусматривается различие прописных и строчных букв, предлагается выбор способов ранжирования найденных документов и т. д. Как уже подчеркивалось выше, следует подробно изучить возможности выбранного вами поискового сервера, правила ввода и формулировки терминов, поскольку без этого вряд ли удастся достичь значительной полноты поиска.
  • Повторите поиск для других видов сервиса Интернета. Многие поисковые серверы обеспечивают раздельный доступ к информационному пространству WWW, UseNet и других видов сервисов Интернет, что регулируется с помощью различных раскрывающихся списков. Проверьте, в какой конкретной области происходил поиск (как правило, по умолчанию это WWW), и повторите его для других видов сервиса, где также может находиться искомый вами документ.
  • Постарайтесь локализовать поиск. Во многих случаях, когда предмет поиска можно локализовать географически, полезно выполнить поиск на серверах местных организаций, например, на серверах университетов. Там находится огромное количество ссылок на местную прессу, компании и общественные организации, работающие в этом регионе и т. д. По разным причинам поисковые серверы не индексируют значительную часть таких документов, и они могут быть найдены только в результате кропотливого локального поиска информации.
  • Старайтесь сами определить наиболее вероятный узел, где хранится искомый документ или файл. При поиске файлов с драйверами, программными продуктами и др. имеет смысл, в первую очередь, обратиться на Web-сервер фирмы-производителя. На многих серверах существуют локальные поисковые системы, обеспечивающие поиск документов по этому серверу, и корпоративные распределенные системы поиска, работающие с несколькими тематически связанными серверами (такие, к примеру, как поиск по серверам издательской корпорации Ziff-Davis). Поэтому, если вы, например, хотите найти информацию по операционной системы Windows 98, то, в первую очередь, имеет смысл провести поиск по ключевым словам на сервере Microsoft (http://www.microsoft.com), драйверы к принтерам и сканерам Hewlett-Packard – на http://www.hp.com, а для поиска сведений, относящихся к OS/2 Warp Connect, логично обратиться к поисковой системе WWW-сервера IBM (http://www.ibm.com). Аналогичный подход можно использовать при нахождении информации по иным товарам и услугам – расписаниям авиакомпаний, маршрутам турагентсв, и т.д.
  • Интернет – Intranet. Публично доступные документы, содержащиеся на различных серверах Интернета, составляют лишь небольшую часть того информационного богатства, которое находится на файл-серверах в локальных сетях корпораций, правительственных учреждений, исследовательских центров, университетов и т. д. Эта «подводная» часть сети, носящая название Intranet, закрыта для посторонних пользователей. Однако ссылки на имена и адреса электронной почты конкретных людей – профессоров, исследователей, журналистов, а также на области их деятельности, как правило, можно найти на WWW-серверах. Завяжите с этими людьми электронную переписку, попросите прислать копии их статей или URL известных им документов по интересующей вас теме – в общем, наладьте информационный обмен. Это очень эффективный путь поиска информации, поскольку знания эксперта – это высшая степень владения информацией.

Поиск документов на русском языке

Вполне вероятно, что еще пару лет назад о появлении мощных поисковых систем, помогающих в нахождении документов на русском языке, можно было лишь мечтать. Достаточно сложная морфология русского языка затрудняла эту задачу, не позволяя «в лоб» применить проверенные западные алгоритмы. Но бурное развитие российской части Интернета помогло и эту «сказку сделать былью».

Создание достаточно полных русскоязычных Web-каталогов, которые можно было бы сравнивать с Yahoo!, по видимому, еще впереди – слишком больших финансовых и людских ресурсов они требуют. Тем не менее, первые и достаточно серьезные шаги в этом направлении уже делаются, – поисковая система Rambler на сегодня представляет уже не просто индекс, а гибридную систему с большим классификатором по тематическим разделам.

Среди поисковых систем, работающих с русскоязычными документами, можно выделить как международные Web-индексы, так и системы, разработанные и внедренные российскими компаниями. Начнем с международных поисковых систем: здесь выбор невелик – это знаменитая AltaVista (http://www.altavista.com). Несмотря на способность целого ряда зарубежных Web-индексов заносить в базу данных русскоязычные слова, лишь AltaVista делает это на уровне, достойном быть примером для остальных.

Как вы наверняка представляете, российский Интернет, как и все в России, многогранен и противоречив. Одна из главных его проблем – это наличие нескольких национальных сетевых кодировок. Для обычного англоязычного Web-сервера эта проблема решается просто. К русскоязычной поисковой машине предъявляются более жесткие требования. Дело в том, что далеко не все серверы поддерживают все или по крайней мере основные кодировки. Часть из них поддерживает или только KOI-8, или только Windows 1251, и только примерно треть поддерживает все или 2-3 основные кодировки. Если вы вводите запрос в окне на поисковом сервере в определенной кодовой странице, то не сможете найти ту информацию, которая существует в другой кодировке на серверах, поддерживающих какую-либо одну кодировку, если ваши кодовые страницы не совпадают. Для получения полной информации вам придется воспользоваться всеми кодировками, поддерживаемыми поисковыми серверами.

Хотя сегодня существует около десятка русскоязычных поисковых систем, мы ограничим свой рассказ о тех системах, которые стандартно вызываются на панели поиска Internet Explorer – Rambler, Яndex, Апорт!

Rambler, http://www.rambler.ru

Поисковая система Rambler была изначально создана в фирме «Стек» для возможности поиска по русскоязычным серверам. Компания «СТЕК» образовалась в Научном Центре Биологических Исследований в г. Пущино (Московская область) в 1991 г., а автором поисковой системы является Дмитрий Крюков.

Рамблер – единственный в российском Интернете портал, объединивший поисковую систему, рейтинг-классификатор, а также ряд бесплатных сервисов и информационных проектов. Ресурсы портала регистрируют ежесуточно более 3,5 млн посещений, а ежемесячная аудитория Рамблера составляет 60-70% всех пользователей Рунета.

Только поисковая система содержит информацию о более чем 12 миллионах документов, расположенных на серверах России и стран СНГ. Рамблер обрабатывает ежесуточно не менее 500 тысяч поисковых запросов (в среднем – 5 запросов в секунду), сканируя 48 тысяч web-серверов и используя несколько одновременно работающих программ-роботов. Все проекты Интернет-холдинга реализованы на базе собственных технологических разработок.

Поисковая система Rambler поддерживает различные логические операции между словами, а также усечения слов с помощью метасимволов. Пользователь может определить выходной формат документов, максимальное количество результатов поиска и т. д.

Яndex, http://www.yandex.ru

Эта поисковая система Интернета – часть проекта фирмы Comptek по разработке набора средств полнотекстовой индексации и поиска в текстовых данных с учетом морфологии русского языка. Яndex (произносится как «яндекс») расшифровывается как Языковый Индекс или, в английском написании, Yandex – Yet Another Index.

Как указывается в документе на сервере, продукты Яndex предназначены для работы с большими объемами русских текстов всех типов – в виде файлов различных форматов, полей баз данных и страничек Интернет.

Поисковая машина Яndex была запущена в эксплуатацию в конце сентября 1997 г. и область поиска системы – русскоязычный Интернет. Отличительные особенности системы, в соответствии с описанием на http://yandex.ru:

  • полнотекстовый поиск с полным учетом морфологии русского и английского языков;
  • мощный язык запросов (в том числе возможность поиска с расстоянием);
  • возможность запроса на естественном языке;
  • корректная обработка сленговых слов;
  • возможность поиска похожего документа;
  • очень компактный индекс;
  • подсветка слов из запроса в найденных документах;
  • развитая релевантность, позволяющая найти искомую информацию, не перегружая пользователя тысячами ссылок на не нужные документы;
  • высокая скорость поиска.

Как работает Яndex

Система просматривает все указанные ей тексты, преобразует каждое русское слово в нормальную форму (для существительных – это именительный падеж единственного числа, для глаголов – неопределенная форма и т.д.) и запоминает подробный адрес каждого слова. Алгоритмы морфологического разбора, которыми мы занимаемся, позволяют проанализировать слово, определить его характеристики и найти все формы, например: идти – идешь – шел; ребенок – дети; окно – окон; отзывать – отозвали.

Яndex обеспечивает индексацию одновременно с морфологическим разбором. Это позволяет создавать компактный индекс – около 30% исходных текстов, сохраняя достаточно высокую скорость индексации – 1-2 Мб/мин. Такая технология дает возможность почти полного снятия омонимии на этапе индексации.

Морфология базируется на словаре из 90 тыс. слов, к которому добавлены алгоритмы словообразования, а также на механизме построения гипотез для слов, отсутствующих в словаре. Создан и пополняется словарь имен собственных.

Русский интерфейс к поисковой системе AltaVista

Работу морфологии Яndex можно использовать не только на самом поисковом сервере Яndex, но и на примере русского поиска с помощью системы AltaVista (http://www.comptek.ru/alta.html). Как известно, слова в AltaVista проиндексированы просто как последовательность символов, что заставляет пользователя при поиске специально думать о том, как русские слова изменяются при склонениях и спряжениях . При запросе же через Яndex в запрос системы автоматически подставляются все допустимые формы требуемых слов.

Апорт! http://www.aport.ru

Поисковая система Апорт! – это проект фирмы Агама при поддержке российского отделения Intel. Система задумана и реализована как Web-индекс для осуществления поиска в Российской части Интернета, на русскоязычных серверах СНГ и мирового Интернета. Рассмотрим в качестве примера образец результатов поиска Апорта-2000 (см. рис. 8.5).

Основной блок выдачи начинается с символа «домик», который обозначает сайт (в противоположность символу «страничка», обозначающему отдельный документ).

Апорт-2000 дает весьма информативное представление найденных при поиске страниц. В блоке каждого сайта Апорт приводит информацию об одной (самой подходящей) из найденных на сайте страниц (8). При этом кроме типичного для поисковых машин «джентельменского набора» (адрес, заголовок, размер и дата файла, и т.п.) Апорт выдает цитаты из документа (9). Важно, что цитаты выбираются из полного текста документа и содержат слова, которые вы искали. Читая цитаты, зачастую легко понять, интересует вас документ или нет. Это очень удобно.

Рис. 8.5. Образец результатов поиска Апорта-2000:

1 – название и адрес сайта; 2 – описание сайта, сделанное человеком (из каталога Апорта); 3 – блок описания самой подходящей (релевантной) из найденных страниц; 4 – цитаты из полного текста страницы, где встречаются слова вашего запроса; 5 – ссылка на результаты поиска по данному сайту (все найденные страницы); 6 – ссылка на полную реконструкцию текста документа (полезно, если сам сайт недоступен через Интернет); 7 – ссылка на рубрику каталога апорта, к которой относится найденный сайт; 8 – подробная информация о сайте; 9 – рубрики из каталога на тему вашего запроса

Имеется ссылка на реконструкцию полного текста документа. Она нужна, если документ недоступен на самом сайте (упал сервер, документ уже удалили и т.п.). В новой версии Апорта реконструкция текста сделана более читаемой, она содержит больше элементов форматирования из оригинального документа. Если вы хотите заняться сайтом более плотно (желаете получить информацию о всех остальных страницах, которые Апорт нашел на нем), то можете воспользоваться ссылкой, которая замыкает блок результатов. По этой ссылке вам выдается дополнительное окно, в котором открываются результаты поиска только по данному сайту. Они состоят из блоков данных по отдельным страницам.


Избранное

Закладки на адреса Интернета, или Избранные страницы как они называются в Internet Explorer, – это очень полезный инструментарий браузера. С их помощью можно заметно облегчить доступ к ранее просмотренным страницам Web. На диске адреса избранных страниц запоминаются в виде ярлыков – небольших файлов, в которых записан URL данной страницы.

Подписка, каналы и активный рабочий стол Active Desktop – все эти понятия являются различными реализациями так называемой Push-технологии, суть которой состоит в активной доставке информационного содержания на компьютер пользователя. Поскольку доставка информации, или как ещё называют, контента (от англ. Content, содержимое) клиентскими Push-программами происходит в фоновом режиме работы компьютера, и накопленные этими клиентами сведения сохраняются на жестком диске машины. Таким образом заметно облегчается доступ к интересующей пользователя информации.

Понятие подписки на содержимое узлов Web и каналы

В Internet Explorer последних версий произошло дальнейшее развитие инструментария закладок, традиционно называемых в браузерах Microsoft как Favorites (Избранные страницы). Если до этого, в версиях 2.х – 3.х избранные страницы представляли собой обычную статичную коллекцию адресов (URL) страниц Web, то теперь появилось два дополнительных уровня, расширяющих это базовое понятие: Subscriptions (Подписка) и Channels (Каналы).

Подписка – это интеграция внутри традиционного браузера функций прежде самостоятельного класса продуктов, – так называемых офф-лайновых браузеров. Задачей офф-лайновых браузеров является копирование в фоновом режиме на жесткий диск содержимого указанных пользователем страниц Web. Затем отслеживаются все изменения, произошедшие на этих страницах, и при необходимости новое содержимое опять подгружается на диск. Таким образом, создается автоматически обновляемая коллекция полновесных страниц (не URL!), которые пользователь может затем просматривать в автономном режиме, не обращаясь непосредственно к узлам Web.

Каналы в деле доставки информационного содержания идут еще дальше, реализуя Webcasting – показ с помощью браузера специально подготовленных последовательностей гипертекстовых страниц, логически связанных в программы Web-вещания. Технология Web-вещания в Internet Explorer получила специальное название, – «Active Channel», – и имеет специальный формат CDF (Channel Definition File). Тем пользователям, кто заинтересуется форматом CDF более подробно, можно посоветовать посетить сервер Microsoft.

Меню и кнопка Избранное

Все действия, связанные с работой с избранными страницами и подпиской, осуществляются с помощью меню Избранное (Favorites). Вне зависимости от того, каким образом вы вызываете меню Избранное, – с помощью кнопки на панели инструментов или из основного меню, – вы получаете доступ к одним и тем же избранным страницам и средствам их создания и организации.

Обычно адреса избранных страниц удобно группировать по тематическим папкам, и первоначально в меню Избранное уже присутствуют несколько стандартных папок с заранее записанными адресами: это папки «Каналы», «Ссылки», «Обновление приложений». Сами адреса избранных страниц представлены ярлыками с названиями документов, которые были даны им авторами этих страниц. Что такое ярлык? С физической точки зрения – это маленький файл с адресом страницы (имя такого файла и есть имя ярлыка), с логической – просто ссылка на запомненную страницу. Операционная система Windows 95 или Windows 98 размещает ярлыки избранных страниц в виде файлов с расширением .URL.

Советы при создании избранных страниц

Когда вы путешествуете по Web и решили добавить адрес текущей страницы Web (той страницы, которую в данный момент просматриваете) в список избранных страниц, то старайтесь держать в уме следующее:

1. По умолчанию страница сохраняется под тем названием, которое дал ей автор страницы. Иногда это название не слишком информативно, и тогда довольно скоро вы позабудете, о чем идет речь на странице под таким названием. Чтобы избежать этого, можно уже на стадии записи страницы в Избранное изменить название ярлыка для страницы на то, которое вам больше нравится (к примеру, написать его по-русски для англоязычных страниц), – для этого просто поместите с помощью мыши курсор в поле названия в диалоговом окне и удалив старое, впечатайте новое имя страницы по вашему вкусу.

2. Старайтесь сразу классифицировать страницу по теме и поместить ее в соответствующую тематическую папку с помощью кнопки Добавить в ... Если подходящей папки нет, то создайте ее (кнопка создания новой папки стандартно присутствует в диалоге сохранения страницы). Эти действия по созданию новой папки для избранных страниц очень похожи на те, что вы обычно производите в программе Проводник Windows, поэтому не должны вызвать затруднений.

3. Аналогично подписке на каналы, выбирайте вариант подписки в соответствии с типом имеющегося соединения с Интернетом. На этом основании не рекомендуется подписываться на страницы Web с загрузкой их на диск, если вы работаете по модему. Если вы выбрали самую простую опцию по добавлению адреса страницы в Избранное, то это все: теперь URL текущей страницы (ярлык) будет добавлен в список избранных страниц, и вы легко посетите ее в нужное время.

4. Проделать операции по добавлению адреса страницы в число избранных страниц и осуществить подписку можно и другим способом, используя контекстное меню, для вызова которого используется правая клавиша мыши. Вы можете добавить страницу к списку избранных страниц, держа курсор в свободном от каких-либо символов месте страницы и нажав на правую клавишу мыши. При этом откроется выпадающее меню, выберите из этого меню опцию Добавить в избранное и проделайте все обычные операции по добавлению страницы к Избранному.


Сохранение страниц Web

Сохранить понравившуюся страницу Web достаточно просто – выберите пункт Сохранить как из меню Файл, далее – выберите папку, в которую хотите поместить страницу, укажите имя и формат сохраняемой страницы Чтобы сохранить все файлы, необходимые для отображения данной страницы, включая рисунки, кадры и таблицы стилей, выберите вариант Веб-страница, полностью. В этом случае сохранятся все файлы в соответствующих форматах.

Чтобы сохранить всю информацию, необходимую для отображения данной страницы, в виде одного файла в кодировке MIME, выберите вариант Веб-архив. Выбор этого типа файла приведет к сохранению всей активной веб-страницы. Этот тип файла доступен только в том случае, если установлен Outlook Express 5 или более поздняя версия.

Чтобы сохранить только активную HTML-страницу, выберите Web-страница, только HTML. Выбор этого типа файла приведет к сохранению информации, содержащейся на веб-странице, но при этом не сохранятся рисунки, звуковые эффекты и прочие файлы.

Чтобы сохранить только текст, содержащийся на активной веб-странице, выберите Только текст. Выбор этого типа файла приведет к сохранению информации, содержащейся на веб-странице, в обычном текстовом формате.

Следует только помнить, что ряд изображений, особенно логотипы фирм и товаров, герои комиксов (например, Микки Маус), фотографии с узлов агентств новостей и прочее, защищены законодательством об авторском праве. Поэтому использование этих изображений для повторного публичного показа, – при проведении компьютерных презентаций, на ваших собственных страницах Web и тому подобное допускается только с согласия правообладателя этих изображений.

И еще: ко многим книгам по тематике Интернета, которые имеются сейчас в продаже в российских книжных магазинах, бывают приложены компакт-диски с различными утилитами и программами просмотра файлов гипермедиа. Это очень удобно, так как можно не тратить множество времени на поиск и переписывание программ с узлов Web. Единственный недостаток таких коллекций на CD-ROM, – это то, что за время подготовки книги разработчики программ часто успевают выпустить очередные версии своих продуктов. Поэтому если вы воспользуетесь программой с диска CD-ROM, приложенного к такой книге, то обратите внимание на адрес в Интернете, откуда можно получать обновленные копии этой программы. Такой адрес, как правило, всегда указан в файле справки на данную программу.


Печать гипертекстовых страниц

Распечатать загруженную страницу Web очень просто – нажмите кнопку Печать на панели инструментов или выберите аналогичный пункт в меню Файл. В появившемся диалоговом окне установите параметры печати: тип принтера, количество копий и т.д.

После того как вы нажмете на кнопку ОК, браузер сам скомпонует вид документа на бумаге, разделит его на печатные страницы и выведет на ваш принтер. Обратите внимание, что на каждом напечатанном листе в качестве колонтитула будет присутствовать URL данного документа. Это поможет вам вспомнить, с какого узла был получен данный документ и вернуться туда при необходимости.

В Internet Explorer существует несколько дополнительных функций:

  • если страница Web разбита на фреймы, то можно напечатать каждый фрейм отдельно, или все вместе (в том числе каждый – на отдельном листе),
  • если вы хотите, чтобы в конце документа была напечатана таблица с URL всех ссылок, присутствующих в данном документе, то установите флажок Печать таблицы ссылок.
  • и наконец, можно распечатать даже все документы, на которые ведут ссылки с данной страницы (на текущем или любом ином узле Web), получив таким образом подробное «видение» темы, которой посвящена данная страница. Для этого следует установить флажок Печать связанных документов.

Редактирование документов Web

Если вы захотите создать свою собственную страницу Web «по образу и подобию» той, что вы встретили на каком-либо узле Web в Интернете и которая вам особенно нравится, то бывает полезно познакомиться с текстом на языке HTML и особенностями ее форматирования. Если у вас на компьютере установлен пакет FrontPage Express (стандартно входит в поставку Windows 98) или FrontPage 2000 (входит в Расширенную версию Microsoft Office 2000), то на панели инструментов появится кнопка Изменить. Нажав на эту кнопку, вы загрузите текущую Web-страницу в соответствующий HTML-редактор, где над ней уже можно поработать.

Если нужно просто посмотреть на исходный код HTML, то выберите пункт В виде HTML в меню Вид браузера и искомый текст появится в отдельном окне с помощью программы Блокнот (Notepad). Прямо отсюда вы можете распечатать текст файла на принтере и сохранить его на диске для дальнейшей работы.


Полезные настройки и разрешение проблем

В зависимости от вашего режима работы с браузером и типа соединения бывает полезно подстроить браузер, чтобы работать более эффективно. Хотя приводимые ниже советы использовать совсем необязательно, – но нужно уметь выбирать нужный режим в зависимости от конкретных обстоятельств работы.

Работа в автономном режиме

Если вы в текущем сеансе работы с браузером просматривали узлы, страницы которых вряд ли могли измениться, а скорость загрузки была крайне низка, то можно заставить браузер Internet Explorer загружать страницы только из временных файлов с жесткого диска при нажатии на кнопки Вперед и Назад. При этом вам даже не обязательно поддерживать соединение с Интернетом.

1. Выберите пункт Работать автономно из меню Файл.

2. Нажмите кнопку Журнал на панели инструментов Internet Explorer, что вызовет появление соответствующей панели, и выберите из списка нужный узел Web.

Не забудьте только отключить автономный режим, чтобы при подключении к следующему Web-узлу браузер загружал уже обновленные страницы Web.

Показ URL в строке состояния браузера

Ссылки, которые Internet Explorer выводит в строке состояния, могут быть представлены в так называемом полном или сокращенном виде. Это не имеет никакого отношения к типу ссылок, и является всего лишь свойством интерфейса данного браузера. Чтобы можно было прочесть полный адрес (URL), на который показывает ссылка, выберите пункт Свойства обозревателя в меню Сервис, далее в появившемся диалоговом окне – закладку Дополнительно. Проверьте, чтобы на этой закладке был снят флажок Показывать краткие ссылки.

Изменение вида интерфейса

После того, как в процессе настройки браузера вы измените начальную страницу и быстрые ссылки на свой вкус, то интерфейс браузера будет уже отражать черты вашей индивидуальности. Несомненно, это послужит большей эффективности вашей работы с Internet Explorer и ресурсами Интернета.

Можно, правда, поэкспериментировать еще с видом панели инструментов, адресной строки и строки быстрых ссылок. Вы можете поменять их местами или расположить в ином порядке. Если захотите попробовать, то установите курсор мыши в начало соответствующих строк или панели инструментов таким образом, чтобы курсор принял форму двунаправленной стрелки с вертикальными полосами в центре (как при форматировании мышкой размеров таблиц в Word или Excel), нажмите и, не отпуская левую клавишу мыши, переместите соответствующий элемент интерфейса браузера. Можно предупредить: расположение элементов интерфейса, принятое в Internet Explorer по умолчанию, достаточно удобно и его вряд ли стоит менять.

Если надо увеличить окно просмотра браузера, то можно снять подписи к кнопкам и запретить панели инструментов и строк интерфейса. Чтобы минимизировать какую-либо панель в Internet Explorer, удобно сделать по ней правый щелчок и в появившемся списке снять флажок у строки с названием данной панели. Установка флажка вернет показ панели.

Управление кэшем (хранилищем временных файлов)

Папка Temporary Internet Files в каталоге Windows хранит копии просмотренных ранее Web-страниц и других файлов. Это ускоряет отображение часто посещаемых Web-страниц, поскольку обозреватель Internet Explorer может открыть их с жесткого диска, а не из Интернета. Увеличение места для этой папки может увеличить скорость отображения ранее посещенных Web-страниц, но уменьшить объем свободного дискового пространства на компьютере. Вы можете изменить размер этой папки, или полностью очистить ее содержимое для контроля за использованием свободного дискового пространства.

Выберите пункт Свойства обозревателя меню Сервис. Здесь в диалоговом окне Свойства на вкладке Общие нажмите на кнопку Настройка. В появившемся окне (рис. 8.6) можно задать режим обновления при загрузке страниц – загружать ли страницу каждый раз заново, лишь однажды за сеанс или никогда. Учтите, что если выбрать режим без обновления (никогда), то Internet Explorer будет грузить такие страницы только с диска. Это очень быстро, но поскольку копии страниц на жестком диске могут устареть, вы рискуете пропустить новую информацию, которая может появиться на этих страницах в Web.

Рис. 8.6. Настройка папки временных файлов Интернета

Если установить параметр Занимать на диске не более: в 100% диска, то будут сохраняться все просмотренные страницы и их можно будет просматривать в автономном режиме до тех пор, пока они не удалятся из Журнала.

Повышение скорости загрузки страниц Web

Среди авторов страниц Web, так же как и в реальной жизни, встречаются люди, которые не слишком берут в расчет технические возможности других пользователей по доступу в Интернет. В данном случае это выражается в том, что такие авторы перегружают страницы новомодными «примочками» типа видео, анимации и фонового звука, используют объемные файлы графики для иллюстраций и т. п. Кроме того, довольно часто перегружают свои страницы анимацией и графикой начинающие пользователи, только-только создавшие свои первые домашние страницы. Обычно им хочется поместить туда как можно больше «крутизны», а результат – такие страницы только отпугивают посетителей. Ведь все эти мультимедийные дополнения на порядок снижают скорость загрузки страниц, особенно при работе по коммутируемой линии.

В таких случаях приходится отключать загрузку графики, звука и видео – возможность, которой стандартно обладает Internet Explorer. Как правило, видео и звук являются наименее информативными элементами страницы, поэтому при медленной загрузке страниц их можно без потерь отключить в первую очередь. Если это не помогает, или если на странице Web нет ни того, ни другого, а лишь присутствует огромная по размеру графика, следует отключить и вывод изображений.

К аналогичным мерам приходится прибегать, если дело вовсе не в излишествах страницы Web, а в перегрузке каналов Интернета. В Сети, так же как и на дорогах любого города, бывают свои часы пик, когда работает очень большое число пользователей и скорость загрузки страниц Web вашего браузера заметно падает. Можно посоветовать построить так свое расписание работы с Интернетом, чтобы минимизировать этот фактор. В европейской части России часы пик наблюдаются обычно примерно с 10 до 18 часов по московскому времени, а позже, когда корпоративные клиенты покидают свои офисы, пропускная способность каналов возрастает. Согласно статистике провайдеров, наименьшая загрузка каналов в европейской части России приходится на очень раннее утро – с 4 до 6 утра. В это время еще спит Европа и уже уходит в ночь Америка, – вот когда ваш модем может показать, на что он способен. Так что те пользователи, кто является жаворонком по своему характеру, могут с успехом использовать это качество в работе с Интернетом.

Итак, если вы решили отключить в Internet Explorer графику, звук и видеозаписи, то следует проделать следующие операции:

1. Выберите пункт Свойства обозревателя меню Сервис.

2. Здесь, на закладке Дополнительно диалогового окна Свойства обозревателя снимите флажки, определяющие, что нужно загружать – графику, звук и видеозаписи, или только часть из них по вашему выбору.

3. Нажмите кнопку ОК для подтверждения своего выбора.

4. Поскольку эти установки действуют только со следующей страницы Web, нажмите кнопку Обновить на панели инструментов Internet Explorer, чтобы перезагрузить текущую страницу.

Web-мастера многих профессионально выполненных узлов Web, зная о проблемах медленной загрузки графики и файлов мультимедиа, предусматривают в структуре узла дополнительные копии страниц, содержащих только тексты документов. В таких случаях на заглавной странице узла располагается ссылка Text Only (Только текст).

Проблемы при работе Internet Explorer

Если вы встретились с ситуацией, которую расцениваете как ошибку в программе, то для начала следует обратиться к меню справки по программе и выбрать пункт Техническая поддержка. Будет загружена страница технической поддержки по Internet Explorer с сервера Microsoft. Вполне вероятно, что вы не первый столкнулись с этим и в разделе наиболее часто задаваемых вопросов можно будет найти советы по разрешению ситуации.

К типичным сообщениям относятся те, что выдают серверы Интернета или сам браузер при невозможности найти запрашиваемые страницы:

  • 404 Not Found – браузер не может найти указанной страницы. Убедитесь в правильности указанного в адресной строке адреса. Страница могла быть перемещена в другое место, переименована или удалена.
  • 403 Forbidden/Access Denied – для доступа к узлу требуются дополнительные разрешения, например, указать верный пароль.
  • 503 Service Unavailable – попробуйте просмотреть страницу позже. В данное время этот сервер недоступен.
  • Bad File Request – ошибка кода интерактивной формы.

Если вы не нашли ответов на свои вопросы на странице «Наиболее часто задаваемые вопросы», то можно попробовать задать их напрямую техническому персоналу Microsoft, для чего загрузить страницу обратной связи и отправить электронное письмо в российское представительство Microsoft (russia@microsoft.com). Особо стоит упомянуть о таком источнике помощи, как телеконференции UseNet. На общедоступном сервере новостей msnews.microsoft.com есть группы, посвященные обсуждению русскоязычных локализованных программных продуктов Microsoft. В их числе есть группы телеконференций по Internet Explorer и Outlook Express (microsoft.public.ru.ie5).

Полезно также просмотреть страницы технической поддержки на сервере вашего провайдера и позвонить по его телефону службы сервиса. Вполне возможно, что с помощью провайдера вы сможете найти подходящее решение и разрешить проблему.


8.4. Электронная почта (E-Mail)

Электронная почта – e-mail (от англ. Electronic mail) является одним из самых старых и наиболее широко распространенных сервисов Интернет. Популярность e-mail объясняется его относительной дешевизной, например, по сравнению с традиционным факсом e-mail на порядок дешевле, и скоростью передачи электронных писем, не превышающей нескольких минут независимо от удаленности адресата от отправителя.

С помощью соответствующего программного обеспечения, выполняется связь и прием-передача сообщений (текстовые и графические файлы) абонентам Сети; для связи необходимо лишь знать электронный адрес соответствующего абонента.
Он формируется следующим образом:

<login>@<server_name>.

Условные скобки в информатике часто используются для обозначения обобщенного имени термина, например, если мы хотим, чтобы кто-то в конкретном месте указал свою фамилию, указывается <фамилия>, вместо имени – <имя> и т.д. При написании конкретного термина эти скобки опускаются.

В приведенной записи: Login – регистрационное имя почтового ящика; @ – служебный разделитель; server_name – доменное имя почтового сервера. Знак @ читается как «коммерческое ЭТ», в живом языке – собачка; произошел от предлога английского предлога at – «на». В связи с этим запись ivanov@mail.ru трактуется буквально как «почтовый ящик Иванова на сервере mail.ru».

Доменным именем почтового сервера является URL-адрес компьютера в Интернет, о котором мы говорили в одном из предыдущих разделов. Крайний справа домен – это самый старший домен (домен верхнего уровня). Остальные поддомены отделяются от него точками. Пробелы в электронном адресе недопустимы! Если есть желание поставить разделитель, то можно использовать тире («-») или знак подчеркивания («_»), но некоторые почтовые сервера могут и на эти знаки накладывать ограничения. Допустимые символы всегда можно увидеть в справочной системе почтовой программы, но все они без исключения разрешают использование заглавных и прописных букв только латинского алфавита.

Двух одинаковых имен не может быть зарегистрировано на одном и том же почтовом сервере. В подавляющем большинстве случаев почтовая программа может Вам предложить возможные допустимые имена для регистрации. Например, на каком-либо сервере уже зарегистрированы пользователи с именами gena, gena1 и gena2. В этом случае Вам в качестве одного из вариантов будет предложено имя gena3. Удобно, когда написание имени совпадает с Вашими обычными реквизитами. Вы можете зарегистрировать одно имя на разных серверах, если не попадете под описанные выше ограничения.

Например: ivanov@hotmail.com, ivanov@mail.ru, ivanov@bsu.edu.ru

Имя почтового ящика является не только элементом адреса e-mail, оно также указывается при входе в почтовую систему в поле LOGIN (Имя пользователя). После ввода имени система запрашивает PASSWORD (пароль). Пароль задается при регистрации, и вводится перед началом каждого сеанса работы с e-mail. Для защиты Ваших прав буквы пароля не отображаются на экране, а вместо них печатаются символы «*» (звездочка). При последующих сеансах, пароль можно изменить, но только при условии, что регистрация произошла корректно, т.е. при регистрации правильно были указаны Ваш login и password. Некоторые почтовые системы для забывчивых пользователей могут предъявить введенную Вами при регистрации напоминающую информацию, например, пароль – это первые 6 букв девичьей фамилии бабушки по материнской линии. Напомним, что пароль – вещь очень серьезная и, если он напрочь забыт, то легче закрыть этот ящик и открыть новый. Правда, хулиганы от программирования только и занимаются тем, что пытаются «взломать» чужие пароли. Но ведь и в обычной почте Вы тоже не застрахованы от того, что на каком-то из этапов, оно может быть вскрыто и прочитано. Не рекомендуется вводить короткие (менее 6 символов) пароли, очевидную или легко просчитываемую информацию.


Получение адреса электронной почты у провайдера

Согласно распространенной практике, получение адреса электронной почты является стандартной услугой, которую предоставляют провайдеры при заключении договора на подключение к Интернету по телефонной линии (Dial-Up). При этом пользователь получает свой адрес E-mail, а сотрудник провайдера заносит этот адрес в список пользователей почтовых серверов, заведя тем самым соответствующую учетную запись пользователя на этих серверах. Сейчас мы перечислим, какие сведения необходимо иметь для начала работы с электронной почтой, используемой через коммутируемое соединение:

  • ваш адрес электронной почты (вида ваше_имя@имя_провайдера.ru);

  • тип сервера входящей почты (POP или IMAP) и имя этого сервера входящей почты;
  • имя сервера исходящей почты (сервер SMTP);
  • ваше имя для учетной записи почты (также называемое как имя входа в систему или имя пользователя – login name или user name), – обычно то же самое, что при подключении к Интернету;
  • пароль, который вы используете, чтобы обратиться к вашей электронной почте (обычно тот же самый, что при подключении к Интернету);
  • сведения о том, поддерживает ли ваш сервер почты защищенный режим передачи пароля Secure Password Authentication (SPA). Обычно такой режим не поддерживается.

4.2. Бесплатная электронная почта

Крылатая фраза о том, что «бесплатный сыр бывает только в мышеловке», давно уже овладела массами, и потому любое предложение о бесплатной услуге многие люди встречают с подозрением – нет ли тут какого подвоха? К счастью, Интернет изначально во многом задумывался как всеобщая бесплатная сеть и поэтому неудивительно, что в Интернете существует возможность получить бесплатный адрес электронной почты.

Разумеется, так называемый бесплатный адрес не является абсолютно бесплатным – вы все равно платите провайдеру за время доступа к Интернету, и речь идет только о том, чтобы не взимать абонентскую плату за сохранение вашей почты и поддержку учетной записи. Эта плата в данном случае покрывается за счет доходов от рекламы. Сегодня в Интернете существуют более десятка хорошо известных и надежных служб бесплатной электронной почты – Mail.Ru (http://www.mail.ru), Chat.Ru (http://www.chat.ru), Hotmail (http://www.hotmail.com), AltaVista (http://www.altavista.com), BigFoot (http://www.bigfoot.com), Usa.net (http://www.usa.net), GeoCities (http://www.geocities.org), и т.д.

Коренным отличием этих служб от той почты, которую вы получаете через своего провайдера и с помощью почтовой программы (такой как Outlook Express или The Bat!), является то, что работа с бесплатным почтовым ящиком происходит с помощью браузера. Вы обращаетесь на Web-сервер службы, вводите свой идентификатор и пароль, после чего получаете доступ к своему почтовому ящику. Теперь можно читать пришедшую почту и отправлять свою собственную, но это происходит через интерфейс браузера. Просто на Web-сервере созданы странички, которые имитируют интерфейс простенькой почтовой программы. Внешне все выглядит очень похоже на работу с обычной почтовой программой, но реально все происходящее вы видите в окне браузера.

Универсальными качествами такой почты, за которые она и пользуется популярностью среди людей, является ее доступность из любой точки, с любого компьютера, на котором есть хоть какой-либо браузер Web и достаточно большой уровень анонимности. К примеру, если вы находитесь в поездке, то вы, как правило, не можете обратиться на почтовый сервер своего провайдера за почтой. Нет, конечно можно осуществить междугородний или даже международный звонок на номер доступа своего провайдера, но это дорогое мероприятие. Другой известный способ – использовать программу Telnet и с помощью команд UNIX обратиться на сервер провайдера и получить свою почту. Однако далеко не все умеют работать с Telnet и знают команды UNIX.

Ну и кроме того, предоставляемые адреса бесплатной почты безлики, их владельцы могут зарегистрироваться под каким угодно именем и находиться где угодно – ведь к своему ящику они обращаются через браузер. Вот почему бесплатные почтовые ящики с доступом через интерфейс браузера так популярны. Кроме того, некоторые службы, например, Chat.Ru, GeoCities, предоставляют возможность бесплатно разместить свою домашнюю страничку, что также привлекает туда пользователей.

Получить адрес бесплатной электронной почты может любой пользователь Интернета, причем любое число раз – ведь один и тот же человек может зарегистрироваться под разными именами. Например, один раз можно зарегистрироваться под истинным именем для переписки с друзьями, а другой под псевдонимом – на случай участия в телеконференциях, где как известно, «народ за словом в карман не лезет», и т.д. Выбор той или иной службы в качестве «базы» вашего будущего адреса особого значения не имеет, так как уровень функциональности всех подобных служб примерно одинаков. В принципе, открытие ящика на любой из бесплатных почтовых служб Интернета происходит по одной и той же схеме: вначале надо зарегистрироваться (выбрать имя и пароль, ввести те или иные данные о себе, которые не обязательно должны быть истинными), а затем вам открывают учетную запись и можно приступать к отправке и получению почты через этот ящик.

Чтобы эффективно работать с почтовым сервисом той службы, в которой вы завели бесплатный почтовый адрес, не поленитесь почитать раздел справки и часто задаваемых вопросов (FAQ). Там вы наверняка найдете ряд полезных советов, которые помогут вам быстрее освоиться в интерфейсе службы и научиться эффективно использовать ее в различных режимах работы. Так, например, Мail.Ru позволяет переадресовывать вашу почту с почтового сервера вашего провайдера в ящик Mail.Ru, сохраняя оригинал письма на почтовом сервере провайдера. Это удобно, если надо познакомиться с содержимым своей почты в тот момент, когда вы находитесь в поездке вдали от дома.

Работа обычных почтовых программ гораздо более эффективна, чем имитация почтового ящика через браузер в бесплатных почтовых службах. Во-первых, почтовые программы обладают множеством функций, не реализованных в бесплатной почте, и, во-вторых, они более экономно используют соединение с Интернетом. В общем случае для перерисовки каждой странички в браузере, имитирующей интерфейс почтовой программы, требуется заметно большее время, чем для перекачки почты в случае нормальной почтовой программы.


Правила подготовки письма

Любое сообщение электронной почты состоит из двух частей: заголовка и содержимого. Заголовок содержит такую информацию, как отправителя сообщения, время/дату отправления и адрес получателя. Содержимое – это то, что набирается в самом сообщении.

В заголовке отправляемого письма поле КОМУ (ТО) является обязательным. Через запятую без пробелов может быть перечислено несколько адресов. Кроме этого поля предлагаются для заполнения следующие поля: копия CC (Carbon Copy) и реже BСС (Blind Carbon Copy). Различие двух последних заключается в том, что основной получатель письма увидит адрес того, кому вы отправляете копию письма (СС), но не увидит адреса скрытой копии (BCC).

Поле ТЕМА (Subject) – желательно заполнять. В нем весьма кратко указывается основное содержание письма. Кстати, услуги, оказываемые многими коммуникационными фирмами, предполагают возможность передачи содержимого этого поля на пейджеры и сотовые телефоны. Иногда это может быть не только содержание поля ТЕМА, но и нескольких первых строк письма. Заполнение поля ТЕМА позволит вашему адресату быстрее сориентироваться в случае, если приходит много писем.

Дата и время (Date) отправки письма проставляются почтовой программой автоматически. Получатель письма получит информацию об адресе отправителя (поле From), дате отправки Date, Subject и др. По вашему усмотрению можно просмотреть расширенный (технический) заголовок. В нем указываются подробный маршрут (имена серверов), по которому было доставлено письмо, тип кодировки, наименование почтовой программы и массу другой сопутствующей информации. Расширенный заголовок просматривают крайне редко.

Теперь перейдем к самой главной части любого письма (в том числе и электронного) – его содержанию. Поле для набора текста письма вы найдете без проблем. Там может находиться только текст. Одна из немногих настроек этого поля – количество символов в строке. Если длина текстовой строки превышает эту цифру, то не поместившееся слово целиком перенесется на новую строку. Это позволяет избавить получателя от дополнительных манипуляций, поскольку в его почтовой программе может быть установлено другое значение длины строки.

Почтовую программу можно настроить таким образом, чтобы в конце каждого письма автоматически записывались ваши реквизиты или какая-либо часто повторяющаяся информация.


Правила использования кодировок шрифтов

Шрифт, которым отображается набираемый текст, – не более, чем настройка вашей почтовой программы – у получателя могут быть другие настройки. Здесь уместно вспомнить о моноширных и пропорциональных шрифтах.

Основная проблема при работе с e-mail – это кодировки шрифтов. Даже при работе с отечественными серверами могут возникнуть сбои при пересылке электронного письма, а уж при работе с зарубежными – тем более. Дело в том, что при отправке почтовые сервера автоматически перекодируют текст письма в кодировку, которую определил администратор, а сервер получателя считывает служебную информацию заголовка письма и перекодирует, как считает нужным ему. При этом не всегда получается читаемый результат. Стандартов для перекодировки несколько типов. Подсчитано, что вариантов перекодировок может быть от 12 (перекодировки только в пределах отечественных стандартов) до 8 тысяч. Для избежания этой неприятной ситуации есть следующие способы.

Первый способ – не допустить самого факта перекодировки, т.е. использовать только символы основной ASCII таблицы – буквы латинского (английского алфавита). Можно, конечно, поупражняться в английском, но при этом мы можем потерять основное преимущество e-mail – оперативность. Со словарями, даже компьютерными, написание письма может занять достаточно существенное время. А где гарантия, что у получателя уровень английского как минимум не ниже вашего? И знает ли он английский вообще?

Второй способ также использует только основную ASCII таблицу, но он основан на так называемом транслитеральном переводе, т.е. буквы одного языка будут преобразованы в буквы другого. Проблема национальных шрифтов стояла уже на заре телеграфии. В 1880 г. баварец Иоганн Шлейер предложил международный язык ВОЛАПЮК (Воляпюк – от англ. World – мир + Speak – говорить). По этому стандарту буквы национальных алфавитов переводятся в буквы или сочетания букв английского алфавита. Текст при этом выглядит ужасно, но вполне «читабельно». Проблема возникает с обратным переводом, когда приходится распознавать сочетания букв, но это не так уж и сложно для современных программ. Пример: Problema voznikaet s obratnym perevodom, kogda prikhoditsa raspoznovat’ sochetaniia bukv, no eto ne tak uzh I slozhno dlia sovremennickh programm.

Третий способ заключается в том, чтобы письмо прикреплять в виде заранее подготовленного файла, лучше заархивированного, поле ТЕМА (Subject) писать по-английски или транслитерально, а остальные поля просто не заполнять. Почтовые сервера никогда не перекодируют Attachment. В этом случае у получателя возникает проблема только со шрифтами, а не с кодировками.

Наконец, вы получили нечто ужасное, с которым не могут справиться ни настройки шрифтов, ни возможные варианты перекодировки, которые вам предоставляет почтовая программа. В безысходной ситуации можно обратиться к автоматическому почтовому декодеру www.design.ru/free/decoder/ index.html. или воспользоваться программой-перекодировщиком, распознающей самые каверзные ситуации и позволяющей автоматически преобразовывать в ВОЛАПЮК и обратно (например, SHTIRLITZ (Shtirlitz for Windows), TOT-Recoder).

И еще одна полезная рекомендация. Поля электронного письма можно не заполнять вручную, а использовать для копирования буфер обмена (clipboard). То же самое относится и к содержанию письма, но будьте готовы к тому, что в письмо перенесется только текст, а все шрифты и форматирование, которые вы использовали в редакторе, будут проигнорированы почтовой программой.

Выражение эмоций в электронной почте

В этом небольшом разделе мы коснемся еще одной традиции электронной почты – выражения эмоций. Дело в том, что E-mail по сравнению с живой речью плохо передает эмоции и чувства автора сообщения по отношению к предмету письма. Для того чтобы как-то компенсировать этот серьезный недостаток, были придуманы специальные значки, среди обитателей Сети именуемые «смайликами».

Смайлик – это просто комбинация из нескольких текстовых символов, которые в совокупности похожи на лицо человека – улыбающееся, подмигивающее, огорченное и т. д. Обычно смайлик вставляют в конце той фразы, которая вызвала особые чувства у автора. Чаще всего используются, к примеру, такие смайлики:

:-) – обсуждаемая тема рассмешила автора;
;-) – автор письма делает намек;
:-( – автор письма расстроен.

Кроме «общепринятых», существуют различные экзотические смайлики, отражающие более сложные чувства авторов электронных писем. В Интернете вы встретите достаточно много коллекций подобных значков (см., к примеру, http://www.alp.ru/smile.htm или http://www.lgg.ru/~dima/smiles.htm). Только не используйте смайлики в деловых письмах. Кто знает, разбирается ли в них ваш строгий адресат!?


8.6. Пользовательский интерфейс Outlook Express

8.6. Использование Outlook Express

Пользовательский интерфейс Outlook Express

Знакомство с интерфейсом Outlook Express начнем, обратившись к нижеследующему рисунку.

Рис. 8.11. Интерфейс программы Outlook

Строка заголовка содержит стандартные элементы окна Windows-приложения (кнопки Свернуть, Восстановить и Закрыть). В этой строке также указано название приложения (Outlook Express).

Строка меню содержит заголовки меню, предоставляющие доступ ко всем функциям, необходимым для работы с Outlook Express. С помощью меню вы можете формировать новые сообщения, отправлять и получать почту, пересылать письма другим пользователям, настраивать интерфейс Outlook Express и т.д. Кроме того, вы встретите в меню множество обычных пунктов, характерных для всех приложений Windows — печать, справка и т.д.

Панель инструментов предназначена для быстрого доступа к некоторым наиболее часто используемым командам Outlook Express. В зависимости от того, в каком режиме работает Outlook Express (почта или новости), число кнопок и их назначение автоматически изменяются. Кроме того, в начальный момент после загрузки Outlook Express устанавливается в общий режим (когда еще не выбран нужный режим – почта или новости). В таком общем режиме кнопки панели инструментов выполняют следующие функции:

  • Создать с … открывает окно для формирования нового письма.
  • Доставить … — с помощью этой кнопки вы можете быстро и легко подключиться к провайдеру, чтобы проверить и доставить входящую почту, а так же отправить вашу собственную.
  • Адреса – открывает доступ к адресной книге, куда вы записываете для хранения адреса e-mail ваших друзей, коллег по работе и т.д.
  • Найти – нажатие на эту кнопку открывает диалоговое окно для задания параметров поиска нужного письма.

Панель "Папки" позволяет вывести на экран списки писем и их содержимое, хранящихся в одной из 5-и стандартных папок Outlook Express: Входящие, Исходящие, Отправленные, Удаленные и Черновики. Outlook Express позволяет завести новые дополнительные папки пользователя и они так же будут доступны из этой панели. После того, как вы настроите доступ к серверам новостей, то в этой панели появятся и имена соответствующих серверов новостей.

Область просмотра Outlook Express при работе с электронной почтой или новостями разделена на две части: вверху вы видите список сообщений электронной почты из текущей папки, а в нижней части окна показывается содержимое отмеченного письма (рис. 8.12). Содержимое письма можно посмотреть и в отдельном окне, если сделать двойной щелчок по строке с выбранным письмом. По умолчанию все письма в папках располагаются в соответствии с алфавитном порядком имен отправителей, но их можно отсортировать и иначе – например, по дате поступления письма. Для этого надо щелкнуть мышкой на заголовке столбца Получено.

Рис. 8.12. Список сообщений электронной почты и содержимое отмеченного письма.

Состояние письма можно интерпретировать с помощью значков с различными изображениями конверта в области просмотра:

  • Открытый конверт отмечает уже прочитанное вами письмо
  • Закрытый конверт плюс жирный шрифт отмечает письмо, которое вы еще не читали
  • Скрепка у письма говорит о том, что в письмо вложен отдельный файл (например, документ в формате Word, графический файл и т. д.). Если выделить такое письмо, и щелкнуть по изображению скрепки в правом углу нижней части окна, то будет показано имя файла. Двойной щелчок по имени вложенного файла позволит просмотреть его содержимое с помощью соответствующей программы.

Строка состояния используется для двух целей. Обычно в ней Outlook Express указывает общее число сообщений в данной папке и отдельно — число непрочитанных сообщений. В правой части строки состояния при проверке поступления новой почты появляется надпись, информирующая о приходе или наоборот, отсутствии новых писем. Кроме того, при работе Outlook Express там появляются значки, характеризующие режим работы этого приложения в данный момент времени (например, зачеркнутый значок сетевого диска означает, что в этот момент нет соединения с Интернетом).


8.5. Работа с The Bat!

Введение

За время, прошедшее с момента своего появления в 1972 г., электронная почта из средства передачи текстовых сообщений между учеными в исследовательских центрах США и Европы превратилась в самый массовый и чрезвычайно популярный сервис Сети. Отечественными программистами разработана простая и в то же время достаточно мощная с функциональной точки зрения клиентская программа работы с электронной почтой The Bat! (см. рис. 8.7).

Рис. 8.7. Внешний вид программы The Bat!

Начальная настройка почтового ящика

Чтобы начать настройку почтового ящика в The Bat!, достаточно выбрать команду Новый почтовый ящик … в меню Ящик. После этого запускается Мастер, который запросит у вас необходимые данные о почтовых серверах и адресе электронной почты, которые вы должны были получить от провайдера.

1. В самом первом окне надо дать название ящика и выбрать для него каталог.

2. В следующем окне вам надо будет ввести ваше имя как абонента электронной почты, которое будет появляться в заголовке писем, когда они придут к адресатам. Обычно пользователи указывают свое настоящее имя, но здесь можно проявить гибкость, и если вы пока не планируете использовать свой адрес для деловой корреспонденции, то можно обойтись и псевдонимом. Кроме того, можно настоятельно рекомендовать записывать свое имя латинским шрифтом, чтобы как избежать проблем неправильного отображения заголовков с русским шрифтом в ряде программ электронной почты (которые могут стоять у ваших коллег по переписке), так и не создавать лишних проблем вашим возможным зарубежным адресатам. Впоследствии, кстати, указанное в этом окне имя можно будет легко изменить с псевдонима на настоящее имя и наоборот, – если в этом возникнет необходимость.

В следующей строке необходимо ввести ваш адрес электронной почты. Как правило, адрес E-mail состоит из вашего имени и доменного имени провайдера, соединенных с помощью знака @. К примеру, это может быть адрес вида user@mail.ru. Когда вы будете называть свой адрес кому-либо вслух, то знак @ произносится как словосочетание «ат», хотя русские пользователи чаще называют его сленговым термином «собака» (этот сленговый термин для знака @ ведет свою историю со времен самых первых компьютерных игр).

И в третьей строке можно ввести название организации. Можно оставить эту строку пустой.

3. Далее Мастер запросит у вас тип сервера входящей почты и доменные имена почтовых серверов провайдера, предназначенных, соответственно, для входящей (РОР3) и исходящей (SMTP) почты. Введите эти адреса. В случае нашего примера это будут адреса pop.mail.ru и smtp.mail.ru соответственно. Наличие разных почтовых серверов связано с тем, что сообщения электронной почты пересылаются между узлами Интернета (узлами различных провайдеров) по протоколу SMTP (Simple Mail Transfer Protocol), а на последнем отрезке между узлом вашего провайдера и вашим компьютером – по РОР (Post Office Protocol). Хотя иногда может использоваться и одно имя (например, mail.mail.ru). Введите в соответствующих полях диалогового окна те адреса почтовых серверов, которые получены вами от провайдера при заключении договора. Что касается типа сервера входящей почты, то если ваш провайдер специально не указал данный параметр, то по умолчанию оставьте РОР3.

4. Теперь в новом окне укажите сведения об учетной записи вашего соединения – имя пользователя и пароль. Это те же самые сведения, которые вы обычно используете для подключения к Интернету.

5. В очередном окне можно закончить первоначальную настройку почтового ящика, а можно перейти к проверке остальных свойств. После нажатия кнопки Готово Мастер завершит процесс настройки.

В принципе, уже можно приступать к обмену почтовыми сообщениями с другими пользователями Интернета. Однако, чтобы никто не смог прочитать ваши письма без вашего разрешения можно «закрыть» ваш почтовый ящик паролем. Это может быть использовано, например, если компьютер находится в офисе и к нему имеют доступ несколько сотрудников. Не путайте пароль ящика с паролем вашего почтового сервера – это две разные вещи, так что убедитесь, что вы используете два различных пароля для сохранения конфиденциальности.

Для защиты своего ящика паролем используйте команду Установить пароль в меню Ящик. Появится приглашение ввести пароль, который в дальнейшем будет использоваться для доступа к почтовому ящику. Если пароль для ящика уже установлен, то можно ввести пустую строку в качестве пароля – после этого ящик будет не защищен.


Почтовые папки Outlook Express

Рассмотрим назначением почтовых папок:

Входящие. Сюда по умолчанию поступает вся новая почта и здесь хранятся все пришедшие сообщения. Впоследствии вы можете создать дополнительные папки (например, посвященные разным проектам или письмам от постоянных адресатов) и настроить Outlook Express таким образом, чтобы при поступлении новых писем вся почта автоматически разбиралась и складывалась в отдельные папки.

Исходящие. Это папка предназначена для временного хранения отправляемых писем. Зачем это нужно? Представьте, что вы подготавливаете несколько писем друг за другом. Чтобы не соединяться каждый раз с Интернетом для отправки очередного письма, письма временно накапливаются в этой папке. Затем при нажатии на кнопку Доставить почту они разом уходят на почтовый сервер провайдера и далее – к своим адресатам. Именно такой режим отправки писем устанавливается в Outlook Express по умолчанию.

Отправленные. Здесь по умолчанию хранятся копии отправленных сообщений, и вы всегда сможете вспомнить, - что, кому и когда вы отсылали.

Удаленные. Если вы решите удалить ненужные сообщения, то они временно помещаются на хранение в эту папку (на случай, если вы передумаете их удалять). Если вы решите насовсем удалить сообщения из этой папки, сделайте правый щелчок по значку папки и из выпавшего меню выберите пункт Очистить папку.

Черновики. Если вы готовите новое письмо, но в процессе работы над ним решите дописать письмо позже, то выберите в меню Файл пункт Сохранить. Такое «недописанное» письмо временно сохраняется в папке Черновики (Drafts). Чтобы продолжить впоследствии работу над письмом из этой папки, просто откройте эту папку и дважды щелкните по черновику письма. Затем, если письмо готово, то его можно отправить и оно будет помещено в папку Исходящие. Если же письмо по-прежнему не готово к отправке, то его опять можно сохранить в папке черновиков.


Получение входящей почты

После запуска Outlook Express делает попытку соединения с сервером провайдера и доставки входящей почты. Если соединение с провайдером уже настроено, то достаточно, выбрав название соединения, нажать кнопку ОК. Иначе появится дополнительное окно, где надо будет ввести ваше имя пользователя и пароль. В любом случае итог будет один, – компьютер начнет устанавливать соединение с почтовым сервером провайдера. Также для соединения с почтовым сервером провайдера достаточно нажать кнопку Доставить почту на панели инструментов Outlook Express.

После того как ваш модем осуществит соединение, появится окно, в котором Outlook Express будет проверять наличие пришедших писем и осуществлять их загрузку на ваш компьютер. После завершения этого действия почтовая программа проверит, нет ли у вас в папке Исходящие готовых писем для отправки, и если есть, то в свою очередь, перешлет их на почтовый сервер провайдера, откуда они уже уйдут адресатам.

Чтение пришедшей почты

По умолчанию все пришедшая почта помещается в папку Входящие и сортируется там по дате поступления. Письма, которые вы еще не читали, помечаются жирным шрифтом и значком закрытого конверта. Если рядом с письмом есть значок с изображением скрепки, то это говорит о том, что в письмо вложен отдельный файл (например, документ в формате Word, графический файл и т. д.). Кроме того, слева от заголовка письма может стоять значок в виде восклицательного знака, который говорит, что адресат пометил данное письмо как сообщение повышенной важности. Если же стоит значок в виде направленной вниз синей стрелки, то наоборот, содержимое письма отправитель пометил как второстепенной важности.

Познакомиться с содержимым письма совсем просто – нужно выделить его, сделав однократный левый щелчок мышью по заголовку письма. Тогда в нижней части окна просмотра Outlook Express появится содержимое письма. Письмо можно посмотреть и в отдельном окне, которое раскроется (см. рис. 8.13), если сделать двойной щелчок по заголовку выбранного письма.

Рис. 8.13. Просмотр письма в отдельном окне

В окне с пришедшим письмом вы найдете ряд новых элементов интерфейса, наиболее важными из них являются следующие кнопки:

Ответить открывает окно для формирования ответного письма. Текст исходного письма может быть автоматически помещен в это окно. Знаки, отмечающие начало строк цитируемого текста, определяются там же, на закладке Отправка.

Ответить … — эта кнопка панели инструментов действует совершенно аналогично предыдущей кнопке Ответить. Исключение состоит в том, что ваше ответное письмо рассылается не только первоначальному автору, но и всем иным адресатам, которым этим автором было послано аналогичное письмо (которые были включены в поле Копия исходного сообщения). Таким образом, эта функция имеет смысл лишь в бизнес-переписке, когда вы организуете таким образом что-то вроде дискуссии. Однако вы должны быть уверены, что все адресаты будут согласны на получения вашего письма. Добавим, что традиция электронной переписки запрещает "веерную рассылку" посланий незнакомым людям, особенно содержащих рекламу (так называемый “Spam”, - сленговое словечко для непрошеной почты, дословно переводимое как «фарш») и пр.

Переслать — эта кнопка позволяет перенаправить (переадресовать) полученное письмо другому пользователю, если вы считаете, что ему(ей) оно будет более интересно, чем вам. Данная функция очень часто используется в бизнес переписке. В разговорной речи среди пользователей почты для этой функции часто используется транслитерированный сленговый термин "форварднуть".

Печать – кнопка с изображением принтера посылает текст письма на принтер. Обратите внимание, что при этом печатается только текст письма, - если письмо содержит вложенные файлы, то для их печати надо открыть соответствующую программу просмотра и выполнить печать уже из данной программы.

Удалить — нажатие на эту кнопку удаляет сообщение из текущей папки и помещает его в папку Удаленные. Впоследствии вы можете очистить папку Удаленные вручную или сообщения будут удаляться из нее автоматически.

Теперь осталось добавить, что если в письмо вложены отдельные файлы, то двойной щелчок по ярлыку каждого вложенного файла позволит просмотреть его содержимое с помощью соответствующей программы. Обратите внимание, что при попытке открыть вложенный файл система безопасности Outlook Express выдаст на экран стандартное предупреждение, и если вы не уверены в том, что пришедший файл абсолютно безопасен для компьютера, то лучше его вначале сохранить на дискету, затем проверить антивирусной программой, и уже затем только открыть для просмотра. Чтобы сохранить файл на дискету (или иной носитель), сделайте правый щелчок по значку вложенного файла в окне с открытым письмом и выберите пункт Сохранить как .

Не следует пугаться всех пришедших с почтой файлов, т.к. далеко не все файлы могут содержать вирусы. К примеру, графические файлы (файлы с расширениями .jpg, .bmp, .tif, .gif и т.д.) и текстовые файлы (файлы с расширениями .txt, .rtf) в общем случае совершенно безопасны, в то время как документы Word (.doc) с большой вероятностью могут содержать макро-вирусы. Ситуация, когда надо быть предельно осторожными – это при получении исполняемых файлов (с расширением .exe, .com).


Пользовательский интерфейс The Bat!

Строка заголовка содержит стандартные элементы окна Windows-приложения (кнопки Свернуть, Восстановить и Закрыть). В этой строке также указано название приложения (The Bat!).

Строка меню содержит заголовки меню, предоставляющие доступ ко всем функциям, необходимым для работы с The Bat!. С помощью меню вы можете формировать новые сообщения, отправлять и получать почту, пересылать письма другим пользователям, настраивать интерфейс The Bat! и т.д.

Панель инструментов предназначена для быстрого доступа к некоторым наиболее часто используемым командам The Bat!.

Кнопки панели инструментов выполняют следующие функции:

  • Получить новую почту с сервера.
  • Отослать почту из очереди, находящейся в папке Outbox.
  • Создать новое сообщение.
  • Ответить на выделенные сообщения.
  • Ответить на все сообщения.
  • Отправить выделенные сообщения.
  • Вызов окна адресной книги, в которую можно записать для хранения адреса e-mail ваших друзей, коллег по работе и т.д.
  • Вызов окна поиска сообщений Message Finder.
  • Распечатать выделенные сообщения.
  • Сохранить выделенные сообщения как...
  • Удалить выделенные сообщения.

Панель «Папки» выводит на экран древовидную структуру учетных записей и папок. Информация разнесена по трем полям с заголовками .

Папка – учетные записи и относящиеся к ним папки,

Новых – количество новых сообщений по каждой папке и

Всего – полное количество сообщений по учетной записи и по каждой папке в ней.

Панель списка сообщений отображает содержимое папки, выбранной в окне панели древовидной структуры. По каждому сообщению выводится следующая информация: наличие присоединенных файлов, закрепление сообщения за папкой, от кого, кому, тема сообщения, дата получения, дата создания.

Несколько слов о том, как интерпретируются значки с различными изображениями конверта:

  • Открытый конверт отмечает уже прочитанное вами письмо.
  • Закрытый конверт плюс жирный шрифт отмечает письмо, которое вы еще не читали.
  • Скрепка у письма говорит о том, что в письмо вложен отдельный файл (например, документ в формате Word, графический файл и т. д.).

Панель просмотра сообщений. При выборе сообщения на панели списка сообщений, на панели просмотра автоматически появляется текст сообщения. Используя команды меню Вид, можно выставить для просмотра заголовок сообщения и служебную информацию, а также настроить вид окон.

Панель сообщений из журнала учетных записей. Выбрав пункт меню Вид->Панель журнала работы, в нижней части окна откроется панель сообщений из журнала учетных записей. В ней указывается последнее сообщение. Для того, чтобы увидеть все записи журнала с момента запуска программы, необходимо щелкнуть мышью по стрелке с правой стороны панельки.


Подготовка и отправка писем электронной почты

Операция подготовки и отправки совершенно аналогична для случаев, когда вы подготавливаете собственное сообщение и отправляете его «с нуля», или же отвечаете на пришедшее письмо (или третий вариант - пересылаете письмо далее другому человеку). Во всех этих случаях на экране появится одно и то же окно (см. рис. 8.14). Конечно, при ответе на чужое письмо или его переадресации другому пользователю отличие будет состоять в том, что Outlook Express автоматически помещает в ответное письмо тот текст, который поступил к вам от адресата. При этом в начале каждой строки исходного письма ставится знак угловой скобки “>”, чтобы отличить ее таким образом от текста вашего ответа. Если текст "пропутешествовал" несколько раз между вами и вашим адресатом, то количество угловых скобок в начале каждой строки будет соответствовать количеству «ходок» вашего письма туда и обратно.

Рис. 8.14. Окно подготовки письма

Формирование нового сообщения

Нажмите на кнопку Создать с … на панели инструментов Outlook Express, что вызовет отдельное окно (см. рис. 8.14). Работу с новым письмом следует начать с заполнения заголовка письма, который содержащий поля: Кому:, Копия:, Скрытая:, Тема:. Заметим, что по понятным причинам обязательным является заполнение только поля Кому: (To:), — иначе письмо просто не найдет своего адресата.

Кому: — так же, как и на обычном конверте, в этом поле вы должны ввести адрес — в данном случае адрес электронной почты вашего адресата. Вы можете не вводить адрес вручную, а выбрать его из адресной книги, если занесли его туда заранее (см. далее раздел "Адресная книга").

Копия: — если вы хотите, чтобы аналогичное письмо пришло и другим адресатам, введите нужные адреса в данном поле, разделяя их с помощью знака ";" (точка с запятой). Словосочетание "Сс" — это сокращение от английского "канцелярского" термина Carbon Copy (по-русски — "копирка"). Все люди, к которым пришло данное письмо, легко смогут узнать из заголовка, кому вы еще послали данное письмо.

Скрытая: — если вы хотите, чтобы аналогичное письмо пришло и другим адресатам, но они не знали, кому еще вы отослали данное письмо, то введите нужные адреса в данном поле, разделяя их с помощью знака ";" (точка с запятой). Словосочетание "Всс" — это сокращение от английского Blind Carbon Copy (по-русски можно было бы перевести как "слепая копирка").

Тема: — здесь следует вписать несколько слов, характеризующих тему сообщения. Заголовок лучше писать по-английски, если вы не уверены, что почтовая программа вашего адресата поддерживает 8-битовую кодировку заголовков и на его машине инсталлированы русские шрифты.

Далее уже можно приступать к самому письму, для чего щелкните курсором мыши в поле письма и введите нужный текст. При необходимости вы можете "вложить" в письмо файл любого формата (см. ниже подраздел о пересылке файлов по E-mail"). По традиции, завершает письмо вставка подписи, для чего следует нажать кнопку с изображением авторучки на панели инструментов (оригинальная и остроумная подпись – одна из традиций Интернета). Если у вас еще не создана подпись, то создать ее можно, выбрав в меню Сервис (Tools) пункт Бланк сообщений и далее – нажав на кнопку Подпись. Созданную таким образом подпись можно потом многократно использовать. В принципе, "интернетовская" подпись — вещь необязательная и вы можете подписать письмо вручную, напечатав обычные слова, подходящие к данному случаю — например, "Искренне ваш..." и т. п.

Теперь осталось лишь нажать на кнопку отправки письма (самая левая кнопка на панели инструментов этого окна с изображением летящего конверта и надписью Отправить) и ваше письмо - на пути к адресату. Если установлен флажок Отправлять сообщения немедленно на вкладке Отправка в окне Параметры (см. меню Сервис), то Outlook Express сразу же произведет соединение с провайдером и отправит письмо. Если же флажок снят, ваши письма будут временно помещаться в папку Исходящие, где они будут накапливаться перед отправкой. В последнем случае на экран будет выведено сообщение о помещении письма в папку Исходящие. Когда вы завершите составление всех писем, нажмите на кнопку Доставить почту на панели инструментов основного окна Outlook Express, и далее процесс соединения с провайдером пойдет совершенно аналогично тому, как мы рассмотрели в предыдущем разделе.


Почтовые папки The Bat!

Inbox (Входящие). Сюда по умолчанию поступает вся новая почта и здесь хранятся все пришедшие сообщения. Впоследствии вы можете создать дополнительные папки (например, посвященные разным проектам или письмам от постоянных адресатов) и настроить The Bat! таким образом, чтобы при поступлении новых писем вся почта автоматически разбиралась и складывалась в отдельные папки.

Outbox (Исходящие). Это папка предназначена для временного хранения отправляемых писем. Зачем это нужно? Представьте, что вы подготавливаете несколько писем друг за другом. Чтобы не соединяться каждый раз с Интернетом для отправки очередного письма, письма временно накапливаются в этой папке. Затем при нажатии на кнопку Отправить почту они разом уходят на почтовый сервер провайдера и далее – к своим адресатам.

Sent (Отправленные). Здесь по умолчанию хранятся копии отправленных сообщений, и вы всегда сможете вспомнить, – что, кому и когда вы отсылали.

Trash(Корзина). Если вы решите удалить ненужные сообщения, то они временно помещаются на хранение в эту папку (на случай, если вы передумаете их удалять). Если вы решите насовсем удалить сообщения из этой папки, сделайте правый щелчок по значку папки и из выпавшего меню выберите пункт Очистить папку.

Совет. Если вы получаете много почты с вложенными файлами (документами, графическими файлами и пр.), то неплохо периодически, – например, хоть раз в месяц проводить чистку своих папок от старых сообщений. Это способствует значительной экономии места на жестком диске машины.

Получение входящей почты

Получение входящей почты – это, наверно, самое простое действие из всего спектра работ с The Bat!, вся функциональность которого состоит в том, что надо установить соединение с почтовым сервером провайдера. Поэтому достаточно запустить программу The Bat!, которая по умолчанию сразу преложит вам соединиться с сервером провайдера. Если соединение с провайдером уже настроено, то достаточно, выбрав нужный почтовый ящик, нажать кнопку Получить новую почту.

После того как ваш модем осуществит соединение, появится окно, в котором будет проверять наличие пришедших писем и осуществлять их загрузку на ваш компьютер (см. рис. 8.8).

Рис. 8.8. Получение почты


Пересылка вложенных файлов по E-mail

Возможность отправить по электронной почте файл любого формата — одно из самых полезных качеств E-mail. Тем самым вы можете направить своим адресатам и документ Word, и файл с нужным изображением, звуковое или видео-приветствие и т.д. Единственное условие — не посылайте очень большие файлы, если вы знаете о том, что ваш адресат не обладает выделенным каналом в Интернет, а работает по обычной телефонной линии. Для таких случаев файл размером 200—300 Кб считается обычно пределом "приличий". Также имейте ввиду, что многие почтовые серверы провайдеров просто возвращают назад почту, если ее размер более определенного предела, чаще всего – более 1 Мб.

Рис. 8.15. Письмо с вложенными файлами

Итак, для вложения файла в письмо, разместив курсор в окне для ввода письма, нажмите кнопку с изображением скрепки на панели инструментов. В ответ на экран будет выведено стандартное диалоговое окно с изображением файловой структуры вашего компьютера. Когда вы найдете на диске нужный файл, выделите его и нажмите кнопку Вложить (Attach). Outlook Express вставит файл в ваше электронное письмо, и ниже тела письма появится дополнительное окно со значком вставленного файла (см. рис. 8.15).

Стоит напомнить, что аналогичным образом выглядят и пришедшие к вам письма, которые содержат вложенные файлы. Достаточно дважды щелкнуть на значке с вложенным файлом, как благодаря механизму OLE (Object Linking and Embedding) операционной системы Windows будет запущено соответствующее приложение для просмотра этого файла.


Ответы на пришедшие письма и их пересылка другим адресатам

Как и многие другие почтовые программы, Outlook Express позволяет ответить на письмо, автоматически совершив такие подготовительные действия как открытие нового окна, ввод адрес абонента в поле Кому:, и размещение в ответном послании первоначального текста для цитирования.

Рассмотрим последовательность действий по ответу на пришедшее письмо:

1. Выберите (пометьте) письмо, на которое хотите ответить, и нажмите на кнопку Ответить в основном окне Outlook Express. Если это письмо уже было открыто в отдельном окне, то там также присутствует кнопка Ответить отправителю. Нажатие на данную кнопку вызовет появление нового окна для ответного сообщения с заполненным полем Кому: и текстом первоначального письма. В поле Тема: будет приведена тема первоначального письма с пометкой "Re:" в начале строки. По этой пометке ваш адресат поймет, что вы прислали ему ответ на письмо по конкретной теме.

2. Если вы пишете друзьям и хотите, чтобы ваше письмо выглядело «в традициях Интернета», то отредактируйте текст первоначального сообщения, оставив только те строки, которые важны для понимания вашего ответа (цитаты). После обычных приветствий и вступительных слов напечатайте под каждой такой цитатой ваш ответ на данное предложение или вопрос.

3. Если же это ответ на деловое письмо, то оставьте весь прежний текст без изменений, а сверху напишите свой ответ.

4. Завершите письмо как обычно и нажмите на кнопку отправки письма (самая левая кнопка на панели инструментов с изображением летящего конверта).

Если ваш адресат разослал такие же письма, как и вам, другим людям, и вы хотите всех познакомить со своим ответом (разослать ваш ответ всем), то вместо кнопки Ответить выберите на панели инструментов Outlook Express кнопку Ответить …. В остальном процесс ответа совершенно аналогичен.

Когда же вы считаете, что пришедшее письмо было бы интересно вашему коллеге (например, по фирме), то вы можете переадресовать его соответствующему лицу, нажав на кнопку Переслать . В этом случае в поле Кому: следует ввести адрес нового получателя. Вы можете ввести адрес как вручную, так и использовать адресную книгу (если нужный адрес внесен в книгу). Обратите внимание на то, что тема первоначального письма будет приведена с пометкой "Fw:" в начале строки. По ней ваш коллега узнает, что это письмо пришло не напрямую, а было переадресовано от вас.

Перед пересылкой вы можете отредактировать текст первоначального письма и добавить вначале письма свои комментарии, если считаете это необходимым. Стоит заметить, что в электронной переписке следует придерживаться таких же правил приличия, как и в обычной жизни. Поэтому не принято переадресовывать письма, которые содержат информацию, адресованную лично вам. В таких случаях лучше пересказать текст другому лицу "своими словами".


Чтение пришедшей почты

По умолчанию вся пришедшая почта помещается в папку Входящие и сортируется там по дате поступления. Непрочитанные письма помечаются жирным шрифтом и значком закрытого конверта. Если рядом с письмом есть значок с изображением скрепки, то это говорит о том, что в письмо вложен отдельный файл (например, документ в формате Word, графический файл и т.д.). Кроме того, слева от заголовка письма может стоять значок в виде восклицательного знака, который говорит, что адресат пометил данное письмо как сообщение повышенной важности. Если же стоит значок в виде направленной вниз синей стрелки, то наоборот, содержимое письма отправитель пометил как второстепенной важности.

Познакомиться с содержимым письма совсем просто – нужно выделить его, сделав однократный левый щелчок мышью по заголовку письма. Тогда в панели просмотра сообщения появится содержимое письма. Письмо можно посмотреть и в отдельном окне, которое раскроется, если сделать двойной щелчок по заголовку выбранного письма (см. рис. 8.9).

Рис. 8.9. Просмотр содержимого письма в отдельном окне

Совет. Чтобы быстрее разобрать почту, удобнее всего вначале раскрывать пришедшие сообщения одинарным щелчком. Тогда даже беглого взгляда достаточно, достойно ли это сообщение вашего дальнейшего внимания. Если да, то лучше раскрыть это сообщение двойным щелчком в отдельном окне.

В окне с пришедшим письмом присутствует следующая панель инструментов:

Наиболее важными из них являются следующие:

Ответить на выбранные письма открывает окно для формирования ответного письма. Текст исходного письма может быть автоматически помещен в это окно. Знаком '>' отмечается начало строк цитируемого текста.

Ответить всем на выбранные письма – эта кнопка панели инструментов действует совершенно аналогично предыдущей кнопке. Исключение состоит в том, что ваше ответное письмо рассылается не только первоначальному автору, но и всем иным адресатам, которым этим автором было послано аналогичное письмо (которые были включены в поле Копия исходного сообщения). Таким образом, эта функция имеет смысл лишь в бизнес-переписке, когда вы организуете таким образом что-то вроде дискуссии. Однако вы должны быть уверены, что все адресаты будут согласны на получения вашего письма. Добавим, что традиция электронной переписки запрещает «веерную рассылку» посланий незнакомым людям, особенно содержащих рекламу (так называемый «Spam», – сленговое словечко для непрошеной почты, дословно переводимое как «фарш») и пр.

Переслать выбранные письма – эта кнопка позволяет перенаправить (переадресовать) полученное письмо другому пользователю, если вы считаете, что ему(ей) оно будет более интересно, чем вам. Данная функция очень часто используется в бизнес-переписке. В разговорной речи среди пользователей почты для этой функции часто используется транслитерированный сленговый термин «форварднуть».

Удалить выбранные письма – нажатие на эту кнопку удаляет сообщение из текущей папки и помещает его в папку Удаленные. Впоследствии вы можете очистить папку Удаленные вручную или сообщения будут удаляться из нее автоматически.

Напечатать выбранные письма – кнопка с изображением принтера посылает текст письма на принтер. Обратите внимание, что при этом печатается только текст письма, – если письмо содержит вложенные файлы, то для их печати надо открыть соответствующую программу просмотра и выполнить печать уже из данной программы.

Теперь осталось добавить, что если в письмо вложены отдельные файлы, то двойной щелчок по ярлыку каждого вложенного файла позволит просмотреть его содержимое с помощью соответствующей программы. Обратите внимание, что при попытке открыть вложенный файл система безопасности The Bat! выдаст на экран стандартное предупреждение, и если вы не уверены в том, что пришедший файл абсолютно безопасен для компьютера, то лучше его вначале сохранить на дискету, затем проверить антивирусной программой, и уже затем только открыть для просмотра. Чтобы сохранить файл на дискету (или иной носитель), сделайте правый щелчок по значку вложенного файла в окне с открытым письмом и выберите пункт Сохранить ….

Не следует пугаться всех пришедших с почтой файлов, так как далеко не все файлы могут содержать вирусы. К примеру, графические файлы (файлы с расширениями .jpg, .bmp, .tif, .gif и т.д.) и текстовые файлы (файлы с расширениями .txt, .rtf) в общем случае совершенно безопасны, в то время как документы Word (.doc) с большой вероятностью могут содержать макро-вирусы. Ситуация, когда надо быть предельно осторожными – это при получении исполняемых файлов (с расширением .exe, .com).


Адресная книга Outlook Express

Адресная книга — это сборник адресов e-mail ваших коллег по электронной переписке, организованный с помощью удобной программной оболочки.

Заполнять адресную книгу Outlook Express можно в двух режимах: во-первых, потратить сначала некоторое время и заранее ввести данные о ваших коллегах, и во-вторых, пополнять адресную книгу "на лету", по мере работы с почтой, — просто копируя туда адреса пришедших писем. Ниже мы рассмотрим эти два случая.

Если вы хотите заполнить адресную книгу заранее, нажмите кнопку Адресная книга (Address Book) на панели инструментов основного окна Outlook Express, что вызовет появление главного окна этого сборника адресов и др. контактной информации (см. рис. 8.16).

Рис. 8.16. Главное окно адресной книги

Кроме имени и адреса E-mail в адресной книге можно хранить множество различной информации — номера телефонов, пейджеров, личных и служебных страниц Web, обычные почтовые адреса абонентов и пр. Для того, чтобы внести в адресную книгу новое имя, нажмите кнопку Создать контакт. Появится окно, показанное на рис. 8.17. Введите в соответствующих полях имя абонента и адрес его электронной почты, при желании можете заполнить дополнительные данные на абонента на других закладках. Если вы захотите отредактировать адрес электронной почты или иной параметр, то выберите имя в адресной книге и нажав кнопку Свойства (Properties), измените данные на закладках аналогичным образом.

Если к вашему компьютеру имеют доступ посторонние люди, не стоит помещать в адресную книгу конфиденциальную информацию, такую как домашние номера телефонов и адреса ваших адресатов.

Рис. 8.17. Заполнение свойств абонента

Вторая возможность: после того, как вы завели адресную книгу и наполнили ее некоторыми адресами, в дальнейшем книгу можно пополнять за счет адресов из вновь пришедших писем. Для этого откройте нужное письмо, отметьте имя адресата в поле заголовка, нажмите правую клавишу мыши и из всплывающего контекстного меню выберите пункт Добавить в адресную книгу.

Теперь, когда адресная книга содержит данные по адресам E-mail ваших коллег по переписке, мы вкратце рассмотрим порядок работы с ней при формировании новых писем и заполнении поля Кому: (To:):

  • Нажмите кнопку Создать в основном окне Outlook Express, поместите курсор в поле Кому: (To:) в окне создания нового сообщения.
  • Щелкните по значку с изображением оторванного листка бумаги рядом со словом Кому:. Это действие вызовет появление диалогового окна (см. рис. 8.18), где можно легко выбрать получателей данного письма.
  • Выберите из списка абонентов нужного человека и нажмите кнопку Кому -> (То->) в средней части окна.
  • Аналогичным образом добавьте абонентов в полях Копия: (Cc:) или Скрытая: (Всс:), если необходимо разослать это письмо еще нескольким адресатам.
  • Нажмите кнопку ОК, и выбранные адреса появятся в соответствующих полях заголовка нового письма.
  • Теперь можно приступать к заполнению тела письма и его отправке, о чем мы уже рассказали ранее.

Рис. 8.18. Выбор получателей сообщения

Имена абонентов, введенных в поля Кому: (To:), Копия: (Cc:), Скрытая: (Всс:) с помощью адресной книги, могут быть представлены в окне письма именами абонентов, а не их электронными адресами. Не беспокойтесь — программа Outlook Express сама подставит адреса E-mail при отправке сообщения.

Еще одна опция, которую вы можете использовать в адресной книге Outlook Express — это групповые имена. Групповые имена представляют собой ваши личные списки рассылки и удобны в том случае, если вам надо часто рассылать письма постоянным группам людей (например, участникам какого-либо совместного с вами проекта). Групповые имена в Outlook Express создаются нажатием на кнопку Создать группу (New Group) на панели значков адресной книги. Затем вы можете указать имя группы и составить список людей в этой группе. После того как вы создали группу, вы можете использовать имя группы в поле Кому: или Копия: отсылаемого сообщения — это сообщение будет направлено всем, кто входит в эту группу. Чтобы в последствии отредактировать список членов группы и их адреса e-mail, надо выбрать (отметить) уже существующую группу и щелкнуть по кнопке Свойства.


Формирование нового сообщения

Нажмите на кнопку Написать на панели инструментов The Bat для вызова отдельного окна редактирования письма (см. рис. 8.10). Работу с новым письмом следует начать с заполнения заголовка письма, содержащего поля: Кому:, Копия:, Тема:. Заметим, что обязательным является заполнение только поля Кому: (To:), – иначе письмо просто не найдет своего адресата.

Рис. 8.10. Окно редактирования письма

Кому: – так же, как и на обычном конверте, в этом поле вы должны ввести адрес – в данном случае адрес электронной почты вашего адресата. Вы можете не вводить адрес вручную, а выбрать его из адресной книги, если занесли его туда заранее (см. далее раздел «Адресная книга»).

Копия: – если вы хотите, чтобы аналогичное письмо пришло и другим адресатам, введите нужные адреса в данном поле, разделяя их с помощью знака «;» (точка с запятой). Все люди, к которым пришло данное письмо, смогут узнать из заголовка, кому вы еще послали данное письмо.

Скрытая копия: – если вы хотите, чтобы аналогичное письмо пришло и другим адресатам, но они не знали, кому еще вы отослали данное письмо, то введите нужные адреса в данном поле, разделяя их с помощью знака «;» (точка с запятой). По умолчанию The Bat! не показывает строку Скрытая копия. Для того чтобы вывести её нужно в меню Вид дать команду Скрытая копия.

Тема: – здесь следует вписать несколько слов, характеризующих тему сообщения. Заголовок лучше писать по-английски, если вы не уверены, что почтовая программа вашего адресата поддерживает 8-битовую кодировку заголовков и на его машине инсталлированы русские шрифты.

Далее уже можно приступать к самому письму, для чего щелкните курсором мыши в поле письма и введите нужный текст. При необходимости вы можете «вложить» в письмо файл любого формата (см. ниже подраздел о пересылке файлов по E-mail). По традиции завершает письмо вставка подписи, подходящей к данному случаю, – например, «Искренне ваш...» и т. п.

Обратите еще внимание на маленький рисунок, находящийся в строке состояния ( [image] ). Он является идентификатором «важности» отправляемого сообщения. В меню Параметры находятся пункт выбора важности сообщений (Нормальный приоритет, Высокий приоритет и Низкий приоритет). При выборе Высокого приоритета значок примет следующий вид: , а низкого – [image] . Важно знать: это не влияет на скорость доставки, а всего лишь управляет наличием изображения с соответствующим значком у вашего письма по приходу письма к адресату. Так, многие почтовые программы маркируют важные сообщения, пришедшие на компьютер, помещая восклицательный знак рядом с заголовком. Теперь дело за адресатом, обратит ли он на это внимание. Поэтому можете не увлекаться установкой этих параметров в ваших письмах.

Теперь осталось лишь нажать на кнопку отправки письма (самая левая кнопка на панели инструментов этого окна с надписью Отправить немедленно- [image] ) и ваше письмо – на пути к адресату.


Пересылка вложенных файлов по E-mail

Возможность отправить по электронной почте файл любого формата – одно из самых полезных качеств E-mail. Тем самым вы можете направить своим адресатам и документ Word, и файл с нужным изображением, звуковое или видео-приветствие и т.д. Единственное условие – не посылайте очень большие файлы, если вы знаете о том, что ваш адресат не обладает выделенным каналом в Интернет, а работает по обычной телефонной линии. Для таких случаев файл размером 200–300 Кбайт считается обычно пределом «приличий». Также имейте в виду, что многие почтовые серверы провайдеров просто возвращают назад почту, если ее размер более определенного предела, чаще всего – более 1 Мбайт.

По-английски процесс вставки файла в письмо называется «attaching», поэтому в разговорной речи среди наших пользователей часто используется транслитерированный сленговый термин «приаттачить файл». Microsoft называет такие файлы «вложенными» – и этот термин чаще всего используется в литературе.

Итак, для вложения файла в письмо, разместив курсор в окне для ввода письма, нажмите кнопку с изображением скрепки на панели инструментов ( [image] ). В ответ на экран будет выведено стандартное диалоговое окно с изображением файловой структуры вашего компьютера. Когда вы найдете на диске нужный файл, выделите его и нажмите кнопку Открыть. The Bat! вставит файл в ваше электронное письмо, и слева от тела письма появится дополнительное окно со значком вставленного файла.

Стоит напомнить, что аналогичным образом выглядят и пришедшие к вам письма, которые содержат вложенные файлы. Достаточно дважды щелкнуть на значке с вложенным файлом, как благодаря механизму OLE (Object Linking and Embedding) операционной системы Windows будет запущено соответствующее приложение для просмотра этого файла.

Некоторые форматы файлов настолько объемные, что занимают многие сотни килобайт (характерный пример таких файлов, – рисунки в формате .bmp). Для снижения размера больших вложенных файлов используйте предварительно какую-нибудь программу-архиватор (например, WinZip), и вкладывайте в электронные письма уже сжатые файлы. Также, если вам надо отослать нескольких вложенных файлов в одном письме, объедините нужные файлы программой-архиватором и отправьте в письме уже единственный архивный файл.

Ответы на пришедшие письма и их пересылка другим адресатам

Как и многие другие почтовые программы, The Bat! позволяет ответить на письмо, автоматически совершив такие подготовительные действия, как открытие нового окна, ввод адрес абонента в поле Кому: (To:), и размещение в ответном послании первоначального текста для цитирования.

Рассмотрим последовательность действий по ответу на пришедшее письмо:

1. Выберите (пометьте) письмо, на которое хотите ответить, и нажмите на кнопку Ответить на выбранные письма ( [image] ) в основном окне The Bat!. Появится новое окно для ответного сообщения с заполненным полем Кому: и текстом первоначального письма. В поле Тема: будет приведена тема первоначального письма с пометкой «Re:» в начале строки. По этой пометке ваш адресат поймет, что вы прислали ему ответ на письмо по конкретной теме.

2. Если вы пишете друзьям и хотите, чтобы ваше письмо выглядело «в традициях Интернета», то отредактируйте текст первоначального сообщения, оставив только те строки, которые важны для понимания вашего ответа (цитаты). После обычных приветствий и вступительных слов напечатайте под каждой такой цитатой ваш ответ на данное предложение или вопрос.

3. Если же это ответ на деловое письмо, то оставьте весь прежний текст без изменений, а сверху напишите свой ответ.

4. Завершите письмо как обычно и нажмите на кнопку отправки письма (самая левая кнопка на панели инструментов).

Если ваш адресат разослал такие же письма, как и вам, другим людям, и вы хотите всех познакомить со своим ответом (разослать ваш ответ всем), то надо выберать на панели инструментов кнопку Ответить всем на выбранные письма ( [image] ). В остальном процесс ответа совершенно аналогичен.

Когда же вы считаете, что пришедшее письмо было бы интересно вашему коллеге (например, по фирме), то вы можете переадресовать его соответствующему лицу, нажав на кнопку Переслать. В этом случае в поле Кому: следует ввести адрес нового получателя. Вы можете ввести адрес как вручную, так и использовать адресную книгу (если нужный адрес внесен в книгу). Обратите внимание на то, что тема первоначального письма будет приведена с пометкой «Fw:» в начале строки. По ней ваш коллега узнает, что это письмо пришло не напрямую, а было переадресовано от вас.

Перед пересылкой вы можете отредактировать текст первоначального письма и добавить в начале письма свои комментарии, если считаете это необходимым. Стоит заметить, что в электронной переписке следует придерживаться таких же правил приличия, как и в обычной жизни. Поэтому не принято переадресовывать письма, которые содержат информацию, адресованную лично вам. В таких случаях лучше пересказать текст другому лицу «своими словами».


Адресная книга The Bat!

Адресная книга – это сборник адресов e-mail ваших коллег по электронной переписке, организованный с помощью удобной программной оболочки. Заполнять адресную книгу Outlook Express можно в двух режимах: во-первых, потратить сначала некоторое время и заранее ввести данные о ваших коллегах, и во-вторых, пополнять адресную книгу «на лету», по мере работы с почтой, – просто копируя туда адреса пришедших писем. Ниже мы рассмотрим эти два случая.

1. Если вы хотите заполнить адресную книгу заранее, нажмите кнопку Адресная книга( [image] ) на панели инструментов основного окна The Bat!, что вызовет появление главного окна этого сборника адресов и другой контактной информации (см. рис. 23).

Кроме имени и адреса E-mail в адресной книге можно хранить множество различной информации – номера телефонов, пейджеров, личных и служебных страниц Web, обычные почтовые адреса абонентов и пр. Для того, чтобы внести в адресную книгу новое имя, нажмите кнопку Добавить нового адресата( [image] ). Введите в соответствующих полях имя абонента и адреса его электронной почты, при желании можете заполнить дополнительные данные на абонента на других закладках. Если вы захотите отредактировать адрес электронной почты или иной параметр, то выберите имя в адресной книге и нажав кнопку Свойства ( [image] ), измените данные на закладках аналогичным образом.

Рис. 23. Адресная книга

Если к вашему компьютеру имеют доступ посторонние люди, не стоит помещать в адресную книгу конфиденциальную информацию, такую, как домашние номера телефонов и адреса ваших адресатов. В программе нет средств защиты адресной книги от несанкционированного доступа.

2. Вторая возможность: после того, как вы завели адресную книгу и наполнили ее некоторыми адресами, в дальнейшем книгу можно пополнять за счет адресов из вновь пришедших писем. Для этого откройте нужное письмо, отметьте имя адресата в поле заголовка, нажмите правую клавишу мыши и из всплывающего контекстного меню выберите пункт Добавить отправителя в адресную книгу.

Теперь, когда адресная книга содержит данные по адресам E-mail ваших коллег по переписке, коротко рассмотрим порядок работы с ней при формировании новых писем и заполнении поля Кому::

– Нажмите кнопку Написать письмо в основном окне The Bat!, поместите курсор в поле Кому: в окне создания нового сообщения.

– Щелкните по значку с изображением оторванного листка бумаги (на рисунке помечен кружком).

Это действие вызовет появление диалогового окна (см. рис. 24), где можно легко выбрать получателей данного письма.

Рис. 24. Выбор адресов из адресной книги

– Выберите из списка абонентов нужного человека или адрес организации и нажмите кнопку > в средней части окна.

– Аналогичным образом добавьте абонентов в полях Копия: или Скрытая копия:, если необходимо разослать это письмо еще нескольким адресатам.

– Нажмите кнопку ОК, и выбранные адреса появятся в соответствующих полях заголовка нового письма.

– Теперь можно приступать к заполнению тела письма и его отправке, о чем мы уже рассказали ранее.

Еще одна опция, которую вы можете использовать в адресной книге The Bat! – это групповые имена. Групповые имена представляют собой ваши личные списки рассылки и удобны в том случае, если вам надо часто рассылать письма постоянным группам людей (например, участникам какого-либо совместного с вами проекта). Групповые имена в The Bat! создаются нажатием на кнопку Создать новую группу на панели значков адресной книги. Затем вы можете указать имя группы и составить список людей в этой группе. После того как вы создали группу, вы можете использовать имя группы в поле Кому: или Копия: отсылаемого сообщения – это сообщение будет направлено всем, кто входит в эту группу. Чтобы впоследствии отредактировать список членов группы и их адреса e-mail, надо выбрать (отметить) уже существующую группу и щелкнуть по кнопке Свойства.

5.11. О шифровании сообщений

Достаточно важный элемент современного использования электронной почты, особенно в сфере бизнеса, – это применение шифрования текста писем и защита сообщений с помощью цифровой подписи. В случае шифрования вы будете уверены, что никто, кроме вашего адресата, не сможет познакомиться с содержимым вашего письма, а цифровая подпись гарантирует, что если кто-то по пути открывал файл с вашим письмом и изменял содержимое, то это не останется незамеченным.

Как мы уже отмечали, сообщение e-mail по пути следования от вашего компьютера до конечного адресата проходит через несколько почтовых серверов и в принципе, на любом из них оно может быть прочитано персоналом провайдеров, отредактировано или даже подменено на ложное сообщение. Разумеется, через почтовые серверы проходят в день тысячи, если не миллионы писем, и прочитать их все просто невозможно. Вдобавок положение о провайдерах Интернета в любой стране запрещает персоналу читать электронные письма клиентов. Поэтому, если вы пишете самое обычное письмо своему приятелю, то можете быть на «на все сто» уверены, что его вряд ли кто прочтет. Но… любители чужих секретов могут в принципе поставить на поток проходящих через почтовый сервер писем некие программы-фильтры, которые отлавливают определенные адреса e-mail или слова или сочетания символов в тексте писем (такие, как 16-значные номера кредиток) и далее отсортированная таким образом почта может подвергнуться уже ручному просмотру.

Поэтому шифрование сообщений и применение цифровой подписи – основная мера, которая может на многие порядки снизить вероятность прочтения электронного письма и его подмену на письмо с другим содержанием. Разумеется, любой шифр можно подобрать и дело лишь за той вычислительной мощью и временем, которые надо на это потратить. Но мы не будем углубляться в проблемы криптографии, поскольку наше пособие ориентировано на обычных пользователей, и в рядовой ситуации шифрование писем – лишь излишняя трата времени. Тем не менее, поскольку даже обычному человеку надо хоть раз в год переслать куда-либо конфиденциальную информацию (или просто информацию, которую он или она считают таковой), во многих почтовых программах, в том числе и в The Bat! существует возможность шифрования информации. The Bat! использует систему Pretty Good Privacy (PGP). PGP может шифровать как файлы, так и е-mail корреспонденцию на основе двух ключей: публичного и секретного. Сначала оба эти ключа генерируются, после чего Вы можете разослать публичный ключ всем вашим знакомым, а также разместить на сервере PGP в Интернете. Далее любой, кто захочет послать вам зашифрованный файл, просто зашифрует его вашим публичным ключом. Интересная особенность такого метода выражается в том, что пользователь, зашифровавший с помощью вашего ключа файл, уже не сможет самостоятельно дешифровать его. Это можно сделать только вашим секретным ключом, который хранится у вас в надежном месте и защищен паролем. Вы можете шифровать файлы на собственном жестком диске собственным публичным ключом, так что позже их сможете прочитать только вы сами.

Замечание. В российском Интернете не стихает дискуссия о правомерности применения шифрования сообщений с точки зрения действующего отечественного законодательства. Российское представительство Microsoft отвечает на этот вопрос просто: «Никаких комментариев по этому вопросу». Большинство же ответов в группах новостей сводится к тому, что вроде запрещено, но де-факто шифрование все-таки используется пользователями, раз это позволяется программами. Особенно большое количество пользователей обсуждают планируемое внедрение системы автоматической перлюстрации электронной почты СОРМ, которую российская служба ФСБ готовится установить на все почтовые серверы провайдеров. Статьи об этом можно встретить на многих серверах Web и в периодических изданиях – см. к примеру, «ФСБ-Онлайнс» в сетевом журнале Inter.net [10].

Замечание. В российском Интернете не стихает дискуссия о правомерности применения шифрования сообщений с точки зрения действующего отечественного законодательства. Российское представительство Microsoft отвечает на этот вопрос просто: «Никаких комментариев по этому вопросу». Большинство же ответов в группах новостей сводится к тому, что вроде запрещено, но де-факто шифрование все-таки используется пользователями, раз это позволяется программами. Особенно большое количество пользователей обсуждают планируемое внедрение системы автоматической перлюстрации электронной почты СОРМ, которую российская служба ФСБ готовится установить на все почтовые серверы провайдеров. Статьи об этом можно встретить на многих серверах Web и в периодических изданиях – см. к примеру, «ФСБ-Онлайнс» в сетевом журнале Inter.net [10].


8.7. Другие сервисы Интернет

Списки рассылки (mailing lists)

Списки рассылки – системы рассылки электронных писем между подписчиками. Суть сервиса «списки рассылки» заключается в том, что выделяется адрес электронной почты, на который можно послать письмо. Сервер службы автоматически разошлет его всем подписчикам данного списка рассылки [11, 12].

Телеконференции (Usenet – группы новостей)

Usenet – это международная некоммерческая сетевая связь для обмена новостями, объединяющая тысячи узлов.

Доступ к Usenet может осуществляться как в интерактивном режиме, так и в режиме отложенного чтения. Usenet представляет собой иерархически организованные по отдельным темам группы новостей (в РЕЛКОМ имеющие название «телеконференции»), в которых содержатся сообщения заинтересованных в соответствующей информации участников. Существуют тысячи различных тем. Некоторые из них регулируются, но большинство открыто для всех (особенно нетехнические группы). Всего действует более 5000 активных групп новостей. Каждая группа новостей выделяется для своей области. В вершине иерархии находятся такие имена как, comp. (компьютеры), rec. (отдых).

Usenet – это система, куда можно отправлять сообщения практически на любую тему, и другие пользователи Internet могут на них ответить.

Для тех, кто не имеет никакого опыта работы с новостями Usenet и не знает, с чего начать, то, возможно, лучше всего стать абонентом группы news.announce.newsusers. Это большая группа, где можно найти полезную информацию для начинающих. Отправлять информацию в эту группу нельзя, но можно прочитать много полезного.

Передача новостей – Телеконференции (NNTP, Network News Transfer Protocol). Существует множество (более 3500) размещенных на серверах в Интернет так называемых телеконференций – в американском переводе Usenet. Это «коллективные» почтовые ящики, информация в которых доступна всем, подписавшимся на нее. В соответствии с протоколом NNTP информация между серверами автоматически обновляется таким образом, что сообщение, направленное на любой из серверов, в конечном итоге (в течение 2-3 часов) оказывается на каждом. Администраторы «подписываются» на выбранные ими темы новостей для пользователей их организации. Телеконференции очень популярны среди сообществ, имеющих схожие задачи или интересы, каждая из них имеет название, а общий список публикуется в сети Usenet.

File Transfer Protocol

Этот сервис обеспечивает оптимизированный (для приема/передачи) доступ к файлам в файловых архивах. Само название ftp означает «протокол передачи файлов» и является средством доступа к файлам, хранящимся на удаленных компьютерных системах. На языке Internet такие удаленные системы называются узлами. ftp-узлы, как правило, имеют древовидную структуру каталогов, каждый из которых относится к определенной теме. В каталогах содержатся файлы. В них хранится множество программного обеспечения, технической документации, исторической, художественной, научной и познавательной литературы и других материалов. Во многих архивах хранятся систематизированные выборки из телеконференций системы Usenet по различным тематикам

При подключении с помощью ftp к другому компьютеру необходимо ввести учетное имя и пароль. Это общие меры защиты. Однако многие узлы желают обеспечить доступ к своим файлам для всех пользователей, не требуя от них учетного имени и пароля. На многих узлах принят стандарт, обеспечивающий такой доступ: в качестве учетного имени всегда задается anonymous, а в качестве пароля почтовый адрес пользователя. Этот метод называется анонимной ftp и стал широко распространенным стандартом. Существует более тысячи узлов, позволяющих использовать анонимную ftp. Обычно, при регистрации как anonymous, удаленная система предоставляет доступ к ограниченному набору файлов.

Соединяясь с ftp-узлами, используя прямое соединение, пользователь вводит имя ftp-узла, указывает имя и пароль при входе в систему, выбирает нужную директорию и определяет один или несколько файлов, которые он хотел бы принять на свою систему.

При отсутствии прямого соединения можно использовать ftp через электронную почту. При этом желаемый ftp-узел достигается посредством специального ftpmai l-сервера, который сам подсоединяется к удаленной системе, входит в нее и пересылает запрошенные файлы по почте в ответ на набор команд, указанных в запросе.

Использование ftp через электронную почту может быть полезно даже для тех, кто имеет прямой доступ к Internet, так как некоторые популярные ftp-узлы обычно перегружены и интерактивное общение с таким системами бывает очень медленным. Поэтому использование почты имеет смысл для того, чтобы не тратить напрасно время и сократить расходы.

Telnet

Telnet – сервис, обеспечивающий удаленное подключение к компьютеру. Этот сервис позволяет сделать ваш компьютер как бы еще одним монитором того компьютера, к которому вы подключились, введя свои имя и пароль. Все команды, которые вы посылаете, выполняются удаленным компьютером, ваши письма и файлы находятся на нем же. Доступен только символьный режим. Данный протокол позволяет работать в Интернет даже при использовании компьютера с 386 процессором и низкоскоростным модемом.


8.10. Глоссарий

CGI (Common Gateway Interface) – это протокол для выполнения сценариев на серверах; в свою очередь серверы осуществляют конечную обработку, например связь с базой данных по запросу со страницы Web. Все коммерческие серверы Web поддерживают сценарии CGI.

DNS (Domain Name System) – служба имен доменов, которая транслирует имена компьютеров в соответствующие адреса IP и обратно.

FTP – протокол передачи файлов, является средством доступа к файлам, хранящимся на удаленных компьютерных системах.

FTP-клиенты – программы для обмена файлами: CuteFTP, WS_FTP.

HTML-редакторы – программы для подготовки Web-документов: FrontPage 2000, DreamWeaver.

Login – регистрационное имя почтового ящика.

Java – язык программирования компании JavaSoft синтаксически подобен C++, но он предусматривает такие ограничения, как запрет на использование указателей.

JavaScript –

Telnet – сервис, обеспечивающий удаленное подключение к компьютеру.

Usenet – это международная некоммерческая сетевая связь для обмена новостями, объединяющая тысячи узлов.

URL – Uniform Resource Locator (универсальный указатель ресурса).

WWW – это система клиент/сервер, которая поддерживает эти гипертекстовые связи.

@ – служебный разделитель.

Адрес IP (Internet Protocol) – это 32-битный компьютерный адрес, с которым непосредственно работают компьютеры Internet.

Браузер – программное средство, предназначенное для просмотра электронных документов, выполненных в формате HTML.

Гиперссылка – выделенный объект, связанный с другим файлом и реагирующий на щелчок мыши.

Гипертекст – текст, содержащий связи с другими текстами, графической, видео- или звуковой информацией.

Глобальные сети – это распределённые сети всемирного масштаба. Самой известной и доступной глобальной сетью является Интернет (Internet).

Менеджеры загрузки (download manager) – программы для перекачки файлов из Сети: Go!Zilla, ReGet, GetRight.

Пакет– это небольшие специфицированные элементы, на которые разбиваются сообщения для передачи по сети.

Почтовые программы (e-mail programmes) – специальные программы для принятия, отправки, сортировки и просмотра электронной почты: Eudora, The Bat!, MS Outlook, Pegasus.

Программы дозвона (dialer programmes) – программы для соединения с провайдером по одному или нескольким номерам телефонов: E-type Dialer, Advanced Dialer.

Программы общения (chat programmes) – программы, предоставляющие возможность вести переговоры в Сети как в текстовом режиме, так и в режиме аудио и видео обмена: MicroIRC, ICQ, IPhone, EasyTalk, NetMeeting.

Списки рассылки – системы рассылки электронных писем между подписчиками.

Тэги (tags) – команды языка HTML.


8.11. Библиографический список

8.12. Библиографический список

  1. Березин С., Раков С. Internet у вас дома. – 2-е изд. – СПб.: BHV-Санкт-Петербург, 1999. – 736 с.
  2. Габбасов Ю. Internet 2000. – СПб.: BHV-Санкт-Петербург, 1999. – 440 с.
  3. Денисов A. Microsoft Internet Explorer 5: Справочник. – СПб.: Питер, 1999. – 448 с.
  4. Крейнак Дж., Хейбрекен Дж. Интернет: Энциклопедия. – СПб.: Питер, 1999. – 560 с.
  5. Monitoring Агентство исследований социума и телерадиовещания Агентство региональных политических исследований URL: http://www.monitoring.ru
  6. Сетевой журнал Inter.net URL: http://www.gagin.ru/internet/12/2.html
  7. Subscribe.Ru – Служба почтовых рассылок URL: http://subscribe.ru
  8. Content.ru | Сервис почтовых рассылок URL: http://content.ru
  9. Сервер информационных технологий URL: http://www.citforum.ru/
  10. Русская компьютерная библиотека. URL: http://www.rusdoc.ru


8.8. Практические упражнения

Упражнение 1. Поиск информации по ключевым словам

1. Запустите программу Internet Explorer (Пуск->Программы->Internet Explorer).

2. На панели Адрес введите: http://www.rambler.com

3. Внимательно рассмотрите загруженную страницу, найдите поле Поиск для ввода ключевых слов и кнопку запуска поиска Найти!.

4. В поле для ввода ключевых слов введите ключевые слова по интересующей Вас теме (например, философия и психология).

5. Щелкните на кнопке Найти!.

6. Просмотрите результаты поиска.

7. Щелкните на гиперссылке с номером 1.

8. Просмотрите загруженную страницу.

9. Щелкните на кнопке Назад на панели инструментов.

10. Повторяя действия пп. 7-9, просмотрите всю первую группу из десяти ссылок на найденные страницы. Сколько из этих страниц все еще существуют? Сколько из них можно считать полезными?

11. Щелкните на кнопке Поиск на панели инструментов.

12. Введите набор ключевых слов из п. 4 в поле панели Поиск.

13. Щелкните на кнопке начала поиска.

14. Сравните результаты поиска.

15. На панель Адрес введите слово find и набор ключевых слов из п.4. Щелкните на кнопке Переход.

16. Объясните, что произошло.


Упражнение 2. Использование папки Избранное

1. Запустите программу Internet Explorer.

2. На панели Адрес введите: http://www.bsu.edu.ru/Info

3. Просмотрите загруженную страницу.

4. Щелкните в рабочей области программы правой кнопкой мыши и выберите в контекстном меню команду Добавить в Избранное.

5. В поле Имя введите: Общая информация о БелГУ.

6. Щелкните на кнопке ОК.

7. Щелкните на кнопке Домой на панели инструментов.

8. Дайте команду Избранное->Общая информация о БелГУ.

9. Убедитесь, что в папке Избранное действительно была сохранена информация о загружаемой странице.

10. Дайте команду Избранное->Упорядочить избранное. Щелкните на кнопке Создать папку. Дайте новой папке имя Материалы.

11. Выберите пункт Общая информация о БелГУ. Щелкните на кнопке Переместить.

12. В диалоговом окне Обзор папок выберите папку Материалы, после чего щелкните на кнопке ОК.

13. Закройте диалоговое окно Упорядочить избранное и программу Internet Explorer без разрыва соединения с Интернетом (если связь по модему).

14. Дайте команду Пуск->Избранное->Материалы-> Общая информация о БелГУ.

15. Ознакомьтесь с тем, какая страница при этом загружается.

16. Уничтожьте папку Материалы и все ее содержимое.


Упражнение 3. Загрузка файла из Интернета

1. Запустите программу Internet Explorer.

2. На панели Адрес введите: ftp://ftp.microsoft.com/ (если связь медленная, то можно попробовать ftp://rusdoc.ru).

3. Внимательно рассмотрите способ представления каталога архива FTP в программе Internet Explorer. Обратите внимание на то, как выглядит значок в строке адреса.

4. Двойными щелчками на значках папок откройте папку /Products/Windows/ Windows95/CDRomExtras/FunStuff/.

5. Щелкните на значке clouds.exe правой кнопкой мыши и выберите в контекстном меню пункт Копировать в папку.

6. Выберите папку, специально отведенную для хранения загруженных файлов, и задайте имя файла.

7. Установите в диалоговом окне загрузки файла флажок Закрыть диалоговое окно после завершения загрузки.

8. Следите за ходом загрузки файла по этому диалоговому окну.

9. Когда загрузка файла завершится, закройте диалоговое окно, информирующее о завершении загрузки.

10. Откройте папку, в которой был сохранен загруженный файл, при помощи программы Проводник.

11. Убедитесь, что загруженный файл можно использовать в соответствии с его назначением.


Упражнение 4. Настройка отображения объектов

Упражнение 4. Настройка отображения объектов (ускорение загрузки Web-страниц ценой отказа от отображения рисунков и других объектов)

1. Запустите программу Internet Explorer.

2. На панели Адрес введите: http://www.webshots.com

3. Щелкните на гиперссылке GALLERY.

4. Зафиксируйте с помощью секундомера время загрузки страницы.

5. Посмотрите, как выглядит загруженная страница.

6. Щелкните на кнопке Назад на панели инструментов.

7. Дайте команду Сервис->Свойства обозревателя.

8. Откройте вкладку Дополнительно.

9. Сбросьте флажки Воспроизводить анимацию, Воспроизводить звуки, Воспроизводить видео и Отображать рисунки.

10. Выберите вкладку Общие.

11. Щелкните на кнопке Удалить файлы.

12. Щелкните на кнопке ОК.

13. Опять щелкните на гиперссылке GALLERY.

14. Еще раз зафиксируйте с помощью секундомера время загрузки страницы.

15. Сравните результаты измерений.

16. Сравните внешний вид страницы при предыдущей и нынешней загрузке.

17. Щелкните на одной из пустых рамок для рисунков правой кнопкой мыши, и выберите в контекстном меню команду Показать рисунок.


Упражнение 5. Создание учетной записи электронной почты

1. Запустите программу The Bat!.

2. Дайте команду Ящик -> Новый почтовый ящик ….

3. Щелкните на кнопке Добавить и выберите в открывшемся меню пункт Почта.

4. В поле Название ящика введите имя почтового ящика. С помощью кнопки Обзор выберите для него каталог.

5. Щелкните на кнопке Далее.

6. Заполните поля Имя и фамилия, Адрес e-mail и Организация. (Необходимую информацию предоставляет преподаватель.)

7. Щелкните на кнопке Далее.

8. Введите заданные имена серверов для входящей и исходящей почты. Если используется один сервер, введите одно и то же имя в оба поля.

9. Щелкните на кнопке Далее.

10. Введите заданные имя пользователя и пароль для доступа к электронной почте.

11. Щелкните на кнопке Далее. Щелкните на кнопке Готово.

12. Посмотрите список в Панели папок. В конце списка должна появиться новая запись.


Упражнение 6. Отправка и получение сообщения электронной почты

1. Запустите программу The Bat!.

2. На панели Папки выберите папку Inbox.

3. Щелкните на кнопке Написать письмо на панели инструментов.

4. В поле Кому введите заданный (свой собственный) адрес электронной почты.

5. В поле Тема введите слова: Проверка работы электронной почты.

6. В тело сообщения введите произвольный легко запоминающийся текст.

7. Щелкните на кнопке Отправить немедленно на панели инструментов.

8. Проследите за процессом отправки созданного сообщения, ход которого отображается в открывшемся окне.

9. Убедитесь, что только что отправленное сообщение появилось в списке поступивших сообщений.

10. Выберите это сообщение в списке и ознакомьтесь с его содержанием на нижней панели.

11. Дважды щелкните на заголовке сообщения, чтобы открыть его в отдельном окне.

12. Закройте окно сообщения.


Упражнение 7. Использование Адресной книги

1. Запустите программу The Bat!.

2. Создайте вручную запись в Адресной книге для своего адреса электронной почты. Для этого щелкните на кнопке Адресная книга и в появившемся окне нажмите кнопку Добавить нового адресата.

3. На вкладке Основное введите свою фамилию, имя, отчество. Укажите адрес электронной почты. По желанию занесите данные о себе также на вкладки Личное и Место работы.

4. Щелкните на кнопке ОК.

5. Убедитесь, что данные занесены в Адресную книгу, – справа в список должен добавиться новый значок.

6. Откройте папку Inbox.

7. Щелкните на заголовке входящего сообщения правой кнопкой мыши и выберите в контекстном меню пункт Специальное->Добавить отправителя в адресную книгу.

8. Убедитесь, что данные занесены в Адресную книгу.

9. Щелкните на кнопке Написать письмо на панели инструментов. Щелкните на кнопке с изображением адресной книги в правой части строки Кому:. Выберите собственный адрес в списке слева и щелкните на кнопке с изображением стрелки (>). Щелкните на кнопке ОК.

10. Убедитесь, что имя адресата внесено в поле Кому. Обратите внимание, что использовано и имя, и адрес.

11. Произвольным образом заполните поле Тема, а также введите текст сообщения.

12. Отправьте созданное сообщение и убедитесь, что оно доставляется правильно (см. упражнение 6).


8.9. Контрольные вопросы

  1. Что такое глобальная сеть? Какая ее важнейшая особенность?
  2. Какие функции выполняет браузер?
  3. Что такое FTP-клиенты?
  4. Что такое гипертекст?
  5. Из чего состоит IP-адрес?
  6. Для чего существует служба имен доменов (DNS)?
  7. Какой формат имеет запись URL?
  8. Для чего используются гиперссылки?
  9. Какие Вы знаете поисковые системы?
  10. Что такое метапоисковые средства поиска?
  11. Как улучшить результаты поиска?
  12. Как сохранить Web-страницу?
  13. Что такое язык HTML?
  14. Какое существует средство для создания и редактирования HTML-страниц?
  15. Как повысить скорость загрузки Web-страниц?
  16. Из чего состоит электронный адрес абонента сети?
  17. Какие существуют правила подготовки электронного письма?
  18. Что такое "смайлики"?
  19. Какие другие сервисы Интернет Вы знаете?


Введение

Сеть представляет собой совокупность компьютеров, объединенных средствами передачи данных. Средства передачи данных в общем случае могут состоять из следующих элементов: связных компьютеров, каналов связи (спутниковых, телефонных, цифровых, волоконно-оптических, радио- и других), коммутирующей аппаратуры, ретрансляторов, различного рода преобразователей сигналов и других элементов и устройств.

Архитектура сети ЭВМ определяет принципы построения и функционирования аппаратного и программного обеспечения элементов сети.

Современные сети можно классифицировать по различным признакам: по удаленности компьютеров, топологии, назначению, перечню предоставляемых услуг, принципам управления (централизованные и децентрализованные), методам коммутации (без коммутации, телефонная коммутация, коммутация цепей, сообщений, пакетов и дейтаграмм и т. д.), видам среды передачи и т. д.

Сети условно разделяют на локальные и глобальные в зависимости от удаленности компьютеров.

Произвольная глобальная сеть может включать другие глобальные сети, локальные сети, а также отдельно подключаемые к ней компьютеры (удаленные компьютеры) или отдельно подключаемые устройства ввода-вывода. Глобальные сети бывают четырех основных видов: городские, региональные, национальные и транснациональные. В качестве устройств ввода-вывода могут использоваться, например, печатающие и копирующие устройства, кассовые и банковские аппараты, дисплеи (терминалы) и факсы. Перечисленные элементы сети могут быть удалены друг от друга на значительное расстояние.

Локальная вычислительная сеть (ЛВС) представляет собой коммуникационную систему, позволяющую совместно использовать ресурсы компьютеров, подключенных к сети, такие, как принтеры, плоттеры, диски, модемы, приводы CD-ROM и другие периферийные устройства. В локальных вычислительных сетях компьютеры расположены на расстоянии до нескольких километров и обычно соединены при помощи скоростных линий связи со скоростью обмена от 1 до 10 и более Мбит/с (не исключается случаи соединения компьютеров и с помощью низкоскоростных телефонных линий). ЛВС обычно развертываются в рамках некоторой организации (корпорации, учреждения). Поэтому их иногда называют корпоративными системами или сетями. Компьютеры при этом, как правило, находятся в пределах одного помещения, здания или соседних зданий.

Функции программного обеспечения компьютера, установленного в сети, условно можно разделить на две группы: управление ресурсами самого компьютера (в том числе и в интересах решения задач для других компьютеров) и управление обменом с другими компьютерами (сетевые функции).

Собственными ресурсами компьютера традиционно управляет ОС. Функции сетевого управления реализует сетевое ПО, которое может быть выполнено как в виде отдельных пакетов сетевых программ, так и в виде сетевой ОС.


7.1. Аппаратные средства ЛВС

Основными аппаратными компонентами ЛВС являются:

1. Рабочие станции (PC) – это, как правило, персональные ЭВМ, которые являются рабочими местами пользователей сети.

Требования, предъявляемые к составу PC, определяются характеристиками решаемых в сети задач, принципами организации вычислительного процесса, используемой ОС и некоторыми другими факторами. Иногда в PC, непосредственно подключенной к сетевому кабелю, могут отсутствовать накопители на магнитных дисках. Такие PC называют бездисковыми рабочими станциями. Однако в этом случае для загрузки в PC операционной системы с файл-сервера нужно иметь в сетевом адаптере этой станции микросхему дистанционной загрузки. Последняя поставляется отдельно, намного дешевле накопителей и используется как расширение базовой системы ввода-вывода BIOS. В микросхеме записана программа загрузки ОС в оперативную память PC. Основным преимуществом бездисковых PC является низкая стоимость, а также высокая защищенность от несанкционированного проникновения в систему пользователей и компьютерных вирусов. Недостаток бездисковой PC заключается в невозможности работать в автономном режиме (без подключения к серверу), а также иметь свои собственные архивы данных и программ.

2. Серверы в ЛВС выполняют функции распределения сетевых ресурсов. Обычно его функции возлагают на достаточно мощный ПК, мини-ЭВМ, большую ЭВМ или специальную ЭВМ-сервер. В одной сети может быть один или несколько серверов. Каждый из серверов может быть отдельным или совмещенным с PC. В последнем случае не все, а только часть ресурсов сервера оказывается общедоступной.

При наличии в ЛВС нескольких серверов каждый из них управляет работой подключенных к нему PC. Совокупность компьютеров сервера и относящихся к нему PC часто называют доменом. Иногда в одном домене находится несколько серверов. Обычно один из них является главным, а другие – выполняют роль резерва (на случай отказа главного сервера) или логического расширения основного сервера.

Важнейшими параметрами, которые должны учитываться при выборе компьютера-сервера, являются тип процессора, объем оперативной памяти, тип и объем жесткого диска и тип дискового контроллера. Значения указанных характеристик, так же как и в случае PC, существенно зависят от решаемых задач, организации вычислений в сети, загрузки сети, используемой ОС и других факторов.

Оперативная память в сервере используется не только для собственно выполнения программ, а и для размещения в ней буферов, дискового ввода вывода. Определив оптимально количество и размер буферов, можно существенно ускорить выполнение операций ввода-вывода.

Объем выбираемого накопителя должен быть достаточным для размещения на нем необходимого программного обеспечения (особенно при бездисковых PC), а также совместно .используемых файлов и баз данных.

3. Линии передачи данных соединяют PC и серверы в районе размещения сети друг с другом. В качестве линий передачи данных чаще всего выступают кабели. Наибольшее распространение получили кабели на витой паре (рис. 7.1,а) и коаксиальный кабель (рис. 7.1,б). Более перспективным и прогрессивным является оптоволоконный кабель. В последнее время стали появляться беспроводные сети, средой передачи данных в которых является радиоканал. В подобных сетях компьютеры устанавливаются на небольших расстояниях друг от друга: в пределах одного или нескольких соседних помещений.

а) б)
Рис. 7.1. Сетевые кабели: а – кабель на основе скрученных пар (витая пара);
б – коаксиальный кабель

4. Сетевые адаптеры (интерфейсные платы) используются для подключения компьютеров к кабелю (рис. 7.2). Функцией сетевого адаптера является передача и прием сетевых сигналов из кабеля. Адаптер воспринимает команды и данные от сетевой операционной системы (ОС), преобразует эту информацию в один из стандартных форматов и передает ее в сеть через подключенный к адаптеру кабель.

Рис. 7.2. Сетевой адаптер

Используемые сетевые адаптеры имеют три основные характеристики: тип шины компьютера, к которому они подключаются (ISA, EISA, Micro Channel и пр.), разрядность (8, 16, 32, 64) и топология образуемой сети (Ethernet, Arcnet, Token-Ring).

К дополнительному оборудованию ЛВС относят источники бесперебойного питания, модемы, трансиверы, репитеры, а также различные разъемы (коннекторы, терминаторы).

Источники бесперебойного питания (ИБП) служат для повышения устойчивости работы сети и обеспечения сохранности данных на сервере. При сбоях по питанию ИБП, подключаемый к серверу через специальный адаптер, выдает сигнал серверу, обеспечивая в течение некоторого времени стабильное напряжение. По этому сигналу сервер выполняет процедуру завершения своей работы, которая исключает потерю данных. Основным критерием выбора ИБП является мощность, которая должна быть не меньше мощности, потребляемой подключаемым к ИБП сервером.

Трансивер – это устройство подключения PC к толстому коаксиальному кабелю. Репитер предназначен для соединения сегментов сетей. Коннекторы (соединители) необходимы для соединения сетевых адаптеров компьютеров с тонким кабелем, а также для соединения кабелей друг с другом. Терминаторы служат для подключения к открытым кабелям сети, а также для заземления (так называемые терминаторы с заземлением).

Модем используется в качестве устройства подключения ЛВС или отдельного компьютера к глобальной сети через телефонную связь.


7.2. Топология ЛВС

Топология – это конфигурация соединения элементов в сеть. Топология во многом определяет такие важнейшие характеристики сети, как ее надежность, производительность, стоимость, защищенность и т.д.

Одним из подходов к классификации топологий ЛВС является выделение двух основных классов топологий: широковещательных и последовательных.

В широковещательных конфигурациях каждый персональный компьютер передает сигналы, которые могут быть восприняты остальными компьютерами. К таким конфигурациям относятся топологии «общая шина», «дерево», «звезда с пассивным центром». Сеть типа «звезда с пассивным центром» можно рассматривать как разновидность «дерева», имеющего корень с ответвлением к каждому подключенному устройству.

В последовательных конфигурациях каждый физический подуровень передает информацию только одному персональному компьютеру. Примерами последовательных конфигураций являются: произвольная (произвольное соединение компьютеров), иерархическая, «кольцо», «цепочка», «звезда с интеллектуальным центром», «снежинка» и др.

Коротко рассмотрим три наиболее широко распространенные (базовые) топологии ЛВС: «звезда», «общая шина» и «кольцо».

В случае топологии «звезда» каждый компьютер через специальный сетевой адаптер подключается отдельным кабелем к центральному узлу (рис. 7.3). Центральным узлом служит пассивный соединитель или активный повторитель.

Рис. 7.3. Топология «звезда»

Недостатком такой топологии является низкая надежность, так как выход из строя центрального узла приводит к остановке всей сети, а также обычно большая протяженность кабелей (это зависит от реального размещения компьютеров). Иногда для повышения надежности в центральном узле ставят специальное реле, позволяющее отключать вышедшие из строя кабельные лучи.

Топология «общая шина» предполагает использование одного кабеля, к которому подключаются все компьютеры. Информация по нему передается компьютерами поочередно (рис. 7.4).

Рис. 7.4. Топология «общая шина»

Достоинством такой топологии является, как правило, меньшая протяженность кабеля, а также более высокая надежность чем у «звезды», так как выход из строя отдельной станции не нарушает работоспособности сети в целом. Недостатки состоят в том, что обрыв основного кабеля приводит к неработоспособности всей сети, а также слабая защищенность информации в системе на физическом уровне, так как сообщения, посылаемые одним компьютером другому, в принципе, могут быть приняты и на любом другом компьютере.

При кольцевой топологии данные передаются от одного компьютера другому по эстафете (рис. 7.5). Если некоторый компьютер получает данные, предназначенные не ему, он передает их дальше по кольцу. Адресат предназначенные ему данные никуда не передает.

Рис. 7.5. Кольцевая топология

Достоинством кольцевой топологии является более высокая надежность системы при разрывах кабелей, чем в случае топологии с общей шиной, так как к каждому компьютеру есть два пути доступа. К недостаткам топологии следует отнести большую протяженность кабеля, невысокое быстродействие по сравнению со «звездой» (но соизмеримое с «общей шиной»), а также слабую защищенность информации, как и при топологии с общей шиной.

Топология реальной ЛВС может в точности повторять одну из приведенных выше или включать их комбинацию. Структура сети в общем случае определяется следующими факторами: количеством объединяемых компьютеров, требованиями по надежности и оперативности передачи информации, экономическими соображениями и т. д.


7.3. Принципы управления

Существует два основных принципа управления в локальных сетях: централизация и децентрализация.

В сетях с централизованным управлением функции управления обменом данными возложены на файл-серверы. Файлы, хранящиеся на сервере, доступны рабочим станциям сети. Одна PC к файлам другой PC доступа не имеет. Правда, обмен файлами между PC может происходить и в обход основных путей с помощью специальных программ.

Существует множество сетевых ОС, реализующих централизованное управление. Среди них Microsoft Windows NT/2000 Server, Novell NetWare (версии З.Х и 4.Х), Microsoft Lan Manager, OS/2 Warp Server Advanced, VINES 6.0 и др.

Преимуществом централизованных сетей является высокая защищенность сетевых ресурсов от несанкционированного доступа, удобство администрирования сети, возможность создания сетей с большим числом узлов. Основной недостаток состоит в уязвимости системы при нарушении работоспособности файл-сервера (это преодолевается при наличии нескольких серверов или в результате принятия некоторых других мер), а также в предъявлении довольно высоких требований к ресурсам серверов.

В централизованной схеме управления все вычислительные ресурсы, данные и программы их обработки были сконцентрированы в одной ЭВМ. Пользователи имели доступ к ресурсам машины с помощью терминалов (дисплеев). Терминалы подключались к ЭВМ через интерфейсные соединения или удаленные телефонные линии связи (так называемые удаленные терминалы). Основной функцией терминала было отображение информации, представляемой пользователю. К достоинствам этой схемы можно отнести удобство администрирования, модификации программного обеспечения и защиты информации. Недостатком схемы является ее низкая надежность (выход из строя ЭВМ влечет за собой разрушение вычислительного процесса), сложность масштабирования (наращивания мощности) модификации аппаратного и программного обеспечения, как правило, резкое снижение оперативности при увеличении числа пользователей системы и др.

Децентрализованные (одноранговые) сети не содержат в своем составе выделенных серверов. Функции управления сетью в них поочередно передаются от одной PC к другой. Ресурсы одной PC (диски, принтеры и другие устройства) оказываются доступными другим PC.

Наиболее распространенными программными продуктами, позволяющими строить одноранговые сети, являются следующие программы и пакеты: Novell NetWare Lite, Windows for Workgroups, Artisoft LANtastic, LANsmart, Invisible Software NET-30 и др. Все они могут работать под управлением DOS. Для одноранговой сети могут быть использованы также ОС Windows 95/98 и Windows NT/2000 Prof.

Развертывание одноранговой сети для небольшого числа PC часто позволяет построить более эффективную и живучую распределенную вычислительную среду. Сетевое программное обеспечение в них является более простым по сравнению с централизованными сетями. Здесь не требуется установка файл-сервера (как компьютера, так и соответствующих программ), что существенно удешевляет систему. Однако такие сети слабее с точки зрения защиты информации и администрирования.


7.4. Технология «клиент-сервер»

Технология «клиент-сервер» пришла на смену централизованной схеме управления вычислительным процессом на базе средней или большой ЭВМ (мэйнфрейма).

В архитектуре клиент-сервера место терминала заняла ПЭВМ (клиентская), а мэйнфрейма – один или несколько мощных компьютеров, специально выделенных для решения общих задач обработки информации (компьютеры-серверы). Достоинством этой модели является высокая живучесть и надежность вычислительной системы, легкость масштабирования, возможность одновременной работы пользователя с несколькими приложениями, высокая оперативность обработки информации, обеспечение пользователя высококачественным интерфейсом и т. д.

Заметим, что эта весьма перспективная и далеко не исчерпавшая себя технология получила свое дальнейшее развитие. Совсем недавно стали говорить о технологии intranet, которая появилась в результате перенесения идей сети Internet в среду корпоративных систем. В отличие от технологии «клиент-сервер» эта технология ориентирована не на данные, а на информацию в ее окончательно готовом к потреблению виде. Технология Intranet объединяет в себе преимущества двух предыдущих схем. Вычислительные системы, построенные на ее основе, имеют в своем составе центральные серверы информации и распределенные компоненты представления информации конечному пользователю (программы-навигаторы, или броузеры). Детальное рассмотрение этой технологии выходит за рамки настоящего пособия.

При взаимодействии любых двух объектов в сети всегда можно выделить сторону, предоставляющую некоторый ресурс (сервис, услугу), и сторону, потребляющую этот ресурс. Потребителя ресурса традиционно называют клиентом, а поставщика – сервером.

В качестве ресурса можно рассматривать аппаратный компонент (диск, принтер, модем, сканер и т. д.), программу, файл, сообщение, информацию или даже ЭВМ в целом. Отсюда происхождение множества терминов: файл-сервер или диск-сервер, принт-сервер или сервер печати, сервер сообщений, SQL-сервер (программа обработки запросов к базе данных, сформулированных на языке SQL), компьютер-сервер и т. д. Очевидно, все эти серверы имеют соответствующих клиентов.

С точки зрения программного обеспечения, технология «клиент-сервер» подразумевает наличие программ-клиентов и программ-серверов. Клиентскими программами обычно являются такие программы, как текстовые и табличные процессоры. В роли серверных программ чаще всего выступают системы управления базами данных. Примером типичной пары программ вида «клиент-сервер» можно считать программу текстового процессора, обрабатывающую документ, в котором содержится таблица с информацией из базы данных.

Некоторая программа, выполняемая в сети, по отношению к одним программам может выступать в роли клиента и в то же время являться сервером для других программ. Более того, за некоторый интервал времени роли клиента и сервера между одними и теми же программами могут меняться.

Разновидностью более сложных клиент-серверных моделей является трехзвенная модель «сервера приложений» – AS-модель (Application Server). Эта модель описывает процесс функционирования сетей, использующих базы данных. Согласно as-модели, каждая их трех основных функций (управление данными, прикладная обработка и представление информации конечному пользователю) реализуется на отдельном компьютере.


7.5. Программное обеспечение технологии «клиент-сервер»

7.5. Программное обеспечение технологии
«клиент-сервер»

Для успешного применения технологии «клиент-сервер» должно использоваться соответствующее программное обеспечение, включающее клиентскую и серверную части. В частности, широко используемый пакет Microsoft Office представляет собой комплекс программ для клиентского компьютера. В его состав входят: текстовый процессор Word, табличный процессор Excel, система подготовки презентаций PowerPoint, система управления базами данных Access и программа управления информацией Outlook.

В связи с успехом распространения этого пакета корпорация Microsoft решила собрать воедино комплекс программ для сервера – так появился пакет MS BackOffice.

В состав названного пакета входят следующие компоненты:

  • Windows NT Server – сетевая операционная система;
  • System Management Server – система администрирования сети;
  • SQL Server – сервер управления базами данных;
  • SNA Server – сервер для соединения с хост-компьютерами;
  • Exchange Server – сервер системы электронной почты;
  • Internet Information Server – сервер для работы с Internet.

Windows NT/2000 Server способна обеспечить совместное использование файлов, печатающих устройств, предоставить услуги по соединению с рабочими станциями (клиентскими компьютерами) и другой сервис.

Существуют следующие две разновидности Windows NT/2000:

  • Windows NT/2000 Workstation предназначена для использования на автономном компьютере;
  • Windows NT/2000 Server предназначена для использования в качестве сетевой операционной системы и может использоваться на рабочей станции для реализации дополнительных возможностей.

Windows NT Server целесообразно использовать в случаях, когда предполагается наличие нескольких процессоров (обычно до четырех). Кроме того, Windows NT Server обеспечивает совместное использование ресурсов многими пользователями, возможность соединения с удаленными сетями через сервис удаленного доступа – RAS (Remote Access Service), а также через средства связи с сетями других фирм (Novell, Digital Pathworks и Apple).

System Management Server (SMS) позволяет сетевому администратору централизованно управлять всей сетью. При этом обеспечивается возможность администрирования каждого компьютера, подключенного к сети, включая установленное на нем программное обеспечение. SMS предоставляет следующий сервис:

  • управление инвентаризацией программного и аппаратного обеспечения;
  • автоматизация установки и распространения программного обеспечения, включая его обновление;
  • удаленное устранение неисправностей и предоставление полного контроля администратору за клавиатурой, мышью и экранами всех компьютеров в сети, работающих под управлением MS-DOS или Windows;
  • управление сетевыми приложениями.

SQL Server представляет собой систему управления реляционными базами данных, использующую принципы технологии «клиент-сервер». MS SQL Server поддерживает систему обработки транзакций, систему сохранения ссылочной целостности, механизм распределенных транзакций, тиражирование данных.

SNA Server обеспечивает возможность связи с IBM AS/400 и мэйнфреймами IBM (EC ЭВМ). Этот продукт позволяет нескольким настольным ПЭВМ, работающим под управлением MS-DOS, Windows, Windows NT, Macintosh, Unix или OS/2, «видеть» хост-компьютеры.

Exchange Server обеспечивает средства передачи и приема сообщений в информационной сети организации. Этот сервис включает электронную почту (E-mail) и обмен информационными сообщениями для рабочих групп. Microsoft Exchange Server построен на принципах технологии «клиент-сервер» и масштабируется в соответствии с возрастанием вычислительных возможностей сети.

Internet Information Server обеспечивает возможность создания Web-, FTP- и Gopher-серверов для сети Internet, поддерживает управление ими с помощью встроенной программы Internet Service Manager.


7.6. Работа пользователя в сети

Сетевые возможности Windows 98/2000 Prof

Рассмотрим работу пользователя в сети средствами ОС Windows 98/2000 Prof, которая может использоваться в качестве:

  • ОС одноранговой сети с узлами, функционирующими под управлением как Windows 98, так и Windows 2000 Professional.
  • клиентской ОС в сетях с выделенным сервером, управляемых ОС Windows NT/2000 Server, a также NetWare.

Использование Windows 98/2000 Prof в качестве ОС одноранговой сети позволяет:

  • осуществлять обмен данными между рабочими станциями сети;
  • совместно использовать ресурсы рабочих станций (диски, папки, принтеры, факсы). Для удобства пользования сетевыми папками на рабочих станциях можно назначать им имена дисков. После этого они будут отображаться в виде сетевых дисков в папке Мой компьютер;
  • обеспечивать парольную защиту ресурсов рабочих станций, выделенных в общее пользование;
  • создавать рабочие группы пользователей.

Рабочей группой называют совокупность пользователей, объединенных одной общей задачей (например, разработкой проекта) и имеющих общее имя. В рамках каждой рабочей группы действует электронная почта Microsoft Mail, позволяющая обмениваться членам группы почтой. В одной сети может быть организовано несколько рабочих групп, имеющих доступ ко всем сетевым ресурсам.

Клиент сети – это программное обеспечение, позволяющее использовать общие ресурсы сети (папки, принтеры и т.д.). Клиент для сетей NetWare позволяет подключаться к серверам Novell NetWare. Клиент для сетей Microsoft позволяет использовать общие ресурсы компьютеров, работающих под управлением Microsoft Windows 98, Windows NT/2000 и LAN Manager.

Служба дает возможность делать файлы, принтеры и прочие ресурсы доступными для других компьютеров, а также автоматизирует архивацию файлов на сервер сети. В качестве примера можно привести службу доступа к файлам и принтерам сетей Microsoft.

Протокол – это набор конкретных правил обмена информацией между устройствами передачи данных. Существует множество различных протоколов. Чтобы два компьютера могли общаться между собой, они должны использовать одинаковый сетевой протокол.


Вход в сеть

Перед окончанием загрузки Windows 98/2000 предлагает ввести «имя пользователя» и пароль (рис. 7.6).

Рис. 7.6. Ввод сетевого пароля

При этом выполняются следующие действия:

1. Принимаемым по умолчанию именем, показываемым в текстовой строке Имя пользователя, является имя компьютера, введенное при настройке. При желании можно изменить входное имя на что-либо другое, например, на ваше имя.

2. Введите в строке Пароль пароль, чтобы предотвратить доступ других пользователей к вашей копии Windows 98/2000. При вводе пароля буквы заменяются звездочками, чтобы никто не подсмотрел пароль. Если вы не будете пользоваться паролем, эту строку оставьте пустой.

3. Щелкните на кнопке OK. Если вы нажмете кнопку Отмена, Windows 98 заканчивает загрузку без поддержки сети. В Windows 2000 Professional нажатие кнопки Отмена не позволит загрузить операционную систему. Т.е. без правильного указания имени пользователя и пароля в Windows 2000 работа пользователя невозможна.

Если при запуске Windows вам не было предложено ввести сетевой пароль, а на рабочем столе Windows 98 отсутствует значок Сетевое окружение, это означает, что компьютер не настроен для работы в сети.

Если вы работаете без сети или хотите войти в сеть под другим именем выполните следующую процедуру.

Для Windows 98:

1. Нажмите кнопку Пуск и выберите пункт Завершение сеанса …

2. На вопрос Вы действительно хотите завершить сеанс? ответьте утвердительно (нажмите кнопку Да).

3. После появления окна Ввод сетевого пароля выполните вышеуказанные в этом разделе действия.

Для Windows 2000:

1. Нажмите кнопку Пуск и выберите пункт Завершение сеанса ....

2. Нажмите кнопку Ок.

3. После появления окна Ввод сетевого пароля выполните вышеуказанные в этом разделе действия.

Работа с документом или программой, расположенной на другом компьютере, практически ничем не отличается от работы с аналогичными ресурсами своего компьютера.

а) [image] б)

Рис. 7.7. Значки: а) значок Сетевое окружение в Windows 98;
б) значок Мое сетевое окружение в Windows 2000

Для получения доступа к сети в Windows 98 дважды щелкните на значке Сетевое окружение (рис. 7.7,а). В Windows 2000 данный значок называется Мое сетевое окружение (рис. 7.7,б). Затем дважды щелкните на значке нужного компьютера. Если нужного компьютера нет в списке, воспользуйтесь значком Вся сеть. Откройте эту папку для просмотра всех рабочих групп, являющихся частями полной сети, к которой подключен ваш компьютер. (Если вы подключены только к своей рабочей группе, вы увидите только одну эту рабочую группу.) При открытии папок рабочих групп выводятся имена всех компьютеров, образующих каждую рабочую группу. Дважды щелкните на искомой папке.

Для каждого компьютера видны только те ресурсы, к которым владелец или системный администратор разрешил доступ.


Настройка компьютера для работы в сети

Настройка компьютера для работы в сети состоит из двух этапов: установки сетевого программного обеспечения и идентификации вашего компьютера для сетевых целей.

Настройка не выполняется в том случае, если при запуске Windows вам было предложено ввести сетевой пароль, а на рабочем столе Windows находится значок Сетевое окружение. Это означает, что компьютер уже настроен для работы в сети.

Перед установкой программного обеспечения необходимо убедиться, что сетевое оборудование (сетевая плата и кабели) установлено правильно.

Окно сетевой настройки (рис. 7.8) может быть вызвано, например, выбором значка Сеть Панели управления .

Рис. 7.8. Окно сетевой настройки

Вкладка Конфигурация отображает список установленных сетевых компонентов. Их можно подгрузить, используя окно, вызываемое по нажатию кнопки Добавить.

Раскрывающийся список Способ входа в сеть позволяет применить один из следующих способов входа в сеть:

  • обычный вход в Windows, при котором система сама определяет тип используемой сети и необходимость соответствующего клиента (устанавливается по умолчанию);
  • клиент для сетей Microsoft.

Вкладка Идентификация предоставляет возможность установки параметров, идентифицирующих компьютер в сети:

  • имя пользователя длиной не более 15 символов. Имя должно упрощать другим пользователям идентификацию того компьютера, с которым они работают;
  • название рабочей группы, которой принадлежит компьютер (не более 15 символов). Это имя должно быть одинаковым для всех компьютеров в сети. Если вы подключаетесь к большей сети, имя рабочей группы присваивает администратор сети;
  • краткое описание компьютера длиной до 48 символов. Windows показывает это описание в некоторых сетевых списках, помогая другим пользователям узнать, с каким компьютером они работают.

Для имени компьютера система по умолчанию использует первые 8 символов имени пользователя.

Вкладка Управление доступом позволяет назначить режим доступа пользователя к сетевым ресурсам:

  • на уровне ресурсов – в этом режиме общим ресурсам (папка, диск, принтер) назначается пароль для доступа к этим ресурсам;
  • на уровне пользователя, используется в сетях под управлением Windows NT/2000 Server, Novell NetWare и других, в которых защита основана на присвоении пользователям или группам определенных прав. Этот режим позволяет указать сетевой домен или сервер, на котором хранится список пользователей с указанием их прав доступа к сетевым ресурсам. В одноранговой сети под управлением Windows 98 данный режим использоваться не может.


Организация сетевого доступа к ресурсам компьютера

Установка службы доступа к файлам и принтерам для сетей Microsoft или NetWare позволяет делать ресурсы компьютера (программы, документы и прочие файлы, а также принтеры) доступными для остальных пользователей. Другие пользователи могут подключать и использовать общие ресурсы компьютера. Чтобы предоставить доступ к отдельным файлам, следует сделать общей содержащую их папку.

Организация доступа к файлам и принтерам компьютера

1. Нажмите кнопку Пуск и выберите пункт Панель управления в меню Настройка.

2. Щелкните дважды на значке Сеть.

3. Выберите вкладку Конфигурация в окне диалога Сеть.

4. Нажмите кнопку Доступ к файлам и принтерам. Появится диалоговое окно, показанное на рис. 7.9.

Рис. 7.9. Организация доступа к файлам и принтерам

5. Установите соответствующий флажок.

6. Нажмите кнопку ОК.

Организация защиты сетевых ресурсов

Существует два режима доступа к общим ресурсам компьютера:

1. Доступ на уровне ресурсов. Выбор данного режима доступа позволяет организовать парольную защиту сетевых ресурсов от несанкционированного доступа. Любой пользователь, желающий получить доступ к общему ресурсу, должен знать пароль, назначенный этому ресурсу. Подобная защита целесообразна в небольших сетях.

Для каждого разделяемого ресурса Windows предоставляет три типа прав доступа:

  • Только чтение. На этом уровне каждый, обращающийся к ресурсу, может только копировать, открывать и просматривать файлы. Файлы нельзя пересылать, модифицировать, переименовывать и удалять, нельзя также добавлять новые файлы.
  • Полное. Этот уровень предоставляет полный доступ к файлам ресурса и позволяет делать все операции с файлами.
  • Определяется паролем. Этот уровень допускает присвоение отдельных паролей для считывания и для полного доступа.

Для предоставления или запрета общего доступа к ресурсу необходимо выполнить следующие действия:

1. В папке Мой компьютер выберите ресурс, к которому следует предоставить или запретить общий доступ.

2. В меню Файл или в контекстном меню (вызывается правой кнопкой мыши) выберите пункт Доступ... Если пункт Доступ отсутствует, необходимо организовать доступ к файлам и принтерам (см. п. 4.4.1).

3. В появившемся окне диалога Свойства (рис. 7.10) установите переключатель в положение Общий ресурс для разрешения общего доступа к ресурсу или в положение Локальный ресурс – для запрета.

Рис. 7.10. Назначение пароля диску D

4. Установите переключатель Тип доступа в положение Определяется паролем.

5. В соответствующих полях Пароль (для чтения и/или для полного доступа) введите пароль доступа к ресурсам компьютера.

6. Нажмите кнопку ОК.

7. Укажите пароль еще раз в окне Подтверждение паролей.

Предоставление доступа к принтеру делается аналогично. Для выбора нужного принтера используйте папку Принтеры (Пуск -> Настройка -> Принтеры).

2. Доступ на уровне пользователей. При использовании данного режима защиты доступ к ресурсам предоставляется в зависимости от прав, полученных пользователем от сетевого администратора, например, Windows NT/2000. Каждый пользователь идентифицируется в сети по имени, присвоенному ему вместе с правами администратором.

При использовании данного метода доступа на станции с Windows 98 можно предоставить право пользования ресурсами станции отдельным пользователям или группам, сформированных администраторами того или иного уровня.

Это делает защиту более гибкой, так как администратор Windows NT/2000 помимо полного доступа и доступа по чтению к папкам может предоставлять ряд дополнительных прав. Имена и группы пользователей домена UC, созданных администратором сети Windows NT/2000, представлены на рис. 7.11.

Рис. 7.11. Добавление пользователей ресурсов станции

Предоставление выбранной группе пользователей соответствующих прав выполняется нажатием кнопки Только чтение, Полный доступ или Специальный. Специальные права более разнообразны и определяются возможностями ОС сервера сети.

Свойства папки Мои документы при использовании защиты на уровне пользователей показаны на рис. 7.12. Только пять пользователей имеют доступ к данному ресурсу, причем каждый из них имеет свои права доступа.

Рис. 7.12. Назначение совместного доступа к папке Мои документы


Отображение сетевого ресурса

Можно «отобразить» сетевой ресурс таким образом, что он оказывается ресурсом вашего компьютера. Предположим, что на вашем компьютере есть накопитель на гибких дисках (А), винчестер (С) и CD-ROM (D). При отображении сетевого накопителя он появляется как накопитель Е. Это упрощает пересылку и копирование файлов с привлечением сетевого накопителя и делает его доступным из MS-DOS.

Чтобы отобразить сетевой ресурс, откройте Сетевое окружение, выберите нужный ресурс и воспользуйтесь любым из следующих способов:

  • Выберите команду Подключить сетевой диск... в меню Файл.
  • Щелкните на сетевом ресурсе правой кнопкой мыши и выберите команду Подключить сетевой диск.
  • Щелкните мышью на кнопке Подключить сетевой диск панели инструментов. Если панель инструментов не отображается, выберите в меню Вид команду Панель инструментов.

Независимо от способа появится окно диалога Подключение сетевого диска (рис. 7.13).

Рис. 7.13. Подключение сетевого диска

1. В строке Путь укажите сетевое имя ресурса, который следует подключить. Например: \\имя_компьютера\имя_папки. Обратите внимание, что перед именем компьютера ставится двойная наклонная черта. Чтобы подключить ресурс, который недавно использовался, нажмите кнопку со стрелкой в раскрывающемся списке Путь и в появившемся списке имен выберите необходимое.

2. Если ресурс защищен паролем, появится окно Ввод сетевого пароля, в котором необходимо указать правильный пароль.

3. В строке Диск укажите букву, которую Windows будет использовать для отображения сетевого ресурса.

4. Если необходимо отображать диск при каждом входе в Windows, включите режим Автоматически подключать при входе в систему.

5. Щелкните на кнопке ОК. Через некоторое время новый диск появится в списке как часть папки Мой компьютер.

Для того чтобы отключить отображение ресурса:

1. Отметьте нужный ресурс.

2. Выберите команду Отключить в меню Файл или щелкните мышью на кнопке Отключить сетевой диск панели инструментов.

Изображение значка ресурса различается в зависимости от его расположения и прав доступа в сети (см. рис. 7.14).

Рис. 7.14. Подключение папки Public в качестве сетевого диска I


Использование сетевого принтера

Одно из преимуществ организации рабочей группы состоит в возможности использования дорогих устройств, например принтеров, всеми компьютерами. Можно установить сетевой принтер и использовать его как принтер, подключенный к вашему компьютеру. Единственное отличие лишь в том, что на этом принтере нельзя выполнять некоторые операции, например удаление текущего печатного задания.

Для установки сетевого принтера на компьютере:

1. Нажмите кнопку Пуск, выберите команду Принтеры в меню Настройка.

2. В появившейся папке Принтеры дважды щелкните на значке Установка принтера. После этого запустится Мастер установки принтеров.

3. Нажмите кнопку Далее для перехода к следующему окну диалога (рис. 7.15).

Рис. 7.15. Второй шаг Мастера установки принтера

4. Выберите Сетевой принтер и нажмите кнопку Далее.

5. В следующем диалоге необходимо указать сетевое имя принтера. Для этого нажмите кнопку Обзор.

6. В окне Обзор принтеров (рис. 7.16) просмотрите все доступные принтеры и выберите нужный.

Рис. 7.16. Окно выбора доступных сетевых дисков

7. Нажмите кнопку ОК.

8. В следующих диалогах:

  • выберите фирму-изготовителя и драйвер принтера;
  • укажите название принтера и возможность использования его по умолчанию;
  • выберите, печатать ли пробную страницу.

На этом установка принтера завершена и он появится в папке Принтеры.


Разрешение вопросов, возникающих при работе в сети

1. В папке Сетевое окружение отсутствуют другие компьютеры

  • Видны не все компьютеры или только ваш.

В папке Сетевое окружение отображаются только компьютеры, входящие в рабочую группу, к которой принадлежит данный компьютер. Если компьютер был переведен в другую рабочую группу, имена компьютеров из остальных групп в папке Сетевое окружение не появятся.

Чтобы указать имя компьютера и рабочей группы, к которой он принадлежит:

1. Выберите вкладку Компьютер в диалоге Сеть
2. Введите имя компьютера и имя рабочей группы. Имя компьютера должно быть уникальным, т.е. не совпадать ни с одним из имен других компьютеров в сети.

  • Не виден ни один компьютер сети.

Просмотрите всю сеть. Для этого дважды щелкните значок Вся сеть. Если значок Вся сеть в папке Сетевое окружение не виден, значит, что на компьютере не установлено сетевое программное обеспечение. Обратитесь к администратору сети.

2. Возможные ошибки при подключении к другому компьютеру

  • Нельзя обнаружить в сети нужный компьютер

Необходимо определить, подключен ли компьютер к сети. Для этого:

1. Нажмите кнопку Пуск и выберите пункт Поиск.
2. Выберите команду Компьютер.
3. В появившемся окне введите имя компьютера, который требуется найти.
4. Нажмите кнопку Найти.

Если не удалось обнаружить компьютер, возможно, компьютер неисправен или отключен от сети.
Если удалось обнаружить компьютер, попробуйте просмотреть общие ресурсы компьютера. Для этого дважды щелкните значок компьютера в списке.

  • Нужный компьютер виден, но его общие ресурсы не отображаются.

Возможно, в данный момент на компьютере нет общих ресурсов.

  • Общие ресурсы видны, но недоступны.

Возможно, у вас нет прав доступа к ресурсам данного компьютера.

3. Не удается предоставить общий доступ к папке или принтеру

Убедитесь, что на компьютере включен режим совместного доступа к ресурсам:

1. Выберите вкладку Конфигурация в окне диалога Сеть.
2. Нажмите кнопку Доступ к файлам и принтерам. Если кнопка недоступна, то, по-видимому, используемая сеть не поддерживает общий доступ к файлам, либо эта возможность запрещена администратором сети. Обратитесь к администратору сети.
3. Установите нужные режимы доступа.

4. Другие пользователи не могут получить доступ к ресурсам компьютера

1. Проверьте, видят ли другие пользователи ваш компьютер в своих папках Сетевое окружение.
2. Если видят, проверьте, видят ли они ваши ресурсы.
3. Если видят, убедитесь, что на компьютере включен режим совместного доступа к ресурсам, как указано в предыдущем разделе.

Если другие пользователи не видят ваш компьютер или ресурсы, проверьте, какие клиенты сети используются в данный момент. Клиент сети обозначается значком [image] . Убедитесь в том, что используется правильный клиент (Клиент для сетей Microsoft).


7.9. Глоссарий

Intranet – технология ориентированая не на данные, а на информацию в ее окончательно готовом к потреблению виде. Технология появилась в результате перенесения идей сети Internet в среду корпоративных систем.

Архитектура сети ЭВМ определяет принципы построения и функционирования аппаратного и программного обеспечения элементов сети.

Домен – это совокупность компьютеров сервера и относящихся к нему PC.

Имя пользователя – имя компьютера, введенное при настройке.

Клиент – потребитель ресурса сети.

Клиент сети – это программное обеспечение, позволяющее использовать общие ресурсы сети (папки, принтеры и т.д.).

Коннекторы (соединители) необходимы для соединения сетевых адаптеров компьютеров с тонким кабелем, а также для соединения кабелей друг с другом.

Линии передачи данных соединяют PC и серверы в районе размещения сети друг с другом.

Локальная вычислительная сеть (ЛВС) представляет собой коммуникационную систему, позволяющую совместно использовать ресурсы компьютеров, подключенных к сети, такие, как принтеры, плоттеры, диски, модемы, приводы CD-ROM и другие периферийные устройства.

Модем – устройство подключения ЛВС или отдельного компьютера к глобальной сети через телефонную связь, предназначенное для преобразования и передачи данных между удаленными клиентами.

Мэйнфрейм – централизованная схема управления вычислительным процессом на базе средней или большой ЭВМ.

Пароль – секретная комбинация символов, служащая для подтверждения права доступа к определенному ресурсу, например, к удаленному компьютеру в сети или к папке на диске.

Протокол – это набор конкретных правил обмена информацией между устройствами передачи данных.

Рабочая группа – совокупность пользователей, объединенных одной общей задачей (например, разработкой проекта) и имеющих общее имя.

Рабочие станции (PC) – это, как правило, персональные ЭВМ, которые являются рабочими местами пользователей сети.

Репитер предназначен для соединения сегментов сетей.

Сервер – это мощный компьютер, выполняющий функции распределения сетевых ресурсов.

Сеть представляет собой совокупность компьютеров, объединенных средствами передачи данных.

Служба дает возможность делать файлы, принтеры и прочие ресурсы доступными для других компьютеров, а также автоматизирует архивацию файлов на сервер сети.

Терминаторы служат для подключения к открытым кабелям сети, а также для заземления (так называемые терминаторы с заземлением).

Технология «клиент-сервер» – архитектура, в которой место терминала выполняет ПЭВМ (клиентская), а мэйнфрейма – один или несколько мощных компьютеров, специально выделенных для решения общих задач обработки информации (компьютеры-серверы).

Трансивер – это устройство подключения PC к толстому коаксиальному кабелю.


7.10. Библиографический список

  1. Локальные вычислительные сети: Справочник. В 3 кн. – Кн. 1. Принципы построения, архитектура, коммуникационные средства / Под ред. С. В. Назарова. – М.: Финансы и статистика, 1994. – 208 с.
  2. Дж. Бойс. Сетевые возможности Windows 95. Настольная книга пользователя: Пер. с англ. – М.: Бином, 1997.
  3. Богумирский Б. Энциклопедия Windows 98 – 2-е изд. – СПб.: Питер, 1999. – 896 с.
  4. Андердал Б. Самоучитель Windows 98. – 2-е изд. – СПб.: Питер, 1999. – 400 с.
  5. Сервер информационных технологий URL: http://www.citforum.ru/
  6. Русская компьютерная библиотека. URL: http://www.rusdoc.ru


Практические упражнения

Упражнение 1. Работа с Сетевым окружением

1. Откройте папку Сетевое окружение на Рабочем столе.

2. В списке компьютеров найдите компьютер с именем UCSRV.

3. Двойным щелчком раскройте список папок данного компьютера, открытых для общего сетевого доступа.

4. Попробуйте открыть папку User. Система выведет окно сообщения Нет доступа к \\Ucsrv\User. Это означает, что пользователь не имеет прав на открытие и просмотр данного ресурса.

5. Теперь откройте папку Centrdoc, вы увидите список папок, связанных с разными отделами Учебного центра. Попробуйте создать свою папку (команда Файл->Создать->Папку) или удалить какую-либо папку или файл. Снова появится окно сообщения Нет доступа. В данном случае вы обладаете ограниченным набором прав для данного ресурса, а именно, можете только просматривать содержимое папок и файлов без возможности внесения изменений.

6. Откройте папку Public. Создайте в ней свою папку (команда Файл->Создать->Папку, имя папки – это ваша фамилия) и затем в свой папке создайте какой-либо файл. Как видите система не выводит окно сообщения Нет доступа, так как вы имеете полный набор прав по отношению к данному ресурсу.

Упражнение 2. Копирование с сетевого ресурса

1. Откройте папку Сетевое окружение на Рабочем столе.

2. В списке компьютеров найдите компьютер с именем UCSRV.

3. Откройте папку Public. Выберите любой документ Word из списка файлов и скопируйте его в буфер обмена.

4. Откройте папку Мой компьютер на рабочем столе. Откройте папку вашей группы. Вставьте файл в свою папку из буфера.

5. Откройте файл в MS Word и посмотрите его содержимое.

Упражнение 3. Организация сетевого доступа к ресурсу

1. Откройте папку Мои документы на Рабочем столе.

2. В списке папок найдите папку своей группы. Если её нет, то командой Файл->Создать->Папку создайте её.

3. Выберите свою папку (не открывая её). В меню Файл или в контекстном меню (вызывается правой кнопкой мыши) выберите команду Доступ... Если данная команда отсутствует, то необходимо организовать доступ к файлам и принтерам.

4. В появившемся окне диалога Свойства установите переключатель в положение Общий ресурс для разрешения общего доступа к ресурсу или в положение Локальный ресурс – для запрета.

5. Установите переключатель Тип доступа в положение Определяется паролем.

6. В соответствующих полях Пароль (для чтения и/или для полного доступа) введите пароль доступа к ресурсам компьютера.

7. Нажмите кнопку ОК.

8. Укажите пароль еще раз в окне Подтверждение паролей.


7.8. Контрольные вопросы

  1. Что такое компьютерная сеть? Какие виды компьютерных сетей Вы знаете?
  2. Каковы преимущества объединения компьютеров в сеть?
  3. Что является основными аппаратными компонентами ЛВС?
  4. Каковы функции сервера?
  5. Что такое домен?
  6. Какие существуют виды кабелей для объединения компьютеров в сеть?
  7. Что такое коннектор?
  8. Для чего служит модем?
  9. Для чего служит сетевой адаптер?
  10. Какие топологии ЛВС Вы знаете, чем они характеризуются?
  11. Какие существуют принципы управления в локальных сетях?
  12. Что такое технология клиент-сервер?
  13. Какое программное обеспечение осуществляет технологию клиент-сервер?
  14. Что такое рабочая группа?
  15. Что такое протокол?
  16. Как настроить компьютер для работы в сети?
  17. Как подключить сетевой принтер?


Электронный учебник по информатике

Введение

6.1. Модели организации баз данных

6.2. Основные этапы разработки приложения

6.3. Стратегия разработки приложения
Данные и информация
Отбор необходимых данных
Нормализация

Чужие ключи

6.4. Архитектура Microsoft Access

6.5. Создание базы данных
Создание новой пустой таблицы

Типы данных

Импорт данных. Импорт текстового файла

Многотабличные базы данных. Отношения между таблицами

Создание связей между таблицами

6.6. Работа с данными при помощи запросов

Выбор данных из одной таблицы

Включение полей в запрос

Ввод условий отбора и выбор между AND и OR

Вычисляемые поля

Итоговые запросы

Перекрестные запросы
Модификация данных с помощью запросов на изменение.

Типовые ошибки и проблемы, возникающие при выполнении запросов на изменение

6.7. Построение и применение форм

Обзор форм

Конструктор форм

Панель элементов

6.8. Основные сведения об отчетах

Создание отчета

Разработка отчета в режиме конструктора

Сортировка и группировка информации

Задание условий группировки и сортировки

Задание диапазонов группировки

6.9. Автоматизация работы приложения с помощью макросов

Создание простого макроса

Проверка работы макроса

Создание сложного макроса

Группы макросов

Задание условий выполнения макрокоманд

6.10. Практические задания

Задание 1. База данных «Абитуриент»
Задание 2. База данных «Торговая организация»
Задание 3. База данных «Банк»
Задание 4. База данных «Страны Европы»
Задание 5. База данных «Библиотека»
Задание 6. База данных «Цементные заводы»
Задание 7. База данных «Служба занятости»
Задание 8. База данных «Железнодорожный вокзал»

6.11. Контрольные вопросы

6.12. Глоссарий

6.13. Библиографический список

СЛЕДУЮЩАЯ ГЛАВА
ПРЕДЫДУЩАЯ ГЛАВА
ОГЛАВЛЕНИЕ
ПОИСК
ПРЕДМЕТНЫЙ УКАЗАТЕЛЬ
ГЛОССАРИЙ УЧЕБНИКА
СОДЕРЖАНИЕ УЧЕБНИКА


Алгоритмы и способы их описания

11.1. Алгоритмы и способы их описания

Понятие алгоритма
Способы описания алгоритмов

Структурные схемы алгоритмов

11.2. Этапы подготовки и решения задач на ЭВМ

11.3. Компиляция и интерпретация программ

11.4. Стили программирования

Процедурное программирование

Функциональное программирование

Логическое программирование

Объектно-ориентированное программирование

11.5 Контрольные вопросы

11.6. Глоссарий

11.7. Библиографический список

СЛЕДУЮЩАЯ ГЛАВА
ПРЕДЫДУЩАЯ ГЛАВА
ОГЛАВЛЕНИЕ
ПОИСК
ПРЕДМЕТНЫЙ УКАЗАТЕЛЬ
ГЛОССАРИЙ УЧЕБНИКА
СОДЕРЖАНИЕ УЧЕБНИКА


Электронный учебник по информатике

ВВЕДЕНИЕ

I. ОСНОВНЫЕ ПОНЯТИЯ ОБ ИНФОРМАЦИИ И ИНФОРМАТИКЕ

1.1. Информация и формы ее представления

Понятие количества информации

1.2. Информационные процессы и технологии

1.3. ЭВМ как средство обработки информации

Понятие архитектуры ЭВМ
Классификация ЭВМ
Структура и принципы функционирования ЭВМ
Основные характеристики вычислительной техники
Перспективы развития вычислительных средств

1.4. Виды программного обеспечения ЭВМ

1.5. Операционная система MS-DOS

Основные составные части MS-DOS

Начальная загрузка MS-DOS

Файловая система MS-DOS

Файловая структура логического диска

1.6. Контрольные вопросы

1.7. Глоссарий

1.8. Библиографический список

ТЕСТ

II. УСТРОЙСТВО ПЕРСОНАЛЬНОГО КОМПЬЮТЕРА

2.1. Базовая аппаратная конфигурация

Системный блок
Материнская плата

Процессор
Шинные интерфейсы материнской платы
Оперативная память
Микросхема ПЗУ и система BIOS
Энергонезависимая память CMOS
Жесткий диск
Дисковод гибких дисков
Дисковод компакт-дисков CD-ROM
Видеокарта (видеоадаптер)
Звуковая карта
Монитор
Мониторы на электронно-лучевой трубке (CRT)
Мониторы на жидких кристаллах (LCD)
Клавиатура
Мышь

2.2. Периферийные устройства персонального компьютера

Устройства ввода графических данных
Устройства вывода данных
Устройства хранения данных
Устройства обмена данными

2.4. Контрольные вопросы

2.5. Глоссарий

2.6. Библиографический список

ТЕСТ

III. ОСНОВЫ РАБОТЫ С ОПЕРАЦИОННОЙ СИСТЕМОЙ Windows 2000

3.1. Введение

3.2. Начало и завершение работы

Запуск Windows 2000 Professional
Аккуратный выход из Windows 2000 Professional
Запуск Windows 98
Завершение работы Windows 98

3.3. Интерфейс Windows 98/2000

Управление Windows
Рабочий стол

Стартовое меню

Панель задач
Окно Мой компьютер

Корзина

Контекстно-зависимые меню

Ярлыки
Структура окна в Windows
Длинные имена файлов
Преимущества использования длинных имен файлов
Расширения имен файлов

3.4. Программа Проводник

Запуск программы Проводник
Иерархическое дерево папок и устройств
Работа с содержимым окна программы Проводник
Кнопки Назад, Вперед и Вверх
Поиск папок и файлов в программе Проводник
Управление файлами
Отображение файлов и папок в окне программы Проводник
Отмена операций с файлами
Операции с файловой структурой
Маркирование объектов
Маркирование группы файлов
Маркирование всех файлов и папок
Копирование и перемещение объектов
Использование буфера обмена для работы с объектами
Удаление файлов
Восстановление удаленных файлов
Переименование объектов
Отмена выполненного действия
Создание новой папки
Открытие папок

3.5. Работа с приложениями

Типы приложений
Запуск приложений
Запуск приложений с помощью стартового меню
Запуск приложения, ярлык которого расположен на рабочем столе
Запуск приложений с помощью кнопок панели инструментов
Запуск приложения с помощью диалогового окна Выполнить
Поиск приложений
Запуск приложения, хранящегося на сетевом запоминающем устройстве
Запуск приложения с помощью окна Сеанс MS-DOS
Запуск резидентных программ
Запуск приложений с помощью программы Проводник
Завершение работы приложения

3.6. Работа Windows 98/2000 в многозадачном режиме

Работа с окнами
Как активизировать окно с помощью мыши
Различные способы расположения окон на рабочем столе
Панель задач

Что такое задача?

Работа с панелью задач
Перемещение панели задач
Изменение размеров панели задач
Конфигурирование панели задач
Переключение между программами с помощью клавиатуры

Многозадачность на практике

Работа с несколькими DOS-приложениями

3.7. Конфигурирование стартового меню

Добавление новых команд в стартовое меню
Перемещение команд в стартовом меню
Удаление команд из стартового меню
Изменение свойств стартового меню

3.8. Установка и удаление приложений Windows

Особенности спецификации Windows
Стандартное средство установки приложений
Удаление приложений Windows

3.9. Установка оборудования

Средства программной установки оборудования
Порядок установки оборудования

3.10. Настройка средств ввода-вывода данных

Настройка клавиатуры
Настройка мыши
Настройка стиля управления операционной системой

3.11. Настройка элементов оформления Windows 98/2000

Настройка фона Рабочего стола
Настройка экранной заставки
Настройка оформления элементов управления Windows
Дополнительные средства оформления Рабочего стола
Средства оформления Рабочего стола Active Desktop
Настройка параметров экрана
Настройка свойств видеоадаптера и монитора
Настройка звуковых схем
Оформление Windows 98 темами Рабочего стола
Настройка Главного меню
Настройка свойств Корзины
Настройка свойств окон папок
Настройка шрифтов
Растровые и векторные шрифты
Векторные шрифты True Type и PostScript
Системное средство установки и удаления шрифтов

3.12. Прочие настройки Windows

Настройка системных часов и системного календаря
Настройка системных часов и системного календаря

3.13. Справочная система Windows 98/2000

Справочная система в диалоговых окнах
Контекстная подсказка
Справочная система Windows

3.14. Стандартные приложения Windows 98/2000

Программа Блокнот
Графический редактор Paint
Текстовый процессор WordPad
Калькулятор

3.15. Служебные приложения Windows 98/2000

Архивация данных (Microsoft BackUp)

Буфер обмена

Дефрагментация диска

Индикатор системных ресурсов

Преобразование в FAT32

Проверка диска

Сведения о системе

Сжатие данных

Агент сжатия

Системный Монитор

Таблица символов

Утилита форматирования дискет

3.16. Стандартные средства мультимедиа

Регулятор громкости

Лазерный проигрыватель

Универсальный проигрыватель

Программа Звукозапись

3.17. Средства обеспечения совместимости с приложениями MS-DOS

Сеанс MS-DOS

Режим MS-DOS

Настройка свойств значка приложения MS-DOS

3.18. Практические упражнения по Windows

Упражнение 1. Отработка приемов управления с помощью мыши
Упражнение 2. Изучение приемов работы с объектами
Упражнение 3. Работа в файловой структуре в программе Проводник
Упражнение 4. Исследование методов запуска программы Проводник
Упражнение 5. Основы работы в текстовом редакторе Блокнот
Упражнение 6. Приемы работы с графическим редактором Paint
Упражнение 7. Приемы форматирования в текстовом процессоре WordPad

3.19. Контрольные вопросы

3.20. Глоссарий

3.21. Библиографический список

ТЕСТ

IV. ИСПОЛЬЗОВАНИЕ ТЕКСТОВОГО ПРОЦЕССОРА Microsoft Word ДЛЯ ПОДГОТОВКИ ДОКУМЕНТОВ

Введение

4.1. Возможности Word 2000

4.2. Запуск Microsoft Word

4.3.Структура окна MS Word
Строка заголовка
Строка меню
Панели инструментов
Настройка панелей инструментов
Вывод на экран/удаление с экрана панелей инструментов
Строка состояния
Описание элементов строки состояния
Назначение индикаторов строки состояния
Контекстное меню

4.4. Выход из MS Word

4.5. Справочная система Word 2000

Справка об объектах в главном окне MS Word

Справка об объектах окна диалога

4.6. Создание и сохранение документов в MS Word
Специальные средства ввода текста
Имена файлов
Папки
Создание документа
Создание пустого документа
Открытие существующего документа
Открытие файлов других форматов
Работа с несколькими документами
Сохранение документа
Автоматическое сохранение документов
Защита сохраненного документа с помощью пароля
Закрытие документа

4.7. Редактирование документа
Средства для представления документа на экране
Масштаб
Перемещение в документе

Перемещение с помощью полос прокрутки

Перемещение с помощью панели поиска

Перемещение с помощью окна диалога Найти и заменить
Перемещение с помощью клавишных команд
Перемещение с помощью схемы документа

4.8.Основные приемы редактирования

Выделение текста
Выделение текста с помощью мыши

Выделение текста с помощью клавиатуры

Удаление фрагмента документа
Перемещение и копирование фрагмента документа

Буфер обмена

Отмена результатов редактирования

4.9. Специальные средства редактирования
Использование поиска и замены
Проверка правописания

Автоматическая проверка правописания

Проверка уже введенного текста
Перенос слов
Автоматический перенос слов
Принудительное разделение слов при переносе

4.10. Форматирование символов
Шрифты
Использование окна диалога Шрифт
Использование панели инструментов Форматирование
Вкладка Интервал окна диалога Шрифт
Изменение регистра букв
Вставка символов
Копирование форматов символов

4.11. Форматирование строк и абзацев
Символ абзаца
Средства форматирования абзаца
Команда Абзац из меню Формат или контекстного меню
Средства панели инструментов Форматирование
Выравнивание абзацев
Табуляция
Удаление табуляции
Установка отступа
Установка расстояния перед абзацем и после него
Установка междустрочного интервала
Границы и заливка

4.12. Списки
Создание маркированных и нумерованных списков
Изменение формата маркированного списка
Изменение формата нумерованного списка
Создание многоуровневых списков

4.13. Использование стилей для форматирования документа
Установка стилей
Оглавление

4.14. Автоформат
Автоформатирование в процессе ввода текста
Автоформатирование уже введенного текста
Автоформатирование с помощью окна диалога Автоформат

4.15. Форматирование страниц документа
Разбивка документа на разделы
Определение размера и ориентации бумаги
Установка ширины полей
Установка точных размеров полей
Создание разворотов и полей под переплет
Установка ширины полей с помощью горизонтальной линейки
Колонтитулы
Создание разных колонтитулов для четных и нечетных страниц
Нумерация страниц
Вставка номеров страниц
Создание колонок

4.16. Работа с таблицами
Создание таблиц
Создание таблицы различными способами
Ввод данных и перемещение по таблице

Отражение и маскирование линий сетки

Вставка и удаление ячеек, строк и столбцов
Объединение и разбиение ячеек, создание заголовков
Настройка таблиц
Перемещение и копирование ячеек
Использование команды Таблица - Свойства таблицы
Автоматическая установка ширины столбцов и высоты строк
Форматирование таблиц
Изменение направления текста
Использование средства Автоформат
Выбор рамки и заполнения
Преобразование таблицы в текст
Преобразование текста в таблицу

4.17. Шаблоны
Шаблоны и документы
Замена шаблона
Перенос элементов одного шаблона в другой
Изменение шаблона
Создание собственного шаблона
Тема
Библиотека стилей

4.18. Создание и редактирование графических изображений
Вставка графических клипов
Импорт графических объектов из файлов
Создание графических объектов при помощи панели инструментов

4.19. Рисование
Работа с рисунком
Изменение размеров рисунков
Перемещение и копирование рисунков
Панель Настройка изображения
Вставка объектов WordArt
Ввод формул
Запуск и настройка редактора формул

4.20. Предварительный просмотр и печать документов
Предварительный просмотр перед печатью
Печать документа
Дополнительные опции печати
Печать неоткрытых документов
Печатать документа с помощью Проводника
Печать в файл

4.21. Основные принципы практической работы с текстовым процессором Microsoft Word

Задание 1

Задание 2
Задание 3
Задание 4
Задание 5
Задание 6
Задание 7
Задание 8
Задание 9
Задание 10
Задание 11
Задание 12
Задание 13
Задание 14
Задание 15
Зачетное задание

4.22. Контрольные вопросы

4.23. Глоссарий

4.24. Библиографический список

ТЕСТ

V. ОБРАБОТКА ДАННЫХ СРЕДСТВАМИ Microsoft Excel

5.1. Рабочая книга и листы

Общие сведения
Работа с листами
Одновременный просмотр нескольких книг
Одновременный просмотр различных частей листа

5.2. Ввод данных

Выделение ячеек на листе
Интерпретация данных
Ввод текста и чисел
Быстрое заполнение повторяющихся данных в столбце
Автозаполнение, основанное на смежных ячейках
Заполнение рядов чисел, дат и других элементов
Создание пользовательского списка или порядка сортировки
Проверка вводимых в ячейку данных

5.3. Изменение данных на листе

Изменение содержимого ячейки
Очистка ячейки
Перемещение и копирование ячеек
Изменение ширины столбца
Вставка строк и столбцов

5.4. Форматирование

Форматирование текста и размещение его внутри ячейки
Выделение данных, отвечающих определенным свойствам
Изменение способа отображения чисел, дат и времени
Отображение и скрытие нулевых значений и других данных
Использование рамок и фона в ячейках

5.5. Создание формул

Применение операторов в формулах
Порядок выполнения действий в формулах
Ссылки на ячейку или на группу ячеек
Ввод формулы
Использование функций
Категории функций Microsoft Excel
Ошибки в формулах
Использование имен

5.6. Проверка книг

Поиск зависимых и влияющих ячеек
Поиск некорректных значений на листе

5.7. Работа с диаграммами

Примеры типов диаграмм
Создание диаграммы
Изменение диаграммы

5.8. Управление списками

Рекомендации по созданию списка на листе книги
Сортировка данных в списке
Разрешение вопросов, возникающих при сортировке
Фильтрация списка с использованием автофильтра
Фильтрация списка с помощью расширенного фильтра

5.9. Подведение итогов данных

Суммирование значений в списке
Подведение промежуточных итогов
Подведение «вложенных» или многоуровневых итогов
Удаление промежуточных итогов

5.10. Сводные таблицы

Части сводной таблицы
Создание сводной таблицы
Изменение структуры сводной таблицы
Группировка данных в сводной таблице
Обработка данных сводной таблицы

5.11. Печать

Задание на листе области печати
Изменение макета выводимого на печать листа Excel
Предварительный просмотр
Печать листа, выделенного диапазона или книги целиком

5.12. Примеры выполнения типовых задач

Пример 1. Выравнивание содержимого ячейки
Пример 2. Использование именованных блоков ячеек
Пример 3. Контроль ввода данных
Пример 4. Транспонирование блока ячеек
Пример 5. Связь копии с источником
Пример 6. Автозаполнение элементов списка
Пример 7. Прогрессии
Пример 8. Формулы. Расчет налога на добавленную стоимость

Пример 9. Мастер функций

Пример 10. Копирование и перемещение формул

Пример 11. Автосуммирование

Пример 12. Встроенные функции Microsoft Excel. Категория «Ссылки и массивы»

Пример 13. Встроенные функции Microsoft Excel. Категория «Текстовые функции»

Пример 14. Встроенные функции Microsoft Excel. Категория «Дата и время»

Пример 15. Встроенные функции Microsoft Excel. Категория «Математические»

Пример 16. Создание списков

Пример 17. Использование формы для работы со списками

Пример 18. Фильтрация списков. Автофильтр

Пример 19. Фильтрация списков. Расширенный фильтр

Пример 20. Промежуточные итоги

Пример 21. Создание сводных таблиц

Пример 22. Построение диаграмм

5.13. Практические задания

Задание 1

Задание 2

Задание 3

Задание 4

Задание 5

Задание 6

Задание 7

Задание 8

Задание 9

Задание 10

Задание 11

Задание 12

5.14. Контрольные вопросы

5.15. Глоссарий

5.16. Библиографический список

ТЕСТ

VI. ПОСТРОЕНИЕ ИНФОРМАЦИОННЫХ СИСТЕМ В СРЕДЕ Microsoft Access

Введение

6.1. Модели организации баз данных

6.2. Основные этапы разработки приложения

6.3. Стратегия разработки приложения
Данные и информация
Отбор необходимых данных
Нормализация

Чужие ключи

6.4. Архитектура Microsoft Access

6.5. Создание базы данных
Создание новой пустой таблицы

Типы данных

Импорт данных. Импорт текстового файла

Многотабличные базы данных. Отношения между таблицами

Создание связей между таблицами

6.6. Работа с данными при помощи запросов

Выбор данных из одной таблицы

Включение полей в запрос

Ввод условий отбора и выбор между AND и OR

Вычисляемые поля

Итоговые запросы

Перекрестные запросы
Модификация данных с помощью запросов на изменение.

Типовые ошибки и проблемы, возникающие при выполнении запросов на изменение

6.7. Построение и применение форм

Обзор форм

Конструктор форм

Панель элементов

6.8. Основные сведения об отчетах

Создание отчета

Разработка отчета в режиме конструктора

Сортировка и группировка информации

Задание условий группировки и сортировки

Задание диапазонов группировки

6.9. Автоматизация работы приложения с помощью макросов

Создание простого макроса

Проверка работы макроса

Создание сложного макроса

Группы макросов

Задание условий выполнения макрокоманд

6.10. Практические задания

Задание 1. База данных «Абитуриент»
Задание 2. База данных «Торговая организация»
Задание 3. База данных «Банк»
Задание 4. База данных «Страны Европы»
Задание 5. База данных «Библиотека»
Задание 6. База данных «Цементные заводы»
Задание 7. База данных «Служба занятости»
Задание 8. База данных «Железнодорожный вокзал»

6.11. Контрольные вопросы

6.12. Глоссарий

6.13. Библиографический список

ТЕСТ

VII. ВВЕДЕНИЕ В ЛОКАЛЬНЫЕ ВЫЧИСЛИТЕЛЬНЫЕ СЕТИ

Введение

7.1. Аппаратные средства ЛВС

7.2. Топология ЛВС

7.3. Принципы управления

7.4. Технология «клиент-сервер»

7.5. Программное обеспечение технологии «клиент-сервер»

7.6. Работа пользователя в сети

Сетевые возможности Windows 95

Вход в сеть

Настройка компьютера для работы в сети
Организация сетевого доступа к ресурсам компьютера

Отображение сетевого ресурса

Использование сетевого принтера

Разрешение вопросов, возникающих при работе в сети

7.7. Практические упражнения

Упражнение 1. Работа с Сетевым окружением
Упражнение 2. Копирование с сетевого ресурса
Упражнение 3. Организация сетевого доступа к ресурсу

7.8. Контрольные вопросы

7.9. Глоссарий

7.10. Библиографический список

ТЕСТ

VIII. ОСНОВЫ РАБОТЫ В ГЛОБАЛЬНОЙ СЕТИ Интернет

8.1. Интернет. Основные понятия

Программное обеспечение Интернет

8.2. Сервис World Wide Web (WWW) – всемирная паутина

8.3. Работа с Internet Explorer

Ввод URL в строке адреса
Переключение кодировок русского языка
Использование гиперссылок
Функции кнопок Вперед и Назад
Прекращение загрузки ненужной страницы
Использование кнопки Обновить
Выбор начальной страницы
Приемы навигации
Панель Журнала браузера Internet Explorer
Поиск в Интернет
Избранное
Сохранение, редактирование и печать страниц Web
Печать гипертекстовых страниц
Редактирование документов Web
Полезные настройки и разрешение проблем

8.4. Электронная почта (E-Mail)

Получение адреса электронной почты у провайдера
Бесплатная электронная почта
Правила подготовки письма
Правила использования кодировок шрифтов
Выражение эмоций в электронной почте

8.5. Работа с The Bat!

Введение
Начальная настройка почтового ящика
Пользовательский интерфейс The Bat!
Почтовые папки The Bat!
Получение входящей почты
Чтение пришедшей почты
Формирование нового сообщения
Пересылка вложенных файлов по E-mail
Ответы на пришедшие письма и их пересылка другим адресатам
Адресная книга The Bat!
О шифровании сообщений

8.6. Использование Outlook Express

Пользовательский интерфейс Outlook Express
Почтовые папки Outlook Express
Получение входящей почты
Чтение пришедшей почты
Подготовка и отправка писем электронной почты
Формирование нового сообщения
Пересылка вложенных файлов по E-mail
Ответы на пришедшие письма и их пересылка другим адресатам
Адресная книга Outlook Express

8.7. Другие сервисы Интернет

8.8. Практические упражнения

Упражнение 1. Поиск информации по ключевым словам
Упражнение 2. Использование папки Избранное
Упражнение 3. Загрузка файла из Интернета
Упражнение 4. Настройка отображения объектов
Упражнение 5. Создание учетной записи электронной почты
Упражнение 6. Отправка и получение сообщения электронной почты
Упражнение 7. Использование Адресной книги

8.9. Контрольные вопросы

8.10. Глоссарий

8.11. Библиографический список

ТЕСТ

IX. ИСПОЛЬЗОВАНИЕ СРЕДСТВ СЖАТИЯ ДАННЫХ

9.1. Основы архивации данных

Теоретические основы сжатия данных
Объекты сжатия
Обратимость сжатия
Алгоритмы обратимых методов
Алгоритм RLE
Программные средства сжатия данных

Базовые требования к диспетчерам архивов
Дополнительные требования к диспетчерам архивов

9.2. Практические упражнения

Упражнение 1. Просмотр архивного файла в формате .ZIP

Упражнение 2. Извлечение файлов из ZIP-архива

Упражнение 3. Создание ZIP-архива

Упражнение 4. Защита ZIP-архива
Упражнение 5. Создание самораспаковывающегося ZIP-архива
Упражнение 6. Создание самораспаковывающегося распределенного архива
Упражнение 7. Наблюдение интеграционных свойств программы WinZip

9.3. Контрольные вопросы

9.4. Глоссарий

ТЕСТ

X. ОСНОВЫ ЗАЩИТЫ КОМПЬЮТЕРНОЙ ИНФОРМАЦИИ

10.1. Понятие компьютерного преступления и защиты информации

10.2. Составы компьютерных преступлений

Неправомерный доступ к компьютерной информации (ст. 272 УК)
Создание, использование и распространение вредоносных программ для ЭВМ (ст. 273 УК)
Нарушение правил эксплуатации ЭВМ, системы ЭВМ или их сети (ст. 274. УК)

10.3. Объекты нападений компьютерных преступлений

10.4. Приемы компьютерных преступлений

Изъятие средств вычислительной техники
Перехват информации
Несанкционированный доступ
Разработка и распространение компьютерных вирусов

10.5. Предупреждение компьютерных преступлений

Правовые меры
Организационно-технические меры
Обзор наиболее распространенных антивирусных пакетов
Комплексные организационно-технические меры

10.6. Контрольные вопросы

10.7. Глоссарий

10.6. Библиографический список

ТЕСТ

XI. ОСНОВЫ АЛГОРИТМИЗАЦИИ И ПРОГРАММИРОВАНИЯ

11.1. Алгоритмы и способы их описания

Понятие алгоритма
Способы описания алгоритмов

Структурные схемы алгоритмов

11.2. Этапы подготовки и решения задач на ЭВМ

11.3. Компиляция и интерпретация программ

11.4. Стили программирования

Процедурное программирование

Функциональное программирование

Логическое программирование

Объектно-ориентированное программирование

11.5 Контрольные вопросы

11.6. Глоссарий

11.7. Библиографический список

ТЕСТ

XII. ЯЗЫК ПРОГРАММИРОВАНИЯ Паскаль

12.1. ОСНОВНЫЕ ПОНЯТИЯ

Основные понятия алгоритмического языка
Основные символы
Элементарные конструкции

12.2. ТИПЫ ДАННЫХ

Концепция типа для данных
Стандартные типы данных
Перечисляемый тип данных
Интервальный тип данных
Массивы
Строки
Множества
Записи
Указатели

12.3. КОНСТАНТЫ

12.4. ПЕРЕМЕННЫЕ. ИНИЦИАЛИЗАЦИЯ ПЕРЕМЕННЫХ

12.5. ВЫРАЖЕНИЯ

Битовая арифметика

12.6. ОПЕРАТОРЫ

Оператор присваивания
Операторы ввода и вывода
Условный оператор
Циклические конструкции в программах
Оператор варианта
Оператор перехода
Операторы выхода

12.7. СТРУКТУРА ПРОГРАММЫ

12.8. ПРОЦЕДУРЫ И ФУНКЦИИ

12.9. МОДУЛИ

12.10. ФАЙЛЫ

Текстовые файлы
Компонентные файлы
Бестиповые файлы
Последовательный и прямой доступ

12.11. ДИНАМИЧЕСКИЕ ПЕРЕМЕННЫЕ

12.12. ЭЛЕМЕНТЫ СТРУКТУРНОГО ПРОГРАММИРОВАНИЯ

12.13. ВВЕДЕНИЕ В ОБЪЕКТНО-ОРИЕНТИРОВАННОЕ ПРОГРАММИРОВАНИЕ

Объекты
Инкапсуляция
Наследование
Полиморфизм
Динамические объекты
Закрытие части объекта

12.14. Практические задачи на программирование

Задачи на программирование алгоритмов линейной структуры
Задачи на программирование алгоритмов ветвящейся структуры
Задачи на программирование алгоритмов циклической структуры
Задачи на использование одномерных массивов
Задачи на использование двумерных массивов
Задачи на обработку строк
Задачи на использование типа "запись"
Задачи на построение процедур и функций
Задачи на работу с файлами

12.15. Контрольные вопросы

12.16. Глоссарий

12.17. Библиографический список

ТЕСТ


Основы архивации данных

9.1. Основы архивации данных

Теоретические основы сжатия данных
Объекты сжатия
Обратимость сжатия
Алгоритмы обратимых методов
Алгоритм RLE
Программные средства сжатия данных

Базовые требования к диспетчерам архивов
Дополнительные требования к диспетчерам архивов

9.2. Практические упражнения

Упражнение 1. Просмотр архивного файла в формате .ZIP

Упражнение 2. Извлечение файлов из ZIP-архива

Упражнение 3. Создание ZIP-архива

Упражнение 4. Защита ZIP-архива
Упражнение 5. Создание самораспаковывающегося ZIP-архива
Упражнение 6. Создание самораспаковывающегося распределенного архива
Упражнение 7. Наблюдение интеграционных свойств программы WinZip

9.3. Контрольные вопросы

9.4. Глоссарий

СЛЕДУЮЩАЯ ГЛАВА
ПРЕДЫДУЩАЯ ГЛАВА
ОГЛАВЛЕНИЕ
ПОИСК
ПРЕДМЕТНЫЙ УКАЗАТЕЛЬ
ГЛОССАРИЙ УЧЕБНИКА
СОДЕРЖАНИЕ УЧЕБНИКА


Основы защиты информации

10.1. Понятие компьютерного преступления и защиты информации

10.2. Составы компьютерных преступлений

Неправомерный доступ к компьютерной информации (ст. 272 УК)
Создание, использование и распространение вредоносных программ для ЭВМ (ст. 273 УК)
Нарушение правил эксплуатации ЭВМ, системы ЭВМ или их сети (ст. 274. УК)

10.3. Объекты нападений компьютерных преступлений

10.4. Приемы компьютерных преступлений

Изъятие средств вычислительной техники
Перехват информации
Несанкционированный доступ
Разработка и распространение компьютерных вирусов

10.5. Предупреждение компьютерных преступлений

Правовые меры
Организационно-технические меры
Обзор наиболее распространенных антивирусных пакетов
Комплексные организационно-технические меры

10.6. Контрольные вопросы

10.7. Глоссарий

10.6. Библиографический список

СЛЕДУЮЩАЯ ГЛАВА
ПРЕДЫДУЩАЯ ГЛАВА
ОГЛАВЛЕНИЕ
ПОИСК
ПРЕДМЕТНЫЙ УКАЗАТЕЛЬ
ГЛОССАРИЙ УЧЕБНИКА
СОДЕРЖАНИЕ УЧЕБНИКА


Электронный учебник по информатике

5.1. Рабочая книга и листы

Общие сведения
Работа с листами
Одновременный просмотр нескольких книг
Одновременный просмотр различных частей листа

5.2. Ввод данных

Выделение ячеек на листе
Интерпретация данных
Ввод текста и чисел
Быстрое заполнение повторяющихся данных в столбце
Автозаполнение, основанное на смежных ячейках
Заполнение рядов чисел, дат и других элементов
Создание пользовательского списка или порядка сортировки
Проверка вводимых в ячейку данных

5.3. Изменение данных на листе

Изменение содержимого ячейки
Очистка ячейки
Перемещение и копирование ячеек
Изменение ширины столбца
Вставка строк и столбцов

5.4. Форматирование

Форматирование текста и размещение его внутри ячейки
Выделение данных, отвечающих определенным свойствам
Изменение способа отображения чисел, дат и времени
Отображение и скрытие нулевых значений и других данных
Использование рамок и фона в ячейках

5.5. Создание формул

Применение операторов в формулах
Порядок выполнения действий в формулах
Ссылки на ячейку или на группу ячеек
Ввод формулы
Использование функций
Категории функций Microsoft Excel
Ошибки в формулах
Использование имен

5.6. Проверка книг

Поиск зависимых и влияющих ячеек
Поиск некорректных значений на листе

5.7. Работа с диаграммами

Примеры типов диаграмм
Создание диаграммы
Изменение диаграммы

5.8. Управление списками

Рекомендации по созданию списка на листе книги
Сортировка данных в списке
Разрешение вопросов, возникающих при сортировке
Фильтрация списка с использованием автофильтра
Фильтрация списка с помощью расширенного фильтра

5.9. Подведение итогов данных

Суммирование значений в списке
Подведение промежуточных итогов
Подведение «вложенных» или многоуровневых итогов
Удаление промежуточных итогов

5.10. Сводные таблицы

Части сводной таблицы
Создание сводной таблицы
Изменение структуры сводной таблицы
Группировка данных в сводной таблице
Обработка данных сводной таблицы

5.11. Печать

Задание на листе области печати
Изменение макета выводимого на печать листа Excel
Предварительный просмотр
Печать листа, выделенного диапазона или книги целиком

5.12. Примеры выполнения типовых задач

Пример 1. Выравнивание содержимого ячейки
Пример 2. Использование именованных блоков ячеек
Пример 3. Контроль ввода данных
Пример 4. Транспонирование блока ячеек
Пример 5. Связь копии с источником
Пример 6. Автозаполнение элементов списка
Пример 7. Прогрессии
Пример 8. Формулы. Расчет налога на добавленную стоимость

Пример 9. Мастер функций

Пример 10. Копирование и перемещение формул

Пример 11. Автосуммирование

Пример 12. Встроенные функции Microsoft Excel. Категория «Ссылки и массивы»

Пример 13. Встроенные функции Microsoft Excel. Категория «Текстовые функции»

Пример 14. Встроенные функции Microsoft Excel. Категория «Дата и время»

Пример 15. Встроенные функции Microsoft Excel. Категория «Математические»

Пример 16. Создание списков

Пример 17. Использование формы для работы со списками

Пример 18. Фильтрация списков. Автофильтр

Пример 19. Фильтрация списков. Расширенный фильтр

Пример 20. Промежуточные итоги

Пример 21. Создание сводных таблиц

Пример 22. Построение диаграмм

5.13. Практические задания

Задание 1

Задание 2

Задание 3

Задание 4

Задание 5

Задание 6

Задание 7

Задание 8

Задание 9

Задание 10

Задание 11

Задание 12

5.14. Контрольные вопросы

5.15. Глоссарий

5.16. Библиографический список

СЛЕДУЮЩАЯ ГЛАВА
ПРЕДЫДУЩАЯ ГЛАВА
ОГЛАВЛЕНИЕ
ПОИСК
ПРЕДМЕТНЫЙ УКАЗАТЕЛЬ
ГЛОССАРИЙ УЧЕБНИКА
СОДЕРЖАНИЕ УЧЕБНИКА


Электронный учебник по информатике

2.1. Базовая аппаратная конфигурация

Системный блок
Материнская плата

Процессор
Шинные интерфейсы материнской платы
Оперативная память
Микросхема ПЗУ и система BIOS
Энергонезависимая память CMOS
Жесткий диск
Дисковод гибких дисков
Дисковод компакт-дисков CD-ROM
Видеокарта (видеоадаптер)
Звуковая карта
Монитор
Мониторы на электронно-лучевой трубке (CRT)
Мониторы на жидких кристаллах (LCD)
Клавиатура
Мышь

2.2. Периферийные устройства персонального компьютера

Устройства ввода графических данных
Устройства вывода данных
Устройства хранения данных
Устройства обмена данными

2.4. Контрольные вопросы

2.5. Глоссарий

2.6. Библиографический список

СЛЕДУЮЩАЯ ГЛАВА
ПРЕДЫДУЩАЯ ГЛАВА
ОГЛАВЛЕНИЕ
ПОИСК
ПРЕДМЕТНЫЙ УКАЗАТЕЛЬ
ГЛОССАРИЙ УЧЕБНИКА
СОДЕРЖАНИЕ УЧЕБНИКА


Электронный учебник по информатике

8.1. Интернет. Основные понятия

Программное обеспечение Интернет

8.2. Сервис World Wide Web (WWW) – всемирная паутина

8.3. Работа с Internet Explorer

Ввод URL в строке адреса
Переключение кодировок русского языка
Использование гиперссылок
Функции кнопок Вперед и Назад
Прекращение загрузки ненужной страницы
Использование кнопки Обновить
Выбор начальной страницы
Приемы навигации
Панель Журнала браузера Internet Explorer
Поиск в Интернет
Избранное
Сохранение, редактирование и печать страниц Web
Печать гипертекстовых страниц
Редактирование документов Web
Полезные настройки и разрешение проблем

8.4. Электронная почта (E-Mail)

Получение адреса электронной почты у провайдера
Бесплатная электронная почта
Правила подготовки письма
Правила использования кодировок шрифтов
Выражение эмоций в электронной почте

8.5. Работа с The Bat!

Введение
Начальная настройка почтового ящика
Пользовательский интерфейс The Bat!
Почтовые папки The Bat!
Получение входящей почты
Чтение пришедшей почты
Формирование нового сообщения
Пересылка вложенных файлов по E-mail
Ответы на пришедшие письма и их пересылка другим адресатам
Адресная книга The Bat!
О шифровании сообщений

8.6. Использование Outlook Express

Пользовательский интерфейс Outlook Express
Почтовые папки Outlook Express
Получение входящей почты
Чтение пришедшей почты
Подготовка и отправка писем электронной почты
Формирование нового сообщения
Пересылка вложенных файлов по E-mail
Ответы на пришедшие письма и их пересылка другим адресатам
Адресная книга Outlook Express

8.7. Другие сервисы Интернет

8.8. Практические упражнения

Упражнение 1. Поиск информации по ключевым словам
Упражнение 2. Использование папки Избранное
Упражнение 3. Загрузка файла из Интернета
Упражнение 4. Настройка отображения объектов
Упражнение 5. Создание учетной записи электронной почты
Упражнение 6. Отправка и получение сообщения электронной почты
Упражнение 7. Использование Адресной книги

8.9. Контрольные вопросы

8.10. Глоссарий

8.11. Библиографический список

СЛЕДУЮЩАЯ ГЛАВА
ПРЕДЫДУЩАЯ ГЛАВА
ОГЛАВЛЕНИЕ
ПОИСК
ПРЕДМЕТНЫЙ УКАЗАТЕЛЬ
ГЛОССАРИЙ УЧЕБНИКА
СОДЕРЖАНИЕ УЧЕБНИКА


Электронный учебник по информатике

1.1. Информация и формы ее представления

Понятие количества информации

1.2. Информационные процессы и технологии

1.3. ЭВМ как средство обработки информации

Понятие архитектуры ЭВМ
Классификация ЭВМ
Структура и принципы функционирования ЭВМ
Основные характеристики вычислительной техники
Перспективы развития вычислительных средств

1.4. Виды программного обеспечения ЭВМ

1.5. Операционная система MS-DOS

Основные составные части MS-DOS

Начальная загрузка MS-DOS

Файловая система MS-DOS

Файловая структура логического диска

1.6. Контрольные вопросы

1.7. Глоссарий

1.8. Библиографический список

СЛЕДУЮЩАЯ ГЛАВА
ОГЛАВЛЕНИЕ
ПОИСК
ПРЕДМЕТНЫЙ УКАЗАТЕЛЬ
ГЛОССАРИЙ УЧЕБНИКА
СОДЕРЖАНИЕ УЧЕБНИКА


Электронный учебник по информатике

Введение

7.1. Аппаратные средства ЛВС

7.2. Топология ЛВС

7.3. Принципы управления

7.4. Технология «клиент-сервер»

7.5. Программное обеспечение технологии «клиент-сервер»

7.6. Работа пользователя в сети

Сетевые возможности Windows 95

Вход в сеть

Настройка компьютера для работы в сети
Организация сетевого доступа к ресурсам компьютера

Отображение сетевого ресурса

Использование сетевого принтера

Разрешение вопросов, возникающих при работе в сети

7.7. Практические упражнения

Упражнение 1. Работа с Сетевым окружением
Упражнение 2. Копирование с сетевого ресурса
Упражнение 3. Организация сетевого доступа к ресурсу

7.8. Контрольные вопросы

7.9. Глоссарий

7.10. Библиографический список

СЛЕДУЮЩАЯ ГЛАВА
ПРЕДЫДУЩАЯ ГЛАВА
ОГЛАВЛЕНИЕ
ПОИСК
ПРЕДМЕТНЫЙ УКАЗАТЕЛЬ
ГЛОССАРИЙ УЧЕБНИКА
СОДЕРЖАНИЕ УЧЕБНИКА


Электронный учебник по информатике

ВВЕДЕНИЕ

I. ОСНОВНЫЕ ПОНЯТИЯ ОБ ИНФОРМАЦИИ И ИНФОРМАТИКЕ

>> теория

>> тест

II. УСТРОЙСТВО ПЕРСОНАЛЬНОГО КОМПЬЮТЕРА

>> теория

>> тест

III. ОСНОВЫ РАБОТЫ С ОПЕРАЦИОННОЙ СИСТЕМОЙ Windows 2000

>> теория

>> практика

>> тест

IV. ИСПОЛЬЗОВАНИЕ ТЕКСТОВОГО ПРОЦЕССОРА Microsoft Word ДЛЯ ПОДГОТОВКИ ДОКУМЕНТОВ

>> теория

>> практика

>> тест

V. ОБРАБОТКА ДАННЫХ СРЕДСТВАМИ Microsoft Excel

>> теория

>> практика

>> тест

VI. ПОСТРОЕНИЕ ИНФОРМАЦИОННЫХ СИСТЕМ В СРЕДЕ Microsoft Access

>> теория

>> практика

>> тест

VII. ВВЕДЕНИЕ В ЛОКАЛЬНЫЕ ВЫЧИСЛИТЕЛЬНЫЕ СЕТИ

>> теория

>> практика

>> тест

VIII. ОСНОВЫ РАБОТЫ В ГЛОБАЛЬНОЙ СЕТИ Интернет

>> теория

>> практика

>> тест

IX. ИСПОЛЬЗОВАНИЕ СРЕДСТВ СЖАТИЯ ДАННЫХ

>> теория

>> практика

>> тест

X. ОСНОВЫ ЗАЩИТЫ КОМПЬЮТЕРНОЙ ИНФОРМАЦИИ

>> теория

>> тест

XI. ОСНОВЫ АЛГОРИТМИЗАЦИИ И ПРОГРАММИРОВАНИЯ

>> теория

>> тест

XII. ЯЗЫК ПРОГРАММИРОВАНИЯ Паскаль

>> теория

>> практика

>> тест


Паскаль

12.1. ОСНОВНЫЕ ПОНЯТИЯ

Основные понятия алгоритмического языка
Основные символы
Элементарные конструкции

12.2. ТИПЫ ДАННЫХ

Концепция типа для данных
Стандартные типы данных
Перечисляемый тип данных
Интервальный тип данных
Массивы
Строки
Множества
Записи
Указатели

12.3. КОНСТАНТЫ

12.4. ПЕРЕМЕННЫЕ. ИНИЦИАЛИЗАЦИЯ ПЕРЕМЕННЫХ

12.5. ВЫРАЖЕНИЯ

Битовая арифметика

12.6. ОПЕРАТОРЫ

Оператор присваивания
Операторы ввода и вывода
Условный оператор
Циклические конструкции в программах
Оператор варианта
Оператор перехода
Операторы выхода

12.7. СТРУКТУРА ПРОГРАММЫ

12.8. ПРОЦЕДУРЫ И ФУНКЦИИ

12.9. МОДУЛИ

12.10. ФАЙЛЫ

Текстовые файлы
Компонентные файлы
Бестиповые файлы
Последовательный и прямой доступ

12.11. ДИНАМИЧЕСКИЕ ПЕРЕМЕННЫЕ

12.12. ЭЛЕМЕНТЫ СТРУКТУРНОГО ПРОГРАММИРОВАНИЯ

12.13. ВВЕДЕНИЕ В ОБЪЕКТНО-ОРИЕНТИРОВАННОЕ ПРОГРАММИРОВАНИЕ

Объекты
Инкапсуляция
Наследование
Полиморфизм
Динамические объекты
Закрытие части объекта

12.14. Практические задачи на программирование

Задачи на программирование алгоритмов линейной структуры
Задачи на программирование алгоритмов ветвящейся структуры
Задачи на программирование алгоритмов циклической структуры
Задачи на использование одномерных массивов
Задачи на использование двумерных массивов
Задачи на обработку строк
Задачи на использование типа "запись"
Задачи на построение процедур и функций
Задачи на работу с файлами

12.15. Контрольные вопросы

12.16. Глоссарий

12.17. Библиографический список

ПРЕДЫДУЩАЯ ГЛАВА
ОГЛАВЛЕНИЕ
ПОИСК
ПРЕДМЕТНЫЙ УКАЗАТЕЛЬ
ГЛОССАРИЙ УЧЕБНИКА
СОДЕРЖАНИЕ УЧЕБНИКА


Электронный учебник по информатике

3.1. Введение

3.2. Начало и завершение работы

Запуск Windows 2000 Professional
Аккуратный выход из Windows 2000 Professional
Запуск Windows 98
Завершение работы Windows 98

3.3. Интерфейс Windows 98/2000

Управление Windows
Рабочий стол

Стартовое меню

Панель задач
Окно Мой компьютер

Корзина

Контекстно-зависимые меню

Ярлыки
Структура окна в Windows
Длинные имена файлов
Преимущества использования длинных имен файлов
Расширения имен файлов

3.4. Программа Проводник

Запуск программы Проводник
Иерархическое дерево папок и устройств
Работа с содержимым окна программы Проводник
Кнопки Назад, Вперед и Вверх
Поиск папок и файлов в программе Проводник
Управление файлами
Отображение файлов и папок в окне программы Проводник
Отмена операций с файлами
Операции с файловой структурой
Маркирование объектов
Маркирование группы файлов
Маркирование всех файлов и папок
Копирование и перемещение объектов
Использование буфера обмена для работы с объектами
Удаление файлов
Восстановление удаленных файлов
Переименование объектов
Отмена выполненного действия
Создание новой папки
Открытие папок

3.5. Работа с приложениями

Типы приложений
Запуск приложений
Запуск приложений с помощью стартового меню
Запуск приложения, ярлык которого расположен на рабочем столе
Запуск приложений с помощью кнопок панели инструментов
Запуск приложения с помощью диалогового окна Выполнить
Поиск приложений
Запуск приложения, хранящегося на сетевом запоминающем устройстве
Запуск приложения с помощью окна Сеанс MS-DOS
Запуск резидентных программ
Запуск приложений с помощью программы Проводник
Завершение работы приложения

3.6. Работа Windows 98/2000 в многозадачном режиме

Работа с окнами
Как активизировать окно с помощью мыши
Различные способы расположения окон на рабочем столе
Панель задач

Что такое задача?

Работа с панелью задач
Перемещение панели задач
Изменение размеров панели задач
Конфигурирование панели задач
Переключение между программами с помощью клавиатуры

Многозадачность на практике

Работа с несколькими DOS-приложениями

3.7. Конфигурирование стартового меню

Добавление новых команд в стартовое меню
Перемещение команд в стартовом меню
Удаление команд из стартового меню
Изменение свойств стартового меню

3.8. Установка и удаление приложений Windows

Особенности спецификации Windows
Стандартное средство установки приложений
Удаление приложений Windows

3.9. Установка оборудования

Средства программной установки оборудования
Порядок установки оборудования

3.10. Настройка средств ввода-вывода данных

Настройка клавиатуры
Настройка мыши
Настройка стиля управления операционной системой

3.11. Настройка элементов оформления Windows 98/2000

Настройка фона Рабочего стола
Настройка экранной заставки
Настройка оформления элементов управления Windows
Дополнительные средства оформления Рабочего стола
Средства оформления Рабочего стола Active Desktop
Настройка параметров экрана
Настройка свойств видеоадаптера и монитора
Настройка звуковых схем
Оформление Windows 98 темами Рабочего стола
Настройка Главного меню
Настройка свойств Корзины
Настройка свойств окон папок
Настройка шрифтов
Растровые и векторные шрифты
Векторные шрифты True Type и PostScript
Системное средство установки и удаления шрифтов

3.12. Прочие настройки Windows

Настройка системных часов и системного календаря
Настройка системных часов и системного календаря

3.13. Справочная система Windows 98/2000

Справочная система в диалоговых окнах
Контекстная подсказка
Справочная система Windows

3.14. Стандартные приложения Windows 98/2000

Программа Блокнот
Графический редактор Paint
Текстовый процессор WordPad
Калькулятор

3.15. Служебные приложения Windows 98/2000

Архивация данных (Microsoft BackUp)

Буфер обмена

Дефрагментация диска

Индикатор системных ресурсов

Преобразование в FAT32

Проверка диска

Сведения о системе

Сжатие данных

Агент сжатия

Системный Монитор

Таблица символов

Утилита форматирования дискет

3.16. Стандартные средства мультимедиа

Регулятор громкости

Лазерный проигрыватель

Универсальный проигрыватель

Программа Звукозапись

3.17. Средства обеспечения совместимости с приложениями MS-DOS

Сеанс MS-DOS

Режим MS-DOS

Настройка свойств значка приложения MS-DOS

3.18. Практические упражнения по Windows

Упражнение 1. Отработка приемов управления с помощью мыши
Упражнение 2. Изучение приемов работы с объектами
Упражнение 3. Работа в файловой структуре в программе Проводник
Упражнение 4. Исследование методов запуска программы Проводник
Упражнение 5. Основы работы в текстовом редакторе Блокнот
Упражнение 6. Приемы работы с графическим редактором Paint
Упражнение 7. Приемы форматирования в текстовом процессоре WordPad

3.19. Контрольные вопросы

3.20. Глоссарий

3.21. Библиографический список


Электронный учебник по информатике

Введение

4.1. Возможности Word 2000

4.2. Запуск Microsoft Word

4.3.Структура окна MS Word
Строка заголовка
Строка меню
Панели инструментов
Настройка панелей инструментов
Вывод на экран/удаление с экрана панелей инструментов
Строка состояния
Описание элементов строки состояния
Назначение индикаторов строки состояния
Контекстное меню

4.4. Выход из MS Word

4.5. Справочная система Word 2000

Справка об объектах в главном окне MS Word

Справка об объектах окна диалога

4.6. Создание и сохранение документов в MS Word
Специальные средства ввода текста
Имена файлов
Папки
Создание документа
Создание пустого документа
Открытие существующего документа
Открытие файлов других форматов
Работа с несколькими документами
Сохранение документа
Автоматическое сохранение документов
Защита сохраненного документа с помощью пароля
Закрытие документа

4.7. Редактирование документа
Средства для представления документа на экране
Масштаб
Перемещение в документе

Перемещение с помощью полос прокрутки

Перемещение с помощью панели поиска

Перемещение с помощью окна диалога Найти и заменить
Перемещение с помощью клавишных команд
Перемещение с помощью схемы документа

4.8.Основные приемы редактирования

Выделение текста
Выделение текста с помощью мыши

Выделение текста с помощью клавиатуры

Удаление фрагмента документа
Перемещение и копирование фрагмента документа

Буфер обмена

Отмена результатов редактирования

4.9. Специальные средства редактирования
Использование поиска и замены
Проверка правописания

Автоматическая проверка правописания

Проверка уже введенного текста
Перенос слов
Автоматический перенос слов
Принудительное разделение слов при переносе

4.10. Форматирование символов
Шрифты
Использование окна диалога Шрифт
Использование панели инструментов Форматирование
Вкладка Интервал окна диалога Шрифт
Изменение регистра букв
Вставка символов
Копирование форматов символов

4.11. Форматирование строк и абзацев
Символ абзаца
Средства форматирования абзаца
Команда Абзац из меню Формат или контекстного меню
Средства панели инструментов Форматирование
Выравнивание абзацев
Табуляция
Удаление табуляции
Установка отступа
Установка расстояния перед абзацем и после него
Установка междустрочного интервала
Границы и заливка

4.12. Списки
Создание маркированных и нумерованных списков
Изменение формата маркированного списка
Изменение формата нумерованного списка
Создание многоуровневых списков

4.13. Использование стилей для форматирования документа
Установка стилей
Оглавление

4.14. Автоформат
Автоформатирование в процессе ввода текста
Автоформатирование уже введенного текста
Автоформатирование с помощью окна диалога Автоформат

4.15. Форматирование страниц документа
Разбивка документа на разделы
Определение размера и ориентации бумаги
Установка ширины полей
Установка точных размеров полей
Создание разворотов и полей под переплет
Установка ширины полей с помощью горизонтальной линейки
Колонтитулы
Создание разных колонтитулов для четных и нечетных страниц
Нумерация страниц
Вставка номеров страниц
Создание колонок

4.16. Работа с таблицами
Создание таблиц
Создание таблицы различными способами
Ввод данных и перемещение по таблице

Отражение и маскирование линий сетки

Вставка и удаление ячеек, строк и столбцов
Объединение и разбиение ячеек, создание заголовков
Настройка таблиц
Перемещение и копирование ячеек
Использование команды Таблица - Свойства таблицы
Автоматическая установка ширины столбцов и высоты строк
Форматирование таблиц
Изменение направления текста
Использование средства Автоформат
Выбор рамки и заполнения
Преобразование таблицы в текст
Преобразование текста в таблицу

4.17. Шаблоны
Шаблоны и документы
Замена шаблона
Перенос элементов одного шаблона в другой
Изменение шаблона
Создание собственного шаблона
Тема
Библиотека стилей

4.18. Создание и редактирование графических изображений
Вставка графических клипов
Импорт графических объектов из файлов
Создание графических объектов при помощи панели инструментов

4.19. Рисование
Работа с рисунком
Изменение размеров рисунков
Перемещение и копирование рисунков
Панель Настройка изображения
Вставка объектов WordArt
Ввод формул
Запуск и настройка редактора формул

4.20. Предварительный просмотр и печать документов
Предварительный просмотр перед печатью
Печать документа
Дополнительные опции печати
Печать неоткрытых документов
Печатать документа с помощью Проводника
Печать в файл

4.21. Основные принципы практической работы с текстовым процессором Microsoft Word

Задание 1

Задание 2
Задание 3
Задание 4
Задание 5
Задание 6
Задание 7
Задание 8
Задание 9
Задание 10
Задание 11
Задание 12
Задание 13
Задание 14
Задание 15
Зачетное задание

4.22. Контрольные вопросы

4.23. Глоссарий

4.24. Библиографический список

СЛЕДУЮЩАЯ ГЛАВА
ПРЕДЫДУЩАЯ ГЛАВА
ОГЛАВЛЕНИЕ
ПОИСК
ПРЕДМЕТНЫЙ УКАЗАТЕЛЬ
ГЛОССАРИЙ УЧЕБНИКА
СОДЕРЖАНИЕ УЧЕБНИКА


12.1. ОСНОВНЫЕ ПОНЯТИЯ

Основные понятия алгоритмического языка

Состав языка. Обычный разговорный язык состоит из четырех основных элементов: символов, слов, словосочетаний и предложений. Алгоритмический язык содержит подобные элементы, только слова называют элементарными конструкциями, словосочетания – выражениями, предложения – операторами. Символы, элементарные конструкции, выражения и операторы составляют иерархическую структуру, поскольку элементарные конструкции образуются из последовательности символов, выражения – это последовательность элементарных конструкций и символов, а оператор – последовательность выражений, элементарных конструкций и символов.

Описание языка есть описание четырех названных элементов. Описание символов заключается в перечислении допустимых символов языка. Под описанием элементарных конструкций понимают правила их образования. Описание выражений – это правила образования любых выражений, имеющих смысл в данном языке. Описание операторов состоит из рассмотрения всех типов операторов, допустимых в языке. Описание каждого элемента языка задается его синтаксисом и семантикой. Синтаксические определения устанавливают правила построения элементов языка. Семантика определяет смысл и правила использования тех элементов языка, для которых были даны синтаксические определения.

Символы языка – это основные неделимые знаки, в терминах которых пишутся все тексты на языке.

Элементарные конструкции – это минимальные единицы языка, имеющие самостоятельный смысл. Они образуются из основных символов языка.

Выражение в алгоритмическом языке состоит из элементарных конструкций и символов, оно задает правило вычисления некоторого значения.

Оператор задает полное описание некоторого действия, которое необходимо выполнить. Для описания сложного действия может потребоваться группа операторов. В этом случае операторы объединяются в составной оператор или блок.

Действия, заданные операторами, выполняются над данными. Предложения алгоритмического языка, в которых даются сведения о типах данных, называются описаниями или неисполняемыми операторами.

Объединенная единым алгоритмом совокупность описаний и операторов образует программу на алгоритмическом языке.

В процессе изучения алгоритмического языка необходимо отличать алгоритмический язык от того языка, с помощью которого осуществляется описание изучаемого алгоритмического языка. Обычно изучаемый язык называют просто языком, а язык, в терминах которого дается описание изучаемого языка – метаязыком.

Синтаксические определения могут быть заданы формальными или неформальным способами. Существуют три формальных способа:

  • металингвистическая символика, называемая Бэкуса - Наура формулами;
  • синтаксические диаграммы;
  • скобочные конструкции.

В последующем изложении будет использоваться неформальный способ.


Основные символы

Основные символы языка – буквы, цифры и специальные символы составляют его алфавит. Турбо Паскаль включает следующий набор основных символов:

1. 26 латинских строчных и 26 латинских прописных букв:

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

a b c d e f g h i j k l m n o p q r s t u v w x y z

2. Подчеркивание

3. 10 цифр:

0 1 2 3 4 5 6 7 8 9

4. Знаки операций:

+ - * / = <> < > <= >= := @

5. Ограничители:

. , ' () [ ] (. .) { } (* *) .. : ;

6. Спецификаторы:

^ # $

7. Служебные (зарезервированные) слова:

ABSOLUTE AND ARRAY ASM ASSEMBLER
BEGIN
CASE CONST CONSTRUCTOR
DESTRUCTOR DIV DO DOWNTO
ELSE END EXPORT EXPORTS EXTERNAL
FAR FILE FOR FORWARD FUNCTION
GOTO
IF IMPLEMENTATION IN INDEX INHERITED INLINE INTERFACE INTERRUPT
LABEL LIBRARY
MOD
NAME NEAR NIL NOT
OBJECT OF OR
PACKED PRIVATE PROCEDURE PROGRAM PUBLIC
RECORD REPEAT RESIDENT
SET SHL SHR STRING
THEN TO TYPE
UNIT UNTIL USES
VAR VIRTUAL
WHILE WITH
XOR

Кроме перечисленных, в набор основных символов входит пробел. Пробелы нельзя использовать внутри сдвоенных символов и зарезервированных слов.


Элементарные конструкции

Элементарные конструкции языка Паскаль включают в себя имена, числа и строки.

Именами (идентификаторами) называют элементы языка – константы, метки, типы, переменные, процедуры, функции, модули, объекты. Имя – это последовательность букв и цифр, начинающаяся с буквы. В именах может использоваться символ ‘_’ подчеркивание. Имя может содержать произвольное количество символов, но значащими являются 63 символа.

Не разрешается в языке Паскаль использовать в качестве имен служебные слова и стандартные имена, которыми названы стандартные константы, типы, процедуры, функции и файлы.

Для улучшения наглядности программы в нее могут вставляться пробелы. По крайней мере один пробел требуется вставить между двумя последовательными именами, числами или служебными и стандартными именами. Пробелы нельзя использовать внутри имен и чисел.

Примеры имен языка Паскаль:

A b12 r1m SIGMA gamma I80_86

Числа в языке Паскаль обычно записываются в десятичной системе счисления. Они могут быть целыми и действительными. Положительный знак числа может быть опущен. Целые числа записываются в форме без десятичной точки, например:

217 –45 8954 +483

Действительные числа записываются в форме с десятичной точкой или в форме с использованием десятичного порядка, который изображается буквой Е:

28.6 0.65 -0.018 4.0 5Е12 -1.72Е9 73.1Е-16

Паскаль допускает запись целых чисел и фрагментов действительных чисел в форме с порядком в шестнадцатеричной системе счисления:

$7F $40 $ABC0

Строки в языке Паскаль – это последовательность символов, записанная между апострофами. Если в строке в качестве содержательного символа необходимо употребить сам апостроф, то следует записать два апострофа. Примеры строк:

'СТРОКА' 'STRING' 'ПРОГРАММА' 'АД''ЮТАНТ'


12.2. ТИПЫ ДАННЫХ

Концепция типа для данных

В математике принято классифицировать переменные в соответствии с некоторыми важными характеристиками. Производится строгое разграничение между вещественными, комплексными и логическими переменными, между переменными, представляющими отдельные значения и множество значений и так далее.

При обработке данных на ЭВМ такая классификация еще более важна. В любом алгоритмическом языке каждая константа, переменная, выражение или функция бывают определенного типа.

В языке Паскаль существует правило: тип явно задается в описании переменной или функции, которое предшествует их использованию.

Концепция типа языка Паскаль имеет следующие основные свойства:

– любой тип данных определяет множество значений, к которому принадлежит константа, которые может принимать переменная или выражение, или вырабатывать операция или функция;
– тип значения, задаваемого константой, переменной или выражением, можно определить по их виду или описанию;
– каждая операция или функция требует аргументов фиксированного типа и выдает результат фиксированного типа.

Отсюда следует, что транслятор может использовать информацию о типах для проверки вычислимости и правильности различных конструкций.

Тип определяет:

– возможные значения переменных, констант, функций, выражений, принадлежащих к данному типу;
– внутреннюю форму представления данных в ЭВМ;
– операции и функции, которые могут выполняться над величинами, принадлежащими к данному типу.

Обязательное описание типа приводит к избыточности в тексте программ, но такая избыточность является важным вспомогательным средством разработки программ и рассматривается как необходимое свойство современных алгоритмических языков высокого уровня. В языке Паскаль существуют скалярные и структурированные типы данных.

К скалярным типам относятся стандартные типы и типы, определяемые пользователем.

Стандартные типы включают целые, действительные, символьный, логические и адресный типы.

Типы, определяемые пользователем, – перечисляемый и интервальный.

Структурированные типы имеют четыре разновидности: массивы, множества, записи и файлы.

Кроме перечисленных, Турбо Паскаль включает еще два типа – процедурный и объектный.

Из группы скалярных типов можно выделить порядковые типы, которые характеризуются следующими свойствами:

– все возможные значения порядкового типа представляют собой ограниченное упорядоченное множество;
– к любому порядковому типу может быть применена стандартная функция Ord, которая в качестве результата возвращает порядковый номер конкретного значения в данном типе;
– к любому порядковому типу могут быть применены стандартные функции Pred и Succ, которые возвращают предыдущее и последующее значения соответственно;
– к любому порядковому типу могут быть применены стандартные функции Low и High, которые возвращают наименьшее и наибольшее значения величин данного типа.

В языке Паскаль введены понятия эквивалентности и совместимости типов. Два типа Т1 и Т2 являются эквивалентными (идентичными), если выполняется одно из двух условий:

– Т1 и Т2 представляют собой одно и то же имя типа;
– тип Т2 описан с использованием типа Т1 с помощью равенства или последовательности равенств. Например:

Type
T1 = Integer;
T2 = T1;
T3 = T2;

Менее строгие ограничения определены совместимостью типов. Например, типы являются совместимыми, если:

– они эквивалентны;
– являются оба либо целыми, либо действительными;
– один тип - интервальный, другой – его базовый;
– оба интервальные с общим базовым;
– один тип - строковый, другой - символьный.

В Турбо Паскаль ограничения на совместимость типов можно обойти с помощью приведения типов. Приведение типов позволяет рассматривать одну и ту же величину в памяти ЭВМ как принадлежащую разным типам. Для этого используется конструкция

Имя_Типа (переменная или значение).

Например, Integer('Z') представляет собой значение кода символа 'Z' в двухбайтном представлении целого числа, а Byte(534) даст значение 22, поскольку целое число 534 имеет тип Word и занимает два байта, а тип Byte занимает один байт, и в процессе приведения старший байт будет отброшен.


Стандартные типы данных

К стандартным относятся целые, действительные, логические, символьный и адресный типы.

Целые типы определяют константы, переменные и функции, значения которых реализуются множеством целых чисел, допустимых в данной ЭВМ.

Тип | Диапазон значений | Требуемая память
Shortint | -128 .. 127 | 1 байт
Integer | -32768 .. 32767 | 2 байта
Longint | -2147483648 .. 2147483647 | 4 байта
Byte | 0 .. 255 | 1 байт
Word | 0 .. 65535 | 2 байта

Над целыми операндами можно выполнять следующие арифметические операции:

  • сложение +,

  • вычитание -,

  • умножение *,

  • деление div,

  • получение остатка от деления mod.

Результат арифметической операции над целыми операндами есть величина целого типа. Результат выполнения операции деления целых величин есть целая часть частного. Результат выполнения операции получения остатка от деления – остаток от деления целых. Например:

17 div 2 = 8, 3 div 5 = 0,
17 mod 2 = 1, 3 mod 5 = 3.

Операции отношения, примененные к целым операндам, дают результат логического типа TRUE или FALSE (истина или ложь).

В языке Паскаль имеются следующие операции отношения:

  • равенство =,

  • неравенство <>,

  • больше или равно >=,

  • меньше или равно <=,

  • больше >,

  • меньше < .

К аргументам целого типа применимы следующие стандартные (встроенные) функции, результат выполнения которых имеет целый тип:

Abs(X), Sqr(X), Succ(X), Pred(X),

и которые определяют соответственно абсолютное значение Х, Х в квадрате, Х+1, Х-1.

Следующая группа стандартных функций для аргумента целого типа дает действительный результат:

Sin(X), Cos(X), ArcTan(X), Ln(X), Exp(X), Sqrt(X).

Эти функции вычисляют синус, косинус и арктангенс угла, заданного в радианах, логарифм натуральный, экспоненту и корень квадратный соответственно.

Результат выполнения функции проверки целой величины на нечетность Odd(X) имеет значение истина, если аргумент нечетный, и значение ложь, если аргумент четный:

X=5 Odd(X)=TRUE, X=4 Odd(X)=FALSE.

Для быстрой работы с целыми числами определены процедуры:

Inc(X) <=> X:=X+1
Inc(X,N)<=> X:=X+N
Dec(X) <=> X:=X-1
Dec(X,N)<=> X:=X-N

Действительные типы определяют те данные, которые реализуются подмножеством действительных чисел, допустимых в данной ЭВМ.

Тип | Диапазон значений | Количество цифр мантиссы | Требуемая память (байт)
Real | 2.9e-39 ... 1.7e+38 | 11 | 6
Single | 1.5e-45 ... 3.4e+38 | 7 | 4
Double | 5.0e-324 ... 1.7e+308 | 15 | 8
Extended | 3.4e-4932 ... 1.1e+4932 | 19 | 10
Comp | -9.2e+18 ... 9.2e+18 | 19 | 8

Тип Real определен в стандартном Паскале и математическим сопроцессором не поддерживается.

Остальные действительные типы определены стандартом IEEE 457 и реализованы на всех современных компьютерах.

Для их использования при наличии сопроцессора или при работе на ЭВМ типа 80486 необходимо компилировать программу с ключом {$ N+}, а при отсутствии сопроцессора – с ключами {$N-,E+}.

Тип Comp хотя и относится к действительным типам, хранит только длинные целые значения.

Над действительными операндами можно выполнять следующие арифметические операции, дающие действительный результат:

сложение +, вычитание -, умножение *, деление /.

К величинам действительного типа применимы все операции отношения, дающие булевский результат.

Один из операндов, участвующих в этих операциях, может быть целым.

К действительным аргументам применимы функции, дающие действительный результат:

Abs(X), Sqr(X), Sin(X), Cos(X), ArcTan(X), Ln(X), Exp(X), Sqrt(X), Frac(X), Int(X), Pi.

Функция Frac(X) возвращает дробную часть X, функция Int(X) – целую часть X. Безаргументная функция Pi возвращает значение числа p действительного типа.

К аргументам действительного типа применимы также функции Trunc(X) и Round(X), дающие целый результат. Первая из них выделяет целую часть действительного аргумента путем отсечения дробной части, вторая округляет аргумент до ближайшего целого.

Логический тип (Boolean) определяет те данные, которые могут принимать логические значения TRUE и FALSE.

К булевским операндам применимы следующие логические операции:

not and or xor.

Логический тип определен таким образом, что FALSE < TRUE. Это позволяет применять к булевским операндам все операции отношения.

В Турбо Паскаль введены еще разновидности логического типа: ByteBool, WordBool и LongBool, которые занимают в памяти ЭВМ один, два и четыре байта соответственно.

Символьный тип (Char) определяет упорядоченную совокупность символов, допустимых в данной ЭВМ. Значение символьной переменной или константы – это один символ из допустимого набора.

Символьная константа может записываться в тексте программы тремя способами:

– как один символ, заключенный в апострофы, например:

'A' 'a' 'Ю' 'ю';

– с помощью конструкции вида #K, где K – код соответствующего символа, при этом значение K должно находиться в пределах 0…255;

– с помощью конструкции вида ^C, где C – код соответствующего управляющего символа, при этом значение C должно быть на 64 больше кода управляющего символа.

К величинам символьного типа применимы все операции отношения.

Для величин символьного типа определены две функции преобразования

Ord(C), Chr(K).

Первая функция определяет порядковый номер символа С в наборе символов, вторая определяет по порядковому номеру К символ, стоящий на К-м месте в наборе символов. Порядковый номер имеет целый тип.

К аргументам символьного типа применяются функции, которые определяют предыдущий и последующий символы:

Pred(C), Succ(C), Pred('F') = 'E', Succ('Y') = 'Z'.

При отсутствии предыдущего или последующего символов значение соответствующих функций не определено.

Для литер из интервала 'a'…'z' применима функция UpCase(C), которая переводит эти литеры в верхний регистр 'A'…'Z'.

Адресный тип (Pointer) определяет переменные, которые могут содержать значения адресов данных или фрагментов программы. Для хранения адреса требуются два слова (4 байта), одно из них определяет сегмент,
второе – смещение.

Работа с адресными переменными (указателями) будет рассмотрена позже, сейчас отметим, что для получения значения адреса какой-либо переменной введена унарная операция @.


Перечисляемый тип данных

Перечисляемый тип представляет собой ограниченную упорядоченную последовательность скалярных констант, составляющих данный тип. Значение каждой константы задается ее именем. Имена отдельных констант отделяются друг от друга запятыми, а вся совокупность констант, составляющих данный перечисляемый тип, заключается в круглые скобки.

Программист объединяет в одну группу в соответствии с каким-либо признаком всю совокупность значений, составляющих перечисляемый тип.

Например, перечисляемый тип Rainbow(РАДУГА) объединяет скалярные значения RED, ORANGE, YELLOW, GREEN, LIGHT_BLUE, BLUE, VIOLET (КРАСНЫЙ, ОРАНЖЕВЫЙ, ЖЕЛТЫЙ, ЗЕЛЕНЫЙ, ГОЛУБОЙ, СИНИЙ, ФИОЛЕТОВЫЙ). Перечисляемый тип Traffic_Light (СВЕТОФОР) объединяет скалярные значения RED, YELLOW, GREEN (КРАСНЫЙ, ЖЕЛТЫЙ, ЗЕЛЕНЫЙ).

Перечисляемый тип описывается в разделе описания типов, который начинается со служебного слова type, например:

type Rainbow = (RED, ORANGE, YELLOW, GREEN, LIGHT_BLUE, BLUE, VIOLET);

Каждое значение является константой своего типа и может принадлежать только одному из перечисляемых типов, заданных в программе. Например, перечисляемый тип Traffic_Light не может быть определен в одной программе с типом Rainbow, так как оба типа содержат одинаковые константы.

Описание переменных, принадлежащих к скалярным типам, которые объявлены в разделе описания типов, производится с помощью имен типов. Например:

type Traffic_Light= (RED, YELLOW, GREEN);
var Section: Traffic_Light;

Это означает, что переменная Section может принимать значения RED, YELLOW или GREEN.

Переменные перечисляемого типа могут быть описаны в разделе описания переменных, например:

var Section: (RED, YELLOW, GREEN);

При этом имена типов отсутствуют, а переменные определяются совокупностью значений, составляющих данный перечисляемый тип.

К переменным перечисляемого типа может быть применим оператор присваивания:

Section: = YELLOW;

Упорядоченная последовательность значений, составляющих перечисляемый тип, автоматически нумеруется, начиная с нуля и далее через единицу. Отсюда следует, что к перечисляемым переменным и константам могут быть применены операции отношения и стандартные функции Pred, Succ, Ord.

Переменные и константы перечисляемого типа не могут быть элементами списка ввода или вывода.


Интервальный тип данных

Отрезок любого порядкового типа может быть определен как интервальный или ограниченный тип. Отрезок задается диапазоном от минимального до максимального значения констант, разделенных двумя точками. В качестве констант могут быть использованы константы, принадлежащие к целому, символьному, логическому или перечисляемому типам. Скалярный тип, на котором строится отрезок, называется базовым типом.

Минимальное и максимальное значения констант называются нижней и верхней границами отрезка, определяющего интервальный тип. Нижняя граница должна быть меньше верхней. Например,

0..99
-128..127
RED..VIOLET

Над переменными, относящимися к интервальному типу, могут выполняться все операции и применяться все стандартные функции, которые допустимы для соответствующего базового типа.

При использовании в программах интервальных типов данных может осуществляться контроль за тем, чтобы значения переменных не выходили за границы, введенные для этих переменных в описании интервального типа.

Массивы

Массивы представляют собой ограниченную упорядоченную совокупность однотипных величин. Каждая отдельная величина называется компонентой массива. Тип компонент может быть любым, принятым в языке Паскаль, кроме файлового типа. Тип компонент называется базовым типом.

Описание типа массива задается следующим образом:

<имя_типа>=ARRAY [<сп.инд.типов> ] OF<тuп>

Здесь <имя muna> – правильный идентификатор; ARRAY, OF – зарезервированные слова (массив, из); <сп.инд.типов> – список из одного или нескольких индексных типов, разделенных запятыми; квадратные скобки, обрамляющие список, требование синтаксиса; <тип> - любой тип Турбо Паскаля. В качестве индексных типов в Турбо Паскале можно использовать любые порядковые типы, кроме LONGINT и типов-диапазонов с базовым типом LONGINT.

Например:

Var Massiv: array[1..100] of Real; {одномерный массив}
Matrix: array[1..N,1..M] of Real; {двумерный массив}

Вся совокупность компонент определяется одним именем. Для обозначения отдельных компонент используется конструкция, называемая переменной с индексом или с индексами:

A[5] S[k+1] B[3,5].

В качестве индекса может быть использовано выражение. Тип индексов может быть только интервальным или перечисляемым. Действительный и целый типы недопустимы. Индексы интервального типа, для которого базовым является целый тип, могут принимать отрицательные, нулевое и положительные значения.

В операторной части программы один массив может быть присвоен другому, если их типы идентичны, например:

R1:=Z.

Для ввода или вывода массива в список ввода или вывода помещается переменная с индексом, а операторы ввода или вывода выполняются в цикле.

При работе с двумерным массивом первый индекс определяет номер строки, второй – номер столбца. Двумерные массивы хранятся в памяти ЭВМ по строкам.

Инициализация массивов (присвоение начальных значений всем компонентам массивов) осуществляется двумя способами.

Первый способ – с использованием типизированных констант, например:

type Dim10= Array[1..10] of Real;
const raM10: Dim10 = ( 0, 2.1, 4, 5.65, 6.1, 6.7, 7.2, 8, 8.7,
  9.3);

При инициализации двумерных массивов значения компонент каждого из входящих в него одномерных массивов записываются в скобках:

type Dim3x2= Array[1..3,1..2] of Integer;
const
iaM3x2: Dim3x2= ( (1, 2)
(3, 4)
(5, 6));

Второй способ инициализации – использование разновидности процедуры FillChar:

FillChar( var V; NBytes: Word; B: Byte);

Эта процедура заполняет участок памяти однобайтовым значением. Например, для обнуления массива A[1..10] of Real можно записать:

FillChar(A, 40, 0); или FillChar(A, SizeOf(A), 0).


Строки

Особое место в языке Паскаль занимают массивы символов.

Стандартный Паскаль допускает два способа хранения символьных массивов в памяти ЭВМ: распакованный и упакованный. Распакованные массивы символов хранятся в памяти ЭВМ по одному символу в машинном слове, упакованные – по одному символу в байте. При описании упакованного массива символов используют служебное слово PACKED, например:

var MAS: Packed Array[1..20] of Char;

Описание распакованного массива символов имеет вид:

var M: Array[1..20] of char;

Для преобразования символьного массива из распакованной формы в упакованную и наоборот, из упакованной в распакованную, в язык Паскаль введены две стандартные функции Pack, UnPack.

Упакованный массив символов образует символьную строку. Символьная строка может быть либо строковой константой, либо строковой переменной. Строковая константа, или строка, представляет собой совокупность символов, заключенную в апострофы. Строка – это элементарная конструкция языка Паскаль. Строковые константы могут входить в состав выражений. Как и числовые константы, они могут быть описаны в разделе описания констант.

Строковые переменные – это одномерные упакованные массивы символов, для описания которых в Турбо Паскале введен тип String.

Например, если строка содержит до 30 символов, ее тип будет определен как

type s = String[30];

Длина строки не может содержать более чем 255 символов.

В Турбо Паскале определено понятие строки переменной длины, в этом случае ее описание задается как

type s = String;

Тип String без указания длины совместим со всеми типами строк.

Особенностью строковых переменных является то, что к ним можно обращаться как к скалярным переменным, так и к массивам. Во втором случае применяется конструкция "переменная с индексом", что обеспечивает доступ к отдельным символам строки. При этом нижняя граница индекса равна 1. Отдельный символ строки совместим с типом Char.

В памяти ЭВМ строка занимает количество байтов, на единицу большее ее длины. Нулевой байт строки содержит ее длину.

Для строк определены операции присваивания, слияния (конкатенации) и сравнения.

Для сравнения строк применяются все операции отношения. Сравнение строк происходит посимвольно, начиная с первого символа. Строки равны, если имеют одинаковую длину и посимвольно эквивалентны.

Строки могут быть элементами списка ввода – вывода, при этом записывается имя строки без индекса.

При вводе строковых переменных количество вводимых символов может быть меньше, чем длина строки. В этом случае вводимые символы размещаются с начала строки, а оставшиеся байты заполняются пробелами. Если количество вводимых символов превышает длину строки, лишние символы отбрасываются.

Инициализация строк может производиться как с помощью типизированных констант:

const sName: String[9]= 'IBM PC/AT';

так и с использованием второй разновидности функции FillChar:

FillChar(var V; NBytes: Word; C: Char).

Например:

FillChar(A, SizeOf(A), '0');

Для работы со строками в Турбо Паскаль включены процедуры и функции, которые обеспечивают редактирование и преобразование строк.


Множества

Понятие множества в языке Паскаль основывается на математическом представлении о множествах: это ограниченная совокупность различных элементов. Для построения конкретного множественного типа используется перечисляемый или интервальный тип данных. Тип элементов, составляющих множество, называется базовым типом.

Множественный тип описывается с помощью служебных слов Set of, например:

type M= Set of B;

Здесь М – множественный тип; В – базовый тип.

Пример описания переменной множественного типа:

type M= Set of 'A'..'D';
var MS: M;

Принадлежность переменных к множественному типу может быть определена прямо в разделе описания переменных:

var C: Set of 0..7;

Константы множественного типа записываются в виде заключенной в квадратные скобки последовательности элементов или интервалов базового типа, разделенных запятыми, например:

['A', 'C'] [0, 2, 7] [3, 7, 11..14].

Константа вида

[ ]

означает пустое подмножество.

Множество включает в себя набор элементов базового типа, все подмножества данного множества, а также пустое подмножество. Если базовый тип, на котором строится множество, имеет К элементов, то число подмножеств, входящих в это множество, равно 2 в степени К. Пусть имеется переменная Р интервального типа:

var P: 1..3;

Эта переменная может принимать три различных значения – либо 1, либо 2, либо 3. Переменная Т множественного типа

var T: Set of 1..3;

может принимать восемь различных значений:

[ ] [1,2] [1] [1,3] [2] [2,3] [3] [1,2,3]

Порядок перечисления элементов базового типа в константах безразличен.

Значение переменной множественного типа может быть задано конструкцией вида [T], где T – переменная базового типа.

К переменным и константам множественного типа применимы операции присваивания (:=), объединения (+), пересечения (*) и вычитания (-):

['A','B'] + ['A','D'] даст ['A','B','D']
['A'] * ['A','B','C'] даст ['A']
['A','B','C'] - ['A','B'] даст ['C'].

Результат выполнения этих операций есть величина множественного типа.

К множественным величинам применимы операции: тождественность (=), не тождественность (<>), содержится в (<=), содержит (>=). Результат выполнения этих операций имеет логический тип, например:

['A','B'] = ['A','C'] даст FALSE
['A','B'] <> ['A','C'] даст TRUE
['B'] <= ['B','C'] даст TRUE
['C','D'] >= ['A'] даст FALSE.

Кроме этих операций для работы с величинами множественного типа в языке Паскаль используется операция

in,

проверяющая принадлежность элемента базового типа, стоящего слева от знака операции, множеству, стоящему справа от знака операции. Результат выполнения этой операции – булевский. Операция проверки принадлежности элемента множеству часто используется вместо операций отношения, например:

A in ['A', 'B'] даст TRUE,
2 in [1, 3, 6] даст FALSE.

При использовании в программах данных множественного типа выполнение операций происходит над битовыми строками данных. Каждому значению множественного типа в памяти ЭВМ соответствует один двоичный разряд. Например, множество

['A','B','C','D']

представлено в памяти ЭВМ битовой строкой

1 1 1 1.

Подмножества этого множества представлены строками:

['A','B','D'] 1 1 0 1

['B','C'] 0 1 1 0

['D'] 0 0 0 1

Величины множественного типа не могут быть элементами списка ввода – вывода.

В каждой конкретной реализации транслятора с языка Паскаль количество элементов базового типа, на котором строится множество, ограничено. В Турбо Паскале количество базовых элементов не должно превышать 256.

Инициализация величин множественного типа производится с помощью типизированных констант:

const seLit: Set of 'A'..'D'= [];

Проиллюстрируем применение данных множественного типа на примере.

Пример. Составить программу, которая вырабатывает и выводит на экран дисплея наборы случайных чисел для игры в "Спортлото 5 из 36". Для заполнения каждой карточки спортлото необходимо получить набор из пяти псевдослучайных чисел. К этим числам предъявляются два требования:

– числа должны находиться в диапазоне 1…36;
– числа не должны повторяться.

Program Lotto;
Var
nb, k: Set of 1..36;
kol, l, i, n: Integer;

Begin
Randomize;
WriteLn('ВВЕДИ kol');
ReadLn(kol);
nb:=[1..36];
for i:=1 to kol do
begin
k:=[];
for l:=1 to 5 do
begin
repeat
n:=Random(36)
until (n in nb) and not (n in k);
k:=k+[n];
Write(n:4)
end;
WriteLn
end
End.


Записи

Запись представляет собой совокупность ограниченного числа логически связанных компонент, принадлежащих к разным типам. Компоненты записи называются полями, каждое из которых определяется именем.

Поле записи содержит имя поля, вслед за которым через двоеточие указывается тип этого поля. Поля записи могут относиться к любому типу, допустимому в языке Паскаль, за исключением файлового типа.

Структура объявления типа записи такова:

<имя_ типа> = RECORD <сп. полей> END

Здесь <имя типа> – правильный идентификатор; RECORD, END – зарезервированные слова (запись, конец); <сп.полей> – список полей; представляет собой последовательность разделов записи, между которыми ставится точка с запятой.

Описание записи в языке Паскаль осуществляется с помощью служебного слова RECORD, вслед за которым описываются компоненты записи. Завершается описание записи служебным словом END.

Например, записная книжка содержит фамилии, инициалы и номера телефона, поэтому отдельную строку в записной книжке удобно представить в виде следующей записи:

type Row=Record
FIO: String[20];
TEL: String[7]
end;
var str: Row;

Описание записей возможно и без использования имени типа, например:

var str: Record
FIO: String[20];
TEL: String[7]
end;

Обращение к записи в целом допускается только в операторах присваивания, где слева и справа от знака присваивания используются имена записей одинакового типа. Во всех остальных случаях оперируют отдельными полями записей. Чтобы обратиться к отдельной компоненте записи, необходимо задать имя записи и через точку указать имя нужного поля, например:

str.FIO, str.TEL

Такое имя называется составным. Компонентой записи может быть также запись, в таком случае составное имя будет содержать не два, а большее количество имен.

Обращение к компонентам записей можно упростить, если воспользоваться оператором присоединения with.

Он позволяет заменить составные имена, характеризующие каждое поле, просто на имена полей, а имя записи определить в операторе присоединения:

with M do OP;

Здесь М – имя записи, ОР – оператор, простой или составной. Оператор ОР представляет собой область действия оператора присоединения, в пределах которой можно не использовать составные имена.

Иногда содержимое отдельной записи зависит от значения одного из ее полей. В языке Паскаль допускается описание записи, состоящей из общей и вариантной частей. Вариантная часть задается с помощью конструкции

case P of,

где Р – имя поля из общей части записи. Возможные значения, принимаемые этим полем, перечисляются так же как и в операторе варианта. Однако вместо указания выполняемого действия, как это делается в операторе варианта, указываются поля варианта, заключенные в круглые скобки. Описание вариантной части завершается служебным словом end. Тип поля Р можно указать в заголовке вариантной части, например:

case P: Integer of

Инициализация записей осуществляется с помощью типизированных констант:

type RecType= Record
x,y: Word;
ch: Char;
dim: Array[1..3] of Byte
end;

const Rec: RecType= ( x: 127; y: 255; ch: 'A'; dim: (2, 4, 8));


Указатели

Операционная система MS – DOS все адресуемое пространство делит на сегменты. Сегмент – это участок памяти размером 64 кбайт. Для задания адреса необходимо определить адрес начала сегмента и смещение относительно начала сегмента.

В Турбо Паскале определен адресный тип Pointer – указатель.

Переменные типа Pointer

var p: Pointer;

содержат адрес какого-либо элемента программы и занимают 4 байта, при этом адрес хранится как два слова, одно из них определяет сегмент, второе – смещение.

Переменную типа указатель можно описать другим способом.

type NameType= ^T;
var p: NameType;

Здесь p – переменная типа указатель, связанная с типом Т с помощью имени типа NameType. Описать переменную типа указатель можно непосредственно в разделе описания переменных:

var p: ^T;

Необходимо различать переменную типа указатель и переменную, на которую этот указатель ссылается. Например, если p – ссылка на переменную типа Т, то p^ – обозначение этой самой переменной.

Для переменных типа указатель введено стандартное значение NIL, которое означает, что указатель не ссылается ни к какому объекту. Константа NIL используется для любых указателей.

Над указателями не определено никаких операций, кроме проверки на равенство и неравенство.

Переменные типа указатель могут быть записаны в левой части оператора присваивания, при этом в правой части может находиться либо функция определения адреса Addr(X), либо выражение @ X, где @ – унарная операция взятия адреса, X – имя переменной любого типа, в том числе процедурного.

Переменные типа указатель не могут быть элементами списка ввода-вывода.


12.3. КОНСТАНТЫ

Тип констант в языке Паскаль определяется по их виду: константы целого типа – это целые числа, не содержащие десятичной точки, константы действительного типа – действительные числа, логические константы – логические значения TRUE и FALSE, символьные константы – либо строки длиной в один символ, либо конструкции вида #K или ^K.

Являясь расширением стандартного Паскаля, Турбо Паскаль позволяет использовать выражения-константы. Выражение-константа представляет собой выражение, которое может вычисляться компилятором без необходимости выполнения программы. Приведем примеры выражений-констант:

256 - 1
(2.5 + 1) / (2.5 - 1)
'Borland' + '' + 'Pascal'
Chr(32)
Ord('Z') - Ord('A') + 1

Простейший случай выражения-константы представляет собой простая константа, например 100 или 'A'. В стандартном Паскале допускается использовать только простые константы. В Турбо Паскале разрешено использование выражений-констант.

Поскольку компилятор должен иметь возможность полностью вычислить выражение-константу во время компиляции, в качестве выражений-констант не допускается использовать следующие конструкции:

  1. Ссылки на переменные и типизированные константы (кроме констант в адресных выражениях).
  2. Вызовы функций (кроме тех, которые отмечены далее).
  3. Оператор получения адреса @ (кроме констант в адресных выражениях).

За исключением этих ограничений для выражений-констант соблюдаются те же синтаксические правила, что и для обычных выражений.

В выражениях-константах допускается использовать следующие стандартные функции:

Abs, Chr, Hi, High, Length, Lo, Low, Odd, Ord, Pred, Ptr, Round, SizeOf, Succ, Swap, Trunc.

Приведем некоторые примеры использования выражений-констант в описаниях констант:

const
Min = 0;
Max = 100;
Center = (Max - Min) div 2;
Beta = Chr(255);
NumChars = Ord('Z') - Ord('A') + 1;
Message = 'Out of memory';
ErrStr = 'Error:' + Message + '.';
ErrPos = 80 - Length(Error) div 2;
ErrAttr = Blink + Red * 16 + White;
Ln10 = 2.302585092994095684;
Ln10R = 1 / Ln10;
Numeric = ['0'..'9'];
Alpha = ['A'..'Z','a'..'z'];
AlphaNum = Alpha + Numeric;


12.4. ПЕРЕМЕННЫЕ. ИНИЦИАЛИЗАЦИЯ ПЕРЕМЕННЫХ

Тип переменных определяется пользователем в разделе описания переменных:

var
X,Y,Z: real;
I,J,K: integer;
Digit: 0..9;
C: Color;
Done,Error: boolean;
Operator: (plus, minus, times);
Hue1,Hue2: set of Color;
Today: Date;
Results: MeasureList;
P1,P2: Person;
Matrix: array[1..10,1..10] of Real;

Переменные, описанные вне процедуры и функции, называются глобальными переменными и располагаются в сегменте данных. Переменные, описанные в самой процедуре или функции, называются локальными переменными и располагаются в сегменте стека.

Тип, задаваемый для переменных, может быть идентификатором типа, который был ранее описан в разделе описания типов того же самого блока, или блока, в который входит данный блок, или модуля, или же этот тип может быть новым определением типа.

В настоящее время в профессиональном программировании принято записывать имена переменных с использованием так называемой венгерской нотации.

Венгерская нотация – это соглашение о наименованиях переменных и функций. Соглашение широко используется при программировании на языках Pascal, C и в среде Windows.

Венгерская нотация основывается на следующих принципах:

  • имена переменных и функций должны содержать префикс, описывающий их тип;
  • имена переменных и функций записываются полными словами или словосочетаниями или их сокращениями, но так, чтобы по имени можно было понять назначение переменной или действие, выполняемое функцией.

Префиксы записываются малыми буквами, первая буква каждого слова – заглавная, префиксы и слова записываются либо слитно, либо через символ _ (подчеркивание).

Для языка Паскаль могут быть рекомендованы следующие префиксы для скалярных переменных и функций:

Префикс | Тип
by | Byte
sh | Shortint
I | Integer
w | Word
l | Longint
r | Real
si | Single
d | Double
e | Extended
c | Comp
ch | Char
b | Boolean
p | Pointer
x,у | координаты символа или точки на экране

Для величин структурированного типа могут быть использованы следующие префиксы:

a – Array
s – String
sz - Stringz
se – Set
re – Record
f – File
t - Text

Например:
rV, arVector[1..20], sName, iCount.

В откомпилированной программе для всех переменных отведено место в памяти, и всем переменным присвоены нулевые значения.

Для задания начальных значений переменным (инициализации переменных) Турбо Паскаль позволяет присваивать начальные значения переменным одновременно с их описанием. Для этого используется конструкция имя переменной: тип = значение; которая должна быть размещена в разделе описания констант, например:

const rWeight: Real = 0.4;


12.5. ВЫРАЖЕНИЯ

Выражение состоит из констант, переменных, указателей функций, знаков операций и скобок. Выражение задает правило вычисления некоторого значения. Порядок вычисления определяется старшинством (приоритетом) содержащихся в нем операций. В языке Паскаль принят следующий приоритет операций:

1. Унарная операция not, унарный минус –, взятие адреса @. Например,

not Done { отрицание булевской переменной }
@Х { указатель на переменную }
-15 { константа со знаком }

2. Операции типа умножения: *, /, div, mod, and, shl, shr. Например,

Х * Y
Z / (1 - Z)
i mod j = i - (i div j) * j

3. Операции типа сложения: +, –, or, xor. Например,

Done or Error
(Х+Y+Z)

4. Операции отношения: =, <>, <, >, <= ,> =, in. Например,

(Х <= Y) and (Y < Z)

Выражения входят в состав многих операторов языка Паскаль, а также могут быть аргументами встроенных функций. Например,

SIN(Х/2) { вызов функции }
['0..'9','А'..'Z'] { описатель множества }
сhar(Digit+48) { назначение типа }

5.1. Битовая арифметика

Битовая или поразрядная арифметика введена в Турбо Паскале для обеспечения возможности работы с двоичными разрядами (битами). Операции битовой арифметики применимы только к целым типам.

Первая группа операций – логические операции not, and, or и xor.

Операция not является одноместной, она изменяет каждый бит целого числа на обратный.

Операции and, or и xor – двуместные, операнды этих операций – целые величины одинаковой длины. Операции выполняются попарно над всеми двоичными разрядами операндов.

Вторая группа операций – это операции сдвига влево shl и сдвига вправо shr:

I shl N
I shr N.

Эти операции сдвигают двоичную последовательность значения I влево или вправо на N двоичных разрядов. При этом биты, уходящие за пределы разрядной сетки, теряются, а освободившиеся двоичные разряды заполняются нулями. При сдвиге вправо отрицательных значений освободившиеся разряды заполняются единицами.


12.6. ОПЕРАТОРЫ

Оператор присваивания

Тип переменной и тип выражения должны совпадать кроме случая, когда выражение относится к целому типу, а переменная – к действительному. При этом происходит преобразование значения выражения к действительному типу. Приведем некоторые примеры операторов присваивания:

X := Y + Z;
Done := (I >= 1) and (I < 100);
Huel := [blue, Succ(C)];
I := Sqr(J) - I * K;

Операторы ввода и вывода

Рассмотрим организацию ввода и вывода данных с терминального устройства. Терминальное устройство – это устройство, с которым работает пользователь, обычно это экран (дисплей) и клавиатура.

Для ввода и вывода данных используются стандартные процедуры ввода и вывода Read и Write, оперирующие стандартными последовательными файлами INPUT и OUTPUT.

Эти файлы разбиваются на строки переменной длины, отделяемые друг от друга признаком конца строки. Конец строки задается нажатием клавиши ENTER.

Для ввода исходных данных используются операторы процедур ввода:

Read(A1,A2,...AK);
ReadLn(A1,A2,...AK);
ReadLn;

Первый из них реализует чтение К значений исходных данных и присваивание этих значений переменным А1, А2, ..., АК. Второй оператор реализует чтение К значений исходных данных, пропуск остальных значений до начала следующей строки, присваивание считанных значений переменным А1, А2, ..., АК. Третий оператор реализует пропуск строки исходных данных.

При вводе исходных данных происходит преобразование из внешней формы представления во внутреннюю, определяемую типом переменных. Переменные, образующие список ввода, могут принадлежать либо к целому, либо к действительному, либо к символьному типам. Чтение исходных данных логического типа в языке Паскаль недопустимо.

Операторы ввода при чтении значений переменных целого и действительного типа пропускают пробелы, предшествующие числу. В то же время эти операторы не пропускают пробелов, предшествующих значениям символьных переменных, так как пробелы являются равноправными символами строк. Пример записи операторов ввода:

var rV, rS: Real;
iW, iJ: Integer;
chC, chD: Char;

Read(rV, rS, iW, iJ);
Read(chC, chD);

Значения исходных данных могут отделяться друг от друга пробелами и нажатием клавиш табуляции и Enter.

Для вывода результатов работы программы на экран используются операторы:

Write(A1,A2,...AK);
WriteLn(A1,A2,...AK);
WriteLn;

Первый из этих операторов реализует вывод значений переменных А1, А2,..., АК в строку экрана. Второй оператор реализует вывод значений переменных А1, А2, ..., АК и переход к началу следующей строки. Третий оператор реализует пропуск строки и переход к началу следующей строки.

Переменные, составляющие список вывода, могут относиться к целому, действительному, символьному или булевскому типам. В качестве элемента списка вывода кроме имен переменных могут использоваться выражения и строки.

Вывод каждого значения в строку экрана происходит в соответствии с шириной поля вывода, определяемой конкретной реализацией языка.

Форма представления значений в поле вывода соответствует типу переменных и выражений: величины целого типа выводятся как целые десятичные числа, действительного типа – как действительные десятичные числа с десятичным порядком, символьного типа и строки – в виде символов, логического типа – в виде логических констант TRUE и FALSE.

Оператор вывода позволяет задать ширину поля вывода для каждого элемента списка вывода. В этом случае элемент списка вывода имеет вид А:К, где А – выражение или строка; К – выражение либо константа целого типа. Если выводимое значение занимает в поле вывода меньше позиций, чем К, то перед этим значением располагаются пробелы. Если выводимое значение не помещается в ширину поля К, то для этого значения будет отведено необходимое количество позиций. Для величин действительного типа элемент списка вывода может иметь вид А:К:М, где А – переменная или выражение действительного типа; К – ширина поля вывода; М – число цифр дробной части выводимого значения. К и М – выражения или константы целого типа. В этом случае действительные значения выводятся в форме десятичного числа с фиксированной точкой.

Пример записи операторов вывода:

var rA, rB: Real;
iP, iQ: Integer;
bR, bS: Boolean;
chT, chV, chU, chW: Char;

WriteLn(rA, rB:10:2);
WriteLn(iP, iQ:8);
WriteLn(bR, bS:8);
WriteLn(chT, chV, chU, chW);


Условный оператор

Операторы отношений сравнивают два значения, возвращая в результате булевское значение True или False. В Паскале реализуются операторы:

> – больше, чем;
>= – больше, чем или равно;
< – меньше,
= – равно;
<= – меньше, чем или равно;
<> – не равно;
in – является элементом.

Общий формат условного оператора:

if <условие> then <оператор1> else <оператор2>

где <условие> – любое булевское выражение (вырабатывающее в результате True или False); <оператор1> и <оператор2> – операторы Паскаля. Если выражение принимает значение True, то выполняется <оператор1>; в противном случае – <оператор2>.

Например:

if a > b then max := a else max := b;

Два важных момента, на которые следует обратить внимание при использовании if/then/else. Во-первых, оператор else не является обязательным, другими словами, допустимо использовать оператор if в следующем виде:

if выражение then оператор 1

В этом случае оператор 1 выполняется только тогда, когда выражение имеет значение True. В противном случае пропускается оператор 1 и выполняется следующий оператор. Во-вторых, если необходимо выполнить более одного оператора, в случае, когда выражение принимает значение, True или False, то следует использовать составной оператор. Составной оператор – это последовательность произвольных операторов программы, заключённая в операторные скобки – зарезервированные слова begin ... end.

Например:

if B = 0 then
Writeln('Деление на нуль невозможно.')
else begin
Ratio := A div B;
Writeln('Отношение =', Ratio)
end;

В Паскале есть четыре логических оператора – and, xor, or, not. Эти логические операторы работают с логическими значениями (True и False), позволяя комбинировать выражения отношений, булевские переменные и булевские выражения. Например:

if (a > b) and (a = 0) then writeln('a = ", a);
if (a > b) and (a = 0) then writeln('a = ", a);


Циклические конструкции в программах

Наряду с операторами (или группами операторов), которые могут выполняться в зависимости от каких-либо условий, существуют еще и операторы, которые могут выполняться несколько раз в одной и той же последовательности. Такой вид конструкции в программе известен как цикл.

Есть три основных типа циклов. Это цикл while ("пока"), цикл for ("для") и цикл repeat...until ("повторять ... пока").

Цикл с параметром. Цикл for является одним из основных видов циклов, которые имеются во всех универсальных языках программирования. Основная идея, заложенная в его функционирование, заключается в том, что операторы, находящиеся внутри цикла, выполняются фиксированное число раз, в то время как переменная цикла (известная еще как индексная переменная) пробегает определенный ряд значений.

Счетный оператор цикла FOR имеет такую структуру:

for <пар_цик> := <нач_знач> to <кон_знач> do <onepamop>

Здесь for, to, do – зарезервированные слова (для, до, выполнить);

<пар_цик> – параметр цикла – переменная типа INTEGER (точнее, любого порядкового типа); <нач_знач> – начальное значение – выражение того же типа; <кон_знач> – конечное значение – выражение того же типа; <оператор> – произвольный оператор Турбо Паскаля. При выполнении оператора FOR вначале вычисляется выражение <нач_зчач> и осуществляется присваивание <пар_цик>:=<нач_знач>. После этого циклически повторяется

– проверка условия <пар_цик> <= <кон_знач>; если условие не выполнено, оператор FOR завершает свою работу;
– выполнение оператора <оператор>;
– наращивание переменной <пар_цик> на единицу.

Пример использования массива и цикла for:

Const N=3;
Var
list: array [1..N] of integer;
i: integer;
Begin
list[1] := 421;
list[2] := 53;
list[3] := 1806;
writeln("Список чисел:");
for i:=1 to N do writeln(list[i]);
End.

Выражение list: array [1..N] of integer объявляет list как массив переменных типа integer c объемом памяти, выделяемым для трех целых переменных (так как N равен 3). К первой переменной массива можно обращаться как к list[1], второй – как к list[2] и третьей – как к list[3].

Оператор в теле цикла for обычно является одним из операторов программы, но может использоваться и составной оператор, заключенный в begin ... end.

Цикл с предусловием. Оператор цикла с предусловием, начинающийся с ключевого слова while, содержит в себе выражение, которое управляет повторным выполнением оператора (который может быть составным оператором). Выражение, с помощью которого осуществляется управление повторением оператора, должно иметь булевский тип. Вычисление его производится до того, как внутренний оператор будет выполнен. Внутренний оператор выполнятся повторно до тех пор, пока выражение принимает значение Тruе. Если выражение с самого начала принимает значение False, то оператор, содержащийся внутри оператора цикла с предусловием, не выполняется.

Оператор цикла с предусловием имеет следующую структуру:

while <условие> do <оператор>

где <условие> – выражение логического типа; <оператор> – произвольные операторы Паскаля. Если <условие> принимает значение True, то выполняется <оператор>; после чего вычисление выражения <условие> и его проверка повторяются.

Примерами операторов цикла с предусловием могут служить следующие операторы:

while Data[I] <> X do I := I + 1;

While I > 0 do begin
if Odd(I) then Z := Z * X;
I := I div 2;
X := Sqr(X);
end;

Цикл с постусловием. В операторе цикла с постусловием, начинающимся со слова repeat, выражение, которое управляет повторным выполнением последовательности операторов содержится внутри оператора repeat. Результат выражения должен быть булевского типа. Операторы, заключенные между ключевыми словами repeat и until, выполняются последовательно до тех пор, пока результат выражения не примет значение True. Последовательность операторов выполнится по край ней мере один раз, поскольку вычисление выражения производится после каждого выполнения последовательности операторов.

Оператор цикла repeat...until с постпроверкой условия имеет следующую структуру:

REPEAT <тело_цикла> UNTIL <условие>.

Здесь REPEAT, UNTIL – зарезервированные слова (повторять до тех пор пока не будет выполнено условие); <тело_цикла> – произвольная последовательность операторов Турбо Паскаля; <условие> – выражение логического типа.

Операторы <тело_цикла> выполняются хотя бы один раз, после чего вычисляется выражение <условие>: если его значение есть FALSE, операторы <тело_цикла> повторяются, в противном случае оператор REPEAT...UNTIL завершает свою работу.

Примеры оператора цикла с постусловием:

repeat
K := I mod J;
I := J;
J := K;
until J = 0;

repeat
Write('Введите значение (0..9):');
Readln(I);
until (I >= 0) and (I <= 9);

Операторы завершения цикла. Для всех операторов цикла выход из цикла осуществляется как вследствие естественного окончания оператора цикла, так и с помощью операторов перехода и выхода.

В версии Турбо Паскаль 7.0 определены стандартные процедуры Break и Continue. Процедура Break выполняет безусловный выход из цикла. Процедура Continue обеспечивает переход к началу новой итерации цикла.


Оператор варианта

Оператор варианта (casе) состоит из выражения (переключателя) и списка операторов, каждому из которых предшествует одна или более констант (они называются константами выбора) или ключевое слово else. Переключатель (селектор) должен иметь порядковый тип (размером в байт или слово). Таким образом, строковый тип и длинный целый тип являются недопустимыми типами переключателя. Все константы выбора должны быть уникальными и иметь порядковый тип, совместимый с типом переключателя.

Структура оператора выбора такова:

CASE <ключ_выбора> OF
<список_выбора>
ELSE <оператор>
END

Здесь CASE, OF, ELSE, END – зарезервированные слова (случай, из, иначе, конец); <ключ_выбора> – выражение любого порядкового типа; <список_выбора> – одна или более конструкций вида: <константа_выбора>: <оператор>; <константа_выбора> – константа того же типа, что и выражение <ключ_выбора>; < оператор> – произвольный оператор Турбо Паскаля.

Оператор выбора работает следующим образом. Вначале вычисляется значение выражения <ключ_выбора>, а затем в последовательности операторов <список_выбора> отыскивается такой, которому предшествует константа, равная вычисленному значению. Найденный оператор выполняется, после чего оператор выбора завершает свою работу. Если в списке выбора не будет найдена константа, соответствующая вычисленному значению ключа выбора, управление передается оператору, стоящему за словом ELSE.

Приведем некоторые примеры оператора варианта:

case Operator of
plus: X := X+Y;
minus: X := X-Y;
times: X := X*Y;
end;

case I of
0, 2, 4, 6, 8: Writeln('Четная цифра');
1, 3, 5, 7, 9: Writeln('Нечетная цифра');
10..100: Writeln('Между 10 и 100');
end;


Оператор перехода

Обычно операторы в программе выполняются в том порядке, в каком они записаны. Оператор перехода прерывает естественный порядок выполнения программы и указывает, что дальнейшее выполнение должно продолжаться, начиная с оператора, помеченного меткой, указанной в операторе перехода. Примеры записи оператора перехода:

goto 218; goto l1;

При использовании оператора перехода должны соблюдаться следующие правила:

1. Метка, которая указывается в операторе перехода, должна находиться в том же блоке или модуле, что и сам оператор перехода. Другими словами, не допускаются переходы из процедуры или функции или внутрь нее.

2. Переход извне внутрь структурного оператора (то есть переход на более глубокий уровень вложенности) может вызвать непредсказуемые эффекты, хотя компилятор не выдает сообщения об ошибке. Например, вы не должны переходить в тело цикла for.

Хорошая практика программирования требует минимального использования переходов.

Операторы выхода

Для завершения работы программ, процедур и функций без предварительного перехода по меткам к закрывающему end в Турбо Паскале введены процедуры Exit и Halt.

Вызов Exit завершает работу своего программного блока и передает управление вызывающей программе. Если Exit выполняется в подпрограмме, то выполнение этой подпрограммы прекратится, и далее будет выполняться следующий за вызовом этой подпрограммы оператор. Если Exit выполняется в основной программе, выход из нее будет эквивалентен ее нормальному завершению.

Вызов процедуры Halt, где бы она ни находилась, завершает работу программы и передает управление операционной системе.

Процедура Halt имеет структуру Halt(n), где n – код возврата, который может быть проанализирован операционной системой с помощью команды IF ERRORLEVEL. Значение n=0 соответствует нормальному завершению работы программы. Вызов процедуры Halt без параметра эквивалентен вызову Halt(0).


12.7. СТРУКТУРА ПРОГРАММЫ

Программа на языке Паскаль состоит из заголовка, разделов описаний и раздела операторов.

Заголовок программы содержит имя программы, например:

Program PRIM;

Описания могут включать в себя раздел подключаемых библиотек (модулей), раздел описания меток, раздел описания констант, раздел описания типов, раздел описания переменных, раздел описания процедур и функций.

Раздел описания модулей определяется служебным словом USES и содержит имена подключаемых модулей (библиотек) как входящих в состав системы Турбо Паскаль, так и написанных пользователем. Раздел описания модулей должен быть первым среди разделов описаний. Имена модулей отделяются друг от друга запятыми:

uses CRT, Graph;

Любой оператор в программе может быть помечен меткой. В качестве метки используются произвольные целые без знака, содержащие не более четырех цифр, либо имена. Метка ставится перед оператором и отделяется от него двоеточием. Все метки, используемые в программе, должны быть перечислены в разделе описания меток, например:

label 3, 471, 29, Quit;

Описание констант позволяет использовать имена как синонимы констант, их необходимо определить в разделе описаний констант:

const K= 1024; MAX= 16384;

В разделе описания переменных необходимо определить тип всех переменных, используемых в программе:

Var P,Q,R: Integer;
A,B: Char;
F1,F2: Boolean;

Описание типов, процедур и функций будет рассмотрено ниже. Отдельные разделы описаний могут отсутствовать, но следует помнить, что в Паскаль-программе должны быть обязательно описаны все компоненты программы.

Раздел операторов представляет собой составной оператор, который содержит между служебными словами

begin.......end

последовательность операторов. Операторы отделяются друг от друга символом ;.

Текст программы заканчивается символом точка.

Кроме описаний и операторов Паскаль-программа может содержать комментарии, которые представляют собой произвольную последовательность символов, расположенную между открывающей скобкой комментариев { и закрывающей скобкой комментариев }.

Текст Паскаль-программы может содержать ключи компиляции, которые позволяют управлять режимом компиляции. Синтаксически ключи компиляции записываются как комментарии. Ключ компиляции содержит символ $ и букву-ключ с последующим знаком + (включить режим) или – (выключить режим). Например:

{$E+} – эмулировать математический сопроцессор;
{$F+} – формировать дальний тип вызова процедур и функций;
{$N+} – использовать математический сопроцессор;
{$R+} – проверять выход за границы диапазонов.

Некоторые ключи компиляции могут содержать параметр, например:

{$I имя файла} – включить в текст компилируемой программы названный файл.

Пример записи простой программы:

Program TRIANG; { вычисление площади треугольника }
Var A, B, C, S, P: Real;
begin
Read(A,B,C);
WriteLn(A,B,C);
P:=(A+B+C)/2;
S:=Sqrt(P*(P-A)*(P-B)*(P-C));
WriteLn('S=',S:8:3)
end.


12.8. ПРОЦЕДУРЫ И ФУНКЦИИ

Алгоритм решения задачи проектируется путем декомпозиции всей задачи в отдельные подзадачи. Обычно подзадачи реализуются в виде подпрограмм.

Подпрограмма – это последовательность операторов, которые определены и записаны только в одном месте программы, однако их можно вызвать для выполнения из одной или нескольких точек программы. Каждая подпрограмма определяется уникальным именем. В языке Паскаль существуют два типа подпрограмм – процедуры и функции.

Процедура и функция – это именованная последовательность описаний и операторов. При использовании процедур или функций Паскаль-программа должна содержать текст процедуры или функции и обращение к процедуре или функции. Тексты процедур и функций помещаются в раздел описаний процедур и функций.

Процедура может содержать такие же разделы описаний, что и Паскаль-программа, а именно: разделы описания модулей, меток, констант, типов, переменных, процедур и функций. В заголовке функции определяется идентификатор функции, формальные параметры (если они имеются) и тип результата функции.

Приведем примеры описания процедуры и функции:

procedure NumString(N: integer; var S: string);
var V: integer;
begin
V := Abs(N);
S := ' ';
repeat
S := Chr(N mod 10 + Ord('0')) + S;
N := N div 10;
until N = 0;
if N < 0 then S := '-' + S;
end;

function Max(a: Vector; n: integer): real;
var x: real; i: integer;
begin
x := a[1];
for i := 2 to n do if x < a[i] then x := a[i];
Max := x;
end;

Процедура активизируется с помощью оператора процедуры, в котором содержатся имя процедуры и необходимые параметры. Операторы, которые должны выполняться при запуске процедуры, содержатся в операторной части модуля процедуры. Если в содержащемся в процедуре операторе внутри модуля процедуры используется идентификатор процедуры, то процедура будет выполняться рекурсивно (будет при выполнении обращаться сама к себе).

Пример вызова процедуры и функции:

NumString(25432, str);
rMax := Max(rV, 10);

Передача имен процедур и функций в качестве параметров. Во многих задачах, особенно в задачах вычислительной математики, необходимо передавать имена процедур и функций в качестве параметров. Для этого в Турбо Паскаль введен новый тип данных – процедурный или функциональный, в зависимости оттого, что описывается.

Описание процедурных и функциональных типов производится в разделе описания типов:

type
FuncType = Function(z: Real): Real;
ProcType = Procedure (a,b: Real; var x,y: Real);

Функциональный и процедурный тип определяется как заголовок процедуры и функции со списком формальных параметров, но без имени. Можно определить функциональный или процедурный тип без параметров, например:

type Proc = Procedure;

После объявления процедурного или функционального типа его можно использовать для описания формальных параметров – имен процедур и функций.

Кроме того, необходимо написать те реальные процедуры или функции, имена которых будут передаваться как фактические параметры. Эти процедуры и функции должны компилироваться в режиме дальней адресации с ключом {$F+}.

Пример. Составить программу для вычисления определенного интеграла

по методу Симпсона. Вычисление подынтегральной функции реализовать с помощью функции, имя которой передается как параметр. Значение определенного интеграла по формуле Симпсона вычисляется следующим образом:

ISimps=2*h/3*(0.5*F(A)+2*F(A+h)+F(A+2*h)+2*F(A+3*h)+2*F(B-h)+0.5*F(B))

где A и B – нижняя и верхняя границы интервала интегрирования; N – число разбиений интервала интегрирования; h=(B-A)/N, причем N должно быть четным.

Program INTEGRAL;
Type Func= function(x: Real): Real;
Var I,TN,TK:Real;
N:Integer;
{$F+}
Function Q(t: Real): Real;
begin
Q:=2*t/Sqrt(1-Sin(2*t));
end;
{$F-}
Procedure Simps(F:Func; a,b:Real; N:Integer;
var INT:Real);
Var sum, h: Real;
j:Integer;
Begin
if Odd(N) then N:=N+1;
h:=(b-a)/N;
sum:=0.5*(F(a)+F(b));
for j:=1 to N-1 do sum:=sum+(j mod 2+1)*F(a+j*h);
INT:=2*h*sum/3
End;

Begin
WriteLn('Введите TN,TK,N ->');
Read(TN,TK,N);
Simps(Q,TN,TK,N,I);
WriteLn('I=',I:8:3)
End.


12.9. МОДУЛИ

Модуль (UNIT) в Турбо Паскале – это особым образом оформленная библиотека подпрограмм. Модуль в отличие от программы не может быть запущен на выполнение самостоятельно, он может только участвовать в построении программ и других модулей.

Модули позволяют создавать личные библиотеки процедур и функций и строить программы практически любого размера.

Модуль в Турбо Паскале представляет собой отдельно хранимую и независимо компилируемую программную единицу.

В общем случае модуль – это совокупность программных ресурсов, предназначенных для использования другими программами. Под программными ресурсами понимаются любые элементы языка Турбо Паскаль: константы, типы, переменные, подпрограммы. Модуль сам по себе не является выполняемой программой, его элементы используются другими программными единицами.

Все программные элементы модуля можно разбить на две части:

– программные элементы, предназначенные для использования другими программами или модулями, такие элементы называют видимыми вне модуля;
– программные элементы, необходимые только для работы самого модуля, их называют невидимыми или скрытыми.

В соответствии с этим модуль, кроме заголовка, содержит две основные части, называемые интерфейсом и реализацией.

В общем случае модуль имеет следующую структуру:

unit <имя модуля>; {заголовок модуля}
interface
 { описание видимых программных элементов модуля }
{ описание скрытых программных элементов модуля }
begin
 { операторы инициализации элементов модуля }
end.

В частном случае модуль может не содержать части реализации и части инициализации, тогда структура модуля будет такой:

unit <имя модуля>; {заголовок модуля}
interface
{ описание видимых программных элементов модуля }
implementation

end.

Использование в модулях процедур и функций имеет свои особенности. Заголовок подпрограммы содержит все сведения, необходимые для ее вызова: имя, перечень и тип параметров, тип результата для функций, эта информация должна быть доступна для других программ и модулей. С другой стороны, текст подпрограммы, реализующий ее алгоритм, другими программами и модулями не может быть использован. Поэтому заголовок процедур и функций помещают в интерфейсную часть модуля, а текст – в часть реализации.

Интерфейсная часть модуля содержит только видимые (доступные для других программ и модулей) заголовки процедур и функций (без служебного слова forward). Полный текст процедуры или функции помещают в часть реализации, причем заголовок может не содержать список формальных параметров.

Исходный текст модуля должен быть откомпилирован с помощью директивы Make подменю Compile и записан на диск. Результатом компиляции модуля является файл с расширением TPU (Turbo Pascal Unit). Основное имя модуля берется из заголовка модуля.

Для подключения модуля к программе необходимо указать его имя в разделе описания модулей, например:

uses CRT, Graph;

В том случае, если имена переменных в интерфейсной части модуля и в программе, использующей этот модуль, совпадают, обращение будет происходить к переменной, описанной в программе. Для обращения к переменной, описанной в модуле, необходимо применить составное имя, состоящее из имени модуля и имени переменной, разделенных точкой.

Например, пусть имеется модуль, в котором описана переменная К:

unit M;
interface
var K: Integer;
implementation
..................
end.

Пусть программа, использующая этот модуль, также содержит переменную К:

Program P;
uses M;
var K: Char;
begin
..................
end.

Для того, чтобы в программе P иметь доступ к переменной K из модуля M, необходимо задать составное имя M.K.

Использование составных имен применяется не только к именам переменных, а ко всем именам, описанным в интерфейсной части модуля.

Рекурсивное использование модулей запрещено.

Если в модуле имеется раздел инициализации, то операторы из этого раздела будут выполнены перед началом выполнения программы, в которой используется этот модуль.


12.10. ФАЙЛЫ

Введение файлового типа в язык Паскаль вызвано необходимостью обеспечить возможность работы с периферийными (внешними) устройствами ЭВМ, предназначенными для ввода, вывода и хранения данных.

Файловый тип данных или файл определяет упорядоченную совокупность произвольного числа однотипных компонент.

Общее свойство массива, множества и записи заключается в том, что количество их компонент определено на этапе написания программы, тогда как количество компонент файла в тексте программы не определяется и может быть произвольным.

Понятие файла достаточно широко. Это может быть обычный файл на диске, коммуникационный порт ЭВМ, устройство печати, клавиатура или другие устройства.

При работе с файлами выполняются операции ввода – вывода. Операция ввода означает перепись данных с внешнего устройства (из входного файла) в основную память ЭВМ, операция вывода – это пересылка данных из основной памяти на внешнее устройство (в выходной файл).

Файлы на внешних устройствах часто называют физическими файлами. Их имена определяются операционной системой. В программах на языке Паскаль имена файлов задаются с помощью строк. Например, имя файла на диске может иметь вид:

'A:LAB1.DAT'
'c:\ABC150\pr.pas'
'lab3.pas'.

Операционная система MS-DOS не делает особого различия между файлами на дисках и лентах и устройствами ЭВМ и портами коммуникаций. В Турбо Паскале могут использоваться имена устройств и портов, определенные в MS-DOS, например:

'CON', 'LPT1', 'PRN', 'COM1', 'AUX', 'NUL'.

С файловой системой связано понятие буфера ввода-вывода. Ввод и вывод данных осуществляется через буфер. Буфер – это область в памяти, которая выделяется для каждого файла. При записи в файл вся информация сначала направляется в буфер и там накапливается до тех пор, пока весь объем буфера не будет заполнен. Только после этого или после специальной команды сброса происходит передача данных на внешнее устройство. При чтении из файла данные вначале считываются в буфер, причем данных считывается не столько, сколько запрашивается, а сколько поместится в буфер.

Механизм буферизации позволяет более быстро и эффективно обмениваться информацией с внешними устройствами.

Для работы с файлами в программе необходимо определить файловую переменную. Турбо Паскаль поддерживает три файловых типа: текстовые файлы, компонентные файлы, бестиповые файлы.

Описание файловых переменных текстового типа производится с помощью служебного слова Text, например:

var tStory: Text;

Описание компонентных файлов имеет вид:

var fComp: File of T;

где T – тип компоненты файла. Примеры описания файловой переменной компонентного типа:

type M= array[1..500] of Longint;
var f1: File of Real;
f2: File of Integer;
fLi: File of M;

Бестиповые файлы описываются с помощью служебного слова File:

var f: File;

Файловые переменные, которые описаны в программе, называют логическими файлами. Все основные процедуры и функции, обеспечивающие ввод-вывод данных, работают только с логическими файлами. Физический файл должен быть связан с логическим до выполнения процедур открытия файлов.

Турбо Паскаль вводит ряд процедур и функций, применимых для любых типов файлов:

Assign, Reset, Rewrite, Close, Rename, Erase, Eof, IOResult.

Процедура Assign (var f; FileName: String) связывает логический файл f с физическим файлом, полное имя которого задано в строке FileName.

Процедура Reset (var f) открывает логический файл f для последующего чтения данных или, как говорят, открывает входной файл. После успешного выполнения процедуры Reset файл готов к чтению из него первого элемента.

Процедура Rewrite (var f) открывает логический файл f для последующей записи данных (открывает выходной файл). После успешного выполнения этой процедуры файл готов к записи в него первого элемента.

Процедура Close (var f) закрывает открытый до этого логический файл. Вызов процедуры Close необходим при завершении работы с файлом. Если по какой-то причине процедура Close не будет выполнена, файл все же будет создан на внешнем устройстве, но содержимое последнего буфера в него не будет перенесено. Для входных файлов использование оператора закрытия файла необязательно.

Логическая функция EOF (var f): Boolean возвращает значение TRUE, когда при чтении достигнет конца файла. Это означает, что уже прочитан последний элемент в файле или файл после открытия оказался пуст.

Процедура Rename (var f; NewName: String) позволяет переименовать физический файл на диске, связанный с логическим файлом f. Переименование возможно после закрытия файла.

Процедура Erase( var f) уничтожает физический файл на диске, который был связан с файловой переменной f. Файл к моменту вызова процедуры Erase должен быть закрыт.

Функция IOResult: Integer возвращает целое число, соответствующее коду последней ошибки ввода-вывода. При нормальном завершении операции функция вернет значение 0. Значение функции IOResult необходимо присваивать какой-либо переменной, так как при каждом вызове функция обнуляет свое значение. Функция IOResult работает только при выключенном режиме проверок ошибок ввода-вывода или с ключом компиляции {$I-}.


Текстовые файлы

Особое место в языке Паскаль занимают текстовые файлы, компоненты которых имеют символьный тип. Для описания текстовых файлов в языке определен стандартный тип Тext:

var TF1, TF2: Text;

Текстовые файлы представляют собой последовательность строк, а строки – последовательность символов. Строки имеют переменную длину, каждая строка завершается признаком конца строки.

С признаком конца строки связана функция EOLn(var T:Text):Boolean, где Т – имя текстового файла. Эта функция принимает значение TRUE, если достигнут конец строки, и значение FALSE, если конец строки не достигнут.

Для операций над текстовыми файлами, кроме перечисленных, определены также операторы обращения к процедурам:

ReadLn (T) – пропускает строку до начала следующей;

WriteLn (T) – завершает строку файла, в которую производится запись, признаком конца строки и переходит к началу следующей.

Для работы с текстовыми файлами введена расширенная форма операторов ввода и вывода. Оператор

Read(T,X1,X2,...XK)

эквивалентен группе операторов

begin
Read(T,X1);
Read(T,X2);
Read(T,XK)
end;

Здесь Т – текстовый файл, а переменные Х1, Х2,...ХК могут быть либо переменными целого, действительного или символьного типа, либо строкой. При чтении значений переменных из файла они преобразуются из текстового представления в машинное.

Оператор

Write(T,X1,X2,...XK);

эквивалентен группе операторов

begin
Write(T,X1);
Write(T,X2);
Write(T,XK)
end;

Здесь Т – также текстовый файл, но переменные Х1, Х2, ..., ХК могут быть целого, действительного, символьного, логического типа или строкой. При записи значений переменных в файл они преобразуются из внутреннего представления в текстовый.

К текстовым файлам относятся стандартные файлы INPUT, OUTPUT.

Рассмотренные ранее операторы ввода – вывода являются частным случаем операторов обмена с текстовыми файлами, когда используются стандартные файлы ввода-вывода INPUT, OUTPUT.

Работа с этими файлами имеет особенности:

– имена этих файлов в списках ввода-вывода не указываются;
– применение процедур Reset, Rewrite и Close к стандартным файлам ввода-вывода запрещено;
– для работы с файлами INPUT, OUTPUT введена разновидность функции EOLn без параметров.
– Турбо Паскаль вводит дополнительные процедуры и функции, применимые только к текстовым файлам, это SetTextBuf, Append, Flush, SeekEOLn, SeekEOF.

Процедура SetTextBuf (var f: Text; var Buf; BufSize: Word) служит для увеличения или уменьшения буфера ввода-вывода текстового файла f. Значение размера буфера для текстовых файлов по умолчанию равно 128 байтам. Увеличение размера буфера сокращает количество обращений к диску. Рекомендуется изменять размер буфера до открытия файла. Буфер файла начнется с первого байта переменной Buf. Размер буфера задается в необязательном параметре BufSize, а если этот параметр отсутствует, размер буфера определяется длиной переменной Buf.

Процедура Append (var f: Text) служит для специального открытия выходных файлов. Она применима к уже существующим физическим файлам и открывает их для дозаписи в конец файла.

Процедура Flush (var f: Text) применяется к открытым выходным файлам. Она принудительно записывает данные из буфера в файл независимо от степени его заполнения.

Функция SeekEOLn (var f: Text): Boolean возвращает значение True, если до конца строки остались только пробелы.


Компонентные файлы

Компонентный или типизированный файл – это файл с объявленным типом его компонент. Компонентные файлы состоят из машинных представлений значений переменных, они хранят данные в том же виде, что и память ЭВМ.

Описание величин файлового типа имеет вид:

type M= File Of T;

где М – имя файлового типа; Т – тип компоненты. Например:

type
FIO= String[20];
SPISOK=File of FIO;
var
STUD, PREP: SPISOK;

Здесь STUD, PREP – имена файлов, компонентами которых являются строки.

Описание файлов можно задавать в разделе описания переменных:

var
fsimv: File of Char;
fr: File of Real;

Компонентами файла могут быть все скалярные типы, а из структурированных – массивы, множества, записи. Практически во всех конкретных реализациях языка Паскаль конструкция "файл файлов" недопустима.

Все операции над компонентными файлами производятся с помощью стандартных процедур:

Reset, Rewrite, Read, Write, Close.

Для ввода-вывода используются процедуры:

Read(f,X);
Write(f,X);

где f – имя логического файла; Х – либо переменная, либо массив, либо строка, либо множество, либо запись с таким же описанием, какое имеет компонента файла.

Выполнение процедуры Read (f,X) состоит в чтении с внешнего устройства одной компоненты файла и запись ее в X. Повторное применение процедуры Read (f,X) обеспечит чтение следующей компоненты файла и запись ее в X.

Выполнение процедуры Write (f,X) состоит в записи X на внешнее устройство как одной компоненты. Повторное применение этой процедуры обеспечит запись X как следующей компоненты файла.

Для работы с компонентными файлами введена расширенная форма операторов ввода и вывода:

Read(f,X1,X2,...XK)
Write(f,X1,X2,...XK)

Здесь f – компонентный файл, а переменные Х1, Х2,..., ХК должны иметь тот же тип, что и объявленный тип компонент файла f.


Бестиповые файлы

Бестиповые файлы позволяют записывать на диск произвольные участки памяти ЭВМ и считывать их с диска в память. Операции обмена с бестиповыми файлами осуществляются с помощью процедур BlokRead и BlockWrite. Кроме того, вводится расширенная форма процедур Reset и Rewrite. В остальном принципы работы остаются такими же, как и с компонентными файлами.

Перед использованием логический файл

var f: File;

должен быть связан с физическим с помощью процедуры Assign. Далее файл должен быть открыт для чтения или для записи процедурой Reset или Rewrite, а после окончания работы закрыт процедурой Close.

При открытии файла длина буфера устанавливается по умолчанию в 128 байт. Турбо Паскаль позволяет изменить размер буфера ввода-вывода, для чего следует открывать файл расширенной записью процедур

Reset(var f: File; BufSize: Word);

или

Rewrite(var f: File; BufSize: Word);

Параметр BufSize задает число байтов, считываемых из файла или записываемых в него за одно обращение. Минимальное значение BufSize – 1 байт, максимальное – 64 Кбайта.

Чтение данных из бестипового файла осуществляется процедурой

BlockRead( var f: File; var X; Count: Word;
var QuantBlock: Word);

Эта процедура осуществляет за одно обращение чтение в переменную X количества блоков, заданное параметром Count, при этом длина блока равна длине буфера. Значение Count не может быть меньше 1. За одно обращение нельзя прочесть больше, чем 64 Кбайтов.

Необязательный параметр QuantBlock возвращает число блоков (буферов), прочитанных текущей операцией BlockRead. В случае успешного завершения операции чтения QuantBlock = Count, в случае аварийной ситуации параметр QuantBlock будет содержать число удачно прочитанных блоков. Отсюда следует, что с помощью параметра QuantBlock можно контролировать правильность выполнения операции чтения.

Запись данных в бестиповой файл выполняется процедурой

BlockWrite( var f: File; var X; Count: Word;
var QuantBlock: Word);

которая осуществляет за одно обращение запись из переменной X количества блоков, заданное параметром Count, при этом длина блока равна длине буфера.

Необязательный параметр QuantBlock возвращает число блоков (буферов), записанных успешно текущей операцией BlockWrite.


Последовательный и прямой доступ

Смысл последовательного доступа заключается в том, что в каждый момент времени доступна лишь одна компонента из всей последовательности. Для того, чтобы обратиться (получить доступ) к компоненте с номером К, необходимо просмотреть от начала файла К-1 предшествующую компоненту. После обращения к компоненте с номером К можно обращаться к компоненте с номером К+1. Отсюда следует, что процессы формирования (записи) компонент файла и просмотра (чтения) не могут произвольно чередоваться. Таким образом, файл вначале строится при помощи последовательного добавления компонент в конец, а затем может последовательно просматриваться от начала до конца.

Рассмотренные ранее средства работы с файлами обеспечивают последовательный доступ.

Турбо Паскаль позволяет применять к компонентным и бестиповым файлам, записанным на диск, способ прямого доступа. Прямой доступ означает возможность заранее определить в файле блок, к которому будет применена операция ввода-вывода. В случае бестиповых файлов блок равен размеру буфера, для компонентных файлов блок – это одна компонента файла.

Прямой доступ предполагает, что файл представляет собой линейную последовательность блоков. Если файл содержит n блоков, то они нумеруются от 1 через 1 до n. Кроме того, вводится понятие условной границы между блоками, при этом условная граница с номером 0 расположена перед блоком с номером 1, граница с номером 1 расположена перед блоком с номером 2 и, наконец, условная граница с номером n находится после блока с номером n.

Реализация прямого доступа осуществляется с помощью функций и процедур FileSize, FilePos, Seek и Truncate.

Функция FileSize (var f): Longint возвращает количество блоков в открытом файле f.

Функция FilePos (var f): Longint возвращает текущую позицию в файле f. Позиция в файле – это номер условной границы. Для только что открытого файла текущей позицией будет граница с номером 0. Это значит, что можно записать или прочесть блок с номером 1. После чтения или записи первого блока текущая позиция переместится на границу с номером 1, и можно будет обращаться к блоку с номером 2. После прочтения последней записи значение FilePos равно значению FileSize.

Процедура Seek (var f; N: Longint) обеспечивает назначение текущей позиции в файле (позиционирование). В параметре N должен быть задан номер условной границы, предшествующей блоку, к которому будет производиться последующее обращение. Например, чтобы работать с блоком 4, необходимо задать значение N, равное 3. Процедура Seek работает с открытыми файлами.

Процедура Truncate (var f) устанавливает в текущей позиции признак конца файла и удаляет (стирает) все последующие блоки.

Пример. Пусть на НМД имеется текстовый файл ID.DAT, который содержит числовые значения действительного типа по два числа в каждой строке – значения аргумента и функции соответственно. Количество пар чисел не более 200. Составить программу, которая читает файл, значения аргумента и функции записывает в одномерные массивы, подсчитывает их количество, выводит на экран дисплея и записывает в файл компонентного типа RD.DAT.

Program F;
Var rArg, rF: Array[1..200] of Real;
inf: Text;
outf: File of Real;
n, l: Integer;
Begin
Assign(inf,'ID.DAT');
Assign(outf,'RD.DAT');
Reset(inf);
Rewrite(outf);
n:=0;
while not EOF(inf) do begin
n:=n+1;
ReadLn(inf,rArg[n],rF[n])
end;
for l:=1 to n do begin
WriteLn(l:2,rArg[l]:8:2,rF[l]:8:2);
Write(outf,rArg[l], rF[l]);
end;
close(outf)
End.


12.11. ДИНАМИЧЕСКИЕ ПЕРЕМЕННЫЕ

Статической переменной (статически размещенной) называется описанная явным образом в программе переменная, обращение к которой осуществляется по имени. Место в памяти для размещения статических переменных определяется при компиляции программы.

В отличие от таких статических переменных в программах, написанных на языке Паскаль, могут быть созданы динамические переменные. Основное свойство динамических переменных заключается в том, что они создаются и память для них выделяется во время выполнения программы. Размещаются динамические переменные в динамической области памяти (heap – области).

Динамическая переменная не указывается явно в описаниях переменных и к ней нельзя обратиться по имени. Доступ к таким переменным осуществляется с помощью указателей и ссылок.

Работа с динамической областью памяти в Турбо Паскале реализуется с помощью процедур и функций New, Dispose, GetMem, FreeMem, Mark, Release, MaxAvail, MemAvail, SizeOf.

Процедура New (var p: Pointer) выделяет место в динамической области памяти для размещения динамической переменной p^ и ее адрес присваивает указателю p.

Процедура Dispose (var p: Pointer) освобождает участок памяти, выделенный для размещения динамической переменной процедурой New, и значение указателя p становится неопределенным.

Процедура GetMem (var p: Pointer; size: Word) выделяет участок памяти в heap-области, присваивает адрес его начала указателю p, размер участка в байтах задается параметром size.

Процедура FreeMem (var p: Pointer; size: Word) освобождает участок памяти, адрес начала которого определен указателем p, а размер параметром size. Значение указателя p становится неопределенным.

Процедура Mark (var p: Pointer) записывает в указатель p адрес начала участка свободной динамической памяти на момент ее вызова.

Процедура Release (var p: Pointer) освобождает участок динамической памяти, начиная с адреса, записанного в указатель p процедурой Mark, то есть, очищает ту динамическую память, которая была занята после вызова процедуры Mark.

Функция MaxAvail: Longint возвращает длину в байтах самого длинного свободного участка динамической памяти.

Функция MemAvail: Longint полный объем свободной динамической памяти в байтах.

Вспомогательная функция SizeOf (X): Word возвращает объем в байтах, занимаемый X, причем X может быть либо именем переменной любого типа, либо именем типа.

Рассмотрим некоторые примеры работы с указателями.

var
p1, p2: ^Integer;

Здесь p1 и p2 – указатели или переменные ссылочного типа.

p1:=NIL; p2:=NIL;

После выполнения этих операторов присваивания указатели p1 и p2 не будут ссылаться ни на какой конкретный объект.

New(p1); New(p2);

Процедура New(p1) выполняет следующие действия:

– в памяти ЭВМ выделяется участок для размещения величины целого типа;
– адрес этого участка присваивается переменной p1:

Аналогично, процедура New(p2) обеспечит выделение участка памяти, адрес которого будет записан в p2:

После выполнения операторов присваивания

p1^:=2; p2^:=4;

в выделенные участки памяти будут записаны значения 2 и 4 соответственно:

В результате выполнения оператора присваивания

p1^:=p2^;

в участок памяти, на который ссылается указатель p1, будет записано значение 4:

После выполнения оператора присваивания

p2:=p1;

оба указателя будут содержать адрес первого участка памяти:

Переменные p1^, p2^ являются динамическими, так как память для них выделяется в процессе выполнения программы с помощью процедуры New.

Динамические переменные могут входить в состав выражений, например:

p1^:=p1^+8; Write('p1^=',p1^:3);

Пример. В результате выполнения программы:

Program DemoPointer;
Var p1,p2,p3:^Integer;
Begin
p1:=NIL; p2:=NIL; p3:=NIL;
New(p1); New(p2); New(p3);
p1^:=2; p2^:=4;
p3^:=p1^+Sqr(p2^);
writeln('p1^=',p1^:3,' p2^=',p2^:3,' p3^=',p3^:3);
p1:=p2;
writeln('p1^=',p1^:3,' p2^=',p2^:3)
End.

на экран дисплея будут выведены результаты:

p1^= 2 p2^= 4 p3^= 18
p1^= 4 p2^= 4


12.12. ЭЛЕМЕНТЫ СТРУКТУРНОГО ПРОГРАММИРОВАНИЯ

Структурированная программа (или подпрограмма) – это программа, составленная из фиксированного множества базовых конструкций. Рассмотрим основные определения и способы образования этих конструкций в схемах алгоритмов.

Из операций, развилок и слияний строятся базовые конструкции: следование, ветвление, цикл. Применяя только эти три конструкции, можно реализовать алгоритм решения любой задачи.

Конструкция, представляющая собой последовательное выполнение двух или более операций, называется следованием.

Конструкция, состоящая из развилки, двух операций и слияния, называется ветвлением. Одна из операций может отсутствовать.

Конструкция, имеющая линии управления, ведущие к предыдущим операциям или развилкам, называется циклом.

Конструкции следование, ветвление и цикл можно представить как операции, так как они имеют единственный вход и единственный – выход. Произвольную последовательность операций можно представить как одну операцию.

Операция может быть реализована любым оператором языка Паскаль (простым или составным), либо группой операторов, за исключением оператора перехода GOTO.

В языке Паскаль количество базовых конструкций увеличено до шести, это:

  • следование;
  • ветвление;
  • цикл с предусловием;
  • цикл с постусловием;
  • цикл с параметром;
  • вариант.


12.13. ВВЕДЕНИЕ В ОБЪЕКТНО-ОРИЕНТИРОВАННОЕ ПРОГРАММИРОВАНИЕ

Объекты

В основе того или иного языка программирования лежит некоторая руководящая идея, оказывающая существенное влияние на стиль соответствующих программ.

Исторически первой была идея процедурного структурирования программ, в соответствии с которой программист должен был решить, какие именно процедуры он будет использовать в своей программе, а затем выбрать наилучшие алгоритмы для реализации этих процедур. Появление этой идеи было следствием недостаточной изученности алгоритмической стороны вычислительных процессов, столь характерной для ранних программных разработок (сороковые – пятидесятые годы). Типичным примером процедурно-ориентированного языка является Фортран – первый и один из наиболее популярных языков программирования. Последовательное использование идеи процедурного структурирования программ привело к созданию обширных библиотек программирования, содержащих множество сравнительно небольших процедур, из которых, как из кирпичиков, можно строить «здание» программы.

По мере прогресса в области вычислительной математики акцент в программировании стал смещаться с процедур в сторону организации данных. Оказалось, что эффективная разработка сложных программ нуждается в действенных способах контроля правильности использования данных. Контроль должен осуществляться как на стадии компиляции, так и при прогоне программ, в противном случае, как это показала практика, резко возрастают трудности создания крупных программных проектов. Отчетливое осознание этой проблемы привело к созданию Алгола-60, а позже Паскаля, Модулы-2, Си и множества других языков программирования, имеющих более или менее развитые структуры типов данных. Логическим следствием развития этого направления стал модульный подход к разработке программ, характеризующийся стремлением «спрятать» данные и процедуры внутри модуля.

Начиная с языка Симула-67, в программировании наметился новый подход, который получил название объектно-ориентированного программирования (ООП). Его руководящая идея заключается в стремлении связать данные с обрабатывающими эти данные процедурами в единое целое – объект. Характерной чертой объектов является инкапсуляция (объединение) данных и алгоритмов их обработки, в результате чего и данные, и процедуры во многом теряют самостоятельное значение. Фактически объектно-ориентированное программирование можно рассматривать как модульное программирование нового уровня, когда вместо во многом случайного, механического объединения процедур и данных акцент делается на их смысловую связь.

Следует заметить, что преимущества ООП в полной мере проявляются лишь при разработке достаточно сложных программ. Более того, инкапсуляция придает объектам совершенно особое свойство «самостоятельности», максимальной независимости от остальных частей программы – правильно сконструированный объект располагает всеми необходимыми данными и процедурами их обработки, чтобы успешно реализовать требуемые от него действия. Таким образом, ООП в наибольшей степени подходит к задаче разработки библиотек программирования. Попытки использовать ООП для программирования несложных алгоритмических действий, связанных, например, с расчетными вычислениями по готовым формулам, чаще всего выглядят искусственными нагромождениями ненужных языковых конструкций. Такие программы обычно не нуждаются в структуризации, расчленении алгоритма на ряд относительно независимых частей, их проще и естественнее разрабатывать традиционными способами Паскаля. При разработке сложных диалоговых программ программист вынужден структурировать программу, так как только в этом случае он может рассчитывать на успех: «критической массой» неструктурированных программ является объем в 1000-1200 строк исходного текста – отладка неструктурированных программ большего объема обычно сталкивается с чрезмерными трудностями. Структурирование программы ведет, фактически, к разработке собственной библиотеки программирования – вот в этот момент к Вам на помощь и приходят новые средства ООП.


Инкапсуляция

В Турбо Паскале средства объектно-ориентированного программирования связаны с тремя зарезервированными словами: OBJECT, CONSTRUCTOR и DESTRUCTOR и двумя стандартными директивами: PRIVATE и VIRTUAL.

Зарезервированное слово OBJECT используется для описания объекта. Описание объекта должно помещаться в разделе описания типов, например:

Type
TPoint = object
X, Y: Integer: {Координаты точки}
Color: word: {Цвет точки}
Visible: Boalean; { Признак светимости}
Procedure SetLocitlon(NewX, NewY: integer);
{Задает новое положение точки на экране}
Procedure SetColor(NewColor: word);
{Устанавливает цвет точки}
Procedure SetVisible(Vls: Boolean);
{Выводит или гасит точку}
Procedure GetLocation(var XLoc, YLoc: Integer):
{Возвращает координаты точки}
Function GetColor: word;
{Возвращает цвет точки}
Function GetVisible: Boolean;
{Возвращает признак светимости точки}
end; {Конец описания объекта TPoint}

В этом примере описывается объект TPOINT, представляющий собой данные и методы (процедуры и функции), необходимые для работы с графическими точками на экране ПК. Заметим, что инкапсулированные в объект процедуры и функции называются методами. Как видим, каждая точка характеризуется некоторым набором данных (своими координатами Х и Y цветом COLOR и признаком светимости VISIBLE). Над этими данными определены все необходимые алгоритмические действия. Если описать такой объект, то в программе можно предусмотреть сколько угодно экземпляров объекта, т.е. переменных типа объект. С помощью этих переменных можно осуществлять все предусмотренные в объекте действия, например, для переменных типа TPOINT можно высветить или погасить любую точку, переместить ее по экрану, изменить цвет. В следующем фрагменте программы точка перемещается на два пикселя вниз и вправо по экрану:

Vаr
Point: TPaint;
X. Y : Integer;
{Экземпляр объекта TPOINT}
with Point do begin
If GetVisible then
SetVlilble(False); {Погасить точку}
GetLocatlon(X,Y); {Получить координаты}
SetLocatlon(X*2, Y*2); {Задать новые координаты}
SetVisible(True) {Зажечь точку}
end;
...

Нетрудно заметить, что описание объекта и использование объектных переменных во многом похоже на описание и использование записей: инкапсулированные в объекте данные и методы становятся доступны с помощью оператора присоединения WITH или с помощью составных имен, например:

If Point.GetVltlble then Point.SetVisible(False);

При описании объекта вначале описываются все инкапсулированные в нем данные, а затем – методы доступа к этим данным. В качестве методов используются процедуры и функции, а также конструкторы и деструкторы (см. ниже). Сами методы при описании объекта не раскрываются, указывается лишь их заголовок. Предполагается, что они описываются где-то ниже по тексту программы, например:

Type
TPoint = object
...
end;

PROCEDURE TPoint.SetVisible(Vis: Boolean);
{Реализация метода SETVISIBLE)
BEGIN
If Vis then
begin
PutPlxel(X,Y,Color);
{Высветить точку цветом Color}
Visible := True; {Установить флаг светимости}
end
else
begin
PutPlxel(X,Y,GetBkColor);
{Погасить точку цветом фона}
Visible := False;
{Сбросить признак светимости}
end
END; {TPoint.SetVisible}

Таким образом, указание методов при описании объекта подобно их опережающему описанию. Поскольку данные и методы инкапсулированы в одном объекте, все данные автоматически становятся глобальными по отношению к любым методам и могут использоваться в них произвольным образом. Точнее говоря, любой метод объекта работает с невидимым оператором WITH, обеспечивающим ему доступ ко всем полям (как мы увидим далее, поля могут следовать в объявлении типа и после объявления метода и в этом смысле не являться для него глобальными). При обращении к методу ему передается особый идентификатор SELF, представляющий собой обобщенное имя экземпляра объекта. Любой метод может использовать идентификатор SELF, чтобы явно указать на принадлежащий объекту метод или поле. Например:

type ТСоо = record
X,Y: Integer;
end:
TPoint = object
X,Y: Integer;
Procedure Init(Coo: ТСоо);
end;

Procedure TPoint(Coo: ТСоо);
begin
with Coo do begin
Self.X := X;
Self.Y := Y
end
end;


Наследование

Любой объект может быть объявлен потомком ранее описанного объекта. В этом случае он наследует все данные и методы объекта-родителя и может дополнять их своими данными и методами. Например, объект TUNE, описывающий линию, можно объявить следующим образом:

Type
TPoint = object
...
end;{Конец описания объекта TPoint}
TLine = object(TPoint)
XE, YE: Integer;
{Координаты второго конца}
Procedure SetLineLocation(x1,y1,x2,y2:Integer);
{Задает новое положение линии на экране}
Procedure GetLineLocation(var x1l,у11,х21,у21:
Integer);
{Возвращает координаты линии}
Procedure SetLineVisible(Vsi: Boolean);
{выводит или гасит линию}
end; {Конец описания объекта TLINE)

При объявлении объекта-потомка за словом OBJECT в круглых скобках указывается имя объекта-родителя. У объекта может быть сколько угодно потомков, но только один родитель.

При объявлении объекта-потомка TLINE перечислены лишь те данные и методы, которых недостает в объекте-родителе TPOINT, остальные TLINE автоматически наследуют от своего родителя.

Таким образом, описание объекта-потомка TLINE эквивалентно такому описанию объекта TLINE_ANOTHER:

Type TLine_Another = object
X, Y: Integer; {Координаты начала линии}
Color: word; {Цвет линии}
Visible: Boolean;{Признак светимости}
XE,YE: Integer; {Координаты второго конца}
Procedure SetLocation(NewX, NewY: Integer);
{Задает новое положение начала линии}
Procedure SetColor(NewColor: word);
{Устанавливает цвет линии}
Procedure SetVisible(Vis: Boolean);
{Выводит или гасит линию}
Procedure GetLocationf(var XLoc, YLoc: Integer);
{Возвращает координаты начала линии}
Function GetColor: word;
{Возвращает цвет линии}
Function GetVisible: Boolean;
{Возвращает признак светимости линии}
Procedure SetLineLocatlon(x1,y1,x2,y2: Integer);
{Задает новое положение линии на экране}
Procedure GetLlneLocatlon(var x1l,у11,x2l,y2l:
Integer):
{Возвращает координаты линии}
Procedure SetLineVisible(Vis: Boolean);
{Выводит или гасит линию}
end; {Конец описания объекта TLine_Another}

Из этого примера видно главное преимущество наследования: при описании объекта-потомка Вам нет необходимости заново описывать уже существующие в объекте-родителе поля и методы. Потомок просто использует их нужным образом для реализации требуемых от него действий. Все, в чем нуждается потомок, – это описать специфичные для него поля и методы, недостающие в объекте-родителе.

Наследование распространяется на любые объекты, в том числе и на объекты-потомки: если в качестве родителя указано имя объекта, который сам по себе является потомком, новый объект наследует все свойства своего родителя и все свойства своих прародителей. Таким образом, наследование обеспечивает создание дерева родственных объектов.

Как и любое другое дерево, дерево объектов имеет «корень» – объект, являющийся прародителем всех других объектов иерархии, и «ветви» -порожденные от него потомки. По мере передвижения от корня к ветвям и перехода с ветви на ветвь объекты разрастаются в своих размерах, присоединяя к себе все новые и новые поля и методы. Если иерархия объектов хорошо продумана, на каждом ее уровне к объекту-родителю добавляются только необходимые поля и методы, поэтому в таком разрастании на самом деле нет ничего плохого. Более того, компоновщик Турбо Паскаля тщательно проверит откомпилированную программу и удалит из нее все лишнее – в том числе в исполняемую программу (ЕХЕ-файл) не будут включены методы, которые по каким-либо причинам не используются в программе.

Механизм наследования – это, пожалуй, самое мощное свойство ООП. Без наследования объекты превращаются в простую комбинацию данных и подпрограмм, не дающую качественных преимуществ по сравнению с традиционными для Паскаля процедурами и модулями. Наоборот, механизм наследования позволяет строить библиотеку по принципу «от простого – к сложному». Вводя с помощью наследования новый объект в свою библиотеку, программист в максимальной степени использует уже созданные (и, возможно, отлаженные) ранее объекты. Такой принцип конструирования программ называется восходящим программированием. В отличие от нисходящего программирования, он не дает возможности поэтапного создания программы. Мелкие детали реализации объектов заслоняют собою генеральный алгоритм, поэтому при использовании ООП рекомендуется сочетание подходов: методами нисходящего программирования генеральный алгоритм расчленяется на ряд относительно крупных и законченных в смысловом отношении фрагментов (модулей), а реализация этих фрагментов может основываться на объектно-ориентированном программировании.

Другое применение ООП – это разработка коммерческих библиотек программирования. Прекрасным примером такого рода применения ООП является уже упоминавшаяся библиотека Turbo Vision.


Полиморфизм

Объект-потомок может не только дополнять поля и методы родителя, но и заменять методы родителя на новые (заменять поля родителя нельзя!). Например, вместо правила SETLINEVISIBLE мы могли бы в объекте TLine объявить правило SETVISIBLE, которое в этом случае перекроет (заменит собой) одноименное правило объекта-родителя TPoint. В результате, к разным родственным объектам TPoint и TLine можно было бы применять одноименные правила SETVISIBLE, обеспечивающие сходные в смысловом отношении действия – показать или сделать невидимым графический объект. Свойство, позволяющее называть разные алгоритмические действия одним именем, называется полиморфизмом.

В следующем простом примере два родственных объекта владеют разными (но одноименными) методами Оut.

Type ТА = object;
Precedure Out;
end;
ТВ = object(TA)
Procedure Out;
end;
Procedure ТА.Out:
begin
Writeln ('МЕТОД ТА.OUT')
end;
Procedure ТВ.Out;
begin
Writeln("Метод ТВ.Out")
end;
Var А: ТА; В: ТВ
Begin
A.Out;
В.Out;
End.

В результате прогона программы на экран выводятся строки:

МЕТОД TA.OUT
Метод TB.Out

В процессе компиляции будет установлена связь объекта с нужным методом, так что обращения A.OUT и B.OUT приводят к вызову разных методов. Такое связывание объектов и инкапсулированных в них полей с методами называется ранним, так как оно осуществляется на этапе компиляции. В Турбо Паскале существует возможность связывания данных с методами на этапе исполнения программы – такое связывание называется поздним. При позднем связывании в описании объекта соответствующий метод дополняется стандартной директивой VIRTUAL. Такие методы называются виртуальными. В отличие от этого методы, с которыми осуществлено раннее связывание (на этапе компиляции), называются статическими.

Появление директивы VIRTUAL в объявлении метода как бы предупреждает компилятор: «Пока ты не знаешь, что я хочу. Придет время – запроси образец!». Встретившись с таким объявлением, компилятор не будет устанавливать связь объекта с методом. Вместо этого он создаст специальную таблицу, которая называется таблицей виртуальных методов (ТВМ). В этой таблице хранятся адреса точек входа всех виртуальных методов. Для каждого типа объект создается своя ТВМ и каждый экземпляр объекта пользуется этой единственной для объектов данного типа таблицей. ТВМ обеспечивает работающую программу механизмом связывания объекта с полями, фактическое связывание осуществляется с помощью обращения к конструктору - специальному методу, который во всем подобен обычной процедуре, но в заголовке вместо PROCEDURE содержит зарезервированное слово CONSTRUCTOR. В момент обращения к конструктору в специальное поле объекта заносится адрес нужной ТВМ, в результате чего все виртуальные методы (в том числе и унаследованные от родителей!) получают доступ к нужным полям.

Таким образом, важным отличием позднего связывания от раннего является то обстоятельство, что при его использовании полиморфизм распространяется не только от текущего уровня иерархии вниз, к потомкам, но также и вверх, к родителям.

Чтобы продемонстрировать отличие раннего связывания от позднего, рассмотрим следующий пример. Пусть имеем такую программу:

Type ТА = object
Procedure Out:
{Выводит сообщение методом OutStr}
Function OutStr: itring:
{Выдает строку "МЕТОД TA.OUTSTR")
end;
ТВ = obоject(TA)
Function OutStr: string;
{Вынет строку "Метод ТВ.OutStr"}
end:
Procedure ТА.Out;
begin
Writeln(OutStr)
end;
Function ТА.OutStr: string;
begin
OutStr := 'МЕТОД ТА.OUTSTR'
end;
Function ТВ.OutStr: string;
begin
OutStr := 'Метод ТВ.OutStr'
end;

Var А: ТА; В: ТВ:
Begin
A.Out;
В.Out
end.

В результате прогона на экран будет выведено:

МЕТОД TA.OOTSTR
МЕТОД TA.OOTSTR

Как и следовало ожидать, метод TB.OUTSTR не работает: ведь он статический и метод родителя ТА.Оut просто не знает о его существовании.

Теперь рассмотрим вариант, использующий виртуальные методы:

type ТА = object
Procedure Out:{Выводит сообщение методом
OutStr}
Function OutStr: string; virtual;
{Выдает строку 'МЕТОЛ ТА.OUTSTR'}
Constructor Init;
end;

ТВ = object(TA)
Function OutStr: string; virtual;
{Выдает строку 'Метод ТВ.OutStr'}
Consitructor Init;
end:
Procedure ТА.Out;
begin
Writeln(OutStr)
end;
Function ТА.OutStr: string;
begin
OutStr := 'МЕТОД ТА.OUTSTR'
end;
Function ТВ.OutStr: string;
begin
OutStr := 'Метод ТВ.OutStr'
end;
Conitructor ТА.Init;
begin
end;
Conitructor ТВ.Init;
begin
end;
Var
А: ТА;
В: ТВ;
begin
A.Init;
В.Init;
A.Out;
В.Out
end.

На экран будет выведено:

МЕТОД TA.OUTSTR
Метод ТВ.OutStr

С помощью ТВМ родительский метод TA.OUT «узнал» о существовании виртуального метода ТВ.OUTSTR и использовал именно его при обращении B.OUT.

Конструктор может не обращаться к виртуальному методу и даже вообще быть пустым, т.е. не иметь никаких исполняемых операторов (как в нашем примере), тем не менее объект будет инициализирован правильно. Дело в том, что заголовок CONSTRUCTOR предписывает компилятору создать специальный набор машинных инструкций, который инициализирует ТВМ и исполняется в момент обращения к конструктору до выполнения его (конструктора) содержательной части. В объекте может быть сколько угодно конструкторов, но ни один из них не может быть виртуальным.

Обращение к статическим методам не требует инициализации объекта и может предшествовать обращению к конструктору. Однако без оператора

А.Init;

обращение

A.Out;

вызовет ошибку периода исполнения программы. Таким образом, если в объекте имеется хотя бы один виртуальный метод, в объект обязательно должен входить конструктор, причем обращение к конструктору должно предшествовать обращению к любому виртуальному методу.

Выбор того, каким именно - статическим или виртуальным должен быть метод, зависит от специфики задачи и Ваших вкусов. Однако следует помнить, что статический метод никогда не может быть перекрыт виртуальным и наоборот. Список формальных параметров статического метода может отличаться от списка в перекрываемом методе, а для виртуальных методов оба списка должны быть идентичны. И, наконец, виртуальные объекты занимают несколько большую память (за счет ТВМ) и вызов виртуальных методов исполняется чуть медленнее, чем вызов статических. Тем не менее, всегда, когда это возможно, следует отдавать предпочтение виртуальным методам, так как они придают программе дополнительную гибкость. Всегда может оказаться, что рано иди поздно Вы или кто-то из пользователей Вашей библиотеки захочет модифицировать ту или иную ее функции. В этом случае перекрытие виртуальных методов позволит предельно упростить задачу.

Отметим, что стандартная функция Турбо Паскаля TypeOf(TObj) возвращает ссылку на ТВМ для объекта типа TObj. Эту ссылку можно использовать, например, для проверки того, с каким именно объектом работает в данный момент виртуальный метод:

If TypeOf(Self) = TypeOf(TA) then ...

И еще одно замечание. Между экземплярами родственных объектов возможен обмен информацией с помощью операторов присваивания. Например, если Point1 и Point2 – экземпляры объекта TPOINT, то допустимо присваивание

Pointl := Рoint2;

или

Point2 := Рoint1;

Присваивания разрешены и между экземплярами родственных объектов разных уровней иерархии, однако в этом случае экземпляру объекта-родителя можно присвоить экземпляр потомка, но не наоборот! Например, разрешается присваивание

Point := Line;

но недопустимо

Line := Point;

если LINE – потомок POINT. Это происходит по той причине, что потомок содержит все поля родителя, поэтому при присваивании потомка родителю эти поля получат правильные значения. Обратное же присваивание оставит без изменения «лишние» поля потомка, что является недопустимым.

При использовании виртуальных правил следует остерегаться присваивания между экземплярами объектов, во всяком случае необходимо помнить, что простое присваивание не заменяет собой инициацию виртуального объекта. Если, например, LINE и POINT – виртуальные объекты, то присваивание

Point := Line;

не инициирует объект POINT, даже если объект LINE был перед этим инициирован. После такого присваивания необходим вызов конструктора объекта POINT перед обращением к любому виртуальному методу этого объекта.


Динамические объекты

Объектные переменные во многом подобны обычным переменным Турбо Паскаля, в частности, их можно размещать в динамической памяти. Турбо Паскаль содержит средства, облегчающие размещение объектных переменных в куче и их удаление из нее, например:

...
Vаг PLine:^TLine;
New(PLine, Init);
...

В этом примере размещение объектной переменной (на нее указывает PLINE) в куче сопровождается одновременным обращением к конструктору TUNB.INIT для инициализации объекта и связывания виртуальных методов с вновь созванной переменной: в процедуре NEW допускается в качестве второго параметра указывать обращение к конструктору.

Более того, процедуру New можно вызывать и как функцию – в этом случае она возвращает значение типа POINTER, указывающее на динамически распределенный объект:

PLine := New(TLine);

или

PLine := New(Tline, Init);

Обратите внимание: первым параметром процедуре New передается указатель на динамически распределяемый объект, в то время как первым параметром функции New – тип распределяемого объекта. И в том, и в другом случае в качестве второго параметра обращения допускается использовать вызов конструктора, однако имя конструктора не может быть составным – ведь в момент обращения динамический объект еще не создан. Например, оператор

New(Pline, PLine^.lnIt);

вызовет сообщение об ошибке.

При обращении к NEW с одновременным вызовом конструктора динамическая память резервируется с помощью специального программного кода, входящего в любой конструктор и вызываемого до начала работы исполняемой части конструктора (до begin). При этом динамическая память может оказаться исчерпанной. В этом случае стандартная функция обработки ошибок администратора кучи выдает значение 0, что вызывает аварийное завершение программы с кодом ошибки 203. Если используется нестандартная функция обработки ошибок и эта функция возвращает 1, конструктор пропускает операторы после begin и возвращает NIL. Таким образом гарантируется, что исполняемые операторы конструктора будут работать только при условии нормального распределения динамической памяти. Однако в теле конструктора может быть создан новый динамический объект, в нем – свой и т.д. Турбо Паскаль допускает произвольную глубину вложенности конструкторов. Если на каком-то уровне обнаружится нехватка динамической памяти, необходимо ликвидировать всю цепочку успешно распределенных объектов. Чтобы эта операция стала возможной, в Турбо Паскаль введена стандартная процедура без параметров FAIL, которая может вызываться только из конструктора и которая освобождает уже выделенную конструктором память, завершает его работу и возвращает NIL.

Для удаления динамического объекта из кучи используется особый метод – деструктор, описываемый с помощью зарезервированного слова DESTRUCTOR. В этом методе можно предусмотреть все действия, связанные с ликвидацией динамического объекта (т.е. переменной объектного типа, размещенной в динамической памяти), например, осуществить. нужную коррекцию списка динамических объектов. Обращение к деструктору указывается вторым параметром при вызове процедуры DISPOSE, например:

Type
TLine = object(Point)
Constructor Init;
Destructor Done;
end;
...
New(PLine, Init); {Размещение
динамического объекта}
...
Dispose(Pline, Done);{Удаление
динамического объекта}

При необходимости деструктор, как и любой другой метод объекта (кроме конструктора!) , можно объявить виртуальным.


Закрытие части объекта

Обычно объекты описываются в отдельном модуле, в интерфейсной части которого приводится объявление объекта, а в исполняемой части – описание всех его методов. При желании часть инкапсулированных переменных и методов объекта Вы можете объявить скрытыми от пользователей Вашего модуля. Для этого используется стандартная директива PRIVATE:

Type
Новый_объект = object (Объект-родитель)
Доступные_поля;
Доступные_процедуры;
Private
Закрытые_поля;
Закрытые_процедуры;
end;

Все данные и методы, объявленные после директивы PRIVATE, доступны только внутри того модуля, в котором объявлен сам объект.

Несмотря на то, что закрытые директивой PRIVATE поля располагаются после объявления доступных методов, любой метод объекта может использовать любое поле. Однако вне модуля доступ к закрытым полям невозможен. Хороший стиль объектно-ориентированного программирования рекомендует доступ к любым полям осуществлять только с помощью инкапсулированных методов. Использование директивы PRIVATE легко решает эту проблему при разработке коммерческих библиотек.


12.16. Глоссарий

Буфер ввода-вывода - это область в памяти, которая выделяется для каждого файла.

Венгерская нотация - это соглашение о наименованиях переменных и функций.

Ветвление - это конструкция, состоящая из развилки, двух операций и слияния. Одна из операций может отсутствовать.

Выражение в алгоритмическом языке состоит из элементарных конструкций и символов, оно задает правило вычисления некоторого значения.

Выражение-константа представляет собой выражение, которое может вычисляться компилятором без необходимости выполнения программы.

Глобальные переменные - это переменные, описанные вне процедуры и функции и располагающиеся в сегменте данных.

Динамическая переменная создается во время выполнения программы и память для них выделяется в динамической области (heap).

Запись представляет собой совокупность ограниченного числа логически связанных компонент, принадлежащих к разным типам. Компоненты записи называются полями, каждое из которых определяется именем.

Именами (идентификаторами) называют элементы языка - константы, метки, типы, переменные, процедуры, функции, модули, объекты. Имя - это последовательность букв и цифр, начинающаяся с буквы. В именах может использоваться символ '_' подчеркивание.

Инициализация переменных - это задание начальных значений переменным.

Инкапсуляция - это объединение данных и алгоритмов их обработки в одной структуре данных (объекте).

Компонентный или типизированный файл - это файл с объявленным типом его компонент.

Компонентные файлы состоят из машинных представлений значений переменных, они хранят данные в том же виде, что и память ЭВМ.

Локальные переменные - это переменные, описанные в самой процедуре или функции и располагающиеся в сегменте стека.

Массивы представляют собой ограниченную упорядоченную совокупность однотипных величин. Каждая отдельная величина называется компонентой массива.

Методы - это инкапсулированные в объект процедуры и функции.

Множество - это ограниченная совокупность различных элементов.

Модуль - это совокупность программных ресурсов, предназначенных для использования другими программами.

Оператор задает полное описание некоторого действия, которое необходимо выполнить. Для описания сложного действия может потребоваться группа операторов. В этом случае операторы объединяются в составной оператор или блок.

Операторы отношений сравнивают два значения, возвращая в результате булевское значение True или False.

Подпрограмма - это последовательность операторов, которые определены и записаны только в одном месте программы, однако их можно вызвать для выполнения из одной или нескольких точек программы. Каждая подпрограмма определяется уникальным именем.

Полиморфизм - это свойство, позволяющее называть разные алгоритмические действия одним именем.

Последовательный доступ - это доступ в каждый момент времени лишь к одной компоненте данных из всей последовательности, записанной в файл.

Программа - это объединенная единым алгоритмом совокупность описаний и операторов на алгоритмическом языке.

Процедура и функция - это именованная последовательность описаний и операторов.

Прямой доступ предполагает, что файл представляет собой линейную последовательность блоков.

Семантика - определение смысла и правила использования тех элементов языка, для которых были даны синтаксические определения.

Символы языка - это основные неделимые знаки, в терминах которых пишутся все тексты на языке.

Синтаксис - правила построения элементов языка.

Следование - это конструкция, представляющая собой последовательное выполнение двух или более операций.

Статической переменной (статически размещенной) называется описанная явным образом в программе переменная, обращение к которой осуществляется по имени. Место в памяти для размещения статических переменных определяется при компиляции программы.

Строки в языке Паскаль - это последовательность символов, записанная между апострофами.

Структурированная программа (или подпрограмма) - это программа, составленная из фиксированного множества базовых конструкций.

Физические файлы - это файлы на внешних устройствах.

Цикл - это конструкция, имеющая линии управления, ведущие к предыдущим операциям или развилкам.

Элементарные конструкции - это минимальные единицы языка, имеющие самостоятельный смысл. Они образуются из основных символов языка.


12.17. Библиографический список

1. Абрамов С.А., Зима Е.В. Начала программирования на языке Паскаль.- М.:Наука,1987.-112 с.

2. Абрамов С.А., Зима Е.В. Начала информатики. - М.:Наука,1989.-256 с.

3. Абрамов В.Г., Трифонов Н.П., Трифонова Г.Н. Введение в язык Паскаль. - М.: Наука, 1988.

4. Задачи по программированию. / С.А. Абрамов, Г.Г. Гнездилова,
Е.Н. Капустина, М.И. Селюн. - М.:Наука, 1988.-224 с.

5. Поляков Д.Б., Круглов И.Ю. Программирование в среде Турбо Паскаль (версия.5).- М.:Изд-во МАИ, 1992.-576 с.

6. Васюкова Н.Д., Тюляева В.В. Практикум по основам программирования. Язык ПАСКАЛЬ: Учеб. пособие для учащихся сред. спец. учеб. заведений. - М.: Высшая школа, 1991. -160 с.

7. Фаронов В.В. Основы Турбо Паскаля.-М.: Учебно-инженерный центр "МВТУ-ФЕСТО ДИДАКТИК", 1992.-304 с.

8. Зуев Е.А. Программирование на языке TURBO PASCAL 6.0, 7.0. -М.:Веста,Радио и Связь, 1993.-384 с.

9. Йенсен К., Вирт Н. Паскаль. Руководство для пользователя. - М.: Финансы и статистика, 1989.

10. Джонс Ж., Харроу К. Решение задач в системе Турбо Паскаль. - М.: Финансы и статистика, 1991.

10. Джонс Ж., Харроу К. Решение задач в системе Турбо Паскаль. - М.: Финансы и статистика, 1991.


12.15. Контрольные вопросы

  1. Что такое программа?
  2. Что такое оператор языка?
  3. Какие символы допускает Турбо-Паскаль?
  4. Какое количество символов может содержать идентификатор?
  5. С какими типами данных работает Паскаль?
  6. Какие допускаются способы хранения символьных массивов?
  7. Какого типа данные составляют множества?
  8. Из чего состоит запись?
  9. Что такое указатель?
  10. Что представляет собой выражение-константа ?
  11. К каким типам данных применимы операции битовой арифметики?
  12. Из каких разделов состоит программа на языке Паскаль?
  13. Какими символами отделяются друг от друга операторы?
  14. Что такое ключ компиляции?
  15. Какие операторы могут выполняться несколько раз в одной и той же последовательности?
  16. Что такое подпрограмма? Какие типы подпрограмм существуют в Паскале?
  17. Чем отличается модуль от программы?
  18. Что такое рекурсия?
  19. Какие операции выполняются с данными файлового типа?
  20. Чем отличаются статические и динамические переменные?
  21. В чем особенность структурного программирования?
  22. Что такое объектно-ориентированное программирование?
  23. Что такое инкапсуляция?


12.14. Практические задачи на программирование

Задачи на программирование алгоритмов линейной структуры

1. Даны два числа a и b. Получить их сумму, разность и произведение.

2. Даны действительные числа x и y. Получить (|x| – |y|) / (1 + |x·y|).

3. Дана длина ребра куба. Найти площадь грани, площадь полной поверхности и объем этого куба.

4. Даны два действительных положительных числа. Найти среднее арифметическое и среднее геометрическое этих чисел.

5. Даны катеты прямоугольного треугольника. Найти его гипотенузу и площадь.

6. Определить периметр правильного n-угольника, описанного около окружности радиуса r.

7. Даны x, y, z. Вычислить a, b, если

а) [image] ;

б) [image] ;

в) [image] ;

г) [image] ;

д) [image] ;

е) [image] ;

ж) [image] .

8. Дана сторона равностороннего треугольника. Найти площадь этого треугольника.

9. Известна длина окружности. Найти площадь круга, ограниченного этой окружностью.

10. Найти площадь кольца, внутренний радиус которого равен 20, а внешний – заданному числу r (r>20).

11. Найти площадь равнобочной трапеции с основаниями a и b и углом α при большем основании a.

12. Вычислить расстояние между двумя точками с координатами x1, y1 и x2, y2.

13. Треугольник задан координатами своих вершин. Найти:

а) периметр треугольника;
б) площадь треугольника.

14. Найти площадь сектора, радиус которого равен 3,7, а дуга содержит заданное число радиан φ.

15. Дано действительное число a. Не пользуясь никакими другими арифметическими операциями, кроме умножения, получить:

а) a4 за две операции;
б) a6 за три операции;
в) a7 за четыре операции;
г) a8 за три операции;
д) a9 за четыре операции;
е) a10 за четыре операции;
ж) a13 за пять операций;
з) a15 за пять операций (указание:a15=(a5)3);
и) a21 за шесть операций;
к) a28 за шесть операций;
л) a64 за шесть операций.

16. Дано действительное число a. Не пользуясь никакими другими арифметическими операциями, кроме умножения, получить:

а) a3 и a10 за четыре операции;
б) a4 и a20 за пять операций;
в ) a5 и a13 за пять операций;
г) a5 и a19 за шесть операций;
д) a2 и a5, a17 за шесть операций;
е) a4 ,a12, a28 за шесть операций.


Задачи на программирование алгоритмов ветвящейся структуры

1. Даны действительные числа x, y. Получить:

а) max(x,y);
б) min(x,y);
в) max(x,y), min(x,y).

2. Даны действительные числа x, y, z. Получить:

а) max(x,y,z);
б) min(x,y,z);
в) max(x,y,z), min(x,y,z).

3. Даны действительные числа x, y, z. Вычислить:

а) max2(x+y+z,xyz);
б) min(x+y+z/2,xyz)+1;
в) min(x+5y+z,2x-y+z) + max(x+y+z,xy+z).

4. Даны действительные числа a, b, c. Удвоить эти числа, если a > b > c, и заменить их абсолютными значениями, если это не так.

5. Даны действительные числа x, y. Вычислить z:

6. Даны два действительных числа. Вывести первое число, если оно больше второго, и оба числа, если это не так.

7. Даны два действительных числа. Заменить первое число нулем, если оно меньше или равно второму, и оставить без изменения в противном случае.

8. Даны действительные числа x, y (x ¹ y). Меньшее из этих двух чисел заменить их полусуммой, а большее – их удвоенным произведением.

9. Даны действительные числа x, y, z. Выяснить, существует ли треугольник с длинами сторон x, y, z.

10. Даны действительные числа a, b, c (a ¹ 0). Выяснить, имеет ли уравнение ax2 + bx + c = 0 действительные корни. Если действительные корни имеются, то найти их. В противном случае ответом должно служить сообщение, что действительных корней нет.

11. Дано действительное число a. Вычислить f(a), если

а)

б)

в)

в)

12. Дано действительное число a. Для функций f(x), графики которых представлены на рис. 2, вычислить f(a).

13. Даны действительные числа x, y. Определить, принадлежит ли точка с координатами x, y заштрихованной части плоскости (рис. 3).

14. Дано натуральное число n (n < 100), определяющее возраст человека (в годах). Дать для этого числа наименования "год", "года" или "лет": например, год, 23 года,5 лет и т.д.

15. Дата вводится в формате "дд.мм.гг". Записать словесно название месяца и полностью указать год. Например, для 10.02.96 вывести 10 февраля 1998 года.

16. Дано натуральное число n. Определить является ли число четным.

а б

в г

д е

ж з

и к

л м

Рис. 2

а б

в г

д е

ж з

и к

л м

Рис. 3

17. Сравнить между собой значение величины x и y. Вывести на печать результат сравнения в виде "x > y", "x = y" или "x < y".

18. Определить, какая из двух точек T1(x1,y1) или T2(x2,y2) расположена ближе к началу координат. Вывести на печать координаты этой точки.

19. Определить, какая из двух фигур - круг или квадрат имеет большую площадь. Известно, что сторона квадрата равна a, радиус круга r. Вывести на печать название и значение площади большей фигуры.


Задачи на программирование алгоритмов циклической структуры

1. Дано натуральное n. Вычислить:

а) 2n;
б) n!;
в)
г)
д)

2. Даны действительное число a, натуральное число n. Вычислить:

а) an;
б) a× (a + 1) × … × (a + n -1);
в)
г) a× (a – n) × (a – 2n) ×…× (a – n2);

3. Вычислить:

(1 + sin 0,1) + (1 + sin 0,2) + … + (1 + sin 10).

4. Дано действительное a. Найти:

а) среди чисел 1, [image] [image] первое, большее a;
б) такое наименьшее n, что [image] .

5. Даны натуральное n, действительное x. Вычислить:

а) sin x + sin2 x + … + sinn x;
б) sin x + sin x2 + … + sin xn;
в) sin x + sin sin x + … + sin sin sin x +sin sin … sin x.

6. Дано натуральное число n.

а) Сколько цифр в числе n?
б) Чему равна сумма его цифр?
в) Найти первую цифру числа n?

7. Даны натуральные числа n, m. Получить сумму m последних цифр числа n.

8. Дано натуральное число n. Выяснить, входит ли цифра 3 в запись числа n2.

9. Даны натуральное число n, действительное число x. Вычислить:

а) [image] б) [image] в)

10. Дано целое число m >. Получить наибольшее целое k, при котором
4k < m.

11. Дано натуральное число n. Получить наименьшее число вида 2r, превосходящее n.

12. Дано натуральное число n. Вычислить

1×2 + 2×3×4+ … + n×(n + 1)×…× 2n.

13. Вычислить:

а) [image] б) [image] в) [image] г) [image] д)

14. Даны натуральное число n, действительное число x. Вычислить:

а) [image] б) [image] в) [image] г)

15. Дано натуральное число n. Вычислить произведение первых n сомножителей:

a) [image] ; б)

16. Вычислить бесконечную сумму с заданной точностью e (e > 0). Считать, что требуемая точность достигнута, если вычислена сумма нескольких первых слагаемых и очередное слагаемое оказалось по модулю меньше, чем e, - это и все последующие слагаемые можно уже не учитывать. Вычислить:

а) [image] б) [image] в) [image] г) [image] .

17. Вычислить сумму положительных и произведение отрицательных значений функции z = cos(nx+a)×sin(nx-a), где n=1,2,…,10.


Задачи на использование одномерных массивов

1. Даны натуральное число n, массив A[n]. Вычислить:

а) a1 + … + an ; б) a1 ×….× an; в) sin |a1 + … + an|; г) |a1|×|a2|× … × |an|;
д) a1 + … + an и a1 × a2 × …× an; е) a1, a1+a2, …, a1+a2+ … + an;
ж) a1×a1, a1×a2, a1×a3, …, a1×an ; з) |a1|, |a1 + a2|, |a1 + … + an| ;
и) -a1, a2, -a3, …, (-1)n×an .

2. Дано натуральное число n. Получить последовательность b1, …, bn, где при i = 1, 2, …, n значение bi равно:

а) i ; б) i2 ; в) i! ; г) 2i+1 ; д) 2i + 3i+1 ; е) (-1)i×3i; ж) 1+1/2+…1/i; з) 2i /i!.

3. Вычислить значения многочлена x3 - 9x2 + 3,2x - 7,5 для x = 0, 1, …, 5.

4. Даны натуральное число n, действительные числа a, b (a¹b). Получить r1, r2, …, rn, где ri = a + ih, h = (b - a) / n.

5. Получить таблицу температур по Цельсию от 0 до 100 градусов и их эквивалентов по шкале Фаренгейта, используя для перевода формулу

.

6. Вычислить значения функции y = 5x3 - 3x2 + 5 для значений x, изменяющихся -3 … 1, с шагом 0,1.

7. Даны натуральные числа i, n, действительные числа a1, …,an (i £ n). Найти среднее арифметическое всех чисел a1, …, an, кроме ai.

8. Даны действительные числа a1, a2, … Известно, что a1>0 и что среди a2, a3,… есть хотя бы одно отрицательное число. Пусть а1, …, аn – члены данной последовательности, предшествующие первому отрицательному члену (n заранее неизвестно). Получить:

     а) a1 + a2 + … + an;
б) среднее арифметическое a1,…, an;
в) a1, a1a2, a1a2a3,
  …, a1a2 … an;               г) a1a2
  + a2a3+ … + an-1an + ana1;
д) (-1)nan;
  е) n + an;
ж) |a1 – an|.

9. Даны натуральное число n, действительные числа a1, …, an. Получить числа b1, …, bn, которые связаны с a1, …, an следующим образом:

b1 = a1, bn = an, bi = (ai+1 – ai)/3, i=2, …, n-1.

10. Даны натуральные числа x, y1, …, y100. (y1 < y2 … < y100, y1 < x < y100). Найти натуральное k, при котором yk-1 < x £ yk.

11. Даны натуральные числа n, a1,…, an. Определить количество членов ak последовательности a1, …, a:

а) являющихся нечетными числами;
б) кратных 3 и не кратных 5;
в) являющихся квадратами четных чисел;
г) имеющих четные порядковые номера и являющихся нечетными числами.

12. Даны целые числа а1, …, а50. Получить сумму тех чисел данной последовательности, которые а) кратны; б) нечетны и отрицательны.

13. Даны натуральное число n, целые числа а1, …, аn. Найти количество и сумму тех членов данной последовательности, которые делятся на 5 и не делятся на 7.

14. Даны натуральные числа n, p, целые числа а1, …, аn. Получить произведение членов последовательности а1, …, аn, кратных p.

15. Даны натуральное число n, действительные числа а1, …, аn. Получить удвоенную сумму всех положительных членов последовательности а1, …, аn.

16. Даны натуральное число n, действительные числа х1, …, хn. В последовательности х1, …, хn все члены, меньшие двух, заменить нулями. Кроме того, получить сумму членов, принадлежащих отрезку [3,7], а также число таких членов.

17. Даны натуральное число n, целые числа а1, …, аn. Получить сумму положительных и число отрицательных членов последовательности а1, …, аn.

18. Даны натуральное число n, целые числа а1, …, аn. Заменить все большие семи члены последовательности а1, …, аn числом 7. Вычислить количество таких членов.

19. Даны целые числа а1, …, а45. Получить число отрицательных членов последовательности а1, …, а35 и число нулевых членов всей последовательности а1, …, а45.

20. Даны натуральное число n, целые а, х1, …, хn. Если в последовательности х1, …, хn есть хотя бы один член, равный а, то получить сумму всех членов, следующих за первым таким членом; в противном случае ответом должно быть число -10.

21. Даны натуральное число n, действительные числа а1, …, аn.

Получить:

а) max(а1, …, аn); б) min(а1, …, аn); в) max(а2, a4, …); г) min(a1, a3, …);
д) min(а2, a4, …) + max (|а1|, |a3|, …); е) max( |a1|, …, |an|).

22. Даны натуральное число n, действительные числа а1, …, аn.

а) Верно ли, что отрицательных членов в последовательности а1, …, аn больше, чем положительных?
б) Верно ли, что наибольший член последовательности а1, …, аn по модулю больше единицы?

23. Даны натуральное число n, действительные числа а1, …, аn. В последовательности а1, …, аn определить число соседств:

а) двух положительных чисел;
б) двух чисел разного знака;
в) двух чисел одного знака, причем модуль первого числа должен быть больше модуля второго числа.

24. Даны целые числа c1, …, c80. Имеются ли в последовательности
c1, …, c80:

а) два идущих подряд нулевых члена;
б) три идущих подряд нулевых члена?

25. Даны целые числа a1, a2, … Известно, что a1 > 0 и что среди a2,a3,… есть хотя бы одно отрицательное число. Пусть a1,…,an – члены данной последовательности, предшествующие первому отрицательному члену (n заранее неизвестно). Получить:

a) max (а1, …, аn ); б) min (a1,2a2, …,nan); в) min (a1+a2, a2+a3, …,an-1+an);
г) количество четных среди а1, …, аn; д) max(a1, a1+a2, …, a1+a2+ … + an);

26. Даны натуральное число n, действительные числа а1, …, аn. Выяснить, является ли последовательность а1, …, аn упорядоченной по убыванию.


Задачи на использование двумерных массивов

1. Даны целые числа a1, a2, a3. Получить целочисленную матрицу B[3x3], для которой bij = ai - 3aj.

2. Даны действительные числа a1, …, a10, b1, …, b20. Получить действительную матрицу C[20x10], для которой cij = aj / (1 +│bi│).

3. Получить A[10x12] – целочисленную матрицу, для которой

aij = i + 2j.

4. Даны натуральное число n, действительная матрица размера nx9. Найти среднее арифметическое:

а) каждого из столбцов;
б) каждого из столбцов, имеющих четные номера.

5. Дано натуральное число n. Выяснить, сколько положительных элементов содержит матрица A[nxn], если

а) aij = sin (i + j/2);
б) aij = cos (i2 + n);
в) aij = sin (i2 – j2/n).

6. Дана действительная матрица размера n x m, в которой не все элементы равны нулю. Получить новую матрицу путем деления всех элементов данной матрицы на ее наибольший по модулю элемент.

7. Дана действительная квадратная матрица порядка 12. Заменить нулями все ее элементы, расположенные на главной диагонали и выше нее.

8. Даны действительные числа x1, …, x8. Получить действительную квадратную матрицу порядка 8:

a) [image] б) [image] в)

9. Дана действительная матрица размера nxm. Определить числа b1, …,bn, равные соответственно:

а) суммам элементов строк;
б) произведениям элементов строк;
в) наименьшим значениям элементов строк;
г) значениям средних арифметических элементов строк;
д) разностям наибольших и наименьших значений элементов строк.

10. Даны натуральное число n, действительная матрица A[nxn]. Получить последовательность элементов главной диагонали a11, a22, …, ann.

11. Все элементы с наибольшим значением в данной целочисленной квадратной матрице порядка 10 заменить нулями.

12. Дана действительная матрица размера 6x9. Найти среднее арифметическое наибольшего и наименьшего значений ее элементов.

13. Дана действительная матрица размера nxm. Найти сумму наибольших значений элементов ее строк.

14. В данной действительной квадратной матрице порядка n найти сумму элементов строки, в которой расположен элемент с наименьшим значением. Предполагается, что такой элемент единственный.

15. В данной действительной матрице размера 6x9 поменять местами строку, содержащую элемент с наибольшим значением, со строкой, содержащей элемент с наименьшим значением. Предполагается, что элементы единственны.

16. Дана действительная матрица размера nxm. Получить последовательность b1, …, bn, где bk – это

   а) наибольшее из значений элементов k-й строки;
б) сумма наибольшего и наименьшего из значений элементов k-й строки;
в) число отрицательных элементов в k-й строке;
г) произведение квадратов тех элементов k-й строки, модули которых принадлежат
  отрезку [1; 1,5].

17. Дана целочисленная квадратная матрица порядка n. Найти номера строк:

а) все элементы которых – нули;
б) элементы в каждой из которых одинаковы;
в) все элементы которых четны;
г) элементы каждой из которых образуют монотонно убывающую последовательность.

18. Дана действительная квадратная матрица порядка 10. В строках с отрицательным элементом на главной диагонали найти:

а) сумму всех элементов;
б) наибольший из всех элементов.

19. Дана квадратная матрица порядка 10. Заменить элементы, расположенные под главной диагональю, максимальным элементом.


Задачи на обработку строк

1. Дана строка символов S. Подсчитать, сколько раз среди символов строки встречается буква я.

2. Дана строка символов S. Подсчитать:

а) сколько раз среди данных символов встречается символ + и сколько раз символ *;
б) общее число вхождений символов +, -, *, / в строке.

3. Дана строка символов S. Преобразовать строку, заменив в ней:

а) каждую точку многоточием (т.е. тремя точками);
б) каждую из групп стоящих рядом точек одной точкой;
в) каждую из групп стоящих рядом точек многоточием (т.е. тремя точками).

4. Дана строка символов S. Выяснить, имеются ли в строке такие члены последовательности si, si+1, что si – это запятая, а si+1 – тире.

5. Дана строка символов S. Известно, что в строке есть по крайней мере одна запятая. Найти такое натуральное i, что

а) si – первая по порядку запятая;
б) si – последняя по порядку запятая.

6. Дана строка символов S. Известно, что символ s1 отличен от восклицательного знака и что среди s2, s3, … есть по крайней мере один восклицательный знак. Пусть s1, …, sn – символы данной строки, предшествующие первому восклицательному знаку (n заранее неизвестно).

а) Определить количество пробелов среди s1, …, sn.
б) Выяснить, входит ли в последовательность s1, …, sn буква ю.
в) Выяснить, верно ли, что среди s1, …, sn имеются все буквы, входящие в слово шина.
г) Выяснить, имеется ли среди s1, …, sn пара соседствующих букв он или но.

7. Дана строка символов S. Преобразовать строку, удалив каждый символ * и повторив каждый символ, отличный от *.

8. Дана строка символов S, в которой есть символ двоеточие.

а) Получить все символы, расположенные до первого двоеточия включительно.
б) Получить все символы, расположенные после первого двоеточия.
в) Получить все символы, расположенные между первым и вторым двоеточием. Если второго двоеточия нет, то получить все символы, расположенные после единственного имеющегося двоеточия.

9. Дана строка символов S.

а) Подсчитать наибольшее количество идущих подряд пробелов.
б) Выяснить, верно ли, что в строке S имеются пять идущих подряд букв е.

10. Дана строка символов S. Исключить из строки группы символов, расположенные между (,). Сами скобки тоже должны быть исключены. Предполагается, что внутри пары скобок нет других скобок.

11. Дана строка символов S. Группы символов, разделенные пробелами (одним или несколькими) и не содержащие пробелов внутри себя, будем называть словами.

а) Подсчитать количество слов в данной последовательности.
б) Подсчитать количество букв а в последнем слове данной последовательности.
в) Найти количество слов, начинающихся с буквы в.
г) Найти какое-нибудь слово, начинающееся с буквы м.
д) Найти длину самого короткого слова.


Задачи на использование типа "запись"

1. Создать тип с описанием товара: код, наименование, цена за единицу товара, количество и сумма.

а) Вывести наименование и цену товаров, коды которых лежат в диапазоне 100 … 120.
б) Подсчитать итоговые суммы по каждому товару.
в) Вывести название товара с наибольшей ценой.

2. Определить тип для представления анкеты школьника, включающей в себя ФИО, возраст, номера школы и класса и оценки по каким-то пяти предметам. Выдать сведения о школьнике с наивысшим средним баллом.

3. Ввести информацию о десяти студентах: фамилия, пол, год рождения, год поступления, оценки по шести предметам.

а) Подсчитать число студентов мужского пола, родившихся в 1974 году.
б) Вывести анкетные данные студентов-отличников.
в) Вывести анкетные данные студентов, получивших оценки 2.
г) Вычислить средний балл группы и распечатать список студентов, имеющих средний балл ниже среднего балла группы.
д) Упорядочить список студентов по среднему баллу.
е) Упорядочить список студентов по фамилии.

4. Описать тип с данными о сотрудниках (структуру записи продумайте самостоятельно).

а) Вывести список сотрудников, проживающих по улице "Победа".
б) Подсчитать количество сотрудников, имеющих детей.
в) Подсчитать количество подарочных наборов, которые необходимо приобрести для детей сотрудников.
г) Начислить премию в размере 50% от оклада сотрудникам, стаж работы которых на данном предприятии превышает 10 лет.
д) Напечатать список сотрудников, которые в текущем году отмечают круглую дату.
е) Напечатать список сотрудников, у которых день рождения в августе.

5. Точки заданы координатами x и y. Выдать координаты точки, наиболее близко расположенной к началу координат.

6. Вершина характеризуется названием и высотой. Выдать название самой высокой вершины.

7. Круг задается радиусом и координатами центра. Определить, найдется ли среди данных десяти кругов круг, лежащий внутри данного круга.


Задачи на построение процедур и функций

1. Даны действительные числа s, t. Получить f(t,-3s,3.22) + f(5.2,t,s-t),

где f (a,b,c) =

2. Даны действительные числа s, t. Получить g(1.2,s) + g(t,s) - g(2s-1,st),

где g(a,b) =

3. Даны действительные числа a, h, натуральное число n. Вычислить

f(a) + 2f(a + h) + … + 2f(a + (n-1)h) + f(a + nh),

где f(x) = (x2 +1) cos2 x.

4. Даны действительные числа a, b, c. Получить

5. Даны действительные числа a, b. Получить

u = min(a, b), v = min(ab, a + b), x = min(u2 + v, 3.14)

6. Даны действительные числа s, t. Получить

h(s, t) + max(h2(s-t, st), h3(s-t, s+t)) + h(1,1),

где

h (a,b) =

7. Даны действительные числа x1, y1, x2, y2, …, x10, y10. Найти периметр десятиугольника, вершины которого имеют соответственно координаты (x1, y1), (x2, y2), …, (x10, y10). (Определить функцию вычисления расстояния между двумя точками, заданными своими координатами).

8. Даны натуральное число n, действительные числа x1, y1, x2, y2, …, xn, yn. Найти площадь n-угольника, вершины которого при некотором последовательном обходе имеют координаты (x1, y1), (x2, y2),…, (xn, yn). (Определить функцию вычисления площади треугольника по координатам его вершин.)

9. Составить функцию, позволяющую определить позицию самого правого вхождения заданного символа в исходную строку. Если строка не содержит символа, результатом работы процедуры должна быть -1.

10. Составить процедуру, изменяющую в исходной строке символов все единицы нулями и все нули единицами. Замена должна выполняться, начиная с заданной позиции строки.


Задачи на работу с файлами

1. Дан файл f, компоненты которого являются действительными числами. Найти:

   а) сумму компонент файла f;
б) произведение компонент файла f;
в) сумму квадратов компонент файла f;
г) модуль суммы и квадрат произведения компонент файла
f;
д) последнюю компоненту файла.

2. Дан файл f, компоненты которого являются действительными числами. Найти:

а) наибольшее из значений компонент;
б) наименьшее из значений компонент с четными номерами;
в) сумму наибольшего и наименьшего из значений компонент;
г) разность первой и последней компонент файла.

3. Дано натуральное n. Записать в файл g целые числа b1, …, bn, где при i = 1, 2, …, n значение bi равно:

а) i ; б) i2 ; в) i! ; г) 2i+1 ; д) 2i + 3i+1 ; е) (-1) i ×3i;
ж) [image] ; з) [image] ;

4. Даны символьные файлы f1и f2. Переписать с сохранением порядка следования компоненты файла f1 в файл f2, а компоненты файла f2 - в файл f1. Использовать вспомогательный файл h.

5. Дан файл f, компоненты которого являются целыми числами. Получить в файле g все компоненты файла f:

а) являющиеся четными числами;
б) делящиеся на 3 и не делящиеся на 7.

6. Дан файл f, компоненты которого являются целыми числами. Записать в файл g все четные числа файла f, а в файл h - все нечетные. Порядок следования чисел сохраняется.

7. Дан символьный файл f. Записать в файл g компоненты файла f в обратном порядке.

8. Даны символьные файлы f и g. Записать в файл h сначала компоненты файла f, а затем - компоненты файла g с сохранением порядка.


Поисковая система электронного учебника по информатике

Введите одно или несколько ключевых слов для поиска:

Параметры поиска:
 область поиска:
ключевые слова:

Замечание! Если поисковая система электронного учебника не работает, то возможно в настройках браузера отключены параметры, связанные с выполнением сценариев на странице.


СТАНДАРТЫ СПЕЦИАЛЬНОСТЕЙ ПО ДИСЦИПЛИНЕ "ИНФОРМАТИКА"

СТАНДАРТЫ РАЗЛИЧНЫХ СПЕЦИАЛЬНОСТЕЙ ПО ДИСЦИПЛИНЕ
"ИНФОРМАТИКА"

Специальность 011600 - "Биология"

Понятие информации, общая характеристика процессов сбора, передачи, обработки и накопления информации; технические и программные средства реализации информационных процессов; модели решения функциональных и вычислительных задач; алгоритмизация и программирование; языки программирование высокого уровня; базы данных; программное обеспечение и технологии программирования; локальные и глобальные сети ЭВМ; основы защиты информации и сведений, составляющих государственную тайну; методы защиты информации; компьютерный практикум. 200 часов.

Cпециальность 032400 - "Биология с дополнительной специальностью химия"

Понятие информации, общая характеристика процессов сбора, передачи, обработки и накопления информации; технические и программные средства реализации информационных процессов, модели решения функциональных и вычислительных задач, языки и программирование, алгоритмы, компьютерный практикум. 72 часа.

Специальность 060400 - "Финансы и кредит"

Понятие информации, общая характеристика процессов сбора, передачи, обработки и накопления информации; технические и программные средства реализации информационных процессов; инструментарии решения функциональных задач; алгоритмизация и программирование; языки программирования высокого уровня, базы данных; программное обеспечение ЭВМ и технологии программирования; локальные и глобальные сети ЭВМ; основы и методы защиты информации; компьютерный практикум. 200 часов.

Специальность 060500 - "Бухгалтерский учет, анализ и аудит"

Понятие информации, общая характеристика процессов сбора, передачи, обработки и накопления информации; технические и программные средства реализации информационных процессов; инструментарии функциональных задач; алгоритмизация и программирование; языки программирования высокого уровня, базы данных; программное обеспечение ЭВМ и технологии программирования; локальные и глобальные сети ЭВМ; основы и методы защиты информации; компьютерный практикум. 200 часов.

Специальность 060600 - Мировая экономика

Понятие информации, общая характеристика процессов сбора, передачи, обработки и накопления информации; технические и программные средства реализации информационных процессов; инструментарии решения функциональных задач; алгоритмизация и программирование; языки программирования высокого уровня, базы данных; программное обеспечение ЭВМ и технологии программирования; локальные и глобальные сети ЭВМ; основы и методы защиты информации; компьютерный практикум. 200 часов.

Специальность 060800 - "Экономика и управление на предприятии (по отраслям)"

Понятие информации, общая характеристика процессов сбора, передачи, обработки и накопления информации; технические и программные средства реализации информационных процессов; модели решения функциональных и вычислительных задач; алгоритмизация и программирование; языки программирования высокого уровня; базы данных; программное обеспечение и технологии программирования; локальные и глобальные сети ЭВМ; основы защиты информации и сведений, составляющих государственную тайну; методы защиты информации; компьютерный практикум. 200 часов.

Специальность 061100 - "Менеджмент организации"

Понятие информации. Общая характеристика процессов сбора, передачи, обработки и накопления информации; технические и программные средства реализации информационных процессов; модели решения функциональных и вычислительных задач: алгоритмизация и программирование; языки программирования высокого уровня; базы данных; программное обеспечение и технологии программирования; локальные и глобальные сети ЭВМ. Основы защиты информации и сведений, методы защиты информации. Компьютерный практикум. 200 часов.

Специальность 350500 - "Социальная работа"

Понятие информации, общая характеристика процессов сбора, передачи, обработки и накопления информации; технические и программные средства реализации информационных процессов; модели решения функциональных и вычислительных задач; алгоритмизация и программирование; языки программирования высокого уровня; базы данных; программное обеспечение и технологии программирования; локальные и глобальные сети ЭВМ; компьютерный практикум. 114 часов.

Специальность 061000 - "Государственное и муниципальное управление"

Понятие информации. Общая характеристика процессов сбора, передачи, обработки и накопления информации; технические и программные средства реализации информационных процессов; модели решения функциональных и вычислительных задач: алгоритмизация и программирование; языки программирования высокого уровня; базы данных; программное обеспечение и технологии программирования; локальные и глобальные сети ЭВМ. Основы защиты информации и сведений, методы защиты информации. Компьютерный практикум. 100 часов.

Специальность 020400 - "Психология"

Назначение и устройство персонального компьютера; понятие формализации, алгоритмизации, программирования; офисные приложения; работа с текстом; защита информации; компьютерные сети; интернет; поиск информации; психологические ресурсы интернет; электронные базы данных в психологии; компьютерные статистические системы. 100 часов.


Тест на знание СУБД Microsoft Access 2000

1. Что такое база данных?

Любой текстовый файл
Организованная структура для хранения информации
Любая информация, представленная в табличной форме
Любая электронная таблица

2. Какое из перечисленных свойств не является свойством реляционной базы?

Несколько узлов уровня связаны с узлом одного уровня
Порядок следования строк в таблице произвольный
Каждый столбец имеет уникальное имя
Для каждой таблицы можно определить первичный ключ

3. Что такое SQL?

Язык разметки базы данных
Структурированный язык запросов
Язык программирования низкого уровня
Язык программирования высокого уровня

4. Какая база данных строится на основе таблиц и только таблиц?

Сетевая
Иерархическая
Реляционная

5. Какой из ниже перечисленных элементов не является объектом MS Access?

Таблица
Книга
Запрос
Макрос
Отчет

6. В какой модели баз данных существуют горизонтальные и вертикальные связи между элементами?

Сетевой
Иерархической
Реляционной
Объектно-ориентированной

7. Какой из ниже перечисленных запросов нельзя построить?

Простой
Перекрестный
На создание таблицы
Параллельный
Записи без подчиненных

8. Что такое поле?

Столбец в таблице
Окно конструктора
Текст любого размера
Строка в таблице

9. Что такое запрос?

Окно конструктора
Связанная таблица
Главная таблица
Средство отбора данных

10. В чем заключается функция ключевого поля?

Однозначно определять таблицу
Однозначно определять запись
Определять заголовок столбца таблицы
Вводить ограничение для проверки правильности ввода данных

11. Из чего состоит макрос?

Из набора тегов
Из совокупности операторов Visual Basic
Из набора гиперссылок
Из набора макрокоманд

12. Какого раздела не существует в конструкторе форм?

Заголовка
Верхнего колонтитула
Область данных
Примечание
Итоговый

Нажмите на кнопку для завершения теста:


Тест по основам алгоритмизации и программирования

1. Отметьте основные способы описания алгоритмов.

Блок-схемный
Словесно-формульный
С помощью сетей Петри
С помощью нормальных форм
С помощью граф-схем

2. Пронумеруйте в правильной последовательности этапы решения на ЭВМ научно-инженерных задач

Отладка программы
Решение задачи на ЭВМ и анализ результатов
Математическое описание задачи
Постановка задачи
Выбор и обоснование метода решения
Составление программы
Алгоритмизация вычислительного процесса

3. На каком из этапов устраняются синтаксические и логические ошибки в программе?

Алгоритмизация вычислительного процесса
Отладка программы
Составление программы
Решение задачи на ЭВМ и анализ результатов

4. Что такое ассемблер?

машинный язык
язык высокого уровня
символический язык, близкий к соответствующему машинному языку
интерпретируемый язык

5. Что из ниже перечисленного не является стилем программирования?

Процедурный
Методологический
Объектно-ориентированный
Логический
Функциональный

6. Отметьте простейшие алгоритмические структуры.

Последовательность двух или более операций
Выбор направления
Многовариантный выбор
Повторение

7. Какое из ниже перечисленных свойств не относится к основным свойствам алгоритма?

Результативность
Массовость
Корректность
Определенность

Нажмите на кнопку для завершения теста:


Тест по использованию архивации данных

1. К каким типам файлов можно применять методы сжатия с потерей информации?

Текстовым документам
Графическим данным
Базам данных
Программному коду

2. От чего не зависит степень сжатия данных?

От магнитного носителя, на котором находятся данные
От используемого архиватора
От типа исходного файла
От метода сжатия

3. Какой формат указывает на то, что сжатие графического файла произошло с потерей информации?

.GIF
.JPG
.TIF
.PCX

4. Какую группу файлов нельзя архивировать средствами MS-DOS?

PISMO.DOC, DOCUMENT.DOC, INSTALL.LOG
FORMA.EXE, PAYWIN.EXE, OTCHET.DOC, VEDOMOST.TXT
RISUNOK.DOC, GRAFIKA.TXT, DC120_32.DLL
KNIGA.XLS, INTERACTIV.DOC, TEST.TXT

5. Каким расширением характеризуются самораспаковывающиеся архивы?

.ZIP
.EXE
.ARJ
.RAR

6. Какой архиватор при создании распределенных архивов именует тома одинаковыми именами?

WinRAR
WinARJ
WinZIP
Lha

7. На каком принципе основан алгоритм RLE?

предварительный просмотр и анализ исходных данных для индивидуальной настройки алгоритма сжатия
код данных заменяется на псевдокод
указывается код данных и коэффициент повтора

Нажми на кнопку для завершения теста:


Тест по компьютерным вирусам и антивирусным программам

1. Какой тип файлов компьютерный вирус не только портит, но и заражает?

Графические файлы
Программные файлы
Информационные файлы без данных
Медиа-файлы

2. Какие разновидности вирусов перехватывают обращения операционной системы к пораженным файлам?

Троянские вирусы
Паразитические вирусы
Вирусы черви
Вирусы-невидимки (стелс-вирусы)

3. Самые опасные вирусы, разрушающие загрузочный сектор - это:

Троянские вирусы
Паразитические вирусы
Вирусы черви
Вирусы-невидимки (стелс-вирусы)

4. Резидентные вирусы:

Активны до выключения компьютера
Активны какое-то ограниченное время
Активизируются после нажатия на определенную компбинацию клавиш

5. Какого типа антивирусные программы способны обнаруживать и лечить зараженные файлы?

Сторожа
Детекторы
Ревизоры
Доктора

6. Какого типа антивирусные программы способны идентифицировать только известные им вирусы и требуют обновления антивирусной базы?

Сторожа
Детекторы
Ревизоры
Доктора

7. Какого типа антивирусные программы подают сигнал тревоги, но лечить неспособны?

Сторожа
Детекторы
Ревизоры
Доктора

8. Антивирусная программа Dr. Web - это:

Программа-сторож
Программа-детектор
Программа-ревизор
Программа-доктор

9. Компьютер не может заразиться вирусом, если Вы:

Запустили зараженный исполняемый файл
Вставили в дисковод зараженную дискету
Установили зараженный драйвер
Открыли для редактирования зараженный документ MS Word

Нажми на кнопку для завершения теста:


Тест на знание табличного процессора Microsoft Excel 2000

1. Для чего предназначено приложение MS Excel?

для работы с числовыми данными
для обработки графических объектов
для создания презентации
для набора текстов

2. Как называется документ MS Excel?

Документ
Книга
Таблица
Лист

3. Что является минимальным элементом для хранения данных?

Ячейка
Строка
Столбец
Лист

4. Чем нумеруются столбцы на листе рабочей книги MS Excel?

Буквами латинского алфавита
Буквами русского алфавита
Цифрами
Специальными символами

5. Чем нумеруются строки на листе рабочей книги MS Excel?

Буквами латинского алфавита
Буквами русского алфавита
Цифрами
Специальными символами

6. Что является разделителем между целой и дробной частью числа в MS Excel?

точка
слэш (/)
знак подчеркивания
запятая

7. Какой признак формулы в строке формул?

Знак (+)
Знак (-)
Знак (=)
Знак(@)

8. Отметьте ссылку абсолютную по строке.

$B5
B5
B$5
$B$5

9. При помощи какого пункта меню устанавливается разрешение переноса информации в ячейке по словам?

Правка-Заменить
Вставка-Ячейки
Сервис-Настройки
Формат-Ячейки

10. Каким значком начинается сообщение об ошибке?

#
$
&
@

11. Что появится в ячейке рабочего листа при вводе выражения 5+2?

сообщение об ошибке
5+2
ничего не появится
7

12. Как выделить несмежный диапазон ячеек?

левая клавиша мыши+CTRL
левая клавиша мыши+SHIFT
левая клавиша мыши+ALT
левая клавиша мыши+TAB

13. Чего нельзя делать с несмежным диапазоном ячеек?

удалять
форматировать
вводить данные
копировать

14. Какой пункт меню используется для создания сводной таблицы?

Файл
Данные
Вид
Вставка

15. С помощью какого пункта меню можно выполнить фильтрацию данных?

Вид
Сервис
Правка
Данные

Нажмите на кнопку для завершения теста:


Тест по устройству персонального компьютера

1. Какое устройство из ниже перечисленных входит в базовую аппаратную конфигурацию компьютера?

принтер
клавиатура
звуковые колонки
сканер

2. Что такое сканер?

устройство ввода графической информации с прозрачного или непрозрачного листового материала
устройство для печати документов
устройство для чтения компакт-дисков
устройство для связи с удаленным компьютером

3. Какое время хранится информация в оперативной памяти?

час
до момента выключения компьютера
день
месяц

4. Что такое драйвер?

средство обеспечения пользовательского интерфейса
программа, отвечающая за взаимодействие с конкретным устройством ПК
графический редактор
средство для просмотра Web-документов

5. Отметьте основные параметры процессоров.

рабочее напряжение
разрядность
размер кэш-памяти
рабочая тактовая частота
адресная шина

6. Что не размещается на материнской плате?

процессор
накопитель на гибких магнитных дисках
постоянное запоминающее устройство
оперативная память

7. Какая клавиша на клавиатуре используется для подтверждения ввода информации?

Delete
Escape
Ctrl
Enter

8. Что не относится к устройствам ввода-вывода?

монитор
принтер
мышь
модем

9. Для чего предназначена клавиша Shift?

для ввода данных
для переключения регистра
для отмены ввода
для удаления данных

10. Какие размеры мониторов относятся к стандартным?

14"
15"
16"
17"
18"

11. Какие типы принтеров, классифицирующиеся по принципу действия, существуют?

Монохромные
Матричные
Струйные
Лазерные
Светодиодные
Цветные

12. Специализированный принтер для вывода на печать чертежей:

Лазерный принтер
Плоттер
Струйный принтер
Матричный принтер

Нажмите на кнопку для завершения теста:


Тест на знание глобальной сети Интернет

1. Гипертекстовая ссылка состоит из:

текста с подчеркнутым шрифтом
указателя
рисунка
курсора
адреса

2. Какие программы используются для работы в глобальной сети Интернет?

почтовые программы
графические процессоры
FTP-клиенты
менеджеры загрузки
программы общения
программы обработки звука

3. Запись http//www.mysite.ru/my-page.htm - это:

Адрес электронной почты
Файл мультимедиа
Web-страница
Сеанс Telnet

4. Запись user@company.ru - это:

Сеанс Telnet
Адрес электронной почты
Статья UseNet
Web-страница

5. Какая из кнопок панели инструментов браузера Internet Explorer используется для открытия панели журнала:

6. Что такое TCP/IP?

Сеть
Web-браузер
Протокол передачи данных
Пароль

7. Язык разметки гипертекста - это:

Hypertext
HTML
Hyperlink
URL

8. Как называются программы, позволяющие находить и просматривать гипертекстовые документы?

Почтовые программы
Менеджеры загрузки
Браузеры
Программы общения

9. Из скольких чисел, разделенных точками, состоит IP-адрес?

4
3
2
1

10. Какая информация может содержаться в сообщении электронной почты?

адреса получателей
тема письма
вложенные файлы
дата и время отправки письма
содержание письма

Нажмите на кнопку для завершения теста:


Тест по использованию локальных вычислительных сетей

1. В зависимости от удаленности компьютеров сети условно разделяют на:

местные
локальные
домашние
глобальные
национальные

2. Локальная вычислительная сеть представляет собой:

систему управления базами данных
коммуникационную систему
операционную систему
информационную систему

3. Что такое Login?

Пароль
Имя пользователя
Протокол передачи данных
Web-браузер

4. Отметьте основные аппаратные компоненты ЛВС:

персональные компьютеры
серверы
рабочие станции
принтеры
линии передачи данных

5. Какие из ниже перечисленных программ относятся к серверному программному обеспечению?

SQL Server
PowerPoint
Outlook
Exchange Server
Internet Information Server

6. Какой тип прав доступа не предоставляется Windows?

только чтение
полный доступ
только модификация
определяется паролем

7. Какой из ниже перечисленных адресов является именем сетевого ресурса:

\\bsusrv\public
c:\bsusrv\mail
//bsusrv/public
c:/bsusrv/mail

8. При вводе сетевого пароля он отображается:

так как набирается
точками
звездочками
в обратном порядке

9. Для сетевого имени компьютера используется максимум:

4 символа
8 символов
16 символов
32 символа
64 символа
128 символов

10. Укажите порядок установки сетевого принтера.

дважды щелкнуть на значке Установка принтера
выбрать, печатать ли пробную страницу
в меню Настройка выбрать команду Принтеры
выбрать Сетевой принтер
указать сетевое имя принтера
нажать кнопку Пуск

Нажмите на кнопку для завершения теста:


Тест по основным понятиям об информации и информатике

Тест по основным понятиям информации и информатике

1. Отметьте те понятия, которые связаны с понятием "информатика".

Сигнал
Вещество
Сообщение
Данные
Энергия

2. Что из ниже перечисленного является информационным процессом?

Сбор информации
Обработка информации
Получение информации
Хранение информации
Обмен информацией

3. Архитектура ЭВМ – это:

совокупность общих принципов организации аппаратно-программных средств и их характеристик
конкретный состав вычислительного средства на некотором уровне детализации
описание связей внутри вычислительного средства во всей их полноте

4. Какие основные устройства содержит ЭВМ неймановской структуры?

арифметико-логическое устройство
устройство управления
устройства ввода-вывода
запоминающее устройство
устройство контроля

5. Операционная система – это:

комплекс программ, управляющих всеми процессами внутри компьютера
программа для обработки текста
программа-оболочка
сервисная программа

6. Какая программа не относится к типовому прикладному программному обеспечению?

текстовый процессор
экспертная система
система управления базами данных
программа архивации данных
графический процессор
программа математического расчета

7. Что такое интерфейс?

программа для распознавания текста
совокупность средств и правил для взаимодействия устройств ПК, программ и пользователя
программа-переводчик
рабочий стол операционной системы Windows

8. Чему равен 1 Гбайт?

1024 байта
562 байта
1024 Кбайт
1024 Мбайт

9. Что такое файл?

именованное последовательность байтов произвольной длины
магнитный носитель
название программы
название ОС

10. Какая допустимая максимальная длина полного имени файла в операционной системе MS-DOS?

256 символов
512 символов
128 символов
64 символа

11. Какой из знаков недопустим в имени файла?

?
%
(
№

12. Сколько знаков может иметь расширение файла в операционной системе MS-DOS?

3
4
5
6

13. Какое расширение имеют исполняемые файлы программ?

.BAT
.SYS
.EXE
.DOC

14. Отметьте элементы файловой структуры.

стартовый сектор
конечный сектор
таблица размещения файлов
корневой каталог
область данных

15. Что такое BIOS?

операционная система
встроенная программа для загрузки операционной системы и автотестирования
интерпретатор команд
сервисная программа

Нажмите на кнопку для завершения теста:


Тест по языку программирования Паскаль

1. Отметьте из каких элементов состоит алгоритмический язык.

Выражения
Символы
Слова
Операторы
Элементарные конструкции

2. Что из ниже перечисленного не входит в набор основных символов Турбо Паскаля ?

латинские строчные и прописные буквы
служебные слова
десять цифр
русские строчные и прописные буквы
знак подчеркивание

3. Какие из типов относятся к стандартным?

Целый
Интервальный
Символьный
Логический
Перечисляемый

4. Что такое массив?

Ограниченная упорядоченная совокупность однотипных величин
Ограниченная совокупность различных элементов
Совокупность ограниченного числа логически связанных компонент, принадлежащих к разным типам

5. Какое из ниже перечисленных выражений не может быть выражением-константой?

Ord('Z') - Ord('A') + 1
['0'..'9']
Blink + Red * 16 + func(White)
80 - Length(Error) div 2
(Max - Min) div 2

6. Какое из следующих описаний переменных является ошибочным?

Operator: (plus, minus, times);
Matrix: array[1.10,1.10] of Real;
Done,Error: boolean;
I,J,K: integer;

7. Укажите приоритет операций в языке Паскаль.

Операции типа сложения: +, –, or, xor
Операции отношения: =, <>, <, >, <= ,> =, in
Унарная операция not, унарный минус –, взятие адреса @
Операции типа умножения: *, /, div, mod, and, shl, shr.

8. Какой оператор не относится к группе операторов ввода-вывода языка Паскаль ?

Read(A1,A2,...AK);
WriteLn(A1,A2,...AK);
PrintLn;
ReadLn;

9. Какой оператор определяет равенство двух значений?

=
==
=:
:=

10. В каком из условных операторов допущена синтаксическая ошибка?

if B = 0 then Writeln('Деление на нуль невозможно.');
if a > b then max := a else max := b;
if (a>b) and (b>0) then c:=a+b;
if a < b then min := a; else min := b;

11. Какие типы циклов существуют в языке Паскаль?

for
do...while
while
repeat...until
loop

12. Какого раздела не существует в программе, написанной на языке Паскаль?

Заголовка
Примечания
Описаний
Операторов

13. Какие файловые типы данных поддерживает Турбо Паскаль?

Текстовые
Графические
Компонентные
Системные
Бестиповые
Архивные

14. Структурированная программа – это программа, составленная из фиксированного множества базовых конструкций. Сколько таких конструкций в языке Паскаль?

3
4
5
6
7

15. Какая из процедур не работает с динамической областью памяти в Турбо Паскале?

New
Dispose
AllocMem
FreeMem
Release

Нажмите на кнопку для завершения теста:


Тест на знание операционной системы Windows 98/2000

1. Что такое ярлык?

графическое представление объекта
указатель на объект
активный элемент управления
копия файла

2. Какие версии операционной системы Windows были выпущены фирмой Microsoft?

Windows 95
Windows 96
Windows 97
Windows 98
Windows 99
Windows 2000

3. Программа Проводник предназначена для:

создания базы данных
работы с файлами, папками и приложениями в операционной системе Windows
выполнения дефрагментации жесткого диска
набора текстов

4. Как вызвать контекстное меню?

2 щелчка левой кнопкой мыши на объекте
1 щелчок правой кнопкой мыши на объекте
2 щелчка правой кнопкой мыши на объекте
1 щелчок левой кнопкой мыши на объекте

5. Как изменить представление папок и файлов в окне?

меню ПРАВКА
меню СЕРВИС
меню ВИД
меню ПЕРЕХОД

6. Что такое буфер обмена?

специальная папка
область памяти
специальный файл
магнитный носитель

7. Как открывается Главное меню?

щелчком правой кнопки мыши на Рабочем столе
щелчком левой кнопки мыши на кнопке Пуск
щелчком правой кнопки мыши на Панели задач
открыто всегда

8. Что такое Мастер?

электронная таблица
диспетчер файлов
специальная программа, работающая в режиме диалога с пользователем
буфер обмена

9. Какая клавиша используется для выделения группы объектов, расположенных не подряд?

ENTER
CTRL
SHIFT
ALT

10. Укажите последовательность действий при копировании файла через буфер обмена(от 1 до 5).

открыть папку-приёмник
вставить файл из буфера командой Вставить( [image])
открыть папку-источник
выделить щелчком нужный файл
копируем файл в буфер командой Копировать ( [image])

11. Какие элементы входят в структуру типичного окна Windows?

системный значок
строка состояния
закрывающая кнопка
системный ярлык
сворачивающая кнопка
открывающая кнопка

Нажмите на кнопку для завершения теста:


Тест на знание текстового процессора Microsoft Word 2000

1. Какой пункт меню позволяет настроить панель инструментов текстового процессора WORD?

Формат
Вид
Правка
Справка

2. При наборе текста в редакторе WORD клавиша Enter используется для:

Вставки рисунка
Перехода на новую строку
Перехода на новый абзац
Перехода на новую страницу

3. Чтобы в текущем документе начать очередной раздел с новой страницы, необходимо:

Нажать несколько раз клавишу Enter
Вставить Разрыв раздела
Создать новый файл
Передвинуть бегунок в полосе прокрутки

4. В каком пункте меню можно настроить параметры страницы текущего документа?

Формат
Вид
Файл
Сервис

5. Каких списков нет в редакторе WORD?

Нумерованных
Многоколоночных
Многоуровневых
Маркированных

6. С помощью какого встроенного в редактор WORD объекта можно всталять в документ математические формулы?

MS Clip Gallery
MS Organization Chart
MS Word Art
MS Equation

7. В каком пункте меню можно настроить параметры проверки правописания?

Вид->Разметка страницы
Сервис->Параметры
Файл->Параметры страницы
Правка->Заменить

8. Чтобы записать документ на магнитный носитель необходимо использовать команду:

Файл->Создать
Файл->Открыть
Файл->Сохранить
Файл->Закрыть

9. Какое основное расширение файлов, созданных в редакторе WORD?

.rtf
.doc
.txt
.dot

10. Что такое колонтитул?

специальная информация внизу или вверху страницы
шаблон документа
символ
многоколоночный текст

11. Какие параметры форматирования можно настроить в диалоговом окне Абзац?

междустрочный интервал
выравнивание текста
начертание
цвет
отступ

12. Что нельзя настроить в диалоговом окне Шрифт?

выбор используемого языка
цвет символов
расстояние между символами
верхний индекс
начертание

Нажмите на кнопку для завершения теста:


Предметный указатель электронного учебника

А
Active Desktop 1, 2, 3, 4,
AGP 1, 2
ANSI 1, 2
ARJ 1, 2, 3
ARPANET1
ASCII 1, 2, 3

В
BIOS 1, 2, 3, 4, 5, 6, 7

С
CD-ROM 1, 2, 3, 4, 5, 6
CD-RW 1, 2
CMOS 1, 2, 3

D
Delphi 1
DIMM-модуль 1, 2
DNS 1
DRAM 1, 2

E
EISA 1

F
FAT 1
FAT-32 1
FrontPage 1, 2
FSB 1
FTP 5, 2, 3, 4, 5, 6

H
High Color 1
HTML 1, 2, 3, 4, 5

I
Internet Explorer 1, 2, 3, 4, 5, 6, 7, 8
IP-адрес 1
ISA 1, 2, 3
ISO 1, 2

J
Java 1

L
LISP 1
Login 1, 2

M
Microsoft Access 1, 2, 3
Microsoft Excel 1, 2, 3, 4
Microsoft Word 1, 2, 3, 4, 5

N
Norton Commander 1

О
OLE 1, 2, 3, 4, 5
Outlook Express 1, 2, 3, 4, 5, 6

P
Paint 1, 2, 3, 4
Pascal 1, 2, 3, 4, 5
PCI 1
PCMCIA 1

R
RAM 1
RAR 1, 2, 3
RISC 1

S
SIMM 1, 2
SRAM 1, 2

U
UNICODE 1, 2
URL 1, 2, 3. 4, 5, 6
USB 1, 2, 3

V
VLB 1

W
Web-документ 1, 2, 3
Web-страница 1, 2, 3
Windows 2000 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12
Windows 95 1, 2, 3, 4, 5, 6
Windows 98 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12
World Wide Web 1, 2, 3, 4

Z
ZIP 1, 2, 3, 4, 5

А
абзац 1, 2, 3, 4, 5, 6, 7, 8, 9
автозавершение 1
автозамена 1
автозаполнение 1, 2, 3, 4
автотекст 1
автоформат 1, 2, 3, 4, 5
Агент сжатия 1
адрес 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12 13, 14, 15, 16, 17
Адресная книга 1, 2, 3
алгоритм 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16
архив 1, 2, 3, 4, 5, 6, 7, 8, 9
распределенный 1
самораспаковывающийся 1, 2
архиватор 1, 2
архитектура 1, 2, 3, 4, 5
атрибут 1, 2, 3, 4, 5, 6, 7, 8

В
байт 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12
база данных 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12
проектирование 1, 2, 3
безопасность 1, 2, 3, 4
Бейсик 1
бит 1, 2, 3, 4, 5
Блокнот 1, 2, 3, 4, 5
брандмауэр 1
броузер 1, 2, 3, 4
буфер обмена 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11

В
видеоадаптер (видеокарта) 1, 2, 3, 4, 5
видеоускорение 1
вирус 1, 2, 3, 4, 5, 6, 7
время доступа 1, 2, 3
выражение 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15
арифметическое 1
логическое 1
вычисления 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17

Г
гиперссылка 1, 2, 3
гипертекст 1
Главное меню 1, 2
график 1, 2, 3, 4
графика 1, 2, 3, 4, 5
группировка 1, 2, 3, 4, 5

Д
данные 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11 , 12, 13,14, 15, 16, 17, 18, 19, 20, 21, 22, 23, 24, 25, 26, 27, 28, 29, 30, 31, 31, 32, 33, 34, 35, 36, 37, 38, 39, 40
диапазон 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19, 20
динамический 1
дигитайзер 1
диск 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11
гибкий 1, 2, 3, 4, 5
дисковод 1, 2, 3, 4, 5, 6, 7, 8, 9, 10
диспетчер 1, 2
дистрибутивный комплект 1
документ 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19, 20, 21, 22, 23, 24, 25, 26, 27, 28, 29, 30, 31, 32, 33, 34, 35, 36, 37, 38, 39, 40, 41
открытие 1, 2, 3, 4
печатный 1, 2
печать 1, 2
пустой 1, 2
редактирование 1, 2
создание 1, 2, 3
сохранение 1, 2, 3
текстовый 1, 2, 3
форматирование 1, 2
электронный 1
доступ 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19, 20, 21, 22, 23, 24, 25, 26, 27, 28, 29, 30
несанкционированный 1, 2
прямой 1, 2
драйвер 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14

Ж
жесткий диск 1, 2, 3, 4, 5, 6, 7

З
заголовок 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14
заполнение 1, 2, 3, 4, 5, 6, 7, 8
запрос 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18
итоговый 1
на выборку 1, 2, 3
на изменение 1
по образцу 1, 2
перекрестный 1, 2, 3, 4, 5
звуковая карта 1, 2
звуковая схема 1
значок 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14
системный 1

И
идентификатор 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13
Избранное 1, 2, 3
изображение 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13
импорт 1, 2, 3, 4, 5, 6, 7
имя 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19, 20 21, 22, 23, 24, 25, 26, 27, 28, 30, 31, 32, 33, 34, 35, 36, 37
доменное 1, 2
файла 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11
инструмент 1, 2, 3, 4, 5, 6
Интернет 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17
интерпретатор 1, 2
интерфейс 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18
асинхронный 1
графический 1, 2, 3
пользовательский 1, 2
последовательный 1
программный 1
информатика
информация 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16
защита 1
поиск 1

К
каталог 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11
кибернетика
клавиатура 1, 2, 3, 4, 5, 6, 7, 8, 9
клавиша 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11
кластер 1, 2
клиент 1, 2, 3, 4, 5, 6, 7, 8, 9
сервер 1, 2, 3
ключ 1, 2, 3, 4, 5, 6
код 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19, 20
исходный 1
объектный 1
кодирование 1, 2, 3, 4, 5
комментарий 1
компилятор 1, 2, 3, 4
компьютер 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19, 20, 21, 22, 23, 24, 25, 26, 27, 28, 29, 30
классификация 1, 2, 3
константа 1, 2, 3, 4, 5, 6, 7, 8
конструктор 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11,12, 13
контроллер 1, 2, 3, 4, 5, 6
контур 1, 2, 3, 4
конфигурация 1, 2, 3, 4, 5, 6, 7
копирование 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15. 16
коэффициент 1, 2, 3
сжатия 1
Корзина 1, 2, 3, 4, 5
кривая 1
курсор 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19, 20, 21, 22, 23
кэш-память 1

Л
Лазерный проигрыватель 1
линия 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11

М
макровирус 1
макрокоманда 1, 2, 3, 4
макрос 1, 2, 3, 4, 5, 6, 7, 8, 9
манипулятор 1, 2, 3
маркер 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15
маршрут 1, 2, 3, 4
маршрутизатор 1
массив 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14
Мастер 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17
материнская плата 1, 2, 3
матрица 1, 2, 3
меню 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19, 20, 21, 22, 23, 25, 26, 27, 28, 29, 30
контекстное 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11
Главное (стартовое) 1, 2, 3, 4, 5, 6
системное 1, 2, 3, 4, 5
метаязык 1
многозадачность 1, 2
модель 1, 2, 3, 4, 5, 6
модем 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12
монитор 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18
мультимедиа 1, 2, 3, 4
мышь 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19

Н
навигация 1, 2
надпись 1, 2, 3
накопитель HiFD 1
накопитель JAZ 1
накопитель ZIP 1

О
обеспечение аппаратное 1
обеспечение программное 1, 2, 3, 4, 5, 6, 7, 8, 9, 10
окно диалоговое 1, 2, 3, 4, 5, 6, 7, 8, 9
окно папки 1, 2
окно приложения 1, 2, 3
окно редактора 1, 2
операнд 1, 2, 3, 4, 5, 6, 7, 8
оператор 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17
варианта 1, 2
конкатенации 1
перехода 1
присваивания 1, 2, 3, 4
операция 1, 2, 3, 4, 5, 6, 7, 8
отладка 1, 2
отладчик 1, 2
отчет 1, 2, 3, 4, 5, 6, 7, 8

П
палитра 1, 2
память динамическая 1
память оперативная 1, 2, 3, 4, 5, 6
панель задач 1, 2, 3, 4, 5
панель индикации 1
панель инструментов 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16
панель управления 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13
панель форматирования 1, 2
панель формул 1, 2, 3
папка 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 13, 14, 15, 16
поиск 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19
параметр 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 15, 16, 17, 18, 19, 20
переменная 1, 2, 3, 4, 5, 6, 7, 8
перетаскивание 1, 2, 3, 4, 5, 6, 7, 8, 9
пиксел 1, 2, 3, 4
плотность 1, 2
подключение 1, 2, 3, 4, 5, 6, 7, 8, 9
подпись 1, 2, 3
подпрограмма 1, 2, 3
поле 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19, 20, 21, 22
полиморфизм 1, 2
полоса прокрутки 1
порт 1, 2, 3, 4, 5, 6, 7, 8, 9, 10
параллельный 1
последовательный 1
правописание 1
прерывание 1, 2
приемник 1, 2, 3
приложение 1, 2, 3, 4, 5, 6, 7, 8, 9 ,10
принтер 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17
Проверка диска 1
Проводник 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12
программа 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19, 20, 21, 22
Преобразование в FAT32 1
программирование 1, 2, 3, 4, 5, 6, 7, 8, 9
программное обеспечение 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11
протягивание 1, 2, 3
профиль 1
процессор 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12

Р
рабочая книга 1
рабочая область 1, 2
рабочий лист 1
Рабочий стол 1, 2, 3, 4, 5, 6
расширение 1, 2, 3, 4, 5
регистр 1, 2, 3, 4, 5, 6, 7, 8, 9
редактор 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13
ресурс 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16
рисунок 1, 2, 3, 4, 5, 6

С
связь 1, 2, 3, 4, 5, 6, 7, 8, 9
Сеанс MS-DOS 1, 2, 3
сектор 1, 2, 3, 4, 5, 6, 7
сервер 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16
сеть глобальная 1, 2, 3, 4
сеть локальная 1, 2, 3, 4
сигнал 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16
символ 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19, 20, 21, 22, 23
маркера 1, 2, 3
основной 1
специальный 1, 2, 3, 4, 5
форматирования 1, 2, 3, 4, 5
Системный Монитор 1
системный блок 1, 2, 3
сканер 1, 2, 3, 4, 5, 6, 7, 8
сканирование 1, 2, 3, 4, 5
словарь 1, 2
слот 1, 2, 3, 4, 5, 6
событие 1, 2, 3, 4, 5
совместимость 1, 2, 3, 4, 5
совместное использование ресурсов 1
соединение 1, 2, 3, 4, 5, 6, 7, 8
сообщение 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15
сортировка 1, 2, 3, 4, 5, 6
список 1, 2, 3, 4, 5, 6, 7
среда 1, 2
ссылка 1, 2, 3, 4, 5, 6, 7, 8, 9
стиль 1, 2, 3, 4, 5, 6, 7, 8, 9
столбец 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15
страница 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14
стример 1, 2
строка 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19, 20, 21
строка заголовка 1, 2, 3
строка меню 1, 2
структура 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12
схема 1, 2, 3, 4, 5, 6, 7, 8
счетчик 1, 2, 3, 4

Т
таблица 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19, 20, 21
табуляция 1, 2, 3, 4
ТВ-тюнер 1
телеконференция 1
тема 1, 2, 3, 4
тестирование 1, 2, 3, 4, 5
транзакция 1
транзистор 1, 2
транслитерация 1
транслятор 1, 2, 3, 4, 5
триггер 1

У
узел 1, 2, 3, 4, 5, 6, 7
указатель 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16
Универсальный проигрыватель 1
уравнение 1
условие отбора 1, 2, 3, 4, 5, 6
устройство 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19, 20

Ф
файл 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19, 20, 21, 22, 23, 24, 25
фильтр 1, 2, 3, 4, 5, 6
форм-фактор 1, 2
форма 1, 2, 3, 4, 5, 6
формат 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19, 20
формула 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12
фрейм 1, 2, 3, 4
функция 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17

X
хакер 1
характеристика 1, 2, 3, 4, 5, 6, 7, 8, 9, 10

Ц
цвет 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16
цикл 1, 2, 3, 4, 5

Ч
частота 1, 2, 3, 4, 5

Ш
шаблон 1, 2, 3, 4, 5, 6, 7, 8, 9
шаг маски 1, 2
шина 1, 2, 3, 4
шрифт 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17

Э
экран 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 15, 16, 17, 18, 19, 20, 21, 22, 23, 24, 25, 26, 27, 28
экранная заставка 1
электронная почта 1, 2, 3, 4
элемент 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19, 20, 21, 22, 23

Я
язык алгоритмический 1, 2
язык ассемблера 1
язык запросов 1, 2
язык программирования 1, 2, 3, 4, 5, 6, 7, 8, 9, 10
яркость 1, 2, 3
ярлык 1, 2, 3, 4, 5, 6, 7, 8, 9
ячейка 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18


ВВЕДЕНИЕ

Основное отличие информатики от других технических дисциплин, изучаемых в высшей школе, состоит в том, что предмет изучения меняется ускоренными темпами. Сегодня количество компьютеров в мире превышает 600 миллионов единиц и продолжает удваиваться в среднем каждые три года.

Вместе с тем, в количественном отношении темп численного роста вычислительных систем заметно превышает темп подготовки специалистов, способных эффективно работать с ними. Все, кто причастен к преподаванию информатики в высшей школе, знают, как часто приходится менять содержание учебных планов, рабочих программ, учебно-методического материала.

Ныне информатика сталкивается с парадоксальным фактом. Её основная задача состоит в преодолении явления, называемого "информационным бумом", путем внедрения средств и методов, автоматизирующих операции с данными. Однако даже в собственной предметной области информатика испытывает такой информационный бум, какого не знает ни одна другая область человеческой деятельности. Мировой ассортимент изданий, имеющих прямое отношение к информатике составляет порядка десяти тысяч томов в год и полностью обновляется не реже, чем раз в два года.

Информатика — одна из немногих общетехнических дисциплин, развивающая такие практические навыки, которые востребованы немедленно, сразу после включения молодого специалиста в профессиональную деятельность.

Анализируя вышеуказанное, авторы данного учебника пришли к выводу что для преподавания информатики необходимо расширенное взаимодействие между печатными изданиями и электронными учебниками. Основные же преимущества электронных учебников состоят в их дешевизне, доступности и мобильности.

Данный электронный учебник состоит из 12 глав, содержащих достаточно полные сведения о современном состоянии аппаратных и программных средств вычислительной техники. Первая глава ОСНОВНЫЕ ПОНЯТИЯ ОБ ИНФОРМАЦИИ И ИНФОРМАТИКЕ — знакомство с предметом изучения.

Вторая глава УСТРОЙСТВО ПЕРСОНАЛЬНОГО КОМПЬЮТЕРА — очень важна, т.к. компьютер — это главный инструмент обработки информации, и тот, кто использует компьютер в работе должен узнать его устройство и принцип действия.

Третья глава ОСНОВЫ РАБОТЫ С ОПЕРАЦИОННОЙ СИСТЕМОЙ Windows 2000 — знакомство с самой распространенной в мире операционной системой, без знания которой невозможна эффективная работа на современном компьютере.

Четвертая, пятая и шестая главы посвящены работе в основных приложениях Microsoft Office. Изучив эти главы, можно создавать высококлассные текстовые документы, разрабатывать электронные таблицы и базы данных.

Седьмая и восьмая глава дает пользователю представление о работе локальной и глобальной компьютерной сети, учит пользоваться электронной почтой и другими сервисами Internet.

Чтобы квалифицированно сохранить и обезопасить данные на компьютере необходимо внимательно изучить главу девятую ИСПОЛЬЗОВАНИЕ СРЕДСТВ СЖАТИЯ ДАННЫХ и десятую ОСНОВЫ ЗАЩИТЫ КОМПЬЮТЕРНОЙ ИНФОРМАЦИИ.

Одиннадцатая и двенадцатая главы дают возможность изучить основы алгоритмизации и программирования на одном из самых популярных в мире языке программирования Паскаль.

Все главы завершаются списком контрольных вопросов, которые могут обсуждаться на лекционных и семинарских занятиях.

Главы, имеющие практическое содержание, имеют набор практических заданий для закрепления полученных знаний.

Каждая глава учебника снабжена набором тестов для контроля знаний преподавателем и для самоконтроля. Программа обработки результатов тестирования дает возможность оценить уровень полученных знаний.

Данный электронный учебник содержит подробный глоссарий и предметный указатель.

Авторы адресуют настоящий учебник студентам, обучающимся специальностям: 011600, 032400, 060400, 060500, 060600, 060800, 061100, 350500, 061000, 020400 . Он может быть использован в обучении "Информатике" и на других, не специализирующихся в информационных технологиях специальностях, а также лицами самостоятельно изучающими аппаратные и программные средства вычислительной техники.


3.1. Введение

Появление Windows 95 ознаменовало переход из эпохи операционной системы MS-DOS к новой эре в мире персональных компьютеров.

Следующая версия — Windows 98 предоставила пользователям ещё больше средств и возможностей для повышения производительности работы и дружественный интерфейс для работы в Internet.

В Windows 2000 Professional соединились возможности промышленной операционной системы Windows NT 4 с простотой интерфейса и мощью Windows 98. Поэтому в ходе дальнейшего изложения материала будут рассматриваться работа в двух операционных системах — Windows 98/2000.

3.2. Начало и завершение работы

Запуск Windows 2000 Professional

Если вы установили Windows 2000, модернизировав предыдущую версию этой операционной системы, процедура регистрации новых учетных записей будет несколько отличаться от обычной. При модернизации программа установки переносит ваш пользовательский профиль из старой версии и с его помощью создает новую учетную запись в Windows 2000 Professional. В этом случае вам достаточно зарегистрироваться, используя свое старое имя пользователя и пароль.

Если же в предыдущей версии операционной системы вы не имели учетной записи, то теперь вам придется ее создать. Создавать новые учетные записи может только пользователь с привилегиями администратора. Следовательно, и зарегистрироваться вам нужно как администратору. Если в предыдущей версии вообще не было создано пользовательских профилей, то для правильной регистрации необходимо ввести имя и пароль администратора, созданные в процессе установки. В любом случае предположим, что перед вами открылось окно регистрации. Следовательно, для регистрации в качестве администратора и создания для себя новых учетных записей выполните ряд действий.

1. Нажмите комбинацию клавиш Ctrl+Alt+Del, если система предлагает вам это сделать. Заметьте, эта комбинация клавиш не приводит к перезагрузке систем Windows NT и Windows 2000 Professional, а является лишь средством защиты, удаляющим из памяти все вирусы типа "троянский конь" и резидентные программы.

2. В появившемся окне введите пароль администратора, установленный в процессе инсталляции.

3. Нажмите клавишу Enter.

Выполнение описанных выше действий приведет к запуску Windows 2000 Professsional.

Аккуратный выход из Windows 2000 Professional

Завершив работу с Windows, необходимо аккуратно выйти из системы. Только в этом случае вы можете быть уверены в правильном сохранении работы и отсутствии неполадок с системой в будущем. Если же компьютером используются несколько пользователей, нужно завершить сеанс своей работы, чтобы остальные имели возможность зарегистрироваться. Кроме того, завершение сеанса защитит ваши документы и параметры от других пользователей.

Когда вы даете команду на завершение работы, Windows выполняет специальную подготовку, закрывает все открытые файлы, предлагая вам сохранить все несохраненные документы, и изменяет параметры сети, в результате чего ваши ресурсы становятся недоступными.

Существует несколько способов завершения работы, которые можно применить к вашему компьютеру. В новых компьютерах описанные возможности существенно расширены, поскольку через АСР1 (расширенный интерфейс управления питанием и конфигурацией) добавлено более совершенное управление питанием.

Правильное завершение работы выполняется следующим образом.

1. Закройте все работающие программы. (В большинстве случаев для этого достаточно выбрать команду Файл->Выход или щелкнуть на кнопке закрытия программы). Если вы проигнорируете этот этап перед вызовом команды завершения работы, Windows предложит вам закрыть их самостоятельно. Почти обязательно это предложение появится в том случае, когда вы забыли сохранить свою работу. Некоторые программы, например работающие в DOS, придется закрыть вручную. Если система не сможет их закрыть самостоятельно, она тут же сообщит вам об этом. Выйдите из всех DOS-программ и, если необходимо, введите exit в командной строке.

2. Щёлкните на кнопке Пуск и выберите команду Завершение работы. На экране появится диалоговое окно (рис.3.1,а)

3. Выберите желаемый вариант из списка и нажмите Ok.

а)

б)

Рис. 3.1. Окно Завершение работы: а) - Windows 2000, б) - Windows 98

Запуск Windows 98

Операционная система Windows 98 запускается автоматически после включения питания компьютера (точно так же, как и операционная система MS-DOS). Отличие заключается в том, что сразу после (или перед) появлением сообщения Starting Windows ... можно нажать клавишу F8

После нажатия клавиши F8 появляется меню, позволяющее запустить операционную систему Windows 98 в различных режимах.

Normal (Нормальный).
Logged (BOOTLOG.TXT) (С регистрацией всех выполняемых операций)
Safe mode (Защищенный режим).
Step by step confirmation (Пошаговая загрузка с подтверждением).
Command prompt only (Только командная строка).
Safe mode command prompt only (Командная строка в защищенном режиме).
Previous version of MS-DOS (Загрузка предыдущей версии MS-DOS).

После выбора с помощью клавиш управления курсором первого режима загрузки Normal и нажатия клавиши Enter происходит обычная загрузка системы (режим Normal является режимом загрузки системы по умолчанию).

Второй режим загрузки Logged используется чаще всего для выявления ошибок, которые возникают в процессе запуска системы (при запуске системы в этом режиме действия, выполняемые в процессе загрузке, регистрируются в файле Bootlog.txt).

Если система по каким-либо причинам не загружается в нормальном режиме, то выберите третий режим загрузки операционной системы Windows 98 Safe mode. Это в большинстве случаев позволит запустить операционную систему в VGA-режиме, после чего вы сможете выявить и устранить конфликты, которые не позволяют загружать систему в нормальном режиме.

Если выбрать четвертый режим загрузки Step by step confirmation, то перед загрузкой операционной системы будут заданы вопросы о необходимости выполнения каждой из команд, содержащихся в файлах CONFIG.SYS и AUTOEXEC.BAT, и некоторых команд, выполняемых по умолчанию во время загрузки системы.

После выбора пятого режима загрузки Command prompt only графический интерфейс пользователя не загружается, и пользователь работает с компьютером в режиме командной строки. При этом он может выполнять все команды операционной системы MS-DOS версии 6.Х, а также некоторые дополнительные. Перед загрузкой операционной системы выполняются все команды файлов CONFIG.SYS и AUTOEXEC.BAT.

Если выбрать шестой режим загрузки Safe mode command prompt only, то операционная система будет работать в режиме системы MS-DOS, но ни одна из команд файлов CONFIG.SYS и AUTOEXEC.BAT не будет выполнена.

После выбора седьмого режима Previous version of MS-DOS будет загружена операционная система MS-DOS, что позволит работать с теми программами, которые по каким-либо причинам не запускаются в Windows 98.

Завершение работы Windows 98

При работе в Windows 98 нельзя выключать компьютер до тех пор, пока вы корректно не выйдете из этой системы.

Работа в Windows 98 завершается следующим образом: пользователь выполняет щелчок на кнопке Пуск и выбирает команду Завершение работы. После этого срывается диалоговое окно (рис.3.1,б), в котором следует выбрать необходимый вариант завершения сеанса работы с Windows 98.

В этот момент весь экран, за исключением итогового окна Завершение работы Windows, несколько затемняется. Существует несколько вариантов завершения сеанса работы с Windows 98 посредством диалогового окна Завершение работы Windows, описание которых приведено в табл. 1.

Таблица 1

Название варианта | Описание
Выключить компьютер | Сохраняются все системные установки, и компьютер подготавливается к выключению. После появления сообщения: "Теперь питание компьютера можно отключить " можно выключить компьютер или перезагрузить систему с помощью комбинации клавиш Ctrl+Alt+Del
Приостановить работу компьютера | Компьютер переводится в экономный режим работы (останавливаются жесткие диски, гасится экран монитора и т.д.)
Перезагрузить компьютер | Сохраняются все системные установки, и компьютер подготавливается к выключению, но после завершения сеанса работы операционная система загружается повторно
Перезагрузить компьютер в режиме MS-DOS | Сохраняются все системные установки, и система перезагружается в режиме эмуляции|| MS-DOS


3.3. Интерфейс Windows 95

3.3. Интерфейс Windows 98/2000

После того как операционная система Windows 98/2000 будет загружена в нормальном режиме, вы увидите графический интерфейс (Graphical User Interface). В дальнейшем этот интерфейс будем называть стандартным. Основными компонентами графического интерфейса являются рабочий стол (Desktop), панель задач (Taskbar), пиктограммы (в терминологии Microsoft — значки) и ярлыки. Кроме того, в Windows 98/2000 помимо стандартного можно использовать и Web-интерфейс, в котором используется активный рабочий стол (Active Desktop).

Таким образом, в зависимости от того, являетесь ли вы приверженцем стандартного интерфейса или же вы любитель Интернет и хотите использовать одни и те же средства для работы и в Интернет, и с локальными ресурсами, вы можете выбирать любой из упомянутых выше интерфейсов.

Весь дальнейший материал изложен с ориентацией на стандартный интерфейс, так как он используется во всех версиях Windows, начиная с Windows 95. Однако, если для выполнения какой-либо операции при работе с Web-интерфейсом будет необходимо выполнить действия, отличные от описанных для стандартного интерфейса, мы обязательно будем говорить об этом.

Одно из отличий Web-интерфейса от стандартного заключается в том, что для активизации какого-либо объекта (например, для запуска приложения) при использовании Web-интерфейса необходимо выполнить один щелчок на соответствующей пиктограмме или ярлыке, в то время как при работе со стандартным интерфейсом вам пришлось бы выполнить двойной щелчок мышью. При использовании Web-интерфейса для выделения объекта достаточно переместить на него указатель мыши, а при работе со стандартным интерфейсом на пиктограмме или ярлыке необходимо выполнить один щелчок.

В Windows 98/2000 используется несколько способов переключения между стандартным и Web-интерфейсом. Наиболее простой заключается в следующем. Нужно открыть окно любой папки (например, Мой компьютер) и выбрать в меню Вид -> Свойства папки (в Windows 2000 — Сервис -> Свойства папки), чтобы открыть одноименное окно (рис. 3.2). В этом окне необходимо установить опции, соответствующие либо Классическому стилю, если вы желаете использовать стандартный интерфейс, либо Стилю Web, если вы хотите работать с Windows 98/2000 посредством Web- интерфейса.

Рис. 3.2. Окно Свойства папки

Управление Windows 98/2000

В Windows 98/2000 большую часть команд можно выполнять с помощью мыши. С мышью связан активный элемент управления — указатель мыши. При перемещении мыши по плоской поверхности указатель перемещается по Рабочему столу, и его можно позиционировать на значках объектов или на пассивных элементах управления приложений.

Основными приемами управления с помощью мыши являются:

  • щелчок (быстрое нажатие и отпускание левой кнопки мыши);
  • двойной щелчок — два щелчка, выполненные с малым интервалом времени между ними;
  • щелчок правой кнопкой (то же, что и щелчок, но с использованием правой кнопки);
  • перетаскивание (drag-and-drop) — выполняется путем перемещения мыши при нажатой левой кнопке (обычно сопровождается перемещением экранного объекта, на котором установлен указатель);
  • протягивание мыши (drag) — выполняется, как и перетаскивание, но при этом происходит не перемещение экранного объекта, а изменение его формы;
  • специальное перетаскивание — выполняется как и перетаскивание, но при нажатой правой кнопке мыши, а не левой;
  • зависание — наведение указателя мыши на значок объекта или на элемент управления и задержка его на некоторое время (при этом обычно на экране появляется всплывающая подсказка, кратко характеризующая свойства объекта).

Рабочий стол

То, что появляется на экране по окончании загрузки операционной системы Windows 98/2000, есть не что иное, как своего рода письменный стол. Поэтому такой виртуальный письменный стол называется Рабочим столом (от английского desktop).

В Windows 98/2000 на рабочем столе располагаются пиктограммы (значки) и ярлыки. С их помощью вы получаете доступ к соответствующим приложениям или документам. Рабочий стол постоянно находится перед глазами пользователя (если, конечно, он не закрыт окном какого-нибудь приложения), поэтому расположенные на нем пиктограммы и ярлыки всегда доступны.

После инсталляции Windows на рабочем столе отображается несколько значков (например, Мои компьютер, Сетевое окружение и Корзина). С помощью первых двух можно получить доступ к локальным, а также выделенным для совместного использования в сети запоминающим устройствам и принтерам. Перетаскивая файлы и папки на значок Корзина, вы сможете быстро удалять их. Кроме того, Корзина позволяет восстанавливать удаленные документы.

Любая расположенная на рабочем столе пиктограмма (или ярлык) может быть удалена с него. Исключение из этого правила составляют лишь пиктограммы, созданные операционной системой, такие, как Мой компьютер, Сетевое окружение, Корзина.

На рабочем столе можно расположить произвольное количество пиктограмм (ярлыков). Поместить на рабочий стол пиктограмму или ярлык довольно просто, если использовать метод Drag and Drop. Например, чтобы создать на рабочем столе ярлык приложения или пиктограмму документа, нужно найти с помощью программы Проводник (Пуск --> Программы -->Проводник) необходимый исполняемый файл или документ и перетащить соответствующую ему пиктограмму на рабочий стол необходимо:

1. Переместить на пиктограмму файла указатель мыши.

2. Нажать левую кнопку и, не отпуская ее, переместить указатель на рабочий стол, после чего отпустите левую кнопку мыши.

3. После этого на рабочем столе появится пиктограмма или ярлык (в зависимости от того, какой файл вы перетаскивали — исполняемый или другого вида).

В нижней части рабочего стола отображается панель задач. Щелкнув на кнопке Пуск панели задач, можно открыть стартовое меню. Панель задач и стартовое меню позволяют быстро выполнять 95 процентов действий, которые обычно приходится предпринимать пользователю в Windows.

Стартовое меню

С появлением операционной системы Windows 95 пользователи получили возможность тратить гораздо меньше времени на запуск программ по сравнению с DOS и многими другими операционными системами.

В структуру Стартового меню (рис. 3.3) входят два раздела — обязательный и произвольный.

Произвольный раздел расположен выше разделительной черты. Пункты этого раздела пользователь может создавать по собственному желанию. Иногда эти пункты образуются автоматически при установке некоторых приложений.

Стартовое меню предназначено, прежде всего, для запуска программ. В нем находятся меню и команды. Команды служат для запуска различных программ, а меню являются средством упорядочения стартового меню.

В меню могут храниться как команды, так и другие меню — подменю. Благодаря этому, вы можете сконфигурировать стартовое меню таким образом, чтобы определенные категории приложений и средств запускались из различных подменю. Ниже кратко описано назначение команд и меню, расположенных на первом уровне стартового меню.

Рис. 3.3. Стартовое меню Windows 2000

Меню Программы стартового меню содержит команды, позволяющие запускать как стандартные приложения Windows, так и другие приложения. В Windows 98/2000 вы можете изменять порядок, в котором расположены команды и подменю меню программы.

Меню Избранное содержит созданные вами ссылки на различную информацию сети Интернет.

Меню Документы стартового меню содержит ссылки на 15 последних вызывавшихся пользователем документов. Таким образом, Windows 98/2000 предоставляет вам возможность быстро получить доступ к информации, с которой вы работаете наиболее часто, и помогает избежать отнимающего много времени поиска документов в папках.

Меню Настройка стартового меню содержит, помимо прочих, команды Панель управления и Принтеры, посредством которых вы можете открыть соответствующие окна. С помощью первого окна можно конфигурировать аппаратные и программные средства компьютера, а второе позволяет устанавливать, удалять и конфигурировать драйверы локальных или сетевых принтеров.

Меню Найти. Система Windows предоставляет в распоряжение пользователя несколько утилит поиска информации. Меню Найти стартового меню содержит команды: Файлы и папки, Компьютер, В Интернете и Людей, которые позволяют соответственно осуществлять поиск файлов и папок, поиск компьютера в локальной сети, поиск данных Internet и поиск информации об интересующих вас персонах.

Команда Справка. Выбрав команду Справка в стартовом меню, вы можете запустить справочную систему Windows, которая поможет вам решить различные проблемы и лучше разобраться с программами и средствами Windows.

Команда Выполнить стартового меню вызывает одноименное окно, которое, в свою очередь, позволяет пользователю вводить команды в режиме командной строки.

Команда Завершение работы позволяет пользователю корректно завершить сеанс работы с Windows 98/2000, перегрузить систему или запустить ее в режиме эмуляции MS-DOS

В Windows 2000 из Office 2000 перенесен адаптируемый интерфейс пользователя. Он позволяет пометить в меню те приложения, которые используются чаще всего и перемещает их в начало меню Пуск (рис. 3.4).

Рис. 3.4. Персонифицированное меню Windows 2000

Панель задач

Назначение панели задач — сделать операцию переключения между многими приложениями такой же простой, как переключение каналов телевизора. Каждому открытому в Windows окну на панели задач соответствует определенная кнопка. Можно открыть нужное окно, щелкнув мышью на соответствующей кнопке Панели задач.

В Windows 98/2000, в дополнение к кнопкам приложений, на панели задач могут находиться одна или несколько панелей инструментов.


Окно Мой компьютер

Рис. 3.5. Окно Мой компьютер

Иерархический принцип отображения папок и файлов, используемый программой Проводник, смущает многих начинающих пользователей. Поэтому, проектируя Windows, разработчики фирмы Microsoft создали на рабочем столе пиктограммы Мой компьютер и Сетевое окружение, призванные решить данную проблему.

Двойной щелчок на пиктограмме Мой компьютер раскрывает окно, отображающее ресурсы, доступные на вашем компьютере. Двойной щелчок на пиктограмме Сетевое окружение позволяет открыть окно, в котором отображаются ресурсы сетей, к которым подключен ваш компьютер.

К примеру, для того чтобы с помощью окна Мой компьютер (рис. 3.5) просмотреть содержимое каталога C:\Windows, необходимо сначала выполнить двойной щелчок на пиктограмме Мой компьютер. Затем последовательно выполнить двойной щелчок на пиктограммах диска С: и папки Windows. Чтобы подняться на один уровень вверх в дереве каталогов, необходимо нажать кнопку Вверх (эта кнопка отображается в Панели инструментов, которая расположена под строкой заголовка).

Корзина

Рис. 3.6. Окно Корзина

Удаление файлов с жесткого диска в операционной системе Windows осуществляется не совсем обычным образом. Перед окончательным удалением файлы помещаются в папку Корзина (рис. 3.6) и в течение какого-то времени могут быть восстановлены.

Откройте окно Корзина, выполнив двойной щелчок на одноименной пиктограмме рабочего стола, либо щелкнув на ней правой кнопкой мыши и выбрав в контекстном меню команду Открыть.

Воспользуйтесь опцией Таблица меню Вид или кнопкой Вид панели инструментов Обычные кнопки, чтобы отобразить на экране даты удаления объектов, их типы, объемы занимаемой памяти, а также имена папок, в которых хранились объекты до удаления.

Чтобы рассортировать список по дате удаления объектов, необходимо:

  • выполнить двойной щелчок на заголовке столбца Дата удаления
  • или выбрать меню Вид --> Упорядочить значки --> по дате удаления.

Если вы хотите восстановить объект, находящийся в Корзине Windows, отметьте его и выберите в меню Файл команду Восстановить. После этого объект будет перемещен в то место, откуда он был удален.


Контекстно-зависимые меню

Выполнив щелчок правой кнопкой мыши практически на любом объекте Windows 98/2000, вы можете открыть его контекстное меню. Это меню содержит команды, которые могут быть применены к выбранному объекту.

Как следует из названия, набор команд в контекстном меню изменяется в зависимости от того, на каком объекте вы выполнили щелчок правой кнопкой мыши. Хотя каждая команда контекстного меню есть и в обычном меню, пользоваться для ее вызова контекстно-зависимым меню проще и эффективнее.

Ярлыки

Ярлыки являются наиболее мощным инструментом Windows 98/2000, поскольку они позволяют пользователю оформить рабочий стол по своему вкусу.

Для того чтобы создать ярлык какого-либо файла, необходимо:

1. Открыть, например, окно Мой компьютер.

2. Открыть папку, в которой хранится какое-либо приложение.

3. Удерживая нажатой правую кнопку мыши перетащите на рабочий стол файл.

4. После того, как Вы отпустите кнопку мыши, на рабочем столе появится контекстное меню, в котором надо выбрать пункт Создать ярлык(и) .

Признак ярлыка - наличие маленькой изогнутой стрелки в левом нижнем углу появляющегося значка. Если такая стрелка отсутствует, то вы, вместо того чтобы создать ярлык, перенесли файл.

Создать ярлык на рабочем столе можно также следующим образом:

1. Щелкнуть правой кнопкой мыши по свободному пространству рабочего стола.

2. В появившемся контекстном меню выбрать Создать --> Ярлык.

3. При помощи кнопки Обзор найти файл или приложение, ярлык которого Вы хотите создать.

4. Далее следовать следовать рекомендациям Мастера создания ярлыка (рис.3.7).

Рис. 3.7. Мастер создания ярлыка


Длинные имена файлов

В Windows 98/2000 расширения имен файлов используются только для того, чтобы обеспечить обратную совместимость с DOS-приложениями и 16-разрядными Windows - приложениями.

Поэтому по умолчанию в окне программы Проводник расширения имен большинства файлов не отображаются. Это справедливо, по крайней мере, для тех файлов, тип которых зарегистрирован в Windows 98/2000. В большинстве случаев пиктограмма файла и так достаточно красноречива: благодаря ей сразу же становится ясно, в каком приложении можно отредактировать или просмотреть файл данного типа.

Преимущества использования длинных имен файлов

Операционная система Windows позволяет присваивать файлам имена длиной до 255 символов. Использование длинных имен файлов имеет целый ряд преимуществ, особенно для пользователей, только начинающих осваивать персональный компьютер. Это позволяет присваивать файлам развернутые имена, более точно отражающие их содержание.

Расширения имен файлов

В Windows 98/2000 расширения имен файлов используются, как и в MS-DOS и автоматически присваиваются файлам соответствующими приложениями. Однако теперь расширения имен файлов могут быть отображены в окне программы Проводник только по требованию пользователя.

Для того чтобы показать расширения имен всех файлов ( Windows 98), необходимо:

1. Открыть Проводник и в меню Вид выбрать команду Свойства папки.

2. Открыть вкладку Вид и отключить опцию Не показывать расширения для зарегистрированных типов файлов.

3. После этого на экране появятся расширения имен всех файлов.

Для того чтобы показать расширения имен всех файлов ( Windows 2000), необходимо:

1. Открыть Проводник и в меню Сервис выбрать команду Свойства папки.

2. Открыть вкладку Вид и отключить опцию Скрывать расширения для зарегистрированных типов файлов.

3. После этого на экране появятся расширения имен всех файлов.

Рис. 3.8. Окно Свойства папки, вкладка Вид (Windows 2000)


Структура окна в Windows 95

Структура окна в Windows 98/2000

Вся работа в операционной системе Windows 98/2000 осуществляется посредством окон. Как правило, все окна, с которыми работает в Windows, стандартны. Рассмотрим подробнее структуру типичного окна Windows (рис.3.9).

Рис. 3.9. Окно системной папки Windows 2000 Professional

Строка заголовка - это верхняя строка любого окна, содержащая имя приложения. Строка заголовка ограничена с обеих сторон стандартными кнопками. Слева в строке заголовка находится кнопка вызова системного меню. В правой ее части находятся кнопки управления размерами окна.

Системный значок. Если при работе с Windows 98/2000 выполнить щелчок на кнопке вызова системного меню, откроется системное меню, в котором содержатся команды, предназначенные для выполнения различных операций с окном.

Строка меню. Для окон папок строка меню имеет стандартный вид. При щелчке на каждом из пунктов этого меню открывается "ниспадающее" меню, пункты которого позволяют проводить операции с содержимым окна или с окном в целом.

Панель инструментов. Содержит командные кнопки для выполнения наиболее часто встречающихся операций. В работе удобнее, чем строка меню, но ограничена по количеству команд. В окнах современных приложений панель инструментов часто бывает настраиваемой. Пользователь сам может разместить на ней те командные кнопки, которыми он пользуется наиболее часто.

Адресная строка. В ней указан путь доступа к текущей папке, что удобно для ориентации в файловой структуре. Адресная строка позволяет выполнить быстрый переход к другим разделам файловой структуры с помощью раскрывающей кнопки на правом краю строки.

Кнопки управления размером. Эти кнопки дублируют основные команды системного меню. Таких кнопок три (рис.3.10).

Щелчок на закрывающей кнопке закрывает окно полностью (и прекращает процесс). Щелчок на сворачивающей кнопке приводит к тому, что окно сворачивается до размера кнопки, которая находится на Панели задач (при этом процесс, связанный с окном, не прекращается). В любой момент окно можно восстановить щелчком на кнопке Панели задач.

Кнопка | Назначение
 | Свернуть окно в Панель задач
 | Полноэкранное представление окна
 | Отображение окна в нормальном виде
 | Закрытие окна

Рис. 3.10. Кнопки управления размером окна

Рабочая область. В ней отображаются значки объектов, хранящихся в папке, причем способом отображения можно управлять. В окнах приложений в рабочей области размещаются окна документов и рабочие панели.

Полосы прокрутки. Если количество объектов слишком велико (или размер окна слишком мал), по правому и нижнему краям рабочей области могут отображаться полосы прокрутки, с помощью которых можно «прокручивать» содержимое папки в рабочей области.

Полосы прокрутки имеют движок и две концевые кнопки. Прокрутку выполняют тремя способами:

  • щелчком на одной из концевых кнопок;
  • перетаскиванием движка;
  • щелчком на полосе прокрутки выше или ниже движка.

Строка состояния. Здесь выводится дополнительная, часто немаловажная, информация. Так, например, если среди объектов, представленных в окне, есть скрытые или системные, они могут не отображаться при просмотре, но в строке состояния об их наличии имеется специальная запись.


3.4. Программа Проводник

Одной из важнейших программ в Windows 98/2000 является программа Проводник. Она позволяет пользователю управлять файлами и программами, хранящимися на компьютерах и в сети.

Окно программы Проводник (рис. 3.11) разделено на две части: в левой отображается иерархическое дерево папок и устройств, в правой - содержимое выбранной папки или устройства.

Запуск программы Проводник

Запустить программу Проводник можно несколькими способами. Однако проще всего это сделать с помощью кнопки Пуск --> Программы --> Проводник.

Аналогичный результат вы можете получить, выполнив щелчок правой кнопкой мыши на пиктограмме любой папки или на кнопке Пуск и выбрав в открывшемся меню команду Проводник. (Эта команда присутствует и в контекстном меню пиктограмм Мой компьютер, Сетевое окружение, Outlook Express и Корзина.)

Иерархическое дерево папок и устройств

Окно программы Проводник состоит из двух частей: слева по умолчанию отображается панель Все папки, которая содержит иерархическое дерево папок и устройств, справа — содержимое папки (или устройства), отмеченной в левой части окна. Если, например, отметить в левой части окна пиктограмму диска С:, то в правой части отобразится содержимое этого диска.

Рис. 3.11. Окно программы Проводник

В левой части окна программы Проводник — всегда отображается иерархическое дерево папок и устройств, которое позволяет с помощью щелчка мышью отобразить на экране содержимое любого доступного системе запоминающего устройства или папки.

Работа с содержимым окна программы Проводник

Чтобы отобразить в иерархическом дереве окна программы Проводник значки папок, содержащихся на запоминающем устройстве или в другой папке необходимо выполнить щелчок на символе «+» рядом со значком соответствующего запоминающего устройства или папки. После этого вместо символа «+» появится символ «-». Выполнив на нем щелчок, мы проделаем обратную операцию — скроем в иерархическом дереве значки папок, содержащихся на этом устройстве или в этой папке.

Чтобы отобразить в иерархическом дереве значки всех папок, включая их подпапки, необходимо нажать Клавишу [*] на цифровом блоке клавиатуры. Следует отметить, что время, по истечении которого будут открыты все подпапки, зависит от их количества. Закрыть открытые подпапки можно посредством нажатия клавиши [-] цифрового блока клавиатуры.

Кнопки Назад, Вперед и Вверх

Чтобы открыть папку, из которой вы перешли в текущую папку, вам необходимо нажать кнопку Назад или воспользоваться комбинацией клавиш Alt + <--.

Для возврата к прежней папке вам достаточно нажать кнопку Вперед на панели инструментов или воспользоваться комбинацией клавиш Alt + -->.

Чтобы открыть в окне программы Проводник папку, которая расположена в дереве папок и устройств на один уровень выше текущей, необходимо нажать клавишу Backspace или выполнить щелчок мышью на кнопке Вверх на панели инструментов.

Поиск папок и файлов в программе Проводник

Чтобы найти файл или папку в Windows 98, необходимо:

1. Войти в программу Проводник в меню Сервис -->Поиск--> Файлы и папки.

2. В открывшемся диалоговом окне (рис. 3.12, б) в поле Имя ввести имя искомой папки (файла), в поле Где искать, выбрать диск на котором предположительно находится искомая папка (файл).

3. В случае необходимости можно сузить поиск, пользуясь кнопкой Обзор. При желании и необходимости можно установить некоторые дополнительные поисковые параметры (текст, ориентировочную дату редактирования документа, размер).

4. Нажать кнопку Найти.

Разыскивать определенный файл в правой части окна Обзор с помощью линейки прокрутки довольно утомительно. Однако существует способ приближаться к искомому файлу (папке) «прыжками». Для этого на клавиатуре необходимо набрать первую из названия файла (папки). В том случае, когда на одну и ту же букву начинаются имена нескольких объектов, выбирается имя первого. Добраться до искомого можно с помощью клавиш управления курсором.

Чтобы найти файл или папку в Windows 2000 используют Главное меню (Пуск -->Найти-->Файлы и папки) (рис. 3.12а).

а)

б)

Рис. 3.12. Окно Поиск папок и файлов: а) в Windows 2000; б) в Windows 98

Управление файлами

Используя программу Проводник, можно выполнять копирование, перемещение и переименование файлов. Кроме того, с помощью этой программы можно запустить требуемое приложение или открыть нужный документ.

Чтобы открыть тот или иной текстовый документ, необходимо дважды щелкнуть по значку документа (для web-интерфейса – один щелчок) или выполнить щелчок правой кнопкой мыши на пиктограмме этого документа и выбрать в контекстном меню команду Открыть. Команда Открыть присутствует и в меню Файл.

Отображение файлов и папок в окне программы Проводник

Когда вы запускаете программу Проводник, в правой части ее окна Windows демонстрирует список имен и значков папок и файлов. Для изменения варианта отображения файлов и папок в окне Обзор можно воспользоваться командами меню Вид или кнопкой Вид панели инструментов.

Очень удобно использовать вариант детального отображения (команда Таблица меню Вид), поскольку в этом случае на экране помимо значка и имени файла или папки отображается дополнительная информация: объем файла, его тип и дата последней модификации.

Для того чтобы установить нужную ширину столбцов для отображения данной информации, необходимо, удерживая нажатой левую кнопку мыши, переместить вертикальную разделительную линию в нужное положение. Если при этом ширина того столбца окажется недостаточной, то Проводник обрежет соответствующее имя и заменит недостающие знаки тремя точками.

Выбрав в программе Проводник отображение детальной информации (команда Таблица меню Вид) о файлах и папках, можно отсортировать файлы и папки в списке по определенному критерию, причем для этого понадобится выполнить всего лишь один щелчок мышью на заголовке соответствующего столбца.

После выполнения второго щелчка на заголовке столбца программа Проводник произведет сортировку в обратном порядке, например, в обратном алфавитном порядке. Если для отображения файлов и папок используется команда Крупные значки, то можно выполнить сортировку, воспользовавшись командами подменю Упорядочить значки меню Вид.

Отмена операций с файлами

В Windows 98/2000 есть простое средство, предназначенное для отмены одного или нескольких ошибочных действий. Так, например, работая с программой Проводник, вы можете отменить удаление файла, переименование, перемещение или копирование, выбрав команду Отменить ххх (где ххх может принимать значения удаление, переименование или копирование) из меню Правка окна Обзор. Или кнопка Отменить [image] на панели инструментов Проводника.


Операции с файловой структурой

Работая в Windows 98/2000 с файлами, вы можете осуществлять с ними самые разнообразные операции, основные из которых:

  • навигация по файловой структуре;
  • запуск программ и открытие документов;
  • создание папок;
  • копирование файлов и папок;
  • перемещение файлов и папок;
  • удаление файлов и папок;
  • переименование файлов и папок;
  • создание ярлыков;
  • изменение атрибутов и др.

Маркирование объектов

При работе с различными объектами системы Windows можно производить необходимые операции не с одним объектом, а с целой группой. Чтобы система знала, к каким объектам относится та или иная команда их предварительно нужно маркировать (отметить).

Маркирование группы файлов

Чтобы отметить несколько объектов, маркируйте первый объект, нажмите клавишу Ctrl и, удерживая ее нажатой, маркируйте другие объекты (выполняйте щелчок левой кнопкой мыши на других объектах).

Если вы используете для работы с Windows web-интерфейс, то для маркирования объекта достаточно на несколько секунд переместить указатель мыши на значок объекта.

Кроме того, маркировать файлы можно следующим образом:

1. Маркируйте первый необходимый объект.

2. Нажмите клавишу Shift и, удерживая ее, маркируйте последний из группы файлов, которые необходимо отметить.

В результате все имена файлов, находящиеся между первым и последним отмеченным файлом, будут маркированы.

Маркирование всех файлов и папок

Чтобы отметить все файлы и папки текущего каталога, необходимо выбрать команду Выделить все в меню Правка окна любой папки. При маркировании имен всех файлов и папок не имеет значения, на имени какого файла или папки находится в данный момент маркер.

Копирование и перемещение объектов

Чтобы скопировать какой-либо объект (файл, папку, ярлык) в Windows 98/2000, необходимо выполнить следующие действия:

  • Открыть папку, содержащую объект-оригинал, а затем папку, в которую должна быть помещена копия объекта: расположить оба окна таким образом, чтобы они были видны на экране одновременно.
  • Отметить нужный объект (объекты) и переместить его, удерживая нажатой клавишу Ctrl и левую кнопку мыши, в целевую папку.
  • Как только кнопка мыши будет отпущена. Windows создаст копию объекта.

Кроме того, объект может быть скопирован и путем перетаскивания в целевую папку. При этом необходимо удерживать нажатой правую кнопку мыши, а в появившемся контекстном меню выбрать команду Копировать.

Если вы выберите в контекстном меню команду Переместить, то объект будет не скопирован, а перенесен в целевую папку.

Использование буфера обмена для работы с объектами

Система Windows создает и обслуживает на компьютере невидимую для пользователя область памяти, называемую буфером обмена. Этой областью можно и нужно уметь пользоваться.

Принцип работы с буфером обмена очень прост:

1. Открываем папку-источник. Выделяем щелчком нужный объект.

2. Копируем или забираем объект в буфер. В первом случае объект остается в папке-источнике и может быть размножен. Во втором случае он удаляется из папки-источника, но может некоторое время храниться в буфере. Последняя операция называется вырезанием объекта.

3. Открываем папку-приемник и помещаем в нее объект из буфера обмена. Три указанные операции (Копировать, Вырезать и Вставить) можно выполнять разными способами. Классический прием состоит в использовании пункта Правка в строке меню, но более удобно пользоваться командными кнопками панели инструментов:

— Копировать;

— Вырезать;

— Вставить.

Самый же эффективный способ работы с буфером обмена состоит в использовании комбинаций клавиш клавиатуры:

CTRL + С — копировать в буфер;

CTRL + X — вырезать в буфер;

CTRL + V — вставить из буфера.

Эти приемы работают во всех приложениях Windows, и их стоит запомнить. Через буфер обмена можно переносить фрагменты текстов из одного документа в другой, можно переносить иллюстрации, звукозаписи, видеофрагменты, файлы, папки и вообще любые объекты. Буфер обмена — мощное средство для работы с приложениями и документами в Windows.

В общем случае буфер обмена невидим для пользователя, и обычно необходимость просмотра его содержимого не возникает. Однако, если она все-таки возникнет, можно воспользоваться специальной служебной программой Просмотр буфер обмена, которая входит в состав операционной системы и запускается по команде Пуск --> Программы --> Стандартные --> Служебные --> Буфер обмена. Если на каком-то конкретном компьютере этой программы нет, это означает, что при установке операционной системы ее компонент не был установлен. Его можно доустановить.

Удаление файлов

Если определенные файлы становятся ненужными, их можно удалить с соответствующего носителя информации. Это позволит сэкономить память на жестком диске. Удалять файлы в Windows 98/2000 рекомендуется следующим образом:

1. Отметить значки файлов, которые необходимо удалить.

2. Выполнить щелчок правой кнопкой мыши на одном из отмеченных значков и выбрать в появившемся контекстном меню команду Удалить.

3. В диалоговом окне нажать кнопку Да, после чего Windows поместит отмеченные файлы в папку Корзина.

Ненужный файл или файлы можно удалить и с помощью мыши. Для этого достаточно перетащить значок удаляемого файла на значок Корзина, удерживая нажатой левую кнопку мыши.

Восстановление удаленных файлов

Если вы случайно удалили какой-либо файл, его можно восстановить, достав из Корзины.

Для этого откройте окно Корзина, выполнив двойной щелчок на одноименном значке либо щелкнув на ней правой кнопкой мыши и выбрав в контекстном меню команду Открыть. Отметьте объект, подлежащий восстановлению, и выберите команду Восстановить меню Файл.

Переименование объектов

Чтобы переименовать файл, сначала отметьте его, а затем выберите команду Переименовать в меню Файл. Вы достигнете той же цели, если нажмете клавишу F2 либо выполните щелчок правой кнопкой мыши на имени необходимого файла и выберете в открывшемся контекстном меню команду Переименовать. После этого можно ввести новое имя файла (папки) или отредактировать старое.

Имя файла (папки) не должно содержать более 255 знаков и не может включать такие символы, как:

  • косая черта (/);
  • обратная косая черта (\);
  • двоеточие (:);
  • звездочка (*);
  • вопросительный знак (?);
  • кавычки ("");
  • угловые скобки (< >);
  • прямая черта (|).

Отмена выполненного действия

Если какой-либо файл был ошибочно удален, переименован, перемещен или скопирован, выполненную с ним операцию можно отменить. Если вы, к примеру, сначала переместили файл, затем скопировали его, потом переименовали и, наконец, удалили, то с помощью команды Отменить меню Правка или комбинации клавиш Ctrl+Z вы сможете последовательно отменить каждое из выполненных действий.

Создание новой папки

Чтобы создать папку на рабочем столе, выполните щелчок правой кнопкой мыши на свободном месте рабочего стола и выберите в подменю Создать появившегося контекстного меню команду Папку.

Если же вы хотите создать папку в уже существующей папке, откройте нужную папку в окне программы Проводник и выберите в меню Файл подменю Создать, а в нем команду Папку. В результате будет создана папка с именем Новая папка. При необходимости вы можете изменить имя. Для этого достаточно указать имя новой папки и нажать клавишу Enter.

Выполнив щелчок правой кнопкой мыши на свободном месте рабочего стола (или окна папки) и выбрав в появившемся контекстном меню команду Выстроить значки, можно упорядочить все имеющиеся здесь пиктограммы и ярлыки. Чтобы Windows автоматически упорядочивала расположенные на рабочем столе (или окне папки) пиктограммы, установите опцию Автоматически в подменю Упорядочить значки упомянутого выше контекстного меню.

Открытие папок

Для того чтобы открыть какую-либо папку (отобразить на экране ее содержимое), достаточно выполнить на ее пиктограмме двойной щелчок левой кнопкой мыши. На экране возникнет окно, в котором будет отображено содержимое папки. Папки, расположенные в появившемся окне, можно открыть аналогичным образом.

Работая в окне программы Проводник, вы можете не только опускаться по веткам иерархического дерева, но и подниматься по ним. Для этих целей используется кнопка Вверх панели инструментов. Кроме того, в Windows переходить от папки к папке можно с помощью кнопок Назад и Вперед (рис. 3.13).

Рис. 3.13. Кнопки Назад, Вперед и Вверх

Чтобы отобразить в окне программы Проводник имена папок и документов, хранящихся на определенном устройстве, откройте с помощью мыши или клавиши F4 поле списка, находящееся в панели инструментов, и выберите в нем имя необходимого устройства. С помощью данного списка можно открыть также папки некоторых стандартных программ.


3.5. Работа с приложениями

Операционная система Windows 98/2000 способна самостоятельно справиться с решением самых разнообразных задач. Однако и ее возможности не безграничны. Рано или поздно вы захотите инсталлировать новые приложения, которые позволят более полно использовать возможности персонального компьютера.

Операционная система Windows 98/2000 позволяет пользователям работать с несколькими приложениями одновременно. При этом переключение между запущенными приложениями можно осуществлять посредством соответствующих кнопок на панели задач.

В Windows 98/2000 приложение можно запустить несколькими способами, например с помощью программы Проводник или Стартового меню. Прежде чем приступить к детальному описанию этих и других способов запуска приложений в Windows, сделаем классификацию всех существующих приложений.

Типы приложений

Принципы, на основании которых в Windows осуществляется работа с тем или иным приложением, во многом зависят от того, разрабатывалось данное приложение для операционной системы Windows 98/2000 (или Windows 95) или же было ориентировано на работу с другой операционной системой. Основываясь на этом, все приложения можно классифицировать следующим образом:

  • Приложения, разработанные специально для Windows 95 или Windows 98/2000. Эти приложения лучше других используют возможности 32-разрядной операционной системы.
  • Приложения, разработанные для графической оболочки Windows 3.х. Данные приложения корректно работают в Windows 98/2000, однако не используют многие достоинства этой операционной системы.
  • Приложения, разработанные для операционной системы MS-DOS. Эти приложения можно запускать в операционной системе Windows 98/2000, однако при их выполнении иногда могут возникать конфликты.
  • Резидентные программы, разработанные для операционной системы MS-DOS. Эти программы могут работать в операционной системе Windows 98/2000 лишь при наличии определенных условий.

Запуск приложений

Запуск приложения в Windows 98/2000 может быть осуществлен одним из следующих способов:

  • Посредством выбора соответствующей команды в стартовом меню.
  • С помощью ярлыка, расположенного на рабочем столе.
  • С помощью кнопки, расположенной на одной из панелей инструментов панели задач.
  • С помощью диалогового окна Выполнить.
  • С помощью программы Проводник.
  • С помощью программы Сеанс MS-DOS.

Запуск приложений с помощью стартового меню

Чтобы запустить приложение с помощью стартового меню, необходимо выполнить следующие действия:

1. Выполните щелчок мышью на кнопке Пуск.

2. В открывшемся стартовом меню (это его первый уровень) будут отображены имена различных подменю и команд. Переместите курсор мыши на меню Программы.

3. В открывшемся подменю также будут отображены имена различных подменю и команд. Отличить меню от команды очень просто: справа от имени любого меню всегда отображается маленький черный треугольник. Чтобы увидеть содержимое определенного меню (открыть меню), достаточно переместить указатель на его имя. Откройте нужное меню.

4. В открывшемся подменю выберите команду, запускающую соответствующее приложение.

Запуск приложения, ярлык которого расположен на рабочем столе

В Windows 98/2000 на рабочем столе располагаются ярлыки различных приложений и документов. Для запуска приложения, ярлык которого расположен на рабочем столе, необходимо выполнить двойной щелчок мышью на этом ярлыке или выполнить на ярлыке щелчок правой кнопкой мыши и выбрать в открывшемся контекстном меню команду Открыть.

Если вы часто работаете с тем или иным приложением, рекомендуется поместить на рабочий стол ярлык данного приложения.

Запуск приложений с помощью кнопок панели инструментов

В Windows 98/2000 существует возможность запуска приложений с помощью кнопок панелей инструментов, расположенных на панели задач. Так, например, вы можете перетащить на панель инструментов пиктограмму или ярлык любого приложения (рис. 3.14) для того, чтобы создать в панели инструментов кнопку.

Рис. 3.14. Панель быстрого запуска на Панели задач

Впоследствии вы сможете быстро запускать соответствующее приложение, просто щелкая мышью по кнопке. Для того чтобы удалить кнопку с панели инструментов, достаточно выполнить на этой кнопке щелчок правой кнопкой мыши и выбрать в открывшемся контекстном меню команду Удалить.

Запуск приложения с помощью диалогового окна Выполнить

С помощью диалогового окна Выполнить можно запустить любое приложение. Однако запускать приложения с помощью этого окна рекомендуется лишь в том случае, если в стартовом меню отсутствует команда запуска данного приложения. Для запуска приложения с помощью диалогового окна Выполнить необходимы следующие действия:

1. Открыть стартовое меню (Пуск).

2. Выбрать команду Выполнить.

3. B поле ввода появившегося диалогового окна ввести команду (если она вам известна) запуска нужного приложения. Например, для запуска приложения Word для Windows необходимо ввести команду с: \windows\winword.exe (рис. 3.15).

Рис. 3.15. Окно команды Выполнить

4. Если вы раньше уже запускали данное приложение с помощью диалогового окна Выполнить, то вместо того, чтобы вновь вводить команду запуска, вы можете выбрать ее в поле списка Открыть.

5. Если вы не знаете команды, с помощью которой можно запустить нужное вам приложение, выполните щелчок на кнопке Обзор. В появившемся после этого диалоговом окне отметьте необходимый исполняемый файл и нажмите кнопку Открыть.

Поиск приложений

Если команда, посредством которой запускается приложение, вам неизвестна, следует открыть диалоговое окно Выполнить и нажать кнопку Обзор. После этого на экране появится диалоговое окно Обзор, с помощью которого можно осуществить поиск нужного приложения.

В диалоговом окне Обзор отображаются имена файлов и папок, хранящихся в текущей папке (по умолчанию в данном окне отображаются только имена папок и исполняемых файлов).

Запуск приложения, хранящегося на сетевом запоминающем устройстве

С помощью диалогового окна Выполнить можно запускать и те приложения, которые хранятся на сетевых запоминающих устройствах.

Откройте диалоговое окно Выполнить и нажмите кнопку Обзор. Чтобы в открывшемся окне отобразить содержимое какого-либо сетевого устройства, необходимо выбрать имя этого устройства в поле списка Где искать.

Если у вас нет прав доступа к данному сетевому запоминающему устройству (папке или приложению), то на экране появляется соответствующее сообщение об ошибке.

Запуск приложения с помощью окна Сеанс MS-DOS

Любое приложение можно запустить и из окна Сеанс MS-DOS. Прежде чем сделать это, следует перейти в каталог, где это приложение хранится. Например, чтобы запустить приложение Word для Windows, которое хранится в каталоге C:\WORD, следует сначала ввести команду

cd c:\word [Enter]

а затем команду

word [Enter]

Запуск резидентных программ

Запуск резидентных программ в Windows 98/2000 осуществляется точно так же, как и запуск других программ. После загрузки резидентные программы остаются в оперативной памяти компьютера.

Чтобы активизировать резидентную программу, ей необходимо каким-то образом передать управление, например, с помощью асинхронного (аппаратного) прерывания. Наиболее часто резидентные программы активизируются посредством нажатия определенной комбинации клавиш. Если вы решили загрузить ту или иную резидентную программу, не забывайте о следующих вещах:

  • Если резидентная программа запущена из окна Сеанс MS-DOS, то она будет функционировать точно так же, как и в системе DOS.
  • В частности, это означает, что резидентная программа автоматически удаляется из оперативной памяти после закрытия названного окна.

Запуск приложений с помощью программы Проводник

Запустить нужное приложение можно с помощью программы Проводник. Для этого следует отобразить в окне Обзор необходимый исполняемый файл (или PIF-файл) и выполнить щелчок на его пиктограмме. Исполняемые файлы, т.е. файлы с расширениями .ЕХЕ, .СОМ, .ВАТ, обозначаются в окне программы Проводник унифицированной пиктограммой.

Завершение работы приложения

В большинстве случаев завершить работу Windows-приложения можно посредством выбора команды Выход в меню Файл. При этом все изменения, внесенные вами, будут сохранены, после чего работа приложения завершится. Существуют и другие методы завершения работы приложения:

  • Выберите команду Выход меню Файл.
  • Выполните щелчок на кнопке Закрыть окна приложения.
  • Выполните двойной щелчок на кнопке вызова системного меню окна приложения.
  • Выполните щелчок правой кнопкой мыши на кнопке соответствующего приложения в панели задач и выберите в появившемся меню команду Закрыть.
  • Нажмите комбинацию клавиш Alt+F4.


3.6. Работа Windows 98/2000 в многозадачном режиме

Все версии Windows обладают способностью одновременно решать несколько задач, т.е. работать в многозадачном режиме (multitasking).

Windows 98/2000 не накладывает ограничений на количество приложений, которые могут работать одновременно. Если вы не можете одновременно запустить в Windows, например, три или четыре приложения, то, скорее всего, причина кроется в том, что компьютер не располагает достаточным объемом оперативной памяти или вычислительная мощность процессора слишком мала.

Помните, что даже самый быстродействующий компьютер работает медленнее, если одновременно запущены несколько приложений.

Если Windows 98/2000 одновременно запущены несколько приложений, то операционная система работает с ними не параллельно, а последовательно. При этом переключение с одного приложения на другое осуществляется настолько быстро, что создается впечатление одновременной работы операционной системы со всеми запущенными приложениями.

Работа с окнами

В Windows 98/2000 работа с различными приложениями осуществляется посредством окон. Окна могут быть в любой момент переконфигурированы пользователем по своему усмотрению.

Любое окно, отображаемое на экране, даже то, которое частично закрыто другими окнами, может быть в любой момент перемещено в другую область рабочего стола. При этом все запущенные приложения будут функционировать нормально.

Как активизировать окно с помощью мыши

Чтобы переместить окно приложения на передний план, необходимо выполнить щелчок мышью в любом месте данного окна.

Если окно приложения не отображается в данный момент на экране, например, потому что оно перекрыто другими окнами, то для его активизации следует пользоваться другими методами, которые будут рассмотрены ниже.

Различные способы расположения окон на рабочем столе

Переместить окно или изменить его размеры можно с помощью мыши.

Чтобы переместить окно в области рабочего стола, необходимо установить курсор мыши на заголовке окна, нажать левую клавишу мыши и переместить окно туда, куда это необходимо.

Чтобы изменить размеры окна, установите курсор мыши на одну из его границ (курсор при этом превращается в двойную стрелку), нажмите левую клавишу мыши и передвижением по вертикали или горизонтали изменяйте размеры.

Вы можете расположить окна на рабочем столе различными способами. Окна могут располагаться каскадом, друг под другом или одно рядом с другим. Однако как бы мы ни расположили окна на рабочем столе, на экране всегда будут отображаться строки заголовков всех открытых окон.

Для того чтобы выбрать способ размещения окна на рабочем столе, нужно выполнить щелчок правой кнопки мыши в свободной области панели задач выбрать в открывшемся контекстном меню команду Окна каскадом (рис.3.16), Окна справа налево или Окна сверху вниз.

Рис. 3.16. Расположение окон на Рабочем столе Каскадом


Панель задач

Панель задач обычно отображается в нижней части Рабочего стола. С ее помощью вы можете управлять задачами, выполняемыми в данный момент.

Что такое задача?

Задачей является любое приложение (процесс), выполняемое в данный момент. Так, например, задачами являются: запущенное приложение Word для Windows, открытое окно Панель управления или любое открытое окно, скажем, окно папки, хранящейся на сетевом запоминающем устройстве.

С помощью Панели задач можно быстро активизировать нужное приложение. Для этого достаточно выполнить щелчок мышью на кнопке данного приложения, расположенной на панели задач. После этого окно приложения будет переведено на передний план Рабочего стола, и вы сможете начать с ним работать.

Работа с панелью задач

Рис. 3.17. Панель задач

После запуска любого приложения на панели задач появляется кнопка, на которой отображается пиктограмма и название запущенного приложения (рис. 3.17). Таким образом, все запущенные приложения отображаются на панели задач в виде кнопок.

Кнопка активного в данный момент приложения изображается нажатой. На панели задач отображается только одна нажатая кнопка. Если вы нажмете другую кнопку (т.е. активизируете другое приложение), кнопка, которая была нажата до этого, будет отпущена.

Если на панели задач становится тесно, размеры кнопок уменьшаются. При этом названия работающих в фоновом режиме приложений отображаются не полностью. Вы видите на кнопках только несколько первых букв названий приложений. При этом не всегда понятно, на какую кнопку необходимо нажать для запуска требуемого приложения. Подведите курсор мыши к одной из кнопок — и примерно через секунду Windows выведет на экран подсказку. В ней будет указано полное имя приложения.

Перемещение панели задач

Иногда в процессе работы с компьютером, оснащенным монитором с небольшим разрешением, панель задач может мешать, так как на рабочем столе остается мало свободного места для отображения окон приложений. Поэтому Windows 98/2000 позволяет пользователям перемещать линейку панели задач и изменять ее размеры.

Например, чтобы поместить линейку задач в правой части рабочего стола, необходимо выполнить следующие действия:

1. Поместить курсор мыши на свободное место панели задач и нажать левую кнопку мыши.

2. Перетащить, не отпуская кнопку мыши, линейку задач к правому краю экрана.

После того как кнопка мыши будет отпущена, панель задач переместится на новое место.

Изменение размеров панели задач

Размеры панели задач можно изменять. Если панель задач расположена в верхней или в нижней части рабочего стола, то можно изменить только ее высоту. Если же панель задач расположена в правой или левой части рабочего стола, можно изменить только ее ширину.

Чтобы изменить какой-либо из размеров панели задач, необходимо:

1. Переместить курсор мыши к соответствующему краю панели задач. При этом курсор мыши должен приобрести вид двунаправленной стрелки.

2. Перетащить, удерживая нажатой кнопку мыши, край панели задач и отпустить кнопку мыши.

После этого размеры панели задач будут соответствующим образом изменены.

Увеличивать размеры панели задач следует только в том случае, если число отображаемых в ней кнопок очень велико.

Описанным выше способом можно изменить размеры панели задач, однако при этом следует учитывать, что площадь, занимаемая линейкой задач, не может превышать половины рабочего стола. Если увеличить размеры панели задач, то автоматически будут увеличены размеры кнопок, отображаемых в ней. Однако Windows может увеличить размеры кнопок лишь до определенных стандартных размеров.

Конфигурирование панели задач

По умолчанию в Windows панель задач всегда отображается на рабочем столе, однако операционной системе можно указать скрывать линейку задач, если в ней нет необходимости. В этом случае панель задач будет появляться на рабочем столе только, когда вы переместите курсор мыши к соответствующей границе экрана.

Чтобы Windows автоматически скрывала линейку задач, когда в ней нет надобности, следует:

1. Выполнить щелчок правой кнопкой мыши на панели задач и выбрать в открывшемся контекстном меню команду Свойства (рис.3.18).

2. В открывшемся диалоговом окне установить опцию Автоматически убирать с экрана и нажать кнопку ОК.

Рис. 3.18. Окно Свойства Панели задач

Чтобы на панели задач отображалось текущее время, необходимо установить в диалоговом окне свойств панели задач опцию Отображать часы (рис. 3.18).

Чтобы получить доступ к панели задач, если она не видна, переместите курсор к нижней границе экрана, и панель задач тотчас же будет отображена. Если панель задач была перемещена, то курсор мыши следует помещать к той границе экрана, около которой панель задач отображалась ранее.

Переключение между программами с помощью клавиатуры

Переключаться между программами можно не только с помощью панели задач, но и с помощью клавиатуры. Если в Windows нажать комбинацию клавиш Alt+Tab, то на экране появится небольшое окно, в котором будут отображены пиктограммы всех запущенных на данный момент приложений. Удерживая нажатой клавишу Alt и нажимая клавишу Tab, необходимо выбрать пиктограмму нужного приложения и отпустить обе клавиши. После этого окно выбранного вами приложения будет перемещено на передний план.

Многозадачность на практике

Преимущества многозадачности не всегда очевидны. Однако несомненным ее достоинством является возможность одновременного запуска нескольких приложений, между которыми можно при необходимости переключаться.

Например, в процессе копирования (перемещения) файлов или форматирования дискет вы можете спокойно продолжать работать с текстовым редактором, т.е. вам не надо ожидать завершения предыдущей операции для того, чтобы выполнить следующую.

Работа с несколькими DOS-приложениями

Windows 98/2000 позволяет одновременно запускать несколько DOS-приложений. При этом новая 32-разрядная операционная система работает достаточно эффективно. Она не только существенно упрощает работу с DOS-приложениями в многозадачном режиме, но и значительно повышает надежность их работы.


3.7. Конфигурирование стартового меню

Стартовое меню можно конфигурировать в соответствии с потребностями пользователя. Так, например, на первом уровне стартового меню можно разместить команды, предназначенные для запуска приложений (или открытия документов), с которыми вы работаете наиболее часто.

Добавление новых команд в стартовое меню

Чтобы добавить в стартовое меню новые команды, необходимо выполнить следующие действия:

1. Выполнить щелчок правой кнопкой мыши на свободной области панели задач.

2. Выбрать в открывшемся контекстном меню команду Свойства.

3. В появившемся диалоговом окне открыть страницу Настройка меню. Выполнить щелчок на кнопке Добавить.

Создать в стартовом меню команду для запуска приложения можно также посредством перетаскивания пиктограммы этого приложения на кнопку Пуск.

4. В поле ввода открывшегося окна ввести команду запуска нужного приложения

5. Если команда запуска приложения неизвестна, нужно выполнить щелчок на кнопке Обзор.

6. В открывшемся окне следует отметить имя нужного исполняемого файла и нажать кнопку Открыть.

7. В появившемся окне отметить ту папку стартового меню, в которую вы хотите вставить команду для запуска приложения, и нажать кнопку Далее.

8. Ввести имя создаваемой команды в поле ввода открывшегося окна и нажать кнопку Готово.

Перемещение команд в стартовом меню

Чтобы перенести какую-либо команду из одного подменю стартового меню в другое, необходимо выполнить следующие действия:

1. Выбрать команду Пуск --> Настройка --> Панель задач и меню "Пуск" .

2. В появившемся окне открыть вкладку Настройка Меню.

3. Выполнить щелчок на кнопке Дополнительно.

4. После этого на экране появится окно программы Проводник. В правой части этого окна отображается иерархическое дерево, корнем которого является папка стартового меню. Отметьте в иерархическом дереве папку, в которой хранится подлежащая перемещению команда, и перетащите соответствующий ярлык в целевую папку.

5. Если это необходимо, измените имя нужной команды или имя подменю стартового меню. Для этого следует отметить соответствующий объект, нажать клавишу F2 и ввести новое имя объекта.

6. Закрыть окно программы Проводник и окно свойств панели задач.

Удаление команд из стартового меню

Чтобы удалить какую-либо команду из стартового меню, необходимо выполнить следующие действия:

  • Выбрать команду Панель задач и меню "Пуск" в меню Настройка стартового меню.
  • В появившемся окне открыть вкладку Настройка меню.
  • Выполнить щелчок на кнопке Удалить.
  • В появившемся окне отметить нужную команду и нажать кнопку Удалить.

Изменение свойств стартового меню

Содержимое стартового меню может отображаться с помощью маленьких или больших пиктограмм. Если использовать маленькие пиктограммы, то на каждом уровне стартового меню можно отобразить большее количество объектов. Чтобы отобразить содержимое стартового меню с помощью маленьких пиктограмм, необходимо выполнить следующие действия:

  • Выбрать команду Панель задач и меню "Пуск" в меню Настройка стартового меню.
  • В открывшемся окне установить опцию Мелкие значки в главном меню и нажать кнопку ОК.


3.8. Установка и удаление приложений Windows

В операционной системе Windows 98 есть несколько способов установки приложений, но основным является метод, основанный на использовании значка Установка и удаление программ в папке Панель управления (Пуск --> Настройка --> Панель управления) (рис. 3.19). Во всех случаях рекомендуется использовать именно это средство, поскольку прочие методы установки не гарантируют правильной регистрации приложений в реестре операционной системы.

Рис. 3.19. Окно Панель управления

Перед началом установки нового приложения следует закрыть все работающие программы и все открытые документы. В некоторых случаях необходимо закрывать и ряд фоновых процессов (их наличие может отображаться в виде значков панели индикации на правом краю Панели задач).

Особенности спецификации Windows

Приступая к установке приложений, необходимо знать особенности операционной системы, связанные с совместным использованием ресурсов, и помнить, что процедура установки непроверенных программных средств относится к категории потенциально опасных.

Принцип совместного использования ресурсов лежит в основе спецификаций Windows, и в области программного обеспечения он приводит к тому, что разные приложения могут использовать общие программные ресурсы.

Так, например, в большинстве приложений Windows можно встретить одинаковые элементы оформления и управления (окна, кнопки, раскрывающиеся списки, меню, флажки, переключатели и многое другое). Одинаковы и приемы управления ими, и методы их использования. С точки зрения приложений это означает, что их многие компоненты обрабатываются одним и тем же программным кодом.

Поэтому в Windows принято выделять стереотипные программные фрагменты и группировать их в динамические библиотеки, к которым открыт доступ из разных программ (динамические библиотеки имеют расширение имени файла .DLL).

При установке новых приложений вместе с ними устанавливаются только те программные ресурсы, которые нужны для работы данного приложения, но отсутствуют на данном компьютере, то есть, не зарегистрированы в его операционной системе. Поэтому для установки новых приложений очень важно, чтобы они проходили правильную регистрацию.

Установку программ следует выполнять стандартными средствами. Этим обеспечивается надежная работа ранее установленных приложений, и обеспечиваются основы для корректной установки последующих приложений.

Стандартное средство установки приложений

Стандартное средство установки (и удаления) приложений Windows запускается командой Пуск --> Настройка --> Панель управления --> Установка и удаление программ. После двойного щелчка на указанном значке открывается диалоговое окно Установка и удаление программ (рис. 3.20). На нем представлен список ранее установленных приложений. Они прошли правильную регистрацию, и если не были нарушены условия их эксплуатации, то можно рассчитывать на то, что они могут быть и корректно удалены.

Рис. 3.20. Окно Установка и удаление программ Windows 2000

Установка приложения начинается со щелчка на кнопке Добавление и удаление. После этого запускается вспомогательная программа Мастер установки. С помощью кнопки Обзор следует разыскать местоположение программы Setup.exe, которая входит в дистрибутивный комплект устанавливаемого приложения, после чего щелкнуть на кнопке Готово.

Во многих случаях после установки приложения следует перезагрузить компьютер. Это одна из причин, по которой до начала установки закрывают все открытые приложения и документы.

Необходимость перезагрузки связана с особенностью операционной системы, которая заключается в том, что основная часть регистрационных действий выполняется в момент завершения работы. Это сделано специально, чтобы не тормозить производительную работу пользователей служебными операциями.

Удаление приложений Windows

Удаление ранее установленных приложений Windows производится средствами того же диалогового окна Установка и удаление программ (рис. 3.20). Следует выделить удаляемый объект и щелкнуть на кнопке Заменить/Удалить. Удаление редко бывает полным. Скорее всего, какие-то компоненты останутся. Чаще всего остаются некоторые папки (как правило, пустые). Компоненты, не удаленные автоматически, следует удалить вручную.


3.9. Установка оборудования

В общем случае оборудование подключается к компьютеру дважды: аппаратно и программно. Под аппаратным подключением понимают физическое соединение с компьютером либо с помощью слотов на материнской плате, либо с помощью внешних разъемов стандартных портов на задней стенке системного блока. Бывает и смешанное подключение, когда интерфейсная плата нового устройства вставляется в слот материнской платы и при этом создается новый (нестандартный) порт, разъем которого выходит на заднюю стенку. Таким способом подключают, как правило, устройства, требующие высокой скорости передачи данных, например, сканеры или сетевые устройства.

Под программным подключением понимают установку программы-драйвера, являющейся посредником между операционной системой и устройством. При установке драйвера происходит выделение операционной системой части ресурсов новому устройству, а также регистрация устройства и его драйвера в реестре операционной системы.

Однако в общем правиле есть и исключения. Такие «стандартные» устройства, как жесткие диски, дисководы гибких дисков и клавиатура не требуют драйверов, поскольку сведения о том, как с ними работать, уже имеются в базовой системе ввода-вывода (BIOS). Они должны распознаваться и работать еще до загрузки операционной системы. То же относится и к монитору, и к видеоадаптеру, но без драйверов они распознаются только как простейшие стандартные модели. Для того чтобы использовать все функциональные возможности конкретной модели, необходимо установить драйвер.

Несколько менее «стандартными» устройствами считаются мышь и дисковод CD-ROM. Они не всегда распознаются средствами BIOS, но после загрузки операционной системы Windows 98/2000 уже считаются стандартными устройствами и обслуживаются драйверами, имеющимися в ее составе, однако если речь идет о необычных моделях, драйвер для них может потребоваться.

Абсолютное большинство прочих устройств требуют наличия программного драйвера. При продаже аппаратного обеспечения общепринято прикладывать к устройству программные драйверы на гибком или лазерном диске. В отсутствие такой возможности можно воспользоваться библиотекой драйверов, входящей в состав операционной системы. Если библиотека не поддерживает конкретную модель устройства, необходимый драйвер можно получить в Интернете на сервере фирмы, изготовившей оборудование, или на сервере компании Microsoft, где имеется коллекция драйверов устройств для операционных систем, выпускаемых этой компанией.

Средства программной установки оборудования

Базовое программное средство установки оборудования запускается двойным щелчком на значке Установка оборудования в окне папки Панель управления. С ее помощью можно установить большую часть оборудования, хотя в общем правиле есть исключения.

Драйвер монитора можно установить в диалоговом окне свойств видеосистемы Пуск --> Настройка -- > Панель управления --> Экран --> Настройка --> Дополнительно --> Монитор --> Изменить.

Там же можно установить или заменить драйвер видеоадаптера: Пуск --> Настройка --> Панель управления --> Экран --> Настройка --> Дополнительно --> Адаптер --> Изменить.

Специальные средства существуют для установки принтеров: Пуск --> Настройка --> Принтеры --> Установка принтера, а также для установки модемов Пуск --> Настройка --> Панель управления --> Модемы.

Однако наиболее универсальным средством для большей части оборудования остается Мастер установки оборудования, который запускается двойным щелчком на значке Установка оборудования в окне папки Панель управления.

Порядок установки оборудования

Новое оборудование подключается при выключенном питании компьютера. Если устройство является самоустанавливающимся (соответствует спецификации Р1ug and-Play), то после включения питания его наличие выявляется автоматически, после сообщения Обнаружено неизвестное устройство операционная система приступает к подбору драйвера для него. В этот момент может потребоваться вставить дистрибутивный диск с операционной системой в дисковод CD-ROM или использовать гибкий диск с драйвером, полученным вместе с устройством. Иногда необходимы оба диска.

Рис. 3.21. Окно Мастера установки оборудования Windows 2000

Если устройство не было опознано при запуске, надо воспользоваться Мастером установки оборудования (рис. 3.21.). Мастер запускается командой Пуск > Настройка > Установка оборудования. На первом этапе он разыскивает устройства, соответствующие спецификации Plug and Play, и выдает список обнаруженных устройств.

На втором этапе он разыскивает прочие устройства. Если нужное устройство не было обнаружено автоматически, мастер предлагает выбрать тип устройства самостоятельно, после чего открывает диалоговое окно, в котором можно выбрать производителя и конкретную модель.

При наличии нужной модели драйвер можно установить из базы данных Windows или с гибкого диска. Если абсолютного совпадения по модели достичь не удается, возможна только установка драйвера с диска, что выполняется после щелчка на кнопке Установить с диска.

По окончании процесса установки оборудования компьютер следует перезагрузить, выполнить проверку на наличие конфликтов. Для проверки наличия конфликтов используют значок Система в окне папки Панель управления или пункт Свойства контекстного меню значка Мой компьютер.


3.10. Настройка средств ввода-вывода данных

Настройка клавиатуры

Настройку клавиатуры выполняют в диалоговом окне Свойства: Клавиатура, которое открывают двойным щелчком на значке Клавиатура в окне Панель управления. На вкладке Скорость представлены средства настройки параметров функции автоповтора символов (величина задержки перед началом повтора символов и темп повтора), а также средства управления частотой мерцания курсора.

Рис. 3.22. Окно Свойства: Клавиатура

На вкладке Язык и раскладки представлены средства для установки дополнительных раскладок клавиатуры и элементы управления для выбора клавиатурной комбинации переключающей раскладку. Здесь же можно выбрать раскладку, принятую по умолчанию, а также задать отображение индикатора раскладки на панели индикации. При наличии этого индикатора диалоговое окно настройки свойств клавиатуры удобнее открывать через контекстное меню индикатора.

Настройка мыши

Настройку мыши выполняют в диалоговом окне Свойства: Мышь, которое открывают с помощью значка Мышь в окне Панель управления. На вкладке Кнопки мыши представлены средства назначения левой или правой кнопке функций основной кнопки, а также средства настройки интервала времени между щелчками, при котором два отдельных щелчка интерпретируются как один двойной.

Рис. 3.22. Окно Свойства: Мышь

На вкладке Указатели представлены средства для выбора схемы указателей мыши. Схема указателей представляет собой именованную совокупность настроек форм указателей мыши, сохраняемую в отдельном файле.

На вкладке Перемещение представлены средства для управления чувствительностью мыши (чувствительность мыши определяется величиной экранного перемещения указателя при заданном перемещении прибора), а также средства управления величиной шлейфа, тянущегося за указателем (нужда в нем возникает при работе малоконтрастными дисплеями, например, жидкокристаллическими дисплеями портативных компьютеров).

Настройка стиля управления операционной системой

От других операционных систем Windows 98/2000 отличается наличием нескольких стилей управления. Классический стиль управления, перешедший из Windows 95, характерен тем, что объекты выделяют одним щелчком, а открывают двумя щелчками.

Кроме классического, в Windows 98/2000 возможны и другие стили управления. Так, например, существует стиль Web, характерный для работы в Интернете. Он подразумевает, что объекты выделяют простым наведением указателя, а открывают одним щелчком. Данный стиль позволяет несколько повысить производительность в ряде операций с объектами, но не очень удобен при проведении групповых операций.

Выбор того или иного стиля управления выполняют включением соответствующего переключателя на вкладке Общие диалогового окна Мой компьютер --> Сервис --> Свойства папки


3.11. Настройка элементов оформления Windows 98/2000

Настройка фона Рабочего стола

Операционные системы Windows 98 и Windows 2000 позволяют использовать в качестве фона Рабочего стола фоновый узор, фоновый рисунок или документ в формате HTML (в этом формате представляются Web-страницы Интернета). Выбор метода оформления осуществляют на вкладке Фон диалогового окна Свойства: Экран, которое открывают с помощью значка Экран в окне Панель управления или посредством пункта Свойства контекстного меню Рабочего стола.

Рис. 3.24. Окно Свойства: Экран

При выборе объекта, используемого в качестве фона, предполагается, что он находится в папке C:\Windows. Если это не так, путь доступа к нужной папке можно указать с помощью командной кнопки Обзор. При выборе фонового узора предоставляются средства для его редактирования и сохранения, то есть для создания новых фоновых узоров на основе имеющихся.

При выборе фонового рисунка предоставляются средства для выбора способа его расположения (по центру экрана или на полном экране). В последнем случае возможен выбор варианта Растянуть перемасштабированием изображения в соответствии с размером Рабочего стола или варианта Рядом (без перемасштабирования, но с размножением копий рисунка по всему полю Рабочего стола).

Настройка экранной заставки

Экранные заставки — это динамические изображения, воспроизведение которых включается автоматически при отсутствии в течение заданного времени событий, вызванных пользователем.

Первоначальное назначение заставок состояло в том, чтобы снизить угрозу «выгорания люминофора» на тех участках экрана, которые подвержены особо длительному стационарному воздействию электронного луча. Результатом этого эффекта было образование бурых пятен в местах длительного воздействия луча. Современным мониторам эффект «выгорания люминофора» не грозит, но экранные заставки продолжают использовать как средство сокрытия экранной информации от посторонних наблюдателей в период отсутствия владельца компьютера на рабочем месте.

Выбор и настройку режима действия экранной заставки осуществляют на вкладке Заставка диалогового окна Свойства: Экран (рис.3.24.). Представленные здесь средства настройки позволяют задать интервал времени, по прошествии которого при отсутствии событий, вызванных пользователем, происходит автоматический запуск заставки, а также назначить пароль.

Настройка оформления элементов управления Windows

Средства настройки внешнего вида элементов управления Windows сосредоточены на вкладке Оформление диалогового окна Свойства: Экран (рис.3.24.). Прежде всего они предназначены для выбора цветовых и шрифтовых настроек. Именованная совокупность данных, описывающих конкретную настройку, называется схемой оформления, она может быть сохранена в файле. Средства настройки оформления позволяют загружать готовые схемы оформления, создавать на их основе новые схемы путем редактирования и сохранять их под заданными именами.

При редактировании конкретной схемы возможно изменение каждого из двух десятков элементов оформления по используемому шрифту и цвету.

Дополнительные средства оформления Рабочего стола

Ряд дополнительных средств оформления Рабочего стола представлен на вкладке Эффекты диалогового окна Свойства: Экран (рис.3.24.). Действие визуальных эффектов, представленных здесь, хорошо прокомментировано названиями соответствующих элементов управления и легко проверяется практическими экспериментами.

Средства оформления Рабочего стола Active Desktop

Если Рабочий стол находится в режиме Active Desktop, его оформление представляет собой аналог Web-страницы, и на Рабочем столе возможно размещение нескольких активных объектов. Активными считаются объекты, которые могут динамически изменяться под управлением внешней программы или удаленного сервера. Таким образом, Рабочий стол Active Desktop может выполнять функции динамического отображения поставляемого содержимого.

Размещением активных компонентов Рабочего стола можно управлять непосредственно на Рабочем столе путем перетаскивания их с помощью мыши. Однако подключением и отключением активных компонентов, а также назначением связи между активным компонентом и поставщиком его содержимого удобно управлять с вкладки Web диалогового окна Свойства: Экран.

Настройка параметров экрана

К настраиваемым параметрам экрана относятся:

  • величина экранного разрешения (измеряется в точках по горизонтали и вертикали);
  • величина цветового разрешения (выражается количеством одновременно отображаемых цветов или разрядностью кодирования цвета точки).

Предельные значения обоих параметров зависят от свойств видеоадаптера и монитора. Их можно задать на вкладке Настройка диалогового окна Свойства: Экран. Цветовое разрешение (глубину цвета) выбирают в раскрывающемся списке Цветовая палитра, а разрешение экрана устанавливают с помощью движка Область экрана.

При недостаточном объеме видеопамяти, присутствующей на плате видеоадаптера, установка повышенного разрешения экрана приводит к сокращению списка возможных значений параметра глубины цвета.

Настройка свойств видеоадаптера и монитора

Настройку свойств видеоадаптера и монитора выполняют в диалоговом окне свойств видеоподсистемы, которое открывают щелчком на кнопке Дополнительно на вкладке Настройка диалогового окна Свойства: Экран (рис. 3.25). В указанном диалоговом окне настройку свойств монитора выполняют на вкладке Монитор, а настройку свойств видеоадаптера — на вкладке Адаптер.

Если и монитор, и видеоадаптер установлены с использованием оригинальных драйверов, на вкладке Адаптер возможна настройка частоты обновления экрана. Предельные значения этого параметра зависят от текущего экранного разрешения, и потому данную регулировку следует провести отдельно для каждого из возможных рабочих разрешений экрана.

Рис. 3.25. Окно Свойства: Экран кнопка Дополнительно вкладка Монитор

Если монитор и видеоадаптер установлены с использованием заменяющих драйверов, управление частотой регенерации экрана может быть ограничено, а в некоторых случаях даже опасно для монитора. В этом случае рекомендуется выбор пункта Определяется адаптером или Оптимальная в раскрывающемся списке Частота обновления.

Настройка звуковых схем

Операционная система Windows является объектно-ориентированной. Управление подобными программными системами организуется с использованием так называемого событийного механизма.

Все операции пользователя, которые он выполняет с экранными элементами управления, являются, с точки зрения операционной системы событиями пользователя. Кроме событий пользователя существуют так называемые системные события, к которым относятся особые ситуации (исключения), возникающие в операционной системе в тех случаях, когда происходит штатное или нештатное программное событие, требующее реакции пользователя.

Оформление Windows является не только визуальным, но и звуковым. К системным событиям и событиям пользователя могут быть поставлены в соответствие звуковые клипы, которые воспроизводятся при наступлении событий. Так событиями, например, могут быть открытие или закрытие окна, удаление объекта в Корзину, поступление электронной почты на сервер, запуск Windows и т.д. Именованная совокупность настроек, связанных с назначением определенным событиям определенных звуков, называется звуковой схемой.

Для настройки звуковых схем используют диалоговое окно Свойства: Звук, которое открывают с помощью значка Звук в окне папки Панель управления.

Оформление Windows темами Рабочего стола

Характерной особенностью Windows 98, отличающей данную систему от других операционных систем, является наличие так называемых тем Рабочего стола. Каждая тема Рабочего стола представляет собой комплексный элемент оформления, в который входят: схема оформления, схема указателей, звуковая схема, фоновый рисунок Рабочего стола, заставка экрана и коллекции значков Рабочего стола. Для тем Рабочего стола характерно художественное согласование всех вышеуказанных элементов оформления в рамках одной темы.

Выбор, настройка и запуск тем Рабочего стола производится с помощью значка Темы Рабочего стола в окне папки Панель управления. При настройке темы есть возможность произвольного выбора подключаемых компонентов и предварительного ознакомления с их содержанием.


Настройка Главного меню

Главное меню — основной элемент управления в Windows. С его помощью можно запустить любую программу, установленную на компьютере с ведома операционной системы, открыть документы, с которыми выполнялась работа в последние дни, выполнить большинство настроек компьютера и операционной системы. Главное меню открывается щелчком на кнопке Пуск.

Главное меню — многоуровневое. Так, например, при наведении указателя мыши на пункт Программы открывается система вложенных меню, отображающая распределение программ по разным категориям.

По своим свойствам каждая категория Главного меню имеет статус папки, а каждый пункт — статус ярлыка. Таким образом, структурой Главного меню можно управлять путем управления структурой папок, представляющих его.

Простейший способ открыть структуру Главного меню для редактирования — воспользоваться пунктом Проводник в контекстном меню кнопки Пуск.

Настройка свойств Корзины

Корзина представляет собой специальную папку Windows 98, в которой временно хранятся удаленные объекты. Физически Корзина на жестком диске представлена скрытой папкой \Recycled, причем для каждого жесткого диска, имеющегося в вычислительной системе, папка \Recycled — своя. Однако логически Корзина представляет собой одну-единственную папку, соответствующую всем папкам \Recycled, имеющимся в компьютерной системе.

Настройку свойств Корзины выполняют в диалоговом окне Свойства: Корзина, открываемом выбором пункта Свойства в контекстном меню. Данное диалоговое окно содержит одну вкладку для настройки глобальных свойств интегрированной Корзины и по одной вкладке на каждый жесткий диск из числа имеющихся в составе вычислительной системы.

Если на вкладке Глобальные установлен переключатель Единые параметры для всех дисков, то элементы управления вкладок, соответствующих конкретным дискам, не активизируются.

Рис. 3.26. Окно Свойства: Корзина

Основным параметром Корзины является ее емкость. Этот параметр выставляется движком и измеряется в процентах от емкости соответствующих дисков (по умолчанию — 10%). Прочие элементы управления диалогового окна свойств Корзины предусматривают возможность удаления объектов без помещения их в Корзину (используется при глобальной расчистке жесткого диска) и возможность отключения сообщения, предупреждающего об удалении объектов.

Настройка свойств окон папок

К основным настройкам свойств окон папок относится настройка режима отображения скрытых и системных объектов, а также настройка способа обзора вложенных папок.

Настройку свойств окон папок осуществляют в диалоговом окне Свойства папки. Его можно открыть из окна любой папки командой Сервис --> Свойства папки вкладка Вид.

Отображение системных и скрытых объектов целесообразно включать перед удалением папок, а также при обслуживании операционной системы. При обычной работе системные и скрытые объекты лучше не отображать, чтобы не перегружать экран излишней информацией. (Если скрытые объекты не отображаются в окне папки, об их наличии можно судить по записи в строке состояния.)

Существует два способа обзора вложенных папок. В одном случае все вложенные папки открываются в одном и том же окне, а в другом для каждой очередной вложенной папки открывается новое окно.

Первый способ не перегружает Рабочий стол открытыми окнами, но при этом теряется наглядность навигации в структуре окон папок. Соответственно, достоинства и недостатки второго метода противоположны. Выбор способа обзора выполняют из окна любой папки командой Сервис --> Свойства папки вкладка Общие путем установки переключателя Открывать папки в одном и том же окне или переключателя Открывать каждую папку в отдельном окне (рис. 3.27).

Рис. 3.27. Окно Сервис --> Свойства папки вкладка Общие


Настройка шрифтов

Важным преимуществом графических операционных систем является возможность гибкого управления как экранными, так и печатными шрифтами в документах.

Операционная система обеспечивает единство принципов применения шрифтов в самых разнообразных приложениях.

Растровые и векторные шрифты

Операционная система Windows 98/2000 позволяет работать с двумя классами шрифтов: растровыми и векторными. Символы растровых шрифтов образуют комбинации точек в матрице заданного размера. Достоинством растровых шрифтов является высокая скорость отображения символьных данных на экране.

В связи с этим операционная система использует растровые шрифты в качестве экранных при отображении системной информации. Основным недостатком растровых шрифтов является негибкость управления размером и начертанием символов.

Символы векторных шрифтов представляют собой криволинейные контуры, составные элементы которых описываются математическими формулами. Это позволяет не хранить отдельно символьные наборы разных размеров. Управление размером (и некоторыми видами начертания) шрифта происходит программно. При отображении на экране или при выводе на печать символы любых размеров строятся из одного и того же символьного набора, поэтому векторные шрифты называют также масштабируемыми.

Векторные шрифты могут использоваться как в качестве экранных, так и в качестве печатных. Применение векторных шрифтов при подготовке документов позволяет реализовать принцип соответствия экранного изображения печатному — так называемый принцип WYSIWYG (What You See Is What You Get). В соответствии с этим принципом мы наблюдаем оформление документа на экране таким, каким оно будет при выводе с помощью печатающего устройства.

Векторные шрифты True Type и PostScript

В настоящее время наибольшее распространение имеют векторные шрифты двух категорий: True Type и PostScript.

Поддержку шрифтов категории True Туре осуществляет лидер в разработке операционных систем и продуктов офисного применения — корпорация Microsoft. Соответственно, операционная система Windows, выпущенная той же корпорацией, обеспечивает возможность использования шрифтов True Type в большинстве приложений без необходимости использования каких-либо специальных средств.

Поддержку шрифтов категории PostScript осуществляет лидер в области программного обеспечения для устройств печати и полиграфических систем — компания Adobe.

При работе с приложениями, выпущенными этой компанией, иногда целесообразно использовать векторные шрифты PostScript. В этом случае операционная система Windows не может работать с ними напрямую и нуждается в специальной программе, работающей в фоновом режиме. В частности, такой программой являются различные версии программы Adobe Type Manager.

Системное средство установки и удаления шрифтов

Файлы, содержащие данные о конструкции шрифтовых наборов, находятся в папке C:\Windows\Fonts, но эту папку не следует обслуживать традиционным средством для работы с файлами и папками, программой Проводник.

Шрифты нельзя устанавливать и удалять путем простого копирования, перемещения и удаления файлов. Они должны проходить особую процедуру регистрации в реестре операционной системы, а для этого нужны специальные средства обслуживания. Именно процесс регистрации и дает нам возможность напрямую использовать одни и те же шрифты и символьные наборы в различных приложениях.

Для шрифтов категории True Type средство установки входит в состав Windows и находится в папке Панель управления (Пуск --> Настройка --> Панель управления --> Шрифты) . Просмотр шрифтов, зарегистрированных операционной системой, можно выполнять в следующих режимах:

  • крупные значки;
  • список;
  • подобие (группировать схожие шрифты);
  • подробности (таблица).

Соответствующие элементы управления представлены кнопками панели документов окна и пунктами меню Вид. Режимы просмотра Подобие (Группировать схожие шрифты) и Подробности (Таблица) — особые, характерные только для папки Fonts.

В режиме Подобие (Группировать схожие шрифты) отображаются сведения о схожести шрифтов на заданный. Шрифт, с которым производится сравнение, выбирают в раскрывающемся списке Группировать шрифты по схожести со шрифтом. В режиме Подробности (Таблица) для файлов шрифтов приводятся некоторые специальные сведения.

Перед установкой нового шрифта следует закрыть все работающие приложения. Это не значит, что их работа непременно нарушится, — она просто не гарантирована.

Установка шрифтов выполняется в диалоговом окне Добавление шрифтов, открываемом по команде Файл > Установить шрифт. Порядок установки следующий:

1. В раскрывающемся списке Диск выбрать диск, на котором расположены файлы устанавливаемого шрифта.

2. В списке Папки выбрать папку, в которой расположены файлы устанавливаемого шрифта.

3. Подождать некоторое время, пока в поле Список шрифтов не сформируется список шрифтов, найденных в указанном источнике.

4. В поле Список шрифтов выбрать устанавливаемые шрифты (при групповом выделении использовать клавиши SHIFT и CTRL).

5. Запустить процесс установки щелчком на командной кнопке ОК.

6. Если шрифт устанавливается для продолжительной работы, целесообразно установить флажок Копировать шрифты в папку Fonts.

Удаление шрифтов производится командой Файл --> Удалить. Соответствующие шрифты при этом должны быть выделены.


3.12. Прочие настройки Windows

Настройка системных часов и системного календаря

При сохранении любого файла вместе с ним сохраняются данные о дате и времени создания или последнего изменения. Это сохранение происходит в полном соответствии с текущими настройками системных часов и системного календаря компьютера.

Средства настройки часов и календаря относятся к базовому программному обеспечению компьютера и располагаются в его базовой системе ввода и вывода (BIOS). Опираясь на показания системных часов, операционная система Windows обеспечивает следующие функциональные возможности:

  • сохранение показаний системных часов вместе с атрибутами файлов при каждой операции сохранения данных;
  • предоставление для настройки системных часов и календаря более удобного интерфейса, чем тот, который предоставляет система BIOS;
  • автоматический учет таких факторов, как изменение поясного времени (это важно для портативных компьютеров), переход на «летнее» и «зимнее» время, учет последних цифр года при смене века.

В Windows 98/2000 настройку системных часов и системного календаря выполняют на вкладке Дата и время диалогового окна Свойства: Дата и время, которое открывается с помощью соответствующего значка Панели управления (рис. 3.29) или из контекстного индикатора времени, расположенного на панели индикации.

Текущий год выставляют с помощью кнопок счетчика. Текущий месяц выбирают в раскрывающемся списке. День месяца выбирают на панели календаря. Точное время устанавливают поразрядно (часы, минуты, секунды) — разряд выбирают с помощью указателя мыши, а значение изменяют с помощью кнопок счетчика. Настройку даты и времени завершают щелчком на командной кнопке Применить (без закрытия окна) или на кнопке ОК (с закрытием).

Рис. 3.29. Окно настройки системных часов и системного календаря

На вкладке Часовой пояс диалогового окна Свойства: Дата и время присутствуют только два элемента управления: раскрывающийся список для выбора соответствующего часового пояса и флажок для учета перехода на «летнее» и «зимнее» время.

Настройка национальных стандартов и форматов

Операционная система Windows в значительной степени учитывает национальные различия, связанные с форматами записи чисел, дат, времени, денежных сумм и т. п. Так, например, в России принято представлять даты в формате дд.мм.гг (день-месяц-год), а в США — мм.дд.гг (месяц-день-год). Например, запись 08.03.99 в России означает 8 марта 1999 года. Та же запись в США означает 3 августа того же года. Другой пример: в России десятичная часть дробного числа отделяется от целой части с помощью запятой, а в США — точкой. Есть различия в форматах записи времени, отрицательных чисел, денежных сумм, единиц измерения физических и денежных величин. Такие различия относятся не только к России и США, но и к другим странам.

Рис. 3.30. Окно настройки национальных стандартов и форматов

Обычно при установке локализованной версии операционной системы настройка национальных стандартов и форматов производится автоматически, в соответствии с указанием страны пребывания в устанавливающей программе. Однако при работе с некоторыми приложениями, не адаптированными к использованию в конкретной стране, необходимо редактировать настройки, принятые по умолчанию. В таких случаях редактирование настроек выполняют на вкладках диалогового окна Язык и стандарты (Пуск --> Настройка --> Панель управления --> Язык и стандарты) (рис. 3.30).


3.13. Справочная система Windows 98/2000

Современное программное обеспечение отличается высокой сложностью, поэтому и в операционной системе, и в большинстве ее приложений предусмотрено наличие справочных систем. Справочную систему Windows 98/2000 можно рассматривать как автоматизированное информационно-справочное средство.

Справочная система в диалоговых окнах

В Windows 98 реализовано несколько уровней доступа к справочной информации. Особенно часто потребность в быстрой и конкретной справке возникает при работе с элементами управления диалоговых окон. Эту возможность предоставляет специальная кнопка подсказки, расположенная в правом верхнем углу диалоговых окон рядом с закрывающей кнопкой.

Подпись: После щелчка на кнопке подсказки указатель мыши принимает форму вопросительного знака. Если навести его в таком состоянии на один из элементов управления диалогового окна и щелкнуть левой кнопкой, появляется всплывающая подсказка, в которой описано назначение данного элемента управления. Этим приемом пользуются при изучении новых диалоговых окон.

Контекстная подсказка

Прием получения контекстной подсказки действует в большинстве диалоговых окон и в некоторых окнах приложений. Его удобно рассматривать на примере стандартной программы Калькулятор, входящей в комплект поставки Windows (Пуск --> Программы --> Стандартные --> Калькулятор).

Окно Калькулятора не является диалоговым — это рабочее окно приложения, но оно тоже содержит немало всевозможных элементов управления. Поскольку это не диалоговое окно, в его правом верхнем углу нет кнопки подсказки, однако подсказку по назначению элементов управления получить можно.

Щелкните правой кнопкой мыши на любом элементе управления, и рядом с ним появится кнопка контекстной подсказки с надписью Что это такое? Если щелкнуть на этой кнопке, откроется всплывающая подсказка с описанием назначения элемента управления.

Справочная система Windows

Классический прием вызова справочной системы Windows состоит в использовании Главного меню (Пуск --> Справка), но то же можно сделать из любого окна папки или Проводника, если использовать пункт Справка в строке меню.

На панели навигации окна справочной системы три вкладки: Содержание, Указатель и Поиск (рис. 3.31а, б). Панель навигации служит для отыскания нужного раздела и статьи справочной системы. На панели содержания отображается текст текущей статьи.

На вкладке Содержание разделы справочной системы представлены в виде иерархической структуры данных, очень похожей на содержание обычных книг. Разделы самого высокого уровня легко охватить беглым взглядом. Раздел раскрывается одним щелчком левой кнопки мыши. Внутри раздела могут содержаться вложенные разделы или отдельные статьи. При щелчке на статье ее содержимое отображается на правой панели.

а)

б)

Рис. 3.31. Окно справочной системы: а) Windows 2000, б) Windows 98

Статьи справочной системы, представленные на правой панели, могут активно использовать так называемые перекрестные ссылки. Перекрестные ссылки оформлены в виде выделенных фрагментов текста. При щелчке на таких фрагментах происходит переход к другой статье, содержимое которой дополняет или уточняет первую.

Текст, содержащий ссылки между отдельными статьями, называется гипертекстом. Для того чтобы не запутаться при движении по гипертекстовому документу и иметь возможность вернуться к исходному пункту, используют кнопки навигационной панели Назад и Вперед.

Данные, представленные на вкладке Указатель, имеют линейную структуру (список). Фактически — это алфавитный указатель, аналогичный тем, которые можно встретить в конце научно-технических изданий. Здесь приведены термины, встречающиеся в справочной системе программы. Если нужно найти конкретные данные и нет желания просматривать все содержание справочной системы, используют указатель.

Отыскав нужный термин или понятие, надо щелкнуть на нем дважды. Если этот термин встречается только в одной статье справочной системы, то на правой панели сразу будет отображен текст статьи. Если данный термин встречается несколько раз, появляется диалоговое окно, в котором можно выбрать нужную статью из предлагаемого списка.

Для таких крупных систем, как Windows, последовательный просмотр и содержания, и указателя может быть неудобным — в этом случае используют вкладку Поиск. Искомое слово вводят в поле ввода и щелкают на кнопке Список разделов. Если это слово встречается в статьях справочной системы, на экране отображается список соответствующих статей. Просмотр включают двойным щелчком на названии статьи или выделив статью и щелкнув на кнопке Вывести.

В справочной системе Windows 98/2000 искомое слово надо вводить полностью, иначе поиск работает некорректно. Справочная система Windows 95 (и ее приложений) имеет другой, более устойчивый механизм, и в ней можно вводить фрагменты искомых слов, например, только первые буквы слов без окончаний.


3.14. Стандартные приложения Windows 98/2000

В операционную систему Windows 98/2000 входит ограниченный набор прикладных программ, с помощью которых можно решать некоторые простейшие повседневные задачи, пока на компьютере не установлены более мощные программные средства. Такие программы, входящие в поставку Windows, называют стандартными приложениями. В силу особой простоты их принято также рассматривать в качестве учебных. Знание приемов работы со стандартными приложениями позволяет ускорить освоение специализированных программных средств.

Программа Блокнот

Блокнот — это простейший текстовый редактор (рис. 3.32), который можно использовать в качестве удобного средства просмотра текстовых файлов (формат .ТХТ и некоторые другие).

Для создания текстовых документов его применяют редко (только для небольших записок), но данную программу удобно использовать для отработки навыков работы с клавиатурой. Программа запускается командой Пуск —> Программы —> Стандартные —> Блокнот. На примере программы Блокнот мы познакомимся с некоторыми приемами создания, редактирования и сохранения документов, типичными для большинства приложений Windows.

Ввод текста с помощью клавиатуры. Текст вводят с помощью алфавитно-цифровых клавиш. Для ввода прописных букв используют клавишу SHIFT. Если нужно ввести длинный ряд (поток) прописных символов, клавиатуру можно переключить с помощью клавиши CAPS LOCK.

Когда текст достигает правой границы окна, он может автоматически перетекать на новую строку, но может продолжаться далее, пока не будет нажата клавиша ENTER. Чтобы включить (или отключить) режим автоматического перетекания текста, используют команду Правка > Перенос по словам.

Рис. 3.32. Окно программы Блокнот

Понятие курсора. Место документа, в которое происходит ввод текста (точка ввода), отмечается на экране вертикальной чертой, которую называют курсором. Не надо путать курсор с указателем мыши — это два разных понятия. Указатель мыши — это активный элемент управления, а курсор — это только маркер, не выходящий за пределы документа.

Переключение между русскими и латинскими символами. При наборе текста иногда приходится переключаться между русскими и латинскими символами. Это делается общесистемным способом, то есть метод переключения между символьными наборами не зависит от конкретной программы, а выполняется во всех программах одинаково. Это функция операционной системы.

Для того чтобы узнать, какой комбинацией клавиш на данном компьютере выполняется переключение раскладок клавиатуры, надо посмотреть, как настроены свойства (Пуск —> Настройка —> Панель управления —> Клавиатура, вкладка Язык).

Выбор шрифта. Размер и форма символов языка определяются использованным шрифтом. Редактор Блокнот слишком прост для того, чтобы позволить использование разных шрифтов в документе, но выбрать один шрифт, используемый для отображения документа, он позволяет. Это выполняется командой Правка —> Шрифт, после которой открывается системное диалоговое окно Выбор шрифта.

В списке Начертание можно задать начертание для избранного шрифта. Обычно используют четыре основных типа начертания: прямое светлое (обычное), наклонное (курсив), полужирное и полужирный курсив.

В списке Размер выбирают размер шрифта. Размеры шрифтов измеряются в пунктах. Пункт — это типографская единица измерения, равная 1/72 дюйма (0,353 мм). Для того чтобы документ хорошо читался на экране, обычно используют шрифт размером 12 пунктов.

Сохранение созданного документа. Созданный документ сохраняют на жестком или гибком магнитном диске в виде нового файла. При сохранении следует указать имя файла. Если этого не сделать, он сохранится под именем Безымянный.txt. Для сохранения нового документа служит команда Файл —> Сохранить как. По этой команде открывается диалоговое окно Сохранение.

В этом окне выбирают папку, в которую будет сохраняться файл, и дают ему имя. Приемы сохранения файлов одинаковы для всех приложений Windows. В качестве папки, в которую редактор Блокнот сохраняет документы по умолчанию, служит папка Мои документы. Большинство приложений Windows предлагают по умолчанию использовать для сохранения документов именно эту папку. В ней можно создать несколько папок для раздельного хранения документов, относящихся к разным темам (проектам) или пользователям.

Если предложенная папка Мои документы соответствует желанию автора, то остается только ввести имя файла в поле Имя файла и щелкнуть на кнопке Сохранить.

Чтобы ранее сохраненный документ сохранить в другой папке, либо под другим именем необходимо пользоваться командой Сохранить как.

Приемы редактирования документов. Под редактированием понимают изменение уже существующих документов. Редактирование начинают с загрузки (открытия) документа. Для этого служит команда Файл —> Открыть.

По этой команде экране появляется стандартное диалоговое окно Открытие документа. Как и окно Сохранение, оно одинаково во всех приложениях Windows. По умолчанию окно Открытие документа открывается с настройкой на папку Мои документы. Если нужный документ находится в другой папке, ее надо разыскать и раскрыть.

Для редактирования текстовых документов следует научиться управлять курсором. Его перемещают с помощью специальных клавиш управления курсором. Для перемещения курсора на экранную страницу вверх или вниз используют клавиши PAGE UP и PAGE DOWN. Для перевода курсора в начало текущей строки используют клавишу HOME, а в конец строки — клавишу END. В большинстве приложений Windows работают также комбинации клавиш CTRL+HOME и CTRL+END, переводящие курсор в начало или конец документа, соответственно. Для произвольного размещения курсора используют указатель мыши.

Удаление ошибочных символов выполняют клавишами BACKSPACE или DELETE. Первая удаляет символы, стоящие слева курсора, а вторая — справа. Для удаления большого блока текста сначала выделяют текстовый блок, а потом нажимают клавишу DELETE. При этом удаляется весь выделенный блок.

Существует прием выделения текстовых фрагментов с помощью клавиатуры. Он выполняется клавишами управления курсором при нажатой клавише SHIFT.

Выделенные фрагменты текста можно не только удалять, но и копировать или перемещать. Эти приемы очень часто применяются при редактировании. Копирование и перемещение происходит через буфер обмена Windows. Напомним комбинации клавиш, которые следует запомнить:,

CTRL + С — копировать в буфер;

CTRL + Х — вырезать в буфер;

CTRL + V — вставить из буфера.

Программа Блокнот не позволяет работать более чем с одним документом, но ее можно запустить два и более раз. В этом случае на экране можно иметь несколько окон программы с разными документами. Перенос текстовых фрагментов через буфер обмена возможен не только внутри одного окна, но и между окнами.

Средства автоматизации. В этой программе есть единственное средство автоматизации и состоит оно в том, что при нажатии на клавишу F5 в документ автоматически впечатывается текущее время и дата. Это удобно для ведения деловых записей и дневников.


Графический редактор Paint

Рис. 3.33. Графический редактор Paint

Графическими называют редакторы, предназначенные для создания и редактирования изображений (рисунков).

Paint — простейший графический редактор. По своим возможностям он не соответствует современным требованиям, но в силу простоты и доступности остается необходимым компонентом операционной системы. Разобравшись с принципами управления этой программой, легче осваивать другие, более мощные средства работы с графикой.

Программа запускается командой Пуск —> Программы —> Стандартные —> Paint.

Рабочее окно программы Paint представлено на рис.3.33. В состав его элементов управления, кроме строки меню, входят панель инструментов, палитра настройки инструмента и цветовая палитра. Кнопки панели инструментов служат для вызова чертежно-графических инструментов.

Задание размера рабочей области. Перед началом работы следует хотя бы приблизительно задать размер будущего рисунка. Размеры задают в полях Ширина и Высота диалогового окна Атрибуты (Рисунок —> Атрибуты).

Размер в сантиметрах задают в тех случаях, когда предполагается вывод работы на печатающее устройство (принтер) или встраивание изображения на страницу с текстовым документом. В тех случаях, когда рисунок предназначен для воспроизведения на экране, в качестве единицы измерения выбирают Точки (пиксели). Так, например, если рисунок готовится для использования в качестве фона Рабочего стола, его размеры следует принять равными величине экранного разрешения монитора (640х480; 800х600; 1024х768 точек и т.д.).

Подготовка к созданию «прозрачных» рисунков. Возможность создания «прозрачных» рисунков — одна из особенностей редактора Paint для операционной системы Windows 98/2000. В редакторе Paint для Windows 95 такой возможности не было.

В диалоговом окне Атрибуты можно назначить один цвет (например, белый) для использования в качестве «прозрачного». Прозрачность цвета означает, что если данный рисунок будет отображаться поверх другого рисунка (фонового), то нижний рисунок будет виден сквозь верхний в тех точках, которые имеют цвет, назначенный «прозрачным». Однако свойство прозрачности сохраняется в файле рисунка не всегда, а только в тех случаях, когда при сохранении выбран графический формат .GIF. Рисунки с прозрачным фоном широко используют для создания Web-страниц в Интернете и при создании электронных документов, например, в мультимедийных изданиях.

Основные чертежно-графические инструменты. Все инструменты, кроме Ластика выполняют рисование основным цветом (выбирается щелчком левой кнопки по палитре красок). Ластик стирает изображение, заменяя его фоновым цветом (выбирается щелчком правой кнопки мыши в палитре красок).

Инструмент Линия предназначен для вычерчивания прямых. Толщину линии выбирают в палитре настройки. Линии вычерчивают методом протягивания мыши. Чтобы линия получилась «строгой» (вертикальной, горизонтальной или наклонной под углом 45°), при ее вычерчивании следует держать нажатой клавишу SHIFT.

Инструмент Карандаш предназначен для рисования произвольных линий. Толщину линии выбирают в палитре настройки.

Инструмент Кривая служит для построения гладких кривых линий. Толщину выбирают в палитре настройки. Построение производится в три приема. Сначала методом протягивания проводят прямую линию, затем щелчком и протягиванием в стороне от линии задают первый и второй радиусы кривизны.

Инструмент Кисть можно использовать для свободного рисования произвольных кривых, как Карандаш, но чаще его используют для рисования методом набивки. Сначала выбирают форму кисти в палитре настройки, а потом щелчками левой кнопки мыши наносят оттиски на рисунок без протягивания мыши.

Инструмент Распылитель используют как для свободного рисования, так и для рисования методом набивки. Форму пятна выбирают в палитре настройки.

Инструмент Прямоугольник применяют для рисования прямоугольных фигур. Рисование выполняется протягиванием мыши. В палитре настройки можно выбрать метод заполнения прямоугольника. Возможны три варианта: Без заполнения (рисуется только рамка), Заполнение фоновым цветом и Заполнение основным цветом.

Если при создании прямоугольника держать нажатой клавишу SHIFT, образуете правильная фигура. Для прямоугольника правильной фигурой является квадрат.

Аналогичный инструмент Скругленный прямоугольник действует точно так же, и при этом получается прямоугольник со скругленными углами.

Инструмент Многоугольник предназначен для рисования произвольных многоугольников. Рисование выполняют серией последовательных щелчков с протягиванием. Если конечная точка многоугольника совпадает с начальной, то многоугольник считается замкнутым. Замкнутые фигуры могут автоматически заливаться краской в соответствии с вариантом заполнения, выбранным в палитре настройки.

Инструмент Эллипс служит для изображения эллипсов и окружностей. Окружность — это частный случай «правильного» эллипса. Она получается при рисовании с нажатой клавишей SHIFT.

Инструмент Заливка служит для заполнения замкнутых контуров основным или фоновым цветом. Заполнение основным цветом производится щелчком левой кнопки мыши, а заполнение фоновым цветом — щелчком правой кнопки.

Инструмент Выбор цветов позволяет точно выбрать основной или дополнительный цвет не из палитры красок, а непосредственно из рисунка. Это важно, когда надо обеспечить тождественность цвета в разных областях изображения. После выбора инструмента наводят указатель на участок рисунка с нужным цветом и щелкают кнопкой мыши. Если произошел щелчок левой кнопкой, текущий цвет становится основным, а если правой — фоновым.

Инструменты выделения областей. Два инструмента предназначены для работы выделенными областями: Выделение и Выделение произвольной области. Инструмент Выделение формирует не произвольную, а прямоугольную выделенную область. Выделенную область можно удалить клавишей DELETE, скопировать в буфер обмена (CTRL+C), вырезать в буфер обмена (CTRL+X) и вставить из буфера обмена (CTRL+V).

Масштабирование изображений. Для точной доводки рисунка иногда необходимо увеличить его масштаб. Максимальное увеличение — восьмикратное. Для изменения масштаба служит команда Вид —> Масштаб. То же можно сделать с помощью инструмента Масштаб, в этом случае величину масштаба выбирают в палитре настройки.

В режиме восьмикратного увеличения на рисунок можно наложить вспомогательную сетку (Вид —> Масштаб —> Показать сетку). Каждая ячейка этой сетки представляет собой одну увеличенную точку изображения. В этом режиме удобно редактировать изображение по отдельным точкам.

Трансформация изображений. Трансформациями называют автоматические изменения формы, расположения или размеров графических объектов. В программе Paint не слишком много инструментов трансформации, но все-таки они есть. Их можно найти в меню Рисунок.

Команда Рисунок —> Отразить/повернуть вызывает диалоговое окно Отражение и поворот, содержащее элементы управления для симметричного отображения рисунка относительно вертикальной или горизонтальной оси симметрии, а также для поворота на фиксированный угол, кратный 90°.

Команда Рисунок —> Растянуть/наклонить вызывает диалоговое окно Растяжение и наклон. Его элементы управления позволяют растянуть рисунок по горизонтали и вертикали или наклонить относительно горизонтальной или вертикальной оси. Параметры растяжения задают в процентах, а параметры наклона — в угловых градусах.

Команда Рисунок > Обратить цвета действует как переключатель. При использовании этой команды цвет каждой точки изображения меняется на «противоположный». В данном случае мы назвали «противоположным» тот цвет, который дополняет данный цвет до белого.

Ввод текста. Программа Paint — графический редактор и не предназначена для работы с текстом. Поэтому ввод текста в этой программе является исключением, а не правилом. Избегайте использования мелких символов, которые смотрятся неопрятно. Рассматривайте режим работы с текстом в программе Paint только как средство для создания кратких и крупных заголовков.

Для ввода текста используют инструмент Надпись. Выбрав инструмент, щелкните на рисунке примерно там, где надпись должна начинаться, — на рисунке откроется поле ввода. В это поле вводится текст с клавиатуры. Размер поля ввода изменяют путем перетаскивания маркеров области ввода — небольших прямоугольных узлов, расположенных по сторонам и углам области ввода.

Закончив ввод, вызывают панель атрибутов текста (Вид —> Панель атрибутов текста). Элементами управления этой панели можно выбрать форму шрифта, его начертание и размер.


Текстовый процессор WordPad

Текстовые процессоры, как и текстовые редакторы, служат для создания, редактирования и просмотра текстовых документов. Однако они выполняют еще одну важную функцию — форматирование документов.

В стандартную поставку Windows входит текстовый процессор WordPad, который фактически является «облегченной» версией гораздо более мощной программы Word. Процессор WordPad запускается командой Пуск —> Программы —> Стандартные —> WordPad.

Как видно из этого рисунка, в отличие от текстового редактора Блокнот окно текстового процессора содержит дополнительную панель элементов управления — панель форматирования.

Поскольку с приемами создания и редактирования документа мы знакомы по текстовому редактору Блокнот (см. выше), то на примере текстового процессора WordPad мы ознакомимся с простейшими приемами форматирования документов.

Настройка параметров печатной страницы. Параметры страницы задают в диалоговом окне Макет страницы (Файл —> Макет страницы).

Настройку параметров печатной страницы следует выполнять в соответствии с тем типом принтера, который предполагается использовать для печати. Для выбора принтера служит кнопка Принтер в диалоговом окне Макет страницы.

Размер листа бумаги выбирают в раскрывающемся списке Размер. При выборе размеров полей следует учитывать тип подготавливаемого документа и требования заказчика.

Настройка параметров абзаца. Абзац является минимальным элементом форматирования. Настройка параметров абзаца выполняется в диалоговом окне Абзац, открываемом командой Формат —> Абзац. Здесь можно задать следующие параметры:

  • величину отступа от левого поля;
  • величину отступа от правого поля;
  • величину специального отступа для первой строки абзаца (используется для создания «красной строки»);
  • метод выравнивания: по левому полю, по центру и по правому полю.

Настройка параметров шрифтового набора. Тип используемого шрифта, его размер и начертание можно задать как с помощью строки меню (команда Формат), так и с помощью элементов управления, представленных на панели форматирования.

Создание маркированных списков. Создание маркированных списков — характерная возможность большинства текстовых процессоров. В программе WordPad первая строка маркированного списка создается командой Формат —> Маркер или щелчком на кнопке Маркеры на панели форматирования.

Последующие строки автоматически получают маркер после нажатия клавиши ENTER. Для прекращения маркировки надо повторить команду еще раз.

Управление табуляцией. Режим табуляции определяет характер линейного смещения текстового курсора в строке при последовательных нажатиях клавиши TAB. Табуляцией пользуются в тех случаях, когда есть необходимость оформления текста ровными столбцами, что в большинстве случаев необходимо при создании таблиц.

Позиции табуляции задают в диалоговом окне Табуляция (Формат —> Табуляция).

Поиск и замена текстовых фрагментов. Наличие средства поиска и замены текстового фрагмента — обязательный элемент текстовых процессоров. В программе WordPad средство поиска запускают командой Правка —> Найти.

Поиск с одновременной заменой запускают командой Правка —> Заменить.


3.15. Служебные приложения Windows 98/2000

Служебные приложения Windows 98/2000 предназначены для обслуживания персонального компьютера и самой операционной системы. Они позволяют находить и устранять дефекты файловой системы, оптимизировать настройки программного и аппаратного обеспечения, а также автоматизировать некоторые рутинные операции, связанные с обслуживанием компьютера.

В Главном меню служебные приложения Windows сосредоточены в категории Пуск —> Программы —> Стандартные —> Служебные. Они поставляются в составе операционной системы и устанавливаются вместе с ней (полностью или выборочно). Ниже приведена краткая характеристика основных служебных приложений.

Архивация данных (Microsoft BackUp)

Программа Архивация данных (рис. 3.37) предназначена для автоматизации регулярного резервного копирования наиболее ценных данных на внешние носители.

При резервном копировании создаются архивные копии, размещенные на внешних носителях (магнитные ленты, магнитные и магнитооптические диски, лазерные диски и т. п.). Приложение ориентировано на работу с внешними накопителями большой емкости, но при их отсутствии позволяет создавать резервные копии данных на гибких дисках, хотя такой подход не приветствуется из-за низкой надежности носителя.

Программа Архивация данных позволяет:

  • создавать Задания на архивацию; при этом указываются папки, содержимое которых подлежит резервному копированию;
  • выполнять полную или частичную архивацию (в последнем случае копируются не все данные, а только та их часть, которая изменилась со времени предыдущей архивации);
  • в случае утраты данных выполнять их восстановление из резервной копии.
  • При организации резервного копирования следует иметь в виду следующие принципы:
  • архивации подлежат только данные, но не программы (в случае выхода программ из строя их следует заново переустановить с дистрибутивного носителя);
  • резервное копирование выполняется тем чаще, чем чаще обновляются данные и чем выше их ценность (если потеря результатов одного рабочего дня является критичной, следует выполнять резервное копирование раз в сутки);
  • резервные копии данных хранят отдельно от компьютера, желательно в другом помещении;
  • при использовании ненадежных носителей (гибких дисков и магнитных лент) следует создавать не менее двух резервных копий;
  • при создании нескольких резервных копий сохранение информации на них производится поочередно: например, одну неделю сохраняют данные на один комплект носителей, а другую неделю — на другой (смена комплекта резервных носителей называется ротацией).

Рис. 3.37. Рабочее окно программы Архивация данных

Буфер обмена

Приложение Буфер обмена предназначено для просмотра текущего содержания буфера обмена Windows.

С его помощью можно выполнить сохранение содержимого буфера обмена в виде файла специального формата (.CLP) или его загрузку. Соответствующие команды — Файл —> Сохранить как и Файл —> Открыть.

Дефрагментация диска

Дефрагментация диска — служебное приложение (рис. 3.38), предназначенное для повышения эффективности работы жесткого диска путем устранения фрагментированности файловой структуры.

Наименьшей единицей хранения данных на диске является кластер. Если свободного места на диске достаточно, то файлы записываются так, что кластеры, в которые происходит запись, располагаются последовательно. В этом случае обращения к файлу происходят достаточно быстро, поскольку затраты времени на поиск очередных кластеров минимальны.

Если диск заполнен до отказа, запись на него возможна только после освобождения некоторого количества кластеров путем удаления файлов. При этом свободные области, образующиеся на диске, в общем случае не образуют одну большую непрерывную область.

При попытке записать длинный файл на диск, имеющий прерывистую структуру свободных областей, файл делится на фрагменты, которые записываются туда, где для них нашлось место. Длительная работа с заполненным жестким диском приводит к постепенному увеличению фрагментированности файлов и значительному замедлению работы.

Программа Дефрагментация диска выполняет перекомпоновку файлов таким образом, что длинные файлы собираются из коротких фрагментов. В результате доступ к файлам заметно упрощается и эффективность работы компьютера возрастает.

Рис. 3.38. Программа дефрагментации дисков

Особенностью Windows 98/2000 является возможность сопроводить процесс дефрагментации оптимизацией размещения файлов. При загрузке операционной системы и запуске основных приложений порядок загрузки файлов обладает определенной стабильностью. В ходе оптимизации файловой структуры система принудительно располагает файлы на диске в том порядке, в каком обычно происходит их открытие.

При оптимизации также учитывается тот факт, что с некоторыми областями жесткого диска обмен происходит быстрее, чем с другими. В них размещаются файлы, которые используются наиболее часто. Оптимизацию подключают установкой флажка Переместить файлы программ для ускорения их запуска в диалоговом окне Настройка дефрагментации, открываемом с помощью командной кнопки Настройка.

Индикатор системных ресурсов

После запуска этого приложения на панели индикации устанавливается небольшой значок, посредством которого можно получить сведения о состоянии системных ресурсов. Ресурсами в данном случае называются специальные модули памяти, предназначенные для обслуживания многозадачного режима работы.

Всякой запущенной программе (или процессу, например открытому окну) выдается небольшая порция этих модулей. По завершении своей работы приложение должно освободить ресурсы, но некорректно работающие (или устаревшие) программы могут «забывать» или «не уметь» это делать. В этом случае возникает явление «утечки» ресурсов, и программы могут «зависать».

Характерным проявлением явления «утечки ресурсов» служат сообщения от операционной системы о недостатке оперативной памяти, в то время как на самом деле ее вполне достаточно.

Для контроля за подобными нештатными ситуациями используют Индикатор системных ресурсов.

Явление «утечки ресурсов» наиболее часто проявляется при запуске приложений Windows 3.1 под управлением Windows 95. Операционная система Windows 98/2000 обеспечивает более корректное распределение системных ресурсов, и необходимость в использовании приложения Индикатор системных ресурсов возникает редко.

Преобразование в FAT32

Программа Преобразование в FAT32 — это мастер-программа, которая позволяет автоматически преобразовать формат файловой системы из FAT 16 в FAT 32, если жесткий диск имеет размер более 512 Мбайт. Эту операцию можно производить на жестких дисках, уже заполненных информацией. Как правило, при этом высвобождается дополнительно 100-200 Мбайт рабочего пространства на каждый Гбайт емкости жесткого диска.

Программа запускается командой Пуск —> Программы —> Стандартные —> Служебные —> Преобразование в FAT32. Обратное преобразование в рамках той же программы невозможно. Следует также иметь в виду, что если тот же жесткий диск используется для работы других операционных систем, то его не следует преобразовывать в новый формат.

Проверка диска

Это исключительно важная программа, которую следует использовать достаточно регулярно. Она позволяет выявлять логические ошибки в файловой структуре (Стандартная проверка), а также физические ошибки, связанные с дефектами поверхности жесткого диска (Полная проверка).

Стандартную проверку рекомендуется проводить после каждого сбоя в работе компьютера, особенно после некорректного завершения работы с операционной системой.

Полную проверку достаточно проводить два раза в год или в случае сомнений в качестве жесткого диска.

Сведения о системе

Сведения о системе — это специальный пакет программных средств, собирающих сведения о настройке операционной системы Windows 98, ее приложений и оборудования компьютерной системы. Средства этого пакета предназначены для специалистов, выполняющих ремонтно-восстановительные работы. Его дополнительное преимущество состоит в том, что он позволяет провести диагностику компьютера с удаленного сервера.

Сжатие данных

Программа Сжатие данных предназначена для повышения плотности записи данных на жесткий диск. В ее основе лежит принцип устранения избыточности информации. Избыточностью обладают почти все файлы данных, ранее не уплотненные иными средствами.

Агент сжатия

Программа Агент сжатия предназначена для дополнительного уплотнения файла сжатого тома. Она работает весьма медленно, но ее работу можно автоматизировать с помощью программы Назначенные задания. Все настройки этой программы можно задать заранее и выполнять по расписанию.

Системный Монитор

Системный Монитор — программа, предназначенная для визуального или протокольного наблюдения за функционированием компьютера и операционной системы. Она позволяет контролировать загрузку процессора, распределение оперативной памяти, обмен данными между дисками и другие параметры вычислительной системы.

Результаты наблюдения можно отображать на экране в виде графиков или записывать в протокольный файл. Исследование компьютера с помощью программы Системный Монитор позволяет находить «узкие места» в производительности компьютерной системы, сравнивать между собой варианты настройки аппаратных и программных средств.

Таблица символов

Кроме шрифтов с алфавитно-цифровыми символами в операционной системе Windows 98 можно использовать и специальные символьные наборы с дополнительными элементами оформления текстовых документов. В любом текстовом процессоре этими символьными наборами можно пользоваться так же, как обычными шрифтами. Однако если для обычных шрифтов раскладка клавиш понятна, то для символьных наборов нужны специальные средства, чтобы установить закрепление символов за клавишами клавиатуры.

Программа Таблица символов позволяет увидеть на экране все символы заданного набора и установить, какой символ, какой клавише соответствует.

|Утилита форматирования дискет

Система Windows не может записывать, а также считывать данные с большинства вновь приобретенных дискет и других носителей информации. Чтобы Windows могла работать с дискетой, последняя должна быть предварительно отформатирована. При форматировании Windows записывает на дискету базовую информацию, которая необходима операционной системе для управления записанными впоследствии данными.

Чтобы отформатировать дискету, необходимо выполнить следующие действия:

1. Выполнить двойной щелчок на пиктограмме Мой компьютер.

2. Вставить дискету в дисковод.

3. Отметить значок дисковода гибких дисков и выбрать команду Форматировать меню Файл. Или же, выполнив щелчок правой кнопкой мыши на соответствующем значке, выбрать в контекстном меню команду Форматировать.

4. Указать посредством выбора соответствующего элемента в поле списка Емкость, на какой объем памяти необходимо отформатировать дискету.

5. Если дискета уже была отформатирована, рекомендуется установить в области Способ форматирования опцию Быстрое, чтобы осуществить быстрое форматирование дискеты. В этом случае все данные с дискеты будут просто удалены.

6. В поле Метка ввести, если это необходимо, метку длиной до 11 символов.

7. Проверить, находится ли в дисководе нужная дискета, и выполнить щелчок на кнопке Начать, а затем в появившемся окне — на кнопке ОК.


3.16. Стандартные средства мультимедиа

Мультимедиа — понятие комплексное. С одной стороны, оно подразумевает особый тип документов, а, с другой стороны, — особый класс программного и аппаратного обеспечения.

Мультимедийные документы отличаются от обычных тем, что кроме традиционных текстовых и графических данных могут содержать звуковые и музыкальные объекты, анимированную графику (мультипликацию), видеофрагменты.

Мультимедийное программное обеспечение — это программные средства, предназначенные для создания и/или воспроизведения мультимедийных документов и объектов.

Мультимедийное аппаратное обеспечение — это оборудование, необходимое для создания, хранения и воспроизведения мультимедийного программного обеспечения. К нему относятся звуковая карта, дисковод CD-ROM, звуковые колонки.

В последние годы в класс аппаратных средств мультимедиа вошли устройства для обработки телевизионных сигналов и воспроизводства телепрограмм (ТВ-тюнеры), аппаратные средства для обработки сжатой видео информации (MPEG-декодеры), дисководы для воспроизведения цифровых видеодисков (DVD), оборудование для записи компакт-дисков (CD-R и CD-RW) и многое другое.

При наличии мультимедийного аппаратного обеспечения операционная система Windows 98/2000 позволяет создавать, хранить и использовать мультимедийные объекты и документы. Программные средства, предназначенные для этой цели, находятся в категории Программы —> Стандартные —> Развлечения. К основным стандартным средствам мультимедиа относятся программы: Регулятор громкости, Лазерный проигрыватель, Универсальный проигрыватель и Звукозапись.

Регулятор громкости

Программа Регулятор громкости является базовым регулятором громкости всей компьютерной системы. Это значит, что она играет центральную роль, и все регулировки громкости программ или аппаратных средств действуют только в пределах, первично заданных Регулятором громкости.

После установки Регулятора громкости на панели индикации создается значок. Щелчок левой кнопки мыши на этом значке открывает мастер-регулятор, оказывающий влияние на все звуковые устройства, установленные в компьютере. Щелчком правой кнопки мыши можно открыть расширенное окно, в котором можно задать громкость, стереобаланс и установки тембра для каждого из устройств отдельно.

Лазерный проигрыватель

Программа Лазерный проигрыватель (рис. 3.39) предназначена для воспроизведения музыкальных аудиодисков с помощью дисковода CD-ROM.

Программа позволяет управлять режимом воспроизведения (непрерывное воспроизведение, произвольное воспроизведение, ознакомительное воспроизведение) звуковых, дорожек, имеет экранные элементы управления, соответствующие органам управления CD-проигрывателей, и позволяет создавать и редактировать списки воспроизведения.

Рис. 3.39. Программа Лазерный проигрыватель

Универсальный проигрыватель

Программу Универсальный проигрыватель тоже можно использовать для воспроизведения аудиодисков, хотя она и не имеет столь широкого набора функций, как Лазерный проигрыватель (в частности, в ней нет средств для работы со списками воспроизведения).

С другой стороны, она отличается высокой универсальностью и позволяет воспроизводить не только звукозаписи, но и видеозаписи, представленные в многочисленных форматах. В тех случаях, когда в электронно-текстовых документах встречаются мультимедийные объекты, они воспроизводятся именно этим стандартным средством Windows 98.

Программа Звукозапись

Программа Звукозапись предназначена для самостоятельного создания файлов звукозаписи. В качестве источника звука может использоваться микрофон, дисковод CD-ROM или внешнее устройство.

Программа имеет графические элементы управления, эквивалентные органам управления обычного бытового магнитофона. Создаваемые звуковые файлы могут проходить ограниченное редактирование с наложением некоторых эффектов (изменение скорости звукозаписи, громкости, эффект «Эхо», обращение звукозаписи). Программа позволяет создавать аудиоклипы небольших размеров, которые можно использовать в звуковых схемах оформления системных событий.


3.17. Средства обеспечения совместимости с приложениями MS

3.17. Средства обеспечения совместимости с приложениями MS-DOS

Операционная система MS-DOS принадлежит к категории однозадачных неграфических операционных систем. Ее приложения полностью захватывают все ресурсы операционной системы, и потому создавать документы в MS-DOS' не столь удобно как в Windows 98. Чтобы одновременно и удовлетворить специфическим требованиям, и, по возможности, сохранить преимущества многозадачной среды, Windows 98 имеет два разных средства: стандартное приложение Сеанс MS-DOS и особый режим работы операционной системы — Режим MS-DOS.

Сеанс MS-DOS

Сеанс MS-DOS (Пуск —> Программы —> Сеанс —> MS-DOS) — это специальное служебное приложение Windows 98, создающее на экране рабочее окно, в котором можно запускать неграфические приложения MS-DOS.

Эта программа удобна тем, что позволяет работать с приложениями MS-DOS, сохранив при этом основные достоинства Windows, такие, как многозадачность, возможность использования буфера обмена для копирования данных, возможность управления с помощью мыши и прочие.

В некоторых случаях приложения MS-DOS не могут запускаться в окне Сеанса MS-DOS, но могут запускаться в полноэкранном режиме. Это относится к простейшим приложениям, имеющим экранную графику. Для переключения в полноэкранный режим окно Сеанс MS-DOS имеет специальную кнопку на панели инструментов. Можно также воспользоваться комбинацией клавиш ALT+ENTER. Для возврата из полноэкранного режима в оконный можно пользоваться только этой комбинацией — других средств нет.

Режим MS-DOS

Это альтернативное средство для работы с приложениями MS-DOS. Если Сеанс MS-DOS — это специальное приложение Windows, то Режим MS-DOS — это особый режим работы операционной системы, при котором происходит эмуляция операционной системы MS-DOS средствами Windows 98.

Преимущества Режима MS-DOS связаны с тем, что он позволяет запускать приложения MS-DOS, которые принципиально не способны разделять ресурсы операционной системы с другими программами, и потому не могут работать под управлением Сеанса MS-DOS.

Основным недостатком Режима MS-DOS является то, что в нем теряются все преимущества Windows, такие, как: многозадачность, графический интерфейс, концепция OLE и прочие.

Запуск программ в Режиме MS-DOS осуществляется либо после соответствующего перезапуска компьютера (Пуск —> Завершение работы —> Перезагрузить компьютер в режиме MS-DOS), либо с использованием значка приложений MS-DOS после специальной перенастройки его свойств. В первом случае навигацию по жесткому диску поиск и запуск приложения приходится выполнять командами MS-DOS, вызываемыми в поле командной строки, а во втором случае приложение запускается автоматически.

Настройка свойств значка приложения MS-DOS

Настройку способа запуска приложения MS-DOS выполняют с помощью его значка. Поскольку при установке приложений MS-DOS соответствующий значок (и пункт в Главном меню) создается далеко не всегда, его создают вручную.

Настройку начинают с выбора пункта Свойства в контекстном меню значка; при этом открывается диалоговое окно Свойства: Имя программы. Выбор между запуском в окне Сеанса MS-DOS или в Режиме MS-DOS выполняют в диалоговом окне Дополнительные настройки программы, открываемом щелчком на командной кнопке Дополнительно (вкладка Программа). Если флажок Режим MS-DOS сброшен, программа будет запускаться в Сеансе MS-DOS, в противном случае — в Режиме MS-DOS.

Если приложение не запускается в окне Сеанс MS-DOS, следует попробовать запустить его в полноэкранном режиме, включив переключатель Полноэкранный на вкладке Экран.

Если в полноэкранном режиме приложение запускается, но вскоре «зависает», следует установить флажок Не давать программе обнаружить Windows в диалоговом окне Дополнительные настройки программы.

Если приложение имеет тенденцию «зависать» после ряда переключении между окнами Windows, надо поэкспериментировать с настройкой элементов управления на вкладке Разное, в частности, в группах Выполнение, Использование мыши, Фоновый режим и Приоритет при ожидании.

Для ряда приложений MS-DOS, неустойчиво работающих в Сеансе MS-DOS, целесообразно отключать механизмы энергосбережения и запуска экранной заставки на вкладке Заставка диалогового окна Свойства: Экран (Пуск —> Настройка —> Панель управления —> Экран —> Заставка).

При окончательной невозможности запустить приложение в Сеансе MS-DOS практикуют запуск в Режиме MS-DOS. В этом случае успех запуска и работы во многом зависит от правильности настройки конфигурации оборудования (в первую очередь мыши, звуковой карты, дисковода CD-ROM). Оперативная память, находящаяся выше первого мегабайта, в операционной системе MS-DOS рассматривается как «внешнее» оборудование.

Если приложение требует к ней доступа, должен быть установлен соответствующий драйвер (менеджер оперативной памяти). Все подключения и настройки драйверов оборудования в операционной системе MS-DOS выполняются либо прямыми командами, подаваемыми из командной строки, либо путем редактирования файлов конфигурации Autoexec.bat и Config.sys. Диалоговое окно Дополнительные настройки программы предоставляет необходимые для этого средства, если включен переключатель Выбрать новую конфигурацию MS-DOS.

При использовании Режима MS-DOS для запуска приложений следует помнить, что с переходом в этот режим теряется возможность возврата в открытые приложения Windows, поэтому их следует предварительно закрыть, а документы из них сохранить. Для обеспечения безопасной работы рекомендуется устанавливать флажок Выдавать предупреждение при входе в Режим MS-DOS в диалоговом окне Дополнительные настройки программы.


3.20. Глоссарий

Windows – графическая операционная система для компьютеров платформы IBM.

Буфер обмена – область памяти для временного хранения объектов при выполнении операций копирования или перемещения.

Вкладка – элемент управления диалогового окна или окна приложения, представляющий отдельную страницу. Содержит другие элементы управления.

Главное ( стартовое) меню – один из основных системных элементов управления Рабочего стола операционных систем Windows, предназначенный для быстрого доступа к приложениям и служебным функциям операционной системы. Вызывается щелчком на кнопке Пуск.

Диалоговое окно – специальное окно, используемое для настройки параметров операционной системы или приложения. Отличается от окна приложения отсутствием строки меню. Содержит набор элементов управления, которые могут быть размещены на нескольких вкладках.

Значки – графическое представление объектов.

Контекстное меню – меню, содержащее команды, применимые к выбранному объекту. Вызывается щелчком правой кнопкой мыши на любом объекте Windows.

Корзина – специальный объект Windows, служащий для временного хранения удаляемых файлов.

Мастер – программный модуль для выполнения каких-либо операций.

Многозадачность – свойство операционной системы, заключающееся в возможности одновременного выполнения нескольких программ.

Мультимедиа – сочетание нескольких видов данных в одном документе (текстовые, графические, музыкальные и видеоданные) или совокупность устройств для воспроизведения этого комплекса данных.

Окно – это сложный графический объект, осуществляющий взаимодействие программы с пользователем и другими программами.

Панель задач – один из основных элементов управления.

Проводник – служебная программ, относящаяся к категории диспетчеров файлов.

Рабочий стол – графическая среда, на которой отображаются объекты и элементы управления Windows.

Файловая структура – иерархическая структура, в виде которой операционная система отображает файлы и папки диска.

Ярлык – указатель на объект.

Ярлык – указатель на объект.


3.21. Библиографический список

1. Информатика. Базовый курс / Симонович С.В. и др. - СПб.: Питер, 1999. - 640 с.

2. Пасько В., Колесников А. Самоучитель работы на персональном компьютере: - 2-е изд., доп. - К.: Издательская группа BHV, 1999. - 656 c.

3. Рассел Ч. Microsoft Windows Server 2000. Справочник администратора. - М.:ЭКОМ, 2001 - 1296 с.

4. Коварт Р., Книттель Б. Использование Microsoft Windows 2000 Professional. Специальное издание. - К.:Вильямс, 2001 - 912 с.

5. Русская компьютерная библиотека URL: http://rusdoc.df.ru


Упражнение 1. Отработка приемов управления с помощью мыши

1. Зависание. Слева на Панели задач имеется кнопка Пуск. Это элемент управления Windows, называемый командной кнопкой. Наведите на нее указатель мыши и задержите на некоторое время — появится всплывающая подсказка: Начните работу с нажатия этой кнопки.

Справа на Панели задач расположена панель индикации. На этой панели, в частности, расположен индикатор системных часов. Наведите на него указатель мыши и задержите на некоторое время — появится всплывающая подсказка с показаниями системного календаря.

2. Щелчок. Наведите указатель мыши на кнопку Пуск и щелкните левой кнопкой — над ней откроется Главное меню Windows. Меню — это один из элементов управления, представляющий собой список возможных команд. Команды, представленные в меню, выполняются щелчком на соответствующем пункте. Все команды, связанные с элементами управления, выполняются одним обычным щелчком.

Однако у щелчка есть и другое назначение. Его применяют также для выделения объектов. Разыщите на Рабочем столе значок Мой компьютер и щелкните на нем. Значок и подпись под ним изменят цвет. Это произошло выделение объекта. Объекты выделяют, чтобы подготовить их к дальнейшим операциям.

Щелкните на другом объекте, например на значке Корзина. Выделение значка Мой компьютер снимется, а вместо него выделится значок Корзина. Если нужно снять выделение со всех объектов, для этого достаточно щелкнуть на свободном от объектов месте Рабочего стола.

3. Двойной щелчок. Двойной щелчок применяют для использования объектов. Например, двойной щелчок на значке, связанном с приложением, приводит к запуску этого приложения, а двойной щелчок на значке документа приводит к открытию данного документа в том приложении, в котором он был создан. При этом происходит одновременно и запуск этого приложения. Относительно документа оно считается родительским.

В системе Windows с одним и тем же объектом можно выполнить много разных действий. Например, файл с музыкальной записью можно воспроизвести (причем в разных приложениях), его можно отредактировать, можно скопировать на другой носитель или удалить. Сколько бы действий ни было возможно с объектом, всегда существует одно основное действие. Оно и выполняется двойным щелчком.

Выполните двойной щелчок на значке Мой компьютер, и на экране откроется одноименное окно Мой компьютер, в котором можно увидеть значки дисков и других устройств, подключенных к компьютеру, например принтеров.

Если нужно закрыть окно, надо щелкнуть один раз на закрывающей кнопке, которая находится в правом верхнем углу окна. Закрывающая кнопка — это элемент управления, и для работы с ним достаточно одного щелчка.

4. Щелчок правой кнопкой. Щелкните правой кнопкой на значке Мой компьютер, и рядом с ним откроется элемент управления, который называется контекстным меню. У каждого объекта Windows свое контекстное меню. Состав его пунктов зависит от свойств объекта, на котором произошел щелчок. Для примера сравните содержание контекстного меню объектов Мой компьютер и Корзина, обращая внимание на их различия.

Доступ к контекстному меню — основное назначение щелчка правой кнопкой. В работе с объектами Windows (особенно с незнакомыми) щелчок правой кнопкой используется очень часто.

Более того, во всех контекстных меню любых объектов имеется пункт Свойства. Он позволяет просматривать и изменять свойства объектов, то есть выполнять настройки программ, устройств и самой операционной системы.

5. Перетаскивание. Перетаскивание — очень мощный прием для работы с объектами операционной системы. Наведите указатель мыши на значок Мой компьютер. Нажмите левую кнопку и, не отпуская ее, переместите указатель — значок Мой компьютер переместится по поверхности Рабочего стола вместе с ним.

Откройте окно Мой компьютер. Окно можно перетаскивать с одного места на другое, если “подцепить” его указателем мыши за строку заголовка. Так прием перетаскивания используют для оформления рабочей среды.

6. Протягивание. Откройте окно Мой компьютер. Наведите указатель мыши на одну из рамок окна и дождитесь, когда он изменит форму, превратившись в двунаправленную стрелку. После этого нажмите левую кнопку и переместите мышь. Окно изменит размер. Если навести указатель мыши на правый нижний угол окна и выполнить протягивание, то произойдет изменение размера сразу по двум координатам (по вертикали и горизонтали).

Изменение формы объектов Windows — полезное, но не единственное использование протягивания. Нередко этот прием используют для группового выделения объектов. Наведите указатель мыши на поверхность Рабочего стола, нажмите кнопку мыши и протяните мышь вправо-вниз — за указателем потянется прямоугольный контур выделения. Все объекты, которые окажутся внутри этого контура, будут выделены одновременно.

7. Специальное перетаскивание. Наведите указатель мыши на значок Мой компьютер, нажмите правую кнопку мыши и, не отпуская ее, переместите мышь. Этот прием отличается от обычного перетаскивания только используемой кнопкой, но дает иной результат. При отпускании кнопки не происходит перемещение объекта, а вместо этого открывается так называемое меню специального перетаскивания. Содержимое этого меню зависит от перемещаемого объекта. Для большинства объектов в нем четыре пункта (Копировать, Переместить, Создать ярлык и Отменить). Для таких уникальных объектов, как Мой компьютер или Корзина, в этом меню только два пункта: Создать ярлык и Отменить.


Упражнение 2. Изучение приемов работы с объектами

1.Откройте папку Мои документы .

2. Щелчком на раскрывающей кнопке разверните окно на полный экран.

3. В строке меню дайте команду Файл —> Создать —> Папку. Убедитесь в том, что в рабочей области окна появился значок папки с присоединенной надписью Новая папка.

4. Щелкните правой кнопкой мыши на свободной от значков рабочей области окна текущей папки. В открывшемся контекстном меню выберите команду Создать —> Папку. Убедитесь в том, что в пределах окна появился значок папки с надписью Новая папка (2).

5. Щелкните правой кнопкой мыши на значке Новая папка. В открывшемся контекстном меню выберите пункт Переименовать. Дайте папке содержательное имя, например Экспериментальная. Аналогично переименуйте папку Новая папка (2). Убедитесь в том, что операционная система не допускает существования в одной папке двух объектов с одинаковыми именами. Дайте второй папке имя Мои эксперименты.

6. Восстановите окно папки Мои документы до нормального размера щелчком на восстанавливающей кнопке.

7. Откройте окно Мой компьютер. В нем откройте окно с содержимым жесткого диска (С:). Пользуясь полосами прокрутки разыщите в нем папку Windows и откройте ее двойным щелчком. В открывшемся содержимом разыщите значок папки Temp и откройте ее (эта папка считается папкой временного хранения данных, и экспериментировать с ее содержимым можно без опасений). Перетаскиванием переместите папку Экспериментальная из папки Мои документы в папку С:\Windows\Temp. Специальным перетаскиванием переместите папку Мои эксперименты в папку С:\ Windows\Temp и по окончании перетаскивания выберите пункт Переместить в открывшемся контекстном меню.

8.Откройте окно С:\Windows\Temp. Щелчком выделите значок папки Экспериментальная. При нажатой клавише Ctrl щелчком выделите значок папки Мои эксперименты. Убедитесь в том, что в рабочей области одновременно выделено два объекта (групповое выделение).

9.Заберите выделенные объекты в буфер обмена комбинацией клавиш Ctrl + X. Убедитесь в том, что их значки исчезли в рабочей области папки.

10. Откройте окно папки Мои документы. Вставьте в него объекты, находящиеся в буфере обмена (Ctrl + V).

11. Выделите значки папок Экспериментальная и Мои эксперименты в папке Мои документы. Щелкните правой кнопкой мыши и в открывшемся контекстном меню выберите пункт Удалить. В открывшемся диалоговом окне подтвердите необходимость удаления объектов. Закройте окно папки Мои документы.

12. Двойным щелчком на значке откройте окно Корзина. Убедитесь, что в нем находятся значки удаленных папок Экспериментальная и Мои эксперименты. Выделите оба значка. Щелкните правой кнопкой мыши и в открывшемся контекстном меню выберите пункт Восстановить. Закройте Корзину.

13. Откройте окно папки Мои документы. Убедитесь в том, что в нем восстановились значки папок Экспериментальная и Мои эксперименты. Выделите оба значка. Удалите их с помощью клавиши Delete при нажатой клавише Shift. В открывшемся диалоговом окне подтвердите необходимость удаления объектов. Закройте окно папки Мои документы.

14. Откройте окно Корзины. Убедитесь в том, что объекты, удаленные при нажатой клавише Shift, не поступили в Корзину. Закройте Корзину.


Упражнение 3. Работа в файловой структуре в программе Проводник

1. Включите персональный компьютер, дождитесь окончания загрузки операционной системы.

2. Запустите программу Проводник с помощью Главного меню (Пуск —> Программы —> Проводник). Обратите внимание на то, какая папка открыта на левой панели Проводника в момент запуска. Это должна быть корневая папка системного диска (папка С:).

3. Разыщите на левой панели папку Мои документы и откройте ее щелчком на значке папки.

4. На правой панели Проводника создайте новую папку Экспериментальная.

5. На левой панели разверните папку Мои документы одним щелчком на значке узла “+”. Обратите внимание на то, что раскрытие и разворачивание папок на левой панели — это разные операции. Убедитесь в том, что на левой панели в папке Мои документы образовалась вложенная папка Экспериментальная.

6. Откройте папку Экспериментальная на левой панели Проводника. На правой панели не должно отображаться никакое содержимое, поскольку эта папка пуста.

7. Создайте на правой панели Проводника новую папку Мои эксперименты внутри папки Экспериментальная. На левой панели убедитесь в том, что рядом со значком папки Экспериментальная образовался узел “+”, свидетельствующий о том, что папка имеет вложенные папки. Разверните узел и рассмотрите образовавшуюся структуру на левой панели Проводника.

8. На левой панели Проводника разыщите папку Windows и разверните ее.

9. На левой панели Проводника внутри папки Windows разыщите папку для временного хранения объектов — Temp, но не раскрывайте ее.

10. Методом перетаскивания переместите папку Экспериментальная с правой панели Проводника на левую — в папку С:\Windows\Temp. Эту операцию надо выполнять аккуратно. Чтобы “попадание” было точным, следите за цветом надписи папки-приемника. При точном наведении надпись меняет цвет — в этот момент можно отпускать кнопку мыши при перетаскивании. Еще труднее правильно “попасть в приемник” при перетаскивании групп выделенных объектов. Метод контроля тот же — по выделению надписи.

11. На левой панели Проводника откройте папку С:\Windows\Temp. На правой панели убедитесь в наличии в ней папки Экспериментальная.

12. Разыщите на левой панели Корзину и перетащите папку Экспериментальная на ее значок. Раскройте Корзину и проверьте наличие в ней только что удаленной папки. Закройте окно программы Проводник.


Упражнение 4. Исследование методов запуска программы Проводник

В операционной системе Windows большинство операций можно выполнить многими разными способами. На примере программы Проводник мы исследуем различные приемы запуска программ.

1. Щелкните правой кнопкой мыши на кнопке Пуск и в открывшемся контекстном меню используйте пункт Проводник. Обратите внимание на то, какая папка открыта на левой панели в момент запуска.

2. Щелкните правой кнопкой мыши на значке Мой Компьютер и в открывшемся контекстном меню используйте пункт Проводник. Обратите внимание на то, какая папка открыта на левой панели в момент запуска.

3. Проверьте контекстные меню всех значков, открытых на Рабочем столе. Установите, для каких объектов контекстное меню имеет средства запуска Проводника, и выясните, какая папка открывается на левой панели в момент запуска.

4. Выполните запуск Проводника через пункт Программы Главного меню.

5. Выполните запуск Проводника через пункт Выполнить Главного меню.

6. Выполните запуск Проводника через ярлык папки Мои документы (Пуск —> Избранное —> Мои документы —> щелчок правой кнопкой мыши —> выбор пункта Проводник).

7. Выполните запуск Проводника с Рабочего стола (предварительно на Рабочем столе следует создать ярлык Проводника).

9. Заполните у себя в тетради отчетную таблицу по образцу:

Метод запуска Проводника | Используемый элемент управления | Папка открытия
Через контекстное меню кнопки Пуск | Кнопка Пуск | С:\Windows\Главное меню
И т.д. |  |


Упражнение 5. Основы работы в текстовом редакторе Блокнот

1. Запустите текстовый редактор Блокнот (Пуск —> Программы —> Стандартные —> Блокнот).

2. Убедитесь, что включена русская раскладка клавиатуры. В противном случае щелкните на указателе языка на панели индикации и выберите в открывшемся меню пункт Русский.

3. Введите с клавиатуры слово Конденсатор (при вводе заглавной буквы удерживайте нажатой клавишу Shift) и нажмите клавишу Enter.

4. Далее введите с клавиатуры термины Резистор, Катушка индуктивности, Выключатель, Амперметр и Вольтметр, нажимая после ввода каждого термина клавишу Enter.

5. Расставьте в документе термины по алфавиту, выделяя строки и перемещая их через буфер обмена. Дважды щелкните на слове Амперметр и убедитесь, что оно при этом выделяется (этот способ служит для выделения отдельных слов). Нажмите комбинацию клавиш Shift + стрелка ВПРАВО, чтобы включить в выделенный фрагмент невидимый символ конца строки — курсор при этом переместится в начало следующей строки.

6. Дайте команду Правка —> Вырезать, чтобы забрать выделенный фрагмент в буфер обмена. Убедитесь, что он действительно удаляется из документа.

7. Нажмите комбинацию клавиш Ctrl + Home, чтобы установить курсор в начало документа. Дайте команду Правка —> Вставить, чтобы вставить фрагмент из буфера обмена.

8. Установите указатель мыши на начало слова Вольтметр. Нажмите левую кнопку мыши и, не отпуская ее, выделите это слово методом протягивания.

9. Нажмите комбинацию клавиш Ctrl + Х, переместите текстовый курсор в начало второй строки текста и вставьте новый фрагмент из буфера обмена (Ctrl+V).

10. Установите текстовый курсор в начало строки, содержащей слова Катушка индуктивности. Дважды нажмите комбинацию Shift + Ctrl + ВПРАВО и убедитесь, что при каждом нажатии выделенный фрагмент расширяется, охватывая следующее слово. Нажмите комбинацию клавиш Shift + стрелка ВПРАВО. Мы выделили нужный фрагмент при помощи клавиатурных команд.

11. Нажмите комбинацию клавиш Shift + Delete, переместите текстовый курсор в начало третьей строки текста и вставьте новый фрагмент из буфера обмена с помощью комбинации клавиш Shift + Insert.

12. Используя описанные приемы, завершите формирование списка введенных терминов в алфавитном порядке.

13. Сохраните созданный документ под именем zadanie.txt.

14. Набрать выданный текст. Сохранить набранный текст под именем zadanie1.txt.


Упражнение 6. Приемы работы с графическим редактором Paint

В этом упражнении мы создадим условное обозначение вольтметра, принятое на электрических схемах.

1. Запустите графический редактор Paint (Пуск —> Программы —> Стандартные —> Paint).

2. Убедитесь, что на палитре задан черный цвет в качестве основного и белый — в качестве фонового.

3. Дайте команду Рисунок —> Атрибуты, в диалоговом окне Атрибуты задайте ширину рисунка, равную 300 точек и высоту — 200 точек. Щелкните на кнопке ОК.

4. Выберите инструмент Эллипс и в палитре настройке инструмента укажите вариант Без заполнения.

5. Нажмите и удерживайте клавишу Shift. Методом протягивания нарисуйте окружность в центральной части области рисунка. Диаметр окружности должен составлять около половины высоты рисунка. Отпустите клавишу Shift.

6. Выберите инструмент Линия. В палитре настройки инструмента выберите вариант толщины линии (второй сверху).

7. Нажмите и удерживайте клавишу Shift. Методом протягивания нарисуйте небольшой горизонтальный отрезок прямой в стороне от окружности. Отпустите клавишу Shift.

8. Выберите инструмент Выделение. В палитре настройки инструмента выберите режим с прозрачным фоном.

9. Методом протягивания выделите прямоугольный фрагмент, охватывающий нарисованный отрезок прямой, но не затрагивающий окружность. Комбинацией клавиш Ctrl + Х поместите его в буфер обмена.

10. Вставьте отрезок прямой на рисунок комбинацией клавиш Ctrl + V. Обратите внимание, что выделение при этом сохраняется.

11. Переместите выделенный фрагмент так, чтобы отрезок прямой примыкал к окружности слева. Обратите внимание на то, что фоновая часть фрагмента не перекрывает окружность.

12. Повторите операции, описанные в пп. 10-11, чтобы создать отрезок прямой, примыкающий к окружности справа.

13. Выберите инструмент Текст.

14. Методом протягивания создайте область ввода текста внутри окружности. Введите символ “V”. С помощью панели Шрифты задайте подходящий размер и начертание шрифта.

15. Методом перетаскивания за границу области ввода текста поместите букву “V” в центре окружности.

16. Щелкните вне области ввода текста, чтобы превратить текст в часть рисунка.

17. Сохраните созданное изображение под именем shema.bmp.


Упражнение 7. Приемы форматирования в текстовом процессоре WordPad

В этом упражнении мы создадим иллюстрированный словарь терминов, введенных в файл zadanie.txt в упражнении 5.

1. Запустите текстовый процессор WordPad (Пуск —> Программы —> Стандартные —> WordPad).

2. Откройте текстовый файл zadanie.txt.

3. Дайте команду Файл —> Сохранить как, в списке Тип файла выберите пункт Word для Windows 6.0 и сохраните файл под именем zadanie2.doc.

4. Выделите первое слово документа Амперметр. На панели форматирования задайте шрифт Ariel (Кириллица), размер шрифта — 14 пунктов, выберите полужирное начертание.

5. Нажмите клавишу End, чтобы снять выделение, а затем — клавишу Enter.

6. Введите краткое описание термина, указанного в предыдущей строке, например так: “прибор для измерения величины электрического тока”.

7.Выделите весь только что введенный абзац (можно использовать “тройной щелчок”). На панели форматирования задайте шрифт Times New Roman (Кириллица), размер шрифта — 12 пунктов.

8. На линейке, расположенной ниже панели форматирования, перетащите маркер в виде квадратика на расстояние 1 см (по линейке) вправо. Убедитесь, что весь абзац теперь отображается с отступом от левого края.

9. Снимите выделение и установите курсор в начало первой строки того же самого абзаца. Нажмите клавишу ТАВ. Убедитесь, что табуляция в первой строке абзаца может использоваться для создания абзацного отступа.

10. Введите аналогичные краткие описания для последующих терминов создаваемого “словаря” и отформатируйте термины и описания так, как указано в пп. 4-9.

11. Установите курсор в конец описания термина Вольтметр и нажмите клавишу Enter.

12. Дайте команду Вставка —> Объект. В диалоговом окне Вставка объекта установите переключатель Создать из файла.

13. Щелкните на кнопке Обзор, разыщите в файловой структуре ранее созданный документ shema.bmp, щелкните на кнопке Вставить. Щелкните на кнопке ОК.

14. Убедитесь, что созданное изображение схематического обозначения вольтметра вставлено в документ в качестве иллюстрации.

15. Измените масштаб отображения рисунка в документе путем перетаскивания маркеров изменения размера, расположенных на границах объекта.

16. Сохраните текущий документ zadanie2.doc.


3.19. Контрольные вопросы

  1. Сколько версий операционной системы Windows Вы знаете?
  2. Что такое окно? Какие существуют разновидности окон в Windows?
  3. Какие основные элементы окна?
  4. Что такое Рабочий стол? Их каких элементов он состоит?
  5. Какие значки появляются на Рабочем столе после инсталляции Windows?
  6. Что такое Главное меню? Как оно открывается?
  7. Что такое Панель задач? Что на ней расположено?
  8. Чем отличается значок от ярлыка?
  9. Что такое контекстно-зависимое меню?
  10. Для чего нужна программа Проводник?
  11. Какими способами можно запустить Проводник?
  12. Перечислите основные функции Проводника?
  13. Что такое буфер обмена, его назначение?
  14. Как можно скопировать, переместить, удалить файл, папку?
  15. Какие Вы знаете способы поиска файла, папки, компьютера в сети?
  16. Что такое Корзина, для чего она служит?
  17. Из каких символов может состоять имя файла в Windows?
  18. Каким способом можно отметить несколько файлов подряд, вразброс?
  19. Как создать новую папку?
  20. Как создать ярлык?
  21. Какие Вы знаете способы запуска приложений?
  22. Какие существуют стандартные приложения Windows?
  23. Какие Вы знаете служебные программы Windows?
  24. Как настроить элементы оформления экрана?
  25. Как установить новое оборудование?
  26. Как установить или удалить новый шрифт?
  27. Какие существуют стандартные средства мультимедиа?


Введение

Общее название программных средств, предназначенных для создания, редактирования и форматирования простых и комплексных текстовых документов – текстовые процессоры. В настоящее время наибольшее распространение имеет текстовый процессор Microsoft Word. Это связано прежде всего с тем, что разработчики предусмотрели локализацию программы в России, путем включения в нее средств поддержки работы с документами, выполненными на русском языке.

4.1. Возможности Word 2000

Любой текст, набранный в Word, называется документом. Каждый документ получает свое имя. Все документы хранятся в папках (папки также имеют названия).

При работе постоянно используется мышь. Выражение "щелчок" означает одинарное нажатие кнопки мыши. "Двойной щелчок" – соответственно два поочередных быстрых нажатия кнопки.

В большинстве случаев используется левая кнопка мыши, правая в основном для вызова контекстного меню с дополнительными функциями.

Все перемещения по столу мыши на экране повторяет так называемый курсор (или указатель). Основная (но не единственная) его форма – стрелка. В тексте курсор имеет форму вертикальной черты.

Окно – прямоугольная область, в которой располагается активный документ. Число окон соответствует количеству открытых файлов (документов).

Ввод текста с клавиатуры на экран в Word называется набор, а вывод на принтер – печать (распечатка).

В первую очередь текстовой процессор предназначен для работы с текстом, а именно – со шрифтами. Возможно изменение их начертания, размера, цвета и стиля. Разнообразие самих шрифтов позволяет создавать документы самого разного типа: визитки, письма, брошюры, документацию, приглашения, объявления, вывески, книги и т.д. Доступна настройка всех параметров абзаца (отступ, межстрочный интервал, выравнивание).

Word позволяет создавать таблицы в тексте, которые можно всячески видоизменять, а также проводить все возможные операции с ячейками таблицы. Работа с таблицами в Word 2000 стала еще удобнее за счет улучшенного интерфейса.

Теперь стало возможным использование одновременно 12 буферов обмена. Иначе говоря, можно скопировать до 12 различных фрагментов и вставлять любой из них при необходимости.

Word поддерживает работу с графикой. Под графикой подразумеваются рисованные картинки, фотографии, а также фигуры, создаваемые вручную. Также есть возможность разработки высокохудожественных надписей. Любой графический объект можно настроить (яркость, контрастность, размер, цвет, положение и др.).

Встроенный редактор формул позволяет создавать самые сложные математические и химические формулы.

Кроме всего перечисленного в Word имеется множество дополнительных функций, ускоряющих и облегчающих работу с текстами:

  • расстановка переносов;
  • изменение масштаба просмотра документа;
  • автоматическая нумерация страниц;
  • создание границ вокруг текста и страниц;
  • разработка своего стиля и использование его в дальнейшем для быстрого форматирования текста;
  • поддержка нескольких словарей для проверки правильности написания;
  • работа с макросами;
  • поддержка нескольких окон;
  • удобная справочная система;
  • проверка орфографии, грамматики и синтаксиса;
  • настройка панелей инструментов (добавление и удаление кнопок и команд);
  • возможность предварительного просмотра перед печатью;
  • настройка параметров страницы и поддержка нестандартных форматов бумаги;
  • вставка в текст специальных символов.


4.2. Запуск Microsoft Word

Существует несколько способов запуска Microsoft Word, как и любого другого приложения, работающего под управлением операционной системы Windows.

Запустить MS Word, можно одним из перечисленных ниже способов :

1. Выбрать соответствующую команду в стартовом меню (Пуск –>Программы –> Microsoft Word).

2. С помощью ярлыка Microsoft Word, расположенного на Рабочем столе.

3. С помощью кнопки Microsoft Word, расположенной на одной из панелей быстрого запуска Панели задач.

Если необходимо не только запустить Word, но и открыть документ, можно использовать программу Проводник.

1. Запустить Проводник любым известным способом.

2. Открыть папку, содержащую требуемый файл Microsoft Word и дважды щелкнуть по его значку левой клавишей мышки.

Можно использовать меню Пуск –> Документы. В появившемся на экране списке содержатся наименования документов, с которыми пользователь работал в последнее время. Щелкнуть мышкой по наименованию требуемого документа.


4.3. Структура окна MS Word

Главное окно Microsoft Word, содержащее пустой документ, показано на рис. 4.1.

Рис. 4.1. Главное окно редактора Microsoft Word

Главное окно можно разделить на пять основных областей:

  • строка заголовка;
  • строка меню;
  • панели управления;
  • рабочая область;
  • строка состояния.

Строка заголовка

Строка заголовка, помимо заголовка приложения, содержит кнопку системного меню и кнопки управления окном. Команды системного меню в основном дублируют кнопки управления (рис. 4.2).

Кнопка | Назначение
 | Свернуть окно в Панель задач
 | Полноэкранное представление окна
 | Отображение окна в нормальном виде
 | Закрытие окна

Рис. 4.2. Кнопки управления размером окна

Строка меню

Строка меню содержит команды основного меню. Все команды являются иерархическими. Это означает, что при выборе одной из таких команд на экране появляется ниспадающие меню. Для ускорения выполнения многих операций существует контекстное меню, оно позволяет выполнить многие операции, не обращаясь к строке меню. Для вызова контекстного меню необходимо нажать правой кнопкой мыши на объекте в документе, с которым нужно выполнить действие. Содержание меню зависит от того, что вы можете сделать с выделенным объектом в настоящий момент.

Панели инструментов

Панели инструментов предоставляют в наше распоряжение удобное средство для быстрого выполнения команд и процедур. Для того, чтобы выполнить команду или процедуру, представленную на панели инструментов соответствующей кнопкой, достаточно установить курсор мыши на эту кнопку и нажать левую клавишу мыши. На рис. 4.1 под строкой меню располагаются панели инструментов: Стандартная и Форматирования. Кроме них MS Word содержит и другие панели инструментов, которые при желании можно отобразить в окне текстового процессора.

Настройка панелей инструментов

В MS Word 2000 панели инструментов представлены на экране не целиком, а только самыми необходимыми кнопками. Для того чтобы вывести на экран нужную кнопку, необходимо нажать значок в виде стрелок. Откроется дополнение к представленной части, в нижнем отделе которого расположена команда Добавить или удалить кнопки. Если нажать стрелку рядом с этой командой, откроется весь список кнопок панели. Выбрать нужную кнопку можно, установив слева от нее флажок.

Вывод на экран/удаление с экрана панелей инструментов

Панели инструментов общего назначения доступны в любой момент работы с MS Word. Другие – выводятся на экран только при выполнении конкретных действий.

Для того чтобы вывести на экран одну из панелей надо выполнить команду Вид –> Панели инструментов и нажать мышью наименование нужной панели инструментов. Для удаления с экрана панели инструментов убрать флажок слева от ее наименования.

Строка состояния

Строка состояния расположена в нижней части окна. В левой части строки состояния отображается информация о текущем документе (рис. 4.3).

Рис. 4.3. Строка состояния

Описание элементов строки состояния

Элемент | Описание
Стр.4 | Номер текущей страницы
Разд. 1 | Номер текущего раздела. Информация, отображаемая этим элементом, имеет смысл только для документов, разбитых на разделы
4/7 | Количество страниц от начала документа до текущей страницы (4) и общее число страниц в документе (19)
На 16,1 см | Расстояние по вертикали между курсором и верхним краем страницы
Ст 37 | Количество строк от начала страницы до курсора
Кол 22 | Количество символов от левого поля до курсора, включая пробелы и символы табуляции

Кроме того, строка состояния содержит индикаторы режима работы, которые информируют, в каком из режимов редактор работает в настоящий момент. Черный цвет индикаторов соответствует включенному состоянию режима, серый – выключенному.

Назначение индикаторов строки состояния

Индикатор | Назначение
ЗАП | Активен режим записи макрокоманд
ИСПР | Активен режим маркировки исправлений. Маркеры исправления показывают, какие изменения были внесены в документ по сравнению с его последней версией
ВДЛ | Активна клавиша F8 (Расширить выделение). Каждое нажатие клавиши F8 будет расширять выделение фрагмента текста. Для сужения выделения используется комбинация клавиш Shift+F8
ЗАМ | Активен режим замены символов. В режиме вставки символов индикатор имеет серый цвет

Включение/выключение режимов осуществляется соответствующими командами и настройками. Кроме того, для переключения режима можно дважды щелкнуть левой клавишей мыши по соответствующему индикатору.

Контекстное меню

Контекстное меню позволяет выполнять многие из команд, не обращаясь к строке меню. Это средство позволяет ускорить выполнение многих операций. Для вызова контекстного меню необходимо нажать правой кнопкой мыши на том объекте, с которым необходимо произвести действие, или Shift+F10 на клавиатуре. Содержание меню определяется тем, что пользователь делает в данный момент и включает только самые необходимые команды.


4.4. Выход из MS Word

После завершения текущего сеанса работы необходимо выйти из MS Word. Для этого можно воспользоваться одним из следующих способов:

  • Выбрать меню Файл –> Выход.
  • Выбрать пункт Закрыть в системном меню главного окна MS Word.
  • Установить указатель мыши на значок системного меню в главном окне MS Word и дважды щелкнуть левой кнопкой мыши.
  • Нажать кнопку Закрыть в строке заголовка главного окна.
  • Нажать Alt+F4 на клавиатуре.

Если в каком-либо из открытых окон содержится не сохраненная информация, MS Word предложит выбрать, как поступить с ней. Для этого на экране появится окно диалога, аналогичное следующему (рис. 4.4).

Рис. 4.4. Сообщение при закрытии документа

Для продолжения операции выбрать одну из опций:

Кнопка | Назначение
Да | Сохраняет документ и выходит из MS Word. Если файлу еще не присвоено имя, MS Word откроет окно диалога Сохранение документа
Нет | Осуществляет выход из MS Word без сохранения документа
Отмена | Закрывает текущее окно диалога и возвращается в MS Word


4.5. Справочная система Word 2000

Подобно большинству наиболее популярных программ, MS Word имеет контестно-зависимую справочную систему. Это означает, что можно получить справку по использованию средства, с которым идет работа в настоящий момент. Основным средством получения справочной информации является меню Справка:

Команда меню | Описание
Справка по Microsoft Word | Запускает справочную систему MS Word – в зависимости от установленных параметров
Показать помощника | Выводит на экран помощника
Что это такое? | Позволяет получить справочную информацию о конкретном объекте
Office на Web | Запускает Internet Explorer и открывает Web-страницы с наиболее полезными сведениями Microsoft
Найти и устранить | Осуществляет поиск и автоматическое устранение ошибок в приложении
О программе | Показывает экран с авторскими правами на программу MS Word, имя владельца лицензии на нее, номер версии программы и ее идентификатор, имя файла ресурсов и каталог по умолчанию.

Для получения справочной информации можно воспользоваться ним из следующих способов:

  • Выбрать команду меню Справка –> Справка по Microsoft Word.
  • Выбрать команду меню Справка –> Что это такое?
  • Нажать F1 в любой момент сеанса работы с MS Word.

Справка об объектах в главном окне MS Word

Меню команды Справка содержит команду Что это такое?, позволяющую получить оперативную справку о назначении любого из элементов главного окна MS Word. Если нажать кнопку Что это такое?, указатель мыши изменится на знак вопроса. Установив указатель на интересующий элемент окна нужно нажать кнопку мыши. На экране появится всплывающее определение для указанного элемента.

Окно справочной системы показано на рис. 4.5.

Рис. 4.5. Окно справочной системы MS Word.

Искать интересующую информацию, нужно к вкладке Содержание. Темы справки упорядочены по разделам, каждый из которых обозначен пиктограммой с изображением книги. Двойное нажатие мышью на данной пиктограмме открывает оглавление следующих подразделов. При этом пиктограмма принимает вид открытой книги. Таким образом, открывается доступ к ее оглавлению. И только нажав пиктограмму со знаком «?», открывается доступ к справочной информации (рис. 4.5).

Закрытие окон справочной системы осуществляется стандартным способом, как любого другого окна.

Справка об объектах окна диалога

Большинство окон диалога содержат командную кнопку Справка, которая располагается в строке заголовка. С помощью этой кнопки можно также получить ответ на вопрос Что это такое? относительно элемента окна диалога, находящегося на экране в настоящий момент.


4.6. Создание и сохранение документов в MS Word

Работа в текстовом процессоре MS Word начинается с создания и сохранения документов.

Для того чтобы создать документ, необходимо выполнить следующие операции:

  1. Ввод текста.

  2. Редактирование текста.
  3. Форматирование символов.
  4. Форматирование абзацев.
  5. Вставка иллюстраций.
  6. Вставка сносок.
  7. Вставка колонтитулов.
  8. Форматирование страниц.

В текстовом процессоре Word принято использовать два метода создания нового документа: на основе готового шаблона или на основе существующего документа. Второй метод проще, но первый более корректен.

Мои документы — традиционная папка для хранения авторских документов в операционных системах Windows.

Избранное — особая логическая папка пользователя, предназначенная для хранения ярлыков Web-страниц.

Web-папки — особые папки, хранящиеся в Web-структурах, например в World Wide Web или в корпоративной сети Intranet. В общем случае при использовании Web-папок сохранение документа происходит не на локальном компьютере, а на удаленном Web-сервере.

При необходимости сохранить документ в произвольную папку, не представленную в данном списке, следует выполнить навигацию по файловой структуре с использованием раскрывающей кнопки на правом краю поля Папка.

Специальные средства ввода текста

Текст вводится с помощью алфавитно-цифровых клавиш. Для ввода прописных букв используется клавиша SHIFT. Если нужно ввести длинный ряд (поток) прописных символов, клавиатуру можно переключить с помощью клавиши CAPS LOCK.

При вводе текста необходимо соблюдать следующие правила:

  • Во всех современных текстовых редакторах переход на новую строку в процессе набора текста происходит автоматически, не требуя ввода специального символа.
  • Окончание абзаца маркируется нажатием клавиши Enter, позволяющей перейти на новую строку.
  • Пробел обязателен после знака препинания; перед знаком препинания пробел не ставится.

Специальные знаки препинания устанавливаются с помощью следующих комбинаций клавиш.

Знаки | Клавиша или комбинация клавиш
Дефис | <->
Неразрывный дефис | <Ctrl> + <Shift> + <дефис>
Тире | <Ctrl> + <серый минус [1] >
Неразрывный пробел | <Ctrl> + <Shift> + <пробел>

Понятие курсора. Место документа, в которое происходит ввод текста (точка ввода) отмечается на экране вертикальной чертой, которую называют курсором. Не надо путать курсор с указателем мыши – это два разных понятия. Указатель – это активный элемент управления, а курсор – это только маркер, не выходящий за пределы документа.

Переключение между русскими и латинскими символами. При наборе текста иногда приходится переключаться между русскими и латинскими символами. Это делается общесистемным способом.

Для того чтобы узнать, какой комбинацией клавиш на данном компьютере выполняется переключение раскладок клавиатуры, надо посмотреть, как настроены ее свойства (Пуск –> Настройка –> Панель управления –> Клавиатура).

Средства отмены и возврата действий. Все операции ввода, редактирования и форматирования текста протоколируются текстовым процессором, и потому необходимое количество последних действий можно отменить. Последнее действие отменяют комбинацией клавиш CTRL+Z. Другие аналогичные средства – команда Правка –> Отменить действие и кнопка Отменить действие на панели инструментов Стандартная.

После отмены ряда действий существует возможность вернуться к состоянию, предшествовавшему отмене. Для этого служит команда Правка –> Вернуть действие или кнопка Вернуть действие на панели инструментов Стандартная.

После открытия MS Word можно сразу начать вводить текст в документ. До тех пор пока файл не сохранен, документ временно находится в оперативной памяти. Для его сохранения необходимо записать его на жесткий диск, воспользовавшись командой Файл –> Сохранить.

При первом сохранении документа необходимо указать в окне диалога Сохранить как имя файла, в котором будет храниться ваш документ. В последующих сеансах работы файл можно оставить под тем же именем (Файл –> Сохранить) или под другим именем (Файл –> Сохранить как). Кроме того, для сохранения файла можно воспользоваться кнопкой Сохранить на стандартной панели инструментов или комбинацией клавиш Shift+F12.

Имена файлов

При задании имени файла необходимо следовать определенным правилам:

  • Имя файла MS Word может иметь длину до 255 символов, включая пробелы.
  • Можно использовать прописные и строчные буквы (А — Z, a — z, A — Я, а — я), цифры (0 — 9), а также специальные символы.
  • В имени недопустимы: звездочки (*), двоеточия (:), точка с запятой (;), знак вопроса (?), символы наклонной черты ( / или \ ), разделители ( | ), знаки больше чем ( > ) и меньше чем ( < ), кавычки (").
  • Из числа специальных можно использовать следующие символы: !, @, #, $, % ,,&,(, ), _, -, { и }. Точки допустимы только в качестве разделителя между именем и расширением файла.

Папки

При сохранении файла на жестком диске компьютера необходимо указывать папку, в которую будет помещен документ. Папки в MS Word аналогичны, по своему назначению, папкам, используемым в офисах для хранения бумажных документов.

Легко отыскать нужные файлы, если они находятся в соответствующих папках, относящихся к определенной тематике.

Создание документа

При создании нового документа MS Word строит его на основе одного из шаблонов. Шаблон определяет совокупность параметров, с помощью которых будет осуществляться форматирование документа. К этим параметрам можно отнести начертание шрифта, величину полей, установки табуляторов и т. д.

Создание пустого документа

Для создания документа пользуются шаблоном Обычный. Этот шаблон полезен в тех случаях, когда нужен пустой документ, в который в дальнейшем будет вводиться информация. При этом к документу не предъявляется каких-либо специальных требований по оформлению или форматированию.

Для того чтобы создать новый документ на основе шаблона Обычный, необходимо выполнить следующие действия:

  1. Выбрать меню Файл –> Создать. В результате на экране появится окно диалога Создание документа, представленное на рис. 4.6.

  2. Выбрать шаблон Обычный.

  3. Установить переключатель Документ. Нажать ОК.

Рис. 4.6. Окно диалога Создание документа.

В качестве альтернативного способа для создания нового документа, основанного на обычном шаблоне, можно использовать комбинацию клавиш Ctrl+N или кнопку Создать [image] на стандартной панели инструментов. В результате будет открыт новый документ, основанный на обычном шаблоне, без вывода на экран окна диалога Создание документа.

Открытие существующего документа

Основным средством открытия существующего документа MS Word является окно диалога Открытие документа (рис. 4.7). Для его открытия существует несколько способов:

  • Выбрать команду Файл –>Открыть.
  • Нажать Ctrl+O на клавиатуре.
  • Нажать кнопку Открыть на стандартной панели инструментов.

Рис. 4.7. Окно диалога «Открытие документа»

По умолчанию окно диалога Открытие документа содержит список документов папки Мои документы. Необходимо найти нужный документ в соответствующей папке и нажать в окне кнопку Открыть или дважды щелкнуть мышкой по значку документа.

MS Word помнит определенное количество (установленное в настройках редактора) последних документов, с которыми работал пользователь. Обычно они внесены в список меню Файл.

Для открытия недавно закрытого файла нужно открыть меню Файл и выбрать имя файла в нижней части меню.

Открытие файлов других форматов

MS Word позволяет открывать файлы, созданные в других форматах типа WordPerfect, Word для DOS, WordStar, Works и др. Для этого используется обычный путь: Файл –> Открыть, но в строке Тип файла нужно выбрать соответствующий тип или указать Все файлы, тогда в основном окне появится список всех файлов, из которых нужно выбрать нужный.

Работа с несколькими документами

Иногда возникает необходимость работать с несколькими документами одновременно. Это удобно как при просмотре версий одного документа, когда можно легко скопировать или переместить текст или рисунок, редактировать их, так и при работе с разными документами.

В процессе работы можно открывать уже существующие документы или создавать новые, вывести их на экран одновременно в виде окон или показывать по мере необходимости, используя меню Окно.

Для того чтобы разделить экран на две части, надо выбрать команду Окно –> Разделить, установить указатель мыши на разделительной линии и, передвинув его в нужном направлении, отпустите кнопку мыши. Если нужно увидеть одновременно все открытые документы, выбрать команду Окно –> Упорядочить все

В список меню Окно Word вносит все открытые в настоящее время файлы. Кроме того, все открытые документы представлены на Панели задач внизу экрана.

Сохранение документа

Для сохранения документа надо дать имя файлу, а также определить, в какой папке и на каком диске он будет записан. Для первоначального сохранения документа, необходимо выполнить следующие действия:

1. Выбрать пункт меню Файл –> Сохранить или нажать F12.

2. В поле Имя файла ввести имя файла или согласиться с предложенным Word.

3. С помощью раскрывающегося списка Папка выбрать имя диска. В результате его название появится в верхнем поле, а в основном окне появится список папок, содержащихся на нем.

4. Из списка папок выбрать ту, в которой будет храниться файл.

5. Выбрав все уровни вложения папок, нажать кнопку Сохранить.

Документ, в который вносятся какие-то изменения, надо также периодически сохранять. Все изменения во время работы находятся в оперативной памяти и не гарантированы от случайностей, одна из которых – бросок питания в электрической сети – в одно мгновение может уничтожить труд нескольких часов. Процедура сохранения заключается в следующем: надо установить указатель мыши на кнопку с изображением дискеты и щелкнуть левой кнопкой мыши. Только после этого изменения в документе будут записаны на жесткий диск.

Частое, регулярно выполняемое сохранение также сокращает время итогового сохранения документа на диске в конце сеанса работы.

Автоматическое сохранение документов

В MS Word есть возможность автоматически сохранять документы с определенным пользователем временным интервалом. При автосохранении документ будет временно сохранен в специальном, созданном для этого системой рабочем файле. Однако в конце сеанса работы необходимо сохранить файл, как обычно, используя команду Файл –> Сохранить или Файл –> Сохранить как. Таким образом, использование автосохранения не освобождает от сохранения в процессе и в конце работы, зато страхует от потери информации.

Для того чтобы установить автоматическое сохранение, нужно выполнить следующие действия:

1. Выбрать команду Сервис –> Параметры.

2. В окне диалога Параметры перейти на вкладку Сохранение.

3. Установить флажок Автосохранение каждые… и выбрать в окне нужный временной интервал, через который будет происходить автосохранение.

Защита сохраненного документа с помощью пароля

Если необходимо защитить свой файл от других пользователей, MS Word позволяет это сделать с помощью специального пароля.

Для предотвращения открытия документа используется Пароль для открытия файла. Установив его, невозможно открыть файл, не введя пароль.

В другом случае можно позволить открыть файл, работать с ним, но при этом защитить его от изменений. Тогда устанавливается Пароль разрешения записи.

Для того чтобы установить пароль, необходимо выполнить следующие действия:

1. Выбрать команду Файл –> Сохранить как и в открывшемся окне нажать кнопку Параметры, или выбрать команду Сервис –> Параметры.

2. Перейти на вкладку Сохранение (см. рис. 4.8).

В нижней части вкладки Сохранение находятся поля ввода: Пароль для открытия файла, Пароль разрешения записи и флажок Рекомендовать доступ только для чтения.

3. Ввести с клавиатуры пароль.

Пароль может содержать до 15 символов, включая буквы, цифры, значки и пробелы. Пароль в этом поле невидим, и главное, его запомнить.

4. Нажать ОК. Появится окно диалога Подтверждение пароля.

5. Повторно ввести пароль и снова нажать ОК.

6. Нажать ОК на вкладке Сохранение.

Рис. 4.8. Вкладка Сохранение меню Сервис –> Параметры.

Для удаления или замены пароля необходимо повторить описанные выше действия, удалить существующий пароль и напечатать новый, если это необходимо.

Пароль разрешения записи устанавливается аналогично.

Возможен еще вариант, когда документ можно открыть для ознакомления с ним, но нельзя, изменять. Для этого предназначен флажок Рекомендовать доступ только для чтения на вкладке Сохранение. Но этот запрет, в отличие от предыдущих случаев, легко снять.

Закрытие документа

После того, как работа с документом закончена и файл сохранен, документ можно закрыть. Если открыто сразу несколько документов, необходимо закрыть каждый документ. Существует несколько способов закрытия документа, но в любом из них при попытке закрыть документ сначала откроется окно запроса (рис. 4.5), в котором необходимо выбрать один из вариантов ответа. После ответа на запрос документ закрывается.


4.7. Редактирование документа

Под редактированием подразумевается внесение каких-либо изменений в существующий документ. MS Word представляет широкий набор средств редактирования документов для этих целей.

Прежде чем перейти непосредственно к средствам редактирования, рассмотрим, существующие в MS Word, режимы работы с документом.

Средства для представления документа на экране

Работа с документом в MS Word может осуществляться в одном из следующих режимов:

  • Обычный режим.
  • Режим Разметки страницы.
  • Режим Схема документа.
  • Режим Предварительного просмотра
  • Полноэкранный режим.
  • Режим Структуры документа.
  • Режим Главного документа.
  • Режим Web-документа.

Ниже приведены средства для переключения режимов.

Режим просмотра | Команда меню Вид | Комбинация клавиш | Кнопка
Обычный | Обычный | Alt+Cttl+N |
Разметки страницы | Разметка страницы | Alt+Ctrl+P |
Структуры документа | Структура | Alt+Ctrl+O |
Схема документа | Схема документа |  |
Web-документа | Web-документ |  |

При редактировании документа в основном используются первые три режима.

Обычный режим обеспечивает наиболее высокую скорость работы документом. Однако часть элементов оформления в этом режиме оказывается недоступна.

Режим разметки страницы позволяет получить адекватное представление о странице документа.

Режим структуры документа предоставляет удобные средства для работы со структурой.

Режим Главного документа основан на режиме структуры. Он полезен при работе с большими документами и позволяет оптимизировать некоторые процедуры.

Режим Схема документа специально предназначен для чтения документа с экрана. Это – режим Word, предлагаемый для применения в Internet. При этом страница делится на две части: схему документа и текст, который представлен более крупными буквами, длина строки изменяется, чтобы помещаться в окне целиком.

Схема документа очень удобна для быстрого поиска нужного раздела в большом документе.

Режим Web-документа предлагается для применения в Internet.

Все режимы могут сочетаться для удобства пользователя, а также применяться независимо друг от друга.

Режим предварительного просмотра и полноэкранный режим, как правило, не используются для редактирования документа.


Масштаб

В процессе работы можно изменять масштаб изображения: увеличивать изображение до 200% – для детальной работы или уменьшить – для просмотра общего вида страницы.

Для изменения масштаба можно воспользоваться кнопкой масштаб стандартной панели инструментов. При ее нажатии открывается список часто используемых масштабов, из которых можно выбрать нужный.

Рис. 4.9. Окно диалога Масштаб

Для изменения масштаба отображения документа с помощью команды используется команда Вид –> Масштаб, в результате чего на экране появится окно диалога Масштаб (рис. 4.10). С помощью этого окна можно установить нужную степень увеличения или уменьшения текста.

Если требуется установить масштаб, который отсутствует в списке предопределенных значений, можно ввести нужное значение в поле Произвольный

Перемещение в документе

Если требуется внести изменения в существующий документ, первое, что необходимо сделать, – это переместиться в требуемое место. Для перемещения по документу MS Word можно использовать любое из следующих средств.

  • Полосы прокрутки.
  • Команды меню.
  • Оперативные клавиши.
  • Перемещение с помощью панели поиска.

Перемещение с помощью полос прокрутки

Для прокрутки информации в вертикальном и горизонтальном направлениях предназначены вертикальная и горизонтальная полосы прокрутки, соответственно.

Каждая из полос прокрутки содержит кнопки прокрутки, на которых изображены стрелки, и движок прокрутки, квадратная кнопка.

  • Для перемещения на одну строку вверх или вниз надо нажать кнопку вертикальной полосы прокрутки, на которой изображена одинарная стрелка.
  • Для перемещения на один экран вверх (или вниз) нажать мышью пространство над (под) движком вертикальной полосы прокрутки.
  • Для перемещения на одну страницу вверх (или вниз) нажать мышью кнопку вертикальной полосы прокрутки, на которой изображена двойная стрелка.
  • Для перемещения в начало (или конец) документа передвинуть движок прокрутки вплотную к верхней (к нижней) кнопке прокрутки.
  • Для перемещения на требуемую страницу документа переместить мышью движок прокрутки. При этом на экране будет отображаться номер страницы и название раздела. Данное средство существенно облегчает позиционирование в больших документах.

Горизонтальная полоса прокрутки позволяет перемещаться вдоль строк аналогично тому, как происходит перемещение по строкам с помощью вертикальной полосы прокрутки.

Перемещение с помощью панели поиска

Система перемещения и поиска получила дальнейшее развитие в виде специальной поисковой панели. Для ее открытия надо нажать кнопку Выбор объекта перехода движка вертикальной полосы прокрутки [image].

С помощью этой панели можно перемещаться от объекта к объекту. При этом можно отыскать не только десять предопределенных объектов поиска, открывающихся после щелчка мыши, но и воспользоваться стандартным средством поиска и перемещения – окном диалога Найти и заменить, которое также открывается с помощью соответствующих кнопок данной панели. Выбранный режим перехода осуществляется с помощью двойных стрелок вертикальной полосы прокрутки.

Перемещение с помощью окна диалога Найти и заменить

Для точного позиционирования в документе MS Word предусмотрена специальная вкладка Перейти в окне диалога Найти и заменить. Для открытия этого окна можно воспользоваться одним из следующих способов:

  • Нажать клавишу F5.
  • Дважды нажать мышью свободное от индикаторов режима работы пространство строки состояния.
  • Нажать кнопку Выбор объектов перехода движка вертикальной полосы прокрутки.

Рис. 4.10. Вкладка Перейти окна диалога Найти и заменить.

Вкладка Перейти окна диалога Найти и заменить (рис. 4.10) имеет смысл только в том случае, если точно знать, куда нужно перейти (например, на страницу с определенным номером, к определенному разделу, к закладке с известным именем и т. д.).

Перемещение с помощью клавишных команд

Для перемещения по документу можно использовать клавишные команды. Ниже приведены оперативные клавиши для перемещения курсора.

Действие | Клавиши
В конец строки | End
В начало строки | Home
На одно слово влево | Ctrl + стрелка влево
На одно слово вправо | Ctrl + стрелка вправо
В конец документа | Ctrl + End
В начало документа | Ctrl + Home
На один экран вверх | Page Up
На один экран вниз | Page Down

Перемещение с помощью схемы документа

Одно из удобных средств перемещения по документу предоставляет режим Схема документа (в предыдущих редакциях Режим электронного документа). Этот режим открывается с помощью команды Вид –> Схема документа. В этом режиме экран разделяется на две части. В одной -- документ, в том режиме, в котором он находится в момент просмотра. В левой половине экрана представлена схема документа, составленная из заголовков разного уровня. Схема аналогична оглавлению.

Для того чтобы переместиться к нужному разделу, достаточно выделить заголовок в левой части экрана, и автоматически в правой части появляется выбранный раздел.


4.8. Основные приемы редактирования

Самые простые операции редактирования сводятся к вставке или удалению символа. Вставка символа осуществляется его непосредственным вводом с клавиатуры. Для удаления символа используются клавиши Delete и Backspace в зависимости от того, требуется удалить символ справа или слева от курсора. Более сложные операции предполагают работу с фрагментами документа, которые могут содержать рисунки, таблицы и другие объекты. В MS Word можно перемещать, копировать и удалять фрагменты документа. Однако прежде чем приступить к операциям с фрагментами, необходимо выделить фрагмент в документе.

Выделение текста

Для выделения текста можно использовать мышь или клавиатуру.

Выделение текста с помощью мыши

Мышь удобна при выделении небольших фрагментов текста. С помощью нее можно выделить фрагмент произвольного размера.

Для выделения... | Выполнить действие...
Слова | Двойной щелчок мышью по требуемому слову
Строки | Установить указатель мыши напротив выделяемой строки слева от документа, вне его пределов. Указатель изменит вид на наклонную стрелку, указывающую на нужную строку. Нажать кнопку мыши
Абзаца | Установить указатель мыши у выделяемого абзаца слева от документа, вне его пределов. Дважды нажать кнопку мыши
Фрагмента произвольного размера | Установить указатель мыши в начале фрагмента. Нажать кнопку мыши и, не отпуская ее, переместить указатель в конец фрагмента. Для завершения выделения отпустите кнопку мыши

Выделенный фрагмент текста изменяет свою окраску на инверсную.

Для отмены выделения щелкнуть мышью в произвольном месте документа.

Для выделения больших фрагментов, когда осуществляется прокрутка выделяемого текста в окне, такой способ неудобен. В этом случае целесообразно использовать клавиатуру или комбинировать мышь с клавиатурой, что дает более удобные средства выделения.

Выделение текста с помощью клавиатуры

Ниже приведены клавишные команды для выделения текста.

Для выделения... | Нажать
Слова | Shift + Ctrl + -> (или <-
Текста до начала строки | Shift + Home
Текста до конца строки | Shift + End
Расширить (или сузить) выделение фрагмента на одну строку | Shift + "стрелка вверх" или "стрелка вниз"
Фрагмента до начала документа | Shift + Ctrl + Home
Фрагмента до конца документа | Shift + Ctrl + End

Дополнительные средства выделения предоставляет клавиша F8. Каждое нажатие этой клавиши расширяет фрагмент выделения текста.

Для выделения... | Нажать F8
Слова | 2 раза
Предложения | 3 раза
Абзаца | 4 раза
Главы | 5 раз
Всего документа | 6 раз

При первом нажатии F8 в строке состояния индикатор режима работы ВДЛ начинается отображаться более ярко, указывая на то, что включен режим выделения. Для выключения режима выделения необходимо нажать клавишу Esc.

Удаление фрагмента документа

Довольно часто при редактировании документа приходится удалять фрагмент документа. В MS Word эта процедура выполняется достаточно просто.

Ниже приведены клавиши, предназначенные для удаления отдельного слова или символа.

Для удаления... | Нажать клавиши
Символа справа от курсора | Delete
Символа слева от курсора | Backspace
Следующего слова | Ctrl+Delete
Предыдущего слова | Ctrl+Backspace

Для удаления фрагмента документа необходимо выделить его, воспользовавшись любым из известных способов, а затем нажать клавишу Delete или Backspace.

Перемещение и копирование фрагмента документа

Наиболее простым способом перемещения и копирования фрагмента документа, содержащего текст и другие объекты, является способ, называемый Перенести-и-оставить. Этот способ предполагает выполнение следующей последовательности действий:

1. Выделить требуемый фрагмент.

2. Установить указатель мыши в пределах выделенного фрагмента.

3. Нажать кнопку мыши и, удерживая ее в нажатом состоянии, переместить фрагмент в требуемое место.

При нажатии кнопки мыши указатель принимает вид наклонной стрелки, на нижнем конце которой расположен пунктирный прямоугольник, процессе перемещения в документе отображает пунктирная вертикальная черта, указывающая то место, которое займет фрагмент, если в этот момент будет отпущена кнопка мыши.

4. Для завершения перемещения отпустить кнопку мыши.

Копирование фрагмента осуществляется аналогичным образом, но перед нажатием мышью выделенного фрагмента необходимо нажать клавишу Ctrl и удерживать ее до тех пор, пока фрагмент не будет скопирован.

Для переноса фрагмента на большое расстояние, этот способ становится неудобным. Необходимо поступить следующим образом:

1. Выделить требуемый фрагмент.

2. Нажать клавишу F2.

3. Установить указатель мыши в то место, куда нужно переместить фрагмент.

4. Нажать Enter.

Копирование фрагмента отличается тем, что вместо клавиши F2 следует нажать Shift+F2.

Буфер обмена

Для копирования и перемещения текста можно воспользоваться Буфером обмена.

Буфер обмена представляет собой область временного хранения информации. Это средство MS Office.

Буфер обмена имеет собственную панель инструментов, содержащую кнопки Копировать, Вставить все, Очистить буфер обмена. На панели расположены двенадцать ячеек, в которые могут быть помещены копируемые или вырезаемые фрагменты или рисунки.

Панель инструментов Буфер обмена открывается, как и любая панель инструментов MS Word, с помощью команды Вид –> Панель инструментов –> Буфер обмена.

Буфером обмена MS Office можно пользоваться, даже если панель его недоступна.

Итак, с помощью буфера обмена можно:

  • Вырезать фрагмент документа, содержащий текст и другие объекты, из одного места и вставить в другое место.
  • Перенести целый документ или его часть в другой документ.
  • Скопировать фрагмент в буфер, не удаляя его из документа, что позволяет многократно использовать его в различных местах документа и других документов.

Для работы с буфером обмена можно использовать команды меню Правка, команды контекстного меню, следующие кнопки стандартной панели инструментов и клавишные команды.

Действие | Команда меню Правка | Команда контекстного меню | Кнопка | Клавишная команда
Удалить в буфер | Вырезать | Вырезать |  | Shift + Delete
Копировать в буфер | Копировать | Копировать |  | Ctrl + Insert
Вставить из буфера | Вставить | Вставить |  | Shift + Insert

Отмена результатов редактирования

Для отмены результатов редактирования можно воспользоваться меню команды Правка, раскрывающимся списком Отменить на стандартной панели инструментов или оперативными клавишами.

Команда Правка –> Отменить позволяет отменить последние действия редактирования. Если необходимо восстановить отмененное действие, нужно выбрать команду Правка –> Вернуть.

С помощью кнопок Отменить и Вернуть [image] стандартной панели инструментов можно отменить или восстановить сразу несколько действий. Для этого надо нажать кнопку раскрытия списка, расположенную справа от кнопки Отменить. На экране появится соответственно список Отменить или Вернуть, в котором следует указать, какие именно действия из списка вы предполагаете отменить или восстановить. Максимальная размерность списков — 100 действий.

При отмене результатов редактирования следует учитывать тот факт, что ошибочные действия рекомендуется отменять, по возможности, сразу после их совершения


4.9. Специальные средства редактирования

Помимо простейших средств, описанных выше, в процессе редактирования можно использовать инструмент поиска и замены, который позволяет найти в документе нужное место или формат, также осуществить контекстную замену всех вхождений указанных символов.

Немаловажным вопросом редактирования является проверка орфографии, грамматики и стиля.

На заключительном этапе редактирования возможно выполнение переноса слов, позволяющего более компактно расположить текст в документе.

Использование поиска и замены

Мы уже говорили о некоторых возможностях окна диалога Найти и заменить (рис. 4.10). Оно открывается сразу тремя командами меню Правка: Найти, Заменить, Перейти или нажатием Ctrl+F.

Ниже приведены опции этого окна диалога:

Опция | Назначение
Найти | Определяет объект поиска. В это поле можно ввести данные непосредственно или вставить с помощью кнопок Формат и Специальный. Кнопка раскрытий списка позволяет задать один из четырех критериев поиска, использовавшихся последнее время
Найти далее | Осуществляет поиск следующего вхождения критерия, указанного в поле Найти
Больше Меньше | Увеличивает возможности вкладки Найти для расширенного поиска, открывает опции Направление, Учитывать регистр, Только слово целиком, Подстановочные знаки, Формат, Специальный, Снять форматирование Уменьшает окно диалога Найти, когда в расширенном поиске нет необходимости
Направление | Определяет направление поиска
Учитывать регистр | Выполняет поиск с учетом прописных и строчных букв в критерии, заданном в поле Найти
Только слово целиком | Выполняет поиск вхождений, являющихся самостоятельными словами
Подстановочные знаки | Позволяет использовать при задании критерия поиска специальные операторы, называемые шаблонами
Произносится как | Включение режима поиска английских слов, которые произносятся так же, как слова, введенные в поле Найти, но пишутся по-другому. Режим доступен только при работе с текстом на английском языке
Все словоформы | Замена всех форм английского слова, введенного в поле Найти, соответствующими формами английского слова, введенного в поле Заменить на. Режим доступен только при работе с текстом на английском языке
Снять форматирование | Удаляет форматирование, ранее установленное для поля Найти
Формат | Определяет формат объекта поиска. Выводит на экран список элементов, которые можно использовать при установке формата
Специальный | Предоставляет список специальных символов, которые могут включаться в критерий поиска

С помощью инструмента поиска-замены можно найти и заменить не только фрагменты текста, стили оформления или абзацы. Этот инструмент полезен и в тех случаях, когда в документе использовались иностранные слова, термины, команды и фразы, которые необходимо заменить русскими словами.

Проверка правописания

Хорошее средство проверки облегчает работу над документом, но ни одно средство проверки правописания не избавляет от внимательной проверки документа на заключительном этапе работы.

Для правописания используется вкладка Правописание окна диалога Параметры», открываемого командой Сервис –> Параметры. Ниже в приведены опции этой вкладки и их назначение.

Опции | Назначение
Орфография
Автоматически проверять орфографию | Позволяет автоматически проверять орфографию. Флажок установлен по умолчанию
Не выделять слова с ошибками | Если флажок снят, слова с ошибками выделяются. Установлен по умолчанию
Всегда предлагать замену | Предлагает автоматически список вариантов для замены ошибочного слова Установлен по умолчанию
Предлагать только из основного словаря | При выборе этой опции можно пользоваться только основным словарем. Не установлен по умолчанию
Пропускать слова из прописных букв | Позволяет не идентифицировать как ошибку слова из прописных букв. Установлен по умолчанию
Пропускать слова с цифрами | Позволяет не идентифицировать как ошибку слова с цифрами. Установлен по умолчанию
Пропускать адреса Internet и имена файлов | Позволяет не идентифицировать как ошибку адреса Internet и имена файлов. Установлен по умолчанию
Вспомогательные словари | Позволяет выбрать несколько словарей для проверки
Словари | Открывает окно диалога «Вспомогательные словари»
Грамматика
Автоматически проверять грамматику | Позволяет осуществить автоматическую проверку грамматики. Установлен по умолчанию
Не выделять слова с ошибками | Позволяет не отвлекаться на исправление ошибок при вводе текста. Установлен по умолчанию
Также проверять орфографию | Позволяет осуществлять одновременную проверку грамматики и орфографии. Не установлен по умолчанию
Статистика удобочитаемости | Определяет, насколько доступен ваш текст для восприятия при чтении. Не установлен по умолчанию
Набор правил | Позволяет выбрать способ проверки грамматики из вариантов, для деловой переписки, строго, для обычной переписки и три типа проверки по выбору пользователя
Настройка | Открывает окно диалога Настройка проверки грамматики, позволяющее установить набор правил для проверки грамматики
Проверка документа | Если в текущем сеансе работы с Word проверка правописания еще не выполнялась, эта кнопка называется Проверка документа. При нажатии этой кнопки очищается внутренний список пропускаемых слов

Автоматическая проверка правописания

Проверка орфографии в MS Word может осуществляться в процессе ввода текста. Для включения автоматической проверки орфографии следует воспользоваться вкладкой Правописание окна диалога Параметры, и используя приведенные выше опции, настроить проверку правописания.

Проверка уже введенного текста

Проверить орфографию уже введенного текста или его фрагмента можно, выполнив одно из следующих действий:

1. Выбрать команду Сервис –> Правописание.

2. Нажать кнопку Состояние проверки правописания на стандартной панели инструментов.

3. Нажать F7 на клавиатуре.

Проверка орфографии сводится к сравнению слов, присутствующих в документе, со словами из словаря MS Word. Встречая слово, в котором допущена ошибка или которое отсутствует в словаре, MS Word, подчеркивает его красной волнистой линией. Если ошибка грамматическая – слово или оборот подчеркивается зеленой волнистой линией.

Перенос слов

Перенос слов целесообразно выполнять на завершающей стадии редактирования.

Благодаря переносу слов, можно получить более компактный текст.

Разделение слов для переноса в документе может осуществляться автоматически или вручную.

Автоматический перенос слов

Действие установки режима автоматического переноса слов различается для нового и уже существующего документа. В режиме автоматического переноса для нового документа MS Word разделяет слова в тексте для переноса по мере ввода без участия пользователя. Если автоматический перенос выполняется для существующего документа, MS Word осуществит перенос слов, не позволяя его контролировать.

Для осуществления автоматического переноса необходимо выполнить следующие действия:

1. Выбрать команду Сервис –> Язык –> Расстановка переносов. На экране появится окно диалога Расстановка переносов (рис. 4.11).

2. Установить флажок Автоматическая расстановка переносов.

3. В поле Ширина зоны переноса слов отображается величина промежутка, оставляемого между окончанием последнего слова в строке и границей правого поля.

4. В поле Максимальное число последовательных переносов указывается максимальное число последовательных строк, в которых можно разделить слова для переноса.

5. Нажать ОК.

Рис. 4.11. Окно диалога Расстановка переносов

Принудительное разделение слов при переносе

Недостатком автоматического переноса является отсутствие контроля при переносе слов. Принудительный перенос позволяет осуществить контроль, предлагая варианты для переноса и предоставляя возможность решить, где именно будет выполнен перенос слова.

Для выполнения этой функции в окне диалога Расстановка переносов (рис. 4.11) необходимо нажать кнопку Принудительно. Откроется окно диалога Расстановка переносов, представленное на рис. 4.12, с помощью которого можно управлять переносом слов.

Рис. 4.12. Окно диалога Расстановка переносов

В поле Вариант отображается слово, в котором MS Word предполагает выполнить перенос. Можно выбрать устраивающий вас вариант, установив в нужном месте указатель. Для осуществления переноса надо нажать кнопку Да.

Если слово, предлагаемое к переносу, надо пропустить, нужно нажать кнопку Нет, в результате в окне диалога появится следующее слово, разделенное на слоги для переноса.


4.10. Форматирование символов

Форматирование символов включает в себя установку различных параметров шрифта, интервалов между символами и смещений. С помощью этих средств можно выделить в документе наиболее важные места (например, заголовки). Кроме того, существуют дополнительные средства, позволяющие устанавливать отображение символов малыми прописными буквами, в виде верхних и нижних индексов и т. д. Помимо этих средств форматирования при работе над документом могут быть использованы специальные символы шрифтов, которые позволяют внести разнообразие в оформление документа.

Шрифты

В понятие шрифта входят параметры: тип и размер шрифта, начертание, цвет, специальные эффекты.

Существует множество разнообразных шрифтов, предназначенных для самых различных целей. Для каждого конкретного случая принято использовать шрифты определенного размера: для основного текста обычно выбирают размер 10-12 пт, для заголовков – более крупные размеры (14 пт и выше), для сносок и примечаний – 8 пт.

Использование окна диалога Шрифт

Процесс форматирования сводится к установке требуемых параметров для символов. Форматирование текста обычно осуществляется уже после его ввода.

Основные параметры шрифта (тип, размер и начертание) можно установить с помощью меню команды Формат –> Шрифт, панели инструментов Форматирование, клавишных команд и контекстного меню.

Для открытия окна диалога Шрифт необходимо выполнить одно из следующих действий:

  • Выбрать команду Формат –> Шрифт.
  • Нажать правой кнопкой мыши по выделенной для форматирования области документа. На экране появится контекстное меню, из которого выбрать команду Шрифт.
  • Нажать комбинацию клавиш Ctrl+D.

Окно диалога содержит три вкладки: Шрифт, Интервал и Анимация (рис. 4.13).

При работе в окне диалога Шрифт установленные параметры шрифта отображаются в окне Образец.

Перед началом форматирования необходимо выделить требуемый фрагмент текста, а затем с помощью окна диалога Шрифт установить для него требуемые параметры. При этом сделанные изменения затронут только выделенный фрагмент и не коснутся остальной части документа.

Рис. 4.13. Вкладка Шрифт окна диалога Шрифт

Однако при форматировании фрагментов документа нет необходимости каждый раз открывать окно диалога Шрифт. Для этих целей целесообразно воспользоваться клавиатурой или кнопками панели инструментов Форматирование.

Использование панели инструментов Форматирование

Для форматирования в MS Word существует специально предназначенная для этих целей панель инструментов Форматирование (рис. 4.14).

Рис. 4.14. Панель инструментов Форматирование

С помощью кнопок этой панели можно выбрать тип и размер шрифта, установить начертание (полужирный, курсив, подчеркивание) и выделение цветом. Если панель инструментов Форматирование отсутствует на экране, надо выполнить команду Вид –> Панели инструментов. Далее в открывшемся списке панелей инструментов выбрать Форматирование.

Вкладка Интервал окна диалога Шрифт

Окно диалога Шрифт содержит еще одну вкладку Интервал, с помощью которой можно установить межсимвольные интервалы и смещение относительно базовой линии вверх или вниз. На рис. 4.15 представлена вкладка Интервал, назначение опций которой приведено ниже.

Рис. 4.15. Вкладка Интервал окна диалога Шрифт.

Используя вкладку Интервал, можно изменить расстояние между символами, а также вертикальное положение символов.

Опция | Назначение
Масштаб | Содержит список предопределенных масштабов, с помощью которого позволяет установить масштаб выделенного фрагмента текста
Интервал
Обычный | Расстояние между символами, используемое по умолчанию в обычном тексте
Разреженный | Увеличивает расстояние между символами
Уплотненный | Уменьшает расстояние между символами
Смещение
Нет | Отсутствует смещение символов относительно базовой линии
Вверх | Символы приподняты над базовой линией
Вниз | Символы опущены ниже базовой линии
Кернинг для символов размером | При установленном флажке расстояние между некоторыми символами в словах увеличивается, что делает слова более читабельными. Используется только со шрифтами TrueType и Adobe Type Manager больше установленного размера
Пунктов и более | Задает минимальный размер шрифта для кернинга


Изменение регистра букв

MS Word дает возможность быстро изменять регистр букв в тексте без повторного ввода. Для этих целей используется команда Формат –> Регистр. Для изменения регистра букв в тексте достаточно выделить фрагмент текста и выбрать в окне диалога Регистр нужную опцию (рис. 4.16). Тот же результат можно получить, используя клавишные команды.

Рис. 4.16. Окно диалога Регистр

Комбинация клавиш Shift+F3 осуществляет циклическое переключение начертания символов выделенного фрагмента:

  • Первая буква каждого слова прописная, остальные – строчные.
  • Все буквы прописные.
  • Все буквы строчные.

Вставка символов

Среди шрифтов TrueType есть специальные, содержащие различные знаки и символы, отсутствующие на клавиатуре. К их числу относятся Symbol и Wingdings.

Для вставки символа необходимо выполнить следующие действия:

1. Установить курсор в то место, где нужно вставить символ.

2. Выбрать команду Вставка –>Символ. Откроется окно диалога Символ, представленное на рис. 4.17.

3. Из раскрывающегося списка Шрифт выбрать шрифт Wingdings.

4. Чтобы увидеть в окне диалога увеличенное изображение символа, необходимо щелкнуть по нему мышью.

5. Чтобы вставить символ в документ надо дважды щелкнуть по нему мышью или нажать кнопку Вставить.

6. Нажать кнопку Закрыть.

Рис. 4.17. Окно диалога Регистр

Вставленный символ будет иметь тот же размер шрифта, что и предшествующий символ, но его можно увеличить до нужного размера.

Копирование форматов символов

Довольно часто приходится устанавливать одни и те же параметры форматирования в документе многократно. Занятие скучное и бессмысленное. MS Word представляет в наше распоряжение средства копирования формата. Таким образом, один раз отформатировав фрагмент текста, можно копировать установленный формат для других фрагментов.

Для копирования формата необходимо выполнить следующие действия:

1. Выделить символы или фрагмент текста, имеющие формат, который надо скопировать.

2. Нажать кнопку Формат по образцу на стандартной панели инструментов один раз, если копируется формат для одного фрагмента, или дважды, если выбранный формат копируется сразу для нескольких фрагментов. Курсор мыши примет вид кисти.

3. Выделить фрагмент текста, для которого копируется формат. После чего, он примет скопированный формат. Если необходимо скопировать формат в несколько фрагментов, отпустить кнопку мыши, а затем выделить следующий фрагмент. Курсор будет по-прежнему иметь вид кисти до тех пор, пока не нажать клавишу Esc.

Можно скопировать любой формат, установленный с помощью команды Формат –> Шрифт, контекстного меню, панели инструментов Форматирование или клавишных команд.

Копируемые параметры определяются выделенными символами:

  • Если выделение включает символ абзаца, то копируется стиль абзаца и все параметры формата абзаца, стиль символов и параметры формата символов.
  • Если выделение не включает символ абзаца, то копируется стиль символов и параметры формата символов.
  • Если выделение включает только маркер абзаца, то копируется стиль абзаца и параметры формата данного абзаца.


4.11. Форматирование строк и абзацев

При работе с текстом пользователь неизбежно сталкивается с понятием абзаца. Абзац – это фрагмент текста или графики, ограниченный символом абзаца. Знак абзаца (или маркер абзаца) – непечатаемый символ, который содержит все параметры форматирования соответствующего абзаца. Таким образом, абзац также является объектом форматирования.

При форматировании абзаца оперируют следующими понятиями:

Отступ – устанавливает расстояние текста абзаца (или только первой строки) от поля страницы.

Выравнивание текста – распределение текста на строке.

Табуляция – применяется для создания фиксированного отступа в начале первой строки каждого абзаца, а также позволяет оформить текст в несколько выровненных колонок.

Междустрочный интервал – позволяет установить расстояние между строками абзаца.

Кроме междустрочного интервала можно установить расстояние перед абзацем и после него.

Границы, заливка и узор – предназначены для создания дизайна абзаца.

Символ абзаца

При создании новых абзацев на них распространяются все установленные параметры форматирования абзаца для данного стиля. Это происходит при каждом нажатии клавиши Enter.

Символы абзаца можно вывести на экран или спрятать в зависимости от действий, выполняемых в настоящий момент. При редактировании текста целесообразно установить режим, при котором символы абзаца будут отображаться на экране.

Для выполнения этой процедуры можно воспользоваться стандартной панелью управления или клавиатурой.

  • Нажать кнопку Непечатаемые символы [image] на стандартной панели инструментов.
  • Нажать комбинацию клавиш Ctrl+Shift+*.

Оба эти способа являются переключателями, повторное нажатие комбинации клавиш или кнопки на стандартной панели инструментов приведет к исчезновению с экрана всех непечатаемых символов.

Средства форматирования абзаца

При создании нового документа используются установки шаблона Обычный до тех пор, пока не будут заданы новые параметры форматирования.

Абзац можно отформатировать как до ввода текста, так и после того, как текст уже введен. Если форматируется уже введенный текст, то абзацы, подлежащие форматированию, должны быть выделены. При форматировании одного абзаца достаточно перед началом форматирования установить в нем курсор.

MS Word предоставляет в наше распоряжение следующие средства форматирования абзаца:

  • Команда Формат –> Абзац позволяет в одном окне диалога установить сразу все необходимые параметры форматирования абзаца.
  • Команда Абзац из контекстного меню – дублирует действие команды главного меню.
  • Панель инструментов Форматирование – установка каждого параметра осуществляется нажатием соответствующей кнопки. За один раз устанавливается только один параметр формата. Однако, если требуется изменить один элемент форматирования, данное средство позволяет сделать это быстрее, чем с помощью соответствующей команды меню.
  • Горизонтальная линейка – используется для установки отступов и табуляции.
  • Клавишные команды – аналогично кнопкам панели инструментов Форматирование позволяют ускорить изменение одного из параметров формата.

Команда Абзац из меню Формат или контекстного меню

Для установки нескольких параметров форматирования абзаца наиболее удобно использовать окно диалога Абзац. Для открытия этого окна диалога надо выбрать команду Абзац из меню Формат или из контекстного меню, открываемого с помощью правой кнопки мыши.

Окно диалога Абзац содержит две вкладки: Отступы и интервалы, Положение на странице (рис. 4.18). С помощью этого окна диалога можно установить доступные в MS Word элементы форматирования абзаца.

Рис. 4.18. Окно диалога Абзац

Устанавливаемые параметры можно визуально оценить в разделе Образец.

Форматирование с помощью команды окна диалога Абзац сводится к заданию значений для выбранных параметров. При этом числовые значения могут быть непосредственно введены в соответствующие поля или выбраны с помощью кнопок, расположенных в правой части полей ввода. Далее назначение опций этого окна диалога будет рассмотрено подробно.

Средства панели инструментов Форматирование

Панель инструментов Форматирование (рис. 4.19) позволяет быстро изменить конкретный параметр формата абзаца. Для этого достаточно выделить требуемые абзацы и нажать мышью нужную кнопку на панели инструментов. С помощью соответствующих кнопок этой панели можно:

  • установить выравнивание (по правому или левому краям, по ширине, по центру);
  • создать фиксированные отступы.

Однако в MS Word имеется возможность вынести на панель Форматирование кнопки соответствующие практически всем командам окна диалога Абзац. В этом возникает необходимость при частом использовании каких-либо процедур.

Рис. 4.19. Панель инструментов Форматирование

Выравнивание абзацев

Выравнивание абзаца может производиться по левому краю, по правому краю, по центру, по ширине.

Выравнивание текста с помощью команды Формат –> Абзац используется в тех случаях, когда это нужно для продолжительной работы в этом режиме. В случае выравнивания небольших фрагментов удобнее использовать выравнивание с помощью панели инструментов или клавишных команд.

Для выравнивания текста с помощью команды Формат –> Абзац надо выполнить следующие действия:

1. Выделить один или несколько абзацев, которые предполагается выровнять. Если требуется выровнять один абзац, необходимо установить курсор в пределах этого абзаца.

2. Выбрать команду Формат –> Абзац, откроется окно диалога Абзац.

3. Нажать кнопку в поле Выравнивание, откроется список видов выравнивания.

4. Выбрать нужный вид выравнивания. Нажать ОК.

Если форматирование абзаца ограничивается изменением выравнивания, целесообразно воспользоваться панелью управления:

1. Выделить один или несколько абзацев, которые предполагается выровнять. Если требуется выровнять один абзац, необходимо установить курсор в пределах этого абзаца.

2. Нажать на панели инструментов Форматирование соответствующую кнопку: По левому краю, По центру, По правому краю или По ширине.

Табуляция

Обычно в начале каждого абзаца устанавливается табуляция, таким образом обозначается «красная строка». Кроме того, можно одновременно использовать сразу несколько установок табуляции. Данным средством иногда пользуются при табулированном представлении текста, не прибегая к помощи таблиц.

При установке табуляции необходимо выбрать тип выравнивания позиции табуляции (рис. 4.20).

Дополнительно для табуляции можно установить заполнитель. MS Word предлагает на выбор три возможных варианта заполнения: сплошной линией, пунктирной и составленной из точек. Практическим примером использования табуляции с заполнением является оглавление.

Окно диалога Табуляция, представленное на рис. 4.20, может быть использовано для установки нескольких символов табуляции различных видов.

Рис. 4.20. Окно диалога Табуляция

Для установки табуляции необходимо выполнить следующие действия:

1. Выделить абзац или фрагмент текста, в котором нужно установить табуляцию, или поместить курсор в текст, откуда должен начаться фрагмент с новой табуляцией.

2. Выбрать команду Формат –> Табуляция, появится окно диалога Табуляция.

3. Ввести значение для позиции табуляции в поле Позиция табуляции. Допускается ввод дробных значений.

4. В разделе Выравнивание выбрать требуемую опцию.

5. В разделе Заполнитель, выбрать форму заполнения табуляции.

6. Нажать кнопку Установить.

Для установки следующих позиций табуляций необходимо повторить пп. 3-6. После чего в списке Позиции табуляции будут представлены все установленные позиции табуляции. Нажать ОК.

С помощью горизонтальной линейки можно установить любой из видов табуляции, кроме табуляций с заполнителем и с чертой.

Непосредственная установка табуляции осуществляется с помощью кнопки Тип табуляции, расположенной в левом конце горизонтальной линейки. Необходимо нажать несколько раз эту кнопку до тех пор, пока значок типа табуляции на ней не примет требуемый вид:

Значок на горизонтальной линейке | Выравнивание
 | По левому краю
 | По правому краю
 | По центру
 | По разделителю

Для установки табуляции с помощью линейки надо выполнить следующие действия:

1. Выделить абзац или фрагмент текста, для которого нужно установить табуляцию, или поместить курсор в этом фрагменте.

2. Нажимать кнопку Тип табуляции до тех пор, пока на линейке не появится символ требуемого типа.

3. Установить указатель мыши в то место, в котором предполагается установить табуляцию, и нажать кнопку мыши. На линейке появится символ табуляции выбранного типа.

Для того чтобы установить несколько табуляций различных типов, надо выполнить пп. 2-3.

Удаление табуляции

Удалить ненужные табуляции можно, воспользовавшись окном диалога Табуляция или горизонтальной линейкой. Для этого в окне диалога Табуляция надо нажать кнопку Удалить все. Если требуется удалить конкретный табулятор, надо указать его в списке Позиции табуляции и нажать кнопку Удалить.

Можно удалить лишние табуляторы с помощью горизонтальной линейки, не открывая окна диалога Табуляция.

Для этого на горизонтальной линейке надо установить указатель мыши на табуляторе, который необходимо удалить. Нажать кнопку мыши и, не отпуская ее, переместить маркер табуляции на серое пространство за пределы рабочей области горизонтальной линейки.

Установка отступа

Иногда при оформлении документа требуется выделить часть его, абзац или несколько абзацев с помощью отступов. В результате край фрагмента документа окажется сдвинутым относительно поля документа.

При установке отступа для абзаца можно задавать как положительные, так и отрицательные отступы.

При использовании окна диалога Абзац используются опции раздела Отступ: Справа, Слева и Первая строка (рис. 4.18).

При создании позиций отступов можно ввести требуемое значение в соответствующее поле или выбрать его с помощью кнопок, расположенных в правой части поля.

Для установки отступов с помощью окна диалога Абзац необходимо выполнить следующие действия:

1. Выделить абзац или поместить курсор в нужный фрагмент текста.

2. Выбрать команду Абзац из меню Формат или контекстного меню. Откроется окно диалога Абзац.

3. Установить величину левого и/или правого отступов. В разделе Образец можно визуально оценить внешний вид изменений.

4. Нажать ОК.

Горизонтальная линейка также позволяет установить все виды отступов. В этом случае достаточно перетащить соответствующие маркеры на требуемые места.
Выноска 2 (без границы): Маркер отступа первой строки абзаца
Выноска 2 (без границы): Маркер отступа левой границы абзаца Выноска 2 (без границы): Маркер отступа правой границы абзаца

Рис. 4.21. Маркеры отступов на горизонтальной линейке

Однако в окне диалога устанавливаются точные значения, а на линейке маркеры можно позиционировать с шагом 0,25 см.

На левом и правом концах линейки расположены треугольные маркеры названные маркерами отступов (рис. 4.21). Их перемещение осуществляется с помощью мыши.

Для установки отступа абзаца необходимо выполнить следующие действия:

1. Выделить абзац или фрагмент текста, для которого предполагается установить отступ.

2. Переместить с помощью мыши маркеры отступа.

Установка расстояния перед абзацем и после него

Для установки интервала до и после абзаца надо выполнить следующие действия:

1. Выбрать команду Формат –> Абзац.

2. Установить требуемые значения для интервалов в полях Перед и После. Можно ввести требуемые значения в поля или воспользоваться кнопками, расположенными в правой части полей. По умолчанию значения интервалов указываются в пунктах (пт). Нажатие кнопок приводит к изменению значений на 6 пт.

3. Нажать ОК.

Установка междустрочного интервала

Междустрочный интервал – расстояние между строками текста. В MS Word междустрочный интервал выражен в строках. Обычно устанавливается интервал, равный одной строке. MS Word предоставляет возможность увеличивать интервал на кратное число строк. Кроме того, можно задать минимальное и точные значения. Для этих целей предназначен раскрывающийся список Междустрочный в окне диалога Абзац. Ниже приведено назначение его опций:

Опции | Назначение
Одинарный | Устанавливает междустрочный интервал для каждой строки в соответствии с наибольшим символом в этой строке
Полуторный | Устанавливает для каждой строки междустрочный интервал в 1,5 раза больший, чем при одиночном междустрочном интервале
Двойной | Устанавливает для каждой строки междустрочный интервал в 2 раза больший, чем при одиночном междустрочном интервале. текста
Минимум | Определяет минимальный междустрочный интервал, который может установить MS Word
Точно | Устанавливает фиксированный междустрочный интервал
Множитель | Устанавливает междустрочный интервал, кратный указанному числу строк

Границы и заливка

Меню Формат также содержит команду Границы и заливка, открывающую одноименное окно диалога Границы и заливка (рис. 4.22). Возможности этого окна диалога разнообразны, и освоив их, можно эффектно оформлять различные элементы в документе.

Окно диалога Границы и заливка содержит вкладки Граница, Страница, Заливка. На рис. 4.22 показана вкладка Граница.

Для создания обрамления фрагмента текста необходимо выполнить следующие действия:

1. Выделить фрагмент текста, который предполагается оформить.

2. Выбрать команду Формат – Границы и заливка, откроется одноименное окно диалога.

3. На вкладке Границы выбрать из предложенных типов Рамку.

4. Выбрать линию из раскрывающегося списка Тип. В поле Образец для рамки будет использована линия указанного типа.

5. Выбрать цвет рамки (если необходимо). Для этого нажать кнопку в поле Цвет и выбрать из списка приемлемый цвет.

6. Если есть необходимость, нажать кнопку Параметры и в открывшемся окне диалога Параметры границы и заливки установить расстояние от текста, введя желаемую величину в поля Верхнее, Нижнее, Правое и Левое. Нажать ОК.

Рис. 4.22. Окно диалога Границы и заливка.

Обрамление фрагмента текста можно сделать с помощью панели инструментов Границы Для ее открытия используется одноименная кнопка на панели инструментов Форматирование.

Панель инструментов Границы содержит все возможные варианты обрамления, присутствующие в окне диалога Границы и заливка.

С помощью вкладки Заливка окна диалога Границы и заливка (рис. 4.23) можно получить дополнительные эффекты при оформлении фрагмента документа.

Данное средство можно использовать как с предварительным обрамлением, так и без него.

Для установки заливки необходимо выделить абзац, предназначенный для оформления. Выбрать узор заполнения из предложенных в списке. Выбрать цвет заливки. Нажать кнопку раскрытия Цвет фона и выбрать цвет фона. В поле Образец отражаются все этапы подбора рисунка, цветов узора и фона. Установить область применения заливки с помощью опции Применить к. Нажать ОК.

Рис. 4.23. Окно диалога Границы и заливка. Вкладка Заливка.


4.12. Списки

Правила оформления различных документов иногда требуют наличия в документах списков. Принято выделять три типа списков:

  • Маркированные списки (или списки-бюллетени) используются при перечислении или выделении отдельных фрагментов текста. В качестве примера можно использоваться данный фрагмент текста, оформленный с помощью средств маркированного списка.
  • Нумерованные списки полезны в тех случаях, когда нужно определить порядок изложения.
  • Многоуровневые (или иерархические) списки, т.е. имеющие несколько уровней. В таких списках допустимы как нумерованные элементы, так и символы маркера.

Создание маркированных и нумерованных списков

Маркированный (нумерованный) список можно создать с помощью окна диалога Список и панели Форматирование. Для создания маркированного списка с помощью окна диалога Список необходимо выполнить следующие действия:

1. Выделить несколько абзацев текста, предназначенных для создания списка.

2. Выбрать команду Формат – Список. Откроется окно диалога Список.

3. Перейти на вкладку Маркированный (Нумерованный) (рис. 4.24).

4. Выбрать список из представленных образцов. Нажать ОК.

Для продолжения списка необходимо поместить курсор в конце последнего абзаца списка и нажать клавишу Enter.

Для создания списков на панели инструментов Форматирование предназначены две кнопки:

Кнопка | Название | Назначение
 | Маркированный список | Создает маркированный список
 | Нумерованный список | Создает нумерованный список

•

Рис. 4.24. Окно диалога Список. Вкладка Маркированный.

При создании списков с помощью кнопок панели инструментов Форматирование параметры их будут заданы по умолчанию.

Для завершения списка необходимо установить курсор в пределах абзаца, начиная с которого нужно отменить список, и нажать кнопку, соответствующую списку (нумерованный или маркированный).

Изменение формата маркированного списка

С помощью окна диалога Список можно изменить следующие параметры маркированного списка:

  • Символ маркера на любой символ из шрифтов, установленных на компьютере.
  • Величину выступа.
  • Расстояние между символом маркера и текстом.
  • Выравнивание.

Для этих целей необходимо войти в меню Формат – Список и нажать кнопку Изменить, после чего откроется окно диалога Изменить маркированный список, представленное на рис. 4.25.

Рис. 4.25. Окно диалога Изменить маркированный список

Ниже приведен состав его опций:

Опции | Назначение
Символ маркера
Шрифт | Предлагает варианты различных шрифтов для выбранного символа
Маркер | Позволяет осуществить выбор варианта символа маркера
Положение маркера
Отступ | Определяет выравнивание и положение маркера относительно левой границы текста
Положение от текста
Отступ | Устанавливает величину отступа от правого края маркера до начала текста
Образец | Позволяет визуально оценить, как будет выглядеть список после внесения в него изменений

Изменение формата нумерованного списка

Нумерованные списки создаются на вкладке Нумерованные (рис. 4.24). Если предложенные форматы нумерованного списка не подходят для оформления конкретного документа, можно создать собственный формат списка, нажав кнопку Изменить в диалоговом окне Список на вкладке Нумерованный. При этом откроется окно диалога Изменение нумерованного списка (рис. 4.26).

Рис. 4.26. Окно диалога Изменить нумерованный список

Ниже приведены опции этого окна диалога, с помощью которых осуществляется изменение формата нумерованного списка.

Опция |  | Назначение
Формат номера
Нумерация | Осуществляет выбор стиля номеров для списка
Начать с | Задает номер, с которого должна начаться нумерация в списке
Шрифт | Позволяет выбрать шрифт для номеров в списке и для любого текста до и после номеров Открывает вкладку Шрифт
Положение номера
Выравнивание | Устанавливает выравнивание списка
На | Определяет выравнивание и положение номера
Положение текста
Отступ | Устанавливает расстояние от правого края номера до начала текста
Образец | Дает возможность увидеть все проводимые изменения до внесения их в документ

Создание многоуровневых списков

Во многих видах документов встречаются более сложные типы списков. Это так называемые многоуровневые списки. В них также используется либо маркировка, либо нумерация, а иногда и сочетание того и другого. Но главное их отличие от предыдущих типов списков – наличие нескольких уровней. В зависимости от уровня для каждого абзаца устанавливается символ или номер.

Рис. 4.27. Вкладка Многоуровневые окна диалога Список.

Многоуровневые списки отличаются от обычных наличием отступов. Определенный отступ принимается за уровень такого списка.

Создание многоуровневого списка возможно только с помощью окна диалога Список. Причем уровни задает сам исполнитель, устанавливая определенные отступы. Word анализирует отступы и, в зависимости от их величины, нумерует, создавая уровни.

Можно создавать измененные форматы нумерации для различных уровней многоуровневого списка, однако в одном документе допустим только один формат многоуровневого списка.

Для создания многоуровневого списка необходимо выполнить следующие действия:

1. Определить фрагмент документа, который предполагается оформить в виде списка.

2. Создать отступы каждого абзаца, воспользовавшись кнопкой Увеличить отступ на панели инструментов Форматирование (при создании отступов нельзя использовать табуляцию).

3. Выделить выбранный фрагмент текста.

4. Выбрать команду Формат – Список. В окне диалога Список перейти на вкладку Многоуровневый (рис. 4.27).

5. Выбрать нужный тип многоуровневого списка из предложенных вариантов. Нажать ОК.


4.13. Использование стилей для форматирования документа

Стиль – это совокупность параметров форматирования, имеющая свое название.

Для того чтобы текст был удобен для чтения, его необходимо отформатировать соответствующим образом: выделить заголовки, оформить подзаголовки в соответствии с их уровнем, выполнить подписи к рисункам и таблицам, выделить новые термины, примечания, установить колонтитулы и т. д. Форматировать каждый из элементов вручную долго и неэффективно. С помощью же стилей можно установить несколько параметров форматирования за один шаг. При этом для каждого из элементов оформления можно установить собственный стиль, который будет иметь уникальное наименование. Достаточно установить требуемые стили, а затем каждый раз просто выбирать из списка необходимый.

Использование стилей позволяет повысить эффективность и ускорить выполнение работы.

В MS Word стиль может быть применен как к целому абзацу, так и к нескольким символам.

В качестве основного стиля, установленного по умолчанию, используется стиль Обычный. Этот стиль применяется для основного текста любого документа и служит основой для создания других стилей. Параметры форматирования можно узнать из описания стиля, содержащегося в окнах диалога Стиль, Изменение стиля, Создание стиля, Организатор. Все перечисленные выше окна диалога содержат раздел Описание, в котором представлены все параметры формата.

Установка стилей

Наиболее широкие возможности по работе со стилями предоставляет окно диалога Стиль. Для установки стиля с помощью окна диалога Стиль необходимо выполнить следующие действия:

1. Установить курсор в пределах фрагмента текста, в котором нужно изменить стиль.

2. Выбрать команду Формат –> Стиль. Откроется окно диалога Стиль (рис. 4.28).

3. В списке Стиль выбрать требуемый стиль.

4. Нажать кнопку Применить.

С помощью окна диалога Стиль также можно:

  • изменять существующие стили;
  • создавать новые стили;
  • удалять ставшие ненужными пользовательские стили;
  • копировать требуемые стили из одного шаблона в другой.

Рис. 4.28. Окно диалога Стиль.

Оглавление

Оглавление можно создать с помощью встроенных стилей форматирования, предлагаемых Word. Создание оглавления сводится к сбору тех заголовков, которым назначены стили Заголовок 1 – Заголовок 9. Поэтому перед составлением оглавления следует убедиться, что заголовкам разделов, глав и параграфов назначены именно эти стили.

В заголовки редко включают заголовки всех уровней. Оглавление, содержащее названия всех частей документа, может выглядеть слишком громоздким. С другой стороны, оглавление, содержащее только заголовки верхнего уровня, дает слишком мало информации о содержании документа.

Чтобы создать оглавление необходимо выполнить следующие действия:

1. Установить курсор в пределах текста, в котором нужно создать оглавление.

2. Выбрать команду Вставка –> Оглавление и указатели. Откроется окно диалога Оглавление и указатели (рис. 4.29).

3. Перейти на вкладку Оглавление.

4. В поле Формат выбрать способ представления оглавления, в поле Уровни – уровень включаемых заголовков, а в поле Заполнитель – символы заполнения между заголовками и номерами страниц.

5. Нажать кнопку ОК.

Рис. 4.29. Включение в оглавление уровней 1-3

После нажатия кнопки ОК на экране появится скомпонованное оглавление, которое в дальнейшем можно изменить и отформатировать.

Рис. 4.30. Готовое оглавление, включающее заголовки трех уровней


4.14. Автоформат

Автоформат может форматировать документ без участия пользователя. MS Word производит анализ документа, идентифицирует отдельные элементы, а затем форматирует текст, применяя стили подключенного шаблона.

Автоформатирование можно производить как по мере ввода текста, так и после его ввода. При этом пользователь оставляет за собой право принять или отвергнуть форматирование, произведенное с помощью автоформата. Кроме того, можно частично принять, а от части внесенных изменений – отказаться.

Автоформатирование в процессе ввода текста

Автоформатирование в процессе ввода одно из наиболее удачных средств, облегчающих создание документа.

Для установки автоформата в процессе ввода текста необходимо выполнить следующие действия:

1. Выбрать команду Сервис –> Автозамена.

2. Перейти на вкладку Автоформат при вводе (рис. 4.31).

3. Установить флажки соответственно с требованиями к автоформатированию.

4. Нажать ОК.

Рис. 4.31. Установка автоформатирования при вводе текста

Автоформатирование уже введенного текста

Для автоматического форматирования существующего текста необходимо на вкладке Автоформат окна диалога Параметры установить переключатель При выборе команды. Далее можно запустить процесс автоформатирования с помощью кнопки Автоформат стандартной панели инструментов или команды Формат –> Автоформат.

При автоматическом форматировании документа, в зависимости от установок, сделанных на вкладке Автоформат (команда Сервис –> Автозамена), MS Word производит следующие изменения:

  • к каждому абзацу применяется стиль;
  • удаляются лишние маркеры абзацев;
  • отступы, сделанные с помощью клавиши tab, заменяются на отступы абзацев;
  • вместо звездочек (*), дефисов (-) или аналогичных символов, используемых для обозначения маркированных списков, вставляются символы бюллетеня;
  • символы (с), (r) и (тм) заменяются на символы из установленного шрифта: символ авторского права, символ зарегистрированного товарного знака и символ товарного знака ©, ® и ™.

С помощью кнопки Автоформат можно быстро отформатировать текст, и если результатат неудовлетворителен, можно отменить автоформатирование нажатием кнопки Отменить.

Автоформатирование с помощью окна диалога Автоформат

Команда Автоформат осуществляет автоматическое форматирование под контролем пользователя. Для проведения автоформатирования с помощью окна диалога Автоформат необходимо выполнить следующие действия:

1. Выбрать команду Формат –> Автоформат. Откроется окно диалога Автоформат, представленное на рис. 4.32.

2. Нажать кнопку Параметры, на экране появится вкладка Автоформат окна диалога Автозамена (рис. 4.28). Установить параметры автоматического форматирования. Нажать ОК. MS Word осуществит автоматическое форматирование и сообщит о завершении процесса.

Рис. 4.32. Окно диалога Автоформат.

На выбор пользователя предлагаются три варианта продолжения действий:

  • принять или отменить все изменения сразу;
  • просмотреть и принять/отменить отдельные изменения;
  • выбрать оформление в библиотеке стилей.


4.15. Форматирование страниц документа

В документе или печатном издании страница оформляется по определенным правилам. Обычно на странице имеются поля: боковые, верхнее и нижнее. Боковые поля могут использоваться под переплет или для заметок. Верхние или нижние поля обычно содержат колонтитул. В колонтитуле можно поместить номер страницы, дату создания, название главы, документа и т.д.

Средства разметки страницы предоставляют следующие возможности:

  • установка конца раздела;
  • установка конца страницы или абзаца;
  • установка ширины полей;
  • изменение размеров листа;
  • создание верхних и нижних колонтитулов;
  • нумерацию страниц.
  • вертикальное выравнивание на странице;
  • разбивка текста на колонки.

Для того чтобы эти средства форматирования могли применяться к фрагменту документа, предусмотрена разбивка на разделы. Разбив документ на разделы их можно по-разному оформить (например, установить различные размеры полей в разделах, использовать для таблиц альбомную ориентацию страницы, в некоторых разделах разбить текст на колонки).

Разбивка документа на разделы

В MS Word разбивка на разделы осуществляется путем вставки символа разрыва раздела.

Символом раздела обозначается место, с которого начинается новый раздел в документе, который может иметь собственный формат.

Вставка символов раздела осуществляется с помощью команды Вставка –> Разрыв. В результате выполнения этой команды открывается окно диалога Разрыв. Ниже приведен состав опций этого окна:

Опция | Назначение
Со следующей страницы | Вставляет маркер конца страницы над точкой вставки Оставшийся текст помещается на следующей странице
На текущей странице | Новый раздел продолжается сразу за предыдущим без вставки маркера конца страницы между ними. Свободное место последней страницы предыдущего раздела заполняется текстом из нового раздела
С четной страницы | Новый раздел начинается на следующей нечетной странице. Если конец раздела попадает на нечетную страницу, то следующая четная страница останется пустой
С нечетной страницы | Новый раздел начинается на следующей четной странице. Если конец раздела попадает на четную страницу, то следующая нечетная страница останется пустой

Определение размера и ориентации бумаги

При подготовке документа обычно требуется установить ориентацию и размер бумаги. В MS Word предусмотрено два типа ориентации бумаги – книжная и альбомная.

MS Word предлагает около десяти предопределенных размеров бумаги, включая letter (письмо), legal (юридический), конверты и т. д. В случае необходимости можно самостоятельно установить требуемые размеры страницы.

Для установки размера и ориентации страниц предназначена вкладка Размер бумаги окна диалога Параметры страницы. Для открытия этого окна диалога необходимо выбрать пункт меню Файл –> Параметры страницы. Окно диалога Параметры страницы можно также открыть, дважды щелкнув мышью в нерабочей области на горизонтальной линейке.

Для установки размера и ориентации страниц необходимо:

1. Выбрать команду Файл –> Параметры, откроется окно диалога Параметры страницы.

2. Перейти на вкладку Размер бумаги (рис. 4.33).

3. В раскрывающемся списке Размер выбрать требуемый размер листа. Если ни один из приведенных размеров не подходит, ввести свои значения в поля Ширина и Высота.

4. Установить нужную ориентацию страницы с помощью переключателя: Книжная или Альбомная.

5. Из списка Применить выбрать, к какому фрагменту следует применить установленные размер и ориентацию страницы. Нажать ОК.

Рис. 4.33. Окно диалога Параметры страницы, вкладка Размер бумаги

Установка ширины полей

Обязательным элементом форматирования страницы являются поля. Поля могут быть пустыми, а могут содержать колонтитулы, номера страниц, сноски или даже текст и графику.

В обычном режиме поля не видны. На экране отображается только текстовая область страницы. В режиме разметки страница выглядит практически так, как она будет напечатана, вместе с полями и прочими элементами разметки.

Ширину полей можно изменить как во всем документе, так и в отдельных его разделах. Можно даже изменить установку ширины полей по умолчанию. Для этого нужно внести изменения в шаблон Обычный или создать собственный шаблон.

Установить ширину полей в документе можно с помощью:

  • окна диалога параметры страницы;
  • горизонтальной линейки.

Установка точных размеров полей

При установке размеров полей для всего документа курсор может находиться в любом месте документа. При этом в документе должны отсутствовать выделенные фрагменты.

Для задания размеров полей для фрагмента документа необходимо выполнить одно из следующих действий:

  • если нужно установить размеры полей для части текста, надо ее выделить;
  • если нужно установить размеры полей для разделов документа, надо вставить разрыв раздела;
  • если нужно установить размеры полей с определенного места до конца документа, надо поместить курсор в то место, откуда будут начинаться новые установки поля, и указать, что новые размеры полей следует применять до конца.

Для установки ширины полей необходимо выполнить следующие действия:

1. Выделить фрагмент текста, для которого надо изменить размеры полей, или поместить курсор в требуемый раздел.

2. Выбрать команду Файл –> Параметры страницы, или установить курсор в нерабочей области горизонтальной линейки и дважды нажать кнопку мыши. Независимо от способа откроется окно диалога Параметры страницы.

3. Перейти на вкладку Поля (рис. 4.34) и установить нужные размеры полей.

5. В списке Применить выбрать, к каким частям документа применить установленные размеры полей. Нажать ОК.

Рис. 4.34. Окно диалога Параметры страницы, вкладка Поля.

Создание разворотов и полей под переплет

В практике достаточно часто используется двусторонняя верстка, называемая разворотом. Двусторонняя верстка предполагает симметричное (т.е. зеркальное) расположение полей. При этом размеры внешних полей четных и нечетных страниц, а также размеры внутренних полей равны. Для внутренних можно дополнительно предусмотреть место на переплет. Как правило, для переплета достаточно 1,5 см.

Для этой цели предназначен флажок Зеркальные поля в окне диалога Параметры страницы. Для создания разворотов необходимо выполнить следующие действия:

1. Выделить фрагмент текста или установить курсор в то место, где предполагается создать разворот.

2. Выбрать команду Файл –> Параметры страницы. Откроется окно диалога Параметры страницы. Перейти на вкладку Поля.

3. Установить флажок Зеркальные поля.

4. В поле Переплет указать (ввести или выбрать) размер полей под переплет. В окне Образец появится дополнительное поле в виде затененной области. Нажать ОК.

Установка ширины полей с помощью горизонтальной линейки

Горизонтальная и вертикальная линейки позволяют быстро установить размеры полей в документе или отдельном разделе, не открывая окна диалога Параметры страницы. В обычном режиме на экране отображается только горизонтальная линейка, в режиме разметки страницы и предварительного просмотра на экране присутствуют обе линейки:

  • горизонтальная, позволяющая выбрать ширину левого и правого (или внутреннего и внешнего) полей;
  • вертикальная, позволяющая установить ширину верхнего и нижнего полей.

Каждая линейка имеет затененную и белую области. Затененная область обозначает поля, белая – текстовую область. Линия раздела между ними определяет положение границы полей. Передвигая мышью границы полей, можно изменить их ширину. Например, для уменьшения ширины левого поля границу левого поля следует передвинуть вправо к левому краю страницы.

Для изменения ширины полей с помощью линейки необходимо выполнить следующие действия:

1. Если линейки не выведены на экран, установить горизонтальную линейку с помощью команды Вид –> Линейка.

2. Установить указатель мыши на границу поля, ширину которого вы хотите изменить. При этом он изменит вид на горизонтальную двунаправленную стрелку.

3. Пунктирная линия на экране указывает текущее положение ширины поля. Нажать кнопку мыши и переместить границу поля в требуемом направлении до тех пор, пока ширина поля не достигнет требуемого размера.

Если потребуется вывести на экран вертикальную линейку для изменения ширины верхнего и нижнего полей, надо выбрать команду Сервис –> Параметры. Затем в открывшемся окне диалога Параметры перейти на вкладку Вид и установить в разделе Окно флажок Вертикальная линейка.


Колонтитулы

Колонтитулы – обычный элемент оформления документа, расположенный в верхнем поле страницы (верхний колонтитул), либо в нижнем поле (нижний колонтитул).

В колонтитул могут быть вынесены название документа, название глав, нумерация страниц, имя автора, дата создания, сноски и т. п. Колонтитул также может содержать графику (например, логотип фирмы). Для работы с колонтитулами предназначена одноименная панель инструментов (рис. 4.35). Для открытия этой панели надо выбрать команду Вид –> Колонтитулы.

Рис. 4.35. Панель Колонтитулы

При этом на экране располагается верхнее или нижнее поле, а основной текст приобретает светло-серую окраску и перестает быть активным. Для каждого из колонтитулов можно ввести требуемый текст, а затем форматировать его как обычный текст с помощью команды Формат –> Шрифт. Для завершения работы над колонтитулами необходимо нажать кнопку Закрыть. Для создания колонтитулов надо выполнить следующие действия:

1. Выбрать команду Вид –> Колонтитулы. В результате на экране появится панель инструментов Колонтитулы.

2. Ввести текст внутри пунктирной рамки, окружающей область колонтитула (например, название документа и имя автора).

3. Разместить (при необходимости) в колонтитуле номер страницы, дату и время, нажимая соответствующие кнопки на панели Колонтитулы.

4. Для возвращения в документ нажать кнопку Закрыть или дважды щелкнуть мышью в области основного текста.

Ниже приведены назначения кнопок панели Колонтитулы.

Кнопки | Название | Назначение
 | Вставка автотекста | Вставляет элемент автотекста, используемый при оформлении колонтитулов
 | Номер страницы | Вставляет номер страницы в колонтитул
 | Число страниц | Вставляет в колонтитул общее количество страниц в документе
 | Формат номера страницы | Открывает одноименное окно диалога
 | Дата | Вставляет текущую дату в колонтитул
 | Время | Вставляет текущее время в колонтитул
 | Параметры страницы | Открывает одноименное окно диалога
 | Основной текст | Отображает или скрывает основной текст
 | Как в предыдущем разделе | Вставляет верхний/нижний колонтитул из предыдущего раздела в текущий или используется для создания другого колонтитула путем разрыва связи между колонтитулами двух разделов
 | Верхний/нижний колонтитул | Переключение между верхним и нижним колонтитулами
 | Перейти к предыдущему | Отображает предыдущий колонтитул
 | Перейти к следующему | Отображает следующий колонтитул
 | Закрыть панель | Осуществляет переход к тексту документа

В колонтитулы можно вставить любое графическое изображение, созданное с помощью графического редактора или снятое при помощи сканера. При этом изображение можно сделать фоном, поверх которого можно разместить текст основного документа.

Чтобы отредактировать колонтитул, нет необходимости пользоваться командой Вставка –> Колонтитул, достаточно дважды щелкнуть по готовому колонтитулу левой клавишей мыши.

Создание разных колонтитулов для четных и нечетных страниц

При двусторонней верстке с использованием разворота принято создавать разные колонтитулы для четных и нечетных страниц. Например, на левой странице разворота в верхнем колонтитуле будет размещено название документа, а на правой стороне – название раздела. Для создания колонтитулов для четных и нечетных страниц:

1. Выбрать команду Вид –> Колонтитулы.

2. Нажать кнопку Параметры страницы на панели инструментов Колонтитулы.

3. Перейти на вкладку Макет.

4. В разделе Различать колонтитулы установить флажок Четных и нечетных страниц и нажать кнопку ОК.

5. Перейти с помощью кнопок Перейти к предыдущему и Перейти к следующему к четному (или нечетному) колонтитулу и оформить колонтитул.

6. Для возвращения в документ дважды нажать мышью на области основного текста.


Нумерация страниц

Любым документом удобнее пользоваться, если в нем пронумерованы страницы. В MS Word можно вставить номера страниц, которые будут отформатированы в виде верхних или нижних колонтитулов. Таким образом, при работе с номерами страниц можно пользоваться всеми средствами, предназначенными для работы с колонтитулами.

Вставка номеров страниц

Номера страниц удобно вставлять в ходе создания колонтитулов нажатием кнопки Номер страницы на панели инструментов Колонтитулы. Их можно размещать в любом месте колонтитула.

В качестве альтернативного способа вставки номера страниц можно воспользоваться командой Вставка –> Номера страниц.

Для установки нумерации страниц необходимо выполнить следующие действия:

1. Выбрать команду Вставка –> Номера страниц. На экране появится окно диалога Номера страниц, представленное на рис. 4.36.

2. В списке Положение указать место на странице (внизу или вверху страницы), где предполагаете располагать номера страниц.

3. Открыть список Выравнивание и установить способ выравнивания номеров страниц (слева, справа, от центра, внутри или снаружи).

4. Чтобы изменить формат нумерации (1, 2, 3), нажать кнопку Формат и добавить номер главы или выбрать другой формат. Нажать кнопку ОК.

Рис. 4.36. Окна диалога Номера страниц

Нумерация страниц не отображается в обычном режиме. Расположение номеров на странице можно увидеть в режиме разметки страницы или предварительного просмотра, а также выбрав команду Вид –> Колонтитулы.

Если потребуется изменить положение номеров страниц, надо выбрать команду Вставка –> Номера страниц, в списке Выравнивание выбрать новый способ выравнивания.

В MS Word по умолчанию применяется сквозная нумерация страниц ко всем разделам документа, но можно изменять начальные номера страниц каждого раздела.

Для того чтобы установить начальный номер страницы раздела, достаточно ввести нужный номер страницы в поле Начать с, предварительно установив переключатель в окне диалога Формат номера страницы.

Для того, чтобы убрать нумерацию страниц, необходимо войти в режим редактирования колонтитулов, т.е. дважды щелкнуть мышью на поле с номером страницы. В этом случае откроется панель инструментов Колонтитулы. После этого убрать в соответствующем поле номер страницы.


Создание колонок

В MS Word можно создавать различные варианты колонок: одинаковой ширины, разной ширины, одинаковой длины, разной длины, с разделителем, со встроенными рисунками.

Но во всех случаях речь идет о колонках газетного типа, т.е. таких, в которых текст по завершении одной колонки переходит в другую.

Колонки можно создавать с помощью команды Формат –> Колонки или кнопки Колонки на стандартной панели инструментов.

В обычном режиме просмотра колонки не видны, их можно увидеть только в режиме разметки страницы и режиме предварительного просмотра.

Документ может быть разбит на колонки полностью или частично. На странице можно расположить столько колонок, на сколько хватит места.

Работа с колонками осуществляется с помощью окна диалога Колонки, которое открывается с помощью команды Формат –> Колонки. Ниже приведен состав опций этого окна диалога.

Опции | Назначение
Тип
Одна, Две, Три | Вставляет одну, две или три колонки одинаковой ширины
Слева | Форматирует текст в две колонки, причем левая колонка имеет ширину в половину правой колонки
Справа | Форматирует текст в две колонки, причем правая колонка имеет ширину в половину левой колонки
Число колонок | Осуществляет разбиение на колонки в соответствии с указанным значением
Разделитель | Вставляет вертикальную линию между колонками. Линия имеет длину наиболее длинной колонки на странице или в разделе
Ширина и промежуток
Номер |  | Показывает номер колонки, ширину и расстояние перед которой можно изменить. Нумерация колонок начинается слева
Ширина |  | Определяет ширину колонки
Промежуток |  | Задает расстояние между текущей колонкой и следующей справа колонкой
Колонки одинаковой ширины |  | Устанавливает равную ширину для всех колонок в разделе
Применить |  | Определяет, какую часть документа требуется разбить на колонки
Ко всему документу |  | Разбивает на колонки весь документ
К выделенному тексту |  | Выделяет фрагмент документа в отдельный раздел и разбивает его на колонки
До конца документа |  | Вставляет маркер конца раздела перед курсором, после чего разбивает фрагмент документа на колонки
К выделенным разделам |  | Разбивает на колонки только выделенные разделы
К данному разделу |  | Разбивает на колонки только раздел, в котором находится курсор
Новая колонка |  | Начинает новую колонку путем вставки маркера конца колонки в местоположении курсора
Образец |  | Отображает результат разбиения текста на колонки

Прежде чем приступить к работе с колонками, текст необходимо разбить на разделы. Например, можно оформить заголовки в одну колонку, выделив их в отдельные разделы. В начале и конце каждого из разделов необходимо вставить маркер раздела.


4.16. Работа с таблицами

В работе с текстовыми редакторами достаточно часто приходится сталкиваться с упорядоченной информацией. Наилучшим способом хранения такой информации в документах являются таблицы. Таблицами можно пользоваться для представления разнообразных списков, перечней, финансовой информации и решения большого числа других задач. Таблицы могут даже содержать иллюстрации для улучшения восприятия информации, содержащейся в таблице.

Создание таблиц

Для создания таблицы можно воспользоваться командой Таблица –> Добавить –> Таблица или кнопкой Добавить таблицу на стандартной панели инструментов.

Команда Нарисовать таблицу предоставляет в распоряжение альтернативное средство, с помощью которого можно создать таблицу более сложной конфигурации (например, с ячейками разной высоты или различным количеством столбцов на строку). При использовании этой команды можно просто рисовать требуемую таблицу с помощью мыши, как карандашом на бумаге.

После создания таблицы можно воспользоваться командой Таблица –> Автоформат, чтобы выбрать требуемый формат из предлагаемого набора стандартных форматов.

Если информация, которую требуется поместить в таблицу, уже присутствует в документе в виде текста, можно преобразовать текст в таблицу. Если таблица содержит числовые значения, можно выполнять вычисления над строками, столбцами или отдельными ячейками таблицы.

Создание таблицы различными способами

Стандартный способ создания таблицы предполагает использование команды Таблица –> Добавить –> Таблица. Для вставки таблицы необходимо выполнить следующие действия:

1. Установить курсор в точку, где должен располагаться левый верхний угол таблицы.

2. Выбрать команду Таблица –> Добавить –> Таблица, в результате чего на экране появится окно диалога Вставка таблицы (рис. 4.37).

3. Указать необходимое количество столбцов и строк.

4. Если необходимо, можно установить точную ширину столбцов.

5. Применить Автоформат, если в этом есть необходимость.

Рис. 4.37. Окно диалога Вставка таблицы

Наиболее простой способ создания таблицы предполагает использование кнопки Добавить таблицу. В этом случае ширина столбцов устанавливается автоматически на основании ширины документа и количества столбцов.

Для создания таблицы с помощью кнопки Добавить таблицу необходимо установить курсор в точку, где будет размещаться таблица. Нажать мышью кнопку Добавить таблицу, в результате чего на экране появится миниатюрное изображение таблицы. Нажав мышью любую из ячеек в изображении таблицы и не отпуская кнопку мыши, необходимо переместить указатель мыши в ячейку, которая будет соответствовать нужному размеру таблицы. Отпустить кнопку мыши. В указанном месте документа появится таблица требуемого размера.

Широкие возможности по созданию таблиц представляет команда Нарисовать таблицу из меню Таблица. В этом случае создание таблицы происходит путем рисования «карандашом» в области документа на экране. С помощью команды Нарисовать таблицу можно создать таблицу со сложной структурой.

Для создания таблицы с помощью команды Таблица –> Нарисовать таблицу необходимо выполнить следующие действия:

1. Выбрать команду Таблица –> Нарисовать таблицу. На экране появится панель инструментов Таблицы и границы, а указатель примет форму карандаша.

2. Задать внешние границы таблицы. Для этого установить указатель в любой из углов таблицы и нажать кнопку мыши. Не отпуская кнопки, переместить указатель в противоположный угол таблицы, после чего отпустить кнопку мыши.

3. Действуя аналогичным образом, провести линии столбцов и строк.

Если в процессе работы над таблицей понадобится удалить линию (строки или столбца), необходимо выбрать на панели Таблицы и границы инструмент Ластик, установить указатель мыши в начало линии, нажать кнопку мыши и провести до конца линии, после чего отпустить кнопку мыши.


Ввод данных и перемещение по таблице

Ввод данных (текст или числа) в таблицу производится с помощью клавиатуры. Если введено больше символов, чем может поместиться в одной строке, Word автоматически перенесет символы, которые не поместились в текущей строке, на следующую строку в той же ячейке.

Наиболее простой способ перемещения по ячейкам таблицы заключается в использовании мыши. Для того чтобы перейти в требуемую ячейку, достаточно установить на нее указатель мыши и нажать левую кнопку. Ниже приведены клавиши, позволяющие перемещаться по таблице.

Комбинация клавиш | Назначение
Tab | Перемещает курсор вправо на одну ячейку. Добавляет новую строку, если курсор расположен в последней ячейке
Shift + Tab | Перемещает курсор влево на одну ячейку
"стрелка вверх" и "стрелка вниз" | Перемещает курсор в последующую или предыдущую строку соответственно
<-- и --> | Перемещает курсор на один символ в пределах ячейки. Нажатие этих клавиш соответственно в начале и конце ячейки приведет к перемещению в предыдущую или последующую ячейки
Alt + Ноmе и Alt + End | Перемещает курсор в первую или последнюю ячейку строки соответственно
Alt + PgUp и Alt + PgDn | Перемещает курсор в первую или последнюю строку столбца соответственно

Отражение и маскирование линий сетки

Линии сетки предназначены для идентификации ячеек таблицы.

Команда Отображать сетку из меню Таблица позволяет отобразить линии сетки. В результате выполнения этой команды линии сетки появятся на экране, а наименование самой команды изменится на Скрыть сетку. Выбор команды Таблица –> Скрыть сетку удаляет сетку с экрана.

При вставке таблицы MS Word по умолчанию создает таблицу с обведенными ячейками. Если такая таблица не устраивает пользователя, необходимо ее выделить, автоматически окажется включенной кнопка Внешние границы. После нажатия на стрелку, откроется одноименная панель, используя которую можно удалить всю обводку, нажимая одну за другой все активизированные кнопки.

Вставка и удаление ячеек, строк и столбцов

После создания таблицы можно изменить ее структуру, добавляя и удаляя ячейки, строки и столбцы.

Конкретный вид опций Добавить и Удалить из меню Таблица и контекстного меню определяется тем, какие элементы таблицы (ячейки, строки или столбцы) были выбраны перед вызовом команды. Если вы пользуетесь командой меню Таблица, то можете добавить строки как сверху, так и снизу от выделенной, а столбцы – как справа, так и слева. При использовании кнопок панели и контекстного меню можно добавлять строки выше выделенной строки, а столбцы – слева от выделенного столбца. Однако можно вынести недостающие кнопки на панель инструментов Таблицы и границы. После вставки новая строка или столбец становятся текущими.

Для вставки строк и столбцов необходимо выполнить следующие действия:

1. Выбрать строку (несколько строк) или столбец (несколько столбцов) в зависимости от того, что надо добавить, строки или столбцы.

2. Выбрать команду Таблица –> Добавить –> Строки выше/Строки ниже или Таблица –> Добавить –> Столбцы справа/Столбцы слева.

Для удаления строк и столбцов необходимо выполнить следующие действия:

1. Выбрать строку (несколько строк) или столбец (несколько столбцов) в зависимости от того, что надо удалить, строки или столбцы.

2. Выбрать команду Таблица –> Удалить –> Строки или Таблица –> Удалить –> Столбцы.

Не обязательно вставлять или удалять строки или столбцы целиком. В некоторых случаях может потребоваться выполнить операции над конкретными ячейками. В этом случае действия будут аналогичны рассмотренным ранее при вставке и удалении строк и столбцов.

Если требуется очистить ячейки (т.е. удалить их содержимое, не удаляя самих ячеек), необходимо выбрать ячейки, предназначенные для удаления содержимого, и нажать Del или Backspace.

Объединение и разбиение ячеек, создание заголовков

Если заголовок размещается непосредственно в таблице, может потребоваться объединить несколько ячеек одной строки в одну ячейку. Аналогичную задачу приходится решать при размещении в таблице достаточно длинного текста, который должен отображаться в одну строку, или графического изображения. Word позволяет объединить несколько расположенных рядом горизонтальных ячеек в одну. При этом содержимое ячеек также объединяется в одну ячейку. Для объединения нескольких расположенных рядом в одной строке ячеек необходимо выделить их и выбрать команду Таблица –> Объединить ячейки.

Можно объединить ячейки, воспользовавшись инструментом Ластик, расположенным на панели Таблицы и границы. Выбрав этот инструмент, нужно провести им по линии, разделяющей ячейки, которые предполагается объединить.

Если требуется создать заголовок таблицы, необходимо выбрать первую строку и произвольное число следующих строк, которые предполагается использовать в качестве заголовков таблицы. Далее выбрать команду Таблица –> Заголовки. Если таблица не поместится на одной странице, MS Word будет автоматически повторять заголовок таблицы на каждой странице.

Если после задания заголовка таблицы текст заголовка изменится, заголовки на последующих страницах будут изменены автоматически.

Разбиение ячеек является обратной операцией по отношению к объединению.

Для разбиения ячеек надо выбрать одну или несколько ячеек, которые предполагается разбить. Выбрать команду Разбить ячейки из меню Таблица или контекстного меню, в результате чего на экране появится окно диалога Разбиение ячейки. В полях ввода Число столбцов и Число строк отображается количество столбцов и строк, на которые MS Word предлагает разбить каждую из ячеек. В случае необходимости надо изменить указанное значение и нажать ОК.

Флажок Объединить перед разбиением позволяет быстро изменить структуру таблицы, например, преобразовать таблицу 2 х 3 в 4 х 6

В качестве альтернативного средства для разбиения ячеек можно воспользоваться кнопкой Разбить ячейки на панели инструментов Таблицы и границы


Настройка таблиц

На практике достаточно часто возникает необходимость изменить параметры таблицы, в которой содержатся данные. MS Word предоставляет широкие возможности по редактированию таблиц, включая вставку и удаление ячеек, строк и столбцов, перемещение и копирование ячеек, изменение высоты и ширины ячеек и многое другое.

Перемещение и копирование ячеек

После того как таблица создана и наполнена данными, может потребоваться изменить расположение данных в таблице.

Для того чтобы переместить или скопировать одну или несколько ячеек вместе с их содержимым, необходимо выполнить следующие действия:

1. Выбрать ячейки, строки или столбцы, которые предполагается переместить или скопировать.

2. Переместить указатель мыши в пределах выбранных ячеек так, чтобы он принял вид стрелки, направленной справа налево.

3. Дальнейшие действия зависят от того, надо ли переместить или скопировать выделенные элементы. Для того чтобы переместить элементы таблицы, нажать левую кнопку мыши. Если требуется скопировать элементы, нажать клавишу Ctrl и левую кнопку мыши.

4. Переместить курсор в ячейку, расположенную левее и выше того места, в котором должны появиться перемещенные или скопированные ячейки. Отпустить кнопку мыши.

При работе с таблицей действие команд Вырезать, Копировать и Вставить из меню Правка или контекстного меню таблицы полностью аналогично работе с текстом.

Использование команды Таблица –> Свойства таблицы

Команда Таблица –> Свойства таблицы позволяет в пределах одной команды изменить ширину сразу нескольких столбцов, строк, ячеек, а также установить величину каждого из элементов таблицы равной определенному значению. При выборе команды Таблица –> Свойства таблицы открывается окно диалога Свойства таблицы, состоящее из четырех вкладок: Таблица, Строка, Столбец, Ячейка. Кроме того, в этом же окне можно установить обрамление и заливку для таблицы, открывая окно диалога Границы и заливка с помощью одноименной кнопки на вкладке Таблица, и осуществить настройку положения таблицы на странице относительно текста.

На вкладке Столбец можно изменить ширину столбцов. На вкладке Строка можно изменить высоту строк. Кроме того, на вкладке Ячейка можно установить интервал между ячейками.

Автоматическая установка ширины столбцов и высоты строк

MS Word предоставляет средство, с помощью которого можно автоматически изменить ширину столбцов и высоту строк. Для этого предназначена команда Таблица –> Автоподбор, которая позволяет для выбранных строк или столбцов:

  • выровнять высоту строк;
  • выровнять ширину столбцов;
  • выровнять ширину столбцов по содержимому, по ширине окна;
  • подобрать фиксированную ширину столбцов.


Форматирование таблиц

Ячейки в таблице и их содержимое можно отформатировать для придания таблице более читабельного вида.

Для форматирования содержимого ячеек можно воспользоваться приемами форматирования обычного текста, представляемые командой Формат.

Помимо содержимого ячеек, можно добавить элементы оформления таблицы (линии сетки всей таблицы или ее отдельных ячеек, обрамление и т.д.). MS Word также предоставляет набор стилей оформления таблицы.

Изменение направления текста

Помимо выравнивания содержимого ячеек таблицы можно изменить направление текста, расположив его горизонтально или вертикально (снизу верх или сверху вниз). Это очень удобно при работе с длинными заголовками столбцов.

Для установки вертикального расположения заголовков столбцов необходимо выделить ячейки, направление текста в которых предполагается изменить. Выбрать команду Формат –> Направление текста. На экране появится окно диалога Направление текста. Указать в разделе Ориентация требуемое расположение текста. При выборе новой опции текст в разделе Образец будет изменять свое направление. Установив требуемое расположение, нажать ОК.

В качестве альтернативного средства можно воспользоваться кнопкой Изменить направление текста панели инструментов Таблицы и границы.

Использование средства Автоформат

Рис. 4.38. Окно диалога Автоформат таблицы

Средство Автоформат позволяет значительно сократить время, требуемое для придания таблице профессионального вида, за счет использования предопределенных стилей оформления таблицы. С их помощью можно быстро установить обрамление и заливку ячеек, параметры шрифта и цветовое оформление, а также автоматическое изменение размеров ячеек в соответствии с их содержимым. Для этого необходимо выполнить следующие действия:

1. Установить курсор в пределах таблицы.

2. Выбрать команду Автоформат из меню Таблица или контекстного меню или нажать кнопку Автоформат таблицы, в результате чего на экране появится окно диалога Автоформат таблицы, показанное на рис. 4.38.

3. Из списка предопределенных форматов выбрать необходимый формат. Внешний вид выбранного формата отображается в разделе Образец.

4. Если необходимо изменить только один или несколько элементов оформления, сохранив при этом часть элементов оформления существующего формата, нужно снять соответствующие флажки в разделе Использовать (Границы, Шрифт, Автоподбор, Заливку, Цвет). При этом в разделе Образец будут отображаться изменения, вносимые в формат таблицы.

5. Для того чтобы применить автоформат только к части таблицы, указать в разделе Изменить оформление ту часть таблицы, формат которой предполагается изменить (Строк заголовка, Первого столбца, Последней строки, Последнего столбца). Нажать ОК.


Выбор рамки и заполнения

MS Word позволяет добавлять рамки к отдельным ячейкам, строкам, столбцам и целиком к таблице.

При установке заполнения выбранные параметры применяются к выделенным ячейкам. Если указатель расположен в пределах таблицы, в которой отсутствуют выделенные ячейки, установленное заполнение будет применено ко всей таблице.

Для добавления рамки ко всей таблице или ее отдельным ячейкам необходимо выполнить следующие действия:

1. Выбрать ячейки, которые нужно заключить в рамки (или целиком всю таблицу).

2. Выбрать команду Границы и заливка из меню Формат или контекстного меню таблицы. Перейти в окне диалога Границы и заливка на вкладку Границы.

3. Выбрать в списке Тип стиль и толщину линии.

4. Выбрать цвет линии в списке Цвет.

5. Выбрать тип рамки в разделе Тип. Нажать ОК.

Можно по своему усмотрению установить тип рамки, цвет и толщину линий, воспользовавшись опциями разделов Тип и Цвет вкладки Граница из меню Формат. Для этого необходимо выполнить следующие действия:

1. Выбрать тип и толщину линии из разделов Тип и Ширина.

2. Выбрать цвет линии из списка Цвет.

3. Выбрать линию или границу таблицы, к которой будет применен выбранный стиль и цвет линии, воспользовавшись возможностями, предоставляемыми разделом Тип. Для настройки границ таблицы и линий сетки достаточно после установки параметров линии просто нажать соответствующую кнопку или линию на образце таблицы.

4. Образец позволяет получить представление о внешнем виде таблицы после ее изменения. Если результаты проделанной работы не устраивают, выбрать Нет в разделе Тип и начать все сначала. Нажать кнопку ОК.

Преобразование таблицы в текст

MS Word позволяет преобразовать содержимое таблицы в абзацы обычного текста, разделенные запятыми, знаками табуляции, маркерами абзацев или другими символами-разделителями. Для этого необходимо выделить строки, которые предполагается преобразовать в текст, или всю таблицу. Выбрать команду Таблица –> Преобразовать в текст. На экране появится окно диалога Преобразовать в текст.

Выбор разделителей текста не ограничивается предопределенными символами, можно по своему усмотрению установить любой одиночный символ.

Преобразование текста в таблицу

При преобразовании текста в таблицу можно использовать текст, уже содержащий символы-разделители (запятые, знаки табуляции или маркеры абзаца), или добавить их перед выделением текста, который требуется преобразовать. Для преобразования существующего текста в таблицу выполнить следующие действия:

1. Если в исходном тексте отсутствуют символы-разделители, добавить их:

Символ-разделитель | Позволяет
Запятые или знаки табуляции | Отделить содержимое ячеек в одной строке
Маркеры абзаца | Пометить концы строк

2. Выделить текст, который предполагается преобразовать в таблицу.

3. Выбрать команду Таблица –> Преобразовать в таблицу, в результате чего на экране появится окно диалога Преобразовать в таблицу .

На основании выбранного текста MS Word предлагает создать таблицу с указанным числом столбцов и строк, а также автоматически устанавливает ширину столбцов и символ-разделитель, который используется при преобразовании выделенного текста в таблицу путем разделения тексте на столбцы. Можно признать предлагаемые установки или изменить их по своему усмотрению.

4. Ввести в соответствующем поле требуемое число столбцов или указать его с помощью кнопок, расположенных в правой части поля.

5. Ввести требуемое количество строк в соответствующем поле.

6. Если нужно изменить символ-разделитель, предложенный MS Word, необходимо выбрать требуемую опцию в разделе Разделитель и нажать кнопку ОК.


4.17. Шаблоны

Деятельность любого учреждения невозможна без канцелярской работы, которая всегда, даже при наличии компьютерной техники, существенно облегчающей канцелярский труд, сопровождается огромным количеством формуляров, справок, служебных записок и т. д. Все эти формы создаются по определенным правилам, имеют свои особенности. Создать любой документ просто, если имеется шаблон этой формы.

Понятие шаблона является одним из фундаментальных понятий MS Word. Итак, шаблон – это совокупность параметров документа, предназначенных для многократного использования.

Шаблоны и документы

По умолчанию все документы основаны на обычном шаблоне, который содержит определенный набор установок: стандартная настройка меню, клавиатуры панелей инструментов, стандартные встроенные стили. Шаблон Обычный является общим шаблоном, так как он лежит в основе не только любого документа, но и любого шаблона. Создав документ, внеся в него установки форматирования, элементы автоматизации, можно в дальнейшем сделать его шаблоном. Если созданный шаблон используется для какого-то определенного типа документов, то такой шаблон называется специальным.

Приступая к работе с шаблонами необходимо ознакомиться со всеми встроенными в MS Word шаблонами. Если среди множества шаблонов найдется сходный с требуемым документом, то внеся в него некоторые изменения и дополнения, можно получить новый шаблон.

Замена шаблона

Иногда большое значение имеет не содержимое документа, а его оформление. Для каждого типа документов существует специальный шаблон, позволяющий оформить его так, как того требует его назначение. Если изменить шаблон, то получится новый документ, хотя содержание может оставаться тем же.

Для замены шаблона необходимо выполнить следующее:

1. Выбрать команду Сервис –> Шаблоны и надстройки. Откроется окно диалога Шаблоны и надстройки.

2. Нажать кнопку Присоединить, откроется окно диалога Присоединение шаблона.

3. Выбрать нужную папку, а в папке – название требуемого шаблона. Нажать Открыть. Снова будет открыто окно диалога Шаблоны и надстройки.

4. Установить флажок Автоматически обновлять стили документа. Нажать ОК.

В активном документе используемые стили будут изменены на стили из присоединенного шаблона.

Перенос элементов одного шаблона в другой

Можно перенести нужные элементы из одного шаблона в другой. Причем, если эти элементы находятся в специальном шаблоне, то удобнее скопировать их в общий шаблон, например Обычный, чтобы можно было использовать их в других шаблонах, основанных на Обычном. Можно также сделать элементы, хранящиеся в другом шаблоне, временно доступными в любом документе, если загрузить шаблон в MS Word в качестве общего шаблона. Для этого надо выполнить следующие действия:

1. Выбрать команду Сервис –> Шаблоны и надстройки. Откроется одноименное окно диалога.

2. Нажать кнопку Организатор. Откроется окно диалога Организатор (рис. 4.39).

3. Перейти на вкладку, обеспечивающую доступ к элементам, которые нужно копировать.

В MS Word по умолчанию в окне всегда появляется активный документ и шаблон Обычный. Если требуются другие шаблоны, следует нажать кнопку Закрыть файл. При этом кнопка поменяет название на Открыть файл.

4. Нажать кнопку Открыть файл, на экране появится окно диалога Открытие документа.

5. Выбрать нужный документ или шаблон, из которого требуется скопировать необходимый элемент.

6. Выбрать из соответствующего списка нужные элементы для копирования, а затем нажать кнопку Копировать.

Если требуется скопировать ряд элементов, расположенных подряд, указать первый элемент списка, нажать клавишу Shift и, не отпуская ее, указать последний элемент.

Если элементы расположены в произвольном порядке, отметить их при нажатой клавише Ctrl.

7. По завершении процесса копирования нажать кнопку Закрыть.

Рис. 4.39. Окно диалога Организатор, вкладка Стили

Использование нескольких шаблонов одновременно

MS Word позволяет использовать несколько шаблонов одновременно. Такая необходимость может возникать, когда из одного шаблона надо позаимствовать, например, форматирование страницы, из другого – стили, из третьего – оперативные клавиши. В таких случаях можно скопировать нужные элементы из разных шаблонов через окно диалога Организатор. В качестве альтернативного способа можно подключить несколько шаблонов одновременно.

При использовании нескольких шаблонов с одинаковыми именами стилей могут возникнуть проблемы, связанные с совпадением имен. Поэтому при использовании нескольких шаблонов задача усложняется необходимостью скопировать шаблон и заменить совпадающие имена стилей.


Изменение шаблона

При работе с документом, построенным на основе какого-то шаблона, может возникнуть необходимость внести в шаблон изменения. Обычно это касается стилей и параметров форматирования страницы. При этом можно непосредственно видоизменять сам шаблон, а можно вносить изменения в документ, основанный на этом шаблоне, и затем сохранить внесенные изменения в шаблоне.

Внося изменения в шаблон, необходимо обязательно копировать его, с тем, чтобы исходный шаблон не был поврежден.

Можно внести изменения в шаблон через документ. Смысл этой процедуры сводится к изменению параметров форматирования документа, при этом также можно пользоваться окном диалога Организатор (рис. 4.37) для копирования стилей из других шаблонов. В заключение документ сохраняется в качестве шаблона.

Создание собственного шаблона

Процедура изменения шаблона через документ может расцениваться как создание шаблона, так как документ был изменен, на базе шаблона, и сохранен в качестве нового шаблона.

Условно можно предложить два способа создания шаблона:

  • изменить документ, созданный на основании какого-то шаблона, и сохранить его в качестве нового шаблона;
  • создать документ, основанный изначально на шаблоне Обычный, внести в него все возможные установки (элементы шаблона) и сохранить в качестве нового шаблона.

Последний способ чрезвычайно трудоемкий, но если среди имеющихся встроенных шаблонов нет ничего, что соответствовало бы определенным требованиям, предъявляемым к нужному документу, другого выхода нет.

Подробнее о работе с шаблонами можно ознакомиться в литературе, приведенной в Списке литературы данных методических указаний.

Тема

Новым средством оформления документа является Тема. Она определяет внешний вид документа с помощью цвета, шрифтов и графических объектов. С ее помощью можно быстро и грамотно создавать профессионально оформленные документы, используемые для электронной почты или Web. В состав этого средства входит набор унифицированных элементов и цветовых схем, предназначенный для создания фоновых рисунков, маркеров, шрифтов, горизонтальных линий и других элементов документа.

Для применения темы, ее изменения или удаления используется команда Формат –> Тема. Область просмотра темы (рис. 4.40) позволяет ознакомиться с образцами элементов оформления страницы перед тем, как применить тему. Для этого достаточно выбрать тему в списке и нажать ОК, и документ примет соответствующий вид. Кроме того, в окне диалога Тема можно задать более яркие цвета текста и рисунков, воспользоваться анимацией некоторых рисунков темы и определить фон документа с помощью флажков Живые цвета, Активная графика, Фоновый рисунок.

Из этого окна можно открыть окно диалога Библиотека стилей с помощью одноименной кнопки.

Рис. 4.40. Окно диалога Тема.

Библиотека стилей

MS Word содержит ряд шаблонов, каждый из которых представляет набор стилей для оформления документа. Для удобства использования стили, доступные во всех шаблонах, сведены в Библиотеку стилей, которая доступна через одноименное окно диалога. Библиотека стилей содержит образцы всех установленных шаблонов. Можно подобрать нужный шаблон с помощью просмотрового окна, наблюдая, как документ будет изменяться после применения того или иного шаблона (рис. 4.41).

Рис. 4.41. Окно диалога Библиотека стилей

В левой части окна диалога содержится список всех доступных шаблонов, среди которых можно выбрать наиболее приемлемый. Верхнее поле содержит имя выбранного шаблона. В нижем расположены три переключателя:

  • При установке переключателя Документ в правом окне будет открыт активный документ. Перебирая различные варианты шаблонов, в этом окне можно увидеть, как меняется документ при изменении шаблона.
  • При установке переключателя Пример в основном окне демонстрируется встроенный пример шаблона, если он предусмотрен.
  • Переключатель Образцы стилей действует аналогично переключателю Пример.

Подобрав соответствующий шаблон, следует нажать ОК, в результате чего в документ будут перенесены элементы формата выбранного шаблона.


4.18. Создание и редактирование графических изображений

В составных документах Word часто используется различного вида графика:

  • клипы – рисунки из коллекции, созданной производителями программного обеспечения;
  • графические объекты, хранящиеся в файлах и созданные специализированными средствами машинной графики;
  • графические объекты, созданные при помощи панели инструментов Рисование, которая появляется на экране после нажатия кнопки Рисование на панели Стандартная.

Вставка графических клипов

Доступ к коллекции клипов Microsoft осуществляется приложением Microsoft Clipart (Clip Gallery), входящим в состав Microsoft Office 2000 и поддерживающим не только рисунки, но и звуки, и видео. Microsoft Clipart предназначен не только для предварительного просмотра клипов и их вставки в документ, но и для управления ими: расширения галереи клипов, создания подборок клипов по темам и т.п.

Вход в Microsoft Clipart осуществляется командами Вставка –> Рисунок –> Картинки. Для вставки графического клипа нужно на вкладке Графика или Картинки (рис. 4.42) выбрать из коллекции требуемую картинку и нажать кнопку Вставить.

Рис. 4.42. Диалоговое окно Microsoft Clip Gallery 3.0 для вставки графических клипов

На вкладке Графика содержатся векторные объекты (изображения) различных типов. Векторный рисунок состоит из некоторого набора графических примитивов (элементарных объектов): окружностей, прямоугольников, замкнутых и незамкнутых кривых. Эти объекты создаются в таких программах, как Microsoft Draw, редакторе рисунков Word и пр. Коллекция клипов вкладки Графика может содержать файлы рисунков форматов .cgm, ,wmf, ,cdr, .eps, .drw, .wpg.

На вкладке Картинки содержатся растровые объекты (изображения).

Растровый графический объект формируется как матрица простейших элементов – пикселей. Каждый пиксель окрашивается в определенный цвет, а вся совокупность пикселей создает цельное изображение. Происхождение растрового рисунка может быть самым различным, в том числе и в результате оцифровки фотографий, с помощью таких программ, как Microsoft Paint, или путем сканирования изображения. Коллекция клипов вкладки Картинки может содержать файлы рисунков форматов .brnp, .tif, .gif, jpg, .pcd, .pcx.

Кнопка Параметры клипа (рис. 4.42) служит для получения сведений о формате файла для выбранного изображения. Кнопка Импортировать клипы служит для включения новых клипов в коллекцию. Кнопка Изменить служит для добавления, переименования или удаления раздела с клипами на этой вкладке.


Импорт графических объектов из файлов

Вставка графических объектов из файлов осуществляется по технологии OLE:

  • внедрение графических объектов;
  • связь с графическим объектом (файлом).

Импорт графических изображений осуществляется в двух вариантах:

  • в виде целого графического файла;
  • в виде части графического изображения, сохраненного как фрагмент в другом файле.

Для вставки графического файла используется команда Вставка –> Рисунок –> Из файла. В диалоговом окне Добавить файл выбирается формат (тип) графического файла, папка, имя файла. Для связывания с графическим файлом указывается переключатель Связать с файлом, что позволяет автоматически обновлять графическое изображение при изменениях в файле-источнике. Для обновления связи выполняется команда Правка –> Связи.

Редактирование рисунков осуществляется после его выделения командой Правка –> Изменить рисунок либо двойным щелчком левой кнопкой мыши на рисунке. Открывается окно Рисунок, которое содержит инструменты графического редактирования.

Рисунки векторного типа допускают поэлементное редактирование, для этого выделяются определенные элементы рисунка нажатием левой кнопки мыши и выполняется их графическая настройка (цвет, линия, размер, местоположение). Возможно добавление новых графических элементов, сдвиг всего рисунка за первоначально заданный контур, изменение размеров контура.

Создание графических объектов при помощи панели инструментов Рисование

Графические объекты в Word можно создавать и редактировать, используя инструменты панели Рисование (рис. 4.43). В результате будет создано векторное изображение, состоящее из элементарных графических фигур: квадратов, прямоугольников, многоугольников, линий, окружностей, эллипсов и пр.

Рис. 4.43. Инструменты панели Рисование

При установке указателя мыши на инструмент панели Рисование выводится название кнопки-инструмента рисования.

Кнопки геометрических фигур: линия, квадрат или прямоугольник, круг или эллипс, криволинейная замкнутая плоская фигура, рамки текста (надпись), набор автофигур обеспечивают построение основы геометрического рисунка.

Кнопки цветового оформления и стиля линии обеспечивают форматирование элементов рисунка.

Кнопки тени и объема дают возможность придать объекту тень и объем, а также изменить их настройки.

Рисованный объект имеет многослойную структуру, отдельные элементы рисунка могут располагаться определенным образом относительно других объектов. Управляет этим режимом кнопка Действия, которая вызывает меню с командами для работы с графическими объектами:

Группировать (Перегруппировать) – для группировки всех выделенных графических объектов в один объект. Эти команды следует вводить после того, как будет выделена группа объектов с помощью кнопки со стрелкой Выбор объектов;

Разгруппировать - разгруппировка выделенного графического объекта на составляющие;

Порядок – размещение графического объекта относительно текста (перед текстом, за текстом) или взаимное расположение графических объектов (на переднем плане, на заднем плане, разместить вперед, переместить назад);

Сетка – настройка шага смещения графического объекта по горизонтали и вертикали, которое может быть свободным или дискретным по узлам сетки;

Сдвиг – сдвиг рисунка вверх, вниз, влево, вправо;

Выровнять – координация выделенных объектов относительно друг друга или печатной страницы;

Повернуть/отразить – изменение ориентации графического объекта: поворот, вращение, зеркальное отображение;

Изменить автофигуру – замена другим видом автофигуры.

Операции редактирования рисунков (копирование, перемещение, удаление и т.п.) могут выполняться как над одним, так и над группой рисованных объектов.


Работа с рисунком

После вставки рисунка в документ его можно изменить:

  • увеличить или уменьшить размер;
  • подогнать рисунок под строго заданные размеры;
  • обрезать ненужную часть;
  • добавить обрамление к рисунку;
  • переместить и скопировать;
  • заключать рисунок в рамку или в текстовое окно и расположить в любом месте страницы.

Изменение размеров рисунков

После вставки рисунка в документ можно изменить его масштаб (увеличить или уменьшить размеры), вписать рисунок в строго заданные размеры, а также подрезать края рисунка. Для изменения размеров рисунка можно воспользоваться одним из следующих способов:

  • увеличить или уменьшить масштаб рисунка в процентном отношении (пропорционально или непропорционально);
  • точно задать высоту и ширину рисунка.

Первое из этих действий можно произвести как с помощью вкладок окна диалога Формат рисунка, так и с помощью мыши. Точно установить размер рисунка можно только с помощью окна диалога Формат рисунка.

Чтобы изменить размеры рисунка с помощью мыши, необходимо его выделить, установить указатель мыши на один из маркеров так, чтобы он принял форму двусторонней стрелки и нажав клавишу мыши, переместить маркер в новое положение. После достижения рисунком требуемых размеров отпустить кнопку мыши.

Для установки точных размеров рисунка необходимо выделить рисунок и воспользоваться командой Формат –> Рисунок, вкладка Размер (рис. 44).

Рис. 4.44. Окно диалога Формат рисунка, вкладка Размер

Если при изменении размеров изображение получается непропорциональным, то для установки этого размера необходимо снять флажок Сохраняя пропорции.

Перемещение и копирование рисунков

Перемещение и копирование рисунков выполняется с помощью мыши или клавиатуры. Эти операции во многом аналогичны перемещению и копированию текста.

Панель Настройка изображения

Для работы с изображением в MS Word предусмотрена специальная панель Настройка изображения (рис.4.45).

Рис. 4.45. Панель Настройка изображения

В нее включены основные средства, необходимые для обработки изображения. Ниже приведены назначения кнопок панели Настройка изображения. Панель предоставляет практически все нужные средства для обработки изображения.

Кнопки | Название | Назначение
 | Вставить рисунок | Открывает окно диалога Добавить рисунок
 | Изображение | Меняет интенсивность окраски изображения, содержит меню из четырех опций: Авто, Оттенки серого, Черно\белое, Подложка
 | Увеличить контрастность | Позволяет увеличить контрастность изображения
 | Уменьшить контрастность | Позволяет уменьшить контрастность изображения
 | Увеличить яркость | Увеличивает яркость
 | Уменьшить яркость | Уменьшает яркость
 | Обрезка | Позволяет выполнить обрезку
 | Тип линии | Позволяет выбрать тип и толщину линии для обрамления рисунка
 | Обтекание текстом | Создает обтекание текстом
 | Формат объекта | Открывает окно диалога Формат объекта
 | Прозрачность | Обесцвечивает изображение
 | Сброс параметров рисунка | Восстанавливает исходные параметры рисунка


Вставка оъектов WordArt

Вставка объектов WordArt

Для создания художественных графических надписей, например заголовков, текстовый процессор Microsoft Word 2000 имеет специальное программное средство WordArt. Доступ к нему осуществляется двумя способами: либо через панель инструментов WordArt (Вид –> Панели инструментов –> WordArt), либо с помощью кнопки Добавить объект WordArt на панели инструментов Рисование.

Графические объекты, вставленные в текстовый документ средством WordArt, могут распечатываться вместе с документом на выводном печатающем устройстве, могут отображаться в составе электронного документа, распространяемого в формате Microsoft Word, и могут отображаться на Web-страницах.

Чтобы вставить объект WordArt в документ, выполните следующие действия:

1. Создать документ на базе шаблона Обычный.

2. Ввести текст документа.

3. Командой Вид –> Панели инструментов –> WordArt включить отображение панели инструментов WordArt.

4. Щелкнуть на кнопке Добавить объект WordArt – произойдет запуск Мастера создания объекта WordArt.

5. В окне Коллекция WordArt выбрать желаемый стиль оформления.

6. В диалоговом окне Изменение текста WordArt выбрать желаемый размер, начертание и ввести текст создаваемого заголовка.

7. После щелчка на кнопке ОК произойдет вставка созданного объекта в документ.

Дальнейшее управление формой и расположением созданного объекта осуществляют элементами управления панели инструментов WordArt. Для того, чтобы внести изменения в объект, достаточно дважды щелкнуть по нему мышкой, после чего активизируется панель инструментов WordArt.


Ввод формул

Необходимость в наличии средства для ввода математических выражений в текстовый документ характерна для научно-технической документации. В программе Microsoft Word таким средством является редактор формул Microsoft Equation 3.0. Он позволяет создавать формульные объекты и вставлять их в текстовый документ. При необходимости вставленный объект можно редактировать непосредственно в поле документа.

Запуск и настройка редактора формул

Для запуска редактора формул служит команда Вставка –> Объект. В открывшемся диалоговом окне Вставка объекта следует выбрать пункт Microsoft Equation 3.0 – откроется панель управления Формула, представленная на рис. 4.46. При этом строка меню текстового процессора замещается строкой меню редактора формул (рис. 4.47).

Прежде чем пользоваться редактором формул, следует выполнить его настройку. Настройка состоит в назначении шрифтов для различных элементов, входящих в формулы. Она выполняется в диалоговом окне Стили, открываемом командой Стиль –> Определить.

Рис. 4.46. Окно панели управления Формула.

Эта настройка является обязательной — без нее редактор формул работать не будет, но выполнить ее достаточно только один раз.

Рис. 4.47. Измененное меню текстового редактора

Панель инструментов редактора формул содержит два ряда кнопок. Кнопки нижнего ряда создают своеобразные шаблоны, содержащие поля для ввода символов. Так, например, для ввода обыкновенной дроби следует выбрать соответствующий шаблон, имеющий два поля: числитель и знаменатель. Заполнение этих полей может производиться как с клавиатуры, так и с помощью элементов управления верхней строки. Переходы между полями выполняются с помощью клавиш управления курсором.

Ввод и редактирование формул завершается нажатием клавиши ESC или закрытием панели редактора формул. Можно также щелкнуть левой кнопкой мыши где-либо в поле документа вне области ввода формулы. Введенная формула автоматически вставляется в текст в качестве объекта. Далее ее можно переместить в любое иное место документа через буфер обмена (CTRL+X – вырезать; CTRL+V – вставить). Для редактирования формулы непосредственно в документе достаточно выполнить на ней двойной щелчок. При этом автоматически открывается окно редактора формул.

Особенности редактора формул:

1. Редактор формул Microsoft Equation 3.0 представляет собой отдельный компонент, поэтому при установке текстового процессора требуется специально указать необходимость его подключения.

2. При работе с редактором формул следует стремиться к максимальной полноте вводимых выражений. Так, например, выражение (формула) может содержать компоненты, ввод которых возможен и без использования редактора формул, но для удобства работы и простоты дальнейшего редактирования следует вводить всю формулу целиком в редакторе формул, не используя иные средства.

3. При вводе формул и выражений не рекомендуется использовать символы русского алфавита. В тех случаях, когда они необходимы, например, в качестве описательных индексов переменных, им следует назначать стиль Текст.

4. В редакторе формул не работает клавиша ПРОБЕЛ, поскольку необходимые интервалы между символами создаются автоматически. Однако если необходимость ввода пробелов все-таки возникнет, то их можно вводить с помощью кнопки Пробелы и многоточия панели инструментов Формула. Всего предусмотрено пять разновидностей пробелов различной ширины.


4.20. Предварительный просмотр и печать документов

Печать документов была и остается одной из наиболее важных функций текстовых редакторов.

MS Word позволяет напечатать требуемый документ одним нажатием кнопки на панели инструментов. Однако возможности MS Word, предоставляемые при печати документов, гораздо шире. С его помощью можно:

  • осуществить предварительный просмотр одной или нескольких страниц документа;
  • напечатать более одной копии документа;
  • напечатать отдельные страницы документа;
  • напечатать черновую копию без графики (для ускорения печати);
  • вывести документ в файл, который впоследствии может быть напечатан без MS Word.

Предварительный просмотр перед печатью

Перед выводом документа на печать целесообразно просмотреть, как он будет выглядеть на бумаге. Это сэкономит время и расходные материалы.

Для просмотра документа можно пользоваться любым из четырех режимов: обычным, разметки страницы, структуры документа и предварительного просмотра перед печатью. Режим предварительного просмотра предоставляет для работы панель Предварительный просмотр со специальными средствами (рис. 4.48).

Рис. 4.48. Панель инструментов режима Предварительный просмотр

В режиме предварительного просмотра можно выполнить следующие действия при помощи соответствующей панели инструментов:

  • Печатать документ в соответствии с опциями, установленными в окне диалога Печать.
  • Осуществлять переключение между режимами увеличение/уменьшение (курсор мыши имеет форму увеличительного стекла) и редактирования (стандартная форма курсора).
  • Осуществлять просмотр одиночных страниц документа.
  • Осуществлять просмотр нескольких страниц документа одновременно.
  • Изменить масштаб отображения документа на экране.
  • Отобразить/спрятать горизонтальную и вертикальную линейки
  • Сжать документ. Целесообразно использовать в том случае, если последняя страница содержит небольшой объем текста.
  • Максимально увеличить область, предназначенную для просмотра документа за счет удаления с экрана панелей и других элементов.
  • Осуществить выход из режима предварительного просмотра

Чтобы вывести документ на экран в режиме предварительного просмотра, необходимо выполнить следующие действия:

1. Открыть документ, который нужно просмотреть.

2. Выполнить команду Файл –> Предварительный просмотр или нажать кнопку Предварительный просмотр на стандартной панели инструментов.

3. Просмотреть одновременно несколько страниц документа на экране. Для этого нажать кнопку Несколько страниц на панели инструментов Предварительный просмотр.

4. Чтобы вернуться к просмотру отдельных страниц документа, нажать кнопку Одна страница.

Находясь в режиме предварительного просмотра, можно осуществить печать документа. Для этого надо нажать кнопку Печать на панели инструментов Предварительный просмотр.

Для завершения работы в окне предварительного просмотра нажать кнопку Закрыть.


Печать документа

Как правило, после завершения работы документ отправляется на печать. MS Word предоставляет возможность печатать текущий документ, а также не открывая документ и даже не открывая сам редактор.

Печать текущего документа

1. Открыть требуемый документ.

2. Выполнить команду Файл –> Печать или нажать комбинацию клавиш Ctrl+Shift+F12. На экране появится окно диалога Печать (рис. 4.49).

3. Нажать кнопку ОК.

В этом случае распечатываются все страницы от начала до конца документа в одном экземпляре с параметрами печати, принятыми по умолчанию или установленными в окне диалога Печать для предыдущего сеанса печати. В качестве альтернативного способа печати открытого документа можно нажать кнопку Печать стандартной панели инструментов.

Окно диалога Печать предоставляет пользователю возможность осуществлять различные варианты печати документа:

  • Печать нескольких копий – в поле Число копий раздела Копии указать требуемое число копий документа. По умолчанию в разделе Копии установлен флажок Разобрать по копиям, в результате чего вначале будут напечатаны все страницы первого экземпляра, затем второго и т. д.
  • Печать части документа – печать части документа можно осуществить двумя путями: указать в окне диалога Печать номера отдельных страниц (или диапазон страниц) или выделить требуемые страницы перед открытием окна диалога Печать. Кроме того, может быть напечатана только текущая страница документа.
  • Печать четных (или нечетных) страниц – для этого в раскрывающемся списке Вывести на печать выбрать Нечетные страницы (Четные страницы).
  • Печать дополнительной информации о документе – по умолчанию при выводе на печать MS Word печатает сам документ. Раскрывающийся список Напечатать в окне диалога Печать позволяет вместо документа напечатать информацию о документе.

Рис. 4.49. Окно диалога Печать.

Дополнительные опции печати

MS Word при печати документов предоставляет еще некоторые средства. Это относится к опциям окна диалога Параметры в окне диалога Печать.

  • Черновая печать – в режиме черновой печати вывод документа осуществляется с максимальной для данного принтера скоростью. При этом качество документа существенно зависит от принтера, на который выводится документ. Документ будет распечатан равноширинным шрифтом с игнорированием всех элементов форматирования символов. Графика также не выводится на принтер.
  • Печать страниц в обратном порядке – некоторые принтеры упорядочивают страницы документа так, что наверху оказывается последняя страница. В таких случаях целесообразно изменить порядок печати на обратный. Для этого в разделе Режим вкладки Параметры установить флажок В обратном порядке.
  • Обновление полей – если документ содержит коды полей, которые не обновляются автоматически, необходимо установить в разделе Режим флажок Обновлять поля. При отсутствии полей в документе устанавливать этот флажок не имеет смысла.
  • Обновление связей – перед печатью может потребоваться обновить связи с объектами OLE. Для этого в разделе Режим устанавливается флажок Обновлять связи. При отсутствии в документе объектов OLE устанавливать этот флажок не имеет смысла.
  • Фоновая печать – во время печати документа в фоновом режиме можно продолжать работу в MS Word. Для включения фонового режима печати устанавливается флажок Фоновая печать.
  • Печать только данных для форм –.эта опция имеет смысл, когда сами формы уже напечатаны заранее, и нужно только впечатать данные. Для этого устанавливается Печатать только данные для форм.

Печать неоткрытых документов

Готовый отредактированный документ можно напечатать, не прибегая к помощи MS Word. Это можно сделать с помощью Проводника.

Печатать документа с помощью Проводника

1. Открыть Проводник.

2. Выбрать требуемый файл (или файлы).

3. Установить указатель мыши на один из выделенных файлов и нажать правую кнопку мыши. Из контекстного меню выбрать опцию Печать, в результате чего указанные документы будут распечатаны на принтере, установленном по умолчанию с текущими параметрами.

Аналогично можно распечатать документ из MS Word, не открывая его. Для этих целей используется окно диалога Открытие документа.

Печать в файл

Иногда возникает необходимость напечатать документ в файл, чтобы затем распечатать его на другом компьютере. Для этого необходимо выполнить следующее:

1. Выполнить команду Файл –> Печать. На экране появится окно диалога Печать.

2. Установить флажок Печать в файл. Выполнить требуемые установки в окне Печать и нажать кнопку ОК. Откроется окно диалога Печать в файл.

3. В поле Имя файла ввести имя файла. Выбрать диск и папку, в которые предполагается поместить файл печати. Нажать ОК.

При печати в файл на исходном компьютере должен быть установлен драйвер того принтера, на котором предполагается распечатывать документ. В противном случае могут возникнуть проблемы при печати.


4.23. Глоссарий

Microsoft Equation 3.0 – объект Word для ввода математических формул.

WordArt – объект Word для создания фигурного текста.

OLE (Object Linking and Embedding) – технология связывания и внедрения объектов; стандарт компании Microsoft для создания динамических, автоматически обновляемых связей между документами или внедрения объекта, созданного в одном из приложений, в документ, с которым работает другое приложение.

Абзац – последовательность строк, сгруппированных для смыслового выделения содержания.

Буквица – это увеличенная в размере первая буква первой строки текста, использующаяся как для оформления текста, так и для подчеркивания начала текста или раздела.

Вертикальная полоса прокрутки – элемент окна Word, предназначенный для перемещения по документу вверх или вниз.

Горизонтальная линейка – элемент окна Word, используемый для установки отступов и табуляции.

Горизонтальная полосы прокрутки – элемент окна Word, предназначенный для перемещения по документу влево или вправо.

Документ, т.е. объект обработки текстового процессора Word, – это файл с произвольным именем и расширением doc.

Курсор – мигающая вертикальная черта, указывающая место в документе, где появляется набираемый на клавиатуре текст.

Колонтитул – часть страницы, на которой размещен постоянный текст, несущий справочную информацию.

Многоколоночная верстка – расположение текста в несколько колонок.

Набор – это ввод текста с клавиатуры на экран.

Панели инструментов – средство для быстрого выполнения команд и процедур.

Редактирование – это ввод изменений, исправлений и дополнений в документ.

Стилевое оформление – это назначение специальных стилей символам или абзацам.

Стиль – характерный вид, разновидность чего-либо, выражающаяся в каких-нибудь особенных признаках, свойствах художественного оформления.

Текст – последовательность слов, построенных по правилам языка.

Текстовый процессор – программа для ввода, редактирования и форматирования текстовых данных.

Текстовый редактор – программа для ввода и редактирования текстовых данных.

Форматирование – представление текстового документа или отдельных его объектов в заданной форме.

Форматирование шрифта – изменение параметров введенных символов.

Форматирование абзаца – задание или изменение его параметров.

Шаблон – это совокупность параметров документа, предназначенных для многократного использования.


4.24. Библиографический список

1. Волков Ю.А. Microsoft Office 2000 Professional. 6 книг в одной. – М.: Лаборатория Базовых Знаний, 2001 – 944 с.

2. Симонович С.В. Информатика. Базовый курс – СПб.: Питер, 1999. – 640 с.

3. Информатика. 10-11 класс /Под ред. Н.В. Макаровой. – СПб.: Питер, 2000. – 304 с.

4. Стоцкий Ю. Самоучитель Office-2000. – СПб.: Питер, 1999. – 576 с.


4.21. Основные принципы практической работы с текстовым процессором Microsoft Word

Основные принципы практической работы связаны с номером версии программы. Базовый принцип здесь состоит в том, что чем больше возможностей имеет программа, тем строже надо подходить к выбору тех функций, которыми можно пользоваться в каждом конкретном случае. При этом возникает ряд вопросов, которые надо решить до начала работы с документом.

К какому типу относится документ? Современные текстовые процессоры позволяют создавать документы трех типов.

Во-первых, это печатные документы, которые создаются и распечатываются на одном рабочем месте или в одной рабочей группе. Дальнейшее движение документа происходит только в бумажной форме.

Второй тип — электронные документы, в формате текстового процессора, например Microsoft Word. Такие документы передаются заказчику в виде файлов. Электронный документ, как правило, не является окончательным. В большинстве случаев заказчик может его дорабатывать, редактировать, форматировать, распечатывать или использовать его компоненты для подготовки своих документов (книг, журналов, сборников статей и т. п.). Набор разрешенных средств в данном случае, как правило, минимален и определяется заказчиком.

Третий тип — Web-документы. Предполагается, что в этом качестве они останутся навсегда, и их преобразование в печатные документы не планируется. В Web-документах большую роль играет управление цветом. Для этой категории документов наиболее широк выбор средств форматирования и оформления.

Если требования заказчика еще не известны, то нежелательны большинство средств форматирования документов, передаваемых для дальнейшей обработки. В частности, необходимо:

  • ограничить используемые наборы шрифтов;
  • минимизировать использование средств форматирования абзацев;
  • отключить все автоматические средства форматирования: расстановку колонтитулов, нумерацию страниц, маркировку и нумерацию списков и прочие;
  • не использовать встроенные средства текстового процессора для создания встроенных объектов (художественные заголовки, векторные рисунки, рамки и прочие) — все объекты должны создаваться специальными программами, храниться в отдельных файлах, вставляться в текст документа методом связывания и прилагаться к файлу документа;
  • в каждом случае отступления от этих правил, например при необходимости использовать формулы, таблицы и специальные символы, согласовывать свои действия с заказчиком.


Задание 1

Включает: Набор текста с использованием правил ввода специальных знаков.

Глава для повторения: 4.6. Создание и сохранение документов в MS Word

1. Создать документ: меню ФАЙЛ->СОЗДАТЬ или соответствующая кнопка на Панели инструментов.

2. Набрать приведенный ниже текст, применяя следующие правила:

  • клавишу ENTER нажимать только в конце абзаца;
  • пробелы использовать только для разделения слов;
  • перед знаком препинания пробел не ставить;
  • после знака препинания обязательно ставить пробел.

3. Сохранить документ под именем Задание_1 в отведенной для работы папке (ФАЙЛ->СОХРАНИТЬ или соответствующая кнопка на Стандартной панели, в открывшемся окне в поле Адрес выбрать отведенную для работы папку, а в поле Имя набрать наименование документа, нажать кнопку Сохранить).

Текст для набора:

Как-нибудь, хард-рок, конь-огонь, юго-восток, северо-запад, Переяславль-Залесский, Комсомольск-на-Амуре, Пале-Рояль, Нью-Орлеан. Пришлось волей-неволей остаться здесь на ночь. В лесу этом зверя всякого видимо-невидимо. Ночевала тучка золотая на груди утеса-великана. Мне было скучно, бесконечно жаль чего-то. Семь бед - один ответ. Волка бояться - в лес не ходить. Грамоте учиться - всегда пригодится. Москва – огромный город, город-страна. Самая северная точка нашей Родины – мыс Флигели на Земле Франца-Иосифа. Собирая ягоды, люди не обирают весь куст – оставляют кое-что для птиц. Н.А. Римский-Корсаков написал оперы «Псковитянка», «Садко», «Снегурочка».


Задание 2

Включает: Создание документа. Набор текста. Поиск текста. Вставку и удаление текста. Выделение и форматирование текста. Сохранение документа.

Главы для повторения:
4.8.Основные приемы редактирования ,
4.9. Специальные средства редактирования

1. Создать документ: меню ФАЙЛ->СОЗДАТЬ или соответствующая кнопка на Панели инструментов.

2. Набрать текст «Определение цели в поиске работы», представленный ниже, без форматирования символов и абзацев, применяя следующие правила:

  • клавиша ENTER нажимать только в конце абзаца;
  • пробелы использовать только для разделения слов;
  • перед знаком препинания пробел не ставить;
  • после знака препинания обязательно ставить пробел.

3. Используя меню ПРАВКА->ЗАМЕНИТЬ, заменить:

  • слово «везение» на слово «удачу»,
  • «ошибки в выборе» в третьем абзаце на «неудачный выбор»,
  • слова в четвертом абзаце «с нелепым, но привычным порядком» на «с нелюбимым делом».

4. В последнем абзаце удалить слова «все равно как-то эта ситуация разрешится» (поставить курсор перед этими словами, выделить удаляемый текст и нажать на клавиатуре клавишу DELETE).

5. Перед последним предложением четвертого абзаца вставить новое предложение «Инерция и иждивенческие настроения мешают нашим соотечественникам воспринимать это как естественный порядок вещей, возможность лучше узнать свои способности.». В режиме вставки (надпись «ЗАМ» в статусной строке должна быть неактивна) поставить курсор в нужное место текста и набрать предложенный текст.

6. Сохранить документ под именем Задание_2 в отведенной папке (ФАЙЛ->СОХРАНИТЬ или соответствующие кнопки на Стандартной панели, в открывшемся окне в поле Адрес выбрать отведенную для работы папку, а в поле Имя набрать наименование документа, нажать кнопку Сохранить.)

7. Выполнить, где необходимо, подчеркивание и выделение текста полужирным шрифтом и курсивом (меню ФОРМАТ->ШРИФТ или соответствующие кнопки на панели Форматирования).

8. Отформатировать абзацы: выровнять текст по ширине, сделать интервал между абзацами в 6 пт (меню ФОРМАТ->АБЗАЦ->Интервал->После - 6пт )

9. Вновь сохранить документ.


Задание 3

Включает: Создание документа. Набор текста. Выделение и форматирование шрифта и текста. Установку параметров страницы. Сохранение документа.

Главы для повторения:
4.10. Форматирование символов
4.11. Форматирование строк и абзацев
4.15. Форматирование страниц документа

1. Создать документ и назвать его Задание_3, сохранить документ в отведенной папке.

2. Установить параметры страницы (меню ФАЙЛ->ПАРАМЕТРЫ СТРАНИЦЫ, вкладка ПОЛЯ 2см-2см-3см-1,5см).

3. Набрать текст «В ЛУННУЮ НОЧЬ», приведенный ниже, без форматирования.

4. Отформатировать шрифт в тексте.

5. Отформатировать абзацы, установить левое выравнивание абзаца, Последний абзац сделать с полным выравниванием по ширине. Стихотворные абзацы выполнить с отступом слева – 3см, справа – 3 см.

6. Выполнить заливку и обрамление текста (меню ФОРМАТ->ГРАНИЦЫ И ЗАЛИВКА, вкладки ГРАНИЦА, ЗАЛИВКА) как в образце.

7. Установить в последнем абзаце полуторный междустрочный интервал.

8. Вновь сохранить документ.


Задание 4

Включает: Создание и сохранение документа. Ввод текста. Передвижение по тексту с помощью клавиатуры и мыши. Способы выделения текста. Форматирование шрифта и текста.

Главы для повторения:
4.8.Основные приемы редактирования ,
4.11. Форматирование строк и абзацев

1. Создать документ Задание_4.

2. Набрать текст стихотворения «Зимним вечером в Ялте» по предложенному формату.

3. Отформатировать абзацы, установить необходимый абзацный отступ (1-я строфа – 2 см слева, 2-я – 3 см слева, 3-я – 4 см слева).

4. Вставить буквицу (ФОРМАТ->БУКВИЦА), выделить и отформатировать текст, как на образце.

5. Вновь сохранить документ.


Задание 5

Включает: Создание и сохранение документа. Ввод текста. Установка параметров страницы. Форматирование шрифта и текста. Создание оглавления.

Главы для повторения:
4.13. Использование стилей для форматирования документа

1. Создать новый документ и назвать его Задание_5.

2. Задать параметры страницы 2-2-4-4, шрифт 14пт, Times New Roman.

3. Набрать приведенный ниже текст «ВЗГЛЯД НА АВСТРАЛИЮ», соблюдая абзацы и заголовки.

4. Проверить орфографию и грамматику.

5. Задать автоматическую расстановку переносов (меню СЕРВИС->ЯЗЫК->РАССТАНОВКА ПЕРЕНОСОВ), установив необходимые параметры.

6. Отформатировать абзацы – интервал между абзацами 6 пт.

7. Заголовки определить специальным стилем Заголовок1,2,… (ФОРМАТ->СТИЛЬ или специальные кнопки на панели Форматирования)

8. Сформировать оглавление (ВСТАВКА->ОГЛАВЛЕНИЯ И УКАЗАТЕЛИ вкладка ОГЛАВЛЕНИЕ), выбрав стиль оглавления Изысканный и установив необходимые параметры.


Задание 6

Включает: Основные способы форматирования документа. Разделение текста на колонки. Заливку текста.

Главы для повторения:
4.9. Специальные средства редактирования
4.11. Форматирование строк и абзацев
4.15. Форматирование страниц документа

1. Набрать приведенный ниже текст, используя шрифт Times New Roman, размер 14 пт.

2. Выполнить, где необходимо, курсив, подчеркивание и выделение текста.

3. Отформатировать абзацы: 1-й и 4-й, выполнив выравнивание абзацев по ширине, 2-й и 5-й – выравнивание по левому краю.

4. Выполнить разделение текста на колонки (ФОРМАТ->КОЛОНКИ или соответствующая кнопка на панели Форматирования)

5. Выделить многоколоночный текст и задать автоматическую расстановку переносов (меню СЕРВИС->ЯЗЫК->РАССТАНОВКА ПЕРЕНОСОВ->ПРИНУДИТЕЛЬНО)

6. Выполнить заливку колонок, во втором случае поставить разделитель колонок

7. Сохранить текст в своей папке под именем Задание_6.


Задание 7

Включает: Основные способы форматирования документа.

1. Набрать приведенный ниже документ, чтобы он отображал заданное расположение текста, шрифт Times New Roman, размер 14 пт.

2. Задать параметры страницы 2 – 2 – 2,5 – 1,5

3. Выполнить, где необходимо, курсив, подчеркивание и выделение текста, использовать, где необходимо, более крупный шрифт.

4. Вставить сноску в третьем абзаце [1] Аристотель. Сочинения: В 4 т. Т.4. – М.: Мысль. 1983. – С.155. (ВСТАВКА->СНОСКА, обычная)

5. Отформатировать абзацы, выполнив выравнивание абзаца по ширине, интервал после каждого абзаца 6 пт.

6. Выполнить заливку и обрамление 3-го абзаца.

7. В последнем абзаце установить полуторный междустрочный интервал

8. Сохранить текст в своей папке под именем Задание_7.


Задание 8

Включает: Набор текста. Центрирование. Изменение шрифтов. Использование курсива. Перемещение абзаца. Создание маркированного и нумерованного списков. Проверку орфографии.

Главы для повторения:
4.9. Специальные средства редактирования ,
4.12. Списки

1. Набрать следующий документ так, чтобы он отображал заданное расположение текста, шрифт Times New Roman, размер 14 пт.

2. Задать параметры страницы 2 - 2 - 3 - 1,5.

3. Выполнить, где необходимо, курсив, подчеркивание и выделение текста и более крупный шрифт.

4. Отформатировать абзацы, выполнив выравнивание абзацев по ширине, интервал после каждого абзаца 6 пт.

5. В маркированном и нумерованном списках выполнить выравнивание абзацев по левому краю.

6. Переместить пункт 6 нумерованного списка так, чтобы он стал 3-м.

7. Сохранить текст в своей папке под именем Задание_8.


Задание 9

Включает: Набор текста. Форматирование текста. Формирование нумерованных и маркированных списков. Вставку колонтитулов.

Главы для повторения:
4.8.Основные приемы редактирования ,
4.15. Форматирование страниц документа

1. Набрать текст Задание_9.

2. Задать параметры страницы 2-2-2-2.

3. Отформатировать текст.

4. Сформировать списки (меню ФОРМАТ->СПИСОК).

5. Вставить верхний колонтитул с датой, номером страницы, фамилией, (меню ВИД->КОЛОНТИТУЛЫ).

6. Сохранить файл в своей папке с именем Задание_9 и закрыть документ.

7. Открыть документ с именем Задание_9.

8. Сохранить документ в этой же папке с именем МОЕ_РЕЗЮМЕ (ФАЙЛ->СОХРАНИТЬ КАК…- в поле Имя файла набрать МОЕ_РЕЗЮМЕ- нажать кнопку СОХРАНИТЬ)

9. На основании этого документа набрать резюме со своими данными, удалив ненужный текст.

10. Отформатировать вновь набранный документ, сохранить его.

11. Напечатать в одном экземпляре (ФАЙЛ->ПЕЧАТЬ или кнопка на панели инструментов)


Задание 10

Включает: Набор текста. Форматирование текста. Формирование многоуровневого списка.

Главы для повторения: 4.12. Списки

1. Набрать представленный ниже документ, используя шрифт Times New Roman, размер 14 пт.

2. Задать параметры страницы 2-2-3-1,5

3. Отформатировать текст в виде многоуровневого списка (выделить текст, войти в меню ФОРМАТ->СПИСОК вкладка Многоуровневый выбрать нужный список).

4. Для установки необходимого уровня списка на панели Форматирования использовать кнопки Уменьшить (Увеличить) отступ.

5. Отформатировать абзацы, выполнив выравнивание абзаца по левому краю, интервал после каждого абзаца 2 пт.

6. Сохранить текст в своей папке под именем Задание_10.


Задание 11

Включает: Вставку таблицы. Ввод текста в таблицу. Форматирование таблицы. Вставку колонтитула.

Главы для повторения:
4.15. Форматирование страниц документа ,
4.16. Работа с таблицами

1. Создать новый документ.

2. Вставить таблицу из двух столбцов и нескольких строк (меню ТАБЛИЦА–>ДОБАВИТЬ–>ТАБЛИЦА).

3. Ввести в таблицу текст, отформатировать текст как на образце. Чтобы добавить недостающую строку в таблицу, необходимо поставить курсор в нижний правый угол и нажать клавишу Tab.

4. Для форматирования таблицы применить меню ТАБЛИЦА–>АВТОФОРМАТ –> выбрать нужный формат.

5. Задать режим повторения заголовка таблицы на следующих страницах (выделить строки, содержащие заголовок, и войти в меню ТАБЛИЦА->ЗАГОЛОВОК)

6. Вставить нижний колонтитул с наименованием учебной группы и фамилии студента.

7. Сохранить документ в своей папке с именем Задание_11.


Задание 12

Включает: Вставку таблицы. Ввод текста в таблицу. Форматирование таблицы. Вставку колонтитула.

Главы для повторения:
4.15. Форматирование страниц документа ,
4.16. Работа с таблицами .

1. Создать новый документ.

2. Вставить таблицу (меню ТАБЛИЦА–>НАРИСОВАТЬ ТАБЛИЦУ)

3. Ввести в таблицу текст, отформатировать текст как на образце.

4. В первом столбце выполнить вертикальную ориентацию текста.

5. Вставить верхний колонтитул с наименованием учебной группы и фамилии студента.

6. Задать режим повторения заголовка таблицы на следующих страницах (выделить строки, содержащие заголовок, и войти в меню ТАБЛИЦА–>ЗАГОЛОВОК)

7. Для форматирования таблицы применить меню ТАБЛИЦА–>АВТОФОРМАТ –> выбрать нужный формат

8. Сохранить документ в своей папке Задание_12.


Задание 13

Включает: Вставку рисованных объектов. Добавление объектам объема, тени, заливки, изменение типа и толщины линий.

Главы для повторения:
4.18. Создание и редактирование графических изображений ,
4.19. Рисование

1. Создать новый документ.

2. Используя панель инструментов Рисование, вставить элементарные рисованные фигуры (Автофигуры и кнопки основной панели Рисование).

3. Добавить, где необходимо, тень, соответствующую настройку тени, объем (панель Рисование).

4. Добавить текст (щелкнуть по нарисованному Вами объекту правой кнопкой мыши и выбрать в контекстном меню пункт Добавить текст, в появившуюся на объекте рамку вписать предлагаемый текст).

5. Выполнить настройку толщины и цвета линий и заливку рисованных объектов (панель Рисование).

6. Выделить (удерживая клавишу SHIFT, щелкнуть по каждому объекту, или кнопка Выбор объектов на панели инструментов Рисование) и сгруппировать рисованные объекты (панель Рисование->Действия->Группировать).

7. В соответствии с приведенным в задании образцом переместить объекты на передний или на задний план (панель Рисование->Действия->Порядок->….).

8. Добавить, где необходимо, свободное вращение (кнопка Свободное вращение на панели Рисование).

9. Сохранить документы с именем Задание_13.


Задание 14

Включает: Вставку объектов WordArt. Изменение в объектах тени, заливки, толщины линий, формы и т.д.

Главы для повторения: 4.19. Рисование

1. Создать новый документ.

2. На панели инструментов Рисование выбрать кнопку Добавить объект WordArt.

3. В открывшемся окне согласно образцу выбрать форму объекта WordArt и набрать текст

4. С помощью инструментальной панели WordArt, которая открывается после щелчка по объекту, изменить во вставленных объектах заливку, толщину линии, настройку тени, размеры и т.д.


Задание 15

Включает: Вставку объектов Microsoft Equation 3.0 (редактор формул).

Главы для повторения: 4.19. Рисование

Для запуска редактора формул служит команда Вставка->Объект.

В открывшемся окне выбрать пункт Microsoft Equation 3.0 – откроется панель управления Формула. При этом меню текстового процессора замещается строкой меню редактора формул. При работе в редакторе формул необходимо помнить некоторые правила:

  • заполнение полей может производиться как с клавиатуры, так и с помощью элементов управления верхней строки панели управления Формула;
  • переходы между полями выполняются с помощью клавиш управления курсором;
  • ввод и редактирование формул завершается нажатием клавиши ESC, закрытием панели редактора формул или щелчком левой клавиши мыши в поле документа вне области ввода формулы;
  • для удобства работы и простоты дальнейшего редактирования следует вводить всю формулу целиком только в редакторе формул, не используя иные средства;
  • в редакторе формул не работает клавиша ПРОБЕЛ, поскольку необходимые интервалы между символами создаются автоматически. Однако если необходимость ввода пробелов возникает, их можно вводить с помощью кнопки Пробел и многоточия панели инструментов Формула.

1. Создать новый документ

2. Набрать текст в обычном режиме работы редактора.

3. Загрузить редактор формул

4. Используя кнопки панели управления Формула и меню редактора формул, выполнить следующее задание.

5. Размер введенных формул отрегулировать как вставленный в текст рисунок.

6. Сохранить задание в отведенной папке с именем Задание_15.


4.22. Контрольные вопросы

  1. Как создать новый документ?
  2. Как можно сохранить один и тот же документ под разными именами?
  3. Что понимается под параметрами страницы?
  4. Как установить параметры страницы?
  5. Как задать функцию автопереноса?
  6. В каком случае при вводе текста надо нажимать клавишу Enter?
  7. Как ставятся пробелы около знаков препинания?
  8. Что понимается под термином "редактирование текста"?
  9. Какие основные способы редактирования предлагает Word?
  10. Как установить режим автоматической проверки орфографии при вводе?
  11. Как удалить фрагмент текста?
  12. Как переместить фрагмент текста?
  13. Что такое формат текста?
  14. Как можно изменить параметры шрифта?
  15. Какие параметры абзаца Вы можете назвать?
  16. Как выполнить форматирование абзаца?
  17. Какие виды списков Вы знаете?
  18. Как оформить текст в виде многоуровневого списка?
  19. Что такое стиль? Как создать стиль? Как изменить стиль?
  20. Может ли заголовок находится в конце страницы?
  21. Как текст оформить в стиле заголовка?
  22. Что такое колонтитул? Как вставить колонтитул в документ?
  23. Какие существуют способы вставки в документ таблицы?
  24. Как изменить ширину столбца и высоту строки?
  25. Как выполнить объединение (разбиение) ячеек таблицы?
  26. Как можно добавить столбец (строку) в таблицу?
  27. Какие изображения можно вставить в документ?
  28. Можно ли выполнить рисунок непосредственно в среде Word?
  29. Как изменить размеры рисунка с помощью мыши?
  30. Как изменить атрибуты рисунка и способ обтекания текстом?
  31. Как оформить многоколоночный текст?
  32. Что такое буквица? Как оформить буквицу?
  33. Какие функции выполняет объект WordArt?
  34. С помощью какого объекта можно вставить формулу в документ?
  35. Для чего служит режим предварительного просмотра?
  36. Какая команда используется для распечатки документа?
  37. Какие установки можно выполнить в диалоговом окне Печать?
  38. Как распечатать несколько копий документа?


Зачетное задание