Интерфейсы RS-232, RS-422, RS-423, RS-485

Данная группа интерфейсов построена на основе интерфейса RS-232. Данный интерфейс предназначен для подключения аппаратуры, передающей или принимающей данные, к оконечной аппаратуре каналов данных . В роли принимающей/передающей аппаратуры может выступать компьютер, принтер и другое периферийное оборудование. В роли оконечной аппаратуры обычно выступает модем. Конечной целью подключения является соединение двух устройств . Интерфейс позволяет исключить канал удаленной связи вместе с парой принимающих/передающих устройств , соединив устройства непосредственно с помощью нуль-модемного кабеля.
Стандарт описывает управляющие сигналы интерфейса, пересылку данных, электрический интерфейс и типы разъемов. В стандарте предусмотрены асинхронный и синхронный режимы обмена, но СОМ-порты поддерживают только асинхронный режим.
RS-232 | RS-422 |  | RS-423 |  | RS-485
L = 15 м V = 20 Кбит/с | L = 12 м L = 120 м L = 1200 м | V = 10 Мбит/с V = 1 Мбит/с V = 100 Кбит/c | L = 9 м L = 91 м L = 1200 м | V = 100 Кбит/с V = 10 Кбит/с V = 1 Кбит/c | L = 12 м L = 120 м L = 1200 м | V = 10 Мбит/с V = 1 Мбит/с V = 100 Кбит/c

На физическом уровне последовательный интерфейс имеет различные реализации, различающиеся способом передачи электрических сигналов. Существует ряд родственных между собой стандартов: RS-232, RS-423, RS-422, RS-485. Выше приведены схемы соединения приемников и передатчиков, а также показаны ограничения на длину линии (L) и максимальную скорость передачи данных (V). Несимметричные линии интерфейсов RS-232 и RS-423 имеют самую низкую защищенность от синфазной помехи, хотя дифференциальный вход приемника RS-423 несколько смягчает ситуацию. Лучшие параметры имеет двухточечный интерфейс RS-422 и его магистральный (шинный) аналог RS-485, работающие на симметричных линиях связи. В них для передачи каждого сигнала используется дифференциальные сигналы с отдельной витой парой проводов.