Untitled Document

Абреввиатура English Значение

2

3

4

4U

AAMOF

ADN

AFAIK

AFAIR

AFK

AKA

AMF

AS

ASAP

ATM

ATSL

BBIAF

BBIAH

BBIAM

BBIAS

BBS

BCNU

BNF

BTW

CU

CUL/CUL8R

CYA

DL

DIIK

EMFBI

FAQ

FITB

FROPPED

FUBAR

FWIW

FYBITS

FYI

GIWIST

HHTYAY

IANAL

IC

IMCO

IMHO

IMNSHO

IMO

IOW

IRL

ITSFWI

JK

JSNM

KHYF

L8R

LAB&TYD

LOL

LTNS

LTNT

MHO

MYOB

NBFD

NTYMI

OIC

OOTQ

OTOH

OTTOMH

PFM

PMJI

POV

RE

RL

ROFL

ROTF

ROTFL

RSN

RTFM

SNAFU

SOW

SYSOP

TANJ

TANSTAAFL

TANSTASQ

TFTHAOT

TNX

TOBAL

TOBG

TPTB

TTBOMK

TTFN

TTUL(TTYL)

UL

w/

w/o

WB

WRT

WTF

WYSIWYG

YGLT

YKYARW

Too

Free

For

For You

As A Matter Of Fact

Any Day Now

As Far As I Now

As Far As I Remember

Away From Keyboard

Also Known As

Adios Muthafukka

On Another Subject

As Soon As possible

At The Moment

Along The Same Line

Be Back In A Few

Be Back In An Hour

Be Back In An Minute

Be Back In A Second

Be back Soon

Be Sening You

Big Name Fan

By The Way

See You

See You Later

Cover You Ass

Download

Domned If I Know

Excuse me for butting in

Frequently Asked Questions

Fill In The Blank

F..king dROPPED

Fouled Up Beyond All Repair

For What its Worths

F.You? Buddy? I'm The Sysop

For Your Information

Gee I Wish I'd Said That

Happy Holidays to You and Yours

I Am Not A Lawyer

I See

In My Considered Opinion

In My Humble Opinion

In My Not So Humble Opinion

In My Opinion

In other Words

In Real Life

If The Shoe Fits? Wear It

Just Kidding

Just Stark Naked Magic

Know How You Feel

Later

Life's A Bitch & Then You Die

Laughing out Loud

Long Time No Seee

Long Time No Typ

My Humble Opinion

Mind Your Own Business

No Big F...king Deal

Now That You Mention It

Oh, I See...

Out Of The Question

On The Other Hand

Off The top Of My Head

Pure F...king Magic

Pardon My Jumping In

Point Of View

Returned

Real Life

Rolling On The Floor Laughing

Rolling On The Floor

Rolling On The Floor Laughing

Real Soon Now

Read The Fine/F.ing Manual

Situation Normal, All Fouled Up

Spesking Of Which

System Operator

There Ain't No Justice

There Ain't No Such Thing As A Free Lunch

There Ain't No Such Thing As A Stupid Question

Thanks For The Help Ahead Of Time

Thanks

There Oughta Be A Law

There Oughta Be Good

The Powers That Be

To the Best Of My Knowledge

Ta Ta For Now

Talk To You Later

Upload

With

Witout

Welcome Back

With Respect To

What The F..k

What You See Is What You Get

You're Gonna Loves This

You Know You're A Redneck When

Тоже

Свободный

Для

Для тебя

Как факт

Теперь в любое время

Насколько мне известно

Насколоко я помню

Я далеко от компа...

Так же известный как

Прощай с...ин сын

По другому вопросу

Как только так сразу

Сейчас

В той же строке

Вернусь через несколько минут

Вернусь через час

Вернусь через минуту

Вернусь через секунду

Скоро вернусь

Еще увидимся

Большой фанат

Между прочим

Увидимся

Увидимся позже

Прикрой свою задницу

Скачивать информацию

Будь я проклят, если знаю!

Простите, что вмешиваюсь

Часто задаваемые вопросы

Заполни пробелы

Выброшено на...

Полностью испорчено

Нафига козе баян?

Отвали, крошка, я тут главный

К твоему сведению

Боже, это должен был сказать я !

С праздником тебя и твоих

Я не юрист

Дошло!

По моему взвешенному мнению

По моему скромному мнению

По моему нескромному мнению

По моему мнению

Другими словами

В реальной жизни

Куй железо, пока горячо!

Я просто шучу

Простое голое волшебство

Понимаю твои чувства

Позже

Весь мир бардак

Ржание до резей в животе

Сколько лет, сколько зим!

Столько времени ни строчки

Мое скромное мнение

Не суй свой нос куда не просят

Не стоящее занятие

Теперь к вашему вопросу

Понятно!

Нет вопросов, разумеется

С другой стороны

Мне это не по зубам

Чистое волшебство

Простите что вмешиваюсь

Точка зрения

Я вернулся

Реальная жизнь

Кататься по полу от смеха

Катаясь по полу

Катаясь по полу от смеха

Теперь по-настоящему скоро

Читай документацию

Дела как сажа бела

Говоря о котором

Системный оператор

Нет здесь

Халявы здесь не предвидится

Здесь чайникам не место

Заранее благодарен

Спасибо

Этому бы быть законом

Это хорошо

Силы которые есть

На пределе моих знаний

Не надо ля-ля

Поговорим позже

Закачивать информацию

С...

Без

С возвращеньицем

В отношении

Что за черт!

Что видишь - то и получишь

Тебе понравиться

Ты же знаешь, это тебя бесит


Толковый словарь компьютерной лексики

АБЗАЦ (paragraph)
 1.Часть текста, ограниченная двумя отступами. 2. В текстовых редакторах – часть документа, между двумя соседними маркерами конца А. в текстовом редакторе Word эти маркеры автоматически вносятся в текст при нажатии клавиши (перевод строки) и видимы при нажатии кнопки «непечатаемые символы». Каждому А. можно придать свой формат, отличный от формата соседних абзацев.
АБОНЕНТ СЕТИ (network abonent, user node)
 1. Пользователь имеющий доступ к ресурсам сети ЭВМ или к компьютерной связи. 2. Терминал, компьютер или рабочая станция, подключенные к вычислительной сети или сети компьютерной связи.
АБСОЛЮТНЫЙ АДРЕС, физический адрес (absolute address, physical address)
 1. Адрес в виде цифрового кода, однозначно идентифицирующий реально существующие в вычислительной системе байт, ячейку памяти или устройство. А.а. непосредственно интерпретируется аппаратными средствами или микропрограммами центрального процессора вычислительной системы. А.а. либо указывается как неизменяемый адрес в машинной команде, либо вычисляется, исходя из логического адреса, и не может быть далее уточнен программными средствами. Ср. логический адрес. 2. Цифровой код, однозначно определяющий положение данных на носители данных. Например, для магнитного диска А.а. представляет код, состоящий из номера поверхности, номера дорожки и номера сектора.
АВМ (analog computer)
 То же, что аналоговая вычислительная машина
АВТОМАТИЗИРОВАННАЯ СИСТЕМА (automatized system)
 Система программных и аппаратных средств, предназначенных для автоматизации процесса деятельности человека. В отличии от автоматической системы А.с. всегда функционирует при участии человека. И человек является ее главным звеном.
АВТОНОМНАЯ ПРОГРАММА (autonomy device stand-alone program)
 Программа, не зависящая от других программ в составе данной программной системы. Например, программа в виде загрузочного модуля, имеющая свои собственные средства инициализации и не требующая для своего выполнения управляющих действий операционной системы.
АДА (Ada)
 Универсальный язык программирования высокого уровня, ориентированный на разработку программного обеспечения ЭВМ, встроенных в системы автоматизированного управления. Назван в честь Августы Ады Лавлейс, считающейся первым в мире программистом. Первая версия А., разработанная в США под руководством Дж. Ишбиа, появилась в 1980 г. последняя версия Ада-95 – в 1995 г. А. обладает средствами программирования процессов, протекающих параллельно в реальном времени. Программы на языке А. имеют модульную структуру, допус-кающую раздельную компиляцию модулей. Кроме того, в стандарте языка А., помимо собствен-ного языка программирования, впервые была определена и его поддерживающая среда програм-мирования, т.е. средства разработки, корректировки и модернизации программ. Все это позволяет создавать на языке А. очень большие программные проекты, например программное обеспечение системы астронавигации.
АДАПТЕР (adapter)
 Электронная схема, позволяющая приспособить друг к другу устройства с различными способами представления данных. Например, аналоговое устройство нельзя напрямую соединить с цифровым устройством: для этого аналоговый сигнал должен быть сначала преобразован в цифровой или наоборот. Чтобы связать два несовместимых компонента аппарат-ных средств, требуется устройство сопряжения, важной составляющей которого и является А. Обычно А. монтируется на отдельной плате.
АДАПТЕР ДИСПЛЕЯ, видеоадаптер, видеокарта (display adapter, video-adapter, videocard)
 Адаптер, согласующий обмен графической информацией между центральным процессором и дисплеем. А.д. преобразует данные, поступающие в ЭВМ в цифровой форме, в соответствующее изображение на экране.
АДРЕС (address)
 1. Номер, код или идентификатор места в памяти ЭВМ, где хранится или куда должна быть записана данная информация. Например, номер байта оперативной памяти или номер дорожки магнитного диска, имя внешнего устройства или узла сети. Различают логические и физические А. Логический А. указывается в машинной программе. При загрузке, а также при переадресации он преобразуется в зависимости от места, занимаемого программой и данными в оперативной памяти, в физический А., закрепленный в вычислительной системе за реально существующим запоминающим устройством или его частью. Это преобразование выполняется со-ответствующим программным обеспечением и аппаратными средствами. 2. Часть команды, оп-ределяющая местоположение операнда. 3. Часть сообщения, указывающая адресат.
АДРЕСАТ (target)
 ). Обладатель адреса (лицо, программа, устройство или компьютер), которому предназначается сообщение, команда или данные. Например, А. считается и почтовый ящик, в который приходит сообщение по электронной почте, и пользователь – владелец этого ящика. Также А. является дисковод, на который послал команду центральный процессор и программа, для которой с диска считываются данные.
АДРЕС IP (IP-address)
 1. Уникальный адрес, идентифицирующий узлы или компьютеры в сети, управляемой протоколами ТСР/IP. В сети, представляющей собой объединение нескольких подсетей, указывает информацию маршрутизации. А. IP представляет собой 32-разрядное значение, которое идентифицирует данный компьютер. Каждый байт А. IP представляется десятичным числом и отделяется от других десятичной точкой. 2. То же, что Интернет-адрес
АДРЕСНАЯ ССЫЛКА (address reference)
 Ссылка в форме адреса
АКТИВНОЕ ОКНО (active window)
 Окно, с которым в настоящий момент работает или может работать пользователь. На нем активизированы элементы управления, через него возможен ввод данных. При одновременном отображении на экране нескольких окон А.о. не перекрывается другими окнами и выделяется контрастным цветом рамки или заголовка, наличием мерцающего курсора и т.п. Чтобы сделать окно активным, как правило, достаточно навести на него указатель мыши и нажать левую кнопку.
АЛГОРИТМ (algorithm)
 Содержание и последовательность операций, точно определяющие решение задачи путем вычислительного процесса, преобразующего исходные данные в конечный результат. Характеристиками алгоритма являются: 1) однозначность результата при заданных исходных данных; 2) возможность расчленения процесса на конечное число отдельных операций, каждая из которых может быть выполнена человеком или вычислительной машиной; 3) способность получения результата для множества исходных данных, соответствующих множеству од-нотипных задач. Например, один из А. вычисления с помощью ЭВМ среднего арифметического трех чисел представляет собой следующую последовательность операций: ввод с клавиатуры в ЭВМ трех чисел; вычисление суммы введенных чисел; деление полученной суммы на 3; вывод результата на экран дисплея. В приведенном примере для записи А. был применен русский язык. Существует специально созданные алгоритмические языки. Вычислительной машине А. задается в виде программы. Могут существовать несколько А. решения одной и той же задачи. Среди них следует выбирать наиболее эффективный, для вычислительной реализации которого требуется наименьшее количество операций, машинного времени, памяти и т.п. Изучение существования и способов построения (разработки) эффективных А. составляет основу теории алгоритмов.
АНИМАЦИЯ (animation)
 Создание иллюзии движения объекта на экране дисплея. В основе А. лежит быстрая смена последовательно смещаемых относительно друг друга образов. Существует несколько способов А., реализуемых в различных системах программирования. При одном способе на экране быстро рисуются и стираются последовательные фазы движения. При другом эти фазы заранее рисуются в виде полноэкранных кадров и запоминаются в памяти компьютера, чтобы затем последовательно отобразиться на экране. В развитых системах применяются средства А., для которых достаточно задать изображение объекта и его начальное и конечное положение. Качество А. зависит от скорости смены кадров. Чем выше скорость, тем плавнее движение. Современные компьютеры позволяют выполнять до 30 смен кадров в секунду.
АНТИВИРУСНАЯ ПРОГРАММА (antivirus program)
 Обслуживающая программа, предназначенная для поиска, диагностики, профилактики и «лечения» файлов, зараженных компьютерным вирусом. В процессе поиска и диагностики определяются зараженные файлы и тип вируса. Профилактика позволяет предотвратить заражение. Например, резидентная А.п. предотвращает несанкционированное пользователем изменение файлов операционной системы, запись в сектор начальной загрузки и т.п. Лечение подразумевает удаление вируса, восстановление поврежденных файлов и т.п.
АППАРАТНЫЕ СРЕДСТВА, технические средства (hardware)
 Электрические, электронные и механические системы, блоки, приборы и устройства, составляющие материальную часть вычислительной системы. А.с. являются, например и сам и микросхемы, его составляющие. К А.с. также относятся дисплей, дисковод, принтер и проч.
АППАРАТНЫЙ БЛОК, блок (hardware block, block)
 Конструктивно оформленная как единое целое совокупность взаимосвязанных устройств, либо совокупность взаимосвязанных элементов или узлов одного устройства, выполняющих определенную функцию. Например, блок питания, обеспечивающий компьютер электроэнергией с заданными показателями, или системный блок, объединяющий основные устройства персонального компьютера.
АППЛЕТ, аплет (applet)
 Небольшая прикладная программа. Термин А. получил распространение в последнее время в связи с технологиями Всемирной паутины WWW, позволяющей внедрять А. в документы Web с целью построения интерактивных страниц Web. Для создания таких А. обычно применяется язык программирования Java, поэтому часто их называют апплетами Java
АРХИВ (archive)
 Совокупность образовавшихся в результате деятельности пользователя вычислительной системы рабочих материалов и средств их долговременного хранения. Рабочими материалами являются копии документов, редко используемых программ, данных и т.п. В качестве средств долговременного хранения удобно использовать магнитные ленты и магнитные диски. В целях экономии памяти архивные файлы предварительно сжимают с помощью архиватора. Правильно организованный А. оберегает пользователя от потерь при любых аварийных ситуациях в компьютере.
АРХИВАТОР (archivator)
 Программа или комплекс программ, выполняющие сжатие (архивирование) файлов для более компактного длительного хранения во внешней памяти и восстановление сжатых файлов в первоначальном виде (разархивирование). В персональных IBM-совместимых компьютерах наиболее распространены в последнее время А. pkzip.exe/pkunzip.exe, arj.exe, rar.exe и winzip.exe. Все они предоставляют возможность более компактного хранения файлов на дисках и позволяют: 1) упаковывать все, отдельные или соответствующие какому-либо шаблону файлы рабочего каталога в архивный файл; 2) добавлять файлы в архивный файл; 3) удалять файлы из архивного файла; 4) просматривать содержимое архивного файла; 5) извлекать из архивного файла или распаковывать все файлы архива; 6) создавать самораспаковывающиеся архивные файлы.
АТРИБУТ (attribute)
 1. Признак или свойство, характеризующие объект. Например, атрибутами выводимых на экран символов являются шрифт, цвет, размер и т.п. 2. В реляционных базах данных – имя одного и того же поля всех кортежей одной таблицы.
АУДИОВИЗУАЛЬНЫЙ (audiovisual)
 Определение, относящееся к данным, которые содержат изображения и его звуковое сопровождение, или к аппаратуре, воспроизводящей такие данные.
БАЗА ДАННЫХ (БД) (БД) (database(DB)
 Один или несколько специальным образом организованных файлов, хранящих систематизированную информацию, для доступа к которой используются программные средства системы управления базой данных (СУБД). Б.д. представляет собой хранилище связанных между собой данных, не зависящих от программ, которые к ним обращаются. Например, в Б.д. предприятия хранятся конструкционные, технологические, производственные, эксплуатационные, экономические и т.п. характеристики изделий предприятия и их аналогов, выпускаемых конкурирующими фирмами. Такой Б.д. могут пользоваться специалисты из отдела маркетинга (для прогноза конкурентоспособности изделий на рынке), плановики (для определе-ния необходимых объемов выпуска продукции), конструкторы (для анализа конструктивных осо-бенностей изделий конкурентов) и т.д. Б.д. должна быть достаточно полной, правильно органи-зованной, всегда соответствовать текущему моменту времени и удобной для использования. Со-держащиеся в ней данные не должны противоречить друг другу . Редактирование, пополнение и исключение данных, их поиск и сортировка осуществляются под управлением СУБД. Б.д. могут быть персональными и коллективного пользования. Сопровождение крупных Б.д. коллективного пользования осуществляет администратор базы данных.
БАЙТ (Б) (byte)
 1. Фрагмент двоичного кода, состоящий из 8 соседних двоичных цифр. 2. Единица измерения количества информации, равная количеству информации, которое содержится в 8 двоичных разрядах. 3. В вычислительной технике байт представляет собой объединение из 8 соседних двоичных разрядов, которыми компьютер может оперировать как одним целым. Так в персональных IBM-совместимых компьютерах каждый байт оперативной памяти имеет свой ад-рес и предназначен для хранения одной буквы, специального символа или двух десятичных или шестнадцатеричных цифр. 1 байт = 8 бит.
БЕГУНОК, движок, ползун (scroll box)
 Небольшой прямоугольник на линейке прокрутки, который используется для скроллинга. Двигая с помощью мыши Б. По линейке прокрутки можно перемещаться по документу. Положение Б. На линейке прокрутки показывает относительное положение в документе отображаемой в окне информации.
БЕЙСИК (Basic, beginner's all-purpose symbolic instruction code)
 Язык программирования, предназначенный для решения математических и экономических задач. Разработан в середине 1960-х годов. Напоминая упрощенную версию Фортрана, Б. Обладает развитыми средствами диалога, а также средствами отладки и редактирования программ. Простота синтаксиса, обеспечивающая сравнительно легкое и быстрое освоение, а также относительная универсальность сделали Б. И его последующие модификации QBASIC и Quick Basic широко распространенными языками программирования персональных компьютеров. Появление системы программирования Visual Basic, работающей в среде Windows, позволяет даже начинающим программистам разрабатывать программные изделия малой и средней сложности, ориентированные на работу в среде Windows.
БИТ (bit)
 1. Один разряд двоичного кода. 2. Единица измерения количества информации, равная количеству информации, которое содержится в одном двоичном разряде или в ответе на вопрос, допускающий ответы «да» либо «нет» и никакого другого.
БЛОК ПАМЯТИ (memory block, storage block)
 Непрерывная область памяти, которой может быть присвоен ключ для ее идентификации или защиты. Выделяемая программе память состоит из одного или нескольких Б.п. размер Б.п. может быть разным. БОД (baud). Единица измерения скорости передачи информации, определяемая числом симво-лов, передаваемых в секунду. Для каналов, передающих информацию в двоичном коде 1 бод = 1 бит/сек.
БРАУЗЕР, броузер (browser)
 Браузер Internet Web-браузер. Программа чтения гипертекста. Браузеры Web помимо чтения гипертекста могут обладать следующими дополнительными возможностями: 1) воспроизводить звук и видеоданные (движущиеся изображения), т.е. воспроизводить гипермедиа; 2) устанавливать соединения с другими компьютерами сети и посылать работающим на них серверам запросы на документы Web; 3) организовывать и поддерживать диалог с другими пользователями сети. Наиболее распространенные Web-браузеры для операционных систем Windows-Microsoft Internet Explorer и Netscape Navigator. Они поддерживают все возможности гипермедиа и устанавливают связь, а Netscape Communicator также позволяет редактировать документы и запускать доступные программы. В различных браузерах один и тот же документ может выглядеть по-разному. Это зависит от характеристик конкретного браузера и от ус-тановленных пользователем настроек.
БУФЕР (buffer)
 1. То же, что буферная память. 2. Электронная схема или устройство, помещаемые между двумя устройствами для согласования различий в их рабочих характеристиках.
БУФЕРНАЯ ПАМЯТЬ, буфер (buffer memory, buffer)
 Память для промежуточного хранения данных. Применяется при обмене данными между двумя устройствами, обладающими различной скоростью обработки информации, чтобы работа «тихоходного» устройства не снижала их общую производительность. Характерным примером применения Б.п. является выдача данных программой на принтер. Так как скорость передачи данных от программы к принтеру неизмеримо выше, чем скорость работы принтера, то чтобы не замедлять работу программы на время выдачи данных, программа помещает данные в Б.п. и продолжает свою работу, а принтер «самостоятельно» извлекает их со своей скоростью и печатает, не требуя прерывания работы программы. Многие внешние устройства имеют собственную Б.п., кроме того, в качестве Б.п. может служить специально выделяемая операцион-ной системой область оперативной памяти
БУФЕР ОБМЕНА (clipboard)
 Средство операционной системы Windows, предназначенное для обмена данными между приложениями. Б.о. позволяет вырезать или скопировать выделенные данные в специальное место, отведенное для временного хранения данных, а затем вставить эти данные из буфера в другое место. В Б.о. вместе сданными хранится информация об их типе и формате, поэтому вставка данных из буфера может производиться различными способами, в зависимости от типа данных и возможностей приложения, в документ которого вставляются данные.
БЫСТРОДЕЙСТВИЕ (performance, speed)
 Характеристика скорости работы устройства. Например, Б. Процессора характеризуется числом элементарных операций, выполняемых в секунду, или тактовой частотой, Б. Принтера – числом знаков, печатаемых в секунду.
ВВОД-ВЫВОД (input-output)
 Общий термин, определяющий процесс обмена данными между оперативной памятью и внешними устройствами
ВЕКТОРНАЯ ГРАФИКА (vector graphics)
 Метод создания изображения в виде совокупности линий. Каждая линия рисунка представляется отрезками прямых (векторами) и сопрягающимися с ними отрезками стандартных геометрических кривых. Для определения формы и расположения отрезка используются математические описания. В.г. применяется в программах рисования, которые работают с рисунком как с совокупностью форм, а не как с группой точек. Рисунки, выполненные методами В.г. более компактны при хранении, допускают точное масштабирование и не зависят от разрешающей способности графических устройств.
ВЕРТИКАЛЬНОЕ МЕНЮ (vertical menu)
 Меню с вертикальным расположением пунктов меню (один под другим). На экране дисплея такое меню перекрывает выведенную ранее информацию.
ВЕРХНИЙ КОЛОНТИТУЛ (header running head)
 Колонтитул, расположенный в верхней части страницы, выше основного текста.
ВЕТВЬ АЛГОРИТМА [algorithm branch]
 Одна из альтернативных последовательностей действий алгоритма, выбор которой зависит от некоторых условий. На блок-схеме – один из альтернативных путей, исходящих из точки ветвления. В программе В.а. соответствует ветвь программы.
ВЕТВЬ ПРОГРАММЫ (program branch)
 1. Участок программы, которому может быть передано управление при ветвлении программы. 2. Участок программы, который может выполняться параллельно с другими участками. На блок-схеме В.п. изображается одним из альтернативных путей, исходящих из точки ветвления.
ВИДЕОКАРТА (videocard)
 То же, что адаптер дисплея.
ВИНЧЕСТЕР (winchester)
 То же, что винчестерский диск.
ВИНЧЕСТЕРСКИЙ ДИСК, винчестер, жесткий диск (winchester disk, hard disk)
 Постоянно закрепленный в дисководе жесткий магнитный диск или пакет дисков, заключенный вместе с головками записи-чтения в герметически закрытый корпус, заполненный очищенным от пыли обычным воздухом под атмосферным давлением. При вращении диска над ним создается «воздушная подушка», обеспечивающая зависание головок над поверхность диска на высоте порядка нескольких микрон. Такая конструкция позволила существенно уменьшить величину и массу головок, толщину магнитного покрытия диска и при этом значительно увеличить плотность записи, а следовательно и емкость дисков. Конструкция разработана в 1973 году в филиале IВМ в г. Винчестер (Великобритания). В.д. широко применяется в персональных компьютерах для записи, долговременного хранения и быстрого чтения больших объемов информации. Емкость В.д. персональных IВМ-совместимых компьютеров может достигать нескольких гигабайт при времени записи-считывания одного бита, измеряемом в долях наносекунд.
ВИРТУАЛЬНЫЙ ДИСК (virtual address)
 То же, что электронный диск.
ВИРУС (virus)
 То же, что компьютерный вирус
ВИСЯЧАЯ СТРОКА (orphan, widow)
 Нарушение правила верстки страниц, согласно которому при переносе абзаца с одной страницы на другую, на странице должно присутствовать не менее определенного числа строк данного абзаца (обычно, не менее двух строк). Таким образом, возможны два случая В.с.: при переносе абзаца на первой странице остается только одна строка («сирота» - orphan) или на следующую страницу переносится только одна строка (“вдова” – widow). Современные текстовые процессоры, например Word, позволяют автоматически отследить выполнение этого правила и не допустить появления В.с.
ВКЛЮЧЕНИЕ ФАЙЛА (file inclusion)
 Осуществляемое препоцессором включение содержимого указанного файла в заданное место исходного текста программы. Таким образом в программу вносится необходимая информация, содержащаяся в других файлах
ВНЕШНЕЕ ЗАПОМИНАЮЩЕЕ УСТРОЙСТВО (ВЗУ) (backing storage external storage)
 Запоминающее устройство, не относящееся к оперативной памяти. Набор ВЗУ реализует внеш-нюю память вычислительной системы, доступ к данным которой осуществляется средствами ввода-вывода. Внешняя память предназначена для длительного хранения информации, поэтому носители данных, применяемые в ВЗУ, не являются энергозависимыми – при выключении ком-пьютера данные на них сохраняются. Существуют ВЗУ на магнитных дисках, магнитных лентах
ВНЕШНЕЕ УСТРОЙСТВО (external device)
 Устройство компьютера, не относящееся к центральному процессору и оперативной памяти, или периферийное устройство вычислительной системы. В.у. обычно являются устройства ввода-вывода: терминалы, дисководы, стримеры, принтеры, плоттеры, сканеры, дигитайзеры и т.п. Часто одним и тем же В.у. могут пользоваться несколько ЭВМ.
ВНЕШНЯЯ ПАМЯТЬ (backing storage, external memory)
 Память, к содержимому которой можно обратиться только при помощи операций ввода-вывода. В.п. реализуется набором внешних запоминающих устройств вычислительной системы. К данным, хранящимся во В.п., центральный процессор непосредственно обращаться на может. Для этого они должны быть предварительно считаны в оперативную память.
ВРЕМЕННОЙ ФАЙЛ, рабочий файл (temporary file (temp file))
 Файл, создаваемый операционной системой или прикладной программой на время ее работы. В.ф. создается в оперативной памяти или на диске и по завершении работы программы уничтожается.
ВСЕМИРНАЯ ПАУТИНА (World Wide Web (WWW))
 Гипертекстовая система поиска ресурсов в Интернет и доступа к ним. В.п. представляет набор услуг Интернет, позволяющий просмотреть любые данные, хранящиеся в компьютерах этой сети, через систему связывающих их гиперссылок. Основу аппаратного обеспечения В.п. составляет множество объединенных в Интернет компьютеров, расположенных по всему миру. Информационную основу В.п. составляет множество хранящихся в памяти этих компьютеров и содержащих гипертекст документов, называемых документами Web. К документах Web пользователь может, указав на выделенное слово или фразу, переходить к документам или получать доступ к файлам, хранящимся в памяти компьютеров в разных точках Земного шара. Поэтому пользователь воспринимает В.п. как Всемирную виртуальную информационную паутину. Поскольку в.п. использует компьютеры Интернет и ее стандартные протоколы для передачи файлов и документов, термин “В.п.” часто относят как к Всемирной сети компьютеров, так и собственно к информации.
ВСПЛЫВАЮЩЕЕ МЕНЮ (pop-up menu)
 Меню, появляющееся на экране дисплея в текущем положении курсора и исчезающее после выбора пункта меню. На экране дисплея такое меню перекрывает выведенную ранее информацию.
ВСТАВКА (paste)
 В приложениях операционной системы Windows – копирование содержимого буфера обмена в документ. При этом содержимое буфера обмена сохраняется и может быть вставлено произвольное количество раз. В зависимости от типа данных, находящихся в буфере обмена, и возможностей приложения, вставка может быть выполнена различными способами.
ВХОД В ПРОГРАММУ (program entry)
 Оператор или команда, которым передается управление при запуске программы или вызове подпрограммы.
ВХОД В СИСТЕМУ, регистрация (login, logon)
 Процедура, обеспечивающая доступ к вычислительной системе зарегистрированных пользователей. Например, начало работы с системой начинается с сообщения ей имени и пароля. Обычно В.в с. предваряет начало сеанса работы пользователя за одним из удаленных терминалов или рабочих станций локальной сети.
ВЫБОРКА (fetching)
 Машинная операция, с помощью которой осуществляется чтение команд или данных из оперативной памяти ЭВМ в регистры устройства управления или арифметико-логического устройства.
ВЫВОД ДАННЫХ, вывод (data output, output)
 Процесс передачи данных из основной памяти ЭВМ на экран дисплея, бумагу или другой подобный носитель, а так же на внешние запоминающие устройства. Выведенные из ЭВМ результаты обработки данных могут быть предназначены для последующего анализа человеком, и поэтому представляются в удобной для него форме, а могут быть подготовлены для ввода в другую вычислительную систему или для использования в другой программе, и поэтому записываются в закодированном виде.
ГЕНЕРАЦИЯ ОПЕРАЦИОННОЙ СИСТЕМЫ, конфигурирование операционной системы [OS generation]
 Процесс формирования на базе полной операционной системы ее рабочей версии, которая по составу и структуре соответствует конфигурации компьютера и адаптирована к потребностям пользователя. Г. о. с. выполняется при загрузке операционной системы. Для операционной системы МS-DOS Г.о.с. выполняется по указаниям, заданным в файле конфигурации config.sys, содержимое которого может корректироваться пользователем или оператором вычислительной системы. Операционная система Windows использует для генерации информацию в файле win.ini и в реестре Windows
ГЕРЦ (Гц) [hertz]
 Единица измерения частоты. Один Гц соответствует одному колебанию в секунду
ГИБКИЙ МАГНИТНЫЙ ДИСК, дискета [floppy disk]
 Магнитный диск, предназначенный для долговременного хранения данных и для переноса данных с одного компьютера на другой. Представляет собой плоскую неразъемную кассету, состоящую из защитной оболочки, в которую заключен диск, покрытый с одной или с обеих сторон магнитным составом. В защитной оболочке имеются центральное отверстие для захвата диска приводным механизмом дисковода и радиальная прорезь (в двусторонних Г. м. д. имеются две такие прорези), через которые головки записи-чтения получают доступ к диску. Кроме того, на оболочке расположено устройство блокировки записи, с помощью которого можно предотвратить запись информации на диск, установленный в дисковод. В отличие от жесткого магнитного диска Г. м. д. вращается в дисководе не постоянно, а только при записи или чтении. Данные записываются на диске по концентрическим дорожкам, которые делятся на секторы. Информационная емкость Г. м. д. зависит от плотности записи. Совершенствование методов записи приводит к тому, что емкость Г. м. д. постоянно увеличивается. B настоящее время применяются Г. м. д., имеющие разный диаметр (указывается в дюймах) и разную емкость: двусторонняя дискета размером 5.25 емкостью 360 Кб (40 дорожек на каждой из сторон по 9 секторов на каждой дорожке); дискета двойной плотности емкостью 760 Кб (80+80 дорожек по 9 секторов на каждой) размером 3.5"; дискеты высокой плотности: емкостью 1.2 Мб (80+80 дорожек по 15 секторов на каждой) размером 5.25" и емко-: стью 1.44 Мб, размером 3.5"; стандартный формат дискеты типа HD (High Density - высокая плотность) - 80 дорожек на каждой из сторон, 18 секторов по 512 байт на дорожке. Уплотненный формат - 82 или 84 дорожки, до 20 секторов по 512 байт, или до 11 секторов по 1024 байта. К Г. м. д. относятся и диски Бернулли (накопители Zip и Jaz) - сменные запоминающие устройства, емкость которых доходит до 230 Мб и выше.
ГИГАБАЙТ, Гб, Гбайт [gigabyte]
 Единица измерения количества информации и емкости памяти. 1 Гбайт = 1024 Мбайт = 1048576 Кбайт = 1073741824 байта
ГИПЕРМЕДИА [hypermedia]
 Компьютерное представление данных различного типа, в котором автоматически поддерживаются смысловые связи между выделенными понятиями, объектами или разделами. Г. аналогично гипертексту, но допускает в качестве связываемых частей не только фрагменты текста, а данные любой природы: графические изображения, видеоклипы, звуковые файлы и пр. В последнее время Г. применяется в Интернет. Для работы с Г. компьютер должен быть оборудован соответствующими мультимедийными устройствами.
ГИПЕРССЫЛКА [hyperlink]
 редство указания смысловой связи фрагмента одного документа с другим документом или его фрагментом. Г. являются характерным средством гипертекста. В настоящее время большинство приложений Windows позволяет использовать Г. в своих документах. Например, в приложении Word Г. обычно изображается в виде подчеркнутого текста синего цвета. Щелчок мышью на таком тексте вызывает переход к тому документу, на который указывает Г. В сети Интернет Г. является основным связующим средством Всемирной паутины
ГИПЕРТЕКСТ [hypertext]
 1. Компьютерное представление текста, в котоpом автоматически поддерживаются смысловые связи между выделенными снятиями, терминами или разделами. 2. Информационная программа, водящая на экран дисплея Г. и выполняющая переходы по смысловым связям. Г. позволяет с помощью клавиатуры или мыши сразу получить на определения или пояснения слов или словосочетаний, выделенных в подсветкой, ссылки на литературные источники и рекомендации по дальнейшему чтению. В форме Г. создаются справочные системы (Неlр) современных программных продуктов. Г. применяется в компьютерных обучающих системах, толковых словорях.
ГРАФИЧЕСКАЯ ИНФОРМАЦИЯ [graphic information, graphic data]
 Информация, представленная в форме изображения - схем, графиков, диаграмм, рисунков, фотографий и т. п
ГРАФИЧЕСКИЙ АДАПТЕР [graphic adapter]
 Адаптер дисплея, поддержи вающий графический режим. Устаревший термин, так как почти все совре менные видеоадаптеры являются графическими
ГРАФИЧЕСКИЙ ДИАЛОГ [graphic dialog]
 Диалог, при котором происход обмен графической информацией между пользователем и ЭВМ
ГРАФИЧЕСКИЙ ИНТЕРФЕЙС ПОЛЬЗОВАТЕЛЯ [graphic user interface (GUI)]
 Интерфейс пользователя, основанный на средствах машинной графики. Г. и. п. предполагает взаимодействие человека с компьютером в форме диалога с использованием ввода и вывода на экран дисплея графической информации, управления программами с помощью кнопок, меню, окон, экраннных панелей и др. элементов управления, а также выделением цветом определенных частей изображения или текста, и т.п. В Г. и. п. используются мышь, световое перо, цифровой планшет графического ввода и другие средства ведения диалога с компьютером и формирования графических изображений.
ГРАФИЧЕСКИЙ ОБЪЕКТ [graphic object]
 Модель объекта реального мира, представленная в виде графического изображения
ГРАФИЧЕСКИЙ ПЛАНШЕТ, цифровой планшет графического ввода, цифровой планшет [graphics tablet]
 Указательное устройство В виде соединенного с компьютером планшета, водя по которому специал ной указкой, обычно называемой пером, можно управлять курсором ил создавать контурные рисунки, которые воспроизводятся на экране диспле в окне графического редактора. Далее эти рисунки можно обрабатывать помощью графического редактора (например, окрашивать, перемещать, дополнять и т. д.). Поэтому Г. п. считается также устройством ввода графической информации (разновидностью дигитайзера). Г. п. при управлении курсором и исполнении рисунков полностью заменяет мышь, однако в отличие от нее является абсолютным указательным устройством, так как вводит в компьютер абсолютные координаты линий, по которым движется перо. Положив на планшет какой-либо рисунок, и обводя его контуры, можно копировать на экран фрагменты этого рисунка.
ГРАФИЧЕСКИЙ ПРИМИТИВ, примитив [graphics primitive]
 Элемент графического изображения, который рисуется и обрабатывается компьютером как одно целое. Например, точка, дуга, прямоугольник, буква и т. п. В системах автоматизированного проектирования можно по собственному усмотрению создавать новые Г. п.
ГРАФИЧЕСКИЙ РЕДАКТОР, Р. изображений [graphic editor]
 Программа редактирования графической информации
ГРАФИЧЕСКИЙ РЕЖИМ [graphics mode]
 Режим работы адаптера дисплея, обеспечивающий вывод на экран графической информации. В Г. р. экран представляет собой растр - множество точек (пикселов), упорядоченных в строки и столбцы, а изображение формируется путем придания своего цвета и яркости каждой точке растра. Работающая программа определяет нужные цвет и яркость каждого пиксела. Эти данные заносятся в видеопамять центральным процессором, а видеоадаптер считывает их и последовательно, переходя от точки к точке по строке и от строки к строке, "рисует" изображение на экране. Ср. с текстовым режимом, при котором видеоадаптер одновременно "рисует" символ, занимающий целое знакоместо. Качество изображения, которое позволяет получить Г. р., определяется его разрешающей способностью и количеством используемых цветов. Разрешающая способность выражается произведением числа столбцов на число строк растра. Стандартные Г. р. видеоадаптеров, определенные фирмой 1ВМ, обеспечивают разрешающую способность от 320x200 до 720x480 и выше при количестве изображаемых цветов от 16 до 256. Разрешение адаптеров специальных графических систем может быть 1024x768 и выше при количестве изображаемых цветов, доходящем до 16 млн. На монохромном дисплее различные Цвета изображаются различными градациями серого, зеленого или коричневого цвета.
ГРАФИЧЕСКИЙ СИМВОЛ [graphic character]
 Этим термином называют все допустимые вычислительной системой изображаемые на экране символы, Кроме псевдографических символов. Например, любая буква или цифра.
ГРАФИЧЕСКИЙ СОПРОЦЕССОР, графический акселератор соргосеввог, [graphics coprocessor]
 Сопроцессор, устанавливаемый на плате видеоадаптера с целью повышения скорости вывода на экран графического Изображения. Часть изображения может создаваться Г. с. без участия центрального процессора. Для этого на Г. с. посылаются специальные команды. Г. с. берет на себя выполнение операций перемещения фрагментов растрового изображения, рисования графических примитивов, закраски и заливки графических объектов и т. п. В результате разгружается центральный процессор и сокращается количество информации, передаваемой по системной шине. Все это повышает быстродействие видеоподсистемы компьютера.
ГРАФОПОСТРОИТЕЛЬ, плоттер [plotter]
 Устройство, предназначенное для изображения на бумаге или другом подобном ей носителе выводимых из ЭВМ данных в форме чертежа, графика или рисунка. Г. используются для выполнения машиностроительных и строительных чертежей, метеорологических карт, разного рола схем, для вывода результатов вычислений в форме графиков или диаграмм. Изображение формируется пишущими элементами (перьями) различной толщины и цвета. Различают Г. планшетного и рулонного типа. Они работают в прямоугольной системе координат. В Г. планшетного типа лист бумаги неподвижно закреплен на планшете, а перо может передвигаться к любой точке, лежащей в пределах установленных диапазонов изменения координат х и у, касаясь поверхности бумаги и, вычерчивая линию, или может двигаться над поверхностью в поднятом состоянии. В Г. рулонного типа двигаются и бумага и перо.


Толковый словарь компьютерной лексики

АБЗАЦ (paragraph)
 1.Часть текста, ограниченная двумя отступами. 2. В текстовых редакторах – часть документа, между двумя соседними маркерами конца А. в текстовом редакторе Word эти маркеры автоматически вносятся в текст при нажатии клавиши (перевод строки) и видимы при нажатии кнопки «непечатаемые символы». Каждому А. можно придать свой формат, отличный от формата соседних абзацев.
АБОНЕНТ СЕТИ (network abonent, user node)
 1. Пользователь имеющий доступ к ресурсам сети ЭВМ или к компьютерной связи. 2. Терминал, компьютер или рабочая станция, подключенные к вычислительной сети или сети компьютерной связи.
АБСОЛЮТНЫЙ АДРЕС, физический адрес (absolute address, physical address)
 1. Адрес в виде цифрового кода, однозначно идентифицирующий реально существующие в вычислительной системе байт, ячейку памяти или устройство. А.а. непосредственно интерпретируется аппаратными средствами или микропрограммами центрального процессора вычислительной системы. А.а. либо указывается как неизменяемый адрес в машинной команде, либо вычисляется, исходя из логического адреса, и не может быть далее уточнен программными средствами. Ср. логический адрес. 2. Цифровой код, однозначно определяющий положение данных на носители данных. Например, для магнитного диска А.а. представляет код, состоящий из номера поверхности, номера дорожки и номера сектора.
АВМ (analog computer)
 То же, что аналоговая вычислительная машина
АВТОМАТИЗИРОВАННАЯ СИСТЕМА (automatized system)
 Система программных и аппаратных средств, предназначенных для автоматизации процесса деятельности человека. В отличии от автоматической системы А.с. всегда функционирует при участии человека. И человек является ее главным звеном.
АВТОНОМНАЯ ПРОГРАММА (autonomy device stand-alone program)
 Программа, не зависящая от других программ в составе данной программной системы. Например, программа в виде загрузочного модуля, имеющая свои собственные средства инициализации и не требующая для своего выполнения управляющих действий операционной системы.
АДА (Ada)
 Универсальный язык программирования высокого уровня, ориентированный на разработку программного обеспечения ЭВМ, встроенных в системы автоматизированного управления. Назван в честь Августы Ады Лавлейс, считающейся первым в мире программистом. Первая версия А., разработанная в США под руководством Дж. Ишбиа, появилась в 1980 г. последняя версия Ада-95 – в 1995 г. А. обладает средствами программирования процессов, протекающих параллельно в реальном времени. Программы на языке А. имеют модульную структуру, допус-кающую раздельную компиляцию модулей. Кроме того, в стандарте языка А., помимо собствен-ного языка программирования, впервые была определена и его поддерживающая среда програм-мирования, т.е. средства разработки, корректировки и модернизации программ. Все это позволяет создавать на языке А. очень большие программные проекты, например программное обеспечение системы астронавигации.
АДАПТЕР (adapter)
 Электронная схема, позволяющая приспособить друг к другу устройства с различными способами представления данных. Например, аналоговое устройство нельзя напрямую соединить с цифровым устройством: для этого аналоговый сигнал должен быть сначала преобразован в цифровой или наоборот. Чтобы связать два несовместимых компонента аппарат-ных средств, требуется устройство сопряжения, важной составляющей которого и является А. Обычно А. монтируется на отдельной плате.
АДАПТЕР ДИСПЛЕЯ, видеоадаптер, видеокарта (display adapter, video-adapter, videocard)
 Адаптер, согласующий обмен графической информацией между центральным процессором и дисплеем. А.д. преобразует данные, поступающие в ЭВМ в цифровой форме, в соответствующее изображение на экране.
АДРЕС (address)
 1. Номер, код или идентификатор места в памяти ЭВМ, где хранится или куда должна быть записана данная информация. Например, номер байта оперативной памяти или номер дорожки магнитного диска, имя внешнего устройства или узла сети. Различают логические и физические А. Логический А. указывается в машинной программе. При загрузке, а также при переадресации он преобразуется в зависимости от места, занимаемого программой и данными в оперативной памяти, в физический А., закрепленный в вычислительной системе за реально существующим запоминающим устройством или его частью. Это преобразование выполняется со-ответствующим программным обеспечением и аппаратными средствами. 2. Часть команды, оп-ределяющая местоположение операнда. 3. Часть сообщения, указывающая адресат.
АДРЕСАТ (target)
 ). Обладатель адреса (лицо, программа, устройство или компьютер), которому предназначается сообщение, команда или данные. Например, А. считается и почтовый ящик, в который приходит сообщение по электронной почте, и пользователь – владелец этого ящика. Также А. является дисковод, на который послал команду центральный процессор и программа, для которой с диска считываются данные.
АДРЕС IP (IP-address)
 1. Уникальный адрес, идентифицирующий узлы или компьютеры в сети, управляемой протоколами ТСР/IP. В сети, представляющей собой объединение нескольких подсетей, указывает информацию маршрутизации. А. IP представляет собой 32-разрядное значение, которое идентифицирует данный компьютер. Каждый байт А. IP представляется десятичным числом и отделяется от других десятичной точкой. 2. То же, что Интернет-адрес
АДРЕСНАЯ ССЫЛКА (address reference)
 Ссылка в форме адреса
АКТИВНОЕ ОКНО (active window)
 Окно, с которым в настоящий момент работает или может работать пользователь. На нем активизированы элементы управления, через него возможен ввод данных. При одновременном отображении на экране нескольких окон А.о. не перекрывается другими окнами и выделяется контрастным цветом рамки или заголовка, наличием мерцающего курсора и т.п. Чтобы сделать окно активным, как правило, достаточно навести на него указатель мыши и нажать левую кнопку.
АЛГОРИТМ (algorithm)
 Содержание и последовательность операций, точно определяющие решение задачи путем вычислительного процесса, преобразующего исходные данные в конечный результат. Характеристиками алгоритма являются: 1) однозначность результата при заданных исходных данных; 2) возможность расчленения процесса на конечное число отдельных операций, каждая из которых может быть выполнена человеком или вычислительной машиной; 3) способность получения результата для множества исходных данных, соответствующих множеству од-нотипных задач. Например, один из А. вычисления с помощью ЭВМ среднего арифметического трех чисел представляет собой следующую последовательность операций: ввод с клавиатуры в ЭВМ трех чисел; вычисление суммы введенных чисел; деление полученной суммы на 3; вывод результата на экран дисплея. В приведенном примере для записи А. был применен русский язык. Существует специально созданные алгоритмические языки. Вычислительной машине А. задается в виде программы. Могут существовать несколько А. решения одной и той же задачи. Среди них следует выбирать наиболее эффективный, для вычислительной реализации которого требуется наименьшее количество операций, машинного времени, памяти и т.п. Изучение существования и способов построения (разработки) эффективных А. составляет основу теории алгоритмов.
АНИМАЦИЯ (animation)
 Создание иллюзии движения объекта на экране дисплея. В основе А. лежит быстрая смена последовательно смещаемых относительно друг друга образов. Существует несколько способов А., реализуемых в различных системах программирования. При одном способе на экране быстро рисуются и стираются последовательные фазы движения. При другом эти фазы заранее рисуются в виде полноэкранных кадров и запоминаются в памяти компьютера, чтобы затем последовательно отобразиться на экране. В развитых системах применяются средства А., для которых достаточно задать изображение объекта и его начальное и конечное положение. Качество А. зависит от скорости смены кадров. Чем выше скорость, тем плавнее движение. Современные компьютеры позволяют выполнять до 30 смен кадров в секунду.
АНТИВИРУСНАЯ ПРОГРАММА (antivirus program)
 Обслуживающая программа, предназначенная для поиска, диагностики, профилактики и «лечения» файлов, зараженных компьютерным вирусом. В процессе поиска и диагностики определяются зараженные файлы и тип вируса. Профилактика позволяет предотвратить заражение. Например, резидентная А.п. предотвращает несанкционированное пользователем изменение файлов операционной системы, запись в сектор начальной загрузки и т.п. Лечение подразумевает удаление вируса, восстановление поврежденных файлов и т.п.
АППАРАТНЫЕ СРЕДСТВА, технические средства (hardware)
 Электрические, электронные и механические системы, блоки, приборы и устройства, составляющие материальную часть вычислительной системы. А.с. являются, например и сам и микросхемы, его составляющие. К А.с. также относятся дисплей, дисковод, принтер и проч.
АППАРАТНЫЙ БЛОК, блок (hardware block, block)
 Конструктивно оформленная как единое целое совокупность взаимосвязанных устройств, либо совокупность взаимосвязанных элементов или узлов одного устройства, выполняющих определенную функцию. Например, блок питания, обеспечивающий компьютер электроэнергией с заданными показателями, или системный блок, объединяющий основные устройства персонального компьютера.
АППЛЕТ, аплет (applet)
 Небольшая прикладная программа. Термин А. получил распространение в последнее время в связи с технологиями Всемирной паутины WWW, позволяющей внедрять А. в документы Web с целью построения интерактивных страниц Web. Для создания таких А. обычно применяется язык программирования Java, поэтому часто их называют апплетами Java
АРХИВ (archive)
 Совокупность образовавшихся в результате деятельности пользователя вычислительной системы рабочих материалов и средств их долговременного хранения. Рабочими материалами являются копии документов, редко используемых программ, данных и т.п. В качестве средств долговременного хранения удобно использовать магнитные ленты и магнитные диски. В целях экономии памяти архивные файлы предварительно сжимают с помощью архиватора. Правильно организованный А. оберегает пользователя от потерь при любых аварийных ситуациях в компьютере.
АРХИВАТОР (archivator)
 Программа или комплекс программ, выполняющие сжатие (архивирование) файлов для более компактного длительного хранения во внешней памяти и восстановление сжатых файлов в первоначальном виде (разархивирование). В персональных IBM-совместимых компьютерах наиболее распространены в последнее время А. pkzip.exe/pkunzip.exe, arj.exe, rar.exe и winzip.exe. Все они предоставляют возможность более компактного хранения файлов на дисках и позволяют: 1) упаковывать все, отдельные или соответствующие какому-либо шаблону файлы рабочего каталога в архивный файл; 2) добавлять файлы в архивный файл; 3) удалять файлы из архивного файла; 4) просматривать содержимое архивного файла; 5) извлекать из архивного файла или распаковывать все файлы архива; 6) создавать самораспаковывающиеся архивные файлы.
АТРИБУТ (attribute)
 1. Признак или свойство, характеризующие объект. Например, атрибутами выводимых на экран символов являются шрифт, цвет, размер и т.п. 2. В реляционных базах данных – имя одного и того же поля всех кортежей одной таблицы.
АУДИОВИЗУАЛЬНЫЙ (audiovisual)
 Определение, относящееся к данным, которые содержат изображения и его звуковое сопровождение, или к аппаратуре, воспроизводящей такие данные.
БАЗА ДАННЫХ (БД) (БД) (database(DB)
 Один или несколько специальным образом организованных файлов, хранящих систематизированную информацию, для доступа к которой используются программные средства системы управления базой данных (СУБД). Б.д. представляет собой хранилище связанных между собой данных, не зависящих от программ, которые к ним обращаются. Например, в Б.д. предприятия хранятся конструкционные, технологические, производственные, эксплуатационные, экономические и т.п. характеристики изделий предприятия и их аналогов, выпускаемых конкурирующими фирмами. Такой Б.д. могут пользоваться специалисты из отдела маркетинга (для прогноза конкурентоспособности изделий на рынке), плановики (для определе-ния необходимых объемов выпуска продукции), конструкторы (для анализа конструктивных осо-бенностей изделий конкурентов) и т.д. Б.д. должна быть достаточно полной, правильно органи-зованной, всегда соответствовать текущему моменту времени и удобной для использования. Со-держащиеся в ней данные не должны противоречить друг другу . Редактирование, пополнение и исключение данных, их поиск и сортировка осуществляются под управлением СУБД. Б.д. могут быть персональными и коллективного пользования. Сопровождение крупных Б.д. коллективного пользования осуществляет администратор базы данных.
БАЙТ (Б) (byte)
 1. Фрагмент двоичного кода, состоящий из 8 соседних двоичных цифр. 2. Единица измерения количества информации, равная количеству информации, которое содержится в 8 двоичных разрядах. 3. В вычислительной технике байт представляет собой объединение из 8 соседних двоичных разрядов, которыми компьютер может оперировать как одним целым. Так в персональных IBM-совместимых компьютерах каждый байт оперативной памяти имеет свой ад-рес и предназначен для хранения одной буквы, специального символа или двух десятичных или шестнадцатеричных цифр. 1 байт = 8 бит.
БЕГУНОК, движок, ползун (scroll box)
 Небольшой прямоугольник на линейке прокрутки, который используется для скроллинга. Двигая с помощью мыши Б. По линейке прокрутки можно перемещаться по документу. Положение Б. На линейке прокрутки показывает относительное положение в документе отображаемой в окне информации.
БЕЙСИК (Basic, beginner's all-purpose symbolic instruction code)
 Язык программирования, предназначенный для решения математических и экономических задач. Разработан в середине 1960-х годов. Напоминая упрощенную версию Фортрана, Б. Обладает развитыми средствами диалога, а также средствами отладки и редактирования программ. Простота синтаксиса, обеспечивающая сравнительно легкое и быстрое освоение, а также относительная универсальность сделали Б. И его последующие модификации QBASIC и Quick Basic широко распространенными языками программирования персональных компьютеров. Появление системы программирования Visual Basic, работающей в среде Windows, позволяет даже начинающим программистам разрабатывать программные изделия малой и средней сложности, ориентированные на работу в среде Windows.
БИТ (bit)
 1. Один разряд двоичного кода. 2. Единица измерения количества информации, равная количеству информации, которое содержится в одном двоичном разряде или в ответе на вопрос, допускающий ответы «да» либо «нет» и никакого другого.
БЛОК ПАМЯТИ (memory block, storage block)
 Непрерывная область памяти, которой может быть присвоен ключ для ее идентификации или защиты. Выделяемая программе память состоит из одного или нескольких Б.п. размер Б.п. может быть разным. БОД (baud). Единица измерения скорости передачи информации, определяемая числом симво-лов, передаваемых в секунду. Для каналов, передающих информацию в двоичном коде 1 бод = 1 бит/сек.
БРАУЗЕР, броузер (browser)
 Браузер Internet Web-браузер. Программа чтения гипертекста. Браузеры Web помимо чтения гипертекста могут обладать следующими дополнительными возможностями: 1) воспроизводить звук и видеоданные (движущиеся изображения), т.е. воспроизводить гипермедиа; 2) устанавливать соединения с другими компьютерами сети и посылать работающим на них серверам запросы на документы Web; 3) организовывать и поддерживать диалог с другими пользователями сети. Наиболее распространенные Web-браузеры для операционных систем Windows-Microsoft Internet Explorer и Netscape Navigator. Они поддерживают все возможности гипермедиа и устанавливают связь, а Netscape Communicator также позволяет редактировать документы и запускать доступные программы. В различных браузерах один и тот же документ может выглядеть по-разному. Это зависит от характеристик конкретного браузера и от ус-тановленных пользователем настроек.
БУФЕР (buffer)
 1. То же, что буферная память. 2. Электронная схема или устройство, помещаемые между двумя устройствами для согласования различий в их рабочих характеристиках.
БУФЕРНАЯ ПАМЯТЬ, буфер (buffer memory, buffer)
 Память для промежуточного хранения данных. Применяется при обмене данными между двумя устройствами, обладающими различной скоростью обработки информации, чтобы работа «тихоходного» устройства не снижала их общую производительность. Характерным примером применения Б.п. является выдача данных программой на принтер. Так как скорость передачи данных от программы к принтеру неизмеримо выше, чем скорость работы принтера, то чтобы не замедлять работу программы на время выдачи данных, программа помещает данные в Б.п. и продолжает свою работу, а принтер «самостоятельно» извлекает их со своей скоростью и печатает, не требуя прерывания работы программы. Многие внешние устройства имеют собственную Б.п., кроме того, в качестве Б.п. может служить специально выделяемая операцион-ной системой область оперативной памяти
БУФЕР ОБМЕНА (clipboard)
 Средство операционной системы Windows, предназначенное для обмена данными между приложениями. Б.о. позволяет вырезать или скопировать выделенные данные в специальное место, отведенное для временного хранения данных, а затем вставить эти данные из буфера в другое место. В Б.о. вместе сданными хранится информация об их типе и формате, поэтому вставка данных из буфера может производиться различными способами, в зависимости от типа данных и возможностей приложения, в документ которого вставляются данные.
БЫСТРОДЕЙСТВИЕ (performance, speed)
 Характеристика скорости работы устройства. Например, Б. Процессора характеризуется числом элементарных операций, выполняемых в секунду, или тактовой частотой, Б. Принтера – числом знаков, печатаемых в секунду.
ВВОД-ВЫВОД (input-output)
 Общий термин, определяющий процесс обмена данными между оперативной памятью и внешними устройствами
ВЕКТОРНАЯ ГРАФИКА (vector graphics)
 Метод создания изображения в виде совокупности линий. Каждая линия рисунка представляется отрезками прямых (векторами) и сопрягающимися с ними отрезками стандартных геометрических кривых. Для определения формы и расположения отрезка используются математические описания. В.г. применяется в программах рисования, которые работают с рисунком как с совокупностью форм, а не как с группой точек. Рисунки, выполненные методами В.г. более компактны при хранении, допускают точное масштабирование и не зависят от разрешающей способности графических устройств.
ВЕРТИКАЛЬНОЕ МЕНЮ (vertical menu)
 Меню с вертикальным расположением пунктов меню (один под другим). На экране дисплея такое меню перекрывает выведенную ранее информацию.
ВЕРХНИЙ КОЛОНТИТУЛ (header running head)
 Колонтитул, расположенный в верхней части страницы, выше основного текста.
ВЕТВЬ АЛГОРИТМА [algorithm branch]
 Одна из альтернативных последовательностей действий алгоритма, выбор которой зависит от некоторых условий. На блок-схеме – один из альтернативных путей, исходящих из точки ветвления. В программе В.а. соответствует ветвь программы.
ВЕТВЬ ПРОГРАММЫ (program branch)
 1. Участок программы, которому может быть передано управление при ветвлении программы. 2. Участок программы, который может выполняться параллельно с другими участками. На блок-схеме В.п. изображается одним из альтернативных путей, исходящих из точки ветвления.
ВИДЕОКАРТА (videocard)
 То же, что адаптер дисплея.
ВИНЧЕСТЕР (winchester)
 То же, что винчестерский диск.
ВИНЧЕСТЕРСКИЙ ДИСК, винчестер, жесткий диск (winchester disk, hard disk)
 Постоянно закрепленный в дисководе жесткий магнитный диск или пакет дисков, заключенный вместе с головками записи-чтения в герметически закрытый корпус, заполненный очищенным от пыли обычным воздухом под атмосферным давлением. При вращении диска над ним создается «воздушная подушка», обеспечивающая зависание головок над поверхность диска на высоте порядка нескольких микрон. Такая конструкция позволила существенно уменьшить величину и массу головок, толщину магнитного покрытия диска и при этом значительно увеличить плотность записи, а следовательно и емкость дисков. Конструкция разработана в 1973 году в филиале IВМ в г. Винчестер (Великобритания). В.д. широко применяется в персональных компьютерах для записи, долговременного хранения и быстрого чтения больших объемов информации. Емкость В.д. персональных IВМ-совместимых компьютеров может достигать нескольких гигабайт при времени записи-считывания одного бита, измеряемом в долях наносекунд.
ВИРТУАЛЬНЫЙ ДИСК (virtual address)
 То же, что электронный диск.
ВИРУС (virus)
 То же, что компьютерный вирус
ВИСЯЧАЯ СТРОКА (orphan, widow)
 Нарушение правила верстки страниц, согласно которому при переносе абзаца с одной страницы на другую, на странице должно присутствовать не менее определенного числа строк данного абзаца (обычно, не менее двух строк). Таким образом, возможны два случая В.с.: при переносе абзаца на первой странице остается только одна строка («сирота» - orphan) или на следующую страницу переносится только одна строка (“вдова” – widow). Современные текстовые процессоры, например Word, позволяют автоматически отследить выполнение этого правила и не допустить появления В.с.
ВКЛЮЧЕНИЕ ФАЙЛА (file inclusion)
 Осуществляемое препоцессором включение содержимого указанного файла в заданное место исходного текста программы. Таким образом в программу вносится необходимая информация, содержащаяся в других файлах
ВНЕШНЕЕ ЗАПОМИНАЮЩЕЕ УСТРОЙСТВО (ВЗУ) (backing storage external storage)
 Запоминающее устройство, не относящееся к оперативной памяти. Набор ВЗУ реализует внеш-нюю память вычислительной системы, доступ к данным которой осуществляется средствами ввода-вывода. Внешняя память предназначена для длительного хранения информации, поэтому носители данных, применяемые в ВЗУ, не являются энергозависимыми – при выключении ком-пьютера данные на них сохраняются. Существуют ВЗУ на магнитных дисках, магнитных лентах
ВНЕШНЕЕ УСТРОЙСТВО (external device)
 Устройство компьютера, не относящееся к центральному процессору и оперативной памяти, или периферийное устройство вычислительной системы. В.у. обычно являются устройства ввода-вывода: терминалы, дисководы, стримеры, принтеры, плоттеры, сканеры, дигитайзеры и т.п. Часто одним и тем же В.у. могут пользоваться несколько ЭВМ.
ВНЕШНЯЯ ПАМЯТЬ (backing storage, external memory)
 Память, к содержимому которой можно обратиться только при помощи операций ввода-вывода. В.п. реализуется набором внешних запоминающих устройств вычислительной системы. К данным, хранящимся во В.п., центральный процессор непосредственно обращаться на может. Для этого они должны быть предварительно считаны в оперативную память.
ВРЕМЕННОЙ ФАЙЛ, рабочий файл (temporary file (temp file))
 Файл, создаваемый операционной системой или прикладной программой на время ее работы. В.ф. создается в оперативной памяти или на диске и по завершении работы программы уничтожается.
ВСЕМИРНАЯ ПАУТИНА (World Wide Web (WWW))
 Гипертекстовая система поиска ресурсов в Интернет и доступа к ним. В.п. представляет набор услуг Интернет, позволяющий просмотреть любые данные, хранящиеся в компьютерах этой сети, через систему связывающих их гиперссылок. Основу аппаратного обеспечения В.п. составляет множество объединенных в Интернет компьютеров, расположенных по всему миру. Информационную основу В.п. составляет множество хранящихся в памяти этих компьютеров и содержащих гипертекст документов, называемых документами Web. К документах Web пользователь может, указав на выделенное слово или фразу, переходить к документам или получать доступ к файлам, хранящимся в памяти компьютеров в разных точках Земного шара. Поэтому пользователь воспринимает В.п. как Всемирную виртуальную информационную паутину. Поскольку в.п. использует компьютеры Интернет и ее стандартные протоколы для передачи файлов и документов, термин “В.п.” часто относят как к Всемирной сети компьютеров, так и собственно к информации.
ВСПЛЫВАЮЩЕЕ МЕНЮ (pop-up menu)
 Меню, появляющееся на экране дисплея в текущем положении курсора и исчезающее после выбора пункта меню. На экране дисплея такое меню перекрывает выведенную ранее информацию.
ВСТАВКА (paste)
 В приложениях операционной системы Windows – копирование содержимого буфера обмена в документ. При этом содержимое буфера обмена сохраняется и может быть вставлено произвольное количество раз. В зависимости от типа данных, находящихся в буфере обмена, и возможностей приложения, вставка может быть выполнена различными способами.
ВХОД В ПРОГРАММУ (program entry)
 Оператор или команда, которым передается управление при запуске программы или вызове подпрограммы.
ВХОД В СИСТЕМУ, регистрация (login, logon)
 Процедура, обеспечивающая доступ к вычислительной системе зарегистрированных пользователей. Например, начало работы с системой начинается с сообщения ей имени и пароля. Обычно В.в с. предваряет начало сеанса работы пользователя за одним из удаленных терминалов или рабочих станций локальной сети.
ВЫБОРКА (fetching)
 Машинная операция, с помощью которой осуществляется чтение команд или данных из оперативной памяти ЭВМ в регистры устройства управления или арифметико-логического устройства.
ВЫВОД ДАННЫХ, вывод (data output, output)
 Процесс передачи данных из основной памяти ЭВМ на экран дисплея, бумагу или другой подобный носитель, а так же на внешние запоминающие устройства. Выведенные из ЭВМ результаты обработки данных могут быть предназначены для последующего анализа человеком, и поэтому представляются в удобной для него форме, а могут быть подготовлены для ввода в другую вычислительную систему или для использования в другой программе, и поэтому записываются в закодированном виде.
ГЕНЕРАЦИЯ ОПЕРАЦИОННОЙ СИСТЕМЫ, конфигурирование операционной системы [OS generation]
 Процесс формирования на базе полной операционной системы ее рабочей версии, которая по составу и структуре соответствует конфигурации компьютера и адаптирована к потребностям пользователя. Г. о. с. выполняется при загрузке операционной системы. Для операционной системы МS-DOS Г.о.с. выполняется по указаниям, заданным в файле конфигурации config.sys, содержимое которого может корректироваться пользователем или оператором вычислительной системы. Операционная система Windows использует для генерации информацию в файле win.ini и в реестре Windows
ГЕРЦ (Гц) [hertz]
 Единица измерения частоты. Один Гц соответствует одному колебанию в секунду
ГИБКИЙ МАГНИТНЫЙ ДИСК, дискета [floppy disk]
 Магнитный диск, предназначенный для долговременного хранения данных и для переноса данных с одного компьютера на другой. Представляет собой плоскую неразъемную кассету, состоящую из защитной оболочки, в которую заключен диск, покрытый с одной или с обеих сторон магнитным составом. В защитной оболочке имеются центральное отверстие для захвата диска приводным механизмом дисковода и радиальная прорезь (в двусторонних Г. м. д. имеются две такие прорези), через которые головки записи-чтения получают доступ к диску. Кроме того, на оболочке расположено устройство блокировки записи, с помощью которого можно предотвратить запись информации на диск, установленный в дисковод. В отличие от жесткого магнитного диска Г. м. д. вращается в дисководе не постоянно, а только при записи или чтении. Данные записываются на диске по концентрическим дорожкам, которые делятся на секторы. Информационная емкость Г. м. д. зависит от плотности записи. Совершенствование методов записи приводит к тому, что емкость Г. м. д. постоянно увеличивается. B настоящее время применяются Г. м. д., имеющие разный диаметр (указывается в дюймах) и разную емкость: двусторонняя дискета размером 5.25 емкостью 360 Кб (40 дорожек на каждой из сторон по 9 секторов на каждой дорожке); дискета двойной плотности емкостью 760 Кб (80+80 дорожек по 9 секторов на каждой) размером 3.5"; дискеты высокой плотности: емкостью 1.2 Мб (80+80 дорожек по 15 секторов на каждой) размером 5.25" и емкостью 1.44 Мб, размером 3.5"; стандартный формат дискеты типа HD (High Density - высокая плотность) - 80 дорожек на каждой из сторон, 18 секторов по 512 байт на дорожке. Уплотненный формат - 82 или 84 дорожки, до 20 секторов по 512 байт, или до 11 секторов по 1024 байта. К Г. м. д. относятся и диски Бернулли (накопители Zip и Jaz) - сменные запоминающие устройства, емкость которых доходит до 230 Мб и выше.
ГИГАБАЙТ, Гб, Гбайт [gigabyte]
 Единица измерения количества информации и емкости памяти. 1 Гбайт = 1024 Мбайт = 1048576 Кбайт = 1073741824 байта
ГИПЕРМЕДИА [hypermedia]
 Компьютерное представление данных различного типа, в котором автоматически поддерживаются смысловые связи между выделенными понятиями, объектами или разделами. Г. аналогично гипертексту, но допускает в качестве связываемых частей не только фрагменты текста, а данные любой природы: графические изображения, видеоклипы, звуковые файлы и пр. В последнее время Г. применяется в Интернет. Для работы с Г. компьютер должен быть оборудован соответствующими мультимедийными устройствами.
ГИПЕРССЫЛКА [hyperlink]
 Средство указания смысловой связи фрагмента одного документа с другим документом или его фрагментом. Г. являются характерным средством гипертекста. В настоящее время большинство приложений Windows позволяет использовать Г. в своих документах. Например, в приложении Word Г. обычно изображается в виде подчеркнутого текста синего цвета. Щелчок мышью на таком тексте вызывает переход к тому документу, на который указывает Г. В сети Интернет Г. является основным связующим средством Всемирной паутины
ГИПЕРТЕКСТ [hypertext]
 1. Компьютерное представление текста, в котоpом автоматически поддерживаются смысловые связи между выделенными понятиями, терминами или разделами. 2. Информационная программа, выводящая на экран дисплея Г. и выполняющая переходы по смысловым связям. Г. позволяет с помощью клавиатуры или мыши сразу получить определения или пояснения слов или словосочетаний, выделенных в подсветкой, ссылки на литературные источники и рекомендации по дальнейшему чтению. В форме Г. создаются справочные системы (Неlр) современных программных продуктов. Г. применяется в компьютерных обучающих системах, толковых словорях.
ГРАФИЧЕСКАЯ ИНФОРМАЦИЯ [graphic information, graphic data]
 Информация, представленная в форме изображения - схем, графиков, диаграмм, рисунков, фотографий и т. п
ГРАФИЧЕСКИЙ АДАПТЕР [graphic adapter]
 Адаптер дисплея, поддержи вающий графический режим. Устаревший термин, так как почти все совре менные видеоадаптеры являются графическими
ГРАФИЧЕСКИЙ ДИАЛОГ [graphic dialog]
 Диалог, при котором происход обмен графической информацией между пользователем и ЭВМ
ГРАФИЧЕСКИЙ ИНТЕРФЕЙС ПОЛЬЗОВАТЕЛЯ [graphic user interface (GUI)]
 Интерфейс пользователя, основанный на средствах машинной графики. Г. и. п. предполагает взаимодействие человека с компьютером в форме диалога с использованием ввода и вывода на экран дисплея графической информации, управления программами с помощью кнопок, меню, окон, экраннных панелей и др. элементов управления, а также выделением цветом определенных частей изображения или текста, и т.п. В Г. и. п. используются мышь, световое перо, цифровой планшет графического ввода и другие средства ведения диалога с компьютером и формирования графических изображений.
ГРАФИЧЕСКИЙ ОБЪЕКТ [graphic object]
 Модель объекта реального мира, представленная в виде графического изображения
ГРАФИЧЕСКИЙ ПЛАНШЕТ, цифровой планшет графического ввода, цифровой планшет [graphics tablet]
 Указательное устройство В виде соединенного с компьютером планшета, водя по которому специал ной указкой, обычно называемой пером, можно управлять курсором ил создавать контурные рисунки, которые воспроизводятся на экране диспле в окне графического редактора. Далее эти рисунки можно обрабатывать помощью графического редактора (например, окрашивать, перемещать, дополнять и т. д.). Поэтому Г. п. считается также устройством ввода графической информации (разновидностью дигитайзера). Г. п. при управлении курсором и исполнении рисунков полностью заменяет мышь, однако в отличие от нее является абсолютным указательным устройством, так как вводит в компьютер абсолютные координаты линий, по которым движется перо. Положив на планшет какой-либо рисунок, и обводя его контуры, можно копировать на экран фрагменты этого рисунка.
ГРАФИЧЕСКИЙ ПРИМИТИВ, примитив [graphics primitive]
 Элемент графического изображения, который рисуется и обрабатывается компьютером как одно целое. Например, точка, дуга, прямоугольник, буква и т. п. В системах автоматизированного проектирования можно по собственному усмотрению создавать новые Г. п.
ГРАФИЧЕСКИЙ РЕДАКТОР, Р. изображений [graphic editor]
 Программа редактирования графической информации
ГРАФИЧЕСКИЙ РЕЖИМ [graphics mode]
 Режим работы адаптера дисплея, обеспечивающий вывод на экран графической информации. В Г. р. экран представляет собой растр - множество точек (пикселов), упорядоченных в строки и столбцы, а изображение формируется путем придания своего цвета и яркости каждой точке растра. Работающая программа определяет нужные цвет и яркость каждого пиксела. Эти данные заносятся в видеопамять центральным процессором, а видеоадаптер считывает их и последовательно, переходя от точки к точке по строке и от строки к строке, "рисует" изображение на экране. Ср. с текстовым режимом, при котором видеоадаптер одновременно "рисует" символ, занимающий целое знакоместо. Качество изображения, которое позволяет получить Г. р., определяется его разрешающей способностью и количеством используемых цветов. Разрешающая способность выражается произведением числа столбцов на число строк растра. Стандартные Г. р. видеоадаптеров, определенные фирмой 1ВМ, обеспечивают разрешающую способность от 320x200 до 720x480 и выше при количестве изображаемых цветов от 16 до 256. Разрешение адаптеров специальных графических систем может быть 1024x768 и выше при количестве изображаемых цветов, доходящем до 16 млн. На монохромном дисплее различные Цвета изображаются различными градациями серого, зеленого или коричневого цвета.
ГРАФИЧЕСКИЙ СИМВОЛ [graphic character]
 Этим термином называют все допустимые вычислительной системой изображаемые на экране символы, Кроме псевдографических символов. Например, любая буква или цифра.
ГРАФИЧЕСКИЙ СОПРОЦЕССОР, графический акселератор соргосеввог, [graphics coprocessor]
 Сопроцессор, устанавливаемый на плате видеоадаптера с целью повышения скорости вывода на экран графического Изображения. Часть изображения может создаваться Г. с. без участия центрального процессора. Для этого на Г. с. посылаются специальные команды. Г. с. берет на себя выполнение операций перемещения фрагментов растрового изображения, рисования графических примитивов, закраски и заливки графических объектов и т. п. В результате разгружается центральный процессор и сокращается количество информации, передаваемой по системной шине. Все это повышает быстродействие видеоподсистемы компьютера.
ГРАФОПОСТРОИТЕЛЬ, плоттер [plotter]
 Устройство, предназначенное для изображения на бумаге или другом подобном ей носителе выводимых из ЭВМ данных в форме чертежа, графика или рисунка. Г. используются для выполнения машиностроительных и строительных чертежей, метеорологических карт, разного рола схем, для вывода результатов вычислений в форме графиков или диаграмм. Изображение формируется пишущими элементами (перьями) различной толщины и цвета. Различают Г. планшетного и рулонного типа. Они работают в прямоугольной системе координат. В Г. планшетного типа лист бумаги неподвижно закреплен на планшете, а перо может передвигаться к любой точке, лежащей в пределах установленных диапазонов изменения координат х и у, касаясь поверхности бумаги и, вычерчивая линию, или может двигаться над поверхностью в поднятом состоянии. В Г. рулонного типа двигаются и бумага и перо.


Толковый словарь компьютерной лексики

ДВИЖОК [scroll box]
 To же, что бегунок
ДВОИЧНАЯ СИСТЕМА СЧИСЛЕНИЯ [binary number system]
 Позиционная система счисления с основанием q = 2. В качестве двоичных цифр используются символы 0 и 1. Представление числа в Д. с. с. рассматривается как двоичный код этого числа. Поэтому Д. с. с. широко применяют для внутреннего представления чисел в ЭВМ.
ДАМП [dump]
 1. Распечатка содержимого памяти ЭВМ или файла, обычно без учета внутренней структуры данных. Копия содержимого регистров, нужного участка оперативной памяти, блока данных или файла выводится на печать последовательно, байт за байтом, в форме двоичного, восьмеричного или шестнадцатеричного кодов. Д. применяется для анализа работы программных систем. Например, Д., полученный после аварийного завершения программы, служит материалом для выявления причин аварийного завершения. 2. То же, что дамп памяти. 3. То же, что дамп экрана
ДАМП ПАМЯТИ, дамп [memory dump, dump]
 Копия содержимого оперативной памяти на внешнем носителе (бумаге, магнитном диске и т. п.)
ДАМП ЭКРАНА, дамп [screen dump, dump]
 Копия содержимого экрана на внешнем носителе (бумаге, магнитном диске и т. п.)
ДАННЫЕ [data]
 I. Информация, подготовленная для передачи, хранения и обработки в вычислительной машине, т. е. представленная в символьной (цифровой) форме. Примерами Д. являются закодированные для ввода или уже введенные в компьютер текст, речь, изображение, таблицы всевозможных величин и т. п. 2. В контексте отдельной программы или пакета программ слово "Д." означает все обрабатываемые программой объекты, отличные от ее команд. Эти Д. можно разбить на два класса: Д., определяемые программистом, и Д., определяемые системой. Д., определяемые программистом, состоят из элементов, которые программист явно определяет и над которыми производит действия в своей программе, например, числа, массивы файлы и т. д. Д., определяемые системой, состоят из тех элементов, которые формируются для служебных целей во время выполнения программы, например, стеки точек возврата, дескрипторы структур данных, списки свободного пространства памяти, буферы ввода-вывода и т. д. Эти Д. обычно генерируются автоматически без явного указания программиста (часто он об этом даже не подозревает). 3. В качестве Д. могут выступать и команды и лаже программы. Например, коды программ иа исходном языке системы программирования являются Д. для компилятора, а коды результирующей объектной программы - Д. для компоновщика.
ДВОИЧНОЕ ПРЕДСТАВЛЕНИЕ [binary-coded representation]
 редставление информации в двоичном коде. Д. п. является основным способом представления данных в памяти ЭВМ
ДВОИЧНОЕ ЧИСЛО [binary number]
 Число, представленное в двоичной системе счисления
ДВОИЧНЫЙ КОД [binary code]
 Код, символами которого являются 0 и 1
ДВОИЧНЫЙ РАЗРЯД [binary digit, bit]
 Место (позиция), занимаемая символом 0 или 1 в двоичном коде
ДВОЙНОЕ СЛОВО [double word]
 Элемент данных, состоящий из двух смежных машинных слов, который воспринимается памятью, арифметическим устройством или устройством управления ЭВМ как единое целое, имеющее определенное смысловое содержание. Например, числа с плавающей точкой одинарной и двойной точности математический сопроцессор персонального IBM-совместимого компьютера различает как слово (занимает 4 байта) и Д. с. (занимает 8 байт), соответственно.
ДВОЙНОЙ ЩЕЛЧОК [double click]
 Действие, которое заключается том, чтобы дважды быстро нажать и отпустить кнопку неподвижной мыши. Д. щ. применяется при выборе и активизации объектов, запуске программ и т. п.
ДИНАМИЧЕСКАЯ СТРАНИЦА WEB [dynamic web page]
 Страница Web, предназначенная для облегчения доступа к программам и данным. Д. с. W. как правило, содержит очень мало собственно текста. Вместо этого зде имеются встроенные ссылки на другие приложения, из которых Д. с. W. влекает информацию по запросам пользователя. Например, Д. с. W. моя предоставлять пользователю информацию определениого сорта, извлекая из различных, уже существующих во Всемирной паутине, баз данных
ДИНАМИЧЕСКИ ЗАГРУЖАЕМАЯ [dynamic link library (DLL) ]
 To же, что библиотека динамической компоновки
ДИНАМИЧЕСКИЙ ОБМЕН ДАННЫМИ [dynamic data exchange (DEE) ]
 Средство, позволяющее приложениям Windows обмениваться друг с другом данными и командами. Суть Д. о. д. состоит в следующем. Вначале первое приложение должно установить связь со вторым. Затем первое приложение может посылать второму команды для исполнения, данные для испольювания, запрашивать и получать результаты. В конце сеанс связи по DDЕ. должен быть завершен. Д. о. д. поддерживают практически все приложен Windows, начиная с самых первых версий операционной системы Windows. Например, копирование данных из документа одного приложения в документ другого приложения с помощью буфера обмена в Windows основано на Д. о. д. В настоящее время Д. о. д. постепенно вытесняется более современными средствами, такими как связывание и внедрение объектов (OLE). Одна из причин состоит в том. что DDE не обеспечивает достаточных средств дли обработки исключительных ситуаций.
ДИНАМИЧЕСКОЕ РАЗМЕЩЕНИЕ МОДУЛЕЙ [dynamic modules allocation]
 Размещение программных модулей в свободных областях оперативной памяти при динамической загрузке программы. При Д. р. м. связи между ними устанавливаются динамически, операционной системой в процессе динамической зафузки. Ср. оверлейное размещение модулей
ДИНАМИЧЕСКОЕ РАСПРЕДЕЛЕНИ ПАМЯТИ [dynamic memory allocation]
 Способ распределения оперативной памяти, при котором она выделяется и освобождается но запросам профаммы в ходе ее выполнения.
ДИНАМИЧЕСКОЕ РАСПРЕДЕЛ РЕСУРСОВ [dynamic resource allocation]
 Способ распределения ресурсов, при котором они выделяются ч освобождаются по запросам профаммы в ходе ее выполнения. Противон статическое распределение ресурсов.
ДИРЕКТИВА [directive]
 Предложение или команда, управляющие вычислительной системой или ее компонентами. Д. содержит указания системе о том, какие необходимо выполнить действия. Д. могут вводиться оператором ЭВМ или пользователем, а также содержаться в программе. В некоторых языках программирования предусмотрены Д., позволяющие управлять работой препроцессора, компилятора, компоновщика и др. компонентов системы программирования. Например, в языке ассемблера с помощью Д. управляют последующей компоновкой профаммы, а в языке Си с помощью Д. управляют работой препроцессора.
ДИРЕКТОРИЙ [directory]
 To же, что каталог
ДИСК БЕРНУЛЛИ [Bernoulli disk]
 Накопитель на сменяемых гибких магнитных дисках большой емкости, разработанный компанией Iomega. В Д. Б. головка записи-чтения поддерживается над диском воздушным потоком в соответствии с принципами аэродинамики, сформулированными швейцарским математиком Д. Бернулли. По своим характеристикам Д. Б. не уступает винчестерскому диску, но в отличие от него имеет сменный носитель данных, похожий на обычную дискету, и в несколько раз превосходит его по долговечности. Разновидностями Д. Б. являются накопители Zip и Jaz, имеющие емкость 90, 100, 150, 230 Мб и 1 Гб на дискету
ДИСКЕТА [diskette].
 To же, что гибкий магнитный диск
ДИСКОВОД [disk drive]
 Устройство для записи и считывания информации с магнитных дисков. Включает в себя механизм вращения дисков, головки записи-чтения, устройство, управляющее перемещением головок, и соответствующие электронные схемы. Существуют Д., предназначенные либо для одного диска, либо для пакета магнитных дисков
ДИСКРЕТНЫЙ СИГНАЛ [discrete signal]
 To же, что цифровой сигнал
ДИСПЕТЧЕР [dispatcher, manager]
 Профамма, управляющая распределением ресурсов. Например, Д. задач обслуживает очередь на использование центрального процессора. Согласно приоритету выбирает задачи из очереди и перелает им управление. См. диспетчер файлов
ДИСПЕТЧЕР ФАЙЛОВ [file manager]
 Модуль операционной системы, упраатяюший размещением файлов в физической памяти и доступом к ним. Л- ф. обрабатывает запросы на открытие и закрытие файлов, ведет список установленных дисков и т. д.
ДИСПЛЕЙ [display]
 Устройство визуального отображения информации, обрабатываемой компьютером. Представляет собой устройство вывода в виде экрана или табло, на котором можно временно отображать информацию как в буквенно-цифроной, так и в фафической форме. В настоящее время наиболее широкое распространение получили Д. на основе электроннолучевой трубки. Под управлением ЭВМ в качестве Д. может работать лаже бытовой телевизор, однако специализированные Д. (мониторы) дают более четкое и устойчивое изображение, что позволяет избежать излишней утомляемости пользователя. Д. может быть цветным или монохромным (черно, белым). Основные характеристики Д. - размер по диагонали (в дюймах) и размер зерна (в миллиметрах). Информация, выводимая на экран Д., может быть текстовой (буквенно-цифровой) или графической (графики, диаграм. мы, рисунки и пр.). Работой Д. управляет адаптер дисплея, преобразующий данные, поступающие из ЭВМ в цифровой форме, в соответствующее изображение на экране. От адаптера дисплея зависит разрешающая способность -количество пикселов (точек), на которые разбит экран (указывается в'виде произведения числа точек по горизонтали на число точек по вертикали) Современные видеоадаптеры обеспечивают разрешающую способность до 1024x768 пикселов и выше. В большинстве Д. имеются возможности для выделения или разделения различных участков текста или изображения путем мерцания, яркого свечения, или окраски. Для уменьшения вредного воздействия излучения от Д. иногда применяется защитный экран. В настоящее время разработаны дисплеи с низким излучением, маркированные Low radiation (LR). В портативных компьютерах применяются дисплеи на жидких кристаллах.
ДИСПЛЕЙ НА ЖИДКИХ КРИСТАЛЛАХ, жидкокристаллический дисплей [liqid crystal displai (LCD) ]
 Дисплей, изображение на котором создается посредством управляемых электронными сигналами жидких кристаллов. Жидкие кристаллы обладают способностью под воздействием электрического поля приобретать молекулярную структуру, пропускающую или не пропускающую поляризованный свет. Плоский экран Д. и. ж. к. состоит из тонкого слоя жидкокристаллических ячеек, заключенных между сетками горизонтальных и вертикальных электродов. Этот слой в свою очередь помещается между двумя фильтрами-поляризаторами света. По командам компьютера между электродами образуется электрическое поле, выборочно "включающее" или "выключающее" ячейки (пикселы). Тем самым формируется изображение на экране. У персональных компьютеров экран может освещаться расположенной сзади электролюминесцентной панелью и бывает цветным или монохромным
ДИСТРИБУТИВ [distribution kit]
 Программный продукт в виде, поставляемом производителем (чаще всего на компакт-дисках). Дистрибутивный диск, как правило, содержит саму программу и инсталлятор (обычно с именем install или setup) для установки программы на жестком диске и настройки ее параметров. Иногда применяются дистрибутивные дискеты
ДЛИНА [length]
 1. Размер области памяти, отводимой объекту (программе-блоку данных, записи, машинному слову, регистру и т. д.). Измеряется в битах-байтах и т. п. 2. Число элементов, образующих объект. Например, длина блока данных- это и размер в байтах области памяти, отведенной блок}' данных, и число машинных слов в блоке; длина файла - это и количество байтов, занимаемых файлом в памяти, и число блоков в файле; длина дорожки - это и информационная емкость дорожки диска и число размешенных на ней секторов.
ДЛИНА РЕГИСТРА [register length]
 To же, что емкость регистра
ДОКУМЕНТ [document]
 1. Важная деловая информация, облеченная в материальную форму. Например, Д. может являться содержащаяся на носителе данных в зафиксированном виде текстовая, графическая или звуковая информация (см. электронный документ). Д. может быть официальным и неофициальным. В официальных Д. информация оформляется установленным порядком и имеет в соответствии с действующим законодательством правовое значение. 2. Текст, подготавливаемый в текстовых процессорах или текстовых редакторах
ДОКУМЕНТАЦИЯ ПРОГРАММНОГО ПРОДУКТА, программная документация [software documentation].
 Совокупность документов, описывающих назначение, структуру и применение программного продукта. Д. п. п. предназначена для облегчения использования программного изделия и включает как печатные документы (описания, руководства, учебники, справочники и т. п.), так и электронные документы (выводимые на экран и распечатываемые тексты, а также обучающие программы, средства диалоговой подсказки и т. п.)
ДОКУМЕНТ WEB. документ WWW [Web document, WWW document].
 Документ на языке HTML. Д. W. составляют информационную основу Всемирной паутины. Они содержат гипертекст, позволяющий пользователю, указав на выделенное слово или фразу, получить доступ к данным, перейти в другую часть данного документа или в другой Д. W., связанный с данным гиперссылкой. Д. W. может также содержать данные гипермедиа, включающие текст, изображения, звук. Доступ к Д. W., их чтение или воспроизведение производится с помощью браузеров Интернет. С понятием Д. W. тесно связны понятия страницы Web и сайты Web- Значения этих терминов в настоящее время жестко не определены. Чаше всего термин "страница Web" является синонимом термина Д. W., а термин "сайт Web" относится к набору страниц, объединенных тематически, либо принадлежащих одной организации, одному автору или пользователю.
ДИСКЕТА [diskette]
 То же, что документ WEB
ДОМЕН [domain]
 1. В системах управления базами данных - множество допустимых значений данного атрибута. Например, Д. атрибута "код города" может быть список всех допустимых трехзначных числовых телефонных кодов городов России, а Д. атрибута "день года" - список всех трехзначных чисел от 001 до 366. Понятие Д. имеет также скрытый смысл. При испольвании реляционных баз данных часто приходится объединять два отношения или две таблицы, основываясь на соответствующих значениях в столбцах, обладающих одним и тем же Д. При этом нельзя объединять две таблицы на базе атрибутов, принадлежащих разным Д., даже если эти атрибуты имеют одинаковый формат. 2. Составная часть имени компьютера в сети Internet.
ДРАЙВЕР, управляющая программа
 Обычно это программа операционной системы, обеспечивающая взаимодействие исполняемой программы с отдельным устройством и способствующая его удобному использованию. Например, сущестуют Д. клавиатуры, дисплеи, мыши, принтеры и т.п. Д. принимает запросы программ на обращение к устройству и преобразует их в команды управления устройством, а также обрабатывает прерывание от обслуживаемого устройства. При этом он учитывает конструктивные особенности устройства и особенности его работы в реальном времени. Таким образом Д. является связующим звеном между программой и устройством. Д. может быть оформлен как резидентная программа или как загружаемый Д. На ряду с реальными Д. может обслуживать и вертуальные устройства, как бы имитируя реальное физическое устройство. Д. считаются также программы управляющие дополнительной памятью компьютера и программы, управляющие другими программами, т.е. вызывающие их и задающие им входные параметры.
ЖЕСТКИЙ ДИСК [hard disk]
 1. То же, что жесткий магнитный диск. 2. То же, что винчестерский диск
ЖЕСТКИЙ МАГНИТНЫЙ ДИСК, жесткий диск (hard disk]
 Магнитный диск, представляющий собой плоский диск из алюминиевого сплава, поверхность которого покрыта магнитным материалом. Для чтения и записи данных Ж. м. д. помещается в специальное устройство - дисковод, снабженное магнитными головками записи-чтения. В дисководе диск постоянно вращается с большой скоростью. Данные записываются на поверхности Ж. м. д. вдоль концентрических окружностей, называемых дорожками. Для выбора нужной дорожки подвижная головка записи-чтения устанавливается в соответствующую позицию. Современные Ж. м. д. выполняются по винчестерской технологии.
ЖИДКОКРИСТАЛЛИЧЕСКИЙ ДИСПЛЕЙ [liquid crystal display (LCD)]
 To же. что дисплей на жидких кристаллах


Толковый словарь компьютерной лексики

ЕМКОСТЬ РЕГИСТРА, длина регистра, размер регистра [register capacity register length, register size]. | Максимальное количество информации, которую можно разместить в регистре. Измеряется в битах, байтах, цифрах или машинных словах
ЕМКОСТЬ ПАМЯТИ, объем памяти [memory capacity] | Максимальное количество информации, которое может храниться в запоминающем устройстве. Е. п. определяет способность памяти разместить определенное количество единиц данных. Е. п. может измеряться в словах, битах, байтах и г ц Е. п. ЭВМ должна соответствовать возможностям ее центрального процессора. Так в персональных IBM-совместимых компьютерах на базе процессора 80286 трудно разумно использовать больше 1 Мб оперативной памяти. В компьютерах на базе процессоров 80386, 80486 и Pentium необходимый объем оперативной памяти определяется по потребностям используемых программ.
ЕСТЕСТВЕННЫЙ ЯЗЫК [natural language] | Язык общения между люль-правила которого основываются на текущем употреблении, а не на TOIU предварительном описании. Например любой национальный разговори язык. Е. я. противопоставляется формализованный язык.


Толковый словарь компьютерной лексики

ЗАГРУЗКА ПО ЛИНИИ СВЯЗИ [downloading]
 Процесс передачи копии файла из удаленного компьютера в компьютер, выдавший запрос. Местный компьютер через свой молем выдает запрос и поручает удаленному компьютеру начать передачу данных, а затем сохраняет поступивший файл на диске Термин 3. п. л. с. употребляется также для обозначения передачи блок-данных в подчиненное устройство, например, файла в принтер.
ЗАГРУЗКА ПРОГРАММЫ [program loading]
 Считывание программы " внешнего запоминающего устройства в оперативную память, настройка адресов и, возможно, запуск. 3. п. выполняется под управлением загрузчика - специальной программы, обычно входящей в состав операционной системы. в процессе загрузки программа записывается на свободное место оперативной памяти, то производится настройка указанных в программе логических адресов, которые в зависимости от места в оперативной памяти, занимаемого программой и отводимого се данным, преобразуются в физические адреса. До момента запуска программа может загружаться целиком, а может происходить загрузка части программы. Тогда отсутствующие в оперативной памяти программные модули загружаются по мере обращения к ним
ЗАГРУЗОЧНЫЙ МОДУЛЬ [load module]
 Программный модуль в виде, пригодном для загрузки и выполнения. 3. м. получается из объектного модуля при редактировании связей и представляет собой программу в виде последовательности машинных команд, имеющую принятый для данной операционной системы формат. 3. м. обычно выполнен в относительных (иногда в абсолютных) адресах и содержит информацию для их настройки загрузчиком в соответствии с отведенной для него областью оперативной памяти. 3. м. являются исполняемые файлы
ЗАГРУЗЧИК [loader]
 Программа, управляющая загрузкой. Обычно 3. выполняет следующие основные функции: 1) распределяет пространство оперативной памяти для программы; 2) настраивает адреса подготовленной компилятором и компоновщиком объектной программы, заменяя все относительные адреса соответствующими адресами фактически распределенной памяти; 3) физически размешает подготовленную версию машинного кода программы в памяти и передает управление на первую команду программы. Существуют программы, сразу выполняющие и компоновку и загрузку.
ЗАДАНИЕ [job]
 Совокупность программ и их данных, обрабатываемая опе- рационной системой как единое целое. Содержание 3. определяется пользователем в виде последовательности управляющих операторов, определяющих выполняемые программы и используемые ими данные.
ЗАДАЧА [task]
 Задание вычислительной системе, представленное в виде программы или части программы и данных, которое операционная система рассматривает как единое целое при распределении ресурсов. В ряде опера-с 10Н"Ы* систем термин "3". совпадает с понятием "процесс", в других — c понятием "задание" 2. Процесс выполнения этого задания
ЗАКЛАДКА [bookmark]
 Место в тексте или выделенный фрагмент в документе, которому присвоено имя. 3. используются во многих текстовых процессорах, например в Microsoft Word, а также в других приложениях. Имя З. может использоваться для перехода к помеченному месту документа, для и нумерации перекрестных ссылок и пр.
ЗАКОММЕНТИРОВАТЬ [comment out]
 Временно отменить действие одного или нескольких операторов программы, превратив их в комментарий Для этого достаточно ограничить эти операторы в соответствии с синтаксис, сом комментария, предусмотренным языком программирования. Например в языке Паскаль нужно заключить исключаемый оператор или последовательность операторов в скобки ( .. \ или с....*). Таким приемом часто пользуются для локализации ошибки при отладке программы. Чтобы восстановить первоначальный вид программы, достаточно убрать ограничители
ЗАКРАСКА [filling]
 В компьютерной графике— изменение цвета пикселов, расположенных внутри изображенного на экране графического объекта. Ср. заливка
ЗАКРЫТИЕ ФАЙЛА [closing of a file, file closing]
 Операция завершении pa-боты программы с файлом. При ее выполнении все связанные с файлом области буферной памяти очищаются, а информация о произведенных HJV;. нениях данных заносится во внешнюю память (обычно на диск). Противоп. открытие фай,1а.
ЗАКРЫТЫЙ ФАЙЛ (closed file]
 Файл, над которым выполнена опера ля закрытия файла. Чтобы записи 3. ф. снова стали доступны для чтения и обработки, его надо открыть. Противоп. открытый файл ЗАЛИВКА [flood filing] В компьютерной графике— однотонная закраска изображенного на экране плоского графического объекта, ограниченного четким контуром.
ЗАМОК [lock]
 1. Ключ защиты памяти, определенная структура данным или программа, используемые для управления доступом к информации. 2. Операция, позволяющая только одному процессу иметь доступ к определенному ресурсу
ЗАПИСЬ [writing, record]
 1. Процесс запоминания (фиксирования) данных В запоминающей среде или на носителе данных (writing). 2. Результат Процесса записи (record). 3. Единица обмена данными между программой и внешней памятью, т. е. совокупность данных, совместно пересылаемых на периферийные устройства или с периферийных устройств одним оператором ввода-вывода. Поэтому файлы, хранимые во внешнем ЗУ, часто представляют собой набор 3. Так, файл данных задачи, которые должны вводиться порциями в процессе ее выполнения, состоит из набора 3. Каждая из таких 3- содержит определенную порцию данных. Например, файл данных о служащих фирмы состоит из 3., содержащих информацию о каждом служащем. Существует различие между совокупностью логически связанных данных и и* физическим представлением в запоминающих устройствах. Как то, так $ другое называют 3., а чтобы различать эти понятия, обычно л первом с.чу40 употребляют термин логическая 3. а во втором — физическая 3., которая представляет собой блок данных и на самом деле может состоять из нескольких логических 3. 4. В базах данных — структурированная совокупность составляющие которой, обычно называемые полями, могут иметь и значение. При этом допускается выполнение действий как над всей Я так и над ее полями. См. кортеж. 5. В языках программирования высокого уровня (например, в Паскале) — структурированный тип данных, компоненты значений которого, обычно называемые полями, могут иметь имя и принадлежать к различным типам данных. В таких языках допускается выполнение действий как над всей 3., так и над ее полями.
ЗАПЛАТА [patch]
 Последовательность операторов или команд, добавленная к коду готовой программы для исправления имеющихся недостатков. Обычно добавляемая последовательность вносится в виде отдельного блока или файла, а в нужном месте программы помещается команда перехода. Часто 3. является средством добавления новой функции к существующей версии программы ло выхода новой версии, где эта функция будет вставлена обычным путем
ЗАПОМИНАЮЩАЯ СРЕДА [storage medium]
 l. Материал, обладающий физическими свойствами, позволяющими записывать, хранить и считывать информацию. Например магнитный состав, которым покрывают магнитные диски. 2. Совокупность однотипных носителей данных, входящих в состав запоминающего устройства. Например, носители данных, составляющие оперативную память, обычно называют 3. с.
ЗАПОМИНАЮЩЕЕ УСТРОЙСТВО (ЗУ) [storage device]
 Техническое устройство, реализующее память. Это любое устройство, способное записывать данные и сохранять их для последующего считывания. ЗУ состоят из запоминающей среды или носится данных и технических средств, осуществляющих запись информации в среду или на носитель и ее считывание. Например. ЗУ на гибких магнитных дисках состоит из дискет и дисковода. В компьютерах применяются разнообразные ЗУ с различными емкостями и скоростями работы. От ЗУ на полупроводниковых кристаллах со временем выборки, измеряемым в долях наносекунд (10~9 сек) до устройств на магнитных лентах со временем выборки, измеряемым в секундах. Диапазон емкости различных устройств также широк. От 16-битовых регистров процессора до винчестеров, способных хранить несколько гигабайт. Существуют постоянные запоминающие устройства, предназначенные только для считывания
ЗАПРОС [request, query]
 Обращение с целью получения ответа. Это может сигнал, с помощью которого операционная система запрашивает периферийные устройства об их готовности к обмену данными. Это может быть Ращение пользователя к базе данных, содержащее задание на поиск, чте-16 и обработку нужной информации. Это может быть обращение програм-11 к устройству ввода с целью получения данных.
ЗАПУСК ПРОГРАММЫ [program start]
 Загрузка программы в память и передана управлении команде программы, выполняемой первой
ЗАРЕЗЕРВИРОВАННОЕ СЛОВО [reserved word]
 To же, что ключевое слово
ЗАХВАТ, монопольное использование [lockout]
 Использование данного ресурса (файла, области памяти, порта ввода-вывода и т. п.) одним с запрещением обращения к этому ресурсу других процессов. 3. способом организации контролируемого доступа к совместно используемому ресурсу, гарантирующим, что в данный момент только одна программа использует этот ресурс
ЗАГРУЗКА [loading]
 Считывание данных из одного запоминающего устройства в другое, обычно обладающее большей оперативностью. Чаше всей, этот термин обозначает копирование программ и данных из внешнего запоминающего устройства в оперативную память
ЗАГРУЗКА ОПЕРАЦИОННОЙ СИСТЕМЫ [operating system loading]
 Считывание операционной системы из внешнего запоминающего устройства и оперативная память, ее настройка и запуск. Обычно 3. о. с. запускается специальной программой, хранящейся в постоянном запоминающем устройстве компьютера. Эта программа сначала производит тестирование устройств компьютера, а затем считывает из внешнего запоминающего устройства и оперативную память программу загрузчик основных модулей операционной системы и передает ей управление. После того как основные модули окажутся в оперативной памяти, дальнейшая загрузка и настройка составных частей системы может осуществляться по мере считывания ее модулей. При этом управление загрузкой может передаваться от одного считанного модуля к другому. Например, 3. о. с. MS-DOS IBM-совместимых персональных компьютеров выполняется при включении компьютера и при перезагрузке, вызванной нажатием кнопки Reset на системном блоке или сочетании клавиш + + . Перед началом 3. о. с. компьютер выполняет тестирование своих устройств. Затем производится 3. о. с. с системного диска если он вставлен в дисковод, или с жесткого диска, если гибкий системный диск отсутствует. Сначала программа из ПЗУ считывает с диска программу загрузчик, та, в свою очередь загружает в оперативную память основные модули операционной системы lo.sys и Ms-dos.sys и передает им управление Затем загружаются загружаемые драйверы и устанавливаются параметры операционной системы, указанные в файле конфигурации config.sys. После этого управление принимает командный процессор command.com, который приводит в действие файл автозапуска autoexec.bat. В результате его работы устанавливается маршрут поиска исполняемых файлов и загружаются резидентные и обычные программы, указанные в autoexec.bat. На этом З.о.с завершается
ЗАВЕРШЕНИЕ ПРОГРАММЫ [completion, termination]
 Последняя фаза обработки программы операционной системой, в ходе которой освобождаются решенные программой ресурсы, выводятся результаты, очищается выделенная программе оперативная память. 3. п. может быть нормальным (после oспешною выполнения программы) и аварийным
ЗАВЕРШЕНИЕ ТРАНЗАКЦИИ [commitment, transaction commitment]
 Действия, выполняемые СУБД при обработке транзакций в том случае, когда все операции транзакции успешно выполнены. 3. т. заключается в том, что результаты всех операций транзакции фиксируются в базе данных, блокировка данных снимается, и данные становятся доступными для обработки другим транзакциями.
ЗАВИСАНИЕ [hang-up, starvation]
 1. Состояние вычислительной системы, при котором она перестает выдавать результаты и реагировать на запросы извне, например, на нажатие пользователем персонального IBM-совместимого компьютера клавиш и , или на другие внешние прерывания. 3. может быть вызвано аппаратными сбоем, ошибками в программном обеспечении или попыткой обращения прикладной программы к устройству, не подключенному к центральному процессору. 2. Состояние, характеризующееся аномально большим временем ожидания задачи или процесса при обращении к какому-либо ресурсу
ЗАГЛУШКА [module stub]
 Фиктивная подпрограмма, имитирующая одну или несколько функций временно отсутствующего модуля разрабатываемой программы. Например. 3. применяются при модульном программировании для того, чтобы можно было проводить компиляцию, тестирование и отладку незаконченной программы, не дожидаясь, когда некоторые отсутствующие " ней модули будут разработаны в надлежащем виде и испытаны. В зависимости от функций заменяемого модуля 3. может выдавать либо правдоподобный результат (например, значения из таблицы), либо некоторое сообщение 'например, фиксирующее вызов отсутствующей подпрограммы)
ЗАХВАТ ЗАПИСИ, блокирование записи [record locking]
 Монопольное использование записи базы данных одной прикладной программой. При этом для любой другой программы запись становится недоступной или доступной только для чтения.
ЗАЦИКЛИВАНИЕ [loophole]
 Образование в процессе выполнения программы непредусмотренного программистом бесконечного цикла. 3. может явиться результатом как синтаксической ошибки, так и логической ошибка, возникающей обычно из-за невозможности предусмотреть все ситуации, которые могут случиться, и приводящей к повтору одних и тех же действий
ЗАЦИКЛИВАНИЕ ПРОГРАММЫ [cycling]
 Бесконечное повторение одной и той же последовательности команд в ходе выполнения программы, которое может быть прекращено только принудительным прерыванием извне (оператором ЭВМ или таймером по истечении отведенного программе ресурса времени). Чаше всего 3. п. является следствием неправильной передачи управления или неверной организации цикла.
ЗАШИТЫЕ ПРОГРАММЫ [firmware]
 To же, что встроенные программы
ЗАЩИТА ДАННЫХ [data protection]
 Меры, направленные против несанкционированного доступа к информации, хранящейся в памяти компьютера -так называемого компьютерного браконьерства. Одним из способов 3 д., хранящихся в вычис.ште.1ьнои системе, является использование символьных паролей или цифровых кодов. В этом случае вычислительная система допускает к информации только пользователей, знающих пароль. Кроме того, в памяти может храниться специальная таблица, в которой перечислены права каждого пользователя на доступ к тем или иным данным. В соответствии с этой таблицей разрешается (или не разрешается) доступ конкретному пользователю к конкретным данным. При этом может производиться регистрация всех попыток и несанкционированного доступа. Для большей надежности информацию можно хранить в зашифрованном виде. Для этого применяются специальные шифры (тайнопись, криптография).
ЗАЩИТА ОТ КОПИРОВАНИЯ [copy protection]
 Меры, предотвращающие копирование программного продукта с целью его распространения или использования без согласия владельца авторских прав. 3. о. к. может обеспеспечивать не только некопируемость дискеты дистрибутива при помощи стандартною дисковода, но и невозможность применения стандартных средств отладки или трассировки программ с целью изучения логики работы защищенной программы. 3. о. к. реализуется как программными, так и аппарат-ным'1 средствами. Чтобы предотвратить копирование дистрибутивной дискеты часто применяются нестандартные нумерация и форматирование ее дорожек Кроме того, программный продукт обычно содержит закодированную информацию (ключ), которая теряется при попытке копирования или отладки программы стандартными средствами. После этого программа становится непригодной к использованию. Существуют специально разработанные различными фирмами системы 3. о. к. Некоторые авторы дополняют систему зашиты блоком ответной реакции, который производит различные карательные действия при попытке использования нелегальной копии.
ЗАЩИТА ПАМЯТИ [memory protection]
 Меры, не позволяющие выполняемой задаче получить доступ к "чужой" памяти, т. е, к памяти, которая за ней не -закреплена. При обращении к памяти осуществляется проверка принадлежности адреса, по которому происходит обращение, к адресному пространству задачи. Широко распространен способ 3. п., при котором программе присваивается ключ защиты, который должен совпадать с ключами защиты памяти всех блоков памяти, выделенных данной программе. Эти меры предотвращают порчу хранящихся в памяти программ и данных другими программами. 3, п. реализуется как аппаратными, так и программными средствами. Для оперативной памяти зашита реализуется аппаратно, чтобы поддерживать ее высокое быстродействие; для более медленных запоминающих устройств 3. п. может быть полностью реализована программно. В настоящее время разработаны различные механизмы контроля над доступом к какой-либо области памяти с учетом допустимых режимов обращений. Широко распространен такой вид аппаратной 3. п., как использование ограничительных регистров, содержимое которых обозначает границы области памяти с определенной формой доступа. Например, область, предназначенная Для хранения подпрограмм общего использования, может быть отмечена операционной системой, как доступная только для исполнения, и данные из нее будут только считываться либо как команды, либо как операнды исполняемых команд. Для защиты виртуальной памяти также используются дескрипторы страниц или сегментов. Нарушение системы 3. п. исполняемой программой обычно вызывает ее аварийное завершение.
ЗАЩИЩЕННЫЙ РЕЖИМ [protected mode]
 Основной режим работы и процессоров IBM-совместимых персональных компьютеров, при котором г грамме доступны только определенные области оперативной памяти, а области памяти, используемые дли специальных целей, защищены. В этом жиме можно полноценно использовать всю оперативную память. Возможно мультипрограммирование
ЗВЕЗДООБРАЗНАЯ СЕТЬ [star network]
 To же, что радиальная сеть
ЗВУКОВАЯ КАРТА [sound card]
 To же, что звуковая плата
ЗВУКОВАЯ КОЛОНКА [speaker]
 Акустическая аппаратура, присоединяемая к звуковой карте для воспроизведения аналогового звукового сигнала. Как правило, к звуковой карте присоединяются лае 3. к. для создания стереоэффекта. Возможно присоединение к звуковой карте компьютера обычных устройств воспроизведения звука, применяемых в бытовой аудиотехнике, но чаще используют 3. к., специально сконструированные для присоединения к компьютеру.
ЗВУКОВАЯ ПЛАТА, звуковой адаптер, звуковая карта [sound board, sound card]
 Плата, позволяющая с помощью компьютера записывать и воспроизводить звуки, синтезировать музыку, управлять внешней акустической аппаратурой, подключенной к компьютеру. Все 3, п. по назначению можно разделить на три группы: чисто звуковые, чисто музыкальные и комбинированные. Чисто звуковые позволят только записывать или воспроизводить непрерывный звуковой поток, наподобие магнитофона. Вся работа по запоминанию записываемого и подготовке воспроизводимого потока возлагаете» на программное обеспечение. Некоторые платы имеют встроенные сигнальные процессоры для обработки звука в процессе его записи или воспроизведения. Чисто музыкальные содержат только музыкальный синтезатор. Такие платы ориентированы, прежде всего, на генерацию относительно коротких музыкальных звуков по командам от центрального процессора; при этом звуки либо создаются заново, либо воспроизводятся звуки, цифровые колы которых были заранее помещены в память синтезатора. Музыкальные платы не имеют возможности записи звука и не рассчитаны на воспроизведение непрерывного звукового потока. Некоторые музыкальные платы содержат эффект-процессор для обработки создаваемого звука. Комбинированные или звукомузыкальные 3. п. располагают блоком цифровой записи/воспроизведения, называемым также цифровым каналом, или трактом, блоком музыкального синтезатора, и блоками, осуществляющими регулирование уровней, коммутацию, усиление и сведение звуковых сигналов.
ЗНАК ЛОГИЧЕСКОЙ ОПЕРАЦИИ [logical operation character, logical operator]
 Символ, определяющий логическую операцию. Как правило, это символы: "НЕ", "NOT", 1 — для операции отрицания; "И". "AND", л — для логического "и"; "ИЛИ", "OR", v — для логического "или"; "ЭКВИВАЛЕНТНО", = — для операции эквивалентности.
ЗНАКОГЕНЕРАТОР [character generator]
 Составная часть адаптера дисплея, преобразующая коды символов в их графическое изображение на экране дисплея. 3. используется в текстовом режиме работы адаптера дисплея. В 3. имеется таблица колов и соответствующих им изображений символов, занимающих одно знакоместо на экране. По поступившему из видеопамяти коду 3. "выбирает" из таблицы символ, изображение которого затем формируется на экране. Программист может программировать 3., изменяя в таблице изображения символов программным способом. Например, изменение шрифтов при работе в текстовом редакторе осуществляется путем смены таблиц
ЗНАКОМЕСТО [font reticle]
 Прямоугольный участок поверхности экрана Дисплея или бумаги, в котором размещается один выводимый знак. См. текстовый режим
ЗНАЧАЩАЯ ЦИФРА, значащий разряд [significant digit]
 Любая цифра числа, записанного в позиционной системе счисления, начиная с первой слева ненулевой цифры. Это означает, что значащей называется любая цифра, отличная от нуля, и нуль, если он не стоит в числе до его первой отличной от нуля цифры. Например, в числе 0.012030 3. ц. являются последние пять цифр. Первые два нуля не являются 3. ц. Они сами по себе не представляют количественную величину, а служат для определения разрядов других цифр (при записи этого же числа в виде 1.2030 * 10-2 они отсутствуют). Остальные два нуля показывают, что в этих разрядах числа содержится именно 0. а не 1 не 2 и г. д. в случае, если в данном числе последний ноль не является значащим, то оно должно быть записано в виде 0.01203. При написании больших целых чисел, например, числа 456000, нули справа могут служить как для обозначения 3. ц., так и для определения разрядов остальных цифр.
ЗНАЧАЩАЯ ЦИФРА, значащий разряд [significant digit]
 Любая цифра числа, записанного в позиционной системе счисления, начиная с первой слева ненулевой цифры. Это означает, что значащей называется любая цифра, отличная от нуля, и нуль, если он не стоит в числе до его первой отличной от нуля цифры. Например, в числе 0.012030 3. ц. являются последние пять цифр. Первые два нуля не являются 3. ц. Они сами по себе не представляют количественную величину, а служат для определения разрядов других цифр (при записи этого же числа в виде 1.2030 * 10-2 они отсутствуют). Остальные два нуля показывают, что в этих разрядах числа содержится именно 0. а не 1 не 2 и г. д. в случае, если в данном числе последний ноль не является значащим, то оно должно быть записано в виде 0.01203. При написании больших целых чисел, например, числа 456000, нули справа могут служить как для обозначения 3. ц., так и для определения разрядов остальных цифр.


Толковый словарь компьютерной лексики

ИНДЕКСИРОВАННАЯ ПЕРЕМЕННАЯ [subscripted variable]
 To же, что элемент массива
ИНДЕКСНАЯ АДРЕСАЦИЯ, адресация с индексированием [indexed addresing]
 Метод адресации, при котором формирование исполнительного адреса осуществляется путем добавления к базовому адресу содержимого индексного регистра
ИНДЕКСНЫЙ РЕГИСТР, регистр индекса, регистр В, регистр ВХ [index
 Регистр центрального процессора, содержимым которого является значение индекса, используемое для индексной адресации
ИНДИКАТОР [indicator]
 1. Элемент данных, отражающий текущее состояние устройства или данных. Например, поле данных, в которое системная или прикладная программа помещает код ошибки, называют И. ошибки. 2. Циферблат или лампочка, сигнализирующие о состоянии устройства. Например, лампочку на дисководе, загорающуюся во время обращения к диску, называют И. активности дисковода. 3. Элемент графического интерфейса пользователя, показывающий ход выполнения некоторого процесса. Например, на рис. И.З показано диалоговое окно с И.
ИНЖЕНЕР-ПРОГРАММИСТ [programmer-engineer]
 1. Инженер, исполняющий функции программиста. 1. Инженер, имеющий квалификацию программиста
ИНЖЕНЕРНАЯ КОМИССИЯ ИНТЕРНЕТ [Internet Engineering Task Force (IETF)]
 To же, что Инженерный консорциум разработчиков стандартов Интернет
ИНЖЕНЕРНЫЙ КОНСОРЦИУМ РАЗРАБОТЧИКОВ СТАНДАРТОВ
 Общественный комитет, на заседаниях которого обсуждаются текущие организационные и технические проблемы Интернет. Если необходимо, IETF формирует рабочую группу для дальнейшего изучения проблемы и выработки рекомендаций по ее преодолению. Часто на основе этих рекомендаций соответствующие организации разрабатывают и утверждают стандарты, применяемые в Интернет. Пользователи Интернет могут сообщать в комитет свои мнения о функционировании сети • и даже выступить на его заседаниях
ИНИЦИАЛИЗАЦИЯ [initialization]
 Приведение программы или устройства в состояние готовности к использованию. И. программы заключается в задании начальных значений или установке в нуль программных переменных (адресов, счетчиков, переключателей, указателей и т. п.) перед выполнением программы. Во многих языках программирования имеются средства определения начальных значений при первом описании переменной. И. магнитного диска включает его форматирование и запись управляющей информации (метки тома, описателей дорожек и Т- п.).
ИНИЦИИРОВАНИЕ [initiation]
 Процесс запуска или перевода программы или устройства в активное состояние.
ИНКАПСУЛЯЦИЯ [encapsulation]
 Термин объектно-ориентированного программирования, означающий структурирование программы на модули особого вида, называемые классами и объединяющие данные и процедуры их обработки, причем внутренние данные класса не могут быть обработаны иначе, кроме как предусмотренными для этого процедурами. Каждый такой класс имеет внутреннюю часть, называемую реализацией (или представлением), и внешнюю часть, называемую интерфейсом. Доступ к реализации возможен только через интерфейс. Таким образом, реализация класса как бы заключена в капсулу и скрыта, откуда и происходит название И.
ИНСТАЛЛЯТОР [installer]
 Программа, выполняющая установку программного продукта на компьютер.
ИНСТАЛЛЯЦИЯ, установка [installation, setup]
 Установка программного продукта на компьютер. И. обычно выполняется под управлением инсталлятора — программы, которая приводит состав и структуру устанавливаемого программного изделия в соответствие с конфигурацией компьютера, а также настраивает программные параметры согласно типу имеющейся операционной системы, классам решаемых задач и режимам работы. Таким образом И. делает программный продукт пригодным для использования в Ланной вычислительной системе и готовым решать определенный класс задач определенном режиме работы
ИНТЕРАКТИВНЫЙ РЕЖИМ [interactive mode]
 То же, что диалоговый режим
ИНТЕРНЕТ [Internet]
 Всемирная информационная компьютерная сеть Представляет собой объединение множества региональных компьютерных сетей и компьютеров, обменивающихся друг с другом информацией по каналам общественных телекоммуникаций (телефонной, радио и спутников,,, связи). И. появилась в конце 70-х — начале 80-х годов в результате постепенного объединения с помощью средств телекоммуникаций, компьютер, ной сети Министерства обороны США, сети Национального научного фонда правительства США, региональных и лаже локальных вычислительных сетей. Согласно официальным данным, в период с 1989 по 1995 гг. сеть И росла, ежегодно удваивая свои размеры. В настоящее время сеть перешла IM коммерческую основу, однако формально ее контролирует общественная организация ISOC (Internet SOCiety). Входящие в И. компьютерные сети взаимодействуют с помощью установленных в И. протоколов TCP/IP, которые позволяют связывать между собой компьютеры различной архитектур],], производимые разными фирмами. Под словом И. обычно подразумевают физический уровень сети, т. е. аппаратное обеспечение, состоящее из компьютеров, кабелей и других устройств передачи данных. Работу в И. обеспечивают базовые программные средства. Они осуществляют поиск нужной информации в архивах, размещенных внутри И., перемещают файлы IM компьютера в компьютер, обеспечивают вход в другие компьютеры, достиг к множеству серверов и баз данных. С помощью аппаратных и программных средств И. предоставляет пользователю различные информационные услуги, среди которых электронная почта, службы электронных объявлений, телеконференций и рекламы. С начала 90-х голов И. предоставляет пользователю сервис, называемый Всемирной паутиной (World Wide Web). Технологии World Wide Web позволяет на основе гипертекста и гипермедиа создавать и хранить информацию в форме документов Web и просматривать все документы Web, хранящиеся в компьютерах глобальной сети, через систему связывающих их ссылок. Подключить компьютер к И. и стать пользователем •электронной почты, Всемирной паутины и других услуг И. помогают поставщики сетевых услуг
ИНТЕРНЕТ-АДРЕС, адрес IP [IP address]
 Уникальный номер, приписанный каждому компьютеру, непосредственно присоединенному к Интернет. И.-а. состоят из четырех чисел, соединенных точками. Например, 192.112.36.4, При передаче пакетов данных по сети эти числа определяют сеть и компьютер, откуда пакет отправлен, и сеть и компьютер — получатели пакета. И-а. используется программным и аппаратным обеспечением сети. Пользователи работают с именами, которые взаимно однозначно связаны с И.-а.
ИНТЕРПРЕТАТОР [interpreter]
 Транслятор (программа или устройство), анализирующий команды или операторы исходной программы и немедленно выполняющий их. Таким образом, И. одновременно и транслирует и выполняет заданную программу, делая это покомандно или пооператорно. Ср. IM, который только транслирует всю программу без ее выполнения И. применяются в большинстве современных программируемых микрокалькуляторов
ИНТЕРПРЕТАЦИЯ [interpretation]
 Метод выполнения исходной программы, при котором каждый отдельно взятый оператор транслируется и сразу выполняется, после чего осуществляется переход к следующему оператору. И выполняется с помощью программных или аппаратных средств, называемых интерпретаторами. Достоинством И. является возможность пошагового прослеживания и выполнения программы, недостатком — относительно малая скорость выполнения.
ИНТЕРФЕЙС [interface]
 Совокупность правил взаимодействия устройств и программ между собой или с пользователем и средств, реализующих это взаимодействие. Понятие И. включает в себя как сами аппаратные и программные средства, связывающие различные устройства или программы между собой или с пользователем, так и правила и алгоритмы, на основе которых эти средства созданы. Например, И. устройств — это и линии связи между ними, и устройства сопряжения, и способ преобразования передаваемых от устройства к устройству сигналов и данных, и физические характеристики капала связи. Программный И. — это и программы, обслуживающие передачу данных от одной задачи к другой, и типы данных, и список общих переменных и областей памяти, и набор допустимых процедур или операций и их параметров. И. пользователя с программой — это и изображенные на экране терминала кнопки, меню и другие элементы управления, с помощью которых пользователь управляет решением задачи, и сам терминал и предусмотренные в программе операторы, позволяющие такое управление осуществить.
ИНТЕРФЕЙС МАЛЫХ ВЫЧИСЛИТЕЛЬНЫХ СИСТЕМ, интерфейс SCSI (читается "интерфейс скази") [small computer system interface (SCSI)]
 Стандарт интерфейса, который определяет работу электрических схем и соединений при передаче данных между устройствами персональных ЭВМ. В основе стандарта лежит протокол, разработанный и запатентованный фирмами Shugart Associates и NCR Corporation примерно в то же время, когда 1В|ц выпустила свой первый PC. Через некоторое время после этого данный стандарт был принят (и несколько изменен) Американским национальным институтом стандартов, который дал ему имя SCSI. Интерфейс разработан для связи компьютера с периферийными устройствами, например с винчестером, принтером и т. п., а также для связи с другими компьютерами в локальной вычислительной сети. Через порт SCSI к компьютеру может быть подсоединено до семи устройств, но передачу данных одновременно может осуществлять только одно устройство. Поэтому каждое подсоединенное устройство наделяется приоритетным номером. Чем выше номер, тем выше приоритет устройства в очереди на передачу данных. Как правило, адаптер шины SCSI, подключенный к системной шине PC, имеет идентификатор 7. Стандарт SCSI имеет несколько спецификаций (первоначальная версия называется теперь SCSI-1), которые допускают различные режимы передачи данных. Эти режимы обеспечивают параметры передачи данных, приближающиеся к параметрам системных шин. Например, скорость передачи данных по стандарту SCSI-2 в 16-битном Fasl Wide-режиме достигает 20 Мб/с (стандарт SCSI-1 обеспечивал скорость передачи не более 5 Мб/с — один байт за каждый такт передачи при тактовой частоте 5 МГц), что позволяет применять этот интерфейс для широкого класса компьютеров, включая суперЭВМ. Стандарт интерфейса SCSI-3 (Fasi-40 Wide SCSI) позволяет передавать данные со скоростью 80 Мб/сек по одиночному кабелю (проводу) SCSI. В настоящее время начинает применяться спецификация SCSI-3, предусматривающая возможность передачи данных по волоконно-оптическим линиям
ИНТЕРФЕЙС ПОЛЬЗОВАТЕЛЯ, пользовательский интерфейс [user interface]
 Интерфейс пользователя с программой, пакетом прикладных программ или вычислительной системой. См. дружественный интерфейс, графический интерфейс пользователя, интеллектуальный интерфейс
ИНТЕРФЕЙС ПРИКЛАДНОГО ПРОГРАММИРОВАНИЯ [application programming interface (API)]
 Стандартизованный набор функций, объекте!! » других программных компонентов, с помощью которых приложение запрашивает и выполняет сервисные функции низшего уровня, такие как развертывание и свертывание окон, чтение с клавиатуры, интерпретация движений мыши и т. л. Обычно И. п. п. служит для связи языков программирования с низкоуровневыми компонентами операционной системы и указывает операционной системе очередность выполнения задач системного уровня. Основная цель И. п. п. — упростить создание приложений и обеспечить переносимость программ
ИНТЕРФЕЙС SCSI (читается "интерфейс скази") [interface SCSI]
 To же, что интерфейс малых вычислительных систем
ИНТРАНЕТ [intranet]
 Корпоративная сеть ЭВМ или группа локальных вычислительных сетей, объединенных общим протоколом связи. Многие сети \\ используют протокол TCP/IP и технологии Интернет. Для защиты информации в сети И. применяются брандмауэры и серверы полномочий
ИНФОРМАТИКА [informatics, computer science]
 Научное направление, изучающее свойства информации и способы ее представления, накапливания, автоматической обработки и передачи. И. начала формироваться в начале 70-х гг.. как дополнение и конкретизация кибернетики в связи с использованием ЭВМ в управлении, науке, проектировании, образовании, сфере услуг и т. л. 13 И. входит группа дисциплин, занимающихся различными вопросами, связанными с разработкой и применением вычислительной техники: прикладная математика, программирование, искусственный интеллект, архитектура ЭВМ, вычислительные сети и др. Современная прикладная И. занимается специальными информационными системами, основанными на ЭВМ и реализующими машинные информационные технологии. Эти системы подразделяются на управленческие, административные, исследовательские, учебные, проектирующие, коммуникационные, системы обслуживания бытовой сферы, экологические, медицинские, военные и т.д. И. охватывает все аспекты их разработки, внедрения, и влияния на развитие общества. Развитие вычислительной техники позволило И. перейти от изучения и разработки систем обработки данных к системам обработки знаний, музыкальных и художественных образов, т. е. к задействованию машин непосредственно в творческих процессах, широкому их использованию в качестве интеллектуальных помощников людей.
ИНФОРМАЦИОННАЯ ЕМКОСТЬ, информационный объем [information]
 Способность запоминающего устройства разместить определенное количество информации. Измеряется максимальным количеством единиц данных (битов, байт, и т. д.), которое может храниться в запоминающем устройстве.
ИНФОРМАЦИОННАЯ СРЕДА [information environment]
 Хранящаяся в компьютере, но не оформленная в виде информационной системы совокупность знаний, фактов и сведений, относящаяся к некоторой предметной области и используемая одним или несколькими пользователями
ИНФОРМАЦИОННАЯ ТЕХНОЛОГИЯ [information technology]
 Совокупность методов, устройств и производственных процессов, используемых людьми для сбора, хранения, обработки и распространения информации. В широком смысле примером И. т. является применение конторских счет и книгопечатание. В узком смысле термин "И. т." употребляется в связи с применением современной электронной техники для обработки информации в целях снижения трудоемкости процессов, использующих эту информацию, повышения их надежности и оперативности. И. т. применяется в вычислительной технике и технике связи, в телевизионном и радиовещании, в науке, медицине, бытовой технике и т.д. Современная И. т. позволяет создавать на базе компьютеров автоматизированные обучающие системы и даже системы искусственного интеллекта
ИНИЦИИРОВАНИЕ [initiation]
 Вычислительный центр, снабженный информационной системой и предназначенный как для предоставления услуг по обработке и хранению данных, так и разнообразных информационных услуг
ИНФОРМАЦИОННОЕ СЛОВО [information word]
 Машинное слово, представляющее собой объект обработки
ИНФОРМАЦИОННЫЙ ОБЪЕМ [information capacity]
 To же. что информационная емкость
ИНФОРМАЦИЯ [information]
 Совокупность знаний, фактов, сведена1 представляющих интерес и подлежащих хранению и обработке. И, являют текст книги, научные формулы, поступления и выплаты по счету в банк-расписание занятий, сообщения измерительных комплексов о расстоянии между Землей и космической станцией и т. п. И., которая требуется для работы вычислительной машины состоит из подлежащих обработке данных программы, определяющей (или дающей пользователю возможность yказать), что и в какой последовательности надо сделать с этими данным11 И. можно передавать, запоминать, искать, копировать, принимать, обрабатывать и, наконец, создавать и разрушать. И. может создаваться и переноситься в форме световых, звуковых и радиоволн, электрического тока пл1 напряжения, магнитных полей, знаков на бумаге. В принципе И. может переносить любая материальная структура или поток энергии. Масштабы использования И. характеризуют уровень развития общества
ИСКЛЮЧИТЕЛЬНАЯ СИТУАЦИЯ, особая ситуация [exception]
 Событие в программе, вызывающее программное прерывание, обработку которого предусматривает программист.
ИСКУССТВЕННЫЙ ИНТЕЛЛЕКТ, машинный интеллект [artificial intelligence, machine intelligence]
 1.Область информатики, занимающаяся научными исследованиями и разработкой методов и средств для правдоподобной имитации отдельных функций человеческого интеллекта с помощью автоматизированных систем. В рамках И. и. создаются методы, программные и технические средства решения задач, для которых отсутствуют формальные алгоритмы: распознавание изображений, понимание естественных языков и речи, обучение с учетом способностей ученика, постановка диагнозов, доказательство теорем и т. п. Эти задачи обычно решаются человеком с привлечением подсознания и поэтому их довольно трудно моделировать. На основе методов И. и. разрабатываются интеллектуальные программные системы, например, интеллектуальные информационные системы, интеллектуальные обучающие системы, интеллектуальные системы программирования и др. Большинство таких систем используют для своей работы соответствующие базы знаний, которые также разрабатываются с привлечением методов И. и. Иногда программы И. и. служат для моделирования поведения человека, а иногда — для технических применений. Методы И. и. используются и при программировании компьютерных игр. Термин "машинный интеллект", являясь синонимом И. и., чаше применяется для указания только технологического аспекта проблемы И. и. 2. Свойство "автоматических и автоматизированных систем выполнять отдельные функции интеллекта человека, например, выбирать и принимать оптимальные решения на основе ранее полученного опыта и анализа внешних воздействий
ИСПОЛНЕНИЕ ПРОГРАММЫ [program run]
 To же, что выполнение программы
ИСПОЛНИТЕЛЬНЫЙ АДРЕС, действительный адрес [effective address, executive address]
 Адрес операнда команды, содержащийся в ней или вычисляемый на основе содержимого ее полей; содержание адресной части модифицированной команды. Фактическое обращение к памяти выполняется именно по И. а.
ИСПОЛНЯЕМЫЙ ОПЕРАТОР [imperative statement]
 Оператор в программе которому соответствует одна или несколько последовательных операций, оставляющих алгоритм решения задачи. Например, оператор присваивания или оператор цикла. Противоп. невыполняемый оператор
КАДР [frame]
 l. Содержимое экрана дисплея. 2. В сетях ЭВМ— порция данных, передаваемая по каналу связи. 3. В некоторых текстовых процессор и настольных редакционно-издательских системах — прямоугольная область, содержащая, например, иллюстрацию, которую при верстке страниц можно произвольным образом перемещать по странице независимо от остального текста
КАЛЬКУЛЯТОР [calculator]
 Малогабаритное вычислительное устройLTBO, выполняющее элементарные операции над числами, требующее ручного ввода чисел и команд. Различают К. программируемые и непрограммируемые. Непрограммируемые К. не имеют памяти для хранения программ, и каждая команда вводится вручную и тотчас выполняется. Программируемый К. обладает относительно небольшой памятью для хранения чисел и относительно несложных программ. Все К. выполняют команды методом интерпретации. См. интерпретатор
КАНАЛ ВВОДА-ВЫВОДА, канал [input-output channel, channel]
 Совокупность технических средств для обмена данными между оперативной памятью ЭВМ и внешними устройствами. Основу К. в.-в. составляет специализированный процессор, обеспечивающий форматирование данных и управляющий операциями ввода-вывода
КАНАЛ ПЕРЕДАЧИ ДАННЫХ [data link]
 Физическое соединение, по которому осуществляется передача данных из одного устройства в другое. К. п. д. может связывать любые два устройства, способные принимать и посылать информацию, например, компьютер и присоединенный к нему принтер, или основной компьютер и терминал в сети. Иногда термин К. п. д. подразумевает не только линию связи, но и любое оборудование, позволяющее принимать и передавать информацию, например, модем. Устройства, составляющие К. п. д., подчиняются протоколам, которые регламентируют процесс передачи. Ср. канал связи
КАНАЛ СВЯЗИ [communication channel]
 Совокупность технических средств для передачи данных в сети ЭВМ от одного компьютера к другому. Ср. канал передачи данных
КАПИТЕЛЬ, малые прописные [small caps]
 Начертание шрифта, в котором для изображения строчных букв используются прописные буквы, но уменьшенного размера (см. рис. H.I). В современной полиграфии используется сравнительно редко
КАРТРИДЖ [cartridge]
 Сменный элемент устройства, содержащий расходуй материал. Например, в матричном принтере— кассета с уложенной специальным образом красящей лентой, в копировальном аппарате — Обойма с красящим порошком
КАТАЛОГ, директорий, папка [directory, folder]
 1. Список файлов и подкаталогов. 2. В файловой системе — файл, предназначенный лля регистрации имен других файлов и обеспечения к ним доступа по зарегистрированным именам. К. содержит данные, описывающие группу файлов, размещенных ла устройстве памяти с прямым доступом (обычно, на магнитном или лазерном диске). Например, в IBM-совместимых персональных компьютерах в К. хранятся имена файлов, сведения об их типе (исполняемый, текстовый и т. п.), размере и времени последнего обновления, а также указатели места их расположения на диске. Если в К. хранится имя файла, то говорят, что этот файл находится или содержится в данном К. В любом К. кроме файлов могу1' содержаться другие К., называемые подкаталогами. На каждом диске имеется один главный или корневой К. Корневой К. обычно не имеет имени (считается, что его имя совпадает с именем лиска, на котором он расположен) и занимает на этом диске специальное место. Все остальные К. являются файлами специального вила и имеют имена, состоящие из 8 символов, и могут иметь расширение (3 символа), отделенное от имени точкой. В корневом К. регистрируются файлы и подкаталоги (К. 1-го уровня). В К. 1-го уровня регистрируются файлы и К, 2-го уровня и т. д. Получается многоуровневая древообразная структура К. на диске.
КАТАЛОГИЗАЦИЯ [catalogization]
 Введение информации о файле в каталог
КВАНТ ВРЕМЕНИ [time slice]
 Относительно короткий интервал времени Центрального процессора, предоставляемый отдельной задаче при квантовании времени
КВАНТОВАНИЕ ВРЕМЕНИ [time slicing]
 Режим работы вычислительной системы, при котором выделение центрального процессора задачам осуществляется на некоторый период — квант времени. После того как квант времени, выделенный задаче, истекает (при условии, что раньше не наступило прерывание), она временно откладывается и помешается в конец очереди готовых к работе задач. Следующий квант выделяется задаче, стоящей в очереди первой. Всем задачам может выделяться квант времени одной и той Же Длительности, и работающие задачи могут выбираться по циклическому алгоритму. Распространен также алгоритм К. в., при котором задачи, интенсивно использующие устройства ввода-вывода, помешаются в очередь перед задачами чисто вычислительного характера, но получают более короткие кванты времени для выполнения
КЕГЛЬ [font size, type size]
 To же, что размер шрифта
КЕРНИНГ [kerning]
 Изменения фактического интервала между некоторыми парами букв для того, чтобы добиться визуального выравнивания промежутков между буквами. Например, в паре букв "Тл" фактический интервал между буквами делается несколько меньше обычного, в противном случае из-за особенностей формы этих букв у читающего может создаться визуальное впечатление, что интервал больше обычного. В современных текстовых процессорах К. выполняется автоматически в соответствии с гарнитурой и размером шрифта.
КИБЕРНЕТИКА [cybernetics]
 Наука об управлении и связи в природе и обществе. Основой К. явилось учение американского математика Н. Винера об обратной связи в сложных системах и организмах, опубликованное им в 1948 г. в книге "Кибернетика, или управление и связь в животном и машине". К. рассматривает сложные объекты природы и общества независимо от способа их организации, как большие кибернетические системы, состоящие из управляющих и управляемых элементов, между которыми существуют информационные прямая и обратная связи. С точки зрения К. системами являются часовой механизм, электронное устройство и человеческий организм. Такой подход привел к системному анализу — научному методу исследования структуры и функционирования сложных явлений, процессов и объектов природы и общества. Результатом анализа является математическое описание способов управления и распространения информации в системе. За анализом следует не только моделирование управления системами и прогнозирование их поведения, но и синтез новых систем. Кибернетический подход стал широко применяться в связи с созданием и развитием ЭВМ. Это привело к образованию ряда научных направлений К. Теоретическая К. на основе дискретной математики занимается теорией управления и теорией информации. Техническая К. занимается средствами автоматизации управления, включая ЭВМ и автоматизированные системы управления. Биологическая К. применяет идеи теоретической К. в биологии и медицине. Экономическая К. занимается созданием математических моделей экономических процессов и применением компьютеров в экономических расчетах. Социальная К. строит и изучает математические модели управления различными процессами, протекающими в человеческом обществе. Многими задачами, поставленными К., в настоящее время занимается информатика
КИЛОБАЙТ (Кбайт, Кб, К) [kilobyte (Kbytes, Kb. К)]
 Единица количества информации; ! Кбайт = 1024 байта
КИЛОГЕРЦ (КГц) [kilohertz (kHz)]
 Единица измерения частоты эквивалентная 1000 колебаний в секунду; 1 КГц = 1000 Гц
КЛАВИАТУРА [keyboard]
 Устройство, предназначенное для непосредственного ввода команд и данных в ЭВМ. Представляет собой набор клавиш. Нажатие клавиши обеспечивает ввод одного, соответствующего этой клавише символа, или вызывает некоторое действие. Большинство современных К. СИ' состоят из 101 клавиши и имеют несколько световых индикаторов, оповещающих о режимах работы клавиатуры. На К. имеются (рис. К.1): ц стандартный набор клавиш пишущей машинки с цифрами, латинскими и русскими буквами и знаками препинания; 2) малая цифровая клавиатура', т.) клавиши редактирования', 4) клавиши управления курсором: 5) функциональные клавиши', 6) специальные клавиши. Буквенно-цифровые клавиши в основном используются для введения команд операционной системы и текстов. Малая цифровая К. дублирует имеющиеся на основной К. клавиши ввода цифр и удобна при вводе числовых данных. Клавиши редактирования и клавиши управления курсором служат для работы с информацией, выведенной па экран. Функциональные клавиши отведены для управления различными функциями вычислительной системы или отдельных программ. Специальные клавиши предназначены для управления компьютером и режимом работы К.
КЛАВИША [key]
 Элемент клавиатуры, нажатием которого генерируется кол соответствующего знака или инициируется определенное действие
КЛАВИШИ БЫСТРОГО ВЫЗОВА, быстрые клавиши, клавиши быстрого доступа, "горячие" клавиши [quick keys, access keys, hot keys]
 Клавиша или сочетание двух (максимум, трех) клавиш, одновременное нажатие на которые сразу вызывает определенные действия программы или вычислительной . В качестве К. б. в. обычно используются функциональные и управляющие клавиши клавиатуры, либо сочетания этих клавиш с буквенными. например, одновременное нажатие сочетания клавиш ++ сразу вызывает перезагрузку операционной системы персонального IBM-co-компьютера. В табл. К.1 приведено краткое описание действия К. б. в. оболочки Nor/on Commander
КАТАЛОГ, рабочий каталог [current directory, working directory]
 Каталог, файлы, которого в данный момент непосредственно доступны программам и пользователю. В персональных IBM-совместимых компьютерах это каталог, с которым в настоящий момент работает пользователь. При этом, если пользователь указывает в команде операционной системы имя файла без указания пути к файлу, то операционная система будет искать или создавать этот файл в Т. к. При работе в оболочке Norton Commander имя f. к. указано в первой строке активной экранной панели, а также в приглашении, расположенном в командной строке


Толковый словарь компьютерной лексики

ОПЕРАТИВНАЯ ПАМЯТЬ ПЕРСОНАЛЬНЫХ IBM-СОВМЕСТИМЫХ КОМПЬЮТЕРОВ [IBM-PC main memory]
 Хотя О. п. п. IBM-с. к. аппаратно однородна (за исключением ПЗУ), при работе в MS-DOS она может быть использована только разделенной на несколько неравных частей. Только 640 Кб оперативной памяти могут использоваться обычными программами для загрузки как самих программ, так и данных. Это так называемая основная память. Часть оперативной памяти от 640 Кб до 1 Мб называют верхней памятью. Адресное пространство сверх 1 Мб называют расширенной памятью. Использование расширенной памяти при работе в MS-DOS возможно с помощью драйвера himcm.sys, но только для хранения данных, организации электронного диска или кэш-памяти. Операционная система Windows 95 и программы, написанные для работы в среде Windows, работают в защищенном режиме и поэтому могут полноценно использовать всю имеющуюся оперативную память
ПОЛНОЕ ИМЯ ФАЙЛА [pathname]
 Составное имя, включающее последовательно записываемые через разделитель "\": - имя диска, — последовательность имен вложенных каталогов, через которые проходит путь к файлу (начиная с высшего в их иерархии), и имя файла с расширением. Таким образом, П. и. ф. состоит из маршрута поиска файла и имени с расширением. Например, в П. и. ф- C:\SYS\DRV\800.com маршрутом является C:\SYS\DRV
МАТЕРИНСКАЯ ПЛАТА [mother board]
 Главная плата системного персональных компьютера». На М. п, персональных IBM-совместимых теров расположены центральный процессор, .математический сопроцессор, оперативная память, системная и цокольная шины, а также разъемы, в которые вставляются выполненные в виде отдельных плат адаптер дисплея, контроллеры жесткого и гибких дисков и порты. У других персональных компьютеров адаптер, контроллеры и порты могут быть выполнены как части М. п.
МАТРИЧНЫЙ ПРИНТЕР [matrix printer]
 Принтер, в котором изображение формируется ударами иголок печатающей головки через красящую ленту. М. п. могут быть 9- и 24-игольчатыми. Качество печати значительно выше у последних
МАШИННАЯ ПРОГРАММА [computer program, machine program]
 Программа на машинном языке. М. п. является последовательностью команд и может быть распознана и выполнена центральным процессором
МАШИННОЕ ВРЕМЯ [computer time]
 Время, затрачиваемое ЭВМ на выполнение определенного комплекса вычислений. Ср. время прогона, время простоя и процессорное время
МАШИННОЕ СЛОВО [computer word]
 Определенной длины последовательность битов или символов, воспринимаемая памятью, арифметический устройством или устройством управления ЭВМ как единое целое, имеющее определенное смысловое содержание. Например, М. с. являются машинные команды, из которых состоят машинные программы, а также операнды, над которыми производятся машинные операции. М. с., представляющее собой объект обработки, иногда называют информационным словом- М. с. может занимать одну ячейку (байт) памяти или несколько соседних ячеек (байтов).
МАШИННО-ЗАВИСИМЫЙ ЯЗЫК [computer-sensitive language]
 To же, что машинно-ориентированный язык
МАШИННО-НЕЗАВИСИМЫЙ ЯЗЫК [computer independent language]
 Язык программирования, структура и средства которого не связаны ни с какой конкретной ЭВМ и позволяют выполнять составленные на нем программы на любых ЭВМ, снабженных трансляторами с этого языка. М-н.я являются все языки программирования высокого уровня. Противоп. машинно-ориентированный язык
МАШИННО-ОРИЕНТИРОВАННЫЙ ЯЗЫК, машинно-зависимый язык [computer-sensitive language, computer-oriented language]
 Язык программируй -пин, который отражает архитектуру данной ЭВМ или данного класса ЭВМ М.-о. я. может обладать набором основных операторов типичного языка программирования высокого уровня, типы и структура данных которого соответствуют архитектуре определенного класса ЭВМ и при этом иметь средства, позволяющие при программировании учитывать особенности снопе, команд, организации памяти, способа адресации и представления данных. Это позволяет создавать программы, эффективность которых для данного класса компьютеров сравнима с эффективностью машинных программ. Пример М.-о. я. является любой язык ассемблера. Ср. машинно-независимый язык
МАШИННЫЙ ИНТЕЛЛЕКТ [machine intelligence]
 To же, что искусственный интеллект
МАШИННЫЙ НОЛЬ [computer zero]
 Представление нуля в ной системе. М. н. обозначаются числа, абсолютная величина меньше наименьшей ненулевой величины из диапазона изменения чисел ной вычислительной системы
МАШИННЫЙ СБОЙ, аппаратный сбой, сбой [machine failure, failure, malfunction]
 Кратковременный отказ или ошибка и работе аппаратных средств вычислительной системы. Причинами, вызывающими М. с., как правило, являются изменение условий или несоблюдение правил эксплуатации оборудования. Например, нестабильность питания, несоблюдение температурного режима, ненадежность соединений, попадание посторонних частиц в подвижные части и т. п.
МАШИННЫЙ ЯЗЫК [computer language, machine language]
 Язык программирования, предназначенный для представления программ и данных в форме, пригодной для непосредственного восприятия их устройствами данной вычислительной машины. Представляет собой систему команд, данных и инструкций: имеющих форму цифровых кодов (в большинстве ЭВМ — двоичных). которые не требуют трансляции и непосредственно интерпретируются процессором ЭВМ. Программы, написанные на других языках программирования, сначала транслируются на М. я., а уже затем выполняются вычислительной машиной
МЕГАБАЙТ (Мбайт, Мб, М) [megabyte]
 Единица количества информации; 1Мб= 1024 Кб- 13048 576 байт
МЕГАГЕРЦ (МГц) [megahertz (MHz)]
 Единица измерения частоты эквивалентная 1 миллиону колебаний в секунду; 1 МГц = 1000 КГц = 1 000000 Гц
МЕЖДУНАРОДНАЯ ОРГАНИЗАЦИЯ ПО СТАНДАРТИЗАЦИИ [International Standards Organization (ISO)]
 Международная некоммерческая организация, работающая под эгидой Организации Объединенных Наций и разрабатывающая и распространяющая научные и технологические стандарты. ISO объединяет организации по стандартизации более 90 стран. Например, среди разработок ISO — средства концептуального построения компьютерных сетей.
МЕЖДУНАРОДНЫЙ КОНСУЛЬТАТИВНЫЙ КОМИТЕТ ПО ТЕЛЕГРАФИИ И ТЕЛЕФОНИИ [Consultative Committee International for Telephone and Telegraph (CCITT)]
 Организация, разрабатывающая протоколы для систем передачи данных', модемов, сетей и факсимильной связи — в Европе. Сейчас она переименована в ITU-T и является подразделением 1TU (International Telecommunications Union). Некоторые из стандартов ССГТТ для взаимодействия модемов через обыкновенную телефонную сеть приняты и в США
МЕТКА [label]
 1. Целое число без знака или идентификатор, приписанный оператору программы и используемый в других частях программы для обращения к этому оператору. М- обычно ставится перед оператором и, либо отделяется от него двоеточием, как в Паскале и Си, либо ставится на определенном поле программы, как в Фортране. Оператор, снабженный меткой называют помеченным оператором. Например, в Паскале оператор присваивания 25; k:= k+i,- помечен М. 25. 2. Физическая запись на внешнем носителе данных, определяющая начало или конец файла или тома
МЕТОД КЛАССА [class method, method]
 Термин объектно-ориентированна программирования, которым обозначается функция (или процедура), являющаяся членом класса. Ср. свойство класса
МИКРОКАЛЬКУЛЯТОР [micro calculator]
 Миниатюрная ЭВМ индивидуального пользования. Современные М. обладают памятью и помимо выполнения арифметических операций и вычисления значений основных алгебраических и тригонометрических функций позволяют программировать на 0 ном из языков программирования
МИКРОКОМАНДА [microinstruction]
 Команда микропрограммы
МИКРОПРОГРАММА [micro program]
 Программа, задающая последовательность элементарных действий процессора по выполнению машинной команды. Эти действия определяются на уровне внутренних регистре: имеющихся в отдельных блоках процессора, и сигналов, поступающих г эти регистры. Каждому такому действию соответствует одна микрокоманд: См. микропрограммирование
МИКРОПРОГРАММИРОВАНИЕ [microprogramming]
 1. Способ задания и изменения системы команд процессора, при котором каждая машинная команда задается микропрограммой. М. поддаются процессоры с микропрограммным способом управления, при котором каждая машинная команд.1 при вводе ее в регистр команд, определяет выполнение соответствующей микропрограммы — последовательности микрокоманд, в совокупности реализующей выполнение команды. Микропрограммы выполнения всех машинных команд хранятся в сверхбыстродействующей (обладающей более высоким быстродействием, нежели оперативная память компьютера) микропрограммной памяти процессора. Это создает возможность модификации системы команд посредством простого изменения содержимого микропрограммной памяти. 2. Процесс создания микропрограмм. Программирование алгоритмов выполнения процессором машинных команд
МИКРОПРОГРАММНАЯ ПАМЯТЬ [micro program store, control memory]
 Сверхбыстродействующая память процессора, в которой хранятся программы, управляющие выполнением машинных команд. Она может Фиксированной (ПЗУ) или гибкой, допускающей перезапись содержимого. /41 микропрограммирование
МАКРОПРОЦЕССОР [microprocessor]
 Одна или несколько микросхем, на которых реализуется процессор. Представляет собой полупроводниковый кристалл или комплект кристаллов, в которых по особой технологии изготовлены арифметико-логическое устройство, устройство управления, цепи передачи данных, регистры и память
МИКРОСЕКУНДА (мксек) [microsecond (mcsec)]
 Единица измерения времени быстро протекающих процессов. 1 мксек = 10-6 сек
МИКРОСХЕМА [chip, microcircuit]
 Интегральная схема, реализующая некоторую сложную функцию. Например, одна из М., реализующих оперативную память современного компьютера, представляет собой сверхбольшую интегральную схему размером 1/2 дюйма на 1/4 дюйма, способную хранить 1 млн бит информации
МИКРОСХЕМА ПАМЯТИ [memory circuit]
 Микросхема, реализующая функцию памяти произвольного доступа. В М. п. используются два основных типа памяти: статическая (SRAM — Static RAM) и динамическая (DRAM — Dynamic RAM). Ячейки статической памяти построены на различных вариантах триггеров — схем с двумя устойчивыми состояниями. После записи бита в такую ячейку она может пребывать в этом состоянии сколь угодно долго — необходимо только наличие питания. Ячейки статической памяти имеют малое время срабатывания (единицы — десятки наносекунд), однако микросхемы на их основе имеют низкую удельную плотность данных и высокое энергопотребление. Поэтому статическая память используется в основном в качестве кэш-памяти. В динамической памяти ячейки построены на основе областей с накоплением зарядов, занимающих гораздо меньшую площадь, нежели триггеры, и практически не потребляющих энергии при хранении. При записи бита в такую ячейку в ней формируется электрический заряд, который сохраняется в течение нескольких миллисекунд. Для постоянного сохранения заряда ячейки необходимо регенерировать — перезаписывать -Одержимое для восстановления зарядов. По сравнению со статической памятью ячейки динамической памяти имеют большее время срабатывания (десятки-сотни наносекунд), но большую удельную плотность и меньшее энергопотребление. Динамическая память используется в качестве основной, В настоящее время применяются следующие М. п.: FPM DRAM (Fast "аёе Mode DRAM — динамическая память с быстрым страничным доступом). Позволяет ускорить страничный обмен и снизить накладные расходы на регенерацию памяти. М. п. EDO (Extended Data Out — расширенное время Удержания данных на выходе) работают в режиме простого конвейера: удерживают на выходах данных содержимое последней выбранной ячейки, в то время как на их входы уже подастся адрес следующей выбираемой ячейки.
МОДЕЛЬ ВЗАИМОДЕЙСТВИЯ ОТКРЫТЫХ СИСТЕМ [International Organization for Standardization/Open System Interconnection model (ISO/OSI model)]
 To же, что модель OSI/ISO
МОДЕЛЬ ДАННЫХ [data model]
 Совокупность принципов организации бачы данных. Известно множество различных М, д., но самыми популярными являются иерархическая, сетевая и реляционная. Каждая М. д. предусматривает различные принципы определения, манипулирования и хранения данных в базе данных, но наиболее важным является принцип организации связей между данными в базе данных. М. д. отличаются друг от друга, прежде всего, способами организации связи между данными. В иерархической М. д. записи данных связаны между собой явным образом, причем способ связывания строго ограничен, а именно, записи данных в иерархической базе данных образуют иерархию. Например, реестр Windows является иерархической базой данных. В сетевой базе данных записи также явным эбразом связаны друг с другом, но способ связей не ограничен. Наибольшую известность получила сетевая М. д.. описанная в стандартах КОДАСИЯ-В реляционной модели данных записи связаны друг с другом неявно, через значения атрибутов (полей кортежа).
МОДУЛЬ ПАМЯТИ [memory module]
 Плата с размещенными на ней микросхемами памяти. С одной стороны платы расположены контактные площадки, которые вставляются в специальный разъем на материнской плате. В настоящее время применяются в основном два типа модулей оперативной памяти-- SIMM и DIMM. SIMM (Single In line Memory Module) — М. п. с одним рядом из 30 или 72 контактов. Применяется во всех современных материнских платах, а также во многих адаптерах, принтерах и прочих устройствах. SIMM может быть различного объема от 4 до 32 Мб. DIMM (Dual In line Memory Module) — М. п.. похожий на SIMM, но с двумя рядами контактов (обычно по 84 контакта в ряду). За счет этого увеличивается разрядность или емкость памяти в модуле. М. п. DIMM могут иметь объем от 16 до 64 Мб. На SIMM в настоящее время устанавливаются преимущественно микросхемы FPM/EDO/BEDO, а на DIMM - EDO/BEDO/SDRAM
МОДЕМ, модулятор-демодулятор [modem]
 Устройство, преобразующее цифровую форму данных в непрерывный аналоговый сигнал и обратно для передачи от одного компьютера к другому через телефонную сеть МОДИФИКАЦИЯ, обновление [update, updating]. Изменение программы или данных с сохранением способа их организации и присвоенных идентификаторов. Так, М. файла подразумевает изменение его содержимого с целью отражения новых сведений. При этом название файла не изменяется. М- программного продукта подразумевает исправление ошибок, найденных после того, как программа выпушена, или незначительные усовершенствования алгоритма. М. программы либо не отражается в ее названии, либо приводит к небольшому изменению номера версии, например вместо 3.0 появляется 3.1. Ср. усовершенствование
МОДИФИЦИРОВАННАЯ АЛЬТЕРНАТИВНАЯ КОДИРОВКА ГОСТА [modified alternative code]
 Применяемая в России десятичная кодировка символов для IBM-совместимых персональных компьютеров. М. а. к. Г. представляет собой таблицу десятичных кодов, в которой каждому вводимому с помощью клавиатуры и изображаемому на экране дисплея символу соответствует код от О.до 255. Эти символы вместе с кодами приведены в табл. М.2, Чтобы определить код символа по этой таблице нужно сложить первые числа строки и столбца, на пересечении которых находится символ. Например, символ "#" находится на пересечении строки, обозначенной числом 30, и столбца — 5. Следовательно, его код 35. Первые 32 символа (коды 0—31) — рабочие символы операционной системы, а с помощью остальных пользою* Те-ть может составлять свои тексты и таблицы. Символ с кодом 32 — пробел. Символы — буквы русского алфавита (кириллица) в компьютере должны быть загружены в знакогенератор видеоадаптера операционной системой с Поддержкой кириллицы или специальной программой — драйвером-русификаторо.м, Коды 176—223 соответствуют псевдографическим символам, предназначенным для изображения рамок, таблиц и диаграмм.
МУЛЬТИМЕДИА [multimedia]
 1. Представление информации в форме видеоизображения с применением мультипликации и звукового сопровождения. 2. Комплекс аппаратных и программных средств для работы с видеоизображением и звуком. Компьютеры, оборудованные М., обычно имеют мощную видеосистему, возможность подключения видеомагнитофона и видеокамеры, аппаратные средства захвата изображения и записи его на жесткий магнитный диск в цифровой форме, средства наложения видео изображений, звуковую плату для воспроизведения и синтеза звука, привод для считывания информации с компакт-диска (CD-ROM), возможность для подключения акустической системы
МУЛЬТИПРОГРАММИРОВАНИЕ [multiprogramming]
 1. Режим или метол организации работы вычислительной системы, при котором одновременно выполняется несколько программ, попеременно использующих одни и те ж ее ресурсы. При простейшей форме М. все активные программы находятся в основной памяти. При этом одни ресурсы (например, оперативная память и винчестер) делятся между программами, другие используются исключительно одной программой (например, графопостроитель), а третьи используются совместно (например, центральный процессор). Строго говоря, программы не работают одновременно, а только попеременно используют центральный процессор, либо исходя из учета приоритетов, либо на основе квантования времени. Программы защищены друг от друга. Никакая программа, за исключением супервизора, не может использовать часть оперативной памяти, выделенную другой программе. М. позволяет повысить загруженность центрального процессора и всего оборудования вычислительной системы. Режим М. может быть организован как в системе с одним процессором, так и с несколькими процессорами. Однако на каком-либо процессоре в каждый промежуток времени может выполняться какая-то одна программа. При М. процессоров всегда меньше, чем процессов. 2. Организация программы в виде нескольких взаимодействующих процессов, каждый из которых является последовательной программой. Такая программа дополняется компьютером в режиме М.
МУЛЬТИПРОЦЕССОРНАЯ ЭВМ [multiprocessor computer]
 To же, что многопроцессорная ЭВМ
МУСОР [garbage]
 Ненужные, не подлежащие дальнейшему использованию в памяти ЭВМ (недоступные, устаревшие, недостоверные и т. п.). М. напрасно занимает место в памяти, поэтому ее следует регулярно очищать от М. Эту процедуру называют сборкой мусора.
МЬШЬ [mouse]
 Указательное устройство, которое представляет собой потешающуюся в ладони коробочку с датчиком перемещения в виде шарика и несколькими кнопками. Обычно М. соединяется с компьютером тонким кабелем через последовательный порт. Существуют и "бесхвостые " М., в которых используется связь в диапазоне волн теплового излучения. При перемещении М. по плоскости вращение шарика преобразуется в электрические сигналы, управляющие положением указателя мыши на экране дисплея. Кнопки М. могут иметь различное назначение, зависящее от используемого драйвера М. и прикладной программы. Например, в текстовом редакторе Word левая кнопка используется для выбора объектов и выполнения действий, а правая — для вызова контекстного меню. Помещением указателя мыши в определенное место экрана и нажатием кнопки можно сообщить работающей программе некоторые сведения или отдать какие-либо команды. Наиболее распространены трехкнопочные мыши. Разновидностью М. является трекбол.
МЭЙНФРЕЙМ [mainframe]
 Универсальная ЭВМ большой мощности, обычно используемая одновременно многими пользователями, работающими на терминалах, подключенных к ней
НАКОПИТЕЛЬ НА ГИБКИХ МАГНИТНЫХ ДИСКАХ (нгмд) [floppy disk drive]
 Внешнее запоминающее устройство, в котором носителями данных являются гибкие магнитные диски. Включает в себя дисковод и сменные дискеты. НГМД могут быть трех видов: для дисков 5.25", емкостью 360 Кб; для дисков 5.25", емкостью 1.2 Мб; для дисков 3.5", емкостью 1.44 Мб. На накопителе для дисков 5.25" — 1.2 Мб можно использовать диск 5.25" — 360 Кб, а на накопителе для дисков 3.5" — 1.44 Мб можно использовать диск 3.5" — 760 Кб. К НГМД относятся и диски Бернулли (накопители Zip и Jaz).
НЕАКТИВНОЕ ОКНО [inactive window]
 Окно, не используемое пользователем в настоящий момент. Н. о. может быть полностью или частично перекрыто другими окнами. Чтобы сделать его активным, как правило, достаточно навести на него указатель мыши, и нажать левую кнопку. Противоп. активное окно.
НЕВИДИМАЯ ЛИНИЯ [hidden line]
 Линия, которую можно или нужно скрыть при пространственном изображении объекта. Например, при изображении куба некоторые ребра будут Н. л. В системах автоматизированном проектирования и программах рисования существуют команды удаления. Н. л
НЕВИДИМАЯ ПОВЕРХНОСТЬ [hidden surface]
 Поверхность, которую можно или нужно скрыть при пространственном изображении объекта. Например, при изображении куба некоторые грани будут Н. п. В системах автоматизированного проектирования и программах рисования существуют специальные команды удаления Н. п.
НЕВЫПОЛНЯЕМЫЙ ОПЕРАТОР [nonexecutable statement]
 Оператор В программе, не содержащий прямое указание на выполнение некоторого действия, определяющего алгоритм решения задачи, а предназначенный для описания объектов программы, либо содержащий другую необходимую для трансляции и выполнения программы информацию. Например, оператор задания формата вводимых или выводимых данных. Противоп. исполняемый оператор
НЕЗАКОННОЕ КОПИРОВАНИЕ ПРОГРАММНЫХ СРЕДСТВ, несанкционированное копирование, пиратство [software piracy, piracy]
 Копирование программного продукта без согласия владельца авторских прав. Н. к. п. с. производится с целью использования программы незаконными, незарегистрированными пользователями, без какой-либо оплаты. Для предотвращения Н. к. п. с. программный продукт часто снабжается средствами защиты от копирования. В настоящее время Н. к. п. с. преследуется по закону
НЕОПРЕДЕЛЕННЫЙ ФОРМАТ [undefined format]
 Формат, в котором запись или блок данных могут иметь переменную длину и ife содержат никакой стандартизированной информации о своей длине или формате. Подпрограммы операционной системы, управляющие данными, рассматривают каждую запись как блок данных, при этом для файла указывается максимальная длина блока
НЕОСНОВНОЙ КЛЮЧ, вторичный ключ [secondary key]
 Ключ в файле с несколькими ключами, не обеспечивающий (в отличие от основного /GIWW) однозначную идентификацию записи. В этот ключ могут входить все поля записи, кроме полей, составляющих основной (первичный) ключ
НЕПЕЧАТАЕМЫЕ СИМВОЛЫ [nonprinting characters]
 Символы, которые могут отображаться на экране, но не должны появляться в печатной документа, например: пробелы, символы табуляции и конца абзаца и т. п.
НЕПОСРЕДСТВЕННЫЙ ОПЕРАНД [immediate operand]
 ]. Операнд, представленный в команде непосредственно своим значением, а не адресом расположения в памяти. Например, в командах типа "проверить по маске", мака может задаваться, как Н. о.
НЕПРЕРЫВНЫЙ СИГНАЛ [continuous signal]
 To же, что аналоговый сигнал
НЕСАНКЦИОНИРОВАННОЕ КОПИРОВАНИЕ [software piracy]
 To же, что незаконное копирование программных средств
НЕСАНКЦИОНИРОВАННЫЙ ДОСТУП [unauthorized access, illegal access]
 Доступ нарушением правил пользовании данными. Это может быть доступ данным лица или программы, которым пользование этими данными не разрешено или доступ с применением неразрешенных средств вычислительной техники. См. защита данных, защита памяти, защита от копирования
НЕЯВНОЕ ОПИСАНИЕ [implicit declaration]
 В некоторых языках программирования допускается отсутствие описания. В этом случае характеристики объекта программы, описание которого отсутствует, устанавливаются по виду его идентификатора, согласно специальным правилам, принятым в данном языке. Например, в Фортране при отсутствии описания переменных действует такое правило: если идентификатор (имя) переменной начинается с одной из букв I, J, К, L, M, N, то это переменная целого типа, значения которой имеют длину 4 байта
НИЖНИЙ КОЛОНТИТУЛ [footer, running foot]
 Колонтитул, расположенный в нижней части страницы, ниже основного текста
НИСХОДЯЩЕЕ МЕНЮ, раскрывающееся меню, спускающееся меню [pull-flown menu]
 Меню, вызываемое указанием его заголовка, появляющееся непосредственно под этим заголовком и исчезающее после окончательного выбора одного из его пунктов. Первоначально Н, м. имеет вид горизонтального меню, обычно расположенного в верхней строке экрана. После выбора пункта этого меню появляется новое, как правило, вертикальное меню, накладывающееся на содержимое экрана, после выбора в этом меню может "^никнуть еще одно поверх предыдущего и т. д. до окончательного выбора 'С1(- рис. М.З). Затем все возникшие меню исчезают. Такие "вложенные" меню иногда называют подменю
НИСХОДЯЩЕЕ ПРОГРАММИРОВАНИЕ [top-down programming]
 Способ Разработки программ, при котором программирование ведется методом «сверху вниз», от общего к летаем. Алгоритм решения задачи разбивается Несколько более простых частей или подзадач. Их выделяют таким о3 бразом, чтобы программирование подзадач было независимым.
НОРМАЛИЗОВАННАЯ ФОРМА [normalized form]
 Форма представления числа с плавающей точкой, при которой мантисса М удовлетворяет двум условиям: М <1 и старшая цифра мантиссы отлична от нуля. Например, среди трех форм одного и того же числа с плавающей точкой: 1.2345 • 102, 0.012345-104 и 0.12345.103 Н. ф. является только третья
НОРМАЛИЗОВАННОЕ ЧИСЛО [normalized number]
 Число с плавающей точкой, записанное в нормализованной форме
НОРМАЛЬНАЯ ФОРМА БЭКУСА-НАУРА (БНФ) [Backus-Naur form (BNF)]
 То же, что формальный язык Бэкуса-Наура
НОСИТЕЛЬ ДАННЫХ [data medium]
 Материальный объект или устройство с определенными физическими свойствами, позволяющими использовать его для записи, хранения и считывания данных. В качестве Н. д. в вычислительной технике применяются полупроводниковые кристаллы, магнитные и лазерные диски, магнитные ленты, магнитные карты, перфокарты и перфоленты, а также бумага, используемая для распечатки. Совместно с устройствами, осуществляющими запись данных на Н. д. и их считывание, Н д образуют запоминающие устройства
НОУТБУК [notebook]
 To же, что портативный компьютер
ОБЛАСТЬ ОПРЕДЕЛЕНИЯ, область существования [definitional domain]
 Участки программы, на которые распространяется описание некоторого объекта и где допустимо использование его имени. В большинстве языков программирования принято следующее правило. Определенное в описании имя константы, типа, переменной, процедуры или функции, либо метки действительно во всем программном блоке, содержащем это описание, и во всех его вложенных блоках (подблоках), за исключением тех подблоков, где эти имя или метка определены заново. Если, например, переменная описала в некотором блоке, содержащем подблоки, то она доступна и в блоке и всех его подблоках, т. е. О. о. такой переменной является сам блок и все его подблоки. Эта переменная является локальной переменной для блока, в котором она описана, и глобальной переменной дли каждого из подблоков.
ОБЛАСТЬ ПАМЯТИ [storage area]
 Последовательность адресуемых элементов памяти (байтов, ячеек памяти и т. п.) с адресами в заданном диапазоне, выделенная для размещения одной или нескольких порций данных
ОБЛАСТЬ СУЩЕСТВОВАНИЯ [definitional domain]
 To же, что область определения
ОБМЕН ДАННЫМИ, обмен [exchange]
 Обобщающее название любой передачи и приема данных в вычислительной системе или сети ЭВМ, если при этом определены или подразумеваются источник и приемник данных. Например. О. д. между винчестером и оперативной памятью. Под О. д. обычно подразумевают весь процесс пересылки данных, включая кодирование, декодирование, буферизацию и контроль по четности
ОБНОВЛЕНИЕ 1 [update]
 To же, что модификация. 2. [upgrade]. To же, что усовершенствование
ОБНУЛЕНИЕ [zero filling]
 Присваивание нулевого значения или занесение непрерывной последовательности нулей в поле данных или область памяти
ОБОЛОЧКА [shell]
 Часть программы, программа или совокупность программ, предназначенная для комплексной автоматизации работы человека с другой программой или комплексом программ, О. является программным средством дружественного интерфейса, создающим для человека наглядные, простые и понятные изображения на экране, удобные средства управления: кнопки, меню, подсказки в диалоге и т. п. См. оболочка операционной системы, графический интерфейс пользователя
ОБОЛОЧКА NORTON COMMANDER [Norton Commander (NC)]
 Оболочка операционной системы MS-DOS IBM-совместимых персональных компьютеров, Разработанная фирмой Peter Norton Computing, Inc. NC обладает характерным набором функций и элементов внешнего оформления, делающим работу с компьютером комфортной для пользователя. Среди них основными являются: оперативная помощь; клавиши быстрого вызова; панели экрана, несущие информацию о дисках; нисходящее меню; командная строка; окна; мышь, подробная оперативная помощь вызывается нажатием клавиши . отправлять функциями NC можно с помощью "горячих клавиш" или меню. Иногда одни и те же действия вызываются и тем и другим способом.
ОБРАБОТКА ТРАНЗАКЦИЙ [transaction processing]
 Действия СУБД Пр управлению параллельным выполнением нескольких транзакций. СУБД следит, к каким данным обращаются транзакции, выполняет блокировку данных, предотвращает тупики и разрешает конфликты, выполняет завершение и откат транзакций
ОБРАБОТЧИК ПРЕРЫВАНИЙ [interrupt handler]
 Программа, выполняющая обработку прерываний.
ОБРАЗ ЗАДАЧИ [task image]
 I. Состояние оперативной памяти задачи записанное во внешнюю память. О. з. включает содержимое областей памяти, отведенных для программы, рабочих областей и связанных с ними блоков управления, а также используемых программой регистров. Многозадачная операционная система формирует О. з. с целью освобождения места в оперативной памяти для задачи с более высоким приоритетом или в режиме разделения времени. Когда будет возможно, О. з. снова загрузится в оперативную память и выполнение задачи продолжится. Кроме того, О. з. может периодически формироваться операционной системой с целью восстановления вычислительного процесса в случае машинного сбоя, отказа оборудовании или неверных ошибочных действий пользователя при диалоговом режиме управления программой.
ОБРАМЛЕНИЕ, окантовка [border]
 l.To же, что граница окна. 2. Декоративная линия, ограничивающая страницу, рисунок и т. п.
ОБРАЩЕНИЕ К ВНЕШНЕМУ УСТРОЙСТВУ [device access]
 1 Действия вычислительной системы, предпринимаемые или подразумеваемые при установлении связи с внешним устройством, включая выполнение устройством определенных функций. Например, обращение к запоминающему устройству предполагает доступ к устройству и полный цикл записи или чтения информации. 2. Ссылка на внешнее устройство
ОБРАЩЕНИЕ К ПОДПРОГРАММЕ [call, subroutine call]
 To же, что вызов подпрограммы
ОБРАЩЕНИЕ К ПРОЦЕДУРЕ [procedure call]
 To же, что вызов процедуры
ОБРАЩЕНИЕ К ФУНКЦИИ [function call]
 To же, что вызов функции
ОБСЛУЖИВАЮЩАЯ ПРОГРАММА, сервисная программа, утилита [service program, utility]
 Программа в составе вычислительной системы, выполняющая общие вспомогательные функции. Например, программа дефрагментации диска или программа поиска и диагностики компьютерного вируса. Систем- О. п. входят в состав операционной системы и выполняют повседневные задачи, например, перезапись данных с одного устройства на другое. Существуют автономные О. п., которые для своего выполнения не требуют операционной системы
ОБУЧАЮЩАЯ ПРОГРАММА (learning program, on-line tutorial]
 1. Программе, выполняющая в диалоговом режиме обучение человека по некоторой дисциплине или по одному из ее разделов. Например, программа обучения одному из языков программирования высокого уровня. О. п. предлагает обучаемому порции учебного материала и контрольные задания по ним в той последовательности, которую требует методика обучения данной дисциплине; определяет правильность выполнения контрольных заданий и указывает характер допущенных ошибок. В зависимости от достигнутых результатов О. п. выбирает дальнейшую последовательность прохождения курса и удобный для обучаемого темп подачи материала. О. п., как правило, обладают дружественным интерфейсом. К О. п. относятся также программы, управляющие обучением людей на тренажерах, позволяющих выработать у человека определенные навыки, необходимые в его профессиональной деятельности. Например, О. п. авиатренажеров. См. автоматизированная обучающая система, интеллектуальная обучающая система. 2. Часть документации программного продукта в виде программы, которая моделирует его работу и предлагает обучающемуся пользователю типичные ситуации, возникающие при работе, контролирует действия пользователя и исправляет ошибки. Например, программа, обучающая работе с мышью.
ОБУЧАЮЩЕЕ ПРИЛОЖЕНИЕ К ПРОГРАММНОМУ ПРОДУКТУ, автоматизированная подготовка [computer based training system (CBT)]
 Обучающая программа, предназначенная для обучения пользователя работе с конкретным программным продуктом. Как правило, О. п. к п. п. реализуется в виде надстройки, которая позволяет пользователю во время обучения работать с самим программным продуктом, а не с его моделью. Ср. обучающая программа.
ОПЕРАНД [operand]
 Элемент данных, участвующий в операции. Например в операции вычитания участвуют два О, — уменьшаемое и вычитаемое, которые являются числами. В машинной команде О могут задаваться явно, как ее составная часть, либо посредством указания адреса О. В языках программирования О. задаются в выражениях в виде констант, переменных, функций и т. п. Например, в арифметическом выражении x+3.1416*sin(z) О. являются переменная х, константа 3.1416 и функция SIN(Z)
ОПЕРАТИВНАЯ ПАМЯТЬ [main memory, main storage]
 Память, непосредственно связанная с центральным процессором вычислительной системы. Только из О- п. вызываются в процессор подлежащие выполнению команды и операнды этих команд, и в нее же записываются результаты выполненных операций. О. п. включает в себя постоянное запоминающее устройство, в котором постоянно хранятся программы и данные, необходимые для работы самого компьютера. Остальные программы вместе с обрабатываемыми данными перед выполнением переписываются в О. п. из внешней памяти. Запоминающие устройства, из которых изготавливается О. п., должны обеспечивать высокую скорость чтения и записи, так как именно быстродействие О. п. ограничивает быстродействие всего компьютера. Поэтому О, п. является сравнительно дорогостоящей, и, чтобы не удорожать ЭВМ, ее память расширяют за счет менее дорогих устройств внешней памяти. В отличие от внешней памяти О. п. иногда называют внутренней. В современных ЭВМ элементы О. п. изготавливаются на микросхемах
ОПЕРАТИВНАЯ ПОМОЩЬ [on-line help, help]
 Помощь, оказываемая пользователю системой в ходе его работы. О. п., как правило, предоставляется при нажатии функциональной клавиши или указании на экранную кнопку с нарисованным вопросительным знаком и имеет вид полсказки, выводимой на экран дисплея. Обычно содержание подсказок охватывает возможности системы, конструкцию операторов (управляющих команд), режимы работы, выход из ошибочных ситуаций.
ОПЕРАТОР [statement, operator]
 1. Допустимое в языке программирования высокого уровня предложение, задающее целостное законченное действие ЭВМ, или представляющее набор описаний. Типичными О. в традиционных языках программирования являются О. ввода-вывода, присваивании, перехода, цикла, процедуры и др. Грамматическая конструкция каждого из них определяется синтаксисом конкретного языка программирования. О. условно делятся на исполняемые О. и невыполняемые О. Исполняемый О. представляет одну или несколько последовательных операций, составляющих алгоритм решения задачи. Невыполняемый О. непосредственно не залает алгоритм, а содержит описания объектов программы либо другую информацию, необходимую для трансляции и выполнения программы. 2. То же, что оператор ЭВМ
ОПЕРАТОР БЕЗУСЛОВНОГО ПЕРЕХОДА [imperative go to statement]
 Оператор перехода, не содержащий никакого условия, а непосредственно указывающий, какой оператор должен быть выполнен следующим. В большинстве языков программирования высокого уровня О. б. п. состоит из слов "GO TO" (перейти к), за которыми ставится метка. Например, в Фортране О. б. п. со то 25 указывает, что следующим должен быть выполнен оператор, помеченный меткой 25. Аналогичную форму имеет О. б. п. в Паскале и Си. Помеченный оператор может располагаться в программе до или после О. б. и. При трансляции программы О. б. п. заменяется компилятором на команду безусловной передачи управления. Чрезмерное увлечение оператором со то приводит к созданию лабиринта в логике' программы, делает программу трудно читаемой. Опытные программисты, пишущие программы на языках Паскаль или Си, практически не используют О. б. п. См. операторы перехода, структурное программирование
ОПЕРАТОР ВВОДА [input statement]
 Оператор в программе, предписывающий передачу данных из устройства ввода или внешней памяти в оперативную память и делающий эти данные доступными программе. В языке программирования может быть несколько конструкций О. в. Вид этих операторов, а также информация, которая должна быть указана транслятору этими операторами, различны и определяются синтаксисом конкретного языка программирования и особенностями внешних запоминающих устройств и устройств ввода. Поэтому в некоторых языках программирования высокого уровня (например, в Си) О. в. не входят в состав основных определений языка. Их Разработка возложена на программистов, проектирующих компиляторы систем программирования. Однако для обеспечения переносимости программ в Различных системах программирования, ориентированных на один язык, применяется стандартный единый набор процедур или функций ввода, в О. в. задается список ввода— перечень переменных и массивов, значения которых должны быть присвоены в процессе ввода данных, и номер устройства или имя файла, из которого данные читаются.
ОПЕРАТОР ВЫЗОВА ПОДПРОГРАММЫ, оператор обращения к подпрограмме [call(ing) statement]
 В языках программирования оператор CALL, задающий вызов подпрограммы: передачу подпрограмме фактических параметров, передачу управления на вход в подпрограмму, выполнение действий, запрограммированных в подпрограмме, и возврат управления вызывающей программе.
ОПЕРАТОР ВЫЗОВА ПРОЦЕДУРЫ, оператор обращения к процедуре [cat-ng procedure statement]
 To же, что оператор процедуры
ОПЕРАТОР ВОЗВРАТА [return statement]
 Оператор, завершающий выполнение процедуры или функции и передающий управление вызывающей программе. Как правило, О. в. обозначается ключевым словом Return (возврат) располагается в теле процедуры или функции, обычно О. в. передает управление либо оператору вызывающей программы, в котором содержался вызов функции (в случае функции), либо оператору, следующему за оператором вызова процедуры (в случае процедуры). В некоторых языках программирована (например, в Фортране) существует конструкция О. в., позволяющая передавать управление любому помеченному оператору вызывающей программы. Для этого его метка должна быть указана как фактический параметр в операторе вызова полпрограммы. В некоторых языках программирования (например, в Си) с помощью О. в. имени функции может присваиваться значение, возвращаемое в вызывающую программу как результат вычисления функции
ОПЕРАТОР ЗАДАНИЯ ФОРМАТА, оператор формата [format statement]
 Оператор, задающий формат вводимых и выводимых данных. Он используются при работе операторов ввода и вывода и описывает форму представления данных и их расположение в записи ввода-вывода. Связь оператора ввода (или вывода) с О. з. ф. обычно осуществляется с помощью метки, записанной как в операторе ввода (или вывода), так и перед О. з. ф. Работу О. з. Ф можно объяснить только во взаимодействии с соответствующим ему оператором ввода или вывода. Например, в памяти компьютера хранятся значения переменных К = 15 и R = —123.45678. Вывод этих величин на экран запрограммирован на языке Фортран оператором вывода и О. з. ф.
ОПЕРАТОРНЫЕ СКОБКИ [statement brackets]
 В языках программирования - ключевые слова begin и end или другие символы (например, фигурные скобки в языке Си), ограничивающие последовательность операторов программы. О. с. ставятся в целях объединения нескольких операторов в составной оператор, представляющий единую синтаксическую конструкцию.
ОПЕРАТОР ОБРАЩЕНИЯ К ПРОЦЕДУРЕ [procedure statement]
 To же, что оператор процедуры
ОПЕРАТОР ПРИСВАИВАНИЯ [assignment statement]
 Оператор, передающий значение арифметического, логического или другого выражения одной или нескольким переменным, либо имени функции. Действие присваивания обычно обозначается символами: "=" (например, в языках Фортран и Си) и ": =" (в языке Паскаль). Слева от символа присваивания пишется имя переменной (или имена переменных), которой должно быть присвоено значение выражения, стоящего справа. При выполнении О. п. вначале вычисляется значение выражения, а затем оно передается переменной. Например, О. п. K=k+1 предписывает вычислить значение выражения к + 1, используя текущее значение переменной k; затем текущее значение k заменить значением только что вычисленного выражения. Короче говоря, увеличить к на единицу. Тип переменной, стоящей слева в О. п. может не совпадать с типом выражения, стоящего справа. Соответствующее преобразование типов обычно автоматически закладывается в объектную программу при компиляции. Однако во избежание возможной потери информации при преобразовании типов желательно, чтобы тип переменной и тип выражения были одинаковыми. В языке Си возможно присваивание одинакового значения нескольким переменным с помощью одного О. п. Например, х = у = о.о;
ОПЕРАТОРЫ ЦИКЛА ЯЗЫКА СИ, предложения цикла языка Си [С loop statements, С loop sentences]
 Для программирования циклов в языке Си предусмотрены следующие основные конструкции предложений: Цикл с предусловием, общий вид которого: while (<выражение>) <тело цикла> Тело цикла будет повторно выполняться до тех пор, пока выражение не станет ложным или равным нулю. Если это выражение ложно или равно нулю при первой же проверке, то тело цикла не выполняется вообще. Телом цикла может служить одиночный оператор или несколько последовательных операторов, заключенных в фигурные скобки (и ^составной оператор). Например, while (summa<1000] {summa = summa + step; step = 2 * step}; Цикл с постусловием, общий вид которого: do <тело цикла> while (<выражение>); Тело цикла будет повторно выполняться до тех пор, пока логическое выражение не станет ложным, или равным нулю. Так как условие проверяется в конце тела цикла, само тело будет выполнено хотя бы один раз. Телом цикла может служить одиночный или составной оператор. Например, do {ch:~ getchar(); putchar(ch);} while(ch!= '\n'); Цикл с предусловием, который удобно применять, как цикл с параметром. Общий вид цикла имеет форму: for (<инициализирующее выражение:»; -(проверяемое выражение>; <корректирующее выражение>) <тело цикла> В операторе for используются три выражения, разделенные символом "точка с запятой". Инициализирующее выражение вычисляется только один раз до начала выполнения какого-нибудь из операторов цикла. Если проверяемое выражение оказывается истинным или не равным нулю, тело цикл* выполняется один раз. Затем вычисляется корректирующее выражение, и снова вычисляется проверяемое выражение. Таким образом, тело цикла выполняется до тех пор, пока проверяемое выражение не станет ложным ИЛИ равным нулю. Так как решение об очередном выполнении тела цикла принимается до начала его прохождения, то может случиться, что тело цикла не выполнится ни разу. Телом цикла может служить одиночный или составной оператор. Например, for (i = 1; i < = 10; i++) { с = a[i]; a[I] = b[i]; b[i] = с}
ОПЕРАТОР ЭВМ [operator]
 Специалист, контролирующий ЭВМ и управляющий ее работой и работой ее отдельных устройств. В настоящее время Q э. работают в вычислительных центрах на крупных вычислительных комплексах или обслуживают сети ЭВМ
ОПЕРАЦИОННАЯ СИСТЕМА (ОС) [operating system (OS)]
 Комплекс программ- организующих вычислительный процесс в вычислительной системе. Основными функциями ОС являются распределение ресурсов вычислительной системы между задачами с целью их наиболее эффективного использования и облегчение работы пользователя с вычислительной системой. Выполняя первую функцию, ОС учитывает и распределяет ресурсы, управляет центральным процессором, памятью, вводом - выводом, обеспечивает выполнение операций над файлами, выступает в роли диспетчера, запуская па выполнение прикладные программы, обеспечивает взаимодействие программ с техническими устройствами и пользователем. Выполнял вторую функцию, она предоставляет пользователю удобный интерфейс с программным обеспечением и устройствами компьютера, а также выполняет вспомогательные действия, такие как копирование или печать файлов. ОС может одновременно поддерживать работу на компьютере одной задачи — быть однозадачной или одновременно поддерживать работу нескольких программ — быть многозадачной (мультизадачной). Пользователь управляет ОС с помощью команд операционной системы. Для управления работой IBM-совместимых персональных компьютеров чаще всего используются ОС MS-DOS и Windows. На персональных компьютерах на базе процессоров 80486 или Pentium с большой оперативной памятью (не ниже 32 Мб) возможна установка ОС OS/2, Windows NT или UNIX
ОПЕРАЦИОННАЯ СИСТЕМА MS-DOS (ОС MS-DOS), MS-DOS [operating system MS-DOS (OS MS-DOS)]
 Разработанная фирмой Microsoft операционная система IBM-совместимых персональных компьютеров. За последние годы фирма выпустила несколько версий: 3.30, 4.01, 5.0 и 6.0, меняя которые, опытные пользователи IBM PC каждый раз получали заметные преимущества, MS-DOS 6.0 обеспечивает: автоматический запуск с первоначальным самотестированием аппаратных и программных средств, режим многовариантной конфигурации компьютера, диалог с пользователем, управление процессом выполнения операций, управление внешними устройствами, обработку запросов ввода-вывода, буферизацию, блокировку данных, планирование и обработку прерываний, организацию разделов памяти, сегментирование, динамическое и оверлейное размещение модулей, доступ к верхней и Дополнительной памяти, диспетчеризацию очередей и многое другое
ОПЕРАЦИОННАЯ СИСТЕМА UNIX (ОС UNIX), UNIX [operating system (OS UNIX), UNIX]
 Интегрированная многозадачная операционная система предоставляющая пользователю удобный язык команд и диалоговый интерфейс. Первоначально разработана в начале 70-х годов специалистами фирмы Bell Laboratories для ЭВМ серии PDP-11. В дальнейшем получила широко, распространение на ЭВМ различных классов и типов. Выделенная мобильная основная часть OS UNIX, написанная на языке Си, обеспечивает ее переносимость и переносимость программ, разработанных под UNIX, на машины с различными системами команд. В ОС UNIX впервые реализованы три основные концепции операционных систем: файловой системы, процессу „ оболочки. Файловая система хранения программ, данных и текстов обеспечивает единый интерфейс всех видов ввода-вывода, а также средства защитить от аппаратных сбоев и несанкционированного доступа. Процесс, который ОС рассматривает как единое целое при распределении ресурсов, характеризуется последовательностью операций при выполнении программы, используемыми этими операциями данными, открытыми файлами, текущим каталогом и т. п. Оболочка имеет удобные средства диалога пользователя с системой, включая язык (SHELL, CSHELL), позволяющий создавать новые команды, изменяя и подстраивая пользовательский интерфейс по желании, пользователя. Кроме того, ОС UNIX предоставляет ряд средств: разработки программ на различных языках программирования, машинной графики, поддержки сетей ЭВМ и т.д. Важным свойством системы является се открытость для расширения. Все это позволяет назвать ОС UNIX интегрированной средой, которая постоянно развивается и совершенствуется. ОС UNIX сыграла важную роль в создании и развитии сети Интернет. Для персональных компьютеров есть разные версии ОС UNIX. Наиболее распространенные из них — BSD и System V
ОПЕРАЦИОННАЯ СИСТЕМА WINDOWS (ОС WINDOWS) [operating
 Собирательное название для набора операционных систем, разработанных фирмой Microsoft для персональных IBM-совместимых компьютеров. Все OCW. обеспечивают основные функции управления вычислительной системой и взаимодействия с пользователем. В настоящее время существует несколько вариантов ОС W., существенно отличающихся по архитектуре и возможностям, а для каждого варианта выпушено несколько версий. Ниже приведен краткий обзор наиболее популярных ОС W. 1) Повсеместное признание ОС W. получила с появлением версий Windows 3.x, которые представляют собой 16-разрядные операционные системы, предназначенные для управления автономными персональными компьютерами и рабочими станциями в локальной сети. Главным достоинством этих операционных систем явилось использование графического интерфейсе пользователя, что и обусловило их широкое распространение. 2) Появившаяся на рынке в 1995 г. Windows 95 представляет собой интегрированную 32-разрядную многозадачную операционную систему общего назначения. Она позволяет создать информационную среду с удобным, ориентированным на рабочий стол дружественным интерфейсом. Включает и себя средства мультимедиа и 32-разрядную файловую систему CD-ROM, обеспечивающие высококачественное воспроизведение цифровой видеозаписи, средства компьютерной связи, упрощающие подключение к Интернет, встроенные возможное™ приема и передачи факса и электронной почты. Кроме того, Windows 95 позволяет создать свою собственную локальную вычислительную сеть. Windows 98 — следующая после Windows 95 операционная система. По сравнению с Windows 95 она обеспечивает: ускоренную загрузку программ; интеграцию браузера Интернет в систему; активный рабочий стол; возможность самообновления; поддержку нескольких мониторов и до 127 внешних устройств; возможность установить расписание чистки памяти. При этом увеличивается место, занимаемое системой на жестком диске (до 295 Мб). 3} Параллельно с разработкой Windows 9x корпорация Microsoft создала семейство операционных систем Windows NT (New Technology). Существуют варианты, предназначенные для управления рабочей станцией (Windows NT Workstation), и варианты, предназначенные для управления сервером локальной сети (Windows NT Server). Эти 32-разрядные операционные системы отличает особо высокая надежность, устойчивость, безопасность и производительность, однако их требования к ресурсам вычислительной системы несколько выше, чем у Windows 9x. 4) Семейство Windows СЕ специально предназначено для управления встроенными системами, организаторами персональной деятельности и другими специализированными компьютерами с ограниченными ресурсами. Интерфейс этих операционных систем подобен интерфейсу других ОС W., но архитектура существенно отличается. Например, Windows СЕ может работать на компьютере, на котором отсутствует клавиатура или жесткий диск
ОПЕРАЦИОННАЯ СРЕДА [operational environment]
 Операционная система и ее приложения, которыми пользуется и во взаимодействии с которыми выполняется (работает) программа. О. с. накладывает свой отпечаток как на саму программу, так и на характер и качество ее работы. Например, поскольку текстовый редактор Microsoft Word 7.0 для Windows 95 работает в О с. Windows 95, он обладает всеми преимуществами ее графического интерфейса
ОПЕРАЦИЯ [operation]
 L Действие, выполняемое над данными. 2. Последовательность элементарных действий различных устройств компьютера, Реализующая выполнение команды.
ОРГАНИЗАТОР ЛИЧНОЙ ДЕЯТЕЛЬНОСТИ [personal digital assistant (PDA)]
 Карманный персональный компьютер, используемый для записи заметок, планирования встреч и выполнения других несложных задач В О. л. д. обычно используется специальная операционная система и отсутствует возможность установки дополнительных приложений. Часто в О. л.д отсутствует клавиатура и ввод данных осуществляется с помощью сенсорного экрана.
ОСНОВНАЯ ПАМЯТЬ [main memory, main storage]
 1. To же, что оперативная память. 1. Составная часть оперативной памяти персональных 1ВМ-совместимых компьютеров при работе в среде MS-DOS
ОСНОВНАЯ ПРОГРАММА [main program, head program]
 To же, что главная программа
ОСНОВНОЙ КЛЮЧ, первичный ключ [master key]
 Ключ, однозначно идентифицирующий запись в файле. Кроме О. к. в записи могут быть предусмотрены не основные (вторичные) ключи
ОСОБАЯ СИТУАЦИЯ [exception]
 To же, что исключительная ситуация
ОСТАНОВ [stop, halt]
 Прекращение автоматической выборки и выполнения команд центральным процессором. О. может быть вызван причинами. связанными с выходом из строя одного из устройств ЭВМ или операционной-системы — аварийный О., а может быть программируемым — предусмотренным выполняемой программой.
ОТКАТ [backtracking, undo]
 1. В текстовых редакторах и системах программирования — действия, отменяющие результат выполнения предыдущей команды или нескольких предыдущих команд и восстанавливающие измененное этими командами состояние обрабатываемого текста или переменных. 2. Возврат вычислительного процесса к ранее запомненному состоянию О. выполняется с целью восстановления вычислительного процесса после машинного сбоя, отказа оборудования или ошибочных действий пользователя при диалоговом режиме управления программой. Возможность О. обеспечивается операционной системой, которая может периодически формировать образ задачи, либо заранее предусматривается программистом путем создания в программе контрольных точек.
ОТКАТ ТРАНЗАКЦИИ [rollback, transaction rollback]
 Действия, выполняемые СУБД при обработке транзакций в том случае, когда успешного завершения транзакции не произошло. О. т. заключается в том, что отменяются результаты всех операций транзакции, а данные возвращаются в то исходное состояние, которое они имели ло начала выполнения транзакции. О. т. может быть вызван различными причинами: 1) О, т. может быть выполнен по инициативе самой транзакции, например, если в процессе ее выполнения обнаруживается, что завершение транзакции приведет к нарушению целостности данных; 2) О. т. может быть вызван машинным сбоем в процессе вы- выполнения транзакции; 3) О. т. может быть выполнен по инициативе СУБД для выхода из тупиковой ситуации.
ОТКРЫТИЕ ФАЙЛА, активизации файла [file activation]
 Операция начала работы программы с файлом. Открыть файл, значит, связать программу с файлом: установить соответствие между физическим файлом на внешнем запоминающем устройстве, буферной памятью и набором данных программы, заполнить соответствующие поля в управляющих таблицах операционной системы и т. п. Иными словами, выполнить все операции, необходимые для обеспечения доступа к содержимому файла. Противоп. закрытие фата.
ОТКРЫТЫЙ ФАЙЛ, активный файл [active file]
 Файл, для которого выполнена операция открытия файла, в результате чего его записи стали доступными для чтения и обработки. Противоп. закрытый файл
ОТКРЫТЫЙ ДОСТУП К БАЗАМ ДАННЫХ [open database connectivity
 Стандартный метод доступа к базам данных, разработанный фирмой Microsoft. В большинстве случаев доступ к данным при помощи О. д. б. д. включает три этапа: 1) установка драйвера базы ДЗЕШЫХ; 2) создание источника данных при помощи утилиты ODBC из панели управления Windows; 3) использование инструкций языка запросов SQL для доступа к базе данных
ОТЛАДКА ПРОГРАММЫ [program debugging]
 Этап разработки программы, состоящий в локализации, выявлении и устранении программных ошибок, факт существования которых уже установлен. О. п. имеет место тогда, когда очевидно, что программа либо не компилируется, либо работает неправильно. Синтаксические ошибки обычно выявляются в процессе компиляции программы. Наличие некоторых синтаксических, а также смысловых или семантических ошибок устанавливается в процессе тестирования программы. В системах программирования существуют специальные средства О. п. — отладчики, которые позволяют в режиме интерпретации установить контрольные точки, выполнить отдельные участки программы и просмотреть результаты работы операторов. Очень эффективной может оказаться трассировка программы, но не будучи тщательно спланированной, она приводит к таким объемам выдаваемой информации, что разобраться в ней программисту бывает просто не под силу. Однако программисту редко удается обойтись стандартными средствами О. п. Желательно еще на этапе программирования предусматривать и вводить в программу собственные средства О. п., отслеживающие ход выполнения алгоритма, обращения к переменным и подпрограммам или воспроизводящие значения переменных. В этом случае места ошибок могут определяться с большой точностью.
ОТЛАДОЧНЫЙ КОМПИЛЯТОР [checkout compiler]
 Компилятор, обладающий средствами, облегчающими пользователю отладку программы. О. к. способен обнаруживать больше синтаксических ошибок, чем обычный, поскольку он детально анализирует синтаксическую конструкцию и взаимодействие операторов. Существуют О. к., способные устранять отдельные виды синтаксических ошибок. Кроме того, в процессе трансляции О. к. производит многочисленные проверки исходной программы, выявляющие переменные, для которых не заданы начальные значения, неправильные индексы и запрещенные переходы. Процесс компиляции программ О. к. осуществляется значительно медленнее по сравнению с обычным компилятором, и, как правило, О. к. не являются оптимизирующими
ОТЛАДЧИК [debugger]
 Программа, облегчающая программисту выполнение отладки разрабатываемых им программ. О. помогает анализировать поведение отлаживаемой программы, обеспечивая ее трассировку, выполняя остановы в указанных точках или при указанных условиях, позволяя просмотреть текущие значения переменных, содержимое ячеек памяти, а иногда и регистров процессора, и при необходимости изменить эти значения. О. является важной составной частью системы программирования.
ОТМЕТКА ФАЙЛОВ И КАТАЛОГОВ [files and directories marking]
 Выделение одного или группы файлов или каталогов с целью копирования, переноса или удаления. При работе с Norton Commander можно отметить файлы и каталоги по одному, нажимая клавишу . При этом цветовой маркер на активной панели NC перемещается на строку вниз, а строка, на которой он находился, отмечается (окрашивается в другой цвет). Можно также отмечать файлы, используя шаблон имени файла. Для этого следует нажать на малой цифровой клавиатуре клавишу <+>. На экране появится окно с уже введенным шаблоном *.* (отметить вес файлы). В этот шаблон можно внести изменения. Например, чтобы отметить все файлы с расширением ш, необходимо ввести шаблон .txt. Далее следует нажать клавишу . Окно исчезнет, а файлы, имена которых соответствуют шаблону, будут отмечены. Можно снять отметку, нажав клавишу <-> на цифровой клавиатуре. В операционной системе Windows О. ф. и к. выполняется с помощью мыши или другого указательного устройства.
ОТНОСИТЕЛЬНЫЙ АДРЕС [relative address]
 Адрес, выражающий разницу отношению к значению базового адреса. Команды объектных модулей всегда содержат О. а., как правило, выражающие номера байтов или ячеек памяти относительно начала области памяти, занимаемой программой, или начала ее рабочей области. В процессе загрузки программы устанавливаются базовые адреса, соответствующие фактически распределенной памяти и л а. либо сразу пересчитываются в физические адреса, либо процессор вычисляет физические адреса команд и данных во время выполнения программы. Применение О. а. делает программу независимой от места ее расположения в оперативной памяти во время выполнения.
ОТНОШЕНИЕ [relation]
 В языках программирования высокого уровня — лва арифметических выражения, соединенные знаками операций сравнения, например, х = 0.5, А + В в < 1, cos(z) >= z. Значением О. является логическое значение "истина" или "ложь" (да или нет). Если условие О. выполнено, то результат— "истина". В противном случае результат— “ложь”. Например, если х = 0.5, то результатом О. х = 0 будет "ложь". О. само является логическим выражением, либо входит в него как составная часть.
ОТСТУП [indent]
 Расстояние от текста до поли страницы. Например, небольшой О. первой строки абзаца называется красной строкой. О. может быть слева и справа. Можно использовать отрицательные отступы для размещения текста на полях
ОЦИФРОВЫВАТЬ [digitize]
 Преобразовывать любую непрерывно изменяемую информацию в цифровую форму данных. Так, сканер О. рисунок на бумаге, преобразуя нарисованные линии и цветовые оттенки в двоичный код. который вводится в память компьютера. Непрерывный звуковой сигнал О. в комбинацию нулей и единиц, которая записывается на лазерный диск-Процедура оцифровки обычно выполняется с помощью аналого-цифрового преобразователя
ОЧЕРЕДЬ [queue]
 Упорядоченный набор элементов данных, в который можно удалять и добавлять элементы, причем новый элемент всегда записывается в его конец, а очередной читаемый или удаляемый элемент всегда выбирается из его начала. Таким образом, первый добавленный элемент О. является единственным доступным и первым удаляемым элементом (по принципу "первым вошел — первым ушел").
ОШИБКА АЛГОРИТМА [algorithm error]
 To же, что логическая ошибка
ОШИБКА В ПРОГРАММЕ, программная ошибка [program error, malfunction]
 Любая ошибка, содержащаяся в программе. Наличие О. в п. очевидно, когда программа либо не компилируется, либо работает неправильно. Различают синтаксические и семантические ошибки. Они выявляются при трансляции и испытаниях программы и устраняются в процессе отладки программы
ПАКЕТ [batch, package, packet]
 1. Порция данных, передаваемая как о целое. Например, в сети Интернет передаваемые данные разбиваются и. размером от 40 до 32000 байт в зависимости от аппаратных средств и носителей информации, и каждый П. перемешается по сети независимо от других П 2. Совокупность программ, выполняемых компьютером в режиме пакетной обработки
ПАКЕТ ДИСКОВ [disk pack]
 To же, что пакет магнитных дисков
ПАКЕТ МАГНИТНЫХ ДИСКОВ, пакет дисков [disk pack]
 Сменный блок магнитных дисков, в котором несколько одинаковых жестких магнитных дисков расположены соосно на равных расстояниях друг от друга. Диски жестко соединены между собой, чтобы сохранить устойчивость пакета при вращении с большой скоростью в дисководе. Информация записывается на обеих сторонах каждого диска вдоль концентрических дорожек, которые обычно делятся на секторы. Доступ к секторам осуществляется при вращении пакета. П. м. д. широко применялись в ЭВМ второго и третьего поколений. Все головки записи-чтения располагаются на одной линии, параллельной оси пакета, и имеют общее устройство позиционирования, которое обеспечивает их одновременное расположение над дорожками с одинаковыми номерами, находящимися на различных поверхностях дисков. Такая конструкция позволяет уменьшить время выборка взаимосвязанных записей, размещая их на одном цилиндре, образованном дорожками с одинаковыми номерами. П. м. д. проектируются с учетом международных стандартов, обеспечивающих их совместимость с дисководами как по механическим, так и по магнитным характеристикам. Необходимая для контроллера дисковода информация о шаге дорожек и размещении на них секторов записывается на специальной поверхности пакета, называемой сервоповерхностью. Вне дисковода пакет хранится в пластмассовом кожухе, предохраняющем его от пыли и механических повреждений
ПАКЕТНАЯ ОБРАБОТКА, пакетный режим [batch processing, batch mode]
 Режим или метод организации работы вычислительной системы, при котором задания или накопленные заранее данные по определенным критериям объединяют в пакет для последующей автоматической обработки в соответствии с заданными приоритетами. При этом управление обработкой осуществляется операционной системой, и пользователь не может влиять на ход выполнения заданий, пока продолжается обработка пакета. П. о. широко применялась во втором поколении ЭВМ с целью снижения непроизводительных затрат машинного времени и эффективного использования оборудования В настоящее время применяется П. о. фоновых задач в системах коллективного пользования
ПАКЕТНЫЙ РЕЖИМ [batch mode]
 To же, что пакетная обработка
ПАКЕТНЫЙ ФАЙЛ [batch file]
 To же. что командный файл
ПРИКЛАДНЫХ ПРОГРАММ (ППП) [application program package]
 Система прикладных программ, предназначенных для решения прикладных задач определенной предметной области. Например, ППП, позволяющих проводить прочностные расчеты инженерных конструкций. Обычно программы, входящие в ППП могут совместно использовать одни и те же данные и объединяются единым пользовательским интерфейсом. Развитые ППП содержат программу-монитор, программы планирования работ и допускают формулирование заданий в терминах предметной области
ПАЛИТРА [palette]
 1. Множество цветов, которые можно отобразить на экране дисплея. Богатство П, зависит как от аппаратного, так и от программного обеспечения. Монитор и видеоадаптер компьютера определяют разрешающую способность экрана и максимально возможное количество отображаемых на нем цветов. Однако имеющееся программное обеспечение может не использовать всех графических возможностей, предоставляемых аппаратурой, и ограничить число цветов, доступных для формирования изображения. Цвет каждого пиксела в машинной программе задается двоичным кодом. Поэтому количество цветов в П. определяется числом бит, отведенным для представления цвета одного пиксела. Например, если для представления цвета пиксела отводится 4 бита, то пиксель может иметь 16 цветов (коды от 0000 до 1111). Следовательно, 4-битовый пиксел допускает 16-цвст-ную П. 2. Таблица соответствия между кодами цветов и цветами, отображаемыми на экране дисплея. 3. Набор цветов в программах рисования или набор цветов и инструментов рисования в программах раскраски.
ПАМЯТЬ [memory, storage, store]
 I. Общее название для любых реальных или абстрактных средств и механизмов фиксации и сохранения информации. 2. То же, что память ЭВМ. 3. То же, что запоминающее устройство
ПАМЯТЬ ПРОИЗВОЛЬНОГО ДОСТУПА, память прямого доступа [random access memory (RAM)]
 To же. что память произвольного доступа
ПАМЯТЬ ЭВМ [memory, storage, store]
 Функциональная часть ЭВМ, предназначенная для записи, хранении и считывания информации. П. Э. подразделяется на основную или оперативную память и внешнюю память. Технических реализуется в виде запоминающих устройств.
ПАНЕЛЬ [panel]
 To же, что панель экрана
ПАНЕЛЬ ИНСТРУМЕНТОВ, инструментальная панель [toolbar]
 Панель экрана с размешенным на ней пиктографическим меню. На панели сосредоточены кнопки вызова инструментальных программных средств, с помощью которых выполняются стандартные действия, например, создание открытие, сохранение, печать документа и т. д. "Нажатие" нужной кнопки с помощью мыши приводит к выполнению соответствующего действия
ПАНЕЛЬ УПРАВЛЕНИЯ [control panel]
 В операционной системе Windows -окно, в котором собраны .тачки различных обслуживающих программ, предназначенных для настройки операционной системы и среды пользователя
ПАНЕЛЬ ЭКРАНА, экранная панель, панель [screen panel, panel]
 Выделенная часть экрана дисплея или окна, предназначенная для размещения меню, управляющих кнопок, справочной и другой информации. Пользователь не может изменять размеры и расположение П. э. (а размер окна — может). Например, П. э. оболочки Norton Commander, несущие информацию о дисках
ПАПКА [folder]
 To же, что каталог
ПАРАЛЛЕЛЬНАЯ ОБРАБОТКА [concurrent processing, parallel processing,
 Режим работы ЭВМ, при котором на ней выполняются несколько параллельных, вычислительных процессов. Этот режим может быть реализован как на многопроцессорной ЭВМ. так и на компьютере с од ним процессором. В последнем случае необходима многозадачная операционная система, обеспечивающая разделение времени между программами. Поскольку кванты времени, предоставляемые чередующимся процессам для человека неразличимо малы, эти программы кажутся выполняемыми параллельно. На многопроцессорной ЭВМ П. о. может означать как одновременное выполнение нескольких задач, Так и решение одной задачи, параллельный алгоритм которой позволяет распределить отдельные ее сегменты но всем доступным в данный момент процессорам.
ПАРАЛЛЕЛЬНЫЙ АЛГОРИТМ [parallel algorithm]
 Алгоритм, в котором можно выделить и одновременно выполнить независимые друг от друга группы операций. Примером П. а. может служить алгоритм умножения матрицы на вектор, в котором каждая компонента результирующего вектора может быть вычислена независимо от других. П. а. может быть реализовав ;; виде программы, задающей несколько параллельных вычислительных процессов
ПАРАЛЛЕЛЬНЫЙ ВЫЧИСЛИТЕЛЬНЫЙ ПРОЦЕСС [parallel calculation]
 Один из двух или более вычислите.1ьных процессов, одновременно выполняющих на ЭВМ за счет использования различных ресурсов вычислительной системы. Например, в многопроцессорной ЭВМ, используя разные процессоры, можно либо параллельно решать различные задачи, либо вести вычисления одной задачи согласно параллельному алгоритму. В этих случаях на разных процессорах будут выполняться П. в. п.
ПАРАЛЛЕЛЬНЫЙ ПОРТ [parallel port]
 Порт, передающий данные порциями по несколько бит параллельно по нескольким линиям связи. Например если процессор соединен с внешним устройством восемью проводами через П. п., то он будет способен передавать одновременно 8 байт информации — по одному биту в каждую линию.
ПАРАМЕТР ЦИКЛА, переменная цикла, управляющая переменная цикла [cycle parameter, cycle index, loop variable]
 Переменная, используемая в операторе цикла Х1Я управления повторением тела цикла. Например, в написанных на языках Фортран, Паскаль и Си операторах цикла DO 10 к = 1, 50, for i:= I to 65 do... ... И for ( count = 1; count <= number; count++}... П. Ц. являются, соответственно, переменные к, i и count
ПАРОЛЬ [password]
 Уникальная последовательность символов, которую необходимо ввести по запросу компьютера, чтобы получить доступ к системе, программе или данным. Система сравнивает введенный П. с хранящимся в памяти образцом. Если произошло совпадение кодов, пользователь получает желаемый доступ. Предполагается, что П. известен ограниченному кругу лиц и поэтому считается средством ограничения доступа к вычислительной системе и ее файлам.
ПАСКАЛЬ [Pascal]
 Язык программирования высокого уровня. Предварительная версия П., разработанная швейцарским ученым Н. Виртом, была опубликована в 1968 г. и предназначалась для обучения программированию, как систематической дисциплине. Впоследствии, претерпев некоторые изменения, П. стал одним из основных языков программирования вычислительных и информационно-логических задач. Структуры данных (массивы, записи, файлы и типы данных, определяемые пользователем), а также процедуры и основные управляющие конструкции языка (условные операторы, операторы цикла и вызова процедур) позволяют использовать весь набор методов структурного программирования и создавать простые, понятные и удобочитаемые программы. П. был относительно легко реализован на многих типах ЭВМ. Особенно популярны разрабатываемые фирмой Borland International Inc. среды программирования для персональных компьютеров, основанные на языке П- (Turbo Pascal, Borland Pascal, Delphi), которые постоянно развиваются и широко применяются многими разработчиками программного обеспечения
ПОЛНОМОЧИЕ [authorization, right]
 Право пользоваться сетью ЭВМ, вычислительной системой, программой или защищенными данными. Необходимость в получении П. возникает, например, для доступа к вычислительной системе и хранящимся в ней файлам в случае, если круг пользователей ограничен. Обычно П. даются пользователю администратором системы в виде пароля, который необходимо ввести по запросу компьютера, чтобы получить доступ к системе, программе или данным.
ПОЛНЫЙ ЭКРАН [full screen view]
 Режим, при котором на экране отображается только документ, и не отображаются панели инструментов, строк меню и прочие элементы интерфейса пользователя
ПОЛОСА ПРОКРУТКИ [scroll bar]
 To же, что линейка прокрутки
ПОЛУЖИРНЫЙ ШРИФТ [bold, boldface]
 Начертание шрифта, при котором для изображения символов используются более толстые линии, а ширина символов несколько увеличена. В данном словаре П. ш. выделены, например, заголовки словарных статей, имена диалоговых окон, полей ввода и др. элементов графического интерфейса.
ПОЛЬЗОВАТЕЛЬ [client, user]
 1. Человек или организация, пользующее. вычислительной системой или программным средством. 2. Программа, использующая данный программный модуль
ПОЛЬЗОВАТЕЛЬСКИЙ ИНТЕРФЕЙС [user interface]
 To же, что интерфейс пользователя
ПОМЕЧЕННЫЙ ОПЕРАТОР [labeled statement]
 Оператор в программе снабженный меткой
ПОРТ [port]
 I. Устройство сопряжения, с помощью которого центральный процессор или оперативная память ЭВМ могут быть снизаны с другими устройствами с целью передачи данных. Например, через П. подключаются к шине процессора устройства ввода-вывода, а программа может посылать данные в П. или получать данные из П. Обычно один и тот же П. может работать на ввод или вывод. По способу передачи данных различают параллельный и последовательный порты. 2. В сети Интернет — число, которое идентифицирует (определяет) конкретную прикладную программу Интернет
ПОРТАТИВНЫЙ КОМПЬЮТЕР [portable computer]
 Малогабаритный переносной персональный компьютер, способный работать от автономного источника питания. Современные П. к., как правило, ни в чем не уступают настольным. Они имеют сравнимые с ними по характеристикам процессор оперативную память, плоский дисплей на жидких кристаллах, клавиатуру, энергонезависимую память и средства подключения внешних устройств. Различают П. к. классов laptop (наколенный компьютер) и notebook (блокнот). К П, к. относятся и так называемые пен-компьютерьг (реп computer— перьевой компьютер). Это электронные записные книжки, в которых первичным устройством ввода является перо, а не клавиатура
ПОРТРЕТНАЯ ОРИЕНТАЦИЯ СТРАНИЦЫ [portrait page orientation]
 To же, что книжная ориентация страницы
ПОРЯДКОВЫЙ ТИП [serial number type]
 Обобщающее название для типа данных, каждому значению которого ставится во взаимно однозначное соответствие некоторый порядковый номер. К П. т. относятся стандартные типы: целый тип (каждое целое число может рассматриваться, как порядковый номер), символьный тип (код символа может рассматриваться, как порядковый номер) и логический тип с двумя порядковыми номерами 0 и 1. Также к П. т, относится любой перечисляемый тип
ПОСЛЕДОВАТЕЛЬНЫЙ ДОСТУП [sequential access, serial access]
 1. Способ доступа к данным, при котором записи файла считываются в том же порядке, в котором они были записаны при его создании. Такая логическая последовательность записей вовсе не означает, что и физически записи расположены последовательно, например, для файла, размещенного на магнитном диске. Впрочем, часто логическая и физическая последовательности ^впадают. 2. Способ доступа, при котором данные считываются в оперативную память в порядке их физического размещения на носителе данных запоминающего устройства. При этом для обращения к нужной записи необходимо последовательно «просмотреть» все участки носителя, начиная либо с самого первого, либо со следующего за тем, к которому было предыдущее обращение. Такой способ доступа осуществляется, например, к данным, хранящимся на магнитных лентах.
ПРИГЛАШЕНИЕ, подсказка [prompt]
 Текст, значок или другое изображение на экране дисплея, указывающее, что программа или система ввода пользователем команд или данных. П. может содержать некоторую нужную пользователю информацию о текущем состоянии системы, мер, в П. операционной системы MS-DOS: C:\EXE> сообщается о дисководе С: и текущем каталоге ЕХЕ
ПРИЕМНИК ДАННЫХ (СООБЩЕНИЙ) [data (message) sink]
 Функциональное устройство, получающее передаваемые данные
ПРИКЛАДНАЯ ПРОГРАММА [application program]
 1. Программа, предназначенная для решения задачи или класса задач в определенной области науки, техники, экономики, искусства, народного хозяйства, связанны с применением вычислительной системы. Например, программа расчета прочности стержневых конструкций, программа резервирования железнодорожных билетов и т. п. 2. Программа, использующая средства, предоставляемые системной программой. В этом смысле термин "П. п." применяется к программе, чтобы отличить ее от системных программ, таких как операционная система или средства разработки и отладки программ
ПРИЛОЖЕНИЕ [application]
 Прикладная программа, предназначенная для выполнения под управлением определенной операционной системы с использованием определенного типа компьютера. Например, текстовый редактор Microsoft Word 7.0 для Windows 95 является приложением Windows 95; выполняемым на IBM-совместимых персональных компьютерах
ПРИМИТИВ [primitive]
 1. Элемент, который нельзя разложить на более простые формы. В языках программирования высокого уровня этот термин используется для обозначения встроенных и неделимых (т. е. не имеющих определенной в языке внутренней структуры) элементов языка. П. являются ключевые слова и встроенные типы, такие как целый тип или вещественный тип. в то время как массив не является П., потому что имеет видимую структуру (состоит из элементов). Аналогично, операция сложения (+) является П., потому что встроена в язык, и ее реализация скрыта от программиста, в то время как определенная программистом функция не является П. 2. То же, что графический примитив
ПРИНТЕР, печатающее устройство [printer]
 Устройство, предназначенное; для вывода текстовой и графической информации из ЭВМ в печатном виде на бумагу или другой подобный носитель. П. используются чаше всего для вывода текстов и текстовых документов. Распространены, в основном, принтеры трех видов: матричные, струйные и лазерные. Качество печати определяется разрешающей способностью П.
ПРИОРИТЕТ [priority]
 Присваиваемый задаче, программе или признак, определяющий очередность их выполнения, или обслуживания вычислительной системой. П. может быть определен количественной величиной. Чем выше П. программы, тем большим преимуществом она обладает в очереди на выполнение, получение ресурсов и т. п. Поэтому в режиме мультипрограммирования программам можно так назначить П., что срочные работы,[ не будут задерживаться вспомогательными задачами.
ПРИОРИТЕТНАЯ МНОГОЗАДАЧНОСТЬ [preemptive multitasking]
 To же, что вытесняющая многозадачность
ПРИСВАИВАНИЕ [assignment]
 Операция задания значения регистру, переменной, элементу массива или другому элементу данных.
ПРОБЛЕМНАЯ ОБЛАСТЬ ПАМЯТИ [dynamic storage area]
 To же, что динамическая область памяти
ПРОБЛЕМНО-ОРИЕНТИРОВАННЫЙ ЯЗЫК [problem-oriented language]
 Язык программирования высокого уровня, предназначенный для решения определенного класса задач (проблем). П.-о. я. по возможности использует символику и систему понятий соответствующей проблемной области. Например, для подготовки на компьютере научно-технических книг, статей и др. публикаций, содержащих математические формулы, предназначен П.-о. я. Тех, в который в качестве ключевых слов входят некоторые полиграфические и математические термины.
ПРОВАЙДЕР [provider]
 To же, что поставщик сетевых услуг
ПРОВЕРКА НА ЧЕТНОСТЬ [even parity]
 Проверка правильности хранимых или пересылаемых данных методом контроля по четности
ПРОГОН БУМАГИ [paper feed]
 Продвижение бумаги в принтере, графопостроителе и т. п. на определенное число строк
ПРОГОН ПРОГРАММЫ [program run, run]
 Однократное выполнение программы
ПРОГРАММА [program]
 Последовательность указаний (команд или описа^-11 и операторов), задающая алгоритм вычислительной машине. П. указывает каком порядке, над какими данными и какие операции должны быть выполнены ЭВМ и в какой форме должен быть выдан результат. Устройство управления ЭВМ воспринимает П., заданную в виде последовательности машинных команд. Составление П. на машинном языке — неудобный и трудоемкий процесс. Поэтому обычно П. для ЭВМ составляется человеком на одном из языков программирования, а затем сама ЭВМ переводит эту программу на машинный язык.
ПРОГРАММА ПРОСМОТРА, браузер, броузер [browser, viewer]
 1. Программа чтения гипертекста (browser). 2. Средства просмотра (viewers) файлов различных типов. Так, в состав ОС Windows 95 входит утилита QuickView Plus для просмотра текстовых и графических файлов. В ОС MS-DOS существует более десяти П. п. файлов баз данных, текстовых и графических файлов, утилита просмотра исполняемых файлов HIEW со встроенным дизассемблером, широко известная утилита DEBUG; средства просмотра текстовых файлов интегрированы в оболочки Norton Commander и Windows Commander. Известны также утилиты просмотра библиотек динамической компоновки (например, DLLVIEW в MS-DOS), шрифтов и архивных файлов. Средства предварительного просмотра файлов различных форматов поддерживаются современными текстовыми и графическими профессорами, программами обработки электронных таблиц
ПРОГРАММА РАСКРАСКИ [paint program]
 Приложение, которое позволяет создавать изображения методом растровой графики, хранимые в памяти в виде набора пикселов, а не отдельных линий, фигур и прочих графических объектов. С помощью П. р. можно рисовать от руки. Для этого пользователю предоставляется набор инструментов: шаблонов, цветов, форм кисточек и линий разной толщины и т. п. П. р. обрабатывает картинку как группу точек и часто допускает поточечную перерисовку небольших фрагментов рисунка. В П. р. при выделении и перемещении фрагмента рисунка на его месте остается неокрашенная область пикселов. Примером П. р. является Microsoft Paint для IBM PC.
ПРОГРАММА РИСОВАНИЯ [drawing program]
 Приложение, которое позволяет создавать изображения методом векторной графики. Эти изображения хранятся в памяти как набор математических описаний отдельных линий и геометрических фигур, которые пользователь рисует на экране дисплея с помощью мыши или другого указательного устройства. П. р Позволяет легко перемешать выделенные геометрические элементы и блоки текста, обращаться с ними как с независимыми объектами, меняя их размеры и ориентацию, а также производить заливку очерченных областей нужным цветом. Для этого пользователю предоставляется набор инструментов: шаблонов фигур и линий разной толщины и цвета, набор цветов для заливки и т. п. П. р. обрабатывает картинку как группу линий и допускает перерисовку отдельно выделяемых составляющих рисунка. Примером П. р. является CorelDRAW для IBM PC.
ПРОГРАММИРОВАНИЕ [programming]
 1. Процесс создания программы. П. включает в себя анализ требований к программе и все стадии ее разработки и реализации: выбор алгоритма, структуры данных, и системы программирования; написание (кодирование) программы и подготовка данных; отладка и испытания программы; создание сопровождающей программу документации. В более узком смысле П. — это написание программы на языке П., ее отладка и испытания. Если алгоритм сложен, то П. рекомендуется выполнять способом модульного П. и начинать с составления блок-схемы программы. При этом пользуются методами восходящего или нисходящего П. 2. Наука, занимающаяся разработкой методов и средств получения и реализации программ для вычислительных машин
ПРОГРАММИРОВАНИЕ, ОРИЕНТИРОВАННОЕ НА СОБЫТИЯ, событийно-управляемое программирование [event-driven programming]
 Способ структуризации программного кола, основанный на следующей идее. Имеется некоторое предопределенное множество поименованных событий. События могут быть явным (или неявным) образом связаны с программными объектами, а могут быть связаны с неявными объектами, в таком случае события обычно называют системными. События могут "возникать". Возникновение события подразумевает, что состояние системы изменилось определенным образом. С событием связывается процедура, которая называется "реакцией" на событие. При возникновении события автоматически вызывается процедура реакции. В современных системах программирования, поддерживающих П.. о. н. с., предусматривается большое число самых разнообразных событии, реакции на которые могут быть определены в программе, например; нажатие клавиши на клавиатуре, перемещение указателя мыши в определенную область экрана, достижение внутренним таймером заданного значения, открытие заданного файла и т.д. В программе, целиком управляемой событиями, нет основного потока управления, он находится вне программы (в операционной системе или в административной системе времени выполнения, то есть там, где реализован механизм возникновения событий). Управление в программу попадает только в форме вызова процедуры реакции. П., о. н. с., подразумевает следующую методику разработки и использования программы. Программист определяет графический интерфейс программы с помощью стандартных или специально разработанных элементов управления, а также определяет необходимые процедуры реакции идя событий, связанных с использованными элементами управления. Пользователь, воздействуя на элементы управления, вызывает те или иные события к, тем самым, управляет ходом работы программы
ПРОГРАММИСТ [programmer]
 Лицо, выполняющее разработку и отладку программ
ПРОМЕЖУТОЧНЫЙ ЯЗЫК [intermediate language]
 Язык программирования, на который производится трансляция с языка программирования высокого уровня и с которого в свою очередь выполняется трансляция на машинный язык.
ПРОТОКОЛ [protocol]
 1. Результат регистрации в хронологическом порядке информации о некотором процессе. Например, П. компиляции — формируемый вычислительной системой листинг, содержащий исходный текст программы, ее эквивалент в виде объектной программы, таблицу соответствия имен и адресных ссылок, диагностические сообщения об ошибках и другую информацию. 2. Совокупность правил, определяющих алгоритм взаимодействия устройств, программ, систем обработки данных, процессов или пользователей. Например, П. линии связи — это правила, регламентирующие структуру и методы кодирования порции данных и процесс ее передачи по линиям связи. П. международной компьютерной сети Интернет (так называемые IP-протоколы) определяют правила взаимодействия между собой как объединенных в Интернет региональных сетей, так и подключенных к сети отдельных компьютеров
ПРОТОКОЛ АРРС [Advanced Program-to-Program Communications (АРРС)]
 Протокол, созданный фирмой IBM для системной сетевой архитектуры (архитектуры SNA), предназначенный для обеспечения связи между при хладными программами, работающими на разных компьютерах и для непосредственного обмена данными. П. АРРС предоставляет в распоряжение прикладных программ набор правил, а также обобщенный язык, которым они могут пользоваться, не обращаясь для этого к сетевым функциям низкого уровня
ПРОТОКОЛ FTP [file transfer protocol (FTP)]
 Один из стандартных протоколов передачи данных, поддерживаемый комитетом IETF и обеспечивающий эффективную передачу файлов по телефонной линии. П. FTP используются при переносе файлов с одного компьютера на другой или upi-трапспортировке файлов между различными узлами сети Интернет. Чтобы установить соединение и обменяться файлами в сети Интернет согласно П. FTP, необходимо запустить специальную прикладную программу, так называемую "клиентскую часть FTP". Клиентское программное обеспечена FTP устанавливается вместе с коммуникационными утилитами TCP/IP. Получить доступ к другому компьютеру для обмена файлами можно, указав пользовательское имя и пароль. Существуют так называемые анонимные FTP-серверы, позволяющие получать файлы любому пользователю, обладающему клиентской частью FTP. В этом случае в качестве пользовательского имени вводится "anonymous", а в качестве пароля — адрес электронной почты пользователя П. FTP
ПРОТОКОЛ РРР [Point-To-Point Protocol (PPP)]
 Набор промышленных стандартов, описывающих процедуры передачи данных. П. РРР связывает конфигурационные параметры нескольких уровней модели OS
ПРОТОКОЛ SNMP [Simple Network Management Protocol (SNMP)]
 Дословный перевод с английского: "простой протокол управления сетью", Сетевой протокол, предназначенный для управления компонентами сети, мониторинга загруженности сети и выполнения других задач
ПРОТОКОЛ SSL [Secure Sockets Layer (SSL)]
 Протокол безопасной передачи данных по Всемирной паутине, разработанный корпорацией Netscape Communications. Он не зависит от приложения и обеспечивает: 1) шифрование (безопасный канал, защищенный от вмешательства посторонних); 2) аутентификацию (применение электронных сертификатов для удостоверения каждой из сторон, вступающих в контакт); 3) целостность сообщений (гарантию того, что сообщение не было изменено при передаче). П. SSL функционирует на уровне более низком, чем протоколы приложений, такие как HTTP или FTP, но в то же время более высоком, чем протокол связи TCP/IP. Такая стратегия позволяет ему действовать независимо от любого протокола Интернет. Если П. SSL реализован одновременно на клиентской и серверной сторонах, информация между ними передается в зашифрованном виде, что гарантирует конфиденциальность
ПРОТОКОЛ TELNET [Telnet]
 Протокол удаленного доступа, используемый в Интернет. Позволяет пользователю одного компьютера устанавливать связь по сети с удаленной вычислительной системой. Когда связь установлена, пользователь может работать так, как будто его клавиатура, мышь и монитор подключены непосредственно к удаленному компьютеру
ПРОТОКОЛЫ TCP/IP [Transmission Control Protocol/Internet Protocol (TCP/IP)]
 Набор базовых протоколов Всемирной компьютерной сети Интернет, которые определяют правила взаимодействия между собой как объединенных в Интернет региональных сетей, так и подключенных к сети отдельных компьютеров. Межсетевым протоколом IP устанавливается, что информация передается пакетами размером от 40 до 32000 байт в зависимости от аппаратных средств и носителей информации, и каждый пакет перемещается по сети независимо от других пакетов. Такая технология не позволяет одному пользователю монополизировать сеть. Пакеты снабжаются Интернет-адресами, которые содержат информацию, достаточную для доставки пакета. Протокол управления передачей данных TCP определяет правила разбиения данных на пакеты и их нумерацию, а также правила, согласно которым при получении отдельных пакетов проверяется, вся ли информация I получена, а данные располагаются в правильном порядке. Если оказывается, что при передаче пакета произошла ошибка, то запрашивается его повторная передача. В соответствии с П. TCP/IP работает аппаратное и программное обеспечение, реализующее передачу данных по Интернет
ПРОТОКОЛ ПЕРЕДАЧИ ГИПЕРТЕКСТА, протокол HTTP [Hypertext Transfer Protocol (HTTP)]
 Стандартный протокол передачи гипертекста и гипермедиа в сети Интернет, поддерживаемый Комитетом IETF и описывающий обмен информацией во Всемирной Компьютерной паутине


Толковый словарь компьютерной лексики

РАСПЕЧАТКА [printing, listing]
 1. Процесс вывода данных из ЭВМ с мощью принтера. 2. Данные, выведенные из ЭВМ в печатном виде (на маге или другом подобном носителе).
РАСПРЕДЕЛЕНИЕ ПАМЯТИ [memory allocation, storage allocation, memo mapping]
 Действия транслятора или операционной системы по выделению областей памяти программам и обрабатываемым этими программами данным. Различают статическое и динамическое. п. Статическое Р. п. выполняется до начала выполнения программы, а динамическое — во время выполнения. Область оперативной памяти, предназначенная для размещения прикладных программ, называется динамической областью памяти, а область выделяемая программе для временного размещения данных — рабочей областью. Основными элементами программы и данных, для которых необходима память вo время выполнения программы, являются: 1) сама исполняемая программа пользователя; 2) системные программы, которые производят вспомогательные действия во время выполнения программы пользователя (от простых библиотечных программ, например, вычисляющих значение синуса угла, до программ, управляющих динамическим Р. п.); 3) структуры данных, создаваемые или объявленные программой пользователя, и используемые ею константы; 4) точки входа и возврата для подпрограмм; 5) временная память для промежуточных результатов вычисления выражений и фактических параметров подпрограмм; 6) буферная память ввода-вывода; 7) различные системные данные (дескрипторы структур данных, списки свободного пространства памяти, информация о состоянии устройств ввода-вывода и т. п.). Существуют следующие основные схемы Р. п.: выделение одного непрерывного раздела, разбиение на разделы, разбиение на страницы, сегментация. Выделение одного непрерывного раздела применяется в однозадачных операционных системах. При этом одна выполняемая задача монополизирует всю память и все устройства. При разбиении на разделы каждой задаче выделяется непрерывно адресуемая часть памяти, границы которой могут быть либо фиксированными (мультипрограммирование с фиксированным числом задач), либо динамически изменяющимися в зависимости от текущей загруженности задачами вычислительной системы (мультипрограммирование с переменным числом задач). Схема страничной организации памяти предполагает разбиение адресуемого пространства каждой задачи на страницы, а физической памяти — на блоки оперативной памяти или секторы на магнитном диске. При этом любая страница может быть помещена в любой блок или сектор. Таким образом, организуется виртуальная память, которая значительно облегчает реализацию мультипрограммирования и повышает производительность вычислительной системы. В случае схемы сегментации памяти оперативная память делится на сегменты фиксированной длины. Для аппаратуры адрес, памяти состоит из двух частей: номера (имени) сегмента и смещения внутри сегмента. Программа и данные также разбиваются на сегменты и могут быть размещены в нескольких сегментах памяти. Учетом и распределением оперативной памяти между программами управляет супервизор основной памяти.
РАСПРЕДЕЛЕНИЕ РЕСУРСОВ [resource allocation]
 Действия операционной системы по выделению ресурсов отдельным заданиям. Выделение ресурсов в программе может происходить как до начала ее выполнения, так и в ходе ее выполнения. Р. р. и управление ими осуществляют специальные резидентные программы операционной системы. Когда в режиме мультипрограммирования ресурсы вычислительной системы делятся между нескольким программами, то каждая программа должна быть защищена от воздействия со стороны другого задания. Например, каналы ввода-вывода — это ресурсы, которые могут совместно использоваться несколькими заданиями. Поэтому программа пользователя не может непосредственно сама инициировать операцию ввода-вывода, а должна обратиться к супервизору ввода-вывода и предоставить всю информацию, необходимую для этой операции
РАСПРЕДЕЛЕННАЯ БАЗА ДАННЫХ [distributed database]
 База данных, i которой данные распределены между несколькими узлами компьютерной сети. Не следует путать Р. б. д. с сетевой базой данных
РАСПРЕДЕЛЕННАЯ КОМПОНЕНТНАЯ МОДЕЛЬ ОБЪЕКТОВ [Distributed Component Object Model (DCOM)]
 Расширение модели COM, специально предназначенное для работы в сетевом окружении и Интернет. Технология DCOM определяет методы создания и взаимодействия объектов, хранящихся на разных компьютерах. Средой для передачи данных между объектами является локальная или глобальная вычислительная сеть. При этом поддерживается как синхронная, так и асинхронная передача данных, что позволяет предотвратить остановку работы клиентского приложения при ожидании отклика от сервера. Технология DCOM может использоваться для интеграции приложений Web.
РАСПРЕДЕЛЕННОЕ ПРИЛОЖЕНИЕ [distributed application]
 Приложение, которое состоит из нескольких компонентов, выполняющихся на различных компьютерах.
РАСТР [raster]
 Двумерный массив точек (элементов растра, пикселов), упорядоченных в ряды (строки) и столбцы, предназначенный для представления изображения путем окраски каждой точки в определенный цвет. С помощью Р. создается изображение на экране дисплея, лазерные и струйные создают растровое изображение на бумаге.
РАСТРОВАЯ ГРАФИКА [bit-mapped graphics, raster graphics]
 Метод создания изображений в виде растра— набора разноцветных точек (пикселов) для упорядоченных в строки и столбцы, В памяти компьютера такие изображения хранятся в виде битовых последовательностей, которые описывают отдельных пикселов. При этом на каждый пиксел приходится определенное число бит, определяющих ту или иную характеристику цвета в соответствии с принятой цветовой моделью и допустимой палитрой. Р. г. применяется в программах раскраски, которые работают с рисунком как с группой точек, а не с совокупностью форм. На принципах Р. г. основана работа экрана дисплея, а также лазерных и струйных принтеров.
РАСШИРЕНИЕ [extension]
 To же, что расширение имени файла
РАСШИРЕНИЕ ИМЕНИ ФАЙЛА, расширение [file name extension, extension]
 Необязательная часть имени файла, предназначенная для указания типа файла или описания его содержания. В операционной системе MS-DOS Р. и. ф. записывается после имени и начинается с точки, за которой следуют от 1 до 3 символов. Символы в Р. и. ф. могут быть прописными и строчными латинскими буквами, цифрами и символами: -, _, $, ft, &, @, !, %, (,), {, }, ', ~, л . Пробелы в Р. и. ф. не допускаются. Многие программы, создавая файлы, устанавливают Р. и. ф., по которому можно узнать, какая программа создала файл. Например, exe, com, bat — расширения командных файлов, причем ехе относится к программам, созданным компиляторами, doc — документы для редактора Word, for, pas, с — программы на Фортране. Паскале и Си, соответственно. Многие программы используют расширение bak для копий файла, создаваемых перед его изменением. Пользователь, создавая файл, может указать свое расширение, например let для писем
РАСШИРЕННАЯ ПАМЯТЬ [extended memory (XMS)]
 Составная часть оперативной памяти персональных. IBM-совместимых компьютеров при работе в среде MS-DOS. См. оперативная память IBM-совместимых персональных компьютеров
РЕАЛЬНЫЙ РЕЖИМ [real mode]
 Режим работы центрального процессора IBM-совместимого персонального компьютера, при котором могут выполняться программы, написанные для компьютеров, имеющих устаревший процессор 8088/86. Чтобы обеспечить такую возможность, современные микропроцессоры при работе в среде MS-DOS вынуждены имитировать (эмулировать) микропроцессор 8088/86 со всеми его ограничениями. Например, в Р. р. можно полноценно использовать только 640 Кб оперативной памяти Начиная с версии 3.0, Windows не поддерживает этот режим работы
РЕГИОНАЛЬНАЯ ВЫЧИСЛИТЕЛЬНАЯ СЕТЬ [wide area network (WAN)]
 Нелокальная вычислительная сеть, соединяющая территориально удаленные ЭВМ. Противоп. локальная вычислительная сеть
РЕГЕНЕРАЦИЯ [regeneration]
 To же, что восстановление
РЕГИСТР [register
 Внутреннее запоминающее устройство процессора или для временного хранения обрабатываемой или управляющей информациии обеспечения быстрого доступа к ней. Часто Р. имеет тот же размер, что и машинное слово, но может иметь и большую или меньшую длину, равную целому числу байт. Р. служат для выполнения определенных функций. Существуют Р., на которые из оперативной памяти вызываются исполняемые команды или их составные части (регистр команд, регистр адреса). Р., на которые вызываются операнды, Р., играющие роль счетчиков, стеков и т. п.
РЕГИСТР АДРЕСА, адресный регистр [address register]
 Регистр внутренней памяти центрального процессора, содержимое которого соответствует некоторому адресу. Это может быть адрес команды, вызываемой для выполнения, или адрес операнда, указанный в команде. А. р. служат для вычисления физических адресов команд и операндов выполняемой программы. Иногда А. р. рассматривается как часть регистра команды.
РЕГИСТР БАЗЫ [base register]
 Тоже, что базовый регистр
РЕГИСТР КОМАНД [instruction register]
 Регистр процессора, в котором находится исполняемая в данный момент команда. Она вызывается на Р. к. из оперативной памяти
РЕДАКТИРОВАНИЕ [editing]
 Внесение изменений в текст или преобразование программ или данных к виду, требуемому для их дальнейшего использования. Р. текста состоит из перемещения, удаления и изменения его отдельных символов и фрагментов, а также ввод нового текста и изменение формата. Р. текста выполняется с помощью специальных программ — текстовых редакторов и текстовых процессоров. Р. исходного текста программ и подготовка исходных данных выполняется с помощью редакторов, входящих в состав системы программирования
РЕДАКТИРОВАНИЕ СВЯЗЕЙ [linkage editing]
 To же, что компоновка


Толковый словарь компьютерной лексики

СВОДНАЯ ТАБЛИЦА [pivot table]
 Интерактивная таблица на рабочем листе Excel, которая позволяет представлять данные других таблиц в компакт ном и удобном для анализа виде. При составлении С. т. используются личные суммирующие и обрабатывающие функции. Достоинством С. г является возможность легкого изменения структуры представления данных: с помощью перетаскивания мышью полей сводной таблицы
СВОПИНГ [swapping]
 1. Метод эффективного использования оперативно памяти, заключающийся в переписывании из нее информации во внешнюю память в те периоды, когда эта информация не используется, и считываний информации обратно в оперативную память, когда в ней снова возникает необходимость. При помощи С. операционная система обеспечивает присутствие используемой в данный момент информации в оперативной памяти. На основе С. организуется виртуальная память путем перемещения страниц (страничный обмен) или сегментов. Кроме того, С. применяется в многозадачных операционных системах в случае, когда необходимо освободить место_ в оперативной памяти под размещение более приоритетной задачи. Для чего менее приоритетная или ждущая задача сохраняется во внешней памяти. на ее место переписывается более приоритетная. При этом может происходить перемещение образов задач. 1. То же, что подкачка
СВЯЗЫВАНИЕ И ВНЕДРЕНИЕ ОБЪЕКТОВ [object linking and embedding, QLE]
 Технология, разработанная корпорацией Microsoft и реализованная J операционной системе Windows и программном обеспечении Macintosh мы Apple, используемая для создания динамически обновляемых связей жду документами, а также для внедрения документа, созданного одним приложением в документ, созданный другим приложением. Документ, в который внедрен объект, называется контейнером, а документ, из которого взят внедренный объект, называется источником. Если объект связан по данной технологии с неким контейнером, то последний содержит только ссылку этот объект, а любые изменения в источнике отражаются в контейнере. Если объект внедрен по технологии OLE, то контейнер содержит копи объекта, и последующие изменения объекта в источнике не будут отражаться в контейнере.
СЕГМЕНТ ПАМЯТИ, сегмент [memory segment]
 1.Часть оперативной паями фиксированного размера, используемая при формировании адресного пространства центрального процессора или задачи, таким образом, что для аппаратуры адрес памяти состоит из двух частей: номера (имени) сегмента и смешения внутри сегмента. Обычно С. п. имеет размер максимально возможного смещения (часто это 64 Кб). См. распределение памяти. 2. Логическая или физическая единица подкачки в системе с виртуальной память/о. Часть физической или виртуальной памяти, используемая как единое целое при перемещении участков программ или данных из внешней памяти в оперативную память и обратно. С. п. отличается от страницы тем, что его размер не зафиксирован, и пользователь в определенной мере может влиять на этот размер
СЕГМЕНТ ПРОГРАММЫ [program segment]
 Часть программы, отдельно обрабатываемая загрузчиком. В оверлейных программах существуют корневой сегмент и сегменты перекрытий
СЕГМЕНТАЦИЯ [segmentation]
 1. Деление памяти, программы, данных на сегменты. 2. Способ распределения памяти операционной системой
СЕКТОР [sector]
 Участок дорожки магнитного диска, имеющий свой физический адрес. Таким образом С. является минимальным физически адресуемым элементом памяти па магнитном диске.
СЕМАНТИКА ЯЗЫКА ПРОГРАММИРОВАНИЯ [programming language semantics]
 Совокупность правил, определяющих смысл чисел, переменных, Сражений, операторов, процедур и других элементов и предложений данного языка программирования
СЕТЬ ЭВМ. вычислительная сеть, компьютерная сеть [computer network]
 Вычислительная система, включающая в себя несколько ЭВМ, терминалов И других аппаратных средств, соединенных между собой обеспечивающим:_ передачу данных линиями связи. Компьютеры могут соединяться друг с другом непосредственно, либо через промежуточные компьютеры. Помимо компьютеров. за которыми работают люди (рабочих станций), в С. Э. могут быть ЭВМ, за которыми никто не работает. Более того, у них могут отсутствовать видеомонитор и клавиатура. Такие компьютеры используются как управляющие центры в сети и концентраторы данных. Обычно их называют cepверами. В зависимости от конструкции сети и возможностей сетевого программного обеспечения пользователь одного компьютера или терминала может получить: доступ к данным, хранящимся в памяти другого компьютера, доступ к памяти и центральному процессору более мощного компьютера для| выполнения своей прикладной программы, объединенные ресурсы всех включенных и нее компьютеров. Для организации дистанционной связи в сети необходимы программные средства передачи данных и аппаратные устройства — модемы. Если в сеть объединяются компьютеры и терминалы, находящиеся в одном помещении, здании или на ограниченной территории, и при этом в качестве устройств передачи данных используются специальные кабели и провода, то говорят, что компьютеры образуют локальную вычислительную сеть. Обычно такая сеть состоит из одной мошной главной ЭВМ и нескольких менее мощных. При этом пользователи менее мощных компьютеров и терминалов имеют совместный доступ к вычислительным ресурсам главной ЭВМ и ее обширной памяти. Подобные сети часто организуются в учреждениях и учебных заведениях. Если в сеть объединяются ЭВМ настолько удаленные друг от друга, что для передачи данных между ними приходится использовать телекоммуникации (телефонную, радио- или даже спутниковую связь), то говорят, что компьютеры образуют глобальную (или региональную) вычислительную сеть. Для диспетчерского управления такой сетью или коммутации линий связи служат специально установленные компьютеры с сетевым программным обеспечением, называемые узлами сети. Примерами сетей служат единая система заказа билетов на авиалиниях или сеть, связывающая компьютеры банка и его филиалов, расположенных в разных городах и даже странах. Широкое распространение получила во всем мире глобальная С. Э. Интернет
СЖАТИЕ ДАННЫХ, уплотнение данных [data compression, data compaction]
 Преобразование данных в более компактную форму без потери содержащей-; в них информации. С, л. позволяет экономить память и повысить эффективность передачи данных. В теории информации существует много методов С. Я-, позволяющих путем изменения кода сократить их избыточность. На основе этих методов разработаны специальные программы — архиваторы, выполняющие архивирование файлов. Кроме того, методы С. д. позволяют существенно увеличивать емкость внешней памяти. Например, в операционные Системы MS-DOS 6.0 и Windows 95 включена программа, увеличивающая как минимум вдвое емкость жесткого и гибкого магнитных дисков с помощью алгоритма MRCI (Microsoft Real-time Compression Interface). Эта программа занимает часть дискового пространства под специальный файл, где хранится сжатая информация. Для пользователя этот файл отображается в виде логического диска, но при обращении к нему выполняется архивирование/разархивирование в реальном масштабе времени. Очевидно, на такой диск не имеет смысла записывать архивные файлы. Существуют специальные методы и программы С. д., позволяющие компактно записывать, а затем воспроизводить графическую, звуковую и видеоинформацию.
СЖАТИЕ ФАЙЛА [file compression, file compaction]
 Преобразование файла в более компактную форму без потери содержащейся в нем информации с целью экономии памяти. С. ф. применяется при архивировании файлов.
СИ [С]
 Язык программирования высокого уровня, предназначенный для разработки системных программ различного назначения. На С. пишутся операционные системы, компиляторы, редакторы, системы управления базами данных, мультимедиа-программы, программы решения научных и инженерных задач и программы обработки текстов. С. был разработан в 1972 г. Д, Ричи в фирме Bell Laboratories и получил свое название, как преемник ранее разработанного в этой фирме малоизвестного языка Би (В). С. обладает широким спектром стандартных типов данных и удобным механизмом композиции стандартных типов в более сложные. Язык дает программисту широкую свободу в выборе синтаксических конструкций, в частности, допускает произвольное использование указателей, что затрудняет работу неопытных программистов и, наоборот, облегчает опытным написание системных программ. В языке С. имеется около 40 арифметических, логических, символьных и других операций над данными (например, сдвиг кода, поразрядные операции, арифметические операции над указателями и т. д.). Управляющие конструкции языка допускают структурное и модульное программирование с раздельной трансляцией модулей. В С. имеются средства работы с системными и Пользовательскими библиотеками программ. Дальнейшим развитием языка С. стал язык программирования общего назначения Си++
СИНТЕЗАТОР РЕЧИ [voice synthesizer]
 Устройство или программа, осуществляющее синтез речи человека на основе цифрового кода
СИНТЕЗ РЕЧИ [speech synthesis, speech generation]
 Процесс создания звуков, имитирующих человеческий голос. Устройство, именуемое синтезатором речи, по сигналам, проступающим из систем обработки данных или систем управления, формирует речевые сообщения, воспроизводимые динамиком компьютера. С. р. производится путем "сборки" сообщений из элементов набора основных звуков, которые либо могут иметь искусственное происхождение, либо представлять собой записанные на носитель фрагменты естественной человеческой речи
СИСТЕМА АВТОМАТИЗИРОВАННОГО ПРОЕКТИРОВАНИЯ (САПР)
 Комплекс программных и аппаратных средств, предназначенных для автоматизации процесса проектирования человеком технических изделий или продуктов интеллектуальной деятельности. САПР широко применяются в архитектуре, электротехнике, электронике, машиностроении, авиа космической технике, математике и программировании. Предоставляя человеку решение творческих задач, САПР берет на себя выполнение на компьютере поддающихся алгоритмизации сложных вспомогательных операций, например, проведение проектных расчетов, выполнение и корректировку чертежей, оптимизацию формы изделий или оптимизацию раскроя материала и т. п. Пополняемая база данных САПР снабжает человека необходимой информацией об изобретениях, существующих стандартах и проектных решениях, типовых элементах конструкций и комплектующих изделиях, материалах, технологиях исполнения, а также о различных законодательных положениях, руководствах, инструкциях и т. п. Развитые САПР способны по задаваемым проектным требованиям автоматически выдавать решения, достаточные для рассмотрения и окончательной корректировки специалистом. Аппаратное обеспечение САПР составляет ЭВМ с набором устройств, необходимых для ввода и вывода графической информации (графопостроитель, световое перо, графический планшет и др.), образующие автоматизированное рабочее место (АРМ проектировщика). Для крупных САПР основой служит локальная вычислительная сеть, в которой главная ЭВМ обслуживает несколько АРМов, в этом случае САПР является системой коллективного пользования
СИСТЕМА АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ [automatic control system]
 Система, управляющая объектом без участия человека. Ср. автоматизированная система управления
СИСТЕМА КОЛЛЕКТИВНОГО ПОЛЬЗОВАНИЯ, система коллективного доступа [multi-access system]
 Вычислительная система, обеспечивающая одновременную работу нескольких пользователей. Каждый пользователь имеет терминал, связанный с центральной ЭВМ через линию связи, по которой осуществляется передача данных. С. к. п. работает в режиме разделения времени, при котором время центрального процессора распределяется между пользователями периодически, но столь короткими квантами, что у каждого пользователя создается иллюзия собственной вычислительной системы, находящейся в его полном распоряжении. Сообщив через терминал свое имя и пароль, пользователь может вести постоянный диалог с машиной, вводить команды, программы, запросы, сообщения и получать ответы в приемлемое для него время. В связи с большим количеством пользователей в С. к. п. важное значение имеет решение вопросов защиты памяти и защиты данных
СИСТЕМА КОМАНД [instruction set]
 Полный набор команд, допустимых в машинном языке данной ЭВМ. Представляет собой список всех команд, которые способна выполнять конкретная ЭВМ, с указанием кодов операций и разрешенных способов адресации
СИСТЕМА ПРОГРАММИРОВАНИЯ (СП) [programming system]
 Совокупность языка программирования и системы разработки программ, обеспечивающей автоматизированную разработку и выполнение программ на данном языке, и подготовку соответствующей документации. Как правило, С. п. включает не эталонный вариант языка, а его некоторую версию, содержащую определенные упрощения или расширения. Некоторые С. п. могут поддерживать разработку программ па нескольких языках. Наиболее известные С. п. для персональных IBM-совместимых компьютеров: Visual Studio, разработанная фирмой Microsoft, поддерживающая языки программирования Basic, Java, C++; Delphi фирмы Inprise (Borland International Inc.), и .др.


Толковый словарь компьютерной лексики

ТЕКСТОВЫЙ РЕЖИМ [character mode]
 Режим работы адаптера дисплея, при котором на экран выводятся изображения только текстовых символов и псевдографических символов. При Т. р. экран делится на определенное число символьных позиций (знакомест), которые группируются в строки. Например, стандартный Т. р. позволяет вывести на экран 25 строк по 80 знакомест. Каждое знакоместо представляет собой прямоугольник, состоящий из определенного количества пикселов (точек, имеющих цвет и яркость). В каждом знакоместе может находиться один символ. Работающая программа определяет сам символ, его цвет и цвет фона этого символа. Эти данные 1 заносятся центральным процессором в видеопамять, а затем считываются и? преобразуются видеоадаптером в изображение на экране. Качество изображения текста зависит от размера матрицы пикселов, определяющей количество пикселов, приходящихся на одно знакоместо. Если для изображения символа используется матрица 8x8 пикселов (8 столбцов по 8 пикселов в каждом столбце), то на экране можно различить отдельные пикселы, из которых состоит символ. Современные видеоадаптеры могут поддерживать Т. р.. в котором матрица пикселов имеет размер 9x16, что обеспечивает высокое качество изображения текста
ТЕКСТОВЫЙ СИМВОЛ [alphanumeric character, information character]
 Буква, цифра, скобка, знак препинания или знак арифметической операции. Являясь составной частью текста, Т. с. являются .и частью его содержания, в отличие от управляющих, и псевдографических символов, которые служат для придания тексту удобной для восприятия формы
ТЕКСТОВЫЙ ФАЙЛ [text file]
 1. Файл, содержащий, текст. 2. Файл, со-1 стоящий исключительно из кода ASC
ТЕКУЩЕЕ СОСТОЯНИЕ [current state]
 Состояние системы, программы, устройства или информации в данный момент времени
ТЕКУЩИЙ ДИСК, активный диск [current disk, active disc]
 Магнитный или лазерный диск, доступный в данный момент для использования. В персональных IBM-совместимых компьютерах это текущий дисковод или логический диск
ТЕКУЩИЙ ДИСКОВОД [current disk drive]
 Дисковод, с которым в данный момент непосредственно работает операционная система. В IBM-совместимых персональных компьютерах это дисковод, с которым в настоящий момент работает пользователь. При работе в оболочке Norton Commander Т.д. указан в первой строке активной экранной панели, а также в приглашении, расположенном в командной строке
ТЕЛЕКОНФЕРЕНЦИЯ [computer conference, teleconference]
 Набор услуг сети ЭВМ. обеспечивающий групповое общение пользователей сети по избранной теме. Каждый участник Т. может послать свое сообщение в адрес Т. и оно может быть прочитано любым другим участником. Таким образом, Т. — это "электронная доска объявлений и дискуссий", которая отличается своей, довольно обширной рубрикой-направлением. В рамках этой рубрики между участниками Т. проводится ряд дискуссий по конкретным темам, помешаются объявления, советы и т.п. Например, в сети Интернет Т. по направлению "Вычислительная техника и смежные области" включает дискуссии по основам вычислительной техники, сведения о новом программном обеспечении, информацию об эксплуатации аппаратных и программных средств и т.д. Специальные программные средства позволяют организовать для пользователей сети большое количество различных Т. и при этом обеспечивают ведение протокола, пересылку и сохранение сообщений. В отличие от электронной почты, здесь не надо посылать одну и ту же статью поочередно каждому участнику. Отправка статьи требует времени и действий не более, чем при отправке письма по электронной почте. Кроме того, не надо принимать все поступающие в сеть материалы Т. Установленная на вашем компьютере программа чтения Т. отделяет сообщения, которые вы уже видели, и показывает только новые, которые поступили после окончания последнего сеанса. Из них можно выбирать и читать только то, что вас интересует
ТЕЛО ПРОЦЕДУРЫ [procedure body]
 Исполняемая часть процедуры, представляющая последовательность операторов, реализующую алгоритм процедуры. В некоторых языках программирования (например, в Паскале) Т. п. Представляет собой блок программы, содержащий раздел описаний, где вводятся локальные переменные и другие локализованные в Т. п. объекты. Некоторые языки программирования (например, Паскаль) допускают в Т. п. наличие нескольких точек входа в процедуру и точек выхода из нее.
ТЕХНОЛОГИЯ CORBA [Common Object Request Broker Architecture (CORBA)]
 Модель объектов и технология ее поддержки, разработанная группой компаний OMG (Object Management Group). Основу Т. CORBA составляет называемый объектный брокер запросов (Object Request Broker, ORB), который управляет взаимодействием клиентов и серверов распределенного приложения. ORB должен быть установлен на каждом компьютере, где исполняются программы использующие Т CORBA. ORB реализован для всех основных аппаратных и программных платформ, поэтому распределенные приложения, использующие Т. СОВRA, могут выполняться в гетерогенных (неоднородных) сетях.
ТЕХНОЛОГИЯ DYNAMIC HTML [Dynamic HTML technology]
 Расширение языка HTML, реализованное корпорацией Microsoft в браузере Internet Explorer 4 T. Dynamic HTML позволяет автору страницы Web запрограммировать управление отображением страницы, задавая процедуры реакции на события OnLoad, OnExit и MouseOver. Ранее интерактивные возможности узла Web реализовывались с помощью языков сценариев (Perl, JavaScript, VBScript), или обеспечивались приложениями, созданными на языках VisualBasic или Java
ТЕХНОЛОГИЯ ММХ [MnltiMedia Extension (ММХ)]
 Разработанная корпорацией Intel технология ускорения обработки мультимедиа. Т. ММХ ускоряет обработку таких ключевых элементов, как аудио- и видеоинформация, трехмерная графика, анимация и распознавание образов. Т. ММХ используется в процессорах ММХ, Pentium II и др. Т. ММХ использует свойство параллелизма, присущее большинству алгоритмов обработки мультимедийной информации
ТЕХНОЛОГИЯ PLUG AND PLAY [plug and play]
 Технология, базирующаяся на возможностях BIOS, операционной системы и внешних устройств и позволяющая автоматически определять и настраивать подключенные устройства. Автоматическая настройка устройств помогает избежать конфликтов между адаптерами и оптимально настроить систему в целом
ТИП ДАННЫХ [data type]
 Понятие языков программирования высокого уровня, обозначающее множество допустимых в вычислительной системе значений объединенных совокупностью применимых к ним операций. Указывая, к какому Т. д. относится объект программы или выражение, программист определяет все множество значений, которые они могут принимать в данной вычислительной системе и совокупность допустимых над ними операций. Например, переменные целого типа могут принимать только целочисленные значения — положительных, отрицательных чисел или нуля, над которыми допустимы арифметические операции и операции сравнения. А переменные логического типа принимают только два значения — "истина" или ложь", над которыми допустимы логические операции. Благодаря разработанной системе Т. д. в языках высокого уровня можно работать с данными, не вникая в детали их представления, хотя в большинстве языков программирования Т. д. позволяет указать и форму представления элемента данных в памяти. В каждом языке определен ряд Т. д., называемых встроенными или стандартными Т. д. В большинство существующих языков программирования встроены целый, вещественный, логический и символьный Т. д. Тип присутствующей в программе константы компилятор может распознать по ее "внешнему виду". Однако в случае переменной необходимо, чтобы се тип был объявлен в описании. Объявление Т. д. необходимо компилятору, чтобы не только правильно компилировать программу, но и контролировать правильность использования данных в ней. Для объявления встроенных типов применяются ключевые слова — описатели, например, integer, real, boolean, character и т. п. или их сокращения. Кроме встроенных Т.д. во многих языках программирования (например, языках Паскаль, Си и др.) имеются средства конструирования Т. д., удобных для программиста. Такие Т. д. включаются в программу с помощью описаний типа.
ТРАССИРОВКА ПРОГРАММЫ [program trace]
 Выполнение программы или ее участка, сопровождающееся выводом на экран, принтер или другой регистрацией в хронологической последовательности информации о событиях, связанных с выполнением программы. Т. п. применяется при отладке или тестировании программы, когда программа пользователя или ее отлаживаемый участок выполняется под управлением специальной программы-трассировщика. При этом, например, можно выводить на экран или в некоторый регистрирующий файл все встретившиеся при выполнении программы помеченные операторы в той последовательности, в которой они фактически выполняются. Таким образом, может отслеживаться программная логика. При Т. п. можно контролировать и значения переменных, важных для поиска ошибки, и т. д. Информация об отладочных действиях задается трассировщику, который изменяет объектную программу в оперативной памяти, размещая в точках трассировки команды перехода на программу трассировки, выполняющую требуемую регистрацию. Более сложные трассировщики могут также изменять объектную программу, исключать и вставлять операторы, позволяя, таким образом, программисту в течение одного и того же прогона программы не только локализовать ошибки, но и попытаться исключить их и посмотреть на результат этого исключения
ТРЕКБОЛ, шаровой манипулятор [track ball]
 Указательное устройство, которое отличается от мыши тем, что его шарик находится сверху и вращается пальцами. Обычно применяется в портативных компьютерах
ТЭГ [tag]
 В языке HTML — код (набор символов), идентифицирующий некоторый элемент документа Web (заголовок, список и т. д.) и указывающий браузеру Web способ отображения этого элемента. Т, ограничиваются угловыми скобками и могут содержать атрибуты (параметры). Например, браузер показывает только ту часть документа, которая заключена между Т. И
УДАЛЕНИЕ [delete]
 Применительно к программному обеспечению У. означает такое изменение состояния объекта, что его дальнейшее использование становится невозможным. У., как правило, не подразумевает физического уничтожения объекта, поэтому в некоторых случаях удаленный объект может быть восстановлен, т. е. переведен в такое состояние, в котором возможно его использование.
УПРАВЛЯЮЩАЯ КЛАВИША [control key]
 Клавиша . Клавиша, которая, будучи нажатой в сочетании с другой клавишей, придает последней альтернативный смысл.
УПРАВЛЯЮЩИЙ ОПЕРАТОР [control statement]
 Оператор, определяющий управляющую информацию, необходимую для выполнения задания или его пункта
УПРАВЛЯЮЩИЙ СИГНАЛ [control signal]
 Сигнал, поступающий на объект управления для выполнения определенных действий
УПРАВЛЯЮЩИЙ СИМВОЛ [control character]
 Символ, который при вводе с клавиатуры или передаче внешнему устройству вызывает выполнение вполне определенно!: функции. Например, если при наборе текста нажимается клавиша . то в текстовый файл заносится невидимый на экране У. с. (точнее. KOI У. с.) перевода строки, который при передаче текста на принтер вызовет перемещение бумаги в печатающем устройстве на одну строку вперед.
УСЛОВИЕ ВЫХОДА ИЗ ЦИКЛА, условие завершения цикла [truncation condition]
 Условие, в зависимости от выполнения которого происходит или повторение выполнения тела цикла или выход из цикла. Если проверка этого условия осуществляется после выполнения тела цикла, то У, в. и. и. называют условием окончания цикла, или постусловием. Если же проверка У. в. и. ц. осуществляется перед выполнением тела цикла, то его называют условием продолжения цикла или предусловием.
УСОВЕРШЕНСТВОВАНИЕ, обновление [upgrade, upgrading]
 1. Замена устройства или программного продукта на его более новую, более мощную версию. Например, У. вычислительной системы за счет замены жесткого диска на более быстрый и более емкий, или ее У. путем замены операционной системы Windows 95 на Windows 98. 2. Новая версия устройства или программного продукта, обладающая новыми свойствами и новыми возможностями. Например, ОС Windows 98 является У. ОС Windows 95
УСТРОЙСТВО, техническое устройство [device, unit].
 Элемент аппаратных I средств, представляющий законченную техническую конструкцию, имеющую определенное функциональное значение. Например, принтер, дисковод.
УСТРОЙСТВО ВВОДА [input device]
 Любое техническое устройство, позволяющее осуществлять ввод данных в ЭВМ. Наиболее удобными У. в. являются видеотерминалы и устройства речевого ввода данных, с которых данные вводятся в ЭВМ без предварительной, подготовки, а также У. в. графической информации (сканеры, дигитайзеры, цифровые планшеты графического ввода), У. в. позволяет преобразовать данные, записанные на носителе данных, или поступающие через микрофон, видеокамеру либо по каналам телефонной связи, в форму цифрового сигнала, пригодную для записи в память ЭВМ.
УСТРОЙСТВО ВЫВОДА [output device]
 Техническое устройство, позволяющее осуществлять вывод из ЭВМ результатов расчетов или оорабо1цки данных, программ и другой информации, хранившейся в ЭВМ. У. в. позволяет преобразовать поступающие из оперативной памяти данные в цифровой форме в форму, удобную для восприятия человеком (текст, графические изображения, звук). К таким У, в. относятся дисплеи, принтеры, графопостроители, синтезаторы звука и речи. В качестве У. в. могут выступать и внешние запоминающие устройства: дисководы магнитных дисков, стримеры, устройства записи на магнитные карты и уходящие в прошлое У. в, НУ перфокарты
УСТРОЙСТВО СОПРЯЖЕНИЯ [interface device]
 Устройство, обеспечивающее интерфейс двух несовместимых компонентов аппаратных средств. Например, чтобы использовать телефонную сеть для передачи данных компьютера к компьютеру, нельзя просто соединить выходной порт компьютера проводами с телефонной розеткой. Ведь выводимые из компьютера данные имеют форму дискретного цифрового сигнала, а большинство устройств телефонной сети пока работают с непрерывными аналоговыми сигналами и не способны передавать цифровой сигнал. Эта несовместимость преодолевается с помощью У. с., называемого модемом.
УСТРОЙСТВО УПРАВЛЕНИЯ [control unit (CU)]
 Функциональная часть центрального процессора ЭВМ, управляющая работой всех остальных устройств и частей, а также потоками информации внутри вычислительной машины. Действия У. у. определяются командами, из которых состоит программа. Команды одна за другой выбираются из оперативной регистр команд. У. у. распознает содержание команды и посылает соответствующие управляющие сигналы другим устройствам компьютера, обеспечивая ее выполнение. Например, если команда требует обращения к то по сигналам У. у. будут выполнены все необходимые операции по делению физического адреса требуемого данного, считыванию данного памяти и записи в соответствующий регистр арифметико-логического устройства.
ФАЙЛ [file]
 Информация, размещаемая на внешних запоминающих устройствах, снабженная идентификатором и оформленная как единое целое средствами операционной системы или языка программирования. Содержимым ф. могут быть программы, данные, тексты и любая другая информация. По способу доступа к данным различают файлы последовательного доступа и файлы прямого доступа. В персональных IBM-совместимых компьютерах Ф. хранятся на магнитных дисках и рассматриваются в процессах ввода или вывода данных как единое целое. Работа с персональным компьютером — это работа с файлами.
ФАЙЛ АВТОЗАПУСКА [autoexec file]
 Командный файл, автоматически выполняемый при загрузке операционной системы. Его содержимое заранее программируется пользователем или оператором вычислительной системы. Так как Ф. а. выполняется при каждом запуске компьютера, то в него обычно записывают команды операционной системы, позволяющие окончательно подготовить вычислительную систему к работе, приспособив ее к нуждам пользователя. Например, в Ф. а. персонального IBM-совместимого компьютера autoexec.bat удобно включить: 1) команды, устанавливающие список каталогов, в которых производится поиск программ в случае, если пользователь введет имя команды без указания в каком каталоге находится соответствующая программа; 2) команду, определяющую вид приглашения операционной системы MS-DOS; 3) команды запуска драй вера- русификатора, оболочки Norton Commander, программы зашиты от компьютерного вируса и других программ, создающих привычную рабочую обстановку на компьютере.
ФИЗИЧЕСКИЙ АДРЕС [physical address]
 Уникальный идентификатор, однозначно определяющий конкретное внешнее устройство
ФЛАЖОК [checkbox]
 Элемент управления, предназначенный для одного из двух возможных значений.
ФОНОВАЯ ЗАДАЧА [background task]
 Задача, с низким приоритетом выполняемая вычислительной системой в режиме мультипрограммирования в т. моменты времени, когда выполнение высокоприоритетных задач по тем или иным причинам невозможно. В качестве Ф. з. выбирают задачи, не требующие диалога с пользователем или предназначенные для пакетной обработки, Выполнение Ф. з. позволяет снизить непроизводительные затраты машинного времени и эффективно использовать оборудование
ФОРМАЛИЗОВАННЫЙ ЯЗЫК [formalized language]
 Язык, полностью или частично определенный по некоторым формальным правилам. К Ф. я. относятся искусственно созданные алгоритмические языки и языки программирования, основанные на точном предварительном описании алфавита, синтаксиса и семантики. Ф. я. противопоставляется естественный язык
ФОРМАЛЬНЫЙ ПАРАМЕТР [formal parameter]
 Условное имя, определенное в ' процедуре или функции для обозначения аргумента процедуры (функции) или результата ее работы. Все сказанное ниже о Ф. п. процедуры относится и к Ф. п. функции. В заголовке процедуры Ф. п. определяет тип элемента данных, который должен быть передан процедуре при ее вызове. В теле процедуры операторы задают алгоритм, как действия над Ф. п . что обеспечивает возможность подстановки различных исходных данных путем замены Ф. п. на фактические параметры, указанные в операторе вызова процедуры. Например, в процедуре решения квадратного уравнения ах2 + Ьх + с =ч! (см. процедура, заголовок процедуры) Ф. п. аргументами являются a. b и обозначающие коэффициенты уравнения, действия над которыми определяют решение задачи. Существуют четыре класса Ф. п., допустимые в большинстве традиционных языков программирования: параметры -значения, метры-переменные, параметры-процедуры и параметры-функции. Ф. п чение представляет в вызываемой процедуре некоторую локальную переменную. Этой переменной в качестве начального значения при вызове процедуры присваивается значение соответствующего фактического параметра, который должен быть выражением. Параметры-значения нельзя использовать для представления результата выполнения процедуры. Ф. п.-переменная при _ вызове замещается фактической переменной вызывающей программы. н э случае любые операторы, в записи которых участвует Ф. п., выполняю непосредственно над фактическим параметром. Параметры-переменные пользуются также для представления результатов выполнения, процедуры.
ФОРМАТ [format]
 1. Способ представления или схема расположения данных в памяти компьютера либо на других носителях данных. Ф. определяет количество и порядок размещения кодов, символов или элементов данных в машинном слове, записи, файле и др. структурах данных в оперативной памяти и на внешних носителях данных. Ф. может определяться как конструктивными особенностями носителя, так и характером данных. Например, Ф., в котором хранятся вещественные числа в основной памяти IBM PC строго определен (см. представление чисел с плавающей точкой), а Ф. печати конкретных вещественных чисел задается программистом средствами языка программирования. На экран или бумагу их можно вывести либо в форме числа с фиксированной точкой, либо в форме числа с плавающей точкой. При этом можно устанавливать длину числа, наличие или отсутствие знака, если число положительное и т. п. 2. Синтаксическая конструкция языка программирования, символически описывающая Ф. данных (представление или Расположение данных в файле) при вводе или выводе.
ФОРМАТИРОВАНИЕ ДАННЫХ [data formatting]
 Преобразование формы и структуры данных в соответствии с предписанным форматом
ФОРМАТИРОВАНИЕ ТЕКСТА [text formatting]
 В текстовых редакторах автоматическое придание тексту определенной формы — формата различают два способа Ф. т.: прямое и стилевое. При прямом форматировании с помощью меню и диалоговых окон пользователь устанавливает шрифт, его размер, размер строки и другие параметры выделенного участка текста. При стилевом форматировании символу, отдельному абзацу или тексту всего документа назначается заранее заготовленный набор параметров, называемый Пользователь делает такое назначение, указывая лишь имя стиля, стилей упрощает процесс Ф. т. и способствует унификации документов. Текстовые редакторы позволяют изменять существующие стили и создавать новые
Ф0РМЫ [forms]
 В языке HTML и документах Web — набор элементов управления (поля ввода, выпадающие меню, переключатели и дополнительные кнопки) для взаимодействия со страницей Web
ХАКЕР [hacker]
 Программист-фанатик поглощенный доскональным изучением и совершенствованием программного обеспечения вычислительных систем. В настоящее время этот термин приобрел отрицательный оттенок из-за участившихся попыток тайного проникновения Х. в чужие компьютеры и сети ЭВМ, "взлома" защиты данных и т.п. неблаговидных поступков
ХОСТ [host]
 То же, что главная ЭВМ


Толковый словарь компьютерной лексики

ЦИФРОВОЙ ПЛАНШЕТ [digital tablet]
 To же, что графический планшет
ЦИФРОВОЙ СИГНАЛ, дискретный сигнал [digital signal, discrete tablet]
 Электрический сигнал, напряжение которого может измениться дискретно, находясь в каждый момент времени на одном из нескотьки (обычно двух) уровней. Каждый уровень имеет свои границы— порот соответствует определенной цифре. В вычислительной технике применяют ся двухуровневые Ц. с., которые иногда называют двоичными, так как в них один уровень (обычно высокий) соответствует цифре 1 (истина), а другой — О (ложь).
ЦП [CPU]
 То же, что центральный процессор
ЦВЕТОВАЯ МОДЕЛЬ [color model].
 Физический метод формирования цветов на экране дисплея или в цветном принтере. Во многих цветных дне плеях используется Ц. м. RGB (red-green-blue) — красный-зеленый-голубой. В этой модели конкретный цвет или оттенок получается путем аддитивного смешения разных долей красного, зеленого и голубого цветов. Причем полное отсутствие этих цветов в смеси дает черный цвет, а сложение !00% всех цветов — белый цвет. Во многих системах печати используется Ц. м. CMY (cyan-magenta-yellow) — голубой-пурпурный-желтый, основанная на поглощающих свойствах красителей. В противоположность RGB-модели, здесь цвета и оттенки получаются путем вычитания из белого цвета определенных долей голубого, пурпурного и желтого. Если вычесть все три цвета полностью, остается черный цвет. 2. Способ описания и программирования цветов в компьютерной графике. Для описания цвета в компьютерной графике широко применяется Ц. м. HSB (hue-saturation-brightness) — тон-насыщенность-яркость. Каждый цвет или оттенок задается тремя количественными характеристиками. Тон определяется по угловой шкале цветового круга: О3 — красный, 60° — желтый, !20° — зеленый, 180° — голубой. 240° — синий, 300° — фиолетовый. Насыщенность и яркость выражаются в процентах. Например, яркость 0% соответствует черному цвету, а 100% — белому. См. насыщенность цвета, палитра, тон, цвет, яркость
ЦВЕТОВОЙ МАРКЕР [color marker]
 Цветовая отметка, выделяющая один из пунктов меню. Ц. м. передвигается по пунктам меню при помощи клавиш управления курсором или указателя мыши и позволяет сделать нужный выбор. Для выбора того или иного пункта, необходимо перевести на него Ц. м. Затем, нажав клавишу ввода или кнопку мыши, зафиксировать сделанный выбор
ЦЕЛАЯ ПЕРЕМЕННАЯ, переменная целого типа [integer variable]
 Переменная, значением которой могут быть только числа целого типа. Ц. п, вводятся 6 программу с помощью описания переменных, в котором указываются идентификатор (имя) переменной и ключевое слово, определяющее целый тип, значения которого она может принимать. В качестве ключевых слов в описаниях Ц. п. применяются: integer — в Фортране и Паскале и int, long или short — в языке Си, в зависимости от размера элемента памяти, отводимого пол целое число
ЦЕЛОСТНОСТЬ ДАННЫХ [data integrity]
 Непротиворечивость, полнота и сохранность данных. Например, Ц. д., хранящихся в базе данных, означает, что хранящиеся данные должны быть полностью согласованы между собой, содержать все сведения, необходимые для выполнения возложенных на базу данных функций, и при этом должно быть исключено их случайное уничтожение (стирание) или искажение. Все это обеспечивается системой управления базой данных
ЦЕЛЫЙ ТИП, целочисленный тип [integer type]
 Тип данных, множество значений которого составляют числа целого типа, над которыми допустимы арифметические операции и операции сравнения. Множество представимых в ЭВМ чисел Ц. т. ограничено и определяется диапазоном изменения чисел данной вычислительной системы, а выполняемые над ними арифметические операции осуществляются машиной по правилам элементарной арифметики: сложение и вычитание выполняются по разрядам, умножение эквивалентно последовательности сложений числа с самим собой, а деление — последовательности вычитаний делителя из делимого. Результаты операций — также числа Ц. т. Например, 5/2 = 2 (но 5.0/2.0 = 2.5). В большинстве языков программирования Ц. т. является встроенным типом. При описании переменных и других объектов программы, относящихся к Ц. т. применяются ключевые слова: integer — в языках Фортран и Паскаль, int. long и short — в языке Си, в зависимости от размера элемента памяти, отводимого под целое число.
ЦЕНТРАЛЬНЫЙ ПРОЦЕССОР (ЦП) [central processing unit (CPU)]
 1. Главный рабочий процессор компьютера или вычислительной системы, выполняющий основные функции по обработке данных и управлению работой Других устройств. В персональном компьютере это микросхема, управляющая работой компьютера и производящая основные вычисления. Функционально ЦП подразделяется на устройство управления и арифметико-логическое устройство, выполняющие операции в соответствии с программой. Кроме того, ЦП имеет внутреннюю процессорную память, состоящую из регистров 1й предназначенную для временного хранения данных, непосредственно ис пользуемых в выполнении операций. В персональных IBM-совместимых компьютерах применяются следующие процессоры, разработанные фирмой г (в порядке возрастания вычислительных возможностей): 80286; 80386SV 803S6DX: 80486SX; 804S6DX; Pentium, Pentium II. Процессор 80286 - 16 * рядный, а все остальные — 32-разрялные, т. е. порции данных, с которыми ЦП может выполнять различные операции, составляют соответственно 16 бит (2 байта) и 32 бита (4 байта). В процессорах 80486 и Pentium встроены математический сопроцессор — для ускорения выполнения операций числами с плавающей точкой', и кэш-память — для быстрой выборки т из оперативной памяти. Основная характеристика этих процессоров тактовая частота. В процессорах Pentium применена 64- или 128-разрядная магистраль, значительно ускоряющая обмен данными с оперативной памятью. Здесь также одно исполнительное устройство заменено на два — U и V, каждое — со своим собственным конвейером; оба параллельно ведут выборку, расшифровку и выполнение команд; устройство U является основным и может выполнять все команды, устройство V — вспомогательным и выполняет только наиболее часто встречающиеся типы команд. Внутренняя кэш-память делена на кэш команд и кэш данных. Есть система предсказания переходов путем опережающего просмотра программы, что позволяет в случае верного предсказания выполнить переход за один такт. Улучшен (по сравнению с 80486) математический сопроцессор. В процессорах Pentium MMX реализованы расширения MultiMedia extension (мультимедийные расширения) — дополнительные возможности, ориентированные на обработку цифрового изображения и звука, которые включают в себя свыше 50 новых команд, предназначенных для обработки звуковых и видеосигналов. Использование ММХ позволяет перенести основную нагрузку по обработке изображения и звука на ЦП, оставив видео- и звуковым адаптерам только преобразование аналоговых сигналов в цифровые. 2. В многомашинном вычислительном комплексе или в компьютерной сети ЦП называют главную ЭВМ, которая кроме выполнения основной обработки информации управляет работой других ЭВМ
ЦИКЛИЧЕСКИЙ ПРОЦЕСС, цикл [cyclic process, cycle]
 Процесс многократного последовательного выполнения одного и того же участка алгоритма или программы. Так как компьютер выполняет операции над данными с огромной скоростью, то ему выгодно поручать задачи, которые требуют многократного повторения действий (при различных значениях обрабатываемых данных), позволяющие с помощью краткой программы задать большой объем вычислений. Программные конструкции, позволяющие программировать Ц. п., называются циклами. Они включают в себя команды или операторы, непосредственно реализующие повторяемые действия алгоритма — так называемое тело цикла, и команды или операторы, управляющие повторением и осуществляющие выход из цикла в нужный момент. В -зависимости от программируемого алгоритма количество повторений может быть известно заранее (например, цикл со счетчиком), а может зависеть от вычисленных в ходе Ц. п. величин (например, итерационный цикл)


Толковый словарь компьютерной лексики

ШАБЛОН [template]
 Документ, используемый в качестве образца для создания новых документов. Например, приложение Microsoft Word всегда использует некоторый Ш. при создании нового документа. Пользователь может либо выбрать имеющийся Ш., либо использовать Ш. по умолчанию
ШАБЛОН ИМЕНИ ФАЙЛА [file name picture].
 Последовательность знаков, позволяющих обозначить имена сразу нескольких файлов. Ш. и. ф., образуется из символов, присутствующих в имени файла, и знаков, указывающих, что на их месте в имени символы либо отсутствуют, либо могут стоять любые допустимые символы. Так, операционная система MS-DOS персональных IBM-совместимых компьютеров позволяет создавать Ш. и. ф., используя знаки * и ?. Знак * обозначает любое число любых символов в имени файла или в расширении имени файла. Знак ? обозначает один произвольный символ или его отсутствие. Например. Ш. и. ф. *.* обозначает все файлы текущего каталога: Ш. и. ф. *.ехе — все файлы с расширением ехе; Ш. и. ф. a:\doc\ab??.t* — все файлы из каталога a:\doc с именем, начинающимся с ab и состоящим не более чем из 4 символов, и расширением, начинающимся с буквы t
ШЕСТНАДЦАТЕРИЧНАЯ СИСТЕМА СЧИСЛЕНИЯ [hexadecimal number
 Позиционная система счисления с основанием системы q = 16. В качестве шестнадцатеричных цифр используются символы 0, 1, 2, 3, 4, 5, 6, 7, 8. 9, А, В, С, D, Е, F. Например, (B3D}](, = 1Ы62 + 3x16' + 13x16° = (2877)10
ШИНА [bus]
 Устройство, служащее для передачи данных и управляющих сигналов между компонентами компьютера. Состоит из линий электрических соединений. По каждой линии Ш. обычно передается один двоичный разряд информационного слова, являющегося элементом данных или адресом. Поэтому максимальная пропускная способность Ш. обеспечивается при числе линий равном сумме числа бит в машинном слове и максимального числа двоичных разрядов адреса, плюс оптимальное количество линий для передачи управляющих сигналов. Существует способ организации ЭВМ, пpи котором все ее компоненты подключаются к единой Ш. Это так называемая шинная архитектура компьютера. В персональных IBM-совместимых компьютерах применяются Ш. высокой пропускной способности. См. адресная шина, системная шина
ШИННАЯ СЕТЬ, сеть шинной топологии [bus network]
 Локальная вычислительная сеть, в которой все узлы сети подключены к основной линии связи (шине). В Ш. с. каждый узел следит за работой линии. Сообщени региструются всеми узлами, но принимаются только теми из них, кому они адресованы. Поскольку Ш. с. базируется на общей магистрали данных, неисправный узел просто выходит из связи, не нарушая общей работы, как это было бы в кольцевой сети, где сообщения передаются от одного узла к следуюшему. Во избежание проблем при попытке двух или более yзлов временно воспользоваться линией в Ш. с. для регулирования потока сообщений обычно применяется механизм разрешения конфликтов или передачи маркера
ШИФРАТОР [scrambler, encipherer, encoder, encryptor]
 1. Програм- ма, выполняюшая шифрование, 2. Блок ЭВМ, выполняющий преобразование входных сигналов. Например, аналого-цифровой преобразователь, npeo6разующий аналоговый сигнал, поступающий на компьютер, в цифровой сигнал. Противоп. дешифратор
ШИФРОВАНИЕ [enciphering, encoding, encryption]
 Алгоритмическое преобразование данных для защиты от несанкционированного прочтения и использования. Выполняется вручную или с помощью программы-шифратора. Широко применяется при передаче конфиденциальной информации по каналам общественных телекоммуникаций (телефонной, радио- и спутниковой связи), а также, при ее сохранении на магнитном носителе. Ш. выполняется с помощью шифра — кода, основные элементы которого (ключ, определяющий возможные варианты шифра, и правила кодирования) известны ограниченному кругу лиц. Расшифровка производится также вручную или с помощью программы-дешифратора.
ШЛЮЗ [gateway]
 Совокупность технических и программных средств, обеспечиваюшая сопряжение нескольких сетей различной архитектуры
ШРИФТ [font]
 Конкретный способ изображения символов из некоторого набора. Обычно в Ш. входят буквы одного или нескольких алфавитов, цифры и специальные знаки. В специальные шрифты входят например, псевдографические символы, математические или астроном символы и т. п. Кроме набора отображаемых символов, Ш. характеризуется множеством других свойств, из которых важнейшими являются гарнитура Ш., начертание Ш. и размер Ш. По способу представления в различаются растровые Ш. и векторные Ш. В первом случае для представления шрифтов используются методы растровой графики и символы Ш. представляют собой массивы пикселов. Во втором случае используются методы векторной графики, и форма символов Ш. описывается математическими функциями. Свойства растровых и векторных Ш. существенно различны. Например, векторный Ш. допускает произвольное масштабирование (т. е. изменение размера), в то время как растровый Ш. не допускает масштабирования или допускает масштабирование только с определенными коэффициентами. С другой стороны, работа с растровым Ш. значительно быстрее, поскольку при этом не требуется дополнительной обработки для вывода символа Ш. на экран или бумагу. Среди векторных Ш. наибольшее распространение получили Ш. типа True Type


Толковый словарь компьютерной лексики

ЩЕЛЧОК [click]
 Действие, которое заключается в том, чтобы быстро нажать и отпустить кнопку неподвижной мыши. Щ. применяется при задании команды с помошью элемента управления, быстрой активизации окон и т. п. При этом указатель мыши должен указывать на выбранный элемент, программу и т. п.


Толковый словарь компьютерной лексики

ЭКЗЕМПЛЯР КЛАССА [class instance, instance]
 Термин объектно-ориентированного программирования, которым обозначается конкретный объект, созданный конструктором некоторого класса. Э. к. обладает свойствами, которые хранят данные, присущие именно этому объекту и методами, которые определены в классе или унаследованы от родительских классов.
ЭКРАН [screen]
 Устройство отображения текста или графической информации.
ЭКСПЕРТНАЯ СИСТЕМА (ЭС) [expert system]
 Система программных и аппаратных средств, включающая базу знаний, способная на основании ме тодов искусственного интеллекта и предоставляемых пользователем фактов идентифицировать ситуацию, поставить диагноз, сделать прогноз, сгенери ровать решение или дать рекомендацию для выбора действия. ЭС обычно ориентируется на некоторую предметную область (например, ЭС диагностики и лечения сердечно-сосудистых заболеваний) и способна получать, накапливать, корректировать знания из этой области, выводить новые знания из уже известных, решать практические задачи на основе этих знаний и объяснять ход решения. Помимо базы знаний, хранящей факты, закономерности правила, в ЭС входят программы-решатели, реализующие функции пла-нирования, поиска решения задачи, механизма логического вывода из часто неполных и нечетких знаний. Создание ЭС начинается с разработки ее пер-оначального варианта — прототипа ЭС. Далее следует длительный, многоэтапный процесс испытаний и совершенствования. Для программирования ЭС применяются в основном языки Лисп, Пролог, Си
ЭЛЕКТРОННАЯ ВЫЧИСЛИТЕЛЬНАЯ МАШИНА (ЭВМ), [computer]
 Вычислительная машина, основными элементами которой являются электронные приборы (транзисторы, микросхемы, магнитные элементы и т. п.). В настоящее время под ЭВМ понимают в основном электронные цифровые вычислительные машины
ЭЛЕКТРОННАЯ ПОЧТА [electronic mail. E-mail]
 1. Набор услуг сети ЭВМ по пересылке сообщений между ее пользователями. Э. п. является средством быстрой доставки писем, текстов программ, документов и другой подобной корреспонденции. Э. п. кроме своей основной функции отправления и приема почты предоставляет пользователю следующие возможности: 1) получать и хранить сообщения в систематизированном виде, "раскладывая" их в папки: 2) пересылать всю почту на другой компьютер; 3) рассылать копии одного сообщения сразу нескольким лицам с помощью списка рассылки. Отдельные программные пакеты обеспечивают отправителю автоматическое уведомление о получении после того, как посланная почта помешена в почтовый ящик получателя, а также уведомление о прочтении после того, как получатель вывел посланное сообщение на экран своего дисплея. 2. Система сервисных программ, обеспечивающая пересылку сообщений по сетям ЭВМ от пользователя к пользователю, а также чтение и хранение этих сообщении. Почтовая программа пользователя должна быть настроена на почтовый сервер поставщика сетевых услуг (провайдера). При передаче сообщения по Э. п. передающий и принимающий компьютеры не обязательно взаимодействуют друг с другом непосредственно. Почта передается от одного компыотера к другому, пока не попадет на почтовый сервер провайдера. При этом она может передаваться из одной сети ЭВМ в другую. Пункты соединения между сетями представляют собой компьютеры, называемые шлюзами. Они должны изменить формат поступающего сообщения в соответствии с требованиями сети назначения
ЭЛЕКТРОННАЯ СХЕМА [electronic circuit]
 Полупроводниковые приборы, соединенные проводниками по определенной схеме для выполнения задан- ной функции. Э. с. применяются в ЭВМ для генерирования, усилени образования, хранения и передачи электрических сигналов различной формы, мощности и частоты. С помощью этих сигналов представляется обрабаты ваемая компьютером информация и управляются различные устройства
ЭЛЕКТРОННАЯ ТАБЛИЦА [spreadsheet]
 Работающая в диалоговом режиме программа обработки данных, обеспечивающая взаимодействие с пользовател ем при помощи выводимых на экран дисплея прямоугольных таблиц. Ячейки таблиц могут содержать строки, числа или формулы, задающие зависимость значений одних ячеек от значений других ячеек. Пользовать может просматривать, задавать и изменять содержимое ячеек с немедленным отображением результата этих действий на экране, Э. т. обеспечивают также задание формата отображаемых данных, поиск и сортировку данных вывод результатов на печать. Кроме того, Э. т. могут дополняться разчиными программными средствами (например, текстовым процессором) для того, чтобы пользователи могли получать информацию, не выходя из Э. т. Такая Э. т. становится интегрированной средой. Наиболее известные интегрированные Э. т.: Works и Excel фирмы Microsoft; Lotus 1-2-3 фирмы Lotus Development; Super Calc фирмы Computer Associates; Quatro Pro фирмы Borland
ЭЛЕКТРОННЫЕ ДЕНЬГИ, цифровые деньги [digital money, digital cash]
 Средства расчета, разрабатываемые в настоящее время компаниями Cyber-Cash и DjgiCash. Простейшей формой электронных денег являются закодированные информационные пакеты, передаваемые по сети. Предполагаемая защищенность от подделки примерно соответствует защищенности долларовых купюр
ЭЛЕКТРОННЫЙ ДИСК, виртуальный диск, псевдодиск [electronic disk, virtual disk. RAM disk]
 Особым образом организованная область оперативной памяти, внешне проявляющая себя как магнитный диск. Скорость обмена данными с Э. д. намного больше, чем с обычным, поэтому, используя Э. Д-. можно значительно увеличить производительность работы с компьютером. Если в процессе работы на Э. д. записывается информация, которую нужно сохранить, ее необходимо периодически копировать на магнитный диск. Это связано с тем, что оперативная память энергозависима и любой сбой электропитания или выключение компьютера приведет к потере информации Один из вариантов использования Э. д. такой: переписать на него программы, которые чаще всего используются, и заставить операционную систем) обращаться для загрузки этих программ не к жесткому диску, а к электронному. В персональных IBM-совместимых компьютерах Э. д. организуется про граммно, с использованием загружаемого драйвера Э. д. ramdrive.sys
ЭЛЕКТРОННЫЙ ДОКУМЕНТ [electronic document]
 Совокупность данных в памяти вычислительной системы, предназначенная для просмотра и про слушивания человеком с помощью программных и аппаратных средств. Э. д. может содержать текстовую, графическую и звуковую информацию. Э. д. может быть оформлен в виде гипертекста
ЭЛЕМЕНТ ДАННЫХ, элементарное данное [data item, item]
 Поименованная или непоименованная составная часть данных, воспринимаемая как неделимый объект обработки. Например, число, логическое значение, строка символо,, переменная, элемент массива, поле данных и т. п. Э. д. называют и сложную часть данных, составленную из других частей, если в контексте она рассматривается, как неделимый объект обработки, например, выводимая на экран запись
ЭЛЕМЕНТНАЯ БАЗА [integrated circuit]
 Набор основных функциональных элементов, на основе которого создаются устройства вычислительной техники. Например, электронные лампы, полупроводниковые диоды и триоды, микросхемы, интегральные схемы и т. л. Э. б. является одним из признаков, по которому классифицируются поколения ЭВМ


Смайлики

Стандаpтные:
:-) Основная улыбка ;-) Шутливая улыбка :-( Нахмурившийся :-I Равнодушный | :-> Саркастический >:-> Злодей >;-> Шутливый злодей
Изменение рта:
:-[ Вампир :-E Зубастый вампир :-F Вампир со сломанным зубом :-q Пытающийся достать языком нос :-* Съевший что-то кислое :-@ Вопящий :-# Одевший вставную челюсть :-] Болван :-? Курящий трубку :-} Потрескавшиеся губы :-{ Усатый :-j Левая улыбка :-a Лижущий губы :-k Укуси меня :-\ Нерешительный :-| Всего хорошего :-< Печальный :-0 Не кричать ! :-` Плюющий | :-! Прикусивший губу :-$ С завязанным ртом :-% Бюрократ :-d Тоже самое, что слева, но в другую сторону :-e Разочарованный :-t Хмурый :-i Полу-улыбка :-& Прикусивший язык :-Q Курящий :-[ Грустный болван :-P С высунутым языком :-S Совравший :-D Хохочущий :-9 Лижущий губы в др. сторону :-C С опухшими губами :-/ Скептик :-o Ой-ой ! :-X С заклеенным ртом :-v Говорящий :-b Высунувший направо язык :-1 Со скривленым ртом
Изменение носа :
:*) Пьяный :^) Со сломанным носом :v) Со сломанным носом, в другом направлении :u) Большой нос (левый) | :_) Нос съехал с лица :<) Курносый :=) Двуносый :o) Клоун :n) Большой нос (правый)
Изменение глаз :
%-) Смотревший на экран более 15 часов подряд B-) Надевший очки в роговой оправе O-) Циклоп или одевший водолазную маску | 8-) С солнечными очками .-) Одноглазый Джо ,-) Шутящий одноглазый Джо g-) Одноглазый Джо в пенсне
Изменение нескольких частей :
|-I Спящий |-O Зевающий %-6 С отмороженным мозгом | |^o Храпящий :,( Плачущий безносый 8-| Озадаченный
Дополнение частей :
::-) Одевший очки (четырехглазик) B:-) С очками, поднятыми вверх `:-) Сбривший бровь ,:-) Сбривший другую бровь :-{) Усатый :-#) С пышными усами {:-) Надевший парик }:-) Надевший парик или страдающий от измен супруги(а) [:-) Слушающий плейер :'-) Смех сквозь слезы (:-) Большая улыбка =:-) С торчащими вверх волосами | 8:-) Маленькая девочка :-)-8 Большая девушка O :-) Ангел C=:-) Чеpт *<:-) Одевший шапку Деда Мороза E-:-) Радио-оператор 8 :-) Колдун @:-) Одевший тюрбан :-)~ Слюнявый :-~) Сопливый :-)) С двойным подбородком >:-) Дьявол -:-) Панк +:-) Священник :-)X Одевший бабочку
Разное :
(-: Левосторонняя улыбка [:] Робот :'-( Плачущий <|-) Китаец <|-( Не любящий шуток китаец -:-( Грустный панк *:o) Клоун Бозо 3:] Улыбающийся рогатый скот 3:[ Не улыбающийся рогатый скот d8= Сварщик (:I Яйцеголовый [ ] Объятия 8 Бесконечный +[ Маст Дай! | :-{} Намазавший губы @= Ядерная война (8-o В химзащите ~~:-( Вспотевший/горящий O |-) Религиозный 8 :-I Колдун Unix >:-I Злой тупица 3:o[ Коза, одетая клоуном <:-I Тупица K:P Карлсон X-( Мертвый X-) Умиpать не стpашно X-I Меpтвым все pавно X-E После смеpти отомщу X->> Встpетимся в аду ! X-X Меpтвые не pазговаpивают
Мега-смайлики :
C=}>;*{)) Пьяный злой черт в парике, надетом наоборот, усами и двойным подбородком -[8~*~E~-8 Плачущая, пьяная, сопливая, злая, слюнявая, слушающая плейер, удивленная панк-рокерша С=%^F~~ Проведящий за компьютером 15 часов голодный чеpт с поломанным носом и выбитым зубом