Иллюстрированный самоучитель по GPRS

Глава 1. Новые возможности мобильного Internet

  • Основные преимущества системы GPRS
  • Почему данные стали «мобильными»?
    • Схема связи на основе GPRS
  • История Internet
  • Альтернативные способы передачи данных по мобильной связи и GPRS
  • Развитие GPRS
    • Приложения GPRS
    • Сети GPRS-GSM
  • Технология GPRS
  • Стандарты GPRS-терминалов
  • GPRS - ключ к эволюционному переходу к системам третьего поколения
    • Модернизация основной сети GSM
    • Новые узлы для пакетной передачи данных
    • Модернизация существующих узлов GSM
  • GPRS и телефон Motorola Timeport 260
    • Что в коробке...
    • Интуитивный телефон
    • Настройка меню WAP через GPRS и получение данных
    • Подключение Timeport 260 к компьютеру, установка программного обеспечения и соединение с Internet
    • Синхронизация -- TrueSync Plus Software от Starfish
  • Мобильный выход в Internet через GPRS с Motorola Timeport 260
    • Подключение телефона
    • Необходимые настройки телефона в сети Би Лайн
    • Настройки в программе GPRS Wizard
    • Необходимые настройки телефона в сети МТС
    • Настройка телефона и компьютера для доступа в Internet через GPRS
  • Настройки телефона Ericsson T39m в сети Би Лайн
    • Передача данных через GPRS
    • WAP-браузер
    • Настройка ПК
    • Настройки почтового клиента T39m

  • Настройка телефонов Siemens S45 и МЕ45 в сети МТС
    • Для доступа к WAP-сайтам через GPRS
    • Настройка телефона и компьютера для доступа в Internet через GPRS
    Настройка телефона Nokia 8310 в сети МТС
    • Для доступа к WAP-сайтам через GPRS
    • Настройка телефона и компьютера для доступа в Internet через GPRS
  • Первые личные впечатления от работы с GPRS
    • Ноутбук
    • Psion
    • Pocket PC
    • Palm
    • Результаты
  • Будущее без проводов - GPRS сегодня и завтра
  • GPRS: плюсы и минусы этого сервиса

Глава 2. Стандарты беспроводной связи

  • IRDA
  • Bluetooth
    • Вопросы и ответы по Bluetooth

Глава 3. Технологии передачи сообщений

  • Short Message Service (SMS)
  • Nokia Smart Messaging
  • Enhanced Messaging Service (EMS)
  • Multimedia Message Service (MMS)

Глава 4. Вопросы и ответы


Иллюстрированный самоучитель по GPRS начало

Основные преимущества системы GPRS

GPRS — это система, которая реализует и поддерживает протокол пакетной передачи информации в рамках сети сотовой связи. При пакетной передаче данных соответствующий радиоканал занимается лишь в процессе передачи информации, благодаря чему достигается более высокая эффективность его использования. Наиболее ощутимо это преимущество при передаче данных и выходе в глобальную сеть Internet.
При использовании системы GPRS информация собирается в пакеты и передается в эфир, они заполняют те «пустоты» (не используемый в данный момент канал трафика), которые всегда есть при передаче голосовой информации. В случае, если при обычной передаче данных сначала устанавливается соединение и только после этого начинается передача данных, то при пакетной передаче этап установления соединения практически отсутствует. В этом и заключается принципиальное отличие режима пакетной передачи данных. В результате более эффективно используются ресурсы сети и появляется возможность более выгодной для абонента тарификации, основанной не на длительности соединения, а на объёме принятой и переданной информации. В сетях, поддерживающих GPRS, предусмотрен поэтапный путь наращивания скорости передачи данных; в пределе GPRS может обеспечивать скорость до 115 Кбит/с. На сегодняшний день основные ограничения связаны с возможностями абонентских терминалов. GPRS-терминалы первого поколения будут обеспечивать передачу информации со скоростью до 53.6 Кбит/с и приём — со скоростью до 26.8 Кбит/с.


Почему данные стали «мобильными»?

Совсем недавно передача данных по мобильной связи была экзотикой, которая мало кого интересовала в практическом плане. Но теперь ситуация быстро изменяется:

  • развиваются сотовые сети, на базе сетей GSM могут добавляться дополнительные услуги и приложения:
  • бурное развитие Internet увеличивает потребность абонентов в доступе;
  • широкое использование Интранет (внутренних корпоративных сетей) ориентирует на подключение бизнес-пользователей к корпоративным сетям в мобильном варианте;
  • появление небольших компьютеров типа PDA или palmtop позволяющих использовать их совместно с мобильными телефонами;
  • мобильность работников — все большее число людей работают дома или в процессе поездки, что требует создания для них системы поддержки мобильности.


Схема связи на основе GPRS

К 2002 году произошло увеличение трафика мобильной передачи данных на 300%, прежде всего из-за сближения рынков Internet и рынка мобильной связи — самых быстрорастущих рынков в экономике. Безусловно, основную долю прироста, особенно в плане роста прибылей связывают с рынком не конечных абонентов, а бизнес-клиентами, но если к концу 2002 года суммарные прибыли от передачи данных по мобильной связи во всем мире ожидаются на уровне 10 млрд. USD, то уже на 2005 год прогнозируется и вовсе фантастическая цифра - 80 млрд. USD.
Это закладывает основу для внедрения GPRS.
Прогнозы утверждают, что основными приложениями мобильной связи станет использование электронной почты (частной и корпоративной), доступ к Internet и базам данных в корпоративных сетях (интранет).


История Internet

Internet — это система связи и одновременно информационная система, среда общения. История Internet начинается примерно в 60-годы XX века.
В 1969 агентство ARPA (Агентство передовых исследовательских проектов) занялось исследованиями с целью создать экспериментальную сеть «с коммутацией пакетов». Эта сеть была создана и получила очень простое и аскетичное наименование ARPANET, то есть, сеть агентства... Сеть была построена для изучения технологий независимой передачи потока данных в системе связи.
Именно успешным развитием исследовательского проекта, мы обязаны тому, что многие организации, которые принимали участие в ее создании, начали применять ее в своих повседневных целях, и в 1975 году экспериментальную сеть объявили рабочей, причем ответственность за нее была возложена на DCA (Агентство Оборонной связи США). Одновременно, специалисты занялись разработкой основ TCP/IP (Transmission Control Protocol/Internet Protocol — Протоколы управления процессом передачи/Internet -протокол).
TCP/IP были приняты, в качестве Военных Стандартов (MIL STD) в 1983 году, после чего от всех хостов (компьютеров), подключенных к APRANET стали требовать работать только с данными протоколами. Одновременно стал распространяться термин «Internet», в то время, как APRANET была разделена на две отдельных сети: MILNET (Военная Сеть) — несекретная часть Оборонной Сети Передачи данных (DDN) и новую (уменьшенных размеров) APRANET. Термин Internet употребляли тогда, когда имели в виду сразу обе сети.
В 1985 году, Фонд Национальной Науки (NSF) принял участие в создании собственной сети NSFNet, которая вскоре была подключена к Internet. Первоначально в состав NSF входили пять супер-компьютерных центров, впрочем, меньше, чем в APRANET, а скорость передачи данных в каналах связи не превышала 56 кбит/с. В то же время, создание NSFNet стало заметным вкладом в развитие Internet, поскольку позволило по-новому взглянуть на то, как можно использовать Internet.
Фонд поставил задачу, чтобы каждый ученый, каждый инженер в США оказались «подключены» к единой сети, а потому приступили к созданию сети с более быстрыми каналами, которая бы объединила многочисленные региональные и локальные сети.
Не так давно, в 1990 году APRANET формально завершила свое существование, а еше через 5 лет, NSFNet прекратила играть первую скрипку в оркестре Internet.
Internet вырос далеко за пределы того, каким его видели и проектировали, он перерос те агентства и организации, которые его создавали, они более не могли играть в его росте доминирующую роль. Сегодня это мощная всемирная сеть связи, основанная на распределенных коммутационных элементах - хабах и каналах связи. С 1983 года Internet растет по экспоненте, и едва ли ни одна деталь сохранилась с тех времен, — Internet все еще работает на основе набора протоколов TCP/IP.
Если термин «Internet» первоначально использовался для описания сети, построенной на базе интернет-протокола IP, то сейчас это слово приобрело глобальный смысл и лишь иногда применяется в качестве названия набора объединенных сетей. Строго говоря — Internet, это любой набор отдельных в физическом смысле сетей, которые соединены между собой единым протоколом IP, что позволяет говорить о них, как об одной логической сети.
Бурный рост Internet, вызвал повышенный интерес к протоколам TCP/IP, а в итоге появились специалисты и компании, которые разобравшись в протоколе, нашли для него и ряд других приложений, прежде всего, использовав этот же протокол для построения локальных вычислительных сетей (LAN — Local Area Network) даже тогда, когда не предусматривалось их подключение к Internet. Кроме того, TCP/IP стал применяться при создании корпоративных сетей, которые взяли на вооружение интернет-технологии, в том числе WWW (World Wide Web) — мировую паутину, чтобы наладить эффективный обмен внутрикорпоративной информацией. Эти корпоративные сети получили название «интранет» и могут подключаться, либо не быть подключены к Internet.
С 1990 года Internet до некоторой степени саморазвивающимся объектом, как говорят инженеры, в нем действует положительная обратная связь, то есть, но мере того как больше ресурсов (информационных и физических) становятся доступными так большее число людей и компаний стремятся получить доступ к этим ресурсам.
Вряд ли стоит специально перечислять все разнообразие услуг, которое можно получить через Internet, ради формальности назовем некоторые из них:

  • отправка и получения e-mail;
  • доступ практически к любой информации;
  • возможность общения;
  • возможность участвовать в исследованиях;
  • получение программного обеспечения;
  • возможность «виртуального» посещения магазинов и реальной покупки товаров;
  • прослушивание и приобретение музыки;
  • просмотр видео;
  • игры.

Вернемся к нашей основной теме — GPRS. GPRS является «довеском» к существующей сети GSM и использует некоторые ресурсы сети совместно. Существующие сети GSM. однако, основаны на применении далеко не новой технологии коммутируемых соединений, существовавшей с начала XX века, которые, в своем стандартном варианте способны обеспечивать скорость передачи данных всего лишь 9.6 кбит/с. В то же время, большинство приложений и услуг, подразумевают значительно большую скорость передачи данных, что было отражено комитетом ETSI в стандартах группы Поколения 2+ (Phase 2+). Соответственно, были предприняты некоторые меры, чтобы исправить текущую ситуацию.


Альтернативные способы передачи данных по мобильной связи и GPRS

Стандартная скорость передачи данных в сетях GSM составляет всего 9600 бит/с, но благодаря методу, известному, как HSGSP, связанному с выделением дополнительных тайм-слотов для осуществления одного «разговора» удается ее повышать. Рассмотрим варианты:

14.4 кбит/с

Такую скорость удается получить за счет сокращения сигнализации и усеченного корректирования ошибок, приходится сокращать заголовок (overhead), высвобождающиеся ресурсы позволяют осуществлять передачу данных с указанной скоростью.

HSCSD (High Speed Circuit Switched Data)

Введение высокоскоростной передачи данных по коммутируемым линиям за счет выделения абоненту нескольких тайм-слотов позволит достичь заметного выигрыша в скорости передачи данных. Например, выделяя 2 тайм-слота, можно достичь скорости до 28.8 кбит/с, а выделив четыре, получим 57.6 кбит/с.

CDPO (Cellular Digital Packet Data)

Как GPRS предназначен для GSM, так CDPD ориентирован на AMPS и CDMA. Позволяет достичь скорость до 14.4 кбит/с, а в случае использования так называемого «расширенного CDMA» обеспечит скорость до 76.8 кбит/с.

GPRS (General Packet Radio Service)

Это система пакетной передачи данных в коммутируемых сетях. Ожидается, что теоретически достижимая скорость может достичь 171.2 кбит/с, хотя в ближайшее время вряд ли стоит ждать достижения скоростей более 111 кбит/с.
Компания Motorola предлагает следующую картинку, наглядно представляющую соотношения систем передачи данных на базе GSM

Одно из основных преимуществ GPRS — это то, что это способ передавать данные с более высокими скоростями, чем это было возможно до недавнего времени. Такие высокие скорости сделают возможными внедрение разнообразных приложений — от нетребовательного к скорости передачи SMS-cepвиса до высокоскоростной передачи данных в локальной корпоративной сети.
Время установки соединения в GPRS будет почти мгновенным, поэтому планируется, что более не будет оплачивать «время на линии», в счет будут включаться объемы переданной или полученной информации. Это означает, что GPRS будет максимально привлекательной технологией для всевозможных приложений, характеризующихся «взрывным» характером передачи данных, таким как e-mail, телеметрия и тому подобных услуг. Это также обеспечивает GPRS совместимость с существующими сетями пакетной передачи данных на базе TCP/IP или Х.25.
Система с коммутацией пакетов весьма эффективна, поскольку сетевые ресурсы эксплуатируются лишь в момент непосредственной передачи пакетов. В переводе на общепонятный язык — это означает, что весь доступный выделенный диапазон связи может использоваться совместно всеми абонентами.
Основные свойства GPRS:

  • Высокая скорость передачи данных — 171.2 кбит/с (средняя 111 кбит/с);
  • Быстрое установление связи/Быстрый разрыв соединения;
  • Способствует внедрению новых услуг (например, Телеметрии);
  • Поддерживает другие сети пакетной передачи данных (TCP/IP,"Х.25);
  • Абоненты совместно используют физические ресурсы сети;
  • Обеспечивает мобильность абонентов, с сохранением доступа к сетям GSM/GPRS. Internet и корпоративным сетям (интранет);
  • Возможность использовать ресурсы сети GSM в офф-пиковые периоды.

Поскольку GPRS выполнен на базе GSM, новое оборудование GPRS/GSM будет обеспечивать доступ, как в сеть GSM, так и в наложенную сеть GPRS. Впрочем, пока, по-видимому, не стоит ожидать никаких других терминалов, кроме терминалов класса «С». Такие терминалы позволяют работать одновременно только в режиме GSM или только в режиме GPRS.
Поскольку сеть GPRS позволяет совместно использовать ресурсы и является наложенной на сеть GSM, существенным моментом является ее возможность загрузить ресурсы сети к «оффпиковые» периоды, например, с 20:00 до 05:00.


Развитие GPRS

Спецификация GPRS Phase 2 к настоящее время не определена в полном объеме, но планируется, что дальнейшая эволюция пойдет по пути повышении скорости передачи данных в системах Enchanced Data rates for GSM Evolution — технологии EDGE или E-GPRS. Введение E-GPRS связывается с повышением скорости передачи данных примерно в три раза по отношению к тому, что может быть достигнуто в сетях GPRS. Повышение скорости передачи данных связывают с переходом на применение нового способа фазовой модуляции, известного под названием 8PSK.
Передаче данных также отводится основная роль в европейских системах 3-го поколения: Universal Mobile Telecommunications System — UMTS (Универсальная система мобильной связи).
Комбинация UMTS и GPRS обеспечит возможность внедрения мультимедийных приложений, таких, как видеотелефония, через Internet.


Приложения GPRS

Набор приложений по оценкам специалистов может включать:

  • e-mail
  • доступ к Internet
  • телеметрию
  • поддержка протокола беспроводных приложений (WAP)
  • поддержка протокола передачи файлов (FTP)

Электронная почта

Это услуга, которая обеспечит абонентов сотовой сети (клиентов) получать и отсылать сообщения по сети Internet без необходимости доступа к компьютеру. Каждый, кто имеет адpec в Internet, сможет отослать сообщение любому, чей электронный адрес вам известен.
Источником адреса для вас может быть ISP (Internet Service Provider — провайдер) или оператор сотовой сети, если он возьмет на себя эти функции. В техническом плане — это компьютер, подключенный к Internet, который будет хранить полученные на ваше имя сообщения пока вы их не заберете (например, в память телефона или вашего домашнего компьютера).

Доступ к Internet

Web -- это распределенная информационная система, основанная на технологии сервер-клиент. Клиентская программа, это ваш браузер (Internet Explorer, Netscape, Linux или какой-либо иной). После того, как вы подключились браузером к сайту, где хранятся интересующие вас страницы, включая текст, графику, а также мультимедиа (видеофрагменты, музыка).

Телеметрия

Удаленный мониторинг сайтов в Internet или какого-либо оборудования — созданы будто бы специально для GPRS, поскольку «взрывной» характер передачи данных чрезвычайно удачно вписывается в технологию пакетной связи GPRS.

WAP

Протокол Беспроводных Приложений — WAP сейчас рекламируется как некий прорыв, который позволит обеспечить тотальный доступ к интернет-ресурсам с мобильных устройств, прежде всего телефонов. Число WAP-совместимых ресурсов в Internet сейчас растет взрывообразными темпами, появились и первые российские ресурсы.

FTP

Это сервис, предназначенный для копирования файлов с одного компьютера на другой. Может использоваться в торговых и бизнес-приложениях.


Сети GPRS-GSM

Чтобы поддерживать GPRS, сети GSM должны быть дополнены двумя основными функциональными элементами: Serving GPRS Support Node (SGSN) — узел, которым играет в сети GPRS ту же роль, что и коммутатор MSC и гостевой регистр VLR в сети GSM: и Gateway GPRS Support Node (GGSN) — эквивалент блока IWF (interworking unit) в сети GSM:

  • SGSN — отвечает за доступ абонентов в сеть GPRS (аутентификацию), а также мониторинг абонентов и трафика. Он служит для аутентификации оборудования и фиксирует все «действия» мобильного абонента в сети.
  • GGSN служит гейтом, то есть, соединяет сеть GPRS и внешние сети общедоступные или частные.

Впрочем, говорить о двух основных элементах можно лишь с некоторой натяжкой, поскольку каждый контроллер в сети GSM должен быть дооборудован устройством PCU (блок управления пакетной связью).

Добавим, что в сети GSM-GPRS появляется несколько новых интерфейсов, каждый с префиксом «G».

  • Gp — это протокол Frame Relay, однако, переход к технологии UMTS позволит внедрить вместо Frame Relay протокол ATM (Asynchronous Tr.mfer Mode) — это, кстати, вызовет переход к коммутаторам ATM от сегодняшних коммутаторов MSC.
  • Сr — протокол с коммутацией соединений типа С7.
  • Gn — протокол пакетной передачи типа TCP/IP (Transmisson Control Protocol и Internet Protocol).


Технология GPRS

Новые возможности GPRS позволит ввести принципиально новые услуги, которые раньше не были доступны. Прежде всего это мобильный доступ к ресурсам Internet с удовлетворяющей потребителя скоростью и с очень выгодной системой тарификации. К примеру, посредством системы GPRS абонент может просматривать WEB-страницы в Internet столько, сколько ему необходимо, поскольку плата взимается только за объем принятой информации, а не за время нахождения в сети Internet. При введении повременной оплаты на фиксированных телефонных линиях, тарифы на доступ в Internet с мобильного GPRS-телефона будут еще более конкурентоспособны. Технология GPRS позволит быстро передавать и получать большие объемы данных, видеоизображения, музыкальные файлы стандарта МРЗ и другую мультимедийную информацию. Для корпоративных пользователей система GPRS может послужить отличным инструментом для обеспечения безопасного и быстрого доступа сотрудников к корпоративным сетям предприятий, к почтовым, информационным серверам, удалённым базам данных. Технологии GPRS может применяться в системах телеметрии: устройство может быть все время подключено, не занимая при этом отдельный канал. Такая услуга может быть востребована службами охраны, банками для подключения банкоматов и в других областях, в том числе и промышленных.


Стандарты GPRS-терминалов

Класс А

Терминал позволяет одновременно осуществлять передачу речи и данных в режиме GPRS

Класс В

Терминал поддерживает и голосовое соединение, и передачу данных в пакетном режиме (GPRS), но или режимы используются не одновременно (во время передачи данных через GPRS абонент не может совершать и принимать голосовые звонки и наоборот).

Класс С

Терминал обеспечивает только передачу данных в пакетном режиме. Наиболее вероятное исполнение — в виде PCMCIA-карты, устанавливаемой в портативный компьютер. Ожидается, что первыми появятся на рынке терминалы класса В. Скорость приёма и передачи информации зависит от возможностей конкретной модели мобильного терминала, а именно от количества каналов, поддерживающих приём и передачу данных. При этом один канал поддерживает передачу информации с максимальной скоростью 13.4 кб/с.
Полная мобильность подразумевает, что человеку повсеместно становятся доступны все возможности, которые он имеет на своем рабочем месте, такие как скоростной доступ в Internet.
GPRS (General Packet Radio Service) — технология, которая делает это реальным уже сегодня.
Суть услуги заключается в организации постоянного подключения через GPRS-телефон к сети Internet. Для работы в Сети возможно использовать компьютер (например, ноутбук) или электронный органайзер (Palm Pilot, Psion, Cassiopea). При этом абонент имеет возможность просматривать HTML-страницы, перекачивать файлы, работать с электронной почтой и любыми другими ресурсами Internet.
Чем привлекательна эта технология:

  • GPRS предоставляет немедленный доступ к услугам, без необходимости дозваниваться к интернет-провайдеру.
  • Пользователи GPRS получают доступ к Internet в полном объеме, как при проводном соединении.
  • Можно работать с WAP-сайтами непосредственно с телефонного аппарата GPRS.
  • Оплачивается только объем посланной/полученной информации, а не эфирное время. До сих пор в сотовых сетях для передачи или приема данных абонентом занимался целый канал на время от установления соединения до его разрыва, которое оплачивалось вне зависимости от его загрузки.
  • В GPRS максимально возможная скорость передачи данных составляет 171,2 Кбит/с — это более чем в 3 раза быстрее, чем режим работы проводных линий, и почти в 12 раз быстрее работы передачи данных в обычных сетях GSM (9,6 кбит/с). Уже сегодня доступна скорость до 33 Кбит/с.


GPRS - ключ к эволюционному переходу к системам
третьего поколения

Общая служба пакетной передачи данных по радиоканалу (General Packet Radio Services — GPRS) представляет собой новую систему пакетной передачи данных для систем GSM, предоставляющая операторам замечательную возможность успешно внедриться на капризный массовый рынок услуг беспроводной передачи данных. Еще важнее то, что от оператора сети стандарта GSM не потребуется значительных усилий по модернизации инфраструктуры основной сети для обеспечения поддержки услуг GPRS. Реализация GPRS на базе существующей платформы GSM не только добавит радиопередачу данных к существующему набору услуг оператора, но и подготовит его сеть к внедрению в недалеком будущем систем стандарта W-CDMA (широкополосная CDMA) в диапазоне 2 ГГи.
Что определяет успех на рынке радиодоступа к сети Internet? В настоящее время мобильная передача данных пока не получила широкого распространения. Тем не менее, на определенных рынках среди разных сегментов пользователей начинает наблюдаться быстрый рост. В основном этот рост определяет рынок корпоративных пользователей, которые начинают пользоваться услугами мобильной передачи данных так же, как они привыкли пользоваться передачей данных в сетях фиксированной связи. Можно перечислить следующие основные предпосылки роста популярности мобильной передачи данных:

  • необходимость обеспечения гибкости моделей деятельности компаний;
  • необходимость получения доступа к обмену данными во время поездок
  • достигаемая значительная экономия времени

Кроме того, в ряд основных выходит фактор использования сетей lnternel/интранет для работы разных приложений, связанных с передачей данных — работа с этими сетями позволяет использовать большое количество стандартного программного обеспечения. Использование электронной почты уже давно стало правилом в компаниях, а последнее время наблюдается устойчивый рост числа индивидуальных пользователей электронной почтой.
Помимо этого, нельзя не учитывать гигантский потенциал специализированных «вертикальных» приложений, таких как электронная коммерция, диспетчерские службы и отслеживание перемещения грузов при автоперевозках.
Система GPRS обеспечит пакетную коммутацию на всем протяжении канала связи от мобильного терминала абонента и выше, существенно оптимизируя услуги передачи данных в сетях стандарта GSM, особенно с учетом прерывистого характера трафика в сетях lnternet/интранет. Соединение будет устанавливаться практически мгновенно, а пользователи будут платить за фактические объемы переданных данных, а не за время соединения.
GPRS использует сетевые ресурсы и занимает участок частотного диапазона только в моменты фактической передачи данных, что обеспечивает чрезвычайно эффективное использование доступной полосы частот и позволяет делить один радиоканал между несколькими пользователями.
Система GPRS поддерживает все самые распространенные протоколы передачи данных в сети, в частности, Internet-протокол IP, что позволит абонентам сети подключаться к любому источнику информации в мире с помощью мобильного терминала GPRS.
GPRS обеспечит бесшовное соединение, например, через интерфейсы TCP/IP или Х.25 с существующими системами передачи данных, что позволит обеспечить поддержку самых разнообразных приложений: от низкоскоростной системы обмена сообщениями до работы с высокоскоростной корпоративной ЛВС.
Итак, какие же изменения должны произойти в основной сети для обеспечения перехода к GPRS?


Модернизация основной сети GSM

В сравнении с развертыванием новой телекоммуникационной системы, создание инфраструктуры GPRS выглядит достаточно несложной и недорогой процедурой. Кроме того, добавление системы пакетной передачи к уже существующей сети стандарта GSM подготовит эту сеть к появлению систем третьего поколения стандарта W-CDMA.
Система GPRS для своего развертывания потребует от сети GSM новых функциональных возможностей и новых типов коммутации с внешними сетями передачи данных; тем не менее, GPRS в большей мере является расширением существующей сети GSM.
Система GPRS будет реализована путем простого добавления новых узлов пакетной обработки данных и модернизации существующих узлов для обеспечения маршрутизации пакетов данных от мобильного терминала до шлюзового узла. Шлюзовой узел обеспечит взаимоприсоединение с внешней сетью пакетной передачи данных для реализации доступа к сетям lnternet/интранет и, например, к базам данных.
GPRS позволит реализовать услугу многоточечной передачи (мультивешания) в соответствии с требованиями, изложенными в документах по стандартизации Фазы 2 ETSI. что в настоящий момент не представляется возможным осуществить на базе существующей системы передачи данных и сетях GSM по коммутируемому каналу. Многоточечную передачу можно будет осуществить между провайдером телекоммуникационных услуг фиксированной сети и группой мобильных абонентов с терминалами GPRS.


Новые узлы для пакетной передачи данных

Для работы приложений GPRS в сети стандарта GSM потребуется установить три новых типа логических узлов:

  • Узел обеспечения GPRS (Serving GPRS Support Node - SGSN)
  • Узел поддержки шлюза GPRS (Gateway GPRS Support Node - GGSN)
  • Центр обеспечения мультивешания (Pomt-to-Multipoint Service Center - PTM-SC)

Узел SGSN обеспечит маршрутизацию пакетов, включая управление мобильной связью, аутентификацию и шифрование в обоих направлениях для всех абонентов GPRS, находящихся в пределах зоны обслуживания системы. Абонент GPRS в зависимости от своего местоположения может обслуживаться любым узлом SGSN сети. Трафик передается от узла SGSN на контроллер базовых станций BSC, а в направлении к мобильному терминалу - через базовую приемопередающую станцию BTS.
Узел GGSN обеспечит шлюз во внешние сети ISP, одновременно неся функции обеспечения безопасности, обработки счетов абонентов и динамического выделения IP-адресов. С точки зрения внешней сети узел GGSN будет представлить собой хост, которому принадлежат все IP-адреса, выделенные абонентам сети GPRS.
Узел PTM-SC обрабатывает трафик мультивещания между магистралью GPRS и домашним регистром HLR. Узлы присоединяются по магистральной сети IP. Функции логических узлов SGSN и GGSN могут быть объединены в одном общем физическом узле, а могут быть разведены по разным точкам, вплоть до размещения в разных сетях мобильной связи.


Модернизация существующих узлов GSM

Клиентам не придется, или почти не придется модернизировать узлы существующих сетей стандарта GSM; те же самые каналы передачи будут использоваться при передачах между BTS и BSC как для GSM, так и для GPRS.
Обеспечивается специальный интерфейс между коммутатором мобильной связи/визитным регистром местонахождения и SGSN для управления сигнализацией мобильных терминалов, поддерживающих как пакетную передачу данных, так и передачу данных по коммутируемому каналу.
Домашний регистр местонахождения HLR включает в себя данные об абонентах GPRS и информацию о маршрутизации; доступ к HLR возможен из узла SGSN. HLR также осуществит привязку каждого абонента к одному или нескольким узлам GGSN.
Контроллер базовых станций BSC должен будет обладать новыми функциональными возможностями управления каналами пакетной передачи данных, должен будет включать в себя новое аппаратное обеспечение в виде Блока управления пакетной передачей (Packet Control Unit — PCU) и новое программное обеспечение для управления мобильными абонентами GPRS и определением их местонахождения. Контроллер BSC также должен иметь новый интерфейс трафика и сигнализации с SGSN.
Базовым станциям BTS необходимы новые протоколы, поддерживающие пакетную передачу данных по радиоканалу и новый функциональные возможности распределения слотовых и канальных ресурсов. Использование сетевых ресурсов будет оптимизировано благодаря динамическому распределению ресурсов между двумя типами трафика, обрабатываемого контроллером BSC.
Факт перехода к системам мобильной связи третьего поколения часто представляется чем-то вроде «большого рывка», требующего полной модернизации всей сетевой инфраструктуры. При правильном выборе стратегии и планировании сети у операторов GSM есть великолепная возможность воспользоваться всеми преимуществами предоставления услуги скоростного мобильного доступа к сети Internet путем осуществления поэтапной модернизации основной сети с последовательным добавлением новых технологий радиодоступа по мере появления таковых на рынке.
Системе GPRS в этом процессе принадлежит роль одного из ключевых компонентов, позволяющего в сочетании с многослотовым GSM соединением в режиме передачи данных, и модуляцией EDGE, обеспечить высокоскоростной доступ к сети Internet абонентам сетей GSM во всем мире.


GPRS и телефон Motorola Timeport 260

Ну что ж, дорогие друзья, поздравляю вас. В наш поселок городского типа пришел GPRS. Точнее, пришла, потому что все ж таки это технология, система пакетной передачи данных, а не «КамАЗ», груженый бетонными блоками.


Что в коробке...

В коробочке от «БиЛайна» находится: GPRS-телефон -Motorola Timeport 260 (tri-band — так называемый опытный образец); зарядное устройство; всевозможные переходники (один даже под трехфазную розетку); клипсу; шнур для подключения мобильника к компьютеру (интерфейс RS-232); конвертик с информацией о PIN- и PUK-кодах; два диска с программным обеспечением: один со специальным приложением (GPRS Wizard), другой — с программой синхронизации мобильника с компьютером (TrueSync); всяческие инструкции —для телефона и для настройки WAP через GPRS.
И вот, обложившись всеми этими высокотехнологичными причиндалами и менторскими бумажками, приступим к тестированию.


Интуитивный телефон

Как всегда. Motorola оказалась на высоте — дизайн у телефона отличный, понятие «эргономичность» к нему тоже имеет самое непосредственное отношение. После включения, Timepon 260 издал приятное «ж-ж-ж», телефон вежливо попросил ввести PIN, что и было сделано, сверившись со справочной бумажкой.
«Выполнено», — сказал телефон и в течение примерно 4 секунд нашел «билайновскую» сеть. Шкала приема работала на полную катушку (Крылатское), и это нормально, потому что Timeport 260 все-таки «трехдиапазонник» (GSM 900, 1800, 1900 МГц). Вот его технические характеристики:

  • GPRS — High speed data transfer (передача данных с высокой скоростью);
  • поддерживает схемы кодировки I и 2 (CS1, CS2);
  • Time Slots: ITX, 3RX;
  • WAP 1.1, PDC 4.0 микробраузер;
  • поддерживает индустриальный стандарт SMG 31;
  • емкость памяти телефонной книги — 100 ячеек;
  • 10 мелодий звонков + 1 программируемый;
  • дисплей Optimax 96 х 64;
  • управление голосом: меню (9 пунктов), автодозвон (25 номеров);
  • виброзвонок VibraCall;
  • IrDA (инфракрасный порт);
  • цифровой диктофон на 3 мин. — VoiceNote;
  • поддержка русского языка;
  • голосовой набор (25 номеров);
  • ускоренный набор номера;
  • звонки по номерам из памяти и телефонной книги;
  • конференц-связь;
  • ожидание и удержание звонка;
  • переадресания звонков;
  • идентификация имени и номера звонящего;
  • автоматический и ручной выбор сети;
  • автоматический ответ (handslrce);
  • iTAP (аналог Т9) — ускоренный набор текста;
  • вес — 108 гр.;
  • размер аппарата с батареей — 45 х 150 х 21 мм;
  • антенна — стационарная;
  • время работы в режиме разговора — 210 мин.;
  • время работы в режиме ожидания — 150 час;
  • литий-ионная батарея;
  • емкость батареи — 600 мАч;
  • время заряда батареи со стандартным зарядным устройством — 2.5 час.

Представляется мне, что Motorola все-таки довольно консервативная компания. Быстренько пробежавшись по настройкам меню телефона (быстренько, потому что это устройство меню мне очень знакомо), оказалось, что, если не учитывать интернет-направленность аппарата, от моего старого доброго «стартака» по организации управления он не сильно отличается.
Все тот же стандартный набор мелодий для вызова и приема SMS, добавилась только одна программируемая; будильник по-прежнему отсутствует. Что мне не очень понравилось — так это кнопки. Они недостаточно мягкие, нажимать их приходится с усилием, пальцы у меня после тестирования болели так, словно было набито на дешевой «компьютерной» клавиатуре пятнадцать полос текста.
Зато возможно настраивать контрастность дисплея; настраивать быстрый доступ к основным функциям телефона и помещать часто используемые функции в свое персональное меню, вызывая их нажатием двух клавиш или используя голосовые команды (например, «Найти по имени», «Найти по номеру ячейки памяти», «Вызвать голосовую почту», «Индикатор заряда батареи», «Заблокировать телефон», «Последние 10 входящих вызовов», «Найти новую сеть», «Воспроизвести записи VoiceNote», «Отрегулировать контраст», «Доступ к Internet», «Включить инфракрасный интерфейс»); выбирать режим ввода текста (обыкновенным образом или в режиме IТАР — аналог Т9).
Кроме того, немного усовершенствована и дополнена функция «Последние 10 вызовов» (нововведение для всех последних телефонов от Motorola) — аппарат запоминает время и дату для 10 последних звонков, при этом показывая пользователю данные о том, ответил он на звонок или нет.


Настройка меню WAP через GPRS и получение данных

Зачем нам WAP, если тема про GPRS, спросите вы, и тут же наступите на грабли. Почему-то, когда о технологии заговорили всерьез, многие интересующиеся мобильниками граждане превратно поняли эту затею. GPRS появилась для того, чтобы повысить скоростные характеристики мобильного доступа в Сеть. А новая услуга, которую сотовые компании потихоньку во всем мире предоставлять начали, так и называется — WAP через GPRS.
При получении данных по GPRS, то есть при пакетной передаче данных, радиоканал используется в процессе отсылки и приема информации: занимаются неиспользуемые голосовые каналы, пустоты, которые остаются свободными при передаче голосовой информации в сотовой сети. Тарификация же основана на том, что абонент платит не за время, проведенное в Internet, а за объем переданной и полученной информации.
Аппарат Motorola Timeport 260 относится к терминалам класса «В», которые поддерживают и передачу голосовых данных, и GPRS, но режимы эти одновременно использоваться не могут (то есть, если абонент в данный момент передает или принимает информацию посредством технологии GPRS, on не может ни позвонить, ни ответить на звонок).
Аппарат поддерживает 3 канала для приема данных и один канал для передачи и может быть использован как модем для доступа в Internet, будучи подключенным к компьютеру. Стандарты же, принятые для телефонов будущего поколения, предусматривают еще два класса терминалов: «А» и «С». Терминал класса «С» работает только в режиме GPRS — это может быть ноутбук или Palm с предустановленной PCMCIA-карточкой. А терминал класса «А» уже позволяет передавать и принимать голосовые данные и пользоваться GPRS одновременно.
У аппарата Timeport 260 доступ к WAP-ресурсам настраивается очень просто. Через меню «Доступ в Internet» пользователь выбирает профиль «Настройка WAP»; далее прописывает значения IP и портов и время ожидания. И все. Можно приступать к настройке. В меню «Передача данных» пользователю необходимо выбрать подменю «GPRS», а далее вводить требуемые значения параметров APN (wap.beelinc.ru), имя пользователя и пароль, тип линии (модем). Завершающий штрих — ввод адреса домашней WAP-странички (wap.beeline.ru).
После завершения процедуры настроек телефон автоматически соединяется с Internet, а на дисплее отображается список доступных WAP-сервисов. Режим соединения аппаратом также выбирается автоматически (канал передачи GPRS или CSD 9.6). В режиме GPRS время соединения и загрузки домашней страницы составляет 5-10 секунд (при этом на дисплее отображается символ поднятой трубки), а в режиме CSD 9.6 -10-20. Это так в инструкции написано — про качество соединения и его скорость. При проверке — совпадает.


Подключение Timeport 260 к компьютеру, установка программного обеспечения и соединение с Internet

Подключить аппарат к компьютеру возможно двумя способами: через порт RS-232 или инфракрасный порт.
Для настройки подключения телефона к компьютеру и доступа через него к Internet вам и понадобится программное обеспечение «номер один» GPRS Wizard. Сначала необходимо инсталлировать программное обеспечение (оболочку и драйвер модема — Motorola Serial GPRS 56K), создать соединение (настроить основные и дополнительные параметры) и только затем произвести «физическое соединение» мобильника и компьютера через порт RS-232. До того момента, пока не установлено программное обеспечение и не заданы все настройки, к порту со шнуром в руках даже и не подходите и уж тем более ни в коем случае телефон при этом не включайте. Нельзя.
GPRS Wizard поддерживает Windows 98/NT/2000/XP. Оболочка и драйвер модема устанавливаются автоматически, также автоматически производится создание удаленного соединения и настройка его параметров и параметров модема. Вам необходимо только в меню программы выбрать тип соединения телефона с компьютером, а затем ввести данные: адрес APN (Access Point Name — имя домена Сети, через который идет интернет-траффик), имя пользователя, пароль и IP-адрес - при настройке основных параметров; первичный и вторичный DNS - при настройке дополнительных параметров (TCP/IP и QoS). Только по завершении данной процедуры вы соединяете компьютер и мобильник, а затем включаете телефон.
Дождавшись появления на дисплее телефона надписи «GPRS», вы имеете возможность начинать работать с GPRS Wizard. Для этого необходимо запустить программу и два раза кликнуть на иконке соединения для установления связи (только не нужно при этом «сидеть» в Internet, а то без конца будете получать уведомление об ошибке при установке соединения).
Скорость соединения при интеграции GPRS-мобильника и компьютера достигла 40 кбит/с на прием и 10-12 кбит/с на передачу! Ведь даже мой неплохой модем на 56k и довольно приличный провайдер совместно организовывали мне результат предельно в 40 кбит/с, не более того! А почту, кстати, получилось скачать гораздо быстрее, чем при традиционном интернет-соединении.


Синхронизация - TrueSync Plus Software от Starfish

При покупке Timeport 260, если вы обратите внимание на титульный лист книжечки — руководства по эксплуатации программного обеспечения, синхронизирующего мобильник с компьютером, вы увидите слоган следующего содержания: «Синхронизируйте ваш компьютер с телефоном Motorola Timeport P7389». Не пугайтесь. Телефон Motorola Timepon 260 фактически является продолжением аппарата Motorola Timeport P7389. Производители программного обеспечения просто не стали менять маркировку для выпускаемого программного обеспечения, потому что оно прекрасно подходит и для первой модели, и для второй.
В пакет программного обеспечения от компании Starfish Software Inc. (http://www.starfish.com/) для синхронизации мобильника с компьютером через инфракрасный порт (я все же сходил в гости к одному товарищу, у которого в наличии на машине таковой имеется) входит программа TrueSync Desktop — организатор «рабочего стола», который позволит вам создавать, редактировать и синхронизировать записи, если вы не будете пользоваться каким-то другим программным органайзером или устройством. Поддержка SMS посредством инструмента TrueSync SMS, который также входит в пакет этого программного обеспечения, делает возможным создание, передачу и прием текстовых сообщений с компьютера через инфракрасный порт.
Приложение работает, обращаясь к драйверу устройства (как в случае с аналоговым факс-модемом) со стандартным запросом обработки данных. Драйвер получает от приложения вызов модема, адресованный виртуальному порту, преобразует в команды, которые понятны телефону, и отправляет на физический порт (RS-232 в нашем случае), к которому подключен телефон, программно эмулируя аналоговый факс-модем. Кстати, я обнаружила, что это программное обеспечение подходит и для моего «стартака», чему чрезвычайно обрадовалась: теперь я смогу синхронизировать с почтовым клиентом Microsoft Outlook все данные своей записной книжки.
Перед тем как инсталлировать TrueSync, убедитесь, что на вашей машине достаточно места для нормальной работы этого приложения. Минимальные требования таковы: объем RAM — 8 Мб, место на жестком диске — 6 Мб, операционная система — Windows 9x или NT.
В начале инсталляции вы должны выбрать из четырех опций: первую — если вы не пользуетесь РIМ (personal information manager) и хотите использовать менеджер TrueSync Desktop; вторую -- если пользуетесь таковым (например, Microsoft Outlook, Lotus Organizer или Sidekick); третью — если хотите инсталлировать только SMS-клиент; четвертую — если ощушаете себя довольно продвинутым компьютерным пользователем и хотите модернизировать инсталляцию программного обеспечения. Я выбрала вторую и в качестве PIM -Outlook 2000.
Далее необходимо определиться с тем, какие дополнительные компоненты для инсталляции вам необходимы: 3Com Palm, REX, REX PRO, Yahoo!, Exite Planner, PageWriter 2000x. He стоит ничего выбирать, если вы таковыми не пользуетесь, если же вы пользуетесь каким-нибудь PIM, выбрав из меню нужный компонент, сможете затем синхронизировать ваш телефон и с ним. В итоге перед вами результат инсталляции четырех основных компонентов: TrueSync Plus, Motorola Time-port P7389, TrueSync.com, Outlook 2000 и тех дополнительных компонентов, которые вы выбрали. После этого автоматически запускается установка клиента TrueSync Plus Wizard.
Помните, в процессе инсталляции GPRS Wizard система установила драйвер Motorola, вот он то в сочетании с программным эмулятором модема и позволяет использовать телефон как обычный модем. А сервисы для пользователя будут доступны следующие:

  • передача и прием файлов и автоматическом режиме;
  • управление модемом в режиме терминала с помошью стандартных АТ-команд;
  • обмен сообщениями в режиме терминала и прием и передача файлов;
  • передача и прием факсовых сообщении;
  • звонки как в фоновом, так и в голосовом режимах;
  • передача и прием SMS;
  • ввод номеров в телефонную книгу на компьютере и в телефоне.

Ну, с Microsoft Outlook все более или менее понятно. К моему удивлению, никаких проблем с синхронизацией почтового клиента и TrueSync не случилось. Гораздо интереснее было разобраться с информационным менеджером TrueSync Desktop. Перед тем как заниматься собственно синхронизацией, необходимо все же проверить работоспособность ИК-порта — видят или не видят компьютер и телефон друг друга.
В случае, если в системной области (то есть, проще говоря, в трее) вы не наблюдаете соответствующую иконку, значит драйвер ИК-порта у вас не установлен или запрещен (Start [image] Settings [image] Control Panel [image] Infrared). Вам придется его установить с диска Windows. После этого в меню телефона «Настройка телефона» необходимо выбрать подменю «Активизация ИК-порта» и, повернув аппарат антенной к инфракрасному порту компьютера, нажать ОК.
По достижении положительного результата пикторгамма ИК в трее изменит вид, вы услышите звуковой сигнал и начнется опознавание устройства в приложении Infrared. В том случае, если система сообщит об обнаружении нового устройства и будет, как обычно, заниматься тугодумством, жевать губами и неопределенно высказываться, — укажите ей нужный драйвер (сама ведь вряд ли найдет): кликните на файле motlser.inf в корневом каталоге CD-ROM, с которого устанавливается синхронизационное программное обеспечение.
В процессе инсталляции TrueSync Desktop укажите страну и город, если хотите, чтобы программа автоматически корректировала время (мало ли, за границу рванете тело греть). После указания логического СОМ-порта выберите режим, в котором будет работать телефон: overwrites — на приеме данных, synchroni/es — на передаче. Затем укажите папку, где будут храниться ваши данные, остальные папки добавите потом, уже в процессе использования программного обеспечения.
После этого программа установки считает данные всех программ-органайзеров и устройств (если у вас есть такие, кроме телефона) и определит род информации, которой потом возможно будет обмениваться между этими компонентами. Поскольку у меня был только телефон и больше никаких «пимов» не предвиделось, то в процессе сканирования мое внимание привлекли только лишь категории данных для аппарата: Phone Memory, SIM Memory, SIM Fixed Dialing, SIM Numbers. После этого программа предложила выбрать объем информации, который будет передаваться при синхронизации, стоит выбрать «minimum: names and numbers» (контактов у меня не так уж и мною — штук 40, а напоминалки я себе никогда не пишу, поскольку ресурсов памяти моего собственного мозга пока на эту нехитрую процедуру хватает).
Да и, как оказалось, именно для телефона только эту опцию и можно выбрать. Остальные опции необходимо выбирать только в том случае, если вы хотите, чтобы синхронизация данных происходила между двумя программами-органайзерами. Конец установки.
Запустив приложение TrueSync Desktop, было обнаружено, что возможности органайзера включают календарь, карту часовых поясов, адресную книгу и заметки. Адресная книга или книга контактов содержит три раздела: Business. Personal и New Entries.
Но если пользоваться только разделами, организованными программой по умолчанию, то из программы-организатора в телефон возможно записывать только имя абонента и его телефонный номер. Поэтому для записи информации из телефона лучше всего создать еще какой-нибудь раздел контактов, воспользовавшись встроенным шаблоном программы
(L-series). Теперь для настройки приема данных необходимо воспользоваться модулем синхронизации и указать источники приема и передачи информации. И тут, если вы захотите перезаписать всю книгу контактов, вас ждет одна неприятная неожиданность: при совпадении имени абонента перезаписывается вся карточка полностью и дополнительные сведения (место работы, адрес компании) могут быть уничтожены. Поэтому для начала лучше всего выбирать опцию «Добавление» без перезаписи всей книги.
Далее в настройках программы для телефона необходимо указать Synchronize и произвести конфигурацию передаваемых данных, выбрав категорию в окне мэппинга (память SIM-карты или телефона, например) и изменяя свои предпочтения на этот счет при помощи кнопки Refresh List. После того, как все настройки осуществлены, вплоть до настроек соответствия полей данных (опция SmariMap или вручную), возможно начинать синхронизацию. В течение процесса синхронизации программа пишет и отображает лог-файл с результатами. Если происходит ошибка, результат всего процесса оказывается отрицательным, то есть нигде ничего не меняется.
В случае, если в режиме синхронизации обмен данными происходит двусторонний, то при передаче информации из программы в телефон, соответственно, только односторонний. Рекомендую, дабы избежать всевозможных накладок и сбоев, сразу пересохранить информацию из телефона, выбрав в его опциях Backup/Restore и, задав имя файлу с сохраняемыми данными и активировав инфракрасный порт, «бэкапнуться» от греха подальше (с первого раза у меня почему-то ничего не получилось, так что пришлось повторить процедуру.).
Теперь, когда у вас есть копия драгоценных контактов, возможно экспериментировать с передачей данных из органайзера TrueSync в телефон.
Если результат передачи данных из программы в телефон не понравился, возможно воспользоваться опцией восстановления информации — Restore. Однако будьте готовы к тому, что восстановятся только имена и телефоны абонентов, сохраненные вами когда-то в памяти телефона и SIM-карты. Настройки же, звукозапись и голосовые метки придется осуществлять заново.


Мобильный выход в Internet через GPRS с Motorola Timeport 260

В свое время с появлением услуги передачи данных в сети GSM основной проблемой мобильных «интернетчиков» была скорость. Навигация по всемирной паутине при 9,6 кбит/с, даже с поправкой на полную свободу перемещений, не внушала особого оптимизма. Погоды не делали и такие «уловки», как сжатие данных или отключение показа графики в интернет-браузерах... В связи с этим запуск одним из ведущих операторов сотовой связи новой системы передачи данных — GPRS (General Packet Radio Services), основным достоинством которой является более скоростной входящий трафик, может стать решающим фактором для повсеместного распространения услуги «мобильный офис». Основная особенность новой технологии состоит в том, что данные передаются небольшими пакетами по свободным радиоканалам (выделяемым динамически), и телефон не занимает тем самым «линию» постоянно.


Подключение телефона

В комплект с Motorola Timeport 260 прилагается кабель для связи с компьютером, а также компакт-диск с программой GPRS Wizard. Разумеется, для работы с Internet, а также с WAP, необходимо заказать у оператора услугу передачи данных.
Как настроить телефон и компьютер, описано ниже, а пока разрешите поделиться своими впечатлениями. Первое, что понадобится, — это: терпение. Кропотливо занести всю массу установок и не сделать ошибки — задание не из простых. Хорошо, если человек знаком с компьютером, и его не обескураживают такие понятия, как DNS, TCP/IP. В крайнем случае возможно приехать с телефоном и ноутбуком в сервис-центр, где специалист по абонентскому обслуживанию все наладит. Кроме того, терпение пригодится и при навигации по всемирной паутине. Несмотря на то, что дозвон происходит за считанные секунды и всегда с первого раза, соединение устанавливается на уровне 16-24 кбит/с (любопытно, что индицируется не реальная скорость соединения, а скорость обмена данными между ПК и модемом в телефоне, устанавливаемая в свойствах модема). Соединение держится долго, однако из-за того, что выделение свободных каналов для связи происходит динамически в зависимости от загрузки базовой станции (чем больше каналов вы займете, тем больше скорость трафика), сильно скачет скорость обмена данными.
При закачке файлов входящий трафик составляет в среднем 2,4 КБ/с, временами поднимаясь максимум до 3,6 КБ/с или же опускаясь до полукилобайта в секунду. Качать объемные данные (больше 10 мегабайт) с такой скоростью утомительно, а вот просто путешествовать по сайтам — вполне сносно даже при включенной графике. Если проводить аналогию с GSM-модемами, работающими на скорости до 9,6 кбит/с, то при GPRS-соединении с полноценным показом всех составляющих интернет-сайтов (графика, баннеры) скорость серфинга почти такая же (или чуть больше), как при 9,6 при отключенной графике. Иногда, особенно днем, GPRS-трафик полностью останавливается на неопределенное время (при сохранении связи). Единственный вариант в этом случае запускать закачку заново. И здесь пригодятся так называемые download-менеджеры, умеющие «докачивать» данные после разрыва связи. При долгом блуждании в сети здорово выручает низкое энергопотребление телефона даже в случае работы по ИК-порту. Кроме того, зарядка Li-Ion-аккумулятора у Timeport T260 проходит очень быстро. Даже если у вас ноутбук с инфракрасным портом, лучший выбор — связь по кабелю. Во-первых, отпадает необходимость точно позиционировать телефон напротив ИК-порта, что весьма проблематично в транспорте, во-вторых, не разрывая соединения с Internet возможно звонить и принимать звонки (попробуйте позвонить, оставляя телефон в зоне действия ИК-интерфейса).
Разумеется, были и сбои, о которых честно предупреждали в Би Лайн. Иногда телефон переставал высвечивать на экране индикацию GPRS. Помогало выключение-включение трубки. В некоторых местах Подмосковья, на карте отмеченных как зона уверенного GPRS-покрытия, невозможно выйти в сеть даже при наличии индикации GPRS (звонки проходят без проблем).
Но тем не менее мобильный Internet в паре с GPRS выглядит заманчиво, особенно если учесть заложенный потенциал в увеличении скорости передачи данных.


Необходимые настройки телефона в сети Би Лайн

Выбрать русский язык (Настройка телефона [image] Выбор языка).
Выбрать пункт «Доступ к Internet»
Войти в меню WAP (нажать и удержать кнопку Menu в течение 2 сек.)
Зайти в меню «Установка», выбрать любой из доступных профилей (по умолчанию — profile 1) и нажать клавишу «Настр».

Рекомендация
В дальнейшем название профиля возможно переименовать под свой вкус, например, «mobile i-net», главное, не забыть сделать его активным (клавиша «Sel»).

Пункт «Настройки WAP»:

Первичный IP: 192.168.017.001
Первичный порт: 9201
Вторичный IP: 192.168.017.001
Вторичный порт: 9200

Пункт «Передача данных» (ввести две независимых настройки для двух видов передачи данных GPRS и WAP)
Подпункт «GPRS» (настройка под работу в WAP через GPRS)

APN: wap.beeline.ru
Имя: beeline
Пароль: beeline
Время ожидания: 600

Подпункт «CSD» (Настройка под обычный WAP)

Телефон: 671
Имя пользователя: beeline
Пароль: beeline
Тип линии: модем
Время ожидания: 600


Настройки в программе GPRS Wizard

Через опцию File [image] New выбрать тип соединения телефона с компьютером (RS-232 или Infrared). Кстати, при первом запуске программа сама попросит заполнить этот пункт. После выбора жмем «Next».
Настройка параметров доступа к сети (Access Mode):

АРМ: internet.beeline.ru
Connection Name: любое слово по вашему выбору
User Name: beeline
Password: beeline

Рекомендация
Желательно отметить галочкой «Remember Password» — запомнить пароль, для того, чтобы не вводить его каждый раз при вызове соединения.

IP Address: Dynamic

Заходим в меню«Advanced:»
На вкладке TCP/IP отмечаем «Specify name Server address», заполняем:

Primary DNS: 194.67.2.114
Secondary DNS: 194.67.1.154

Остальные параметры оставляем как есть.

Во вкладке QOS Minimum все пять параметров устанавливаем в «Subscribed:»
Во вкладке QOS Requested нее пять параметров устанавливаем в «Subscribed:»
Жмем «Finish».
Далее все просто, подключаем телефон к компьютеру (через ИК-порт или кабель), запускаем GPRS Wizard и выбираем нужный тип соединения (щелкаем два раза по нужной пиктограммке). Следует отметить, что на данный момент распространены две версии фирменного программного обеспечения Motorola GPRS Wizard. В отличие от версии 1.0.0, вторая редакция этой программы позволяет вносить сразу все настройки соединения (в предыдущей версии имя пользователя, пароль и значения DNS необходимо было заводить в свойствах удаленного доступа в среде Windows), а также берет на себя функцию дозвона до провайдера. Хотя дозваниваться возможно и стандартным способом через «Удаленный доступ к сети».
Кроме приведенных выше значений DNS, существуют еще один вариант:

Primary DNS: 194.190.165.66
Secondary DNS: 194.190.192.34,

который тоже работает. Так как программа GPRS Wizard позволяет создавать несколько независимых типов соединений с различными параметрами (в том числе по кабелю или ИК-порту), то имеет смысл создать и сохранить оба варианта прописки Domain Name Service.


Необходимые настройки телефона в сети МТС

Меню [image] Доступ в Internet (нажмите и 2 секунды удерживайте кнопку «Menu»).
Меню [image] Настройка телефона [image] Настроить Internet [image] Настроить Profile [image] Настройки WAP

Первичный IP: 212.044.140.013
Первичный порт: 9201
Вторичный IP: 212.044.140.013
Вторичный порт: 9201
Время ожидания: 600

Нажмите «С» для выхода в меню верхнего уровня.
Передача данных [image] GPRS

АРМ: wap.mts.ru
Имя пользователя: mts
Пароль: mts

Дважды нажмите «С» для выхода в меню верхнего уровня и нажмите «Sel» для активации настроенного профиля [image] OK [image] Дважды нажмите «С» для выхода.


Настройка телефона и компьютера для доступа в Internet через GPRS

С компакт-диска, входящего в комплект поставки, установите на компьютер программу «Motorola GPRS wizard» и модем «Motorola Serial GPRS 56K». После установки запустите профамму «Motorola GPRS wizard» и создайте новое соединение: File [image] New. При соединении телефона и компьютера через инфракрасный порт выберите Communication Mode [image] Infrared. При соединении телефона и компьютера посредством кабеля, входящего в комплект поставки телефона, выберите Communication Mode [image] Serial RS232.
Нажмите Next.
В строке APN введите: internet.mts.ru.
В строке Connection Name введите любое имя, например:

MTS_GPRS.

В строках User Name и Password введите: mts.
Отметьте «галкой» Remember Password.

Нажмите кнопку Advanced и отметьте «галкой» Specify name Server address.
В строке Primary DNS введите: 213.087.000.001
В строке Secondary DNS введите: 213.087.001.001
Нажмите ОК.

Нажмите Finish.

Для установления соединения дважды нажмите на иконку с названием вашего соединения.

Далее следует отредактировать созданное удаленное соединение:

  • на вкладке «Общие» отключите «Использовать код страны и параметры связи»
  • В окне удаленного соединения в свойствах модема (кнопка «Настройка» в поле «Подключение») на вкладке «Подключение» нажмите кнопку «Дополнительно» и наберите в строке инициализации:

    AT+CGDCONT = 1,"IP","internet.mts.ru"

  • Сохраните введенные настройки модема
  • В свойствах удаленного соединения на вкладке «Тип сервера» установите:
    • тип сервера удаленного доступа: РРР: Internet. Windows NT Server, Windows 98/2000
    • уберите все «галки», за исключением TCP/IP в области «Допустимые сетевые протоколы»

  • нажмите кнопку «Настройка TCP/IP» и в появившемся окне установите следующие параметры:
    • Адрес IP назначается сервером
    • Адреса DNS вводятся вручную
    • Первичный адрес DNS: 213.087.000.001
    • Вторичный адрес DNS: 213.087.001.001
    • Включите «Использовать стандартный шлюз для удаленной сети»
    • Отключите «Использовать сжатие заголовков IP»

    • Сохраните введенные настройки


Настройки телефона Ericsson T39m в сети Би Лайн

Многофункциональный телефон Ericsson T39m поддерживает современные технологии связи, такие как GPRS и Bluetooth, имеет WAP-браузер и собственный почтовый клиент. Однако для полноценной реализации всех этих возможностей необходимо правильно их настроить. Помочь неискушенному пользователю должна приведенная ниже инструкция.


Передача данных через GPRS

  1. 1. Создаем учетную запись (аккаунт) для GPRS-доступа к данным: Menu [image] Settings [image] Data comm. Data accounts [image] Add accounts
  2. 2. Выбираем тип аккаунта Account type: GPRS data
  3. 3. Присваиваем ему имя (Name), например, «Beeline GPRS data»
  4. 4. Далее заводим стандартные настройки для GPRS в «Би Лайн»:
  6. АРМ: internet.beeline.ru
    User id: beeline
    Password: beeline
  8. 5. Сохраняем настройки (Save)
  9. 6. Далее заходим в созданный аккаунт и выбираем «редактировать» (Edit)
  10. 7. Заводим недостающие настройки:

  11. Password request: Off
    Allow calls: Automatic (это позволит принимать звонки при GPRS-сессиях)
    IP address: не заполняем (!)

  12. 8. Заходим в подменю Advanced settings

  13. Authentication: Normal
  14. Data compr.: Off
    Header compr.: Off

  15. 9. В подменю Quality of serv. все пункты выставляем в Subscribed
  16. 10. Возвращаемся в меню «Data comm.», заходим в подменю «Pref. service» и отмечаем «GPRS and GSM»

Проверяем, что созданный аккаунт имеет CID (Context Identification), равный 1.


WAP-браузер

  1. 1. Создаем учетную запись (аккаунт) для GPRS-доступа к WAP: Menu [image] Settings [image] Data comm. Data accounts [image] Add accounts
  2. 2. Выбираем тип аккаунта Account type: GPRS data
  3. 3. Присваиваем ему имя (Name), например, «Beeline WAP GPRS»
  4. 4. Далее заводим стандартные настройки для GPRS в «Би Лайн»:

  5. APN: wap.beeline.ru
    User id: beeline
    Password: beeline

  6. 5. Сохраняем настройки (Save)
  7. 6. Далее заходим в созданный аккаунт и выбираем «редактировать» (Edit)
  8. 7. Заводим недостающие настройки:

  9. Password request: Off
    Allow calls: Automatic (это позволит принимать звонки при GPRS-сессиях)
    IP address: не заполняем (!)

  10. 8. Заходим в подменю Advanced settings

  11. Authentification: Normal Data compr.: Off Header compr.: Off

  12. 9. В подменю     Quality of serv. все пункты выставляем в Subscribed
  13. 10. Возвращаемся в меню «Data comm.», заходим в подменю «Pref. service» и отмечаем «GPRS and GSM»

Созданный аккаунт необходим для функционирования WAP-браузера через GPRS.

  1. 1. Menu [image] WAP services [image] WAP settings
  2. 2. Выбираем любой профиль
  3. 3. Для удобства переименовываем его (Rename), например, «WAP в Beeline»
  4. 4. Устанавливаем домашнюю страницу (Chg homepage)

  5. Title: любое слово, например, Mobile Bee
    Address: wap.beeline.ru

  6. 5. Обязательно сохраняем установки (Save to): Current profile
  7. 6. Заходим в подменю Gateway
  8. 7. Далее заходим в меню IP settings

  9. Connect using:
  10. Внимание!
    Выбираем в открывшемся меню созданный ранее GPRS-аккаунт:
  11. IP address 192.168.017.001
    User id: beeline
    Password: beeline
    Data mode: Conn oriented
    Security: Off
    Show images: On (необходимо для показа графики в WAP-pecypcax, в противном случае ставьте "Off")
    Response timer: 150

  12. 8. Возвращаемся в меню «Gateway», выбираем подпункт «Change type» и отмечаем там опцию «IP»
  13. 9. Возвращаемся в меню «WAP services» и выбираем созданный профиль в качестве основного: «Select profile» [image] данный профиль.

Кроме того, возможно создать аккаунт для доступа к WAP-данным обычным способом, на скорости 9,6 кбит/сек (протокол CDS). Для этого:

  1. 1. Создаем новую учетную запись для GSM-доступа к данным: Menu [image] Settings [image] Data comm. Data accounts [image] Add accounts
  2. 2. Выбираем тип аккаунта Account type: GSM data
  3. 3. Присваиваем ему имя (Name), например, «Beeline GSM data»
  4. 4. Далее заводим стандартные настройки для GSM-данных в «Би Лайн»
  6. Phone no: 671
  7. User id: beeline
  8. Password: beeline
  10. 5. Сохраняем настройки (Save)
  11. 6. Далее заходим в созданный аккаунт и выбираем «редактировать» (Edit)
  12. 7. Заводим недостающие настройки:

  13. Password request: Off
    Data rate: 9,6 kbit/s
    Dial type: Analogue

Для работы WAP-браузера через CSD-протокол, необходимо в его настройках выбрать данный аккаунт:

  • Menu [image] WAP services [image] WAP settings [image] нужный профиль [image] Gateway [image] IP settings [image] Connect using + данный аккаунт;
  • либо отметить в этом же пункте опцию «Always ask». В этом случает Wap-браузер будет выдавать запрос, какой из созданных аккаунтов использовать для передачи данных.


Настройка ПК

Настройки персонального компьютера для установки Т39т в качестве GPRS-модема (на примере Microsoft Windows 98/Ме):

  1. 1. Вручную устанавливаем модем (Панель управления [image] Модемы [image] Добавить...)
  2. 2. Отмечаем «Выбрать тип модема вручную», далее «Установить с диска...»
  3. 3. Указываем системе inf-файл (erit39.inf), расположенный на комплектном CD-ROM.
    4. Выбираем нужный тип модемного интерфейса (Bluetooth, Cable или IR Modem).
    5. После того, как операционная система установит выбранный модем, заходим в папку «Удаленный доступ к сети» и создаем новое соединение с такими параметрами:

  4. Телефон: *99***#
    Имя пользователя: beeline
    Пароль: beeline

  5. 6. На вкладке «Сеть» отмечаем только ТСР/1Р-протокол (программное сжатие данных отключаем) и вводим в его настройках следующие значения:

  6. Адрес IP назначается сервером
    Значения DNS вводим вручную
    Первичный: 194.67.002.114
    Вторичный: 194.190.195.066
  8. Отключаем «Использовать сжатие заголовком IP»
    7. В настройках модема (Настройка [image] Подключение [image] Дополнительно) в строку инициализации заводим следующую строку:

  9. AT+CGDCONT=1,"IP","internet.beeline.ru">


Настройки почтового клиента T39m

Встроенный e-mail-клиент позволяет работать с корреспонденцией (писать и читать электронные письма) в режиме off-line. Соединение происходит только при приеме или отправке писем. Возможно два режима передачи данных — как с использованием GPRS, так и CSD.
Для корректной работы почтового клиента необходимо, чтобы ваш e-mail-сервер допускал сбор писем извне по протоколу РОРЗ или SMTP. Такой возможностью располагает всем известный сервер Mail.ru, поэтому приведенные ниже настройки будут рассматриваться на его примере.

  1. 1. Menu [image] Messages [image] Options [image] E-mail [image] Edit account [image] Add new?
  2. 2. Даем имя создаваемой учетной записи, например, «Почта с Mail.ru»
  3. 3. В подменю «Connect Using» выбираем необходимый Data account
  4. Внимание!
    Для работы почты и для использования телефона в качестве GPRS-модема необходимо предварительно создать спеииачьную учетную запись, где в качестве APN должно быть прописано:

    internet.beeline.ru
  5. Остальные настройки абсолютно такие же, как в описанном выше GPRS-аккаунте.
    4. Именно этот аккаунт (APN: internct.beeline.ru) выбираем для почтового клиента
  6. 5. Заносим данные для РОРЗ server (на примере Mail.ru):

  7. РОРЗ server: 194.067.023.077
  • Обратите внимание, что заносится именно IP-адрес сервера, а не «pop.mail.ru», как это указано в справочной информации на Mail.ru.

  • РОРЗ port:110
    Mailbox: ваш логин на Mail.ru
    Password: ваш пароль на Mail.ru
    STMP server: 194.067.023.077
    STMP port: 25
    E-mail address: ваш адрес на Mail.ru
    From name: указать, от кого будут сообщения
    Signature (подпись): либо без подписи (No Signature), либо использовать данные бизнес-карточки (Use bus. card), которую надо заполнить
  • 6. В подпункте «Check interval» возможно указать периодичность автоматической проверки приходящей почты или отключить данный режим
  • 7. Вернуться в меню «Options» и выбрать активный почтовый аккаунт (имеет смысл, когда таковых несколько) Для приема или отправки писем достаточно зайти в меню и выбрать там подпункты: Messages [image] E-mail [image] Send & receive.

Сам процесс получения почты довольно медлительный, несмотря на то, что соединение идет через GPRS-протокол. Телефон сначала пытается «достучаться» до удаленного почтового сервера, производит авторизацию, после чего начинает скачивать почту. Иногда процесс на долгое время «зависает», но даже если его прервать, часть почты все равно приходит (ее можно найти в подменю «Inbox»). Правда, поначалу скачиваются только заголовки писем (кому, от кого и тема письма). Телефон понимает и русские символы. Правда, иногда проблемы с кодировкой все же случаются и не только на кириллице. Более детальная информация о конкретном письме возможно получить, отметив нужное письмо. Далее телефон просто «докачает» выбранное письмо. Но и в этом случае, вы увидите только начало письма.
В заключение стоит отметить, что благодаря возможности создавать несколько Data Accounts в телефоне Ericsson T39m, имеет смысл заранее запрограммировать отдельные ак-каунты под различные нужды. К примеру, возможно создать сразу 4 учетные записи. Одна для WAP-браузера через GPRS-протокол (APN wap.beeline.ru), вторая для GPRS-доступа к Internet и почте (APN internet.beeline.ru). Третья — для «простого» WAP (CSD-протокол). Четвертая — для передачи данных на скорости 9,6 кбит/с (CSD-протокол).


Для доступа к WAP-сайтам через GPRS

Menu [image] Setup [image] Connectivity, поставить «галочку» напротив GPRS.
Menu [image] Surf & fun [image] Internet, выберите пункт Profiles и настройте любой из профилей:
Profile name — любое название
WAP parameters:

IP address: 212.044.140.013
Port: 9201
2nd address: 212.044.140.013
2nd port: 9201
Homepage: http://wap.mts.ru
Linger time: 300

Нажмите Save для сохранения настроек профиля. CSD settings:

Dial-up number: 0885
Call type: analogue
Login name: mts
Password: mts

Нажмите Save для сохранения настроек.
GPRS settings:

APN: wap.mts.ru
Login name: mts
Password: mts

Нажмите Save для сохранения настроек.


Настройка телефона и компьютера для доступа в Internet через GPRS

В телефоне в пункте Menu [image] Setup [image] Connectivity, поставить «галочку» напротив GPRS.
В телефоне в пункте Menu [image] Setup [image] Connectivity [image] Baud rate установите скорость 57.6 kb/s
С компакт диска из комплекта поставки телефона установите на компьютер драйвер модема через меню «Пуск» [image] «Панель управления» [image] «Модемы».
Нажмите кнопку «Добавить», отметьте «галочкой» «Выбрать тип модема вручную» [image] «Установить с диска» [image] «Обзор» и выберите CD-ROM, далее войдите в директорию «Software» [image] «gprs» и нажмите ОК. Далее нажмите ОК и выберите модем S45 (GPRS). Нажмите «Далее» и выберите порт (например, СОМ1) и нажмите «Далее». Нажмите «Готово».
Создайте новое удаленное соединение, укажите в качестве используемого модема ранее установленный модем S45 (GPRS) и введите номер телефона *99***1#
Далее следует отредактировать созданное удаленное соединение:

  • на вкладке «Общие» отключите «Использовать код страны и параметры связи»
  • В окне удаленного соединения в свойствах модема (кнопка «Настройка» в поле «Подключение») на вкладке «Подключение» нажмите кнопку «Дополнительно» и наберите в строке инициализации:
  • AT+CGDCONT = 1,"IP"."internet.mts.ru"
  • Сохраните введенные настройки модема
  • В свойствах удаленного соединения на вкладке «Тип сервера» установите:
    • тип сервера удаленного доступа: РРР: Internet, Windows NT Server, Windows 98/2000
    • уберите все «галки», за исключением TCP/IP в области «Допустимые сетевые протоколы»
  • нажмите кнопку «Настройка TCP/IP» и в появившемся окне установите следующие параметры:
    • Адрес IP назначается сервером
    • Адреса DNS вводятся вручную
    • Первичный адрес DNS: 213.087.000.001
    • Вторичный адрес DNS: 213.087.001.001
    • Включите «Использовать стандартный шлюз для удаленной сети»
    • Отключите «Использовать сжатие заголовков IP»
  • Сохраните введенные настройки


Для доступа к WAP-сайтам через GPRS

Menu [image] Services [image] Settings [image] Active service settings (выберите один из профилей и активируйте его).
Menu [image] Services [image] Settings [image] Edit active service settings, настройте выбранный вариант профиля:

Settings name: любое название
Homepage: http://wap.mts.ru
Session mode: Permanent
Connection security: Off
Data bearer: GPRS
GPRS connection: Always online (attach в
систему GPRS происходит при включении телефона) или When needed (attach в
систему GPRS происходит по необходимости)
GPRS access point: wap.mts.ru
IP address: 212.044.140.013
Authentication type: Normal
Login type: Automatic
User name: mts
Password: mts (ввести и подтвердить)


Настройка телефона и компьютера для доступа в Internet через GPRS

В телефоне в пункте Menu [image] Settings [image] GPRS modem settings [image] Active access point выберите для настройки один из вариантов, например Access point 2
Menu [image] Settings [image] GPRS modem settings [image] Edit active access point

GPRS access point: internet.mts.ru

С сервера http://www.nokia.com/ скачайте Modem setup (2,65 Мб) и установите его на компьютер, при этом указав для подключения ИК-порт (IrDA)
В компьютере создайте новое удаленное соединение и укажите модем «Nokia 8310». который будет использоваться при работе через это удаленное соединение и введите номер *99#
Далее следует отредактировать созданное удаленное соединение:

  • на вкладке «Общие» отключите «Использовать код страны и параметры связи»
  • В окне удаленного соединения в свойствах модема (кнопка «Настройка» в поле «Подключение») на вкладке «Подключение» нажмите кнопку «Дополнительно» и наберите в строке инициализации:
  • AT+CGDCONT = 1, "IP", "internet.nits, ru"
  • Сохраните введенные настройки модема
  • В свойствах удаленного соединения на вкладке «Тип сервера» установите:
    • тип сервера удаленного доступа: РРР: Internet, Windows NT Server, Windows 98/2000
    • уберите все «галки», за исключением TCP/IP в области «Допустимые сетевые протоколы»
  • нажмите кнопку «Настройка TCP/IP» и в появившемся окне установите следующие параметры:
    • Адрес IP назначается сервером
    • Адреса DNS вводятся вручную
    • Первичный адрес DNS: 213.087.000.001
    • Вторичный адрес DNS: 213.087.001.001
    • Включите «Использовать стандартный шлюз для удаленной сети»
    • Отключите «Использовать сжатие заголовков IP»
    • Сохраните введенные настройки


Первые личные впечатления от работы с GPRS

Как известно, надежд на «пакетную передачу данных по радиосетям», сиречь GPRS возлагалось немало. В теории, при использовании GPRS достижима скорость 171,2 Кбит/с — в разы больше, чем даже на современных модемах. На практике, как выяснилось, такой прелести нету, жизнь внесла свои коррективы.
Итак, впечатления от работы с GPRS в реальной жизни.

Исходные данные

Подключение к Beeline GSM, Motorola Timeport 260 (он же Timeport 7389i), несколько «терминалов» — ноутбук, Psion Series 5mx, HP Jornada 720, Palm Illc и Compaq iPAQ PocketPC 3660.
Motorola T260 относится к классу В — звонки «не теряет», но одновременно разговаривать и работать в Internet не дает.

Настройки

Сложилось устойчивое впечатление, что в сети Beeline GSM возможно работать, не вводя строку инициализации модема, которая устанавливает на минимум «качество сервиса» и определяет так называемую Access Point Name. Но на всякий случай...
Первая, задает минимальное качество сервиса...

AT+CGQMIN=1,1,1,1,1.1

Вторая, определяет APN (у этой команды есть еще несколько параметров, но их возможно пропустить):

AT+CGDCONT=1,"IP", "APN"

где IP — строка IP (с кавычками); APN — название точки доступа (с кавычками), в нашем случае, «internet.beeline.ru».
Кроме того, что при наличии проблем, возможно попробовать «раскочегарить» Motorola T260, подключив его к ПК, соединившись с сетью GPRS, а затем отключив его и подсоединив уже к машинке (помогают также пляски с бубном вокруг телефона).
Для подключения к сети GPRS используется номер «псевдотелефона» *99# — с точки зрения любого ПК (и ручного и настольного), для соединения с сетью GPRS необходимо позвонить на «псевдотелефон».


Ноутбук

Подключение ноутбука (или любого ПК с Windows, независимо от версии, от Windows 95 до Windows 2000) проблем не предполагает. В комплект поставки Motorola Timeport 260 (по крайней мере, это было у телефона, который мы исследовали) входит коммуникационный кабель (при наличии в ноутбуке инфракрасного порта, телефон возможно подключить и с помощью него), компакт-диск с программой GPRS Wizard и руководство по настройке. Достаточно инсталлировать и запустить программу GPRS Wizard, заполнить параметры конфигурации в диалоге создания нового «подключения» и дважды кликнуть на пиктограмме этого «подключения». Процедура запуска «GPRS-модема» в работу занимает около 15 с (собственно, на «коннект» нужна примерно 1 с, однако, GPRS Wizard долго инициализирует трубку), после чего возможно работать (для отключения необходимо еще раз активировать пиктограмму подключения). Единственная оговорка — при подключении телефона к кабелю он должен быть выключен, потом его, естественно, нужно включить.


Psion

Подключение Psion — задача не во всем тривиальная. Дело в том, что у Motorola T260 имеются некоторые технические особенности, которые осложняют TCP/IP стеку «общение» с этим телефоном. Проблемы решаются посредством программы gprsroute или GPRS Helper (от PsiNT — правда, программа кривая неимоверно, только и разница, что красиво запускается из панели управления). Создаем новый «профиль» нового модема в панели управления Psion, в котором надо указать скорость связи как 57,6 Кбит/с, строку инициализации AT&FO, использование программной коррекции ошибок (пункт Software XON/XOFF пкладки Anvanced), отключить параметры Terminal Detect (DSR/DTR) и Carrier Detect (DCD), тип модема необходимо задать как Mobile. В панели настройки Internet необходимо заполнить поля адресов сервера DNS (информация имеется в руководстве по настройке доступа с ПК) и задать имя пользователя и пароль (и то и другое — слово beeline).
После этого, достаточно набрать и строке ввода адрес Web-сайта, для того, чтобы на экране появился диалог подключения. При этом, на экране телефона появится надпись «Соединение» и строка, например, «171.20.12.228» (это адрес, который назначен телефону, обычно от сеанса к сеансу он меняется). В этот момент на экране обычно появляется диалог о невозможности связаться с заданным сайтом — это следствие тех самых особенностей Motorola Timeport 260. Проблема решается просто — переключаемся в окно System (оранжевая пиктограмма в левом нижнем углу экрана) и запускаем программу gprsroute (это надо проделывать при каждом подключении; кончилось тем, что мы создали специальную макрокоманду, которая автоматически запускала эту программу при надобности). Она выдает сообщение, что работает корректно, после чего браузер уже может подключиться к сайту и работать с ним. Да, пользователям Psion Series 5mx нужно поставить Mobile Connectivity Software (качается с Psion.com).


Pocket PC

Настройка Pocket PC и НРС 2000 требует создания нового «подключения» (Connection), в котором необходимо задать скорость связи 56 Кбит/с, заполнить поля адреса сервера DNS (информация есть в руководстве по настройке ПК), задать номер «псевдотелефона» GPRS, имя пользователя и пароль (beeline). Кроме того, в строке инициализации модема рекомендуется задать строку:

+cdgcont=1,"IP","internet.beeline.ru"

(без пробелов), правда, наши эксперименты показали, что в сети Beeline GSM ее использовать не обязательно, по крайней мере, у нас телефон прекрасно подключался и без нее. Однако, в случае каких-либо проблем имеет смысл попробовать задать эту строку. В случае, если вы соединяете телефон и PocketPC с помощью инфракрасного порта, то необходимо активировать «программное управление потоком» (XON/XOFF) и снять отметку с пункта «ждать сигнала в линии». Да, не забывайте, что нельзя удалять букву G из шаблонов набора номера.


Palm

Процедура настройки в принципе мало, чем отличается от процедуры подключения PocketPC. Создаем новый «профиль» модема (называем его, например, GPRS), с параметрами Connection Method — iRCOMM to PC, на вкладке Details задаем скорость соединения 57,6 Кбит/с, отключаем управление потоком на Palm. В панели управления Networks вводим имя пользователя и пароль (beeline), заполняем поля адреса сервера DNS (из документации по настройке ПК). Теперь нужно кликнуть по кнопке Script и ввести сценарий регистрации:

Send: atz
Send CR
Send at+cgdcont=1, "IP","internet.beeline.ru"
Send CR
Send: atd*99#
Send CR
End

Как и в случае, с Psion/Pocket PC, строку at+cgd-cont=1,"lP","internet.beeline.ru" можно не вводить, ограничившись atz. После нажатия кнопки Connect Palm подключается к сети.

Добавление
 Найдено еще одно магическое действие, которое иногда помогает подключиться к сети GPRS при использовании Psion и Palm. В случае сообщений об ошибке, связанной с появлением сигнала «занято», рекомендуется зайти в терминальную программу, инициализировать трубку atz, набрать номер (aid *99#), когда на экране появятся символы CONNECT и запросы РРР (характерный «мусор»), подождать 10 с, после чего ввести +++ (перейти в режим команд) и АТН (повесить трубку). Если вместо коннекта появляется BUSY — ждем 10 с, после чего процесс повторяем. Как правило, помогает. И небольшая полудокументированная возможность, которая позволяет на Palm отслеживать работу сценария — перед нажатием экранной кнопки Connect, нажимаем и удерживаем кнопку «стрелка вниз». В окне набора номера на Palm будут отображаться передаваемые модему строки.


Результаты

Меньше всего проблем было с ноутбуком — сказывается наличие специальных программ, из ручных ПК наиболее «стабильным» оказался Psion (создавалось ощущение — машинка «поупрямилась», но привыкла и работала без проблем), наиболее капризным — Palm.
В сети Beeline GSM услуги GPRS — вторичны, то есть, когда в сети ощущается недостаток каналов для связи, то она начинает отключать абонентов GPRS (с этим связаны периодические «затыки» в работе). Не стоит удивляться, если какие-то попытки подключиться окажутся безуспешными — надо просто попробовать еще раз.
Скорость связи в реальной жизни весьма сильно зависит от нагрузки, которая приходится на конкретную соту. Как показала практика, «средняя скорость связи» — параметр мало что говорящий о качестве связи при работе с GPRS в том виде, в каком он существует сейчас. В принципе, если все-таки давать цифры, то можно сказать, что «средняя скорость» связи составила примерно 9,6 Кбит/с, причем, с очень большим разбросом — то ничего-ничего-ничего (10-12 байт/с) то «полсайта» разом (20 Кбайт/с). Но вообще, «скоростные» оценки GPRS, повторимся, пока бессмысленны — скорость целиком и полностью зависит от места и времени. Наличие неподалеку (в пределах действия соты) людей, разговаривающих по сотовому телефону, может печально сказаться на скорости связи
Кроме того, в текущей реализации, GPRS — технология, определенно ориентированная не на передачу крупных файлов, а на работу с множеством мелких. Небольшие файлы (из которых, например, состоит любой Web-сайт) «проскакивают» существенно быстрее, с крупными файлами мы неоднократно наблюдали картину — файл «качается» и вдруг на полпути «замирает». Это означает, например, что передача крупных файлов электронной почты или потокового видео может быть менее стабильной, нежели при работе в «традиционном» для GSM режиме (для этого, кстати, больше подходит технология HSCSD). Правда, по ходу испытаний мы заметили, что в случае «затыка» очень полезно «подергать» в соседнем окне браузера канал связи, попытавшись открыть, например, какой-нибудь сайт — процесс «оживает». На практике это означает, что если с «мылом» и FTP, обычно есть проблемы, то сайты «летают».
С другой стороны, плюсы у GPRS есть тоже и плюсы несомненные. Например, подключается машинка практически моментально, в пределах 5 с (даже с учетом времени, которое нужно, например, на Psion для запуска коммуникационных программ). Простой подсчет показывает, что если вы, допустим, два раза в день подключаетесь к сотовому Internet, для того, чтобы проверить почту, то (предположим, идеальный случай — на подключение тратится примерно 30 с) за месяц будет сэкономлено 30 минут. И вообще, при отсутствии этой раздражающей паузы работать намного комфортнее.
Другой плюс — принцип «помегабайтной» оплаты. Пока непонятно, какие расценки выдадут на-гора наши операторы, но в целом, есть основания полагать, что пользователям, которые много работают с сотовым Internet, будет выгодно использовать GPRS. Правда, тут уже придется учитывать, что каждая лишняя картинка будет стоить вам уже вполне определенную сумму, и тем, кто использует ноутбуки придется придумывать, как же уменьшить количество информации на часто посещаемых ими сайтах (например, отключать загрузку картинок) и искать почтовую программу, которая позволила бы заранее отсеивать ненужные письма, «скачивая» только те, которые действительно необходимы. Пользователям, которые работают с ручными ПК, будет несколько проще — там средства, которые позволяют игнорировать ненужную информацию, обычно предусматриваются изначально, например, все почтовые программы для всех платформ предоставляют возможность просмотреть только заголовки писем и выбрать конкретные.


Будущее без проводов - GPRS сегодня и завтра

Технология GPRS — это система пакетной передачи данных по сети сотовой связи GSM. Что же она нам дает?
Сначала отдадим должное заезженным штампам...
Мир будущего будет мобильным. Он будет мобильным во всех отношениях, особенно в информационном. Случись где какая неприятность, мы узнаем об этом мгновенно — гораздо быстрей, чем узнаем сегодня, по вещательным каналам или посредством прессы.
Информация давно стала ходовым товаром, но в наши дни она превращается в необходимое условие нормальной жизнедеятельности. Огромное количество людей по всему миру зарабатывают деньги вне стен конторы. Работа дома, работа в пути, работа по пути из дома на работу... Со временем этот кошмар станет повсеместным, и многие из привычных сегодня вещей изменятся до неузнаваемости. Например, деньги. Их, скорее всего, не будет вовсе - в смысле, наличных. Будут электронные деньги (которых полно и сегодня - в виде платежных банковских карт), будут еще более электронные деньги (для расчетов через Internet сама карта не нужна, нужен банковский счет и его реквизиты), будет виртуальный эквивалент денег, не имеющий физического аналога (все богатство в сотовом телефоне - с ума сойти).
Так вот, мир будущего будет мобильным, и это славно... Только как быть нам сегодняшним? Хочется же еще пожить, причем не откладывая, не заглядывая с завистью за горизонт.
В принципе, мы уже и так мобильны до невозможности. Голосовая беспроводная связь доступна любому, кто имеет хоть какие-то деньги... Не совсем так - чем дальше от Садового кольца, тем меньше беспроводной связи по причине уменьшения количества тех, кто имеет деньги. В некоторых деревнях наших северных и восточных областей люди и обычного-то телефона не видели, не то что сотового. Но это совсем другая тема...
До недавнего времени, когда сотовый телефон и России еще «устаканивался». сбрасывая фальшивые белые одежды дорогой игрушки и облачаясь в потертую спецовку труженика, наша мобильность ограничивалась возможностью переговорить но телефону прямо на бегу. О какой-либо серьезной работе, кроме сердитых ценных указаний или торопливых переговоров по мелочам, и речи не было.
Нет, «мобильный Internet» был, есть и будет. Можно прямо с телефона (вглядываться в серенький экран в попытке разобрать - чего это там транслитом обозначено), возможно посредством телефона с карманного компьютера, возможно с ноутбука. Но - скорости. 9,6 Кбит в секунду - это не доступ. Это только в WAP-e анекдоты почитать.
«Мобильный Internet», равно как и «мобильный офис» (офис в кармане, на ладони, подмышкой и так далее) — пустой звук до тех самых пор, пока он не будет обеспечен высокоскоростной, надежной и дешевой беспроводной связью...
Совсем недавно крупнейшие операторы сотовой связи в России ввели в действие сервис, который мы с нетерпением ждали — услуги GPRS. И с этого времени наша жизнь и в самом деле стала мобильной. То есть - может стать, если мы оценим возможности GPRS, а операторы не будут лениться развивать эту замечательную технологию.
После пышного вступления немного технической информации. GPRS — General Packet Radio Service - это система пакетной передачи данных по сети сотовой связи GSM. Она увеличивает скорость обмена информации по беспроводным сетям, не перегружает каналы связи и при этом является очень дешевым каналом для передачи данных.
Сразу вопрос - насколько дешевым? Представьте себе, дешевле любых иных доступных сегодня беспроводных каналов связи. Если идея связистов перевода фиксированных телефонных линий на повременную оплату воплотится в жизнь, для многих из нас GPRS станет реальной альтернативой проводному доступу к Глобальной сети - разница в стоимости окажется ничтожной...
Как такое может быть? Разве пользователь GPRS не оплачивает время соединения? Разве операторы сотовой связи пойдут на введение специальных расценок для пользователей Internet? Для операторов - чистое разорение.
Но в том-то и дело, что за передачу или прием данных посредством GPRS нам придется оплачивать не общее время соединения, а только время потраченное на обмен информацией, а с развитием сервиса - только трафик. Секрет - в технологии GPRS. Этот протокол использует для передачи данных свободные каналы, отдавая приоритет голосовой связи. Причем, передача данных ведется пакетами сразу по нескольким (числом до семи, хотя пока используется меньшее количество) свободным каналам.
Этот процесс выглядит следующим образом. Дозвонившись до оператора и запустив на коммуникаторе, смартфоне, карманном или портативном компьютере браузер или почтовую программу, мы посылаем запрос на отправку или получение информации. Базовая станция принимает запрос, формирует из массива данных порции информации - пакеты, ищет свободные каналы связи и осуществляет передачу в параллельном режиме. Если скорость передачи данных по одному каналу не превышает 14 Кбит/с (обычный на сегодняшний день показатель), то с применением технологии GPRS скорость обмена возрастает вдвое, втрое и так далее (до семи раз) - в зависимости от числа используемых каналов. Одновременно базовая станция преобразует данные из форматов GSM в форматы, которые используются TCP/IP для обмена данными в Internet.
Скорость передачи (то есть количество каналов, по которым идет обмен) величина не постоянная. Чем больше загрузка сети, тем скорость обмена меньше, поскольку и свободных от передачи голосовых данных каналов тоже меньше. Зато в более-менее свободное время (ночью или ранним утром) скорость обмена увеличивается — благодаря одновременному использованию большего количества свободных каналов..
Одно из преимуществ технологии GPRS, которое трудно переоценить, это отсутствие перегрузки обычных каналов, используемых для передачи голосовых данных (проще говоря — для телефонных переговоров) даже при большом трафике беспроводных соединений с Internet. Телефоны, коммуникаторы и смартфоны, имеющие полную поддержку GPRS на аппаратном уровне, позволяют вести телефонный разговор и подключаться к Internet одновременно. При этом никто не ощущает дискомфорта - данные передаются исключительно по свободным каналам. А если кому-то «не хватает в эфире места», канал, по которому ведется передача данных, немедленно освобождается для голосовой связи. И базовая станция тут же ищет другой свободный канал.
Впрочем, на это способен только самый совершенный (и, вероятно, самый дорогой) класс аппаратуры связи - так называемый класс А терминалов GPRS. Только он позволяет одновременно поддерживать голосовую связь и вести обмен данными.
Более демократичный тип терминалов GPRS — класс В - «умеет» работать в голосовом и терминальном режиме поочередно. То есть во время соединения с Глобальной сетью голосовые, сугубо телефонные функции устройства недоступны. Именно к этому классу относятся самые массовые модели телефонов с поддержкой GPRS.
Третий тип — класс С — это присоединяемые устройства для ноутбуков или карманных компьютеров. Они выполнены в виде модулей сотовой связи с поддержкой GPRS. Формат модулей — карты PC card или CompactFlash (в принципе, возможны устройства в формате любых карт памяти или просто подключаемые к портам компьютера). Подобный модуль превращает КПК или ноутбук в мощный инструмент беспроводной связи.
Чаще всего используется комбинация сотового телефона, относящегося к классу В, и ноутбука. Связь между телефоном и компьютером осуществляется посредством инфракрасного порта или интерфейсного кабеля RS-232. Последний применяется чаще, поскольку на практике оказывается надежней - инфракрасная связь подвержена помехам.
Реже применяется тандем из сотового телефона и карманного компьютера. Дело опять же в практике. КПК только на словах удобен для просмотра web-страниц. Маленький экран вынуждает пользователя без конца передвигать экранные полосы прокрутки, либо до предела уменьшать масштаб отображения страницы в браузере. А отсутствие емких накопителей не позволяет сохранять на КПК сколько-нибудь значительные объемы информации... Но звучит привлекательно — «весь мир в кармане». Разве нет?
И все же самыми соблазнительными выглядят смартфоны - компьютеризированные сотовые телефоны со встроенными почтовыми клиентами и средствами просмотра WAP-pесурсов. Кроме того, что они являются беспроводными модемами для подключения настольного компьютера, ноутбука или КПК к Internet, они способны работать с сетевыми ресурсами самостоятельно — хотя бы принять и отослать электронную почту, что очень и очень немало.
Совершенно ясно, что мы находимся в самом начале большого пути. Что пока технология GPRS живет больше на словах, чем на деле. Об этом свидетельствует небольшое количество клиентов, которые используют прелести GPRS хоть в какой-то мере... Но количество это растет пугающими темпами! В разы, в десятки раз и день ото дня...
Это не утверждение, а гипотеза, лишь отчасти подкрепленная фактами. Что же мешает повсеместному распространению GPRS?
Во-первых, не вполне четкие перспективы замечательной технологии. Сотовые операторы не спешат вкладывать большие средства на переоборудование базовых станций, не имея ясного представления о возможном спросе на услуги беспроводной передачи данных.
Отчасти проблема решилась скандалами с повременной оплатой разговоров по проводным линиям. В регионах под это дело провайдеры поспешили до предела снизить цены на подключение к Internet. Сегодня самый дешевый Internet надо искать не в Москве, а где-нибудь в Воронеже или в Вологде.
Сотовые операторы, проведя приблизительные расчеты, пришли к выводу - беспроводной доступ в Internet с использованием GPRS может стоить не дороже проводного доступа — в случае ввода повременной оплаты за пользование фиксиро-
ванными каналами связи, разумеется. Более того, при достаточно широком распространении GPRS появляется возможность снизить цены (лучше получить по рублю с миллиона пользователей, чем миллион с кучки каких-нибудь нуворишей)... Представляете, в некоторых развитых странах (например, в Японии) беспроводной доступ уже дешевле, чем проводной! Прибавьте к этому удобства мобильного доступа - возможность проверить почту прямо в машине или во время прогулки...
Вторая причина (возвращаемся к вышеозначенному перечислению) сдерживания распространения GPRS кому-то может показаться спорной. Это мое личное предположение, но мне кажется, что оно не особенно искажает истинное положение вещей... Речь о сложностях настройки GPRS. Технология очень удобная — в работе. Но для того, чтобы правильно настроить телефон и компьютер, придется заглянуть на сайт оператора и ознакомиться с «ничего себе» инструкцией...
Не вполне прямая параллель - с введением компании Би Лайн новой услуги «beeinfo». Это электронный справочник в меню сотового телефона. То есть в меню аппарата при его включении из памяти SIM-карты переписываются заранее внесенные туда номера сервисных служб. Информационные услуги - прогноз погоды, курс валют, иная справочная информация (наличие билетов в театрах, гороскоп, адреса организаций и многое, многое другое) - предоставляются в виде сообщений SMS, которые приходят на телефон пользователя. Но при этом не надо помнить или вносить в книжку телефона список номеров, по которым можно получить информационную услугу. Эти номера вписаны в меню телефона в виде текстовых, четко обозначенных и удобно читаемых пунктов - «Анекдоты», «Афоризмы», «Праздники»... То же самое без каких-либо затрат доступно всем абонентам Би Лайн. Только для выбора услуги (кстати, в большинстве далеко не бесплатной) надо открыть специальную справочную книжицу, прилагаемую к каждому телефону, и набрать соответствующий номер. Вот и все.
Знаете, это замечательный маркетинговый ход - приблизить свой товар (в данном случае - услугу) к потребителю, сделать ее простой, понятной и удобной для использования.
Есть ли время у домохозяйки или под завязку загруженного работой делового человека играться с этими юроскопами (в смысле - с настройками, набором номера, его запоминанием в адресной книжке телефона)? А если этот гороскоп всего лишь экранная кнопочка с русской надписью — почему бы и нет?
Примерно то же самое должно произойти и с сервисом GPRS. Автоматическая или, как минимум, предельно упрощенная настройка телефона, сопровождаемая бумажным комиксом (как у японцев, снабжающих сложную электронику руководством «для младенцев»), а еще лучше - всплывающей экранной подсказкой. И на коробке с телефоном написать: «Эта штука умеет подключаться к Internet и получать-отправлять электронную почту, не снимая с вас последних штанов». Успех практически гарантирован. Без особой помпы, но зато верный...
Третья по значимости причина - технического плана. Для эффективного использования GPRS сегодняшних скоростей обмена по каналам GSM явно недостаточно. Отсюда первая задача - увеличение скоростей обмена. Вторая задача -улучшение технологией параллельной передачи пакетов данных по свободным каналам, то есть увеличение числа одновременно задействованных каналов. И то, и другое задачи реальные и вполне решаемые. Можно с уверенностью сказать - будет услуга востребованной, будет и все остальное.
Мы говорим о GPRS, как о чем-то малодоступном. Между тем, воспользоваться этой прелестью возможно уже сегодня — достаточно заглянуть на сайты московских операторов или посетить ближайшую телефонную лавку (сколько же их в столице).
Правда, нужен соответствующий аппарат... Тоже, в общем-то, не проблема. Выбирая новый телефон, мы обращаем внимание на перечень его сервисных функций. Ну, там WAP, электронная почта, органайзер... А смотреть надо на наличие поддержки GPRS! Тогда все остальное попросту прилагается. (Какой GPRS без почты и браузера?)
Описания сегодняшних моделей, по причине их многочисленности, опустим.
Лучше подумаем - чего бы хотелось. Что появится и магазинах в ближайшее время и что именно следует выбирать.
Здесь много вкусовщины. Кому-то нравятся аппараты необычные — со встроенными QWERTY-клавиатурам и или с плейерами МРЗ. Кто-то предпочитает сверхзащищенные телефоны, которые хоть оземь, хоть об стенку — все равно работают. А кто-то выберет аппарат с большим экраном — чтобы не щуриться, словно ослепшая курочка.
Мне нравятся аппараты надежные (а кому они не нравятся?) и многофункциональные. Не вижу большого смысла в применении карманного компьютера, будь у меня многофункциональный коммуникатор. Но при этом он должен быть небольшим по размерам, как сотовый телефон, и с возможностью синхронизации с ноутбуком - причем, не только для обновлений телефонной книжки...
Появись, скажем, телефон с экраном Panasonic GD95, с РОРЗ и SMTP почтовым клиентом (в Panasonic уже есть), с инфракрасным, а еще лучше с Bluetooth портом, да еще и... с «читалочкой» для электронных книг, я бы не задумываясь избавился от своей карманной машинки и носил бы в кармане исключительно этот аппарат.
Но это я (кто угодно, но только не пример для подражания). Другим пользователям нужны от своего телефона иные возможности. К примеру, встроенный фотоаппарат, цветной экран, большой объем памяти, тот же плейер МРЗ...
Обилие новых моделей с перечисленными функциями — заслуга развивающихся стандартов сотовой связи, в том числе и GPRS. В самом деле, что за прок от встроенного цифрового фотоаппарата, если снимок с него невозможно переслать по радиоканалу связи своему респонденту или самому себе - на компьютер? Но пересылка посредством обычного подключения способна разорить кого угодно (и вымотать нервы затяжным ожиданием конца сеанса передачи). Потому-то и смотрели мы на новые аппараты больше с теоретической точки зрения, чем с практической. Теперь можем не только смотреть, но и прицениться — благодаря внедрению GPRS.
Что касается карманных компьютеров в их классическом виде, то тут будущее за гибридными устройствами — за коммуникаторами. Хоть и невелик экран КПК, но он в разы больше, чем дисплей телефона. Хоть и удобны в применении современные сотовые телефоны, но возможность загрузки и запуска на коммуникаторе компьютерных программ великое дело. Как настроить телефон под свои потребности? Как воспользоваться его немалыми вычислительными возможностями (а в каждом сотовом телефоне живет очень даже неплохой компьютер), если нужных программ в его постоянной памяти нет?
Не такой уж пустяк. Вспомните, как мы (те из нас, у кого старые и совсем уж простенькие телефоны) с завистью заглядываемся на владельцев аппаратов со встроенным календарем и многофункциональным органайзером... Карманный компьютер — штука необязательная, мы начинаем активно пользоваться им только привыкнув, «подсев» на эту занимательную штучку (кстати, происходит очень быстро). А сотовый телефон всегда рядом. Без него, как без рук...
Отсюда - еще одно предположение. Брать надо аппарат с большими потенциальными возможностями. Органайзер -это мелочи. Но инфракрасный порт и встроенный модем, поддержка GPRS, браузер WAP (вот уж необязательно) и почтовый клиент (а это — наоборот) очень желательны. Сегодня беспроводной доступ к ресурсам Internet кажется нам баловством, а завтра может оказаться так, что мы побежим в магазин в надежде поменять телефон на что-нибудь «GPRS-ное»...
Теперь можно присмотреться к витринам сотовых магазинов. Есть из чего выбрать, да?
В России при всех перипетиях новейшей истории сложилась уникальная ситуация. Нам нечего модернизировать, все приходится строить заново. Мы не отягощены грузом устаревших технологий (за их полным отсутствием). Это дает надежду на то, что самые последние достижения в области техники связи появятся у нас едва ли ни быстрей, чем за океаном.
В принципе, так и происходит. Мы догоняем запад в плане внедрения высокоскоростных протоколов обмена данными. Значит, не за горами и аппараты нового поколения — с возможностями обмена мультимедийными данными, просмот-
pa на дисплеях своих телефонов видеофильмов и прослушивания посредством высококачественных гарнитур хорошей музыки.
Скажете - фантастика? Пока - да. Но дайте время...
Вчера сотовый телефон был только у начальника и очень зажиточного коммерсанта. Сегодня сотовый телефон лежит в авоське рядовою обывателя — рядом с редиской и утренней газетой. Кого удивишь этой когда-то престижной штукой?
На широкое внедрение сотовых сетей связи нам понадобилось около пяти лет. Сколько времени понадобится для широкого внедрения GPRS?
И еще... Представляю, какими слезами зарыдают инициаторы перевода фиксированных телефонных линий на по-временку. Вероятно, такими же, какими рыдали почтовики, пристрелившие в начале девяностых свою дойную корову - систему доставки подписчикам периодических изданий.
Интересно - повторится ли эта история?


GPRS: плюсы и минусы этого сервиса

GPRS — дополнительный опциональный сервис в GSM-сетях, который позволяет обладателям сотовых телефонов с поддержкой GPRS получать доступ к ресурсам сети со скоростью до 171,2 Кбит/с и при этом платить только за объем переданных данных, а не за время, проведенное на линии. О GPRS активно заговорили в 2000 году, а летом 2001-го GPRS стал реальностью — был запушен в коммерческую эксплуатацию соответствующий сервис в сети «БиЛайн GSM». Что же произошло с тех пор?
Много всего, как положительного, так и отрицательного.

Заработал GPRS-роуминг

Пока GPRS-роуминг работает между несколькими операторами, большинство которых находится в Скандинавии, наиболее продвинутой в отношении всеобщей «мобилизации».
Но сам факт запуска такого сервиса весьма важен.
Теоретически выход к интернет-ресурсам для роумеров посредством мобильного телефона был доступен давно. Но практически низкие скорости работы в сочетании с высокими расценками за минуту пребывания в онлайне делали этот сервис неактуальным. Пользовались им либо люди с очень толстыми кошельками, либо бедняги, застигнутые в чужом городе острой необходимостью немедленно получить доступ к Сети. Все прочие роумеры предпочитали использовать для посещения сетевых ресурсов интернет-кафе, которые сейчас есть практически в каждом сколько-нибудь значительном населенном пункте, да и в каждом районе крупного города.
Доступность GPRS в роуминге позволит роумерам в любое время и в любом месте получать доступ к сетевым ресурсам с приличной скоростью и по разумной цене. Очевидно, что человеку, для которого активное @-общение есть необходимая составляющая образа жизни, удобнее получать доступ к Сети в любом месте, а не искать для этой цели интернет-кафе, которое, кстати, в чужом городе найти не так уж и просто.

Новые региональные сети — GPRS-ready

Новые сети, которые все три национальных оператора - «БиЛайн», МТС и «Мегафон» с North-West GSM — разворачивают в рамках своей региональной экспансии над российскими городами и весями, в основном строятся «с нуля». Не всегда приходящему в регион национальному оператору удается купить локальную компанию и тем самым закрепиться на новой территории. Чаще приходится разворачивать новую сеть, используя для ее создания базовые станции, в которых поддержка GPRS уже реализована. Соответственно, сеть получается «GPRS-ready», то есть готовая к запуску нового сервиса, который надо только включить.
GPRS может предоставлять связь куда более быструю и стабильную, чем обеспечивает телефонная линия.
Любая другая альтернатива для dial-up-соединения - выделенная линия, ASDL, спутниковый доступ или доступ по каналам кабельного телевидения — для индивидуального пользователя уже оказывается заметно дороже и по этой причине
недоступна даже большинству столичных пользователей, не говоря уже о менее обеспеченных жителях регионов.
Не надо забывать, что и с обычном телефонизацией в регионах дело обстоит заметно хуже, чем в столицах, так что для многих региональных пользователей GPRS является не только оптимальным средством для обеспечения доступа в Internet с домашних компьютеров, а просто единственным средством.

Реальная скорость работы GPRS ниже обещанной

Скорость передачи данных в 171,2 Кбит/с является максимально возможной, и достигается она в том случае, когда, во-первых, телефон единолично работает с базовой станцией, занимая все ее ресурсы; во-вторых, при этом не используется протокол коррекции ошибок. В реальности же имеющиеся телефоны используют не все восемь доступных таймслотов, а не более грех (почти на всех моделях на входящий поток отводится три таймслота, а на исходящий — один таймслот); протокол коррекции ошибок используется и «отъедает» положенную ему часть от пропускной способности канала. В результате скорость работы составляет 57 600 бит/с.
Кроме того, сеть имеет такую конфигурацию, что «голосовые» пользователи имеют приоритет перед работающими с GPRS. В случае, если текущая загрузка базовой станции высока, то для работы GPRS предоставляется менее трех таймслотов, и в это время скорость передачи данных пропорционально уменьшается. Если все каналы станции заняты голосовыми абонентами, то передача данных через GPRS вообще не ведется. Правда, в этой ситуации коннект не рвется, просто соединение «висит» в ожидании момента, когда базовая станция сможет выделить на него освободившиеся от голосовых абонентов таймслоты.
Однако даже 57600 Кбит/с -- великолепная скорость, недоступная большинству интернетчиков, использующих для работы с сетью dial-up-соединение. Кроме того, GPRS-соединение стабильнее, чем соединение, установленное по обычным телефонным проводам.

Поддержка GPRS не стала стандартной для новых моделей GSM-телефонов

Ничего удивительного в этом нет. Сегодня далеко не по всякой GSM-сети возможно встретить поддержку GPRS, поэтому соответствующий функционал в телефоне пока не является реально необходимым. Ситуация изменится к концу года, когда в большинстве GSM-сетей будет запушена поддержка GPRS-сервиса. Но, как вы помните, среднее время жизни мобильного телефона составляет всего лишь девять месяцев, так что когда нынешние покупатели новых моделей телефонов без GPRS столкнутся с необходимостью иметь поддержки этого сервиса, они задумаются о покупке нового телефона взамен приобретаемого сегодня.

Не появились коммуникаторы с поддержкой GPRS

Несмотря на активные разработки коммуникаторов (телефоны, совмещенные с карманными компьютерами), до сих пор нет такого устройства с поддержкой GPRS. А уже после того как GPRS стал актуальным, на нашем рынке появились Nokia 9210 (платформа EPOC) и Siemens SX45 MultiMobile (платформа Pocket PC).
В каждом из них есть браузер и почтовый клиент, но поддержка GPRS — а сюда она прямо просится! — в них отсутствует.
Строго говоря, коммуникатор Motorola Accompli 008 поддерживает GPRS, но официально в качестве платформы этого устройства выбрана Java, и я не знаю человека, который приобрел бы себе такое устройство, ибо совершенно непонятно, где для него искать программы.


IRDA

Вообше-то IrDA - это международная организация, которая разрабатывает и внедряет стандарты беспроводной связи. IrDA обеспечивает беспроводную связь для устройств, которые, в противном случае, использовали бы для подобных целей кабель.
Для соединения по ИК-порту устройства должны быть в прямой видимости друг от друга (инфракрасный луч испускается в виде 30° конуса) и на расстоянии от полного контакта до одного метра. Скорость передачи варьируется от 9600 bps до 16 Mbps. Популярность этого стандарта связи объяснима -дешевизна и простота в использовании. Не надо никаких проводов - поднее устройства друг к другу и дело в шляпе, а имплементация подобного порта в устройство обходится производителю в 1 доллар...
Преимущества и недостатки этого способа связи очевидны. Из недостатков самым, наверное, главным, возможно назвать тот, что для связи устройства должны находиться в прямой видимости. Плюс к тому, некоторые виды освещения (например, солнечное) могут помешать связи, ведь используется, хоть и невидимый глазу, но световой поток... Следующее ограничение - это дальность связи, а одного метра бывает достаточно не всегда.
Главное достоинство же — цена, до сих пор, как вы понимаете, продолжает играть главную роль в расчетах производителей и служить популяризации этого формата. Прямая видимость, тоже может быть плюсом — во первых, этим условием обеспечивается простейшая физическая защита передаваемой информации - перехватить ее из-за всех ограничений ИК-связи достаточно проблематично (разве что попробовать «вписаться» с приемником где-нибудь в пределах этого 30° конуса). И с третьей стороны, зачастую общение требуется между двумя конкретными устройствами, что с блеском обеспечивает инфракрасная связь.
И цена, и небольшое потребление энергии, и компактность, и универсальность делают инфракрасный порт идеальным устройством для братьев наших карманных. На больших компьютерах он уже смотрится непростительным пережитком старого — и медленно и, в общем, не очень удобно, учитывая условие прямой видимости...


Bluetooth

Как вам понравятся такие чудеса, как отправка сигнала настольного компьютера к принтеру, копирование файлов с одного декстопа на другой или синхронизация Palm с ноутбуком? Да, какие же это чудеса, это, благо, будни... А если ко всему вышеуказанному добавить то, что все эти устройства физически не связаны друг с другом? Иными словами, принтер не подключён к компьютеру, компьютеры не соединены сетевыми проводами, а КПК вообще находится на расстоянии семи метров от ноутбука. Становится интереснее?
Дело в том, что все эти устройства могут быть оснащены маленькими передатчиками, которые были разработаны специально для беспроводных коммуникаций на расстояниях до 10 метров. Эти маленькие чипы — первая волна впечатляющих Bluetooth-продуктов.
Стоит заметить, что Bluetooth - вообще впечатляющая идея, нацеленная на изобретение какого-то универсального, невидимого соединения, работающего с любыми устройствами. Инфракрасный порт не всегда может справиться с такой работой, так как требует прямой связи между ИК портами и работает в коротком диапазоне.
Однако светлое будущее, предписываемое технологии Bluetooth, заставило себя ждать не менее трех лет, да и несколько разочаровало. Реалии как всегда были сильно преувеличены. Первая же линейка Bluetooth-продуктов стала очередным
крахом надежд, подтвердив старую истину: «Первый блин комом!»
Правда, следующие блинчики, пожалуй, испечены неплохо. Bluetooth версии 1.1 заставляет обратить на себя внимание и выходит в этом году из тени. На сегодняшний день, если эта технология не поддерживается встроенными средствами, то может присоединяться к широкому перечню устройств, включающему сотовые телефоны. К примеру, Ericsson T68 с поддержкой GPRS, расположившийся в кармане, позволит выходить в Internet и через PC, и через лаптоп, и через КПК.
Естественно, не вполне корректно утверждать, что Bluetooth соединение возможно между абсолютно любыми устройствами. Ведь, если телефону «есть что сказать» колонкам, принтеру с ними «разговаривать не о чем». Поэтому составной частью изучения технологии Bluetooth является осознание того, какие устройства могут общаться друг с другом и о чем.
К сожалению, и версия 1.1 не идеальна. Самым большим камнем преткновения, пожалуй, является цена. Имейте в виду, что для соединения их понадобится как минимум два. Снижение цен, по мнению специалистов, возможно ожидать не менее чем через пару лет.
Вторая проблема заключается в том, что пока технология Bluetooth «заключена» в большинстве случаев в пристегивающиеся модули, что несколько снижает ее эргономичность. Кроме того, использование периферийных устройств беспроводной связи предполагает процесс установки и конфигурации программного обеспечения. Согласитесь, что встроенный Bluetooth — штука гораздо более привлекательная.
К счастью, существует и ряд факторов, которые позволяют надеяться, что все острые углы так или иначе будут сглажены. Прежде всего, на сегодняшний день над разработкой Bluetooth продуктов трудятся по самым общим оценкам до 1500 компаний. Кроме того, Bluetooth изначально довольно умная технология. Плюсом является и то, что в ней предусмотрена система безопасности, которая позволит к примеру, вашему КПК общаться только с вашим сотовым.
Bluetooth — стандарт связи, которому пророчат блестящее будущее. Если верить обещаниям, предсказаниям и уже фактам, вскоре модули беспроводной связи Bluetooth появятся но всех устройствах, включая холодильники и микроволновые печи.
Итак, это высокоскоростной микроволновый стандарт, позволяющий передавать данные на расстоянии до 10 метров. Работает Bluetooth на частоте 2,56 Ghz и способен одновременно соединять до 8 устройств. Этот стандарт не требует никаких навыков у пользователя - как только Bluetooth-устройства сближаются на определенное расстояние, они тут же обмениваются информацией и устанавливают небольшую локальную сеть. Модуль Bluetooth невелик и потребляет около 1 миливатта энергии, что не очень много даже для мобильных устройств.
Время поговорить о преимуществах и недостатках Bluetooth. Самым большим преимуществом этого стандарта является то, что для связи устройств совершенно не требуется прямой видимости — устройства начинают «видеть» друг друга будучи сближенными на определенное расстояние. Этому стандарту нипочем даже стены и с его помощью возможно создавать небольшие сети в условиях квартиры, а например, соединение карманного компьютера с мобильным телефоном может быть осуществлено вообще без извлечения последнего скажем, из кармана.
К сожалению, на практике все обстоит гораздо сложнее и недостаток правильно написанных программ и драйверов для Bluetooth-устройств создает ситуацию, когда разрекламированная простота его использования вырастает в большую проблему... Ну, например, если одно устройство «видит» другое, а то его — нет. Вот и поди, поломай голову, где собака зарыта — настроек-то минимум.
С другой стороны именно всеядность Bluetooth может стать одним из его минусов. Предположим, в комнате на переговорах сидит некоторое количество людей с Bluetooth-устройствами. При условии, что все устройства «видят» друг друга, а вам надо передать информацию, скажем, визитную карточку конкретному человеку, могут возникнуть проблемы в нахождении этого человека. В этом случае инфракрасное общение может оказаться более удобным. В это же время Bluetooth пока еще намного дороже ИК-порта, хотя обещают, что ситуация должна в ближайшем будущем немного исправиться.
Теоретически, ничего не мешает производителю включить в устройство оба стандарта связи, ведь, но сути, они предназначены для разных вещей. Да так оно, на практике, и происходит, во всяком случае, в первых устройствах, оборудованных Bluetooth, таких как карманные компьютеры или мобильные телефоны. Но к сожалению пока Bluetooth не настолько развит, чтобы заслужить популярность.


Вопросы и ответы по Bluetooth

Прилагательное «новая» к технологии Bluetooth возможно отнести с большой натяжкой. В этом году концепции Bluetooth исполняется восемь лет. По меркам сетевых технологий, возраст весьма почтенный. Технология Bluetooth стала результатом совместных разработок крупнейших компаний телекоммуникационной и компьютерной индустрии: 3COM, Ericsson, Intel, IBM, Lucent, Microsoft, Motorola, Nokia и Toshiba. Позднее к ним присоединились около двух тысяч других производителей со всех частей света и из разных сфер бизнеса, что сделало Bluetooth самым быстроразвивающимся промышленным стандартом. Уже к 2002 году технология Bluetooth была встроена в сотни миллионов электронных устройств. 2002 и 2003 годы, скорее всего, станут «звездными» для Bluetooth. Вероятней всего, технология будет применяться практически во всех отраслях народного хозяйства.

Что такое Bluetooth?

В глобальном смысле Bluetooth — это технология беспроводной передачи данных для любых устройств с ее поддержкой: мобильных телефонов, КПК, ноутбуков, настольных компьютеров, принтеров, цифровых устройств и даже бытовой техники. Материальное воплощение Bluetooth — это маленький чип, представляющий собой высокочастотный приемопередатчик малого радиуса действия, работающий в диапазоне частот ISM (Industrial, Scientific and Medical) 2.4465-2.4835 ГГц. Диапазон рассчитан на работу медицинских приборов, бытовой техники, беспроводных телефонов, беспроводных локальных сетей стандарта IEEE. Для его использования не требуется лицензия.

Как работает Bluetooth?

Bluetooth работает как многоточечный радиоканал, управляемый многоуровневым протоколом, подобно сотовой связи GSM. Bluetooth способен «обходить» препятствия (стены в том числе), поэтому соединяемые устройства могут находиться вне зоны прямой видимости. Соединение может происходить не только по принципу точка — точка (два устройства), но и по принципу точка — несколько точек (одно устройство работаете несколькими другими). Помимо наличия Bluetooth-чипа в различных устройствах, для работы системы необходимо определенное программное обеспечение. Технология использует небольшие приемопередатчики малого радиуса действия, либо непосредственно встроенные в устройство, либо подключаемые через свободный порт или слот расширения (USB, CF. SD/MMC, MS. PCMCIA). Технология использует FHSS -скачкообразную перестройку частоты (1600 скачков в секунду) с расширением спектра. При работе передатчик переходит с одной рабочей частоты на другую по псевдослучайному алгоритму, для того, чтобы избежать конфликтов с другими устройствами. Для полнодуплексной передачи используется дуплексный режим с временным разделением (TDD). Поддерживается изохронная и асинхронная передача данных, и обеспечивается простая интеграция с TCP/IP. Временные интервалы (Time Slots) развертываются для синхронных пакетов, каждый из которых передается на своей частоте радиосигнала. Каждое устройство имеет уникальный 48-битовый сетевой адрес, совместимый с форматом стандарта локальных сетей IEEE 802.11х.

Возможен ли частотный конфликт Bluetooth-устройств с другими, использующими беспроводную радиосвязь?

Частотный диапазон работы Bluetooth совпадаем с рабочим диапазоном большинства современных беспроводных систем в промышленности, научных и медицинских учреждениях, быту. В случае возникновения так называемого «частотного конфликта», между Bluetooth и другими беспроводными системами данного диапазона могут возникнуть серьезные помехи. Для решения этой проблемы был реализован скачкообразный принцип работы Bluetooth. To есть, во время его работы постоянно происходит перестройка частоты радиопередатчика с одной на другую (1600 скачков в секунду). Это позволяет освободить нужные другим устройствам частоты и избежать конфликтов.

Почему многие называют Bluetooth «синим зубом»?

Дело в том, что буквальный перевод Bluetooth с английского — это «синий зуб». Однако название технологии возникло не случайно, и придумал его вовсе не дантист. На самом деле оно неразрывно связано с историей. Давным-давно Blue-tooth'oм называли датского христианского короля, жившего в 900-х годах и правившего во времена набегов викингов на Западную Европу. Король Гаральд Синий Зуб (Harald Bluetooth) вошел в историю как собиратель скандинавских земель. В частности, ему приписывается объединение Дании и Норвегии. Видимо, осведомленные в исторических вопросах изобретатели технологии Bluetooth решили, что по аналогии с историей короля-объединителя земель она призвана объединить мир мобильной электроники.

Какие бывают Bluetooth-устройства?

На сегодняшний день Bluetooth-устройства бывают следующими: беспроводные гарнитуры (wireless handsfree или headset), сотовые телефоны, КПК, адаптеры и модули Bluetooth, принтеры, автомобильные системы контроля, авторучки распознавания рукописных символов, бытовая техника. В дальнейшем их число и разновидности будут стремительно расти.

Как можно использовать Bluetooth?

Уже сегодня возможно привести массу примеров удачного использования Bluetooth. На сегодняшний день наиболее распространенный пример — это передача разного рода данных между устройствами на небольшом расстоянии. Например, все тот же телефонный разговор через беспроводной наушник или выход в Internet с мобильного компьютера без использования каких-либо кабельных соединений. В этом случае телефон выполняет функцию удаленного телефонного аппарата или модема, который может лежать, скажем, в кармане пиджака или чемодане, не занимая руки пользователя. Или точка доступа к корпоративной сети в офисе может находиться вне зоны видимости в другой комнате, но оборудование при этом в состоянии обеспечить работу с удаленными данными точно также, если бы его компьютер пользователя был подключен к локальной сети через кабель.

На каком расстоянии может осуществляться Bluetooth-соединение?

Изначально технология задумывалась для довольно узкого применения в коммуникационном оборудовании и предполагала возможность связи на расстоянии до 10 метров. Сегодня некоторые фирмы уже предлагают микросхемы Bluetooth, способные поддерживать связь на расстоянии до 100 метров. Так как радиотехнология Bluetooth «не боится» препятствий, поэтому соединяемые устройства могут находиться вне зоны прямой видимости. Соединение происходит автоматически, как только Bluetooth-устройства оказываются в пределах досягаемости, причем не только с одним устройством, но и сразу с несколькими (если они находятся в зоне досягаемости).

Каково энергопотребление и скорость передачи данных через Blutooth-соединение?

По установленному стандарту энергопотребление устройств Bluetooth не должно превышать 10 мВт (0.1 Вт). Скорость передачи данных, предусматриваемая стандартом, составляет порядка 720 Кбит/сек в асимметричном режиме и 420 Кбит/сек в полнодуплексном режиме. Обеспечивается передача трех голосовых каналов, но не видеосигнала.

Возможна ли защита данных, передаваемых посредством Bluetooth, и как она работает?

Да. Во-первых, для связи любых устройств с поддержкой Bluetooth необходима стандартная процедура идентификации. Каждое устройство имеет уникальный 48-битовый сетевой адрес, совместимый с форматом стандарта локальных сетей IEEE 802.11х. По этим адресам устройства идентифицируют друг друга. Для доступа с любого устройства Bluetooth к другому, активному и находящемуся в зоне досягаемости, необходима двухсторонняя проверка пароля. Только после этого может быть осуществлено взаимодействие. Во-вторых, благодаря программному обеспечению может быть реализовано шифрование данных, передаваемых между любыми устройствами, поддерживающими совместимый алгоритм.

Кто может получать доступ к моему Bluetooth-устройству во время активности функции беспроводной связи?

Все зависит от режима работы вашего устройства. Как правило, программное обеспечение Bluetooth-устройств имеет широкий набор настроек, который позволяет легко изменять его поведение по отношению к партнерам по связи. Вы имеете возможность включать/отключать видимость вашего устройства для других пользователей. К примеру, создав список периодически используемых вами устройств, возможно сделать так, чтобы ваш аппарат был недоступен для любых других. В этом случае все попытки доступа к вашему устройству со стороны «чужаков» будут блокироваться, так как их нет в заранее сформированном списке партнеров по связи. Настройка взаимодействия Bluetooth-устройств требует некоторого опыта и понимания их схемы взаимодействия. Во избежание несанкционированного доступа к данным вашего устройства, требуется выполнить все необходимые установки по условиям взаимодействия с сетевым окружением.

Как настроить Bluetooth устройства на взаимодействие? Что такое «спаривание» Bluetooth-устройств?

Сначала Bluetooth активируется как минимум на двух устройствах, которые необходимо заставить работать вместе. Они должны быть расположены в зоне досягаемости друг от друга (для мобильных устройств 8-10 м).
Затем на одном из них выполняется поиск доступных устройств, и формируется список окружения. Каждое устройство Bluetooth имеет свой уникальный 48-битовый сетевой адрес, подобно МАС-адресу сетевого адаптера в обычном ПК, по которому происходит идентификация устройств.
Дальше осуществляется сам процесс идентификации. Предположим, что при поиске и сетевом окружении найден сетевой адрес какого-то мобильного телефона. Он заносится в память искавшего устройства. Затем вы решаете «спарить» оба устройства для взаимодействия и активируете соответствующую запись о сотовом телефоне на искавшем устройстве. В результате этого ваш аппарат пытается обратиться к мобильному телефону и передает ему свой уникальный сетевой адрес. Тот, в свою очередь, заносит этот адрес в свой список сетевого окружения, но прежде чем будет открыт доступ к его ресурсам, телефон запросит цифровой пароль. После его ввода на телефоне, аналогичный запрос появится на устройстве, которое запросило сеанс связи. В случае, если пароли совпадут на обоих устройствах, взаимодействие будет установлено. Второй и третий этапы называются процессом «спаривания» Bluetooih-устройств.

У меня при связи двух устройств с поддержкой Bluetooth постоянно запрашивается пароль. Нельзя ли автоматизировать процесс их идентификации?

Можно. Программное обеспечение Bluetooth-устройств имеет широкий набор настроек, который регулирует их взаимодействие с партнерами по связи. Настроек довольно много, и они могут отличаться от устройства к устройству. Среди общих функций обычно присутствует возможность автоматической идентификации устройств после того, как они были «спарены». В этом случае никакие пароли повторно запрашиваться не будут, так как необходимая информация для проверки подлинности сохраняется в памяти устройств после первичной идентификации.

Я выполнил все настройки для работы Bluetooth, но устройства не могут установить связь. Как можно решить эту проблему?

Проверьте, активирована ли функция Bluetooth на втором устройстве, с которым вы осуществляете соединение.
Убедитесь, что устройства находятся в зоне досягаемости друг от друга (для мобильных устройств это расстояние в 8-10 метров, которое при истощении батарей может несколько уменьшаться). Еще раз внимательно проверьте все настройки. В случае, если на одном из устройств установлена функция шифрования данных, второе должно тоже его поддерживать.
Если включена функция автоматического сохранения паролей, отключите ее на обоих устройствах, произведите процесс идентификации заново.
Удалите старую информацию из списка о партнерах для связи, произведите повторный поиск активного оборудования и снова осуществите «спаривание» нужных устройств.
Проверьте доступность программных обновлений на web-сайтах разработчиков используемых устройств. Пока программное обеспечение часто вызывает проблемы несовместимости некоторых функций на устройствах от разных производителей.

Кто изготавливает Bluetooth-чипы?

Разработкой Bluetooth-устройств может заниматься любая компания. Bluetooth-начинка разрабатывается непосредственно самим производителем оборудования или закупается у других фирм. Компания Ericsson первой создала аппарат, реально работающий с технологией Bluetooth. В начале 1998 года сразу несколько гигантов компьютерного и телекоммуникационного рынка, такие как Ericsson, 3COM, Nokia, Intel. IBM, Toshiba, объединились с целью создания технологии беспроводного соединения между мобильными устройствами и периферийной техникой. Вскоре после этого была представлена специальная рабочая группа SIG (Special Interest Group). Очень быстро к ней присоединились такие компании как Motorola, Dell, Compaq, Xircom и многие другие. Был создан форум Bluetooth, в который входит порядка двух тысяч компаний (http://www.bluetooth.com/). Массовый выход технологии на открытый рынок уже начался, и мы можем воочию убедиться в этом сами. Технологию Bluetooth не зря называют одной из самых перспективных и быстро развивающихся, ибо она удобна, проста в применении и относительно дешева.

Стоит ли ожидать интеграции технологии Bluetooth с персональными компьютерами?

Да, безусловно. В последнее время технологии Bluetooth уделяется все больше внимания, и это должно способствовать ее внедрению в самые разные устройства. Пока цена устройств Bluetooth довольно высока, и многие разработчики не спешат с ее внедрением, что замедляет массовое распространение технологии. На сегодняшний день о поддержке Bluetooth заявила даже корпорация Microsoft, которая обешает скоро выпустить необходимые программные обновления для работы подобных устройств под Windows XP. Некоторые фирмы уже предусматривают возможность установки внутренних модулей Bluetooth при покупке, например, ноутбуков.

Есть ли конкуренты у Bluetooth?

На стадии начального развития «синий зуб» не рассматривался как конкурент для таких технологий как IEEE 802.11а, IEEE 802.11b и HomeRF. Он так же, как они, работает в диапазоне 2,44 ГГц, однако этот проект был ориентирован на более формальные спецификации, менее глобален и более узок по своему назначению. Скорее, главным конкурентом Bluetooth на первом этапе развития являлся IrDA — на сегодняшний день наиболее широко распространенная технология беспроводного соединения компьютеров и внешних устройств. Она преобразует информацию в инфракрасное излучение и передает от одного устройства к другому. Однако вместе с преимуществами ИК-связь обладает существенными недостатками: работа по принципу точка-точка (только два устройства одновременно), оборудование должно находиться в зоне прямой видимости, дальность действия инфракрасных приемопередатчиков обычно не больше нескольких метров. A Bluetooth действует как многоточечный радиоканал (несколько устройств одновременно), для полноценной связи всех компонентов ему совсем не обязательно, чтобы они находились очень близко (до 8-10 м и более), между ними могут быть физические преграды.
Новое, особенно «дальнобойное» оборудование Bluetooth теперь рассматривается и как конкурент IEEE 802.11х, HomeRF, то есть, как технология для построения локальных сетей. Благодаря тому, что одними из важнейших параметров «синего зуба» должна была стать низкая стоимость устройств связи, а также миниатюрность чипов, технология становится все более привлекательной для самых разных способов применения. В недалеком будущем Bluetooth может стать стандартом де-факто для беспроводных коммуникаций, вытеснив другие, более дорогие и менее мобильные стандарты. Наиболее существенную конкуренцию Bluetooth составят спецификации беспроводных локальных сетей IEEE 802.11х.

Сколько стоит производство Bluetooth и когда технология будет доступна рядовому пользователю?

Аналитики считают, что оптимальная цена комплекта компонентов для поддержки Bluetooth: процессора, радиопередатчика, антенны и флэш-памяти — составляет $5. В настоящее время производителям различного оборудования встраивание этих элементов обходится в $10-15, а это существенная разница. Для сравнения ИК-порт обходится компаниям всего лишь в $1 за комплект. Получается, что как только объемы производства Bluetooth компонентов возрастут, и цены на них снизятся, технология станет сверхпопулярной. Решением проблемы может стать комплексный вариант устройства Bluetooth на одном чипе, который позволит значительно снизить его стоимость, что уже внедряют некоторые производители Bluetooth-компонентов.

Каковы перспективы развития технологии?

Они у Bluetooth огромны. Ожидается, что эта технология будет совместима с очень многими протоколами и системами. Низкая стоимость, высокая степень защиты, удобство и простота в использовании — очень весомые преимущества стандарта. Использование частоты 2,4 ГГц не требует лицензирования, да и распространение других лицензий на работу с Bluetooth производится за символическую плату. Помимо общедоступности, данная технология обещает стать и общепринятой, так как в ближайшее время мировое промышленное сообщество примет технологию как глобальный стандарт. Такое единство вызвано тем, что гораздо проще и дешевле снабжать все устройства стандартными чипами, нежели разрабатывать компьютеры под разные интерфейсные карты. Дешевизна сетевых адаптеров позволит их встраивать буквально во все средства связи, бытовые приборы, компьютеры и другую оргтехнику.
Удобства для пользователей, которые сулит внедрение технологии, крайне заманчивы и наверняка будут иметь огромную популярность. Скажем, когда вы приходите в офис, ваш карманный компьютер тут же автоматически синхронизируется с настольным ПК, передаются новые контакты на ваш мобильный телефон. Технология позволит объединять любые электронные устройства, вплоть до холодильников, стиральных машин, микроволновых печей и дверных замков. Только представьте, как ваш холодильник передает на ваш мобильный телефон информацию о том, что в нем закончились определенные виды продуктов, а тот, в свою очередь, пополняет список необходимых покупок на вашем КПК.
Аналитики Cahners ln-Stat Group в апреле опубликовали новый доклад, в котором сказано, что к 2005 году количество электронных устройств, поддерживающих технологию Bluetooth, приблизится к миллиарду (955 млн.). Предсказывается, что средний ежегодный показатель роста рынка Bluetooth за пять лет составит 360%. Аналитики считают, что именно «синий зуб» станет тем сигналом, который всколыхнет полупроводниковую индустрию и выведет ее из кризиса, в котором она сейчас находится.


Short Message Service (SMS)

Short Message Service (SMS) на сегодняшний день является самым распространенным и используемым способом отправки и получения коротких сообщений посредством мобильной связи стандарта GSM. SMS хорошо себя зарекомендовал как средство коммуникаций в направлении человек - человек и при отправке сообщений, носящих преимущественно информационный характер, от сервера к абоненту и между серверами.
Работа SMS обеспечивается за счет SMS-центра (Short Message Service Center или SMSC), который выступает в качестве банка данных, где хранятся сообщения, и движущего средства, переправляющего их дальше. Короткие сообщения пересылаются по тому же каналу сотовой сети, что и телефонные звонки. А в случае сети, обеспечивающей пакетную передачу данных, сообщения могут отправляться даже непосредственно во время разговора по телефону.
В спецификациях к стандартным коротким сообщениям указано, что оно не может превышать 160 знаков. Теоретически, сообщение может быть в 255 раз больше, но, к сожалению, ни один из существующих телефонных аппаратов не сможет сохранить такое количество информации. В среднем, их память рассчитана всего лишь на 4 полных сообщения
Большую нишу на рынке мобильных сообщений занимают контент-провайдеры компании, обеспечивающие пользователей дополнительными SMS-услугами. При этом свой доход они получают, только заключив соответствующие финансовые договоры с операторами связи. В 2001 году наблюдался значительный рост интереса к SMS-сервисам, что позволило контент-провайдерам быстро завоевать позиции и получить дорогу к подписчикам.
Обычно адресат сообщение получает бесплатно, исключения составляют только те случаи, когда пользователь получил их по роумингу, находясь в чужой стране или, если прислали сообщение с информацией но подписке от провайдера.
В настоящее время ежемесячно отправляется 15 миллиардов SMS-сообшений, поэтому на первый взгляд вполне может показаться, что возможности открыть новые рынки здесь отсутствуют. Однако это не совсем так. Восемьдесят процентов ежедневно отправляемых коротких сообщений носят характер межличностного общения. При этом, если учесть тот факт, что технология SMS использует только 15% всего рынка GSM, то возможно увидеть огромный потенциал этой технологии. К примеру, использование службы текстовых сообщений в целях рекламного дела. Кроме того, до сих пор остается практически незатронутой область бизнеса, то есть, использование сообщений в корпоративных целях.


Nokia Smart Messaging

Nokia быстро распознала огромный потенциал SMS и его чрезвычайную полезность как носителя информации. Самые ранние сервисы Nokia позволяли закачивать новые мелодии и логотипы для телефонных аппаратов, вслед за которыми пришла поддержка возможности отправки картинок между абонентами.
Сервисы Nokia, особенно возможности закачивания новых мелодий звонков, принесли компании огромный успех. На сегодняшний день это крупнейший в Европе сервис, который приносит огромную прибыль.
Но у этого сервиса есть один большой минус. Стандарт сообщений Nokia Smart Messaging — проприетарный, и поэтому не поддерживается другими производителями телефонов.


Enhanced Messaging Service (EMS)

Мобильные телекоммуникации стоят перед лицом многих проблем, решение которых крайне необходимо для получения впоследствии всеобщего признания пользователями будущих сервисов передачи данных и грядущих выгод поколения связи 3G. Первым тагом к нему стала разработка стандарта сообщений — Enhanced Messaging Service (EMS).
EMS создана с использованием той же инфраструктуры, что и SMS, и этим напоминает Nokia Smail Messaging. Новый стандарт появился благодаря совместным усилиям телекоммуникационных компаний Ericsson, Motorola, Siemens и Alcatel.
EMS принес коротким сообщениям простейшие мультимедийные возможности.
С появлением нового сервиса стало возможным:

  • форматирование текста сообщений. Теперь текст может содержать символы, выделенные жирным шрифтом или курсивом, подчеркивание отдельных слов, центрирование текста по ширине строки. И главное — теперь нет ограничения в количестве знаков;
  • в сообщения могут быть включены изображения (черно-белые, четырехцветные или 64-цветные) размером до 255 х 255 пиксел;
  • в сообщения могут быть включены анимированные изображения (черно-белые, четырехцветные или 64-цветные) размером до 255 х 255 пиксел;
  • наличие различных стандартных анимаций, записанных в память телефона, например, «улыбки»;
  • в сообщения также могут быть включены простые звуковые сигналы, которые в будущем, возможно, заменят полифонические мелодии;
  • стандартные звуковые сигналы, записанные в память телефона, которые наряду с анимированными изображениями возможно использовать в сообщение, например, «WOW»;
  • с EMS появляется возможность закачивать в память телефонного аппарата элементы мультимедиа - мелодии, логотипы. Причем перед сохранением их возможно просмотреть или прослушать;
  • приложения vCard и vCalendar, позволяющие передавать контакты и данные календаря или записной книжки.

В случае, если EMS сообшение отправлено на телефон, не поддерживаюший этот стандарт, адресат получит только текст, то есть, обычное SMS сообшение. Это становится возможным благодаря способу кодировки сообщений EMS. Короткое сообщение имеет область данных, расположенную перед основным текстом, она называется User Data Header. Ее размер не фиксирован, и у обычных SMS равен нулю. В EMS сообщении вся медиа информация хранится внутри этой области, а текст записывается там же, где и в SMS.
На сегодняшний день главными спонсорами продвижения этого стандарта являются компании Ericsson, Motorola, Siemens и Alcatel. Но к нему проявляют большой интерес и другие, например, Mitsubishi Trium, NEC, Panasonic и Sagem.
Так что, с такой поддержкой EMS может достичь очень широкого распространения.


Multimedia Message Service (MMS)

MMS относится к новому поколению решений для мобильных сообщений. До сих пор окончательно не стандартизированный этот сервис обещает добавить телефонам множество функций, которые не может обеспечить EMS.
Стандарт MMS предназначен для сетей GPRS, которые в отличие от более простого GSM обладают постоянным подключением к сети, более высокой пропускной способностью и возможностью пакетной передачи данных, что в совокупности с более мощными устройствами и обеспечивает переход к мультимедийным сообщениям.
Работа MMS основана на стандартах SMS и e-mail. Он включил в себя лучшее от обеих систем, и в результате получился «гибридный» стандарт, оптимизированный для использования с мобильными устройствами. Это позволяет упростить процесс интеграции с существующими системами, приложениями и, главное, пользователями. Одним из достоинств нового стандарта является то, что при отправке сообщения могут быть использованы как номера телефонов, так и адреса электронной почты.
Стандарт Multimedia Message Service позволяет включать в сообщение текст, картинки в формате JPEG, сжатые посредством кодировщика AMR аудио-файлы, SMS-сообщение, спрятанное внутри MMS.
В будущем MMS планируется добавить поддержку видео форматов и различные «надбавки», например, Synchronised Multimedia Integration Language (SMIL), которая позволит представлять медиа данные в структурированной форме.
Поддержка видео, хотя может и кажется, что это, прежде всего, приоритет терминалов, очень важная часть стандарта. Но пока телефоны оснащены небольшим объемом памяти, с их помощью невозможно будет скачивать даже небольшие видеоклипы. Также очень важна возможность потокового видео непосредственно с сервера.
Также, как и SMS требует наличие некоего сервис-центра для хранения и отправки сообщений, для работы MMS необходим сервис-центр для управления потоком мультимедийных сообщений.
MMS-центр (в документации он называется MMS Relay/Server) отвечает за следующий набор задач:

  • получение и отправка медиа-сообщений с и на мобильные устройства
  • конвертирование медиа форматов в зависимости от возможностей телефонного
    аппарата, на которое отправляется сообщение
  • генерация информации о счете
  • получение и доставка сообщений с и на зарубежные MMS-центры
  • получение и доставка сообщений с и на внешние системы, например, электронную почту
  • получение и доставка сообщений внешним провайдерам, обеспечивающих дополнительными услугами, и от них

Для определения места, куда отправить сообщение, MMS Relay/ Server использует Home Location Register. В настоящее время MMS использует только один протокол соединения мобильных устройств с сервером — это WAP. В будущем планируется добавить новые механизмы передачи данных.
Провайдер, обеспечивающий пользователей дополнительными возможностями (Value Added Service provider), может посылать абонентам и получать от них (опционально) MMS-сообщения. В случае, если компания-провайдер заключит финансовый договор с оператором сети, то доход будет переправляться ему.
Сначала, MMS-центр посылает шлюзу уведомление, которое содержит важную информацию о сообщении - об его отправителе и размере.
Посреднический шлюз отправляет короткое сообщение на мобильный телефон, сообщая о доставленном мультимедийном сообщении. Программное обеспечение, установленное на устройстве, считывает эту информацию и информирует абонента.
В случае, если владелец устройства желает ознакомиться с присланным сообщением, его телефон напрямую соединяется с МMS-центром по WAP-соединению.
Кстати, в середине апреля этого года в Венгрии был произведен первый в мире коммерческий запуск полномасштабного Multimedia Messaging Services (MMS), работающего на MMS-технологии от Ericsson. Новый сервис позволяет пользователям отправлять и получать мультимедийные сообщения, содержащие рисунки, текст и звуки. Первое время он работай только с одним аппаратом — SonyEricsson T68i. Теперь же, когда на этой неделе SonyEricsson представила сразу несколько новинок, у пользователей появится выбор.


Глава 4. Вопросы и ответы

Что такое GPRS?

GPRS — это технология пакетной передачи данных по радиоканалу (General Packet Radio Service) и сетях GSM. Главной особенностью GPRS является то, что информация (принимаемая/передаваемая) делится на небольшие пакеты данных и затем передается одновременно по нескольким каналам связи. Благодаря этому максимально возможная скорость доступа посредством технологии GPRS составляет 170 Кбит/сек. При этом голосовой канал занят только во время передачи данных, а не постоянно, как при других формах доступа в сеть.

Что необходимо, чтобы пользоваться GPRS?

Для этого вам необходимо подключить услугу GPRS у оператора. Естественно, вам необходимо приобрести телефон, поддерживающий GPRS. Вот, в принципе, и все. Покупка дополнительных аксессуаров зависит от того, с какими устройствами вы будете использовать GPRS-телефон. Возможно, вам не придется покупать ничего дополнительного и вам хватит IrDA порта на телефоне и ноутбуке. Иногда в комплект с телефонами входит кабель для связи с ПК (к примеру, у Siemens ME45/S45). В противном случае вам придется покупать его отдельно.

Могу ли я пользоваться GPRS через Bluetooth?

Да, конечно. Если ваш телефон оснащен поддержкой GPRS и оснащен Bluetooth, вы имеете возможность использовать его как внешний модем с любым устройством, имеющим Bluetooth-модуль. К примеру, если речь идет о ноутбуке, то нам необходимо приобрести Bluetooth PC Card и наслаждаться работой с Internet без лишних проводов.

С помощью каких устройств возможно получить доступ в Internet, используя соединение через GPRS?

Ограничений нет вообще. Абсолютно с любого устройства, начиная от старенького Palm'a заканчивая настольным компьютером. Дело в том, что само устройство не должно иметь поддержки GPRS.
Для работы через GPRS соединение вам необходимо создать обычный модем. В случае, если речь идет о КПК, то необходимо создать внешний модем работающий через IrDA, так как всю необходимую работу с данными производит модем, встроенный в ваш телефон.

Можно ли использовать GPRS-модем на настольном ПК?

Да, это возможно. Для этого вам необходимо создать новый модем, используя специальный драйвер GPRS-модема. Обычно необходимое программное обеспечение находится на диске, поставляемом вместе с телефоном. В случае, если же данного диска нет, вы можете найти необходимое программное обеспечение в Internet.
После этого необходимо произвести настройки модема и готово!

Какова максимальная скорость передачи данных через GPRS соединение?

В перспективе скорость составит 170 Кбит/сек. В настоящий момент эта скорость составляет 40-45 Кбит/сек. Это связано с тем, что большинство выпускаемых сейчас GPRS-телефонов имеют 3 таймслота для приема и 1 таймслот для передачи информации.
Как заявляют операторы, они увеличат пропускную способность своих сетей сразу, после того как появятся телефоны с большим количеством таймслотов. Речь идет не о том, что такие телефоны вообще появятся (они уже есть), а о том, когда их цена станет доступной большому количеству пользователей.

Какая средняя скорость передачи данных через GPRS соединение?

Говорить о средней скорости при GPRS некорректно Так как информация или перелается или нет. То есть скорость от 0 до 40-45 Кбит/сек. А вот скорость передачи пакетов зависит от загруженности сети в тот или иной момент. В случае, если вы находитесь в старой, перегруженной соте, то скорость будет минимальной. А если вы в новой соте, к тому же, абсолютно не загруженной — скорость будет всегда максимальной.

Какие сотовые телефоны Motorola поддерживают технологию GPRS?

Самый первый в мире коммерческий сотовый телефон, который стал поддерживать технологию GPRS, был аппарат Motorola Timeport P7389i. В 2000 году он был снят с производства и ему на смену пришел более продвинутый аппарат MOTOROLA Timeport 260. В конце лета 2001 года компания MOTOROLA выпустила первый в мире аппарат низкой ценовой категории, который стал поддерживать технологию GPRS — телефон Motorola Talkabout 192. В настоящий момент в линейке аппаратов компании Motorola есть также новые GPRS аппараты — Motorola V.66/V.60/V.70, Motorola Timeport 280 и Motorola Accompli 008.
С начала 2002 года вся линейка сотовых телефонов Motorola стандарта GSM будет поддерживать GPRS, как основную функцию.

Могу ли я использовать GPRS для прямого соединения телефона и корпоративного сервера?

Соединение стандарта GPRS связывает телефон с компанией, предоставляющей услуги доступа в Internet, практически так же, как Вы соединяетесь с Internet-провайдером по наземной линии связи. Возможность соединиться с корпоративным сервером напрямую зависит от разных факторов. Возможно, настроить специальную связь через ISP и удастся. Более подробную информацию Вы сможете получить у представителя компании, предоставляющей доступ в Internet.

Могу ли я пользоваться телефоном, поддерживающим GPRS, за границей?

Разговор по телефону требует только доступности сети GSM и будет возможен там, где заключены соглашения о роуминге. Передача данных по стандарту GPRS будет зависеть от содержания соглашений о роуминге, которые ваша компания-оператор заключила с другими операторами. Подробнее об этом Вы можете узнать у представителя Вашей компании-оператора.

Могу ли я работать с телефоном, поддерживающим GPRS, в среде Microsoft Windows 2000?

Это возможно при помощи кабеля, входящего в комплект поставки (RS-232-кабель для Motorola Timeport 260 и USB-кабель для Motorola Timeport 280, которые входят в комплект поставки) с использованием дополнительного программного обеспечения, входящего в комплект поставки, поддерживающего передачу данных через кабель и/или инфракрасный порт.

Как узнать, какую скорость передачи обеспечит использование GPRS?

Это будет определяться тем, сколько тайм-слотов поддерживает ваш GPRS телефон на передачу данных (например Motorola Timeport 260, a Motorola Timeport 280 и V.66/V.60/V.70 — 4 тайм-слота, то есть, минимум 38.4 kbps) и также тем, какую схему кодирования применяет ваш оператор сотовой связи в данное время.

Я пользуюсь телефоном Motorola поддерживающим технологию GPRS. После смены компании-оператора GPRS не работает. В чем причина?

Каждая компания-оператор предъявляет к оборудованию свои требования. Телефон GPRS, проданный Вам первой компанией-оператором, имеет запрограммированные ею сетевые WAP и GPRS настройки. Возможно, Вы сможете изменить эти настройки при подключении телефона к персональному компьютеру по стандарту GPRS, использую программное обеспечение GPRS Wixard (или GPRS Manager), входящее в комплект поставки. Щелкнув на кнопку «Дополнительно» (Advanced) в окне Мастера GPRS (GPRS Data Wizard), Вы получите возможность менять некоторые параметры. Подробнее о смене настроек при переходе к другому провайдеру узнайте у представителя новой компании-оператора.

Можно ли использовать сотовый телефон Motorola GPRS как модем для компьютеров, работающих с операционной системой, отличной от Microsoft Windows?

В настоящее время такие операционные системы не поддерживаются.
Нужно ли регистрироваться у компании-провайдера, предоставляющей доступ в Internet, для пользования GPRS?
Нет, Ваш сотовый оператор и есть Ваш Internet провайдер, именно эта компания направляет пакеты передаваемых Вами данных. При пользовании GPRS выбрать себе другую компанию-провайдера Internet нельзя.

Как пользоваться GPRS на настольном компьютере или на ноутбуке?

Запустите CD-ROM с программным обеспечением GPRS Wizard (или GPRS Manager), входящий в комплект поставки, перейдите в Master GPRS и корректно введите: Имя точки доступа (Access Point Name, АРМ), Имя соединения (Connection Name) и при необходимости IP-адрес (обычно этот адрес является динамическим, то есть меняется при каждой регистрации). Активируйте соединение, дважды щелкнув по иконке мышкой и введя имя пользователя и пароль (их также предоставляет компания-оператор).

GPRS — это настоящее соединение dial-up?

Нет, вызова для передачи данных на самом деле не производится. Телефон автоматически регистрируется в сети GPRS и при необходимости загружает нужную информацию. Вы платите только за объем загружаемой информации (то есть за число переданных пакетов). При этом у Вас действует роуминг в сети GSM и Вы имеете возможность отвечать на вызовы (все телефоны Motorola в настоящее время имеют Класс В (Class В), который поддерживает данную возможность).

Можно ли разговаривать по сотовому телефону во время сеанса GPRS?

Да, это возможно. Тот факт, что во время сеанса GPRS-доступа вы занимаете голосовой канал не постоянно, является главным преимуществом этой технологии. Канал занят только во время передачи/приема данных. В случае, если вам поступит звонок, сеанс прервется и возобновится автоматически после окончания разговора.
Стоит отметить также, что существует три вида GPRS-модемов — А, В, С.

С-класс — это, обычно, именно GPRS-модемы, по ним не предполагается разговаривать, они созданы только для передачи данных. Чаще всего это PC-GPRS карты для ноутбуков.
В-класс — это аппараты способные работать как обычные телефоны, а так же как GPRS-модем. На данный момент все продающиеся телефоны относятся к А-классу. То есть в них вы имеете возможность или предавать/принимать данные, или разговаривать поочередно.
А-класс — это аппараты нового поколения, в них возможно одновременно передавать/принимать данные и разговаривать. Пока на рынке подобных устройств в продаже нет, по крайне мере, официально в России они не продаются.

Могу ли я принимать и отправлять SMS во время сеанса GPRS?

Да, это возможно. Здесь ситуация обстоит так же, как и при возможности принимать звонки во время сеанса. Как только образуется пауза в приеме/передаче данных, вы получите SMS-сообщения. При этом соединение не прервется, а только приостановится на несколько секунд.

В чем преимущества GPRS по сравнению с Dial-Up?

Преимущество заключается в том, что во время сеанса GPRS вы платите только за полученную/переданную информация. А при Dial-Up соединении вы оплачиваете время сеанса. К примеру, если вы пользуетесь Internet-пейджерами, то вам невыгодно оплачивать время, проведенное в сети. Гораздо эффективнее в этой ситуации платить за трафик, который составит считанные килобайты.

Может ли внезапно прерваться GPRS-соединение?

Нет. По крайне мере, исходя из опыта, смело можно это утверждать. Если вы не перемещаетесь во время сеанса между сотами, то соединение будет абсолютно стабильно. Скорее сядет аккумулятор в телефоне, чем прервется связь.

Могу ли я пользоваться GPRS, например, двигаясь в автомобиле?

Да, это возможно. Официатьно оператор не гарантирует такой возможности, но как показала практика, это вполне реально.
Стоит учесть, что могут возникнуть проблемы при перемещении между базовыми станциями, так как может оказаться, что вы попадете в перегруженную соту. в результате чего получите отказ GPRS-сеанса. Но это бывает довольно редко. Даже при перемещении по центру Москвы, где количество базовых станции очень велико, и их перегруженность очевидна, связь была стабильной.

Как оплачиваются услуги GPRS?

В настоящий момент в коммерческую эксплуатацию услугу GPRS запустила только компания «Би Лайн». Так что вопрос оплаты GPRS может возникнуть только у абонентов этого оператора.
«Би Лайн» выбрал следующий вариант тарификации: оплачиваются все полученные/переданные Мб. Один мегабайт тарифицируется по $0,30 с учетом всех налогов.
Вы получите обычный счет, в котором будет указана сумма в $, которую вы потратили, используя GPRS-соединение. Она приплюсовывается к голосовому трафику, и вы можете оплатить этот счет, как обычно, в любом удобном вам месте. Вам не придется платить за GPRS отдельно.

На каких условиях сотовая сеть предоставляет услуги GPRS?

В настоящее время услуги GPRS предоставляются на вторичной основе. Это значит, что приоритетным для оператора является голосовой трафик. В случае, если возникнет ситуация, при которой сота окажется перегружена пользователями, оборудование автоматически ограничит возможность GPRS-доступа. Как только количество пользователей в одной конкретной соте сократится, опять же, автоматически оборудование настроится на предоставление GPRS услуг в полном объеме. Это сделано для того, чтобы не ограничивать предоставления голосового трафика абонентам.

Можно ли пользоваться WAP через GPRS?

Да, это возможно. Все продаваемые сейчас GPRS-телефоны предоставляют такую возможность. Стоит учесть, что у оператора «Би Лайн» возможность пользоваться WAP через GPRS оплачивается отдельно. Вы платите $3 и пользуетесь WAP в течение месяца, не оплачивая количество переданной/полученной информации. Подобная форма оплаты удобна абонентам, которые не планируют использовать GPRS для других целей.

Планируется ли увеличение скорости соединения через GPRS операторами?

Да, планируется. Как только появятся телефоны, способные работать на более высоких скоростях. Операторы к этому будут готовы. Основная проблема заключается в том, что увеличение количества таймслотов приведет к большей пере-грузке базовых станций. Необходимо будет увеличить пропускную способность всей сети.

От чего зависит скорость соединения через GPRS?

Скорость передачи данных в GPRS-сети зависит от нескольких важных обстоятельств. Первое и, пожалуй, самое важное, это загруженность сети. Или конкретной соты в конкретный момент. Также на скорость может повлиять старое оборудование и программное обеспечение, установленное на базовой станции. Второе, это количество таймслотов, выделенных под работу GPRS.

Существует ли GPRS-роуминг?

Да, совсем недавно такое понятие появилось. В настоящий момент абоненты «Би Лайн» могут пользоваться услугами GPRS у некоторых европейских операторов, поддерживающих эту технологию. Причем абсолютно бесплатно, пока...

Какой GPRS-телефон на данный момент является лучшим?

Как показала практика, все аппараты работают примерно одинаково. Единственным значительным отличием является процедура настройки. В некоторых моделях она чересчур сложна.

Что делать, если я активировал услугу передачи данных GPRS, а она у меня не работает?

Обратитесь в справочную службу вашего оператора.
Но в первую очередь проверьте правильность всех настроек па самом телефоне и на устройстве, через которое вы хотите осуществить доступ в сеть.

Где в Москве и области я могу пользоваться GPRS-доступом к сети Internet?

Вся территория Москвы охвачена GPRS-сетью. Что касается Подмосковья и территории России, то для каждою конкретного района или города вам необходимо уточнить данные у оператора. Хотелось бы отметить, что почти вся Московская область охвачена сетью GPRS.

У меня в телефоне есть функция отправки SMS через GPRS. Могу ли я ей пользоваться, и если да, то сколько это стоит?

Да, это возможно. Тарифицироваться SMS будет, как обычно, согласно выбранному вами тарифному плану.

Как долго телефон может работать с GPRS от одной подзарядки аккумулятора?

Это зависит от мощности аккумулятора в вашем телефоне. Стоит учесть, что во время сеанса GPRS энергия тратится не постоянно и с разной мощностью. Это связано с тем, что расход энергии происходит только во время приема/передачи данных. Причем, имеет большое значение какой объем информации принимается/передается. Если речь идет об Internet-пейджере, то телефон будет работать очень долго, а если вы постоянно скачиваете большие файлы, аккумулятор разрядится быстро.
В среднем, время работы возможно определить по количеству заявленных часов работы в режиме разговора.

Я слышал, что излучение при работе с GPRS вредно для здоровья, так ли это?

Излучение во время сеанса GPRS идентично излучению во время обычного разговора. Единственным исключением является мощность этого излучения. В случае, если в телефоне для передачи данных используются три таймслота, и по всем ним идет передача данных, соответственно сила излучения в этом случае в три раза больше чем при обычном режиме работы. Поэтому настоятельно рекомендуем держать телефон во время GPRS-сеанса как можно дальше от головы и других жизненно важных органов. С другой стороны, пока никому не удалось документально доказать, что излучение от сотового телефона может привести к заболеваниям.