Технология GPRS.

04.03.2005

Необходимость решения для доступа из сотовых сетей в интернет и локальные корпоративные сети обсуждалась в течение многих лет. Широкое распространение такого рода технологий замедлялось из-за проблем с покрытием, стоимостью, эксплуатационными качествами и безопасным удаленным доступом в корпоративных сетях. Запуск основанного на GSM-сетях сервиса GPRS (General Packet Radio Service) имеет потенциал для изменения этой ситуации и обеспечения соединения "в любое время и в любом месте".

GPRS - это радио-сервис, основанный на пакетной коммутации, который дает возможность постоянного - "always on" - соединения, вытесняя трудоемкое и отнимающее много времени соединение через dial-up. Данный сервис обеспечивает также реальную пропускную способность свыше 40 кбит/с - это примерно те же скорости, что и в случае хороших наземных соединениях через модем. В целом, GPRS (General Packet Radio Service) является очередной ступенью от GSM к сотовым сетям третьего поколения - 3G. GPRS предлагает более быструю передачу данных через сети GSM со скоростями от 9.6 до 115 кбит/с. Эта новая технология создает пользователям возможность производить телефонные звонки и передавать данные одновременно. (Например, если вы имеете мобильный телефон, поддерживающий функцию GPRS, вы имеете возможность одновременно разговаривать по телефону и получать сообщения по электронной почте).

Наиболее привлекательным аспектом технологии GPRS для поставщиков услуг, помимо снижения стоимости эксплуатации, является простота управления при ее использовании, а также новые биллинговые возможности, ставшие доступными после перехода от коммутируемой к пакетной передаче данных. Клиенты также получают от внедрения этой технологии свои преимущества, поскольку она дает им множество усовершенствованных сервисов от провайдера, наряду с совершенно новыми.

Технология GPRS продвинула мобильные системы на шаг вперед, сделав более удобным и доступным использование медиа-контента в небольших мобильных устройствах. Среди других важных преимуществ GPRS - более эффективное использование радио-спектра. Пользователи теперь занимают радио-ресурсы только тогда, когда происходит реальная передача данных. Это, по сути, означает, что в одной точке доступа можно обслужить большее число пользователей, тогда как скорости передачи данных остаются высокими.

Улучшенная функциональность и эффективность GPRS ведет к снижению стоимости коммерческого предоставления сервисов передачи данных. Предлагая новые привлекательные возможности своим абонентам благодаря новой технологии, провайдеры привлекают все большее число клиентов. Но самым важным преимуществом GPRS является существенно улучшенное качество сервисов передачи данных. Функции QoS стали вполне доступными, и их даже можно будет измерить в терминах надежности, времени отклика и поддерживаемых возможностей. Новые приложения, разработанные для пользователей GPRS, окажутся привлекательными для многих клиентов мобильной связи и позволят провайдерам облегчить введение новых сервисов и модификацию старых.

Основные вехи

После того, как этот еще относительно новый сервис впервые был представлен на рынке и прежде чем он, наконец, устоялся, можно выделить несколько стадий его "становления". Внедрение сервиса GPRS включает стандартизацию, развитие инфраструктуры, испытания сетей, заключение контрактов, развертывание сети, готовность терминалов, разработка приложений и т.п. Вот эти основные вехи внедрения GPRS: Date Milestone

1999 - 2000, полностью Операторы сетей заключают контракты на тестирование и коммерческий запуск инфраструктуры GPRS.Встраивание инфраструктуры GPRS в сети GSM

Лето 2000 Стало возможным первое тестирование сервисов GPRS. Типовые скорости передачи данных - 28 кбит/с.Например, T-Mobil планирует тестирование GPRS на Expo2000 в Ганновере летом 2000 года

Начало 2001 Терминалы GPRS стали доступными в коммерческих количествах

Весь 2001 Сетевые операторы запустили сервисы GPRS в коммерческое использование и развернули сеть GPRS. Первые пользователи начинают регулярно использовать сервисы GPRS для неголосовых мобильных коммуникаций

2001/2 Типовые скорости - 56 кбит/с. Новые специализированные приложения GPRS, более высокие скорости передачи данных, решения для увеличения емкости сетей

2002 Типовые скорости - 112 кбит/с.Фаза 2 GPRS/ EDGE начинает осуществляться на практике

2002 Поддержка GPRS в новых моделях мобильных телефонов GSM становиться обычным явлением, а использование этого сервиса достигает критической массы. (Эквивалентной статусу SMS в 1999 году)

2002/3 3GSM работает в коммерческих масштабах

Как и сам стандарт GSM, сервис GPRS развивался фазами. Во время первой фазы ожидалось, что коммерческое использование сервиса начнется в 2000/2001 гг. Поддерживается решение GPRS по принципу "точка-точка" (пересылка информации отдельному пользователю GPRS), но не "точка-мультиточка" (пересылка одной и той же информации одновременно нескольким пользователям GPRS). Фаза 2 GPRS еще не является полностью определенной, но как ожидается, будут поддерживаться более высокие скорости передачи данных путем внедрения новых уже существующих технологий, таких как EDGE (Enhanced Data rates for GSM Evolution), в дополнение к поддержке решения "точка-мультиточка".

Как работает GPRS?

GPRS - это стандарт ETSI (European Telecommunications Standards Institute) для пакетной коммутации в системах GSM. В настоящее время по всему миру наиболее широко распространены сети на основе GSM и их называют сетями второго поколения (2G). Технология GSM использует вариацию TDMA (time division multiple access) и является наиболее широко используемой из трех основных цифровых беспроводных технологий (TDMA, GSM и CDMA).
GSM оцифровывает и сжимает данные, затем пересылает их по каналу с двумя другими потоками пользовательских данных, каждый в своем собственном временном интервале (в тайм-слоте). Функционирует на частоте либо 900 МГц, либо 1800 МГц. GSM имеет более 120 миллионов пользователей по всему миру и доступен в 120 странах, согласно данным GSM MoU Association. С тех пор, как большинство операторов сетей GSM заключили роуминговые соглашения с иностранными операторами, пользователи продолжают пользоваться своими мобильными телефонами во время путешествий в другие страны.
GPRS является т.н. накладывающейся технологией, распространяемой на сетях GSM, CDMA и TDMA. Эта технология применяет новый метод эффективной передачи пакетных данных по радиосетям. Технология пакетной коммутации основана на методах IP и X.25, оба из которых очень популярны и широко используются во многих сетях. Пакетная коммутация GPRS работает в целом так же, как и пакетная коммутация IP, то есть данные расщепляются на пакеты и пересылаются по назначению разными путями по сети, затем снова собираются на принимающей стороне. Пакетная коммутация GPRS допускает любой существующий трафик IP или X.25 для пересылки данных через радиосеть GPRS.

GPRS использует радиополосу шириной в 200 кГц, и она делится на восемь каналов. Общая емкость каналов составляет 271 кбит/с, но каждый из этих каналов способен передавать потоки данных в 14.4 кбит/с. Теоретически возможна скорость в 115 кбит/с, но в реальных условиях она используется крайне редко или вообще не используется. Средняя скорость в 48 кбит/с является наиболее вероятной оценкой, поскольку точки доступа поделены между множественными пользователями, причем диапазон или расположение приемника будут также зависеть от имеющейся в наличии ширины полосы. Этот результат гораздо лучше, чем могут предложить существующие устройства мобильных коммуникаций, дающие всего 9.6 кбит/с. Другим важным аспектом интернет-связи через GPRS - и это первое такого рода внедрение для широкополосной сети - является то, что соединение с интернет непрерывно (всегда "он-лайн"), и в то же время ему не приходится подтягивать ресурсы из точек доступа в то время, когда оно не используется, потому что данные передаются только тогда, когда в этом есть необходимость. Приемник запрашивает информацию, и устройство подтягивает в этот момент радио-ресурсы, а затем снова находится в нерабочем состоянии, пока не начинает принимать запрошенную информацию. Радио-полосы распределяются динамическим образом, в зависимости от типа контента - одновременно несколько или даже больше, в зависимости от того, передается ли текстовое сообщение или "живое" видео. Когда пользователь включает устройство, поддерживающее GPRS, обычно оно автоматически ищет канал GPRS в данной местности. Если соответствующий канал найден, устройство будет пытаться соединиться с сетью.

Сеть GPRS:

Сеть GPRS - наложенная сеть, располагающаяся поверх инфраструктур GSM. Ключевые компоненты сети GPRS включают

-PCU- Блок управления пакетами, дающий возможность станциям GSM пересылать и получать пакеты при GPRS коммуникациях.
-SGSN - Часть инфраструктуры GSM, ответственная за отсылку и получение пакетов от абонентов в своем районе обслуживания. Этот блок также производит авторизацию, контактируя с сервером и проверяя информацию о пользователе. Кроме того, он отслеживает маршрут перемещений абонента, чтобы иметь возможность надлежащим образом распределять ресурсы, а также собирает поступающую биллинговую информацию, пересылая ее в главный офис.
-GGSN - Компонент сети GSM, ответственный за взаимодействие с интернет и другими общественными сетями, передающими данные и голос. Компонент хранит маршрутизирующую базу данных, базу данных с адресами и фильтрующую базу данных.
-GTP - Туннелирующий протокол GPRS, основанный на протоколах TCP/IP, инкапсулирующий пакеты IP и X.25, приходящие из узлов SGSN в GGSN.

Когда пользователь GPRS делает звонок, устройство GPRS контактирует со станцией GSM, которая в свою очередь обращается к станции SGSN, которая взаимодействует с другими станциями SGSN или станциями GGSN, если ей нужно получить доступ к сети другого рода (IP или X.25). Для пользователя GPRS соединение получается "бесшовным", нет процедуры "установления звонка". Технология GPRS, накладываемая поверх сети GSM, изначально была предназначена для того, чтобы динамически и индивидуально распределять радио-ресурсы GSM "попакетно", по мере необходимости. Если к соте GSM одновременно подключается сразу много пользователей GPRS, и сота GSM не способна поддерживать такой объем голосового трафика, станция GPRS воспользуется радиоресурсами соседних сот GSM. Таким образом, в реальности пользователи GPRS обслуживаются многими сотами GSM одновременно, когда в этом возникает необходимость. Итак, SGSN получает запрос на соединение, запрашивает информацию о профиле пользователя из узла HLR и производит аутентификацию пользователя. В этой точке может осуществляться шифрование. SGSN использует информацию о профиле (включая имя точки доступа, которое идентифицирует сеть и оператора) для определения, к которому узлу GGSN производить маршрутизацию. Выбранные ворота могут предоставлять сервис удаленной аутентификации пользователя (Remote Authentication Dial-In User Service, RADIUS) и назначать динамический адрес интернет-протокола (IP) пользователю перед настройкой соединений во внешние сети. Этот процесс называется "контекстная активация пакетного профиля данных" и установки могут варьироваться от оператора к оператору. Он может включать дополнительные функции, такие как менеджмент QoS (Quality of Service - качество сервиса) и менеджмент виртуальных частных сетей (virtual private network, VPN). Когда мобильное устройство выключено или находится вне зоны покрытия GPRS, его контекст дезактивируется и устройство отсоединяется от сети.
Когда мобильный пользователь посылает данные, узел SGSN направляет пакеты на соответствующий узел GGSN. GGSN затем направляет данные в соответствии с текущим "контекстом", устанавливаемым для данной сессии. В обратном направлении, пакеты, предназначенные для пользователя, направляются в GGSN, ассоциированный с IP адресом пользователя. Узел GGSN проверяет полученные пакеты в соответствии с текущим контекстом, идентифицирует SGSN, обслуживающий данного пользователя и направляет движение в соответствующем направлении. Узел SGSN затем пересылает пакеты на базовую станцию, где находится пользователь.

Преимущества GPRS

GPRS обеспечивает более высокие скорости передачи данных, постоянное соединение - "всегда онлайн", устойчивость соединения, широкую поддержку приложений и сильные механизмы безопасности.

Увеличение скорости передачи данных

GPRS в настоящее время поддерживает средние скорости передачи данных порядка 115 кбит/с, но такие скорости достигаются только при задействовании всех восьми тайм-слотов (промежутков времени) для GPRS. Вместо этого носители и конечные устройства будут конфигурироваться типовым образом, чтобы работать с определенным количеством тайм-слотов для данных, передаваемых в обоих направлениях. Например, устройство GPRS может быть настроено для работы максимум с четырьмя слотами в прямом направлении и двумя слотами в обратном направлении. В хороших радиоусловиях это дает скорости приблизительно в 50 кбит/с в прямом направлении и 20 кбит/с в обратном направлении. Это более чем в три раза быстрее, чем в нынешних сетях GSM (14.4 кбит/с) и того же порядка, что и при хорошем модемном аналоговом соединении в кабельной линии. Совокупная ширина полосы узла сотовой связи делится между голосовым трафиком и трафиком данных. Операторы GPRS по-разному используют эту ширину полосы. Обычно они конфигурируют сети, давая приоритет голосовому трафику; некоторые из них назначают тайм-слоты для трафика данных, чтобы гарантировать минимальный уровень этого сервиса в высокозагруженные голосовым трафиком промежутки времени. Неиспользованная емкость, зарезервированная под голосовой трафик, может быть динамически переопределена под передачу данных. Имея более высокие скорости передачи данных, GPRS дает возможность реализации приложений, требующих более высокой ширины полосы и в настоящее время не осуществимых на сетях GSM.

Постоянное соединение

Постоянное соединение - "всегда онлайн" - устраняет задержки по времени, характерные для dial-up соединения, связанные с установлением нового соединения с сетью всякий раз, когда требуется отсылать и получать данные. Информация может передаваться конечному пользователю в режиме реального времени. GPRS позволяет провайдерам осуществлять биллинговый учет попакетно, а не поминутно, давая таким образом возможность предоставлять пользователям более эффективные по стоимости сервисы.

Устойчивость соединения

GPRS улучшила целостность передачи данных путем применения ряда механизмов. Во-первых, пользовательские данные кодируются с некоторой избыточностью, что улучшает их устойчивость к неблагоприятным радиоусловиям. Уровень избыточности при кодировании можно варьировать, в зависимости от тех же радиоусловий. GPRS определяет четыре кодирующие схемы - с CS1 по CS4. Вначале поддерживаются только CS1 и CS2, которые обеспечивают примерно 9 и 13 кбит/с на каждый тайм-слот. Если в полученном фрейме обнаружена ошибка в BSS, этот фрейм до передачи его на центральную сеть GPRS периодически повторяется, пока не будет получен в приемлемом качестве.

Широкая поддержка приложений

Подобно сети интернет, GPRS основан на пакетной коммутации данных. Это означает, что все собственные IP приложения могут быть реализованы в рамках GPRS - такие как e-mail, Web-доступ, мгновенная передача сообщений и передача файлов. Кроме того, его более высокие скорости передачи данных дают возможность GPRS осуществлять работу приложений, требующих большей ширины полосы (таких как мультимедийный веб-контент), которые не идут в условиях более медленных GSM dial-up соединений. GPRS более-менее хорошо подходит для приложений, основанных на Wireless Application Protocol (WAP). WAP достиг широкого распространения в новом поколении мобильных телефонов, поддерживающих микробраузеры.

Безопасность

GPRS строится на проверенной на практике модели аутентификации и авторизации, используемой GSM. При инициации сессии пользователя аутентифицируют, используя секретную информацию, содержащуюся на смарт-карте, называемой "модуль идентификации абонента" (Subscriber Identity Module, SIM). Аутентификационные данные посылаются на узел сети HLR и там подтверждаются. GPRS дает возможность дополнительной аутентификации путем использования таких протоколов как RADIUS - перед тем, как абонентам будет разрешен доступ в интернет или корпоративную сеть данных. GPRS поддерживает шифрование пользовательских данных при передаче через беспроводный интерфейс с мобильного терминала на SGSN. Кроме того, может иметь место высокоуровневое сквозное шифрование VPN (Virtual Private Network), когда пользователь подсоединяется к частной корпоративной сети. Итак, если разделить эти преимущества на те, что касаются пользователей и поставщиков услуг, то получаем следующую картину:

Для поставщиков услуг:

-Новый рынок и возрастание прибыли при переходе к предложению новых мультимедийных и контент-сервисов для клиентов.
-Многие клиенты с большей вероятностью захотят приобрести мобильный телефон с функцией GPRS, нежели покупать новый персональный компьютер, поскольку моделей телефонов на рынке существует гораздо больше, чем ПК.
-GPRS позволяет снизить себестоимость услуг за счет эффективного использования ресурсов.
-Новые возможности использования ширины полосы позволяют разрабатывать более продвинутые приложения, без вынужденного уменьшения качества контента.

Для клиентов:

-Сервисы QoS становятся доступными в качестве продаваемого продукта. Теперь, когда технология GPRS представила первое приложение с коммутацией пакетов для абонентов мобильной связи, поставщики услуг могут использовать обычные технологии для внедрения сервисных приложений в условиях традиционных IP сетей.
-Скорость гораздо выше, по сравнению с существующими сейчас скоростями GMS, и будет продолжать расти, что является очевидным преимуществом для пользователей. Скорости увеличатся в пять раз, а в некоторых случаях, и более.
-Низкая стоимость (зависящая от объема передаваемых данных);
-Постоянное соединение;
-Приложения, которые могут работать в многозадачном режиме (одновременно и текст, и голос, и видео).

Ограничения GPRS

Уже совершенно понятно, что GPRS является важным новым сервисом для мобильных устройств, не просто дающим возможность передачи данных, а существенно улучшающим спектральную эффективность, емкость и функциональность, по сравнению с используемыми до сих пор неголосовыми мобильными сервисами. Однако важно отметить, что GPRS имеет и некоторые ограничения, которые описаны ниже:

Ограниченная емкость соты

GPRS оказывает существенное влияние на существующую емкость соты сети. Объем имеющихся радиоресурсов, которые могут быть использованы для различных целей, ограничен, причем использование ресурсов для одной цели препятствует одновременному их использованию для других. Например, и голосовые вызовы, и GPRS-сессии используют одни и те же сетевые ресурсы. Ощутимость влияния зависит от количества тайм-слотов, зарезервированных для эксклюзивного использования GPRS, если это имеет место быть. Однако в действительности GPRS динамически управляет назначением каналов и позволяет уменьшать нагрузку канала сигнала в пиковое время путем пересылки коротких сообщений по GPRS каналам. Результат: Потребность в SMS как в дополнительном носителе, использующем другой тип радиоресурсов.

Реальные скорости гораздо ниже

Достижение теоретически максимальной скорости передачи данных через GPRS - 172.2 кбит/с потребовало бы, чтобы отдельный пользователь использовал все восемь тайм-слотов без какой-либо защиты от ошибок. Ясно, что на практике достаточно маловероятно, чтобы оператор сети позволил использовать все тайм-слоты одному пользователю GPRS. Кроме того, "первое поколение" GPRS-терминалов жестко лимитировано на поддержку всего одного, двух или трех тайм-слотов. Поэтому ширина полосы, доступная пользователю GPRS, так же жестко лимитирована. По этой причине теоретические максимальные скорости GPRS не могут быть достигнуты в реальных сетях и на реальных терминалах. Реальность такова, что мобильные сети, вероятно, всегда будут иметь более низкие скорости передачи данных, по сравнению с фиксированными сетями. Результат: Относительно высокие скорости передачи данных через мобильные устройства могут не быть доступными индивидуальным пользователям мобильных сервисов , пока не появились возможности существенного повышения скоростей на сетях GSM Evolution (EDGE) или Universal Mobile Telephone System (3GSM).

Неоптимальная модуляция

GPRS основан на технологии модуляции, известной как GMSK (Gaussian minimum-shift keying). Сети EDGE основаны на новой модуляционной схеме, допускающей гораздо более высокие скорости передачи данных через воздушный интерфейс - это называют модуляцией 8 PSK (eight-phase-shift keying). Поскольку 8 PSK также будет использоваться в 3GSM, сетевым операторам потребуется учесть этот момент на некоторой стадии перехода к сетям мобильной связи третьего поколения. Результат: Необходимость EDGE.

Задержки передачи

Пакеты GPRS посылаются по всем направлениям, чтобы в итоге достичь одного и того же пункта назначения. Это создает опасность того, что один или несколько таких пакетов потеряются или будут повреждены во время передачи данных по радиосвязи. Стандарты GPRS учитывают это неотъемлемое свойство беспроводных пакетных технологий, закладывая в свои стратегии задачи сохранения целостности данных и ретрансмиссии. Однако в результате этой подстраховки могут происходить задержки передачи. Вследствие этого приложения, требующие высокого качества передачи видеоизображений, могут выполняться на должном уровне при использовании HSCSD (High Speed Circuit Switched Data, высокоскоростная коммутация каналов данных). HSCSD - это просто коммутация каналов данных, при которой отдельный пользователь может использовать до четырех разных каналов одновременно. Из-за принципа сквозной связи между отправителем и получателем, задержки передачи менее вероятны. Результат: Необходимость HSCSD.

Где применяется GPRS

Неголосовые мобильные сервисы, такие как SMS и GPRS, лежат в основе широкого спектра корпоративных и потребительских приложений. Данный раздел описывает те из них, что относятся непосредственно к GPRS. В прошлые десятилетия мобильные приложения, подобные GPRS, использовались исключительно военными, медицинскими, правительственными и транспортными организациями, но не было ни стандартов, ни провайдеров, позволяющих широко распространить данные технологии, чтобы сделать их доступными для обычных людей. И только относительно недавно абоненты начали со все возрастающей активностью пользоваться GPRS, поскольку технология стала гораздо дешевле и доступней. Кроме того, абоненты мобильных систем всегда хотели иметь возможность использовать те же приложения, которыми они пользуются, когда работают на персональных компьютерах. Предпринималось множество попыток, с привлечением различных технологий, для того, чтобы предложить пользователям мобильной связи те же возможности, что и интернет, при помощи существующих технологий, но проблема состояла в том, чтобы минимизировать весь контент, а также трансформировать его таким образом, чтобы сделать его совместимым с параметрами устройства и используемой полосы. В условиях постоянной миниатюризации электроники многие новые мобильные устройства становятся быстрее, эффективнее и более похожими на персональные компьютеры. С усовершенствованием аппаратной части будет предложено множество приложений. Приложения, используемые в домашних условиях очень важны, однако приложения для бизнеса, похоже, совершат настоящий прорыв в этой технологии. Многие аналитики предупреждают, что к 2002-2003 почти половину повседневных бизнес-операций можно будет производить при помощи мобильных устройств.

Текст - Текстовые приложения для нового поколения мобильных устройств будут значительно отличаться от своих предшественников. Поскольку устройства будут функционировать с использованием IP, они не будут нуждаться в специальных системах передачи сообщений. Пользователь будет иметь возможность пользоваться любой существующей интернет-системой, предназначенной для передачи сообщений (ICQ, MSN, AOL ... и т.д.). И шансы таковы, что даже если поставщики услуг решат не создавать единой системы передачи сообщений, пользователи будут иметь возможность использовать для этого существующее бесплатно распространяемое программное обеспечение (например, Trillium). Пользователи имеют возможность получать на свои мобильные телефоны широкий спектр контента - котировки акций, спортивные результаты, погоду информацию о полетах, заголовки новостей, напоминания, результаты лотерей, шутки, гороскопы, информацию о ситуации на дорогах, местные сервисы и тому подобное. Эта информация не обязана быть чисто текстовой - это могут быть также карты, графики или другие типы визуальной информации. Длина короткого сообщения в 160 символов достаточна для передачи "количественной" информации, такой как цены на акции, спортивные результаты или сводка погоды. Однако когда информация носит качественный характер, например, гороскопы или новости, 160 символов не хватает ни на что другое, кроме как раздразнить интерес или вызвать раздражение получателя информации. По этой причине GPRS, наиболее вероятно, будет использоваться для информационных сервисов, построенных на "качественной" информации для конечных пользователей, имеющих устройства, поддерживающие GPRS, но при этом SMS будет продолжать использоваться для пересылки большей части "количественной" информации. Интересно, что чат-приложения являются формой "качественной" информации, для которой может сохраниться передача при помощи SMS, чтобы добиться краткости подачи мысли и уменьшить долю не относящихся к делу посланий.

Картинки - В условиях повышения разрешающей способности дисплеев мобильных устройств, становится все более целесообразно пересылать полноцветные фотографии, открытки и презентации. А ведь еще совсем недавно пользователи имели возможность созерцать на экранах мобильных телефонов лишь черно-зеленые изображения, на которые можно было смотреть только под определенным углом зрения и угадывать, что там могло быть изображено. Неподвижные изображения, такие как фотографии, картинки, открытки, поздравления и презентации, а также неподвижные веб-страницы можно посылать и получать по мобильной сети. При помощи GPRS можно посылать изображения с цифровой камеры, соединенной при помощи GPRS радиоустройства непосредственно с интернет-сайтами.

Звук - Новые устройства смогут использовать не только новые аудио-возможности, но и услуги передачи звука через интернет. Устройства также можно настроить на отправку и получение звуковых фрагментов в реальном времени. И не вызывает сомнения, что со временем интерфейс голосовых команд будет доступен для любых простых команд. Такого рода технология уже доступна сегодня в самых дорогих автомобилях и самых продвинутых сотовых телефонах. GPS и сервисы дорожных карт также являются сегодня весьма привлекательными для пользователей сервисами. В Японии почти все автомобили оборудованы стандартной опцией для DVD GPS системы. Несмотря на многочисленные попытки улучшения качества голосовой связи в мобильных сетях, таких как Enhanced Full Rate (EFR), требуемого качества они по-прежнему не предоставляют. Существует ряд обычных в практике, например, журналистов или полицейских ситуаций, когда необходимо фиксировать разговоры с людьми или радиосообщения при помощи портативных микрофонов профессионального качества связи и посылать эту информацию на радиостанцию или в отделение полиции. Если просто оставить мобильный телефон включенным или надиктовать на мобильный телефон нужную информацию, это не даст достаточного качества звука для анализа и перезаписи голоса, когда точная идентификация голоса важна. Поскольку даже короткие голосовые фрагменты занимают значительный объем в виде файлов, GPRS или другие высокоскоростные мобильные сервисы передачи данных в подобных случаях насущно необходимы.

Видео - Так же, как и с передачей звука, пользователи имеют возможность работать с живым видео. В качестве запоминающих устройств, процессоры становятся миниатюрнее, а скорости доступа повышаются, что является существенным моментом при использовании сотовых телефонов для проведения видеоконференций, что вскоре станет повседневной практикой. Более того, просмотр телевизионных передач вскоре будет возможен не только при помощи телевизоров, но и через мобильные устройства. Со временем природа и форма мобильных коммуникаций становится все менее текстовой и более визуальной. Беспроводная индустрия движется от текстовых сообщений к сообщениям в виде иконок и картинок, и далее - от передачи фотографий и чертежей, к видеосообщениям и пересылке фильмов, которые можно загружать и просматривать в полном объеме через мобильное устройство. Пересылка движущихся изображений через мобильную среду находит применения и в смежных нишах рынка. Например, это касается мониторинга автостоянок или мониторинга жилищ в отсутствии хозяев - против случайных гостей или воров, когда система, в случае срабатывания, может отправлять в адрес хозяина изображение происходящего. Также могут быть очень востребованы приложения для видеоконференций, в которых, например, команды дистрибьюторов могут проводить свои регулярные встречи по продажам без необходимости собираться в специальном "физическом" месте встречи - это еще одно приложение для передачи движущихся изображений.

Интернет - Еще недавно технологии, используемые мобильными устройствами, были ограничены возможностями самих мобильных устройств. С усовершенствованием мобильных коммуникаций и электроники мобильные телефоны становятся все отчетливее похожи на компьютеры. Таким образом, большинство функций ПК становятся доступными и на мобильных устройствах. Такие функции, как электронная почта, группы новостей, интерактивный чат через web-интерфейс, будут доступны вне зависимости от места нахождения пользователя. Этими сервисами можно будет пользоваться в автомобилях, дома, в офисах, на улице. Использование Circuit Switched Data для поиска и просмотра веб-страниц никогда не поддерживало приложения для мобильных пользователей. Из-за низких скоростей передачи Circuit Switched Data, требуется слишком много времени для того, чтобы данные были переданы с интернет-сервера на браузер. В качестве альтернативы пользователи отключают изображения и выводят только текст, сталкиваясь с затруднениями при чтении текстовых страниц на экране. По этой причине поиск и просмотр веб-страниц гораздо лучше подходит для работы с GPRS.

Чат - Чат может быть отделен от основных информационных сервисов, поскольку источником информации в этом случае является лицо, с которым ведется разговор, тогда как обычно информационные сервисы "потребляются" из интернет-сайтов. "Интенсивность информации" - количество информации, переданной на единицу сообщения - в чате обычно ниже, поскольку у него иные задачи: люди в чате чаще выражают свои мнения, нежели сообщают фактические данные. Точно так же, как и в интернете, где чат-группы являются очень популярным интернет-приложением, группы близких по интересам людей - так называемые общества по интересам - все чаще начинают использовать неголосовые мобильные сервисы в качестве инструментов для общения и дискуссий. "Совместная деятельность" GPRS с интернет позволяет мобильным пользователям принимать полноценное участие в интернет-чатах, без необходимости создания каких-либо отдельных групп, предназначенных специально для мобильных пользователей. Так как число участников является важным фактором, определяющим оценку участия в группах новостей, использование GPRS здесь было бы предпочтительно. Однако GPRS в своей первой фазе не поддерживает сервисы типа точка-мультиточка, что затрудняет пересылку отдельного сообщения группе людей. По этой причине, как ожидается, в обозримом будущем SMS сохранит свою значимость для чат-приложений, хотя распространения GPRS можно ожидать скорее раньше, чем позже.

Совместный доступ к документации/совместная работа - Передача данных по мобильной сети облегчает совместное использование документов и удаленную совместную работу. Это позволяет разным людям, находящимся в разных местах, работать с одними и теми же документами одновременно. Могут быть предусмотрены даже мультимедийные приложения, содержащие одновременно голосовые фрагменты, текст, картинки и изображения. Эти виды приложений могут быть полезны в процессе решения задач в различных областях деятельности, таких как пожаротушение, медицина, размещение рекламных объявлений, архитектура, журналистика и т.п. Даже решение по поводу того, на какой курорт заказывать путевку, можно принимать удаленно, если есть возможность совместно с менеджером турагентства просмотреть необходимые проспекты и документы с комментариями, без необходимости посещения турагентства физически. Находясь где угодно, человек может иметь преимущества вследствие возможности комментировать совместно просматриваемые визуальные изображения, касающиеся вопроса, по которому может быть полезна совместная работа. Обеспечивая достаточную пропускную способность, GPRS облегчает мультимедийные приложения, такие как совместное использование документов.

Коммуникации во время выполнения заданий - Достаточно распространена ситуация, когда сотрудники компании, оказывающей услуги, большую часть времени проводят "в поле", выполняя определенные задания. Неголосовые мобильные сервисы могут быть использованы для назначения новых заданий и коммуникации в плане их выполнения - между сотрудниками, постоянно находящимися в офисе и мобильным "полевым" сотрудникам. Обычно клиенты компаний звонят в офис (call center), штат которого принимает звонок и рассматривает его. Их звонки требуют визита "полевого" сотрудника компании. Приложения для отсылки заданий могут, как вариант, комбинироваться с приложениями определения местоположения автомобиля - чтобы определять ближайшего к месту назначения сотрудника, которого можно послать на обслуживание клиента. Неголосовые сервисы GSM могут быть использованы не только для пересылки заданий, но также как инструменты для инженеров по эксплуатации или продавцов, которые могли бы постоянно поддерживать свой офис информированным о прогрессе в выполнении тех или иных задач. Удаленный сотрудник может посылать сообщение о состоянии типа "Задание 1234 выполнено, занимаюсь 1235". 160 символов короткого сообщения достаточны для осуществления большинства коммуникаций, необходимых для продаж, сервисов или каких-либо других приложений для назначения заданий, таких как заказ пиццы по мобильному телефону и заказ курьера. Однако 160 символов требует определенных ухищрений для того, чтобы можно было вместить в этот объем данные о клиенте, т.е. неизбежно придется пользоваться сокращениями. Эти 160 символов не оставляют много пространства для того, чтобы дать разъездному сотруднику какую-либо информацию о проблеме, о которой поступил запрос, или подробное описание клиента. Разъездные представители компании имеют возможность прибыть к клиенту, но помимо этого они не снабжены практически никакой информацией. Вот где GPRS придется к месту, позволяя гораздо лучше проинформировать сотрудника, поскольку очень легко можно как отправить, так и получить существенный объем информации. При помощи GPRS, например, можно послать сотруднику фотографию клиента и его дома, чтобы помочь ему в поиске и идентификации клиента. Благодаря всем этим преимуществам, ожидается, что приложения для назначения заданий в первую очередь появятся среди приложений для коммуникаций на основе GPRS.

Корпоративная электронная почта - Если до половины сотрудников компании некоторое время своего рабочего дня проводят не в офисе, для них важно оставаться в контакте с офисом путем расширения возможности использования корпоративных систем электронной почты за пределы офисных персональных компьютеров. Корпоративные системы электронной почты работают на компьютерах внутренней сети (LAN) и включают такие приложения, как Microsoft Mail, Outlook, Outlook Express, Microsoft Exchange, Lotus Notes и Lotus cc:Mail. Поскольку устройства, поддерживающие GPRS, более широко распространены в корпорациях, чем среди индивидуальных пользователей мобильными телефонами, наиболее вероятно, что для приложений корпоративной электронной почты с использованием GPRS рынок будет больше, чем для приложений электронной почты через интернет.

Электронная почта через интернет - Сервисы электронной почты через интернет имеют форму шлюзовых сервисов, при котором сообщения не сохраняются или сервисов почтового ящика, в котором сообщения сохраняются. В случае шлюзовых сервисов беспроводная платформа электронной почты просто переводит сообщение из SMTP, интернет-протокола электронной почты, в SMS и посылает его в SMS-центр. В случае сервисов электронной почты электронной почты в виде почтового ящика, сообщения сохраняются, а пользователь получает уведомление на свой мобильный телефон и может затем прочесть сообщение в исходном виде, переслать его и так далее. Получив новое письмо, большинство пользователей услуг электронной почты через интернет не получают на свой мобильный телефон уведомления об этом факте. Когда они находятся вне офиса, им приходится периодически присоединяться к почтовому ящику, если они ждут письма. Однако, связывая интернет-email с механизмом предупреждения, таким как SMS или GPRS, пользователи могут получать уведомление о поступлении нового письма.

Определение местоположения автомобилей - Это приложение интегрирует системы спутникового позиционирования, которые дают людям информацию, где они находятся, при помощи неголосовых мобильных сервисов. Global Positioning System (GPS) является свободной к использованию глобальной сетью из 24 спутников, поддерживаемой Департаментом Обороны США. Любой человек, имеющий GPS приемник, может получить информацию о своем местоположении со спутника и таким образом понять, где он находится. Приложения для определения местоположения автомобилей могут быть использованы для предоставления нескольких сервисов, включая удаленную диагностику состояния автомобиля, определение местонахождения угнанных автомобилей и информирование о новой тарификации парка арендованных автомобилей. Сервис передачи коротких сообщений (SMS) является идеальным для пересылки от Global Positioning System (GPS) такой информации о местоположении, как долгота, широта, азимут и высота. Координаты, определяемые GPS, обычно в записи имеют порядка 60 символов в длину. В качестве альтернативы можно использовать GPRS.

Удаленный доступ к LAN - Для всех уже очевидно, что мобильные устройства превращаются в миниатюрные персональные компьютеры, так что все уже свыклись с тем, что они способны или будут способны поддерживать большинство приложений, поддерживаемых персональными компьютерами. Другой привлекательной функцией корпоративных мобильных устройств будут VPN. В настоящее время они интенсивно развиваются и становятся крайне популярными среди пользователей мобильных услуг. Совместное использование файлов, создание пользовательских зон, запрос баз данных, персонифицированный вход в систему, совместная работа, интеграция с другими устройствами и многие другие функции обычного персонального компьютера с большой вероятностью будут предложены для широкого использования пользователям мобильной связи. Когда сотрудники, чья работа связана с частыми передвижениями, находятся не за столами в офисе, им жизненно необходима связь с внутренней сетью (Local Area Network) компании. Удаленные приложения LAN осуществляют доступ к любым приложениям, которые сотрудник использовал бы, сидя за своим столом, таким как доступ к интранет, к сервисам корпоративной электронной почты, таким как Microsoft Exchange или Lotus Notes, и к приложениям с базами данных, выполняемыми в Oracle, Sybase или любой другой среде. Мобильный терминал, такой как карманный компьютер или ноутбук, имеет то же самое программное обеспечение, что и персональный компьютер на столе сотрудника, либо урезанные версии приложений доступны через корпоративную LAN. По этой причине данная область приложений с наибольшей вероятностью станет конгломератом удаленного доступа к нескольким различным типам информации - таким как электронная почта, интранет, базы данных. Вся эта информация может быть доступна через инструменты веб-браузинга, а может быть, все же потребует соответствующих программных приложений для мобильных устройств. Идеальный инструмент для удаленного доступа к LAN зависит от количества данных, которые необходимо пересылать, но скорость и минимальная задержка реакции GPRS делают эту технологию как раз идеальным инструментом.

Пересылка файлов - Как предполагает этот общий термин, приложения для пересылки файлов выполняют любую форму загрузки большого объема данных через мобильную сеть. Такими данными могут быть презентационные документы для менеджера турагентства, описание устройства для сервис-инженера или программное приложение, такое как Adobe Acrobat Reader, чтобы прочесть документы. Источником этой информации может быть один из методов интернет-коммуникаций, такой как FTP (File Transfer Protocol), telnet, http или Java - либо их собственная база данных или действующая платформа. Безотносительно к источнику и типу файла, который необходимо переслать, этот тип приложений требует большой пропускной способности. Поэтому высокоскоростные мобильные сервисы передачи данных, типа GPRS, EDGE или 3GSM, жизненно необходимы для того, чтобы удовлетворительно выполнять такого рода задачи.

Домашняя автоматизация - Возможности мобильных устройств могут быть с огромной пользой расширены и для личных нужд, и для нужд бизнеса, за счет компактных и простых функций домашних и бизнес-приложений. Например, критически важной функцией является встраивание в мобильные телефоны сигнальных устройств. Все что угодно, от оповещения о пожаре в доме до уведомления о получении электронной почты, может мгновенно доводиться до сведения пользователя мобильного телефона. В приложениях для домашней автоматизации удаленная система безопасности комбинируется с удаленным контролем. В основном вы можете наблюдать свой дом откуда угодно, где бы вы ни находились - в дороге, на отдыхе или в офисе. Если ваша охранная сигнализация сработает, вы не просто будете предупреждены, вы сможете также увидеть, кто именно пытается проникнуть в ваше жилище и, возможно, даже запереть их внутри. То есть вы можете не только видеть происходящее в вашем доме, но также и производить в доме какие-то действия. Вы можете удаленно включить свой видеомагнитофон на запись телепрограммы, включить плиту, чтобы подогреть ужин к своему приходу домой и тому подобное. Ваш мобильный телефон, оборудованный GPRS, реально действует как пульт дистанционного управления, типа тех, что мы ежедневно используем для телевизора, видеомагнитофона, hi-fi и т.п., но на гораздо большем расстоянии. Поскольку Internet Protocol (IP) будет скоро во всех устройствах - не только в мобильных телефонах, оборудованных GPRS, но и во всех типах бытовой техники и в каждом устройстве - к этим устройствам можно будет обращаться и выдавать им инструкции. Ключевым инструментом для домашней автоматизации будет Bluetooth, который позволяет объединять в сеть различные несовместимые устройства и осуществлять взаимодействие между ними.

Сети 3G: следующий шаг

Прямым следствием эволюции услуг GSM/GPRS является создание UMTS (Universal Mobile Telecommunications System). Это следующий этап от GPRS в направлении реальной мобильной сети третьего поколения (3G). Это широкополосная технология, основанная на пакетной передаче при скоростях передачи данных до 2 Мбит/с в помещениях и 348 кбит/с на открытых пространствах. UMTS предложит совместимый (последовательный) набор сервисов клиентам мобильных сетей, вне зависимости от того, где они находятся. UMTS, основанный на коммуникационном стандарте GSM, поддержан всеми ведущими производителями. Эти планы реализовывались в течение 2002 года. Пользователи услуг мобильной связи будут иметь доступ как к беспроводной, так и к спутниковой передаче сигнала. Спектр EMR для UMTS был предварительно распределен на полосы по 1885 - 2025 МГц для будущих систем IMT-2000, и 1980 - 2010 МГц и 2170 - 2200 МГц для спутникового подразделения систем UMTS. Наиболее удобный пока кандидат для перехода к 3G - это WCDMA (Wide Band Code Division Multi Access). Попросту говоря, WCDMA является основой технологии беспроводной передачи, которая использует уникальный пользовательский код для кодирования каналов. Каналы не используют отдельные полосы каналов, но разделяют полосу в 5 МГц, что дает им невероятную ширину полосы. Технология GPRS представляет собой первый значительный шаг по направлению к новой эре связи - в любое время, в любом месте. Следующим шагом после GPRS для мобильной индустрии станет фокусировка непосредственно на построении сетей 3G на основе сетей 2.5G, что позволит в конечном счете обеспечить более высокую емкость и скорости данных, а также поддерживать новые мультимедийные сервисы. Ключевые технологии 3G включают:

Повышенные скорости передачи данных для систем GPRS Evolution (EDGE) - Повышение скоростей передачи данных для сети GPRS примерно до 384 кбит/с на канал.

Широкополосный CDMA (WCDMA) - Использует радиоканал CDMA 5 МГц для поддержки теоретических скоростей передачи данных до 2 Мбит/с. WCDMA, как ожидается, станет доминирующим стандартом при переходе к сетям 3G и будет развертываться по всему миру в соединении с сетями GSM/GPRS.

Cdma2000 - Поддерживает более высокие скорости передачи данных 3G, представлена версия под названием 1xEV, которая дает возможность достижения скоростей в 2.4 Мбит/с и которая, вероятно, будет внедряться в США и ряде стран Азии. Широкомасштабное внедрение этих сетей, как ожидается, будет происходить в течение нескольких будущих лет. Итак, технология GPRS принесла мобильной индустрии много пользы, сделав доступ в интернет с мобильных устройств более удобным, благодаря высокой скорости передачи данных и тому, что устройства GPRS обеспечивают функции, подобные тем, что обеспечивают персональные компьютеры. Это облегчает поставщикам услуг внедрение этих сервисов и расширяет услуги доступа в интернет с мобильных устройств, оборудованных GPRS модулем, и облегчает интеграцию с более старыми мобильными сотовыми технологиями. GPRS - явно не 3G протокол, но эта технология сама по себе является важной вехой и очередным эволюционным этапом в направлении к 3G. Примерно в то же время, когда станут доступными первые устройства 3G, будет происходить эволюция не только в технологии, но также в представлении людей о технологиях. В самом ближайшем будущем мобильные устройства станут гораздо более полезными для людей и будут существенно улучшать каждый день нашей жизни. Многие мрачно пророчат, что технология покорит нас, но как показывает реальность, на самом деле до сих пор технология освобождала нас.

Технология GPRS

Автор: Виталий Шуравко
25.11.2002

Сегодня интернет начинает играть все более важную роль в работе. Часто бывает необходимо иметь доступ к электронной почте, корпоративному сайту или просто "поймать" нужного человека в ICQ. Если вам приходится часто работать вне офиса или дома - то проблема мобильного доступа в интернет становится весьма актуальной.

Традиционная передача данных

Для мобильного интернета уже достаточно давно можно использовать функцию GSM телефона "передача данных", которая позволяет работать на скорости 9,6 кбит/c. Однако, у традиционной передачи данных есть ряд существенных недостатков. Во-первых, это низкая скорость. Обычные модемы, которые работают на телефонной линии, способны обеспечивать скорость в 3-5 раз выше. Во-вторых, относительно высокая стоимость доступа, которая обусловлена тем, что при работе необходимо постоянно висеть на линии, а оплата услуг ведется на повременной основе. Кроме того, при таком способе подключения нерационально используются частотные ресурсы оператора, так как при работе в интернете часто возникает ситуация, когда данные не передаются а линия остается занята.

GPRS

Следующим шагом на пути развития технологии передачи данных стала система GPRS (General Packet Radio Service - пакетная передача данных по радиоканалу). При передаче информации через GPRS не выделяется отдельная линия, а используются небольшие порции данных или "пакеты". Кроме того, пакеты данных передаются одновременно по многим каналам в паузах между передачей речи. Именно в одновременном использовании нескольких каналов и заключается выигрыш в скорости, которая теоретически может достигать 171.2 кбит/с. Более реальные цифры - около 30 кбит/c что приблизительно сопоставимо с обычной наземной модемной линией. Важно отметить, что голосовой трафик имеет безусловный приоритет перед данными, так что скорость передачи информации определяется не только возможностями сетевого и абонентского оборудования, но и загрузкой сети. В GPRS ни один канал не занимается под передачу данных целиком - и это основное качественное отличие этой технологии от используемых ранее.

Еще одно немаловажное отличие - иная схема оплаты услуги. При использовании GPRS расчеты производятся пропорционально объему переданной информации, а не времени, проведенному online. То есть можно, к примеру, весь день общаться в ICQ а в итоге заплатить лишь за небольшой объем переданной/полученной информации.

Для чего нужен GPRS?

Если вы не собираетесь подключать свой телефон к каким либо устройствам, то основной сферой применения GPRS в телефоне являться просмотр WAP страниц. Технология GPRS способна значительно оживить интерес к WAP. Многие пользователи WAP остаются недовольны низкой скоростью и дороговизной услуги, так как при просмотре страниц приходится оставаться на линии. Благодаря GPRS работа с WAP становится весьма быстрой и недорогой. Можно с легкостью пользоваться всеми WAP ресурсами, получать информацию о погоде, афиши кинотеатров и массу подобной информации. Кроме того, посредством WAP и GPRS можно производить загрузку всевозможного контента вроде логотипов, мелодий и игр. Некоторые операторы сотовой связи предлагают неограниченную возможность использования WAP через GPRS за фиксированную ежемесячную оплату. Также возможна отсылка SMS через сеть GPRS. Кроме того, GPRS используется как транспортный протокол для обмена мультимедийными MMS сообщениями, которые помимо текста могут содержать в себе фотографии, звук, мелодии.

В том случае, если вы обладатель карманного компьютера, у вас открывается значительно больше возможностей. Это работа с электронной почтой, Web страницами, ICQ и другими системами обмена сообщениями, а также всеми другими приложениями, которые используют интернет. Причем, если у вас карманный компьютер и мобильный телефон имеют возможность связи через Bluetooth, то можно носить в одном кармане телефон, а в другом карманный компьютер с постоянной запущенной ICQ или E-mail клиентом, который будет периодически проверять почту! И что самое приятное - оплата идет только за трафик, который в этом случае будет относительно небольшим.

Если подключать телефон к ноутбуку или обычному компьютеру, то мы получим выход в интернет с скоростью сопоставимой с обычным модемом. Причем пользоваться всем этим можно не только около телефонной розетки, а в любом месте где есть покрытие сети и работает GPRS. Например в кафе, на даче, в машине и т.д. В случае с ноутбуком, можно рассматривать вариант подключения PCMCIA GPRS модема. А многие новые модели уже имеют встроенный GPRS модуль

Корпоративные пользователи и телеметрия

Для тех, кто пользуется интернетом по работе, будет весьма востребована возможность удаленного беспроводного доступа к ресурсам корпоративной сети и базам данных. В первую очередь это удобно тем сотрудникам которые вынуждены работать вдалеке от офиса. GPRS позволит иметь практически мгновенный доступ к нужной информации.

На основе GPRS также можно создавать блоки для телеметрии. Например, гораздо проще установить в банкомат GPRS модуль, чем искать и устанавливать выделенную линию. А в случае, если вблизи нет возможности установить телефон - беспроводная связь единственно возможное решение.

GPRS изнутри

Доработку GSM-сети для предоставления услуг высокоскоростной передачи данных GPRS можно условно разделить на две формы - программную и аппаратную. Если говорить о программном обеспечении, то оно нуждается в замене или обновлении практически всюду - начиная с реестров HLR-VLR и заканчивая базовыми станциями BTS. В частности, вводится режим многопользовательского доступа к временным кадрам каналов GSM, а в HLR, например, появляется новый параметр Mobile Station Multislot Capability (количество каналов, с которыми одновременно может работать мобильный телефон абонента, но об этом ниже).

Ядро системы GPRS (GPRS Core Network) состоит из двух основных блоков - SGSN (Serving GPRS Support Node - узел поддержки GPRS) и GGPRS (Gateway GPRS Support Node - шлюзовой узел GPRS). Остановимся на их функциях более подробно.

SGSN является, грубо говоря, мозгом рассматриваемой системы. В некотором роде SGSN можно назвать аналогом MSC - коммутатора сети GSM. SGSN контролирует доставку пакетов данных пользователям, взаимодействует с реестром абонентов HLR, проверяя, разрешены ли запрашиваемые пользователями услуги, ведет мониторинг находящихся online пользователей, организует регистрацию абонентов вновь "проявившихся" в зоне действия сети и т.п. Так же как и MSC, SGSN, в системе может быть и не один - в этом случае каждый узел отвечает за свой участок сети.

Предназначение GGSN можно понять из его названия - это шлюз между сотовой сетью (вернее, ее частью для передачи данных GPRS) и внешними информационными магистралями (Internet, корпоративными интранет-сетями, другими GPRS системами и так далее). Основной задачей GGSN, таким образом, является маршрутизация данных, идущих от и к абоненту через SGSN. Вторичными функциями GGSN является адресация данных, динамическая выдача IP-адресов, а также отслеживание информации о внешних сетях и собственных абонентах (в том числе тарификация услуг).

Заметим, что в GPRS-систему заложена хорошая масштабируемость - при появлении новых абонентов оператор может увеличивать число SGSN, а при увеличении суммарного трафика - добавлять в систему новые GGSN. Внутри ядра GPRS-системы (между SGSN и GGSN) данные передаются с помощью специального туннельного протокола GTP (GPRS Tunneling Protocol).

Еще одной составной частью системы GPRS является PCU (Packet Control Unit - устройство контроля пакетной передачи). PCU стыкуется с контроллером базовых станций BSC и отвечает за направление трафика данных непосредственно от BSC к SGSN.

Прежде чем приступить к работе с GPRS, мобильная станция, так же как и в обычном случае передачи голоса, должна зарегистрироваться в системе. Как уже было сказано, регистрацией (а, точнее, "прикреплением" (attachment) к сети) пользователей занимается SGSN. В случае успешного прохождения всех процедур (проверки доступности запрашиваемой услуги и копирования необходимых данных о пользователе из HLR в SGSN) абоненту выдается P-TMSI (Packet Temporary Mobile Subscriber Identity - временный номер мобильного абонента для пакетной передачи данных), аналогичный TMSI, который назначается мобильному телефону для передачи голоса (кстати, если абонентский терминал относится к классу А, то ему при регистрации выделяется как TMSI, так и P-TMSI).

Для быстрой маршрутизации информации к мобильному абоненту GPRS-система нуждается в данных о его месторасположении относительно сети, причем с большей точностью, нежели в случае передачи голосового трафика. Но представьте себе, как возрастет служебный трафик в сотовой сети и расход энергии мобильным аппаратом, если телефон будет информировать систему каждый раз при переходе от одной соты к другой! Чтобы найти разумный компромисс между объемом сигнального трафика в сети GPRS и необходимостью знать с высокой точностью местонахождение абонента принято деление терминалов на три класса:

  • IDLE (неработающий). Телефон отключен или находится вне зоны действия сети. Очевидно, что система не отслеживает перемещение подобных абонентов.
  • S TANDBY (режим ожидания). Аппарат зарегистрирован (прикреплен) в GPRS-системе, но уже долгое время (определяемое специальным таймером) не работает с передачей данных. Местоположение STANDBY-абонентов известно с точностью до RA (Routing Area - область маршрутизации). RA мельче, чем LA (каждая LA разбивается на несколько RA, но, тем не менее, RA крупнее, чем сота, и состоит из нескольких элементарных ячеек).
  • READY (готовность). Абонентский терминал зарегистрирован в системе и находится в активной работе. Координаты телефонов, находящихся в режиме READY, известны системе (а, точнее, SGSN) с точностью до соты.

Согласно этой идеологии, терминалы, находящиеся в STANDBY-режиме, при переходе из одного RA в другой посылают SGSN специальный сигнал о смене области маршрутизации (routing area update request). Если новая и старая RA контролируется одним SGSN, то смена RA приводит лишь к корректировке записи в SGSN. Если же абонент переходит в зону действия нового SGSN, то новый SGSN запрашивает у старого информацию о пользователе, а MSC, VLR, HLR и вовлеченные в работу GGSN ставятся в известность о смене SGSN. Когда телефон, работающий с GPRS-системой, перемещается в другую LA, то SGSN отправляет соответствующему VLR сообщение о необходимости смены записи о местонахождении абонента.

Следует отметить такой важный параметр, как QoS (Quality of Service - качество сервиса). Очевидно, что видеоконференция в режиме реального времени и отправка сообщения электронной почты предъявляют разные требования, например, к задержкам на пути пакетов данных. Поэтому в GPRS существует несколько классов QoS, подразделяющихся по необходимому приоритету, надежности, задержкам, пиковым и средним значением скорости.

GPRS телефоны

Для работы с системой пакетной передачи данных необходимо иметь телефон, совместимый с GPRS. GPRS-терминалы подразделяются на три класса:

  • устройства класса А способны одновременно работать как с передачей голоса, так и с передачей данных;
  • устройства класса В могут осуществлять либо передачу голоса, либо передачу данных, но не одновременно;
  • устройства класса С поддерживают только передачу данных и не могут быть использованы для голосовой связи. Как правило, это такие устройства как GPRS модемы.

Следует заметить, что максимальная скорость передачи данных определяется, в первую очередь, количеством каналов, с которыми одновременно может работать телефон. Один канал обеспечивает передачу данных со скоростью до 13.4 кбит/с. Конфигурация телефона может выглядеть как 4/1, то есть 4 канала на прием и 1 на передачу.

Подробная информация о технологии GPRS

GPRS - новые возможности мобильного Интернета

Полная мобильность подразумевает, что человеку повсеместно становятся доступны все возможности, которые он имеет на своем рабочем месте, например, скоростной доступ в интернет.
GPRS (General Packet Radio Service) - технология пакетной передачи данных посредством сотовой связи.
Суть услуги заключается в организации постоянного подключения через GPRS-телефон или GPRS-карту к сети интернет. Для работы в Сети можно использовать компьютер, ноутбук или электронный органайзер (Palm Pilot, Psion, Cassiopea). При этом Вы сможете просматривать HTML-страницы, перекачивать файлы, работать с электронной почтой и любыми другими ресурсами Интернета.

Чем привлекательна эта технология?
  • GPRS предоставляет немедленный доступ к услугам, без необходимости дозваниваться к интернет-провайдеру.
  • Пользователи GPRS получают доступ к Интернету в полном объеме, как при проводном соединении.
  • Можно работать с WAP-сайтами непосредственно с телефонного аппарата GPRS.
  • Оплачивается только объем посланной/полученной информации, а не эфирное время. До сих пор в сотовых сетях для передачи или приема данных абонентом занимался целый канал на время от установления соединения до его разрыва, которое оплачивалось вне зависимости от его загрузки.
  • В GPRS максимально возможная скорость передачи данных составляет 171,2 Кбит/с - это более чем в 3 раза быстрее, чем режим работы проводных линий, и почти в 12 раз быстрее работы передачи данных в обычных сетях GSM (9,6 кбит/с). Уже сегодня доступна скорость до 33 Кбит/с.
Передача данных: GPRS и GSM

В настоящее время передача данных по GSM каналам организована следующим образом: абоненту выделяется отдельный канал, используемый системой для передачи голоса, посредством модема, встроенного в мобильный терминал, происходит передача данных через этот канал, при этом в промежутках между передачей данных канал остается занятым. GPRS (General packet Radio Service) - это система, которая реализует и поддерживает протокол пакетной передачи информации в рамках сети сотовой связи GSM. При использовании системы GPRS информация собирается в пакеты и передается в эфир, они заполняют те "пустоты" (не используемые в данный момент голосовые каналы), которые всегда есть в промежутках между разговорами абонентов, а использование сразу нескольких голосовых каналов обеспечивает высокие скорости передачи данных. При этом этап установления соединения занимает несколько секунд. В этом и заключается принципиальное отличие режима пакетной передачи данных. В результате у абонента появляется возможность передавать данные, не занимая каналы в промежутках между передачей данных, более эффективно используются ресурсы сети.

Что дает абоненту технология GPRS?

GPRS позволит ввести принципиально новые услуги, которые раньше не были доступны. Прежде всего это мобильный доступ к ресурсам Интернета с удовлетворяющей потребителя скоростью, мгновенным соединением и с очень выгодной системой тарификации. Например, при просмотре с помощью системы GPRS WEb-страницы в Интернете, мы можем изучать содержимое столько, сколько нам необходимо, поскольку платим только за принятую информацию и не платим за время нахождения в сети Интеренет (не передавая данные, мы не занимаем каналы сети). При введении повременной оплаты на фиксированных телефонных линиях, тарифы на доступ в Интернет с мобильного GPRS-телефона будут еще более конкурентоспособны.
Технология GPRS позволит быстро передавать и получать большие объемы данных, видеоизображения, музыкальные файлы стандарта Mp3 и другую мультимедийную информацию.
Для тех абонентов, кто уже оценил удобство использования телефонов с WAP - броузером, внедрение технологии GPRS означает практически мгновенную загрузку WAP - страниц на экране телефона и более выгодную систему тарификации.
Для корпоративных пользователей система GPRS может послужить отличным инструментом для обеспечения безопасного и быстрого доступа сотрудников к корпоративным сетям предприятий, к почтовым, информационным серверам, удаленным базам данных. При этом появится возможность получать доступ к корпоративным сетям даже если абонент находится в сети другого GSM оператора, с которым организован GPRS-роуминг.
Технологии GPRS может применяться в системах телеметрии: устройство может быть все время подключено, не занимая при этом отдельный канал. Такая услуга может быть востребована службами охраны, банками для подключения банкоматов и в других областях, в том числе и промышленных.

Принципы построения системы GPRS

На структурном уровне систему GPRS можно разделить на 2 части: подсистему базовых станций и ядро сети GPRS (GPRS Core Network). В подсистему базовых станций входят все контроллеры и базовые станции системы GSM, которые поддерживают пакетную передачу данных на программном и аппаратном уровне. Ядро сети GPRS включает в себя совершенно новые сетевые элементы, предназначенные для обработки пакетов данных и обеспечения связи с сетью Интернет.
Основным сетевым элементом является пакетный коммутатор - SGSN (Serving GPRS Support Node). Данный сетевой элемент берет на себя все функции обработки пакетной информации и преобразования кадров GSM в форматы, используемые протоколами TCP/Ip глобальной компьютерной сети Internet. Пакетный коммутатор призван разгрузить GSM коммутатор, обеспечивая обработку пакетной информации, оставляя обычному коммутатору лишь голосовой трафик.
Вторым важным сетевым элементом является GPRS шлюз - GGSN (Gataway GPRS Support Node). Он обеспечивает связь системы GPRS с пакетными сетями передачи данных: Internet, Intranet, X.25 и др. GGSN содержит всю необходимую информацию о сетях, куда абоненты GPRS могут получать доступ, а также параметры соединения.
Кроме упомянутых элементов в GPRS Core входят другие элементы: DNS (Сервер доменных имен), Charging Gateway (Шлюз для связи с системой тарификации), Border Gateway (Пограничный шлюз) и другие вспомогательные элементы.
Следует отметить широкие возможности масштабирования системы GPRS. При быстром увеличении количества абонентов, пользующихся услугой пакетной передачи данных возможно увеличение емкости системы GPRS за счет расширения или установки дополнительных пакетных коммутаторов (SGSN). При увеличении суммарного объема данных, передаваемых абонентами (при несущественном увеличении числа абонентов), возможна установка дополнительных GPRS - шлюзов, которые обеспечат большую суммарную пропускную способность всей системы, а также расширение системы базовых станций. Таким образом, наращивая систему GPRS, оператор сможет обеспечивать высокое качество услуг, основанных на пакетной передаче данных.

Терминальное оборудование GPRS

Для того, чтобы использовать возможность передачи данных посредством системы GPRS, требуется специальные терминалы, поддерживающие работу в режиме GPRS.
Стандартами определены 3-класса GPRS терминалов:
  • класс А - терминал позволяет осуществлять одновременно голосовое соединение и работу в режиме GPRS;
  • класс В (сотовые телефоны) - терминал поддерживает и голосовое соединения и передачу данных в пакетном режиме (GPRS), но эти режимы используются не одновременно (во время передачи данных через GPRS абонент не может совершать и принимать голосовые звонки и наоборот);
  • класс С (карты PCMCIA, CF и USB адаптеры) - терминал обеспечивает только передачу данных в пакетном режиме. Наиболее вероятное исполнение - pCMCIA карта устанавливаемая в портативный компьютер - ноутбук.
Ожидается, что первыми доступными на рынке станут терминалы класса b. Эти терминалы буду поддерживать различные скорости приема и передачи информации. Терминалы класса В с поддержкой GPRS можно будет использовать в качестве модема для передачи данных и доступа в Интернет (при подключении телефона к компьютеру через порт RS-232 или инфракрасный порт), для приема и передачи SMS (при этом стандартное ограничение на длину короткого сообщения -160 символов будет снято), а также для скоростного доступа к WAP-серверам с экрана своего мобильного телефона.

Скорости передачи в системе GPRS

В сетях, поддерживающих GPRS, предусмотрен поэтапный путь наращивания скорости передачи данных; максимальная реальная скорость приема и передачи, которую на первом этапе сможет поддерживать система GPRS, равна 107 Кбит/с.
Сегодня основные ограничения накладывают абонентские терминалы. Скорость приема и передачи информации, которую может обеспечить мобильный терминал, зависит от количества каналов, которые терминал поддерживает на прием и передачу. Один канал поддерживает передачу информации с максимальной скоростью 13.4 кбит/с. Таким образом, количество каналов, которые будет поддерживать конкретная модель терминала будет определять максимальные возможные скорости, на которых возможна передача и прием информации.
Абонентские терминалы GPRS, предполагаемые к выпуску в ближайшее время, будут поддерживать от 2 до 4 каналов для приема информации и до 2 каналов для передачи, что позволяет получить максимальную скорость приема до 53,6 кбит/с и передачи до 26.8 кбит/с. В последующем ожидается появление моделей GPRS терминалов, поддерживающих большее количество каналов (до 7).
При использовании системы пакетной передачи абонент получает и отправляет данные с переменной скоростью, которая определяется условиями распространения сигнала и наличием свободных каналов в пределах заданной соты. При этом динамическое выделение каналов производится исходя из приоритета голосовых каналов, т. е. система автоматически выделяет под пакетную передачу все каналы, не занятые передачей голоса. Таким образом, реальная скорость приема и передачи будет во многом зависеть от загруженности голосовых каналов в пределах каждой конкретной соты.
Перспектива появления новых аппаратов с поддержкой большого количества каналов, а значит, работающих на максимально возможных скоростях передачи данных (до 115 Кбит/с), вызывает определенное беспокойство у некоторых специалистов. Дело в том, что потенциально устройства GPRS при работе на высоких частотах могут выходить за рамки максимально допустимого уровня радиационного излучения. Повторим еще раз, речь идет только о высоких скоростях обмена, поскольку, например, канал GPRS, работающий со скоростью 30-40 Кбит/с (а именно такая скорость нам светит в ближайшем будущем), излучает максимум 0.75 Вт. Это конечно больше, чем фактическое излучение терминала стандарта GSM, но в пределах нормы. Средний уровень мощности излучения еще ниже, поскольку передатчик работает только тогда, когда передаются данные, а в остальное время он выключен. При передаче файла из телефона в базовую станцию передатчик работает постоянно; при передаче текстовых сообщений или во время веб-браузинга он включается редко, что снижает мощность излучения до нескольких милливатт.

Перспективы развития услуг на базе GPRS

Появление технология GPRS должно значительно ускорить развитие мобильной передачи данных во всех областях человеческой деятельности. Во многом это связано с появлением новых услуг, развитие которых было затруднено из-за низкой скорости и высокой стоимости передачи данных через голосовые каналы GSM. Технология GPRS позволит абонентам получать доступ в глобальную сеть из любой точки, где существует покрытие сети, при этом цена такой передачи будет чрезвычайно привлекательной, а при введении повременной оплаты на фиксированных телефонных линиях, тарифы на доступ в Интернет с мобильного GPRS-телефона будут еще более конкурентоспособны.
Для корпоративных пользователей появление услуг на основе технологии GPRS будет означать реализацию давней мечты полностью мобильного офиса с доступом как в глобальную, так и в корпоративную сеть своей фирмы, с гарантией безопасного соединения. Практически исчезнет проблема доступа к корпоративной сети во время командировок, в том числе и зарубежных, поскольку GPRS-роуминг, организация которого планируется в ближайшее время, обеспечит безопасный, дешевый и высокоскоростной доступ к любому ресурсу корпоративной сети. Существуют идеи промышленного применения данной технологии для различных задач подвижного мониторинга и контроля состояния объектов.
Не стоит забывать и о том, что GPRS является идеальным транспортом для WAP-приложений, практически все телефоны с поддержкой GPRS будут иметь встроенный WAP-броузер, что позволит их владельцам не только передавать данные, но и получать оперативную информацию с различных WAP-серверов.

Перспективы пакетной передачи данных

Система GPRS является первым шагом на пути развития сетей беспроводной пакетной передачи данных. Первоначально услуги на основе GPRS будут предоставляться на ограниченной территории действия сотовой связи. В дальнейшем зона, где возможно использование технологии GPRS будет расти и, в результате, в ближайшем будущем услуги на основе GPRS будут предоставляться на всей территории действия сети сотовой связи. Также планируется увеличение скоростей приема и передачи информации за счет улучшения характеристик мобильных терминалов и инфраструктуры GPRS.
Следующим шагом на пути развития сетей пакетной передачи данных будет внедрение технологии EDGE, которая позволит достичь скорости передачи информации до 385 Кбит/с, при этом базой для развертывания технологии EDGE частично будет служить система GPRS. Таким образом, будет плавно осуществлен переход от систем с коммутацией каналов к системам пакетной передачи данных, которые найдут свою конечную реализацию в системах передачи информации третьего поколения. При этом для абонента станет возможной скорость передачи до 2 Мбит/с.