В. Алексеев. GSM/GPRS Терминалы ведущих мировых производителей

GSM/GPRS ТЕРМИНАЛЫ ВЕДУЩИХ МИРОВЫХ ПРОИЗВОДИТЕЛЕЙ

В. Алексеев

Введение

В последнее время тема беспроводной связи становится все более популярной среди российских дистрибьюторов электронных компонентов. Ежегодно появляются новые фирмы, предлагающие GSM/GPRS модули и терминалы различных производителей. Сегодня даже опытным разработчикам становится нелегко отдать предпочтение той или иной модели только на основании технической документации. Поэтому подход к выбору необходимой модели для использования в производстве должен основываться на комплексном анализе нескольких параметров.

Применение GSM/GPRS - терминалов позволяет упростить и, в ряде случаев, удешевить разработку законченных систем автоматизации производства. Для реализации беспроводной связи между оборудованием достаточно установить GSM/GPRS - терминал в уже существующую на промышленном предприятии сеть.

Ниже использована следующая терминология.

GSM/GPRS-модуль - это базовый, бескорпусной элемент, для запуска которого в работу необходимы дополнительные комплектующие и оборудование.

Под термином GSM/GPRS-терминал подразумевается полностью готовое к работе устройство, изготовленное на основе базового модуля и не требующее дополнительных доработок. В стандартном варианте GSM/GPRS-терминал содержит в закрытом корпусе базовый модуль, схемы электропитания цифрового и радиочастотного блоков, аудиосистему, интерфейсы, разъемы для питания и антенны, держатель и интерфейс SIM-карты.

В настоящее время на российском рынке официально представлены GSM/GPRS - терминалы производства ENFORA, SONY ERICSSON, SIEMENS, WAVECOM, NOKIA, SOLOMON, ТЭСС-ЭЛЕКТРОНИКС. Кроме того, на рынке можно встретить и продукцию системных интеграторов указанных фирм (Falcom, Telcom и т.д.).

Все GSM/GPRS - терминалы этих фирм удовлетворяют стандарту EGSM 900/1800 МГц и отличаются, в основном, дополнительными сервисными функциями. В таблице 1 приведены основные технические характеристики, общие для большинства GSM/GPRS терминалов ведущих мировых производителей.

Дополнительные функции, обусловленные базовым модулем, определяют индивидуальные специфические особенности GSM/GPRS – терминалов, а, следовательно, и те специальные задачи, для решения которых эти терминалы подходят наилучшим образом.

Поэтому, ниже основное внимание уделено отличительным особенностям продукции различных производителей.

Таблица 1 - Общие технические характеристики GSM/GPRS терминалов ведущих мировых производителей

Таблица 1 (Gif 450x480, 8882 байт)

GSM/GPRS ТЕРМИНАЛЫ ПРОИЗВОДСТВА ФИРМЫ ENFORA

Несмотря на то, что GSM/GPRS модули и терминалы производства фирмы (http://www.enfora.com/) ENFORA, хорошо известны в Америке и Западной Европе, эта марка практически незнакома российским разработчикам. Вместе с тем, это наиболее разработанный и универсальный тип устройств, пригодных для применения практически во всех M2M приложениях.

Основное отличие терминалов Enfora от продукции других производителей заключается в том, что стандартные случаи пользовательских приложений уже зашиты в базовое программное обеспечение. Это позволяет управлять пользовательскими вводами/выводами с помощью расширенного набора АТ команд и подключать к ним напрямую самое различное оборудование без промежуточного управляющего микроконтроллера.

Spider SA. Терминал Spider SA GSM12xx – это внешний GSM/GPRS терминал, на базе модуля GSM-107/108.

В настоящее время выпускаются две модели этого терминала - GSM1202, GSM1208, предназначенные для работы в диапазонах частот соответственно 900/1800/1900, GSM 850/900/1800/1900 МГц.

Терминалы серии Spider SA выполнены в герметичном, ударопрочном, металлическом корпусе, предназначенном для эксплуатации в жестких промышленных условиях. Общие технические характеристики аналогичны данным, приведенным в таблице 1. Размеры 55х87х30 мм.

На передней панели размещены SMA разъем для внешней антенны, разъем для подключения гарнитуры, держатель SIM – карты с автоматическим выталкивателем, светодиодный индикатор режимов работы. На задней панели размещены разъемы интерфейсов питания, RS-232, и интерфейса пользовательских вводов/выводов.

Напряжение питания терминала (от 5 до 30 В) подается через разъем Molex-2-pin. Последовательный интерфейс RS-232, v24, выведен на стандартный 9 – контактный разъем. На 8 – контактном разъеме Wago имеются выводы ADC1, ADC2, DAC, GPIO1, GPIO3, GPIO5, GPIO6, GND.

Spider SA-GL - внешний GSM/GPRS терминал, на базе модуля Enabler-II, GPRS класс 10.

В состав серии входят три модели этого терминала - GSM1212, GSM1218

Терминалы серии Spider SA-GL упрощенный и более дешевый вариант рассмотренной выше модели Spider SA.

В терминале Spider SA-GL на заднюю панель выведены только разъем питания (5 - 9 В) и 9-контактный стандартный разъем RS-232. В этом терминале нет пользовательских вводов/выводов. По своей сути этот терминал аналогичен терминалам MC-35i-T Siemens и GT-29 SONNY ERICSSON.

Новая версия Spider SA-GL, анонсированная ENFORA в конце 2004 г, будет поставляться с USB - интерфейсом и питанием непосредственно от этой шины. Эта модель поступит в коммерческую продажу во втором квартале 2005 г.

Из отличительных черт терминалов Enfora необходимо отметить, прежде всего, мощный интерфейс АТ-команд, что очень полезно для тех случаев, когда требуется разработка сложных специфических комплексов с применением модулей беспроводной связи. Интегрированные в базовый модуль Enabler стандартные функции помогают разработчику ускорить процесс разработки за счет экономии времени, необходимого на конфигурирование вспомогательных устройств.

В число наиболее значимых опций Enfora входит функция UDP/TCP сборки/разборки пакетов, которая позволяет конвертировать, упаковывать и передавать данные со стандартного последовательного интерфейса без специального протокола, необходимого внешнему устройству.

Терминал Enfora может быть сконфигурирован таким образом, чтобы при включении автоматически активировалась функция PAD, устройство регистрировалось в сети, и начинался сбор и передача информации с подключенного к модулю счетчика.

Терминал может быть запрограммирован таким образом, чтобы внешние события, такие как, например, регистрация в сети или же ввод-вывод общего назначения отслеживались и вызывали бы определенного рода действия (изменение состояния выходного интерфейса, посылка SMS-сообщения и др.). Подобные функции обработки событий не требуют внешнего контроллера и доступны через интерфейс управления (AT-команды).

Терминалы Enfora могут автоматически посылать на один или несколько серверов сообщения, которые очевидным образом содержат актуальный IP-адрес устройства. Внутри такого сообщения содержится специальная информация, позволяющая идентифицировать конкретного отправителя.

Программное обеспечение ENFORA позволяет осуществлять управление модулем посредством UDP API даже в том случае, если модем не зарегистрирован в GPRS-сети (не назначен внешний динамический IP-адрес).

Примером прикладного использования функционала обработки событий может быть часть решения по контролю доступа в помещение, когда сигнал, поступающий на I/O-интерфейс модуля, вызывает автоматическую посылку SMS-сообщения (или UDP-пакета по IP-сети). В качестве другого примера можно привести процедуру установления телефонного соединения на заданный номер и включение камеры слежения. Подобного рода действия могут быть запрограммированы посредством использования AT-команд, а в дальнейшем при необходимости перепрограммированы, как на месте, так и удаленно, с доступом к модему по GSM/GRPS сети.

Spider MT-G- внешний GSM/GPRS 900/1800 терминал, на базе модуля Enabler-II, GPRS класс 10. Эта модель предназначена для эксплуатации на автомобильном транспорте. Терминал размещен в металлическом корпусе, в котором также имеется GPS навигатор. Модель позволяет определять в автоматическом и ручном режимах технические характеристики грузового автомобиля, текущие координаты его местонахождения и передавать эту информацию на центральный диспетчерский пульт. По GSM/GPRS каналу можно передавать, как данные, так и голосовые сообщения. В модели предусмотрен режим автоматической передачи в аварийных ситуациях.

Технические параметры GSM/GPRS блока соответствуют рассмотренной выше модели Spider – SA.

Из характерных особенностей данной модели можно выделить совмещенный c GSM/GPRS терминалом 12 – канальный GPS приемник на базе модуля Trimble. Кроме того, в данной модели имеются два дополнительных ввода.вывода для 12 разрядных -АЦП, контролируемые с помощью AT - команд.

На передней панели Spider-MT-G размещены SMA разъемы для внешних GPS и GSM антенн, разъем питания (5 – 30 В), держатель SIM – карты с автоматическим выталкивателем, светодиодный индикатор режимов работы. На задней панели размещены разъемы RS-232, гарнитуры и интерфейса пользовательских вводов/выводов.

На 12 – контактном разъеме интерфейса пользователя выведены пять программируемых I/O, два микрофонных вывода (плюс и минус), два вывода динамика (плюс и минус) и два ввода/вывода АЦП. Размеры блока 100х125х40 мм.

GSM/GPRS ТЕРМИНАЛЫ НА БАЗЕ МОДУЛЕЙ ПРОИЗВОДСТВА SONY ERICSSON

GT47 Sony Ericsson - внешний GSM/GPRS терминал, GSM 900/1800, GPRS класс 8, разработанный на базе модуля GR47.

Основные технические и функциональные характеристики терминала GT47 соответствуют базовому модулю GR47 и приведены в таблице 1.

Терминал GT47 размещен в корпусе из ударопрочного полистирола. На верхней крышке корпуса имеется держатель SIM карты. На боковых стенках размещены индикатор режима работы, интерфейсные разъемы, разъемы для подачи питания, антенный разъем. Внешняя антенна подсоединяется через FME разъем.

В терминале GT47 на внешнем 15- контактном разъеме объединены выводы RS-232, АЦП (или цифровой, конфигурируемый вход), два цифровых конфигурируемых входа и два цифровых выхода, индикатор входящего вызова, расширенные цифровые линии ввода/вывода. Напряжение питания от 5 до 32 В подается через отдельный разъем.

Габаритные размеры GT47 составляют 77х67х26 мм, вес 110 г.

Терминал GR47 имеет встроенный TCP/IP стэк, выводы (контакты под пайку) для подключения сильноточных линий различных переключателей и реле, перепрограммируемый аудио интерфейс, позволяющий работать с внешними устройствами.

Библиотека TCP/UDP/IP включает в себя следующие команды:

  • Открытие/закрытие IP соединения с выделением динамического IP адреса;
  • Отправка/прием TCP пакета;
  • Отправка/прием UDP пакета;
  • Преобразование URL в IP адрес;
  • Получение текущей IP информации.

Это позволяет реализовать приложения FTP и E-Mail клиента, а также Web Browser, при подключении к терминалу клавиатуры и жидкокристаллического дисплея (ЖКИ).

Из уникальных характеристик GR47 следует прежде всего отметить:

  • Расширенный температурный диапазон от минус 30 до плюс 75 градусов Цельсия;
  • Возможность конфигурации 15 – контактного интерфейса под конкретные проекты пользователя;
  • Средства разработки приложений пользователя.

Функция конфигурации внешнего интерфейса позволяет сформировать с помощью специальных АТ команд необходимый для решения конкретной задачи набор вводов выводов. При этом появляется возможность применения в терминале GT47 двух последовательных интерфейсов RS-232 (EIA/TIA 574), дополнительных АЦП и. GPIO (1-AI, 3-DI, 5DO).

Для разработки и загрузки приложений пользователя используется программно-аппаратный комплекс «M2mpower».

В качестве отладочного комплекта может быть использован набор на базе GT47, включающий терминал, антенну, источник питания, интерфейсные кабели, гарнитуру и документацию.

Набор программного обеспечения «M2mpower package CD» включает в себя интегрированную среду разработки «M2mpower IDE». редактор, интерпретатор, примеры скриптов, техническую документацию.

Язык программирования построен на фундаменте ANSI C.

Загрузка скрипта в модуль осуществляется с помощью IDE M2mpower двумя АТ командами - AT*E2APC и AT*E2APD по протоколу обмена XModem.

Следует подчеркнуть, что в модуль загружается скрипт, а не выполняемый командный файл. В модуле находится интерпретатор скрипта, взаимодействующий с внутренним менеджером памяти и библиотекой функций, работающей непосредственно с базовым ПО.

GT29 Sony Ericsson - внешний GSM/GPRS терминал, GSM 900/1800, GPRS класс 8, разработанный на базе модуля GM47.

Модель GM29 это простой и дешевый внешний GSM/GPRS терминал, GSM 900/1800, GPRS класс 8.

На 9 контактный интерфейсный разъем модели GM29 выведен только RS232 (8 контактов). Девятый контакт разъема заведен на индикатор входящего вызова (ring indicator). Терминал выполняет все стандартные функции, которые могут быть реализованы с помощью АТ- команд через RS232. Базовые характеристики соответствуют таблице 1.

MT-232-02 - двухдиапазонный (800/1900 МГц) GSM/GPRS, GPRS класс 8 терминал на базе модуля GM47 Sony Ericsson, производства российской фирмы ТЭСС- Электроникс. Параметры данной модели аналогичны параметрам GM29.

GSM/GPRS ТЕРМИНАЛЫ НА БАЗЕ МОДУЛЕЙ ПРОИЗВОДСТВА SIEMENS

GSM/GPRS-терминалы на базе модулей производства SIEMENS наиболее широко используются в России и хорошо известны российским разработчикам. Это связано с тем, что первые GSM терминалы этой фирмы (модель M20-T) появились в России еще в 1998 г.

SIEMENS TC-35i-T – внешний GSM 900/1800 терминал на базе модуля TC35i SIEMENS. Терминал TC-35i-T предназначен для передачи данных, SMS и голосовых сообщений только в режиме GSM.

Терминал размещен в корпусе из ударопрочного полистирола.

На внешние разъемы выведен RS-232 (SUB-D-9), аудио интерфейс, разъем питания (6 контактов) и антенный вывод FME. Основные технические характеристики соответствуют таблице 1. Отличительная особенность данного терминала заключается в том, что эта модель без поддержки GPRS является наиболее простой из всех представленных на сегодняшний день в России GSM терминалов.

SIEMENS MC-35i-T – внешний GSM 900/1800 – GPRS класс 8 терминал на базе модуля MC35i SIEMENS.

Терминал MC-35i-T предназначен для передачи данных, SMS и голосовых сообщений в режимах GSM и GPRS.

Данная модель отличается от TC-35i-T тем, что имеет поддержку GPRS и меньшее энергопотребление. Аудио интерфейс MC-35i-T обеспечивает поддержку полускоростного (HR), полноскоростного (FR) и улучшенного (EFR) режимов кодирования речи. Кроме того, в MC-35i-T имеются функции эхоподавления и шумоподавления. При передаче данных поддерживается режим USSD. Имеется PPP стек.

В остальном модели MC-35i-T и TC-35i-T имеют схожие параметры.

MT-232-03 - двухдиапазонные GSM 800/1900 МГц, GPRS класс8 терминалы на базе модуля SIEMENS MC-35i, адаптированные к работе в российских условиях. Терминалы серии MT-232 являются полностью готовыми к работе устройствами и выпускаются серийно российской фирмой ТЭСС- Электроникс. Модули серии МТ выпускаются с интерфейсом RS-232. По требованию заказчиков модули могут быть укомплектованы дополнительными интерфейсами.

Общие технические характеристики МТ-232-03 приведены в таблице 1. По функциональным возможностям этот терминал аналогичен рассмотренному выше терминалу Siemens MC-35i-T.

От других терминалов данного класса модели серии МТ-232 отличаются уровнем комплексного технического обслуживания и консалтинга на стадии проектирования.

На стадии разработки проекта может быть заказан терминал с необходимым набором интерфейсов и дополнительных функций: RS-232, RS-495, I2C, UART1, UART2, USB, BLUETOOTH, встроенный TCP/IP стэк, HSCSD, USSD и т.д.

PCI-DTM-02-xx - встраиваемый GSM 900/1800, GPRS класс 8 модем на базе модуля TC45 SIEMENS, производства российской фирмы ТЭСС Северо-Запад. Модель разработана на базе одного из последних модулей Siemens TC-45-Java. В настоящее время непосредственно фирма Siemens не выпускает терминалы на базе модуля TC-45-Java. Это обусловлено тем, что первоначально новая продукция Siemens «обкатывается» небольшими тиражами на изделиях партнерских фирм. Сегодня терминалы на базе модуля Siemens-TC-45-Java выпускают три системных интегратора продукции Siemens. Кроме отмеченной выше фирмы, подобные терминалы выпускают английская фирма TACTUS (модель MTC-45) и немецкая фирма Hy Line communication products (модель HCP-45-T), испанская фирма XACOM.

Из специфических особенностей следует отметить прежде всего среду разработки программных приложений пользователя - J2ME, Java 2 Micro Edition, встроенный TCP/IP стэк, два стандартных RS-232, четыре пользовательских ввода/вывода, функции поддержки WAP и MMS.

Для этого класса изделий имеется возможность создания собственных приложений пользователя на языке Java (JME2).

Приложение пользователя, загруженное во флэш память модуля и работающее на микроконтроллере базового модуля TC-45, позволяет отказаться от внешнего микроконтроллера, управляющего периферийными устройствами. Немаловажным для России является также тот факт, что терминал, управляющий внешними периферийными устройствами с помощью приложения пользователя, не рассматривается, как видоизмененный сертифицированный продукт и на него не требуется никаких дополнительных сертификатов.

Благодаря тому, что TC-45 включает в себя поддержку Java 2 Micro Edition (J2ME), приложения пользователя для этого модуля могут быть написаны на Java.

Поскольку Java представляет собой непосредственно язык программирования и операционную среду, так называемую «Виртуальную Java-машину» (Java Virtual Machine), то одно и тоже приложение пользователя, написанное на Java, можно применять и в охранных устройствах, и в телефонах, и в телеметрических системах с аналогичной Java-платформой. Особенностями Java являются: объектно-ориентированность, многопоточность, платформонезависимость, богатые возможности для написания приложений, ориентированных на технологии "клиент-сервер".

К другим достоинствам приложений пользователя, написанным на Java, можно отнести объемную библиотеку классов, ориентированную на сокращение времени разработки сетевых приложений, построенных по технологии "клиент-сервер".

На Java, например, достаточно просто написать программу для сервера, ожидающего соединения на определенном порту TCP/IP и обрабатывающего поток данных от клиентов. В комплект поставки изделий на базе ТС-45 входит документация и набор программного обеспечения, включающий библиотеку Java-классов с примерами функций для работы с GSM/GPRS-соединениями, которые можно использовать для быстрого и эффективного написания приложений пользователя. В состав прилагаемых программ входит также эмулятор рабочей среды модуля для ПК, включающий в себя отладчик.

GSM/GPRS ТЕРМИНАЛЫ НА БАЗЕ МОДУЛЕЙ ПРОИЗВОДСТВА WAVECOM

Французская фирма WAVECOM, специализирующаяся на разработке и изготовлении GSM/GPRS модулей и модемов, активно стала работать на российском рынке с 2001 г. За это время GSM/GPRS терминалы WAVECOM завоевали популярность у многих российских разработчиков.

Fastrack M1306B - внешний GSM/GPRS терминал, GSM 900/1800, GPRS класс 10, на базе модуля Q2406B-IP.

Модель выполнена в герметичном, ударопрочном металлическом корпусе, что позволяет использовать его в жестких промышленных условиях.

На 15-контактном внешнем разъеме mini sub-D, объединены RS-232 и пользовательские вводы/выводы. Общие технические характеристики совпадают с таблицей. Внешняя антенна подключается через разъем SMA.

Через внешний разъем MOLEX Micro Fit-4p на терминал можно подавать напряжение питания от 5 до 32 В, в том числе и непосредственно от бортовой сети автомобиля. Во встроенном блоке питания предусмотрена защита от перегрузок по току и напряжению.

Светодиодный индикатор, выведенный на переднюю панель, позволяет контролировать четыре режима работы.

Из отличительных черт M1306B следует, во – первых, отметить два ввода/вывода общего назначения, которые могут быть мультиплексированы с I2C шиной для подключения внешних устройств. Кроме того, в терминале реализовано автоматическое отключение питания при подаче сигнала на последовательный порт.

Как другую отличительную черту M1306B можно выделить возможность создания собственных приложений пользователя для модулей с помощью открытой перепрограммируемой платформы OPEN AT. Эта среда представляет собой набор программ, с помощью которого разработчики могут писать приложение под конкретную задачу на языке высокого уровня (С++) и затем загружать его непосредственно в Flash-память модуля.

Входящие в состав OPEN AT дополнительные средства Remote Application Execution Tool позволяют осуществлять отладку программ непосредственно в модуле Q24xxx в режиме Embedded Application.

Реальная отладка прикладных программ пользователя выполняется с помощью трассировщика на компьютере и компилируется для приложения, работающего внутри модуля.

MT-232-02 - двухдиапазонный (800/1900 МГц) GSM терминал на базе модуля Q2400A WAVECOM, производства российской фирмы ТЭСС- Электроникс. Терминал предназначен для передачи данных, SMS только в режиме GSM.

Параметры данной модели аналогичны параметрам SIEMENS TC-35i-T. Из отличительных черт можно отметить возможность создания приложений пользователя с помощью OPEN AT.

TANGO FALCOM - двухдиапазонный (800/1900 МГц) GSM/GPRS терминал на базе модуля Q2406A WAVECOM, производства фирмы (http://www.falcom.de/) FALCOM.

Параметры данной модели аналогичны параметрам FASTRACK, M1206 WAVECOM. В отличии от моделей WAVECOM данный терминал имеет второй последовательный интерфейс RS232 (Rx, Tx) (Slave), выведенный на RJ45 8pin (shielded).

GSM/GPRS ТЕРМИНАЛЫ НА БАЗЕ МОДУЛЕЙ ПРОИЗВОДСТВА MOTOROLA

GSM/GPRS модули G18 и G20 производства Motorola хорошо известны в России. Сама фирма Motorola в настоящее время не выпускает терминалы, оставляя этот рынок своим партнерам – системным интеграторам, ссылки на продукцию которых можно найти на сайте http://www.motorola.com/.

В России сейчас наибольшей популярностью пользуется сертифицированный GSM/GPRS терминал SCMi250u на базе модуля G20 Motorola, производства фирмы SOLOMON.

Модель SCMi250u, производства фирмы SOLOMON представляет собой полностью готовый к работе четырехдиапазонный (850/900/1800/1900 МГц) GSM/GPRS терминал (GPRS, класс8), изготовленный на базе модуля MOTOROLA. Терминал предназначен для подключения к шине USB1.1.

Основное отличие от продукции других производителей заключается в том, что питание на терминал поступает непосредственно с разъема USB, что позволяет избавиться от лишнего провода и внешнего блока питания.

Терминал предназначен для использования в качестве беспроводного модема в комплекте с любыми типами компьютеров, имеющих шину USB1.1.

Модель SCMi250u может быть использована для выхода в Интернет в режиме GPRS, работы с e-mail и для других прикладных задач.

В промышленной телеметрии эта модель используется на центральных диспетчерских пунктах для обеспечения связи с удаленными GSM/GPRS терминалами.

Устойчивая работа в сетях российских операторов обеспечивается за счет универсального драйвера, входящего в комплект поставки.

Из других технических характеристик следует выделить:

  • Диапазон частот GSM 850/900/1800/1900 МГц;
  • GPRS, класс 8;
  • Скорость передачи данных до 64Кбит/с;
  • Интерфейс: USB 1.1;
  • Размеры: 60x35x12мм;
  • Вес: 15г.

GSM/GPRS ТЕРМИНАЛЫ ПРОИЗВОДСТВА ФИРМЫ NOKIA

В России марка фирмы Nokia пользуется давней и заслуженной популярностью благодаря сотовым телефонам и GSM шлюзам. Терминалы на базе GSM/GPRS модулей этой фирмы известны хуже. Это связано с тем, что идеология Nokia в области GSM/GPRS телеметрии значительно отличается от рассмотренных выше концепций других производителей. Фирма Nokia ориентируется в первую очередь на рынок торгового оборудования, игровых автоматов и бытовой электроники, с удаленным контролем и управлением домашних приборов и оборудования с помощью сотовых телефонов. Успешное функционирование GSM/GPRS оборудования в этой области рынка возможно только при тесной кооперации производителей оборудования, разработчиков специального программного обеспечения и операторов сетей сотовой связи. С этой целью Nokia разработала свою стратегическую модель под названием “M2M GATEWAY”, включающую три основных блока:

  • GSM/GPRS модули или терминалы со специальным набором функций;
  • Специальное программное обеспечение для шлюза между удаленным GSM/GPRS терминалом и сервером приложений;
  • (http://www.nokia.com/nokia/0,1522,,00.html?orig=/m2m) Открытое программное обеспечение для приложений пользователя, работающих на удаленных устройствах .

Nokia30 - внешний GSM 900/1800 – GPRS класс 8 терминал на базе модуля Nokia12. Основные технические характеристики этого терминала соответствуют таблице 1. Из характерных особенностей данной модели можно выделить такие специфические функции, как отправка SMS при изменении состояний цифровых I/O. С другой стороны, принимаемые сообщения могут менять состояния пользовательских вводов/выводов.

Таким образом, терминал Nokia30 может работать, как простое устройство ввода-вывода, управляемое SMS, без внешнего микроконтроллера.

При работе с внешним устройством на базе ПК или МК терминал может взаимодействовать с удаленным сервером приложений через M2M GATEWAY. В этом режиме данные по последовательному порту могут передаваться с использованием транспортного протокола по спецификации CORBA. Это позволяет дистанционно активизировать заданные функции на другом устройстве и принимать отклик этих устройств с новыми измененными параметрами.

В режиме M2M GATEWAY данные могут передаваться одновременно по каналам GSM, GPRS и по телефонной сети через модемный пул. В этом случае на удаленных терминалах и центральном сервере используется универсальный программный интерфейс, разработанный на базе CORBA.

Однако, следует подчеркнуть, что реализация работы через M2M GATEWAY возможна только при предоставлении дополнительных услуг со стороны оператора сотовой связи и в первую очередь при организации выделенных физических линий от шлюза до коммуникационного центра оператора.

Так же, как и в рассмотренном выше модуле TC – 45, в моделях Nokia предусмотрена разработка приложений пользователя, написанных на Java. Программное обеспечение M2M GATEWAY также написано на Java. Поэтому разработка приложений для этой платформы может выполняться достаточно просто с использованием свободно распространяемых по сети Интернет прикладных программ.

ЗАКЛЮЧЕНИЕ

Обзор продукции GSM/GPRS терминалов различных производителей показывает, что этот сегмент рынка развивается очень быстро. На рынке постоянно появляются новые имена производителей и названия новых моделей. Вместе с тем меняется и политика производителей.

Если несколько лет назад ведущие мировые производители старались выпускать только ОЕМ модули, то сегодня на рынке можно видеть GSM/GPRS терминалы производства практически всех ведущих фирм. Как и в случае сотовых телефонов, наблюдается усложнение моделей за счет добавления вспомогательных опций. Крупные производители повернулись в сторону производства сложных GSM/GPRS модемов со специфическими функциями. При этом в первую, очередь делается упор на М2М применения и на разработку приложений пользователя.

Системные интеграторы, работающие в разных нишевых направлениях, стараются найти в предлагаемом списке GSM/GPRS терминалов те дополнительные функции, которые наиболее полно удовлетворяли бы их специфическим требованиям.

Наиболее широкий спектр дополнительных опций, реализуемых в России, системным интеграторам предлагает фирма Enfora. Далее по сложности следуют терминалы фирмы Sony Ericsson, Wavecom, Siemens. Очень интересные прикладные функции предусмотрены в терминалах фирмы Nokia. Однако, к сожалению, большинство из них не могут быть в настоящее время реализованы в России.

Одним из наиболее весомых аргументов в маркетинговом споре ведущих мировых производителей GSM/GPRS модулей является тезис о прикладном программном обеспечении. Наиболее сложную оболочку для разработки приложений пользователя Open AT предлагает фирма WAVECOM. Этот продукт предоставляет пользователям действительно неограниченные возможности для творчества.

Известно, что сложность и надежность любой системы находятся в обратной зависимости. Учитывая это, другие фирмы предлагают более простые способы разработок программ пользователей.

Следует особо подчеркнуть, что в рекламных компаниях фирм, предлагающих открытые платформы для создания собственных управляющих программ, ни слова не упоминается о надежности работы модулей с различными видами приложений. Конечно, ни одна из рассмотренных выше фирм не несет никакой ответственности за работу модулей с программным обеспечением, разработанным самим пользователем. Таким образом, открытые перепрограммируемые платформы являются своего рода фильтром, позволяющим производителям и дистрибьюторам GSM/GPRS модулей выделить из числа своих клиентов наиболее крупных заказчиков и продолжать адресную дополнительную работу по отладке и обкатке оборудования за дополнительные деньги.

Поэтому подход к выбору необходимой модели должен основываться на комплексном анализе таких параметров, как:

  • оптимальное сочетание необходимых функций и технических параметров, сосредоточенных в одном терминале;
  • предполагаемый объем выпускаемой продукции;
  • адекватность заявляемых технических параметров реальным характеристикам, полученным при эксплуатации образцов в различные периоды загрузки в сетях различных российских операторов.
  • уровень технической поддержки и наличие технической документации, необходимой для быстрой интеграции в конечное изделие.

      Об авторе: Виктор Алексеев, Tess North-West Ltd, директор, к.ф-м.н., mailtu:info@telemetry.spb.ru

      Данная публикация - сокращенный вариант статьи в журнале "Компоненты и технологии" № 1, 2005