Перспективы беспроводных технологий M2M

Применение беспроводных технологий от SonyEricsson

Виктор Каплуновский, специалист по беспроводной связи, фирма СЭА,
e-mail: kapvik@sea.com.ua

Виктор Олейник, технический специалист, фирма СЭА,

e-mail: solaris@sea.com.ua

В статье рассматривается беспроводная технология M2M, реализация этой технологии на модулях и терминалах SonyEricsson, применение беспроводной технологии M2M в различных сферах деятельности.

Введение

В сегодняшнем мире нас окружает большое количество оборудования - дома, офисная техника, всевозможные системы охраны и безопасности, промышленное и полупромышленное оборудование: датчики, системы доступа, всевозможные измерительные и контрольные системы, исполнительные механизмы и т.д. Многие из них требуют постоянного наблюдения, контроля, установок определенных параметров, или же сбора данных, результатов измерений и т.д. В абсолютном большинстве случаев требуется обеспечение передачи данных или сигналов управления к таким устройствам или получения информации от них. Именно это и называется М2М технологии, передача информации, связь: machine-to-machine, mobile-to-machine или machine-to-mobile.

Беспроводные M2M

Беспроводные подходы позволяют увеличить мобильность M2M, сэкономить деньги, отказаться от реализаций, предусматривающих протяжку кабеля, и от соответствующего оборудования. Беспроводные системы M2M передают данные несколькими способами, в том числе, с помощью однокристальных радиосхем или радиомодулей.

Применение M2M

· Системы доступа

Дают возможность определенной группе людей с помощью своего сотового телефона заходить в определенные помещения, открывать электронные замки, двери и т.д. Такие действия осуществляются с помощью обыкновенного телефонного звонка или посылкой определенного кода.

  • Системы охраны помещений

Позволяют осуществлять дистанционную беспроводную охрану помещений. Дает возможность пользователям систем самостоятельно дистанционно ставить-снимать с охраны такие помещения. Так же дополнительные сервисные функции, как Alarm и Panic.

  • Системы безопасности

Беспроводные системы безопасности (пожарная, аварийная, персональная и т.д.). Позволяет независимо и дистанционно отслеживать состояние объектов и при необходимости полностью автономно посылать сигналы тревоги или информацию о состоянии объектов.

  • Дистанционный контроль и управление "домашним" оборудованием

Дает возможность с помощью мобильного телефона дистанционно осуществлять контроль "домашнего" оборудования, поддерживать определенные условия в помещениях, дистанционно управлять таким оборудованием (обогреватели, кондиционеры, насосы, сауны и т.д.).

· Автоматы по продаже, кофейные автоматы, обменные машины, автоматические бензоколонки и т.д.

Дистанционно контролировать состояние, осуществлять контроль работоспособности, дистанционная охрана, дистанционный сбор информации о наличии "запасов" и их количестве, статистика. Телефонные аппараты, установленные вдоль автомобильных трасс, парковочные автоматы, управление уличными табло.

  • Лифты, эскалаторы и т.д

Дистанционный контроль работоспособности, передача аварийных сигналов и т.д.

· GSM видео

Предоставляет возможность осуществлять дистанционную передачу изображения (охрана, контроль состояния и т.д) через GSM сеть.

Практическая реализация

Компания SonyEricsson наиболее активно продвигает на рынок концепцию M2M. Это GSM/GPRS-модемы. GPRS - это технология пакетной передачи данных по радиоканалу (General Packet Radio Service) в сетях GSM. Главной особенностью GPRS является то, что информация (принимаемая/передаваемая) делится на небольшие пакеты данных и затем передается одновременно по нескольким каналам связи. Благодаря этому максимально возможная скорость доступа с помощью технологии GPRS составляет 170 Кбит/сек. При этом голосовой канал занят только во время передачи данных, а не постоянно, как при других формах доступа в сеть.

Компания SonyEricsson предлагает 4 класса GSM/GPRS модемов:

· 1 класс — GSM универсальные модули (GR47, GM47);

· 2-й класс — GSM специализированные терминалы (GM29, GT47);

· 3-й класс — PCMCIA GSM модули;

· 4-й класс — модули стандарта AMPS/CDMA.

Последними разработками компании SonyEricsson в этой области являются модули GSM/GPRS GR47, GR48, GM47 и GM48, поддерживающие протокол TCP/IP. Проведем краткий обзор модемов GR47(модуль см. рис. 1) и GT47(терминал см. рис. 2).

Основные параметры модуля GR47:

· диапазоны частот 900/1800 МГц;

· совместимость со стандартом 3GPP GSM Phase 2+;

· выходная мощность 2 Вт/900 МГц, 1 Вт/1800 МГц;

· чувствительность –102 дБм;

· напряжение питания 3,4…4 В;

· средний ток потребления в режиме связи 250 мА, в режиме GPRS 350 мА,в режиме ожидания 5 мА;

· габаритные размеры 50x33x7,2 мм;

· диапазон рабочих температур по полной спецификации –30... +75С,по сокращенной спецификации –40...+85С (без аналогов);

· температура хранения –40...+85С;

· вес 18,5 г.

Модуль оборудован антенным разъемом MMCX и 60-контактным разъемом
с определенным набором функций данного класса. GSM модули GM47,GM48 открывают новые возможности для приложений, то есть возможность отправлять данные прямо на терминал GSM сети. Модули работают в двух частотных диапазонах GM47 в стандарте 900/1800, GM48 в стандарте 850/1900. Обеспечивая легкий доступ к Интернет-соединениям, эти два продукта интегрируются в информационные системы достаточно просто. Они предназначаются к использованию в М2М приложениях (машина-машина) и (человек-машина), где необходимо управление голосом и или отправка/получение данных через GPRS, CSD, HSCSD и SMS.
Возможности:

· Возможность взаимодействия с GPS;

· Асинхронная передача данных CSD c 9.6/14.4 kbps;

· Режим оцифровывания звука;

· Диапазоны частот (800/1900 или 850/1900);

· Асинхронная передача данных HSCSD (2+1);

· Готовое устройство для работы с Интернетом;

· Поддерживает текстовой и PDU формат;

· MO/MT/CB/SMS Status Report;

· Возможность одновременной передачи и получения голосовых данных FR/EFR;

· Поддержка TCP/IP стека;

  • AT команды;

· GPRS Class 8 (4+1).

Основной отличительной особенностью модулей GR47,GM47 является фирменное программное обеспечение. Следует отметить, что модули позволяют загружать во внутреннюю Flash-память до двух скрипов общим объемом 44 К/байта, написанных с помощью программного обеспечения М2М-Power, поставляемой компанией SonyEricsson. При использовании внутренних скриптов модуль начинает функционировать без внешнего источника АТ-команд. Следовательно, модуль может работать автономно, без внешнего микроконтроллера. При этом все внешние порты ввода/вывода (UART, I2C, I/O 1–7 digital) становятся доступны для внутреннего скрипта. Таким образом, задействуются все внутренние и внешние ресурсы модуля.

Основные параметры терминала G T47:

· диапазон частот 900/1800 МГц;

· совместимость со стандартом 3GPP GSM Phase 2+;

· выходная мощность 2 Вт/900 МГц, 1 Вт/1800 МГц;

· напряжение питания 5…32 В;

· средний ток потребления в режиме связи 250 мА, в режиме GPRS 350 мА,в режиме ожидания 15 мА;

· габаритные размеры 77x67x26 мм;

· рабочая температура –30...+75С;

· температура хранения –40...+85С;

· вес 110 г.

Антенна присоединяется к модему через разъем FME; на 15-контактный разъем выведены:

· интерфейс RS-232 с поддержкой управления модемом при помощи АТ-команд и скоростью передачи данных 1,2…460,8 кбит/с;

· один АЦП или цифровой вход (конфигурируемый);

· два цифровых входа и два цифровых выхода (конфигурируемые);

· выход постоянного напряжения 4,8 В/75 мА.

Модемы GR47,GT47 сделаны на одной и той же основе, отличие лишь в конструкции и в дополнительных сервисных возможностях, поэтому основные функции GT47 совпадают с функциями GR47.

Среди новинок, которые придут на смену существующим моделям модемов GR47 и GM47, это GR64, GS64, EE54. Опытные образцы уже выпущены и проходят тестовые испытания.

Рис. 3. Модуль GR64

Рис. 4. Модуль GS64

Основные параметры модуля G R64 (рис. 3):

· радиочастотные параметры и габаритные размеры совместимые полностью с модемом GR47;

· диапазон рабочих температур по полной спецификации –30... +75С,по сокращенной спецификации –40...+85С (без аналогов);

· вес 9,5 г.

Модуль оборудован антенным разъемом MMCX и 60-контактным разъемом с определенным набором функций данного класса. Новые функциональные отличия GR64 от модуля GM47,G R47:

· на борту модуля имеется Sim держатель.

· поддержка двух Sim карточек с переключением.

· поддержка Sim карточки с пониженным питанием 1.8/3 В.

· наличие выхода для подключения клавиатурной матрицы 4х4.

· GPRS Class 10.

· усовершенствованные IP протоколы. FTP client.

· расширен интерфейс ввода вывода.

· интерфейс USB 2.0

· значительно расширены функции вложенных приложений. Обмен данными с вложениями возможен с помощью GPRS.

· Изменены характеристики голосового канала.

Основные параметры модуля G S64 (рис. 4) полностью совпадают с характеристиками модема GR64 (рис. 3), за исключением уменьшенных габаритных размеров 37х30х3,2 и стыковочных разъемов. Модем разработан для приложений, в которых используется автономное питание от батареи. Это приложения такие как PDA, переносные POS терминалы, миниатюрные системы мониторинга. Вес GS64 модема 5 гр.

Основные преимущества модуля EE54 (рис. 5) перед GS64:

· [image] Class 10 EDGE технология позволяет использовать этот модем в приложениях с высокой плотностью передачи данных со скоростью до 238 кбит/с.

· Возможность чтения номеров из телефонной книги Sim карточки.

· Возможность использования сервисных номеров.

· Криптографическая защита передаваемых данных.

· Протокол с идентификацией по паролю.

· Расширенный список дополнительного GSM сервиса.

Более подробную информацию о модемах SonyEricsson можно получить на сайте SonyEricsson www.sonyericsson.com в разделе M2M по адресу http://www.sonyericsson.com/spg.jsp?cc=ru&lc=ru&ver=4002&template=pp1&zone=pp&lm=pp1.

Для заказа GSM/GPRS-модемов компании SonyEricsson, а также для получения технической информации обращайтесь в офис СЭА, тел.: (044) 575-94-00,
E-mail: info@sea.com.ua, сайт www.sea.com.ua.