РЭК :: ТЕХНОЛОГИИ : GSM

  • GSM
  • GPRS
  • GPRS классы
  • GPS
  • FRAM
  • NMEA-0183
  • SiRFXTrac
  • Bluetooth

    • РЭК . ТЕХНОЛОГИИ
    GSM

    Что такое GSM?

    На заре развития сотовой телефонии в мире существовало множество стандартов, не совместимых друг с другом. Америка развивала сети AMPS, Скандинавия - NMT, а Азия, как всегда, выбрала свой путь и сделала ставку на технологию PDC. Крупные страны, такие как Великобритания или Германия, разрабатывали собственные системы. Подобное разнообразие стандартов накладывало существенные ограничения на область действия каждого сотового телефона и создавало лишние проблемы производителям оборудования (следствием чего в том числе были заоблачные цены на абонентские устройства).

    Поэтому еще в 1982 году была сформирована Groupe Speciale Mobile, приоритетной задачей которой являлась разработка общеевропейского стандарта (pan-European public land mobile system) сотовой связи следующего поколения. Причем одним из основных требований к создаваемой системе стало обеспечение максимально простого для пользователя перемещения между различными сетями (не обязательно расположенными в одной стране) с сохранением работоспособности переносного телефона. Технические спецификации новейшей технологии появились в 1990 году, а сеть, построенная на ее основе, приняла первых абонентов год спустя. Думаем, нет нужды говорить, как активно выросли за прошедшие десять лет сотовые системы на основе GSM (теперь эта аббревиатура расшифровывается как Global System for Mobile Communication), - заметим лишь, что в настоящее время их услугами пользуются почти 200 миллионов человек на всех обжитых континентах.


РЭК :: ТЕХНОЛОГИИ : GPRS

  • GPS
  • FRAM
  • NMEA-0183
  • SiRFXTrac
  • Bluetooth

    • РЭК . ТЕХНОЛОГИИ
    GPRS

    Что такое GPRS?

    GPRS - General Packet Radio Service - это своеобразная надстройка над обычной GSM сотовой сетью, которая позволяет передавать данные на существенно более высоких, чем в обычной GSM сети, скоростях. Если в обычной сети можно получить максимум 14,4 Кбит/с, то теоретический максимум в GPRS составляет 171.2 Кбит/с при всех занятых слотах (см. подробнее о GPRS классах). Разумеется, теоретический максимум - он на то и теоретический, чтобы к нему стремиться, но передача данных на скоростях близких к нему вполне возможна, а уж о пресловутых 56К и говорить нечего - дело техники.

    Почему Packet? GPRS - это именно пакетная система передачи данных, функционирующая аналогично с Internet. Весь поток данных отправителя разбивается на отдельные пакеты и затем доставляется получателю, где все пакеты собираются воедино. Разумеется, совсем необязательно, что все пакеты пойдут одним маршрутом.
    Впрочем, пакетная передача данных - не единственное сходство Internet и GPRS. При начале GPRS сессии каждому GPRS терминалу присваивается свой уникальный адрес, что в аналогии с Internet превращает каждое GPRS устройство в отдельный веб-сервер. Протокол GPRS прозрачен для TCP/IP, поэтому интеграция GPRS сети с Internet происходит незаметно для конечного пользователя.

    Для передачи данных, помимо высокоэффективных алгоритмов кодирования используется довольно интересная технология. Терминалу автоматически выделяются неиспользуемые в данный момент времени тайм-слоты, что позволяет оптимизировать загрузку сети. Разумеется, такая схема влечет за собой "плавающие" в зависимости от количества активных абонентов скорости передачи данных у конкретной БС. Частичным решением этой проблемы может быть система приоритетов голосовых и GPRS соединений, которая выстраивается оператором сотовой связи.


РЭК :: ТЕХНОЛОГИИ : FRAM

  • SiRFXTrac
  • Bluetooth

    • РЭК . ТЕХНОЛОГИИ
    FRAM

    Что такое FRAM?

    At the core of Ramtron's FRAM technology are ferroelectric crystals that allow FRAM products to operate like random access memories while supplying nonvolatile data storage.

    When an electric field is applied to a ferroelectric crystal, the central atom moves in the direction of the field. As the atom moves within the crystal, it passes through an energy barrier, causing a charge spike. Internal circuits sense the charge spike and set the memory. If the electric field is removed from the crystal, the central atom stays in position, preserving the state of the memory. Therefore, the FRAM memory needs no periodic refresh and when power fails FRAM memory retains its data. It's fast, and doesn't wear out!

    Memory Basics

    FRAM (Ferroelectric Random Access Memory) offers a unique set of features relative to other memory technologies. Traditional mainstream semiconductor memories can be divided into two primary categories -- volatile and nonvolatile. Volatile memories include SRAM (static random access memory) and DRAM (dynamic random access memory). They share the property that they lose their contents after power is removed from the electronic system. RAM type devices are very easy to use, and are high performing, but they share the annoying quirk of losing their mind when the lights go out.

    Nonvolatile memories do not lose their contents when power is removed. However all of the mainstream nonvolatile memories share a common ancestry that derives from ROM (read only memory) technology. As you might guess, something called read only memory is not easy to write, in fact it's impossible. All of its descendants make it very difficult to write new information into them. They include technologies called EPROM (almost obsolete now), EEPROM, and Flash. ROM based technologies are very slow to write, wear out after being written a small number of times, and use a large amounts of power to write.

    FRAM offers features consistent with a RAM technology, but is nonvolatile like a ROM technology. FRAM bridges the gap between the two categories and creates something completely new -- a nonvolatile RAM.


РЭК :: ТЕХНОЛОГИИ : Bluetooth

    Bluetooth

    Описание технологии Bluetooth

    Bluetooth - это технология, которая призвана заменить традиционное проводное соединение сотового телефона, мобильного компьютера и других периферийных устройств между собой, на более удобное соединение по радио каналу.

    Дословно Bluetooth переводится как "Голубой зуб". Так прозвали когда-то короля викингов Харальда, жившего в Дании около тысячи лет назад. Прозвище это король получил за темный передний зуб. Король Харальд вошел в историю как человек, объединивший Данию и принесший им христианство. Таким образом, именем исторической личности был назван протокол, который, по замыслу его создателей, так же должен творить историю...

    Перейдем к реальным фактам. В начале 1998 года, Ericsson, IBM, Intel, Toshiba и Nokia - крупнейшие компании компьютерного и телекоммуникационного рынка - объединились для совместной разработки технологии беспроводного соединения мобильных устройств. В1998 году, 20 мая, произошло официальное представление специальной рабочей группы (SIG - Special Interest Group), призванной обеспечить беспрепятственное внедрение технологии, получившей название Bluetooth. Вскоре в группу вошли 3COM/Palm, Axis Communication, Motorola, Compaq, Dell, Qualcomm, Lucent Technologies, UK Limited, Xircom. Сейчас группа включает в себя более 1400 компаний, принимающих участие в работе над бесплатной открытой спецификацией Bluetooth. Благодаря простоте и изяществу этой технологии, многие специалисты уверены, что Bluetooth не имеет конкуренции в области создания небольших локальных сетей и беспроводного объединения устройств в пределах дома, офиса или, скажем, машины.

    Идея и первые решения Bluetooth появились в исследовательском центре Ericsson, расположенном в городе Лунд в Швеции. В отличие от технологии инфракрасной связи IrDA (Infrared Direct Access), работающей по принципу "точка-точка" в зоне прямой видимости, технология Bluetooth разрабатывалась для работы, как по принципу "точка-точка", так и в качестве многоточечного радиоканала, управляемого многоуровневым протоколом, похожим на протокол мобильной связи GSM.

    Bluetooth стал конкурентом таким технологиям, как IEEE 802.11, HomeRF и IrDA, хотя последняя и не предназначена для построения локальных сетей, но является самой распространенной технологией беспроводного соединения компьютеров и периферийных устройств.

    Одними из немаловажных параметров новой технологии должны были стать низкая стоимость устройства связи – в пределах 20 долларов, соответственно небольшие размеры (ведь речь идет о мобильных устройствах) и, что немаловажно, совместимость, простота встраивания в различные устройства. Собственно ради этого и была организована группа SIG, которая, помимо всего прочего, позволила множеству производителей объединиться, а не разрабатывать собственные, несовместимые друг с другом платформы. То есть в скором будущем Bluetooth может стать "стандартом де-факто" для беспроводных коммуникаций.

    Анализируя исторические факты, мы можем наблюдать то, что практически за небольшой период времени технология Bluetooth вышла на первое место среди аналогичных технологий.

    Технология беспроводных сетей Bluetooth

    Автор: Алексей Шашков
     Дата: 28.01.2001

      Оглавление

      Вступление
      Установка соединения
      Перспективы

    Вступление

    Bluetooth. Это короткое слово в последнее время всё чаще и чаще мелькает на новостных лентах. Все уже слышали, что это технология беспроводных сетей. Однако, подобные технологии существовали и раньше, но ни одна из них не имела и не имеет такой мощной и всесторонней поддержки, и ни про одну из них столько не говорилось. Что же такого особенного в Bluetooth?

    Само слово Bluetooth можно перевести как "голубой зуб", или "голубая челюсть", что, конечно же, никоим образом не описывает ни сути технологии ни чего-либо ещё. Bluetooth - таким было прозвище датского короля Harald'a BlЕtand'a, сурового викинга который очень давно объединил Данию и Норвегию. Это имя было выбрано в качестве названия технологии потому, что первоначально Bluetooth задумывалась как средство для простого соединения компьютеров и телекоммуникационных устройств, вроде мобильных телефонов.

    Как видно из сегодняшней карты, королевство первого Bluetooth не стало вечным, но современных разработчиков Bluetooth это похоже не пугает. И, как показывает сегодняшняя ситуация, у них есть на это все основания. Разработанная технология оказалось настолько удачной, что похоже на то, что через несколько лет она будет везде, от компьютеров и мобильных телефонов (как и предполагалось первоначально), до холодильников и микроволновых печей (чего первоначально не предполагалось). В общем, даёшь Интернет на кухню!

    А началось всё с того, что в начале 1998 года компании Nokia, Ericsson, IBM, Intel и Toshiba образовали консорциум, который занялся разработкой технологии беспроводной связи, которую назвали Bluetooth. Изначально консорциум был открыт для сотрудничества, и сейчас в Bluetooth SIG (Special Interest Group) Promoters, которая занимается разработкой стандарта, входят 3Com, Ericsson, IBM, Intel, Lucent, Microsoft, Motorola, Nokia, и Toshiba. В настоящее время действует версия 1.0.B спецификации, выпущенная 1 декабря 1999 года. В момент выпуска спецификации было объявленно, что она не является финальной, и финальная спецификация должна выйти ещё через три года. А эти три года должны уйти на "обкатку в боевых условиях". Кроме вышеперечисленных компаний, в группу Bluetooth может абсолютно бесплатно войти любая компания которая планирует производить или разрабатывать устройства и ПО на основе спецификаций Bluetooth. В настоящее в эту группу уже вошли около 2000 компаний самых различных направлений, так что перспективы у Bluetooth действительно неплохие.

    Физически типичное Bluetooth устройство представляет собой радиоприёмник и радиопередатчик, работающие на частотах 2400-2483.5 MHz. Эти частоты выбраны не случайно, они являются открытыми и свободными от всякого лицензирования в большинстве стран мира. Исключение составляют Испания и Франция. До недавнего времени в этой компании присутствовала ещё и Япония, но с октября 1999 года там эта проблема частично решена, и теперь Bluetooth устройства а Японии могут использовать полный спектр радиочастот предусмотренный спецификациями Bluetooth. Хотя, некоторые ограничения в Японии всё ещё остались. В Испании спектр радиочастот разрешённый для использования Bluetooth устройствами ограничен 2445-2475 MHz, во Франции этот спектр ограничен до 2446.5-2483.5 MHz. Поэтому Bluetooth устройства разработанные специально для Франции, Испании или Японии не будут работать совместно с устройствами разработанными для всего остального мира. Соответственно, верно и обратное утверждение. В настоящее время члены Bluetooth консорциума работают с властями этих стран, и есть основания полагать что такая ситуация не продлиться долго.

    Используемые частоты определяют возможности Bluetooth по передаче данных. Ширина канала для Bluetooth устройств составляет 723.2 кб/с в асинхронном режимы (впрочем, даже в этом режиме всё-таки остаётся до 57.6 кб/с для одновременной передачи в обратном направлении), или 433.9 кб/с в полностью синхронном режиме. Если не передаются данные, то через Bluetooth соединение можно передавать до 3 аудиоканалов. Каждый из аудиоканалов поддерживает по 64 кб/с синхронному аудиоканалу в каждом направлении. Кроме этого, возможна и комбинированная передача, данных и голоса.

    Расстояние на которое может быть установлено Bluetooth соединение невелико, и составляет от 10 до 30 метров. В настоящее время ведутся работы над увеличением этого расстояния, хотя бы до 100 метров. Зато даже сейчас для Bluetooth не требуется прямой видимости или какой либо направленной антенны, соединение может быть установлено даже через стену (конечно же, если стена не экранирована).

    Главной особенностью Bluetooth является то, что различные Bluetooth устройства соединяются с друг другом автоматически, стоит им только оказаться в пределах досягаемости. У пользователя не болит голова о кабелях, драйверах, или чём-либо ещё, всё что от него требуется, это позаботиться о том, что бы Bluetooth устройства находились достаточно близко друг к другу, обо всём остальном должны позаботиться сами Bluetooth устройства и программное обеспечение.

    Установка соединения

    Оказавшись рядом, Bluetooth устройства могут устанавливать не только соединения типа точка-к-точка, когда имеется только два устройства, но и точка-к-многоточек, когда одно устройство одновременно работает с несколькими другими. При соединении одного устройства с несколькими другими, устройство которое обслуживает несколько соединений называется master, а подключенные устройства - slave. К одному master'у может быть подключено до семи активных slave. Кроме активных slave (то есть, устройств которые активно обмениваются данными), может существовать множество неактивных slave, которые не могут обмениваться данными с master пока заняты все каналы, но, тем не менее, остаются синхронизированы с ним. Такая структура называется piconet.

    В одной piconet может быть только один master, однако каждый slave может одновременно являться master'ом для других устройств, и образовывать свой piconet. Несколько piconet объединенных таким образом образуют scatternet. В рамках scatternet разные устройства могут не только быть одновременно master и slave одновременно для различных piconet, но и просто slave для разных piconet. Более наглядно с этой структурой можно ознакомиться на представленном ниже рисунке.

    Более того, в случае необходимости любой slave в piconet может стать master. Естественно, старый master при этом становится slave.
    Таким образом, в scatternet могут объединяться столько Bluetooth устройств, сколько необходимо, логические связи могут образовываться так, как это требуется, и могут изменяться как угодно, в случае необходимости. Единственное условие, различные piconet входящие в один scatternet должны иметь разные каналы связи, то есть работать на различных частотах и иметь различные hopping channel. Hopping - это регулярная смена частот, определяемая параметрами hopping sequence. Всего спецификация предусматривает 10 вариантов hopping sequence, 5 с циклом в 79 смен и 5 с циклом в 23 смены. С любым hopping sequence частоты сменяются 1600 hops/sec. Используется hopping для того, что бы бороться с затуханием радиосигнала и интерференцией.

    Как уже говорилось, автоматическая установка соединения между Bluetooth устройствами находящимися в пределах досягаемости является одной из важнейших особенностей Blueooth, поэтому первое, с чего начинается работа Bluetooth устройства в незнакомом окружении - это device discovery, или, по-русски, поиск других Bluetooth устройств. Для этого посылается запрос, и ответ на него зависит не только от наличия в радиусе связи активных Bluetooth устройств, но и от режима в котором находятся эти устройства. На этом этапе возможно три основных режима.

    Discoverable mode. Находящиеся в этом режиме устройства всегда отвечают на все полученные ими запросы.
    Limited discoverable mode. В этом режиме находятся устройства которые могут отвечать на запросы только ограниченное время, или должны отвечать только при соблюдении определённых условий.
    Non-discoverable mode. Находящиеся в этом режиме устройства, как видно из названия режима, не отвечают на новые запросы.

    Но это ещё не всё. Даже если удаётся обнаружить устройство, оно может быть в connectable mode или в non-connectable mode. В non-connectable mode устройство не позволяет настроить некоторые важные параметры соединения, и, таким образом, оно хоть и может быть обнаружено, обмениваться данными с ним не удастся. Если устройство находится в connectable mode, то на этом этапе Bluetooth устройства договариваются между собой об используемом диапазоне частот, размере страниц, количестве и порядке hop'ов, и других физических параметрах соединения.

    Если процесс обнаружения устройств прошёл нормально, то новое Bluetooth устройство получает набор адресов доступных Bluetooth устройств, и за этим следует device name discovery, когда новое устройство выясняет имена всех доступных Bluetooth устройств из списка. Каждое Bluetooth устройство должно иметь свой глобально уникальный адрес (вроде как MAC-адреса у сетевых плат), но на уровне пользователя обычно используется не этот адрес, а имя устройства, которое может быть любым, и ему не обязательно быть глобально уникальным. Имя Bluetooth устройства может быть длиной до 248 байт, и использовать кодовую страницу в соответствии с Unicode UTF-8 (при использовании UCS-2, имя может быть укорочено до 82 символов). Спецификация предусматривает, что Bluetooth устройства не обязаны принимать больше первых 40 символов имени другого Bluetooth устройства. Если же Bluetooth устройство обладает экраном ограниченного размера, и ограниченной вычислительной мощью, то количество символов, которое оно примет может быть уменьшено до 20.

    Ещё одной из важнейших особенностей Bluetooth является автоматическое подключение Bluetooth устройств к службам предоставляемым другими Bluetooth устройствами. Поэтому, после того как имеется список имён и адресов, выполняется service discovery, поиск доступных услуг, предоставляемых доступными устройствами. Получение или предоставление каких либо услуг - это то, ради чего всё собственно и затевалось, поэтому для поиска возможных услуг используется специальный протокол, называемый, как несложно догадаться, Service Discovery Protocol (SDP), более подробно он будет описан ниже.

    Естественно, Bluetooth не могла обойтись без такой важной вещи, как технология защиты передаваемых данных, встроенной в сам протокол. В зависимости от выполняемых задач, предусмотренно три режима защиты в которых может находится устройство.

    Security mode 1 (non secure), устройство не может самостоятельно инициировать защитные процедуры.

    Security mode 2 (service level enforced security), устройство не инициирует защитные процедуры пока не установлено и не настроено соединение. После того как соединение установлено, процедуры защиты обязательны, и определяются типом и требованиями используемых служб.

    Security mode 3 (link level enforced security), защитные процедуры инициируются в процессе установления и настройки соединения. Если удалённое устройство не может пройти требований защиты, то соединение не устанавливается.

    Естественно, что Security mode 3 и 2 могут использоваться вместе, то есть сначала устанавливается защищённое соединение, а потом оно ещё защищается в соответствии с требованиями и возможностями конкретной службы.

    Основой системы безопасности Bluetooth, используемой в Security mode 3, является понятие сеансового ключа, или Bond. Сеансовый ключ генерится в процессе соединения двух устройств, и используется для идентификации и шифрования передаваемых данных. Для генерации ключа могут использоваться самые различные составляющие, от заранее известных обоим устройствам значений, до физических адресов устройств. Комбинируя защиту на уровне соединения с защитой на уровне приложений (где может использоваться абсолютно любая из существующая на сегодня систем защиты данных) можно создавать достаточно надёжно защищённые соединения. Но всё равно, очевидной слабостью Bluetooth соединений с точки зрения построения защищённых соединений остаётся возможность перехвата трафика, причём для этого даже не придётся использовать какое либо специфическое оборудование. Впрочем, эта проблема не нова, и в настоящее время часто приходится использовать открытые сети, вроде Интернет, где возможен перехват трафика, для передачи закрытых данных. Противодействие "брони и снаряда" продолжается.

    Перспективы

    Bluetooth относится к тем технологиям, которые при грамотном использовании могут в самом деле перевернуть весь человеческий быт. Уже сейчас на выставках демонстрируются принтеры с Bluetooth, которые не надо подключать к компьютеру, достаточно просто внести его в комнату, включить в розетку, и можно начинать печатать. То же самое верно и в обратном порядке, достаточно просто войти в комнату с ноутбуком оснащённым Bluetooth в руках, и сразу же можно пользоваться принтером, войти в локальную сеть для обмена файлами и документами, воспользоваться Интернет соединением. RJ-45 розетки для ноутбуков, которые можно встретить в некоторых самолётах и особо продвинутых аэропортах скоро должны отойти в прошлое.

    Несколько иллюстраций с прошедшей в ноябре 2000-го года выставки Comdex Fall:

    Toshiba. Мультимедийный ноутбук, проектор и цифровой фотоаппарат. Всё анонсировано к производству в 2001 году.

    Коллекция полностью безпроводных PDA с расширенными коммуникационными возможностями.

    Комплект оснащения киберпанка будущего - наушники, видеокамера, микрофон, внизу лежит коммуникатор в виде часов. Все работает :-) Связь со станцией по протоколу Bluetooth на расстоянии до 100 метров!

    Системы hands free с использованием Bluetooth становятся настолько просты в использовании, насколько это только возможно. Достаточно что бы мобильный телефон с Bluetooth интерфейсом просто находился где-нибудь внутри автомобиля, а его подключение к hands free системе произойдёт автоматически.

    Стандартизация используемая в Bluetooth, позволит делать беспроводные мыши, клавиатуры, джойстики и геймпады которые будут подходить к любому PC, и что бы начать работу с любимым девайсом достаточно будет просто подойти к компьютеру, а не выключать его, и лазать под стол с проводами. Это оценят не только любители кваковских чемпионатов, которые и сейчас не выходят из дома без своей мышки в кармане. Благодаря той же стандартизации, можно рассчитывать на то, что через несколько лет мы избавимся от той кучи дистанционных пультов на диване, отдельного для телевизора, отдельного для видеомагнитофона, отдельного для музыкально центра, отдельного для DVD проигрывателя, отдельного для кондиционера, и так далее, а будем управлять всей техникой в квартире с мобильного телефона, который к тому же и PDA являться будет. Но и это ещё не предел.

    В последнее время много говорится о концепции "цифрового дома". Некоторые, хорошо известные и весьмя серьёзные корпорации буквально помешались на этом. Технология Bluetooth может поднять эту идею на новую высоту. Представьте себе, у вас имеется брелок (браслет, кольцо, да что угодно), с Bluetooth устройством, способным принимать ваш голос и передавать его на центральный компьютер в доме. Мощный сервер идентифицирует голос, распознает звуковую команду, и по тому же Bluetooth даст команду любой периферии, раскиданной по дому. Таким образом, голосовые команды можно будет давать всему что угодно в доме, телевизорам, лампочкам, шторам, кондиционерам, микроволновым печкам, сливному бачку в туалете, в конце концов! И при этом не будет никакой необходимости, что бы вся эта периферия обладала достаточной вычислительной мощью, для распознания голоса, достаточно что бы подобной мощью обладал любимый компьютер стоящий в доме. Кроме этого, не придётся заботиться о том что бы новый холодильник, к примеру, подключить и настроить под вашу домашнюю сеть, достаточно только убедиться, что холодильник имеет Bluetooth интерфейс. И тогда, только внеся его на кухню и подключив в розетку, можно будет засунуть в него бутылочку пива и скомандовать "что бы через три минуты пиво было холодным!". Домашний сервер, отлично знающий привычки владельца, и давно запомнивший что означает та или иная фраза, немедленно даст команду холодильнику три минуты работать в режиме максимальной заморозки, а через три минуты заботливо напомнит вам, что пиво уже остыло. Более того, командовать своим домом можно будет и через мобильный телефон, практически с любой точки земного шара.

    Это всё, конечно же удобно, но не знаю, согласился бы лично я жить в подобном доме. Это же если сейчас пойманный троян грозит только парой потерянных файлов, то в "цифровом доме" возможны гораздо более "интересные" эффекты. Конечно, прямо сейчас можно придумать с десяток мер, которые сильно затруднят жизнь взломщикам, но как говорилось выше, противодействие брони и снаряда продолжается, и конца этому процессу не будет никогда. Но как, всё-таки, удобно всё может быть, если не принимать во внимание "мелкие технические неполадки".

    Всё это в перспективе. А сегодня, Bluetooth устройства можно встретить в основном только на выставках, или же в продаже, но по ценам, которые никак не могут способствовать их широкому распостранению. Кроме этого, большинство демонстрируемых сегодня Bluetooth устройств не могут похвастаться достаточной универсальностью, то есть они далеко не всегда могут просто обнаружить друг друга, не говоря уже про то, что бы воспользоваться предоставляемыми службами, если заранее не предусмотренно что конкретно ЭТА железка должна работать с конкретно ЭТОЙ. Но ведь это только начало, и как сама технология, так и программное обеспечением будут продолжать совершенствоваться, и когда-нибудь, может быть даже совсем скоро, то что сегодня кажется дикой фантастикой станет реальностью.

    В статье использованы материалы сайтов:


РЭК :: ТЕХНОЛОГИИ : GPRS классы и схемы кодирования

    GPRS классы и схемы кодирования

    GPRS сеть (пакетная система передачи данных) поддерживает четыре схемы кодирования каналов передачи данных:

    Схема кодирования | CS-1 | CS-2 | CS-3 | CS-4
Pre-cod. USF | 3 | 6 | 6 | 12
Информационных бит без USF | 181 | 268 | 312 | 428
Битов четности BC | 40 | 16 | 16 | 16
Битов завершения | 4 | 4 | 4 | -
Output conv encoder | 456 | 588 | 676 | 456
Punctured bits | 0 | 132 | 220 | -
Схема кодирования | 1/2 | ~2/3 | ~3/4 | 1
Скорость данных, kbit/s | 9.05 | 13.4 | 15.6 | 21.4
Максимальная скорость передачи данных через 8 тайм-слотов | 72.4 kb/s | 107.2 kb/s | 124.8 kb/s | 171.2 kb/s

    Выбор схемы кодирования зависит от канала связи предоставлямого оператором сети GSM, определяемым качеством соединения модема с базовой станцией. Если канал связи с шумами/помехами, то для надежного обмена данными сеть может использовать схему CS-1. В этом случае скорость обмена не более 9.05 kbit/s в одном используемом GSM тайм-слоте. Если канал связи обеспечивает уверенный прием/передачу, то сеть может использовать схему CS-3 или CS-4 для достижения оптимальной скорости до 21.4 kbit/s в одном GSM тайм-слоте.

    Перечень мульти-слотовых классов (multislot classes):
    Класс | Прием | Передача | Максимальное количество используемох тайм-слотов
1 | 1 | 1 | 2
2 | 2 | 1 | 3
3 | 2 | 2 | 3
4 | 3 | 1 | 4
5 | 2 | 2 | 4
6 | 3 | 2 | 4
7 | 3 | 3 | 5
8 | 4 | 1 | 5
9 | 3 | 2 | 5
10 | 4 | 2 | 5
11 | 4 | 3 | 5
12 | 4 | 4 | 5
13 | 3 | 3 | неограничено
14 | 4 | 4 | неограничено
15 | 5 | 5 | неограничено
16 | 6 | 6 | неограничено
17 | 7 | 7 | неограничено
18 | 8 | 8 | неограничено
19 | 6 | 2 | неограничено
20 | 6 | 3 | неограничено
21 | 6 | 4 | неограничено
22 | 6 | 4 | неограничено
23 | 6 | 6 | неограничено
24 | 8 | 2 | неограничено
25 | 8 | 3 | неограничено
26 | 8 | 4 | неограничено
27 | 8 | 4 | неограничено
28 | 8 | 6 | неограничено
29 | 8 | 8 | неограничено


РЭК :: ТЕХНОЛОГИИ : GPS

    GPS

    Что такое GPS?

    GPS - начальные буквы названия глобальной системы определения координат - Global Positioning System. Эта система позволяет с точностью не хуже 100 м определить местоположение объекта, т.е. определить его широту, долготу и высоту над уровнем моря, а также направление и скорость его движения. Кроме того, с помощью GPS можно определить время с точностью до 1 наносекунды.

    GPS состоит из совокупности определенного количества искусственных спутников Земли (спутниковой системы NAVSTAR) и наземных станций слежения, объединенных в общую сеть. В качестве абонентского оборудования служат индивидуальные GPS-приемники, способные принимать сигналы со спутников и по принятой информации вычислять свое местоположение. В состав спутниковой системы NAVSTAR входят 24 ИСЗ, находящихся на 6 различных круговых орбитах, которые расположены под углом 60 градусов друг к другу. Период обращения одного спутника - 12 часов. Вес каждого спутника около 787 кг, размер более 5 м, включая солнечные батареи. На борту каждого спутника установлены атомные часы, обеспечивающие точность 10 в - 9 степени сек, вычислительно кодирующее устройство и передатчик мощностью 50 Вт, излучающий на частоте 1575.42 МГц.

    Рождением NAVSTAR можно считать февраль 1978 года, когда на орбиту был выведен первый спутник системы. Средний срок службы одного спутника приблизительно 10 лет, поэтому в программу входит постоянное производство и выведение на орбиту новых спутников, на смену использовавшим свой ресурс. Стоимость постройки и запуска 24 спутников - 12 миллиардов долларов.


РЭК :: ТЕХНОЛОГИИ

    • РЭК . МОБИЛЬНЫЕ ТЕХНОЛОГИИ

  • GSM, глобальная система мобильных коммуникаций.
  • GPRS, система пакетной передачи данных.
  • GPS, система глобального позиционирования.
  • FRAM, технология ферромагнитных кристаллов применяется в элементах памяти низкого энергопотребления.
  • NMEA-0183, описывается стандарт передачи данных GPS. NMEA предложения формата GGA, GLL, GSA, GSV, RMC, VTG и ZDA несут разнородную информацию о времени, дате, координатах, курсе и других параметрах местонахождения системы и видимых спутниках. GPS приемники Falcom могут быть настроены так чтобы Ваша система могла получать только требуемую информацию (NMEA предложения) с заданным интервалом или по запросу.
  • SiRFXTrac, новая технология повышения чувствительности GPS приемника позволяет определять местоположения системы в местах где традиционные системы не способны работать - карьер, улица с высокими и близкорасположенными зданиями, под навесом, в лесу и т.п.
  • GPRS, классы и схемы кодирования, описание классов GPRS модемов и используемых схем кодирования.
  • Bluetooth, это технология, которая призвана заменить традиционное проводное соединение сотового телефона, мобильного компьютера и других периферийных устройств между собой, на более удобное соединение по радио каналу.


РЭК :: ТЕХНОЛОГИИ : NMEA-0183 v2.1

    NMEA-0183 v2.1

    Описание протокола NMEA-0183 версии 2.1

    NMEA – это формат передачи сообщений между корабельными приборами. Он включает в себя систему сообщений для обмена информацией между навигационными GPS приёмниками и потребителями навигационной информации. Все команды и сообщения передаются в текстовом ASCII виде, относящиеся к GPS приёмникам начинаются с $GP, в конце строки сообщения должны быть символы <CR><LF>. В последнем поле сообщения может быть указана контрольная сумма текущего сообщения, начинающаяся с разделителя *. Контрольная сумма 8 – ми битная (исключающая ИЛИ) всех символов сообщения, включая пробелы, расположенных между разделителями $ и *, не включая последних. Шестнадцатеричный результат переводится в два ASCII символа (0-9, A-F).

    Содержание некоторых сообщений протокола NMEA версии 2.1

  • $GPGGA Сообщение содержит GPS данные о местоположении, времени местоопределения, качестве данных, количестве использованных спутников, HDOP (Фактор Ухудшения Точности Плановых Координат), информацию о дифференциальных поправках и их возраст.
  • $GPGLL Сообщение содержит GPS–данные о географической широте, долготе и времени определения координат.
  • $GPGSA В этом сообщении отображается режим работы GPS приёмника, параметры спутников, используемых при решении навигационной задачи, результаты которой отображены в сообщении $GPGGA и значения факторов точности определения координат.
  • $GPGSV В сообщении указывается количество видимых спутников, их номера, возвышение, азимут, и значение отношения сигнал/шум для каждого из них.
  • $GPRMC Сообщение RMC содержит данные о времени, местоположении, курсе и скорости, передаваемые навигационным GPS приёмником. Контрольная сумма обязательна для этого сообщения, интервалы передачи не должны превышать 2 секунды. Все поля данных должны быть подготовлены, пока ещё нет самих данных. Недействительные поля могут быть использованы, пока данные временно не готовы.
  • $GPVTG Сообщение VTG передает текущее истинное направление курса (COG) и скорость относительно земли (SOG).
  • $GPZDA Сообщение ZDA содержит информацию о времени по UTC, календарный день, месяц, год и локальный часовой пояс.

    • GGA - GPS Данные о местоположении

     | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11 | 12 | 13 | 14 15
$GPGGA, | hhmmss.ss, | 1111.11, | a, | yyyyy.yy, | a, | x, | xx, | x.x, | xxx, | M, | x.x, | M, | x.x, | xxxx*hh

    1. Гринвичское время на момент определения местоположения.

    2. Географическая широта местоположения.

    3. Север/Юг (N/S).

    4. Географическая долгота местоположения.

    5. Запад/Восток (E/W).

    6. Индикатор качества GPS сигнала:

    0 = Определение местоположения не возможно или не верно;

    1 = GPS режим обычной точности, возможно определение местоположения;

    2 = Дифференциальный GPS режим, точность обычная, возможно определение местоположения;

    3 = GPS режим прецизионной точности, возможно определение местоположения.

    7. Количество используемых спутников (00-12, может отличаться от числа видимых).

    8. Фактор Ухудшения Точности Плановых Координат (HDOP).

    9. Высота антенны приёмника над/ниже уровня моря.

    10. Единица измерения высоты расположения антенны, метры.

    11. Геоидальное различие - различие между земным эллипсоидом WGS-84 и уровнем моря(геоидом), ”-” = уровень моря ниже эллипсоида.

    12. Единица измерения различия, метры.

    13. Возраст Дифференциальных данных GPS - Время в секундах с момента последнего SC104 типа 1 или 9 обновления, заполнено нулями, если дифференциальный режим не используется.

    14. Индификатор станции, передающей дифференциальные поправки, ID, 0000-1023.

    15. Контрольная сумма строки.

    Пример сообщения:
    $GPGGA,004241.47,5532.8492,N,03729.0987,E,1,04,2.0,-0015,M,,,,*31

    GLL - географическое положение — Широта/Долгота

     | 1 | 2 | 3 | 4 | 5 | 6 7 |
$GPGLL, | 1111.11, | a, | yyyyy.yy, | a, | hhmmss.ss, | A*hh | <CR><LF>

    1. Географическая широта местоположения.

    2. Север/Юг (N/S).

    3. Географическая долгота местоположения.

    4. Запад/Восток (E/W).

    5. Гринвичское время на момент определения местоположения.

    6. Статус A = данные верны
    V = данные не верны

    7. Контрольная сумма строки.

    Пример сообщения:
    $GPGLL,5532.8492,N,03729.0987,E,004241.469,A*33

    GSA - GPS факторы точности и активные спутники

    В этом сообщении отображается режим работы GPS приёмника, параметры спутников, используемых при решении навигационной задачи, результаты которой отображены в сообщении $GPGGA и значения факторов точности определения координат.

     | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11 | 12 | 13 | 14 | 15 | 16 | 17 18 |
$GPGSA, | a, | x, | xx, | xx, | xx, | xx, | xx, | xx, | xx, | xx, | xx, | xx, | xx, | xx, | x.x, | x.x, | x.x*hh | <CR><LF>

    1. Режим: M = Ручной, принудительно включен 2D или 3D режим;
    A = Автоматический, разрешено автомат. выбирать 2D/3D.

    2. Режим: 1 = Местоположение не определено, 2 = 2D, 3 = 3D

    3-14. PRN номера спутников, использованных при решении задачи местоопределения (нули для неиспользованных).

    15. Фактор PDOP.

    16. Фактор HDOP.

    17. Фактор VDOP.

    18. Контрольная сумма строки.

    Пример сообщения:
    $GPGSA,A,3,01,02,03,04,,,,,,,,,2.0,2.0,2.0*34

    GSV - видимые спутники GPS

    В этом сообщении отображается число видимых спутников(SV), PRN номера этих спутников, их высота над местным горизонтом, азимут и отношение сигнал/шум. В каждом сообщении может быть информация не более чем о четырех спутниках, остальные данные могут быть расположены в следующих по порядку $GPGSV сообщениях. Полное число отправляемых сообщений и номер текущего сообщения указаны в первых двух полях каждого сообщения.

     | 1 | 2 | 3 | 4 | 5 | 6 | 7 8 15 | 16 | 17 | 18 | 19 20 |
$GPGSV, | x, | x, | xx, | xx, | xx, | xxx, | xx..........., | xx, | xx, | xxx, | xx*hh | <CR><LF>

    1. Полное число сообщений, от 1 до 9.

    2. Номер сообщения, от 1 до 9.

    3. Полное число видимых спутников.

    4. PRN номер спутника.

    5. Высота, градусы, (90° - максимум).

    6. Азимут истинный, градусы, от 000° до 359°.

    7. Отношение сигнал/шум от 00 до 99 дБ, ноль - когда нет сигнала.

    8-11. Тоже, что в 4-7 для второго спутника.

    12-15. Тоже, что в 4-7 для третьего спутника.

    16-19. Тоже, что в 4-7 для четвертого спутника.

    20. Контрольная сумма строки.

    Пример сообщения:
    $GPGSV,3,1,12,02,86,172,,09,62,237,,22,39,109,,27,37,301,*7A
    $GPGSV,3,2,12,17,28,050,,29,21,314,,26,18,246,,08,10,153,*7F
    $GPGSV,3,3,12,07,08,231,,10,08,043,,04,06,170,,30,00,281,*77

    RMC – pекомендуемый минимум GPS / навигационных данных

     | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11 | 12 |
$GPRMC, | Hhmmss.ss, | A, | 1111.11, | A, | yyyyy.yy, | a, | x.x, | x.x, | ddmmyy, | x.x, | A | *hh | <CR><LF>
    1. Время фиксации местоположения UTC
    2. Состояние: А = действительный, V = предупреждение навигационного приёмника
    3. Географическая широта местоположения
    4. Север/Юг (N/S)
    5. Географическая долгота местоположения
    6. Запад/Восток (E/W)
    7. Скорость над поверхностью (SOG) в узлах
    8. Истинное направление курса в градусах
    9. Дата: dd/mm/yy
    10. Магнитное склонение в градусах
    11. Запад/Восток (E/W)
    12. Контрольная сумма строки (обязательно)

    Пример сообщения:
    $GPRMC,113650.0,A,5548.607,N,03739.387,E,
    000.01,255.6,210403,08.7,E*69

    VTG – истинное направление курса и скорость относительно земли
     | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 |
$GPVTG, | x.x, | T, | x.x, | M, | x.x, | N, | x.x, | K, | i, | *hh | <CR><LF>
    1. Направление курса в градусах, T
    2. Направление курса в градусах, T
    3. Магнитное склонение в градусах, М
    4. Магнитное склонение в градусах, М
    5. Скорость над поверхностью (SOG) в узлах, N = узлы
    6. Скорость над поверхностью (SOG) в узлах, N = узлы
    7. Скорость над поверхностью (SOG) в км/ч, К = км/ч
    8. Скорость над поверхностью (SOG) в км/ч, К = км/ч
    9. Контрольная сумма строки (обязательно)
    10. Контрольная сумма строки (обязательно)

    Пример сообщения:
    $GPVTG,217.5,T,208.8,M,000.00,N,000.01,K*4C

    ZDA – время и дата

     | 1 | 2 | 3 | 4 | 5 | 6 | 7 |
$GPZDA, | hhmmss.s, | xx, | xx, | xxxx, | xx, | xx | *hh | <CR><LF>
    1. Время UTC
    2. День (01до 31)
    3. Месяц (01 to 12)
    4. Год
    5. Часовой пояс, смещение от GMT, от 00 до ± 13 часов
    6. Часовой пояс, смещение от GMT, минуты
    7. hh Контрольная сумма строки

    Пример сообщения:
    $GPZDA,172809,12,07,1996,00,00*45


РЭК :: ТЕХНОЛОГИИ : SirfTrac

    SirfTrac

    SiRFTrac

    новые технологии программирования SiRF улучшают качество определения GPS координат и чувствительность приема сигнала GPS спутников, где применение традиционных SiRF GPS приёмников безуспешно

    SAN JOSE, Calif., Oct 28, 2002 - SiRF Technology, Inc. today unveiled a new high sensitivity GPS software that will extend the operating range in which GPS can be used, dramatically increasing the versatility of GPS-enabled consumer products such as personal digital assistants (PDAs). The result is that mobile consumers can continue using their GPS-enabled products in far more locations than ever before possible.

    The SiRFXTrac software enables the highly popular SiRFStarIIe/LP chipset to acquire, and continue tracking GPS signals at far lower signal levels than is currently possible with competitive autonomous GPS solutions. For the user, this means that GPS can now be used in environments previously deemed inaccessible - environments such as urban canyons, parking garages, dense foliage, multi-level freeways, and, in some cases, indoors. By expanding the number of areas in which GPS can get a position fix, SiRFXTrac will improve existing location- based applications and enable new ones that have been impractical until now.

    MEW Integrates SiRFXTrac Into Compact Flash

    Already, Matsushita Electric Works (MEW), with whom SiRF has numerous other strategic alliances, has developed and is shipping a compact flash GPS attachment loaded with SiRFXTrac for the PDA market.

    "SiRFXTrac opens up new applications for PDA manufacturers and other consumer product manufacturers alike: if you're offering a mobile device or a consumer application, this software will improve the user experience. It's as simple as that," according to J. Gerry Purdy, Ph.D. of MobileTrax, a market research firm in Cupertino, CA.

    "We believe that improved GPS tracking is appealing to customers, especially when combined with content-rich map data and consumer applications," according to Robert Gourdine, director of marketing for Navigation Technologies, the leader in navigational mapping software.

    About SiRF

    SiRF Technology, Inc. develops and markets semiconductor and software products designed to enable location-awareness in high-volume mobile consumer devices and commercial applications. Location-awareness refers to the ability of a device to determine and make use of the information regarding its location. SiRF's products enable a range of devices to utilize GPS to detect location. They have been integrated into mobile consumer devices, such as automobile navigation systems, cellular phones, GPS-based mobile computing peripherals and handheld GPS navigation devices, as well as into commercial applications, such as property tracking devices and fleet management systems. SiRF markets and sells its products in four target markets: wireless handheld, automotive, mobile computing, and embedded consumer applications.

    SiRF, SiRFstar, and the SiRF logo are registered trademarks of SiRF Technology, Inc. All other trademarks are the property of their respective owners.

    For additional information, please visit www.sirf.com