Домены - введение

Регистрация доменных имен. Часть 1: немного теории.

Август 2001.

Предупреждение: все течет, все меняется, поэтому что-то могло измениться со времени написания этих статей (ссылки, IP-адреса, процедуры). Найдете несовпадения – пишите мне, постараюсь исправить статьи, хоть и не обещаю. Ругать меня – бесполезно. Нужна помощь – пишите, постараюсь помочь. Что-то не понимаете – перечтите пять раз первую статью и ту, которую не понимаете, прежде чем мне писать. Теперь приступим...

Данная статья открывает собой небольшой цикл статей на тему "Регистрация доменного имени". Будут рассмотрены многие вопросы: зачем вообще это надо, как выбрать имя, каким способом можно его зарегистрировать, что для этого нужно знать, сколько это будет стоить, какие есть в этом процессе подводные камни, и другие сопутствующие вопросы. Также будут даны пошаговые описания процессов регистрации доменных имен.

Сначала оговорим, кому нужен этот цикл. Если у вас есть деньги и вы готовы заплатить сторонней фирме за регистрацию имени для сайта, то так и сделайте - головной боли меньше. А если вы хотите знать сам процесс, или у вас есть здоровое чувство любопытства, чтобы хотеть сделать это самому, а также вы не хотите переплачивать и хотите быть уверены, что имя будет зарегистрировано именно на вас, а не на фирму-посредника, то — читайте дальше :)

В этой статье мы узнаем некоторые общие понятия; поймем, зачем нам, собственно, нужно доменное имя; узнаем, что на ru, com, net и org свет клином не сошелся; выберем себе имя; научимся проверять, занято оно уже кем-то другим или нет.

Итак, первым делом рассмотрим, что такое, собственно, "доменное имя" (от английского "domain name"). Все знают, что адреса различных сайтов выглядят примерно как www.company.ru. В данном случае доменным именем первого уровня (от английского "top level domain") будет "ru" (оно часто также называется "домен" и "зона"), а доменным именем второго уровня будет являться "company". Вот это доменное имя второго уровня и будет нас интересовать в течение всего цикла. Доменные имена третьего уровня выделяются, как правило, бесплатно, особого интереса для нас не имеют, поэтому упоминаться не будут, за исключением доменов .com.ru, .net.ru, .org.ru, .pp.ru, - они выдаются РосНИИРОСом бесплатно, но практически приравнены к домену .ru и поэтому я опишу процесс регистрации доменного имени в этих зонах в следующих статьях. Также в дальнейшем я упомяну и процесс регистрации в зонах .msk.ru и .spb.ru - они являются практически аналогами зон .com.ru и т.д., только делегируются Релкомом.

Прошу учесть, что имя сайта и то, где он находится – вещи разные. Сайт может находиться у вашего провайдера или на каком-нибудь бесплатном сервере, - главное, чтобы они поддерживали такую услугу, как виртуальный хостинг (что это такое, я расскажу в следующей статье). При регистрации доменного имени нужно будет просто правильно указать настройки, и ваш сайт станет доступен по зарегистрированному имени. Часто предлагается регистрация доменного имени вместе с хостингом, то есть для вас регистрируют доменное имя и предоставляют место для расположения вашего сайта (это и называется хостингом). Не менее часто последнее время предлагают зарегистрировать доменное имя бесплатно, если вы согласны платить за хостинг. Так как нас интересует только регистрация доменного имени (хостинг мы себе и сами найдем), то вопрос о бесплатной регистрации доменных имен с платным хостингом мной затрагиваться не будет.

Зачем нужно регистрировать себе доменное имя второго уровня, тем более что это практически всегда стоит денег, если можно бесплатно получить имя третьего уровня, или вообще обойтись адресом, выданным провайдером, нечто типа home.provider.ru/~moya_stranica/? Попытаюсь ответить на этот вопрос. Во-первых, улучшается запоминаемость адреса вашего сайта. Его легко запомнить, увидев на визитке или в рекламе. Его легко продиктовать. Как следствие, если на нем есть ценная или интересная информация, посетитель вернется к нему, даже через неделю вспомнив его адрес, и порекомендует друзьям. Во-вторых, это дает независимость от вашего провайдера и от служб, предоставляющих бесплатные услуги для размещения сайтов. Просто при необходимости переносите сайт и изменяете настройки доменного имени. В-третьих, если вы регистрируете адрес для коммерческой структуры, то пользователь быстрей найдет вас, если знает ваше название и оно совпадает с названием сайта. При поиске информации большинство людей набирает сначала www.имя_компании.ru (www.имя_компании.com), а уже потом идет на поисковые сайты. Также ваши конкуренты не смогут использовать против вас или с выгодой для себя имя сайта, размещая там стороннюю информацию. В-четвертых, свое доменное имя укрепляет имидж и солидность, как компании, так и простого человека, если он имеет свой сайт. Отсутствие у сайта собственного доменного имени часто трактуется посетителями сервера как нехватка у его хозяев средств на регистрацию - соответствующее отношение у них (посетителей) и сложится по отношению к фирме. В-пятых, можно будет иметь почтовый адрес что_угодно@ваше_имя.ru - тоже неплохо. Например, если фирма называется "Эктако" и имеет сайт www.ectaco.ru, то можно будет настроить много почтовых адресов: webmaster@ectaco.ru, julian@ectaco.ru, и т.п.

Итак, мы все обдумали и решили, что мы уже взрослые и свое доменное имя нам зарегистрировать надо. Уясним же теперь одну не очень приятную вещь - это всегда стоит денег. Иногда больше, иногда меньше - в зависимости от престижности домена первого уровня, в котором вы будете регистрировать себе имя. Так, зарегистрировать и ежегодно платить за имя в зоне "ru" будет стоить 24 у.е. (с учетом НДС), а в зоне "tv" - 150 у.е. В других зонах это может быть дешевле, а может и дороже. Системы оплаты могут быть разными. Где-то принимают оплату через кредитную карту, где-то через банк интернет-платежей PayPal, где-то переводом.

Кто-то может возразить, что есть сайты, типа www.namezero.com, www.namezero.ru, и www.emeisp.com, дающие доменные имена бесплатно. Да, они дают их бесплатно. Но, во-первых, регистрируют они их на себя, а не на вас, во-вторых, как правило, крутят на вашей странице рекламу, а, в-третьих, они могут после раскрутки вами адреса отказать вам в обслуживании и предложить выкупить раскрученное доменное имя вам же либо кому-нибудь еще за кругленькую сумму. Оно вам надо? К тому же, так как сервис бесплатный, он может в любой момент либо закрыться без предупреждения, либо стать платным. Впрочем, бесплатная регистрация доменных имен - тема отдельная и достаточно интересная, поэтому обязательно будет освещена мной в отдельной статье.

Но не все так плохо. Есть такие неплохие и вместе с тем бесплатные зоны, как .com.ru / .net.ru / .org.ru / .pp.ru / .spb.ru / .msk.ru. О них я расскажу в первую очередь, ибо у простого российского человека денег на платный домен может и не быть.

Теперь займемся выбором зоны, в которой будем регистрировать себе доменное имя. Немногие знают, что этих самых зон очень много, и имя можно себе составить - пальчики оближешь! Ну например, очень даже запросто можно получить имя domashnee.tv, piratskie.cd, europaplus.fm, krutoy.dj, dukenukem.md, i_love.ms, doloi.ie, legko.li, trud.no, hate.is, fig.im, moy_vysokiy.iq, idi.na, da.nu, windows98.se. Я уж молчу про адреса типа bazara.net, anekdotov.net, perevodov.net, referatov.net, deneg.net (правда, именно эти имена уже заняты, хотя, например, насчет имени mozgov.net я не знаю, может и свободно пока что). Да что там! Сейчас писать на заборах "Машка - дура!" уже не модно. Гораздо интереснее раздать её друзьям адрес сайта mashka.co.za, разместив там соответствующую информацию. Для не очень сведущих в компьютерной терминологии поясняю - названия некоторых зон выглядят очень похожими на распространенные сокращения. Например, сочетание "md" расшифровывается как "must die" (должен умереть), "ms" - Microsoft, "ie" - "Internet Explorer", "se" - "special (или second) edition", "iq" - "intelligence quotient" (коэффициент интеллекта). Сокращения "tv", "fm", "cd", "dj", думаю, расшифровывать не надо, а "co.za" при произношении звучит как русское слово "коза". Список всех зон (доменных имен первого уровня) с указанием, какая зона какой стране принадлежит, а также с ссылками (по возможности) на сервисы "whois" можно было просмотреть 25 августа 2001 г. по адресам http://www.host4u.co.za/codes.htm и http://www.norid.no/domreg.html

Не все зоны доступны для непосредственной регистрации. Например, к великому разочарованию многих товарищей (точнее, господ), адрес tipa.au зарегистрировать просто не получится. Почему - объясняю. Существуют так называемые общемировые зоны. Это com, net, org, edu, mil, gov, произошедшие соответственно от COMmercial (или COMmon), NET (сеть), ORGanization, EDUcation, MILitary, GOVernment. Взяв эти зоны за пример, многие держатели зон, в том числе и au, создали такие подзоны в своих доменах. Таким образом, для регистрации доступны только зоны типа com.au, co.uk, co.jp, co.za, и т.п. То есть, если быть точным, вы регистрируете себе доменное имя уже третьего, а не второго, уровня. Но так как по смыслу они приравнены ко второму уровню, я различий делать в статье не буду, вы же просто примите эту информацию к сведению. Наиболее полный список доступных зон я нашел по адресу http://www.allwhois.com/alltlds.html (см.рис.1). Тут же можно посмотреть, какие зоны доступны для регистрации в них доменных имен и по каким примерно ценам (см.рис.2).

Хочу предупредить: в некоторых зонах регистрировать имена можно только резидентам, то есть тем, кто проживает или зарегистрирован (для фирм) или хотя бы имеет представителя в той стране, которой принадлежит зона. Это, в частности, относится к зоне .is (Исландия). Но не всё так мрачно — во-первых, с помощью того же интернета можно обзавестись друзьями в нужной стране, которые помогут, либо, во-вторых, можно всё же воспользоваться посредническими услугами фирм-регистраторов — другого выхода просто может и не быть.

Теперь приступим к выбору собственно самого имени. Если вы регистрируете его для коммерческой организации, то выбор, как правило, невелик - либо аббревиатура (сокращение по первым буквам), либо полное название, либо частично сокращенное. Примеры: krf.ru - КарелРыбФлот, aura.ru - компьютерная фирма "Аура", compumir.ru - сеть магазинов "Компьютерный мир". Хотя иногда и в этом случае приходится напрягаться - если имя уже занято. Тогда можно либо подобрать укороченное звучание названия фирмы, либо выбрать другую зону, благо их доступно более чем. Для частного лица можно основываться на фамилии / имени / интернетовском никнейме, или придумать что-нибудь примечательное. Например, существует такой сайт - divanov.net. О чем вы подумаете в первую очередь? Правильно - о том, что по этому адресу находится интернет-магазин по продаже диванов. На самом деле там и правда находится интернет-магазин, но продает он, во-первых, не только диваны, а во-вторых, носит такое имя не из-за них, а потому, что директор магазина - Дмитрий Иванов. Вот где выразился полет фантазии! Еще один из последних писков моды - имена типа gromko.ru, mnogo.ru, и иже с ними. Еще можно использовать в имени некоторые сокращения - 4u, 4all, 2u, и тому подобные (4u по-английски звучит как "for you", т.е. "для тебя"). Пример такого имени - monitor4u. Также запоминающимся будет адрес, в смысловом содержании которого задействовано и имя первого уровня (зона). Несколько таких примеров я приводил выше, но приведу еще один (очень уж он мне понравился). В ближайшее время собирается появиться еще одна зона - "eu", для европейских стран, содружеств, и сообществ. Так вот, весьма прикольно звучит адрес yahoo.eu: (Для тех, кто не сообразил сразу - прочитайте "yahoo" вслух по правилам английского языка, а "eu" - как "ею", и все поймете). Хотя вряд ли европейские координаторы дадут вам зарегистрировать такой домен - "Yahoo" уже давно является зарегистрированной торговой маркой. Рекомендую, кстати, продумать несколько названий для сайта - если один из адресов занят, можно будет использовать для регистрации альтернативный.

Сделаю небольшое отступление касательно недавно появившейся услуги по регистрации доменных имен на кириллице (на русском языке). В общем и целом я согласен с Артемием Лебедевым, который написал в своем ру.ководстве соответствующий параграф и назвал его "Спасайся кто может". Вкратце - не рекомендуется регистрация доменного имени на русском языке, потому что его невозможно набрать тому, у кого нет русской клавиатуры, из-за чего посещать такой сайт будут в основном жители России и ближнего русифицированного зарубежья. Еще одна проблема - возможность чередования русских и латинских букв в имени сайта. Например, одно написание - WWW.IBM.COM, второе - WWW.IВМ.COM. В чем разница? В том, что во втором случае латинские буквы "b" и "m" заменены на русские "в" и "м". Вот и попробуй тут догадайся, что набирать и куда при этом попадешь... В общем, как сказал А.Лебедев, в данном случае "СОМ - это не рыба такая, это домен", так что тему регистрации доменных имен на русском языке на ближайшее время закроем.

Ну вот, напридумывали мы себе имен всяких-разных. Теперь надо бы проверить, не заняты ли они, и узнать, во сколько обойдется их регистрация. Тут-то нас и поджидают несколько подводных камней, начиная с того, что вы рискуете переплатить лишних 50-100 баксов при регистрации, и заканчивая тем, что, воспользовавшись нечестной службой проверки, вы лишитесь своего адреса, не успев его зарегистрировать. Рассмотрим все это подробнее.

Сервис проверки занятости имени обычно называют "whois". Предоставляют его чаще всего те фирмы, которые занимаются регистрацией этих имен. Вот здесь и могут возникнуть проблемы. Если вы воспользуетесь сервисом на сайте какой-либо регистрирующей фирмы, а не на сайте держателя зоны, то вполне может оказаться, что ваше имя зарегистрирует эта фирма, чтобы впоследствии предложить его для выкупа вам или кому-нибудь другому по завышенной цене. Современные технологии вполне позволяют вести на сайте журнал запросов проверяемых доменных имен. После этого не составляет никакого труда просмотреть этот журнал, отобрать наиболее значимые и примечательные имена и зарегистрировать их. В следующий раз при проверке или при попытке регистрации имени вам будет выдана информация, что этот домен уже зарегистрирован, и будет указана контактная информация. При попытке связаться по указанным координатам вы получите предложение выкупить домен. Причем сама фирма-регистратор может оказаться и не очень-то виноватой - журналом проверок имен может воспользоваться какой-нибудь один недобросовестный сотрудник, который передаст его друзьям на стороне, и уже те зарегистрируют его. Фирма-регистратор, где вы проверяли имя, окажется как бы и ни при чем, но имя-то для вас будет уже потеряно. Поэтому я рекомендую всегда пользоваться для проверки занятости имени сайтами держателей доменов первого уровня. Обманывать вас носитель домена не должен - зачем ему это, если и без того вся власть по управлению имен у него в руках. С другой стороны, лично я слышал жалобы на Network Solutions (одна из старейших и навороченнейших контор по регистрации доменов в зонах com/net/org) по поводу киберсквоттинга (перехвата доменных имен)...

Приступим, наконец, к проверке. Для зоны "ru" проверять занятость имени можно на www.nic.ru. Там же можно проверить и занятость имен в зонах com, net, org. Свободность имен в зонах .com.ru, .org.ru, .net.ru, .pp.ru можно проверить на сайте РосНИИРОС. Определить адрес носителя домена можно попытаться двумя способами. Обычно адрес такого сайта соответствует названию зоны и выглядит как www.nic."зона" либо www."зона". К примеру: www.nic.ru, www.cd, www.nic.is, и т.п. Если это не помогает, советую заглянуть по адресу http://www.host4u.co.za/codes.htm - там дан список всех зон со ссылками на сайты их держателей, если таковые (сайты) имеются. Можете также зайти на уже упоминавшийся сайт AllWhois – там тоже есть возможность перехода на сайт с сервисом whois для выбранного домена (см.рис.3). Так что берите список придуманных имен - и вперед, приступайте к проверке! Правда, предупреждаю сразу: к сожалению, не все ссылки на сайте AllWhois правильные, так что иногда придется поискать нужный сайт ручками. Могу еще посоветовать хороший сайт проверки существования доменных имен www.domainwhitepages.com - можно посмотреть любой домен в любой зоне. Однако, пользуясь им, помните про возможность перехвата информации...

Напоследок приведу пару примеров возможных "подводных камней".

Первый пример иллюстрирует, каким образом можно заплатить лишние деньги за регистрацию. Есть такой сайт — www.dot.am. Они предлагают зарегистрировать доменное имя в зоне "am" (Армения), упирая на то, что это имя очень подходит для радиостанций, вещающих на данной длине волны. Ну то, что эта зона создана для Армении, а не для поддержки владельцев радиостанций, не так уж и важно. А вот то, что за регистрацию они просят $300, тогда как на сайте Армении (www.amnic.net) вы можете сделать то же самое за $250 - уже интереснее, ведь 50 баксов на дороге не валяются.

Второй пример – перехват доменного имени. Одного человека попросили помочь зарегистрировать доменное имя для сайта о Соловецких островах solovki.ru, причем это было не к спеху. Откуда произошла утечка информации, до сих пор неясно: то ли человек сболтнул где-то, то ли он как раз воспользовался левым сервисом whois, но через два дня оказались занятыми имена solovki.ru и solovki.com, то есть имена в самых распространенных зонах. После того, как мы обратились к людям, на которых оказались зарегистрированы эти имена, они ответили: "предлагайте вашу сумму, тогда обсудим передачу вам этих имен". Но тут они слегка просчитались. Да, человек, ищущий информацию о Соловках, первым делом попытается набрать именно эти адреса. Но информации-то там нет! Поэтому он обратится к поисковой машине, которая выдаст им список сайтов, наполненных нужной информацией. И если сайт будет называться solovki.it или solovki.org, а не solovki.ru/com, то от этого ничего не изменится. Так что перехватчики ничего не выиграли, а только потратили деньги на бессмысленную регистрацию имени. Правда, на данный момент они стали действовать хитрее - просто берут информацию с наиболее продвинутого сайта о Соловках solovki.net и с других более мелких сайтов, и размещают ее у себя, при этом скромно называя себя "пожалуй, лучшим информационным ресурсом о Соловецких островах", и предлагая размещать за деньги на своем сайте рекламу. Правда, никто этого пока что так и не сделал... Так что не допускайте утечки информации.

Итак, теорию мы узнали, имена придумали и проверили. Осталось их зарегистрировать. В следующих статьях я приведу пошаговые примеры регистрации доменного имени в различных зонах - "ru", "pp.ru", "com.ru", "msk.ru", "co.za", и в других. Также я расскажу о бесплатной поддержке DNS (она пригодится, если необходима максимальная экономия денег при регистрации имени), и других полезных и сопутствующих вещах. До встречи!

© 2001-2002 Vladimir N. Deribin


Регистрация доменных имен. Часть 2: корпоративный домен в зоне "ru".

Август 2001.

Предупреждение: все течет, все меняется, поэтому что-то могло измениться со времени написания этих статей (ссылки, IP-адреса, процедуры). Найдете несовпадения – пишите мне, постараюсь исправить статьи, хоть и не обещаю. Ругать меня – бесполезно. Нужна помощь – пишите, постараюсь помочь. Что-то не понимаете – перечтите пять раз первую статью и ту, которую не понимаете, прежде чем мне писать. Теперь приступим...

Домены в зоне ".ru" делятся на несколько групп: общего пользования (geographical, generic), открытого пользования (public), и корпоративного пользования (все остальные). Те, кто интересуется различиями и тонкостями, могут прочитать "Приложение 1 / 2 к Договору об оказании услуг" по адресу http://www.nic.ru/dns/contract/sup1_2_ripn.html, там все подробно описано. Нас же будут интересовать корпоративные доменные имена - чаще всего именно этот тип является объектом регистрации. В этой статье я расскажу о том, как я производил регистрацию доменного имени в зоне "ru" для крупного комбината.

Здесь я должен сделать необходимые технические пояснения, так как без понимания их самому регистрировать имя и выбирать сервер, где будет находиться содержимое сайта, будет трудно. Рассмотрим две необходимые нам вещи - виртуальный хостинг и DNS.

Сначала разберемся, что такое DNS. Расшифровывается это как Domain Name System - система доменных имен. Каждый компьютер, подключенный к Интернету, имеет свой цифровой адрес (IP-адрес), который состоит из четырех чисел, например, 195.164.34.128. Для того, чтобы обращаться не по цифровому адресу, а по символьному (доменному имени), и существует эта система. Каждому цифровому адресу можно присвоить сколько угодно символьных имен. К каждому компьютеру в сети можно обратиться и по цифровому адресу. Компьютер может вообще не иметь символьного имени, и обращаться к нему можно будет только по IP-аресу. Специальные DNS-серверы содержат в себе описания доменных имен, чтобы при наборе доменного имени компьютер знал, куда следовать дальше. Также на DNS-серверах указывается, где находится почтовая система доменного имени. Для доменного имени можно иметь отдельную почтовую систему (чтобы можно было создавать адреса типа что_нибудь@домен.ru), а можно просто указать пересылку всей почты с адреса все_подряд@домен.ru на какой-нибудь существующий адрес. Впрочем, поддержку почты можно вообще не включать, равно как можно зарегистрировать доменное имя только для того, чтобы иметь соответствующие почтовые ящики и при этом не иметь сайта. Подробнее и понятнее о DNS можно прочитать по адресу http://www.corbina.net/~msh/papers/pcweek-98-41/index.html.

О виртуальном хостинге я уже упоминал в первой статье, теперь же расскажу подробно. При регистрации доменного имени необходимо обязательно указать IP-адрес сервера, где будет находиться ваш сайт. Если на сервере находятся несколько сайтов, то обращаться к ним по цифровому адресу невозможно - физический сервер-то один, и при наборе IP-адреса вы будете попадать только на главную страницу сервера. Здесь-то нас и выручит виртуальный хостинг - в настройках сервера, где находится сайт, указывается, что тот, кто обращается к серверу по определенному доменному имени, переадресовывается на соответствующую папку на сервере. В системе Apache это называется name-based virtual hosts. Вот эта услуга по поддержке переадресации пользователей на соответствующий сайт и называется виртуальным хостингом. Обычно доменное имя, ссылающееся с помощью виртуального хостинга, называют виртуальным доменом. Иногда также виртуальными доменами называют домены третьего уровня. К нашему случаю это отношения не имеет.

Приступим к подготовительным действиям, необходимым для регистрации домена в зоне ".ru". Многие слышали и знают, что в России регистрацией доменных имен в зоне ".ru" занимался РосНИИРОС (www.ripn.net). Теперь же РосНИИРОС возложил эту работу на свою дочернюю организацию - RU-CENTER (www.nic.ru). Сам же РосНИИРОС занимается внесением организаций, персон, и служб поддержки в свою базу данных и ее поддержанием, а также бесплатной регистрацией в зонах ".com.ru", ".org.ru", ".net.ru", ".pp.ru" (об этом я расскажу в статье 3 - ".pp.ru", и в статье 4 - ".com.ru").

Так как RU-CENTER все равно содержит данные персон, организаций и служб поддержки в базе РосНИИРОС, то мы первым делом зарегистрируем себя в базе РосНИИРОС и как персону (которая будет регистрировать имена и будет их владельцем), и как службу технической поддержки (что мы, сами, что ли, не справимся с технической поддержкой наших доменов? :). Организации, на которые будем регистрировать корпоративные домены, также будет необходимо вносить в эту базу.

Регистрация нас, любимых, в базе РосНИИРОС будет происходить следующим образом. Заходим на сайт РосНИИРОС (www.ripn.net), идем по ссылке "Регистрация доменов", далее выбираем "Раздел для зарегистрированных клиентов", далее "Веб-формы для регистрации", подпункт "- физических лиц". Теперь видим перед собой запрос на наш идентификатор (см.рис.1). Обычно идентификатор составляют по первым буквам фамилии, имени и отчества, я же себе выбрал идентификатор HAROLD [-RIPN]. Нажимаем кнопку "Продолжить" и перед нами открывается форма для ввода наших личных данных (см.рис.2). В ней все комментируется на русском языке, поэтому каждое поле для заполнения я объяснять не буду - просто введите свои данные.

После ввода личных данных в форму и нажатия "Далее" появляется запрос об указании технической поддержки. Так как мы - сами себе поддержка и мы себя как службу поддержки пока что не зарегистрировали, выбираем пункт "Зарегистрировать" (см.рис.3). Естественно, у нас появляется форма для ввода данных (см.рис.3a). Как идентификатор я выбрал себе INSKIN [-MNT-RIPN], ввел остальные данные и нажал "Продолжить". Появился запрос на указание контактного лица службы техподдержки. В его качестве я опять-таки указал свой ранее выбранный идентификатор (HAROLD-RIPN), то есть мы становимся и персоной, и техподдержкой, и ее (техподдержки) контактным лицом. После очередного нажатия "Продолжить" появился экран с введенными мной данными для окончательной проверки и с просьбой указать e-mail для уведомления о завершении процесса (см.рис.4). Так как ввел я все правильно, то нажал кнопку "Зарегистрировать объект". В результате на экран вывелось сообщение, что объекты поставлены на обработку, и что после завершения обработки меня уведомят.

Примерно через 15 минут я получил письмо на указанный мной адрес с ранее введенными о себе данными и с уведомлением о том, что они находятся в обработке. Через день пришло письмо, сообщающее о том, что данные внесены в базу РосНИИРОС. Теперь можно проверить наше наличие в базе с помощью сервиса "Whois" на сайте РосНИИРОС (см.рис.5) по адресу http://www.ripn.net:8080/nic/whois/. Введем во второй строке один из наших идентификаторов (в моем случае - INSKIN-MNT-RIPN или HAROLD-RIPN) и посмотрим наши данные. О'кей, мы присутствуем, и данные наши правильны. Можно переходить к процессу регистрации доменных имен.

Регистрацию доменного имени для организации мы начнем с внесения этой организации в базу данных РосНИИРОС. Для этого зайдем снова на www.ripn.net, "Регистрация доменов", "Раздел для зарегистрированных клиентов", "Веб-формы для регистрации", подпункт "- организаций". Что мы видим? Правильно - запрос идентификатора организации! Я для организации "Беломорский ЛДК" выбрал идентификатор BLDK [-ORG-RIPN], вы же можете придумать его по своему усмотрению. Как водится, нажимаем кнопку "Продолжить" и видим форму для введения данных регистрируемой организации. Опять-таки, к каждому полю даны подробные комментарии, так что затруднений с заполнением быть не должно. Одна из возможных проблем - незнание соответствий русских и английских названий форм собственности (ОАО, ООО, ЗАО, и т.п.). Могу посоветовать либо обратиться к друзьям, знающим английский язык, либо ко мне, либо вообще ввести все транслитом. В остальном регистрация организации в базе данных РосНИИРОС идентична регистрации персоны. Дождемся получения двух писем (предварительного и окончательного) по почте о внесении в базу организации (на что уйдет около суток) и будем двигаться дальше.

Местом для размещения сайта я выбрал провайдера Sampo (http://sampo.ru). При регистрации у него он выделяет по умолчанию для сайта 5 мегабайт. На первый взгляд мало, но мне пока что больше и не нужно. Во-вторых, денег за сам хостинг не берет, а в-третьих, этот провайдер поддерживает виртуальный хостинг, что является для нас одним из самых важных моментов. Адрес сайта, по умолчанию определяемый провайдером, выглядел как http://sampo.ru/~bkld/. О некоторых технических параметрах мне пришлось с ними договориться заранее. Во-первых, они согласились предоставить виртуальный хостинг. Обходится это в небольшую сумму (10 рублей) ежемесячно, хотя, на мой взгляд, за внесение одноразово восьми-десяти строк в конфигурационный файл сервера Apache вообще деньги брать стыдно. Во-вторых (еще один важный момент), они обеспечили поддержку DNS. То есть они согласились (опять-таки за плату) прописать в двух своих DNS-серверах (два - необходимый минимум для регистрации, можно и больше) соответствие символьного имени bldk.ru цифровому адресу своего сервера. Обратите внимание: настроить DNS желательно, но не обязательно, до начала процесса регистрации домена. В-третьих, они настроили переадресацию почты с адреса что_угодно@bldk.ru на уже существующий адрес электронной почты организации. Ну и в-четвертых, они настроили сервер, чтобы сайт был доступен как по адресу bldk.ru, так и по адресу www.bldk.ru. Примечание: в дальнейших статьях я опишу, как пользоваться бесплатным сервисом поддержки DNS.

РосНИИРОС прекратил регистрацию доменов в зоне "ru", передав эту деятельность дочерней организации RU-CENTER (http://www.nic.ru/). К ним мы и пойдем регистрироваться. На стартовой странице сайта мы увидим поле запроса домена для регистрации (см.рис.6). Введем желаемое имя домена, в нашем случае - BLDK, и нажмем "Ok". На следующей странице нам сообщат, что доменное имя свободно, и предложат заказать его регистрацию. О'кей, нажимаем кнопку "Заказать" и переходим к следующей странице, на которой видим просьбу ввести DNS-серверы. Если регистрируемое вами доменное имя еще не прописано в DNS-серверах (например, если вы хотите зарегистрировать его сейчас, а начать использовать потом), то оставляем поля пустыми, иначе вводим имена и IP-адреса серверов. Так как я договорился с провайдером и он прописал домен в свои DNS-серверы, сообщив мне при этом их цифровые и символьные имена, то я в данном случае указал их. Нажимаем "Продолжить" (нам придется делать это довольно часто). Появляется следующая страница - со стоимостью выбранных услуг. Если вы в предыдущем экране не поставили галочку в поле "Использовать secondary DNS-сервер RU-CENTER", то цена услуг должна составить 20 у. е. (без учета НДС). Опять нажимаем "Продолжить". На очередной странице у нас запросят номер договора и пароль. Мы прокрутим экран вниз и выберем ссылку "Получить данные из РосНИИРОС". Те, кто по каким-либо причинам не регистрировал организацию в базе РосНИИРОС, могут также заполнить предлагаемые анкеты и получить номер договора прямо в этой форме. После выбора ссылки получения данных из РосНИИРОС появятся поля ввода данных: идентификатор организации (в нашем случае BLDK [-ORG-RIPN]), адрес электронной почты и пароль службы поддержки организации, которая указана в поле MNT-BY. В нашем случае это будут e-mail и пароль, принадлежащие INSKIN-MNT-RIPN. После ввода этих данных нажимаем кнопку "Получить данные" и у нас появляется экран с данными организации BLDK-ORG-RIPN. Нажимаем наверху кнопку "Передать данные", и на очередной странице видим заполненную данными организации анкету. Проматываем анкету вниз, вводим пароль, запоминаем его, ставим галочку "Я запомнил пароль" и нажимаем кнопку "Отправить анкету", после чего получаем страницу с сообщением, что наша анкета сохранена для заключения договора. Номер договора и пароль, естественно, надо обязательно запомнить - они очень пригодятся в будущем. Нажимаем кнопку "Оформить заказ". Теперь нам сообщают, что заказ поступит в обработку при условии заключенного договора с RU-CENTER и при наличии достаточной суммы на личном счете нашего договора. Также будет дана возможность выписать счет на оплату заказанных услуг. Сначала выпишем счет, для чего нажмем кнопку "Выписать счет", не забыв проверить правильность суммы. После нажатия мы перейдем на следующую страницу, где нас уведомят, что счет нам выставлен, и предложат распечатать его копию для оплаты. Мы так и сделаем, после чего пойдем напечатанный счет оплачивать :-) Только не забудьте, что юридические лица должны платить с учетом НДС.

Небольшое лирическое отступление: предварительное прописывание домена в DNS провайдера приводит к интересному эффекту - если вы будете работать в Интернете через этого же провайдера, или укажете адрес его DNS-сервера у себя на компьютере в настройках протокола TCP/IP, то при вводе доменного имени в строке браузера ваш сайт уже будет грузиться по новому адресу, хоть домен еще и не зарегистрирован в RU-CENTER! К сожалению, пользователи других провайдеров на попытку ввода имени сайта получат ответ о том, что такового не существует. Для того мы и регистрируем домен в RU-CENTER, чтобы он был доступен по всему миру. Но продолжим.

Теперь мы являемся клиентами RU-CENTER и можем, используя номер договора и пароль, смотреть свои данные на сервере. Пришло время непосредственно заключить договор. Заходим на сервер RU-CENTER (http://www.nic.ru/), ищем справа пункт "Для клиентов" (https://www.nic.ru/dns/manager/), заходим и видим поле запроса номера договора и пароля, а ниже - несколько пунктов. Один из них - "Заключить договор" (https://www.nic.ru/dns/contract/). Переходим по этому адресу, загружаем себе форму договора для юридического лица (ибо в данном случае мы регистрируем домен именно на юридическое лицо), заполняем, печатаем в двух экземплярах и отправляем по обычной почте (представьте себе, такая до сих пор существует!) вместе с копией свидетельства о Государственной регистрации юридического лица в RU-CENTER. Адрес указан в описании "Как заключить договор юридическому лицу", которое находится там же, где мы взяли форму договора.

Теперь остается только ждать, пока договор дойдет по адресу, заверится, и одна копия вернется назад. А пока мы можем в пункте "Для клиентов" посмотреть баланс лицевого счета. Если наша оплата пройдет раньше, чем подпишется договор, то оплаченная сумма будет видна в пункте "Заблокировано средств". После подписания договора, но до завершения регистрации домена, сумма будет видна в пунктах "Зачислено платежей на сумму" и "Остаток". Ну и после регистрации домена "Зачислено платежей на сумму" и "Оказано услуг на сумму".

По ходу регистрации домена нам будут приходить различные письма, причем будут приходить на адрес электронной почты той организации, для которой мы регистрируем домен. Так, после подписания договора придет уведомление, что "пункт заказа [номер] от [дата] получил статус 'выполняется'". Это значит, что домен начали регистрировать. Что интересно, уведомление о заключении договора может прийти как до, так и после сообщений о процессе регистрации домена. Потом придет уведомление, что тестирование DNS-серверов прошло успешно (если вы их указывали при регистрации), и, наконец, уведомление, что "пункт заказа [номер] от [дата] получил статус «завершен»". Ура! Домен зарегистрирован! Теперь ваш сайт будет доступен из любой точки мира по зарегистрированному адресу - надо только подождать немного (не больше суток), чтобы запись о домене разошлась по DNS-серверам всего мира.


Регистрация доменных имен. Часть 2: доменное имя в зоне .pp.ru.

Август 2001, правлено в июне 2002.

Предупреждение: все течет, все меняется, поэтому что-то могло измениться со времени написания этих статей (ссылки, IP-адреса, процедуры). Найдете несовпадения – пишите мне, постараюсь исправить статьи, хоть и не обещаю. Ругать меня – бесполезно. Нужна помощь – пишите, постараюсь помочь. Что-то не понимаете – перечтите пять раз первую статью и ту, которую не понимаете, прежде чем мне писать. Теперь приступим...

Решил я выложить написанные мною материалы о регистрации доменных имен, а также о других вещах, на отдельный сайт. Естественно, захотелось мне для этого сайта поиметь отдельное имя, да и еще один пример регистрации домена не будет лишним. Немного поколебавшись, я остановился на зоне ".pp.ru", ведь не у всех есть деньги на регистрацию доменных имен в зоне "ru", а в выбранной мною зоне регистрация бесплатна. Но ведь есть еще платежи за внесение цифрового адреса вашего сайта в DNS, скажете вы. На это я отвечу вам, что есть сайты, предоставляющие эту услугу бесплатно. Хорошо, но почему зона ".pp.ru", а не ".com.ru", ".net.ru", ".org.ru"? Потому что эти три зоны доступны для регистрации только на организации (юридические лица), а ".pp.ru" предназначена как раз для частных лиц. Можно, конечно, ввести фиктивные данные для регистрации в зонах для организаций, но, во-первых, мне лень эти данные выдумать, а во-вторых, у меня есть реальный клиент на регистрацию имени в зоне ".com.ru", и вот на нем-то я и покажу процесс регистрации домена в этой зоне.

Итак, сегодня мы научимся регистрировать бесплатное доменное имя для своего сайта в зоне ".pp.ru", да еще и с использованием бесплатного сервиса поддержки DNS MyDomain.Com (про который узнаем много нового). Сестра, скальпель!

В очередной раз еще больше углублюсь в описание DNS. В предыдущей статье (о регистрации корпоративного доменного имени в зоне ".ru") я писал, что при вводе данных в анкету необходимо указывать адреса серверов DNS. Если вы обратили внимание, то в той анкете был пунктик "использовать secondary DNS-сервер RU-CENTER". Для дальнейших процедур совершенно необходимо понимать, что такое primary и secondary DNS-серверы и чем они отличаются.

Первичный DNS-сервер содержит основную информацию о домене. Когда мы набираем доменное имя, обращение для сопоставления символьного имени c цифровым (IP-адрес) идет именно к первичному серверу, а если он не отвечает - то к одному из вторичных. Вторичные серверы содержат просто копию данных, взятых с первичного. Они регулярно обращаются к первичному серверу для сверки информации, хранящейся у них, с информацией, находящейся на нем. В случае несовпадения они копируют себе более свежую информацию. Технически было бы достаточно и одного, первичного, сервера, но так как абсолютно надежной техники не бывает, необходимо наличие вторичных серверов (хотя бы одного), к которым и будет происходить обращение в случае неполучения ответа от первичного. Если первичный сервер слишком долго не отвечает на запросы вторичных, они удаляют у себя записи о доменном имени. Таким образом, слишком долгое бездействие первичного сервера (в результате неисправности, например) может привести к тому, что ваш сайт перестанет быть доступным по зарегистрированному вами доменному имени. Это вовсе не значит, что вы потеряете свой домен - просто вам будет необходимо внести запись о нем в другой, более надежный DNS-сервер и указать адрес этого сервера в настройках вашего доменного имени. Доступность сайта восстановится примерно в течение суток.

Как правило, услуги DNS-сервера предоставляют все фирмы, предлагающие платное размещение сайта. Так как мы находимся в условиях российской реальности и нам дорога каждая копейка, попробуем воспользоваться серверами, предоставляющими бесплатный DNS-сервис. После долгих поисков в Интернете я нашел несколько служб: GraniteCanyon (soa.granitecanyon.com - первичный и вторичный серверы), ZoneEdit (www.zoneedit.com - первичный и вторичный серверы), MyDomain.Com (www.mydomain.com - первичный и вторичный серверы), Secondary.Com (secondary.com - только вторичный сервер). Но это все англоязычные сайты, а есть и русские, предоставляющие, к сожалению, только Secondary DNS. Вот они: DNS на Trifle.Net (http://www.trifle.net/DNS/) и Secondary.Net.Ua (http://secondary.net.ua/). Пользоваться мы будем и английскими, и русскими серверами, в зависимости от ситуации и настроения :) Вышеперечисленные сайты - не единственные, предоставляющие такие услуги. Вроде бы Da.Ru тоже дает возможность пользоваться подобным сервисом (http://www.da.ru/da/intro.html), но у них его надо раз в полгода обновлять, а нам подобная морока ни к чему.

Информация о вашем домене хранится на DNS-сервере в специальном файле. Этот файл называется зоной. Строго говоря, физически в виде файла зона может и не существовать, а, например, храниться в какой-то базе данных. Каждая зона соответствует одному домену. Зона (файл с данными о домене) состоит из записей. Типов записей несколько: SOA, A, NS, MX, CNAME, и др. Мы попробуем создать блок этих записей для внесения в зону для нашего доменного имени. Для своего сайта в качестве первичного и вторичных DNS-серверов я выбрал MyDomain.Com. Первоначально я хотел использовать для этой цели GraniteCanyon, но на момент написания статьи (август 2001 года) у них устойчиво лежал вторичный сервер, причем лежал с 15 апреля. Администрация GraniteCanyon оправдывается тем, что "не хочет торопиться с такими вещами". Регистратор же доменов в зоне ".pp.ru" не даст зарегистрировать домен, пока не убедится в работоспособности всех указанных для доменного имени DNS-серверов. Поэтому от услуг GraniteCanyon пришлось временно отказаться в пользу MyDomain.Com. Тем не менее, хоть это в данном конкретном случае не особо и надо, разберемся чуть-чуть поподробнее с форматами записей в файле с описанием домена (или в зоне, см. выше) на DNS-сервере.

Обязательная запись, находящаяся в зоне - SOA. В ней указываются такие параметры, как главный сервер имен для зоны, адрес электронной почты администратора домена (в нашем случае это будет мой адрес, так как я буду являться администратором моего доменного имени tech.pp.ru), порядковый номер версии файла зоны (обновляется в сторону увеличения при изменении данных, чтобы вторичные серверы знали, что пора обновить свои копии записей), интервал времени, через который вторичные серверы должны опрашивать первичный на предмет внесения изменений в зону, и т. п. Так как GraniteCanyon и остальные бесплатные сервисы сами устанавливают эти значения, мы их рассматривать в этой статье не будем. Кто желает поподробнее почитать про типы и форматы записей, а также просто про DNS, может обратиться к ресурсу http://www.dns.net/dnsrd/.

Другие записи, которые могут нам пригодиться, это A, NS, MX, CNAME. В записи A указывается IP-адрес сервера, на котором будет находиться наш сайт. В записях NS (их обычно бывает как минимум две) перечисляются имена DNS-серверов для домена. MX содержит адрес почтового сервера, куда будет направляться вся почта, приходящая на домен. В CNAME можно указать, куда перенаправлять пользователей, указавших какой-либо поддомен в домене.

Итак, основные понятия уяснили, можно приступать к процессу внесения данных на MyDomain.com. Но сначала - небольшое лирическое отступление.

Сервис MyDomain.Com бесплатно предлагает достаточно уникальный набор услуг. Тогда как прочие сервисы могут работать только как DNS-серверы, MyDomain.Com может выступать в роли редиректора. То есть если у вас сайт находится где-нибудь по адресу www.prov.ru/~culzizop/ и сервер, где сайт размещен, не поддерживает услугу виртуального хостинга (или у вас нет на это денег), MyDomain как раз вас выручит - www.vashe_imya.ru можно настроить, чтобы оно ссылалось на адрес вашего сайта, причем так, чтобы настоящий адрес сайта виден не был! Мало того, этот сервер предоставляет еще и редирект мыла с shto_ugodno@vashe_imya.ru на указываемый вами адрес электронной почты, и таких редиректов может быть до пяти, и на разные адреса! В общем, просто изобилие фич - и при отсутствии оплаты. Покопайтесь у них на сайте сами - много чего интересного может обнаружиться. А пока что двинемся дальше.

Первым делом нам надо у них зарегистрироваться. Порядок действий, в общем-то, стандартен. Заходим на сайт, ищем "Signup now free" или "Free signup", на первом экране вводим свой e-mail, на втором – пароль и данные, и все. Возвращаемся на стартовую страницу сайта, выбираем Login (во время ввода адреса электронной почты и пароля оставьте галочку "Remember my login & password", а то на следующий экран не пустят) и видим интерфейс управления своей учетной записью. Ну что ж, жмем "Add domain to my list" и на следующей странице вводим tech.pp.ru (к примеру), выбрав в выпадающем списке пункт "MyDomainPlus: чего-то там". На следующем экране увидим форму администрирования домена. В данном случае нам понадобится пункт "IP-pointing" (Внимание: раньше IP-pointing был в "MyDomainFree", теперь он в "MyDomainPlus"; оба сервиса бесплатны). Он по принципу своему как раз и приведет к желаемому эффекту – полноценной записи на DNS-сервере. Так что смело жмите в этот пункт (IP-pointing). Тут же вы увидите строку для ввода с примером над ней, и если то, что написано выше про типы записей в зоне, вы читали внимательно, то радостно удивитесь – нам предлагается ввести значение для записи типа А. Повторюсь: в ней указывается IP-адрес сервера, где будет находиться наш сайт. Вносим! Я, для моего конкретного случая, ввел "195.161.9.124" (без кавычек, естественно). Ну что, ввели? Жмите "Continue", а на следующем экране – "Confirm changes". После этого вам покажут экран с настройками вашего домена (см.рис.1). При желании вы можете поменять тип переадресации ("Edit web settings") (см.рис.2) и настроить переадресацию почты ("Edit email settings"). Кстати говоря, этот сервис поддерживает фичу, называемую "round robin". То есть вы можете добавить IP-адреса нескольких серверов, и пользователей при попытке зайти на ваш сайт будет пересылать каждый раз на другой сервер. Часть работы сделана, можно отключаться – выбирайте в меню пункт "Logout". В будущем при входе на их сайт со своим логином и паролем вам будет доступен список ваших содержащихся на MyDomain доменов с возможностью менять настройки (см.рис.3).

Раньше при добавлении домена на сервисе MyDomain.Com этот сервис вносил на ns-серверы зону для домена только после того, как домен будет зарегистрирован с указанием ns-серверов от MyDomain. Так как РосНИИРОС не регистрирует домен в .pp.ru, если для него нет зоны на ns-сервере, то приходилось заморачиваться и писать письмо в MyDomain, чтобы они добавили зону для домена заранее. Теперь это дело автоматизировано, где-то там есть ссылочка специальная, посмотрите, сам я не видел. Даваните ее для инициации принудительного внесения зоны на их ns-серверы, иначе РосНИИРОС домен не зарегистрирует. Сразу после надавливания на ссылку вам должны дать список ns-серверов (вида ns1.mydomain.com 212.54.67.89). Скопируйте куда-нибудь его – он нам скоро пригодится. 7 июня 2002 года список ns-серверов можно было посмотреть также по адресу http://www.mydomain.com/help/regional.

Кстати говоря, IP-адрес и прочую информацию о любом сервере имен можно получить, зайдя на сайт Network Solutions по адресу http://www.networksolutions.com/cgi-bin/whois/whois и введя в строке поиска "host ns1.mydomain.com", к примеру. Ключевое слово – "host", после которого через пробел указывается символьное имя DNS-сервера.

Также на сайте Secondary.net.ua можно посмотреть, внесены ли данные о нашем домене в DNS-сервер или нет. Заходим на secondary.net.ua, выбираем пункт "dig и nslookup", в открывшейся форме в первой строке вводим имя домена (в моем случае tech.pp.ru), во второй строке – символьное имя ns-сервера (к примеру, ns1.mydomain.com или ns2.secondary.com), галочку оставляем напротив пункта "Nslookup", жмем кнопку "Запустить" и получаем информацию. Эта функция полезна, если вы получаете от регистратора доменных имен сообщение о том, что тестирование DNS-серверов прошло неудачно.

Ну что ж, осталось совсем немного: зарегистрировать само доменное имя и попросить администраторов сервера, где лежит наш сайт, включить виртуальный хостинг. Обратите внимание – перед регистрацией домена обязательно должно быть инициировано добавление зоны для него на ns-серверы MyDomain.Com. Желательно проверить наличие информации о домене на DNS-серверах способом, описанным в предыдущем абзаце, ибо без присутствия этой информации домен зарегистрировать не получится.

Для регистрации вашего имени (в моем случае – tech.pp.ru) движемся на сайт RIPN – www.ripn.net. Далее идем по накатанной колее: "Регистрация доменов" –> "Раздел для зарегистрированных клиентов" –> "Web-форма для регистрации доменов и работы с данными". Можно, если хотите, сразу перейти по адресу https://www.ripn.net/nic/dns/form/. Там попросят указать наш идентификатор в системе RIPN. Выберем, что будем указывать идентификатор персоны, и введем его и соответствующие адрес электронной почты и пароль (их мы получили, когда регистрировались как персона в базе РосНИИРОС – см. статью 2, "Регистрация корпоративного доменного имени в зоне .ru"). Нажмем "Войти" и на следующем экране увидим форму, где укажем, что регистрируем имя "tech" в зоне ".pp.ru", и введем остальные данные. В качестве DNS-серверов я ввел ns1.mydomain.com [пробел] 216.34.13.236 [Enter] ns2.mydomain.com [пробел] 64.75.34.132 [Enter] ns3.mydomain.com [пробел] 64.75.34.140 [Enter] ns4.mydomain.com [пробел] 64.75.34.134 (см.рис.4). Обратите внимание – IP-адреса DNS-серверов могли измениться, так что используйте данные, полученные способом, описанным четырьмя абзацами ранее. В других случаях их можно взять с сайтов, предоставляющих услугу, либо узнать с помощью соответствующего сервиса (см. выше). Нажали "Заказать", подтвердили заказ и ждем, когда ответ придет на электронную почту. Письма будут приходить такие же и в том же порядке, что при регистрации домена в зоне .ru (см. статью 2), то есть нас будут уведомлять, что домен поставлен в обработку, потом что тестирование DNS-серверов прошло успешно, и так далее, до сообщения о том, что регистрация доменного имени произведена.

После успешной регистрации доменного имени этим именем можно будет пользоваться не раньше, чем через сутки, а скорее всего только часов через 48-72. Но и то, приводить оно будет на сайт того, у кого мы разместили свой сайт / страничку, и так будет до тех пор, пока сайтодержатели не включат виртуальный хостинг. Для этого просто надо написать письмо системному администратору, предварительно сделав оплату способом, стандартным для этого сервера. После этого ваш домен станет показывать уже ваш сайт :)

Приведу примерную хронологию событий: в пятницу я зарегистрировался на MyDomain.com, добавил запись о своем домене на их сервере, и послал им письмо, с просьбой добавить зону в свой DNS-сервер до того, как я буду регистрировать домен (в то время это еще было необходимо); во вторник вечером (то есть через 4 дня) я получил ответ, что файл с описанием моего домена tech.pp.ru добавлен на их DNS-сервер; в среду я на сайте RIPN оставил заявку на регистрацию домена; в четверг получил ответ, что домен зарегистрирован; в понедельник при вводе адреса http://tech.pp.ru/ стал грузиться мой сайт.

Вот и все на этот раз. Поправки, комментарии, вопросы шлите по адресу электронной почты, указанному в моем резюме.


Регистрация доменных имен. Часть 4: доменное имя в зоне .com.ru.

Август 2001, правлено в июне 2002.

Предупреждение: все течет, все меняется, поэтому что-то могло измениться со времени написания этих статей (ссылки, IP-адреса, процедуры). Найдете несовпадения – пишите мне, постараюсь исправить статьи, хоть и не обещаю. Ругать меня – бесполезно. Нужна помощь – пишите, постараюсь помочь. Что-то не понимаете – перечтите пять раз первую статью и ту, которую не понимаете, прежде чем мне писать. Теперь приступим...

Сегодня мы узнаем, как зарегистрировать себе имя в зоне ".com.ru". Это достаточно просто, тем более что во многом процесс будет идентичен регистрации имени в зоне ".pp.ru", только ввиду отсутствия возможности воспользоваться виртуальным хостингом нам придется воспользоваться такой возможностью, предоставляемой сервисом MyDomain.Com, как "Stealth forwarding" (доменное имя работает как редирект на существующий сайт).

Ситуация сложилась такая: есть в Санкт-Петербурге фирма, называется ОАО "Автоарматура", и энтузиасты в лице её системных администраторов решили сделать нечто вроде сайта с координатами и примерами продукции предприятия. Так как основано это было на энтузиазме, то денег, естественно, никто выделять на имя в зонах ru/com не собирался, а значит, оптимальной оказалась зона ".com.ru".

Может возникнуть вполне резонный вопрос – почему не ".spb.ru"? Потому что при регистрации в Релкоме каждый DNS-сервер, указанный в заявке, будет тестироваться на корректность описания зоны с использованием механизма transfer зоны, поэтому этот механизм в обязательном порядке должен быть открыт для IP адреса автомата. Сервис, предоставляемый MyDomain.Com, не дает такой возможности, а другие подобные сервисы не поддерживают "Stealth forwarding", или хотят за это денег. Так что придется пока что довольствоваться зоной ".com.ru".

Сам сайт АО "Автоарматуры" находился на момент написания статьи по адресу http://autoarmatura.hut.ru/. Хостинг сайта можно менять без проблем - достаточно потом зайти на MyDomain.com и изменить настройки для доменного имени.

Процесс регистрации на сайте MyDomain.com я описывать не буду, так как это было сделано мною в предыдущей статье. Те, у кого нет моих предыдущих статей в печатном виде, могут взять их у меня на сайте http://tech.pp.ru/.

Теперь нам надо только добавить наше доменное имя в свой аккаунт на MyDomain, а также написать им письмо, чтобы они добавили его в свои DNS-серверы до того, как мы подадим заявку на регистрацию имени. Путь более чем стандартный. Идем на www.mydomain.com, ищем пункт "Login", логинимся, видим статистику нашего экрана (см.рис.1). В моем случае также показывается уже существующее на данном аккаунте доменное имя tech.pp.ru. Кликаем на ссылку "Add a domain to my domain list". На следующем экране вводим что_вам_надо.com.ru (см.рис.2), затем жмем "Add". А вот теперь нам надо выбрать, каким образом пользователь будет попадать на нашу страницу. Так как денег на оплату виртуального хостинга у нас нет, то выбирать мы можем только из двух пунктов: "Standard forwarding" и "Stealth forwarding". Первый из них будет перекидывать пользователя на вашу страницу, причем в браузере будет показываться ее настоящий адрес. В нашем случае человек, набрав autoarmatura.com.ru, попадет на autoarmatura.hut.ru, при этом в адресной строке браузера появится именно второй адрес. Так как меня это не устраивало (а вдруг я хостера сменю, а у людей в закладках старый адрес останется), то я выбрал второй вид редиректа – "Stealth forwarding". При его использовании всегда показывается только адрес вашего домена, и никакой другой. Его и выбираем. У нас появляется несколько строк для ввода (см.рис.3). Ну, кто знаком с созданием страниц, сам все поймет, поэтому следующий абзац может пропустить.

Для тех же, кто не знаком с метатегами, кратко опишу, чего и где вводить. Первая строка – "URL to forward to". С ней все понятно – вводим туда адрес уже существующего сайта/страницы. Переключатель "Pass subdirectories" определяет, поддерживать ли при адресации папки, то есть откроется ли при вводе адреса autoarmatura.com.ru/prices/ информация с адреса autoarmatura.hut.ru/prices/. Ставим в "Yes". Вторая строка – "Meta tag title". В ней вводится заголовок, который будет появляться в заголовке окна браузера при заходе на ваш сайт. Третья строка – "Meta tag keywords". Тут мы можем указать ключевые слова, по которым нас сможет отыскать поисковая машина. Строка может выглядеть примерно так (без кавычек): "ОАО Автоарматура, автоарматура, авто, автомобильные, переключатели, выключатели, антенны, замки зажигания, ВАЗ, ГАЗ". Последнее поле ввода – "Meta tag description". Информация, содержащаяся здесь, будет показываться пользователям поисковыми машинами в результатах поиска как описание найденного сайта. Например, можно ввести такую строку: "ОАО "Автоарматура" – автоарматура (замки зажигания, антенны, переключатели) для любых отечественных автомобилей". Подробнее о применении этих тегов можно прочесть на сайте MyDomain.com здесь (http://mydomain.com/help/ mydomain/tut-howsearch). Кстати, небольшой нюанс – они там наворотили чего-то с кодировкой, в результате чего один русский символ идет за 5-7, и при этом как русский он не показывается! Так что, к сожалению, заполнять эти поля надо латиницей... Я написал письмо в поддержку, но мне ничего так и не ответили. Может на момент прочтения вами этой статьи ситуация и будет уже исправлена...

Ну, ввели / не ввели, а надо двигаться дальше – жмите "Continue", затем "Confirm changes". После того как выведется экран с результирующими данными (см.рис.4), не забудьте, если это необходимо, сменить адрес электронной почты, на который будет перенаправляться все сообщения. Все, теперь надо инициировать добавление зоны для домена на ns-серверы MyDomain. Нажмите соответствующую ссылку, запишите полученную информацию о DNS-серверах, и поехали дальше. (Раньше процедура была сложней и запутанней, но это было давно и неправда :).

После этого проверьте наличие информации о нашем доменном имени в их DNS-сервере: зайдите на Secondary.net.ua, выберите "dig и nslookup", введите в поле "Доменное имя" свое доменное имя (я вводил "autoarmatura.com.ru"), в поле "Сервер, к которому будет послан запрос" – "ns1.mydomain.com", нажмите "Запустить", убедитесь в наличии. Если информации еще нет, подождите полчасика, и повторите процедуру. Появилась наконец информация? Пора домен регистрировать :)

Перемещаемся на сайт RIPN – www.ripn.net. Так как доменное имя мы регистрируем на организацию, то надо внести ее в базу данных РосНИИРОС, так как нам будет нужен ее идентификатор [что-нибудь-ORG-RIPN]. Так что на стартовой странице выбираем пункт "Регистрация доменов", далее в пункте "Регистрация доменов, прочие услуги" выбираем подпункт "- третьего уровня в зонах .COM.RU, .NET.RU, .ORG.RU, .PP.RU", и, наконец, в пункте "Веб-формы для регистрации" – подпункт "организаций". Дальнейшая технология ввода данных для добавления была мною подробно описана в моей второй статье (о регистрации доменного имени в зоне ".ru"). Впрочем, там все просто и трудностей составить не должно, только придется подождать, пока вам сообщат, что объект добавлен в базу данных. Кстати говоря, эту процедуру вы можете провести в тот же день, когда вы отправляете письмо в службу поддержки MyDomain.Com с просьбой внесения доменного имени в DNS-серверы – тогда как раз ко времени ответа от MyDomain.Com уже будет добавлен объект в базу РосНИИРОС и задержка по времени будет минимальной. После добавления объекта идем регистрировать доменное имя по накатанной колее: www.ripn.net –> "Регистрация доменов" –> "Раздел для зарегистрированных клиентов" –> "Web-форма для регистрации доменов и работы с данными". Можно, если хотите, сразу перейти по адресу https://www.ripn.net/nic/dns/form/. Там попросят указать наш идентификатор в системе RIPN. Выберем, что будем указывать идентификатор персоны, и введем его и соответствующие адрес электронной почты и пароль (их мы получили, когда регистрировались как персона в базе РосНИИРОС – см. статью 2, "Регистрация корпоративного доменного имени в зоне ".ru"). Нажмем "Войти" и на следующем экране увидим форму, где укажем, что регистрируем имя "autoarmatura" в зоне ".com.ru", и введем остальные данные. В поле "admin-o" укажем полученный идентификатор (в моем случае – autoarm-org-ripn), в поле "bill-o" будет указан наш идентификатор, который мы указали при входе в систему, а в поле "mnt-by" я указал себя как службу поддержки (inskin-mnt-ripn). В качестве DNS-серверов я ввел ns1.mydomain.com [пробел] 216.34.13.236 [Enter] ns2.mydomain.com [пробел] 64.75.34.132 [Enter] ns3.mydomain.com [пробел] 64.75.34.140 [Enter] ns4.mydomain.com [пробел] 64.75.34.134. Данные эти мы получили во время инициации добавления зоны на ns-серверы. В других случаях их можно взять с сайтов, предоставляющих услугу, либо узнать с помощью соответствующего сервиса. Нажали "Заказать", подтвердили заказ, после чего получили на экране сообщение, что заявка отправлена. Теперь ждем, когда придет письмо по электронной почте. Письма будут приходить такие же и в том же порядке, что при регистрации домена в зоне ".ru" (см. статью 2), то есть нас будут уведомлять, что домен поставлен в обработку, потом что тестирование DNS-серверов прошло успешно, и так далее, до сообщения о том, что регистрация доменного имени произведена успешно.

Вот и все, на этом процесс регистрации доменного имени в зоне ".com.ru" завершен. Сайт ОАО "Автоарматура" доступен по адресу http://autoarmatura.com.ru/, и при этом хоститься может где угодно, надо только будет при необходимости менять настройки домена на сайте MyDomain.Com. На сегодня – все.

© 2001-2002 Vladimir N. Deribin

href=index.htm>введение | теория | .ru | .pp.ru | .com.ru | .msk.ru/.spb.ru | ссылки


введение | теория | .ru | .pp.ru | .com.ru | .msk.ru/.spb.ru | ссылки

Регистрация доменных имен. Часть 5: доменное имя в зоне .msk.ru / .spb.ru.

Июнь 2002.

Предупреждение: все течет, все меняется, поэтому что-то могло измениться со времени написания этих статей (ссылки, IP-адреса, процедуры). Найдете несовпадения – пишите мне, постараюсь исправить статьи, хоть и не обещаю. Ругать меня – бесполезно. Нужна помощь – пишите, постараюсь помочь. Что-то не понимаете – перечтите пять раз первую статью и ту, которую не понимаете, прежде чем мне писать. Теперь приступим...

Ну вот, написание статьи близится к завершению, и как только ее напечатают в Компьютер-прайсе, я помещу ее здесь.

Дам небольшие наметки. Пользоваться надо двумя бесплатными DNS: первичным XName.Org и вторичными Secondary.Net.Ua – они оба поддерживают так нужный Релкому xfer. Кто ничего из предыдущей фразы не понял – ждите, пока статью допишу :)

А пока можете воспользоваться службой бесплатной регистрации имен в этих зонах: http://free.msk.su/. Вот что об этой службе я могу рассказать. Есть возможность ТОЛЬКО редиректа на существующий адрес, с сокрытием реального адреса (с помощью фрейма) или без оного, то есть вы можете использовать этот сервис для регистрации имени и переадресации на уже существующий сайт. Рекламу пока что вешать не собираются. Редирект мыла не дают и делать не планируют. Если в последующем захотите привязать адрес к своему сайту (к IP-адресу), то вам имя домена отдадут, но тогда придется возиться вам самим с ним (обеспечивать DNS, и т.п.). Вроде бы и все. Зайдите к ним на сайт, посмотрите, там все просто.


Регистрация доменных имен. Введение, или Как все начиналось.

Данная статья открывает собой небольшой цикл статей на тему "Регистрация доменного имени". Будут рассмотрены многие вопросы: зачем вообще это надо, как выбрать имя, каким способом можно его зарегистрировать, что для этого нужно знать, сколько это будет стоить, какие есть в этом процессе подводные камни, и другие сопутствующие вопросы. Также будут даны пошаговые описания процессов регистрации доменных имен. Основной упор будет сделан на бесплатные домены (.com.ru, .pp.ru, .spb.ru, и т. п.), но не будут забыты и платные зоны .ru и другие.

По возможности понятно я попытаюсь рассказать полностью о необходимых для регистрации домена вещах: DNS, виртуальный хостинг, и т. п. Что-то я, конечно, упущу, потому что большинству ни к чему влезать в технические дебри. Тем же, кто захочет узнать подробнее и глубже некоторые аспекты, я дам соответствующие ссылки.

Зачем все это? Затем, что когда я столкнулся с необходимостью зарегистрировать доменное имя, я не нашел НИЧЕГО толкового по этой теме, и до всего пришлось доходить самому. Чтобы другим не пришлось париться как мне, я и выложил здесь этот материал. Если у кого будут какие дополнительные вопросы ко мне – пишите. Вот список уже доступных статей:

Статья 1: Что такое доменные имена; зоны; цены; выбор имени.

Статья 2: Регистрируем доменное имя в зоне .ru; что такое DNS; платный DNS.

Статья 3: Как я регистрировал Tech.Pp.Ru; бесплатный DNS; DNS на MyDomain.Com.

Статья 4: Регистрация имени в зоне .com.ru; DNS на MyDomain.Com - форвард.

Статья 5: Имя в зоне .msk.ru (.spb.ru); DNS на XName.Org и Secondary.Net.Ua.


Регистрация доменных имен. Чиста палезные ссылки.

Сайты, предоставляющие первичный и/или вторичный бесплатные DNS.

GraniteCanyon.Com – precursor, так сказать, всех нынешних подобных сервисов. Полностью бесплатный, с полным контролем зоны, но также и с проблемами – очень длительный срок не работал вторичный сервер, да и сейчас, похоже, не работает... Предоставляет либо первичный, либо вторичный, либо и тот и другой ns-серверы (всего два). Ограничений никаких не имеет. Поддерживает transfer zone, что позволяет использовать вместе с ним и другие вторичные серверы.

MyDomain.Com – один из самых неплохих сервисов. Имеют платные услуги, значит имеют деньги, значит поддерживают бесплатный сервис на уровне. Сам им пользуюсь для этого (tech.pp.ru) сайта, да и для других – пока нареканий не было. Дает первичный и вторичный DNS (всего 4 ns-сервера). Все настройки производятся с помощью веб-форм. Поддерживает веб-редирект, то есть ваш сайт может быть доступен по вашему доменному имени, даже если он находится на бесплатном хостинге, не поддерживающем виртуальный хостинг (см. мою статью о регистрации домена в зоне .com.ru). Естественно, поддерживается и IP-pointing, причем есть такая фича, как "Round robin" – можно указать несколько IP-адресов разных серверов, и перекидывать юзера будет каждый раз на разный сервер. Можно настраивать редирект почты для адресов своего домена. Можно редактировать CNAME и MX-записи, нельзя – NS. Transfer zone не поддерживает, поэтому для .msk.ru / .spb.ru не подходит. Информации об ограничениях на их сайте я не нашел.

ZoneEdit.Com – также один из самых известных и вполне стабильных раздавателей DNS. Ограничения: на один аккаунт – не больше пяти доменов. Обращений к DNS-серверу на один домен не должно превышать 1 млн.раз за год. Это равняется трем тысячам запросам в день на ваш сайт. Даже без учета кэширования DNS это много, так что можно сказать, что ограничения нет. Для .spb.ru / .msk.ru не подходит по некоторым причинам, о которых долго писать.

XName.Org – или/или, 1st/2nd. Поддерживают, естественно, zone transfer, поэтому подходят для .spb.ru / .msk.ru (см. мою статью о регистрации домена в зоне .spb.ru / .msk.ru).

Сайты, предоставляющие только вторичный бесплатный DNS.

Secondary.Com – один из самых известных сервисов. Ограничения: максимум 5 доменов и 100 записей на один аккаунт. По смыслу схемы, должен поддерживать transfer zone, и, следовательно, подходить для поддержки доменов в зоне .spb.ru / .msk.ru, но конкретно я не проверял. Как проверю – здесь же и напишу.

Secondary.Net.Ua – украинский сервис, достаточно быстрый и надежный. Ограничений никаких. Дают три ns-сервера. Для получения аккаунта необходимо иметь RIPE или NetworkSolutions NIC handle. Поддерживает transfer zone, для чего надо при настройке зоны включить галочку "Allow xfer". То бишь можно юзать для .spb.ru / .msk.ru.

www.trifle.net/DNS/ – самый старый русский сервис, дающий вторичный DNS. Не самый надежный и защищенный, но вполне работоспособный. Про поддержку transfer zone, про ограничения и кол-во выдаваемых серверов не знаю, потому как не пользовался.

Сопутствующие сайты.

PublicRedirect.Com – позволяет бесплатно делать редирект одного домена на другой. То бишь имеете вы пять доменов, и хотите, чтобы они вели на один сайт, а виртуальный хостинг оплачивать за все 5 доменов – жаба душит, или хостер не дает. Ну и делаете виртуальный хостинг только для одного домена, а потом идете на этот сайт, и с его помощью настраиваете сколько угодно доменов на уже существующий. За стабильность работы сервиса не отвечу, стоимость-то – ноль :)

Общая информация по доменам.

AllDomains.Com – достаточно полная и верная информация практически по всем TLD и ccTLD.

Форумы по доменам.

WebHostingTalk.Ru – русскоязычный форум по хостингу и всему, что с ним связано. Есть отдельный тред по доменам. Я на этом форуме достаточно часто объявляюсь :)

WebHostingTalk.Com – англоязычный форум по хостингу и всему, что с ним связано. Также есть отдельный тред по доменам. Там я реже, но там иногда можно найти ответы на вопросы, на которые в русскоязычном форуме никто ответа не знает.

Ru-Board – форум на Ru-Board, посвященный хостингу. Отдельного треда для доменов нет, но среди тем о хостинге попадаются и темы по доменам, тоже можно что-нить полезное найти.

Службы Whois.

Whois на RIPN – служба на сайте РосНИИРОС. Можно посмотреть информацию о доменах в зонах .ru, .com.ru, .net.ru, .org.ru, .pp.ru, и о персонах и организациях, зарегистрированных в базе РосНИИРОС (с суффиксами -RIPN, -MNT-RIPN, -ORG-RIPN).

Whois на RU-CENTER – служба на сайте Nic.Ru. Можно посмотреть информацию о доменах в зонах .ru, .su, .org., .com, .net, .biz, .info, .name, а также об IP-адресах, автономных системах, персонах и обратных зонах по базе данных RIPE (Европа).

Afilias whois (.INFO) – whois для TLD .info (Nic.Ru не всегда дает верную информацию).

.Name whois – для проверки занятости. Для регистрации – сюда.

whois и список уже зарегистрированных доменов второго уровня – для TLD .museum.

.biz whois – от Neulevel, держателя .biz.

UWhois.Com – whois почти по всем ccTLDs.