EFF's Guide to the Internet, v

EFF's Guide to the Internet, v.2.22

(formerly The Big Dummy's Guide to the Internet)

Copyright 1993, 1994 Electronic Frontier Foundation

Руководство по глобальной компьютерной сети Internet

Copyright (C) 1994, Мильвидский Андрей Романович, SOFTCOM, Ltd.

РАСПРОСТРАНЕНИЕ:

Все права на перевод данного руководства на русский язык принадлежат

предприятию SOFTCOM.

SOFTCOM, Ltd.

123154, P.O. Box 18, Moscow, Russia

Ph./Fax: +7(095)192-5816

E-Mail: softcom@glas.apc.org

СОДЕРЖАНИЕ

Вступление Мильвидского Андрея, президента SOFTCOM, Ltd.

Вступление Митчела Капора, сооснователя Electronic Frontier Foundation

Предисловие Адама Гаффина, автора книги, Network World

Глава 1: Установил, настроил и вперед!

1.1 Подготовка и установка...

1.2 Вперед!

1.3 Общедоступные системы входа в Internet

1.4 Если в вашем городе нет прямого доступа к Internet

1.5 Происхождение Сети

1.6 Как работает Сеть

1.7 Когда что-то не так

1.8 Куда обратиться с вопросами

Глава 2: Электронная почта (E-mail)

2.1 Основы

2.2 Elm ── более удобный способ

2.3 Pine ── еще лучший способ, чем Elm

2.4 Улыбки

2.5 Посылка электронной почты в другие сети

2.6 Семь комманд Unix, без которых нельзя обойтись

2.7 Когда что-то не так

Глава 3: Usenet I

3.1 Всемирная поилка

3.2 Движение по Usenet с помощью nn

3.3 Комманды nn

3.4 Использование rn

3.5 Комманды rn

3.6 Основные группы новостей

3.7 Обсуждения

3.8 Кросс-постинг

Глава 4: Usenet II

4.1 Наезды, болтовня и недержание

4.2 Файлы исключений (killfiles) - средства от тех, кто вас беспокоит

4.3 Несколько советов по Usenet

4.4 Мальчик с опухолью мозга, налог на модемы и письмо-пирамида

4.5 Большая подпись

4.6 Первая поправка и местное законодательство

4.7 История Usenet

4.8 Если что-то не так

4.9 Куда обратиться с вопросами

Глава 5: Списки рассылки и Bitnet

5.1 Списки рассылки Internet

5.2 Bitnet

Глава 6: Telnet

6.1 Внутрь сети

6.2 Каталоги библиотек

6.3 Некоторые интересные подсистемы Telnet

6.4 Системы досок объявлений Telnet (BBS)

6.5 Как "указать пальцем" на кого-нибудь

6.6 Как найти человека в сети

6.7 Когда что-то не так

6.8 Куда обратиться с вопросами

Глава 7: Протокол пересылки файлов (FTP)

7.1 Тонны файлов

7.2 Ваш друг Archie

7.3 Прием файлов

7.4 Дополнительные буквы ── указатели метода раскодировки файла

7.5 Клавиатурная кабалистика

7.6 Некоторые интересные подсистемы FTP

7.7 ncftp ── а теперь скажи мне!

7.8 Проект "Гуттенберг" ── электронные книги

7.9 Когда что-то не так

7.10 Куда обратиться с вопросами

Глава 8: Программы Gopher, WAIS и WWW

8.1 Программы Gopher

8.2 Копаем глубже

8.3 Комманды Gopher

8.4 Некоторые интересные подсистемы Gopher

8.5 Серверы распределенной информации (WAIS)

8.6 Всемирная сеть (WWW)

8.7 Клиенты, или как выловить из сети побольше

8.8 Когда что-то не так

8.9 Куда обратиться с вопросами

Глава 9: Усовершенствованная электронная почта

9.1 Файлы по почте

9.2 Прием файлов

9.3 Посылка файлов в подсистемы вне Internet

9.4 Получение по электронной почте файлов FTP

9.5 Oracle знает все

Глава 10: Новости со всего света

10.1 Clarinet: ЮПИ (UPI), Дэйв Барри (Dave Barry) и Дилберт (Dilbert)

10.2 Рейтер (Reuters)

10.3 США Сегодня (USA Today)

10.4 Национальное Общественное Радио (National Public Radio)

10.5 Мир сегодня: от Беларуссии до Бразилии

10.6 Организации, передающие новости по электронной почте

10.7 Куда обратиться с вопросами

Глава 11: IRC, MUD и другие вещи, которые веселее, чем кажутся

11.1 Разговор (Talk)

11.2 Релейный разговор (Internet Relay Chat - IRC)

11.3 Команды IRC

11.4 IRC во время кризиса

11.5 MUD

11.6 Го, го, го (да еще и шахматы)!

11.7 Обратная сторона медали

11.8 Куда обратиться с вопросами

Глава 12: Образование и сеть

12.1 Сеть в школьных классах

12.2 Некоторые специфические ресурсы для учителей и учеников

12.3 Usenet и Bitnet в классе

Глава 13: Бизнес в сети

13.1 Открываем лавочку

13.2 Куда обратиться с вопросами

Глава 14: Заключение ── конец?

Приложение A: Глоссарий

Приложение B: Общая информация об ассоциации Electronic Frontier Foundation

Вступление

Мильвидского Андрея Романовича,

Президент,

SOFTCOM, Ltd.

Возросший за последние годы в России интерес к Internet определил

необходимость выхода в свет подобного руководства на русском языке. К

сожалению многие пользователи Internet в России еще не раскрыли для себя

все возможности глобальных информационных сетей, к которым они получили

доступ, и в большинстве случаев использование Internet ограничивается

работой с электронной почтой и телеконференциями, в то время, как Internet

наряду с этим имеет множество других возможностей, направленных на

предоставление удобного и недорогого доступа к неисчерпаемым объемам

информации, и предоставление различных способов общения с людьми по всему

миру.

Данное руководство стало первым пособием по Internet на русском языке,

опубликованном в России. Оно призвано расширить взгляды читателей на

возможности Internet и содержит в себе множество примеров их использования.

В настоящий момент печатная версия данного руководства активно продается в

книжных магазинах на территории России.

Мне хотелось бы поблагодарить за оказание активной поддержки в процесе

подготовки данного издания сотрудников ассоциации EFF и издательства MIT

Press, в особенности его сотрудницу Кристину Санмартин (Cristina Sanmartin),

которая приняла непосредственное участие в разрешении многих проблем,

возникавших в процессе работы.

Я надеюсь, что наши усилия не окажутся бесполезными и данное

руководство станет для вас путеводной звездой в бескрайнем мире Internet.

Мильвидский Андрей Романович,

Президент,

SOFTCOM, Ltd.

milvid@glas.apc.org

Вступление

Митчела Капора (Mitchell Kapor),

Сооснователь,

Electronic Frontier Foundation

Добро пожаловать в мир Internet.

Ассоциация Electronic Frontier Foundation (EFF) с радостью

субсидировала публикацию данного руководства по Internet. EFF - некоммерческая

организация, основанная в Вашингтоне, считающая своей задачей обеспечить

всеобщий доступ к недавно появившимся технологиям связи, позволяющим принимать

активное участие в событиях, происходящих в нашем мире. Поскольку все большее

и большее количество информации становится доступно через Internet, появляются

большие возможности для тех, кто имеет к этой информации доступ. К сожалению,

если доступ в Internet не будет иметь широкого распространения, многие лишатся

возможностей, открываемых им.

Руководство по Internet составлялось с целью открыть некоторые двери к

обширной информационным ресурсам, доступным в самой большой в мире сети -

Internet.

Идея создания руководства по Internet в ассоциации EFF и издательстве

MIT Press, выпустившем печатную версию руководства, зародилась в ходе

нескольких дискуссий, в которых принимал участие Стив Кислер (Steve Cisler) из

Apple Computer, Inc., в июне 1991 года. При поддержке Apple Computer

ассоциации EFF удалось заинтересовать Адама Гаффина (Adam Gaffin) в написании

этого руководства, работа над которым фактически началась уже в сентябре 1991

года. Первоначально руководство распространялось электронным путем, как "Big

Dummy's Guide to the Internet".

Идея состояла в том, чтобы написать руководство по Internet для людей

с небольшим опытом или отсутствием такового в работе с компьютерными сетями.

Мы предполагали составление этого руководства в ASCII и других форматах для

рассылки его на дисках, так же как и его изготовление в печатном виде. В

данный момент мы более чем достигли наших целей. Люди из таких географически

удаленных мест, как Германия, Италия, Канада, Южная Африка, Япония, Шотландия,

Норвегия и Антарктика прислали по электронной почте сообщения о том, что они

получили руководство.

В данный момент руководство по Internet доступно в различных форматах,

включая ASCII, Windows Help, World-Wide Web, PostScript и AmigaGuide. Также

руководство доступно и в печатном виде.

Вы можете найти электронную версию руководства, используя анонимный

ftp к ftp.eff.org в файле /pub/Net_info/Guidebooks/EFF_Net_Guide/netguide.eff.

Или послать по электронной почте сообщение по адресу info@eff.org. Электронная

версия регулярно модифицируется и дополняется

(/pub/Net_info/Guidebooks/EFF_Net_Guide/Udates/ ).

Ассоциация EFF хотела бы поблагодарить Адама Гаффина за проделанную

работу по составлению популярного описания сети. Также мы хотели бы

поблагодарить сотрудников фирмы Apple, особенно Стива Кислера, за их поддержку

наших стремлений донести это руководство до вас. В заключение мы хотели бы

поблагодарить наших издателей в MIT Press, особенно Боба Приора (Bob Prior),

за сотрудничество вне рамок нашего договора, что позволило нам продолжить

распространение книги в электронном формате и сохранить ее низкую стоимость.

Мы приглашаем вас присоединиться к EFF в нашей борьбе за равноправие

доступа к сетям и свободу слова, которые должны быть защищены в недавно

появившихся системах связи. EFF - членская организация, и благодаря взносам,

подобным вашему, мы сможем продолжать субсидировать важные проекты и делать

связь более доступной. Информация о Electronic Frontier Foundation и некоторых

работах ассоциации расположена в конце этой книги. Мы надеемся, что это

руководство поможет вам узнать о целых новых мирах, где вы несомненно найдете

новых друзей и приобретете новый опыт. Наслаждайтесь!

Митчел Капор (Mitchell Kapor)

Председатель Правления

Electronic Frontier Foundation

mkapor@eff.org

Предисловие

Адама Гаффина,

Автор руководства,

Network World, Framingham, Mass.

Добро пожаловать в Internet! Вы приближаетесь к моменту начала

путишествия по уникальному миру, миру без границ, к системе, которая

предоставит Вам возможность мгновенно перенестись в любую точку планеты,

несмотря на то, что является лишь серией электронных импульсов.

Вы получите возможность присоединиться к постоянно растущему сообществу

миллионов людей во всем мире, ежедневно использующих данные ресурсы.

При помощи этой книги Вы сможете использовать Internet чтобы:

∙ Поддерживать контакты с друзьями, родственниками и коллегами

во всем мире, затрачивая на это лишь ничтожную долю стоимости

телефонного звонка или даже почтовой пересылки.

∙ Принимать участие в обсуждении различных вопросов от археологии

до зоологии на различных языках.

∙ Иметь доступ в тысячи информационных баз данных и библиотек по

всему миру.

∙ Получать последнюю информацию о новостях, спорте, официальных

прогнозах погоды.

∙ Принимать участие в играх "реального времени" вместе с дюжиной

других людей со всего мира.

Подсоединение к Сети в наши дни связано с захватывающим дух чувством

приключения и желанием познания.

Посещение сети сегодня больше напоминает путешествие в другую страну,

где столь многое можно увидеть и сделать, но вначале все будет

казаться незнакомым для вас, и вы будете чувствовать себя иностранцем.

Когда вы впервые попадаете в Сеть, вы не имеете возможности

ориентироваться по указателям. Вы потеряетесь. А если вам не повезет, вы

можете даже зайти в некоторые частные владения, из которых вас

достаточно быстро вернут на место откуда вы пришли. Больше того, целые

страны могут оказаться недоступными для вас.

Но к счастью, большинство владений в сетях являются по-настоящему

дружественными по отношению к посетителям. В действительности, Сеть

имеет богатые традиции по оказанию всяческой поддержки своим постоянным

посетителям и новичкам. Еще недавно существовало только очень малое

количество руководств для простых пользователей, и информация о Сети

распространялась традиционным "устным" способом, когда

сторожилы помогали новичкам.

Итак, вы соединились с Сетью. Не бойтесь попросить помочь вам. Вы

будете удивлены как много людей протянет вам руку!

Без помощи некоторых людей, эта книга могла бы не быть написана.

В связи с этим я хочу выразить благодарность всем, кто вносил свои предложения,

добавления и исправления со времени первого появления руководства

(названного в оригинале Big Dummy's Guide to the Internet) в Internet в

1993 году.

Особую благодарность хочу выразить моей любимой жене Ненси (Nancy).

Также мне хотелось бы поблагодарить следующих людей, которые, зная это

или нет, так или иначе, оказали практическую помощь при написании книги.

Ронда Чепмен (Rhonda Chapman), Джим Кокс (Jim Cocks), Том Зарник

(Tom Czarnik), Кристофер Девис (Christopher Davis), Девид ДеСимон (David

DeSimone), Джанни деВото (Jeanne deVoto), Фил Эшиллер (Phil Eschallier),

Нико Гарсиа (Nico Garcia), Джо Гренрос (Joe Granrose),

Жорж Хейткоттер (Joerg Heitkoetter), Джо Илакьюа (Joe Ilacqua),

Джонатан Кеменс (Jonathan Kamens), Питер Камински (Peter Kaminski),

Томас А. Кригер (Thomas A. Kreeger), Стентон МакКендлиш (Stanton McCandlish),

Лин Филлипс (Leanne Phillips), Ненси Рейнольдс (Nancy Reynolds),

Хелен Трильен Рос (Helen Trillian Rose), Барри Шейн (Barry Shein),

Дженифер "Майра" Смит (Jennifer "Moira" Smith), Джерард ван дер

Лен (Gerard van der Leun) и Скот Яноф (Scott Yanoff).

Если у вас возникнут какие-либо предложения или замечания о том как

сделать это руководство лучше, я был бы рад ознакомиться с ними. Вы

можете связаться со мной через электронную почту, послав сообщение

по адресу adamg@world.std.com.

Бостон, Массачусетс, Февраль, 1994

Глава 1: УСТАНОВИЛ, НАСТРОИЛ - И ВПЕРЕД!

1.1 Подготовка и установка ...

В наши дни весь мир находится на расстоянии телефонного звонка. Имея

модем и компьютер, вы можете связаться с Internet - самой большой

компьютерной сетью в мире (а если вам повезет, то и модем не нужен: многие

колледжи и компании предоставляют своим студентам и служащим прямой доступ

к Internet).

В качестве телефонной линии можно использовать ту, по которой вы

разговариваете - только помните, что если у вас есть дополнительные

аппараты, то вы (а также все остальные в доме или в офисе) не смогут ими

воспользоваться, пока вы находитесь на связи с Сетью.

Модем - это нечто вроде переводчика между компьютером и телефонной

сетью. Он нужен потому, что телефонные линии и компьютеры передают и

обрабатывают информацию двумя различными и несовместимыми способами.

Компьютеры "разговаривают" на языке цифр - они пересылают и хранят

информацию в виде последовательностей чисел. Телефонные линии работают с

аналоговыми сигналами, которые на экране осциллографа выглядят как волны.

Когда ваш компьютер готов передавать данные в другой компьютер по

телефонной линии, модем преобразует числа из компьютера в такие волны (это

звучит как какофония скрипов), то есть "модулирует" их. Если же к вашему

модему приходит информация в виде волн, он их преобразует в числа,

доступные компьютеру - "демодулирует".

Все чаще и чаще выпускаются компьютеры со встроенными модемами. Если

на вашем компьютере такового нет, вам придется решить, какую скорость

передачи должен иметь модем, который вы себе купите. Скорость модема

измеряется в битах в секунду (бод). Количество бод - это количество бит,

которые может в течение одной секунды передавать или принимать модем. Буква

или символ состоят из восьми бит.

Сейчас можно купить модем 2400 за сумму меньше 60 долларов - и

большинство из них также способны передавать факсы. По ценам, начиная от 150

долларов можно купить модем, который может пересылать данные со скоростью

14400 бод (и даже быстрее при использовании специальных способов сжатия

данных). Если у вас есть основания полагать, что вы будете использовать

Сеть для пересылки большого количества файлов, то более быстрый модем

окупит свою цену. Он многократно снизит время пересылки, и если вы платите

за доступ к Сети почасово, резко уменьшит размеры поступающих счетов за

время связи.

Как и компьютер, к которому он присоединен, модем бесполезен без

программного обеспечения, которое объясняет ему, как ему работать. В

настоящее время большинство модемов поставляется с программным обеспечением,

которое легко инсталлируется. Испробуйте соответствующую программу. Если ее

трудно использовать или понять, рассмотрите как вариант поход в ближайший

магазин, торгующий программным обеспечением, с целью найти программу

получше. На коммуникационные программы можно потратить несколько сот

долларов; однако если у вас нет каких-то очень уж специальных потребностей,

это будут выброшенные деньги, поскольку есть неимоверное количество хороших

программ стоимостью где-то около ста долларов и меньше. Среди основных

свойств, которые вам следует искать в своей программе, должно быть наличие

набора различных "протоколов" (о них вскоре будет сказано больше) для

передачи файлов в Сеть и из нее наличие возможности писать файлы сценариев

("script") или команд ("command"), дающих возможность автоматизировать

такие шаги, как, например, вход в местную систему.

Покупая модем и программное обеспечение к нему, спросите у продавца,

как их устанавливать и как ими пользоваться. Испробуйте программное

обеспечение, если сможете. Если продавец не может вам помочь, найдите

другого продавца. Вы не только предохраните себя от большого разочарования,

но и познакомитесь с первой директивой Internet : "Ask. People Know."

(Спросите тех, кто знает).

Чтобы использовать все предоставляемые Сетью удобства, вы должны

провести несколько минут за изучением руководств и документации, полученной

с программным обеспечением. Есть несколько моментов, на которые следует

обратить особое внимание: Загрузка из компьютера в сеть (upload) и

загрузка из сети в компьютер (download); перехват экрана (screen

capturing), называемый также ("screen dumping"); регистрация (logging); как

сменить протокол; эмуляция терминала. Также существенно знать, как

преобразовать файл, созданный вашим текст-процессором, в формат "ASCII" или

"текст", что позволит вам поделиться своими мыслями с другими

пользователями Сети.

Загрузка файла из компьютера в Сеть (Upload) - это процесс передачи

файла из вашего компьютера в какую-то из систем сети.

Загрузка файла из Сети в компьютер (Download) - это процесс передачи

файла из какого-то места в Сети в ваш компьютер. Вообще говоря, все

процессы к гиперпространстве идут "Вверх" ("up") в сторону Сети, а "Вниз"

("down") - в вашу сторону.

Есть вероятность, что купленное вами программное обеспечение будет

содержать несколько "протоколов", используемых при таких передачах. Эти

протоколы представляют собой системы, разработанные для гарантии того, что

шумы в линии или статические помехи не вызовут ошибок, могущих привести к

гибели передаваемой информации. По сути говоря, при передаче с

использованием протокола файл передается последовательностью фрагментов.

После передачи каждого фрагмента ваш компьютер и Сеть их сравнивают. Если

два таких фрагмента не совпадают полностью, передачу повторяют до тех пор,

пока обе стороны не согласятся, что имеющиеся у них фрагменты информации

идентичны. Если после нескольких попыток информация не прошла, вы либо

получите сообщение об ошибке, либо ваш экран "зависнет". В этом

случае попробуйте снова. Если после пяти попыток вы не сдвинетесь с места,

то что-то неправильно а) в файле; б) в телефонной линии; в) в системе, с

которой вы соединились; или г) в вашем собственном компьютере.

Время от времени вы, вероятно, захотите запомнить некоторые приходящие

от Сети сообщения, чтобы посмотреть их позже - какой-нибудь рецепт,

какая-то особенно остроумная реплика, что-то, о чем вы хотите написать

своему конгрессмену, еще что-нибудь. Здесь на сцене появляются перехват

экрана и регистрация.

Когда вы даете своему коммуникационному программному обеспечению

команду перехватить экран, оно открывает в вашем компьютере файл (обычно в

той же директории, которая используется этим программным обеспечением) и

"выгружает" в него тот образ, который находится на экране в этот момент.

Регистрация работает несколько по-другому. При выдаче команды

регистрации программное обеспечение также получает директиву открыть файл

(и опять-таки, как правило, в той же директории, которая используется этим

программным обеспечением) и дать ему имя. Затем, пока режим регистрации не

будет явно отменен, все что проходит по вашему экрану, копируется в этот

файл - будто записывается на видеокассету. Это удобно при перехватывании

длинных документов, прокрутка которых занимает несколько страниц - если

использовать перехват экрана, для каждого нового экрана пришлось бы

повторять команду перехвата.

Эмуляция терминала - это способ, которым ваш компьютер изображает, или

эмулирует режим, в котором другие компьютеры помещают информацию на экран

или принимают символы с клавиатуры. Вообще говоря, большая часть систем

Сети используют систему, называемую VT100. К счастью, почти все программы

коммуникаций, предлагаемые на рынке в настоящее время, поддерживают этот

режим - однако убедитесь, что в отношении вашего коммуникационного пакета

это тоже верно.

Еще вы должны знать кое-что о протоколах. Есть несколько способов

передачи символов компьютерами. К счастью, вам надо иметь понятие только о

двух протоколах: 8-1-N (это значит "8 бит, 1 бит останова, отсутствие

контроля по четности-нечетности" - что-нибудь поняли?) и 7-1-E (7 бит, 1

бит останова, контроль по четности).

Вообще говоря, системы на основе Unix используют протокол 7-1-E, в то

время как системы на основе MS-DOS используют протокол 8-1-N. А что делать,

если вы не знаете, к какой из этих систем вы подсоединены? Попробуйте одну

из этих установок. Если то, что вы получите после соединения, выглядит

абракадаброй, вам, скорее всего, нужен другой режим. В этом случае вы либо

можете изменить установки, не прерывая связи, и нажать enter, или прервать

связь и попробовать соединиться снова с другими параметрами связи. Может

также оказаться, что ваш модем и модем на другом конце связи не согласованы

по скорости передачи (числу бод) Если смена протокола не помогает,

попробуйте изменить скорость передачи (но не следует устанавливать ее выше,

чем указано для вашего модема). И не беспокойтесь, помните: вы ничего не

можете сломать! Если что-то выглядит неправильно, то оно, скорее всего, и

есть неправильно. Ничто не узнается без старания, ошибок и усилий.

Вот это - главные основы. А теперь - в Сеть!

1.2 Вперед!

Когда-то только те, кто учились или работали в организациях, связанных

с Сетью непосредственно, имели доступ в этот мир. Теперь же все

возрастающее число "общедоступных" систем обеспечивает доступ каждому. Эти

системы можно найти в нескольких штатах, а пара таких подсистем может

обеспечить доступ через всю страну.

Есть два основных вида таких местных систем. Наиболее обычная известна

под именем системы UUCP (UUCP - обычный способ передачи информации между

двумя операционными системами Unix), и она предоставляет доступ к

международной электронной почте и конференциям.

Но в последние годы наблюдался рост числа более мощных подсистем,

которые позволяют входить в Сеть таким образом, что можно использовать всю

ее мощь. Такие подсистемы Internet дают доступ не только к электронной

почте и конференциям, но и к таким услугам, как базы данных, электронные

библиотеки, большие собрания файлов и программ по всему миру. Они также

быстрее - как только вы заканчиваете писать сообщение, оно уже отсылается

по адресу назначения.

Некоторые подсистемы ведутся коммерческими компаниями, - другие -

некоммерческими, бесприбыльными организациями. Некоторые из этих

общедоступных или местных систем освобождают от оплаты. Другие требуют

фиксированной помесячной или годовой оплаты при неограниченном времени

доступа. И лишь немногие взимают почасовую плату за время связи. Системы,

взимающие плату за доступ, обычно позволяют расплачиваться электронным

способом с помощью кредитной карточки. Некоторые позволяют вам установить

систему ведения расчетов.

Но цена - это только один из аспектов, который следует учесть при

выборе местной системы, особенно если вы живете там, где таких доступных

систем более одной. Многие системы дают сначала возможность осмотреться, а

потом уже поставить свою подпись. Каков диапазон услуг у каждой из них?

Насколько они легки в использовании? Какую поддержку и помощь можно

получить от системного администратора?

Последние два вопроса имеют особую важность, поскольку у многих систем

совсем нет пользовательского интерфейса; после соединения вас выбрасывают

прямо в операционную систему Unix. Если вы с ней знакомы, или если вы

хотите ее изучить, то такие системы обладают в этом смысле феноменальными

возможностями - кроме доступа к Сети, вы получаете доступ ко всей мощи

системы Unix, которая может все - от компиляции вашей программы до игры в

какую-нибудь игру в режиме реального времени.

Но если вы не хотите быть поставленным перед необходимостью изучения

Unix, то на этот случай существуют другие общедоступные системы, работающие

с помощью системы меню (как в ресторане: вам показывают список, а вы

выбираете из него то, что вам хочется), или предоставляющие доступ к

"интерфейсу пользователя", с которым легче разобраться, чем с криптографией

Unix.

Если вам не требуется доступ ко всему набору услуг Internet,

подсистемы UUCP имеет смысл с финансовой точки зрения. Они берут плату

меньше, чем коммерческие фирмы, предлагающие доступ к Internet, хотя их

сообщения могут проходить не так быстро.

Некоторые системы могут также иметь свойственные только им местные

услуги, от расширенного набора конференций до библиотек больших файлов.

1.3 Общедоступные системы входа в Internet

Когда ваш коммуникационный пакет прозвонится на одну из таких местных

систем, после соединения произойдет одно или два события. Либо вы увидите

на экране кучу мусора, либо вас попросят зарегистрироваться. Если появится

мусор, то, вероятно, вам надо изменить параметры программного обеспечения

(на 7-1-E или 8-1-N, в зависимости от ситуации). Прервите связь, внесите

изменения и попробуйте снова.

После соединения есть вероятность увидеть следующее сообщение:

Welcome to THE WORLD

Public Access UNIX for the '90s

Login as 'new' if you do not have an account

login:

────────────────────────────────────────────────────────────────────────────

Добро пожаловать в МИР

Общедоступный UNIX для 90-х

Зарегистрируйтесь как 'new' (новый), если

у вас нет своего раздела

login:

────────────────────────────────────────────────────────────────────────────

Последняя строка - это приглашение к некоторому действию. Поскольку

это ваше первое обращение к системе, введите

new

и нажмите enter. Чаще всего, когда местная система попросит вас что-то

ввести, в кавычках будет сообщаться, что именно следует ввести (например,

'new'). Сами кавычки вводить не надо. Повторяем еще раз: не вводите

кавычки.

Что вы увидите после этого - зависит от системы, но обычно такое

сообщение будет состоять из информации относительно цен и услуг (а для

запоминания этой информации можете включить функцию регистрации у своего

программного обеспечения). Вероятно, что вас спросят, хотите ли вы

определить для себя раздел или желаете сначала осмотреться в системе.

У вас могут запросить также ваше "имя пользователя" ("user name").

Имеется в виду не ваше полное имя, а некоторое однословное имя, которое вы

желаете использовать, находясь на связи. Это может быть произвольная

комбинация букв и цифр, все - символы нижнего регистра. Многие используют

для этого первый инициал в комбинации с фамилией (например, "jdoe"); или

имя и первую букву фамилии (например, "johnd"); или просто инициалы

("jxd"). Другие придумывают себе клички. Вы сначала все же подумайте,

поскольку имя пользователя станет частью вашего электронного адреса (об

этом подробнее см. главу 2). Единственным исключением являются системы

Free-Net, которые присвоят вам имя пользователя, состоящее из произвольной

последовательности букв и цифр.

Вот вы уже и в Сети. Оглядитесь в системе. Посмотрите, есть ли на ней

файлы помощи, которые вы могли бы прочесть. Если эта система работает на

основе меню, выберите различные возможности и посмотрите, что произойдет.

Помните: вы ничего не можете сломать. Чем больше вы будете играть, тем

свободнее будете себя чувствовать.

Далее приводится список общедоступных подсистем Internet, которые

являются компьютерными системами, дающими доступ в Сеть. Все они дают

доступ к международной почте и к Usenet (международные конференции). Кроме

того, они предлагают:

FTP: Протокол передачи файлов - доступ к сотням библиотек файлов (все

- от программного обеспечения компьютера до исторических документов и

текстов песен). У вас будет возможность передать эти файлы из Сети на

свой компьютер.

Telnet: Доступ к базам данных, каталогам компьютеризированных

библиотек, сводкам погоды и прочим информационным услугам, а также

живые, в реальном времени компьютерные игры с другими игроками по

всему свету.

Могут предлагаться и такие услуги:

WAIS: Сервер распределенной информации (Wide-area Information

Server); программа, которая может просмотреть десятки баз данных в

одном поиске.

Gopher: Программа, которая дает доступ к десяткам электронных баз

данных и услуг путем выбора возможностей из меню. Ее можно

использовать также для копирования текстовых и программных файлов в

свой почтовый ящик.

IRC: Релейный разговор по Internet (Internet Relay Chat), эмулятор

радиотелефона, который позволяет поддерживать живой разговор с

клавиатуры с людьми по всему свету.

Однако даже в тех системах, в которых эти услуги прямо не

предоставляются, имеется возможность связаться с ними с помощью telnet (см.

главу 6). В следующем далее списке приведены системы, которые предоставляют

услуги с помощью меню, отмечены; все остальные выводят вас прямо в систему Unix

(это как система MS-DOS, которая окончила колледж). К некоторым из этих систем

можно получить доступ через национальные сети данных, такие, как CompuServe

Packet Network и SprintNet.

Просим заметить, что указанные цены могут меняться. Многие подсистемы

требуют от новых или возможных пользователей зарегистрироваться при первом

вызове особым образом; в данном списке указывается имя, которое следует в

таких случаях использовать.

Алабама

Хантсвилль. Nuance. Позвоните по голосовому номеру и спросите

модемные номера. Вступление 35 долларов; месячная плата 25 долларов.

Голосовой номер: (205) 533-4296.

[1]Альберта

Эдмонтон. PUCNet Computer Connections, (403) 484-5640. Вступление

10 долларов; месячная плата 25 долларов при

двадцати часах доступа в месяц плюс 6.25 долларов в час за доступ к функциям ftp

и telnet. Голосовой номер: (403) 448-1901.

Аляска

Анкоридж. Северовосточный университет Аляски, Служба тундры

(University of Alaska Southeast, Tundra Services), (907) 789-1314; имеет

местную службу дозвона в нескольких городах. Месячная плата 20 долларов.

Голосовой номер: (907) 465-6453.

Аризона

Туксон. Data Basics, (602) 721-5887. Плата 25

долларов в месяц или 180 долларов в год. Голосовой номер: (602) 721-1988.

Феникс/Туксон. Internet Direct, (602) 274-9600

(Феникс); (602) 321-9600 (Таксон). При входе регистрируйтесь как: guest

(гость). 20 долларов в месяц. Голосовой номер: (602) 274-0100 (Феникс);

(602) 324-0100 (Туксон).

Британская Колумбия

Виктория. Victoria Free-Net, (604)

595-2300. Меню. Доступ ко всем возможностям требует заполнения письменной

формы. Пользователи могут быть подсоединены к другим системам Free-Net в

Канаде и Соединенных Штатах. Бесплатно. При входе регистрируйтесь как:

guest (гость). Голосовой номер: (604) 389-6026.

Вирджиния

Норфолк/Пенинсула. Wyvern Technologies, (804) 627-1828 (Норфолк);

(804) 886-0662 (Пенинсула). Вступительный взнос 10 долларов; 15 долларов в

месяц или 144 доллара в год. Голосовой номер: (804) 622-4289.

Вашингтон, Округ Колумбия

The Meta Network. Чтобы узнать местные модемные номера, позвоните по

голосовому номеру. Правительственные конференции, меню. Вступительный взнос 15

долларов; 20 долларов в месяц. Голосовой номер: (703) 243-6622.

CapAccess, (202), 785-1523. Зарегистрируйтесь как: guest (гость) с

паролем visitor. Система типа Free-Net (бесплатная - см. Кливленд, Огайо).

Бесплатно. Голосовой номер: (202) 994-4245.

См. также: Список под рубрикой Балтимора, Мэриленд о сетях

Express Access и Clarknet.

Делавар

Миддлтаун. Systems Solutions, (302) 378-1881.

Вступительный взнос 20 долларов; 25 долларов в месяц за полный доступ к

Internet. Голосовой номер: (800) 331-1386

Джорджия

Атланта. Netcom, (303) 758-0101. Информацию о ценах см. Лос Анжелес,

Калифорния.

Иллинойс

Шампань. Prarienet Free-Net, (217) 255-9000. Меню.

Зарегистрируйтесь как: visitor (посетитель). Для жителей Иллинойса -

бесплатно; для остальных 25 долларов в год. Голосовой номер: (217)

244-1962.

Чикаго. MCSNet, (312) 248-0900. 25 долларов в месяц или 65 долларов за

три месяца неограниченного доступа; 30 долларов за три месяца при

ограничении доступа 15 часов в месяц. Голосовой номер: (312) 248-UNIX.

Пеория. Peoria Free-Net, (309) 674-1100.

Аналогична Cleveland Free-Net, см. ниже Огайо.

Пользователи могут быть подсоединены к большим системам Кливленда для выхода на

Usenet и другие службы. Во многих местных библиотеках, правительственных

зданиях и гражданских учреждениях имеются общедоступные терминалы с выходом

на Peoria Free-Net. Для того, чтобы узнать их местонахождение, позвоните по

указанному ниже телефону. Полный доступ (в том числе доступ к электронной

почте) требует заполнения соответствующей письменной формы. Бесплатно.

Голосовой номер: (309) 677-2544.

Калифорния

Беркли. Holonet. Меню. Для бесплатной пробы модемный номер

(510) 704-1058. Информация о местных номерах узнается по голосовому номеру.

60 долларов в год для местного доступа, 2 доллара в час в нерабочее

время. Голосовой номер: (510) 704-0160.

Купертино. Portal. Как Unix, так и меню. (408) 725-0561

(2400 бод); (408) 973-8091 (9600/14400 бод). Вступление 19.95 долларов,

19.95 долларов в месяц. Голосовой номер: (408) 973-9111.

Ирвайн. Dial N' CERF. См. Сан-Диего

Лос Анжелес/Графство Орандж. Kaiwan Public Access Internet,

(714) 539-5726; (310) 527-7358.

Вступление 15 долларов; 11 долларов в месяц (кредитная карта). Голосовой

номер: (714) 638-2139.

Лос Анжелес. Dial N' CERF. См. Сан-Диего

Окленд. Dial N' CERF. См. Сан-Диего

Пасадена. Dial N' CERF. См. Сан-Диего

Пало Альто. Институт Глобальных Коммуникаций (Institute for Global

Communications)., (415) 322-0284. Unix. Местные конференции по проблемам

окружающей среды. Зарегистрируйтесь как: new (новый). 10 долларов в

месяц и 3 доллара за каждый час соединения после первого. Голосовой номер:

(415) 442-0220.

Сан-Диего. Dial N' CERF USA, которую ведет Калифорнийская

Федерация Образования и Исследований (California Education and Research

Federation). Предоставляет местные номера для набора в Сан-Диего, Лос

Анжелесе, Окленде, Пасадене и Ирвайне. Боле подробную информацию можно

получить по голосовым номерам (800) 876-CERF или (619) 534-5087.

Вступление - 50 долларов; 20 долларов в месяц плюс 5 долларов за час

доступа (3 доллара в выходные). Голосовой номер: (800) 876-2373.

Сан-Диего. CTS Network Services, (619) 637-3660.

Зарегистрируйтесь как: help (помощь). Вступление 15 долларов, месячная

плата от 10 долларов до 23 долларов в зависимости от используемого сервиса.

Голосовой номер: (619) 637-3637.

Сан-Диего. Cyberspace Station, (619) 634-1376.

Unix. Зарегистрируйтесь как: guest (гость). Плата: 10 долларов

вступительный взнос; 15 долларов в месяц или 60 долларов за шесть месяцев.

Сан-Франциско. Pathways. Номера узнайте по голосовому номеру. Меню.

Вступительный взнос 25 долларов; 8 долларов в месяц и 3 доллара в час.

Голосовой номер: (415) 346-4188.

Сан-Хосе. Netcom, (510) 865-9004 или 426-6610; (408) 241-9760; (415)

424-0131 (до 9600 бод). Unix. Ведет архивы почты Usenet. Зарегистрируйтесь

как: guest (гость). Вступительный взнос 15 долларов, далее 17.50 долларов в

месяц за неограниченное использование, если вы согласны на автоматическое

выставление счета по адресу счета вашей кредитной карты (иначе 19.50

долларов в месяц по ежемесячным счетам). Голосовой номер: (408)

554-UNIX.

Сан-Хосе. A2i, (408) 293-9010. Зарегистрируйтесь как: guest (гость).

20 долларов в месяц; 45 долларов за три месяца; 72 доллара за шесть

месяцев.

Сосалито. Whole Earth 'Lectronic Link WELL, (415) 332-6106.

Используется средней трудности программное

обеспечение Picospan - некоторый гибрид Unix и системы меню. Новые

пользователи получают напечатанное руководство. Более 200 конференций,

доступных только через WELL. Зарегистрируйтесь как: newuser (новый

пользователь). 15 долларов в месяц плюс 2 доллара в час. Доступ через

всеамериканскую сеть CompuServe Packet Network можно получить за

дополнительные 4.50 долларов в час. Голосовой номер: (415) 332-4335.

Записанное сообщение о текущем состоянии системы: (800) 326-8354 (Только

для континентальной части США).

Квебек

Монреаль. Коммуникационная Ассамблея Монреаля (Communications

Accessibles Montreal), (514) 931-7178 (9600 бод); (514) 931-2333 (2400

бод). 25 долларов в месяц. Голосовой номер: (514) 931-0749.

Колорадо

Колорадо Спрингс/Денвер. CNS, (719) 570-1700 (Колорадо Спрингс); (303)

758-2656 (Денвер). Местные календарные распечатки, записи по лыжному спорту

и биржевым сделкам. У пользователей есть выбор между меню и Unix.

Зарегистрируйтесь как: new (новый). Вступительный взнос 35 долларов; 2.75

долларов в час (минимальная плата 10 долларов в месяц). Голосовой номер:

(719) 592- 1240.

Колорадо Спрингс. Old Colorado

City Communications, (719) 632- 4111. Зарегистрируйтесь как: newuser

(новый пользователь). 25 долларов в месяц. Голосовой номер: (719)

632-4848.

Денвер. Denver Free-Net, (303) 270-4865.

Меню.Доступ к любым услугам требует заполнения письменной формы.

Пользователь имеет возможность связаться с любыми системами Free-Net по

всей стране. Бесплатно. Зарегистрируйтесь как: guest (гость).

Голден. Colorado SuperNet. Обратитесь по

электронной почте к службе факса. Только для жителей Колорадо. Местные

номера для связи есть в нескольких городах Колорадо. Чтобы узнать их,

позвоните по приведенному ниже номеру. 3 доллара за час доступа (1 доллар

за час от

полуночи до 6 утра.); разовый вступительный взнос 20 долларов. Голосовой

номер: (303) 273-3471.

Массачусетс

Бедфорд. Internet Access Company,

(617) 275-0331. Чтобы зарегистрироваться, следуйте подсказкам.

Вступительный взнос 20 долларов; 19.50 долларов в месяц. Голосовой номер:

(617) 275-2221.

Бруклин. The World, (617) 739-9753. "Online Book Initiative"

(Инициатива "Электронная книга") - коллекция электронных книг, поэзии и

прочих текстовых файлов. Зарегистрируйтесь как: new (новый). 5 долларов в

месяц плюс 2 доллара за час доступа или 20 долларов за 20 часов в месяц.

Доступно из любых мест США посредством CompuServe Packet Network

за дополнительные 5.60 долларов в час. Голосовой номер: (617) 739-0202.

Линн. North Shore Access, (617) 593-4557.

Зарегистрируйтесь как: new (новый). 10 долларов за 10 часов доступа в месяц;

1 доллар за каждый час сверх этой нормы. Голосовой номер: (617) 593-3110.

Ворчестер. NovaLink, (508) 754-4009. Зарегистрируйтесь как: info.

Вступительный взнос 12.95 долларов (сюда входит оплата первых двух часов

доступа); 9.95 долларов в месяц (с учетом пяти часов дневного времени

доступа) 1.80 долларов за каждый час сверх этой нормы.

Голосовой номер: (800) 274-2814.

Мичиган

Энн Арбор. MSEN. Для получения сведений о модемных номерах позвоните

по голосовму номеру. Unix. Плата: 20 долларов вступительный взнос; 20

долларов в месяц. Голосовой номер: (313) 998-4562.

Энн Арбор. Michnet. Имеет местные модемные номера в нескольких городах

Мичигана. Чтобы их узнать, позвоните по указанному ниже голосовому номеру.

35 долларов в месяц плюс одноразовый вступительный взнос в 40 долларов.

Дополнительные сетевые взносы за доступ через номера вне Michnet.

Голосовой номер: (313) 764-9430.

Мэриленд

Балтимора. Express Access, (410) 766-1855; (301)

220-0462; (714) 377-9784. Зарегистрируйтесь как: new (новый).

Вступительный взнос 20 долларов; 25 долларов в месяц или 250 долларов в

год. Голосовой номер: (800 969-9090.

Балтимора. Clarknet, (410) 730-9786; (410) 995-0271; (301) 596-1626;

(301) 854-0446. Зарегистрируйтесь как: guest (гость). 23 доллара в месяц,

126 долларов за 6 месяцев или 228 долларов в год. Голосовой номер: (410)

730-9765.

Нью-джерси

Нью-Брунсвик. Digital Express, (908) 937-9481.

Зарегистрируйтесь как: new (новый). Вступительный взнос 20 долларов; 25

долларов в месяц или 250 долларов в год. Голосовой номер: (800) 969-9090.

Нью-Йорк. Panix, (212) 787-3100. Unix или меню. Зарегистрируйтесь

как: newuser (новый пользователь). Вступительный взнос 40 долларов; 19

долларов в месяц или 208 долларов в год. Голосовой номер: (212) 877-4854.

Нью-Йорк. Echo, (212) 989-8411. Unix, но с наличием программного

обеспечения ведения локальных конференций. Зарегистрируйтесь как: newuser

(новый пользователь). 19.95 долларов (13.75 долларов для студентов и

старшеклассников) в месяц. Голосовой номер: (212) 255-3839.

Нью-Йорк. MindVox, (212) 989-4141. Локальные конференции.

Зарегистрируйтесь как: guest (гость). 10 долларов вступительный взнос и 15

долларов в месяц. Голосовой номер: (212) 989-2418.

Нью-Йорк. Pipeline, (212) 267-8606 (9600 бод и выше); (212) 267-7341

(2400 бод). Предлагается графический интерфейс к Windows за 90 долларов.

Зарегистрируйтесь как: guest (гость). 20 долларов в месяц и 2 доллара за

каждый час доступа сверх первых 20 часов или 35 долларов в месяц без лимита

времени. Голосовой номер: (212) 267-3636.

Нью-Йорк. Maestro, (212) 240-9700. Зарегистрируйтесь как:

newuser (новый пользователь). 12 долларов в месяц или 140 долларов в год.

Голосовой номер: (212) 240-9600.

Нью-Хэмпшир

Манчестер. MV Communications, Inc. Чтобы

узнать местные модемные номера, позвоните по указанному ниже голосовму

номеру. 5 долларов в месяц минимум, плюс переменная почасовая ставка,

зависящая от используемых услуг. Голосовой номер: (603) 429-2223.

Огайо

Кливленд. Cleveland Free-Net, (216)

368-3888. Решения Верховного Суда Огайо и США, исторические документы,

множество локальных конференций. Полный доступ (включающий электронную

почту) требует заполнения письменного заявления. Бесплатно. Голосовой

номер: (216) 368-8737.

Цинциннати. Tri-State Free-Net, (513) 579-1990.

Аналогично Cleveland

Free-Net. Полный доступ (включающий электронную почту) требует заполнения

письменного заявления. Бесплатно.

Кливленд. Wariat, (216) 481-9436. Unix или меню. Вступительный взнос

20 долларов; 35 долларов в месяц. Голосовой номер: (216) 481-9428.

Дэйтон. Freelance Systems

Programming, (513) 258-7745. Вступительный взнос 20 долларов; 1 доллар в

час. Голосовой номер: (513) 254-7246.

Лорэн. Lorain County Free-Net,

(216) 277-2359 или 366-9753. Аналогично Cleveland Free-Net. В

поисках дополнительных услуг пользователи могут быть подсоединены к большим

системам Кливленда. Полный доступ (включающий электронную почту) требует

заполнения письменного заявления. Бесплатно. Голосовой номер: (216)

366-4200.

Медина. Medina Free-Net, (216) 723-6732,

225-6732 или 335-6732. В поисках дополнительных услуг пользователи могут

быть подсоединены к большим системам Кливленда. Полный доступ (включающий

электронную почту) требует заполнения письменного заявления. Бесплатно.

Янгстаун. Youngstown Free-Net, (216)

742-3072. В поисках дополнительных услуг пользователи могут быть

подсоединены

к большим системам Кливленда. Полный доступ (включающий электронную

почту) требует заполнения письменного заявления. Бесплатно.

Онтарио

Оттава. National Capital

FreeNet, (613) 780-3733 или (613) 564-3600. Бесплатно, но для доступа ко

всем функциям требуется заполнить письменное заявление.

Торонто. UUNorth. Для получения информации о модемных номерах

позвоните по указанному ниже голосовому номеру. Вступительный взнос 20

долларов; 25 долларов за 20 часов соединения в нерабочее время в месяц.

Голосовой номер: (416) 225-8649.

Торонто. Internex Online, (416) 363-3783.

Как Unix, так и меню. 40

долларов в год за один час в день. Голосовой номер: (416) 363-8676.

Орегон

Портленд. Agora, (503) 293-1772 (2400 бод), (503) 293-2059 (9600 бод

или выше). Зарегистрируйтесь как: apply. 6 долларов в месяц за один час

соединения в день.

Портленд. Teleport, (503) 220-0636 (2400 бод); (503) 220-1016 (9600 и

выше). Зарегистрируйтесь как: new (новый). 10 долларов в месяц за один

час соединения в день. Голосовой номер: (503) 223-4245.

Пенсильвания

Питтсбург. Telerama, (412) 481-5302. 6 долларов за 10 часов

соединения в месяц,

60 центов за каждый дополнительный час. Голосовой номер: (412) 481-3505.

Род Айленд

Ист-Гринвич. IDS World Network, (401) 884-9002.

Кроме Usenet поддерживает конференции из сетей Fidonet и RIME. 10

долларов в месяц; 50 долларов за шесть месяцев; 100 долларов в год.

Провиденс/Сиконк. Anomaly, (401) 331-3706. 125 долларов

за шесть месяцев или 200 долларов в год. Для работников учреждений

образования 75 долларов за шесть месяцев или 125 долларов в год. Голосовой

номер: (401) 273-4669.

Северная Каролина

Шарлотта. Vnet Internet Access, (704) 347-8839;

(919) 406-1544. Зарегистрируйтесь как: new (новый). 25 долларов в месяц.

Голосовой номер: (704) 374-0779.

Triangle Research Park. Rock Concert Net. По

указанному ниже голосовому номеру спросите модемные номера в разных городах

Северной Каролины. 30 долларов в месяц; вступительный взнос 50 долларов.

Голосовой номер: (919) 248-1999.

Техас

Остин. RealTime Communications,

(512) 459-4391. Зарегистрируйтесь как: new (новый). 75 долларов в год.

Голосовой номер: (512) 451-0046.

Даллас. Texas Metronet, (214) 705-2901; (817)

261-1127. Зарегистрируйтесь как: info или signup. Вступительный взнос от

10 долларов до 35 долларов, в зависимости от услуг; от 10 долларов до 45

долларов в месяц, в зависимости от услуг. Голосовой номер: (214) 705-2900

или (817) 543-8756.

Хьюстон. The Black Box, (713) 480-2686. 21.65 долларов

в месяц. Голосовой номер: (713) 480-2684.

Флорида

Талахасси. Talahassee Free-Net, (904)

488-5056. Меню. Полный доступ требует заполнения регистрационной формы.

Есть возможность подсоединяться к другим системам Free-Net по всей стране.

Бесплатно. Голосовой номер: (904) 488-5056.

Штат Вашингтон

Сиэтл. Halcyon, (206) 382-6245. У пользователей есть выбор между

меню и Unix. Зарегистрируйтесь как: new (новый). Вступительный взнос 10

долларов; 60 долларов в квартал или 200 долларов в год. Голосовой номер:

(206) 955-1050.

Сиэтл. Eskimo North, (206) 367-3837 (все скорости), (206) 362-6731

(9600/14400 бод). 10 долларов в месяц или 96 долларов в год. Голосовой

номер: (206) 367-7457.

Соединенное Королевство

Лондон. Demon Internet Systems, 44 (0)81 343 4848. Вступительный

взнос 12.50; 10 в месяц или 132.50 в год. Голосовой номер: 44 (0)81 349

0063

1.4 Если в вашем городе нет прямого доступа к Internet

Если там, где вы живете, нет общедоступной подсистемы, вы все равно

можете связаться с сетью. Некоторые службы предлагают доступ через

национальные сети данных, такие, как CompuServe Packet Network и SprintNet,

у которых есть десятки, даже сотни местных модемных номеров по всей стране.

Среди этих служб Holonet в Беркли, Калифорния, Portal в Купертино,

Калифорния, WELL в Сосалито, Калифорния, Dial 'N CERF в Сан-Диего,

Калифорния, World в Бруклине, Массачусетс и Michnet в Энн Арбор, Мичиган.

Dial 'N CERF предлагает доступ через номер, начинающийся на 800. Ожидаемая

плата за пользование этими сетями - от 2 до 12 долларов в час, сверх

основных цен каждого организатора сети. Точная сумма зависит от сети, времени

суток и типа используемого вами модема. За более подробной информацией

обратитесь в указанные выше службы.

Есть еще четыре организации, дающие доступ к Сети пользователям по

всей стране:

Delphi, базируется в Кембридже, Массачусетс, - сеть, ориентированная

на потребителя, очень похожа на CompuServe или America Online, но только в

настоящий момент предлагает своим подписчикам доступ к службам Internet.

Цены Delphi: 3 доллара в месяц за доступ к Internet, сверх стандартной

платы. Это 10 долларов в месяц за четыре часа доступа в нерабочее время

и 4 доллара за каждый дополнительный час; или 20

долларов за каждые 20 часов доступа в месяц и 1.80 доллара в час за каждый

дополнительный час. Более подробная информация по телефону (800) 695-4005.

BIX (Обмен Байтовой Информацией - Byte Information eXchange)

предлагает доступ к таким возможностям Internet, как FTP, Telnet и

электронная почта в качестве части своих основных услуг. Эта система

принадлежит той же компании, что и Delphi, и предлагает доступ 20 часов в

месяц за 20 долларов. За более подробной информацией обращайтесь по

телефону (800) 695-4775.

PSI, базирующаяся в Рестоне, штат Вайоминг, предоставляет доступ к

услугам Internet по местным модемным номерам пользователям со всей страны,

имеющим компьютер производства фирмы IBM или совместимый. PSILink,

включающая доступ к

электронной почте, Usenet и ftp, стоит 29 долларов в месяц, плюс

одноразовый регистрационный взнос 19 долларов. Требуется специальное

программное обеспечение, но его PSI предоставляет бесплатно.

Global Dialup Service предоставляет доступ к telnet за 39

долларов в месяц плюс одноразовый вступительный взнос 39 долларов. Более

подробную информацию можно получить по телефону (800) 82PSI82 или (703)

620-6651.

NovX Systems Integration, базирующаяся в Сиэтле, штат Вашингтон,

предлагает полный доступ к Internet по номеру, начинающемуся с 800,

доступному из любого места Соединенных Штатов. Вступительный взнос 24.95

долларов, дополнительно к плате 19.95 долларов в месяц и 10.5 долларов

почасовой оплаты. Дополнительную информацию можно получить по телефону (206)

447-0800.

1.5 Происхождение сети

В 1960-х годах исследователи начали эксперименты по соединению

компьютеров друг с другом и с людьми с помощью телефонных линий, используя

фонды Агентства Перспективных Проектов Исследований Министерства Обороны

США (U.S Defense Department's Advanced Research Projects Agency - ARPA).

ARPA интересовалась вопросом о том, можно ли связывать расположенные в

разных местах компьютеры с помощью новой технологии, которая называлась

"коммутация пакетов" (packet switching). Эта технология, в которой данные,

предназначенные для переброски в другое место, разбиваясь на пакеты,

каждый из которых имел свой "адрес назначения" ("forwarding address"),

обещала возможность нескольким пользователям работать по одной и той же

линии связи одновременно. Столь же важным с точки зрения ARPA было то, что

такая технология позволяла создавать сети, дающие возможность

автоматической маршрутизации данных по включенным в нее цепям и

компьютерам. Целью ARPA было не создание современного международного

компьютерного сообщества, а развитие сети передачи данных, которая могла бы

выдержать ядерное нападение.

Предыдущие попытки объединения компьютеров в сеть требовали наличия

линии между двумя компьютерами сети, нечто вроде железнодорожной

одноколейки. Пакетная система позволила создавать "шоссейные магистрали"

для данных, по которым много машин движутся фактически в одном и том же

ряду. Каждому пакету выдается компьютерный эквивалент карты и расписания,

так что его можно направить в желательное место назначения, где все такие

пакеты снова соберут в сообщение, пригодное для использования человеком или

компьютером.

Эта система позволила компьютерам использовать разделяемые данные, а

исследователям - использовать электронную почту. Сама по себе электронная

почта уже была революцией, поскольку оказалось, что подробные письма можно

пересылать со скоростью телефонного звонка.

По мере того, как эта система, названная ARPANet, росла, несколько

предприимчивых студентов колледжа (и один старшеклассник) разработали способ

ее использования для проведения электронных конференций. Они начались как

научные дискуссии, но скоро от них отпочковались конференции практически по

всем аспектам жизни, как только люди осознали возможность "разговаривать" с

сотнями и даже тысячами людей по всей стране.

В семидесятых годах при поддержке ARPA были разработаны правила, или

протоколы, пересылки данных между различными компьютерными сетями. Эти

протоколы с общим именем "Internet" сделали возможным разработку всемирной

Сети, которую мы сейчас имеем и которая соединяет компьютеры всех видов

через национальные границы. К концу семидесятых были разработаны связи

между ARPANet и ее контрагентами в других странах. Мир оказался связан в

одно целое паутиной компьютерных сетей.

В восьмидесятых годах эта сеть сетей, которая стала известна под

именем Internet, развилась до невероятной степени. Сотни, а потом и тысячи

колледжей, исследовательских организаций и правительственных ведомств стали

присоединять свои компьютеры к этой всемирной Сети. Некоторые

предприимчивые любители и компании, не желающие платить высокие цены за

доступ к Internet (или не имеющие возможности соответствовать жестким

правительственным требованиям для получения такого доступа), научились

присоединять свои системы к Internet даже только ради электронной почты и

конференций. Некоторые из этих систем стали предлагать доступ к Internet для

всех. Теперь любой владелец компьютера и модема - и некоторой толики

настойчивости может открыть себе окно в этот мир.

В девяностых годах сеть продолжает разрастаться экспоненциально. По

некоторым оценкам, объем пересылаемых сообщений растет на 20 процентов в

месяц. В ответ на это правительство и другие пользователи пытаются в

последние годы расширить саму Сеть. Когда-то основной "хребет" Сети в

Соединенных Штатах передавал данные со скоростью 56000 бит в секунду. Это

оказалось слишком медленно для все возрастающего объема пересылаемых

данных, и в последнее время максимальная скорость возросла до 1.5 миллиона,

а затем - до 45 миллионов бит в секунду. Но даже раньше, чем Сеть оказалась

в состоянии достичь подобной скорости, эксперты по Сети стали выискивать

способы перекачки данных со скоростью порядка 2 миллиардов бит в секунду -

это достаточно, чтобы перегнать через всю страну Британскую Энциклопедию за

одну или две секунды. Другое серьезное новшество - разработка коммерческих

служб, которые предоставляют услуги по межсетевому обмену, сравнимые по

скорости с соответствующими услугами правительственной системы. Фактически

в середине 1994 года правительство Соединенных Штатов самоустранится от

ежедневного управления работой Сети, и местные и национальные организаторы

услуг сети будут ее расширять.

1.6 Как работает сеть

Фактически всемирная Сеть является сложной паутиной меньших локальных

сетей. Чтобы представить себе это, нарисуйте современную дорожную сеть

трансконтинентальных суперскоростных дорог между большими городами. От этих больших

городов отходят дороги поменьше, связывающие между собой маленькие города,

жители которых путешествуют по узким, медленным проселкам.

Этими суперскоростными дорогами для Сети является высокоскоростной Internet. К

нему присоединены компьютеры, использующие конкретные системы для пересылки

данных с высокой скоростью. В Соединенных Штатах основной "хребет" Internet

теоретически может передавать данные со скоростью 45 миллионов бит в

секунду (сравните со средним домашним модемом, у которого предельная

скорость около 9600 или 14400 бит в секунду).

К компьютерам "хребта" подсоединены меньшие сети, обслуживающие

конкретные географические регионы, которые, как правило, пересылают данные

со скоростью 1,5 миллиона бит в секунду.

К ним присоединяются сети еще поменьше или даже индивидуальные

компьютеры.

В отличие от коммерческих сетей, таких, как CompuServe или Prodigy, в

Internet не существует одного центрального компьютера, управляющего работой

сети - его ресурсы распределены между тысячами отдельных компьютеров. В

этом его величайшая сила и его величайшая слабость. Такой подход

означает виртуальную невозможность единовременной катастрофы всей Сети -

даже если один компьютер выйдет из строя, остальная часть Сети останется

сохранной. Такая конструкция также уменьшает стоимость доступа к сети для

организаций и отдельных лиц. Но тысячи соединенных вместе компьютеров

затрудняют передвижение по Сети и поиск того, что вам в ней нужно -

особенно потому, что у разных компьютеров разные команды для доступа к

ресурсам. Только недавно пользователи Сети начали разрабатывать средства

навигации и "карты", позволяющие новичкам передвигаться по Сети без риска

заблудиться.

Никто не знает точно, сколько компьютеров и сетей фактически

составляют Сеть. По некоторым оценкам, это около 5000 сетей, объединяющих

два миллиона компьютеров и более чем 15 миллионов человек во всем мире.

Какова бы ни была истинная цифра, но явно, что сейчас она только растет.

Сеть - это более, чем просто чудо технологии. Это - человеческое

общение на самом его фундаментальном уровне. Скорость могла бы быть чуть

побольше, чтобы сообщение обходило мир за несколько секунд, но это все

равно не слишком отличается от большой и интересной вечеринки. В этом

гиперпространстве вы можете увидеть что-то, что вас рассмешит, что-то, что

вас рассердит. Вы прочтете какие-то глупости и какие-то умные мысли,

которые заставят вас задуматься. Вы найдете новых друзей и встретите людей,

с которыми не захотите иметь никакого дела.

Основные содержатели сетей продолжают работать над способами

облегчения пользователю Сети процесса общения с пользователями другой сети.

Ведется работа по созданию системы "телефонного справочника лиц", в котором

можно будет, например, найти чей-то адрес электронной почты. Этот дрейф в

сторону интеграции сетей будет, похоже, ускорен в ближайшие годы, поскольку

пользователи хотят иметь "бесшовный" доступ к сетям - подобно тому, как

пользователь телефона просто набирает номер, и ему нет дела до того, как

организуют соединение телефонные компании.

А сегодня еще теснее становятся связи между Internet и такими

коммерческими сетями, как CompuServe и Prodigy, пользователи которых теперь

могут обмениваться электронной почтой со своими друзьями из Internet.

Некоторые держатели коммерческих сетей, таких, как Delphi и America Online,

работают над тем, чтобы дать своим абонентам прямой выход на услуги

Internet.

И по мере того, как с ней становится легче работать, все больше людей

вступают в ту всемирную общину, что мы зовем Сетью.

Быть соединенным с сетью - это значит больше, чем просто читать

конференции и регистрировать у себя на компьютере сообщения; это значит

также задавать вопросы и отвечать на них, обмениваться мнениями - короче,

участвовать.

Если вы решите пойти по этому пути, брать и давать, вы станете

гражданином этого Гиперкосмоса. Если вы впервые читаете эти слова то это

может показаться интересным, но неправдоподобным - как можно "обитать" в

каком-то месте, не занимающем физического пространства. Но поставьте галочку

на полях возле этих слов. Войдите в Сеть и начните в ней активно

участвовать этак год. Потом перечитайте эту фразу. Ничего странного в

словах "гражданин Гиперкосмоса" вы уже не увидите. Эта будет самая

естественная в мире вещь.

И это приводит нас к еще одной фундаментальной истине, которую надо

помнить:

Вам не удастся сломать Сеть!

Когда вы путешествуете по Сети, ваш компьютер может зависнуть, экран

может покрыться жуткой абракадаброй. Вам может показаться, что вы сломали

какой-то отдаленный компьютер стоимостью в миллион долларов - или даже ваш

собственный персональный компьютер. Рано или поздно такое чувство

появляется у каждого - и скорее всего, не раз. Но Сеть и ваш компьютер

прочнее, чем вы думаете, так что успокойтесь. Вы можете повредить Сеть не в

большей степени, чем телефонную сеть. Если что-то неправильно, просто

попробуйте снова. Если опять ничего не получается, всегда можно

отсоединиться. Если становится все хуже и хуже, можно просто выключить свой

компьютер. Сделайте глубокий вдох. И позвоните снова. Оставьте записку

тому, кто работает на том компьютере, с которым вы соединялись, и попросите

совета. Попробуйте еще раз. Настойчивость вознаграждается.

Оставайтесь и вносите свой вклад. Это обогатит Сеть - и вас тоже.

1.7 Когда что-то не так

∙ Ваш компьютер соединился с общедоступной системой, а на экране -

мусор.

Если вы используете параметры 8-1-N, попробуйте 7-1-E (и наоборот).

Если это не поможет, попробуйте другую скорость модема.

∙ Вы набрали номер общедоступной подсистемы со своего компьютера, но

ничего не произошло.

Проверьте правильность набора номера. Если он верен, включите динамик

модема (для Хэйс (Hayse) -совместимых модемов это обычно выполняется вводом команды

ATM1 в режиме терминала коммуникационного программного обеспечения). Если

все время идут длинные редкие гудки, общедоступная подсистема может быть

отключена на обслуживание, или из-за аварии, или еще зачем-нибудь. Если вы

получаете сообщение "connect" (соединение), но ничего сверх этого,

попробуйте пару раз нажать клавиши enter или escape.

∙ Вы пытаетесь зарегистрироваться, но после ввода пароля ничего не

происходит либо вы получаете сообщение "timed out" (время ожидания вышло),

за которым следует разъединение.

Наберите номер снова и попробуйте еще раз.

∙ Всегда помните, что если у вас возникла проблема, которая не хочет

решаться - спрашивайте! Спрашивайте системного администратора, спрашивайте

приятеля, но спрашивайте. Кто-то наверняка знает, что делать.

1.8 Куда обратиться с вопросами

Сеть растет настолько быстро, что даже лучшее руководство по ее

ресурсам устареет раньше, чем будет напечатано. В конце каждой главы мы ,

тем не менее, стараемся дать указания о том, в какое место Сети обратиться

с вопросами, чтобы получить больше информации или держаться в курсе новых

ресурсов и услуг.

Питер Камински (Peter Kaminski) ведет список систем, дающих открытый

доступ к услугам Internet. Его можно получить как по самой сети - отчего

вам не легче, если у вас сейчас нет доступа, но что трудно переоценить,

если вам просто нужно найти новую систему. Ищите его файл "PDIAL" в группах

новостей alt.bbs.lists или news.answers на Usenet (информацию о доступе к

Usenet см. в главе 3).

Книга Стивена Леви (Steven Levy) , "Хакеры: герои компьютерной

революции" ("Hackers: Heroes of the Computer Revolution") (Anchor

Press/Doubleday, 1984) описывает раннюю культуру и этос, которые в конце

концов породили Internet и Usenet.

Работа Джона Квотермэйна (John Quarterman) "Матрица: Всемирные

компьютерные сети и системы конференций" ("The Matrix: Computer Networks

and Conferencing Systems Worldwide") (Digital Press, 1990) дает

исчерпывающий взгляд на компьютерные сети и их взаимные соединения.

Множество документов об Internet, его истории и его ресурсах можно

найти в директории pub/Net_info на FTP-сервере (Electronic Frontier

Foundation) (расшифровка этой криптограммы дается в главе 7).

Глава 2: ЭЛЕКТРОННАЯ ПОЧТА (E-Mail)

2.1 Основы

Электронная почта - это ваша персональная связь с миром Сети. Все те

миллионы людей по всему свету, которые используют Сеть, имеют свой адрес

электронной почты, или электронный адрес. Все возрастающее число "шлюзов"

("gateways") каждый день связывают с Сетью все больше и больше людей. Когда

вы зарегистрировались в своей местной системе, с которой сейчас, в данный

момент, работаете, она тоже автоматически сгенерировала для вас адрес.

Основные понятия, на которых построена электронная почта, параллельны

основным концепциям построения обычной почты. Вы посылаете людям письма по

их конкретным адресам. Они, в свою очередь, пишут вам на ваш почтовый

адрес. Вы можете подписаться на электронные аналоги газет и журналов. Можно

даже получать устаревшую электронную почту (electronic junk mail).

Электронная почта имеет два серьезных преимущества по сравнению с

обычной почтой. Наиболее очевидное - скорость. Ваше сообщение будет идти на

другой конец мира не несколько дней, а несколько часов, минут или даже

секунд (в зависимости от места, где вы "бросили письмо" и состояния связи

между этим местом и вашим адресатом). Другое преимущество состоит в том,

что после овладения основами вы сможете получить доступ к базам данных и

файлам библиотек. Как это делается, вы увидите позже, при изучении вопроса

о том, как передавать файлы программ или данных по электронной почте.

Электронная почта имеет преимущества и перед телефоном. Свое сообщение вы

отправляете тогда, когда это вам удобно. Ваш адресат отвечает тогда, когда

это удобно ему. Не надо организовывать одновременное присутствие двух

абонентов на двух концах. И если телефонный разговор через всю страну

быстро выливается в солидный счет, то электронная почта позволяет

обмениваться большими объемами информации буквально за центы - даже если

ваш абонент живет в Новой Зеландии.

Электронная почта - это ваша связь для запроса помощи, ваша

"спасательная линия" к Сети. Иногда Сеть сильно обманывает ожидания! Как

бы вы ни старались, где бы вы ни искали, вы иногда не сможете сказать, в

чем причина ваших трудностей. Но если вы знаете, как использовать

электронную почту, то получить помощь можно, просто нажав несколько

клавиш: вы можете попросить помощи у вашего системного администратора или

просто у знакомого в письме, направленном по электронной почте.

Самый быстрый способ начать освоение электронной почты - это послать

сообщение самому себе. Большинство общедоступных систем имеют несколько

различных систем электронной почты, каждая из которых позволяет вам как

посылать, так и получать письма. Мы начнем с простейшей, которая по вполне

понятным причинам известна под именем "mail" (почта) и потом просмотрим

парочку других интерфейсов. В командной строке вашей местной системы

введите:

mail имя_пользователя

где имя_пользователя - это имя, которое вы взяли себе при первом входе в

систему. Нажмите enter. Компьютер ответит строкой

subject:

Введите

test (проверка)

или вообще произвольный текст (но необходимо нажать enter раньше, чем

дойдете до края экрана). Нажмите enter.

Курсор опустится на строку ниже. Теперь можно начать писать сам текст

сообщения. Введите любое предложение, о чем угодно. И здесь вы впервые

встретитесь с раздражающим моментом системы Unix, который будет донимать

вас и дальше: нажать enter необходимо раньше, чем вы доберетесь до самого

конца строки. Многие программы Unix ,как пишущие машинки, не могут сами

переносить слово на следующую строку (хотя некоторые текст-процессоры Unix

такие, как emacs, обладают этой способностью).

Закончив с вводом сообщения, нажмите return. Теперь нажмите control-D

(клавиши control и D одновременно). Это команда Unix, которая сообщает

компьютеру о том, что письмо закончено, и он должен закрыть "конверт" и

отправить письмо (можно было также просто один раз нажать enter и после

этого в пустой строке ввести точку в начале строки и снова нажать enter).

Вы только что послали свое первое сообщение по электронной почте. И

поскольку вы послали сообщение самому себе, а не другому пользователю Сети,

оно уже прибыло, как мы сейчас увидим.

Если бы вы хотели, вы могли бы даже сначала написать это сообщение на

своем собственном компьютере, а затем загрузить его в этот электронный

"конверт". Есть серьезные соображения в пользу того, чтобы именно так и

поступать, когда речь идет о длинных или ответственных сообщениях. Одно из

них состоит в том, что после нажатия enter в конце строки при работе с

"mail" в ней нельзя простым способом исправить ошибки (если только

не использовать специальные команды для вызова текст-процессора Unix).

Кроме того, если вы платите за почасовой доступ, загрузка заранее

подготовленного сообщения поможет вам сэкономить деньги. Помните, что

документ следует записывать в формате ASCII или текстовом. Загрузка

документа, который вы подготовили в текстовом процессоре с использованием

специальных команд форматирования (а в наши дни такими командами обладают

многие текстовые процессоры) может дать очень странные эффекты.

Когда вы увидите пустую строку после строки "subject", приступите к

загрузке сообщения с помощью протокола ASCII. Или можно скопировать текст и

вставить его, если ваше программное обеспечение это позволяет. После того,

как это будет сделано, нажмите control-D, как выше.

Теперь у вас есть письмо, которое вас ждет. Обычно, когда вы входите,

ваша общедоступная подсистема сообщает вам о том, нет ли для вас нового

письма. Чтобы открыть свой почтовый ящик и посмотреть новое письмо, введите

mail

и нажмите enter.

Когда местная система видит команду "mail" без имени, она знает, что

вы смотрите свой почтовый ящик, а не посылаете сообщение. Ваш экран в

простой системе Unix выведет следующее:

Mail version SMI 4.0 Mon Apr 24 18:34:15 PDT 1989 Type ? for help.

"/usr/spool/mail/adamg": 1 message 1 new 1 unread

>N 1 adamg Sat Jan 15 20:04 12/290 test

────────────────────────────────────────────────────────────────────────────

Mail Версия SMI 4.0 Пн Апр 24 18:34:15 PDT 1989 Для помощи введите ?.

"/usr/spool/mail/adamg": 1 сообщение 1 новое 1 непрочтенное

>N 1 adamg Сб Янв 15 20:04 12/2 90 test

────────────────────────────────────────────────────────────────────────────

На первую строку не обращайте внимания; это компьютерный жаргон,

интересный только для тех, кто управляет вашей системой. Можно ввести знак

вопроса и нажать return, но если вы не знаете Unix, большая часть того, что

вы увидите, не будет представлять для вас смысла.

Вторая строка сообщает вам директорию, в которую помещаются пришедшие

к вам сообщения, что опять-таки вам, скоре всего, не особенно интересно. В

ней также сообщается, сколько сообщений хранится в вашем почтовом ящике,

сколько их пришло с момента вашего последнего обращения к почтовому ящику и

сколько из них не прочитано.

Интерес представляет третья строка - она сообщает, от кого пришло

сообщение, сколько в нем строк и символов, и какова его тема (subject).

Буква "N" означает "new" - новое сообщение, которое прибыло после того, как

вы в последний раз заглядывали в почтовый ящик. Нажмите enter. И вот оно,

ваше сообщение - только теперь оно гораздо длиннее того, что вы писали!

Message 1:

From adamg Jan 15 20:04:55 1994

Received: by eff.org id AA28949

(5.65c/IDA-1.4.4/pen-ident for adamg); Sat, 15 Jan 1994 20:04:55 -0400

(ident-sender: adamg@eff.org)

Date: Sat, 15 Jan 1994 21:34:55 -0400

From: Adam Gaffin <adamg>

Message-Id: <199204270134.AA28949@eff.org>

To: adamg

Subject: test

Status: R

This is only a test!

────────────────────────────────────────────────────────────────────────────

Сообщение 1:

От adamg Янв 15 20:04:55 1994

Получено: (кем) eff.org id AA28949

(5.65c/IDA-1.4.4/pen-ident для adamg); Сб, 15 Янв 1994 20:04:55 -0400

(идент-отправителя: adamg@eff.org)

Дата: Сб, 15 Янв 1994 21:34:55 -0400

От: Adam Gaffin <adamg>

Ид сообщения-Id: <199204270134.AA28949@eff.org>

Кому: adamg

Тема: test

Статус: R

Это просто проверка!

────────────────────────────────────────────────────────────────────────────

Тпру! Это что еще такое? А это просто ваше сообщение, только с

почтовой маркой. Точно так же, как почта ставит марки и печати на каждое

почтовое отправление, так и почтовая система Сети поступает аналогично.

Только это называется не марка, и не штемпель, а "заголовок" ("header")

Каждая система, которая обрабатывает или направляет ваше письмо, ставит на

нем свой штамп. Так как многие сообщения проходят через несколько систем по

дороге к месту назначения, то вы часто будет получать сообщения, у которых

заголовки будут казаться бесконечными. Наряду со многим другим заголовок

несет информацию о том, когда сообщение было послано и получено, и даже

разницу между вашим местным временем и средним временем по Гринвичу - как в

конце строки 4 выше.

Если бы это сообщение было длинным, оно сейчас бы поехало по экрану

справа налево и сверху вниз - если только те, кто управляют вашей местной

системой, не поставили приостановку прокрутки через каждые двадцать четыре

строки. Один из способов иметь дело с сообщением, которое не

останавливается при выводе на экран - использовать возможность регистрации

или функцию текстового буфера в своем коммуникационном программном

обеспечении. Ее следует запустить перед тем, как ввести номер того

сообщения, которое желательно просмотреть. Компьютер спросит вас, как вы

хотите назвать файл, который будет создан. После ввода имени файла и

нажатия клавиши enter, введите номер сообщения, которое желательно

просмотреть, и нажмите enter. Когда прокрутка сообщения закончится,

отключите функцию текстового буфера. Сообщение будет сохранено в вашем

компьютере. Теперь вы можете читать сообщение, не находясь на связи с Сетью

(что может дать некоторую экономию, если вы платите почасово), и так же вне

связи с сетью написать ответ.

Ну ладно, а что делать пока? Можно ответить на сообщение, удалить его

или сохранить. Чтобы ответить на сообщение, введите символ r нижнего

регистра и нажмите enter. Вы получите нечто вроде такого:

To: adamg

Subject: Re: test

Заметьте, что в этот раз имя пользователя вводить не потребовалось.

Компьютер взял его из сообщения, на которое вы отвечаете, и автоматически

адресует ответ отправителю. Компьютер также автоматически вставляет строку

темы (subject), добавив "Re" к исходной теме. Но если вы вдруг передумаете и

решите не отвечать - как избавиться от этого сообщения? Нажмите один раз

control-C. Вы получите следующее:

(Interrupt -- one more to kill letter)

────────────────────────────────────────────────────────────────────────────

(Прерывание -- еще раз для уничтожения письма)

────────────────────────────────────────────────────────────────────────────

Если нажать control-C еще раз, то сообщение исчезнет, и вы вернетесь в

командную строку системы mail.

Теперь, если вы введете символ d нижнего регистра и нажмете enter, вы

удалите исходное сообщение. Для выхода из просмотра почтового ящика введите

символ q нижнего регистра.

Если вы введете q, не введя перед этим d, ваше сообщение будет

передано в файл с именем mbox. Это файл, в котором сохраняются все

прочитанные, но не удаленные сообщения. Если вы хотите сейчас сохранить его

в почтовом ящике, введите символ x нижнего регистра и нажмите enter. При

этом вы выйдете из программы mail без выполнения каких-либо изменений.

Функции файла mbox во многом аналогичны функциям почтового ящика.

Чтобы получить к нему доступ, введите

mail -f mbox

в командной строке вашей местной системы и нажмите enter.

Вы получите меню, аналогичное меню почтового ящика, из которого можно

будет прочитать эти старые сообщения, удалить их или ответить на них.

Хорошей идеей будет время от времени чистить почтовый ящик и файл mbox,

хотя бы для порядка.

А есть ли недостатки у электронной почты? Несколько есть. Один из них

состоит в том, что люди больше склонны впадать в раж при электронном

общении, нежели при персональном. Может быть, это потому, что так легко

нажать клавишу r и ответить на послание, ни секунды не задумываясь. Вот

зачем нам нужны "улыбки" (см. раздел 2.4)! Нет электронного эквивалента

уведомления о вручении: есть очень большой шанс, что ваше сообщение доберется

до адресата, но нет никакого способа узнать, произошло это или нет, кроме

получения ответа от адресата.

Итак, вы готовы посылать электронную почту другим пользователям Сети.

Чтобы послать письмо человеку, нужно знать его адрес. Как же его узнать?

Увы, к сожалению, простейший ответ нельзя назвать чересчур элегантным:

позвонить человеку по телефону или послать письмо на бумаге с просьбой

сообщить свой электронный адрес. Жители электронной границы только

начинают разрабатывать эквиваленты телефонных книг, а те, что существуют

сегодня, далеко не полны (однако далее в главе 6 мы покажем, как

использовать некоторые из этих справочников).

В конце концов вы начнете переписываться с людьми, что означает, что

вы узнаете, как к ним адресоваться. Это очень важно, потому что малейшая

ошибка - запятая вместо точки, например, может вернуть ваше сообщение к вам

не доставленным. В этом смысле адреса Сети напоминают телефонные номера:

одна неверная цифра - и вы позвонили не тому человеку. К счастью, в

настоящее время большинство адресов Сети составлены по относительно легкой

для понимания системе.

Ранее вы послали письмо самому себе, используя только собственное

имя-пользователя. Это примерно как позвонить по местному телефону - не надо

набирать 1 или код региона. Это срабатывает также для всех, кто имеет

раздел на той же системе, что и вы.

Однако посылка почты за пределы вашей системы требует использования

эквивалентов кодов региона для Сети, называемых "доменами" (domains)

Обычный адрес в Сети выглядит примерно так:

tomg@world.std.com

Tomg - это чей-то идентификатор пользователя, и он находится при (знак @ -

коммерческое "при") подсистеме (или по-Internet'овски "домене"), известном

как world.std.com. В больших организациях часто имеется более чем один

компьютер, связанный с Internet; в этом случае имя каждой конкретной машины

представляет собой мир (вы скоро заметите, что владельцы компьютеров

Internet, как владельцы лодок, дают машинам собственные имена).

Домены сообщают имя организации, которая ведет данную подсистему

электронной почты, и что это за подсистема, а также, если подсистема

находится вне Соединенных Штатов - в какой стране она расположена. Большие

организации могут иметь более одного компьютера и шлюза, связанного с

Internet, поэтому часто можно увидеть имя домена из двух частей; а иногда

даже трех- или четырех частные имена доменов.

Вообще говоря, американские адреса заканчиваются суффиксом

организации, таким, как ".edu," что означает подсистему колледжа или

университета. Среди других суффиксов встречаются:

.com для коммерческих организаций

.org для некоммерческих организаций

.gov и .mil для правительственных и военных ведомств

.net для компаний или организаций, которые ведут большие сети

Подсистемы в остальном мире имеют тенденции использовать двухбуквенный

код, представляющий страну местонахождения. Большинство кодов - смысловые,

например, .ca для канадских систем, но есть парочка достаточно странных.

Швейцарские подсистемы оканчиваются на .ch, а Южноафриканские - на .za.

Некоторые подсистемы в США следуют таким же международным соглашениям

(например, well.sf.ca.us).

Заметьте, что все приведенные выше адреса написаны символами нижнего

регистра. В отличие от всего остального, что как-то связано с Unix, большая

часть почтовых систем Сети не различает регистра символов, поэтому можно не

беспокоить себя расстановкой больших букв в электронном адресе. Но увы,

есть некоторые исключения - некоторые общедоступные подсистемы разрешают

включение больших букв в имена пользователей. Если у вас есть сомнения,

спросите того человека, которому вы хотите написать, или пусть сначала этот

человек пошлет вам письмо (вспомним, что электронный адрес отправителя

обычно можно увидеть в верхней части сообщения). Имя домена - часть адреса

после символа @ - никогда не следует писать большими буквами.

Это простая и надежная система, и она отлично работает, но адрес

приходится писать точь-в-точь, и это крайне существенно - как существенно

при наборе номера телефона не ошибиться ни в одной цифре. Пошлите сообщение

в адрес tomg@unm.edu (это университет Нью-Мексико), в то время как его надо

было послать по адресу tomg@umn.edu (университет Миннесоты), и либо ваше

письмо вернется не доставленным, либо попадет не к тому человеку.

Если ваше сообщение вернется как не могущее быть доставленным, то вы

получите внушительного вида сообщение от MAILER-DAEMON (это такая

благодетельная программа в Unix, назначение которой - работать с почтой) со

зловещего вида заголовком, за которым следует текст вашего сообщения.

Иногда можно сказать, что было неправильно, посмотрев на первые строки

возвращенного сообщения. Кроме неверного адреса, возможно еще, что ваша

местная система не содержит адреса места назначения в той "карте" других

систем, которые она ведет. Или возможно, что вы пытались послать сообщение

в другую сеть, такую, как Bitnet или CompuServe, что требует специального

оформления адреса.

Иногда все это выглядит весьма раздражающе. Но помните первую заповедь

Сети: Спрашивайте! Пошлите сообщение системному администратору. Он может

помочь решить проблему.

Есть один вид адресов, который может создать проблемы вашей системе. У

систем на основе Unix есть два основных способа обмена почтой. Один

известен под названием UUCP и развивался на основе адресной системы,

отличной от той, что принята в остальных частях Сети. С тех пор большая

часть систем UUCP переключились на стандартную систему адресации Сети, но

несколько традиционных подсистем держатся за свою оригинальную адресацию,

которая содержит множество восклицательных знаков, например:

uunet!somesite!othersite!mybuddy

(uunet!одна_система!другая_система!мой_приятель)

Для многих местных систем проблема представляют в большом количестве

имеющиеся восклицательные знаки, которые для большинства систем и

"оболочек", работающих на компьютерах с системой Unix, ничего не значат.

Это означает, что адресация письма к такой системе (или даже ответ на

письмо, которое вы от нее получили) может запутать компьютер так, что и

концов не найдешь, и ваше сообщение никогда не будет отослано. Если так

случится, попробуйте вставить обратную косую черту перед каждым

восклицательным знаком, чтобы адрес выглядел примерно так:

uunet\!somesite\!othersite\!mybuddy

(uunet\!одна_система\!другая_система\!мой_приятель)

Отметим, что таким образом вам не удастся ответить на сообщение вводом

символа r нижнего регистра - может прийти сообщение об ошибке, и вам

придется создавать новое сообщение.

Если вы хотите распробовать, какие возможности есть у электронной

почты, направьте по ней письмо на адрес

almanac@oes.orst.edu

Строку "subject:" оставьте пустой. В качестве сообщения введите следующее:

send quote

(послать цитату)

Или если вы в мрачном настроении, напишите:

send moral-support

(послать моральную поддержку)

В любом случае в течение нескольких минут или нескольких часов (в

зависимости от состояния связи между вашей местной системой и Internet) вы

получите ответ. Если вы просили послать цитату, то вы получите просто

какой-то случайный набор пословиц. Если вы просили моральной поддержки, вы

тоже получите случайный набор пословиц, но более жизнеутверждающего

содержания.

Этот конкретный "почтовый сервер" ведется Университетом Штата Орегон

(Oregon State University). Его основная цель - дать путь распространения

сельскохозяйственной информации по электронной почте. Если вы хотите

узнать, как использовать полный набор услуг этого сервера, пошлите по его

адресу сообщение с текстом:

send help

(Прислать помощь)

Вы сразу получите длинный документ с детальным перечислением того, что вам

доступно и как до этого добраться.

У вас есть ценное мнение? Хотите дать разумный совет Президенту

Соединенных Штатов? Пошлите сообщение по адресу president@whitehouse.gov.

Если вице-президент тоже годится, напишите по адресу

vice-president@whitehouse.gov.

Программа "mail" достаточно мощная и является принятым в Сети

стандартом, по крайней мере на компьютерах с системой Unix. Но с ней

довольно трудно работать - вы можете, конечно, ввести знак вопроса и

получить список команд, но это имеет ограниченную ценность, если вы не

знакомы с системой Unix. К счастью, есть еще парочка почтовых программ,

которые легче в работе.

2.2 Elm ── более удобный способ

Elm представляет собой комбинацию почтового ящика с программой

написания писем, в которой для перемещения между письмами используется

меню. Большинство систем на основе Unix в настоящее время ее содержит.

Чтобы ею воспользоваться, введите

elm

и нажмите enter. Вы получите меню ожидающих вас сообщений, а также список

команд, которые вы можете выполнять. Это будет выглядеть примерно так:

Mailbox is '/usr/spool/mail/adamg' with 38 messages [ELM 2.3 PL11]

1 Sep 1 Christopher Davis (13) here's another message.

2 Sep 1 Christopher Davis (91) This is a message from Eudora

3 Aug 31 Rita Marie Rouvali (161) First Internet Hunt !!! (fwd)

4 Aug 31 Peter Scott/Manage (69) New File <UK077> University of Londo

5 Aug 30 Peter Scott/Manage (64) New File <DIR020> X.500 service at A

6 Aug 30 Peter Scott/Manage (39) New File <NET016> DATAPAC Informatio

7 Aug 28 Peter Scott/Manage (67) Proposed Usenet group for HYTELNET n

8 Aug 28 Peter Scott/Manage (56) New File <DIR019> JANET Public Acces

9 Aug 26 Helen Trillian Ros (15) Tuesday

10 Aug 26 Peter Scott/Manage (151) Update <CWK004> Oxford University OU

────────────────────────────────────────────────────────────────────────────

Почтовый ящик '/usr/spool/mail/adamg' содержит 38 сообщений [ELM 2.3 PL11]

1 Сен 1 Christopher Davis (13) Это другое сообщение

2 Сен 1 Christopher Davis (91) Сообщение от Eudora

3 Авг 31 Rita Marie Rouvali (161) Первая охота в Internet !!! (fwd)

4 Авг 31 Peter Scott/Manage (69) Новый файл <UK077> Университет Лондо

5 Авг 30 Peter Scott/Manage (64) Новый файл <DIR020> X.500 услуга при

6 Авг 30 Peter Scott/Manage (39) Новый файл <NET016> DATAPAC Информац

7 Авг 28 Peter Scott/Manage (67) Предложенная группа Usenet для HYTEL

8 Авг 28 Peter Scott/Manage (56) Новый файл <DIR019> JANET Общедоступ

9 Авг 26 Helen Trillian Ros (15) Вторник

10 Авг 26 Peter Scott/Manage (151) Дополнения <CWK004> Оксфордский Унив

────────────────────────────────────────────────────────────────────────────

У вас есть возможность выполнить любую из следующих команд нажатием

соответствующего символа: d) удалить или u)восстановить удаленное

сообщение, m) - послать сообщение, r) ответить или f) переадресовать

сообщение, q) выйти. Чтобы прочитать сообщение, нажмите <return>. j =

движение вниз, k = движение вверх, ? = помощь.

В каждой строке указана дата получения сообщения, отправитель,

количество строк в сообщении и его тема (subject).

Если используется эмуляция терминала VT100, то можно передвигаться

вверх и вниз по меню с помощью соответствующих клавиш управления курсором.

В противном случае введите номер строки того сообщения, которое надо

удалить или прочесть, и нажмите enter.

При чтении сообщения оно останавливается через каждые 24 строки, а не

прокручивается сразу и до конца. Чтобы прочесть следующую страницу, нажмите

пробел. Можно ввести символ r нижнего регистра, чтобы ответить на

сообщение, или символы q или i нижнего регистра для возвращения обратно в

меню (I - первая буква слова "index" - указатель).

В главном меню нажатие буквы m на нижнем регистре и вслед за ней -

клавиши enter позволяет начать новое сообщение. Для удаления сообщения

введите символ d нижнего регистра. Это можно сделать в процессе чтения

сообщения. При нахождении в меню поставьте курсор на строку удаляемого

сообщения и нажмите d.

Когда закончите работу с программой Elm, введите символ q нижнего

регистра. Программа спросит, правда ли вы хотите удалить те сообщения,

которые пометили. Потом она спросит вас, хотите ли вы передать те

сообщения, которые вы прочли, но не удалили, в файл полученных сообщений

("received"). Пока что отвечайте n.

Программа Elm имеет один очень большой недостаток для начинающего.

Тот текстовый редактор, который она по умолчанию вызывает, когда вы

нажимаете клавиши r или m, часто оказывается программой по имени emacs.

Почитатели систем Unix клянутся именем этой программы, но все остальные почти всегда

находят, что работать с ней невозможно. К несчастью, вам не всегда удастся

избавиться от нее (или от vi - другого текстового редактора, встречающегося

в системах Unix), так что чуть позже мы поговорим о тех командах, которые

все же предохраняют от полного сумасшествия.

Если вы хотите сохранить сообщение в своем компьютере, то нажмите s,

либо в момент чтения сообщения, либо при нахождении курсора на строке

сообщения в меню программы Elm. Появится имя файла. Если вам оно не

нравится, впишите новое (забоем пользоваться не придется). Нажмите enter, и

сообщение будет сохранено с указанным именем файла в вашей "домашней

директории" в вашей местной системе. После выхода из программы Elm можно

выгрузить сообщение в свой компьютер (как загружать такие файлы в свой

компьютер или выгружать из него "вверх" - спросите у своего системного

администратора).

2.3 Pine ── еще лучший способ, чем Elm

Программа Pine построена на основе Elm, но включает некоторые

усовершенствования, которые делают ее идеальной системой для новичка. Как и

программа Elm, Pine начинается с меню. У нее есть также такая возможность, как

"адресная книга", удобная в тех случаях, когда у людей бывают длинные или

сложные адреса электронной почты. Нажатие A в главном меню выводит вас в

адресную книгу, и там вы вводите имя (или прозвище) человека, а потом - его

адрес. Затем, если вы хотите послать этому человеку сообщение, достаточно

только ввести его имя или прозвище, а Pine автоматически вставит фактический

адрес. Адресная книга также позволяет установить список рассылки. Эта

возможность позволяет посылать одно и то же сообщение нескольким лицам

одновременно.

Но что действительно ставит Pine в особое положение - это его

встроенный текстовый редактор, который на взгляд и на ощупь очень похож на

программы текстовых процессоров, работающие на машинах с MS-DOS и Macintosh. У

него не только есть автоматический перенос слов в конце строки (самая

революционная концепция, которая когда-либо рождалась на свет), у него есть

еще и контроль правописания и команда поиска. И что лучше всего, все

команды, которые вам нужны, собраны в двухстрочное мини-меню внизу каждого

экрана. Команды выглядят примерно так:

^W Where is (где это)

Символ-шапочка (^) - это синоним клавиши "control" вашей клавиатуры. Чтобы

найти у себя в документе конкретное слово, нажмите одновременно клавиши

control и W; в ответ появится приглашение ввести слово для поиска.

Некоторые из команд Pine довольно причудливы (например, control-V для

перевода страницы вниз), что связано с тем, что редактор создан на основе

emacs (который странен по самой сути). Но все же все команды, которые вам

нужны, собраны в двухстрочном мини-меню внизу экрана, так что выбор

правильной команды не отнимет больше двух секунд. Чтобы использовать Pine,

введите в командной строке

pine

и нажмите enter. Эта программа относительно новая, так что в некоторых

системах ее может еще не быть. Но она настолько проста в работе, что вам

стоит послать электронное письмо своему системному администратору и

поторопить его ее приобрести!

2.4 Улыбки

Когда вы участвуете в электронной дискуссии, вы не видите, как

улыбается или пожимает плечами ваш собеседник, чтобы показать, что он

просто шутит. В электронном общении нет языка жестов. То, что вам кажется

шуткой, кто-то может принять за оскорбление. Чтобы предотвратить срыв из-за

таких недоразумений и бурные ссоры, у нас есть "улыбки" - "смайлики" (Smile

- улыбка). Поверните голову

влево и посмотрите на то, что идет за этой фразой. :-). Или просто :).

Это и есть основной смайлик. Он означает, что не следует принимать

всерьез некоторый предшествующий комментарий. Смайлик делается из

двоеточия, дефиса и закрывающей круглой скобки. Некоторые предпочитают

слово "grin" (усмешка), обычно в форме:

<grin>

Иногда для краткости ставят просто букву <g>.

Вот еще некоторые смайлики:

;-) Подмигиваю;

:-( Поморщился;

:-O Поражен;

8-) В очках;

=|:-)= Эйб Линкольн.

Два последних немножко искусственны :-).

2.5 Посылка электронной почты в другие сети

Есть много компьютерных сетей, не являющихся частью Сети, но в

настоящий момент подсоединенные через "шлюзы", которые разрешают

прохождение электронной почты. Вот список нескольких самых больших сетей, а

также указания о том, как посылать электронную почту в эти сети и как

пользователи этих сетей могут посылать свои сообщения вам.:

America Online

Уберите все пробелы из имени пользователя и добавьте "aol.com," вот так

пользователь@aol.com

Пользователи сети America Online, которые хотят послать сообщение вам,

должны только подставить ваш адрес в Сети в поле "to:" (кому) перед

составлением сообщения.

ATTMail

Адресуйте свое сообщение к пользователь@attmail.com.

Пользователь ATTMail может послать сообщение вам следующим образом:

internet!домен!пользователь

Если ваш адрес - nancyr@world.std.com, то ваш корреспондент мог бы

послать вам сообщение по адресу:

internet!world.std.com!nancyr

Bitnet

Пользователи Bitnet (или NetNorth в Канаде и EARN в Европе) часто

имеют адреса вида: IZZY@INDVMS. Если вам повезет, то для посылки сообщения

по таком адресу надо только добавить "bitnet" в конце, чтобы получилось

izzy@indvms.bitnet. Иногда случается, что письмо на такой адрес вернется

не доставленным, поскольку адреса Bitnet не всегда хорошо переводятся в

форму Internet. Если это случится, можно послать сообщение через один из

двух шлюзов Internet/Bitnet. Прежде всего замените @ на %, чтобы

получилось имя_пользователя%подсистема.bitnet. Затем добавьте либо

@vm.marist.edu, либо @cunyvm.cuny.edu, чтобы, как в приведенном выше

примере, получилось izzy%indyvms.bitnet@vm.marist.edu или

izzy%indvyvms.bitnet@cunyvm.cuny.edu

Для пользователей Bitnet задача несколько проще: они с легкостью

могут посылать письмо прямо на ваш электронный адрес без всех этих

глупостей. Так что посылайте им ваш адрес, и все будет в порядке.

CompuServe

У пользователей CompuServe адреса цифровые и имеют следующий вид:

73727,545. Чтобы послать письмо пользователю CompuServe, замените запятую

точкой и добавьте "@compuserve.com"; например:

73727.545@compuserve.com.

Имейте в виду, что некоторые пользователи CompuServe должны вносить

дополнительную плату за получение почты из Internet.

Если вы знаете пользователей CompuServe, которые хотят посылать вам

сообщения, посоветуйте им обратиться к GO MAIL и создать сообщение. В

области адреса вместо ввода номера CompuServe пусть они напишут ваш адрес в

форме:

>INTERNET:Ваш_Идентиикатор@Ваш_Адрес.

Например, >INTERNET:adamg@world.std.com. Заметьте, что оба символа

">" и ":" обязательны.

Delphi

Для посылки сообщения пользователю Delphi адрес имеет форму

имя_пользователя@delphi.com.

Fidonet

Чтобы послать сообщение пользователю какой-то доски объявлений (BBS)

Fidonet, нужно знать имя, под которым он регистрируется в системе и его

"номер узла". Номер узла, или адрес Fidonet состоит из трех номеров и имеет

вид: 1:322/190. Первый номер сообщает, в какой из нескольких больших

географических зон находится BBS (1 - США и Канада, 2 - Европа и Израиль, 3

- Азиатско-Тихоокеанский регион, 4 - Южная Америка). Второй номер

определяет сеть BBS, а последний номер есть "номер узла" ("FidoNode") -

номер BBS в этой сети. Если у вашего корреспондента только два номера

(например, 322/190), это означает, что система находится в зоне 1.

Вот теперь фокус. Вы должны изменить порядок номеров и добавить к ним

буквы f, n и z (первые буквы "FidoNode" (узел Fido), "network" (сеть) и

"zone" (зона)). Например, приведенный выше адрес будет иметь вид

f190.n322.z1.

Теперь добавьте в конце "fidonet.org", чтобы получилось

f190.n322.z1.fidonet.org. Теперь добавьте "Имя.Фамилия@", чтобы получилось

Имя.Фамилия@f190.n322.z1.fidonet.org

Отметьте наличие точки между именем и фамилией. Кроме того, в некоторых

странах есть их собственные "хребтовые" системы Fidonet, которые могут

менять адресацию. Например, если бы предыдущий адрес относился к Германии,

то в конце надо было бы добавить "fido.de" вместо "fidonet.org."

Ф-фух!

Обратный процесс отличается от описанного полностью. Прежде всего

человек должен выйти на "net mail" (сетевую почту) зоны своей BBS и знать

адрес Fidonet своего локального шлюза Fidonet/UUCP (часто его знает

системный оператор). Ваш корреспондент из Fidonet должен адресовать свое

сообщение сетевой почты, указав в поле "to:" UUCP (а не ваше имя). В поле

номер узла, он должен ввести номер узла шлюза Fidonet/UUCP (если система

шлюза находится в той же региональной сети, что и система отправителя, то

ввести надо только последний номер, например, 390 вместо 322/390). После

этого первая строка сообщения должна быть вашим адресом в Internet, а за

ней должна быть оставлена чистая строка. Вот теперь можно писать сообщение

и посылать его.

В связи с тем, как Fidonet организует передачу почты, доставка

сообщения в любом направлении может занять день или два. Кроме того,

поскольку сеть систем Fidonet - любительская, хорошим тоном считается

спросить разрешения у системного оператора в тех случаях, когда вы

собираетесь прогонять по почте большой объем информации. Сообщения

коммерческого характера категорически воспрещаются (даже если вас о них

просили). Кроме того, очень вероятно, что кроме вашего адресата сообщение

прочтет еще кто-нибудь.

GEnie

Чтобы послать сообщение пользователю GEnie, добавьте "@genie.com"

к концу имени пользователя сети GEnie, например: walt@genie.com.

MCIMail

Чтобы послать сообщение кому-нибудь, имеющему раздел в MCIMail,

добавьте "@mcimail.com" в конце имени или адреса этого человека. Например:

555-1212@mcimail.com

или

jsmith@mcimail.com

Заметьте, что если в сети MCIMail есть несколько подписчиков с таким

именем, то вы получите сообщение от MCI с их именами и числовыми адресами.

Выберите того, который вам нужен, и пошлите ваше сообщение снова.

Чтобы послать сообщение вам из MCI, пользователь должен ввести

Ваше Имя (EMS)

в ответ на приглашение "To:". В ответ на приглашение EMS следует ввести

internet

а затем ваш адрес в Сети в ответ на приглашение "Mbx:".

Peacenet

Чтобы послать сообщение пользователю, используется форма:

имя_пользователя@igc.org

Подписчики Peacenet могут посылать сообщения по вашему обычному

адресу.

Prodigy

Идентификатор_пользователя@prodigy.com. Имейте в виду, что пользователи Prodigy

должны вносить дополнительную плату за электронную почту из Internet.

2.6 Семь команд Unix, без которых нельзя обойтись

Если вы соединяетесь с Сетью через систему на основе Unix, то в конце

концов вам с этой системой Unix придется установить какие-то отношения. К

добру или к худу, но большинство систем Unix НЕ ЗАПРЕЩАЮТ вам доступ к

своей внутренней работе - если, к примеру, вы хотите скопировать почту с

Usenet в файл, то придется использовать несколько команд Unix, если вы

хотите когда-нибудь сделать еще что-нибудь с этим файлом.

Как и MS-DOS, Unix является операционной системой - она говорит

компьютеру, как и что ему делать. Система Unix имеет репутацию еще более

сложной системы, чем MS-DOS, но в большинстве случаев все, что вам будет

нужно - это несколько основных, и притом простых, команд.

Если на вашем компьютере используется MS-DOS или даже PC-DOS, то

основные понятия построения команд покажутся вам очень знакомыми - но

будьте осторожны насчет команды cd, которая работает с существенными

отличиями от команды DOS с тем же именем, что может довести до бешенства. И

еще в отличие от MS-DOS, Unix различает символы верхнего и нижнего

регистров - если вы введете команду или директорию не на том регистре,

получите сообщение об ошибке.

Если вы работаете на машине Mac, помните, что Unix хранит файлы в

"директориях", а не в "фолдерах". Директории Unix организованы как ветви

дерева. В самом низу лежит корневая директория ("root"), от которой

ответвляются субдиректории (могущие, в свою очередь, иметь свои

субдиректории). Эквивалентом Mac субдиректории Unix является фолдер внутри

другого фолдера.

cat Эквивалент команды "type" в MS-DOS (просмотр файла). Чтобы сделать остановку

после каждого экрана, введите

cat файл | more

где "файл" - имя файла, который вы хотите просмотреть.

Нажатие control-C остановит вывод. Другой способ - ввести

more файл

и достичь того же результата. Можно использовать команду cat

для записи или загрузки текстовых файлов в вашу

именную или домашнюю директорию (аналогично команде MS-DOS

"copy con"). Если ввести

cat>test

то будет создан файл с именем "test". Можно либо ввести

что-то очень простое (после окончания строки редактирование

ее невозможно, и оканчивать строку обязательно нажатием

клавиши return), либо загрузить что-нибудь в этот файл,

используя свой коммуникационный пакет в протоколе ASCII). Для

закрытия файла нажмите control-D.

cd Команда "сменить директорию" ("change directory"). Чтобы

сменить текущую директорию на другую, введите

cd имя_директории

и нажмите enter. В отличие от MS-DOS, в котором

используется значок \ для обозначения субдиректорий

(например, \stuff\text), в Unix используется символ /

(например: /stuff/text). Поэтому, чтобы сменить текущую

директорию на субдиректорию stuff/text, следует ввести

cd stuff/text

и нажать enter. Как и в MS-DOS, нет необходимости

добавлять первую черту дроби, если субдиректория

ответвляется от текущей директории. Чтобы двигаться по

дереву директорий в сторону корня, введите

cd ..

и enter. Обратите внимание на необходимость двух пробелов

между cd и двумя точками - это страшно бесит пользователей

MS-DOS.

cp Копирует файл. Синтаксис таков

cp файл1 файл2

При этом файл1 копируется в файл2 (или файл2 затирается

файлом файл1).

ls Эта команда, если за ней следует enter, сообщает вам,

что находится в директории - аналогично команде dir

системы DOS, но только в алфавитном порядке.

ls | more

Будет останавливать вывод через каждые 24 строки - это

удобно, если у вас в директории много всякого. Базовая

команда ls не выводит "спрятанные" файлы, такие, как

файл .login, управляющий взаимодействием вашей системы и

Unix. Чтобы увидеть эти файлы, введите

ls -a или ls -a | more

ls -l сообщит вам размер каждого файла, а также дату

его создания и модификации.

mv Аналогично команде rename системы MS-DOS

mv файл1 файл2

переименовывает файл1 в файл2. Команду также можно

использовать для переноса файла из одной директории в

другую.

mv файл1 News

переместит файл файл1 в вашу директорию News.

rm Удаляет файл. Введите

rm имя_файла

и нажмите enter (но имейте в виду: как только вы нажали

enter, файл исчез навсегда).

СИМВОЛЫ ПОДСТАНОВКИ: При поиске, копировании или удалении файлов

можно в тех случаях, когда вы не знаете точных имен файлов, использовать

символы подстановки.

ls man*

найдет такие файлы, названия которых начинаются с man:

manual, manual.txt, man-o-man.

Если вы точно занете все символы, кроме одного или двух, используйте

знак вопроса. Например,

ls man?

позволит найти файл по имени mane, но не файл с именем manual.

2.7 Когда что-то не так

∙ Вы послали письмо, но получили зловещее сообщение от

MAILER-DAEMON, содержащее десяток строк компьютерной абракадабры, за

которой следует ваше сообщение.

Вот в этих самых строчках и можно часто найти ключ к разгадке, что же

было не так. Вы могли неправильно вписать адрес электронной почты.

Подсистема, которой было послано сообщение, могла быть отключена на

обслуживание или из-за сбоя. Вы могли воспользоваться неверным "переводом"

при посылке сообщения в Сети за пределы Internet.

∙ Вы вызвали свой текстовый редактор своей местной системы чтобы написать

сообщение или ответ, и похоже, что не можете из него выйти.

Если это emacs, попробуйте control-X, control-C (другими словами,

прижав клавишу control, нажмите X, а помтом - клавишу control и C). В самом

худшем случае можно прервать связь.

∙ При работе с Elm была нечаянно нажата клавиша d для файла, который

желательно сохранить.

Введите номер сообщения, нажмите enter и затем u, что "отменит

удаление" сообщения. Это работает только до выхода из Elm; после выхода

сообщение будет потеряно.

∙ Вы пытаетесь загрузить из своего компьютера сообщение формата ASCII,

написанное на вашем компьютере, в сообщение, которое вы подготавливаете в

Elm или Pine, и получаете кучу левых скобок, больших букв M, K и L, и еще

каких-то забавных символов.

Хоть верьте, хоть нет, в конце концов ваше сообщение будет выглядеть

нормально, а весь этот мусор только свидетельствует о проблемах, которые

встречаются у некоторых текстовых процессоров Unix при загрузке файлов формата

ASCII. Но ваша загрузка будет идти гораздо дольше. Один из способов с этим

справиться состоит в использовании простой почтовой программы, которая не

будет выдавать никаких таинственных символов в процессе загрузки текстового

файла в сообщение. Другой способ (он лучше, если сообщение подготовлено как

ответ на чье-то послание) - создать на своей местной системе текстовый файл

командой cat, например,

cat>файл

и загрузить туда ваш текст. Потом в программах Elm или Pine можно вставить

сообщение простой командой (control-R для Pine, например); только в этот

раз ничего такого странного вы уже и не увидите.

∙ Вы какое-то время не чистили почтовый ящик в Elm, и случайно нажали

"y", когда хотели нажать "n" (или наоборот) при выходе из программы, и

теперь все сообщения исчезли. Посмотрите в своей директориии News (в

командной строке введите: cd News) файл с именем recieved. Там лежат все

ваши сообщения. К сожалению, загрузить их в ваш почтовый ящик в Elm

невозможно - вам придется загружать этот файл или читать его в сеансе

связи.

Глава 3: USENET I

3.1 Всемирная поилка

Представьте себе разговор, который ведется на протяжении часов и дней,

как будто люди оставляют записки на доске объявлений. Или представьте себе

электронный эквивалент общего разговора людей по радио, где каждый может

внести свою лепту в общую копилку, и не одному не приходится ждать.

В отличие от электронной почты, которая обычно является разговором

"одного с одним", Usenet - это разговор "многих со многими". Usenet - это

международное место встречи, место, где люди собираются со своими друзьями,

место обсуждения событий дня, место, где можно узнать последние новости из

мира компьютеров и вообще обсудить все, что угодно. Вступление в дискуссию

на Usenet - это некоторый опыт раскрепощения. Никто не знает ни вида, ни

голоса своих собеседников, возраста, семейного положения и пр. О вас судят

только по вашим словам и вашим способностям сформулировать свою точку

зрения.

Для многих Usenet и ЕСТЬ Сеть. Фактически ее часто путают с Internet.

Но это совершенно отдельная система. Все подсистемы Internet МОГУТ нести

Usenet, но и многие подсистемы вне Internet тоже могут, от совершеннейших

машин под Unix до старых машин семейства XT и Apple II.

Технически сообщения Usenet передаются вокруг всего света от одной

местной системы к другой с помощью одного или нескольких специфических

протоколов Сети. В вашей местной системе все ее сообщения Usenet хранятся в

одном месте, к которому имеет доступ каждый владелец раздела на этой

системе. Таким образом, сколько бы людей ни читали сообщение, местная

система должна хранить только одну его копию. Многие местные системы

регулярно "разговаривают" с несколькими другими на тот случай, если

какая-то из их связей выйдет по каким-то причинам из строя. Когда две

местных системы соединяются, они сравнивают списки сообщений Usenet,

которые у них есть. Если какое-то сообщение отсутствует у одной из них,

другая его передаст, и наоборот. Так как они - компьютеры, им не трудно

проводить несколько тысяч и даже миллионов сравнений ежедневно.

Именно что миллионов. Потому что Usenet - большая сеть. Каждый день

пользователи Usenet закачивают в систему около 40 миллионов символов - это

примерно тома от A до G Британской Энциклопедии. Очевидно, никто не был бы

в силах работать со всем этим потоком сообщений. Давайте посмотрим, как

искать те конференции и дискуссии, которые вас интересуют.

Основной строительный блок Usenet - это группа новостей ("newsgroup"),

которая представляет собой собрание сообщений по некоторой группе тем (в

других сетях это называют конференциями, форумами, досками объявлений или

группами по интересам). Этих групп новостей сейчас более 5000 на нескольких

разных языках, и они охватывают все - от искусства до зоологии, от научной

фантастики до Южной Африки.

Некоторые общедоступные системы, обычно те, которые работают через

посредство меню, стараются облегчить ситуацию, деля Usenet на несколько

основных категорий. Выбрав одну из них, вы получите список групп новостей в

этой категории. Затем выберите ту группу новостей, которая вас интересует,

и читайте.

Другие системы дают возможность составить свой собственный "список

чтения", чтобы смотреть сообщения только в тех конференциях, в которых вы

хотите. В обоих случаях конференции организованы согласно некоторой

иерархии, придуманной в ранние восьмидесятые. Имена групп новостей

начинаются с самой общей темы. Например, группы новостей, имя которых

начинается с "comp.", посвящены конкретным темам, относящимся к

компьютерам. За этими общими темами следуют более детализированные

(например, группы "comp.unix" ограничиваются обсуждением вопросов,

связанных с Unix). Главные иерархии таковы:

bionet Исследовательская биология

bit.listserv Конференции, возникшие как списки рассылки Bitnet

biz Бизнес

comp Компьютеры и относящиеся к ним темы

misc Дискуссии, которые больше некуда поместить

news Новости о самой Usenet

rec Хобби, игры и отдых

sci Наука (кроме исследовательской биологии)

soc "Социальные" группы, часто связанные этнически

talk Политика и связанные с ней темы

alt Противоречивые или необычные темы; поддерживается

не всеми подсистемами

Кроме того, многие местные системы ведут группы новостей по

конкретному городу, штату или региону. Например, ne.housing - группа

новостей, где жители Новой Англии дают объявления о съеме квартир. Все

увеличивается число систем, несущих группы новостей K12, которые рассчитаны

на учителей и учащихся начальной и средней школы. А во многих городах

ведутся группы новостей clari, которые фактически являются коммерческими

службами, состоящими из сообщений телеграфных агентств и уникальной службы

компьютерной хроники (подробности в гл. 10).

3.2 Движение по Usenet с помощью nn

Как нырнуть внутрь? Как уже упоминалось, все делается через меню -

нужно просто выбирать из списка выбора до тех пор, пока на выберете ту

группу новостей, которую вы хотите читать, а тогда выбрать команду "read"

(читать). В системах Unix можно также использовать программу "newsreader"

(чтец новостей). Две наиболее часто используемых программы - это rn и nn ("no

news" (нет новостей) -- поскольку считается, что ее использовать легче).

(Намек на английскую поговорку: "Нет новостей - хорошая новость". Примечание

переводчика.)

Для начинающих nn будет лучшим выбором, поскольку эта программа

работает с меню - вам предлагается список статей в конкретной группе

новостей, а затем вы выбираете те, которые хотите прочитать. Чтобы

испробовать ее, свяжитесь с вашей местной системой и в командной строке

введите

nn news.announce.newusers

и нажмите enter. Через несколько секунд вы увидите нечто вроде следующего:

Newsgroup: news.announce.newusers Articles: 22 of 22/1 NEW

a Gene Spafford 776 Answers to Frequently Asked Questions

b Gene Spafford 362 A Primer on How to Work With the Usenet Community

c Gene Spafford 387 Emily Postnews Answers Your Questions on Netiquette

d Gene Spafford 101 Hints on writing style for Usenet

e Gene Spafford 74 Introduction to news.announce

f Gene Spafford 367 USENET Software: History and Sources

g Gene Spafford 353 What is Usenet?

h taylor 241 A Guide to Social Newsgroups and Mailing Lists

i Gene Spafford 585 Alternative Newsgroup Hierarchies, Part I

j Gene Spafford 455 >Alternative Newsgroup Hierarchies, Part II

k David C Lawrenc 151 How to Create a New Newsgroup

l Gene Spafford 106 How to Get Information about Networks

m Gene Spafford 888 List of Active Newsgroups

n Gene Spafford 504 List of Moderators

o Gene Spafford 1051 Publicly Accessible Mailing Lists, Part I

p Gene Spafford 1123 Publicly Accessible Mailing Lists, Part II

q Gene Spafford 1193 >Publicly Accessible Mailing Lists, Part III

r Jonathan Kamens 644 How to become a USENET site

s Jonathan Kamen 1344 List of Periodic Informational Postings, Part I

-- 15:52 -- SELECT -- help:? -----Top 85%-----

Explanatory postings for new users. (Moderated)

────────────────────────────────────────────────────────────────────────────

Группа новостей: news.announce.newusers Статьи: 22 из 22/1 НОВАЯ

a Джин Спаффорд 776 Ответы на часто задаваемые вопросы

b Джин Спаффорд 362 Основы того, как работать в общине USENET

c Джин Спаффорд 387 Эмили Постньюз отвечает на ваши вопросы о сетевом этикете

d Джин Спаффорд 101 Заметки о стиле написания в Usenet

e Джин Спаффорд 74 Введение в news.announce

f Джин Спаффорд 367 Программное обеспечение USENET: История и истоки

g Джин Спаффорд 353 Что такое Usenet?

h taylor 241 Руководство по социальным группам новостей и спискам рассылки

i Джин Спаффорд 585 Иерархии альтернативных групп новостей, часть I

j Джин Спаффорд 455 >Иерархии альтернативных групп новостей, часть II

k Дэвид К Лоренс 151 Как создать новую группу новостей

l Джин Спаффорд 106 Как получить информацию о сетях

m Джин Спаффорд 888 Список активных групп новостей

n Джин Спаффорд 504 Список модераторов

o Джин Спаффорд 1051 Общедоступные списки рассылки, часть I

p Джин Спаффорд 1123 Общедоступные списки рассылки, часть II

q Джин Спаффорд 1193 >Общедоступные списки рассылки, часть III

r Джонатан Камен 644 Как стать подсистемой USENET

s Джонатан Камен 1344 Список поступлений периодической информации, часть I

-- 15:52 -- ВЫБОР -- помощь:? -----Верхних85%-----

Пояснительные сообщения для новых пользователей. (Модерируемая)

────────────────────────────────────────────────────────────────────────────

Это неплохая группа новостей для того, чтобы начать исследование

Usenet! Вот что это все значит: первая буква каждой строки - это та буква,

которую нужно ввести, чтобы прочесть конкретную "статью" (разумно, чтобы

"группа новостей" содержала "статьи"). Далее следует имя человека,

написавшего эту статью, за которой указывается ее длина в строках и тема

этой статья. Внизу экрана указывается местное время вашей местной

подсистемы, работа, которую вы выполняете прямо сейчас (то есть ВЫБОР - вы

выбираете статьи), клавиша, которую надо нажать для получения помощи

(клавиша ?), и сколько статей из данной группы новостей показано на экране.

Слово "(moderated)" - модерируемая - значит, что группа новостей имеет

"модератора", который только и направляет в нее сообщения. Это обычное

ограничение для групп типа данной, содержащей статьи с основной информацией,

или групп для дайджестов, которые в основном являются электронными

журналами (о них чуть позже).

Положим, что вы конкретно интересуетесь, что хочет сказать "Эмили

Постньюз" о соблюдении этикета в Usenet. Нажмите клавишу c (нижний

регистр!), и строка окажется подсвеченной. Если вы хотите посмотреть что-то

другое, нажмите соответствующую клавишу. Если вы хотите посмотреть, что

написано на следующей странице статьи, нажмите return или пробел.

Но вы нетерпеливы, и вам хочется прочесть статью прямо сейчас. Команда

для этого отдается большой буквой Z. Нажмите ее, и вы увидите следующее:

Gene Spafford: Emily Postnews Answers Your Questions on NetiquetteSep 92 04:17

Original-author: brad@looking.on.ca (Brad Templeton)

Archive-name: emily-postnews/part1

Last-change: 30 Nov 91 by brad@looking.on.ca (Brad Templeton)

**NOTE: this is intended to be satirical. If you do not recognize

it as such, consult a doctor or professional comedian. The

recommendations in this article should recognized for what

they are -- admonitions about what NOT to do.

"Dear Emily Postnews"

Emily Postnews, foremost authority on proper net behaviour,

gives her advice on how to act on the net.

============================================================================

Dear Miss Postnews: How long should my signature be? -- verbose@noisy

A: Dear Verbose: Please try and make your signature as long as you

-- 09:57 --.announce.newusers-- LAST --help:?--Top 4%--

────────────────────────────────────────────────────────────────────────────

Джин Спаффорд: Эмили Постньюз отвечает на ваши вопросы по сетевому этикету сен 92 04:17

Оригинал-автор: brad@looking.on.ca (Brad Templeton)

Имя архива: emily-postnews/part1

Последнее изменение: 30 Ноя 91 brad@looking.on.ca (Brad Templeton)

**ПРИМЕЧАНИЕ: Предполагается, что это говорится в ироническом смысле. Если вы

этого не поняли, свяжитесь с врачом или профессиональным комедиантом.

Рекомендации, здесь приведенные, следует понимать так, как их следует

понимать - советы о том, чего НЕ делать.

"Дорогая Эмили Постньюз"

Эмили Постньюз, главный авторитет правильного поведения в сети,

дает советы о том, как действовать в сети.

============================================================================

Дорогая мисс Постньюз: насколько длинной должна быть моя подпись? - verbose@noisy

О: Дорогой Verbose: Постарайтесь сделать вашу подпись как можно дли

-- 09:57 --.announce.newusers-- ПОСЛЕДНЯЯ --help:?--Выведено 4%--

────────────────────────────────────────────────────────────────────────────

Первые несколько строк представляют собой заголовок сообщения,

аналогичный тому заголовку, который вы получаете в сообщениях с электронной

почты. Потом идет начало сообщения. В последней строке снова сообщается

время, имя группы новостей или часть этого имени, положение сообщения в

стеке сообщений, как получить помощь и какая доля сообщения находится на

экране. Если хотите продолжить чтение, просто нажмите клавишу пробел (не

enter!) для вывода на экран следующей порции и так далее до конца. По

окончанию чтения вы вернетесь в меню группы новостей. Теперь нажмите

клавишу Q (на этот раз - на верхнем регистре), что приводит к выходу из nn

и возвращает вас в командную строку местной системы. Чтобы взглянуть на

другую интересную группу новостей, введите

nn comp.risks

и нажмите enter. Эта группа новостей - еще одна модерируемая группа, на

этот раз - дайджест всех тех забавных и пугающих способов, которыми только

могут ошибаться компьютеры и те, кто ими управляет и пользуется.

Опять-таки для чтения статей следует выбирать соответствующие им буквы.

Если вы находитесь в середине чтения статьи и решили перейти к следующей,

нажмите клавишу n.

Сейчас как раз настало время посмотреть насчет тех групп новостей,

которые вам в особенности интересны. Местные системы на основе Unix, в

которых есть nn, используют программу с именем nngrep (у вас никогда не

было ощущения, что Unix не полностью написан на английском?), позволяющую

вам сканировать группы новостей. Выйдите из nn и в командной строке вашей

местной системы введите:

nngrep слово

где "слово" - это та тема, которая вас интересует. Если у вас компьютер

Macintosh, можете попробовать

nngrep mac

Вы получите что-то вроде:

alt.music.machines.of.loving.grace

alt.religion.emacs

comp.binaries.mac

comp.emacs

comp.lang.forth.mac

comp.os.mach

comp.sources.mac

comp.sys.mac.announce

comp.sys.mac.apps

comp.sys.mac.comm

comp.sys.mac.databases

comp.sys.mac.digest

comp.sys.mac.games

comp.sys.mac.hardware

comp.sys.mac.hypercard

comp.sys.mac.misc

comp.sys.mac.programmer

comp.sys.mac.system

comp.sys.mac.wanted

gnu.emacs.announce

gnu.emacs.bug

gnu.emacs.gnews

gnu.emacs.gnus

gnu.emacs.help

gnu.emacs.lisp.manual

gnu.emacs.sources

gnu.emacs.vm.bug

gnu.emacs.vm.info

gnu.emacs.vms

Заметьте, что некоторые конференции безусловно относятся к компьютерам

Macintosh, а некоторые - столь же безусловно нет; - nngrep не совершенная

система. Если вас интересует список ВСЕХ групп новостей, доступных на вашей

местной системе, введите

nngrep -a |more

или

nngrep -a |pg

и нажмите enter (что именно надо вводить - зависит от того, какая система

Unix используется в вашей местной системе; если одно не сработает,

попробуйте другое). Вам нет абсолютной необходимости добавлять |more или

|pg, но если этого не сделать, то список будет прокручиваться непрерывно, а

не останавливаться каждые 24 строки. Если вы работаете с nn, нажмите

большую букву Y для получения аналогичного списка.

Вводить "nn группа новостей" для каждой группы новостей может в конце

концов здорово надоесть. При использовании nn ваша местная система смотрит

в файл с именем .newsrc. Это в основе своей - список всех групп новостей на

местной системе с обозначениями каждой группы и статей, которые вы прочли

(ведется полностью компьютером) Вы можете также составить себе "список

чтения", который вызывает каждую из тех групп, на которые вы желаете

подписаться. Чтобы испробовать это, введите

nn

без имени группы новостей и нажмите enter.

К сожалению, вам придется начать с файла .newsrc, который "подписал"

вас на каждую отдельную группу новостей на вашей местной системе! Чтобы

удалить группу новостей из списка чтения, введите большое U в то время,

когда ее меню находится на экране. Компьютер спросит у вас, действительно

ли вы хотите "отменить подписку". Если ввести в ответ большое Y, подписка

для вас будет отменена, и вы перейдете к следующей группе. Для многих

местных систем, несущих тысячи групп новостей, этой работы хватит на всю

оставшуюся жизнь.

Но к счастью, есть пара более простых способов сделать то же самое.

Оба они требуют вызова файла .newsrc в текст-процессор. В файле .newsrc

file каждая группа новостей занимает одну строку, состоящую из имени

группы, восклицательного знака или двоеточия и диапазона чисел. Группы

новостей с двоеточием - это те, на которые вы подписаны; а те, за которыми

стоит восклицательный знак - остальные. Чтобы начать с чистого листа,

следует изменить все двоеточия на восклицательные знаки.

Если вы умеете пользоваться программами emacs или vi, вызовите файл

.newsrc (можете сначала сделать его копию на всякий случай), и сделайте

замену с помощью функции глобального поиска и замены.

Если с этими текстовыми процессорами вам работать неудобно, вы можете

выгрузить файл .newsrc к себе в компьютер, сделать желательные изменения и

загрузить измененный файл. Однако перед выгрузкой файла к себе вы должны

сделать пару дел. Одно из них - ввести

cp .newsrc temprc

и нажать enter. Фактически вы будете загружать файл temprc (заметьте, что

это имя не начинается с точки - некоторые компьютеры, из тех, что

используют MS-DOS, не разрешают начинать имена файлов с точки). После

выгрузки файла вызовите свой любимый текстовый редактор и используйте его

функции поиска и замены для изменения восклицательных знаков на двоеточия.

Будьте внимательны, чтобы не изменить ничего другого! Запомните документ в

формате текста или ASCII. Снова соединитесь с вашей местной системой. В

командной строке введите

cp temprc temprc1

и нажмите enter. Этот новый файл будет служить в качестве резервной копии

старого файла .newsrc на тот случай, если что-то будет неправильно. Теперь

загрузите файл temprc из своего компьютера. Старый файл temprc системы Unix

будет затерт. Теперь введите

cp temprc .newsrc

и нажмите enter. Вы можете теперь начать составлять список чтения с

чистого листа.

3.3 Команды nn

Чтобы пометить к чтению соответствующую статью введите написанную рядом с

ее названием букву (на нижнем регистре). Чтобы пометить конкретную статью и

все ее отклики, введите букву и звездочку, например:

a*

Чтобы снять выбор статьи, введите расположенную рядом с ней букву (на

нижнем регистре).

C Отменяет статью (повсюду), которую вы написали. Каждая

посланная на Usenet статья имеет неповторяющийся

идентификационный номер (ИД номер). Нажатие большой буквы C

посылает новое сообщение, по которому каждая получившая

ранее статью местная система находит ее и удаляет.

F Послать общедоступный отклик. Если эта команда выбрана при

нахождении на "странице" группы новостей, вас спросят, к

какой статье послать отклик. Если она выбрана при работе с

конкретной статьей, отклик будет направлен к этой статье.

В любом случае будет задан вопрос, хотите ли вы включить

исходную статью в свой текст. Внимание: будет вызван тот

текстовый редактор, который установлен у вас по умолчанию.

N Переход к следующей группе новостей с непрочитанными

статьями

P Переход к предыдущей группе новостей с непрочитанными

статьями.

G груп.нов Переходит к указанной группе новостей. Может быть

использована для подписки на новую группу новостей.

Нажатие клавиши G выводит субменю:

u Переход к группе и показ только

непрочитанных статей.

a Переход к группе и показ всех статей, в том

числе уже прочитанных.

s Будут показаны только статью с конкретной

темой (subject).

n Будут показаны только статьи, написанные

конкретным лицом.

M Посылает кому-то копию текущей статьи. Вас спросят

электронный адрес получателя, а также о том, хотите ли вы

добавить какие-либо комментарии к пересылаемой статье перед

отправкой. Как и команда F, выводит в принятый по умолчанию

редактор.

:post Поместить статью. У вас спросят имя группы.

Q Выйти из nn.

U Отменить подписку на текущую группу новостей.

R Ответить на статью по электронной почте.

пробел Нажатие пробела вызывает следующую страницу статьи.

X Если у вас есть выбранные статьи, то эта команда покажет их

вам и переведет вас к следующей группе новостей с

непрочитанными статьями. Если выбранных статей нет, то все

статьи отмечаются как прочитанные, и вы переходите к

следующей группе новостей.

=слово Находит и отмечает все статьи в группе новостей с указанным

словом в качестве строки темы ("subject:"), например:

=modem

Z Показывает все выбранные статьи немедленно и возвращается в

текущую группу новостей.

? Вызывает экран помощи

< Переходит к предыдущей странице в группе новостей.

> Переходит к следующей странице в группе новостей.

$ Переходит к последней странице статьи.

^ Переходит к первой странице статьи.

3.4 Использование rn

Некоторые предпочитают эту более старую программу чтения новостей.

Если ввести

rn news.announce.newusers

в командной строке вашей местной системы, вы увидите нечто вроде такого:

******** 21 unread articles in news.announce.newusers--read now? [ynq]

────────────────────────────────────────────────────────────────────────────

*** 21 непрочитанная статья в news.announce.newusers -- читать сейчас? [ynq]

────────────────────────────────────────────────────────────────────────────

Если нажать клавишу Y, то на вашем экране появится первая статья. Если вы

хотите сначала посмотреть, какие вообще есть статьи, нажмите клавишу = на

своей клавиатуре, и увидите нечто вроде следующего:

152 Introduction to news.announce

153 A Primer on How to Work With the Usenet Community

154 What is Usenet?

155 Answers to Frequently Asked Questions

156 Hints on writing style for Usenet

158 Alternative newsgroup Hierarchies, Part I

159 Alternative newsgroup Hierarchies, Part II

160 Emily Postnews Answers Your Questions on Netiquette

161 USENET Software: History and Sources

162 A Guide to Social newsgroup and Mailing Lists

163 How to Get Information about Networks

164 How to Create a New newsgroup

169 List of Active newsgroups

170 List of Moderators

171 Publicly Accessible Mailing Lists, Part I

172 Publicly Accessible Mailing Lists, Part II

173 Publicly Accessible Mailing Lists, Part III

174 How to become a USENET site

175 List of Periodic Informational Postings, Part I

176 List of Periodic Informational Postings, Part II

177 List of Periodic Informational Postings, Part III

End of article 158 (of 178)--what next? [npq]

────────────────────────────────────────────────────────────────────────────

152 Введение в news.announce

153 Начальные сведения по работе в обществе Usenet

154 Что такое Usenet?

155 Ответы на часто задаваемые вопросы

156 Советы по стилю писем на Usenet

158 Альтернативная иерархия групп новостей, Часть I

159 Альтернативная иерархия групп новостей, Часть II

160 Эмили Постньюз отвечает на вопросы по сетевому этикету

161 Программное обеспечение USENET: История и источники

162 Руководство по группам новостей Social и спискам рассылки

163 Как получить информацию о сетях

164 Как создать новую группу новостей

169 Список активных групп новостей

170 Список модераторов

171 Общедоступные списки рассылки, Часть I

172 Общедоступные списки рассылки, Часть II

173 Общедоступные списки рассылки, Часть III

174 Как стать подсистемой USENET

175 Список поступлений периодической информации, Часть I

176 Список поступлений периодической информации, Часть II

177 Список поступлений периодической информации, Часть III

Конец статьи 158 (из 178) - что дальше? [npq]

────────────────────────────────────────────────────────────────────────────

Обратите внимание, что все статьи теперь перечисляются в порядке

номеров без указания того, кто их послал. Похоже, что статья 154 должна

быть интересной. Чтобы ее прочесть, введите 154 и нажмите enter. Вы

увидите что-то вроде:

Article 154 (20 more) in news.announce.newusers (moderated):

From: spaf@cs.purdue.EDU (Gene Spafford)

newsgroup: news.announce.newusers,news.admin,news.answers

Subject: What is Usenet?

Date: 20 Sep 92 04:17:26 GMT

Followup-To: news.newusers.questions

Organization: Dept. of Computer Sciences, Purdue Univ.

Lines: 353

Supersedes: <spaf-whatis_715578719@cs.purdue.edu>

Archive-name: what-is-usenet/part1

Original from: chip@tct.com (Chip Salzenberg)

Last-change: 19 July 1992 by spaf@cs.purdue.edu (Gene Spafford)

The first thing to understand about Usenet is that it is widely

misunderstood. Every day on Usenet, the "blind men and the elephant"

phenomenon is evident, in spades. In my opinion, more flame wars arise

because of a lack of understanding of the nature of Usenet than from any

other source. And consider that such flame wars arise, of necessity,

among people who are on Usenet. Imagine, then, how poorly understood

Usenet must be by those outside!

--MORE--(7%)

────────────────────────────────────────────────────────────────────────────

Статья 154 (еще 20) в news.announce.newusers (модерированная):

От : spaf@cs.purdue.EDU (Джин Спаффорд)

группа новостей: news.announce.newusers,news.admin,news.answers

Subject: Что такое USENET?

Дата: 20 Сен 92 04:17:26 СВГ

Отклики: news.newusers.questions

Организация : Факультет кибернетики, Purdue Univ.

Строк: 353

Отменяет: <spaf-whatis_715578719@cs.purdue.edu>

Архивное : what-is-usenet/часть 1

Изначально от: chip@tct.com (Chip Salzenberg)

Последнее изменение: 19 июля 1992 от spaf@cs.purdue.edu (Джин Спаффорд)

Первое, что следует понимать насчет Usenet, - это то, что никто не

понимает, что это. На Usenet каждый день наблюдается "феномен слепых и

слона". По-моему, больше всего таких споров возникает из-за недостатка

понимания природы Usenet, чем из-за чего-нибудь другого. И заметьте, Что

по самой своей природе эти войны возникают между людьми, которые

находятся внутри Usenet. Вообразите же, как мало понимают о Usenet те, кто

находится вне его!

--ДАЛЬШЕ--(7%)

────────────────────────────────────────────────────────────────────────────

В этот раз заголовок выглядит очень похоже на те, которые приходят в

сообщениях электронной почты. Чтобы продолжить чтение, нажмите пробел. Если

нажать клавишу n (на нижнем регистре), то вы увидите следующее по порядку

номеров сообщение.

Для выхода из rn просто продолжайте нажимать клавишу (на нижнем

регистре), пока не вернетесь в командную строку. Теперь давайте установим

список чтения. Поскольку rn использует тот же файл .newsrc, что и nn, вы

можете воспользоваться описанным выше методом поиска и замены. А можно и

по-другому: введите

rn

и нажмите enter. Когда на вашем экране появится первая группа новостей,

нажмите клавишу u (на нижнем регистре). Нажмите ее опять, опять и опять.

Или просто держите ее нажатой (а если компьютер начнет пищать, отпустите ее

на пару секунд). В конце концов вам скажут, что вы находитесь в конце

группы новостей, и спросят, что делать дальше. Вот здесь вы и начнете

вводить группы новостей. Введите

g группа новостей

(например, g comp.sys.mac.announce) и нажмите enter. Вас спросят, не

хотите ли вы "подписаться". Нажмите клавишу y. Затем введите

g следующая группа новостей

(например, g comp.announce.newusers) и нажмите enter. Повторяйте до тех

пор, пока не будет сделано все, что надо. Этот процесс также установит и

список чтения для nn, если вы предпочитаете эту программу чтения новостей.

Но как узнать, на какие группы новостей подписываться? Введите символ l

нижнего регистра, и вы увидите список доступных групп новостей. Но на вашей

системе может быть более 2000 групп новостей, а это, наверное, не совсем

то, что вы хотите. Но к счастью, с помощью команды l можно искать группы с

заданными словами в названиях. Введя

l mac

и нажав после этого enter, вы получите список групп новостей с этим набором

букв в именах, (и как и в nn, вы также увидите группы, имеющие отношение к

emacs и тому подобному - кроме групп, относящихся к компьютерам Macintosh).

Из-за огромного числа передаваемых по Usenet сообщений большинство

систем несет сообщения только за несколько дней или недель. Так что если

есть сообщение, которое вы хотите сохранить, то вы должны либо включить

перехват экрана, либо запомнить сообщение в файле, который впоследствии

загрузите к себе в компьютер. Чтобы при работе с rn запомнить сообщение в

виде файла, введите:

s имяфайла

где имяфайла - имя, которым вы хотите назвать файл, в который будет

записано сообщение, и нажмите enter. Вас спросят, хотите ли вы запомнить

его в формате "почтового ящика" ("mailbox format"). В большинстве случаев

вы можете ответить n (при этом будет удален заголовок).Сообщение будет

записано в файл в директории News (к которой можно получить доступ, введя

cd News и нажав enter).

Кроме того, некоторые группы новостей заполняются особенно быстро -

стоит вам пару дней отсутствовать, и вы по возвращению найдете сотни

статей! Один из способов с ними разобраться - пометить их все как

"читанные", чтобы они на экране больше не появлялись. При работе с nn

введите большую букву J; при работе с rn - малую букву c.

3.5 Команды rn

В rn вам доступны разные команды - в зависимости от того, находитесь

вы уже в группе новостей или читаете конкретную статью. В любой момент ввод

символа h нижнего регистра выведет список доступных вам команд и краткие

инструкции по их использованию. Вот некоторые из них:

Сразу после вызова rn или в группе новостей:

c Помечает каждую статью в группе новостей как рочитанную (или

"взятую"), чтобы их не надо было смотреть снова. Система

спросит вас, уверены ли вы в правильности своих действий.

Это может быть сделано или при вопросе о том, хотите ли вы

прочесть некоторую конкретную группу новостей или при

нахождении в этой группе новостей.

g Переходит к группе новостей, формат:

g группа.новостей

Используется как для перехода к группе, на которую вы уже

подписаны, так и для подписки на новые группы.

h Выводит список доступных команд и краткие инструкции.

l Дает список доступных групп новостей.

p Переходит к первой "подписанной" группе новостей с

непрочитанными статьями.

q Выходит из rn, если вы еще не вошли в группу новостей. Если

вы находитесь в группе новостей, выходит из нее и переходит к

следующей "подписанной" группе новостей.

Только внутри группы новостей:

= Дает список существующий статей в группе новостей.

m Снова метит указанные статьи как "не прочитанные", чтобы

можно было вернуться к ним впоследствии. Введите

1700m

и нажмите enter - и вы пометите эту статью как не читанную.

Введите

1700-1800m

и нажмите enter - и вы пометите все эти статьи как не

читанные.

пробел Выводит следующую страницу списка статей. Если вы

находитесь на последней странице, выводит первую статью

группы новостей.

u Отменяет подписку на группу новостей.

/текст/ Ищет в группе новостей статьи с указанным словом или

фразой в строке "subject:" - от текущей статьи до конца

группы новостей. Например,

/EFF/

переместит вас к первой статье с данным словом в строке "subject:".

?текст? То же, что и /текст/, только поиск ведется от текущей статьи

в обратном направлении.

Только внутри конкретной статьи:

e Некоторые группы новостей состоят из статей, которые

представляют собой двоичные файлы - как правило, программы

или графические образы. Нажатие клавиши e преобразует символы

ASCII такой статьи в файл, который вы можете загрузить к себе

в компьютер и потом смотреть или использовать (в

предположении, что у вас есть подходящий компьютер и

программное обеспечение). Такие файлы могут быть разделены на

несколько статей, просто продолжайте вызывать статьи и

нажимать e после вызова. Результирующий файл окажется в

субдиректории News.

C Если вы послали статью, а потом решили, что этого не надо

было делать, вызовите ее в своей местной системе и нажмите

этот символ. Ваше сообщение начнет исчезать из всех систем во

всем мире.

F Отправить общедоступный отклик на текущую статью в текущую

группу новостей. Включает копию статьи, которую вы можете

редактировать с помощью текстового редактора вашей местной

системы.

f То же самое, что и выше, с тем исключением, что копия

исходной статьи не включается в сообщение.

m Метит текущую статью как "не прочитанную", так что можно

будет вернуться к ней позже. Вводить номер статьи не нужно.

Control-N Выводит на экран первый отклик на статью. Если эта

статья не имеет откликов, выводит первую нечитанную

статью в группе новостей.

Control-P Переходит к сообщению, на которое отвечает текущая статья.

n Переходит к следующей не читанной статье текущей группы

новостей.

N Переходит к следующей статье в группа новостей, даже если она

уже читанная.

q Выходит из текущей статьи. Оставляет в текущей группе

новостей.

R Отвечает только по электронной почте автору текущей статьи.

Включает копию его сообщения в ответ.

r То же, что выше, но копия исходной статьи не включается в

ответ.

s файл Копирует текущую статью в файл в директории News, где "файл"

- имя файла, в котором желательно произвести сохранение. Вас

спросят, желаете ли вы использовать при запоминании формат

"почтового ящика". Если вы ответите клавишей N, большая часть

заголовка не будет запоминаться.

s|польз.почты Пересылает кому-то копию статьи. В качестве "польз почты"

подставьте адрес электронной почты получателя. Эта команда не

позволяет добавлять к статье комментарии.

пробел Нажатие пробела выводит следующую страницу статьи или - в

конце статьи - переходит к следующей непрочитанной статье.

3.6 Основные группы новостей

При таком большом выборе каждый захочет иметь свой собственный список

чтения Usenet. Но есть несколько групп новостей, которые особенно интересны

для новичков. Среди них:

news.announce.newusers Эта группа состоит из серии статей,

объясняющих различные аспекты Usenet.

news.newusers.questions Здесь вы можете задать вопрос (чуть позже

покажем, как) о том, как работает Usenet.

news.announce.newsgroup Здесь смотрите информацию о новых

предлагаемых группах новостей.

news.answers Содержит список Часто Задаваемых Вопросов

("Frequently Asked Questions - FAQ) и

ответов на них из многих разных групп

новостей. Как бороться со сдвигом времени

при межконтинентальных перелетах см. в FAQ

rec.travel.air; ответы на вопросы по

Microsoft Windows - в FAQ из

comp.os.ms-windows, и т. д.

alt.internet.services Ищете что-то конкретное на Internet?

Спросите здесь.

alt.infosystems.announce Люди, добавляющие к Internet новые

информационные службы, сообщают здесь

подробности.

3.7 Обсуждения

"Нити" ("Threads") - это общая часть Usenet. Когда кто-то посылает

сообщение, очень часто кто-то и отвечает. Скоро возникает нить разговора.

Следить за такими нитями относительно легко. В nn связанные между собой

сообщения группируются вместе, и чтобы прочесть следующее сообщение,

достаточно нажать control-N. Осваиваясь в Usenet, неплохо сначала прочитать

какое-то обсуждение перед тем, как в него вклиниться. Таким образом можно

прощупать разные группы новостей - у каждой свой ритм.

В конце концов, вам тоже захочется поговорить. Есть два основных

способа это сделать. Можно присоединиться к уже идущему разговору, а можно

начать совершенно новую нить.

Если вы хотите присоединиться к обсуждению, то вы должны решить,

хотите ли вы включать в свое сообщение фрагменты того, на которое вы

отвечаете. Смысл в том, что читатели видят, на что вы отвечаете - на тот

случай, если у них нет оригинала (помните, что у сообщений Usenet малое

время жизни в усредненной местной системе) или они не могут его найти.

Если у вас местная система на основе Unix, то вступление в разговор

делается одинаково как в nn, так и в rn: нажмите клавишу F, закончив

работу с данной статьей в нити. В rn нажмите малую букву f, если вы не

хотите включать фрагменты того сообщения, на которое отвечаете, и большую

букву F, если хотите. В nn введите большую букву F. После этого вас

спросят, хотите ли вы включать фрагменты исходного сообщения.

И вот здесь вы столкнетесь с еще одной стенкой системы Unix. Когда вы

нажмете клавишу F, ваша местная система вызовет основной текстовый редактор

Unix. Если вам повезет, это будет pico - очень легкая система. Но гораздо

вероятнее, что вы попадете в emacs (или, возможно, vi), с которыми вы уже

встречались в главе, посвященной электронной почте.

Одна наиболее важная команда emacs такова:

control-x control-c

Это значит: при прижатой клавише control нажмите x. Затем при

прижатой клавише control нажмите c. Запомните это. На самом деле

это настолько важно, что стоит повторить:

control-x control-c

Эта последовательность нажатий клавиш выводит вас из emacs. Если они

сработают правильно, вас спросят, хотите ли вы послать, отредактировать,

прервать или внести в список сообщение, над которым вы работаете. Если они

не сработают (допустим, если вы случайно нажали какую-то другую мистическую

комбинацию клавиш, значащую что-то свое для emacs) и ничего не случится,

или вы получите еще одно загадочное приглашение от emacs в нижней строке

экрана, попробуйте нажать control-g. Это должно остановить все, что

пытается делать emacs (вы должны увидеть слово "quit" - выйти - в нижней

строке экрана), и тогда можно нажать control-x control-c. Но если и это не

поможет, у вас всегда есть возможность повесить трубку и позвонить снова!

Если вы дали своей программе чтения новостей указание, что вы хотите

включить в свой ответ фрагменты исходного сообщения, то она автоматически

поместит его целиком вверху вашего сообщения. Чтобы удалить ненужные

строки, поставьте на них курсор клавишами управления курсором и нажмите

control-K - это удаляет по одной строке за раз.

Теперь можете писать свое сообщение. Помните, что нажимать enter

необходимо раньше, чем курсор дойдет до конца строки, поскольку у редактора

emacs нет возможности переноса слов на следующую строку.

Закончив, нажмите control-X control-C. Вас спросят насчет передачи,

редактирования, прекращения и т. д. Выберите что-нибудь. Если вы нажмете

Y, ваша местная система начнет процесс пересылки вашего сообщения по Сети.

Программы nn и rn работают при пересылке нового сообщения по-разному.

В nn необходимо ввести:

:post

и нажать enter в любой группе новостей. Вас спросят, в какую группу

новостей следует поместить сообщение. Введите имя и нажмите enter. Вас

спросят о "ключевых словах" Это слова, которые должны привлечь внимание

того, кто просматривает группу новостей. Допустим, что вы продаете свой

автомобиль. Здесь вы можете ввести марку своего автомобиля. Далее идет

строка "summary" (краткое содержание), что несколько похоже. И наконец, вас

спросят о рассылке ("distribution") сообщения. Здесь вы скажете, насколько

широко должно распространяться ваше сообщение. Задумайтесь на секунду.

Если вы продаете машину, то нет смысла рассылать сообщение по всему миру.

Но если вы хотите говорить об охране окружающей среды, то смысл очень

большой. Каждая местная система имеет свой набор классификаций рассылок, но

обычно есть местная (для пользователей системы), еще одна для города, еще -

для штата или района, потом для страны (например, usa), для континента

(Америка и Канада - na), и наконец, всемирная (обычно: world).

Какую из них выбрать? Обычно секундное раздумье поможет сделать

правильный выбор. Если вы продаете машину, воспользуйтесь городской или

региональной рассылкой - тем, кто в Австралии, это, пожалуй, не

интересно, и даже несколько утомительно. Если идет речь об обсуждении

президентских выборов, то имеет смысл выбрать рассылку по США. Если же

обсуждаются события на Ближнем Востоке, то вполне стоит выбрать всемирную

рассылку.

Теперь можете ввести сове сообщение. Если вы составили его вне сеанса

связи (хорошая идея, если вы не слишком уживаетесь с emacs), то теперь его

можно загрузить в местную систему. При загрузке его в emacs вы увидите

таинственные символы, но после нажатия control-X и вслед за ним control-C

они исчезнут. Или по-другому: "запомните" сообщение (например, нажав m в

rn), выйдите, составьте сообщение автономно (вне сеанса связи), войдите

снова и загрузите ваше сообщение в файл вашей местной системы. Теперь

вызовите Usenet и найдите статью, которую вы "запомнили". Начните отвечать,

и вас спросят, хотите ли вы включить заранее подготовленное сообщение.

Введите имя файла, который вы только что создали, и нажмите enter.

В rn вам придется ждать до тех пор, пока вы не дойдете до конца группы

новостей, и потом нажать F, что выведет вас в систему составления

сообщений. Или можно в командной строке местной системы ввести

Pnews

и нажать enter. У вас спросят что-то похожее на то, что спрашивает система

nn, за исключением того, что вам будет дан список возможных рассылок. Если

вы выберете слово "world" (мир), вы увидите такое сообщение:

This program posts news to thousands of machines throughout the entire

civilized world. Your message will cost the net hundreds if not thousands of

dollars to send everywhere. Please be sure you know what you are doing.

Are you absolutely sure that you want to do this? [ny]

────────────────────────────────────────────────────────────────────────────

Эта программа рассылает новости в тысячи машин по всему цивилизованному

миру. Рассылка вашего сообщения по всему миру обойдется сети в

сотни, если не тысячи долларов. Пожалуйста, подумайте еще раз, правильно ли

вы поступаете.

Вы абсолютно уверены, что хотите это сделать? [ny]

────────────────────────────────────────────────────────────────────────────

Не волнуйтесь - ваше сообщение не обойдется Сети в бешеные тысячи, но

все же стоит подумать, действительно ли ваше сообщение нужно всюду.

Если вы хотите ответить на некоторую статью по электронной почте, а не

общедоступным сообщением, нажмите R в nn или r либо R в rn. В rn, как и

при статьях-откликах, символ верхнего регистра включает в ваше сообщение

текст исходного.

Большинство групп новостей не модерированы, что означает, что каждое

сообщение, посланное вами, в конце концов придет на каждую местную систему

в указанном вами географическом регионе, если на этой местной системе есть

такая группа новостей.

Но некоторые группы новостей модерированы, как вы могли ранее видеть в

comp.risks. В этих группах сообщения посылаются в определенное место, где

модератор, работающий как редактор журнала, решает, что же именно

поместить. В некоторых случаях группы модерируются как школьные журналы. В

других случаях это делается для уменьшения большого числа сообщений,

которые иначе были бы помещены.

Вы заметите, что многие статьи в Usenet заканчиваются причудливыми

"подписями", которые часто содержат какое-то изречение, забавную картинку

или (почти случайно) имя автора и его адрес электронной почты. Вы тоже

можете завести себе собственную "подпись", которая будет автоматически

добавляться к каждой вашей статье. Создайте файл подписи на своем

компьютере. Старайтесь сделать ее не длиннее четырех строк, чтобы не

надоедать другим участникам Сети. Теперь при соединении со своей местной

системой, введите

cat>.signature

и нажмите enter (обратите внимание на точку перед s). Загрузите ваш файл

подписи с помощью протокола ASCII вашего коммуникационного пакета. После

этого нажмите control-D - команду Unix для закрытия файла. Теперь каждый

раз, когда вы будете посылать сообщение, этот файл будет к нему добавлен.

Есть несколько предостережений, относящихся к помещению статей. Usenet

не отличается от городского собрания или публикаций: предполагается, что

вы не будете нарушать закон, помещая материалы с нарушением авторских прав

или занимаясь незаконной деятельностью. Кроме того, здесь не место для

продажи своей продукции (кроме некоторых групп новостей biz. и for-sale ).

3.8 Кросс-постинг

Иногда у вас может появиться статья, которая, по вашему мнению, должна

быть послана более чем в одну группу новостей Usenet. Вместо того, чтобы

посылать несколько сообщений в разные группы, можно послать одно и то же

сообщение в несколько групп одновременно с помощью процесса, который

называется кросс-постинг.

Допустим, что вы хотите начать обсуждение таможенной политики по

поводу импорта редких тропических рыб из Бразилии. Может найтись, что

сказать у читателей rec.aquaria. Точно также может быть свое мнение у тех,

кто читает alt.politics.animals и talk.politics.misc.

Кросс-постинг облегчает жизнь. Он также означает, что подписчик

нескольких групп новостей увидит ваше сообщение только один раз -

программное обеспечение для чтения новостей отменит все остальные копии,

как только человек прочтет сообщение. Когда вы будете посылать сообщение (с

помощью Pnews для rn или команды :post в nn), вас спросят, в какую группу

новостей его надлежит поместить. Напишите имена нескольких групп,

разделенных запятыми, но без пробелов, например:

rec.aquaria,alt.politics.animals,talk.politics.misc

и нажмите enter. После ответа на остальные вопросы (география рассылки и

пр.), сообщение будет помещено в различные группы (если же группа

модерируется, то сообщение попадет сначала к модератору, который и решит,

стоит ли его публиковать).

Помещать сообщение в большое количество групп новостей или в неподходящие

группы новостей считается дурным тоном. Может быть, вам и не надо помещать его в

20 различных мест. И хотя вы считаете, что ваше эссе по поводу политики

жизненно важно для судеб мира, есть шансы, что его не посчитают интересным

читатели rec.arts.comics - по крайней мере не настолько интересным, чтобы

обрушивать его им на головы. Вы получите множество нелицеприятных сообщений

по электронной почте с предложением ограничивать свои сообщения

"соответствующими" группами новостей.

Глава 4: USENET II

4.1 Наезды, болтовня и недержание

Что-то есть такое в электронном общении, что делает некоторых людей

крайне раздражительными. Может быть, это связано с незамедлительностью

общения и его полуанонимностью. Чтобы это ни было, но скоро вы познакомитесь с

целыми классами людей, которые будут портить вам жизнь.

Вместо того, чтобы остановиться и чуть подумать, как было бы в случае

получения письма на бумаге, гораздо проще садануть по клавише R и сказать

кому-то, что вы не можете даже сказать, что вы о нем думаете. Даже спокойные в

других случаях люди вдруг оборачиваются рычащими психами. Когда это случается,

происходят наезды.

Наезд (flame) - это особо злобный личный выпад против кого-то за что-то

им (или ею) написанное. Иногда обмен наездами выливается в войну наездов,

которая захватывает все пространство группы новостей (иногда нескольких,

потому что наезжатели любят заниматься кросс-постингом, чтобы оповещать о

своих настроениях весь мир). Это может продолжаться неделями (иногда годами, и

тогда идут "священные войны", обычно на такие темы, как сравнительные

достоинства компьютеров Macintosh и IBM). И когда они начинают затихать,

кто-то новый в этой войне прочитывает все сообщения, расстраивается и дает

срочное сообщение, что война наездов ушла в электронную почту и все желающие

могут вернуться к нормальной работе группы новостей. И от этого обычно

затевается новая война наездов, в которой бедняга автор последнего сообщения

становится мишенью для атак как лицо, посмевшее поставить под вопрос Первую

Поправку к Конституции, и найдется кто-нибудь, кто заступится за невинно

побиваемого камнями... В общем, ясно.

И очень часто дискуссия настолько выходит из берегов, что кто-нибудь

предскажет, что либо правительство вмешается и закроет эту лавочку, или кто-то

воззовет к закрытию сети вообще, или даже Гнев Божий сметет всех, кто замешан

в этой пакости. Это непременно вызовет ответ от тех, кто понимает, что Сеть -

это аморфная тварь, которую так просто не убьешь: "Предсказана неминуемая

гибель Usenet. Фильм начнется в 11".

Войны наездов сначала безумно интересно наблюдать. Но потом они быстро

надоедают. А уж когда впервые наедут на вас!

Но наезжатели - не единственные типы в сети, которых следует

остерегаться.

Недержатели (spewers) считают, что все, что интересно им, представляет

интерес для всего большого мира и должно быть запихнуто в глотку даже тем,

кому до этого нет дела. И чем чаще, тем лучше. Обычно работа недержателя

узнается по количеству статей, которые он посылает на разные группы новостей и

количеству этих групп новостей - и то, и другое выражается двузначными

числами. Часто такие сообщения относятся к различным этническим конфликтам в

мире. Чаще всего не находится связи между статьей и группой новостей, на

которую она отправлена. Без разницы. Если попробовать сказать ему, что он

выступает не совсем по теме, вас обзовут бесчувственным

расистом/американцем/кем угодно или в лучшем случае проигнорируют, чтобы

написать еще несколько сот строчек комментария о том предательстве, которое,

по мнению недержателя, грозит уничтожением его народу.

Очень близко к этим людям находятся пересматриватели Холокауста, которые

периодически наводняют определенные группы (такие, как soc.history) долгими

воплями о том, что Холокауста вообще никогда не было. Некоторые пытаются с

ними спорить, приводя факты, но другие понимают, что это только их

подзадоривает.

Болтуны - это более доброкачественная разновидность. Проблема с ними в

том, что они не могут высказаться кратко - у них тратится экрана три или

четыре на то, на что другому хватило бы фразы или двух. К видам этой болезни

можно отнести и излишнее цитирование. Подверженные этому люди могут включить в

свой ответ сообщение целиком, не отличая существенного от несущественного. В

резко выраженных случаях цитируется длинное сообщение, а потом добавляется

одна строчка:

"Согласен."

или что-нибудь в этом роде, а за ней часто идет чудовищная подпись -

.signature (см. раздел 4.5).

Есть еще некоторые типы из фауны Usenet, которых вы скоро научитесь

распознавать. Среди них:

Сетевые хамы. Этот сорт людей, которые обожают оскорблять других, те,

кто пишет грязные послания в группу новостей кройки и шитья просто, чтобы

покрепче нахамить.

Вросшие в Сеть. Это те, для кого Сеть - жизнь, кто не знает, как они

будут жить после окончания колледжа с потерей бесплатного доступа 24 часа в

сутки.

Сетевые боги. Люди с прежних времен, Истинные титаны Сети и хранители ее

коллективной истории. Они помнят времена, когда Сеть состояла из пары

компьютеров, соединенных осветительным проводом.

Затаившиеся. Этих людей не видно, но они есть. Это те, кто читают группы

новостей, но ни статей, ни ответов не посылают.

Волшебники. Люди, которые знают все насквозь о каком-то аспекте Сети.

Например, волшебники Unix могут проделывать с этой операционной системой

поразительные трюки.

Сетевые ангелы. Всегда готовые помочь новичку, поделиться своим знанием

с тем, кто не родился с умением перемещаться по Сети, они не так редко

встречаются, как можно было бы подумать. Пошлите вопрос на любую тему, и вы с

удивлением увидите, сколько вы получите ответов.

Последняя группа возвращает нас обратно к устной традиции Сети. При

наличии малого числа письменных руководств, люди по традиции учатся находить

свой путь в Сети, задавая вопросы либо кому-то за соседним терминалом, либо

кому-то в Сети. Традиция продолжается: есть вопрос - спрашивай.

В настоящее время одним из мест, в котором можно получить помощь,

является группа новостей news.newusers.questions, которая, как явствует из

названия, предлагает дополнительную информацию о Usenet. Но смотрите, что вы

посылаете. Некоторые из волшебников Usenet начинают беситься, отвечая опять и

опять на одни и те же вопросы. В конце концов они вам ответят, но сначала

скажут, что нужно было спросить у своего системного администратора или

заглянуть, что пишут в группе новостей news.announce.newusers.

4.2 Файлы исключений (killfiles) - средства от тех, кто вас беспокоит

По мере чтения информации на Usenet вы будете набредать на темы или

людей, от которых у вас уже крыша едет - или которых вы просто уже не хотите

видеть.

В этом случае файлы исключений (killfiles) - это как раз то, что вам

нужно. При запуске программы чтения новостей она проверит, а нет ли у вас

списка слов, фраз или имен, которые вы не желаете видеть. И если да, то она не

покажет сообщений, в которых эти слова содержатся.

Например, каскады.

Как вы уже видели, при посылке ответа на сообщение с включением фрагментов

самого исходного сообщения перед строками исходного сообщения ставится символ

>. А если пишется ответ на ответ? Тогда перед строкой будет стоять >>. А ответ

на ответ на ответ? Тогда >>>. Продолжая в том же духе, мы скоро получим

сообщение с огромными треугольниками, построенными из символов >.

Есть люди, которые любят строить такие треугольники, или каскады. На

ваше сообщение они отвечают так: убирают то, что вы сказали, оставляя только

"В сообщении 123435 Вы говорили:", и последнюю строку сообщения, к которой они

прибавляют бессмысленное, но хлесткое возражение. И так далее, и еще раз, и

так пока треугольники не доедут до правого края страницы. Тогда они начинают

у каждой новой строки убирать по одному символу >. Кто первый доберется до

края этого треугольника, тот и выигрывает.

Для такого народа есть своя группа новостей: alt.cascade. К сожалению,

каскадеры устраивают каскады и в других группах новостей. Поскольку для

построения полного каскада нужно много сообщений, намеченная группа новостей

вскоре ими заполняется. Попробуйте пожаловаться - и вас закидают посланиями

насчет Первой Поправки и права на художественное самовыражение - а то и еще

одним каскадом, что хуже. Единственное, что можно сделать - это игнорировать

их, построив файл исключения.

Есть еще некоторые группы новостей, в которых файлы исключений очень

удобны из-за способа организации этих групп новостей. Например, читатели

группы rec.arts.tv.soaps (телевизионные мыльные оперы) используют сокращенные

имена в указании темы (например, AMC вместо "All My Children" - "Все мои

дети"). Таким образом, те, кто хочет читать только о сериале "One Life to

Live" ("Живем только раз") могут заблокировать все сообщения по поводу "The

Young and the Restless" ("Молодые и беспокойные") и всех прочих. (Чтобы не

заставлять людей случайно просматривать все сообщения с буквами "gh", зрители

"General Hospital" ("Главный госпиталь") в качестве темы указывают "gh:").

Как nn, так и rn позволяют создавать файлы исключений, но разными

способами.

Чтобы создать файл исключений в nn, перейдите к группе новостей с

исключаемыми сообщениями и нажмите символ K верхнего регистра. В нижней строке

экрана вы увидите:

AUTO (k)ill or (s)elect (CR => Kill subject 30 days)

────────────────────────────────────────────────────────────────────────────

АВТОМАТИЧЕСКОЕ исключение или выбор (CR=> исключение темы на 30 дней)

────────────────────────────────────────────────────────────────────────────

Если вы нажмете return, nn спросит вас, тема какой статьи вам надоела.

Выберите ее, и статья вместе со всеми откликами исчезнет на 30 дней. Если

вместо этого ввести символ k нижнего регистра, вы увидите:

AUTO KILL on (s)ubject or (n)ame (s)

────────────────────────────────────────────────────────────────────────────

АВТО ИСКЛЮЧЕНИЕ темы или имени (имен)

────────────────────────────────────────────────────────────────────────────

Если нажать клавишу S или просто enter, вы увидите:

KILL Subject: (=/)

────────────────────────────────────────────────────────────────────────────

ИСКЛЮЧИТЬ Тему: (=/)

────────────────────────────────────────────────────────────────────────────

Введите исключаемое слово или фразу и нажмите enter. У вас спросят:

KILL in (g)roup 'eff.test' or in (a)ll groups (g)

────────────────────────────────────────────────────────────────────────────

ИСКЛЮЧИТЬ в группе 'eff.test' или во всех группах

────────────────────────────────────────────────────────────────────────────

только имя будет указано той группы, с которой вы работаете в настоящий

момент. Поскольку каскадеры и прочие надоеды часто посылают свои сообщения

кросс-постингом в широкий спектр групп новостей, можно уделить внимание

возможности нажать a (все) вместо g (группа). Далее следует:

Lifetime of entry in days (p)ermanent (30)

────────────────────────────────────────────────────────────────────────────

Время действия в днях (p) - постоянно (30)

────────────────────────────────────────────────────────────────────────────

Клавиша P исключит оскорбительные статьи навсегда, а нажатие enter - только на

30 дней. Можно также указать число дней блокирования.

В программе rn создание файлов исключения работает по-другому - принятый

по умолчанию генератор файлов исключения работает только для сообщений в

конкретных группах, а не глобально в списке ваших групп новостей. Чтобы

создать глобальный файл исключений, его придется написать самому.

Чтобы создать файл исключения в rn, перейдите в группу новостей, в

которой находятся оскорбительные сообщения и введите их номер, так, чтобы они

оказалось у вас на экране. Введите большую букву K. С этого момента все

сообщения с соответствующей строкой темы исчезнут прежде, чем вы начнете

читать группу. Вам следовало бы выбрать ответ, а не исходное сообщение, чтобы

учесть все отклики (исходное сообщение не содержит "Re: " в строке темы). В

следующий раз при вызове этой группы новостей rn сообщит, что производится

исключение сообщений. Когда это будет сделано, нажмите пробел и вернитесь в

режим чтения.

Чтобы создать "глобальный" файл исключения, который будет автоматически

стирать статьи во всех читаемых вами группах, нажмите control-K. Это позволит

вызвать ваш текстовый редактор, установленный в вашей местной системе по

умолчанию, и создать файл (с именем KILL, в вашей субдиректории News).

В первой строке вводится слово, фраза или имя, которые вы не хотите

видеть, а за ним - команда, которая сообщает rn, надо ли просматривать все

сообщение в поисках слова или имени, а также что делать, если такое слово

найдется.

Каждая строка должна иметь такой вид:

/образ/модификатор:j

"Образ" - это слово или фраза, которую должна искать программа rn. При

поиске не учитывается регистр символов: исключены будут как "test", так и

"Test". Модификатор сообщает rn, следует ли ограничиться при поиске только

заголовками сообщений (что может быть полезным, если желательно никогда не

просматривать сообщений от определенного лица):

a: Смотреть все сообщение

h: Смотреть только заголовки

Команду модификатора можно опустить, и тогда rn будет

просматривать только строки тем (subject) сообщений. Символ "j" в конце

строки дает указание rn опустить все статьи с указанным словом.

Итак, если вы никогда больше не хотите видеть слово "foo" ни в каком

заголовке, введите :

/foo/h:j

Это особенно полезно тогда, когда желательно отфильтровать статьи от тех

авторов, которые посылают их более чем в одну группу новостей, например,

каскадеров, поскольку имя группы новостей всегда находится в заголовке.

Если вы хотите блокировать сообщения, у которых каскады указаны в теме,

попробуйте:

/foo/:j

Чтобы избавиться от всех откликов на любую статью, используйте такой

образец:

/Subject: *Re:/:j

Когда вы закончите писать строки на каждую фильтруемую фразу, выйдите из

текстового редактора как обычно, и вы снова вернетесь в rn.

Одно предостережение: не особо увлекайтесь глобальными файлами

исключения. Обширный глобальный файл исключения или частое использование

модификатора a: может страшно замедлить работу rn, поскольку система будет

вынуждена просматривать каждое слово в каждом сообщении во всех группах

новостей, которые вы желаете читать .

Если же существует какой-то человек, чьи послания на группу новостей вы

больше никогда не хотите видеть, найдите сначала адрес этого человека (строка

"from:" в его посланиях), а потом вставьте в свой файл исключения строку вида:

/From: *имя@адрес\.all/h:j

4.3 Несколько советов по Usenet

В системе Unix учитывается регистр символов - очень часто. Многие

команды Unix, в том числе многие из тех, что используются при чтении статей

Usenet, различают символы верхнего и нижнего регистра. Нажмите d вместо

намеченного D, и либо ничего не произойдет, либо случится нечто совсем не то,

что вы ожидали. Так что будьте внимательны к регистру символов!

В nn почти всегда можно получить помощь-подсказку, введя знак вопроса

(исключение - момент написания вами сообщения, поскольку в этот момент вы

работаете с текстовым процессором). В rn для получения оперативной подсказки

следует ввести символ h нижнего регистра.

При просмотре конкретной группы новостей, командой l в rn или командой

nngrep в nn, вы иногда можете оказаться в необходимости попробовать несколько

ключевых слов. Например, если группа новостей посвящена теме "Grateful Dead",

вы ее не найдете, введя, скажем, "l grateful dead", поскольку ее имя

rec.music.gdead. Вообще говоря, следует пробовать наименьшую возможную часть

слова или темы, которую вы ищете, например, для поиска группы новостей на тему

"Star Trek" (Звездный поиск) введите "trek". Если одно слово не подойдет,

попробуйте другое.

4.4 Мальчик с опухолью мозга, налог на модемы и письмо-пирамида

Как и весь остальной мир, Usenet несет свою долю городских легенд и

предосудительной деятельности. Особенно упорно заражается эта сеть тремя

легендами. Проведя в Usenet более 15 минут, вы наверняка набредете на Мальчика

С Опухолью Мозга, на злодейский план FCC (Федеральная комиссия по связи)

обложить налогом ваш модем и на чудо-лекарство от бедности Дэйва Роудса (Dave

Rhodes). Мы здесь приведем все эти три истории.

Однажды семилетнему английскому мальчику по имени Крейг Шерголд (Craig

Shergold) был поставлен диагноз неизлечимой опухоли мозга. На смертном одре он

попросил, чтобы его друзья послали ему по открытке. Эту слезоточивую историю

напечатали местные газеты. Скоро у мальчика появилось новое желание: он

захотел попасть в книгу рекордов Гиннеса как владелец самой большой коллекции

открыток. Слово пронеслось по миру, и люди стали посылать ему открытки

миллионами.

Случилось чудо, и мальчик выжил. Какой-то американский миллиардер даже

привез его в США для хирургической операции по удалению остатков опухоли. И

сбылась самая несбыточная мечта мальчика - он попал в книгу рекордов Гиннеса.

Но сейчас, когда Крейг стал уже подростком, его мечта обратилась в кошмар

для почты того маленького городка на окраине Лондона, где он живет. Как и сам

Крейг, его просьба об открытках не умерла, и каждый год почту заваливают

миллионы открыток. Как только поток начинает иссякать, появляется кто-то, кто

снова запускает просьбу к людям посылать Крейгу открытки (или поздравления,

или визитные карточки - письма Крейга давно живут собственной жизнью и начали

мутировать). И этот процесс не остановить!

А какое отношение это имеет к Сети? Письма Крейга время от времени

всплывают в Usenet и на разных досках объявлений. Сколько бы ни посылал

регулярных сообщений кто-нибудь вроде Джин Спаффорд (Gene Spafford) с просьбой

не обращать внимания на эти письма или расходовать свои деньги как-то разумней

(например, пожертвовать в местный Красный Крест), кто-то все равно поместит

статью с предложением послать открыточку бедному малютке Крейгу.

И в Федеральную комиссию по связи тоже не посылайте открыток.

В 1987 году Федеральная комиссия по связи рассматривала вопрос об отмене

снижения налоговой ставки, которая была предоставлена CompuServe и другим

коммерческим компьютерным сетям при использовании национальной телефонной

системы. Рассмотрение было быстренько свернуто после получения колоссального

количества встревоженных писем от пользователей досок объявлений с возмущением

по поводу этого "налога на модем".

Но теперь каждые примерно два месяца кто-нибудь посылает "срочное"

сообщение с предупреждением пользователям сети о том, что FCC собирается

ввести налог на модем. Это НЕПРАВДА. Всегда есть простой способ узнать, не

имеете ли вы дела с фальшивкой: в ней ВСЕГДА упоминается инцидент, когда

ведущий радиопрограммы на радио KGO в Сан-Франциско был взбешен, читая статью

о налогах в "Нью-Йорк Таймс".

Другой способ понять, что это неправда - обратить внимание на то, что

никогда не упоминается номер соответствующего дела в FCC или дата закрытия.

Не стоит беспокоить из-за этого вашего конгрессмена - лучше напишите ему

о чем-нибудь еще.

Раньше или позже, а в конце концов вы напоретесь на сообщение с названием

"Как быстро заработать". Это - письмо-пирамида. Ее версия в Usenet всегда

упоминает парня по имени Дэйв Роудс (Dave Rhodes), кто был уже при смерти,

когда вдруг сообразил, как совершенно законным путем заработать массу денег:

послать по всей компьютерной мировой системе письмо-пирамиду. Что ж, это так и

есть.

4.5 Большая подпись

Подпись оформляется файлом .sigs. Но есть подписи и подписи. Многие в

свой файл подписи помещают только существенную информацию: имя, адрес

электронной почты, иногда - номер телефона. Другие добавляют цитату, которую

они считают смешной или глубокомысленной и объявление, что их точка зрения не

является точкой зрения их работодателя. Некоторые еще добавляют графические

образы из символов ASCII. А есть такие, которые полностью теряют чувство меры

и помещают огромные творения из тысячи цитат, причудливых ASCII-рисунков и

таким количеством адресов электронной почты, которое никогда и никому не

понадобится. Более всего подвержены этому первокурснички, допущенные в Сеть.

Самые худшие результаты этой практики можно посмотреть в группе новостей

alt.fan.warlord, которая существуют для критики слишком уж далеко заходящих

файлов .sigs, - вроде такого:

___________________________________________________________________________

|#########################################################################|

|#| |#|

|#| ***** * * ***** * * ***** ***** ***** |#|

|#| * * * * ** ** * * * * |#|

|#| * ****** *** * * * *** * ** ***** ***** |#|

|#| * * * * * * * * * * * |#|

|#| * * * ***** * * ***** ***** * * |#|

|#| |#|

|#| **** ***** ***** ***** ***** ***** ***** ***** |#|

|#| * ** * * * * * * * * |#|

|#| **** * * ** ***** * * ** * * * |#|

|#| * ** * * * ** * * * * * * * |#|

|#| **** ***** ***** ** ***** ***** ***** ***** ***** |#|

|#| |#|

|#| T-H-E M-E-G-A B-I-G .S-I-G C-O-M-P-A-N-Y |#|

|#| ~-----------------------------~ |#|

|#| "Annoying people with huge net.signatures for over 20 years..." |#|

|#| |#|

|#|---------------------------------------------------------------------|#|

|#| "The difference between a net.idiot and a bucket of shit is that at |#|

|#| least a bucket can be emptied. Let me further illustrate my point |#|

|#| by comparing these charts here. (pulls out charts) Here we have a |#|

|#| user who not only flames people who don't agree with his narrow- |#|

|#| minded drivel, but he has this huge signature that takes up many |#|

|#| pages with useless quotes. This also makes reading his frequented |#|

|#| newsgroups a torture akin to having at 300 baud modem on a VAX. I |#|

|#| might also add that his contribution to society rivals only toxic |#|

|#| dump sites." |#|

|#| -- Robert A. Dumpstik, Jr |#|

|#| President of The Mega Big Sig Company |#|

|#| September 13th, 1990 at 4:15pm |#|

|#| During his speech at the "Net.abusers |#|

|#| Society Luncheon" during the |#|

|#| "1990 Net.idiots Annual Convention" |#|

|#|_____________________________________________________________________|#|

|#| |#|

|#| Thomas Babbit, III: 5th Assistant to the Vice President of Sales |#|

|#| __ |#|

|#| ========== ______ Digital Widget Manufacturing Co. |#|

|#| \\ / 1147 Complex Incorporated Drive |#|

|#| )-======= Suite 215 |#|

|#| Nostromo, VA 22550-1147 |#|

|#| #NC-17 Enterpoop Ship :) Phone # 804-844-2525 |#|

|#| ---------------- Fax # 804-411-1115 |#|

|#| "Shut up, Wesley!" Online Service # 804-411-1100 |#|

|#| -- Me at 300-2400, and now 9600 baud! |#|

|#| PUNet: tbabb!digwig!nostromo |#|

|#| Home address: InterNet: dvader@imperial.emp.com |#|

|#| Thomas Babbit, III Prodigy: Still awaiting author- |#|

|#| 104 Luzyer Way ization |#|

|#| Sulaco, VA 22545 "Manufacturing educational widget |#|

|#| Phone # 804-555-1524 design for over 3 years..." |#|

|#|=====================================================================|#|

|#| |#|

|#| Introducing: |#|

|#| ______ |#|

|#| The |\ /| / |#|

|#| | \/ | / |#|

|#| | | / |#|

|#| | | / |#|

|#| | | ETELHED /_____ ONE |#|

|#|'`'`'`'`'`'`'`'`'`'`'`'`'`'`'`'`'`'`'`'`'`'`'`'`'`'`'`'`'`'`'`'`'`'`'|#|

|#| 50Megs Online! The k00l BBS for rad teens! Lots of games and many |#|

|#| bases for kul topix! Call now and be validated to the Metelhed Zone|#|

|#| -- 804-555-8500 -- |#|

|#|\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\V/////////////////////////////////////|#|

|#| "This is the end, my friend..." -- The Doors |#|

|#########################################################################|

---------------------------------------------------------------------------

Hit "b" to continue

Hahahha . . . fooled u!

────────────────────────────────────────────────────────────────────────────

___________________________________________________________________________

|#########################################################################|

|#| |#|

|#| ***** * * ***** * * ***** ***** ***** |#|

|#| * * * * ** ** * * * * |#|

|#| * ****** *** * * * *** * ** ***** ***** |#|

|#| * * * * * * * * * * * |#|

|#| * * * ***** * * ***** ***** * * |#|

|#| |#|

|#| **** ***** ***** ***** ***** ***** ***** ***** |#|

|#| * ** * * * * * * * * |#|

|#| **** * * ** ***** * * ** * * * |#|

|#| * ** * * * ** * * * * * * * |#|

|#| **** ***** ***** ** ***** ***** ***** ***** ***** |#|

|#| |#|

|#| К-О-М-П-А-Н-И-Я М-Е-Г-А-П-О-Д-П-И-С-Ь И-Н-К. |#|

|#| ~-----------------------------~ |#|

|#| "Достаем людей длинными подписями более двадцати лет.........." |#|

|#| |#|

|#|---------------------------------------------------------------------|#|

|#| "Различие между ведром и сетевым идиотом состоит в том, что ведро |#|

|#| иногда иссякает. Да будет мне позволено проилюстрировать мою точку |#|

|#| зрения диаграммно (достает две диаграммы). Вот у нас пользователь, |#|

|#| не только наезжающий на тех, кто не согласен с его узколобыми взг- |#|

|#| лядами, но и держащий вот такую длинную подпись, занимающую неско- |#|

|#| лько страниц бесполезными цитатами, отчего чтение часто посещаемых |#|

|#| им групп новостей превращается в пытку при модеме 300 бод на VAX. |#|

|#| Мог бы еще добавить, что его влияние на общественный климат срав- |#|

|#| ним только с выбросом промышленных отходов |#|

|#| -- Роберт А. Штемпель, Мл. |#|

|#| Президент "Мегаподпись, инк" |#|

|#| 13 сентября 1990 в 16:15 |#|

|#| На секции "Засорители Сети" |#|

|#| Конференции |#|

|#| "Сетевые идиоты 1990 года" |#|

|#|_____________________________________________________________________|#|

|#| |#|

|#| Томас Бэббит III: 5-й помощник вице-президента по сбыту |#|

|#| __ |#|

|#| ========== ______ Компания "Цифровые примочки" |#|

|#| \\ / 1147 Сложный встроенный диск |#|

|#| )-======= Номер 215 |#|

|#| Нострому, Вайоминг 22550-1147 |#|

|#| #NC-17 Enterpoop Ship :) Телефон 804-844-2525 |#|

|#| ---------------- Факс 804-411-1115 |#|

|#| "Заткнись, Уэсли!" Горячая линия # 804-411-1100 |#|

|#| -- Я на 300-2400, а теперь 9600 baud! |#|

|#| PUNet: tbabb!digwig!nostromo |#|

|#| Домашний адрес: InterNet: dvader@imperial.emp.com |#|

|#| Томас Бэббит III Prodigy: ждем утверждения |#|

|#| 104 Луззер вей |#|

|#| Сулако, Вайоминг 22545 "Все примочки для образования.... |#|

|#| телефон 804-555-1524 вот уже три года..." |#|

|#|=====================================================================|#|

|#| |#|

|#| Введение: |#|

|#| ______ |#|

|#| The |\ /| / |#|

|#| | \/ | / |#|

|#| | | / |#|

|#| | | / |#|

|#| | | ETELHED /_____ ONE |#|

|#|'`'`'`'`'`'`'`'`'`'`'`'`'`'`'`'`'`'`'`'`'`'`'`'`'`'`'`'`'`'`'`'`'`'`'|#|

|#| 50МБ на связи! k00l BBS для крутых тинов! Куча игр и много еще |#|

|#| чего! Позвони сейчас и запишись в Зону Метельхеда! |#|

|#| -- 804-555-8500 -- |#|

|#|\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\V/////////////////////////////////////|#|

|#| "Это конец, Мой друг.........." -- "Двери" (The Doors) |#|

|#########################################################################|

Для продолжение нажмите "b"

Ух, как смешно!

────────────────────────────────────────────────────────────────────────────

4.6 Первая поправка и местное законодательство

Из-за международной природы Usenet возникают интересные юридические

вопросы, которые пока еще не полностью разрешены. Может ли обсуждение или

статья, законные в одной стране, быть переданы в другую страну, где они

противоречат закону? Становится сообщение противозаконным, пересекая границу

страны? А что если это другая страна - единственный путь в третью страну, где

та же статья опять вполне законна? Несколько иностранных колледжей и других

организаций отсоединили себя от определенных групп новостей, в которых

американцы помещают то, что вполне законно в США - дискуссии о наркотиках и

альтернативном сексе. Даже в США некоторые университеты отказываются от

некоторых групп, которые их администраторы считают непристойными, обычно из

иерархии alt.

Интересный пример такого вопроса возник в 1993 году, когда канадский суд

наложил запрет на репортажи об одном противоречивом деле об убийстве.

Американцы, не связанные этим постановлением, продолжали помещать материалы о

процессе, которые мог прочесть любой канадец, имеющий раздел на Сети.

4.7 История Usenet

В начале семидесятых годов разработчики Unix вышли с новой возможностью:

система обмена информацией между двумя компьютерами Unix по телефонным линиям.

В 1979 году два аспиранта из университета в Дьюке, Северная Каролина,

Том Траскотт (Tom Truscott) и Джим Эллис (Jim Ellis), выступили с идеей

использовать эту систему, известную как UUCP (Unix-to-Unix CoPy - копирование

из UNIX в UNIX), для распространения информации, интересной для людей из числа

связанных с Unix. Вместе со Стивом Белловином (Steve Bellovin), аспирантом из

университета Северной Каролины и Стивом Дэниелом (Steve Daniel) они написали

программное обеспечение конференций и связали компьютеры в университете Дьюка

и Северной Каролины.

Слухи разошлись быстро, и в 1981-м году аспирант из Беркли Марк Хортон

(Mark Horton) и старшеклассник местной школы Мэтт Гликман (Matt Glickman)

выпустили новую версию, которая добавила новые возможности и позволила

осуществлять пересылку больших объемов информации - исходная программа из

Северной Каролины разрешала только передачу нескольких статей на группу

новостей в день.

Сегодня Usenet связывает десятки тысяч мест и систем по всему миру, от

огромных компьютеров до компьютеров Amiga. Имея более 3000 групп новостей и

несметные тысячи читателей, Usenet, возможно, является самой большой

компьютерной сетью мира.

4.8 Если что-то не так

∙ Вы запускаете rn и получаете предупреждение, что присутствуют "bogus

newsgroups" (фальшивые группы новостей)

В течение пары минут вас спросят, сохранять их или удалить. Удалите их.

Фальшивые группы новостей - это те группы новостей, о которых ваш системный

администратор или кто-то еще решил, что они не нужны.

∙ В пределах группы новостей rn вы получаете сообщение: "skipping

unavailable article" (Пропуск недоступной статьи)

Это обычно статья, которую кто-то послал, а потом отменил.

∙ Вы загрузили текстовый файл из своего компьютера в вашу местную

систему для использования либо как сообщения Usenet, либо как письма по

электронной почте, а ваш адресат, читая файл, видит ^M в конце каждой строки.

Это связано с тем, что Unix обрабатывает концы строк не так, как

компьютеры MS-DOS или Macintosh. Большинство систем Unix имеют программы для

преобразования приходящих с других компьютеров файлов. Чтобы ее использовать,

загрузите ваш файл и после того в командной строке наберите:

dos2unix файл файл

или

mac2unix файл файл

в зависимости от того, какой компьютер вы используете; файл - это имя только

что загруженного файла. Аналогичная программа подготавливает файлы к загрузке

в ваш компьютер, например:

unix2dos файл файл

или

unix2mac файл файл

гарантирует, что текстовый файл, который вы собираетесь загрузить, будет на

вашем компьютере выглядеть нормально.

4.9 Куда обратиться с вопросами

Линн Филлипс (Leanne Phillips) периодически помещает список часто

задаваемых вопросов (и ответов на них) об использовании файлов исключения

(killfile) в rn в группах новостей news.newusers.questions и news.answers на

Usenet. Билл Уолер (Bill Wohler) помещает руководство по использованию

программы чтения новостей nn в группах новостей news.answers и news.software.

В группах новостей news.announce.newusers и news.groups на Usenet ищите "A

Guide to Social newsgroups and Mailing Lists" (Руководство по социальным

группам новостей и спискам рассылки), где дается краткое описание различных

групп новостей из иерархии soc.

"Managing UUCP and Usenet" (Введение UUCP и Usenet) Тима О'Рэйли (Tim

O'Reilly) и Грэйс Тодино (Grace Todino) (O'Reilly & Associates, 1992) -

хорошее руководство для организации собственной системы Usenet.

Глава 5: СПИСКИ РАССЫЛКИ И BITNET

5.1 Списки рассылки и Internet

Usenet не является единственным форумом Сети. Так называемые "списки

рассылки, или почтовые списки ("mailing lists") представляют собой другую

возможность взаимодействия пользователей Сети между собой. В отличие от

сообщений Usenet, которые хранятся где-то централизованно, сообщения списка

рассылки прибывают прямо в ваш почтовый ящик.

Чтобы присоединиться к списку рассылки, надо попросить разрешения. В

отличие от Usenet, где ваше сообщение расходится по всему миру, в списке

рассылки вы посылаете сообщение центральному модератору, который и решает,

передавать его остальным участникам списка или включить в периодически

составляемый "дайджест", доставляемый подписчикам.

Но зачем при таком числе групп новостей нужны еще списки рассылки?

Даже на Usenet некоторые темы не набирают заинтересованных на целую

группу, - например, есть список Queen, который полностью посвящен музыкальной

группе покойного Фредди Меркьюри.

И поскольку тех, кто может принять участие в дискуссии, определяет

модератор, список рассылки дает некоторую свободу в высказывании своих

мыслей (и свободу не опасаться сетевых хамов), что не всегда возможно на

Usenet. В некоторых группах помещают статьи анонимно - только модератор

знает подлинное имя автора. Среди примеров можно привести 12Step (12

шагов), где могут обсудить свои проблемы люди, участвующие в движениях

Анонимных Алкоголиков, и sappho - список, ограниченный гомосексуальными и

бисексуальными женщинами.

Найти почтовые адреса и описания таких списков можно в группе

новостей news.announce.newusers с темой "Publicly Accessible Mailing Lists"

(Общедоступные списки рассылки). Число списков рассылки в настоящий момент

измеряется сотнями, так что сообщения этой группы делятся на три части.

Если вы найдете список, на который захотите подписаться, пошлите

сообщение по электронной почте на адрес

список-request@адрес

где "список" - имя списка рассылки, а "адрес" - адрес электронной почты

модератора с просьбой включить вас в список. В письме укажите свой полный

адрес электронной почты на случай, если с заголовком вашего сообщения

что-нибудь случится, а на тот случай, если вашу просьбу удовлетворят,

спросите адрес для посылки сообщений в список.

5.2 Bitnet

Как будто недостаточно Usenet и списков рассылки, так есть еще

"дискуссионные группы" или "списки" Bitnet.

Bitnet - это международная сеть, связывающая колледжи и университеты,

но в ней для передачи информации используется набор протоколов, отличный от

принятого в Internet или Usenet. Эта сеть предлагает сотни дискуссионных

групп, сравнимых по области охвата с группами новостей Usenet.

Одно из наибольших различий - это способ распределения сообщений.

Сообщения Bitnet пересылаются вам в почтовый ящик, как и в случае со

списком рассылки. Однако списки рассылки ведутся человеком, а дискуссионные

группы Bitnet автоматизированы - вы на них подписываетесь посылкой

сообщения компьютеру - "серверу списка" (listserver). Это в каком-то

смысле робот-модератор, отслеживающий распределение сообщений по списку. Во

многих случаях он также ведет указатели и архивы прошлых поступлений в

конкретной дискуссионной группе, что достаточно удобно, если вы хотите

быстренько просмотреть историю обсуждения или связанную с ним информацию.

Многие дискуссионные группы Bitnet теперь "переведены" в форму Usenet

и ведутся в иерархии Usenet bit.listserv. Вообще говоря, возможно, лучше

читать сообщения посредством Usenet, если у вас есть такая возможность. Это

сэкономит память на жестких дисках вашей местной системы.

Если на список Bitnet подписаны 50 человек, это означает, что на

каждое сообщение будет храниться 50 копий, а когда 50 человек читают

сообщение Usenet, в системе все равно хранится только одна копия. Это также

полезно для вашего здоровья, если в дискуссионной группе имеется много

сообщений. Представьте себе, что вы открываете свой почтовый ящик, а там

200 сообщений - 199 из дискуссионной группы, и только одно - настоящее

письмо по электронной почте, которое для вас существенно.

Подписка и отмена подписки выполняется путем посылки сообщения по

электронной почте компьютеру - серверу списка. Для адресации все серверы

списка известны как "listserv" (вот именно) по некоему адресу Bitnet. Это

значит, что нужно в конце адреса добавить ".bitnet" если он имеет вид,

например, listserv@miamiu. Пусть, к примеру, вы интересуетесь вопросами

окружающей среды, - тогда вы можете захотеть подписаться на дискуссионную

группу Econet. Для этого пошлите сообщение по электронной почте к

listserv@miamiu.bitnet

Некоторые серверы списков Bitnet подсоединены также и к Internet, так что

если вы видите, что адрес сервера списка кончается на ".edu", то можно не

добавлять ".bitnet" к концу адреса.

Строку "subject:" в послании к серверу списка всегда оставляйте

пустой. В самом сообщении скажите серверу списка, чего вы хотите, указав

последовательность простых команд:

subscribe группа Ваше Имя Чтобы подписаться на список, где "группа" -

имя списка, а "Ваше Имя" - ваше полное имя,

например: subscribe econet Генри Филдинг

unsubscribe группа Ваше имя Чтобы отсоединиться от группы, например:

unsubscribe econet Генри Филдинг

list global Это передает вам список всех доступных

дискуссионных групп Bitnet. Но осторожно -

этот список ОЧЕНЬ длинный!

get refcard Передает вам список других команд, которые вы

можете использовать при работе с сервером

списка, такие, как команды для выбора прошлых

поступлений из дискуссионной группы.

Каждая из этих команд занимает отдельную строку в вашем сообщении (и

вы можете использовать одну из них или все сразу). Если вы хотите получить

список всех дискуссионных групп Bitnet, пошлите сообщение по электронной

почте на адрес

listserv@bitnic.educom.edu

Строку "subject:" оставьте пустой и используйте команду list global.

При подписке на группу Bitnet есть два важных отличия от Usenet.

Первое: когда вы хотите послать сообщение для прочтения другими

участниками дискуссионной группы, вы посылаете сообщение на имя группы и ее

адрес Bitnet. В примере с Econet посылать сообщение следует на адрес:

econet@miamiu.bitnet

Заметьте, что этот адрес отличается от адреса сервера списка, который

вы использовали для подписки. Адрес сервера списка используется ТОЛЬКО для

подписки или прекращения подписки на дискуссионную группу. Если вы

попробуете использовать адрес дискуссионной группы для подписки или отказа

от нее, ваше сообщение попадет к каждому подписчику, и у некоторых из них

возникнут недобрые чувства, коими они не преминут с вами поделиться по

электронной почте.

Второе различие относится к посылке сообщения по электронной почте

автору конкретного сообщения в группе. Программы чтения новостей Usenet

типа rn и nn позволяют сделать это одной клавишей. Но если вы нажмете

клавишу R для ответа на сообщение в дискуссионной группе, ваше сообщение

пойдет на сервер списка, а оттуда - к каждому, кто в этом списке есть! Это

может быть неожиданно для вас и утомительно для остальных. Чтобы убедиться,

что ваше письмо поехало прямо к автору сообщения, возьмите его адрес

электронной почты из его сообщения и составьте к нему новое сообщение.

Также помните, что если вы видите адрес вроде IZZY@INDYVMS, то это - адрес

Bitnet.

Два списка Bitnet очень полезны для дальнейшего продвижения по

сети. Список NEW-LIST сообщает названия новых дискуссионных групп. Чтобы

подписаться, пошлите по адресу listserv@ndsuvm1.bitnet сообщение

sub NEW-LIST Свое Имя

Список INFONETS - это то место, куда надо обращаться с вопросами по

поводу Bitnet. Здесь также можно получить ответы на вопросы о главных

компьютерных сетях и о том, как до них добраться. Чтобы подписаться,

пошлите сообщение по электронной почте в адрес info-nets-

request@think.com:

sub INFONETS Ваше Имя

Оба эти списка доступны также и с Usenet, - первый как

bit.listserv.new-list; второй - как bit.listserv.infonets (иногда как

bit.listserv.info-nets).

Глава 6: TELNET

6.1 Внутрь сети

Как всякое масштабное сообщество, мир компьютерных сетей имеет свои

библиотеки, в которые можно обратиться за нужной информацией или просто

взять хорошую книгу. Telnet - один из ключей к этим библиотекам.

Telnet - это программа, дающая возможность использовать все мощные

средства Internet для связи с базами данных, каталогами библиотек и прочими

информационными ресурсами мира. Хотите узнать погоду в Вермонте?

Осведомиться, как растут овощи в Азербайджане? Получить дополнительную

информацию о человеке, чье имя мелькнуло в сеансе связи? Все это и многое

другое позволит сделать Telnet.

Увы, существует одно большое "но". В отличие от телефонной сети,

Internet не универсален - не все имеют доступ к любым его услугам. Почти

все колледжи и университеты обеспечивают доступ к telnet. То же верно и в

отношении платных общедоступных систем, перечисленных в главе 1. Но

бесплатные системы (Free-Net) не дают доступа к каждой системе telnet. А

если вы работаете с общедоступной подсистемой UUCP или Usenet, то доступа к

telnet у вас не будет. Основной причиной этого является цена. Связь с

Internet легко может стоить 1000 долларов США или более при аренде

высокоскоростной телефонной линии. Тем не менее доступ к некоторым базам

данных и библиотекам файлов можно получить по электронной почте; несколько

позже мы покажем, как это сделать. В остальной же части данной главы

предполагается, что пользователь работает в подсистеме, дающей по крайней

мере частичный доступ к Internet.

Большей частью подсистемы telnet просты в использовании и снабжены

аппаратом оперативных подсказок. Большая часть таких подсистем работает

лучше всего при эмуляции терминала VT100 (а в некоторых случаях - только

так). Попробуем же одну из них.

Введите в командной строке вашей системы команду

telnet access.usask.ca

и нажмите клавишу enter. Этого достаточно для выхода на подсистему telnet!

Вы таким образом связываетесь со службой, известной под названием Hytelnet,

которая представляет доступ к каталогам компьютеризованных

библиотек и других баз данных, доступных посредством telnet. Вы увидите

нечто вроде следующего:

Trying 128.233.3.1 ...

Connected to access.usask.ca.

Escape character is '^]'.

Ultrix UNIX (access.usask.ca)

login:

────────────────────────────────────────────────────────────────────────────

Пробуется 128.233.3.1 ...

Соединение с access.usask.ca.

Символ выхода '^]'.

Ultrix UNIX (access.usask.ca)

login:

────────────────────────────────────────────────────────────────────────────

Каждая подсистема Telnet имеет два адреса: один состоит из слов, чтобы

его легче было запоминать людям, второй - из цифр, что удобнее для

компьютеров. "Символ выхода" ("escape character") полезно запомнить. Когда

ничто другое не помогает, нажмите одновременно клавишу <control> и клавишу

] одновременно, и вы вернетесь в операционную систему своей системы. В ответ

на запрос login (регистрация) введите

hytelnet

и нажмите клавишу enter. Вы увидите нечто вроде следующего:

Welcome to HYTELNET

version 6.2

...................

What is HYTELNET? <WHATIS> . Up/Down arrows MOVE

Library catalogs <SITES1> . Left/Right arrows SELECT

Other resources <SITES2> . ? for HELP anytime

Help files for catalogs <OP000> .

Catalog interfaces <SYS000> . m returns here

Internet Glossary <GLOSSARY> . q quits

Telnet tips <TELNET> .

Telnet/TN3270 escape keys <ESCAPE.KEY> .

Key-stroke commands <HELP.TXT> .

........................

HYTELNET 6.2 was written by Peter Scott,

U of Saskatchewan Libraries, Saskatoon, Sask, Canada. 1992

Unix and VMS software by Earl Fogel, Computing Services, U of S 1992

────────────────────────────────────────────────────────────────────────────

Добро пожаловать в HYTELNET

Версии 6.2

...................

Что такое Hytelnet <WHATIS> . Стрелки вверх-вниз -

Каталоги библиотек <SITES1> . ПЕРЕМЕЩЕНИЕ

Прочие ресурсы <SITES2> . Стрелки вправо-влево - ВЫБОР

Файлы подсказок для каталогов <OP000> . ? Оперативная подсказка

Интерфейсы каталогов <SYS000> . m возврат в данное меню

Глоссарий Internet <GLOSSARY> . q выход

Подсказки по Telnet <TELNET> .

Клавиши выхода Telnet/TN3270 <ESCAPE.KEY> .

Команды клавиатуры <HELP.TXT> .

........................

HYTELNET 6.2 написан Питером Скоттом,

Библиотека Саскачеванского ун-та, Саскатун, Саск., канада. 1992

ПО систем Unix и VMS - Эрл Фогель, Компьютерные услуги, Ун-т Саск. 1992

────────────────────────────────────────────────────────────────────────────

Первый выбор, "<WHATIS>", будет подсвечен. Воспользуйтесь клавишами

"Стрелка вверх" и "Стрелка вниз" для перемещения курсора по предлагаемым

возможностям. Выбрав желательную, нажмите клавишу <Enter>. Вам будет

предъявлено другое меню, которое, в свою очередь, даст возможность вызывать

текстовые файлы, разъясняющие, как связаться с подсистемами и описывающие

все специальные команды и инструкции, которые могут понадобиться. Hytelnet

имеет одну особенность. Чтобы вернуться из начатой операции (например, в

главное меню из субменю), нажмите клавишу "стрелка влево".

Попробуйте поиграть с системой. Включите протоколирование экрана или

на худой конец запаситесь ручкой и бумагой. Вы наверняка встретитесь с

некоторыми интересными возможностями telnet, которые вам захочется

испробовать, и вам понадобятся их "адреса" в telnet.

При перемещениях между возможностями Hytelnet может показаться, что вы

не выходили из операционной системы вашего компьютера - настолько быстро

работает telnet. Однако в моменты большой нагрузки на сеть будет заметна

задержка между вводом команды или запроса и ответом удаленной службы.

Чтобы отключиться от Hytelnet и вернуться в операционную систему,

введите символ q и нажмите клавишу <enter>.

Некоторые компьютеры telnet настроены таким образом, что получить к

ним доступ можно только через специальный "порт". В таких случаях после их

имени всегда выводится номер, например: india.colorado.edu 13. Этот номер

обязательно надо указать, в противном случае доступа вы не получите.

В самом деле, испробуйте этот адрес. Введите:

telnet india.colorado.edu 13

и нажмите клавишу enter. Вы увидите нечто вроде следующего текста:

Trying 128.138.140.44 ...

────────────────────────────────────────────────────────────────────────────

Пробуется 128.138.140.44 ...

────────────────────────────────────────────────────────────────────────────

за которым будет вот такая информация:

telnet india.colorado.edu 13

Escape character is '^]'.

Sun Jan 17 14:11:41 1994

Connection closed by foreign host.

────────────────────────────────────────────────────────────────────────────

telnet india.colorado.edu 13

Символ выхода '^]'

Воскр. Янв. 17 14:11:41 1994

Связь прервана системой абонента

────────────────────────────────────────────────────────────────────────────

Нас здесь интересует средняя строчка, в которой сообщается точное

стандартное время, отсчитанное государственными атомными часами в Боулдере,

Колорадо.

6.2 Каталоги библиотек

В настоящее время с помощью telnet можно получить доступ к сотням

библиотек по всему миру, от Снохомишской публичной библиотеки в штате

Вашингтон до Библиотеки Конгресса США. Их названия, адреса telnet и

инструкции по использованию можно найти с помощью Hytelnet.

Зачем искать книги в библиотеке, до которой нельзя добраться физически?

Дело в том, что многие библиотеки обмениваются книгами, так что если в

вашей библиотеке нет того, чего вы ищете, то вы сможете сказать

библиотекарю, где эту книгу можно взять. Или, если вы живете там, где

библиотеки еще не соединены в сеть, вы можете использовать telnet для

составления некоторой предварительной библиографии.

В сетевых библиотеках используется несколько программ работы с базами

данных. Одна из наиболее простых принята в Гарварде, так что давайте ее

попробуем.

Свяжитесь по telnet с hollis.harvard.edu. После соединения вы

увидите:

***************** H A R V A R D U N I V E R S I T Y

***************** OFFICE FOR INFORMATION TECHNOLOGY

*** *** ***

*** VE *** RI ***

*** *** *** HOLLIS (Harvard OnLine LIbrary System)

***** *****

**** TAS **** HUBS (Harvard University Basic Services)

*** ***

***** IU (Information Utility)

***

CMS (VM/CMS Timesharing Service)

** HOLLIS IS AVAILABLE WITHOUT ACCESS RESTRICTIONS **

Access to other applications is limited to individuals who have been

granted specific permission by an authorized person.

To select one of the applications above, type its name on the command

line followed by your user ID, and press RETURN.

** HOLLIS DOES NOT REQUIRE A USERID **

EXAMPLES: HOLLIS (press RETURN) or HUBS userid (press RETURN)

===>

────────────────────────────────────────────────────────────────────────────

***************** ОТДЕЛ ИНФОРМАЦИОННЫХ ТЕХНОЛОГИЙ

***************** ГАРВАРДСКОГО УНИВЕРСИТЕТА

*** *** ***

*** VE *** RI ***

*** *** *** HOLLIS (Гарвардская система связи библиотек)

***** *****

**** TAS **** HUBS (Основные службы Гарвардского ун-та)

*** ***

***** IU (Информационная утилита)

***

CMS (Служба разделения времени VM/CMS)

** HOLLIS ДОСТУПЕН БЕЗ ОГРАНИЧЕНИЙ **

Доступ к другим приложениям позволен лишь тем, кто имеет специальное

разрешение от ответственного лица.

Для выбора одного из указанных выше приложений введите его название в

командной строке и свой ID пользователя, а затем нажмите RETURN.

** HOLLIS НЕ ТРЕБУЕТ ID ПОЛЬЗОВАТЕЛЯ**

ПРИМЕРЫ: HOLLIS (нажмите RETURN) или HUBS ID пользователя (нажмите

RETURN)

===>

────────────────────────────────────────────────────────────────────────────

Введите:

hollis

и нажмите enter. Перед вами промелькнут несколько экранов, и наконец

система остановится, предъявив вам следующее:

WELCOME TO HOLLIS

(Harvard OnLine Library Information System)

To begin, type one of the 2-character database codes listed below:

HU Union Catalog of the Harvard libraries

OW Catalog of Older Widener materials

LG Guide to Harvard Libraries and Computing Resources

AI Expanded Academic Index (selective 1987-1988, full 1989- )

LR Legal Resource Index (1980- )

PA PAIS International (1985- )

To change databases from any place in HOLLIS, type CHOOSE followed by a

2-character database code, as in: CHOOSE HU

For general help in using HOLLIS, type HELP. For HOLLIS news, type

HELP NEWS. For HOLLIS hours of operation, type HELP HOURS.

ALWAYS PRESS THE ENTER OR RETURN KEY AFTER TYPING YOUR COMMAND

────────────────────────────────────────────────────────────────────────────

ДОБРО ПОЖАЛОВАТЬ В HOLLIS

(Гарвардская система связи библиотек)

Для начала работы введите один из ниже перечисленных кодов баз данных

HU Каталог объединенных библиотек Гарварда

OW Каталог материалов Older Widener

LG Руководство по Гарвардским библиотечным и компьютерным

источникам

AI Расширенный академический указатель (выборочный 1987-1988,

полный - с 1989)

LR Юридический справочник (1980- )

PA PAIS International (1985- )

Для смены базы данных в любой момент работы с HOLLIS, введите CHOOSE с

двухсимвольным кодом базы данных, например: CHOOSE HU

Для получения общих пояснений по использованию HOLLIS, введите HELP.

Для получения информации по новостям HOLLIS, введите HELP NEWS.

Для получения информации о часах работы HOLLIS введите HELP HOURS.

ПОСЛЕ НАБОРА КАЖДОЙ КОМАНДЫ НАЖИМАЙТЕ КЛАВИШУ ENTER ИЛИ RETURN

────────────────────────────────────────────────────────────────────────────

Прежде всего обратите внимание на имя системы: Hollis. Библиотекари

мира любят придумывать для своих машин человеческие имена (недалеко от

Гарварда библиотекари Брандийского университета назвали свою библиотечную

систему Louis; в Массачусетском технологическом работает Barton).

Если вам нужно выполнить некоторый общий поиск, то в Гарвардской

системе для этого лучше всего выбрать HU, что дает доступ к главным

хранилищам, в том числе и медицинских библиотек. При выборе этой

возможности вы увидите:

THE HARVARD UNIVERSITY LIBRARY UNION CATALOG

To begin a search, select a search option from the list below and type its

code on the command line. Use either upper or lower case.

AU Author search

TI Title search

SU Subject search

ME Medical subject search

KEYWORD Keyword search options

CALL Call number search options

OTHER Other search options

For information on the contents of the Union Catalog, type HELP.

To exit the Union Catalog, type QUIT.

A search can be entered on the COMMAND line of any screen.

ALWAYS PRESS THE ENTER OR RETURN KEY AFTER TYPING YOUR COMMAND.

────────────────────────────────────────────────────────────────────────────

КАТАЛОГ ОБЪЕДИНЕННЫХ БИБЛИОТЕК ГАРВАРДСКОГО УНИВЕРСИТЕТА

Для начала работы введите один из ниже перечисленных кодов возможностей.

Набирать символы можно как на верхнем, так и на нижнем регистре.

AU Поиск по автору

TI Поиск по названию

SU Поиск по теме

ME Поиск по медицинской теме

KEYWORD Поиск по ключевым словам

CALL Вызов поиска по номеру

OTHER Другие варианты поиска

Для получения информации по содержанию каталога объединенных библиотек,

введите HELP. Для выхода из каталога, введите QUIT.

Поиск может быть инициализирован вводом в строке COMMAND любого экрана.

ПОСЛЕ НАБОРА КАЖДОЙ КОМАНДЫ НАЖИМАЙТЕ КЛАВИШУ ENTER ИЛИ RETURN

────────────────────────────────────────────────────────────────────────────

Допустим, что нас интересует, придерживается ли Гарвард до сих пор

чопорных правил тех пуритан, что его когда-то основали. Почему не

посмотреть, нет ли у них где-нибудь книжки "The Joy of Sex" (радость

секса)? Введите:

TI Joy of Sex

и нажмите enter. Появится следующее сообщение:

HU: YOUR SEARCH RETRIEVED NO ITEMS. Enter new command or HELP. You typed:

TI JOY OF SEX

*******************************************************************************

ALWAYS PRESS THE ENTER OR RETURN KEY AFTER TYPING YOUR COMMAND.

-------------------------------------------------------------------------------

OPTIONS: FIND START - search options HELP

QUIT - exit database

COMMAND?

────────────────────────────────────────────────────────────────────────────

HU: ПО ЗАПРОСУ НИЧЕГО НЕ НАЙДЕНО. ВВЕДИТЕ НОВУЮ КОМАНДУ ИЛИ HELP. ВАШ ВВОД:

TI JOY OF SEX

*******************************************************************************

ПОСЛЕ НАБОРА КАЖДОЙ КОМАНДЫ НАЖИМАЙТЕ КЛАВИШУ ENTER ИЛИ RETURN

-------------------------------------------------------------------------------

ВОЗМОЖНОСТИ: ПОИСК START - возможности поиска HELP

QUIT - выход из базы данных

КОМАНДА?

────────────────────────────────────────────────────────────────────────────

Ладно же! А есть у них где-нибудь в заголовках слово "sex"? Попробуем

другой поиск по заглавию (TI), на этот раз такой: TI sex. Мы получим:

HU GUIDE: SUMMARY OF SEARCH RESULTS 2086 items retrieved by your search:

FIND TI SEX

------------------------------------------------------------------------------

1 SEX

2 SEX A

823 SEXA

827 SEXBO

831 SEXCE

833 SEXDR

834 SEXE

879 SEXIE

928 SEXJA

929 SEXLE

930 SEXO

965 SEXPI

968 SEXT

1280 SEXUA

2084 SEXWA

2085 SEXY

-------------------------------------------------------------------------------

OPTIONS: INDEX (or I 5 etc) to see list of items HELP

START - search options

REDO - edit search QUIT - exit database

COMMAND?

────────────────────────────────────────────────────────────────────────────

HU GUIDE: СВОДКА РЕЗУЛЬТАТОВ ПОИСКА 2086 позиций найдено по запросу:

FIND TI SEX

------------------------------------------------------------------------------

1 SEX

2 SEX A

823 SEXA

827 SEXBO

831 SEXCE

833 SEXDR

834 SEXE

879 SEXIE

928 SEXJA

929 SEXLE

930 SEXO

965 SEXPI

968 SEXT

1280 SEXUA

2084 SEXWA

2085 SEXY

-------------------------------------------------------------------------------

ВОЗМОЖНОСТИ: INDEX (или I 5 и т.д.) для списка HELP

START - возможности поиска

REDO - редактирование запроса QUIT - выход из базы данных

КОМАНДА?

────────────────────────────────────────────────────────────────────────────

Если хотите получить более подробную информацию по первой строке,

введите 1 и нажмите enter:

HU INDEX: LIST OF ITEMS RETRIEVED 2086 items retrieved by your search:

FIND TI SEX

------------------------------------------------------------------------------

SEX

1 geddes patrick sir 1854 1932/ 1914 bks

SEX A Z

2 goldenson robert m/ 1987 bks

SEX ABUSE HYSTERIA SALEM WITCH TRIALS REVISITED

3 gardner richard a/ 1991 bks

SEX AETATES MUNDI ENGLISH AND IRISH

4 irish sex aetates mundi/ 1983 bks

SEX AFTER SIXTY A GUIDE FOR MEN AND WOMEN FOR THEIR LATER YEARS

5 butler robert n 1927/ 1976 bks

------------------------------------------------------ (CONTINUES) ------------

OPTIONS: DISPLAY 1 (or D 5 etc) to see a record HELP

GUIDE MORE - next page START - search options

REDO - edit search QUIT - exit database

COMMAND?

────────────────────────────────────────────────────────────────────────────

HU INDEX: СПИСОК НАЙДЕННЫХ ПОЗИЦИЙ 2086 позиций найдено по запросу:

FIND TI SEX

------------------------------------------------------------------------------

СЕКС

1 геддес патрик сэр 1854 1932/ 1914

СЕКС ОТ А ДО Я

2 голденсон роберт м/ 1987

ИСТЕРИЯ НА СЕКСУАЛЬНОЙ ПОЧВЕ - ПЕРЕСМОТР ПРОЦЕССОВ САЛЕМСКИХ ВЕДЬМ

3 гарднер ричард a/ 1991

SEX AETATES MUNDI В АНИГЛИИ И ИРЛАНДИИ

4 ирландия sex aetates mundi/ 1983

СЕКС ПОСЛЕ ШЕСТИДЕСЯТИ - РУКОВОДСТВО ДЛЯ МУЖЧИН И ЖЕНЩИН ЗРЕЛЫХ ЛЕТ

5 батлер роберт н/ 1927/ 1976 bks

------------------------------------------------------ (ПРОДОЛЖЕНИЕ) ------------

ВОЗМОЖНОСТИ: DISPLAY 1 (или D 5 и т.д.) просмотр записии ПОМОЩЬ

РУКОВОДСТВО MORE - след. стр. START - возможности поиска

REDO - редактирование команды поиска QUIT - выход из базы данных

КОМАНДА?

────────────────────────────────────────────────────────────────────────────

Большинство библиотечных систем дают возможность выйти из них и

вернуться в операционную систему вашего компьютера. В Hollis для этого

следует нажать клавишу escape и

xx

В частности, интересна система, работающая в Колорадском объединении

исследовательских библиотек (Colorado Alliance of Research Libraries),

которая ведет базы данных для библиотек в Колорадо, на западе, и даже в

Бостоне.

Telnet pac.carl.org.

Для входа в систему следуйте достаточно простым инструкциям. Получив

меню, введите 72 (хотя эта возможность и не указана), что выведет вас на

Библиотечный Округ Пайкс Пик (Pikes Peak Library District), который

обслуживает город Колорадо-Спрингс.

Несколько лет тому назад библиотекари этого города решили, что могут

использовать свою базу данных не только для ведения информации о книгах, но

и для ведения записей о городских событиях и общественной жизни. Теперь,

если вам нужно просмотреть постановления муниципалитета или городские

архивы, придется только ввести слово, которое вы ищете, и вы получите

ссылки на соответствующие решения или постановления. Carl также может вас

связать с библиотекой Гавайского университета, которая, как и библиотека в

Колорадо Спрингс, содержит больше, чем просто оперативные библиографические

материалы. В частности, она предлагает доступный по сети Гавайский

Альманах, содержащий все, что вы когда-либо можете захотеть узнать о

Гавайцах, включая среднее число пострадавших при катании на досках в каждом

году (семь).

6.3 Некоторые интересные подсистемы Telnet

Время

Для определения точного времени:

Telnet: india.colorado.edu 13

Вы увидите нечто вроде следующего:

Escape character is '^]'.

Sun Apr 5 14:11:41 1992

Connection closed by foreign host.

────────────────────────────────────────────────────────────────────────────

Символ выхода '^]'.

Воск. Апр. 5 14:11:41 1992

Связь прервана местной системой абонента

────────────────────────────────────────────────────────────────────────────

В средней строке указана дата и точное время согласно показаниям

федеральных атомных часов.

География

Сервер географических названий Мичиганского университета предоставляет

пользователю общую информацию, такую, как население и географические

координаты городов США, а также общие сведения о реках, горах и других

географических объектах.

Telnet: martini.eecs.umich.edu 3000

Пароль или имя пользователя не требуется. Введите название города,

почтовый (Zip) код или географическое свойство и нажмите enter. Эта система

не любит сокращенных названий (например, Mt. McKinley), так что пишите их

полностью (например, Mount McKinley).

Введя название города или сокращенный почтовый код, можно узнать

графство, в котором он расположен, полный почтовый код, а также долготу и

широту. В базу данных включены еще не все географические свойства.

Животные

См. "Здоровье".

Законодательство по авторским правам

См. Конгресс.

Здоровье

Управление США по пищевым продуктам и лекарствам (The U.S. Food and

Drug Administration) ведет базу данных по информации, относящейся к

вопросам здравоохранения.

Telnet: fdabbs.fda.gov

Регистрация: bbs

У вас спросят имя и пароль, который вы хотите закрепить за собой на

будущее. После этого введите

topics

и нажмите enter. Вы увидите такой экран:

TOPICS DESCRIPTION

* NEWS News releases

* ENFORCE Enforcement Report

* APPROVALS Drug and Device Product Approvals list

* CDRH Centers for Devices and Radiological Health Bulletins

* BULLETIN Text from Drug Bulletin

* AIDS Current Information on AIDS

* CONSUMER FDA Consumer magazine index and selected articles

* SUBJ-REG FDA Federal Register Summaries by Subject

* ANSWERS Summaries of FDA information

* INDEX Index of News Releases and Answers

* DATE-REG FDA Federal Register Summaries by Publication Date

* CONGRESS Text of Testimony at FDA Congressional Hearings

* SPEECH Speeches Given by FDA Commissioner and Deputy

* VETNEWS Veterinary Medicine News

* MEETINGS Upcoming FDA Meetings

* IMPORT Import Alerts

* MANUAL On-Line User's Manual

────────────────────────────────────────────────────────────────────────────

ТЕМЫ ОПИСАНИЯ

* NEWS Выпуски новостей

* ENFORCE Отчет о вступлении в силу новых законов

* APPROVALS Список утверждения лекарств и пищевых продуктов

* CDRH Центры для проектов и бюллетеней радиологического здраво-

охранения

* BULLETIN Тексты из Бюллетеня лекарств

* AIDS Текущая информация по СПИД

* CONSUMER Указатель и избранные статьи журнала потребителей FDA

* SUBJ-REG Сводки федерального регистра FDA по темам

* ANSWERS Сводки по информации FDA

* INDEX Указатель новых выпусков и ответов

* DATE-REG Сводки федерального регистра FDA по датам публикации

* CONGRESS Тексты свидетельств на слушаниях FDA

* SPEECH Речи уполномоченных и депутатов FDA

* VETNEWS Новости ветеринарии

* MEETINGS Предстоящие заседания FDA

* IMPORT Предостережения относительно импорта

* MANUAL Руководство пользователя

────────────────────────────────────────────────────────────────────────────

Произвести поиск в указанных темах можно по ключевым словам или

хронологически. Однако может оказаться неплохой идеей сначала скопировать

себе текст руководства, поскольку система выполняет поиск несколько

странным образом. Для переписывания копии введите

manual

и нажмите enter. Потом введите

scan

и нажмите enter. Вы увидите:

FOR LIST OF AVAILABLE TOPICS TYPE TOPICS

OR ENTER THE TOPIC YOU DESIRE ==>

MANUAL

BBSUSER

08-OCT-91

1 BBS User Manual

────────────────────────────────────────────────────────────────────────────

ДЛЯ ПОЛУЧЕНИЯ СПИСКА ТЕМ ВВЕДИТЕ TOPICS

ИЛИ ВВЕДИТЕ ЖЕЛАТЕЛЬНУЮ ТЕМУ==>

РУКОВОДСТВО

ПОЛЬЗОВАТЕЛЯ BBS

08-10-91

1 BBS Руководство Пользователя

────────────────────────────────────────────────────────────────────────────

В этот момент следует активизировать функцию перехвата экрана или

протоколирования на своем компьютере и нажать клавишу 1, а потом enter.

Руководство начнет прокручиваться на экране вашего компьютера порциями

по 24 строки.

Информация по лыжному спорту

См. Погода.

Информация по найму и программам колледжей

Федеральная Служба Обмена Информацией (The Federal Information

Exchange) в Гэйтесбурге, штат Мэриленд, ведет две системы с одним и тем же

адресом: FEDIX и MOLIS. FEDIX предлагает информацию по исследованиям,

школьному образованию и работе от нескольких федеральных ведомств, в том

числе NASA, Министерства Энергетики и федеральной администрации авиации.

Еще несколько федеральных ведомств предоставляют информацию по работе и

образованию для меньшинств. MOLIS предоставляет информацию о колледжах для

меньшинств, их программах и преподавателях.

Telnet: fedix.fie.com

User name: fedix (федеральная база данных по найму) или

molis (система колледжей для меньшинств)

Обе системы используют для доступа к информации простые меню.

История

Стэнфордский Университет ведет базу данных по документам, имеющим

отношение к Мартину Лютеру Кингу.

Telnet: forsythetn.stanford.edu

Раздел: socrates

В главном меню введите

select mlk

и нажмите enter.

Калькуляторы

Фирма Hewlett-Packard содержит бесплатную службу, через которую можно

попросить совета по калькуляторам этой фирмы.

Telnet: hpcvbbs.cv.hp.com

Регистрация в системе не нужна.

Конгресс

Информационная служба Библиотеки Конгресса дает возможность произвести

поиск среди текущих и прошлых законодательных актов (вплоть до 1982 года).

Telnet: locis.loc.gov

Пароль: не нужен.

После соединения вам будет предложено главное меню, из которого можно

выбрать несколько баз данных, в том числе карточный каталог Библиотеки

Конгресса (с изданиями до 1978 года) и базу данных с информацией по законам

об авторских правах.

Для доступа к базе данных с информацией по работе Конгресса выберите

номер, проставленный рядом с ней, и нажмите enter. Вам будет задан вопрос,

за какой законодательный год вести поиск. После чего на экран будет

выведено меню, подобное приводимому ниже:

***C103- THE LEGISLATIVE INFORMATION FILE FOR THE 103RD CONGRESS,

which was updated on 05/10/93 and contains 4,044 records,

is now available for your search.

CURRENCY: All information is NOT current through the above date, which is

machine generated when ANY information is added to the file.

Bill numbers, official titles, sponsors, and status (STEP) added

within 48 hours. Indexing terms and digests added later, in

some cases several weeks after the bill is added to the file.

TO START RETRIEVE to find: EXAMPLES:

SEARCH: member name --------------> retrieve rep gingrich

retrieve sen kennedy

bill number --------------> retrieve h.r. 1

subject keywords ---------> retrieve day care

FOR HELP: Type the word HELP and press the ENTER key.

READY FOR NEW COMMAND:

────────────────────────────────────────────────────────────────────────────

***C103- ФАЙЛ С ИНФОРМАЦИЕЙ ПО ЗАКОНОДАТЕЛЬНЫМ РЕШЕНИЯМ 103-ГО КОНГРЕССА,

обновленный 10/5/93 и содержащий 4044 записи, доступен

для поиска.

АКТУАЛЬНОСТЬ: НЕ вся информация актуальна по отношению к приведенной

дате, поскольку эта дата генерируется машиной при

добавлении ЛЮБОЙ информации к файлу. Номера биллей,

официальные названия, спонсоры и статус вносятся в

течение 48 часов. Позиции указателей и краткое

содержание добавляются иногда через несколько недель

после внесения билля в файл.

НАЧАЛО: ПРИМЕРЫ:

ПОИСК: имя члена Конгресса -------> retrieve rep gingrich

retrieve sen kennedy

номер билля ---------------> retrieve h.r. 1

ключевые слова ------------> retrieve day care

ДЛЯ ПОДСКАЗКИ: введите слово HELP и нажмите клавишу ENTER.

ГОТОВ К ПРИЕМУ НОВОЙ КОМАНДЫ:

────────────────────────────────────────────────────────────────────────────

Космос

Система NASA Spacelink в Хантсвилле, штат Алабама, дает доступ к

докладам и данным всех видов по NASA, ее истории и различных задачах,

прошлых и настоящих. Вы найдете там подробные отчеты о каждом отдельном

зонде, спутнике и запуске, когда-либо произведенном NASA, а также

ежедневные уточнения и планы уроков для учителей.

Система поддерживает большую библиотеку файлов формата GIF с

графическими изображениями, но их нельзя выгружать с помощью telnet. Если

они вам нужны, вам придется связаться с системой напрямую по телефону (205)

895-0028.

Telnet: spacelink.msfc.nasa.gov

После соединения вы получите краткий обзор системы и приглашение

зарегистрироваться и выбрать пароль.

База экстрагалактических данных (NED-NASA/IPAC Extragalactic Database)

содержит данные более чем о 100000 галактиках, квазарах и других объектах

за пределами Млечного пути.

Telnet: ipac.caltech.edu.

Регистрация: ned

Вы можете узнать больше, чем вам когда-либо хотелось о квазарах, новых

и тому подобных объектах с помощью системы, ведомой Смитсоновской

Астрофизической обсерваторией в Кембридже, штат Массачусетс.

Telnet: cfa204.harvard.edu

Log in: einline

Физический факультет университета Массачусетса в Амхерсте ведет

систему доски объявлений (BBS), предлагающую широкую сеть конференций и

библиотек документов, относящихся к космосу.

Telnet: spacemet.phast.umass.edu

Регистрация с собственным именем и паролем.

Окружающая среда

Envirolink - это большая база данных и система конференций по вопросам

окружающей среды. Базируется в Питтсбурге.

Telnet: envirolink.org

Регистрация: gopher

Ведомство США по охране окружающей среды (U.S. Environmental

Protection Agency) ведет оперативные базы данных материалов, относящихся к

рискованным промышленным выбросам, программе очистки Великих Озер и усилиям

по очистке окружающей среды в Новой Англии. Ведомство планирует возможное

включение работ по очистке среды и в других регионах. База данных фактически

представляет собой компьютеризованный карточный каталог документов EPA --

эти документы можно просматривать, но чтобы их увидеть, все же надо

посетить местное представительство EPA.

Telnet: epaibm.rtpnc.epa.gov

Пароль или имя пользователя не требуются. В главном

меню введите:

public

и нажмите enter (Перечислены и другие возможности, но они предназначены

только для служащих EPA). Вы увидите однострочечное меню. Введите:

ols

и нажмите enter, после чего вы увидите нечто подобное следующему:

NET-106 Logon to TSO04 in progress.

DATABASES:

N NATIONAL CATALOG CH CHEMICAL COLL. SYSTEM

H HAZARDOUS WASTE 1 REGION I

L CLEAN LAKES

OTHER OPTIONS:

? HELP

Q QUIT

ENTER SELECTION -->

────────────────────────────────────────────────────────────────────────────

NET-106 Logon to TSO04 в процессе.

БАЗЫ ДАННЫХ

N НАЦИОНАЛЬНЫЙ КАТАЛОГ CH СИСТЕМА ХИМ. СБОРА

H ОПАСНЫЕ ВЫБРОСЫ 1 РЕГИОН I

L ОЧИСТКА ОЗЕР

ДРУГИЕ ВОЗМОЖНОСТИ:

? ПОМОЩЬ

Q ВЫХОД

ВВЕДИТЕ ВЫБОР-->

────────────────────────────────────────────────────────────────────────────

Выберите возможность, и вы получите меню, которое позволит выполнить

поиск документа по заглавию, ключевому слову, году публикации или компании.

После ввода слова для поиска и нажатия клавиши enter вам будет сообщено,

сколько найдено подходящих позиций. Нажмите клавишу 1 и enter для просмотра

списка позиций. Для просмотра библиографической справки по каждой

конкретной позиции нажмите V и enter, а затем введите номер записи.

Университет Мичигана ведет базу данных газетных и журнальных статей,

относящихся к окружающей среде, в особенности штата Мичиган, восходящих к

1980-му году.

Telnet: hermes.merit.edu

Host: mirlyn

Log in: meem

Погода

Факультет метеорологии, океанографии и космологии Мичиганского

университета (The University of Michigan's Department of Atmospheric,

Oceanographic and Space Sciences) предоставляет прогнозы погоды для городов

США и других стран, а также отчеты о лыжном спорте и ураганах.

Telnet: madlab.sprl.umich.edu 3000 (обратите внимание на 3000).

Регистрационное имя не нужно.

См. также рубрику Weather (Погода) в списке FTP для информации о

загрузке спутниковых и радарных карт погоды.

Правительственная информация

Национальная служба технической информации ведет систему, которая не

только предоставляет огромный набор федеральных документов всех сортов - от

докладов по окружающей среде до тезисов патентов - но служит шлюзом к

десяткам других федеральных информационных систем.

Telnet: fedworld.gov

Имя при регистрации: new

См. также рубрики Конгресс и Текущие события

Радиолюбительство

Национальный Справочник Радиолюбительских Позывных (The National Ham

Radio Call-Sign Callbook) дает возможность разыскать американского

радиолюбителя по позывным, городу, фамилии или почтовому коду. Успешный

поиск возвращает имя радиолюбителя, его адрес, позывные, возраст, тип

лицензии и время ее выдачи.

Telnet: callsign.cs.buffalo.edu 2000 или ham.njit.edu 2000.

После соединения вы сообщаете системе, что вы хотите просмотреть и что при

этом искать. Например, если вам хочется найти радиолюбителей в каком-то

определенном городе, введите:

city название города

и нажмите enter (например: city Kankakee).

Другие возможности поиска - "call" (вызов) (после этого вводится

позывной радиолюбителя), "name," (имя) и "zip" (почтовый код, который здесь

вводится). При поиске радиолюбителя в большом городе следует действовать

осторожно; вывод списка может практически никогда не кончиться, если его

не прервать клавишами control-]. В противном случае по окончании работы

введите

quit

и нажмите enter для прекращения соединения.

Разговор

Канадское правительственное агентство Communications Canada

разрабатывает систему "Гипертекстовая технология разговорного доступа"

(Conversational Hypertext Access Technology - CHAT). Это система

предназначена для обеспечения простого доступа к базам данных людям,

имеющим мало опыта в общении с компьютером или не имеющим такового вообще.

В системе используются так называемые гипертекстовые связи. Пользователи не

указывают шифров команд, а задают вопросы на английском языке.

Telnet: debra.doc.ca

Log in: chat

Вы может выбрать одну из доступных сейчас баз данных, например, со

сведениями по СПИД (AIDS), и задать вопрос на английском языке.

Спросите базу данных AIDS: "When was AIDS first discovered?" (Когда

был впервые открыт СПИД), и она ответит:

"The first case of AIDS in North America was diagnosed in 1979. Before

that, it existed in Africa, probably beginning in the 1950's. AIDS was

discovered in North America when a number of young men with a history of

homosexuality developed a rare type of cancer called Kaposi's sarcoma."

────────────────────────────────────────────────────────────────────────────

"Первый случай СПИД в Северной Америке был диагностирован в 1979 году. До

того он существовал в Африке, возможно, с 1950 года. СПИД был открыт в

Северной Америке, когда у нескольких молодых людей с продолжительными

гомосексуальными связями развился рак редкого типа - так называемая саркома

Капоши."

────────────────────────────────────────────────────────────────────────────

Иногда может оказаться необходимым перефразировать вопрос. Например, в

ответ на вопрос "What is the link between AIDS and drug use?" (Какова связь

между СПИД и употреблением наркотиков?) компьютер ответит:

"I know two things about drugs: the drugs that are used to treat people

with AIDS, and the risks that drug users have in getting AIDS. Please ask

about treatments or drug users."

────────────────────────────────────────────────────────────────────────────

"О наркотиках я знаю две вещи: они используются для лечения больных

СПИД, и наркоманы входят в группу риска по СПИД. Пожалуйста, спросите о

лечении или о наркоманах."

────────────────────────────────────────────────────────────────────────────

Решения верховного суда

Информационная база данных Мэрилендского университета (The University

of Maryland Info Database) отслеживает решения Верховного суда США с 1991

года.

Telnet: info.umd.edu

Выберите тип терминала и нажмите enter (или просто нажмите enter, если

вы работаете с VT100). В главном меню выберите номер рядом с "Educational

Resources" (Ресурсы образования) и нажмите enter. Одним из пунктов выбора

будет "United States" (США). Выберите этот номер, а затем выберите номер

рядом с "Supreme Court" (Верховный суд).

Сельское хозяйство

PENPages, которую ведет Колледж агрономии университета штата

Пенсильвания, предлагает еженедельный обзор погоды, состояния сельского

хозяйства в мире от Департамента сельского хозяйства США. В этих обзорах

указывается все - от влияния погодных условий на произрастание пальм в

Малайзии до состояния всходов пшеницы в Украине. Доклады официальных лиц

штата Пенсильвания содержат предложения по улучшению жизни на фермах. В

одной из баз данных перечисляются торговцы сеном штата Пенсильвания и

оценивается качество их сена!

Эта служба дает возможность поиска информации различными способами.

Система меню предоставляет оперативный доступ к отчетам, которые быстро

меняются, таким, как отчеты о погоде в мире. Система указателей позволяет

провести поиск среди нескольких тысяч документов по ключевым словам. В

главном же меню можно просмотреть руководство или выбрать "PENPages", что

выводит пользователя на подсистему сельского хозяйства.

Telnet: psupen.psu.edu

User name: Двухбуквенный код штата или WORLD

Сеть Современной Технологической Информации (Advanced Technology

Information Network) университета штата Калифорния предоставляет такую же

информацию, как и PENPages, но относящуюся в основном к посевам в

Калифорнии. Она также ведет список предстоящих в Калифорнии ярмарок и

следит за новостями биотехнологии.

Telnet: caticsuf.cati.csufresno.edu

Log in: public

Вас попросят зарегистрироваться и присвоят вам имя пользователя и

пароль. Для доступа к сельскохозяйственной информации введите "a" в

главном меню. Для вызова меню, содержащего отчет о новостях биотехнологии

за две недели, введите "d".

СПИД

Университет Майами ведет базу данных о тех, кто занимается связанными

со СПИД проблемами здравоохранения в южной Флориде.

Telnet: callcat.med.miami.edu

Log in: library

В главном меню выберите P, и вам будет предоставлена возможность

просмотреть список врачей, больниц и других лиц и организаций, которые

занимаются лечением больных СПИД. Можно также провести поиск по медицинской

специальности.

См. также рубрики "Разговор" и "Здоровье"

Текущие события

ЦРУ каждый год публикует Книгу Фактов, которая, в сущности,

представляет собой альманах по всем странам и всемирным организациям,

включающий информацию по основной продукции стран, виду правительств и

именам их лидеров. Доступ к этой книге дает база данных Мэрилендского

Университета (University of Maryland Info Database).

Telnet: info.umd.edu

Выберите тип терминала и нажмите enter (или просто нажмите enter, если

вы работаете с VT100). Из главного меню выберите номер рядом с "Educational

Resources" (Ресурсы образования). Потом выберите номер рядом с

"International", за которым следует "Factbook." После этого можно провести

поиск по стране или организации.

Эта подсистема также ведет копию бюджета США, документы о

североамериканском соглашении о свободной торговле и прочих

правительственных программах. Для доступа к такой информации в меню

"Educational Resources" выберите номер рядом с "United States" и затем

номер рядом с "Government" (Правительство).

Служба доступа к информации по законодательству (Access Legislative

Information Service) дает возможность искать и просматривать билли

законодательного собрания Гавайев.

Telnet: access.uhcc.hawaii.edu

Транспорт

Система Навигатор по метро (The Subway Navigator) в Париже поможет вам

узнать, как добраться из точки А в точку Б в любом метрополитене земного

шара.

Telnet: metro.jussieu.fr 10000

Регистрация не нужна.

При соединении у вас спросят, на каком языке вести поиск (можно

выбрать английский или французский), а потом - в каком городе искать. У вас

спросят, с какой станции вы собираетесь выехать и на какую желаете

приехать.

Химия

Электронная Периодическая Таблица Элементов рисует таблицу у вас на

экране и дает возможность просмотреть различные свойства отдельных

элементов.

Telnet: camms2.caos.kun.nl

Пароль не требуется

Telnet

Hytelnet при университете Саскатчевана представляет собой оперативное

руководство пользователя по тысячам подсистем telnet во всем мире.

Telnet: access.usask.ca

Регистрация: hytelnet

6.4 Системы досок объявлений Telnet (BBS)

Вы можете считать, что Usenet с его сотнями групп новостей вполне мог

бы удовлетворить самых требовательных клиентов в области диалоговых

телекоммуникаций.

Но существует множество систем "досок объявлений" и других систем,

которые предоставляют еще больше конференций и других услуг, и многие из

них нельзя найти непосредственно в Сети. Некоторые из них бесплатны, в

других надо платить за доступ. В это число входят:

Bookstacks Unlimited - Книжная лавка в Кливленде, использующая

Internet для объявления о своих услугах. В ее диалоговую систему входит,

однако, не только каталог, но и конференции по книгам и литературе вообще.

Telnet: books.com

Вход под своим именем с выбором пароля для связи в дальнейшем.

Cimarron. Ведется Техническим Институтом (Instituto Technical) в

Монтерее, Мехико. В эту

систему входят испаноязычные конференции, но с английскими командами, как

можно видеть из предлагаемого ниже меню доступных конференций:

Список конференций

Name Заглавие

General Основная

Dudas Dudas de Cimarron

Comentarios Comentarios al SYSOP

Musica Para los afinados........

Libros El sano arte de leer.....

Sistemas Sistemas Operativos en General.

Virus Su peor enemigo......

Cultural Espacio Cultural de Cimarron

NeXT El Mundo de NeXT

Ciencias Solo apto para Nerds.

Inspiracion Para los Romanticos e Inspirados.

Deportes Discusiones Deportivas

Чтобы получить право оставлять сообщения и право доступа к файлам,

необходимо оставить записку для SYSOP (System Operator - системный оператор)

со своим именем, адресом, родом

занятий и телефонным номером. Для этого в ответ на любое приглашение

нажмите клавишу M, а затем клавишу enter, что вызовет систему почты.

Нажатие клавиши H вызовет список команд с пояснением того, как их

использовать.

Telnet: bugs.mty.itesm.mx (только с 8 вечера to 10 утра, Восточное время)

В ответ на "login:" введите

bbs

и нажмите enter.

Cleveland Free-Net. Первая из серии бесплатных сетей, представляющая

собой честолюбивую попытку сделать Сеть общедоступной. Изначально -

внутрибольничная вспомогательная сеть, сейчас поддерживается университетом

Case Western Reserve University, городом Кливлендом, штатом Огайо и фирмой

IBM. В ней используются простые меню, подобные меню CompuServe, но

организованные в виде структуры города:

<<< CLEVELAND FREE-NET DIRECTORY >>>

1 The Administration Building

2 The Post Office

3 Public Square

4 The Courthouse & Government Center

5 The Arts Building

6 Science and Technology Center

7 The Medical Arts Building

8 The Schoolhouse (Academy One)

9 The Community Center & Recreation Area

10 The Business and Industrial Park

11 The Library

12 University Circle

13 The Teleport

14 The Communications Center

15 NPTN/USA TODAY HEADLINE NEWS

------------------------------------------------

h=Help, x=Exit Free-Net, "go help"=extended help

Your Choice ==>

────────────────────────────────────────────────────────────────────────────

<<< ДИРЕКТОРИЯ FREE-NET КЛИВЛЕНДА>>>

1 Административное здание

2 Почта

3 Городская площадь

4 Суд и административный центр

5 Центр Искусств

6 Центр науки и технологии

7 Медицинский центр

8 Школьное здание (Академия один)

9 Общественный центр и зона отдыха

10 Деловой и промышленный районы

11 Библиотека

12 Университетский городок

13 Телепорт

14 Центр коммуникаций

15 Международные/США Заголовки новостей

------------------------------------------------

h=Подсказка, x=Выход из Free-Net, "go help"=расширенная подсказка

Ваш выбор==>

────────────────────────────────────────────────────────────────────────────

Система содержит огромное и все возрастающее количество общедоступных

документов, от копий решений верховного суда США и штата Огайо до Великой

Хартии Вольностей и Конституции США. Она дает возможность связаться с

различными правительственными ведомствами и содержит ежедневные сведения из

USA Today (США Сегодня). Кроме Usenet (который находится в области Teleport) она

содержит большой набор конференций на любые темы - от домашних животных и до

политики. И конечно, она бесплатная!

Telnet: freenet-in-a.cwru.edu или

freenet-in-b.cwru.edu или

freenet-in-c.cwru.edu

При использовании связи с Free-Net можно просмотреть систему. Однако

для того, чтобы посылать сообщения на ее конференции или использовать

электронную почту, следует письменно запросить для себя адрес. Информация

об этом доступна в момент соединения.

DUBBS. Это система электронной доски объявлений в Дельфте в

Нидерландах. Конференции и файлы по большей части пишутся на голландском

языке, но файлы с подсказками и сами команды написаны на английском.

Telnet: tudrwa.tudelft.nl

ISCA BBS. Ведется студенческой ассоциацией по компьютерам в Айове,

содержит более 100 конференций, в том числе несколько на иностранных

языках. После регистрации в системе нажмите K для вывода списка (необходимо

будет ввести название конференции, а не номер при нем). Нажатием клавиши H

вызывается информация о командах.

Telnet bbs.isca.uiowa.edu

В ответ на "login:" введите

bbs

и нажмите enter.

Youngstown Free-Net. Создатели Cleveland Free-Net продают свое

программное обеспечение за 1 доллар всем желающим создать подобную систему.

Поэтому многие города сейчас имеют собственные бесплатные сети, в том числе

город Янгстаун, штат Огайо.

Telnet: yfn.ysu.edu

В ответ на запрос "login:" введите

visitor

и нажмите enter.

6.5 Как "указать пальцем" на кого-нибудь

Finger (палец) - это удобная маленькая программа, которая позволяет

узнать побольше о людях из Сети -- и рассказать им побольше о себе.

Finger использует те же понятия, что и telnet или ftp. Но он работает

только с одним файлом, имеющим имя .plan (именно так, точка перед именем).

Это текстовый файл, который создается пользователем Internet в своей

домашней директории. Туда можно поместить свой телефонный номер, рассказать

о себе или вообще написать все, что угодно.

Чтобы с помощью программы Finger указать на чей-то чужой файл .plan,

введите в командной строке:

finger электронный адрес

Электронный адрес - это адрес электронной почты человека. На экране вы

получите информацию о том, когда этот человек последний раз был на связи,

получил ли он с того времени новую почту, а также то, что написано в его

файле .plan (если он не пуст).

Некоторые лица и организации подходят к использованию файла .plan

творчески, позволяя делать почти все - от узнавания погоды в Массачусетсе

до передачи результатов последних бейсбольных встреч. Попробуйте

обратиться программой Finger к следующим электронным адресам:

weather@cirrus.mit.edu Национальная служба погоды, прогнозы по

различным регионам Массачусетса

quake@geophys.washington.edu Эпицентры и магнитуды землетрясений в

мире

jtchern@ocf.berkeley.edu Положение в высшей лиге бейсбола и

результаты игр прошедшего дня

nasanews@space.mit.edu События текущего дня в NASA

coke@cs.cmu.edu Посмотреть, сколько банок газировки

каждого вида осталось в конкретном

автомате, установленном на факультете

кибернетики университета

Карнегги-Меллона

6.6 Как найти человека в сети

Итак, у вас есть друг, и вы хотите узнать, есть ли у этого друга адрес

в Internet, на который можно написать? Проще всего снять трубку, набрать

номер и спросить его самого. Хотя есть много различных служб типа

телефонных справочников, к которым можно добраться через Internet, их

информация далеко не полна - студенты колледжей, пользователи коммерческих

служб таких, как CompuServe и многих других общедоступных подсистем

Internet, и множество других категорий пользователей в эти справочники

просто не вносятся. Основные организаторы электронной почты работают с

универсальной системой директорий, но это может занять достаточно много

времени.

В то же время некоторые службы "телефонных справочников" могут дать

некоторые указания или дать просто позабавиться, читая списки знаменитостей

или давно забытых знакомых.

Директория whois (кто такой) сообщает имена, адреса электронной почты,

а часто - и номера телефонов внесенных в нее лиц. Чтобы ею воспользоваться,

свяжитесь по telnet с:

internic.net

Регистрация не нужна. Простейший способ использования этой директории -

ввести

whois имя

"имя", вводимое в ответ на приглашение - это фамилия лица или название

организации, которую вы ищете.

Стоит испробовать еще одну службу, тем более что она, похоже,

доставляет начинающим меньше проблем. Это - Knowbot Information Service, к

которой можно обратиться по telnet:

info.cnri.reston.va.us 185

Регистрация опять-таки не нужна. Эта служба в действительности

просматривает множество подсистем "телефонных справочников", в том числе

каталог пользователей MCIMail. Чтобы найти конкретного человека, введите

query имя

где "имя" - фамилия человека, которого вы ищете. Подробную информацию по

другим командам можно получить, введя знак вопроса в ответ на приглашение.

Этой системой можно воспользоваться и по электронной почте. Пошлите

сообщение по адресу

netaddress@info.cnri.reston.va.us

Строку "subject:" можно оставить пустой. В качестве текста сообщения

пошлите

query имя

Это будет поиск простейшего типа. Если вам нужны детали или более сложный

поиск, добавьте еще одну строку:

man

Другой путь поиска - через сервер имен Usenet. Это система, с помощью

которой MIT (Массачусетский Институт Технологии) ведет учет электронных

адресов всех, кто когда либо посылал сообщения в MIT с помощью Usenet. Она

работает по электронной почте. Пошлите сообщение по адресу

mail-server@rtfm.mit.edu

Строку "subject:" оставьте пустой. В качестве текста сообщения укажите

send usenet-addresses/фамилия

где "фамилия" - фамилия человека, которого вы ищете.

6.7 Когда что-то не так

∙ При попытке связаться с подсистемой telnet ничего не происходит.

Подсистема может быть остановлена для обслуживания или устранения

неисправностей

∙ Вы получили сообщение "host unavailable". Подсистема telnet зачем-то

отключена.

Попробуйте еще раз позже.

∙ Получено сообщение "host unknown".

Проверьте правильность написания имени подсистемы.

∙ Вы ввели пароль для подсистемы telnet, требующей пароля, и

получили сообщение "login incorrect".

Попробуйте снова. Если снова получено то же сообщение, нажмите клавиши

control и ] одновременно для отсоединения и возврата в собственную

операционную систему.

∙ Не удается отсоединиться от подсистемы telnet.

Нажмите клавиши control и ] одновременно для отсоединения и возврата в

собственную местную систему.

6.8 Куда обратиться с вопросами

Группы новостей alt.internet.services и alt.bbs.internet сети Usenet

могут дать указания к новым системам telnet. Скотт Янофф (Scott Yanoff)

помещает в первой из них свой "Updated Internet Services List" (Обновленный

список подсистем Internet). В группе alt.bbs.internet newsgroup можно

также найти подборку часто задаваемых вопросов по системам досок объявлений

(BBS) Internet.

Питер Скотт (Peter Scott), ведущий базу данных Hytelnet database,

поддерживает список рассылки, посвященный новым службам telnet и изменениям

в существующих. Чтобы получить доступ к этому списку, пошлите ему сообщение

по адресу scott@sklib.usask.ca.

Глисон Сэкмэн (Gleason Sackman) ведет другой список рассылки,

посвященный новым службам Internet и сообщениям о новых использованиях

Сети. Чтобы подписаться на этот список, пошлите сообщение по адресу

listserv@internic.net. Строку "subject:" оставьте пустой, а в качестве

текста сообщения укажите: Sub net-happenings Свое имя.

Глава 7: ПРОТОКОЛ ПЕРЕСЫЛКИ ФАЙЛОВ (FTP)

7.1 Тонны файлов

Сотни соединенных с Internet систем имеют библиотеки или архивы

файлов, открытые для всеобщего доступа. Из них большинство состоит из

дешевых общедоступных программ для стандартных работ на компьютере. Если

вам захотелось завести новую коммуникационную программу для вашей IBM или

захотелось поиграть в новую игрушку на собственной Amiga, и то, и другое

можно снять с Internet.

Но существуют и библиотеки документов. Если вам нужны копии

последних постановлений Верховного Суда США, их можно найти в Internet.

Можете запросить и получить копии исторических документов, от Великой

Хартии до Декларации Независимости, или переводы телеграмм, в которых Ленин

требовал расстрела восставших крестьян. Можете найти песенную лирику,

стихи, и даже сжатое изложение всех сюжетов из серии "Затерянные в

Космосе". Также к вашим услугам файлы с исчерпывающей информацией по любым

вопросам, связанных с самим Internet. Прежде всего мы посмотрим, как

добраться до этих файлов, то есть покажем вам, где они находятся.

Наиболее употребительный способ достать эти файлы состоит в

использовании протокола пересылки файлов (File Transfer Protocol - ftp).

Как и при работе с telnet, не все системы, соединенные с Сетью, имеют

доступ к ftp. Однако если ваша система входит в это число, то любой из

этих файлов вы можете получить по электронной почте (см. следующую главу).

Запустить ftp так же просто, как и использовать telnet. В ответ на

приглашение местной системы введите

ftp система.имя

и нажмите enter. Здесь "система.имя" означает адрес подсистемы ftp, к которой

желательно получить доступ. Одно из основных различий между telnet и ftp

состоит в том, что соединение с подсистемами ftp в рабочие часы (обычно от

шести утра и до шести вечера по местному времени) считается дурным тоном.

Это связано с тем, что пересылка файлов по сети занимает приличную часть

ресурсов компьютера, которые в дневное время наверняка понадобятся на более

важную работу. Тем не менее существуют системы ftp, открытые для доступа 24

часа в сутки. Это отмечено в списке подсистем ftp в разделе 7.6.

7.2 Ваш друг Archie

А как найти нужный файл?

Еще несколько лет назад это была жуткая головная боль - не было общего

каталога, из которого можно было бы узнать, где в Сети хранится нужный

файл. У кого хватило бы терпения в поисках чего бы то ни было перерыть

сотни библиотек?

Аллен Эмтэйдж (Alan Emtage), Билл Хилан (Bill Heelan) и Питер Дейч

(Peter Deutsch), студенты университета Мак-Гилла в Монреале (McGill

University), задались тем же вопросом. Но они дали на него некоторый

ответ.

Они создали базу данных по имени archie, периодически обращающуюся

к библиотекам файлов и смотрящую, к чему они предлагают доступ. В свою

очередь, каждый может обратиться к archie, ввести с клавиатуры имя файла и

посмотреть, откуда из Сети можно его взять.

Сейчас archie ведет каталог примерно 1000 библиотек файлов по всему

миру. В настоящее время есть три способа попросить archie найти для вас

файл: через telnet, через "клиент-программу" archie на вашем собственном

компьютере и по электронной почте. Все три способа позволяют задать

частичное или полное имя файла и узнать, где он хранится в Сети.

Если у вас есть доступ к telnet, то можно обратиться к одному из

следующих адресов: archie.mcgill.ca; archie.sura.net; archie.unl.edu;

archie.ans.net; или archie.rutgers.edu. Если будет запрос регистрационного

имени, введите

archie

и нажмите enter.

После установления связи ключевой командой будет prog, которая

употребляется в такой форме:

prog имя_файла

затем enter, где "имя_файла" - программа или файл, которые вы ищете. Если

вам неизвестно точное имя файла, попробуйте ввести его часть. Например,

"PKZIP" сработает не хуже, чем "PKZIP204.EXE." Система не поддерживает

символы-"джокеры" DOS или Unix. Если вы попросите archie поискать "PKZIP*",

он ответит, что ничего подобного найти не может. Следует помнить одну

вещь: файл - это не обязательно программа, это может быть и документ. Это

означает, что можно использовать archie для поиска, например, всего, что

относится к Битлз, точно также как и любых программ и графических файлов.

Некоторые из подсистем Сети имеют теперь собственные программы

archie, принимающие ваш запрос и передающие его в ближайшую базу данных

archie - спросите у своего системного администратора, есть ли у вас такая

программа. Эти программы-"клиенты" поставляют информацию куда быстрее, чем

сама программа archie! Если таковая у вас есть, введите в командной строке

своей операционной системы:

archie -s имя_файла

где имя_файла - программа или документ, которые вы ищете, и нажмите enter.

Ключ -s дает программе указание не различать большие и малые буквы в имени

файла и позволяет искать файл по неполному имени. Таким образом, вы можете

ввести:

archie -s имя_файла|more

что позволяет вести вывод найденной информации постранично (удобно тогда,

когда искомый файл содержится во многих подсистемах). Можно также открыть

файл на компьютере с помощью функции регистрации выводимого на экран

текста.

Третий путь, для людей, которым недоступны оба описанных выше -

электронная почта.

Пошлите сообщение по адресу archie@quiche.cs.mcgill.ca. Строку subject

можно оставить пустой. Внутри сообщения введите:

prog имя_файла

где имя_файла - имя файла, который вы ищете. Можно попросить archie поискать

несколько программ, имена которых задаются в той же команде "prog",

например:

prog file1 file2 file3

В течение нескольких часов archie вернет список соответствующих

подсистем. Во всех трех случаях, если существует система, содержащая ваш

файл, вы получите ответ вроде следующего:

Host sumex-aim.stanford.edu

Location: /info-mac/comm

FILE -rw-r--r-- 258256 Feb 15 17:07 zterm-09.hqx

Location: /info-mac/misc

FILE -rw-r--r-- 7490 Sep 12 1991 zterm-sys7-color-icons.hqx

────────────────────────────────────────────────────────────────────────────

Система sumex-aim.stanford.edu

Расположено: /info-mac/comm

ФАЙЛ -rw-r--r-- 258256 Feb 15 17:07 zterm-09.hqx

Расположено: /info-mac/misc

ФАЙЛ -rw-r--r-- 7490 Sep 12 1991 zterm-sys7-color-icons.hqx

────────────────────────────────────────────────────────────────────────────

Есть шансы, что вы получите для каждой программы список ответов

одинакового вида. "host" - это система, которая содержит файл. "Location"

сообщает, в какой директории его следует искать после соединения с системой. На

странные группы из букв r и тире пока не обращайте внимания. После них

указывается размер в байтах файла или директории, дата загрузки и имя

файла.

7.3 Прием файлов

А теперь можно принять файл.

Предположим, что имеющаяся у вас подсистема имеет ftp. Тогда вы можете

к ней подсоединиться как к telnet, введя:

ftp sumex-aim.stanford.edu

(или имя любой подсистемы, к которой вы хотите получить доступ). Нажмите

enter. Если соединение сработает, вы увидите следующее:

Connected to sumex-aim.stanford.edu.

220 SUMEX-AIM FTP server (Version 4.196 Mon Jan 13 13:52:23 PST 1992) ready.

Name (sumex-aim.stanford.edu:adamg):

────────────────────────────────────────────────────────────────────────────

Соединение с sumex-aim.stanford.edu.

220 SUMEX-AIM FTP сервер (Версия 4.196 Пон Янв 13 13:52:23 PST 1992) готов.

Имя (sumex-aim.stanford.edu:adamg):

────────────────────────────────────────────────────────────────────────────

Если в течение минуты ничего не произойдет, нажмите control-C для

возврата в свою местную систему. Если же соединение сработает, введите

anonymous

и нажмите enter. Вы увидите множество ссылок от Сети к "anonymous ftp"

(анонимный ftp). Дело в том, что вы не обязаны сообщать библиотечной

подсистеме свое имя. Причина этого заключается в том, что такие подсистемы

созданы для того, чтобы дать доступ любому к определенным общедоступным

файлам, оставляя в то же время возможность владельцам собственных учетных

разделов в подсистемах входить под своим именем и получать доступ к своим

персональным файлам. После этого следует запрос о пароле. В качестве пароля

укажите свой адрес электронной почты. После этого появится следующее:

230 Guest connection accepted. Restrictions apply.

Remote system type is UNIX.

Using binary mode to transfer files.

ftp>

────────────────────────────────────────────────────────────────────────────

230 Гостевая связь принята. Ограничения применены.

Система абонента - UNIX.

При передаче файлов используется двоичный режим.

────────────────────────────────────────────────────────────────────────────

Теперь введите

ls

и нажмите enter. Вы увидите что-то ужасное вроде:

200 PORT command successful.

150 Opening ASCII mode data connection for /bin/ls.

total 2636

-rw-rw-r-- 1 0 31 4444 Mar 3 11:34 README.POSTING

dr-xr-xr-x 2 0 1 512 Nov 8 11:06 bin

-rw-r--r-- 1 0 0 11030960 Apr 2 14:06 core

dr--r--r-- 2 0 1 512 Nov 8 11:06 etc

drwxrwsr-x 5 13 22 512 Mar 19 12:27 imap

drwxr-xr-x 25 1016 31 512 Apr 4 02:15 info-mac

drwxr-x--- 2 0 31 1024 Apr 5 15:38 pid

drwxrwsr-x 13 0 20 1024 Mar 27 14:03 pub

drwxr-xr-x 2 1077 20 512 Feb 6 1989 tmycin

226 Transfer complete.

ftp>

────────────────────────────────────────────────────────────────────────────

200 ПОРТ команда выполнена успешно.

150 Открыт режим ASCII связи для /bin/ls.

всего 2636

-rw-rw-r-- 1 0 31 4444 Mar 3 11:34 README.POSTING

dr-xr-xr-x 2 0 1 512 Nov 8 11:06 bin

-rw-r--r-- 1 0 0 11030960 Apr 2 14:06 core

dr--r--r-- 2 0 1 512 Nov 8 11:06 etc

drwxrwsr-x 5 13 22 512 Mar 19 12:27 imap

drwxr-xr-x 25 1016 31 512 Apr 4 02:15 info-mac

drwxr-x--- 2 0 31 1024 Apr 5 15:38 pid

drwxrwsr-x 13 0 20 1024 Mar 27 14:03 pub

drwxr-xr-x 2 1077 20 512 Feb 6 1989 tmycin

226 Передача завершена.

ftp>

────────────────────────────────────────────────────────────────────────────

Вот так! А теперь расшифруем этот Розеттский камень.

Прежде всего, ls - это команда ftp для вывода директории (можно

использовать просто dir, но если вы привыкли к MS-DOS, это может вызвать

путаницу при попытке использовать команду в своей собственной местной

системе, где она не сработает, так что лучше просто помнить, что в процессе

сеанса связи следует для вывода директорий использовать ls).

Самая первая буква каждой строки сообщает, относится данная строка к

директории или к файлу. Если первая буква "d" или "l", это директория,

иначе это файл.

Остальная часть этих зловещих строк из букв и черточек состоит из

флагов, сообщающих системе ftp, кто имеет право просматривать, изменять или

удалять эти файлы. Вы можете их смело игнорировать. Можете также

игнорировать все символы вплоть до конца строки, пока не наткнетесь на

второе число, то, что стоит перед датой. Это размер файла в байтах. Если

эта строка относится к директории, то по этому числу можно грубо судить о

числе позиций в директории - директория с листингом размером в 512 байт

относительно мала. Далее следует дата загрузки файла или директории, а после

нее (наконец-то!) имя файла.

Обратите внимание на файл README.POSTING в начале директории.

Большинство архивов содержат документ "read me" (прочти меня), который

обычно содержит некоторые основные сведения о подсистеме, ее ресурсах и

способах их использования. Давайте возьмем этот файл, как для получения из

него информации, так и для того, чтобы увидеть, как передаются файлы оттуда

сюда. В ответ на приглашение ftp> введите

get README

и нажмите enter. Заметим, что подсистемы ftp не отличаются в некоторых

общих чертах от подсистем Unix: они различают символы верхнего и нижнего

регистров. Вы увидите нечто вроде такого:

200 PORT command successful.

150 Opening BINARY mode data connection for README (4444 bytes).

226 Transfer complete. 4444 bytes received in 1.177seconds (3.8 Kbytes/s)

────────────────────────────────────────────────────────────────────────────

200 ПОРТ команда выполнена успешно.

150 Открытие соединения режима BINARY для передачи README (4444 байта).

226 Передача завершена. 4444 байта приняты за 1.177 секунд (3.8 Кбайт/сек)

────────────────────────────────────────────────────────────────────────────

Это оно и есть! Файл теперь расположен в вашей домашней директории вашей же

подсистемы, из которой вы можете выгрузить его в свой компьютер. Простая

команда "get" - это ключ к передаче файла из архивов в вашу подсистему.

Если вам нужно загрузить к себе больше одного файла за один раз

(например, серия документов), используется команда mget вместо get;

например:

mget *.txt

При такой передаче файлов копируется каждый файл из данной директории, имя

которого оканчивается на .txt. Перед копированием каждого файла у вас

запросят подтверждения, надо ли его копировать. Несмотря на это, mget может

сэкономить довольно много времени - нет необходимости вводить каждое имя

файла. Если вы хотите сэкономить еще больше времени, и уверены, что ВСЕ

заказанные файлы вам нужны, введите

prompt

до выполнения команды mget. Это отключит вывод приглашения и все файлы

будут введены прямо в вашу исходную директорию.

Следует помнить еще одну команду. Если вы хотите скопировать

компьютерную программу, введите:

bin

и нажмите enter. Это сообщит подсистеме ftp и вашей системе о том, что

пересылается двоичный файл, т.е. программа. Большинство подсистем ftp

используют двоичный формат по умолчанию, но неплохо на всякий случай

сообщить об этом, если вдруг вы связались с одной из тех немногих, для

которых это не так. Чтобы переключить директорию, введите

cd имя_директории

(здесь подставьте имя директории, к которой хотите получить доступ) и

нажмите enter. Введите

ls

и нажмите enter для получения листинга файлов данной конкретной директории.

Чтобы сдвинуться по дереву директорий вверх, введите

cd ..

(Обратите внимание, что между буквой d и первой точкой стоит пробел) и

нажмите enter. Или введите

cdup

и нажмите enter. Продолжайте так до тех пор, пока не дойдете до

интересующей вас директории. Иначе, если вы уже знаете путь к директории,

которая вам нужна (от нашего друга archie), просто введите после соединения

get директория/субдиректория/имя_файла

На многих подсистемах файлы, предназначенные для общего пользования,

расположены в директориях pub или public; иногда существует директория

info.

Почти каждая подсистема имеет директорию bin, которая на первый взгляд

может показаться кладовой (англ. bin - кладовая), где может лежать что-то

интересное. На самом же деле это означает "binary" (двоичный) и просто

представляет собой место, где системный администратор держит программы,

обеспечивающие работу системы ftp. Lost+found - другая директория, которая

может показаться интересной, но и она ничего достойного общественного

интереса не содержит.

Выше мы видели, как использовать archie. Из нашего примера видно, что

некоторые системные администраторы именуют файлы довольно неразумным

образом. К счастью, у вас есть способ переименовать файл в процессе

передачи. В том же примере работы с archie можно ввести:

get zterm-sys7-color-icons.hqx zterm.hqx

и нажать enter. Вместо того, чтобы всегда иметь дело с файлом по имени

zterm-sys7-color-icons.hqx, вы теперь имеете файл с простым именем

zterm.hqx. Последние три буквы дают нам еще нечто: Многие программы

подвергаются сжатию для сокращения времени передачи и экономии места. Чтобы

их потом использовать, следует их сначала развернуть соответствующей

программой декомпрессии.

7.4 Дополнительные буквы ── указатели метода раскодировки файла

Для сжатия файлов используется много разных методов. Сказать, какой

метод используется при передаче файла, можно по последней букве или

последней тройке букв имени файла. Здесь перечисляются наиболее

употребительные из них и указывается, что следует сделать, чтобы развернуть

файл, созданный таким методом. (Большинство программ декодирования файла

можно найти с помощью archie).

.txt или .TXT Означает что файл является документом, а не программой.

.ps или .PS Документ PostScript (на языке описания страниц Adobe). Такой

файл можно распечатать на любом принтере с возможностью

PostScript или использовать программу просмотра вроде

GhostScript из проекта GNU.

.doc или .DOC Еще одно общепринятое "расширение" для документов.

Декомпрессия не нужна, если за именем не следует:

.Z Это метод сжатия Unix. Для развертки файла введите

uncompress имяфайла.Z

и нажмите enter в командной строке своей системы. Если файл

представляет собой сжатый текст, его можно прочитать

интерактивно, введя:

zcat имя_файла.txt.Z |more

Программа u16.zip является программой MS-DOS, позволяющей

загрузить такой файл и развернуть его в своем компьютере.

Аналогичная программа для Macintosh называется MacCompress

(найдите ее с помощью archie).

.zip или .ZIP Это означает, что файл скомпрессирован обычной программой

компрессии для MS-DOS, известной как PKZIP (найдите с помощью

archie PKZIP204.EXE). Многие системы Unix позволят вам

распаковать этот файл с помощью программы, называемой... как?

Правильно, unzip.

.gz Версия ZIP для Unix. Для распаковки введите

gunzip filename.gz

в командной строке своей системы.

.zoo или .ZOO Формат компрессии Unix и MS-DOS. Для разворачивания

используйте программу по имени zoo.

.Hqx или .hqx Формат компрессии для Mactintosh. Требует программы BinHex.

.shar или Еще один формат Unix. Для распаковки используется unshar.

.Shar

.tar Еще один формат Unix, часто используемый при упаковке

нескольких связанных друг с другом файлов в один большой

файл. Большинство систем Unix имеют программу с именем tar

для "un-tarring" (распаковки) таких файлов. Часто такие

файлы еще и сжимаются методом gz, так что их надо сначала

распаковать, а потом обработать программой tar.

.sit или .Sit Формат Mactinosh, требующий программы StuffIt.

.ARC Другой формат MS-DOS, требующий использования программ ARC

или ARCE.

.LHZ Другой формат MS-DOS, требующий использования программы LHARC.

Несколько слов предостережения напоследок: перед тем, как взять файл,

посмотрите его размер. Сеть перемещает данные с феноменальной скоростью. Но

файл в 500 кбайт, который будет передан в вашу систему за несколько секунд,

может потребовать час или два при выгрузке в ваш компьютер, если вы

используете модем 2400 бод. Ваша система может также иметь ограничения по

числу байт, которые вам разрешено хранить в одном сеансе связи. Ну, и кроме

того, хотя это и маловероятно, может оказаться, что ваш файл заражен

вирусом. И если вы хотите брать с Сети много программ, то запаситесь

хорошим антивирусным средством - на всякий случай.

7.5 Клавиатурная кабалистика

Системные администраторы - такие же люди, как и все прочие: они

стараются облегчить себе жизнь. А когда приходится целые дни сидеть за

клавиатурой, это означает сделать все возможное, чтобы уменьшить число

нажимаемых за день клавиш.

К сожалению, нам, всем остальным, это создает трудности.

Вы уже прочли о директориях bin и lost+found. Etc - еще одна такая с

виду интересная директория, которая используется самой системой ftp для

хранения файлов. И в ней тоже нет ничего по-настоящему интересного.

Когда же вы попадете в настоящие библиотеки, вы обнаружите, что во

многих случаях файлы содержат такие, мягко говоря, не описательные имена,

как V1.1-AK.TXT. Самый известный пример - набор из нескольких сот файлов,

известных как файлы RFC, содержащие основную техническую и организационную

информацию, на которой во многом зиждется структура Internet. Эти файлы

можно найти во многих подсистемах ftp, но всегда в виде RFC101.TXT,

RFC102.TXT и т. п. без всякого намека на то, какая информация в каком из

них содержится.

К счастью, почти все подсистемы ftp содержат "Розеттский камень",

помогающий расшифровать такие имена. У большинства есть файл с именем

README (или что-то в этом роде), дающий основную информацию о системе.

Затем, большинство директорий либо содержит аналогичный файл README, либо

имеет указатель, дающий краткое описание каждого файла. Обычно это первый

файл в директории, и чаще всего в виде 00INDEX.TXT. Считайте этот файл

командой ftp. Затем его можно просмотреть интерактивно или выгрузить в свой

компьютер и посмотреть, какие файлы могут вас заинтересовать.

Еще один файл, который вы часто будете просматривать, называется

ls-lR.Z. Он содержит листинг, включающий в себя каждый файл системы, но

без всякого описания (имя происходит от команды Unix ls -lR, дающей листинг

всех файлов во всех ваших директориях). Буква Z означает, что файл был

подвергнут сжатию, то есть что вам придется перед чтением файла

использовать команду Unix uncompress.

И наконец, существуют такие системные администраторы, которые

находят удовольствие в том, чтобы затруднять людям жизнь - и уж они-то

полностью используют предоставляемые системой Unix возможности создавать

неимоверно длинные имена файлов. На некоторых подсистемах FTP встречаются

имена файлов символов этак из 80, битком набитые заглавными буквами,

подчеркиваниями и прочими орфографическими ухищрениями - такое имя

практически невозможно ввести правильно при попытке считать файл. Против

этого у вас есть секретное оружие - команда mget. Просто введите mget,

пробел и первые пять или шесть символов имения файла, поставив за ними

звездочку, например:

mget This_F*

Подсистема FTP спросит, хотите ли вы считать файлы, имя которых начинается

подобным образом. Если таких файлов несколько, вам, может быть, придется

несколько раз ответить "n", но это все же проще, чем потратить неимоверное

количество времени и сил на ввод полного имения файла.

7.6 Некоторые интересные подсистемы FTP

То, что приведено далее, является списком некоторых интересных

подсистем ftp, организованных по категориям. Конечно, при сотнях имеющихся

в Сети подсистемах ftp этот список только чуть-чуть скользит по поверхности

того, что существует на самом деле. Свобода в работе с archie поможет вам

найти конкретные файлы. Время, указанное для каждой подсистемы, указано

как Восточное и задает период, в который подсистема свободна для связи.

Американские аборигены

pines.hsu.edu Эта подсистема - исходная директория для IndianNet,

содержит множество директорий и файлов об индейцах и эскимосах, в том

числе данные по федеральному цензу, отчетов исследователей и базу

данных по распределению по племенам. См. директории pub и indian.

Амига

ftp.uu.net Содержит программы для Amiga в директории systems/amiga.

24 часа в сутки.

wuarchive.wustl.edu. См. в директории pub/aminet.

24 часа в сутки.

Атари

atari.archive.umich.edu Практически все файлы для Atari, которые

только могут понадобиться, находятся в директории atari. 19:00 - 7:00.

Библиотеки

ftp.unt.edu Директория library содержит многочисленные списки

библиотек с компьютеризованными каталогами, к которым возможен доступ через

Сеть.

Вирусы

ftp.unt.edu Директория antivirus содержит антивирусные программы для

компьютеров под MS- DOS и компьютеров Macintosh. 19:00 - 7:00.

Гонконг

nok.lcs.mit.edu Картинки формата GIF поп-звезд, зданий и видов

Гонконга можно найти в директории pub/hongkong/HKPA. 18:00 - 6:00.

Домашние животные

rtfm.mit.edu Директории pub/usenet/rec.pets.dogs и

pub/usenet.rec.pets.cats содержат документы о собаках и кошках

соответственно. При использовании этой подсистемы ftp см. предупреждение

под рубрикой "Книги". 18:00 - 6:00.

Закон

info.umd.edu U.S. Решения Верховного Суда США с 1989 по настоящее

время хранятся в директории info/Government/US/SupremeCt. Каждый элемент

имеет отдельную директорию (например, term1992). Возьмите файлы README и

Index, чтобы расшифровать номера дел. 18:00 - 6:00.

ftp.uu.net Решения Верховного суда лежат в директории court-opinions.

Вам может понадобиться взять файл-указатель, сообщающий номера файлов,

идущих с каждым именем файла. Решения записаны только в форматах

WordPerfect и Atex. 24 часа в сутки.

История

nptn.org Эта подсистема представляет собой большую и растущую

коллекцию текстовых файлов. В директории pub/e.texts/freedom.shrine можно

найти копии важных исторических документов, от Великой Хартии Вольностей до

Декларации Независимости или Провозглашения освобождения рабов.

24 часа в сутки.

ra.msstate.edu Штат Миссисипи ведет сборную базу данных по

историческим документам, в которой есть подробности всего - от военной

стратегии Аттилы до песен вьетнамских солдат. 16:00 - 6:00.

seq1.loc.gov Библиотека Конгресса приобрела множество документов

бывшего Советского правительства, и многие из них переведены на английский.

В директории pub/soviet.archive/text.english можно найти все - от телеграмм

Ленина с приказами о расстрелах участников крестьянских восстаний до

ответов Хрущева Кеннеди во время кубинского ракетного кризиса. Файл README

в директории pub/soviet.archive содержит указатель этих документов.

18:00 - 6:00.

Картины

wuarchiv.wustl.edu Директория graphics/gif содержит сотни

фотографических и рисованных картин формата GIF - от кукол до автомобилей,

звездных карт и поп-звезд. Они организованы в длинные последовательности

субдиректорий.

Книги

rtfm.mit.edu Директория pub/usenet/rec.arts.books содержит список

литературы различных авторов, равно как и список рекомендованных книжных

магазинов в различных городах. К сожалению, у этой подсистемы неимоверно

длинные имена файлов - настолько, что приходится производить прокрутку

экрана, работая на компьютерах с MS-DOS или на некоторых других. Даже если

вам нужен только один из этих файлов, то имеет смысл использовать mget

вместо get. При этом вас будут спрашивать о каждом файле, нужен ли он вам,

но иначе вас будет здорово злить, когда на ваши попытки ввести имя файла

система будет отвечать, что такового не имеется - а на самом деле вы просто

не видите конца имени файла, который вылез за экран. 18:00 - 6:00.

mrcnext.cso.uiuc.edu Проект "Гуттенберг" (Project Gutenberg)

представляет собой попытку перевести тексты с бумаги в электронную форму.

Сейчас существуют уже более ста названий, от Льюиса Кэррола до Марка Твена,

от "Повести о двух городах" до "Сына Тарзана". Искать в директориях

/etext/etext92 и /etext/etext93. 18:00 - 9:00.

Компьютерная этика

ftp.eff.org Исходная директория системы Electronic Frontier

Foundation. С помощью команды cd перейдите в директорию pub и ищите в

директориях EFF, SJG и CPSR документы о самой директории EFF и различных

изданиях, относящихся к Сети, этике и закону. 24 часа в сутки.

Космос

ames.arc.nasa.gov Хранит текстовые файлы по космосу и по истории

программ NASA в субдиректории pub/SPACE. В директориях pub/GIF и

pub/SPACE/GIF можно найти файлы GIF, имеющие отношение к NASA или к

астрономии, в том числе изображения планет, спутников и других небесных тел.

21:00 - 9:00.

Кулинария

wuarchive.wustl.edu Рецепты и директории рецептов можно найти в

директории usenet/rec.food.cooking/recipes.

gatekeeper.dec.com Рецепты в директории pub/recipes.

Литература

nptn.org В директориях pub/e.texts/gutenberg/etext91 и etext92 можно

получить копии Басен Эзопа, литературных работ Льюиса Кэрролла и многих

других, или даже Книгу Мормона. 24 часа в сутки.

world.std.com Директория obi содержит все - от сказок до личных

дел переживших Хиросиму. 18:00 - 6:00.

Макинтош

sumex-aim.stanford.edu Это основная директория с программным

обеспечением для машин Macintosh. После регистрации переключитесь в

директорию info-mac, которая вызовет длинную последовательность

субидректорий с практически любыми бесплатными и распространяемыми

программами для Mac, которые вы только можете пожелать. 21:00 - 9:00.

ftp.uu.net Много программ для Macintosh можно найти в

директории systems/mac/simtel20. 24 часа в сутки.

Музыка

cs.uwp.edu Директория pub/music содержит все - от текстов современных

песен до рекомендованных компакт-дисков по музыке барокко. Она несколько

отличается от других подсистем ftp, и по ней легче передвигаться. Слева

пишутся имена файлов и директорий, а справа - их краткие описания,

например:

SITES 1528 Other music-related FTP archive sites

classical/ - (dir) Classical Buying Guide

database/ - (dir) Music Database program

discog/ = (dir) Discographies

faqs/ = (dir) Music Frequently Asked questions files

folk/ - (dir) Folk Music Files and pointers

guitar/ = (dir) Guitar TAB files from ftp.nevada.edu

info/ = (dir) rec.music.info archives

interviews/ - (dir) Interviews with musicians/groups

lists/ = (dir) Mailing lists archives

lyrics/ = (dir) Lyrics Archives

misc/ - (dir) Misc files that don't fit anywhere else

pictures/ = (dir) GIFS, JPEGs, PBMs and more.

press/ - (dir) Press Releases and misc articles

programs/ - (dir) Misc music-related programs for various machines

releases/ = (dir) Upcoming USA release listings

sounds/ = (dir) Short sound samples

226 Transfer complete.

ftp>

────────────────────────────────────────────────────────────────────────────

ПОДСИСТЕМЫ 1528 другие архивные подсистемы FTP о музыке

classical/ - (дир) Руководство для покупки классики

database/ - (дир) Программа музыкальной базы данных

discog/ = (дир) Дискография

faqs/ = (дир) Файлы стандартных вопросов о музыке

folk/ - (дир) Файлы и указатели народной музыки

guitar/ = (дир) Файлы Guitar TAB от ftp.nevada.edu

info/ = (дир) Архивы rec.music.info

interviews/ - (дир) Интервью с музыкантами и группами

lists/ = (дир) Архивы списков рассылки

lyrics/ = (дир) Архивы стихов

misc/ - (дир) Разные файлы - неизвестно, куда отнести

pictures/ = (дир) GIFS, JPEGs, PBMs и пр.

press/ - (дир) Пресс-релизы и различные статьи

programs/ - (дир) Различные музыкальные программы для разных машин

releases/ = (дир) Листинг предстоящих выпусков в США

sounds/ = (дир) Примеры коротких звуков

226 Передача окончена.

ftp>

────────────────────────────────────────────────────────────────────────────

Указывая имя директории, не включайте символ '/'. 19:00 - 7:00.

potemkin.cs.pdx.edu Архив Боба Дилана. Интервью, заметки, ведение

ежегодных записей о его жизни и др., в директории pub/dylan directory.

21:00 - 9:00.

ftp.nevada.edu Гитарная музыка современных песен в

диретории pub/guitar, субдиректории организованы по группам или

исполнителям.

Научная фантастика

elbereth.rutgers.edu В директории pub/sfl содержатся пересказы

сюжетов различных фантастических ТВ-спектаклей, в том числе Star Trek (не

только исходный спектакль и продолжение, но и мультипликационная версия),

Lost in Space, Battlestar Galactica, the Twilight Zone, the Prisoner и

Doctor Who. Здесь также содержится список различных относящихся к жанру

фантастики вещей и электронный журнал поклонников фантастики. 18:00 - 6:00.

Обзоры фильмов

lcs.mit.edu См. в директории movie-reviews. 18:00 - 6:00.

Погода

wuarchive.wustl.edu Директория /multimedia/images/wx содержит

изображения формата GIF, относящиеся к погоде в Северной Америке. Файлы

обновляются ежечасно и имеют форму: CV100222. Первые две буквы говорят о

типе файла: CV означает фотографию в видимом свете, сделанном со спутника

наблюдения за погодой. CI означает то же самое, но фотография сделана в

инфракрасных лучах. Оба формата черно-белые. Файлы, чье имя начинается с

SA, представляют собой цветную радарную карту Соединенных Штатов, на

которой изображены отдельные погодные узоры, а также фронты и температуры в

крупных городах. Числа указывают дату и время по Гринвичу снятия

изображения: первые две цифры числа представляют собой месяц, вторые -

дату, и две последние цифры - час. Файл WXKEY.GIF поясняет различные

символы, используемые в файлах SA.

Потребитель

rtfm.mit.edu Директория pub/usenet/misc.consumers содержит документы

относительно кредита. Директория pub/usenet/rec.travel.air расскажет о том,

как иметь дело с сотрудниками служб заказа билетов, укажет наилучшие цены

на места и т. д. К этой подсистеме ftp относится то же предупреждение, что

было сделано под рубрикой "Книги". 18:00 - 6:00.

Правительство

ncsuvm.cc.ncsu.edu Директория SENATE содержит библиографические

записи о слушаниях в Сенате США и документы по нескольким последним

конгрессам. Возьмите файл README.DOS9111, который содержит расшифровку

кодовых имен файлов. 18:00 - 6:00.

nptn.org Агентство General Accounting Office является подразделением

Конгресса, которое занимается расследованиями. Директория

pub/e.texts/gao.reports представляет собой эксперимент агентства по

рассылке докладов о результатах своей деятельности. 24 часа в сутки.

info.umd.edu Директория info/Government/US/Whitehouse хранит копии

пресс-релизов и прочих документов, изданных администрацией Клинтона.

18:00 - 6:00.

leginfo.public.ca.gov Репозиторий повесток законодательного собрания,

биллей и другой информации о работе правительства штата Калифорния.

24 часа в сутки.

whitehouse.gov Здесь можно найти копии документов о позиции

президента, записи пресс-конференций и относящуюся к этим вопросам

информацию. 24 часа в сутки.

См. также под рубрикой "Закон"

Путешествия

nic.stolaf.edu Прежде чем предпринять очередное путешествие за море,

вам может захотеться узнать, не издал ли Государственный департамент

каких-либо сведений и советов относительно той страны, в которую вы

направляетесь. Сведения и рекомендации, охватывающие все возможные темы -

от нанесенных ураганом повреждений до гражданских войн, можно найти в

директории pub/travel-advisories/advisories, организованной по странам.

19:00 - 7:00.

Религия

nptn.org В директории pub/e.texts/religion можно найти субдиректории

по главам как из Библии, так и из Корана. 24 часа в сутки.

Секс

rtfm.mit.edu В директории pub/usenet/alt.sex и

pub/usenet/alt.sex.wizards содержатся документы по всем относящимся к сексу

вопросам. Предупреждение под рубрикой "Книги" может быть отнесено к данной

подсистеме ftp. 18:00 - 6:00.

Телевидение

coe.montana.edu Директория pub/TV/Guides содержит историческую и

другую информацию о десятках телепрограмм. Она допускает одновременное

обращение не более чем двух анонимных ftp, так что, может быть, придется

подождать, пока вас впустят. 20:00 - 8:00.

ftp.cs.widener.edu Директория pub/simpsons содержит больше файлов,

чем может понадобиться кому бы то ни было о Барте и его семье. Директория

pub/strek содержит файлы об исходном спектакле и продолжении, а также о

фильмах. См. также "Научная фантастика".

Фотография

ftp.nevada.edu Photolog - оперативно доступный дайджест новостей

фотографии, в директории pub/photo.

Шекспир

atari.archive.umich.edu Директория shakespeare содержит большинство

произведений Барда. Многие другие подсистемы также содержат их, но в виде

одного здоровенного мегафайла. Данная подсистема разбивает их на группы

(комедии, стихи, исторические произведения и т.д.) так что можно загрузить

к себе отдельные пьесы или сонеты.

Экономика

neeedc.umesbs.maine.edu Федеральный резервный банк Бостона (Federal

Reserve Bank of Boston) использует эту подсистему (три 'e' в слове "neeedc"

- не ошибка!) для хранения всех видов данных по экономике Новой Англии.

Многие файлы содержат информацию за 20 и более лет, обычно в виде, легко

адаптируемом для ввода в электронные таблицы или базы данных. См. в

директории frbb. 18:00 - 6:00.

town.hall.org. В директории edgar можно найти основные сведения о

системе, предназначенной для рассылки годовых отчетов и других открыто

хранимых данных, в которых нуждаются компании для подачи сведений в

комиссию Securities and Exchange Commission. Директория other/fed содержит

различные файлы статистического учета от ведомства Federal Reserve Board.

FTP

iraun1.ira.uka.de Эта подсистема, которую ведет факультет кибернетики

(computer-science department) университета Карлсруэ в Германии предлагает

список анонимных подсистем FTP как международных (в директории

anon.ftp.sites), так и в Германии (в директории anon.ftp.sites.DE).

12:00 - 2:00.

ftp.netcom.com Директория pub/profiles содержит список подсистем ftp.

Internet

ftp.eff.org Директория pub/Net_info содержит множество субдиректорий,

содержащих, в свою очередь, различные ресурсы Internet и файлы с

информацией, в том числе последние версии интерактивных Руководств по

Internet EFF. 24 часа в сутки.

nic.ddn.mil Директория internet-drafts содержит информацию об

Internet, а директория scc содержит бюллетени службы зашиты сети.

18:00 - 6:00.

MS-DOS

wuarchive.wustl.edu Содержит одно из самых больших собраний

программного обеспечения для MS-DOS. Файлы фактически скопированы или

"отражены" с компьютера, находящегося в U.S. Army's White Sands Missile

Range (этот компьютер использует абсолютно недоступное пониманию

программное обеспечение ftp). Здесь также содержится большая коллекция

программного обеспечения для Macintosh, Windows, Atari, Amiga, Unix, OS9,

CP/M и Apple II. Посмотрите в директориях mirrors и systems. Директория gif

содержит большое количество графических изображений формата GIF.

24 часа в сутки.

ftp.uu.net Программы и файлы для MS-DOS смотрите в директории

systems/msdos/simtel20. 24 часа в сутки.

Usenet

ftp.uu.net В директории usenet можно найти файлы "часто задаваемые

вопросы", скопированные с rtfm.mit.edu. Директория communications содержит

программы, позволяющие пользователям MS-DOS прямо соединяться с

подсистемами UUCP. В директории info можно найти информацию о ftp и

подсистемах ftp. Директория inet содержит информацию об Internet.

24 часа в сутки.

rtfm.mit.edu Эта подсистема содержит все доступные файлы "часто

задаваемые вопросы" для групп новостей Usenet в директории pub/usenet.

Предупреждение, относящееся к использованию этой подсистемы, см. под

рубрикой "Книги". 18:00 - 6:00.

7.7 ncftp ── а теперь скажи мне!

Если вам повезет, то персонал, ведущий вашу местную систему или

общедоступную подсистему, установит программу, называемую ncftp, которая

смягчает некоторые острые углы процесса работы с ftp.

Прежде всего, когда работаешь с ncftp вместо простого старого ftp,

можно больше не думать о неправильном написании слова "anonymous" при

установлении связи. Программа займется этим сама. А после входа в систему

вместо получения строки за строкой черточек и букв x, r и d, вы получаете

прост листинг самих файлов или директорий (если вы привыкли к MS-DOS, то

предъявляемый вам экран будет очень похож на то, что выводится в результате

выполнения команды dir /w). Программа даже создает список последних

использованных вами подсистем ftp, так что можно просто выбрать подсистему

из списка, чем пытаться запомнить неимоверно сложное имя подсистемы ftp.

Вызов программы (если в вашей подсистеме она есть) прост. Введите в

командной строке

ncftp имя_подсистемы

где "имя_подсистемы" - имя той подсистемы, к которой вы хотите получить

доступ (а можно просто ввести команду ncftp и затем использовать ее команду

open). После соединения можете воспользоваться привычной вам уже командой

ftp, вроде ls, get или mget. Позиции, которые заканчиваются символом /,

представляют собой директории, к которым вы можете перейти с помощью

команды cd; остальные - это файлы, которые можно взять. Среди полезных

команд ncftp есть type, позволяющая изменить тип передачи файла (например,

с ASCII на двоичный) и size, позволяющая узнать размер файла перед взятием,

например

size declaration.txt

скажет, каков размер файла declaration.txt . Когда вы говорите "bye" (прощай)

для окончания связи с подсистемой, ncftp запоминает последнюю директорию, к

которой вы обращались, и в следующий раз при соединении с данной

подсистемой вы войдете в эту директорию автоматически. Если ввести

help

то вам будет выдан список файлов, которые можно прочесть, чтобы

расширить свое представление о возможностях программы.

7.8 Проект "Гуттенберг" ── электронные книги

Проект "Гуттенберг", руководимый Майклом Хартом (Michael Hart), ставит

себе честолюбивую цель: сделать более 10000 книг и документов доступными по

электронным сетям к 2001 году. В 1993 году в рамках проекта на его

подсистемы ftp загружалось в среднем четыре книги в месяц, в 1994 году это

число надеются удвоить. Проект стартовал в 1971 году и теперь ведет

библиотеку из сотен "доступных к выдаче" книг, от "Басен" Эзопа до "Алисы в

зазеркалье". Растет также число документов, посвященных текущим событиям,

таких, как "World Factbook" (Всемирная книга фактов) - альманах,

выпускаемый ЦРУ. Кроме nptn.org, тексты проекта "Гутенберг" можно получить

также от mrcnext.cso.uiuc.edu из директории etext.

7.9 Когда что-то не так

∙ Вы получили сообщение "host unavailable". Подсистема ftp зачем-то

отключена.

Попробуйте еще раз позже.

∙ Получено сообщение "host unknown".

Проверьте правильность написания имени подсистемы.

∙ Вы неверно ввели слово "anonymous" при входе и получили сообщение,

что требуется пароль.

Введите что-нибудь, нажмите enter, введите "bye", нажмите enter, и

попробуйте еще раз. Можно по-другому: попробуйте ввести "ftp" вместо

"anonymous." Удивительно, на сколь большом числе подсистем это срабатывает.

А еще лучше - воспользуйтесь ncftp, если в вашей подсистеме она есть, и

никогда больше об этом не думайте.

7.10 Куда обратиться с вопросами

Свободное использование archie поможет вам найти конкретные файлы и

документы. За информацией о новых интересных подсистемах ftp попробуйте

обратиться в группу новостей comp.archives на Usenet. Можно также поискать

в группах новостей comp.misc, comp.sources.wanted или news.answers на

Usenet списки подсистем ftp, помещаемые каждый месяц Томом Чарником (Tom

Czarnik) и Джоном Грэнроузом (Jon Granrose).

Группа новостей comp.archives содержит новости о новых подсистемах ftp

и интересных новых файлах на существующих. В группе новостей comp.virus на

Usenet ищите сообщение о тех подсистемах ftp которые содержат антивирусные

программы для Amiga, MS-DOS, Macintosh, Atari и других компьютеров. Группы

новостей comp.sys.ibm.pc.digest и comp.sys.mac.digest предоставляют

информацию о новых программах для MS-DOS и Macintosh, а также ответы на

вопросы пользователей таких компьютеров.

Глава 8: ПРОГРАММЫ GOPHER, WAIS И WWW

8.1 Программы Gopher

Даже при наличии таких средств, как Hytelnet и archie, работа с telnet

и ftp может здорово донимать человека. Запоминать все эти адреса telnet и

ftp. Совершенно своебразные команды отдельных служб telnet. Да еще эти

таинственные имена файлов и директорий!

Но теперь, когда Сеть стала богатейшим репозиторием информации, люди

разрабатывают себе различные способы, облегчающие нахождение информации и

доступ к файлам. Два вида услуг - программы gopher и WAIS (Wide-Area

Information Servers - серверы распространенной информации) - могут сделать

навигацию по Internet столь же легкой и удобной, как по коммерческим сетям

вроде CompuServe или Prodigy.

Как программы gopher, так и программы WAIS, по сути дела воспринимают

запрос на информацию, а затем сканируют Сеть в ее поисках, избавляя от этой

работы вас. Обе работают через посредство систем меню, что избавляет от

необходимости набора долгой последовательности символов - просто поставьте

курсор на выбранный пункт и нажмите enter. Программы gopher даже позволяют

подобным образом выбирать программы и файлы из подсистем ftp.

Сначала займемся программами gopher, названными по официальному

геральдическому животному университета штата Миннесота, где система была

разработана (gopher - мешотчатая крыса).

У многих общедоступных подсистем теперь есть доступная для работы на

связи программа gopher. Для ее использования введите в командной строке

gopher

и нажмите enter. Если вы знаете, что на вашей подсистеме программы gopher

нет, или если при вводе вышеуказанной команды ничего не произошло,

свяжитесь по telnet с

consultant.micro.umn.edu

В ответ на приглашение к регистрации (log-in), введите:

gopher

и нажмите enter. Вас спросят об используемом у вас типе эмуляции

терминала, после чего покажут нечто вроде этого:

Internet Gopher Information Client v1.03

Root gopher server: gopher.micro.umn.edu

--> 1. Information About Gopher/

2. Computer Information/

3. Discussion Groups/

4. Fun & Games/

5. Internet file server (ftp) sites/

6. Libraries/

7. News/

8. Other Gopher and Information Servers/

9. Phone Books/

10. Search lots of places at the U of M <?>

11. University of Minnesota Campus Information/

Press ? for Help, q to Quit, u to go up a menu Page: 1/1

────────────────────────────────────────────────────────────────────────────

Информационный клиент Internet Gopher v1.03

Корневой сервер gopher: gopher.micro.umn.edu

--> 1. Информация о Gopher/

2. Компьютерная информация/

3. Дискуссионные группы/

4. Развлечения и игры/

5. Подсистемы файлового сервера Internet (ftp)/

6. Библиотеки/

7. Новости/

8. Другие серверы Gopher и информационные серверы/

9. Телефонные книги/

10. Поиск места в университете Миннесоты <?>

11. Информация по студенческому городку университета Миннесоты/

Нажмите ? для получения пояснения, q для выхода, u - вверх по меню Стр.: 1/1

────────────────────────────────────────────────────────────────────────────

Если у вас используется эмуляция терминала VT100 или другого терминала

семейства VT, то вы получите возможность перемещаться между пунктами выбора

с помощью клавиш управления курсором "стерлка вверх" и "стрелка вниз".

Поставив курсор на тот пункт, который вас интересует, просто нажмите enter

и вы получите либо новое меню, либо бланк ввода запроса базы данных, либо

текстовый файл - в зависимости от того, с чем связан выбранный пункт меню.

Программы gopher очень удобны для изучения ресурсов Сети. Просто

выбирайте различные пункты меню и смотрите, что появляется. Поиграйте с

этими возможностями и посмотрите, куда это вас приведет. Некоторые пункты

выбора окажутся документами. После чтения документа до конца или нажатия

при его чтении символа 'q' нижнего регистра для прекращения вас спросят,

хотите ли вы сделать копию документа в своей домашней директории или

послать себе такую копию электронной почтой. Другие пункты выбора

представляют собой простые базы данных, позволяющие ввести слово для поиска

конкретных баз данных. Чтобы вернуться к тому состоянию, в котором была

начата работа с программой gopher, нажмите в ответ на приглашение в меню

клавишу "u", что вернет вас обратно "вверх" по структуре меню программы

gopher (похоже на "cd .." при работе с ftp).

Обратите внимание, что одна из предоставляемых возможностей

приведенного выше меню - "Internet file server (ftp) sites" (Подсистемы

протокола передачи файлов (ftp) Internet"). Выбрав этот пункт, вы

соединитесь с модифицированным вариантом программы archie - archie с

небольшой разницей. При поиске файла с помощью archie программы gopher вы

получаете меню подсистем, содержащих искомый вами файл, как и старом

варианте archie. Однако теперь вместо записывания или запоминания адреса и

директории ftp вам необходимо только поставить курсор рядом с номером в

меню нажать enter. Вы соединитесь с соответствующей подсистемой ftp, в

которой можете выбрать интересующий вас файл. После этого поставьте курсор

на этот файл и нажмите символ 's' нижнего регистра. У вас спросят, какое

имя использовать для этого файла в вашей домашней директории, и под этим

именем он будет туда скопирован. К сожалению, такой процесс передачи файлов

для компьютерных программ и сжатых файлов работает еще не на всех

общедоступных подсистемах. Если на вашей он не работает, придется

копировать файл как и раньше - через ftp anonymous.

Кроме подсистем ftp, в мире существуют сотни баз данных и библиотек, к

которым можно получить доступ через программы gopher. Пока еще нет

программы gopher общего интерфейса для библиотечных каталогов, так что для

соединения с каким-либо из них будьте готовы следовать указаниям,

получаемых в интерактивном режиме.

Пункты меню программы gopher, которые оканчиваются символом '/',

являются шлюзами к другим меню или возможностям. Пункты меню,

оканчивающиеся точкой, представляют собой текстовые, программные или

графические файлы, которые можно скопировать в свою домашнюю директорию

(или послать по электронной почте себе или кому-то другому). Строки,

кончающиеся на <?> или <CSO> представляют собой запросы, которые можно

направить к базе данных за получением информации. Разница между ними

состоит в том, пункты с <?> вызывают однострочечные интерфейсы, в которых

можно искать ключевые слова или просто слова, в то время как <CSO> вызывают

электронную таблицу, в которой можно заполнить несколько полей -

это можно наблюдать при связи с директориями "White Pages" (телефонным

справочником частных лиц) в колледжах.

Программы gopher позволяют выполнять поиск, алгоритм которого

описывается достаточно сложным булевским выражением. Например, если вам

желательно искать только те файлы, которые содержат слова "MS-DOS" и

"Macintosh," можно ввести:

ms-dos and macintosh

(программы gopher не различают символы верхнего и нижнего регистров) в поле

ключевых слов. Можно и по-другому: для получения списка файлов, в которых

упоминается хотя бы одно из слов "MS-DOS" или "Macintosh," введите

ms-dos or macintosh

8.2 Копаем глубже

Каким бы захватывающим ни был процесс изучения "мира gopher", в

какой-то момент может оказаться желательным какую-то информацию или файл

найти быстро. А может просто надоесть вызывать бесконечные цепи меню, чтобы

добраться до того единственного, которое нужно. К счастью, существуют

способы облегчить использование даже программ gopher.

Один из них - это обратиться к подруге archie по имени veronica (это

имя похоже на шифр, но не верьте в это ни секунды), которая в мире gopher

делает то же, что archie - для подсистем ftp.

У большинства программ gopher программу veronica можно найти, выбрав

опцию "Other gopher and information services" (Другие услуги по gopher и

информационные услуги), а потом - "Searching through gopherspace using

veronica." (Поиск в мире gopher с помощью программы veronica). После такого

выбора вы увидите нечто вроде:

Internet Gopher Information Client v1.1

Search titles in Gopherspace using veronica

--> 1. .

2. FAQ: Frequently-Asked Questions about veronica (1993/08/23).

3. How to compose veronica queries (NEW June 24) READ ME!!.

4. Search Gopher Directory Titles at PSINet <?>

5. Search Gopher Directory Titles at SUNET <?>

6. Search Gopher Directory Titles at U. of Manitoba <?>

7. Search Gopher Directory Titles at University of Cologne <?>

8. Search gopherspace at PSINet <?>

9. Search gopherspace at SUNET <?>

10. Search gopherspace at U. of Manitoba <?>

11. Search gopherspace at University of Cologne <?>

Press ? for Help, q to Quit, u to go up a menu Page: 1/1

────────────────────────────────────────────────────────────────────────────

Клиент информации Internet Gopher v1.1

Поиск заглавий в мире gopher программой veronica

--> 1. .

2. FAQ: Часто задаваемые вопросы о программе veronica (1993/08/23).

3. Как составить вопросы для программы veronica (НОВ ИЮН 24) ПРОЧТИ!!.

4. Поиск в директориях названий Gopher в PSINet <?>

5. Поиск в директориях названий Gopher в SUNET <?>

6. Поиск в директориях названий Gopher Университета Манитобы <?>

7. Поиск в директориях названий Gopher Университета Колонны <?>

8. Поиск в мире Gopher PSINet <?>

9. Поиск в мире Gopher SUNET <?>

10. Поиск в мире Gopher Университета Манитобы <?>

11. Поиск в мире Gopher Университета Колонны <?>

Нажмите ? - помощь, q - выход, u - вверх по меню Стр: 1/1

────────────────────────────────────────────────────────────────────────────

Есть из чего выбирать! Прежде всего, есть разница поиска в директориях

названий и просто в добром старом мире gopher. Если вы знаете, какую

директорию вы ищете (например, содержащую программы для MS-DOS), то

выполняйте поиск директории названий. Но если вы не знаете наверняка, в

директории какого типа может быть ваша информация, ищите просто по всему

миру gopher (общий поиск). Вообще говоря, неважно, какую конкретно

программу veronica вы будете использовать - они все способны давать одни и

те же результаты. Дело в том, что Internet стал настолько популярен, что

одна программа veronica (или одна программа gopher, или что бы то ни было в

единственном числе) будет немедленно выше головы перегружена

информационными запросами со всего мира.

Программу veronica можно использовать для поиска практически чего

угодно. Хотите найти музеи, которые могут сообщить о своей экспозиции?

Попробуйте поискать "museum." Ищете копию Декларации Независимости?

Попробуйте "declaration."

Во многих случаях такой поиск приведет к появлению нового меню

программы gopher, которое можно изучать далее.

Допустим, что вы хотите удивить пришедших к обеду гостей вишневым

"фламбе". Если вызвать программу veronica и ввести "flambe" после ее

вызова, то вы вскоре получите меню с несколькими рецептами "фламбе", в том

числе один с названием "dessert flambe." Поставьте на него курсор и нажмите

enter, и вы получите меню "фламбе с вишнями". Потом нажмите клавишу q для

выхода, и программа gopher спросит вас, хотите ли вы запомнить файл в вашей

домашней директории своей общедоступной подсистемы или хотите послать

куда-нибудь по электронной почте его копию.

Как видите, программу veronica можно использовать как альтернативную к

archie, которая в связи с возрастающей популярностью Internet работает,

похоже, все дольше и дольше.

Кроме программ archie и veronica, сейчас есть еще и программы jughead.

Они работают аналогично программам veronica, но их область поиска

ограничена теми системами gopher, на которых они расположены.

Если есть какие-то конкретные ресурсы gopher, которые часто вами

используются, то можно с помощью некоторых способов добираться до них

побыстрее.

Один из них - использовать программу gopher аналогично программе

telnet. Если известен конкретный адрес программы gopher в Internet (часто

тот же, что и ее адрес в telnet или ftp), то можно с ней связаться

непосредственно, а не проходить цепочку меню. Пусть, например, вы хотите

использовать программу gopher на info.umd.edu. Если на вашей общедоступной

системе установлена программа gopher, введите

gopher info.umd.edu

в командной строке, и вас соединят.

Но даже и это может утомить, если у вас есть несколько часто

используемых программ gopher. Здесь появляются на сцене закладки

(bookmark). Программы gopher позволяют создать список ваших излюбленных

подсистем gopher и даже запросов к базе данных. И тогда вместо вкапывания

все глубже и глубже в структуру директорий gopher, вы просто вызовете список

своих закладок и выберете нужную вам услугу.

Для создания закладки на определенную подсистему gopher сначала надо

вызвать программу gopher. Затем надо пройти по всем меню gopher до того

меню, которое вам нужно. Введите символ A верхнего регистра. Вам будет

предложено имя для этой закладки, которое вы можете изменить, убрав

предложенное символами "забой" и введя новое. Закончив эту работу, нажмите

enter. Теперь, находясь в области действия программы gopher и желая

вернуться к этой конкретной службе gopher, просто нажмите клавишу V (на

верхнем или нижнем регистре - в данном случае программа gopher не делает

различий) в любой момент работы с программой gopher. При этом будет вызван

список созданных вами ранее закладок. Перейдите к желательной и нажмите

enter, и вас соединят.

Символ A верхнего регистра удобен также и для запоминания отдельных

запросов к базам данных или программе veronica, которые часто используются

(например, поиск новостей по определенным темам, если ваша общедоступная

система ведет индексированный архив новостей от телеграфных агентств).

Вместо символа A верхнего регистра можно использовать и символ a

нижнего регистра, что выводит в конкретную строчку меню, а не ведет к

предъявлению меню целиком.

Если вы захотите удалить закладку, нажмите символ V при работе с

gopher, выберите намеченную к удалению позицию и нажмите символ D.

Еще один совет:

Если вам хочется найти адрес какой-то конкретной услуги gopher, нажмите

клавишу "=" после подсвечивания соответствующего пункта в меню программы.

Вы получите пару строчек, имеющих вид технической информации и для

большинства людей не доступные к непосредственному использованию, но

некоторые из них состоят из адреса нужной подсистемы.

8.3 Команды Gopher

a Добавить строку в меню gopher к своему списку закладок.

A Добавить целое меню gopher или запрос к базе данных к своему

списку закладок.

d Удалить позицию из своего списка закладок (сначала следует нажать

клавишу v).

q Выход из программы gopher. Система попросит подтверждения.

Q Выход из программы gopher без запроса подтверждения.

s Запоминание подсвеченного файла в домашней директории.

u Движение вверх по структуре меню gopher.

v Просмотр своего списка закладок.

= Получение информации об исходной подсистеме данной позиции меню

gopher.

> Движение вперед на один экран по меню gopher.

< Движение назад на один экран по меню gopher.

8.4 Некоторые интересные подсистемы Gopher

В мире существуют несколько сотен подсистем gopher. Ниже приводится

список только некоторых из них. Если на вашей подсистеме установлена

программа-"клиент" gopher, то вы можете до них добраться, введя в командной

строке

gopher имя_подсистемы

Не можете найти то, что ищете? Вспомните, что можно использовать программу

veronica для просмотра по категориям и темам!

Архитектура

libra.arch.umich.edu Поддерживает оперативную передачу различных

архитектурных изображений.

Астрономия

cast0.ast.cam.ac.uk Эта подсистема gopher, посвященная астрономии,

ведется Астрономическим институтом (Institute of

Astronomy) и Королевской обсерваторией Гринвича

(Royal Greenwich Observatory), Кембридж, Англия.

Геология

gopher.stolaf.edu Выберите "Internet Resources" (Ресурсы Internet),

а затем "Weather and geography" (Погода и

география) для получения информации по последним

землетрясениям.

Животные

saimiri.primate.wisc.edu Информация по приматам и законам об охране

животных.

Здоровье

odie.niaid.nih.gov База данных по СПИД Национального Института

Здравоохранения (National Institutes of Health) в

меню "AIDS related information" (Информация,

относящаяся к СПИД).

helix.nih.gov Для доступа к ведомостям Национального Института

Рака (National Cancer Institute) по различным

видам рака выберите "Health and clinical

information" (информация по клинике и

здравоохранению), а затем - "Cancernet

information."

nysernet.org Информацию о раке груди можно найти в меню

"Special Collections: Breast Cancer" (Специальное

собрание: рак груди).

welchlink.welch.jhu.edu Медицинская программа gopher Университета Джона

Хопкинса (John Hopkins University).

Израиль

jerusalem1.datasrv.co.il Эта израильская система предлагает многочисленные

документы об Израиле и жизни евреев.

Инвалидность

val-dor.cc.buffalo.edu Рог изобилия в смысле информационных ресурсов по

работам, посвященным проблемам инвалидности, и

связям с другими службами, посвященным тем же

проблемам.

Искусство

marvel.loc.gov Библиотека Конгресса ведет несколько "галерей"

изображений с экспозиций библиотеки. Большинство

этих картинок, в формате GIF или JPEG, ОГРОМНЫ,

так что при первом обращении к ним будьте

осторожны. Экспозиции включают работы из Ватикана,

копии когда-то секретных советских документов,

изображения искусственно изготовленных предметов,

относящихся к путешествию Колумба в 1492 году.

Выберите в главном меню "2" и затем - "Exhibits."

galaxy.ucr.edu Калифорнийский музей фотографии (California Museum

of Photography) ведет здесь свою собственную

электронную галерею. В главном меню выберите

"Campus Events", затем "California Museum of

Photography", Затем "Network Exhibitions".

История

См. под рубрикой "Искусство".

Компьютеры

wuarchive.wustl.edu Десятки директорий с программным обеспечением для

компьютеров всех видов. Большинство программ

перед употреблением следует "распаковать".

sumex-aim.stanford.edu Система аналогичного типа с упором на программы и

файлы для Macintosh.

Музыка

mtv.com Ведется Адамом Карри (Adam Curry), диск-жокеем

MTV. Эта подсистема содержит музыкальные новости и

ежедневный отчет Карри о знаменитостях

"Cybersleaze".

Окружающая среда

ecosys.drdr.virginia.edu Копии ведомостей Агентства по охране окружающей

среды (Environmental Protection Agency) по сотням

химикалиев, которые можно разыскивать по ключевым

словам. Выберите "Education" (Образование), а

затем "Environmental fact sheets" (Ведомости

фактов по окружающей среде).

envirolink.org Десятки документов и файлов, относящихся к

деятельности по охране окружающей среды в мире.

Погода

wx.atmos.uiuc.edu Смотрите предсказания погоды для Северной Амереки

или зубрите сведения о собственной погоде.

Правительство

marvel.loc.gov Эта подсистема, поддерживаемая Библиотекой

Конгресса, предоставляет пользователю

многочисленные ресурсы, в том числе доступ к

каталогу Библиотеки и все виды информации о

Конгрессе США.

gopher.lib.umich.edu Широкий диапазон правительственной информации - от

назначений комитетов и до экономической статистики

и информации NAFTA.

ecix.doc.gov Информация о конверсии военных сооружений для

частного использования.

sunsite.unc.edu Копии текущего и прошлых федеральных бюджетов

можно найти, выбрав "Sunsite archives" (Архивы

Сансайт), затем "Politics" (Политика) и "Sunsite

politcal science archives" (Политологические

архивы Сансайт).

wiretap.spies.com Документы, относящиеся к правительству Канады,

можно найти в меню "Government docs".

stis.nih.gov Для доступа к множеству других федеральных

подсистем gopher выберите "Other U.S. government

gopher servers" (Другие серверы gopher

Правительства США).

Природа

ucmp1.berkeley.edu Университет Калифорнии при Музее палеонтологии

Беркли (University of California at Berkeley's

Museum of Paleontology) ведет здесь несколько

электронных выставок. Изображения формата GIF

растений и животных можно получить из меню "Remote

Nature" (отдаленная природа). Меню "Origin of the

Species" (Происхождение видов) дает возможность

прочитать эту работу Дарвина или просмотреть ее по

ключевым словам.

Сельское хозяйство

cyfer.esusda.gov Сельскохозяйственной статистики и законов больше,

чем большинству людей когда-либо может

понадобиться.

usda.mannlib.cornell.edu Более 140 различных типов данных по сельскому

хозяйству, большей частью в формате электронных

таблиц Lotus 1-2-3.

Спорт

culine.colorado.edu Расписание игр команд из различных

профессиональных лиг можно найти здесь в подпункте

"Professional Sports Schedules" (Расписания для

профессионального спорта).

Ценз

bigcat.missouri.edu Подробные федеральные данные по цензу для общин из

более чем 10000 человек, а также для штатов и

графств. В главном меню выбирается "Reference and

Information Center" (Центр ссылок и информации),

затем "United States and Missouri Census

Information" (Информация по цензу по Соединенным

Штатам и Миссури), затем "United States Census"

(Ценз по Соединенным Штатам).

Энтомология

spider.ento.csiro.au Все о ползучих тварях, хороших и плохих.

Япония

gopher.ncc.go.jp В меню "Japan information" (Японская информация)

можно найти документы по японской жизни и

культуре.

Internet

gopher.lib.umich.edu Домашняя директория для нескольких руководств по

ресурсам Internet в специальных областях,

например, в социальных науках. Выберите "What's

New & Featured Resources" (Что нового и

характерные ресурсы), а затем - "Clearinghouse".

8.5 Серверы распределенной информации (WAIS)

Теперь, как вы знаете, существуют сотни баз данных и каталогов

библиотек, которые вы можете просматривать. Но в процессе такого просмотра

вы убеждаетесь, что у каждой базы данных - свой, не похожий на другие,

метод поиска. Если вы соединяетесь с несколькими базами данных или

каталогами, эта разница вызывает головную боль. Программы gopher частично

снимают эту проблему.

Серверы распределенной информации (Wide-area information servers WAIS)

дают другой путь доступа к спрятанной в Сети информации. При работе с WAIS

пользователь видит только один интерфейс - как получить доступ к десяткам,

если не сотням, различных баз данных является заботой самой программы. Вы

сообщаете программе WAIS слово, и она сама находит в сети те места, где это

слово встречается. Вы получаете меню документов, отсортированных по степени

отношения, которое они, по мнению программы WAIS, имеют к задаче

вашего поиска.

Как и в случае с программами gopher, программы-"клиенты" WAIS можно

найти на многих общедоступных подсистемах Internet. Если в вашей системе

есть клиент WAIS, введите в командной строке:

swais

и нажмите enter (Символ "s" заменяет слово "simple" - простой). Если нет,

свяжитесь по telnet с bbs.oit.unc.edu, который ведется университетом Северной

Каролины (University of North Carolina). В ответ на приглашение "login:"

введите

bbs

и нажмите enter. Вас попросят зарегистрироваться, а затем вы пполучите

список "бюллетеней", представляющих собой различные файлы с объяснениями

того, как работает система. После этого нажмите клавишу Q, и вам будет

предъявлено другое меню. Нажмите 4 для выбора пункта "simple WAIS client"

(простой клиент WAIS), и вы увидите нечто вроде следующего:

SWAIS Source Selection Sources: 23#

Server Source Cost

001: [ archie.au] aarnet-resource-guide Free

002: [ archive.orst.edu] aeronautics Free

003: [nostromo.oes.orst.ed] agricultural-market-news Free

004: [sun-wais.oit.unc.edu] alt-sys-sun Free

005: [ archive.orst.edu] alt.drugs Free

006: [ wais.oit.unc.edu] alt.gopher Free

007: [sun-wais.oit.unc.edu] alt.sys.sun Free

008: [ wais.oit.unc.edu] alt.wais Free

009: [ archive.orst.edu] archie-orst.edu Free

010: [ archie.au] archie.au-amiga-readmes Free

011: [ archie.au] archie.au-ls-lRt Free

012: [ archie.au] archie.au-mac-readmes Free

013: [ archie.au] archie.au-pc-readmes Free

014: [ pc2.pc.maricopa.edu] ascd-education Free

015: [ archie.au] au-directory-of-servers Free

016: [ cirm2.univ-mrs.fr] bib-cirm Free

017: [ cmns-sun.think.com] bible Free

018: [ zenon.inria.fr] bibs-zenon-inria-fr Free

Keywords:

<space> selects, w for keywords, arrows move, <return> searches, q quits, or ?

────────────────────────────────────────────────────────────────────────────

SWAIS Выбор источника Источники: 23#

Сервер Источник Цена

001: [ archie.au] aarnet-resource-guide Бесплатно

002: [ archive.orst.edu] воздухоплавание Бесплатно

003: [nostromo.oes.orst.ed] Сельхоз-рынок-новости Бесплатно

004: [sun-wais.oit.unc.edu] alt-sys-sun Бесплатно

005: [ archive.orst.edu] alt.drugs Бесплатно

006: [ wais.oit.unc.edu] alt.gopher Бесплатно

007: [sun-wais.oit.unc.edu] alt.sys.sun Бесплатно

008: [ wais.oit.unc.edu] alt.wais Бесплатно

009: [ archive.orst.edu] archie-orst.edu Бесплатно

010: [ archie.au] archie.au-amiga-readmes Бесплатно

011: [ archie.au] archie.au-ls-lRt Бесплатно

012: [ archie.au] archie.au-mac-readmes Бесплатно

013: [ archie.au] archie.au-pc-readmes Бесплатно

014: [ pc2.pc.maricopa.edu] ascd-образование Бесплатно

015: [ archie.au] au-директория-серверов Бесплатно

016: [ cirm2.univ-mrs.fr] bib-cirm Бесплатно

017: [ cmns-sun.think.com] библия Бесплатно

018: [ zenon.inria.fr] bibs-zenon-inria-fr Бесплатно

Ключевые слова:

<пробел> выбор, w - ключ. слова, стелки-движение, <return> поиск, q выход, или ?

────────────────────────────────────────────────────────────────────────────

Каждая строка представляет собой отдельную базу данных (.au в конце

означает, что эта база находится в Австралии, .fr в конце последней строки

означает Францию). И это только первая страница! Если ввести букву K

верхнего регистра, вы перейдете к следующей странице (всего их несколько).

Нажатие буквы J верхнего регистра возвращает на страницу назад.

Первое, что желательно сделать - сообщить программе WAIS, в какой базе

данных следует произвести поиск. Для выбора базы данных передвиньте курсор

на ту строку, которую желательно выбрать (воспользуйтесь клавишами

управления курсором "стрелка вверх" и "стрелка вниз" и нажмите пробел.

Рядом с номером строки появится звездочка. Повторите эту процедуру, пока

не выберете все намеченные к поиску базы данных. Потом нажмите клавишу W, и

вас спросят, какие ключевые слова надо искать. Можно ввести полную строку

таких слов, но разделять их надо пробелом, а не запятой.

Нажмите клавишу return, и поиск начнется.

Пусть, например, вас крайне интересует пшеница. Тогда вы можете выбрать

agricultural-market-news (сельхоз-рынок-новости) и узнать ее текущую цену

на мировом рынке. Но вы хотите знать также и о ее использовании в

религиозных текстах, так что вы выберете еще и Библию и Книгу Мормона. А

что с нею можно делать? Выберем еще книгу рецептов (receips) и поваренную

книгу (usenet-cookbook). А нет ли каких-нибудь решений Верховного Суда, где

упоминается этот злак? Выберем supreme-court. Учтем синонимы? Для этого

выберем roget-thesaurus и просто thesaurus.

Теперь нажмем w и введем wheat (Пшеница). Нажмем enter, и программа

WAIS начнет поиск. По мере просмотра она сообщает, не отключены ли

какие-нибудь базы данных, и если да, то когда можно будет произвести в них

поиск. Примерно через минуту программа сообщит, сколько она нашла позиций.

После этого вы получите новое меню, которое выглядит примерно следующим

образом:

Keywords:

# Score SourceTitleLines

001: [1000] (roget-thesaurus) #465. [results of comparison. 1] Di 19

002: [1000] (roget-thesaurus) #609. Choice. -- N. choice, option; 36

003: [1000] (roget-thesaurus) #465. [results of comparison. 1] Di 19

004: [1000] (roget-thesaurus) #609. Choice. -- N. choice, option; 36

005: [1000] (recipes) aem@mthvax Re: MONTHLY: Rec.Food.Recipes 425

006: [1000] ( Book_of_Mormon) Mosiah 9:96

007: [1000] ( Book_of_Mormon) 3 Nephi 18:185

008: [1000] (agricultural-ma) Re: JO GR115, WEEKLY GRAIN82

009: [ 822] (agricultural-ma) Re: WA CB351 PROSPECTIVE PLANTINGS 552

010: [ 800] ( recipes) kms@apss.a Re: REQUEST: Wheat-free, Suga 35

011: [ 750] (agricultural-ma) Re: WA CB101 CROP PRODUCTION258

012: [ 643] (agricultural-ma) Re: SJ GR850 DAILY NAT GRN SUM72

013: [ 400] ( recipes) pat@jaamer Re: VEGAN: Honey Granola63

014: [ 400] ( recipes) jrtrint@pa Re: OVO-LACTO: Sourdough/Trit 142

────────────────────────────────────────────────────────────────────────────

Ключевые слова:

# Коэфф. Строки заголовков источников

001: [1000] (roget-thesaurus) #465. [результат сравнений. 1] Di 19

002: [1000] (roget-thesaurus) #609. Выбор. -- N.выбор,возможность; 36

003: [1000] (roget-thesaurus) #465. [результат сравнений. 1] Di 19

004: [1000] (roget-thesaurus) #609. Выбор. -- N.выбор,возможность; 36

005: [1000] (recipes) aem@mthvax Re: Ежемесячно: Rec.Food.Recipes 425

006: [1000] ( Book_of_Mormon) Мосайа9:96

007: [1000] ( Book_of_Mormon) 3 Нефи 18:185

008: [1000] (agricultural-ma) Re: JO GR115, ЕЖЕНЕДЕЛЬНО ЗЕРНО82

009: [ 822] (agricultural-ma) Re: WA CB351 ПЕРСПЕКИВНОЕ ВЫРАЩИВАНИЕ 552

010: [ 800] ( recipes) kms@apss.a Re: ЗАПРОС: Без Пшеницы, Сахар 35

011: [ 750] (agricultural-ma) Re: WA CB101 ВЫРАЩИВАНИЕ258

012: [ 643] (agricultural-ma) Re: SJ GR850 DAILY NAT GRN SUM72

013: [ 400] ( recipes) pat@jaamer Re: VEGAN: Медовые клецки63

014: [ 400] ( recipes) jrtrint@pa Re: OVO-LACTO: Болтушка/Трит 142

────────────────────────────────────────────────────────────────────────────

Каждая из строк представляет собой документ, который содержит слово wheat

(пшеница) или какое-то родственное слово. Переставьте курсор (клавишами

"стрелка вверх" и "стрелка вниз") на тот документ, который вы хотите

посмотреть, нажмите enter, и он начнет выводиться на ваш экран.

"Коэффициент" (score) - попытка программы WAIS оценить, насколько данный

документ отвечает цели вашего поиска. Не похоже, чтобы Верховный Суд имел в

последнее время что сказать об этом растении!

А теперь представьте, сколько времени пришлось бы вам провести, ныряя

в различные базы данных просто для того, чтобы найти эти относительно

тривиальные примеры.

8.6 Всемирная сеть (WWW)

Разработанная исследователями Европейской Лаборатории физики

элементарных частиц (European Particle Physics Laboratory) в Женеве,

программа Всемирная сеть (World-Wide Web - WWW) в чем-то похожа на WAIS. Но она

разработана на основе системы, известной как Гипертекст. Слова в одном

документе "привязаны" к другим документам. Это как работать с энциклопедией

- читаешь статью, смотришь ссылки, которые тебя интересуют, и листаешь

страницы, чтобы на эти ссылки посмотреть. Чтобы попробовать поработать с

программой World-Wide Web, свяжитесь по telnet с

ukanaix.cc.ukans.edu

Зарегистрируйтесь как: www. После соединения вы увидите нечто вроде:

Welcome to CERN

The World-Wide Web: CERN entry point

CERN is the European Particle Physics Laboratory in Geneva, Switzerland.

Select by number information here, or elsewhere.

Help[1] About this program

World-Wide Web[2] About the W3 global information initiative.

CERN information[3] Information from and about this site

Particle Physics[4] Other HEP sites with information servers

Other Subjects[5] Catalogue of all online information by subject. Also:

by server type[6] .

** CHECK OUT X11 BROWSER "ViolaWWW": ANON FTP TO info.cern.ch in

/pub/www/src *** Still beta, so keep bug reports calm :-)

If you use this service frequently, please install this or any W3 browser on

your own machine (see instructions[7] ). You can configure it to start

1-7, <RETURN> for more, Quit, or Help:

────────────────────────────────────────────────────────────────────────────

Добро пожаловать в CERN

Всемирная сеть: Входная точка CERN

CERN - Европейская лаборатория физики элементарных частиц в Женеве, Швейцария.

Выберите информацию отсюда или откуда-нибудь еще по номеру.

Помощь[1] Об этой программе

Всемирная сеть[2] О глобальной информационной инициативе W3.

Информация по CERN[3] Информация о данной подсистеме

Физика элем. частиц[4] Другие подсистемы HEP с серверами информации

Другие темы[5] Каталог всей доступной информации по темам.

Каталог по серверам - введите [6] .

** ПРОВЕРЬТЕ БРАУЗЕР X11 "ViolaWWW": АНОН. FTP К info.cern.ch in

/pub/www/src *** Пока бета-версия, так что об ошибках сообщайте спокойно:-)

Если вы часто пользуетесь этой услугой, то установите этот или любой

другой W3 браузер на вашей машине (см. инструкции [7] ). Его можно

настроить.

Запуск 1-7, <RETURN> - другие пункты меню, Quit (выход), или Help (помощь):

────────────────────────────────────────────────────────────────────────────

По этой сети передвигаются, вводя номер, проставленный рядом с

требуемым пунктом. Поэтому, чтобы больше узнать о сети, введите 2. Эта

система тоже ничего плохого не сделает, если с ней просто поиграть.

8.7 Клиенты, или как выловить из сети побольше

Если вы привыкли работать просто под Unix или MS-DOS, тогда вам

понравится образ действий программ gopher и WAIS. Но если вы привыкли к

компьютеру с графическим интерфейсом, такому, как Macintosh, или

IBM-совместимый компьютер с Windows, или Next, то интерфейсы этих программ

покажутся вам весьма примитивными. И даже для пользователя-ветерана MS-DOS

интерфейс Всемирной сети (World-Wide Web) достаточно неуклюж (а некоторые

документы и файлы этой Сети сейчас используют специальный формат, который

может озадачить ваш несчастный компьютер).

Однако есть возможность включить эти услуги в ваш графический

интерфейс пользователя. Фактически сейчас есть способы связаться с Internet

напрямую (а не полагаться на интерфейс - каков бы он ни был - используемый

вашей общедоступной системой) с помощью так называемых программ "клиентов".

Эти программы обеспечивают графический интерфейс для всего - от ftp до

Всемирной сети (World-Wide Web).

Сейчас существует все возрастающее число программ "клиентов" для всего

- от ftp до программ gopher. PSI из Рестона, Вайоминг, которая предлагает

всеамериканский доступ к Internet, фактически требует от своих

пользователей применения таких программ. С помощью протоколов, известных

под именами SLIP и PPP, эти программы связываются с Сетью, используя те же

основные пакеты данных, что и гораздо более мощные компьютеры на связи с

Сетью.

Помимо интеграции в пользовательский интерфейс ("desktop") вашего

компьютера, программы-клиенты дают возможность делать сразу несколько дел

на сети - во время загрузки большого файла в одном окне, можно по программе

разговора Internet болтать с приятелем через другое.

К сожалению, использование программ-клиентов может стоить

приличных денег. Некоторые из них, например, требуют прямого соединения с

Internet через Ethernet. Другие работают через модемные протоколы типа

SLIP, но общедоступные подсистемы, разрешающие такой доступ, могут

требовать за это дополнительно от 25 до 200 долларов в месяц.

Более подробную информацию по поводу установки одной из таких

связей можно получить у вашего системного администратора.

8.8 Когда что-то не так

По мере того, как Internet становится все более и более популярным,

его ресурсы работают все более и более напряженно. Если попытаться в

середине дня использовать программу gopher, по крайней мере на Восточном

Побережье США, можно заметить, что перед появлением тех или иных меню или

баз данных проходит очень долгое время. Иногда приходит сообщение, что со

службой, с которой вы хотите связаться, работает сейчас слишком много

людей, и вы связаться не можете. В этом случае можно только либо

попробовать снова через минут 20, либо подождать до конца дня, когда

нагрузка, вероятно, снизится. Если такая вещь происходит при работе с

программой veronica, попробуйте какой-то другой из ее входов.

Если вы выбираете файл с помощью программы gopher, то иногда вам будет

задан вопрос, не желаете ли вы его сохранить под каким-нибудь неимоверно

длинным именем (это опять-таки привет от наших друзей - системных

администраторов: Unix разрешает до 128 символов в имени файла, вот они и

стараются). В некоторых программах коммуникаций под MS-DOS имя, занимающее

более одной строки, можно пройти клавишей "забой", сокращая его до одной

строки, чтобы дать более простое имя. Этой клавишей можно пройти до самого

начала имени. Когда же вы будете готовы к загрузке файла в свой компьютер,

помните, что имя файла будет укорочено согласно существующим в MS-DOS

ограничениям. И хуже того, компьютер может вообще отказаться это

выполнять. Что тогда делать? Тогда не запоминать этот файл в домашней

директории, а отправить самому себе по электронной почте. Он появится у вас

на почте сразу после выхода из программы gopher. Теперь используйте команду

mail для записи его в своей домашней директории - в этот момент вы

можете его назвать как угодно. Теперь его можно загрузить в свой компьютер.

8.9 Куда обратиться с вопросами

Дэвид Риггинс (David Riggins) ведет список программ gopher по типам и

категориям. Самые последние можно найти в подсистеме ftp ftp.einet.net, в

директории pub. Ищите файл с именем вроде "gopher-jewels.txt." Можно также

включить себя в список рассылки, чтобы последние версии автоматически

попадали в ваш почтовый ящик. Пошлите по почте сообщение в адрес

gopherjewelslist-request@tpis.cactus.org (ага, первая часть это

действительно одно слово). Строку "subject:" оставьте пустой, а в качестве

текста сообщения задайте SUBSCRIBE (подписка).

Блэйк Гампрехт (Blake Gumprecht) ведет список программ gopher и

подсистем telnet, относящихся к правительственным учреждениям или

поддерживаемых правительством. Каждые три недели он посылает этот список в

группы news.answers и soc.answers на Usenet. Его можно также получить

через anonymous ftp от rtfm.mit.edu как файл

/pub/usenet/news.answers/us-govt-net-pointers.

Студенты Школы информации и библиотечного дела Мичиганского

Университета (University of Michigan's School of Information and Library

Studies) недавно составили отдельные списки ресурсов Internet в 11

конкретных областях, от воздухоплавания до театра. Эти списки можно

получить с помощью программы gopher по адресу gopher.lib.umich.edu, в меню

"What's New and Featured Resources" (Что нового и характерные ресурсы).

Группы новостей Usenet comp.infosystems.gopher и comp.infosystems.wais

- это те места, в которых размещаются дискуссии о программах gophers и WAIS

соответственно.

Проект Interpedia является попыткой провести программы gopher на шаг

дальше путем создания электронного репозитория для всей интересной и

полезной информации: которую можно получить от сети или ее пользователей.

Чтобы попасть в список рассылки этого проекта: пошлите сообщение по

электронной почте с пустой строкой "subject:" и текстом "subscribe" на

адрес interpedia-request@telerama.lm.com. Вы получите документацию по

проекту через анонимный ftp по адресу ftp.lm.com в директории

pub/interpedia directory.

Глава 9: УСОВРШЕНСТВОВАННАЯ ЭЛЕКТРОННАЯ ПОЧТА

9.1 Файлы по почте

Сама по себе электронная почта является мощным средством, и сейчас вы,

наверное, рассылаете письма по электронной почте во все концы света. Может

быть, вы даже состоите в некоторых списках рассылки. Но электронная почта

может гораздо больше, чем просто пересылать письма. Если ваша система не

имеет доступа к ftp или имеет доступ не ко всем подсистемам ftp,

существующим в Сети, то вы можете распорядиться, чтобы файлы и программы

пересылали прямо в ваш почтовый ящик. А с помощью некоторых простых

способов можно пересылать по электронной почте файлы данных - электронные

таблицы или даже целые программы друзьям и коллегам по всему свету.

Ключом к таким возможностям является набор программ, известных как

кодировщики и декодеры. При всех своих колоссальных возможностях

электронная почта Сети имеет одно существеннейшее ограничение: она не может

работать с графическими или управляющими символами, которые есть даже в

самой простейшей компьютерной программе. Однако кодировщики могут

переводить их в вид, который доступен для электронной почты, а декодеры

возвращают их в тот вид, в котором они должны быть. Если ваша система

основана на Unix, то почти наверняка у вас есть кодировщик и декодер,

доступные во время связи. Эти программы позволяют также использовать

программы, направляемые по почте в различные группы Usenet, такие, как

comp.binaries.ibm.pc.

Если и вы, и ваш абонент оба желаете обмениваться файлами в системе на

основе Unix, то вам повезло, поскольку практически все системы на основе

Unix имеют доступные при связи программы кодировщик/декодер. Предположим

пока, что у нас именно этот случай. Прежде всего, загрузите тот файл,

который хотите послать подруге, в свою систему (как загрузить файл в

директорию с вашим именем или в свою "домашнюю" директорию - спросите у

системного администратора, если не знаете сами). Потом введите:

uuencode файл файл> файл.uu

и нажмите enter. "Файл" - это имя файла, который желательно подготовить к

передаче по почте - и в самом деле, это имя надо ввести дважды! Символ >

представляет собой команду системы Unix, дающую указание системе назвать

"закодированный" "файл.uu" (а на самом деле вы можете выбрать любое имя).

А теперь займемся отправкой сообщения по почте. Простой и грубый

способ состоит в том, чтобы ввести

mail подруга

где "подруга" - адрес вашей подруги. В строке subject введите имя

включаемого файла. Когда получите пустую строку, введите

~r file.uu

или любое имя, которым вы назвали этот файл, и нажмите enter. (В некоторых

системах ~ может не сработать; в этом случае спросите системного

администратора, какой символ использовать). Файл будет введен в ваше

почтовое сообщение. Нажмите control-D, и ваш файл уже в пути!

С другой стороны, когда ваша подруга обратится к своему почтовому

ящику, ей придется передать файл в свою домашнюю директорию. Для этого она

должна ввести:

uudecode имя.файла

и нажать enter. Эта команда создаст новый файл в директории с ее именем, и

имя файла будет то, которое вы ему дали. Теперь она может загрузить этот

файл в свой компьютер. Но перед тем, как его использовать, ей придется

открыть его в каком-нибудь текст-процессоре и удалить почтовый заголовок,

которым файл был "проштемпелеван". Если же ваша почтовая программа

автоматически добавляет "подпись", скажите ей об этом, чтобы она ее тоже

удалила.

9.2 Прием файлов

Если кто-то переслал вам файл по электронной почте, то для того, чтобы

принять его в пригодном для использования виде, надо выполнить несколько

шагов. Если вы используете простую почтовую программу, то перейдите к почте

и введите

w # имя.файла

где # - номер сообщения, которое желательно передать, а имя.файла - имя,

которое желательно дать результирующему файлу. При работе с pine вызовите

сообщение, а затем нажмите клавишу O, потом E. Вас попросят ввести имя

файла. При работе с elm вызовите сообщение, а затем нажмите клавишу S. Вы

увидите нечто вроде этого:

=file.request

Введите новое имя файла и нажмите enter (если вы нажмете enter без

ввода имени файла, сообщение будет запомнено в другой папке, а не в вашей

домашней директории).

Во всех трех случаях выйдите из почтовой программы и вернитесь в

командную строку вашей системы. Поскольку файл для пересылки был

закодирован, теперь придется запустить декодер. Для этого в командной

строке введите:

uudecode имя.файла

где имя.файла - это тот файл, который вы создали, работая с почтой.

Программа uudecode создаст новый, не компрессированный двоичный файл. В

некоторых случаях может оказаться необходимым обработать его еще какими-то

программами (например, если он архивирован в формате "tar"), но обычно он

уже готов к загрузке в ваш компьютер (где может оказаться необходимым

применить программу распаковки вроде PKXZIP).

9.3 Посылка файлов в подсистемы вне Internet

А что если ваша подруга имеет связь только с системой не типа Unix,

такой, как CompuServe или MCIMail? Существуют программы для компьютеров

MS-DOS, Apple и Amiga, позволяющие кодировать и декодировать файлы.

Конечно, поскольку вы не можете послать их вашей подруге по электронной

почте (а как она их будет декодировать?), вам придется сперва посылать их

обычной почтой или передать на дискете. После этого она может принимать

файлы по электронной почте и проходить через все описанные выше процессы

(но только на своем компьютере). Не забудьте передать ей и

программу-кодировщик, если она тоже захочет посылать вам файлы.

Для машин с MS-DOS понадобятся программы uunecode.com и uudecode.com.

Обе эти программы можно найти через ftp anonymous при wuarchive.wustl.edu в

директории /mirrors/msdos/starter. Версию MS-DOS также легко использовать

как версию Unix: просто введите

uudecode имя_файла.расширение

и нажмите enter.

Пользователи Mac должны взять программу по имени uutool, которую

можно найти в директории info-mac/util на sumex-aim.stanford.edu.

Перед тем, как послать кому-то очень большой файл, стоит дважды

подумать. Конечно, большие подсистемы, присоединенные непосредственно к

Internet, возможно, умеют работать с мегафайлами, но многие системы

поменьше - не могут. Некоторые коммерческие системы, такие, как CompuServe

и MCIMail, ограничивают размер сообщений, которые пользователям разрешено

получать. Сеть Fidonet вообще не разрешает передачу кодированных сообщений.

А вообще говоря, файлы размером 30000 байт или около того являются верхней

границей надежности работы с системами вне Internet.

9.4 Получение по электронной почте файлов FTP

Чтобы дать людям возможность обходиться без доступа к ftp, на многих

подсистемах ftp имеются серверы почты (известные также как серверы

архивов), позволяющие брать файлы с помощью электронной почты. Вы просто

посылаете запрос одной из таких машин, а она возвращает желаемый файл. Как

и при работе с ftp, вы можете найти все - от исторических документов до

программного обеспечения (но имейте в виду, что прямой доступ к ftp гораздо

быстрее и расходует меньше ресурсов, чем электронная почта).

Среди наиболее интересных или полезных почтовых серверов есть такие:

mail-server@rtfm.mit.edu Файлы с "часто задаваемыми вопросами",

относящимися к Usenet; списки сенаторов и конгрессменов Соединенных Штатов

по штатам и их адреса и номера служебных телефонов.

archive-server@eff.org Информация о фонде Electronic Frontier

Foundation; документы о юридических изданиях в Сети.

archive-server@cs.widener.edu Резервные копии издания Computer

Underground Digest и все факты, которые вам может захотеться узнать о

Симпсонах ("The Simpsons").

netlib@uunet.uu.net Программы для разных типов персональных

компьютеров; архивы прошлых поступлений от различных групп новостей на

Usenet.

archive-server@ames.arc.nasa.gov Файлы текстов и картинок

(GIF-формат) по космической тематике.

service@nic.ddn.mil Подробная информация о Internet.

Большая часть почтовых серверов работают единообразно - вы посылаете

сообщение по электронной почте, объясняющее, какой файл вам нужен и как вы

хотите, чтобы вам его послали. Самая важная команда - "send", которая

сообщает компьютеру, что вы просите его послать некоторый файл.

Однако предварительно вы должны узнать, где у почтового сервера

хранится этот файл, потому что вы должны сообщить, в какой директории или

субдиректории он находится. Для этого есть пара способов. Можно послать

сообщение по электронной почте на архив-сервер, состоящее из одной строки:

index

Сервер после этого пошлет вам список директорий из своей корневой, или

главной директории. Потом вы должны послать второе сообщение из одной

строки тому же архив-серверу:

index директория/субдиректория

где указывается директория или путь директории для которой вы хотите

получить листинг. Другой способ - послать сообщение по электронной почте

нашему старому другу archie, который должен ответить вам точное

местонахождение файла на архив-сервере (однако параллельно - с листингами

для всех прочих подсистем, которые содержат этот файл).

Узнав имя файла и путь директории, составьте для архив-сервера

сообщение вроде следующего:

send директория/субдиректория/файл

Отправьте это сообщение, и через небольшое время - от пары минут до

пары дней - вы найдете у себя в почтовом ящике в виде сообщения копию

файла, который вы запрашивали. Конкретное время, которое понадобится на

передачу того или иного файла, зависит от многих факторов, в том числе от

того, сколько запросов стоят в очереди впереди вашего (почтовые серверы

могут обрабатывать ограниченное количество запросов одновременно), и от

состояния связи между вами и вашим сервером.

С виду просто. Чуть сложнее обстоит дело, если вам нужна программа, а

не документ. Программы или другие файлы, содержащие необычные символы или

строки длиннее 130 символов (например, графические файлы), требуют

специальной обработки почтовым сервером, чтобы они прошли по электронной

почте. Потом они должны быть пропущены через хотя бы одну

программу-конвертер для приведения их в тот вид, в котором они будут

использоваться. Чтобы гарантировать приход к вам программы или любого

другого файла "не подлежащего передаче по почте", включите в свое сообщение

серверу еще одну строку:

encoder

Это преобразует файл в кодированную форму. Чтобы его декодировать, сначала

следует передать этот файл-сообщение в вашу домашнюю директорию в виде

файла.

Некоторая дополнительная сложность возникает тогда, когда вам

требуется достаточно длинный файл. Многие подсистемы Сети могут передавать

почту лишь в течение ограниченного времени. Чтобы гарантировать, что вы

получите файл целиком, дайте почтовому серверу указание разбить его на

небольшие фрагменты. Это делается включением в ваше сообщение строки,

подобной следующей:

size 100000

Это дает почтовому серверу сведения о максимальном размере в байтах

каждого сегмента файла. Для подсистем UUCP рекомендуется данный конкретный

размер. Подсистемы Internet и Bitnet могут работать с фрагментами до

300000. Когда вы получите по почте такие файлы, передайте их в свою

домашнюю директорию. Выйдите из почты и вызовите каждый файл в

текст-процессор своей системы и удалите заголовки и "хвосты". После этого

введите в командной строке своей системы:

cat файл1 файл2 > большой_файл

где файл1 - первый файл, файл - второй файл, и так далее. Символ > дает

системе указание объединить их в цельный файл с именем большой_файл (или

как вы его там назовете). После запоминания файла в своей домашней

директории (см. выше в разделе 9.2), можно запустить программу uudecode,

tar и т. д. Однако следует предостеречь: Если файл достаточно длинный, и

разбит на фрагменты, - подумайте, сколько времени у вас займет скачивание

всей этой информации, особенно если у вас модем 2400 бод!

Есть и другие почтовые серверы. Чтобы получить их список, пошлите по

электронной почте сообщение к mail-server@rtfm.mit.edu:

send usenet/comp.sources.wanted/How_to_find_sources_(READ_THIS_BEFORE_POSTING)

Следует писать все буквы и символы точно так, как здесь приведено.

Некоторые почтовые серверы используют иное программное обеспечение, что

требует других команд, несколько отличных от приведенных выше. Вообще

говоря, если вы пошлете почтовому серверу сообщение, в котором сказано

только:

help

вы должны получить файл, в котором детально описаны команды сервера.

А что делать, если нужный вам файл не находится ни на одном из этих

серверов? Здесь на сцене появляется ftpmail. Эта служба, которую ведет

Digital Equipment Corp. в штате Калифорния, может связаться почти с любой

подсистемой ftp в мире, взять нужный вам файл и послать его вам по почте.

Использовать ее просто - послать сообщение по электронной почте по адресу

ftpmail и включить в это сообщение последовательность команд, сообщающих

системе, где найти файл, который вам нужен, и в каком формате его

переслать.

Составьте сообщение по электронной почте на адрес:

ftpmail@decwrl.dec.com

Строку "subject:" оставьте пустой. Внутри сообщения вы можете дать

несколько команд. Первой строкой должна быть:

reply адрес

где "адрес" - ваш адрес электронной почты. Следующая строка должна быть

connect host

где "host" - та система, которая содержит интересующий вас файл (например:

wuarchive.wustl.edu). Другие команды, которые вам следует рассмотреть, это

"binary" (обязательно для программных файлов); "compress" (уменьшает размер

файла для ускорения передачи) и "uuencode" (кодирует файлы так, что с

полученными файлами можно работать). Последняя строка вашего сообщения

должна состоять из одного только слова "quit".

Допустим, что вам нужна копия конституции США. С помощью archie вы

нашли файл, который называется (странно!) constitution, на подсистеме ftp

archive.cis.ohio-state.edu, в директории /pub/firearms/politics/rkba. Вы

посылаете по адресу ftpmail@decwrl.dec.com сообщение, подобное следующему:

reply adamg@world.std.com

connect archive.cis.ohio-state.edu

binary

compress

uuencode

get pub/firearms/politics/rkba/constitution

quit

Когда вы получите файл в свой почтовый ящик, скопируйте его в файл

описанной выше процедурой. Прогоните его через uudecode. Теперь

введите

uncompress имя.файла

чтобы с файлом можно было работать.

Так как этот файл был текстовый, команду "binary" можно было заменить

на "ascii" и убрать "uuencode". Для программ эти строки все же стоит

оставить. Предупреждение относительно ftpmail: эта служба стала настолько

популярной, что затребованные файлы могут прибыть через неделю или позже.

9.5 Oracle знает все

Еще одна услуга, которую вы можете получить по электронной почте -

консультация от Usenet Oracle. У Oracl вы можете спросить все, что угодно,

и получите ответ (а понравится вам этот ответ или нет - это отдельный

вопрос).

Прежде всего вам захочется получить инструкции о том, как

адресоваться к Oracle (он, или она, или оно к таким вещам очень

чувствителен и любит, чтобы к нему обращались в почтительном, торжественном

и просто подхалимском тоне). Направьте свое электронное послание по адресу:

oracle@iuvax.cs.indiana.edu

В строке "subject:" введите

help

и нажмите enter. В самом этом сообщении ничего пока говорить не надо - по

крайней мене сейчас. Нажмите control-D для отсылки своего запроса о помощи.

Через несколько часов Oracle пришлет вам подробные инструкции. Они

содержатся в достаточно длинном файле, так что перед тем, как начать его

читать, включите режим регистрации в своем коммуникационном программном

обеспечении, чтобы запомнить читаемое у себя в компьютере (или запомните

сообщение в файле своей домашней директории и загрузите его к себе в

компьютер). Когда вы его переварите, вы будете в состоянии составить запрос

к Oracle. Пошлите его по указанному выше адресу, но в строке "subject"

дайте описание вашего вопроса. Ответ придет в течение двух дней. И не

удивляйтесь, если найдете у себя в почтовом ящике вопрос: Oracle берет

плату, заставляя отвечать на вопросы тех, кто ищет знания!

Глава 10: НОВОСТИ СО ВСЕГО СВЕТА

10.1 Clarinet: ЮПИ (UPI), Дэйв Барри (Dave Barry) и Дилберт (Dilbert)

Название Usenet "группы новостей" (newsgroups) не вполне соответствует

содержанию. Эти группы могут быть интересными, информативными и ценными с

образовательной точки зрения, но они часто не являются новостями - по

крайней мере в том смысле, в котором большинство людей понимают это слово.

Но на Сети есть несколько источников новостей и спортивной хроники.

Одним из самых крупных их источников является Clarinet - компания в

Купертино, Калифорния, которая распространяет новости телеграфных агентств,

а также службы новостей, посвященных компьютерам, и даже полоса комиксов

Дилберта (Dilbert) в форме Usenet.

Распространяемые в форме Usenet статьи и колонки Clarinet организованы

в более чем 100 групп новостей (и в этом случае название вполне

соответствует сути). Некоторые из них сосредоточены на очень узкой области,

например, clari.news.gov.taxes. Общие новости и новости спорта приходят от

United Press International; новости по компьютерам исходят от службы

NewsBytes; и еще от некоторых синдикатов.

Поскольку Clarinet выставляет счета за свои услуги, не все местные

системы содержат его статьи. Те, которые это делают, выносят их в группы

новостей Usenet, название которых начинается с "clari". Как и в других

иерархиях Usenet, в этой имена начинаются с самой широкой области и

заканчиваются наиболее конкретной. Некоторые из них включают деловые

новости (clari.biz); общие национальные и иностранные новости политические

события и т. п. (clari.news), спортивные новости (clari.sports); обзоры

Майка Ройко (Mike Royko), мисс Мэннерз (Miss Manners), Дэйва Барри (Dave

Barry) и других (clari.feature); а также отчеты NewsBytes по компьютерам и

телекоммуникациям (clari.nb). Поскольку Clarinet начинался в Канаде,

существует специальный набор групп новостей clari.canada. Группы новостей

clari.nb делятся на специальные группы по типам компьютеров (например,

clari.nb.apple).

Статьи в группах новостей clari обновляются постоянно. Есть даже

группы новостей "бюллетени" для срочных сообщений: clari.news.bulletin и

clari.news.urgent. Clarinet также поддерживает группы новостей для срочных

сведений, которые относятся к событиям текущего момента (масштабные

стихийные бедствия или перевороты в крупных странах и т. п.).

Иногда в группах новостей clari можно обнаружить статьи, которые

попали туда случайно. Истории о бывшем мэре Вашингтона, округ Колумбия

Мэррионе Барри, например, часто переплетаются с обзорами Дэйва Барри.

Это происходит из-за метода работы телеграфных агентств. UPI

использует для рассылки своих материалов по газетам и радиостанциям

трехбуквенные коды, и редакторы в спешке (сроки-то поджимают!) иногда

вбивают неверный код.

10.2 Рейтер (Reuters)

Это, грубо говоря, британский аналог ЮПИ или Ассошиэйтед пресс. Msen -

общедоступная система в Мичигане, постоянно поставляет рассылки Рейтер в

несколько конференций стиля Usenet. Если ваша подсистема подписана на эту

услугу, то ищите группы новостей, имена которых начинаются с msen.reuters.

10.3 США Сегодня (USA Today)

Если в вашей системе нет групп новостей clari или msen.reuters, то

держаться в курсе новостей вам помогут другие доступные в Сети способы.

Агентство Ю-Эс-Эй ТУДЭЙ (USA Today) было первооткрывателем жанра

электронных газет - оно продавало свои сведения доскам объявлений и

системам связи по всей стране в течение нескольких лет. Cleveland Free-Net

предоставляет электронную версию Ю-Эс-Эй ТУДЭЙ (наряду с другими услугами)

бесплатно. В настоящее время газеты входят только пять дней в неделю, так

что новости уикендов придется брать где-то в другом месте.

Telnet: freenet-in-a.cwru.edu или

freenet-in-b.cwru.edu

После соединения и регистрации ищите следующий пункт меню: NPTN/USA

TODAY HEADLINE NEWS. (Заголовки новостей NPTN/USA TODAY) Введите номер

этого пункта меню и нажмите enter. Вы увидите меню, в котором содержится

несколько названий базовых категорий, например, спорт или телекоммуникации.

Выберите одну из них, и вы получите другое меню, в котором названы десять

последних дат публикаций. Каждый пункт содержит резюме дневных новостей по

данной теме размером в один абзац.

10.4 Национальное Общественное Радио (National Public Radio)

Загляните в группу новостей alt.radio.networks.npr в Usenet для

получения отчета по новостям NPR, показанного как "All Things Considered"

(Все рассмотренные дела). Эта группа новостей также является местом для

обсуждения Сети, проводимых в ней мероприятий, отдельных персоналий и

политики.

10.5 Мир сегодня: от Беларуссии до Бразилии

Радио "Свободная Европа" и "Свобода" - радиостанции, вещающие на

бывшие коммунистические страны в Восточной Европе. Их отделы хроники каждый

день подготавливают сводку новостей по этим странам и распространяют эту

сводку по Сети, через список рассылки Bitnet или группы новостей Usenet.

Чтобы получать такие сводки непосредственно в свой почтовый ящик, пошлите

сообщение по адресу:

listserv@ubvm.cc.buffalo.edu

Строку "subject" оставьте пустой, а в качестве сообщения укажите:

subscribe rferl-l Свое имя

Или можно просматривать бюллетени в группе новостей Usenet

misc.news-east-europe.rferl.

Ежедневно обновляемую хронику из Бразилии (на португальском языке)

можно получить из Университета Сан-Паулу (University of Sao Paulo). С

помощью анонимного ftp свяжитесь с:

uspif.if.usp.br

Для переключения на директорию whois используйте команду cd. Сводки

новостей хранятся в форме: NEWS.23OCT92;1. Но чтобы их получить, не

ставьте точку с запятой и не употребляйте заглавных букв, например:

get news.23oct92

Ежедневные сводки новостей из Франции (на французском) можно получить

в National Capital FreeNet в Оттаве, Онтарио. Свяжитесь по Telnet с

freenet.carleton.ca

и зарегистрируйтесь как: guest. В главном меню выберите номер пункта "The

Newsstand", а затем "La presse de France."

10.6 Организации, передающие новости по электронной почте

Некоторые газеты, телевизионные станции и сети, а также другие

организации, работающие с новостями, приветствуют желание своих читателей

или зрителей связываться с ними с помощью электронных средств через адреса

электронной почты Internet. Среди них:

The Middlesex News, Framingham, Mass. sysop@news.ci.net

The Boston Globe voxbox@globe.com

WCVB-TV, Boston, Mass. wcvb@aol.com

NBC News, New York, N.Y. nightly@nbc.com

The Ottawa Citizen, Ottawa, Ont. ottawa-citizen@freenet.carleton.ca

CJOH-TV, Ottawa, Ont. ab363@freenet.carleton.ca

St. Petersburg (Fla.) Times 73174.3344@compuserve.com

Illinois Issues, Springfield, Ill. gherardi@sangamon.edu

WTVF-TV, Nashville, Tenn. craig.ownsby@nashville.com

10.7 Куда обратиться с вопросами

Группа новостей clari.net.newusers на Usenet содержит много различных

статей о Clarinet и способах поиска интересующих вас новостей.

Чтобы принять участие в обсуждении будущего электронной прессы,

подпишитесь на включение в список рассылки "Репортаж и исследования с

применением компьютеров" (Computer Assisted Reporting and Research) на

Bitnet. Пошлите по почте сообщение

Subscribe carr-l Свое имя

по адресу listserv@ulkyvm.bitnet.

Глава 11: IRC, MUD И ДРУГИЕ ВЕЩИ, КОТОРЫЕ ВЕСЕЛЕЕ, ЧЕМ КАЖУТСЯ

Многие системы Сети дают доступ к некоторым интерактивным службам,

позволяющим поддерживать живой разговор или играть в режиме реального

времени в какие-нибудь игры с людьми, рассеянными по всему миру. Чтобы

узнать, предлагает ли это ваша местная система, спросите у системного

администратора или просто попробуйте - если ничего не произойдет, то ваша

система таких услуг не предоставляет. Вообще говоря, если у вас есть telnet

и ftp, то вероятно, что и эти услуги у вас тоже есть.

11.1 Разговор (Talk)

Это аналог телефонного разговора, который предоставляет Сеть. Для него

требуется, чтобы и вы, и ваш абонент имели доступ к этой функции и при этом

находились на связи одновременно. Чтобы этим воспользоваться, введите:

talk пользователь@подсистема.имя

где пользователь@подсистема.имя - адрес электронной почты вашего абонента.

Она (ваш абонент) увидит у себя на экране нечто вроде:

talk: connection requested by yourname@site.name

talk: respond with: talk yourname@site.name

────────────────────────────────────────────────────────────────────────────

talk: связь запрошена от ваше-имя@подсистема.имя

talk: отвечайте: talk ваше-имя@подсистема.имя

────────────────────────────────────────────────────────────────────────────

Чтобы начать разговор, она должна будет ввести в командной строке своей

системы:

talk ваше_имя@подсистема.имя

указав ваш электронный адрес. У вас обоих после этого появятся на экране

два окна - верхнее и нижнее. Она будет видеть все, что вы вводите в одном

окне, а вы - все, что вводит она в другом. Для разъединения нажмите

control-C.

Одно замечание: Общедоступные системы, использующие компьютеры Sun, иногда

плохо работают с программой talk. Если она не работает, попробуйте ввести

otalk

или

ntalk

вместо команды talk. При этом, однако, абонент на другом конце должен иметь ту

же самую программу на связи.

11.2 Релейный разговор (Internet Relay Chat - IRC)

IRC - это программа, которая позволяет поддерживать живой разговор с

клавиатуры с людьми по всему миру. Она очень похожа на международный

радиотелефон - и даже использует "каналы". Введите что-нибудь на своем

компьютере, и оно немедленно отобразится по всему миру у каждого, кто

окажется на одном с вами канале. Вы можете включиться в существующий

разговор или начать свой собственный. Можете даже создать приватный канал

для небольшого числа людей - хоть одного или двух. И так же как и с

радиотелефоном, можете дать себе даже оригинальную кличку или псевдоним.

В настоящее время IRC объединяет системы в 20 различных странах, от

Австралии до Гонконга и Израиля. К сожалению, она похожа на telnet - на

вашей подсистеме она либо есть, либо нет. Если она есть, просто введите

irc

и нажмите enter. Вы увидите нечто вроде следующего:

*** Connecting to port 6667 of server world.std.com

*** Welcome to the Internet Relay Network, adamg

*** Your host is world.std.com, running version 2.7.1e+4

*** You have new mail.

*** If you have not already done so, please read the new user information with

+/HELP NEWUSER

*** This server was created Sat Apr 18 1992 at 16:27:02 EDT

*** There are 364 users on 140 servers

*** 45 users have connection to the twilight zone

*** There are 124 channels.

*** I have 1 clients and 3 servers

MOTD - world.std.com Message of the Day -

MOTD - Be careful out there...

MOTD -

MOTD - ->Spike

* End of /MOTD command.

23:13 [1] adamg [Mail: 32] * type /help for help

------------------------------------------------------------------------------

────────────────────────────────────────────────────────────────────────────

*** Связь с портом 6667 сервера world.std.com

*** Добро пожаловать в релейную сеть Internet, adamg

*** Ваша местная система - world.std.com, рабочая версия 2.7.1e+4

*** Вам пришло новое письмо.

*** Если вы это уже сделали, пожалуйста прочтите информацию для нового

пользователя +/HELP NEWUSER

*** Этот сервер создан в субботу 18 апреля 1992 в 16:27:02 Восточного времени

*** Всего 364 пользователя на 140 серверах

*** 45 пользователей имеют соединения с зоной сумерек

*** Всего 124 канала.

*** У меня 1 клиентов и 3 серверов

MOTD - world.std.com Сообщения текущего дня

MOTD - Здесь осторожно....

MOTD -

MOTD - ->Spike

* Конец команды /MOTD.

23:13 [1] adamg [почта: 32] * для получения подсказки введите /help

----------------------------------------------------------------------

────────────────────────────────────────────────────────────────────────────

Сейчас вы находитесь на канале 0 - "нулевом" канале, в котором вы

можете просматривать различные файлы подсказок, но кроме этого у вас мало

возможностей. Как вы видите, IRC занимает весь ваш экран. Верхняя часть

экрана представляет собой место, в котором появляются сообщения. Последняя

строка - это место, где вводятся ваши команды и сообщения системе IRC. Все

команды IRC начинаются символом /. Он сообщает компьютеру, что вы вводите

команду, а не сообщение. Чтобы посмотреть, какие каналы вам доступны,

введите:

/list

и нажмите enter. Вы увидите нечто вроде:

*** Channel Users Topic

*** #Money 1 School CA$H (/msg SOS_AID help)

*** #Gone 1 ----->> Gone with the wind!!! ------>>>>>

*** #mee 1

*** #eclipse 1

*** #hiya 2

*** #saigon 4

*** #screwed 3

*** #z 2

*** #comix 1 LET'S TALK 'BOUT COMIX!!!!!

*** #Drama 1

*** #RayTrace 1 Rendering to Reality and Back

*** #NeXT 1

*** #wicca 4 Mr. Potato Head, R. I. P.

*** #dde^mhe` 1 no'ng chay? mo*? ...ba` con o*iiii

*** #jgm 1

*** #ucd 1

*** #Maine 2

*** #Snuffland 1

*** #p/g! 4

*** #DragonSrv 1

────────────────────────────────────────────────────────────────────────────

*** Канал Пользователей Тема

*** #Money 1 Школьная касса CA$H (/сбщ SOS_AID помощь)

*** #Gone 1 ----->> Унесенные ветром!!! ------>>>>>

*** #mee 1

*** #eclipse 1

*** #hiya 2

*** #saigon 4

*** #screwed 3

*** #z 2

*** #comix 1 ПОГОВОРИМ ПРО КОМИКСЫ!!!!!

*** #Drama 1

*** #RayTrace 1 Выход в реальность и обратно

*** #NeXT 1

*** #wicca 4 Мистер Картофельная Голова. Да Почиет с миром!

*** #dde^mhe` 1 no'ng chay? mo*? ...ba` con o*iiii

*** #jgm 1

*** #ucd 1

*** #Maine 2

*** #Snuffland 1

*** #p/g! 4

*** #DragonSrv 1

────────────────────────────────────────────────────────────────────────────

Поскольку IRC допускает большое число каналов, список может

прокручиваться на экране, и у вас может возникнуть желание включить

регистрацию экрана для того, чтобы запомнить весь список. Заметьте, что у

каналов всегда есть имена, а не номера. Каждая строка в списке содержит имя

канала, число тех, кто сейчас с ним связан и, возможно, специфику темы,

которой канал посвящен. Для переключения на конкретный канал введите

/join #канал

где "#канал" - имя канала, и нажмите enter. Некоторые "общедоступные"

каналы в действительности требуют приглашения от кого-нибудь, кто уже в

канале находится. Чтобы запросить приглашение, введите

/who #имя_канала

где #имя_канала - имя желательного канала, и нажмите enter. Потом спросите

кого-нибудь, у кого около имени стоит символ @, можете ли вы

присоединиться. Обратите внимание, что при вводе канала следует включать

символ #. Выберите такой, на котором есть несколько пользователей, чтобы вы

могли увидеть IRC в действии.

Если этот канал занят, то как только вы присоединитесь, верхняя часть

вашего экрана заполнится сообщениями. Каждое из них будет начинаться с

псевдонима человека в IRC, за которым будет следовать текст сообщения.

Поначалу это может показаться очень сложным. Одновременно могут идти

несколько разговоров, и иногда сообщения приходят настолько быстро, что их

почти не удается прочитать.

Но постепенно вы войдете в ритм работы канала, и ситуация станет более

осмысленной. Может быть, вы даже захотите внести свою лепту (и не

удивляйтесь, если сразу увидите сообщение в свой адрес - в некоторых

каналах новичков приветствуют немедленно). Чтобы ввести сообщение ко всем

пользователям, просто напишите его внизу экрана (компьютер по отсутствию

косой черты в начале поймет, что это сообщение, а не команда) и нажмите

enter.

Общедоступные сообщения содержат в скобках имя пользователя,

например:

<tomg>

Если вы получите от кого-то частное сообщение, имя пославшего будет

заключено между звездочками, вот так:

*tomg*

11.3 Команды IRC

Замечание: После каждой команды нажимайте enter.

/away Если вас позвали на кухню выключить газ под пригорающей

сковородкой, отдайте эту команду. Она даст остальным знать,

что вы еще на связи, но на минутку отошли от компьютера.

/help Выводит список команд, для которых есть файл помощи. Вы

увидите приглашение "topic:" (тема) Введите тему, по которой

хотите получить информацию, и нажмите enter. Для выхода из

подсказки просто нажмите enter.

/invite Приглашает другого пользователя IRC присоединиться к

разговору.

/invite fleepo #hottub

пошлет приглашение к fleepo присоединиться к каналу #hottub.

Имя канала указывать не обязательно.

/join Эта команда используется для переключения на определенный

канал или его создания, например:

/join #hottub

Если такой канал существует и не является приватным, вы к

нему присоединитесь. В противном случае канал будет создан.

Обратите внимание, что первым символом должен быть #.

/list Выводит список общедоступных каналов, их темы (если указаны)

и текущее число их пользователей. Скрытые и приватные каналы

не показываются.

/m имя Послать этому пользователю приватное сообщение

/mode Позволяет определить, кто может присоединиться к созданному

вами каналу.

/mode #канал +s

создает секретный канал.

/mode #канал +p

делает канал приватным

/nick Позволяет сменить имя, под которым видят вас остальные.

/nick fleepo

сменит ваше имя в текущем сеансе на fleepo. Остальные

по-прежнему могут использовать /whois для определения вашего

адреса электронной почты. Если вы хотите войти в канал, где

кто-то уже использует это имя, IRC попросит вас выбрать

другое имя.

/query Устанавливает режим приватного разговора между вами и другим

пользователем IRC. Чтобы это сделать, введите

/query имя

Все сообщения будут теперь пересылаться только этому лицу.

Если она введет

/query имя

где имя является вашим, то вы установите режим приватного

разговора. Для выхода из этого режима введите

/query

без дополнений. Находясь в режиме query, вы и ваш партнер

можете "слушать" дискуссии на всех общедоступных каналах, в

которые вы были включены, хотя вы не сможете отвечать или

посылать туда сообщения.

/quit Выход из IRC.

/signoff Выход из IRC.

/summon Просьба к кому-то связанному с системой, имеющей IRC,

присоединиться к вам на IRC. При этом надо указать полный

электронный адрес этого лица.

/summon fleepo@foo.bar.com

пошлет сообщение к fleepo с приглашением запустить IRC.

Обычно не очень хорошо приглашать людей, если вы не узнали

заранее, что это им понравится, иначе можно просто наскучить.

Эта команда работает не на всех подсистемах.

/topic Когда вы создаете новый канал, используйте эту команду, чтобы

дать другим знать, о чем в нем пойдет речь.

/topic #Amiga

сообщит тем, кто воспользуется командой /list, что на этом

канале обсуждаются компьютеры Amiga.

/who <кан> Покажет электронные адреса людей на определенном канале..

/who #foo

укажет адреса всех на канале foo.

/who

покажет адреса каждого человека, находящегося в данный момент

времени на IRC, но будьте осторожны: в вечер рабочего дня вы

можете нарваться на список имен в 500!

/whois Эта команда используется для получения информации о

конкретном пользователе IRC или для того, чтобы

посмотреть, кто сейчас на связи.

/whois имя

даст вам электронный адрес человека, который использует

это имя.

/whois *

Даст список всех на каждом канале.

/whowas Аналогично /whois; дает информацию о тех, кто недавно

вышел из IRC.

11.4 IRC во время кризиса

IRC стала новым средством для того, чтобы оставаться на уровне главных

и срочных событий. Когда в 1993 году российские законодатели

забаррикадировались в здании парламента, некоторые предприимчивые москвичи

и пара американцев создала "канал новостей" на IRC, чтобы связываться с

главными лицами непосредственно из Москвы. Канал был создан для обеспечения

непрерывного цикла информации, подобно тому, как радиостанции повторяют

хронику каждые двадцать минут. В 1994 году аналогичный канал создали жители

Лос Анжелеса для пересылки информации о землетрясении в Норбридже. В обоих

случаях все это было заархивировано где-то в Сети для тех, кто не смог

"настроиться" на этот канал в реальном времени.

Как найти такие каналы в будущем? Просмотрите доступные каналы

командой /list. Если был определен какой-то канал для обсуждения выдающихся

событий, то есть шансы, что краткое пояснение рядом с его именем даст вам

понять, что на него стоит настроиться.

11.5 MUD

Многопользовательские измерения или пропасти (Multiple-User Dimensions

or Dungeons - MUD) уводят IRC в царство фантазии. MUD представляют собой

живые ролевые игры, в которых вы входите в новую ипостась и в новую

реальность. Исследуя этот мир (в основном командами "look" (смотреть) "go"

(идти) и "take" (взять)), вы встречаетесь с другими пользователями, которые

могут затеять с вами дружеский разговор, попросить вашей помощи в важной

миссии или просто попытаются убить вас без видимой причины.

Каждая MUD имеет свою личность и своего создателя (или Бога), который

когда-то пожелал провести долгие часы за определением правил для данной

конкретной MUD, законов природы и баз данных информации для нее. Некоторые

MUD делают упор на общественные аспекты электронных связей в реальном

времени - пользователи часто собираются поболтать и вместе определить новые

структуры или целые миры. Другие ближе к играм типа "Пропасти и драконы" и

битком набиты чудовищами, драконами и злыми людьми, мешающими вам выполнить

вашу миссию и не останавливающимися перед убийством.

Многие MUD (есть также связанные с ними игры, известные под именем

MUCK и MUSE) требуют от вас немедленно заявить по электронной почте о своем

персонаже и пароле. Из тех, что позволяют сначала оглядеться, можно назвать

HoloMuck в Университете Мак-Гилла (McGill University) в Монреале. В

прологе к этой игре вы прибываете в центр города Танстаафл на планете Холо.

Вы должны найти себе место для жилья (иначе вас бросят в убежище для

бездомных) и начать исследования. В этом мире допустимо волшебство, но лишь

за чертой города. Если вам надоест город, вы можете бродить по всему

остальному миру и даже выйти на орбиту (это все, конечно, требует денег, вы

можете либо ждать еженедельного жалованья, либо сходить в городское

казино).Ознакомившись с городом и получив себе роль, вы можете даже

построить себе дом (или линию метро, или что-нибудь еще).

Чтобы соединиться, свяжитесь по telnet с

collatz.mcrcim.mcgill.edu 5757

После соединения введите

connect guest guest

и нажмите enter. Это соединит вас с учетным разделом "guest", имеющим

пароль "guest." Вы увидите следующее:

The Homeless Shelter(#22Rna)

You wake up in the town's Homeless Shelter, where vagrants are put for

protective holding. Please don't sleep in public places-- there are plenty of

open apartments available. Type 'apartments' to see how to get to an

apartment building with open vacancies.

There is a small sign on the wall here, with helpful information. Type 'look

sign' to read it.

The door is standing open for your return to respectable society. Simply walk

'out' to the center.

────────────────────────────────────────────────────────────────────────────

Убежище Бездомных(#22Rna)

Вы просыпаетесь в городском убежище для бездомных, где содержат бродяг.

Пожалуйста, не спите в общественных местах - есть достаточно свободных

квартир. Введите 'apartments' чтобы увидеть, как попасть в дом, где есть

свободные квартиры.

На стене есть небольшой знак с полезной информацией. Введите 'look sign',

чтобы его прочесть.

Дверь в порядочное общество для вас открыта. Просто идите наружу (walk

'out') к центру.

────────────────────────────────────────────────────────────────────────────

Конечно, вы хотите присоединиться к порядочному обществу, но сначала

желательно посмотреть, что написано на знаке. Введите

look sign

и нажмите enter, что выведет список доступных команд. Потом введите

out

и enter, что вызовет следующее:

You slip out the door, and head southeast...

Tanstaafl Center

This is the center of the beautiful town of Tanstaafl. High Street runs north

and south into residential areas, while Main Street runs east and west into

business districts.

SW: is Tanstaafl Towers. Please claim an apartment... no sleeping in public!

SE: the Public Library offers both information and entertainment.

NW: is the Homeless Shelter, formerly the Town Jail.

NE: is Town Hall, site of several important services, including: Public

Message Board, Bureau of Land Management (with maps and regulations), and

other governmental/ bureaucratic help.

Down: Below a sign marked with both red and blue large letter 'U's, a

staircase leads into an underground subway passage.

(Feel free to 'look' in any direction for more information.)

[Obvious exits: launch, d, nw, se, w, e, n, s, ne, sw]

Contents:

Instructions for newcomers

Directional signpost

Founders' statue

────────────────────────────────────────────────────────────────────────────

Вы вышли из дверей, и на юго-восток перед вами лежит...

Центр Танстаафла

Это центр красивого города Танстаафла. Высокая улица пересекает жилую

часть с севера на юг, а Главная улица - с востока на запад деловую

часть.

ЮЗ: Башни Танстаафла. Пожалуйста, снимите квартиру... не спите в общественых

местах!

ЮВ: Публичная библиотека предлагает и информацию, и беллетристику

СЗ: Убежище бездомных, ранее - городская тюрьма.

СВ.: Городская ратуша - местонахождение нескольких важнейших служб, в том

числе: Общественная доска объявлений, бюро земельных вопросов (с картами и

правилами) и другие правительственные/бюрократические службы.

Вниз: Под знаком, помеченным большими красными и синими буквами 'U' есть

лестница, ведущая в подземный переход метро.

(Не стесняйтесь 'look' (смотреть) во всех направлениях для более подробной

информации.)

[Очевидные выходы: вызов, вниз, сз, св, з, в, с, ю, юв, юз]

Содержание:

Инструкции для новичков

Дорожный указатель

Памятник основателям

────────────────────────────────────────────────────────────────────────────

Чтобы увидеть "Инструкции для новичков", введите

look Instructions for newcomers

и нажмите enter. То же самое можно сделать для "Дорожного указателя" и

"Памятника основателям". Потом введите

SW

и enter, чтобы попасть к Башням Танстаафла - жилому комплексу города, где

попробовать снять квартиру. (Придется поискать, многие уже заняты). А

теперь - вперед, исследовать Холо! Все время имейте на уме команду "take"

(взять). Периодически вы будете натыкаться на предметы, которые, если их

взять, добавят вам новую силу или новые способности. Если ввести

help

и enter, вы получите список файлов, прочитав которые, можно узнать

больше о командах этой MUD.

Команда "say" (говорить) дает возможность открыто говорить с другими

игроками. Например:

say Hey, I'm here!

(Эй, я здесь!)

будет передано всем, кто с вами в одной комнате. Если вы хотите

говорить с кем-то одним, напишите "whisper" (шептать) вместо "say"

(гоаорить).

whisper agora=Hey, I'm here!

Это услышит только agora. Другой способ связаться с кем-то, где бы

в мире он ни был, - использовать пейджер. Если ваш вдруг выключился,

есть шанс, что какой-то волшебник смотрит, не нужна ли вам помощь.

Чтобы прочесть его сообщение, введите

page

Чтобы послать сообщение ему, введите

page имя=сообщение

где имя - имя волшебника (в его сообщении оно указано).

У других MUD и MUCK могут быть другие команды, но в принципе

используется та же идея - работать с помощью простых английских слов.

При связи с MUD выбирайте пароль так же тщательно, как и для

своей местной системы - к сожалению, существуют взломщики MUD, которые

любят вламываться в чужие разделы. И никогда, никогда не используйте свой

пароль своей местной системы!

MUD оказались очень прилипчивы. "Еще не решено, является ли занятие

MUD 'просто игрой' или 'продолжением реальной жизни средствами игры'",

говорит Дженнифер Смит (Jennifer Smith), активный участник MUD, написавшая

по этому поводу FAQ (список часто задаваемых вопросов).

Она предостерегает: "НЕ следует делать ничего такого, что вы не

сделали бы в реальном мире, даже если мир - фантастический. Важно помнить,

что этот мир - фантазия сотен человек, а не только ваша. На конце каждого

провода находится человек! Всегда помните, что когда-нибудь вы можете

встретиться с этими людьми и получить в глаз. Люди, которые

плохо относятся к другим, зарабатывают дурную репутацию и получают в конце

концов печать, что с ними лучше дела не иметь".

11.6 Го, го, го (да еще и шахматы)!

Мечтаете о хорошей партии в го или в шахматы? Больше не надо ходить в

ближайший парк с доской в руке. В Internet есть пара машин, которые

позволяют приглашать на игру людей со всего света. Или наблюдать за чужой

игрой (если вы предпочитаете).

Для игры в го:

telnet hellspark.wharton.upenn.edu 6969

log on as: guest

Вы обнаружите подсказки к различным файлам со справочной информацией,

которые помогут начать. Для партии в шахматы:

telnet news.panix.com 5000

log on as: guest

Вы обнаружите подсказки к различным файлам со справочной информацией,

которые помогут вам выбрать ваш уровень игры.

11.7 Обратная сторона медали

Не все в Сети только игры и развлечения. Как всякое общество, Сеть

имеет своих неприятных типов, весь смысл существования которых в том,

кажется, и состоит, чтобы отравлять вам жизнь. (В главе 4 вы уже с

некоторыми из них встречались). Есть люди, которые проводят в Сети больше

времени, чем это многие сочли бы безвредным для здоровья. Есть и свои

преступники. Клиффорд Столл (Clifford Stoll) в "Яйце кукушки" ("The

Cuckoo's Egg") написал, как он выследил команду немецких хакеров, проникших

в компьютеры США и торговавших найденной там информацией с Советами.

Роберт Моррис (Robert Morris), студент Корнелльского Университета

(Cornell University), был осужден за то, что выпустил программу-"червяка",

которая эффективно вывела из строя несколько тысяч связанных с Internet

компьютеров.

Среднестатистический пользователь Сети больше должен беспокоиться о

взломщиках, которые узнают чужие пароли и влезают в системы Сети, и людях,

которые заражают вирусами программы на подсистемах ftp.

Есть широко известная программа по имени "Crack", которая умеет

расшифровывать пароли пользователей, составленные из слов, которые можно

найти в словарях (и вот почему не следует пользоваться такими паролями).

Короче говоря, есть гнусные типы, которые хотят испортить вам жизнь. Лучший

способ с ними общаться - это посчитать до 10 и не обращать внимания - как и

у других сопляков, у них половина удовольствия состоит в вашей бурной

реакции на пакость.

А тем временем два студента из Корнельского Университета (Cornell

University) признаны виновными в 1992 году в загрузке на подсистемы ftp

зараженных вирусом программ для Macintosh. Если вы планируете брать много

программ с подсистем ftp, разумно будет обзавестись хорошим противовирусным

средством.

Но не могут ли слуги закона зайти слишком далеко, преследуя

преступников? Организация Electronic Frontier Foundation была основана во

многом в ответ на правительственный рейд против тех, кто был объявлен

бандой хакеров. Рейд чуть не привел к банкротству одной специализирующейся

на играх компании, утверждавшей, что не имеет с хакерами ничего общего -

правительство арестовало ее компьютеры и отказалось их вернуть. Дело против

другой компании умерло в суде, когда ее адвокат доказал, что

предположительно "похищенная" информация, которую он напечатал в

электронной газете, может быть получена по номеру, начинающемуся на 800,

примерно за 13 долларов от телефонной компании, у которой были взяты

данные.

11.8 Куда обратиться с вопросами

Найти обсуждение вопросов, связанных с IRC, можно в группе новостей

alt.irc newsgroup. "Обсуждение сетевых компьютерных конференций" ("A

Discussion on Computer Network Conferencing") Даррена Рида (Darren Reed)

(Май, 1992), дает теоретическую основу для суждений о том, почему системы

конференций типа IRC - Хорошая Вещь. К ней можно получить доступ через ftp

при nic.ddn.mil в директории rfc по имени rfc1324.txt.

Каждую пятницу Скотт Геринг (Scott Goehring) помещает новый список MUD

и связанных с ними игр, а также их адреса telnet в группе новостей

rec.games.mud.announce. Есть еще несколько групп новостей mud, относящихся

к определенным типам MUD, в том числе rec.games.mud.social,

rec.games.mud.adventure, rec.games.mud.tiny, rec.games.mud.diku и

rec.games.mud.lp.

Хороший обзор впечатлений от Internet Морриса Ворма (Morris Worm)

можно прочесть в работе "Вирусы указывают на необходимость улучшения

управления Internet" ("Virus Highlights Need for Improved Internet

Management"), изданного U.S. General Accounting Office (июнь, 1989).

Копию этой работы можно получить по ftp от cert.sei.cmu.edu в директории

pub/virus-l/docs. Она там под именем gao_rpt.

Клиффорд Столл (Clifford Stoll) описывает, как работает Internet и как

он по нему отловил группу хакеров из Германии, работавшую на КГБ, в книге

"Яйцо кукушки: Выслеживание шпиона в лабиринте компьютерного шпионажа"

("Cuckoo's Egg: Tracking a Spy through the Maze of Computer Espionage,")

Даблдей (Doubleday) (1989).

Глава 12: ОБРАЗОВАНИЕ И СЕТЬ

12.1 Сеть в школьных классах

Если вы - учитель, то вы уже, наверное, начали рассматривать

возможности Сети для использования в учебном процессе. И действительно,

Usenet, ftp и telnet имеют огромный образовательный потенциал - от ведения

хроники мировых событий до организации межнациональных научных

экспериментов.

Поскольку в наше время Сеть захватывает так много стран и остается

включенной даже когда отключаются телефоны, вы и ваши студенты можете

"настроиться" на сведения из первых рук во время международных конфликтов.

Посмотрите в вашей системе список групп soc.culture на Usenet, чтобы

узнать, есть ли там такая, которая относится к интересующей вас стране или

району. Даже в мирное время эти группы могут очень пригодиться для того,

чтобы найти людей из стран или регионов, которые вы изучаете.

Самая большая проблема - это завести раздел для ваших студентов, если

вы не такой везучий, что живете там, где не возможен локальный вызов системы

Free-Net. Тем не менее многие колледжи и университеты охотно идут на

переговоры по вопросам открытия разделов для старших учеников за низкую

плату или без таковой вообще. Некоторые штаты, в том числе Калифорния и

Техас, имеют связанные с Internet сети для учителей и учеников.

12.2 Некоторые специфические ресурсы для учителей и учеников

Кроме того, на Internet есть некоторое количество ресурсов, специально

рассчитанных на учащихся средних и старших классов и учителей. Вы можете

их использовать для постановки экспериментов совместно с классом из другой

страны, узнать, как использовать в классе компьютеры или узнать о последних

достижениях в области преподавания чего угодно - от физики до физкультуры.

Среди этих ресурсов:

AskERIC Ведомая Центром Образовательных ресурсов и информации

"Educational Resource and Information Center", программа

AskERIC дает возможность работникам образования,

библиотекарям и прочим, кто интересуется образованием K-12,

получить информацию практически обо всем. Центр

поддерживает электронный адрес (askeric@ericir.syr.edu) для

задавания вопросов и обещает ответ в течение 48 часов. Он

также поддерживает подсистему gopher, содержащую краткое

изложение вопросов и ответов, планы уроков по различным

предметам, и прочую информацию по образованию. Адрес

подсистемы gopher ericir.syr.edu.

Health-Ed: Список рассылки для работников образования в области

здравоохранения. Посылать запрос по адресу

health-ed-request@stjhmc.fidonet.org

K12Net: Сеть K12Net, возникшая на хоббистской сети Fidonet, в

настоящий момент имеется на многих системах Usenet и

является основной системой для многих интересных и ценных

служб. Среди них есть услуги по международным разговорам

для студентов, обсуждения на иностранных языках (например,

есть французский и немецкий - единственная конференция, где

американские студенты могут потренироваться в разговоре на

этих языках со своими коллегами из Квебека и Германии).

Существуют также конференции для учителей по конкретным

предметам, от физкультуры до физики. Сеть K12 все еще имеет

ограниченную рассылку, так что спросите у своего системного

администратора, несет ли ее ваша система.

Kidsphere: Kidsphere представляет собой список рассылки для учителей

средних и старших классов, которые организуют совместные

проекты и обсуждают использование телекоммуникации в

образовательном процессе. Здесь также можно найти сведения

о новом программном обеспечении, список подсистем, с

которых можно получить изображения в компьютерной графике

от различных спутников и зондов NASA, и вообще сведения,

интересные для пользующихся модемом учителей.

Чтобы подписаться, пошлите по электронной почте

сообщение на kidsphere по адресу request@vms.cis.pitt.edu

или joinkids@vms.cis.pitt.edu, и через пару дней можете

начинать получать сообщения.

Чтобы принять участие в дискуссии, посылайте сообщения

по адресу kidsphere@vms.cis.pitt.edu.

KIDS является частью KIDSPHERE только для учащихся,

которые хотят общаться учащимися. Чтобы подписаться,

пошлите запрос в адрес joinkids@vms.cis.pitt.edu как выше.

Чтобы принять участие в дискуссии, посылайте сообщения по

адресу kids@vms.cist.pitt.edu.

Knoxville Использование газет в электронном классе. Эта подсистема

News- gopher позволяет студентам и преподавателям связываться

Sentinel с газетой и обеспечивает ресурсы, выделяемые из раздела

Online хроники. Свяжитесь с помощью программы gopher с адресом

gopher.opup.org

MicroMUSE Это электронный город будущего, построенный целиком его

участниками (информацию о системах MUSE и вообще системах

MUD и расшифровку этих сокращений см. в главе 11). Сотни

студентов со всех концов света участвовали в этом учебном

эксперименте, который координировал Массачусетский

Технологический институт (MIT). Свяжитеь по Telnet с

michael.ai.mit.edu. Зарегистрируйтесь как guest (гость), а

затем следуйте указаниям для получения дополнительной

информации.

NASA Spacelink: Эта система, которую ведет NASA в Хантсвилле, штат Алабама,

предоставляет отчеты и данные всех видов о NASA, ее истории

и различных задачах, прошлых и настоящих. Свяжитесь по

Telnet со spacelink.msfc.nasa.gov или 128.158.13.250.

После соединения вам предъявят краткое описание

системы и попросят зарегистрироваться. Система поддерживает

большую библиотеку файлов формата GIF с графическими

изображениями космических объектов, но заметьте, что их

нельзя загрузить в свой компьютер по telnet. Если вам это

нужно, вам придется связаться с системой напрямую по

телефону (205) 895-0028. Многое тем не менее можно

получить с ftp от ames.arc.nasa.gov.

Newton: Ведется Национальной Аргоновой Лабораторией (Argonne

National Laboratory), предлагает конференции для учащихся и

преподавателей, в том числе конференцию под названием "Ask

a Scientist" (Спросите ученого).

Telnet: newton.dep.anl.gov.

Log in as: cocotext

Вас попросят сообщить свое имя и адрес. После этого из

главного меню выберите 4 для выхода на разные конференции.

Категория "Ask a Scientist" (спросите ученого) позволит вам

задать вопросы ученым из разных областей - от биологии до

геологии. В других категориях можно обсудить вопросы

преподавания, спорта и компьютерных сетей.

OERI: Ведомство Министерства Образования США по ресурсам

образования и их усовершенствованию (U.S. Department of

Education's Office of Educational Resources and

Improvement) ведет систему gopher, предоставляющую

многочисленные ресурсы для образования, а также информацию

и статистику для преподавателей. Свяжитеь по gopher с

gopher.ed.gov.

Spacemet Forum: Если ваша система не поддерживает конференции K12, но дает

доступ к telnet, до этой конференции можно добраться через

SpaceMet Forum - систему доски объявлений, рассчитанную на

преподавателей и студентов. Ее ведет факультет физики и

астрономии Массачусетского Университета (University of

Massachusetts) в Амхерсте.

Telnet: spacemet.phast.umass.edu.

После установления связи нажмите один раз клавишу escape,

после чего вас попросят зарегистрироваться. Как и Сеть

K12Net, SpaceMet Forum начался как подсистема Fidonet, но

скоро ее перерос. Морт и Хелен Стернхейм (Mort and Helen

Sternheim), преподаватели этого университета, основали

SpaceMet как электронную доску объявлений много лет назад

для поддержки научного образования в средних школах

соседних городов.

Кроме конференций K12, SpaceMet поддерживает еще

многочисленные конференции, посвященные вопросам

образования. Есть также большая библиотека файлов, которые

могут заинтересовать учащихся и работников образования, но

имейте в виду, что прием этих файлов на вашу подсистему

может оказаться затруднен или просто невозможен. В отличие

от большинства подсистем Internet, SpaceMet не использует

интерфейс ftp. Иногда это можно сделать по Cети, но

рассчитывать на это не стоит.

12.3 Usenet и Bitnet в классе

Существуют различные группы новостей Usenet, потенциально интересные

учителям и учащимся.

Как и можно было бы ожидать, многие из них имеют научный уклон. Их

можно найти, введя l sci. в качестве команды rn или используя nngrep sci. в

качестве команды nn. Сейчас их под сорок, и темы варьируются от археологии и

экономики ("dismal science" (наука о несчастливых днях) - помните?) до

астрономии и нанотехнологии (конструирование микроскопически малых машин).

Из многих таких групп студенты быстро усваивают одну вещь: наука - не

просто скучный набор тусклых фактов. Наука - это умение сделать вывод, это

спор и отстаивание своей точки зрения. Группы Usenet sci. поощряют умение

мыслить критически.

Кроме науки, социальных исследований и уроков по истории можно

заниматься изучением других стран - для этого есть группы новостей

soc.culture.

Большая часть таких групп начиналась эмигрантами из соответствующих

стран для того, чтобы не терять культурной связи со старой родиной. Однако

во времена кризисов такие группы часто становились центрами передачи

информации из страны или в страну и обсуждения происходящего. На Usenet

сейчас представлены около 50 стран от Афганистана до Югославии. Чтобы

посмотреть, какие существуют группы, используйте l soc.culture. в rn или

nngrep soc.culture. в качестве команды nn.

Есть несколько "разговорных" групп новостей, предлагающих для

обсуждения некоторые дополнительные вопросы, но учителям следует их сначала

просмотреть, прежде чем предлагают учащимся. Диапазон достаточно широк - от

talk.abortion и talk.politics.guns (аборты и политика-оружие) до

talk.politics.space and talk.environment (политика-космос и окружающая

среда).

Одно предостережение: Учитель может захотеть сначала исследовать

отдельные группы новостей, прежде чем выпустить туда своих учащихся без

привязи. У некоторых групп уровень глупости и страстности выше, чем у

других.

Есть также некоторое число дискуссионных групп Bitnet, представляющих

потенциальный интерес для учащихся и учителей. См. в главе 5 информацию о

нахождении дискуссионных групп Bitnet и подписке на них. Среди тех, которые

ориентированы на вопросы образования, есть такие:

biopi-l ksuvm.bitnet Среднее биологическое образование

(Secondary biology education)

chemed-l uwf.bitnet Химическое образование

(Chemistry education)

dts-l iubvm.bitnet Список общества учителя-робота

(The Dead Teacher's Society list)

phys-l uwf.bitnet Дискуссия для преподавателей физики

(Discussions for physics teachers)

physhare psuvm.bitnet Общий ресурс для учителей физики

(Where physics teachers share resources)

scimath-l psuvm.bitnet Математическое и научное образование

(Science and math education)

Чтобы получить графические изображения астрономических объектов в

графическом формате GIF, свяжитесь по ftp с nic.funet.fi. Перейдите в

директорию /pub/astro/general и возьмите файл astroftp.txt. Среди

подсистем, там перечисленных, есть ames.arc.nasa.gov, содержащая снимки,

сделанные зондами Вояджер (Voyager) и Галлилей (Galileo), а также другие

изображения.

Глава 13: БИЗНЕС В СЕТИ

13.1 Открываем лавочку

Когда-то давным-давно, до года так, чтобы не соврать, 1990 или где-то

около, в виртуальном сообществе рынка не было - если вы хотели купить

книжку, надо было бежать в ближайший книжный магазин.

А все потому, что в те дни Сеть в основном состояла из сетей,

финансируемых правительством, в которых открытая коммерческая деятельность

была запрещена. Сейчас же сеть в основном поддерживается частными

компаниями, и некоторые из них начали эксперимент с открытием электронных

"магазинов" и тому подобных служб. Многие из таких магазинов содержатся

книготорговцами, а службы варьируются от доставки заказанных копий

федеральных документов и до электронной рассылки хроники в надежде, что

кто-то подпишется на какое-нибудь периодическое издание (напечатанное на

бумаге). Некоторые компании также используют группы новостей Usenet ( из

иерархии biz, относящейся к бизнесу) для рассылки пресс-релизов и

информации о продукции.

Однако коммерческая деятельность остается на куда более низком уровне,

чем на других сетях, таких, как CompuServe, с его Electronic Mall, или

Prodigy, с рекламными объявлениями почти на каждом экране. Это частично

связано с новизной и сложностью Internet как носителя коммерческой

информации. Но частично это связано также с соображениями безопасности.

Компании беспокоятся по поводу электронных взломщиков, которые могли бы

проникнуть по сети в их систему, и вообще многим не нравится идея

пересылать по Internet номер кредитной карты (сообщение электронной почты

может пройти через несколько подсистем, пока достигнет места назначения).

Эти страхи могут быть развеяны по мере того, как пользователи Сети перейдут

к таким средствам, как шифровка сообщений и "электронные подписи". Тем

временем бизнесмены в Сети пока еще считаются чем-то вроде

пионеров-освоителей Internet.

Несколько общедоступных систем и региональных сетей открыли "рыночные

площади" для электронного занятия бизнесом.

Мир (World) в Бруклине, Массачусетс, в настоящее время арендует

"место" для нескольких книжных магазинов и программистских фирм, а также

для магазина "Игрушки для взрослых". Чтобы пролистать их предложения,

свяжитесь через gopher с world.std.com

В главном меню выберите "Shops on the World" (Магазины Мира)

Msen в Энн Арборе предоставляет в распоряжение пользователя свой "Msen

Marketplace" (рынок Msen), где можно найти туристское агентство и "Online

Career Center" (Электронный транспортный центр), предлагающий рекламу по

всей стране. Msen также предоставляет "Internet Business Pages" (Телефонный

справочник организаций в Internet) - электронный список компаний, которые

ищут контактов с сообществом Internet. Доступ к Msen можно получить через

программу gopher по адресу

gopher.msen.com

В главном меню выберите "Рынок Msen".

Сеть Nova Scotia Technology Network ведет службу gopher "Cybermarket"

(Гиперрынок) по адресу

nstn.ns.ca

Там можно найти электронный книжный магазин, в котором можно заказать книги

по электронной почте (придется ей доверить свой номер кредитной карты), и

аналогичный "virtual record store" (магазин виртуальных записей). Оба эти

магазина дают возможности поиска товара по ключевым словам и просмотра

каталогов.

Есть и другие электронные бизнес-системы, в том числе:

AnyWare Associates Эта компания в Бостоне ведет шлюз факс-Internet,

позволяющий пересылать факсовые сообщения в любую

точку мира по Internet (конечно, за деньги).

Дополнительную информацию запрашивайте по адресу

sales@awa.com

Bookstacks Unlimited Этот книжный магазин в Кливленде предоставляет

возможность поиска по ключевому слову в базе

данных, содержащей тысячи выставленных на продажу

книг. Адрес Telnet:

books.com

Counterpoint Publishing Основным продуктом для Internet этой компании,

базирующеяся в Кембридже, штат Массачусетс,

является индексированная версия федеральных

журналов, в том числе Федерального регистра

(ежедневный компендиум правительственных

контрактов, законодательных предложений и т. п.).

Пользователи Internet могут просматривать

последние копии, но полный доступ стоит порядка

нескольких тысяч долларов в год. С помощью gopher

свяжитесь с

enews.com

и выберите "Counterpoint Publishing" ("Издательство

"Контрапункт"")

Dialog Национальная база данных, к которой можно получить

доступ через telnet по адресу

dialog.com

Однако чтобы зарегистрироваться, необходимо

предварительно установить себе раздел в Dialog.

Dow Jones News Телеграфное агентство, которое ведется информационной

Retrieval компанией - владельцем "Уолл стрит

Джорнэл". Доступ через telnet по адресу

djnr.dowjones.com

Как и для компании Dialog, чтобы

зарегистрироваться, нужно иметь свой раздел.

Infinity Link Просмотр каталогов книг, музыки, программного

обеспечения, видеокассет и лазерных дисков.

Система базируется в Малверне, Пенсильвания. Связь

через gopher по адресу

columbia.ilc.com

Регистрация: cas

The Internet Company Эта компания, базирующаяся в Кембридже,

Массачусетс, является некоторого рода сервисным

бюро и работает с несколькими издательскими

компаниями над продукцией, имеющей отношение к

Internet. Ее электронный стенд новостей (Electronic

Newsstand) предлагает краткие специальные цены для

подписки на национальные журналы, от New Republic

до New Yorker. Связь через gopher по адресу

enews.com

MarketBase Можете попробовать эту систему классифицированных

объявлений, разработанную этой компанией в Санта

Барбаре, Калифорния. Связь через gopher по адресу

mb.com

O'Reilly and Associates О'Рэйли (O'Reilly), известный своими книгами

"Nutshell" (Ореховая скорлупа) по Unix, ведет три

службы Internet. Сервер gopher по адресу

ora.com

Даст информацию о компании и ее книгах. Аналогичная

информация передается в группу новостей Usenet

biz.oreilly.announce. Ее Навигатор Глобальной сети

(Global Network Navigator), к которому можно

получить доступ через Всемирную Сеть (World-Wide

Web) представляет собой некоторый вид электронного

журнала, который позволяет пользователям

просматривать интересующие их службы и каталоги.

13.2 Куда обратиться с вопросами

Список рассылки com-priv - это то место, в котором обсуждаются

вопросы, связанные с коммерциализацией и приватизацией Internet. Чтобы

подписаться (или отказаться от подписки), направьте запрос по электронной

почте на com-priv- по адресу request@psi.com.

Книга Мэри Кронин (Mary Cronin), "Doing Business on the Internet"

("Как заниматься бизнесом в Internet") (1994, Van Nostrand Reinhold),

исследует вопрос более глубоко.

Кентский Государственный Университет (Kent State University) в штате

Огайо ведет репозиторий "Business Sources on the Net" (Бизнес-материалы на

Сети). Свяжитесь с помощью gopher с адресом refmac.kent.edu.

Глава 14: ЗАКЛЮЧЕНИЕ ── КОНЕЦ?

Революция только начинается. Новые системы коммуникаций и цифровые

технологии уже до неузнаваемости изменили наш образ жизни. Только

подумайте, что теперь вполне обычным кажется то, о чем десять лет назад

нельзя было и мечтать. Вы можете просмотреть фонды своей местной библиотеки

- или библиотеки на другой стороне земного шара - работать со своим

банковским счетом и проверить, не обанкротился ли ваш ближний, и все это с

помощью компьютера и модема.

Снижение стоимости в сочетании с повышением производительности

приносят все более и более мощные компьютеры и цифровые системы все

большему и большему количеству людей. Сеть, с ее быстро растущей коллекцией

баз данных и прочих источников информации, уже не ограничивается

промышленно развитыми странами Запада, - она раскинулась нынче от Сибири до

Зимбабве. А цены компьютеров и модемов, которые к ней подключаются,

продолжают снижаться, и все больше и больше людей могут это себе позволить.

Гиперпространство стало жизненно важной частью ежедневного распорядка

миллионов людей. По электронной связи завязываются знакомства, люди

влюбляются и вступают в брак, а все начинается с контакта в гиперпространстве,

этом эфемерном "месте", поглощающем границы государств и наций.

Коммерческие сделки выполняются в коде ASCII. На электронных связях

начинаются политические и общественные движения, объединяющие людей за

тысячи миль друг от друга.

И это только начало.

Мы живем в веке коммуникаций, но средства этих коммуникаций остаются

сильно разделенными. Но когда-нибудт ваш телефон, телевизор, факс и

персональный компьютер будут заменены единым "информационным процессором",

привязанным к всемирной Сети оптоволоконными соединениями.

На кончиках ваших пальцев будет не только доступ к базам данных и

библиотекам, но и власть. Имея связь с тысячами, с миллионами людей, вы

сможете участвовать в социальных и политических движениях во всей стране и

во всем мире.

Как это произойдет? Частично - от новой технологии. Высокого

разрешения телевизоры потребуют разработки недорогих компьютеров, которые

смогут обрабатывать объемы информации, доступные сегодня рабочим станциям.

Телефонные и телеграфные компании в сотрудничестве, а иногда и конкурируя,

проведут в ваш дом оптическо-волоконные линии.

Администрация Клинтона, пожалуй, впервые возглавляемая людьми, которые

умеют использовать не только компьютерную сеть, но и компьютер, продвигается

к созданию сети "информационных суперхайвеев", сравнимой по масштабу с

системой автодорожных хайвеев пятидесятых годов (сын одного из

продвигателей этой программы избран вице-президентом в 1992 году).

Сейчас мы как раз имеем компьютерно-сетевой эквивалент начала

пятидесятых, как раз перед созданием массивной сети хайвеев. Конечно,

интересного очень много, но чтобы до него добраться, надо петлять по

двухрядным дорогам и иметь хорошую карту.

Создание этой новой Сети потребует большего, чем высокоскоростные

каналы и коммутационное оборудование, - потребуется новая парадигма

коммуникаций - Сеть как служба информации. Сеть остается достаточно сложным

и таинственным местом. Чтобы получить сегодня что-то от сети, вы должны

потратить приличное время либо общаясь с ее ветеранами, либо читая учебник

вроде этого. Вам придется выучить такие тайны бытия, как экстравагантности

команды Unix cd.

Сравните это с телефоном, который сейчас дает доступ к колоссальным

информационным ресурсам нажатием нескольких кнопок, или с компьютерной

сетью типа Prodigy, в которой можно передвигаться с помощью простых команд

и кнопок мыши.

Системные администраторы Internet начали уже понимать, что не все

желают изучать тонкости системы Unix, и что отказ это делать не ставит

людей вне морали. Мы уже наблюдаем развитие простых интерфейсов, которые

позволят миллионам людей воспользоваться всей мощью Сети. Можно заметить

эту тенденцию в меню программ gopher и Всемирной Сети (World-Wide

Web), которые не требуют изощренных навыков обращения с компьютером, но

открывают ворота к тысячам источников информации. Почтовые программы и

текстовые редакторы, такие, как pico и pine, обещают те же возможности, что

и программы постарше вроде emacs, но при в несколько раз меньшей сложности.

Некоторые разработчики программного обеспечения продолжают эту

тенденцию дальше, создавая графические интерфейсы, позволяющие перемещаться

в пределах Internet щелчками мыши на экране, или вызывать простой текстовый

редактор - примерно как происходит передвижение в компьютере Macintosh или

в коммерческой сети, такой, как Prodigy.

Теперь о самих службах Internet.

На каждую базу данных, к которой есть доступ из Internet, сегодня

приходится три или четыре, к которым такого доступа нет. Правительственные

ведомства только теперь начинают подсоединять свои хранилища информации к

Сети. Некоторые торговцы - от владельцев баз данных до владельцев книжных

магазинов, предоставляют доступ к своим ресурсам через Сеть.

Сейчас немногие используют одно из самых интересных приложений Сети.

Есть стандарт, называемый MIME, который позволяет пересылать по Сети

звуковые и графические файлы в виде сообщения. Представьте себе, что вам по

электронной почте приходит сообщение с первыми произнесенными словами вашей

внучки или фотография нового дома вашего приятеля. В конце концов, с

помощью этого стандарта по сети можно будет передавать даже небольшие

видеосюжеты.

Все это требует расширения возможностей Сети, которая должна будет

работать и с миллионами новых пользователей, и с новыми приложениями,

которые им понадобятся. Воспроизведение движущегося образа на экране

компьютера требует колоссального количества бит компьютера и

соответствующих мощностей, чтобы с ними работать.

Из всего этого формируется Национальная Информационная Инфраструктура,

способная передавать в секунду миллиарды бит информации - это столько,

сколько нужно, чтобы присоединить информационные "шланги" к каждому

предприятию и каждому дому.

По мере роста этих "суперхайвеев" будут развиваться и "развязки",

"ответвления", потому что мало пользы от высокоскоростных магистралей, если

на них нельзя въехать. Цены на модемы, похоже, будут падать, как и на

компьютеры. Все больше людей сможет позволить себе высокоскоростные модемы

(9600 бод и выше). При скорости 9600 бод вы можете загрузить спутниковую

карту погоды Северной Америки меньше чем за две минуты, - файл, который при

более медленном модеме будет загружаться до 20 минут. И в конце концов,

дома могут быть присоединены прямо к национальной цифровой сети. Большая

часть дальних телефонных разговоров уже передается в цифровой форме по

оптоволоконным линиям. Телефонные компании понемножку думают о том, чтобы

провести такие линии и на "последней миле" - подводу к дому. Фонд

Электронной Границы (Electronic Frontier Foundation) работает над тем,

чтобы сделать цены на такие связи приемлемыми.

Помимо технических вопросов, возникают острые вопросы социального,

политического и экономического характера. Кому следует предоставить доступ

к таким услугам, и сколько они будут стоить? Если мы живем в информационном

веке, не придется ли нам сегодня сеять семена, из которых вырастет

информационно подавленный класс, который не сможет конкурировать со

счастливцами, имеющими достаточно денег и умения, чтобы манипулировать

новыми каналами коммуникаций? Кто фактически будет решать, к чему и у кого

есть доступ? По мере того, как все больше и больше компаний будут

осознавать, какие выгоды несет новая информационная инфраструктура, что

случится с такой системой как Usenet - возможно, первой в мировой истории

анархической системой, где каждый может сказать все, что хочет?

Каковы законы электронной границы? Там, где теряются в гиперпространстве

национальные и государственные границы, возникает вопрос: КТО есть закон?

Что, если действия, законные в одной стране, "совершаются" в другой стране,

где они нелегальны, и при этом "совершаются" по компьютерной сети,

пересекающей эту страну? Кто должен преследовать компьютерных взломщиков?

А какую роль сыграете вы в этой революции?

Приложение A: ГЛОССАРИЙ

Как и любое общество, Сеть выработала свой собственный язык. Ниже

приводится глоссарий наиболее частых фраз и слов, на которые вы, вероятно,

наткнетесь. Но это - всего лишь малая часть net.speak. Более полный список

можно найти в "The New Hacker's Dictionary" ("Новом словаре хакера"),

составленном Эриком Реймондом (Eric Raymond) (MIT Press). Работа Реймонда

основана на доступной из сети ссылке, известной как "The Jargon File,"

("Файл жаргона"), на который можно выйти через анонимный ftp из

ftp.gnu.mit.ai.mit под именем jarg300.txt.gz в директории pub/gnu

(информацию о распаковке файлов .gz см. в главе 7).

(От переводчика: Поскольку предполагается, что читатель встретит эти слова

во время своих странствий в Сети, и они будут, естественно, английскими, мы

не стали заменять их русскими эквивалентами, давая подстрочный перевод

вокабулы только там, где такие переводы используются в тексте данного

руководства)

ASCII Имеет два значения. ASCII - это универсальный компьютерный

код для английских букв и символов. Компьютер хранит

информацию в виде двоичных чисел. В коде ASCII буква "A"

хранится как 01000001, независимо от вида компьютера - будь

он сделан IBM, Apple или Commodore. ASCII также означает

метод, или протокол для копирования файла из одного

компьютера в другой по сети, в котором ни один компьютер не

ведет проверку на ошибки, могущие возникнуть из-за

статического электричества или других причин.

ANSI Компьютеры используют различные методы для представления

информации на экране и для определения способа

взаимодействия экрана и клавиатуры. ANSI - это один из

методов подобной "эмуляции терминала". Он более всего

популярен в системах досок объявлений (BBS) на основе PC,

но используется и в некоторых подсистемах Сети. Для

правильного его использования сначала надо его установить,

или активизировать, в своем коммуникационном пакете.

ARPANet Предшественник Internet. Начата в 1969 году с

финансированием от Defense Department's Advanced Projects

Research Agency. (Агентство перспективных исследовательских

проектов министерства обороны).

backbone Высокоскоростная сеть, объединяюцая несколько мощных

(хребет, компьютеров. В США хребтом Internet часто считается NSFNet,

хребтовая - финансируемая правительством сеть, объединяющая

сеть) несколько суперкомпьютеров во всей стране.

Baud Скорость передачи данных модемом. Один бод - это, грубо

(бод) говоря, один бит в секунду. Для передачи буквы или символа

нужно восемь бит. Модемы редко передают данные с указанной

в паспорте скоростью из-за статических помех или помех в

компьютере. Более дорогие модемы используют системы типа

Microcom Network Protocol (MNP), которые исправляют такие

ошибки или уплотняют данные для ускорения передачи.

BITNet Другая система академической ориентации, международная

компьютерная сеть, использующая для передачи данных другой

набор компьютерных инструкций. К ней легко получить доступ

из Internet по электронной почте, и в ней много конференция

и баз данных. Ее название происходит от "Because It's

Time." ("Поскольку самое время")

Bounce Это то, что делает ваша электронная почта, когда не может

(Возврат) найти получателя - возвращает вам обратно - если не

выбрасывает письмо в эфир, где оно пропадает навеки.

Command line В местных системах Unix это место, где вы вводите команды,

(Командная говорящие машине, чего вы хотите.

строка)

Communications Программа, говорящая модему, как ему работать

software

(Коммуникаци-

онный пакет)

Daemon Вообще-то безвредная программа Unix, работа которой обычно

незаметна для пользователя. В Internet вы, скорее всего,

встретитесь с ней только когда ваша электронная почта не

может быть доставлена адресату - вы получите свое исходное

сообщение и к нему уродливое дополнение от "mailer daemon".

Distribution Способ ограничить места рассылки вашего послания на Usenet.

(рассылка) Удобно для помещения объявлений типа "продается" или для

обсуждения местных политических вопросов.

Domain Последняя часть адреса Internet, например, "news.com."

Домен

Dot Когда разговариваете с ветераном Сети, если хотите

произвести на него впечатление, называйте точку словом

"dot", а не "period", например: "Мой адрес - john at site

dot domain dot com."

Dot file Файл в общедоступной системе Unix, который меняет способ

(файл с взаимодействия вашего сообщения с системой. Например, файл

точкой перед .login содержит различные параметры для таких вещей, как

именем) текстовый редактор, который вызывается при посылке вами

сообщения. При использовании команды ls эти файлы не

появляются в списке директории, для их вывода

воспользуйтесь командой ls -a.

Down Когда общедоступная система останавливается из-за

("упала") технической неисправности и недоступна, она "упала".

Download Копирование файла из местной системы в ваш компьютер.

(Загрузка Есть несколько различных методов, или протоколов, для

"вниз" - загрузки файлов, большинство из которых периодически

из централь- проверяют файл, копирование которого они ведут, для

ного компью- гарантии неповрежеднности и неискаженности информации в

тера в пери- процессе передачи. Некоторые, такие, как XMODEM,

ферийный) позволяют передавать только один файл за один сеанс.

Другие, такие, как пакетный YMODEM и ZMODEM, позволяют

ввести имена нескольких файлов одновременно, для которых

загрузка выполнится автоматически.

EMACS Стандартный текстовый редактор Unix, предпочитаемый

Unix-овцами и ненавидимый начинающими.

E-mail Электронная почта - способ пересылки частных сообщений

другому абоненту Сети. В английском языке используется и

как существительное, и как действие.

Emoticon См. Smiley.

F2F Лицом к лицу. Фактическая встреча с кем-то, с кем вы

обменивались письмами или наездами.

FAQ Часто задаваемые вопросы. Компиляция ответов на них. Многие

группы новостей Usenet содержат такие файлы, которые раз в

месяц или около того посылаются на сеть для новичков.

Film at 11 Одна из реакций на слишком эмоциональный спор: "Предсказана

неминуемая гибель Сети. Фильм начнется в 11."

Finger Программа Internet, дающая возможность узнать кое-что о

другом пользователе, если он предварительно создал файл

.plan.

Flame Электронное рычание или ругань в чей-то адрес. Часто

(Наезд) порождает войну наездов, которая иногда превращается

в священную войну (см. главу 4).

Followup Послание на Usenet в ответ на какое-то более раннее

(Отклик) послание.

Foo/foobar Нечто вроде алгебраического символа, например: "Если вы

интересуетесь, какая другая система ведется коммерческой

компанией, ищите адрес в виде foo@foobar.com."

Fortune cookie Пустой, остроумный или глубокий комментарий, иногда

(Предсказание находимый на сети.

судьбы)

Freeware Бесплатное программное обеспечение

FTP Протокол передачи файлов. Система передачи файлов по Сети.

Get a life Что сказать тому, кто, возможно, провел слишком много

(Поживи времени перед компьютером.

малость)

GIF Графический формат обмена. Формат, разработанный в

середине восьмидесятых годов в CompuServe для передачи

графических образов с фотографическим качеством. Теперь

часто используется при электронной передаче графики.

GNU Это не Unix. Проект Организации бесплатного программного

обеспечения (Free Software Foundation) для написания

бесплатной версии операционной системы Unix .

Hacker В Сети, в отличие от больших сообществ, это не плохой

человек - это просто тот, кто любит напрягать аппаратное и

программное обеспечение до предела, чтобы посмотреть, что

может делать компьютер. Тех, кого многие называют хакерами,

net.denizens определяет как взломщиков (crackers).

Handshake Два модема при установке соединения сначала договариваются,

(Рукопожатие) как передавать данные.

Hang Модем не может повесить трубку.

(Зависание)

Holy war Споры, которые затрагивают некоторые основные постулаты

(Священная веры, несогласие с которыми и вызывает войну. Например:

война) Машины IBM PC по жизни лучше машин Macintosh.

Host system Общедоступная подсистема, дает доступ к Сети тем, кто не

(Местная входит в научное общество или правительственные службы.

система)

IMHO In My Humble Opinion (По моему скромному мнению).

Internet Всемирная система, объединяющая меньшие компьютерные сети.

Сети, объединенные в Internet, используют специальный набор

стандартов коммуникации, известный как TCP/IP.

Killfile Файл, который позволяет фильтровать поступления на Usenet,

(файл исключая сообщения на определенную тему или от определенных

исключения) лиц.

Log on/log in Вход в местную систему или общедоступную подсистему.

(регистрация)

Log off Отсоединение от системы

Lurk Чтение сообщений в группе новостей Usenet без каких бы то

(Затаиться) ни было сообщений в нее.

Mailing list В сущности, представляет собой конференцию, в которой

(Список сообщения рассылаются прямо в ваш почтовый ящик, а не в

рассылки) группу новостей Usenet. Включиться в список можно посылкой

сообщения на некоторый электронный адрес, который часто

представляет собой компьютер, автоматизирующий процесс.

MOTSS Members of the Same Sex - Участники того же пола.

Электронная связь геев и лесбиянок. Изначально сокращение

использовалось в федеральном цензе 1980 года.

Net.god Некто, кто в сети со дня основания, кто все знает и все

(Сетевой бог) перепробовал.

Net.personality Некто, достаточно самоуверенный/болтливый/досужий, чтобы

(Сетевая регулярно посылать сообщения на десятки групп новостей

личность) Usenet, и чье присутствие ощущают тысячи людей.

Net.police Презрительный термин для тех, кто хочет распространить свои

(сетевая стандарты поведения на всех пользователей сети. Часто

полиция) используется в жестоких войнах наездов (и там иногда

превращается в net.nazis - сетевые нацисты).

Netiquette Набор правил на основе зравого смысла, рассчитанных на то,

(Сетевой чтобы не осложнять жизнь другим.

этикет)

Network Система коммуникации, связывающая два или несколько

(Сеть) компьютеров. Это может быть просто нить кабеля между двумя

компьютерами на расстоянии двух метров, и может быть

оптоволоконная телефонная или спутниковая сеть, соединяющая

тысячи компьютеров в разных концах света.

Newbie Новичок в сети. Иногда это прозвище используется

(чайник) презрительно сетевыми ветеранами, которые забыли, что и они

когда-то были новичками, не знавшими ответа ни на один

вопрос. "Clueless newbie" - всегда презрительное прозвище.

Newsgroup Конференция Usenet.

(Группа

новостей)

NIC Network Information Center - Сетевой Информационный Центр.

Настолько близко к понятию центра сети, насколько это

вообще возможно в сети типа Internet. Здесь обычно можно

найти информацию о конкретной сети.

NSA line eater Наиболее осторожные/параноидальные пользователи Сети верят,

(строчко- что агентство национальной безопасности (National Security

глотатель Agency) обладает огромной мощности компьютером, который

NSA) читает все, что идет через Сеть. Они шутливо (?) адресуются

к этому строчкоглотателю в своих посланиях. Восходит к

первым дням Сети, когда концы сообщений иногда пропадали

без видимой причины.

NSF National Science Foundation - Национальный Фонд Науки.

Содержит NSFNet - высокоскоростную сеть, которая когда-то

была хребтом Internet в США.

Offline Когда вы не соединены с местной системой или Сетью,

(Автономный вы находитесь в автономном режиме.

режим)

Online Ваш компьютер соединен с электронной службой, электронной

(На связи) доской объявлений или общедоступной системой.

Ping Программа, которая может отследить маршрут сообщения от

вашей подсистемы к другой.

.plan file Файл, в котором собрано все, что вы хотите сообщить о себе

(файл .plan) другим пользователям сети. Вы помещаете этот файл в свою

домашнюю директорию на вашей местной общедоступной системе.

После этого каждый, кто указывает на вас программой

fingers, увидит этот файл.

Post Составить сообщение и послать его в группу новостей на

(Послать прочтение остальным.

сообщение)

Postmaster Человек, к которому следует обратиться в конкретной

подсистеме, чтобы попросить информацию о ней или

пожаловаться на поведение пользователя.

Protocol Метод, используемый для передачи файла между местной

(Протокол) системой и компьютером. Их несколько типов, например,

Kermit, YMODEM и ZMODEM.

Prompt Местная система просит вас что-то сделать и ждет ответа.

(Приглашение) Например, если вы видите "login:", введите свое имя

пользователя.

README files Файлы, имеющиеся на подсистемах FTP, объясняющие, что

(файы README) представляет собой данная директори FTP или дающие другую

полезную информацию (например, как пользоваться FTP).

Real Soon Now Неопределенный термин, описывающий, когда нечто на самом

(Как только, деле произойдет.

так сразу)

RFC Request for Comments (Запрос комментариев). Серия

документов, описывающих разные технические аспекты

Internet.

ROTFL Rolling on the Floor Laughing - Катаюсь по полу от смеха.

Ответ на особо смешной комментарий.

ROT13 Простой способ кодировать грубые шутки, обзор фильмов с

продолжением, порнографию и пр. Суть в том, что каждая

буква заменяется той, что отстоит от нее на 13 позиций в

алфавите. Существуют декодеры, работающие в момент сеанса

связи, в nn и rn они встроены.

RTFM Read the ....ing Manual. - Читайте свое ....

руководство. Часто используется в наездах на тех, кто

задает вопросы, ответы на которые можно за несколько

минут найти в руководстве. Вежливее - RTM.

Screen capture Часть коммуникационного пакета, открывающая файл в вашем

(Перехват компьютере и записывающая туда все, что проходит по экрану

экрана) в сеансе связи с местной системой.

Server Компьютер, который может автоматически рассылать информацию

(Сервер) и файлы в ответ на специально закодированное сообщение

электронной почты.

Shareware Программное обеспечение, доступное в Сети бесплатно. Если

вам нравится это программное обеспечение и вы пользуетесь

им, пошлите запрошенный гонорар автору, чье имя и адрес

содержатся в рассылаемом файле с программным обеспечением.

.sig file Иногда - файл подписи (.signature). Файл, который, будучи

(файл .sig) помещен в вашу домашнюю директорию на общедоступной

подсистеме, будет автоматически добавляться ко всем

написанным вами сообщениям на Usenet.

.sig quote Глубокомысленное/остроумное/еще какое-нибудь изречение,

(цитата .sig) которое включается в ваш файл .sig.

Signal-to-noise Количество полезной информации, находимой в конкретной

ratio группе новостей Usenet. Часто с пренебрежительным оттенком,

(Отношение например: "В этой группе новостей очень низкое

смгнал-шум) отношение сигнал - шум"

SIMTEL20 White Sands Missile Range поддерживало гигантскую

коллекцию бесплатного и дешевого программного

обеспечения, которое "отражалось" на многие другие

подсистемы ftp в Сети. Осенью 1993 года Военно-Воздушные

Силы решили, что у них есть еще чем заниматься, кроме

ведения библиотеки бесплатного программного обеспечения,

и закрыли ее. Но ссылки на коллекцию с именем SIMTEL20 все

еще можно видеть в Сети.

Smiley Способ электронного выражения эмоций. Наклоните голову

(Смайлик) влево и посмотрите на эту картинку :-). Смайлики

бывают разные - от хохочущего до унылого.

Snail mail Письмо, которое приходит на бумаге в почтовый ящик на

(письмо- вашей входной двери.

улитка)

Sysadmin Системный администратор; человек, который управляет местной

или общедоступной подсистемой.

Sysop Системный оператор. Тот, кто ведет электронную доску

объявлений (BBS)

TANSTAAFL There Ain't No Such Thing As A Free Lunch.

(Танстаафл) Дармовой закуски не бывает.

TCP/IP Transmission Control Protocol/Internet Protocol. (Протокол

управления передачей/Протокол Internet) Конкретная система

передачи данных через компьютерную сеть - основа Internet.

Telnet Программа, которая позволяет связаться с другими

компьютерами в Internet.

Terminal Есть несколько способов определить, каким образом ваша

emulation клавиатура и экран должны взаимодействовать с операционной

(Эмуляция системой общедоступной подсистемы. Большинство

терминала) коммуникационных программ предлагают выбор "эмуляции", что

позволяет копировать поведение клавиатуры, которая обычно

присоединяется к компьютеру.

UUCP Unix-to-Unix CoPy (Копирование из Unix в Unix). Метод

передачи поступлений на Usenet и электронной почты, который

требует гораздо меньше сетевых ресурсов, чем TCP/IP, но

работает гораздо дольше.

Upload Копирование файла из вашего компьютера в местную

(Загрузка систему

"Вверх")

User name В большинстве местных систем при первом соединении вас

(Имя попросят назвать имя пользователя, состоящее из одного

пользователя) слова. Это может быть любая комбинация букв и цифр.

VT100 Еще одна система эмуляции терминала. Она поддерживается

множеством коммуникационных программ и общепринята в Сети.

Более новая версия - VT102

Приложение B: ОБЩАЯ ИНФОРМАЦИЯ ОБ АССОЦИАЦИИ ELECTRONIC FRONTIER FOUNDATION

Electronic Frontier Foundation (EFF) - членская организация, основанная в

июле 1990 года, чтобы гарантировать сохранность принципов заложенных в

Конституции и Декларации Прав в связи с появлением новых

технологий связи.

С самого начала EFF старалась объединить национальную инфраструктуру

коммуникаций и политические структуры, которые смогли бы ей управлять

чтобы поддерживать Первую Редакцию, конфиденциальность

и другие демократические начала. Мы полагаем, что нашей общей целью должно

быть создание Электронной Демократии, в связи с этим наши центры работают

над следующими вопросами:

∙ новые законопроекты, защищающие основные конституционные гражданские

права пользователей новых коммуникационных технологий,

∙ стратегия общих требований цензуры для всех служб сети, чтобы любые

высказывания, даже если они спорны, не подвергались какой-либо

дискриминации,

∙ Национальная Общедоступная Сеть, где голос, данные и видео-услуги

доступны всем гражданам на равноправной основе, и

∙ многообразие сообществ, которые дают возможность всем гражданам

иметь свой голос при достижении "информационного" возраста.

Зарегистрируйте нас!

Я желаю стать членом ассоциации Electronic Frontier Foundation. Я вношу:

$__________ Регулярное членство - $40

$__________ Членство для учащегося - $20

Специальный вклад

Я желаю сделать взнос в размере $__________ для дальнейшей поддержки

деятельности ассоциации EFF и расширения своего участия в организации.

Документы доступные в виде твердых копий

Следующие документы доступны для бесплатного получения от

Electronic Frontier Foundation.

Пожалуйста укажите любой из документов, который вы хотите получить.

___ Open Platform Proposal - EFF's proposal for a national

telecommunications infrastructure.

12 страниц. Июль, 1992.

___ An Analysis of the FBI Digital Telephony Proposal - Response of

EFF-organized coalition to the FBI's digital telephony proposal of Fall,

1992.

8 страниц. Сентябрь, 1992.

___ Building the Open Road: The NREN and the National Public Network - A

discussion of the National Research and Education Network as a prototype

for a National Public Network.

20 страниц. Май, 1992.

___ Innovative Services Delivered Now: ISDN Applications at Home, School,

the Workplace and Beyond - A compilation of ISDN applications currently in

use.

29 страниц. Январь, 1993.

___ Decrypting the Puzzle Palace - John Perry Barlow's argument for strong

encryption and the need for an end to U.S. policies preventing its

development and use.

13 страниц. Май, 1992.

___ Crime and Puzzlement - John Perry Barlow's piece on the founding of

the Electronic Frontier Foundation and the world of hackers, crackers and

those accused of computer crimes.

24 страницы. Июнь, 1990.

___ Networks & Policy - A quarterly newsletter detailing EFF's activities

and achievements.

Ваша контактная информация:

Имя: _________________________________________________________

Организация: _________________________________________________

Адрес: _______________________________________________________

_______________________________________________________

Телефон: (____) _______________ Факс: (____) _______________ (не обязательно)

Адрес E-почты: _______________________________________________

Способ платежа

___ Вложенный чек для оплаты Electronic Frontier Foundation.

___ Пожалуйста возьмите плату с моей:

___ MasterCard ___ Visa ___ American Express

Номер карточки: ________________________________________

Дата истечения срока: __________________________________

Подпись: _______________________________________________

Стратегия конфиденциальности

Иногда EFF использует наш список рассылки по почте совместно с другими

организациями, преследующими подобные цели. Однако, мы уважаем

индивидуальное желание сохранять конфиденциальность и не будем

распространять ваше имя без вашего согласия.

___ Я предоставляю разрешение EFF на распространение моего имени и

контактной информации в организациях, преследующих подобные цели.

Распечатайте и вышлете по следующему адресу:

Membership Coordinator

Electronic Frontier Foundation

1001 G Street, N.W.

Suite 950 East

Washington, DC 20001

202/347-5400 voice

202/393-5509 fax

Electronic Frontier Foundation есть некоммерческая, 501(c)(3) организация,

существующая на основании вкладов ее индивидуальных членов, корпораций и

частных основателей. Все взносы облагаются налогом.