Установка модема

Глава 1. Установка модема

Установка внешнего модема

Для установки модема необходимо выбрать место, расположенное недалеко от сетевой розетки. Расстояние от модема до подключаемого к нему компьютера или терминала ограничено длинной кабеля RS-232C.

Убедитесь, что Вам видны индикаторы на передней панели, и легко доступен выключатель питания.

Подключение компьютера, терминала или принтера

Для подключения модема к терминалу или другому устройству, необходимо:

  1. Вставить один конец кабеля RS-232C в соответствующий раз'ем на задней панели модема
  2. Подключить второй конец кабеля к соответствующему раз'ему Вашего компьютера, терминала или другой аппаратуры, используемой совместно с модемом. Если при этом вы испытываете затруднения, обратитесь к руководству по Вашему оборудованию или к поставщику.
  3. После соединения кабеля проверьте настройки вашего терминала или коммуникационной программы для сигналов Carrier Detect (CD) и DTR. Сигнал CD управляется командой &Cn, реакция на сигнал DTR задается командой &Dn (или переключателем 3). Для более полной информации об этих командах обратитесь к Приложению A.

Внимание! Прежде, чем подсоединять или отсоединять кабель RS-232, убедитесь, что все оборудование - и модем, и компьютер (терминал), отключено от сети. Подключение кабеля при работающей аппаратуре может привести к повреждению модема или последовательного порта компьютера.

Подключение источника питания

Для подключения источника питания

  1. Вставьте кабель от прилагающегося к модему блока питания в круглый раз'ем находящийся на задней панели модема рядом с выключателем.
  2. Подсоедините блок питания к сети 220 вольт.
  3. Включите питание модема с помощью переключателя POWER на задней панели. Исправный модем выполнит самотестирование (которое может продолжаться около секунды), после чего должны погаснуть все индикаторы, кроме MR, TR и (возможно) AA.
  4. Включите компьютер, или другое оборудование, подключенное к модему.
Индикаторы состояния внешнего модема
AA
Индикатор AA (AutoAnswer) загорается, когда модем установлен в режим автоматического ответа на входящий звонок.
TR
Индикатор TR (Data Terminal Ready) загорается, когда модем получает сигнал DTR. Коммуникационное программное обеспечение вашего компьютера устанавливает этот сигнал в состояние 'On', когда компьютер готов к приему или передаче данных. Данный индикатор не светится при работе с компьютером Macintosh, который использует сигнал DTR для другой цели.
OH
Индикатор OH (Off Hook) светится когда модем "поднимает трубку" т.е. подключается к телефонной линии. (Он может мигать во время импульсного набора номера.)
CD
Индикатор CD (Carrier Detect) светится, когда модем обнаруживает несущую удаленного модема
HS
Индикатор HS (High Speed) загорается при работе модема с "высокой скоростью". В моделях IDC-1414 и IDC-1914 это означает любую скорость, превышающую 1200 bps.
TD(SD)
Индикатор TD (Transmit Data) мигает всякий раз, когда происходит передача данных от терминала к модему. При непрерывной передаче данных на высоких скоростях этот индикатор может светиться почти постоянно.
RD
Индикатор RD (Receive Data) мигает, когда модем передает данные Вашему терминалу. При непрерывной передаче данных на высоких скоростях этот индикатор может светиться почти постоянно.
MR
Индикатор MR (Modem Ready) светится постоянно, если модем исправен и включен в сеть. Индикатор может мигать, когда модем выполняет самотестирование (описанное в Приложении D).

Следующий раздел посвящен установке внутреннего модема. Пользователю внешнего модема следует перейти к главе "Подключение к телефонной линии".

Установка внутреннего модема

Данный внутренний модем предназначен для установки в IBM-PC/AT/286/386/486 или совместимый персональный компьютер, поэтому все дальнейшее изложение материала дано применительно к этим компьютерам. Если Вы по каким либо причинам хотите установить модем в компьютер другого типа, Вам следует проконсультироваться о возможности такой установки у своего поставщика или на фирме-изготовителе Вашего компьютера.

Как снять кожух с компьютера

Чтобы снять кожух Вашего компьютера необходимо выполнить следующие действия:

  1. Обязательно выключите питание. Какие либо установки и переключения при включенном питании недопустимы и могут привести к повреждению оборудования! Рекомендуется в целях безопасности отсоединить сетевой шнур.
  2. Убедитесь, что имеется свободный доступ к задней панели компьютера, куда выведены разъемы для подключения кабелей.
  3. Отвинтив соответствующие винты, осторожно снимите кожух.
Как правильно установить микропереключатели на плате модема

IBM-совместимые компьютеры поддерживают работу до 4-х последовательных портов ввода вывода, (в дальнейшем COM-портов), называющихся COM1, COM2, COM3, COM4. Каждому из этих портов соответствует свой диапазон адресов в адресном пространстве ввода-вывода машины, по которым процессор обращается к соответствующему порту ввода/вывода. Физически аппаратура COM-портов располагается на плате специального адаптера или на универсальной плате ввода-вывода, а в некоторых системах и непосредственно на материнской плате. Установка внутреннего модема равносильна добавлению в Вашу систему еще одного COM-порта. Обычно аппаратура COM-портов сконструирована так, чтобы она при помощи съемных перемычек или микропереключателей могла быть настроена на любой адрес. Где бы физически ни располагались COM-порты, важно, чтобы каждый из них был настроен на свой адрес, причем так, чтобы эти адреса не перекрывались. Если в вашем компьютере не установлено COM-портов то Вы можете смело использовать заводские установки модема соответствующие COM1 и пропустить дальнейший материал данного раздела. В противном случае установите микропереключатели модема в соответствии с документацией.

Внимание! При работе с COM-портами используются линии запроса прерываний (IRQ): стандартно с COM1 и COM3 - IRQ4 а с COM2 и COM4 - IRQ3. Предположим что в Вашей системе используется "мышь", подключенная через COM2, и последовательный принтер, подключенный к COM1. Добавление в вашу систему модема, сконфигурированного как COM3 c IRQ4, вызовет конфликт с принтером, если последний работает в режиме фоновой печати, из-за попытки двух портов COM1 и COM3 захватить одну и ту же линию прерывания IRQ4. Если модем сконфигурировать как COM4 c IRQ 3 то аналогичный конфликт возникнет у модема и "мыши". К счастью, выход из описанной ситуации есть. Ваш модем может быть настроен помимо IRQ3, IRQ4 также на IRQ2 или IRQ5. В любом случае при выборе IRQ, отличного от IRQ3 или IRQ4, следует детально разобраться, не вызовет ли такая настройка конфликт с другими устройствами ввода-вывода Вашего компьютера, поскольку например некоторые типы стриммеров и устройств "мышь", работающих не через COM-порт, а через системную магистраль, используют IRQ2, а стандартный параллельный принтерный порт LPT2 - IRQ5. Пожалуйста, прежде чем приступать к подобного рода настройкам, внимательно изучите руководство пользователя Вашего компьютера и руководства по Вашим внешним устройствам, или обратитесь к Вашему поставщику.

Как вставить плату модема в компьютер

Плату модема можно вставить в любой свободный раз'ем на системной плате Вашего компьютера, для чего необходимо проделать следующее:

  1. Разместите корпус компьютера так чтобы Вам было удобно
  2. Выберете любой свободный слот
  3. Если на разъеме установлена пылезащитная крышка, удалите ее.
  4. Если на задней панели компьютера установлен пылезащитный кронштейн, удалите его, предварительно отвинтив крепежный винт. В некоторых случаях этот кронштейн закреплен одной - двумя точками контактной сварки. В этом случае кронштейн следует просто выломать, слегка покачивая его из стороны в сторону.
  5. Вставьте плату в разъем до упора, надавливая пальцами на края платы . При этом следите, чтобы не возникало перекосов.
  6. Закрепите плату винтом.

Подключение модема к телефонной линии

Подключение модема к телефонной линии следует производить по следующей схеме:

  1. Телефонный, шнур входящий в комплект поставки, рассчитан на подключения к телефонной розетке стандарта RJ-11. Если у вас смонтирована розетка другого типа, следует либо сменить розетку, либо подыскать шнур с соответствующей вилкой. Кроме того, шнур Вашего телефонного аппарата тоже должен оканчиваться вилкой стандарта RJ-11. Если это не так и Вы желаете использовать модем вместе с телефонным аппаратом, то у телефонного аппарата следует сменить существующую вилку на RJ-11. В любом случае, при возникновении проблем с подключением, обратитесь на телефонный узел или к поставщику.
  2. Отключите Ваш телефонный аппарат от линии, вынув вилку.
  3. Один конец шнура, входящего в комплект поставки, соедините с гнездом RJ-11 модема с надписью "WALL" или "LINE" как показано на рисунке .....
  4. Другой конец шнура подключите к телефонной розетке.

Подключение телефонного аппарата.

Конструкция Вашего модема предусматривает подключение к нему дополнительного телефонного аппарата. Это дает возможность пользоваться телефонным аппаратом для обычного разговора, когда модем не используется, или для ручного набора номера.

Подключение телефонного аппарата к модему следует производить по следующей схеме:

  1. Подключите шнур Вашего телефонного аппарата в розетку модема с надписью "PHONE".
  2. Снимите трубку телефонного аппарата. Если все подключено правильно, вы должны услышать непрерывный гудок - "ответ станции".
  3. Повесьте трубку.

Проверка соединений.

Включите компьютер и загрузив Ваш телекоммуникационный пакет, переведите его в режим эмуляции терминала. Подразумевается, что Ваше программное обеспечение настроено должным образом, в соответствии с прилагаемым к нему руководством.

Проверку аппаратуры следует производить по нижеприведенной схеме:

  1. Введите команду AT (она должна отобразиться на экране), в ответ модем должен послать сообщение "OK" и ждать ввода следующей команды.

    Внимание! Здесь и далее в этом документе слова "Введите команду XXX" означают, что необходимо набрать на клавиатуре строку XXX и завершить ввод нажатием клавиши <ENTER>.

    Возможно, что вместо "OK" вы увидите "0", или увидите ответ, но сама команда не отобразится на экране - это означает, что используемая коммуникационная программа перевела модем в режим числовых ответов или в режим подавления эха. Попытайтесь исправить ситуацию командой AT Z. Если и после этого вы не увидите сообщения "OK" - обратитесь к поставщику.

    Если ответа нет, то вероятнее всего программное обеспечение или аппаратура настроены неверно, не совпадают формат или скорость передачи данных или программа настроена на работу не с тем COM-портом, на котором установлен модем. Убедитесь что программное обеспечение настроено на работу со скоростью 300, 1200, 2400, 9600, или 19200 бит/с. Проверьте настройку COM-портов. Если и после исправления возможных ошибок система не работает, то вероятно проблема вызвана неисправностью или несовместимостью аппаратуры. В этом случае обратитесь к Вашему поставщику.

  2. С помощью Вашего телекоммуникационного программного обеспечения можно попробовать заставить модем позвонить самому себе. Наберите команду ATD x <номер_телефона>, где x означает D, если Ваша АТС работает с импульсным набором номера и T, если с тональным. Под словом <номер_телефона> понимается последовательность цифр номера к которому подключен Ваш модем.

    Например, если Ваш модем подключен к номеру 555-12-34 и АТС работает с импульсным набором номера наберите ATDP 555 12 34.

  3. В ответ на эту команду модем замкнет линию и, услышав непрерывный гудок, начнет набирать номер. При этом в динамике модема можно слышать характерные щелчки. Очевидно, что результатом попытки позвонить самому себе будет сигнал "занято" и модем, услышав короткие гудки, должен выдать сообщение "BUSY".

На этом минимальную проверку оборудования можно считать законченной. Итак, Ваш модем готов к работе. И если Вы не собираетесь разбираться в тонкостях, можно пропустить дальнейшее изложение и работать с модемом, используя стандартные процедуры предлагаемые Вашим телекоммуникационным ПО. Если же вы решили глубже разобраться в работе с модемом, внимательно изучите последующие главы.


Основные понятия

Глава 2. Основные понятия

Глава 2 содержит основные сведения о модемах и принципах передачи данных, а также описание вопросов совместимости модемов и факсов. Опытный пользователь может пропустить эту главу.

Что такое модем

Как известно, данные в компьютере представлены в цифровой форме - закодированные в виде нулей и единиц, которым физически соответствует низкий или высокий уровень напряжения. Телефонная же сеть рассчитана на передачу речевых сообщений, представляемых в форме аналоговых электрических сигналов, поэтому непосредственная передача цифровой информации через телефонную сеть невозможна.

Итак, для преобразования форм представления информации необходимо некоторое устройство включаемое между компьютером и телефонной линией. Такое устройство называют модемом (сокращение от МОДулятор-ДЕМодулятор).

В общих чертах, связь через модем работает следующим образом: Пусть два компьютера соединены через модемы друг с другом по телефонной линии. Тогда поток данных из первого компьютера в цифровой форме поступает в модем первого компьютера, где преобразуется в аналоговую форму, пригодную для передачи по телефонному каналу. С выхода первого модема преобразованные в аналоговую форму данные попадают в телефонную линию.

Процесс преобразования данных из цифровой в аналоговую форму называется модуляцией.

В свою очередь, аналоговый сигнал, попав из телефонной линии на вход модема второго компьютера, преобразуется в цифровой поток данных, который принимается вторым компьютером.

Процесс преобразования данных из аналоговой формы в цифровую называется демодуляцией.

Таким образом, основное назначение модема - преобразование данных из цифровой формы в аналоговую, пригодную для передачи по телефонному каналу и наоборот из аналоговой в цифровую, воспринимаемую компьютером.

Модемы по способу подключения к телефонному каналу делятся на акустические и с непосредственным подключением. Ваш модем относится ко второму классу устройств, так как электрически связан с телефонной линией.

Являясь интеллектуальным устройством, Ваш модем поддерживает такие функции, как автоматический набор номера и автоответ. Автонабор освобождает Вас от необходимости вручную набирать номер другого модема, а автоответ позволяет Вашему модему автоматически отвечать на звонки других модемов, причем ваш модем автоматически освобождает линию ("вешает трубку"), при разрыве соединения вызывающей стороной. Для получения детальной информации об автонаборе и автоответе обратитесь к главам 4 и 5 соответственно.

Что такое скорость передачи данных

Выше указывалось, что основным назначением модема является преобразование цифровых данных в аналоговую форму, пригодную для передачи через телефонную сеть. Итак, передающему модему от компьютера передается поток бит. В зависимости от физического протокола передачи данных, по которому работает модем, при модуляции модем ставит в соответствие каждому биту или последовательности бит цифровой информации некий аналоговый сигнал. Единицей скорости изменения сигнала (т.е. скорости передачи в канале) является бод. Нас,как правило, будет интересовать скорость передачи цифровых данных, а не скорость передачи в канале, поэтому, в дальнейшем, под скоростью передачи данных будем подразумевать цифровую скорость передачи и пользоваться единицами измерения бит/с.

Так как в одном изменении состояния сигнала может быть закодированно несколько бит информации, очевидно, что скорость передачи цифровых данных и скорость работы канала совпадают далеко не всегда. Поэтому не следует смешивать понятия бод и бит/с.

В зависимости от модели Вашего и удаленного модема, вы можете устанавливать соединения на следующих скоростях:

Если модем поддерживает протокол

  • V.32bis - максимальная скорость составляет 14400 бит/с.
  • V32 - 9600 бит/с.
  • V22/V22bis - 2400 бит/с.

В среднем, при передаче данных через модем, каждым десяти переданным битам соответствует 1-байт или символ машинописного текста. Часто скорость передачи данных измеряют в символах в секунду (обозначается cps - от английского Character Per Second) Поэтому передаче данных на скорости 14400бит/с будет соответствовать приблизительно 1440 cps (для асинхронного метода передачи).

Установление соединений для передачи данных

Когда Вы звоните на другой модем или Ваш модем отвечает на звонок удаленного модема, модем пытается установить соединение для передачи данных на максимально возможной скорости. Эта особенность позволяет свести к минимуму время занятости телефонного канала и уменьшить стоимость передачи данных.

Если линия зашумленная или удаленный модем не поддерживает высокую скорость передачи, Ваш модем может автоматически переходить на более низкую скорость до тех пор, пока не найдет подходящую. После этого два модема начинают обмениваться специальными сигналами подтверждения (handshake), при помощи которых согласовываются протоколы передачи данных. Если модемы установили соединение, то Ваш модем выдает соответствующее сообщение CONNECT ( например CONNECT 2400 ) и модемы начинают обмен данными.

Телекоммуникационное программное обеспечение

Для работы с модемом требуется телекоммуникационное программное обеспечение. В настоящее время поставляется большое количество телекоммуникационных пакетов. Ваш модем совместим с большинством из них.

После загрузки коммуникационной программы Вы можете перевести ее в режим эмуляции терминала (в разных пакетах этот режим может называться по разному, например terminal mode или direct mode), управляя модемом при помощи AT-команд, вводимых вручную, и получая ответы модема, выдаваемые на экран. Однако, большинство коммуникационных пакетов позволяет делать это более простым путем, при этом программа служит как бы буфером между пользователем и модемом, позволяя управлять модемом не только с помощью AT-команд, но и через систему меню, а так же выполнять более сложные процедуры по передаче файлов, ведению записных книжек, автодозвону до абонента, эмуляцию различных терминалов и т.п.

Если вам не интересно, что происходит "за экраном дисплея" и как управлять модемом напрямую с помощью AT-команд, можно сразу после загрузки ПО приступить к работе с модемом и пропустить остальные главы этого руководства.

Работа в асинхронном режиме

Существуют два метода обмена данными - синхронный и асинхронный. Синхронный метод поддерживается только внешним модемом и используется достаточно редко. Если вы все же пользуетесь синхронным устройством, обратитесь к главе () данного руководства.

В асинхронном режиме при передаче байта, (группа бит, кодирующая передаваемый символ), наряду с битами данных в поток вставляются служебные биты: стартовый бит, стоповые биты, иногда биты контроля четности.

Итак:

  • стартовый бит: Указывает начало байта данных
  • биты данных : собственно данные
  • бит четности : Проверочный бит, обычно устанавливаемый в ноль или единицу так, чтобы общее число единиц в байте было всегда или четно, или нечетно. Этот бит используется для контроля правильности передачи данных при работе с большими машинами (mainframes).
  • стоповые биты: Один или два бита, означающих конец передаваемого байта.

Режим команд и режим данных

  • Переключение модема в командный режим
  • Переключение модема в режим данных
  • Смена режима

Ваш модем может находиться в одном из двух основных режимов - командном режиме или режиме данных. В командном режиме модем исполняет команды, выдаваемые оператором. В режиме данных модем воспринимает все, что может быть получено от компьютера как данные, которые должны быть переданы в линию. Таким образом, бесполезно вводить команды в режиме данных, так как модем не воспримет их как команды.

Ниже описано, как модем переключается между этими режимами.

Переключение модема в командный режим

Модем автоматически переключается в командный режим в следующих случаях:

  • При включении питания Вашего компьютера
  • При потере соединения с удаленным модемом
  • Если модем набирает номер, а Вы нажали какую-нибудь клавишу на клавиатуре Вашего компьютера. ( В этом случае, перед тем как перейти в командный режим, модем аннулирует текущий вызов.)
  • При обнаружении перехода сигнала DTR (Data Terminal Ready) из состояния "ON" ("включен") в "OFF" ("выключен"), если задана одна из команд &D1, &D2 или &D3.

Переключение модема в режим данных

Модем автоматически переходит в режим данных после установления соединения с удаленным модемом или факсом.

Как описывалось выше, в момент установления соединения, модемы проводят обмен подтверждающими сигналами (handshake), после чего начинают обмен данными. Обычно, в момент установления соединения и при передаче данных, звук в динамике модема отключается, однако, если необходимо слышать, что происходит на линии, то можно включить постоянный аудиоконтроль командой M2.

Смена режима

Если Ваш модем установил асинхронное соединение с удаленным модемом, то перевести его в командный режим, не разрывая текущее соединение, можно, введя с клавиатуры специальную управляющую последовательность символов, которая называется Escape-последовательностью.

По умолчанию, Escape-последовательностью является последовательность из трех подряд символов "плюс" - "+++". Если требуется, данные символы можно заменить, изменив содержимое регистра S2. Подробнее об этом читайте в Главе 7.

Ниже приводится процедура, в которой описано, как при помощи Escape - последовательности переходить из режима данных в командный режим, не теряя при этом установленного соединения.

  • Escape-символы в синхронном режиме игнорируются
  1. после установления асинхронного соединения с удаленным модемом подождите не менее одной секунды, прежде чем что-либо набирать.
  2. Введите Escape-символ три раза, по-умолчанию три подряд символа "+" и подождите не менее одной секунды.
  3. Примерно через 1-2 секунды модем должен выдать OK и перейти в командный режим без разрыва соединения.

    Теперь можно посылать модему AT-команды, например для чтения или изменения значений S-регистров.

  4. Для возобновления передачи данных (если вы не разорвали соединение) наберите ATO и нажмите <Enter>, модем выдаст сообщение "CONNECT nnnn", где nnnn - скорость установленного соединения, после чего вернется в режим данных.

    Естественно, такой возврат возможен только в том случае, если Вы не выдавали команд, приводящих к разрыву соединения.

    Вместо команды O можно пользоваться и другими командами:

Если Вы желаете, чтобы, помимо обычного возврата в режим данных, Ваш и удаленный модем провели также и тестирование канала с целью оптимизации параметров передаваемых ими сигналов с учетом особенностей данного канала (затухание, отражения, несогласованность и т.д.), воспользуйтесь командой O1.

Если и Ваш, и удаленный модем поддерживают протоколы исправления ошибок и сжатия данных (MNP, V.42, V.42bis) и Вы хотите возобновить дальнейшую передачу данных с использованием этих протоколов (причем первоначально соединение установлено без использования протоколов коррекции ошибок), следует использовать команду \O (введите AT \O <Enter>)

Ввод AT-команд

Для управления функциями модема, такими как набор номера, установление соединения для передачи данных или факс-сообщений, ответ удаленному модему или разъединение, используются AT-команды. Для того, чтобы ввести AT-команду, необходимо набрать командную строку, завершив ее клавишей <Enter>, когда модем находится а командном режиме. Детально работа с AT-командами описывается в Главе 3.

Сообщения модема.

После того, как Вы послали модему команду и ее выполнение завершено, модем выдает сообщение о результатах (обычно подтверждающее сообщение "OK").

Замечание. Некоторые коммуникационные программы перехватывают это сообщение и Вы не всегда можете видеть ответы модема у себя на экране.

Полное описание всех выдаваемых модемом сообщений приведено в Главе 3.

Вопросы совместимости

В таблицах 2-2 и 2-3, соответственно, приведены стандарты протоколов передачи данных и факс-сообщений поддерживаемые Вашим модемом. Здесь же указаны максимальные скорости передачи данных, возможные при работе в соответствии с тем или иным протоколом.

Таблица 2-2 Протоколы передачи данных
Максимальная скорость, бит/с | Стандарт
14400 | МКТТ V.32bis
9600 | МКТТ V.32
2400 | МКТТ V.22bis
1200 | МКТТ V.22
1200 | Bell 212
1200/75 | МКТТ V.23
300 | МКТТ V.21
 | Bell 103

Таблица 2-3 Протоколы передачи факс-сообщений
Максимальная скорость, бит/с | Стандарт
14400 | МКТТ V.17
9600 | МКТТ V.29
7200 |
4800 |
4800 | МКТТ V.27ter
2400 |
300 | МКТТ V.21 CH. 2


Управление модемом

Глава 3. Управление модемом

В главе 3 описан формат AT-команд. Здесь также описаны возможные сообщения, выдаваемые модемом в ответ на введенную команду.

Обычно пользователи работают с модемом посредством развитых телекоммуникационных программами, в этом случае нет необходимости управлять модемом посредством AT-команд напрямую и анализировать непосредственные ответы модема. Программа сама посылает команды и обрабатывает сообщения модема. Иными словами, весь интерфейс низкого уровня скрыт от пользователя, которому обычно не важно, что именно телекоммуникационный пакет посылает модему и какие сообщения получает в ответ, для того, чтобы, например, передать файл или положить письмо в ящик электронной почты, так как Вас, как правило, интересует конечный результат, а не способ его достижения.

Впрочем, если Вам по каким либо причинам требуется управлять модемом напрямую, то сведения изложенные в настоящей главе окажутся как нельзя кстати.

Ввод команд

  • Как исправить неправильно набранную команду
  • Как набирать команды в виде, наиболее удобном для восприятия
  • Ввод командных строк длиной более сорока символов
  • Пропуск параметров (параметры по умолчанию)
  • Повторное выполнение командной строки
  • Сведения о командах

С помощью AT-команд Вашему модему можно приказать исполнять большое количество разнообразных функций, среди которых - набор номера, ответ удаленному модему, действия по передаче факсов и многие другие. Однако, модем воспринимает AT-команды тогда и только тогда, когда он находится в командном режиме.

Чтобы ввести AT-команду, сделайте следующее:

  1. Наберите AT в латинском регистре (вообще, всюду в данном документе все символы команд набираются в латинском регистре). Эти две буквы всегда должны стоять в начале командной строки (за исключением случая A/, описанного ниже). Допустимо использовать или заглавные, или строчные буквы, но не те и другие одновременно ( AT или at, но не At)
  2. Наберите команду или подряд несколько команд, которые Вы хотите исполнить. Длина командной строки не должна превышать 40 символов.
  3. Нажмите клавишу <Enter>. Модем выполнит командную строку и выдаст сообщение о результате.

Как исправить неправильно набранную команду.

Если при наборе команды вы обнаружили ошибку, то для ее исправления следует клавишей <BackSpace> ("забой") стереть неверные символы и набрать остаток командной строки заново. Таким способом можно исправлять любые неверно набранные команды, за исключением самого префикса AT.

Как набирать команды в виде, наиболее удобном для восприятия.

Чтобы сделать набранную командную строку более удобочитаемой и, тем самым, избежать возможных ошибок, допустимо отделять отдельные команды и поля параметров знаками препинания и пробелами. В любом месте командной строки допускается ставить пробел. В телефонном же номере допустимы кроме пробелов и знаки скобок, и дефис.
Например:

  AT M3 DT 9, 1 (818)555-1234

При разборе командной строки модем игнорирует пробелы и указанные знаки препинания. Однако, длина строки команд вместе с этими знаками не должна превышать 40-символьный лимит.

Ввод командных строк длиной более 40 символов

Если Вы хотите ввести строку длиной более 40 символов, вам придется разбить ее на две отдельные строки и вводить каждую отдельно. В случае, если требуется ввести очень длинную команду набора номера D (к примеру, команда для набора номера и выдачи тонового пароля может оказаться значительно длиннее), наберите сначала первую часть номера, длиной до 39 символов (вместе с самой командой AT, D и прочими символами), в конце поставьте ';' и нажмите <Enter>. При этом модем, исполнив команду, вернется в командный режим и Вы сможете набрать еще одну команду D с оставшейся частью номера.

Пропуск параметров (параметры по умолчанию)

Некоторые команды требуют задания числовых параметров, однако при вводе эти параметры можно опустить, тогда модем, исполняя команду, будет использовать параметр, принятый по умолчанию. Везде в этом документе, где явно не указано иное, значением параметра по умолчанию является 0.

Например, команда Q - "Задать режим выдачи ответов" имеет параметр 0 или 1.

Q0 - говорит модему, что тот обязан сопровождать каждую выполняемую команду подтверждающим сообщением.
Q1 - запрещает какие либо подтверждения.
При этом ввод Q без параметра (например AT Q) эквивалентен Q0.

Другим хорошим примером является строка инициализации, используемая программой MTEZ с некоторыми модемами, часто вызывающая удивление пользователей:

  AT S=Q

которую можно записать в более понятном виде, как AT S0=0 Q0 (т.е. запретить автоматический ответ и разрешить выдачу подтверждений).

Повторное выполнение командной строки.

Следует отметить, что последняя введенная командная строка хранится в памяти модема до тех пор, пока ее не заменит следующая команда. Поэтому имеется возможность повторить исполнение последней командной строки. Для этого служит специальная команда A/. Поскольку при выключении питания или аппаратном сбросе содержимое буфера командной строки разрушается, очевидно, что в этом случае пытаться повторить последнюю командную строку бессмысленно.

Внимание! Команда A/ набирается без стандартного префикса AT и не завершается клавишей . Просто наберите A/ и модем автоматически выполнит предыдущую команду.

Команда A/ обычно используется для повторного выполнения длинной команды или для перенабора телефонного номера, который был занят.

Команду A/ можно использовать неоднократно, до тех пор, пока не будет набрана новая командная строка, начинающаяся с AT, или не произойдет сброс модема или выключение питания.

Сведения о командах.

Теперь, когда вы знаете, что такое команды и как они задаются, обратитесь к следующим главам для полного описания доступных команд.

  • Команды для вызова удаленного модема описаны в Главе 4.
  • Команды, используемые при ответе на звонок удаленного модема, описаны в Главе 5.
  • Команды работы с протоколами исправления ошибок и сжатия данных описаны в Главе 7.

Сообщения модема

  • Текстовые и числовые сообщения
  • Наборы сообщений
  • Сообщения модема при работе с протоколами коррекции ошибок и сжатия данных

Когда Вы послыаете модему какую-либо команду, модем выдает в ответ сообщение - обычно OK. Вы можете никогда не увидеть этих сообщений, так как некоторые телекоммуникационные программы перехватывают и самостоятельно обрабатывают сообщения, до того, как они могут быть выведены на дисплей. Однако, если Вы собираетесь непосредственно управлять модемом, Вам необходимо знать, какие сообщения и в каких случаях выдает модем.

В данном разделе рассматриваются все виды сообщений, выдаваемые модемом.

Текстовые и числовые сообщения

Модем, в зависимости от настроек, может посылать два типа сообщений - в виде текста и в виде чисел (соотвественно, называемые текстовыми или числовыми сообщениями). Каждому текстовому сообщению однозначно соответствует числовое и наоборот. Как правило, большинство программ и пользователей, работающих с модемом непосредственно, используют более удобные текстовые сообщения, на которые модем настроен по умолчанию. Однако в этом тексте для краткости иногда будут указаны только соответствующие им числовые сообщения. (См. Табл. 3-1).

Если Ваше программное обеспечение требует числовых ответов, то перевести модем в этот режим можно при помощи команды V0.

Запретить получение каких либо ответов вообще (например, для модема, подключенного к принтеру) можно командой Q1.

Наборы сообщений

Модем может работать в одном из пяти режимов, задаваемых командой Xn. Каждый из этих режимов предусматривает свой метод набора номера и каждому из них соответствует определенный набор сообщений, которые может выдавать модем в ответ на введенную команду или в ответ на возникшую ситуацию, например обнаружение сигнала "занято" или установление соединения. Так как команда Xn влияет не только на вид сообщений модема, но и на метод набора номера, описание этой команды и соответствующих сообщений находится в Главе 4, в разделе "Методы набора номера".

Сообщения модема при работе с протоколами коррекции ошибок и сжатия данных

Ваш модем поддерживает протоколы исправления ошибок и сжатия данных MNP и V.42/V.42bis. При работе с этими протоколами модем выдает дополнительные сообщения, перечисленные в Таблице 3-1. Чтобы разрешить выдачу расширенного набора сообщений, следует пользоваться командой Wn.

Внимание! Команду W, разрешающую выдачу расширенных сообщений при прохождении фазы выбора протокола коррекции-сжатия данных в момент установления соединения между двумя модемами, следует отличать от модификатора W в команде D (набор номера).

По умолчанию принимается установка W0, запрещающая выдачу расширенного набора ответов, если регистр S95=0 (заводская установка). В режиме W0 все сообщения "CONNECT XXXX" соответствуют скорости обмена данными между модемом и Вашим терминалом (DTE speed).

Командой W1 разрешается выдача сообщений "CARRIER" и "PROTOCOL". В этом режиме сообщения "CONNECT XXXX" также указывают скорость обмена данными с терминалом, последнее справедливо в случае, если регистр S95=0.

Если Вы желаете, чтобы сообщение "CONNECT XXXX" указывало физическую скорость передачи данных в канале (DCE speed) вместо скорости обмена с терминалом, введите команду W2. Эта команда запрещает выдачу расширенного набора ответов, если регистр S95=0.

Модемы, поддерживающие протоколы исправления ошибок и сжатия данных MNP и V.42/V.42bis, обрабатывают также команду \V1. В этом режиме все сообщения "CONNECT" будут содержать суффикс /ARQ, если модем установил соединение с использованием протокола коррекции ошибок. Этот режим устанавливается по умолчанию.

Внимание! Многие программы могут работать некорректно в режиме W1, а некоторые - и в режиме W2, поэтому не рекомендуется изменять заводские настройки, если вы не уверены, что ваша программа способна работать с расширенными сообщениями. С другой стороны, коммуникационные программы, использующие современные протоколы передачи файлов (например, Zmodem), могут работать неустойчиво, если установлен режим W0 или отсутствуют суффиксы /ARQ в режиме W2.

Таблица 3-1
Сообщение модема | Сообщение в числовой форме | Значение сообщения
OK | 0 | Комманда выполнена успешно
CONNECT | 1 | Если модем находится в состоянии, отличном от X0, данное сообщение означает, что установлено соединение со скоростью 300 bps. В состоянии X0 оно означает, что было установленно соединение с удаленным модемом на произвольной скорости.
RING | 2 | Модем обнаружил входящий звонок
NO CARRIER | 3 | Потеряна (или не обнаружена в процессе установления соединения) несущая удаленного модема.
ERROR | 4 | Была введена неверная или недопустимая в данном режиме команда, произошел сбой аппаратуры модема или длинна коммандной строки превысила 40 символов
CONNECT 1200 | 5 | Установленно соединение на скорости 1200 bps (в режиме X0 не выдается)
NO DIALTONE | 6 | Модем не обнаружил непрерывного гудка (сигнала "набирайте"). Сообщение выдается только в режимах X2 и X4, а так же в любом режиме, если использован символ 'W' в команде набора номера.
BUSY | 7 | Модем обнаружил короткие гудки (сигнал "занято"). Это сообщение не выдается в режимах X0, X1, X2, так как определение сигнала "занято" в этих режимах не производится.
NO ANSWER | 8 | Модем не обнаружил "тишину" в линии, когда был использован символ '@' в команде набора номера.
CONNECT 2400 | 10 | Установленно соединение на скорости 2400 bps (в режиме X0 не выдается)
CONNECT 4800 | 11 | Установленно соединение на скорости 4800 bps
CONNECT 9600 | 12 | Установленно соединение на скорости 9600 bps
CONNECT 14400 | 13 | Установленно соединение на скорости 14400 bps
CONNECT 19200 | 14 | Установленно соединение на скорости 19200 bps
CONNECT 16800 | 15 | Установленно соединение на скорости 16800 bps
CONNECT 38400 | 16 | Установленно соединение на скорости 38400 bps
CONNECT 57600 | 18 | Установленно соединение на скорости 57600 bps
CONNECT 1200/REL | 22 | Установлено соединение с коррекцией ошибок на скорости 1200 bps
CONNECT 2400/REL | 23 | Установлено соединение с коррекцией ошибок на скорости 2400 bps
CONNECT 4800/REL | 24 | Установлено соединение с коррекцией ошибок на скорости 4800 bps
CONNECT 9600/REL | 26 | Установлено соединение с коррекцией ошибок на скорости 9600 bps
CONNECT 19200/REL | 27 | Установлено соединение с коррекцией ошибок на скорости 19200 bps
CONNECT 38400/REL | 28 | Установлено соединение с коррекцией ошибок на скорости 38400 bps
CARRIER 300 | 40 | Скорость обмена с удаленным модемом 300 bps
CARRIER 1200/75 V.23 | 44 | Скорость передачи 1200 bps, скорость приема - 75 bps
CARRIER 75/1200 V.23 | 45 | Скорость передачи 72 bps, скорость приема - 1200 bps
CARRIER 1200 | 46 | Скорость обмена с удаленным модемом 1200 bps
CARRIER 2400 | 47 | Скорость обмена с удаленным модемом 2400 bps
CARRIER 4800 | 48 | Скорость обмена с удаленным модемом 4800 bps
CARRIER 7200 | 49 | Скорость обмена с удаленным модемом 7200 bps
CARRIER 9600 | 50 | Скорость обмена с удаленным модемом 9600 bps
CARRIER 12000 | 51 | Скорость обмена с удаленным модемом 12000 bps
CARRIER 14400 | 52 | Скорость обмена с удаленным модемом 14400 bps
CARRIER 16800 | 52 | Скорость обмена с удаленным модемом 16800 bps (только для IDC-19xx)
CARRIER 19200 | 52 | Скорость обмена с удаленным модемом 19200 bps (только для IDC-19xx)
COMPRESSION: CLASS 5 | 66 | Установлен протокол сжатия данных MNP-5
COMPRESSION: V.42 BIS | 67 | Установлен протокол сжатия данных V.42bis
COMPRESSION: NONE | 69 | Протокол сжатия данных не установлен
PROTOCOL: NONE | 70 | Асинхронный режим, без коррекции ошибок
PROTOCOL: LAPM | 77 | Установлен протокол коррекции ошибок V.42 LAPM
PROTOCOL: ALT | 80 | Установлен протокол коррекции ошибок MNP
PROTOCOL: MNP 2,4 | 81 | Установлен байт- ориентированный протокол коррекции ошибок MNP 4
PROTOCOL: MNP 3,4 | 82 | Установлен бит-ориентированный протокол коррекции ошибок MNP 4
COMPRESSION: MNP 5 | 83 | Установлен протокол сжатия данных MNP 5


Установление исходящих соединений

Глава 4. Установление исходящих соединений
(как позвонить другому модему)

В этой главе описаны команды, используемые для вызова удаленного модема, когда Ваш компьютер работает в режиме имитации терминала. (В руководстве по вашему телекоммуникационному программному обеспечению должно быть описано как перевести его в этот режим.) Разделы настоящей главы включают:

  • установление исходящих соединений;
  • режимы набора номера;
  • использование тонального и импульсного набора номера;
  • паузы и ожидания при наборе номера;
  • набор номера при установлении соединения через местную АТС;
  • "только вызывающий" и "только отвечающий" модем;
  • набор номера телефона, находящегося в памяти;
  • автоматический набор номера при установлении голосового соединения;
  • передача тонов как данных;
  • автоматический перенабор последнего набранного номера;
  • переадресация вызова;
  • ручной набор номера;
  • разъединение;
  • список S-регистров, влияющих на набор номера.

Установление исходящих соединений

Чтобы вызвать удаленный модем:

  1. Наберите ATDxxxxxxx, где xxxxxxx номер абонента, на модем которого Вы звоните, включая модификаторы (если той же командной строке Вы хотите задать какие-либо другие команды набирайте их перед командой набора номера).

    Например команда набора номера может выглядеть так:

             ATDP 8W (095) 924-3018
    где P - модификатор импульсного набора номера, W - модификатор ожидания второго непрерывного сигнала, (095)924-3018 - номер абонента.
  2. Нажмите клавишу <Enter>

После окончания набора номера, модем ожидает ответа удаленного модема до истечения интервала времени, задаваемого регистром S7. Если за указанный интервал времени Ваш модем получил ответ, то оба модема начинают обмениваться последовательностью подтверждающих сигналов для настройки параметров. Если фаза установления соединения завершена успешно, начинается собственно передача данных и Ваш модем переходит в режим данных.

Если после набора номера получен сигнал "Занято", можно повторить набор используя команду A/.

Передача данных прекращается в следующих случаях:

  • модем теряет сигнал несущей удаленного модема;
  • модему послана команда "отбой";
  • Ваш модем обнаруживает состояние "Off" интерфейсного сигнала DTR и ему были выданы команды &D2 или &D3;
  • телекоммуникационная программа выполняет "разрыв соединения" (см. Руководство по программному обеспечению).

При этом модем разрывает соединение, возвращается в командный режим и выдает сообщение "NO CARRIER" ("потеря несущей").

Режимы набора номера

  • Режим X0
  • Режим X1
  • Режим X2
  • Режим X3
  • Режим X4

Модем может работать в одном из пяти режимов, задаваемых командой Xn. Каждый из этих режимов предусматривает свой метод набора номера и каждому из них соответствует определенный набор сообщений, которые может выдавать модем в ответ на введенную команду или в ответ на возникшую ситуацию, например обнаружение сигнала "занято" или установление соединения. Сообщения модема описаны в Главе 3.

Ниже описаны эти режимы и указано, какие наборы сообщений модема им соответствуют.

Режим X0
Набор ответов режима X0 включает в себя первые пять сообщений, приведенных в Таблице 3-1. (Т.е. сообщения 0, 1, 2, 3, 4 ,5 или соответствующие им текстовые.) При работе в режиме X0, в случае успешного установлении соединения, вы будете получать сообщение "CONNECT", без указания на какой скорости произошло соединение.

В этом режиме модем игнорирует любые сигналы АТС - через две секунды (этот интервал задается регистром S6) после ввода команды D модем начнет набор номера, вне зависимости от того, был ли обнаружен непрерывный сигнал станции. При этом так же отключается определение сигнала "занято" - модем всегда будет ждать ответа удаленного модема до истечения регистра S7, игнорируя состояние телефонной линии.

Такой режим набора номера называется набором вслепую (blind dial). Набор вслепую может быть рекомендован для использования с ATC, которые выдают нестандартный или очень тихий сигнал "набирайте" (непрерывный гудок), или вообще не выдают никакого сигнала, как некоторые мини-АТС.

Режим X1
Этот режим отличается от режима X0 только набором ответов модема - при установлении соединения к слову CONNECT будет добавлено число указывающее скорость в бит/с, т.е возможны ответы модема 0-5, а так же 10 и выше. (см Табл. 3-1). Набор номера также производится вслепую.

Режим X2
Набор сообщений режима X2 включает сообщения 0-6, 10 и выше.

В этом случае перед набором номера модем будет ожидать непрерывного гудка (сигнала "набирайте"). В случае отсутствия сигнала "набирайте" в течение 10 секунд (это время задается в регистре S75, см. Приложение B) набор номера будет прерван, модем выдаст сообщение NO DIALTONE ( "Нет сигнала 'набирайте'") или 6, если установлен режим числовых ответов.

Режим X3
Набор сообщений режима X3 включает те же сообщения 0-5, 10 и выше, что и набор X1, а так же сообщение 7.

В этом режиме используется "слепой" набор номера. Если после набора номера модем обнаруживает сигнал "занято", выдается сообщение BUSY или 7 в режиме числовых ответов.

Режим X4
Этот режим устанавливается по умолчанию.

В этом режиме модем определяет и сигнал "занято", и сигнал "набирайте". Допустимы любые сообщения из Табл. 3-1.

Таким образом, режим X0 используется, как правило, с устаревшим программным обеспечением, не способным корректно обрабатывать сообщения модема, отличные от CONNECT и NO CARRIER. Режимы X1, X2 и X3 используются при работе на линиях, выдающих нестандартные сигналы или не выдающих сигналов вообще. Режим X1 используется для отключения обнаружения сигналов "занято" и "набирайте", X2 - для отключения обнаружения сигнала "занято", а X3 - сигнала "набирайте". В обычных случаях используется режим X4.

Набор номера. Модификаторы команды набора номера.

В данном разделе описаны модификаторы набора номера, которые могут присутствовать в команде набора номера.
Модификатор Функция и пример
TТональный (DTMF) набор номера
Перед цифрами номера ставиться буква T
Пример: ATDT 555-1212
PИмпульсный набор
Перед цифрами номера ставиться буква P
Пример: ATDP 555-1212
WОжидание второго сигнала "ответ станции"
Этот модификатор используется при наборе номеров абонентов, требующих ожидания второго сигнала "ответ станции" например при междугородных звонках или при выходе в город через офисную АТС.

Например для выхода в город через местную АТС обычно нужно набрать 9 и, дождавшись непрерывного гудка городской АТС, набирать номер городского абонента. В этом случае команда набора номера может иметь вид:

ATDT 9W P 555-1212
что означает "набрать тональным сигналом цифру '9', дождаться гудка "набирайте" от городской АТС (модем будет ожидать его в течение времени, задаваемого регистром S74, по умолчанию - 20 секунд), набрать импульсным методом городской номер.

Аналогично, при звонке в другой город

ATDP8W (812) - 555-12-12
RВызов с использованием тона "ответ"
Если на конце командной строки стоит модификатор R, при установлении соединения с удаленным модемом Ваш модем вместо тона "вызов" будет использовать тон "ответ". Этот модификатор следует использовать для установления исходящих соединений с устаревшими модемами, не имеющими режима ответа. Внимание! При разборе командной строки, любые символы, набранные после R, игнорируются.
Например: ATDP555-12-12R
&Zn=xxxЗапомнить номер в памяти
здесь xxx - номер телефона, n - адрес ячейки памяти, куда записывается номер Для записи номеров доступны 4 ячейки с номерами 0,1,2 и 3, таким образом, Вы можете запомнить до четырех номеров в памяти модема, а потом вызывать их оттуда при помощи команды DS
Например:
AT&Z0=555-1212
Выполнение этой команды приводит к тому, что номер 555-1212 будет сохранен в ячейке с адресом 0.
ATDS=nНабор номера, записанного в памяти модема
По этой команде модем будет производить набор номера записанного в ячейке памяти n. Как указывалось выше (см. описание модификатора &Zn=xxx) для хранения номеров доступны 4 ячейки c адресами 0,1,2 и 3.
Например:
ATDS0=1
Здесь модем будет производить набор номера, записанного в ячейке с адресом 1.
@Доступ к системе с перевызовом.
Модификатор @ говорит модему, что, перед тем как продолжать выполнение действий, указанных далее в командной строке, следует дождаться отсутствия каких либо сигналов в линии в течении 5 с.

Иногда для доступа к удаленным системам применяется следующий прием: Вы звоните на удаленную систему. Удаленная система снимает трубку и ожидает, когда ей передадут номер телефона (обычно сигналами тонального набора). Далее удаленная система отсоединяется, и проверяет, есть ли среди номеров абонентов, имеющих к ней доступ, номер Вашего телефона. Если доступ с Вашего телефона разрешен, то удаленная система перезванивает Вам сама, после чего Вы обычным образом устанавливаете с ней соединение. Такой прием называется "callback" - обратный вызов.
Например:

ATDP555-1212 @ T555-1515,;H
означает следующее: Модем импульсным набором набирает номер 555-1212 (системы с обратным вызовом), ждет пока система снимет трубку, определяя это по отсутствию в линии каких либо сигналов в течении 5 с. Далее модем тоном передает свой номер 555-1515. Запятая говорит, что модем должен ждать 2 с, после чего возвратиться в командный режим (точка с запятой - возврат в командный режим) и разорвать соединени (команда H в конце строки).
;Возврат в командный режим
Модификатор ; приводит к возврату в командный режим после набора номера. Эта особенность может использоваться, например, для телефонного разговора с оператором удаленной системы, передачи данных или для набора очень длинных номеров, превышающих 40-символьный лимит.
Например:
ATDP555-1212;
Модем наберет номер и возвратится в командный режим. Вы, в свою очередь, услышав ответ оператора, можете снять трубку своего телефонного аппарата и перейти к разговору с оператором, предварительно набрав команду ATH. После окончания разговора с оператором, для перехода в режим данных введите команду ATX1D без параметров и повесьте трубку. (X1 используется для отключения обнаружения сигналов АТС, так как соединение уже установлено). Услышав вызывной тон Вашего модема, оператор удаленного модема наберет ATA и повесит трубку своего аппарата. ( Пользователи модемов IDC-1414BXL и IDC-1914BXL могут вместо этих команд использовать клавиши V/D и ORG/ANS). Если требуется разорвать соединение, введите команду ATH.
!Переадресация сообщений.
Некоторые оффисные АТС воспринимают кратковременный разрыв линии абонента как команду переадресации данного соединения на другой номер. Eсли вы работаете с такой АТС, то для переадресации можно использовать модификатор ! .
Пример: команда
AT D!
на некоторых офисных ATC может быть использована для "подбора" абонента, звонящего по другой линии.

Ручной набор номера

Если по каким либо причинам невозможно использовать автоматический набор номера (например, необходимо предварительно договориться голосом с абонентом), Вы можете набирать номер с телефонного аппарата, подключенного к Вашему модему.

Ниже описано, как работать с модемом при ручном наборе номера.

  1. Поднимите трубку Вашего телефонного аппарата. Модем должен при этом находится в командном режиме.
  2. Наберите вручную номер удаленного модема. Если трубку снимет оператор - попросите его перевести свой модем в режим ответа.
  3. Услышав высокочастотный тон "ответ" удаленного модема, наберите ATX1D и нажмите <Enter>.
  4. Повесьте трубку. Модемы перейдут в режим установления соединения.

Разрыв соединения

Чтобы разорвать соединение после завершения передачи данных, необходимо сделать следующее

  1. Для перехода из режима данных в режим команд, наберите Escape-последовательность, (по умолчанию "+++"). Модем вернется в режим команд и выдаст сообщение OK.
  2. Модем будет готов к приему очередных команд через время, заданное в регистре S12 (стандартно 1с).
  3. Введите команду ATH. Не забудьте завершить ее нажатием клавиши <Enter>. Модем при этом отсоединится от линии ("положит трубку"), выдаст Вам сообщение OK и вернется в командный режим.

Если Ваше коммуникационное ПО имеет специальную команду для разрыва соединения, Вы можете так же воспользоваться ей.

Регистры, влияющие на набор номера

Параметры, влияющие на набор номера хранятся в регистрах модема с именами S6, S7, S8, S9, S10, а так же в регистрах S70-S81.
регистр | значение по умолчанию | описание функции
S6 | 2 c | Максимальное время ожидания сигнала "ответ станции"
S7 | 30 с | Время ожидания тона "ответ" удаленного модема после набора номера
S8 | 2 с | Длительность паузы соответствующая модификатору "," команды набора номера
S9 | 600 мс | Время детектирования тона "ответ" удаленного модема. Если Ваш модем слышит непрерывный "ответ" дольше, чем время указанное в S9 то он считает что удаленный модем ему ответил, иначе - что ответа нет.
S10 | 1.4 c | Время ожидания перед отбоем после потери несущей. Если в процессе передачи данных ваш модем теряет несущую, то перед тем как отработать отбой он будет ожидать ее появления в течении времени, указанное в S10


Установление входящих соединений

Глава 5. Установление входящих соединений
(как ответить позвонившему Вам модему)

В этой главе описано, как ответить на вызов удаленного модема, а также как ответить голосом, а потом перейти в режим передачи данных.

Автоматический ответ на входящий звонок

Если вам требуется, чтобы модем автоматически отвечал на звонки, проделайте следующее:

  1. Введите команду ATS0=n где n - количество звонков которое модем пропустит, прежде чем перейти в режим ответа. Допустимые значения 1-255, 0 (по умолчанию) означает запрет автоответа. Например, после команды ATS0=4, модем будет отвечать только после 4-го звонка.
  2. Нажмите <Enter>, на что модем ответит OK. У внешнего модема, кроме того, должен загореться индикатор 'AA'
  3. Автоответ будет работать до тех пор, пока не произойдет сброс модема или не будет отключено питание. При этом в регистр S0 будет записано значение, хранящееся в NVRAM. NVRAM (перезаписываемая постоянная память, ППЗУ) - особый тип памяти, установленной в Вашем модеме, где хранятся редко изменяемые параметры настройки. В отличие от RAM (оперативная память), записанное в NVRAM содержимое не разрушается при выключении питания, а в отличие от ROM (постоянная память), содержимое NVRAM можно модифицировать.

Внимание! Далеко не каждая коммуникационная программа способна работать с модемом в режиме автоответа. Многие программы предпочитают самостоятельно обнаружить звонок и выдать в модем команду ответа A. Прежде, чем устанавливать режим автоответа, ознакомьтесь с документацией на программное обеспечение.

Как работает автоответ

Если Ваш модем настроен на режим автоответа, то при звонке на него с удаленного модема будет происходить следующее:

  1. Звонит телефонный аппарат, подключенный к гнезду Phone модема, модем выдает сообщения RING. У внешнего модема может мигать индикатор 'AA'. В случае, если динамик модема не отключен командой L0, модем так же издает звуковой сигнал.
  2. Модем подсчитывает звонки и переходит в режим ответа, отсчитав число звонков указанное в регистре S0. Модем подключается к линии и начинает ожидать сигнал несущей от вызывающего модема. Если в течении времени, заданного регистром S7, соединение не установлено, модем отключается от линии и возвращается в командный режим.
  3. Если сигнал несущей получен, модем устанавливает соединение с удаленным модемом и переходит к фазе обмена подтверждениями (handshake).
  4. Модем выдает соответствующее сообщение CONNECT, переключается в режим данных и переводит линию DCD интерфейса RS-232C в состояние 'On', сигнализируя о готовности к обмену данными.

Как ответить на звонок вручную

Чтобы отключить режим автоответа, следует командой ATS0=0 записать в регистр S0 значение 0, при этом, реагируя на входящие звонки, модем будет только выдавать сообщение RING. Перейти в режим ответа в этом случае можно при помощи ввода вручную команды A.

После детектирования сигнала звонка (получения сообщения RING) введите командную строку AT A<Enter>, при этом модем подключится к линии, установит соединение и перейдет в режим данных.

Разрыв соединения

Чтобы разорвать соединение после завершения передачи данных, необходимо сделать следующее:

  1. Для перехода из режима данных в режим команд наберите Escape-последовательность, (по умолчанию "+++"). Модем вернется в режим команд.
  2. Модем будет готов к приему очередных команд через время заданное в регистре S12 (стандартно 1с), и подтвердит это выдачей сообщения OK.
  3. Введите команду ATH. Не забудьте завершить ее нажатием клавиши <Enter>. Модем при этом отсоединится от линии ("положит трубку"), выдаст Вам сообщение OK и вернется в командный режим.

Если Ваше коммуникационное ПО имеет специальную команду для разрыва соединения, вы можете так же воспользоваться ей.

Регистры, влияющие на ответ

Поведение модема при ответе управляется различными регистрами. Регистры, влияющие на ответ и разрыв соединения, приведены в следующей таблице.
Регистр | Значение по умолчанию | Функция
S0 | 0 | Число звонков, после которого модем автоматически отвечает на вызов. 0 - автоматический ответ запрещен
S7 | 30 | Время ожидания несущей вызывающего модема в секундах
S9 | 6 | Время в 1/10 с, в течении которого должна присутствовать несущая вызывающего модема, чтобы Ваш модем ее распознал
S10 | 14 - соотв. 1,4 с | Время в 1/10 c, в течение которого модем ожидает возвращения сигнала несущей удаленного модема перед разрывом соединения, если несущая потеряна.


Использование конфигурационных профилей

Глава 6. Использование конфигурационных профилей

Заводские настройки модема позволяют приступать к обмену данными сразу после установки модема и коммуникационного программного обеспечения.

Если ваши требования к настройкам отличаются от предоставляемых конфигураций по умолчанию, вы можете изменить их и сохранить конфигурационные профили в NVRAM модема. Эти профили сохраняются после выключения модема и могут быть в любой момент считаны соответствующими командами.

В модеме имеются два конфигурационных профиля с номерами 0 и 1.

Для записи того или иного профиля в NVRAM используется команда &Wn, где n может быть 0 или 1 для записи соответствующего профиля. В профиле могут быть указаны следующие команды:

    B1, E1, F0, L2, M1, Q0, V1, X4, Y0, &C0, &D0,
    &G0, &J0, &L0, &M0, &P0, &S0, &T0
также сохраняются значения следующих регистров
    S0=0, S1=0, S2=43, S3=13, S4=10, S5=8, S6=2,
    S7=50, S8=2, S9=6, S11=95, S12=50, S14=???H,
    S21=??H, S22=??H, S23=??H, S25=5, S26=1, S27=??H
(Везде приведены значения по умолчанию.)

Кроме того, сохраняются команды, управляющие протоколами коррекции ошибок и сжатия данных, а так же все S-регистры с номерами больше 30.

Запись профиля

Приведенный далее пример показывает, как сохранять профиль. Предположим, что необходимо записать следующие настройки в профиль с номером 0:

     X1 E0 &C1 &D0 &M0 S0=3 S10=100
Для этого:
  1. Наберите AT
  2. Наберите команды, указанные выше
  3. Наберите &W0, эта команда говорит что команды и значения регистров, установленные в данный момент, следует записать в профиль 0
  4. Нажмите <Enter>, при этом модем ответит OK, что указывает на то что команды и значения регистров сохранены в профиле 0.

Вызов профиля

Однажды записанный профиль будет устанавливаться модемом всякий раз при включении питания. Для указания, какой из двух возможных профилей необходимо считать, используется команда &Yn, где n - номер профиля, 0 или 1.

Например, для того, чтобы при включении питания всегда загружался профиль 0:

  1. Наберите AT&Y0
  2. Нажмите <Enter>, при этом, когда вы в следующий раз включите питание, модем переустановит свои рабочие параметры из профиля 0.

Сброс с вызовом указанного профиля

Вы можете использовать команду Zn для сброса модема и загрузки сохраненного конфигурационного профиля.

Например, сброс с вызовом профиля 0.

  1. Наберите AT Z0
  2. Нажмите <Enter>.

Если необходимо после сброса загрузить профиль 1 вместо профиля 0, следует набрать AT Z1 вместо Z0.

Возврат к стандартному профилю по умолчанию.

Чтобы вернуться к стандартному профилю, воспользуйтесь командой AT&F.

Пример:

  1. Наберите AT &F
  2. Нажмите <Enter>, при этом рабочие параметры модема будут установлены в соответствии с таблицей.
(Таблица приводится только для справок и не является полной.)

Параметр | Значение по умолчанию | Возможность умолчания записью NVRAM
Автоответ | Запрещен | да
Код символа (забой) | 08 | нет
Совместимость BELL/CCITT на скорости 1200 bps | Bell 212A | да
Детектор сигнала "занято" | разрешен | да
Код символа "возврат каретки" | 13 | нет
Код символа "перевод строки" | 10 | нет
Скорость передачи | 9600 | нет
Состояние DSR | Всегда активное | да
Контроль DTR | Игнорируется | да
Длительность DTR | 50мс | да
Эхо | разрешено | да
Escape - символ | + | нет
Защитный тон | запрещен | да
LongSpace disconnect | запрещен | да
Контроль четности | четность | да
Параметры импульсного набора | 39/61 | да
Ответы модема | текстовые | да
Разрешенные сообщения | все | да
Задержка RTS к CTS | 10мс | да
Аудиоконтроль | Разрешен при вызове Запрещен при передаче данных | да
Громкость динамика | средняя | да
Значение тестового таймера | 0с | да
Время ожидания несущей после набора номера | 30с | нет
Время ожидания сигнала ответ станции | 2с | нет
Ожидание сигнала ответ станции перед набором номера | разрешено | нет

Внимание! При производственном тестировании модема в NVRAM записываются профили, ОТЛИЧАЮЩИЕСЯ от устанавливаемого командой &F. Эти установки, по мнению разработчиков, являются оптимальными для большинства пользователей. Поэтому, если вы изменили установки и хотите вернуться к предыдущим, рекомендуется воздержаться от применения команды &F. Заводские установки записываются в оба профиля - 0 и 1; если вы не изменили второй профиль - воспользуйтесь его содержимым вместо профиля по умолчанию.


Исправление ошибок и сжатие данных

Глава 7. Исправление ошибок и сжатие данных.

Ваш модем поддерживают специальные протоколы коррекции ошибок MNP4 и V.42, которые позволяют передавать данные без ошибок, даже по зашумленным телефонным каналам. Модем так же поддерживает протоколы сжатия данных MNP5 и V.42bis, позволяющие увеличить реальную скорость передачи данных за счет сжатия.

Протоколы коррекции ошибок

  • MNP
  • V42

Ваш модем поддерживает два протокола коррекции ошибок:
MNP уровней 1 - 4;
CCITT V.42

При использовании данных протоколов, передаваемый поток данных разбивается на пакеты, вычисляются, определенным образом, контрольные значения для каждого пакета, передаваемые вместе с пакетом. Если при передаче данных произошла ошибка и полученные контрольные значения не совпадают, происходит повторная передача пакета.

MNP

Протокол MNP (расшифровывается как Microcom Networking Protocol) обнаруживает и исправляет ошибки, возникающие при обмене данными.

Существует несколько "уровней" этого протокола, каждый из которых представляет собой набор специальных методов, используемый для передачи данных.

MNP Class 1 - Обеспечивает автоматическую коррекцию ошибок на полудуплексных асинхронных соединениях.

MNP Class 2 - Обеспечивает автоматическую коррекцию ошибок на дуплексных асинхронных соединениях.

MNP Class 3 - при использовании обычного асинхронного метода передачи между компьютером и модемом, преобразует передаваемые удаленному модему данные в соответствии с синхронным протоколом SDLC, а так же выполняет обратное преобразование для принимаемых данных. Синхронная передача повышает пропускную способность модема, так как при синхронной передаче отпадает необходимость в обработке стартовых и стоповых бит - т.е. каждый передаваемый символ имеет длину 8 бит вместо десяти.

MNP Class 4 - представляет собой надстройку над протоколами MNP-2 и 3, определяющую методику начального согласования размера пакета данных во время установления соединения.

V.42

V.42 - протокол коррекции ошибок, принятый CCITT (Международным Комитетом Телеграфии и Телефонии) в январе 1990г.

Эффективность протокола V.42 выше, чем MNP-4, особенно при работе на сильно зашумленных линиях. Кроме того, протокол V.42 обеспечивает более помехозащищенный метод начальной инициализации, чем MNP-4.

Протоколы сжатия данных MNP-5 и V.42bis

Как отмечалось выше, протоколы MNP-5 и V.42bis используются для сжатия данных. MNP-5 был впервые предложен фирмой Microcom и обеспечивает отношение сжатия около 2:1. V.42bis, рекомендованный CCITT в январе 1990 года, более эффективен и обеспечивает отношение сжатия 3:1 а в некоторых случаях 4:1 (при передаче текстов). Кроме того, недостатком протокола MNP-5 является УВЕЛИЧЕНИЕ об'ема данных, если их сжатие невозможно (например, передается уже сжатый каким-либо методом файл). При этом возможна потеря производительности, по сравнению с передачей данных без такого "сжатия". Протокол V.42bis свободен от этого недостатка.

Поддерживая оба протокола, Ваш модем может работать с модемами использующими как тот, так и другой протокол.


Модемы (установка, наладка, команды, режимы)

    Введение
    • Терминология
    • Проверка аппаратуры
    • Что может понадобиться еще
    • Краткое содержание
  1. Установка модема
    • Установка внешнего модема
    • Установка внутреннего модема
    • Подключение модема к телефонной линии
    • Подключение телефонного аппарата
    • Проверка соединений

  2. Основные понятия
    • Что такое модем
    • Что такое скорость передачи данных
    • Установление соединений для передачи данных
    • Телекоммуникационное программное обеспечение
    • Работа в асинхронном режиме
    • Режим команд и режим данных
    • Ввод AT-команд
    • Сообщения модема
    • Вопросы совместимости

  3. Управление модемом
    • Ввод команд
    • Сообщения модема

  4. Установление исходящих соединений (как позвонить другому модему)
    • Установление исходящих соединений
    • Режимы набора номера
    • Набор номера. Модификаторы команды набора номера
    • Ручной набор номера
    • Разрыв соединения
    • Регистры, влияющие на набор номера

  5. Установление входящих соединений (как ответить позвонившему Вам модему)
    • Автоматический ответ на входящий звонок
    • Как ответить на звонок вручную
    • Разрыв соединения
    • Регистры, влияющие на ответ

  6. Использование конфигурационных профилей
    • Запись профиля
    • Вызов профиля
    • Сброс с вызовом указанного профиля
    • Возврат к стандартному профилю по умолчанию

  7. Исправление ошибок и сжатие данных
    • Протоколы коррекции ошибок
    • Протоколы сжатия данных MNP-5 и V42bis


Введение

  • Терминология
  • Проверка аппаратуры
  • Что может понадобиться еще
  • Краткое содержание

Терминология

Так как большинство терминов, связанных с технологией передачи данных, происходит из английского языка, при написании данного документа было решено, везде, где перевод мог вызвать затруднения, оставить английские термины. В других случаях использовались общепринятые русские аналоги. Ниже об'ясняются некоторые из них.

BPS - сокращение от bits per second (бит в секунду). Это единица измерения скорости работы модема.

IRQ - сокращение от Interrupt ReQuest (запрос прерывания) - вход контроллера прерываний IBM - совместимого компьютера. Внутренние модемы и COM-порты используют его для прерывания центрального процессора. Каждый из этих входов имеет свой номер. (Например: IRQ7 - вход, используемый обычно для параллельного порта.)

NVRAM - сокращение от non-volatile ram (перезаписываемое ПЗУ) Модемы хранят телефонные номера и значения некоторых регистров в специальной микросхеме, содержимое которой не пропадает при отключении питания.

Escape (выход) - это слово обозначает команду, по которой модем переключается из режима передачи данных в режим команд, при этом не разрывается установленное соединение.

Терминал - это приблизительный аналог термина DTE (Data Terminal Equipment), означающий устройство, с которого поступают в модем данные и команды. Им может быть компьютер или просто 'неинтеллектуальный' терминал, работающий по интерфейсу RS-232.

Dumb-режим ("неинтеллектуальный" режим) - режим работы модема, в котором он не реагирует на AT-команды.

Проверка аппаратуры

Распаковав купленный комплект оборудования убедитесь, что в комплект поставки входят следующие компоненты:

  • модем
  • телефонный шнур для подключения модема к телефонной линии
  • кабель стандарта RS-232 (только для внешнего модема)
  • руководство
  • Дискета(ы) с телекоммуникационным программным обеспечением и руководство по этому программному обеспечению (если поставка такого обеспечения предусмотрена).

Осмотрите их и убедитесь, что все компоненты на месте и не имеют механических повреждений. При обнаружении недокомплекта или механических повреждений немедленно сообщите об этом Вашему поставщику.

Что может понадобиться еще

Чтобы превратить Ваш компьютер в законченную систему передачи данных Вам могут потребоваться следующие вещи:

  • Какое-либо телекоммуникационное программное обеспечение, если оно не входит в комплект поставки
  • Розетка для подключения модема к телефонной сети
  • Дополнительный телефонный аппарат (однако он не является необходимым)
  • Если ваш модем внешний, вам понадобится свободный последовательный порт RS-232 в Вашем компьютере.

Краткое содержание глав и приложений руководства

Ниже приведено краткое содержание глав и приложений данного руководства.

Глава 1. Установка модема - содержит детальную информацию, требующуюся при установке модема, описания перемычек и переключателей.

Глава 2. Основные понятия, излагает основные сведения о модемах и технологии передачи данных, содержит описание вопросов совместимости модемов и факсов. Опытный пользователь может пропустить эту главу.

Глава 3. Управление модемом, объясняет, как управлять модемом с помощью AT-команд и как модем должен отвечать на эти команды.

Глава 4. Установление исходящих соединений. В этой главе описано, как позвонить другому модему и установить цифровое соединение.

Глава 5. Установление входящих соединений. Описывает, как отвечать на звонки другого модема вручную или автоматически.

Глава 6. Использование конфигурационных профилей. Рассказывает, как настроить Ваш Модем в соответствии с Вашими требованиями.

Глава 7. Исправление ошибок и сжатие данных. Описывает как использовать протоколы коррекции ошибок и сжатия данных (MNP, V.42, V42bis), поддерживаемые Вашим модемом.