Обзор портов компьютера

Порт порту рознь

За относительно короткий, но бурный период расцвета IBM-совместимых персональных компьютеров было создано великое множество самых разнообразных устройств, значительно расширяющих изначальные возможности базовых систем. Ведь даже самый современный компьютер, используемый сам по себе, без дополнительных периферийных устройств, с большим трудом может выполнять какие-либо функции, отличные от тривиальной игровой приставки. Хотя для многих современных игр, особенно авиа- и автосимуляторов, без джойстика или руля с педалями насладиться всеми игровыми эффектами будет весьма затруднительно. Ну, а для любой более серьезной области применения говорить о самодостаточности "голого" компьютера уже попросту несерьезно. Но вместе с тем, избежать вакханалии взаимной несовместимости различных устройств, произведенных в различное время и в различных странах многочисленными компаниями, позволило использование в любых компьютерных устройствах ряда стандартных интерфейсов. В прошлой статье цикла мы затронули тему использования в компьютерах некоторых шин, имеющих слоты для подключения специальных плат расширения. Однако имеется большое количество устройств, подключаемых непосредственно к компьютеру, используя предусмотренные для этого порты, которые мы и рассмотрим сегодня.

Обычно разъемы интерфейсов для подключения внешних устройств располагаются на обратной стороне корпуса ПК, причем на системных платах стандарта АТХ большинство внешних портов распаяно непосредственно на плате.

Последовательные - COM порты

Еще со времен первых IBM-PC одним из самых важных средств "общения" компьютера с "внешним миром" стали последовательные порты, интерфейс которых, часто обозначаемый как RS-232, обеспечивает, наряду с предельной простотой реализации, высокую помехозащищенность на длинных линиях. Одним из важнейших применений последовательного интерфейса в компьютерах стандарта Baby АТ стало использование его для подключения мышки. Но и сейчас СОМ - порты активно используются для управления работой источников бесперебойного питания (ИБП), подключения большинства внешних модемов, некоторых цифровых фотокамер (в основном устаревших), а так же многих других устройств. Главный элемент последовательного интерфейса - 16450 UART (Universal Asynchron Receiver Transmitter - универсальный асинхронный приемо-передатчик), обеспечивающий максимальную скорость передачи данных 115200 бит/с, обычно интегрированный в микросхему южного моста системного чипсета. Физически разъемы СОМ - порта представляют собой 9-контактный (вилка) 2-х рядный Sub-D разъем, хотя иногда можно встретить (в устаревших устройствах или в некоторых модемах) 25-контактные разъемы.

Пересылка данных по линии RS-232 осуществляется побитно, последовательно друг за другом, при этом возможен обмен данными в двух направлениях. Передача данных осуществляется в асинхронном режиме, каждый "пакет" данных состоит из стартового бита, 8 бит данных и стопового бита, причем как прием, так и передача осуществляются с одной тактовой частотой. Для снижения вероятности ошибок в пакет данных иногда включается дополнительный бит контроля четности. Амплитуда сигналов достигает величины + / - 12 В, благодаря чему обеспечивается высокая помехозащищенность передаваемых по кабелю данных.

BIOS современных компьютеров поддерживает до 4-х СОМ - портов, причем для их обслуживания выделяются всего 2 прерывания: IRQ3 и IRQ4. Стандартные значения адресов и прерываний для СОМ - портов приведены в таблице:

Порт | Базовый адрес | Линия прерывания
СОМ1 | 3F8h | IRQ4
СОМ2 | 2F8h | IRQ3
СОМ3 | 3E8h | IRQ4
СОМ4 | 2E8h | IRQ3

Обычно, на системной плате располагаются 2 СОМ - порта, СОМ1 и СОМ2, параметры которых можно задавать непосредственно из BIOS-а. Если же они не используются, то лучше их отключить, чтобы освободить IRQ для других устройств. Порты СОМ3 и СОМ4, в случае необходимости их использования, оперативно создаются операционной системой Windows.

Да, при всех достоинствах интерфейса RS-232 (а достоинство это, по сути дела только одно - совместимость с широким спектром устаревшего оборудования), сегодня уже всем ясно - он отжил свое и будущего у него нет - замена RS-232 на более современную шину USB неизбежна. Не зря же Intel с Microsoft уже начиная со своей спецификации "идеального ПК" РС99 настоятельно рекомендуют полностью отказаться от использования интерфейса RS-232.

Параллельный порт

Вторым типом интерфейса внешних устройств, сохранившихся в современных компьютерах еще со времен первых IBM-PC, является параллельный интерфейс, иногда называемый, по имени фирмы-разработчика, Centronics. До сих пор этот тип интерфейса является основным для большей части современных принтеров, хотя в последнее время он все активнее заменяется универсальной последовательной шиной USB. Кроме устройств печати, параллельный интерфейс раньше служил для непосредственного соединения двух компьютеров, и до сих пор все еще используется в отдельных моделях сканеров. Разъем для параллельного интерфейса типа Sub-D представляет собой розетку и содержит 25 контактов, расположенных в 2 ряда. Обмен данными с периферийным устройством осуществляется по 8 шинам передачи данных со скоростью от 120 Кбит/с до 2 Мбит/с в зависимости от режима работы параллельного порта, которых существует несколько:

  • Стандартный;
  • ЕРР;
  • ЕСР.

Эти режимы, наряду с адресом I/O и прерыванием IRQ, определяются в BIOS-е системной платы. По умолчанию используются I/O адрес 378h и IRQ7, эти значения в большинстве случаев вполне подходят для нормальной работы.

Стандартный параллельный порт (SPP) обеспечивает только одностороннюю передачу данных от компьютера к принтеру, но позволяет работать практически со всеми устройствами, подключаемыми к параллельному порту, хотя скорость передачи при этом не превышает 200 Кбит/с.

Расширенный параллельный порт (EPP - Enhanced Parallel Port) полностью совместим со стандартным, но является двунаправленным. EPP использует существующие сигналы параллельного порта и осуществляет асимметричный двунаправленный обмен данными со скоростью до 2 Мбит/с. В режиме ЕРР предусматривается возможность подключения в цепочку до 64 периферийных устройств.

Порт с расширенными возможностями (ECP - Extended Capability Port) является дальнейшим развитием ЕРР. ECP, как и ЕРР, использует протокол DMA и, предоставляя симметричный двунаправленный обмен данными, обеспечивает максимальную пропускную способность до 2,5 Мбит/c. Одной из наиболее важных функций, реализованных в ЕСР, является сжатие данных по методу RLE. ECP наилучшим образом подходит для передачи больших объемов данных (например, для сканеров и принтеров).

Стандарты портов ЕРР и ЕСР включены в единый стандарт Американского института инженеров по электротехнике и электронике IEEE 1284. Для тех, кто не знает, какой режим двунаправленной передачи данных наиболее оптимален для имеющегося принтера или сканера, в BIOS есть опция ECP + EPP. Если выбрать этот режим, то устройство, подключенное к параллельному порту, сможет использовать любой из режимов ECP или EPP.

IrDA

Выносной блок IrDA Порт IrDA позволяет устанавливать связь с периферийным оборудованием без кабеля при помощи ИК-излучения на расстоянии до 1 метра. К числу такого оборудования относятся, в первую очередь, ноутбуки, карманные ПК и другие образцы мобильной техники. Сам порт IrDA основан на архитектуре коммуникационного СОМ-порта ПК, который работает со скоростью передачи данных до 115,2 Кбит/с. Так как интерфейс IrDA использует узкий ИК-диапазон (850-900 нм) с малой мощностью излучения, то его использование не требует сертификации FCC (Федеральной Комиссии по Связи). Задавать режимы работы инфракрасного порта можно из BIOS-а системной платы, причем для организации IrDA используется второй последовательный порт, и если его отключить, то работа инфракрасного порта станет невозможной.

ASUS iPanel DeLux К сожалению, практически все современные системные платы, используемые для создания настольных компьютеров, имеют лишь внутренние разъемы для подсоединения приемо/передатчика инфракрасного излучения, поэтому для организации полноценного интерфейса IrDA на ПК необходимо дополнительно приобрести и установить специальную многофункциональную панель, например, типа iPanel DeLux фирмы ASUS, устанавливаемую в свободный отсек накопителей в корпусе ПК и имеющей, наряду с портами IrDA и СОМ, еще и 2 USB, 3 стандартных аудиоразъема и комплект для мониторинга и индикации состояния ПК. Помимо этого, возможно также использование отдельного выносного блока IrDA, подключаемого к свободному разъему СОМ - порта.

USB 1.1

К 1995 году стало ясно, что СОМ - порты изживают себя, не обеспечивая ни достаточной скорости обмена данными между ПК и подключенным устройством, ни возможность "горячего" подключения этих устройств, да и ограничение количества подключенных к одному порту устройств так же вынуждало искать замену устаревшему интерфейсу. И такая замена появилась достаточно быстро в лице универсальной последовательной шины - USB (Universal Serial Bus), предложенной консорциумом компаний во главе с Intel. Однако вплоть до появления Windows 98 производители оборудования и программного обеспечения "крутились" вхолостую: производители компьютерного "железа" ждали, пока Microsoft напишет качественные драйвера USB для Windows, а та, в свою очередь, предпочитала дождаться появления достаточного количества реального оборудования. В результате, несмотря на то, что Intel встроил поддержку USB в южные мосты чипсетов i430VX и i430HX, вплоть до появления плат стандарта АTX разъемы USB на системных платах предлагались только опционально, что, конечно же, не способствовало росту популярности новой шины.

Шина USB обеспечивает работу 127 устройств, подключенных последовательно, только необходимо при этом учитывать, что пропускная способность одного контроллера ограничена пиковой величиной 12 Мбит/c, реально же пользователь может рассчитывать только на 700 - 900 Кбайт/с, поэтому реально будет говорить о не более 3 - 5 одновременно подключенных устройств к одному каналу. Одним из важнейших потребительских свойств шины, в значительной мере облегчающей работу с ней является обеспечиваемая ею возможность "горячего" подключения самых разнообразных устройств к ПК без отключения питания. Кроме того, раз уж речь зашла о питании, не лишним будет отметить способность USB организовать питание периферийных устройств непосредственно с интерфейса, правда, достаточно маломощных. Стоит отметить, что USB работает по принципу "ведущий - ведомый", то есть два отдельных устройства могут обмениваться данными друг с другом только через ПК или специальный хаб, располагающие управляющим контроллером. Поэтому USB 1.1 больше всего подходит для подсоединения к ПК ограниченного числа низкоскоростных устройств. Большим достоинством шины USB является значительная длина соединительного кабеля, которая может достигать 5 метров.

USB хаб К сожалению, физическое расположение разъемов USB на задней стенке компьютера при подключении устройства, особенно "на лету", порой доставляет определенные неудобства - поэтому сегодня так популярны всякого рода хабы, т.е. расширители портов, расположенные в более удобных для доступа местах - например, в мониторах.

USB 2.0

Логотип USB Хотя шина USB 1.1 сегодня стала практически стандартом де-факто для подключения низкоскоростных периферийных устройств, век ее оказался на удивление недолог. "Виной" тому оказались стремительно растущая мощность современных компьютеров, позволяющая выполнять на них задачи, ранее просто немыслимые, как, например, ввод и обработка видеоизображений в реальном масштабе времени. Естественно, для решения таких задач требуется пропускная способность линий передачи данных существенно большая, чем способны обеспечить существующие интерфейсы, включая USB 1.1. Его новая версия, USB 2.0 с начала текущего года активно продвигается на рынок, чему способствует интеграция контроллера USB 2.0 во все без исключения новейшие чипсеты, выпускаемые ведущими производителями весной - летом 2002 года.

Основное отличие новой ревизии USB 2.0 станет пиковая скорость передачи данных, достигающая 480 Мбит/с против 12 Мбит/с у USB 1.1, что сопоставимо со скоростью интерфейса UltraATA66 и на 20 % превосходит своего основного конкурента - EEE 1394. С целью максимальной совместимости с большим количеством периферийного оборудования, выполненного по спецификации USB 1.1, устройства стандарта USB 2.0 могут использоваться с контроллерами/хабами стандарта 1.1, естественно, при этом скорость будет ограничена все теми же 12 Мбит/с.

Так как основополагающий принцип функционирования шины USB, а именно принцип "ведущий - ведомый", остался в USB 2.0 неизменным, то новый интерфейс вряд ли составит конкуренцию IEEE1394 на рынке бытовой электроники, поскольку невозможно организовать, к примеру, передачу данных с видеокамеры на цифровой магнитофон, минуя компьютер. Тем не менее, у нового стандарта есть и большой плюс: отсутствие лицензирования и необходимости выплаты лицензионных отчислений, что имеет место в случае с FireWire.

А вот с поддержкой со стороны программного обеспечения шина USB 2.0 до сих пор испытывает определенные проблемы. Дело в том, что Microsoft изначально планировала включить поддержку USB 2.0 в свою новую операционную систему Windows XP, однако непонятно по какой причине этого не произошло. И теперь полноценная поддержка новой шины планируется только после выхода первого Service Pack-а для Windows XP, а пока - довольствуйтесь патчами.

IEEE 1394 (FireWire)

Периферийная шина передачи данных FireWire (IEEE 1394), пришла в мир ПК из экзотического для большинства из нас мира компьютеров Mac. Обладая очень высокими характеристиками и возможностями, эта шина первоначально, из-за лицензионной политики компании-разработчика Apple, не получила особого распространения, и лишь с появлением портативных видеокамер стандартов MiniDV и Digital8 IEEE 1394 получил широкое признание. По сравнению с популярной шиной USB 1.1 шина FireWire имеет следующие основные преимущества:

  • Увеличение максимальной скорости передачи с 12 Мбит/c (USB 1.1) до 400 Мбит/c (FireWire).
  • Возможность питания внешних устройств от шины 1.25A/12В (FireWire) против максимальных 500 мA/5В (USB).
  • Одноранговая шина FireWire не требует управления, устройства общаются по принципу peer-to-peer.

Стандарт IEEE 1394 поддерживает как асинхронный, так и синхронный протоколы передачи данных и предоставляет гораздо больше возможностей, чем технология Plug&Play. Например, каждое устройство может быть подключено/отключено в любой момент времени, даже во время непосредственной передачи данных, при этом шина автоматически переконфигурируется и происходит новое назначение адресов. Все устройства IEEE 1394 подразделяются по максимальной скорости передачи данных на три класса: 100, 200, 400 Мбит/с соответственно. В ближайшем будущем планируется ввести поддержку скоростей 800 и 1600 Мбит/с. Шина IEEE 1394 позволяет последовательно подключать до 63 устройств, причем длина кабеля может достигать 4,5 метров. Для подключения периферийных устройств в IEEE 1394 используется два типа разъемов - 6-и (на фото слева) и 4-х контактные.

В отличие от USB, где применение различных типов разъемов обусловлено различным типом устройств, в IEEE 1394 в случае, когда нет необходимости в питании устройства, используется 4-контактный малогабаритный разъем, такого типа разъемы чаще всего используются в видеокамерах. Если же устройство необходимо питать от шины, то используется более крупный 6-контактный разъем. Большинство компьютерных устройств рассчитано именно на последний тип разъемов.

Но все-таки главным в деле продвижения новой шины к потребителю является ее поддержка производителями программного обеспечения, и здесь дела у FireWire идут более чем хорошо, так как все версии операционной системы Windows, начиная с 98SE, имеют в своем составе качественные драйвера для этой шины. Да и с поддержкой производителей "железа" дело постепенно налаживается, так компания SiS уже выпустила первый чипсет SiS745 с интегрированным контроллером IEEE 1394, что является пока первой, но очень много значащей, ласточкой.

Так как до сих пор окончательно не решен вопрос победителя в споре перспективных шин FireWire и USB 2.0, то предусмотрительные вендоры выпускают комбинированные решения, например, на иллюстрации приведена PCI-карта, 3 внешних порта USB 2.0 которой дополняют 2 порта FireWire.

А что же нас ждет в будущем? Уже в конце этого года должно начаться массовое внедрение нового интерфейса SerialATA. И хотя, на первый взгляд, он предназначен только для замены устаревающего интерфейса IDE, но, в случае успешного развития событий, SerialATA способен значительно потеснить и FireWire, и USB 2.0. Так, скорость передачи данных у SerialATA может достигать 150 Мбайт/с, что превосходит оба вышеупомянутых интерфейса. И это только в первой редакции, в последующем планируется ее сначала удвоить, а потом и учетверить. Топология подключаемых устройств типа "звезда" позволяет безболезненно вывести один - два разъема для подключения внешних устройств, да и максимальной длинны кабеля 1 метр вполне может хватить для комфортной работы с такими устройствами. А выгода от замены целой кучи разнокалиберных интерфейсов одним универсальным настолько очевидна, что рано или поздно воплотится в жизнь.

Виктор Куц