USB

Шина USB

В этом разделе приведено краткое описание шины USB

При подготовке этого раздела использовались материалы с USB Implementers Forum.

Содержание:

  • Введение

  • Технические характеристики

  • Топология

  • Кабели и разъемы

  • Какие устройства есть или будут использовать USB

  • Развитие USB

Введение

Шина USB (Universal Serial Bus - универсальная последовательная шина) появилась по компьютерным меркам довольно давно - версия первого утвержденного варианта стандарта появилась 15 января 1996 года. Разработка стандарта была инициировна весьма авторитетными фирмами - Intel, DEC, IBM, NEC, Northen Telecom и Compaq.
Основная цель стандарта, поставленная перед его разработчиками - создать реальную возможность пользователям работать в режиме Plug&Play с периферийными устройствами. Это означает, что должно быть предусмотрено подключение устройства к работающему компьютеру, автоматическое распознавание его немедленно после подключения и последующей установки соответствующих драйверов. Кроме этого, желательно питание маломощных устройств подавать с самой шины. Скорость шины должна быть достаточной для подавляющего большинства периферийных устройств. Попутно решается историческая проблема нехватки ресурсов на внутренних шинах IBM PC совместимого компьютера - контроллер USB занимает только одно прерывание независимо от количества подключенных к шине устройств.

usb_connect.gif (12518 bytes) Практически все поставленные задачи были решены в стандарте на USB и весной 1997 года стали появляться компьютеры, оборудованные разъемами для подключения USB устройств (см. фото слева), но периферия с подключением к USB до середины 1998 года так практически и не появилась. В чем дело? Почему только к концу 1998 года уже существенно активнее производители оборудования стали предлагать на рынке устройства с USB интерфейсом? Этому есть несколько объяснений:

  • отсутствие острой необходимости для пользователей настольных компьютеров в устройствах с полной поддержкой Plug&Play. Периферия к настольному компьютеру подключается, как правило, всерьез и надолго и особой нужды в частой смене периферии у подавляющего большинства пользователей нет.

  • более высокая стоимость устройств с USB по сравнению с аналогичными устройствами, имеющими стандартные интерфейсы

  • отсутствие поддержки со стороны производителей программного обеспечения и, главным образом, Microsoft, хотя она и была одним из авторов стандарта. Только в Windows 98 появилась полная поддержка USB, а в Windows NT она только должна быть в 1999 году.

Сейчас USB стала активно внедряться производителями компьютерной периферии. Сенсацией стало наличие в компьютере iMAC фирмы Apple Computers только USB в качестве внешней шины.

Технические характеристики

Возможности USB следуют из ее технических характеристик:

  • Высокая скорость обмена (full-speed signaling bit rate) - 12 Mb/s

  • Максимальная длина кабеля для высокой скорости обмена - 5 m

  • Низкая скорость обмена (low-speed signaling bit rate) - 1.5 Mb/s

  • Максимальная длина кабеля для низкой скорости обмена - 3 m

  • Максимальное количество подключенных устройств (включая размножители) - 127

  • Возможно подключение устройств с различными скоростями обмена

  • Отсутствие необходимости в установке пользователем дополнительных элементов, таких как терминаторы для SCSI

  • Напряжение питания для периферийных устройств - 5 V

  • Максимальный ток потребления на одно устройство - 500 mA (это не означает, что через USB можно запитать устройства с общим током потребления 127 x 500 mA=63.5 A)

Поэтому целесообразно подключать к USB практически любые периферийные устройства, кроме цифровых видеокамер и высокоскоростных жестких дисков. Особенно удобен этот интерфейс для подключения часто подключаемых/отключаемых приборов, таких как цифровые фотокамеры. Конструкция разъемов для USB рассчитана на многократное сочленение/расчленение.
Возможность использования только двух скоростей обмена данными ограничивает применяемость шины, но существенно уменьшает количество линий интерфейса и упрощает аппаратную реализацию.
Питание непосредственно от USB возможно только для устройств с малым потреблением, таких как клавиатуры, мыши, джойстики и т.п.

Топология

USB icon Такой иконой официально обозначается шина USB как в Windows 98, так и на задних стенках компьютеров (к сожалению, далеко не всех), а также на всех разъемах USB. Эта икона на самом деле правильно отображает идею топологии USB. Топология USB практически не отличается от топологии обычной локальной сети на витой паре, обычно называемой "звездой". Даже терминология похожа - размножители шины также называются HUB'ами.

Условно дерево подключения USB устройств к компьютеру можно изобразить так (цифрами обозначены периферийные устройства с USB интерфейсом):

usb_topologi.gif (3588 bytes)

Вместо любого из устройств может также стоять HUB. Основное отличие от топологии обычной локальной сети - компьютер (или host устройство) может быть только один. HUB может быть как отдельным устройством с собственным блоком питания, так и встроенным в периферийное устройство. Наиболее часто HUB'ы встраиваются в мониторы и клавиатуры

schema.gif (11347 bytes)

На рисунке выше показан пример правильного соединения периферийных устройств в условную USB сеть. Так как обмен данными по USB идет только между компьютером и периферийным устройством (между устройствами обмена нет), то устройства с большими объемами приема и/или передачи данных должны подключаться либо к самому компьютеру, либо к ближайшему свободному узлу. В данном случае наивысший трафик у колонок (~1.3 Mb/s), затем идут модем и сканер, подключенные к HUB'у в мониторе и завершают цепь клавиатура, джойстик и мышь, трафик у которых близок к нулю.
Может возникнуть вопрос - почему колонки имеют такой высокий трафик? Дело в том, что колонки с USB интерфейсом существенно отличаются от обычных. Для использования таких колонок НЕ ТРЕБУЕТСЯ звуковая карта. Драйвер колонок отправляет оцифрованный звук сразу в колонки, где с помощью АЦП (ADC) он преобразуется в аналоговый сигнал и подается на динамики.

Кабели и разъемы

Сигналы USB передаются по 4-х проводному кабелю, схематично показанному на рисунке ниже:
Usb cable image

Здесь GND - цепь "корпуса" для питания периферийных устройств, VBus - +5V также для цепей питания. Шина D+ предназначена для передачи данных по шине, а шина D- для приема данных.
Кабель для поддержки полной скорости шины (full-speed) выполняется как витая пара, защищается экраном и может также использоваться для работы в режиме минимальной скорости (low-speed). Кабель для работы только на минимальной скорости (например, для подключения мыши) может быть любым и неэкранированным.
Разъемы, используемые для подключения периферийных устройств, показаны на рисунке ниже.

Разъемы серии "А"

Разъемы серии "В"

  • предназначены ТОЛЬКО для подключения к источнику, т.е. компьютеру или HUB'у.

  • предназначены ТОЛЬКО для подключения к периферийному устройству

usb_a_male.jpg (10474 bytes)

Вилка типа "A".

usb_b_male.jpg (10585 bytes)

Вилка типа "B".

usb_a_female.jpg (3291 bytes)

Розетка типа "А"

usb_b_female.jpg (3598 bytes)

Розетка типа "В"

Как видно из рисунка, невозможно подключить устройство неправильно, так как разъем серии "А" можно подключить только к активному устройству на USB - HUB'у или компьютеру, а серии "В" только к собственно периферийному устройству.

USB разъемы имеют следующую нумерацию контактов:

Номер контакта | Назначение | Цвет провода
1 | V BUS | Красный
2 | D - | Белый
3 | D + | Зеленый
4 | GND | Черный
Оплетка | Экран | Оплетка

Цоколевка разъемов USB

usb_female_out.gif (2632 bytes) | usb_female_in.gif (1572 bytes)
Розетка типа 'A' | Розетка типа 'B'

usb_male_out.gif (1539 bytes) | usb_male_in.gif (1880 bytes)
Вилка типа 'A' | Вилка типа 'B'

Какие устройства есть или будут использовать USB

В режиме низкой скорости:

  • Клавиатуры

  • Мыши

  • Джойстики

  • Матричные принтеры

  • Дигитайзеры

  • Цифровые фотокамеры

  • Модемы для обычных телефонных линий

  • Цепи управления монитором компьютера

В режиме высокой скорости:

  • Колонки

  • ISDN модемы

  • Внешние накопители класса Iomega Zip

  • Офисные АТС

  • Лазерные и струйные принтеры

Развитие USB

В 1999 году тот же консорциум компьютерных компаний, который инициировал разработку первой версии стандарта на шину USB, начал активно разрабатывать версию 2.0 USB, которая отличается тем, что полоса пропускания шины увеличена в 20 (!) раз, до 250 Mbits/s, что делает возможным передачу видеоданных по USB и делает ее прямым конкурентом IEEE-1394 (FireWire).
Совместимость всей ранее выпущенной периферии и высокоскоростных кабелей полностью сохраняется и сохраняется одно из самых главных достоинств USB - низкая стоимость контроллера. Контроллер стандарта 2.0 также предполагается интегрировать в chipset.
Все хорошо, но есть одно но: шина IEEE-1394 уже весьма активно используется даже в бытовых цифровых видеокамерах, для нее есть платы видеомонтажа и при постоянном падении цен на цифровые видеокамеры она будет использоваться все шире и шире. Новая же версия USB должна быть только окончательно разработана к середине 2000 года, а первые устройства с поддержкой нового варианта USB должны появиться не ранее конца 2000 года. Для компьютерной индустрии это очень большие сроки. Уже в июле 1999 года, например, фирма ASUSTeK Computers выпускает первую материнскую плату (P3B-1394) со встроенным контроллером IEEE-1394. Наверняка это не останется незамеченным и другие производители также начнут выпускать подобные платы. Поэтому к моменту выхода устройств на USB 2.0 место под солнцем может быть уже занято.

Разъем USB на материнской плате

  2   4   6   8  10  12  14  16
*-------------------------------*
| о   х   о   о   о   о   о   о |   Все четные контакты - GND
| о   о   о   о   о   о   о   о |
*-------------------------------*
  1   3   5   7   9  11  13  15

              Назначение контактов:

 Для левого разъема     |   Для правого разъема    |   Цвет
   USB на планке        |      USB на планке       |   провода
                        |                          |
  1 - Vcc (+5 V)        |     9 - Vcc (+5 V)       |   Красный
                        |                          |
  3 - D0-               |    11 - D1-              |   Белый
                        |                          |
  5 - D0+               |    13 - D1+              |   Зеленый
                        |                          |
  7 - GND               |    15 - GND              |   Черный